Introduction

MindFusion.Wpf Package Programmer's Guide
Introduction

The following controls are contained in the MindFusion Pack for WPF:

MindFusion.Diagramming for WPF

MindFusion.Diagramming for WPF is a general-purpose software component that can be used to display various types of diagrams and charts, in many different formats. It is implemented as a WPF control and can be easily integrated into any application targeting the Microsoft WPF platform. By providing your software with ready to use capabilities for visualizing and editing relational data, MindFusion.Diagramming for WPF saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Diagramming for WPF can give graphical representation to:

  • Workflow processes
  • Class relationships
  • Graphs and networks
  • Entity-relationship / database diagrams
  • IVR systems
  • Industrial automation processes
  • Genealogy trees
  • Algorithms and flowcharts
  • Organizational charts
  • XML documents
  • Classification hierarchies
  • And much more

MindFusion.Diagramming for WPF provides intuitive user-interaction model for creating or editing diagrams. In addition, its programmatic interface places at your disposal many useful functions, ranging from printing and XML serialization to path-finding and automatic layout algorithms.

MindFusion.Scheduling for WPF / MindFusion.DataViews for WPF

MindFusion.Scheduling for WPF is a set of software components that can be used to present calendars, gantts and timetables to users and let them edit schedule information interactively. It is implemented as a WPF Control and can be easily integrated into any application targeting the WPF platform. By providing your software with ready-to-use capabilities for visualizing and editing schedule data, MindFusion.Scheduling for WPF saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Scheduling for WPF can display a schedule in several view types, such as:

  • Range of months, displaying several months in a grid, each of the months displaying its days in a smaller grid;
  • Single month view, displaying the days of a month and allowing scrolling to previous or next month;
  • Range of weeks, displaying days in a grid in which the days of a week occupy a single row;
  • List view, displaying a single day on each row or column;
  • Timetable view, displaying the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task or contact;

MindFusion.DataViews for WPF contains separate Gantt, Grid and TreeView controls.

MindFusion.Charting for WPF / MindFusion.Gauges for WPF

MindFusion.Charting for WPF is a smart programming tool suitable for creating all types of:

  • line / area / stacked area / scatter charts
  • bar / groups of bars / stacked / overlay / column charts
  • pie / doughnut charts
  • oval and linear gauges

The component is designed to be easy to use, with powerful and intuitive API, various samples and tutorials. The controls have been tested with the most popular .NET development environments and programming languages C#, VB.NET and Delphi.NET.

MindFusion.Spreadsheet for WPF

MindFusion.Spreadsheet for WPF is a spreadsheet component that can be used to create, open, manage, and export spreadsheet documents in many different formats without requiring Microsoft Excel. It is implemented as a .NET control and can be easily integrated into any application targeting the Microsoft .NET platform.

MindFusion.Spreadsheet for WPF supports:

  • Importing documents from CSV, XLSX, ODS
  • Export to PDF, CSV, image
  • Numerous chart types
  • Customizable cell appearance
  • Merged cells
  • Conditional formatting
  • Data validation
  • Images
  • Cell annotations
  • Previewing and printing
  • Undo and redo
  • Auxiliary forms

MindFusion.Spreadsheet for WPF provides intuitive user-interaction model for creating or editing spreadsheet documents. Its programmatic interface is powerful and simple to use. The control has been tested with the most popular .NET development environments and programming languages.

MindFusion.Reporting for WPF

MindFusion.Reporting for WPF is a general-purpose software component that can be used to design, display, print and export various types of reports and charts. It is implemented using WPF and can be easily integrated into any application targeting the WPF platform. By providing your software with ready to use capabilities for visualizing and editing relational data, MindFusion.Reporting for WPF saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Reporting for WPF supports:

  • Creating reports with header and footer
  • Including charts and pictures
  • All .NET data sources
  • Previewing and printing
  • Rendering reports as WPF FixedDocument

MindFusion.Reporting for WPF provides rich report designer.

The control has been tested with the most popular .NET development environments and programming languages C#, VB.NET and Delphi.NET.

MindFusion.Mapping for WPF

MindFusion.Mapping for WPF comprises a WPF control and a class library that provide your application with great features for loading, customizing and displaying any type of regional, national or world map. Easy to integrate and program, this control gives you the power to build the perfect map according to your needs with minimal time and efforts from your side. You can:

  • Add labels to map elements
  • Access database data associated with map elements
  • Choose the color scheme
  • Set decorative elements like images, icons, and texts

Map data can be loaded from the popular ESRI Shapefile format and you have at your disposal an impressive variety of *.shp files, which give you valuable data for any country in the world as well for selected cities, rivers, roads and other geographic objects. Data for the attributes of map elements can be loaded from a DBF file associated with each map. The control supports multiple layers so you can show several maps in a single view.

MindFusion.Mapping for WPF is installed with various samples in C# and VB.NET that demonstrate all important features of the control and significantly shorten the time needed to learn how to use it. The help file also includes step-by-step guides and tutorials. The API is documented in details and both offline and online documentation is provided. The control and the map files included in the package are royalty free.

MindFusion.UI for WPF

MindFusion.UI for WPF contains a set of lightweight controls, such as accordion, date picker and window.

© 2018 MindFusion


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion Pack for WPF:

New in 2018.R1

MindFusion.Diagramming for WPF

Non-blocking layout methods

All graph layout classes now contain an async ArrangeAsync method that runs layout calculations in a background task. This is only available in .NET 4.5 build of the diagram assemblies.

C# [image] Copy Code

async void OnLayoutLayered(object sender, RoutedEventArgs e)
{
var layout = new LayeredLayout();
await layout.ArrangeAsync(diagram);
diagram.ZoomToFit();
}

Layout improvements

  • The KeepLinkShapes property of LayeredLayout lets you preserve initial Shape value of links when LinkType is set to Cascading. The orthogonal path applied by latter property is approximated using respective link shape.
  • Set ConsiderNodeShapes property of LayeredLayout to align link end points to non-rectangular node borders.
  • Fix for wrong link positions when the diagram contains folded containers.
  • Fix for unnecessarily large distance between subsequent layers after a long node appears in a layer.

PathFinder improvements

  • Speed of FindAllCycles and EnumAllCycles methods improved.
  • FindAllCycles and EnumAllCycles no longer report mirrored versions of cycles in undirected mode.

Export Excel files

The ExcelExporter class from MindFusion.Diagramming.Wpf.ExcelExport.dll assembly exports diagrams to Excel Open XML Format (XLSX) files. Diagrams are exported as Excel AutoShapes drawings. The Export overload that takes a DiagramDocument parameter creates a sheet for each DiagramPage in the document. The Export(Diagram) overload creates a single Excel sheet.

Export improvements

  • CreateImage fix for blurry bitmaps when exporting large diagrams.
  • Visio2013Exporter processes links' arrowheads.
  • Visio2013Exporter preserves the diagram Z order.
  • Visio2013Exporter exports links' Text and Labels.
  • Visio2013Exporter exports Image of ShapeNode objects.
  • SvgExporter fix for non-zero origin of diagram's Bounds.

VirtualizingDiagram improvements

  • VirtualizingDiagram can contain nodes of different types now. Nodes returned for data items by InstantiateNode callback are stored in separate pools according to their type, and data items reuse node instances from respective pool. VisualCacheSize now specifies the size of per-type node pools.
  • If a data item has Container property set, the control associates its node with Container item's node. It Container item has been realized as a ContainerNode, the source node is added to it as a child. If Container's realized node is of another type, the source node is attached as subordinate using AttachTo method. An alternative way to specify container items is via the ResolveContainer callback.

Overview improvements

  • The boolean FitAll has been replaced by ScaleMode enumeration property. It implements a third scaling mode where overview's scale stays fixed and ignores diagram's zoom level.
  • If AllowZoom is enabled, users can zoom the diagram by resizing the overview's viewport tracking rectangle.

Miscellaneous

  • The LinkTextEdited event is now raised when a LinkLabel has been edited. The edited label is specified via Label property of the event arguments object.
  • LinkPadding property added to LayeredLayout specifies how much space to leave between links when LinkType is set to Cascading.
  • GridAlignPoint property of DiagramNode class specifies which point of a node should snap to a point of the alignment grid.
  • Z order of ContainerNode's children is now local to the container. Adding child node to a container no longer changes ZIndex values.
  • The Compact method of Diagram class moves nodes as far possible to the top or left sides of diagram without changing their initial relative positions.
  • The ExtendSelection element of ModifierKeyAction lets users select items with lasso rectangle without deselecting old ones.
  • Set KeepInsideDiagram property of Selection to prevent users from dragging multiple selection outside of diagram boundaries.
  • Fix for link auto-routing around rotated DiagramNodeAdapter objects.
  • ImagePadding property of ShapeNode, TableNode and Cell lets you set padding space between element's borders and the contained Image.
  • Visio2013Exporter now applies the TextVerticalAlignment property of nodes.
  • Improved GridRouter routes when connected nodes are close to each other.
  • New Add overload of ContainerNode enables resizing child nodes proportionally to their container.
  • Group rotation fix when setting RotationAngle to zero from code.
  • The Visibility property of LinkLabel lets you hide labels temporarily.

MindFusion.Spreadsheet for WPF

Autofiltering

Worksheets now support autofiltering. To enable it, call the AutoFilter method of the CellRange class. To specify autofiltering criteria for individual columns, use the AutoFilter overload. These criteria can also be specified interactively, through the drop-down buttons inside the headers of each column in the target range.

Localization

The standard forms form the MindFusion.Spreadsheet.Wpf.StandardForms.dll assembly can now be localized for German, Spanish, French, Korean, Portuguese, Russian, and Chinese. To do this call the new SetLocalizationInfo method of the Workbook class and provide a XML file containing the localized strings for the respective language. The XML files for the above languages can be found in the Localization folder inside the component installation.

Grouping and Outlining

Rows and columns can now be grouped. To group or ungroup a range of rows or columns, use the Group or Ungroup methods of the RowRange and ColumnRange classes. To set the outline level of a row/column or a range of rows/columns directly, use the OutlineLevel property. Groups can be expanded and collapsed interactively, by clicking on the expand/collapse button in the view, or programmatically, by settings the IsCollapsed property of the respective row or column.

New Events

Several new events have been added to the WorkbookView class: ColumnGroupCollapsed, ColumnGroupExpanded, ColumnOutlineLevelToggled, RowGroupCollapsed, RowGroupExpanded, and RowOutlineLevelToggled.

Miscellaneous

  • The ExcelImporter class now exposes a ReadConditionalFormats property, which can be used to prevent importing of conditional formats.

MindFusion Virtual Keyboard

Key improvements

  • The UnicodeKey class can send any Unicode symbol as input to target text controls.
  • The IsPressed property is set to true while a key is pressed down by the user, allowing for data triggers in Xaml templates to change appearance of pressed keys.
  • Values of Content property of RegularKey can now be sent to external processes.

Keyboard improvements

  • A new Windows10 color scheme added to MindFusion.UI.Wpf.ColorSchemes.
  • The SetKeyLabels method lets you override labels of keys for a given language.

Active window tracking

  • The control updates its layout immediately when a window with a different current language activates.
  • Pressing a key no longer activates last target window, which was necessary when keyboard is used as a popup inside application but led to activation flickering. Set the new PreventActivation property instead to disable the keyboard's popup window from activating altogether.

Miscellaneous

  • Move multiple selected keys in keyboard creator.
  • Various keyboard creator fixes.


Version History

Version History

The list below describes recent changes and additions to MindFusion Pack for WPF:

New in 2017.R1

MindFusion.Charting for WPF

Funnel Chart

Funnel charts are often used to represent the stages of a process and show relative values or measurements associated with each stage. In MindFusion.Charting API, funnel charts can be created using the FunnelChart control associated with a FunnelSeries providing data. FunnelChart inherits appearance properties from the base Chart class, and offers additional customization through StemWidth and SegmentPadding properties.

Miscellaneous

  • Set ShowCrosshairs to display crosshairs in RealTimeChart.
  • InnerLabelAlignment property of BarSeries lets you customize label alignment in bars.
  • ClearMeshSelection method lets you clear selected meshes in 3D charts.

MindFusion.Diagramming for WPF

Flip shapes

The shape of a ShapeNode can be flipped horizontally or vertically. Enable the AllowFlip property and the shape flips when an edge is dragged over its opposite edge. You can get or set current flip state using FlipX and FlipY properties.

Fluent API

Extension methods in MindFusion.Diagramming.Wpf.Fluent and MindFusion.Diagramming.Wpf.Layout.Fluent namespaces let you initialize objects using fluent programming style:

C# [image] Copy Code

using MindFusion.Diagramming.Wpf.Fluent;
using MindFusion.Diagramming.Wpf.Layout.Fluent;
//...

diagram.Factory
.CreateShapeNode(20, 20, 60, 40)
.Brush(Colors.LightGray)
.Font("Arial", 12)
.EnableStyledText(true)
.Text("Task <i>1</i>")
.ToolTip("This is the task")
.TextRotationAngle(15);

new TreeLayout()
.LevelDistance(20)
.NodeDistance(20)
.LinkStyle(TreeLayoutLinkType.Cascading3)
.Arrange(diagram);

ShapeListBox control

The ShapeListBox control displays a list of Shape icons along with their DisplayName. It lets users drag-and-drop a Shape to the diagram's canvas to create a new ShapeNode. Set the ItemsSource property to an array or collection of shapes that should be rendered inside the control. For example, setting the Shape.Shapes list as ItemsSource will show all pre-defined shapes. You can customize the shape appearance by setting ShapeBrush and ShapeSize properties.

DiagramLink improvements

  • AllowSplitLinks now works for Bezier links too. Users can insert a new Bezier segment by dragging any point (other than a control point) of a selected link. Adjacent segments can be merged back into a single one by dragging a tangent control point (square adjustment handle) onto a pass-through control point (round adjustment handle).
  • IntermediateShape shapes are now rendered at correct position for Spline links.
  • RerouteLinks.WhileModifying now works when multiple nodes are being dragged, either due to selection or grouping.
  • Fix for link visibility issues when folding nested containers.
  • The component no longer keeps a separate segmentCount field, removing a common source of errors. The SegmentCount property now calculates its value from ControlPoints elements. The UpdateFromPoints(updateGroups, updateSegments) overload has been removed too.
  • SegmentCount setter no longer refuses changing number of segments if auto-routing is enabled or the link is a self-loop.
  • The new Spline element of LinkShape enumeration draws links as interpolating splines that pass through all of their control points:

Shape formula improvements

  • The LocationForNode method of ShapeControlPoint returns current position of the control point for a node.
  • The UpdateShapeControlPoints method of ShapeNode lets you update the node appearance after adding new control points to a Shape.
  • ControlPoints are now saved in shape libraries.

Miscellaneous

  • TextLines property of ShapeNode returns the lines of text as wrapped for current node size.
  • The PanAndModify behavior lets you select and modify when the mouse pointer is over an item, or pan the view otherwise.
  • Fix for LayeredLayout not sorting subgraphs correctly when using the MultipleGraphsPlacement.*Sort options.
  • The RotationStep property of Diagram class specifies the increments applied to a node's RotationAngle during interactive rotation.
  • The Bounds property of DiagramNode now supports binding.
  • GridRouter evaluates routes between more distant sides of connected nodes when RoutingOptions.EvaluateFarPoints is enabled.
  • Fix for magnifier offset when origin of Diagram.Bounds is non-zero.
  • Enable inertia for pan interactions by setting the PanInertia property to true.
  • A NodeRenderer added to custom node templates will now repaint automatically when any dependency property of the node changes.
  • Set FreeFormMode to enable free-form lasso selection that lets users draw irregular outline to select items inside.
  • HeadStrokeDashStyle property added to DiagramLink lets you set the dash style of arrowhead outlines independently from link segments' one.
  • Fixed orientation change gesture for cascading links when AllowSplitLinks is enabled.
  • PdfExporter now creates page hyperlinks if HyperLink is set to a value in "page://{number}" format, e.g. set "page://1" to open the second PDF page when the item is clicked.
  • Disable adding new headers to the lanes grid by setting AllowAddHeaders to false.
  • The Visio Stencils import API provides access to BeginArrow and EndArrow values.
  • The Visio Stencils import API provides access to Connection elements defined for a shape.
  • Fixed bug in ResizeToFitText method with long words in the text when preserving node's ratio.

MindFusion.Scheduling for WPF

RangeSelector integration

The Calendar control can integrate with the new RangeSelector component in order to implement a timeline in the Resource view. The new ResourceTimeline sample illustrates this integration.

MindFusion.Spreadsheet for WPF

Improved XLSX Import and Export

The ExcelExporter and ExcelImporter classes are now times faster than before and the results are more accurate. Various problems and inconsistencies were fixed. Both classes now expose a View property. If you set the View property of the ExcelExporter, the exporter will also export view information, such as the active tab and selection. Alternatively, setting this property during import, will cause the view information to be imported.

Miscellaneous

  • It is now possible to add images to worksheet cells.
  • The CsvExporter class can now export partial worksheets through the new Export overload.
  • The WorkbookView expoxes new Cut, Copy, and Paste methods, which can be used to cut, copy, and paste the current selection of the active worksheet in the view.
  • The WorkbookView now exposes ColumnsMoved, RowsMoved, ColumnsResized, and RowsResized events.
  • The WorkbookView now exposes ColumnsMoving and RowsMoving events, which can be used to validate interactive columns and rows moving.
  • The WorkbookView now exposes ColumnsResizing and RowsResizing events, which can be used to validate interactive columns and rows resizing.

New in 2016.R2

MindFusion.Charting for WPF

Candlestick Charts

The CandlestickSeries class represents movements of stock or currency prices in financial charts. Individual values in the chart are specified via StockPrice objects assigned to the series' Values property. Candlestick bodies are filled using brushes from the Fills collection if ones are specified, or otherwise with the FallingPriceBrush and RisingPriceBrush depending on the difference between Open and Close prices. CandlestickSeries can be added to either LineChart or BarChart controls.

Miscellaneous

  • Bars in BarChart3D can be rendered as cylinders by setting the new BarModel3D property to Cylinder.
  • LineChart performance has been improved when rendering large data-sets.

API Changes

  • Piece substrings renamed to Slice in PieChart properties and related types.
  • CrossHair substrings' capitalization changed to Crosshair in AxesChart properties.

MindFusion Virtual Keyboard

MindFusion Virtual Keyboard has been initially added to MindFusion Pack for WPF.

New in 2016.R1

License keys

There is no separate trial build of the control assemblies anymore. Instead, set the LicenseKey property of the controls to disable their evaluation mode and stop displaying trial messages. If your application contains more than one control by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) from application start-up code to specify the key once instead of setting it per each control. License key strings are now listed on the Keys & Downloads page at MindFusion's customer portal.

Visual Studio 2015 support

MindFusion Pack for WPF now includes support for Visual Studio 2015. The installer can create VS2015 toolbox palette for the component.

Barcodes

The new BarcodeLabel class allow displaying EAN, UPC or QR barcodes.

MindFusion.Charting for WPF

Improved Zooming

Selected area with width smaller than MinZoomSpan does not evoke any action in the control. In addition, the new ZoomChanged event fires whenever zoom occurs and provides useful data for the zoom action with its ZoomChangedArgs.

Cross Hair Improvements

The cross hair control has been improved with several new properties, a method and an event. The properties are:

  • CrosshairBackground, which lets you change the background of the control.
  • CrosshairTemplate, which you can use to set your own ControlTemplate for the cross hair.
  • CrosshairType that let you choose among several types of cross hair to display.

The new CrosshairPosition method returns the current location of the cross hair. For more precise handling of cross hair movements a new event is available – CrosshairPositionChanged.

Greatly Improved 3D Charts

3D charts have received plenty of improvements, new properties and performance optimizations:

  • PointMergeThreshold – The property sets the radius of an area around a given point where no other points are drawn. The result is better performance especially in charts with numerous points, which happen to be close to one another. Of points with similar coordinates only a single one is rendered, the rest are omitted.
  • InterpolationType.None – A new InterpolationType has been added to the InterpolationType, which does not interpolation but adds data directly and connects the points with triangulation.

The SurfaceType enum has been replaced with three bool properties, which makes the API easier to understand and use.

  • ShowSurface – shows/hides the surface of a 3D chart
  • ShowScatters – shows/hides the scatters
  • ShowWireFrame – shows/hides the wireframe

ScatterFaceSize – the property regulates the size of the polygons that build a 3D scatter. Bigger values lead to bigger polygons, which results in faster performance and more rough scatter mesh.

Effect3D.ShaderEffect – the property can be applied to all 3D chart elements, including scatters and performs much faster.

Exporting Images

Two new methods have been added for exporting the chart as an image – CreateImage and ExportImage.

Custom Formatting of Labels in Real-time Charts

A new property has been added to the RealTimeChart library – Axis.LabelFormatProvider. Use it to specify custom formatting of numeric labels. If required, you can specify format arguments for your format classes with Axis.LabelFormat.

MindFusion.Diagramming for WPF

Free-form nodes

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline. To let users draw free-form nodes interactively, set Diagram.Behavior to DrawFreeForms or LinkFreeforms. Use the Points property of FreeFormNode to get or set outline points programmatically. If the Closed property is set, the node is drawn as a closed shape and its interior filled, or otherwise the node is drawn as a poly-line. If the distance between first and last points drawn by user is shorter than Diagram.AutoCloseDistance, the node's Closed property is automatically set to true. AutoCloseDistance default value is Double.MaxValue, so free-form nodes are always closed.

Additional drawing modes, convenient for touch input, convert FreeFormNode objects drawn by user to ShapeNode objects with most similar shape. To enable them, set Behavior to DrawFreeShapes or LinkFreeShapes. The shapes against which the user's input is matched are set via diagram's FreeFormTargets property. By default it contains Rectangle, Decision and Ellipse shapes.

Shape control points

Shape formulas can now be parameterized by associating control points with Shape objects. Each control point is passed to the shape script as a named variable. Apart from the name, you can specify the default, min and max coordinates for each parameter via the ShapeControlPoint constructor, and whether to treat its values as percents or fixed offset.

Resize table columns and rows

Columns and rows of a TableNode can now be resized interactively if its AllowResizeColumns or AllowResizeRows properties are enabled. In order to resize, move the mouse pointer to the border line on column's right side or row's bottom side until it shows resize cursor and start dragging. The control raises TableColumnResizing and TableRowResizing events to let you validate new size or prevent resizing some elements. The TableColumnResized and TableRowResized events are raised after the operation completes.

Barcode nodes

The BarcodeNode class displays EAN, UPC or QR barcodes as node's content. In-place edit operations let users enter new numeric codes for 1D codes or text strings for QR codes. The barcode format is specified via the Format property, the encoded number or text is set via Content, and color of 1D bars / 2D modules via BarColor.

Support for Visio stencils

The diagram can now display shapes from stencil files in Visio 2003 XML stencil format (.vsx). To load a stencil file, use an instance of the VisioStencil class. The shapes are displayed in the diagram through VisioNode objects. To associate a stencil shape with the node, create an instance of the VisioContent class and assign it to the node's Content property. Note that standard stencils installed with Visio are copyrighted by Microsoft, and you should not use them in your application. This feature is intended to let you use public domain stencils, or commercial clipart you have purchased a license for.

ShapeDesigner improvements

  • The ShapeDesigner control supports undo. Call its Undo or Redo methods to respectively undo or redo a change done to the designed shape.
  • ZoomFactor property added to ShapeDesigner. It also supports interactive zoom in/out via mouse wheel.
  • The SelectedElement property exposes the graphic element currently selected in ShapeDesigner canvas. You can bind to its stroke and brush properties to create alternative user interface for editing element attributes.

AnchorPatern improvements

  • The XUnit and YUnit properties allow specifying the coordinates of an AnchorPoint as a fixed offset from the node's top-left corner rather than in percentage, so that the point position does not change when the node is resized.
  • The AnchorPattern property of Shape class lets you associate anchor points with shape definitions. If a ShapeNode instance does not contain its own AnchorPattern, it will derive the one defined by the node's Shape.
  • The RowAnchorPattern property lets you specify default AnchorPattern for all table rows.

Miscellaneous

  • Undo/redo records for in-place edit operations are now created automatically. They are represented by instances of the EditTextCmd class.
  • LinkTextStyle.Center improved for vertical links.
  • KeepInsideDiagram property of NodeConstraints prevents a node from leaving diagram boundaries during user interaction (the older RestrictItemsToBounds property does not stop nodes from leaving diagram area but returns them to original position if dropped outside).
  • Dashed selection frames are now drawn in two colors and should be visible on both the default white background and custom darker backgrounds. You can change the second dash color by setting DashBackground property of HandlesVisualStyle.
  • Set the WhileModifying flag in RoutingOptions.TriggerRerouting to reroute links while users drag their end points.
  • Custom connection point classes can now override NearestAnchorPoint to implement custom anchor point selection logic; the method is now also called at the beginning of interactive link creation.
  • LinkHitDistance is now backed by a dependency property.
  • Fixed node spacing in bottom-to-top TreeLayout.
  • AllowRenamePages property of TabbedDiagramView now automatically sets new Title values instead of only raising events.
  • ChangeUnit now also scales stoke widths.
  • ShapeDesigner supports alignment grid, which can be customized using ShowGrid, AlignToGrid and GridSize properties.
  • ShapeDesigner allows specifying anchor points for the shape.

Fixed bugs

  • Fixed a bug where link to a child node inside a nested container would not point to correct position if both nested and outer containers are folded.
  • Fix for incorrect Visio formula parsing in VisioNodes for some regional settings.
  • Dots in item borders were not visible with default StrokeDashCap value when using dot and dash-dot stroke styles. Default value has been changed from Flat to Square to fix that.
  • Links to contained nodes were left visibly disconnected from them after deleting a folded ContainerNode.

MindFusion.Mapping for WPF

Zoom control

The ZoomControl class lets user change interactively the current zoom level and scroll position of a MapView. To set it up, add a ZoomControl to the page, place it anywhere over a MapView, and set the control's Target property to that view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, CornerRadius and TickPosition.

Miscellaneous

  • The new Behavior property lets users select multiple map elements interactively.

MindFusion.Reporting for WPF

Report Parameters

Parameters can now be added to a report through the new Parameters collection of the Report class. The parameters provide name, description and value and can be of any type, including expression. For more information about parameters, check the Report Parameters topic.

Barcodes

MindFusion.Reporting for WPF reports can now display UPC-A, UPC-E, EAN-8, EAN-13, and QR barcodes. The barcodes are represented by the new Barcode report item.

Miscellaneous

  • Fixed an issue with horizontal data ranges.
  • Items in data range headers and footers can now bind to the data source of the data range.
  • New sample illustrating the Barcode report items.

MindFusion.Scheduling for WPF

Interactive Recurrence Rescheduling

Recurrences can be rescheduled interactively by holding down the RescheduleRecurrenceKey while dragging a recurrent item. The control tries to preserve the current pattern of the recurrence when possible. Otherwise, the recurrence may be modified to accommodate to the new start and end times of the modified item. Interactive rescheduling is not registered in the undo history.

New Theme

A new built-in theme is available in MindFusion.Scheduling for WPF – the Light theme. It is available through the ThemeType enumeration.

New Members

Several new properties and events have been added to the control:

  • The RescheduleRecurrenceKey property in the Calendar class can be used to modify recurrences interactively.
  • TickSize added to the ResourceViewSettings class.
  • Calendar.FilterItem event.

New in 2015.R1

MindFusion.Diagramming for WPF

Support for Xaml templates

  • Template property has been added to the base DiagramNode class and now all node types can be templated. A NodeRenderer element can be added to templates to invoke nodes' standard low-level drawing code before rendering custom template elements.
  • TableNode cells can be templated by setting the Template property of the Cell class for individual cells, or by defining a template for all cells using a default style with {x:Type diag:TableNode+Cell} as a target type.

Improved arrowhead rendering

  • Arrowheads are rendered as a single path when possible and several arrowhead Shape definitions have been changed to implement mitered joints when HeadPen is set to a thick pen.
  • The point where end segments connect to arrowheads can be specified via the LinkSegmentInset property of Shape. Shape definitions from the ArrowHeads class set it to suitable default value. This allows using transparent or semi-transparent brushes without seeing the link line drawn behind arrowheads.

Shape designer control

The ShapeDesigner component implements a vector-drawing canvas where Shape definitions can be created interactively. Call the ImportShape method to open a shape for editing. Call the ExportShape method to create a Shape with specified Id from current content of the designer canvas. ShapeDesigner shows a palette with two kinds of elements: Primitives which when dropped on the canvas add a single curve or line segment, and Templates which when dropped on canvas add a closed path of several graphic primitives.

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Export Visio 2013 files

The Visio2013Exporter class can export the content of Diagram and DiagramDocument objects to Visio 2013 VSDX files. In order to use it, add a reference to the MindFusion.Diagramming.Wpf.VisioExport.dll assembly. Similarly to the VDX format exporter, Visio2013Exporter relies on a template file, called Visio2013.vxt, containing some boilerplate Visio XML code. The template must be either located in same folder as the application assemblies, or its path must be specified via the TemplatePath property. At this time the exporter supports shapes from Visio basic stencil.

Visio2013Importer improvements

  • The importer now supports Visio group shapes. Child shapes in groups are no longer lost when importing, and their corresponding diagram nodes are attached to the corresponding group node.
  • Visio NURBS curves are now imported as Bezier-style links.
  • Fix for importing connectors with applied rotation transform.
  • Shapes with a hidden attribute in master definition are now imported as invisible items.
  • The Item argument of ImportItem event handlers is now pre-set to a DiagramItem instance created for the imported Visio shape, letting you avoid parsing some standard data such as Bounds or Text. You can either modify this item's properties, or replace it with a new instance of a different type.
  • Fixed a crash when a shape master does not have a name attribute (this happens with custom stencils).
  • Fixed a crash when theme1.xml is missing from the imported vsdx archive (this happens with files converted from old Visio versions to 2013 format).
  • Fixed a parse exception for some non-English locales.
  • Fixed a bug where one-segment connectors were imported at wrong positions.
  • Added support for gradient brushes.

Other export improvements

  • PdfExporter, SvgExporter and WmfExporter will now render the swimlane grid if PrintOptions.EnableLanes is set.
  • VisioExporter export speed has been improved greatly for large diagrams.

Miscellaneous

  • Layout algorithms now automatically resize diagram's Bounds if it's not large enough to fit the arranged content. To revert to old behavior and keep fixed Bounds size, set GrowToFit to false.
  • The control raises DrawForeground event to let you render custom graphics on top of the diagram.
  • Set the Brush property of LinkLabel to fill the background of link labels.
  • TabbedDiagramView now activates the first tab after its document is loaded from a file.
  • TextPadding property is now applied by table cells.
  • Multiple-resize of rotated nodes fixed to apply same offsets in nodes' local coordinate system.
  • Anchoring.Keep option is now honored by OrthogonalRouter.
  • ZoomIn, ZoomOut, ZoomToRect, ZoomToFit methods added to DiagramView control.
  • Diagram.XmlOptions properties let you enable or disable style and theme serialization.
  • The magnifier tool now shows swimlanes and grid points.
  • The ChangeUnit method sets a new MeasureUnit and scales the coordinates of diagram items to keep them the same size.
  • the SetSelfLoopShape event is raised when a link becomes a self-loop, giving you a chance to set a custom shape for the link.
  • LinkLabels are now copied by DiagramLink copy constructor and clipboard methods.
  • Fixed LinkLabel positioning along Bezier links.
  • NodeStyleSelector property of VirtualizingDiagram lets you dynamically apply styles based on node's data.
  • Changing Diagram's ZoomFactor now updates MindFusion.UI.WpfZoomControl slider automatically.
  • Fix for wrong scale when printing diagrams with MeasureUnit different from WpfPoint.

Dependency properties

The following properties have been converted to dependency properties:

  • CellFrameStyle, Shape, and CaptionHeight properties of TableNode.
  • CaptionHeight and Shape properties of ContainerNode and TreeViewNode.
  • MeasureUnit property of Diagram class.
  • Arrowhead shape and size properties of DiagramLink class.
  • Default-value properties of Diagram class.

API changes

  • For consistence with MindFusion libraries for other platforms, BackBrush in default diagram style has been changed to white brush.
  • Type of LinkLabel.Margin property changed from double to Thickness.
  • ZoomControl can be now used with other MindFusion components and has been moved to MindFusion.Common.Wpf assembly in MindFusion.UI.Wpf namespace.
  • The SelectionMoved event has been renamed to SelectionModified, and is also raised if nodes are resized when AllowMultipleResize is enabled. Event handlers now receive SelectionEventArgs parameter instead of EventArgs.
  • The SelectionMoving event has been renamed to SelectionModifying, and is also raised if nodes are resized when AllowMultipleResize is enabled. Event handlers now receive SelectionValidationEventArgs parameter instead of ValidationEventArgs.

MindFusion.Spreadsheet for WPF

MindFusion.Spreadsheet for WPF has been initially added to MindFusion Pack for WPF.

MindFusion.Charting for WPF

Real-time Chart Library

A brand new library has been added to the MindFusion.Charting for WPF component - a real time chart. The new control is specially optimized to render fast large amounts of data in real time. Its major feature is the ability to handle a lot of points without loading the machine it runs on. The library also offers various customization options for the chart - scatters, multiple legends, multiple Y and Y2 axes, custom labels, tooltips, grid. You can read more about the component in the "Real Time Chart" section in the "Programming Interface Overview" topic. We have added samples, tutorial and detailed documentation for the component in the MindFusion.Charting for WPF installation.

Miscellaneous

  • ShowCrosshair renders a cross hair that will trace the mouse position over the plot area.
  • Curve property, which when enabled draws a line as a canonical spline.

3D Charts

  • All 3D charts support unlimited number of series.
  • New property Lights holds a collection of Light objects instead of the LightType property.
  • Detailed hit testing, which returns a ChartHitTestResult3D that contains the clicked 3D point, the normalized 3D point, a collection of chart elements (if found), and the nearest peak (in surface charts).
  • AllowMeshSelection property, which when enabled allows selection of mesh objects with a mouse click. The MeshSelectionBrush sets the brush for the selection.
  • Behavior3D property, which lets you choose how the chart responds to mouse interactions.
  • Improved performance for all chart types.

Surface Charts

  • SurfaceType property, which sets whether scatters or surface is drawn.
  • SurfaceSeries.GroundLevelMargin property, which sets the GroundLevel-offset.
  • Each Series3D can be clipped in a given range with the ClipMinimum and ClipMaximum properties.
  • TextureType property sets the texture of the chart - Brush or ColorMap.
  • New ColorMapList property, which sets a Color map with arbitrary colors and offsets.
  • CloseModelFigure property, which closes the sides of the model if enabled.

MindFusion.Scheduling for WPF

Improved data grid

The cells and headers in the data grid can now be customized through a set of new properties: CellBorderBrush, CellBorderThickness, HeaderBackground, HeaderBorderBrush, HeaderBorderThickness, HeaderFontSize, HeaderForeground, and HeaderMargin. The new ColumnCreating event can be used to replace a grid column with a custom one.

New Holiday Providers

Five new holiday providers have been added to the MindFusion.HolidayProviders.dll assembly, namely AustraliaHolidayProvider, FranceHolidayProvider, GermanyHolidayProvider, RussiaHolidayProvider, and UKHolidayProvider.

Improved Timetable view

The WorkTimeStartHour and WorkTimeEndHour properties have been renamed to WorkTimeStart and WorkTimeEnd respectively and are now of type TimeSpan to allow more flexible work time intervals. In addition, the new WorkTimeStarts and WorkTimeEnds properties can be used to specify different work time intervals for the different days in the view. The new ColumnHeaderTemplate property can be used to customize the column headers by using a DataTemplate object.

Improved WeekRange view

The Week Range view can now display week numbers, similarly to the Single Month view. The week numbers can be enabled through the WeekHeaderPosition property and can be customized through the RotateWeekHeaderTexts, WeekHeaderFormat, WeekHeaderStyle, and WeekNumbersHeaderWidth properties.

Improved Resource view

The row headers can be customized through the new RowHeaderTemplate property.

Miscellaneous

  • New resource and item hit-testing methods: GetItemAt and GetResourceAt.
  • The modifier key to clone items interactively can now be specified through the ItemCloneKey property.
  • New ItemStartModifying event.
  • Various bug fixes.
  • Two new samples - CustomMonthCalendar and CustomTimetableGrid.

MindFusion.Mapping for WPF

Zoom control

The ZoomControl class lets user change interactively the current zoom level and scroll position of a MapView. To set it up, add a ZoomControl to the page, place it anywhere over a MapView, and set the control's Target property to that view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, CornerRadius and TickPosition.

Miscellaneous

  • The new Behavior property lets users select multiple map elements interactively.

MindFusion.Reporting for WPF

Improved charts

Several new properties have been added to the LineChart class to imporive the customization for the plot, grid, legend and axes. The axes settings can be specified through the new XAxisSettings and YAxisSettings properties.

The AxesChart class exposes four new properties, which can be used to specify the intervals displayed by the chart axes. The new properties are XMinValue, XMaxValue, YMinValue, and YMaxValue.

Miscellaneous

  • Report items can be searched by name through the new FindItem method.

New in 2014.R1

Visual Studio 2013 support

MindFusion Pack for WPF now includes support for Visual Studio 2013. The installer can create VS2013 toolbox palette for the components, and can optionally install VS2013 sample projects.

MindFusion.Diagramming for WPF

Import Visio 2013 files

The Visio2013Importer class can import .vsdx files, created by version 2013 of Microsoft Visio. In order to use it, you must add a reference to the MindFusion.Diagramming.Wpf.VisioImport.dll assembly. Various overloads of the Import method can be used to import the Visio drawing into a DiagramDocument whose pages correspond to the Visio pages, or into a single Diagram whose content is merged from all imported pages. When merging multiple pages, their positions in the diagram depend on the PagesPerRow value. Visio2013Importer supports Visio's basic flowchart and data flow stencils. For each node shape from the .vsdx file, the importer creates a ShapeNode object whose Shape, Text, Brush and Stroke properties are set to values corresponding to the imported Visio shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Zoom control

The MindFusion.UI.WpfZoomControl class lets the users to interactively change the current zoom level and scroll position of a Diagram or DiagramView. To set it up, add a MindFusion.UI.WpfZoomControl to the window, place it anywhere over the target diagram, and set the control's Target property to that diagram or view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by MindFusion.UI.WpfZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, Stroke, CornerRadius and TickPosition.

Miscellaneous

  • Enable the AllowRenamePages property of TabbedDiagramView to let users rename a DiagramPage interactively by clicking its tab.
  • Several new shapes added for better compatibility with Visio 2013 basic stencil: RightTriangle, Decagon, Trapezoid, Star4Pointed, Star5Pointed, Star6Pointed, Star7Pointed, Star16Pointed, Star24Pointed, Star32Pointed, Donut, Plaque.
  • DefaultEncoding and AutoDetectEncoding properties added to PdfExporter.
  • New RoundAndSquare and RoundAndSquare2 handle styles can be set as the HandlesStyle of nodes.
  • SkipEmptyPages property added to PrintOptions.
  • The projection of a node on the scales of Ruler control now shows the boundaries of the rotated node shape. To ignore rotation as in older versions, set ProjectRotatedBounds to false.
  • Fixed invisible inplace edit text-box problem under Windows 8 and .NET 4.5.
  • Fixed bug in undo/redo of RotationAngle assignments.

New in 2013.R2

MindFusion.Charting for WPF

New Bubble chart

A new chart has been added - the bubble chart. The bubble chart is represented by the new BubbleChart class. Its data series are specified through instances of the BubbleSeries class. The visual elements inside the chart are represented by Bubble objects.

Improved 3D charts

The 3D charts, such as BarChart3D and SurfaceChart, no longer derive (indirectly) from Chart. Instead, they share a new base class - Chart3D. This way the 2D and 3D class hierarchies are now parallel. Many of the properties of the old 3D chart classes have been promoted to the new Chart3D class. The hit-testing in 3D charts has also been improved. The Chart3D.HitTest method returns a ChartHitTestResult3D object, which contains information about the result of the hit-testing operation, in addition to the list of ChartElement objects available in the 2D version.

Several new properties have been added to the SurfaceChart, including CloseModelFigure, Effect3D, SurfaceType. The SurfaceType property now enables the surface chart to display its associated data as scatter marks, rather than a surface. The scatter marks can be customized through several new properties in the SurfaceSeries class, namely ScatterSize, ScatterType, and ShowScatterFlag.

Chart Effects

New ChartEffect property has been added to the Chart class. Currently the only supported effect is Glass.

Miscellaneous

  • ClipToPlotArea, SecondaryGridFills, and SecondaryGridStrokes properties added to AxesChart;
  • AxisCrossingPoint, HorLabelAlignment, and VertLabelAlignment properties added to AxisSettings;
  • ToolTipText and ToolTipType properties added to ChartSeries;
  • New and improved existing samples;

MindFusion.Diagramming for WPF

Display graphs in 3D

The DiagramView3D control lets you display the elements of a diagram in 3D space. Assign the Diagram that should be displayed in this view to the Diagram property. DiagramView3D adds a 3D model to the scene for each node or link of the specified diagram. The positions of nodes in 3D coordinate space are specified via the Position3D attached property. Links are rendered as straight lines connecting the 3D node models. By default, nodes always face the camera, unless NodeRotationType is set to None.

Import OpenOffice Draw files

The DrawImporter class can import .odg files, created by the OpenOffice Draw vector graphics editor. In order to use it, you must add a reference to the MindFusion.Diagramming.Wpf.DrawImport.dll assembly. Various overloads of the Import method can be used to import the OpenOffice drawing into a DiagramDocument whose pages correspond to the Draw pages, or into a single Diagram whose content is merged from all imported pages. DrawImporter supports shapes from the General and Flowchart shape palettes in Draw. For each node shape from the .odg file, the importer creates a ShapeNode object whose Shape, Text, Brush and Stroke properties are set to values corresponding to the imported OpenOffice shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Import Visio 2003 XML drawings

VisioImporter allows importing Visio 2003 XML Drawing files (*.vdx) into WpfDiagram. The standard Visio flowchart shapes, as well as most of the UML and Database entity shapes are imported to their closest representation in the MindFusion.Diagramming object model. The Visio connectors are imported as DiagramLink objects, preserving the relationship between the connected nodes. In addition, most of the attributes of Visio objects such as text, text formatting, fill and line colors and styles are preserved. The component raises an event for each imported node to let you set the node shape if it is not recognized by MindFusion.Diagramming or if you need to set a different shape.

The Import method imports all Visio pages into a DiagramDocument, creating a DiagramPage for each page from the VDX. To determine how many pages there are in a Visio document and import only a single page, call the GetPageCount and ImportPage methods. All pages of a Visio drawing can be imported into a single Diagram by calling the ImportAllPages method, which lays out the pages as set in PagesPerRow.

Miscellaneous

  • Improved appearance of hatch patterns used to draw frames for several HandlesStyle types.
  • Added support for loading HatchBrush objects from files saved by Windows Forms and ASP.NET versions of the control. Such brushes are implemented using the WPF ImageBrush class, and you can create brushes corresponding to GDI+ HatchStyle patterns using the CreateInstance method of the HatchBrush class.
  • AttachTo overloads that attach nodes to link segments or control points now allow specifying negative index values. Negative values are interpreted as relative to the last point or segment, regardless of the current number of link segments. For example, -2 denotes the second-to-last point or segment.
  • Improved handling of clip paths in PdfExporter.
  • The swimlane grid can be exported to Visio by setting the ExportLanes property of VisioExporter.
  • The Copy method lets you copy text attributes between objects implementing the ITextAttributes interface, such as diagram items, table cells and tree items.
  • Improved placement of link labels along shorter link segments.
  • The ArrangeLinkLabels method rearranges link labels whose AutoArrange flag is set.

New in 2013.R1

Visual Studio 2012 support

MindFusion Pack for WPF now includes support for Visual Studio 2012. The installer can create VS2012 toolbox palette for the components, and can optionally install VS2012 sample projects. In addition, toolbox palettes are now created for all .NET target frameworks supported by the respective Visual Studio versions.

MindFusion.Charting for WPF

Styles and Themes

Styles define the appearance of a given chart element - the axis, the series, the legend. Each ChartTheme is a collection of styles. With MindFusion.Charting for WPF you can now:

  • create themes based on the appearance of an existing chart
  • create themes with the ThemeEditor tool
  • save themes to XML files
  • load themes from XML files
  • use a number of predefined themes.

The Working with Themes tutorial gives detailed information on how to create, save, load and edit themes with MindFusion.Charting for WPF.

Better Design Time Support

MindFusion.Charting for WPF lets you now edit all collection properties, including the Series collection, the brushes and strokes in design time through the property grid.

Axis Intervals

The new AxisSettings.IntervalCount property lets you specify the exact number of intervals at the axis. In such case the control does not use the Interval property and calculates the value of each interval based on AxisSettings.Min, AxisSettings.Max and AxisSettings.IntervalCount.

API Changes

  • ChartSeries.Fills, ChartSeries.Strokes, LineSeries.ScatterFills, LineSeries.ScatterStrokes are now of type BrushCollection. The change was required by the new design time support features.
  • a bug with the Series property in the ChartLegend was fixed.

Important Note

Due to the extended design time support that we added in this version all predefined data series and brush collections have been removed from the charts. This might lead to exceptions if you reference them. To correct this just create a new instance of the type you are trying to access in the collection.

MindFusion.Diagramming for WPF

Preserve order in tree layout

The Balance property of TreeLayout can be set to Preserve to keep the original geometric order of child nodes when arranging them under their parent. This can be used to arrange tree branches in a specific order by first positioning them in increasing horizontal or vertical positions. Another possibility is to apply TreeLayout from NodeModified handler to let users rearrange the tree branches by dragging and dropping a node.

Selection improvements

  • Set Behavior to SelectOnly to let users select existing items, but not modify them or draw new ones.
  • The SetsDirtyFlag property of the Selection class specifies whether the Dirty flag should be set when selection changes.
  • SelectionStartMoving event raised when the user begins moving multiple selected items.
  • The ToggleSelection modifier key can be used to select or deselect items by clicking, but disables selection via lasso rectangle.

Miscellaneous

  • The AllowAddChildren and AllowRemoveChildren properties of ContainerNode specify whether users are allowed to add or remove child nodes to / from the container.
  • The GetNearestBorderPoint method of DiagramNode can be used to find a point from the node's border closest to a specified point.
  • The ScrollZoneSize property of Diagram can be used to specify the size of the area near the control edges that starts auto-scrolling.
  • The last row in a TableNode will now be rendered clipped if it fits only partially inside the node, whereas in previous versions the row would not be rendered at all.
  • The HandlesStyle of a link can now be set to Invisible to stop rendering its selection handles, but still allow dragging control points.
  • The Tag property of DiagramDocument (inherited from FrameworkElement) is now automatically saved in XML files if it's a simple value, and SerializeTag is raised to let you save complex objects.

Fixed bugs

  • Ruler alignment guides did not set the Dirty flag.
  • Images exported by CreateImage excluded items at negative coordinates.
  • ZTop and ZBottom methods did not work correctly with layers.

MindFusion.Reporting for WPF

Exporting

New exporters have been added - PdfExporter and MhtmlExporter, which enable exporting to the PDF and MHTML formats respectively. For more information about the new exporter, check Exporting Reports.

Side-By-Side Containers

Items in the report can now be arranged parallelly by putting them inside the new SideBySideContainer report item. For example, this is useful to display two (or more) data ranges one next to the other.

Miscellaneous

  • New DefaultEncoding property in PdfExporter;
  • New Median aggregate function;

MindFusion.Scheduling for WPF

Improved item presenter

The ItemPresenter class now provides the start and end time of the represented item fragment through the new StartTime and EndTime properties. In addition, derived classes can override the new OnStartTimeChanged, OnEndTimeChanged, and OnItemPropertyChanged methods to get notified when the StartTime or EndTime properties change or when any property of the underlying item changes.

Improved recurrence

The Recurrence class now exposes a new event - ValidateOccurrence, which can be used to validate and customize the occurrences of a recurrence pattern.

New in 2012.R2

MindFusion.Charting for WPF

Radar and Polar charts

A brand new type of charts has been added - the radar chart control. It supports:

  • unlimited number of data series
  • 4 types of labels at the inner axis and outer axes
  • label borders
  • customizable sweep angle and sweep direction
  • spiderweb
  • labels for each data series
  • scatters
  • custom labels

Hit testing

MindFusion.Charting for WPF supports hit testing. Use the HitTest method, which returns a list of ChartElement objects that contain the specified point. Each chart element has properties that help you identify the data that it represents:

  • PiePiece.SliceIndex and PiePiece.SliceValue get the index of the data this piece represents in the Data for the PieSeries as well its value.
  • Bar.BarIndex and Bar.SeriesIndex get the index of the bar in the series and the index of the series in the Series collection. The Value property gets the value for the bar.
  • Line.SeriesIndex gives you the index of the Line in the Series collection. DataPoints gives you the data for this Line as provided by the user.

Visual effects

Each chart supports the System.Windows.Media.Effects.DropShadowEffect and System.Windows.Media.Effects.Blur effect. Use the Effect property to specicy the chosen effect.

MindFusion.Diagramming for WPF

Node effects

Two visual effects, represented by GlassEffect and AeroEffect classes, can be applied to nodes. To apply an effect, create an instance of the respective class, set up its properties, then add the instance to the Effects collection of a node (or to Diagram.NodeEffects collection to apply it to all nodes). Effects can be added, removed or modified at any time and this will immediately reflect on the diagram. Effects of different types can be applied simultaneously. It is also possible to apply more than one effect of the same type.

Improved styling support

The Brush, Stroke* and Font* dependency properties no longer contain initial local values and will inherit style values without having to clear the local values first. The diagram now exposes a style property for each built-in node type, which allows creating global styles for nodes directly in the diagram's markup code in the Xaml page. The properties are called ShapeNodeStyle, TableNodeStyle, etc. and are of the WPF's standard Style type.

Themes and Theme Editor

A theme in WpfDiagram is a set of styles, each associated with specific item type. When the theme is applied to a diagram, the styles registered in the theme affect all objects of their associated type. Themes are represented by the Theme class and can be assigned to Diagram objects through their Theme property. Styles are associated with item types within the theme through the RegisterStyle method. The package now includes a Theme Editor tool that provides simple visual environment for theme creation and modification. There are also several predefined themes available in the Themes subfolder of the installation root folder. For more information about this new feature, check Styles and Themes.

Diagram documents and tabbed views

The DiagramDocument class represents a collection of diagram pages or sheets, represented by DiagramPage objects. DiagramPage is derived from Diagram and only adds a Title property, so any current code that processes Diagram objects will work with DiagramPage objects too. New pages can be added to the document and existing pages can be removed and reordered via the Pages collection. The diagram document provides higher level of events for the pages contained inside it. The document supports the notion of an active page.

The new TabbedDiagramView can be used to display DiagramDocument objects. The view displays tabs for the individual pages in the document. The active page can be changed interactively by activating its associated tab. New pages can be added and removed to/from the document through buttons in the tab tray and the pages can be rearranged by dragging their associated tabs with the mouse.

One-way graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Multiple labels per link

The LinkLabel class allows multiple captions to be displayed for a single DiagramLink object. Link labels provide a set of properties allowing full customization of their display and positioning. Labels can also be arranged automatically to avoid overlapping nodes and other labels by setting LinkLabel.AutoArrange to true.

Layers

Items can now be assigned to layers, and layers can be hidden, locked or moved up/down in the Z order as a group. Set the LayerIndex property of items to associate them with layers in the Diagram.Layers collection. The Layer objects provide Visible, Locked and ZIndex properties, which will affect all items in the respective layer. Layers also expose a Title property shown in the LayerListView control. Newly drawn items are added to the layer specified via Diagram.ActiveLayer. For additional information about layers, refer to Layers.

Layer list control

The LayerListView control provides user interface for working with Layer objects. The control displays a list of all layers in a specified Diagram with a title and an overview area, and also allows editing of layer's Title, Visible and Locked properties and choosing the Diagram's currently active layer. New layers can be added to the Diagram by clicking the '+' button. The selected layer can be deleted by clicking the '-' button.

Parallel layouts

The .NET 4 version of MindFusion.Diagramming for WPF takes advantage of the Task Parallel Library (TPL) to enable parallelism on the different layout algorithms. Set the EnableParallelism property on the Layout class to true to enable arranging different subgraphs on different threads to possibly improve performance on multiprocessor systems. In addition, the maximum degree of concurrency can be manipulated through the MaxDegreeOfParallelism property. Note that only independent subgraphs are processed in parallel, so the SplitGraph property of layout classes that provide it must also be set.

Magnifier

The new magnifier tool allows users to interactively zoom in (or out) portions of the diagram by holding down a modifier key or pressing a mouse button. The magnifier's zoom factor and appearance can be customized. Additional information can be found in the corresponding section of Scrolling and Zooming.

Miscellaneous

  • the value of DiagramItem.ZIndex property is no longer required to be unique and smaller than the number of items;
  • the Shape property in ContainerNode and TreeViewNode can be set to Rectangle or RoundedRectangle;
  • diagram item collection types now implement the generic IList<> interface;
  • PdfExporter now creates PDF Bezier objects for Bezier curves in the diagram instead of approximating them with lines;
  • the DrawBackground event is raised to let you render custom graphics in the diagram background;
  • VisioExporter.DynamicsOff can be used to disable dynamic link routing in Visio 2010 in order to preserve the position of control points from the exported diagram;

API changes

  • LinkStyle enum renamed to LinkShape;
  • DiagramLink.Style property renamed to Shape;
  • TableStyle enum renamed to SimpleShape;
  • TableNode.Style property renamed to Shape;
  • ZLevelUp, ZLevelDown, ZTop and ZBottom methods now require a boolean argument specifying whether items are allowed to change layers;
  • ZIndex no longer corresponds to the position of items within Diagram.Items collection. Items however still contains the items sorted by Z order, as defined by item's ZIndex and LayerIndex;
  • Event handler delegates have been removed; events are now defined as generic EventHandler specialized via EventArgs type. For example the type of NodeCreated is now EventHandler<NodeEventArgs>;

New in 2012.R1

MindFusion.Charting for WPF

Surface charts

New type of charts has been added to the MindFusion.Charting for WPF control. It supports:

  • positive and negative values on the X, Y and Z-axis with the SurfaceSeries.XData,SurfaceSeries.YData and SurfaceSeries.ZData properties;
  • wireframe with adjustable color, width and thickness with the ShowWireFrame, SquareSize and WireFrameThickness properties;
  • customizable surface color, elevation shape and sensitivity with the SurfaceColor, ElevationShape and ElevationSensitivity properties;
  • interactive rotation of the camera with the AllowCameraInteraction property;
  • adjustable camera position and light type with the RotationAngle, RotationAxis and LightType properties;
  • scaling of the chart with the Scale property.

The new chart is represented by the SurfaceChart class. The tutorial Building a Surface Chart offers step-by-step instructions on how to adjust a surface chart according to your needs.

Dragging

Users can drag data points in line charts or the top of a bar in bar charts to change the data value. This is done by setting the Behavior property to Behavior.AllowXDrag or Behavior.AllowYDrag. The Behavior enumeration now allows bitwise combination and you can enable dragging along both X and Y axis.

Second X-axis

The X2AxisSettings allows you to define a second X-axis. Data for series that are bound to X2 is set with X2Data. X2Labels sets custom labels for the X2-axis. Data binding is available through the X2DataPath and X2LabelPath properties.

Zoom

Zooming is now supported in all types of bar and line charts - just set the Behavior property to Behavior.ZoomChart. You can zoom out the chart one step at a time by calling ZoomOut. Use ResetZoom to restore the chart to its original state at once.

DateTime values

You can set the XData, YData or Y2Data of the LineSeries or BarSeries instances to DateTime values. Set the ValueFormat property of the respective AxisSettings object to ValueFormat.DateTime and specify appropriate DateTime values as start and end of the axis. You can find details on how to use DateTime values with the control in the DateTime Values section of this reference.

Miscellaneous

  • You can set the start angle in pie charts with StartAngle.
  • Labels at the chart axis can be rotated with the LabelRotationAngle property.
  • Improved space calculations in line and bar charts with mixed data.
  • Data binding properties for the second Y-axis are available: Y2DataPath and Y2LabelPath.
  • Chart series can have dashed strokes or outlines with the StrokeDashArray, StrokeDashCap, StrokeDashOffset, StrokeEndLineCap, StrokeLineJoin, StrokeMiterLimit and StrokeStartLineCap properties.
  • The new LabelStroke property sets the brush for drawing labels at chart axes. The TitleStroke defines the brush for drawing the title label. TitleRotationAngle defines the rotation angle of the title label in horizontal axes.

MindFusion.Diagramming for WPF

Rotation improvements

  • Attached nodes can rotate together with their master node if the group's FollowMasterRotation property is set to RotateChildren.
  • The Text of a ShapeNode can be rotated independently from the node by setting the TextRotationAngle property.
  • Fixed a bug where links did not follow the rotation of their target TreeViewNode.
  • The scroll buttons shown in the caption bar of a TableNode can now be used when the table is rotated.

Virtualization

VirtualizingDiagram can display very large diagrams where there are actual DiagramNode and DiagramLink instances created only for the elements that should be currently shown on screen. This helps keeping the WPF visual tree small and could lead to huge performance improvements if there are thousands of elements in the diagram.

The data items that should be displayed as nodes must be assigned to the NodesSource property, and the data items that should be displayed as links must be assigned to the LinksSource property. The BindingMode property specifies whether the data source should be updated when the user draws new diagram items interactively.

Automatic node alignment

If AutoAlignNodes is enabled, the node currently being drawn or resized is aligned to another node so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Fractal tree layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Miscellaneous

  • The SaveToXml method now saves the definition of a custom Shape if a node's Shape has not any Id specified.
  • If NegatedY is set, the vertical Ruler scale displays negated Y coordinates.
  • The Ruler control scales now start from the origin of the diagram's Bounds instead of (0,0).
  • Fixed a bug where GroupAnchorStyles attachments did not preserve the correct distance for some values.
  • The TextBox control used for in-place editing now wraps text to multiple lines by default.
  • The Id property added to DiagramItem allows assigning custom identifiers to items. It can also be used to just store additional custom data similarly to Tag.
  • Call FindLinkById and FindNodeById to find items by their Id.
  • HookHeaders enables lane headers to be anchored to the left and top sides of the control's visible area.
  • Improved path-finding for long links in QuickRouter.
  • StartPoint and EndPoint provide a shortcut to setting the first and last control points of a DiagramLink.
  • Specify start and end nodes in LayeredLayout via the StartNode and EndNode properties.
  • GetAllIncomingLinks and GetAllOutgoingLinks methods added to DiagramNode.
  • Self-loop links that connect TableNode rows or TreeViewNode items are now routed around the node preserving their correct end points.
  • Links automatically align to the center of table rows or tree-view items when AutoSnapLinks is enabled.
  • Diagram.Viewport returns the currently visible region of the diagram.
  • Draw with the right or middle mouse button by setting RightButtonAction or MiddleButtonAction to Draw.

MindFusion.Mapping for WPF

MindFusion.Mapping for WPF has been initially added to MindFusion Pack for WPF.

MindFusion.Scheduling for WPF

Optimizations

The Calendar control now support virtualization and is able to handle hundreds of items. The virtualization cannot be turned off. When using custom item or cell presenters, you need to pay special attention to the fact that those presenters can be subsequently reused by the virtualization engine for other items or cells. When a CellPresenter is reused, its StartTime and EndTime properties are updated to reflect the start and end time of the new cell. This causes the OnStartTimeChanged and OnEndTimeChanged methods to be invoked. When an ItemPresenter is reused its Item property is updated and its OnItemChanged method is invoked.

Delayed Scrolling

Delayed scrolling can now be enabled through the new DelayScroll property. When scrolling is delayed calendar views do not update immediatelly during scrollbar interactions. Instead the control displays a small tooltip with information about the new scroll position. The contents of the tooltip can be a date or an index, depending on the specific view and the scrollbar being modified. When the scrollbar interaction is complete, the view updates to reflect the new scroll position.

Miscellaneous

  • The new KeepItemOrder property can be used to prioritize the newly created items during collision processing.

New in Q3.2011

MindFusion.DataViews for WPF

Various improvements to the MindFusion.DataViews for WPF components, including the ability to programmatically drill in and out of views as well as scroll to a particular activity or resource.

MindFusion.Diagramming for WPF

Dynamic node shapes

Shape instances can be defined using custom code that takes into consideration the current width and height of nodes. This allows creating shapes whose primitive elements change non-uniformly, e.g. by growing only in width or height when a node is resized. There are two ways to create such shapes. The first one is to use the Shape constructor that takes a CreatePathDelegate parameter, which can be implemented using a .NET function. Another Shape constructor takes a string argument that represents a Visio-like shape formula evaluated in run-time. The latter method enables serializing the shape code in external files, which can be reused by different applications and by MindFusion components for other platforms.

CompositeLayout algorithm

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.

SpringLayout improvements

  • Better handling of large nodes and nodes with non-uniform size.
  • The SpringLayout energy model has been changed to one that leads to better symmetry in the arranged graphs. The old model can still be used by setting LayoutMethod to Classic. This is recommended when using rounded links.
  • The Randomize property allows starting the layout process from random node positions.

Other layout improvements

  • If there is only one used execution path after a branching and up to two empty ones, FlowchartLayout will now center the used path under the branching start node.
  • OrthogonalLayout now produces more compact layouts with less link bends if MinimizeLinkBends is enabled.
  • If the Radius of CircularLayout is set to 0, the algorithm automatically selects a radius that fits all nodes along the circle's circumference.
  • KeepLaneSizes property added to the SwimlaneLayout algorithm.

Miscellaneous

  • Call SetZoomFactor to zoom the diagram with the specified zoom center point.
  • The DrawAdjustmentHandles method can be used when custom-drawing to render adjustment handles with their standard look and feel.
  • Set the StableSort property to get consistent results between different runs of LayeredLayout.
  • Now it is possible to resize multiple nodes simultaneously. To enable this, set AllowMultipleResize to true.

MindFusion.Reporting for WPF

Exporting

A new exporter has been added - ExcelExporter, which enables exporting reports to the Open Office XML format. In addition, the APIs of all exporters have been unified. For more information about the new exporter, check Exporting Reports.

MindFusion.Scheduling for WPF

Exporting

New exporter has been added - ExcelExporter, which enables exporting calendars to the Open Office XML format.

Miscellaneous

Many Calendar properties have been changed to dependency properties. These include Schedule, Date, EndDate, and more.

MindFusion.UI for WPF

Many new controls, including DockControl, TabControl, Slider, Rating, ColorPicker and more.

New in Q2.2011

MindFusion.DataViews for WPF

A completely new assembly has been added to MindFusion Pack for WPF - MindFusion.DataViews.Wpf. The assembly contains two new controls - ActivityChart and ResourceChart. The Activity Chart and Resource Chart secions in this documentation discuss those controls in more details.

New in Q1.2011

MindFusion.Charting for WPF

MindFusion.Charting for WPF has been initially added to MindFusion Pack for WPF.

MindFusion.Diagramming for WPF

Swimlane layout algorithm

SwimlaneLayout can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through a custom control template, or one composed of locked background nodes.

CascadeLayout algorithm

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

TriangularLayout algorithm

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.

HierarchicalLayout algorithm

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and not intersect. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.

Miscellaneous

  • OrthogonalLayout results have been greatly improved for nonplanar and high vertex-degree graphs.
  • LinkType adds supports for Bezier links to SpringLayout.
  • The swimlane grid can be printed by setting the EnableLanes property of PrintOptions.
  • The text of lane headers can be edited by the user if LaneGrid.AllowInplaceEdit is enabled.
  • TextBrush has been moved to the base DiagramItem class and now it is a dependency property.
  • EnumAllCycles method added to PathFinder.
  • Table cells now derive their default text attributes from the CellTextStyle property.

MindFusion.Scheduling for WPF

Resource View Improvements

  • The rows in the resource view can now be resized interactively by the users. To enable this functionality set AllowResizeRows to true.
  • The header texts are no longer scrolled out of view during horizontal scrolling.

Holiday Providers

The implementations of the new IHolidayProvider interface can now be used to supply culture-specific lists of holidays. The USHolidayProvider can be used to supply the major holidays in United States for a specific time interval.

Miscellaneous

  • CanSelect and IsPadding properties added to the CellPresenter class.
  • ShowInnerPaddingDays property added to the MonthRangeSettings class.

MindFusion.Reporting for WPF

New and Improved Charts

The PieChart has been improved with new properties allowing additional customizations. There are also new BarChart and LineChart report items. For more information about the new report items, refer to their respective topics.

MindFusion.UI for WPF

MindFusion.UI for WPF has been initially added to MindFusion Pack for WPF.

New in Q4.2010

MindFusion.Diagramming for WPF

Templated Nodes

The TemplatedNode class represents nodes whose appearance is set through Xaml data templates. This class is useful mostly as a base type of custom nodes, as shown in tutorials 3 and 4. However it is not abstract and can be used directly if the text -related properties defined in DiagramItem are sufficient for your purposes. The appearance of such nodes can be set through their Template property or the NodeTemplate property of the Diagram class.

WmfExporter component

The WmfExporter class creates a Windows Metafile (WMF) drawing from the content of a Diagram. The exporter enumerates all graphics primitives contained in the WPF visual tree and creates corresponding WMF records. This enables custom graphics and hosted controls to be rendered in WMF too. To use WmfExporter, add a reference to the MindFusion.Diagramming.Wpf.WmfExport.dll assembly to your project.

MindFusion.Scheduling for WPF

Undo/Redo support

If the UndoEnabled property is set to true, MindFusion.Scheduling for WPF tracks changes done on the schedule and allows undoing and redoing them later by calling the Undo and Redo methods of the Schedule class respectively. Multiple changes could be recorded as a single undoable operation by enclosing them between StartCompositeOperation and CommitCompositeOperation calls. It is also possible to create custom undoable operations by deriving from the Command class and calling ExecuteCommand with the custom command as argument.

MindFusion.Gauges for WPF

Miscellaneous

  • The new QueryLabelValue added to the BaseScale class.

MindFusion.Reporting for WPF

Custom Rendering of Items

Item appearance can now be modified or completely replaced through the use of the new Prerender event of the Report class. For more information, refer to Custom Rendering of Report Elements.

Miscellaneous

  • Label.TextAlignment property added.
  • TitleMember and TooltipFormat properties added to PieChart.
  • Report.CultureInfo property added.
  • Improved support for LINQ data sources.
  • New sample and tutorial.

New in Q3.2010

MindFusion.Gauges for WPF

MindFusion.Gauges for WPF has been added to MindFusion Pack for WPF.

MindFusion.Diagramming for WPF

SVG Export

Diagrams can now be exported to SVG (Scalable Vector Graphics) drawings using the new SvgExporter class.

Miscellaneous

  • Enabled styling of diagram items through the WPF styling system.

New in Q2.2010

MindFusion.Reporting for WPF

MindFusion.Reporting for WPF has been initially added to MindFusion Pack for WPF.

MindFusion.Diagramming for WPF

New font properties

The Font property of diagram nodes, table cells and treeview items is deprecated. The DiagramItem class now exposes FontFamily, FontSize, FontStretch, FontStyle, FontWeight and TextDecorations dependency properties. This enables better support for the WPF animation and styling features. The Cell and TreeViewItem classes now derive from a common TextPresenter class that provides the same font properties as DiagramItem.

New text alignment properties

The TextFormat and CaptionFormat properties are now deprecated. They have been replaced by the TextAlignment, TextVerticalAlignment, TextWrapping and TextTrimming properties defined in DiagramItem. In addition, there is a new TextPadding property that specifies the padding of text within the text's bounding rectangle. The same properties are exposed by TextPresenter - the new base class of the Cell and TreeViewItem classes.

New pen properties

The Pen property of DiagramItem is deprecated. It has been replaced by Stroke, StrokeThickness, StrokeDashStyle, StrokeDashCap, StrokeStartLineCap, StrokeEndLineCap, StrokeLineJoin and StrokeMiterLimit. This enables better support for the WPF animation and styling features.

Miscellaneous

  • The OriginConnection and DestinationConnection properties of DiagramLink enable getting detailed information about the link's origin and destination, such as the target TreeViewItem when connected to a TreeViewNode.
  • Auto-scrolling in the Overview control has been improved.
  • The Overview control can be scrolled programmatically using its ScrollTo method.
  • ClipText property added to ShapeNode.
  • GetNearestNode returns the node nearest to the specified point.
  • The SetBounds method can be used to set a node's Bounds without changing the position of attached nodes.

MindFusion.Scheduling for WPF

Customizable Cell Templates

The cells in the various views can now be customized through WPF control templates. This is achieved through the new CellPresenter class. For an example on how to do this take a look at the two new samples - CustomResourceCells and Holidays.

Miscellaneous

  • The GroupType and CurrentView properties of Calendar are now dependency properties.
  • Improved support for Visual Studio 2010.
  • Several properties which did not work as expected have been fixed.
  • Various other bug fixes.


Licensing

Licensing

There are no separate trial builds of MindFusion assemblies. When you purchase a component you can find the license key for this component listed on the Keys & Downloads page at the customer's portal [image] . Assign this license key to the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one MindFusion component, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) method from application start-up code to specify the key once instead of setting it per each control.


Programming Interface Overview

Programming Interface Overview


MindFusion.Charting for WPF Overview

MindFusion.Charting for WPF Overview

This section contains topics describing in details the individual chart controls and their features.


Chart Types

Chart Types

MindFusion.Charting for WPF offers the following controls that appear as icons in the VS toolbox:

  • line
  • bar
  • 3D bar
  • pie
  • 3D pie
  • surface charts
  • radar and polar charts.

Customizing the type of the chart

You can change the type of the chart with LineType, BarType, RadarType and PieType properties. All of them take value from the respective enumerations LineType enum, BarType enum, RadarType enum and PieType enum. Some chart types require more than one series - BarType.VerticalOverlay, BarType.HorizontalOverlay, BarType.VerticalStack, BarType.HorizontalStack, LineType.Area2DStack. Use the Series property to add the series.

Scatter charts

You can add scatters at data points to any line series. You should only set the ScatterType property of the LineSeries class to be anything different than ScatterType.None, which is its default value. You can draw only scatter charts by setting the LineType of the LineSeries to LineType.None.

Radar charts also support scatters. You can customize how the scatters for each series look with the RadarSeries.RadarScatterFills, RadarSeries.RadarScatterStrokes, RadarSeries.ScatterType, RadarSeries.ScatterSize and RadarSeries.RadarScatterStrokeThickness properties.

3D Bar charts

You can change the type of the 3D bar chart with the BarType3D property and the values from the BarType3D enumeration - it supports six types of layout for 3D bars. The 3D bar chart supports multiple series.

Pie / Doughnut charts

They support currently only a single PieSeries.

3D Pie / Doughnut charts

The PieChart3D.DoughnutThickness property regulates the inner radius of the chart. If it is set to 0, you will have a 3D pie chart. Any value greater than 0 will make the chart a doughnut. If you add more than one PieSeries to the control, the DoughnutThickness is applied to all of them.

3D Surface Charts

The surface charts can be drawn with or without a color map. The color map can be gradient or exact. Use the TextureType property to specify whether to use a color map and what type. ShowWireFrame renders the chart with a wireframe. Surface charts can also show scatters - use the ShowScatters property.


Chart Series

Chart Series

Each graphic on the chart represents a ChartSeries object. It holds data, which is used for calculating the coordinates of the graphics as well various style and appearance properties. All ChartSeries for a chart are kept in the Series property.

Each ChartSeries has a Title property, which shows as a label in the ChartLegend should you use one.

The ChartSeries defines the Fills and Strokes used for painting the chart graphics that corresponds to this series. It also holds properties for labels drawn at the series - LabelFontFamily, LabelFontSize etc.

Line and Bar charts can contain unlimited number of LineSeries, BarSeries and CandlestickSeries objects. Pie and doughnut charts have just one, which is an instance of PieSeries. The order in which the series are added may influence the appearance of the chart.

Radar and polar charts use the RadarSeries object. They is no limit to the number of series you can add. Each series defines properties for the data of the chart, the labels and the scatter for the graphic, if scatters will be drawn.

Pie and doughnut charts use the PieSeries class. They can have only one PieSeries.

3D surface charts use SurfaceSeries. This class, as well all 3D series class derive from AxesSeries3D.

3D bar charts and 3D pie charts use the same ChartSeries objects as their 2D counterparts - BarSeries and PieSeries. That's because the location of the series in 3D bar and pie charts along the Z-axis is done automatically by the control depending on the type of the chart and its settings.


Data

Data

Data properties

Data for the chart is set with the data properties of the ChartSeries objects. For line and bar charts they are XData and YData. For pie charts it is Data. 3D surface charts use the ZData property to specify the data for the Z-axis. If you want to set the data with data binding use the *Path properties instead - DataPath, XDataPath, YDataPath or ZDataPath.

Radar charts use the RadarSeries.Data property. If data binding is used the property is RadarSeries.DataPath. Polar charts use not only data but angles. The property for the angles are RadarSeries.Angles.

3D bar charts use the same data properties as their 2D counterparts - AxesSeries.XData and AxesSeries.YData, AxesSeries.XDataPath and AxesSeries.YDataPath. 3D pie charts use PieSeries.Data and PieSeries.DataPath. The location of the series along the Z-axis is done automatically by the control in those types of charts.

Your ChartSeries might be bound to the second X-axis or the second Y-axis or both. In this case use the X2Data or Y2Data properties to set the data as numbers. If you prefer data binding the properties are X2DataPath and Y2DataPath. The surface chart can have a second Z-axis and the data for it is set with Z2Data and Z2DataPath.

Data format

Data in each series is expected to be one-dimensional IList which holds double values or objects that can be converted to double with the standard .NET converters and parsers.

DateTime values

If you want to use DateTime values in your chart, check the DateTime Values section of this reference.


DateTime Values

DateTime Values

1. If you want to use DateTime values as X, Y or Y2 data for your chart you do that the same way as you would add numeric values. MindFusion.Charting for WPF supports DateTime values given in any of these formats:

  • as double values that are representation of a DateTime value in an OLE Automation format.

C# [image] Copy Code

DateTime myDateTime = new DateTime(2011, 12, 1);
lineSeries[0].XData.Add(myDateTime.ToOADate());

VB.NET [image] Copy Code

Dim myDateTime As New DateTime(2011, 12, 1)
lineSeries(0).XData.Add(myDateTime.ToOADate())

  • as DateTime objects

C# [image] Copy Code

DateTime myDateTime = new DateTime(2011, 12, 1);
lineSeries[0].XData.Add(myDateTime);

VB.NET [image] Copy Code

Dim myDateTime As New DateTime(2011, 12, 1)
lineSeries(0).XData.Add(myDateTime)

  • as long integer values that are representation of a DateTime value in ticks.

C# [image] Copy Code

lineSeries[0].XData.Add(myDateTime.Ticks);

VB.NET [image] Copy Code

lineSeries(0).XData.Add(myDateTime.Ticks)

2. You must set the ValueFormat property of the Axis object for the respective X, Y, X2 or Y2 axis at which DateTime data will be shown to ValueFormat.DateTime:

C# [image] Copy Code

Axis xAxis = new Axis();
......
xAxis.ValueFormat = ValueFormat.DateTime;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.ValueFormat = ValueFormat.DateTime

3. The start and end values of the respective axis must be set to the desired DateTime value. The properties for that - Axis.MinValue and Axis.MaxValue accept only double values. When the ValueFormat is ValueFormat.DateTime the control expects OLE Automation representation of the values for the properties:

C# [image] Copy Code

DateTime start = new DateTime(2011, 3, 1);
DateTime end = new DateTime(2011, 10, 31);
Axis xAxis = new Axis();
xAxis.MinValue = start.ToOADate();
xAxis.MaxValue = end.ToOADate();

VB.NET [image] Copy Code

Dim start As New DateTime(2011, 3, 1)
Dim [end] As New DateTime(2011, 10, 31)
lineChart1.XAxisSettings.MinValue = start.ToOADate()
lineChart1.XAxisSettings.MaxValue = [end].ToOADate()

The size of the interval among the scale divisions of the axis depends on the number of divisions we want to see:

C# [image] Copy Code

xAxis.Interval = (end.ToOADate() - start.ToOADate()) / 8;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.Interval = ([end].ToOADate() - start.ToOADate()) / 8

4. Then we select the type of labels to appear at the axis and rotate them at 35 degrees because formatted as DateTime values they are too long. We use the LabelRotationAngle property for that:

C# [image] Copy Code

xAxis.Interval = (end.ToOADate() - start.ToOADate())/8;
xAxis.LabelRotationAngle = 35;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.Interval = ([end].ToOADate() - start.ToOADate()) / 8
lineChart1.XAxisSettings.LabelRotationAngle = 35

5. Finally, don't forget to add the axis to the respective X/Y/X2/Y2 collection:

C# [image] Copy Code

myLineChart.XAxes.Add(xAxis);

Using DateTime values in a chart is shown in detail in the DateTimeValues sample that is installed with the control.


Labels

Labels

Labels can be displayed for any chart type - line charts display them at data points, bar charts - inside or at the top of bars, pie charts - inside or beside each pie slice.

Line charts

Line charts show labels at data points with the LineSeries.Labels property. If you want to use data binding, the property is LineSeries.LabelPath.

Bar charts

Bar charts can show labels inside bars depending on the value of the InnerLabelType property. If it is set to LabelType.CustomText, custom labels are specified with InnerLabel. The type of labels at the top of the bars depends on TopLabelType. Custom labels are set with TopLabel. If you want to use data binding for setting the labels the properties are InnerLabelPath and TopLabelPath.

Pie charts

Pie charts can show labels both inside and outside the slices. The type depends on InnerLabelType and OuterLabelType. If custom labels are drawn, the properties are InnerLabel or OuterLabel as well InnerLabelPath and OuterLabelPath if you use data binding.

Radar charts

Radar charts can show labels at the outer axes, at the inner axis and at data points. The type of the labels is set with RadarChart.InnerLabelType and RadarChart.OuterLabelType. The type of labels at data points in each series is set with RadarSeries.LabelType. Custom labels are specifies with RadarChart.InnerLabels and RadarChart.OuterLabels as well RadarSeries.Labels.

3D Surface charts

In 3D surface charts you can show the last label if the maximum number at an axis is not a multiple of the interval - for example the biggest number is 33 and the interval is 5.

3D Bar charts

3D bar charts can also show inner and outer labels with the same properties as their 2D counterparts - BarSeries.InnerLabelType and BarSeries.TopLabelType. Custom labels are set with BarSeries.InnerLabel and BarSeries.TopLabel. The properties for custom labels when data binding is used are BarSeries.InnerLabelPath and BarSeries.TopLabelPath.

3D Pie charts

3D pie charts can have labels inside and outside the pie slices - choose the right type of labels with PieSeries.InnerLabelType and PieSeries.OuterLabelType. If you want to set custom labels the properties are PieSeries.InnerLabel and PieSeries.OuterLabel or PieSeries.InnerLabelPath and PieSeries.OuterLabelPath if you use data binding.

Font Settings

The Font settings for labels drawn at each chart are set with ChartSeries.LabelFontFamily, ChartSeries.LabelFontSize, ChartSeries.LabelFontWeight and ChartSeries.LabelFontStyle.


Axes

Axes

This topic is only relevant for charts that use the Cartesian coordinate system.

The XAxes, YAxes, X2Axes and Y2Axes are used for setting the properties of the axes. Each chart can have as many axes of each type as needed. Create an object of type Axis, set the desired properties and add it to the respective AxesCollection cited above.

In 3D surface charts the properties for the Z-axis are set with ZAxisSettings. The labels at each axis depend on LabelType.

If the LabelType is LabelType.CustomText there are two options for placing custom labels:

  • at scale divisions - the Axis.CustomLabelPosition property should be set to CustomLabelPosition.AutoScalePoints
  • at the position of data points - the Axis.CustomLabelPosition property should be set to CustomLabelPosition.ChartDataPoints

Custom labels are placed either at data points or at the intervals of the axis - see the CustomLabelPosition property. The Title property sets the title of the axis.

Custom labels are specified with the Labels property. Of course, you can use data binding - specify the name of the data bound property with LabelPath.

The sample code demonstrates how to set custom labels using a list as well using a data bound property:

C# [image] Copy Code

barChart1.DataSource = salesStatistics;
Axis xAxis = new Axis();
xAxis.LabelPath = "Products";
xAxis.LabelType = LabelType.CustomText;
barChart1.XAxes.Add(xAxis);

Axis yAxis = new Axis();
yAxis.LabelType = LabelType.CustomText;
yAxis.Labels = new string[] { "2008", "2009", "2010"};
barChart1.YAxes.Add(yAxis);

VB.NET [image] Copy Code

barChart1.DataSource = salesStatistics
barChart1.XLabelPath = "Products"
barChart1.YLabels = New String() {"2008", "2009", "2010"}

The axis can be customized by the MinValue, MaxValue and Interval. They set the exact start and end numbers as well the size thus the count of the intervals between them.

You can set the count of the intervals at the axis explicitly with the IntervalCount property. In this case, the Interval property will not be considered and the length of the interval will be calculated based on Axis.MinValue, Axis.MaxValue and Axis.IntervalCount.

The sample code below shows how to set an axis that shows the divisions from 0 to 1000, divided at intervals of 100:

C# [image] Copy Code

Axis xAxis = new Axis();
xAxis.MinValue = 0;
xAxis.MaxValue = 1000;
xAxis.Interval = 100;
barChart1.XAxes.Add(xAxis);

VB.NET [image] Copy Code

barChart1.XAxisSettings.MinValue = 0
barChart1.XAxisSettings.MaxValue = 1000
barChart1.XAxisSettings.Interval = 100

If you want to use DateTime data in your chart, please refer to the DateTime Values topic - there are detailed instructions how to set the chart axis when data is DateTime values.

Second Y-axis

If you want to show the second Y-axis, all you should create an Axis object and add it to the Y2Axes property. Set the scale with Axis.MinValue, Axis.MaxValue and Axis.Interval. Alternatively you can set the value of the Y2Data or Y2DataPath properties in an axes chart - in this case an Y2 axis will be calculated and drawn automatically.

Second X-axis

If you want to show the second X-axis, you need to create an Axis object and it to the X2Axes property just like you do with the other axes. If you set the value of the X2Data or X2DataPath properties in an axes chart the axes will be drawn automatically based on your data.

XAML

When you want to write the code for your axes in design time using XAML the right way to do it is to initialize the whole AxesCollection rather than adding one more axis to it. This way the collection is reset and all axes that might have been added as default will be cleared.

XAML (correct) [image] Copy Code

<chart:BarChart Name="barChart1" Margin="0,0,26,28">
<chart:BarChart.XAxes>
<chart:AxesCollection>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:AxesCollection>
</chart:BarChart.XAxes>
</chart:BarChart>

If you directly add the Axis, the collection shall not be reset, a possible default axis will be present and you migh end up having two axes instead of one:

XAML (wrong) [image] Copy Code

<chart:BarChart Name="barChart1" Margin="0,0,26,28">
<chart:BarChart.XAxes>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:BarChart.XAxes>
</


Legend

Legend

1. There are no limits as to the count of legend you can add to the chart. MindFusion.Charting for WPF supports two types of legends.

1.1 ChartLegend takes its labels from the Title property of the ChartSeries it refers to. The brushes for the rectangles that are drawn before each label are taken from the Fills property of the ChartSeries. The series are set with the Series property.

Here is a sample code that creates a ChartLegend:

C# [image] Copy Code

ChartLegend legend = new ChartLegend();
legend.Series = barChart1.Series;
legend.BorderBrush = Brushes.LightGray;
legend.Background = Brushes.White;
barChart1.Legends.Add(legend);

VB.NET [image] Copy Code

Dim legend As New ChartLegend()
legend.Series = barChart1.Series
legend.BorderBrush = Brushes.LightGray
legend.Background = Brushes.White
barChart1.Legends.Add(legend)

1.2 SeriesLegend is designed to give details about data in a single ChartSeries. Its labels and brushes are set with LabelsSource and BrushesSource properties.

Here is a sample code that creates a SeriesLegend with two brushes and two labels:

C# [image] Copy Code

SeriesLegend legend1 = new SeriesLegend();
legend1.BrushesSource = new List<Brush>() {
new SolidColorBrush(Color.FromArgb(100, 0, 255, 0)),
Brushes.Yellow };
legend1.BorderBrush = Brushes.Silver;
legend1.Background = new SolidColorBrush(Color.FromRgb(240, 240, 240));
legend1.LabelsSource = new List<string>() { "Arina LLC", "Falderia Corp." };
lineChart1.Legends.Add(legend1);

VB.NET [image] Copy Code

Dim legend1 As New SeriesLegend()
legend1.BrushesSource = New List(Of Brush)() From { _
New SolidColorBrush(Color.FromArgb(100, 0, 255, 0)), _
Brushes.Yellow _
}
legend1.BorderBrush = Brushes.Silver
legend1.Background = New SolidColorBrush(Color.FromRgb(240, 240, 240))
legend1.LabelsSource = New List(Of String)() From { _
"Arina LLC", _
"Falderia Corp." _
}
lineChart1.Legends.Add(legend1)

2. Both types of legend descend from the Legend class and expose its style properties:

  • Orientation
  • HorizontalAlignment and VerticalAlignment
  • CornerRadius for rounding the edges of the legend's rectangle.

3. You can place the legend anywhere around the plot area where the chart is drawn. The docking of the legend is set with the Dock attached property of the LayoutPanel, which contains both the chart and the legend. The alignment of the legend depends on its position: if its docked to the bottom or the top of the plot area, the alignment is set with the HorizontalAlignment. If the legend is placed at the left or right side of the plot area, its alignment is set with VerticalAlignment.

Here is sample code that places a legend to the right of the plot area and aligns it in the middle:

C# [image] Copy Code

LayoutPanel.SetDock(legend, Dock.Right);
legend.VerticalAlignment = VerticalAlignment.Top;

VB.NET [image] Copy Code

LayoutPanel.SetDock(legend, Dock.Right)
legend.VerticalAlignment = VerticalAlignment.Top

Diagram of the Legend classes.


Zoom

Zoom

1. You can zoom any chart with axes (line, area, bar column etc). by setting the Behavior of the chart to Behavior.ZoomChart:

C# [image] Copy Code

lineChart1.Behavior = Behavior.ZoomChart;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.ZoomChart

2. If you want to go one step back in zooming out the chart, you must call ZoomOut():

C# [image] Copy Code

lineChart1.ZoomOut();

VB.NET [image] Copy Code

lineChart1.ZoomOut()

3. You can reset the chart to its original state, before zooming has begun, by calling ResetZoom():

C# [image] Copy Code

lineChart1.ResetZoom();

VB.NET [image] Copy Code

lineChart1.ResetZoom()

4. To stop the chart from responding with zooming to user actions, set its Behavior property to Behavior.DoNothing:

C# [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing

5. Zooming fires the ZoomChanged event. You can set the minimal interval for which zoom happens with MinZoomSpan.


Drag

Drag

MindFusion.Charting for WPF allows users to change data of a bar in a bar chart or the coordinates of a point in a line chart. This is done by setting the Behavior property to Behavior.AllowXDrag or Behavior.AllowYDrag. The Behavior enumeration allows bitwise combining of its members.

1. If you want to allow dragging the data point in any direction you should use:

C# [image] Copy Code

lineChart1.Behavior = Behavior.AllowXDrag | Behavior.AllowYDrag;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.AllowXDrag Or Behavior.AllowYDrag

In bar charts you should only allow dragging in the direction of the bar - for horizontal bars this is AllowXDrag, for vertical it is AllowYDrag.

2. If you want to stop the drag behavior you should set the property to DoNothing:

C# [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing

3. When the chart is dragged a thin red line appears to indicate the contour of the resulting graphic. If the graphic is dragged beyond values currently visible at the axes, the axes is rescaled automatically.


Hit testing

Hit testing

Hit testing is done with the HitTest method. You must give a point for which to test and the method will return a list of the ChartElement objects that contain this point. The ChartElement can be either Bar, Line or PieSlice. Each ChartElement has Index and SeriesIndex properties, which allow you to recognize the series that this chart element belongs to.

The location of the data that the ChartElement represents in the data list for the series can be get with the Bar.BarIndex, PieSlice.SliceIndex and Line.Points properties.

The following code tests which bar the user has clicked. It uses the MouseDown event:

C# [image] Copy Code

private void barChart1_MouseDown(object sender, MouseButtonEventArgs e)
{
List<ChartElement> result = barChart1.HitTest(e.GetPosition(barChart1));

if (result.Count > 0)
{
foreach (ChartElement element in result)
{
if (element is Bar)
{
Bar bar = element as Bar;
BarSeries series = barChart1.Series[bar.SeriesIndex] as BarSeries;
double yData = (double)series.YData[bar.BarIndex];
double xData = (double)series.XData[bar.BarIndex];
}
}
}
}

VB.NET [image] Copy Code

Private Sub barChart1_MouseDown(sender As Object, e As MouseButtonEventArgs)

Dim result As List(Of ChartElement) = barChart1.HitTest(e.GetPosition(barChart1))

If result.Count > 0 Then
For Each element As ChartElement In result
If TypeOf element Is Bar Then
Dim bar As Bar = TryCast(element, Bar)
Dim series As BarSeries = TryCast(barChart1.Series(bar.SeriesIndex), BarSeries)
Dim yData As Double = CDbl(series.YData(bar.BarIndex))
Dim xData As Double = CDbl(series.XData(bar.BarIndex))
End If
Next
End If

End Sub


Real Time Chart

Real Time Chart


General Template

General Template

The RealTimeChart template consists of a grid container, which lays out the various chart parts/ The grid consists initially of 3 rows and 3 columns. In the middle (row 1, column 1), we have the plot area, which is a FrameworkElement. The PlotArea draws the chart together with the X-axis.

PlotArea Declaration (XAML) [image] Copy Code

<local:PlotArea
x:Name="plotArea"
ClipToBounds="False"
Grid.Column="1" Grid.Row="1"
XAxis="{TemplateBinding XAxis}"
SeriesCollection="{TemplateBinding SeriesCollection}"
ScrollOffset="{TemplateBinding ScrollOffset}"
BitmapOffset="{TemplateBinding BitmapOffset}">
</local:PlotArea>

Y-axes and Y2-axes are rendered in an ItemsControl. There are two ItemsControl instances - one to the left and one to the right of the PlotArea element:

Y-axes Declaration (XAML) [image] Copy Code

<!-- left Y axes -->
<ItemsControl
Grid.Row="1" Grid.Column="0"
Style="{StaticResource YAxisControl}"
ItemsSource="{TemplateBinding YAxisCollection}" />

<!-- right Y axes -->
<ItemsControl
Grid.Row="1" Grid.Column="2"
Style="{StaticResource YAxisControl}"
ItemsSource="{TemplateBinding Y2AxisCollection}" />

The legend is an ItemsControl as well. It is bound to the SeriesCollection of the chart and is visible when ShowLegend is true. Initially it is placed at the bottom of the chart, in the middle (last grid row, middle grid column):

Legend Declaration (XAML) [image] Copy Code

<!-- legend template -->
<local:Legend
x:Name="legend"
ItemsSource="{TemplateBinding SeriesCollection}"
Grid.Row="2" Grid.Column="1"
Background="{TemplateBinding LegendBackground}"
BorderBrush="{TemplateBinding LegendBorderBrush}"
BorderThickness="1"
Width="{TemplateBinding LegendWidth}"
Height="{TemplateBinding LegendHeight}"
Orientation="{TemplateBinding LegendOrientation}"
HorizontalAlignment="{TemplateBinding LegendHorizontalAlignment}"
VerticalAlignment="{TemplateBinding LegendVerticalAlignment}"
Visibility="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=ShowLegend, Converter={StaticResource chartToLegendVisibilityConverter}}">
</local:Legend>

The title is a TextBlock located at the top:

Title Declaration (XAML) [image] Copy Code

<TextBlock
x:Name="title"
Grid.Row="0" Grid.Column="1"
Text="{TemplateBinding TitleText}"
HorizontalAlignment="{TemplateBinding TitleHorizontalAlignment}"
VerticalAlignment="{TemplateBinding TitleVerticalAlignment}"
FontFamily="{TemplateBinding TitleFontFamily}"
FontSize="{TemplateBinding TitleFontSize}" />

The Y-axis template

The Y and Y2 axes are rendered by custom ItemsControl, which uses custom AxisRenderer (derived from FrameworkElement). The axes are arranged in a horizontal StackPanel.

The Y-axis Control Template (XAML) [image] Copy Code

<Style x:Key="YAxisControl" TargetType="{x:Type ItemsControl}" xmlns:x="http://mindfusion.eu">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type ItemsControl}">
<ItemsPresenter />
</ControlTemplate>
</Setter.Value>
</Setter>
<Setter Property="ItemsPanel">
<Setter.Value>
<ItemsPanelTemplate>
<StackPanel Orientation="Horizontal"></StackPanel>
</ItemsPanelTemplate>
</Setter.Value>
</Setter>
<Setter Property="ItemTemplate">
<Setter.Value>
<DataTemplate DataType="{x:Type local:Axis}">
<local:AxisRenderer XAxis="{Binding Path=XAxis, ElementName=plotArea}" YAxis="{Binding}" xmlns:local="http://mindfusion.eu"></local:AxisRenderer>
</DataTemplate>
</Setter.Value>
</Setter>
</Style>

The Legend template

Each item is a StackPanel, which contains a Path Shape and a string. The StackPanel-s are arranged in a WrapPanel. The SeriesToGeometryConverter converts the ScatterType of each Series to a Path.Data object.

The Legend Control Template (XAML) [image] Copy Code
<Style TargetType="{x:Type local:Legend}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:Legend}">
<Border BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" CornerRadius="{TemplateBinding CornerRadius}" Padding="{TemplateBinding Padding}" Background="{TemplateBinding Background}" Margin="{TemplateBinding Margin}">
<ItemsPresenter />
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
<Setter Property="ItemsPanel">
<Setter.Value>
<ItemsPanelTemplate>
<WrapPanel Orientation="{Binding Orientation, RelativeSource={RelativeSource FindAncestor, AncestorType={x:Type local:Legend}}}" />
</ItemsPanelTemplate>
</Setter.Value>
</Setter>
<Setter Property="ItemTemplate">
<Setter.Value>
<DataTemplate DataType="{x:Type local:Series}">
<StackPanel Orientation="Horizontal" Margin="10, 0">
<Path Stroke="{Binding Stroke}" Fill="{Binding Fill}" Data="{Binding Converter={StaticResource seriesToGeometryConverter}}"></Path>
<TextBlock Margin="5,0,0,0" FontFamily="{Binding TitleFontFamily}" FontSize="{Binding TitleFontSize}" Text="{Binding Title}" />
</StackPanel>
</DataTemplate>
</Setter.Value>
</Setter>
</Style>

Here is the entire RealTimeChart template:

RealTimeChart (XAML) [image] Copy Code

<ResourceDictionary
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:local="clr-namespace:MindFusion.RealTimeCharting.Wpf">

<local:ChartToLegendVisibilityConverter x:Key="chartToLegendVisibilityConverter"/>
<local:SeriesToGeometryConverter x:Key="seriesToGeometryConverter"/>
<local:DoubleToGridLengthConverter x:Key="doubleToGridLengthConverter"/>
<local:DoubleToThicknessConverter x:Key="doubleToThicknessConverter"/>
<local:PointToThicknessConverter x:Key="pointToThicknessConverter"/>
<local:PointToStringConverter x:Key="pointToStringConverter"/>

<Style x:Key="YAxisControl" TargetType="{x:Type ItemsControl}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type ItemsControl}">
<ItemsPresenter />
</ControlTemplate>
</Setter.Value>
</Setter>

<Setter Property="ItemsPanel">
<Setter.Value>
<ItemsPanelTemplate>
<StackPanel Orientation="Horizontal"></StackPanel>
</ItemsPanelTemplate>
</Setter.Value>
</Setter>

<Setter Property="ItemTemplate">
<Setter.Value>
<DataTemplate DataType="{x:Type local:Axis}">
<local:AxisRenderer XAxis="{Binding Path=XAxis, ElementName=plotArea}" YAxis="{Binding}"></local:AxisRenderer>
</DataTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="{x:Type local:RealTimeChart}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:RealTimeChart}">
<Border Background="{TemplateBinding Background}"
BorderBrush="{TemplateBinding BorderBrush}"
BorderThickness="{TemplateBinding BorderThickness}">
<Grid>
<!-- add border columns and rows for spacing, bound to margins -->
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" MinWidth="{TemplateBinding FrameLeftThickness}" />
<ColumnDefinition Width="*"></ColumnDefinition>
<ColumnDefinition Width="Auto" MinWidth="{TemplateBinding FrameRightThickness}"></ColumnDefinition>
</Grid.ColumnDefinitions>
<Grid.RowDefinitions>
<RowDefinition Height="{TemplateBinding FrameTopThickness, Converter={StaticResource doubleToGridLengthConverter}}"></RowDefinition>
<RowDefinition Height="*"></RowDefinition>
<RowDefinition Height="{TemplateBinding FrameBottomThickness, Converter={StaticResource doubleToGridLengthConverter}}"></RowDefinition>
</Grid.RowDefinitions>

<!-- legend template -->
<local:Legend
x:Name="legend"
ItemsSource="{TemplateBinding SeriesCollection}"
Grid.Row="2" Grid.Column="1"
Background="{TemplateBinding LegendBackground}"
BorderBrush="{TemplateBinding LegendBorderBrush}"
BorderThickness="1"
Width="{TemplateBinding LegendWidth}"
Height="{TemplateBinding LegendHeight}"
Orientation="{TemplateBinding LegendOrientation}"
HorizontalAlignment="{TemplateBinding LegendHorizontalAlignment}"
VerticalAlignment="{TemplateBinding LegendVerticalAlignment}"
Visibility="{Binding RelativeSource={RelativeSource TemplatedParent}, Path=ShowLegend, Converter={StaticResource chartToLegendVisibilityConverter}}">
</local:Legend>

<!-- title template -->
<TextBlock
x:Name="title"
Grid.Row="0" Grid.Column="1"
Text="{TemplateBinding TitleText}"
HorizontalAlignment="{TemplateBinding TitleHorizontalAlignment}"
VerticalAlignment="{TemplateBinding TitleVerticalAlignment}"
FontFamily="{TemplateBinding TitleFontFamily}"
FontSize="{TemplateBinding TitleFontSize}" />

<!-- left Y axes -->
<ItemsControl
Grid.Row="1" Grid.Column="0"
Style="{StaticResource YAxisControl}"
ItemsSource="{TemplateBinding YAxisCollection}" />

<!-- right Y axes -->
<ItemsControl
Grid.Row="1" Grid.Column="2"
Style="{StaticResource YAxisControl}"
ItemsSource="{TemplateBinding Y2AxisCollection}" />

<!-- plot area template -->
<local:PlotArea
x:Name="plotArea"
ClipToBounds="False"
Grid.Column="1" Grid.Row="1"
XAxis="{TemplateBinding XAxis}"
SeriesCollection="{TemplateBinding SeriesCollection}"
ScrollOffset="{TemplateBinding ScrollOffset}"
BitmapOffset="{TemplateBinding BitmapOffset}">
</local:PlotArea>

<!-- tooltip template -->
<StackPanel
x:Name="toolTipPanel"
ClipToBounds="False"
Grid.Column="1" Grid.Row="1"
Orientation="Vertical"
Visibility="{Binding ElementName=plotArea, Path=ToolTipVisibility}"
Margin="{Binding ElementName=plotArea, Path=MousePosition, Converter={StaticResource pointToThicknessConverter}}">
<Canvas>
<TextBlock
x:Name="tb"
Background="{Binding ElementName=plotArea, Path=TooltipBackground}"
Foreground="{Binding ElementName=plotArea, Path=TooltipStroke}"
ClipToBounds="False"
Margin="15,0,0,0"
Text="{Binding ElementName=plotArea, Path=DataPoint, Converter={StaticResource pointToStringConverter}, ConverterParameter='X'}" />
<TextBlock
Background="{Binding ElementName=plotArea, Path=TooltipBackground}"
Foreground="{Binding ElementName=plotArea, Path=TooltipStroke}"
ClipToBounds="False"
Margin="{Binding ElementName=tb, Path=ActualHeight, Converter={StaticResource doubleToThicknessConverter}}"
Text="{Binding ElementName=plotArea, Path=DataPoint, Converter={StaticResource pointToStringConverter}, ConverterParameter='Y'}" />
</Canvas>
</StackPanel>

</Grid>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="{x:Type local:Legend}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:Legend}">
<Border BorderBrush="{TemplateBinding BorderBrush}"
BorderThickness="{TemplateBinding BorderThickness}"
CornerRadius="{TemplateBinding CornerRadius}"
Padding="{TemplateBinding Padding}"
Background="{TemplateBinding Background}"
Margin="{TemplateBinding Margin}">
<ItemsPresenter />
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>

<Setter Property="ItemsPanel">
<Setter.Value>
<ItemsPanelTemplate>
<WrapPanel Orientation="{Binding Orientation, RelativeSource={RelativeSource FindAncestor, AncestorType={x:Type local:Legend}}}"/>
</ItemsPanelTemplate>
</Setter.Value>
</Setter>

<Setter Property="ItemTemplate">
<Setter.Value>
<DataTemplate DataType="{x:Type local:Series}">
<StackPanel Orientation="Horizontal" Margin="10, 0">
<Path Stroke="{Binding Stroke}" Fill="{Binding Fill}" Data="{Binding Converter={StaticResource seriesToGeometryConverter}}">
</Path>
<TextBlock Margin="5,0,0,0" FontFamily="{Binding TitleFontFamily}" FontSize="{Binding TitleFontSize}" Text="{Binding Title}"/>
</StackPanel>
</DataTemplate>
</Setter.Value>
</Setter>
</Style>
</ResourceDictionary>


Series

Series

RealTimeChart supports unlimited number of series. Each series is an instance of the Series class and must be added to the RealTimeChart.SeriesCollection. It exposes a variety of properties, the most important one is Data. The data for each series is a list of Point objects.

Series can be drawn as scatters or as a line with scatters. The ScatterType property lets you choose among several scatter shapes. Use ScatterStroke to specify the brush for the scatters.

Each Series can have a Title, with customizable TitleFontFamily and TitleFontSize. Those properties are used by the legend to render a label for this Series.


Axes

Axes

The chart can have one X-axis and multiple Y and Y2 axes. The X-axis is defined as a property of the RealTimeChart class. Each axis is an instance of the Axis class and exposes the same set of properties.

You can define the axes with its Origin, Interval and Length. The Origin specifies the first number at the axis. The Length - the difference between the first and the last number and interval - the difference between each two adjacent numbers.

Labels might not start exactly at the first number, that's why you have LabelOrigin. You can format the labels using the LabelFormat, LabelFontFamily and LabelFontSize properties. Labels at the X-axis can be pinned - in this case they do not change position when the chart runs in "Fast Scroll" mode. You can draw them with offset and ticks - just set the LabelOffset and TickLength properties.

Y-axes can be located either to the left or to the right of the plot area. This means you need to llign the labels either to the left or to the right of the axis - use LabelHorizontalAlignment to do this. The X-axis can be drawn at the top as well at the bottom of the chart - the VerticalAlignment property regulates this.


Legend

Legend

The Legend is rendered by a custom ItemsControl. By default it is placed to the bottom of the chart and aligned to the middle. If you want to change the position and/or the alignment of the legend control, you'll have to overwrite the default char template - check the "General Template" section to see how.

Some of the legend settings are accessible through properties - LegendWidth and LegendHeight let you customize the size of the legend, LegendOrientation lets you choose how the labels are drawn. Together those properties allow you to customize the layout of your legend.

The legend labels are retrieved automatically from the Series.Title property. If the Series is drawn with scatters, a matching symbol is drawn in the legend.


Tooltip

Tooltip

The TooltipVisibility property must be set to Visibility.Visible if you want to show the tooltip. The tooltip displays the X and Y value of the current mouse location. Since the Y-value depends on theY-axis and multiple Y-axes are possible, you have the FallbackTooltipAxis property to specify exactly which Y-axis the tooltip is bound to.

The tooltip has cuztomizable background - use FallbackTooltipBackground to set the Brush.


MindFusion.DataViews for WPF Overview

MindFusion.DataViews for WPF Overview


Project

Project

MVVM Pattern

MindFusion.DataViews for WPF incorporates the MVVM pattern. The Model is represented by the user's business model, the View is either the ActivityChart or the ResourceChart and the ViewModel is represented by a set of interfaces abstracting the Model from the View. The ViewModel helps accommodate different custom models to the views and provides several features, such as undo and redo. The ViewModel automatically propagates all changes back to the Model. The general rule of thumb is, that once the ViewModel is established, all changes to the project should be performed through it and not directly through the Model.

The principal interface in the ViewModel is the IProjectViewModel - this is a container of all the objects in the ViewModel, such as activities, dependencies and resources. It provides methods for creating, deleting and managing various objects.

Creating the ViewModel

To create the ViewModel, call the CreateViewModel method of the BaseChart class. This call automatically associates the newly created IProjectViewModel with the BaseChart control through its DataContext property. The CreateViewModel method accepts several IEnumerable arguments, which identify the objects in the Model. In addition, the method accepts several Type object which identify the runtime types of the respective objects in the Model. The later are used by the ViewModel during object creation when it needs to create the corresponding elements in the Model. Not all of the arguments are required. For example the following call is valid and will create a project over a set of activities:

C# [image] Copy Code

var project = chart.CreateViewModel(activities, null, null, null, typeof(Activity), null, null, null);

Visual Basic [image] Copy Code

Dim project = chart.CreateViewModel(activities, Nothing, Nothing, Nothing, GetType(Activity), Nothing, Nothing, Nothing)

During the creation of the ViewModel several properties are automatically used in order to resolve various properties in the Model and establish a relationship between them and the corresponding properties in the ViewModel. The following table lists these properties grouped by the model object they are related to:

Related Model Object | Property
Activity | ActivityChildrenExpression ActivityNameExpression ActivityStartTimeExpression ActivityEndTimeExpression ActivityProgressExpression
Resource Allocation | AllocationActivityExpression AllocationStartTimeExpression AllocationEndTimeExpression AllocationProgressExpression AllocationResourceExpression
Resource | ResourceTitleExpression ResourceDescriptionExpression

Other ViewModel Objects

There are interfaces in the ViewModel object model, which correspond to the different project elements - activities, dependencies and resources, respectively IActivityViewModel, IDependencyViewModel and IResourceViewModel. Those objects are automatically created from the Model when the IProjectViewModel is initially created and can be accessed from the corresponding properties - Activities, Dependencies, Resources.

For additional information about the individual ViewModel objects, check the dedicated topics - Activities, Dependencies and Resources.


Activities (Tasks)

Activities (Tasks)

Activities are represented in the object model by the IActivityViewModel interface. The root activities in the project hierarchy can be obtained from the Activities property of the IProjectViewModel. The subactivities of an activity can be accessed through its Subactivities property.

Creating New Activities

New activities can be created by calling the CreateActivity method. The first argument specifies the parent activity, the second argument specifies the 0-based position in the parent's children list where the new activity should be added. To create a root activity, pass null (Nothing in Visual Basic) as the first argument. Creating a new activity through the ViewModel is automatically reflected back to the Model if the Model implements the IList interface. The type of the newly created Model activity is specified by the ActivityType property of the project.

The following sample code creates and initializes a new activity in an existing project:

C# [image] Copy Code

var activity = project.CreateActivity(null, -1);
activity.ActivityName = "New activity";
var subactivity = project.CreateActivity(activity, -1);
subactivity.ActivityName = "New child activity";

Visual Basic [image] Copy Code

Dim activity = project.CreateActivity(Nothing, -1)
activity.ActivityName = "New activity"
Dim subactivity = project.CreateActivity(activity, -1)
subactivity.ActivityName = "New child activity"

Deleting Activities

Activities are deleted through the RemoveActivity method. Activity deletion is automatically reflected back to the Model if the Model implements the IList interface.

Modifying Activities

Activities can be modified through the properties exposed by the IActivityViewModel interface. All modifications to the activities are automatically reflected back to the Model through the binding expressions used to establish the mapping between the ViewModel and Model properties. For additional information about those binding expressions, check the Project topic.

Undo and Redo

All of the above operations are undoable. Check Undo and Redo for additional information.


Dependencies

Dependencies

The dependencies represent relationships between the activities in the project. Dependencies are represented in the object model by the IDependencyViewModel interface. The dependencies in the project can be obtained from the Dependencies property of the IProjectViewModel.

Creating New Dependencies

New dependencies can be created by calling the CreateDependency method. This method takes as argument the source and target activities of the dependency being created. These parameters cannot be null (Nothing in Visual Basic). Creating a new dependency through the ViewModel is automatically reflected back to the Model if the Model implements the IList interface. The type of the newly created Model dependency is specified by the DependencyType property of the project.

The following sample code creates and initializes a new dependency in an existing project:

C# [image] Copy Code

var dependency = project.CreateDependency(sourceActivity, targetActivity);
dependency.DependencyType = DependencyType.FinishToFinish;

Visual Basic [image] Copy Code

Dim dependency = project.CreateDependency(sourceActivity, targetActivity)
dependency.DependencyType = DependencyType.FinishToFinish

Deleting Dependencies

Dependencies are deleted through the RemoveDependency method. Dependency deletion is automatically reflected back to the Model if the Model implements the IList interface.

Modifying Dependencies

Dependencies can be modified through the properties exposed by the IDependencyViewModel interface.

Undo and Redo

All of the above operations are undoable. Check Undo and Redo for additional information.


Resources

Resources

Resources are represented in the object model by the IResourceViewModel interface. The resources in the project can be obtained from the Resources property of the IProjectViewModel.

Creating New Resources

New resources can be created by calling the CreateResource method. This does not take arguments. Creating a new resource through the ViewModel is automatically reflected back to the Model if the Model implements the IList interface. The type of the newly created Model resource is specified by the ResourceType property of the project.

The following sample code creates and initializes a new resource in an existing project:

C# [image] Copy Code

var resource = project.CreateResource();
resource.Title = "New resource";

Visual Basic [image] Copy Code

Dim resource = project.CreateResource()
resource.Title = "New resource"

Deleting Resources

Resources are deleted through the RemoveResource method. Resource deletion is automatically reflected back to the Model if the Model implements the IList interface.

Allocating Resources

Resources are allocated for activities in the project using a special mediator object - IResourceAllocationViewModel. To create new allocation object, call the CreateResourceAllocation method of the project. This method accepts two arguments identifying the resource and the related activity. Both arguments need to be specified.

The following example creates a new allocation of the resource created above for a specified activity:

C# [image] Copy Code

project.CreateResourceAllocation(resource, targetActivity);

Visual Basic [image] Copy Code

project.CreateResourceAllocation(resource, targetActivity)

To delete a resource allocation, call the RemoveResourceAllocation method.

To get the activities a resource is allocated for, use the Allocations property. Each allocation in this list exposes its related activity through the Activity property.

Undo and Redo

All of the above operations are undoable. Check Undo and Redo for additional information.


Undo and Redo

Undo and Redo

To enable undo and redo set the UndoEnabled property of the IProjectViewModel to true. All subsequent modifications to the project, including creation and deletion of items will be recorded in an undo history for later undo. To undo the most recent modification, call the Undo method; to redo the last undone modification, call the Redo method. To purge the undo history, either set UndoEnabled to false, or call PurgeUndoHistory method. The undo and redo function are also available as ICommand objects through the UndoCommand and RedoCommand properties.

Note

Modifying the underlying Model will automatically reset the undo history. Therefore it is recommended that all changes to the project are performed through the ViewModel.

Composite Operations

It is possible to wrap up several modifications to the project in an atomic undo operation. To achieve this, nest all of the modification in a StartCompositeOperation/CommitCompositeOperation block. To reject all modifications in a composite block, call CancelCompositeOperation instead.

The following example creates several activities in a project and wraps them as a composite operation:

C# [image] Copy Code

project.StartCompositeOperation();
project.CreateActivity(null, -1).ActivityName = "test 1";
project.CreateActivity(null, -1).ActivityName = "test 2";
project.CreateActivity(null, -1).ActivityName = "test 5";
project.CommitCompositeOperation();

Visual Basic [image] Copy Code

project.StartCompositeOperation()
project.CreateActivity(Nothing, -1).ActivityName = "test 1"
project.CreateActivity(Nothing, -1).ActivityName = "test 2"
project.CreateActivity(Nothing, -1).ActivityName = "test 5"
project.CommitCompositeOperation()

Binding Undo/Redo Commands

Because the undo/redo operations of the project are exposed as commands (through the UndoCommand and RedoCommand properties), they can be easily bound to from various UI elements. For example, in order to bind a button in the UI to the Undo command of the project, use the following XAML code:

XAML [image] Copy Code

<Button Content="Undo">
<Button.Command>
<Binding Path="DataContext.UndoCommand" ElementName="activityView" />
</Button.Command>
</Button>

The above code assumes that activityView identifies an ActivityChart control defined within the XAML.


Views

Views

The MindFusion.DataViews for WPF currently provides two views to display projects - ActivityChart and ResourceChart. For more information about those, check the corresponding subtopics - Activity Chart and Resource Chart. For more information about the user interactions with those controls, visit User Interaction.

UI Virtualization

Both views employ UI virtualization. This enables the views to display large sets of data without noticeably affecting performance. UI virtualization is enabled by default and can be disabled by using a custom ItemsPanel.


Activity Chart

Activity Chart

The ActivityChart displays the activities (tasks) in a project and the dependencies between them. The control is split in two major parts - data grid to the left and schedule subview to the right. Both of them display the same items only in different ways. The grid to the left display the item properties. The view to the right displays the items as a chart. Each activity is displayed in its own row. The dependencies between activities are illustrated as links connecting the source and target activities. Milestone activities have special presentation in the chart. The items in the ActivityChart can be modified either interactively by dragging them around in the schedule view to the right or by adjusting their properties in the data grid to the left. For more information about item interactions check the User Interaction topic.

A simple ActivityChart is illustrated below:

To associated data with the ActivityChart, use the CreateViewModel method. For more information regarding this, check the Project topic.


Resource Chart

Resource Chart

The ResourceChart displays the resources in a project and their allocation amongst different activities (tasks). The control is split in two major parts - data grid to the left and schedule subview to the right. Both of them display the same items only in different ways. The grid to the left display the resource properties. The view to the right displays the allocations of the resource. Each resource is displayed in its own row and may have more than one allocation. If a resource is allocated to different activities during the same period of time, the allocations are said to collide and they are displayed one on top of the other. The allocations in the ResourceChart can be modified interactively by dragging them around in the schedule view. The resources can be modified by adjusting their properties in the data grid to the left. For more information about item interactions check the User Interaction topic.

A simple ResourceChart is illustrated below:

To associated data with the ResourceChart, use the CreateViewModel method. For more information regarding this, check the Project topic.


User Interaction

User Interaction

Item Modification

Items in ActivityChart and ResourceChart can be modified interactively by the user. This can be done either through the mouse or the keyboard. Four major operations are supported - moving the item, resizing its start or end, and adjusting the item's progress. To move an item click within the item's presenter and drag. To resize the item click near the left or right edge of the item's presented and drag. In ActivityChart make sure the mouse is not positioned over one of the item anchors or instead of resizing the item, new dependency creation will be initiated. To modify the item progress click at the right side of the progress bar and drag. An alternative way to modify an item is by activating the item and using the keyboard arrow keys to move or resize the item.

Events

When an item is modified interactively certain events are raised depending on the view. In ActivityChart the events are ActivityModifying, ActivityModified and ActivityClicked. In ResourceChart the events are AllocationModifying, AllocationModified and AllocationClicked.

Snapping

Snapping is the process of adjusting the modified item property to a round value. For example when an item is moved, it can be automatically aligned (snapped) to the nearest day or hour, depending on the resolution of the view.

Snapping can be enabled through the IsSnappingEnabled property. The number of snapping points can be specified through the SnappingPointCount property. For example, if this property is set to 4, and the current view resolution is 1 day, snapping will occur at 0h, 8h, 16h and 24h of each day.

Cursors

Various interaction cursors can be customized through the ItemLeftResizeCursor, ItemRightResizeCursor and ItemProgressResizeCursor of the BaseChart class.

Dependency Creation

Dependencies can be created interactively in the ActivityChart by pointing to the source activity then clicking on one of the two anchors at its start or end (depending on the type of dependency that needs to be created) and dragging with the mouse to the target activity. The type of the newly created dependency depends on the source anchor and the drop location. An alternative to create dependency interactively is to click on an activity and drag vertically.

Events

When a dependency is created interactively, the DependencyCreated event is raised.

Cursors

Various interaction cursors can be customized through the DependencyAnchorCursor and DependencyConnectionCursor of the ActivityChart class.

Miscellaneous

Undo/Redo

Interactive modifications are subject to undo/redo if UndoEnabled is set to true. For more information about this, check Undo and Redo.

Popups

During interactive modification of items, popups are displayed if the ShowPopups property is set to true. For information how to customize these popups, check Popups.

Drill In/Drill Out

ActivityChart and ResourceChart can show different time resolution for the items in their ScheduleGrid - ActivityPresenter and AllocationPresenter respectively. Interactive drilling in/out is done by holding CTRL key and either using the mouse scroll wheel or holding down the mouse left button on the TimelineHeader and moving along the Y-axis. An alternative is to double click a DateTime cell in the TimelineHeader to increase the resolution, effectively zooming in.


Customizing Appearance

Customizing Appearance

The topics in this chapter discuss the techniques available for the customization of the appearance of various elements in the ActivityChart and ResourceChart control.


Customizing the Appearance of Items

Customizing the Appearance of Items

Items in the ActivityChart and ResourceChart controls can be customized through various properties exposed by the base BaseChart class. The ItemBackground, ItemBorderBrush, ItemMouseOverBackground and ItemMouseOverBorderBrush can be used to customize the background and border of the items in normal and hovered state respectively. The ItemAccentBrush and ItemFocusBrush properties can be used to specify the appearance of specific item parts, such as the end and start brackets and the focus frame. Various item-related cursors can be specified through the ItemLeftResizeCursor, ItemRightResizeCursor and ItemProgressResizeCursor properties.

Activities and allocations can be customized individually by handling the ActivityPresenterCreated and AllocationPresenterCreated events of the ActivityChart and ResourceChart classes respectively. The event argument provides a reference to the ActivityPresenter or AllocationPresenter object, which is used to present the item. The presenter provides properties similar to the one specified above - Background, BorderBrush, AccentBrush, FocusBrush, MouseOverBackground, MouseOverBorderBrush, CornerRadius, and so on. In addition, the ActivityPresenter exposes several properties which can be used to customize the appearance of the resource names - ResourcesLabelFontStyle, ResourcesLabelFontWeight, ResourcesLabelFontSize, ResourcesLabelFontStretch, ResourcesLabelForeground, ResourcesLabelOffsetX and ResourcesLabelOffsetY.


Customizing the Appearance of Dependencies

Customizing the Appearance of Dependencies

Dependencies can be customized through various properties exposed by the ActivityChart. The fill and stroke of the dependencies can be specified through the DependenciesFill, DependenciesStroke and DependenciesStrokeThickness properties. The bends of the dependency can be rounded by specifying a value greater than 0 for the DependenciesCornerRadius property. The size of the dependencies' arrow head can be customized through the DependenciesArrowSize property. Various cursors related to dependency interactions can be specified through the DependencyAnchorCursor and DependencyConnectionCursor properties.

Dependencies can be customized individually by handling the DependencyPresenterCreated event. The event argument provides a reference to the DependencyPresenter object, which is used to present the dependency. The DependencyPresenter provides properties similar to the one specified above - ArrowSize, CornerRadius, StrokeThickness and also utilizes the properties derived from Control - BorderBrush and Background.


Default Styles and Templates

Default Styles and Templates

This topic shows the default styles of the ActivityPresenter, AllocationPresenter and DependencyPresenter classes. The styles reference various theme-specific brushes defined as static resources. Those brushes are not listed here for clarity.

ActivityPresenter

XAML [image] Copy Code

<!-- ActivityPresenter style -->
<Style TargetType="local:ActivityPresenter">

<Setter Property="ResourcesLabelFontWeight" Value="Bold"/>
<Setter Property="ResourcesLabelForeground" Value="{StaticResource ActivityResourceTextBrush}" />
<Setter Property="FocusVisualStyle" Value="{x:Null}" />
<Setter Property="SnapsToDevicePixels" Value="False" />
<Setter Property="Height" Value="16"/>
<Setter Property="ProgressBackground" Value="{StaticResource ProgressBackgroundBrush}"/>

<Setter Property="Template">
<Setter.Value>

<ControlTemplate TargetType="local:ActivityPresenter">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="5" />
<ColumnDefinition />
<ColumnDefinition Width="5" />
</Grid.ColumnDefinitions>

<!-- Start resize handle -->
<Thumb Width="5" Grid.Column="0" HorizontalAlignment="Left" Name="StartResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding LeftResizeCursor}" />

<!-- End resize handle -->
<Thumb Width="5" Grid.Column="2" HorizontalAlignment="Right" Name="EndResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding RightResizeCursor}" />

<!-- Start dependency anchor -->
<Thumb x:Name="LeftAnchor" Grid.Column="0" Grid.ColumnSpan="3" Width="5" Height="8" Style="{StaticResource LeftAnchor}" Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="1,1,0,1" Visibility="Visible" Opacity="0" IsHitTestVisible="False" HorizontalAlignment="Left" VerticalAlignment="Center" Cursor="{TemplateBinding DependencyAnchorCursor}" />

<!-- Finish dependency anchor-->
<Thumb x:Name="RightAnchor" Grid.Column="0" Grid.ColumnSpan="3" Width="5" Height="8" Style="{StaticResource RightAnchor}" Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="0,1,1,1" Visibility="Visible" Opacity="0" IsHitTestVisible="False" HorizontalAlignment="Right" VerticalAlignment="Center" Cursor="{TemplateBinding DependencyAnchorCursor}" />

<!-- Non-milestone presentation root (border) -->
<Border Name="Root" Grid.Column="1" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="1" Background="{TemplateBinding Background}">
<Rectangle Name="Focus" RadiusX="0" RadiusY="0" Stroke="{TemplateBinding FocusBrush}" StrokeThickness="1" Opacity="0" />
</Border>

<!-- Milestone presentation root (path) -->
<Path Name="MilestoneRoot" Grid.Column="1" Data="M0,0.5 L0.5,1 L1,0.5 L0.5,0 z" Stretch="Uniform" Stroke="{TemplateBinding BorderBrush}" StrokeThickness="1" Visibility="Collapsed" Fill="{TemplateBinding Background}">
</Path>
<Path Name="MilestoneFocus" Grid.Column="1" Data="M0,0.5 L0.5,1 L1,0.5 L0.5,0 z" Stretch="Uniform" Stroke="{TemplateBinding FocusBrush}" StrokeThickness="1" Visibility="Collapsed" Opacity="0" Margin="2" />

<!-- AutoActivity presentation root (grid) -->
<Grid Name="AutoActivityRoot" Grid.Column="1" Visibility="Collapsed" Margin="-7,0">
<Grid.ColumnDefinitions>
<ColumnDefinition Width="5" />
<ColumnDefinition />
<ColumnDefinition Width="5" />
</Grid.ColumnDefinitions>

<Border Name="AutoActivityBorder" Grid.Column="1" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}}" BorderBrush="{TemplateBinding AccentBrush}" BorderThickness="1" Background="{TemplateBinding Background}" Margin="8,2,8,8">
</Border>
<Path Name="AutoActivityLeftPart" Margin="0,0,-9,0" Grid.Column="0" Data="M0,0 L1,0 L1,0.5 L0.5,1 L0,0.5 Z" Stretch="Uniform" Stroke="{TemplateBinding AccentBrush}" StrokeThickness="1" Fill="{TemplateBinding Background}">
</Path>
<Path Name="AutoActivityRightPart" Margin="-9,0,0,0" Grid.Column="2" Data="M0,0 L1,0 L1,0.5 L0.5,1 L0,0.5 Z" Stretch="Uniform" Stroke="{TemplateBinding AccentBrush}" StrokeThickness="1" Fill="{TemplateBinding Background}">
</Path>
</Grid>

<!-- Move handle -->
<Thumb Name="Mover" Grid.Column="1" Style="{StaticResource InvisibleThumb}" />

<!-- Progress presentation -->
<Border Name="ProgressContainer" Grid.Column="1" Margin="1" Height="5" VerticalAlignment="Center" HorizontalAlignment="Stretch">
<Border Name="Progress" Width="{TemplateBinding ProgressLength}" HorizontalAlignment="Left">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="5" />
</Grid.ColumnDefinitions>
<Border Grid.ColumnSpan="2" Background="{TemplateBinding ProgressBackground}" IsHitTestVisible="False" />
<Thumb Grid.Column="1" Name="ProgressResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding ProgressResizeCursor}" />
</Grid>
</Border>
</Border>

<Border x:Name="LeftSide" Grid.Column="0" Margin="5,0,-5,0" IsHitTestVisible="False" BorderThickness="2,2,0,2" BorderBrush="{TemplateBinding AccentBrush}" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}, ConverterParameter=Left}" />
<Border x:Name="RightSide" Grid.Column="2" Margin="-5,0,5,0" IsHitTestVisible="False" BorderThickness="0,2,2,2" BorderBrush="{TemplateBinding AccentBrush}" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}, ConverterParameter=Right}" />

</Grid>

<ControlTemplate.Triggers>

<Trigger Property="IsMouseOver" Value="True">
<Setter TargetName="Root" Property="Background" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="Root" Property="BorderBrush" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="MilestoneRoot" Property="Fill" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="MilestoneRoot" Property="Stroke" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="LeftAnchor" Property="IsHitTestVisible" Value="True" />
<Setter TargetName="RightAnchor" Property="IsHitTestVisible" Value="True" />
<Setter TargetName="AutoActivityBorder" Property="BorderBrush" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="AutoActivityBorder" Property="Background" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="AutoActivityLeftPart" Property="Stroke" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="AutoActivityLeftPart" Property="Fill" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="AutoActivityRightPart" Property="Stroke" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="AutoActivityRightPart" Property="Fill" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
</Trigger>

<Trigger Property="IsKeyboardFocusWithin" Value="True">
<Setter TargetName="Focus" Property="Opacity" Value="1" />
<Setter TargetName="MilestoneFocus" Property="Opacity" Value="1" />
</Trigger>

<Trigger Property="EnableDependencies" Value="False">
<Setter TargetName="LeftAnchor" Property="Visibility" Value="Collapsed"/>
<Setter TargetName="RightAnchor" Property="Visibility" Value="Collapsed"/>
</Trigger>

<EventTrigger RoutedEvent="UIElement.MouseEnter">
<BeginStoryboard>
<Storyboard>
<DoubleAnimation Storyboard.TargetName="LeftAnchor" Storyboard.TargetProperty="(UIElement.Opacity)" Duration="0:0:0.2" To="1" />
<DoubleAnimation Storyboard.TargetName="RightAnchor" Storyboard.TargetProperty="(UIElement.Opacity)" Duration="0:0:0.2" To="1" />
</Storyboard>
</BeginStoryboard>
</EventTrigger>

<EventTrigger RoutedEvent="UIElement.MouseLeave">
<BeginStoryboard>
<Storyboard>
<DoubleAnimation Storyboard.TargetName="LeftAnchor" Storyboard.TargetProperty="(UIElement.Opacity)" Duration="0:0:0.2" To="0" />
<DoubleAnimation Storyboard.TargetName="RightAnchor" Storyboard.TargetProperty="(UIElement.Opacity)" Duration="0:0:0.2" To="0" />
</Storyboard>
</BeginStoryboard>
</EventTrigger>

<Trigger Property="IsMouseOver" SourceName="LeftAnchor" Value="True">
<Setter TargetName="LeftAnchor" Property="Background" Value="Red" />
</Trigger>

<Trigger Property="IsMouseOver" SourceName="RightAnchor" Value="True">
<Setter TargetName="RightAnchor" Property="Background" Value="Red" />
</Trigger>

<Trigger Property="IsMilestone" Value="True">
<Setter TargetName="Root" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="MilestoneRoot" Property="Visibility" Value="Visible" />
<Setter TargetName="MilestoneFocus" Property="Visibility" Value="Visible" />
<Setter TargetName="LeftAnchor" Property="Width" Value="10" />
<Setter TargetName="RightAnchor" Property="Width" Value="10" />
<Setter TargetName="LeftSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="AutoActivityRightPart" Property="Margin" Value="-11,1,1,1" />
</Trigger>

<Trigger Property="ScheduleMode" Value="Auto">
<Setter TargetName="Root" Property="Visibility" Value="Collapsed" />
<Setter TargetName="StartResizer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="EndResizer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="LeftAnchor" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightAnchor" Property="Visibility" Value="Collapsed" />
<Setter TargetName="Mover" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Margin" Value="7,4,7,0" />
<Setter TargetName="ProgressContainer" Property="Height" Value="2" />
<Setter TargetName="ProgressContainer" Property="VerticalAlignment" Value="Top" />
<Setter TargetName="ProgressContainer" Property="IsHitTestVisible" Value="False" />
<Setter TargetName="MilestoneRoot" Property="Visibility" Value="Collapsed" />
<Setter TargetName="MilestoneFocus" Property="Visibility" Value="Collapsed" />
<Setter TargetName="LeftSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="AutoActivityRoot" Property="Visibility" Value="Visible" />
<Setter Property="IsTabStop" Value="False" />
</Trigger>

<MultiTrigger>
<MultiTrigger.Conditions>
<Condition Property="ScheduleMode" Value="SemiAuto" />
<Condition Property="IsMilestone" Value="False"/>
</MultiTrigger.Conditions>
<Setter TargetName="Root" Property="Margin" Value="0,3" />
<Setter TargetName="Root" Property="CornerRadius" Value="3" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Height" Value="2" />
<Setter TargetName="LeftSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="LeftAnchor" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightAnchor" Property="Visibility" Value="Collapsed" />
</MultiTrigger>

<MultiTrigger>
<MultiTrigger.Conditions>
<Condition Property="ScheduleMode" Value="SemiAuto" />
<Condition Property="IsMilestone" Value="True"/>
</MultiTrigger.Conditions>
<Setter TargetName="LeftSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightSide" Property="Visibility" Value="Collapsed" />
<Setter TargetName="LeftAnchor" Property="Visibility" Value="Collapsed" />
<Setter TargetName="RightAnchor" Property="Visibility" Value="Collapsed" />
</MultiTrigger>

</ControlTemplate.Triggers>

</ControlTemplate>

</Setter.Value>
</Setter>

</Style>

AllocationPresenter

XAML [image] Copy Code

<Style TargetType="local:AllocationPresenter">

<Setter Property="FocusVisualStyle" Value="{x:Null}" />
<Setter Property="SnapsToDevicePixels" Value="False" />
<Setter Property="Height" Value="16"/>
<Setter Property="ProgressBackground" Value="{StaticResource ProgressBackgroundBrush}"/>

<Setter Property="Template">
<Setter.Value>

<ControlTemplate TargetType="local:AllocationPresenter">

<Grid ToolTip="{Binding Path=Allocation.ActivityName, RelativeSource={RelativeSource TemplatedParent}}">
<Grid.ColumnDefinitions>
<ColumnDefinition Width="5" />
<ColumnDefinition />
<ColumnDefinition Width="5" />
</Grid.ColumnDefinitions>

<!-- Start resize handle -->
<Thumb Width="5" Grid.Column="0" HorizontalAlignment="Left" Name="StartResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding LeftResizeCursor}" />

<!-- End resize handle -->
<Thumb Width="5" Grid.Column="2" HorizontalAlignment="Right" Name="EndResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding RightResizeCursor}" />

<!-- Non-milestone presentation root (border) -->
<Border Name="Root" Grid.Column="1" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="1" Background="{TemplateBinding Background}">
<Rectangle Name="Focus" RadiusX="0" RadiusY="0" Stroke="{TemplateBinding FocusBrush}" StrokeThickness="1" Opacity="0" />
</Border>

<!-- Move handle -->
<Thumb Name="Mover" Grid.Column="1" Style="{StaticResource InvisibleThumb}" />

<!-- Progress presentation -->
<Border Name="ProgressContainer" Grid.Column="1" Margin="1" Height="5" VerticalAlignment="Center" HorizontalAlignment="Stretch">
<Border Name="Progress" Width="{TemplateBinding ProgressLength}" HorizontalAlignment="Left">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="5" />
</Grid.ColumnDefinitions>
<Border Grid.ColumnSpan="2" Background="{TemplateBinding ProgressBackground}" IsHitTestVisible="False" />
<Thumb Grid.Column="1" Name="ProgressResizer" Style="{StaticResource InvisibleThumb}" Cursor="{TemplateBinding ProgressResizeCursor}" />
</Grid>
</Border>
</Border>
<TextBlock Grid.Column="1" IsHitTestVisible="False" HorizontalAlignment="Center" VerticalAlignment="Center" Text="{Binding Path=Allocation.ActivityName, RelativeSource={RelativeSource TemplatedParent}}" Visibility="{Binding Path=ShowActivity, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibilityConverter}}"/>

<Border x:Name="LeftSide" Grid.Column="0" Margin="5,0,-5,0" IsHitTestVisible="False" BorderThickness="2,2,0,2" BorderBrush="{TemplateBinding AccentBrush}" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}, ConverterParameter=Left}" />
<Border x:Name="RightSide" Grid.Column="2" Margin="-5,0,5,0" IsHitTestVisible="False" BorderThickness="0,2,2,2" BorderBrush="{TemplateBinding AccentBrush}" CornerRadius="{Binding CornerRadius, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource cornerRadiusConverter}, ConverterParameter=Right}" />

</Grid>

<ControlTemplate.Triggers>
<Trigger Property="IsMouseOver" Value="True">
<Setter TargetName="Root" Property="Background" Value="{Binding Path=MouseOverBackground, RelativeSource={RelativeSource TemplatedParent}}" />
<Setter TargetName="Root" Property="BorderBrush" Value="{Binding Path=MouseOverBorderBrush, RelativeSource={RelativeSource TemplatedParent}}" />
</Trigger>
<Trigger Property="IsKeyboardFocusWithin" Value="True">
<Setter TargetName="Focus" Property="Opacity" Value="1" />
</Trigger>
</ControlTemplate.Triggers>

</ControlTemplate>

</Setter.Value>
</Setter>

</Style>

DependencyPresenter

XAML [image] Copy Code

<Style TargetType="local:DependencyPresenter">

<Setter Property="SnapsToDevicePixels" Value="False" />

<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:DependencyPresenter">
<Path Fill="{TemplateBinding Background}" Stroke="{TemplateBinding BorderBrush}" StrokeThickness="1" Data="{TemplateBinding PathData}" Stretch="Fill" Margin="{TemplateBinding HitTestDistance, Converter={StaticResource thicknessValueConverter}}" />
</ControlTemplate>
</Setter.Value>
</Setter>

</Style>


Popups

Popups

SchedulePopupContent

Item popups can be customized through the PopupStyle property of the BaseChart class. To customize the appearance of the tooltips in the chart, assign a WPF Style with a custom ControlTemplate to this property. This Style targets the SchedulePopupContent class, which is used for the presentation of the popup. The default style of item popups in the default theme is displayed below:

XAML [image] Copy Code

<!-- SchedulePopupContent style -->
<Style TargetType="local:SchedulePopupContent">
<Setter Property="BorderBrush" Value="{StaticResource PopupContentBorderBrush}" />
<Setter Property="BorderThickness" Value="1" />
<Setter Property="Background" Value="{StaticResource PopupContentBackgroundBrush}" />
<Setter Property="Padding" Value="2" />
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:SchedulePopupContent">
<Border Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
<StackPanel Orientation="Vertical">
<StackPanel Name="NameContainer" Orientation="Horizontal">
<TextBlock Text="{Binding DataContext.ActivityName}" FontWeight="Bold" />
<TextBlock Text=" (" />
<TextBlock Text="{Binding DataContext.ScheduleMode}" />
<TextBlock Text=")" />
</StackPanel>
<StackPanel Name="StartTimeContainer" Orientation="Horizontal">
<TextBlock Text="Start time: " />
<TextBlock Text="{Binding ExpectedStartTime}" />
</StackPanel>
<StackPanel Name="EndTimeContainer" Orientation="Horizontal">
<TextBlock Text="End time: " />
<TextBlock Text="{Binding ExpectedEndTime}" />
</StackPanel>
<StackPanel Name="DurationContainer" Orientation="Horizontal">
<TextBlock Text="Duration: " />
<TextBlock Text="{Binding ExpectedDuration}" />
</StackPanel>
<StackPanel Name="ProgressContainer" Orientation="Horizontal" >
<TextBlock Text="Progress: " />
<TextBlock Text="{Binding ExpectedProgress}" />
</StackPanel>
</StackPanel>
</Border>
<ControlTemplate.Triggers>
<Trigger Property="Action" Value="ResizeStart">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="ResizeEnd">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="Move">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="ResizeProgress">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Visible" />
</Trigger>
</ControlTemplate.Triggers>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The template in the style relies on several static WPF Brush resources, which are defined differently across the themes. The local namespace prefix is defined to point to the http://mindfusion.eu/dataviews/wpf namespace. The control template defined in the style binds to various properties of the SchedulePopupContent class, including ExpectedStartTime, ExpectedEndTime, ExpectedDuration and ExpectedProgress. The DataContext of the SchedulePopupContent class property contains a reference to the underlying IActivityViewModel or IResourceAllocationViewModel depending on the actual item.

DependencyPopupContent

Dependency popups can be customized through the DependencyPopupStyle property of the ActivityChart class. You can customize the appearance of these tooltips by assigning a WPF Style with a custom ControlTemplate to this property. This Style targets the DependencyPopupContent class, which is used for the presentation of the popup. The default style of the dependency popups in the default theme is displayed below:

XAML [image] Copy Code

<!-- DependencyPopupContent style -->
<Style TargetType="local:DependencyPopupContent">
<Setter Property="BorderBrush" Value="{StaticResource PopupContentBorderBrush}" />
<Setter Property="BorderThickness" Value="1" />
<Setter Property="Background" Value="{StaticResource PopupContentBackgroundBrush}" />
<Setter Property="Padding" Value="2" />
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:DependencyPopupContent">
<Border Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
<StackPanel Orientation="Vertical">
<TextBlock Text="{TemplateBinding PopupTitle}" FontWeight="Bold" Margin="0,0,0,3"/>
<Line X1="0" X2="1" Y1="0" Y2="0" Stretch="Fill" Stroke="Black" StrokeThickness="1.5" Margin="0,0,0,3"/>
<StackPanel Name="FromContainer" Orientation="Horizontal">
<TextBlock Text="From: " />
<TextBlock Text="{TemplateBinding From}" FontWeight="Bold" />
</StackPanel>
<StackPanel Name="ToContainer" Orientation="Horizontal">
<TextBlock Text="To: " />
<TextBlock Text="{TemplateBinding To}" FontWeight="Bold"/>
</StackPanel>
<StackPanel Name="DependencyTypeContainer" Orientation="Horizontal">
<TextBlock Text="Dependency type: " />
<TextBlock Text="{TemplateBinding FromType}" FontWeight="Bold" />
<TextBlock Text="To" FontWeight="Bold" />
<TextBlock Text="{TemplateBinding ToType}" FontWeight="Bold" />
</StackPanel>
</StackPanel>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

As with the SchedulePopupContent default style, this style also relies on several static WPF Brush resources, which are defined differently in different themes. The local namespace prefix is defined to point to http://mindfusion.eu/dataviews/wpf namespace.The ControlTemplate defined in the style binds to various properties of the DependencyPopupContent class, including PopupTitle, From, To, FromType and ToType.


Themes

Themes

MindFusion.DataViews for WPF ships with several built-in themes that can be easily applied on the different views. The following table contains the URIs of the resource dictionaries of all predefined themes:

Theme | Resource Dictionary URI
Mild | Themes/Mild.xaml
Vista | Themes/Vista.xaml
WindowsBlue | Themes/WindowsBlue.xaml

To apply a specific theme, simply add it to a resource dictionary in your application's visual tree by using a MergedDictionaries. The following example demonstrates how to add the Vista theme in XAML:

XAML [image] Copy Code

<Grid>
<Grid.Resources>
<ResourceDictionary>
<ResourceDictionary.MergedDictionaries>
<ResourceDictionary Source="/MindFusion.DataViews.Wpf;component/Themes/Vista.xaml" />
</ResourceDictionary.MergedDictionaries>
</ResourceDictionary>
</Grid.Resources>

<!-- Add the respective view here. -->

</Grid>

Themes can also be dynamically applied or removed through code by following the same pattern. The code below illustrates this:

C# [image] Copy Code

var res = new ResourceDictionary();

res.MergedDictionaries.Add(new ResourceDictionary() { Source = new Uri(@"/MindFusion.DataViews.Wpf;component/Themes/Vista.xaml", UriKind.RelativeOrAbsolute) });

grid.Resources = res;

Visual Basic [image] Copy Code

Dim res = New ResourceDictionary()

res.MergedDictionaries.Add(New ResourceDictionary() With {.Source = New Uri("/MindFusion.DataViews.Wpf;component/Themes/Vista.xaml", UriKind.RelativeOrAbsolute)})

grid.Resources = res

The images below illustrate an ActivityChart with different themes applied to it:

Generic

Mild

Vista

WindowsBlue

© 2018 MindFusion


MindFusion.Diagramming for WPF Overview

MindFusion.Diagramming for WPF Overview


Integrating WpfDiagram into your User Interface

Integrating WpfDiagram into your User Interface

Most of the functionality provided by the MindFusion.Diagramming for WPF package is implemented by the Diagram class. You can add its instance directly as a child of a Panel -derived object. In this case, it would participate as any other control in the WPF measure/arrange passes. Note that in the measure phase, a Diagram instance always returns the size of its Bounds as a desired size, and not the size of its content.

A Diagram could also be placed in one of the following containers:

  • ScrollViewer: use it to enable scrolling and panning the diagram content.
  • Ruler: enables scrolling, and also displays alignment rulers that let you measure and align objects in the diagram.
  • DiagramView: enable displaying multiple views of the same diagram, each having distinct zoom levels and scroll positions.


Diagram Structure

Diagram Structure

The following topics are contained within this topic:

Standard Item Types
Information about the standard MindFusion.Diagramming for WPF item types, such as ShapeNode, TableNode and DiagramLink.

Custom Item Types
Information on how to implement and use custom item types.

Using WPF Controls as Nodes
Information on how to host WPF controls in MindFusion.Diagramming for WPF diagrams.

Creating and Deleting Items
Information on how to create and delete items both interactively and programmaticaly.

Accessing Items
Information about how to access the diagram items, how to get the selected items and how to find particular items in the diagram according to a specifiec criteria.

Attaching and Grouping Items
Information about the use of the Group class in orde to create hierarchies of dependent objects in MindFusion.Diagramming for WPF.

Layers
Information about how to organize items in layers and how to use the LayerListView control.

Collapsing and Expanding Tree Branches
Information on how to enable expanding diagram nodes.

Multiple Diagram Pages
Information about the multi-page DiagramDocument class and the TabbedDiagramView control.


Standard Item Types

Standard Item Types

Diagram elements in MindFusion.Diagramming for WPF are represented by instances of the DiagramNode and DiagramLink classes. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties. MindFusion.Diagramming for WPF also offers intuitive user interface for drawing and editing diagram items interactively.

Shape Nodes

Shape nodes can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. There are more than 100 predefined node shapes (you can preview them here) and apart from them, MindFusion.Diagramming for WPF offers an easy way to define custom shapes. Shape nodes can be rotated, either interactively using the round selection handle drawn above them, or programmatically using the RotationAngle property. ShapeNode appearance can be customized further using several types of custom painting. The first type gives you full control over the painting. With the second one your painting code is performed additionally to the basic painting. The third one performs standard drawing of nodes and custom drawing of their shadows.

Templated Nodes

The TemplatedNode class represents nodes whose appearance is set through Xaml data templates. This class is useful mostly as a base type of custom nodes, as shown in tutorials 3 and 4. However it is not abstract and can be used directly if the text -related properties defined in DiagramItem are sufficient for your purposes. The appearance of such nodes can be set through their Template property or the NodeTemplate property of the Diagram class.

Table Nodes

Tables can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells can span several rows and columns as set in the RowSpan and ColumnSpan properties. Cells, columns and rows can be customized in various ways - there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics. The file formats supported are BMP, GIF, JPEG, ICO and WMF (the same applies for shape nodes).

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, the contained nodes move too. Containers can be folded to hide the contained nodes, and unfolded back to show them again. Nodes inside a container can be linked to nodes both inside and outside of it. When a container is folded, the links connected to contained nodes point to the container outlines. Containers can be nested one within another to unlimited depth.

Free-form Nodes

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline. To let users draw free-form nodes interactively, set Behavior to DrawFreeForms. Use the Points property of FreeFormNode to get or set outline points programmatically. If the Closed property is set, the node is drawn as a closed shape and its interior filled, or otherwise the node is drawn as a poly-line. If the distance between first and last points drawn by user is shorter than AutoCloseDistance, the node gets closed automatically.

TreeView Nodes

The TreeViewNode class represents nodes that can display hierarchical data. The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

Visio Nodes

The diagram can display shapes from stencil files in Visio 2003 XML stencil format (.vsx). To load a stencil file, use an instance of the VisioStencil class. The shapes are displayed in the diagram through VisioNode objects. To associate a stencil shape with the node, create an instance of the VisioContent class and assign it to the node's Content property. Note that standard stencils installed with Visio are copyrighted by Microsoft, and you should not use them in your application. This feature is intended to let you use public domain stencils, or commercial clipart you have purchased a license for.

Barcode Nodes

The BarcodeNode class displays EAN, UPC or QR barcodes as node's content. In-place edit operations let users enter new numeric codes for 1D codes or text strings for QR codes. The barcode format is specified via the Format property, the encoded number or text is set via Content, and color of 1D bars / 2D modules via BarColor.

Links

Links are used to represent various types of connections and relations in diagrams. MindFusion.Diagramming for WPF offers three basic link types:

  • Polyline links composed of straight-line segments;
  • Curved links composed of Bézier or spline segments;
  • Cascading links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links - having one or both of their ends not connected to nodes. Some customizable link's properties are: arrowheads, Shape, color, text, pen width and style, modification behavior and number of segments.


Custom Item Types

Custom Item Types

You can create your own item types by deriving the DiagramNode and DiagramLink classes or their successors such as TableNode, ContainerNode and so on. You can add custom data fields to the diagram items, and implement custom visualization and interaction functionality.

Serialization

If you add custom fields to your item class, you will probably want their values saved when saving diagram files, and restored when loading files. To enable this, override the SaveTo and LoadFrom methods of the DiagramItem class, and you can use BinaryWriter and BinaryReader objects to implement binary serialization. For XML serialization, you must implement the SaveToXml and LoadFromXml methods.

Clipboard operations

You must implement the Clone method in order to enable CopyToClipboard and PasteFromClipboard to work with your custom item type, If Clone is not implemented, you will get an instance of the base class created for the pasted item, and this could lead to an exception when the base class deserialization code tries to load the item state from a data stream created by the derived class. If your class has any custom fields, it must also implement the SaveToXml and LoadFromXml methods for proper serialization.

Rendering

If you need to provide custom rendering for your items, override the Draw method. In this way, you can render your item on a DrawingContext surface.

User interaction

To enable drawing of items from a custom class, set the Behavior property of the diagram view to Custom, and set the CustomNodeType or CustomLinkType property to the Type object that corresponds to your class. If you need to change how items handle user interaction while they are being initially created, implement the StartCreate, UpdateCreate and CompleteCreate methods. In order to change how items respond to user interaction while they are being modified, implement the StartModify, UpdateModify and CompleteModify methods.


Using WPF controls as nodes

Using WPF controls as nodes

The DiagramNodeAdapter class lets you use any WPF UIElement object as a diagram node. This allows you to use ready-made or custom WPF controls to display or edit the entities represented in your application's diagrams. The controls hosted in MindFusion.Diagramming for WPF nodes might be interactive and with embedded user interface. For example you might utilize calendars, grids, rich-text controls or html-pages as entity editors or viewers. You might also create your own custom control and integrate it seamlessly with MindFusion.Diagramming for WPF; as a result you can get as advanced entity-relationship diagram editor as your application needs.

Creating Controls Interactively

To let the user draw UIElement objects with the mouse, set Behavior to Custom. The type of controls to be created in the host nodes is specified by the CustomNodeType property of Diagram. If the following code executes, each node drawn by users would host a GridView instance, and nodes could be connected by drawing links between them:

C# [image] Copy Code

// Draw datagrid nodes and allow connecting them with links
diagram.Behavior = Behavior.Custom;

// Default type of hosted controls is GridView
diagram.CustomNodeType = typeof(GridView);

Visual Basic [image] Copy Code

' Draw datagrid nodes and allow connecting them with links
diagram.Behavior = Behavior.Custom

' Default type of hosted controls is GridView
diagram.CustomNodeType = GetType(GridView)

Adding a WPF Control Programmatically

To display a WPF UIElement-derived object in the diagram programmatically, add an instance of the class to the diagram's Nodes collection. This automatically creates a DiagramNodeAdapter for the UIElement object. You can as well instantiate the DiagramNodeAdapter explicitly and add it to Nodes. To get the DiagramNodeAdapter associated with an UIElement, use the DiagramItem attached property.


Creating and Deleting Items

Creating and Deleting Items

Creating Items Programmatically

In order to add a new node or link to a diagram, create an instance of the item class by using the new operator and add it to the diagram's Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming for WPF predefined types.

There are several shortcut methods provided for creating instances of the predefined node and link types. The methods are members of the diagram's Factory object:

  • The CreateShapeNode method creates a ShapeNode at the specified position.
  • The CreateTableNode method creates a TableNode at a specified position. Tables have a method that connects them with other tables called AddRelation.
  • The CreateContainerNode method creates a ContainerNode at the specified position.
  • There are several overloads of the CreateDiagramLink method that allow connecting two nodes of the same type or of different types.

Drawing New Items

Users can draw diagram elements with the mouse. The Behavior property specifies what type of elements should be created when a user starts drawing. When a user starts drawing, an item is created and an initialization event is raised to let you customize the item appearance before showing it on the screen. The initialization events include ones such as InitializeNode, InitializeLink, and so on. While items are being drawn, the control raises validation events such as NodeCreating to let you validate the operation and prevent creating items at a specific location. When the user releases the mouse button, the item is added to the collection that contains items from the same type (for example Nodes) and an event is raised, for example NodeCreated.

Deleting Items

Call the Remove method of the Nodes or Links collection to delete an item from the diagram. The ClearAll method clears diagram contents by deleting all items. A shortcut for removing a link between two tables is provided by the BreakRelation method.


Accessing Items

Accessing Items

One of the most common tasks when using the component is iterating over all items in the diagram document or navigating through the connections between items - from a node to the incoming or outgoing links, or from a link to its origin and destination nodes. To enumerate items of a diagram use the Items, Links or Nodes collections. The nodes that a link connects are referenced by the link's Destination and Origin properties. To access the links that are connected to a node, use its IncomingLinks and OutgoingLinks collections. The first collection contains references to all links pointing to the node, the second - to the links that start from it. Links can connect to rows of a table; to find such links use table's Rows collection and the IncomingLinks and OutgoingLinks collections. A shortcut for accessing the other end of a relation in entity-relationship diagrams is provided by the RelatedOneToMany and RelatedManyToOne properties of the Row class.

Selected Items

If only one item is selected, it is considered the active item and can be accessed with the ActiveItem property. The type of this property is DiagramItem; you can get the actual type of the selected item through .NET reflection. Multiple items can be selected when clicking or dragging with the CTRL key pressed at the same time. Multiple-selection is represented by the Selection property of the Diagram class. The Selection object provides collections to access the selected Links and Nodes.

Finding Items

You can search for diagram items by their Tag or Id using the FindLink, FindNode, FindLinkById and FindNodeById methods. Tag and id objects are compared by calling the Equals method of the System.Object class. Thus if the tags are of value type, they are compared by value (that is bitwise equality). If they are of reference type their Equals method is used. If there are more items with the same tag, the first one will be returned. If no item with the specified tag exists, a null reference (Nothing in Visual Basic) will be returned. Groups can also be searched by tag using FindGroup.

Relationship Queries

The Query method traverses the graph by following node/link connections and group's parent/child relationships to find items in specific relation to the current one. The method receives a string argument consisting of selectors and optional predicates. The query is executed in several steps. In each step the result set is constructed from the previous result set by following the relationship specified by the current selector. If a predicate is specified after the selector identifier, the result set is filtered to include only items for which the predicate evaluates to true.


Attaching and Grouping Items

Attaching and Grouping Items

MindFusion.Diagramming for WPF allows attaching a node to another diagram element, establishing a subordinate - master relationship between the two items. The easiest way to attach nodes is to call the AttachTo method. When a master element is moved or resized, any subordinated node follows it, so that the initial distance between the two items stays constant. This happens both when a user moves the master item around, and when the item position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another item and set its Text, so that the shape node acts as an additional label assigned to the main item.
  • Attach a shape node to another item and set the node's Image, so it acts as an additional icon displayed inside or near the main item.
  • Attach a shape node or a table to another item and handle the NodeClicked or similar events to perform some action on the main item. This makes the subordinated node act as a button or another type of UI element attached to the main item. For more complex UI requirements, use an attached DiagramNodeAdapter and handle the events raised by the control it hosts.
  • In all previous cases, the Locked property can be set for attached nodes, which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinates.
  • Attach child elements in a tree branch to the branch root, so that when a user moves a tree node, the node's children moves simultaneously with it. Modifying an item in such hierarchical group makes the modification pervade through all dependant subordinated items.

Hierarchical Grouping

A unit of attached items is represented by an instance of the Group class. To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master object as argument. Attach items to the group using the various Group methods. The AttachTo method of nodes is a shortcut to creating a group and attaching an item to it.

Every member of a group can be the master item of another group, that is an item can be subordinate in one group and meanwhile be another group's master. MindFusion.Diagramming for WPF doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put an item as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies - that is item1 is attached to item2, item2 to item3 ... itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Attaching Items to a Group

Links cannot be attached to groups but can be master items of groups. If a group's master item is a link, nodes can be attached to the control points or segments of the link. See the AttachToLinkPoint and AttachToLinkSegment methods for details. If the master item is a node, other nodes can be attached to any of its corners, or to an area specified as percent of master-node's bounding rectangle. Check AttachToCorner and AttachProportional for details. A shortcut to creating Group instance and calling the appropriate AttachTo* methods is provided by the AttachTo method of the DiagramNode class.

Accessing Group Items

Group members can be accessed using the MainItem property and the AttachedNodes collection. To get the groups in which an item participates, use its MasterGroup and SubordinateGroup properties.

Destroying Groups

If a user deletes the master item of a group, the group is destroyed automatically and the GroupDestroyed event is raised. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact. Groups can be destroyed programmatically by removing them from the diagram's Groups collection.


Layers

Layers

Items can be assigned to layers, and layers can be hidden, locked or moved up/down in the Z order as a group. Layer objects provide Visible, Locked and ZIndex properties, which will affect all items in the respective layer. Layers also expose a Title property shown in the LayerListView control. Newly drawn items are added to the layer specified via Diagram.ActiveLayer.

Set the LayerIndex property of items to associate them with layers in the Diagram.Layers collection. If LayerIndex has the default value of -1, the item is not associated with any layer and its visibility depends only on the item's own Visible property.

Layer list control

The LayerListView control provides user interface for working with Layer objects. The control presents a list of the specified Diagram's layers, showing their title and an overview image of the objects in each layer, and also allows editing of layer's Visible and Locked properties and choosing the Diagram's currently active layer. New layers can be added to the Diagram by clicking the + button and removed by clicking the - button.


Collapsing and Expanding Tree Branches

Collapsing and Expanding Tree Branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. Use the nodes' Collapse and Expand methods to do this programmatically. To determine whether a subtree is expanded or collapsed, check its root's Expanded property.

Displaying Expand/Collapse Button

If the Expandable property of a node is set to true, there is a [±] button displayed beside the node to allow users to collapse or expand the tree branch starting there. The button location can be customized by the diagram's ExpandButtonPosition property. By default, pressing that button calls automatically the Collapse and Expand methods and raises the TreeExpanded or TreeCollapsed events.

Defining Tree Direction

A node can be connected to other nodes through outgoing and incoming links. Setting the ExpandOnIncoming property specifies which items connected to a node will be regarded as its descendants. If ExpandOnIncoming is false (default value) then each node will be regarded as a parent of its outgoing links and the items attached to them. If ExpandOnIncoming is set to true, the node's incoming links define its children. So that property specifies the direction of parent-children relationship between diagram items and respectively the overall direction in which collapsing / expanding is done.

Expanding a Branch Recursively

Use the RecursiveExpand property to specify whether the whole tree branch starting from a node will be shown when expanding, or only the first level of descendants. A related property is the Expandable property of the Group class, which specifies whether expanding and collapsing propagate through group members.

HtmlBuilder Support

The HtmlBuilder class can generate map areas for the [±] buttons displayed beside Expandable nodes. To enable that, assign an URL to the ExpandBtnHyperLink property. That URL can contain some format specifiers, which are automatically replaced with the values of nodes' Tag or ZIndex properties. On the server side, you can identify the node whose [±] button is clicked.

Custom Expand/Collapse Functionality

By using the ExpandButtonAction property, you can override the standard functionality of the [±] button. Set this property to RaiseEvents and handle the ExpandButtonClicked event if you need to implement your own expand/collapse logic.


Multiple Diagram Pages

Multiple Diagram Pages

The DiagramDocument class represents a collection of diagram pages or sheets, represented by DiagramPage objects. New pages can be added to the document and existing pages can be removed and reordered via the Pages collection. The SaveToXml methods of DiagramDocument save all pages in a single file, and respectively the LoadFromXml methods load all pages from the file. DiagramDocument can also load files created by the serialization methods of Diagram, and will show them in a single page. Note that the opposite is not true: Diagram cannot load directly a DiagramDocument file.

DiagramPage is derived from Diagram and only adds a Title property, so any code that processes Diagram objects will work with DiagramPage objects too. A diagram document forwards each event raised by its pages, giving you a chance to use the same handler for events raised by different pages. If a page should implement distinct user interaction or validation logic, it is also possible to attach handlers to the Diagram events inherited by DiagramPage.

A DiagramDocument can be exported to PDF and Visio, and imported from Visio using the new overloads available in the PdfExporter, VisioExporter and VisioImporter classes respectively. Other export classes do not support multi-page export at this time, but still can be used to export individual pages via their Export(Diagram) method.

A single DiagramPage could be assigned to the Diagram property of DiagramView, and that lets you create your own user interface for presenting a list of pages to the user and selecting a current page. The package also includes a TabbedDiagramView that presents all pages of a document in a tabbed user interface where each tab corresponds to a page. The page displayed in the active tab is exposed by the CurrentPage property of TabbedDiagramView. The active page can be changed interactively by activating its associated tab. New pages can be added and removed to/from the document through buttons in the tab tray and the pages can be rearranged by dragging their associated tabs with the mouse.


User Interaction

User Interaction

The following topics are contained within this topic:

Controlling User Interaction
Information on how to control user interactions with the control through diagram behavior, node constraints and event handling.

Handling Events
Information about some more notable events in MindFusion.Diagramming for WPF.

Single and Multiple Selection
Provides information on how to select items, how to modify the selection appearance and behavior and how to access the items that are already selected.

Automatic Alignment
Information about the built-in tools for automatic item alignment during interactions.

Clipboard Operations
Information on how to use the Windows clipboard with MindFusion.Diagramming for WPF.

Scrolling and Zooming
Controlling scrolling and zooming in diagram views.

Tool-Tips
Information on how to enable tooltips for individual items and for the entire diagram.

In-place Editing the Contents of Items
Information about the standard in-place item editing and how it can be extended.


Controlling User Interaction

Controlling User Interaction

There are several ways to control user actions on the diagram as a whole, or on individual items in the diagram.

Disabling Interaction

By setting the Enabled property of Diagram to false, you can make the diagram contents non-modifiable at all. Thus it will function as nothing more than a static image you can use to present some data to the user. The diagram can still be modified programmatically though.

Specify How User's Actions are Interpreted

The Behavior property provides several predefined sets of rules specifying how user input with the mouse/keyboard is interpreted. If Behavior is set to LinkShapes, mouse dragging started from an unoccupied point of the document is processed as a ShapeNode creation request and dragging over a node creates a link. Note that such behavior leads to some extra work when creating overlaying nodes - users need to draw the second node on an empty area and move it over the first one afterwards. If you want to avoid that, use the DrawShapes behavior. If LinkTables is set, dragging the mouse over an empty area creates a table and dragging over a table creates a link. Behavior options also include DrawLinks, DrawTables and Modify.

Setting Diagram Bounds

Document size can be get or set with the Bounds property. By default, users are able to move items outside the diagram bounds. To prevent this, enable the RestrictItemsToBounds property. It provides three options to restrict item positions. They might not be restricted at all. The most restrictive option is to keep items entirely inside the document area. Another option allows items to be partially outside the document area but having at least a small visible part inside.

Item Constraints

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former can be used to constrain the move direction, node size and aspect ratio. The latter enables or disables specific manipulation handles of a node. That allows making the node non-moveable, non-resizable, or resizable only horizontally/vertically.

Items can be locked by the Locked properties. Locked items are excluded from selection and users cannot select, move or modify them.

Control How Links Connect to Nodes

The AllowIncomingLinks property of the DiagramNode class specifies whether incoming links can be drawn to a node. The AllowOutgoingLinks property enables drawing of outgoing links to a node.

Anchor points define where link's ends are placed when a user attaches a link to a node. A pattern of anchor points can be assigned to a node by setting the node's AnchorPattern. The SnapToAnchor property specifies whether link ends are aligned to anchor points when creating or modifying links.

Once a link is created, a user can still move its end points to different positions, unless LinkEndsMovable is set to false. This can also be controlled on a per-link basis by the AllowMoveEnd and AllowMoveStart properties. You can dynamically validate moving of links' end points using the LinkModifying event.

The AllowSelfLoops property enables or disables drawing of reflexive links. They are allowed by default, but can be disabled if you consider them meaningless for the application. AllowLinksRepeat controls if two nodes can be connected more than once in the same direction.

In-place Text Editing

The text of nodes and tables can be edited in-place by double-clicking the respective items. To enable the feature set the AllowInplaceEdit property to true. For tables, both captions and cells can be edited in this way. Handle the CellTextEditing event to enable/disable in-place editing per cell. Depending on the type of item being edited, one of these events can be fired when editing completes: NodeTextEdited, CellTextEdited. In-place editing mode is exited when users click outside the text entry control. Pressing ENTER or ESC exits in-place editing mode if respectively InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc are enabled.

Validation Events

When users try to create, delete or select an item, one of the following events is raised. To ban the action, set corresponding event bool argument to false:

Event | Description
NodeCreating | Raised while a user draws a new node.
LinkCreating | Raised while a user draws a new link.
NodeSelecting | Raised when the user is trying to select a node.
LinkSelecting | Raised when the user is trying to select a link.
NodeDeleting | Raised when the user is trying to delete a node.
LinkDeleting | Raised when the user is trying to delete a link.
NodeModifying | Raised while a user modifies an existing node.
LinkModifying | Raised while a user modifies an existing link.

For more events that can be fired by user's actions, please, consult the Events section of the documentation.

Miscellaneous

  • Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can immediately modify it.
  • The ModifierKeyActions property allows assigning different functions to the CTRL, ALT and SHIFT keys.
  • AllowMultipleResize specifies whether the user can resize multiple selected items simultaneously.


Handling Events

Handling Events

Most events are raised only in response to users actions. If you need to execute the same code after user actions and API calls, move the common code to a method and invoke the method both in the respective event handler and after the API method or property setter call. A notable exception is the *Deleted set of events, which are also raised when items are deleted programmatically, because in some circumstances deleting an item could delete other items related to it.

When a user starts drawing a new item with the mouse, the control raises an initialization event to let you set the appearance properties of the item. That is, for a node, the control raises InitializeNode.

While the user is holding down the mouse button and drawing, a validation event is raised to let you cancel the item creation (for example, NodeCreating). If the action is not cancelled, a creation event is raised to let your application know about the new item (for example, NodeCreated). There are events raised when users modify items, for example, NodeModifying and NodeModified. Call the CancelDrag method to cancel the item modification or creation from the *Modifying or *Creating events raised for nodes or links.

When a user presses the DEL key, there is a validation event raised to let you confirm deleting an item (for example, NodeDeleting), and if not cancelled, there is an item-deleted event raised (for example, NodeDeleted).

There are many other events related to various activities a user could carry out on the diagram. The full set of events can be found here:
Diagram Events


Single and Multiple Selection

Single and Multiple Selection

Selecting and Modifying Items

In order to move or modify a diagram element, users drag its adjustment handles. Adjustment handles appear around an item when it is selected. Each handle can be dragged to perform specific transformation on the item. The appearance and behavior of modification handles can be altered by the HandlesStyle property. Depending on the value assigned to ModificationStart, those handles can also appear automatically when the mouse pointer hovers over an item.

Active Item

If only one diagram item is selected, it is considered the 'active' item. One of the items in a multiple-selection is also regarded as active; it is usually the one selected last. The active item has white modification handles drawn around it, while other items in multiple-selection have gray handles. The active item is probably the one users are most interested in while editing a diagram, and your program can update its state and user-interface according to that. Access to the active item is provided by the ActiveItem property of the Diagram class.

Multiple-Selection

Selection of diagram items in MindFusion.Diagramming for WPF is represented by an instance of the Selection class. This class provides methods to programmatically select or deselect items and properties that specify how the selection looks and behaves. A property of the Diagram class, also called Selection, exposes the items selected within the current document. Multiple items can be selected, thus moved at the same time. To programmatically add items to or remove them from the multiple-selection invoke one of the AddItem, Toggle and RemoveItem methods. The Clear method deselected all items and the Change method selects a single item, deselecting all others. Setting AllowMultipleSelection to false disables multiple-selection.

Drawing a Selection Lasso

To select multiple items, users must draw a selection lasso or rectangle with the left mouse button while holding down the CTRL key. In order to enable free-form lasso mode, set FreeFormMode to true. The MiddleButtonActions and RightButtonActions properties let you enable drawing the selection lasso using the middle or right mouse button.

Appearance

The visual style of multiple-selection is defined by the Style property of the Selection class. For example, selection might be painted as a dashed rectangle or a semi-transparent filled rectangle. Colors of the selection rectangle can be changed by setting the selection's Pen and Brush properties. Another property related to selection visualization is the diagram's SelectionOnTop, which specifies whether selected items must be painted according to their z-order position or on top of the non-selected items.

Enumerating Items

The Selection class exposes the selected items as .NET collections. The Items collection references all selected items, getting them as DiagramItem instances. The Nodes and Links collections keep references to the selected items of specific classes. Alternatively you might enumerate all items in the diagram and check their Selected property.

Automatic Selection

Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can modify it immediately.


Automatic Alignment

Automatic Alignment

The following features help the user align items interactively.

Alignment Grid

Items are aligned to a grid when AlignToGrid is enabled. More information is available in the Alignment Grid topic.

Align nodes to nodes

If AutoAlignNodes is enabled, the node currently being drawn or resized is aligned to another node so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Snap links to nearby nodes

The currently drawn or modified link can automatically snap to the nearest border point of the nearest node when AutoSnapLinks is set. The maximal distance at which links will connect to a nearby node is set via AutoSnapDistance.


Clipboard Operations

Clipboard Operations

A single diagram item or a selection of items can be copied or cut to the Windows clipboard. This is done programmatically using the CopyToClipboard and CutToClipboard methods. To paste the clipboard contents into the current diagram call PasteFromClipboard.

MindFusion.Diagramming for WPF does not provide keyboard interface to clipboard operations. You might assign the standard CTRL+C, CTRL+X and CTRL+V shortcuts to menu items and handle them by calling the respective methods.


Scrolling and Zooming

Scrolling and Zooming

In order to enable scrolling, you must place the Diagram control inside a ScrollViewer, Ruler or a DiagramView.

Automatic Scrolling

The AutoScroll property controls automatic scrolling. If it is enabled and the user drags an adjustment handle near the Diagram edges while manipulating an item, the control will scroll the viewport towards the mouse position. The ScrollZoneSize property defines the size of the area near the view borders that triggers automatic scrolling.

Diagram Size

The diagram size is set through the Bounds property. Its value is a Rect instance that specifies the origin of the diagram coordinate system and the diagram size.

Programmatic Scrolling

In order to scroll the document content programmatically, you can call the ScrollTo method or set ScrollX and ScrollY properties. The latter can also be used to access the current scroll position in case you need it. The BringIntoView method scrolls the viewport to ensure that a specific diagram item can be seen in the view.

Scrolling Tables

Table rows can be scrolled too. If the Scrollable property is set to true, an up/down scroll button is displayed in the table's caption area. By means of this button, users can scroll the rows of the table. Scrolling can also be done programmatically using the CurrentScrollRow property.

Zooming

Zooming is controlled by the ZoomFactor property, ZoomIn and ZoomOut methods. The zoom factor is expressed as a percentage, 100% meaning no zoom. Higher than 100% makes the diagram items look closer and bigger on the screen - zooming in. Less than 100% makes items look further and smaller on screen - zooming out. The ZoomIn method increases zoom factor by 10%. Respectively the ZoomOut method decreases zoom factor again by 10%. To zoom and scroll the view to fit the diagram contents to the control's client area, call ZoomToFit. To zoom and scroll the view so it fits a specified rectangular document area to the control's client area, call ZoomToRect.

Magnifying

The Diagram provides an option for zooming in (or out) portions of the diagram through the Magnifier tool. The magnifier tool can be permanently activated by setting MagnifierEnabled to true. Alternatively, on-demand magnification through the right mouse button or by pressing a modifier key can be enabled be setting the appropriate value to the RightButtonActions or ModifierKeyActions properties respectively.

The magnification factor can be specified through the MagnifierFactor property. The size of the tool can be set through the MagnifierWidth and MagnifierHeight properties.

Panning

The diagram view can be panned by holding ALT while dragging the mouse with the left button down. Another modifier key can be used for panning by setting ModifierKeyActions. The MiddleButtonActions and RightButtonActions properties let you use the middle or right mouse button to start panning. MindFusion.Diagramming for WPF displays the PanCursor while panning.


Tool-Tips

Tool-Tips

Tool-tips are short text messages displayed when the mouse pointer hovers over a diagram item for a while. To enable tool-tips, set the ShowToolTips property to true. The delay before a tool-tip appears is set by the ToolTipDelay property.

Tool-tips can be defined for each diagram element and for the whole document. If the mouse pointer stands still and it points to an item, then the ToolTip of the item is displayed. The ToolTip of the diagram appears if there is no item under the cursor or if there is an item but there isn't any tool-tip text defined for it. The anchor points assigned to nodes also provide a ToolTip property.

Tool-tip's text is also used as a value of the ALT attribute of image map areas corresponding to items; see HtmlBuilder for more information.


In-place Editing the Contents of Items

In-place Editing the Contents of Items

Standard in-place editing

To activate the standard in-place editing of the text of MindFusion.Diagramming for WPF objects, set the AllowInplaceEdit property to true. AllowInplaceEdit allows in-place editing the content of a diagram element by double-clicking it. In-place editing mode can be accepted and exited by clicking anywhere outside the text-field.

If you want to change the way of accepting / rejecting changes, the following Diagram properties allow using the ENTER and ESC keys to perform that: InplaceEditAcceptOnEnter and InplaceEditCancelOnEsc. When InplaceEditAcceptOnEnter is set to true, pressing the ENTER key causes accepting changes and exiting inplace-edit mode. If InplaceEditAcceptOnEnter is set to false, pressing ENTER inserts a new line in the text while in inplace-edit mode. If InplaceEditCancelOnEsc is set to true, pressing the ESC key performs rejecting changes and exiting inplace-edit mode.

In-place editing can be applied to the following properties: ShapeNode.Text, DiagramLink.Text, TableNode.Cell.Text, TableNode.Caption and ContainerNode.Caption. For tables, both captions and cells can be edited in this way.

If you want to enable/disable in-place editing of a specific table's cell, handle the CellTextEditing event. To enable/disable in-place editing of nodes, handle the NodeTextEditing event. For a DiagramLink object, the LinkTextEditing event is raised while in-place editing. These validation events let you prevent users from editing the text in the particular object if it is necessary.

When in-place editing of a node is completed, the NodeTextEdited event is raised. For a table's cell, handle the CellTextEdited event. LinkTextEdited event is raised when in-place editing of a DiagramLink object completes.

By default, MindFusion.Diagramming for WPF creates a TextBox control to let users edit item's text. The EnterInplaceEditMode event allows customizing the properties of that control, or attaching event handlers to it. InplaceEditFont specifies the font of the in-place edited text box. Actually, InplaceEditFont is assigned to the Font property of that text box.

When leaving inplace-edit mode, the LeaveInplaceEditMode event is raised. This event is raised in all cases of closing the inplace-edit control, for example, when the user accepts or cancels the changes made to an item's text, or when the EndEdit method is called.

To enter in-place editing mode programmatically and let users edit an item's text inline, call the BeginEdit method of Diagram. The EndEdit method exits inplace edit mode.

In-place editing of custom items

The InplaceEditable interface allows implementing the standard in-place editing for custom defined items. By means of the methods of this interface, you can specify the position of the inplace-edit textbox control and copy the entered text to a property of the edited item.

GetEditRect returns the destination rectangle of the in-place edit box. GetTextToEdit represents the initial contents of the in-place edit box. SetEditedText sets the edited text to the object after completing the in-place editing.


Placement and Layout

Placement and Layout

The following topics are contained within this topic:

Items Placement - Position, Size and Z-order
Information on how to modify the position, size and z-order of diagram items, both interactively and programmatically.

Alignment Grid
Information about the alignment grid.

Lanes Grid
Introduces the lanes grid - a grid that can be used in Swimlane diagrams or Gantt charts.

Laying Out Diagrams Automatically
Provides information about the automatic layouts available in MindFusion.Diagramming for WPF. Thes include the TreeLayout, SpringLayout and GridLayout.

Link Routing
Information about the automatic link routing.

Anchor Points and Patterns
Information on how to use anchor patterns and how to create custom anchor patterns.


Items Placement - Position, Size and Z-order

Items Placement - Position, Size and Z-order

Measure Unit

The MeasureUnit property specifies the unit of measure for all location and size-related values assigned to MindFusion.Diagramming for WPF properties or passed as arguments to its methods.

Location and Size of Nodes

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method. ShapeNode.ResizeToFitImage and TableNode.ResizeToFitImage methods set nodes' sizes to fit that of their pictures.

Links Control Points

Links have two or more control points, depending on their Shape and SegmentCount. You can get access to the control points by the link's ControlPoints collection. You must call UpdateFromPoints after moving control points of a link; that's needed in order to repaint the link and update its internal state variables. The Bounds property is read-only. It returns the smallest rectangle that bounds all link points.

Link Dynamics

The Dynamic property of a link can be enabled to make the link automatically recalculate its end point positions if the nodes connected to the link are moved or resized; the end points are moved in such a way that the link points to the centers of the connected nodes. A related property is AutoSnapToNode, which can be enabled to make the link end points align to the border of their origin or destination nodes while a user move the link ends.

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

Links have an AutoRoute property that enables or disables automatic routing of a link. Routed links avoid nodes by finding the shortest path between their origin and destination that does not cross any other nodes. The link routing algorithm can be tuned by using the properties exposed by RoutingOptions.

Interactive Moving or Resizing

End-users of your application can move or resize the diagram elements. They do this by selecting an item and dragging any of its adjustment handles, a point inside its interior, any of its sides or a selection frame. The HandlesStyle property of nodes controls how interaction can be performed. Additionally it defines the representation of selected items on screen. EnabledHandles lets you disable specific manipulations users are allowed to perform on a node, for example resizing the item horizontally or moving it. If an item is modified interactively, the NodeModified or LinkModified event is raised, depending on the item's type.

Controlling the Z-order

The Z-order defines how items are ordered on the Z-axis - so that one looks above or below another. Members of the DiagramItem class give you full control over the Z-order. To move an item one level up or down, invoke the ZLevelUp or ZLevelDown methods. To move an item to the bottom of the Z-order call its ZBottom method. To move the item in front of all others, call its ZTop method. You can use the ZIndex property to get or set the index of an item within the Z-order array.


Alignment Grid

Alignment Grid

MindFusion.Diagramming for WPF provides an alignment grid to help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set by the GridSizeX and GridSizeY properties. The GridOffsetX and GridOffsetY properties allow specifying the horizontal and vertical offset of the first point in the alignment grid.

Items created or modified by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridPen defines the pen with which the alignment points or lines are drawn.


Lanes Grid

Lanes Grid

The classes from the MindFusion.Diagramming.Wpf.Lanes namespace let you develop process maps and lane diagrams, useful in business process planning and reporting. Processes consist of consecutive operations accomplished by people involved, technical installations, means of contact, and flow of information. The MindFusion.Diagramming for WPF lane grid features allow indicating and arranging related diagram items in complicated processes and systems, that is, Swim lane diagrams (known as Rummler-Brache diagram), Gantt Charts (planning and scheduling of projects). A lane in the grid can visually contain nodes, links, shapes or images, that represent tasks fulfilled in specified periods of time by people, companies or departments.

The MindFusion.Diagramming.Wpf.Lanes namespace provides the Grid, Header, HeaderCollection and Style classes, the ICell interface and the ResizeType enumeration. These types expose additional properties and methods that let you define your own grids as required by your application logic. Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The cells color and style can be customized too.

Use the EnableLanes property of the Diagram class to display lanes in your application. The LaneGrid lets you setup the rows and columns in the grid by defining horizontal and vertical lanes, where each lane can be titled by its own header and/or subheadings. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth. The intersection of rows and columns can be either a simple cell for bottommost elements in the hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the grid class Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The CellBoundsChanged event is raised when a cell is resized. An application can handle this event in order to rearrange or resize nodes so that they stay within a specific column or row of the grid.

The position of the grid and grid headers within the diagram is defined via TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation via the RowHeadersWidths and ColumnHeadersHeights proeprties.

The appearance of the lanes grid can be customized further via the AlignCells property, which specifies whether cells are aligned to each other, the HeadersOnTop poperty, which specifies whether headers should appear on top of the Z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top-left corner.

The Grid class provides many miscalleaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing: FindColumn, FindRow, GetCellBounds, GetCellColumn, GetCellFromPoint, GetCellRow, GetColumn, GetRow, GetRowIndex, GetColumnHeaderBounds, GetColumnIndex, GetHeaderBounds, GetRowHeaderBounds, GetHeaderFromPoint.

The headers in the lanes grid can be customized by using the following properties of the Header class:

Property Name | Description
Height | Gets or sets the height of the header and the related row in the grid.
ResizeType | Gets or sets the resize type of the header.
RotateTitle | Gets or sets a value indicating whether rotating of the header caption at 90 degree is enabled.
Style | Gets or sets the style of the header.
SubHeaders | Gets a collection with the subheaders of the header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment format of the header.
Width | Gets or sets the width of the header and the related column in the grid.


Laying Out Diagrams Automatically

Laying Out Diagrams Automatically

Applications that process hierarchical or more complex entity-relationship data might need to present that data to end-users in an aesthetical and visually appealing manner. Such applications would store their data as graph of connected nodes possibly having additional information attached to them. However, position and size coordinates of nodes might be unnecessary and/or unavailable. MindFusion.Diagramming for WPF provides a way to automatically arrange the nodes of a diagram, applying attractive layouts on the overall structure of the diagram. To utilize that functionality, an application can create a diagram by assigning generic coordinates to its nodes, instantiating a layout object and invoking the layout's Arrange method. Non-blocking ArrangeAsync method is available in the .NET 4.5 build of diagramming.dll assembly. The Arrange methods can be prevented from changing positions of individual items by setting the IgnoreLayout property of those items to true.

The classes that implement automatic layout algorithms are located in the MindFusion.Diagramming.Wpf.Layout namespace. The following sections list the available algorithms categorized by their general implementation strategy: force-directed algorithms, graph topology based algorithms and semantics based algorithms.


Force-directed layout algorithms

Force-directed layout algorithms

Force-directed algorithms simulate forces acting between objects in the graph and iteratively run a physical simulation that pulls the objects closer or pushes them apart. At each iteration the energy associated with the simulated system decreases, and the node positions calculated by this process usually lead to evenly distributed nodes and uniform link lengths.

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling its Arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes and the number of iteration steps to use while calculating node positions. You can also specify that MindFusion.Diagramming for WPF tries to minimize link crossings. If you select that option, the algorithm would produce better result with more iteration steps. However, it needs more time to complete if more steps are specified. In VB.NET and C#, Spring-Embedder layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming.Wpf;
using MindFusion.Diagramming.Wpf.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
SpringLayout sl = new SpringLayout();
sl.IterationCount = 500;
sl.NodeDistance = 30;
sl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim sl As New SpringLayout()
sl.IterationCount = 500
sl.NodeDistance = 30
sl.Arrange(diagram)

End Sub

Grid Graph Layout

The GridLayout algorithm arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Grid layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming.Wpf;
using MindFusion.Diagramming.Wpf.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
GridLayout gl = new GridLayout();
gl.GridSize = 75;
gl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming.Wpf
Imports MindFusion.Diagramming.Wpf.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim gl As New GridLayout()
gl.GridSize = 75
gl.Arrange(diagram)

End Sub

Simulated Annealing Graph Layout

The AnnealLayout class implements the Simulated Annealing graph layout algorithm. Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. AnnealLayout assigns costs to graph configurations by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings. Thus the best configuration found will have good aesthetic properties.

Circular Graph Layout

CircularLayout distributes nodes evenly on the circumference of a circle at positions that result in as few link crossing as possible. Set its Radius property to specify the size of the layout circle. Set SiftingRounds to set the number of fine-tuning crossing-reduction iterations.


Topology based layout algorithms

Topology based layout algorithms

The following algorithms are based on the topological features of the graph being arranged, such as the size and adjacency of faces (a face is a region bounded by links) and the overall direction of links. The algorithms differ in the shape they apply to graph faces and the manner in which faces are embedded in the plane.

One-way Graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Topological Graph Layout

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as curves above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Orthogonal Graph Layout

The OrthogonalLayout class implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings. This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Orthogonal Router

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

Cascade Graph Layout

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Triangular Graph Layout

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.


Semantics based layout algorithms

Semantics based layout algorithms

The following algorithms arrange the diagram in a way that shows the semantics of individual items or the overall graph structure, such as hierarchical relations between objects, loops and decisions in flowcharts, assignments of nodes to layers or swimlanes.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout object and call its Arrange method. Members of TreeLayout control many aspects of the layout process. The type of layout can be directional or radial. You can choose how much space to leave between tree levels and between nodes on the same level. For directional layouts, the style of links in the arranged tree can be set to straight, orthogonal or curved. Global tree direction and alignment can be customized too. In VB.NET and C#, tree layout might be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming.Wpf;
using MindFusion.Diagramming.Wpf.Layout;

...

private void button1_Click(object sender, EventArgs e)
{
TreeLayout tl = new TreeLayout();
tl.Type = TreeLayoutType.Cascading;
tl.Direction = TreeLayoutDirection.LeftToRight;
tl.LinkStyle = TreeLayoutLinkType.Cascading2;
tl.LevelDistance = 10;
tl.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming.Wpf
Imports MindFusion.Diagramming.Wpf.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim tl As New TreeLayout()
tl.Type = TreeLayoutType.Cascading
tl.Direction = TreeLayoutDirection.LeftToRight
tl.LinkStyle = TreeLayoutLinkType.Cascading2
tl.LevelDistance = 10
tl.Arrange(diagram)

End Sub

Fractal Tree Layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. In C# and VB.NET, layered layout can be applied like this:

C# [image] Copy Code

using MindFusion.Diagramming.Wpf;
using MindFusion.Diagramming.Wpf.Layout;

...

private void btnArrange_Click(object sender, System.EventArgs e)
{
LayeredLayout ll = new LayeredLayout();
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal;
ll.SplitLayers = true;
ll.LayerDistance = 35;
ll.Arrange(diagram);
}

Visual Basic [image] Copy Code

Imports MindFusion.Diagramming.Wpf
Imports MindFusion.Diagramming.Wpf.Layout

...

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

Dim ll = New LayeredLayout()
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal
ll.SplitLayers = True
ll.LayerDistance = 35
ll.Arrange(Diagram)

End Sub

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Flowchart Graph Layout

FlowchartLayout recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Workflow Graph Layout

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MindFusion.Diagramming for WPF package demonstrate two sample sets of layout rules.

Swimlane Layout

SwimlaneLayout can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through a custom control template, or one composed of locked background nodes.

Hierarchical Graph Layout

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and not intersect. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.


Multi-level layout algorithms

Multi-level layout algorithms

Multi-level algorithms are used to arrange very large graphs quickly by running other layout algorithms on small parts of the original diagram. Since layout algorithms are usually of polynomial complexity, applying them on smaller subgraphs considerably reduces the overall running time. Multi-level algorithms typically construct a virtual graph that is coarse representation of the diagram, where each virtual node represents a set of actual nodes and links between them. Each set is arranged independently from the others, then the virtual graph is arranged too and the actual sets are placed at the positions of the virtual nodes.

Composite Graph Layout

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.


Link Routing

Link Routing

Routed links avoid nodes marked as obstacles by finding the shortest path between their origin and destination that does not cross any other nodes.

Setting Up a Link Router

The control finds paths for links affected by modifications of nearby nodes by calling methods of an object that implements the ILinkRouter interface. This object can be get or set through the LinkRouter property of the Diagram class. MindFusion.Diagramming for WPF provides two classes that implement ILinkRouter - GridRouter and QuickRouter. By default LinkRouter is set to a QuickRouter instance.

Automatic or Explicit Routing

The RouteAllLinks method can be invoked to explicitly rearrange links in a way they do not cross nodes. In addition, links have an AutoRoute property that enables or disables automatic routing of a link; that property is initialized from the diagram's RouteLinks member. The TriggerRerouting member of the RoutingOptions class specifies when links must be rerouted automatically.

Tuning the Routing Algorithm

When a GridRouter is used, the RoutingOptions class allows customizing various aspects of the routing algorithm. That algorithm evaluates possible paths aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path. The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links.


Anchor Points and Patterns

Anchor Points and Patterns

Anchor Points

For each node you can define one or more points to which links must dock when connecting to that node. Such points are represented by instances of the AnchorPoint class. The position of an anchor point relative to node's bounding rectangle is specified by the X and Y properties. Their values are expressed as percent of the node's width and height to accommodate for moving and resizing. The final location of an anchor point is determined by this simple calculation:

C# [image] Copy Code

return new PointF(
nodeRect.X + nodeRect.Width * X / 100,
nodeRect.Y + nodeRect.Height * Y / 100);

Visual Basic [image] Copy Code

Return New PointF( _
nodeRect.X + nodeRect.Width * X / 100, _
nodeRect.Y + nodeRect.Height * Y / 100)

A point's position can also be defined as a fixed offset from the node's top-left corner, letting you define anchor positions that do not depend on the node's width or height. This is controlled independently for X and Y coordinates, by means of the XUnit and YUnit properties.

You can control whether an anchor point accepts incoming or outgoing links or both. That is done by the AllowIncoming and AllowOutgoing properties. When a link is drawn, its ends are aligned to the nearest anchors allowing docking of the respective end type. Another way to control whether links can be connected to an anchor point is to handle the ValidateAnchorPoint event.

Anchor Patterns

An AnchorPattern instance defines a set of anchor points to be used together. When creating an anchor pattern, pass to its constructor an array of AnchorPoint objects. The AnchorPattern class exposes several predefined patterns as static properties. An existing pattern can be assigned as a single entity to the AnchorPattern property of nodes. The following example creates a pattern of four anchor points:

C# [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, true),
new AnchorPoint(100, 50, true, true),
new AnchorPoint(50, 100, true, true),
new AnchorPoint(0, 50, true, true)});

Visual Basic [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint() { _
new AnchorPoint(50, 0, true, true), _
new AnchorPoint(100, 50, true, true), _
new AnchorPoint(50, 100, true, true), _
new AnchorPoint(0, 50, true, true) })

The points are located at the middles of bounding rectangle sides of nodes to which the pattern is assigned. All four points accept both incoming and outgoing links.

Anchor Patterns and Tables

A distinct anchor pattern can be assigned to every row of a table. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

Anchor Points and User Interaction

By default, a link is attached to an anchor point only when the link is created. Afterwards, the user can move the link end to any part of the node. To ensure that links always stay attached to an anchor point even after subsequent modifications done by the user, set the SnapToAnchor property to CreateOrModify. You can prevent the user from attaching specific links to specific anchor points by handling the ValidateAnchorPoint event.

Setting Anchor Point Programmatically

You can connect a link to a specific anchor point by setting the link's OriginAnchor and DestinationAnchor properties to the index of the point in the respective node's AnchorPattern. The ReassignAnchorPoints method of DiagramLink automatically chooses anchor points of the origin and destination nodes that are close to each other, so that the link takes a shorter path between the nodes. The ReassignAnchorPoints method of DiagramNode sets the anchor point of each link connected to the node so that links are evenly distributed among the available anchor points.


Undo and Redo

Undo and Redo

The following topics are contained within this topic:

Overview
Introduces to the MindFusion.Diagramming for WPF undo system.

Actions and Commands
Previews the available actions on a diagram and their associated undo/redo commands.

Undo Manager
Introduces the UndoManager class.

Command History
Information about the command history where all previously executed commands are stored.

Undo or Redo of Property Changes
Information on how to undo/redo changes in diagram item properties.

Composite Commands
Demonstrates how to encapsulate a set of commands as a single command that can be undone as an atomic operation.

Subclassing the Command Class
Information on how to create custom commands.


Overview

Overview

Interactive actions, carried out by users, and programmatic commands that change the structure of a diagram are recorded in a history queue. While action records are still in that queue, the actions can be undone or redone. The queue has a fixed length - if it gets full, recording a new action makes the oldest one drop from the queue.

Undo is disabled by default. To enable it, set the UndoEnabled property to true. To undo or redo an action, call the Undo or Redo methods of UndoManager. MindFusion.Diagramming for WPF does not provide keyboard shortcuts for undo/redo. Your application must have its own menu items and/or keyboard accelerators to provide the necessary user interface, and invoke the respective methods in response to UI events.

MindFusion.Diagramming for WPF automatically saves the following types of actions for later undo/redo:

  • adding an item to the diagram
  • removing an item from the diagram
  • moving or resizing items
  • creating a group
  • destroying a group
  • expanding or collapsing trees
  • scrolling table rows
  • adding or removing tables' rows

Changes to property values are not saved automatically in the history. If your application must be able to undo/redo property changes, use the ChangeItemCmd command. ChangeItemCmd allows recording several property changes as an atomic undoable action.

In some cases you may need to create your own types of actions or commands. For example, suppose you need to implement undo/redo for changes made to the Tag property of items or changes to controls embedded in ControlNode items. However, MindFusion.Wpf Package is not able to detect such changes, so it cannot undo them. To enable undo/redo you would have to create a subclass of Command and implement its Execute, Undo and Redo methods.


Actions and Commands

Actions and Commands

Undoable interactive actions and programmatic commands that can be carried out by MindFusion.Diagramming for WPF are represented by Command subclasses. The Command class provides the necessary interface to Execute, Undo or Redo actions. In some cases you will have to implement these methods in derived classes, but you must not call them directly. Use the Undo or Redo methods of the UndoManager to undo or redo a command. The UndoManager methods call the respective Command methods and in addition update the state of the command history and the Diagram.

The following MindFusion.Diagramming for WPF classes are derived from Command:

Command | Description
AddItemCmd | Adds a new item to the diagram.
RemoveItemCmd | Removes an item from the diagram.
AddGroupCmd | Creates a new hierarchical group.
RemoveGroupCmd | Destroys a group.
GroupAttachCmd | Attaches an item to a group.
GroupDetachCmd | Detaches an item from a group.
ModifyItemCmd | Moves or resizes an item.
RedimTableCmd | Change number of table's columns or rows.
ExpandItemCmd | Expands or collapses a tree of items.
ScrollTableCmd | Scrolls table's rows.
ExpandHeaderRowCmd | Expands or collapses tables sections.
ChangeItemCmd | Handles undo/redo of item property changes.
CompositeCmd | Allows several actions to be undo and redone at the same time.

Instances of most of these classes are created implicitly by MindFusion.Diagramming for WPF in response to users' actions or method calls. You might need to explicitly instantiate only ChangeItemCmd - to undo or redo property changes - and CompositeCmd - to present several actions as single undoable operation.

The data of your application might be tightly integrated in MindFusion.Diagramming for WPF diagrams, for example by Tag objects or .NET controls embedded in ControlNode items. In these cases MindFusion.Diagramming for WPF cannot detect, undo or redo changes to your data. To enable undo of such changes, you must inherit the Command class and implement your versions of the Execute, Undo and Redo methods. To record your own action in the undo/redo history, call the ExecuteCommand method of the Diagram class.


Undo Manager

Undo Manager

The undo manager acts as a mediator between commands, the diagram and the command history. It is represented by the UndoManager class, whose only instance can be accessed by the Diagram's UndoManager property.

By default, undo functionality is disabled - commands are executed, but are not recorded in history for later undo or redo. To enable undo, set UndoEnabled to true. You might need to disable undo before executing actions you don't want end-users to undo, for example creating special start/end nodes. Another situation in which you might want to disable undo is when creating programmatically a lot of new diagram items - say hundreds or thousands. MindFusion.Diagramming for WPF creates an undo record for each item creation; if the Capacity of the command history is smaller than the number of items created, most of the records will drop from the history queue while adding new ones. That would waste processing power and memory for creating undo records that won't be used.

As an alternative, you can create a composite record by calling StartComposite. All subsequent create-item actions are saved in the composite. The composite is saved in the undo history as a single record that allows undo or redo of all constituent actions as a single operation. StartComposite creates and returns a CompositeCmd instance, which is marked as active composite in the undo manager. While there is an active composite, all actions that are carried out are added to it. Call the Execute method of the active composite to stop recording subcommands in it and save it in the history as atomic undoable operation.

Use the Undo and Redo methods of the undo manager to undo or redo actions. Do not call the respective methods of the Command class - they are called internally by the undo manager, and in addition the current command history position is updated and the diagram view is repainted.


Command History

Command History

The undo/redo history is represented by a CommandHistory instance. That instance is created by the UndoManager and can be accessed by its History property.

The undo manager adds commands to the history after executing them. If the history queue is full, the oldest command records are removed when new ones are added. Use the Capacity property of CommandHistory to specify how many action records to keep in the queue.

The history has a current-command pointer indicating which are the next commands to undo or redo. If a command is undone, the current pointer in the history queue is moved back and allows undoing even older actions. If the current pointer is not at the last record, any newer commands can be redone again. Each time an action is undone or redone, respectively an ActionUndone or ActionRedone event is fired.

To query which are the next commands to be undone or redone, use the NextUndo and NextRedo read-only properties. They return the Command instances contained in the queue which are referred by the current position pointer. If no further undo or redo is possible, the properties return null (Nothing in Visual Basic). You might use them to indicate to end-users which are the next commands to undo/redo.

C# [image] Copy Code

if (diagram.UndoManager.History.NextUndo == null)
{
// Everything has been undone
miUndo.Enabled = false;
miUndo.Text = "Undo";
}
else
{
if (diagram.UndoManager.History.NextUndo is AddItemCmd)
{
// The next action to undo is item-creation
miUndo.Enabled = true;
miUndo.Text = "Undo Create";
}
}

Visual Basic [image] Copy Code

If Diagram.UndoManager.History.NextUndo Is Nothing Then

' Everything has been undone
miUndo.Enabled = False
miUndo.Text = "Undo"

Else

If TypeOf Diagram.UndoManager.History.NextUndo Is AddItemCmd Then

' The next action to undo is item-creation
miUndo.Enabled = True
miUndo.Text = "Undo Create"

End If

End If

To ban end-users from undoing last commands, clear the command history by invoking the Clear method. It is possible to filter some commands so they are not recorded in the history by handling the ActionRecording event.


Undo or Redo of Property Changes

Undo or Redo of Property Changes

Changes to item properties are not recorded automatically for later undo. To enable undo of property changes, you must explicitly create a ChangeItemCmd instance and add it to the history queue.

The ChangeItemCmd constructor requires a reference to an item as argument and saves the item's initial state to be restored by later Undo. Call the Execute method after one or more assignments to item's properties. Execute records the final state of the item to be restored by later Redo. This allows changes to several properties of an item to be saved within a single record, which can be undone or redone as a single operation:

C# [image] Copy Code

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(diagram.Nodes[0], "Change");

// Change properties
ShapeNode shape = (ShapeNode)diagram.Nodes[0];
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);
shape.Shape = Shape.FromId("Ellipse");

// Add to history
propChange.Execute();

Visual Basic [image] Copy Code

' Save item state
Dim propChange = New ChangeItemCmd(Diagram.Nodes(0), "Change")

' Change properties
Dim shape As ShapeNode = Diagram.Nodes(0)
shape.Text = "new text"
shape.Brush = New SolidBrush(Color.Blue)
shape.Shape = MindFusion.Diagramming.Shape.FromId("Ellipse")

' Add to history
propChange.Execute()

You might need to treat changes to several items as an atomic operation. To do so, create a CompositeCmd instance and add the ChangeItemCmd commands to the composite by the AddSubCmd method:

C# [image] Copy Code

if (diagram.Selection.Nodes.Count == 0)
return;

// Make all changes seem like a single operation by
// putting them in composite Command
CompositeCmd composite = new CompositeCmd(
diagram, "Change selection");

foreach (DiagramNode node in diagram.Selection.Nodes)
{
ShapeNode shape = node as ShapeNode;
if (shape == null)
continue;

// Save item state
ChangeItemCmd propChange = new ChangeItemCmd(shape, "Change");

// Change properties
shape.Text = "new text";
shape.Brush = new SolidBrush(Color.Blue);

// Add to the composite
composite.AddSubCmd(propChange);
}

// Store final state of all contained commands
composite.Execute();

Visual Basic [image] Copy Code

If diagram.Selection.Nodes.Count = 0 Then
Return
End If

' Make all changes seem like a single operation by
' putting them in composite Command
Dim composite As CompositeCmd = New CompositeCmd( _
diagram, "Change selection")

Dim node As DiagramNode
For Each node In diagram.Selection.Nodes

Dim shape As ShapeNode = CType(node, ShapeNode)
If Not shape Is Nothing Then

' Save item state
Dim propChange As ChangeItemCmd = New ChangeItemCmd(shape, "Change")

' Change properties
shape.Text = "new text"
shape.Brush = New SolidBrush(Color.Blue)

' Add to the composite
composite.AddSubCmd(propChange)

End If

Next

' Store final state of all contained commands
composite.Execute()


Composite Commands

Composite Commands

Sometimes you might prefer having a set of actions undo and redo as a single atomic operation. MindFusion.Diagramming for WPF provides the CompositeCmd class to help you with that. CompositeCmd objects act as containers of other Command-derived objects. When Undo or Redo are invoked on a composite command, all its subcommands are respectively undone or redone.

To add a command to the composite call the AddSubCmd method. Call Execute to execute all subcommands contained in the composite. Subcommands are executed or redone in the same order in which they were added to the container, and are undone in the opposite order.

Often MindFusion.Diagramming for WPF implicitly generates Command objects in response to users actions or method calls, and automatically records them in the history queue. You do not have direct access to those commands and cannot add them to a composite by AddSubCmd. To enable creating composites in such cases, the undo manager provides the notion of active composite. Active composite is created by calling the StartComposite function of UndoManager. Each action executed after that is made part of the composite, instead of adding it directly to the command history. Invoking the Execute method of the current composite completes it and saves it in the history queue.

C# [image] Copy Code

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode (0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();

Visual Basic [image] Copy Code

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = Diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = Diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = Diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = Diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()


Subclassing the Command Class

Subclassing the Command Class

MindFusion.Diagramming for WPF diagrams can be just a part of the data model of your application, which might already have undo/redo functions implemented for its native data. To integrate MindFusion.Diagramming for WPF undo functionality into the application's undo mechanism, use the ActionRecorded event. When the event is fired, add a corresponding wrapper-record to your application's history from the event handler. The wrapper could just call Undo and Redo methods of the UndoManager. In such situations make sure the MindFusion.Diagramming for WPF's history Capacity is at least as big as your application's.

Another possibility is to reuse MindFusion.Diagramming for WPF's undo functionality by subclassing Command and creating classes responsible for changes in your application's data. When a change occurs outside the diagram, it can still be recorded by the Diagram's ExecuteCommand method and integrated into MindFusion.Diagramming for WPF's command history.

A simpler scenario when you might have to subclass Command is using complex objects as tags or embedding controls in ControlNode instances. Actions that change these objects or controls cannot be detected and handled automatically by MindFusion.Diagramming for WPF. To integrate such an action into the diagram's undo history, you must create a Command instance that knows how to carry out, undo or redo the action.

Command subclasses must implement Execute, Undo and Redo methods. Actions represented by your subclass must be carried out by executing the ExecuteCommand method of Diagram. ExecuteCommand invokes Execute on the command passed as argument, which is then added to the history queue and whose Undo and Redo methods can be called multiple times later by the undo manager. Usually you can implement Redo as a call to Execute, but if the latter is time consuming, its result state can be saved in an instance member and restored by Redo.

Do not call the Undo and Redo methods of your class directly, just implement them and they will be invoked by UndoManager's Undo or Redo methods when necessary.

The example below shows a simple implementation of Command methods:

C# [image] Copy Code

public class PersonTag
{
public string Name;
public string Address;

// And so on
...
}

public class AddressChangeCmd : Command
{
public AddressChangeCmd(PersonTag p, string address) :
base("Address change")
{
this.p = p;
this.oldAddress = p.Address;
this.newAddress = address;
}

public override void Execute(bool undoEnabled)
{
p.Address = newAddress;
}

public override void Undo()
{
p.Address = oldAddress;
}

public override void Redo()
{
// Undo manager is enabled if Redo is called
// so pass true for the undoEnabled argument
Execute(true);
}

private PersonTag p;
private string oldAddress;
private string newAddress;
}

...

// Somewhere in later code
PersonTag tag = (PersonTag)diagram. ActiveItem.Tag;
AddressChangeCmd cc = new AddressChangeCmd(tag, "far far away");
diagram.ExecuteCommand(cc);

Visual Basic [image] Copy Code

Public Class PersonTag

Public Name As String
Public Address As String

' And so on
...

End Class

Public Class AddressChangeCmd
Inherits Command

Public Sub New(ByVal p As PersonTag, ByVal address As String)

MyBase.New("Address change")

Me.p = p
Me.oldAddress = p.Address
Me.newAddress = address

End Sub

Protected Overrides Sub Execute(ByVal undoEnabled As Boolean)

p.Address = newAddress

End Sub

Protected Overrides Sub Undo()

p.Address = oldAddress

End Sub

Protected Overrides Sub Redo()

' Undo manager is enabled if Redo is called
' so pass true for the undoEnabled argument
Execute(True)

End Sub

Private p As PersonTag
Private oldAddress As String
Private newAddress As String

End Class

...

' Somewhere in later code
Dim tag As PersonTag = CType(diagram.ActiveItem.Tag, PersonTag)
Dim cc As AddressChangeCmd = New AddressChangeCmd(tag, "far far away")
diagram.ExecuteCommand(cc)


Diagram Serialization and Output

Diagram Serialization and Output

The following topics are contained within this topic:

Serializing Diagrams
Provides information on how to serialize and deserialize diagrams to and from XML.

Exporting the Diagram
Detailed information about all formats that the diagrams can be exported to.

Printing and Print Preview
Information on how to print and preview diagrams.


Serializing Diagrams

Serializing Diagrams

XML Serialization

It is possible to save a diagram as an XML document. To do that, call the SaveToXml method of the Diagram class. To deserialize a diagram back from its XML representation, call the LoadFromXml method.

Custom item classes can implement XML serialization for their additional properties by overriding the SaveToXml and LoadFromXml methods. In addition, such classes must specify a string to use as their identifier in the XML document by calling RegisterItemClass.

The control raises SerializeTag and DeserializeTag to enable serialization of complex Id and Tag objects without overriding the item classes. The PropertyName event argument specifies which property is being serialized.


Exporting the Diagram

Exporting the Diagram

Exporting Images

You can create a static image representing the current diagram using the CreateImage method. The method returns an instance of the BitmapSource class. The following example shows how to export a diagram to a Png image file in response to a menu item click, using the SaveFileDialog control where the location is selected and the name of the image file is entered:

C# [image] Copy Code

private void OnExportImage(object sender, RoutedEventArgs e)
{
// Configure save file dialog box
var dlg = new SaveFileDialog
{
FileName = "Diagram",
DefaultExt = ".png",
Filter = "Diagram Files (.png)|*.png"
};

// Show save file dialog box
var result = dlg.ShowDialog();

// Process save file dialog box results
if (result == true)
{
var encoder = new PngBitmapEncoder();
encoder.Frames.Add(BitmapFrame.Create(diagram.CreateImage(100)));

using (var stream = new FileStream(dlg.FileName, FileMode.Create))
encoder.Save(stream);
}
}

The MindFusion.Diagramming.Wpf.Export Namespace contains classes for exporting to Dxf, Pdf, Svg and Visio formats.

Exporting to PDF

Add references to the MindFusion.Diagramming.Wpf.PdfExport.dll and MindFusion.Pdf.dll assemblies to your project. Create a PdfExporter instance and call its Export method. Margins specifies the page margins for all pages in the document. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. The AutoScale property allows scaling the diagram to fit in one or more PDF pages. If invisible items should be displayed in the PDF, enable the InvisibleItems property. The following example shows how to export a diagram to a Pdf file in response to pressing a button event and using the SaveFileDialog control where the location is selected and the name of the Pdf file is entered:

C# [image] Copy Code

private void OnExportPdf(object sender, RoutedEventArgs e)
{
// Configure save file dialog box
var dlg = new SaveFileDialog
{
FileName = "Diagram",
DefaultExt = ".pdf",
Filter = "Diagram Files (.pdf)|*.pdf"
};

// Show save file dialog box
var result = dlg.ShowDialog();

// Process save file dialog box results
if (result == true)
{
PdfExporter pdfex = new PdfExporter();
pdfex.PageSize = MindFusion.Pdf.PageSize.DiagramSize;
pdfex.PageOrientation = MindFusion.Pdf.PageOrientation.Portrait;
pdfex.Margins = new Thickness(48, 48, 48, 48);

pdfex.Export(diagram, dlg.FileName);
}
}

Exporting to SVG

Add references to the MindFusion.Diagramming.Wpf.SvgExport.dll and MindFusion.Svg.dll assemblies to your project. Create an SvgExporter instance and call its Export method, passing a Diagram object and the full path to the .svg file as parameters. To export images displayed by diagram items to external files, enable the ExternalImages property.

C# [image] Copy Code

var svgExp = new SvgExporter();
svgExp.ExternalImages = false;
svgExp.Export(diagram, dlg.FileName);

Exporting WMF images

Add a reference to the MindFusion.Diagramming.Wpf.WmfExport.dll assembly to your project. Create a WmfExporter instance and call its Export method, passing a Diagram object and the full path to the .wmf file as parameters.

Exporting Visio drawings

In order to enable Visio export, add a reference to the MindFusion.Diagramming.Wpf.VisioExport.dll to your project. Create a new instance of the VisioExporter class and call its Export method passing a Diagram object and the full path to the exported Visio .vdx file as parameters. The Visio page dimension and items size measure unit is set to the diagram's MeasureUnit.

ShapeNode objects are mapped to their closest Visio counterparts and TableNode objects are exported as groups of Visio shapes. DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

The exporter object requires the VisioExport.vxt file to be present in the application's directory. This file contains an XML template data used by the component to generate Visio documents.

To create Visio groups from the WpfDiagram groups, enable the CreateVisioGroups property. If a shape node that contains an image should be exported as a Visio group of a shape, picture and text objects, use the ExportImagesAsGroups property set to true by default. ExportInvisibleItems allows exporting of invisible items. If TableNode objects should be exported as groups of Visio rectangular shapes, enable the ExportTablesAsGroups property.

The following example shows how to export a diagram to a Visio file in response to choosing a File > Export to > Visio menu item and using the SaveFileDialog control where the location is selected and the name of the Visio file is entered:

C# [image] Copy Code

private void OnExportVisio(object sender, RoutedEventArgs e)
{
var dlg = new SaveFileDialog();
dlg.Filter = "Visio files (*.vdx)|*.vdx|All files|*.*||";

if (dlg.ShowDialog(this) == true)
{
var visioExporter = new VisioExporter();
visioExporter.Export(diagram, dlg.FileName);
}
}

Export Excel files

The ExcelExporter class from MindFusion.Diagramming.Wpf.ExcelExport.dll assembly exports diagrams to Excel Open XML Format (XLSX) files. Diagrams are exported as Excel AutoShapes drawings. The Export overload that takes a DiagramDocument parameter creates a sheet for each DiagramPage in the document. The Export(Diagram) overload creates a single Excel sheet.


Printing and Print Preview

Printing and Print Preview

You can print a Diagram using the standard WPF printing facilities. The DocumentPaginator property lets you print a multiple-page diagram. The following example shows how to use it:

C# [image] Copy Code

PrintDialog pd = new PrintDialog();

if (pd.ShowDialog())
pd.PrintDocument(diagram.DocumentPaginator, "my diagram");

As a shortcut, WpfDiagram provides the Print and PrintPreview methods, which use DocumentPaginator internally to print the diagram content, or to preview how it would look when printed.


Appearance

Appearance

The following topics are contained within this topic:

Styles and Themes
Provides information on how to use styles and themes.

Node Effects
Information on how to apply the built-in node effects.

Modifying WpfDiagram Appearance
General options affecting the appearance of a MindFusion.Diagramming for WPF diagram.

Customizing the Appearance of Items
Information about how to modify various aspects of the appearance of individual diagram items.

User Defined Node Shapes and Custom Drawing
Information on how to define arbitrary node shapes as well as how to use custom-drawing.

Text Attributes and Formatting
Provides information on how to customize the text of diagram items and lists all possible formatting tags.


Styles and Themes

Styles and Themes

The style and theme system provides a consistent way to customize the appearance of a Diagram and its items. By using styles and themes, it is easier to achieve coherent look and feel across the entire diagram. In addition, changing the look and feel can be achieved by simply replacing the current theme. New themes can be designed in the visual environment of the Theme Editor tool and subsequently used and distributed as XML files. Several pre-defined theme files are installed under the Themes subfolder of the control's root installation folder.

Styles

MindFusion.Diagramming for WPF styling system uses regular WPF Style objects. To apply a style to an individual diagram item set the style to the item's Style property - the same way you would apply a style to a regular FrameworkElement object. All rules that apply to the WPF Style objects are in effect here as well. For example, you can define a Style as a resource, then reference this resource from diagram items declared in XAML. To apply a style for all items of a particular type, define a Style object within the current scope with its TargetType set to the appropriate type. Alternatively you can use a Theme (see the following section).

Themes

The theme in MindFusion.Diagramming for WPF is a set of styles, each associated with specific item type. When the theme is applied to a diagram, the styles registered in the theme affect all objects of their associated type.

Themes are represented by the Theme class and can be assigned to Diagram objects through the Theme property. Styles are associated with types within the theme through the RegisterStyle method. The following code creates a new theme, with a single style for ShapeNode items and applies this theme to an existing diagram.

C# [image] Copy Code

Theme theme = new Theme();
Style style = new Style();
style.Setters.Add(new Setter(ShapeNode.FontFamilyProperty, new FontFamily("Courier New")));
theme.RegisterStyle(typeof(ShapeNode), style);
diagram.Theme = theme;

VB.NET [image] Copy Code

Dim theme As New Theme()
Dim style As New Style()
style.Setters.Add(New Setter(ShapeNode.FontFamilyProperty, New FontFamily("Courier New")))
theme.RegisterStyle(GetType(ShapeNode), style)
diagram.Theme = theme

Alternatively, themes can be loaded from XML files by calling the LoadFromXml method. Such XML files can be produced by the Theme Editor tool, or by calling the SaveToXml method of an existing theme.

Another way to implicitly register styles with themes is through a set of shortcut properties exposed by the Diagram class, namely DiagramLinkStyle, ShapeNodeStyle, TableNodeStyle, ContainerNodeStyle, and TreeViewNodeStyle. Setting any of these properties automatically registers the property value as a style within the currently associated theme. These properties are particularly useful for specifying styles through XAML. The following example illustrates this:

XAML [image] Copy Code

<d:Diagram xmlns:d="http://mindfusion.eu/diagramming/wpf">
<d:Diagram.ShapeNodeStyle>
<Style TargetType="d:ShapeNode">
<Setter Property="Stroke" Value="Green" />
</Style>
</d:Diagram.ShapeNodeStyle>
</d:Diagram>

Theme Editor

The Theme Editor provides simple visual environment for theme creation and modification. The editor displays a sample diagram with items of various types and exposes a list of all style properties through a property grid to the left. Any modification of the style properties in the grid is immediately reflected on the diagram to give a preview on what effect the change would have if the theme is applied to a diagram. The theme can be saved at any time through the Save menu. Existing themes can be opened and modified.

The following image illustrates the Theme Editor in action:


Node Effects

Node Effects

To apply an effect to the nodes in a diagram, create an instance of one of the effect classes and add this instance to the Diagram.NodeEffects collection. To apply the effect to individual nodes, add the instance to the node's Effects collection. To discard the diagram effects for a particular node, add a null reference (Nothing in Visual Basic) at position 0 in the node's Effects collection. Effects can also be applied through styles by using the DiagramNode.EffectsSource and Diagram.NodeEffectsSource dependency properties.

It is possible to combine different effects by adding instances of their appropriate types to the effect collections. If is also admissible to apply more than one effect of the same type.

The currently supplied effect types are Aero and Glass. They are examined in more details in the sections below.

Aero Effect

The Aero effect is represented by the AeroEffect class. The effect is designed to roughly resemble the Aero theme of Windows. More specifically, the effect adds semi transparency to the nodes, a smooth shade at the outside and a thin inset stroke. The semi transparency is specified through the Opacity property. Opacity varies from 0 to 1 inclusive, where 0 indicates full transparency and 1 indicates the original node color. The semi transparency is applied only on the node brush. The colors of the shade and the inner stroke are specified through the ShadeColor and InnerOutlineColor properties respectively. The following image illustrates how these properties affect the output:

The following example applies the Aero effect on the nodes of an existing diagram:

C# [image] Copy Code

AeroEffect effect = new AeroEffect();
effect.Opacity = 0.5;
effect.InnerOutlineColor = Color.FromArgb(100, 255, 255, 255);
diagram.NodeEffects.Add(effect);

Visual Basic [image] Copy Code

Dim effect As New AeroEffect()
effect.Opacity = 0.5
effect.InnerOutlineColor = Color.FromArgb(100, 255, 255, 255)
diagram.NodeEffects.Add(effect)

Tips

  • The Aero effect works very well in scenarios with overlapping nodes or in cases where the background is more complex than solid color, due to the effect of semi transparency.
  • Aero combines well with the Glass effect. There are some examples at the end of this topic.
  • The ShadeColor is usually black or another dark color. However, some nice glow effects can be achieved by setting bright ShadeColor on a diagram with dark background.
  • The Aero effect can impact performance if there are many nodes visible in the diagram.

Glass Effect

The Glass effect is represented by the GlassEffect class. The Glass effect adds visuals on top of the nodes in order to give the impression of a reflective surface. There are several variations of this effect, which can be selected through the Type property. The color of the reflection and the ambient color can be specified through the ReflectionColor and GlowColor properties respectively. When UsePenAsGlow is set to true the color of the node's pen is used as the ambient color. The following image illustrates the differences between the distinct effect types:

The following example applies a Glass effect with the default settings to the nodes of a diagram:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())

Tips

  • The GlowColor is usually white. However, for Type4 glass effects it is often more suitable to use black glow.
  • The Glass effect combines well with the Aero effect. There are some examples at the end of this topic.
  • Several glass effects of different types can be applied simultaneously for emphasized effect.

Examples

The values of the effect properties are usually selected in accordance with the color scheme of the target diagram and the desired end result. In addition different types of effects can be applied simultaneously to achieve more interesting results. The examples below demonstrate possible effect combinations in various color contexts.

Aero & Glass (Dark on Light)

In this example the Aero and Glass effects are combined. The Aero effect is useful in scenarios when dark nodes are placed on light background or vice versa, in order to emphasize the contrast.

Here is the code that applies the above effects:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())
diagram.NodeEffects.Add(New AeroEffect())

Aero & Glass (Light on Dark)

This example is similar to the first one, only this time the nodes are painted in light colors and the background is dark.

Here is the code that applies the above effect:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type3;
diagram.NodeEffects.Add(glassEffect);
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type3
diagram.NodeEffects.Add(glassEffect)
diagram.NodeEffects.Add(New AeroEffect())

Glow Effect

This example uses bright colors on black background to create a glow effect. The example utilizes an Aero effect with ShadeColor set to the color of the nodes' pens.

Here is the code that applies the above effects:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type2;
glassEffect.UsePenAsGlow = true;
diagram.NodeEffects.Add(glassEffect);
AeroEffect aeroEffect = new AeroEffect();
aeroEffect.Opacity = 0;
aeroEffect.InnerOutlineColor = Colors.Black;
aeroEffect.ShadeColor = Color.FromArgb(255, 128, 255, 255);
diagram.NodeEffects.Add(aeroEffect);

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type2
glassEffect.UsePenAsGlow = True
diagram.NodeEffects.Add(glassEffect)
Dim aeroEffect As New AeroEffect()
aeroEffect.Opacity = 0
aeroEffect.InnerOutlineColor = Colors.Black
aeroEffect.ShadeColor = Color.FromArgb(255, 128, 255, 255)
diagram.NodeEffects.Add(aeroEffect)


Modifying the Diagram Appearance

Modifying the Diagram Appearance

You can customize most of MindFusion.Diagramming for WPF visualization effects.

Background

The Diagram background area can be filled using a solid brush, gradient, texture or color patterns, by setting the BackBrush property. Background theme can also be an image set by the BackgroundImage property. The image can be any from the supported by the .NET System.Drawing.Image file formats - metafiles, icons, bitmaps, jpegs or gifs. Background image can be centered, aligned to a corner of the control or document, tiled or stretched to cover the drawing area - depending on the BackgroundImageAlign property value. It is possible to paint the area outside Bounds using a distinct brush by setting the ExteriorBrush property.

Shadows

Unlike the ActiveX and Windows Forms versions of the control, MindFusion.Diagramming for WPF does not provide a built-in shadow rendering. Instead, it relies on the WPF Effect classes for rendering shadows and other visual effects, such as blur. To enable any of these effects, set the Effect property of items to an instance of an Effect -derived class.

Selection

The style of selection handles drawn around the active item can be set through the ActiveItemHandlesStyle compound property. Items in multiple selection have their handles drawn using the style specified through the SelectedItemHandlesStyle property. Disabled manipulation handles are painted using DisabledHandlesStyle when ShowDisabledHandles is enabled (see EnabledHandles). The Style property of the Selection class controls the way multiple-selection is displayed.

Mouse Cursors

Different mouse cursor icons can be set to give context-sensitive feedback to users, prompting them if creation/modification of an item is possible. The following properties specify what cursors are displayed at different situations: PointerCursor, MoveCursor, DisallowCursor, DrawLinkCursor, AllowLinkCursor, DisallowLinkCursor, HorizontalResizeCursor, VerticalResizeCursor, DiagonalResizeCursor, CounterDiagonalResizeCursor. MindFusion.Diagramming for WPF displays the PanCursor while panning the diagram view. Set the OverrideCursor property if you need to set a cursor that does not depend on the current context.

Grid Settings

An alignment grid is drawn if the ShowGrid is set to true. The GridPen property specifies the pen used to draw grid points and lines.


Customizing the Appearance of Items

Customizing the Appearance of Items

For every MindFusion.Diagramming for WPF item, different visual styles and properties can be set as described in the following paragraphs.

Styling

Diagram items can be styled using the WPF styling system. The Style property inherited from FrameworkElement can be set to an instance of the System.Windows.Style class that sets the Brush, Stroke*, Text* and Font* dependency properties. If a style is not explicitly assigned to an item, it can use global styles defined for a type in the application or window resource dictionaries. For example, if this style is defined as a window resource, ShapeNodes will have a thick red border:

Xaml [image] Copy Code

<Style TargetType="diag:ShapeNode" >
<Setter Property="Stroke" Value="Red"/>
<Setter Property="StrokeThickness" Value="5"/>
<Setter Property="Brush" Value="LightYellow" />
</Style>

Since style setters have lower precedence than local property values, styling works immediately only for items created through no-args constructors. Properties of items loaded from a file or created through a DiagramItem(Diagram) constructor might have local values, which can be cleared through the ClearStyleableProperties method in order to enable styling.

Pen Width and Style

The borders of nodes and the lines of links are drawn using a pen whose color, width and style can be customized through the Stroke, StrokeThickness and StrokeDashStyle properties.

Color of Diagram Elements

The color of link segments can be set using the Stroke property. Brush specifies how closed arrowhead shapes are filled. Nodes have similar properties for color customization: the color of node borders is specified through the Stroke property; the interior of a node is filled using Brush.

Text

Diagram items can have associated text, displayed inside or over them. It can be set through the Text property of the base DiagramItem class. TextBrush specifies the brush used to draw the item's text.

The text of shape nodes can be laid out and rendered inside a polygonal outline; that depends on the value of PolygonalTextLayout. To make a node big enough to display its text without clipping, call ResizeToFitText. Links have their text drawn horizontally above their middle segment or rotated as specified by TextStyle.

All diagram items expose FontFamily, FontStyle and FontSize properties, specifying the name, style and size of the font of item's text. Text is formatted through properties such as TextAlignment, TextTrimming and TextWrapping.

Images

Shape nodes and tables can display images inside them. Use ShapeNode.Image and TableNode.Image properties to load images into the respective items. A node can be made the same size as the image it contains by calling ResizeToFitImage.

Images can be positioned in different ways: they can be tiled, stretched or aligned to the containing nodes' centers or sides. Use ShapeNode.ImageAlign and TableNode.ImageAlign to specify how images are placed within the corresponding nodes. An image shown inside a node is clipped in accordance with the shape of that node.

Table cells can have Image and ImageAlign assigned too. For example that might be used to display an icon for the key field of a database table.

Effects

WPF shader effects such as drop shadows and blur can be applied to diagram items through their Effect property. The Effect dependency property is defined in the base UIElement class from which DiagramItem is derived. For more information on shader effects, check the Effect topic in the MSDN library.

Note

The DefaultEffect property of the Diagram class allows to specify an effect that must be assigned to all new items.

DiagramLink-specific Properties

The shape and orientation of link segments is specified by the Shape property; the number of segments is specified by the SegmentCount property. The form and size of the arrowhead shape is set using the HeadShape and HeadShapeSize properties. Shapes displayed at the origin of links are defined by BaseShape and BaseShapeSize. Shapes can be displayed at middles of segments, helping to follow the path of long links. They are defined by the IntermediateShape and IntermediateShapeSize properties. The lines of arrowhead shapes are painted using the HeadPen pen. Custom painting code may be invoked for a link, as set in CustomDraw.

Rounded Links

Links comprising straight segments, that is, ones whose Shape is set to Polyline or Cascading, can use arcs to join their adjacent segments. To enable that feature, set RoundedLinks to true. Use RoundedLinksRadius to set the radius of the joining arcs.

Link Crossings

Intersection points where links cross their paths can be rendered as arcs or breaks, as specified by LinkCrossings. It depends on the Z-order, which links jump over the others, or which links appear cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, links at lower Z position are cut by links at higher Z. Radius of arcs and breaks can be set through the CrossingRadius property.

ShapeNode-specific Properties

The shape of a node is defined using its Shape property. Shape templates can be applied to a shape node with an orientation of 0/90/180/270 degrees as specified through the ShapeOrientation property. Your own drawing code may be invoked for a node, depending on the value of CustomDraw. Shape nodes can be marked as Transparent, having only their text or images rendered.

TableNode-specific Properties

The outline of a table can be either a rectangle or rounded rectangle, as specified by the Shape property. The borders of table cells can be rendered in different ways, depending on the value of CellFrameStyle. The table caption area is painted using the CaptionBackBrush brush. Custom painting can be performed on a table and its cells as set in the CustomDraw and CellCustomDraw properties.


User Defined Node Shapes and Custom Drawing

User Defined Node Shapes and Custom Drawing

The appearance of MindFusion.Diagramming for WPF items can be customized in several additional ways, as described below.

Shape Templates

The Shape class provides the means for defining complex node shapes, made of straight lines, arcs and Bézier curves. A shape template must always contain an outline to be used for hit testing, clipping and finding intersections with other items. Optionally shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in hit testing and clipping. Text regions are the parts of shapes in which node's text is laid out and rendered. MindFusion.Diagramming for WPF provides a set of 87 predefined shape templates, which can be accessed by the Shapes collection or FromId method of the Shape class. Each predefined shape has a string identifier assigned to it. Use the FromId method to find a shape with the specified id. A shape template can be assigned to the Shape member of shape nodes.

Dynamic Shapes

Shapes defined via ElementTemplate objects are scaled proportionally to the size of nodes. If shape elements should scale non-uniformly, use the Shape(formula) constructor to define shapes through Visio-like formulas that take into consideration the current width and height of nodes. Another Shape constructor takes a CreatePathDelegate parameter that can be used to define shapes via .NET functions.

A formula shape can be parameterized by adding ShapeControlPoint objects to the shape's ControlPoints collection. The control point positions are passed as arguments to the shape scripts, where they can be used to modify the node's appearance. For example, the following code defines a rounded rectangle shape, whose corner radius can be modified by users via the control point.

C# [image] Copy Code

// a rounded rectangle shape, with an arc at each corner
string roundRect = @"
r = Min(Width / 2, radius.X);
MoveTo(r, 0);
LineTo(Width - r, 0);
ArcTo(Width, r, false, true, r, r);
LineTo(Width, Height - r);
ArcTo(Width - r, Height, false, true, r, r);
LineTo(r, Height);
ArcTo(0, Height - r, false, true, r, r);
LineTo(0, r);
ArcTo(r, 0, false, true, r, r);
";

var myRect = new Shape(roundRect, "MyRect");

// add a control point for the 'radius' parameter
myRect.ControlPoints.Add(new ShapeControlPoint(
"radius", 15, 5, 45, UnitType.Fixed, 0, 0, 0, UnitType.Fixed));

Shape Libraries

The ShapeDesigner tool included in the MindFusion.Diagramming for WPF suite lets you draw custom shapes and store them in shape libraries. A library file can be loaded into your application using the ShapeLibrary class. The definitions loaded from a shape library are automatically added to the Shapes collection and can be accessed through the FromId method, just as the predefined shapes.

Custom Painting

Another way to customize item's appearance is implemented by raising an event each time an item is painted, giving you the option to attach your own drawing code to the MindFusion.Diagramming for WPF's rendering engine. Use the corresponding CustomDraw property of items to enable that feature in your application.

MindFusion.Diagramming for WPF provides several options for custom drawing. If you choose Additional drawing style, your drawing code will be executed after the standard item drawing code is executed and Image is rendered, but before the text is rendered. Furthermore, the DrawingContext object you receive to draw on has a clipping region applied that corresponds to a node's shape. If using Full drawing mode, none of the standard MindFusion.Diagramming for WPF drawing code is executed - just yours. The ShadowOnly mode performs standard painting of items, but leaves the drawing of shadows to your code.

Place your own drawing code in a handler of the DrawNode, DrawCell and DrawLink events. These events are fired for each custom-drawn item that needs repainting.

Combining Custom Shapes with Custom Drawing

Finally, you could combine user-defined shapes with the Additional custom-painting style. Thus, you can get custom shapes enabled for a node and your custom painting code executing with the node shape used as clipping region. You might clear the clipping region, but be careful - if you draw outside node's bounding rectangle the view may not update correctly.

Shape control points

Shape formulas can now be parameterized by associating control points with Shape objects. Each control point is passed to the shape script as a named variable. Apart from the name, you can specify the default, min and max coordinates for each parameter via the ShapeControlPoint constructor, and whether to treat its values as percents or fixed offset.

For example, the following code creates an arrow shape with adjustable arrowhead and fletching sizes:

C# [image] Copy Code

string arrow60deg = @"
x1 = p1.X;
y1 = p1.Y;
x2 = IIf(Width>=2*Height,0.5*Height*Tan(PI/6), 0.15*Width);
x3 = IIf(Width>=2*Height, Height/4, 0.15*Width);
MoveTo(0, Height * 0.5);
LineTo(x1 , Height);
LineTo(x1, Height - y1);
LineTo(Width -x3 -x2 -x2, Height - y1);
LineTo(Width -x3 -x2, Height);
LineTo(Width, Height);
LineTo(Width * p2.X / 100, Height * p2.Y / 100);
LineTo(Width, 0);
LineTo(Width - x3 -x2, 0);
LineTo(Width -x3 -x2 -x2, y1);
LineTo(x1, y1);
LineTo(x1, 0);
LineTo(0, Height * 0.5);
";

diagram.DefaultShape = new Shape(arrow60deg, "", new List<ShapeControlPoint>
{
new ShapeControlPoint("p1",
20, 0, -10, UnitType.Fixed,
20, 0, 100, UnitType.Fixed) { MaxXRelativeToWidth = true },
new ShapeControlPoint("p2",
80, 60, 100, UnitType.Percentage,
50, 50, -50, UnitType.Percentage) { MaxYRelativeToHeight = true }
}, "arrow60deg");


Text Attributes and Formatting

Text Attributes and Formatting

A ShapeNode node can display Text within its outlines. Text position and alignment depend on the value of TextAlignment, TextPadding, TextWrapping and TextVerticalAlignment. The text is painted with the color set in TextBrush. Even more useful layout and formatting attributes can be enabled through PolygonalTextLayout and EnableStyledText.

Layout Text in Arbitrary Shapes

ShapeNode instances can have various shapes, as specified by their Shape and ShapeOrientation properties. To layout text inside non-rectangular shapes, enable PolygonalTextLayout. If enabled, MindFusion.Diagramming for WPF uses a formatting algorithm that fits exactly each line of text within the width of a line inside a polygonal shape. If a shape node has curved outlines, the formatting algorithm approximates them the poly-lines.

Text Wrapping

If there isn't enough space available to fit a whole line of text, MindFusion.Diagramming for WPF wraps the text to a new line when it reaches the edge of the node. You can specify that the text should be wrapped only at word boundaries by setting TextTrimming to Word. The default is to split words into multiple parts if there is not enough space to fit a whole word.

If you prefer to use your own line-breaks, you can disable the automatic text wrapping by setting TextWrapping to None. If automatic wrapping is disabled and there isn't enough space to fit the whole line, the text is clipped at the node boundaries.

Text in Tables

A TableNode can display text in its caption area and inside each cell. Text in the Caption is painted with TextBrush and is aligned as specified by CaptionFormat. Text in cells is painted using their own TextBrush and is aligned according to their own TextFormat. Even more useful formatting attributes can be enabled by EnableStyledText property.

Styled Text

The ShapeNode.EnableStyledText property of shape nodes and the TableNode.EnableStyledText property of tables enables or disables styled text rendering. Styled text can have various attributes applied to the characters it contains. The attributes are specified using HTML-like formatting tags embedded in the raw text. Shape nodes can display styled text only if PolygonalTextLayout is enabled. Use the DrawStyledText method to display styled text in custom-drawn items.

The following table lists the currently supported style tags:

Tag | Description
<i>text</i> | Indicates italic text.
<b>text</b> | Indicates bold text.
<u>text</u> | Indicates underlined text.
<sub>text</sub> | Indicates subscript.
<sup>text</sup> | Indicates superscript.
<color=#RRGGBB>text</color> | Changes the color of the text. The red green and blue color channels are specified as two-digit hexadecimal numbers.

Links' Text

The Text of a DiagramLink is painted with the color specified in TextBrush and is positioned as set in TextStyle.

Fonts

All items provide FontFamily, FontSize, FontStyle, FontWeight and FontStretch properties that allows getting or setting the font attributes used for rendering the items' text.


Initial Values of Item Properties

Initial Values of Item Properties

Each new item, created either by the user or programmatically, is initialized with some kind of default property values.

If you create items by using the new operator and adding them the diagram's Nodes or Links collection, you can initialize the items by passing a Diagram reference to the respective constructor, or by passing another item to the copy constructor. In the former case, item properties are initialized from the default-property values defined in Diagram. In the latter case, properties are copied from the prototype item.

When users draw new items, the items are initialized from the Diagram properties, but you can change the default values by handling the InitializeNode and InitializeLink events.

Items created via the diagram's Factory object are always initialized from the default-property values defined in Diagram.

Below are listed item properties and the corresponding constants or Diagram properties through which they are initialized:

DiagramItem Property | Initialized With
Brush | ShapeBrush TableBrush LinkBrush
Font | Font
Locked | false
Pen | ShapePen TablePen LinkPen
Selected | SelectAfterCreate
Tag | null
ToolTip | (empty string)
Visible | true

ShapeNode Property | Initialized With
CustomDraw | ShapeCustomDraw
EnabledHandles | AdjustmentHandles.All
Expandable | NodesExpandable
HandlesStyle | ShapeHandlesStyle
Image | null
ImageAlign | ImageAlign.Fit
Text | ShapeText
TextColor | TextColor
TextFormat | TextFormat
Transparent | false

ContainerNode Property | Initialized With
AutoShrink | false
Caption | ContainerCaption
CaptionBrush | Black
CaptionFormat | TextFormat
CaptionHeight | ContainerCaptionHeight
Foldable | ContainersFoldable
Folded | false
HighlightPen | ContainerHighlightPen
Margin | ContainerMargin
MinimumSize | ContainerMinimumSize

TableNode Property | Initialized With
Caption | TableCaption
CaptionColor | Color.FromArgb(0, 0, 0)
CaptionFormat | Centered horizontal and vertical alignment
CellCustomDraw | CellCustomDraw
CellFrameStyle | CellFrameStyle
ColumnWidth | TableColumnWidth
CustomDraw | TableCustomDraw
HandlesStyle | TableHandlesStyle
Image | null
ImageAlign | ImageAlign.Fit
ConnectionStyle | TableConnectionStyle
RowHeight | TableRowHeight
Scrollable | TablesScrollable
Shape | TableShape
TextColor | TextColor

DiagramLink Property | Initialized With
BaseShape | LinkBaseShape
BaseShapeSize | LinkBaseShapeSize
HeadShape | LinkHeadShape
HeadShapeSize | LinkHeadShapeSize
AutoRoute | RouteLinks
CascadeOrientation | LinkCascadeOrientation
CustomDraw | LinkCustomDraw
Dynamic | DynamicLinks
HeadPen | LinkPen
IntermediateShape | LinkIntermediateShape
IntermediateShapeSize | LinkIntermediateShapeSize
RetainForm | LinksRetainForm
SegmentCount | LinkSegments
Shape | LinkShape
Text | LinkText
TextColor | TextColor
TextStyle | LinkTextStyle


Table of Predefined Shapes

Table of Predefined Shapes

Shape | Identifier | Common Uses
 | Actor | An user An actor in use case model
 | Alternative | An alternative in SDL An extraction in flowcharts Storage in quality management
 | Arrow1 | Use as desired
 | Arrow2 | Use as desired
 | Arrow3 | Transportation in quality management A reference point
 | Arrow4 | Use as desired
 | Arrow5 | Use as desired
 | Arrow6 | Use as desired
 | Arrow7 | A signal Electronic transmission of data
 | Arrow8 | Use as desired
 | Arrow9 | Use as desired
 | BeginLoop | Begin of a loop
 | BpmnComplex | BPMN Gateways: Complex Decision/Merge
 | BpmnDataBasedXor | BPMN Gateways: Data-Based Exclusive Decision/Merge (XOR)
 | BpmnEndCancel | BPMN Events: Cancel (End)
 | BpmnEndCompensation | BPMN Events: Compensation (End)
 | BpmnEndError | BPMN Events: Error (End)
 | BpmnEndLink | BPMN Events: Link (End)
 | BpmnEndMessage | BPMN Events: Message (End)
 | BpmnEndMultiple | BPMN Events: Multiple (End)
 | BpmnEndTerminate | BPMN Events: Terminate (End)
 | BpmnEventBasedXor | BPMN Gateways: Event-Based Exclusive Decision/Merge (XOR)
 | BpmnInclusive | BPMN Gateways: Inclusive Decision/Merge (OR)
 | BpmnIntermediateCancel | BPMN Events: Cancel (Intermediate)
 | BpmnIntermediateCompensation | BPMN Events: Compensation (Intermediate)
 | BpmnIntermediateError | BPMN Events: Error (Intermediate)
 | BpmnIntermediateLink | BPMN Events: Link (Intermediate)
 | BpmnIntermediateMessage | BPMN Events: Message (Intermediate)
 | BpmnIntermediateMultiple | BPMN Events: Multiple (Intermediate)
 | BpmnIntermediateRule | BPMN Events: Rule (Intermediate)
 | BpmnIntermediateTimer | BPMN Events: Timer (Intermediate)
 | BpmnParallelFork | BPMN Gateways: Parallel Fork/Join (AND)
 | BpmnStartLink | BPMN Events: Link (Start)
 | BpmnStartMessage | BPMN Events: Message (Start)
 | BpmnStartMultiple | BPMN Events: Multiple (Start)
 | BpmnStartRule | BPMN Events: Rule (Start)
 | BpmnStartTimer | BPMN Events: Timer (Start)
 | Cloud | Object instance in data flow diagrams
 | Collate | A collation in flowcharts
 | ConeDown | Use as desired
 | ConeUp | Use as desired
 | ConnectedIssues | Connected issues in quality management
 | CreateRequest | Request to create in SDL
 | Cross | Use as desired
 | Cube | Use as desired
 | Cylinder | Use as desired
 | Database | A database in flowcharts
 | DataTransmition | Electronic transmission of data
 | DDelay | Use as desired
 | Decagon | Use as desired
 | Decision | Decision in flowcharts A comparison in flowcharts Relationship in data flow diagrams
 | Decision2 | A decision in SDL
 | Delay | A delay in process diagrams
 | DInDelay | Use as desired
 | DirectAccessStorage | A direct access storage
 | DiskStorage | Data stored on disk in flowcharts
 | Display | Data that is displayed for human use
 | DividedEvent | An event
 | DividedProcess | A process or document in flowcharts Entity in data flow diagrams
 | Document | A document
 | Donut | Use as desired
 | DOutDelay | Use as desired
 | Ellipse | A cross-reference within the same page of a flowchart Process in data flow diagrams State in data flow diagrams A continuation of the flowchart in SDL An use case Operation in quality management
 | EndLoop | End of a loop
 | ExternalOrganization | An external organization
 | ExternalProcess | An external process
 | File | A file
 | FramedRectangle | Use as desired
 | Gate | A gateway
 | Heart | Use as desired
 | Heptagon | Use as desired
 | Hourglass | Use as desired
 | Input | Data that is input by manual means
 | InternalStorage | An internal storage
 | Interrupt | An interrupt
 | Interrupt2 | An interrupt
 | IsoProcess | Iso9000 process
 | Junction | A summing junction A return in SDL
 | Lightning | Use as desired
 | LinedDocument | A document in flowcharts
 | ManualOperation | Operation performed by a human
 | Merge | A merger in flowcharts Inbound goods in quality management Non-electronic file Stop state in data flow diagrams
 | MessageFromUser | A message from user side in SDL
 | MessageToUser | A message to user side in SDL
 | Microform | A microform
 | MicroformProcessing | A microform processing
 | MicroformRecording | A microform recording
 | MultiDocument | A multiple document in flowcharts
 | MultiProc | A multiple process or document in flowcharts
 | Octagon | Use as desired
 | OfflineStorage | An offline storage
 | OffpageConnection | A cross-reference to another page of a flowchart
 | OffpageReference | A cross-reference to another page of a flowchart A foreign module
 | Or | An 'or' statement
 | Pentagon | Use as desired
 | Plaque | Use as desired
 | PrimitiveFromCall | A primitive from call control in SDL
 | PrimitiveToCall | A primitive to call control in SDL
 | Procedure | Procedure in SDL
 | Process | A process or document in flowcharts A file or data storage
 | Prysm | Use as desired
 | PunchedCard | A punched card
 | PyramidDown | Use as desired
 | PyramidUp | Use as desired
 | Rectangle | A metric operation 'External interactor' in data flow diagrams Inspection in quality management
 | RightTriangle | Use as desired
 | RoundRect | A process or item in flowcharts An event An issue in quality management
 | RSave | Input or output data in flowcharts
 | Save | A save in SDL Input or output data in flowcharts
 | Sort | A sort operation
 | Sphere | Use as desired
 | Star | Use as desired
 | Star4Pointed | Use as desired
 | Star5Pointed | Use as desired
 | Star6Pointed | Use as desired
 | Star7Pointed | Use as desired
 | Star16Pointed | Use as desired
 | Star24Pointed | Use as desired
 | Star32Pointed | Use as desired
 | Start | Start of a program flow A starting point in SDL
 | Tape | Sequentially accessible data
 | Terminator | Start or end of a program flow
 | TransmittalTape | A transmittal tape
 | Trapezoid | Use as desired


MindFusion.Gauges for WPF Overview

MindFusion.Gauges for WPF Overview

This section contains information about the two type of gauge controls contained in MindFusion.Charting for WPF - OvalGauge and LinearGauge and how to use their features.


Gauges

Gauges

MindFusion.Charting for WPF provides two type of gauge controls - oval and linear. The two types of gauges are represented by the OvalGauge and LinearGauge classes respectively. The purpose of the gauge controls is to visualize various quantities in two layouts - circular and linear.

Structure

The most important component of each gauge control are the scales contained within it. The scales are collections of gauge elements such as ticks, labels, pointers, and so on. The scales provide interactivity and animation. The gauges are merely shells, which provide visual decoration to the shells nested within them. The following example demonstrates how to define a simple OvalGauge control with a single oval scale in it in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale />
</gauges:OvalGauge>

The example (and all following examples hereafter) assumes that the gauges namespace is defined as following:

XAML [image] Copy Code

xmlns:gauges="http://mindfusion.eu/gauges/wpf"

Running the example will yield a result similar to the image below:

Removing the scale from the above gauge and running the application again will result in an empty gauge control.

Scales

As previously mentioned the scales can contain ticks, labels, pointers, ranges and other elements. There are two types of scale corresponding to the two types of gauges - OvalScale and LinearScale, which share a common base class - BaseScale. The oval scale distributes its elements in a circle and the linear scale distributes its elements along a horizontal or vertical axis.

Although it is possible to add oval scales to a linear gauge control and linear scales to an oval gauge control, this is not a common scenario. The scales are responsible for arranging their contents. They also provide user interaction and pointer animation.

The following example adds a pointer to the gauge defined in the previous section:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>
</gauges:OvalGauge>

Running the application now will produce the following result:

To learn more about gauge scales, refer to the Scales topic.

Composition

Gauge controls can contain more than just one scale. A common scenario is an oval gauge containing several concentric scales displaying different measures. The following example illustrates an oval gauge control with two concentric scales:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale />

<gauges:OvalScale Margin="50" Fill="Transparent" Stroke="Transparent" FunctionType="Logarithmic">
<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings LabelFormat="0" TickShape="Rectangle" Fill="Gray" />
</gauges:OvalScale.MajorTickSettings>
<gauges:OvalScale.MiddleTickSettings>
<gauges:MiddleTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MiddleTickSettings>
<gauges:OvalScale.MinorTickSettings>
<gauges:MinorTickSettings ShowTicks="False" />
</gauges:OvalScale.MinorTickSettings>
</gauges:OvalScale>

</gauges:OvalGauge>

The second scale in the example has a fixed margin so that it does not overlap the first scale. The following image demonstrates the gauge:

Gauge controls are not limited to the type of scales that can be added to them. Linear scales can be added to oval gauges and oval scales can be added to linear gauges, although this is not common. What is more, any WPF FrameworkElement can be added to a gauge. This can be especially useful for arranging scales within the gauge by employing the appropriate panels. In the example above, increasing the size of the gauge will cause the scales to overlap because the inner scale has a fixed margin. This can be resolved by using a Grid panel as a parent of the inner scale as illustrated by the example below:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale />

<Grid>
<Grid.RowDefinitions>
<RowDefinition />
<RowDefinition Height="3*" />
<RowDefinition />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="3*" />
<ColumnDefinition />
</Grid.ColumnDefinitions>

<gauges:OvalScale Fill="Transparent" Stroke="Transparent" FunctionType="Logarithmic" Grid.Column="1" Grid.Row="1">
<!-- Scale settings -->
</gauges:OvalScale>

</Grid>

</gauges:OvalGauge>

Resizing the gauge now will be consistent.

Custom Gauges

The customization of the gauge controls can be achieved by using custom control templates. A simple control template is provided in the following example.

XAML [image] Copy Code

<Style TargetType="gauges:OvalGauge">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="gauges:OvalGauge">
<gauges:CenterPanel>
<Ellipse Stroke="DarkSlateBlue" StrokeThickness="4" Stretch="Uniform">
<Ellipse.Fill>
<RadialGradientBrush Center="0.3,0.3">
<GradientStop Offset="0" Color="White" />
<GradientStop Offset="1" Color="LightSteelBlue" />
</RadialGradientBrush>
</Ellipse.Fill>
</Ellipse>
<Ellipse Stretch="Uniform">
<Ellipse.Fill>
<RadialGradientBrush>
<GradientStop Offset="0.75" Color="#00000000" />
<GradientStop Offset="1" Color="#60000000" />
</RadialGradientBrush>
</Ellipse.Fill>
</Ellipse>
<ItemsPresenter />
</gauges:CenterPanel>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The above template simply adds to concentric ellipses as a background of the gauge. Applying the template on an oval gauge with a scale and a pointer within it will produce the following result:

Built-in Gauge Templates

There are several built-in templates for quadratic gauges in different orientations. Each built-in template is encapsulated in a separate resource dictionary. In order to use the custom templates, its corresponding resource dictionary needs to be merged in the application. The following table lists the predefined gauge templates and the names of their respective resource dictionaries.

Template | Dictionary Name
Quadratic North-West | /MindFusion.Gauges.Wpf;component/Themes/OvalGaugeNW.xaml
Quadratic North-East | /MindFusion.Gauges.Wpf;component/Themes/OvalGaugeNE.xaml
Quadratic South-East | /MindFusion.Gauges.Wpf;component/Themes/OvalGaugeSW.xaml
Quadratic South-West | /MindFusion.Gauges.Wpf;component/Themes/OvalGaugeNE.xaml

Each dictionary contains two styles - one for the gauge control and one for the scales contained in it. The keys of the styles are displayed in the table below:

Template | Gauge Style Key | Scale Style Key
Quadratic North-West | OvalGaugeStyleNW | OvalScaleStyleNW
Quadratic North-East | OvalGaugeStyleNE | OvalScaleStyleNE
Quadratic South-East | OvalGaugeStyleSW | OvalScaleStyleSW
Quadratic South-West | OvalGaugeStyleSE | OvalScaleStyleSE

To use the built-in templates, the resource dictionary should be merged within the application. The following example merges the dictionary containing the North-West quadratic gauge templates.

XAML [image] Copy Code

<Window.Resources>
<ResourceDictionary>
<ResourceDictionary.MergedDictionaries>
<ResourceDictionary Source="/MindFusion.Gauges.Wpf;component/Themes/OvalGaugeNW.xaml" />
</ResourceDictionary.MergedDictionaries>
</ResourceDictionary>
</Window.Resources>

After that the styles in the dictionary can be referenced as static resources:

XAML [image] Copy Code

<gauges:OvalGauge Style="{StaticResource OvalGaugeStyleNW}">

<gauges:OvalScale Style="{StaticResource OvalScaleStyleNW}">
<gauges:OvalScale.Pointers>
<gauges:Pointer Value="10" />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>

</gauges:OvalGauge>

Running the application will produce the following result:


Scales

Scales

As discussed in the Gauges topic, the scales are the most important component of a gauge. The scales display ticks and labels, they arrange and animate pointers and also maintain ranges and other auxiliary elements. There are two types of scales - oval and linear. The oval scale distributes its elements in a circle, the linear scale distributes its element on a vertical or horizontal axis depending on its orientation. The oval and linear scales are represented by the OvalScale and LinearScale classes respectively. These classes share a common base class - BaseScale and apart from the difference in their layout logic they are very similar.

Default Template

The following XAML shows the default template for the scale classes.

XML [image] Copy Code

<ControlTemplate>
<Grid Background="Transparent">
<Path Name="ScalePath" Fill="{TemplateBinding Fill}" Stroke="{TemplateBinding Stroke}" StrokeThickness="{TemplateBinding StrokeThickness}" />
<Grid Name="RangeContainer" />
<Grid Name="TickContainer" />
<Grid Name="LabelContainer" />
<ItemsPresenter />
<Grid Name="PointerContainer">
<Grid.Effect>
<DropShadowEffect Opacity="0.3" ShadowDepth="2" />
</Grid.Effect>
</Grid>
</Grid>
</ControlTemplate>

As can be observed in the template the scales have several named parts. The following table lists them.

Part | Type | Description
ScalePath | Path | A WPF Path object which renders the scale geometry.
RangeContainer | Grid | A WPF Grid panel which acts as a container of the Range objects added to the scale.
TickContainer | Grid | A WPF Grid panel which acts as a container of the scale ticks.
LabelContainer | Grid | A WPF Grid panel which acts as a container of the scale labels.
PointerContainer | Grid | A WPF Grid panel which acts as a container of the Pointer objects added to the scale.

The appearance order of the scale elements can be modified by replacing the scale template with another template in which the element containers are rearranged accordingly.

Customization

Geometry

The scales display a geometry according to its type. The elements displayed in the scale are aligned and arranged relative to the scale geometry. The geometry is either circular, for oval scale, or trapezial, for linear scales. The following figures show the geometries of oval and horizontal and vertical linear scales.

Oval | Horizontal Linear | Vertical Linear

The scale geometry can be customized through various properties. The fill and stroke of the geometry are defined by the Fill, Stroke and StrokeThickness properties. The start and end width are specified through the StartWidth and EndWidth properties. These properties are of type Length and can express relative values. See the Metrics section at the end of this topic for additional information regarding this. The start and end angles of the oval geometry can be specified through the StartAngle and EndAngle properties of the OvalScale class respectively. Both properties are expressed in degrees.

Data

The MinValue and MaxValue properties can be used to define the range of values displayed on the scale. The distribution of the values along the scale geometry is determined by the FunctionType property and can be Linear, Logarithmic or Custom. The base of the logarithmic distribution is specified through the LogarithmBase property. The custom value distribution function is supplied through the CustomFunction and ReversedCustomFunction properties.

Scale Elements

Various elements can be added to a scale, including ticks, labels and pointers.

Ticks and Labels

The ticks and labels represent cornerstones along the scale, usually round values. The ticks and labels are created and added to the scales implicitly according to the specified settings. There are three categories of ticks and labels - major, middle and minor. Each category has corresponding settings, exposed respectively by the MajorTickSettings, MiddleTickSettings and MinorTickSettings properties of the BaseScale class. These settings provide properties for specifying the number of ticks along the scale, their alignment and appearance, the format of their associated label, and more. For additional information about ticks and labels refer to the Ticks and Labels topic.

Pointers

The pointers represent needles or similar types of indicators within the scale. They are used to visualize a current measurement within the scale. For example, in a car speedometer the pointers are used to indicate the current speed. Pointers can be added to the scale through the Pointers property. Pointers expose numerous properties that can be used to customize their appearance. For additional information check the Pointers topic.

Ranges

The ranges emphasize portions of the scale which represent particular interest. An example of a range is the red zone of a car cyclometer. Ranges are added to the scale through the Ranges property. For extensive information on how to use and setup ranges, refer to the Ranges topic.

Miscellaneous

In addition to the elements discussed so far, scales can host any WPF FrameworkElement. The following code demonstrates how to add a WPF Path to a scale.

XML [image] Copy Code

<gauges:OvalScale>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="4*" />
<ColumnDefinition Width="1*" />
<ColumnDefinition Width="4*" />
</Grid.ColumnDefinitions>
<Grid.RowDefinitions>
<RowDefinition Height="2.5*" />
<RowDefinition Height="1*" />
<RowDefinition Height="5.5*" />
</Grid.RowDefinitions>
<Path Data="M125,5 L155,90 L245,90 L175,145 L200,230 L125,180 L50,230 L75,145 L5,90 L95,90 z" Grid.Row="1" Grid.Column="1" Stroke="Black" Fill="Lime" Stretch="Uniform" />
</Grid>
</gauges:OvalScale>

The above XAML will render a scale similar to this image:

Interaction

Users can interactively adjust the value of the pointers in the scale by clicking anywhere within the scale bounds. Interactivity only applies to pointers with IsInteractive property set to true. When the value of a pointer is changed interactively, the ValueChanged of the pointer is raised.

Animation

Scales enable animations and interactivity of the pointers contained within them. The animation is enabled through the EnableAnimation property but only applies to pointers with IsAnimated set to true. Oval scales, which represent continuous intervals (for example clocks), can enable animation across scale boundaries by setting AnimateThroughSmallerArc property to true.

Metrics

The sizes of various scale elements can be specified either relatively to the size of the scale or as absolute values. This applies to all properties of type Length. Expressing a relative value in XAML can be achieved by appending the percent sign (%) at the end of the value. The following example defines a pointer with relative width and height in XAML:

XAML [image] Copy Code

<gauges:Pointer PointerWidth="100%" PointerHeight="50%" />

Relative sizes are calculated differently depending on the type of scale. In oval scales relative sizes are calculated based on the radius of the scale. Therefore the above pointer will extend from the center to the outer edge of the scale. In linear scales sizes are based on the width or height of the scale depending on the scale orientation.


Ticks and Labels

Ticks and Labels

There are three categories of ticks and labels in a scale - major, middle and minor. Each category is governed by a separate settings object in the BaseScale class - MajorTickSettings, MiddleTickSettings and MinorTickSettings.

The number of ticks from a specific category can be specified in either of two ways:

  • By setting the Count property to the desired number of ticks.
  • By setting the Step property to the desired quantity between adjacent ticks.

If both of the above properties are specified Step will take precedence. The ticks and/or labels in a particular category can be hidden through the ShowTicks and ShowLabels properties of the respective settings objects.

Here is a table with some examples illustrating various combinations of the above properties, applied on an oval scale with MinValue set to 0 and MaxValue set to 100:

Settings | Scale
MajorTickSettings Count = 5 MiddleTickSettings Count = 3 ShowLabels = false MinorTickSettings ShowTicks = false |
MajorTickSettings Step = 15 MiddleTickSettings Count = 4 ShowLabels = false MinorTickSettings Count = 2 |
MajorTickSettings Count = 10 MiddleTickSettings Count = 1 ShowLabels = False MinorTickSettings Step = 2 |

Alignment

The alignment of ticks and labels relative to the scale geometry is specified through the TickAlignment and LabelAlignment properties. The following scheme illustrates the possible alignment modes in an oval scale:

The pale blue lane at the background represents an oval scale, the orange line represents the center of the scale and the green objects are the elements being aligned to the scale using different alignment modes. The center of each element is illustrated in light green color. The alignment modes used for each of the elements in the scheme is specified below:

  1. InnerInside
  2. InnerCenter
  3. InnerOutside
  4. CenterInside
  5. TrueCenter
  6. CenterOutside
  7. OuterInside
  8. OuterCenter
  9. OuterOutside

The position of the aligned elements can be further adjusted through their offset, specified respectively by the TickOffset and LabelOffset properties.

Label Rotation

The following schemes illustrates all possible label rotation modes in an oval scale.

Auto | BaselineAwayFromCenter | BaselineToCenter | None | Sideways

Appearance

The fill and stroke of the ticks are specified through the Fill, Stroke and StrokeThickness properties. The TickShape specifies the shape of the ticks. There are several predefined shapes available. The tick appearance can can be customized by providing custom tick template through the TickTemplate property. The size of the ticks is controlled by the TickWidth and TickHeight properties and can be specified as either relative or absolute value.

The foreground color of the labels can be specified through the LabelForeground property. The size of the label font is set through the FontSize property. FontSize is of type Length and can express relative sizes. The other font attributes of the labels are specified from the FontFamily, FontSize and FontWeight properties of the containing scale.

The following XAML code defines a custom tick template which represents a button with a star within it.

XAML [image] Copy Code

<DataTemplate>
<Button>
<Path Data="M125,5 L155,90 L245,90 L175,145 L200,230 L125,180 L50,230 L75,145 L5,90 L95,90 z" DataContext="{Binding RelativeSource={RelativeSource Mode=FindAncestor, AncestorType={x:Type ContentControl}, AncestorLevel=2}}" Stretch="Uniform" Stroke="{Binding Stroke}" StrokeThickness="{Binding StrokeThickness}" Fill="{Binding Fill}" />
</Button>
</DataTemplate>

An oval gauge using the above templates for its major ticks will look like this:

Custom Intervals

It is possible to customize the appearance of the ticks in a specific interval by using CustomInterval objects. To initialize the custom interval, set its MinValue and MaxValue properties to reflect the range of ticks this interval will apply to, then use its Fill, Stroke and StrokeThickness properties to specify explicit fill and stroke for the ticks in this interval. Finally add the custom interval to the CustomIntervals collection of the respective TickSettings.

Below is an example of a custom interval defined in XAML. The custom interval specifies red background for all major ticks of an oval scale in the range [10..50].

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings>
<gauges:MajorTickSettings.CustomIntervals>
<gauges:CustomInterval MinValue="10" MaxValue="50" Fill="Red" />
</gauges:MajorTickSettings.CustomIntervals>
</gauges:MajorTickSettings>
</gauges:OvalScale.MajorTickSettings>
</gauges:OvalScale>

Custom Labels

The text of the labels can be customized beyond simple formatting of the value associated with them. This can be achieved by handling the QueryLabelValue event of the BaseScale class. The handlers of this event will receive an instance of the QueryLabelValueEventArgs class. The new label value can be assigned to the NewValue property of this instance.


Pointers

Pointers

The pointers represent needles or similar type of indicators within the scale. They are used to visualize a current measurement within the scale. The most important member of the pointer object is its Value. The pointer is automatically adjusted by its containing scale so that it points to the scale location, corresponding to its value.

The size of the pointer is defined by the PointerWidth and PointerHeight properties. These properties can express the size as relative or absolute value. The location of the pointer can be adjusted through the PointerOffset property and its alignment in a linear scale can be specified through the Alignment property.

The pointer can be made interactive by setting the IsInteractive property to true. Clicking with the mouse within a scale causes all its interactive pointers to be adjusted to the value corresponding to the clicked point. A pointer can be made discrete by setting IsDiscrete to true. The value of a discrete pointer is always integer.

Usage

The sample code below illustrates how to define and add pointers to a linear scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">
<gauges:LinearScale Orientation="Horizontal">
<gauges:LinearScale.Pointers>
<gauges:Pointer IsInteractive="True" />
</gauges:LinearScale.Pointers>
</gauges:LinearScale>
</gauges:LinearGauge>

Custom Appearance

The appearance of the pointer can be customized by using a custom ControlTemplate. The following example demonstrates an oval gauge with a compass needle type of pointer:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale Fill="Transparent" Stroke="Transparent" StartAngle="0" EndAngle="360" AnimateThroughSmallerArc="True">
<gauges:OvalScale.Pointers>

<gauges:Pointer PointerWidth="180%" PointerHeight="20%" PointerOffset="80%" IsInteractive="True" IsAnimated="True" Value="75">
<gauges:Pointer.Template>
<ControlTemplate TargetType="gauges:Pointer">
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="3*" />
<RowDefinition Height="4*" />
<RowDefinition Height="3*" />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="48*" />
<ColumnDefinition Width="2*" />
<ColumnDefinition Width="2*" />
<ColumnDefinition Width="48*" />
</Grid.ColumnDefinitions>

<Polygon Grid.Column="2" Grid.ColumnSpan="2" Grid.RowSpan="3" Points="0,0 1,0.5 0,1" Stretch="Fill">
<Polygon.Fill>
<LinearGradientBrush StartPoint="0.5,0" EndPoint="0.5,1">
<GradientStop Offset="0" Color="#990000" />
<GradientStop Offset="0.3" Color="#FF0000" />
<GradientStop Offset="1" Color="#660000" />
</LinearGradientBrush>
</Polygon.Fill>
</Polygon>
<Polygon Grid.ColumnSpan="2" Grid.RowSpan="3" Points="1,0 0,0.5 1,1" Stretch="Fill">
<Polygon.Fill>
<LinearGradientBrush StartPoint="0.5,0" EndPoint="0.5,1">
<GradientStop Offset="0" Color="#999999" />
<GradientStop Offset="0.3" Color="#CCCCCC" />
<GradientStop Offset="1" Color="#666666" />
</LinearGradientBrush>
</Polygon.Fill>
</Polygon>
<Polygon Grid.ColumnSpan="4" Grid.RowSpan="3" Points="0,0.5 0.5,0 1,0.5 0.5,1" Stretch="Fill" Stroke="#202020" />
<Ellipse Grid.Column="1" Grid.ColumnSpan="2" Grid.Row="1" Fill="DimGray" Stroke="Black" StrokeThickness="1" />

</Grid>
</ControlTemplate>
</gauges:Pointer.Template>
</gauges:Pointer>
</gauges:OvalScale.Pointers>

<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MajorTickSettings>
<gauges:OvalScale.MiddleTickSettings>
<gauges:MiddleTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MiddleTickSettings>
<gauges:OvalScale.MinorTickSettings>
<gauges:MinorTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MinorTickSettings>

</gauges:OvalScale>

</gauges:OvalGauge>

The above gauge will look similar to the following image:


Ranges

Ranges

The range is a visual representation of an interval within a gauge. Ranges are commonly used to mark or emphasize specific zones on the scale. Often the end of the scale is a danger zone and a range can be used to indicate this. The following image illustrates an oval gauge with three ranges (red, yellow and green) specifying different zones on the scale.

The range interval is specified through the MinValue and MaxValue properties. The Alignment and Offset properties control the positioning and the StartWidth and EndWidth properties specify the size of the range. The range can be auto-sized to the scale by setting AutoSize to true. To learn more about the different alignment modes check the Ticks and Labels topic.

Appearance

The Fill, Stroke and StrokeThickness properties can be used to specify the appearance of the range. The stroke on the different sides of the range can be turned off by using the CapStart, CapEnd, StrokeInside and StrokeOutside properties.

Usage

The sample code below illustrates how to define and add ranges to a linear scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">

<gauges:LinearScale>
<gauges:LinearScale.Ranges>
<gauges:Range MinValue="70" MaxValue="80" StartWidth="0" EndWidth="5%" Fill="Yellow" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" CapEnd="False" />
<gauges:Range MinValue="80" MaxValue="90" StartWidth="5%" EndWidth="10%" Fill="orange" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" CapStart="False" CapEnd="False" />
<gauges:Range MinValue="90" MaxValue="100" StartWidth="10%" EndWidth="15%" Fill="Red" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" CapStart="False" />
</gauges:LinearScale.Ranges>
</gauges:LinearScale>

</gauges:LinearGauge>

The linear gauge defined above will look like this:


Indicators

Indicators

The indicator is a gauge element, which changes its appearance based on its Value property and its defined states. The states of the indicator are specified as CustomInterval objects and are located in the States collection. When the value of the indicator falls within one of its defined states, this state becomes active and its Fill, Stroke and StrokeThickness properties are applied to the indicator automatically. In addition, the attached property ActiveColor is applied as a glow color of the indicator. If the value of the indicator does not fall in any of the defined states, then the DefaultState becomes active.

A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

Usage

The sample code below illustrates how to define and add indicators to a scale in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer Name="pointer" IsInteractive="True" />
</gauges:OvalScale.Pointers>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="4*" />
<ColumnDefinition />
<ColumnDefinition Width="4*" />
</Grid.ColumnDefinitions>
<Grid.RowDefinitions>
<RowDefinition Height="6*" />
<RowDefinition />
<RowDefinition Height="2*" />
</Grid.RowDefinitions>
<gauges:Indicator Grid.Row="1" Grid.Column="1" Value="{Binding Value, ElementName=pointer}">
<gauges:CustomInterval MinValue="80" MaxValue="100" Fill="Red" />
</gauges:Indicator>
</Grid>
</gauges:OvalScale>
</gauges:OvalGauge>

The oval gauge defined above will look like this:


MindFusion.Mapping for WPF Overview

MindFusion.Mapping for WPF Overview


Loading Map Files

Loading Map Files

Maps in the MindFusion.Mapping for WPF are represented by the Map class. Its LoadFromStream method can load map data from files in the ESRI Shapefile format. Shapefiles come with an associated DBF database, that can provide various attribute values for the map elements. To load the DBF database along with the main map file, set the dbfStream parameter of LoadFromFile. The loaded database can be accessed via the Database property, and each record associated with a map element is exposed via the DatabaseRow property of the Shape class.

To display a map once it is loaded, assign it to the BaseMap property of the MapView control, or add a new MapLayer to the view and assign the map to its Map property. The following code demonstrates how to load a map with associated database from the application's XAP file and assign it to BaseMap:

C# [image] Copy Code

private void OnLoaded(object sender, RoutedEventArgs e)
{
var mapUri = new Uri("MyApp;component/my_map.shp", UriKind.Relative);
var dbfUri = new Uri("MyApp;component/my_map.dbf", UriKind.Relative);

var mapStreamInfo = Application.GetResourceStream(mapUri);
var dbfStreamInfo = Application.GetResourceStream(dbfUri);

if (mapStreamInfo != null && dbfStreamInfo != null)
{
var map = new Map();
map.LoadFromStream(mapStreamInfo.Stream, dbfStreamInfo.Stream, "NAME");
map.AssignColors();

mapView.BaseMap = map;
}
}

Visual Basic [image] Copy Code

Private Sub OnLoaded(sender As Object, e As RoutedEventArgs)

Dim mapUri = New Uri("MyApp;component/my_map.shp", UriKind.Relative)
Dim dbfUri = New Uri("MyApp;component/my_map.dbf", UriKind.Relative)

Dim mapStreamInfo = Application.GetResourceStream(mapUri)
Dim dbfStreamInfo = Application.GetResourceStream(dbfUri)

If mapStreamInfo IsNot Nothing AndAlso dbfStreamInfo IsNot Nothing Then
Dim map = New Map()
map.LoadFromStream(mapStreamInfo.Stream, dbfStreamInfo.Stream, "NAME")
map.AssignColors()

mapView.BaseMap = map
End If

End Sub

Maps can be loaded as well from XAML code by setting the MapLocation property of a map layer. The following example loads a map file:

Xaml [image] Copy Code

<ScrollViewer HorizontalScrollBarVisibility="Auto">
<map:MapView x:Name="mapView">
<map:MapLayer MapLocation="my_map.shp" DatabaseLocation="my_map.dbf" LabelField="NAME" />
</map:MapView>
</ScrollViewer>


Map Layers

Map Layers

The MapView control can display several map and decoration layers. In order to add a new layer, create a MapLayer or DecorationLayer instance and add it to the Layers collection of the view. Assigning a map to the BaseMap property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map property to the specified value.

Visibility of individual layers can be set through their Visible property. In addition, you can turn on or off interactive selection and highlighting in a layer by setting the EnableHighlight and EnableSelection properties. Even if interactive support is disabled, map elements can still be selected or highlighted programmatically by calling the Select or Highlight methods of the Layer class.

The following excerpt from the Layers sample project shows how to add several map layers displaying different maps:

C# [image] Copy Code

// load base map
var layer0 = new MapLayer();
layer0.Visible = true;
layer0.Map = new Map();
layer0.Map.LoadFromFile(FindMap("ne_50m_admin_0_countries.shp"));

mapView.Layers.Add(layer0);

// load urban areas map
var layer1 = new MapLayer();
layer1.Visible = false;
layer1.LineColor = Color.Yellow;
layer1.FillColors[0] = Color.Yellow;
layer1.Map = new Map();
layer1.Map.LoadFromFile(FindMap("ne_50m_urban_areas.shp"));

mapView.Layers.Add(layer1);

// load rivers map
var layer2 = new MapLayer();
layer2.Visible = false;
layer2.LineColor = Color.Blue;
layer2.Map = new Map();
layer2.Map.LoadFromFile(FindMap("50m_rivers_lake_centerlines.shp"));

mapView.Layers.Add(layer2);

Visual Basic [image] Copy Code

' load base map
Dim layer0 As New MapLayer()
layer0.Visible = True
layer0.Map = New Map()
layer0.Map.LoadFromFile(FindMap("ne_50m_admin_0_countries.shp"))

mapView.Layers.Add(layer0)

' load urban areas map
Dim layer1 As New MapLayer()
layer1.Visible = False
layer1.LineColor = Color.Yellow
layer1.FillColors(0) = Color.Yellow
layer1.Map = New Map()
layer1.Map.LoadFromFile(FindMap("ne_50m_urban_areas.shp"))

mapView.Layers.Add(layer1)

' load rivers map
Dim layer2 As New MapLayer()
layer2.Visible = False
layer2.LineColor = Color.Blue
layer2.Map = New Map()
layer2.Map.LoadFromFile(FindMap("50m_rivers_lake_centerlines.shp"))

mapView.Layers.Add(layer2)


Customizing the Map

Customizing the Map

Maps can be customized by assigning labels to the map elements, by specifying new colors, or by adding decoration images.

To set an element's label, assign to the Label property of MapElement. The label is diplayed using the font set through the FontName and FontSize properties. Note that labels can be automatically loaded from the Shapefile database by passing a column name as third argument of the LoadFromStream method.

Colors of map elements can be set via the Color property of the Shape class. This property specifies an index within the layer's palette. The palette colors can be customized via the FillColors property of the Layer class. By default, all shapes are painted using the same color. The AssignColors method lets you automatically assign colors in such a way that no adjacent shapes share the same color.


Decorations

Decorations

Decorations can be displayed by adding a DecorationLayer to the MapView. At this time there are two kinds of built-in decorations supported, DecorationImage and DecorationBubble.

DecorationImage can display a bitmap image at the specified latitude and longitude. This is useful if you need to show an icon (e.g denoting a landmark or a kind of business object) located there. The image is set via the Image property. You can specify an additional image through the HighlightImage property, which is drawn over the main image when the decoration is highlighted or selected. The PivotX and PivotY properties lets you specify the exact pixel within the image that should be placed at the decoration's map location. Decoration images can also have an associated Label drawn below them.

DecorationBubble is used to drawn a circle at the specified latitude and longitude. The circle radius length can be set proportionally to some statistical value associated with the location, for example population or income. The circle can be customized by setting its Label, FontName, FontSize, FillColor and BorderColor properties.

The following excerpt from the Markers sample project shows how to add a decoration layer and decoration images to the map view:

C# [image] Copy Code

// add a second layer to display decoration objects
var decorationLayer = new DecorationLayer(mapView.BaseMap.BoundingBox);
mapView.Layers.Add(decorationLayer);

// create decoration images
foreach (var landmark in landmarks)
{
var img = new DecorationImage(
Image.FromFile(@"Images\" + landmark.Image),
landmark.ImageX, landmark.ImageY,
landmark.Latitude, landmark.Longitude);
img.Label = landmark.Label;
decorationLayer.Decorations.Add(img);
}

Visual Basic [image] Copy Code

' add a second layer to display decoration objects
Dim decorationLayer = New DecorationLayer(mapView.BaseMap.BoundingBox)
mapView.Layers.Add(decorationLayer)

' create decoration images
For Each landmark As var In landmarks
Dim img = New DecorationImage(Image.FromFile("Images\" & Convert.ToString(landmark.Image)), landmark.ImageX, landmark.ImageY, landmark.Latitude, landmark.Longitude)
img.Label = landmark.Label
decorationLayer.Decorations.Add(img)
Next


Scrolling and Zooming

Scrolling and Zooming

In order to enable scrolling and zooming, the MapView control must be placed inside a ScrollViewer.

The view can be panned interactively by dragging it with the mouse. The user can also zoom into or out of the map via the mouse wheel. To implement a different scroll or zoom interaction logic, you can use the properties and methods exposed by MapView from various input event handlers. In order to change the scroll position, call the ScrollTo method. In order to change the zoom level, set the ZoomFactor property or call the SetZoomFactor method.

The following excerpt from the Markers sample project shows how to center the view on a specific decoration object:

C# [image] Copy Code

mapView.ZoomFactor = 6;

// office is a reference to a DecorationBubble instance
mapView.ScrollTo(office.Latitude, office.Longitude);

// focus is necessary in order to receive mouse wheel events
mapView.Focus();

Visual Basic [image] Copy Code

mapView.ZoomFactor = 6

' office is a reference to a DecorationBubble instance
mapView.ScrollTo(office.Latitude, office.Longitude)

' focus is necessary in order to receive mouse wheel events
mapView.Focus()


MindFusion.Reporting for WPF Overview

MindFusion.Reporting for WPF Overview

The next few chapters will give you an overview of the majority of the MindFusion.Reporting for WPF features, grouped by functionality. Hyperlinks refer to the detailed description of methods and properties of each class.


Report Items

Report Items

The following items are available to use in the MindFusion.Reporting for WPF reports. Report items share several common properties (derived from the base class ReportItem). The most important properties are Location and Size - specifying respectively the position and size of the item relative to its parent element. Other properties affecting the appearance of the item are Background, BorderBrush and BorderThickness.

Page

The page is the most fundamental element of a MindFusion.Reporting for WPF report. Pages in the report are represented by objects of the Page class. Each report can contain an arbitrary number of pages. The page itself can contain an arbitrary number of other report elements, such as labels and data ranges. When the report is processed by a call to its Run method, the pages can be split if the target space is insufficient to hold the processed page contents.

Properties

Pages have few properties of interest. Amongst them are the properties affecting the page appearance - Background, BorderBrush and BorderThickness. The Location property is irrelevant and is ignored. The Size property of pages only defines a design-time size. The actual page size depends on the parameters passed to the Layout method during report layout.

Header and Footer

Each page can optionally contain a header and/or a footer. Headers are displayed on top of the page, while footers are displayed at the bottom. If a page is split during report processing, its header and footer are displayed for each occurrence of the page in the final layout. Report Designer) or through XAML or code. The header and footer of a page are defined through DataTemplate objects, which are assigned to the HeaderTemplate and FooterTemplate properties of the page respectively. The root element of the data templates needs to be an ItemContainer object.

Here is an example of a page with a header and a footer declared in XAML:

XAML [image] Copy Code

<r:Page>

<r:Page.HeaderTemplate>
<DataTemplate>
<r:ItemContainer Size="100%,45">
<r:Label Text="This is the page header" Size="100%,45" Background="Orange"
HorizontalAlignment="Center" VerticalAlignment="Bottom" />
</r:ItemContainer>
</DataTemplate>
</r:Page.HeaderTemplate>

<!-- Page content -->

<r:Page.FooterTemplate>
<DataTemplate>
<r:ItemContainer Size="100%,45">
<r:Label Text="This is the page footer" Size="100%,45" Background="Orange"
HorizontalAlignment="Center" VerticalAlignment="Bottom" />
</r:ItemContainer>
</DataTemplate>
</r:Page.FooterTemplate>

</r:Page>

There are various properties, such as BorderBrush, Background and Visible, which affect the visualization of the header and footer in the final layout.

Label

The label elements display texts within a report. Labels are represented by the Label class. The text displayed by the label can be either static, a value from a data source or a value calculated by an expression. Additionally, the text can contain various formatting specifiers, such as <b>, <i> and so on, which affect its appearance. The text displayed by a label is specified through its Text property.

Data-bound labels

Labels can be bound to values using ordinary WPF bindings. The DataContext of the label depends on the location of the label within the report. The DataContext of labels, placed in a data-bound DataRange object, are automatically initialized to corresponding object in the data range's data source when the DataRange is run. The DataContext of labels outside of a DataRange object is inherited from the label's parent element. The following XAML code demonstrates a label with text bound to the MyMember property of its DataContext.

XAML [image] Copy Code

<r:Label Text="{Binding MyMember}" />

Expressions

Labels can display texts more complex than static and bound values. You can include expressions within the text of the label. When the text is processed, the expressions within it are evaluated and replaced with the result of the evaluation. To embed expressions in the label text enclose the expressions in square brackets. For example, the following label text is valid and it will display the string "Date: " followed by the system's date at the time of evaluation. Note, that the expression in the example is highlighted in bold.

Expression [image] Copy Code

Date: [Now()]

The result of the evaluation of the above text will be something similar to "Date: 12/10/2008 2:23:38 PM".

It is possible to specify formatting to the value of the expression. To do so, add an '@' symbol after the expression but before the closing ']' then add the string representing the formatting specifier enclosed in quotes. The following example extends the previous one by adding formatting to the resulting date. Note, that the formatting specifier in the example is highlighted in bold.

Expression [image] Copy Code

Date: [Now()@"d"]

The result of the evaluation will now be similar to the following: "Date: 12/10/2008".

If you are using expressions in XAML, you might have to escape the quotes in the formatting specifier using &quot;:

Expression [image] Copy Code

<r:Label Text="Date: [Now()@&quot;d&quot;]" />

For more information about the expressions in MindFusion.Reporting for WPF in general, visit Expressions. For more information on how to use expressions in label texts, check Using Expressions in Label Texts.

Properties

The Text of the label is formatted using the string specified by the TextFormat property. Keep in mind that if the text evaluates to a string, the TextFormat property will have no effect on the output.

Other properties affecting the appearance of the label include FontFamily, FontSize, FontStyle and FontWeight, which affect the font of the displayed text; Background, BorderBrush and BorderThickness, which affect the border and background of the label; HorizontalAlignment, VerticalAlignment and Padding, which affect the positioning of the displayed text.

DataRange

The data range elements provide a way to implement master-detail relationships in MindFusion.Reporting for WPF reports. The data ranges are represented by the DataRange class. Extensive information about how to data-bind using data ranges can be found in the Supplying data for the Report topic.

Properties

DataRange objects inherit some common visualization properties, such as Background, BorderBrush and BorderThickness. There are three additional properties - AlternatingBackground, AlternatingBorderBrush and AlternatingBorderThickness, which default to null (Nothing in Visual Basic). When these properties are assigned values different from null, they are used as the background and border of even occurrences of this data range in the final layout. In other words, Background, BorderBrush an BorderThickness are used for the odd occurrences of a data range, while AlternatingBackground, AlternatingBorderBrush an AlternatingBorderThickness are used for the even ones.

The ArrangeByX property specifies whether to attempt to lay out data range instances horizontally first, then vertically. If ArrangeByX is set to false (the default), the instances of the data range are always arranged vertically regardless of whether there is space along the x-axis. The Repeat property is used with disconnected data ranges to specify the number of occurrences of these data ranges in the final layout.

Picture

The picture elements enable you to add static images to a report. Pictures are represented by the Picture class. Similarly to labels, pictures can be data-bound. The content of the picture is specified through the Image property.

Properties

The border and background of the image can be specified through the BorderBrush, BorderThickness and Background properties respectively. You can transform the image through the RenderTransform property. The alignment of the displayed image is controlled through the HorizontalAlignment and VerticalAlignment property.

CustomReportItem

Custom report items allow embedding of any WPF framework element in a MindFusion.Reporting for WPF report. The content of the custom report item is specified through its Template property. This property is of type DataTemplate, similarly to the ItemTemplate property of a DataRange. In contrast to the DataRange however, the root of the custom report item's template is not required to be ItemContainer.

In addition to the template, the custom items also provide a Value property, which can be used to associate particular object with the item. This object can be subsequently bound to from the elements contained in the template.

The following example demonstrates a very simple CustomReportItem, declared in XAML:

XAML [image] Copy Code

<r:CustomReportItem Value="5">
<r:CustomReportItem.Template>
<DataTemplate>
<TextBlock Text="{Binding}" />
</DataTemplate>
</r:CustomReportItem.Template>
</r:CustomReportItem>

The report item above will simply display a WPF TextBlock with Text = "5". However, it illustrates the flexibility provided by the CustomReportItem class when creating MindFusion.Reporting for WPF reports.


Supplying Data for the Report

Supplying Data for the Report

The data for a report is supplied through its DataContext property. This could be either a DataSet, a collection or any other arbitrary object. Items within the report can bind to various properties of the supplied data object using common WPF bindings. The following example illustrates a report containing a label. The label in the report has its Text property bound to the StringValue property of the report's DataContext object.

XAML [image] Copy Code

<r:Report x:Name="report">
<r:Report.DataContext>
<l:SomeObject StringValue="someValue" />
</r:Report.DataContext>
<r:Page>
<r:Label Text="{Binding StringValue}" />
</r:Page>
</r:Report>

The DataContext property of the report is inherited by its children, which means that if an item in the report does not have an explicitly set DataContext, it will inherit the DataContext of its parent item. In the sample above the Page inherits the DataContext from the report and the Label in turn inherits it from the page. There are exceptions to this rule as outlined in the section below.

Using DataRange objects

The DataRange items are used to display lists of elements - for example arrays or data tables. Therefore, it is required that the data object supplied to the DataRange implements the IEnumerable interface. The DataRange object provides an ItemTemplate property, which defines the template of the individual objects in the supplied data.

The data for the DataRange is supplied through its DataSource property. If the value of this property is null (Nothing in Visual Basic) the DataRange raises the QueryDetails event on its containing report passing its current DataContext object as a master row. If the event does not yield a result, the DataRange uses its current DataContext as a data source.

When the DataRange processes its data source, it creates an instance of the template specified by the ItemTemplate property for each object in the data source. The DataContext of these new instances is set to the corresponding object in the data source. For example, if the DataRange displays a table with ten records, ten new instances of the ItemTemplate are created and the DataContext of each new instance is set to the corresponding record in the database table.

In the following example a DataRange is bound to the Employee table in an existing data set. The data set is expected to be set as a DataContext of the report, containing the DataRange.

XAML [image] Copy Code

...
<r:DataRange DataSource="{Binding Employees}" />
...

The DataRange in the above example can provide an ItemTemplate for the objects in its data source. Assuming that the Employee table has a column, named FirstName, the following example demonstrates a label which binds its Text to this column:

XAML [image] Copy Code

...
<r:DataRange DataSource="{Binding Employees}">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Text="[FirstName]" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
...

Note that the root element of the DataTemplate object provided by the ItemTemplate should always be an ItemContainer object.

Master detail relations

MindFusion.Reporting for WPF supports master detail relation through data range composition. You need to create a data range, bound to the master data. Then you need to create another data range as a child of the first one. The details data for the embedded data range is then supplied through the QueryDetails event of the report. The inner data range usually provides a name so that it can be identified in the QueryDetails event handler. Here is a XAML code defining two embedded data ranges:

XAML [image] Copy Code

...
<r:DataRange DataSource="{Binding Employees}">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:DataRange Name="OrdersRange" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
...

The following code illustrates a sample QueryDetails event handler, which supplies the details data for the inner data range. The example relies on a GetEmployeeOrders method, which takes care of the actual retrieval of the orders for a specific employee.

C# [image] Copy Code

void report_QueryDetails(object sender, QueryDetailsEventArgs e)
{
DataRange dataRange = sender as DataRange;
if (dataRange != null)
{
if (dataRange.Name == "OrdersRange")
{
// Obtains the orders related to the corresponding employee
e.Details = GetEmpoyeeOrders(e.MasterRow);
}
}
}

Visual Basic [image] Copy Code

Sub myReport_QueryDetails(ByVal sender As Object, ByVal e As QueryDetailsEventArgs)

Dim dataRange As DataRange = sender
If (Not dataRange Is Nothing) Then

If (dataRange.Name = "ProductsRange") Then

e.Details = GetEmployeeOrders(e.MasterRow)

End If

End If

End Sub


Custom Rendering of Report Elements

Custom Rendering of Report Elements

The term "rendering" is used to identify the process of creation of the report's visual appearance. A report is rendered when either RenderPage or RenderAllPages methods of a ReportLayout object are invoked. Both of these methods operate on an IRenderTarget object.

When a report is rendered, the items in the report are iterated and a visual representation is created for each item. This visual representation is represented by a WPF UIElement object, which is considered the root of the item's visual tree. After the item's visuals are created, the root UIElement object is passed to the Render method of the IRenderTarget object.

Customizing Rendering

After the item's visual representation is created but before it is passed to the Render method of the IRenderTarget object a special event is raised - Report.Prerender. This event enables clients to modify or completely replace the visual representation of the item before it is added to the final visual tree of the report. The event can also be used to prevent the rendering of an item.

Modifying Appearance

The root UIElement object defining the visual appearance of the item being rendered can be obtained from the RootVisual property of the PrerenderEventArgs object accompanying the Prerender event. The structure of the RootVisual depends on the type of the report item being rendered. The following table lists the structure of the RootVisual corresponding to different report items.

Report Item | RootVisual
CustomReportItem | <ContentControl />
ItemContainer | <Border />
Label | <Border> <TextBlock /> </Border>
Page | <Border />
Picture | <Border> <Image /> </Border>
PieChart |

For example, to change the background of a Label, cast the RootVisual object to Border and set its Background.

Replacing Appearance

The RootVisual property can be set to any UIElement-derived object and this object will be used as appearance for the item. Note that the report layout is not affected by the size of the new RootVisual.

The following example demonstrates how to replace the appearance of all Label objects in a report with WPF Button elements. The example assumes that e is a reference to the PrerenderEventArgs passed to the event handler.

C# [image] Copy Code

if (e.Item is Label)
{
var label = e.Item as Label;
e.RootVisual = new Button()
{
Width = e.Size.Width,
Height = e.Size.Height,
Content = label.Text,
Padding = new Thickness(0),
};
}

Visual Basic [image] Copy Code

If TypeOf e.Item Is Label Then

Dim label = CType(e.Item, Label)
e.RootVisual = New Button() With _
{ _
.Width = e.Size.Width, _
.Height = e.Size.Height, _
.Content = label.Text, _
.Padding = New Thickness(0) _
}

End If

Preventing Rendering

To prevent an item from appearing in the final report, set the SkipRender property of the accompanying PrerenderEventArgs to false. Hiding an item (as well as changing the size of the item's visual presentation) has no effect on the layout of the report.


Charts in Reports

Charts in Reports

MindFusion.Reporting for WPF provides a single chart item - a PieChart, which can be used to visualize data as pie charts.

PieChart

The following image illustrates a simple pie chart:

Data

The data to be displayed by the PieChart is provided through its DataSource property. If this property is null (Nothing in Visual Basic) the PieChart raises the QueryDetails event of its containing report passing its DataContext as a master row and uses the return IEnumeration as data source. If QueryDetails did not yield any details, the DataContext is used as a data source.

The TargetMember property of the pie chart specifies the property of the objects in the data source, which will be used for pie plotting.

Appearance

The pie chart inherits some general properties from its base class ReportItem, such as Background, BorderBrush and BorderThickness. Various other properties affect the appearance of the pie pieces, such as Brushes, PieBrush, PieStroke and PieStrokeThickness.


Running, Laying Out and Rendering

Running, Laying Out and Rendering

Processing

In order to use existing reports in any way they need to be processed by calling their Run method. Calling this method results in the creation of various internal structures corresponding to the data the report is bound to. If the source data or the report design change in any way, the report needs to be rerun.

Laying out

Once the report is run, it can be laid out on target pages of specific sizes by calling its Layout method, passing as arguments the size of the paper to layout on and the paper margin. Both size and margin are expressed in device independent pixels (1/96-th of an inch). The following code lays out the report on a standard A4 paper format with 0.5 inch margin:

C# [image] Copy Code

ReportLayout layout = report.Layout(
new Size(8.5 * 96, 11 * 96), new Thickness(0.5 * 96),
MindFusion.Reporting.PageOrientation.Portrait);

Visual Basic [image] Copy Code

Dim layout = report.Layout( _
New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96), _
MindFusion.Reporting.PageOrientation.Portrait)

The result of report layout is encapsulated in a ReportLayout object, which can be manipulated independently of the source report. The same report can be laid out multiple times (on papers of different sizes and orientations, for example) without having to run it over and over again. Its important to note however, that rerunning a report will invalidate all its current layouts. Performing any operation on an invalid layout will result in an InvalidOperationException.

Rendering

Once the report is laid out, we can render its pages using a IRenderTarget object. The following code illustrates how to render a report to a WPF FixedDocument object using the FixedDocumentRenderTarget class.

C# [image] Copy Code

FixedDocumentRenderTarget renderTarget = new FixedDocumentRenderTarget();
for (int i = 0; i < layout.PageCount; i++)
layout.RenderPage(i, renderTarget);

Visual Basic [image] Copy Code

Dim renderTarget As New FixedDocumentRenderTarget()
For i = 0 To layout.PageCount - 1
layout.RenderPage(i, renderTarget)
Next i

The resulting FixedDocument can be accessed through the Document property of the FixedDocumentRenderTarget instance.

To check how to export a report as an image, check Exporting Reports.


Report Parameters

Report Parameters

Report parameters have names, description and value. The value of a parameter can be any object, including expression.

Adding Report Parameters

Report parameters can be added to a report through the Parameters collection of the Report class. Parameters can be added either programmatically or through the built-in editor inside a designer.

Adding Parameters in Code

To add a parameter in code, create an instance of this class, specify its name, value, and optionally description and type (through the Name, Value, Description, and Type properties respectively), and add it to the Parameters collection. The type of a parameter is determined automatically from the value. However, setting the type explicitly is required when the parameter value is an expression. Otherwise, the value will be interpreted as string. The following code illustrates how to create a parameter with expression value in code:

C# [image] Copy Code

ReportParameter parameter = new ReportParameter("DateCreated", "[Now()]");
parameter.Type = ReportParameterType.Expression;
report.Parameters.Add(parameter);

Visual Basic [image] Copy Code

Dim parameter As New ReportParameter("DateCreated", "[Now()]")
parameter.Type = ReportParameterType.Expression
report.Parameters.Add(parameter)

Adding Parameters in XAML

To add a report parameter in XAML, use the following syntax:

XAML [image] Copy Code

<r:Report>
<r:Report.Parameters>
<r:ReportParameter Name="test" Value="5" Type="Double" />
<r:ReportParameter Name="DateCreated" Value="[Now()]" Type="Expression" />
</r:Report.Parameters>

...

</r:Report>

Accessing Report Parameters

Report parameters can be referenced in expressions by name. To access a report parameter, prefix its name with "Parameters." or "Report.". The following example demonstrates an expression that references the DateCreated parameter defined earlier:

Expression [image] Copy Code

The report was created on [Parameters.DateCreated.Value]

The Value member reference above is optional. Specifying [Parameters.DateCreated] will yield the same result. If the value of a parameter is an expression, it will be evaluated when the parameter is accessed.

The name, type or description of the parameter can be referenced using the same syntax. For example, the following expression displays the description of a parameter:

Expression [image] Copy Code

[Parameters.MyParam.Description]

If the value of the report parameter is a custom object, the properties of this object can be accessed in the same manner.

It is possible to reference report parameters within the value of other parameters. This needs to be done with caution to avoid cyclic referencing, which will result in an exception.


Displaying Reports in a DocumentViewer

Displaying Reports in a DocumentViewer

In order to display a report in a DocumentViewer it needs to be processed, laid out and rendered to a FixedDocument object. To learn more about these operations, check the Running, Laying Out and Rendering topic. Once the report is rendered in a FixedDocument all that needs to be done is assigning that document to the DocumentViewer's Document property.

The following code illustrates all necessary steps. The code assumes that report and viewer are variables identifying existing Report and DocumentViewer objects respectively.

C# [image] Copy Code

report.Run();

ReportLayout layout = report.Layout(
new Size(8.5 * 96, 11 * 96), new Thickness(0.5 * 96),
MindFusion.Reporting.PageOrientation.Portrait);

FixedDocumentRenderTarget renderTarget = new FixedDocumentRenderTarget();
layout.RenderAllPages(renderTarget);

viewer.Document = renderTarget.Document;

Visual Basic [image] Copy Code

report.Run()

Dim layout = report.Layout( _
New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96), _
MindFusion.Reporting.PageOrientation.Portrait)

Dim renderTarget = New FixedDocumentRenderTarget()
layout.RenderAllPages(renderTarget)

viewer.Document = renderTarget.Document


Printing and Print Previewing

Printing and Print Previewing

To print or preview a report, you can use the built-in ReportPrinter class. The class provides only two methods - Print and Preview, which perform the necessary tasks. The following code prints a report identified by the report variable.

C# [image] Copy Code

ReportPrinter reportPrinter = new ReportPrinter(report);
reportPrinter.Print();

Visual Basic [image] Copy Code

Dim reportPrinter As New ReportPrinter(report)
reportPrinter.Print()

Keep in mind that the report should have been processed by a call to its Run method before it is printed or previewed.


Exporting Reports

Exporting Reports

Exporting to image

Reports can be exported to an image by rendering them using an ImageRenderTarget object. Before the report can be rendered, it needs to be processed and laid out. To learn more about these operations, check Running, Laying Out and Rendering topic. Once the report is rendered in an ImageRenderTarget object, it can be saved in a variety of image formats by calling the Save of the ImageRenderTarget. All standard image formats are supported, including BMP, GIF, JPEG, TIFF, PNG and WMP.

The following code illustrates how to export an existing report as a multi-frame TIFF. The example assumes that the report is already processed by a call to its Run method.

C# [image] Copy Code

// Layout the report
ReportLayout layout = report.Layout(
new Size(8.5 * 96, 11 * 96), new Thickness(0.5 * 96),
MindFusion.Reporting.PageOrientation.Portrait);

// Create and setup the rendering target
ImageRenderTarget renderTarget = new ImageRenderTarget()
{
PageBackground = Brushes.White,
PageBorderBrush = Brushes.Black,
IsMultipage = true,
};

// Perform the rendering
layout.RenderAllPages(renderTarget);

renderTarget.Save("myreport.tif", new TiffBitmapEncoder());

Visual Basic [image] Copy Code

' Layout the report
Dim layout As ReportLayout = report.Layout( _
New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96), _
MindFusion.Reporting.PageOrientation.Portrait)

' Create and setup the rendering target
Dim renderTarget As New ImageRenderTarget() With _
{ _
.PageBackground = Brushes.White, _
.PageBorderBrush = Brushes.Black, _
.IsMultipage = True _
}

' Perform the rendering
layout.RenderAllPages(renderTarget)

renderTarget.Save("myreport.tif", New TiffBitmapEncoder())

ImageRenderTarget provides several useful properties. The IsMultipage property specifies whether the report pages should be rendered to separate bitmap frames or whether all pages should be rendered in a single frame one below the other. Many image formats do not support multiple frames. If IsMultipage is true and the target format does not support multiple frames, only the first page will be exported.

The Dpi property can be used to specify custom DPI for the output image. If this property is set to 0 (the default value), the output image will have the DPI of the screen.

The PageBackground and PageBorderBrush properties specify the appearance for pages, which do not explicitly specify Background and BorderBrush. If a page does not have background and PageBackground is not set, the page will be rendered as either transparent or using the default background color of the target image format, usually black.

Exporting as PDF

Reports can be easily exported to PDF by using the PdfExporter class. The reports being exported must have been previously processed by a call to their Run method but do not necessarily need to be laid out. The PDF exporter performs internal layouting according to the specified settings.

To export a report to PDF, instantiate from the PdfExporter class and call the Export method. This method takes two arguments - the report to be exported and the file name of the output PDF. Several options can be specified on the PdfExporter object before calling Export, such as the page size and orientation.

Note

The PdfExporter class is located in the MindFusion.Reporting.Wpf.PdfExport.dll assembly. In order to use this class, you have to add a reference to this assembly to your project. In addition, the MindFusion.Reporting.Wpf.PdfExport.dll is dependent on the MindFusion.Common.dll and MindFusion.Pdf.dll assemblies, so you will have to deploy those two as well (although it might not be necessary to reference them directly in your project).

Several enumerations used by the PdfExporter class, such as PageSize and PageOrientation are located in MindFusion.Pdf.dll.

The following code illustrates how to export an existing report (identified by the report variable) to a PDF:

C# [image] Copy Code

PdfExporter exporter = new PdfExporter();
exporter.PageSize = MindFusion.Pdf.PageSize.A3;
exporter.PageOrientation = MindFusion.Pdf.PageOrientation.Landscape;
exporter.Export(report, "report.pdf");

Visual Basic [image] Copy Code

Dim exporter As New PdfExporter()
exporter.PageSize = MindFusion.Pdf.PageSize.A3
exporter.PageOrientation = MindFusion.Pdf.PageOrientation.Landscape
exporter.Export(report, "report.pdf")

Exporting as HTML/MHTML

Exporting to HTML/MHTML is very similar to exporting to PDF - you create an instance of the HtmlExporter/MhtmlExporter class, set the desired options and call the Export method. As is usual, the exported report must have been previously run by a call to its Run method. Several options can be specified on the exporter including page size and margins.

Note

The HtmlExporter and MhtmlExporter classes are located in the MindFusion.Reporting.Wpf.HtmlExport.dll assembly. In order to use these classes, you have to add a reference to this assembly to your project.

During the export to HTML all images are exported to a special folder, as specified by the imageFolder argument of the Export method. Various other report elements can be exported as image as well. Prime example are the elements filled with gradient brushes and CustomReportItem elements.

The following code illustrates how to export an existing report to an HTML:

C# [image] Copy Code

HtmlExporter exporter = new HtmlExporter();
exporter.PageSize = new Size(11 * 96, 17 * 96);
exporter.Export(report, "report.html", "");

Visual Basic [image] Copy Code

Dim exporter As New HtmlExporter()
exporter.PageSize = New Size(11 * 96, 17 * 96)
exporter.Export(report, "report.html", "");

Exporting as XLSX

Similarly to the other exporters, create an instance of the ExcelExporter class, set the desired options and call the Export method. As is usual, the exported report must have been previously run by a call to its Run method. Several options can be specified on the ExcelExporter including page size and margins.

Note

The ExcelExporter class is located in the MindFusion.Reporting.Wpf.ExcelExport.dll assembly. In order to use this class, you have to add a reference to this assembly to your project.

The following code illustrates how to export an existing report to an XLSX:

C# [image] Copy Code

ExcelExporter exporter = new ExcelExporter();
exporter.Export(report, "report.xlsx");

VB.NET [image] Copy Code

Dim exporter As New ExcelExporter()
exporter.Export(report, "report.xlsx")


Expressions

Expressions


Overview

Overview

Expressions in MindFusion.Reporting for WPF are conceptually very similar to expressions in various programming languages, such as C# and Visual Basic. An expression is a text fragment that can be evaluated to a single value or object. Expressions can contain a literal value, a function invocation, an operator and its operands, or a member reference.

Expressions can use operators that in turn use other expressions as parameters, or function calls whose parameters are in turn other method calls, so expressions can range from simple to very complex.

Literals

The simplest type of expression is a literal. A literal is a constant value written directly in the expression. For example 5 and "Hello World" in the example below are both literals.

Expression [image] Copy Code

"Hello world"
5

The first line in the example is an expression containing a single literal - the string "Hello World". The second line is another expression containing the number 5. Both of these expressions evaluate to their contained literals.

Literals in MindFusion.Reporting for WPF can be numbers, strings and colors. The string literals should be enclosed in quotes. The color literals have the format #RRGGBB, where RR, GG and BB are the hexadecimal representations of the red, green and blue channels of the color.

Identifiers

Identifiers are character sequences starting with a letter and containing an arbitrary number of letters and numbers. The following expressions are examples of identifiers:

Expression [image] Copy Code

Price
width
label1

An identifier can be evaluated to either a member in the current data context or an object in the report. For example, if identifier expression is associated with a label contained in a DataRange, bound to a table data source, then the identifier will be interpreted as a field in that table. The special identifier this evaluates to the object containing the expression - usually a label.

The following example shows an expression,which concatenates two data fields of type string - FirstName and LastName:

Expression [image] Copy Code

FirstName + " " + LastName

In the case when the identifier evaluates to an object, the dot (.) operator can be applied to it in order to reference a member of this object. The following expression will evaluate to the width of the object containing the expression:

Expression [image] Copy Code

this.Width

For more information on how to use expressions in labels check Using Expressions in Label Texts.

Invoking Functions

The following example demonstrates another type of expression, called function invocation. The function in the example is Len with a single string argument.

Expression [image] Copy Code

Len("Hello World")

A function invocation requires the name of the function, followed by parenthesis and any function parameters. The function invocation evaluates to the return value of the function. In the above example, the invocation will evaluate to the number of characters in the string specified as argument, that is, 11.

Each function expects arguments of specific type. Passing an argument of type that does not match the type the function expects will either result in false evaluation or a run-time error. Additionally, the number of arguments passed to the function should match the number of arguments expected.

There are numerous predefined functions that can be called within an expression. A complete list with all available functions, see Function Reference.

Operators

An operator is a symbol that takes one or more expressions, called operands, as input and returns a value. Operators that take one operand, such as the unary minus operator (-) are called unary operators. Operators that take two operands, such as arithmetic operators (+, -, *, /) are called binary operators. In MindFusion.Reporting for WPF there are no tertiary operators.

The following example illustrates an expression that is the sum of two numbers (operands).

Expression [image] Copy Code

2 + 3

The operand of an operator can be any valid expression that evaluates to a value of the same type as the one expected by the operator. For example, the following expression applies operators to the result of a function invocation, then passes the result as an argument to another function.

Expression [image] Copy Code

Sqrt(Pow(SideA, 2) + Pow(SideB, 2))

The example evaluates the hypotenuse of a right triangle with sides specified by the identifiers SideA and SideB respectively.

The following table describes the operators available in MindFusion.Reporting for WPF in more details:

Operator | Description
+ | Addition. The addition operator can work on both number and string operands, including mixing between both.
- | Subtraction or Unary minus. Can be applied on numeric operands.
! | Logical negation. Unary operator that can be applied only on boolean operands.
*, / | Multiplication and Division. Can be applied to any numeric operands.
% | Modulo. Can be applied on integer operands and returns the reminder of the division between them.
<, >, <=, >= | Comparison operators. Can be used on numeric operands.
==, <> | Equality operators. Can be used on numeric and string operands.
&&, || | Logical AND and OR operators. Can be applied on boolean operands.
&, ^, | | Bitwise operators (OR, XOR and OR). Can be applied on integer operands.
. | Member reference operator. Can be applied to objects in order to reference a member.

Operator precedence

The operators encountered in an expression are evaluated according to their precedence. Operators with higher priority are evaluated before operators with lower priority. The following example will evaluate to 14, because the multiplication will be evaluated first.

Expression [image] Copy Code

2 + 3 * 4

You can change operator precedence by using parenthesis. Changing the order of the operators in the above example, so that the addition is performed first, can be done like this:

Expression [image] Copy Code

(2 + 3) * 4

The following table lists the operators in order of precedence:

Member reference | .
Unary | - (unary), !
Arithmetic - Multiplicative | +, - (binary)
Arithmetic - Additive | <, >, <=, >=
Relational | <, >, <=, >=
Equality | ==, <>
Logical, in order of precedence | &, ^, |
Conditional, in order of precedence | &&, ||


Function Reference

Function Reference

The functions available in expressions are organized in several categories, based on their purpose. Some functions belong to more than one category. Below is a table of all functions sorted alphabetically.

Name | Description
Abs | Returns the absolute value of a specified number.
Acos | Returns the angle whose cosine is the specified number.
Asc | Returns the ANSI character code corresponding to the first letter in a string.
Asin | Returns the angle whose sine is the specified number.
Atn | Returns the angle whose tangent is the specified number.
CBool | Converts the value, specified as an argument, to a value of type Boolean.
CDate | Converts the value, specified as an argument, to a value of type Date.
CDbl | Converts the value, specified as an argument, to a value of type Double.
Chr | Returns the character associated with the specified ANSI character code.
CInt | Converts the value, specified as an argument, to a value of type Integer.
CLong | Converts the value, specified as an argument, to a value of type Long.
Cos | Returns the cosine of an angle.
CStr | Converts the value, specified as an argument, to a value of type String.
CSng | Converts the value, specified as an argument, to a value of type float.
DateAdd | Returns a date to which a specified time interval has been added.
DatePart | Returns the specified part of a given date.
Day | Returns a whole number between 1 and 31, inclusive, representing the day of the month.
DateDiff | Returns the number of intervals between two dates.
DateSerial | Returns a value of type Date for a specified year, month, and day.
E | Represents the natural logarithmic base, specified by the constant, e.
Exp | Returns e raised to the specified power.
Hour | Returns a whole number between 0 and 23, inclusive, representing the hour of the day.
IIf | Returns one of two parts, depending on the evaluation of an expression.
InStr | Returns the position of the first occurrence of one string within another.
InStrRev | Returns the position of an occurrence of one string within another, from the end of string.
Int | Returns the integer portion of a number.
IsDate | Returns a Boolean value indicating whether an expression can be converted to a date.
IsNull | Returns a Boolean value that indicates whether an expression contains no valid data (Null).
IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.
LCase | Returns a string that has been converted to lowercase.
Left | Returns a specified number of characters from the left side of a string.
Len | Returns the number of characters in a string.
Log | Returns the logarithm of a specified number.
LTrim | Returns a copy of a string without leading spaces.
Mid | Returns a specified number of characters from a string.
Minute | Returns a whole number between 0 and 59, inclusive, representing the minute of the hour.
Month | Returns a whole number between 1 and 12, inclusive, representing the month of the year.
Now | Returns the current date and time according to the setting of your computer's system date and time.
PageCount | Returns the number of pages.
PageCurrent | Returns the number of the current page.
PI | Represents the ratio of the circumference of a circle to its diameter.
Pow | Returns a specified number raised to the specified power.
RangeItemCount | Returns the count of the items in the current DataRange.
RangeItemCurrent | Returns a number that is the index of the current instance of the DataRange.
Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
Right | Returns a specified number of characters from the right side of a string.
Rnd | Returns a random number.
Round | Returns the number nearest the specified value.
RTrim | Returns a copy of a string without trailing spaces.
Second | Returns a whole number between 0 and 59, inclusive, representing the second of the minute.
Sgn | Returns a value indicating the sign of a number.
Sin | Returns the sine of the specified angle.
Space | Returns a string consisting of the specified number of spaces.
Sqr | Returns the square root of a number.
Sqrt | Returns the square root of a number.
Str | Returns a string representation of a number.
StrComp | Returns a value indicating the result of a string comparison.
String | Returns a repeating character string of the length specified.
StrReverse | Returns a string in which the character order of a specified string is reversed.
Today | Returns a DateTime value containing the current date according to your system.
Tan | Returns the tangent of the specified angle.


Aggregate Functions

Aggregate Functions

The following functions are contained in this category:

Name | Description
Avg | Returns the average of the values identified by a specified field.
Count | Returns the number of the values identified by a specified field.
Max | Returns the maximum of the values identified by a specified field.
Median | Returns the median of the values identified by a specified field.
Min | Returns the minimum of the values identified by a specified field.
Sum | Returns the sum of the values identified by a specified field.


Avg

Avg

Returns the average of the values identified by the specified field.

Syntax

Copy Code

double Avg (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The average of all values identified by fieldName.

See Also

Aggregate Functions


Count

Count

Returns the number of the values identified by the specified field.

Syntax

Copy Code

int Count (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The number of values identified by fieldName.

See Also

Aggregate Functions


COUNT

COUNT

Counts the numbers in the specified cell, cells, and lists.

Syntax [image] Copy Code

COUNT( [Any value1], [Any value2], ... ) → Integer

Parameters

value1
value2
…
Zero or more items to include in the counting.

Remarks

Arguments that are numbers, dates, or text representations of numbers (such as "123") are counted. Logical values and text representations of numbers types directly into the list of arguments are counted. Error values are not counted and do not cause the function to return an error (that is, this function does not propagate errors). If an argument is an array or a reference, only numbers in that array or reference are counted. Empty cells, logical values, text, or error values are not counted. To count logical values, text, or error values, use the COUNTA function. To count only numbers that meet certain criteria, use the COUNTIF function.

If there are no arguments provided, the function returns zero.

Example

Formula [image] Copy Code

=COUNT(A1:B5)
=COUNT(3,"1",A1,B2:B5,{1;2})

See Also

Function Reference
COUNTA Function


COUNTA

COUNTA

Counts the number of cells that are not empty in the specified cell or cells, and the items in the lists.

Syntax [image] Copy Code

COUNTA( [Any value1], [Any value2], ... ) → Integer

Parameters

value1
value2
…
Zero or more items to include in the counting.

Remarks

Counts the number of non-blank values in the supplied list. A value is non-blank if it contains any content of any type, including an error. In a reference, every cell that is not empty is included in the count. In arrays, all elements that are not blank are included. An empty text value ("") is not considered blank. Errors values are counted and do not cause the function to return an error (that is, this function does not propagate errors). To exclude error values, logical values, and text representations of numbers in a reference as part of the calculation, use the COUNT function.

If there are no arguments provided, the function returns zero.

Example

Formula [image] Copy Code

=COUNTA(A1:B5)
=COUNTA(3,"1",A1,B2:B5,{1;2})

See Also

Function Reference
COUNT Function
ISBLANK Function


COUNTBLANK

COUNTBLANK

Counts the empty cells in the specified ranges of cells.

Syntax [image] Copy Code

COUNTBLANK( [Reference value1], [Reference value2], ... ) → Integer

Parameters

value1
value2
…
Zero or more cell references to include in the counting.

Remarks

Counts the number of non-blank values in the cell or cells in the specified list. A cell is considered blank if it does not contain any data, that is if ISBLANK for this cell returns TRUE. Cells containing zeros, or empty strings are not blank. Errors values are not counted and do not cause the function to return an error (that is, this function does not propagate errors).

If there are no arguments provided, the function returns zero.

Example

Formula [image] Copy Code

=COUNTBLANK(A1:C5)

See Also

Function Reference
COUNT Function
COUNTA Function
COUNTIF Function


COUNTIF

COUNTIF

Counts the number of cells in the specified range that meet the specified criterion.

Syntax [image] Copy Code

COUNTIF( Reference r, Criterion c ) → Integer

Parameters

r
Required. A reference that identifies the cells to count.
c
Required. A number or text value that defines which cells to count. For example, ">10", "products", "5".

Remarks

The criterion can be a number or a text value. If c is a number, the cells are counted if they contain numbers equal to the criterion or text values equal to the text representation of the criterion. If c is a string that starts with a comparison operator ('<=', '<>', '<', '>=', '>', '=') the cell values are counted if they satisfy the condition of the criterion. For example, the cell with value 10 will be counted if c is '<15'. Cells with text values cannot satisfy criteria with the following comparison operators: '<=', '<', '>', and '>='. Text comparison is case-insensitive.

Criteria can contain wildcard characters - the question mark (?) and the asterisk (*). A question mark matches any single character, and an asterisk matches any sequence of characters. To match blank cells use blank or empty criteria.

Example

Formula [image] Copy Code

=COUNTIF(A1:A5,">50")
=COUNTIF(A10:I15,"us*")

See Also

Function Reference
COUNT Function
COUNTA Function
COUNTIF Function


Max

Max

Returns the maximum of the values identified by the specified field.

Syntax

Copy Code

double Max (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The maximum of all values identified by fieldName.

See Also

Aggregate Functions


MAX

MAX

Returns the largest from the specified arguments.

Syntax [image] Copy Code

MAX( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers for which to find the maximum value.

Remarks

The arguments can be either numbers, or cells or arrays that contain numbers. Logical values, text, and empty cells are ignored. To consider logical values and text, use the MAXA function.

Example

Formula [image] Copy Code

=MAX(A1:A5)
=MAX(A1:A5,25)

See Also

Function Reference
MAXA Function
MIN Function
MINA Function


MAXA

MAXA

Returns the largest from the specified arguments, including logical and text values.

Syntax [image] Copy Code

MAXA( Any value1, [Any value2], ... ) → Number

Parameters

value1
value2
…
One or more numbers, texts, or logical values for which to find the maximum value.

Remarks

The arguments can be either numbers, text, or logical values, or cells or arrays, containing numbers, text, or logical values. Text values are treated as zeros. Logical TRUE is treated as 1, and FALSE is treated as 0. Empty cells are not included.

Example

Formula [image] Copy Code

=MAXA(A1:A5)
=MAXA(A1:A5,"V",1>0)

See Also

Function Reference
MAX Function
MIN Function
MINA Function


Median

Median

Returns the median of the values identified by the specified field.

Syntax

Copy Code

double Median (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The median of the values identified by fieldName.

Remarks

When the number of values is even, Median returns the average of the two values in the middle. For example, if the list of values is [1, 3, 9, 12], this function returns the average of 3 and 9, that is, 6.

See Also

Aggregate Functions


MEDIAN

MEDIAN

Returns the median (middle value) of the specified arguments.

Syntax [image] Copy Code

MEDIAN( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers for which to find the median value.

Remarks

The arguments can be either numbers or logical values, or cells or arrays that contain numbers or logical values. Text and empty cells are ignored.

MEDIAN sorts the numbers smallest to largest. If given an odd number of values, MEDIAN returns the middle value. If given an even number of values, MEDIAN returns the arithmetic average of the two middle values.

Example

Formula [image] Copy Code

=MEDIAN(A1:A6)
=MEDIAN({1;3;4;11})

See Also

Function Reference
COUNT Function
COUNTA Function
SUM Function


Min

Min

Returns the minimum of the values identified by the specified field.

Syntax

Copy Code

double Min (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The minimum of all values identified by fieldName.

See Also

Aggregate Functions


MIN

MIN

Returns the smallest from the specified arguments.

Syntax [image] Copy Code

MIN( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers for which to find the minimum value.

Remarks

The arguments can be either numbers, or cells or arrays that contain numbers. Logical values, text, and empty cells are ignored. To consider logical values and text, use the MINA function.

Example

Formula [image] Copy Code

=MIN(A1:A5)
=MIN(A1:A5,25)

See Also

Function Reference
MINA Function
MAX Function
MAXA Function


MINA

MINA

Returns the smallest from the specified arguments, including logical and text values.

Syntax [image] Copy Code

MINA( Any value1, [Any value2], ... ) → Number

Parameters

value1
value2
…
One or more numbers, texts, or logical values for which to find the minimum value.

Remarks

The arguments can be either numbers, text, or logical values, or cells or arrays, containing numbers, text, or logical values. Text values are treated as zeros. Logical TRUE is treated as 1, and FALSE is treated as 0. Empty cells are not included.

Example

Formula [image] Copy Code

=MINA(A1:A5)
=MINA(A1:A5,"V",1>0)

See Also

Function Reference
MIN Function
MAX Function
MAXA Function


Sum

Sum

Returns the sum of the values identified by the specified field.

Syntax

Copy Code

double Sum (
string fieldName
)

Parameters

fieldName
A string identifying the field to aggregate.

Return Value

The sum of all values identified by fieldName.

See Also

Aggregate Functions


SUM

SUM

Returns the sum of the specified arguments.

Syntax [image] Copy Code

SUM( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers to sum.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain any numbers, the function returns 0.

Example

Formula [image] Copy Code

=SUM(A1:A5,10,{1;4})

See Also

Function Reference
AVERAGE Function
COUNT Function
COUNTA Function


SUMIF

SUMIF

Returns the sum of the cells in the specified range that meet the specified criterion.

Syntax [image] Copy Code

SUMIF( Reference r, Criterion c, [Reference sumRange] ) → Number

Parameters

r
Required. A reference that identifies the cells to evaluate.
c
Required. A number or text that defines which cells to sum. For example, 32, "32", ">32", "apples".
sumRange
Optional. The actual cells to add if their corresponding cells in r match c.

Remarks

If the optional range sumRange is specified, then the values of sumRange starting from the top left cell and matching the geometry of r (same number of rows and columns) are summed if the corresponding value in r meets c. The actual range r is not considered. If the resulting range exceeds the sheet bounds (column numbers larger than the maximum column or row numbers larger than the maximum), no error is generated - the cells falling outside are silently ignored.

The criterion can be a number or a text value. If c is a number, the cells match if they contain numbers equal to the criterion or text values equal to the text representation of the criterion. If c is a string that starts with a comparison operator ('<=', '<>', '<', '>=', '>', '=') the cell values match if they satisfy the condition of the criterion. For example, the cell with value 10 will be counted if c is '<15'. Cells with text values cannot satisfy criteria with the following comparison operators: '<=', '<', '>', and '>='. Text comparison is case-insensitive.

Criteria can contain wildcard characters - the question mark (?) and the asterisk (*). A question mark matches any single character, and an asterisk matches any sequence of characters.

Example

Formula [image] Copy Code

=SUMIF(A1:A5,">1000")

See Also

Function Reference
COUNTIF Function
SUM Function
IF Function


SUMPRODUCT

SUMPRODUCT

Returns the sum of the products of the values in the specified arrays.

Syntax [image] Copy Code

SUMPRODUCT( ReferenceOrArray array1, [ReferenceOrArray array2], ... ) → Number

Parameters

array1
array2
…
One or more arrays or cell references to include in the calculation.

Remarks

All parameters shall have the same dimensions. Otherwise, the function will return the #VALUE! error value. SUMPRODUCT treats entries that are not numeric as if they were zeros.

Example

Formula [image] Copy Code

=SUMPRODUCT(A1:B4,C1:D4)

See Also

Function Reference


SUMSQ

SUMSQ

Returns the sum of the squares of the specified arguments.

Syntax [image] Copy Code

SUMSQ( Number n1, Number n2, ... ) → Number

Parameters

n1
n2
…
One or more numbers to sum.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain any numbers, the function returns 0.

Example

Formula [image] Copy Code

=SUMSQ(A1:A5)

See Also

Function Reference
SUM Function
SUMPRODUCT Function


Conversion Functions

Conversion Functions

The following functions are contained in this category:

Name | Description
CBool | Converts the value, specified as an argument, to a value of type Boolean.
CDate | Converts the value, specified as an argument, to a value of type Date.
CDbl | Converts the value, specified as an argument, to a value of type Double.
CInt | Converts the value, specified as an argument, to a value of type Integer.
CLong | Converts the value, specified as an argument, to a value of type Long.
CSng | Converts the value, specified as an argument, to a value of type float.
CStr | Converts the value, specified as an argument, to a value of type String.
Int | Returns the integer portion of a number.
Str | Returns a string representation of a number.


CBool

CBool

Converts the value, specified as an argument, to a value of boolean type.

Syntax

Copy Code

bool CBool (
object value
)

Parameters

value
An expression that can be evaluated to a boolean.

Return Value

true, if the specified value can be evaluated as a boolean and evaluates to true; otherwise, false.

Remarks

If value is a boolean, value is returned. If value is a number, true is returned if the number is non-zero, otherwise - false. If value is a string, true is returned if the string is "true" and false if the string is "false", no case-sensitive.

See Also

Conversion Functions
CDate Function
CDbl Function
CInt Function
CLong Function
CSng Function
CStr Function


CDate

CDate

Converts the value, specified as an argument, to a value of date type.

Syntax

Copy Code

DateTime CDate (
object value
)

Parameters

value
Any date expression or a string expression recognizable as a date or time.

Return Value

A DateTime value.

Remarks

Use the IsDate function to determine if value can be converted to a date. CDate recognizes date literals and time literals as well as some numbers that fall within the range of acceptable dates.

CDate recognizes date formats according to the locale setting of your system. The correct order of day, month, and year may not be determined if it is provided in a format other than one of the recognized date settings. In addition, a long date format is not recognized if it also contains the day-of-the-week string.

See Also

Conversion Functions
Date & Time Functions
DateAdd Function
DatePart Function


CDbl

CDbl

Converts the value, specified as an argument, to a value of type double.

Syntax

Copy Code

double CDbl (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to double, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to double. If value is a string, it is parsed as a double and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CSng Function
CStr Function


CInt

CInt

Converts the value, specified as an argument, to a value of type int.

Syntax

Copy Code

int CInt (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to int, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to int. If value is a string, it is parsed as an integer and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CDbl Function
CSng Function
CStr Function


CLong

CLong

Converts the value, specified as an argument, to a value of type long.

Syntax

Copy Code

long CLong (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to long, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to long. If value is a string, it is parsed as a long and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CDbl Function
CInt Function
CStr Function


CSng

CSng

Converts the value, specified as an argument, to a value of type float.

Syntax

Copy Code

float CSng (
object value
)

Parameters

value
Any valid expression.

Return Value

Returns the specified argument converted to float, or 0, if the argument cannot be converted.

Remarks

If value is a number of any kind, it is converted to float. If value is a string, it is parsed as a float and the result is returned. If none of the above applies, 0 is returned.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CLong Function
CStr Function


CStr

CStr

Converts the value, specified as an argument, to a string value.

Syntax

Copy Code

string CStr (
object value
)

Parameters

value
Any valid expression.

Remarks

The data in value determines what is returned according to the following table:

Parameter Type | Return Value
Boolean | A string containing "true" or "false".
Date | A string containing a date in the short-date format of your system.
Null | A zero-length string ("").
Empty | A zero-length string ("").
Other numeric | A string containing the number.

See Also

Conversion Functions
CBool Function
CDate Function
CInt Function
CLong Function
CSng Function
Str Function


Int

Int

Returns the integer portion of a number.

Syntax

Copy Code

int Int (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The largest integer less than or equal to value.

See Also

Conversion Functions
Math Functions
CInt Function
Round Function


INT

INT

Rounds the specified number down to the nearest integer.

Syntax [image] Copy Code

INT( Number n ) → Number

Parameters

n
Required. The number to round.

Example

Formula [image] Copy Code

=INT(5.8)
=INT(-4.2)

See Also

Function Reference
CEILING Function
FLOOR Function
MOD Function
MROUND Function
ROUND Function
TRUNC Function


Str

Str

Returns a string representation of the specified number.

Syntax

Copy Code

string Str (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

Str converts the specified number to a string using the current regional settings. If you want to perform a more sophisticated formatting of a number or use a different culture, you have to use the formatting capabilities provided when embedding an expression.

See Also

Conversion Functions
String Function
Len Function


Date & Time Functions

Date & Time Functions

The following functions are contained in this category:

Name | Description
CDate | Converts the value, specified as an argument, to a value of type Date.
DateAdd | Returns a date to which a specified time interval has been added.
DateDiff | Returns the number of intervals between two dates.
DatePart | Returns the specified part of a given date.
DateSerial | Returns a value of type Date for a specified year, month, and day.
Day | Returns a whole number between 1 and 31, inclusive, representing the day of the month.
Hour | Returns a whole number between 0 and 23, inclusive, representing the hour of the day.
Minute | Returns a whole number between 0 and 59, inclusive, representing the minute of the hour.
Month | Returns a whole number between 1 and 12, inclusive, representing the month of the year.
Now | Returns the current date and time according to the setting of your computer's system date and time.
Second | Returns a whole number between 0 and 59, inclusive, representing the second of the minute.
Today | Returns a DateTime value containing the current date according to your system.


DateAdd

DateAdd

Returns a date to which a specified time interval has been added.

Syntax

Copy Code

DateTime DateAdd (
string type,
double count,
DateTime date
)

Parameters

type
A string expression that defines the type of units to add.
count
A numeric expression that specifies the number of units to add. This expression can either be positive, to perform addition, or negative, to perform subtraction.
date
A DateTime value to which the units are added.

Settings

The type parameter can have one of the following values:

Parameter Value | Description
y | The value of count represents the number of years to add or subtract from date.
m | The value of count represents the number of months to add or subtract from date.
d | The value of count represents the number of days to add or subtract from date.
h | The value of count represents the number of hours to add or subtract from date.
n | The value of count represents the number of minutes to add or subtract from date.
s | The value of count represents the number of seconds to add or subtract from date.

Remarks

You can use the DateAdd function to add or subtract a specified time interval from a date.

See Also

Date & Time Functions
DateDiff Function
DatePart Function


DateDiff

DateDiff

Returns the number of intervals between two dates.

Syntax

Copy Code

long DateDiff (
string part,
DateTime a,
DateTime b
)

Parameters

part
String expression that is the interval you want to use to calculate the differences between a and b. See Remarks section for values.
a
A DateTime value.
b
A DateTime value.

Remarks

The part parameter can have one of the following values:

Parameter Value | Description
y | The returned value specifies the difference between a and b, expressed in years.
m | The returned value specifies the difference between a and b, expressed in months.
d | The returned value specifies the difference between a and b, expressed in days.
h | The returned value specifies the difference between a and b, expressed in hours.
n | The returned value specifies the difference between a and b, expressed in minutes.
s | The returned value specifies the difference between a and b, expressed in seconds.

You can use the DateDiff function to determine how many specified time intervals exist between two dates. For example, use DateDiff to calculate the number of days between two dates.

If a refers to a later point in time than b, the DateDiff function returns a negative number.

When comparing December 31 to January 1 of the immediately succeeding year, DateDiff for Year ("y") returns 1 even though only a day has elapsed.

See Also

Date & Time Functions
DateAdd Function
DatePart Function


DatePart

DatePart

Returns the specified component of the specified date.

Syntax

Copy Code

int DatePart (
string part,
DateTime date
)

Parameters

part
A string expression that is the interval of time you want to return. See the Remarks section for possible values.
date
A DateTime value you want to evaluate.

Remarks

The part parameter can have the following values:

Parameter Value | Description
y | Returns the year component of date.
m | Returns the month component of date.
d | Returns the day component of date.
h | Returns the hour component of date.
n | Returns the minute component of date.
s | Returns the second component of date.

You can use the DatePart function to obtain a specific component of a date. For example, you can use DatePart to obtain the month of a particular date.

See Also

Date & Time Functions
DateAdd Function
DateDiff Function
Month Function
Day Function
Hour Functinon
Minute Function
Second Function


DateSerial

DateSerial

Returns a value of type DateTime for a specified year, month, and day.

Syntax

Copy Code

DateTime DateSerial (
int year,
int month,
int day
)

Parameters

year
An expression evaluating to a number between 100 and 9999, inclusive.
month
Any numeric expression.
day
Any numeric expression.

Remarks

To specify a date, such as December 31, 1991, the range of numbers for each DateSerial parameter should be in the accepted range for the unit; that is, 1-31 for days and 1-12 for months. However, you can also specify relative dates for each parameter using any numeric expression that represents some number of days, months, or years before or after a certain date.

When any parameter exceeds the accepted range for that parameter, it increments to the next larger unit as appropriate. For example, if you specify 35 days, it is evaluated as one month and some number of days, depending on where in the year it is applied. However, if the date specified by the three parameters, either directly or by expression, falls outside the acceptable range of dates, an error occurs.

See Also

Date & Time Functions
Day Function
Month Function
Now Function


Day

Day

Returns an integer number between 1 and 31, inclusive, representing the day of the month component of the specified date.

Syntax

Copy Code

int Day (
DateTime date
)

Parameters

date
A DateTime value.

See Also

Date & Time Functions
Hour Function
Minute Function
Month Function
Now Function
Second Function


DAY

DAY

Returns the day of the month of the specified date.

Syntax [image] Copy Code

DAY( Date date ) → Integer

Parameters

date
Required. The date to inspect.

Example

Formula [image] Copy Code

=DAY(TODAY())

See Also

Function Reference
HOUR Function
MINUTE Function
MONTH Function
NOW Function
SECOND Function
TODAY Function
WEEKDAY Function
YEAR Function


DAYS

DAYS

Returns the number of days between the specified dates.

Syntax [image] Copy Code

DAYS( Date endDate, Date startDate ) → Number

Parameters

endDate
Required. The end date of the interval.
startDate
Required. The start date of the interval.

Example

Formula [image] Copy Code

=DAYS(TODAY(),DATE(2013,1,1))

See Also

Function Reference
DAYS360 Function
DATEDIF Function


DAYS360

DAYS360

Returns the number of days between the specified two dates based on a 360-day year (twelve 30-day months).

Syntax [image] Copy Code

DAYS360( Date startDate, Date endDate ) → Number

Parameters

startDate
Required. The start date of the interval.
endDate
Required. The end date of the interval.

Example

Formula [image] Copy Code

=DAYS360(TODAY(),DATE(2013,1,1))

See Also

Function Reference
DAYS Function
DATEDIF Function


Hour

Hour

Returns a whole number between 0 and 23, inclusive, representing the hour of the day component of the specified date.

Syntax

Copy Code

double Hour (
DateTime date
)

Parameters

date
A DateTime value.

See Also

Date & Time Functions
Day Function
Minute Function
Month Function
Now Function
Second Function


HOUR

HOUR

Returns the hour component [0…23] of the specified time.

Syntax [image] Copy Code

HOUR( Time time ) → Integer

Parameters

time
Required. The time that contains the hour.

Remarks

Time values are a part of date values and are represented by decimal numbers. For example, 12:00 PM is represented by 0.5 because it is exactly halfway through a day.

Example

Formula [image] Copy Code

=HOUR(NOW())

See Also

Function Reference
DAY Function
MINUTE Function
MONTH Function
NOW Function
WEEKDAY Function
YEAR Function


Minute

Minute

Returns an integer number between 0 and 59, inclusive, representing the minute of the hour component of the specified date.

Syntax

Copy Code

int Minute (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the minute of the hour by calling DatePart.

See Also

Date & Time Functions
Day Function
Hour Function
Now Function
Second Function


MINUTE

MINUTE

Returns the minute component [0…59] of the specified time.

Syntax [image] Copy Code

MINUTE( Time time ) → Integer

Parameters

time
Required. The time that contains the minute.

Remarks

Time values are a part of date values and are represented by decimal numbers. For example, 12:00 PM is represented by 0.5 because it is exactly halfway through a day.

Example

Formula [image] Copy Code

=MINUTE(NOW())

See Also

Function Reference
DAY Function
HOUR Function
MONTH Function
NOW Function
SECOND Function
WEEKDAY Function


Month

Month

Returns a integer number between 1 and 12, inclusive, representing the month of the year component of the specified date.

Syntax

Copy Code

int Month (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the month of the year by calling DatePart.

See Also

Date & Time Functions
Day Function
Now Function


MONTH

MONTH

Returns the month of the specified date.

Syntax [image] Copy Code

MONTH( Date date ) → Integer

Parameters

date
Required. The date to inspect.

Remarks

The month is given as an integer, ranging from 1 (January) to 12 (December).

Example

Formula [image] Copy Code

=DAY(TODAY())

See Also

Function Reference
DAY Function
HOUR Function
MINUTE Function
NOW Function
WEEKDAY Function
YEAR Function


Now

Now

Returns the current date and time according to the setting of your computer's system date and time.

Syntax

Copy Code

DateTime Now ()

Remarks

To access the system date, use the Today property.

See Also

Date & Time Functions
Day Function
Hour Function
Minute Function
Month Function
Second Function


NOW

NOW

Returns the current system date and time.

Syntax [image] Copy Code

NOW( ) → Date

Example

Formula [image] Copy Code

=NOW()

See Also

Function Reference
DATE Function
DAY Function
HOUR Function
MINUTE Function
MONTH Function
WEEKDAY Function
TODAY Function


Second

Second

Returns an integer value between 0 and 59, inclusive, representing the second of the minute component of the specified date.

Syntax

Copy Code

int Second (
DateTime date
)

Parameters

date
A DateTime value.

Remarks

Alternatively, you can obtain the second of the hour by calling DatePart.

See Also

Date & Time Functions
Day Function
Hour Function
Minute Function
Now Property


SECOND

SECOND

Returns the second component [0…59] of the specified time.

Syntax [image] Copy Code

SECOND( Time time ) → Integer

Parameters

time
Required. The time that contains the minute.

Remarks

Time values are a part of date values and are represented by decimal numbers. For example, 12:00 PM is represented by 0.5 because it is exactly halfway through a day.

Example

Formula [image] Copy Code

=SECOND(NOW())

See Also

Function Reference
DAY Function
HOUR Function
MONTH Function
NOW Function
MINUTE Function
WEEKDAY Function


Today

Today

Returns a DateTime value containing the current system date.

Syntax

Copy Code

DateTime Today ()

Remarks

The DateTime data type includes time components. When returning the system date, Today sets all of these to 0, so the returned value represents midnight (00:00:00).

To access the day of a date, use the Day property.

See Also

Date & Time Functions
Now Function
DatePart Function
DateSerial Function
DateAdd Function


TODAY

TODAY

Returns the current date.

Syntax [image] Copy Code

TODAY( ) → Date

Remarks

This function returns the serial number of the current system's date. This only returns the date, without the time component. For the specific time of day as well, use the NOW function.

Example

Formula [image] Copy Code

=TODAY()
="The year is "&YEAR(TODAY())

See Also

Function Reference
DATE Function
TIME Function
DAY Function
NOW Function


Inspection Functions

Inspection Functions

The following functions are contained in this category:

Name | Description
IsDate | Returns a Boolean value indicating whether an expression can be converted to a date.
IsNull | Returns a Boolean value that indicates whether an expression contains no valid data (Null).
IsNumeric | Returns a Boolean value indicating whether an expression can be evaluated as a number.


IsDate

IsDate

Returns a boolean value indicating whether the specified expression can be converted to a date.

Syntax

Copy Code

bool IsDate (
object value
)

Parameters

value
Any expression.

Return Value

true, if value is a date or can be converted to a valid date; otherwise, false.

Remarks

A value is recognized as a date if it is a date, it is a string that contains a valid representation of a date, or it is a number. In the last case, the number will be interpreted as the number of ticks.

See Also

Inspection Functions
CDate Function
IsNull Function
IsNumeric Function


IsNull

IsNull

Returns a boolean value that indicates whether the specified expression contains no valid data (null).

Syntax

Copy Code

bool IsNull (
object value
)

Parameters

value
Any expression.

Return Value

true, if value is null, that is, it contains no valid data; otherwise, false.

See Also

Inspection Functions
IsDate Function
IsNumeric Function


IsNumeric

IsNumeric

Returns a boolean value indicating whether the specified expression can be evaluated to a number.

Syntax

Copy Code

bool IsNumeric (
object value
)

Parameters

value
Any expression.

Return Value

true, if the specified expression is recognized as a number; otherwise, false.

See Also

Inspection Functions
IsDate Function
IsNull Function


Math Functions

Math Functions

The following functions are contained in this category:

Name | Description
Abs | Returns the absolute value of a specified number.
Acos | Returns the angle whose cosine is the specified number.
Asin | Returns the angle whose sine is the specified number.
Atn | Returns the angle whose tangent is the specified number.
Cos | Returns the cosine of an angle.
E | Represents the natural logarithmic base, specified by the constant, e.
Exp | Returns e raised to the specified power.
Int | Returns the integer portion of a number.
Log | Returns the logarithm of a specified number.
PI | Represents the ratio of the circumference of a circle to its diameter.
Pow | Returns a specified number raised to the specified power.
Rnd | Returns a random number.
Round | Returns the number nearest the specified value.
Sgn | Returns a value indicating the sign of a number.
Sin | Returns the sine of the specified angle.
Sqr | Returns the square root of a number.
Sqrt | Returns the square root of a number.
Tan | Returns the tangent of the specified angle.


Abs

Abs

Returns the absolute value of the specified number.

Syntax

Copy Code

double Abs (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The absolute value of the specified number. If the specified value is not a number, 0 is returned.

Remarks

The absolute value of a number is its unsigned magnitude. For example, Abs(-1) and Abs(1) both return 1.

See Also

Math Functions
Sgn Function


ABS

ABS

Return the absolute (non-negative) value of the specified number.

Syntax [image] Copy Code

ABS( Number n ) → Number

Parameters

n
Required. The real number of which you want the absolute value.

Example

Formula [image] Copy Code

=ABS(-2)

See Also

Function Reference


Acos

Acos

Returns the angle whose cosine is the specified number.

Syntax

Copy Code

double Acos (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The angle whose cosine is the specified number.

See Also

Math Functions
Asin Function
Atn Function


ACOS

ACOS

Returns the arccosine, or inverse cosine, of the specified number. The arccosine is the angle whose cosine is the specified number. The returned angle is given in radians in the range [0…π].

Syntax [image] Copy Code

ACOS( Number n ) → Number

Parameters

n
Required. A number representing a cosine, in the range [-1…1].

Remarks

If you want to convert the result from radians to degrees, multiply it by 180/PI or use the DEGREES function.

Example

Formula [image] Copy Code

=ACOS(0.5)
=ACOS(0.5)*180/PI()

See Also

Function Reference
COS Function
PI Function
RADIANS Function
DEGREES Function


ACOSH

ACOSH

Returns the inverse hyperbolic cosine of the specified number. The inverse hyperbolic cosine is the value whose hyperbolic cosine is n, so ACOSH(COSH(n)) equals n.

Syntax [image] Copy Code

ACOSH( Number n ) → Number

Parameters

n
Required. The number whose inverse hyperbolic cosine to find. Must be greater than or equal to 1.

Example

Formula [image] Copy Code

=ACOSH(1)
=ACOSH(10)

See Also

Function Reference
ACOS Function
COSH Function
ASINH Function


Asin

Asin

Returns the angle whose sine is the specified number.

Syntax

Copy Code

double Asin (
double value
)

Parameters

value
Any valid numeric expression, where -1 <= value <= 1.

Remarks

A positive return value represents a counterclockwise angle from the x-axis; a negative return value represents a clockwise angle.

See Also

Math Functions
Acos Function
Atn Function


ASIN

ASIN

Returns the arcsine, or inverse sine, of the specified number. The arcsine is the angle whose sine is the specified number. The returned angle is given in radians in the range [-π/2…π/2].

Syntax [image] Copy Code

ASIN( Number n ) → Number

Parameters

n
Required. A number representing a sine, in the range [-1…1].

Remarks

To express the arcsine in degrees, multiply the result by 180/PI or use the DEGREES function.

Example

Formula [image] Copy Code

=ASIN(0.5)
=ASIN(0.5)*180/PI()

See Also

Function Reference
SIN Function
PI Function
RADIANS Function
DEGREES Function


ASINH

ASINH

Returns the inverse hyperbolic sine of the specified number. The inverse hyperbolic sine is the value whose hyperbolic sine is n, so ASINH(SINH(n)) equals n.

Syntax [image] Copy Code

ASINH( Number n ) → Number

Parameters

n
Required. The number whose inverse hyperbolic sine to find.

Example

Formula [image] Copy Code

=ASINH(1)
=ASINH(10)

See Also

Function Reference
ASIN Function
SINH Function
ACOSH Function


Atn

Atn

Returns the arctangent of the specified number.

Syntax

Copy Code

double Atn (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

The Atn function takes the ratio of two sides of a right triangle (number) and returns the corresponding angle in radians. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle. The range of the result is -pi/2 to pi/2 radians.

See Also

Math Functions
Cos Function
Sin Function
Tan Function


Cos

Cos

Returns the cosine of the specified angle.

Syntax

Copy Code

double Cos (
double value
)

Parameters

value
Any valid numeric expression that specifies an angle in radians.

Remarks

The Cos function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side adjacent to the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Math Functions
Sin Function
Tan Function


COS

COS

Returns the cosine of the specified angle.

Syntax [image] Copy Code

COS( Number n ) → Number

Parameters

n
Required. The angle for which to return the cosine. The angle is expressed in radians.

Remarks

If the angle is in degrees, multiply it by PI/180 or use the RADIANS function to convert it to radians.

Example

Formula [image] Copy Code

=COS(PI())
=COS(60*PI()/180)

See Also

Function Reference
ACOS Function
RADIANS Function
DEGREES Function


COSH

COSH

Returns the hyperbolic cosine of the specified number.

Syntax [image] Copy Code

COSH( Number n ) → Number

Parameters

n
Required. The number whose hyperbolic cosine to find.

Example

Formula [image] Copy Code

=COSH(1)
=COSH(10)

See Also

Function Reference
COS Function
ACOSH Function
SINH Function


E

E

Represents the natural logarithmic base, specified by the constant, e.

Syntax

Copy Code

double E ()

Return Value

The return value is the constant 2.71828.

See Also

Math Functions
Exp Function
Log Function


Exp

Exp

Returns e (the base of natural logarithms) raised to the specified power.

Syntax

Copy Code

double Exp (
double value
)

Parameters

value
Any valid numeric expression.

Return Value

The number e raised to the power value.

Remarks

The Exp function complements the action of the Log function and is sometimes referred to as the antilogarithm.

See Also

Math Functions
Sqr Function


EXP

EXP

Returns e raised to the specified power.

Syntax [image] Copy Code

EXP( Number x ) → Number

Parameters

x
Required. The exponent applied to the base e.

Remarks

The constant e equals 2.71828182845904, the base of the natural logarithm. To calculate powers of other bases use the exponentiation operator (^) or the POWER function.

Example

Formula [image] Copy Code

=EXP(1)

See Also

Function Reference
LOG Function
LN Function
POWER Function


Log

Log

Returns the natural (base e) logarithm of the specified number.

Syntax

Copy Code

double Log (
double value
)

Parameters

value
Any valid numeric expression greater than 0.

Remarks

The natural logarithm is the logarithm to the base e. The constant e is approximately 2.718282.

See Also

Math Functions
Exp Function


LOG10

LOG10

Returns the base-10 logarithm of the specified number.

Syntax [image] Copy Code

LOG10( Number n ) → Number

Parameters

n
Required. The number for which to find a logarithm. Must be a positive value.

Remarks

Returns the base-10 logarithm of n. If n is negative or zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=LOG10(100)

See Also

Function Reference
LOG Function
LN Function
POWER Function
EXP Function


LOG

LOG

Returns the logarithm of the specified number to the specified base.

Syntax [image] Copy Code

LOG( Number n, [Number base = 10] ) → Number

Parameters

n
Required. The number for which to find a logarithm. Must be a positive value.
base
Optional. The base of the logarithm. If omitted, base is assumed to be 10.

Remarks

Returns the logarithm of n in the specified base. If either n or base is negative or zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=LOG(100)
=LOG(16,2)

See Also

Function Reference
LOG10 Function
LN Function
POWER Function
EXP Function


PI

PI

Returns the constant value of p.

Syntax

Copy Code

double PI ()

Remarks

The numeric constant p is the ratio of the circumference of a circle to its diameter.

Return Value

The return value is the constant 3.14159.

See Also

Math Functions
Pow Function


Pow

Pow

Returns the specified number raised to the specified power.

Syntax

Copy Code

double Pow (
double a,
double b
)

Parameters

a
A number to be raised to a power.
b
A number that specifies a power.

Return Value

The number x raised to the power y.

See Also

Math Functions
Sqr Function


POWER

POWER

Returns the specified number raised to the specified power.

Syntax [image] Copy Code

POWER( Number n, Number power ) → Number

Parameters

n
Required. The number to raise.
power
Required. The power to raise to.

Remarks

The "^" operator can be used instead of POWER to raise a number to a power, such as in 5^2.

Example

Formula [image] Copy Code

=POWER(5,2)
=POWER(2.1,-2.5)

See Also

Function Reference
LOG Function
LOG10 Function
LN Function
EXP Function


Rnd

Rnd

Returns a random number.

Syntax

Copy Code

double Rnd (
int type
)

Parameters

type
An integer value.

Return Value

The return value depends on the type parameter. The following table describes the behavior of the function depending on the value of the value of type:

Parameter Value | Description
Less than zero | The same number every time, using type as the seed.
Greater than zero | The next random number in the sequence.
Equal to zero | The most recently generated number.

Remarks

The Rnd function returns a value less than 1, but greater than or equal to zero. The value of type determines how Rnd generates a random number as outlined in the above table.

See Also

Math Functions


Round

Round

Returns the specified value rounded to the specified precision.

Syntax

Copy Code

double Round (
double value,
int digits
)

Parameters

value
A number to be rounded.
digits
The number of significant fractional digits (precision) in the return value.

Return Value

Returns the number nearest to value with precision equal to digits. If value is halfway between two numbers, one of which is even and the other odd, then the even number is returned. If the precision of value is less than digits, then value is returned unchanged.

Remarks

The digits parameter specifies the number of significant fractional digits in the return value and ranges from 0 to 28. If digits is zero, then a whole number is returned.

This kind of rounding is sometimes called rounding to nearest, or banker's rounding. If digits is zero, this kind of rounding is sometimes called rounding toward zero.

See Also

Math Functions
Left Function
RTrim Function


ROUND

ROUND

Returns the specified number, rounded to the specified number of digits.

Syntax [image] Copy Code

ROUND( Number n, [Integer digits = 0] ) → Number

Parameters

n
Required. The number to round
digits
Optional. The number of digits to round to. If omitted, digits is assumed to be 0.

Remarks

If digits is greater than 0, the number is rounded to the specified number of decimal places. If digits is 0, the number is rounded to the nearest integer. If digits is less than 0, the number is rounded to the left of the decimal point. If digits is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=ROUND(2.15,1)
=ROUND(21.5,-1)

See Also

Function Reference
TRUNC Function
INT Function


ROUNDDOWN

ROUNDDOWN

Returns the specified number, rounded down (towards zero) to the specified number of digits.

Syntax [image] Copy Code

ROUNDDOWN( Number n, [Integer digits = 0] ) → Number

Parameters

n
Required. The number to round.
digits
Optional. The number of digits to round to. If omitted, digits is assumed to be 0.

Remarks

If digits is greater than 0, the number is rounded to the specified number of decimal places. If digits is 0, the number is rounded down to the nearest integer. If digits is less than 0, the number is rounded to the left of the decimal point. If digits is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=ROUNDDOWN(2.95,1)
=ROUNDDOWN(21.9,-1)

See Also

Function Reference
TRUNC Function
INT Function
ROUND Function
ROUNDUP Function


ROUNDUP

ROUNDUP

Returns the specified number, rounded up (away from zero) to the specified number of digits.

Syntax [image] Copy Code

ROUNDUP( Number n, [Integer digits = 0] ) → Number

Parameters

n
Required. The number to round.
digits
Optional. The number of digits to round to. If omitted, digits is assumed to be 0.

Remarks

If digits is greater than 0, the number is rounded to the specified number of decimal places. If digits is 0, the number is rounded up to the nearest integer. If digits is less than 0, the number is rounded to the left of the decimal point. If digits is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=ROUNDUP(2.15,1)
=ROUNDUP(21.5,-1)

See Also

Function Reference
TRUNC Function
INT Function
ROUND Function
ROUNDDOWN Function


Sgn

Sgn

Indicates the sign of a number.

Syntax

Copy Code

double Sgn (
double value
)

Parameters

value
A numeric expression.

Return Value

The function has the following possible return values:

Parameter Value | Return Value
Greater than zero | 1
Equal to zero | 0
Less than zero | -1

If value cannot be evaluated to a number or is null, the function returns 0.

Remarks

The sign of the value parameter determines the return value of the Sgn function.

See Also

Math Functions
Abs Function
Str Function


Sin

Sin

Returns the sine of the specified angle.

Syntax

Copy Code

double Sin (
double value
)

Parameters

value
Any valid numeric expression.

Remarks

This function takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the hypotenuse. The result lies in the range -1 to 1, inclusive.

See Also

Math Functions
Asin Function
Cos Function
Tan Function


SIN

SIN

Returns the sine of the specified angle.

Syntax [image] Copy Code

SIN( Number n ) → Number

Parameters

n
Required. The angle for which to return the sine. The angle is expressed in radians.

Remarks

If the angle is in degrees, multiply it by PI/180 or use the RADIANS function to convert it to radians.

Example

Formula [image] Copy Code

=SIN(PI())
=SIN(30*PI()/180)

See Also

Function Reference
ASIN Function
RADIANS Function
DEGREES Function


SINH

SINH

Returns the hyperbolic sine of the specified number.

Syntax [image] Copy Code

SINH( Number n ) → Number

Parameters

n
Required. The number whose hyperbolic sine to find.

Example

Formula [image] Copy Code

=SINH(1)
=SINH(10)

See Also

Function Reference
SIN Function
ASINH Function
COSH Function


Sqr

Sqr

Returns square root of the specified number.

Syntax

Copy Code

double Sqr (
double value
)

Parameters

value
A numeric expression for which the square root is calculated.

Remarks

If value is negative, the return value is NaN.

See Also

Math Functions
Log Function


Sqrt

Sqrt

Returns the square root of the specified number.

Syntax

Copy Code

double Sqrt (
double value
)

Parameters

value
A numeric expression for which the square root is calculated.

Remarks

If value is negative, the return value is NaN.

See Also

Math Functions


SQRT

SQRT

Returns the square of the specified number.

Syntax [image] Copy Code

SQRT( Number n ) → Number

Parameters

n
Required. The number for which to find square root.

Remarks

If n is negative, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=SQRT(16)

See Also

Function Reference
POWER Function
SQRTPI Function


SQRTPI

SQRTPI

Returns the square root of the specified number multiplied by π (pi).

Syntax [image] Copy Code

SQRTPI( Number n ) → Number

Parameters

n
Required. The number for which to find square root.

Remarks

Calculates the square root of (n * π). If n is negative, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=SQRTPI(2)

See Also

Function Reference
POWER Function
SQRT Function
PI Function


Tan

Tan

Returns the tangent of the specified angle.

Copy Code

double Tan (
double value
)

Parameters

value
Any valid numeric expression that specifies the angle in radians.

Remarks

Tan takes an angle and returns the ratio of two sides of a right triangle. The ratio is the length of the side opposite the angle divided by the length of the side adjacent to the angle.

See Also

Math Functions
Atn Function
Cos Function
Sin Function


TAN

TAN

Returns the tangent of the specified angle.

Syntax [image] Copy Code

TAN( Number n ) → Number

Parameters

n
Required. The angle for which to return the tangent. The angle is expressed in radians.

Remarks

If the angle is in degrees, multiply it by PI/180 or use the RADIANS function to convert it to radians.

Example

Formula [image] Copy Code

=TAN(PI())
=TAN(45*PI()/180)

See Also

Function Reference
ATAN Function
ATAN2 Function
RADIANS Function
DEGREES Function
SIN Function
COS Function
PI Function


TANH

TANH

Returns the hyperbolic tangent of the specified number.

Syntax [image] Copy Code

TANH( Number n ) → Number

Parameters

n
Required. The number whose hyperbolic tangent to find.

Example

Formula [image] Copy Code

=TANH(1)
=TANH(10)

See Also

Function Reference
TAN Function
ATANH Function


Miscellaneous Functions

Miscellaneous Functions

The following functions are contained in this category:

Name | Description
PageCount | Returns the number of pages.
PageCurrent | Returns the number of the current page.
RangeItemCount | Returns the count of the items in the current DataRange.
RangeItemCurrent | Returns a number that is the index of the current instance of the DataRange.


PageCount

PageCount

Returns the total number of pages within the current report.

Syntax

Copy Code

int PageCount ()

Remarks

PageCount is only usable in expressions related to report items. For example, PageCount is usable in expressions embedded in the Text of a Label. When evaluated it returns the total number of pages in the final report layout.

See Also

Miscellaneous Functions
PageCurrent Function
RangeItemCurrent Function
RangeItemCount Function


PageCurrent

PageCurrent

Returns the number of the current page.

Syntax

Copy Code

int PageCurrent ()

Remarks

PageCurrent is only usable in expressions related to report items. For example, PageCurrent is usable in expressions embedded in the Text of a Label. When evaluated it returns the index of the page in the final report layout to which the associated report item belongs to.

See Also

Miscellaneous Functions
PageCount Function
RangeItemCount Function
RangeItemCurrent Function


RangeItemCount

RangeItemCount

Returns the total number of instances of the current DataRange.

Syntax

Copy Code

int RangeItemCount ()

Remarks

RangeItemCount is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCount is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Miscellaneous Functions
RangeItemCurrent Function
PageCount Function
PageCurrent Function


RangeItemCurrent

RangeItemCurrent

Returns the index of the current instance of the current DataRange.

Syntax

Copy Code

int RangeItemCurrent ()

Remarks

RangeItemCurrent is only usable in expressions related to report items, which are containted in DataRange containers. For example, RangeItemCurrent is usable in expressions embedded in the Text of a Label, but only when this label is contained in a DataRange. When evaluated it returns the total number of instances of the related DataRange.

See Also

Miscellaneous Functions
RangeItemCount Function
PageCount Function
PageCurrent Function


Program Flow Functions

Program Flow Functions

The following functions are contained in this category:

Name | Description
IIf | Returns one of two objects, depending on the evaluation of an expression.


IIf

IIf

Returns one of two objects, depending on the evaluation of an expression.

Syntax

Copy Code

object IIf (
bool condition,
object a,
object b
)

Parameters

condition
The expression you want to evaluate.
a
An expression returned if condition evaluates to true.
b
An expression returned if condition evaluates to false.

Return Value

Returns a if condition evaluates to true; otherwise, returns b.

Example

The following example demonstrates how you can use IIf to find the smaller of two numbers:

Copy Code

IIf(5 < 3, 5, 3)

Although the result of the above calculation is obvious, this may not always be the case. Here is the same example applied to fields from a database:

Copy Code

IIf(Field1 < Field2, Field1, Field2)

See Also

Program Flow Functions


Text Functions

Text Functions

The following functions are contained in this category:

Name | Description
Asc | Returns the ANSI character code corresponding to the first letter in a string.
Chr | Returns the character associated with the specified ANSI character code.
InStr | Returns the position of the first occurrence of one string within another.
InStrRev | Returns the position of an occurrence of one string within another, from the end of string.
LCase | Returns a string that has been converted to lowercase.
Left | Returns a specified number of characters from the left side of a string.
Len | Returns the number of characters in a string.
LTrim | Returns a copy of a string without leading spaces.
Mid | Returns a specified number of characters from a string.
Replace | Returns a string in which a specified substring has been replaced with another substring a specified number of times.
Right | Returns a specified number of characters from the right side of a string.
RTrim | Returns a copy of a string without trailing spaces.
Space | Returns a string consisting of the specified number of spaces.
StrComp | Returns a value indicating the result of a string comparison.
String | Returns a repeating character string of the length specified.
StrReverse | Returns a string in which the character order of a specified string is reversed.


Asc

Asc

Returns the ANSI character code corresponding to the first letter in the specified string.

Syntax

Copy Code

string Asc (
string value
)

Parameters

value
A string expression.

Remarks

If value contains no characters, a run-time error occurs.

See Also

Text Functions
Chr Function


Chr

Chr

Returns the character associated with the specified ANSI character code.

Syntax

Copy Code

string Chr (
int c
)

Parameters

c
A number that identifies a character.

Remarks

Numbers from 0 to 31 are the same as standard, nonprintable ASCII codes.

See Also

Text Functions
Asc Function


InStr

InStr

Returns the position of the first occurrence of one string within another.

Syntax

Copy Code

int InStr (
string a,
string b
)

Parameters

a
A string expression representing the string being searched.
b
A string expression representing the string being searched for.

Return Value

The InStr function returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

Text Functions
InStrRev Function


InStrRev

InStrRev

Returns the position of the first occurrence of one string within another, starting from the end of string.

Syntax

Copy Code

int InStrRev (
string a,
string b
)

Parameters

a
A string expression representing the string being searched.
b
A string expression representing the string being searched for.

Return Value

InStrRev returns the following values:

Parameter | Return Value
a is zero-length | -1
a is null | -1
b is zero-length | -1
b is null | -1
b is not found | -1
b is found within a | The position at which match is found.

See Also

Text Functions
InStr Function


LCase

LCase

Returns the specified string converted to lowercase.

Syntax

Copy Code

string LCase (
string value
)

Parameters

value
Any valid string expression.

Remarks

Only uppercase letters are converted to lowercase; all lowercase letters and non-letter characters remain unchanged.

See Also

Text Functions
Str Function


Left

Left

Returns the specified number of characters from the left side of the specified string.

Syntax

Copy Code

string Left (
string a,
int length
)

Parameters

a
A string expression from which the leftmost characters are returned. If a is null, null is returned.
length
A numeric expression indicating how many characters to return. If 0, a zero-length string is returned. If greater than or equal to the number of characters in a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Text Functions
Right Function
Len Function
Mid Function


LEFT

LEFT

Returns the specified number of characters from the left of the specified text.

Syntax [image] Copy Code

LEFT( Text text, [Integer length = 1] ) → Text

Parameters

text
Required. The string containing the characters that should be returned.
length
Optional. The number of characters to return. If omitted, length is assumed to be 1. Must be non-negative integer.

Remarks

If length is negative, the function returns #VALUE!. If length is greater than the number of characters in text, the entire text is returned. If length is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=LEFT(A1,LEN(A1)-1)
=LEFT("-350")

See Also

Function Reference
LEN Function
MID Function
RIGHT Function


Len

Len

Returns the number of characters in the specified string.

Syntax

Copy Code

int Len (
string value
)

Parameters

value
Any valid string expression. If value is null, the function returns zero.

See Also

Text Functions
InStr Function


LEN

LEN

Returns the number of characters in the specified text.

Syntax [image] Copy Code

LEN( Text text ) → Integer

Parameters

text
Required. The text whose length to find.

Remarks

Returns the number of characters in text. If text is a number, it is automatically converted to text, including a fractional part and decimal separator if necessary.

Example

Formula [image] Copy Code

=LEN(A1&A2)

See Also

Function Reference
TEXT Function
ISTEXT Function
LEFT Function
MID Function
RIGHT Function


LTrim

LTrim

Returns a copy of the specified string without leading white spaces.

Syntax

Copy Code

string LTrim (
string value
)

Parameters

value
Any valid string expression. If value is null, null is returned.

Remarks

Use RTrim to return a string without its trailing white spaces.

See Also

Text Functions
Left Function
Right Function
RTrim Function


Mid

Mid

Returns a specified number of characters from a string.

Syntax

Copy Code

string Mid (
string value,
int pos,
int length
)

Parameters

value
A string expression from which characters are returned. If value is null, null is returned.
pos
The zero-based starting character position in value of the substing to be returned. If pos is greater than the number of characters in value, the function returns an empty string ("").
length
The number of characters to return. If there are fewer than length characters in the string, all characters from pos to the end of the string are returned.

Remarks

To determine the number of characters in a string, use the Len function.

See Also

Text Functions
Left Function
Right Function
Len Function


MID

MID

Returns the specified number of characters from the specified text, starting at the specified position.

Syntax [image] Copy Code

MID( Text text, Integer start, Integer length ) → Text

Parameters

text
Required. The string containing the characters that should be returned.
start
Required. The position of the first character to return. The first character in the text has position 1.
length
Required. The number of characters to return.

Remarks

If start is less than or equal to 0, the function returns the #VALUE! error value. If start is greater than the number of characters in text, an empty string is returned. If length is negative, the function returns #VALUE!. If length specifies more characters than available, the function returns all characters from start to the end of text. If length is zero, an empty string is returned.

If start or length are not integer values, they are automatically truncated.

Example

Formula [image] Copy Code

=MID(A2,1,5)
=MID("Quick brown fox",7,5)

See Also

Function Reference
LEFT Function
LEN Function
RIGHT Function
REPLACE Function
SUBSTITUTE Function
FIND Function
SEARCH Function


Replace

Replace

Returns a string in which a specified substring has been replaced with another substring a specified number of times.

Syntax

Copy Code

string Replace (
string value,
string oldValue,
string newValue
)

Parameters

value
A string expression representing the string to be searched for.
oldValue
A string expression representing the substring to be replaced.
newValue
A string expression representing the substring to replace all occurrences of oldValue.

Return Value

A string equivalent to value but with all instances of oldValue replaced with newValue. If any of the specified parameters is null, null is returned.

See Also

Text Functions
Left Function
RTrim Function


REPLACE

REPLACE

Returns the specified text where the characters at the specified position are replaced with another specified text.

Syntax [image] Copy Code

REPLACE( Text text, Integer start, Integer count, Text new ) → Text

Parameters

text
Required. The original text.
start
Required. The start position of the subtext that should be replaced.
count
Required. The number of characters of the subtext that should be replaced.
new
Required. The text that should replace the characters in text.

Remarks

Returns text, but removes count characters starting at position start, and replaces the removed characters with new. The character positions in the text begin at 1.

If start or count are not integer, they are automatically truncated. If start is less than 1, the function returns the #VALUE! error value. If start is greater than the length of the text, the new text is appended at the end. If count goes beyond the end of the text, the function removes all characters from start until the end of the text.

Example

Formula [image] Copy Code

=REPLACE("Mr. Brown is here",5,5,"O'Donel")

See Also

Function Reference
LEFT Function
RIGHT Function
MID Function
SEARCH Function
SUBSTITUTE Function
TRIM Function


Right

Right

Returns the specified number of characters from the right side of the specified string.

Syntax

Copy Code

string Right (
string a,
int length
)

Parameters

a
A string expression from which the rightmost characters are returned. If a is null, null is returned.
length
A numeric expression indicating how many characters to return. If 0, a zero-length string is returned. If greater than or equal to the number of characters in a, the entire string is returned.

Remarks

To determine the number of characters in a, use the Len function.

See Also

Text Functions
Len Function
Left Function
Mid Function


RIGHT

RIGHT

Returns the specified number of characters from the right of the specified text.

Syntax [image] Copy Code

RIGHT( Text text, [Integer length = 1] ) → Text

Parameters

text
Required. The string containing the characters that should be returned.
length
Optional. The number of characters to return. If omitted, length is assumed to be 1. Must be non-negative integer.

Remarks

If length is negative, the function returns #VALUE!. If length is greater than the number of characters in text, the entire text is returned. If length is not an integer, it is automatically truncated.

Example

Formula [image] Copy Code

=RIGHT(A1,LEN(A1)-1)
=RIGHT("-350")

See Also

Function Reference
LEN Function
MID Function
LEFT Function


RTrim

RTrim

Returns a copy of the specified string without trailing white spaces.

Syntax

Copy Code

string RTrim (
string value
)

Parameters

value
Any valid string expression. If value is null, null is returned.

Remarks

Use LTrim to return a string without its leading white spaces.

See Also

Text Functions
Left Function
Right Function
LTrim Function


Space

Space

Returns a string consisting of the specified number of spaces.

Syntax

Copy Code

string Space (
int count
)

Parameters

count
Any valid integer expression. Represents the number of spaces in the resulting string.

Remarks

The Space function is useful for formatting output and clearing data in fixed-length strings.

See Also

Text Functions
Replace Function


StrComp

StrComp

Returns a value indicating the result of a comparison of the specified strings.

Syntax

Copy Code

int StrComp (
string a,
string b
)

Parameters

a
Any valid string expression.
b
Any valid string expression.

Return Value

The StrComp function has the following return values.

Parameters | Return Value
String a sorts ahead of string b | -1
String a is equal to string b | 0
String a sorts after string b | 1

Remarks

The strings are compared by alphanumeric sort values beginning with the first character.

See Also

Text Functions
InStr Function


String

String

Returns a string consisting of the specified character repeating the specified number of times.

Syntax

Copy Code

string String (
int count,
int c
)

Parameters

count
A numberic expression specifying the number of occurrences of c in the resulting string.
c
A numberic expression specifying the character or string expression whose first character is used to build the return string.

See Also

Text Functions
Space Function
Str Function


StrReverse

StrReverse

Returns a string in which the character order of the specified string is reversed.

Syntax

Copy Code

string StrReverse (
string value
)

Parameters

value
A string value that must be reversed.

Remarks

The value argument is the string whose characters are to be reversed. If value is a zero-length string (""), a zero-length string is returned. If value is null, null is returned.

See Also

Text Functions
StrComp Function


Using Expressions in Label Texts

Using Expressions in Label Texts

You can embed expressions within the text of Label elements by enclosing the expression in square brackets. The following example shows the text of a label with a function call expression embedded within it:

Example [image] Copy Code

The date and time now is: [Now()]

The expression will be evaluated when the report, containing the label is processed by a call to its Run method. Once the expression is evaluated, its string representation is inserted at its place in the text. In the above example, when the label is displayed, the result will be similar to the following: "The date and time now is: 12/15/2000 1:05:11 PM".

Formatting

By default the result from the evaluation of an embedded expression is formatted to a string through a call to its ToString method. It is also possible to apply custom formatting as illustrated by the following example:

Example [image] Copy Code

The date and time now is: [Now() @ "d"]

The above example will format the date received as a result of the expression evaluation using short date format. The result will be similar to the following: "The date and time now is: 12/15/2000".

Generally, you can apply any string, which would be a valid format string for the ToString method of the expression evaluation result. The following example illustrates how you can apply formatting to an expression, which evaluates to a number. The example assumes that Price is a identifier which evaluates to a double value.

Example [image] Copy Code

Cost: [Price @ "$#,##0.00"]

Specifying culture

When applying formatting to an expression, the current culture is used by default. The following example will produce text similar to "16 Jan" when evaluated on machines with regional settings set to en-US or similar:

Example [image] Copy Code

[Now() @ "dd MMM"]

Evaluating the example is dependent on the current culture however and may yield unexpected results if the current culture is not the one expected. To explicitly specify the culture, use the following syntax:

Example [image] Copy Code

[Now() @ "dd MMM" : "en-US"]

This will force the expression to always be evaluated with the specified culture regardless of the current regional settings.


Using Expressions in XAML

Using Expressions in XAML

MindFusion.Reporting for WPF expressions can be used not only in label texts but also as any property value using the markup extension ExpressionExtension. Expressions can be particularly useful for WPF elements participating in the data template of a CustomReportItem. For example the following code defines a custom report item, which renders as a WPF Border. The width of the border is 10 times the value of the SomeNumericId identifier.

XAML [image] Copy Code

<r:CustomReportItem>

<r:CustomReportItem.Template>
<DataTemplate>

<Border
Width="{r:Expression '[CDbl(SomeNumericId * 10)]'}"
Height="15"
Background="Red"
BorderBrush="Black"
BorderThickness="1">
...
</Border>

</r:CustomReportItem>

The expressions are evaluated at the time the object is created from the XAML. In contrast to bindings, the expressions are not reevaluated when one of their components changes.


MindFusion.Scheduling for WPF Overview

MindFusion.Scheduling for WPF Overview

The MindFusion.Scheduling for WPF API is divided in two major parts, implemented in different .NET namespaces. The schedule data is represented by instances of the Schedule class and the helper Appointment, Task, Location, Contact and Resource classes, implemented in the MindFusion.Scheduling namespace. The calendar views are implemented by the Calendar class in the MindFusion.Scheduling.Wpf namespace.


The Schedule

The Schedule

The Schedule class represents the data displayed by MindFusion.Scheduling for WPF calendar views. The schedule contains a collection of schedule items defined by the Item abstract class and implemented by the Appointment class. Appointment objects contain references to instances of the miscellaneous Task, Location, Contact and Resource classes, which are also contained in the respective collection members of the Schedule class.

If your application has to process other types of schedule data items, create a class for each item type and inherit it from Item or Appointment. All methods and properties defined in Item are abstract, so if a class inherits from it, that class must implement all members of the Item class. On the other hand, if a class derives from Appointment, it can just add its own distinct properties and override the SaveTo and LoadFrom methods to implement serialization of the new members of the class. Custom schedule item classes must be registered for serialization via the RegisterItemClass method of the Schedule.


Schedule Items

Schedule Items

Events scheduled to occur at an appointed time are represented in MindFusion.Scheduling for WPF by the abstract class Item. Item comprises the information that should be defined for all schedule events. For example, the StartTime and EndTime properties specify the time and duration of an event. The Recurrence property lets you create recurrent events that occur repeatedly following some recurrence pattern. There are several descriptive properties that define additional information about an item, such as Priority, HeaderText and DescriptionText. The class also defines methods that support serialization in XML.

It is possible to associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item. These properties contain objects from the Resource, Contact, Location and Task classes respectively.

The appearance of items when viewed in the Calendar can be set via the ItemSettings property. It lets you define the color, alignment and style of various elements of the item visualization, such as frame lines, fill, header and description texts, icon images, and so on.

The abstract class Item is derived by the concrete class Appointment, which can be readily used in your applications. You could also define your own event class, which derives either from Appointment or Item. In order to integrate your custom class into the calendar API and user interface, you must do the following:

  • Provide parameterless constructor to let users create items of the custom class interactively;
  • Override the SaveTo / LoadFrom methods if you have any additional data fields in your custom class and register the class for serialization using the Schedule.RegisterItemClass method;
  • Override CopyOccurrence to support recurrence of the custom item. Also ensure you call MarkException on the associated recurrence whenever a custom property of the new item changes.


Recurrence

Recurrence

Schedule items can recur in time, following a specific recurrence pattern. For example an event could be set to occur each Monday, on the third day of each month, and so on. Assign a Recurrence object to item's Recurrence property to specify the time period, pattern, and other properties for the repetition of that item in time.

Once a recurrent item is added to the Schedule of a Calendar instance, the calendar creates multiple occurrences of the item in the time period being visualized. Occasionally you will get references to these occurrences passed as arguments to the calendar events or returned by the calendar methods. Occurrences are instances of the same class as of the item that was set recurrent, however their RecurrenceState property is set to Occurrence. If a user moves a recurrent event's occurrence in the calendar, thus changing its start or end time, or changes the occurrence text, an exception is created. Exceptions are item instances whose RecurrenceState is set to Exception.


Resources

Resources

MindFusion.Scheduling for WPF lets you associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item objects. These properties contain objects from the Resource, Contact, Location and Task classes respectively. If you need to assign a resource to schedule items, you must also add the resource to the appropriate collection in the Schedule class, namely Resources, Contacts, Locations or Tasks.

The timetable, week range and list views let you display distinct rows or columns for selected resources and to group items by their associated resources. To enable that, add the resources of interest to the appropriate resource collection of the Calendar object (that is, ItemResources, ItemContacts, ItemLocations and ItemTasks respectively) and set the Calendar.GroupType property to the appropriate value.

The class Resource is the base class of Contact, Location and Task. It defines an Id property, which must be unique among all resources in the schedule, and a pair of SaveTo and LoadFrom methods, which implement serialization.

You can define custom resources by deriving from Resource or from any of the Resource-derived classes. Custom resources are added to the schedule by adding them to the Calendar.Schedule.Resources collection. In order to enable serialization of custom resources, you have to provide a parameterless constructor and override the SaveTo / LoadFrom methods in the custom resource class. In addition you must register that class by calling Schedule.RegisterResourceClass before any deserialization code takes place.


Serializing the Schedule

Serializing the Schedule

The SaveTo and LoadFrom methods of the Schedule class let you save and load complete schedules to/from XML documents.

The serialization methods of the Schedule work by invoking the SaveTo and LoadFrom methods of the Item and Resource classes or the classes derived from them. If you define your own Item or Resource-derived classes, you must override the SaveTo and LoadFrom methods and register the classes for serialization by calling the RegisterItemClass and RegisterResourceClass methods of the Schedule.


Undo and Redo

Undo and Redo

If the UndoEnabled property is set to true, the control records users actions and allows undoing them later. The records are stored in a list, and can be undone consecutively by calling the Undo method of the Schedule class. An action that has been undone can be redone by calling the Redo method. You can enable or disable UI elements that undo or redo commands by inspecting the values of the CanUndo and CanRedo properties.

The control also runs and saves in the undo history AddItemCommand and RemoveItemCommand commands when items are programmatically added or removed from the Items collection of the Schedule. No other changes are recorded automatically when done from code. If support for undo/redo of such changes is required, they must be done through the ExecuteCommand method.

To allow undoing changes of Item properties, create a ChangeItemCommand instance before setting the property values, and call ExecuteCommand afterwards. Any other types of undoable changes can be implemented by deriving from the Command class and overriding its Execute, Undo and Redo methods.

Note

Changes made to the schedule during in-place editing or creation of an item while Undo/Redo is enabled are not supported and will usually result in broken undo consistency or errors. Any modifications to the schedule should be performed before the in-place operation has begun or after it has ended.


Calendar and Timetable Views

Calendar and Timetable Views

The Calendar class implements several types of views that can be enabled by setting the calendar's CurrentView property. These views provide different outlooks over the schedule data and allow for different user interaction behavior. By changing the views from more general ones to more specialized ones, your application can implement drilling down through the schedule data. At this time MindFusion.Scheduling for WPF supports the following views:

  • The Month Range View displays a range of months or years.
  • The Single Month View displays a single month and lets the user scroll to the previous or next month.
  • The Week Range View displays a grid in which the days of a week occupy a single row.
  • The List View displays a list of cells where each cell represents an arbitrary time interval, such as second, minute, hour, and so on.
  • The Timetable View displays the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task, contact or resource.


Month Range View

Month Range View

The Month Range view displays an arbitrary long sequence of months arranged in rows and columns. Each month represents a grid of day cells, each of which displays the day number and the schedule events set to occur on its respective date. The months in the view can be scrolled back or forth in time by an arbitrary interval using the navigation buttons in the view header.

In order to enable the Month Range view, set the CurrentView property of the Calendar class to MonthRange. Use the MonthRangeSettings and the MonthSettings properties of the Calendar class to adjust the appearance of the view. The ItemSettings property affects how schedule items will be displayed.


Single Month View

Single Month View

The Single Month view displays a single month and lets the user scroll to the previous or next month or the previous or next year by using the navigation buttons optionally displayed in the view header. The month represents a grid of day cells, which display the day number and the schedule events set to occur on the specific date.

In order to enable the Single Month view, set the CurrentView property of the Calendar class to SingleMonth. Use the MonthSettings property of the Calendar class to set the appearance of the view. The CalendarStyle property of the associated DaySettings object specifies a common appearance style to be used for all cells in the view. The ItemSettings property affects how schedule items will be displayed.


Week Range View

Week Range View

This Week Range view displays a range of weeks. Each week occupies a whole row or column whose cells represent days. The day cells display the day name or number according to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

In order to enable the Week Range view, set the CurrentView property of the Calendar class to WeekRange. Use the WeekRangeSettings property of the Calendar class to adjust the appearance of the view. The ItemSettings property lets you specify how schedule items should be displayed.


List View

List View

Set the CurrentView property of the Calendar class to List to select the list view. This view displays several rows or columns where each row or column represents a single second, minute, hour, day, week, month or year. The day cells display the represented time in a user-specified format to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

Use the ListViewSettings property of the of the Calendar class to set the appearance of the list view. The CalendarStyle property of the associated CellSettings specifies a common appearance style to be used for all cells in the view. The ItemSettings property lets you specify how schedule items should be displayed.


Timetable View

Timetable View

Set the CurrentView property of the Calendar class to Timetable to select the timetable view. This view displays the allotment of resources to distinct hours of a day; the columns in this view represent dates, tasks, locations, contacts or resources. The columns can be grouped by location, task, contact or resource. Each row represents an hour or a custom time interval. The cells in the view display information about the schedule items allocated to the task, contact, location or resource for the specific time interval.

Use the TimetableSettings property of the Calendar class to set the appearance of the timetable view. The CalendarStyle property specifies a common appearance style for all cells in the view, while the WorkTimeCellStyle property defines the style of cells in the work time interval. The ItemSettings property lets you specify how schedule items should be displayed.


Resource View

Resource View

Set the CurrentView property of the Calendar class to ResourceView to select the resource view. This view displays the distribution of items over a period of time for particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Use the ResourceViewSettings property of the Calendar class to set the appearance of the resource view. The CalendarStyle property specifies a common appearance style for all cells in the view and the WeekendStyle property specifies the style of weekend cells. The ItemSettings property lets you specify how schedule items should be displayed.

For more information about the resource view settings, see the ResourceViewSettings class.


Grouping

Grouping

Views that can be grouped: Timetable / Week Range / List / Resource. The other views do not support grouping.

In order to enable grouping the following steps should be done:

  • The resources should be created and added to the appropriate collection in the schedule: Calendar.Schedule.Contacts for contacts, Calendar.Schedule.Locations for locations, Calendar.Schedule.Tasks for tasks and Calendar.Schedule.Resources for general and custom resources.
  • The selected resources by which to group should be added to the appropriate collection in the control: Calendar.ItemContacts for contacts, and so on. The selected resources are a subset of all resources defined in the schedule.
  • The Calendar.GroupType should be set to the appropriate value, for example GroupType.GroupByContacts to group by contacts.

The following code illustrates how to enable grouping by contacts:

C# [image] Copy Code

// Define two contacts to group by
Contact c1 = new Contact();
c1.FirstName = "John";

Contact c2 = new Contact();
c2.FirstName = "Jack";

// Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1);
calendar.Schedule.Contacts.Add(c2);

// Select these contacts for grouping by adding them to
// the appropriate Calendar collection
calendar.ItemContacts.Add(c1);
calendar.ItemContacts.Add(c2);

// Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts;

Visual Basic [image] Copy Code

' Define two contacts to group by
Dim c1 As New Contact()
c1.FirstName = "John"

Dim c2 As New Contact()
c2.FirstName = "Jack"

' Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1)
calendar.Schedule.Contacts.Add(c2)

' Select these contacts for grouping by adding them to
' the appropriate Calendar collection
calendar.ItemContacts.Add(c1)
calendar.ItemContacts.Add(c2)

' Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts

The text displayed in the header of the corresponding resource depends on the type of the resource and is as follows:

  • A string formatted according to Calendar.ContactNameFormat for contacts.
  • The Resource.Name for general and custom resources, and locations.
  • The Task.Subject for tasks.

Grouping and Appearance

  • In timetable view each column (or row in a horizontal view) that represents a day is additionally subdivided to the number of grouped resources. For example if there are 3 resources selected to group by, each day column in the view is subdivided to 3 columns. The sub-columns represent individual resources and contain only the items specific for them. The sub-columns have headers containing the resource text. The header of the day column is displayed above the headers of its underlying resource columns.
  • The week range view displays a separate view for grouped resources. For example if there are two resources, two views are displayed alongside, each of which contains the items associated with its corresponding resource.


Customizing Appearance

Customizing Appearance

The following topics are contained within this topic:

Styles and Themes
Information about the visualization styles and themes available in MindFusion.Scheduling for WPF.

Customizing the Appearance of Views
Information on how to modify the appearance of various MindFusion.Scheduling for WPF views.

Customizing the Appearance of Items
Information on how to modify the appearance of items in MindFusion.Scheduling for WPF.


Styles and Themes

Styles and Themes

A CalendarStyle is a set of appearance attributes, such as colors, brushes and margins that can be applied to schedule items or calendar view cells as an integral entity. Styles support cascading propagation of attributes up through the visualization hierarchy. Attributes defined in more specific styles override the attributes defined in more general styles. If a style leaves some attribute values undefined, the ones specified in a more general style or in the current theme are used. For example, the style associated with an item (through Calendar.SetItemStyle) cascades to ItemSettings.CalendarStyle, which cascades to the corresponding property in the current theme. If a property in the item's style is defined, it will be used. Otherwise the style system will take the value of this property from ItemSettings.CalendarStyle. If the property is not present there too, the value will be taken from the current theme. A property is considered undefined if its value is set to null (Nothing in Visual Basic).

Themes are complete sets of styles and attributes that can be applied to the calendar and its views. The themes contain values for all properties in the MonthSettings, TimetableSettings, ListViewSettings, and so on, defining the appearance of the various calendar views. MindFusion.Scheduling for WPF comes with several predefined themes: Standard, Windows2003, Silver, Lila and Vista. Use the Calendar.Theme property to apply a specific theme.

The following table illustrates how various views would look like when particular appearance Theme is applied to them.

 | Standard | Windows2003 | Lila | Silver | Vista | Light
List View |  |  |  |  |  |
Week Range |  |  |  |  |  |
Month Range |  |  |  |  |  |
Timetable |  |  |  |  |  |
Resource View |  |  |  |  |  |


Customizing the Appearance of Views

Customizing the Appearance of Views

The appearance of individual calendar views depends on the settings corresponding to them. For example the appearance of the list view is controlled by the Calendar.ListViewSettings property, while the appearance of the timetable view is controlled by the Calendar.TimetableSettings property, and so on. The month range view is an exception to this rule since it depends on both Calendar.MonthSettings and Calendar.MonthRangeSettings properties.

The settings object defines styles for various elements of the view. Most settings contain properties, which let you change the size and number of elements (such as columns, rows, headers, and so on) contained in the view. There are usually properties that control the padding and margin of various elements and properties that define the format of the text displayed in the view.


Customizing the Cell Template

Customizing the Cell Template

The following topics are discussed in more details:

Cell Presenters
Provides information about the cell presenters and how they are used to visualize view cells in the control.

The Default Cell Template The Default Cell Template
Lists the complete XAML code of the default cell template.

Creating New Cell Template Creating New Cell Template
Demonstrates how to create a new cell template.

Creating New Cell Presenter
Demonstrates how to create a new cell presenter and what are the benefits from this.


Cell Presenters

Cell Presenters

The cell presenters are objects of the CellPresenter class (or a class derived from CellPresenter) which are used to define the visual presentation of view cells in the Calendar control. Using a separate object for presentation provides abstraction between the logical views and the displaying control (Calendar). The same presentation pattern is used for the items as described in Customizing the Item Template.

The CellPresenter objects are instantiated by the Calendar control when a view is being constructed or rebuilt. A special pair of events is raised every time a presenter is being created - CellPresenterCreating and CellPresenterCreated. The first event is raised before the presenter is created. It allows the client to create presenters of a custom CellPresenter-derived class. The second event is raised after the presenter is created and initialized. It can be used to supply custom style to the presenter.

The CellPresenter class provides several properties, which can be bound to from within the control template. StyleKey StyleKeyComplex, StyleKeyWithHeader and StyleKeyToday are probably the most important properties as they define the control template that should be used for the presenter.

The complete XAML code of the default cell template can be found here here Creating New Cell Template Creating New Cell Template Creating New Cell Presenter.


The Default Cell Template

The Default Cell Template

Below is the complete XAML code of the default style of the cell presenter.

XAML [image] Copy Code

<!-- Static images -->
<BitmapImage x:Key="HiddenItemsImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/MoreDown.png" />
<BitmapImage x:Key="RecurrenceImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Recurrence.png" />
<BitmapImage x:Key="RecurrenceExImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/RecurrenceEx.png" />
<BitmapImage x:Key="ReminderImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Reminder.png" />
<BitmapImage x:Key="ArrowLeftImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowLeft.png" />
<BitmapImage x:Key="ArrowRightImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowRight.png" />
<BitmapImage x:Key="ArrowUpImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowUp.png" />
<BitmapImage x:Key="ArrowDownImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowDown.png" />

<Style TargetType="local:CellPresenter">
<Style.Triggers>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<Border
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
BorderBrush="{Binding CellStyle.BorderBrush}"
BorderThickness="{Binding CellStyle.BorderThickness}"
Background="{Binding Background}"
Margin="{Binding CellMargin}" />

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="WithHeader">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<Border
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
BorderBrush="{Binding CellStyle.BorderBrush}"
BorderThickness="{Binding CellStyle.BorderThickness}"
Background="{Binding Background}"
Margin="{Binding CellStyle.Margin}">
<Grid>
<Border
BorderBrush="{Binding CellHeaderStyle.BorderBrush}"
BorderThickness="{Binding CellHeaderStyle.BorderThickness}"
Background="{Binding CellHeaderStyle.Background}"
Margin="{Binding CellHeaderStyle.Margin}"
Width="{Binding HeaderWidth}"
Height="{Binding HeaderHeight}"
VerticalAlignment="{Binding HeaderVerticalAlignment}"
HorizontalAlignment="{Binding HeaderHorizontalAlignment}" />
<Border Visibility="{Binding Path=IsTodayCell, RelativeSource={RelativeSource TemplatedParent},
Converter={StaticResource visibleConverter}, ConverterParameter=true}"
Margin="{Binding CellHeaderStyle.Margin}"
Width="{Binding HeaderWidth}"
Height="{Binding HeaderHeight}"
VerticalAlignment="{Binding HeaderVerticalAlignment}"
HorizontalAlignment="{Binding HeaderHorizontalAlignment}">
<Border Visibility="{Binding Path=CellSettings.ShowToday, RelativeSource={RelativeSource TemplatedParent},
Converter={StaticResource visibleConverter}, ConverterParameter=true}"
BorderBrush="{Binding CellSettings.TodayBrush}"
BorderThickness="{Binding CellHeaderStyle.BorderThickness}"
Background="{Binding CellSettings.TodayFillBrush}">
</Border>
</Border>
<Border
BorderThickness="{Binding CellHeaderStyle.BorderThickness}"
Margin="{Binding CellHeaderStyle.Margin}"
Width="{Binding HeaderWidth}"
Height="{Binding HeaderHeight}"
VerticalAlignment="{Binding HeaderVerticalAlignment}"
HorizontalAlignment="{Binding HeaderHorizontalAlignment}">
<TextBlock
FontFamily="{Binding CellHeaderStyle.FontFamily}"
FontSize="{Binding CellHeaderStyle.FontSize}"
FontStretch="{Binding CellHeaderStyle.FontStretch}"
FontStyle="{Binding CellHeaderStyle.FontStyle}"
FontWeight="{Binding CellHeaderStyle.FontWeight}"
Foreground="{Binding CellHeaderStyle.Foreground}"
TextAlignment="{Binding CellHeaderStyle.TextAlignment}"
VerticalAlignment="{Binding CellHeaderStyle.VerticalAlignment}"
HorizontalAlignment="{Binding CellHeaderStyle.HorizontalAlignment}"
Margin="{Binding CellHeaderStyle.ContentMargin}"
Text="{Binding HeaderText}">
<TextBlock.LayoutTransform>
<RotateTransform Angle="{Binding HeaderTextRotation, FallbackValue=0}" />
</TextBlock.LayoutTransform>
</TextBlock>
</Border>
<Image Name="hiddenItemsCue" Source="{StaticResource HiddenItemsImage}" Margin="0,0,1,1" HorizontalAlignment="Right" Visibility="{Binding HiddenItemsCueVisibility}" VerticalAlignment="Bottom" Width="14" Height="7" Stretch="None" />
</Grid>
</Border>

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

</Style.Triggers>
</Style>

The local namespace is defined as follows:

XAML [image] Copy Code

xmlns:local="clr-namespace:MindFusion.Scheduling.Wpf"

As can be seen in the above XAML, the style contains several triggers. Each trigger supplies a control template for the cells in different views. For example, the first trigger supplies the template of cells in the Resource and Timetable views. Those are the cells without headers. The trigger is activated when the value of the StyleKey property is set to "Simple".

XAML [image] Copy Code

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple">
...

The next trigger supplies the template of cells that can have headers. Those are the cells in the SingleMonth, MonthRange, List and WeekRange views. The trigger is activated when the value of the StyleKey property is set to "WithHeader".

XAML [image] Copy Code

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="WithHeader">
...

The last trigger supplies the template for the cell representing the current day.

The following table illustrates the presentation of a cell in the three different templates:

Condition | Presentation
StyleKey=Simple |
StyleKey=Today |
StyleKey=WithHeader |


Creating New Cell Template

Creating New Cell Template

New cell templates are created the same way as custom control templates - by creating a new .NET Style with TargetType set to CellPresenter. The Style should provide a setter for the Template property. The following XAML snippet illustrates how.

XAML [image] Copy Code

<Style TargetType="{x:Type planner:CellPresenter}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type planner:CellPresenter}">
...
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The style definition needs to be placed in the application's resources (App.xaml or Application.xaml).

More advanced scenarios can include several triggers, which supply different templates for cells in the different views. The Default Cell Template uses this technique to provide different templates for the cells in different views. Below is an example XAML code illustrating this.

XAML [image] Copy Code

<Style TargetType="{x:Type local:CellPresenter}">
<Style.Triggers>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:CellPresenter}">

<!-- The template for Timetable and Resource view cells goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="WithHeader">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:CellPresenter}">

<!-- The template for SingleMonth, MonthRange, List and WeekRange view cells goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

</Style.Triggers>
</Style>

For more information on how to create new templates, check the DualView sample.


Creating New Cell Presenter

Creating New Cell Presenter

In certain scenarios creating a new template is not sufficient. For example the case when you want to add an interactive control, such as Button in the cell's presenter and want to attach an event handler to this button so that you can perform specific action when it is pressed. In order to implement the above scenario, you have to derive from CellPresenter and associate a custom template with the new class. For more information on how to create custom templates, check Creating New Cell Template Creating New Cell Template. Somewhere within the newly created template, there will be a button definition similar to the one below.

XAML [image] Copy Code

<Button x:Name="myButton" />

It is important to name the button so that it can be accessed in the template class.

The definition of the custom presenter class will look similar to the following.

C# [image] Copy Code

class MyPresenter : CellPresenter
{
public MyPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyPresenter);
}
}

Visual Basic [image] Copy Code

Class MyPresenter
Inherits CellPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.New(calendar)

Me.DefaultStyleKey = GetType(MyPresenter)

End Sub

End Class

In order to attach an event handler to the button myButton, you have to override the OnApplyTemplate method, obtain a reference to the button through the GetTemplateChild method and attach an event handler to the button's Click event. Make sure to call the method of the base class in the OnApplyTemplate override. The following code illustrates how.

C# [image] Copy Code

public override void OnApplyTemplate()
{
base.OnApplyTemplate();

Button myButton = GetTemplateChild("myButton") as Button;
if (myButton != null)
myButton.Click += OnMyButtonClick;
}

...

void OnMyButtonClick(object sender, RoutedEventArgs e)
{
// Perform the necessary actions here
}

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate()

MyBase.OnApplyTemplate()

Dim myButton As Button = CType(GetTemplateChild("myButton"), Button)
If Not myButton Is Nothing Then
AddHandler myButton.Click, AddressOf OnMyButtonClick
End If

End Sub

...

Sub OnMyButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)

' Perform the necessary actions here

End Sub

Now that the custom presenter and its template are ready, the presenter has to be associated with a cell. This can be done in the CellPresenterCreating event handler of the Calendar class.

C# [image] Copy Code

private void calendar_CellPresenterCreating(object sender, CellPresenterCreatingEventArgs e)
{
e.CellPresenter = new MyPresenter(calendar);
}

Visual Basic [image] Copy Code

Private Sub calendar_CellPresenterCreating(ByVal sender As Object, ByVal e As CellPresenterCreatingEventArgs)

e.CellPresenter = New HolidayPresenter(calendar)

End If

For an extensive example on how to create custom cell presenters, check the new Holidays sample.


Customizing the Appearance of Items

Customizing the Appearance of Items

There are several ways to customize the appearance of items in MindFusion.Scheduling for WPF.

Customizing the Item Settings
Provides information on how to modify the appearance of items through the ItemSettings object exposed by the Calendar class.

Customizing the Item Styles
Illustrates how to modify the appearance of items in the Calendar using CalendarStyle objects.

Customizing the Item Template
Demonstrates how to replace the default item template and how to create custom item presenters.


Customizing the Item Settings

Customizing the Item Settings

The most common way to customize the appearance of items in MindFusion.Scheduling for WPF is by setting various properties in Calendar.ItemSettings. This would affect the appearance of all items in the control. For example ItemsVisible specifies whether to display the items, Size and HeaderSize define the dimensions of the item and its header and so on. Four properties in the ItemSettings class are particularly interesting - CalendarStyle, SelectedItemStyle, PointedItemStyle and PointedSelectedItemStyle. These properties define various aspects in the visualization of the items depending on their current state - normal, selected, hovered with the mouse and selected and hovered at the same time. For example SelectedItemStyle defines settings for items which are selected but not hovered with the mouse.

For more information on the item styles and how to assign specific styles to individual items, see Customizing the Item Styles.


Customizing the Item Styles

Customizing the Item Styles

As described in Customizing the Item Settings, the appearance of each item is controlled through four CalendarStyle objects - one for each state of the item (normal, selected, pointed, and pointed and selected). The default four styles for all items can be found in the ItemSettings object returned by the Calendar.ItemSettings property.

To customize the appearance of an individual item, associate a CalendarStyle objects with it by calling one of the following Calendar methods: SetItemStyle, SetSelectedItemStyle, SetPointedItemStyle and SetPointedSelectedItemStyle properties. The particular style that will be used when the item is rendered depends on the state of the item. The style set through SetItemStyle is used when the item is neither selected nor the mouse hovers over it. The style set through SetSelectedItemStyle is used when the item is selected and the mouse is not over it. The style set through SetPointedItemStyle is used when the mouse is over a non-selected item and, finally, the style set through SetPointedSelectedItemStyle is used when the item is selected and the mouse is over it at the same time. The "pointed item" styles are considered extended styles and are only used if ItemSettings.UseExtendedStyles is set to true. The item styles support the cascading paradigm described in Styles and Themes. The most general item styles are defined in the current theme. They cannot be changed by any means except by changing the theme itself. The styles defined in Calendar.ItemSettings are of higher priority and any of their properties that are explicitly specified will be used prior those from the theme. The styles defined for individual items are of highest priority and will always be used first, when present.

The following code defines a sample Calendar control in XAML:

XAML [image] Copy Code

<planner:Calendar x:Name="calendar" Theme="Vista" Date="1, 1, 2010" />

Create two items and add them to the above control using the following code:

C# [image] Copy Code

Appointment a = new Appointment();
a.StartTime = new DateTime(2010, 1, 1);
a.EndTime = new DateTime(2010, 1, 2);
a.HeaderText = "a";
calendar.Schedule.Items.Add(a);

Appointment b = new Appointment();
b.StartTime = new DateTime(2010, 1, 3);
b.EndTime = new DateTime(2010, 1, 4);
b.HeaderText = "b";
calendar.Schedule.Items.Add(b);

Visual Basic [image] Copy Code

Dim a As New Appointment()
a.StartTime = New DateTime(2010, 1, 1)
a.EndTime = New DateTime(2010, 1, 2)
a.HeaderText = "a"
calendar.Schedule.Items.Add(a)

Dim b As New Appointment()
b.StartTime = New DateTime(2010, 1, 3)
b.EndTime = New DateTime(2010, 1, 4)
b.HeaderText = "b"
calendar.Schedule.Items.Add(b)

Specify a custom brush for the text of both items.

C# [image] Copy Code

CalendarStyle style = new CalendarStyle();
style.Foreground = Brushes.Orange;
calendar.ItemSettings.CalendarStyle = style;

Visual Basic [image] Copy Code

Dim style As New CalendarStyle()
style.Foreground = Brushes.Orange
calendar.ItemSettings.CalendarStyle = style

Running the code at this point will display both items with text colored in Orange. It is also noticeable that the rest of the visualization properties are not modified since they were not set explicitly in the custom style and are therefore obtained from the current theme.

Now define a custom background for item a using the following code:

C# [image] Copy Code

CalendarStyle aStyle = new CalendarStyle();
aStyle.Background = Brushes.Blue;
calendar.SetItemStyle(a, aStyle);

Visual Basic [image] Copy Code

Dim aStyle As New CalendarStyle()
aStyle.Background = Brushes.Blue
calendar.SetItemStyle(a, aStyle)

The code above will change the background of a, while the background of b will be left intact.


Customizing the Item Template

Customizing the Item Template

The following topics are discussed in more details:

Item Presenters
Provides information about the item presenters and how they are used to visualize items in the control.

The Default Item Template The Default Item Template
Lists the complete XAML code of the default item template.

Creating New Item Template Creating New Item Template
Demonstrates how to create a new item template.

Creating New Item Presenter
Demonstrates how to create a new item presenter and what are the benefits from this.


Item Presenters

Item Presenters

The item presenters are objects of the ItemPresenter class (or a class derived from ItemPresenter) which are used to define the visual presentation of items in the Calendar control. Using a separate object for presentation provides abstraction between the data (Item) and the displaying control (Calendar). This abstraction brings several notable benefits.

  • The appearance of the items in a Calendar control can be customized without modifying the Item class. To do this a new style with a setter for the control's Template has to be defined for the ItemPresenter class.
  • The same schedule can be displayed in several Calendar controls simultaneously.
  • Different presenters can be used for the same items in different Calendar controls, or for different items in the same Calendar control.

The ItemPresenter objects are instantiated by the Calendar control when an item needs to be displayed. A special event is raised every time a presenter is created - ItemPresenterCreated. It is possible that several presenters are created for a single item. For example, consider the case when an item wraps across several rows in a SingleMonth or WeekRange views.

The ItemPresenter class provides several properties, which can be bound to from within the control template. Orientation and StyleKey StyleKeyComplex, StyleKeySimpleHorizontal and StyleKeySimpleVertical are probably the most important properties as they define the control template that should be used for the presenter.

The complete XAML code of the default item template can be found here here Creating New Item Template Creating New Item Template Creating New Item Presenter.


The Default Item Template

The Default Item Template

Below is the complete XAML code of the default style of the item presenter.

XAML [image] Copy Code

<!-- Static images -->
<BitmapImage x:Key="HiddenItemsImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/MoreDown.png" />
<BitmapImage x:Key="RecurrenceImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Recurrence.png" />
<BitmapImage x:Key="RecurrenceExImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/RecurrenceEx.png" />
<BitmapImage x:Key="ReminderImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Reminder.png" />
<BitmapImage x:Key="ArrowLeftImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowLeft.png" />
<BitmapImage x:Key="ArrowRightImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowRight.png" />
<BitmapImage x:Key="ArrowUpImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowUp.png" />
<BitmapImage x:Key="ArrowDownImage" UriSource="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/ArrowDown.png" />

<Style TargetType="local:ItemPresenter">
<Style.Triggers>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Complex">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<local:ResizeBands
MoveBandMargin="{TemplateBinding MoveBandMargin}"
Orientation="{TemplateBinding Orientation}"
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
ItemSettings="{TemplateBinding ItemSettings}"
ResizeBandsVisible="{TemplateBinding Selected}">
<local:SideBorders>
<Border Background="{Binding ItemStyle.Background}">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
</Grid.ColumnDefinitions>
<StackPanel Orientation="Vertical">
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceImage}" Visibility="{Binding RecurrenceIconVisibility}" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceExceptionIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceExImage}" Visibility="{Binding RecurrenceExceptionIconVisibility}" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowReminderIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource ReminderImage}" Visibility="{Binding ReminderIconVisibility}" Margin="1"/>
</Border>
</StackPanel>
<StackPanel Grid.Column="1" Orientation="Vertical">
<Border
BorderBrush="{Binding ItemStyle.LineBrush}"
BorderThickness="0,0,0,1"
Height="{Binding ItemSettings.HeaderSize}"
Margin="6,0,6,0">
<TextBlock x:Name="HeaderBlock"
Margin="{TemplateBinding HeaderTextMargin}"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
</Border>
<TextBlock
DataContext="{TemplateBinding Item}"
TextWrapping="Wrap" Text="{Binding DescriptionText}"
Margin="5,1,1,1" Grid.Column="1" Grid.Row="1" />
</StackPanel>
</Grid>
</Border>
</local:SideBorders>
</local:ResizeBands>
</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

<MultiDataTrigger>
<MultiDataTrigger.Conditions>
<Condition Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple" />
<Condition Binding="{Binding Orientation, RelativeSource={RelativeSource Self}}" Value="Horizontal" />
</MultiDataTrigger.Conditions>
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<Grid
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}">
<local:SideBorders>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>
<Image Grid.Column="0"
Visibility="{TemplateBinding StartArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="{StaticResource ArrowLeftImage}" />
<StackPanel Orientation="Horizontal" Grid.Column="1">
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceImage}" Visibility="{Binding RecurrenceIconVisibility}" Stretch="None" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceExceptionIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceExImage}" Visibility="{Binding RecurrenceExceptionIconVisibility}" Stretch="None" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowReminderIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource ReminderImage}" Visibility="{Binding ReminderIconVisibility}" Stretch="None" Margin="1"/>
</Border>
</StackPanel>
<TextBlock x:Name="HeaderBlock" Grid.Column="2"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<Image Grid.Column="3"
Visibility="{TemplateBinding EndArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="{StaticResource ArrowRightImage}"/>
</Grid>
</local:SideBorders>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</MultiDataTrigger>

<MultiDataTrigger>
<MultiDataTrigger.Conditions>
<Condition Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple" />
<Condition Binding="{Binding Orientation, RelativeSource={RelativeSource Self}}" Value="Vertical" />
</MultiDataTrigger.Conditions>
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<Grid
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}">
<local:SideBorders>
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="Auto" />
<RowDefinition />
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Image Grid.Row="0"
Visibility="{TemplateBinding StartArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="{StaticResource ArrowUpImage}" />
<StackPanel Orientation="Vertical" Grid.Row="1">
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceImage}" Visibility="{Binding RecurrenceIconVisibility}" Stretch="None" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowRecurrenceExceptionIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource RecurrenceExImage}" Visibility="{Binding RecurrenceExceptionIconVisibility}" Stretch="None" Margin="1"/>
</Border>
<Border Visibility="{Binding Path=ItemSettings.ShowReminderIcons, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}, ConverterParameter=true}">
<Image Source="{StaticResource ReminderImage}" Visibility="{Binding ReminderIconVisibility}" Stretch="None" Margin="1"/>
</Border>
</StackPanel>
<TextBlock x:Name="HeaderBlock" Grid.Row="2"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<Image Grid.Row="3"
Visibility="{TemplateBinding EndArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="{StaticResource ArrowDownImage}" />
</Grid>
</local:SideBorders>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</MultiDataTrigger>

</Style.Triggers>
</Style>

<Style TargetType="local:SideBorders">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:SideBorders">
<Grid>
<Rectangle HorizontalAlignment="Left"
Width="{Binding BorderThickness.Left}"
Fill="{Binding ItemStyle.LeftBorderBrush}" />
<Rectangle VerticalAlignment="Top"
Height="{Binding BorderThickness.Top}"
Fill="{Binding ItemStyle.TopBorderBrush}" />
<Rectangle HorizontalAlignment="Right"
Width="{Binding BorderThickness.Right}"
Fill="{Binding ItemStyle.RightBorderBrush}" />
<Rectangle VerticalAlignment="Bottom"
Height="{Binding BorderThickness.Bottom}"
Fill="{Binding ItemStyle.BottomBorderBrush}" />
<Border BorderThickness="{Binding BorderThickness}">
<ContentPresenter Margin="{Binding ItemStyle.ContentMargin}" />
</Border>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ResizeBands">
<Style.Resources>
<local:VisibleConverter x:Key="visibleConverter"/>
</Style.Resources>
<Style.Triggers>

<Trigger Property="Orientation" Value="Vertical">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ResizeBands">
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition />
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto"/>
<ColumnDefinition />
</Grid.ColumnDefinitions>
<Border x:Name="ResizeBandBack"
Grid.ColumnSpan="2"
BorderThickness="1,1,1,0"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.ResizeBandSize}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<Border x:Name="UnderMoveBand"
Grid.Row="1"
BorderThickness="1,1,0,1"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Width="{Binding ItemSettings.MoveBandSize}"
Background="White" />
<Border x:Name="MoveBand"
Grid.Row="1"
BorderThickness="1,1,0,1"
Width="{Binding ItemSettings.MoveBandSize}"
Margin="{TemplateBinding MoveBandMargin}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}" />
<Border x:Name="ResizeBandForward"
Grid.Row="2" Grid.ColumnSpan="2"
BorderThickness="1,0,1,1"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.ResizeBandSize}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<ContentPresenter Grid.Column="1" Grid.Row="1"/>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Trigger>

<Trigger Property="Orientation" Value="Horizontal">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ResizeBands">
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>
<Border x:Name="ResizeBandBackHorizontal"
Grid.RowSpan="2"
BorderThickness="1,1,0,1"
Width="{Binding ItemSettings.ResizeBandSize}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<Border x:Name="UnderMoveBandHorizontal"
Grid.Column="1"
Background="White"
BorderThickness="1,1,1,0"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.MoveBandSize}"/>
<Border x:Name="MoveBandHorizontal"
Grid.Column="1"
BorderThickness="1,1,1,0"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Margin="{TemplateBinding MoveBandMargin}"
Height="{Binding ItemSettings.MoveBandSize}" />
<Border x:Name="ResizeBandForwardHorizontal"
Grid.Column="2" Grid.RowSpan="2"
BorderThickness="0,1,1,1"
Width="{Binding ItemSettings.ResizeBandSize}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<ContentPresenter Grid.Column="1" Grid.Row="1" />
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Trigger>

</Style.Triggers>
</Style>

The local namespace is defined as follows:

XAML [image] Copy Code

xmlns:local="clr-namespace:MindFusion.Scheduling.Wpf;assembly=MindFusion.Scheduling.Wpf"

As can be seen in the above XAML, the style contains several triggers. Each trigger supplies a control template for the items in different contexts. For example, the first trigger supplies the template of the so-called complex items. Those are the items in Resource view and non all day items in Timetable view. The trigger is activated when the value of the StyleKey property is set to "Complex".

XAML [image] Copy Code

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Complex">
...

The next trigger supplies the template of the so-called simple items when they are displayed horizontally. Simple items are all day items in Timetable view and the items in SingleMonth, MonthRange, List and WeekRange views. The trigger is activated when the value of the StyleKey property is set to "Simple" and the value of the Orientation property is set to Horizontal.

XAML [image] Copy Code

<MultiDataTrigger>
<MultiDataTrigger.Conditions>
<Condition Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple" />
<Condition Binding="{Binding Orientation, RelativeSource={RelativeSource Self}}" Value="Horizontal" />
</MultiDataTrigger.Conditions>
...

The last trigger supplies the template for simple items, displayed vertically.

The following table illustrates the presentation of the same item in the three different contexts:

Condition | Presentation
StyleKey=Complex |
StyleKey=Simple, Orientation=Horizontal |
StyleKey=Simple, Orientation=Vertical |

It is completely legal to define a single control template for the three cases.

Named Elements

There is one element of particular interest in the template - HeaderBlock. This element is used when initiating item in-place editing operations in order to determine where the in-place text box should be opened. If you create a custom template and want to retain the in-place editing functionality you need to name an element HeaderBlock. Additionally you need to place this element in either grid or border parent.


Creating New Item Template

Creating New Item Template

New item templates are created the same way as custom control templates - by creating a new .NET Style with TargetType set to ItemPresenter. The Style should provide a setter for the Template property. The following XAML snippet illustrates how.

XAML [image] Copy Code

<Style TargetType="{x:Type planner:ItemPresenter}">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type planner:ItemPresenter}">
...
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The style definition needs to be placed in the application's resources (App.xaml or Application.xaml).

More advanced scenarios can include several triggers, which supply different templates depending on specific conditions. The Default Item Template uses this technique to provide different templates for the items in different views. Below is an example XAML code illustrating this.

XAML [image] Copy Code

<Style TargetType="{x:Type local:ItemPresenter}">
<Style.Triggers>
<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Complex">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:ItemPresenter}">

<!-- The template for Timetable and Resource view items goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>
<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type local:ItemPresenter}">

<!-- The template for SingleMonth, MonthRange, List and WeekRange view items goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>
</Style.Triggers>
</Style>

For more information on how to create new templates, check Tutorial 5: Custom Item Templates.


Creating New Item Presenter

Creating New Item Presenter

In certain scenarios creating a new template is not sufficient. For example the case when you want to add an interactive control, such as Button in the Item's presenter and want to attach an event handler to this button so that you can perform specific action when it is pressed. In order to implement the above scenario, you have to derive from ItemPresenter and associate a custom template with the new class. For more information on how to create custom templates, check Creating New Item Template Creating New Item Template. Somewhere within the newly created template, there will be a button definition similar to the one below.

XAML [image] Copy Code

<Button x:Name="myButton" />

It is important to name the button so that it can be accessed in the template class.

The definition of the custom presenter class will look similar to the following.

C# [image] Copy Code

class MyPresenter : ItemPresenter
{
public MyPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyPresenter);
}
}

Visual Basic [image] Copy Code

Class MyPresenter
Inherits ItemPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.New(calendar)

Me.DefaultStyleKey = GetType(MyPresenter)

End Sub

End Class

In order to attach an event handler to the button myButton, you have to override the OnApplyTemplate method, obtain a reference to the button through the GetTemplateChild method and attach an event handler to the button's Click event. Make sure to call the method of the base class in the OnApplyTemplate override. The following code illustrates how.

C# [image] Copy Code

public override void OnApplyTemplate()
{
base.OnApplyTemplate();

Button myButton = GetTemplateChild("myButton") as Button;
if (myButton != null)
myButton.Click += OnMyButtonClick;
}

...

void OnMyButtonClick(object sender, RoutedEventArgs e)
{
// Perform the necessary actions here
}

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate()

MyBase.OnApplyTemplate()

Dim myButton As Button = CType(GetTemplateChild("myButton"), Button)
If Not myButton Is Nothing Then
AddHandler myButton.Click, AddressOf OnMyButtonClick
End If

End Sub

...

Sub OnMyButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)

' Perform the necessary actions here

End Sub

Now that the custom presenter and its template are ready, you need to associate the presenter with an item. In order to do this, you have to define a new Item class and associate MyPresenter with it using the ItemPresenterAttribute. To see the new presenter in action, create an item of type MyAppointment and add it to the displayed schedule.

C# [image] Copy Code

[ItemPresenter(typeof(MyPresenter))]
public class MyAppointment : Appointment
{
public MyAppointment()
{
}

...
}

Visual Basic [image] Copy Code

<ItemPresenter(GetType(MyAppointmentPresenter))> _
Public Class MyAppointment
Inherits Appointment

Public Sub New(ByVal calendar As calendar)

End Sub

...

End Class

For an extensive example on how to create custom item presenters, check the new CustomItemTemplate sample.


Serialization and Output

Serialization and Output


Creating and Printing Reports

Creating and Printing Reports

Creating a Report

To create a report for a Schedule object, create an instance of the Report class. This class along with the rest of the reporting classes are declared in the MindFusion.Scheduling.Wpf.Reporting.dll assembly.

C# [image] Copy Code

Report report = new Report();

VB.NET [image] Copy Code

Dim report As New Report()

The report is associated with Schedule objects through its Schedule property.

Adding Columns to the Report

Each report contains zero or more columns. The columns in the report display individual properties of the items in the underlying Schedule, such as HeaderText, StartTime and so on. To add new columns to an existing report, call the CreateColumn method, set the desired properties of the ReportColumn object returned by this method, then add the column to the report's Columns collection. There is no limit to the number of columns a report can contain.

The following code creates two columns in the report, displaying the HeaderText and StartTime properties of the items respectively.

C# [image] Copy Code

ReportColumn column = null;

// Create the column representing the item header
column = report.CreateColumn();
column.Property = "HeaderText";
column.Width = 100;
report.Columns.Add(column);

// Create the column representing the item start time
column = report.CreateColumn();
column.Property = "StartTime";
column.Width = 50;
report.Columns.Add(column);

VB.NET [image] Copy Code

Dim column As ReportColumn = Nothing

' Create the column representing the item header
column = report.CreateColumn()
column.[Property] = "HeaderText"
column.Width = 100
report.Columns.Add(column)

' Create the column representing the item start time
column = report.CreateColumn()
column.[Property] = "StartTime"
column.Width = 50
report.Columns.Add(column)

The widths of the columns are interpreted differently depending on the AbsoluteColumnWidth property in the report's Options. By default, the name of the associated property is displayed as a header of each column. This header can be customized through the column's Header property or the report's QueryHeaderText event.

Customizing the Report

The reports can be customized through the properties in the ReportOptions class. An instance of this class can be accessed through the report's Options property. The following example sets the background of all even rows in the report to red:

C# [image] Copy Code

report.Options.AlternativeStyle.Brush = new MindFusion.Drawing.SolidBrush(Color.Red);

VB.NET [image] Copy Code

report.Options.AlternativeStyle.Brush = New MindFusion.Drawing.SolidBrush(Color.Red)

Printing or Previewing a Report

To print or preview a report, call its Print or PrintPreview methods respectively. The report needs to be already associated with a Schedule object or these methods will raise an exception.

Exporting a Report

The reports can be exported to PDF and Excel by calling the ExportPdf and ExportExcel respectively. Each method accepts as argument the name of the file to export to. Once again, if the report is not associated with a Schedule, the methods will raise an exception.

Grouped Reports

The reports can also display items grouped by their associated resources. To enable grouping, set GroupType to ByContacts, ByResources, ByLocations or ByTasks, depending on the type of the resource to group by. The appearance of the resource header in the report can be customized through the GroupHeaderStyle property.


Exporting

Exporting

Currently MindFusion.Scheduling for WPF supports exporting to the XLSX format.

Exporting to Open Office XML (XLSX) files

Add references to the MindFusion.Scheduling.WPF.Excel.dll and MindFusion.Excel.WPF.dll assemblies to your project. Create an ExcelExporter instance and call its Export method, passing a reference to the calendar to be exported and a string specifying the output file name.

The following example shows how to export a calendar to an XLSX file. The example assumes that xlsxPath is a variable containing the name of the file to export to and calendar is a variable identifying the Calendar to export.

C# [image] Copy Code

MindFusion.Scheduling.WPF.Export.ExcelExporter excelExporter =
new MindFusion.Scheduling.WPF.Export.ExcelExporter();
excelExporter.Export(calendar, xlsxPath);

VB.NET [image] Copy Code

Dim excelExporter As New MindFusion.Scheduling.WPF.Export.ExcelExporter()
excelExporter.Export(calendar, xlsxPath)


MindFusion.Spreadsheet for WPF Overview

MindFusion.Spreadsheet for WPF Overview

The next few chapters give you an overview of all MindFusion.Spreadsheet for WPF features, grouped by functionality.


Workbook

Workbook

The workbook consists of a set of worksheets. In addition, the workbook contains a list of named ranges, manages undo/redo and provides formula calculations.

The workbooks are represented by the Workbook class. The worksheets in the workbook can be accessed and managed through the Worksheets collection of the Workbook class. New worksheets are created and added to the workbook indirectly, through the Add method of this collection. The NamedRange objects of the workbook are managed through the NamedRanges collection.

The workbook acts as a model and do not provide visualization directly. To display a workbook on a form, use the WorkbookView control. To print or preview a workbook, use the WorkbookPrinter class. For more information about this, see Workbook View.

Serialization

Workbooks can be imported from and exported to a variety of formats. To import a workbook, use the appropriate importer class - CsvImporter, CalcImporter, ExcelImporter and so on. Alternatively, to export a workbook, use an instance of the one of the exporter classes - PdfExporter, CsvExporter and so on. The workbook can be serialized to and deserialized from a stream or a file through the respective SaveTo* and LoadFrom* methods. For example, to save the workbook to an XML, use one of the SaveToXml overloads. To read more about serialization, check the Serialization and Output topic.

Undo and Redo

The Workbook class provides automatic undo and redo of changes. The undo and redo can be enabled and disabled through the UndoEnabled property. To undo or redo an action, use the Undo and Redo methods. To check if there is an action to be undone or redone, use the CanUndo and CanRedo properties. When an action is undone or redone, the ActionUndone or ActionRedone events are raised. For more information about this, check the Undo and Redo topic.

Localization

To specify the culture of the workbook and its associated worksheets, use the Locale property. This culture is used when parsing and formatting data in the worksheets. The default of this property is the culture of the current thread.


Worksheet

Worksheet

The worksheet represents a rectangular grid of cells. Each cell can contain data, such as numbers, text, and formulas. The worksheet can contain other elements, such as images, annotations and charts.

The worksheets are represented by the Worksheet class. The Worksheet class cannot be instantiated directly. New worksheets can be created through the Worksheets collection of an existing Workbook object. The worksheets are part of the model and do not provide visualization. To display a worksheet on a form, use the built-in WorkbookView control. For more information about this, see Workbook View.

Cells and Cell Ranges

The cells in a worksheet are accessed through the Cells property, by providing the cell name or the zero-based indices of the cell's column and row. The cell name is specified in the A1 or R1C1 formats. The following example demonstrates how to set the data of a worksheet cell:

C# [image] Copy Code

worksheet.Cells["C4"].Data = 100; // Accessing the cell by its name in the A1 format
worksheet.Cells["R4C3"].Data = 100; // Accessing the cell by its name in the R1C1 format
worksheet.Cells[2, 3].Data = 100; // Accessing the cell by its zero-based indices

Visual Basic [image] Copy Code

worksheet.Cells("C4").Data = 100 ' Accessing the cell by its name in the A1 format
worksheet.Cells("R4C3").Data = 100 ' Accessing the cell by its name in the R1C1 format
worksheet.Cells(2, 3).Data = 100 ' Accessing the cell by its zero-based indices

The individual cells in the worksheet are represented by the Cell class. This class can be used to manage the cell's data, style, and so on. The worksheets can also provide access to a rectangular subset of cells through the CellRange class. Instances of this class can be obtained through the CellRanges collection by specifying the top, left, bottom, and right cells of the cell area of interest. The CellRange objects can be used to style the entire range of cells, to merge and unmerge the cells in the range, and so on.

Rows and Columns

The rows and columns in a worksheet are represented by the Row and Column classes respectively. The individual rows and columns are obtained by indexing the Rows and Columns collections. The Row and Column objects can be used to adjust the size of the respective row and column and to style all cells in the row or column. The Rows and Columns collections can also provide access to a range of rows and columns. These ranges are represented by the RowRange and ColumnRange classes respectively and can be accessed by using the collection's indexer that accepts two arguments - the start and end index of the range. The range objects can be used to style, resize or hide a range of rows or columns. The following example demonstrates how to hide all rows in a worksheet beyond row 30:

C# [image] Copy Code

worksheet.Rows[30, worksheet.Rows.Count - 1].IsHidden = true;

Visual Basic [image] Copy Code

worksheet.Rows(30, worksheet.Rows.Count - 1).IsHidden = True

Pictures and Charts

In addition to the regular data, the worksheet can also contain pictures and charts (collectively known as interactive objects). The interactive objects in the worksheet are managed through the Drawing object. For example, to add new pictures or charts to a worksheet, use one of the AddPicture overloads of the Drawing class.

For additional information about charts, see Charts.


Charts

Charts

The following topics are contained within this topic:

Chart Types
Information about the various chart types provided by MindFusion.Spreadsheet for WPF.

Creation and Initialization
Information on how to create chart objects and how to initialize their data series.

Customization
Information on how to customize the appearance of the chart.

Legend
Information about the chart legend.


Chart Types

Chart Types

MindFusion.Spreadsheet for WPF offers various chart types, grouped into several categories - Area, Bar, Bubble, Column, Donut, Line, Pie, Radar, Scatter, Smooth area and Smooth line. The type of a chart can be set at any time through the Type property. There are various restrictions based on the type of the chart. For example, Pie and Donut charts can display only a single series.

Area Charts

This category includes the Area, AreaStacked, and AreaStacked100Percent chart types. These charts display 2D polygonal areas for each series. The following table provides short description of the charts in this category.

Type | Description
Area | A chart with 2D areas. The areas are overlayed one over the other.
AreaStacked | A chart with 2D areas. The areas are stacked one on top of the other.
AreaStacked100Percent | A chart with 2D areas. The areas are stacked and scaled to fill the height of the plot area.

Bar Charts

This category includes the Bar, BarStacked, and BarStacked100Percent chart types. These charts display vertical bars for the individual values in each series, grouped by index. The following table provides short description of the charts in this category.

Type | Description
Bar | A chart with 2D vertical bars. The bars are arranged one next to the other.
BarStacked | A chart with 2D vertical bars. The bars are stacked one on top of the other.
BarStacked100Percent | A chart with 2D vertical bars. The bars are stacked and scaled to fill the height of the plot area.

Bubble Charts

This category includes the Bubble chart. The chart displays a circle for the individual values in each series. The size of the circles is proportional to the represented value.

Column Charts

This category includes the Column, ColumnStacked, and ColumnStacked100Percent chart types. These charts display horizontal bars for the individual values in each series, grouped by index. The following table provides short description of the charts in this category.

Type | Description
Column | A chart with 2D horizontal bars. The bars are arranged one next to the other.
ColumnStacked | A chart with 2D horizontal bars. The bars are stacked one on top of the other.
ColumnStacked100Percent | A chart with 2D horizontal bars. The bars are stacked and scaled to fill the width of the plot area.

Donut Charts

This category includes the Donut and DonutExploded chart types. These charts display a donut piece for each value of the first series. The series beyond the first are ignored. The following table provides short description for the charts in this category.

Type | Description
Donut | A chart with 2D donut pieces.
DonutExploded | A chart with 2D donut pieces. The pieces are extruded slightly away from the center.

Line Charts

This category includes the Line, LineMarks, LineStacked, LineStacked100Percent, LineWithMarks, LineWithMarksStacked, and LineWithMarksStacked100Percent chart types. These charts display a polygonal line for each series. The y-coordinates of the line points correspond to the values of the series. The following table provides short description for the charts in this category.

Type | Description
Line | A chart with polygonal lines.
LineMarks | A chart with indicators at each value point.
LineStacked | A chart with polygonal lines. The lines are stacked one on top of the other.
LineStacked100Percent | A chart with polygonal lines. The lines are stacked and scaled to fill the height of the plot area.
LineWithMarks | A chart with polygonal lines and indicators at each value point.
LineWithMarksStacked | A chart with polygonal lines and indicators at each value point. The lines are stacked one on top of the other.
LineWithMarksStacked100Percent | A chart with polygonal lines and indicators at each value point. The lines are stacked and scaled to fill the height of the plot area.

Pie Charts

This category includes the Pie and PieExploded chart types. These charts display a pie piece for each value of the first series. The series beyond the first are ignored. The following table provides short description for the charts in this category.

Type | Description
Pie | A chart with 2D pie pieces.
PieExploded | A chart with 2D pie pieces. The pieces are extruded slightly away from the center.

Radar Charts

This category includes the RadarFilled, RadarFilledWithLines, RadarWithLines, RadarWithLinesAndMarks, and RadarWithMarks chart types. These charts display a spider-web with number of axes corresponding to the number of values in the series. The following table provides short description for the charts in this category.

Type | Description
RadarFilled | A chart with a 2D polygonal area for each series.
RadarFilledWithLines | A chart with an outlined 2D polygonal area for each series.
RadarWithLines | A chart with a 2D polygon for each series.
RadarWithLinesAndMarks | A chart with a 2D polygon and indicators at each value point.
RadarWithMarks | A chart with indicators at each value point.

Scatter Charts

This category includes the ScatterWithLines, ScatterWithLinesAndMarks, ScatterWithMarks, ScatterWithSmoothLines, and ScatterWithSmoothLinesAndMarks chart types. These charts display the values of their series as points in a 2D space. The following table provides short description for the charts in this category.

Type | Description
ScatterWithLines | A chart with polygonal lines for each series.
ScatterWithLinesAndMarks | A chart with polygonal lines and indicators at each value point.
ScatterWithMarks | A chart with indicators at each value point.
ScatterWithSmoothLines | A chart with smooth lines for each series.
ScatterWithSmoothLinesAndMarks | A chart with smooth lines and indicators at each value point.

Smooth Area Charts

The charts in this category are similar to the Area Charts with the only difference that the displayed areas are smooth.

Smooth Line Charts

The charts in this category are similar to the Line Charts with the only difference that the displayed lines are smooth.


Creation and Initialization

Creation and Initialization

Creating the Chart

Chart objects are created indirectly, by calling one of the AddChart methods of the Drawing class. The drawing of a worksheet is accessible through the Drawing property. The following example demonstrates how to create and add a new chart to an existing worksheet:

C# [image] Copy Code

worksheet.Drawing.AddChart();

Visual Basic [image] Copy Code

worksheet.Drawing.AddChart()

Setting the Data

There are two ways to set the data of the chart. The first one is by calling the SetDataSource method and specifying the cell range that contains the data. The second method is by manually creating the Series objects and adding them to the chart's Series collection.

To specify the data of the chart by the SetDataSource method, pass to the method a string representing a cell range (in the A1 or R1C1 format) or an expression that evaluates to a cell range. The resulting cell range is used to obtain the data of the chart. Note, that the data can identify cells from another worksheet, not necessarily the worksheet containing the chart. The data in the specified cell range is fetched and analyzed based on the chart type and the values of the other SetDataSource parameters, and the appropriate series are created and added to Series collection of the chart.

To specify the data of the chart manually, create instances of the Series class, set their Name, Labels and Values properties and add them to the chart's Series collection. The series are created indirectly, by calling the Add method of the Series collection of the chart. The Name of the series can be an expression. In this case the actual name is the result of the expression evaluation. The Labels and Values properties can represent a cell range or an expression, which evaluates to a cell range or an array. The cell range must be a vector, that is its width or height must be equal to 1.

The following example illustrates both methods. The example assumes that chart identifies an existing chart.

C# [image] Copy Code

// Method 1
chart.SetDataSource("DataSheet!$A$1:$D$10", PlotBy.Column, null, null);

// Method 2
var series = chart.Series.Add();
series.Name = "My Series";
series.Values = "=A1:A5";

Visual Basic [image] Copy Code

' Method 1
chart.SetDataSource("DataSheet!$A$1:$D$10", PlotBy.Column, Nothing, Nothing)

' Method 2
Dim series = chart.Series.Add()
series.Name = "My Series"
series.Values = "=A1:A5"

Positioning

The chart object can be positioned inside the worksheet programmatically through a set of properties. The Anchor property specifies whether the object is positioned relatively to a cell or to the top-left corner of the worksheet. The FromColumn and FromRow properties specify the relative cell and the HorizontalOffset and VerticalOffset properties specify the distance of the chart from its origin. The chart can be resized through the Width and Height properties.

The chart can be positioned and resized interactively by selecting the chart and dragging the handles at the four corners with the mouse.


Customization

Customization

Customizing the Chart

All texts in the chart can be customized through the FontName, FontSize, FontBold, FontItalic, FontUnderline, FontStrikeout, and TextBrush properties of the Chart class. Some texts can be individually customized using specialized settings. The chart title can be set through the Title property and customized through the TitleFontName, TitleFontSize, TitleFontBold, TitleFontItalic, TitleFontUnderline, TitleFontStrikeout, and TitleTextBrush properties. The background color of the chart can be set through the Fill property. The LineBrush, LineSize and LineStyle properties can be used to customize the outline.

The fill and outline of the plot area can be customized through the PlotFill, PlotBorderBrush, PlotBorderSize, and PlotBorderStyle properties. The grid lines can be styled through the GridLineBrush and GridLineSize properties. Note, the grid lines are only visible when the ShowMajorGridLines property of the respective AxisSettings is set to true.

Customizing the Axes

This discussion is only relevant for charts that have at least one axis. The charts that do not have axes (such as the Pie and Donut charts) are not affected by the following settings.

The axes of the chart are customized through the settings exposed by the XAxisSettings and YAxisSettings properties of the chart. For charts with label and value axes, the XAxisSettings always affects the label axis and the YAxisSettings affects the value axis. For example, for Bar Charts the XAxisSettings actually affects the y-axis, which is the label axis.

The axis labels are affected by the FontName, FontSize, FontBold, FontItalic, FontUnderline, FontStrikeout, and TextBrush properties of the Chart class. The axis title can be set through the Title property of the respective AxisSettings object and is also affected by the font and color properties of the chart. However, the title can be individually customized through the TitleFontName, TitleFontSize, TitleFontBold, TitleFontItalic, TitleFontUnderline, TitleFontStrikeout, and TitleTextBrush properties of the AxisSettings. When these properties are null (Nothing in Visual Basic) the title will use the corresponding properties of the chart.

The major and minor ticks of an axis can be displayed through the ShowMajorTicks and ShowMinorTicks properties respectively. The ShowMinorTicks property is only relevant for value axes. To display the major grid lines associated with the axis, use the ShowMajorGridLines property.

The scaling and labels of the value axes are automatically calculated according to the displayed data. They can also be specified manually through the Minimum, Maximum, MajorUnit, and MinorUnit properties.

Customizing the Series

The elements associated with a series are colored automatically using different shadings of the colors in the DefaultColors property of the chart. To individually customize a series, use the Fill, LineBrush, LineSize, and LineStyle properties of the Series class.


Legend

Legend

The chart legend can be customized through a set of properties in the Chart class. The legend can be shown or hidden through the ShowLegend property. The position of the legend relatively to the plot area is specified through LegendPosition. The text font and color of the legend are specified through the LegendFontName, LegendFontSize, LegendFontBold, LegendFontItalic, LegendFontUnderline, LegendFontStrikeout, and LegendTextBrush properties. If any of these properties are null (Nothing in Visual Basic), the legend uses the corresponding property of the chart. For example, if LegendFontName is null (the default), the legend will use the FontName property of the chart. The appearance of the legend can be modified through the LegendFill, LegendBorderBrush, and LegendBorderSize properties. The number of lanes in the legend can be set through LegendLanes.


Workbook View

Workbook View

The WorkbookView control can be used to display Workbook objects on a Windows form. It displays a single worksheet at a time. The other worksheets in the workbook can be accessed through the tabs at the bottom of the view. New sheets can be added interactively by pressing the 'plus' button. The formula bar displays the data of the currently active cell. The following image illustrates the WorkbookView control:

The WorkbookView displays the cells and objects of the worksheet, provides properties for manipulating the active cell and selection, for scrolling the view, for hiding the scrollbars and the worksheet headers, and so on. More specifically the control provides the users the ability to:

  • scroll the worksheet using the scrollbars, the keyboard or the mouse;
  • modify cell data by pressing F2 while the cell is active, by typing directly, or by using the formula bar;
  • perform auto-fills by dragging the bottom right corner of the current selection;
  • select cells by using the keyboard or by dragging with the mouse;
  • cut, copy and paste cell data;
  • modify interactive objects (such as pictures and charts) by dragging them with the mouse;
  • resize and hide headers, and more.

The workbook is associated with the view through the Workbook property. The currently active worksheet can be get or set through the ActiveWorksheet property. The currently active cell can be get or set through the ActiveCell property. The cell and object selection can be manipulated through the Selection property. The ScrollX and ScrollY properties can be used to get or set the position of the scrollbars. The worksheet headers can be hidden through the ShowHeaders property. The grid lines can be toggled through the ShowGridLines property. The cursors displayed during various user interactions can be customized through a set of properties: PointerCursor, AutoFillCursor, DiagonalResizeCursor, CounterDiagonalResizeCursor, HorizontalResizeCursor, VerticalResizeCursor, MoveCursor, DisallowCursor, HorizontalSplitCursor, and VerticalSplitCursor.

The view provides many events that can be used to track, validate and respond to user activities in the view. Some of the more interesting ones are listed below. For the complete list of events, check WorkbookView Events.

  • CellClicked - raised when the user clicks a cell with the mouse.
  • HyperlinkClicked - raised when the user clicks a cell containing a Hyperlink.
  • InplaceEditStarting - raised when the user is about to in-place edit a cell and can be used to prevent cells from being in-place edited.
  • WorksheetAdded - raised when a new view is added interactively by pressing the 'plus' button.
  • ActiveWorksheetChanged - raised when the user changes the currently displayed worksheet by pressing its respective tab.

The view also provides several methods that can be used to auto-size rows and columns based on the cell content, namely, ResizeColumnToFit, ResizeColumnsToFit, ResizeRowToFit, and ResizeRowsToFit.


Undo and Redo

Undo and Redo

Overview

MindFusion.Spreadsheet for WPF provides a complete undo and redo support for every change in a workbook. To enable undo and redo, set the UndoEnabled property of the Workbook to true. When undo is enabled, changes are recorded in an internal undo history. Most changes are recorded automatically and some changes need to be recorded manually. To undo the most recent change, call the Undo method. To redo the most recently undone change, call the Redo method. To check if there are changes that can be currently undone and redone, use the CanUndo and CanRedo properties respectively. To get notified when the values of these properties change, handle the PropertyValueChanged event of the Workbook class.

All interactive modifications of a workbook and its worksheets are automatically recorded in the undo history. This includes creating, editing and deleting cell data, resizing worksheet headers, auto-filling, moving or resizing interactive objects, and so on. Adding and removing worksheets and named ranges to and from the Worksheets and NamedRanges collections of the Workbook are automatically recorded as well.

Programmatic changes, more specifically, property assignments, are usually not recorded automatically. To get a better understanding of how to record programmatic changes, check the following section.

Commands

The undoable changes in MindFusion.Spreadsheet for WPF are represented by the Command class and its subclasses. When a change occurs, an instance of the appropriate Command class is created and executed. Executing the command effectively causes the change to happen and also registers the command in the undo history. When Undo is called, the most recently executed command is undone, which causes its associated change to be reverted.

Most commands are created and executed automatically by the system. For example, when a Worksheet is added to a Workbook, a new AddItemCommand(Worksheet) command is created and executed. However, as mentioned earlier, property changes are usually not recorded automatically. To track and undo property changes in a worksheet, use the TrackChangesCommand. This command cannot be instantiated directly. To create a TrackChangesCommand object, call the StartChangeOperation method of the Workbook class. After the command has been started, the subsequent modifications to the worksheet will be recorded into this command. To complete and execute the command, either call the CommitChangeOperation method of the Workbook class or the Dispose method of the command itself. To cancel the command (and revert all recorded modifications), call the CancelChangeOperation method of the Workbook class or the Cancel method of the command.

The following example illustrates how to record several worksheet changes in a TrackChangesCommand. Note, that due to the disposable pattern, the command is automatically executed at the end of the using block.

C# [image] Copy Code

using (workbook.StartChangeOperation(worksheet))
{
worksheet.Name = "My worksheet";
worksheet.Cells["A1"].Data = 100;
}

Visual Basic [image] Copy Code

Using workbook.StartChangeOperation(worksheet)
worksheet.Name = "My worksheet"
worksheet.Cells("A1").Data = 100
End Using

Note, that the TrackChangesCommand records the changes of a single worksheet. To change several worksheets, create and execute individual TrackChangesCommand instances for each of them. This will cause several undo records to be registered in the undo history, one for each worksheet. The CompositeCommand can be used to avoid this.

Composite Commands

The CompositeCommand is a special command that can be used to wrap up several commands into a single operation. Similarly to the TrackChangesCommand, the CompositeCommand class cannot be instantiated directly. To create a CompositeCommand object, call the StartCompositeOperation method of the Workbook class. After a composite command has been started, executing other commands will register them as children of this CompositeCommand, rather than directly in the undo history. To complete the composite action, either call the CommitCompositeOperation method of the Workbook class or the Dispose method of the command itself. To cancel an active composite command (and revert all of its subactions), call the CancelCompositeOperation method of the Workbook class or the Cancel method of the command.

The following example creates a new worksheet in an existing workbook and changes the name of this new worksheet, both as a single composite operation. Note, that due to the disposable pattern, the composite command is automatically executed at the end of the using block.

C# [image] Copy Code

using (workbook.StartCompositeOperation())
{
var worksheet = workbook.Worksheets.Add();
using (workbook.StartChangeOperation(worksheet))
worksheet.Name = "My worksheet";
}

Visual Basic [image] Copy Code

Using workbook.StartCompositeOperation()
Dim worksheet = workbook.Worksheets.Add()
Using workbook.StartChangeOperation(worksheet)
worksheet.Name = "My worksheet"
End Using
End Using


Serialization and Output

Serialization and Output

The following topics are contained within this topic:

Serializing the Workbook
Information on how to serialize and deserialize MindFusion.Spreadsheet for WPF workbooks to XML files.

Importing
Information on how to import workbooks from various formats.

Exporting
Information on how to export workbooks to various formats.

Printing and Print Preview
Information about how to setup, preview and print workbooks.


Serializing the Workbook

Serializing the Workbook

Workbooks can be serialized as XML documents. To do that, call the SaveToXml method of the Workbook class. To deserialize a workbook back from its XML representation, call the LoadFromXml method. The control raises the SerializeTag and DeserializeTag events to enable serialization of complex Tag objects. The following code illustrates how to serialize and deserialize a custom worksheet tag:

C# [image] Copy Code

// The custom class that will be used as a tag
public class SampleData
{
public string CategoryId
{
get;
set;
}

public int OrderNumber
{
get;
set;
}
}

...

// The SerializeTag event handler
private void OnSerializeTag(object sender, SerializeTagEventArgs e)
{
var sampleData = e.Tag as SampleData;
var dataElement = e.Context.AddChildElement("Data", e.Representation);
e.Context.WriteString(sampleData.CategoryId, "CategoryId", dataElement);
e.Context.WriteInt(sampleData.OrderNumber, "OrderNumber", dataElement);
e.Handled = true;
}

// The DeserializeTag event handler
private void OnDeserializeTag(object sender, SerializeTagEventArgs e)
{
var dataElement = e.Representation.Element("Data");
var categoryId = e.Context.ReadString("CategoryId", dataElement);
var orderNumber = e.Context.ReadInt("OrderNumber", dataElement);
e.Tag = new SampleData { CategoryId = categoryId, OrderNumber = orderNumber };
e.Handled = true;
}

Visual Basic [image] Copy Code

' The custom class that will be used as a tag
Public Class SampleData

Public Property CategoryId() As String
Get
Return _categoryId
End Get
Set(ByVal value As String)
_categoryId = value
End Set
End Property

Public Property OrderNumber() As Integer
Get
Return _orderNumber
End Get
Set(ByVal value As Integer)
_orderNumber = value
End Set
End Property

Private _categoryId As String
Private _orderNumber As Integer

End Class

...

' The SerializeTag event handler
Private Sub OnSerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)
Dim sampleData = CType(e.Tag, SampleData)
Dim dataElement = e.Context.AddChildElement("Data", e.Representation)
e.Context.WriteString(sampleData.CategoryId, "CategoryId", dataElement)
e.Context.WriteInt(sampleData.OrderNumber, "OrderNumber", dataElement)
e.Handled = True
End Sub

' The DeserializeTag event handler
Private Sub OnDeserializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)
Dim dataElement = e.Representation.Element("Data")
Dim categoryId = e.Context.ReadString("CategoryId", dataElement)
Dim orderNumber = e.Context.ReadInt("OrderNumber", dataElement)
e.Tag = New SampleData With {.CategoryId = categoryId, .OrderNumber = orderNumber}
e.Handled = True
End Sub


Importing

Importing

Importing from CSV

To import a worksheet from an CSV (comma-separated values) file, create an instance of the CsvImporter class, set the appropriate properties and call the Import method. The Quote and Separator properties can be used to specify the quote and separator characters respectively in the imported file. The CsvImportForm (found in the MindFusion.Spreadsheet.Wpf.StandardForms.dll assembly) can be used to facilitate the import from CSV.

The following example illustrates how to import a worksheet from an CSV file:

C# [image] Copy Code

var csvImporter = new CsvImporter();
csvImporter.Import(worksheet, @"d:\mysheet.csv");

Visual Basic [image] Copy Code

Dim csvImporter As New CsvImporter()
csvImporter.Import(worksheet, "d:\mysheet.csv")

Importing from ODS Files

To import a workbook from an ODS (OpenDocument) file, create an instance of the CalcImporter class and call the Import method. The following example illustrates how to do this:

C# [image] Copy Code

var calcImporter = new CalcImporter();
calcImporter.Import(workbook, @"d:\mysheet.ods");

Visual Basic [image] Copy Code

Dim calcImporter As New CalcImporter()
calcImporter.Import(workbook, "d:\mysheet.ods")

Importing from XLSX Files

To import a workbook from an XLSX (Office Open XML) file, create an instance of the ExcelImporter class and call the Import method. The following example illustrates how to do this:

C# [image] Copy Code

var excelImporter = new ExcelImporter();
excelImporter.Import(workbook, @"d:\mysheet.xlsx");

Visual Basic [image] Copy Code

Dim excelImporter As New ExcelImporter()
excelImporter.Import(workbook, "d:\mysheet.xlsx")


Exporting

Exporting

Exporting to ODS

To export a workbook to an ODS (OpenDocument Spreadsheet) file, create an instance of the CalcExporter class and call the Export method. The following example illustrates how to do this:

C# [image] Copy Code

var calcExporter = new CalcExporter();
calcExporter.Export(workbook, @"c:\mysheet.ods");

Visual Basic [image] Copy Code

Dim calcExporter As New CalcExporter()
calcExporter.Export(workbook, @"c:\mysheet.ods")

Exporting to XLSX

To export a workbook to an XLSX (Office Open XML) file, create an instance of the ExcelExporter class and call the Export method. The following example illustrates how to do this:

C# [image] Copy Code

var excelExporter = new ExcelExporter();
excelExporter.Export(workbook, @"c:\mysheet.xlsx");

Visual Basic [image] Copy Code

Dim excelExporter As New ExcelExporter()
excelExporter.Export(workbook, @"c:\mysheet.xlsx")

Exporting to CSV

To export a worksheet to an CSV (comma-separated values) file, create an instance of the CsvExporter class, set the appropriate properties and call the Export method. The Quote and Separator properties can be used to specify the quote and separator characters respectively in the exported file. The CsvExportForm (found in the MindFusion.Spreadsheet.Wpf.StandardForms.dll assembly) can be used to facilitate the export to CSV.

The following example illustrates how to export a worksheet to an CSV file:

C# [image] Copy Code

var csvExporter = new CsvExporter();
csvExporter.Export(worksheet, @"d:\mysheet.csv");

Visual Basic [image] Copy Code

Dim csvExporter As New CsvExporter()
csvExporter.Export(worksheet, "d:\mysheet.csv")

Exporting to PDF

To export a worksheet to a PDF file, create an instance of the PdfExporter class, set the appropriate properties and call the Export method. The following example illustrates how to do this:

C# [image] Copy Code

var pdfExporter = new PdfExporter();
pdfExporter.Export(worksheet, @"d:\mysheet.pdf");

Visual Basic [image] Copy Code

Dim pdfExporter As New PdfExporter()
pdfExporter.Export(worksheet, "d:\mysheet.pdf")


Printing and Print Preview

Printing and Print Preview

To print or preview a workbook, create and instance of the WorkbookPrinter class, set the appropriate properties and call the Print or PrintPreview methods respectively. The range of the printed worksheets can be restricted through the FromWorksheet and ToWorksheet properties. The page ordering can be specified through the PageOrder property. The grid lines and interactive objects can be enabled or disabled through the EnableGridLines and EnableObjects properties respectively. The output scale can be customized through Scale. Note, that the print and preview is affected by rows and column with PageBreak set to true.


Formulas

Formulas

Formulas in MindFusion.Spreadsheet for WPF conform to the standard formula format established by the modern spreadsheet engines. The formula is expressed as a string, starting with an equal sign (=), followed by an expression. The expression can contain literals, mathematical operators, cell references, function calls, and so on.

Literals

A literal is a constant value written directly in the expression. For example, the number 5 or the text "Hello World" in the example below are both literals.

Formula [image] Copy Code

="Hello World"
=5

Both of the above formulas will evaluate to their respective literals. That is, the first formula will evaluate to the text "Hello World" and the second formula will evaluate to the number 5.

The literals in MindFusion.Spreadsheet for WPF can be numbers, texts and error values. The text literals should be enclosed in quotes. The error values are #NAME?, #REF!, #ERROR!, #VALUE!, #NUM!, #N/A, #DIV/0!, and #NULL!.

Cell and Cell Range References

Formula expressions can contain references to cells or cell ranges. The cell references are written as a combination of the column letter(s) and row number of the cell. For example, A1 is a reference to the top-left cell of the current worksheet. Alternatively, cell references can be written in the RMCN format, where M and N are the numbers of the cell row and column respectively. For example, the reference to the top-left cell of the current worksheet in this format will look like this: R1C1. The cell reference can include the name of a worksheet when the referenced cell is not part of the worksheet containing the formula. The worksheet name is written before the cell name, separated with an exclamation mark, for example, Sheet1!A1. If the worksheet name contains characters other than letters and numbers or the worksheet name starts with a character other than a letter, the worksheet name must be enclosed in single quotes, for example, 'My sheet'!A1.

The cell range references are expressed as a pair of cell names separated with a colon (:), for example, A1:C2 references the cell range with the cell A1 at the top-left and the cell C2 at the bottom-right. Cell ranges can also include the name of a worksheet, for example, Sheet1!A1:C2.

The cell and cell range references are evaluated differently depending on the context in which they are encountered. Generally, the cell references are dereferenced and the value of the cell is used in the expression. For example, the following formula calculates the sum of two cells:

Formula [image] Copy Code

=A1+B1

In some cases the referenced cell or cell range is not dereferenced. For example, the following formula returns the number of the cell row. The actual value of the cell has no effect on the result of the evaluation.

Formula [image] Copy Code

=ROW(A1)

Operators

Formula expression can contain mathematical or comparison operators. The operators are similar to functions - they take one or more operands and return a value. The syntax of the operators depend on their type, but is usually in the form <operand1><operator><operand2>, where <operand1> is an expression representing the first operand, <operand2> is an expression representing the second operand, and <operator> is the symbol of the operator. For example, the addition operator (+) can be used to sum two numeric values (A1+5). The preceding syntax applies to operators that accept two operands (binary operators). Operators accepting a single operand (unary operators) are written in the form <operator><operand>. For example, the unary minus operator (–) can be used like this:

Formula [image] Copy Code

=-PI()

The mathematical operators supported by MindFusion.Spreadsheet for WPF are + (addition), – (subtraction), – (unary minus), / (division), * (multiplication), & (concatenation), and ^ (exponent). The supported comparison operators are < (less than), <= (less than or equal), = (equal), <> (not equal), >= (greater than or equal), and > (greater than).

The operators encountered in a formula are evaluated according to their precedence. Operators with higher priority are evaluated before operators with lower priority. For example, the following formula will evaluate to 14, because the multiplication will be evaluated first:

Formula [image] Copy Code

=2+3*4

Operator precedence can be changed by using parentheses. Changing the order of the operators in the above example, so that the addition is evaluated first, can be done like this:

Formula [image] Copy Code

=(2+3)*4

The following table lists the operators in order of precedence:

Unary | – (unary minus)
Arithmetic - Multiplicative | *, /
Arithmetic - Additive | +. –
Comparison | <, <=, >=, >
Equality | =, <>

Functions

The formula expressions can contain calls to one or more of the built-in functions or to a custom function. For a complete list of the functions available in MindFusion.Spreadsheet for WPF formulas, check the Function Reference topic. The function call has the following syntax: <name>(<param1>,..,<paramN>), where <name> is the name of the function and <param1> through <paramN> are the function parameters. The following example illustrates a formula containing a function call:

Formula [image] Copy Code

=SUM(A1:D5)

Some function do not have parameters. In this case the parentheses are still required:

Formula [image] Copy Code

=NA()

Function calls can be nested. In this case the result of the nested function is used as a parameter of the nesting function. For example:

Formula [image] Copy Code

=ABS(COS(PI()))

Custom functions

MindFusion.Spreadsheet for WPF provides the ability to register custom functions with the calculation engine. This can be done by implementing the IExpressionEvaluator interface and assigning an instance of the class to the ExtendedEvaluator property of the Workbook class. For illustration how to do this, check the CustomFunctions sample.

Arrays and Matrices

Arrays and matrices can be written directly into a formula, using the following syntax:

Syntax [image] Copy Code

{E11;..;E1N|E21;..;E2N|..|EM1;..;EMN}

The first sequence of values E11 to E1N represents the top row of the matrix, the second sequence (E21..E2N) represents the second row, and so on. For example, the following formula demonstrates a matrix with 3 columns and 2 rows:

Formula [image] Copy Code

={1;2;3|4;5;6}


Auxiliary Forms

Auxiliary Forms

MindFusion.Spreadsheet for WPF provides a set of Windows forms that can be used to facilitate the creation and manipulation of various objects in the worksheet. All of the forms are contained in the MindFusion.Spreadsheet.Wpf.StandardForms.dll assembly, in the MindFusion.Spreadsheet.Wpf namespace. Additional information about each form, including sample code, can be found in the form's topic.


Tutorials

Tutorials


MindFusion.Charting for WPF Tutorials

MindFusion.Charting for WPF Tutorials


Building a Surface Chart

Building a Surface Chart

A surface chart is a 3D chart that plots the correlation between its data points. It is useful for spotting trends or patterns. MindFusion.Charting for WPF offers you a quick and intuitive way to implement and customize a surface chart into your application - look at the following steps:

1. Create the surface chart

In design time, drag the icon of the surface chart from the tool box and place it at the desired control container (grid, window, panel etc.) of your application. You can also create the chart programmatically:

C# [image] Copy Code

SurfaceChart chart = new SurfaceChart();
Grid.SetRow(chart, 0);
Grid.SetColumn(chart, 0);
grid1.Children.Add(chart);

VB.NET [image] Copy Code

Dim chart As New SurfaceChart()
Grid.SetRow(chart, 0)
Grid.SetColumn(chart, 0)
grid1.Children.Add(chart)

2. Data

The data can be set either through numbers or data binding.

2.1 Set numerical arrays

Each of the XData, YData and ZData properties represent a one-dimensional list, where you add your data or assign directly an array to the property:

C# [image] Copy Code

SurfaceSeries surfaceSeries = surfaceChart1.Series[0] as SurfaceSeries;
surfaceSeries.XData = new double[] { 1, 4, 5, 6 };

surfaceSeries.YData.Clear();
surfaceSeries.YData.Add(-3.0);
surfaceSeries.YData.Add(-1.4);
surfaceSeries.YData.Add(4.2);
surfaceSeries.YData.Add(1.8);

surfaceSeries.ZData = new double[] { -2.3, -8, -4.12, 1.66 };

surfaceChart1.Series[0] = surfaceSeries;

VB.NET [image] Copy Code

Dim surfaceSeries As SurfaceSeries = TryCast(surfaceChart1.Series(0), SurfaceSeries)
surfaceSeries.XData = New Double() {1, 4, 5, 6}

surfaceSeries.YData.Clear()
surfaceSeries.YData.Add(-3.0)
surfaceSeries.YData.Add(-1.4)
surfaceSeries.YData.Add(4.2)
surfaceSeries.YData.Add(1.8)

surfaceSeries.ZData = New Double() {-2.3, -8, -4.12, 1.66}

surfaceChart1.Series(0) = surfaceSeries

3. The surface

3.1 Surface color

The surface is drawn with its respective Brush (as specified in the SurfaceSeries.Fills) when the TextureType property is set to Brush.

C# [image] Copy Code

surfaceChart1.TextureType = TextureType.Brush;

VB.NET [image] Copy Code

surfaceChart1.TextureType = TextureType.Brush

3.2 Color map

You can draw the surface in different colors, which will demonstrate the distinction between the values. To do this, set the appropriate colors in the ColorMapList property and set TextureType to GradientColorMap or ExactColorMap.

Gradient color map. | Exact color map.

3.3 Wireframe

The chart can have a grid of lines at the surface that is called a wireframe. Set ShowWireFrame to true to display the wireframe. You can turn off color or color map for a chart that has a wireframe and vice versa - add a wireframe to each chart that has a surface color or colormap. The wireframe is drawn using the respective Brush (as specified in SurfaceSeries.Strokes) and its size is specified through the WireFrameThickness property.

3.4 Customizing how the surface is drawn

The surface can be drawn in oval shapes (slopes) when the InterpolationType property is set to Bezier. Alternatively, when the InterpolationType is Linear the slopes will appear as pyramids. The InterpolationSensitivity gives the radius, at which the elevation slope will be drawn - smaller values make up for steeper slopes and vice versa.

4. Camera

You can choose between a Perspective and Orthographic camera and between Directional and Ambient light. They are set with CameraType and LightType. If you enable AllowCameraInteraction the user will be able to change the position of the camera by clicking on the chart and dragging with the mouse. You can set the initial rotation angle and axis with the RotationAngle and RotationAxis properties.

5. Scale

If you want the chart to appear smaller or larger use the Scale property and assign to it the desired zoom factor.


Building a 3D Bar Chart

Building a 3D Bar Chart

This tutorial will teach you how to create and customize a 3D bar chart with MindFusion.Charting for WPF.

1. Getting started

Drag the icon of the 3D bar chart onto your work area in design time if you use Microsoft Visual Studio. In code, you can create the new chart like this:

C# [image] Copy Code

BarChart3D bChart = new BarChart3D();
Grid.SetColumn(bChart, 0);
Grid.SetRow(bChart, 0);
grid.Children.Add(bChart);

VB.NET [image] Copy Code

Dim bChart As BarChart3D = New BarChart3D
Grid.SetColumn(bChart, 0)
Grid.SetRow(bChart, 0)
grid.Children.Add(bChart)

Now you have the default BarChart3D onto your form.

2. Customize the appearance

When you want to show more series in a 3D bar chart you must change the BarType3D property to a value that uses multiple series. The 3D model is going to be bigger when the series are more and we will change the ModelHeight property to let all bars be drawn in reasonable space:

C# [image] Copy Code

barChart3D1.BarType3D = BarType3D.VerticalInColumn;
barChart3D1.ModelHeight = 30;

VB.NET [image] Copy Code

barChart3D1.BarType3D = BarType3D.VerticalInColumn
barChart3D1.ModelHeight = 30

3. Data

3.1 Set the DataSource

In our chart we will use an instance of the System.Collections.ObjectModel.ObservableCollection where we store data for the chart. The name of this collection is sales.

C# [image] Copy Code

barChart3D1.DataSource = sales;

VB.NET [image] Copy Code

barChart3D1.DataSource = sales

4. Create ChartSeries

The BarChart3D has a Series property that holds BarSeries objects, which represent the series of the chart. When we create a new series, we add it to the BarChart3D.Series property:

C# [image] Copy Code

//remove the predefined series
barChart3D1.Series.Clear();

BarSeries series1 = new BarSeries();
series1.YDataPath = "Turnover";
series1.XData = new double[] { 1, 2, 3, 4, 5, 6 };
series1.Fills.Add(Brushes.Green);
series1.TopLabelType = LabelType.ChartData;
barChart3D1.Series.Add(series1);

BarSeries series2 = new BarSeries();
series2.YDataPath = "Profit";
eries2.XData = new double[] { 1, 2, 3, 4, 5, 6 };
series2.Fills.Add(Brushes.Red);
series2.TopLabelType = LabelType.ChartData;
barChart3D1.Series.Add(series2);

VB.NET [image] Copy Code

'remove the predefined series
barChart3D1.Series.Clear()

Dim series1 As BarSeries = New BarSeries
series1.YDataPath = "Turnover"
series1.XData = New Double() {1, 2, 3, 4, 5, 6}
series1.Fills.Add(Brushes.Green)
series1.TopLabelType = LabelType.ChartData
barChart3D1.Series.Add(series1)

Dim series2 As BarSeries = New BarSeries
series2.YDataPath = "Profit"
eries2.XData = New Double() {1, 2, 3, 4, 5, 6}
series2.Fills.Add(Brushes.Red)
series2.TopLabelType = LabelType.ChartData
barChart3D1.Series.Add(series2)

5. Customize the axis

5.1 X-axis

We want to show custom labels at the X-axis and we will read them from our ObservableCollection list. We will also change the label for the X-axis and increase its offset from the axis labels:

C# [image] Copy Code

barChart3D1.XAxisSettings.LabelType = LabelType.CustomText;
barChart3D1.XLabelPath = "Month";
barChart3D1.XAxisSettings.TitleOffset = 5;
barChart3D1.XAxisSettings.Title = "2012";

VB.NET [image] Copy Code

barChart3D1.XAxisSettings.LabelType = LabelType.CustomText
barChart3D1.XLabelPath = "Month"
barChart3D1.XAxisSettings.TitleOffset = 5
barChart3D1.XAxisSettings.Title = "2012"

5.2 Y-axis

For the Y-axis we want to change the interval of the axis, its title and the offset of the title to the axis labels.

C# [image] Copy Code

barChart3D1.YAxisSettings.Interval = 50;
barChart3D1.YAxisSettings.Title = "in USD";
barChart3D1.YAxisSettings.TitleOffset = 8;

VB.NET [image] Copy Code

barChart3D1.YAxisSettings.Interval = 50
barChart3D1.YAxisSettings.Title = "in USD"
barChart3D1.YAxisSettings.TitleOffset = 8

Here is the final chart:


Building a 3D Pie Chart

Building a 3D Pie Chart

This tutorial will walk you through the steps to create a 3D pie chart with two data series. Pie data is read through data binding.

1. Create the pie chart

You can create the chart in the XAML editor by dragging the icon for the 3D pie chart and dropping it at your work area. Alternatively, you can create the chart through code:

C# [image] Copy Code

PieChart3D pChart = new PieChart3D();
Grid.SetRow(pChart, 0);
Grid.SetColumn(pChart, 0);
myGrid.Children.Add(pChart);

VB.NET [image] Copy Code

Dim pChart As PieChart3D = New PieChart3D
Grid.SetRow(pChart, 0)
Grid.SetColumn(pChart, 0)
myGrid.Children.Add(pChart)

2. Create the PieSeries

Each chart has initially a default series - we clear it and create our two pie series from scratch:

C# [image] Copy Code

pieChart3D1.Series.Clear();

PieSeries series1 = new PieSeries();
pieChart3D1.Series.Add(series1);

PieSeries series2 = new PieSeries();
pieChart3D1.Series.Add(series2);

VB.NET [image] Copy Code

pieChart3D1.Series.Clear

Dim series1 As PieSeries = New PieSeries
pieChart3D1.Series.Add(series1)

Dim series2 As PieSeries = New PieSeries
pieChart3D1.Series.Add(series2)

The data for the pie chart is taken from an ObservableCollection called sales. It has two fields - Profit and Turnover that will provide data for the pie series:

C# [image] Copy Code

pieChart3D1.DataSource = "sales";

series1.DataPath = "Profit";
series2.DataPath = "Turnover";

VB.NET [image] Copy Code

pieChart3D1.DataSource = "sales"

series1.DataPath = "Profit"
series2.DataPath = "Turnover"

3. Set the labels

We want to show the percent value for each slice inside it. For this we use the InnerLabelType property. We adjust the location of the labels with InnerLabelLocation. The font is bold.

C# [image] Copy Code

series1.InnerLabelLocation = 0.7;
series1.InnerLabelType = LabelType.Percents;
series1.LabelFontWeight = FontWeights.Bold;

VB.NET [image] Copy Code

series1.InnerLabelLocation = 0.7
series1.InnerLabelType = LabelType.Percents
series1.LabelFontWeight = FontWeights.Bold

4. Customizing the appearance

We increase the thickness of the doughnut series with DoughnutThickness and create a set of brushes for the slices:

C# [image] Copy Code

pieChart3D1.DoughnutThickness = 2;

List<Brush> brushes = new List<Brush>();
brushes.Add(Brushes.LightBlue);
brushes.Add(Brushes.LightGreen);
brushes.Add(Brushes.LightPink);
brushes.Add(Brushes.LightYellow);
brushes.Add(Brushes.LightSalmon);
brushes.Add(Brushes.LightCyan);

series1.Fills = brushes;
series2.Fills = brushes;

VB.NET [image] Copy Code

pieChart3D1.DoughnutThickness = 2

Dim brushes As List(Of Brush) = New List(Of Brush)
brushes.Add(Brushes.LightBlue)
brushes.Add(Brushes.LightGreen)
brushes.Add(Brushes.LightPink)
brushes.Add(Brushes.LightYellow)
brushes.Add(Brushes.LightSalmon)
brushes.Add(Brushes.LightCyan)

series1.Fills = brushes
series2.Fills = brushes

Here is the final chart:


Working with Themes

Working with Themes

With MindFusion.Charting for WPF you can:

  • Create custom themes based on the appearance of an existing chart;
  • Save a custom theme as an XML file;
  • Load a custom theme from its XML file;
  • Use a number of predefined themes.

1. Create a custom theme based on the appearance of an existing chart

Style your chart as you want. In our sample we will use a BarChart. We set a background, font settings for the title, brushes for the grid and customize the outline of the chart:

C# [image] Copy Code

BarChart modelChart = new BarChart()
{
Background = Brushes.Beige,
BorderThickness = new Thickness(5),
CornerRadius = new CornerRadius(5),
TitleFontSize = 18,
TitleFontWeight = FontWeights.Bold,
TitleFontFamily = new FontFamily("Tahoma"),
GridFills = new List<Brush>() { Brushes.LightGray, Brushes.Gray },
GridStrokes = new List<Brush>() { Brushes.DarkGray },
PlotAreaStroke = Brushes.DarkGray
};

VB.NET [image] Copy Code

Dim modelChart As New BarChart() With { _
.Background = Brushes.Beige, _
.BorderThickness = New Thickness(5), _
.CornerRadius = New CornerRadius(5), _
.TitleFontSize = 18, _
.TitleFontWeight = FontWeights.Bold, _
.TitleFontFamily = New FontFamily("Tahoma"), _
.GridFills = New List(Of Brush)() From { _
Brushes.LightGray, _
Brushes.Gray _
}, _
.GridStrokes = New List(Of Brush)() From { _
Brushes.DarkGray _
}, _
.PlotAreaStroke = Brushes.DarkGray _
}

Customize the appearance of the BarSeries. In the sample we add 4 brushes and strokes - one for each bar, because we are showing four bars.

C# [image] Copy Code

//create a new series and style it.
BarSeries series = new BarSeries() { StrokeThickness = 2, };

series.Fills.Add(Brushes.Red);
series.Fills.Add(Brushes.Green);
series.Fills.Add(Brushes.Blue);
series.Fills.Add(Brushes.Violet);
series.Strokes.Add(Brushes.DarkRed);
series.Strokes.Add(Brushes.DarkGreen);
series.Strokes.Add(Brushes.DarkBlue);
series.Strokes.Add(Brushes.DarkViolet);

//add the series to the series collection
modelChart.Series.Add(series);

VB.NET [image] Copy Code

'create a new series and style it.
Dim series As New BarSeries() With { _
.StrokeThickness = 2 _
}

series.Fills.Add(Brushes.Red)
series.Fills.Add(Brushes.Green)
series.Fills.Add(Brushes.Blue)
series.Fills.Add(Brushes.Violet)
series.Strokes.Add(Brushes.DarkRed)
series.Strokes.Add(Brushes.DarkGreen)
series.Strokes.Add(Brushes.DarkBlue)
series.Strokes.Add(Brushes.DarkViolet)

'add the series to the series collection
modelChart.Series.Add(series)

We finally create a new ChartTheme based on the model and we apply this theme to the chart we already have - barChart1.

C# [image] Copy Code

//create the theme
ChartTheme theme = new ChartTheme(modelChart);

//apply the theme
theme.Apply(barChart);

VB.NET [image] Copy Code

'create the theme
Dim theme As New ChartTheme(modelChart)

'apply the theme
theme.Apply(barChart)

2. Save a custom theme as a XML file

You do this by calling the ChartTheme.SaveToXml method and providing the name of the xml file.

C# [image] Copy Code

theme.SaveToXml("sampleTheme.xml");

VB.NET [image] Copy Code

theme.SaveToXml("sampleTheme.xml")

3. Load a theme from a XML file

You load a theme with the ChartTheme.LoadFromXml method. The method takes one argument, which is the name of the XML file.

C# [image] Copy Code

barChart.LoadTheme("C:\\Users\\UserName\\Downloads\\Blue.xml");

VB.NET [image] Copy Code

barChart.LoadTheme("C:\Users\UserName\\Downloads\Blue.xml")

4. Predefined themes

MindFusion.Charting for WPF offers a set of predefined themes, which are found in the setup directory. You can load them the way you would load any XML ChartTheme - see point 3.

The predefined Blue theme applied on a bar chart.


Building a RealTimeChart

Building a RealTimeChart

A real time chart is a type of line chart that can handle large number of points in a fast and efficient manner. MindFusion.Charting for WPF provides a special library, which you can use to render exactly those types of charts. Here are the major steps you need to follow if you plan to implement a real time chart into your application.

1. Initialize the control

Drag the RealTimeChart icon from the Visual Studio Toolbox onto the window of your WPF application. A new instance of the control is created:

XAML [image] Copy Code

<my:RealTimeChart Margin="12" Name="realTimeChart1" />

2. Create the X-axis

We use the XAxis property of the control to specify how our X-axis will look. First, we set the intervals and the length of the axis. We want the axis to start at 0 (its Origin), which also where the first label is drawn (LabelOrigin):

C# [image] Copy Code

chart1.XAxis.Length = 300;
chart1.XAxis.LabelOrigin = 0;
chart1.XAxis.Origin = 0;
chart1.XAxis.Interval = 30;

We need a title, drawn with a bigger font:

C# [image] Copy Code

chart1.XAxis.Title = "Time";
chart1.XAxis.TitleFontSize = 18.0;

Finally, we tell the control not to pin the labels - e.g. they will slide along the axes with the change of data:

C# [image] Copy Code

chart1.XAxis.PinLabels = false;

3. Adding Y-axes

We create a new Axis object and set its length, origin and interval. We set a title, no special settings for the title font. We want ticks and use TickLength to specify them. Finally, we add the newly created axis to the collection of Y-axes:

C# [image] Copy Code

Axis axis = new Axis();
axis.Origin = 0;
axis.Length = 100;
axis.Interval = 10;
axis.Title = "in Mbs";
axis.TitleRotationAngle = 0.0;
axis.TickLength = 5;
realTimeChart.YAxisCollection.Add(axis);

We want to add an Y-axis to the right of the plot area. When we create the axes, we add it to the Y2AxisCollection. Note that we align the labels to the right, because the axis is aligned to the right:

C# [image] Copy Code

Axis axis2 = new Axis();
axis2.Origin = 0;
axis2.Length = 10485760;
axis2.Interval = 1048576;
axis2.Title = "in Bytes";
axis2.TitleRotationAngle = 0.0;
axis2.TickLength = 5;
axis2.LabelHorizontalAlignment = HorizontalAlignment.Right;
realTimeChart.Y2AxisCollection.Add(axis2);

4. Adding Chart Series

Series should be bound to an Y-axis. We create two series, each one bound to one of the one of the Y-axis that we have. It is important to give our series a title - it will show in the legend. We create the series with diamond scatters at data points.

C# [image] Copy Code

//series bound to the left Y-axis
Series series1 = new Series(realTimeChart.YAxisCollection[0])
{
Stroke = new SolidColorBrush(Colors.Red),
Title = "Server 1",
ScatterType = ScatterType.Diamond,
ScatterStroke = new SolidColorBrush(Colors.Pink),
TitleFontFamily = new FontFamily("Verdana"),
TitleFontSize = 12
};

The second series is bound to Y2:

C# [image] Copy Code

//series bound to the right Y-axis
Series series2 = new Series(realTimeChart.Y2AxisCollection[0])
{
Stroke = new SolidColorBrush(Colors.Green),
Fill = Brushes.Green,
Title = "Server 2",
ScatterType = ScatterType.None,
TitleFontFamily = new FontFamily("Verdana"),
TitleFontSize = 12
};

It's important that you add the series to the SeriesCollection. Otherwise they will not show in the graphic:

C# [image] Copy Code

realTimeChart.SeriesCollection.Add(series1);
realTimeChart.SeriesCollection.Add(series2);

5. Setting data

Data is added as single Point objects or a collection of Point-s to the Data property of the Series.

C# [image] Copy Code

series1.Data.Add(new Point(x1, y1));
series2.Data.Add(new Point(x2, y2));

Please, note that you must call Commit() to update the chart:

C# [image] Copy Code

//Update the chart
realTimeChart.Commit();

6. Background image

We add a *.png file to the project in Visual Studio with the "Add existing item" menn. Then, we create an image brush from that file and set it as a background to the grid, which is our layout control. Here is the code in XAML:

C# [image] Copy Code

<Grid.Background>
<ImageBrush ImageSource="mf_logo.png" Opacity="0.1"/>
</Grid.Background>

The background of the RealTimeChart must be transparent for the image to show through:

C# [image] Copy Code

<my:RealTimeChart Margin="12" Name="realTimeChart" Background="Transparent"/>

7. We are ready!

Here is the chart we've built:


MindFusion.DataViews for WPF Tutorials

MindFusion.DataViews for WPF Tutorials


Tutorial 1: Getting Started

Tutorial 1: Getting Started

This tutorial will show you how to create a simple application with MindFusion.DataViews for WPF.

1. Create a new WPF application project

Select File -> New -> Project from the Visual Studio menu. In the dialog that appears, select Visual C# -> Windows from the tree on the left, then WPF Application from the list on the right. Type in the name of your project (the tutorial uses Tutorial1) and click 'OK'.

2. Add an ActivityChart control to the main window

Before using the ActivityChart control, it must be added it to the toolbox. Display the toolbox by selecting View -> Toolbox from the menu. Then select the appropriate category for the control and right-click on it. From the context menu choose 'Choose Items...'. In the "Customize Toolbox Items" dialog select the Components tab and click the 'Browse...' button. Then navigate to the control assembly file - MindFusion.DataViews.Wpf.dll. This file is found in the installation folder of the product. Once the dll is added to the list of components, click 'OK'. An ActivityChart item should appear in the selected category in the toolbox. Click on this item and drag it to the window's working area. This creates a new ActivityChart control on the window.

Note

Be sure to also reference the MindFusion.DataViews.Wpf.dll assembly. The file is located in the installation folder of the product.

3. Setting the control's properties

First prepare the main window control by setting its Height to 600, its Width to 800 and its WindowState to Maximized. Select the newly created control and click View -> Properties Window from the menu. In the Properties window change the name of the control to activityView and set Margin to 0.

The complete generated XAML code should look similar to the following:

XAML [image] Copy Code

<Window x:Class="Tutorial1.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:dataviews="http://mindfusion.eu/dataviews/wpf"
Title="Window1" WindowState="Maximized" Height="600" Width="800">
<Grid>
<dataviews:ActivityChart Name="activityView" />
</Grid>
</Window>

4. Adding data to the chart

First switch to code source view - by clicking View -> Code or by pressing F7. To create some activities and add them to the chart, you could use the built-in Activity class. First, prepare a collection that will hold the Activity objects. In the window's constructor add the following line:

Note

Be sure to include the MindFusion.DataViews.Wpf namespace via the using (Imports in Visual Basic) keyword in the beginning of the file.

C# [image] Copy Code

ObservableCollection<Activity> activities = new ObservableCollection<Activity>();

Visual Basic [image] Copy Code

Dim activities As New ObservableCollection(Of Activity)()

Next, create seven Activity objects with different StartTime, EndTime, Progress and ActivityName and add them to the collection. For example:

C# [image] Copy Code

Activity a0 = new Activity()
{
StartTime = DateTime.Today, // activity's start
EndTime = DateTime.Today, // activity's end
Progress = 1, // activity's progress
ActivityName = "Project start" // activity's name
};
activities.Add(a0);

Visual Basic [image] Copy Code

Dim a0 As New Activity() With { _
.StartTime = DateTime.Today, _
.EndTime = DateTime.Today, _
.Progress = 1, _
.ActivityName = "Project start" _
}
activities.Add(a0)

After you've created some activities, create an IProjectViewModel by calling the CreateViewModel method on activityView to create the ViewModel for the specified activity model. This is enough to display the data in the ActivityChart.

C# [image] Copy Code

IProjectViewModel project = activityView.CreateViewModel(activities, null, null, null, typeof(Activity), null, null, null);

Visual Basic [image] Copy Code

Dim project As IProjectViewModel = activityView.CreateViewModel(activities, Nothing, Nothing, Nothing, GetType(Activity), Nothing, Nothing, Nothing)

5. Build and run

Compile and run the application. The result should look similar to the image below:

Note

You can find the complete source code of this tutorial in the product installation folder, under the folder for the appropriate .NET version and language.


Tutorial 2: Adding Dependencies to the Chart

Tutorial 2: Adding Dependencies to the Chart

This tutorial shows how to enable dependencies between activities in an project using MindFusion.DataViews for WPF

1. Create and initialize a new WPF application project

Follow steps 1 through 4 from Tutorial 1.

2. Create dependencies between the activities in the chart

To create the dependencies you could use the built-in Dependency class, but you are not limited to it and can use you own custom created class that implements the IDependency interface. First, create a collection that will hold the Dependency objects.

C# [image] Copy Code

ObservableCollection<Dependency> dependencies = new ObservableCollection<Dependency>();

Visual Basic [image] Copy Code

Dim dependencies As New ObservableCollection(Of Dependency)()

Next, create some dependencies between the existing Activity objects and add them to the underlying collection.

C# [image] Copy Code

dependencies.Add(new Dependency() { From = a0, To = a1, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a0, To = a2, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a2, To = a3, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a1, To = a4, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a3, To = a4, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a1, To = a5, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a4, To = a6, DependencyType = DependencyType.FinishToStart });
dependencies.Add(new Dependency() { From = a5, To = a6, DependencyType = DependencyType.FinishToStart });

Visual Basic [image] Copy Code

dependencies.Add(New Dependency() With { _
.From = a0, _
.[To] = a1, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a0, _
.[To] = a2, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a2, _
.[To] = a3, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a1, _
.[To] = a4, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a3, _
.[To] = a4, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a1, _
.[To] = a5, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a4, _
.[To] = a6, _
.DependencyType = DependencyType.FinishToStart _
})
dependencies.Add(New Dependency() With { _
.From = a5, _
.[To] = a6, _
.DependencyType = DependencyType.FinishToStart _
})

3. Create the project and associate it with the view

Modify the project initialization from the previous tutorial to include the newly created dependencies like this:

C# [image] Copy Code

IProjectViewModel project = activityView.CreateViewModel(activities, dependencies, null, null, typeof(Activity), typeof(Dependency), null, null);

Visual Basic [image] Copy Code

Dim project As IProjectViewModel = activityView.CreateViewModel(activities, dependencies, Nothing, Nothing, GetType(Activity), GetType(Dependency), Nothing, Nothing)

4. Build and run

Compile and run the application. The result should look similar to the image below:

Note

You can find the complete source code of this tutorial in the product installation folder, under the folder for the appropriate .NET version and language.


Tutorial 3: Adding Resources

Tutorial 3: Adding Resources

This tutorial shows how to create resources and associate them to activities with MindFusion.DataViews for WPF.

1. Create a WPF application and create a view with activities and dependencies

Follow steps 1 and 2 from Tutorial 2.

2. Create resources and allocate them to activities

To create the resources you could use the built-in Resource class. To allocated them to resources you can use the built-in ResourceAllocation class. Create a collection that will hold the Resource objects and a collection that will hold the ResourceAllocation objects:

C# [image] Copy Code

ObservableCollection<Resource> resources = new ObservableCollection<Resource>();
ObservableCollection<ResourceAllocation> allocations = new ObservableCollection<ResourceAllocation>();

Visual Basic [image] Copy Code

Dim resources As New ObservableCollection(Of Resource)()
Dim allocations As New ObservableCollection(Of ResourceAllocation)()

Next, create three Resource objects and then allocate these resources to some of the already created Activity objects through four ResourceAllocation objects. For example:

C# [image] Copy Code

Resource r1 = new Resource()
{
Title = "Location 1",
Description = "This is location 1",
};
resources.Add(r1);

ResourceAllocation ra1 = new ResourceAllocation()
{
Activity = a1,
Resource = r1,
StartTime = a1.StartTime,
EndTime = a1.EndTime,
Progress = a1.Progress
};
allocations.Add(ra1);

Visual Basic [image] Copy Code

Dim r1 As New Resource() With { _
.Title = "Location 1", _
.Description = "This is location 1"}
resources.Add(r1)

Dim ra1 As New ResourceAllocation() With { _
.Activity = a1, _
.Resource = r1, _
.StartTime = a1.StartTime, _
.EndTime = a1.EndTime, _
.Progress = a1.Progress}
allocations.Add(ra1)

Note

Please note that you are not limited to the built-in classes for activities, dependencies, resources and allocations. You can use your own custom objects as you will find out in Tutorial 5.

3. Create the project and associate it with the view

Modify the project initialization from the previous tutorial to include the newly created resources like this:

C# [image] Copy Code

IProjectViewModel project = activityView.CreateViewModel(activities, dependencies, resources, allocations, typeof(Activity), typeof(Dependency), typeof(Resource), typeof(ResourceAllocation));

Visual Basic [image] Copy Code

Dim project As IProjectViewModel = activityView.CreateViewModel(activities, dependencies, resources, allocations, GetType(Activity), GetType(Dependency), GetType(Resource), GetType(ResourceAllocation))

4. Build and run

Compile and run the application. The result will be similar to the image below:

Note

You can find the complete source code of this tutorial in the product installation folder, under the folder for the appropriate .NET version and language.


Tutorial 4: Binding the Resource Chart

Tutorial 4: Binding the Resource Chart

This tutorial will show you how to synchronize a ResourceChart view with the ActivityChart view with MindFusion.DataViews for WPF.

1. Create a WPF application and add an ActivityChart view with data

Follow steps 1 through 3 from Tutorial 3.

2. Add a ResourceChart to the main window

If you followed the previous steps, a ResourceChart control should be present in Visual Studio Toolbox. Click on this item and drag it to the window's working area. This creates a new ResourceChart control on the window. Select the newly created control and from the Properties window set its Margin to 0 and its Name to resourceView. In the root Grid on the window, add two RowDefinition items and distribute the two chart views respectively into Grid.Row 0 and Grid.Row 1. The complete XAML for Window1 should look similar to this:

XAML [image] Copy Code

<Window x:Class="Tutorial4.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:dataviews="http://mindfusion.eu/dataviews/wpf"
Title="Window1" WindowState="Maximized" Width="800" Height="600">
<Grid>
<Grid.RowDefinitions>
<RowDefinition />
<RowDefinition />
</Grid.RowDefinitions>
<!-- Add an activity chart to the form -->
<dataviews:ActivityChart Name="activityView" Grid.Row="0"/>
<!-- Add a resource chart to the form -->
<dataviews:ResourceChart Name="resourceView" Grid.Row="1"/>
</Grid>
</Window>

3. Bind the ResourceChart to the project

In the code-behind, after you've created the IProjectViewModel for the activityView, all you have to do to bind the ResourceChart to the same project is to set its DataContext property to the newly created project.

C# [image] Copy Code

resourceView.DataContext = project;

Visual Basic [image] Copy Code

resourceView.DataContext = project

Note

It is not necessary that the project is created by the ActivityChart object and then bound to the ResourceChart object. The opposite is also true and the two chart views will again be synchronized by using the same IProjectViewModel.

4. Build and run

Compile and run the application. The result will be similar to the image below:

Note

You can find the complete source code of this tutorial in the product installation folder, under the folder for the appropriate .NET version and language.


Tutorial 5: Using a Custom Model

Tutorial 5: Using a Custom Model

This tutorial will show you how you can use custom Model classes with MindFusion.DataViews for WPF.

1. Getting started

Follow step 1 from Tutorial 1. Add the MindFusion.DataViews.Wpf controls to Visual Studio Toolbox (See step 2 in Tutorial 1). Manually reference the MindFusion.DataViews.Wpf.dll by clicking Project -> Add Reference... -> Browse and navigating to the file (usually located in the products installation folder).

2. Creating custom model classes

2.1 MyActivity class

In Visual Studio click Project -> Add Class... and name the new class MyActivity. This class will expose the following properties - Name, Start, End, Progress and Children. The complete code for MyActivity.cs (MyActivity.vb in Visual Basic) looks like this:

C# [image] Copy Code

// MyActivity.cs

class MyActivity
{
public MyActivity()
{
Children = new List<MyActivity>();
}

public string Name { get; set; }
public DateTime Start { get; set; }
public DateTime End { get; set; }
public double Progress { get; set; }
public List<MyActivity> Children { get; set; }
}

Visual Basic [image] Copy Code

' MyActivity.vb

Class MyActivity

Public Sub New()
Children = New List(Of MyActivity)()
End Sub

Public Property Name() As String
Get
Return m_Name
End Get
Set(ByVal value As String)
m_Name = Value
End Set
End Property
Private m_Name As String

Public Property Start() As DateTime
Get
Return m_Start
End Get
Set(ByVal value As DateTime)
m_Start = Value
End Set
End Property
Private m_Start As DateTime

Public Property [End]() As DateTime
Get
Return m_End
End Get
Set(ByVal value As DateTime)
m_End = Value
End Set
End Property
Private m_End As DateTime

Public Property Progress() As Double
Get
Return m_Progress
End Get
Set(ByVal value As Double)
m_Progress = Value
End Set
End Property
Private m_Progress As Double

Public Property Children() As List(Of MyActivity)
Get
Return m_Children
End Get
Set(ByVal value As List(Of MyActivity))
m_Children = Value
End Set
End Property
Private m_Children As List(Of MyActivity)
End Class

2.2 MyDependency class

Create a new class and name it MyDependency. This class will implement the IDependency interface which exposes the following members - From, To and DependencyType. The complete code for MyDependency.cs (MyDependency.vb in Visual Basic) looks like this:

C# [image] Copy Code

// MyDependency.cs

class MyDependency : IDependency
{
public MyDependency()
{
}

#region IDependency Members

public DependencyType DependencyType { get; set; }
public object From { get; set; }
public object To { get; set; }

#endregion
}

Visual Basic [image] Copy Code

' MyDependency.vb

Class MyDependency
Implements IDependency

Public Sub New()
End Sub

#Region "IDependency Members"

Public Property DependencyType() As DependencyType Implements IDependency.DependencyType
Get
Return m_DependencyType
End Get
Set(ByVal value As DependencyType)
m_DependencyType = Value
End Set
End Property
Private m_DependencyType As DependencyType

Public Property From() As Object Implements IDependency.From
Get
Return m_From
End Get
Set(ByVal value As Object)
m_From = value
End Set
End Property
Private m_From As Object

Public Property [To]() As Object Implements IDependency.To
Get
Return m_To
End Get
Set(ByVal value As Object)
m_To = value
End Set
End Property
Private m_To As Object

#End Region

End Class

2.3 MyResource class

Create a new class and name it MyResource. This class will expose the following properties - Title and Description. The complete code for MyResource.cs (MyResource.vb in Visual Basic) looks like this:

C# [image] Copy Code

// MyResource.cs

class MyResource
{
public MyResource()
{
}

public string Title { get; set; }
public string Description { get; set; }
}

Visual Basic [image] Copy Code

' MyResource.vb

Class MyResource

Public Sub New()
End Sub

Public Property Title() As String
Get
Return m_Title
End Get
Set(ByVal value As String)
m_Title = Value
End Set
End Property
Private m_Title As String

Public Property Description() As String
Get
Return m_Description
End Get
Set(ByVal value As String)
m_Description = Value
End Set
End Property
Private m_Description As String

End Class

2.4 MyAllocation class

Create a new class and name it MyAllocation. Add the following members - Activity, Resource, Start, End and Progress. The complete code for MyAllocation.cs (MyAllocation.vb in Visual Basic) looks like this:

C# [image] Copy Code

// MyAllocation.cs

class MyAllocation
{
public MyAllocation()
{
}

public MyActivity Activity { get; set; }
public MyResource Resource { get; set; }
public DateTime Start { get; set; }
public DateTime End { get; set; }
public double Progress { get; set; }
}

Visual Basic [image] Copy Code

' MyAllocation.vb

Class MyAllocation
Inherits MyActivity

Public Sub New()
End Sub

Public Property Activity() As MyActivity
Get
Return m_Activity
End Get
Set(ByVal value As MyActivity)
m_Activity = Value
End Set
End Property
Private m_Activity As MyActivity

Public Property Resource() As MyResource
Get
Return m_Resource
End Get
Set(ByVal value As MyResource)
m_Resource = Value
End Set
End Property
Private m_Resource As MyResource

Public Property Start() As DateTime
Get
Return m_Start
End Get
Set(ByVal value As DateTime)
m_Start = Value
End Set
End Property
Private m_Start As DateTime

Public Property [End]() As DateTime
Get
Return m_End
End Get
Set(ByVal value As DateTime)
m_End = Value
End Set
End Property
Private m_End As DateTime

Public Property Progress() As Double
Get
Return m_Progress
End Get
Set(ByVal value As Double)
m_Progress = Value
End Set
End Property
Private m_Progress As Double

End Class

3. Set up an ActivityChart and a ResourceChart in the main window

From Visual Studio Toolbox drag an ActivityChart and a ResourceChart controls and drop them to the main window area. Customize their properties and name them activityView and resourceView respectively. Next, layout the two charts in the root Grid on two rows. In order to bind the views to the custom created classes, their BindingExpression properties must be set with information pointing to the respective properties to be bound in the model classes. For example the ActivityNameExpression BindingExpression property should point to the Name property in the MyActivity class, the ResourceDescriptionExpression property should point to the Description property of the MyResource class. The complete generated XAML should look similar to the following:

XAML [image] Copy Code

<Window x:Class="Tutorial5.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:dataviews="http://mindfusion.eu/dataviews/wpf"
Title="Window1" WindowState="Maximized" Height="600" Width="800">
<Grid>
<Grid.RowDefinitions>
<RowDefinition />
<RowDefinition />
</Grid.RowDefinitions>

<dataviews:ActivityChart
Name="activityView" Grid.Row="0"

ActivityNameExpression="{Binding Name}"
ActivityStartTimeExpression="{Binding Start}"
ActivityEndTimeExpression="{Binding End}"
ActivityProgressExpression="{Binding Progress}"
ActivityChildrenExpression="{Binding Children}"

ResourceTitleExpression="{Binding Title}"
ResourceDescriptionExpression="{Binding Description}"

AllocationActivityExpression="{Binding Activity}"
AllocationResourceExpression="{Binding Resource}"
AllocationStartTimeExpression="{Binding Start}"
AllocationEndTimeExpression="{Binding End}"
AllocationProgressExpression="{Binding Progress}"/>

<dataviews:ResourceChart Name="resourceView" Grid.Row="1" />
</Grid>
</Window>

Note

If there will be two or more views that will share a single project, you need to define the binding expressions in only one of the views. As in the above example, these properties are set only for the ActivityChart instance.

4. Create the data

Create some data to be displayed in the views - activities, dependencies, resources and allocations. You can follow the patterns, shown in the previous tutorials, but this time use the newly created custom classes. As the MyActivity class defines a Children property and the chart views are able to display sets of data in hierarchical relationship (See TreeGrid), let's add some subactivities like this:

C# [image] Copy Code

MyActivity a2 = new MyActivity()
{
Start = a0.End,
End = a0.End.AddDays(3),
Progress = 1,
Name = "Task 2",
};

a2.Children.Add(new MyActivity() { Name = "SubTask 2.1", Start = a2.Start, End = a2.Start.AddDays(1), Progress = 1 });
a2.Children.Add(new MyActivity() { Name = "SubTask 2.2", Start = a2.Start.AddDays(1), End = a2.Start.AddDays(3), Progress = 1 });

myActivities.Add(a2);

Visual Basic [image] Copy Code

Dim a2 As New MyActivity() With { _
.Start = a0.[End], _
.[End] = a0.[End].AddDays(3), _
.Progress = 1, _
.Name = "Task 2" _
}

a2.Children.Add(New MyActivity() With { _
.Name = "SubTask 2.1", _
.Start = a2.Start, _
.[End] = a2.Start.AddDays(1), _
.Progress = 1 _
})

a2.Children.Add(New MyActivity() With { _
.Name = "SubTask 2.2", _
.Start = a2.Start.AddDays(1), _
.[End] = a2.Start.AddDays(3), _
.Progress = 1 _
})

myActivities.Add(a2)

5. Create the project and bind the views to the data

Create the IProjectViewModel by calling the CreateViewModel method. Pass the types of the custom classes as parameters to the method like this:

C# [image] Copy Code

project = activityView.CreateViewModel(myActivities, myDependencies, myResources, myAllocations, typeof(MyActivity), typeof(MyDependency), typeof(MyResource), typeof(MyAllocation));

Visual Basic [image] Copy Code

project = activityView.CreateViewModel(myActivities, myDependencies, myResources, myAllocations, GetType(MyActivity), GetType(MyDependency), GetType(MyResource), GetType(MyAllocation))

Now the project is created and bound to activityView.All is left to do is to associate the ResourceChart with it:

C# [image] Copy Code

resourceView.DataContext = project;

Visual Basic [image] Copy Code

resourceView.DataContext = project

Note

Please note that with this setup the Model will be updated by changes in the View, but the view won't get updated by direct changes to the Model. In order to support two-way data binding, the Model must implement the INotifyPropertyChanged interface and raise the PropertyChanged event when appropriate. For information how to do this, check this article [image] .

6. Build and run

Compile and run the application. The result will be similar to this image:

Note

You can find the complete source code of this tutorial in the product installation folder, under the folder for the appropriate .NET version and language.


MindFusion.Diagramming for WPF Tutorials

MindFusion.Diagramming for WPF Tutorials

The tutorials in this section assume you have already added a Diagram object to your WPF application as shown in the Getting Started topic. Visual Studio solutions that contain the full source code from the tutorials are available in the Samples folder under the MindFusion.Diagramming for WPF installation folder.


Tutorial 1: Loading Graph Data

Tutorial 1: Loading Graph Data

This tutorial shows how to load graph data from XML and create diagram objects corresponding to the graph nodes and edges.

1. Right-click the project in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleGraph.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Graph>
<Nodes>
<Node id="0" name="start" />
<Node id="1" name="activity 1" />
<Node id="2" name="task 1" />
<Node id="3" name="task 2" />
<Node id="4" name="activity 2" />
<Node id="5" name="task 3" />
<Node id="6" name="task 4" />
<Node id="7" name="activity 3" />
<Node id="8" name="task 5" />
<Node id="9" name="task 6" />
<Node id="10" name="end" />
</Nodes>
<Links>
<Link origin="0" target="1" />
<Link origin="1" target="2" />
<Link origin="1" target="3" />
<Link origin="2" target="4" />
<Link origin="3" target="4" />
<Link origin="4" target="5" />
<Link origin="4" target="6" />
<Link origin="5" target="10" />
<Link origin="6" target="10" />
<Link origin="0" target="7" />
<Link origin="7" target="8" />
<Link origin="8" target="9" />
<Link origin="1" target="9" />
<Link origin="9" target="10" />
</Links>
</Graph>

2. Set the file's "Build Action" property to "Content" and "Copy to Output Directory" to "Copy if newer".

3. Add a Loaded event handler to the WPF window:

Xaml [image] Copy Code

<Window ...
Loaded="OnWindowLoaded" ...>

C# [image] Copy Code

private void OnWindowLoaded(object sender, RoutedEventArgs e)
{
}

4. Add the following variables to the Loaded handler. "nodeMap" maps diagram nodes to their identifiers, and "bounds" contains the default node size.

C# [image] Copy Code

var nodeMap = new Dictionary<string, DiagramNode>();
var bounds = new Rect(0, 0, 60, 22);

5. Load the XML document and its root element using the Linq for XML API:

C# [image] Copy Code

// load the graph xml
var xml = XDocument.Load("SampleGraph.xml");
var graph = xml.Element("Graph");

6. Load the graph node elements and create their corresponding ShapeNode objects by calling the CreateShapeNode method of the Factory class. CreateShapeNode is just a shortcut to creating a ShapeNode instance using the "new" operator and adding it to the Nodes collection of the diagram. Additionally, this code maps the new node to the "id" attribute of the XML element, and sets the node's Text to the value of the "name" attribute.

C# [image] Copy Code

// load node data
var nodes = xml.Descendants("Node");
foreach (var node in nodes)
{
var diagramNode = diagram.Factory.CreateShapeNode(bounds);
nodeMap[node.Attribute("id").Value] = diagramNode;
diagramNode.Text = node.Attribute("name").Value;
}

7. Load the graph links and create corresponding DiagramLink objects. The Origin and Destination of the links are accessed by their ids through the "nodeMap" dictionary.

C# [image] Copy Code

// load link data
var links = xml.Descendants("Link");
foreach (var link in links)
{
diagram.Factory.CreateDiagramLink(
nodeMap[link.Attribute("origin").Value],
nodeMap[link.Attribute("target").Value]);
}

8. Arrange the diagram using the LayeredLayout class.

C# [image] Copy Code

// arrange the graph
var layout = new LayeredLayout();
layout.Arrange(diagram);

9. Build and run the project. If everything is fine, you should see this representation of the graph:


Tutorial 2: Loading Hierarchical Data

Tutorial 2: Loading Hierarchical Data

This tutorial shows how to load hierarchical data recursively from XML and create diagram items corresponding to the hierarchy.

1. Right-click the project in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleTree.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Project>
<Activity Name="Activity 1">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
<Activity Name="sub-activity 2-3" />
</Activity>
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
<Activity Name="Activity 2">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
</Activity>
</Activity>
<Activity Name="Activity 3">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
<Activity Name="sub-activity 1-4" />
</Activity>
<Activity Name="sub-activity 2" />
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
</Project>

2. Set the file's "Build Action" property to "Content" and "Copy to Output Directory" to "Copy if newer".

3. Add a Loaded event handler to the WPF window:

Xaml [image] Copy Code

<Window ...
Loaded="OnWindowLoaded" ...>

C# [image] Copy Code

private void OnWindowLoaded(object sender, RoutedEventArgs e)
{
}

4. Add the following member ot the window class to hold the default node size.

C# [image] Copy Code

Rect nodeBounds = new Rect(0, 0, 100, 22);

5. Create the tree root node, and call the CreateChildren method, which builds the tree recursively.

C# [image] Copy Code

var root = diagram.Factory.CreateShapeNode(nodeBounds);
root.Text = "Project";
var document = XDocument.Load("SampleTree.xml");
CreateChildren(root, document.Element("Project"));

6. Define CreateChildren as follows. It takes as parameters the parent DiagramNode and parent XML element, iterates the child XML elements to build the next level of the hierarchy, and creates corresponding diagram items by calling CreateShapeNode and CreateDiagramLink.

C# [image] Copy Code

private void CreateChildren(DiagramNode parentDiagNode, XElement parentXmlElement)
{
foreach (var element in parentXmlElement.Elements("Activity"))
{
var node = diagram.Factory.CreateShapeNode(nodeBounds);
node.Text = element.Attribute("Name").Value;
diagram.Factory.CreateDiagramLink(parentDiagNode, node);
CreateChildren(node, element);
}
}

7. Use TreeLayout to arrange the diagram. Add the following code to the end of the Loaded handler.

C# [image] Copy Code

var layout = new TreeLayout();
layout.Type = TreeLayoutType.Cascading;
layout.Direction = TreeLayoutDirections.LeftToRight;
layout.LinkStyle = TreeLayoutLinkType.Cascading2;
layout.NodeDistance = 5;
layout.LevelDistance = -25; // let horizontal positions overlap
layout.Arrange(diagram);

8. Build and run the project. If everything is fine, you should see this representation of the hierarchy:


Tutorial 3: Create a Custom Node Type

Tutorial 3: Create a Custom Node Type

This tutorial shows how to define a custom node class that inherits TemplatedNode and adds several new properties. Its appearance is defined using a WPF data template.

1. Right-click the project in Solution Explorer and choose Add -> New Item from the context menu. Create a new WPF Resource Dictionary file called generic.xaml and add the following control template to it. Note that Stroke, Brush and Text are properties of the base DiagramItem class. Image, Title and FullName are new properties defined in the custom class.

Xaml [image] Copy Code

<ResourceDictionary
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:local="clr-namespace:Tutorial3">

<Style TargetType="local:OrgChartNode">
<Setter Property="Template">
<Setter.Value>
<DataTemplate DataType="local:OrgChartNode">
<Grid>

<Rectangle
Stroke="{Binding Stroke}"
Fill="{Binding Brush}" />

<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="80" />
<ColumnDefinition Width="*" />
</Grid.ColumnDefinitions>

<Image
Source="{Binding Path=Image}"
HorizontalAlignment="Stretch"
VerticalAlignment="Stretch"
Stretch="Uniform">
</Image>

<StackPanel Margin="4,8,0,0" Orientation="Vertical" Grid.Column="1">
<TextBlock Text="{Binding Title}" FontWeight="800" />
<TextBlock Text="{Binding FullName}" Foreground="Blue" />
<TextBlock Text="{Binding Text}" FontSize="9" />
</StackPanel>
</Grid>

</Grid>
</DataTemplate>
</Setter.Value>
</Setter>
</Style>

</ResourceDictionary>

2. Add to the project a new class called OrgChartNode. Make it derive from TemplatedNode.

C# [image] Copy Code

using System.Windows;
using System.Windows.Media;
using MindFusion.Diagramming.Wpf;

namespace Tutorial3
{
public class OrgChartNode : TemplatedNode
{
}
}

3. Add a static constructor that overrides the DefaultStyleKey metadata to associate the node class with the data template defined in the resource dictionary. Note that "OrgChartNode" is set as TargetType for both the Style and DataTemplate elements in the Xaml.

C# [image] Copy Code

static OrgChartNode()
{
DefaultStyleKeyProperty.OverrideMetadata(
typeof(OrgChartNode), new FrameworkPropertyMetadata(typeof(OrgChartNode)));
}

4. Define the custom Title, FullName and Image dependency properties.

C# [image] Copy Code

public string Title
{
get { return (string)GetValue(TitleProperty); }
set { SetValue(TitleProperty, value); }
}

public static readonly DependencyProperty TitleProperty = DependencyProperty.Register(
"Title",
typeof(string),
typeof(OrgChartNode),
new PropertyMetadata(""));

public string FullName
{
get { return (string)GetValue(FullNameProperty); }
set { SetValue(FullNameProperty, value); }
}

public static readonly DependencyProperty FullNameProperty = DependencyProperty.Register(
"FullName",
typeof(string),
typeof(OrgChartNode),
new PropertyMetadata(""));

public ImageSource Image
{
get { return (ImageSource)GetValue(ImageProperty); }
set { SetValue(ImageProperty, value); }
}

public static readonly DependencyProperty ImageProperty = DependencyProperty.Register(
"Image",
typeof(ImageSource),
typeof(OrgChartNode),
new FrameworkPropertyMetadata(null, FrameworkPropertyMetadataOptions.AffectsRender));

5. Add a Loaded event handler to the WPF window.

Xaml [image] Copy Code

<Window ...
Loaded="OnWindowLoaded" ...>

C# [image] Copy Code

private void OnWindowLoaded(object sender, RoutedEventArgs e)
{
}

6. Add a few instances of the OrgChartNode class.

C# [image] Copy Code

var node1 = new OrgChartNode
{
Bounds = new Rect(100, 60, 240, 100),
Title = "CEO",
FullName = "John Smith",
Text = "Our beloved leader. \r\n" +
"The CEO of this great corporation.",
Image = new BitmapImage(
new Uri("016.png", UriKind.Relative))
};
diagram.Nodes.Add(node1);

var node2 = new OrgChartNode
{
Bounds = new Rect(220, 220, 240, 100),
Title = "CIO",
FullName = "Bob Smith",
Text = "The CIO of this great corporation.",
Image = new BitmapImage(
new Uri("ac0026-64.png", UriKind.Relative))
};
diagram.Nodes.Add(node2);

diagram.Factory.CreateDiagramLink(node1, node2);

7. Build and run the project. You should see the custom nodes rendered like this:


Tutorial 4: Custom Nodes Integration

Tutorial 4: Custom Nodes Integration

This tutorial builds upon the OrgChartNode type from Tutorial 3. It shows how to fully integrate the custom type with other MindFusion.Diagramming for WPF features, such as serialization, undo support, creating nodes by drag-and-drop or drawing with the mouse on the canvas.

1. Add a NodeListView to the page and add a few OrgChartNode objects as its children:

Xaml [image] Copy Code

<Grid.Resources>
<ResourceDictionary>
<BitmapImage x:Key="img1" UriSource="016.png" />
<BitmapImage x:Key="img2" UriSource="ac0026-64.png" />
</ResourceDictionary>
</Grid.Resources>

<diag:NodeListView Width="150">
<t:OrgChartNode
Bounds="0,0,140,70"
Title="CEO" FullName="Type here"
Text="Chief executive officer"
Image="{StaticResource img1}"
/>
<t:OrgChartNode
Bounds="0,0,140,70"
Title="CIO" FullName="Type here"
Text="Chief information officer"
Image="{StaticResource img2}"
/>
</diag:NodeListView>

2. Add a copy constructor to the OrgChartNode class. The control throws an exception if you try to create via drag-and-drop an instance of a class without copy constructor:

C# [image] Copy Code

// Required for creating nodes by dragging them from the NodeListView
public OrgChartNode(OrgChartNode prototype) : base(prototype)
{
Title = prototype.Title;
FullName = prototype.FullName;
Image = prototype.Image;
}

3. In order to enable drawing OrgChartNodes with the mouse, inherit the LinkNodesBehavior and override its CreateNode method. You could also inherit BehaviorBase or any of its derived classes, and override either CreateNode or StartDraw:

C# [image] Copy Code

public class OrgChartBehavior : LinkNodesBehavior
{
public OrgChartBehavior(Diagram diagram) : base(diagram) { }

protected override DiagramNode CreateNode()
{
return new OrgChartNode();
}
}

4. Assign an instance of the behavior class to the CustomBehavior property of the Diagram class:

C# [image] Copy Code

private void Window_Loaded(object sender, RoutedEventArgs e)
{
// enable drawing OrgChartNodes with the mouse
diagram.CustomBehavior = new OrgChartBehavior(diagram);
}

5. To implement serialization of any new properties added by a custom item class, override the SaveToXml and LoadFromXml methods of the base DiagramItem class:

C# [image] Copy Code

// serialization support for custom properties

protected override void SaveToXml(XmlElement xmlElement, XmlPersistContext context)
{
base.SaveToXml(xmlElement, context);
context.WriteString(Title, "Title", xmlElement);
context.WriteString(FullName, "FullName", xmlElement);
context.WriteImage(Image, "Image", xmlElement);
}

protected override void LoadFromXml(XmlElement xmlElement, XmlPersistContext context)
{
base.LoadFromXml(xmlElement, context);
Title = context.ReadString("Title", xmlElement);
FullName = context.ReadString("FullName", xmlElement);
Image = context.ReadImage("Image", xmlElement);
}

6. Call the static RegisterItemClass method to assign an XML element name to the custom item type:

C# [image] Copy Code

private void Window_Loaded(object sender, RoutedEventArgs e)
{
// enable serialization of the custom class
Diagram.RegisterItemClass(typeof(OrgChartNode), "my:OrgChartNode", 1);

// enable drawing OrgChartNodes with the mouse
diagram.CustomBehavior = new OrgChartBehavior(diagram);
}

7. In order to enable undo / redo of changes done on OrgChartNode, create a DiagramItemProperties -derived class that contains member corresponding to the additional properties defined by OrgChartNode:

C# [image] Copy Code

public class OrgChartNodeProperties : DiagramNodeProperties
{
internal string Title;
internal string FullName;
internal ImageSource Image;
}

8. Override the CreateProperties, SaveProperties and RestoreProperties methods:

C# [image] Copy Code

// undo and redo support

protected override DiagramItemProperties CreateProperties()
{
return new OrgChartNodeProperties();
}

protected override void SaveProperties(DiagramItemProperties props)
{
base.SaveProperties(props);

var state = (OrgChartNodeProperties)props;
state.Title = Title;
state.FullName = FullName;
state.Image = Image;
}

protected override void RestoreProperties(DiagramItemProperties props)
{
base.RestoreProperties(props);

var state = (OrgChartNodeProperties)props;
Title = state.Title;
FullName = state.FullName;
Image = state.Image;
}

9. The full source code for this tutorial with several additional UI controls that invoke serialization and undo methods is available in the Samples\CSharp\Tutorial4 subfolder under the MindFusion.Diagramming for WPF installation folder.


MindFusion.Reporting for WPF Tutorials

MindFusion.Reporting for WPF Tutorials


Tutorial 1: Getting Started

Tutorial 1: Getting Started

This tutorial will help you create a very simple data-bound report from scratch. The following steps are explained in more details below:

  • Creating a new project
  • Adding a MindFusion report to the project
  • Adding a data source to the project
  • Instantiating the report
  • Adding the data source to the MindFusion report
  • Creating a data-bound DataRange
  • Displaying the report
  • Running the application

1. Creating a new project

From MS Visual Studio select the File -> New -> Project menu command in order to create a new project.

In the dialog box that appears, select the project language and type. Select the desired programming language, then pick the 'Windows' category and select 'WPF Application' from the list to the right. Type the name and the location of the project in the text boxes at the bottom of the dialog, then click 'OK'. This tutorial uses 'Tutorial1' as a name of the project.

2. Adding a MindFusion report to the project

For the purposes of this tutorial we will create the new report as a resource in a separate resource dictionary. To add a new dictionary to the project, select 'Project -> Add New Item...' menu command.

In the dialog box that appears, select the 'Resource Dictionary (WPF)' item in the list, then type the name of the dictionary file in the text box at the bottom of the dialog ('MyReport.xaml' for the purposes of this tutorial) and click 'Add'. If the 'Resource Dictionary (WPF)' item is not visible in the list to the right, select 'WPF' in the tree to the left first.

A new empty resource dictionary is added to the project. Before we can create the report in the dictionary, we need to add a reference to the MindFusion.Reporting.Wpf.dll assembly to the project. To do this, locate to the 'References' item in the Solution Explorer, right-click on it, then select 'Add Reference...' from the context menu. In the 'Add Reference' dialog box that appears, select 'Browse' then navigate to the MindFusion.Reporting.Wpf.dll file and click 'OK'.

Now that the reference to the reporting assembly is added to the project we can create our report. Modify the definition of the newly added resource dictionary definition to include the reporting XML namespace as illustrated below:

XAML [image] Copy Code

<ResourceDictionary xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:r="http://mindfusion.eu/reporting/wpf">

</ResourceDictionary>

Then add the following code to the dictionary:

XAML [image] Copy Code

<r:Report x:Key="myReport">
<r:Page>

</r:Page>
</r:Report>

The code above declares a new empty report with a single page in it.

3. Adding a data source to the project

Select the 'Add New Data Source...' command from the 'Data' menu in MS Visual Studio. This will display the 'Data Source Configuration Wizard', which will automate the process of adding a new data source to your application.

Follow the instructions in the wizard that appears in order to create a new data source. On the first step of the wizard select the type of the data source ('Database' in this particular sample), then click 'Next'.

In the next step of the wizard, set up the database connection.

- Click on the 'New Connection' button and enter the information required to describe the connection in the 'Add Connection' dialog box that appears. This tutorial uses the nwind.mdb file supplied with the project installation as its data source. For this purpose, select 'Microsoft Access Database File (OLE DB)' as a data adapter and enter the path to the nwind.mdb file as a database file name.

- Click 'OK' to close the 'Add Connection' dialog box, then click 'Next' to move to the next step of the wizard. The MS Visual Studio will ask you whether you want to copy the mdb file to your project directory and modify the connection string to reflect this. Select 'Yes'.

On the following step save the connection under the default name 'nwindConnectionString', then click 'Next'.

Select the database objects you want to import in the project.

Expand the 'Tables' node and select the 'Products' table by placing a check in the box to its left. Type the name of the imported dataset in the text box at the bottom of the dialog (this tutorial uses the default - nwindDataSet), then click 'Finish'.

4. Instantiating the report

The FromDictionary method of the Report class facilitates report loading from resource dictionaries. The following code illustrates how to load the report myReport from the MyReport.xaml resource dictionary.

C# [image] Copy Code

Report myReport = Report.FromDictionary(new Uri(@"MyReport.xaml", UriKind.Relative), "myReport");

Visual Basic [image] Copy Code

Dim myReport As Report = Report.FromDictionary(New Uri("MyReport.xaml", UriKind.Relative), "myReport")

Paste this code in the constructor of the main application window - Window1, right after the call to InitializeComponent.

5. Associating the data source with the MindFusion report

The data source is supplied to the report through its DataContext property. This is done manually through code.

The first step is to load the data using the objects created automatically by the Data Source Configuration Wizard in one of the previous steps. Here is the code illustrating how to load the data from the Products table using a TableAdapter:

C# [image] Copy Code

nwindDataSet dataset = new nwindDataSet();
Tutorial1.nwindDataSetTableAdapters.ProductsTableAdapter adapter =
new Tutorial1.nwindDataSetTableAdapters.ProductsTableAdapter();
adapter.Fill(dataset.Products);

Visual Basic [image] Copy Code

Dim dataset = New nwindDataSet()
Dim adapter As New Tutorial1.nwindDataSetTableAdapters.ProductsTableAdapter()
adapter.Fill(dataset.Products)

To associate the data source with the report, simply assign it to the DataContext property.

C# [image] Copy Code

myReport.DataContext = dataset;

Visual Basic [image] Copy Code

myReport.DataContext = dataset

6. Creating a data-bound DataRange

In order to display the data from the associated data source, we need to modify our report by adding a DataRange object to it. The following XAML code illustrates how:

XAML [image] Copy Code

<r:Report x:Key="myReport">
<r:Page>
<r:DataRange Location="0,20" Size="100%,20" DataSource="{Binding Products}">
<r:DataRange.HeaderTemplate>
<DataTemplate>
<r:ItemContainer Size="100%,20">
<r:Label Text="ProductID" Location="0%,0" Size="20%,20" />
<r:Label Text="ProductName" Location="20%,0" Size="20%,20" />
<r:Label Text="QuantityPerUnit" Location="40%,0" Size="20%,20" />
<r:Label Text="UnitPrice" Location="60%,0" Size="20%,20" />
<r:Label Text="UnitsInStock" Location="80%,0" Size="20%,20" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.HeaderTemplate>
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Text="{Binding ProductID}" Location="0%,0" Size="20%,20" />
<r:Label Text="{Binding ProductName}" Location="20%,0" Size="20%,20" />
<r:Label Text="{Binding QuantityPerUnit}" Location="40%,0" Size="20%,20" />
<r:Label Text="{Binding UnitPrice}" Location="60%,0" Size="20%,20" />
<r:Label Text="{Binding UnitsInStock}" Location="80%,0" Size="20%,20" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
</r:Page>
</r:Report>

7. Displaying the report

Now that our report is instantiated and its data source has been assigned, we can display it on the main application window. Open the window in the VS designer by double-clicking on the Window1.xaml file in the Solution Explorer.

Open the Toolbox, locate the DocumentViewer item (usually under the Controls tab) and create a new DocumentViewer on the window by double-clicking on the DocumentViewer item in the Toolbox.

Go back to the code behind and add the following code in the window's constructor after the report's data source assignment:

C# [image] Copy Code

myReport.Run();

ReportLayout layout = myReport.Layout(new Size(8.5 * 96, 11 * 96),
new Thickness(0.5 * 96), PageOrientation.Portrait);

FixedDocumentRenderTarget renderTarget = new FixedDocumentRenderTarget();
layout.RenderAllPages(renderTarget);

documentViewer1.Document = renderTarget.Document;

Visual Basic [image] Copy Code

myReport.Run()

Dim layout = myReport.Layout(New Size(8.5 * 96, 11 * 96), _
New Thickness(0.5 * 96), PageOrientation.Portrait)

Dim renderTarget As New FixedDocumentRenderTarget()
layout.RenderAllPages(renderTarget)

documentViewer1.Document = renderTarget.Document

The code above processes the report and lays it out on A4 paper. The report is then rendered to a FixedDocument using a FixedDocumentRenderTarget object. Finally the FixedDocument is assigned to the Document property of the newly created DocumentViewer in order to display the rendering result in the window. To learn more about these operations, check the Running, Laying Out and Rendering and Displaying Reports in a DocumentViewer topics.

8. Running the application

The application is ready. Compile and run to see the result. After expanding the main application form, it should look similar to the following:

Click the 'Print' button in the viewer's toolbar to print the report.


Tutorial 2: Binding to a Data Source

Tutorial 2: Binding to a Data Source

This tutorial will demonstrate how to create and bind DataRange objects manually and how to create master-detail relationship between data-ranges representing related tables. The following steps are explained in more details below:

  • Prerequisites
  • Adding a new data adapter
  • Nesting DataRange objects for master-detail implementation
  • Providing details in a master-detail relationship
  • Running the application

Prerequisites

This tutorial continues from where Tutorial 1: Getting Started has ended. It is therefore assumed that we have an existing application with a single data-bound report in it and a window with a set up DocumentViewer that displays an instance of this report.

1. Adding a new data adapter

Now that we have an existing data set and an adapter for the 'Products' table, we will expand this data source by creating an adapter for the 'Categories' table.

To do this, go to the 'Data Sources' window, select the 'nwindDataSet' and click the 'Configure DataSet with Wizard' button from the 'Data Sources' window toolbar. This will bring up the 'Data Source Configuration Wizard' that we used in Tutorial 1 in order to setup the data source initially.

Note

To open the 'Data Sources' window, select the Data -> Show Data Sources menu command.

Expand the 'Tables' node and select the 'Categories' table by placing a check in the box to its left. Click 'Finish' to create a new table adapter for the selected table.

2. Nesting DataRange objects for master-detail implementation

We create a new DataRange object within the report's existing XAML declaration in a way similar to the one used in Tutorial 1. The new DataRange object is bound to the Categories data table and contains two elements - a Label and a Picture, bound respectively to the CategoryName and Picture fields in the Categories table. The XAML code below illustrates the code of the new DataRange object.

XAML [image] Copy Code

...
<r:DataRange Location="0,0" Size="100%,150" DataSource="{Binding Categories}">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Location="10,10" Size="190,20" Text="{Binding CategoryName}" />
<r:Picture Location="60%,10" Size="38%,135" Image="{Binding Picture}" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
...

Now we want to embed the old DataRange, showing products, within the newly created DataRange, showing categories and we want to establish a master-detail relationship between the two data ranges so that the result displays products, grouped by category. Here is the new XAML code of the report illustrating the embedded data ranges.

XAML [image] Copy Code

<r:Report x:Key="myReport">
<r:Page>
<r:DataRange Location="0,0" Size="100%,150" DataSource="{Binding Categories}">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Location="10,10" Size="190,20" Text="{Binding CategoryName}" />
<r:Picture Location="60%,10" Size="38%,135" Image="{Binding Picture}" />

<r:DataRange Location="0,75" Size="60%,20" Name="ProductsRange">
<r:DataRange.HeaderTemplate>
<DataTemplate>
<r:ItemContainer Size="100%,20">
<r:Label Text="ProductID" Location="0%,0" Size="20%,20" />
<r:Label Text="ProductName" Location="20%,0" Size="20%,20" />
<r:Label Text="QuantityPerUnit" Location="40%,0" Size="20%,20" />
<r:Label Text="UnitPrice" Location="60%,0" Size="20%,20" />
<r:Label Text="UnitsInStock" Location="80%,0" Size="20%,20" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.HeaderTemplate>
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Text="{Binding ProductID}" Location="0%,0" Size="20%,20" />
<r:Label Text="{Binding ProductName}" Location="20%,0" Size="20%,20" />
<r:Label Text="{Binding QuantityPerUnit}" Location="40%,0" Size="20%,20" />
<r:Label Text="{Binding UnitPrice}" Location="60%,0" Size="20%,20" />
<r:Label Text="{Binding UnitsInStock}" Location="80%,0" Size="20%,20" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>

</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
</r:Page>
</r:Report>

Note that the old DataRange (the one showing products) has had its data source removed. We will supply the data through the QueryDetails event depending on the category each instance of this DataRange belongs to. Note also that the products range now has a name associated with it. This will help us identify the range within the QueryDetails event handler as illustrated later in this topic. Finally, note that the Location of the embedded DataRange has been modified so that it is positioned correctly in its parent and its size is reduced to 60% so that it doesn't overlap with the image to the right.

Navigate to the window's constructor in the code behind and add the code necessary to populate the Categories table in the data set. Additionally, expose the existing adapter variable as a class field because it will be needed in the QueryDetails event handler. The following code (in bold) demonstrates this.

C# [image] Copy Code

...
nwindDataSet dataset = new nwindDataSet();
adapter = new Tutorial2.nwindDataSetTableAdapters.ProductsTableAdapter();
adapter.Fill(dataset.Products);
Tutorial2.nwindDataSetTableAdapters.CategoriesTableAdapter categoriesAdapter =
new Tutorial2.nwindDataSetTableAdapters.CategoriesTableAdapter();
categoriesAdapter.Fill(dataset.Categories);

myReport.DataContext = dataset;
...

private Tutorial2.nwindDataSetTableAdapters.ProductsTableAdapter adapter;

Visual Basic [image] Copy Code

...
Dim dataset As New nwindDataSet()
adapter = New Tutorial2.nwindDataSetTableAdapters.ProductsTableAdapter()
adapter.Fill(dataset.Products)
Dim categoriesAdapter As New Tutorial2.nwindDataSetTableAdapters.CategoriesTableAdapter()
categoriesAdapter.Fill(dataset.Categories)

myReport.DataContext = dataset
...

Private adapter As Tutorial2.nwindDataSetTableAdapters.ProductsTableAdapter

3. Providing details in a master-detail relationship

To provide a master-detail implementation for the two data ranges, we need to handle the QueryDetails event on the Report class. Keep in mind that the event must be handled before the Run method of the Report is invoked. The following code illustrates how the event handler should look.

C# [image] Copy Code

void myReport_QueryDetails(object sender, QueryDetailsEventArgs e)
{
DataRange dataRange = sender as DataRange;
if (dataRange != null)
{
if (dataRange.Name == "ProductsRange")
{
Tutorial2.nwindDataSet.CategoriesRow categoryRow = e.MasterRow as Tutorial2.nwindDataSet.CategoriesRow;

e.Details = adapter.GetData().Where(
product => product.CategoryID == categoryRow.CategoryID);
}
}
}

Visual Basic [image] Copy Code

Sub myReport_QueryDetails(ByVal sender As Object, ByVal e As QueryDetailsEventArgs)

Dim dataRange As DataRange = sender
If (Not dataRange Is Nothing) Then

If (dataRange.Name = "ProductsRange") Then

Dim categoryRow As Tutorial2.nwindDataSet.CategoriesRow = e.MasterRow

e.Details = From product In adapter.GetData() _
Where (product.CategoryID = categoryRow.CategoryID)

End If

End If

End Sub

The code above inspects the report element, which requests details. This is usually a DataRange or a PieChart object. Then, it identifies the object by inspecting its Name. If the object is the one we are expecting, we provide the necessary details by matching the CategoryID of the products in the database against the ID of the category associated with the data range.

Note

Do not forget to include the System.Linq namespace in order the above code to compile successfully.

4. Running the application

Running the application will yield a result similar to the one illustrated by the following image:


Tutorial 3: Customizing the Report

Tutorial 3: Customizing the Report

This tutorial illustrates how to adjust various settings of a report in order to customize its appearance. The following steps are explained in more details below:

  • Prerequisites
  • Adding report header and footer
  • Customizing background colors
  • Customizing borders
  • Customizing fonts
  • Additional customizations

Prerequisites

This tutorial continues from where Tutorial 2: Binding to a Data Source has ended. It is therefore assumed that the reader is acquainted with Tutorial 1 and Tutorial 2 before reading further.

1. Adding report header and footer

Headers and footers can be added to the report through the HeaderTemplate and FooterTemplate properties of the Page class. These properties specify a DataTemplate which is instantiated once for each page in the final report. The root element of the DataTemplate is expected to be of type ItemContainer. The following XAML code illustrates how to add a footer to the current report, which displays the current page and the total number of pages:

XAML [image] Copy Code

<r:Report x:Key="myReport">
<r:Page>

<!-- Page content -->
...

<r:Page.FooterTemplate>
<DataTemplate>
<r:ItemContainer Size="100%,30">
<r:Label Size="100%,30" Text="[PageCurrent()] of [PageCount()]" HorizontalAlignment="Center" VerticalAlignment="Center" />
</r:ItemContainer>
</DataTemplate>
</r:Page.FooterTemplate>

</r:Page>
</r:Report>

The width component of the size of headers and footers is ignored - their width is always the same as the width of the element they belong to. In the code above the width is set to 100% for clarity. The height of the footer in the above case is set to 30 (device independent pixels as no unit is specified explicitly). The footer contains a single Label, which displays the current page and the total number of pages in the report. This is achieved through the use of an expression. To learn more about expressions, check the Overview topic. To learn more on how to use expressions in label texts, check Using Expressions in Label Texts.

If you run the application now, you will notice a small text at the bottom of each page specifying the current page and the total number of pages in the report.

2. Customizing background colors

Many report elements allow their background color to be changed. The page header/footer and the page itself allow this too. In this tutorial we will set the background of the footer, created in the previous step, to Gainsboro. To do this, simply assign "Gainsboro" to the Background of the item container, representing the footer. The following XAML code illustrates this, the new coded is highlighted:

XAML [image] Copy Code

<r:ItemContainer Size="100%,30" Background="Gainsboro">

Additionally, we will customize the background of the alternating rows of the embedded data range. To do this, set the AlternatingBackground property of the DataRange to PaleGoldenrod the same way we set the brush of the footer above. Finally, set the background of the embedded data range's header to LightSteelBlue.

Running the application will yield the following result:

3. Customizing borders

Many report elements allow their border to be customized. In this tutorial we will set the border of the outer data range. To do this, simply set the BorderBrush and BorderThickness properties of the parent DataRange to the appropriate values. In this particular case we will set those to #A0A8B0 and 1 respectively. The following XAML code illustrates the modified code:

XAML [image] Copy Code

...
<r:DataRange Location="0,0" Size="100%,150" DataSource="{Binding Categories}" BorderBrush="#A0A8B0" BorderThickness="1">
...

4. Customizing fonts

The font in MindFusion.Reporting for WPF is governed by a set of properties - FontFamily, FontSize, FontStyle and FontWeight. These properties are attached and inherit through the report hierarchy, which means that specifying any of them on a parent element will automatically propagate the value to all children of this element which do not have an explicitly specified value for this particular property. For example, to change the font family of all elements in the report, simply set the FontFamily property on the Report element. To change the value of an individual label, set the FontFamily property on that label.

In this tutorial we will change the font of the report to ensure that all texts fit in their corresponding elements. Set the FontFamily to "Arial" and FontSize to "8" as illustrated by the XAML code below:

XAML [image] Copy Code

<r:Report x:Key="myReport" FontFamily="Arial" FontSize="8">
...

5. Additional customizations

Running the report now reveals some minor flaws that we might want to get fixed. For example, the instances of the outer data range appear to be adjoined to each other because of the border we applied to the data range earlier. To insert some spacing between adjacent instances, set the Bottom component of the Margin property of the outer data range to, say, "5".

We may further improve the report by preventing the data range instances to split accross pages. In order to do this, set the CanOverflow property of the ItemContainer representing the item template of the outer data range to false.

Running the application now and setting the viewer to display two pages at once will result in the following:


Tutorial 4: Using Charts in Reports

Tutorial 4: Using Charts in Reports

This tutorial extends Tutorial 1: Getting Started by adding a pie chart to the report. The following steps are illustrated in more details:

  • Prerequisites
  • Adding a pie chart to the report
  • Binding the chart
  • Providing pie data using a query

Prerequisites

As mentioned above this tutorial extends Tutorial 1. Therefore it is expected that the reader has finished with Tutorial 1 before reading further.

1. Adding a pie chart to the report

The PieChart is another type of report element, just like Label and Picture. To add a chart to the report, simply add it to a page (or another container). Once the chart is added to the report, we have to position and resize the chart. This particular chart will hold quite a few pieces, so we will make it big enough. Set the Location of the chart to "225,0" and its Size to "250,250". Adjust the Location of the existing data range so that it does not overlap with the newly added chart. Set it to "0,300". Set some additional visualization properties - set PieBrush to "Blue", PieStroke to "Black" and PieStrokeThickness to "1".

Here is how the Report will look like after these modifications:

XAML [image] Copy Code

...
<r:PieChart Location="225,0" Size="250,250" PieBrush="Blue" PieStroke="Black" PieStrokeThickness="1" />
<r:DataRange Location="0,300" Size="100%,20" DataSource="{Binding Products}">
...

2. Binding the chart

To provide data for the chart, set its DataSource property. In this particular case, bind the DataSource to the Products table ("{Binding Products}") and set the TargetMember property to the name of the field, which will supply values for the chart - in this case "UnitPrice".

Running the application will have the following result:

3. Providing pie data using a query

As is observed from the illustration above, the chart pies are very small due to the large amount of products displayed. One way to resolve this problem is to filter the data displayed on the chart according to some criteria. To do this we need to create a custom query and a new data adapter in our data set.

Navigate to the nwindDataSet.xsd file in the Solution Explorer window and double-click on it to open the data sat diagram in the environment. Right-click on an empty area in the diagram designer and select the 'Add -> TableAdapter...' command from the context menu.

A new table adapter is created in the data set and the TableAdapter Configuration Wizard is displayed. Ensure that the appropriate connection is selected in the combo box and click 'Next'. On the 'Choose a Command Type' step leave 'Use SQL statements' as selected and click 'Next'. The 'Enter a SQL Statement' step appears.

We have to enter the text of our SQL query in the next step. There are several ways to improve the query creation experience, but we will use a ready-made query text that selects only the products with price less than 20 and sorts them in ascending order.

SQL [image] Copy Code

SELECT ProductName, UnitPrice
FROM Products
WHERE (UnitPrice < 20)
ORDER BY UnitPrice

Click the 'Advanced Options...' and uncheck the 'Generate Insert, Update and Delete statements' check box. Click 'OK' to close the 'Advanced Options' dialog box, then click 'Finish'. The table adapter representing our query is now properly initialized and appears on the diagram.

Select the data table representing the newly created query and press F2 to rename it. Replace "Products1" with "CheapProducts" then press ENTER. Rename the associated adapter to "CheapProductsTableAdapter". Save the data set and close it.

Go back to the report declaration and change the binding of the pie chart from Products to CheapProducts, then navigate to the window's constructor and add the following code for populating data from the data source using the newly created adapter:

C# [image] Copy Code

Tutorial4.nwindDataSetTableAdapters.CheapProductsTableAdapter cheapProductsAdapter =
new Tutorial4.nwindDataSetTableAdapters.CheapProductsTableAdapter();
cheapProductsAdapter.Fill(dataset.CheapProducts);

Visual Basic [image] Copy Code

Dim cheapProductsAdapter As New Tutorial4.nwindDataSetTableAdapters.CheapProductsTableAdapter()
cheapProductsAdapter.Fill(dataset.CheapProducts)

Running the application will now display the filtered list of products as illustrated below:

Tutorial 5 demonstrates how to paint the chart pieces with different colors and how to custom render the corresponding items in the data range.


Tutorial 5: Custom Rendering

Tutorial 5: Custom Rendering

This tutorial illustrates how to specify multiple brushes for a PieChart as well as how to employ custom rendering in order to achieve particular effect. The following steps are explained in more details below:

  • Prerequisites
  • Defining the custom brushes
  • Setting the chart brushes
  • Custom-rendering DataRange entries

Prerequisites

This tutorial extends Tutorial 4. Therefore it is expected that the reader has finished with Tutorial 4 before reading further.

1. Defining the custom brushes

We define an array with brushes as a resource of the report itself. The array is defined in XAML using the x:Array extension. The code, which defines the brush array is highlighted in bold below:

XAML [image] Copy Code

<r:Report x:Key="myReport">
<r:Report.Resources>
<x:ArrayExtension Type="{x:Type Brush}" x:Key="PieBrushes">
<SolidColorBrush Color="#FFFF00" />
<SolidColorBrush Color="#FF0000" />
<SolidColorBrush Color="#2EAB57" />
<SolidColorBrush Color="#FF00FF" />
<SolidColorBrush Color="#808080" />
<SolidColorBrush Color="#1652B4" />
<SolidColorBrush Color="#800080" />
<SolidColorBrush Color="#00FF00" />
<SolidColorBrush Color="#FFA500" />
<SolidColorBrush Color="#20B2AA" />
<SolidColorBrush Color="#006400" />
<SolidColorBrush Color="#FFFFFF" />
<SolidColorBrush Color="#808000" />
</x:ArrayExtension>
</r:Report.Resources>
<r:Page>
...

2. Setting the chart brushes

Now that the brushes are defined they can be easily referenced as a static resource and assigned to the Brushes property of the PieChart. The following XAML illustrates the modified declaration of the PieChart element within the report definition:

XAML [image] Copy Code

<r:PieChart Location="225,0" Size="250,250" DataContext="{Binding CheapProducts}" TargetMember="UnitPrice" Brushes="{StaticResource PieBrushes}" PieStroke="Black" PieStrokeThickness="1" />

Running the report now will produce a colored pie chart. However it is not clear which products are represented by the chart pieces. To fix this, the background of the report entries can be modified to match the color of the corresponding pie chart pieces.

3. Custom-rendering DataRange entries

Custom rendering is performed by handling the Prerender event of the Report class. The following code illustrates handling of the event in C# and Visual Basic:

C# [image] Copy Code

myReport.Prerender += new EventHandler<PrerenderEventArgs>(myReport_Prerender);

VB.NET [image] Copy Code

AddHandler myReport.Prerender, AddressOf myReport_Prerender

The event can be handled at any point before the ReportLayout.RenderAllPages method is invoked. The event is raised for each individual item in the report after its visual representation is created but before it is added to the output. The rows in the DataRange are represented by ItemContainer objects. The DataContext property of each ItemContainer is set to the corresponding product row from the data set. The visual representation of the containers is specified through a WPF Border object. The custom-rendering code checks whether the current element is an ItemContainer and verifies if it corresponds to a "cheap product" by checking the UnitPrice field. If those conditions are at hand, the custom-rendering code sets the appropriate Brush to the background of the Border associated with the entry. The code of the event handler is listed below:

C# [image] Copy Code

private void myReport_Prerender(object sender, PrerenderEventArgs e)
{
if (e.Item is ItemContainer)
{
var row = e.Item.DataContext as nwindDataSet.ProductsRow;
if (row != null)
{
if (row.UnitPrice < 10)
{
int i = 0;
int index = -1;
foreach (nwindDataSet.CheapProductsRow cheapRow in dataset.CheapProducts)
{
if (cheapRow.ProductName == row.ProductName)
{
index = i;
break;
}

i++;
}

var border = e.RootVisual as Border;
border.BorderBrush = new SolidColorBrush(Colors.Red);
border.BorderThickness = new Thickness(1);
border.Background = brushes[index];
}
}
}
}

VB.NET [image] Copy Code

Private Sub myReport_Prerender(ByVal sender As Object, ByVal e As PrerenderEventArgs)

If (TypeOf e.Item Is ItemContainer) Then

If TypeOf e.Item.DataContext Is nwindDataSet.ProductsRow Then

Dim row = CType(e.Item.DataContext, nwindDataSet.ProductsRow)
If (row IsNot Nothing) Then

If (row.UnitPrice < 10) Then

Dim i As Integer = 0
Dim index As Integer = -1
For Each cheapRow As nwindDataSet.CheapProductsRow In dataset.CheapProducts

If (cheapRow.ProductName = row.ProductName) Then
index = i
Exit For
End If

i += 1

Next cheapRow

Dim border = CType(e.RootVisual, Border)
border.BorderBrush = New SolidColorBrush(Colors.Red)
border.BorderThickness = New Thickness(1)
border.Background = brushes(index)

End If

End If

End If

End If

End Sub

Running the report now and switching to two-page layout will bring the following result:


MindFusion.Scheduling for WPF Tutorials

MindFusion.Scheduling for WPF Tutorials


Tutorial 1: Getting Started

Tutorial 1: Getting Started

This tutorial will show you how to create a simple timetable application with MindFusion.Scheduling for WPF.

1. Create a new WPF application project

Select File -> New -> Project from the Visual Studio menu. In the dialog that appears, select Visual C# -> Windows from the tree on the left, then WPF Application from the list on the right. Type in the name (of your project the tutorial uses Tutorial1) and click 'OK'.

2. Add the Calendar control to the main window

Before using the Calendar control, it must be added it to the toolbox. Display the toolbox by selecting View -> Toolbox from the menu. Then select the appropriate category for the control and right-click on it. From the context menu choose 'Choose Items...'. In the "Customize Toolbox Items" dialog select the WPF Components tab and click the 'Browse...' button. Then navigate to the control assembly file - MindFusion.Scheduling.WPF.dll. This file is usually found in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WPF' folder or in the folder where you have installed the product. Once the dll is added to the list of components, click 'OK'. A Calendar item should appear in the selected category in the toolbox. Click on this item and drag it to the window's working area. This creates a new MindFusion.Scheduling for WPF Calendar control on the window.

3. Setting the control's properties

Select the newly created control and click View -> Properties Window from the menu. In the Properties window change the name of the control to 'calendar' and set Margin to 0. Change CurrentView to Timetable. The timetable view displays rows of cells corresponding to the time of the day, and the cells in each column correspond to a specific date. Change Theme to Silver.

The generated XAML code so far should look similar to the following:

XAML [image] Copy Code

<planner:Calendar Name="calendar" CurrentView="Timetable" Theme="Silver" />

In order to modify various view settings through the visual designer, create a new TimetableSettings object and assign it to the TimetableSettings property of the control. Set ShowCurrentTime to true. The code which does this is displayed below:

XAML [image] Copy Code

<planner:Calendar Name="calendar" CurrentView="Timetable" Theme="Silver">
<planner:Calendar.TimetableSettings>
<planner:TimetableSettings ShowCurrentTime="True" />
</planner:Calendar.TimetableSettings>
</planner:Calendar>

An alternative way to modify the settings of the view is through code. The code equivalent the above XAML is illustrated here:

C# [image] Copy Code

calendar.TimetableSettings.ShowCurrentTime = true;

Visual Basic [image] Copy Code

calendar.TimetableSettings.ShowCurrentTime = True

Note, that when the assignment is done in code, there is no need to create and assign a new TimetableSettings object.

4. Adding more days to the Timetable

Initially the timetable displays only one day - usually the day when the control was added to the form. To change the set of displayed days, you must add few lines of code. For that purpose, double-click on the window's title bar in the designer area. This switches to source code view and automatically creates an event handler for the window's Load event (named Window_Load). Add the following lines to the body of the event handler.

C# [image] Copy Code

calendar.BeginInit();
calendar.TimetableSettings.Dates.Clear();

for (int i = 0; i < 5; i++)
{
calendar.TimetableSettings.Dates.Add(
DateTime.Today + new TimeSpan(i, 0, 0, 0));
}

calendar.EndInit();

Visual Basic [image] Copy Code

calendar.BeginInit()
calendar.TimetableSettings.Dates.Clear()

Dim i As Integer
For i = 0 To 4

calendar.TimetableSettings.Dates.Add(DateTime.Today.AddDays(i))

Next i

calendar.EndInit()

The code above adds five days to the timetable view, starting from today.

The first and last methods called above are used together to enclose code, which contains series of modifications to the calendar. BeginInit disables the internal update logic of the control, while EndInit resumes the control's normal behavior and updates its internal state to reflect all changes made since the call to BeginInit.

5. Build and run

Compile and run the application. The result should look similar to the image below.


Tutorial 2: Creating Recurrent Items

Tutorial 2: Creating Recurrent Items

This tutorial shows how to programmatically create recurring items using MindFusion.Scheduling for WPF.

1. Create and initialize a new WPF application project

Follow steps 1 through 3 from the previous tutorial.

Set CurrentView to WeekRange, Date to Jan 1, 2010 and EndDate to Mar 1, 2010, respectively. Increase the size of the window to, say, 600x500.

2. Create an appointment

Create a new appointment in the handler of the window's Load event. To create the appointment, add the following lines of code to the body of the event handler.

Note

Be sure to include both MindFusion.Scheduling and MindFusion.Scheduling.Wpf namespaces via the using (Imports in Visual Basic) keyword in the beginning of the file.

C# [image] Copy Code

Appointment app = new Appointment();
app.HeaderText = "Meet George";
app.DescriptionText = "This is a sample appointment";
app.StartTime = new DateTime(2010, 1, 10, 14, 0, 0);
app.EndTime = new DateTime(2010, 1, 10, 16, 30, 0);

calendar.Schedule.Items.Add(app);

Visual Basic [image] Copy Code

Dim app As New Appointment()
app.HeaderText = "Meet George"
app.DescriptionText = "This is a sample appointment"
app.StartTime = new DateTime(2010, 1, 10, 14, 0, 0)
app.EndTime = new DateTime(2010, 1, 10, 16, 30, 0)

calendar.Schedule.Items.Add(app)

The code above creates a new appointment on 10th of January, 2010, starting at 2:00 PM and ending at 4:30 PM.

3. Create the recurrence

Now that the appointment is added to the schedule, create a Recurrence object that defines how the appointment recurs. The following code creates and initializes a new Recurrence object and associates it with the item. Append these lines to the window's Load event handler.

C# [image] Copy Code

Recurrence rec = new Recurrence();
rec.Pattern = RecurrencePattern.Weekly;
rec.DaysOfWeek = DaysOfWeek.Monday | DaysOfWeek.Wednesday;
rec.Weeks = 2;
rec.StartDate = new DateTime(2010, 1, 10);
rec.RecurrenceEnd = RecurrenceEnd.Never;

app.Recurrence = rec;

Visual Basic [image] Copy Code

Dim rec As New Recurrence()
rec.Pattern = RecurrencePattern.Weekly
rec.DaysOfWeek = DaysOfWeek.Monday + DaysOfWeek.Wednesday
rec.Weeks = 2
rec.StartDate = new DateTime(2010, 1, 10)
rec.RecurrenceEnd = RecurrenceEnd.Never

app.Recurrence = rec

This fragment creates a new recurrence object that continues infinitely and repeats the appointment on Monday and Wednesday every two weeks.

4. Build and run

Compile and run the application. The image below depicts what the application output would look like.


Tutorial 3: Using the Standard Forms

Tutorial 3: Using the Standard Forms

This tutorial shows how to use the standard MindFusion.Scheduling for WPF dialogs to edit appointments in the calendar. This tutorial extends the application created in the previous tutorial so if you haven't done it already, complete Tutorial 2: Creating Recurrent Items first.

1. Add a reference to the dialogs assembly

In order to use the stock forms that come with MindFusion.Scheduling for WPF, add a reference to the assembly that contains them. To do so, open the Solution Explorer by selecting View -> Solution Explorer from the Visual Studio menu, then right-click on the 'References' item and select 'Add Reference' from the context menu. In the dialog that appears, navigate to the MindFusion.Scheduling.Wpf.StandardForms.dll file and click 'OK'. The file is usually located in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WPF' folder or in the folder where you have installed the product.

Note

In Visual Basic projects check the 'Show All Files' button in the Solution Explorer toolbar in order for the References project item to appear.

2. Handling the ItemClick event

The appointment form is usually displayed in response to double-clicking the appointment. Switch to design view, select the control and in the Properties window click the 'Events' button located in the toolbar near the top of the window. Navigate to the ItemClick event in the event list and double-click it. This automatically creates an event handler for the event (with default name calendar_ItemClick) and places the input cursor at its beginning.

3. Display the form

To display the form add the following code to the body of the event handler just created.

Note

Be sure to include both MindFusion.Scheduling and MindFusion.Scheduling.Wpf namespaces via the using (Imports in Visual Basic) keyword in the beginning of the file.

C# [image] Copy Code

// Display the form only if left mouse button is double-clicked
if (e.LeftButton != MouseButtonState.Pressed || e.Clicks != 2)
return;

calendar.ResetDrag();

// Create the form
AppointmentForm form = new AppointmentForm(calendar.Schedule);
form.Title = e.Item.HeaderText;
form.SetAppointment(e.Item as Appointment);

// Display the form to the user
form.ShowDialog();

Visual Basic [image] Copy Code

' Display the form only if left mouse button is double-clicked
If e.LeftButton <> MouseButtonState.Pressed Or e.Clicks <> 2 Then Return

calendar.ResetDrag()

' Create the form
Dim form As New AppointmentForm(calendar.Schedule)
form.Title = e.Item.HeaderText
form.SetAppointment(CType(e.Item, Appointment))

' Display the form to the user
form.ShowDialog()

The form automatically updates the edited item with all modifications made by the user.

4. Build and run

Compile and run the application. Create an appointment by typing and then double-click it to display the appointment dialog.


Tutorial 4: Creating Custom Appointment Classes

Tutorial 4: Creating Custom Appointment Classes

This tutorial shows how to create a custom schedule item class. For simplicity, the sample demonstrates that by inheriting a class from Appointment.

1. Create and initialize a new WPF application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

2. Create new class for the custom item

Select Project -> Add Class... from the menu, type the name of the custom item class in the dialog that appears (for example MyApp) and click 'OK'. Include the MindFusion.Scheduling namespace at the beginning of the file.

C# [image] Copy Code

using MindFusion.Scheduling;

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling

The custom class will expose a new property of type Boolean (called Kept) that will indicate whether the appointment has been kept or cancelled. The implementation of the property is trivial. Simply add a private field of type Boolean and make the property getter setter to return the field and to set the field respectively. The following sample code illustrates this:

C# [image] Copy Code

public class MyApp : Appointment
{
public MyApp()
{
_kept = true;
}

public bool Kept
{
get { return _kept; }
set { _kept = value; }
}

private bool _kept;
}

Visual Basic [image] Copy Code

Class MyApp
Inherits Appointment

Public Sub New()

_kept = True

End Sub

Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)
_kept = Value
End Set

End Property

Private _kept As Boolean

End Class

Note

You must provide constructor that takes no argument with your custom item class. MindFusion.Scheduling for WPF creates item class instances using reflection and an exception will be thrown if there isn't such constructor available.

3. Set the custom item as default

By default the Calendar control instantiates items of type Appointment when the user creates items interactively (by typing). To make the calendar create items of the new class, add the following line of code in the window's constructor.

C# [image] Copy Code

calendar.InteractiveItemType = typeof(MyApp);

Visual Basic [image] Copy Code

calendar.InteractiveItemType = GetType(MyApp)

Now all items created by the user at runtime will be instances of MyApp.

4. Test

To test whether the calendar actually creates MyApp instances, add an event handler to the control's ItemClick event. Add the following as a body of the event handler:

C# [image] Copy Code

if (e.Item is MyApp)
{
calendar.ResetDrag();
MessageBox.Show("This is our item.");
}

Visual Basic [image] Copy Code

If TypeOf e.Item Is MyApp Then

calendar.ResetDrag()
MessageBox.Show("This is our item.")

End If

Clicking on an item now should display the message box.

5. Serialization

Serialization of custom items requires additional efforts. Attempts to save a schedule containing items of type MyApp will result in an InvalidOperationException exception. In order to support serialization, we have to register MyApp with the schedule. For this purpose, add the following line of code somewhere in the window's constructor:

C# [image] Copy Code

Schedule.RegisterItemClass(typeof(MyApp), "myapp", 1);

Visual Basic [image] Copy Code

Schedule.RegisterItemClass(GetType(MyApp), "myapp", 1)

Now the exception won't be thrown, but you still need to override the SaveTo and LoadFrom methods of the Appointment class in order to serialize the custom property Kept. The code below illustrates how this is done.

C# [image] Copy Code

public override void SaveTo(XmlElement element, XmlSerializationContext context)
{
base.SaveTo(element, context);
context.WriteBool(kept, "Kept", element);
}

public override void LoadFrom(XmlElement element, XmlSerializationContext context)
{
base.LoadFrom(element, context);
kept = context.ReadBool("Kept", element);
}

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo(ByVal element As XmlElement, ByVal context As XmlSerializationContext)

MyBase.SaveTo(element, context)
context.WriteBool(_kept, "Kept", element)

End Sub

Public Overrides Sub LoadFrom(ByVal element As XmlElement, ByVal context As XmlSerializationContext)

MyBase.LoadFrom(element, context)
_kept = context.ReadBool("Kept", element)

End Sub

6. Recurrence

Recurrence of items from a custom class is not handled wholly automatically. Let's take a closer look at how recurrence works in MindFusion.Scheduling for WPF. When a recurrence pattern is associated with an existing item, the item is said to become the master of the recurrence. Every time the occurrences of a master item must be displayed in a given time range, they are generated by instantiating new objects of the same type as that of the master. This is necessary in order to support infinite recurrences, where the generation of all recurrence instances is not possible. When the occurrences are generated, their properties are copied from the master item. This is done automatically for the built-in item properties, but not for those added by a derived item class. In order to copy the custom properties from the master item to a particular occurrence, you need to override the CopyOccurrence method. The following code sample shows how to do this.

C# [image] Copy Code

protected override void CopyOccurrence(Item master)
{
base.CopyOccurrence(master);
_kept = (master as MyApp).Kept;
}

Visual Basic [image] Copy Code

Protected Overloads Overrides Sub CopyOccurrence(ByVal master As Item)

MyBase.CopyOccurrence(master)
_kept = CType(master, MyApp).Kept

End Sub

In addition, it is recommended to mark an item from a recurrent series as an exception when the value of a custom property changes. Otherwise, the change will be lost the next time the instance is generated.

C# [image] Copy Code

//...
public bool Kept
{
get { return _kept; }
set
{
_kept = value;

if (Recurrence != null)
Recurrence.MarkException(this, false);
}
}
//...

Visual Basic [image] Copy Code

' ...
Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)

_kept = Value

If Not Recurrence Is Nothing Then
Recurrence.MarkException(Me, False)
End If

End Set

End Property
' ...

7. Interactive cloning

The users can clone items by holding down a particular key (the SHIFT key by default). To enable your custom items for interactive cloning, you have to override the Clone method, create a new object from your custom type and duplicate the fields of the prototype item. If you do not override the Clone method, MindFusion.Scheduling for WPF will still create copies of the item, but they will be of type Appointment instead of the custom item type. Here is a sample implementation of the Clone method.

C# [image] Copy Code

//...
public override object Clone()
{
MyApp clone = new MyApp();

// The following code replicates the code used in
// the Appointment's Clone method
clone.AllDayEvent = this.AllDayEvent;
clone.DescriptionText = this.DescriptionText;
clone.EndTime = this.EndTime;
clone.HeaderText = this.HeaderText;
clone.Location = this.Location;
clone.Locked = this.Locked;
clone.Priority = this.Priority;
clone.Reminder = this.Reminder;
clone.SelectedStyle = this.SelectedStyle.Clone() as Style;
clone.StartTime = this.StartTime;
clone.Style = this.Style.Clone() as Style;
clone.Tag = this.Tag;
clone.Task = this.Task;
clone.Visible = this.Visible;

foreach (Resource resource in this.Resources)
clone.Resources.Add(resource);

foreach (Contact contact in this.Contacts)
clone.Contacts.Add(contact);

// Now copy the custom fields
clone.Kept = this.Kept;

return clone;
}
//...

Visual Basic [image] Copy Code

'...
Public Overloads Overrides Function Clone() As Object

Dim aClone As New MyApp

' The following code replicates the code used in
' the Appointment's Clone method
aClone.AllDayEvent = Me.AllDayEvent
aClone.DescriptionText = Me.DescriptionText
aClone.EndTime = Me.EndTime
aClone.HeaderText = Me.HeaderText
aClone.Location = Me.Location
aClone.Locked = Me.Locked
aClone.Priority = Me.Priority
aClone.Reminder = Me.Reminder
aClone.StartTime = Me.StartTime
aClone.Tag = Me.Tag
aClone.Task = Me.Task
aClone.Visible = Me.Visible

Dim resource As Resource
For Each resource In Me.Resources
aClone.Resources.Add(resource)
Next resource

Dim contact As Contact
For Each contact In Me.Contacts
aClone.Contacts.Add(contact)
Next contact

' Now copy the custom fields
aClone.Kept = Me.Kept

Return aClone

End Function
'...


Tutorial 5: Custom Item Templates

Tutorial 5: Custom Item Templates

This tutorial demonstrates how to customize the items presentation through custom item templates.

1. Create and initialize a new WPF application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

Set CurrentView to Timetable, Theme to Vista and Date to Jan 1, 2010.

2. Creating the item template

In order to customize the item appearance, you need to define a new control template for the item presentation just what you would do when you are customizing the template of a regular WPF control. Since the Item itself is not a WPF Control-derived class, there is a special class, which is used to represent items in the Calendar control - ItemPresenter. For more information on the ItemPresenter and its role in the item presentation, check Item Presenters.

The easiest way to customize the ItemPresenter's template is to create a copy of the default template and modify it. The full code of the default item template can be found here. The default template contains several triggers, which determine the item's appearance in different views and in different orientations. For simplicity this tutorial will only customize the appearance of the items in vertical Timetable view.

Copy the template listed below to the App.xaml (Application.xaml in Visual Basic) file in your project.

XAML [image] Copy Code

<Style TargetType="{x:Type planner:ItemPresenter}">
<Style.Triggers>

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Complex">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="{x:Type planner:ItemPresenter}">
<Border DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
BorderThickness="{Binding ItemStyle.BorderThickness}"
CornerRadius="8"
Margin="0,5,0,5">

<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="Auto" />
<RowDefinition />
</Grid.RowDefinitions>

<Border HorizontalAlignment="Stretch" BorderThickness="0,0,0,1"
BorderBrush="{Binding ItemStyle.LineBrush}"
Height="{Binding ItemSettings.HeaderSize}"
Margin="5,1,5,1">

<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>

<TextBlock x:Name="HeaderBlock"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="Left"
HorizontalAlignment="Stretch"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<StackPanel Orientation="Horizontal" Grid.Column="1">
<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Recurrence.png"
Visibility="{Binding RecurrenceIconVisibility}" Margin="1" />
<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/RecurrenceEx.png"
Visibility="{Binding RecurrenceExceptionIconVisibility}" Margin="1" />
<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Reminder.png"
Visibility="{Binding ReminderIconVisibility}" Margin="1" />
</StackPanel>
</Grid>
</Border>
<Border Grid.Row="1" Margin="5,1,5,1" DataContext="{TemplateBinding Item}">
<StackPanel Orientation="Vertical">
<TextBlock Text="{Binding StartTime}" />
<TextBlock Text="{Binding EndTime}" />
</StackPanel>
</Border>
<Border HorizontalAlignment="Stretch" BorderThickness="0,1,0,0"
Grid.Row="2"
BorderBrush="{Binding ItemStyle.LineBrush}"
Margin="5,1,5,1">
<TextBlock x:Name="DescriptionBlock"
DataContext="{TemplateBinding Item}"
TextWrapping="Wrap" Text="{Binding DescriptionText}" />
</Border>
</Grid>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</DataTrigger>

<MultiDataTrigger>
<MultiDataTrigger.Conditions>
<Condition Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple" />
<Condition Binding="{Binding Orientation, RelativeSource={RelativeSource Self}}" Value="Horizontal" />
</MultiDataTrigger.Conditions>

<!-- Simple horizontal template omitted for clarity. -->

</MultiDataTrigger>

<MultiDataTrigger>
<MultiDataTrigger.Conditions>
<Condition Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Simple" />
<Condition Binding="{Binding Orientation, RelativeSource={RelativeSource Self}}" Value="Vertical" />
</MultiDataTrigger.Conditions>

<!-- Simple vertical template omitted for clarity. -->

</MultiDataTrigger>

</Style.Triggers>
</Style>

The planner namespace is defined in the <Application> tag as follows:

XAML [image] Copy Code

xmlns:planner="clr-namespace:MindFusion.Scheduling.Wpf;assembly=MindFusion.Scheduling.Wpf"

The local namespace is set to the namespace of your project (Tutorial5 by default).

The first line of the above XAML code automatically associates the defined style with all ItemPresenter instances.

XAML [image] Copy Code

<Style TargetType="{x:Type planner:ItemPresenter}">

The first trigger defined in the style is matched for items displayed in Timetable and Resource views. Those items are identified when the value of the StyleKey property is set to "Complex".

XAML [image] Copy Code

<DataTrigger Binding="{Binding StyleKey, RelativeSource={RelativeSource Self}}" Value="Complex">

The other two triggers are matched for horizontal and vertical items displayed in SingleMonth, MonthRange, List and WeekRange views. The value of the StyleKey property for those items is set to "Simple". This tutorial uses the default templates for these two types of presentation and therefore they are omitted above for clarity.

The new template is similar to the default one with the following differences:

  • The resize bands of the items are not displayed;
  • The items now have rounded edges;
  • The recurrence and reminder icons are displayed in the item's header, to the right of the item's HeaderText;
  • The start time and end time of the item are displayed below the item's header. They are automatically updated whenever the item's StartTime or EndTime change;

Without making any further modifications, run the sample, create a new item and see the newly defined template applied to it. The following image illustrates how an item will look like in the Vista theme.

3. Formatting the start and end time

Looking at the new item presentation you can see that the start and end dates displayed below the item's header are formatted using the default DateTime formatting and are not very readable. Let's define our custom IValueConverter class, which will enable us to display the dates in a custom format during databinding. For this purpose, create a new class - FormattingConverter and implement it as illustrated below.

C# [image] Copy Code

class FormattingConverter : System.Windows.Data.IValueConverter
{
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
{
string format = parameter as string;
if (format == null)
return value.ToString();

return string.Format(culture, format, value);
}

public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
{
throw new NotImplementedException();
}
}

Visual Basic [image] Copy Code

Class FormattingConverter
Implements System.Windows.Data.IValueConverter

Public Function Convert(ByVal value As Object, ByVal targetType As Type, ByVal parameter As Object, ByVal culture As System.Globalization.CultureInfo) As Object Implements IValueConverter.Convert

Dim format As String = CStr(parameter)
If format Is Nothing Then
Return value.ToString()
End If

Return String.Format(culture, format, value)

End Function

Public Function ConvertBack(ByVal value As Object, ByVal targetType As Type, ByVal parameter As Object, ByVal culture As System.Globalization.CultureInfo) As Object Implements IValueConverter.ConvertBack

Throw New NotImplementedException()

End Function

End Class

The above class takes a string argument and uses this string in order to format the input value. The next step is to create a static resource object of this class. Insert the following line before the <Style> definition in App.xaml (Application.xaml in Visual Basic):

XAML [image] Copy Code

<local:FormattingConverter x:Key="formattingConverter" />

Now locate the following two lines in the template:

XAML [image] Copy Code

<TextBlock Text="{Binding StartTime}" />
<TextBlock Text="{Binding EndTime}" />

And modify them as following:

XAML [image] Copy Code

<TextBlock Text="{Binding StartTime, Converter={StaticResource formattingConverter}, ConverterParameter='Start time: \{0:H:mm\}', Mode=Default}" />
<TextBlock Text="{Binding EndTime, Converter={StaticResource formattingConverter}, ConverterParameter='End time: \{0:H:mm\}', Mode=Default}" />

The above code instructs the Text bindings to format their source values using the "Start time: {0:H:mm}" and "{End time: {0:H:mm}" formatting strings respectively.

4. Build and run

Compile and run the application. Creating a new item with a Reminder and sample description will yield a result similar to the following:


Tutorial 6: Creating and Printing Reports

Tutorial 6: Creating and Printing Reports

This tutorial demonstrates how to setup and preview an event report in MindFusion.Scheduling for WPF.

1. Create the report

To create a report, simply instantiate from the Report class and pass a reference to the target Schedule object as an argument to the constructor.

C# [image] Copy Code

Report report = new Report(calendar.Schedule);

Visual Basic [image] Copy Code

Dim report As New Report(calendar.Schedule)

2. Setting-up the report columns

Report columns are created by calling the CreateColumn method on the report object. Once created the column's properties can be customized as needed. All report columns can be accessed at any time through the Columns property of the report. The following code illustrates how to create three columns containing the header text, the start date and the end date of items and how to add them to the report created in step 1.

C# [image] Copy Code

ReportColumn column = null;

// Create the first column
column = report.CreateColumn();
column.Property = "HeaderText";
column.Width = 100;

// Create the second column
column = report.CreateColumn();
column.Property = "StartTime";
column.Width = 50;

// Create the third column
column = report.CreateColumn();
column.Property = "EndTime";
column.Width = 50;

Visual Basic [image] Copy Code

Dim column As ReportColumn = Nothing

' Create the first column
column = report.CreateColumn()
column.Property = "HeaderText"
column.Width = 100

' Create the second column
column = report.CreateColumn()
column.Property = "StartTime"
column.Width = 50

' Create the third column
column = report.CreateColumn()
column.Property = "EndTime"
column.Width = 50

The first column twice as wide as the other columns.

3. Setup report options

You can customize various aspects of the report by modifying the properties of the ReportOptions object, accessed through the Report.Options property. In this particular case you will make the width of the columns in the report to resize to automatically fill the width of one page.

C# [image] Copy Code

report.Options.AbsoluteColumnWidth = false;

Visual Basic [image] Copy Code

report.Options.AbsoluteColumnWidth = False

4. Print / Preview the report

The report is printed or previewed by calling the Print or PrintPreview methods respectively. Both methods accept two .NET DateTime instances, which specify the time range of the items included in the report. If you do NOT have infinite recurrences in the report it is safe to specify DateTime.MinValue and DateTime.MaxValue for those parameters to ensure that all items will get included in the report.

C# [image] Copy Code

report.PrintPreview(DateTime.MinValue, DateTime.MaxValue);

Visual Basic [image] Copy Code

report.PrintPreview(DateTime.MinValue, DateTime.MaxValue)

Here is how our report would look like.


Tutorial 7: Exchanging Data with Microsoft Outlook

Tutorial 7: Exchanging Data with Microsoft Outlook

This tutorial demonstrates how to import and export MindFusion.Scheduling for WPF event information from/to Microsoft® Outlook®.

1. Create and initialize a new WPF application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

Set CurrentView to WeekRange, Date to Jan 1, 2010 and EndDate to Mar 1, 2010, respectively.

2. Add a reference to the Outlook library

Go to the 'Solution Explorer' window. You can show this window by selecting View -> Solution Explorer from the menu. Find the 'References' node in the tree view displayed in the 'Solution Explorer', right-click on it with the mouse and select 'Add Reference...' from the context menu that appears. In the "Add reference" dialog click the 'Browse...' button and navigate to the Outlook Import/Export library - MindFusion.Scheduling.Outlook.dll. This file is usually found in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for WPF' folder or in the folder where you have installed the product. Click the 'OK' button to add the assembly reference to your project.

Note

In Visual Basic projects you will have to check the 'Show All Files' button in the Solution Explorer toolbar in order for the References project item to appear.

3. Import the necessary namespaces

Include the MindFusion.Scheduling and MindFusion.Scheduling.Outlook namespaces in the beginning of the file. These namespaces contain all schedule classes along with the OutlookImporter and OutlookExporter classes, which provide Outlook Export/Import capabilities.

C# [image] Copy Code

using MindFusion.Scheduling;
using MindFusion.Scheduling.Outlook;

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling
Imports MindFusion.Scheduling.Outlook

4. Add import and export buttons to the form

Add two buttons to the form, named _btnImport and _btnExport accordingly. Set the texts of the buttons to 'Import' and 'Export' respectively. Create a Click event handler for each of those buttons by double-clicking on the buttons in the design environment.

The body of the event handler of the 'Import' button should look like this:

C# [image] Copy Code

private void _btnImport_Click(object sender, RoutedEventArgs e)
{
OutlookImporter importer = new OutlookImporter(calendar.Schedule);
importer.ImportItems();
}

Visual Basic [image] Copy Code

Private Sub _btnImport_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs)

Dim importer As OutlookImporter = New OutlookImporter(calendar.Schedule)
importer.ImportItems()

End Sub

The code above creates a new instance of the OutlookImporter class, passing to the constructor a reference to the Schedule object, which will be the target of the importing operation. Then it calls the ImportItems method of the OutlookImporter class in order to import all items from Outlook to the specified schedule. More complicated scenarios are possible. For example you can filter certain items during the importing process by attaching a handler to the ItemImporting event of the OutlookImporter class.

The body of the event handler of the 'Export' button will look similarly.

C# [image] Copy Code

private void _btnExport_Click(object sender, RoutedEventArgs e)
{
OutlookExporter exporter = new OutlookExporter(calendar.Schedule);
exporter.ExportItems();
}

Visual Basic [image] Copy Code

Private Sub _btnExport_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs)

Dim exporter As OutlookExporter = New OutlookExporter(calendar.Schedule)
exporter.ExportItems()

End Sub

5. Build and run

Compile and run the application. Click the 'Import' button to import all items from Outlook into out application. Click the 'Export' button to export all items from the application to Outlook.


Reference

Reference


MindFusion Namespace

MindFusion Namespace
Classes Enumerations

Classes

Class | Description
Utilities | Contains common helper methods.

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of contents relative to the layout rectangle.


MindFusion.Alignment Enumeration

Alignment Enumeration
See Also
[image]

Specifies the alignment of contents relative to the layout rectangle.

Namespace: MindFusion
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum Alignment

Visual Basic [image] Copy Code

Public Enum Alignment

Members

Member name | Description
Far | The contents are aligned far from the origin of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | The contents are aligned near the layout rectangle. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.
None | The contents are unavailable.

See Also

MindFusion Namespace


MindFusion.Utilities Class

Utilities Class
[image]

Contains common helper methods.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class Utilities

Visual Basic [image] Copy Code

Public NotInheritable Class Utilities

Inheritance Hierarchy

System.Object
MindFusion.Utilities

See Also

Utilities Members
MindFusion Namespace


MindFusion.Utilities Members

Utilities Members
Methods
[image]

Contains common helper methods.

The following tables list the members exposed by the Utilities type.

Public Methods

Name | Description
AddPoints | Adds two points. In .NET 2.0 Point.Offset() may be used instead.
AddRoundRect | Overloaded.
ApplyPadding | Subtract padding space from specified rectangle.
ApproxBezier | Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
CheckIntersect | Checks if the specified rectangle and circle intersect.
Closer | Overloaded.
CompareFiles | Compares two files.
CompareStreams | Compares two streams. The streams should the buffered for performance. The streams are not closed.
CreateRotateTransform | Creates a new rotation transformation at the specified angle around the specified point.
Degrees | Converts the specified value from radians to degrees.
Distance | Overloaded.
DistanceSq | Calculates the square of the distance between the specified points.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToLineSegment | Calculates distance from the specified point to the specified line segment
DistToPolyline | Overloaded.
DistToRect | Calculates distance from the specified point to the specified rectangle.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawImage | Draws the specified image to the specified graphics, using the specified destination rectangle and alignment.
Farther | Returns the point from the specified pair, which lies farther from the specified pivot.
FindAncestor | Finds visual tree ancestor of the specified type.
FromLTRB | Creates a new System.Windows.Rect out of the specified coordinates.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetNearestPt | Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
HitTest | Hit tests a Visual against a Geometry value.
HitTestResult | Hit tests a Visual against a Geometry value.
ImageRect | Returns the region where an image should be displayed for specified alignment.
Intersect | Determines whether the specified line segments intersect.
LineIntersect | Like LineIntersectNaN, but semantically ambiguous as it returns Real.MinValue instead of NaN. Better use LineIntersectNaN. Left for compatibility.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
LoadImage | Overloaded.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
PointAlongLength | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInPolygon | Determines if the specified point is within the specified polygon.
PointInPolyRect | Determines if the specified point is within the smallest rectangle that encloses the specified polygon.
PointInRect | Checks whether the specified rectangle contains the specified point.
PointInSegment | Checks whether the line segment defined by the specified points contain the specified point.
Radians | Converts the specified value from degrees to radians.
SaveImage | Overloaded. Saves an image to a file or a stream.
SaveJpeg | Saves an image to the specified jpeg file.
SaveToFile | Overloaded.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.
SnapToDevicePixel | Overloaded.

See Also

Utilities Class
MindFusion Namespace


MindFusion.Utilities Methods

Utilities Methods
[image]

Public Methods

Name | Description
AddPoints | Adds two points. In .NET 2.0 Point.Offset() may be used instead.
AddRoundRect | Overloaded.
ApplyPadding | Subtract padding space from specified rectangle.
ApproxBezier | Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
CheckIntersect | Checks if the specified rectangle and circle intersect.
Closer | Overloaded.
CompareFiles | Compares two files.
CompareStreams | Compares two streams. The streams should the buffered for performance. The streams are not closed.
CreateRotateTransform | Creates a new rotation transformation at the specified angle around the specified point.
Degrees | Converts the specified value from radians to degrees.
Distance | Overloaded.
DistanceSq | Calculates the square of the distance between the specified points.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToLineSegment | Calculates distance from the specified point to the specified line segment
DistToPolyline | Overloaded.
DistToRect | Calculates distance from the specified point to the specified rectangle.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawImage | Draws the specified image to the specified graphics, using the specified destination rectangle and alignment.
Farther | Returns the point from the specified pair, which lies farther from the specified pivot.
FindAncestor | Finds visual tree ancestor of the specified type.
FromLTRB | Creates a new System.Windows.Rect out of the specified coordinates.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetNearestPt | Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
HitTest | Hit tests a Visual against a Geometry value.
HitTestResult | Hit tests a Visual against a Geometry value.
ImageRect | Returns the region where an image should be displayed for specified alignment.
Intersect | Determines whether the specified line segments intersect.
LineIntersect | Like LineIntersectNaN, but semantically ambiguous as it returns Real.MinValue instead of NaN. Better use LineIntersectNaN. Left for compatibility.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
LoadImage | Overloaded.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
PointAlongLength | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInPolygon | Determines if the specified point is within the specified polygon.
PointInPolyRect | Determines if the specified point is within the smallest rectangle that encloses the specified polygon.
PointInRect | Checks whether the specified rectangle contains the specified point.
PointInSegment | Checks whether the line segment defined by the specified points contain the specified point.
Radians | Converts the specified value from degrees to radians.
SaveImage | Overloaded. Saves an image to a file or a stream.
SaveJpeg | Saves an image to the specified jpeg file.
SaveToFile | Overloaded.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.
SnapToDevicePixel | Overloaded.

See Also

Utilities Class
MindFusion Namespace


MindFusion.Utilities.AddPoints Method

Utilities.AddPoints Method
[image]

Adds two points. In .NET 2.0 Point.Offset() may be used instead.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point AddPoints (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function AddPoints( _
p1 As Point, _
p2 As Point _
) As Point

Parameters

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.AddRoundRect Method

Utilities.AddRoundRect Method
[image]

Overload List

Name | Description
Utilities.AddRoundRect (PathFigure, Double, Double, Double, Double, Double, Boolean) | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
Utilities.AddRoundRect (PathFigure, Rect, Double, Boolean) | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.AddRoundRect Method (PathFigure, Double, Double, Double, Double, Double, Boolean)

Utilities.AddRoundRect Method (PathFigure, Double, Double, Double, Double, Double, Boolean)
See Also
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static PathFigure AddRoundRect (
PathFigure gp,
double x,
double y,
double width,
double height,
double r,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Function AddRoundRect( _
gp As PathFigure, _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
r As Double, _
setStartPoint As Boolean _
) As PathFigure

Parameters

gp

x

y

width

height

r

setStartPoint

Return Value

See Also

AddRoundRect Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.AddRoundRect Method (PathFigure, Rect, Double, Boolean)

Utilities.AddRoundRect Method (PathFigure, Rect, Double, Boolean)
See Also
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static PathFigure AddRoundRect (
PathFigure pf,
Rect rc,
double r,
bool setStartPoint
)

Visual Basic [image] Copy Code

Public Shared Function AddRoundRect( _
pf As PathFigure, _
rc As Rect, _
r As Double, _
setStartPoint As Boolean _
) As PathFigure

Parameters

pf

rc

r

setStartPoint

Return Value

See Also

AddRoundRect Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.ApplyPadding Method

Utilities.ApplyPadding Method
[image]

Subtract padding space from specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect ApplyPadding (
Rect rect,
Thickness padding,
double defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ApplyPadding( _
rect As Rect, _
padding As Thickness, _
defaultValue As Double _
) As Rect

Parameters

rect

A Rect instance.

padding

A Thickness instance specifying padding size.

defaultValue

A double value specifying default padding.

Return Value

The padded rectangle.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.ApproxBezier Method

Utilities.ApproxBezier Method
[image]

Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point[] ApproxBezier (
Point[] points,
int startIdx,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier( _
points() As Point, _
startIdx As Integer, _
quality As Integer _
) As Point()

Parameters

points

startIdx

quality

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CalcBezierCoef Method

Utilities.CalcBezierCoef Method
[image]

Calculates the bezier coefficients in the equation of the specified bezier curve.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void CalcBezierCoef (
ref double a0,
ref double a1,
ref double a2,
ref double a3,
ref double b0,
ref double b1,
ref double b2,
ref double b3,
ref double u,
ref double s,
ref double z,
ref double x4,
ref double y4
)

Visual Basic [image] Copy Code

Public Shared Sub CalcBezierCoef( _
ByRef a0 As Double, _
ByRef a1 As Double, _
ByRef a2 As Double, _
ByRef a3 As Double, _
ByRef b0 As Double, _
ByRef b1 As Double, _
ByRef b2 As Double, _
ByRef b3 As Double, _
ByRef u As Double, _
ByRef s As Double, _
ByRef z As Double, _
ByRef x4 As Double, _
ByRef y4 As Double _
)

Parameters

a0

a1

a2

a3

b0

b1

b2

b3

u

s

z

x4

y4

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Ccw Method

Utilities.Ccw Method
[image]

Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int Ccw (
Point p0,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Ccw( _
p0 As Point, _
p1 As Point, _
p2 As Point _
) As Integer

Parameters

p0

p1

p2

Return Value

Remarks

1 if the movement is in a counterclockwise direction, -1 if not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CheckIntersect Method

Utilities.CheckIntersect Method
[image]

Checks if the specified rectangle and circle intersect.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool CheckIntersect (
Point pt,
Rect rc,
double rad
)

Visual Basic [image] Copy Code

Public Shared Function CheckIntersect( _
pt As Point, _
rc As Rect, _
rad As Double _
) As Boolean

Parameters

pt
A Point specifying the radius of a circle.
rc
A Rect instance specifying a rectangle.
rad
A double value specifying the circle's radius.

Return Value

true if the shapes intersect, otherwise false.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Closer Method

Utilities.Closer Method
[image]

Overload List

Name | Description
Utilities.Closer (Double, Double, Double) | Returns the point from the specified pair, which lies closer to the specified pivot.
Utilities.Closer (Point, Point, Point) | Returns the point from the specified pair, which lies closer to the specified pivot.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Closer Method (Double, Double, Double)

Utilities.Closer Method (Double, Double, Double)
See Also
[image]

Returns the point from the specified pair, which lies closer to the specified pivot.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double Closer (
double pivot,
double choice1,
double choice2
)

Visual Basic [image] Copy Code

Public Shared Function Closer( _
pivot As Double, _
choice1 As Double, _
choice2 As Double _
) As Double

Parameters

pivot

choice1

choice2

Return Value

See Also

Closer Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Closer Method (Point, Point, Point)

Utilities.Closer Method (Point, Point, Point)
See Also
[image]

Returns the point from the specified pair, which lies closer to the specified pivot.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point Closer (
Point pivot,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Closer( _
pivot As Point, _
p1 As Point, _
p2 As Point _
) As Point

Parameters

pivot

p1

p2

Return Value

See Also

Closer Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CompareFiles Method

Utilities.CompareFiles Method
[image]

Compares two files.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static long CompareFiles (
string file1,
string file2
)

Visual Basic [image] Copy Code

Public Shared Function CompareFiles( _
file1 As String, _
file2 As String _
) As Long

Parameters

file1

file2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CompareStreams Method

Utilities.CompareStreams Method
[image]

Compares two streams. The streams should the buffered for performance. The streams are not closed.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static long CompareStreams (
Stream s1,
Stream s2
)

Visual Basic [image] Copy Code

Public Shared Function CompareStreams( _
s1 As Stream, _
s2 As Stream _
) As Long

Parameters

s1

s2

Return Value

Returns the index of the first different byte or -1 if files are equal.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CreateRotateTransform Method

Utilities.CreateRotateTransform Method
[image]

Creates a new rotation transformation at the specified angle around the specified point.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static MatrixTransform CreateRotateTransform (
double angle,
Point center
)

Visual Basic [image] Copy Code

Public Shared Function CreateRotateTransform( _
angle As Double, _
center As Point _
) As MatrixTransform

Parameters

angle

center

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Degrees Method

Utilities.Degrees Method
[image]

Converts the specified value from radians to degrees.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double Degrees (
double radians
)

Visual Basic [image] Copy Code

Public Shared Function Degrees( _
radians As Double _
) As Double

Parameters

radians

The value to convert.

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method

Utilities.Distance Method
[image]

Overload List

Name | Description
Utilities.Distance (Double, Double) | Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.
Utilities.Distance (Point, Point) | Calculates the distance between the specified points.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method (Double, Double)

Utilities.Distance Method (Double, Double)
See Also
[image]

Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double Distance (
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
x As Double, _
y As Double _
) As Double

Parameters

x

y

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method (Point, Point)

Utilities.Distance Method (Point, Point)
See Also
[image]

Calculates the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double Distance (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistanceSq Method

Utilities.DistanceSq Method
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistanceSq (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToBezier Method

Utilities.DistToBezier Method
[image]

Calculates the shortest distance from the specified point to the specified bezier curve.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistToBezier (
Point pt,
IList bez_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToBezier( _
pt As Point, _
bez_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

bez_pts

nPoints

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToLineSegment Method

Utilities.DistToLineSegment Method
[image]

Calculates distance from the specified point to the specified line segment

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistToLineSegment (
Point pt,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function DistToLineSegment( _
pt As Point, _
p1 As Point, _
p2 As Point _
) As Double

Parameters

pt

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method

Utilities.DistToPolyline Method
[image]

Overload List

Name | Description
Utilities.DistToPolyline (Point, IList, Int32) | Calculates the shortest distance from the specified point to the specified polyline.
Utilities.DistToPolyline (Point, IList, Int32, Int32@) | Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method (Point, IList, Int32)

Utilities.DistToPolyline Method (Point, IList, Int32)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

line_pts

nPoints

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)

Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer, _
ByRef segmNum As Integer _
) As Double

Parameters

pt

line_pts

nPoints

segmNum

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToRect Method

Utilities.DistToRect Method
[image]

Calculates distance from the specified point to the specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double DistToRect (
Point pt,
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRect( _
pt As Point, _
r As Rect _
) As Double

Parameters

pt

r

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToRectPoint Method

Utilities.DistToRectPoint Method
[image]

Returns the nearest to pt point that lies on the outline of rectangle.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point DistToRectPoint (
Point pt,
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRectPoint( _
pt As Point, _
r As Rect _
) As Point

Parameters

pt

r

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DrawImage Method

Utilities.DrawImage Method
[image]

Draws the specified image to the specified graphics, using the specified destination rectangle and alignment.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawImage (
DrawingContext graphics,
ImageSource pict,
Rect rect,
ImageAlign align,
GraphicsUnit measureUnit
)

Visual Basic [image] Copy Code

Public Shared Sub DrawImage( _
graphics As DrawingContext, _
pict As ImageSource, _
rect As Rect, _
align As ImageAlign, _
measureUnit As GraphicsUnit _
)

Parameters

graphics

pict

rect

align

measureUnit

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Farther Method

Utilities.Farther Method
[image]

Returns the point from the specified pair, which lies farther from the specified pivot.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point Farther (
Point pivot,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Farther( _
pivot As Point, _
p1 As Point, _
p2 As Point _
) As Point

Parameters

pivot

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.FindAncestor Method

Utilities.FindAncestor Method
[image]

Finds visual tree ancestor of the specified type.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyObject FindAncestor (
DependencyObject descendent,
Type t
)

Visual Basic [image] Copy Code

Public Shared Function FindAncestor( _
descendent As DependencyObject, _
t As Type _
) As DependencyObject

Parameters

descendent
The object whose ancestor to find.
t
A System.Type object specifying what kind of ancestor to look for.

Return Value

A DependencyObject that is an ancestor of the specified object.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.FromLTRB Method

Utilities.FromLTRB Method
[image]

Creates a new System.Windows.Rect out of the specified coordinates.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect FromLTRB (
double l,
double t,
double r,
double b
)

Visual Basic [image] Copy Code

Public Shared Function FromLTRB( _
l As Double, _
t As Double, _
r As Double, _
b As Double _
) As Rect

Parameters

l

t

r

b

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetBezierPt Method

Utilities.GetBezierPt Method
[image]

Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point GetBezierPt (
IList points,
int segment,
double t
)

Visual Basic [image] Copy Code

Public Shared Function GetBezierPt( _
points As IList, _
segment As Integer, _
t As Double _
) As Point

Parameters

points

segment

t

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetEllipseIntr Method

Utilities.GetEllipseIntr Method
[image]

Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void GetEllipseIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetEllipseIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetNearestPt Method

Utilities.GetNearestPt Method
[image]

Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point GetNearestPt (
Point pt,
Point segPt1,
Point segPt2
)

Visual Basic [image] Copy Code

Public Shared Function GetNearestPt( _
pt As Point, _
segPt1 As Point, _
segPt2 As Point _
) As Point

Parameters

pt

segPt1

segPt2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetRectIntr Method

Utilities.GetRectIntr Method
[image]

Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void GetRectIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetRectIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetRoundRect Method

Utilities.GetRoundRect Method
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static PathGeometry GetRoundRect (
double x,
double y,
double width,
double height,
double r
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRect( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
r As Double _
) As PathGeometry

Parameters

x

y

width

height

r

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.HitTest Method

Utilities.HitTest Method
[image]

Hit tests a Visual against a Geometry value.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Visual HitTest (
Visual v,
Geometry g
)

Visual Basic [image] Copy Code

Public Shared Function HitTest( _
v As Visual, _
g As Geometry _
) As Visual

Parameters

v

g

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.HitTestResult Method

Utilities.HitTestResult Method
[image]

Hit tests a Visual against a Geometry value.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static HitTestResultBehavior HitTestResult (
HitTestResult result
)

Visual Basic [image] Copy Code

Public Shared Function HitTestResult( _
result As HitTestResult _
) As HitTestResultBehavior

Parameters

result

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.ImageRect Method

Utilities.ImageRect Method
[image]

Returns the region where an image should be displayed for specified alignment.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect ImageRect (
ImageAlign align,
Rect layoutRect,
Size imageSize
)

Visual Basic [image] Copy Code

Public Shared Function ImageRect( _
align As ImageAlign, _
layoutRect As Rect, _
imageSize As Size _
) As Rect

Parameters

align

A member of the ImageAlign enumeration.

layoutRect

Layout rectangle relatively to which the image is aligned.

imageSize

The image size.

Return Value

A System.Windows.Rect specifying image placement.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Intersect Method

Utilities.Intersect Method
[image]

Determines whether the specified line segments intersect.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool Intersect (
Point p1,
Point p2,
Point p3,
Point p4
)

Visual Basic [image] Copy Code

Public Shared Function Intersect( _
p1 As Point, _
p2 As Point, _
p3 As Point, _
p4 As Point _
) As Boolean

Parameters

p1

p2

p3

p4

Return Value

true if the segments intersect, false if not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersect Method

Utilities.LineIntersect Method
[image]

Like LineIntersectNaN, but semantically ambiguous as it returns Real.MinValue instead of NaN. Better use LineIntersectNaN. Left for compatibility.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point LineIntersect (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersect( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersectNaN Method

Utilities.LineIntersectNaN Method
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point LineIntersectNaN (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersectNaN( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

The intersection point of the specified lines or Point(double.NaN, double.NaN) if the lines do not intersect.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LoadImage Method

Utilities.LoadImage Method
[image]

Overload List

Name | Description
Utilities.LoadImage (Stream) | Loads an image from the specified stream.
Utilities.LoadImage (String) | Loads an image from the specified file.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LoadImage Method (Stream)

Utilities.LoadImage Method (Stream)
See Also
[image]

Loads an image from the specified stream.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static BitmapFrame LoadImage (
Stream s
)

Visual Basic [image] Copy Code

Public Shared Function LoadImage( _
s As Stream _
) As BitmapFrame

Parameters

s

Return Value

See Also

LoadImage Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LoadImage Method (String)

Utilities.LoadImage Method (String)
See Also
[image]

Loads an image from the specified file.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static BitmapFrame LoadImage (
string path
)

Visual Basic [image] Copy Code

Public Shared Function LoadImage( _
path As String _
) As BitmapFrame

Parameters

path

Return Value

See Also

LoadImage Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.MatchPointsMinLength Method

Utilities.MatchPointsMinLength Method
[image]

Returns an array of node anchor points which match current node links anchor point

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int[] MatchPointsMinLength (
Point[] nodeAnchorPoints,
int[] pointRealIndexes,
Point[] fixedLinksAnchorPoints,
List<Int32> usedAnchorPointIndexes
)

Visual Basic [image] Copy Code

Public Shared Function MatchPointsMinLength( _
nodeAnchorPoints() As Point, _
pointRealIndexes() As Integer, _
fixedLinksAnchorPoints() As Point, _
usedAnchorPointIndexes As List(Of Int32) _
) As Integer()

Parameters

nodeAnchorPoints

pointRealIndexes

fixedLinksAnchorPoints

usedAnchorPointIndexes

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.MinDistToRect Method

Utilities.MinDistToRect Method
[image]

Calculates the minimum distance between a given point and a given rectangle.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double MinDistToRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function MinDistToRect( _
pt As Point, _
rc As Rect _
) As Double

Parameters

pt
A point in the plane.
rc
A rectangle.

Return Value

A double value specifying the minimum distance between the point and the rectangle.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointAlongLength Method

Utilities.PointAlongLength Method
[image]

Returns a point lying at the specified distance from the start point along the path specified via the collection of points.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point PointAlongLength (
double distance,
IList<Point> segments
)

Visual Basic [image] Copy Code

Public Shared Function PointAlongLength( _
distance As Double, _
segments As IList(Of Point) _
) As Point

Parameters

distance

A double value specifying the desired distance.

segments

A list of points specifying the path.

Return Value

A Point structure specifying the point coordinates.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInEllipse Method

Utilities.PointInEllipse Method
[image]

Checks whether the specified point is contained in the ellipse defined by the specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInEllipse (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInEllipse( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInPolygon Method

Utilities.PointInPolygon Method
[image]

Determines if the specified point is within the specified polygon.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInPolygon (
Point[] poly,
Point ptTest
)

Visual Basic [image] Copy Code

Public Shared Function PointInPolygon( _
poly() As Point, _
ptTest As Point _
) As Boolean

Parameters

poly

ptTest

Return Value

true if the point is inside the polygon, false if not.

Remarks

It uses the classical polygon hit-testing algorithm: a horizontal ray starting at the point is extended infinitely rightwards and the number of polygon edges that intersect the ray are counted. If the number is odd, the point is inside the polygon.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInPolyRect Method

Utilities.PointInPolyRect Method
[image]

Determines if the specified point is within the smallest rectangle that encloses the specified polygon.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInPolyRect (
Point[] poly,
Point ptTest,
ref Rect rBound
)

Visual Basic [image] Copy Code

Public Shared Function PointInPolyRect( _
poly() As Point, _
ptTest As Point, _
ByRef rBound As Rect _
) As Boolean

Parameters

poly

ptTest

rBound

Return Value

true or false depending on whether the point is in the rect or not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInRect Method

Utilities.PointInRect Method
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInSegment Method

Utilities.PointInSegment Method
[image]

Checks whether the line segment defined by the specified points contain the specified point.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInSegment (
Point pt,
Point sgm1,
Point sgm2
)

Visual Basic [image] Copy Code

Public Shared Function PointInSegment( _
pt As Point, _
sgm1 As Point, _
sgm2 As Point _
) As Boolean

Parameters

pt

sgm1

sgm2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Radians Method

Utilities.Radians Method
[image]

Converts the specified value from degrees to radians.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double Radians (
double degrees
)

Visual Basic [image] Copy Code

Public Shared Function Radians( _
degrees As Double _
) As Double

Parameters

degrees

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveImage Method

Utilities.SaveImage Method
[image]

Saves an image to a file or a stream.

Overload List

Name | Description
Utilities.SaveImage (BitmapSource, String) | Saves an image to the specified png file.
Utilities.SaveImage (ImageSource, Stream) | Saves an image to the specified stream.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveImage Method (BitmapSource, String)

Utilities.SaveImage Method (BitmapSource, String)
See Also
[image]

Saves an image to the specified png file.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SaveImage (
BitmapSource b,
string filename
)

Visual Basic [image] Copy Code

Public Shared Sub SaveImage( _
b As BitmapSource, _
filename As String _
)

Parameters

b

filename

See Also

SaveImage Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveImage Method (ImageSource, Stream)

Utilities.SaveImage Method (ImageSource, Stream)
See Also
[image]

Saves an image to the specified stream.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SaveImage (
ImageSource b,
Stream s
)

Visual Basic [image] Copy Code

Public Shared Sub SaveImage( _
b As ImageSource, _
s As Stream _
)

Parameters

b

s

See Also

SaveImage Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveJpeg Method

Utilities.SaveJpeg Method
[image]

Saves an image to the specified jpeg file.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SaveJpeg (
BitmapSource b,
string filename
)

Visual Basic [image] Copy Code

Public Shared Sub SaveJpeg( _
b As BitmapSource, _
filename As String _
)

Parameters

b

filename

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveToFile Method

Utilities.SaveToFile Method
[image]

Overload List

Name | Description
Utilities.SaveToFile (String, Byte[]) | Saves the specified bytes to file. The file is overwritten if exists.
Utilities.SaveToFile (String, String, Encoding) | Saves the specified string to file.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveToFile Method (String, Byte[])

Utilities.SaveToFile Method (String, Byte[])
See Also
[image]

Saves the specified bytes to file. The file is overwritten if exists.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SaveToFile (
string filename,
byte[] content
)

Visual Basic [image] Copy Code

Public Shared Sub SaveToFile( _
filename As String, _
content() As Byte _
)

Parameters

filename

content

See Also

SaveToFile Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SaveToFile Method (String, String, Encoding)

Utilities.SaveToFile Method (String, String, Encoding)
See Also
[image]

Saves the specified string to file.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SaveToFile (
string filename,
string content,
Encoding encoding
)

Visual Basic [image] Copy Code

Public Shared Sub SaveToFile( _
filename As String, _
content As String, _
encoding As Encoding _
)

Parameters

filename

content

encoding

See Also

SaveToFile Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SegmentIntersect Method

Utilities.SegmentIntersect Method
[image]

Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool SegmentIntersect (
Point s1,
Point s2,
Point l1,
Point l2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Function SegmentIntersect( _
s1 As Point, _
s2 As Point, _
l1 As Point, _
l2 As Point, _
ByRef pt As Point _
) As Boolean

Parameters

s1

s2

l1

l2

pt

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SnapToDevicePixel Method

Utilities.SnapToDevicePixel Method
[image]

Overload List

Name | Description
Utilities.SnapToDevicePixel (Point, Visual) | Finds the device pixel nearest to the specified point.
Utilities.SnapToDevicePixel (Rect, Visual) | Aligns the specified rect to device pixels.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SnapToDevicePixel Method (Point, Visual)

Utilities.SnapToDevicePixel Method (Point, Visual)
See Also
[image]

Finds the device pixel nearest to the specified point.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point SnapToDevicePixel (
Point itemPoint,
Visual v
)

Visual Basic [image] Copy Code

Public Shared Function SnapToDevicePixel( _
itemPoint As Point, _
v As Visual _
) As Point

Parameters

itemPoint

A point to align to the nearest pixel.

v
A System.Windows.Media.Visual instance.

Return Value

A Point containing the nearest pixel coordinates.

See Also

SnapToDevicePixel Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SnapToDevicePixel Method (Rect, Visual)

Utilities.SnapToDevicePixel Method (Rect, Visual)
See Also
[image]

Aligns the specified rect to device pixels.

Namespace: MindFusion
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect SnapToDevicePixel (
Rect r,
Visual v
)

Visual Basic [image] Copy Code

Public Shared Function SnapToDevicePixel( _
r As Rect, _
v As Visual _
) As Rect

Parameters

r
A rectangle.
v
A System.Windows.Media.Visual instance.

Return Value

A rectangle with coordinates aligned to device pixels.

See Also

SnapToDevicePixel Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Barcodes.Wpf Namespace

MindFusion.Barcodes.Wpf Namespace
Classes

Classes

Class | Description
BarcodeLabel | Represents a barcode label.


MindFusion.Barcodes.Wpf.BarcodeLabel Class

BarcodeLabel Class
[image]

Represents a barcode label.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public class BarcodeLabel : Control

Visual Basic [image] Copy Code

Public Class BarcodeLabel
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Barcodes.Wpf.BarcodeLabel

See Also

BarcodeLabel Members
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel Members

BarcodeLabel Members
Constructors Fields Properties Methods
[image]

Represents a barcode label.

The following tables list the members exposed by the BarcodeLabel type.

Public Constructors

Name | Description
BarcodeLabel | Initializes a new instance of the BarcodeLabel class.

Public Fields

Name | Description
BarColorProperty | Identifies the BarColor dependency property.
ContentProperty | Identifies the Content dependency property.
FormatProperty | Identifies the Format dependency property.
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.

Public Properties

Name | Description
BarColor | Gets or sets the color of barcode modules. This is a dependency property.
Content | Gets or sets the text or numeric code that should be represented as barcode symbol. This is a dependency property.
Format | Gets or sets the barcode format. This is a dependency property.
QRCorrectionLevel | Gets or sets the correction level of QR barcodes. This is a dependency property.

Protected Methods

Name | Description
OnRender | Control.OnRender override.

See Also

BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel Constructor

BarcodeLabel Constructor
[image]

Initializes a new instance of the BarcodeLabel class.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public BarcodeLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel Methods

BarcodeLabel Methods
[image]

Protected Methods

Name | Description
OnRender | Control.OnRender override.

See Also

BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.OnRender Method

BarcodeLabel.OnRender Method
[image]

Control.OnRender override.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel Properties

BarcodeLabel Properties
[image]

Public Properties

Name | Description
BarColor | Gets or sets the color of barcode modules. This is a dependency property.
Content | Gets or sets the text or numeric code that should be represented as barcode symbol. This is a dependency property.
Format | Gets or sets the barcode format. This is a dependency property.
QRCorrectionLevel | Gets or sets the correction level of QR barcodes. This is a dependency property.

See Also

BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.BarColor Property

BarcodeLabel.BarColor Property
[image]

Gets or sets the color of barcode modules. This is a dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public Color BarColor { get; set; }

Visual Basic [image] Copy Code

Public Property BarColor As Color

Property Value

A Color object. The default is Black.

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.Content Property

BarcodeLabel.Content Property
[image]

Gets or sets the text or numeric code that should be represented as barcode symbol. This is a dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public string Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As String

Property Value

A string value. The default is an empty string.

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.Format Property

BarcodeLabel.Format Property
[image]

Gets or sets the barcode format. This is a dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public BarcodeFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As BarcodeFormat

Property Value

A member of the BarcodeFormat enumeration. The default is QR.

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.QRCorrectionLevel Property

BarcodeLabel.QRCorrectionLevel Property
[image]

Gets or sets the correction level of QR barcodes. This is a dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public CorrectionLevel QRCorrectionLevel { get; set; }

Visual Basic [image] Copy Code

Public Property QRCorrectionLevel As CorrectionLevel

Property Value

A member of the CorrectionLevel enumeration. The default is M.

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel Fields

BarcodeLabel Fields
[image]

Public Fields

Name | Description
BarColorProperty | Identifies the BarColor dependency property.
ContentProperty | Identifies the Content dependency property.
FormatProperty | Identifies the Format dependency property.
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.

See Also

BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.BarColorProperty Field

BarcodeLabel.BarColorProperty Field
[image]

Identifies the BarColor dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarColorProperty As DependencyProperty

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.ContentProperty Field

BarcodeLabel.ContentProperty Field
[image]

Identifies the Content dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.FormatProperty Field

BarcodeLabel.FormatProperty Field
[image]

Identifies the Format dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Barcodes.Wpf.BarcodeLabel.QRCorrectionLevelProperty Field

BarcodeLabel.QRCorrectionLevelProperty Field
[image]

Identifies the QRCorrectionLevel dependency property.

Namespace: MindFusion.Barcodes.Wpf
Assembly: MindFusion.Barcodes.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty QRCorrectionLevelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly QRCorrectionLevelProperty As DependencyProperty

See Also

BarcodeLabel Members
BarcodeLabel Class
MindFusion.Barcodes.Wpf Namespace


MindFusion.Charting.Wpf Namespace

MindFusion.Charting.Wpf Namespace
Classes Enumerations

Classes

Class | Description
Annotation | Represents an Annotation at a chart element.
AnnotationsCollection | Represents an observable collection of Annotation objects.
AxesChart | Base class for charts which support the Cartesian coordinate system.
AxesChart3D | Base class for 3D charts which support the Cartesian coordinate system.
AxesCollection | Represents an observable collection of Axis objects.
AxesSeries | Base class for series of charts that support the Cartesian coordinate system.
AxesSeries3D | Represents a series in an AxesChart3D chart.
Axis | Contains the settings of a chart axis.
Bar | Represents a bar in charts that show bars.
BarChart | Represents a bar chart.
BarChart3D | Represents a 3D bar chart.
BarElementCollection | Represents an observable collection of Bar objects.
BarSeries | Represents a series in a bar chart.
BoolToVisibilityConverter | Converts a bool value to a System.Windows.Visibility value.
BrushCollection | Represents an observable collection of Brush objects.
Bubble | Represents a bubble in bubble charts.
BubbleChart | Represents a bubble chart.
BubbleSeries | Represents a series in a bubble chart.
Candlestick | Represents a candlestick shape in financial charts.
CandlestickElementCollection | Represents an observable collection of Candlestick objects.
CandlestickSeries | Represents a data series rendered as candlestick chart.
Chart | Base class for all charts.
Chart3D | Base class for all 3D charts.
ChartElement | Base class for all graphical elements on the chart.
ChartHitTestResult3D | Contains the result of hit-testing operations in 3D charts.
ChartLegend | Describes a legend where each item gives info about a ChartSeries.
ChartSeries | Base class for Series in the chart.
ChartSeriesCollection | Represents an observable collection of ChartSeries objects.
ChartTheme | Represents a styling theme for the chart.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
CrosshairControl | Represents the crosshair
CrosshairPanel | Arrange child crosshair elements.
CrosshairPositionChangedArgs | Provides details about events triggered by movement of the crosshair.
CrosshairToVisibilityConverter | Converts values of the chart crosshair to a value of the Visibility enum.
CrosshairTypeToVisibilityConverter | Converts the type of the crosshair to visibility enum value.
FunnelChart | A control used to draw funnel charts. Funnel charts represent the stages of a process and show relative values or measurements associated with each stage.
FunnelPiece | Represents a segment of funnel chart.
FunnelSeries | Represents a series in a funnel chart.
LabelPresenter | Represents labels in a 3D chart.
LayoutPanel | Represents the panel of the whole chart.
Legend | A base class for classes that create legends in the chart.
LegendItem | Represents an item in a SeriesLegend.
LegendsCollection | Represents an observable collection of Legend objects.
Line | Represents a line in line charts.
LineChart | Represents a line chart.
LineSeries | Represents a series in a line chart.
Mesh | Generates a mesh in 3D charts.
MultiConverter | Converts multiple values.
PieChart | Represents a pie chart.
PieChart3D | Represents a 3D pie chart.
PieSeries | Represents a series in a pie chart.
PieSlice | Represents a slice in a pie chart.
PlotArea | Represents the plot area where the chart is drawn.
PointToDoubleConverter | Converts a System.Windows.Point object to a double value.
PointToMarginConverter | Converts the value of a Point to a Margin.
RadarChart | Represents a radar chart.
RadarSeries | Represents a series in a radar chart.
RectToDoubleConverter | Converts a Rect value to a double.
Scatter | Represents scatter marks drawn at data points in line charts.
SeriesLegend | Represents a legend with custom set labels and colors.
StockPrice | Represents a data object, containing open, close, low and high values for a certain date.
StringArrayConverter | Converts comma-separated string values to list of strings and vice versa.
SurfaceChart | Represents a 3D surface chart.
SurfaceSeries | Represents a series in a surface chart.
Triangle | Triangle class.
Vertex | Vertex class
XmlSerializationContext | Contains methods that can help you serialize and deserialize charts to and from XML documents.
ZoomChangedArgs | Provides arguments for ZoomChanged events.

Enumerations

Enumeration | Description
AnnotationType | Represents types of Annotation that are drawn.
BarModel3D | Specifies what models are used to represent bars in 3D barcharts.
BarType | Specifies the types of bar charts supported by the control.
BarType3D | Specifies the types of 3D bar charts supported by the control.
Behavior | Defines values that specify how the component responds to actions performed by the user.
Behavior3D | Specifies how 3D charts react to mouse input.
BubbleLabelType | Specifies the types of labels that can be drawn at the bubbles in a bubble chart.
BubbleScaleType | Specifies an algorithm for calculating the sizes of the bubbles in a bubble chart.
CameraType | Defines types of camera that can be used in a 3D chart.
ChartEffect | Specifies an effect that can be applied to the elements of a chart.
ChartEffect3D | Specifies a 3D effect in a surface chart.
CrosshairType | Identifies how the crosshair is rendered.
CustomLabelPosition | Specifies where custom labels are drawn.
GridType | Specifies the possible grid options for charts that support grid.
InnerLabelPosition | Defines values that specify the alignment of the inner labels in a radar chart.
InterpolationType | Defines shape types that are used when elevations are drawn at the surface chart.
LabelType | Specifies the different types of chart labels that can be drawn at the chart axes.
LightType | Defines light types that can be used in a 3D chart.
LineType | Specifies the type of the line chart.
PieType | Specifies the type of the pie chart.
RadarStyle | Defines values that specify how the radar graphic is drawn.
RadarType | Defines values that specify the type of the radar chart.
RoundCornerType | Specifies which corners of a 3D chart element are drawn rounded.
ScatterType | Specifies the types of scatter shapes supported by the control.
SliceLayout | Specifies how slices in a 3D pie chart are arranged vertically.
SurfaceType | Specifies the type of a surface chart.
TextureType | Specifies how to color a surface chart.
ToolTipType | Specifies the type of tooltips to display for the values in a chart series.
ValueFormat | Defines types of data related to a chart axis.


MindFusion.Charting.Wpf.Annotation Class

Annotation Class
[image]

Represents an Annotation at a chart element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Annotation : DependencyObject

Visual Basic [image] Copy Code

Public Class Annotation
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Charting.Wpf.Annotation

See Also

Annotation Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation Members

Annotation Members
Constructors Fields Properties Events
[image]

Represents an Annotation at a chart element.

The following tables list the members exposed by the Annotation type.

Public Constructors

Name | Description
Annotation | Creates a new instance of the Annotation class.

Public Fields

Name | Description
AnnotationTypeProperty | Identifies the AnnotationType dependency property.
FillProperty | Identifies the Fill dependency property.
IndexProperty | Identifies the Index dependency property.
LabelProperty | Identifies the Label dependency property.
SizeProperty | Identifies the Size dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
AnnotationType | Gets or sets the type of the Annotation label. This is a dependency property.
Fill | Gets or sets the fill of the Annotation. This is a dependency property.
Index | Gets or sets the zero-based index of the chart element where this Annotation is drawn. This is a dependency property.
Label | Gets or sets the Annotation label. This is a dependency property.
Size | Gets or sets the size of the Annotation. This is a dependency property.
Stroke | Gets or sets the stroke of the Annotation. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the Stroke for the Annotation. This is a dependency property.
Value | Gets or sets the value that indicates where to draw this Annotation. This is a dependency property.

Public Events

Name | Description
AnnotationChanged | Occurs when the Annotation has changed.

See Also

Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation Fields

Annotation Fields
[image]

Public Fields

Name | Description
AnnotationTypeProperty | Identifies the AnnotationType dependency property.
FillProperty | Identifies the Fill dependency property.
IndexProperty | Identifies the Index dependency property.
LabelProperty | Identifies the Label dependency property.
SizeProperty | Identifies the Size dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.AnnotationTypeProperty Field

Annotation.AnnotationTypeProperty Field
[image]

Identifies the AnnotationType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnnotationTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnnotationTypeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.FillProperty Field

Annotation.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.IndexProperty Field

Annotation.IndexProperty Field
[image]

Identifies the Index dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IndexProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.LabelProperty Field

Annotation.LabelProperty Field
[image]

Identifies the Label dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.SizeProperty Field

Annotation.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.StrokeProperty Field

Annotation.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.StrokeThicknessProperty Field

Annotation.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.ValueProperty Field

Annotation.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation Constructor

Annotation Constructor
[image]

Creates a new instance of the Annotation class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Annotation ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation Properties

Annotation Properties
[image]

Public Properties

Name | Description
AnnotationType | Gets or sets the type of the Annotation label. This is a dependency property.
Fill | Gets or sets the fill of the Annotation. This is a dependency property.
Index | Gets or sets the zero-based index of the chart element where this Annotation is drawn. This is a dependency property.
Label | Gets or sets the Annotation label. This is a dependency property.
Size | Gets or sets the size of the Annotation. This is a dependency property.
Stroke | Gets or sets the stroke of the Annotation. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the Stroke for the Annotation. This is a dependency property.
Value | Gets or sets the value that indicates where to draw this Annotation. This is a dependency property.

See Also

Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.AnnotationType Property

Annotation.AnnotationType Property
[image]

Gets or sets the type of the Annotation label. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AnnotationType AnnotationType { get; set; }

Visual Basic [image] Copy Code

Public Property AnnotationType As AnnotationType

Property Value

A member of the AnnotationType enumeration. The default is Empty.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Fill Property

Annotation.Fill Property
[image]

Gets or sets the fill of the Annotation. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A WPF System.Windows.Media.Brush object. The default is a solid red brush.

Remarks

The Fill is used or painting the interior of an Annotation shape when the AnnotationType is Point.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Index Property

Annotation.Index Property
[image]

Gets or sets the zero-based index of the chart element where this Annotation is drawn. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value. The default is -1.

Remarks

When the property is set to 0 in bar charts, the Annotation is drawn at the first bar and so on.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Label Property

Annotation.Label Property
[image]

Gets or sets the Annotation label. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string value. The default is an empty string.

Remarks

The Value property indicates where the Label will be drawn at the chart element.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Size Property

Annotation.Size Property
[image]

Gets or sets the size of the Annotation. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Double

Property Value

A double value. The default is 5.

Remarks

The Size property is used when the AnnotationType is set to Point.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Stroke Property

Annotation.Stroke Property
[image]

Gets or sets the stroke of the Annotation. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A WPF System.Windows.Media.Brush object. The default is a solid red brush.

Remarks

This property is used to draw annotations of type Stick as well the outline of point annotations.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.StrokeThickness Property

Annotation.StrokeThickness Property
[image]

Gets or sets the thickness of the Stroke for the Annotation. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.Value Property

Annotation.Value Property
[image]

Gets or sets the value that indicates where to draw this Annotation. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value. The default is 0.

Remarks

The location of the Annotation is calculated based on its Value. In a bar that represents value of 10, Annotation with value of 5 will be drawn in the middle of the bar.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation Events

Annotation Events
[image]

Public Events

Name | Description
AnnotationChanged | Occurs when the Annotation has changed.

See Also

Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Annotation.AnnotationChanged Event

Annotation.AnnotationChanged Event
[image]

Occurs when the Annotation has changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler AnnotationChanged

Visual Basic [image] Copy Code

Public Event AnnotationChanged As EventHandler

Remarks

This method is used internally by the control and is not intended to be called from your code.

See Also

Annotation Members
Annotation Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AnnotationsCollection Class

AnnotationsCollection Class
Remarks See Also
[image]

Represents an observable collection of Annotation objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class AnnotationsCollection : ObservableCollection<Annotation>

Visual Basic [image] Copy Code

Public Class AnnotationsCollection
Inherits ObservableCollection(Of Annotation)

Remarks

This class is used internally by the control and is not intended to be called from your code.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Annotation)
System.Collections.ObjectModel.ObservableCollection(Annotation)
MindFusion.Charting.Wpf.AnnotationsCollection

See Also

AnnotationsCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AnnotationsCollection Members

AnnotationsCollection Members
Constructors
[image]

Represents an observable collection of Annotation objects.

The following tables list the members exposed by the AnnotationsCollection type.

Public Constructors

Name | Description
AnnotationsCollection | Initializes a new instance of the AnnotationsCollection class.

See Also

AnnotationsCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AnnotationsCollection Constructor

AnnotationsCollection Constructor
[image]

Initializes a new instance of the AnnotationsCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AnnotationsCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

The AnnotationsCollection class is used internally by the control and is not intended to be called from your code.

See Also

AnnotationsCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AnnotationType Enumeration

AnnotationType Enumeration
[image]

Represents types of Annotation that are drawn.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum AnnotationType

Visual Basic [image] Copy Code

Public Enum AnnotationType

Members

Member name | Description
Empty | No annotation mark is drawn.
Point | The annotation mark is a point.
Stick | The annotation mark is a stick.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Class

AxesChart Class
[image]

Base class for charts which support the Cartesian coordinate system.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class AxesChart : Chart

Visual Basic [image] Copy Code

Public MustInherit Class AxesChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.AxesChart
MindFusion.Charting.Wpf.BarChart
MindFusion.Charting.Wpf.BubbleChart
MindFusion.Charting.Wpf.LineChart

See Also

AxesChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Members

AxesChart Members
Constructors Fields Properties Methods Events
[image]

Base class for charts which support the Cartesian coordinate system.

The following tables list the members exposed by the AxesChart type.

Public Constructors

Name | Description
AxesChart | Initializes a new instance of the AxesChart class.

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property.
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property.
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property.
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property.
CrosshairTypeProperty | Identifies the CrosshairType dependency property.
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property.
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property.
MousePositionProperty | Identifies the MousePosition dependency property.
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property.
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property.
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property.
XAxesProperty | Identifies the XAxes dependency property.
Y2AxesProperty | Identifies the Y2Axes dependency property.
YAxesProperty | Identifies the YAxes dependency property.

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series.
Behavior | Gets or sets the behavior of the chart control.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair.
CrosshairStroke | Gets or sets the stroke for the crosshair.
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair.
CrosshairTemplate | Gets or sets the crosshair template.
CrosshairType | Gets or sets the type of crosshair.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes.
GridStrokes | Gets or sets the brushes for the grid lines.
GridStrokeThickness | Gets or sets the thickness of grid lines.
GridType | Gets or sets the grid type.
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series.
MinZoomSpan | Gets or sets the area of zoom.
MousePosition | Gets or sets the position of the mouse.
PlotAreaFill | Gets or sets the background of the plot area.
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area.
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes.
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowCrosshair | Gets or sets whether the crosshair is visible.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart.
XAxes | Gets setttings for all X axes of the chart.
Y2Axes | Gets setttings for all Y2 axes of the chart.
YAxes | Gets setttings for all Y axes of the chart.

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap.
CrosshairPosition | Gets the current location of the crosshair.
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file.
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Control.OnApplyTemplate override.
OnAxesChanged | Raised when the axes has changed.
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event.
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart.
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics.
ZoomOut | Zooms out the chart one step back.

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control.
OnMouseLeave | Raised when the mouse leaves the chart area.
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control.
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control.
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart.

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event.
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range.

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Fields

AxesChart Fields
[image]

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property.
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property.
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property.
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property.
CrosshairTypeProperty | Identifies the CrosshairType dependency property.
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property.
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property.
MousePositionProperty | Identifies the MousePosition dependency property.
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property.
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property.
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property.
XAxesProperty | Identifies the XAxes dependency property.
Y2AxesProperty | Identifies the Y2Axes dependency property.
YAxesProperty | Identifies the YAxes dependency property.

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.BarTypeProperty Field

AxesChart.BarTypeProperty Field
[image]

Identifies the BarType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ClipToPlotAreaProperty Field

AxesChart.ClipToPlotAreaProperty Field
[image]

Identifies the GridType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipToPlotAreaProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipToPlotAreaProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairBackgroundProperty Field

AxesChart.CrosshairBackgroundProperty Field
[image]

Identifies the CrosshairBackground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairBackgroundProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairStrokeProperty Field

AxesChart.CrosshairStrokeProperty Field
[image]

Identifies the CrosshairStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairStrokeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairStrokeThicknessProperty Field

AxesChart.CrosshairStrokeThicknessProperty Field
[image]

Identifies the CrosshairStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairStrokeThicknessProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairTemplateProperty Field

AxesChart.CrosshairTemplateProperty Field
[image]

Identifies the CrosshairTemplate dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairTemplateProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairTypeProperty Field

AxesChart.CrosshairTypeProperty Field
[image]

Identifies the CrosshairType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridFillsProperty Field

AxesChart.GridFillsProperty Field
[image]

Identifies the GridFills dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridFillsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridStrokesProperty Field

AxesChart.GridStrokesProperty Field
[image]

Identifies the GridStrokes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridStrokeThicknessProperty Field

AxesChart.GridStrokeThicknessProperty Field
[image]

Identifies the GridStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokeThicknessProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridTypeProperty Field

AxesChart.GridTypeProperty Field
[image]

Identifies the GridType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.LineTypeProperty Field

AxesChart.LineTypeProperty Field
[image]

Identifies the LineType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LineTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LineTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.MinZoomSpanProperty Field

AxesChart.MinZoomSpanProperty Field
[image]

Identifies the MinZoomSpan dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinZoomSpanProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinZoomSpanProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.MousePositionProperty Field

AxesChart.MousePositionProperty Field
[image]

Identifies the MousePosition dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MousePositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MousePositionProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaFillProperty Field

AxesChart.PlotAreaFillProperty Field
[image]

Identifies the PlotAreaFill dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaFillProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaRectProperty Field

AxesChart.PlotAreaRectProperty Field
[image]

Identifies the PlotAreaRect dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaRectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaRectProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaStrokeProperty Field

AxesChart.PlotAreaStrokeProperty Field
[image]

Identifies the PlotAreaStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaStrokeThicknessProperty Field

AxesChart.PlotAreaStrokeThicknessProperty Field
[image]

Identifies the PlotAreaStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeThicknessProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.SecondaryGridFillsProperty Field

AxesChart.SecondaryGridFillsProperty Field
[image]

Identifies the SecondaryGridFills dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondaryGridFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SecondaryGridFillsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.SecondaryGridStrokesProperty Field

AxesChart.SecondaryGridStrokesProperty Field
[image]

Identifies the SecondaryGridStrokes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondaryGridStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SecondaryGridStrokesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ShowCrosshairProperty Field

AxesChart.ShowCrosshairProperty Field
[image]

Identifies the ShowCrosshair dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCrosshairProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCrosshairProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.X2AxesProperty Field

AxesChart.X2AxesProperty Field
[image]

Identifies the X2Axes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2AxesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2AxesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.XAxesProperty Field

AxesChart.XAxesProperty Field
[image]

Identifies the XAxes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.Y2AxesProperty Field

AxesChart.Y2AxesProperty Field
[image]

Identifies the Y2Axes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2AxesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2AxesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.YAxesProperty Field

AxesChart.YAxesProperty Field
[image]

Identifies the YAxes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Constructor

AxesChart Constructor
[image]

Initializes a new instance of the AxesChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Methods

AxesChart Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap.
CrosshairPosition | Gets the current location of the crosshair.
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file.
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Control.OnApplyTemplate override.
OnAxesChanged | Raised when the axes has changed.
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event.
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart.
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics.
ZoomOut | Zooms out the chart one step back.

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control.
OnMouseLeave | Raised when the mouse leaves the chart area.
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control.
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control.
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart.

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CreateImage Method

AxesChart.CreateImage Method
[image]

Converts the chart object into a Bitmap.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RenderTargetBitmap CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As RenderTargetBitmap

Return Value

A RenderTargetBitmap that represents the current chart.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairPosition Method

AxesChart.CrosshairPosition Method
[image]

Gets the current location of the crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Point> CrosshairPosition (
AxesSeries series,
Point mousePos
)

Visual Basic [image] Copy Code

Public Function CrosshairPosition( _
series As AxesSeries, _
mousePos As Point _
) As Nullable(Of Point)

Parameters

series

The series.

mousePos

The position of the mouse.

Return Value

The location of the crosshair measured in the Cartesian coordinate system.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ExportImage Method

AxesChart.ExportImage Method
[image]

Exports a RenderTargetBitmap to a png file.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void ExportImage (
RenderTargetBitmap rtb,
int testNumber
)

Visual Basic [image] Copy Code

Public Sub ExportImage( _
rtb As RenderTargetBitmap, _
testNumber As Integer _
)

Parameters

rtb

The RenderTargetBitmap to export.

testNumber

The extension of the name for the exported image.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnApplyTemplate Method

AxesChart.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnAxesChanged Method

AxesChart.OnAxesChanged Method
[image]

Raised when the axes has changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static void OnAxesChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnAxesChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The Axis that raised the event.

e

An object with event data.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnCrosshairPositionChanged Method

AxesChart.OnCrosshairPositionChanged Method
[image]

Triggers the CrosshairPositionChanged event.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void OnCrosshairPositionChanged (
CrosshairPositionChangedArgs eventArgs
)

Visual Basic [image] Copy Code

Public Sub OnCrosshairPositionChanged( _
eventArgs As CrosshairPositionChangedArgs _
)

Parameters

eventArgs

CrosshairPositionChangedArgs object with data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnMouseEnter Method

AxesChart.OnMouseEnter Method
[image]

Raised when the mouse enters the control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseEnter (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseEnter( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnMouseLeave Method

AxesChart.OnMouseLeave Method
[image]

Raised when the mouse leaves the chart area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeave (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeave( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnPreviewMouseDown Method

AxesChart.OnPreviewMouseDown Method
[image]

Raised when the left mouse button is pressed while the pointer is over this control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

An instance of the MouseButtonEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnPreviewMouseMove Method

AxesChart.OnPreviewMouseMove Method
[image]

Raised when the mouse pointer moves while the mouse pointer is over the chart control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.OnPreviewMouseUp Method

AxesChart.OnPreviewMouseUp Method
[image]

Raised when the left mouse button is released while the mouse pointer is over the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

An instance of the MouseButtonEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ResetZoom Method

AxesChart.ResetZoom Method
[image]

Resets the zoom of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void ResetZoom ()

Visual Basic [image] Copy Code

Public Sub ResetZoom ()

Remarks

Resets the chart to its original state before zooming has started.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.Zoom Method

AxesChart.Zoom Method
[image]

Zooms into the specified range of the chart graphics.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Zoom (
Point selectionStart,
Point selectionEnd
)

Visual Basic [image] Copy Code

Public Sub Zoom( _
selectionStart As Point, _
selectionEnd As Point _
)

Parameters

selectionStart

The start of the range to zoom into.

selectionEnd

The end of the range to zoom into.

Remarks

This method is used internally by the control and is not intended to be called within your code.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ZoomOut Method

AxesChart.ZoomOut Method
[image]

Zooms out the chart one step back.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void ZoomOut ()

Visual Basic [image] Copy Code

Public Sub ZoomOut ()

Remarks

Call ResetZoom to set the chart to its original state at once.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Properties

AxesChart Properties
[image]

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series.
Behavior | Gets or sets the behavior of the chart control.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair.
CrosshairStroke | Gets or sets the stroke for the crosshair.
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair.
CrosshairTemplate | Gets or sets the crosshair template.
CrosshairType | Gets or sets the type of crosshair.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes.
GridStrokes | Gets or sets the brushes for the grid lines.
GridStrokeThickness | Gets or sets the thickness of grid lines.
GridType | Gets or sets the grid type.
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series.
MinZoomSpan | Gets or sets the area of zoom.
MousePosition | Gets or sets the position of the mouse.
PlotAreaFill | Gets or sets the background of the plot area.
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area.
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes.
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowCrosshair | Gets or sets whether the crosshair is visible.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart.
XAxes | Gets setttings for all X axes of the chart.
Y2Axes | Gets setttings for all Y2 axes of the chart.
YAxes | Gets setttings for all Y axes of the chart.

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.BarType Property

AxesChart.BarType Property
[image]

Gets or sets the type of bars for all bar series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarType BarType { get; set; }

Visual Basic [image] Copy Code

Public Property BarType As BarType

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.Behavior Property

AxesChart.Behavior Property
[image]

Gets or sets the behavior of the chart control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration. Default value is DoNothing.

Remarks

The property specifies the behavior of the chart and is used when you want to switch to zoom mode and vice versa.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ClipToPlotArea Property

AxesChart.ClipToPlotArea Property
[image]

Clip all data in bounds of the plot area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ClipToPlotArea { get; set; }

Visual Basic [image] Copy Code

Public Property ClipToPlotArea As Boolean

Property Value

true to clip chart contents within the plot area; otherwise, false. The default is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairBackground Property

AxesChart.CrosshairBackground Property
[image]

Gets or sets the background brush of the crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush CrosshairBackground { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairBackground As Brush

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairStroke Property

AxesChart.CrosshairStroke Property
[image]

Gets or sets the stroke for the crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush CrosshairStroke { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.Red.

Remarks

Use ShowCrosshair to enable the tracking cursor.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairStrokeThickness Property

AxesChart.CrosshairStrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double CrosshairStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairStrokeThickness As Double

Property Value

A double value. The default value is 2.0.

Remarks

Use ShowCrosshair to enable the tracking cursor.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairTemplate Property

AxesChart.CrosshairTemplate Property
[image]

Gets or sets the crosshair template.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ControlTemplate CrosshairTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairTemplate As ControlTemplate

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairType Property

AxesChart.CrosshairType Property
[image]

Gets or sets the type of crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairType CrosshairType { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairType As CrosshairType

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridFills Property

AxesChart.GridFills Property
[image]

Gets or sets the brushes for the grid stripes.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> GridFills { get; set; }

Visual Basic [image] Copy Code

Public Property GridFills As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

Remarks

Each stripe in the chart grid is drawn with a subsequent Brush taken from GridFills. If the count of brushes is smaller than the count of grid stripes the control cycles through them.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridStrokes Property

AxesChart.GridStrokes Property
[image]

Gets or sets the brushes for the grid lines.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> GridStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokes As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

Remarks

Each line in the chart grid is drawn with a subsequent Brush from the GridStrokes collection. If the count of brushes is less than the count of grid lines the control cycles through them.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridStrokeThickness Property

AxesChart.GridStrokeThickness Property
[image]

Gets or sets the thickness of grid lines.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GridStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.GridType Property

AxesChart.GridType Property
[image]

Gets or sets the grid type.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public GridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As GridType

Property Value

A member of the GridType enumeration. The default is Horizontal.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.LineType Property

AxesChart.LineType Property
[image]

Gets or sets the type of lines for all line series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LineType LineType { get; set; }

Visual Basic [image] Copy Code

Public Property LineType As LineType

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.MinZoomSpan Property

AxesChart.MinZoomSpan Property
[image]

Gets or sets the area of zoom.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MinZoomSpan { get; set; }

Visual Basic [image] Copy Code

Public Property MinZoomSpan As Double

Property Value

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.MousePosition Property

AxesChart.MousePosition Property
[image]

Gets or sets the position of the mouse.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

An instance of the System.Windows.Point structure.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaFill Property

AxesChart.PlotAreaFill Property
[image]

Gets or sets the background of the plot area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush PlotAreaFill { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaFill As Brush

Property Value

A WPF Brush object. The default is null (Nothing in Visual Basic).

Remarks

The PlotAreaFill Brush paints the rectangle created by the axes in charts that use the Cartesian coordinate system.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaStroke Property

AxesChart.PlotAreaStroke Property
[image]

Gets or sets the outline of the plot area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush PlotAreaStroke { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStroke As Brush

Property Value

A WPF Brush object. The default is a solid gray brush.

Remarks

PlotAreaStroke draws the outlining of the plot area in charts that use the Cartesian coordinate system. Plot area is called the area between the axes.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PlotAreaStrokeThickness Property

AxesChart.PlotAreaStrokeThickness Property
[image]

Gets or sets the thickness of the outline of the plot area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness PlotAreaStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStrokeThickness As Thickness

Property Value

A WPF Thickness object. The default is Thickness(2, 0, 0, 2).

Remarks

PlotAreaStrokeThickness specifies the width of the Brush that outlines the plot area in charts that use the Cartesian coordinate system.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.PointAreaRadius Property

AxesChart.PointAreaRadius Property
[image]

Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double PointAreaRadius { get; set; }

Visual Basic [image] Copy Code

Public Property PointAreaRadius As Double

Property Value

A double value. The default is 10.

Remarks

The property is used when the control handles mouse input from the user.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.SecondaryGridFills Property

AxesChart.SecondaryGridFills Property
[image]

Gets or sets the secondary brushes for the grid stripes.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> SecondaryGridFills { get; set; }

Visual Basic [image] Copy Code

Public Property SecondaryGridFills As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.SecondaryGridStrokes Property

AxesChart.SecondaryGridStrokes Property
[image]

Gets or sets the secondary brushes for the grid lines.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> SecondaryGridStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property SecondaryGridStrokes As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ShowCrosshair Property

AxesChart.ShowCrosshair Property
[image]

Gets or sets whether the crosshair is visible.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowCrosshair { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCrosshair As Boolean

Property Value

A bool value. The default value is false.

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.X2Axes Property

AxesChart.X2Axes Property
[image]

Gets setttings for all X2 axes of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesCollection X2Axes { get; set; }

Visual Basic [image] Copy Code

Public Property X2Axes As AxesCollection

Property Value

A strongly typed collection of Axis objects.

Remarks

When customizing Axis in XAML assign a whole collection to the property. This will reset it and clear any default Axis that might have been added.

XAML [image] Copy Code

<chart:AxesCollection>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:AxesCollection>

When working in code you should also clear the predefined axes:

C# [image] Copy Code

barChart1.XAxes.Clear();

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.XAxes Property

AxesChart.XAxes Property
[image]

Gets setttings for all X axes of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesCollection XAxes { get; set; }

Visual Basic [image] Copy Code

Public Property XAxes As AxesCollection

Property Value

A strongly typed collection of Axis objects.

Remarks

When customizing Axis in XAML assign a whole collection to the property. This will reset it and clear any default Axis that might have been added.

XAML [image] Copy Code

<chart:AxesCollection>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:AxesCollection>

When working in code you should also clear the predefined axes:

C# [image] Copy Code

barChart1.XAxes.Clear();

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.Y2Axes Property

AxesChart.Y2Axes Property
[image]

Gets setttings for all Y2 axes of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesCollection Y2Axes { get; set; }

Visual Basic [image] Copy Code

Public Property Y2Axes As AxesCollection

Property Value

A list of strongly typed Axis objects.

Remarks

When customizing Axis in XAML assign a whole collection to the property. This will reset it and clear any default Axis that might have been added.

XAML [image] Copy Code

<chart:AxesCollection>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:AxesCollection>

When working in code you should also clear the predefined axes:

C# [image] Copy Code

barChart1.XAxes.Clear();

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.YAxes Property

AxesChart.YAxes Property
[image]

Gets setttings for all Y axes of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesCollection YAxes { get; set; }

Visual Basic [image] Copy Code

Public Property YAxes As AxesCollection

Property Value

A strongly typed collection of Axis objects.

Remarks

When customizing Axis in XAML assign a whole collection to the property. This will reset it and clear any default Axis that might have been added.

XAML [image] Copy Code

<chart:AxesCollection>
<chart:Axis MinValue="0" MaxValue="100" Interval="10" LabelType="AutoScale" LabelRotationAngle="40.0"></chart:Axis>
</chart:AxesCollection>

When working in code you should also clear the predefined axes:

C# [image] Copy Code

barChart1.XAxes.Clear();

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart Events

AxesChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event.
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range.

See Also

AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.AppearanceChanged Event

Chart.AppearanceChanged Event
[image]

Occurs when the value of a property that influences the appearance of the chart changes.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler AppearanceChanged

Visual Basic [image] Copy Code

Public Event AppearanceChanged As PropertyChangedEventHandler

Event Data

AppearanceChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.CrosshairPositionChanged Event

AxesChart.CrosshairPositionChanged Event
[image]

Event handler for the CrosshairPositionChanged event.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CrosshairPositionChangedArgs> CrosshairPositionChanged

Visual Basic [image] Copy Code

Public Event CrosshairPositionChanged As EventHandler(Of CrosshairPositionChangedArgs)

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.DataChanged Event

Chart.DataChanged Event
[image]

Occurs when the data for the chart has changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

Event Data

DataChanged event handlers receive an argument of type EventArgs.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart.ZoomChanged Event

AxesChart.ZoomChanged Event
[image]

Raised when zooming into a data range.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ZoomChangedArgs> ZoomChanged

Visual Basic [image] Copy Code

Public Event ZoomChanged As EventHandler(Of ZoomChangedArgs)

See Also

AxesChart Members
AxesChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Class

AxesChart3D Class
[image]

Base class for 3D charts which support the Cartesian coordinate system.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class AxesChart3D : Chart3D

Visual Basic [image] Copy Code

Public MustInherit Class AxesChart3D
Inherits Chart3D

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart3D
MindFusion.Charting.Wpf.AxesChart3D
MindFusion.Charting.Wpf.BarChart3D
MindFusion.Charting.Wpf.SurfaceChart

See Also

AxesChart3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Members

AxesChart3D Members
Constructors Fields Properties Methods
[image]

Base class for 3D charts which support the Cartesian coordinate system.

The following tables list the members exposed by the AxesChart3D type.

Public Constructors

Name | Description
AxesChart3D | Initializes a new instance of the AxesChart3D class.

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SideWallThicknessProperty | Identifies the SideWallThickness dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property.
X2LabelPathProperty | Identifies the X2LabelPath dependency property.
X2LabelsProperty | Identifies the X2Labels dependency property.
XAxisSettingsProperty | Identifies the XAxisSettings dependency property.
XLabelPathProperty | Identifies the XLabelPath dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property.
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property.
Y2LabelsProperty | Identifies the Y2Labels dependency property.
YAxisSettingsProperty | Identifies the YAxisSettings dependency property.
YLabelPathProperty | Identifies the YLabelPath dependency property.
YLabelsProperty | Identifies the YLabels dependency property.
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property.
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property.
Z2LabelsProperty | Identifies the Z2Labels dependency property.
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property.
ZLabelPathProperty | Identifies the ZLabelPath dependency property.
ZLabelsProperty | Identifies the ZLabels dependency property.

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property.
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property.
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property.
GridType | Gets or sets the grid type. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property.
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property.
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property.
XAxisSettings | Gets the settings for the X-axis. This is a dependency property.
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property.
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property.
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property.
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property.
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property.
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property.
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property.
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property.
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property.
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property.
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property.
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property.
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property.
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property.

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | Gets a ChartHitTestResult3D object that contains the result of the hit-test operation.
OnApplyTemplate | Chart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Fields

AxesChart3D Fields
[image]

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SideWallThicknessProperty | Identifies the SideWallThickness dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property.
X2LabelPathProperty | Identifies the X2LabelPath dependency property.
X2LabelsProperty | Identifies the X2Labels dependency property.
XAxisSettingsProperty | Identifies the XAxisSettings dependency property.
XLabelPathProperty | Identifies the XLabelPath dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property.
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property.
Y2LabelsProperty | Identifies the Y2Labels dependency property.
YAxisSettingsProperty | Identifies the YAxisSettings dependency property.
YLabelPathProperty | Identifies the YLabelPath dependency property.
YLabelsProperty | Identifies the YLabels dependency property.
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property.
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property.
Z2LabelsProperty | Identifies the Z2Labels dependency property.
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property.
ZLabelPathProperty | Identifies the ZLabelPath dependency property.
ZLabelsProperty | Identifies the ZLabels dependency property.

See Also

AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridFillsProperty Field

AxesChart3D.GridFillsProperty Field
[image]

Identifies the GridFills dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridFillsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridStrokesProperty Field

AxesChart3D.GridStrokesProperty Field
[image]

Identifies the GridStrokes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokesProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridStrokeThicknessProperty Field

AxesChart3D.GridStrokeThicknessProperty Field
[image]

Identifies the GridStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokeThicknessProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridTypeProperty Field

AxesChart3D.GridTypeProperty Field
[image]

Identifies the GridType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridTypeProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.SideWallThicknessProperty Field

AxesChart3D.SideWallThicknessProperty Field
[image]

Identifies the SideWallThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SideWallThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SideWallThicknessProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2AxisSettingsProperty Field

AxesChart3D.X2AxisSettingsProperty Field
[image]

Identifies the X2AxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2AxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2AxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2LabelPathProperty Field

AxesChart3D.X2LabelPathProperty Field
[image]

Identifies the X2LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2LabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2LabelsProperty Field

AxesChart3D.X2LabelsProperty Field
[image]

Identifies the X2Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2LabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XAxisSettingsProperty Field

AxesChart3D.XAxisSettingsProperty Field
[image]

Identifies the XAxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XLabelPathProperty Field

AxesChart3D.XLabelPathProperty Field
[image]

Identifies the XLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XLabelsProperty Field

AxesChart3D.XLabelsProperty Field
[image]

Identifies the XLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2AxisSettingsProperty Field

AxesChart3D.Y2AxisSettingsProperty Field
[image]

Identifies the Y2AxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2AxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2AxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2LabelPathProperty Field

AxesChart3D.Y2LabelPathProperty Field
[image]

Identifies the Y2LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2LabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2LabelsProperty Field

AxesChart3D.Y2LabelsProperty Field
[image]

Identifies the Y2Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2LabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YAxisSettingsProperty Field

AxesChart3D.YAxisSettingsProperty Field
[image]

Identifies the YAxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YLabelPathProperty Field

AxesChart3D.YLabelPathProperty Field
[image]

Identifies the YLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YLabelsProperty Field

AxesChart3D.YLabelsProperty Field
[image]

Identifies the YLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2AxisSettingsProperty Field

AxesChart3D.Z2AxisSettingsProperty Field
[image]

Identifies the Z2AxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Z2AxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Z2AxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2LabelPathProperty Field

AxesChart3D.Z2LabelPathProperty Field
[image]

Identifies the Z2LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Z2LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Z2LabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2LabelsProperty Field

AxesChart3D.Z2LabelsProperty Field
[image]

Identifies the Z2Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Z2LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Z2LabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZAxisSettingsProperty Field

AxesChart3D.ZAxisSettingsProperty Field
[image]

Identifies the ZAxisSettings dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZAxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZAxisSettingsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZLabelPathProperty Field

AxesChart3D.ZLabelPathProperty Field
[image]

Identifies the ZLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZLabelPathProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZLabelsProperty Field

AxesChart3D.ZLabelsProperty Field
[image]

Identifies the ZLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZLabelsProperty As DependencyProperty

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Constructor

AxesChart3D Constructor
[image]

Initializes a new instance of the AxesChart3D class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesChart3D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Methods

AxesChart3D Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | Gets a ChartHitTestResult3D object that contains the result of the hit-test operation.
OnApplyTemplate | Chart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.HitTest Method

AxesChart3D.HitTest Method
[image]

Gets a ChartHitTestResult3D object that contains the result of the hit-test operation.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override ChartHitTestResult3D HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
p As Point _
) As ChartHitTestResult3D

Parameters

p

The point to test.

Return Value

An instance of the ChartHitTestResult3D class.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.OnApplyTemplate Method

AxesChart3D.OnApplyTemplate Method
[image]

Chart3D.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D Properties

AxesChart3D Properties
[image]

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property.
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property.
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property.
GridType | Gets or sets the grid type. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property.
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property.
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property.
XAxisSettings | Gets the settings for the X-axis. This is a dependency property.
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property.
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property.
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property.
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property.
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property.
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property.
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property.
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property.
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property.
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property.
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property.
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property.
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property.
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property.

See Also

AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridFills Property

AxesChart3D.GridFills Property
[image]

Gets or sets the brushes for the grid stripes. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> GridFills { get; set; }

Visual Basic [image] Copy Code

Public Property GridFills As List(Of Brush)

Property Value

A list of WPF Brush objects.

Remarks

Each stripe in the chart grid is drawn with a subsequent Brush taken from GridFills. If the count of brushes is smaller than the count of grid stripes the control cycles through them.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridStrokes Property

AxesChart3D.GridStrokes Property
[image]

Gets or sets the brushes for the grid lines. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> GridStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokes As List(Of Brush)

Property Value

A list of WPF Brush objects.

Remarks

Each line in the chart grid is drawn with a subsequent Brush from the GridStrokes collection. If the count of brushes is less than the count of grid lines the control cycles through them.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridStrokeThickness Property

AxesChart3D.GridStrokeThickness Property
[image]

Gets or sets the thickness of grid lines. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GridStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokeThickness As Double

Property Value

A double value. The default is 0.3.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.GridType Property

AxesChart3D.GridType Property
[image]

Gets or sets the grid type. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public GridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As GridType

Property Value

A member of the GridType enumeration. The default is Horizontal.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.SideWallThickness Property

AxesChart3D.SideWallThickness Property
[image]

Gets or sets the thickness of the side walls. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SideWallThickness { get; set; }

Visual Basic [image] Copy Code

Public Property SideWallThickness As Double

Property Value

A double value. The default is 1.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2AxisSettings Property

AxesChart3D.X2AxisSettings Property
[image]

Gets the settings for the secondary X-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis X2AxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property X2AxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2LabelPath Property

AxesChart3D.X2LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string X2LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property X2LabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.X2Labels Property

AxesChart3D.X2Labels Property
[image]

Gets or sets the custom labels for the X2-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList X2Labels { get; set; }

Visual Basic [image] Copy Code

Public Property X2Labels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

If the list contains objects other than strings, they will be converted to strings using their ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XAxisSettings Property

AxesChart3D.XAxisSettings Property
[image]

Gets the settings for the X-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis XAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XLabelPath Property

AxesChart3D.XLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string XLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property XLabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

The labels are drawn when the XAxisSettings.LabelType property is set to CustomText.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.XLabels Property

AxesChart3D.XLabels Property
[image]

Gets or sets the custom labels for the X-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList XLabels { get; set; }

Visual Basic [image] Copy Code

Public Property XLabels As IList

Property Value

A list of objects to use as labels. The default is a list with four strings {"Jan", "Feb", "March", "April"}.

Remarks

The labels are painted at the X-axis when the XAxisSettings.LabelType property is set to CustomText. Objects of any type are supported. Non-string objects are converted using their ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2AxisSettings Property

AxesChart3D.Y2AxisSettings Property
[image]

Gets the settings for the secondary Y-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis Y2AxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property Y2AxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

When the MinValue and MaxValue of Y2AxisSettings are set, the Y2-axis is drawn even when there is no AxesSeries whose Y2Data is set.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2LabelPath Property

AxesChart3D.Y2LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Y2LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property Y2LabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Y2Labels Property

AxesChart3D.Y2Labels Property
[image]

Gets or sets the custom labels for the Y2-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Y2Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Y2Labels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

If the list contains objects other than strings, they will be converted to strings using their ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YAxisSettings Property

AxesChart3D.YAxisSettings Property
[image]

Gets the settings for the Y-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis YAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YLabelPath Property

AxesChart3D.YLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string YLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property YLabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

The labels are drawn when the YAxisSettings.LabelType property is set to CustomText.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.YLabels Property

AxesChart3D.YLabels Property
[image]

Gets or sets the custom labels for the Y-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList YLabels { get; set; }

Visual Basic [image] Copy Code

Public Property YLabels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

The labels are painted at the Y-axis when the value of the YAxisSettings.LabelType property is set to CustomText. The list can hold any type of objects. Non-string objects are converted to strings using the standard ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2AxisSettings Property

AxesChart3D.Z2AxisSettings Property
[image]

Gets the settings for the secondary Z-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis Z2AxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property Z2AxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2LabelPath Property

AxesChart3D.Z2LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Z2LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property Z2LabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.Z2Labels Property

AxesChart3D.Z2Labels Property
[image]

Gets or sets the custom labels for the Z2-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Z2Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Z2Labels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

If the list contains objects other than strings, they will be converted to strings using their ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZAxisSettings Property

AxesChart3D.ZAxisSettings Property
[image]

Gets the settings for the Z-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis ZAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property ZAxisSettings As Axis

Property Value

An instance of the AxisSettings class.

Remarks

The AxisSettings object specifies all types of appearance settings for the axis: type of labels, minimum and maximum value of the scale, interval, title, tick length, axis length and more.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZLabelPath Property

AxesChart3D.ZLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string ZLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property ZLabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

The property is used in data binding.

The labels are drawn when the ZAxisSettings.LabelType property is set to CustomText.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesChart3D.ZLabels Property

AxesChart3D.ZLabels Property
[image]

Gets or sets the custom labels for the Z-axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList ZLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ZLabels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

If the list contains objects other than strings, they will be converted to strings using their ToString method.

See Also

AxesChart3D Members
AxesChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesCollection Class

AxesCollection Class
[image]

Represents an observable collection of Axis objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class AxesCollection : ObservableCollection<Axis>

Visual Basic [image] Copy Code

Public Class AxesCollection
Inherits ObservableCollection(Of Axis)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Axis)
System.Collections.ObjectModel.ObservableCollection(Axis)
MindFusion.Charting.Wpf.AxesCollection

See Also

AxesCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesCollection Members

AxesCollection Members
Constructors
[image]

Represents an observable collection of Axis objects.

The following tables list the members exposed by the AxesCollection type.

Public Constructors

Name | Description
AxesCollection | Initializes a new instance of the AxesCollection class.

See Also

AxesCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesCollection Constructor

AxesCollection Constructor
[image]

Initializes a new instance of the AxesCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxesCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Class

AxesSeries Class
[image]

Base class for series of charts that support the Cartesian coordinate system.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class AxesSeries : ChartSeries

Visual Basic [image] Copy Code

Public MustInherit Class AxesSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.AxesSeries3D
MindFusion.Charting.Wpf.BarSeries
MindFusion.Charting.Wpf.BubbleSeries
MindFusion.Charting.Wpf.CandlestickSeries
MindFusion.Charting.Wpf.LineSeries

See Also

AxesSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Members

AxesSeries Members
Constructors Fields Properties Events
[image]

Base class for series of charts that support the Cartesian coordinate system.

The following tables list the members exposed by the AxesSeries type.

Protected Constructors

Name | Description
AxesSeries | Overloaded.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property.
XDataPathProperty | Identifies the XDataPath dependency property.
XDataProperty | Identifies the XData dependency property.
YAxisProperty | Identifies the YAxis dependency property.
YDataPathProperty | Identifies the YDataPath dependency property.
YDataProperty | Identifies the YData dependency property.

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis |
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property.
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property.
YAxis |
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property.
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property.

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Fields

AxesSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property.
XDataPathProperty | Identifies the XDataPath dependency property.
XDataProperty | Identifies the XData dependency property.
YAxisProperty | Identifies the YAxis dependency property.
YDataPathProperty | Identifies the YDataPath dependency property.
YDataProperty | Identifies the YData dependency property.

See Also

AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XAxisProperty Field

AxesSeries.XAxisProperty Field
[image]

Identifies the XAxis dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XDataPathProperty Field

AxesSeries.XDataPathProperty Field
[image]

Identifies the XDataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XDataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XDataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XDataProperty Field

AxesSeries.XDataProperty Field
[image]

Identifies the XData dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XDataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YAxisProperty Field

AxesSeries.YAxisProperty Field
[image]

Identifies the YAxis dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxisProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YDataPathProperty Field

AxesSeries.YDataPathProperty Field
[image]

Identifies the YDataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YDataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YDataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YDataProperty Field

AxesSeries.YDataProperty Field
[image]

Identifies the YData dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YDataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Constructor

AxesSeries Constructor
[image]

Overload List

Name | Description
AxesSeries () | Initializes a new instance of the AxesSeries class.
AxesSeries (Axis, Axis) | Initializes a new instance of the AxesSeries class.

See Also

AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Constructor ()

AxesSeries Constructor ()
See Also
[image]

Initializes a new instance of the AxesSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected AxesSeries ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

AxesSeries Constructor Overload List
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Constructor (Axis, Axis)

AxesSeries Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the AxesSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected AxesSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Protected New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

AxesSeries Constructor Overload List
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Properties

AxesSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis |
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property.
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property.
YAxis |
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property.
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property.

See Also

AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XAxis Property

AxesSeries.XAxis Property
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XData Property

AxesSeries.XData Property
[image]

Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As DoubleCollection

Property Value

An instance of the WPF System.Windows.Media.DoubleCollection class. The default is an empty collection.

Remarks

If used in XAML the XData property is parsed using the WPF DoubleCollectionConverter class.

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.XDataPath Property

AxesSeries.XDataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string XDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property XDataPath As String

Property Value

A string value. The default is an empty string.

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YAxis Property

AxesSeries.YAxis Property
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis YAxis { get; set; }

Visual Basic [image] Copy Code

Public Property YAxis As Axis

Property Value

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YData Property

AxesSeries.YData Property
[image]

Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As DoubleCollection

Property Value

An instance of the WPF System.Windows.Media.DoubleCollection class. The default is an empty collection.

Remarks

If used in XAML the YData property is parsed using the WPF DoubleCollectionConverter class.

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries.YDataPath Property

AxesSeries.YDataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string YDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property YDataPath As String

Property Value

A string value. The default is an empty string.

See Also

AxesSeries Members
AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries Events

AxesSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

AxesSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.AppearanceChanged Event

ChartSeries.AppearanceChanged Event
[image]

Occurs when series appearance was changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler AppearanceChanged

Visual Basic [image] Copy Code

Public Event AppearanceChanged As PropertyChangedEventHandler

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.DataChanged Event

ChartSeries.DataChanged Event
[image]

Occurs when series data was changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Class

AxesSeries3D Class
[image]

Represents a series in an AxesChart3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class AxesSeries3D : AxesSeries

Visual Basic [image] Copy Code

Public MustInherit Class AxesSeries3D
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.AxesSeries3D
MindFusion.Charting.Wpf.SurfaceSeries

See Also

AxesSeries3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Members

AxesSeries3D Members
Constructors Fields Properties Events
[image]

Represents a series in an AxesChart3D chart.

The following tables list the members exposed by the AxesSeries3D type.

Protected Constructors

Name | Description
AxesSeries3D | Overloaded.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)
Z2DataPathProperty | Identifies the Z2DataPath dependency property.
Z2DataProperty | Identifies the Z2Data dependency property.
ZDataPathProperty | Identifies the ZDataPath dependency property.
ZDataProperty | Identifies the ZData dependency property.

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)
Z2Data | Gets or sets the data used for calculating the Z2-coordinates of data points. This is a dependency property.
Z2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z2-data for this series. This is a dependency property.
ZData | Gets or sets the data used for calculating the Z-coordinates of data points. This is a dependency property.
ZDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z-data for this series. This is a dependency property.

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Fields

AxesSeries3D Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)
Z2DataPathProperty | Identifies the Z2DataPath dependency property.
Z2DataProperty | Identifies the Z2Data dependency property.
ZDataPathProperty | Identifies the ZDataPath dependency property.
ZDataProperty | Identifies the ZData dependency property.

See Also

AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.Z2DataPathProperty Field

AxesSeries3D.Z2DataPathProperty Field
[image]

Identifies the Z2DataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Z2DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Z2DataPathProperty As DependencyProperty

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.Z2DataProperty Field

AxesSeries3D.Z2DataProperty Field
[image]

Identifies the Z2Data dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Z2DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Z2DataProperty As DependencyProperty

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.ZDataPathProperty Field

AxesSeries3D.ZDataPathProperty Field
[image]

Identifies the ZDataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZDataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZDataPathProperty As DependencyProperty

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.ZDataProperty Field

AxesSeries3D.ZDataProperty Field
[image]

Identifies the ZData dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZDataProperty As DependencyProperty

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Constructor

AxesSeries3D Constructor
[image]

Overload List

Name | Description
AxesSeries3D () | Initializes a new instance of the AxesSeries3D class.
AxesSeries3D (Axis, Axis) | Initializes a new instance of the AxesSeries3D class.

See Also

AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Constructor ()

AxesSeries3D Constructor ()
See Also
[image]

Initializes a new instance of the AxesSeries3D class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected AxesSeries3D ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

AxesSeries3D Constructor Overload List
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Constructor (Axis, Axis)

AxesSeries3D Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the AxesSeries3D class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected AxesSeries3D (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Protected New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

AxesSeries3D Constructor Overload List
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Properties

AxesSeries3D Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)
Z2Data | Gets or sets the data used for calculating the Z2-coordinates of data points. This is a dependency property.
Z2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z2-data for this series. This is a dependency property.
ZData | Gets or sets the data used for calculating the Z-coordinates of data points. This is a dependency property.
ZDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z-data for this series. This is a dependency property.

See Also

AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.Z2Data Property

AxesSeries3D.Z2Data Property
[image]

Gets or sets the data used for calculating the Z2-coordinates of data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection Z2Data { get; set; }

Visual Basic [image] Copy Code

Public Property Z2Data As DoubleCollection

Property Value

A WPF DoubleCollection object. The default is an empty collection.

Remarks

If used in XAML the Z2Data property is parsed using the WPF DoubleCollectionConverter class.

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.Z2DataPath Property

AxesSeries3D.Z2DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the Z2-data for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Z2DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property Z2DataPath As String

Property Value

A string value. The default is an empty string.

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.ZData Property

AxesSeries3D.ZData Property
[image]

Gets or sets the data used for calculating the Z-coordinates of data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection ZData { get; set; }

Visual Basic [image] Copy Code

Public Property ZData As DoubleCollection

Property Value

A WPF DoubleCollection object. The default is an empty collection.

Remarks

If used in XAML the ZData property is parsed using the WPF DoubleCollectionConverter class.

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D.ZDataPath Property

AxesSeries3D.ZDataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the Z-data for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string ZDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property ZDataPath As String

Property Value

A string value. The default is an empty string.

See Also

AxesSeries3D Members
AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.AxesSeries3D Events

AxesSeries3D Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

AxesSeries3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Class

Axis Class
[image]

Contains the settings of a chart axis.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Axis : FrameworkElement

Visual Basic [image] Copy Code

Public Class Axis
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.Axis

See Also

Axis Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Members

Axis Members
Constructors Fields Properties Events
[image]

Contains the settings of a chart axis.

The following tables list the members exposed by the Axis type.

Public Constructors

Name | Description
Axis | Initializes a new instance of the AxisSettings class.

Public Fields

Name | Description
AxisCrossingPointProperty | Identifies the AxisCrossingPoint dependency property.
AxisOffsetProperty | Identifies the AxisOffset dependency property.
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
HorLabelAlignmentProperty | Identifies the HorLabelAlignment dependency property.
IntervalCountProperty | Identifies the IntervalCount dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelRotationAngleProperty | Identifies the LabelRotationAngle dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelStrokeProperty | Identifies the LabelStroke dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleOffsetProperty | Identifies the TitleOffset dependency property.
TitleProperty | Identifies the Title dependency property.
TitleRotationAngleProperty | Identifies the TitleRotationAngle dependency property.
TitleStrokeProperty | Identifies the TitleStroke dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.
VertLabelAlignmentProperty | Identifies the VertLabelAlignment dependency property.

Public Properties

Name | Description
AxisCrossingPoint | Gets or sets the point where this axis is crossed by the other axis. This is a dependency property.
AxisOffset | Gets or sets the offset of the axis. This is a dependency property.
CustomLabelPosition | Gets or sets the position of custom labels. This is a dependency property.
HorLabelAlignment | Gets or sets the horizontal alignment of labels at the axis. This is a dependency property.
Interval | Gets or sets the interval between two adjacent values at the axis. This is a dependency property.
IntervalCount | Gets or sets the count of intervals at the axis. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the labels at the axis. This is a dependency property.
LabelFontSize | Gets or sets the font size for the labels at the axis. This is a dependency property.
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property.
LabelFontWeight | Gets or sets the font weight for the labels at the axis. This is a dependency property.
LabelFormat | Gets or sets the format of the labels. This is a dependency property.
LabelOffset | Gets or sets the offset of the label from the axis. This is a dependency property.
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels.
LabelRotationAngle | Gets or sets the rotation angle of labels at a horizontal axis. This is a dependency property.
Labels | Gets or sets custom labels for the axis.
LabelStroke | Gets or sets the brush for drawing the labels at the axis. This is a dependency property.
LabelType | Gets or sets the type of labels drawn at the axis. This is a dependency property.
MaxValue | Gets or sets the maximum value at the axis. This is a dependency property.
MinValue | Gets or sets the minimum value at the axis. This is a dependency property.
Stroke | Gets or sets the brush for drawing the axis. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for this axis. This is a dependency property.
Tick | Gets or sets the length of tick marks. This is a dependency property.
Title | Gets or sets the title of the axis. This is a dependency property.
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property.
TitleFontSize | Gets or sets the font size for the title. This is a dependency property.
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property.
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property.
TitleOffset | Gets or sets the offset of the title label from the axis. This is a dependency property.
TitleRotationAngle | Gets or sets the rotation angle of the title label at a horizontal axis. This is a dependency property.
TitleStroke | Gets or sets the brush for drawing the title of the axis. This is a dependency property.
ValueFormat | Gets or sets the format of data related to this axis. This is a dependency property.
VertLabelAlignment | Gets or sets the vertical alignment of labels at the axis. This is a dependency property.

Public Events

Name | Description
InnerValueChanged | Occurs when a property of the AxisSettings object has changed.

See Also

Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Fields

Axis Fields
[image]

Public Fields

Name | Description
AxisCrossingPointProperty | Identifies the AxisCrossingPoint dependency property.
AxisOffsetProperty | Identifies the AxisOffset dependency property.
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
HorLabelAlignmentProperty | Identifies the HorLabelAlignment dependency property.
IntervalCountProperty | Identifies the IntervalCount dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelRotationAngleProperty | Identifies the LabelRotationAngle dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelStrokeProperty | Identifies the LabelStroke dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleOffsetProperty | Identifies the TitleOffset dependency property.
TitleProperty | Identifies the Title dependency property.
TitleRotationAngleProperty | Identifies the TitleRotationAngle dependency property.
TitleStrokeProperty | Identifies the TitleStroke dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.
VertLabelAlignmentProperty | Identifies the VertLabelAlignment dependency property.

See Also

Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.AxisCrossingPointProperty Field

Axis.AxisCrossingPointProperty Field
[image]

Identifies the AxisCrossingPoint dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AxisCrossingPointProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AxisCrossingPointProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.AxisOffsetProperty Field

Axis.AxisOffsetProperty Field
[image]

Identifies the AxisOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AxisOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AxisOffsetProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.CustomLabelPositionProperty Field

Axis.CustomLabelPositionProperty Field
[image]

Identifies the CustomLabelPosition dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomLabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomLabelPositionProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.HorLabelAlignmentProperty Field

Axis.HorLabelAlignmentProperty Field
[image]

Identifies the HorLabelAlignment dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorLabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorLabelAlignmentProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.IntervalCountProperty Field

Axis.IntervalCountProperty Field
[image]

Identifies the IntervalCount dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalCountProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.IntervalProperty Field

Axis.IntervalProperty Field
[image]

Identifies the Interval dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontFamilyProperty Field

Axis.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontSizeProperty Field

Axis.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontStyleProperty Field

Axis.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontWeightProperty Field

Axis.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFormatProperty Field

Axis.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelOffsetProperty Field

Axis.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelPathProperty Field

Axis.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelRotationAngleProperty Field

Axis.LabelRotationAngleProperty Field
[image]

Identifies the LabelRotationAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelRotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelRotationAngleProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelsProperty Field

Axis.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelStrokeProperty Field

Axis.LabelStrokeProperty Field
[image]

Identifies the LabelStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelStrokeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelTypeProperty Field

Axis.LabelTypeProperty Field
[image]

Identifies the LabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTypeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.MaxValueProperty Field

Axis.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.MinValueProperty Field

Axis.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.StrokeProperty Field

Axis.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.StrokeThicknessProperty Field

Axis.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TickProperty Field

Axis.TickProperty Field
[image]

Identifies the Tick dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontFamilyProperty Field

Axis.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontSizeProperty Field

Axis.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontStyleProperty Field

Axis.TitleFontStyleProperty Field
[image]

Identifies the TitleFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontStyleProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontWeightProperty Field

Axis.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleOffsetProperty Field

Axis.TitleOffsetProperty Field
[image]

Identifies the TitleOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleOffsetProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleProperty Field

Axis.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleRotationAngleProperty Field

Axis.TitleRotationAngleProperty Field
[image]

Identifies the TitleRotationAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleRotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleRotationAngleProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleStrokeProperty Field

Axis.TitleStrokeProperty Field
[image]

Identifies the TitleStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleStrokeProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.ValueFormatProperty Field

Axis.ValueFormatProperty Field
[image]

Identifies the ValueFormat dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueFormatProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.VertLabelAlignmentProperty Field

Axis.VertLabelAlignmentProperty Field
[image]

Identifies the VertLabelAlignment dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VertLabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VertLabelAlignmentProperty As DependencyProperty

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Constructor

Axis Constructor
[image]

Initializes a new instance of the AxisSettings class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Axis ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Properties

Axis Properties
[image]

Public Properties

Name | Description
AxisCrossingPoint | Gets or sets the point where this axis is crossed by the other axis. This is a dependency property.
AxisOffset | Gets or sets the offset of the axis. This is a dependency property.
CustomLabelPosition | Gets or sets the position of custom labels. This is a dependency property.
HorLabelAlignment | Gets or sets the horizontal alignment of labels at the axis. This is a dependency property.
Interval | Gets or sets the interval between two adjacent values at the axis. This is a dependency property.
IntervalCount | Gets or sets the count of intervals at the axis. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the labels at the axis. This is a dependency property.
LabelFontSize | Gets or sets the font size for the labels at the axis. This is a dependency property.
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property.
LabelFontWeight | Gets or sets the font weight for the labels at the axis. This is a dependency property.
LabelFormat | Gets or sets the format of the labels. This is a dependency property.
LabelOffset | Gets or sets the offset of the label from the axis. This is a dependency property.
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels.
LabelRotationAngle | Gets or sets the rotation angle of labels at a horizontal axis. This is a dependency property.
Labels | Gets or sets custom labels for the axis.
LabelStroke | Gets or sets the brush for drawing the labels at the axis. This is a dependency property.
LabelType | Gets or sets the type of labels drawn at the axis. This is a dependency property.
MaxValue | Gets or sets the maximum value at the axis. This is a dependency property.
MinValue | Gets or sets the minimum value at the axis. This is a dependency property.
Stroke | Gets or sets the brush for drawing the axis. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for this axis. This is a dependency property.
Tick | Gets or sets the length of tick marks. This is a dependency property.
Title | Gets or sets the title of the axis. This is a dependency property.
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property.
TitleFontSize | Gets or sets the font size for the title. This is a dependency property.
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property.
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property.
TitleOffset | Gets or sets the offset of the title label from the axis. This is a dependency property.
TitleRotationAngle | Gets or sets the rotation angle of the title label at a horizontal axis. This is a dependency property.
TitleStroke | Gets or sets the brush for drawing the title of the axis. This is a dependency property.
ValueFormat | Gets or sets the format of data related to this axis. This is a dependency property.
VertLabelAlignment | Gets or sets the vertical alignment of labels at the axis. This is a dependency property.

See Also

Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.AxisCrossingPoint Property

Axis.AxisCrossingPoint Property
[image]

Gets or sets the point where this axis is crossed by the other axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double AxisCrossingPoint { get; set; }

Visual Basic [image] Copy Code

Public Property AxisCrossingPoint As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.AxisOffset Property

Axis.AxisOffset Property
[image]

Gets or sets the offset of the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double AxisOffset { get; set; }

Visual Basic [image] Copy Code

Public Property AxisOffset As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.CustomLabelPosition Property

Axis.CustomLabelPosition Property
[image]

Gets or sets the position of custom labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CustomLabelPosition CustomLabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLabelPosition As CustomLabelPosition

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.HorLabelAlignment Property

Axis.HorLabelAlignment Property
[image]

Gets or sets the horizontal alignment of labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Nullable<HorizontalAlignment> HorLabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorLabelAlignment As Nullable(Of HorizontalAlignment)

Property Value

One of the System.Windows.HorizontalAlignment enumeration values.

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.Interval Property

Axis.Interval Property
[image]

Gets or sets the interval between two adjacent values at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.IntervalCount Property

Axis.IntervalCount Property
[image]

Gets or sets the count of intervals at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int IntervalCount { get; set; }

Visual Basic [image] Copy Code

Public Property IntervalCount As Integer

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontFamily Property

Axis.LabelFontFamily Property
[image]

Gets or sets the font family for the labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontSize Property

Axis.LabelFontSize Property
[image]

Gets or sets the font size for the labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontStyle Property

Axis.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFontWeight Property

Axis.LabelFontWeight Property
[image]

Gets or sets the font weight for the labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelFormat Property

Axis.LabelFormat Property
[image]

Gets or sets the format of the labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelOffset Property

Axis.LabelOffset Property
[image]

Gets or sets the offset of the label from the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelPath Property

Axis.LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving X-labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelRotationAngle Property

Axis.LabelRotationAngle Property
[image]

Gets or sets the rotation angle of labels at a horizontal axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelRotationAngle As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.Labels Property

Axis.Labels Property
[image]

Gets or sets custom labels for the axis.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelStroke Property

Axis.LabelStroke Property
[image]

Gets or sets the brush for drawing the labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelStroke { get; set; }

Visual Basic [image] Copy Code

Public Property LabelStroke As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.LabelType Property

Axis.LabelType Property
[image]

Gets or sets the type of labels drawn at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType LabelType { get; set; }

Visual Basic [image] Copy Code

Public Property LabelType As LabelType

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.MaxValue Property

Axis.MaxValue Property
[image]

Gets or sets the maximum value at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.MinValue Property

Axis.MinValue Property
[image]

Gets or sets the minimum value at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.Stroke Property

Axis.Stroke Property
[image]

Gets or sets the brush for drawing the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.StrokeThickness Property

Axis.StrokeThickness Property
[image]

Gets or sets the thickness of the stroke for this axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.Tick Property

Axis.Tick Property
[image]

Gets or sets the length of tick marks. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Tick { get; set; }

Visual Basic [image] Copy Code

Public Property Tick As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.Title Property

Axis.Title Property
[image]

Gets or sets the title of the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontFamily Property

Axis.TitleFontFamily Property
[image]

Gets or sets the font family for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontSize Property

Axis.TitleFontSize Property
[image]

Gets or sets the font size for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontStyle Property

Axis.TitleFontStyle Property
[image]

Gets or sets the font style for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleFontWeight Property

Axis.TitleFontWeight Property
[image]

Gets or sets the font weight for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleOffset Property

Axis.TitleOffset Property
[image]

Gets or sets the offset of the title label from the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TitleOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TitleOffset As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleRotationAngle Property

Axis.TitleRotationAngle Property
[image]

Gets or sets the rotation angle of the title label at a horizontal axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TitleRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleRotationAngle As Double

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.TitleStroke Property

Axis.TitleStroke Property
[image]

Gets or sets the brush for drawing the title of the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush TitleStroke { get; set; }

Visual Basic [image] Copy Code

Public Property TitleStroke As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.ValueFormat Property

Axis.ValueFormat Property
[image]

Gets or sets the format of data related to this axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ValueFormat ValueFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ValueFormat As ValueFormat

Property Value

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.VertLabelAlignment Property

Axis.VertLabelAlignment Property
[image]

Gets or sets the vertical alignment of labels at the axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Nullable<VerticalAlignment> VertLabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VertLabelAlignment As Nullable(Of VerticalAlignment)

Property Value

One of the System.Windows.VerticalAlignment enumeration values.

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis Events

Axis Events
[image]

Public Events

Name | Description
InnerValueChanged | Occurs when a property of the AxisSettings object has changed.

See Also

Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Axis.InnerValueChanged Event

Axis.InnerValueChanged Event
[image]

Occurs when a property of the AxisSettings object has changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler InnerValueChanged

Visual Basic [image] Copy Code

Public Event InnerValueChanged As EventHandler

See Also

Axis Members
Axis Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar Class

Bar Class
[image]

Represents a bar in charts that show bars.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Bar : ChartElement

Visual Basic [image] Copy Code

Public Class Bar
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Bar

See Also

Bar Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar Members

Bar Members
Properties Methods
[image]

Represents a bar in charts that show bars.

The following tables list the members exposed by the Bar type.

Public Properties

Name | Description
BarIndex | Gets the index of the bar in the series.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Height | Gets the height of the bar.
Progress | Gets the progress of the bar.
SeriesIndex | Gets the index of the series this bar belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Value | Gets the value of the bar.
Width | Gets the width of the bar.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this bar.

See Also

Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar Methods

Bar Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this bar.

See Also

Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.CreateShape Method

Bar.CreateShape Method
[image]

Creates a Shape that represents this bar.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A Shape object.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar Properties

Bar Properties
[image]

Public Properties

Name | Description
BarIndex | Gets the index of the bar in the series.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Height | Gets the height of the bar.
Progress | Gets the progress of the bar.
SeriesIndex | Gets the index of the series this bar belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Value | Gets the value of the bar.
Width | Gets the width of the bar.

See Also

Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.BarIndex Property

Bar.BarIndex Property
[image]

Gets the index of the bar in the series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int BarIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BarIndex As Integer

Property Value

An integer value.

Remarks

The index of the bar corresponds to the position of the data this bar represents in the data array for the series.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.Height Property

Bar.Height Property
[image]

Gets the height of the bar.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

A double value.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.Progress Property

Bar.Progress Property
[image]

Gets the progress of the bar.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Progress As Double

Property Value

A double value.

Remarks

The progress is given as a number, not as a percent of the bar value.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.SeriesIndex Property

Bar.SeriesIndex Property
[image]

Gets the index of the series this bar belongs to.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An integer value.

Remarks

The index of the series corresponds to the location of the series this bar belongs to in the Series list.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.Value Property

Bar.Value Property
[image]

Gets the value of the bar.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Double

Property Value

A double value.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bar.Width Property

Bar.Width Property
[image]

Gets the width of the bar.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

A double value.

See Also

Bar Members
Bar Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Class

BarChart Class
[image]

Represents a bar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BarChart : AxesChart

Visual Basic [image] Copy Code

Public Class BarChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.AxesChart
MindFusion.Charting.Wpf.BarChart

See Also

BarChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Members

BarChart Members
Constructors Fields Properties Methods Events
[image]

Represents a bar chart.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Initializes a new instance of the BarChart class.

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property. (Inherited from AxesChart.)
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property. (Inherited from AxesChart.)
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property. (Inherited from AxesChart.)
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property. (Inherited from AxesChart.)
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property. (Inherited from AxesChart.)
CrosshairTypeProperty | Identifies the CrosshairType dependency property. (Inherited from AxesChart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property. (Inherited from AxesChart.)
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property. (Inherited from AxesChart.)
MousePositionProperty | Identifies the MousePosition dependency property. (Inherited from AxesChart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property. (Inherited from AxesChart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property. (Inherited from AxesChart.)
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property. (Inherited from AxesChart.)
SeriesWidthProperty | Identifies the SeriesWidth dependency property.
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property. (Inherited from AxesChart.)
XAxesProperty | Identifies the XAxes dependency property. (Inherited from AxesChart.)
Y2AxesProperty | Identifies the Y2Axes dependency property. (Inherited from AxesChart.)
YAxesProperty | Identifies the YAxes dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series. (Inherited from AxesChart.)
Behavior | Gets or sets the behavior of the chart control. (Inherited from AxesChart.)
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair. (Inherited from AxesChart.)
CrosshairStroke | Gets or sets the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairTemplate | Gets or sets the crosshair template. (Inherited from AxesChart.)
CrosshairType | Gets or sets the type of crosshair. (Inherited from AxesChart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series. (Inherited from AxesChart.)
MinZoomSpan | Gets or sets the area of zoom. (Inherited from AxesChart.)
MousePosition | Gets or sets the position of the mouse. (Inherited from AxesChart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes. (Inherited from AxesChart.)
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
SeriesWidth | Gets or sets the width of the bar series.
ShowCrosshair | Gets or sets whether the crosshair is visible. (Inherited from AxesChart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart. (Inherited from AxesChart.)
XAxes | Gets setttings for all X axes of the chart. (Inherited from AxesChart.)
Y2Axes | Gets setttings for all Y2 axes of the chart. (Inherited from AxesChart.)
YAxes | Gets setttings for all Y axes of the chart. (Inherited from AxesChart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap. (Inherited from AxesChart.)
CrosshairPosition | Gets the current location of the crosshair. (Inherited from AxesChart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file. (Inherited from AxesChart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from AxesChart.)
OnAxesChanged | Raised when the axes has changed. (Inherited from AxesChart.)
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event. (Inherited from AxesChart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Fields

BarChart Fields
[image]

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property. (Inherited from AxesChart.)
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property. (Inherited from AxesChart.)
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property. (Inherited from AxesChart.)
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property. (Inherited from AxesChart.)
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property. (Inherited from AxesChart.)
CrosshairTypeProperty | Identifies the CrosshairType dependency property. (Inherited from AxesChart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property. (Inherited from AxesChart.)
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property. (Inherited from AxesChart.)
MousePositionProperty | Identifies the MousePosition dependency property. (Inherited from AxesChart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property. (Inherited from AxesChart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property. (Inherited from AxesChart.)
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property. (Inherited from AxesChart.)
SeriesWidthProperty | Identifies the SeriesWidth dependency property.
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property. (Inherited from AxesChart.)
XAxesProperty | Identifies the XAxes dependency property. (Inherited from AxesChart.)
Y2AxesProperty | Identifies the Y2Axes dependency property. (Inherited from AxesChart.)
YAxesProperty | Identifies the YAxes dependency property. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart.SeriesWidthProperty Field

BarChart.SeriesWidthProperty Field
[image]

Identifies the SeriesWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesWidthProperty As DependencyProperty

See Also

BarChart Members
BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Constructor

BarChart Constructor
[image]

Initializes a new instance of the BarChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Properties

BarChart Properties
[image]

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series. (Inherited from AxesChart.)
Behavior | Gets or sets the behavior of the chart control. (Inherited from AxesChart.)
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair. (Inherited from AxesChart.)
CrosshairStroke | Gets or sets the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairTemplate | Gets or sets the crosshair template. (Inherited from AxesChart.)
CrosshairType | Gets or sets the type of crosshair. (Inherited from AxesChart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series. (Inherited from AxesChart.)
MinZoomSpan | Gets or sets the area of zoom. (Inherited from AxesChart.)
MousePosition | Gets or sets the position of the mouse. (Inherited from AxesChart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes. (Inherited from AxesChart.)
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
SeriesWidth | Gets or sets the width of the bar series.
ShowCrosshair | Gets or sets whether the crosshair is visible. (Inherited from AxesChart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart. (Inherited from AxesChart.)
XAxes | Gets setttings for all X axes of the chart. (Inherited from AxesChart.)
Y2Axes | Gets setttings for all Y2 axes of the chart. (Inherited from AxesChart.)
YAxes | Gets setttings for all Y axes of the chart. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart.SeriesWidth Property

BarChart.SeriesWidth Property
[image]

Gets or sets the width of the bar series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SeriesWidth { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesWidth As Double

Property Value

A double value. The default is 0.8.

Remarks

Valid numbers range in the interval [0..1]. The value indicates what portion of the interval the bars of this series occupy. The rest is left blank space.

See Also

BarChart Members
BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart Events

BarChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Class

BarChart3D Class
[image]

Represents a 3D bar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BarChart3D : AxesChart3D

Visual Basic [image] Copy Code

Public Class BarChart3D
Inherits AxesChart3D

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart3D
MindFusion.Charting.Wpf.AxesChart3D
MindFusion.Charting.Wpf.BarChart3D

See Also

BarChart3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Members

BarChart3D Members
Constructors Fields Properties Methods
[image]

Represents a 3D bar chart.

The following tables list the members exposed by the BarChart3D type.

Public Constructors

Name | Description
BarChart3D | Creates a new 3D bar chart.

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowGroundLevelSelectionProperty | Identifies the AllowGroundLevelSelection dependency property.
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BarModel3DProperty | Identifies the BarModel3D dependency property.
BarType3DProperty | Identifies the BarType3D dependency property.
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadius3DProperty | Identifies the CornerRadius3D dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart3D.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart3D.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart3D.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart3D.)
GroundLevelXProperty | Identifies the GroundLevelX dependency property.
GroundLevelYProperty | Identifies the GroundLevelY dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelOffsetProperty | Identifies the ModelOffset dependency property.
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
RoundCornerTypeProperty | Identifies the RoundCornerType dependency property.
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SeriesWidthProperty | Identifies the SeriesWidth dependency property.
SideWallThicknessProperty | Identifies the SideWallThickness dependency property. (Inherited from AxesChart3D.)
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property. (Inherited from AxesChart3D.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart3D.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart3D.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property. (Inherited from AxesChart3D.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart3D.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart3D.)
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property. (Inherited from AxesChart3D.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart3D.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart3D.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property. (Inherited from AxesChart3D.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart3D.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart3D.)
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property. (Inherited from AxesChart3D.)
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property. (Inherited from AxesChart3D.)
Z2LabelsProperty | Identifies the Z2Labels dependency property. (Inherited from AxesChart3D.)
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property. (Inherited from AxesChart3D.)
ZLabelPathProperty | Identifies the ZLabelPath dependency property. (Inherited from AxesChart3D.)
ZLabelsProperty | Identifies the ZLabels dependency property. (Inherited from AxesChart3D.)

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowGroundLevelSelection | Gets or sets whether the ground-level plane can be selected.
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
BarModel3D | Gets or sets the model of the bars. This is a dependency property.
BarType3D | Gets or sets the type of the chart. This is a dependency property.
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CornerRadius3D | Gets or sets the corner radius of the bars. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridType | Gets or sets the grid type. This is a dependency property. (Inherited from AxesChart3D.)
GroundLevelX | Gets or sets the value that indicates the level of the groundX in the chart. This is a dependency property.
GroundLevelY | Gets or sets the value that indicates the level of the groundY in the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelOffset | Gets or sets the offset of the model in the chart. This is a dependency property.
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
RoundCornerType | Gets or sets which edges of the bar are drawn with rounded corners. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SeriesWidth | Gets or sets the size of the series in the chart. This is a dependency property.
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property. (Inherited from AxesChart3D.)
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property. (Inherited from AxesChart3D.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property. (Inherited from AxesChart3D.)
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property. (Inherited from AxesChart3D.)
XAxisSettings | Gets the settings for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property. (Inherited from AxesChart3D.)
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property. (Inherited from AxesChart3D.)
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property. (Inherited from AxesChart3D.)
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property. (Inherited from AxesChart3D.)
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | AxesChart3D.HitTest override.
OnApplyTemplate | AxesChart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Fields

BarChart3D Fields
[image]

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowGroundLevelSelectionProperty | Identifies the AllowGroundLevelSelection dependency property.
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BarModel3DProperty | Identifies the BarModel3D dependency property.
BarType3DProperty | Identifies the BarType3D dependency property.
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadius3DProperty | Identifies the CornerRadius3D dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart3D.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart3D.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart3D.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart3D.)
GroundLevelXProperty | Identifies the GroundLevelX dependency property.
GroundLevelYProperty | Identifies the GroundLevelY dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelOffsetProperty | Identifies the ModelOffset dependency property.
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
RoundCornerTypeProperty | Identifies the RoundCornerType dependency property.
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SeriesWidthProperty | Identifies the SeriesWidth dependency property.
SideWallThicknessProperty | Identifies the SideWallThickness dependency property. (Inherited from AxesChart3D.)
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property. (Inherited from AxesChart3D.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart3D.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart3D.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property. (Inherited from AxesChart3D.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart3D.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart3D.)
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property. (Inherited from AxesChart3D.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart3D.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart3D.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property. (Inherited from AxesChart3D.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart3D.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart3D.)
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property. (Inherited from AxesChart3D.)
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property. (Inherited from AxesChart3D.)
Z2LabelsProperty | Identifies the Z2Labels dependency property. (Inherited from AxesChart3D.)
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property. (Inherited from AxesChart3D.)
ZLabelPathProperty | Identifies the ZLabelPath dependency property. (Inherited from AxesChart3D.)
ZLabelsProperty | Identifies the ZLabels dependency property. (Inherited from AxesChart3D.)

See Also

BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.AllowGroundLevelSelectionProperty Field

BarChart3D.AllowGroundLevelSelectionProperty Field
[image]

Identifies the AllowGroundLevelSelection dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowGroundLevelSelectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowGroundLevelSelectionProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.BarModel3DProperty Field

BarChart3D.BarModel3DProperty Field
[image]

Identifies the BarModel3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarModel3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarModel3DProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.BarType3DProperty Field

BarChart3D.BarType3DProperty Field
[image]

Identifies the BarType3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarType3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarType3DProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.CornerRadius3DProperty Field

BarChart3D.CornerRadius3DProperty Field
[image]

Identifies the CornerRadius3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadius3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadius3DProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.GroundLevelXProperty Field

BarChart3D.GroundLevelXProperty Field
[image]

Identifies the GroundLevelX dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroundLevelXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroundLevelXProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.GroundLevelYProperty Field

BarChart3D.GroundLevelYProperty Field
[image]

Identifies the GroundLevelY dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroundLevelYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroundLevelYProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.ModelOffsetProperty Field

BarChart3D.ModelOffsetProperty Field
[image]

Identifies the ModelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModelOffsetProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.RoundCornerTypeProperty Field

BarChart3D.RoundCornerTypeProperty Field
[image]

Identifies the RoundCornerType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RoundCornerTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RoundCornerTypeProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.SeriesWidthProperty Field

BarChart3D.SeriesWidthProperty Field
[image]

Identifies the SeriesWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesWidthProperty As DependencyProperty

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Constructor

BarChart3D Constructor
[image]

Creates a new 3D bar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarChart3D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Methods

BarChart3D Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | AxesChart3D.HitTest override.
OnApplyTemplate | AxesChart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.HitTest Method

BarChart3D.HitTest Method
[image]

AxesChart3D.HitTest override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override ChartHitTestResult3D HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
p As Point _
) As ChartHitTestResult3D

Parameters

p

The point to test.

Return Value

An instance of the ChartHitTestResult3D class.

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.OnApplyTemplate Method

BarChart3D.OnApplyTemplate Method
[image]

AxesChart3D.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D Properties

BarChart3D Properties
[image]

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowGroundLevelSelection | Gets or sets whether the ground-level plane can be selected.
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
BarModel3D | Gets or sets the model of the bars. This is a dependency property.
BarType3D | Gets or sets the type of the chart. This is a dependency property.
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CornerRadius3D | Gets or sets the corner radius of the bars. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridType | Gets or sets the grid type. This is a dependency property. (Inherited from AxesChart3D.)
GroundLevelX | Gets or sets the value that indicates the level of the groundX in the chart. This is a dependency property.
GroundLevelY | Gets or sets the value that indicates the level of the groundY in the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelOffset | Gets or sets the offset of the model in the chart. This is a dependency property.
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
RoundCornerType | Gets or sets which edges of the bar are drawn with rounded corners. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SeriesWidth | Gets or sets the size of the series in the chart. This is a dependency property.
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property. (Inherited from AxesChart3D.)
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property. (Inherited from AxesChart3D.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property. (Inherited from AxesChart3D.)
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property. (Inherited from AxesChart3D.)
XAxisSettings | Gets the settings for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property. (Inherited from AxesChart3D.)
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property. (Inherited from AxesChart3D.)
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property. (Inherited from AxesChart3D.)
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property. (Inherited from AxesChart3D.)
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)

See Also

BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.AllowGroundLevelSelection Property

BarChart3D.AllowGroundLevelSelection Property
[image]

Gets or sets whether the ground-level plane can be selected.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool AllowGroundLevelSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowGroundLevelSelection As Boolean

Property Value

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.BarModel3D Property

BarChart3D.BarModel3D Property
[image]

Gets or sets the model of the bars. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarModel3D BarModel3D { get; set; }

Visual Basic [image] Copy Code

Public Property BarModel3D As BarModel3D

Property Value

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.BarType3D Property

BarChart3D.BarType3D Property
[image]

Gets or sets the type of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarType3D BarType3D { get; set; }

Visual Basic [image] Copy Code

Public Property BarType3D As BarType3D

Property Value

A member of the BarType3D enumeration. The default is Vertical.

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.CornerRadius3D Property

BarChart3D.CornerRadius3D Property
[image]

Gets or sets the corner radius of the bars. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius3D { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius3D As Double

Property Value

A double value. The default is 0.2.

Remarks

The RoundCornerType property specifies how the edges of the bars are drawn.

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.GroundLevelX Property

BarChart3D.GroundLevelX Property
[image]

Gets or sets the value that indicates the level of the groundX in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GroundLevelX { get; set; }

Visual Basic [image] Copy Code

Public Property GroundLevelX As Double

Property Value

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.GroundLevelY Property

BarChart3D.GroundLevelY Property
[image]

Gets or sets the value that indicates the level of the groundY in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GroundLevelY { get; set; }

Visual Basic [image] Copy Code

Public Property GroundLevelY As Double

Property Value

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.ModelOffset Property

BarChart3D.ModelOffset Property
[image]

Gets or sets the offset of the model in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ModelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ModelOffset As Double

Property Value

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.RoundCornerType Property

BarChart3D.RoundCornerType Property
[image]

Gets or sets which edges of the bar are drawn with rounded corners. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RoundCornerType RoundCornerType { get; set; }

Visual Basic [image] Copy Code

Public Property RoundCornerType As RoundCornerType

Property Value

A member of the RoundCornerType enumeration. The default is All.

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarChart3D.SeriesWidth Property

BarChart3D.SeriesWidth Property
[image]

Gets or sets the size of the series in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SeriesWidth { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesWidth As Double

Property Value

A double value. The default is 0.8.

See Also

BarChart3D Members
BarChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarElementCollection Class

BarElementCollection Class
[image]

Represents an observable collection of Bar objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BarElementCollection : ObservableCollection<Bar>

Visual Basic [image] Copy Code

Public Class BarElementCollection
Inherits ObservableCollection(Of Bar)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Bar)
System.Collections.ObjectModel.ObservableCollection(Bar)
MindFusion.Charting.Wpf.BarElementCollection

See Also

BarElementCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarElementCollection Members

BarElementCollection Members
Constructors
[image]

Represents an observable collection of Bar objects.

The following tables list the members exposed by the BarElementCollection type.

Public Constructors

Name | Description
BarElementCollection | Initializes a new instance of the BarElementCollection class.

See Also

BarElementCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarElementCollection Constructor

BarElementCollection Constructor
[image]

Initializes a new instance of the BarElementCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarElementCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarElementCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarModel3D Enumeration

BarModel3D Enumeration
[image]

Specifies what models are used to represent bars in 3D barcharts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum BarModel3D

Visual Basic [image] Copy Code

Public Enum BarModel3D

Members

Member name | Description
Bar | Draw bars as rectangular cuboids.
Cylinder | Draw bars as cylinders.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Class

BarSeries Class
[image]

Represents a series in a bar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BarSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class BarSeries
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.BarSeries

See Also

BarSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Members

BarSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a bar chart.

The following tables list the members exposed by the BarSeries type.

Public Constructors

Name | Description
BarSeries | Overloaded.

Public Fields

Name | Description
BarWidthProperty | Identifies the BarWidth dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelAlignmentProperty | Identifies the InnerLabelAlignment dependency property.
InnerLabelClipProperty | Identifies the InnerLabelClip dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
ProgressPathProperty | Identifies the ProgressPath dependency property.
ProgressProperty | Identifies the Progress dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelProperty | Identifies the TopLabel dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
Annotations | Gets the list with the annotations of this series.
BarWidth | Gets or sets the width of the bar. This is a dependency property.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabel | Gets or sets the custom inner labels. This is a dependency property.
InnerLabelAlignment | Gets or sets alignment of the inner labels. This is a dependency property.
InnerLabelClip |
InnerLabelPath | Gets or sets the path used for retrieving inner label values from a DataSource. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
Progress | Gets or sets a list that indicates the progress of bars in the chart. This is a dependency property.
ProgressPath | Gets or sets the path used for retrieving progress values from the DataSource. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
TopLabel | Gets or sets the custom top labels. This is a dependency property.
TopLabelOffset | Gets or sets the offset of the top label from the edge of the bar. This is a dependency property.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.
TopLabelType | Gets or sets the type of the top labels. This is a dependency property.
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Fields

BarSeries Fields
[image]

Public Fields

Name | Description
BarWidthProperty | Identifies the BarWidth dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelAlignmentProperty | Identifies the InnerLabelAlignment dependency property.
InnerLabelClipProperty | Identifies the InnerLabelClip dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
ProgressPathProperty | Identifies the ProgressPath dependency property.
ProgressProperty | Identifies the Progress dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelProperty | Identifies the TopLabel dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.BarWidthProperty Field

BarSeries.BarWidthProperty Field
[image]

Identifies the BarWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarWidthProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelAlignmentProperty Field

BarSeries.InnerLabelAlignmentProperty Field
[image]

Identifies the InnerLabelAlignment dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelAlignmentProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelClipProperty Field

BarSeries.InnerLabelClipProperty Field
[image]

Identifies the InnerLabelClip dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelClipProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelClipProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelPathProperty Field

BarSeries.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelProperty Field

BarSeries.InnerLabelProperty Field
[image]

Identifies the InnerLabel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelTypeProperty Field

BarSeries.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.ProgressPathProperty Field

BarSeries.ProgressPathProperty Field
[image]

Identifies the ProgressPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.ProgressProperty Field

BarSeries.ProgressProperty Field
[image]

Identifies the Progress dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelOffsetProperty Field

BarSeries.TopLabelOffsetProperty Field
[image]

Identifies the TopLabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelOffsetProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelPathProperty Field

BarSeries.TopLabelPathProperty Field
[image]

Identifies the TopLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelProperty Field

BarSeries.TopLabelProperty Field
[image]

Identifies the TopLabel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelTypeProperty Field

BarSeries.TopLabelTypeProperty Field
[image]

Identifies the TopLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelTypeProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Constructor

BarSeries Constructor
[image]

Overload List

Name | Description
BarSeries () | Initializes a new instance of the BarSeries class.
BarSeries (Axis, Axis) | Creates a new instance of the BarSeries class.

See Also

BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Constructor ()

BarSeries Constructor ()
See Also
[image]

Initializes a new instance of the BarSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarSeries Constructor Overload List
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Constructor (Axis, Axis)

BarSeries Constructor (Axis, Axis)
See Also
[image]

Creates a new instance of the BarSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BarSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

BarSeries Constructor Overload List
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Properties

BarSeries Properties
[image]

Public Properties

Name | Description
Annotations | Gets the list with the annotations of this series.
BarWidth | Gets or sets the width of the bar. This is a dependency property.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabel | Gets or sets the custom inner labels. This is a dependency property.
InnerLabelAlignment | Gets or sets alignment of the inner labels. This is a dependency property.
InnerLabelClip |
InnerLabelPath | Gets or sets the path used for retrieving inner label values from a DataSource. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
Progress | Gets or sets a list that indicates the progress of bars in the chart. This is a dependency property.
ProgressPath | Gets or sets the path used for retrieving progress values from the DataSource. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
TopLabel | Gets or sets the custom top labels. This is a dependency property.
TopLabelOffset | Gets or sets the offset of the top label from the edge of the bar. This is a dependency property.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.
TopLabelType | Gets or sets the type of the top labels. This is a dependency property.
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

See Also

BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.Annotations Property

BarSeries.Annotations Property
[image]

Gets the list with the annotations of this series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AnnotationsCollection Annotations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Annotations As AnnotationsCollection

Property Value

An instance of the AnnotationsCollection class.

Remarks

Create an Annotation object for each Annotation you want to show at the bar chart. Add the annotations to the Annotations property.

Example

The following code creates a new Annotation for the bar with index 0 (the first bar on the chart). It is displayed as a point at the location of 10 inside the bar and has a label. The Annotation point is painted in green.

C# [image] Copy Code

Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Opening notes";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = Brushes.Green;
annotation1.Stroke = Brushes.Green;
barSeries1.Annotations.Add(annotation1);

Visual Basic [image] Copy Code

Dim annotation1 As New Annotation()
annotation1.Index = 0
annotation1.Label = "Opening notes"
annotation1.Value = 10.0
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = Brushes.Green
annotation1.Stroke = Brushes.Green
barSeries1.Annotations.Add(annotation1)

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.BarWidth Property

BarSeries.BarWidth Property
[image]

Gets or sets the width of the bar. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double BarWidth { get; set; }

Visual Basic [image] Copy Code

Public Property BarWidth As Double

Property Value

A double value in the range [0..1]. The default is 0.8.

Remarks

The BarWidth property specifies the width of the bar as a portion of the available space. The rest is left as space.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabel Property

BarSeries.InnerLabel Property
[image]

Gets or sets the custom inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList InnerLabel { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabel As IList

Property Value

A list of object to use as labels. The default is an empty list.

Remarks

The property is used when the InnerLabelType is set to CustomText.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelAlignment Property

BarSeries.InnerLabelAlignment Property
[image]

Gets or sets alignment of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public TextAlignment InnerLabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelAlignment As TextAlignment

Property Value

A member of the System.Windows.TextAlignment enumeration. The default value is Left.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelClip Property

BarSeries.InnerLabelClip Property
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool InnerLabelClip { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelClip As Boolean

Property Value

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelPath Property

BarSeries.InnerLabelPath Property
[image]

Gets or sets the path used for retrieving inner label values from a DataSource. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string value. The default is an empty string.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.InnerLabelType Property

BarSeries.InnerLabelType Property
[image]

Gets or sets the type of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default value is Empty.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.Progress Property

BarSeries.Progress Property
[image]

Gets or sets a list that indicates the progress of bars in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As DoubleCollection

Property Value

An instance of the WPF DoubleCollection class. The default is an empty collection.

Remarks

The progress of the bar is set as an absolute value rather than a percentage of any sort. Thus a bar that demonstrates a value of 6 and has a progress value 3 will be filled to the middle.

The order of values in the progress list corresponds to the order of the bars e.g. the first value in the array sets the progress of the first bar etc.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.ProgressPath Property

BarSeries.ProgressPath Property
[image]

Gets or sets the path used for retrieving progress values from the DataSource. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string ProgressPath { get; set; }

Visual Basic [image] Copy Code

Public Property ProgressPath As String

Property Value

A string value. The default is an empty string.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabel Property

BarSeries.TopLabel Property
[image]

Gets or sets the custom top labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList TopLabel { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabel As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

The property is used when the TopLabelType is set to CustomText.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelOffset Property

BarSeries.TopLabelOffset Property
[image]

Gets or sets the offset of the top label from the edge of the bar. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TopLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelOffset As Double

Property Value

A double value. The default is 5.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelPath Property

BarSeries.TopLabelPath Property
[image]

Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string TopLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelPath As String

Property Value

A string value. The default is an empty string.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries.TopLabelType Property

BarSeries.TopLabelType Property
[image]

Gets or sets the type of the top labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType TopLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default value is Empty.

Remarks

Custom labels are set with the TopLabel property or TopLabelPath, when data binding is used.

See Also

BarSeries Members
BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarSeries Events

BarSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

BarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarType Enumeration

BarType Enumeration
[image]

Specifies the types of bar charts supported by the control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum BarType

Visual Basic [image] Copy Code

Public Enum BarType

Members

Member name | Description
Horizontal | Bars are drawn horizontal.
HorizontalOverlay | Bars are drawn horizontal and bars from each series are drawn inside the respective bar from the previous series.
HorizontalStack | Bars are drawn in a horizontal stack.
Vertical | Bars are drawn vertical.
VerticalOverlay | Bars are drawn vertical and bars from each series are drawn inside the respective bar from the previous series.
VerticalStack | Bars are drawn in a vertical stack.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BarType3D Enumeration

BarType3D Enumeration
[image]

Specifies the types of 3D bar charts supported by the control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum BarType3D

Visual Basic [image] Copy Code

Public Enum BarType3D

Members

Member name | Description
Horizontal | Bars are drawn horizontal.
HorizontalInColumn | Bars are drawn horizontal and bars from each series are drawn in front of the respective bars from the previous series.
HorizontalStack | Bars are drawn in a horizontal stack.
Vertical | Bars are drawn vertical.
VerticalInColumn | Bars are drawn vertical and bars from each series are drawn in front of the respective bars from the previous series.
VerticalStack | Bars are drawn in a vertical stack.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
AllowXDrag | Allows dragging of chart points along the X axes.
AllowYDrag | Allows dragging of chart points along the Y axes.
DoNothing | The control does not respond to actions performed by the user.
ZoomChart | The control responds to actions performed by the user by zooming the chart.

Remarks

The values of the Behavior enumeration allow bitwise combination - for example you can allow dragging along both the X and Y axes.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Behavior3D Enumeration

Behavior3D Enumeration
[image]

Specifies how 3D charts react to mouse input.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum Behavior3D

Visual Basic [image] Copy Code

Public Enum Behavior3D

Members

Member name | Description
ChangePerspective | Indicates that the mouse input adjust the camera location and direction.
ChangeValue | Indicates that mouse clicks adjust the displayed data, by adding, decreasing or increasing values depending on the clicked mouse button and the chart type.
DoNothing | Indicates that the mouse input has no effect.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter Class

BoolToVisibilityConverter Class
[image]

Converts a bool value to a System.Windows.Visibility value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BoolToVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class BoolToVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.BoolToVisibilityConverter

See Also

BoolToVisibilityConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter Members

BoolToVisibilityConverter Members
Constructors Methods
[image]

Converts a bool value to a System.Windows.Visibility value.

The following tables list the members exposed by the BoolToVisibilityConverter type.

Public Constructors

Name | Description
BoolToVisibilityConverter | Initializes a new instance of the BoolToVisibilityConverter class.

Public Methods

Name | Description
Convert | Converts a bool value to System.Windows.Visibility value.
ConvertBack | IConverter.ConvertBack override.

See Also

BoolToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter Constructor

BoolToVisibilityConverter Constructor
[image]

Initializes a new instance of the BoolToVisibilityConverter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BoolToVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BoolToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter Methods

BoolToVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a bool value to System.Windows.Visibility value.
ConvertBack | IConverter.ConvertBack override.

See Also

BoolToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter.Convert Method

BoolToVisibilityConverter.Convert Method
[image]

Converts a bool value to System.Windows.Visibility value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type of the conversion.

parameter

A parameter to use in the conversion.

culture

An instance of the System.Globalization.CultureInfo class.

Return Value

See Also

BoolToVisibilityConverter Members
BoolToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BoolToVisibilityConverter.ConvertBack Method

BoolToVisibilityConverter.ConvertBack Method
[image]

IConverter.ConvertBack override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

Remarks

This method is not implemented in the BoolToVisibilityConverter class.

See Also

BoolToVisibilityConverter Members
BoolToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BrushCollection Class

BrushCollection Class
[image]

Represents an observable collection of Brush objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BrushCollection : ObservableCollection<Brush>

Visual Basic [image] Copy Code

Public Class BrushCollection
Inherits ObservableCollection(Of Brush)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Brush)
System.Collections.ObjectModel.ObservableCollection(Brush)
MindFusion.Charting.Wpf.BrushCollection

See Also

BrushCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BrushCollection Members

BrushCollection Members
Constructors
[image]

Represents an observable collection of Brush objects.

The following tables list the members exposed by the BrushCollection type.

Public Constructors

Name | Description
BrushCollection | Initializes a new instance of the BrushCollection class.

See Also

BrushCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BrushCollection Constructor

BrushCollection Constructor
[image]

Initializes a new instance of the BrushCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BrushCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble Class

Bubble Class
[image]

Represents a bubble in bubble charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Bubble : ChartElement

Visual Basic [image] Copy Code

Public Class Bubble
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Bubble

See Also

Bubble Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble Members

Bubble Members
Properties Methods
[image]

Represents a bubble in bubble charts.

The following tables list the members exposed by the Bubble type.

Public Properties

Name | Description
DataPoint | Gets a point representing the data associated with this bubble.
Diameter | Gets the size of this bubble.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Point | Gets a point representing the physical location of this bubble within the chart.
SeriesIndex | Gets the index of the series represented by this bubble.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
XDataIndex | Gets the 0-based index of the XData element associated with this bubble.
YDataIndex | Gets the 0-based index of the YData element associated with this bubble.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

See Also

Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble Methods

Bubble Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

See Also

Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.CreateShape Method

Bubble.CreateShape Method
[image]

Creates a Shape that represents the line element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A WPF Shape object.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble Properties

Bubble Properties
[image]

Public Properties

Name | Description
DataPoint | Gets a point representing the data associated with this bubble.
Diameter | Gets the size of this bubble.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Point | Gets a point representing the physical location of this bubble within the chart.
SeriesIndex | Gets the index of the series represented by this bubble.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
XDataIndex | Gets the 0-based index of the XData element associated with this bubble.
YDataIndex | Gets the 0-based index of the YData element associated with this bubble.

See Also

Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.DataPoint Property

Bubble.DataPoint Property
[image]

Gets a point representing the data associated with this bubble.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point DataPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DataPoint As Point

Property Value

A WPF Point object.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.Diameter Property

Bubble.Diameter Property
[image]

Gets the size of this bubble.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Diameter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diameter As Double

Property Value

A double value.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.Point Property

Bubble.Point Property
[image]

Gets a point representing the physical location of this bubble within the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point Point { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Point As Point

Property Value

A WPF Point object.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.SeriesIndex Property

Bubble.SeriesIndex Property
[image]

Gets the index of the series represented by this bubble.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An integer value.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.XDataIndex Property

Bubble.XDataIndex Property
[image]

Gets the 0-based index of the XData element associated with this bubble.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int XDataIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XDataIndex As Integer

Property Value

An integer value.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Bubble.YDataIndex Property

Bubble.YDataIndex Property
[image]

Gets the 0-based index of the YData element associated with this bubble.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int YDataIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property YDataIndex As Integer

Property Value

An integer value.

See Also

Bubble Members
Bubble Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Class

BubbleChart Class
[image]

Represents a bubble chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BubbleChart : AxesChart

Visual Basic [image] Copy Code

Public Class BubbleChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.AxesChart
MindFusion.Charting.Wpf.BubbleChart

See Also

BubbleChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Members

BubbleChart Members
Constructors Fields Properties Methods Events
[image]

Represents a bubble chart.

The following tables list the members exposed by the BubbleChart type.

Public Constructors

Name | Description
BubbleChart | Initializes a new instance of the BubbleChart class.

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property. (Inherited from AxesChart.)
BubbleScaleTypeProperty | Identifies the BubbleScaleType dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property. (Inherited from AxesChart.)
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property. (Inherited from AxesChart.)
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property. (Inherited from AxesChart.)
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property. (Inherited from AxesChart.)
CrosshairTypeProperty | Identifies the CrosshairType dependency property. (Inherited from AxesChart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property. (Inherited from AxesChart.)
MaxBubbleSizeProperty | Identifies the MaxBubbleSize dependency property.
MinBubbleSizeProperty | Identifies the MinBubbleSize dependency property.
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property. (Inherited from AxesChart.)
MousePositionProperty | Identifies the MousePosition dependency property. (Inherited from AxesChart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property. (Inherited from AxesChart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property. (Inherited from AxesChart.)
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property. (Inherited from AxesChart.)
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property. (Inherited from AxesChart.)
XAxesProperty | Identifies the XAxes dependency property. (Inherited from AxesChart.)
Y2AxesProperty | Identifies the Y2Axes dependency property. (Inherited from AxesChart.)
YAxesProperty | Identifies the YAxes dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series. (Inherited from AxesChart.)
Behavior | Gets or sets the behavior of the chart control. (Inherited from AxesChart.)
BubbleScaleType | Gets or sets a value specifying the algorithm to use when calculating the size of the bubbles in the chart. This is a dependency property.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair. (Inherited from AxesChart.)
CrosshairStroke | Gets or sets the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairTemplate | Gets or sets the crosshair template. (Inherited from AxesChart.)
CrosshairType | Gets or sets the type of crosshair. (Inherited from AxesChart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series. (Inherited from AxesChart.)
MaxBubbleSize | Gets or sets the radius length of the biggest bubble. This is a dependency property.
MinBubbleSize | Gets or sets the radius length of the smallest bubble. This is a dependency property.
MinZoomSpan | Gets or sets the area of zoom. (Inherited from AxesChart.)
MousePosition | Gets or sets the position of the mouse. (Inherited from AxesChart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes. (Inherited from AxesChart.)
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowCrosshair | Gets or sets whether the crosshair is visible. (Inherited from AxesChart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart. (Inherited from AxesChart.)
XAxes | Gets setttings for all X axes of the chart. (Inherited from AxesChart.)
Y2Axes | Gets setttings for all Y2 axes of the chart. (Inherited from AxesChart.)
YAxes | Gets setttings for all Y axes of the chart. (Inherited from AxesChart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap. (Inherited from AxesChart.)
CrosshairPosition | Gets the current location of the crosshair. (Inherited from AxesChart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file. (Inherited from AxesChart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Chart.OnApplyTemplate override.
OnAxesChanged | Raised when the axes has changed. (Inherited from AxesChart.)
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event. (Inherited from AxesChart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Fields

BubbleChart Fields
[image]

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property. (Inherited from AxesChart.)
BubbleScaleTypeProperty | Identifies the BubbleScaleType dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property. (Inherited from AxesChart.)
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property. (Inherited from AxesChart.)
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property. (Inherited from AxesChart.)
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property. (Inherited from AxesChart.)
CrosshairTypeProperty | Identifies the CrosshairType dependency property. (Inherited from AxesChart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property. (Inherited from AxesChart.)
MaxBubbleSizeProperty | Identifies the MaxBubbleSize dependency property.
MinBubbleSizeProperty | Identifies the MinBubbleSize dependency property.
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property. (Inherited from AxesChart.)
MousePositionProperty | Identifies the MousePosition dependency property. (Inherited from AxesChart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property. (Inherited from AxesChart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property. (Inherited from AxesChart.)
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property. (Inherited from AxesChart.)
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property. (Inherited from AxesChart.)
XAxesProperty | Identifies the XAxes dependency property. (Inherited from AxesChart.)
Y2AxesProperty | Identifies the Y2Axes dependency property. (Inherited from AxesChart.)
YAxesProperty | Identifies the YAxes dependency property. (Inherited from AxesChart.)

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.BubbleScaleTypeProperty Field

BubbleChart.BubbleScaleTypeProperty Field
[image]

Identifies the BubbleScaleType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BubbleScaleTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BubbleScaleTypeProperty As DependencyProperty

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.MaxBubbleSizeProperty Field

BubbleChart.MaxBubbleSizeProperty Field
[image]

Identifies the MaxBubbleSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxBubbleSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxBubbleSizeProperty As DependencyProperty

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.MinBubbleSizeProperty Field

BubbleChart.MinBubbleSizeProperty Field
[image]

Identifies the MinBubbleSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinBubbleSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinBubbleSizeProperty As DependencyProperty

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Constructor

BubbleChart Constructor
[image]

Initializes a new instance of the BubbleChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BubbleChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Methods

BubbleChart Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap. (Inherited from AxesChart.)
CrosshairPosition | Gets the current location of the crosshair. (Inherited from AxesChart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file. (Inherited from AxesChart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Chart.OnApplyTemplate override.
OnAxesChanged | Raised when the axes has changed. (Inherited from AxesChart.)
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event. (Inherited from AxesChart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.OnApplyTemplate Method

BubbleChart.OnApplyTemplate Method
[image]

Chart.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart Properties

BubbleChart Properties
[image]

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series. (Inherited from AxesChart.)
Behavior | Gets or sets the behavior of the chart control. (Inherited from AxesChart.)
BubbleScaleType | Gets or sets a value specifying the algorithm to use when calculating the size of the bubbles in the chart. This is a dependency property.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair. (Inherited from AxesChart.)
CrosshairStroke | Gets or sets the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairTemplate | Gets or sets the crosshair template. (Inherited from AxesChart.)
CrosshairType | Gets or sets the type of crosshair. (Inherited from AxesChart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series. (Inherited from AxesChart.)
MaxBubbleSize | Gets or sets the radius length of the biggest bubble. This is a dependency property.
MinBubbleSize | Gets or sets the radius length of the smallest bubble. This is a dependency property.
MinZoomSpan | Gets or sets the area of zoom. (Inherited from AxesChart.)
MousePosition | Gets or sets the position of the mouse. (Inherited from AxesChart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes. (Inherited from AxesChart.)
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowCrosshair | Gets or sets whether the crosshair is visible. (Inherited from AxesChart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart. (Inherited from AxesChart.)
XAxes | Gets setttings for all X axes of the chart. (Inherited from AxesChart.)
Y2Axes | Gets setttings for all Y2 axes of the chart. (Inherited from AxesChart.)
YAxes | Gets setttings for all Y axes of the chart. (Inherited from AxesChart.)

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.BubbleScaleType Property

BubbleChart.BubbleScaleType Property
[image]

Gets or sets a value specifying the algorithm to use when calculating the size of the bubbles in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BubbleScaleType BubbleScaleType { get; set; }

Visual Basic [image] Copy Code

Public Property BubbleScaleType As BubbleScaleType

Property Value

A member of the BubbleScaleType enumeration. The default is Linear.

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleChart.MaxBubbleSize Property

BubbleChart.MaxBubbleSize Property
[image]

Gets or sets the radius length of the biggest bubble. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MaxBubbleSize { get; set; }

Visual Basic [image] Copy Code

Public Property MaxBubbleSize As Double

Property Value

A double value. The default is NaN.

Remarks

The property specifies the radius of the biggest bubble. If the property value is NaN, the radius of the biggest bubble is set to 50. The radius of the smallest bubble is specified by MinBubbleSize. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace
MinBubbleSize Property


MindFusion.Charting.Wpf.BubbleChart.MinBubbleSize Property

BubbleChart.MinBubbleSize Property
[image]

Gets or sets the radius length of the smallest bubble. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MinBubbleSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinBubbleSize As Double

Property Value

A double value. The default is NaN.

Remarks

The property specifies the radius of the smallest bubble. If the property value is NaN, the radius of the biggest bubble is set to 20. The radius of the biggest bubble is specified by MaxBubbleSize. The length of the radiuses of all other bubbles are calculated based on their value compared to the value of the biggest and smallest bubble.

Use the Y2Data property to specify the values of the bubbles. If you do not need a third data array for the bubble chart, the size of the bubble is calculated based on its value in the YData list.

See Also

BubbleChart Members
BubbleChart Class
MindFusion.Charting.Wpf Namespace
MaxBubbleSize Property


MindFusion.Charting.Wpf.BubbleChart Events

BubbleChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

BubbleChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleLabelType Enumeration

BubbleLabelType Enumeration
[image]

Specifies the types of labels that can be drawn at the bubbles in a bubble chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum BubbleLabelType

Visual Basic [image] Copy Code

Public Enum BubbleLabelType

Members

Member name | Description
CustomText | The labels are set by the user.
Empty | No labels are drawn.
Location | The labels are the location of the chart data.
Size | The labels are the numbers from the chart data.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleScaleType Enumeration

BubbleScaleType Enumeration
[image]

Specifies an algorithm for calculating the sizes of the bubbles in a bubble chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum BubbleScaleType

Visual Basic [image] Copy Code

Public Enum BubbleScaleType

Members

Member name | Description
Area | Indicates a quadratic scaling of bubble sizes.
Linear | Indicates a linear scaling of bubble sizes.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Class

BubbleSeries Class
[image]

Represents a series in a bubble chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class BubbleSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class BubbleSeries
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.BubbleSeries

See Also

BubbleSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Members

BubbleSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a bubble chart.

The following tables list the members exposed by the BubbleSeries type.

Public Constructors

Name | Description
BubbleSeries | Overloaded.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelPathProperty | Identifies the LabelPath dependency property.
LabelPositionProperty | Identifies the LabelPosition dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
SizeDataProperty | Identifies the SizeData dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels.
LabelPosition | Gets or sets a value indicating the vertical alignment of the labels relatively to their associated bubbles. This is a dependency property.
Labels | Gets or sets the labels drawn at data points. This is a dependency property.
LabelType | Gets or sets the type of labels. This is a dependency property.
SizeData | Gets or sets a list of values to use as the relative sizes of the bubbles in the series. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Fields

BubbleSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelPathProperty | Identifies the LabelPath dependency property.
LabelPositionProperty | Identifies the LabelPosition dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
SizeDataProperty | Identifies the SizeData dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelPathProperty Field

BubbleSeries.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelPositionProperty Field

BubbleSeries.LabelPositionProperty Field
[image]

Identifies the LabelPosition dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPositionProperty As DependencyProperty

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelsProperty Field

BubbleSeries.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelTypeProperty Field

BubbleSeries.LabelTypeProperty Field
[image]

Identifies the LabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTypeProperty As DependencyProperty

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.SizeDataProperty Field

BubbleSeries.SizeDataProperty Field
[image]

Identifies the SizeData dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeDataProperty As DependencyProperty

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Constructor

BubbleSeries Constructor
[image]

Overload List

Name | Description
BubbleSeries () | Initializes a new instance of the BubbleSeries class.
BubbleSeries (Axis, Axis) | Initializes a new instance of the BubbleSeries class.

See Also

BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Constructor ()

BubbleSeries Constructor ()
See Also
[image]

Initializes a new instance of the BubbleSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BubbleSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BubbleSeries Constructor Overload List
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Constructor (Axis, Axis)

BubbleSeries Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the BubbleSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BubbleSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

BubbleSeries Constructor Overload List
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Properties

BubbleSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels.
LabelPosition | Gets or sets a value indicating the vertical alignment of the labels relatively to their associated bubbles. This is a dependency property.
Labels | Gets or sets the labels drawn at data points. This is a dependency property.
LabelType | Gets or sets the type of labels. This is a dependency property.
SizeData | Gets or sets a list of values to use as the relative sizes of the bubbles in the series. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

See Also

BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelPath Property

BubbleSeries.LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

A string value. The default is an empty string.

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelPosition Property

BubbleSeries.LabelPosition Property
[image]

Gets or sets a value indicating the vertical alignment of the labels relatively to their associated bubbles. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment LabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPosition As VerticalAlignment

Property Value

A member of the WPF VerticalAlignment enumeration. The default is Stretch.

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.Labels Property

BubbleSeries.Labels Property
[image]

Gets or sets the labels drawn at data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList

Property Value

A list of objects to use as labels. The default is null (Nothing in Visual Basic).

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.LabelType Property

BubbleSeries.LabelType Property
[image]

Gets or sets the type of labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BubbleLabelType LabelType { get; set; }

Visual Basic [image] Copy Code

Public Property LabelType As BubbleLabelType

Property Value

A member of the BubbleLabelType enumeration. The default is Empty.

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries.SizeData Property

BubbleSeries.SizeData Property
[image]

Gets or sets a list of values to use as the relative sizes of the bubbles in the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection SizeData { get; set; }

Visual Basic [image] Copy Code

Public Property SizeData As DoubleCollection

Property Value

A DoubleCollection object. The default is null (Nothing in Visual Basic).

See Also

BubbleSeries Members
BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.BubbleSeries Events

BubbleSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

BubbleSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CameraType Enumeration

CameraType Enumeration
[image]

Defines types of camera that can be used in a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum CameraType

Visual Basic [image] Copy Code

Public Enum CameraType

Members

Member name | Description
Orthographic | Defines an orthographic projection camera.
Perspective | Defines a perspective projection camera.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick Class

Candlestick Class
[image]

Represents a candlestick shape in financial charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Candlestick : ChartElement

Visual Basic [image] Copy Code

Public Class Candlestick
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Candlestick

See Also

Candlestick Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick Members

Candlestick Members
Constructors Properties Methods
[image]

Represents a candlestick shape in financial charts.

The following tables list the members exposed by the Candlestick type.

Public Constructors

Name | Description
Candlestick | Initializes a new instance of the Candlestick class.

Public Properties

Name | Description
BarIndex | Gets the index of the candlestick in the series.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Height | Gets the height of the candlestick.
Position | Gets or sets the horizontal position of the candlestick.
SeriesIndex | Gets the index of the series this candlestick belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Width | Gets the width of the candlestick.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this candlestick.

See Also

Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick Constructor

Candlestick Constructor
[image]

Initializes a new instance of the Candlestick class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Candlestick ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick Methods

Candlestick Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this candlestick.

See Also

Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.CreateShape Method

Candlestick.CreateShape Method
[image]

Creates a Shape that represents this candlestick.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A System.Windows.Shapes.Shape object.

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick Properties

Candlestick Properties
[image]

Public Properties

Name | Description
BarIndex | Gets the index of the candlestick in the series.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Height | Gets the height of the candlestick.
Position | Gets or sets the horizontal position of the candlestick.
SeriesIndex | Gets the index of the series this candlestick belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Width | Gets the width of the candlestick.

See Also

Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.BarIndex Property

Candlestick.BarIndex Property
[image]

Gets the index of the candlestick in the series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int BarIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BarIndex As Integer

Property Value

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.Height Property

Candlestick.Height Property
[image]

Gets the height of the candlestick.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.Position Property

Candlestick.Position Property
[image]

Gets or sets the horizontal position of the candlestick.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Double

Property Value

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.SeriesIndex Property

Candlestick.SeriesIndex Property
[image]

Gets the index of the series this candlestick belongs to.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Candlestick.Width Property

Candlestick.Width Property
[image]

Gets the width of the candlestick.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

See Also

Candlestick Members
Candlestick Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickElementCollection Class

CandlestickElementCollection Class
[image]

Represents an observable collection of Candlestick objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CandlestickElementCollection : ObservableCollection<Candlestick>

Visual Basic [image] Copy Code

Public Class CandlestickElementCollection
Inherits ObservableCollection(Of Candlestick)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Candlestick)
System.Collections.ObjectModel.ObservableCollection(Candlestick)
MindFusion.Charting.Wpf.CandlestickElementCollection

See Also

CandlestickElementCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickElementCollection Members

CandlestickElementCollection Members
Constructors
[image]

Represents an observable collection of Candlestick objects.

The following tables list the members exposed by the CandlestickElementCollection type.

Public Constructors

Name | Description
CandlestickElementCollection | Initializes a new instance of the CandlestickElementCollection class.

See Also

CandlestickElementCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickElementCollection Constructor

CandlestickElementCollection Constructor
[image]

Initializes a new instance of the CandlestickElementCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CandlestickElementCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CandlestickElementCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Class

CandlestickSeries Class
Remarks See Also
[image]

Represents a data series rendered as candlestick chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CandlestickSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class CandlestickSeries
Inherits AxesSeries

Remarks

Candlestick charts show price movements of stocks or currencies for a period of time. Prices are specified in open-high-low-close format as instances of the StockPrice class.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.CandlestickSeries

See Also

CandlestickSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Members

CandlestickSeries Members
Constructors Fields Properties Events
[image]

Represents a data series rendered as candlestick chart.

The following tables list the members exposed by the CandlestickSeries type.

Public Constructors

Name | Description
CandlestickSeries | Overloaded. Initializes a new instance of the CandlestickSeries class.

Public Fields

Name | Description
CandleWidthProperty | Identifies the CandleWidth dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DateFormatProperty | Identifies the DateFormat dependency property.
FallingPriceBrushProperty | Identifies the FallingPriceBrush dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelFormatProperty | Identifies the InnerLabelFormat dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
RisingPriceBrushProperty | Identifies the RisingPriceBrush dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
TopLabelFormatProperty | Identifies the TopLabelFormat dependency property.
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelsProperty | Identifies the TopLabels dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.
ValuesProperty | Identifies the Values dependency property.
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
CandleWidth | Gets or sets the body width of candlesticks.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
DateFormat | Gets or sets the format of date labels.
FallingPriceBrush | Gets or sets the Brush used to fill candlesticks representing falling prices.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabelFormat | Gets or sets a string specifying how price values are formatted when shown as inner labels.
InnerLabelPath | Gets or sets the path used for retrieving inner label values from the DataSource. This is a dependency property.
InnerLabels | Gets or sets the labels displayed inside candlestick bodies. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
RisingPriceBrush | Gets or sets the Brush used to fill candlesticks representing rising prices.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
TopLabelFormat | Gets or sets a string specifying how price values are formatted when shown as top labels.
TopLabelOffset | Gets or sets the distance from top label to the edge of the candlestick.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.
TopLabels | Gets or sets the labels displayed above candlesticks. This is a dependency property.
TopLabelType | Gets or sets the type of the top labels. This is a dependency property.
Values | Gets or sets the price values associated with this series.
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Fields

CandlestickSeries Fields
[image]

Public Fields

Name | Description
CandleWidthProperty | Identifies the CandleWidth dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DateFormatProperty | Identifies the DateFormat dependency property.
FallingPriceBrushProperty | Identifies the FallingPriceBrush dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelFormatProperty | Identifies the InnerLabelFormat dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
RisingPriceBrushProperty | Identifies the RisingPriceBrush dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
TopLabelFormatProperty | Identifies the TopLabelFormat dependency property.
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelsProperty | Identifies the TopLabels dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.
ValuesProperty | Identifies the Values dependency property.
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.CandleWidthProperty Field

CandlestickSeries.CandleWidthProperty Field
[image]

Identifies the CandleWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CandleWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CandleWidthProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.DateFormatProperty Field

CandlestickSeries.DateFormatProperty Field
[image]

Identifies the DateFormat dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DateFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DateFormatProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.FallingPriceBrushProperty Field

CandlestickSeries.FallingPriceBrushProperty Field
[image]

Identifies the FallingPriceBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FallingPriceBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FallingPriceBrushProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelFormatProperty Field

CandlestickSeries.InnerLabelFormatProperty Field
[image]

Identifies the InnerLabelFormat dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelFormatProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelPathProperty Field

CandlestickSeries.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelsProperty Field

CandlestickSeries.InnerLabelsProperty Field
[image]

Identifies the InnerLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelsProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelTypeProperty Field

CandlestickSeries.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.RisingPriceBrushProperty Field

CandlestickSeries.RisingPriceBrushProperty Field
[image]

Identifies the RisingPriceBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RisingPriceBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RisingPriceBrushProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelFormatProperty Field

CandlestickSeries.TopLabelFormatProperty Field
[image]

Identifies the TopLabelFormat dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelFormatProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelOffsetProperty Field

CandlestickSeries.TopLabelOffsetProperty Field
[image]

Identifies the TopLabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelOffsetProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelPathProperty Field

CandlestickSeries.TopLabelPathProperty Field
[image]

Identifies the TopLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelPathProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelsProperty Field

CandlestickSeries.TopLabelsProperty Field
[image]

Identifies the TopLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelsProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelTypeProperty Field

CandlestickSeries.TopLabelTypeProperty Field
[image]

Identifies the TopLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelTypeProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.ValuesProperty Field

CandlestickSeries.ValuesProperty Field
[image]

Identifies the Values dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValuesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValuesProperty As DependencyProperty

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Constructor

CandlestickSeries Constructor
[image]

Initializes a new instance of the CandlestickSeries class.

Overload List

Name | Description
CandlestickSeries () | Initializes a new instance of the CandlestickSeries class.
CandlestickSeries (Axis, Axis) | Initializes a new instance of the CandlestickSeries class.

See Also

CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Constructor ()

CandlestickSeries Constructor ()
See Also
[image]

Initializes a new instance of the CandlestickSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CandlestickSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CandlestickSeries Constructor Overload List
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Constructor (Axis, Axis)

CandlestickSeries Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the CandlestickSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CandlestickSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

An Axis used to calculate horizontal positions of chart elements.

yAxis
An Axis used to calculate vertical positions of chart elements.

See Also

CandlestickSeries Constructor Overload List
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Properties

CandlestickSeries Properties
[image]

Public Properties

Name | Description
CandleWidth | Gets or sets the body width of candlesticks.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
DateFormat | Gets or sets the format of date labels.
FallingPriceBrush | Gets or sets the Brush used to fill candlesticks representing falling prices.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabelFormat | Gets or sets a string specifying how price values are formatted when shown as inner labels.
InnerLabelPath | Gets or sets the path used for retrieving inner label values from the DataSource. This is a dependency property.
InnerLabels | Gets or sets the labels displayed inside candlestick bodies. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
RisingPriceBrush | Gets or sets the Brush used to fill candlesticks representing rising prices.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
TopLabelFormat | Gets or sets a string specifying how price values are formatted when shown as top labels.
TopLabelOffset | Gets or sets the distance from top label to the edge of the candlestick.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.
TopLabels | Gets or sets the labels displayed above candlesticks. This is a dependency property.
TopLabelType | Gets or sets the type of the top labels. This is a dependency property.
Values | Gets or sets the price values associated with this series.
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

See Also

CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.CandleWidth Property

CandlestickSeries.CandleWidth Property
[image]

Gets or sets the body width of candlesticks.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double CandleWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CandleWidth As Double

Property Value

A double value specifying the width of candlestick bodies. The default value is 20.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.DateFormat Property

CandlestickSeries.DateFormat Property
[image]

Gets or sets the format of date labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string DateFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DateFormat As String

Property Value

A string specifying the format used when drawing Date labels. The default value is "MMM dd".

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.FallingPriceBrush Property

CandlestickSeries.FallingPriceBrush Property
[image]

Gets or sets the Brush used to fill candlesticks representing falling prices.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush FallingPriceBrush { get; set; }

Visual Basic [image] Copy Code

Public Property FallingPriceBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.OrangeRed.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelFormat Property

CandlestickSeries.InnerLabelFormat Property
[image]

Gets or sets a string specifying how price values are formatted when shown as inner labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string InnerLabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelFormat As String

Property Value

A string containing .NET format specifiers. The default value is "Open = {0}, Close = {1}".

Remarks

This string is passed as argument to String.Format along with Open, Close, Low and High members of StockPrice, in that order.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelPath Property

CandlestickSeries.InnerLabelPath Property
[image]

Gets or sets the path used for retrieving inner label values from the DataSource. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string containing the binding path for inner labels. The default value is an empty string.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabels Property

CandlestickSeries.InnerLabels Property
[image]

Gets or sets the labels displayed inside candlestick bodies. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList

Property Value

A list containing custom inner labels.

Remarks

Labels from this list are displayed when InnerLabelType is set to CustomText.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.InnerLabelType Property

CandlestickSeries.InnerLabelType Property
[image]

Gets or sets the type of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default value is Empty.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.RisingPriceBrush Property

CandlestickSeries.RisingPriceBrush Property
[image]

Gets or sets the Brush used to fill candlesticks representing rising prices.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush RisingPriceBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RisingPriceBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.LawnGreen.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelFormat Property

CandlestickSeries.TopLabelFormat Property
[image]

Gets or sets a string specifying how price values are formatted when shown as top labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string TopLabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelFormat As String

Property Value

A string containing .NET format specifiers. The default value is "Open = {0}, Close = {1}".

Remarks

This string is passed as argument to String.Format along with Open, Close, Low and High members of StockPrice, in that order.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelOffset Property

CandlestickSeries.TopLabelOffset Property
[image]

Gets or sets the distance from top label to the edge of the candlestick.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TopLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelOffset As Double

Property Value

A double value specifying label offset. The default value is 5.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelPath Property

CandlestickSeries.TopLabelPath Property
[image]

Gets or sets the path used for retrieving top label values from the DataSource. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string TopLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelPath As String

Property Value

A string containing the binding path for top labels. The default value is an empty string.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabels Property

CandlestickSeries.TopLabels Property
[image]

Gets or sets the labels displayed above candlesticks. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList TopLabels { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabels As IList

Property Value

A list containing custom top labels.

Remarks

Labels from this list are displayed when TopLabelType is set to CustomText.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.TopLabelType Property

CandlestickSeries.TopLabelType Property
[image]

Gets or sets the type of the top labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType TopLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default value is Empty.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries.Values Property

CandlestickSeries.Values Property
[image]

Gets or sets the price values associated with this series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList<StockPrice> Values { get; set; }

Visual Basic [image] Copy Code

Public Property Values As IList(Of StockPrice)

Property Value

A list of StockPrice values.

See Also

CandlestickSeries Members
CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CandlestickSeries Events

CandlestickSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

CandlestickSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Class

Chart Class
[image]

Base class for all charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class Chart : Control

Visual Basic [image] Copy Code

Public MustInherit Class Chart
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.AxesChart
MindFusion.Charting.Wpf.FunnelChart
MindFusion.Charting.Wpf.PieChart
MindFusion.Charting.Wpf.RadarChart

See Also

Chart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Members

Chart Members
Constructors Fields Properties Methods Events
[image]

Base class for all charts.

The following tables list the members exposed by the Chart type.

Public Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Public Fields

Name | Description
ChartEffectProperty | Identifies the ChartEffect dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

Public Properties

Name | Description
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property.
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle.
DataSource | Gets or sets the data source. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the chart labels.
Legends | Gets or sets a list with the chart legends.
LicenseKey | Gets or sets the license key of the control.
PlotAreaMargin | Gets or sets the margin around the plot area.
Series | Gets the list with the series in the chart.
Title | Gets or sets the title of the chart.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleMargin | Gets or sets the margin around the title.
TitleVisibility | Gets or sets the visibility of the chart's title.

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
EndInit | FrameworkElement.EndInit override.
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter.
LoadTheme | Loads the theme with the specified name.
OnAppearanceChanged | Raises the AppearanceChanged event.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
OnDataChanged | Fired when data on the chart has changed.
SaveTheme | Saves the current theme as a file with the specified name.
UpdateChart | Recalculates and redraws the chart.

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes.
DataChanged | Occurs when the data for the chart has changed.

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Fields

Chart Fields
[image]

Public Fields

Name | Description
ChartEffectProperty | Identifies the ChartEffect dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.ChartEffectProperty Field

Chart.ChartEffectProperty Field
[image]

Identifies the ChartEffect dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartEffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartEffectProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.CornerRadiusProperty Field

Chart.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.DataSourceProperty Field

Chart.DataSourceProperty Field
[image]

Identifies the DataSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataSourceProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontFamilyProperty Field

Chart.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontSizeProperty Field

Chart.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontStyleProperty Field

Chart.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontWeightProperty Field

Chart.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.PlotAreaMarginProperty Field

Chart.PlotAreaMarginProperty Field
[image]

Identifies the PlotAreaMargin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaMarginProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontFamilyProperty Field

Chart.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontSizeProperty Field

Chart.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontStyleProperty Field

Chart.TitleFontStyleProperty Field
[image]

Identifies the TitleFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontStyleProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontWeightProperty Field

Chart.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleMarginProperty Field

Chart.TitleMarginProperty Field
[image]

Identifies the TitleMargin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleMarginProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleProperty Field

Chart.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleVisibilityProperty Field

Chart.TitleVisibilityProperty Field
[image]

Identifies the TitleVisibility dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleVisibilityProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Constructor

Chart Constructor
[image]

Initializes a new instance of the Chart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Chart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Methods

Chart Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
EndInit | FrameworkElement.EndInit override.
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter.
LoadTheme | Loads the theme with the specified name.
OnAppearanceChanged | Raises the AppearanceChanged event.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
OnDataChanged | Fired when data on the chart has changed.
SaveTheme | Saves the current theme as a file with the specified name.
UpdateChart | Recalculates and redraws the chart.

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.BeginInit Method

Chart.BeginInit Method
[image]

FrameworkElement.BeginInit override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.EndInit Method

Chart.EndInit Method
[image]

FrameworkElement.EndInit override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.HitTest Method

Chart.HitTest Method
[image]

Gets a collection of ChartElement objects that contain the specified point as parameter.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public new List<ChartElement> HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Shadows Function HitTest( _
p As Point _
) As List(Of ChartElement)

Parameters

p

The point to test.

Return Value

A collection of ChartElement objects.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LoadTheme Method

Chart.LoadTheme Method
[image]

Loads the theme with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void LoadTheme (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadTheme( _
fileName As String _
)

Parameters

fileName

The name of the file to load.

Remarks

fileName should point to a valid xml file that describes the ChartTheme to be applied.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.OnAppearanceChanged Method

Chart.OnAppearanceChanged Method
[image]

Raises the AppearanceChanged event.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static void OnAppearanceChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnAppearanceChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

e

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.OnApplyTemplate Method

Chart.OnApplyTemplate Method
[image]

FrameworkElement.ApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

This method is used internally by the control and is not intended to be called within your code.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.OnDataChanged Method

Chart.OnDataChanged Method
[image]

Fired when data on the chart has changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static void OnDataChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnDataChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The chart instance that fired the event.

e

DependencyPropertyChangedEventArgs object that specifies the event data.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.SaveTheme Method

Chart.SaveTheme Method
[image]

Saves the current theme as a file with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void SaveTheme (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTheme( _
fileName As String _
)

Parameters

fileName

The name of the file.

Remarks

The current appearance settings of the chart will be saved as a theme in XML format in a file with the specified name.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.UpdateChart Method

Chart.UpdateChart Method
[image]

Recalculates and redraws the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public virtual void UpdateChart ()

Visual Basic [image] Copy Code

Public Overridable Sub UpdateChart ()

Remarks

Call the method to force the Chart to recalculate and repaint itself. The method rebuilds the visual tree for the control.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Properties

Chart Properties
[image]

Public Properties

Name | Description
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property.
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle.
DataSource | Gets or sets the data source. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the chart labels.
Legends | Gets or sets a list with the chart legends.
LicenseKey | Gets or sets the license key of the control.
PlotAreaMargin | Gets or sets the margin around the plot area.
Series | Gets the list with the series in the chart.
Title | Gets or sets the title of the chart.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleMargin | Gets or sets the margin around the title.
TitleVisibility | Gets or sets the visibility of the chart's title.

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.ChartEffect Property

Chart.ChartEffect Property
[image]

Gets or sets the effect to apply to the elements of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartEffect ChartEffect { get; set; }

Visual Basic [image] Copy Code

Public Property ChartEffect As ChartEffect

Property Value

A member of the ChartEffect enumeration. The default is None.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.ChartTheme Property

Chart.ChartTheme Property
[image]

Gets or sets a ChartTheme that defines the appearance of chart elements.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartTheme ChartTheme { get; set; }

Visual Basic [image] Copy Code

Public Property ChartTheme As ChartTheme

Property Value

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.CornerRadius Property

Chart.CornerRadius Property
[image]

Gets or sets the corner radius of the chart control's bounding rectangle.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the WPF CornerRadius structure. The default is CornerRadius(3).

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.DataSource Property

Chart.DataSource Property
[image]

Gets or sets the data source. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As IEnumerable

Property Value

An IEnumerable object that contains data for the chart.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontFamily Property

Chart.LabelFontFamily Property
[image]

Gets or sets the font family for the chart labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the WPF FontFamily class. The default is FontFamily("Times New Roman").

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontSize Property

Chart.LabelFontSize Property
[image]

Gets or sets the font size for the chart labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value. The default is 12.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontStyle Property

Chart.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure. The default is FontStyles.Normal.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LabelFontWeight Property

Chart.LabelFontWeight Property
[image]

Gets or sets the font weight for the chart labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure. The default is FontWeights.Normal.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.Legends Property

Chart.Legends Property
[image]

Gets or sets a list with the chart legends.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LegendsCollection Legends { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Legends As LegendsCollection

Property Value

A list of Legend objects. The default is an empty collection.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.LicenseKey Property

Chart.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.PlotAreaMargin Property

Chart.PlotAreaMargin Property
[image]

Gets or sets the margin around the plot area.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness PlotAreaMargin { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaMargin As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(10).

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.Series Property

Chart.Series Property
[image]

Gets the list with the series in the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartSeriesCollection Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As ChartSeriesCollection

Property Value

A collection of ChartSeries objects. Default value is a collection with one Chart Series added to it.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.Title Property

Chart.Title Property
[image]

Gets or sets the title of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontFamily Property

Chart.TitleFontFamily Property
[image]

Gets or sets the font family for the title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

A string value. The default is an empty string.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontSize Property

Chart.TitleFontSize Property
[image]

Gets or sets the font size for the title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. The default is 14.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontStyle Property

Chart.TitleFontStyle Property
[image]

Gets or sets the font style for the title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure. The default is FontStyles.Normal.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleFontWeight Property

Chart.TitleFontWeight Property
[image]

Gets or sets the font weight for the title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure. The default is FontWeights.Normal.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleMargin Property

Chart.TitleMargin Property
[image]

Gets or sets the margin around the title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness TitleMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TitleMargin As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(0, 10, 0, 0).

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart.TitleVisibility Property

Chart.TitleVisibility Property
[image]

Gets or sets the visibility of the chart's title.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Visibility TitleVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property TitleVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration. The default is Visible.

See Also

Chart Members
Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart Events

Chart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes.
DataChanged | Occurs when the data for the chart has changed.

See Also

Chart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Class

Chart3D Class
[image]

Base class for all 3D charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class Chart3D : Control

Visual Basic [image] Copy Code

Public MustInherit Class Chart3D
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart3D
MindFusion.Charting.Wpf.AxesChart3D
MindFusion.Charting.Wpf.PieChart3D

See Also

Chart3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Members

Chart3D Members
Constructors Fields Properties Methods
[image]

Base class for all 3D charts.

The following tables list the members exposed by the Chart3D type.

Protected Constructors

Name | Description
Chart3D | Initializes a new instance of the Chart3D class.

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property.
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property.
BehaviorProperty | Identifies the Behavior dependency property.
CameraTypeProperty | Identifies the CameraType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
Effect3DProperty | Identifies the Effect3D dependency property.
LightsProperty | Identifies the Lights dependency property.
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property.
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property.
ModelDepthProperty | Identifies the ModelDepth dependency property.
ModelHeightProperty | Identifies the ModelHeight dependency property.
ModelWidthProperty | Identifies the ModelWidth dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
RenderBackSidesProperty | Identifies the RenderBackSides dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
RotationAxisProperty | Identifies the RotationAxis dependency property.
ScaleProperty | Identifies the Scale dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property.
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property.
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property.
CameraType | Gets or sets the type of the camera. This is a dependency property.
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property.
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends.
Lights | Gets or sets the lights in the chart model. This is a dependency property.
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property.
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property.
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property.
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property.
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property.
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property.
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property.
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property.
Series | Gets the list with the series in the chart.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property.
Title | Gets or sets the title of the chart. This is a dependency property.
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property.
TitleFontSize | Gets or sets the font size for the title. This is a dependency property.
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property.
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property.
TitleMargin | Gets or sets the margin around the title. This is a dependency property.
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property.

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
ClearMeshSelection | Clears any mesh selection.
EndInit | FrameworkElement.EndInit override.
HitTest | Performs a hit-testing with the specified point and returns a ChartHitTestResult3D object that describes the result of the hit-test operation.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
UpdateChart | Recalculates and redraws the chart.

See Also

Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Fields

Chart3D Fields
[image]

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property.
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property.
BehaviorProperty | Identifies the Behavior dependency property.
CameraTypeProperty | Identifies the CameraType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
Effect3DProperty | Identifies the Effect3D dependency property.
LightsProperty | Identifies the Lights dependency property.
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property.
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property.
ModelDepthProperty | Identifies the ModelDepth dependency property.
ModelHeightProperty | Identifies the ModelHeight dependency property.
ModelWidthProperty | Identifies the ModelWidth dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
RenderBackSidesProperty | Identifies the RenderBackSides dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
RotationAxisProperty | Identifies the RotationAxis dependency property.
ScaleProperty | Identifies the Scale dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

See Also

Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.AllowCameraInteractionProperty Field

Chart3D.AllowCameraInteractionProperty Field
[image]

Identifies the AllowCameraInteraction dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowCameraInteractionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowCameraInteractionProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.AllowMeshSelectionProperty Field

Chart3D.AllowMeshSelectionProperty Field
[image]

Identifies the AllowMeshSelection dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowMeshSelectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowMeshSelectionProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.BehaviorProperty Field

Chart3D.BehaviorProperty Field
[image]

Identifies the Behavior dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BehaviorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BehaviorProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.CameraTypeProperty Field

Chart3D.CameraTypeProperty Field
[image]

Identifies the CameraType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CameraTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CameraTypeProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.CornerRadiusProperty Field

Chart3D.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.DataSourceProperty Field

Chart3D.DataSourceProperty Field
[image]

Identifies the DataSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataSourceProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Effect3DProperty Field

Chart3D.Effect3DProperty Field
[image]

Identifies the Effect3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Effect3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Effect3DProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.LightsProperty Field

Chart3D.LightsProperty Field
[image]

Identifies the Lights dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LightsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LightsProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.MeshFaceSizeProperty Field

Chart3D.MeshFaceSizeProperty Field
[image]

Identifies the MeshFaceSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MeshFaceSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MeshFaceSizeProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.MeshSelectionBrushProperty Field

Chart3D.MeshSelectionBrushProperty Field
[image]

Identifies the MeshSelectionBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MeshSelectionBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MeshSelectionBrushProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelDepthProperty Field

Chart3D.ModelDepthProperty Field
[image]

Identifies the ModelDepth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModelDepthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModelDepthProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelHeightProperty Field

Chart3D.ModelHeightProperty Field
[image]

Identifies the ModelHeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModelHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModelHeightProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelWidthProperty Field

Chart3D.ModelWidthProperty Field
[image]

Identifies the ModelWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModelWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModelWidthProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.PlotAreaMarginProperty Field

Chart3D.PlotAreaMarginProperty Field
[image]

Identifies the PlotAreaMargin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaMarginProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RenderBackSidesProperty Field

Chart3D.RenderBackSidesProperty Field
[image]

Identifies the RenderBackSides dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RenderBackSidesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RenderBackSidesProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RotationAngleProperty Field

Chart3D.RotationAngleProperty Field
[image]

Identifies the RotationAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotationAngleProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RotationAxisProperty Field

Chart3D.RotationAxisProperty Field
[image]

Identifies the RotationAxis dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotationAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotationAxisProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ScaleProperty Field

Chart3D.ScaleProperty Field
[image]

Identifies the Scale dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.StaticLightsProperty Field

Chart3D.StaticLightsProperty Field
[image]

Identifies the StaticLights dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StaticLightsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StaticLightsProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontFamilyProperty Field

Chart3D.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontSizeProperty Field

Chart3D.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontStyleProperty Field

Chart3D.TitleFontStyleProperty Field
[image]

Identifies the TitleFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontStyleProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontWeightProperty Field

Chart3D.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleMarginProperty Field

Chart3D.TitleMarginProperty Field
[image]

Identifies the TitleMargin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleMarginProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleProperty Field

Chart3D.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleVisibilityProperty Field

Chart3D.TitleVisibilityProperty Field
[image]

Identifies the TitleVisibility dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleVisibilityProperty As DependencyProperty

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Constructor

Chart3D Constructor
[image]

Initializes a new instance of the Chart3D class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Chart3D ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Methods

Chart3D Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
ClearMeshSelection | Clears any mesh selection.
EndInit | FrameworkElement.EndInit override.
HitTest | Performs a hit-testing with the specified point and returns a ChartHitTestResult3D object that describes the result of the hit-test operation.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
UpdateChart | Recalculates and redraws the chart.

See Also

Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.BeginInit Method

Chart3D.BeginInit Method
[image]

FrameworkElement.BeginInit override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ClearMeshSelection Method

Chart3D.ClearMeshSelection Method
[image]

Clears any mesh selection.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void ClearMeshSelection ()

Visual Basic [image] Copy Code

Public Sub ClearMeshSelection ()

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.EndInit Method

Chart3D.EndInit Method
[image]

FrameworkElement.EndInit override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.HitTest Method

Chart3D.HitTest Method
[image]

Performs a hit-testing with the specified point and returns a ChartHitTestResult3D object that describes the result of the hit-test operation.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public new virtual ChartHitTestResult3D HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Shadows Overridable Function HitTest( _
p As Point _
) As ChartHitTestResult3D

Parameters

p

The point to test.

Return Value

An instance of the ChartHitTestResult3D class.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.OnApplyTemplate Method

Chart3D.OnApplyTemplate Method
[image]

FrameworkElement.ApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.UpdateChart Method

Chart3D.UpdateChart Method
[image]

Recalculates and redraws the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public virtual void UpdateChart ()

Visual Basic [image] Copy Code

Public Overridable Sub UpdateChart ()

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D Properties

Chart3D Properties
[image]

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property.
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property.
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property.
CameraType | Gets or sets the type of the camera. This is a dependency property.
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property.
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends.
Lights | Gets or sets the lights in the chart model. This is a dependency property.
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property.
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property.
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property.
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property.
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property.
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property.
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property.
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property.
Series | Gets the list with the series in the chart.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property.
Title | Gets or sets the title of the chart. This is a dependency property.
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property.
TitleFontSize | Gets or sets the font size for the title. This is a dependency property.
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property.
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property.
TitleMargin | Gets or sets the margin around the title. This is a dependency property.
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property.

See Also

Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.AllowCameraInteraction Property

Chart3D.AllowCameraInteraction Property
[image]

Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool AllowCameraInteraction { get; set; }

Visual Basic [image] Copy Code

Public Property AllowCameraInteraction As Boolean

Property Value

true if the camera changes position when the user clicks with the mouse at the chart and drags it; otherwise, false. The default is true.

Remarks

When the AllowCameraInteraction is enabled and the user drags with the left mouse button the camera changes its position. If they drag with the right mouse button the chart is scaled.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.AllowMeshSelection Property

Chart3D.AllowMeshSelection Property
[image]

Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool AllowMeshSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMeshSelection As Boolean

Property Value

true to allow selection of objects in the model; otherwise, false. The default is false.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Behavior Property

Chart3D.Behavior Property
[image]

Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Behavior3D Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior3D

Property Value

A member of the Behavior3D enumeration. The default is ChangePerspective.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.CameraType Property

Chart3D.CameraType Property
[image]

Gets or sets the type of the camera. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CameraType CameraType { get; set; }

Visual Basic [image] Copy Code

Public Property CameraType As CameraType

Property Value

A member of the CameraType enumeration. The default is Perspective.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ChartTheme Property

Chart3D.ChartTheme Property
[image]

Gets or sets a ChartTheme that defines the appearance of chart elements.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartTheme ChartTheme { get; set; }

Visual Basic [image] Copy Code

Public Property ChartTheme As ChartTheme

Property Value

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.CornerRadius Property

Chart3D.CornerRadius Property
[image]

Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the WPF CornerRadius structure. The default is CornerRadius(3).

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.DataSource Property

Chart3D.DataSource Property
[image]

Gets or sets the data source. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As IEnumerable

Property Value

An IEnumerable object that contains data for the chart. The default is null (Nothing in Visual Basic).

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Effect3D Property

Chart3D.Effect3D Property
[image]

Gets or sets the 3D effect of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartEffect3D Effect3D { get; set; }

Visual Basic [image] Copy Code

Public Property Effect3D As ChartEffect3D

Property Value

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Legends Property

Chart3D.Legends Property
[image]

Gets or sets a list with the chart legends.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LegendsCollection Legends { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Legends As LegendsCollection

Property Value

A list with Legend objects. The default is an empty collection.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Lights Property

Chart3D.Lights Property
[image]

Gets or sets the lights in the chart model. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Light> Lights { get; set; }

Visual Basic [image] Copy Code

Public Property Lights As ObservableCollection(Of Light)

Property Value

A collection of WPF Light objects.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.MeshFaceSize Property

Chart3D.MeshFaceSize Property
[image]

Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MeshFaceSize { get; set; }

Visual Basic [image] Copy Code

Public Property MeshFaceSize As Double

Property Value

A double value. The default is 1.

Remarks

Smaller values make the surface chart smoother but slow down performance and vice versa - bigger values speed up chart rendering but make the chart more uneven.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.MeshSelectionBrush Property

Chart3D.MeshSelectionBrush Property
[image]

Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush MeshSelectionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property MeshSelectionBrush As Brush

Property Value

A WPF Brush object. The default is a solid red brush.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelDepth Property

Chart3D.ModelDepth Property
[image]

Gets or sets the depth of the 3D model that holds the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ModelDepth { get; set; }

Visual Basic [image] Copy Code

Public Property ModelDepth As Double

Property Value

A double value. The default is NaN.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelHeight Property

Chart3D.ModelHeight Property
[image]

Gets or sets the height of the 3D model that holds the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ModelHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ModelHeight As Double

Property Value

A double value. The default is NaN.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.ModelWidth Property

Chart3D.ModelWidth Property
[image]

Gets or sets the width of the 3D model that holds the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ModelWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ModelWidth As Double

Property Value

A double value. The default is NaN.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.PlotAreaMargin Property

Chart3D.PlotAreaMargin Property
[image]

Gets or sets the margin around the plot area. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness PlotAreaMargin { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaMargin As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(10).

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RenderBackSides Property

Chart3D.RenderBackSides Property
[image]

Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool RenderBackSides { get; set; }

Visual Basic [image] Copy Code

Public Property RenderBackSides As Boolean

Property Value

true if back sides should be rendered; otherwise, false. The default is false.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RotationAngle Property

Chart3D.RotationAngle Property
[image]

Gets or sets the angle of rotation for the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

A double value. The default is 60.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.RotationAxis Property

Chart3D.RotationAxis Property
[image]

Gets or sets the axis of rotation of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vector3D RotationAxis { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAxis As Vector3D

Property Value

An instance of the WPF Vector3D class.

Remarks

The angle of rotation is specified with RotationAngle.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Scale Property

Chart3D.Scale Property
[image]

Gets or sets the scale factor of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A double value. The default is 200.

Remarks

You can scale the chart interactively by setting AllowCameraInteraction to true and then drag the mouse over the chart while the right mouse button is pressed.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Series Property

Chart3D.Series Property
[image]

Gets the list with the series in the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartSeriesCollection Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As ChartSeriesCollection

Property Value

A collection of ChartSeries objects.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.StaticLights Property

Chart3D.StaticLights Property
[image]

Gets or sets the static lights in the chart model. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Light> StaticLights { get; set; }

Visual Basic [image] Copy Code

Public Property StaticLights As ObservableCollection(Of Light)

Property Value

A collection of WPF Light objects.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.Title Property

Chart3D.Title Property
[image]

Gets or sets the title of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is an empty string.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontFamily Property

Chart3D.TitleFontFamily Property
[image]

Gets or sets the font family for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

A WPF FontFamily object. The default is FontFamily("Times New Roman").

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontSize Property

Chart3D.TitleFontSize Property
[image]

Gets or sets the font size for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. The default is 14.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontStyle Property

Chart3D.TitleFontStyle Property
[image]

Gets or sets the font style for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure. The default is FontStyles.Normal.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleFontWeight Property

Chart3D.TitleFontWeight Property
[image]

Gets or sets the font weight for the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure. The default is FontWeights.Normal.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleMargin Property

Chart3D.TitleMargin Property
[image]

Gets or sets the margin around the title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness TitleMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TitleMargin As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(0, 10, 0, 0).

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Chart3D.TitleVisibility Property

Chart3D.TitleVisibility Property
[image]

Gets or sets the visibility of the chart's title. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Visibility TitleVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property TitleVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration. The default is Visible.

See Also

Chart3D Members
Chart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartEffect Enumeration

ChartEffect Enumeration
[image]

Specifies an effect that can be applied to the elements of a chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum ChartEffect

Visual Basic [image] Copy Code

Public Enum ChartEffect

Members

Member name | Description
Glass | Indicates a glass-like effect.
None | Indicates that no effect is applied.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartEffect3D Enumeration

ChartEffect3D Enumeration
[image]

Specifies a 3D effect in a surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum ChartEffect3D

Visual Basic [image] Copy Code

Public Enum ChartEffect3D

Members

Member name | Description
None | Indicates no effect.
ShaderEffect | Indicates that a shader effect is applied to the model mesh.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement Class

ChartElement Class
[image]

Base class for all graphical elements on the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class ChartElement : IShapeCreator

Visual Basic [image] Copy Code

Public MustInherit Class ChartElement
Implements IShapeCreator

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Bar
MindFusion.Charting.Wpf.Bubble
MindFusion.Charting.Wpf.Candlestick
MindFusion.Charting.Wpf.FunnelPiece
MindFusion.Charting.Wpf.Line
MindFusion.Charting.Wpf.PieSlice
MindFusion.Charting.Wpf.Scatter

See Also

ChartElement Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement Members

ChartElement Members
Constructors Properties Methods
[image]

Base class for all graphical elements on the chart.

The following tables list the members exposed by the ChartElement type.

Protected Constructors

Name | Description
ChartElement | Initializes a new instance of the ChartElement class.

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement.
Fill | Gets the fill of the element.
Shape | Gets or sets the shape that represents this ChartElement.
Stroke | Gets or the stroke of the element.
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets the stroke thickness of the element.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element.

See Also

ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement Constructor

ChartElement Constructor
[image]

Initializes a new instance of the ChartElement class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected ChartElement ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement Methods

ChartElement Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element.

See Also

ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.CreateShape Method

ChartElement.CreateShape Method
[image]

Creates a Shape that represents the chart element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract Shape CreateShape ()

Visual Basic [image] Copy Code

Public MustOverride Function CreateShape () As Shape

Return Value

A WPF Shape object.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement Properties

ChartElement Properties
[image]

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement.
Fill | Gets the fill of the element.
Shape | Gets or sets the shape that represents this ChartElement.
Stroke | Gets or the stroke of the element.
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets the stroke thickness of the element.

See Also

ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.Effect Property

ChartElement.Effect Property
[image]

Gets or sets the effect of this ChartElement.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

An instance of the WPF Effect class.

Remarks

Currently the control supports BlurEffect and DropShadowEffect.

Example

The following example adds a DropShadowEffect to the series of a surface chart:

C# [image] Copy Code

series1.Effect = new System.Windows.Media.Effects.DropShadowEffect();

Visual Basic [image] Copy Code

series1.Effect = New System.Windows.Media.Effects.DropShadowEffect()

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.Fill Property

ChartElement.Fill Property
[image]

Gets the fill of the element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Fill As Brush

Property Value

A WPF Brush object. The default is a solid light blue brush.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.Shape Property

ChartElement.Shape Property
[image]

Gets or sets the shape that represents this ChartElement.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the WPF Shape class.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.Stroke Property

ChartElement.Stroke Property
[image]

Gets or the stroke of the element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Stroke As Brush

Property Value

A WPF Brush object. The default is a solid black brush.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeDashArray Property

ChartElement.StrokeDashArray Property
[image]

Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashArray As DoubleCollection

Property Value

A WPF DoubleCollection object.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeDashCap Property

ChartElement.StrokeDashCap Property
[image]

Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeDashOffset Property

ChartElement.StrokeDashOffset Property
[image]

Gets a value that specifies the distance within the dash pattern where a dash begins.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeDashOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashOffset As Double

Property Value

A double value. The default is 0.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeEndLineCap Property

ChartElement.StrokeEndLineCap Property
[image]

Gets a PenLineCap enumeration value that describes the Shape at the end of a line.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeEndLineCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeLineJoin Property

ChartElement.StrokeLineJoin Property
[image]

Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeLineJoin As PenLineJoin

Property Value

A member of the WPF PenLineJoin enumeration. The default is Miter.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeMiterLimit Property

ChartElement.StrokeMiterLimit Property
[image]

Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeMiterLimit As Double

Property Value

A double value. The default is 1.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeStartLineCap Property

ChartElement.StrokeStartLineCap Property
[image]

Gets a PenLineCap enumeration value that describes the Shape at the start of a line.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeStartLineCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartElement.StrokeThickness Property

ChartElement.StrokeThickness Property
[image]

Gets the stroke thickness of the element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

ChartElement Members
ChartElement Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D Class

ChartHitTestResult3D Class
[image]

Contains the result of hit-testing operations in 3D charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class ChartHitTestResult3D

Visual Basic [image] Copy Code

Public Class ChartHitTestResult3D

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartHitTestResult3D

See Also

ChartHitTestResult3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D Members

ChartHitTestResult3D Members
Properties
[image]

Contains the result of hit-testing operations in 3D charts.

The following tables list the members exposed by the ChartHitTestResult3D type.

Public Properties

Name | Description
ChartElements | Gets a list with the hit-tested chart elements.
ClosestPeak | Gets a point representing the surface chart peak, which is closest to the hit-tested point.
DataPoint | Gets or sets the logical value corresponding to the hit-tested point in the model mesh.
MeshPoint | Gets or sets the physical point from the model mesh, corresponding to the hit-tested point. If more than one point of the model mesh is at the hit-tested location, the closest point is returned.
Series | Gets the chart series related to the hit-tested element.

See Also

ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D Properties

ChartHitTestResult3D Properties
[image]

Public Properties

Name | Description
ChartElements | Gets a list with the hit-tested chart elements.
ClosestPeak | Gets a point representing the surface chart peak, which is closest to the hit-tested point.
DataPoint | Gets or sets the logical value corresponding to the hit-tested point in the model mesh.
MeshPoint | Gets or sets the physical point from the model mesh, corresponding to the hit-tested point. If more than one point of the model mesh is at the hit-tested location, the closest point is returned.
Series | Gets the chart series related to the hit-tested element.

See Also

ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D.ChartElements Property

ChartHitTestResult3D.ChartElements Property
[image]

Gets a list with the hit-tested chart elements.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<ChartElement> ChartElements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChartElements As List(Of ChartElement)

Property Value

A list of ChartElement objects.

See Also

ChartHitTestResult3D Members
ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D.ClosestPeak Property

ChartHitTestResult3D.ClosestPeak Property
[image]

Gets a point representing the surface chart peak, which is closest to the hit-tested point.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Point3D> ClosestPeak { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClosestPeak As Nullable(Of Point3D)

Property Value

A WPF Point3D object.

See Also

ChartHitTestResult3D Members
ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D.DataPoint Property

ChartHitTestResult3D.DataPoint Property
[image]

Gets or sets the logical value corresponding to the hit-tested point in the model mesh.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point3D DataPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DataPoint As Point3D

Property Value

A WPF Point3D object.

See Also

ChartHitTestResult3D Members
ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D.MeshPoint Property

ChartHitTestResult3D.MeshPoint Property
[image]

Gets or sets the physical point from the model mesh, corresponding to the hit-tested point. If more than one point of the model mesh is at the hit-tested location, the closest point is returned.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point3D MeshPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MeshPoint As Point3D

Property Value

A WPF Point3D object.

See Also

ChartHitTestResult3D Members
ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartHitTestResult3D.Series Property

ChartHitTestResult3D.Series Property
[image]

Gets the chart series related to the hit-tested element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartSeries Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As ChartSeries

Property Value

A ChartSeries object.

See Also

ChartHitTestResult3D Members
ChartHitTestResult3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Class

ChartLegend Class
[image]

Describes a legend where each item gives info about a ChartSeries.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class ChartLegend : Legend

Visual Basic [image] Copy Code

Public Class ChartLegend
Inherits Legend

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Wpf.Legend
MindFusion.Charting.Wpf.ChartLegend

See Also

ChartLegend Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Members

ChartLegend Members
Constructors Fields Properties Methods Events
[image]

Describes a legend where each item gives info about a ChartSeries.

The following tables list the members exposed by the ChartLegend type.

Public Constructors

Name | Description
ChartLegend | Initializes a new instance of the ChartLegend class.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
SeriesProperty | Identifies the Series dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property. (Inherited from Legend.)

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property. (Inherited from Legend.)
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the legend. This is a dependency property. (Inherited from Legend.)
Series | Gets or sets the series for the legend. This is a dependency property.
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property. (Inherited from Legend.)
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property. (Inherited from Legend.)

Protected Methods

Name | Description
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed. (Inherited from Legend.)

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Fields

ChartLegend Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
SeriesProperty | Identifies the Series dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property. (Inherited from Legend.)

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend.SeriesProperty Field

ChartLegend.SeriesProperty Field
[image]

Identifies the Series dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesProperty As DependencyProperty

See Also

ChartLegend Members
ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Constructor

ChartLegend Constructor
[image]

Initializes a new instance of the ChartLegend class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartLegend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Methods

ChartLegend Methods
[image]

Protected Methods

Name | Description
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend.IsItemItsOwnContainerOverride Method

ChartLegend.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

Return Value

See Also

ChartLegend Members
ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Properties

ChartLegend Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property. (Inherited from Legend.)
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the legend. This is a dependency property. (Inherited from Legend.)
Series | Gets or sets the series for the legend. This is a dependency property.
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property. (Inherited from Legend.)
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property. (Inherited from Legend.)

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend.Series Property

ChartLegend.Series Property
[image]

Gets or sets the series for the legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartSeriesCollection Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As ChartSeriesCollection

Property Value

An instance of the ChartSeriesCollection class. The default is an empty collection.

See Also

ChartLegend Members
ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartLegend Events

ChartLegend Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed. (Inherited from Legend.)

See Also

ChartLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.AppearanceChanged Event

Legend.AppearanceChanged Event
[image]

Occurs when the appearance of the legend was changed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler AppearanceChanged

Visual Basic [image] Copy Code

Public Event AppearanceChanged As PropertyChangedEventHandler

Event Data

AppearanceChanged event handlers receive an argument of type PropertyChangedEventArgs.

Remarks

This method is used internally by the control and is not intended to be called within your code.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Class

ChartSeries Class
[image]

Base class for Series in the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class ChartSeries : FrameworkElement

Visual Basic [image] Copy Code

Public MustInherit Class ChartSeries
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.FunnelSeries
MindFusion.Charting.Wpf.PieSeries
MindFusion.Charting.Wpf.RadarSeries

See Also

ChartSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Members

ChartSeries Members
Constructors Fields Properties Events
[image]

Base class for Series in the chart.

The following tables list the members exposed by the ChartSeries type.

Protected Constructors

Name | Description
ChartSeries | Initializes a new instance of the ChartSeries class.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokesSourceProperty | Identifies the StrokesSource dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TitleProperty | Identifies the Title dependency property.
ToolTipTextProperty | Identifies the ToolTipText dependency property.
ToolTipTypeProperty | Identifies the ToolTipType dependency property.

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of.
Fills | Gets the fills of the series. This is a dependency property.
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property.
Index | Gets or sets the index of this ChartSeries.
LabelBackground | Gets or sets the background of the label. This is a dependency property.
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property.
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property.
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property.
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property.
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property.
LabelForeground | Gets or sets the foreground of the label. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property.
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property.
Strokes | Gets the strokes of the series. This is a dependency property.
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property.
Title | Gets or sets the title of the series. This is a dependency property.
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property.
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property.

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed.
DataChanged | Occurs when series data was changed.

See Also

ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Fields

ChartSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokesSourceProperty | Identifies the StrokesSource dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TitleProperty | Identifies the Title dependency property.
ToolTipTextProperty | Identifies the ToolTipText dependency property.
ToolTipTypeProperty | Identifies the ToolTipType dependency property.

See Also

ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.ChartProperty Field

ChartSeries.ChartProperty Field
[image]

Identifies the Chart dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.FillsSourceProperty Field

ChartSeries.FillsSourceProperty Field
[image]

Identifies the FillsSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillsSourceProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBackgroundProperty Field

ChartSeries.LabelBackgroundProperty Field
[image]

Identifies the LabelBackground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBackgroundProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBorderBrushProperty Field

ChartSeries.LabelBorderBrushProperty Field
[image]

Identifies the LabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderBrushProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBorderThicknessProperty Field

ChartSeries.LabelBorderThicknessProperty Field
[image]

Identifies the LabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderThicknessProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontFamilyProperty Field

ChartSeries.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontSizeProperty Field

ChartSeries.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontStyleProperty Field

ChartSeries.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontWeightProperty Field

ChartSeries.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelForegroundProperty Field

ChartSeries.LabelForegroundProperty Field
[image]

Identifies the LabelForeground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelForegroundProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashArrayProperty Field

ChartSeries.StrokeDashArrayProperty Field
[image]

Identifies the StrokeDashArray dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashArrayProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashCapProperty Field

ChartSeries.StrokeDashCapProperty Field
[image]

Identifies the StrokeDashCap dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashOffsetProperty Field

ChartSeries.StrokeDashOffsetProperty Field
[image]

Identifies the StrokeDashOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashOffsetProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeEndLineCapProperty Field

ChartSeries.StrokeEndLineCapProperty Field
[image]

Identifies the StrokeEndLineCap dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeEndLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeEndLineCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeLineJoinProperty Field

ChartSeries.StrokeLineJoinProperty Field
[image]

Identifies the StrokeLineJoin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeLineJoinProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeLineJoinProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeMiterLimitProperty Field

ChartSeries.StrokeMiterLimitProperty Field
[image]

Identifies the StrokeMiterLimit dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeMiterLimitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeMiterLimitProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokesSourceProperty Field

ChartSeries.StrokesSourceProperty Field
[image]

Identifies the StrokesSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokesSourceProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeStartLineCapProperty Field

ChartSeries.StrokeStartLineCapProperty Field
[image]

Identifies the StrokeStartLineCap dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeStartLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeStartLineCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeThicknessProperty Field

ChartSeries.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.TitleProperty Field

ChartSeries.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.ToolTipTextProperty Field

ChartSeries.ToolTipTextProperty Field
[image]

Identifies the ToolTipText dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToolTipTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolTipTextProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.ToolTipTypeProperty Field

ChartSeries.ToolTipTypeProperty Field
[image]

Identifies the ToolTipType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToolTipTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolTipTypeProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Constructor

ChartSeries Constructor
[image]

Initializes a new instance of the ChartSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected ChartSeries ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Properties

ChartSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of.
Fills | Gets the fills of the series. This is a dependency property.
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property.
Index | Gets or sets the index of this ChartSeries.
LabelBackground | Gets or sets the background of the label. This is a dependency property.
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property.
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property.
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property.
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property.
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property.
LabelForeground | Gets or sets the foreground of the label. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property.
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property.
Strokes | Gets the strokes of the series. This is a dependency property.
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property.
Title | Gets or sets the title of the series. This is a dependency property.
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property.
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property.

See Also

ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.Chart Property

ChartSeries.Chart Property
[image]

Gets or sets the Chart this ChartSeries is part of.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Chart Chart { get; set; }

Visual Basic [image] Copy Code

Public Property Chart As Chart

Property Value

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.Fills Property

ChartSeries.Fills Property
[image]

Gets the fills of the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection Fills { get; set; }

Visual Basic [image] Copy Code

Public Property Fills As BrushCollection

Property Value

A collection of WPF Brush objects. The default is an empty collection.

Remarks

Brushes from the Fills property are used for painting the graphical elements of the series - lines, areas, bars, pie slices, etc.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.FillsSource Property

ChartSeries.FillsSource Property
[image]

Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection FillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property FillsSource As BrushCollection

Property Value

A collection of WPF Brush objects.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.Index Property

ChartSeries.Index Property
[image]

Gets or sets the index of this ChartSeries.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value. The default is -1.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBackground Property

ChartSeries.LabelBackground Property
[image]

Gets or sets the background of the label. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBackground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

Remarks

The LabelBackground property specifies the background of labels drawn at data points in this ChartSeries.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBorderBrush Property

ChartSeries.LabelBorderBrush Property
[image]

Gets or sets the brush for the label border. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderBrush As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

Remarks

The LabelBorderBrush property specifies the border around labels drawn at data points in this ChartSeries.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelBorderThickness Property

ChartSeries.LabelBorderThickness Property
[image]

Gets or sets the thickness of the label border. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness LabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderThickness As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(1).

Remarks

The LabelBorderThickness property specifies the border drawn around label drawn at data points in this ChartSeries.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontFamily Property

ChartSeries.LabelFontFamily Property
[image]

Gets or sets the font family for the chart labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the WPF FontFamily class. The default is FontFamily("Times New Roman").

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontSize Property

ChartSeries.LabelFontSize Property
[image]

Gets or sets the font size for the chart labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value. The default is 12.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontStyle Property

ChartSeries.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure. The default is FontStyles.Normal.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelFontWeight Property

ChartSeries.LabelFontWeight Property
[image]

Gets or sets the font weight for the chart labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure. The default value is FontWeights.Normal.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.LabelForeground Property

ChartSeries.LabelForeground Property
[image]

Gets or sets the foreground of the label. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelForeground As Brush

Property Value

An instance of the WPF Brush class. The default is a solid black brush.

Remarks

The LabelForeground property specifies the brush used for drawing labels at data points in this ChartSeries.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashArray Property

ChartSeries.StrokeDashArray Property
[image]

Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashArray As DoubleCollection

Property Value

A WPF DoubleCollection object. The default is null (Nothing in Visual Basic).

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashCap Property

ChartSeries.StrokeDashCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeDashOffset Property

ChartSeries.StrokeDashOffset Property
[image]

Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeDashOffset { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashOffset As Double

Property Value

A double value. The default is 0.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeEndLineCap Property

ChartSeries.StrokeEndLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeEndLineCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeLineJoin Property

ChartSeries.StrokeLineJoin Property
[image]

Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeLineJoin As PenLineJoin

Property Value

A member of the WPF PenLineJoin enumeration. The default is Miter.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeMiterLimit Property

ChartSeries.StrokeMiterLimit Property
[image]

Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeMiterLimit As Double

Property Value

A double value. The default is 1.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.Strokes Property

ChartSeries.Strokes Property
[image]

Gets the strokes of the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection Strokes { get; set; }

Visual Basic [image] Copy Code

Public Property Strokes As BrushCollection

Property Value

A collection of WPF Brush objects. The default is an empty collection.

Remarks

Brushes from the Strokes property are used for outlining the graphical elements of the series - lines, areas, basr, pie slices, etc.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokesSource Property

ChartSeries.StrokesSource Property
[image]

Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection StrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property StrokesSource As BrushCollection

Property Value

A collection of WPF Brush objects.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeStartLineCap Property

ChartSeries.StrokeStartLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeStartLineCap As PenLineCap

Property Value

A member of the WPF PenLineCap enumeration. The default is Flat.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.StrokeThickness Property

ChartSeries.StrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. The default is 1.

Remarks

The property sets the thickness of the stroke drawn with any Brush taken from the Strokes list. Strokes are used to pain the contour of areas in an area chart or bars in a bar chart. In a line chart they draw the lines.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.Title Property

ChartSeries.Title Property
[image]

Gets or sets the title of the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is an empty string.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.ToolTipText Property

ChartSeries.ToolTipText Property
[image]

Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList ToolTipText { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipText As IList

Property Value

A list of objects to use as tooltips. The default is null (Nothing in Visual Basic).

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries.ToolTipType Property

ChartSeries.ToolTipType Property
[image]

Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ToolTipType ToolTipType { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipType As ToolTipType

Property Value

A member of the ToolTipType enumeration. The default is ChartData.

See Also

ChartSeries Members
ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeries Events

ChartSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed.
DataChanged | Occurs when series data was changed.

See Also

ChartSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeriesCollection Class

ChartSeriesCollection Class
[image]

Represents an observable collection of ChartSeries objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class ChartSeriesCollection : ObservableCollection<ChartSeries>

Visual Basic [image] Copy Code

Public Class ChartSeriesCollection
Inherits ObservableCollection(Of ChartSeries)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(ChartSeries)
System.Collections.ObjectModel.ObservableCollection(ChartSeries)
MindFusion.Charting.Wpf.ChartSeriesCollection

See Also

ChartSeriesCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeriesCollection Members

ChartSeriesCollection Members
Constructors
[image]

Represents an observable collection of ChartSeries objects.

The following tables list the members exposed by the ChartSeriesCollection type.

Public Constructors

Name | Description
ChartSeriesCollection | Initializes a new instance of the ChartSeriesCollection class.

See Also

ChartSeriesCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartSeriesCollection Constructor

ChartSeriesCollection Constructor
[image]

Initializes a new instance of the ChartSeriesCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartSeriesCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartSeriesCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Class

ChartTheme Class
[image]

Represents a styling theme for the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class ChartTheme

Visual Basic [image] Copy Code

Public Class ChartTheme

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartTheme

See Also

ChartTheme Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Members

ChartTheme Members
Constructors Properties Methods
[image]

Represents a styling theme for the chart.

The following tables list the members exposed by the ChartTheme type.

Public Constructors

Name | Description
ChartTheme | Overloaded. Initializes a new instance of the ChartTheme class.

Public Properties

Name | Description
AxisStyles | Gets or sets the styles of the axis.
SeriesStyles | Gets or sets the styles of the series.
ThemeStyle | Gets or sets the style of this theme.

Public Methods

Name | Description
Apply | Overloaded.
BasedOn | Specifies the Chart whose appearance settings will be copied to this ChartTheme.
LoadFromXml | Overloaded. Loads the current theme from an XML file or node.
SaveToXml | Overloaded. Saves the current theme to an XML file or node.

See Also

ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Constructor

ChartTheme Constructor
[image]

Initializes a new instance of the ChartTheme class.

Overload List

Name | Description
ChartTheme () | Initializes a new instance of the ChartTheme class.
ChartTheme (Chart) | Initializes a new instance of the ChartTheme based on the appearance of the specified chart.

See Also

ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Constructor ()

ChartTheme Constructor ()
See Also
[image]

Initializes a new instance of the ChartTheme class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartTheme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartTheme Constructor Overload List
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Constructor (Chart)

ChartTheme Constructor (Chart)
See Also
[image]

Initializes a new instance of the ChartTheme based on the appearance of the specified chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartTheme (
Chart chart
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart _
)

Parameters

chart

The chart that whose appearance settings will be copied to this ChartTheme.

See Also

ChartTheme Constructor Overload List
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Methods

ChartTheme Methods
[image]

Public Methods

Name | Description
Apply | Overloaded.
BasedOn | Specifies the Chart whose appearance settings will be copied to this ChartTheme.
LoadFromXml | Overloaded. Loads the current theme from an XML file or node.
SaveToXml | Overloaded. Saves the current theme to an XML file or node.

See Also

ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.Apply Method

ChartTheme.Apply Method
[image]

Overload List

Name | Description
ChartTheme.Apply (Chart) | Applies the current ChartTheme at the specified chart.
ChartTheme.Apply (Chart3D) | Applies the current ChartTheme to the specified chart.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.Apply Method (Chart)

ChartTheme.Apply Method (Chart)
See Also
[image]

Applies the current ChartTheme at the specified chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Apply (
Chart chart
)

Visual Basic [image] Copy Code

Public Sub Apply( _
chart As Chart _
)

Parameters

chart

The Chart to apply the current ChartTheme at.

See Also

Apply Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.Apply Method (Chart3D)

ChartTheme.Apply Method (Chart3D)
See Also
[image]

Applies the current ChartTheme to the specified chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Apply (
Chart3D chart
)

Visual Basic [image] Copy Code

Public Sub Apply( _
chart As Chart3D _
)

Parameters

chart

The Chart3D to apply the current ChartTheme to.

See Also

Apply Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.BasedOn Method

ChartTheme.BasedOn Method
[image]

Specifies the Chart whose appearance settings will be copied to this ChartTheme.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void BasedOn (
Chart chart
)

Visual Basic [image] Copy Code

Public Sub BasedOn( _
chart As Chart _
)

Parameters

chart

The Chart to use as a theme.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.LoadFromXml Method

ChartTheme.LoadFromXml Method
[image]

Loads the current theme from an XML file or node.

Overload List

Name | Description
ChartTheme.LoadFromXml (String) | Loads the current theme from the XML file with the specified name.
ChartTheme.LoadFromXml (XmlNode) | Loads the current ChartTheme from the specified XML node.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.LoadFromXml Method (String)

ChartTheme.LoadFromXml Method (String)
See Also
[image]

Loads the current theme from the XML file with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

A string that specifies the path to the XML file that describes the ChartTheme to load.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.LoadFromXml Method (XmlNode)

ChartTheme.LoadFromXml Method (XmlNode)
See Also
[image]

Loads the current ChartTheme from the specified XML node.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XmlNode node
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
node As XmlNode _
)

Parameters

node

A XmlNode object that specifies the node that represents the current ChartTheme.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.SaveToXml Method

ChartTheme.SaveToXml Method
[image]

Saves the current theme to an XML file or node.

Overload List

Name | Description
ChartTheme.SaveToXml (String) | Saves this ChartTheme as a XML file with the specified name.
ChartTheme.SaveToXml (XmlNode) | Saves the current theme under the specified XML node.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.SaveToXml Method (String)

ChartTheme.SaveToXml Method (String)
See Also
[image]

Saves this ChartTheme as a XML file with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where this ChartTheme will be saved.

See Also

SaveToXml Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.SaveToXml Method (XmlNode)

ChartTheme.SaveToXml Method (XmlNode)
See Also
[image]

Saves the current theme under the specified XML node.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlNode node
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
node As XmlNode _
)

Parameters

node

The XmlNode that will be the parent node for the current ChartTheme.

See Also

SaveToXml Method Overload List
ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme Properties

ChartTheme Properties
[image]

Public Properties

Name | Description
AxisStyles | Gets or sets the styles of the axis.
SeriesStyles | Gets or sets the styles of the series.
ThemeStyle | Gets or sets the style of this theme.

See Also

ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.AxisStyles Property

ChartTheme.AxisStyles Property
[image]

Gets or sets the styles of the axis.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<List<Style>> AxisStyles { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStyles As List(Of List(Of Style))

Property Value

A collection of WPF Style objects that correspond to the settings of each chart axis.

Remarks

The property allows you to set the style of charts with multiple X, X2, Y or Y2 axes.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.SeriesStyles Property

ChartTheme.SeriesStyles Property
[image]

Gets or sets the styles of the series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Style> SeriesStyles { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStyles As List(Of Style)

Property Value

A strongly typed list with WPF Style objects that represent the style of each series in the chart.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ChartTheme.ThemeStyle Property

ChartTheme.ThemeStyle Property
[image]

Gets or sets the style of this theme.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Style ThemeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ThemeStyle As Style

Property Value

An instance of the WPF Style class. The default is an empty Style object.

See Also

ChartTheme Members
ChartTheme Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter Class

Converter Class
Remarks See Also
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Remarks

This class is used internally by the control and is not intended to be called by your code.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.Converter

See Also

Converter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to a string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Color.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to the corresponding enumeration member of the specified type.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to a 64-bit integer.
ToSByte | Converts the specified string value to an 8-bit signed integer.
ToSingle | Converts the specified string value to a float.
ToStream | Converts the specified string value to a .NET Stream.
ToStreamV4 | Converts the specified string value to a .NET Stream.
ToUint16 | Converts the specified string value to an unsigned 16-bit integer.
ToUint32 | Converts the specified string value to an unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to a string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Color.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to the corresponding enumeration member of the specified type.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to a 64-bit integer.
ToSByte | Converts the specified string value to an 8-bit signed integer.
ToSingle | Converts the specified string value to a float.
ToStream | Converts the specified string value to a .NET Stream.
ToStreamV4 | Converts the specified string value to a .NET Stream.
ToUint16 | Converts the specified string value to an unsigned 16-bit integer.
ToUint32 | Converts the specified string value to an unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified boolean value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified byte value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified char value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to a string in the format #AARRGGBB.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified color value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified decimal value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified double value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified enum.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified 16-bit integer.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified 64-bit integer value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the 8-bit signed integer value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Overload List

Name | Description
Converter.FromSingle (Double) | Converts the specified double value to string.
Converter.FromSingle (Single) | Converts the specified float value to string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromSingle Method (Double)

Converter.FromSingle Method (Double)
See Also
[image]

Converts the specified double value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified double value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromSingle Method (Single)

Converter.FromSingle Method (Single)
See Also
[image]

Converts the specified float value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified float value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string that represents the specified stream value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string that represents the specified memory stream value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified 16-bit integer value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified 32-bit integer value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified unsigned 64-bit integer value.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.FromXmlElement Method

Converter.FromXmlElement Method
[image]

Deserializes a Point object from the specified XmlElement.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Point FromXmlElement (
XmlElement point
)

Visual Basic [image] Copy Code

Public Shared Function FromXmlElement( _
point As XmlElement _
) As Point

Parameters

point

The XmlElement representing the serialized point.

Return Value

A Point object deserialized from the specified XmlElement.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToBrush Method

Converter.ToBrush Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Brush ToBrush (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBrush( _
s As String _
) As Brush

Parameters

s

The string value to convert from.

Return Value

A System.Windows.Media.Brush object deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to the corresponding enumeration member of the specified type.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization fails.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to a 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to a 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to a 64-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to an 8-bit signed integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to a float.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to a .NET Stream.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to a .NET Stream.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to an unsigned 16-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to an unsigned 32-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairControl Class

CrosshairControl Class
[image]

Represents the crosshair

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CrosshairControl : ItemsControl

Visual Basic [image] Copy Code

Public Class CrosshairControl
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Wpf.CrosshairControl

See Also

CrosshairControl Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairControl Members

CrosshairControl Members
Constructors Methods
[image]

Represents the crosshair

The following tables list the members exposed by the CrosshairControl type.

Public Constructors

Name | Description
CrosshairControl | Initializes a new instance of the CrosshairControl class.

Protected Methods

Name | Description
IsItemItsOwnContainerOverride | Overrides ItemsControl.IsItemItsOwnContainerOverride

See Also

CrosshairControl Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairControl Constructor

CrosshairControl Constructor
[image]

Initializes a new instance of the CrosshairControl class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CrosshairControl Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairControl Methods

CrosshairControl Methods
[image]

Protected Methods

Name | Description
IsItemItsOwnContainerOverride | Overrides ItemsControl.IsItemItsOwnContainerOverride

See Also

CrosshairControl Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairControl.IsItemItsOwnContainerOverride Method

CrosshairControl.IsItemItsOwnContainerOverride Method
[image]

Overrides ItemsControl.IsItemItsOwnContainerOverride

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item.

Return Value

true if the item is its own container; otherwise false.

See Also

CrosshairControl Members
CrosshairControl Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel Class

CrosshairPanel Class
[image]

Arrange child crosshair elements.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CrosshairPanel : Panel

Visual Basic [image] Copy Code

Public Class CrosshairPanel
Inherits Panel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
MindFusion.Charting.Wpf.CrosshairPanel

See Also

CrosshairPanel Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel Members

CrosshairPanel Members
Constructors Methods
[image]

Arrange child crosshair elements.

The following tables list the members exposed by the CrosshairPanel type.

Public Constructors

Name | Description
CrosshairPanel | Initializes a new instance of the CrosshairPanel class.

Protected Methods

Name | Description
ArrangeOverride | Implements ArrangeOverride.
MeasureOverride | Implements MeasureOverride

See Also

CrosshairPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel Constructor

CrosshairPanel Constructor
[image]

Initializes a new instance of the CrosshairPanel class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CrosshairPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel Methods

CrosshairPanel Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Implements ArrangeOverride.
MeasureOverride | Implements MeasureOverride

See Also

CrosshairPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel.ArrangeOverride Method

CrosshairPanel.ArrangeOverride Method
[image]

Implements ArrangeOverride.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The available size.

Return Value

The final size.

See Also

CrosshairPanel Members
CrosshairPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPanel.MeasureOverride Method

CrosshairPanel.MeasureOverride Method
[image]

Implements MeasureOverride

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size.

Return Value

The desired size.

See Also

CrosshairPanel Members
CrosshairPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs Class

CrosshairPositionChangedArgs Class
[image]

Provides details about events triggered by movement of the crosshair.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CrosshairPositionChangedArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CrosshairPositionChangedArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.Wpf.CrosshairPositionChangedArgs

See Also

CrosshairPositionChangedArgs Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs Members

CrosshairPositionChangedArgs Members
Constructors Properties
[image]

Provides details about events triggered by movement of the crosshair.

The following tables list the members exposed by the CrosshairPositionChangedArgs type.

Public Constructors

Name | Description
CrosshairPositionChangedArgs | Initializes a new instance of the CrosshairPositionChangedArgs class with the specified arguments.

Public Properties

Name | Description
Series | Gets the series.
XValue | Gets the X-value of the cross-hair measured in the Cartesian coordinate system of the chart.
YValue | Gets the Y-value of the cross-hair measured in the Cartesian coordinate system of the chart.

See Also

CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs Constructor

CrosshairPositionChangedArgs Constructor
[image]

Initializes a new instance of the CrosshairPositionChangedArgs class with the specified arguments.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairPositionChangedArgs (
AxesSeries s,
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
s As AxesSeries, _
x As Double, _
y As Double _
)

Parameters

s

The series.

x

The X-coordinate of the crosshair.

y

The Y-coordinate of the crosshair.

See Also

CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs Properties

CrosshairPositionChangedArgs Properties
[image]

Public Properties

Name | Description
Series | Gets the series.
XValue | Gets the X-value of the cross-hair measured in the Cartesian coordinate system of the chart.
YValue | Gets the Y-value of the cross-hair measured in the Cartesian coordinate system of the chart.

See Also

CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs.Series Property

CrosshairPositionChangedArgs.Series Property
[image]

Gets the series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public AxesSeries Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As AxesSeries

Property Value

See Also

CrosshairPositionChangedArgs Members
CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs.XValue Property

CrosshairPositionChangedArgs.XValue Property
[image]

Gets the X-value of the cross-hair measured in the Cartesian coordinate system of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double XValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XValue As Double

Property Value

See Also

CrosshairPositionChangedArgs Members
CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairPositionChangedArgs.YValue Property

CrosshairPositionChangedArgs.YValue Property
[image]

Gets the Y-value of the cross-hair measured in the Cartesian coordinate system of the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double YValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property YValue As Double

Property Value

See Also

CrosshairPositionChangedArgs Members
CrosshairPositionChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter Class

CrosshairToVisibilityConverter Class
[image]

Converts values of the chart crosshair to a value of the Visibility enum.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CrosshairToVisibilityConverter : IMultiValueConverter

Visual Basic [image] Copy Code

Public Class CrosshairToVisibilityConverter
Implements IMultiValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.CrosshairToVisibilityConverter

See Also

CrosshairToVisibilityConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter Members

CrosshairToVisibilityConverter Members
Constructors Methods
[image]

Converts values of the chart crosshair to a value of the Visibility enum.

The following tables list the members exposed by the CrosshairToVisibilityConverter type.

Public Constructors

Name | Description
CrosshairToVisibilityConverter |

Public Methods

Name | Description
Convert | Converts the specified value to one of the Visibility enum values.
ConvertBack | Converts the values back to their original types.

See Also

CrosshairToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter Constructor

CrosshairToVisibilityConverter Constructor
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairToVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CrosshairToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter Methods

CrosshairToVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts the specified value to one of the Visibility enum values.
ConvertBack | Converts the values back to their original types.

See Also

CrosshairToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter.Convert Method

CrosshairToVisibilityConverter.Convert Method
[image]

Converts the specified value to one of the Visibility enum values.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object[] values,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
values() As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

values

The values to convert.

targetType

The target type of the conversion.

parameter

Parameters to use by the conversion.

culture

The culture of the conversion.

Return Value

The converted value.

See Also

CrosshairToVisibilityConverter Members
CrosshairToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairToVisibilityConverter.ConvertBack Method

CrosshairToVisibilityConverter.ConvertBack Method
[image]

Converts the values back to their original types.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object[] ConvertBack (
Object value,
Type[] targetTypes,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetTypes() As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object()

Parameters

value

The value to convert.

targetTypes

The target types of the conversion.

parameter

Parameters to use by the conversion.

culture

The culture of the conversion.

Return Value

The converted value.

See Also

CrosshairToVisibilityConverter Members
CrosshairToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairType Enumeration

CrosshairType Enumeration
[image]

Identifies how the crosshair is rendered.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum CrosshairType

Visual Basic [image] Copy Code

Public Enum CrosshairType

Members

Member name | Description
ShowCrosshair | Renders only the crosshair.
ShowValuesX | Renders the crosshair together with the X-value.
ShowValuesXY | Renders both the X and Y value and the crosshair.
ShowValuesY | Renders the crosshair with the Y-value.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter Class

CrosshairTypeToVisibilityConverter Class
[image]

Converts the type of the crosshair to visibility enum value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class CrosshairTypeToVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class CrosshairTypeToVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter

See Also

CrosshairTypeToVisibilityConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter Members

CrosshairTypeToVisibilityConverter Members
Constructors Methods
[image]

Converts the type of the crosshair to visibility enum value.

The following tables list the members exposed by the CrosshairTypeToVisibilityConverter type.

Public Constructors

Name | Description
CrosshairTypeToVisibilityConverter |

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | Implements IValueConverter.ConvertBack

See Also

CrosshairTypeToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter Constructor

CrosshairTypeToVisibilityConverter Constructor
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CrosshairTypeToVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CrosshairTypeToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter Methods

CrosshairTypeToVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | Implements IValueConverter.ConvertBack

See Also

CrosshairTypeToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter.Convert Method

CrosshairTypeToVisibilityConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type of the conversion.

parameter

Parameters for the conversion.

culture

The culture.

Return Value

The converted value.

See Also

CrosshairTypeToVisibilityConverter Members
CrosshairTypeToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CrosshairTypeToVisibilityConverter.ConvertBack Method

CrosshairTypeToVisibilityConverter.ConvertBack Method
[image]

Implements IValueConverter.ConvertBack

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

CrosshairTypeToVisibilityConverter Members
CrosshairTypeToVisibilityConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.CustomLabelPosition Enumeration

CustomLabelPosition Enumeration
[image]

Specifies where custom labels are drawn.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum CustomLabelPosition

Visual Basic [image] Copy Code

Public Enum CustomLabelPosition

Members

Member name | Description
AutoScalePoints | The labels are the drawn at auto scale points.
ChartDataPoints | The labels are draw at data points.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Class

FunnelChart Class
[image]

A control used to draw funnel charts. Funnel charts represent the stages of a process and show relative values or measurements associated with each stage.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class FunnelChart : Chart

Visual Basic [image] Copy Code

Public Class FunnelChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.FunnelChart

See Also

FunnelChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Members

FunnelChart Members
Constructors Fields Properties Methods Events
[image]

A control used to draw funnel charts. Funnel charts represent the stages of a process and show relative values or measurements associated with each stage.

The following tables list the members exposed by the FunnelChart type.

Public Constructors

Name | Description
FunnelChart | Initializes a new instance of the FunnelChart class.

Public Fields

Name | Description
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
SegmentPaddingProperty | Identifies the SegmentPadding dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
StemWidthProperty | Identifies the StemWidth dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Public Properties

Name | Description
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CurrentSeries | Gets or sets the FunnelSeries displayed in this chart.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
SegmentPadding | Gets or sets the padding space between funnel segments.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowLabels | Gets or sets whether to show data labels.
StemWidth | Gets or sets the width of the funnel stem.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | FrameworkElement.ApplyTemplate override. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Fields

FunnelChart Fields
[image]

Public Fields

Name | Description
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
SegmentPaddingProperty | Identifies the SegmentPadding dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
StemWidthProperty | Identifies the StemWidth dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

See Also

FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.SegmentPaddingProperty Field

FunnelChart.SegmentPaddingProperty Field
[image]

Identifies the SegmentPadding dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SegmentPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SegmentPaddingProperty As DependencyProperty

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.ShowLabelsProperty Field

FunnelChart.ShowLabelsProperty Field
[image]

Identifies the ShowLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowLabelsProperty As DependencyProperty

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.StemWidthProperty Field

FunnelChart.StemWidthProperty Field
[image]

Identifies the StemWidth dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StemWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StemWidthProperty As DependencyProperty

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Constructor

FunnelChart Constructor
[image]

Initializes a new instance of the FunnelChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FunnelChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Properties

FunnelChart Properties
[image]

Public Properties

Name | Description
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CurrentSeries | Gets or sets the FunnelSeries displayed in this chart.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
SegmentPadding | Gets or sets the padding space between funnel segments.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowLabels | Gets or sets whether to show data labels.
StemWidth | Gets or sets the width of the funnel stem.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

See Also

FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.CurrentSeries Property

FunnelChart.CurrentSeries Property
[image]

Gets or sets the FunnelSeries displayed in this chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FunnelSeries CurrentSeries { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentSeries As FunnelSeries

Property Value

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.SegmentPadding Property

FunnelChart.SegmentPadding Property
[image]

Gets or sets the padding space between funnel segments.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SegmentPadding { get; set; }

Visual Basic [image] Copy Code

Public Property SegmentPadding As Double

Property Value

A double value specifying padding size. The default value is 0.

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.ShowLabels Property

FunnelChart.ShowLabels Property
[image]

Gets or sets whether to show data labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLabels As Boolean

Property Value

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart.StemWidth Property

FunnelChart.StemWidth Property
[image]

Gets or sets the width of the funnel stem.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StemWidth { get; set; }

Visual Basic [image] Copy Code

Public Property StemWidth As Double

Property Value

A double value specifying the stem width. The default value is 0.

See Also

FunnelChart Members
FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelChart Events

FunnelChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

FunnelChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Class

FunnelPiece Class
[image]

Represents a segment of funnel chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class FunnelPiece : ChartElement

Visual Basic [image] Copy Code

Public Class FunnelPiece
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.FunnelPiece

See Also

FunnelPiece Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Members

FunnelPiece Members
Constructors Properties Methods
[image]

Represents a segment of funnel chart.

The following tables list the members exposed by the FunnelPiece type.

Public Constructors

Name | Description
FunnelPiece | Overloaded.

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Visible | Gets or sets whether this object is visible.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this chart element.

See Also

FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Constructor

FunnelPiece Constructor
[image]

Overload List

Name | Description
FunnelPiece (Double, Brush) | Initializes a new instance of the FunnelPiece class.
FunnelPiece (Double, Brush, Int32) | Initializes a new instance of the FunnelPiece class.

See Also

FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Constructor (Double, Brush)

FunnelPiece Constructor (Double, Brush)
See Also
[image]

Initializes a new instance of the FunnelPiece class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FunnelPiece (
double coeff,
Brush fill
)

Visual Basic [image] Copy Code

Public New ( _
coeff As Double, _
fill As Brush _
)

Parameters

coeff

fill

See Also

FunnelPiece Constructor Overload List
FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Constructor (Double, Brush, Int32)

FunnelPiece Constructor (Double, Brush, Int32)
See Also
[image]

Initializes a new instance of the FunnelPiece class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FunnelPiece (
double coeff,
Brush fill,
int pieceCount
)

Visual Basic [image] Copy Code

Public New ( _
coeff As Double, _
fill As Brush, _
pieceCount As Integer _
)

Parameters

coeff

fill

pieceCount

See Also

FunnelPiece Constructor Overload List
FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Methods

FunnelPiece Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this chart element.

See Also

FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece.CreateShape Method

FunnelPiece.CreateShape Method
[image]

Creates a Shape that represents this chart element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A Shape instance.

See Also

FunnelPiece Members
FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece Properties

FunnelPiece Properties
[image]

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
Visible | Gets or sets whether this object is visible.

See Also

FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelPiece.Visible Property

FunnelPiece.Visible Property
[image]

Gets or sets whether this object is visible.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

See Also

FunnelPiece Members
FunnelPiece Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries Class

FunnelSeries Class
[image]

Represents a series in a funnel chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class FunnelSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class FunnelSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.FunnelSeries

See Also

FunnelSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries Members

FunnelSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a funnel chart.

The following tables list the members exposed by the FunnelSeries type.

Public Constructors

Name | Description
FunnelSeries | Initializes a new instance of the FunnelSeries class.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving labels.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries Constructor

FunnelSeries Constructor
[image]

Initializes a new instance of the FunnelSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FunnelSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries Properties

FunnelSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving labels.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

See Also

FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries.DataPath Property

FunnelSeries.DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the data for this series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property DataPath As String

Property Value

See Also

FunnelSeries Members
FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries.LabelPath Property

FunnelSeries.LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving labels.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

See Also

FunnelSeries Members
FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.FunnelSeries Events

FunnelSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

FunnelSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.GridType Enumeration

GridType Enumeration
[image]

Specifies the possible grid options for charts that support grid.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum GridType

Visual Basic [image] Copy Code

Public Enum GridType

Members

Member name | Description
Crossed | The grid is built of vertical and horizontal segments, which follow the intervals of the two axes.
Horizontal | The grid is built of horizontal segments only.
None | No grid is drawn.
Vertical | The grid is built of vertical segments only.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.InnerLabelPosition Enumeration

InnerLabelPosition Enumeration
[image]

Defines values that specify the alignment of the inner labels in a radar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum InnerLabelPosition

Visual Basic [image] Copy Code

Public Enum InnerLabelPosition

Members

Member name | Description
Center | The label is aligned to the center.
Left | The label is aligned to the left.
Right | The label is aligned to the right.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.InterpolationType Enumeration

InterpolationType Enumeration
[image]

Defines shape types that are used when elevations are drawn at the surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum InterpolationType

Visual Basic [image] Copy Code

Public Enum InterpolationType

Members

Member name | Description
Bezier | Defines bezier interpolation type.
Linear | Defines linear interpolation type.
None | Defines no interpolation type.

Remarks

Charts that use the Linear interpolation type have sharper edges than charts that use the Bezier interpolation type.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LabelPresenter Class

LabelPresenter Class
[image]

Represents labels in a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LabelPresenter : ContentControl

Visual Basic [image] Copy Code

Public Class LabelPresenter
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Charting.Wpf.LabelPresenter

See Also

LabelPresenter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LabelPresenter Members

LabelPresenter Members
Constructors
[image]

Represents labels in a 3D chart.

The following tables list the members exposed by the LabelPresenter type.

Public Constructors

Name | Description
LabelPresenter | Initializes a new instance of the LabelPresenter class.

See Also

LabelPresenter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LabelPresenter Constructor

LabelPresenter Constructor
[image]

Initializes a new instance of the LabelPresenter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LabelPresenter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LabelType Enumeration

LabelType Enumeration
[image]

Specifies the different types of chart labels that can be drawn at the chart axes.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum LabelType

Visual Basic [image] Copy Code

Public Enum LabelType

Members

Member name | Description
AutoScale | The labels are the numbers from the numerical auto scale.
ChartData | The labels are the numbers from the chart data.
CustomText | The labels are set by the user.
Empty | No labels are drawn.
Percents | The labels show the percentage value of each element.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Class

LayoutPanel Class
[image]

Represents the panel of the whole chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LayoutPanel : Panel

Visual Basic [image] Copy Code

Public Class LayoutPanel
Inherits Panel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
MindFusion.Charting.Wpf.LayoutPanel

See Also

LayoutPanel Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Members

LayoutPanel Members
Constructors Fields Attached Properties Properties Methods
[image]

Represents the panel of the whole chart.

The following tables list the members exposed by the LayoutPanel type.

Public Constructors

Name | Description
LayoutPanel | Initializes a new instance of the LayoutPanel class.

Public Fields

Name | Description
DockProperty | Identifies the Dock attached property.
PlotAreaProperty | Identifies the PlotArea dependency property.

Public Attached Properties

Name | Description
DockProperty | Gets or sets a value that indicates the position of a chart element within a parent DockPanel.

Public Properties

Name | Description
PlotArea | Gets or sets the plot area where the chart is drawn. This is a dependency property.

Public Methods

Name | Description
GetDock | Gets the dock of an element contained in the LayoutPanel.
SetDock | Sets the dock of an element added to the layout panel.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Fields

LayoutPanel Fields
[image]

Public Fields

Name | Description
DockProperty | Identifies the Dock attached property.
PlotAreaProperty | Identifies the PlotArea dependency property.

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.DockProperty Field

LayoutPanel.DockProperty Field
[image]

Identifies the Dock attached property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockProperty As DependencyProperty

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.PlotAreaProperty Field

LayoutPanel.PlotAreaProperty Field
[image]

Identifies the PlotArea dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaProperty As DependencyProperty

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Constructor

LayoutPanel Constructor
[image]

Initializes a new instance of the LayoutPanel class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LayoutPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Methods

LayoutPanel Methods
[image]

Public Methods

Name | Description
GetDock | Gets the dock of an element contained in the LayoutPanel.
SetDock | Sets the dock of an element added to the layout panel.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.ArrangeOverride Method

LayoutPanel.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The size allocated for the LayoutPanel.

Return Value

The size used by the LayoutPanel.

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.GetDock Method

LayoutPanel.GetDock Method
[image]

Gets the dock of an element contained in the LayoutPanel.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static Dock GetDock (
UIElement element
)

Visual Basic [image] Copy Code

Public Shared Function GetDock( _
element As UIElement _
) As Dock

Parameters

element

The element.

Return Value

The dock of the element. A member of the WPF Dock enumeration.

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.MeasureOverride Method

LayoutPanel.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The size available for the LayoutPanel.

Return Value

The size requested by the LayoutPanel.

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.SetDock Method

LayoutPanel.SetDock Method
[image]

Sets the dock of an element added to the layout panel.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static void SetDock (
UIElement element,
Dock dock
)

Visual Basic [image] Copy Code

Public Shared Sub SetDock( _
element As UIElement, _
dock As Dock _
)

Parameters

element

The element to be added.

dock

The dock.

Example

The following example sets the dock of a ChartLegend to Right.

C# [image] Copy Code

LayoutPanel.SetDock(chartLegend1, Dock.Right);

Visual Basic [image] Copy Code

LayoutPanel.SetDock(chartLegend1, Dock.Right)

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Attached Properties

LayoutPanel Attached Properties
[image]

Public Attached Properties

Name | Description
DockProperty | Gets or sets a value that indicates the position of a chart element within a parent DockPanel.

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.Dock Attached Property

LayoutPanel.Dock Attached Property
[image]

Gets or sets a value that indicates the position of a chart element within a parent DockPanel.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code
See LayoutPanel.GetDock, LayoutPanel.SetDock
Visual Basic [image] Copy Code
See LayoutPanel.GetDock, LayoutPanel.SetDock

Property Value

A member of the WPF Dock enumeration.

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel Properties

LayoutPanel Properties
[image]

Public Properties

Name | Description
PlotArea | Gets or sets the plot area where the chart is drawn. This is a dependency property.

See Also

LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LayoutPanel.PlotArea Property

LayoutPanel.PlotArea Property
[image]

Gets or sets the plot area where the chart is drawn. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FrameworkElement PlotArea { get; set; }

Visual Basic [image] Copy Code

Public Property PlotArea As FrameworkElement

Property Value

A WPF FrameworkElement object.

See Also

LayoutPanel Members
LayoutPanel Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Class

Legend Class
[image]

A base class for classes that create legends in the chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public abstract class Legend : ItemsControl

Visual Basic [image] Copy Code

Public MustInherit Class Legend
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Wpf.Legend
MindFusion.Charting.Wpf.ChartLegend
MindFusion.Charting.Wpf.SeriesLegend

See Also

Legend Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Members

Legend Members
Constructors Fields Properties Events
[image]

A base class for classes that create legends in the chart.

The following tables list the members exposed by the Legend type.

Protected Constructors

Name | Description
Legend | Initializes a new instance of the Legend class.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property.
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property.
Orientation | Gets or sets the orientation of the legend. This is a dependency property.
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property.
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property.

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed.

See Also

Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Fields

Legend Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

See Also

Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.CornerRadiusProperty Field

Legend.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared CornerRadiusProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.HorizontalAlignmentProperty Field

Legend.HorizontalAlignmentProperty Field
[image]

Identifies the HorizontalAlignment dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared HorizontalAlignmentProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.OrientationProperty Field

Legend.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.ShapeSizeProperty Field

Legend.ShapeSizeProperty Field
[image]

Identifies the ShapeSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeSizeProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.StrokeThicknessProperty Field

Legend.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.VerticalAlignmentProperty Field

Legend.VerticalAlignmentProperty Field
[image]

Identifies the VerticalAlignment dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared VerticalAlignmentProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Constructor

Legend Constructor
[image]

Initializes a new instance of the Legend class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Legend ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Properties

Legend Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property.
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property.
Orientation | Gets or sets the orientation of the legend. This is a dependency property.
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property.
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property.

See Also

Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.CornerRadius Property

Legend.CornerRadius Property
[image]

Gets or sets the corner radius of the legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the WPF CornerRadius structure. The default is CornerRadius(3).

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.HorizontalAlignment Property

Legend.HorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public new HorizontalAlignment HorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property HorizontalAlignment As HorizontalAlignment

Property Value

A member of the WPF HorizontalAlignment enumeration. The default is Top.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.Orientation Property

Legend.Orientation Property
[image]

Gets or sets the orientation of the legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the WPF Orientation enumeration. The default is Vertical.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.ShapeSize Property

Legend.ShapeSize Property
[image]

Gets or sets the size of the shapes in the legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

A double value. The default is 10.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.StrokeThickness Property

Legend.StrokeThickness Property
[image]

Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. The default is 1.

Remarks

The StrokeThickness specifies how thick the outline of rectangles drawn before legend labels will be.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend.VerticalAlignment Property

Legend.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public new VerticalAlignment VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property VerticalAlignment As VerticalAlignment

Property Value

A member of the WPF VerticalAlignment enumeration. The default is Top.

See Also

Legend Members
Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Legend Events

Legend Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed.

See Also

Legend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem Class

LegendItem Class
Remarks See Also
[image]

Represents an item in a SeriesLegend.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LegendItem : DependencyObject

Visual Basic [image] Copy Code

Public Class LegendItem
Inherits DependencyObject

Remarks

LegendItem represents entries in a SeriesLegend. Use this type of legend when you want to have full control over the labels and colors of the legend.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Charting.Wpf.LegendItem

See Also

LegendItem Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem Members

LegendItem Members
Constructors Fields Properties
[image]

Represents an item in a SeriesLegend.

The following tables list the members exposed by the LegendItem type.

Public Constructors

Name | Description
LegendItem | Initializes a new instance of the LegendItem class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
LabelProperty | Identifies the Label dependency property.

Public Properties

Name | Description
Brush | The Brush used for painting the shape of this item. This is a dependency property.
Label | The label for this item. This is a dependency property.

See Also

LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem Fields

LegendItem Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
LabelProperty | Identifies the Label dependency property.

See Also

LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem.BrushProperty Field

LegendItem.BrushProperty Field
[image]

Identifies the Brush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

LegendItem Members
LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem.LabelProperty Field

LegendItem.LabelProperty Field
[image]

Identifies the Label dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

LegendItem Members
LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem Constructor

LegendItem Constructor
[image]

Initializes a new instance of the LegendItem class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LegendItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem Properties

LegendItem Properties
[image]

Public Properties

Name | Description
Brush | The Brush used for painting the shape of this item. This is a dependency property.
Label | The label for this item. This is a dependency property.

See Also

LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem.Brush Property

LegendItem.Brush Property
[image]

The Brush used for painting the shape of this item. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the WPF Brush class. The default is a solid light blue brush.

Remarks

The Brush paints the rectangle before the Label in the legend.

See Also

LegendItem Members
LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendItem.Label Property

LegendItem.Label Property
[image]

The label for this item. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As Object

Property Value

An object to be used as label. The default is an empty string.

See Also

LegendItem Members
LegendItem Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendsCollection Class

LegendsCollection Class
[image]

Represents an observable collection of Legend objects.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LegendsCollection : ObservableCollection<Legend>

Visual Basic [image] Copy Code

Public Class LegendsCollection
Inherits ObservableCollection(Of Legend)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Legend)
System.Collections.ObjectModel.ObservableCollection(Legend)
MindFusion.Charting.Wpf.LegendsCollection

See Also

LegendsCollection Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendsCollection Members

LegendsCollection Members
Constructors
[image]

Represents an observable collection of Legend objects.

The following tables list the members exposed by the LegendsCollection type.

Public Constructors

Name | Description
LegendsCollection | Initializes a new instance of the LegendsCollection class.

See Also

LegendsCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LegendsCollection Constructor

LegendsCollection Constructor
[image]

Initializes a new instance of the LegendsCollection class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LegendsCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendsCollection Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LightType Enumeration

LightType Enumeration
[image]

Defines light types that can be used in a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum LightType

Visual Basic [image] Copy Code

Public Enum LightType

Members

Member name | Description
Ambient | Defines a light that provides constant lightening at the 3D scene.
Directional | Defines a light that projects its effect along a specified vector.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line Class

Line Class
[image]

Represents a line in line charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Line : ChartElement

Visual Basic [image] Copy Code

Public Class Line
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Line

See Also

Line Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line Members

Line Members
Properties Methods
[image]

Represents a line in line charts.

The following tables list the members exposed by the Line type.

Public Properties

Name | Description
DataPoints | Gets the data points this line represents.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
LineType | Gets the type of the line.
Points | Gets the points for this line.
SeriesIndex | Gets the index of the series represented by this line.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

See Also

Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line Methods

Line Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

See Also

Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line.CreateShape Method

Line.CreateShape Method
[image]

Creates a Shape that represents the line element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A WPF Shape object.

See Also

Line Members
Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line Properties

Line Properties
[image]

Public Properties

Name | Description
DataPoints | Gets the data points this line represents.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
LineType | Gets the type of the line.
Points | Gets the points for this line.
SeriesIndex | Gets the index of the series represented by this line.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line.DataPoints Property

Line.DataPoints Property
[image]

Gets the data points this line represents.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointCollection DataPoints { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DataPoints As PointCollection

Property Value

An instance of the WPF PointCollection class.

See Also

Line Members
Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line.LineType Property

Line.LineType Property
[image]

Gets the type of the line.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LineType LineType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineType As LineType

Property Value

A member of the LineType enumeration.

See Also

Line Members
Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line.Points Property

Line.Points Property
[image]

Gets the points for this line.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointCollection Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the WPF PointCollection class.

See Also

Line Members
Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Line.SeriesIndex Property

Line.SeriesIndex Property
[image]

Gets the index of the series represented by this line.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An integer value.

Remarks

The SeriesIndex corresponds to the position in the Series property of the ChartSeries this line represents.

See Also

Line Members
Line Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineChart Class

LineChart Class
[image]

Represents a line chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LineChart : AxesChart

Visual Basic [image] Copy Code

Public Class LineChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.AxesChart
MindFusion.Charting.Wpf.LineChart

See Also

LineChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineChart Members

LineChart Members
Constructors Fields Properties Methods Events
[image]

Represents a line chart.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Initializes a new instance of the LineChart class.

Public Fields

Name | Description
BarTypeProperty | Identifies the BarType dependency property. (Inherited from AxesChart.)
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
ClipToPlotAreaProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
CrosshairBackgroundProperty | Identifies the CrosshairBackground dependency property. (Inherited from AxesChart.)
CrosshairStrokeProperty | Identifies the CrosshairStroke dependency property. (Inherited from AxesChart.)
CrosshairStrokeThicknessProperty | Identifies the CrosshairStrokeThickness dependency property. (Inherited from AxesChart.)
CrosshairTemplateProperty | Identifies the CrosshairTemplate dependency property. (Inherited from AxesChart.)
CrosshairTypeProperty | Identifies the CrosshairType dependency property. (Inherited from AxesChart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
LineTypeProperty | Identifies the LineType dependency property. (Inherited from AxesChart.)
MinZoomSpanProperty | Identifies the MinZoomSpan dependency property. (Inherited from AxesChart.)
MousePositionProperty | Identifies the MousePosition dependency property. (Inherited from AxesChart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaRectProperty | Identifies the PlotAreaRect dependency property. (Inherited from AxesChart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
SecondaryGridFillsProperty | Identifies the SecondaryGridFills dependency property. (Inherited from AxesChart.)
SecondaryGridStrokesProperty | Identifies the SecondaryGridStrokes dependency property. (Inherited from AxesChart.)
ShowCrosshairProperty | Identifies the ShowCrosshair dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2AxesProperty | Identifies the X2Axes dependency property. (Inherited from AxesChart.)
XAxesProperty | Identifies the XAxes dependency property. (Inherited from AxesChart.)
Y2AxesProperty | Identifies the Y2Axes dependency property. (Inherited from AxesChart.)
YAxesProperty | Identifies the YAxes dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
BarType | Gets or sets the type of bars for all bar series. (Inherited from AxesChart.)
Behavior | Gets or sets the behavior of the chart control. (Inherited from AxesChart.)
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
ClipToPlotArea | Clip all data in bounds of the plot area. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
CrosshairBackground | Gets or sets the background brush of the crosshair. (Inherited from AxesChart.)
CrosshairStroke | Gets or sets the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairStrokeThickness | Gets or sets the thickness of the stroke for the crosshair. (Inherited from AxesChart.)
CrosshairTemplate | Gets or sets the crosshair template. (Inherited from AxesChart.)
CrosshairType | Gets or sets the type of crosshair. (Inherited from AxesChart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
LineType | Gets or sets the type of lines for all line series. (Inherited from AxesChart.)
MinZoomSpan | Gets or sets the area of zoom. (Inherited from AxesChart.)
MousePosition | Gets or sets the position of the mouse. (Inherited from AxesChart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
SecondaryGridFills | Gets or sets the secondary brushes for the grid stripes. (Inherited from AxesChart.)
SecondaryGridStrokes | Gets or sets the secondary brushes for the grid lines. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
ShowCrosshair | Gets or sets whether the crosshair is visible. (Inherited from AxesChart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2Axes | Gets setttings for all X2 axes of the chart. (Inherited from AxesChart.)
XAxes | Gets setttings for all X axes of the chart. (Inherited from AxesChart.)
Y2Axes | Gets setttings for all Y2 axes of the chart. (Inherited from AxesChart.)
YAxes | Gets setttings for all Y axes of the chart. (Inherited from AxesChart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
CreateImage | Converts the chart object into a Bitmap. (Inherited from AxesChart.)
CrosshairPosition | Gets the current location of the crosshair. (Inherited from AxesChart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
ExportImage | Exports a RenderTargetBitmap to a png file. (Inherited from AxesChart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Control.OnApplyTemplate override. (Inherited from AxesChart.)
OnAxesChanged | Raised when the axes has changed. (Inherited from AxesChart.)
OnCrosshairPositionChanged | Triggers the CrosshairPositionChanged event. (Inherited from AxesChart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms into the specified range of the chart graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse enters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnPreviewMouseDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnPreviewMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)
OnPreviewMouseUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineChart Constructor

LineChart Constructor
[image]

Initializes a new instance of the LineChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LineChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineChart Events

LineChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
CrosshairPositionChanged | Event handler for the CrosshairPositionChanged event. (Inherited from AxesChart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)
ZoomChanged | Raised when zooming into a data range. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Class

LineSeries Class
[image]

Represents a series in a line chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class LineSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class LineSeries
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.LineSeries

See Also

LineSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Members

LineSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a line chart.

The following tables list the members exposed by the LineSeries type.

Public Constructors

Name | Description
LineSeries | Overloaded.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
CurveProperty | Identifies the Curve dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
ScatterFillsSourceProperty | Identifies the ScatterFills property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesSourceProperty | Identifies the ScatterStrokesSource dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Curve | Gets or sets whether the line is drawn as a canonical spline.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelOffset | Gets or sets the offset of the labels displayed for the values in this series. This is a dependency property.
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels. This is a dependency property.
Labels | Gets or sets the labels drawn at data points. This is a dependency property.
ScatterFills | Gets the fills of the scatters. This is a dependency property.
ScatterFillsSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
ScatterSize | Gets or sets the size of the scatter for the series. This is a dependency property.
ScatterStrokes | Gets the strokes of the scatters. This is a dependency property.
ScatterStrokesSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to stroke the scatters in this series. This is a dependency property.
ScatterStrokeThickness | Gets or sets the thickness of the scatter strokes. This is a dependency property.
ScatterType | Gets or sets the type of the scatter for the series. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Fields

LineSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
CurveProperty | Identifies the Curve dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
ScatterFillsSourceProperty | Identifies the ScatterFills property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesSourceProperty | Identifies the ScatterStrokesSource dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.CurveProperty Field

LineSeries.CurveProperty Field
[image]

Identifies the Curve dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CurveProperty

Visual Basic [image] Copy Code

Public Shared CurveProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.LabelOffsetProperty Field

LineSeries.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.LabelPathProperty Field

LineSeries.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.LabelsProperty Field

LineSeries.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterFillsSourceProperty Field

LineSeries.ScatterFillsSourceProperty Field
[image]

Identifies the ScatterFills property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterFillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterFillsSourceProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterSizeProperty Field

LineSeries.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterStrokesSourceProperty Field

LineSeries.ScatterStrokesSourceProperty Field
[image]

Identifies the ScatterStrokesSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokesSourceProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterStrokeThicknessProperty Field

LineSeries.ScatterStrokeThicknessProperty Field
[image]

Identifies the ScatterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokeThicknessProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterTypeProperty Field

LineSeries.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Constructor

LineSeries Constructor
[image]

Overload List

Name | Description
LineSeries () | Initializes a new instance of the LineSeries class.
LineSeries (Axis, Axis) | Creates a new LineSeries.

See Also

LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Constructor ()

LineSeries Constructor ()
See Also
[image]

Initializes a new instance of the LineSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LineSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineSeries Constructor Overload List
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Constructor (Axis, Axis)

LineSeries Constructor (Axis, Axis)
See Also
[image]

Creates a new LineSeries.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LineSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

LineSeries Constructor Overload List
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Properties

LineSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Curve | Gets or sets whether the line is drawn as a canonical spline.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelOffset | Gets or sets the offset of the labels displayed for the values in this series. This is a dependency property.
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels. This is a dependency property.
Labels | Gets or sets the labels drawn at data points. This is a dependency property.
ScatterFills | Gets the fills of the scatters. This is a dependency property.
ScatterFillsSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
ScatterSize | Gets or sets the size of the scatter for the series. This is a dependency property.
ScatterStrokes | Gets the strokes of the scatters. This is a dependency property.
ScatterStrokesSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to stroke the scatters in this series. This is a dependency property.
ScatterStrokeThickness | Gets or sets the thickness of the scatter strokes. This is a dependency property.
ScatterType | Gets or sets the type of the scatter for the series. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)

See Also

LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.Curve Property

LineSeries.Curve Property
[image]

Gets or sets whether the line is drawn as a canonical spline.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool Curve { get; set; }

Visual Basic [image] Copy Code

Public Property Curve As Boolean

Property Value

A boolean value. The default value is false.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.LabelOffset Property

LineSeries.LabelOffset Property
[image]

Gets or sets the offset of the labels displayed for the values in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. The default is 10.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.LabelPath Property

LineSeries.LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

A string value. The default is an empty string.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.Labels Property

LineSeries.Labels Property
[image]

Gets or sets the labels drawn at data points. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

When the labels are not strings they are converted using their ToString method.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterFills Property

LineSeries.ScatterFills Property
[image]

Gets the fills of the scatters. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ScatterFills { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFills As BrushCollection

Property Value

An instance of the BrushCollection class. The default is an empty collection.

Remarks

Brushes from ScatterFills are used to paint the interior of scatter shapes drawn at data points in line charts. Each scatter is painted with a consecutive Brush from ScatterFills. If count of ScatterFills is less than count of scatters the control cycles through them.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterFillsSource Property

LineSeries.ScatterFillsSource Property
[image]

Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ScatterFillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFillsSource As BrushCollection

Property Value

An instance of the BrushCollection class.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterSize Property

LineSeries.ScatterSize Property
[image]

Gets or sets the size of the scatter for the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As Double

Property Value

A double value. The default is 10.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterStrokes Property

LineSeries.ScatterStrokes Property
[image]

Gets the strokes of the scatters. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ScatterStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokes As BrushCollection

Property Value

An instance of the BrushCollection class. The default is an empty collection.

Remarks

Brushes from ScatterStrokes are used to paint the outline of scatter shapes drawn at data points in line charts. Each scatter is struck with a consecutive Brush from ScatterStrokes. If count of ScatterStrokes is less than count of scatters the control cycles through them.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterStrokesSource Property

LineSeries.ScatterStrokesSource Property
[image]

Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to stroke the scatters in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ScatterStrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokesSource As BrushCollection

Property Value

An instance of the BrushCollection class.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterStrokeThickness Property

LineSeries.ScatterStrokeThickness Property
[image]

Gets or sets the thickness of the scatter strokes. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ScatterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries.ScatterType Property

LineSeries.ScatterType Property
[image]

Gets or sets the type of the scatter for the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

A member of the ScatterType enumeration. The default is None.

See Also

LineSeries Members
LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineSeries Events

LineSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

LineSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.LineType Enumeration

LineType Enumeration
[image]

Specifies the type of the line chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum LineType

Visual Basic [image] Copy Code

Public Enum LineType

Members

Member name | Description
Area2D | the chart is drawn as an area.
Area2DStack | the chart is drawn as a stacked area.
Line | the chart is drawn as a line.
None | No graphic is drawn.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Class

Mesh Class
[image]

Generates a mesh in 3D charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Mesh

Visual Basic [image] Copy Code

Public Class Mesh

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.Mesh

See Also

Mesh Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Members

Mesh Members
Constructors Fields Properties Methods
[image]

Generates a mesh in 3D charts.

The following tables list the members exposed by the Mesh type.

Public Constructors

Name | Description
Mesh |

Protected Fields

Name | Description
m_bounds | Bounds
m_facets | The facets.
m_points | A list ov vertices that build the mesh points.
m_recursion | Recursion limit.

Public Properties

Name | Description
Bounds | Bounds.
Facets | The facets.
Points | The points.
Recursion | Recursion level.

Public Methods

Name | Description
Append | Appends the specified point.
Compute | Performs computations needed for rendering a 3D chart.
GetVertexIndicies | Get the indexes for the triangular mesh. Points is the points. Every 3 indicies is a triangle.
Setup | Performs initial setup for a 3D chart.

Protected Methods

Name | Description
flipIfNeeded | Flip if needed.
Insert | Insert.

See Also

Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Fields

Mesh Fields
[image]

Protected Fields

Name | Description
m_bounds | Bounds
m_facets | The facets.
m_points | A list ov vertices that build the mesh points.
m_recursion | Recursion limit.

See Also

Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.m_bounds Field

Mesh.m_bounds Field
[image]

Bounds

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Rect m_bounds

Visual Basic [image] Copy Code

Protected m_bounds As Rect

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.m_facets Field

Mesh.m_facets Field
[image]

The facets.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected List<Triangle> m_facets

Visual Basic [image] Copy Code

Protected m_facets As List(Of Triangle)

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.m_points Field

Mesh.m_points Field
[image]

A list ov vertices that build the mesh points.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected List<Vertex> m_points

Visual Basic [image] Copy Code

Protected m_points As List(Of Vertex)

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.m_recursion Field

Mesh.m_recursion Field
[image]

Recursion limit.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected int m_recursion

Visual Basic [image] Copy Code

Protected m_recursion As Integer

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Constructor

Mesh Constructor
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Mesh ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Methods

Mesh Methods
[image]

Public Methods

Name | Description
Append | Appends the specified point.
Compute | Performs computations needed for rendering a 3D chart.
GetVertexIndicies | Get the indexes for the triangular mesh. Points is the points. Every 3 indicies is a triangle.
Setup | Performs initial setup for a 3D chart.

Protected Methods

Name | Description
flipIfNeeded | Flip if needed.
Insert | Insert.

See Also

Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Append Method

Mesh.Append Method
[image]

Appends the specified point.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Append (
Vertex v
)

Visual Basic [image] Copy Code

Public Sub Append( _
v As Vertex _
)

Parameters

v

The Vertex to append.

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Compute Method

Mesh.Compute Method
[image]

Performs computations needed for rendering a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Compute (
List<Vertex> set,
Rect bounds,
double groundLevel
)

Visual Basic [image] Copy Code

Public Sub Compute( _
set As List(Of Vertex), _
bounds As Rect, _
groundLevel As Double _
)

Parameters

set

A list with vertexes.

bounds

The bounds.

groundLevel

The ground level.

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.flipIfNeeded Method

Mesh.flipIfNeeded Method
[image]

Flip if needed.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected void flipIfNeeded (
Triangle a,
Triangle b,
int depth
)

Visual Basic [image] Copy Code

Protected Sub flipIfNeeded( _
a As Triangle, _
b As Triangle, _
depth As Integer _
)

Parameters

a

b

depth

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.GetVertexIndicies Method

Mesh.GetVertexIndicies Method
[image]

Get the indexes for the triangular mesh. Points is the points. Every 3 indicies is a triangle.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int[] GetVertexIndicies ()

Visual Basic [image] Copy Code

Public Function GetVertexIndicies () As Integer()

Return Value

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Insert Method

Mesh.Insert Method
[image]

Insert.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected void Insert (
Vertex v,
Triangle old
)

Visual Basic [image] Copy Code

Protected Sub Insert( _
v As Vertex, _
old As Triangle _
)

Parameters

v

old

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Setup Method

Mesh.Setup Method
[image]

Performs initial setup for a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void Setup (
Rect bounds,
double groundLevel
)

Visual Basic [image] Copy Code

Public Sub Setup( _
bounds As Rect, _
groundLevel As Double _
)

Parameters

bounds

The bounds of the chart.

groundLevel

The ground level.

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh Properties

Mesh Properties
[image]

Public Properties

Name | Description
Bounds | Bounds.
Facets | The facets.
Points | The points.
Recursion | Recursion level.

See Also

Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Bounds Property

Mesh.Bounds Property
[image]

Bounds.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Facets Property

Mesh.Facets Property
[image]

The facets.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Triangle> Facets { get; set; }

Visual Basic [image] Copy Code

Public Property Facets As List(Of Triangle)

Property Value

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Points Property

Mesh.Points Property
[image]

The points.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Vertex> Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As List(Of Vertex)

Property Value

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Mesh.Recursion Property

Mesh.Recursion Property
[image]

Recursion level.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int Recursion { get; set; }

Visual Basic [image] Copy Code

Public Property Recursion As Integer

Property Value

See Also

Mesh Members
Mesh Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter Class

MultiConverter Class
[image]

Converts multiple values.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class MultiConverter : IMultiValueConverter

Visual Basic [image] Copy Code

Public Class MultiConverter
Implements IMultiValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.MultiConverter

See Also

MultiConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter Members

MultiConverter Members
Constructors Methods
[image]

Converts multiple values.

The following tables list the members exposed by the MultiConverter type.

Public Constructors

Name | Description
MultiConverter |

Public Methods

Name | Description
Convert | Converts the coordinates of a Point to a string to be used by a tool tip.
ConvertBack | Converts the value back.

See Also

MultiConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter Constructor

MultiConverter Constructor
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public MultiConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MultiConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter Methods

MultiConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts the coordinates of a Point to a string to be used by a tool tip.
ConvertBack | Converts the value back.

See Also

MultiConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter.Convert Method

MultiConverter.Convert Method
[image]

Converts the coordinates of a Point to a string to be used by a tool tip.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object[] values,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
values() As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

values

targetType

parameter

culture

Return Value

See Also

MultiConverter Members
MultiConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.MultiConverter.ConvertBack Method

MultiConverter.ConvertBack Method
[image]

Converts the value back.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object[] ConvertBack (
Object value,
Type[] targetTypes,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetTypes() As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object()

Parameters

value

targetTypes

parameter

culture

Return Value

See Also

MultiConverter Members
MultiConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart Class

PieChart Class
[image]

Represents a pie chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PieChart : Chart

Visual Basic [image] Copy Code

Public Class PieChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.PieChart

See Also

PieChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart Members

PieChart Members
Constructors Fields Properties Methods Events
[image]

Represents a pie chart.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Initializes a new instance of the PieChart class.

Public Fields

Name | Description
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Public Properties

Name | Description
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | FrameworkElement.ApplyTemplate override. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

PieChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart Constructor

PieChart Constructor
[image]

Initializes a new instance of the PieChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PieChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart Events

PieChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

PieChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Class

PieChart3D Class
[image]

Represents a 3D pie chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PieChart3D : Chart3D

Visual Basic [image] Copy Code

Public Class PieChart3D
Inherits Chart3D

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart3D
MindFusion.Charting.Wpf.PieChart3D

See Also

PieChart3D Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Members

PieChart3D Members
Constructors Fields Properties Methods
[image]

Represents a 3D pie chart.

The following tables list the members exposed by the PieChart3D type.

Public Constructors

Name | Description
PieChart3D | Initializes a new instance of the PieChart3D class.

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadius3DProperty | Identifies the CornerRadius3D dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
DetachOrientationProperty | Identifies the DetachOrientation dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
RoundCornerTypeProperty | Identifies the RoundCornerType dependency property.
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SliceLayoutProperty | Identifies the SliceLayout dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CornerRadius3D | Gets or sets the corner radius of the 3D pie slices. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
DetachOrientation | Gets or sets the orientation of the detached pie slices. This is a dependency property.
DoughnutThickness | Gets or sets the inner radius of doughnut charts. This is a dependency property.
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
RoundCornerType | Gets or sets at which corners of the pie chart the CornerRadius3D property will be applied. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SliceLayout | Gets or sets the layout of the pie slices. This is a dependency property.
StartAngle | Gets or sets the angle from which pie slices are drawn. This is a dependency property.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | Chart3D.HitTest override.
OnApplyTemplate | FrameworkElement.ApplyTemplate override. (Inherited from Chart3D.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Fields

PieChart3D Fields
[image]

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CornerRadius3DProperty | Identifies the CornerRadius3D dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
DetachOrientationProperty | Identifies the DetachOrientation dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
Effect3DProperty | Identifies the Effect3D dependency property. (Inherited from Chart3D.)
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
RoundCornerTypeProperty | Identifies the RoundCornerType dependency property.
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
SliceLayoutProperty | Identifies the SliceLayout dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)

See Also

PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.CornerRadius3DProperty Field

PieChart3D.CornerRadius3DProperty Field
[image]

Identifies the CornerRadius3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadius3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadius3DProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.DetachOrientationProperty Field

PieChart3D.DetachOrientationProperty Field
[image]

Identifies the DetachOrientation dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DetachOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DetachOrientationProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.DoughnutThicknessProperty Field

PieChart3D.DoughnutThicknessProperty Field
[image]

Identifies the DoughnutThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DoughnutThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DoughnutThicknessProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.RoundCornerTypeProperty Field

PieChart3D.RoundCornerTypeProperty Field
[image]

Identifies the RoundCornerType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RoundCornerTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RoundCornerTypeProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.SliceLayoutProperty Field

PieChart3D.SliceLayoutProperty Field
[image]

Identifies the SliceLayout dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SliceLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SliceLayoutProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.StartAngleProperty Field

PieChart3D.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Constructor

PieChart3D Constructor
[image]

Initializes a new instance of the PieChart3D class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PieChart3D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Methods

PieChart3D Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | Chart3D.HitTest override.
OnApplyTemplate | FrameworkElement.ApplyTemplate override. (Inherited from Chart3D.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

See Also

PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.HitTest Method

PieChart3D.HitTest Method
[image]

Chart3D.HitTest override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override ChartHitTestResult3D HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
p As Point _
) As ChartHitTestResult3D

Parameters

p

The point to test.

Return Value

An instance of the ChartHitTestResult3D class.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D Properties

PieChart3D Properties
[image]

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CornerRadius3D | Gets or sets the corner radius of the 3D pie slices. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
DetachOrientation | Gets or sets the orientation of the detached pie slices. This is a dependency property.
DoughnutThickness | Gets or sets the inner radius of doughnut charts. This is a dependency property.
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property. (Inherited from Chart3D.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
RoundCornerType | Gets or sets at which corners of the pie chart the CornerRadius3D property will be applied. This is a dependency property.
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
SliceLayout | Gets or sets the layout of the pie slices. This is a dependency property.
StartAngle | Gets or sets the angle from which pie slices are drawn. This is a dependency property.
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)

See Also

PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.CornerRadius3D Property

PieChart3D.CornerRadius3D Property
[image]

Gets or sets the corner radius of the 3D pie slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius3D { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius3D As Double

Property Value

A double value. The default is 2.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.DetachOrientation Property

PieChart3D.DetachOrientation Property
[image]

Gets or sets the orientation of the detached pie slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Orientation DetachOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property DetachOrientation As Orientation

Property Value

A member of the WPF Orientation enumeration. The default is Horizontal.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.DoughnutThickness Property

PieChart3D.DoughnutThickness Property
[image]

Gets or sets the inner radius of doughnut charts. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double DoughnutThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DoughnutThickness As Double

Property Value

A double value. The default is 10.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.RoundCornerType Property

PieChart3D.RoundCornerType Property
[image]

Gets or sets at which corners of the pie chart the CornerRadius3D property will be applied. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RoundCornerType RoundCornerType { get; set; }

Visual Basic [image] Copy Code

Public Property RoundCornerType As RoundCornerType

Property Value

A member of the RoundCornerType enumeration. The default is All.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.SliceLayout Property

PieChart3D.SliceLayout Property
[image]

Gets or sets the layout of the pie slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SliceLayout SliceLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SliceLayout As SliceLayout

Property Value

A member of the SliceLayout enumeration. The default is Flat.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieChart3D.StartAngle Property

PieChart3D.StartAngle Property
[image]

Gets or sets the angle from which pie slices are drawn. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value. The default is 0.

See Also

PieChart3D Members
PieChart3D Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Class

PieSeries Class
[image]

Represents a series in a pie chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PieSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class PieSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.PieSeries

See Also

PieSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Members

PieSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a pie chart.

The following tables list the members exposed by the PieSeries type.

Public Constructors

Name | Description
PieSeries | Initializes a new instance of the PieSeries class.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
DetachedSlicesListProperty | Identifies the DetachedSlicesList dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelProperty | Identifies the OuterLabel dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PieTypeProperty | Identifies the PieType dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Data | Gets or sets the data for the chart. This is a dependency property.
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series. This is a dependency property.
DetachedSlicesList | Gets or sets the position of detached slices. This is a dependency property.
DoughnutThickness | Gets or sets the thickness of the doughnut as a percent from the radius of the pie. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabel | Gets or sets the custom inner labels. This is a dependency property.
InnerLabelLocation | Gets or sets the location of the inner label. This is a dependency property.
InnerLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom inner labels. This is a dependency property.
InnerLabelType | Gets or sets the type of labels drawn inside pie slices. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
OuterLabel | Gets or sets the custom outer labels. This is a dependency property.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom outer labels. This is a dependency property.
OuterLabelType | Gets or sets the type of labels drawn outside pie slices. This is a dependency property.
PieType | Gets or sets the type of the chart. This is a dependency property.
StartAngle | Gets or sets the start angle of the chart. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Fields

PieSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
DetachedSlicesListProperty | Identifies the DetachedSlicesList dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelProperty | Identifies the OuterLabel dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PieTypeProperty | Identifies the PieType dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)

See Also

PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DataPathProperty Field

PieSeries.DataPathProperty Field
[image]

Identifies the DataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DataProperty Field

PieSeries.DataProperty Field
[image]

Identifies the Data dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DetachedSlicesListProperty Field

PieSeries.DetachedSlicesListProperty Field
[image]

Identifies the DetachedSlicesList dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DetachedSlicesListProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DetachedSlicesListProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DoughnutThicknessProperty Field

PieSeries.DoughnutThicknessProperty Field
[image]

Identifies the DoughnutThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DoughnutThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DoughnutThicknessProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelLocationProperty Field

PieSeries.InnerLabelLocationProperty Field
[image]

Identifies the InnerLabelLocation dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelLocationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelLocationProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelPathProperty Field

PieSeries.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelProperty Field

PieSeries.InnerLabelProperty Field
[image]

Identifies the InnerLabel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelTypeProperty Field

PieSeries.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelOffsetProperty Field

PieSeries.OuterLabelOffsetProperty Field
[image]

Identifies the OuterLabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelOffsetProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelPathProperty Field

PieSeries.OuterLabelPathProperty Field
[image]

Identifies the OuterLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelProperty Field

PieSeries.OuterLabelProperty Field
[image]

Identifies the OuterLabel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelTypeProperty Field

PieSeries.OuterLabelTypeProperty Field
[image]

Identifies the OuterLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.PieTypeProperty Field

PieSeries.PieTypeProperty Field
[image]

Identifies the PieType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PieTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PieTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.StartAngleProperty Field

PieSeries.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Constructor

PieSeries Constructor
[image]

Initializes a new instance of the PieSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PieSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Properties

PieSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Data | Gets or sets the data for the chart. This is a dependency property.
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series. This is a dependency property.
DetachedSlicesList | Gets or sets the position of detached slices. This is a dependency property.
DoughnutThickness | Gets or sets the thickness of the doughnut as a percent from the radius of the pie. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
InnerLabel | Gets or sets the custom inner labels. This is a dependency property.
InnerLabelLocation | Gets or sets the location of the inner label. This is a dependency property.
InnerLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom inner labels. This is a dependency property.
InnerLabelType | Gets or sets the type of labels drawn inside pie slices. This is a dependency property.
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
OuterLabel | Gets or sets the custom outer labels. This is a dependency property.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom outer labels. This is a dependency property.
OuterLabelType | Gets or sets the type of labels drawn outside pie slices. This is a dependency property.
PieType | Gets or sets the type of the chart. This is a dependency property.
StartAngle | Gets or sets the start angle of the chart. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

See Also

PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.Data Property

PieSeries.Data Property
[image]

Gets or sets the data for the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As DoubleCollection

Property Value

An instance of the WPF DoubleCollection class. The default is an empty collection.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DataPath Property

PieSeries.DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the data for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property DataPath As String

Property Value

A string value. The default is an empty string.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DetachedSlicesList Property

PieSeries.DetachedSlicesList Property
[image]

Gets or sets the position of detached slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection DetachedSlicesList { get; set; }

Visual Basic [image] Copy Code

Public Property DetachedSlicesList As DoubleCollection

Property Value

A WPF DoubleCollection with numbers that correspond to the distance at which detached slices are offset from the pie. The default value is an empty collection.

Remarks

Use this property to specify which slices of the pie are detached and at what distance. Put zeros at the place of the other slices.

Example

The following code shows how to detach the third and fifth slices in a pie with 6 values.

C# [image] Copy Code

series.Data = new DoubleCollection() { 26, 33, 27, 17, 20, 18 };
series.DetachedSlicesList = new DoubleCollection() { 0, 0, 10, 0, 20, 0 };

Visual Basic [image] Copy Code

series.Data = New DoubleCollection() From {26, 33, 27, 17, 20, 18}
series.DetachedSlicesList = New DoubleCollection() From {0, 0, 10, 0, 20, 0}

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.DoughnutThickness Property

PieSeries.DoughnutThickness Property
[image]

Gets or sets the thickness of the doughnut as a percent from the radius of the pie. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double DoughnutThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DoughnutThickness As Double

Property Value

A double value. The default is 0.75.

Remarks

The larger the value, the thicker the doughnut would be e.g. the smaller its hole. Doughnuts are drawn when the PieType is set to PieType.Doughnut2D.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabel Property

PieSeries.InnerLabel Property
[image]

Gets or sets the custom inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList InnerLabel { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabel As IList

Property Value

A list of objects to use as labels. The default is an empty list.

Remarks

The labels can be of any type. They are converted to strings using their ToString method. The labels are drawn when the InnerLabelType property is set to CustomText.

If you are using data binding the property for setting custom labels from a data source is InnerLabelPath.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelLocation Property

PieSeries.InnerLabelLocation Property
[image]

Gets or sets the location of the inner label. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double InnerLabelLocation { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelLocation As Double

Property Value

A double value that indicates the offset of the label from the center of the pie as a percent of the radius. Valid values range from 0 to 1. The default value is 0.5.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelPath Property

PieSeries.InnerLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

InnerLabelPath is used when InnerLabelType is set to CustomText and DataSource is not null (Nothing in Visual Basic).

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.InnerLabelType Property

PieSeries.InnerLabelType Property
[image]

Gets or sets the type of labels drawn inside pie slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default is Empty.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabel Property

PieSeries.OuterLabel Property
[image]

Gets or sets the custom outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList OuterLabel { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabel As IList

Property Value

A list of objects to use as labels. The default is a list with five strings { "Jan", "Feb", "March", "April", "May" }.

Remarks

OuterLabel property is used when the OuterLabelType is CustomText. Custom outer labels are read from the OuterLabelPath property if DataSource is not null (Nothing in Visual Basic).

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelOffset Property

PieSeries.OuterLabelOffset Property
[image]

Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double OuterLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelOffset As Double

Property Value

A double value. The default is 20.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelPath Property

PieSeries.OuterLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string OuterLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelPath As String

Property Value

A string value. The default is an empty string.

Remarks

OuterLabelPath is used when OuterLabelType is set to CustomText and the DataSource is not null (Nothing in Visual Basic).

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.OuterLabelType Property

PieSeries.OuterLabelType Property
[image]

Gets or sets the type of labels drawn outside pie slices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default is Percents.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.PieType Property

PieSeries.PieType Property
[image]

Gets or sets the type of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PieType PieType { get; set; }

Visual Basic [image] Copy Code

Public Property PieType As PieType

Property Value

A member of the PieType enumeration values. The default is Doughnut2D.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries.StartAngle Property

PieSeries.StartAngle Property
[image]

Gets or sets the start angle of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value in the interval [0..360]. The default is 0.

Remarks

An exception is raised if the value of the property is not a valid angle value.

See Also

PieSeries Members
PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSeries Events

PieSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

PieSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice Class

PieSlice Class
[image]

Represents a slice in a pie chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PieSlice : ChartElement

Visual Basic [image] Copy Code

Public Class PieSlice
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.PieSlice

See Also

PieSlice Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice Members

PieSlice Members
Properties Methods
[image]

Represents a slice in a pie chart.

The following tables list the members exposed by the PieSlice type.

Public Properties

Name | Description
Detached | Gets the distance at which this slice is detached.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Percent | Gets the percentage of this slice' value relative to pie's total.
RadiusX | Gets the X-radius of the pie containing this slice.
RadiusY | Gets the Y-radius of the pie containing this slice.
SeriesIndex | Gets the index of the series of this pie slice.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
SliceIndex | Gets the index of this pie slice in the series.
SliceValue | Gets the data this slice represents.
StartAngle | Gets the start angle of the slice.
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
SweepAngle | Gets the sweep angle of the slice.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this slice.

See Also

PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice Methods

PieSlice Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this slice.

See Also

PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.CreateShape Method

PieSlice.CreateShape Method
[image]

Creates a Shape that represents this slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A WPF Shape object.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice Properties

PieSlice Properties
[image]

Public Properties

Name | Description
Detached | Gets the distance at which this slice is detached.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Percent | Gets the percentage of this slice' value relative to pie's total.
RadiusX | Gets the X-radius of the pie containing this slice.
RadiusY | Gets the Y-radius of the pie containing this slice.
SeriesIndex | Gets the index of the series of this pie slice.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
SliceIndex | Gets the index of this pie slice in the series.
SliceValue | Gets the data this slice represents.
StartAngle | Gets the start angle of the slice.
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)
SweepAngle | Gets the sweep angle of the slice.

See Also

PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.Detached Property

PieSlice.Detached Property
[image]

Gets the distance at which this slice is detached.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Detached { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Detached As Double

Property Value

A double value.

Remarks

The value is taken from the DetachedSlicesList property of the PieSeries that contains this slice.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.Percent Property

PieSlice.Percent Property
[image]

Gets the percentage of this slice' value relative to pie's total.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Percent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Percent As Double

Property Value

A double value.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.RadiusX Property

PieSlice.RadiusX Property
[image]

Gets the X-radius of the pie containing this slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double RadiusX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RadiusX As Double

Property Value

A double value.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.RadiusY Property

PieSlice.RadiusY Property
[image]

Gets the Y-radius of the pie containing this slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double RadiusY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RadiusY As Double

Property Value

A double value.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.SeriesIndex Property

PieSlice.SeriesIndex Property
[image]

Gets the index of the series of this pie slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An integer value.

Remarks

The SeriesIndex corresponds to the position in the Series list of the series this PieSlice belongs to.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.SliceIndex Property

PieSlice.SliceIndex Property
[image]

Gets the index of this pie slice in the series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SliceIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SliceIndex As Integer

Property Value

An integer value.

Remarks

The SliceIndex corresponds to the location of the data this slice represents in the data array for the series.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.SliceValue Property

PieSlice.SliceValue Property
[image]

Gets the data this slice represents.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SliceValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SliceValue As Double

Property Value

A double value.

Remarks

The data is taken from the Data property of the PieSeries this slice belongs to.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.StartAngle Property

PieSlice.StartAngle Property
[image]

Gets the start angle of the slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Double

Property Value

A double value.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieSlice.SweepAngle Property

PieSlice.SweepAngle Property
[image]

Gets the sweep angle of the slice.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Double

Property Value

A double value.

See Also

PieSlice Members
PieSlice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PieType Enumeration

PieType Enumeration
[image]

Specifies the type of the pie chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum PieType

Visual Basic [image] Copy Code

Public Enum PieType

Members

Member name | Description
Doughnut2D | The chart is drawn as a doughnut.
Pie2D | The chart is drawn as a 2D pie.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea Class

PlotArea Class
[image]

Represents the plot area where the chart is drawn.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PlotArea : Control

Visual Basic [image] Copy Code

Public Class PlotArea
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.PlotArea

See Also

PlotArea Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea Members

PlotArea Members
Constructors Fields Methods
[image]

Represents the plot area where the chart is drawn.

The following tables list the members exposed by the PlotArea type.

Public Constructors

Name | Description
PlotArea | Initializes a new instance of the PlotArea class.

Public Fields

Name | Description
CanvasSizeInitializedEvent | Occurs when the canvas for the chart's plot area is initialized.
PlotAreaCanvasInitializedEvent | Occurs when the size of the canvas for the chart's plot area is initialized.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.

See Also

PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea Fields

PlotArea Fields
[image]

Public Fields

Name | Description
CanvasSizeInitializedEvent | Occurs when the canvas for the chart's plot area is initialized.
PlotAreaCanvasInitializedEvent | Occurs when the size of the canvas for the chart's plot area is initialized.

See Also

PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea.CanvasSizeInitializedEvent Field

PlotArea.CanvasSizeInitializedEvent Field
[image]

Occurs when the canvas for the chart's plot area is initialized.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent CanvasSizeInitializedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly CanvasSizeInitializedEvent As RoutedEvent

See Also

PlotArea Members
PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea.PlotAreaCanvasInitializedEvent Field

PlotArea.PlotAreaCanvasInitializedEvent Field
[image]

Occurs when the size of the canvas for the chart's plot area is initialized.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent PlotAreaCanvasInitializedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaCanvasInitializedEvent As RoutedEvent

See Also

PlotArea Members
PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea Constructor

PlotArea Constructor
[image]

Initializes a new instance of the PlotArea class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PlotArea ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea Methods

PlotArea Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.

See Also

PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea.ArrangeOverride Method

PlotArea.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The area this element should use to arrange itself.

Return Value

The actual size used.

Remarks

This method is used internally by the control and is not intended to be called within your code.

See Also

PlotArea Members
PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PlotArea.OnApplyTemplate Method

PlotArea.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

This method is used internally by the control and is not intended to be called within your code.

See Also

PlotArea Members
PlotArea Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter Class

PointToDoubleConverter Class
[image]

Converts a System.Windows.Point object to a double value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PointToDoubleConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PointToDoubleConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.PointToDoubleConverter

See Also

PointToDoubleConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter Members

PointToDoubleConverter Members
Constructors Methods
[image]

Converts a System.Windows.Point object to a double value.

The following tables list the members exposed by the PointToDoubleConverter type.

Public Constructors

Name | Description
PointToDoubleConverter | Initializes a new instance of the PointToDoubleConverter class.

Public Methods

Name | Description
Convert | Converts a System.Windows.Point object to a double value.
ConvertBack | IConverter.ConvertBack override.

See Also

PointToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter Constructor

PointToDoubleConverter Constructor
[image]

Initializes a new instance of the PointToDoubleConverter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointToDoubleConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PointToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter Methods

PointToDoubleConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a System.Windows.Point object to a double value.
ConvertBack | IConverter.ConvertBack override.

See Also

PointToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter.Convert Method

PointToDoubleConverter.Convert Method
[image]

Converts a System.Windows.Point object to a double value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type of the conversion.

parameter

A parameter to use in the conversion.

culture

An instance of the System.Globalization.CultureInfo class.

Return Value

See Also

PointToDoubleConverter Members
PointToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToDoubleConverter.ConvertBack Method

PointToDoubleConverter.ConvertBack Method
[image]

IConverter.ConvertBack override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

This method is not implemented in the PointToDoubleConverter class.

See Also

PointToDoubleConverter Members
PointToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter Class

PointToMarginConverter Class
[image]

Converts the value of a Point to a Margin.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class PointToMarginConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PointToMarginConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.PointToMarginConverter

See Also

PointToMarginConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter Members

PointToMarginConverter Members
Constructors Methods
[image]

Converts the value of a Point to a Margin.

The following tables list the members exposed by the PointToMarginConverter type.

Public Constructors

Name | Description
PointToMarginConverter |

Public Methods

Name | Description
Convert | Converts the Point to a Margin.
ConvertBack | Converts back the value.

See Also

PointToMarginConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter Constructor

PointToMarginConverter Constructor
[image]

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointToMarginConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PointToMarginConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter Methods

PointToMarginConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts the Point to a Margin.
ConvertBack | Converts back the value.

See Also

PointToMarginConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter.Convert Method

PointToMarginConverter.Convert Method
[image]

Converts the Point to a Margin.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

PointToMarginConverter Members
PointToMarginConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.PointToMarginConverter.ConvertBack Method

PointToMarginConverter.ConvertBack Method
[image]

Converts back the value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

PointToMarginConverter Members
PointToMarginConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Class

RadarChart Class
[image]

Represents a radar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class RadarChart : Chart

Visual Basic [image] Copy Code

Public Class RadarChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart
MindFusion.Charting.Wpf.RadarChart

See Also

RadarChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Members

RadarChart Members
Constructors Fields Properties Methods Events
[image]

Represents a radar chart.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Initializes a new instance of the RadarChart class.

Public Fields

Name | Description
AngleDirectionProperty | Identifies the AngleDirection dependency property.
AngleStepProperty | Identifies the AngleStep dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
InnerAxisStrokeProperty | Identifies the InnerAxisStroke dependency property.
InnerLabelAngleProperty | Identifies the InnerLabelAngle dependency property.
InnerLabelBackgroundProperty | Identifies the InnerLabelBackground dependency property.
InnerLabelBorderBrushProperty | Identifies the InnerLabelBorderBrush dependency property.
InnerLabelBorderThicknessProperty | Identifies the InnerLabelBorderThickness dependency property.
InnerLabelForegroundProperty | Identifies the InnerLabelForeground dependency property.
InnerLabelOffsetProperty | Identifies the InnerLabelOffset dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelPositionProperty | Identifies the InnerLabelPosition dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
InnerStrokeDashArrayProperty | Identifies the InnerStrokeDashArray dependency property.
InnerStrokeThicknessProperty | Identifies the InnerStrokeThickness dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OuterAxisStrokeProperty | Identifies the OuterAxisStroke dependency property.
OuterLabelBackgroundProperty | Identifies the OuterLabelBackground dependency property.
OuterLabelBorderBrushProperty | Identifies the OuterLabelBorderBrush dependency property.
OuterLabelBorderThicknessProperty | Identifies the OuterLabelBorderThickness dependency property.
OuterLabelForegroundProperty | Identifies the OuterLabelForeground dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelsProperty | Identifies the OuterLabels dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
OuterStrokeDashArrayProperty | Identifies the OuterStrokeDashArray dependency property.
OuterStrokeThicknessProperty | Identifies the OuterStrokeThickness dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
RadarTypeProperty | Identifies the RadarType dependency property.
SectionBrushesProperty | Identifies the SectionBrushes dependency property.
SectionStrokesProperty | Identifies the SectionStrokes dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Public Properties

Name | Description
AngleDirection | Gets or sets the sweep direction of the angles in a polar chart. This is a dependency property.
AngleStep | Gets or sets the increment step for the angles that build the sections of the chart. This is a dependency property.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
InnerAxisStroke | Gets or sets the stroke for the inner axis. This is a dependency property.
InnerLabelAngle | Gets or sets the angle of the inner labels. This is a dependency property.
InnerLabelBackground | Gets or sets the background for the inner labels. This is a dependency property.
InnerLabelBorderBrush | Gets or set the brush for the border drawn around inner labels. This is a dependency property.
InnerLabelBorderThickness | Gets or sets the thickness of the border drawn around inner labels. This is a dependency property.
InnerLabelForeground | Gets or sets the brush for the foreground of the inner labels. This is a dependency property.
InnerLabelOffset | Gets or sets the offset of the labels drawn at the inner axis. This is a dependency property.
InnerLabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis. This is a dependency property.
InnerLabelPosition | Gets or sets the position of the inner labels. This is a dependency property.
InnerLabels | Gets or sets the custom labels for the inner axis. This is a dependency property.
InnerLabelType | Gets or sets the type of labels drawn at the inner axis. This is a dependency property.
InnerStrokeDashArray | Gets or sets the dash array of the stroke for the inner axis. This is a dependency property.
InnerStrokeThickness | Gets or sets the thickness of the stroke for the inner axis. This is a dependency property.
Interval | Gets or sets the interval at the inner axis. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
MaxValue | Gets or sets the maximum value of the radar. This is a dependency property.
MinValue | Gets or sets the minimum value of the radar. This is a dependency property.
OuterAxisStroke | Gets or sets the stroke for the outer axis. This is a dependency property.
OuterLabelBackground | Gets or sets the brush that fills the background of the outer labels. This is a dependency property.
OuterLabelBorderBrush | Gets or sets the brush for the border of the outer labels. This is a dependency property.
OuterLabelBorderThickness | Gets or sets the thickness of the border of the outer labels. This is a dependency property.
OuterLabelForeground | Gets or sets the brush for the foreground of the outer labels. This is a dependency property.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the radar. This is a dependency property.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis. This is a dependency property.
OuterLabels | Gets or sets the custom outer labels. This is a dependency property.
OuterLabelType | Gets or sets the type of labels drawn at the outer axis. This is a dependency property.
OuterStrokeDashArray | Gets or sets the dash array of the stroke for the outer axis. This is a dependency property.
OuterStrokeThickness | Gets or sets the thickness of the stroke for the outer axis. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
RadarType | Gets or sets the type of the radar chart. This is a dependency property.
SectionBrushes | Gets or sets a list with the brushes used for painting the sections of the radar chart. This is a dependency property.
SectionStrokes | Gets or sets a list of brushes used for outlining the sections of the radar chart. This is a dependency property.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
StartAngle | Gets or sets the start angle in a polar chart. This is a dependency property.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Fields

RadarChart Fields
[image]

Public Fields

Name | Description
AngleDirectionProperty | Identifies the AngleDirection dependency property.
AngleStepProperty | Identifies the AngleStep dependency property.
ChartEffectProperty | Identifies the ChartEffect dependency property. (Inherited from Chart.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
InnerAxisStrokeProperty | Identifies the InnerAxisStroke dependency property.
InnerLabelAngleProperty | Identifies the InnerLabelAngle dependency property.
InnerLabelBackgroundProperty | Identifies the InnerLabelBackground dependency property.
InnerLabelBorderBrushProperty | Identifies the InnerLabelBorderBrush dependency property.
InnerLabelBorderThicknessProperty | Identifies the InnerLabelBorderThickness dependency property.
InnerLabelForegroundProperty | Identifies the InnerLabelForeground dependency property.
InnerLabelOffsetProperty | Identifies the InnerLabelOffset dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelPositionProperty | Identifies the InnerLabelPosition dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
InnerStrokeDashArrayProperty | Identifies the InnerStrokeDashArray dependency property.
InnerStrokeThicknessProperty | Identifies the InnerStrokeThickness dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OuterAxisStrokeProperty | Identifies the OuterAxisStroke dependency property.
OuterLabelBackgroundProperty | Identifies the OuterLabelBackground dependency property.
OuterLabelBorderBrushProperty | Identifies the OuterLabelBorderBrush dependency property.
OuterLabelBorderThicknessProperty | Identifies the OuterLabelBorderThickness dependency property.
OuterLabelForegroundProperty | Identifies the OuterLabelForeground dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelsProperty | Identifies the OuterLabels dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
OuterStrokeDashArrayProperty | Identifies the OuterStrokeDashArray dependency property.
OuterStrokeThicknessProperty | Identifies the OuterStrokeThickness dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
RadarTypeProperty | Identifies the RadarType dependency property.
SectionBrushesProperty | Identifies the SectionBrushes dependency property.
SectionStrokesProperty | Identifies the SectionStrokes dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.AngleDirectionProperty Field

RadarChart.AngleDirectionProperty Field
[image]

Identifies the AngleDirection dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AngleDirectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AngleDirectionProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.AngleStepProperty Field

RadarChart.AngleStepProperty Field
[image]

Identifies the AngleStep dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AngleStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AngleStepProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerAxisStrokeProperty Field

RadarChart.InnerAxisStrokeProperty Field
[image]

Identifies the InnerAxisStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerAxisStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerAxisStrokeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelAngleProperty Field

RadarChart.InnerLabelAngleProperty Field
[image]

Identifies the InnerLabelAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelAngleProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBackgroundProperty Field

RadarChart.InnerLabelBackgroundProperty Field
[image]

Identifies the InnerLabelBackground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBackgroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBorderBrushProperty Field

RadarChart.InnerLabelBorderBrushProperty Field
[image]

Identifies the InnerLabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBorderBrushProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBorderThicknessProperty Field

RadarChart.InnerLabelBorderThicknessProperty Field
[image]

Identifies the InnerLabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBorderThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelForegroundProperty Field

RadarChart.InnerLabelForegroundProperty Field
[image]

Identifies the InnerLabelForeground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelForegroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelOffsetProperty Field

RadarChart.InnerLabelOffsetProperty Field
[image]

Identifies the InnerLabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelOffsetProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelPathProperty Field

RadarChart.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelPositionProperty Field

RadarChart.InnerLabelPositionProperty Field
[image]

Identifies the InnerLabelPosition dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPositionProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelsProperty Field

RadarChart.InnerLabelsProperty Field
[image]

Identifies the InnerLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelsProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelTypeProperty Field

RadarChart.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerStrokeDashArrayProperty Field

RadarChart.InnerStrokeDashArrayProperty Field
[image]

Identifies the InnerStrokeDashArray dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeDashArrayProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerStrokeThicknessProperty Field

RadarChart.InnerStrokeThicknessProperty Field
[image]

Identifies the InnerStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.IntervalProperty Field

RadarChart.IntervalProperty Field
[image]

Identifies the Interval dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.MaxValueProperty Field

RadarChart.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.MinValueProperty Field

RadarChart.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterAxisStrokeProperty Field

RadarChart.OuterAxisStrokeProperty Field
[image]

Identifies the OuterAxisStroke dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterAxisStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterAxisStrokeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBackgroundProperty Field

RadarChart.OuterLabelBackgroundProperty Field
[image]

Identifies the OuterLabelBackground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBackgroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBorderBrushProperty Field

RadarChart.OuterLabelBorderBrushProperty Field
[image]

Identifies the OuterLabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBorderBrushProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBorderThicknessProperty Field

RadarChart.OuterLabelBorderThicknessProperty Field
[image]

Identifies the OuterLabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBorderThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelForegroundProperty Field

RadarChart.OuterLabelForegroundProperty Field
[image]

Identifies the OuterLabelForeground dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelForegroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelOffsetProperty Field

RadarChart.OuterLabelOffsetProperty Field
[image]

Identifies the OuterLabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelOffsetProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelPathProperty Field

RadarChart.OuterLabelPathProperty Field
[image]

Identifies the OuterLabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelPathProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelsProperty Field

RadarChart.OuterLabelsProperty Field
[image]

Identifies the OuterLabels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelsProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelTypeProperty Field

RadarChart.OuterLabelTypeProperty Field
[image]

Identifies the OuterLabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterStrokeDashArrayProperty Field

RadarChart.OuterStrokeDashArrayProperty Field
[image]

Identifies the OuterStrokeDashArray dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterStrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterStrokeDashArrayProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterStrokeThicknessProperty Field

RadarChart.OuterStrokeThicknessProperty Field
[image]

Identifies the OuterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterStrokeThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.RadarTypeProperty Field

RadarChart.RadarTypeProperty Field
[image]

Identifies the RadarType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.SectionBrushesProperty Field

RadarChart.SectionBrushesProperty Field
[image]

Identifies the SectionBrushes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionBrushesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionBrushesProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.SectionStrokesProperty Field

RadarChart.SectionStrokesProperty Field
[image]

Identifies the SectionStrokes dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionStrokesProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.StartAngleProperty Field

RadarChart.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Constructor

RadarChart Constructor
[image]

Initializes a new instance of the RadarChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RadarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Methods

RadarChart Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart.)
HitTest | Gets a collection of ChartElement objects that contain the specified point as parameter. (Inherited from Chart.)
LoadTheme | Loads the theme with the specified name. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | FrameworkElement.ApplyTemplate override.
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the current theme as a file with the specified name. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OnApplyTemplate Method

RadarChart.OnApplyTemplate Method
[image]

FrameworkElement.ApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Properties

RadarChart Properties
[image]

Public Properties

Name | Description
AngleDirection | Gets or sets the sweep direction of the angles in a polar chart. This is a dependency property.
AngleStep | Gets or sets the increment step for the angles that build the sections of the chart. This is a dependency property.
ChartEffect | Gets or sets the effect to apply to the elements of the chart. This is a dependency property. (Inherited from Chart.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
InnerAxisStroke | Gets or sets the stroke for the inner axis. This is a dependency property.
InnerLabelAngle | Gets or sets the angle of the inner labels. This is a dependency property.
InnerLabelBackground | Gets or sets the background for the inner labels. This is a dependency property.
InnerLabelBorderBrush | Gets or set the brush for the border drawn around inner labels. This is a dependency property.
InnerLabelBorderThickness | Gets or sets the thickness of the border drawn around inner labels. This is a dependency property.
InnerLabelForeground | Gets or sets the brush for the foreground of the inner labels. This is a dependency property.
InnerLabelOffset | Gets or sets the offset of the labels drawn at the inner axis. This is a dependency property.
InnerLabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis. This is a dependency property.
InnerLabelPosition | Gets or sets the position of the inner labels. This is a dependency property.
InnerLabels | Gets or sets the custom labels for the inner axis. This is a dependency property.
InnerLabelType | Gets or sets the type of labels drawn at the inner axis. This is a dependency property.
InnerStrokeDashArray | Gets or sets the dash array of the stroke for the inner axis. This is a dependency property.
InnerStrokeThickness | Gets or sets the thickness of the stroke for the inner axis. This is a dependency property.
Interval | Gets or sets the interval at the inner axis. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
LicenseKey | Gets or sets the license key of the control. (Inherited from Chart.)
MaxValue | Gets or sets the maximum value of the radar. This is a dependency property.
MinValue | Gets or sets the minimum value of the radar. This is a dependency property.
OuterAxisStroke | Gets or sets the stroke for the outer axis. This is a dependency property.
OuterLabelBackground | Gets or sets the brush that fills the background of the outer labels. This is a dependency property.
OuterLabelBorderBrush | Gets or sets the brush for the border of the outer labels. This is a dependency property.
OuterLabelBorderThickness | Gets or sets the thickness of the border of the outer labels. This is a dependency property.
OuterLabelForeground | Gets or sets the brush for the foreground of the outer labels. This is a dependency property.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the radar. This is a dependency property.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis. This is a dependency property.
OuterLabels | Gets or sets the custom outer labels. This is a dependency property.
OuterLabelType | Gets or sets the type of labels drawn at the outer axis. This is a dependency property.
OuterStrokeDashArray | Gets or sets the dash array of the stroke for the outer axis. This is a dependency property.
OuterStrokeThickness | Gets or sets the thickness of the stroke for the outer axis. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
RadarType | Gets or sets the type of the radar chart. This is a dependency property.
SectionBrushes | Gets or sets a list with the brushes used for painting the sections of the radar chart. This is a dependency property.
SectionStrokes | Gets or sets a list of brushes used for outlining the sections of the radar chart. This is a dependency property.
Series | Gets the list with the series in the chart. (Inherited from Chart.)
StartAngle | Gets or sets the start angle in a polar chart. This is a dependency property.
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.AngleDirection Property

RadarChart.AngleDirection Property
[image]

Gets or sets the sweep direction of the angles in a polar chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SweepDirection AngleDirection { get; set; }

Visual Basic [image] Copy Code

Public Property AngleDirection As SweepDirection

Property Value

A member of the WPF SweepDirection enumeration. The default value is Clockwise.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.AngleStep Property

RadarChart.AngleStep Property
[image]

Gets or sets the increment step for the angles that build the sections of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double AngleStep { get; set; }

Visual Basic [image] Copy Code

Public Property AngleStep As Double

Property Value

A double value. The default is NaN.

Remarks

The smaller the AngleStep, the more sections the radar chart shall have.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerAxisStroke Property

RadarChart.InnerAxisStroke Property
[image]

Gets or sets the stroke for the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush InnerAxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property InnerAxisStroke As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelAngle Property

RadarChart.InnerLabelAngle Property
[image]

Gets or sets the angle of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double InnerLabelAngle { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelAngle As Double

Property Value

A double value. The default is 180.

Remarks

The property specifies the angle at which the inner labels will be drawn in the radar chart measured in degrees along the radar circle.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBackground Property

RadarChart.InnerLabelBackground Property
[image]

Gets or sets the background for the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush InnerLabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBackground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

Remarks

The property specifies the background of the inner labels.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBorderBrush Property

RadarChart.InnerLabelBorderBrush Property
[image]

Gets or set the brush for the border drawn around inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush InnerLabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBorderBrush As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelBorderThickness Property

RadarChart.InnerLabelBorderThickness Property
[image]

Gets or sets the thickness of the border drawn around inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness InnerLabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBorderThickness As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(0).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelForeground Property

RadarChart.InnerLabelForeground Property
[image]

Gets or sets the brush for the foreground of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush InnerLabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelForeground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelOffset Property

RadarChart.InnerLabelOffset Property
[image]

Gets or sets the offset of the labels drawn at the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double InnerLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelOffset As Double

Property Value

A double value. The default is 0.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelPath Property

RadarChart.InnerLabelPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string value. The default is an empty string.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelPosition Property

RadarChart.InnerLabelPosition Property
[image]

Gets or sets the position of the inner labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public InnerLabelPosition InnerLabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPosition As InnerLabelPosition

Property Value

A member of the InnerLabelPosition enumeration. The default is Right.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabels Property

RadarChart.InnerLabels Property
[image]

Gets or sets the custom labels for the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerLabelType Property

RadarChart.InnerLabelType Property
[image]

Gets or sets the type of labels drawn at the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default is AutoScale.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerStrokeDashArray Property

RadarChart.InnerStrokeDashArray Property
[image]

Gets or sets the dash array of the stroke for the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection InnerStrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStrokeDashArray As DoubleCollection

Property Value

A list with double values that specify the dash pattern for the stroke. The default is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.InnerStrokeThickness Property

RadarChart.InnerStrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double InnerStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.Interval Property

RadarChart.Interval Property
[image]

Gets or sets the interval at the inner axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Double

Property Value

A double value. The default is 20.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.MaxValue Property

RadarChart.MaxValue Property
[image]

Gets or sets the maximum value of the radar. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value. The default is 100.

Remarks

The MaxValue property specifies the biggest number at the inner axis of the radar.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.MinValue Property

RadarChart.MinValue Property
[image]

Gets or sets the minimum value of the radar. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value. The default is 0.

Remarks

The MinValue property specifies the smallest number at the inner axis of the radar chart.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterAxisStroke Property

RadarChart.OuterAxisStroke Property
[image]

Gets or sets the stroke for the outer axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush OuterAxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property OuterAxisStroke As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBackground Property

RadarChart.OuterLabelBackground Property
[image]

Gets or sets the brush that fills the background of the outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush OuterLabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBackground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBorderBrush Property

RadarChart.OuterLabelBorderBrush Property
[image]

Gets or sets the brush for the border of the outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush OuterLabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBorderBrush As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelBorderThickness Property

RadarChart.OuterLabelBorderThickness Property
[image]

Gets or sets the thickness of the border of the outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness OuterLabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBorderThickness As Thickness

Property Value

An instance of the WPF Thickness structure. The default is Thickness(0).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelForeground Property

RadarChart.OuterLabelForeground Property
[image]

Gets or sets the brush for the foreground of the outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush OuterLabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelForeground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelOffset Property

RadarChart.OuterLabelOffset Property
[image]

Gets or sets the offset of the outer label from the edge of the radar. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double OuterLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelOffset As Double

Property Value

A double value. The default is 20.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelPath Property

RadarChart.OuterLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string OuterLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelPath As String

Property Value

A string value. The default is an empty string.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property
[image]

Gets or sets the custom outer labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList OuterLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterLabelType Property

RadarChart.OuterLabelType Property
[image]

Gets or sets the type of labels drawn at the outer axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

A member of the LabelType enumeration. The default is AutoScale.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterStrokeDashArray Property

RadarChart.OuterStrokeDashArray Property
[image]

Gets or sets the dash array of the stroke for the outer axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection OuterStrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property OuterStrokeDashArray As DoubleCollection

Property Value

A list of double values that specifies the dash patters. The default is an empty list.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.OuterStrokeThickness Property

RadarChart.OuterStrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the outer axis. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double OuterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property OuterStrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.RadarType Property

RadarChart.RadarType Property
[image]

Gets or sets the type of the radar chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RadarType RadarType { get; set; }

Visual Basic [image] Copy Code

Public Property RadarType As RadarType

Property Value

A member of the RadarType enumeration. The default is Polar.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.SectionBrushes Property

RadarChart.SectionBrushes Property
[image]

Gets or sets a list with the brushes used for painting the sections of the radar chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> SectionBrushes { get; set; }

Visual Basic [image] Copy Code

Public Property SectionBrushes As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

Remarks

The SectionBrushes property specifies the brushes for filling the circles or polygons that build the inside of the radar chart. If the count of the SectionBrushes is less than the count of the radar sections, the control cycles the brushes.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.SectionStrokes Property

RadarChart.SectionStrokes Property
[image]

Gets or sets a list of brushes used for outlining the sections of the radar chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> SectionStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property SectionStrokes As List(Of Brush)

Property Value

A list of WPF Brush objects. The default is an empty list.

Remarks

The SectionStrokes property specifies the brushes for outlining the circles or polygons that build the inside of the radar chart. If the count of the SectionStrokes is less than the count of the radar sections, the control cycles the strokes.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart.StartAngle Property

RadarChart.StartAngle Property
[image]

Gets or sets the start angle in a polar chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value. The default is 0.

See Also

RadarChart Members
RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarChart Events

RadarChart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

RadarChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Class

RadarSeries Class
[image]

Represents a series in a radar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class RadarSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class RadarSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.RadarSeries

See Also

RadarSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Members

RadarSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a radar chart.

The following tables list the members exposed by the RadarSeries type.

Public Constructors

Name | Description
RadarSeries | Initializes a new instance of the RadarSeries class.

Public Fields

Name | Description
AnglesProperty | Identifies the Angles dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
RadarScatterFillsSourceProperty | Identifies the RadarScatterFillsSource dependency property.
RadarScatterStrokesSourceProperty | Identifies the RadarScatterStrokesSource dependency property.
RadarScatterStrokeThicknessProperty | Identifies the RadarScatterStrokeThickness dependency property.
RadarStyleProperty | Identifies the RadarStyle dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
Angles | Gets or sets the angles for the radar series. This is a dependency property.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Data | Gets or sets the data for the radar series. This is a dependency property.
DataPath | Gets or sets the path to the property in the DataSource used for retrieving data for the radar series. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelOffset | Gets or sets the offset of the labels. This is a dependency property.
LabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for this series. This is a dependency property.
Labels | Gets or sets the custom labels for the series. This is a dependency property.
LabelType | Gets or sets the type of labels. This is a dependency property.
RadarScatterFills | Gets or sets the brushes used to fill scatters drawn at data points in this series. This is a dependency property.
RadarScatterFillsSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
RadarScatterStrokes | Gets the strokes of the scatter marks. This is a dependency property.
RadarScatterStrokesSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
RadarScatterStrokeThickness | Gets or sets the thickness of the scatter stroke. This is a dependency property.
RadarStyle | Gets or sets the style of the radar series. This is a dependency property.
ScatterSize | Gets or sets the size of the scatter marks. This is a dependency property.
ScatterType | Gets or sets the type of the scatter. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Fields

RadarSeries Fields
[image]

Public Fields

Name | Description
AnglesProperty | Identifies the Angles dependency property.
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
RadarScatterFillsSourceProperty | Identifies the RadarScatterFillsSource dependency property.
RadarScatterStrokesSourceProperty | Identifies the RadarScatterStrokesSource dependency property.
RadarScatterStrokeThicknessProperty | Identifies the RadarScatterStrokeThickness dependency property.
RadarStyleProperty | Identifies the RadarStyle dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)

See Also

RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.AnglesProperty Field

RadarSeries.AnglesProperty Field
[image]

Identifies the Angles dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnglesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnglesProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.DataPathProperty Field

RadarSeries.DataPathProperty Field
[image]

Identifies the DataPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataPathProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.DataProperty Field

RadarSeries.DataProperty Field
[image]

Identifies the Data dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelOffsetProperty Field

RadarSeries.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelPathProperty Field

RadarSeries.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelsProperty Field

RadarSeries.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelTypeProperty Field

RadarSeries.LabelTypeProperty Field
[image]

Identifies the LabelType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTypeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterFillsSourceProperty Field

RadarSeries.RadarScatterFillsSourceProperty Field
[image]

Identifies the RadarScatterFillsSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterFillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterFillsSourceProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterStrokesSourceProperty Field

RadarSeries.RadarScatterStrokesSourceProperty Field
[image]

Identifies the RadarScatterStrokesSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterStrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterStrokesSourceProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterStrokeThicknessProperty Field

RadarSeries.RadarScatterStrokeThicknessProperty Field
[image]

Identifies the RadarScatterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterStrokeThicknessProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarStyleProperty Field

RadarSeries.RadarStyleProperty Field
[image]

Identifies the RadarStyle dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarStyleProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.ScatterSizeProperty Field

RadarSeries.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.ScatterTypeProperty Field

RadarSeries.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Constructor

RadarSeries Constructor
[image]

Initializes a new instance of the RadarSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RadarSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Properties

RadarSeries Properties
[image]

Public Properties

Name | Description
Angles | Gets or sets the angles for the radar series. This is a dependency property.
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
Data | Gets or sets the data for the radar series. This is a dependency property.
DataPath | Gets or sets the path to the property in the DataSource used for retrieving data for the radar series. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelOffset | Gets or sets the offset of the labels. This is a dependency property.
LabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for this series. This is a dependency property.
Labels | Gets or sets the custom labels for the series. This is a dependency property.
LabelType | Gets or sets the type of labels. This is a dependency property.
RadarScatterFills | Gets or sets the brushes used to fill scatters drawn at data points in this series. This is a dependency property.
RadarScatterFillsSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
RadarScatterStrokes | Gets the strokes of the scatter marks. This is a dependency property.
RadarScatterStrokesSource | Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.
RadarScatterStrokeThickness | Gets or sets the thickness of the scatter stroke. This is a dependency property.
RadarStyle | Gets or sets the style of the radar series. This is a dependency property.
ScatterSize | Gets or sets the size of the scatter marks. This is a dependency property.
ScatterType | Gets or sets the type of the scatter. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)

See Also

RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.Angles Property

RadarSeries.Angles Property
[image]

Gets or sets the angles for the radar series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection Angles { get; set; }

Visual Basic [image] Copy Code

Public Property Angles As DoubleCollection

Property Value

A collection of numbers that represent the angles in the chart. The default is an empty collection.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.Data Property

RadarSeries.Data Property
[image]

Gets or sets the data for the radar series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As DoubleCollection

Property Value

A collection that holds the data for the series. The default is an empty collection.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.DataPath Property

RadarSeries.DataPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving data for the radar series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property DataPath As String

Property Value

A string value. The default is an empty string.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelOffset Property

RadarSeries.LabelOffset Property
[image]

Gets or sets the offset of the labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. The default is 20.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelPath Property

RadarSeries.LabelPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving custom labels for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

A string value. The default is an empty string.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.Labels Property

RadarSeries.Labels Property
[image]

Gets or sets the custom labels for the series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As IList

Property Value

A list of objects to use as labels. The default is an empty list.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.LabelType Property

RadarSeries.LabelType Property
[image]

Gets or sets the type of labels. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public LabelType LabelType { get; set; }

Visual Basic [image] Copy Code

Public Property LabelType As LabelType

Property Value

A member of the LabelType enumeration. The default is AutoScale.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterFills Property

RadarSeries.RadarScatterFills Property
[image]

Gets or sets the brushes used to fill scatters drawn at data points in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterFills { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterFills As BrushCollection

Property Value

An collection of WPF Brush objects. The default is an empty collection.

Remarks

The RadarScatterFills property specifies brushes for filling scatter shapes drawn at data points in a radar series. If you want to show scatters at data points, change the ScatterType property to a value different than None.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterFillsSource Property

RadarSeries.RadarScatterFillsSource Property
[image]

Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterFillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterFillsSource As BrushCollection

Property Value

A collection of WPF Brush objects.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterStrokes Property

RadarSeries.RadarScatterStrokes Property
[image]

Gets the strokes of the scatter marks. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokes As BrushCollection

Property Value

A collection of WPF Brush objects. The default is an empty collection.

Remarks

The RadarScatterStrokes property specifies brushes for filling scatter shapes drawn at data points in a radar series. If you want to show scatters at data points change the ScatterType property to a value different than None.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterStrokesSource Property

RadarSeries.RadarScatterStrokesSource Property
[image]

Gets or sets a strongly typed collection of brushes, which will be used as a source for the brushes used to fill the scatters in this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterStrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokesSource As BrushCollection

Property Value

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarScatterStrokeThickness Property

RadarSeries.RadarScatterStrokeThickness Property
[image]

Gets or sets the thickness of the scatter stroke. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double RadarScatterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokeThickness As Double

Property Value

A double value. The default is 1.

Remarks

The RadarScatterStrokeThickness property specifies the thickness of the stroke used for outlining scatters drawn at data points in this RadarSeries. If you want to show scatters set ScatterType to a value different than None.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.RadarStyle Property

RadarSeries.RadarStyle Property
[image]

Gets or sets the style of the radar series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RadarStyle RadarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property RadarStyle As RadarStyle

Property Value

A member of the RadarStyle enumeration. The default is Line.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.ScatterSize Property

RadarSeries.ScatterSize Property
[image]

Gets or sets the size of the scatter marks. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As Double

Property Value

A double value. The default is 10.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries.ScatterType Property

RadarSeries.ScatterType Property
[image]

Gets or sets the type of the scatter. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

A member of the ScatterType enumeration. The default is Circle.

See Also

RadarSeries Members
RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarSeries Events

RadarSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

RadarSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarStyle Enumeration

RadarStyle Enumeration
[image]

Defines values that specify how the radar graphic is drawn.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum RadarStyle

Visual Basic [image] Copy Code

Public Enum RadarStyle

Members

Member name | Description
Arc | The radar graphic is built of arcs.
Bezier | The radar graphic is built of bezier curves.
Line | The radar graphic is built of lines.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RadarType Enumeration

RadarType Enumeration
[image]

Defines values that specify the type of the radar chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum RadarType

Visual Basic [image] Copy Code

Public Enum RadarType

Members

Member name | Description
Polar | The chart is polar.
Radar | The chart is radar.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter Class

RectToDoubleConverter Class
[image]

Converts a Rect value to a double.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class RectToDoubleConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class RectToDoubleConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.RectToDoubleConverter

See Also

RectToDoubleConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter Members

RectToDoubleConverter Members
Constructors Methods
[image]

Converts a Rect value to a double.

The following tables list the members exposed by the RectToDoubleConverter type.

Public Constructors

Name | Description
RectToDoubleConverter | Initializes a new instance of the RectToDoubleConverter class.

Public Methods

Name | Description
Convert | Converts a Rect value to a double.
ConvertBack | IValueConverter.ConvertBack override.

See Also

RectToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter Constructor

RectToDoubleConverter Constructor
[image]

Initializes a new instance of the RectToDoubleConverter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public RectToDoubleConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RectToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter Methods

RectToDoubleConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a Rect value to a double.
ConvertBack | IValueConverter.ConvertBack override.

See Also

RectToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter.Convert Method

RectToDoubleConverter.Convert Method
[image]

Converts a Rect value to a double.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type of the conversion.

parameter

A parameter to use in the conversion.

culture

An instance of the System.Globalization.CultureInfo class.

Return Value

See Also

RectToDoubleConverter Members
RectToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RectToDoubleConverter.ConvertBack Method

RectToDoubleConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

Remarks

This method is not implemented in the RectToDoubleConverter class.

See Also

RectToDoubleConverter Members
RectToDoubleConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.RoundCornerType Enumeration

RoundCornerType Enumeration
[image]

Specifies which corners of a 3D chart element are drawn rounded.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum RoundCornerType

Visual Basic [image] Copy Code

Public Enum RoundCornerType

Members

Member name | Description
All | All corners of the 3D chart element are drawn rounded.
Bottom | Only the bottom corners of the 3D chart element are drawn rounded.
None | No corners of the 3D chart element are drawn rounded.
Top | The top corners of the 3D chart element are drawn rounded.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter Class

Scatter Class
[image]

Represents scatter marks drawn at data points in line charts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Scatter : ChartElement

Visual Basic [image] Copy Code

Public Class Scatter
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.ChartElement
MindFusion.Charting.Wpf.Scatter

See Also

Scatter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter Members

Scatter Members
Constructors Properties Methods
[image]

Represents scatter marks drawn at data points in line charts.

The following tables list the members exposed by the Scatter type.

Public Constructors

Name | Description
Scatter | Initializes a new instance of the Scatter class.

Public Properties

Name | Description
Center | Gets the center of this scatter.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Point3D | Gets the position of the scatter if this is a 3D chart.
ScatterIndex | Gets the index of the scatter.
ScatterSize | Gets the size of this scatter.
ScatterType | Gets the type of this scatter.
SeriesIndex | Gets the index of the series in the series collection this scatter belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this scatter element.

See Also

Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter Constructor

Scatter Constructor
[image]

Initializes a new instance of the Scatter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Scatter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter Methods

Scatter Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this scatter element.

See Also

Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.CreateShape Method

Scatter.CreateShape Method
[image]

Creates a Shape that represents this scatter element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A WPF Shape object.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter Properties

Scatter Properties
[image]

Public Properties

Name | Description
Center | Gets the center of this scatter.
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Point3D | Gets the position of the scatter if this is a 3D chart.
ScatterIndex | Gets the index of the scatter.
ScatterSize | Gets the size of this scatter.
ScatterType | Gets the type of this scatter.
SeriesIndex | Gets the index of the series in the series collection this scatter belongs to.
Shape | Gets or sets the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of Double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a value that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.Center Property

Scatter.Center Property
[image]

Gets the center of this scatter.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point Center { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Center As Point

Property Value

An instance of the WPF Point structure.

Remarks

This property returns the physical location of this scatter.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.Point3D Property

Scatter.Point3D Property
[image]

Gets the position of the scatter if this is a 3D chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point3D Point3D { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Point3D As Point3D

Property Value

A WPF Point object.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.ScatterIndex Property

Scatter.ScatterIndex Property
[image]

Gets the index of the scatter.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int ScatterIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterIndex As Integer

Property Value

An integer value.

Remarks

The ScatterIndex corresponds to the position in the data array of the ChartSeries this scatter belongs to.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.ScatterSize Property

Scatter.ScatterSize Property
[image]

Gets the size of this scatter.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ScatterSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterSize As Double

Property Value

A double value.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.ScatterType Property

Scatter.ScatterType Property
[image]

Gets the type of this scatter.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterType As ScatterType

Property Value

A member of ScatterType enumeration.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Scatter.SeriesIndex Property

Scatter.SeriesIndex Property
[image]

Gets the index of the series in the series collection this scatter belongs to.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An integer value.

Remarks

The SeriesIndex property corresponds to the position in the Series list of the ChartSeries this scatter belongs to.

See Also

Scatter Members
Scatter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ScatterType Enumeration

ScatterType Enumeration
[image]

Specifies the types of scatter shapes supported by the control.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum ScatterType

Visual Basic [image] Copy Code

Public Enum ScatterType

Members

Member name | Description
Circle | The scatter is drawn in the shape of a circle.
Cross | The scatter is drawn in the shape of a cross.
Diamond | The scatter is drawn in the shape of a diamond.
HorStick | The scatter is drawn in the shape of a horizontal stick.
InvertedTriangle | The scatter is drawn in the shape of an inverted triangle.
None | No scatter is drawn.
Plus | The scatter is drawn in the shape of a plus.
Square | The scatter is drawn in the shape of a square.
Star | The scatter is drawn in the shape of a star.
Triangle | The scatter is drawn in the shape of a triangle.
VertStick | The scatter is drawn in the shape of a vertical stick.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Class

SeriesLegend Class
[image]

Represents a legend with custom set labels and colors.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class SeriesLegend : Legend

Visual Basic [image] Copy Code

Public Class SeriesLegend
Inherits Legend

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Wpf.Legend
MindFusion.Charting.Wpf.SeriesLegend

See Also

SeriesLegend Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Members

SeriesLegend Members
Constructors Fields Properties Events
[image]

Represents a legend with custom set labels and colors.

The following tables list the members exposed by the SeriesLegend type.

Public Constructors

Name | Description
SeriesLegend | Initializes a new instance of the SeriesLegend class.

Public Fields

Name | Description
BrushesSourceProperty | Identifies the BrushesSource dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property. (Inherited from Legend.)
LabelsSourceProperty | Identifies the LabelsSource dependency property.
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property. (Inherited from Legend.)

Public Properties

Name | Description
BrushesSource | Gets or sets the source of the brushes that are used by this legend. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property. (Inherited from Legend.)
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property. (Inherited from Legend.)
LabelsSource | Gets or sets the source of the labels that are used by this legend. This is a dependency property.
Orientation | Gets or sets the orientation of the legend. This is a dependency property. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property. (Inherited from Legend.)
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property. (Inherited from Legend.)

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed. (Inherited from Legend.)

See Also

SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Fields

SeriesLegend Fields
[image]

Public Fields

Name | Description
BrushesSourceProperty | Identifies the BrushesSource dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property. (Inherited from Legend.)
LabelsSourceProperty | Identifies the LabelsSource dependency property.
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property. (Inherited from Legend.)

See Also

SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend.BrushesSourceProperty Field

SeriesLegend.BrushesSourceProperty Field
[image]

Identifies the BrushesSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushesSourceProperty As DependencyProperty

See Also

SeriesLegend Members
SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend.LabelsSourceProperty Field

SeriesLegend.LabelsSourceProperty Field
[image]

Identifies the LabelsSource dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsSourceProperty As DependencyProperty

See Also

SeriesLegend Members
SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Constructor

SeriesLegend Constructor
[image]

Initializes a new instance of the SeriesLegend class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SeriesLegend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Properties

SeriesLegend Properties
[image]

Public Properties

Name | Description
BrushesSource | Gets or sets the source of the brushes that are used by this legend. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the legend. This is a dependency property. (Inherited from Legend.)
HorizontalAlignment | Gets or sets the horizontal alignment of the legend when placed at the top or bottom of the plot area. This is a dependency property. (Inherited from Legend.)
LabelsSource | Gets or sets the source of the labels that are used by this legend. This is a dependency property.
Orientation | Gets or sets the orientation of the legend. This is a dependency property. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the legend. This is a dependency property. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the legend. This is a dependency property. (Inherited from Legend.)
VerticalAlignment | Gets or sets the vertical alignment of the legend when placed at the left or right of the plot area. This is a dependency property. (Inherited from Legend.)

See Also

SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend.BrushesSource Property

SeriesLegend.BrushesSource Property
[image]

Gets or sets the source of the brushes that are used by this legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection BrushesSource { get; set; }

Visual Basic [image] Copy Code

Public Property BrushesSource As BrushCollection

Property Value

A collection of WPF Brush objects. The default is an empty collection.

See Also

SeriesLegend Members
SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend.LabelsSource Property

SeriesLegend.LabelsSource Property
[image]

Gets or sets the source of the labels that are used by this legend. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public IList LabelsSource { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsSource As IList

Property Value

A list of objects that represent the labels. The default is an empty list.

Remarks

When the labels are not strings their are converted using the standard ToString method.

See Also

SeriesLegend Members
SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SeriesLegend Events

SeriesLegend Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the appearance of the legend was changed. (Inherited from Legend.)

See Also

SeriesLegend Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SliceLayout Enumeration

SliceLayout Enumeration
[image]

Specifies how slices in a 3D pie chart are arranged vertically.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum SliceLayout

Visual Basic [image] Copy Code

Public Enum SliceLayout

Members

Member name | Description
Cascading | The slices are drawn above each other as a cascade.
Flat | The slices are drawn next to each other. This is the standard way of rendering slices in a pie/doughnut chart.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Class

StockPrice Class
Remarks See Also
[image]

Represents a data object, containing open, close, low and high values for a certain date.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class StockPrice

Visual Basic [image] Copy Code

Public Class StockPrice

Remarks

Instances of this class represent price movements of stocks or currencies for a given time period. They are used as values of CandlestickSeries.

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.StockPrice

See Also

StockPrice Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Members

StockPrice Members
Constructors Properties
[image]

Represents a data object, containing open, close, low and high values for a certain date.

The following tables list the members exposed by the StockPrice type.

Public Constructors

Name | Description
StockPrice | Overloaded. Initializes a new instance of the StockPrice class.

Public Properties

Name | Description
Close | Gets or sets the close value.
Date | Gets or sets the date.
High | Gets or sets the high value.
Low | Gets or sets the low value.
Open | Gets or sets the open value.

See Also

StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Constructor

StockPrice Constructor
[image]

Initializes a new instance of the StockPrice class.

Overload List

Name | Description
StockPrice () | Initializes a new instance of the StockPrice class.
StockPrice (Double, Double, Double, Double) | Initializes a new instance of the StockPrice class.
StockPrice (Double, Double, Double, Double, DateTime) | Initializes a new instance of the StockPrice class.

See Also

StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Constructor ()

StockPrice Constructor ()
See Also
[image]

Initializes a new instance of the StockPrice class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public StockPrice ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StockPrice Constructor Overload List
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Constructor (Double, Double, Double, Double)

StockPrice Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the StockPrice class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public StockPrice (
double open,
double close,
double low,
double high
)

Visual Basic [image] Copy Code

Public New ( _
open As Double, _
close As Double, _
low As Double, _
high As Double _
)

Parameters

open

The open value.

close

The close value.

low

The low value.

high

The high value.

See Also

StockPrice Constructor Overload List
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Constructor (Double, Double, Double, Double, DateTime)

StockPrice Constructor (Double, Double, Double, Double, DateTime)
See Also
[image]

Initializes a new instance of the StockPrice class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public StockPrice (
double open,
double close,
double low,
double high,
DateTime date
)

Visual Basic [image] Copy Code

Public New ( _
open As Double, _
close As Double, _
low As Double, _
high As Double, _
date As DateTime _
)

Parameters

open

The open value.

close

The close value.

low

The low value.

high

The high value.

date

The corresponding date.

See Also

StockPrice Constructor Overload List
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice Properties

StockPrice Properties
[image]

Public Properties

Name | Description
Close | Gets or sets the close value.
Date | Gets or sets the date.
High | Gets or sets the high value.
Low | Gets or sets the low value.
Open | Gets or sets the open value.

See Also

StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice.Close Property

StockPrice.Close Property
[image]

Gets or sets the close value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Close { get; set; }

Visual Basic [image] Copy Code

Public Property Close As Double

Property Value

A double value specifying the close price.

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice.Date Property

StockPrice.Date Property
[image]

Gets or sets the date.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

A DateTime value specifying the date associated with current StockPrice.

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice.High Property

StockPrice.High Property
[image]

Gets or sets the high value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double High { get; set; }

Visual Basic [image] Copy Code

Public Property High As Double

Property Value

A double value specifying the high price.

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice.Low Property

StockPrice.Low Property
[image]

Gets or sets the low value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Low { get; set; }

Visual Basic [image] Copy Code

Public Property Low As Double

Property Value

A double value specifying the low price.

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StockPrice.Open Property

StockPrice.Open Property
[image]

Gets or sets the open value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Open { get; set; }

Visual Basic [image] Copy Code

Public Property Open As Double

Property Value

A double value specifying the open price.

See Also

StockPrice Members
StockPrice Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter Class

StringArrayConverter Class
[image]

Converts comma-separated string values to list of strings and vice versa.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class StringArrayConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class StringArrayConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.Wpf.StringArrayConverter

See Also

StringArrayConverter Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter Members

StringArrayConverter Members
Constructors Methods
[image]

Converts comma-separated string values to list of strings and vice versa.

The following tables list the members exposed by the StringArrayConverter type.

Public Constructors

Name | Description
StringArrayConverter | Initializes a new instance of the StringArrayConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter Constructor

StringArrayConverter Constructor
[image]

Initializes a new instance of the StringArrayConverter class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public StringArrayConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter Methods

StringArrayConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter.CanConvertFrom Method

StringArrayConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

StringArrayConverter Members
StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter.ConvertFrom Method

StringArrayConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

StringArrayConverter Members
StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.StringArrayConverter.ConvertTo Method

StringArrayConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

StringArrayConverter Members
StringArrayConverter Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Class

SurfaceChart Class
[image]

Represents a 3D surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class SurfaceChart : AxesChart3D

Visual Basic [image] Copy Code

Public Class SurfaceChart
Inherits AxesChart3D

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Wpf.Chart3D
MindFusion.Charting.Wpf.AxesChart3D
MindFusion.Charting.Wpf.SurfaceChart

See Also

SurfaceChart Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Members

SurfaceChart Members
Constructors Fields Properties Methods
[image]

Represents a 3D surface chart.

The following tables list the members exposed by the SurfaceChart type.

Public Constructors

Name | Description
SurfaceChart | Initializes a new instance of the SurfaceChart class.

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CloseModelFigureProperty | Identifies the CloseModelFigure dependency property.
ColorMapListProperty | Identifies the ColorMapList dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
CustomModelPositionsProperty | Identifies the CustomModelPositions dependency property.
CustomModelProperty | Identifies the CustomModel dependency property.
CustomModelTextureCoordinatesProperty | Identifies the CustomModelTextureCoordinates dependency property.
CustomModelTriangleIndicesProperty | Identifies the CustomModelTriangleIndices dependency property.
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property.
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart3D.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart3D.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart3D.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart3D.)
GroundLevelProperty | Identifies the GroundLevel dependency property.
InterpolationSensitivityProperty | Identifies the InterpolationSensitivity dependency property.
InterpolationTypeProperty | Identifies the InterpolationType dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
PointMergeThresholdProperty | Identifies the PointMergeThreshold dependency property.
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
ScatterFaceSizeProperty | Identifies the ScatterFaceSize dependency property.
ShowScattersProperty | Identifies the ShowScatters dependency property.
ShowSurfaceProperty | Identifies the ShowSurface dependency property.
ShowWireFrameProperty | Identifies the ShowWireFrame dependency property.
SideWallThicknessProperty | Identifies the SideWallThickness dependency property. (Inherited from AxesChart3D.)
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TextureTypeProperty | Identifies the TextureType dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
WireFrameThicknessProperty | Identifies the WireFrameThickness dependency property.
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property. (Inherited from AxesChart3D.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart3D.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart3D.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property. (Inherited from AxesChart3D.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart3D.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart3D.)
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property. (Inherited from AxesChart3D.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart3D.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart3D.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property. (Inherited from AxesChart3D.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart3D.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart3D.)
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property. (Inherited from AxesChart3D.)
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property. (Inherited from AxesChart3D.)
Z2LabelsProperty | Identifies the Z2Labels dependency property. (Inherited from AxesChart3D.)
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property. (Inherited from AxesChart3D.)
ZLabelPathProperty | Identifies the ZLabelPath dependency property. (Inherited from AxesChart3D.)
ZLabelsProperty | Identifies the ZLabels dependency property. (Inherited from AxesChart3D.)

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CloseModelFigure | Gets or sets a value indicating whether to add side walls to the model, which extend from the model surface down to the bottom of the plot area. This is a dependency property.
ColorMapList | Gets or sets the colors of the color map. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CustomModel | Draw custom model. This is a dependency property.
CustomModelPositions | Custom model positions. This is a dependency property.
CustomModelTextureCoordinates | Custom model texture coordinates. This is a dependency property.
CustomModelTriangleIndices | Custom model triangle indices. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property.
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridType | Gets or sets the grid type. This is a dependency property. (Inherited from AxesChart3D.)
GroundLevel | Gets or sets the value that indicates the level of the ground in the chart. This is a dependency property.
InterpolationSensitivity | Gets or sets the sensitivity with which the chart represents changes between adjacent data values. This is a dependency property.
InterpolationType | Gets or sets how surface points are added around the data points of the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
PointMergeThreshold | The threshold for merging points.
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
ScatterFaceSize | Gets or sets the size of the faces that build the scatters of the 3D chart. This is a dependency property.
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
ShowScatters | Show Scatters. This is a dependency property.
ShowSurface | Show Surface. This is a dependency property.
ShowWireFrame | Gets or sets a value indicating whether the wire frame is drawn. This is a dependency property.
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property. (Inherited from AxesChart3D.)
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
TextureType | Gets or sets the texture of the chart. This is a dependency property.
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
WireFrameThickness | Gets or sets the thickness of the wireframe. This is a dependency property.
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property. (Inherited from AxesChart3D.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property. (Inherited from AxesChart3D.)
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property. (Inherited from AxesChart3D.)
XAxisSettings | Gets the settings for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property. (Inherited from AxesChart3D.)
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property. (Inherited from AxesChart3D.)
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property. (Inherited from AxesChart3D.)
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property. (Inherited from AxesChart3D.)
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | AxesChart3D.HitTest override.
OnApplyTemplate | Chart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

Protected Methods

Name | Description
CalculateSpherePoints | Calculates the points of the sphere.
CalculateSpherePoints2 | Calculates the points of the sphere.

See Also

SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Fields

SurfaceChart Fields
[image]

Public Fields

Name | Description
AllowCameraInteractionProperty | Identifies the AllowCameraInteraction dependency property. (Inherited from Chart3D.)
AllowMeshSelectionProperty | Identifies the AllowMeshSelection dependency property. (Inherited from Chart3D.)
BehaviorProperty | Identifies the Behavior dependency property. (Inherited from Chart3D.)
CameraTypeProperty | Identifies the CameraType dependency property. (Inherited from Chart3D.)
CloseModelFigureProperty | Identifies the CloseModelFigure dependency property.
ColorMapListProperty | Identifies the ColorMapList dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart3D.)
CustomModelPositionsProperty | Identifies the CustomModelPositions dependency property.
CustomModelProperty | Identifies the CustomModel dependency property.
CustomModelTextureCoordinatesProperty | Identifies the CustomModelTextureCoordinates dependency property.
CustomModelTriangleIndicesProperty | Identifies the CustomModelTriangleIndices dependency property.
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart3D.)
Effect3DProperty | Identifies the Effect3D dependency property.
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart3D.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart3D.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart3D.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart3D.)
GroundLevelProperty | Identifies the GroundLevel dependency property.
InterpolationSensitivityProperty | Identifies the InterpolationSensitivity dependency property.
InterpolationTypeProperty | Identifies the InterpolationType dependency property.
LightsProperty | Identifies the Lights dependency property. (Inherited from Chart3D.)
MeshFaceSizeProperty | Identifies the MeshFaceSize dependency property. (Inherited from Chart3D.)
MeshSelectionBrushProperty | Identifies the MeshSelectionBrush dependency property. (Inherited from Chart3D.)
ModelDepthProperty | Identifies the ModelDepth dependency property. (Inherited from Chart3D.)
ModelHeightProperty | Identifies the ModelHeight dependency property. (Inherited from Chart3D.)
ModelWidthProperty | Identifies the ModelWidth dependency property. (Inherited from Chart3D.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart3D.)
PointMergeThresholdProperty | Identifies the PointMergeThreshold dependency property.
RenderBackSidesProperty | Identifies the RenderBackSides dependency property. (Inherited from Chart3D.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from Chart3D.)
RotationAxisProperty | Identifies the RotationAxis dependency property. (Inherited from Chart3D.)
ScaleProperty | Identifies the Scale dependency property. (Inherited from Chart3D.)
ScatterFaceSizeProperty | Identifies the ScatterFaceSize dependency property.
ShowScattersProperty | Identifies the ShowScatters dependency property.
ShowSurfaceProperty | Identifies the ShowSurface dependency property.
ShowWireFrameProperty | Identifies the ShowWireFrame dependency property.
SideWallThicknessProperty | Identifies the SideWallThickness dependency property. (Inherited from AxesChart3D.)
StaticLightsProperty | Identifies the StaticLights dependency property. (Inherited from Chart3D.)
TextureTypeProperty | Identifies the TextureType dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart3D.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart3D.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart3D.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart3D.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart3D.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart3D.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart3D.)
WireFrameThicknessProperty | Identifies the WireFrameThickness dependency property.
X2AxisSettingsProperty | Identifies the X2AxisSettings dependency property. (Inherited from AxesChart3D.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart3D.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart3D.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property. (Inherited from AxesChart3D.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart3D.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart3D.)
Y2AxisSettingsProperty | Identifies the Y2AxisSettings dependency property. (Inherited from AxesChart3D.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart3D.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart3D.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property. (Inherited from AxesChart3D.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart3D.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart3D.)
Z2AxisSettingsProperty | Identifies the Z2AxisSettings dependency property. (Inherited from AxesChart3D.)
Z2LabelPathProperty | Identifies the Z2LabelPath dependency property. (Inherited from AxesChart3D.)
Z2LabelsProperty | Identifies the Z2Labels dependency property. (Inherited from AxesChart3D.)
ZAxisSettingsProperty | Identifies the ZAxisSettings dependency property. (Inherited from AxesChart3D.)
ZLabelPathProperty | Identifies the ZLabelPath dependency property. (Inherited from AxesChart3D.)
ZLabelsProperty | Identifies the ZLabels dependency property. (Inherited from AxesChart3D.)

See Also

SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CloseModelFigureProperty Field

SurfaceChart.CloseModelFigureProperty Field
[image]

Identifies the CloseModelFigure dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CloseModelFigureProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CloseModelFigureProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ColorMapListProperty Field

SurfaceChart.ColorMapListProperty Field
[image]

Identifies the ColorMapList dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColorMapListProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColorMapListProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelPositionsProperty Field

SurfaceChart.CustomModelPositionsProperty Field
[image]

Identifies the CustomModelPositions dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomModelPositionsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomModelPositionsProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelProperty Field

SurfaceChart.CustomModelProperty Field
[image]

Identifies the CustomModel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomModelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomModelProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelTextureCoordinatesProperty Field

SurfaceChart.CustomModelTextureCoordinatesProperty Field
[image]

Identifies the CustomModelTextureCoordinates dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomModelTextureCoordinatesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomModelTextureCoordinatesProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelTriangleIndicesProperty Field

SurfaceChart.CustomModelTriangleIndicesProperty Field
[image]

Identifies the CustomModelTriangleIndices dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomModelTriangleIndicesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomModelTriangleIndicesProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.Effect3DProperty Field

SurfaceChart.Effect3DProperty Field
[image]

Identifies the Effect3D dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Effect3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Effect3DProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.GroundLevelProperty Field

SurfaceChart.GroundLevelProperty Field
[image]

Identifies the GroundLevel dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroundLevelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroundLevelProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.InterpolationSensitivityProperty Field

SurfaceChart.InterpolationSensitivityProperty Field
[image]

Identifies the InterpolationSensitivity dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InterpolationSensitivityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InterpolationSensitivityProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.InterpolationTypeProperty Field

SurfaceChart.InterpolationTypeProperty Field
[image]

Identifies the InterpolationType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InterpolationTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InterpolationTypeProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.PointMergeThresholdProperty Field

SurfaceChart.PointMergeThresholdProperty Field
[image]

Identifies the PointMergeThreshold dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointMergeThresholdProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointMergeThresholdProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ScatterFaceSizeProperty Field

SurfaceChart.ScatterFaceSizeProperty Field
[image]

Identifies the ScatterFaceSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterFaceSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterFaceSizeProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowScattersProperty Field

SurfaceChart.ShowScattersProperty Field
[image]

Identifies the ShowScatters dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowScattersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowScattersProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowSurfaceProperty Field

SurfaceChart.ShowSurfaceProperty Field
[image]

Identifies the ShowSurface dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowSurfaceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowSurfaceProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowWireFrameProperty Field

SurfaceChart.ShowWireFrameProperty Field
[image]

Identifies the ShowWireFrame dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowWireFrameProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowWireFrameProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.TextureTypeProperty Field

SurfaceChart.TextureTypeProperty Field
[image]

Identifies the TextureType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextureTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextureTypeProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.WireFrameThicknessProperty Field

SurfaceChart.WireFrameThicknessProperty Field
[image]

Identifies the WireFrameThickness dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WireFrameThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WireFrameThicknessProperty As DependencyProperty

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Constructor

SurfaceChart Constructor
[image]

Initializes a new instance of the SurfaceChart class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SurfaceChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Methods

SurfaceChart Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override. (Inherited from Chart3D.)
ClearMeshSelection | Clears any mesh selection. (Inherited from Chart3D.)
EndInit | FrameworkElement.EndInit override. (Inherited from Chart3D.)
HitTest | AxesChart3D.HitTest override.
OnApplyTemplate | Chart3D.OnApplyTemplate override.
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart3D.)

Protected Methods

Name | Description
CalculateSpherePoints | Calculates the points of the sphere.
CalculateSpherePoints2 | Calculates the points of the sphere.

See Also

SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CalculateSpherePoints Method

SurfaceChart.CalculateSpherePoints Method
[image]

Calculates the points of the sphere.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected void CalculateSpherePoints (
Point3D position,
Point3DCollection points,
Int32Collection indices,
PointCollection textures,
Orientation textureOrientation,
double radius,
int separators,
Dictionary<Point3D, Int32> temp
)

Visual Basic [image] Copy Code

Protected Sub CalculateSpherePoints( _
position As Point3D, _
points As Point3DCollection, _
indices As Int32Collection, _
textures As PointCollection, _
textureOrientation As Orientation, _
radius As Double, _
separators As Integer, _
temp As Dictionary(Of Point3D, Int32) _
)

Parameters

position

The 3D position.

points

The points.

indices

The indices.

textures

The textures of the chart.

textureOrientation

The texture orientation.

radius

The raidus.

separators

The separators.

temp

A dictionary used by the calculations.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CalculateSpherePoints2 Method

SurfaceChart.CalculateSpherePoints2 Method
[image]

Calculates the points of the sphere.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected void CalculateSpherePoints2 (
Point3D position,
Point3DCollection points,
Int32Collection indices,
PointCollection textures,
Orientation textureOrientation,
double radius,
int separators,
int count
)

Visual Basic [image] Copy Code

Protected Sub CalculateSpherePoints2( _
position As Point3D, _
points As Point3DCollection, _
indices As Int32Collection, _
textures As PointCollection, _
textureOrientation As Orientation, _
radius As Double, _
separators As Integer, _
count As Integer _
)

Parameters

position

The position.

points

The points to calculate.

indices

The indices.

textures

The textures.

textureOrientation

The texture orientation.

radius

The radius.

separators

The separators.

count

The point count.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.HitTest Method

SurfaceChart.HitTest Method
[image]

AxesChart3D.HitTest override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override ChartHitTestResult3D HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
p As Point _
) As ChartHitTestResult3D

Parameters

p

The point to test.

Return Value

An instance of the ChartHitTestResult3D class.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.OnApplyTemplate Method

SurfaceChart.OnApplyTemplate Method
[image]

Chart3D.OnApplyTemplate override.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

This method is overridden in the chart control and is used internally. It is not meant to be called by your code.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart Properties

SurfaceChart Properties
[image]

Public Properties

Name | Description
AllowCameraInteraction | Gets or sets a value indicating whether the position of the camera changes when the users clicks at the chart and drags with the mouse. This is a dependency property. (Inherited from Chart3D.)
AllowMeshSelection | Gets or sets a value indicating whether the individual mesh objects in the chart model can be selected with the mouse. This is a dependency property. (Inherited from Chart3D.)
Behavior | Gets or sets a value indicating how the chart control responds to actions with the mouse. This is a dependency property. (Inherited from Chart3D.)
CameraType | Gets or sets the type of the camera. This is a dependency property. (Inherited from Chart3D.)
ChartTheme | Gets or sets a ChartTheme that defines the appearance of chart elements. (Inherited from Chart3D.)
CloseModelFigure | Gets or sets a value indicating whether to add side walls to the model, which extend from the model surface down to the bottom of the plot area. This is a dependency property.
ColorMapList | Gets or sets the colors of the color map. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property. (Inherited from Chart3D.)
CustomModel | Draw custom model. This is a dependency property.
CustomModelPositions | Custom model positions. This is a dependency property.
CustomModelTextureCoordinates | Custom model texture coordinates. This is a dependency property.
CustomModelTriangleIndices | Custom model triangle indices. This is a dependency property.
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart3D.)
Effect3D | Gets or sets the 3D effect of the chart. This is a dependency property.
GridFills | Gets or sets the brushes for the grid stripes. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokes | Gets or sets the brushes for the grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridStrokeThickness | Gets or sets the thickness of grid lines. This is a dependency property. (Inherited from AxesChart3D.)
GridType | Gets or sets the grid type. This is a dependency property. (Inherited from AxesChart3D.)
GroundLevel | Gets or sets the value that indicates the level of the ground in the chart. This is a dependency property.
InterpolationSensitivity | Gets or sets the sensitivity with which the chart represents changes between adjacent data values. This is a dependency property.
InterpolationType | Gets or sets how surface points are added around the data points of the chart. This is a dependency property.
Legends | Gets or sets a list with the chart legends. (Inherited from Chart3D.)
Lights | Gets or sets the lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
MeshFaceSize | Gets or sets the size of the faces that build the mesh of the 3D chart. This is a dependency property. (Inherited from Chart3D.)
MeshSelectionBrush | Gets or sets the brush used to highlight selected objects in the chart model. This is a dependency property. (Inherited from Chart3D.)
ModelDepth | Gets or sets the depth of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelHeight | Gets or sets the height of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
ModelWidth | Gets or sets the width of the 3D model that holds the chart. This is a dependency property. (Inherited from Chart3D.)
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property. (Inherited from Chart3D.)
PointMergeThreshold | The threshold for merging points.
RenderBackSides | Gets or sets a value indicating whether the back sides of the chart and the wire frame, if present, are rendered. This is a dependency property. (Inherited from Chart3D.)
RotationAngle | Gets or sets the angle of rotation for the chart. This is a dependency property. (Inherited from Chart3D.)
RotationAxis | Gets or sets the axis of rotation of the chart. This is a dependency property. (Inherited from Chart3D.)
Scale | Gets or sets the scale factor of the chart. This is a dependency property. (Inherited from Chart3D.)
ScatterFaceSize | Gets or sets the size of the faces that build the scatters of the 3D chart. This is a dependency property.
Series | Gets the list with the series in the chart. (Inherited from Chart3D.)
ShowScatters | Show Scatters. This is a dependency property.
ShowSurface | Show Surface. This is a dependency property.
ShowWireFrame | Gets or sets a value indicating whether the wire frame is drawn. This is a dependency property.
SideWallThickness | Gets or sets the thickness of the side walls. This is a dependency property. (Inherited from AxesChart3D.)
StaticLights | Gets or sets the static lights in the chart model. This is a dependency property. (Inherited from Chart3D.)
TextureType | Gets or sets the texture of the chart. This is a dependency property.
Title | Gets or sets the title of the chart. This is a dependency property. (Inherited from Chart3D.)
TitleFontFamily | Gets or sets the font family for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontSize | Gets or sets the font size for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontStyle | Gets or sets the font style for the title. This is a dependency property. (Inherited from Chart3D.)
TitleFontWeight | Gets or sets the font weight for the title. This is a dependency property. (Inherited from Chart3D.)
TitleMargin | Gets or sets the margin around the title. This is a dependency property. (Inherited from Chart3D.)
TitleVisibility | Gets or sets the visibility of the chart's title. This is a dependency property. (Inherited from Chart3D.)
WireFrameThickness | Gets or sets the thickness of the wireframe. This is a dependency property.
X2AxisSettings | Gets the settings for the secondary X-axis. This is a dependency property. (Inherited from AxesChart3D.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. This is a dependency property. (Inherited from AxesChart3D.)
X2Labels | Gets or sets the custom labels for the X2-axis. This is a dependency property. (Inherited from AxesChart3D.)
XAxisSettings | Gets the settings for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. This is a dependency property. (Inherited from AxesChart3D.)
XLabels | Gets or sets the custom labels for the X-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2AxisSettings | Gets the settings for the secondary Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Y2Labels | Gets or sets the custom labels for the Y2-axis. This is a dependency property. (Inherited from AxesChart3D.)
YAxisSettings | Gets the settings for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. This is a dependency property. (Inherited from AxesChart3D.)
YLabels | Gets or sets the custom labels for the Y-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2AxisSettings | Gets the settings for the secondary Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
Z2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z2-labels. This is a dependency property. (Inherited from AxesChart3D.)
Z2Labels | Gets or sets the custom labels for the Z2-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZAxisSettings | Gets the settings for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)
ZLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Z-labels. This is a dependency property. (Inherited from AxesChart3D.)
ZLabels | Gets or sets the custom labels for the Z-axis. This is a dependency property. (Inherited from AxesChart3D.)

See Also

SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CloseModelFigure Property

SurfaceChart.CloseModelFigure Property
[image]

Gets or sets a value indicating whether to add side walls to the model, which extend from the model surface down to the bottom of the plot area. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool CloseModelFigure { get; set; }

Visual Basic [image] Copy Code

Public Property CloseModelFigure As Boolean

Property Value

A boolean value. The default is false.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ColorMapList Property

SurfaceChart.ColorMapList Property
[image]

Gets or sets the colors of the color map. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SortedList<Double, Color> ColorMapList { get; set; }

Visual Basic [image] Copy Code

Public Property ColorMapList As SortedList(Of Double, Color)

Property Value

A map that specifies the colors corresponding to chart values.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModel Property

SurfaceChart.CustomModel Property
[image]

Draw custom model. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool CustomModel { get; set; }

Visual Basic [image] Copy Code

Public Property CustomModel As Boolean

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelPositions Property

SurfaceChart.CustomModelPositions Property
[image]

Custom model positions. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point3DCollection CustomModelPositions { get; set; }

Visual Basic [image] Copy Code

Public Property CustomModelPositions As Point3DCollection

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelTextureCoordinates Property

SurfaceChart.CustomModelTextureCoordinates Property
[image]

Custom model texture coordinates. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointCollection CustomModelTextureCoordinates { get; set; }

Visual Basic [image] Copy Code

Public Property CustomModelTextureCoordinates As PointCollection

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.CustomModelTriangleIndices Property

SurfaceChart.CustomModelTriangleIndices Property
[image]

Custom model triangle indices. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Int32Collection CustomModelTriangleIndices { get; set; }

Visual Basic [image] Copy Code

Public Property CustomModelTriangleIndices As Int32Collection

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.Effect3D Property

SurfaceChart.Effect3D Property
[image]

Gets or sets the 3D effect of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ChartEffect3D Effect3D { get; set; }

Visual Basic [image] Copy Code

Public Property Effect3D As ChartEffect3D

Property Value

A member of the ChartEffect3D enumeration.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.GroundLevel Property

SurfaceChart.GroundLevel Property
[image]

Gets or sets the value that indicates the level of the ground in the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GroundLevel { get; set; }

Visual Basic [image] Copy Code

Public Property GroundLevel As Double

Property Value

A double value. The default is NaN.

Remarks

Use the GroundLevel property to change where the X and Y axis intersect.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.InterpolationSensitivity Property

SurfaceChart.InterpolationSensitivity Property
[image]

Gets or sets the sensitivity with which the chart represents changes between adjacent data values. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double InterpolationSensitivity { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationSensitivity As Double

Property Value

A double value. The default is 14.

Remarks

Smaller values make for sharper surface contours and vice versa.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.InterpolationType Property

SurfaceChart.InterpolationType Property
[image]

Gets or sets how surface points are added around the data points of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public InterpolationType InterpolationType { get; set; }

Visual Basic [image] Copy Code

Public Property InterpolationType As InterpolationType

Property Value

A member of the InterpolationType enumeration. The default is Bezier.

Remarks

The InterpolationType property specifies the method that is used to calculate the location of the points close to a given chart data point.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.PointMergeThreshold Property

SurfaceChart.PointMergeThreshold Property
[image]

The threshold for merging points.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double PointMergeThreshold { get; set; }

Visual Basic [image] Copy Code

Public Property PointMergeThreshold As Double

Property Value

A double value that indicates the biggest distance at which two points will be merged into one to increase performance. Default value is 0.2

Remarks

For better performance increase the value of the property. Note that this might decrease quality

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ScatterFaceSize Property

SurfaceChart.ScatterFaceSize Property
[image]

Gets or sets the size of the faces that build the scatters of the 3D chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ScatterFaceSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFaceSize As Double

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowScatters Property

SurfaceChart.ShowScatters Property
[image]

Show Scatters. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowScatters { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScatters As Boolean

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowSurface Property

SurfaceChart.ShowSurface Property
[image]

Show Surface. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowSurface { get; set; }

Visual Basic [image] Copy Code

Public Property ShowSurface As Boolean

Property Value

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.ShowWireFrame Property

SurfaceChart.ShowWireFrame Property
[image]

Gets or sets a value indicating whether the wire frame is drawn. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowWireFrame { get; set; }

Visual Basic [image] Copy Code

Public Property ShowWireFrame As Boolean

Property Value

true if the wire frame is drawn; otherwise false. The default is false.

Remarks

You can set the thickness of the wire frame lines with the WireFrameThickness property.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.TextureType Property

SurfaceChart.TextureType Property
[image]

Gets or sets the texture of the chart. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public TextureType TextureType { get; set; }

Visual Basic [image] Copy Code

Public Property TextureType As TextureType

Property Value

A member of the TextureType enumeration. The default is Brush.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceChart.WireFrameThickness Property

SurfaceChart.WireFrameThickness Property
[image]

Gets or sets the thickness of the wireframe. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double WireFrameThickness { get; set; }

Visual Basic [image] Copy Code

Public Property WireFrameThickness As Double

Property Value

A double value. The default value is 1.

Remarks

The wire frame is drawn when ShowWireFrame is enabled.

See Also

SurfaceChart Members
SurfaceChart Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Class

SurfaceSeries Class
[image]

Represents a series in a surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class SurfaceSeries : AxesSeries3D

Visual Basic [image] Copy Code

Public Class SurfaceSeries
Inherits AxesSeries3D

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Wpf.ChartSeries
MindFusion.Charting.Wpf.AxesSeries
MindFusion.Charting.Wpf.AxesSeries3D
MindFusion.Charting.Wpf.SurfaceSeries

See Also

SurfaceSeries Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Members

SurfaceSeries Members
Constructors Fields Properties Events
[image]

Represents a series in a surface chart.

The following tables list the members exposed by the SurfaceSeries type.

Public Constructors

Name | Description
SurfaceSeries | Overloaded.

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
ClipMaximumProperty | Identifies the ClipMaximum dependency property.
ClipMinimumProperty | Identifies the ClipMinimum dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
GroundLevelMarginProperty | Identifies the GroundLevelMargin dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
ShowScatterFlagProperty | Identifies the ShowScatterFlag dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TextureOrientationProperty | Identifies the TextureOrientation dependency property.
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)
Z2DataPathProperty | Identifies the Z2DataPath dependency property. (Inherited from AxesSeries3D.)
Z2DataProperty | Identifies the Z2Data dependency property. (Inherited from AxesSeries3D.)
ZDataPathProperty | Identifies the ZDataPath dependency property. (Inherited from AxesSeries3D.)
ZDataProperty | Identifies the ZData dependency property. (Inherited from AxesSeries3D.)

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
ClipMaximum | Gets or sets the maximum value to display for this series. This is a dependency property.
ClipMinimum | Gets or sets the minimum value to display for this series. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
GroundLevelMargin | Gets or sets the offset of the ground level for this series. This is a dependency property.
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
ScatterSize | Gets or sets the size of the scatter marks of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.
ScatterType | Gets or sets the type of the scatter mark of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.
ShowScatterFlag | Gets or sets a value indicating whether to display projections from the scatter marks to the bottom of the plot area. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
TextureOrientation | Gets or sets the orientation of the texture applied to the elements representing this series. This is a dependency property.
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)
Z2Data | Gets or sets the data used for calculating the Z2-coordinates of data points. This is a dependency property. (Inherited from AxesSeries3D.)
Z2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z2-data for this series. This is a dependency property. (Inherited from AxesSeries3D.)
ZData | Gets or sets the data used for calculating the Z-coordinates of data points. This is a dependency property. (Inherited from AxesSeries3D.)
ZDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z-data for this series. This is a dependency property. (Inherited from AxesSeries3D.)

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Fields

SurfaceSeries Fields
[image]

Public Fields

Name | Description
ChartProperty | Identifies the Chart dependency property. (Inherited from ChartSeries.)
ClipMaximumProperty | Identifies the ClipMaximum dependency property.
ClipMinimumProperty | Identifies the ClipMinimum dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
GroundLevelMarginProperty | Identifies the GroundLevelMargin dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
ShowScatterFlagProperty | Identifies the ShowScatterFlag dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TextureOrientationProperty | Identifies the TextureOrientation dependency property.
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
ToolTipTextProperty | Identifies the ToolTipText dependency property. (Inherited from ChartSeries.)
ToolTipTypeProperty | Identifies the ToolTipType dependency property. (Inherited from ChartSeries.)
XAxisProperty | Identifies the XAxis dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
YAxisProperty | Identifies the YAxis dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)
Z2DataPathProperty | Identifies the Z2DataPath dependency property. (Inherited from AxesSeries3D.)
Z2DataProperty | Identifies the Z2Data dependency property. (Inherited from AxesSeries3D.)
ZDataPathProperty | Identifies the ZDataPath dependency property. (Inherited from AxesSeries3D.)
ZDataProperty | Identifies the ZData dependency property. (Inherited from AxesSeries3D.)

See Also

SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ClipMaximumProperty Field

SurfaceSeries.ClipMaximumProperty Field
[image]

Identifies the ClipMaximum dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipMaximumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipMaximumProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ClipMinimumProperty Field

SurfaceSeries.ClipMinimumProperty Field
[image]

Identifies the ClipMinimum dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipMinimumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipMinimumProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.GroundLevelMarginProperty Field

SurfaceSeries.GroundLevelMarginProperty Field
[image]

Identifies the GroundLevelMargin dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroundLevelMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroundLevelMarginProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ScatterSizeProperty Field

SurfaceSeries.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ScatterTypeProperty Field

SurfaceSeries.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ShowScatterFlagProperty Field

SurfaceSeries.ShowScatterFlagProperty Field
[image]

Identifies the ShowScatterFlag dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowScatterFlagProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowScatterFlagProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.TextureOrientationProperty Field

SurfaceSeries.TextureOrientationProperty Field
[image]

Identifies the TextureOrientation dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextureOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextureOrientationProperty As DependencyProperty

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Constructor

SurfaceSeries Constructor
[image]

Overload List

Name | Description
SurfaceSeries () | Initializes a new instance of the SurfaceSeries class.
SurfaceSeries (Axis, Axis) | Initializes a new instance of the SurfaceSeries class.

See Also

SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Constructor ()

SurfaceSeries Constructor ()
See Also
[image]

Initializes a new instance of the SurfaceSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SurfaceSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SurfaceSeries Constructor Overload List
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Constructor (Axis, Axis)

SurfaceSeries Constructor (Axis, Axis)
See Also
[image]

Initializes a new instance of the SurfaceSeries class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public SurfaceSeries (
Axis xAxis,
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
xAxis As Axis, _
yAxis As Axis _
)

Parameters

xAxis

yAxis

See Also

SurfaceSeries Constructor Overload List
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Properties

SurfaceSeries Properties
[image]

Public Properties

Name | Description
Chart | Gets or sets the Chart this ChartSeries is part of. (Inherited from ChartSeries.)
ClipMaximum | Gets or sets the maximum value to display for this series. This is a dependency property.
ClipMinimum | Gets or sets the minimum value to display for this series. This is a dependency property.
Fills | Gets the fills of the series. This is a dependency property. (Inherited from ChartSeries.)
FillsSource | Gets or sets a list of brushes used for filling elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
GroundLevelMargin | Gets or sets the offset of the ground level for this series. This is a dependency property.
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. This is a dependency property. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the chart labels. This is a dependency property. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. This is a dependency property. (Inherited from ChartSeries.)
ScatterSize | Gets or sets the size of the scatter marks of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.
ScatterType | Gets or sets the type of the scatter mark of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.
ShowScatterFlag | Gets or sets a value indicating whether to display projections from the scatter marks to the bottom of the plot area. This is a dependency property.
StrokeDashArray | Gets or sets a collection of Double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. This is a dependency property. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. This is a dependency property. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the end of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries shape. This is a dependency property. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries shape element. This is a dependency property. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. This is a dependency property. (Inherited from ChartSeries.)
StrokesSource | Gets or sets a list of brushes used as a source for the strokes used to outline chart elements in this ChartSeries. This is a dependency property. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the shape at the start of a line. This is a dependency property. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. This is a dependency property. (Inherited from ChartSeries.)
TextureOrientation | Gets or sets the orientation of the texture applied to the elements representing this series. This is a dependency property.
Title | Gets or sets the title of the series. This is a dependency property. (Inherited from ChartSeries.)
ToolTipText | Gets or sets the tooltips to use when ToolTipType is set to Custom. This is a dependency property. (Inherited from ChartSeries.)
ToolTipType | Gets or sets a value specifying what tooltips to display for the values in this series. This is a dependency property. (Inherited from ChartSeries.)
XAxis | (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. This is a dependency property. (Inherited from AxesSeries.)
YAxis | (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. This is a dependency property. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. This is a dependency property. (Inherited from AxesSeries.)
Z2Data | Gets or sets the data used for calculating the Z2-coordinates of data points. This is a dependency property. (Inherited from AxesSeries3D.)
Z2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z2-data for this series. This is a dependency property. (Inherited from AxesSeries3D.)
ZData | Gets or sets the data used for calculating the Z-coordinates of data points. This is a dependency property. (Inherited from AxesSeries3D.)
ZDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Z-data for this series. This is a dependency property. (Inherited from AxesSeries3D.)

See Also

SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ClipMaximum Property

SurfaceSeries.ClipMaximum Property
[image]

Gets or sets the maximum value to display for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ClipMaximum { get; set; }

Visual Basic [image] Copy Code

Public Property ClipMaximum As Double

Property Value

A double value. The default is NaN indicating that maximum clipping is disabled.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ClipMinimum Property

SurfaceSeries.ClipMinimum Property
[image]

Gets or sets the minimum value to display for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ClipMinimum { get; set; }

Visual Basic [image] Copy Code

Public Property ClipMinimum As Double

Property Value

A double value. The default is NaN indicating that minimum clipping is disabled.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.GroundLevelMargin Property

SurfaceSeries.GroundLevelMargin Property
[image]

Gets or sets the offset of the ground level for this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double GroundLevelMargin { get; set; }

Visual Basic [image] Copy Code

Public Property GroundLevelMargin As Double

Property Value

A double value. The default is 0.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ScatterSize Property

SurfaceSeries.ScatterSize Property
[image]

Gets or sets the size of the scatter marks of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As DoubleCollection

Property Value

A double value. The default is 1.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ScatterType Property

SurfaceSeries.ScatterType Property
[image]

Gets or sets the type of the scatter mark of this series when displayed in a chart with SurfaceType set to Scatter. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

A member of the ScatterType enumeration. The default is Circle.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.ShowScatterFlag Property

SurfaceSeries.ShowScatterFlag Property
[image]

Gets or sets a value indicating whether to display projections from the scatter marks to the bottom of the plot area. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ShowScatterFlag { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScatterFlag As Boolean

Property Value

The default is false.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries.TextureOrientation Property

SurfaceSeries.TextureOrientation Property
[image]

Gets or sets the orientation of the texture applied to the elements representing this series. This is a dependency property.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Orientation TextureOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property TextureOrientation As Orientation

Property Value

A member of the WPF Orientation enumeration. The default is Vertical.

See Also

SurfaceSeries Members
SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceSeries Events

SurfaceSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

SurfaceSeries Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.SurfaceType Enumeration

SurfaceType Enumeration
[image]

Specifies the type of a surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum SurfaceType

Visual Basic [image] Copy Code

Public Enum SurfaceType

Members

Member name | Description
Both | Indicates that the chart should display both scatter and surface.
Scatter | Indicates that the chart should display scatter marks.
Surface | Indicates that the chart should display a surface.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.TextureType Enumeration

TextureType Enumeration
[image]

Specifies how to color a surface chart.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum TextureType

Visual Basic [image] Copy Code

Public Enum TextureType

Members

Member name | Description
Brush | Indicates that the surface is colored using a brush.
ExactColorMap | Indicates that the surface is colored using an exact color map.
GradientColorMap | Indicates that the surface is colored using a gradient color map.
None | Indicates that the surface is invisible.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ToolTipType Enumeration

ToolTipType Enumeration
[image]

Specifies the type of tooltips to display for the values in a chart series.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum ToolTipType

Visual Basic [image] Copy Code

Public Enum ToolTipType

Members

Member name | Description
ChartData | Indicates that the tooltips should display the associated value.
CustomText | Indicates that the tooltips are supplied by the user.
Empty | Indicates no tooltips.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Class

Triangle Class
[image]

Triangle class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Triangle

Visual Basic [image] Copy Code

Public Class Triangle

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.Triangle

See Also

Triangle Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Members

Triangle Members
Constructors Fields Properties Methods
[image]

Triangle class.

The following tables list the members exposed by the Triangle type.

Public Constructors

Name | Description
Triangle | Overloaded.

Protected Fields

Name | Description
m_a | The a-vertex.
m_ab | Identifies the ab side.
m_abDet | The ab-determination.
m_abDetCalcd | The ab-determination.
m_abLen | The a-length.
m_abLenCalcd | The ab-length.
m_b | The b-vertex.
m_bc | Identifies the bc side.
m_bcDet | The bc-determination.
m_bcDetCalcd | The bc-determination.
m_bcLen | The b-length.
m_bcLenCalcd | The bc-length.
m_c | The c-vertex.
m_ca | Identifies the ca side.
m_caDet | The ca-determination.
m_caDetCalcd | The ca-determination.
m_caLen | The c-length.
m_caLenCalcd | The ca-length.
m_center | Identifies the center vertex.
m_centerComputed | Identifies the center.
m_index | Index of this triangle for debug.

Public Properties

Name | Description
A | Vertex A
AB | Triangle AB shares side AB.
AB_Length | Length of AB, cached and lazy calculated.
Area | Area of the triangle.
B | Vertex B
BC | Triangle BC shares side BC.
BC_Length | Length of BC, cached and lazy calculated.
C | Vertex C
CA | Triangle CA shares side CA.
CA_Length | Length of CA, cached and lazy calculated.
Center | Compute the center
FarthestFromCenter | Farthest distance a point is from center is distance squared.
Index | Index.
RegionCode | Which search region it is in.

Protected Properties

Name | Description
abDet | AB det.
bcDet | BC det.
caDet | CA det.

Public Methods

Name | Description
Contains | Does this contain t.
Edge | Get the indexed edge.
Edge_Length | Return the indexed edge length;
GetVertex | Vertex.
Inside | Is this rectangle within the region.
OpositeOfEdge | Return the oposite of the edge.
RepairEdges | Repair any Edge links, both ways.
ResetIndex | Reset the index, indexing gives each triangle an ID unique since construction of the mesh.
SetEdge | Set the edge by index.
SetVertex | Set the vertex by index.
ToString | To string.
VertexAngleRadians | Get the angle of a vertex in radians.
VertexCosineAngle | Get the cosine angle associated with a vertex.

Protected Methods

Name | Description
bothIn | Checks if both vertexes are in.
vertexTest | Vertex sidedness test.

See Also

Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Fields

Triangle Fields
[image]

Protected Fields

Name | Description
m_a | The a-vertex.
m_ab | Identifies the ab side.
m_abDet | The ab-determination.
m_abDetCalcd | The ab-determination.
m_abLen | The a-length.
m_abLenCalcd | The ab-length.
m_b | The b-vertex.
m_bc | Identifies the bc side.
m_bcDet | The bc-determination.
m_bcDetCalcd | The bc-determination.
m_bcLen | The b-length.
m_bcLenCalcd | The bc-length.
m_c | The c-vertex.
m_ca | Identifies the ca side.
m_caDet | The ca-determination.
m_caDetCalcd | The ca-determination.
m_caLen | The c-length.
m_caLenCalcd | The ca-length.
m_center | Identifies the center vertex.
m_centerComputed | Identifies the center.
m_index | Index of this triangle for debug.

See Also

Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_a Field

Triangle.m_a Field
[image]

The a-vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Vertex m_a

Visual Basic [image] Copy Code

Protected m_a As Vertex

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_ab Field

Triangle.m_ab Field
[image]

Identifies the ab side.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Triangle m_ab

Visual Basic [image] Copy Code

Protected m_ab As Triangle

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_abDet Field

Triangle.m_abDet Field
[image]

The ab-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_abDet

Visual Basic [image] Copy Code

Protected m_abDet As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_abDetCalcd Field

Triangle.m_abDetCalcd Field
[image]

The ab-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_abDetCalcd

Visual Basic [image] Copy Code

Protected m_abDetCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_abLen Field

Triangle.m_abLen Field
[image]

The a-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected double m_abLen

Visual Basic [image] Copy Code

Protected m_abLen As Double

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_abLenCalcd Field

Triangle.m_abLenCalcd Field
[image]

The ab-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_abLenCalcd

Visual Basic [image] Copy Code

Protected m_abLenCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_b Field

Triangle.m_b Field
[image]

The b-vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Vertex m_b

Visual Basic [image] Copy Code

Protected m_b As Vertex

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_bc Field

Triangle.m_bc Field
[image]

Identifies the bc side.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Triangle m_bc

Visual Basic [image] Copy Code

Protected m_bc As Triangle

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_bcDet Field

Triangle.m_bcDet Field
[image]

The bc-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_bcDet

Visual Basic [image] Copy Code

Protected m_bcDet As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_bcDetCalcd Field

Triangle.m_bcDetCalcd Field
[image]

The bc-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_bcDetCalcd

Visual Basic [image] Copy Code

Protected m_bcDetCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_bcLen Field

Triangle.m_bcLen Field
[image]

The b-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected double m_bcLen

Visual Basic [image] Copy Code

Protected m_bcLen As Double

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_bcLenCalcd Field

Triangle.m_bcLenCalcd Field
[image]

The bc-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_bcLenCalcd

Visual Basic [image] Copy Code

Protected m_bcLenCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_c Field

Triangle.m_c Field
[image]

The c-vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Vertex m_c

Visual Basic [image] Copy Code

Protected m_c As Vertex

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_ca Field

Triangle.m_ca Field
[image]

Identifies the ca side.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Triangle m_ca

Visual Basic [image] Copy Code

Protected m_ca As Triangle

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_caDet Field

Triangle.m_caDet Field
[image]

The ca-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_caDet

Visual Basic [image] Copy Code

Protected m_caDet As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_caDetCalcd Field

Triangle.m_caDetCalcd Field
[image]

The ca-determination.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_caDetCalcd

Visual Basic [image] Copy Code

Protected m_caDetCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_caLen Field

Triangle.m_caLen Field
[image]

The c-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected double m_caLen

Visual Basic [image] Copy Code

Protected m_caLen As Double

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_caLenCalcd Field

Triangle.m_caLenCalcd Field
[image]

The ca-length.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_caLenCalcd

Visual Basic [image] Copy Code

Protected m_caLenCalcd As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_center Field

Triangle.m_center Field
[image]

Identifies the center vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected Vertex m_center

Visual Basic [image] Copy Code

Protected m_center As Vertex

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_centerComputed Field

Triangle.m_centerComputed Field
[image]

Identifies the center.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool m_centerComputed

Visual Basic [image] Copy Code

Protected m_centerComputed As Boolean

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.m_index Field

Triangle.m_index Field
[image]

Index of this triangle for debug.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected static int m_index

Visual Basic [image] Copy Code

Protected Shared m_index As Integer

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Constructor

Triangle Constructor
[image]

Overload List

Name | Description
Triangle () | Constructor.
Triangle (Triangle) | Copy constructor.
Triangle (Vertex, Vertex, Vertex) | Constructor by vertex.

See Also

Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Constructor ()

Triangle Constructor ()
See Also
[image]

Constructor.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Triangle Constructor Overload List
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Constructor (Triangle)

Triangle Constructor (Triangle)
See Also
[image]

Copy constructor.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle (
Triangle src
)

Visual Basic [image] Copy Code

Public New ( _
src As Triangle _
)

Parameters

src

See Also

Triangle Constructor Overload List
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Constructor (Vertex, Vertex, Vertex)

Triangle Constructor (Vertex, Vertex, Vertex)
See Also
[image]

Constructor by vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle (
Vertex a,
Vertex b,
Vertex c
)

Visual Basic [image] Copy Code

Public New ( _
a As Vertex, _
b As Vertex, _
c As Vertex _
)

Parameters

a

b

c

See Also

Triangle Constructor Overload List
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Methods

Triangle Methods
[image]

Public Methods

Name | Description
Contains | Does this contain t.
Edge | Get the indexed edge.
Edge_Length | Return the indexed edge length;
GetVertex | Vertex.
Inside | Is this rectangle within the region.
OpositeOfEdge | Return the oposite of the edge.
RepairEdges | Repair any Edge links, both ways.
ResetIndex | Reset the index, indexing gives each triangle an ID unique since construction of the mesh.
SetEdge | Set the edge by index.
SetVertex | Set the vertex by index.
ToString | To string.
VertexAngleRadians | Get the angle of a vertex in radians.
VertexCosineAngle | Get the cosine angle associated with a vertex.

Protected Methods

Name | Description
bothIn | Checks if both vertexes are in.
vertexTest | Vertex sidedness test.

See Also

Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.bothIn Method

Triangle.bothIn Method
[image]

Checks if both vertexes are in.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool bothIn (
Triangle t,
Vertex a,
Vertex b
)

Visual Basic [image] Copy Code

Protected Function bothIn( _
t As Triangle, _
a As Vertex, _
b As Vertex _
) As Boolean

Parameters

t

The triangle.

a

The A-vertex.

b

B-vertex.

Return Value

true if both vertexes are in; otherwise false.

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Contains Method

Triangle.Contains Method
[image]

Does this contain t.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Vertex t
)

Visual Basic [image] Copy Code

Public Function Contains( _
t As Vertex _
) As Boolean

Parameters

t

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Edge Method

Triangle.Edge Method
[image]

Get the indexed edge.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle Edge (
int i
)

Visual Basic [image] Copy Code

Public Function Edge( _
i As Integer _
) As Triangle

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Edge_Length Method

Triangle.Edge_Length Method
[image]

Return the indexed edge length;

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Edge_Length (
int i
)

Visual Basic [image] Copy Code

Public Function Edge_Length( _
i As Integer _
) As Double

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.GetVertex Method

Triangle.GetVertex Method
[image]

Vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex GetVertex (
int i
)

Visual Basic [image] Copy Code

Public Function GetVertex( _
i As Integer _
) As Vertex

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Inside Method

Triangle.Inside Method
[image]

Is this rectangle within the region.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool Inside (
Rect region
)

Visual Basic [image] Copy Code

Public Function Inside( _
region As Rect _
) As Boolean

Parameters

region

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.OpositeOfEdge Method

Triangle.OpositeOfEdge Method
[image]

Return the oposite of the edge.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex OpositeOfEdge (
int i
)

Visual Basic [image] Copy Code

Public Function OpositeOfEdge( _
i As Integer _
) As Vertex

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.RepairEdges Method

Triangle.RepairEdges Method
[image]

Repair any Edge links, both ways.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void RepairEdges (
Triangle a
)

Visual Basic [image] Copy Code

Public Sub RepairEdges( _
a As Triangle _
)

Parameters

a

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.ResetIndex Method

Triangle.ResetIndex Method
[image]

Reset the index, indexing gives each triangle an ID unique since construction of the mesh.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static void ResetIndex ()

Visual Basic [image] Copy Code

Public Shared Sub ResetIndex ()

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.SetEdge Method

Triangle.SetEdge Method
[image]

Set the edge by index.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void SetEdge (
int i,
Triangle t
)

Visual Basic [image] Copy Code

Public Sub SetEdge( _
i As Integer, _
t As Triangle _
)

Parameters

i

t

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.SetVertex Method

Triangle.SetVertex Method
[image]

Set the vertex by index.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public void SetVertex (
int i,
Vertex v
)

Visual Basic [image] Copy Code

Public Sub SetVertex( _
i As Integer, _
v As Vertex _
)

Parameters

i

v

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.ToString Method

Triangle.ToString Method
[image]

To string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.VertexAngleRadians Method

Triangle.VertexAngleRadians Method
[image]

Get the angle of a vertex in radians.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double VertexAngleRadians (
int i
)

Visual Basic [image] Copy Code

Public Function VertexAngleRadians( _
i As Integer _
) As Double

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.VertexCosineAngle Method

Triangle.VertexCosineAngle Method
[image]

Get the cosine angle associated with a vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double VertexCosineAngle (
int i
)

Visual Basic [image] Copy Code

Public Function VertexCosineAngle( _
i As Integer _
) As Double

Parameters

i

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.vertexTest Method

Triangle.vertexTest Method
[image]

Vertex sidedness test.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool vertexTest (
Vertex la,
Vertex lb,
Vertex t
)

Visual Basic [image] Copy Code

Protected Function vertexTest( _
la As Vertex, _
lb As Vertex, _
t As Vertex _
) As Boolean

Parameters

la

lb

t

Return Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle Properties

Triangle Properties
[image]

Public Properties

Name | Description
A | Vertex A
AB | Triangle AB shares side AB.
AB_Length | Length of AB, cached and lazy calculated.
Area | Area of the triangle.
B | Vertex B
BC | Triangle BC shares side BC.
BC_Length | Length of BC, cached and lazy calculated.
C | Vertex C
CA | Triangle CA shares side CA.
CA_Length | Length of CA, cached and lazy calculated.
Center | Compute the center
FarthestFromCenter | Farthest distance a point is from center is distance squared.
Index | Index.
RegionCode | Which search region it is in.

Protected Properties

Name | Description
abDet | AB det.
bcDet | BC det.
caDet | CA det.

See Also

Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.A Property

Triangle.A Property
[image]

Vertex A

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex A { get; set; }

Visual Basic [image] Copy Code

Public Property A As Vertex

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.AB Property

Triangle.AB Property
[image]

Triangle AB shares side AB.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle AB { get; set; }

Visual Basic [image] Copy Code

Public Property AB As Triangle

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.AB_Length Property

Triangle.AB_Length Property
[image]

Length of AB, cached and lazy calculated.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double AB_Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AB_Length As Double

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.abDet Property

Triangle.abDet Property
[image]

AB det.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool abDet { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property abDet As Boolean

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Area Property

Triangle.Area Property
[image]

Area of the triangle.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Area { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Area As Double

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.B Property

Triangle.B Property
[image]

Vertex B

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex B { get; set; }

Visual Basic [image] Copy Code

Public Property B As Vertex

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.BC Property

Triangle.BC Property
[image]

Triangle BC shares side BC.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle BC { get; set; }

Visual Basic [image] Copy Code

Public Property BC As Triangle

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.BC_Length Property

Triangle.BC_Length Property
[image]

Length of BC, cached and lazy calculated.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double BC_Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BC_Length As Double

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.bcDet Property

Triangle.bcDet Property
[image]

BC det.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool bcDet { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property bcDet As Boolean

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.C Property

Triangle.C Property
[image]

Vertex C

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex C { get; set; }

Visual Basic [image] Copy Code

Public Property C As Vertex

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.CA Property

Triangle.CA Property
[image]

Triangle CA shares side CA.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Triangle CA { get; set; }

Visual Basic [image] Copy Code

Public Property CA As Triangle

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.CA_Length Property

Triangle.CA_Length Property
[image]

Length of CA, cached and lazy calculated.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double CA_Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CA_Length As Double

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.caDet Property

Triangle.caDet Property
[image]

CA det.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

protected bool caDet { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property caDet As Boolean

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Center Property

Triangle.Center Property
[image]

Compute the center

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex Center { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Center As Vertex

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.FarthestFromCenter Property

Triangle.FarthestFromCenter Property
[image]

Farthest distance a point is from center is distance squared.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double FarthestFromCenter { get; set; }

Visual Basic [image] Copy Code

Public Property FarthestFromCenter As Double

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.Index Property

Triangle.Index Property
[image]

Index.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Triangle.RegionCode Property

Triangle.RegionCode Property
[image]

Which search region it is in.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int RegionCode { get; set; }

Visual Basic [image] Copy Code

Public Property RegionCode As Integer

Property Value

See Also

Triangle Members
Triangle Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ValueFormat Enumeration

ValueFormat Enumeration
[image]

Defines types of data related to a chart axis.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public enum ValueFormat

Visual Basic [image] Copy Code

Public Enum ValueFormat

Members

Member name | Description
DateTime | The data is DateTime values.
Number | The data is numbers.

See Also

MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Class

Vertex Class
[image]

Vertex class

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class Vertex

Visual Basic [image] Copy Code

Public Class Vertex

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.Vertex

See Also

Vertex Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Members

Vertex Members
Constructors Properties Methods
[image]

Vertex class

The following tables list the members exposed by the Vertex type.

Public Constructors

Name | Description
Vertex | Overloaded.

Public Properties

Name | Description
Index | Index of this vertex.
X | X coordinate.
Y | Y coordinate.
Z | Z coordinate.

Public Methods

Name | Description
DeltaSquared | Delta distance squared between this and other vertex t
DeltaSquaredXY | Delta distance squared between this and other vertex t
Distance | The distance between this and t.
DistanceXY | The distance between this and t.
InsideXY | Is this rectangle within the region.
ToString | To string.

See Also

Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Constructor

Vertex Constructor
[image]

Overload List

Name | Description
Vertex () | Vertex default constructor.
Vertex (Double, Double, Double) | Vertex constructor.

See Also

Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Constructor ()

Vertex Constructor ()
See Also
[image]

Vertex default constructor.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Vertex Constructor Overload List
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Constructor (Double, Double, Double)

Vertex Constructor (Double, Double, Double)
See Also
[image]

Vertex constructor.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Vertex (
double x,
double y,
double z
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
z As Double _
)

Parameters

x

y

z

See Also

Vertex Constructor Overload List
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Methods

Vertex Methods
[image]

Public Methods

Name | Description
DeltaSquared | Delta distance squared between this and other vertex t
DeltaSquaredXY | Delta distance squared between this and other vertex t
Distance | The distance between this and t.
DistanceXY | The distance between this and t.
InsideXY | Is this rectangle within the region.
ToString | To string.

See Also

Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.DeltaSquared Method

Vertex.DeltaSquared Method
[image]

Delta distance squared between this and other vertex t

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double DeltaSquared (
Vertex t
)

Visual Basic [image] Copy Code

Public Function DeltaSquared( _
t As Vertex _
) As Double

Parameters

t

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.DeltaSquaredXY Method

Vertex.DeltaSquaredXY Method
[image]

Delta distance squared between this and other vertex t

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double DeltaSquaredXY (
Vertex t
)

Visual Basic [image] Copy Code

Public Function DeltaSquaredXY( _
t As Vertex _
) As Double

Parameters

t

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.Distance Method

Vertex.Distance Method
[image]

The distance between this and t.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Distance (
Vertex t
)

Visual Basic [image] Copy Code

Public Function Distance( _
t As Vertex _
) As Double

Parameters

t

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.DistanceXY Method

Vertex.DistanceXY Method
[image]

The distance between this and t.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double DistanceXY (
Vertex t
)

Visual Basic [image] Copy Code

Public Function DistanceXY( _
t As Vertex _
) As Double

Parameters

t

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.InsideXY Method

Vertex.InsideXY Method
[image]

Is this rectangle within the region.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool InsideXY (
Rect region
)

Visual Basic [image] Copy Code

Public Function InsideXY( _
region As Rect _
) As Boolean

Parameters

region

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.ToString Method

Vertex.ToString Method
[image]

To string.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex Properties

Vertex Properties
[image]

Public Properties

Name | Description
Index | Index of this vertex.
X | X coordinate.
Y | Y coordinate.
Z | Z coordinate.

See Also

Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.Index Property

Vertex.Index Property
[image]

Index of this vertex.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.X Property

Vertex.X Property
[image]

X coordinate.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.Y Property

Vertex.Y Property
[image]

Y coordinate.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.Vertex.Z Property

Vertex.Z Property
[image]

Z coordinate.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double Z { get; set; }

Visual Basic [image] Copy Code

Public Property Z As Double

Property Value

See Also

Vertex Members
Vertex Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Contains methods that can help you serialize and deserialize charts to and from XML documents.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class XmlSerializationContext

Visual Basic [image] Copy Code

Public Class XmlSerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Charting.Wpf.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize charts to and from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadBrushCollection | Reads a collection of brushes from the element with the specified name and the specified parent.
ReadBrushList | Reads a list of brushes from the specified element with the specified parent.
ReadByte | Reads a byte value from the specified element with the specified parent.
ReadChar | Reads a char value from the specified element with the specified parent.
ReadColor | Reads a System.Windows.Media.Color object from the specified element with the specified parent.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value from the specified element with the specified parent.
ReadDouble | Reads a double value from the specified element with the specified parent.
ReadDoubleArray | Reads an array with double values from the specified element with the specified subelements and the specified parent.
ReadDoubleCollection | Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.
ReadEffect | Reads a System.Windows.Media.Effects.Effect value from the specified element with the specified parent.
ReadEnum | Overloaded. Reads an enumeration.
ReadFloat | Overloaded. Reads a float value.
ReadFontFamily | Reads a System.Windows.Media.FontFamily value from the specified element with the specified parent.
ReadFontStyle | Reads a FontStyle enumeration member from the specified element with the specified parent.
ReadFontWeight | Reads a System.Windows.FontWeight structure value from the specified element with the specified parent.
ReadGradientStopCollection | Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.
ReadInt | Overloaded. Reads an integer value.
ReadLong | Reads a long value from the specified element with the specified parent.
ReadObject | Reads an object value from the specified element with the specified parent.
ReadPen | Reads a System.Windows.Media.Pen value from the specified element with the specified parent.
ReadPoint | Overloaded. Reads a System.Windows.Point value.
ReadPointCollection | Reads a System.Windows.Media.PointCollection value from the specified element with the specified parent.
ReadRectangle | Reads a System.Windows.Shapes.Rectangle value from the specified element with the specified parent.
ReadSByte | Reads an 8-bit signed integer value from the specified element with the specified parent.
ReadShort | Reads a short value from the specified element with the specified parent.
ReadSize | Reads a System.Windows.Size value from the specified element with the specified parent.
ReadStream | Reads a System.IO.Stream value from the specified element with the specified parent.
ReadString | Overloaded. Reads a string value.
ReadThickness | Reads a System.Windows.Thickness value from the specified element with the specified parent.
ReadUInt | Reads an unsigned integer value from the specified element with the specified parent.
ReadULong | Reads an unsigned long value from the specified element with the specified parent.
ReadUShort | Reads an unsigned short value from the specified element with the specified parent.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes the specified brush as an XML element. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushCollection | Writes the specified collection of brushes under the specified name with the specified Xml parent.
WriteBrushList | Writes the specified list of brushes as a XML element.
WriteByte | Writes a byte value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteChar | Writes a char value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteColor | Writes a System.Windows.Media.Color value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteColorArray | Writes an array of System.Windows.Media.Color objects as a System.Xml.XmlElement object with the the specified name and the specified subelements and the specified parent.
WriteDecimal | Writes a decimal value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteDouble | Writes a double value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteDoubleArray | Writes the specified double array as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteDoubleCollection | Writes the specified DoubleCollection as a XML node with the specified name and with the specified parent element.
WriteEffect | Writes the specified visual effect with the specified element name under the specified parent element.
WriteEnum | Writes the specified enum value.
WriteFontFamily | Writes a System.Windows.Media.FontFamily value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteFontStyle | Writes a System.Windows.FontStyle value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteFontWeight | Writes a System.Windows.FontWeight value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteGradientStop | Writes a System.Windows.Media.GradientStop value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteGradientStopCollection | Writes a WPF GradientStopCollection as an XmlElement object with the specified name and the specified parent.
WriteInt | Writes an int value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteLong | Writes a long value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteObject | Writes a System.Object as a System.Xml.XmlElement with the specified name and the specified parent.
WritePen | Writes a System.Windows.Media.Pen value as a System.Xml.XmlElement object with the specified name and the specified parent.
WritePoint | Writes a System.Windows.Point with the specified name.
WritePointCollection | Writes the specified System.Windows.Media.PointCollection as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteRectangle | Writes a System.Drawing.Rectangle as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteSByte | Write a 8-bit signed integer value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteShort | Writes a short value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteSize | Writes a System.Windows.Size value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteStream | Writes the specified System.IO.Stream value as a System.Xml.XmlElement object with the specified name and the specified parent..
WriteString | Writes a string value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteThickness | Writes a System.Windows.Thickness value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteUInt | Writes an unsigned integer value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteULong | Writes an unsigned long value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteUShort | Writes an unsigned short value as a System.Xml.XmlElement object with the specified name and the specified parent.

See Also

XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Fields

XmlSerializationContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.LatestFormat Field

XmlSerializationContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Overload List

Name | Description
XmlSerializationContext (Chart, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Chart, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Constructor (Chart, Int32, XmlDocument)

XmlSerializationContext Constructor (Chart, Int32, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
int fileVersion,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

chart

The Chart object this class will operate on.

fileVersion

The file version of the file being deserialized.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Constructor (Chart, XmlDocument)

XmlSerializationContext Constructor (Chart, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
document As XmlDocument _
)

Parameters

chart

The Chart object this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadBrushCollection | Reads a collection of brushes from the element with the specified name and the specified parent.
ReadBrushList | Reads a list of brushes from the specified element with the specified parent.
ReadByte | Reads a byte value from the specified element with the specified parent.
ReadChar | Reads a char value from the specified element with the specified parent.
ReadColor | Reads a System.Windows.Media.Color object from the specified element with the specified parent.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value from the specified element with the specified parent.
ReadDouble | Reads a double value from the specified element with the specified parent.
ReadDoubleArray | Reads an array with double values from the specified element with the specified subelements and the specified parent.
ReadDoubleCollection | Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.
ReadEffect | Reads a System.Windows.Media.Effects.Effect value from the specified element with the specified parent.
ReadEnum | Overloaded. Reads an enumeration.
ReadFloat | Overloaded. Reads a float value.
ReadFontFamily | Reads a System.Windows.Media.FontFamily value from the specified element with the specified parent.
ReadFontStyle | Reads a FontStyle enumeration member from the specified element with the specified parent.
ReadFontWeight | Reads a System.Windows.FontWeight structure value from the specified element with the specified parent.
ReadGradientStopCollection | Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.
ReadInt | Overloaded. Reads an integer value.
ReadLong | Reads a long value from the specified element with the specified parent.
ReadObject | Reads an object value from the specified element with the specified parent.
ReadPen | Reads a System.Windows.Media.Pen value from the specified element with the specified parent.
ReadPoint | Overloaded. Reads a System.Windows.Point value.
ReadPointCollection | Reads a System.Windows.Media.PointCollection value from the specified element with the specified parent.
ReadRectangle | Reads a System.Windows.Shapes.Rectangle value from the specified element with the specified parent.
ReadSByte | Reads an 8-bit signed integer value from the specified element with the specified parent.
ReadShort | Reads a short value from the specified element with the specified parent.
ReadSize | Reads a System.Windows.Size value from the specified element with the specified parent.
ReadStream | Reads a System.IO.Stream value from the specified element with the specified parent.
ReadString | Overloaded. Reads a string value.
ReadThickness | Reads a System.Windows.Thickness value from the specified element with the specified parent.
ReadUInt | Reads an unsigned integer value from the specified element with the specified parent.
ReadULong | Reads an unsigned long value from the specified element with the specified parent.
ReadUShort | Reads an unsigned short value from the specified element with the specified parent.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes the specified brush as an XML element. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushCollection | Writes the specified collection of brushes under the specified name with the specified Xml parent.
WriteBrushList | Writes the specified list of brushes as a XML element.
WriteByte | Writes a byte value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteChar | Writes a char value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteColor | Writes a System.Windows.Media.Color value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteColorArray | Writes an array of System.Windows.Media.Color objects as a System.Xml.XmlElement object with the the specified name and the specified subelements and the specified parent.
WriteDecimal | Writes a decimal value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteDouble | Writes a double value as a System.Xml.XmlElement object with the the specified name and the specified parent.
WriteDoubleArray | Writes the specified double array as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteDoubleCollection | Writes the specified DoubleCollection as a XML node with the specified name and with the specified parent element.
WriteEffect | Writes the specified visual effect with the specified element name under the specified parent element.
WriteEnum | Writes the specified enum value.
WriteFontFamily | Writes a System.Windows.Media.FontFamily value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteFontStyle | Writes a System.Windows.FontStyle value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteFontWeight | Writes a System.Windows.FontWeight value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteGradientStop | Writes a System.Windows.Media.GradientStop value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteGradientStopCollection | Writes a WPF GradientStopCollection as an XmlElement object with the specified name and the specified parent.
WriteInt | Writes an int value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteLong | Writes a long value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteObject | Writes a System.Object as a System.Xml.XmlElement with the specified name and the specified parent.
WritePen | Writes a System.Windows.Media.Pen value as a System.Xml.XmlElement object with the specified name and the specified parent.
WritePoint | Writes a System.Windows.Point with the specified name.
WritePointCollection | Writes the specified System.Windows.Media.PointCollection as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteRectangle | Writes a System.Drawing.Rectangle as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteSByte | Write a 8-bit signed integer value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteShort | Writes a short value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteSize | Writes a System.Windows.Size value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteStream | Writes the specified System.IO.Stream value as a System.Xml.XmlElement object with the specified name and the specified parent..
WriteString | Writes a string value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteThickness | Writes a System.Windows.Thickness value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteUInt | Writes an unsigned integer value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteULong | Writes an unsigned long value as a System.Xml.XmlElement object with the specified name and the specified parent.
WriteUShort | Writes an unsigned short value as a System.Xml.XmlElement object with the specified name and the specified parent.

See Also

XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlNode) | Adds a new child node with the specified name to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.AddChildElement Method (String, XmlElement)

XmlSerializationContext.AddChildElement Method (String, XmlElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName

A string that specifies the name of the child to add.

parentElement

A System.Xml.XmlElement class that is the parent of the new node.

Return Value

The newly created System.Xml.XmlElement node.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.AddChildElement Method (String, XmlElement, String)

XmlSerializationContext.AddChildElement Method (String, XmlElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName

A string that specifies the name of the new element.

parentElement

A System.Xml.XmlElement object that is the parent of the new element.

innerText

A string that represents the initial value of the new XmlElement.

Return Value

The newly created System.Xml.XmlElement object.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.AddChildElement Method (String, XmlNode)

XmlSerializationContext.AddChildElement Method (String, XmlNode)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlNode parentNode
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentNode As XmlNode _
) As XmlElement

Parameters

elementName

The name of the new element.

parentNode

A System.Xml.XmlNode object that is the parent of the new element.

Return Value

The newly created System.Xml.XmlElement object.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName

The name of the element to read.

parentElement

A System.Xml.XmlElement object that is parent of the element to read.

Return Value

The bool value that was deserialized.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

The name of the element to read.

parentElement

A System.Xml.XmlElement object that is parent of the element to read.

defaultValue

The value that is returned if parsing the element fails.

Return Value

The bool value that is deserialized or default value if deserialization fails.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBrush Method

XmlSerializationContext.ReadBrush Method
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Media.Brush object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBrushCollection Method

XmlSerializationContext.ReadBrushCollection Method
[image]

Reads a collection of brushes from the element with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public BrushCollection ReadBrushCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrushCollection( _
elementName As String, _
parentElement As XmlElement _
) As BrushCollection

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element.

Return Value

The collection of the deserialized brushes.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadBrushList Method

XmlSerializationContext.ReadBrushList Method
[image]

Reads a list of brushes from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Brush> ReadBrushList (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrushList( _
elementName As String, _
parentElement As XmlElement _
) As List(Of Brush)

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The deserialized list with brushes.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method
[image]

Reads a byte value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method
[image]

Reads a char value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized char value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method
[image]

Reads a System.Windows.Media.Color object from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized Color value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method
[image]

Reads a decimal value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized decimal value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method
[image]

Reads a double value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized double value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadDoubleArray Method

XmlSerializationContext.ReadDoubleArray Method
[image]

Reads an array with double values from the specified element with the specified subelements and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double[] ReadDoubleArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Double()

Parameters

elementName

The name of the element to read.

subElementName

The name of the subelements to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized array with double values.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadDoubleCollection Method

XmlSerializationContext.ReadDoubleCollection Method
[image]

Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public DoubleCollection ReadDoubleCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleCollection( _
elementName As String, _
parentElement As XmlElement _
) As DoubleCollection

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized DoubleCollection value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadEffect Method

XmlSerializationContext.ReadEffect Method
[image]

Reads a System.Windows.Media.Effects.Effect value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Effect ReadEffect (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XmlElement _
) As Effect

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element.

Return Value

The System.Windows.Media.Effects.Effect object that was read.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method
[image]

Reads an enumeration.

Overload List

Name | Description
XmlSerializationContext.ReadEnum (String, XmlElement) | Reads an enum value with the specified name.
XmlSerializationContext.ReadEnum (String, XmlElement, Object) | Reads an enum value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadEnum Method (String, XmlElement)

XmlSerializationContext.ReadEnum Method (String, XmlElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadEnum Method (String, XmlElement, Object)

XmlSerializationContext.ReadEnum Method (String, XmlElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method
[image]

Reads a float value.

Overload List

Name | Description
XmlSerializationContext.ReadFloat (String, XmlElement) | Reads a double value with the specified name.
XmlSerializationContext.ReadFloat (String, XmlElement, Single) | Reads a double value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFloat Method (String, XmlElement)

XmlSerializationContext.ReadFloat Method (String, XmlElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFloat Method (String, XmlElement, Single)

XmlSerializationContext.ReadFloat Method (String, XmlElement, Single)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XmlElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Single _
) As Double

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFontFamily Method

XmlSerializationContext.ReadFontFamily Method
[image]

Reads a System.Windows.Media.FontFamily value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public FontFamily ReadFontFamily (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontFamily( _
elementName As String, _
parentElement As XmlElement _
) As FontFamily

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Media.FontFamily value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFontStyle Method

XmlSerializationContext.ReadFontStyle Method
[image]

Reads a FontStyle enumeration member from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ReadFontStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontStyle( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized enumeration member value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadFontWeight Method

XmlSerializationContext.ReadFontWeight Method
[image]

Reads a System.Windows.FontWeight structure value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ReadFontWeight (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontWeight( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

Remarks

The deserialized System.Windows.FontWeight structure value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadGradientStopCollection Method

XmlSerializationContext.ReadGradientStopCollection Method
[image]

Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public GradientStopCollection ReadGradientStopCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadGradientStopCollection( _
elementName As String, _
parentElement As XmlElement _
) As GradientStopCollection

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The deserialized System.Windows.Media.GradientStopCollection value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method
[image]

Reads an integer value.

Overload List

Name | Description
XmlSerializationContext.ReadInt (String, XmlElement) | Reads an integer value with the specified name.
XmlSerializationContext.ReadInt (String, XmlElement, Int32) | Reads an integer value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadInt Method (String, XmlElement)

XmlSerializationContext.ReadInt Method (String, XmlElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadInt Method (String, XmlElement, Int32)

XmlSerializationContext.ReadInt Method (String, XmlElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value returned if the specified element is not found.

Return Value

See Also

ReadInt Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method
[image]

Reads a long value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized long value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadObject Method

XmlSerializationContext.ReadObject Method
[image]

Reads an object value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized object value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadPen Method

XmlSerializationContext.ReadPen Method
[image]

Reads a System.Windows.Media.Pen value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Media.Pen value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadPoint Method

XmlSerializationContext.ReadPoint Method
[image]

Reads a System.Windows.Point value.

Overload List

Name | Description
XmlSerializationContext.ReadPoint (String, XmlElement) | Reads a Point object with the specified name.
XmlSerializationContext.ReadPoint (XmlElement) | Reads a PointF object from the specified element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadPoint Method (String, XmlElement)

XmlSerializationContext.ReadPoint Method (String, XmlElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point ReadPoint (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
elementName As String, _
parentElement As XmlElement _
) As Point

Parameters

elementName

parentElement

Return Value

See Also

ReadPoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadPoint Method (XmlElement)

XmlSerializationContext.ReadPoint Method (XmlElement)
See Also
[image]

Reads a PointF object from the specified element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Point ReadPoint (
XmlElement element
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
element As XmlElement _
) As Point

Parameters

element

Return Value

See Also

ReadPoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadPointCollection Method

XmlSerializationContext.ReadPointCollection Method
[image]

Reads a System.Windows.Media.PointCollection value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public PointCollection ReadPointCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection( _
elementName As String, _
parentElement As XmlElement _
) As PointCollection

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Media.PointCollection value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadRectangle Method

XmlSerializationContext.ReadRectangle Method
[image]

Reads a System.Windows.Shapes.Rectangle value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Rect ReadRectangle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangle( _
elementName As String, _
parentElement As XmlElement _
) As Rect

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The deserialized System.Windows.Shapes.Rectangle value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method
[image]

Reads an 8-bit signed integer value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized 8-bit signed integer value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method
[image]

Reads a short value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized short value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadSize Method

XmlSerializationContext.ReadSize Method
[image]

Reads a System.Windows.Size value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Size ReadSize (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSize( _
elementName As String, _
parentElement As XmlElement _
) As Size

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Size value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method
[image]

Reads a System.IO.Stream value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.IO.Stream value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method
[image]

Reads a string value.

Overload List

Name | Description
XmlSerializationContext.ReadString (String, XmlElement) | Reads a string value with the specified name.
XmlSerializationContext.ReadString (String, XmlElement, String) | Reads a string value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadString Method (String, XmlElement)

XmlSerializationContext.ReadString Method (String, XmlElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName

parentElement

Return Value

See Also

ReadString Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadString Method (String, XmlElement, String)

XmlSerializationContext.ReadString Method (String, XmlElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As String _
) As String

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadString Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadThickness Method

XmlSerializationContext.ReadThickness Method
[image]

Reads a System.Windows.Thickness value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XmlElement _
) As Thickness

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized System.Windows.Thickness value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method
[image]

Reads an unsigned integer value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized unsigned integer value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method
[image]

Reads an unsigned long value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized unsigned long value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method
[image]

Reads an unsigned short value from the specified element with the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName

The name of the element to read.

parentElement

The XML parent of the element to read.

Return Value

The deserialized unsigned short value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.SelectNode Method

XmlSerializationContext.SelectNode Method
[image]

Returns the child node with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement SelectNode (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNode( _
parentElement As XmlElement, _
name As String _
) As XmlElement

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.SelectNodes Method

XmlSerializationContext.SelectNodes Method
[image]

Returns the child nodes with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlNodeList SelectNodes (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNodes( _
parentElement As XmlElement, _
name As String _
) As XmlNodeList

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child nodes.

Return Value

An XmlNodeList containing the found child nodes.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool boolValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

boolValue

The bool value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteBrush Method

XmlSerializationContext.WriteBrush Method
[image]

Writes the specified brush as an XML element. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush

The Brush to write.

elementName

The name of the new XML element.

parentElement

The parent of the new XML element.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteBrushCollection Method

XmlSerializationContext.WriteBrushCollection Method
[image]

Writes the specified collection of brushes under the specified name with the specified Xml parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBrushCollection (
BrushCollection brushes,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrushCollection( _
brushes As BrushCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brushes

The collection to write.

elementName

The name of the new element.

parentElement

The parent of the new node.

Return Value

The newly created element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteBrushList Method

XmlSerializationContext.WriteBrushList Method
[image]

Writes the specified list of brushes as a XML element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBrushList (
List<Brush> brushes,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrushList( _
brushes As List(Of Brush), _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brushes

The PointCollection to write.

elementName

The name of the new XML element.

parentElement

The parent of the new XML element.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method
[image]

Writes a byte value as a System.Xml.XmlElement object with the the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

The byte value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method
[image]

Writes a char value as a System.Xml.XmlElement object with the the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char charValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

charValue

The char value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method
[image]

Writes a System.Windows.Media.Color value as a System.Xml.XmlElement object with the the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color

The System.Windows.Media.Color value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method
[image]

Writes an array of System.Windows.Media.Color objects as a System.Xml.XmlElement object with the the specified name and the specified subelements and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

A list with System.Windows.Media.Color objects to write.

elementName

The name of the new element.

subElementName

The name of the sub element that holds the separate Color elements.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method
[image]

Writes a decimal value as a System.Xml.XmlElement object with the the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal decimalValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

decimalValue

The decimal value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method
[image]

Writes a double value as a System.Xml.XmlElement object with the the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double doubleValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

doubleValue

The double value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteDoubleArray Method

XmlSerializationContext.WriteDoubleArray Method
[image]

Writes the specified double array as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDoubleArray (
double[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleArray( _
array() As Double, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

The double array to write.

elementName

The name of the new element.

subElementName

The name of the subelements that will hold the double values.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteDoubleCollection Method

XmlSerializationContext.WriteDoubleCollection Method
[image]

Writes the specified DoubleCollection as a XML node with the specified name and with the specified parent element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDoubleCollection (
DoubleCollection array,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleCollection( _
array As DoubleCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

The DoubleCollection to write.

elementName

The name of the new XML element.

parentElement

The parent of the new XML element.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteEffect Method

XmlSerializationContext.WriteEffect Method
[image]

Writes the specified visual effect with the specified element name under the specified parent element.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteEffect (
Effect effect,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As Effect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

effect

The visual effect to write.

elementName

The name of the element for this effect.

parentElement

The parent element of this effect.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object enumValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

enumValue

The enum value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteFontFamily Method

XmlSerializationContext.WriteFontFamily Method
[image]

Writes a System.Windows.Media.FontFamily value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontFamily (
FontFamily fontFamily,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontFamily( _
fontFamily As FontFamily, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

fontFamily

The System.Windows.Media.FontFamily value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteFontStyle Method

XmlSerializationContext.WriteFontStyle Method
[image]

Writes a System.Windows.FontStyle value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontStyle (
Object fontValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontStyle( _
fontValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

fontValue

The FontStyle value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteFontWeight Method

XmlSerializationContext.WriteFontWeight Method
[image]

Writes a System.Windows.FontWeight value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontWeight (
Object fontValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontWeight( _
fontValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

fontValue

The FontWeight value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteGradientStop Method

XmlSerializationContext.WriteGradientStop Method
[image]

Writes a System.Windows.Media.GradientStop value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteGradientStop (
GradientStop stop,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGradientStop( _
stop As GradientStop, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stop

The System.Windows.Media.GradientStop to write.

elementName

The name of the XML element to write.

parentElement

The parent of the new XML element.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteGradientStopCollection Method

XmlSerializationContext.WriteGradientStopCollection Method
[image]

Writes a WPF GradientStopCollection as an XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteGradientStopCollection (
GradientStopCollection stops,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGradientStopCollection( _
stops As GradientStopCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stops

The GradientStopCollection to write.

elementName

The name of the XML element that will be used for this GradientStop collection.

parentElement

The parent node of the XML element that will represent the GradientStop collection.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method
[image]

Writes an int value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int intValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

intValue

The int value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method
[image]

Writes a long value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long longValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

longValue

The long value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteObject Method

XmlSerializationContext.WriteObject Method
[image]

Writes a System.Object as a System.Xml.XmlElement with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object objectValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

objectValue

The System.Object to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WritePen Method

XmlSerializationContext.WritePen Method
[image]

Writes a System.Windows.Media.Pen value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen

The Pen value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WritePoint Method

XmlSerializationContext.WritePoint Method
[image]

Writes a System.Windows.Point with the specified name.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePoint (
Point point,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
point As Point, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

point

The System.Windows.Point value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WritePointCollection Method

XmlSerializationContext.WritePointCollection Method
[image]

Writes the specified System.Windows.Media.PointCollection as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePointCollection (
PointCollection points,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection( _
points As PointCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

points

The PointCollection to write.

elementName

The name of the new XML element.

parentElement

The parent of the new XML element.

Return Value

The new XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteRectangle Method

XmlSerializationContext.WriteRectangle Method
[image]

Writes a System.Drawing.Rectangle as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteRectangle (
Rect rectangle,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangle( _
rectangle As Rect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

rectangle

The System.Drawing.Rectangle to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method
[image]

Write a 8-bit signed integer value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method
[image]

Writes a short value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short shortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shortValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteSize Method

XmlSerializationContext.WriteSize Method
[image]

Writes a System.Windows.Size value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSize (
Size size,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSize( _
size As Size, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

size

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method
[image]

Writes the specified System.IO.Stream value as a System.Xml.XmlElement object with the specified name and the specified parent..

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream

The Stream value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method
[image]

Writes a string value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string stringValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteThickness Method

XmlSerializationContext.WriteThickness Method
[image]

Writes a System.Windows.Thickness value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteThickness (
Thickness thickness,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

thickness

The Thickness value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method
[image]

Writes an unsigned integer value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint uintValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

uintValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method
[image]

Writes an unsigned long value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong ulongValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ulongValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method
[image]

Writes an unsigned short value as a System.Xml.XmlElement object with the specified name and the specified parent.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort ushortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ushortValue

The value to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.XmlElement.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.BaseURI Property

XmlSerializationContext.BaseURI Property
[image]

Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public string BaseURI { get; set; }

Visual Basic [image] Copy Code

Public Property BaseURI As String

Property Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.FileVersion Property

XmlSerializationContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs Class

ZoomChangedArgs Class
[image]

Provides arguments for ZoomChanged events.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public class ZoomChangedArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ZoomChangedArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.Wpf.ZoomChangedArgs

See Also

ZoomChangedArgs Members
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs Members

ZoomChangedArgs Members
Constructors Properties
[image]

Provides arguments for ZoomChanged events.

The following tables list the members exposed by the ZoomChangedArgs type.

Public Constructors

Name | Description
ZoomChangedArgs | Initializes a new instance of the ZoomChangedArgs class.

Public Properties

Name | Description
EndNum | Gets or sets the end number for the zoom.
EndNum2 | Gets or sets the end number on the Y2-axis for the zoom.
StartNum | The number, where zooming starts.
StartNum2 | Gets or sets the start number on the Y2-axis for the zoom.

See Also

ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs Constructor

ZoomChangedArgs Constructor
[image]

Initializes a new instance of the ZoomChangedArgs class.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public ZoomChangedArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs Properties

ZoomChangedArgs Properties
[image]

Public Properties

Name | Description
EndNum | Gets or sets the end number for the zoom.
EndNum2 | Gets or sets the end number on the Y2-axis for the zoom.
StartNum | The number, where zooming starts.
StartNum2 | Gets or sets the start number on the Y2-axis for the zoom.

See Also

ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs.EndNum Property

ZoomChangedArgs.EndNum Property
[image]

Gets or sets the end number for the zoom.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Double> EndNum { get; set; }

Visual Basic [image] Copy Code

Public Property EndNum As List(Of Double)

Property Value

See Also

ZoomChangedArgs Members
ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs.EndNum2 Property

ZoomChangedArgs.EndNum2 Property
[image]

Gets or sets the end number on the Y2-axis for the zoom.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Double> EndNum2 { get; set; }

Visual Basic [image] Copy Code

Public Property EndNum2 As List(Of Double)

Property Value

See Also

ZoomChangedArgs Members
ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs.StartNum Property

ZoomChangedArgs.StartNum Property
[image]

The number, where zooming starts.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Double> StartNum { get; set; }

Visual Basic [image] Copy Code

Public Property StartNum As List(Of Double)

Property Value

See Also

ZoomChangedArgs Members
ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.Charting.Wpf.ZoomChangedArgs.StartNum2 Property

ZoomChangedArgs.StartNum2 Property
[image]

Gets or sets the start number on the Y2-axis for the zoom.

Namespace: MindFusion.Charting.Wpf
Assembly: MindFusion.Charting.Wpf

Syntax

C# [image] Copy Code

public List<Double> StartNum2 { get; set; }

Visual Basic [image] Copy Code

Public Property StartNum2 As List(Of Double)

Property Value

See Also

ZoomChangedArgs Members
ZoomChangedArgs Class
MindFusion.Charting.Wpf Namespace


MindFusion.DataViews.Wpf Namespace

MindFusion.DataViews.Wpf Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
ActionEventArgs | Contains the arguments passed to routed events related to activities and resource allocations.
ActionValidationEventArgs | Contains the arguments passed to validation routed event related to activities and resource allocations.
Activity | A model class that represents an activity instance in ActivityChart or ResourceChart.
ActivityChart | Displays tasks over a period of time and the relationships between those tasks.
ActivityPresenter | Represents an activity in an ActivityChart.
ActivityState | Encapsulates the state of an activity for subsequent undo operations.
AllocationPresenter | Represents a resource allocation in a ResourceChart.
BaseChart | The base class for all data views.
BasePresenter | The base class for activity and allocation presenters.
BasePresenterEventArgs | Contains the arguments passed to handlers of base presenter-related events.
BoolColumn | A column in a DataGrid which displays boolean values.
BoolToVisibilityConverter | Implements bidirectional bool to Visibility conversion.
ChangeItemCommand | Handles undo / redo of property changes.
ChoiceColumn | A column in a DataGrid which displays enumeration values.
ColumnCreatingEventArgs | Contains the arguments passed to handlers of the ColumnCreating event.
ColumnHeader | Represents the column header of a DataGrid.
Command | Represents an action that changes the ViewModel and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
CornerRadiusConverter | Converts double values to CornerRadius.
CreateActivityCommand | Implements creation of new activities in the underlying ViewModel.
CreateDependencyCommand | Implements creation of new dependencies in the underlying ViewModel.
CreateResourceAllocationCommand | Implements creation of new allocations in the underlying ViewModel.
CreateResourceCommand | Implements creation of new resources in the underlying ViewModel.
DataGrid | Displays data in a customizable grid.
DataGridVisibleAttribute | Specifies whether a property should be displayed in a DataGrid.
DateChangedEventArgs | Contains argumens passed to event handlers related to date changes.
DateTimeColumn | A column in a DataGrid which displays DateTime values.
DependenciesOverlay | Represents a container for the dependencies in an ActivityChart.
Dependency | A simple built-in implementation of the IDependency interface.
DependencyEventArgs | Contains the arguments passed to handlers of dependency-related events.
DependencyPopupContent | The content of the popup displayed during interactive creation or modification of dependencies in an ActivityChart control.
DependencyPresenter | Represents a dependency link between two activities in an ActivityChart.
DependencyPresenterEventArgs | Contains the arguments passed to handlers of dependency presenter-related events.
DependencyState | Encapsulates the state of a dependency in the ViewModel.
DrillValidationRoutedEventArgs | Contains the arguments passed to validation routed event related related to drilling in and out.
Extensions | Provides helper methods to various classes in the ViewModel.
GridCell | Represents a cell in a DataGrid.
GridColumn | Represents a column in a DataGrid.
GridRow | Represents a row in a DataGrid.
HeaderColumn | A special grid column used to hold the headers of the grid rows.
HeadersPresenter | The headers container in a DataGrid.
NumericColumn | A column in a DataGrid which displays numeric values.
ProjectEventArgs | Contains the arguments passed to event handlers related to the view model.
ProjectMouseEventArgs | Contains the arguments passed to mouse event handlers related to the view model.
ProjectValidationEventArgs | Contains the arguments passed to validation event handlers related to the view model.
RemoveActivityCommand | Implements removal of activities from the underlying ViewModel.
RemoveDependencyCommand | Implements removal of dependencies from the underlying ViewModel.
RemoveResourceAllocationCommand | Implements removal of resource allocations from the underlying ViewModel.
RemoveResourceCommand | Implements removal of activities from the underlying ViewModel.
Resource | A model class that represents a resource instance in resource charts.
ResourceAllocation | A model class that represents a resource allocation in activity or resource charts.
ResourceAllocationState | Encapsulates the state of a resource allocation for subsequent undo operations.
ResourceChart | Displays resource allocation for tasks over a period of time.
ResourceState | Encapsulates the state of a resource for subsequent undo operations.
RowHeader | Represents the header cell of a row in a DataGrid.
ScheduleColumn | A column in a DataGrid which displays activities or resource allocations.
ScheduleColumnHeader | Represents the ColumnHeader of a ScheduleColumn in a TreeGrid.
ScheduleGrid | A tree grid that can display activities and resource allocations.
ScheduleGridCell | Represents a cell in a ScheduleGrid.
ScheduleGridRow | Represents a row in a ScheduleGrid.
SchedulePopupContent | The content of the popup displayed during interactive creation or modification of items in BaseChart-derived controls.
ScheduleRow | Represents a viewer in a ScheduleColumn.
ScheduleRowPanel | A custom panel used to arrange activities and resource allocations in ScheduleRow objects.
SortedObservableCollection(T) | Represents a generic ObservableCollection with sorted items.
TextColumn | A column in a DataGrid which displays values, which do not have dedicated column.
ThicknessValueConverter | Converts double values to Thickness.
TimelineHeader | Represents a panel-like control, which displays up to three synchronous timelines each with different time resolution.
TimelineSettings | Encapsulates settings for a timeline in a ScheduleColumnHeader.
TimeRange | Represents a time range with maximum length of one day. The range is defined by two TimeSpan instances.
TimeRangeCollection | Represents a sorted observable collection of TimeRange objects, which are merged in their time spans overlap.
TreeGrid | A grid that can display hierarchical data.
TreeGridVirtualPanel | A virtualizing panel for the TreeGrid class.
TreeNode | Represents an item in a TreeGrid control.
TypeActivator | Represents an IActivator that creates objects from a type through reflection.
UndoEventArgs | Contains the arguments passed to the ActionUndone and ActionRedone event handlers.
UndoState | Encapsulates the state of an object for subsequent undo operations.

Interfaces

Interface | Description
IActivator | Represents an object that can be used to created other objects.
IActivityViewModel | Represents an activity in the ViewModel.
IDependency | Represents a dependency between two objects.
IDependencyViewModel | Represents a dependency in the ViewModel.
IItemViewModel | The base interface for activity and resource view models.
IProjectViewModel | Represents a project in the ViewModel.
IResourceAllocationViewModel | Represents the allocation of a resource for a specific activity.
IResourceViewModel | Represents an resource in the ViewModel.
IUndoable | Represents an object which can save and restore its state.

Delegates

Delegate | Description
ActionEventHandler | Represents the method that will handle routed events related to activities or resource allocations.
ActionValidationEventHandler | Represents the method that will handle validation routed events related to activities or resource allocations.
DrillValidationRoutedEventHandler | Represents the method that will handle validation routed events related to drilling in and out.

Enumerations

Enumeration | Description
Action | Indicates a user action performed on an item.
DependencyType | Specifies the type of a dependency.
GridColumnBindingTarget | Specifies the binding type in the ApplyBinding method.
PopupPlacement | Specifies the placement target for item and dependency popups.
ScheduleMode | Indicates how an activity behaves when its children are modified.
TimeUnit | Specifies time resolution.


MindFusion.DataViews.Wpf.Action Enumeration

Action Enumeration
[image]

Indicates a user action performed on an item.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum Action

Visual Basic [image] Copy Code

Public Enum Action

Members

Member name | Description
Move | Specifies that the user moves the item.
None | Specifies no action.
ResizeEnd | Specifies that the user modifies the end of the item.
ResizeProgress | Specifies that the user modifies the progress of the item.
ResizeStart | Specifies that the user modifies the start of the item.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs Class

ActionEventArgs Class
[image]

Contains the arguments passed to routed events related to activities and resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ActionEventArgs : RoutedEventArgs

Visual Basic [image] Copy Code

Public Class ActionEventArgs
Inherits RoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
MindFusion.DataViews.Wpf.ActionEventArgs
MindFusion.DataViews.Wpf.ActionValidationEventArgs

See Also

ActionEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs Members

ActionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to routed events related to activities and resource allocations.

The following tables list the members exposed by the ActionEventArgs type.

Public Constructors

Name | Description
ActionEventArgs | Initializes a new instance of the ActionEventArgs class.

Public Properties

Name | Description
Action | Gets or sets the action related to the event.
Item | Gets or sets the activity or resource allocation related to the event.

See Also

ActionEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs Constructor

ActionEventArgs Constructor
[image]

Initializes a new instance of the ActionEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ActionEventArgs (
Object item,
Action action
)

Visual Basic [image] Copy Code

Public New ( _
item As Object, _
action As Action _
)

Parameters

item

The related activity or resource allocation.

action

The action related to the event.

See Also

ActionEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs Properties

ActionEventArgs Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the action related to the event.
Item | Gets or sets the activity or resource allocation related to the event.

See Also

ActionEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs.Action Property

ActionEventArgs.Action Property
[image]

Gets or sets the action related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Action Action { get; set; }

Visual Basic [image] Copy Code

Public Property Action As Action

Property Value

A member of the Action enumeration.

See Also

ActionEventArgs Members
ActionEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventArgs.Item Property

ActionEventArgs.Item Property
[image]

Gets or sets the activity or resource allocation related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As Object

Property Value

A reference to a IResourceAllocationViewModel or a IActivityViewModel depending on the object being modified.

See Also

ActionEventArgs Members
ActionEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionEventHandler Delegate

ActionEventHandler Delegate
[image]

Represents the method that will handle routed events related to activities or resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public delegate void ActionEventHandler (
Object sender,
ActionEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub ActionEventHandler ( _
sender As Object, _
e As ActionEventArgs _
)

Parameters

sender

The object where the event handler is attached.

e

The event data.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventArgs Class

ActionValidationEventArgs Class
[image]

Contains the arguments passed to validation routed event related to activities and resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ActionValidationEventArgs : ActionEventArgs

Visual Basic [image] Copy Code

Public Class ActionValidationEventArgs
Inherits ActionEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
MindFusion.DataViews.Wpf.ActionEventArgs
MindFusion.DataViews.Wpf.ActionValidationEventArgs

See Also

ActionValidationEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventArgs Members

ActionValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to validation routed event related to activities and resource allocations.

The following tables list the members exposed by the ActionValidationEventArgs type.

Public Constructors

Name | Description
ActionValidationEventArgs | Initializes a new instance of the ActionValidationEventArgs class.

Public Properties

Name | Description
Action | Gets or sets the action related to the event. (Inherited from ActionEventArgs.)
Confirm | Gets or sets a value indicating whether the operation has been validated.
Item | Gets or sets the activity or resource allocation related to the event. (Inherited from ActionEventArgs.)

See Also

ActionValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventArgs Constructor

ActionValidationEventArgs Constructor
[image]

Initializes a new instance of the ActionValidationEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ActionValidationEventArgs (
Object item,
Action action
)

Visual Basic [image] Copy Code

Public New ( _
item As Object, _
action As Action _
)

Parameters

item

The related activity or resource allocation.

action

The action related to the event.

See Also

ActionValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventArgs Properties

ActionValidationEventArgs Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the action related to the event. (Inherited from ActionEventArgs.)
Confirm | Gets or sets a value indicating whether the operation has been validated.
Item | Gets or sets the activity or resource allocation related to the event. (Inherited from ActionEventArgs.)

See Also

ActionValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventArgs.Confirm Property

ActionValidationEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation has been validated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true, to confirm the operation; false, to reject it.

See Also

ActionValidationEventArgs Members
ActionValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActionValidationEventHandler Delegate

ActionValidationEventHandler Delegate
[image]

Represents the method that will handle validation routed events related to activities or resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public delegate void ActionValidationEventHandler (
Object sender,
ActionValidationEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub ActionValidationEventHandler ( _
sender As Object, _
e As ActionValidationEventArgs _
)

Parameters

sender

The object where the event handler is attached.

e

The event data.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Class

Activity Class
Remarks See Also
[image]

A model class that represents an activity instance in ActivityChart or ResourceChart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class Activity : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Activity
Implements INotifyPropertyChanged

Remarks

The class implements INotifyPropertyChanged interface to facilitate data binding.

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Activity

See Also

Activity Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Members

Activity Members
Constructors Properties Methods Events
[image]

A model class that represents an activity instance in ActivityChart or ResourceChart.

The following tables list the members exposed by the Activity type.

Public Constructors

Name | Description
Activity | Creates a new instance of the Activity class.

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
EndTime | Gets or sets the end time of the activity.
Progress | Gets or sets the progress/completion of the activity.
StartTime | Gets or sets the start time of the activity.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event with the provided parameters.

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Constructor

Activity Constructor
[image]

Creates a new instance of the Activity class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Activity ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Methods

Activity Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event with the provided parameters.

See Also

Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.OnPropertyChanged Method

Activity.OnPropertyChanged Method
[image]

Raises the PropertyChanged event with the provided parameters.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected void OnPropertyChanged (
string name
)

Visual Basic [image] Copy Code

Protected Sub OnPropertyChanged( _
name As String _
)

Parameters

name

The name of the changed property.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Properties

Activity Properties
[image]

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
EndTime | Gets or sets the end time of the activity.
Progress | Gets or sets the progress/completion of the activity.
StartTime | Gets or sets the start time of the activity.

See Also

Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.ActivityName Property

Activity.ActivityName Property
[image]

Gets or sets the name of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityName { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityName As String

Property Value

A string specifying a human-readable name of the activity.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.EndTime Property

Activity.EndTime Property
[image]

Gets or sets the end time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the end time.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.Progress Property

Activity.Progress Property
[image]

Gets or sets the progress/completion of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Double

Property Value

A double value indicating the level of completion of the activity. Valid values range from 0 to 1.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.StartTime Property

Activity.StartTime Property
[image]

Gets or sets the start time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A .NET DateTime object specifying the start time.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity Events

Activity Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Activity.PropertyChanged Event

Activity.PropertyChanged Event
[image]

Occurs when a property value changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Activity Members
Activity Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Class

ActivityChart Class
[image]

Displays tasks over a period of time and the relationships between those tasks.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ActivityChart : BaseChart

Visual Basic [image] Copy Code

Public Class ActivityChart
Inherits BaseChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BaseChart
MindFusion.DataViews.Wpf.ActivityChart

See Also

ActivityChart Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Members

ActivityChart Members
Constructors Fields Properties Methods Events
[image]

Displays tasks over a period of time and the relationships between those tasks.

The following tables list the members exposed by the ActivityChart type.

Public Constructors

Name | Description
ActivityChart | Initializes a new instance of the ActivityChart class.

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property. (Inherited from BaseChart.)
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property. (Inherited from BaseChart.)
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property. (Inherited from BaseChart.)
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property. (Inherited from BaseChart.)
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property. (Inherited from BaseChart.)
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property. (Inherited from BaseChart.)
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property. (Inherited from BaseChart.)
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property. (Inherited from BaseChart.)
DataTypeProperty | Identifies the DataType dependency property.
DependenciesArrowSizeProperty | Identifies the DependenciesArrowSize dependency property.
DependenciesCornerRadiusProperty | Identifies the DependenciesCornerRadius property.
DependenciesFillProperty | Identifies the DependenciesFill dependency property.
DependenciesStrokeProperty | Identifies the DependenciesStroke dependency property.
DependenciesStrokeThicknessProperty | Identifies the DependenciesStrokeThickness dependency property.
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property.
DependencyConnectionCursorProperty | Identifies the DependencyConnectionCursor dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property. (Inherited from BaseChart.)
DependencyPopupStyleProperty | Identifies the DependencyPopupStyle dependency property.
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property. (Inherited from BaseChart.)
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property. (Inherited from BaseChart.)
EmphasizeActivityInteractionsProperty | Identifies the EmphasizeActivityInteractions dependency property.
EnableDependenciesProperty | Identifies the EnableDependencies dependency property.
EnableDependencyHandlesProperty | Identifies the EnableDependencyHandles dependency property.
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property. (Inherited from BaseChart.)
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from BaseChart.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from BaseChart.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from BaseChart.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from BaseChart.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from BaseChart.)
HitTestDependenciesProperty | Identifies the HitTestDependencies dependency property.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. (Inherited from BaseChart.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BaseChart.)
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property. (Inherited from BaseChart.)
ItemBackgroundProperty | Identifies the ItemBackground dependency property. (Inherited from BaseChart.)
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property. (Inherited from BaseChart.)
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property. (Inherited from BaseChart.)
ItemHeightProperty | Identifies the ItemHeight dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property. (Inherited from BaseChart.)
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property. (Inherited from BaseChart.)
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property. (Inherited from BaseChart.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property. (Inherited from BaseChart.)
PopupPlacementProperty | Identifies the PopupPlacement dependency property. (Inherited from BaseChart.)
PopupStyleProperty | Identifies the PopupStyle dependency property. (Inherited from BaseChart.)
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property. (Inherited from BaseChart.)
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property. (Inherited from BaseChart.)
ShowCriticalPathProperty | Identifies the ShowCriticalPath dependency property.
ShowNowProperty | Identifies the ShowNow dependency property. (Inherited from BaseChart.)
ShowPopupsProperty | Identifies the ShowPopups dependency property. (Inherited from BaseChart.)
ShowResourcesProperty | Identifies the ShowResources dependency property.
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property. (Inherited from BaseChart.)
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property. (Inherited from BaseChart.)
TimelineHeaderProperty | Identifies the TimelineHeader dependency property. (Inherited from BaseChart.)

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property. (Inherited from BaseChart.)
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds. (Inherited from BaseChart.)
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control. (Inherited from BaseChart.)
DataType | Gets or sets the type of the data contained in the chart. This is a dependency property.
DependenciesArrowSize | Gets or sets the arrow head size of all dependencies. This is a dependency property.
DependenciesCornerRadius | Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.
DependenciesFill | Gets or sets a brush that describes the fill of all dependencies. This is a dependency property.
DependenciesStroke | Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.
DependenciesStrokeThickness | Gets or sets the thickness of dependencies' strokes. This is a dependency property.
DependencyAnchorCursor | Gets or sets the cursor to display when the user is about to start interactive dependency creation on an item in the chart. This is a dependency property.
DependencyConnectionCursor | Gets or sets the cursor to display when the user is creating a dependency interactively. This is a dependency property.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyPopupStyle | Gets or sets the style of the dependency popup windows displayed when dependencies are created or clicked. This is a dependency property.
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
EmphasizeActivityInteractions | Gets or sets a value indicating whether semitransparency is applied to dependencies in a chart, when an activity interaction is taking place. This is a dependency property.
EnableDependencies | Gets or sets a value indicating whether dependencies are enabled for the chart. This is a dependency property.
EnableDependencyHandles | Gets or sets a value indicating whether the activities will show dependency handles when pointed by the user. This is a dependency property.
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property. (Inherited from BaseChart.)
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property. (Inherited from BaseChart.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HitTestDependencies | Gets or sets a value indicating whether the dependencies in the chart can be hit-tested by the user. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property. (Inherited from BaseChart.)
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property. (Inherited from BaseChart.)
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property. (Inherited from BaseChart.)
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property. (Inherited from BaseChart.)
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property. (Inherited from BaseChart.)
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property. (Inherited from BaseChart.)
Project | Gets the IProjectViewModel object assigned to this chart. (Inherited from BaseChart.)
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ShowCriticalPath | Gets or sets a value indicating whether to display the current critical path. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property. (Inherited from BaseChart.)
ShowResources | Gets or sets a value indicating whether the activity presenters will display allocated resources if present. This is a dependency property.
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property. (Inherited from BaseChart.)

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state. (Inherited from BaseChart.)

Public Methods

Name | Description
CreateChartImage | Creates a BitmapSource representing the currently visible portion of the Timeline chart.
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property. (Inherited from BaseChart.)
DrillIn | Overloaded. Zooms in the view. (Inherited from BaseChart.)
DrillOut | Overloaded. Zooms out the view. (Inherited from BaseChart.)
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline. (Inherited from BaseChart.)
OnApplyTemplate | BaseChart.OnApplyTemplate override.
ScrollIntoView | Overloaded. Scrolls to a given activity in the schedule grid.

Protected Methods

Name | Description
OnActivityClicked | Raises the ActivityClicked event.
OnActivityModified | Raises the ActivityModified event.
OnActivityModifying | Raises the ActivityModifying event.
OnActivityPresenterCreated | Raises the ActivityPresenterCreated event.
OnDependencyClicked | Raises the DependencyClicked event.
OnDependencyCreated | Raises the DependencyCreated event.
OnDependencyPresenterCreated | Raises the DependencyPresenterCreated event.
OnDrilledIn | Raises the DrilledIn event. (Inherited from BaseChart.)
OnDrilledOut | Raises the DrilledOut event. (Inherited from BaseChart.)
OnDrillingIn | Raises the DrillingIn event. (Inherited from BaseChart.)
OnDrillingOut | Raises the DrillingOut event. (Inherited from BaseChart.)
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BaseChart.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BaseChart.)
OnLostFocus | Control.OnLostFocus override. (Inherited from BaseChart.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from BaseChart.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from BaseChart.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseChart.)
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override. (Inherited from BaseChart.)
OnPreviewMouseUp | Control.OnPreviewMouseUp override. (Inherited from BaseChart.)
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override. (Inherited from BaseChart.)
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event. (Inherited from BaseChart.)

Public Events

Name | Description
ActivityClicked | Raised when the user clicks on an activity with the mouse.
ActivityModified | Raised when the user has modified an activity interactively.
ActivityModifying | Raised when the user is modifying an activity interactively.
ActivityPresenterCreated | Raised when an ActivityPresenter object is created for an IActivityViewModel to allow customization of the presenter.
DependencyClicked | Raised when the user clicks on a dependency with the mouse.
DependencyCreated | Raised when the user creates a new dependency interactively.
DependencyPresenterCreated | Raised when a DependencyPresenter object is created for a IDependencyViewModel to allow for customization of the presenter.
DrilledIn | Raised when the view was drilled in. (Inherited from BaseChart.)
DrilledOut | Raised when the view was drilled out. (Inherited from BaseChart.)
DrillingIn | Raised when the view is currently drilling in. (Inherited from BaseChart.)
DrillingOut | Raised when the view is currently drilling out. (Inherited from BaseChart.)
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes. (Inherited from BaseChart.)

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Fields

ActivityChart Fields
[image]

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property. (Inherited from BaseChart.)
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property. (Inherited from BaseChart.)
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property. (Inherited from BaseChart.)
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property. (Inherited from BaseChart.)
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property. (Inherited from BaseChart.)
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property. (Inherited from BaseChart.)
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property. (Inherited from BaseChart.)
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property. (Inherited from BaseChart.)
DataTypeProperty | Identifies the DataType dependency property.
DependenciesArrowSizeProperty | Identifies the DependenciesArrowSize dependency property.
DependenciesCornerRadiusProperty | Identifies the DependenciesCornerRadius property.
DependenciesFillProperty | Identifies the DependenciesFill dependency property.
DependenciesStrokeProperty | Identifies the DependenciesStroke dependency property.
DependenciesStrokeThicknessProperty | Identifies the DependenciesStrokeThickness dependency property.
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property.
DependencyConnectionCursorProperty | Identifies the DependencyConnectionCursor dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property. (Inherited from BaseChart.)
DependencyPopupStyleProperty | Identifies the DependencyPopupStyle dependency property.
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property. (Inherited from BaseChart.)
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property. (Inherited from BaseChart.)
EmphasizeActivityInteractionsProperty | Identifies the EmphasizeActivityInteractions dependency property.
EnableDependenciesProperty | Identifies the EnableDependencies dependency property.
EnableDependencyHandlesProperty | Identifies the EnableDependencyHandles dependency property.
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property. (Inherited from BaseChart.)
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from BaseChart.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from BaseChart.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from BaseChart.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from BaseChart.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from BaseChart.)
HitTestDependenciesProperty | Identifies the HitTestDependencies dependency property.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. (Inherited from BaseChart.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BaseChart.)
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property. (Inherited from BaseChart.)
ItemBackgroundProperty | Identifies the ItemBackground dependency property. (Inherited from BaseChart.)
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property. (Inherited from BaseChart.)
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property. (Inherited from BaseChart.)
ItemHeightProperty | Identifies the ItemHeight dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property. (Inherited from BaseChart.)
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property. (Inherited from BaseChart.)
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property. (Inherited from BaseChart.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property. (Inherited from BaseChart.)
PopupPlacementProperty | Identifies the PopupPlacement dependency property. (Inherited from BaseChart.)
PopupStyleProperty | Identifies the PopupStyle dependency property. (Inherited from BaseChart.)
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property. (Inherited from BaseChart.)
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property. (Inherited from BaseChart.)
ShowCriticalPathProperty | Identifies the ShowCriticalPath dependency property.
ShowNowProperty | Identifies the ShowNow dependency property. (Inherited from BaseChart.)
ShowPopupsProperty | Identifies the ShowPopups dependency property. (Inherited from BaseChart.)
ShowResourcesProperty | Identifies the ShowResources dependency property.
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property. (Inherited from BaseChart.)
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property. (Inherited from BaseChart.)
TimelineHeaderProperty | Identifies the TimelineHeader dependency property. (Inherited from BaseChart.)

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DataTypeProperty Field

ActivityChart.DataTypeProperty Field
[image]

Identifies the DataType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataTypeProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesArrowSizeProperty Field

ActivityChart.DependenciesArrowSizeProperty Field
[image]

Identifies the DependenciesArrowSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesArrowSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesArrowSizeProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesCornerRadiusProperty Field

ActivityChart.DependenciesCornerRadiusProperty Field
[image]

Identifies the DependenciesCornerRadius property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesCornerRadiusProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesFillProperty Field

ActivityChart.DependenciesFillProperty Field
[image]

Identifies the DependenciesFill dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesFillProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesStrokeProperty Field

ActivityChart.DependenciesStrokeProperty Field
[image]

Identifies the DependenciesStroke dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesStrokeProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesStrokeThicknessProperty Field

ActivityChart.DependenciesStrokeThicknessProperty Field
[image]

Identifies the DependenciesStrokeThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesStrokeThicknessProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyAnchorCursorProperty Field

ActivityChart.DependencyAnchorCursorProperty Field
[image]

Identifies the DependencyAnchorCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyAnchorCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyAnchorCursorProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyConnectionCursorProperty Field

ActivityChart.DependencyConnectionCursorProperty Field
[image]

Identifies the DependencyConnectionCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyConnectionCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyConnectionCursorProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyPopupStyleProperty Field

ActivityChart.DependencyPopupStyleProperty Field
[image]

Identifies the DependencyPopupStyle dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyPopupStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyPopupStyleProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EmphasizeActivityInteractionsProperty Field

ActivityChart.EmphasizeActivityInteractionsProperty Field
[image]

Identifies the EmphasizeActivityInteractions dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EmphasizeActivityInteractionsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EmphasizeActivityInteractionsProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EnableDependenciesProperty Field

ActivityChart.EnableDependenciesProperty Field
[image]

Identifies the EnableDependencies dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDependenciesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDependenciesProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EnableDependencyHandlesProperty Field

ActivityChart.EnableDependencyHandlesProperty Field
[image]

Identifies the EnableDependencyHandles dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDependencyHandlesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDependencyHandlesProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.HitTestDependenciesProperty Field

ActivityChart.HitTestDependenciesProperty Field
[image]

Identifies the HitTestDependencies dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HitTestDependenciesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HitTestDependenciesProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ItemTemplateProperty Field

ActivityChart.ItemTemplateProperty Field
[image]

Identifies the ItemTemplate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ShowCriticalPathProperty Field

ActivityChart.ShowCriticalPathProperty Field
[image]

Identifies the ShowCriticalPath dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCriticalPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCriticalPathProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ShowResourcesProperty Field

ActivityChart.ShowResourcesProperty Field
[image]

Identifies the ShowResources dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowResourcesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowResourcesProperty As DependencyProperty

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Constructor

ActivityChart Constructor
[image]

Initializes a new instance of the ActivityChart class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ActivityChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Methods

ActivityChart Methods
[image]

Public Methods

Name | Description
CreateChartImage | Creates a BitmapSource representing the currently visible portion of the Timeline chart.
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property. (Inherited from BaseChart.)
DrillIn | Overloaded. Zooms in the view. (Inherited from BaseChart.)
DrillOut | Overloaded. Zooms out the view. (Inherited from BaseChart.)
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline. (Inherited from BaseChart.)
OnApplyTemplate | BaseChart.OnApplyTemplate override.
ScrollIntoView | Overloaded. Scrolls to a given activity in the schedule grid.

Protected Methods

Name | Description
OnActivityClicked | Raises the ActivityClicked event.
OnActivityModified | Raises the ActivityModified event.
OnActivityModifying | Raises the ActivityModifying event.
OnActivityPresenterCreated | Raises the ActivityPresenterCreated event.
OnDependencyClicked | Raises the DependencyClicked event.
OnDependencyCreated | Raises the DependencyCreated event.
OnDependencyPresenterCreated | Raises the DependencyPresenterCreated event.
OnDrilledIn | Raises the DrilledIn event. (Inherited from BaseChart.)
OnDrilledOut | Raises the DrilledOut event. (Inherited from BaseChart.)
OnDrillingIn | Raises the DrillingIn event. (Inherited from BaseChart.)
OnDrillingOut | Raises the DrillingOut event. (Inherited from BaseChart.)
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BaseChart.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BaseChart.)
OnLostFocus | Control.OnLostFocus override. (Inherited from BaseChart.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from BaseChart.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from BaseChart.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseChart.)
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override. (Inherited from BaseChart.)
OnPreviewMouseUp | Control.OnPreviewMouseUp override. (Inherited from BaseChart.)
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override. (Inherited from BaseChart.)
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event. (Inherited from BaseChart.)

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.CreateChartImage Method

ActivityChart.CreateChartImage Method
[image]

Creates a BitmapSource representing the currently visible portion of the Timeline chart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override BitmapSource CreateChartImage ()

Visual Basic [image] Copy Code

Public Overrides Function CreateChartImage () As BitmapSource

Return Value

A .NET BitmapSource object representing the Timeline chart.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnActivityClicked Method

ActivityChart.OnActivityClicked Method
[image]

Raises the ActivityClicked event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActivityClicked (
ProjectMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActivityClicked ( _
e As ProjectMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnActivityModified Method

ActivityChart.OnActivityModified Method
[image]

Raises the ActivityModified event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActivityModified (
ProjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActivityModified ( _
e As ProjectEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnActivityModifying Method

ActivityChart.OnActivityModifying Method
[image]

Raises the ActivityModifying event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActivityModifying (
ProjectValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActivityModifying ( _
e As ProjectValidationEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnActivityPresenterCreated Method

ActivityChart.OnActivityPresenterCreated Method
[image]

Raises the ActivityPresenterCreated event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActivityPresenterCreated (
BasePresenterEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActivityPresenterCreated ( _
e As BasePresenterEventArgs _
)

Parameters

e

An object, containing the event data

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnApplyTemplate Method

ActivityChart.OnApplyTemplate Method
[image]

BaseChart.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnDependencyClicked Method

ActivityChart.OnDependencyClicked Method
[image]

Raises the DependencyClicked event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDependencyClicked (
ProjectMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDependencyClicked ( _
e As ProjectMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnDependencyCreated Method

ActivityChart.OnDependencyCreated Method
[image]

Raises the DependencyCreated event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDependencyCreated (
DependencyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDependencyCreated ( _
e As DependencyEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.OnDependencyPresenterCreated Method

ActivityChart.OnDependencyPresenterCreated Method
[image]

Raises the DependencyPresenterCreated event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDependencyPresenterCreated (
DependencyPresenterEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDependencyPresenterCreated ( _
e As DependencyPresenterEventArgs _
)

Parameters

e

An object, containing the event data

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ScrollIntoView Method

ActivityChart.ScrollIntoView Method
[image]

Scrolls to a given activity in the schedule grid.

Overload List

Name | Description
ActivityChart.ScrollIntoView (IActivityViewModel) | Scrolls to a given activity in the schedule grid.
ActivityChart.ScrollIntoView (IActivityViewModel, Boolean) | Scrolls to a given activity in the schedule grid taiking into considaration whethter the activity is visible within its parent.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ScrollIntoView Method (IActivityViewModel)

ActivityChart.ScrollIntoView Method (IActivityViewModel)
See Also
[image]

Scrolls to a given activity in the schedule grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void ScrollIntoView (
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public Sub ScrollIntoView ( _
activity As IActivityViewModel _
)

Parameters

activity
The activity to scroll to.

Exceptions

Exception | Condition
ArgumentException | Thrown when the provided IActivityViewModel object is not part of the underlying IProjectViewModel.
ArgumentNullException | Thrown when the provided IActivityViewModel is null.

See Also

ScrollIntoView Method Overload List
ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ScrollIntoView Method (IActivityViewModel, Boolean)

ActivityChart.ScrollIntoView Method (IActivityViewModel, Boolean)
See Also
[image]

Scrolls to a given activity in the schedule grid taiking into considaration whethter the activity is visible within its parent.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void ScrollIntoView (
IActivityViewModel activity,
bool expandIfCollapsed
)

Visual Basic [image] Copy Code

Public Sub ScrollIntoView ( _
activity As IActivityViewModel, _
expandIfCollapsed As Boolean _
)

Parameters

activity
The activity to scroll to.
expandIfCollapsed
If set to true the activity will be made visible in all cases; if set to false, if the activity is not visible due to a parent being collapsed, the view will scroll to the collapsed parent insted.

Exceptions

Exception | Condition
ArgumentException | Thrown when the provided IActivityViewModel object is not part of the underlying IProjectViewModel.
ArgumentNullException | Thrown when the provided IActivityViewModel is null.

See Also

ScrollIntoView Method Overload List
ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Properties

ActivityChart Properties
[image]

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property. (Inherited from BaseChart.)
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds. (Inherited from BaseChart.)
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control. (Inherited from BaseChart.)
DataType | Gets or sets the type of the data contained in the chart. This is a dependency property.
DependenciesArrowSize | Gets or sets the arrow head size of all dependencies. This is a dependency property.
DependenciesCornerRadius | Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.
DependenciesFill | Gets or sets a brush that describes the fill of all dependencies. This is a dependency property.
DependenciesStroke | Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.
DependenciesStrokeThickness | Gets or sets the thickness of dependencies' strokes. This is a dependency property.
DependencyAnchorCursor | Gets or sets the cursor to display when the user is about to start interactive dependency creation on an item in the chart. This is a dependency property.
DependencyConnectionCursor | Gets or sets the cursor to display when the user is creating a dependency interactively. This is a dependency property.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyPopupStyle | Gets or sets the style of the dependency popup windows displayed when dependencies are created or clicked. This is a dependency property.
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
EmphasizeActivityInteractions | Gets or sets a value indicating whether semitransparency is applied to dependencies in a chart, when an activity interaction is taking place. This is a dependency property.
EnableDependencies | Gets or sets a value indicating whether dependencies are enabled for the chart. This is a dependency property.
EnableDependencyHandles | Gets or sets a value indicating whether the activities will show dependency handles when pointed by the user. This is a dependency property.
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property. (Inherited from BaseChart.)
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property. (Inherited from BaseChart.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HitTestDependencies | Gets or sets a value indicating whether the dependencies in the chart can be hit-tested by the user. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property. (Inherited from BaseChart.)
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property. (Inherited from BaseChart.)
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property. (Inherited from BaseChart.)
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property. (Inherited from BaseChart.)
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property. (Inherited from BaseChart.)
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property. (Inherited from BaseChart.)
Project | Gets the IProjectViewModel object assigned to this chart. (Inherited from BaseChart.)
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ShowCriticalPath | Gets or sets a value indicating whether to display the current critical path. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property. (Inherited from BaseChart.)
ShowResources | Gets or sets a value indicating whether the activity presenters will display allocated resources if present. This is a dependency property.
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property. (Inherited from BaseChart.)

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state. (Inherited from BaseChart.)

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DataType Property

ActivityChart.DataType Property
[image]

Gets or sets the type of the data contained in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Type DataType { get; set; }

Visual Basic [image] Copy Code

Public Property DataType As Type

Property Value

A .NET Type object.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesArrowSize Property

ActivityChart.DependenciesArrowSize Property
[image]

Gets or sets the arrow head size of all dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesArrowSize { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesArrowSize As Double

Property Value

A double value specifying the default arrow head size of dependencies. The default is 6.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesCornerRadius Property

ActivityChart.DependenciesCornerRadius Property
[image]

Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesCornerRadius As Double

Property Value

A double value specifying the roundness of dependency bends. The default is 3.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesFill Property

ActivityChart.DependenciesFill Property
[image]

Gets or sets a brush that describes the fill of all dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush DependenciesFill { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesFill As Brush

Property Value

A WPF Brush specifying the fill of the dependency arrow heads.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesStroke Property

ActivityChart.DependenciesStroke Property
[image]

Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush DependenciesStroke { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesStroke As Brush

Property Value

A WPF Brush specifying the stroke of the dependencies in the chart.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependenciesStrokeThickness Property

ActivityChart.DependenciesStrokeThickness Property
[image]

Gets or sets the thickness of dependencies' strokes. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesStrokeThickness As Double

Property Value

A WPF Brush specifying the stroke thickness of the dependencies in the chart.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyAnchorCursor Property

ActivityChart.DependencyAnchorCursor Property
[image]

Gets or sets the cursor to display when the user is about to start interactive dependency creation on an item in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor DependencyAnchorCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyAnchorCursor As Cursor

Property Value

A WPF Cursor.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyConnectionCursor Property

ActivityChart.DependencyConnectionCursor Property
[image]

Gets or sets the cursor to display when the user is creating a dependency interactively. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor DependencyConnectionCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyConnectionCursor As Cursor

Property Value

A WPF Cursor.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyPopupStyle Property

ActivityChart.DependencyPopupStyle Property
[image]

Gets or sets the style of the dependency popup windows displayed when dependencies are created or clicked. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Style DependencyPopupStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyPopupStyle As Style

Property Value

A WPF Style

Remarks

The default style of the popup is demonstrated below:

XAML [image] Copy Code

<Style TargetType="local:DependencyPopupContent">
<Setter Property="BorderBrush" Value="{StaticResource PopupContentBorderBrush}" />
<Setter Property="BorderThickness" Value="1" />
<Setter Property="Background" Value="{StaticResource PopupContentBackgroundBrush}" />
<Setter Property="Padding" Value="2" />
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:DependencyPopupContent">
<Border Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
<StackPanel Orientation="Vertical">
<TextBlock Text="{TemplateBinding PopupTitle}" FontWeight="Bold" Margin="0,0,0,3"/>
<Line X1="0" X2="1" Y1="0" Y2="0" Stretch="Fill" Stroke="Black" StrokeThickness="1.5" Margin="0,0,0,3"/>
<StackPanel Name="FromContainer" Orientation="Horizontal">
<TextBlock Text="From: " />
<TextBlock Text="{TemplateBinding From}" FontWeight="Bold" />
</StackPanel>
<StackPanel Name="ToContainer" Orientation="Horizontal">
<TextBlock Text="To: " />
<TextBlock Text="{TemplateBinding To}" FontWeight="Bold"/>
</StackPanel>
<StackPanel Name="DependencyTypeContainer" Orientation="Horizontal">
<TextBlock Text="Dependency type: " />
<TextBlock Text="{TemplateBinding FromType}" FontWeight="Bold" />
<TextBlock Text="To" FontWeight="Bold" />
<TextBlock Text="{TemplateBinding ToType}" FontWeight="Bold" />
</StackPanel>
</StackPanel>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EmphasizeActivityInteractions Property

ActivityChart.EmphasizeActivityInteractions Property
[image]

Gets or sets a value indicating whether semitransparency is applied to dependencies in a chart, when an activity interaction is taking place. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool EmphasizeActivityInteractions { get; set; }

Visual Basic [image] Copy Code

Public Property EmphasizeActivityInteractions As Boolean

Property Value

true to fade out dependencies during activity interactions; otherwise, false.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EnableDependencies Property

ActivityChart.EnableDependencies Property
[image]

Gets or sets a value indicating whether dependencies are enabled for the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool EnableDependencies { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDependencies As Boolean

Property Value

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.EnableDependencyHandles Property

ActivityChart.EnableDependencyHandles Property
[image]

Gets or sets a value indicating whether the activities will show dependency handles when pointed by the user. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool EnableDependencyHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDependencyHandles As Boolean

Property Value

true to show dependency handles; otherwise, false.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.HitTestDependencies Property

ActivityChart.HitTestDependencies Property
[image]

Gets or sets a value indicating whether the dependencies in the chart can be hit-tested by the user. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool HitTestDependencies { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestDependencies As Boolean

Property Value

true, to hit-test dependencies; false, to ignore them.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ItemTemplate Property

ActivityChart.ItemTemplate Property
[image]

Gets or sets the DataTemplate used to display each item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ItemTemplate As DataTemplate

Property Value

A WPF DataTemplate.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ShowCriticalPath Property

ActivityChart.ShowCriticalPath Property
[image]

Gets or sets a value indicating whether to display the current critical path. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowCriticalPath { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCriticalPath As Boolean

Property Value

true to display the critical path; otherwise, false.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ShowResources Property

ActivityChart.ShowResources Property
[image]

Gets or sets a value indicating whether the activity presenters will display allocated resources if present. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowResources { get; set; }

Visual Basic [image] Copy Code

Public Property ShowResources As Boolean

Property Value

true to display resources allocated for the activities; otherwise, false.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart Events

ActivityChart Events
[image]

Public Events

Name | Description
ActivityClicked | Raised when the user clicks on an activity with the mouse.
ActivityModified | Raised when the user has modified an activity interactively.
ActivityModifying | Raised when the user is modifying an activity interactively.
ActivityPresenterCreated | Raised when an ActivityPresenter object is created for an IActivityViewModel to allow customization of the presenter.
DependencyClicked | Raised when the user clicks on a dependency with the mouse.
DependencyCreated | Raised when the user creates a new dependency interactively.
DependencyPresenterCreated | Raised when a DependencyPresenter object is created for a IDependencyViewModel to allow for customization of the presenter.
DrilledIn | Raised when the view was drilled in. (Inherited from BaseChart.)
DrilledOut | Raised when the view was drilled out. (Inherited from BaseChart.)
DrillingIn | Raised when the view is currently drilling in. (Inherited from BaseChart.)
DrillingOut | Raised when the view is currently drilling out. (Inherited from BaseChart.)
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes. (Inherited from BaseChart.)

See Also

ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ActivityClicked Event

ActivityChart.ActivityClicked Event
[image]

Raised when the user clicks on an activity with the mouse.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectMouseEventArgs> ActivityClicked

Visual Basic [image] Copy Code

Public Event ActivityClicked As EventHandler(Of ProjectMouseEventArgs)

Event Data

ActivityClicked event handlers receive an argument of type ProjectMouseEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ActivityModified Event

ActivityChart.ActivityModified Event
[image]

Raised when the user has modified an activity interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectEventArgs> ActivityModified

Visual Basic [image] Copy Code

Public Event ActivityModified As EventHandler(Of ProjectEventArgs)

Event Data

ActivityModified event handlers receive an argument of type ProjectEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ActivityModifying Event

ActivityChart.ActivityModifying Event
[image]

Raised when the user is modifying an activity interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectValidationEventArgs> ActivityModifying

Visual Basic [image] Copy Code

Public Event ActivityModifying As EventHandler(Of ProjectValidationEventArgs)

Event Data

ActivityModifying event handlers receive an argument of type ProjectValidationEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.ActivityPresenterCreated Event

ActivityChart.ActivityPresenterCreated Event
[image]

Raised when an ActivityPresenter object is created for an IActivityViewModel to allow customization of the presenter.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<BasePresenterEventArgs> ActivityPresenterCreated

Visual Basic [image] Copy Code

Public Event ActivityPresenterCreated As EventHandler(Of BasePresenterEventArgs)

Event Data

ActivityPresenterCreated event handlers receive an argument of type BasePresenterEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyClicked Event

ActivityChart.DependencyClicked Event
[image]

Raised when the user clicks on a dependency with the mouse.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectMouseEventArgs> DependencyClicked

Visual Basic [image] Copy Code

Public Event DependencyClicked As EventHandler(Of ProjectMouseEventArgs)

Event Data

DependencyClicked event handlers receive an argument of type ProjectMouseEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyCreated Event

ActivityChart.DependencyCreated Event
[image]

Raised when the user creates a new dependency interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DependencyEventArgs> DependencyCreated

Visual Basic [image] Copy Code

Public Event DependencyCreated As EventHandler(Of DependencyEventArgs)

Event Data

DependencyCreated event handlers receive an argument of type DependencyEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityChart.DependencyPresenterCreated Event

ActivityChart.DependencyPresenterCreated Event
[image]

Raised when a DependencyPresenter object is created for a IDependencyViewModel to allow for customization of the presenter.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DependencyPresenterEventArgs> DependencyPresenterCreated

Visual Basic [image] Copy Code

Public Event DependencyPresenterCreated As EventHandler(Of DependencyPresenterEventArgs)

Event Data

DependencyPresenterCreated event handlers receive an argument of type DependencyPresenterEventArgs.

See Also

ActivityChart Members
ActivityChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrilledIn Event

BaseChart.DrilledIn Event
[image]

Raised when the view was drilled in.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DrilledIn

Visual Basic [image] Copy Code

Public Event DrilledIn As EventHandler

Event Data

DrilledIn event handlers recieve an argument of type EventArgs.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrilledOut Event

BaseChart.DrilledOut Event
[image]

Raised when the view was drilled out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DrilledOut

Visual Basic [image] Copy Code

Public Event DrilledOut As EventHandler

Event Data

DrilledOut event handlers recieve an argument of type EventArgs.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillingIn Event

BaseChart.DrillingIn Event
[image]

Raised when the view is currently drilling in.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectValidationEventArgs> DrillingIn

Visual Basic [image] Copy Code

Public Event DrillingIn As EventHandler(Of ProjectValidationEventArgs)

Event Data

DrillingIn event handlers recieve an argument of type ProjectValidationEventArgs.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillingOut Event

BaseChart.DrillingOut Event
[image]

Raised when the view is currently drilling out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectValidationEventArgs> DrillingOut

Visual Basic [image] Copy Code

Public Event DrillingOut As EventHandler(Of ProjectValidationEventArgs)

Event Data

DrillingOut event handlers recieve an argument of type ProjectValidationEventArgs.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.RelativeTimelineDateChanged Event

BaseChart.RelativeTimelineDateChanged Event
[image]

Occurs when RelativeTimelineDate changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateChangedEventArgs> RelativeTimelineDateChanged

Visual Basic [image] Copy Code

Public Event RelativeTimelineDateChanged As EventHandler(Of DateChangedEventArgs)

Event Data

RelativeTimelineDateChanged event handlers recieve an argument of type DateChangedEventArgs.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Class

ActivityPresenter Class
Remarks See Also
[image]

Represents an activity in an ActivityChart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ActivityPresenter : BasePresenter

Visual Basic [image] Copy Code

Public Class ActivityPresenter
Inherits BasePresenter

Remarks

This class serves as the view in a MVVM pattern where the ViewModel is IActivityViewModel and the Model is either an Activity object or a user-defined activity object.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BasePresenter
MindFusion.DataViews.Wpf.ActivityPresenter

See Also

ActivityPresenter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Members

ActivityPresenter Members
Constructors Fields Properties Methods Events
[image]

Represents an activity in an ActivityChart.

The following tables list the members exposed by the ActivityPresenter type.

Public Constructors

Name | Description
ActivityPresenter | Initializes a new instance of the ActivityPresenter class.

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property. (Inherited from BasePresenter.)
ClickedEvent | Identifies the Clicked routed event. (Inherited from BasePresenter.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property. (Inherited from BasePresenter.)
DurationProperty | Identifies the Duration dependency property. (Inherited from BasePresenter.)
EnableDependenciesProperty | Identifies the EnableDependencies dependency property.
EnableDependencyHandlesProperty | Identifies the EnableDependencyHandles dependency property.
EndTimeProperty | Identifies the EndTime dependency property. (Inherited from BasePresenter.)
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property. (Inherited from BasePresenter.)
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property. (Inherited from BasePresenter.)
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property. (Inherited from BasePresenter.)
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property. (Inherited from BasePresenter.)
FocusBrushProperty | Identifies the FocusBrush dependency property. (Inherited from BasePresenter.)
IsCriticalProperty | Identifies the IsCritical dependency property.
IsMilestoneProperty | Identifies the IsMilestone dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BasePresenter.)
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property. (Inherited from BasePresenter.)
ModifiedEvent | Identifies the Modified routed event. (Inherited from BasePresenter.)
ModifyingEvent | Identifies the Modifying routed event. (Inherited from BasePresenter.)
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property. (Inherited from BasePresenter.)
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property. (Inherited from BasePresenter.)
ProgressLengthProperty | Identifies the ProgressLength dependency property. (Inherited from BasePresenter.)
ProgressProperty | Identifies the Progress dependency property. (Inherited from BasePresenter.)
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property. (Inherited from BasePresenter.)
ResourceAllocationsProperty | Identifies the ResourceAllocations dependency property.
ResourcesLabelFontSizeProperty | Identifies the ResourcesLabelFontSize dependency property.
ResourcesLabelFontStretchProperty | Identifies the ResourcesLabelFontStretch dependency property.
ResourcesLabelFontStyleProperty | Identifies the ResourcesLabelFontStyle dependency property.
ResourcesLabelFontWeightProperty | Identifies the ResourcesLabelFontWeight dependency property.
ResourcesLabelForegroundProperty | Identifies the ResourcesLabelForeground dependency property.
ResourcesLabelOffsetXProperty | Identifies the ResourcesLabelOffsetX dependency property.
ResourcesLabelOffsetYProperty | Identifies the ResourcesLabelOffsetY dependency property.
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property. (Inherited from BasePresenter.)
ScheduleModeProperty | Identifies the ScheduleMode dependency property.
StartTimeProperty | Identifies the StartTime dependency property. (Inherited from BasePresenter.)

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property. (Inherited from BasePresenter.)
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Duration | Gets the duration of the item. This is a dependency property. (Inherited from BasePresenter.)
EnableDependencies | Gets or sets a value indicating whether dependencies are enabled for this activity. This is a dependency property.
EnableDependencyHandles | Gets or sets a value indicating whether the activity presenter will show the dependency handles. This is a dependency property.
EndTime | Gets the end time of the item. This is a dependency property. (Inherited from BasePresenter.)
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property. (Inherited from BasePresenter.)
IsCritical | Gets or sets a value indicating whether the underlying activity is part of the critical path. This is a dependency property.
IsMilestone | Gets a value indicating whether the underlying activity is a milestone. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property. (Inherited from BasePresenter.)
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Progress | Gets or sets the progress/completion of the item. This is a dependency property. (Inherited from BasePresenter.)
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property. (Inherited from BasePresenter.)
ResourceAllocations | Gets or sets the resource allocation associated with the bound activity. This is a dependency property.
ResourcesLabelFontSize | Gets or sets a font size of the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontStretch | Gets or sets a font stretch to the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontStyle | Gets or sets a font style to the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontWeight | Gets or sets a font weight to the text displaying allocated resources. This is a dependency property.
ResourcesLabelForeground | Gets or sets a foreground of the text displaying allocated resources. This is a dependency property.
ResourcesLabelOffsetX | Gets or sets a horizontal offset to the relative position of the text displaying allocated resources. This is a dependency property.
ResourcesLabelOffsetY | Gets or sets a vertical offset to the relative position of the text displaying allocated resources. This is a dependency property.
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
ScheduleMode | Gets a value indicating the mode of the underlying activity. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property. (Inherited from BasePresenter.)
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT). (Inherited from BasePresenter.)

Public Methods

Name | Description
OnApplyTemplate | BasePresenter.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BasePresenter.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BasePresenter.)
OnMouseDoubleClick | Control.OnMouseDoubleClick override. (Inherited from BasePresenter.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BasePresenter.)
OnPreviewMouseLeftButtonDown | UIElement.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseMove | BasePresenter.OnPreviewMouseMove override.
OnPreviewMouseUp | BasePresenter.OnPreviewMouseUp override.

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object. (Inherited from BasePresenter.)
Modified | Occurs when the presenter has been modified interactively. (Inherited from BasePresenter.)
Modifying | Occurs when the presenter is being modified interactively. (Inherited from BasePresenter.)

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Fields

ActivityPresenter Fields
[image]

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property. (Inherited from BasePresenter.)
ClickedEvent | Identifies the Clicked routed event. (Inherited from BasePresenter.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property. (Inherited from BasePresenter.)
DurationProperty | Identifies the Duration dependency property. (Inherited from BasePresenter.)
EnableDependenciesProperty | Identifies the EnableDependencies dependency property.
EnableDependencyHandlesProperty | Identifies the EnableDependencyHandles dependency property.
EndTimeProperty | Identifies the EndTime dependency property. (Inherited from BasePresenter.)
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property. (Inherited from BasePresenter.)
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property. (Inherited from BasePresenter.)
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property. (Inherited from BasePresenter.)
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property. (Inherited from BasePresenter.)
FocusBrushProperty | Identifies the FocusBrush dependency property. (Inherited from BasePresenter.)
IsCriticalProperty | Identifies the IsCritical dependency property.
IsMilestoneProperty | Identifies the IsMilestone dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BasePresenter.)
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property. (Inherited from BasePresenter.)
ModifiedEvent | Identifies the Modified routed event. (Inherited from BasePresenter.)
ModifyingEvent | Identifies the Modifying routed event. (Inherited from BasePresenter.)
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property. (Inherited from BasePresenter.)
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property. (Inherited from BasePresenter.)
ProgressLengthProperty | Identifies the ProgressLength dependency property. (Inherited from BasePresenter.)
ProgressProperty | Identifies the Progress dependency property. (Inherited from BasePresenter.)
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property. (Inherited from BasePresenter.)
ResourceAllocationsProperty | Identifies the ResourceAllocations dependency property.
ResourcesLabelFontSizeProperty | Identifies the ResourcesLabelFontSize dependency property.
ResourcesLabelFontStretchProperty | Identifies the ResourcesLabelFontStretch dependency property.
ResourcesLabelFontStyleProperty | Identifies the ResourcesLabelFontStyle dependency property.
ResourcesLabelFontWeightProperty | Identifies the ResourcesLabelFontWeight dependency property.
ResourcesLabelForegroundProperty | Identifies the ResourcesLabelForeground dependency property.
ResourcesLabelOffsetXProperty | Identifies the ResourcesLabelOffsetX dependency property.
ResourcesLabelOffsetYProperty | Identifies the ResourcesLabelOffsetY dependency property.
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property. (Inherited from BasePresenter.)
ScheduleModeProperty | Identifies the ScheduleMode dependency property.
StartTimeProperty | Identifies the StartTime dependency property. (Inherited from BasePresenter.)

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.EnableDependenciesProperty Field

ActivityPresenter.EnableDependenciesProperty Field
[image]

Identifies the EnableDependencies dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDependenciesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDependenciesProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.EnableDependencyHandlesProperty Field

ActivityPresenter.EnableDependencyHandlesProperty Field
[image]

Identifies the EnableDependencyHandles dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDependencyHandlesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDependencyHandlesProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.IsCriticalProperty Field

ActivityPresenter.IsCriticalProperty Field
[image]

Identifies the IsCritical dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsCriticalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsCriticalProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.IsMilestoneProperty Field

ActivityPresenter.IsMilestoneProperty Field
[image]

Identifies the IsMilestone dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsMilestoneProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsMilestoneProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourceAllocationsProperty Field

ActivityPresenter.ResourceAllocationsProperty Field
[image]

Identifies the ResourceAllocations dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceAllocationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceAllocationsProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontSizeProperty Field

ActivityPresenter.ResourcesLabelFontSizeProperty Field
[image]

Identifies the ResourcesLabelFontSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelFontSizeProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontStretchProperty Field

ActivityPresenter.ResourcesLabelFontStretchProperty Field
[image]

Identifies the ResourcesLabelFontStretch dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelFontStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelFontStretchProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontStyleProperty Field

ActivityPresenter.ResourcesLabelFontStyleProperty Field
[image]

Identifies the ResourcesLabelFontStyle dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelFontStyleProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontWeightProperty Field

ActivityPresenter.ResourcesLabelFontWeightProperty Field
[image]

Identifies the ResourcesLabelFontWeight dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelFontWeightProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelForegroundProperty Field

ActivityPresenter.ResourcesLabelForegroundProperty Field
[image]

Identifies the ResourcesLabelForeground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelForegroundProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelOffsetXProperty Field

ActivityPresenter.ResourcesLabelOffsetXProperty Field
[image]

Identifies the ResourcesLabelOffsetX dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelOffsetXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelOffsetXProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelOffsetYProperty Field

ActivityPresenter.ResourcesLabelOffsetYProperty Field
[image]

Identifies the ResourcesLabelOffsetY dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourcesLabelOffsetYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourcesLabelOffsetYProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ScheduleModeProperty Field

ActivityPresenter.ScheduleModeProperty Field
[image]

Identifies the ScheduleMode dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScheduleModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScheduleModeProperty As DependencyProperty

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Constructor

ActivityPresenter Constructor
[image]

Initializes a new instance of the ActivityPresenter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ActivityPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Methods

ActivityPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | BasePresenter.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BasePresenter.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BasePresenter.)
OnMouseDoubleClick | Control.OnMouseDoubleClick override. (Inherited from BasePresenter.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BasePresenter.)
OnPreviewMouseLeftButtonDown | UIElement.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseMove | BasePresenter.OnPreviewMouseMove override.
OnPreviewMouseUp | BasePresenter.OnPreviewMouseUp override.

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ArrangeOverride Method

ActivityPresenter.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.OnApplyTemplate Method

ActivityPresenter.OnApplyTemplate Method
[image]

BasePresenter.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.OnPreviewMouseLeftButtonDown Method

ActivityPresenter.OnPreviewMouseLeftButtonDown Method
[image]

UIElement.OnPreviewMouseLeftButtonDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.OnPreviewMouseMove Method

ActivityPresenter.OnPreviewMouseMove Method
[image]

BasePresenter.OnPreviewMouseMove override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.OnPreviewMouseUp Method

ActivityPresenter.OnPreviewMouseUp Method
[image]

BasePresenter.OnPreviewMouseUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Properties

ActivityPresenter Properties
[image]

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property. (Inherited from BasePresenter.)
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Duration | Gets the duration of the item. This is a dependency property. (Inherited from BasePresenter.)
EnableDependencies | Gets or sets a value indicating whether dependencies are enabled for this activity. This is a dependency property.
EnableDependencyHandles | Gets or sets a value indicating whether the activity presenter will show the dependency handles. This is a dependency property.
EndTime | Gets the end time of the item. This is a dependency property. (Inherited from BasePresenter.)
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property. (Inherited from BasePresenter.)
IsCritical | Gets or sets a value indicating whether the underlying activity is part of the critical path. This is a dependency property.
IsMilestone | Gets a value indicating whether the underlying activity is a milestone. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property. (Inherited from BasePresenter.)
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Progress | Gets or sets the progress/completion of the item. This is a dependency property. (Inherited from BasePresenter.)
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property. (Inherited from BasePresenter.)
ResourceAllocations | Gets or sets the resource allocation associated with the bound activity. This is a dependency property.
ResourcesLabelFontSize | Gets or sets a font size of the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontStretch | Gets or sets a font stretch to the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontStyle | Gets or sets a font style to the text displaying allocated resources. This is a dependency property.
ResourcesLabelFontWeight | Gets or sets a font weight to the text displaying allocated resources. This is a dependency property.
ResourcesLabelForeground | Gets or sets a foreground of the text displaying allocated resources. This is a dependency property.
ResourcesLabelOffsetX | Gets or sets a horizontal offset to the relative position of the text displaying allocated resources. This is a dependency property.
ResourcesLabelOffsetY | Gets or sets a vertical offset to the relative position of the text displaying allocated resources. This is a dependency property.
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
ScheduleMode | Gets a value indicating the mode of the underlying activity. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property. (Inherited from BasePresenter.)
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT). (Inherited from BasePresenter.)

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.EnableDependencies Property

ActivityPresenter.EnableDependencies Property
[image]

Gets or sets a value indicating whether dependencies are enabled for this activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool EnableDependencies { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDependencies As Boolean

Property Value

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.EnableDependencyHandles Property

ActivityPresenter.EnableDependencyHandles Property
[image]

Gets or sets a value indicating whether the activity presenter will show the dependency handles. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool EnableDependencyHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDependencyHandles As Boolean

Property Value

true to display the presenter handles; otherwise, false.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.IsCritical Property

ActivityPresenter.IsCritical Property
[image]

Gets or sets a value indicating whether the underlying activity is part of the critical path. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsCritical { get; set; }

Visual Basic [image] Copy Code

Public Property IsCritical As Boolean

Property Value

true if the activity participates in the critical path; otherwise, false.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.IsMilestone Property

ActivityPresenter.IsMilestone Property
[image]

Gets a value indicating whether the underlying activity is a milestone. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsMilestone { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsMilestone As Boolean

Property Value

true if the underlying item is a milestone; otherwise, false.

Remarks

The value of this property is not supposed to be modified. Instead, any changes should be performed directly on the underlying activity.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourceAllocations Property

ActivityPresenter.ResourceAllocations Property
[image]

Gets or sets the resource allocation associated with the bound activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IEnumerable ResourceAllocations { get; set; }

Visual Basic [image] Copy Code

Public Property ResourceAllocations As IEnumerable

Property Value

An .NET IEnumerable with the resource allocations related to the underlying activity.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontSize Property

ActivityPresenter.ResourcesLabelFontSize Property
[image]

Gets or sets a font size of the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ResourcesLabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelFontSize As Double

Property Value

A double specifying the font size.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontStretch Property

ActivityPresenter.ResourcesLabelFontStretch Property
[image]

Gets or sets a font stretch to the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public FontStretch ResourcesLabelFontStretch { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelFontStretch As FontStretch

Property Value

A FontStretch object.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontStyle Property

ActivityPresenter.ResourcesLabelFontStyle Property
[image]

Gets or sets a font style to the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public FontStyle ResourcesLabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelFontStyle As FontStyle

Property Value

A FontStyle object.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelFontWeight Property

ActivityPresenter.ResourcesLabelFontWeight Property
[image]

Gets or sets a font weight to the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public FontWeight ResourcesLabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelFontWeight As FontWeight

Property Value

A FontWeight object.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelForeground Property

ActivityPresenter.ResourcesLabelForeground Property
[image]

Gets or sets a foreground of the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ResourcesLabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelForeground As Brush

Property Value

A WPF Brush object.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelOffsetX Property

ActivityPresenter.ResourcesLabelOffsetX Property
[image]

Gets or sets a horizontal offset to the relative position of the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ResourcesLabelOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelOffsetX As Double

Property Value

A double value specifying the horizontal offset.

Remarks

The ResourcesLabelOffsetX and ResourcesLabelOffsetY properties are relative to the top-right corner of the activity presenter instance.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ResourcesLabelOffsetY Property

ActivityPresenter.ResourcesLabelOffsetY Property
[image]

Gets or sets a vertical offset to the relative position of the text displaying allocated resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ResourcesLabelOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property ResourcesLabelOffsetY As Double

Property Value

A double value specifying the vertical offset.

Remarks

The ResourcesLabelOffsetX and ResourcesLabelOffsetY properties are relative to the top-right corner of the activity presenter instance.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter.ScheduleMode Property

ActivityPresenter.ScheduleMode Property
[image]

Gets a value indicating the mode of the underlying activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleMode ScheduleMode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScheduleMode As ScheduleMode

Property Value

A member of the ScheduleMode enumeration.

See Also

ActivityPresenter Members
ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityPresenter Events

ActivityPresenter Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object. (Inherited from BasePresenter.)
Modified | Occurs when the presenter has been modified interactively. (Inherited from BasePresenter.)
Modifying | Occurs when the presenter is being modified interactively. (Inherited from BasePresenter.)

See Also

ActivityPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.Clicked Event

BasePresenter.Clicked Event
[image]

Occurs when the user clicks or double-clicks with the mouse on this object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event MouseButtonEventHandler Clicked

Visual Basic [image] Copy Code

Public Event Clicked As MouseButtonEventHandler

Event Data

Clicked event handlers receive an argument of type MouseButtonEventArgs.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.Modified Event

BasePresenter.Modified Event
[image]

Occurs when the presenter has been modified interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event ActionEventHandler Modified

Visual Basic [image] Copy Code

Public Event Modified As ActionEventHandler

Event Data

Modified event handlers receive an argument of type ActionEventArgs.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.Modifying Event

BasePresenter.Modifying Event
[image]

Occurs when the presenter is being modified interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event ActionValidationEventHandler Modifying

Visual Basic [image] Copy Code

Public Event Modifying As ActionValidationEventHandler

Event Data

Modifying event handlers receive an argument of type ActionValidationEventArgs.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState Class

ActivityState Class
[image]

Encapsulates the state of an activity for subsequent undo operations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ActivityState : UndoState

Visual Basic [image] Copy Code

Public Class ActivityState
Inherits UndoState

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.UndoState
MindFusion.DataViews.Wpf.ActivityState

See Also

ActivityState Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState Members

ActivityState Members
Constructors Properties Methods
[image]

Encapsulates the state of an activity for subsequent undo operations.

The following tables list the members exposed by the ActivityState type.

Public Constructors

Name | Description
ActivityState | Initializes a new instance of the ActivityState class.

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
AllocationStates | Gets or sets the undo states of the resource allocations associated with the activity.
EndTime | Gets or sets the end time of the activity.
Progress | Gets or sets the progress of the activity.
ScheduleMode | Gets or sets the mode of the activity.
StartTime | Gets or sets the start time of the activity.

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState Constructor

ActivityState Constructor
[image]

Initializes a new instance of the ActivityState class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ActivityState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState Methods

ActivityState Methods
[image]

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.Equals Method

ActivityState.Equals Method
[image]

UndoState.Equals override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
UndoState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As UndoState _
) As Boolean

Parameters

other

An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState Properties

ActivityState Properties
[image]

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
AllocationStates | Gets or sets the undo states of the resource allocations associated with the activity.
EndTime | Gets or sets the end time of the activity.
Progress | Gets or sets the progress of the activity.
ScheduleMode | Gets or sets the mode of the activity.
StartTime | Gets or sets the start time of the activity.

See Also

ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.ActivityName Property

ActivityState.ActivityName Property
[image]

Gets or sets the name of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityName { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityName As String

Property Value

A string, which stores the activity name.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.AllocationStates Property

ActivityState.AllocationStates Property
[image]

Gets or sets the undo states of the resource allocations associated with the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public UndoState[] AllocationStates { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationStates As UndoState()

Property Value

An array of UndoState objects.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.EndTime Property

ActivityState.EndTime Property
[image]

Gets or sets the end time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.Progress Property

ActivityState.Progress Property
[image]

Gets or sets the progress of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Double

Property Value

A double value, which stores the activity progress.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.ScheduleMode Property

ActivityState.ScheduleMode Property
[image]

Gets or sets the mode of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleMode ScheduleMode { get; set; }

Visual Basic [image] Copy Code

Public Property ScheduleMode As ScheduleMode

Property Value

A member of the ScheduleMode enumeration.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ActivityState.StartTime Property

ActivityState.StartTime Property
[image]

Gets or sets the start time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

ActivityState Members
ActivityState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Class

AllocationPresenter Class
[image]

Represents a resource allocation in a ResourceChart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class AllocationPresenter : BasePresenter

Visual Basic [image] Copy Code

Public Class AllocationPresenter
Inherits BasePresenter

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BasePresenter
MindFusion.DataViews.Wpf.AllocationPresenter

See Also

AllocationPresenter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Members

AllocationPresenter Members
Constructors Fields Properties Methods Events
[image]

Represents a resource allocation in a ResourceChart.

The following tables list the members exposed by the AllocationPresenter type.

Public Constructors

Name | Description
AllocationPresenter | Initializes a new instance of the AllocationPresenter class.

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property. (Inherited from BasePresenter.)
ActivityNameForegroundProperty | Identifies the ActivityNameForeground dependency property.
ClickedEvent | Identifies the Clicked routed event. (Inherited from BasePresenter.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property. (Inherited from BasePresenter.)
DurationProperty | Identifies the Duration dependency property. (Inherited from BasePresenter.)
EndTimeProperty | Identifies the EndTime dependency property. (Inherited from BasePresenter.)
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property. (Inherited from BasePresenter.)
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property. (Inherited from BasePresenter.)
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property. (Inherited from BasePresenter.)
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property. (Inherited from BasePresenter.)
FocusBrushProperty | Identifies the FocusBrush dependency property. (Inherited from BasePresenter.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BasePresenter.)
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property. (Inherited from BasePresenter.)
ModifiedEvent | Identifies the Modified routed event. (Inherited from BasePresenter.)
ModifyingEvent | Identifies the Modifying routed event. (Inherited from BasePresenter.)
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property. (Inherited from BasePresenter.)
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property. (Inherited from BasePresenter.)
ProgressLengthProperty | Identifies the ProgressLength dependency property. (Inherited from BasePresenter.)
ProgressProperty | Identifies the Progress dependency property. (Inherited from BasePresenter.)
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property. (Inherited from BasePresenter.)
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property. (Inherited from BasePresenter.)
ShowActivityProperty | Identifies the ShowActivity dependency property.
StartTimeProperty | Identifies the StartTime dependency property. (Inherited from BasePresenter.)

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property. (Inherited from BasePresenter.)
ActivityNameForeground | Gets or sets the Foreground of the text, displaying the name of the allocated activity. This is a dependency property.
Allocation | Gets the underlying item as IResourceAllocationViewModel.
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Duration | Gets the duration of the item. This is a dependency property. (Inherited from BasePresenter.)
EndTime | Gets the end time of the item. This is a dependency property. (Inherited from BasePresenter.)
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property. (Inherited from BasePresenter.)
IsInCollision | Gets a value indicating whether the presenter collides with another allocation presenter, while both presenters display allocations for the same resource.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property. (Inherited from BasePresenter.)
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Progress | Gets or sets the progress/completion of the item. This is a dependency property. (Inherited from BasePresenter.)
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property. (Inherited from BasePresenter.)
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
ShowActivity | Gets or sets a value indicating whether the presenter should display the name of the activity it's allocated to. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property. (Inherited from BasePresenter.)
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT). (Inherited from BasePresenter.)

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BasePresenter.)

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BasePresenter.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BasePresenter.)
OnMouseDoubleClick | Control.OnMouseDoubleClick override. (Inherited from BasePresenter.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BasePresenter.)
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override. (Inherited from BasePresenter.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from BasePresenter.)

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object. (Inherited from BasePresenter.)
Modified | Occurs when the presenter has been modified interactively. (Inherited from BasePresenter.)
Modifying | Occurs when the presenter is being modified interactively. (Inherited from BasePresenter.)

See Also

AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Fields

AllocationPresenter Fields
[image]

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property. (Inherited from BasePresenter.)
ActivityNameForegroundProperty | Identifies the ActivityNameForeground dependency property.
ClickedEvent | Identifies the Clicked routed event. (Inherited from BasePresenter.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property. (Inherited from BasePresenter.)
DurationProperty | Identifies the Duration dependency property. (Inherited from BasePresenter.)
EndTimeProperty | Identifies the EndTime dependency property. (Inherited from BasePresenter.)
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property. (Inherited from BasePresenter.)
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property. (Inherited from BasePresenter.)
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property. (Inherited from BasePresenter.)
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property. (Inherited from BasePresenter.)
FocusBrushProperty | Identifies the FocusBrush dependency property. (Inherited from BasePresenter.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BasePresenter.)
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property. (Inherited from BasePresenter.)
ModifiedEvent | Identifies the Modified routed event. (Inherited from BasePresenter.)
ModifyingEvent | Identifies the Modifying routed event. (Inherited from BasePresenter.)
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property. (Inherited from BasePresenter.)
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property. (Inherited from BasePresenter.)
ProgressLengthProperty | Identifies the ProgressLength dependency property. (Inherited from BasePresenter.)
ProgressProperty | Identifies the Progress dependency property. (Inherited from BasePresenter.)
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property. (Inherited from BasePresenter.)
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property. (Inherited from BasePresenter.)
ShowActivityProperty | Identifies the ShowActivity dependency property.
StartTimeProperty | Identifies the StartTime dependency property. (Inherited from BasePresenter.)

See Also

AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.ActivityNameForegroundProperty Field

AllocationPresenter.ActivityNameForegroundProperty Field
[image]

Identifies the ActivityNameForeground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityNameForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityNameForegroundProperty As DependencyProperty

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.ShowActivityProperty Field

AllocationPresenter.ShowActivityProperty Field
[image]

Identifies the ShowActivity dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowActivityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowActivityProperty As DependencyProperty

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Constructor

AllocationPresenter Constructor
[image]

Initializes a new instance of the AllocationPresenter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public AllocationPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Properties

AllocationPresenter Properties
[image]

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property. (Inherited from BasePresenter.)
ActivityNameForeground | Gets or sets the Foreground of the text, displaying the name of the allocated activity. This is a dependency property.
Allocation | Gets the underlying item as IResourceAllocationViewModel.
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property. (Inherited from BasePresenter.)
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Duration | Gets the duration of the item. This is a dependency property. (Inherited from BasePresenter.)
EndTime | Gets the end time of the item. This is a dependency property. (Inherited from BasePresenter.)
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property. (Inherited from BasePresenter.)
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property. (Inherited from BasePresenter.)
IsInCollision | Gets a value indicating whether the presenter collides with another allocation presenter, while both presenters display allocations for the same resource.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property. (Inherited from BasePresenter.)
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property. (Inherited from BasePresenter.)
Progress | Gets or sets the progress/completion of the item. This is a dependency property. (Inherited from BasePresenter.)
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property. (Inherited from BasePresenter.)
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property. (Inherited from BasePresenter.)
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BasePresenter.)
ShowActivity | Gets or sets a value indicating whether the presenter should display the name of the activity it's allocated to. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property. (Inherited from BasePresenter.)
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT). (Inherited from BasePresenter.)

See Also

AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.ActivityNameForeground Property

AllocationPresenter.ActivityNameForeground Property
[image]

Gets or sets the Foreground of the text, displaying the name of the allocated activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ActivityNameForeground { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityNameForeground As Brush

Property Value

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.Allocation Property

AllocationPresenter.Allocation Property
[image]

Gets the underlying item as IResourceAllocationViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IResourceAllocationViewModel Allocation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Allocation As IResourceAllocationViewModel

Property Value

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.IsInCollision Property

AllocationPresenter.IsInCollision Property
[image]

Gets a value indicating whether the presenter collides with another allocation presenter, while both presenters display allocations for the same resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsInCollision { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsInCollision As Boolean

Property Value

true indicates that the item is in collision; otherwise false

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter.ShowActivity Property

AllocationPresenter.ShowActivity Property
[image]

Gets or sets a value indicating whether the presenter should display the name of the activity it's allocated to. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowActivity { get; set; }

Visual Basic [image] Copy Code

Public Property ShowActivity As Boolean

Property Value

true to display the name of the related activity; otherwise, false.

See Also

AllocationPresenter Members
AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.AllocationPresenter Events

AllocationPresenter Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object. (Inherited from BasePresenter.)
Modified | Occurs when the presenter has been modified interactively. (Inherited from BasePresenter.)
Modifying | Occurs when the presenter is being modified interactively. (Inherited from BasePresenter.)

See Also

AllocationPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Class

BaseChart Class
[image]

The base class for all data views.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class BaseChart : Control

Visual Basic [image] Copy Code

Public Class BaseChart
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BaseChart
MindFusion.DataViews.Wpf.ActivityChart
MindFusion.DataViews.Wpf.ResourceChart

See Also

BaseChart Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Members

BaseChart Members
Constructors Fields Properties Methods Events
[image]

The base class for all data views.

The following tables list the members exposed by the BaseChart type.

Protected Constructors

Name | Description
BaseChart | Initializes a new instance of the BaseChart class.

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property.
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property.
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property.
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property.
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property.
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property.
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property.
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property.
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property.
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property.
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property.
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property.
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property.
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderForegroundProperty | Identifies the HeaderBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property.
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property.
ItemBackgroundProperty | Identifies the ItemBackground dependency property.
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property.
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property.
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property.
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property.
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property.
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property.
PopupPlacementProperty | Identifies the PopupPlacement dependency property.
PopupStyleProperty | Identifies the PopupStyle dependency property.
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property.
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property.
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property.
ShowNowProperty | Identifies the ShowNow dependency property.
ShowPopupsProperty | Identifies the ShowPopups dependency property.
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property.
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property.
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property.
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property.
TimelineHeaderProperty | Identifies the TimelineHeader dependency property.

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property.
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property.
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property.
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property.
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property.
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property.
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property.
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property.
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property.
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property.
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property.
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property.
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds.
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property.
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property.
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property.
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property.
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property.
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property.
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property.
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property.
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property.
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property.
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property.
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property.
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property.
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property.
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property.
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property.
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property.
Project | Gets the IProjectViewModel object assigned to this chart.
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property.
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property.
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property.
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property.
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property.
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property.
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property.
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property.
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property.

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state.

Public Methods

Name | Description
CreateChartImage | Creates a bitmap containing an image of the chart.
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property.
DrillIn | Overloaded. Zooms in the view.
DrillOut | Overloaded. Zooms out the view.
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
ScrollIntoView | Scrolls to a date in the schedule grid.

Protected Methods

Name | Description
OnDrilledIn | Raises the DrilledIn event.
OnDrilledOut | Raises the DrilledOut event.
OnDrillingIn | Raises the DrillingIn event.
OnDrillingOut | Raises the DrillingOut event.
OnKeyDown | UIElement.OnKeyDown override.
OnKeyUp | UIElement.OnKeyUp override.
OnLostFocus | Control.OnLostFocus override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseUp | Control.OnPreviewMouseUp override.
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override.
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event.

Public Events

Name | Description
DrilledIn | Raised when the view was drilled in.
DrilledOut | Raised when the view was drilled out.
DrillingIn | Raised when the view is currently drilling in.
DrillingOut | Raised when the view is currently drilling out.
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes.

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Fields

BaseChart Fields
[image]

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property.
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property.
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property.
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property.
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property.
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property.
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property.
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property.
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property.
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property.
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property.
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property.
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property.
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderForegroundProperty | Identifies the HeaderBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property.
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property.
ItemBackgroundProperty | Identifies the ItemBackground dependency property.
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property.
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property.
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property.
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property.
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property.
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property.
PopupPlacementProperty | Identifies the PopupPlacement dependency property.
PopupStyleProperty | Identifies the PopupStyle dependency property.
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property.
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property.
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property.
ShowNowProperty | Identifies the ShowNow dependency property.
ShowPopupsProperty | Identifies the ShowPopups dependency property.
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property.
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property.
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property.
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property.
TimelineHeaderProperty | Identifies the TimelineHeader dependency property.

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityChildrenExpressionProperty Field

BaseChart.ActivityChildrenExpressionProperty Field
[image]

Identifies the ActivityChildrenExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityChildrenExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityChildrenExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityEndTimeExpressionProperty Field

BaseChart.ActivityEndTimeExpressionProperty Field
[image]

Identifies the ActivityEndTimeExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityEndTimeExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityEndTimeExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityNameExpressionProperty Field

BaseChart.ActivityNameExpressionProperty Field
[image]

Identifies the ActivityNameExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityNameExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityNameExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityProgressExpressionProperty Field

BaseChart.ActivityProgressExpressionProperty Field
[image]

Identifies the ActivityProgressExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityProgressExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityProgressExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityStartTimeExpressionProperty Field

BaseChart.ActivityStartTimeExpressionProperty Field
[image]

Identifies the ActivityStartTimeExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityStartTimeExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityStartTimeExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationActivityExpressionProperty Field

BaseChart.AllocationActivityExpressionProperty Field
[image]

Identifies the AllocationActivityExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllocationActivityExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllocationActivityExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationEndTimeExpressionProperty Field

BaseChart.AllocationEndTimeExpressionProperty Field
[image]

Identifies the AllocationEndTimeExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllocationEndTimeExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllocationEndTimeExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationProgressExpressionProperty Field

BaseChart.AllocationProgressExpressionProperty Field
[image]

Identifies the AllocationProgressExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllocationProgressExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllocationProgressExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationResourceExpressionProperty Field

BaseChart.AllocationResourceExpressionProperty Field
[image]

Identifies the AllocationResourceExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllocationResourceExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllocationResourceExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationStartTimeExpressionProperty Field

BaseChart.AllocationStartTimeExpressionProperty Field
[image]

Identifies the AllocationStartTimeExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllocationStartTimeExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllocationStartTimeExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllowAutoScrollProperty Field

BaseChart.AllowAutoScrollProperty Field
[image]

Identifies the AllowAutoScroll dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowAutoScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowAutoScrollProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllowInfiniteScrollProperty Field

BaseChart.AllowInfiniteScrollProperty Field
[image]

Identifies the AllowInfiniteScroll dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowInfiniteScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowInfiniteScrollProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyFromExpressionProperty Field

BaseChart.DependencyFromExpressionProperty Field
[image]

Identifies the DependencyFromExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyFromExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyFromExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyToExpressionProperty Field

BaseChart.DependencyToExpressionProperty Field
[image]

Identifies the DependencyToExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyToExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyToExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyTypeExpressionProperty Field

BaseChart.DependencyTypeExpressionProperty Field
[image]

Identifies the DependencyTypeExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyTypeExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyTypeExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ExpressionConverterProperty Field

BaseChart.ExpressionConverterProperty Field
[image]

Identifies the ExpressionConverter dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpressionConverterProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpressionConverterProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBackgroundProperty Field

BaseChart.HeaderBackgroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBorderBrushProperty Field

BaseChart.HeaderBorderBrushProperty Field
[image]

Identifies the HeaderBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderBrushProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBorderThicknessProperty Field

BaseChart.HeaderBorderThicknessProperty Field
[image]

Identifies the HeaderBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderThicknessProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderContentTemplateProperty Field

BaseChart.HeaderContentTemplateProperty Field
[image]

Identifies the HeaderContentTemplate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderContentTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderContentTemplateProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderFontSizeProperty Field

BaseChart.HeaderFontSizeProperty Field
[image]

Identifies the HeaderFontSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderFontSizeProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderForegroundProperty Field

BaseChart.HeaderForegroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderForegroundProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderMarginProperty Field

BaseChart.HeaderMarginProperty Field
[image]

Identifies the HeaderMargin dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderMarginProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.IsSnappingEnabledProperty Field

BaseChart.IsSnappingEnabledProperty Field
[image]

Identifies the IsSnappingEnabled dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSnappingEnabledProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSnappingEnabledProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.IsSnappingProperty Field

BaseChart.IsSnappingProperty Field
[image]

Identifies the IsSnapping dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSnappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSnappingProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemAccentBrushProperty Field

BaseChart.ItemAccentBrushProperty Field
[image]

Identifies the ItemAccentBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemAccentBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemAccentBrushProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemBackgroundProperty Field

BaseChart.ItemBackgroundProperty Field
[image]

Identifies the ItemBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemBackgroundProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemBorderBrushProperty Field

BaseChart.ItemBorderBrushProperty Field
[image]

Identifies the ItemBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemBorderBrushProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemFocusBrushProperty Field

BaseChart.ItemFocusBrushProperty Field
[image]

Identifies the ItemFocusBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemFocusBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemFocusBrushProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemHeightProperty Field

BaseChart.ItemHeightProperty Field
[image]

Identifies the ItemHeight dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemHeightProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemLeftResizeCursorProperty Field

BaseChart.ItemLeftResizeCursorProperty Field
[image]

Identifies the ItemLeftResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemLeftResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemLeftResizeCursorProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemMouseOverBackgroundProperty Field

BaseChart.ItemMouseOverBackgroundProperty Field
[image]

Identifies the ItemMouseOverBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemMouseOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemMouseOverBackgroundProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemMouseOverBorderBrushProperty Field

BaseChart.ItemMouseOverBorderBrushProperty Field
[image]

Identifies the ItemMouseOverBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemMouseOverBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemMouseOverBorderBrushProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemProgressResizeCursorProperty Field

BaseChart.ItemProgressResizeCursorProperty Field
[image]

Identifies the ItemProgressResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemProgressResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemProgressResizeCursorProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemRightResizeCursorProperty Field

BaseChart.ItemRightResizeCursorProperty Field
[image]

Identifies the ItemRightResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemRightResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemRightResizeCursorProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.LeftPanelWidthProperty Field

BaseChart.LeftPanelWidthProperty Field
[image]

Identifies the LeftPanelWidth dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeftPanelWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LeftPanelWidthProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.PopupPlacementProperty Field

BaseChart.PopupPlacementProperty Field
[image]

Identifies the PopupPlacement dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PopupPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PopupPlacementProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.PopupStyleProperty Field

BaseChart.PopupStyleProperty Field
[image]

Identifies the PopupStyle dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PopupStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PopupStyleProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.RelativeTimelineDateProperty Field

BaseChart.RelativeTimelineDateProperty Field
[image]

Identifies the RelativeTimelineDate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RelativeTimelineDateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RelativeTimelineDateProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ResourceDescriptionExpressionProperty Field

BaseChart.ResourceDescriptionExpressionProperty Field
[image]

Identifies the ResourceDescriptionExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceDescriptionExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceDescriptionExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ResourceTitleExpressionProperty Field

BaseChart.ResourceTitleExpressionProperty Field
[image]

Identifies the ResourceTitleExpression dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceTitleExpressionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceTitleExpressionProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowNowProperty Field

BaseChart.ShowNowProperty Field
[image]

Identifies the ShowNow dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNowProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNowProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowPopupsProperty Field

BaseChart.ShowPopupsProperty Field
[image]

Identifies the ShowPopups dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPopupsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPopupsProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowStartEndIndicatorsProperty Field

BaseChart.ShowStartEndIndicatorsProperty Field
[image]

Identifies the ShowStartEndIndicators depednency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowStartEndIndicatorsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowStartEndIndicatorsProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.SnappingPointCountProperty Field

BaseChart.SnappingPointCountProperty Field
[image]

Identifies the SnappingPointCount dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnappingPointCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnappingPointCountProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineDateTimeUnitsAfterProperty Field

BaseChart.TimelineDateTimeUnitsAfterProperty Field
[image]

Identifies the TimelineDateTimeUnitsAfter dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineDateTimeUnitsAfterProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineDateTimeUnitsAfterProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineDateTimeUnitsBeforeProperty Field

BaseChart.TimelineDateTimeUnitsBeforeProperty Field
[image]

Identifies the TimelineDateTimeUnitsBefore dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineDateTimeUnitsBeforeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineDateTimeUnitsBeforeProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineHeaderProperty Field

BaseChart.TimelineHeaderProperty Field
[image]

Identifies the TimelineHeader dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineHeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineHeaderProperty As DependencyProperty

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Constructor

BaseChart Constructor
[image]

Initializes a new instance of the BaseChart class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected BaseChart ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Methods

BaseChart Methods
[image]

Public Methods

Name | Description
CreateChartImage | Creates a bitmap containing an image of the chart.
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property.
DrillIn | Overloaded. Zooms in the view.
DrillOut | Overloaded. Zooms out the view.
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
ScrollIntoView | Scrolls to a date in the schedule grid.

Protected Methods

Name | Description
OnDrilledIn | Raises the DrilledIn event.
OnDrilledOut | Raises the DrilledOut event.
OnDrillingIn | Raises the DrillingIn event.
OnDrillingOut | Raises the DrillingOut event.
OnKeyDown | UIElement.OnKeyDown override.
OnKeyUp | UIElement.OnKeyUp override.
OnLostFocus | Control.OnLostFocus override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseUp | Control.OnPreviewMouseUp override.
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override.
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event.

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.CreateChartImage Method

BaseChart.CreateChartImage Method
[image]

Creates a bitmap containing an image of the chart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public virtual BitmapSource CreateChartImage ()

Visual Basic [image] Copy Code

Public Overridable Function CreateChartImage () As BitmapSource

Return Value

A BitmapSource instance containing the image.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.CreateViewModel Method

BaseChart.CreateViewModel Method
[image]

Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IProjectViewModel CreateViewModel (
IEnumerable activites,
IEnumerable dependencies,
IEnumerable resources,
IEnumerable allocations,
Type activityType,
Type dependencyType,
Type resourceType,
Type resourceAllocationType
)

Visual Basic [image] Copy Code

Public Function CreateViewModel( _
activites As IEnumerable, _
dependencies As IEnumerable, _
resources As IEnumerable, _
allocations As IEnumerable, _
activityType As Type, _
dependencyType As Type, _
resourceType As Type, _
resourceAllocationType As Type _
) As IProjectViewModel

Parameters

activites
A .NET IEnumerable describing the activity backing store. This object needs to implement the IList interface if changes to the ViewModel are expected to reflect to the backing store. This object needs to implement INotifyCollectionChanged if changes to the backing store are expected to reflect to the ViewModel.
dependencies
A .NET IEnumerable describing the dependency backing store. This object needs to implement the IList interface if changes to the ViewModel are expected to reflect to the backing store. This object needs to implement INotifyCollectionChanged if changes to the backing store are expected to reflect to the ViewModel.
resources
A .NET IEnumerable describing the resource backing store. This object needs to implement the IList interface if changes to the ViewModel are expected to reflect to the backing store. This object needs to implement INotifyCollectionChanged if changes to the backing store are expected to reflect to the ViewModel.
allocations
A .NET IEnumerable describing the resource allocations backing store. This object needs to implement the IList interface if changes to the ViewModel are expected to reflect to the backing store. This object needs to implement INotifyCollectionChanged if changes to the backing store are expected to reflect to the ViewModel.
activityType
The Type of new activities created through the ViewModel. If this parameter is null (Nothing in Visual Basic) the newly created activities are of type Activity.
dependencyType
The Type of new dependencies created through the ViewModel. If this parameter is null (Nothing in Visual Basic) the newly created dependencies are of type Dependency.
resourceType
The Type of new resources created through the ViewModel. If this parameter is null (Nothing in Visual Basic) the newly created resources are of type Resource.
resourceAllocationType
The Type of new resource allocations created through the ViewModel. If this parameter is null (Nothing in Visual Basic) the newly created allocations are of type ResourceAllocation.

Return Value

A built-in implementation of the IProjectViewModel interface wrapping the specified sources.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillIn Method

BaseChart.DrillIn Method
[image]

Zooms in the view.

Overload List

Name | Description
BaseChart.DrillIn () | Zooms the view in with one predefined step.
BaseChart.DrillIn (DateTime) | Zooms the view in with one predefined step at the specified relative date.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillIn Method ()

BaseChart.DrillIn Method ()
See Also
[image]

Zooms the view in with one predefined step.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillIn ()

Visual Basic [image] Copy Code

Public Sub DrillIn ()

See Also

DrillIn Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillIn Method (DateTime)

BaseChart.DrillIn Method (DateTime)
See Also
[image]

Zooms the view in with one predefined step at the specified relative date.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillIn (
DateTime relativeDate
)

Visual Basic [image] Copy Code

Public Sub DrillIn( _
relativeDate As DateTime _
)

Parameters

relativeDate
The relative date to be visible after the zoom operation.

See Also

DrillIn Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillOut Method

BaseChart.DrillOut Method
[image]

Zooms out the view.

Overload List

Name | Description
BaseChart.DrillOut () | Zooms the view out with one predefined step.
BaseChart.DrillOut (DateTime) | Zooms the view out with one predefined step at the specified relative date.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillOut Method ()

BaseChart.DrillOut Method ()
See Also
[image]

Zooms the view out with one predefined step.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillOut ()

Visual Basic [image] Copy Code

Public Sub DrillOut ()

See Also

DrillOut Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillOut Method (DateTime)

BaseChart.DrillOut Method (DateTime)
See Also
[image]

Zooms the view out with one predefined step at the specified relative date.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillOut (
DateTime relativeDate
)

Visual Basic [image] Copy Code

Public Sub DrillOut( _
relativeDate As DateTime _
)

Parameters

relativeDate
The relative date to be visible after the zoom operation.

See Also

DrillOut Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillTo Method

BaseChart.DrillTo Method
[image]

Zooms the view to a specified relative date, specifying the settings for the bottom timeline.

Overload List

Name | Description
BaseChart.DrillTo (DateTime, DateTime, TimelineSettings) | Zooms the view to a specified date interval, specifying the settings for the bottom timeline.
BaseChart.DrillTo (DateTime, TimelineSettings) | Zooms the view to a specified relative date, specifying the settings for the bottom timeline.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillTo Method (DateTime, DateTime, TimelineSettings)

BaseChart.DrillTo Method (DateTime, DateTime, TimelineSettings)
See Also
[image]

Zooms the view to a specified date interval, specifying the settings for the bottom timeline.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillTo (
DateTime startDate,
DateTime endDate,
TimelineSettings drillToSettings
)

Visual Basic [image] Copy Code

Public Sub DrillTo( _
startDate As DateTime, _
endDate As DateTime, _
drillToSettings As TimelineSettings _
)

Parameters

startDate

A DateTime value.

endDate

A DateTime value.

drillToSettings

The desired settings for the bottom timeline.

See Also

DrillTo Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DrillTo Method (DateTime, TimelineSettings)

BaseChart.DrillTo Method (DateTime, TimelineSettings)
See Also
[image]

Zooms the view to a specified relative date, specifying the settings for the bottom timeline.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void DrillTo (
DateTime relativeDate,
TimelineSettings drillToSettings
)

Visual Basic [image] Copy Code

Public Sub DrillTo ( _
relativeDate As DateTime, _
drillToSettings As TimelineSettings _
)

Parameters

relativeDate
The date to scroll to.
drillToSettings

The desired settings for the bottom timeline.

See Also

DrillTo Method Overload List
BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnApplyTemplate Method

BaseChart.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnDrilledIn Method

BaseChart.OnDrilledIn Method
[image]

Raises the DrilledIn event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrilledIn (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrilledIn( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnDrilledOut Method

BaseChart.OnDrilledOut Method
[image]

Raises the DrilledOut event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrilledOut (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrilledOut( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnDrillingIn Method

BaseChart.OnDrillingIn Method
[image]

Raises the DrillingIn event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrillingIn (
ProjectValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrillingIn ( _
e As ProjectValidationEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnDrillingOut Method

BaseChart.OnDrillingOut Method
[image]

Raises the DrillingOut event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrillingOut (
ProjectValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrillingOut ( _
e As ProjectValidationEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnKeyDown Method

BaseChart.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnKeyUp Method

BaseChart.OnKeyUp Method
[image]

UIElement.OnKeyUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyUp (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyUp( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnLostFocus Method

BaseChart.OnLostFocus Method
[image]

Control.OnLostFocus override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnLostFocus (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLostFocus( _
e As RoutedEventArgs _
)

Parameters

e
The RoutedEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnMouseLeftButtonDown Method

BaseChart.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnMouseLeftButtonUp Method

BaseChart.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseLeftButtonUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnMouseMove Method

BaseChart.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnPreviewMouseLeftButtonUp Method

BaseChart.OnPreviewMouseLeftButtonUp Method
[image]

UIElement.OnPreviewMouseLeftButtonUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnPreviewMouseUp Method

BaseChart.OnPreviewMouseUp Method
[image]

Control.OnPreviewMouseUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnPreviewMouseWheel Method

BaseChart.OnPreviewMouseWheel Method
[image]

UIElement.OnPreviewMouseWheel override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseWheel (
MouseWheelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseWheel( _
e As MouseWheelEventArgs _
)

Parameters

e
The MouseWheelEventArgs that contains the event data.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.OnRelativeTimelineDateChanged Method

BaseChart.OnRelativeTimelineDateChanged Method
[image]

Raises the RelativeTimelineDateChanged event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected void OnRelativeTimelineDateChanged (
DateChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnRelativeTimelineDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e
The DateChangedEventArgs associated with the event.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ScrollIntoView Method

BaseChart.ScrollIntoView Method
[image]

Scrolls to a date in the schedule grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void ScrollIntoView (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub ScrollIntoView( _
date As DateTime _
)

Parameters

date
The date to scroll to.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Properties

BaseChart Properties
[image]

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property.
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property.
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property.
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property.
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property.
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property.
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property.
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property.
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property.
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property.
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property.
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property.
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds.
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property.
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property.
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property.
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property.
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property.
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property.
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property.
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property.
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property.
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property.
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property.
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property.
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property.
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property.
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property.
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property.
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property.
Project | Gets the IProjectViewModel object assigned to this chart.
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property.
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property.
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property.
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property.
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property.
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property.
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property.
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property.
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property.

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state.

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityChildrenExpression Property

BaseChart.ActivityChildrenExpression Property
[image]

Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityChildrenExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityChildrenExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityEndTimeExpression Property

BaseChart.ActivityEndTimeExpression Property
[image]

Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityEndTimeExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityEndTimeExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityNameExpression Property

BaseChart.ActivityNameExpression Property
[image]

Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityNameExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityNameExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityProgressExpression Property

BaseChart.ActivityProgressExpression Property
[image]

Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityProgressExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityProgressExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ActivityStartTimeExpression Property

BaseChart.ActivityStartTimeExpression Property
[image]

Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityStartTimeExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityStartTimeExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationActivityExpression Property

BaseChart.AllocationActivityExpression Property
[image]

Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string AllocationActivityExpression { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationActivityExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationEndTimeExpression Property

BaseChart.AllocationEndTimeExpression Property
[image]

Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string AllocationEndTimeExpression { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationEndTimeExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationProgressExpression Property

BaseChart.AllocationProgressExpression Property
[image]

Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string AllocationProgressExpression { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationProgressExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationResourceExpression Property

BaseChart.AllocationResourceExpression Property
[image]

Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string AllocationResourceExpression { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationResourceExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllocationStartTimeExpression Property

BaseChart.AllocationStartTimeExpression Property
[image]

Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string AllocationStartTimeExpression { get; set; }

Visual Basic [image] Copy Code

Public Property AllocationStartTimeExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllowAutoScroll Property

BaseChart.AllowAutoScroll Property
[image]

Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowAutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAutoScroll As Boolean

Property Value

true to allow autoscrolling while interacting with the elements in the chart; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AllowInfiniteScroll Property

BaseChart.AllowInfiniteScroll Property
[image]

Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowInfiniteScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInfiniteScroll As Boolean

Property Value

true to allow scrolling outside of the currently displayed time interval; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.AutoScrollSpeed Property

BaseChart.AutoScrollSpeed Property
[image]

Gets or sets the auto scrolling speed, in milliseconds.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double AutoScrollSpeed { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScrollSpeed As Double

Property Value

A double value, specifying the auto-scrolling speed.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.Columns Property

BaseChart.Columns Property
[image]

Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IList<GridColumn> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As IList(Of GridColumn)

Property Value

An instance of the GridColumn class.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyFromExpression Property

BaseChart.DependencyFromExpression Property
[image]

Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string DependencyFromExpression { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyFromExpression As String

Property Value

A string value.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyToExpression Property

BaseChart.DependencyToExpression Property
[image]

Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string DependencyToExpression { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyToExpression As String

Property Value

A string value.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.DependencyTypeExpression Property

BaseChart.DependencyTypeExpression Property
[image]

Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string DependencyTypeExpression { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyTypeExpression As String

Property Value

A string value.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ExpressionConverter Property

BaseChart.ExpressionConverter Property
[image]

Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IValueConverter ExpressionConverter { get; set; }

Visual Basic [image] Copy Code

Public Property ExpressionConverter As IValueConverter

Property Value

An IValueConverter object.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBackground Property

BaseChart.HeaderBackground Property
[image]

Gets or sets the brush used to fill the header background. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBackground As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBorderBrush Property

BaseChart.HeaderBorderBrush Property
[image]

Gets or sets border brush of the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderBrush As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderBorderThickness Property

BaseChart.HeaderBorderThickness Property
[image]

Gets or sets the border thickness of the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderThickness As Thickness

Property Value

A Thickness object.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderContentTemplate Property

BaseChart.HeaderContentTemplate Property
[image]

Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderContentTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderContentTemplate As DataTemplate

Property Value

A WPF DataTemplate.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderFontSize Property

BaseChart.HeaderFontSize Property
[image]

Gets or sets the size of the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double HeaderFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFontSize As Double

Property Value

A double value.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderForeground Property

BaseChart.HeaderForeground Property
[image]

Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderForeground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderForeground As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.HeaderMargin Property

BaseChart.HeaderMargin Property
[image]

Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderMargin { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderMargin As Thickness

Property Value

A Thickness object.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.IsAutoScrolling Property

BaseChart.IsAutoScrolling Property
[image]

Gets or sets the current autoscrolling state.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected bool IsAutoScrolling { get; set; }

Visual Basic [image] Copy Code

Protected Property IsAutoScrolling As Boolean

Property Value

true if the control is currently auto-scrolling; otherwise, false.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.IsSnapping Property

BaseChart.IsSnapping Property
[image]

Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsSnapping { get; set; }

Visual Basic [image] Copy Code

Public Property IsSnapping As Boolean

Property Value

true if snapping will happen during interaction; otherwise, false.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.IsSnappingEnabled Property

BaseChart.IsSnappingEnabled Property
[image]

Gets or sets a value indicating whether item snapping is enabled. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsSnappingEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsSnappingEnabled As Boolean

Property Value

true if snapping is enabled; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemAccentBrush Property

BaseChart.ItemAccentBrush Property
[image]

Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemAccentBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ItemAccentBrush As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemBackground Property

BaseChart.ItemBackground Property
[image]

Gets or sets the background of the items in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ItemBackground As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemBorderBrush Property

BaseChart.ItemBorderBrush Property
[image]

Gets or sets the border brush of the items in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ItemBorderBrush As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemFocusBrush Property

BaseChart.ItemFocusBrush Property
[image]

Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemFocusBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ItemFocusBrush As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemHeight Property

BaseChart.ItemHeight Property
[image]

Gets or sets the height of the items in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ItemHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ItemHeight As Double

Property Value

A double value. The default is 16.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemLeftResizeCursor Property

BaseChart.ItemLeftResizeCursor Property
[image]

Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor ItemLeftResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property ItemLeftResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemMouseOverBackground Property

BaseChart.ItemMouseOverBackground Property
[image]

Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemMouseOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseOverBackground As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemMouseOverBorderBrush Property

BaseChart.ItemMouseOverBorderBrush Property
[image]

Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ItemMouseOverBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseOverBorderBrush As Brush

Property Value

A WPF Brush.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemProgressResizeCursor Property

BaseChart.ItemProgressResizeCursor Property
[image]

Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor ItemProgressResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property ItemProgressResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ItemRightResizeCursor Property

BaseChart.ItemRightResizeCursor Property
[image]

Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor ItemRightResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property ItemRightResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.LeftPanelWidth Property

BaseChart.LeftPanelWidth Property
[image]

Gets or sets the width of the left panel in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double LeftPanelWidth { get; set; }

Visual Basic [image] Copy Code

Public Property LeftPanelWidth As Double

Property Value

A double value specifying the width of the left panel. The default is 500.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.PopupPlacement Property

BaseChart.PopupPlacement Property
[image]

Gets or sets the placement position of item popups in a chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public PopupPlacement PopupPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property PopupPlacement As PopupPlacement

Property Value

A member of the PopupPlacement enumeration. The default is Static.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.PopupStyle Property

BaseChart.PopupStyle Property
[image]

Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Style PopupStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PopupStyle As Style

Property Value

A WPF Style.

Remarks

The default style of the popup is demonstrated below:

XAML [image] Copy Code

<Style TargetType="local:SchedulePopupContent">
<Setter Property="BorderBrush" Value="{StaticResource PopupContentBorderBrush}" />
<Setter Property="BorderThickness" Value="1" />
<Setter Property="Background" Value="{StaticResource PopupContentBackgroundBrush}" />
<Setter Property="Padding" Value="2" />
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:SchedulePopupContent">
<Border Background="{TemplateBinding Background}" BorderBrush="{TemplateBinding BorderBrush}" BorderThickness="{TemplateBinding BorderThickness}" Padding="{TemplateBinding Padding}">
<StackPanel Orientation="Vertical">
<StackPanel Name="NameContainer" Orientation="Horizontal">
<TextBlock Text="{Binding DataContext.ActivityName}" FontWeight="Bold" />
<TextBlock Text=" (" />
<TextBlock Text="{Binding DataContext.ScheduleMode}" />
<TextBlock Text=")" />
</StackPanel>
<StackPanel Name="StartTimeContainer" Orientation="Horizontal">
<TextBlock Text="Start time: " />
<TextBlock Text="{Binding ExpectedStartTime}" />
</StackPanel>
<StackPanel Name="EndTimeContainer" Orientation="Horizontal">
<TextBlock Text="End time: " />
<TextBlock Text="{Binding ExpectedEndTime}" />
</StackPanel>
<StackPanel Name="DurationContainer" Orientation="Horizontal">
<TextBlock Text="Duration: " />
<TextBlock Text="{Binding ExpectedDuration}" />
</StackPanel>
<StackPanel Name="ProgressContainer" Orientation="Horizontal" >
<TextBlock Text="Progress: " />
<TextBlock Text="{Binding ExpectedProgress}" />
</StackPanel>
</StackPanel>
</Border>
<ControlTemplate.Triggers>
<Trigger Property="Action" Value="ResizeStart">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="ResizeEnd">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="Move">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Visible" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Collapsed" />
</Trigger>
<Trigger Property="Action" Value="ResizeProgress">
<Setter TargetName="StartTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="EndTimeContainer" Property="Visibility" Value="Collapsed" />
<Setter TargetName="ProgressContainer" Property="Visibility" Value="Visible" />
</Trigger>
</ControlTemplate.Triggers>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The style references several static resources, which are theme-specific.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.Project Property

BaseChart.Project Property
[image]

Gets the IProjectViewModel object assigned to this chart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IProjectViewModel Project { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Project As IProjectViewModel

Property Value

An implementation of the IProjectViewModel interface.

Remarks

This auxiliary property effectively returns the chart's DataContext cast to IProjectViewModel.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.RelativeTimelineDate Property

BaseChart.RelativeTimelineDate Property
[image]

Gets or sets the relative date of the timeline in the right grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime RelativeTimelineDate { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTimelineDate As DateTime

Property Value

A .NET DateTime object.

Remarks

This property, along with TimelineDateTimeUnitsBefore and TimelineDateTimeUnitsAfter, specify the currently displayed time interval.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ResourceDescriptionExpression Property

BaseChart.ResourceDescriptionExpression Property
[image]

Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ResourceDescriptionExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ResourceDescriptionExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ResourceTitleExpression Property

BaseChart.ResourceTitleExpression Property
[image]

Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ResourceTitleExpression { get; set; }

Visual Basic [image] Copy Code

Public Property ResourceTitleExpression As String

Property Value

A WPF BindingExpression.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowNow Property

BaseChart.ShowNow Property
[image]

Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowNow { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNow As Boolean

Property Value

true to display the current time; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowPopups Property

BaseChart.ShowPopups Property
[image]

Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowPopups { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPopups As Boolean

Property Value

true to display popups; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.ShowStartEndIndicators Property

BaseChart.ShowStartEndIndicators Property
[image]

Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowStartEndIndicators { get; set; }

Visual Basic [image] Copy Code

Public Property ShowStartEndIndicators As Boolean

Property Value

true to show project's start and end; otherwise, false. The default is true.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.SnappingPointCount Property

BaseChart.SnappingPointCount Property
[image]

Gets or sets the number of snapping point within each timeline cell. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int SnappingPointCount { get; set; }

Visual Basic [image] Copy Code

Public Property SnappingPointCount As Integer

Property Value

An integer value specifying the number of snapping points when IsSnappingEnabled is set to true. The default is 3.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineDateTimeUnitsAfter Property

BaseChart.TimelineDateTimeUnitsAfter Property
[image]

Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int TimelineDateTimeUnitsAfter { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineDateTimeUnitsAfter As Integer

Property Value

An integer value.

Remarks

This property, along with RelativeTimelineDate and TimelineDateTimeUnitsBefore, specify the currently displayed time interval.

Note

This value may be adjusted internally if the resulting width of the Timeline is too short.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineDateTimeUnitsBefore Property

BaseChart.TimelineDateTimeUnitsBefore Property
[image]

Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int TimelineDateTimeUnitsBefore { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineDateTimeUnitsBefore As Integer

Property Value

This property, along with RelativeTimelineDate and TimelineDateTimeUnitsAfter, specify the currently displayed time interval.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart.TimelineHeader Property

BaseChart.TimelineHeader Property
[image]

Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineHeader TimelineHeader { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineHeader As TimelineHeader

Property Value

An instance of the TimelineHeader class.

See Also

BaseChart Members
BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BaseChart Events

BaseChart Events
[image]

Public Events

Name | Description
DrilledIn | Raised when the view was drilled in.
DrilledOut | Raised when the view was drilled out.
DrillingIn | Raised when the view is currently drilling in.
DrillingOut | Raised when the view is currently drilling out.
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes.

See Also

BaseChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Class

BasePresenter Class
[image]

The base class for activity and allocation presenters.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract class BasePresenter : Control

Visual Basic [image] Copy Code

Public MustInherit Class BasePresenter
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BasePresenter
MindFusion.DataViews.Wpf.ActivityPresenter
MindFusion.DataViews.Wpf.AllocationPresenter

See Also

BasePresenter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Members

BasePresenter Members
Constructors Fields Properties Methods Events
[image]

The base class for activity and allocation presenters.

The following tables list the members exposed by the BasePresenter type.

Protected Constructors

Name | Description
BasePresenter | Initializes a new instance of the BasePresenter class.

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property.
ClickedEvent | Identifies the Clicked routed event.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property.
DurationProperty | Identifies the Duration dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property.
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property.
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property.
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property.
FocusBrushProperty | Identifies the FocusBrush dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property.
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property.
ModifiedEvent | Identifies the Modified routed event.
ModifyingEvent | Identifies the Modifying routed event.
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property.
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property.
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property.
ProgressLengthProperty | Identifies the ProgressLength dependency property.
ProgressProperty | Identifies the Progress dependency property.
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property.
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property.
StartTimeProperty | Identifies the StartTime dependency property.

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property.
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property.
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property.
Duration | Gets the duration of the item. This is a dependency property.
EndTime | Gets the end time of the item. This is a dependency property.
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property.
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property.
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property.
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property.
Progress | Gets or sets the progress/completion of the item. This is a dependency property.
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property.
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property.
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property.
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property.
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT).

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.
OnKeyUp | UIElement.OnKeyUp override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseDown | UIElement.OnMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object.
Modified | Occurs when the presenter has been modified interactively.
Modifying | Occurs when the presenter is being modified interactively.

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Fields

BasePresenter Fields
[image]

Public Fields

Name | Description
AccentBrushProperty | Identifies the AccentBrush dependency property.
ClickedEvent | Identifies the Clicked routed event.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DependencyAnchorCursorProperty | Identifies the DependencyAnchorCursor dependency property.
DurationProperty | Identifies the Duration dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpectedDurationProperty | Identifies the ExpectedDuration dependency property.
ExpectedEndTimeProperty | Identifies the ExpectedEndTime dependency property.
ExpectedProgressProperty | Identifies the ExpectedProgress dependency property.
ExpectedStartTimeProperty | Identifies the ExpectedStartTime dependency property.
FocusBrushProperty | Identifies the FocusBrush dependency property.
IsSnappingProperty | Identifies the IsSnapping dependency property.
LeftResizeCursorProperty | Identifies the LeftResizeCursor dependency property.
ModifiedEvent | Identifies the Modified routed event.
ModifyingEvent | Identifies the Modifying routed event.
MouseOverBackgroundProperty | Identifies the MouseOverBackground dependency property.
MouseOverBorderBrushProperty | Identifies the MouseOverBorderBrush dependency property.
ProgressBackgroundProperty | Identifies the ProgressBackground dependency property.
ProgressLengthProperty | Identifies the ProgressLength dependency property.
ProgressProperty | Identifies the Progress dependency property.
ProgressResizeCursorProperty | Identifies the ProgressResizeCursor dependency property.
RightResizeCursorProperty | Identifies the RightResizeCursor dependency property.
StartTimeProperty | Identifies the StartTime dependency property.

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.AccentBrushProperty Field

BasePresenter.AccentBrushProperty Field
[image]

Identifies the AccentBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AccentBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AccentBrushProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ClickedEvent Field

BasePresenter.ClickedEvent Field
[image]

Identifies the Clicked routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ClickedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ClickedEvent As RoutedEvent

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.CornerRadiusProperty Field

BasePresenter.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.DependencyAnchorCursorProperty Field

BasePresenter.DependencyAnchorCursorProperty Field
[image]

Identifies the DependencyAnchorCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyAnchorCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyAnchorCursorProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.DurationProperty Field

BasePresenter.DurationProperty Field
[image]

Identifies the Duration dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DurationProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.EndTimeProperty Field

BasePresenter.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedDurationProperty Field

BasePresenter.ExpectedDurationProperty Field
[image]

Identifies the ExpectedDuration dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpectedDurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpectedDurationProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedEndTimeProperty Field

BasePresenter.ExpectedEndTimeProperty Field
[image]

Identifies the ExpectedEndTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpectedEndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpectedEndTimeProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedProgressProperty Field

BasePresenter.ExpectedProgressProperty Field
[image]

Identifies the ExpectedProgress dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpectedProgressProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpectedProgressProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedStartTimeProperty Field

BasePresenter.ExpectedStartTimeProperty Field
[image]

Identifies the ExpectedStartTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpectedStartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpectedStartTimeProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.FocusBrushProperty Field

BasePresenter.FocusBrushProperty Field
[image]

Identifies the FocusBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FocusBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FocusBrushProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.IsSnappingProperty Field

BasePresenter.IsSnappingProperty Field
[image]

Identifies the IsSnapping dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSnappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSnappingProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.LeftResizeCursorProperty Field

BasePresenter.LeftResizeCursorProperty Field
[image]

Identifies the LeftResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeftResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LeftResizeCursorProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ModifiedEvent Field

BasePresenter.ModifiedEvent Field
[image]

Identifies the Modified routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ModifiedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ModifiedEvent As RoutedEvent

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ModifyingEvent Field

BasePresenter.ModifyingEvent Field
[image]

Identifies the Modifying routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ModifyingEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ModifyingEvent As RoutedEvent

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.MouseOverBackgroundProperty Field

BasePresenter.MouseOverBackgroundProperty Field
[image]

Identifies the MouseOverBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MouseOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MouseOverBackgroundProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.MouseOverBorderBrushProperty Field

BasePresenter.MouseOverBorderBrushProperty Field
[image]

Identifies the MouseOverBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MouseOverBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MouseOverBorderBrushProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressBackgroundProperty Field

BasePresenter.ProgressBackgroundProperty Field
[image]

Identifies the ProgressBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressBackgroundProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressLengthProperty Field

BasePresenter.ProgressLengthProperty Field
[image]

Identifies the ProgressLength dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressLengthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressLengthProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressProperty Field

BasePresenter.ProgressProperty Field
[image]

Identifies the Progress dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressResizeCursorProperty Field

BasePresenter.ProgressResizeCursorProperty Field
[image]

Identifies the ProgressResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressResizeCursorProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.RightResizeCursorProperty Field

BasePresenter.RightResizeCursorProperty Field
[image]

Identifies the RightResizeCursor dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RightResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RightResizeCursorProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.StartTimeProperty Field

BasePresenter.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Constructor

BasePresenter Constructor
[image]

Initializes a new instance of the BasePresenter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected BasePresenter ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Methods

BasePresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.
OnKeyUp | UIElement.OnKeyUp override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseDown | UIElement.OnMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnApplyTemplate Method

BasePresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnKeyDown Method

BasePresenter.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnKeyUp Method

BasePresenter.OnKeyUp Method
[image]

UIElement.OnKeyUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyUp (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyUp( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnMouseDoubleClick Method

BasePresenter.OnMouseDoubleClick Method
[image]

Control.OnMouseDoubleClick override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDoubleClick (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDoubleClick( _
e As MouseButtonEventArgs _
)

Parameters

e

The event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnMouseDown Method

BasePresenter.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnPreviewMouseMove Method

BasePresenter.OnPreviewMouseMove Method
[image]

UIElement.OnPreviewMouseMove override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.OnPreviewMouseUp Method

BasePresenter.OnPreviewMouseUp Method
[image]

UIElement.OnPreviewMouseUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Properties

BasePresenter Properties
[image]

Public Properties

Name | Description
AccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property.
CornerRadius | Gets or sets the radius of the corners of this presenter. This is a dependency property.
DependencyAnchorCursor | Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property.
Duration | Gets the duration of the item. This is a dependency property.
EndTime | Gets the end time of the item. This is a dependency property.
ExpectedDuration | Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedEndTime | Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedProgress | Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
ExpectedStartTime | Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.
FocusBrush | Gets or sets the brush of the focus indicator of the item. This is a dependency property.
IsSnapping | Gets or sets a value indicating whether snapping is enabled. This is a dependency property.
LeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property.
MouseOverBackground | Gets or sets the background of the item when the user points it with the mouse. This is a dependency property.
MouseOverBorderBrush | Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property.
Progress | Gets or sets the progress/completion of the item. This is a dependency property.
ProgressBackground | Gets or sets the background brush of the progress indicator. This is a dependency property.
ProgressLength | Gets the calculated length of the progress indicator. This is a dependency property.
ProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property.
RightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property.
StartTime | Gets the start time of the item. This is a dependency property.
TimeResolution | Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT).

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.AccentBrush Property

BasePresenter.AccentBrush Property
[image]

Gets or sets the brush used for special parts such as the start and end brackets of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush AccentBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AccentBrush As Brush

Property Value

A WPF Brush.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.CornerRadius Property

BasePresenter.CornerRadius Property
[image]

Gets or sets the radius of the corners of this presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

A double value specifying the roundness.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.DependencyAnchorCursor Property

BasePresenter.DependencyAnchorCursor Property
[image]

Gets or sets the cursor to display when the user is creating a new dependency or when the user is pointing one of the anchors with the mouse. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor DependencyAnchorCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyAnchorCursor As Cursor

Property Value

A WPF Cursor.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.Duration Property

BasePresenter.Duration Property
[image]

Gets the duration of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeSpan Duration { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Duration As TimeSpan

Property Value

A .NET TimeSpan object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.EndTime Property

BasePresenter.EndTime Property
[image]

Gets the end time of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedDuration Property

BasePresenter.ExpectedDuration Property
[image]

Gets or sets the expected Duration of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeSpan ExpectedDuration { get; set; }

Visual Basic [image] Copy Code

Public Property ExpectedDuration As TimeSpan

Property Value

A .NET TimeSpan object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedEndTime Property

BasePresenter.ExpectedEndTime Property
[image]

Gets or sets the expected EndTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime ExpectedEndTime { get; set; }

Visual Basic [image] Copy Code

Public Property ExpectedEndTime As DateTime

Property Value

A .NET DateTime object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedProgress Property

BasePresenter.ExpectedProgress Property
[image]

Gets or sets the expected Progress of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ExpectedProgress { get; set; }

Visual Basic [image] Copy Code

Public Property ExpectedProgress As Double

Property Value

A double value.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ExpectedStartTime Property

BasePresenter.ExpectedStartTime Property
[image]

Gets or sets the expected StartTime of the item at the end of the current interaction. This property is only relevant during user interaction. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime ExpectedStartTime { get; set; }

Visual Basic [image] Copy Code

Public Property ExpectedStartTime As DateTime

Property Value

A .NET DateTime object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.FocusBrush Property

BasePresenter.FocusBrush Property
[image]

Gets or sets the brush of the focus indicator of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush FocusBrush { get; set; }

Visual Basic [image] Copy Code

Public Property FocusBrush As Brush

Property Value

A WPF Brush.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.IsSnapping Property

BasePresenter.IsSnapping Property
[image]

Gets or sets a value indicating whether snapping is enabled. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsSnapping { get; set; }

Visual Basic [image] Copy Code

Public Property IsSnapping As Boolean

Property Value

true if snapping is enabled; otherwise, false.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.LeftResizeCursor Property

BasePresenter.LeftResizeCursor Property
[image]

Gets or sets the cursor to display when the user is resizing the start of the item or when the user is about to start a resizing operation. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor LeftResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property LeftResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.MouseOverBackground Property

BasePresenter.MouseOverBackground Property
[image]

Gets or sets the background of the item when the user points it with the mouse. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush MouseOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property MouseOverBackground As Brush

Property Value

A WPF Brush.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.MouseOverBorderBrush Property

BasePresenter.MouseOverBorderBrush Property
[image]

Gets or sets the border brush of the item when the user points it with the mouse. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush MouseOverBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property MouseOverBorderBrush As Brush

Property Value

A WPF Brush.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.Progress Property

BasePresenter.Progress Property
[image]

Gets or sets the progress/completion of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Progress As Double

Property Value

A double value.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressBackground Property

BasePresenter.ProgressBackground Property
[image]

Gets or sets the background brush of the progress indicator. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ProgressBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ProgressBackground As Brush

Property Value

A WPF Brush.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressLength Property

BasePresenter.ProgressLength Property
[image]

Gets the calculated length of the progress indicator. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ProgressLength { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ProgressLength As Double

Property Value

A double value specifying the width of the horizontal progress indicator.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.ProgressResizeCursor Property

BasePresenter.ProgressResizeCursor Property
[image]

Gets or sets the cursor to display when the user is modifying the progress of the item or when the user is about to start a modification. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor ProgressResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property ProgressResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.RightResizeCursor Property

BasePresenter.RightResizeCursor Property
[image]

Gets or sets the cursor to display when the user is resizing the end of the item or when the user is about to start a resizing operation. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Cursor RightResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property RightResizeCursor As Cursor

Property Value

A WPF Cursor.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.StartTime Property

BasePresenter.StartTime Property
[image]

Gets the start time of the item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter.TimeResolution Property

BasePresenter.TimeResolution Property
[image]

Gets the time resolution in the panel containing this presenter, expressed as DIPs per tick (DPT).

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double TimeResolution { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TimeResolution As Double

Property Value

A double value specifying the resolution in the parent chart.

See Also

BasePresenter Members
BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenter Events

BasePresenter Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object.
Modified | Occurs when the presenter has been modified interactively.
Modifying | Occurs when the presenter is being modified interactively.

See Also

BasePresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenterEventArgs Class

BasePresenterEventArgs Class
[image]

Contains the arguments passed to handlers of base presenter-related events.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class BasePresenterEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class BasePresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.BasePresenterEventArgs

See Also

BasePresenterEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenterEventArgs Members

BasePresenterEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of base presenter-related events.

The following tables list the members exposed by the BasePresenterEventArgs type.

Public Constructors

Name | Description
BasePresenterEventArgs | Initializes a new instance of the BasePresenterEventArgs class.

Public Properties

Name | Description
Presenter | Gets the presenter related to the event.

See Also

BasePresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenterEventArgs Constructor

BasePresenterEventArgs Constructor
[image]

Initializes a new instance of the BasePresenterEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BasePresenterEventArgs (
BasePresenter presenter
)

Visual Basic [image] Copy Code

Public New ( _
presenter As BasePresenter _
)

Parameters

presenter

The presenter related to the event.

See Also

BasePresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenterEventArgs Properties

BasePresenterEventArgs Properties
[image]

Public Properties

Name | Description
Presenter | Gets the presenter related to the event.

See Also

BasePresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BasePresenterEventArgs.Presenter Property

BasePresenterEventArgs.Presenter Property
[image]

Gets the presenter related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BasePresenter Presenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Presenter As BasePresenter

Property Value

See Also

BasePresenterEventArgs Members
BasePresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Class

BoolColumn Class
[image]

A column in a DataGrid which displays boolean values.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class BoolColumn : GridColumn

Visual Basic [image] Copy Code

Public Class BoolColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.BoolColumn

See Also

BoolColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Members

BoolColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays boolean values.

The following tables list the members exposed by the BoolColumn type.

Public Constructors

Name | Description
BoolColumn | Overloaded.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Constructor

BoolColumn Constructor
[image]

Overload List

Name | Description
BoolColumn (ItemPropertyInfo) | Initializes a new instance of the BoolColumn class.
BoolColumn (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object) | Initializes a new instance of the BoolColumn class.

See Also

BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Constructor (ItemPropertyInfo)

BoolColumn Constructor (ItemPropertyInfo)
See Also
[image]

Initializes a new instance of the BoolColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BoolColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

BoolColumn Constructor Overload List
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)

BoolColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)
See Also
[image]

Initializes a new instance of the BoolColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BoolColumn (
ItemPropertyInfo propertyInfo,
IValueConverter viewerConverter,
Object viewerConverterParam,
IValueConverter editorConverter,
Object editorConverterParam
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo, _
viewerConverter As IValueConverter, _
viewerConverterParam As Object, _
editorConverter As IValueConverter, _
editorConverterParam As Object _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.
viewerConverter
An IValueConverter that will be used in the viewer-data bound relationship in this column.
viewerConverterParam
The converter parameter that will be used by viewerConverter.
editorConverter
An IValueConverter that will be used in the editor-data bound relationship in this column.
editorConverterParam

The converter parameter that will be used by editorConverter.

See Also

BoolColumn Constructor Overload List
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn Methods

BoolColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.CancelEdit Method

BoolColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.CommitEdit Method

BoolColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.ConfirmBeginEdit Method

BoolColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.CreateEditor Method

BoolColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.CreateViewer Method

BoolColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolColumn.InitEditor Method

BoolColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

BoolColumn Members
BoolColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter Class

BoolToVisibilityConverter Class
[image]

Implements bidirectional bool to Visibility conversion.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class BoolToVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class BoolToVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.BoolToVisibilityConverter

See Also

BoolToVisibilityConverter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter Members

BoolToVisibilityConverter Members
Constructors Methods
[image]

Implements bidirectional bool to Visibility conversion.

The following tables list the members exposed by the BoolToVisibilityConverter type.

Public Constructors

Name | Description
BoolToVisibilityConverter | Initializes a new instance of the BoolToVisibilityConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation
ConvertBack | IValueConverter.ConvertBack implementation

See Also

BoolToVisibilityConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter Constructor

BoolToVisibilityConverter Constructor
[image]

Initializes a new instance of the BoolToVisibilityConverter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BoolToVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BoolToVisibilityConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter Methods

BoolToVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation
ConvertBack | IValueConverter.ConvertBack implementation

See Also

BoolToVisibilityConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter.Convert Method

BoolToVisibilityConverter.Convert Method
[image]

IValueConverter.Convert implementation

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

BoolToVisibilityConverter Members
BoolToVisibilityConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.BoolToVisibilityConverter.ConvertBack Method

BoolToVisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

BoolToVisibilityConverter Members
BoolToVisibilityConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand Class

ChangeItemCommand Class
[image]

Handles undo / redo of property changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ChangeItemCommand : Command

Visual Basic [image] Copy Code

Public Class ChangeItemCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.ChangeItemCommand

See Also

ChangeItemCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand Members

ChangeItemCommand Members
Constructors Properties Methods
[image]

Handles undo / redo of property changes.

The following tables list the members exposed by the ChangeItemCommand type.

Public Constructors

Name | Description
ChangeItemCommand | Initializes a new instance of the ChangeItemCommand class.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand Constructor

ChangeItemCommand Constructor
[image]

Initializes a new instance of the ChangeItemCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ChangeItemCommand (
IProjectViewModel viewModel,
IUndoable item
)

Visual Basic [image] Copy Code

Public New ( _
viewModel As IProjectViewModel, _
item As IUndoable _
)

Parameters

viewModel
The ViewModel this command will operate on.
item

A reference to the item being changed.

See Also

ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand Methods

ChangeItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand.Execute Method

ChangeItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

Remarks

true, if the state of the item has changed; otherwise, false.

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand.Redo Method

ChangeItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChangeItemCommand.Undo Method

ChangeItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Class

ChoiceColumn Class
[image]

A column in a DataGrid which displays enumeration values.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ChoiceColumn : GridColumn

Visual Basic [image] Copy Code

Public Class ChoiceColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.ChoiceColumn

See Also

ChoiceColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Members

ChoiceColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays enumeration values.

The following tables list the members exposed by the ChoiceColumn type.

Public Constructors

Name | Description
ChoiceColumn | Overloaded. Initializes a new instance of the ChoiceColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Constructor

ChoiceColumn Constructor
[image]

Initializes a new instance of the ChoiceColumn class.

Overload List

Name | Description
ChoiceColumn (ItemPropertyInfo) | Initializes a new instance of the ChoiceColumn class.
ChoiceColumn (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object) | Initializes a new instance of the ChoiceColumn class.

See Also

ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Constructor (ItemPropertyInfo)

ChoiceColumn Constructor (ItemPropertyInfo)
See Also
[image]

Initializes a new instance of the ChoiceColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ChoiceColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

ChoiceColumn Constructor Overload List
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)

ChoiceColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)
See Also
[image]

Initializes a new instance of the ChoiceColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ChoiceColumn (
ItemPropertyInfo propertyInfo,
IValueConverter viewerConverter,
Object viewerConverterParam,
IValueConverter editorConverter,
Object editorConverterParam
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo, _
viewerConverter As IValueConverter, _
viewerConverterParam As Object, _
editorConverter As IValueConverter, _
editorConverterParam As Object _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.
viewerConverter
An IValueConverter that will be used in the viewer-data bound relationship in this column.
viewerConverterParam
The converter parameter that will be used by viewerConverter.
editorConverter
An IValueConverter that will be used in the editor-data bound relationship in this column.
editorConverterParam
The converter parameter that will be used by editorConverter.

See Also

ChoiceColumn Constructor Overload List
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn Methods

ChoiceColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.CancelEdit Method

ChoiceColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.CommitEdit Method

ChoiceColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.ConfirmBeginEdit Method

ChoiceColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.CreateEditor Method

ChoiceColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.CreateViewer Method

ChoiceColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ChoiceColumn.InitEditor Method

ChoiceColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

ChoiceColumn Members
ChoiceColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnCreatingEventArgs Class

ColumnCreatingEventArgs Class
[image]

Contains the arguments passed to handlers of the ColumnCreating event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ColumnCreatingEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ColumnCreatingEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.ColumnCreatingEventArgs

See Also

ColumnCreatingEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnCreatingEventArgs Members

ColumnCreatingEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ColumnCreating event.

The following tables list the members exposed by the ColumnCreatingEventArgs type.

Public Properties

Name | Description
Column | Gets or sets the column that will represent the property in the grid.
Property | Gets the property for which the column is being created.

See Also

ColumnCreatingEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnCreatingEventArgs Properties

ColumnCreatingEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets or sets the column that will represent the property in the grid.
Property | Gets the property for which the column is being created.

See Also

ColumnCreatingEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnCreatingEventArgs.Column Property

ColumnCreatingEventArgs.Column Property
[image]

Gets or sets the column that will represent the property in the grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public GridColumn Column { get; set; }

Visual Basic [image] Copy Code

Public Property Column As GridColumn

Property Value

A GridColumn object.

See Also

ColumnCreatingEventArgs Members
ColumnCreatingEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnCreatingEventArgs.Property Property

ColumnCreatingEventArgs.Property Property
[image]

Gets the property for which the column is being created.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ItemPropertyInfo Property { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Property As ItemPropertyInfo

Property Value

An ItemPropertyInfo object.

See Also

ColumnCreatingEventArgs Members
ColumnCreatingEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnHeader Class

ColumnHeader Class
[image]

Represents the column header of a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ColumnHeader : ContentControl

Visual Basic [image] Copy Code

Public Class ColumnHeader
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.DataViews.Wpf.ColumnHeader
MindFusion.DataViews.Wpf.ScheduleColumnHeader

See Also

ColumnHeader Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnHeader Members

ColumnHeader Members
Constructors Methods
[image]

Represents the column header of a DataGrid.

The following tables list the members exposed by the ColumnHeader type.

Public Constructors

Name | Description
ColumnHeader | Initializes a new instance of the ColumnHeader class.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnHeader Constructor

ColumnHeader Constructor
[image]

Initializes a new instance of the ColumnHeader class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ColumnHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnHeader Methods

ColumnHeader Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ColumnHeader.OnApplyTemplate Method

ColumnHeader.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ColumnHeader Members
ColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command Class

Command Class
[image]

Represents an action that changes the ViewModel and whose effects can be undone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.ChangeItemCommand
MindFusion.DataViews.Wpf.CompositeCommand
MindFusion.DataViews.Wpf.CreateActivityCommand
MindFusion.DataViews.Wpf.CreateDependencyCommand
MindFusion.DataViews.Wpf.CreateResourceAllocationCommand
MindFusion.DataViews.Wpf.CreateResourceCommand
MindFusion.DataViews.Wpf.RemoveActivityCommand
MindFusion.DataViews.Wpf.RemoveDependencyCommand
MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand
MindFusion.DataViews.Wpf.RemoveResourceCommand

See Also

Command Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command Members

Command Members
Constructors Properties Methods
[image]

Represents an action that changes the ViewModel and whose effects can be undone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object.

Protected Methods

Name | Description
Execute | Carries out an action that changes the ViewModel in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the ViewModel to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected Command (
IProjectViewModel project
)

Visual Basic [image] Copy Code

Protected New ( _
project As IProjectViewModel _
)

Parameters

project

The project this command will operate on.

See Also

Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command Methods

Command Methods
[image]

Protected Methods

Name | Description
Execute | Carries out an action that changes the ViewModel in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the ViewModel to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command.Execute Method

Command.Execute Method
[image]

Carries out an action that changes the ViewModel in some way.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected abstract bool Execute ()

Visual Basic [image] Copy Code

Protected MustOverride Function Execute () As Boolean

Return Value

true, if the command actually caused any changes; otherwise, false.

Remarks

Commands, which return false, are never recorded in the command history.

See Also

Command Members
Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected abstract void Redo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Redo ()

See Also

Command Members
Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the ViewModel to the state it was in before carrying out the action.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected abstract void Undo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Undo ()

See Also

Command Members
Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command Properties

Command Properties
[image]

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object.

See Also

Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Command.Project Property

Command.Project Property
[image]

Gets the ViewModel modified by this Command object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected IProjectViewModel Project { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Project As IProjectViewModel

Property Value

An IProjectViewModel object.

See Also

Command Members
Command Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand Class

CompositeCommand Class
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CompositeCommand : Command

Visual Basic [image] Copy Code

Public Class CompositeCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.CompositeCommand

See Also

CompositeCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand Members

CompositeCommand Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class.

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand Constructor

CompositeCommand Constructor
[image]

Initializes a new instance of the CompositeCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CompositeCommand (
IProjectViewModel project
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel _
)

Parameters

project

The project this command will operate on.

See Also

CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand Methods

CompositeCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand.Execute Method

CompositeCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the command actually caused any changes; otherwise, false.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand.Redo Method

CompositeCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand.Undo Method

CompositeCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand Properties

CompositeCommand Properties
[image]

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CompositeCommand.Commands Property

CompositeCommand.Commands Property
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public List<Command> Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As List(Of Command)

Property Value

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CornerRadiusConverter Class

CornerRadiusConverter Class
[image]

Converts double values to CornerRadius.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CornerRadiusConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class CornerRadiusConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.CornerRadiusConverter

See Also

CornerRadiusConverter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CornerRadiusConverter Members

CornerRadiusConverter Members
Constructors
[image]

Converts double values to CornerRadius.

The following tables list the members exposed by the CornerRadiusConverter type.

Public Constructors

Name | Description
CornerRadiusConverter | Initializes a new instance of the CornerRadiusConverter class.

See Also

CornerRadiusConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CornerRadiusConverter Constructor

CornerRadiusConverter Constructor
[image]

Initializes a new instance of the CornerRadiusConverter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CornerRadiusConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CornerRadiusConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Class

CreateActivityCommand Class
[image]

Implements creation of new activities in the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CreateActivityCommand : Command

Visual Basic [image] Copy Code

Public Class CreateActivityCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.CreateActivityCommand

See Also

CreateActivityCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Members

CreateActivityCommand Members
Constructors Properties Methods
[image]

Implements creation of new activities in the underlying ViewModel.

The following tables list the members exposed by the CreateActivityCommand type.

Public Constructors

Name | Description
CreateActivityCommand | Overloaded. Initializes a new instance of the CreateActivityCommand class.

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Constructor

CreateActivityCommand Constructor
[image]

Initializes a new instance of the CreateActivityCommand class.

Overload List

Name | Description
CreateActivityCommand (IProjectViewModel) | Initializes a new instance of the CreateActivityCommand class.
CreateActivityCommand (IProjectViewModel, IActivityViewModel) | Initializes a new instance of the CreateActivityCommand class.
CreateActivityCommand (IProjectViewModel, IActivityViewModel, Int32) | Initializes a new instance of the CreateActivityCommand class.

See Also

CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Constructor (IProjectViewModel)

CreateActivityCommand Constructor (IProjectViewModel)
See Also
[image]

Initializes a new instance of the CreateActivityCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateActivityCommand (
IProjectViewModel project
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel _
)

Parameters

project

The project this command will operate on.

See Also

CreateActivityCommand Constructor Overload List
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Constructor (IProjectViewModel, IActivityViewModel)

CreateActivityCommand Constructor (IProjectViewModel, IActivityViewModel)
See Also
[image]

Initializes a new instance of the CreateActivityCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateActivityCommand (
IProjectViewModel project,
IActivityViewModel parent
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
parent As IActivityViewModel _
)

Parameters

project

The project this command will operate on.

parent

The activity to be used as a parent for the newly created activity.

See Also

CreateActivityCommand Constructor Overload List
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Constructor (IProjectViewModel, IActivityViewModel, Int32)

CreateActivityCommand Constructor (IProjectViewModel, IActivityViewModel, Int32)
See Also
[image]

Initializes a new instance of the CreateActivityCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateActivityCommand (
IProjectViewModel project,
IActivityViewModel parent,
int index
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
parent As IActivityViewModel, _
index As Integer _
)

Parameters

project

The project this command will operate on.

parent

The activity to be used as a parent for the newly created activity.

index

The index within parent where the newly created activity will be added.

See Also

CreateActivityCommand Constructor Overload List
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Methods

CreateActivityCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand.Execute Method

CreateActivityCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the activity was created and added to the ViewModel successfully; otherwise, false.

See Also

CreateActivityCommand Members
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand.Redo Method

CreateActivityCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CreateActivityCommand Members
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand.Undo Method

CreateActivityCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CreateActivityCommand Members
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand Properties

CreateActivityCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateActivityCommand.Result Property

CreateActivityCommand.Result Property
[image]

Gets the result of the command execution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IActivityViewModel Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As IActivityViewModel

Property Value

An IActivityViewModel object representing the newly created activity.

See Also

CreateActivityCommand Members
CreateActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand Class

CreateDependencyCommand Class
[image]

Implements creation of new dependencies in the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CreateDependencyCommand : Command

Visual Basic [image] Copy Code

Public Class CreateDependencyCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.CreateDependencyCommand

See Also

CreateDependencyCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand Members

CreateDependencyCommand Members
Constructors Properties Methods
[image]

Implements creation of new dependencies in the underlying ViewModel.

The following tables list the members exposed by the CreateDependencyCommand type.

Public Constructors

Name | Description
CreateDependencyCommand | Initializes a new instance of the CreateDependencyCommand command.

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand Constructor

CreateDependencyCommand Constructor
[image]

Initializes a new instance of the CreateDependencyCommand command.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateDependencyCommand (
IProjectViewModel project,
IActivityViewModel from,
IActivityViewModel to
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
from As IActivityViewModel, _
to As IActivityViewModel _
)

Parameters

project

The project this command will operate on.

from

The source activity of the newly created dependency.

to

The target activity of the newly created dependency.

See Also

CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand Methods

CreateDependencyCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand.Execute Method

CreateDependencyCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the dependency was created and added to the ViewModel successfully; otherwise, false.

See Also

CreateDependencyCommand Members
CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand.Redo Method

CreateDependencyCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CreateDependencyCommand Members
CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand.Undo Method

CreateDependencyCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CreateDependencyCommand Members
CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand Properties

CreateDependencyCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateDependencyCommand.Result Property

CreateDependencyCommand.Result Property
[image]

Gets the result of the command execution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IDependencyViewModel Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As IDependencyViewModel

Property Value

An IDependencyViewModel object representing the newly created activity.

See Also

CreateDependencyCommand Members
CreateDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand Class

CreateResourceAllocationCommand Class
[image]

Implements creation of new allocations in the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CreateResourceAllocationCommand : Command

Visual Basic [image] Copy Code

Public Class CreateResourceAllocationCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.CreateResourceAllocationCommand

See Also

CreateResourceAllocationCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand Members

CreateResourceAllocationCommand Members
Constructors Properties Methods
[image]

Implements creation of new allocations in the underlying ViewModel.

The following tables list the members exposed by the CreateResourceAllocationCommand type.

Public Constructors

Name | Description
CreateResourceAllocationCommand | Initializes a new instance of the CreateResourceAllocationCommand class.

Public Properties

Name | Description
Activity | Get the activity for which the resource will be allocated.
Resource | Gets the resource that will be allocated.
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand Constructor

CreateResourceAllocationCommand Constructor
[image]

Initializes a new instance of the CreateResourceAllocationCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateResourceAllocationCommand (
IProjectViewModel project,
IResourceViewModel resource,
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
resource As IResourceViewModel, _
activity As IActivityViewModel _
)

Parameters

project

The project this command will operate on.

resource

The resource that will be allocated.

activity

The activity for which the resource will be allocated.

See Also

CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand Methods

CreateResourceAllocationCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Execute Method

CreateResourceAllocationCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the resource was created and added to the ViewModel successfully; otherwise, false.

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Redo Method

CreateResourceAllocationCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Undo Method

CreateResourceAllocationCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand Properties

CreateResourceAllocationCommand Properties
[image]

Public Properties

Name | Description
Activity | Get the activity for which the resource will be allocated.
Resource | Gets the resource that will be allocated.
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Activity Property

CreateResourceAllocationCommand.Activity Property
[image]

Get the activity for which the resource will be allocated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IActivityViewModel Activity { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Activity As IActivityViewModel

Property Value

An IActivityViewModel object representing the related activity.

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Resource Property

CreateResourceAllocationCommand.Resource Property
[image]

Gets the resource that will be allocated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IResourceViewModel Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As IResourceViewModel

Property Value

An IResourceViewModel object representing the related resource.

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceAllocationCommand.Result Property

CreateResourceAllocationCommand.Result Property
[image]

Gets the result of the command execution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IResourceAllocationViewModel Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As IResourceAllocationViewModel

Property Value

An IResourceAllocationViewModel object representing the newly created allocation.

See Also

CreateResourceAllocationCommand Members
CreateResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand Class

CreateResourceCommand Class
[image]

Implements creation of new resources in the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class CreateResourceCommand : Command

Visual Basic [image] Copy Code

Public Class CreateResourceCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.CreateResourceCommand

See Also

CreateResourceCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand Members

CreateResourceCommand Members
Constructors Properties Methods
[image]

Implements creation of new resources in the underlying ViewModel.

The following tables list the members exposed by the CreateResourceCommand type.

Public Constructors

Name | Description
CreateResourceCommand | Initializes a new instance of the CreateResourceCommand class.

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand Constructor

CreateResourceCommand Constructor
[image]

Initializes a new instance of the CreateResourceCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public CreateResourceCommand (
IProjectViewModel project
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel _
)

Parameters

project

The project this command will operate on.

See Also

CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand Methods

CreateResourceCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand.Execute Method

CreateResourceCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the resource was created and added to the ViewModel successfully; otherwise, false.

See Also

CreateResourceCommand Members
CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand.Redo Method

CreateResourceCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CreateResourceCommand Members
CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand.Undo Method

CreateResourceCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CreateResourceCommand Members
CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand Properties

CreateResourceCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the result of the command execution.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.CreateResourceCommand.Result Property

CreateResourceCommand.Result Property
[image]

Gets the result of the command execution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IResourceViewModel Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As IResourceViewModel

Property Value

An IResourceViewModel object representing the newly created resource.

See Also

CreateResourceCommand Members
CreateResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Class

DataGrid Class
[image]

Displays data in a customizable grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DataGrid : MultiSelector

Visual Basic [image] Copy Code

Public Class DataGrid
Inherits MultiSelector

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.Primitives.MultiSelector
MindFusion.DataViews.Wpf.DataGrid
MindFusion.DataViews.Wpf.TreeGrid

See Also

DataGrid Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Members

DataGrid Members
Constructors Fields Properties Methods Events
[image]

Displays data in a customizable grid.

The following tables list the members exposed by the DataGrid type.

Public Constructors

Name | Description
DataGrid | Initializes a new instance of the DataGrid class.

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property.
AlternatingRowBackgroundProperty | Identifies the AlternatingRowBackground dependency property.
AlternatingRowBorderBrushProperty | Identifies the AlternatingRowBorderBrush dependency property.
AlternatingRowBorderThicknessProperty | Identifies the AlternatingRowBorderThickness dependency property.
AutoGenerateColumnsProperty | Identifies the AutoGenerateColumns dependency property.
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property.
CurrentCellProperty | Identifies the CurrentCell dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderForegroundProperty | Identifies the HeaderBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
RowBackgroundProperty | Identifies the RowBackground dependency property.
RowBorderBrushProperty | Identifies the RowBorderBrush dependency property.
RowBorderThicknessProperty | Identifies the RowBorderThickness dependency property.
RowHeadersVisibleProperty | Identifies the RowHeadersVisible dependency property.

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.
AlternatingRowBackground | Gets or sets the background brush of alternating grid rows. This is a dependency property.
AlternatingRowBorderBrush | Gets or sets the border brush of alternating grid rows. This is a dependency property.
AlternatingRowBorderThickness | Gets or sets the border thickness of alternating grid rows. This is a dependency property.
AutoGenerateColumns | Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property.
CellBorderBrush | Gets or sets the border brush of the cells in the grid. This is a dependency property.
CellBorderThickness | Gets or sets the border thickness of the cells in the grid. This is a dependency property.
Columns | Gets or sets a list with the columns displayed in the grid.
CurrentCell | Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual column headers. This is a dependency property.
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property.
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.
LicenseKey | Gets or sets the license key of the control.
RowBackground | Gets or sets the background brush of grid rows. This is a dependency property.
RowBorderBrush | Gets or sets the border brush of grid rows. This is a dependency property.
RowBorderThickness | Gets or sets the border thickness of grid rows. This is a dependency property.
RowHeadersVisible | Gets or sets a value indicating whether row headers are visible. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnColumnCreating | Raises the ColumnCreating event.
OnItemsSourceChanged | Selector.OnItemsSourceChanged override.
OnKeyDown | ItemsControl.OnKeyDown override.
OnRowClicked | Raises the RowClicked event.
OnTextInput | ItemsControl.OnTextInput override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid.
RowClicked | Raised when a row in the grid is clicked with the mouse.

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Fields

DataGrid Fields
[image]

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property.
AlternatingRowBackgroundProperty | Identifies the AlternatingRowBackground dependency property.
AlternatingRowBorderBrushProperty | Identifies the AlternatingRowBorderBrush dependency property.
AlternatingRowBorderThicknessProperty | Identifies the AlternatingRowBorderThickness dependency property.
AutoGenerateColumnsProperty | Identifies the AutoGenerateColumns dependency property.
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property.
CurrentCellProperty | Identifies the CurrentCell dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderForegroundProperty | Identifies the HeaderBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
RowBackgroundProperty | Identifies the RowBackground dependency property.
RowBorderBrushProperty | Identifies the RowBorderBrush dependency property.
RowBorderThicknessProperty | Identifies the RowBorderThickness dependency property.
RowHeadersVisibleProperty | Identifies the RowHeadersVisible dependency property.

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AllowColumnReorderProperty Field

DataGrid.AllowColumnReorderProperty Field
[image]

Identifies the AllowColumnReorder dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowColumnReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowColumnReorderProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBackgroundProperty Field

DataGrid.AlternatingRowBackgroundProperty Field
[image]

Identifies the AlternatingRowBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingRowBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingRowBackgroundProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBorderBrushProperty Field

DataGrid.AlternatingRowBorderBrushProperty Field
[image]

Identifies the AlternatingRowBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingRowBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingRowBorderBrushProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBorderThicknessProperty Field

DataGrid.AlternatingRowBorderThicknessProperty Field
[image]

Identifies the AlternatingRowBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingRowBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingRowBorderThicknessProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AutoGenerateColumnsProperty Field

DataGrid.AutoGenerateColumnsProperty Field
[image]

Identifies the AutoGenerateColumns dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoGenerateColumnsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoGenerateColumnsProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CellBorderBrushProperty Field

DataGrid.CellBorderBrushProperty Field
[image]

Identifies the CellBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellBorderBrushProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CellBorderThicknessProperty Field

DataGrid.CellBorderThicknessProperty Field
[image]

Identifies the CellBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellBorderThicknessProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CurrentCellProperty Field

DataGrid.CurrentCellProperty Field
[image]

Identifies the CurrentCell dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentCellProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentCellProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBackgroundProperty Field

DataGrid.HeaderBackgroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBorderBrushProperty Field

DataGrid.HeaderBorderBrushProperty Field
[image]

Identifies the HeaderBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderBrushProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBorderThicknessProperty Field

DataGrid.HeaderBorderThicknessProperty Field
[image]

Identifies the HeaderBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderThicknessProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderContentTemplateProperty Field

DataGrid.HeaderContentTemplateProperty Field
[image]

Identifies the HeaderContentTemplate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderContentTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderContentTemplateProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderFontSizeProperty Field

DataGrid.HeaderFontSizeProperty Field
[image]

Identifies the HeaderFontSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderFontSizeProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderForegroundProperty Field

DataGrid.HeaderForegroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderForegroundProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderMarginProperty Field

DataGrid.HeaderMarginProperty Field
[image]

Identifies the HeaderMargin dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderMarginProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBackgroundProperty Field

DataGrid.RowBackgroundProperty Field
[image]

Identifies the RowBackground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowBackgroundProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBorderBrushProperty Field

DataGrid.RowBorderBrushProperty Field
[image]

Identifies the RowBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowBorderBrushProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBorderThicknessProperty Field

DataGrid.RowBorderThicknessProperty Field
[image]

Identifies the RowBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowBorderThicknessProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowHeadersVisibleProperty Field

DataGrid.RowHeadersVisibleProperty Field
[image]

Identifies the RowHeadersVisible dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowHeadersVisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowHeadersVisibleProperty As DependencyProperty

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Constructor

DataGrid Constructor
[image]

Initializes a new instance of the DataGrid class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataGrid ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Methods

DataGrid Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnColumnCreating | Raises the ColumnCreating event.
OnItemsSourceChanged | Selector.OnItemsSourceChanged override.
OnKeyDown | ItemsControl.OnKeyDown override.
OnRowClicked | Raises the RowClicked event.
OnTextInput | ItemsControl.OnTextInput override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.ClearContainerForItemOverride Method

DataGrid.ClearContainerForItemOverride Method
[image]

ItemsControl.ClearContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void ClearContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub ClearContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.GetContainerForItemOverride Method

DataGrid.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.IsItemItsOwnContainerOverride Method

DataGrid.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnApplyTemplate Method

DataGrid.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnColumnCreating Method

DataGrid.OnColumnCreating Method
[image]

Raises the ColumnCreating event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnCreating (
ColumnCreatingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnCreating( _
e As ColumnCreatingEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnItemsSourceChanged Method

DataGrid.OnItemsSourceChanged Method
[image]

Selector.OnItemsSourceChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnItemsSourceChanged (
IEnumerable oldValue,
IEnumerable newValue
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnItemsSourceChanged( _
oldValue As IEnumerable, _
newValue As IEnumerable _
)

Parameters

oldValue

Old value of the source.

newValue

New value of the source.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnKeyDown Method

DataGrid.OnKeyDown Method
[image]

ItemsControl.OnKeyDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e

Information about the event.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnRowClicked Method

DataGrid.OnRowClicked Method
[image]

Raises the RowClicked event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowClicked (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowClicked( _
e As MouseButtonEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.OnTextInput Method

DataGrid.OnTextInput Method
[image]

ItemsControl.OnTextInput override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextInput (
TextCompositionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextInput( _
e As TextCompositionEventArgs _
)

Parameters

e

Information about the event.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.PrepareContainerForItemOverride Method

DataGrid.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Properties

DataGrid Properties
[image]

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.
AlternatingRowBackground | Gets or sets the background brush of alternating grid rows. This is a dependency property.
AlternatingRowBorderBrush | Gets or sets the border brush of alternating grid rows. This is a dependency property.
AlternatingRowBorderThickness | Gets or sets the border thickness of alternating grid rows. This is a dependency property.
AutoGenerateColumns | Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property.
CellBorderBrush | Gets or sets the border brush of the cells in the grid. This is a dependency property.
CellBorderThickness | Gets or sets the border thickness of the cells in the grid. This is a dependency property.
Columns | Gets or sets a list with the columns displayed in the grid.
CurrentCell | Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual column headers. This is a dependency property.
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property.
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.
LicenseKey | Gets or sets the license key of the control.
RowBackground | Gets or sets the background brush of grid rows. This is a dependency property.
RowBorderBrush | Gets or sets the border brush of grid rows. This is a dependency property.
RowBorderThickness | Gets or sets the border thickness of grid rows. This is a dependency property.
RowHeadersVisible | Gets or sets a value indicating whether row headers are visible. This is a dependency property.

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AllowColumnReorder Property

DataGrid.AllowColumnReorder Property
[image]

Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowColumnReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowColumnReorder As Boolean

Property Value

true to allow interactive reordering; otherwise, false. The default is false.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBackground Property

DataGrid.AlternatingRowBackground Property
[image]

Gets or sets the background brush of alternating grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush AlternatingRowBackground { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingRowBackground As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBorderBrush Property

DataGrid.AlternatingRowBorderBrush Property
[image]

Gets or sets the border brush of alternating grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush AlternatingRowBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingRowBorderBrush As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AlternatingRowBorderThickness Property

DataGrid.AlternatingRowBorderThickness Property
[image]

Gets or sets the border thickness of alternating grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness AlternatingRowBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingRowBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.AutoGenerateColumns Property

DataGrid.AutoGenerateColumns Property
[image]

Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AutoGenerateColumns { get; set; }

Visual Basic [image] Copy Code

Public Property AutoGenerateColumns As Boolean

Property Value

true to automatically generate the grid columns based on the properties of the underlying items; otherwise, false.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CellBorderBrush Property

DataGrid.CellBorderBrush Property
[image]

Gets or sets the border brush of the cells in the grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush CellBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellBorderBrush As Brush

Property Value

AWPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CellBorderThickness Property

DataGrid.CellBorderThickness Property
[image]

Gets or sets the border thickness of the cells in the grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness CellBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property CellBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.Columns Property

DataGrid.Columns Property
[image]

Gets or sets a list with the columns displayed in the grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public BindingList<GridColumn> Columns { get; set; }

Visual Basic [image] Copy Code

Public Property Columns As BindingList(Of GridColumn)

Property Value

A collection of GridColumn objects.

Remarks

This list is automatically populated from the underlying Items collection if AutoGenerateColumns is set to true.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.CurrentCell Property

DataGrid.CurrentCell Property
[image]

Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public GridCell CurrentCell { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentCell As GridCell

Property Value

An instance of the GridCell class specifying the currently focused cell in the grid.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBackground Property

DataGrid.HeaderBackground Property
[image]

Gets or sets the brush used to fill the header background. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBackground As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBorderBrush Property

DataGrid.HeaderBorderBrush Property
[image]

Gets or sets border brush of the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderBrush As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderBorderThickness Property

DataGrid.HeaderBorderThickness Property
[image]

Gets or sets the border thickness of the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderContentTemplate Property

DataGrid.HeaderContentTemplate Property
[image]

Gets or sets the template to use for the individual column headers. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderContentTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderContentTemplate As DataTemplate

Property Value

A WPF DataTemplate.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderFontSize Property

DataGrid.HeaderFontSize Property
[image]

Gets or sets the size of the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double HeaderFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFontSize As Double

Property Value

A double value.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderForeground Property

DataGrid.HeaderForeground Property
[image]

Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderForeground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderForeground As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.HeaderMargin Property

DataGrid.HeaderMargin Property
[image]

Gets or sets the margin of the texts displayed in the grid header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderMargin { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderMargin As Thickness

Property Value

A WPF Thickness.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.LicenseKey Property

DataGrid.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

A string value.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBackground Property

DataGrid.RowBackground Property
[image]

Gets or sets the background brush of grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush RowBackground { get; set; }

Visual Basic [image] Copy Code

Public Property RowBackground As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBorderBrush Property

DataGrid.RowBorderBrush Property
[image]

Gets or sets the border brush of grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush RowBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RowBorderBrush As Brush

Property Value

A WPF Brush.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowBorderThickness Property

DataGrid.RowBorderThickness Property
[image]

Gets or sets the border thickness of grid rows. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness RowBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RowBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowHeadersVisible Property

DataGrid.RowHeadersVisible Property
[image]

Gets or sets a value indicating whether row headers are visible. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool RowHeadersVisible { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeadersVisible As Boolean

Property Value

true to display the row headers; otherwise, false.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid Events

DataGrid Events
[image]

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid.
RowClicked | Raised when a row in the grid is clicked with the mouse.

See Also

DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.ColumnCreating Event

DataGrid.ColumnCreating Event
[image]

Raised when a column is automatically generated by the grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnCreatingEventArgs> ColumnCreating

Visual Basic [image] Copy Code

Public Event ColumnCreating As EventHandler(Of ColumnCreatingEventArgs)

Event Data

ColumnCreating event handlers receive an argument of type ColumnCreatingEventArgs.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGrid.RowClicked Event

DataGrid.RowClicked Event
[image]

Raised when a row in the grid is clicked with the mouse.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<MouseButtonEventArgs> RowClicked

Visual Basic [image] Copy Code

Public Event RowClicked As EventHandler(Of MouseButtonEventArgs)

Event Data

ColumnCreating event handlers receive an argument of type MouseButtonEventArgs.

See Also

DataGrid Members
DataGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Class

DataGridVisibleAttribute Class
[image]

Specifies whether a property should be displayed in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DataGridVisibleAttribute : Attribute

Visual Basic [image] Copy Code

Public Class DataGridVisibleAttribute
Inherits Attribute

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.DataViews.Wpf.DataGridVisibleAttribute

See Also

DataGridVisibleAttribute Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Members

DataGridVisibleAttribute Members
Constructors Properties
[image]

Specifies whether a property should be displayed in a DataGrid.

The following tables list the members exposed by the DataGridVisibleAttribute type.

Public Constructors

Name | Description
DataGridVisibleAttribute | Overloaded. Initializes a new instance of the DataGridVisibleAttribute class.

Public Properties

Name | Description
Visible | Gets or sets a value indicating whether the property this attribute is associated with should be displayed in a DataGrid.

See Also

DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Constructor

DataGridVisibleAttribute Constructor
[image]

Initializes a new instance of the DataGridVisibleAttribute class.

Overload List

Name | Description
DataGridVisibleAttribute () | Initializes a new instance of the DataGridVisibleAttribute class.
DataGridVisibleAttribute (Boolean) | Initializes a new instance of the DataGridVisibleAttribute class.

See Also

DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Constructor ()

DataGridVisibleAttribute Constructor ()
See Also
[image]

Initializes a new instance of the DataGridVisibleAttribute class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataGridVisibleAttribute ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DataGridVisibleAttribute Constructor Overload List
DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Constructor (Boolean)

DataGridVisibleAttribute Constructor (Boolean)
See Also
[image]

Initializes a new instance of the DataGridVisibleAttribute class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataGridVisibleAttribute (
bool visible
)

Visual Basic [image] Copy Code

Public New ( _
visible As Boolean _
)

Parameters

visible
true if the property should be visible in a DataGrid; otherwise, false. The default is true.

See Also

DataGridVisibleAttribute Constructor Overload List
DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute Properties

DataGridVisibleAttribute Properties
[image]

Public Properties

Name | Description
Visible | Gets or sets a value indicating whether the property this attribute is associated with should be displayed in a DataGrid.

See Also

DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DataGridVisibleAttribute.Visible Property

DataGridVisibleAttribute.Visible Property
[image]

Gets or sets a value indicating whether the property this attribute is associated with should be displayed in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the property should be visible in a DataGrid; otherwise, false. The default is true.

See Also

DataGridVisibleAttribute Members
DataGridVisibleAttribute Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs Class

DateChangedEventArgs Class
[image]

Contains argumens passed to event handlers related to date changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DateChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.DateChangedEventArgs

See Also

DateChangedEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs Members

DateChangedEventArgs Members
Constructors Properties
[image]

Contains argumens passed to event handlers related to date changes.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Constructors

Name | Description
DateChangedEventArgs | Initializes a new instance of the DateChangedEventArgs class.

Public Properties

Name | Description
NewDate | Gets the value of the date after its change.
PreviousDate | Gets the value of the date prior ot its change.

See Also

DateChangedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs Constructor

DateChangedEventArgs Constructor
[image]

Initializes a new instance of the DateChangedEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateChangedEventArgs (
DateTime previousDate,
DateTime newDate
)

Visual Basic [image] Copy Code

Public New ( _
previousDate As DateTime, _
newDate As DateTime _
)

Parameters

previousDate
The DateTime value prior to the change.
newDate
The DateTime value after the change.

See Also

DateChangedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs Properties

DateChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewDate | Gets the value of the date after its change.
PreviousDate | Gets the value of the date prior ot its change.

See Also

DateChangedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property
[image]

Gets the value of the date after its change.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime NewDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewDate As DateTime

Property Value

A DateTime object.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property
[image]

Gets the value of the date prior ot its change.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime PreviousDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PreviousDate As DateTime

Property Value

A DateTime object.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Class

DateTimeColumn Class
[image]

A column in a DataGrid which displays DateTime values.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DateTimeColumn : GridColumn

Visual Basic [image] Copy Code

Public Class DateTimeColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.DateTimeColumn

See Also

DateTimeColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Members

DateTimeColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays DateTime values.

The following tables list the members exposed by the DateTimeColumn type.

Public Constructors

Name | Description
DateTimeColumn | Overloaded. Initializes a new instance of the DateTimeColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | GridColumn.CreateViewerBinding override.
InitEditor | GridColumn.InitEditor override.

See Also

DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Constructor

DateTimeColumn Constructor
[image]

Initializes a new instance of the DateTimeColumn class.

Overload List

Name | Description
DateTimeColumn (ItemPropertyInfo) | Initializes a new instance of the DateTimeColumn class.
DateTimeColumn (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object) | Initializes a new instance of the DateTimeColumn class.

See Also

DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Constructor (ItemPropertyInfo)

DateTimeColumn Constructor (ItemPropertyInfo)
See Also
[image]

Initializes a new instance of the DateTimeColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTimeColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

DateTimeColumn Constructor Overload List
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)

DateTimeColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)
See Also
[image]

Initializes a new instance of the DateTimeColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTimeColumn (
ItemPropertyInfo propertyInfo,
IValueConverter viewerConverter,
Object viewerConverterParam,
IValueConverter editorConverter,
Object editorConverterParam
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo, _
viewerConverter As IValueConverter, _
viewerConverterParam As Object, _
editorConverter As IValueConverter, _
editorConverterParam As Object _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.
viewerConverter
An IValueConverter that will be used in the viewer-data bound relationship in this column.
viewerConverterParam
The converter parameter that will be used by viewerConverter.
editorConverter
An IValueConverter that will be used in the editor-data bound relationship in this column.
editorConverterParam
The converter parameter that will be used by editorConverter.

See Also

DateTimeColumn Constructor Overload List
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn Methods

DateTimeColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | GridColumn.CreateViewerBinding override.
InitEditor | GridColumn.InitEditor override.

See Also

DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.CancelEdit Method

DateTimeColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.CommitEdit Method

DateTimeColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.ConfirmBeginEdit Method

DateTimeColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.CreateEditor Method

DateTimeColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.CreateViewer Method

DateTimeColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.CreateViewerBinding Method

DateTimeColumn.CreateViewerBinding Method
[image]

GridColumn.CreateViewerBinding override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Binding CreateViewerBinding ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewerBinding () As Binding

Return Value

A .NET Binding that should be used by the associated viewer.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DateTimeColumn.InitEditor Method

DateTimeColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overrides Sub InitEditor( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

DateTimeColumn Members
DateTimeColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Class

DependenciesOverlay Class
[image]

Represents a container for the dependencies in an ActivityChart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependenciesOverlay : ItemsControl

Visual Basic [image] Copy Code

Public Class DependenciesOverlay
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.DataViews.Wpf.DependenciesOverlay

See Also

DependenciesOverlay Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Members

DependenciesOverlay Members
Constructors Fields Properties Methods
[image]

Represents a container for the dependencies in an ActivityChart.

The following tables list the members exposed by the DependenciesOverlay type.

Public Constructors

Name | Description
DependenciesOverlay | Initializes a new instance of the DependenciesOverlay class.

Public Fields

Name | Description
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property.
DependenciesArrowSizeProperty | Identifies the DependenciesArrowSize dependency property.
DependenciesCornerRadiusProperty | Identifies the DependenciesCornerRadius property.
DependenciesFillProperty | Identifies the DependenciesFill dependency property.
DependenciesStrokeProperty | Identifies the DependenciesStroke dependency property.
DependenciesStrokeThicknessProperty | Identifies the DependenciesStrokeThickness dependency property.
IsDrawingDependencyProperty | Identifies the IsDrawingDependency dependency property.
TimelineGridDateProperty | Identifies the TimelineGridDate dependency property.

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether auto-scrolling is enabled. This is a dependency property.
AllowInfiniteScroll | Gets or sets a value indicating whether interactions in the overlay can cause the parent chart to scroll outside its current time range. This is a dependency property.
DependenciesArrowSize | Gets or sets the arrow head size of all dependencies. This is a dependency property.
DependenciesCornerRadius | Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.
DependenciesFill | Gets or sets a brush that describes the fill of all dependencies.
DependenciesStroke | Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.
DependenciesStrokeThickness | Gets or sets the thickness of dependencies' strokes. This is a dependency property.
IsDrawingDependency | Gets or sets a value indicating whether a dependency is currently being created interactively by the user. This is a dependency property.
TimelineGridDate | Gets or sets the date of the associated timeline. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
MeasureOverride | Control.MeasureOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Fields

DependenciesOverlay Fields
[image]

Public Fields

Name | Description
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property.
DependenciesArrowSizeProperty | Identifies the DependenciesArrowSize dependency property.
DependenciesCornerRadiusProperty | Identifies the DependenciesCornerRadius property.
DependenciesFillProperty | Identifies the DependenciesFill dependency property.
DependenciesStrokeProperty | Identifies the DependenciesStroke dependency property.
DependenciesStrokeThicknessProperty | Identifies the DependenciesStrokeThickness dependency property.
IsDrawingDependencyProperty | Identifies the IsDrawingDependency dependency property.
TimelineGridDateProperty | Identifies the TimelineGridDate dependency property.

See Also

DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.AllowAutoScrollProperty Field

DependenciesOverlay.AllowAutoScrollProperty Field
[image]

Identifies the AllowAutoScroll dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowAutoScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowAutoScrollProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.AllowInfiniteScrollProperty Field

DependenciesOverlay.AllowInfiniteScrollProperty Field
[image]

Identifies the AllowInfiniteScroll dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowInfiniteScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowInfiniteScrollProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesArrowSizeProperty Field

DependenciesOverlay.DependenciesArrowSizeProperty Field
[image]

Identifies the DependenciesArrowSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesArrowSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesArrowSizeProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesCornerRadiusProperty Field

DependenciesOverlay.DependenciesCornerRadiusProperty Field
[image]

Identifies the DependenciesCornerRadius property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesCornerRadiusProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesFillProperty Field

DependenciesOverlay.DependenciesFillProperty Field
[image]

Identifies the DependenciesFill dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesFillProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesStrokeProperty Field

DependenciesOverlay.DependenciesStrokeProperty Field
[image]

Identifies the DependenciesStroke dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesStrokeProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesStrokeThicknessProperty Field

DependenciesOverlay.DependenciesStrokeThicknessProperty Field
See Also
[image]

Identifies the DependenciesStrokeThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependenciesStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependenciesStrokeThicknessProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.IsDrawingDependencyProperty Field

DependenciesOverlay.IsDrawingDependencyProperty Field
[image]

Identifies the IsDrawingDependency dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDrawingDependencyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDrawingDependencyProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.TimelineGridDateProperty Field

DependenciesOverlay.TimelineGridDateProperty Field
[image]

Identifies the TimelineGridDate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineGridDateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineGridDateProperty As DependencyProperty

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Constructor

DependenciesOverlay Constructor
[image]

Initializes a new instance of the DependenciesOverlay class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependenciesOverlay ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Methods

DependenciesOverlay Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
MeasureOverride | Control.MeasureOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.ArrangeOverride Method

DependenciesOverlay.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds
The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.GetContainerForItemOverride Method

DependenciesOverlay.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.IsItemItsOwnContainerOverride Method

DependenciesOverlay.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.MeasureOverride Method

DependenciesOverlay.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint
The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.OnApplyTemplate Method

DependenciesOverlay.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.PrepareContainerForItemOverride Method

DependenciesOverlay.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element
Element used to display the specified item.
item
Specified item.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay Properties

DependenciesOverlay Properties
[image]

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether auto-scrolling is enabled. This is a dependency property.
AllowInfiniteScroll | Gets or sets a value indicating whether interactions in the overlay can cause the parent chart to scroll outside its current time range. This is a dependency property.
DependenciesArrowSize | Gets or sets the arrow head size of all dependencies. This is a dependency property.
DependenciesCornerRadius | Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.
DependenciesFill | Gets or sets a brush that describes the fill of all dependencies.
DependenciesStroke | Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.
DependenciesStrokeThickness | Gets or sets the thickness of dependencies' strokes. This is a dependency property.
IsDrawingDependency | Gets or sets a value indicating whether a dependency is currently being created interactively by the user. This is a dependency property.
TimelineGridDate | Gets or sets the date of the associated timeline. This is a dependency property.

See Also

DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.AllowAutoScroll Property

DependenciesOverlay.AllowAutoScroll Property
[image]

Gets or sets a value indicating whether auto-scrolling is enabled. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowAutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAutoScroll As Boolean

Property Value

true to allow autoscrolling while interacting with the elements in the overlay; otherwise, false.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.AllowInfiniteScroll Property

DependenciesOverlay.AllowInfiniteScroll Property
[image]

Gets or sets a value indicating whether interactions in the overlay can cause the parent chart to scroll outside its current time range. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowInfiniteScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInfiniteScroll As Boolean

Property Value

true to allow scrolling outside of the currently displayed time interval; otherwise, false.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesArrowSize Property

DependenciesOverlay.DependenciesArrowSize Property
[image]

Gets or sets the arrow head size of all dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesArrowSize { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesArrowSize As Double

Property Value

A double value specifying the default arrow head size of dependencies.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesCornerRadius Property

DependenciesOverlay.DependenciesCornerRadius Property
[image]

Gets or sets the smoothing radius of dependencies' corners. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesCornerRadius As Double

Property Value

A double value specifying the roundness of dependency bends.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesFill Property

DependenciesOverlay.DependenciesFill Property
[image]

Gets or sets a brush that describes the fill of all dependencies.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush DependenciesFill { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesFill As Brush

Property Value

A WPF Brush specifying the fill of the dependency arrow heads.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesStroke Property

DependenciesOverlay.DependenciesStroke Property
[image]

Gets or sets a brush that describes the stroke fill of all dependencies. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush DependenciesStroke { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesStroke As Brush

Property Value

A WPF Brush specifying the stroke thickness of the dependencies in the chart.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.DependenciesStrokeThickness Property

DependenciesOverlay.DependenciesStrokeThickness Property
[image]

Gets or sets the thickness of dependencies' strokes. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double DependenciesStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DependenciesStrokeThickness As Double

Property Value

A WPF Brush specifying the stroke thickness of the dependencies in the panel.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.IsDrawingDependency Property

DependenciesOverlay.IsDrawingDependency Property
[image]

Gets or sets a value indicating whether a dependency is currently being created interactively by the user. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsDrawingDependency { get; set; }

Visual Basic [image] Copy Code

Public Property IsDrawingDependency As Boolean

Property Value

true if the user is drawing a dependency interactively; otherwise, false.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependenciesOverlay.TimelineGridDate Property

DependenciesOverlay.TimelineGridDate Property
[image]

Gets or sets the date of the associated timeline. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime TimelineGridDate { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineGridDate As DateTime

Property Value

A .NET DateTime object.

See Also

DependenciesOverlay Members
DependenciesOverlay Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency Class

Dependency Class
[image]

A simple built-in implementation of the IDependency interface.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class Dependency : IDependency

Visual Basic [image] Copy Code

Public Class Dependency
Implements IDependency

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Dependency

See Also

Dependency Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency Members

Dependency Members
Constructors Properties
[image]

A simple built-in implementation of the IDependency interface.

The following tables list the members exposed by the Dependency type.

Public Constructors

Name | Description
Dependency | Initializes a new instance of the Dependency class.

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets or sets the source of the dependency.
To | Gets or sets the target of the dependency.

See Also

Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency Constructor

Dependency Constructor
[image]

Initializes a new instance of the Dependency class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Dependency ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency Properties

Dependency Properties
[image]

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets or sets the source of the dependency.
To | Gets or sets the target of the dependency.

See Also

Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency.DependencyType Property

Dependency.DependencyType Property
[image]

Gets or sets the type of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public virtual DependencyType DependencyType { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property DependencyType As DependencyType

Property Value

A member of the DependencyType enumeration.

See Also

Dependency Members
Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency.From Property

Dependency.From Property
[image]

Gets or sets the source of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object From { get; set; }

Visual Basic [image] Copy Code

Public Property From As Object

Property Value

An object representing the source of the dependency.

See Also

Dependency Members
Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Dependency.To Property

Dependency.To Property
[image]

Gets or sets the target of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object To { get; set; }

Visual Basic [image] Copy Code

Public Property To As Object

Property Value

An object representing the target of the dependency.

See Also

Dependency Members
Dependency Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyEventArgs Class

DependencyEventArgs Class
[image]

Contains the arguments passed to handlers of dependency-related events.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependencyEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DependencyEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.DependencyEventArgs

See Also

DependencyEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyEventArgs Members

DependencyEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of dependency-related events.

The following tables list the members exposed by the DependencyEventArgs type.

Public Constructors

Name | Description
DependencyEventArgs | Initializes a new instance of the DependencyEventArgs class.

Public Properties

Name | Description
Dependency | Gets the dependency related to the event.

See Also

DependencyEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyEventArgs Constructor

DependencyEventArgs Constructor
[image]

Initializes a new instance of the DependencyEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyEventArgs (
IDependencyViewModel dependency
)

Visual Basic [image] Copy Code

Public New ( _
dependency As IDependencyViewModel _
)

Parameters

dependency

The dependency related to the event.

See Also

DependencyEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyEventArgs Properties

DependencyEventArgs Properties
[image]

Public Properties

Name | Description
Dependency | Gets the dependency related to the event.

See Also

DependencyEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyEventArgs.Dependency Property

DependencyEventArgs.Dependency Property
[image]

Gets the dependency related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IDependencyViewModel Dependency { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dependency As IDependencyViewModel

Property Value

An IDependencyViewModel representing the related dependency.

See Also

DependencyEventArgs Members
DependencyEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent Class

DependencyPopupContent Class
[image]

The content of the popup displayed during interactive creation or modification of dependencies in an ActivityChart control.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependencyPopupContent : Control

Visual Basic [image] Copy Code

Public Class DependencyPopupContent
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.DependencyPopupContent

See Also

DependencyPopupContent Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent Members

DependencyPopupContent Members
Constructors Fields Properties
[image]

The content of the popup displayed during interactive creation or modification of dependencies in an ActivityChart control.

The following tables list the members exposed by the DependencyPopupContent type.

Public Constructors

Name | Description
DependencyPopupContent | Initializes a new instance of the DependencyPopupContent class.

Public Fields

Name | Description
FromProperty | Identifies the From dependency property.
FromTypeProperty | Identifies the FromType dependency property.
PopupTitleProperty | Identifies the PopupTitle dependency property.
ToProperty | Identifies the To dependency property.
ToTypeProperty | Identifies the ToType dependency property.

Public Properties

Name | Description
From | Gets or sets a string identifying the name of the source activity, or an empty string, if the dependency does not have a source activity. This is a dependency property.
FromType | Gets or sets a string identifying the relation between the dependency and its source activity. This is a dependency property.
PopupTitle | Gets or sets the title content of the popup. This is a dependency property.
To | Gets or sets a string identifying the name of the target activity, or an empty string, if the dependency does not have a target activity. This is a dependency property.
ToType | Gets or sets a string identifying the relation between the dependency and its source target. This is a dependency property.

See Also

DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent Fields

DependencyPopupContent Fields
[image]

Public Fields

Name | Description
FromProperty | Identifies the From dependency property.
FromTypeProperty | Identifies the FromType dependency property.
PopupTitleProperty | Identifies the PopupTitle dependency property.
ToProperty | Identifies the To dependency property.
ToTypeProperty | Identifies the ToType dependency property.

See Also

DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.FromProperty Field

DependencyPopupContent.FromProperty Field
[image]

Identifies the From dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FromProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FromProperty As DependencyProperty

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.FromTypeProperty Field

DependencyPopupContent.FromTypeProperty Field
[image]

Identifies the FromType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FromTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FromTypeProperty As DependencyProperty

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.PopupTitleProperty Field

DependencyPopupContent.PopupTitleProperty Field
[image]

Identifies the PopupTitle dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PopupTitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PopupTitleProperty As DependencyProperty

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.ToProperty Field

DependencyPopupContent.ToProperty Field
[image]

Identifies the To dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToProperty As DependencyProperty

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.ToTypeProperty Field

DependencyPopupContent.ToTypeProperty Field
[image]

Identifies the ToType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToTypeProperty As DependencyProperty

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent Constructor

DependencyPopupContent Constructor
[image]

Initializes a new instance of the DependencyPopupContent class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyPopupContent ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent Properties

DependencyPopupContent Properties
[image]

Public Properties

Name | Description
From | Gets or sets a string identifying the name of the source activity, or an empty string, if the dependency does not have a source activity. This is a dependency property.
FromType | Gets or sets a string identifying the relation between the dependency and its source activity. This is a dependency property.
PopupTitle | Gets or sets the title content of the popup. This is a dependency property.
To | Gets or sets a string identifying the name of the target activity, or an empty string, if the dependency does not have a target activity. This is a dependency property.
ToType | Gets or sets a string identifying the relation between the dependency and its source target. This is a dependency property.

See Also

DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.From Property

DependencyPopupContent.From Property
[image]

Gets or sets a string identifying the name of the source activity, or an empty string, if the dependency does not have a source activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string From { get; set; }

Visual Basic [image] Copy Code

Public Property From As String

Property Value

A string identifying the source activity.

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.FromType Property

DependencyPopupContent.FromType Property
[image]

Gets or sets a string identifying the relation between the dependency and its source activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string FromType { get; set; }

Visual Basic [image] Copy Code

Public Property FromType As String

Property Value

A string specifying the start type of the dependency.

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.PopupTitle Property

DependencyPopupContent.PopupTitle Property
[image]

Gets or sets the title content of the popup. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string PopupTitle { get; set; }

Visual Basic [image] Copy Code

Public Property PopupTitle As String

Property Value

A string specifying the popup's title.

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.To Property

DependencyPopupContent.To Property
[image]

Gets or sets a string identifying the name of the target activity, or an empty string, if the dependency does not have a target activity. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string To { get; set; }

Visual Basic [image] Copy Code

Public Property To As String

Property Value

A string identifying the target activity.

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPopupContent.ToType Property

DependencyPopupContent.ToType Property
[image]

Gets or sets a string identifying the relation between the dependency and its source target. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ToType { get; set; }

Visual Basic [image] Copy Code

Public Property ToType As String

Property Value

A string specifying the end type of the dependency.

See Also

DependencyPopupContent Members
DependencyPopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Class

DependencyPresenter Class
[image]

Represents a dependency link between two activities in an ActivityChart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependencyPresenter : Control

Visual Basic [image] Copy Code

Public Class DependencyPresenter
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.DependencyPresenter

See Also

DependencyPresenter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Members

DependencyPresenter Members
Constructors Fields Properties Methods Events
[image]

Represents a dependency link between two activities in an ActivityChart.

The following tables list the members exposed by the DependencyPresenter type.

Public Constructors

Name | Description
DependencyPresenter | Initializes a new instance of the DependencyPresenter class.

Public Fields

Name | Description
ArrowSizeProperty | Identifies the ArrowSize dependency property.
ClickedEvent | Identifies the Clicked routed event.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DependencyTypeProperty | Identifies the DependencyType dependency property.
FromBoundsProperty | Identifies the FromBounds dependency property.
HitTestDistanceProperty | Identifies the HitTestDistance dependency property.
IsCriticalProperty | Identifies the IsCritical dependency property.
PathDataProperty | Identifies the PathData dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ToBoundsProperty | Identifies the ToBounds dependency property.

Public Properties

Name | Description
ArrowSize | Gets or sets the size of the dependency's arrow. This is a dependency property.
CornerRadius | Gets or sets the smoothing radius of dependency's corners. This is a dependency property.
DependencyType | Gets the type of the underlying dependency. This is a dependency property.
FromBounds | Gets the bounding rectangle (expressed in global coordinates) of the source activity of the underlying dependency. This is a dependency property.
HitTestDistance | Gets or sets the distance at which the presenter geometry will be hit-tested. This is a dependency property.
IsCritical | Gets or sets a value indicating whether the underlying dependency is part of the critical path. This is a dependency property.
PathData | Gets the geometry of the underlying dependency. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the dependency's stroke. This is a dependency property.
ToBounds | Gets the bounding rectangle (expressed in global coordinates) of the target activity of the underlying dependency. This is a dependency property.

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseDown | Control.OnMouseDown override.

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object.

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Fields

DependencyPresenter Fields
[image]

Public Fields

Name | Description
ArrowSizeProperty | Identifies the ArrowSize dependency property.
ClickedEvent | Identifies the Clicked routed event.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DependencyTypeProperty | Identifies the DependencyType dependency property.
FromBoundsProperty | Identifies the FromBounds dependency property.
HitTestDistanceProperty | Identifies the HitTestDistance dependency property.
IsCriticalProperty | Identifies the IsCritical dependency property.
PathDataProperty | Identifies the PathData dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ToBoundsProperty | Identifies the ToBounds dependency property.

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.ArrowSizeProperty Field

DependencyPresenter.ArrowSizeProperty Field
[image]

Identifies the ArrowSize dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ArrowSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ArrowSizeProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.ClickedEvent Field

DependencyPresenter.ClickedEvent Field
[image]

Identifies the Clicked routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ClickedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ClickedEvent As RoutedEvent

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.CornerRadiusProperty Field

DependencyPresenter.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.DependencyTypeProperty Field

DependencyPresenter.DependencyTypeProperty Field
[image]

Identifies the DependencyType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DependencyTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DependencyTypeProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.FromBoundsProperty Field

DependencyPresenter.FromBoundsProperty Field
[image]

Identifies the FromBounds dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FromBoundsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FromBoundsProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.HitTestDistanceProperty Field

DependencyPresenter.HitTestDistanceProperty Field
[image]

Identifies the HitTestDistance dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HitTestDistanceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HitTestDistanceProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.IsCriticalProperty Field

DependencyPresenter.IsCriticalProperty Field
[image]

Identifies the IsCritical dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsCriticalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsCriticalProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.PathDataProperty Field

DependencyPresenter.PathDataProperty Field
[image]

Identifies the PathData dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PathDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PathDataProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.StrokeThicknessProperty Field

DependencyPresenter.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.ToBoundsProperty Field

DependencyPresenter.ToBoundsProperty Field
[image]

Identifies the ToBounds dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToBoundsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToBoundsProperty As DependencyProperty

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Constructor

DependencyPresenter Constructor
[image]

Initializes a new instance of the DependencyPresenter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Methods

DependencyPresenter Methods
[image]

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseDown | Control.OnMouseDown override.

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.HitTestCore Method

DependencyPresenter.HitTestCore Method
[image]

UIElement.HitTestCore override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override HitTestResult HitTestCore (
PointHitTestParameters hitTestParameters
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTestCore( _
hitTestParameters As PointHitTestParameters _
) As HitTestResult

Parameters

hitTestParameters

Describes the hit test to perform, including the initial hit point.

Return Value

Results of the test, including the evaluated point.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.MeasureOverride Method

DependencyPresenter.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.OnMouseDoubleClick Method

DependencyPresenter.OnMouseDoubleClick Method
[image]

Control.OnMouseDoubleClick override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDoubleClick (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDoubleClick( _
e As MouseButtonEventArgs _
)

Parameters

e

The event data.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.OnMouseDown Method

DependencyPresenter.OnMouseDown Method
[image]

Control.OnMouseDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The event data.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Properties

DependencyPresenter Properties
[image]

Public Properties

Name | Description
ArrowSize | Gets or sets the size of the dependency's arrow. This is a dependency property.
CornerRadius | Gets or sets the smoothing radius of dependency's corners. This is a dependency property.
DependencyType | Gets the type of the underlying dependency. This is a dependency property.
FromBounds | Gets the bounding rectangle (expressed in global coordinates) of the source activity of the underlying dependency. This is a dependency property.
HitTestDistance | Gets or sets the distance at which the presenter geometry will be hit-tested. This is a dependency property.
IsCritical | Gets or sets a value indicating whether the underlying dependency is part of the critical path. This is a dependency property.
PathData | Gets the geometry of the underlying dependency. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the dependency's stroke. This is a dependency property.
ToBounds | Gets the bounding rectangle (expressed in global coordinates) of the target activity of the underlying dependency. This is a dependency property.

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.ArrowSize Property

DependencyPresenter.ArrowSize Property
[image]

Gets or sets the size of the dependency's arrow. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ArrowSize { get; set; }

Visual Basic [image] Copy Code

Public Property ArrowSize As Double

Property Value

A double value specifying the arrow head size of dependency. The default is 6.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.CornerRadius Property

DependencyPresenter.CornerRadius Property
[image]

Gets or sets the smoothing radius of dependency's corners. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

A double value specifying the roundness of dependency bends. The default is 3.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.DependencyType Property

DependencyPresenter.DependencyType Property
[image]

Gets the type of the underlying dependency. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyType DependencyType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DependencyType As DependencyType

Property Value

A member of the DependencyType enumeration.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.FromBounds Property

DependencyPresenter.FromBounds Property
[image]

Gets the bounding rectangle (expressed in global coordinates) of the source activity of the underlying dependency. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Rect FromBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FromBounds As Rect

Property Value

A WPF Rect.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.HitTestDistance Property

DependencyPresenter.HitTestDistance Property
[image]

Gets or sets the distance at which the presenter geometry will be hit-tested. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double HitTestDistance { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestDistance As Double

Property Value

A double value specifying the distance at which the dependency will detect mouse clicks.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.IsCritical Property

DependencyPresenter.IsCritical Property
[image]

Gets or sets a value indicating whether the underlying dependency is part of the critical path. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsCritical { get; set; }

Visual Basic [image] Copy Code

Public Property IsCritical As Boolean

Property Value

true if the dependency participates in the critical path; otherwise, false.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.PathData Property

DependencyPresenter.PathData Property
[image]

Gets the geometry of the underlying dependency. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Geometry PathData { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PathData As Geometry

Property Value

A WPF Geometry.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.StrokeThickness Property

DependencyPresenter.StrokeThickness Property
[image]

Gets or sets the thickness of the dependency's stroke. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value specifying the stroke thickness.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.ToBounds Property

DependencyPresenter.ToBounds Property
[image]

Gets the bounding rectangle (expressed in global coordinates) of the target activity of the underlying dependency. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Rect ToBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ToBounds As Rect

Property Value

A WPF Rect.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter Events

DependencyPresenter Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks or double-clicks with the mouse on this object.

See Also

DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenter.Clicked Event

DependencyPresenter.Clicked Event
[image]

Occurs when the user clicks or double-clicks with the mouse on this object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event MouseButtonEventHandler Clicked

Visual Basic [image] Copy Code

Public Event Clicked As MouseButtonEventHandler

Event Data

Clicked event handlers receive an argument of type MouseButtonEventArgs.

See Also

DependencyPresenter Members
DependencyPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenterEventArgs Class

DependencyPresenterEventArgs Class
[image]

Contains the arguments passed to handlers of dependency presenter-related events.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependencyPresenterEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DependencyPresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.DependencyPresenterEventArgs

See Also

DependencyPresenterEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenterEventArgs Members

DependencyPresenterEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of dependency presenter-related events.

The following tables list the members exposed by the DependencyPresenterEventArgs type.

Public Constructors

Name | Description
DependencyPresenterEventArgs | Initializes a new instance of the DependencyPresenterEventArgs class.

Public Properties

Name | Description
Presenter | Gets the presenter related to the event.

See Also

DependencyPresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenterEventArgs Constructor

DependencyPresenterEventArgs Constructor
[image]

Initializes a new instance of the DependencyPresenterEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyPresenterEventArgs (
DependencyPresenter presenter
)

Visual Basic [image] Copy Code

Public New ( _
presenter As DependencyPresenter _
)

Parameters

presenter

The presenter related to the event.

See Also

DependencyPresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenterEventArgs Properties

DependencyPresenterEventArgs Properties
[image]

Public Properties

Name | Description
Presenter | Gets the presenter related to the event.

See Also

DependencyPresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyPresenterEventArgs.Presenter Property

DependencyPresenterEventArgs.Presenter Property
[image]

Gets the presenter related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyPresenter Presenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Presenter As DependencyPresenter

Property Value

An instance of the DependencyPresenter class.

See Also

DependencyPresenterEventArgs Members
DependencyPresenterEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState Class

DependencyState Class
[image]

Encapsulates the state of a dependency in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DependencyState : UndoState

Visual Basic [image] Copy Code

Public Class DependencyState
Inherits UndoState

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.UndoState
MindFusion.DataViews.Wpf.DependencyState

See Also

DependencyState Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState Members

DependencyState Members
Constructors Properties Methods
[image]

Encapsulates the state of a dependency in the ViewModel.

The following tables list the members exposed by the DependencyState type.

Public Constructors

Name | Description
DependencyState | Initializes a new instance of the DependencyState class.

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState Constructor

DependencyState Constructor
[image]

Initializes a new instance of the DependencyState class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState Methods

DependencyState Methods
[image]

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState.Equals Method

DependencyState.Equals Method
[image]

UndoState.Equals override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
UndoState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As UndoState _
) As Boolean

Parameters

other

An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

DependencyState Members
DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState Properties

DependencyState Properties
[image]

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.

See Also

DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyState.DependencyType Property

DependencyState.DependencyType Property
[image]

Gets or sets the type of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DependencyType DependencyType { get; set; }

Visual Basic [image] Copy Code

Public Property DependencyType As DependencyType

Property Value

An member of the DependencyType enumeration.

See Also

DependencyState Members
DependencyState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DependencyType Enumeration

DependencyType Enumeration
[image]

Specifies the type of a dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum DependencyType

Visual Basic [image] Copy Code

Public Enum DependencyType

Members

Member name | Description
FinishToFinish | Indicates a finish-to-finish dependency.
FinishToStart | Indicates a start-to-finish dependency.
StartToFinish | Indicates a start-to-finish dependency.
StartToStart | Indicates a start-to-start dependency.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs Class

DrillValidationRoutedEventArgs Class
[image]

Contains the arguments passed to validation routed event related related to drilling in and out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class DrillValidationRoutedEventArgs : RoutedEventArgs

Visual Basic [image] Copy Code

Public Class DrillValidationRoutedEventArgs
Inherits RoutedEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.RoutedEventArgs
MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs

See Also

DrillValidationRoutedEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs Members

DrillValidationRoutedEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to validation routed event related related to drilling in and out.

The following tables list the members exposed by the DrillValidationRoutedEventArgs type.

Public Constructors

Name | Description
DrillValidationRoutedEventArgs | Initializes a new instance of the DrillValidationRoutedEventArgs class.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation has been validated.

See Also

DrillValidationRoutedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs Constructor

DrillValidationRoutedEventArgs Constructor
[image]

Initializes a new instance of the DrillValidationRoutedEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DrillValidationRoutedEventArgs (
RoutedEvent routedEvent
)

Visual Basic [image] Copy Code

Public New ( _
routedEvent As RoutedEvent _
)

Parameters

routedEvent
The routed event identifier for this instance of the DrillValidationRoutedEventArgs class.

See Also

DrillValidationRoutedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs Properties

DrillValidationRoutedEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation has been validated.

See Also

DrillValidationRoutedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventArgs.Confirm Property

DrillValidationRoutedEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation has been validated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true to confirm the operation; otherwise, false.

See Also

DrillValidationRoutedEventArgs Members
DrillValidationRoutedEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.DrillValidationRoutedEventHandler Delegate

DrillValidationRoutedEventHandler Delegate
[image]

Represents the method that will handle validation routed events related to drilling in and out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public delegate void DrillValidationRoutedEventHandler (
Object sender,
DrillValidationRoutedEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub DrillValidationRoutedEventHandler ( _
sender As Object, _
e As DrillValidationRoutedEventArgs _
)

Parameters

sender

The object where the event handler is attached.

e

The event data.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions Class

Extensions Class
[image]

Provides helper methods to various classes in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public sealed class Extensions

Visual Basic [image] Copy Code

Public NotInheritable Class Extensions

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Extensions

See Also

Extensions Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions Members

Extensions Members
Methods
[image]

Provides helper methods to various classes in the ViewModel.

The following tables list the members exposed by the Extensions type.

Public Methods

Name | Description
AllActivities | Enumerates all activities in the specified project.
AllSubactivities | Enumerates all activities under the specified root activity.
AllSubactivitiesAndSelf | Enumerates all activities under the specified root activity and the root activity itself.

See Also

Extensions Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions Methods

Extensions Methods
[image]

Public Methods

Name | Description
AllActivities | Enumerates all activities in the specified project.
AllSubactivities | Enumerates all activities under the specified root activity.
AllSubactivitiesAndSelf | Enumerates all activities under the specified root activity and the root activity itself.

See Also

Extensions Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions.AllActivities Method

Extensions.AllActivities Method
[image]

Enumerates all activities in the specified project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static IEnumerable<IActivityViewModel> AllActivities (
IProjectViewModel project
)

Visual Basic [image] Copy Code

Public Shared Function AllActivities ( _
project As IProjectViewModel _
) As IEnumerable(Of IActivityViewModel)

Parameters

project
The project to enumerate.

Return Value

An enumeration of all activities in the project.

See Also

Extensions Members
Extensions Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions.AllSubactivities Method

Extensions.AllSubactivities Method
[image]

Enumerates all activities under the specified root activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static IEnumerable<IActivityViewModel> AllSubactivities (
IActivityViewModel parent
)

Visual Basic [image] Copy Code

Public Shared Function AllSubactivities ( _
parent As IActivityViewModel _
) As IEnumerable(Of IActivityViewModel)

Parameters

parent
The activity to enumerate.

Return Value

An enumeration of all subactivities of the specified activity.

Remarks

This method performs a recursive enumeration.

See Also

Extensions Members
Extensions Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Extensions.AllSubactivitiesAndSelf Method

Extensions.AllSubactivitiesAndSelf Method
[image]

Enumerates all activities under the specified root activity and the root activity itself.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static IEnumerable<IActivityViewModel> AllSubactivitiesAndSelf (
IActivityViewModel parent
)

Visual Basic [image] Copy Code

Public Shared Function AllSubactivitiesAndSelf ( _
parent As IActivityViewModel _
) As IEnumerable(Of IActivityViewModel)

Parameters

parent
The activity to enumerate.

Return Value

An enumeration of all subactivities of the specified activity.

Remarks

This method performs a recursive enumeration.

See Also

Extensions Members
Extensions Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Class

GridCell Class
[image]

Represents a cell in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class GridCell : ContentControl

Visual Basic [image] Copy Code

Public Class GridCell
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.DataViews.Wpf.GridCell
MindFusion.DataViews.Wpf.ScheduleGridCell

See Also

GridCell Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Members

GridCell Members
Constructors Fields Properties Methods
[image]

Represents a cell in a DataGrid.

The following tables list the members exposed by the GridCell type.

Public Constructors

Name | Description
GridCell | Initializes a new instance of the GridCell class.

Public Fields

Name | Description
IsEditingProperty | Identifies the IsEditing dependency property.

Public Properties

Name | Description
IsEditing | Gets or sets a value indicating whether the cell is currently in in-place editing mode. This is a dependency property.

Public Methods

Name | Description
BeginEdit | Initiates in-place editing within this cell.
CancelEdit | Cancels the current editing operation.
CommitEdit | Confirms the current editing operation.
ConfirmEdit | Checks if the user input represented by the specified event argument should initiates an editing operation for this cell.

Protected Methods

Name | Description
OnGotFocus | FrameworkElement.OnGotFocus override.
OnIsKeyboardFocusWithinChanged | UIElement.OnIsKeyboardFocusWithinChanged override.

See Also

GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Fields

GridCell Fields
[image]

Public Fields

Name | Description
IsEditingProperty | Identifies the IsEditing dependency property.

See Also

GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.IsEditingProperty Field

GridCell.IsEditingProperty Field
[image]

Identifies the IsEditing dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsEditingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsEditingProperty As DependencyProperty

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Constructor

GridCell Constructor
[image]

Initializes a new instance of the GridCell class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public GridCell ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Methods

GridCell Methods
[image]

Public Methods

Name | Description
BeginEdit | Initiates in-place editing within this cell.
CancelEdit | Cancels the current editing operation.
CommitEdit | Confirms the current editing operation.
ConfirmEdit | Checks if the user input represented by the specified event argument should initiates an editing operation for this cell.

Protected Methods

Name | Description
OnGotFocus | FrameworkElement.OnGotFocus override.
OnIsKeyboardFocusWithinChanged | UIElement.OnIsKeyboardFocusWithinChanged override.

See Also

GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.BeginEdit Method

GridCell.BeginEdit Method
[image]

Initiates in-place editing within this cell.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void BeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Public Sub BeginEdit( _
e As RoutedEventArgs _
)

Parameters

e
The RoutedEventArgs associated with the input event that caused the editing.

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.CancelEdit Method

GridCell.CancelEdit Method
[image]

Cancels the current editing operation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void CancelEdit ()

Visual Basic [image] Copy Code

Public Sub CancelEdit ()

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.CommitEdit Method

GridCell.CommitEdit Method
[image]

Confirms the current editing operation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void CommitEdit ()

Visual Basic [image] Copy Code

Public Sub CommitEdit ()

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.ConfirmEdit Method

GridCell.ConfirmEdit Method
[image]

Checks if the user input represented by the specified event argument should initiates an editing operation for this cell.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ConfirmEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Public Function ConfirmEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.OnGotFocus Method

GridCell.OnGotFocus Method
[image]

FrameworkElement.OnGotFocus override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnGotFocus (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnGotFocus( _
e As RoutedEventArgs _
)

Parameters

e
The RoutedEventArgs that contains the event data.

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.OnIsKeyboardFocusWithinChanged Method

GridCell.OnIsKeyboardFocusWithinChanged Method
[image]

UIElement.OnIsKeyboardFocusWithinChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnIsKeyboardFocusWithinChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnIsKeyboardFocusWithinChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e
A DependencyPropertyChangedEventArgs that contains the event data.

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell Properties

GridCell Properties
[image]

Public Properties

Name | Description
IsEditing | Gets or sets a value indicating whether the cell is currently in in-place editing mode. This is a dependency property.

See Also

GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridCell.IsEditing Property

GridCell.IsEditing Property
[image]

Gets or sets a value indicating whether the cell is currently in in-place editing mode. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsEditing { get; set; }

Visual Basic [image] Copy Code

Public Property IsEditing As Boolean

Property Value

true if currently in in-place editing mode; otherwise, false.

See Also

GridCell Members
GridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Class

GridColumn Class
[image]

Represents a column in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract class GridColumn : DependencyObject

Visual Basic [image] Copy Code

Public MustInherit Class GridColumn
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.BoolColumn
MindFusion.DataViews.Wpf.ChoiceColumn
MindFusion.DataViews.Wpf.DateTimeColumn
MindFusion.DataViews.Wpf.HeaderColumn
MindFusion.DataViews.Wpf.NumericColumn
MindFusion.DataViews.Wpf.ScheduleColumn
MindFusion.DataViews.Wpf.TextColumn

See Also

GridColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Members

GridColumn Members
Constructors Fields Properties Methods
[image]

Represents a column in a DataGrid.

The following tables list the members exposed by the GridColumn type.

Protected Constructors

Name | Description
GridColumn | Overloaded. Initializes a new instance of the GridColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
NameProperty | Identifies the Name dependency property.
VisibilityProperty | Identifies the Visibility dependency property.
WidthProperty | Identifies the Width dependency property.

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column.
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property.
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property.
Name | Gets or sets the text displayed in the column's header. This is a dependency property.
PropertyInfo | Gets information about the property associated with the column.
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column.
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property.
Visibility | Gets or sets the visibility of this column. This is a dependency property.
Width | Gets or sets the desired width for this column. This is a dependency property.

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column.
CancelEdit | Invoked when an editing operation is canceled.
CommitEdit | Invoked when an editing operation is confirmed.
ConfirmBeginEdit | Checks if the user input represented by the specified event argument initiates an editing operation for this column.
CreateEditor | Creates an editor for the specified data in the column.
CreateEditorBinding | Creates a binding between the data and the associated editor.
CreateViewer | Creates the visual presentation for the specified data in the column.
CreateViewerBinding | Creates a binding between the data and the associated viewer.
InitEditor | Invoked for each editor in this column before it is displayed.

See Also

GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Fields

GridColumn Fields
[image]

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
NameProperty | Identifies the Name dependency property.
VisibilityProperty | Identifies the Visibility dependency property.
WidthProperty | Identifies the Width dependency property.

See Also

GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.IsReadOnlyProperty Field

GridColumn.IsReadOnlyProperty Field
[image]

Identifies the IsReadOnly dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsReadOnlyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.NameProperty Field

GridColumn.NameProperty Field
[image]

Identifies the Name dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NameProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NameProperty As DependencyProperty

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.VisibilityProperty Field

GridColumn.VisibilityProperty Field
[image]

Identifies the Visibility dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibilityProperty As DependencyProperty

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.WidthProperty Field

GridColumn.WidthProperty Field
[image]

Identifies the Width dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WidthProperty As DependencyProperty

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Constructor

GridColumn Constructor
[image]

Initializes a new instance of the GridColumn class.

Overload List

Name | Description
GridColumn (ItemPropertyInfo) | Initializes a new instance of the GridColumn class.
GridColumn (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object) | Initializes a new instance of the GridColumn class.

See Also

GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Constructor (ItemPropertyInfo)

GridColumn Constructor (ItemPropertyInfo)
See Also
[image]

Initializes a new instance of the GridColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected GridColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Protected New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

GridColumn Constructor Overload List
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)

GridColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)
See Also
[image]

Initializes a new instance of the GridColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected GridColumn (
ItemPropertyInfo propertyInfo,
IValueConverter viewerConverter,
Object viewerConverterParam,
IValueConverter editorConverter,
Object editorConverterParam
)

Visual Basic [image] Copy Code

Protected New ( _
propertyInfo As ItemPropertyInfo, _
viewerConverter As IValueConverter, _
viewerConverterParam As Object, _
editorConverter As IValueConverter, _
editorConverterParam As Object _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.
viewerConverter
An IValueConverter that will be used in the viewer-data bound relationship in this column.
viewerConverterParam
The converter parameter that will be used by viewerConverter.
editorConverter
An IValueConverter that will be used in the editor-data bound relationship in this column.
editorConverterParam
The converter parameter that will be used by editorConverter.

See Also

GridColumn Constructor Overload List
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Methods

GridColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column.
CancelEdit | Invoked when an editing operation is canceled.
CommitEdit | Invoked when an editing operation is confirmed.
ConfirmBeginEdit | Checks if the user input represented by the specified event argument initiates an editing operation for this column.
CreateEditor | Creates an editor for the specified data in the column.
CreateEditorBinding | Creates a binding between the data and the associated editor.
CreateViewer | Creates the visual presentation for the specified data in the column.
CreateViewerBinding | Creates a binding between the data and the associated viewer.
InitEditor | Invoked for each editor in this column before it is displayed.

See Also

GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.ApplyBinding Method

GridColumn.ApplyBinding Method
[image]

Establishes a binding between the specified framework element and the value displayed in this column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected void ApplyBinding (
FrameworkElement target,
DependencyProperty property,
GridColumnBindingTarget sender
)

Visual Basic [image] Copy Code

Protected Sub ApplyBinding( _
target As FrameworkElement, _
property As DependencyProperty, _
sender As GridColumnBindingTarget _
)

Parameters

target

The element to bind.

property

The property of the element to bind.

sender

A flag indicating whether the specified element is an editor or a viewer of the value.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CancelEdit Method

GridColumn.CancelEdit Method
[image]

Invoked when an editing operation is canceled.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overridable Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CommitEdit Method

GridColumn.CommitEdit Method
[image]

Invoked when an editing operation is confirmed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overridable Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.ConfirmBeginEdit Method

GridColumn.ConfirmBeginEdit Method
[image]

Checks if the user input represented by the specified event argument initiates an editing operation for this column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

Remarks

By default, pressing F2 initiates editing.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CreateEditor Method

GridColumn.CreateEditor Method
[image]

Creates an editor for the specified data in the column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected abstract FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected MustOverride Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CreateEditorBinding Method

GridColumn.CreateEditorBinding Method
[image]

Creates a binding between the data and the associated editor.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual Binding CreateEditorBinding ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateEditorBinding () As Binding

Return Value

A .NET Binding that should be used by the associated editor.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CreateViewer Method

GridColumn.CreateViewer Method
[image]

Creates the visual presentation for the specified data in the column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected abstract FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected MustOverride Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.CreateViewerBinding Method

GridColumn.CreateViewerBinding Method
[image]

Creates a binding between the data and the associated viewer.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual Binding CreateViewerBinding ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateViewerBinding () As Binding

Return Value

A .NET Binding that should be used by the associated viewer.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.InitEditor Method

GridColumn.InitEditor Method
[image]

Invoked for each editor in this column before it is displayed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn Properties

GridColumn Properties
[image]

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column.
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property.
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property.
Name | Gets or sets the text displayed in the column's header. This is a dependency property.
PropertyInfo | Gets information about the property associated with the column.
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column.
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property.
Visibility | Gets or sets the visibility of this column. This is a dependency property.
Width | Gets or sets the desired width for this column. This is a dependency property.

See Also

GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.EditorValueConverter Property

GridColumn.EditorValueConverter Property
[image]

Gets the IValueConverter that is used in the editor-data relationship in this column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IValueConverter EditorValueConverter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EditorValueConverter As IValueConverter

Property Value

An IValueConverter object.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.EditorValueConverterParameter Property

GridColumn.EditorValueConverterParameter Property
[image]

Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object EditorValueConverterParameter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EditorValueConverterParameter As Object

Property Value

An object specifying the parameter of the editor converter.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.IsReadOnly Property

GridColumn.IsReadOnly Property
[image]

Gets or sets a value indicating whether the column is read-only. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; set; }

Visual Basic [image] Copy Code

Public Property IsReadOnly As Boolean

Property Value

true if the values in this column cannot be modified; otherwise, false.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.Name Property

GridColumn.Name Property
[image]

Gets or sets the text displayed in the column's header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value specifying the column's header text.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.PropertyInfo Property

GridColumn.PropertyInfo Property
[image]

Gets information about the property associated with the column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ItemPropertyInfo PropertyInfo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyInfo As ItemPropertyInfo

Property Value

An ItemPropertyInfo object.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.ViewerValueConverter Property

GridColumn.ViewerValueConverter Property
[image]

Gets the IValueConverter that is used in the viewer-data relationship in this column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IValueConverter ViewerValueConverter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ViewerValueConverter As IValueConverter

Property Value

An IValueConverter object.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.ViewerValueConverterParameter Property

GridColumn.ViewerValueConverterParameter Property
[image]

Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object ViewerValueConverterParameter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ViewerValueConverterParameter As Object

Property Value

An object specifying the parameter of the editor converter.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.Visibility Property

GridColumn.Visibility Property
[image]

Gets or sets the visibility of this column. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Visibility Visibility { get; set; }

Visual Basic [image] Copy Code

Public Property Visibility As Visibility

Property Value

A member of the Visibility enumeration. The default is Visible.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumn.Width Property

GridColumn.Width Property
[image]

Gets or sets the desired width for this column. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the width of the column. The default is 90.

See Also

GridColumn Members
GridColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridColumnBindingTarget Enumeration

GridColumnBindingTarget Enumeration
[image]

Specifies the binding type in the ApplyBinding method.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum GridColumnBindingTarget

Visual Basic [image] Copy Code

Public Enum GridColumnBindingTarget

Members

Member name | Description
Editor | Indicates that the binding is applied to an element that will be used as an editor of the value.
Viewer | Indicates that the binding is applied to an element that will be used as a viewer of the value.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Class

GridRow Class
[image]

Represents a row in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class GridRow : ItemsControl

Visual Basic [image] Copy Code

Public Class GridRow
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.DataViews.Wpf.GridRow
MindFusion.DataViews.Wpf.ScheduleGridRow

See Also

GridRow Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Members

GridRow Members
Constructors Fields Properties Methods Events
[image]

Represents a row in a DataGrid.

The following tables list the members exposed by the GridRow type.

Public Constructors

Name | Description
GridRow | Initializes a new instance of the GridRow class.

Public Fields

Name | Description
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property.
ClickedEvent | Identifies the Clicked routed event.
DataItemProperty | Identifies the DataItem dependency property.
IndexProperty | Identifies the Index dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Public Properties

Name | Description
CellBorderBrush | Gets or sets the border brush of the cells in the row. This is a dependency property.
CellBorderThickness | Gets or sets the border thickness of the cells in the row. This is a dependency property.
DataItem | Gets or sets the item associated with this row. This is a dependency property.
Index | Gets or sets the index of this row within its parent. This is a dependency property.
IsExpanded | Gets or sets a value indicating whether this row is expanded. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
Clicked | Occurs when the user clicks on this row with the mouse.

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Fields

GridRow Fields
[image]

Public Fields

Name | Description
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property.
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property.
ClickedEvent | Identifies the Clicked routed event.
DataItemProperty | Identifies the DataItem dependency property.
IndexProperty | Identifies the Index dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.CellBorderBrushProperty Field

GridRow.CellBorderBrushProperty Field
[image]

Identifies the CellBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellBorderBrushProperty As DependencyProperty

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.CellBorderThicknessProperty Field

GridRow.CellBorderThicknessProperty Field
[image]

Identifies the CellBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellBorderThicknessProperty As DependencyProperty

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.ClickedEvent Field

GridRow.ClickedEvent Field
[image]

Identifies the Clicked routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ClickedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ClickedEvent As RoutedEvent

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.DataItemProperty Field

GridRow.DataItemProperty Field
[image]

Identifies the DataItem dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataItemProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataItemProperty As DependencyProperty

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.IndexProperty Field

GridRow.IndexProperty Field
[image]

Identifies the Index dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IndexProperty As DependencyProperty

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.IsExpandedProperty Field

GridRow.IsExpandedProperty Field
[image]

Identifies the IsExpanded dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Constructor

GridRow Constructor
[image]

Initializes a new instance of the GridRow class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public GridRow ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Methods

GridRow Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.ArrangeOverride Method

GridRow.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.GetContainerForItemOverride Method

GridRow.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.IsItemItsOwnContainerOverride Method

GridRow.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.OnApplyTemplate Method

GridRow.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.PrepareContainerForItemOverride Method

GridRow.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Properties

GridRow Properties
[image]

Public Properties

Name | Description
CellBorderBrush | Gets or sets the border brush of the cells in the row. This is a dependency property.
CellBorderThickness | Gets or sets the border thickness of the cells in the row. This is a dependency property.
DataItem | Gets or sets the item associated with this row. This is a dependency property.
Index | Gets or sets the index of this row within its parent. This is a dependency property.
IsExpanded | Gets or sets a value indicating whether this row is expanded. This is a dependency property.

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.CellBorderBrush Property

GridRow.CellBorderBrush Property
[image]

Gets or sets the border brush of the cells in the row. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush CellBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellBorderBrush As Brush

Property Value

A WPF Brush.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.CellBorderThickness Property

GridRow.CellBorderThickness Property
[image]

Gets or sets the border thickness of the cells in the row. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness CellBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property CellBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.DataItem Property

GridRow.DataItem Property
[image]

Gets or sets the item associated with this row. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object DataItem { get; set; }

Visual Basic [image] Copy Code

Public Property DataItem As Object

Property Value

An object representing the data associated with the row.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.Index Property

GridRow.Index Property
[image]

Gets or sets the index of this row within its parent. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the 0-based index of the row.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.IsExpanded Property

GridRow.IsExpanded Property
[image]

Gets or sets a value indicating whether this row is expanded. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Public Property IsExpanded As Boolean

Property Value

true if the row is expandable and expanded; otherwise, false.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow Events

GridRow Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks on this row with the mouse.

See Also

GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.GridRow.Clicked Event

GridRow.Clicked Event
[image]

Occurs when the user clicks on this row with the mouse.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event MouseButtonEventHandler Clicked

Visual Basic [image] Copy Code

Public Event Clicked As MouseButtonEventHandler

Event Data

Clicked event handlers receive an argument of type MouseButtonEventArgs.

See Also

GridRow Members
GridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn Class

HeaderColumn Class
[image]

A special grid column used to hold the headers of the grid rows.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class HeaderColumn : GridColumn

Visual Basic [image] Copy Code

Public Class HeaderColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.HeaderColumn

See Also

HeaderColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn Members

HeaderColumn Members
Constructors Fields Properties Methods
[image]

A special grid column used to hold the headers of the grid rows.

The following tables list the members exposed by the HeaderColumn type.

Public Constructors

Name | Description
HeaderColumn | Initializes a new instance of the HeaderColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn Constructor

HeaderColumn Constructor
[image]

Initializes a new instance of the HeaderColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public HeaderColumn ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn Methods

HeaderColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.CancelEdit Method

HeaderColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.CommitEdit Method

HeaderColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.ConfirmBeginEdit Method

HeaderColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.CreateEditor Method

HeaderColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.CreateViewer Method

HeaderColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeaderColumn.InitEditor Method

HeaderColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

HeaderColumn Members
HeaderColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Class

HeadersPresenter Class
[image]

The headers container in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class HeadersPresenter : ItemsControl

Visual Basic [image] Copy Code

Public Class HeadersPresenter
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.DataViews.Wpf.HeadersPresenter

See Also

HeadersPresenter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Members

HeadersPresenter Members
Constructors Fields Properties Methods
[image]

The headers container in a DataGrid.

The following tables list the members exposed by the HeadersPresenter type.

Public Constructors

Name | Description
HeadersPresenter | Initializes a new instance of the HeadersPresenter class.

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property.
ColumnReorderKeyProperty | Identifies the ColumnReorderKey dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.
ColumnReorderKey | Gets or sets the modifier key, which when hold down, allows repordering of the chart columns. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the presenter. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the presenter. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the presenter. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewKeyDown | UIElement.OnPreviewKeyDown override.
OnPreviewMouseLeftButtonDown | UIElement.OnPreviewMouseLeftButtonDown override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Fields

HeadersPresenter Fields
[image]

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property.
ColumnReorderKeyProperty | Identifies the ColumnReorderKey dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.

See Also

HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.AllowColumnReorderProperty Field

HeadersPresenter.AllowColumnReorderProperty Field
[image]

Identifies the AllowColumnReorder dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowColumnReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowColumnReorderProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.ColumnReorderKeyProperty Field

HeadersPresenter.ColumnReorderKeyProperty Field
[image]

Identifies the ColumnReorderKey dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColumnReorderKeyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColumnReorderKeyProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderBorderBrushProperty Field

HeadersPresenter.HeaderBorderBrushProperty Field
[image]

Identifies the HeaderBorderBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderBrushProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderBorderThicknessProperty Field

HeadersPresenter.HeaderBorderThicknessProperty Field
[image]

Identifies the HeaderBorderThickness dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderThicknessProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderContentTemplateProperty Field

HeadersPresenter.HeaderContentTemplateProperty Field
[image]

Identifies the HeaderContentTemplate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderContentTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderContentTemplateProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderMarginProperty Field

HeadersPresenter.HeaderMarginProperty Field
[image]

Identifies the HeaderMargin dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderMarginProperty As DependencyProperty

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Constructor

HeadersPresenter Constructor
[image]

Initializes a new instance of the HeadersPresenter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public HeadersPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Methods

HeadersPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewKeyDown | UIElement.OnPreviewKeyDown override.
OnPreviewMouseLeftButtonDown | UIElement.OnPreviewMouseLeftButtonDown override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.GetContainerForItemOverride Method

HeadersPresenter.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.IsItemItsOwnContainerOverride Method

HeadersPresenter.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.OnApplyTemplate Method

HeadersPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.OnMouseLeftButtonUp Method

HeadersPresenter.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseLeftButtonUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.OnMouseMove Method

HeadersPresenter.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.OnPreviewKeyDown Method

HeadersPresenter.OnPreviewKeyDown Method
[image]

UIElement.OnPreviewKeyDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.OnPreviewMouseLeftButtonDown Method

HeadersPresenter.OnPreviewMouseLeftButtonDown Method
[image]

UIElement.OnPreviewMouseLeftButtonDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.PrepareContainerForItemOverride Method

HeadersPresenter.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter Properties

HeadersPresenter Properties
[image]

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.
ColumnReorderKey | Gets or sets the modifier key, which when hold down, allows repordering of the chart columns. This is a dependency property.
HeaderBorderBrush | Gets or sets border brush of the presenter. This is a dependency property.
HeaderBorderThickness | Gets or sets the border thickness of the presenter. This is a dependency property.
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.
HeaderMargin | Gets or sets the margin of the texts displayed in the presenter. This is a dependency property.

See Also

HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.AllowColumnReorder Property

HeadersPresenter.AllowColumnReorder Property
[image]

Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowColumnReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowColumnReorder As Boolean

Property Value

true to allow interactive reordering; otherwise, false. The default is false.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.ColumnReorderKey Property

HeadersPresenter.ColumnReorderKey Property
[image]

Gets or sets the modifier key, which when hold down, allows repordering of the chart columns. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ModifierKeys ColumnReorderKey { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnReorderKey As ModifierKeys

Property Value

A member of the ModifierKeys enumeration.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderBorderBrush Property

HeadersPresenter.HeaderBorderBrush Property
[image]

Gets or sets border brush of the presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderBrush As Brush

Property Value

A WPF Brush.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderBorderThickness Property

HeadersPresenter.HeaderBorderThickness Property
[image]

Gets or sets the border thickness of the presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderThickness As Thickness

Property Value

A WPF Thickness.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderContentTemplate Property

HeadersPresenter.HeaderContentTemplate Property
[image]

Gets or sets the template to use for the individual headers in the presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderContentTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderContentTemplate As DataTemplate

Property Value

A WPF DataTemplate.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.HeadersPresenter.HeaderMargin Property

HeadersPresenter.HeaderMargin Property
[image]

Gets or sets the margin of the texts displayed in the presenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderMargin { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderMargin As Thickness

Property Value

A WPF Thickness.

See Also

HeadersPresenter Members
HeadersPresenter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivator Interface

IActivator Interface
[image]

Represents an object that can be used to created other objects.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IActivator

Visual Basic [image] Copy Code

Public Interface IActivator

Inheritors

MindFusion.DataViews.Wpf.TypeActivator

See Also

IActivator Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivator Members

IActivator Members
Methods
[image]

Represents an object that can be used to created other objects.

The following tables list the members exposed by the IActivator type.

Public Methods

Name | Description
CreateInstance | Creates an instance.

See Also

IActivator Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivator Methods

IActivator Methods
[image]

Public Methods

Name | Description
CreateInstance | Creates an instance.

See Also

IActivator Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivator.CreateInstance Method

IActivator.CreateInstance Method
[image]

Creates an instance.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Object CreateInstance ()

Visual Basic [image] Copy Code

Function CreateInstance () As Object

Return Value

The created instance.

See Also

IActivator Members
IActivator Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel Interface

IActivityViewModel Interface
[image]

Represents an activity in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IActivityViewModel : INotifyPropertyChanged, INotifyCollectionChanged, IUndoable, IItemViewModel

Visual Basic [image] Copy Code

Public Interface IActivityViewModel
Implements INotifyPropertyChanged, INotifyCollectionChanged, IUndoable, IItemViewModel

See Also

IActivityViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel Members

IActivityViewModel Members
Properties Methods
[image]

Represents an activity in the ViewModel.

The following tables list the members exposed by the IActivityViewModel type.

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
Duration | Gets or sets the duration of the activity.
EndTime | Gets or sets the end time of the activity.
IsCritical | Gets or sets a value indicating whether this activity is part of the critical path.
IsMilestone | Gets or sets a value indicating whether the activity is a milestone.
Parent | Gets the parent activity of this activity in the ViewModel.
Progress | Gets or sets the progress of the activity, expressed as a value in the range [0..1].
ResourceAllocations | Gets a list with objects describing the resources allocated for this activity.
ScheduleMode | Gets or sets a value indicating whether activities resize to the extent of their subactivities.
StartTime | Gets or sets the start time of the activity.
Subactivities | Gets the child activities of this activity in the ViewModel.

Public Methods

Name | Description
AddModelChild | Adds the specified activity as a child to this activity in the underlying Model.
AddResourceAllocation | Adds the resource allocation to this activity.
AutoUpdate | Updates the activity according to its children.
BeginAutoUpdate | Indicates that an Auto activity will be updated according to its children.
EndAutoUpdate | Indicates that an Auto activity is no longer updated according to its children.
RaisePropertyChanged | Raises the PropertyChanged event on this activity.
RemoveModelChild | Removes the specified activity from the underlying Model.
RemoveResourceAllocation | Removes the resource allocation from this activity.
SetTimes | Sets both start time and duration to the specified values.
UpdateTimesFromAllocations | Invoked when the underlying resource allocations change to allow the activity to update its start and end time accordingly.

See Also

IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel Methods

IActivityViewModel Methods
[image]

Public Methods

Name | Description
AddModelChild | Adds the specified activity as a child to this activity in the underlying Model.
AddResourceAllocation | Adds the resource allocation to this activity.
AutoUpdate | Updates the activity according to its children.
BeginAutoUpdate | Indicates that an Auto activity will be updated according to its children.
EndAutoUpdate | Indicates that an Auto activity is no longer updated according to its children.
RaisePropertyChanged | Raises the PropertyChanged event on this activity.
RemoveModelChild | Removes the specified activity from the underlying Model.
RemoveResourceAllocation | Removes the resource allocation from this activity.
SetTimes | Sets both start time and duration to the specified values.
UpdateTimesFromAllocations | Invoked when the underlying resource allocations change to allow the activity to update its start and end time accordingly.

See Also

IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.AddModelChild Method

IActivityViewModel.AddModelChild Method
[image]

Adds the specified activity as a child to this activity in the underlying Model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void AddModelChild (
int index,
Object activity
)

Visual Basic [image] Copy Code

Sub AddModelChild( _
index As Integer, _
activity As Object _
)

Parameters

index

The 0-based position in the children collection where the new child should be inserted, or -1, to add the new child at the end.

activity

The activity to be added as a child.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.AddResourceAllocation Method

IActivityViewModel.AddResourceAllocation Method
[image]

Adds the resource allocation to this activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void AddResourceAllocation (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public MustOverride Sub AddResourceAllocation ( _
allocation As IResourceAllocationViewModel _
)

Parameters

allocation
An IResourceAllocationViewModel object providing the allocation information.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.AutoUpdate Method

IActivityViewModel.AutoUpdate Method
[image]

Updates the activity according to its children.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void AutoUpdate ()

Visual Basic [image] Copy Code

Sub AutoUpdate ()

Remarks

When an Auto activity is being updated to respect its children's sizes and progress, this should be done inside a BeginAutoUpdate - EndAutoUpdate block. Other updates should be considered illegitimate.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.BeginAutoUpdate Method

IActivityViewModel.BeginAutoUpdate Method
[image]

Indicates that an Auto activity will be updated according to its children.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void BeginAutoUpdate ()

Visual Basic [image] Copy Code

Sub BeginAutoUpdate ()

Remarks

When an Auto activity is being updated to respect its children's sizes and progress, this should be done inside a BeginAutoUpdate - EndAutoUpdate block. Other updates should be considered illegitimate.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.EndAutoUpdate Method

IActivityViewModel.EndAutoUpdate Method
[image]

Indicates that an Auto activity is no longer updated according to its children.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void EndAutoUpdate ()

Visual Basic [image] Copy Code

Sub EndAutoUpdate ()

Remarks

When an Auto activity is being updated to respect its children's sizes and progress, this should be done inside a BeginAutoUpdate - EndAutoUpdate block. Other updates should be considered illegitimate.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.RaisePropertyChanged Method

IActivityViewModel.RaisePropertyChanged Method
[image]

Raises the PropertyChanged event on this activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void RaisePropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Sub RaisePropertyChanged( _
propertyName As String _
)

Parameters

propertyName

The name of the changed property.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.RemoveModelChild Method

IActivityViewModel.RemoveModelChild Method
[image]

Removes the specified activity from the underlying Model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

int RemoveModelChild (
Object activity
)

Visual Basic [image] Copy Code

Function RemoveModelChild( _
activity As Object _
) As Integer

Parameters

activity

The activity to remove.

Return Value

The 0-based index of the removed activity.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.RemoveResourceAllocation Method

IActivityViewModel.RemoveResourceAllocation Method
[image]

Removes the resource allocation from this activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void RemoveResourceAllocation (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public MustOverride Sub RemoveResourceAllocation ( _
allocation As IResourceAllocationViewModel _
)

Parameters

allocation
The IResourceAllocationViewModel object to be removed.

Return Value

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.SetTimes Method

IActivityViewModel.SetTimes Method
[image]

Sets both start time and duration to the specified values.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void SetTimes (
DateTime start,
TimeSpan duration,
bool updateAllocations
)

Visual Basic [image] Copy Code

Sub SetTimes( _
start As DateTime, _
duration As TimeSpan, _
updateAllocations As Boolean _
)

Parameters

start

The new start time of the activity.

duration

The new duration of the activity.

updateAllocations
Specifies whether to adjust the resource allocations of this activity to cover the same relative length as before the change.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.UpdateTimesFromAllocations Method

IActivityViewModel.UpdateTimesFromAllocations Method
[image]

Invoked when the underlying resource allocations change to allow the activity to update its start and end time accordingly.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void UpdateTimesFromAllocations ()

Visual Basic [image] Copy Code

Sub UpdateTimesFromAllocations ()

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel Properties

IActivityViewModel Properties
[image]

Public Properties

Name | Description
ActivityName | Gets or sets the name of the activity.
Duration | Gets or sets the duration of the activity.
EndTime | Gets or sets the end time of the activity.
IsCritical | Gets or sets a value indicating whether this activity is part of the critical path.
IsMilestone | Gets or sets a value indicating whether the activity is a milestone.
Parent | Gets the parent activity of this activity in the ViewModel.
Progress | Gets or sets the progress of the activity, expressed as a value in the range [0..1].
ResourceAllocations | Gets a list with objects describing the resources allocated for this activity.
ScheduleMode | Gets or sets a value indicating whether activities resize to the extent of their subactivities.
StartTime | Gets or sets the start time of the activity.
Subactivities | Gets the child activities of this activity in the ViewModel.

See Also

IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.ActivityName Property

IActivityViewModel.ActivityName Property
[image]

Gets or sets the name of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

string ActivityName { get; set; }

Visual Basic [image] Copy Code

Property ActivityName As String

Property Value

A string specifying the activity name.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.Duration Property

IActivityViewModel.Duration Property
[image]

Gets or sets the duration of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

TimeSpan Duration { get; set; }

Visual Basic [image] Copy Code

Property Duration As TimeSpan

Property Value

A .NET TimeSpan object specifying the duration.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.EndTime Property

IActivityViewModel.EndTime Property
[image]

Gets or sets the end time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the end time.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.IsCritical Property

IActivityViewModel.IsCritical Property
[image]

Gets or sets a value indicating whether this activity is part of the critical path.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsCritical { get; set; }

Visual Basic [image] Copy Code

Property IsCritical As Boolean

Property Value

true if the activity participates in the critical path; otherwise, false.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.IsMilestone Property

IActivityViewModel.IsMilestone Property
[image]

Gets or sets a value indicating whether the activity is a milestone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsMilestone { get; set; }

Visual Basic [image] Copy Code

Property IsMilestone As Boolean

Property Value

true if the activity is a milestone; otherwise, false.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.Parent Property

IActivityViewModel.Parent Property
[image]

Gets the parent activity of this activity in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel Parent { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Parent As IActivityViewModel

Property Value

An IActivityViewModel object specifying the parent.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.Progress Property

IActivityViewModel.Progress Property
[image]

Gets or sets the progress of the activity, expressed as a value in the range [0..1].

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

double Progress { get; set; }

Visual Basic [image] Copy Code

Property Progress As Double

Property Value

A double value specifying the progress.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.ResourceAllocations Property

IActivityViewModel.ResourceAllocations Property
[image]

Gets a list with objects describing the resources allocated for this activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IResourceAllocationViewModel> ResourceAllocations { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property ResourceAllocations As IEnumerable(Of IResourceAllocationViewModel)

Property Value

An enumeration of IResourceAllocationViewModel objects.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.ScheduleMode Property

IActivityViewModel.ScheduleMode Property
[image]

Gets or sets a value indicating whether activities resize to the extent of their subactivities.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract ScheduleMode ScheduleMode { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property ScheduleMode As ScheduleMode

Property Value

A member of the ScheduleMode enumeration.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.StartTime Property

IActivityViewModel.StartTime Property
[image]

Gets or sets the start time of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Property StartTime As DateTime

Property Value

A .NET DateTime object specifying the start time.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IActivityViewModel.Subactivities Property

IActivityViewModel.Subactivities Property
[image]

Gets the child activities of this activity in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IActivityViewModel> Subactivities { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Subactivities As IEnumerable(Of IActivityViewModel)

Property Value

An enumeration of IActivityViewModel objects.

See Also

IActivityViewModel Members
IActivityViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency Interface

IDependency Interface
[image]

Represents a dependency between two objects.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IDependency

Visual Basic [image] Copy Code

Public Interface IDependency

Inheritors

MindFusion.DataViews.Wpf.Dependency

See Also

IDependency Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency Members

IDependency Members
Properties
[image]

Represents a dependency between two objects.

The following tables list the members exposed by the IDependency type.

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets or sets the source of the dependency.
To | Gets or sets the target of the dependency.

See Also

IDependency Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency Properties

IDependency Properties
[image]

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets or sets the source of the dependency.
To | Gets or sets the target of the dependency.

See Also

IDependency Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency.DependencyType Property

IDependency.DependencyType Property
[image]

Gets or sets the type of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract DependencyType DependencyType { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property DependencyType As DependencyType

Property Value

A member of the DependencyType enumeration.

See Also

IDependency Members
IDependency Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency.From Property

IDependency.From Property
[image]

Gets or sets the source of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Object From { get; set; }

Visual Basic [image] Copy Code

Property From As Object

Property Value

An object representing the source activity.

See Also

IDependency Members
IDependency Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependency.To Property

IDependency.To Property
[image]

Gets or sets the target of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Object To { get; set; }

Visual Basic [image] Copy Code

Property To As Object

Property Value

An object representing the target activity.

See Also

IDependency Members
IDependency Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel Interface

IDependencyViewModel Interface
[image]

Represents a dependency in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IDependencyViewModel : INotifyPropertyChanged, IUndoable

Visual Basic [image] Copy Code

Public Interface IDependencyViewModel
Implements INotifyPropertyChanged, IUndoable

See Also

IDependencyViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel Members

IDependencyViewModel Members
Properties
[image]

Represents a dependency in the ViewModel.

The following tables list the members exposed by the IDependencyViewModel type.

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets a reference to the source activity.
IsCritical | Gets or sets a value indicating whether this dependency is part of the critical path.
Model | Gets a reference to the associated Model.
To | Gets a reference to the target activity.

See Also

IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel Properties

IDependencyViewModel Properties
[image]

Public Properties

Name | Description
DependencyType | Gets or sets the type of the dependency.
From | Gets a reference to the source activity.
IsCritical | Gets or sets a value indicating whether this dependency is part of the critical path.
Model | Gets a reference to the associated Model.
To | Gets a reference to the target activity.

See Also

IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel.DependencyType Property

IDependencyViewModel.DependencyType Property
[image]

Gets or sets the type of the dependency.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract DependencyType DependencyType { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property DependencyType As DependencyType

Property Value

A member of the DependencyType enumeration.

See Also

IDependencyViewModel Members
IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel.From Property

IDependencyViewModel.From Property
[image]

Gets a reference to the source activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel From { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property From As IActivityViewModel

Property Value

An IActivityViewModel object specifying the source activity.

See Also

IDependencyViewModel Members
IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel.IsCritical Property

IDependencyViewModel.IsCritical Property
[image]

Gets or sets a value indicating whether this dependency is part of the critical path.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsCritical { get; set; }

Visual Basic [image] Copy Code

Property IsCritical As Boolean

Property Value

true if the dependency participates in the critical path; otherwise, false.

See Also

IDependencyViewModel Members
IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel.Model Property

IDependencyViewModel.Model Property
[image]

Gets a reference to the associated Model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IDependency Model { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Model As IDependency

Property Value

An IDependency object.

See Also

IDependencyViewModel Members
IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IDependencyViewModel.To Property

IDependencyViewModel.To Property
[image]

Gets a reference to the target activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel To { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property To As IActivityViewModel

Property Value

An IActivityViewModel object specifying the target activity.

See Also

IDependencyViewModel Members
IDependencyViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel Interface

IItemViewModel Interface
[image]

The base interface for activity and resource view models.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IItemViewModel

Visual Basic [image] Copy Code

Public Interface IItemViewModel

Inheritors

MindFusion.DataViews.Wpf.IActivityViewModel
MindFusion.DataViews.Wpf.IResourceAllocationViewModel
MindFusion.DataViews.Wpf.IResourceViewModel

See Also

IItemViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel Members

IItemViewModel Members
Properties Methods
[image]

The base interface for activity and resource view models.

The following tables list the members exposed by the IItemViewModel type.

Public Properties

Name | Description
Bounds | Gets or sets the bounding rectangle of the visual element representing the item in the associated View.
Children | Gets the subitems of this item in the ViewModel.
Index | Gets or sets the 0-based global index of this item within the entire hierarchy.
IsBoundsValid | Gets or sets a value indicating whether the Bounds property is valid or needs to be recalculated.
IsExpanded | Gets or sets a value indicating whether the item is expanded, that is, if its children are visible.
Model | Gets a reference to the associated Model.

Public Methods

Name | Description
UpdateIndex | Recursively updates the index of this item and all its children.

See Also

IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel Methods

IItemViewModel Methods
[image]

Public Methods

Name | Description
UpdateIndex | Recursively updates the index of this item and all its children.

See Also

IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.UpdateIndex Method

IItemViewModel.UpdateIndex Method
[image]

Recursively updates the index of this item and all its children.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

int UpdateIndex (
int lastIndex
)

Visual Basic [image] Copy Code

Function UpdateIndex( _
lastIndex As Integer _
) As Integer

Parameters

lastIndex

The calculated index of the item.

Return Value

The index after the last child of the item.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel Properties

IItemViewModel Properties
[image]

Public Properties

Name | Description
Bounds | Gets or sets the bounding rectangle of the visual element representing the item in the associated View.
Children | Gets the subitems of this item in the ViewModel.
Index | Gets or sets the 0-based global index of this item within the entire hierarchy.
IsBoundsValid | Gets or sets a value indicating whether the Bounds property is valid or needs to be recalculated.
IsExpanded | Gets or sets a value indicating whether the item is expanded, that is, if its children are visible.
Model | Gets a reference to the associated Model.

See Also

IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.Bounds Property

IItemViewModel.Bounds Property
[image]

Gets or sets the bounding rectangle of the visual element representing the item in the associated View.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Property Bounds As Rect

Property Value

A WPF Rect.

Remarks

If the item is not visible (e.g. due to a parent being collapsed), Bounds should equal Rect.Empty.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.Children Property

IItemViewModel.Children Property
[image]

Gets the subitems of this item in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IEnumerable Children { get; }

Visual Basic [image] Copy Code

ReadOnly Property Children As IEnumerable

Property Value

An enumeration of the direct children of this item.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.Index Property

IItemViewModel.Index Property
[image]

Gets or sets the 0-based global index of this item within the entire hierarchy.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

int Index { get; set; }

Visual Basic [image] Copy Code

Property Index As Integer

Property Value

An 0-based integer specifying the global index of this item.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.IsBoundsValid Property

IItemViewModel.IsBoundsValid Property
[image]

Gets or sets a value indicating whether the Bounds property is valid or needs to be recalculated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsBoundsValid { get; set; }

Visual Basic [image] Copy Code

Property IsBoundsValid As Boolean

Property Value

true if the Bounds property is current; false, if it is stale.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.IsExpanded Property

IItemViewModel.IsExpanded Property
[image]

Gets or sets a value indicating whether the item is expanded, that is, if its children are visible.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Property IsExpanded As Boolean

Property Value

true if the item is expanded; otherwise, false.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IItemViewModel.Model Property

IItemViewModel.Model Property
[image]

Gets a reference to the associated Model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Object Model { get; }

Visual Basic [image] Copy Code

ReadOnly Property Model As Object

Property Value

An object representing the underlying model.

See Also

IItemViewModel Members
IItemViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel Interface

IProjectViewModel Interface
[image]

Represents a project in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IProjectViewModel : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Interface IProjectViewModel
Implements INotifyPropertyChanged

See Also

IProjectViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel Members

IProjectViewModel Members
Properties Methods Events
[image]

Represents a project in the ViewModel.

The following tables list the members exposed by the IProjectViewModel type.

Public Properties

Name | Description
Activities | Gets the top-level activities in the ViewModel.
ActivityActivator | Gets or sets a delegate that can be used to create new activities.
ActivityType | Gets or sets the type of activities created through the ViewModel.
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone.
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Dependencies | Gets all dependencies in the ViewModel.
DependencyActivator | Gets or sets a delegate that can be used to create new dependencies.
DependencyType | Gets or sets the type of dependencies created through the ViewModel.
IsEndTimeSticky | Gets or sets a value indicating whether to recalculate Activity.Duration or Activity.EndTime when StartTime changes.
NonWorkingDays | Gets or sets the non-working days for a week in a project.
NonWorkingHours | Gets or sets the non-working hours for a working day in a project.
ProjectEnd | Gets or sets a date, indicating the end of a project.
ProjectStart | Gets or sets a date, indicating the start of a project.
RedoCommand | Gets a command which performs redo on the last undone action in the command history.
ResourceActivator | Gets or sets a delegate that can be used to create new resources.
ResourceAllocationActivator | Gets or sets a delegate that can be used to create new resource allocations.
ResourceAllocations | Gets all resource allocations in the ViewModel.
ResourceAllocationType | Gets or sets the type of resource allocations created through the ViewModel.
Resources | Gets the top-level resources in the ViewModel.
ResourceType | Gets or sets the type of resources created through the ViewModel.
UndoCommand | Gets a command which performs undo on the current action saved in the command history.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
AddActivity | Adds an existing activity to the project.
AddDependency | Adds an existing dependency to the project.
AddResource | Adds an existing resource to the project.
AddResourceAllocation | Adds an existing resource allocation to the project.
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
ClearActivities | Removes all activities from the project.
ClearDependencies | Removes all dependencies from the project.
ClearResourceAllocations | Removes all resource allocations from the project.
ClearResources | Removes all resources from the project.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
CreateActivity | Creates and adds a new activity to the project. A respective object of type ActivityType is created and added to the underlying model as well.
CreateDependency | Creates and adds a new dependency to the project. A respective object of type DependencyType is created and added to the underlying model as well.
CreateResource | Creates and adds a new resource to the project. A respective object of type ResourceType is created and added to the underlying model as well.
CreateResourceAllocation | Creates and adds a new resource allocation to the project. A respective object of type ResourceAllocationType is created and added to the underlying model as well.
DoCreateActivity | Creates and adds a new activity to the project.
DoCreateDependency | Creates and adds a new dependency to the project.
DoCreateResource | Creates and adds a new resource to the project.
DoCreateResourceAllocation | Creates and adds a new resource allocation to the project.
DoRemoveActivity | Removes the specified activity from the project.
DoRemoveDependency | Removes the specified dependency from the project.
DoRemoveResource | Removes the specified resource from the project.
DoRemoveResourceAllocation | Removes the specified resource allocation from the project.
ExecuteCommand | Executes the specified command on this project.
FindCriticalPath | Finds the critical path in the project.
FindFreePeriod | Overloaded. Finds an unallocated period with the specified duration for the specified resource, within the specified time interval.
InvalidateBounds | Invalidates the bounds of all activities in the project.
PurgeUndoHistory | Purges all commands from the underlying undo history. If undo is not enabled, nothing happens.
RaiseActionRedone | Raises the ActionRedone event.
RaiseActionUndone | Raises the ActionUndone event.
Redo | Executes again an action saved in the command history.
RemoveActivity | Removes the specified activity from the project.
RemoveDependency | Removes the specified dependency from the project.
RemoveResource | Removes the specified resource from the project.
RemoveResourceAllocation | Removes the specified resource allocation from the project.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when the activities or dependencies in the project are changed.
InvalidateActivityIndexes | Raised when the activity indices need to be reevaluated.

See Also

IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel Methods

IProjectViewModel Methods
[image]

Public Methods

Name | Description
AddActivity | Adds an existing activity to the project.
AddDependency | Adds an existing dependency to the project.
AddResource | Adds an existing resource to the project.
AddResourceAllocation | Adds an existing resource allocation to the project.
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
ClearActivities | Removes all activities from the project.
ClearDependencies | Removes all dependencies from the project.
ClearResourceAllocations | Removes all resource allocations from the project.
ClearResources | Removes all resources from the project.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
CreateActivity | Creates and adds a new activity to the project. A respective object of type ActivityType is created and added to the underlying model as well.
CreateDependency | Creates and adds a new dependency to the project. A respective object of type DependencyType is created and added to the underlying model as well.
CreateResource | Creates and adds a new resource to the project. A respective object of type ResourceType is created and added to the underlying model as well.
CreateResourceAllocation | Creates and adds a new resource allocation to the project. A respective object of type ResourceAllocationType is created and added to the underlying model as well.
DoCreateActivity | Creates and adds a new activity to the project.
DoCreateDependency | Creates and adds a new dependency to the project.
DoCreateResource | Creates and adds a new resource to the project.
DoCreateResourceAllocation | Creates and adds a new resource allocation to the project.
DoRemoveActivity | Removes the specified activity from the project.
DoRemoveDependency | Removes the specified dependency from the project.
DoRemoveResource | Removes the specified resource from the project.
DoRemoveResourceAllocation | Removes the specified resource allocation from the project.
ExecuteCommand | Executes the specified command on this project.
FindCriticalPath | Finds the critical path in the project.
FindFreePeriod | Overloaded. Finds an unallocated period with the specified duration for the specified resource, within the specified time interval.
InvalidateBounds | Invalidates the bounds of all activities in the project.
PurgeUndoHistory | Purges all commands from the underlying undo history. If undo is not enabled, nothing happens.
RaiseActionRedone | Raises the ActionRedone event.
RaiseActionUndone | Raises the ActionUndone event.
Redo | Executes again an action saved in the command history.
RemoveActivity | Removes the specified activity from the project.
RemoveDependency | Removes the specified dependency from the project.
RemoveResource | Removes the specified resource from the project.
RemoveResourceAllocation | Removes the specified resource allocation from the project.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.

See Also

IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.AddActivity Method

IProjectViewModel.AddActivity Method
[image]

Adds an existing activity to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract bool AddActivity (
IActivityViewModel activity,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function AddActivity ( _
activity As IActivityViewModel, _
index As Integer _
) As Boolean

Parameters

activity
The activity to add to the project.
index
The 0-based index of the activity, or -1, to add the activity at the end of the list.

Return Value

true if the operation was successful; otherwise, false.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to add new activity to the model, call CreateActivity.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.AddDependency Method

IProjectViewModel.AddDependency Method
[image]

Adds an existing dependency to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract bool AddDependency (
IDependencyViewModel dependency,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function AddDependency ( _
dependency As IDependencyViewModel, _
index As Integer _
) As Boolean

Parameters

dependency

The dependency to add to the project.

index
The 0-based index of the dependency, or -1, to add the dependency at the end of the list.

Return Value

true if the operation was successful; otherwise, false.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to add new dependency to the model, call CreateDependency.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.AddResource Method

IProjectViewModel.AddResource Method
[image]

Adds an existing resource to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract bool AddResource (
IResourceViewModel resource,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function AddResource ( _
resource As IResourceViewModel, _
index As Integer _
) As Boolean

Parameters

resource
The resource to add to the project.
index
The 0-based index of the resource, or -1, to add the resource at the end of the list.

Return Value

true if the operation was successful; otherwise, false.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to add new resource to the model, call CreateResource.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.AddResourceAllocation Method

IProjectViewModel.AddResourceAllocation Method
[image]

Adds an existing resource allocation to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract bool AddResourceAllocation (
IResourceAllocationViewModel allocation,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function AddResourceAllocation ( _
allocation As IResourceAllocationViewModel, _
index As Integer _
) As Boolean

Parameters

allocation
The allocation to add to the project.
activityIndex
The 0-based index of the resource allocation within its related activity, or -1, to add the allocation at the end of the list.
resourceIndex

The 0-based index of the resource allocation within its related resource, or -1, to add the allocation at the end of the list.

Return Value

true if the operation was successful; otherwise, false.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to add new resource allocation to the model, call CreateResourceAllocation.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CancelCompositeOperation Method

IProjectViewModel.CancelCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void CancelCompositeOperation ()

Visual Basic [image] Copy Code

Sub CancelCompositeOperation ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ClearActivities Method

IProjectViewModel.ClearActivities Method
[image]

Removes all activities from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void ClearActivities ()

Visual Basic [image] Copy Code

Sub ClearActivities ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ClearDependencies Method

IProjectViewModel.ClearDependencies Method
[image]

Removes all dependencies from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void ClearDependencies ()

Visual Basic [image] Copy Code

Sub ClearDependencies ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ClearResourceAllocations Method

IProjectViewModel.ClearResourceAllocations Method
[image]

Removes all resource allocations from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void ClearResourceAllocations ()

Visual Basic [image] Copy Code

Sub ClearResourceAllocations ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ClearResources Method

IProjectViewModel.ClearResources Method
[image]

Removes all resources from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void ClearResources ()

Visual Basic [image] Copy Code

Sub ClearResources ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CommitCompositeOperation Method

IProjectViewModel.CommitCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void CommitCompositeOperation ()

Visual Basic [image] Copy Code

Sub CommitCompositeOperation ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CreateActivity Method

IProjectViewModel.CreateActivity Method
[image]

Creates and adds a new activity to the project. A respective object of type ActivityType is created and added to the underlying model as well.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel CreateActivity (
IActivityViewModel parent,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateActivity ( _
parent As IActivityViewModel, _
index As Integer _
) As IActivityViewModel

Parameters

parent
The parent of the newly created activity, or null (Nothing in Visual Basic), if the new activity should be top-level.
index
The index within parent where the new activity will be added, or -1, to add the new activity at the end of the parent's children collection.

Return Value

An IActivityViewModel representing the newly created activity, or null (Nothing in Visual Basic), if the operation could not be completed.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CreateDependency Method

IProjectViewModel.CreateDependency Method
[image]

Creates and adds a new dependency to the project. A respective object of type DependencyType is created and added to the underlying model as well.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IDependencyViewModel CreateDependency (
IActivityViewModel from,
IActivityViewModel to
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateDependency ( _
from As IActivityViewModel, _
to As IActivityViewModel _
) As IDependencyViewModel

Parameters

from

The source activity of the newly created dependency.

to

The target activity of the newly created dependency.

Return Value

An IDependencyViewModel representing the newly created dependency, or null (Nothing in Visual Basic), if the operation could not be completed.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CreateResource Method

IProjectViewModel.CreateResource Method
[image]

Creates and adds a new resource to the project. A respective object of type ResourceType is created and added to the underlying model as well.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IResourceViewModel CreateResource ()

Visual Basic [image] Copy Code

Public MustOverride Function CreateResource () As IResourceViewModel

Return Value

An IResourceViewModel representing the newly created resource, or null (Nothing in Visual Basic), if the operation could not be completed.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CreateResourceAllocation Method

IProjectViewModel.CreateResourceAllocation Method
[image]

Creates and adds a new resource allocation to the project. A respective object of type ResourceAllocationType is created and added to the underlying model as well.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IResourceAllocationViewModel CreateResourceAllocation (
IResourceViewModel resource,
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public MustOverride Function CreateResourceAllocation ( _
resource As IResourceViewModel, _
activity As IActivityViewModel _
) As IResourceAllocationViewModel

Parameters

resource
The resource related to the new allocation.
activity
The activity related to the new allocation.

Return Value

An IResourceAllocationViewModel representing the newly created resource allocation, or null (Nothing in Visual Basic), if the operation could not be completed.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoCreateActivity Method

IProjectViewModel.DoCreateActivity Method
[image]

Creates and adds a new activity to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel DoCreateActivity (
IActivityViewModel parent,
int index
)

Visual Basic [image] Copy Code

Public MustOverride Function DoCreateActivity ( _
parent As IActivityViewModel, _
index As Integer _
) As IActivityViewModel

Parameters

parent
The parent of the newly created activity, or null (Nothing in Visual Basic), if the new activity should be top-level.
index
The index within parent where the new activity will be added, or -1, to add the new activity at the end of the parent's children collection.

Return Value

An IActivityViewModel representing the newly created activity, or null (Nothing in Visual Basic), if the operation could not be completed.

Remarks

This method is not subject to undo/redo and should not be invoked directly. Instead, call the CreateActivity method, which will register the operation for subsequent undo.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoCreateDependency Method

IProjectViewModel.DoCreateDependency Method
[image]

Creates and adds a new dependency to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IDependencyViewModel DoCreateDependency (
IActivityViewModel from,
IActivityViewModel to
)

Visual Basic [image] Copy Code

Public MustOverride Function DoCreateDependency ( _
from As IActivityViewModel, _
to As IActivityViewModel _
) As IDependencyViewModel

Parameters

from
The source activity of the newly created dependency.
to
The target activity of the newly created dependency.

Return Value

An IDependencyViewModel representing the newly created dependency, or null (Nothing in Visual Basic), if the operation could not be completed.

Remarks

This method is not subject to undo/redo and should not be invoked directly. Instead, call the CreateDependency method, which will register the operation for subsequent undo.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoCreateResource Method

IProjectViewModel.DoCreateResource Method
[image]

Creates and adds a new resource to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IResourceViewModel DoCreateResource ()

Visual Basic [image] Copy Code

Public MustOverride Function DoCreateResource () As IResourceViewModel

Return Value

An IResourceViewModel representing the newly created resource, or null (Nothing in Visual Basic), if the operation could not be completed.

Remarks

This method is not subject to undo/redo and should not be invoked directly. Instead, call the CreateResource method, which will register the operation for subsequent undo.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoCreateResourceAllocation Method

IProjectViewModel.DoCreateResourceAllocation Method
[image]

Creates and adds a new resource allocation to the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IResourceAllocationViewModel DoCreateResourceAllocation (
IResourceViewModel resource,
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public MustOverride Function DoCreateResourceAllocation ( _
resource As IResourceViewModel, _
activity As IActivityViewModel _
) As IResourceAllocationViewModel

Parameters

resource
The resource related to the new allocation.
activity
The activity related to the new allocation.

Return Value

An IResourceAllocationViewModel representing the newly created resource allocation, or null (Nothing in Visual Basic), if the operation could not be completed.

Remarks

This method is not subject to undo/redo and should not be invoked directly. Instead, call the CreateResourceAllocation method, which will register the operation for subsequent undo.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoRemoveActivity Method

IProjectViewModel.DoRemoveActivity Method
[image]

Removes the specified activity from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int DoRemoveActivity (
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public MustOverride Function DoRemoveActivity ( _
activity As IActivityViewModel _
) As Integer

Parameters

activity
The activity to remove.

Return Value

The 0-based index of the removed activity within its containing collection.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to remove an activity from the model, call RemoveActivity.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoRemoveDependency Method

IProjectViewModel.DoRemoveDependency Method
[image]

Removes the specified dependency from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int DoRemoveDependency (
IDependencyViewModel dependency
)

Visual Basic [image] Copy Code

Public MustOverride Function DoRemoveDependency ( _
dependency As IDependencyViewModel _
) As Integer

Parameters

dependency
The dependency to remove.

Return Value

The 0-based index of the removed dependency within its containing collection.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to remove a dependency from the model, call RemoveDependency.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoRemoveResource Method

IProjectViewModel.DoRemoveResource Method
[image]

Removes the specified resource from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int DoRemoveResource (
IResourceViewModel resource
)

Visual Basic [image] Copy Code

Public MustOverride Function DoRemoveResource ( _
resource As IResourceViewModel _
) As Integer

Parameters

resource

The resource to remove.

Return Value

The 0-based index of the removed resource within its containing collection.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to remove a resource from the model, call RemoveResource.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DoRemoveResourceAllocation Method

IProjectViewModel.DoRemoveResourceAllocation Method
[image]

Removes the specified resource allocation from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void DoRemoveResourceAllocation (
IResourceAllocationViewModel allocation,
out int activityIndex,
out int resourceIndex
)

Visual Basic [image] Copy Code

Public MustOverride Sub DoRemoveResourceAllocation ( _
allocation As IResourceAllocationViewModel, _
<System.Runtime.InteropServices.Out()> ByRef activityIndex As Integer, _
<System.Runtime.InteropServices.Out()> ByRef resourceIndex As Integer _
)

Parameters

allocation
The allocation to remove.
activityIndex
The 0-based index of the removed resource allocation within its containing activity's collection.
resourceIndex

The 0-based index of the removed resource allocation within its containing resource's collection.

Remarks

This method is not subject to undo/redo and should not be invoked directly. If you need to remove a resource allocation from the model, call RemoveResourceAllocation.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ExecuteCommand Method

IProjectViewModel.ExecuteCommand Method
[image]

Executes the specified command on this project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void ExecuteCommand (
Command command
)

Visual Basic [image] Copy Code

Public MustOverride Sub ExecuteCommand ( _
command As Command _
)

Parameters

command
The Command to execute.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.FindCriticalPath Method

IProjectViewModel.FindCriticalPath Method
[image]

Finds the critical path in the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IEnumerable<Object> FindCriticalPath ()

Visual Basic [image] Copy Code

Function FindCriticalPath () As IEnumerable(Of Object)

Return Value

An enumerable of IActivityViewModel and IDependencyViewModel objects representing the found path, or null (Nothing in Visual Basic), if the path could not be found.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.FindFreePeriod Method

IProjectViewModel.FindFreePeriod Method
[image]

Finds an unallocated period with the specified duration for the specified resource, within the specified time interval.

Overload List

Name | Description
IProjectViewModel.FindFreePeriod (IResourceViewModel, TimeSpan) | Finds an unallocated period with the specified duration for the specified resource, within the project's time interval.
IProjectViewModel.FindFreePeriod (IResourceViewModel, TimeSpan, DateTime, DateTime) | Finds an unallocated period with the specified duration for the specified resource, within the specified time interval.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.FindFreePeriod Method (IResourceViewModel, TimeSpan)

IProjectViewModel.FindFreePeriod Method (IResourceViewModel, TimeSpan)
See Also
[image]

Finds an unallocated period with the specified duration for the specified resource, within the project's time interval.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime FindFreePeriod (
IResourceViewModel resource,
TimeSpan duration
)

Visual Basic [image] Copy Code

Function FindFreePeriod( _
resource As IResourceViewModel, _
duration As TimeSpan _
) As DateTime

Parameters

resource

The resource for which to find a free period.

duration

The required duration of the searched period.

Return Value

The start time of the found period, or DateTime.MinValue, if the request cannot be satisfied.

See Also

FindFreePeriod Method Overload List
IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.FindFreePeriod Method (IResourceViewModel, TimeSpan, DateTime, DateTime)

IProjectViewModel.FindFreePeriod Method (IResourceViewModel, TimeSpan, DateTime, DateTime)
See Also
[image]

Finds an unallocated period with the specified duration for the specified resource, within the specified time interval.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime FindFreePeriod (
IResourceViewModel resource,
TimeSpan duration,
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Function FindFreePeriod( _
resource As IResourceViewModel, _
duration As TimeSpan, _
from As DateTime, _
to As DateTime _
) As DateTime

Parameters

resource

The resource for which to find a free period.

duration

The required duration of the searched period.

from

The start of the time interval in which to search.

to

The end of the time interval in which to search.

Return Value

The start time of the found period, or DateTime.MinValue, if the request cannot be satisfied.

See Also

FindFreePeriod Method Overload List
IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.InvalidateBounds Method

IProjectViewModel.InvalidateBounds Method
[image]

Invalidates the bounds of all activities in the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void InvalidateBounds ()

Visual Basic [image] Copy Code

Sub InvalidateBounds ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.PurgeUndoHistory Method

IProjectViewModel.PurgeUndoHistory Method
[image]

Purges all commands from the underlying undo history. If undo is not enabled, nothing happens.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void PurgeUndoHistory ()

Visual Basic [image] Copy Code

Sub PurgeUndoHistory ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RaiseActionRedone Method

IProjectViewModel.RaiseActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void RaiseActionRedone (
Command command
)

Visual Basic [image] Copy Code

Public MustOverride Sub RaiseActionRedone ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RaiseActionUndone Method

IProjectViewModel.RaiseActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void RaiseActionUndone (
Command command
)

Visual Basic [image] Copy Code

Public MustOverride Sub RaiseActionUndone ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Redo Method

IProjectViewModel.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void Redo ()

Visual Basic [image] Copy Code

Sub Redo ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RemoveActivity Method

IProjectViewModel.RemoveActivity Method
[image]

Removes the specified activity from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int RemoveActivity (
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public MustOverride Function RemoveActivity ( _
activity As IActivityViewModel _
) As Integer

Parameters

activity

The activity to remove.

Return Value

The 0-based index of the removed activity within its containing collection.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RemoveDependency Method

IProjectViewModel.RemoveDependency Method
[image]

Removes the specified dependency from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int RemoveDependency (
IDependencyViewModel dependency
)

Visual Basic [image] Copy Code

Public MustOverride Function RemoveDependency ( _
dependency As IDependencyViewModel _
) As Integer

Parameters

dependency

The dependency to remove.

Return Value

The 0-based index of the removed dependency within its containing collection.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RemoveResource Method

IProjectViewModel.RemoveResource Method
[image]

Removes the specified resource from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int RemoveResource (
IResourceViewModel resource
)

Visual Basic [image] Copy Code

Public MustOverride Function RemoveResource ( _
resource As IResourceViewModel _
) As Integer

Parameters

resource

The resource to remove.

Return Value

The 0-based index of the removed resource within its containing collection.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RemoveResourceAllocation Method

IProjectViewModel.RemoveResourceAllocation Method
[image]

Removes the specified resource allocation from the project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void RemoveResourceAllocation (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public MustOverride Sub RemoveResourceAllocation ( _
allocation As IResourceAllocationViewModel _
)

Parameters

allocation

The resource allocation to remove.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.StartCompositeOperation Method

IProjectViewModel.StartCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void StartCompositeOperation ()

Visual Basic [image] Copy Code

Sub StartCompositeOperation ()

Remarks

The composite can be subsequently accepted by calling CommitCompositeOperation or discarded by calling CancelCompositeOperation.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Undo Method

IProjectViewModel.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void Undo ()

Visual Basic [image] Copy Code

Sub Undo ()

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel Properties

IProjectViewModel Properties
[image]

Public Properties

Name | Description
Activities | Gets the top-level activities in the ViewModel.
ActivityActivator | Gets or sets a delegate that can be used to create new activities.
ActivityType | Gets or sets the type of activities created through the ViewModel.
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone.
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Dependencies | Gets all dependencies in the ViewModel.
DependencyActivator | Gets or sets a delegate that can be used to create new dependencies.
DependencyType | Gets or sets the type of dependencies created through the ViewModel.
IsEndTimeSticky | Gets or sets a value indicating whether to recalculate Activity.Duration or Activity.EndTime when StartTime changes.
NonWorkingDays | Gets or sets the non-working days for a week in a project.
NonWorkingHours | Gets or sets the non-working hours for a working day in a project.
ProjectEnd | Gets or sets a date, indicating the end of a project.
ProjectStart | Gets or sets a date, indicating the start of a project.
RedoCommand | Gets a command which performs redo on the last undone action in the command history.
ResourceActivator | Gets or sets a delegate that can be used to create new resources.
ResourceAllocationActivator | Gets or sets a delegate that can be used to create new resource allocations.
ResourceAllocations | Gets all resource allocations in the ViewModel.
ResourceAllocationType | Gets or sets the type of resource allocations created through the ViewModel.
Resources | Gets the top-level resources in the ViewModel.
ResourceType | Gets or sets the type of resources created through the ViewModel.
UndoCommand | Gets a command which performs undo on the current action saved in the command history.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Activities Property

IProjectViewModel.Activities Property
[image]

Gets the top-level activities in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IActivityViewModel> Activities { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Activities As IEnumerable(Of IActivityViewModel)

Property Value

An enumeration of all root activities.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ActivityActivator Property

IProjectViewModel.ActivityActivator Property
[image]

Gets or sets a delegate that can be used to create new activities.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IActivator ActivityActivator { get; set; }

Visual Basic [image] Copy Code

Property ActivityActivator As IActivator

Property Value

An IActivator object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ActivityType Property

IProjectViewModel.ActivityType Property
[image]

Gets or sets the type of activities created through the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Type ActivityType { get; set; }

Visual Basic [image] Copy Code

Property ActivityType As Type

Property Value

A .NET Type object specifying the type of the activities created through the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CanRedo Property

IProjectViewModel.CanRedo Property
[image]

Gets or sets a value indicating whether there is a command in the redo history which can be redone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool CanRedo { get; }

Visual Basic [image] Copy Code

ReadOnly Property CanRedo As Boolean

Property Value

true if there is a command in the undo history that can be redone; otherwise, false.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.CanUndo Property

IProjectViewModel.CanUndo Property
[image]

Gets or sets a value indicating whether there is a command in the undo history which can be undone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool CanUndo { get; }

Visual Basic [image] Copy Code

ReadOnly Property CanUndo As Boolean

Property Value

true if there is a command in the undo history that can be undone; otherwise, false.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Dependencies Property

IProjectViewModel.Dependencies Property
[image]

Gets all dependencies in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IDependencyViewModel> Dependencies { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Dependencies As IEnumerable(Of IDependencyViewModel)

Property Value

An enumeration of all dependencies in the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DependencyActivator Property

IProjectViewModel.DependencyActivator Property
[image]

Gets or sets a delegate that can be used to create new dependencies.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IActivator DependencyActivator { get; set; }

Visual Basic [image] Copy Code

Property DependencyActivator As IActivator

Property Value

An IActivator object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.DependencyType Property

IProjectViewModel.DependencyType Property
[image]

Gets or sets the type of dependencies created through the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Type DependencyType { get; set; }

Visual Basic [image] Copy Code

Property DependencyType As Type

Property Value

A .NET Type object specifying the type of the dependencies created through the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.IsEndTimeSticky Property

IProjectViewModel.IsEndTimeSticky Property
[image]

Gets or sets a value indicating whether to recalculate Activity.Duration or Activity.EndTime when StartTime changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool IsEndTimeSticky { get; set; }

Visual Basic [image] Copy Code

Property IsEndTimeSticky As Boolean

Property Value

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.NonWorkingDays Property

IProjectViewModel.NonWorkingDays Property
[image]

Gets or sets the non-working days for a week in a project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract SortedObservableCollection<DayOfWeek> NonWorkingDays { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property NonWorkingDays As SortedObservableCollection(Of DayOfWeek)

Property Value

A collection of DayOfWeek objects representing the non-working days.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.NonWorkingHours Property

IProjectViewModel.NonWorkingHours Property
[image]

Gets or sets the non-working hours for a working day in a project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract TimeRangeCollection NonWorkingHours { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property NonWorkingHours As TimeRangeCollection

Property Value

A TimeRangeCollection object representing the non-working portions of the day.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ProjectEnd Property

IProjectViewModel.ProjectEnd Property
[image]

Gets or sets a date, indicating the end of a project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Nullable<DateTime> ProjectEnd { get; set; }

Visual Basic [image] Copy Code

Property ProjectEnd As Nullable(Of DateTime)

Property Value

A DateTime object, possibly null (Nothing in Visual Basic) to indicate no end time.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ProjectStart Property

IProjectViewModel.ProjectStart Property
[image]

Gets or sets a date, indicating the start of a project.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Nullable<DateTime> ProjectStart { get; set; }

Visual Basic [image] Copy Code

Property ProjectStart As Nullable(Of DateTime)

Property Value

A DateTime object, possibly null (Nothing in Visual Basic) to indicate no start time.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.RedoCommand Property

IProjectViewModel.RedoCommand Property
[image]

Gets a command which performs redo on the last undone action in the command history.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

ICommand RedoCommand { get; }

Visual Basic [image] Copy Code

ReadOnly Property RedoCommand As ICommand

Property Value

A .NET ICommand object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ResourceActivator Property

IProjectViewModel.ResourceActivator Property
[image]

Gets or sets a delegate that can be used to create new resources.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IActivator ResourceActivator { get; set; }

Visual Basic [image] Copy Code

Property ResourceActivator As IActivator

Property Value

An IActivator object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ResourceAllocationActivator Property

IProjectViewModel.ResourceAllocationActivator Property
[image]

Gets or sets a delegate that can be used to create new resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IActivator ResourceAllocationActivator { get; set; }

Visual Basic [image] Copy Code

Property ResourceAllocationActivator As IActivator

Property Value

An IActivator object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ResourceAllocations Property

IProjectViewModel.ResourceAllocations Property
[image]

Gets all resource allocations in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

IEnumerable<IResourceAllocationViewModel> ResourceAllocations { get; }

Visual Basic [image] Copy Code

ReadOnly Property ResourceAllocations As IEnumerable(Of IResourceAllocationViewModel)

Property Value

An enumeration of all resource allocations in the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ResourceAllocationType Property

IProjectViewModel.ResourceAllocationType Property
[image]

Gets or sets the type of resource allocations created through the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Type ResourceAllocationType { get; set; }

Visual Basic [image] Copy Code

Property ResourceAllocationType As Type

Property Value

A .NET Type object specifying the type of the resource allocations created through the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Resources Property

IProjectViewModel.Resources Property
[image]

Gets the top-level resources in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IResourceViewModel> Resources { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Resources As IEnumerable(Of IResourceViewModel)

Property Value

An enumeration of all resources in the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ResourceType Property

IProjectViewModel.ResourceType Property
[image]

Gets or sets the type of resources created through the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

Type ResourceType { get; set; }

Visual Basic [image] Copy Code

Property ResourceType As Type

Property Value

A .NET Type object specifying the type of the resource allocations created through the project.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.UndoCommand Property

IProjectViewModel.UndoCommand Property
[image]

Gets a command which performs undo on the current action saved in the command history.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

ICommand UndoCommand { get; }

Visual Basic [image] Copy Code

ReadOnly Property UndoCommand As ICommand

Property Value

A .NET ICommand object.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.UndoEnabled Property

IProjectViewModel.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Property UndoEnabled As Boolean

Property Value

true to enable undo and redo; false, to disable it.

Remarks

Setting this property to false will purge the current undo history.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel Events

IProjectViewModel Events
[image]

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when the activities or dependencies in the project are changed.
InvalidateActivityIndexes | Raised when the activity indices need to be reevaluated.

See Also

IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ActionRedone Event

IProjectViewModel.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.ActionUndone Event

IProjectViewModel.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.Changed Event

IProjectViewModel.Changed Event
[image]

Raised when the activities or dependencies in the project are changed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

event EventHandler Changed

Visual Basic [image] Copy Code

Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IProjectViewModel.InvalidateActivityIndexes Event

IProjectViewModel.InvalidateActivityIndexes Event
[image]

Raised when the activity indices need to be reevaluated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

event EventHandler InvalidateActivityIndexes

Visual Basic [image] Copy Code

Event InvalidateActivityIndexes As EventHandler

Event Data

InvalidateActivityIndexes event handlers receive an argument of type EventArgs.

See Also

IProjectViewModel Members
IProjectViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel Interface

IResourceAllocationViewModel Interface
[image]

Represents the allocation of a resource for a specific activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IResourceAllocationViewModel : IUndoable

Visual Basic [image] Copy Code

Public Interface IResourceAllocationViewModel
Implements IUndoable

See Also

IResourceAllocationViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel Members

IResourceAllocationViewModel Members
Properties Methods
[image]

Represents the allocation of a resource for a specific activity.

The following tables list the members exposed by the IResourceAllocationViewModel type.

Public Properties

Name | Description
Activity | Gets or sets the activity associated with this allocation.
ActivityName | Gets the name of the associated activity.
Duration | Gets or sets the duration time of the resource allocation.
EndTime | Gets or sets the end time of the resource allocation.
Progress | Gets or sets the progress of the allocation, expressed as a value in the range [0..1].
Resource | Gets or sets the resource associated with this allocation.
ScheduleMode | Gets the ScheduleMode of the associated activity.
StartTime | Gets or sets the start time of the resource allocation.

Public Methods

Name | Description
SetTimes | Sets the start time and duration of the allocation, optionally synchronizing the associated activity by calling its UpdateTimesFromAllocations method.

See Also

IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel Methods

IResourceAllocationViewModel Methods
[image]

Public Methods

Name | Description
SetTimes | Sets the start time and duration of the allocation, optionally synchronizing the associated activity by calling its UpdateTimesFromAllocations method.

See Also

IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.SetTimes Method

IResourceAllocationViewModel.SetTimes Method
[image]

Sets the start time and duration of the allocation, optionally synchronizing the associated activity by calling its UpdateTimesFromAllocations method.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

void SetTimes (
DateTime start,
TimeSpan duration,
bool updateTimesFromAllocations
)

Visual Basic [image] Copy Code

Sub SetTimes( _
start As DateTime, _
duration As TimeSpan, _
updateTimesFromAllocations As Boolean _
)

Parameters

start

The new start time of the allocation.

duration

The new duration of the allocation.

updateTimesFromAllocations
true to synchronize the associated activity; otherwise, false.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel Properties

IResourceAllocationViewModel Properties
[image]

Public Properties

Name | Description
Activity | Gets or sets the activity associated with this allocation.
ActivityName | Gets the name of the associated activity.
Duration | Gets or sets the duration time of the resource allocation.
EndTime | Gets or sets the end time of the resource allocation.
Progress | Gets or sets the progress of the allocation, expressed as a value in the range [0..1].
Resource | Gets or sets the resource associated with this allocation.
ScheduleMode | Gets the ScheduleMode of the associated activity.
StartTime | Gets or sets the start time of the resource allocation.

See Also

IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.Activity Property

IResourceAllocationViewModel.Activity Property
[image]

Gets or sets the activity associated with this allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IActivityViewModel Activity { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Activity As IActivityViewModel

Property Value

An IActivityViewModel object identifying the associated activity.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.ActivityName Property

IResourceAllocationViewModel.ActivityName Property
[image]

Gets the name of the associated activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

string ActivityName { get; }

Visual Basic [image] Copy Code

ReadOnly Property ActivityName As String

Property Value

A string specifying the name of the associated activity.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.Duration Property

IResourceAllocationViewModel.Duration Property
[image]

Gets or sets the duration time of the resource allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

TimeSpan Duration { get; set; }

Visual Basic [image] Copy Code

Property Duration As TimeSpan

Property Value

A .NET TimeSpan object.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.EndTime Property

IResourceAllocationViewModel.EndTime Property
[image]

Gets or sets the end time of the resource allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.Progress Property

IResourceAllocationViewModel.Progress Property
[image]

Gets or sets the progress of the allocation, expressed as a value in the range [0..1].

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

double Progress { get; set; }

Visual Basic [image] Copy Code

Property Progress As Double

Property Value

A double value specifying the progress.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.Resource Property

IResourceAllocationViewModel.Resource Property
[image]

Gets or sets the resource associated with this allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IResourceViewModel Resource { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Resource As IResourceViewModel

Property Value

An IResourceViewModel object identifying the associated resource.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.ScheduleMode Property

IResourceAllocationViewModel.ScheduleMode Property
[image]

Gets the ScheduleMode of the associated activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract ScheduleMode ScheduleMode { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property ScheduleMode As ScheduleMode

Property Value

A member of the ScheduleMode enumeration.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceAllocationViewModel.StartTime Property

IResourceAllocationViewModel.StartTime Property
[image]

Gets or sets the start time of the resource allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

IResourceAllocationViewModel Members
IResourceAllocationViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel Interface

IResourceViewModel Interface
[image]

Represents an resource in the ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IResourceViewModel : INotifyPropertyChanged, INotifyCollectionChanged, IUndoable, IItemViewModel

Visual Basic [image] Copy Code

Public Interface IResourceViewModel
Implements INotifyPropertyChanged, INotifyCollectionChanged, IUndoable, IItemViewModel

See Also

IResourceViewModel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel Members

IResourceViewModel Members
Properties Methods
[image]

Represents an resource in the ViewModel.

The following tables list the members exposed by the IResourceViewModel type.

Public Properties

Name | Description
Allocations | Gets a list with objects describing the activities this resource is allocated for.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

Public Methods

Name | Description
AddResourceAllocation | Add allocation to this resource
RemoveResourceAllocation | Removes the model resource allocation from this resource.
RemoveResourceAllocation | Removes the resource allocation from this resource.

See Also

IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel Methods

IResourceViewModel Methods
[image]

Public Methods

Name | Description
AddResourceAllocation | Add allocation to this resource
RemoveResourceAllocation | Removes the model resource allocation from this resource.
RemoveResourceAllocation | Removes the resource allocation from this resource.

See Also

IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.AddResourceAllocation Method

IResourceViewModel.AddResourceAllocation Method
[image]

Add allocation to this resource

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void AddResourceAllocation (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public MustOverride Sub AddResourceAllocation ( _
allocation As IResourceAllocationViewModel _
)

Parameters

allocation
An IResourceAllocationViewModel object providing the allocation information.

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.RemoveResourceAllocation Method

IResourceViewModel.RemoveResourceAllocation Method
[image]

Removes the model resource allocation from this resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

int RemoveResourceAllocation (
Object allocation
)

Visual Basic [image] Copy Code

Function RemoveResourceAllocation( _
allocation As Object _
) As Integer

Parameters

allocation

The model object to be removed

Return Value

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.RemoveResourceAllocation Method

IResourceViewModel.RemoveResourceAllocation Method
[image]

Removes the resource allocation from this resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract int RemoveResourceAllocation (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public MustOverride Function RemoveResourceAllocation ( _
allocation As IResourceAllocationViewModel _
) As Integer

Parameters

allocation
The IResourceAllocationViewModel object to be removed.

Return Value

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel Properties

IResourceViewModel Properties
[image]

Public Properties

Name | Description
Allocations | Gets a list with objects describing the activities this resource is allocated for.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

See Also

IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.Allocations Property

IResourceViewModel.Allocations Property
[image]

Gets a list with objects describing the activities this resource is allocated for.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract IEnumerable<IResourceAllocationViewModel> Allocations { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Allocations As IEnumerable(Of IResourceAllocationViewModel)

Property Value

An IEnumerable with all allocations of this resource.

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.Description Property

IResourceViewModel.Description Property
[image]

Gets or sets a description of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

string Description { get; set; }

Visual Basic [image] Copy Code

Property Description As String

Property Value

A string specifying the description.

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IResourceViewModel.Title Property

IResourceViewModel.Title Property
[image]

Gets or sets a title of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

string Title { get; set; }

Visual Basic [image] Copy Code

Property Title As String

Property Value

A string specifying the title.

See Also

IResourceViewModel Members
IResourceViewModel Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable Interface

IUndoable Interface
[image]

Represents an object which can save and restore its state.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public interface IUndoable

Visual Basic [image] Copy Code

Public Interface IUndoable

Inheritors

MindFusion.DataViews.Wpf.IActivityViewModel
MindFusion.DataViews.Wpf.IDependencyViewModel
MindFusion.DataViews.Wpf.IResourceAllocationViewModel
MindFusion.DataViews.Wpf.IResourceViewModel

See Also

IUndoable Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable Members

IUndoable Members
Methods
[image]

Represents an object which can save and restore its state.

The following tables list the members exposed by the IUndoable type.

Public Methods

Name | Description
CreateState | Creates an empty state object corresponding to the concrete type of this IUndoable.
RestoreState | Restores the state of this IUndoable object.
SaveState | Saves the state of this IUndoable object.

See Also

IUndoable Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable Methods

IUndoable Methods
[image]

Public Methods

Name | Description
CreateState | Creates an empty state object corresponding to the concrete type of this IUndoable.
RestoreState | Restores the state of this IUndoable object.
SaveState | Saves the state of this IUndoable object.

See Also

IUndoable Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable.CreateState Method

IUndoable.CreateState Method
[image]

Creates an empty state object corresponding to the concrete type of this IUndoable.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract UndoState CreateState ()

Visual Basic [image] Copy Code

Public MustOverride Function CreateState () As UndoState

Return Value

An instance of an UndoState-derived class.

See Also

IUndoable Members
IUndoable Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable.RestoreState Method

IUndoable.RestoreState Method
[image]

Restores the state of this IUndoable object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract void RestoreState (
UndoState state
)

Visual Basic [image] Copy Code

Public MustOverride Sub RestoreState ( _
state As UndoState _
)

Parameters

state
An UndoState that represents previous state of the item.

See Also

IUndoable Members
IUndoable Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.IUndoable.SaveState Method

IUndoable.SaveState Method
[image]

Saves the state of this IUndoable object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract UndoState SaveState ()

Visual Basic [image] Copy Code

Public MustOverride Function SaveState () As UndoState

Return Value

An UndoState instance that represents the current state of the item.

See Also

IUndoable Members
IUndoable Interface
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn Class

NumericColumn Class
[image]

A column in a DataGrid which displays numeric values.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class NumericColumn : GridColumn

Visual Basic [image] Copy Code

Public Class NumericColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.NumericColumn

See Also

NumericColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn Members

NumericColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays numeric values.

The following tables list the members exposed by the NumericColumn type.

Public Constructors

Name | Description
NumericColumn | Initializes a new instance of the NumericColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn Constructor

NumericColumn Constructor
[image]

Initializes a new instance of the NumericColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public NumericColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn Methods

NumericColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.CancelEdit Method

NumericColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.CommitEdit Method

NumericColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.ConfirmBeginEdit Method

NumericColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.CreateEditor Method

NumericColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.CreateViewer Method

NumericColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.NumericColumn.InitEditor Method

NumericColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

NumericColumn Members
NumericColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.PopupPlacement Enumeration

PopupPlacement Enumeration
[image]

Specifies the placement target for item and dependency popups.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum PopupPlacement

Visual Basic [image] Copy Code

Public Enum PopupPlacement

Members

Member name | Description
RelativeToItem | Specifies that the popup is placed relative to the item.
Static | Specifies that the popup is placed in a static position, relative to the chart object; Actual position is the top right corner of the left grid in a chart.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectEventArgs Class

ProjectEventArgs Class
[image]

Contains the arguments passed to event handlers related to the view model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ProjectEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ProjectEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.ProjectEventArgs
MindFusion.DataViews.Wpf.ProjectMouseEventArgs
MindFusion.DataViews.Wpf.ProjectValidationEventArgs

See Also

ProjectEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectEventArgs Members

ProjectEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers related to the view model.

The following tables list the members exposed by the ProjectEventArgs type.

Public Constructors

Name | Description
ProjectEventArgs | Initializes a new instance of the ProjectEventArgs class.

Public Properties

Name | Description
Element | Gets the element related to the event.

See Also

ProjectEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectEventArgs Constructor

ProjectEventArgs Constructor
[image]

Initializes a new instance of the ProjectEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ProjectEventArgs (
Object element
)

Visual Basic [image] Copy Code

Public New ( _
element As Object _
)

Parameters

element

The element related to the event.

See Also

ProjectEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectEventArgs Properties

ProjectEventArgs Properties
[image]

Public Properties

Name | Description
Element | Gets the element related to the event.

See Also

ProjectEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectEventArgs.Element Property

ProjectEventArgs.Element Property
[image]

Gets the element related to the event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Element { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Element As Object

Property Value

An object identifying the related element.

See Also

ProjectEventArgs Members
ProjectEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs Class

ProjectMouseEventArgs Class
[image]

Contains the arguments passed to mouse event handlers related to the view model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ProjectMouseEventArgs : ProjectEventArgs

Visual Basic [image] Copy Code

Public Class ProjectMouseEventArgs
Inherits ProjectEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.ProjectEventArgs
MindFusion.DataViews.Wpf.ProjectMouseEventArgs

See Also

ProjectMouseEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs Members

ProjectMouseEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to mouse event handlers related to the view model.

The following tables list the members exposed by the ProjectMouseEventArgs type.

Public Constructors

Name | Description
ProjectMouseEventArgs | Initializes a new instance of the ProjectMouseEventArgs class.

Public Properties

Name | Description
ClickCount | Gets the number of times the button has been clicked.
Element | Gets the element related to the event. (Inherited from ProjectEventArgs.)
LeftButtonDown | Gets a value indicating whether the left mouse button is pressed.
MiddleButtonDown | Gets a value indicating whether the middle mouse button is pressed.
Position | Gets the mouse position, relative to the element.
RightButtonDown | Gets a value indicating whether the right mouse button is pressed.

See Also

ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs Constructor

ProjectMouseEventArgs Constructor
[image]

Initializes a new instance of the ProjectMouseEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ProjectMouseEventArgs (
Object element,
Point position,
bool leftButtonDown,
bool middleButtonDown,
bool rightButtonDown,
int clickCount
)

Visual Basic [image] Copy Code

Public New ( _
element As Object, _
position As Point, _
leftButtonDown As Boolean, _
middleButtonDown As Boolean, _
rightButtonDown As Boolean, _
clickCount As Integer _
)

Parameters

element

The element related to the event.

position

The mouse position relative to the element.

leftButtonDown
true if the left mouse button is pressed; otherwise, false.
middleButtonDown
true if the middle mouse button is pressed; otherwise, false.
rightButtonDown
true if the right mouse button is pressed; otherwise, false.
clickCount

The number of times the button has been clicked.

See Also

ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs Properties

ProjectMouseEventArgs Properties
[image]

Public Properties

Name | Description
ClickCount | Gets the number of times the button has been clicked.
Element | Gets the element related to the event. (Inherited from ProjectEventArgs.)
LeftButtonDown | Gets a value indicating whether the left mouse button is pressed.
MiddleButtonDown | Gets a value indicating whether the middle mouse button is pressed.
Position | Gets the mouse position, relative to the element.
RightButtonDown | Gets a value indicating whether the right mouse button is pressed.

See Also

ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs.ClickCount Property

ProjectMouseEventArgs.ClickCount Property
[image]

Gets the number of times the button has been clicked.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int ClickCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClickCount As Integer

Property Value

An integer value specifying the number of clicks.

See Also

ProjectMouseEventArgs Members
ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs.LeftButtonDown Property

ProjectMouseEventArgs.LeftButtonDown Property
[image]

Gets a value indicating whether the left mouse button is pressed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool LeftButtonDown { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LeftButtonDown As Boolean

Property Value

true if the left mouse button is pressed; otherwise, false.

See Also

ProjectMouseEventArgs Members
ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs.MiddleButtonDown Property

ProjectMouseEventArgs.MiddleButtonDown Property
[image]

Gets a value indicating whether the middle mouse button is pressed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool MiddleButtonDown { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MiddleButtonDown As Boolean

Property Value

true if the middle mouse button is pressed; otherwise, false.

See Also

ProjectMouseEventArgs Members
ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs.Position Property

ProjectMouseEventArgs.Position Property
[image]

Gets the mouse position, relative to the element.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A WPF Point specifying the mouse position.

See Also

ProjectMouseEventArgs Members
ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectMouseEventArgs.RightButtonDown Property

ProjectMouseEventArgs.RightButtonDown Property
[image]

Gets a value indicating whether the right mouse button is pressed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool RightButtonDown { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RightButtonDown As Boolean

Property Value

true if the right mouse button is pressed; otherwise, false.

See Also

ProjectMouseEventArgs Members
ProjectMouseEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectValidationEventArgs Class

ProjectValidationEventArgs Class
[image]

Contains the arguments passed to validation event handlers related to the view model.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ProjectValidationEventArgs : ProjectEventArgs

Visual Basic [image] Copy Code

Public Class ProjectValidationEventArgs
Inherits ProjectEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.ProjectEventArgs
MindFusion.DataViews.Wpf.ProjectValidationEventArgs

See Also

ProjectValidationEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectValidationEventArgs Members

ProjectValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to validation event handlers related to the view model.

The following tables list the members exposed by the ProjectValidationEventArgs type.

Public Constructors

Name | Description
ProjectValidationEventArgs | Initializes a new instance of the ProjectValidationEventArgs class.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Element | Gets the element related to the event. (Inherited from ProjectEventArgs.)

See Also

ProjectValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectValidationEventArgs Constructor

ProjectValidationEventArgs Constructor
[image]

Initializes a new instance of the ProjectValidationEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ProjectValidationEventArgs (
Object element
)

Visual Basic [image] Copy Code

Public New ( _
element As Object _
)

Parameters

element

The element related to the event.

See Also

ProjectValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectValidationEventArgs Properties

ProjectValidationEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Element | Gets the element related to the event. (Inherited from ProjectEventArgs.)

See Also

ProjectValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ProjectValidationEventArgs.Confirm Property

ProjectValidationEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true to confirm the operation; false, to reject it. The default is true.

See Also

ProjectValidationEventArgs Members
ProjectValidationEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand Class

RemoveActivityCommand Class
[image]

Implements removal of activities from the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class RemoveActivityCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveActivityCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.RemoveActivityCommand

See Also

RemoveActivityCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand Members

RemoveActivityCommand Members
Constructors Properties Methods
[image]

Implements removal of activities from the underlying ViewModel.

The following tables list the members exposed by the RemoveActivityCommand type.

Public Constructors

Name | Description
RemoveActivityCommand | Initializes a new instance of the RemoveActivityCommand class.

Public Properties

Name | Description
Result | Gets the 0-based index of the removed activity within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand Constructor

RemoveActivityCommand Constructor
[image]

Initializes a new instance of the RemoveActivityCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public RemoveActivityCommand (
IProjectViewModel project,
IActivityViewModel activity
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
activity As IActivityViewModel _
)

Parameters

project

The project this command will operate on.

activity

The activity to remove.

See Also

RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand Methods

RemoveActivityCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand.Execute Method

RemoveActivityCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the activity was removed successfully from the ViewModel; otherwise, false.

See Also

RemoveActivityCommand Members
RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand.Redo Method

RemoveActivityCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveActivityCommand Members
RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand.Undo Method

RemoveActivityCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveActivityCommand Members
RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand Properties

RemoveActivityCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the 0-based index of the removed activity within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveActivityCommand.Result Property

RemoveActivityCommand.Result Property
[image]

Gets the 0-based index of the removed activity within its containing collection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As Integer

Property Value

An integer specifying the 0-based index of the removed activity.

See Also

RemoveActivityCommand Members
RemoveActivityCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand Class

RemoveDependencyCommand Class
[image]

Implements removal of dependencies from the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class RemoveDependencyCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveDependencyCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.RemoveDependencyCommand

See Also

RemoveDependencyCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand Members

RemoveDependencyCommand Members
Constructors Properties Methods
[image]

Implements removal of dependencies from the underlying ViewModel.

The following tables list the members exposed by the RemoveDependencyCommand type.

Public Constructors

Name | Description
RemoveDependencyCommand | Initializes a new instance of the RemoveDependencyCommand class.

Public Properties

Name | Description
Result | Gets the 0-based index of the removed dependency within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand Constructor

RemoveDependencyCommand Constructor
[image]

Initializes a new instance of the RemoveDependencyCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public RemoveDependencyCommand (
IProjectViewModel project,
IDependencyViewModel dependency
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
dependency As IDependencyViewModel _
)

Parameters

project

The project this command will operate on.

dependency

The dependency to remove.

See Also

RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand Methods

RemoveDependencyCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand.Execute Method

RemoveDependencyCommand.Execute Method
[image]

Command.Execute override

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the dependency was removed successfully from the ViewModel; otherwise, false.

See Also

RemoveDependencyCommand Members
RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand.Redo Method

RemoveDependencyCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveDependencyCommand Members
RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand.Undo Method

RemoveDependencyCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveDependencyCommand Members
RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand Properties

RemoveDependencyCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the 0-based index of the removed dependency within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveDependencyCommand.Result Property

RemoveDependencyCommand.Result Property
[image]

Gets the 0-based index of the removed dependency within its containing collection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As Integer

Property Value

An integer specifying the 0-based index of the removed dependency.

See Also

RemoveDependencyCommand Members
RemoveDependencyCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand Class

RemoveResourceAllocationCommand Class
[image]

Implements removal of resource allocations from the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class RemoveResourceAllocationCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveResourceAllocationCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand

See Also

RemoveResourceAllocationCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand Members

RemoveResourceAllocationCommand Members
Constructors Properties Methods
[image]

Implements removal of resource allocations from the underlying ViewModel.

The following tables list the members exposed by the RemoveResourceAllocationCommand type.

Public Constructors

Name | Description
RemoveResourceAllocationCommand | Initializes a new instance of the RemoveResourceCommand class.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand Constructor

RemoveResourceAllocationCommand Constructor
[image]

Initializes a new instance of the RemoveResourceCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public RemoveResourceAllocationCommand (
IProjectViewModel project,
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
allocation As IResourceAllocationViewModel _
)

Parameters

project

The project this command will operate on.

allocation

The resource allocation to remove.

See Also

RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand Methods

RemoveResourceAllocationCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand.Execute Method

RemoveResourceAllocationCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the allocation was removed successfully from the ViewModel; otherwise, false.

See Also

RemoveResourceAllocationCommand Members
RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand.Redo Method

RemoveResourceAllocationCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveResourceAllocationCommand Members
RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceAllocationCommand.Undo Method

RemoveResourceAllocationCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveResourceAllocationCommand Members
RemoveResourceAllocationCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand Class

RemoveResourceCommand Class
[image]

Implements removal of activities from the underlying ViewModel.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class RemoveResourceCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveResourceCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Command
MindFusion.DataViews.Wpf.RemoveResourceCommand

See Also

RemoveResourceCommand Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand Members

RemoveResourceCommand Members
Constructors Properties Methods
[image]

Implements removal of activities from the underlying ViewModel.

The following tables list the members exposed by the RemoveResourceCommand type.

Public Constructors

Name | Description
RemoveResourceCommand | Initializes a new instance of the RemoveResourceCommand class.

Public Properties

Name | Description
Result | Gets the 0-based index of the removed resource within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand Constructor

RemoveResourceCommand Constructor
[image]

Initializes a new instance of the RemoveResourceCommand class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public RemoveResourceCommand (
IProjectViewModel project,
IResourceViewModel resource
)

Visual Basic [image] Copy Code

Public New ( _
project As IProjectViewModel, _
resource As IResourceViewModel _
)

Parameters

project

The project this command will operate on.

resource

The resource to remove.

See Also

RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand Methods

RemoveResourceCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand.Execute Method

RemoveResourceCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the resource was removed successfully from the ViewModel; otherwise, false.

See Also

RemoveResourceCommand Members
RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand.Redo Method

RemoveResourceCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveResourceCommand Members
RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand.Undo Method

RemoveResourceCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveResourceCommand Members
RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand Properties

RemoveResourceCommand Properties
[image]

Public Properties

Name | Description
Result | Gets the 0-based index of the removed resource within its containing collection.

Protected Properties

Name | Description
Project | Gets the ViewModel modified by this Command object. (Inherited from Command.)

See Also

RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RemoveResourceCommand.Result Property

RemoveResourceCommand.Result Property
[image]

Gets the 0-based index of the removed resource within its containing collection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int Result { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Result As Integer

Property Value

An integer specifying the 0-based index of the removed resource.

See Also

RemoveResourceCommand Members
RemoveResourceCommand Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Class

Resource Class
Remarks See Also
[image]

A model class that represents a resource instance in resource charts.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class Resource : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Resource
Implements INotifyPropertyChanged

Remarks

The class implements INotifyPropertyChanged interface to facilitate data binding.

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.Resource

See Also

Resource Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Members

Resource Members
Constructors Properties Methods Events
[image]

A model class that represents a resource instance in resource charts.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Creates a new instance of the Resource class.

Public Properties

Name | Description
Allocations | Gets or sets the collection object that holds the activities, associated with the resource instance.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event with the provided parameters.

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Constructor

Resource Constructor
[image]

Creates a new instance of the Resource class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Resource ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Methods

Resource Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event with the provided parameters.

See Also

Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource.OnPropertyChanged Method

Resource.OnPropertyChanged Method
[image]

Raises the PropertyChanged event with the provided parameters.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected void OnPropertyChanged (
string name
)

Visual Basic [image] Copy Code

Protected Sub OnPropertyChanged( _
name As String _
)

Parameters

name

the name of the property.

See Also

Resource Members
Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Properties

Resource Properties
[image]

Public Properties

Name | Description
Allocations | Gets or sets the collection object that holds the activities, associated with the resource instance.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

See Also

Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource.Allocations Property

Resource.Allocations Property
[image]

Gets or sets the collection object that holds the activities, associated with the resource instance.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Object> Allocations { get; set; }

Visual Basic [image] Copy Code

Public Property Allocations As ObservableCollection(Of Object)

Property Value

A collection with all allocations of this resource.

See Also

Resource Members
Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource.Description Property

Resource.Description Property
[image]

Gets or sets a description of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string specifying the resource's description.

See Also

Resource Members
Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource.Title Property

Resource.Title Property
[image]

Gets or sets a title of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string specifying the resource's title.

See Also

Resource Members
Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource Events

Resource Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.Resource.PropertyChanged Event

Resource.PropertyChanged Event
[image]

Occurs when a property value changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Resource Members
Resource Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation Class

ResourceAllocation Class
[image]

A model class that represents a resource allocation in activity or resource charts.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ResourceAllocation : Activity

Visual Basic [image] Copy Code

Public Class ResourceAllocation
Inherits Activity

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.ResourceAllocation

See Also

ResourceAllocation Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation Members

ResourceAllocation Members
Constructors Properties Events
[image]

A model class that represents a resource allocation in activity or resource charts.

The following tables list the members exposed by the ResourceAllocation type.

Public Constructors

Name | Description
ResourceAllocation | Initializes a new instance of the ResourceAllocation class.

Public Properties

Name | Description
Activity | Gets or sets the activity for which the resource is allocated.
ActivityName | Gets or sets the name of the activity.
EndTime | Gets or sets the end time of the allocation.
Progress | Gets or sets the progress/completion of the allocation.
Resource | Gets or sets the allocated resource.
StartTime | Gets or sets the start time of the allocation.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation Constructor

ResourceAllocation Constructor
[image]

Initializes a new instance of the ResourceAllocation class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ResourceAllocation ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation Properties

ResourceAllocation Properties
[image]

Public Properties

Name | Description
Activity | Gets or sets the activity for which the resource is allocated.
ActivityName | Gets or sets the name of the activity.
EndTime | Gets or sets the end time of the allocation.
Progress | Gets or sets the progress/completion of the allocation.
Resource | Gets or sets the allocated resource.
StartTime | Gets or sets the start time of the allocation.

See Also

ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.Activity Property

ResourceAllocation.Activity Property
[image]

Gets or sets the activity for which the resource is allocated.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Activity { get; set; }

Visual Basic [image] Copy Code

Public Property Activity As Object

Property Value

An object identifying the associated activity.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.ActivityName Property

ResourceAllocation.ActivityName Property
[image]

Gets or sets the name of the activity.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string ActivityName { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityName As String

Property Value

A string value.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.EndTime Property

ResourceAllocation.EndTime Property
[image]

Gets or sets the end time of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A DateTime object.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.Progress Property

ResourceAllocation.Progress Property
[image]

Gets or sets the progress/completion of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Double

Property Value

A double value indicating the progress in the range [0..100].

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.Resource Property

ResourceAllocation.Resource Property
[image]

Gets or sets the allocated resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Resource { get; set; }

Visual Basic [image] Copy Code

Public Property Resource As Object

Property Value

An object identifying the associated resource.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.StartTime Property

ResourceAllocation.StartTime Property
[image]

Gets or sets the start time of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A DateTime object.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation Events

ResourceAllocation Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocation.PropertyChanged Event

ResourceAllocation.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

ResourceAllocation Members
ResourceAllocation Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState Class

ResourceAllocationState Class
[image]

Encapsulates the state of a resource allocation for subsequent undo operations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ResourceAllocationState : UndoState

Visual Basic [image] Copy Code

Public Class ResourceAllocationState
Inherits UndoState

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.UndoState
MindFusion.DataViews.Wpf.ResourceAllocationState

See Also

ResourceAllocationState Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState Members

ResourceAllocationState Members
Constructors Properties Methods
[image]

Encapsulates the state of a resource allocation for subsequent undo operations.

The following tables list the members exposed by the ResourceAllocationState type.

Public Constructors

Name | Description
ResourceAllocationState | Initializes a new instance of the ResourceAllocationState class.

Public Properties

Name | Description
EndTime | Gets or sets the end time of the allocation.
Progress | Gets or sets the progress of the allocation.
StartTime | Gets or sets the start time of the allocation.

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState Constructor

ResourceAllocationState Constructor
[image]

Initializes a new instance of the ResourceAllocationState class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ResourceAllocationState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState Methods

ResourceAllocationState Methods
[image]

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState.Equals Method

ResourceAllocationState.Equals Method
[image]

UndoState.Equals override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
UndoState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As UndoState _
) As Boolean

Parameters

other

An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

ResourceAllocationState Members
ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState Properties

ResourceAllocationState Properties
[image]

Public Properties

Name | Description
EndTime | Gets or sets the end time of the allocation.
Progress | Gets or sets the progress of the allocation.
StartTime | Gets or sets the start time of the allocation.

See Also

ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState.EndTime Property

ResourceAllocationState.EndTime Property
[image]

Gets or sets the end time of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

ResourceAllocationState Members
ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState.Progress Property

ResourceAllocationState.Progress Property
[image]

Gets or sets the progress of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Double

Property Value

A double value specifying the allocation progress.

See Also

ResourceAllocationState Members
ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceAllocationState.StartTime Property

ResourceAllocationState.StartTime Property
[image]

Gets or sets the start time of the allocation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

ResourceAllocationState Members
ResourceAllocationState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Class

ResourceChart Class
[image]

Displays resource allocation for tasks over a period of time.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ResourceChart : BaseChart

Visual Basic [image] Copy Code

Public Class ResourceChart
Inherits BaseChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.BaseChart
MindFusion.DataViews.Wpf.ResourceChart

See Also

ResourceChart Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Members

ResourceChart Members
Constructors Fields Properties Methods Events
[image]

Displays resource allocation for tasks over a period of time.

The following tables list the members exposed by the ResourceChart type.

Public Constructors

Name | Description
ResourceChart | Initializes a new instance of the ResourceChart class.

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property. (Inherited from BaseChart.)
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property. (Inherited from BaseChart.)
ActivityNameForegroundProperty | Identifies the ActivityNameForeground dependency property.
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property. (Inherited from BaseChart.)
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property. (Inherited from BaseChart.)
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property. (Inherited from BaseChart.)
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property. (Inherited from BaseChart.)
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property. (Inherited from BaseChart.)
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property. (Inherited from BaseChart.)
DataTypeProperty | Identifies the DataType dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property. (Inherited from BaseChart.)
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property. (Inherited from BaseChart.)
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property. (Inherited from BaseChart.)
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property. (Inherited from BaseChart.)
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from BaseChart.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from BaseChart.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from BaseChart.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from BaseChart.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from BaseChart.)
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. (Inherited from BaseChart.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BaseChart.)
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property. (Inherited from BaseChart.)
ItemBackgroundProperty | Identifies the ItemBackground dependency property. (Inherited from BaseChart.)
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property. (Inherited from BaseChart.)
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property. (Inherited from BaseChart.)
ItemHeightProperty | Identifies the ItemHeight dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property. (Inherited from BaseChart.)
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property. (Inherited from BaseChart.)
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property. (Inherited from BaseChart.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property. (Inherited from BaseChart.)
PopupPlacementProperty | Identifies the PopupPlacement dependency property. (Inherited from BaseChart.)
PopupStyleProperty | Identifies the PopupStyle dependency property. (Inherited from BaseChart.)
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property. (Inherited from BaseChart.)
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property. (Inherited from BaseChart.)
ShowActivitiesProperty | Identifies the ShowActivities dependency property.
ShowNowProperty | Identifies the ShowNow dependency property. (Inherited from BaseChart.)
ShowPopupsProperty | Identifies the ShowPopups dependency property. (Inherited from BaseChart.)
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property. (Inherited from BaseChart.)
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property. (Inherited from BaseChart.)
TimelineHeaderProperty | Identifies the TimelineHeader dependency property. (Inherited from BaseChart.)

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property. (Inherited from BaseChart.)
ActivityNameForeground | Gets or sets the Foreground of the text, displaying the name of the allocated activity in an AllocationPresenter. This is a dependency property.
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds. (Inherited from BaseChart.)
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control. (Inherited from BaseChart.)
DataType | Gets or sets the type of the data contained in the grid. This is a dependency property.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property. (Inherited from BaseChart.)
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property. (Inherited from BaseChart.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property. (Inherited from BaseChart.)
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property. (Inherited from BaseChart.)
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property. (Inherited from BaseChart.)
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property. (Inherited from BaseChart.)
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property. (Inherited from BaseChart.)
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property. (Inherited from BaseChart.)
Project | Gets the IProjectViewModel object assigned to this chart. (Inherited from BaseChart.)
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ShowActivities | Gets or sets a value indicating whether an allocation presenter will display the name of the activity it's allocatated to. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property. (Inherited from BaseChart.)
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property. (Inherited from BaseChart.)

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state. (Inherited from BaseChart.)

Public Methods

Name | Description
CreateChartImage | Creates a bitmap containing an image of the chart. (Inherited from BaseChart.)
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property. (Inherited from BaseChart.)
DrillIn | Overloaded. Zooms in the view. (Inherited from BaseChart.)
DrillOut | Overloaded. Zooms out the view. (Inherited from BaseChart.)
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline. (Inherited from BaseChart.)
OnApplyTemplate | BaseChart.OnApplyTemplate override.
ScrollIntoView | Overloaded. Scrolls to a given allocation or resource.

Protected Methods

Name | Description
OnAllocationClicked | Raises the AllocationClicked event.
OnAllocationModified | Raises the AllocationModified event.
OnAllocationModifying | Raises the AllocationModifying event.
OnAllocationPresenterCreated | Raises the AllocationPresenterCreated event.
OnDrilledIn | Raises the DrilledIn event. (Inherited from BaseChart.)
OnDrilledOut | Raises the DrilledOut event. (Inherited from BaseChart.)
OnDrillingIn | Raises the DrillingIn event. (Inherited from BaseChart.)
OnDrillingOut | Raises the DrillingOut event. (Inherited from BaseChart.)
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BaseChart.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BaseChart.)
OnLostFocus | Control.OnLostFocus override. (Inherited from BaseChart.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from BaseChart.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from BaseChart.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseChart.)
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override. (Inherited from BaseChart.)
OnPreviewMouseUp | Control.OnPreviewMouseUp override. (Inherited from BaseChart.)
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override. (Inherited from BaseChart.)
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event. (Inherited from BaseChart.)

Public Events

Name | Description
AllocationClicked | Raised when the user clicks on an allocation with the mouse.
AllocationModified | Raised when the user has modified an allocation interactively.
AllocationModifying | Raised when the user is modifying an allocation interactively.
AllocationPresenterCreated | Raised when an AllocationPresenter object is created for an IResourceAllocationViewModel to allow customization of the presenter.
DrilledIn | Raised when the view was drilled in. (Inherited from BaseChart.)
DrilledOut | Raised when the view was drilled out. (Inherited from BaseChart.)
DrillingIn | Raised when the view is currently drilling in. (Inherited from BaseChart.)
DrillingOut | Raised when the view is currently drilling out. (Inherited from BaseChart.)
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes. (Inherited from BaseChart.)

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Fields

ResourceChart Fields
[image]

Public Fields

Name | Description
ActivityChildrenExpressionProperty | Identifies the ActivityChildrenExpression dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpressionProperty | Identifies the ActivityEndTimeExpression dependency property. (Inherited from BaseChart.)
ActivityNameExpressionProperty | Identifies the ActivityNameExpression dependency property. (Inherited from BaseChart.)
ActivityNameForegroundProperty | Identifies the ActivityNameForeground dependency property.
ActivityProgressExpressionProperty | Identifies the ActivityProgressExpression dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpressionProperty | Identifies the ActivityStartTimeExpression dependency property. (Inherited from BaseChart.)
AllocationActivityExpressionProperty | Identifies the AllocationActivityExpression dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpressionProperty | Identifies the AllocationEndTimeExpression dependency property. (Inherited from BaseChart.)
AllocationProgressExpressionProperty | Identifies the AllocationProgressExpression dependency property. (Inherited from BaseChart.)
AllocationResourceExpressionProperty | Identifies the AllocationResourceExpression dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpressionProperty | Identifies the AllocationStartTimeExpression dependency property. (Inherited from BaseChart.)
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property. (Inherited from BaseChart.)
AllowInfiniteScrollProperty | Identifies the AllowInfiniteScroll dependency property. (Inherited from BaseChart.)
DataTypeProperty | Identifies the DataType dependency property.
DependencyFromExpressionProperty | Identifies the DependencyFromExpression dependency property. (Inherited from BaseChart.)
DependencyToExpressionProperty | Identifies the DependencyToExpression dependency property. (Inherited from BaseChart.)
DependencyTypeExpressionProperty | Identifies the DependencyTypeExpression dependency property. (Inherited from BaseChart.)
ExpressionConverterProperty | Identifies the ExpressionConverter dependency property. (Inherited from BaseChart.)
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from BaseChart.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from BaseChart.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from BaseChart.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from BaseChart.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from BaseChart.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from BaseChart.)
IsSnappingEnabledProperty | Identifies the IsSnappingEnabled dependency property. (Inherited from BaseChart.)
IsSnappingProperty | Identifies the IsSnapping dependency property. (Inherited from BaseChart.)
ItemAccentBrushProperty | Identifies the ItemAccentBrush dependency property. (Inherited from BaseChart.)
ItemBackgroundProperty | Identifies the ItemBackground dependency property. (Inherited from BaseChart.)
ItemBorderBrushProperty | Identifies the ItemBorderBrush dependency property. (Inherited from BaseChart.)
ItemFocusBrushProperty | Identifies the ItemFocusBrush dependency property. (Inherited from BaseChart.)
ItemHeightProperty | Identifies the ItemHeight dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursorProperty | Identifies the ItemLeftResizeCursor dependency property. (Inherited from BaseChart.)
ItemMouseOverBackgroundProperty | Identifies the ItemMouseOverBackground dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrushProperty | Identifies the ItemMouseOverBorderBrush dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursorProperty | Identifies the ItemProgressResizeCursor dependency property. (Inherited from BaseChart.)
ItemRightResizeCursorProperty | Identifies the ItemRightResizeCursor dependency property. (Inherited from BaseChart.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LeftPanelWidthProperty | Identifies the LeftPanelWidth dependency property. (Inherited from BaseChart.)
PopupPlacementProperty | Identifies the PopupPlacement dependency property. (Inherited from BaseChart.)
PopupStyleProperty | Identifies the PopupStyle dependency property. (Inherited from BaseChart.)
RelativeTimelineDateProperty | Identifies the RelativeTimelineDate dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpressionProperty | Identifies the ResourceDescriptionExpression dependency property. (Inherited from BaseChart.)
ResourceTitleExpressionProperty | Identifies the ResourceTitleExpression dependency property. (Inherited from BaseChart.)
ShowActivitiesProperty | Identifies the ShowActivities dependency property.
ShowNowProperty | Identifies the ShowNow dependency property. (Inherited from BaseChart.)
ShowPopupsProperty | Identifies the ShowPopups dependency property. (Inherited from BaseChart.)
ShowStartEndIndicatorsProperty | Identifies the ShowStartEndIndicators depednency property. (Inherited from BaseChart.)
SnappingPointCountProperty | Identifies the SnappingPointCount dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfterProperty | Identifies the TimelineDateTimeUnitsAfter dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBeforeProperty | Identifies the TimelineDateTimeUnitsBefore dependency property. (Inherited from BaseChart.)
TimelineHeaderProperty | Identifies the TimelineHeader dependency property. (Inherited from BaseChart.)

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ActivityNameForegroundProperty Field

ResourceChart.ActivityNameForegroundProperty Field
[image]

Identifies the ActivityNameForeground dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActivityNameForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActivityNameForegroundProperty As DependencyProperty

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.DataTypeProperty Field

ResourceChart.DataTypeProperty Field
[image]

Identifies the DataType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataTypeProperty As DependencyProperty

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ItemTemplateProperty Field

ResourceChart.ItemTemplateProperty Field
[image]

Identifies the ItemTemplate dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ShowActivitiesProperty Field

ResourceChart.ShowActivitiesProperty Field
[image]

Identifies the ShowActivities dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowActivitiesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowActivitiesProperty As DependencyProperty

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Constructor

ResourceChart Constructor
[image]

Initializes a new instance of the ResourceChart class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ResourceChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Methods

ResourceChart Methods
[image]

Public Methods

Name | Description
CreateChartImage | Creates a bitmap containing an image of the chart. (Inherited from BaseChart.)
CreateViewModel | Creates a new ViewModel for the specified activity and dependency models. The ViewModel is automatically associated with the chart through its DataContext property. (Inherited from BaseChart.)
DrillIn | Overloaded. Zooms in the view. (Inherited from BaseChart.)
DrillOut | Overloaded. Zooms out the view. (Inherited from BaseChart.)
DrillTo | Overloaded. Zooms the view to a specified relative date, specifying the settings for the bottom timeline. (Inherited from BaseChart.)
OnApplyTemplate | BaseChart.OnApplyTemplate override.
ScrollIntoView | Overloaded. Scrolls to a given allocation or resource.

Protected Methods

Name | Description
OnAllocationClicked | Raises the AllocationClicked event.
OnAllocationModified | Raises the AllocationModified event.
OnAllocationModifying | Raises the AllocationModifying event.
OnAllocationPresenterCreated | Raises the AllocationPresenterCreated event.
OnDrilledIn | Raises the DrilledIn event. (Inherited from BaseChart.)
OnDrilledOut | Raises the DrilledOut event. (Inherited from BaseChart.)
OnDrillingIn | Raises the DrillingIn event. (Inherited from BaseChart.)
OnDrillingOut | Raises the DrillingOut event. (Inherited from BaseChart.)
OnKeyDown | UIElement.OnKeyDown override. (Inherited from BaseChart.)
OnKeyUp | UIElement.OnKeyUp override. (Inherited from BaseChart.)
OnLostFocus | Control.OnLostFocus override. (Inherited from BaseChart.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from BaseChart.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from BaseChart.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseChart.)
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override. (Inherited from BaseChart.)
OnPreviewMouseUp | Control.OnPreviewMouseUp override. (Inherited from BaseChart.)
OnPreviewMouseWheel | UIElement.OnPreviewMouseWheel override. (Inherited from BaseChart.)
OnRelativeTimelineDateChanged | Raises the RelativeTimelineDateChanged event. (Inherited from BaseChart.)

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.OnAllocationClicked Method

ResourceChart.OnAllocationClicked Method
[image]

Raises the AllocationClicked event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAllocationClicked (
ProjectMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAllocationClicked ( _
e As ProjectMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.OnAllocationModified Method

ResourceChart.OnAllocationModified Method
[image]

Raises the AllocationModified event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAllocationModified (
ProjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAllocationModified ( _
e As ProjectEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.OnAllocationModifying Method

ResourceChart.OnAllocationModifying Method
[image]

Raises the AllocationModifying event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAllocationModifying (
ProjectValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAllocationModifying ( _
e As ProjectValidationEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.OnAllocationPresenterCreated Method

ResourceChart.OnAllocationPresenterCreated Method
[image]

Raises the AllocationPresenterCreated event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAllocationPresenterCreated (
BasePresenterEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAllocationPresenterCreated ( _
e As BasePresenterEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.OnApplyTemplate Method

ResourceChart.OnApplyTemplate Method
[image]

BaseChart.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ScrollIntoView Method

ResourceChart.ScrollIntoView Method
[image]

Scrolls to a given allocation or resource.

Overload List

Name | Description
ResourceChart.ScrollIntoView (IResourceAllocationViewModel) | Scrolls to a given allocation in the schedule grid.
ResourceChart.ScrollIntoView (IResourceViewModel) | Scrolls to a given resource in the chart.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ScrollIntoView Method (IResourceAllocationViewModel)

ResourceChart.ScrollIntoView Method (IResourceAllocationViewModel)
See Also
[image]

Scrolls to a given allocation in the schedule grid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void ScrollIntoView (
IResourceAllocationViewModel allocation
)

Visual Basic [image] Copy Code

Public Sub ScrollIntoView ( _
allocation As IResourceAllocationViewModel _
)

Parameters

allocation
The allocation to scroll to.

Exceptions

Exception | Condition
ArgumentException | Thrown when the provided IResourceAllocationViewModel object is not part of the underlying IProjectViewModel.
ArgumentNullException | Thrown when the provided IResourceAllocationViewModel is null.

See Also

ScrollIntoView Method Overload List
ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ScrollIntoView Method (IResourceViewModel)

ResourceChart.ScrollIntoView Method (IResourceViewModel)
See Also
[image]

Scrolls to a given resource in the chart.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void ScrollIntoView (
IResourceViewModel resource
)

Visual Basic [image] Copy Code

Public Sub ScrollIntoView ( _
resource As IResourceViewModel _
)

Parameters

resource
The resource to scroll to.

Exceptions

Exception | Condition
ArgumentException | Thrown when the provided IResourceViewModel object is not part of the underlying IProjectViewModel.
NullReferenceException | Thrown when the provided IResourceViewModel is null.

See Also

ScrollIntoView Method Overload List
ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Properties

ResourceChart Properties
[image]

Public Properties

Name | Description
ActivityChildrenExpression | Gets or sets the BindingExpression that identifies the children of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityNameExpression | Gets or sets the BindingExpression that identifies the name of the underlying activities. This is a dependency property. (Inherited from BaseChart.)
ActivityNameForeground | Gets or sets the Foreground of the text, displaying the name of the allocated activity in an AllocationPresenter. This is a dependency property.
ActivityProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying items. This is a dependency property. (Inherited from BaseChart.)
ActivityStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying items. This is a dependency property. (Inherited from BaseChart.)
AllocationActivityExpression | Gets or sets the BindingExpression that identifies the activity of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationEndTimeExpression | Gets or sets the BindingExpression that identifies the end time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationProgressExpression | Gets or sets the BindingExpression that identifies the progress of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationResourceExpression | Gets or sets the BindingExpression that identifies the resource of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllocationStartTimeExpression | Gets or sets the BindingExpression that identifies the start time of the underlying allocations. This is a dependency property. (Inherited from BaseChart.)
AllowAutoScroll | Gets or sets a value indicating if auto scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AllowInfiniteScroll | Gets or sets a value indicating if infinite scrolling is allowed in the chart. This is a dependency property. (Inherited from BaseChart.)
AutoScrollSpeed | Gets or sets the auto scrolling speed, in milliseconds. (Inherited from BaseChart.)
Columns | Gets or sets a list with the columns displayed in the left grid. The columns in this list are automatically generated by the control. (Inherited from BaseChart.)
DataType | Gets or sets the type of the data contained in the grid. This is a dependency property.
DependencyFromExpression | Gets or sets a string that identifies the source activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyToExpression | Gets or sets a string that identifies the target activity of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
DependencyTypeExpression | Gets or sets a string that identifies the type of the underlying dependencies. This is a dependency property. (Inherited from BaseChart.)
ExpressionConverter | Gets or sets an IValueConverter object that can be used to convert the values produced from the expressions. This is a dependency property. (Inherited from BaseChart.)
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderContentTemplate | Gets or sets the template to use for the individual headers in the presenter. This is a dependency property. (Inherited from BaseChart.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from BaseChart.)
IsSnapping | Gets or sets a value indicating whether snapping is enabled and the snapping criteria are met. This is a dependency property. (Inherited from BaseChart.)
IsSnappingEnabled | Gets or sets a value indicating whether item snapping is enabled. This is a dependency property. (Inherited from BaseChart.)
ItemAccentBrush | Gets or sets the brush used for special parts such as the start and end brackets of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBackground | Gets or sets the background of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemBorderBrush | Gets or sets the border brush of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemFocusBrush | Gets or sets the brush of the focus indicator of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemHeight | Gets or sets the height of the items in the chart. This is a dependency property. (Inherited from BaseChart.)
ItemLeftResizeCursor | Gets or sets the cursor to display when the user is resizing the start of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBackground | Gets or sets the background of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemMouseOverBorderBrush | Gets or sets the border brush of the items in the chart when the user points them with the mouse. This is a dependency property. (Inherited from BaseChart.)
ItemProgressResizeCursor | Gets or sets the cursor to display when the user is modifying the progress of an item in the chart or when the user is about to start a modification. This is a dependency property. (Inherited from BaseChart.)
ItemRightResizeCursor | Gets or sets the cursor to display when the user is resizing the end of an item in the chart or when the user is about to start a resizing operation. This is a dependency property. (Inherited from BaseChart.)
ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property.
LeftPanelWidth | Gets or sets the width of the left panel in the chart. This is a dependency property. (Inherited from BaseChart.)
PopupPlacement | Gets or sets the placement position of item popups in a chart. This is a dependency property. (Inherited from BaseChart.)
PopupStyle | Gets or sets the style of the popup windows displayed when the items in the chart are being modified interactively. This is a dependency property. (Inherited from BaseChart.)
Project | Gets the IProjectViewModel object assigned to this chart. (Inherited from BaseChart.)
RelativeTimelineDate | Gets or sets the relative date of the timeline in the right grid. This is a dependency property. (Inherited from BaseChart.)
ResourceDescriptionExpression | Gets or sets the BindingExpression that identifies the description of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ResourceTitleExpression | Gets or sets the BindingExpression that identifies the title of the underlying resources. This is a dependency property. (Inherited from BaseChart.)
ShowActivities | Gets or sets a value indicating whether an allocation presenter will display the name of the activity it's allocatated to. This is a dependency property.
ShowNow | Gets or sets a value indicating whether indication of the current time will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
ShowPopups | Gets or sets whether popups are displayed during interactive operations on activities in the chart. This is a dependency property. (Inherited from BaseChart.)
ShowStartEndIndicators | Gets or sets a value indicating whether indicators for ProjectStart and ProjectEnd will be displayed in the right (Schedule) grid. This is a dependency property. (Inherited from BaseChart.)
SnappingPointCount | Gets or sets the number of snapping point within each timeline cell. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsAfter | Gets or sets the number of time units after the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineDateTimeUnitsBefore | Gets or sets the number of time units before the relative Timeline date to display. This is a dependency property. (Inherited from BaseChart.)
TimelineHeader | Gets or sets the TimelineHeader object of the schedule grid. This is a dependency property. (Inherited from BaseChart.)

Protected Properties

Name | Description
IsAutoScrolling | Gets or sets the current autoscrolling state. (Inherited from BaseChart.)

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ActivityNameForeground Property

ResourceChart.ActivityNameForeground Property
[image]

Gets or sets the Foreground of the text, displaying the name of the allocated activity in an AllocationPresenter. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush ActivityNameForeground { get; set; }

Visual Basic [image] Copy Code

Public Property ActivityNameForeground As Brush

Property Value

A WPF Brush.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.DataType Property

ResourceChart.DataType Property
[image]

Gets or sets the type of the data contained in the grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Type DataType { get; set; }

Visual Basic [image] Copy Code

Public Property DataType As Type

Property Value

A .NET Type.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ItemTemplate Property

ResourceChart.ItemTemplate Property
[image]

Gets or sets the DataTemplate used to display each item. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ItemTemplate As DataTemplate

Property Value

A WPF DataTemplate.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.ShowActivities Property

ResourceChart.ShowActivities Property
[image]

Gets or sets a value indicating whether an allocation presenter will display the name of the activity it's allocatated to. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowActivities { get; set; }

Visual Basic [image] Copy Code

Public Property ShowActivities As Boolean

Property Value

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart Events

ResourceChart Events
[image]

Public Events

Name | Description
AllocationClicked | Raised when the user clicks on an allocation with the mouse.
AllocationModified | Raised when the user has modified an allocation interactively.
AllocationModifying | Raised when the user is modifying an allocation interactively.
AllocationPresenterCreated | Raised when an AllocationPresenter object is created for an IResourceAllocationViewModel to allow customization of the presenter.
DrilledIn | Raised when the view was drilled in. (Inherited from BaseChart.)
DrilledOut | Raised when the view was drilled out. (Inherited from BaseChart.)
DrillingIn | Raised when the view is currently drilling in. (Inherited from BaseChart.)
DrillingOut | Raised when the view is currently drilling out. (Inherited from BaseChart.)
RelativeTimelineDateChanged | Occurs when RelativeTimelineDate changes. (Inherited from BaseChart.)

See Also

ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.AllocationClicked Event

ResourceChart.AllocationClicked Event
[image]

Raised when the user clicks on an allocation with the mouse.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectMouseEventArgs> AllocationClicked

Visual Basic [image] Copy Code

Public Event AllocationClicked As EventHandler(Of ProjectMouseEventArgs)

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.AllocationModified Event

ResourceChart.AllocationModified Event
[image]

Raised when the user has modified an allocation interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectEventArgs> AllocationModified

Visual Basic [image] Copy Code

Public Event AllocationModified As EventHandler(Of ProjectEventArgs)

Event Data

AllocationModified event handlers receive an argument of type ProjectEventArgs

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.AllocationModifying Event

ResourceChart.AllocationModifying Event
[image]

Raised when the user is modifying an allocation interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ProjectValidationEventArgs> AllocationModifying

Visual Basic [image] Copy Code

Public Event AllocationModifying As EventHandler(Of ProjectValidationEventArgs)

Event Data

AllocationModifying event handlers receive an argument of type ProjectValidationEventArgs.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceChart.AllocationPresenterCreated Event

ResourceChart.AllocationPresenterCreated Event
[image]

Raised when an AllocationPresenter object is created for an IResourceAllocationViewModel to allow customization of the presenter.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<BasePresenterEventArgs> AllocationPresenterCreated

Visual Basic [image] Copy Code

Public Event AllocationPresenterCreated As EventHandler(Of BasePresenterEventArgs)

Event Data

AllocationPresenterCreated event handlers receive an argument of type BasePresenterEventArgs.

See Also

ResourceChart Members
ResourceChart Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState Class

ResourceState Class
[image]

Encapsulates the state of a resource for subsequent undo operations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ResourceState : UndoState

Visual Basic [image] Copy Code

Public Class ResourceState
Inherits UndoState

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.UndoState
MindFusion.DataViews.Wpf.ResourceState

See Also

ResourceState Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState Members

ResourceState Members
Constructors Properties Methods
[image]

Encapsulates the state of a resource for subsequent undo operations.

The following tables list the members exposed by the ResourceState type.

Public Constructors

Name | Description
ResourceState | Initializes a new instance of the ResourceState class.

Public Properties

Name | Description
Allocations | Gets or sets the collection object that holds the allocations, associated with the resource instance.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState Constructor

ResourceState Constructor
[image]

Initializes a new instance of the ResourceState class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ResourceState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState Methods

ResourceState Methods
[image]

Public Methods

Name | Description
Equals | UndoState.Equals override.

See Also

ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState.Equals Method

ResourceState.Equals Method
[image]

UndoState.Equals override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
UndoState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As UndoState _
) As Boolean

Parameters

other

An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

ResourceState Members
ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState Properties

ResourceState Properties
[image]

Public Properties

Name | Description
Allocations | Gets or sets the collection object that holds the allocations, associated with the resource instance.
Description | Gets or sets a description of the resource.
Title | Gets or sets a title of the resource.

See Also

ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState.Allocations Property

ResourceState.Allocations Property
[image]

Gets or sets the collection object that holds the allocations, associated with the resource instance.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<IResourceAllocationViewModel> Allocations { get; set; }

Visual Basic [image] Copy Code

Public Property Allocations As IEnumerable(Of IResourceAllocationViewModel)

Property Value

An enumeration of all allocations of the associated resource.

See Also

ResourceState Members
ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState.Description Property

ResourceState.Description Property
[image]

Gets or sets a description of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string specifying the description.

See Also

ResourceState Members
ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ResourceState.Title Property

ResourceState.Title Property
[image]

Gets or sets a title of the resource.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string specifying the title.

See Also

ResourceState Members
ResourceState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader Class

RowHeader Class
[image]

Represents the header cell of a row in a DataGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class RowHeader : Button

Visual Basic [image] Copy Code

Public Class RowHeader
Inherits Button

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.Primitives.ButtonBase
System.Windows.Controls.Button
MindFusion.DataViews.Wpf.RowHeader

See Also

RowHeader Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader Members

RowHeader Members
Constructors Fields Properties
[image]

Represents the header cell of a row in a DataGrid.

The following tables list the members exposed by the RowHeader type.

Public Constructors

Name | Description
RowHeader | Initializes a new instance of the RowHeader class.

Public Fields

Name | Description
ShowExpandButtonProperty | Identifies the ShowExpandButton property.

Public Properties

Name | Description
ShowExpandButton | Gets or sets a value indicating whether the expand/collapse button displayed in this header is visible. This is a dependency property.

See Also

RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader Fields

RowHeader Fields
[image]

Public Fields

Name | Description
ShowExpandButtonProperty | Identifies the ShowExpandButton property.

See Also

RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader.ShowExpandButtonProperty Field

RowHeader.ShowExpandButtonProperty Field
[image]

Identifies the ShowExpandButton property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowExpandButtonProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowExpandButtonProperty As DependencyProperty

See Also

RowHeader Members
RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader Constructor

RowHeader Constructor
[image]

Initializes a new instance of the RowHeader class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public RowHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader Properties

RowHeader Properties
[image]

Public Properties

Name | Description
ShowExpandButton | Gets or sets a value indicating whether the expand/collapse button displayed in this header is visible. This is a dependency property.

See Also

RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.RowHeader.ShowExpandButton Property

RowHeader.ShowExpandButton Property
[image]

Gets or sets a value indicating whether the expand/collapse button displayed in this header is visible. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ShowExpandButton { get; set; }

Visual Basic [image] Copy Code

Public Property ShowExpandButton As Boolean

Property Value

true to show the expand/collapse button; otherwise, false.

See Also

RowHeader Members
RowHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Class

ScheduleColumn Class
[image]

A column in a DataGrid which displays activities or resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleColumn : GridColumn

Visual Basic [image] Copy Code

Public Class ScheduleColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.ScheduleColumn

See Also

ScheduleColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Members

ScheduleColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays activities or resource allocations.

The following tables list the members exposed by the ScheduleColumn type.

Public Constructors

Name | Description
ScheduleColumn | Initializes a new instance of the ScheduleColumn class.

Public Fields

Name | Description
EndTimeProperty | Identifies the EndTime dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
StartTimeProperty | Identifies the StartTime dependency property.
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
EndTime | Gets or sets a value which indicates the last date in the scrollable area. This is a dependency property.
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
StartTime | Gets or sets a value which indicates the first date in the scrollable area. This is a dependency property.
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Fields

ScheduleColumn Fields
[image]

Public Fields

Name | Description
EndTimeProperty | Identifies the EndTime dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
StartTimeProperty | Identifies the StartTime dependency property.
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

See Also

ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.EndTimeProperty Field

ScheduleColumn.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.StartTimeProperty Field

ScheduleColumn.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Constructor

ScheduleColumn Constructor
[image]

Initializes a new instance of the ScheduleColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Methods

ScheduleColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | Creates a binding between the data and the associated editor. (Inherited from GridColumn.)
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | Creates a binding between the data and the associated viewer. (Inherited from GridColumn.)
InitEditor | GridColumn.InitEditor override.

See Also

ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.CancelEdit Method

ScheduleColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.CommitEdit Method

ScheduleColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.ConfirmBeginEdit Method

ScheduleColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.CreateEditor Method

ScheduleColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.CreateViewer Method

ScheduleColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.InitEditor Method

ScheduleColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn Properties

ScheduleColumn Properties
[image]

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
EndTime | Gets or sets a value which indicates the last date in the scrollable area. This is a dependency property.
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
StartTime | Gets or sets a value which indicates the first date in the scrollable area. This is a dependency property.
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

See Also

ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.EndTime Property

ScheduleColumn.EndTime Property
[image]

Gets or sets a value which indicates the last date in the scrollable area. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumn.StartTime Property

ScheduleColumn.StartTime Property
[image]

Gets or sets a value which indicates the first date in the scrollable area. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

ScheduleColumn Members
ScheduleColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader Class

ScheduleColumnHeader Class
[image]

Represents the ColumnHeader of a ScheduleColumn in a TreeGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleColumnHeader : ColumnHeader

Visual Basic [image] Copy Code

Public Class ScheduleColumnHeader
Inherits ColumnHeader

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.DataViews.Wpf.ColumnHeader
MindFusion.DataViews.Wpf.ScheduleColumnHeader

See Also

ScheduleColumnHeader Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader Members

ScheduleColumnHeader Members
Constructors Methods
[image]

Represents the ColumnHeader of a ScheduleColumn in a TreeGrid.

The following tables list the members exposed by the ScheduleColumnHeader type.

Public Constructors

Name | Description
ScheduleColumnHeader | Initializes a new instance of the ScheduleColumnHeader class.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.

See Also

ScheduleColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader Constructor

ScheduleColumnHeader Constructor
[image]

Initializes a new instance of the ScheduleColumnHeader class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleColumnHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader Methods

ScheduleColumnHeader Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.

See Also

ScheduleColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader.MeasureOverride Method

ScheduleColumnHeader.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

Return Value

See Also

ScheduleColumnHeader Members
ScheduleColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleColumnHeader.OnApplyTemplate Method

ScheduleColumnHeader.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ScheduleColumnHeader Members
ScheduleColumnHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid Class

ScheduleGrid Class
[image]

A tree grid that can display activities and resource allocations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleGrid : TreeGrid

Visual Basic [image] Copy Code

Public Class ScheduleGrid
Inherits TreeGrid

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.Primitives.MultiSelector
MindFusion.DataViews.Wpf.DataGrid
MindFusion.DataViews.Wpf.TreeGrid
MindFusion.DataViews.Wpf.ScheduleGrid

See Also

ScheduleGrid Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid Members

ScheduleGrid Members
Constructors Fields Properties Methods Events
[image]

A tree grid that can display activities and resource allocations.

The following tables list the members exposed by the ScheduleGrid type.

Public Constructors

Name | Description
ScheduleGrid | Initializes a new instance of the ScheduleGrid class.

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property. (Inherited from DataGrid.)
AlternatingRowBackgroundProperty | Identifies the AlternatingRowBackground dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrushProperty | Identifies the AlternatingRowBorderBrush dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThicknessProperty | Identifies the AlternatingRowBorderThickness dependency property. (Inherited from DataGrid.)
AutoGenerateColumnsProperty | Identifies the AutoGenerateColumns dependency property. (Inherited from DataGrid.)
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property. (Inherited from DataGrid.)
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. (Inherited from DataGrid.)
CurrentCellProperty | Identifies the CurrentCell dependency property. (Inherited from DataGrid.)
DataTypeProperty | Identifies the DataType dependency property. (Inherited from TreeGrid.)
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from DataGrid.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from DataGrid.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from DataGrid.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from DataGrid.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from DataGrid.)
RowBackgroundProperty | Identifies the RowBackground dependency property. (Inherited from DataGrid.)
RowBorderBrushProperty | Identifies the RowBorderBrush dependency property. (Inherited from DataGrid.)
RowBorderThicknessProperty | Identifies the RowBorderThickness dependency property. (Inherited from DataGrid.)
RowHeadersVisibleProperty | Identifies the RowHeadersVisible dependency property. (Inherited from DataGrid.)

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBackground | Gets or sets the background brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrush | Gets or sets the border brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThickness | Gets or sets the border thickness of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AutoGenerateColumns | Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property. (Inherited from DataGrid.)
CellBorderBrush | Gets or sets the border brush of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
CellBorderThickness | Gets or sets the border thickness of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
Columns | Gets or sets a list with the columns displayed in the grid. (Inherited from DataGrid.)
CurrentCell | Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property. (Inherited from DataGrid.)
DataType | Gets or sets the type of the data contained in the grid. This is a dependency property. (Inherited from TreeGrid.)
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderContentTemplate | Gets or sets the template to use for the individual column headers. This is a dependency property. (Inherited from DataGrid.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DataGrid.)
RowBackground | Gets or sets the background brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderBrush | Gets or sets the border brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderThickness | Gets or sets the border thickness of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowHeadersVisible | Gets or sets a value indicating whether row headers are visible. This is a dependency property. (Inherited from DataGrid.)

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from TreeGrid.)

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override. (Inherited from DataGrid.)
CreateRowContainer | TreeGrid.CreateRowContainer override.
GetContainerForItemOverride | DataGrid.GetContainerForItemOverride override. (Inherited from TreeGrid.)
IsItemItsOwnContainerOverride | DataGrid.IsItemItsOwnContainerOverride override. (Inherited from TreeGrid.)
OnColumnCreating | Raises the ColumnCreating event. (Inherited from DataGrid.)
OnItemsSourceChanged | Selector.OnItemsSourceChanged override. (Inherited from DataGrid.)
OnKeyDown | ItemsControl.OnKeyDown override. (Inherited from DataGrid.)
OnRowClicked | Raises the RowClicked event. (Inherited from DataGrid.)
OnTextInput | ItemsControl.OnTextInput override. (Inherited from DataGrid.)
PrepareContainerForItemOverride | DataGrid.PrepareContainerForItemOverride override. (Inherited from TreeGrid.)

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid. (Inherited from DataGrid.)
RowClicked | Raised when a row in the grid is clicked with the mouse. (Inherited from DataGrid.)

See Also

ScheduleGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid Constructor

ScheduleGrid Constructor
[image]

Initializes a new instance of the ScheduleGrid class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleGrid ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid Methods

ScheduleGrid Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from TreeGrid.)

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override. (Inherited from DataGrid.)
CreateRowContainer | TreeGrid.CreateRowContainer override.
GetContainerForItemOverride | DataGrid.GetContainerForItemOverride override. (Inherited from TreeGrid.)
IsItemItsOwnContainerOverride | DataGrid.IsItemItsOwnContainerOverride override. (Inherited from TreeGrid.)
OnColumnCreating | Raises the ColumnCreating event. (Inherited from DataGrid.)
OnItemsSourceChanged | Selector.OnItemsSourceChanged override. (Inherited from DataGrid.)
OnKeyDown | ItemsControl.OnKeyDown override. (Inherited from DataGrid.)
OnRowClicked | Raises the RowClicked event. (Inherited from DataGrid.)
OnTextInput | ItemsControl.OnTextInput override. (Inherited from DataGrid.)
PrepareContainerForItemOverride | DataGrid.PrepareContainerForItemOverride override. (Inherited from TreeGrid.)

See Also

ScheduleGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid.CreateRowContainer Method

ScheduleGrid.CreateRowContainer Method
[image]

TreeGrid.CreateRowContainer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual GridRow CreateRowContainer ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateRowContainer () As GridRow

Return Value

An instance of the ScheduleGridRow class.

See Also

ScheduleGrid Members
ScheduleGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGrid Events

ScheduleGrid Events
[image]

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid. (Inherited from DataGrid.)
RowClicked | Raised when a row in the grid is clicked with the mouse. (Inherited from DataGrid.)

See Also

ScheduleGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Class

ScheduleGridCell Class
[image]

Represents a cell in a ScheduleGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleGridCell : GridCell, IWeakEventListener

Visual Basic [image] Copy Code

Public Class ScheduleGridCell
Inherits GridCell
Implements IWeakEventListener

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.DataViews.Wpf.GridCell
MindFusion.DataViews.Wpf.ScheduleGridCell

See Also

ScheduleGridCell Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Members

ScheduleGridCell Members
Constructors Fields Properties Methods
[image]

Represents a cell in a ScheduleGrid.

The following tables list the members exposed by the ScheduleGridCell type.

Public Constructors

Name | Description
ScheduleGridCell | Initializes a new instance of the ScheduleGridCell class.

Public Fields

Name | Description
IsEditingProperty | Identifies the IsEditing dependency property. (Inherited from GridCell.)
NonWorkingBackgroundBrushProperty | Identifies the NonWorkingBackgroundBrush dependency property.

Public Properties

Name | Description
IsEditing | Gets or sets a value indicating whether the cell is currently in in-place editing mode. This is a dependency property. (Inherited from GridCell.)
NonWorkingBackgroundBrush | Gets or sets the brush used to define the color of the non-working time periods representation. This is a dependency property.

Public Methods

Name | Description
BeginEdit | Initiates in-place editing within this cell. (Inherited from GridCell.)
CancelEdit | Cancels the current editing operation. (Inherited from GridCell.)
CommitEdit | Confirms the current editing operation. (Inherited from GridCell.)
ConfirmEdit | Checks if the user input represented by the specified event argument should initiates an editing operation for this cell. (Inherited from GridCell.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnGotFocus | FrameworkElement.OnGotFocus override. (Inherited from GridCell.)
OnIsKeyboardFocusWithinChanged | UIElement.OnIsKeyboardFocusWithinChanged override. (Inherited from GridCell.)
OnRenderSizeChanged | FrameworkElement.OnRenderSizeChanged override.

See Also

ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Fields

ScheduleGridCell Fields
[image]

Public Fields

Name | Description
IsEditingProperty | Identifies the IsEditing dependency property. (Inherited from GridCell.)
NonWorkingBackgroundBrushProperty | Identifies the NonWorkingBackgroundBrush dependency property.

See Also

ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell.NonWorkingBackgroundBrushProperty Field

ScheduleGridCell.NonWorkingBackgroundBrushProperty Field
[image]

Identifies the NonWorkingBackgroundBrush dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NonWorkingBackgroundBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NonWorkingBackgroundBrushProperty As DependencyProperty

See Also

ScheduleGridCell Members
ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Constructor

ScheduleGridCell Constructor
[image]

Initializes a new instance of the ScheduleGridCell class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleGridCell ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Methods

ScheduleGridCell Methods
[image]

Public Methods

Name | Description
BeginEdit | Initiates in-place editing within this cell. (Inherited from GridCell.)
CancelEdit | Cancels the current editing operation. (Inherited from GridCell.)
CommitEdit | Confirms the current editing operation. (Inherited from GridCell.)
ConfirmEdit | Checks if the user input represented by the specified event argument should initiates an editing operation for this cell. (Inherited from GridCell.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnGotFocus | FrameworkElement.OnGotFocus override. (Inherited from GridCell.)
OnIsKeyboardFocusWithinChanged | UIElement.OnIsKeyboardFocusWithinChanged override. (Inherited from GridCell.)
OnRenderSizeChanged | FrameworkElement.OnRenderSizeChanged override.

See Also

ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell.OnApplyTemplate Method

ScheduleGridCell.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ScheduleGridCell Members
ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell.OnRenderSizeChanged Method

ScheduleGridCell.OnRenderSizeChanged Method
[image]

FrameworkElement.OnRenderSizeChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnRenderSizeChanged (
SizeChangedInfo sizeInfo
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRenderSizeChanged( _
sizeInfo As SizeChangedInfo _
)

Parameters

sizeInfo
Details of the old and new size involved in the change.

See Also

ScheduleGridCell Members
ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell Properties

ScheduleGridCell Properties
[image]

Public Properties

Name | Description
IsEditing | Gets or sets a value indicating whether the cell is currently in in-place editing mode. This is a dependency property. (Inherited from GridCell.)
NonWorkingBackgroundBrush | Gets or sets the brush used to define the color of the non-working time periods representation. This is a dependency property.

See Also

ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridCell.NonWorkingBackgroundBrush Property

ScheduleGridCell.NonWorkingBackgroundBrush Property
[image]

Gets or sets the brush used to define the color of the non-working time periods representation. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Brush NonWorkingBackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Property NonWorkingBackgroundBrush As Brush

Property Value

A WPF Brush.

See Also

ScheduleGridCell Members
ScheduleGridCell Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow Class

ScheduleGridRow Class
[image]

Represents a row in a ScheduleGrid.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleGridRow : GridRow

Visual Basic [image] Copy Code

Public Class ScheduleGridRow
Inherits GridRow

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.DataViews.Wpf.GridRow
MindFusion.DataViews.Wpf.ScheduleGridRow

See Also

ScheduleGridRow Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow Members

ScheduleGridRow Members
Constructors Fields Properties Methods Events
[image]

Represents a row in a ScheduleGrid.

The following tables list the members exposed by the ScheduleGridRow type.

Public Constructors

Name | Description
ScheduleGridRow | Initializes a new instance of the ScheduleGridRow class.

Public Fields

Name | Description
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property. (Inherited from GridRow.)
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. (Inherited from GridRow.)
ClickedEvent | Identifies the Clicked routed event. (Inherited from GridRow.)
DataItemProperty | Identifies the DataItem dependency property. (Inherited from GridRow.)
IndexProperty | Identifies the Index dependency property. (Inherited from GridRow.)
IsExpandedProperty | Identifies the IsExpanded dependency property. (Inherited from GridRow.)

Public Properties

Name | Description
CellBorderBrush | Gets or sets the border brush of the cells in the row. This is a dependency property. (Inherited from GridRow.)
CellBorderThickness | Gets or sets the border thickness of the cells in the row. This is a dependency property. (Inherited from GridRow.)
DataItem | Gets or sets the item associated with this row. This is a dependency property. (Inherited from GridRow.)
Index | Gets or sets the index of this row within its parent. This is a dependency property. (Inherited from GridRow.)
IsExpanded | Gets or sets a value indicating whether this row is expanded. This is a dependency property. (Inherited from GridRow.)

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from GridRow.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from GridRow.)
GetContainerForItemOverride | GridRow.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | GridRow.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override. (Inherited from GridRow.)

Public Events

Name | Description
Clicked | Occurs when the user clicks on this row with the mouse. (Inherited from GridRow.)

See Also

ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow Constructor

ScheduleGridRow Constructor
[image]

Initializes a new instance of the ScheduleGridRow class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleGridRow ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow Methods

ScheduleGridRow Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from GridRow.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from GridRow.)
GetContainerForItemOverride | GridRow.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | GridRow.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override. (Inherited from GridRow.)

See Also

ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow.GetContainerForItemOverride Method

ScheduleGridRow.GetContainerForItemOverride Method
[image]

GridRow.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

ScheduleGridRow Members
ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow.IsItemItsOwnContainerOverride Method

ScheduleGridRow.IsItemItsOwnContainerOverride Method
[image]

GridRow.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

ScheduleGridRow Members
ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleGridRow Events

ScheduleGridRow Events
[image]

Public Events

Name | Description
Clicked | Occurs when the user clicks on this row with the mouse. (Inherited from GridRow.)

See Also

ScheduleGridRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleMode Enumeration

ScheduleMode Enumeration
[image]

Indicates how an activity behaves when its children are modified.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum ScheduleMode

Visual Basic [image] Copy Code

Public Enum ScheduleMode

Members

Member name | Description
Auto | Specifies that the StartTime, EndTime and Progress of an activity are automatically updated according to the values of its children.
Manual | Specifies that the StartTime, EndTime and Progress of an activity are not changed when its children are modified.
SemiAuto | Specifies an auto activity with no children.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent Class

SchedulePopupContent Class
[image]

The content of the popup displayed during interactive creation or modification of items in BaseChart-derived controls.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class SchedulePopupContent : Control

Visual Basic [image] Copy Code

Public Class SchedulePopupContent
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.SchedulePopupContent

See Also

SchedulePopupContent Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent Members

SchedulePopupContent Members
Constructors Fields Properties
[image]

The content of the popup displayed during interactive creation or modification of items in BaseChart-derived controls.

The following tables list the members exposed by the SchedulePopupContent type.

Public Constructors

Name | Description
SchedulePopupContent | Initializes a new SchedulePopupContent class.

Public Fields

Name | Description
ActionProperty | Identifies the Action dependency property.

Public Properties

Name | Description
Action | Gets or sets the type of action performed by the user. This is a dependency property.

See Also

SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent Fields

SchedulePopupContent Fields
[image]

Public Fields

Name | Description
ActionProperty | Identifies the Action dependency property.

See Also

SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent.ActionProperty Field

SchedulePopupContent.ActionProperty Field
[image]

Identifies the Action dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActionProperty As DependencyProperty

See Also

SchedulePopupContent Members
SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent Constructor

SchedulePopupContent Constructor
[image]

Initializes a new SchedulePopupContent class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public SchedulePopupContent ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent Properties

SchedulePopupContent Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the type of action performed by the user. This is a dependency property.

See Also

SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SchedulePopupContent.Action Property

SchedulePopupContent.Action Property
[image]

Gets or sets the type of action performed by the user. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Action Action { get; set; }

Visual Basic [image] Copy Code

Public Property Action As Action

Property Value

A member of the Action enumeration.

Remarks

The value of this property is used to filter out some of the information displayed by the popup. The filtering is performed by triggers in the control template.

See Also

SchedulePopupContent Members
SchedulePopupContent Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Class

ScheduleRow Class
[image]

Represents a viewer in a ScheduleColumn.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleRow : ItemsControl

Visual Basic [image] Copy Code

Public Class ScheduleRow
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.DataViews.Wpf.ScheduleRow

See Also

ScheduleRow Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Members

ScheduleRow Members
Constructors Fields Properties Methods
[image]

Represents a viewer in a ScheduleColumn.

The following tables list the members exposed by the ScheduleRow type.

Public Constructors

Name | Description
ScheduleRow | Initializes a new instance of the ScheduleRow class.

Public Fields

Name | Description
EndTimeProperty | Identifies the EndTime dependency property.
StartTimeProperty | Identifies the StartTime dependency property.

Public Properties

Name | Description
EndTime | Gets or sets the end time associated with the row. This is a dependency property.
StartTime | Gets or sets the start time associated with the row. This is a dependency property.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Fields

ScheduleRow Fields
[image]

Public Fields

Name | Description
EndTimeProperty | Identifies the EndTime dependency property.
StartTimeProperty | Identifies the StartTime dependency property.

See Also

ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.EndTimeProperty Field

ScheduleRow.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.StartTimeProperty Field

ScheduleRow.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Constructor

ScheduleRow Constructor
[image]

Initializes a new instance of the ScheduleRow class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleRow ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Methods

ScheduleRow Methods
[image]

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.GetContainerForItemOverride Method

ScheduleRow.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.IsItemItsOwnContainerOverride Method

ScheduleRow.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.PrepareContainerForItemOverride Method

ScheduleRow.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow Properties

ScheduleRow Properties
[image]

Public Properties

Name | Description
EndTime | Gets or sets the end time associated with the row. This is a dependency property.
StartTime | Gets or sets the start time associated with the row. This is a dependency property.

See Also

ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.EndTime Property

ScheduleRow.EndTime Property
[image]

Gets or sets the end time associated with the row. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRow.StartTime Property

ScheduleRow.StartTime Property
[image]

Gets or sets the start time associated with the row. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

ScheduleRow Members
ScheduleRow Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Class

ScheduleRowPanel Class
[image]

A custom panel used to arrange activities and resource allocations in ScheduleRow objects.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ScheduleRowPanel : Panel

Visual Basic [image] Copy Code

Public Class ScheduleRowPanel
Inherits Panel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
MindFusion.DataViews.Wpf.ScheduleRowPanel

See Also

ScheduleRowPanel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Members

ScheduleRowPanel Members
Constructors Fields Properties Methods
[image]

A custom panel used to arrange activities and resource allocations in ScheduleRow objects.

The following tables list the members exposed by the ScheduleRowPanel type.

Public Constructors

Name | Description
ScheduleRowPanel | Initializes a new instance of the ScheduleRowPanel class.

Public Fields

Name | Description
PaddingProperty | Identifies the Padding dependency property.
SpacingProperty | Identifies the Spacing dependency property.

Public Properties

Name | Description
Padding | Gets or sets the distance between the edges of the panel and its content. This is a dependency property.
Spacing | Gets or sets the distance between colliding resource allocations. This is a dependency property.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Fields

ScheduleRowPanel Fields
[image]

Public Fields

Name | Description
PaddingProperty | Identifies the Padding dependency property.
SpacingProperty | Identifies the Spacing dependency property.

See Also

ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.PaddingProperty Field

ScheduleRowPanel.PaddingProperty Field
[image]

Identifies the Padding dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As DependencyProperty

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.SpacingProperty Field

ScheduleRowPanel.SpacingProperty Field
[image]

Identifies the Spacing dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SpacingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SpacingProperty As DependencyProperty

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Constructor

ScheduleRowPanel Constructor
[image]

Initializes a new instance of the ScheduleRowPanel class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScheduleRowPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Methods

ScheduleRowPanel Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.

See Also

ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.ArrangeOverride Method

ScheduleRowPanel.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.MeasureOverride Method

ScheduleRowPanel.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size that this element can give to child elements.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel Properties

ScheduleRowPanel Properties
[image]

Public Properties

Name | Description
Padding | Gets or sets the distance between the edges of the panel and its content. This is a dependency property.
Spacing | Gets or sets the distance between colliding resource allocations. This is a dependency property.

See Also

ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.Padding Property

ScheduleRowPanel.Padding Property
[image]

Gets or sets the distance between the edges of the panel and its content. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding of the panel.

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ScheduleRowPanel.Spacing Property

ScheduleRowPanel.Spacing Property
[image]

Gets or sets the distance between colliding resource allocations. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Spacing { get; set; }

Visual Basic [image] Copy Code

Public Property Spacing As Double

Property Value

A double value specifying the distance between adjacent items.

See Also

ScheduleRowPanel Members
ScheduleRowPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Class

SortedObservableCollection(T) Class
Remarks See Also
[image]

Represents a generic ObservableCollection with sorted items.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class SortedObservableCollection<T> : ObservableCollection<T> where T : IComparable

Visual Basic [image] Copy Code

Public Class SortedObservableCollection(Of T As IComparable)
Inherits ObservableCollection(Of T)

Remarks

Items must implement the IComparable interface.

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
System.Collections.ObjectModel.ObservableCollection(T)
MindFusion.DataViews.Wpf.SortedObservableCollection(T)
MindFusion.DataViews.Wpf.TimeRangeCollection

See Also

SortedObservableCollection(T) Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Members

SortedObservableCollection(T) Members
Constructors Properties Methods
[image]

Represents a generic ObservableCollection with sorted items.

The following tables list the members exposed by the SortedObservableCollection(T) type.

Public Constructors

Name | Description
SortedObservableCollection | Overloaded. Initializes a new instance of the SortedObservableCollection<T> class.

Public Properties

Name | Description
AreItemsUnique | Gets or sets a value to indicate whether the collection can contain duplicate items.

Protected Methods

Name | Description
InsertItem | ObservableCollection<T>.InsertItem override.
MoveItem | ObservableCollection<T>.MoveItem override.
OnCollectionChanged | ObservableCollection<T>.OnCollectionChanged override.
SetItem | ObservableCollection<T>.SetItem override.
Sort | Sorts the collection.

See Also

SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Constructor

SortedObservableCollection(T) Constructor
[image]

Initializes a new instance of the SortedObservableCollection<T> class.

Overload List

Name | Description
SortedObservableCollection(T) () | Initializes a new instance of the SortedObservableCollection<T> class.
SortedObservableCollection(T) (Boolean) | Initializes a new instance of the SortedObservableCollection<T> class, specifying if the collection can hold duplicate items.
SortedObservableCollection(T) (IEnumerable(T)) | Initializes a new instance of the SortedObservableCollection<T> class that contains elements copied from the specified collection.
SortedObservableCollection(T) (List(T)) | Initializes a new instance of the SortedObservableCollection<T> class that contains elements copied from the specified list.

See Also

SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Constructor ()

SortedObservableCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the SortedObservableCollection<T> class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public SortedObservableCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

SortedObservableCollection(T) Constructor Overload List
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Constructor (Boolean)

SortedObservableCollection(T) Constructor (Boolean)
See Also
[image]

Initializes a new instance of the SortedObservableCollection<T> class, specifying if the collection can hold duplicate items.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public SortedObservableCollection<T> (
bool areItemsUnique
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
areItemsUnique As Boolean _
)

Parameters

areItemsUnique

Specifies if the collection can contain duplicate items.

See Also

SortedObservableCollection(T) Constructor Overload List
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Constructor (IEnumerable(T))

SortedObservableCollection(T) Constructor (IEnumerable(T))
See Also
[image]

Initializes a new instance of the SortedObservableCollection<T> class that contains elements copied from the specified collection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public SortedObservableCollection<T> (
IEnumerable<T> collection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
collection As IEnumerable(Of T) _
)

Parameters

collection
The initial contents of the new collection.

See Also

SortedObservableCollection(T) Constructor Overload List
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Constructor (List(T))

SortedObservableCollection(T) Constructor (List(T))
See Also
[image]

Initializes a new instance of the SortedObservableCollection<T> class that contains elements copied from the specified list.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public SortedObservableCollection<T> (
List<T> list
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
list As List(Of T) _
)

Parameters

list
The initial contents of the new collection.

See Also

SortedObservableCollection(T) Constructor Overload List
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Methods

SortedObservableCollection(T) Methods
[image]

Protected Methods

Name | Description
InsertItem | ObservableCollection<T>.InsertItem override.
MoveItem | ObservableCollection<T>.MoveItem override.
OnCollectionChanged | ObservableCollection<T>.OnCollectionChanged override.
SetItem | ObservableCollection<T>.SetItem override.
Sort | Sorts the collection.

See Also

SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).InsertItem Method

SortedObservableCollection(T).InsertItem Method
[image]

ObservableCollection<T>.InsertItem override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void InsertItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub InsertItem( _
index As Integer, _
item As T _
)

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert.

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).MoveItem Method

SortedObservableCollection(T).MoveItem Method
[image]

ObservableCollection<T>.MoveItem override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void MoveItem (
int oldIndex,
int newIndex
)

Visual Basic [image] Copy Code

Protected Overrides Sub MoveItem( _
oldIndex As Integer, _
newIndex As Integer _
)

Parameters

oldIndex
The zero-based index specifying the location of the item to be moved.
newIndex
The zero-based index specifying the new location of the item.

Remarks

Items in the collection are sorted upon modification, so calls to this method will result in an InvalidOperationException.

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).OnCollectionChanged Method

SortedObservableCollection(T).OnCollectionChanged Method
[image]

ObservableCollection<T>.OnCollectionChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Arguments of the event being raised.

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).SetItem Method

SortedObservableCollection(T).SetItem Method
[image]

ObservableCollection<T>.SetItem override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void SetItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetItem( _
index As Integer, _
item As T _
)

Parameters

index
The zero-based index of the element to replace.
item
The new value for the element at the specified index.

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).Sort Method

SortedObservableCollection(T).Sort Method
[image]

Sorts the collection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void Sort ()

Visual Basic [image] Copy Code

Protected Overridable Sub Sort ()

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T) Properties

SortedObservableCollection(T) Properties
[image]

Public Properties

Name | Description
AreItemsUnique | Gets or sets a value to indicate whether the collection can contain duplicate items.

See Also

SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.SortedObservableCollection(T).AreItemsUnique Property

SortedObservableCollection(T).AreItemsUnique Property
[image]

Gets or sets a value to indicate whether the collection can contain duplicate items.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AreItemsUnique { get; set; }

Visual Basic [image] Copy Code

Public Property AreItemsUnique As Boolean

Property Value

true if the items in the collection should be unique; otherwise, false.

See Also

SortedObservableCollection(T) Members
SortedObservableCollection(T) Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Class

TextColumn Class
[image]

A column in a DataGrid which displays values, which do not have dedicated column.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TextColumn : GridColumn

Visual Basic [image] Copy Code

Public Class TextColumn
Inherits GridColumn

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.DataViews.Wpf.GridColumn
MindFusion.DataViews.Wpf.TextColumn

See Also

TextColumn Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Members

TextColumn Members
Constructors Fields Properties Methods
[image]

A column in a DataGrid which displays values, which do not have dedicated column.

The following tables list the members exposed by the TextColumn type.

Public Constructors

Name | Description
TextColumn | Overloaded. Initializes a new instance of the TextColumn class.

Public Fields

Name | Description
IsReadOnlyProperty | Identifies the IsReadOnly dependency property. (Inherited from GridColumn.)
NameProperty | Identifies the Name dependency property. (Inherited from GridColumn.)
VisibilityProperty | Identifies the Visibility dependency property. (Inherited from GridColumn.)
WidthProperty | Identifies the Width dependency property. (Inherited from GridColumn.)

Public Properties

Name | Description
EditorValueConverter | Gets the IValueConverter that is used in the editor-data relationship in this column. (Inherited from GridColumn.)
EditorValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the EditorValueConverter property. (Inherited from GridColumn.)
IsReadOnly | Gets or sets a value indicating whether the column is read-only. This is a dependency property. (Inherited from GridColumn.)
Name | Gets or sets the text displayed in the column's header. This is a dependency property. (Inherited from GridColumn.)
PropertyInfo | Gets information about the property associated with the column. (Inherited from GridColumn.)
ViewerValueConverter | Gets the IValueConverter that is used in the viewer-data relationship in this column. (Inherited from GridColumn.)
ViewerValueConverterParameter | Gets the converter parameter used by the IValueConverter defined by the ViewerValueConverter property. (Inherited from GridColumn.)
Visibility | Gets or sets the visibility of this column. This is a dependency property. (Inherited from GridColumn.)
Width | Gets or sets the desired width for this column. This is a dependency property. (Inherited from GridColumn.)

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | GridColumn.CreateEditorBinding override.
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | GridColumn.CreateViewerBinding override.
InitEditor | GridColumn.InitEditor override.

See Also

TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Constructor

TextColumn Constructor
[image]

Initializes a new instance of the TextColumn class.

Overload List

Name | Description
TextColumn (ItemPropertyInfo) | Initializes a new instance of the TextColumn class.
TextColumn (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object) | Initializes a new instance of the TextColumn class.

See Also

TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Constructor (ItemPropertyInfo)

TextColumn Constructor (ItemPropertyInfo)
See Also
[image]

Initializes a new instance of the TextColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TextColumn (
ItemPropertyInfo propertyInfo
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.

See Also

TextColumn Constructor Overload List
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)

TextColumn Constructor (ItemPropertyInfo, IValueConverter, Object, IValueConverter, Object)
See Also
[image]

Initializes a new instance of the TextColumn class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TextColumn (
ItemPropertyInfo propertyInfo,
IValueConverter viewerConverter,
Object viewerConverterParam,
IValueConverter editorConverter,
Object editorConverterParam
)

Visual Basic [image] Copy Code

Public New ( _
propertyInfo As ItemPropertyInfo, _
viewerConverter As IValueConverter, _
viewerConverterParam As Object, _
editorConverter As IValueConverter, _
editorConverterParam As Object _
)

Parameters

propertyInfo
An ItemPropertyInfo object specifying the property that will be displayed by the column.
viewerConverter
An IValueConverter that will be used in the viewer-data bound relationship in this column.
viewerConverterParam
The converter parameter that will be used by viewerConverter.
editorConverter
An IValueConverter that will be used in the editor-data bound relationship in this column.
editorConverterParam
The converter parameter that will be used by editorConverter.

See Also

TextColumn Constructor Overload List
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn Methods

TextColumn Methods
[image]

Protected Methods

Name | Description
ApplyBinding | Establishes a binding between the specified framework element and the value displayed in this column. (Inherited from GridColumn.)
CancelEdit | GridColumn.CancelEdit override.
CommitEdit | GridColumn.CommitEdit override.
ConfirmBeginEdit | GridColumn.ConfirmBeginEdit override.
CreateEditor | GridColumn.CreateEditor override.
CreateEditorBinding | GridColumn.CreateEditorBinding override.
CreateViewer | GridColumn.CreateViewer override.
CreateViewerBinding | GridColumn.CreateViewerBinding override.
InitEditor | GridColumn.InitEditor override.

See Also

TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CancelEdit Method

TextColumn.CancelEdit Method
[image]

GridColumn.CancelEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CancelEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CancelEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CommitEdit Method

TextColumn.CommitEdit Method
[image]

GridColumn.CommitEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void CommitEdit (
FrameworkElement editor
)

Visual Basic [image] Copy Code

Protected Overrides Sub CommitEdit( _
editor As FrameworkElement _
)

Parameters

editor
A FrameworkElement representing the editor.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.ConfirmBeginEdit Method

TextColumn.ConfirmBeginEdit Method
[image]

GridColumn.ConfirmBeginEdit override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool ConfirmBeginEdit (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Function ConfirmBeginEdit( _
e As RoutedEventArgs _
) As Boolean

Parameters

e
A RoutedEventArgs specifying the user input.

Return Value

true to initiate editing; otherwise, false.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CreateEditor Method

TextColumn.CreateEditor Method
[image]

GridColumn.CreateEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateEditor (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditor( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data being edited.

Return Value

A FrameworkElement representing the editor for the specified data.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CreateEditorBinding Method

TextColumn.CreateEditorBinding Method
[image]

GridColumn.CreateEditorBinding override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Binding CreateEditorBinding ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateEditorBinding () As Binding

Return Value

A .NET Binding that should be used by the associated editor.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CreateViewer Method

TextColumn.CreateViewer Method
[image]

GridColumn.CreateViewer override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override FrameworkElement CreateViewer (
Object rowData
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewer( _
rowData As Object _
) As FrameworkElement

Parameters

rowData

The data for which to create presentation.

Return Value

A FrameworkElement that should be used for visualization of the specified data.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.CreateViewerBinding Method

TextColumn.CreateViewerBinding Method
[image]

GridColumn.CreateViewerBinding override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Binding CreateViewerBinding ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateViewerBinding () As Binding

Return Value

A .NET Binding that should be used by the associated viewer.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TextColumn.InitEditor Method

TextColumn.InitEditor Method
[image]

GridColumn.InitEditor override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual void InitEditor (
FrameworkElement editor,
RoutedEventArgs e,
GridCell senderCell
)

Visual Basic [image] Copy Code

Protected Overridable Sub InitEditor ( _
editor As FrameworkElement, _
e As RoutedEventArgs, _
senderCell As GridCell _
)

Parameters

editor
A FrameworkElement representing the editor.
e

The arguments associated with the event, which caused the editing operation.

senderCell
The GridCell which is being edited.

See Also

TextColumn Members
TextColumn Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter Class

ThicknessValueConverter Class
[image]

Converts double values to Thickness.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class ThicknessValueConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ThicknessValueConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.ThicknessValueConverter

See Also

ThicknessValueConverter Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter Members

ThicknessValueConverter Members
Constructors Methods
[image]

Converts double values to Thickness.

The following tables list the members exposed by the ThicknessValueConverter type.

Public Constructors

Name | Description
ThicknessValueConverter | Initializes a new instance of the ThicknessValueConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessValueConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter Constructor

ThicknessValueConverter Constructor
[image]

Initializes a new instance of the ThicknessValueConverter class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ThicknessValueConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ThicknessValueConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter Methods

ThicknessValueConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessValueConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter.Convert Method

ThicknessValueConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ThicknessValueConverter Members
ThicknessValueConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.ThicknessValueConverter.ConvertBack Method

ThicknessValueConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ThicknessValueConverter Members
ThicknessValueConverter Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Class

TimelineHeader Class
[image]

Represents a panel-like control, which displays up to three synchronous timelines each with different time resolution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TimelineHeader : Control, IWeakEventListener

Visual Basic [image] Copy Code

Public Class TimelineHeader
Inherits Control
Implements IWeakEventListener

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.DataViews.Wpf.TimelineHeader

See Also

TimelineHeader Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Members

TimelineHeader Members
Constructors Fields Properties Methods Events
[image]

Represents a panel-like control, which displays up to three synchronous timelines each with different time resolution.

The following tables list the members exposed by the TimelineHeader type.

Public Constructors

Name | Description
TimelineHeader | Initializes a new instance of the TimelineHeader class.

Public Fields

Name | Description
AllowDrillProperty | Identifies the AllowDrill dependency property.
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
DrilledInEvent | Identifies the DrilledIn routed event.
DrilledOutEvent | Identifies the DrilledOut routed event.
DrillingInEvent | Identifies the DrillingIn routed event.
DrillingOutEvent | Identifies the DrillingOut routed event.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.

Public Properties

Name | Description
AllowDrill | Gets or sets a value indicating whether the TimelineHeader is allowed to zoom in and out. This is a dependency property.
BottomTimelineSettings | Gets or sets the TimelineSettings object, associated with the bottom timeline. This is a dependency property.
CellWidth | Gets or sets the standard width of cell in the bottom timeline. This is a dependency property.
LeftAutoScrollOffsetValue | Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the left.
MiddleTimelineSettings | Gets or sets the TimelineSettings object, associated with the middle timeline. This is a dependency property.
RightAutoScrollOffsetValue | Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the right.
Timelines | Gets or sets the number of timelines to be displayed in the header. This is a dependency property.
TopTimelineSettings | Gets or sets the TimelineSettings object, associated with the top timeline. This is a dependency property.

Public Methods

Name | Description
AutoScrollLeft | Scrolls all timelines to the left.
AutoScrollRight | Adds n units to the represented TimeSpan.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
ReceiveWeakEvent | IWeakEventListener.ReceiveWeakEvent implementation.

Protected Methods

Name | Description
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewKeyUp | UIElement.OnPreviewKeyUp override.
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override.

Public Events

Name | Description
DrilledIn | Raised when the TimelineHeader is drilled in.
DrilledOut | Raised when the TimelineHeader is drilled out.
DrillingIn | Raised when the TimelineHeader is currently drilling in.
DrillingOut | Raised when the TimelineHeader is currently drilling out.

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Fields

TimelineHeader Fields
[image]

Public Fields

Name | Description
AllowDrillProperty | Identifies the AllowDrill dependency property.
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
DrilledInEvent | Identifies the DrilledIn routed event.
DrilledOutEvent | Identifies the DrilledOut routed event.
DrillingInEvent | Identifies the DrillingIn routed event.
DrillingOutEvent | Identifies the DrillingOut routed event.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.AllowDrillProperty Field

TimelineHeader.AllowDrillProperty Field
[image]

Identifies the AllowDrill dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowDrillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowDrillProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.BottomTimelineSettingsProperty Field

TimelineHeader.BottomTimelineSettingsProperty Field
[image]

Identifies the BottomTimelineSettings dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BottomTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BottomTimelineSettingsProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrilledInEvent Field

TimelineHeader.DrilledInEvent Field
[image]

Identifies the DrilledIn routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent DrilledInEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly DrilledInEvent As RoutedEvent

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrilledOutEvent Field

TimelineHeader.DrilledOutEvent Field
[image]

Identifies the DrilledOut routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent DrilledOutEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly DrilledOutEvent As RoutedEvent

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrillingInEvent Field

TimelineHeader.DrillingInEvent Field
[image]

Identifies the DrillingIn routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent DrillingInEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly DrillingInEvent As RoutedEvent

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrillingOutEvent Field

TimelineHeader.DrillingOutEvent Field
[image]

Identifies the DrillingOut routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent DrillingOutEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly DrillingOutEvent As RoutedEvent

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.MiddleTimelineSettingsProperty Field

TimelineHeader.MiddleTimelineSettingsProperty Field
[image]

Identifies the MiddleTimelineSettings dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MiddleTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MiddleTimelineSettingsProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.TimelinesProperty Field

TimelineHeader.TimelinesProperty Field
[image]

Identifies the Timelines dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelinesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelinesProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.TopTimelineSettingsProperty Field

TimelineHeader.TopTimelineSettingsProperty Field
[image]

Identifies the TopTimelineSettings dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopTimelineSettingsProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Constructor

TimelineHeader Constructor
[image]

Initializes a new instance of the TimelineHeader class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Methods

TimelineHeader Methods
[image]

Public Methods

Name | Description
AutoScrollLeft | Scrolls all timelines to the left.
AutoScrollRight | Adds n units to the represented TimeSpan.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
ReceiveWeakEvent | IWeakEventListener.ReceiveWeakEvent implementation.

Protected Methods

Name | Description
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewKeyUp | UIElement.OnPreviewKeyUp override.
OnPreviewMouseLeftButtonUp | UIElement.OnPreviewMouseLeftButtonUp override.

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.AutoScrollLeft Method

TimelineHeader.AutoScrollLeft Method
[image]

Scrolls all timelines to the left.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void AutoScrollLeft ()

Visual Basic [image] Copy Code

Public Sub AutoScrollLeft ()

Remarks

The number and type of units is specified through the UnitCount and Unit properties of the BottomTimelineSettings.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.AutoScrollRight Method

TimelineHeader.AutoScrollRight Method
[image]

Adds n units to the represented TimeSpan.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void AutoScrollRight ()

Visual Basic [image] Copy Code

Public Sub AutoScrollRight ()

Remarks

The number and type of units is specified through the UnitCount and Unit properties of the BottomTimelineSettings.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.OnApplyTemplate Method

TimelineHeader.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.OnMouseLeftButtonDown Method

TimelineHeader.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.OnMouseMove Method

TimelineHeader.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.OnPreviewKeyUp Method

TimelineHeader.OnPreviewKeyUp Method
[image]

UIElement.OnPreviewKeyUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewKeyUp (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewKeyUp( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.OnPreviewMouseLeftButtonUp Method

TimelineHeader.OnPreviewMouseLeftButtonUp Method
[image]

UIElement.OnPreviewMouseLeftButtonUp override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.ReceiveWeakEvent Method

TimelineHeader.ReceiveWeakEvent Method
[image]

IWeakEventListener.ReceiveWeakEvent implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool ReceiveWeakEvent (
Type managerType,
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Public Function ReceiveWeakEvent( _
managerType As Type, _
sender As Object, _
e As EventArgs _
) As Boolean

Parameters

managerType
The type of the WeakEventManager calling this method.
sender
Object that originated the event.
e
Event data.

Return Value

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Properties

TimelineHeader Properties
[image]

Public Properties

Name | Description
AllowDrill | Gets or sets a value indicating whether the TimelineHeader is allowed to zoom in and out. This is a dependency property.
BottomTimelineSettings | Gets or sets the TimelineSettings object, associated with the bottom timeline. This is a dependency property.
CellWidth | Gets or sets the standard width of cell in the bottom timeline. This is a dependency property.
LeftAutoScrollOffsetValue | Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the left.
MiddleTimelineSettings | Gets or sets the TimelineSettings object, associated with the middle timeline. This is a dependency property.
RightAutoScrollOffsetValue | Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the right.
Timelines | Gets or sets the number of timelines to be displayed in the header. This is a dependency property.
TopTimelineSettings | Gets or sets the TimelineSettings object, associated with the top timeline. This is a dependency property.

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.AllowDrill Property

TimelineHeader.AllowDrill Property
[image]

Gets or sets a value indicating whether the TimelineHeader is allowed to zoom in and out. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool AllowDrill { get; set; }

Visual Basic [image] Copy Code

Public Property AllowDrill As Boolean

Property Value

true to enable interactive zooming; otherwise, false. The default is true.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.BottomTimelineSettings Property

TimelineHeader.BottomTimelineSettings Property
[image]

Gets or sets the TimelineSettings object, associated with the bottom timeline. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings BottomTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property BottomTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.CellWidth Property

TimelineHeader.CellWidth Property
[image]

Gets or sets the standard width of cell in the bottom timeline. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double CellWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CellWidth As Double

Property Value

A double value specifying the width of the cells in the bottom timeline. The default is 40.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.LeftAutoScrollOffsetValue Property

TimelineHeader.LeftAutoScrollOffsetValue Property
[image]

Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the left.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int LeftAutoScrollOffsetValue { get; set; }

Visual Basic [image] Copy Code

Public Property LeftAutoScrollOffsetValue As Integer

Property Value

An integer specifying the number of cells to scroll.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.MiddleTimelineSettings Property

TimelineHeader.MiddleTimelineSettings Property
[image]

Gets or sets the TimelineSettings object, associated with the middle timeline. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings MiddleTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.RightAutoScrollOffsetValue Property

TimelineHeader.RightAutoScrollOffsetValue Property
[image]

Gets or sets a value, which indicates the number of cells to scroll when autoscrolling to the right.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int RightAutoScrollOffsetValue { get; set; }

Visual Basic [image] Copy Code

Public Property RightAutoScrollOffsetValue As Integer

Property Value

An integer specifying the number of cells to scroll.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.Timelines Property

TimelineHeader.Timelines Property
[image]

Gets or sets the number of timelines to be displayed in the header. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int Timelines { get; set; }

Visual Basic [image] Copy Code

Public Property Timelines As Integer

Property Value

An integer value that specifies the number of timelines in the header. The default is 3.

Remarks

If value is set outside the interval 1-3, coerced value in this range is used instead.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.TopTimelineSettings Property

TimelineHeader.TopTimelineSettings Property
[image]

Gets or sets the TimelineSettings object, associated with the top timeline. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings TopTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property TopTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader Events

TimelineHeader Events
[image]

Public Events

Name | Description
DrilledIn | Raised when the TimelineHeader is drilled in.
DrilledOut | Raised when the TimelineHeader is drilled out.
DrillingIn | Raised when the TimelineHeader is currently drilling in.
DrillingOut | Raised when the TimelineHeader is currently drilling out.

See Also

TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrilledIn Event

TimelineHeader.DrilledIn Event
[image]

Raised when the TimelineHeader is drilled in.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler DrilledIn

Visual Basic [image] Copy Code

Public Event DrilledIn As RoutedEventHandler

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrilledOut Event

TimelineHeader.DrilledOut Event
[image]

Raised when the TimelineHeader is drilled out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler DrilledOut

Visual Basic [image] Copy Code

Public Event DrilledOut As RoutedEventHandler

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrillingIn Event

TimelineHeader.DrillingIn Event
[image]

Raised when the TimelineHeader is currently drilling in.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event DrillValidationRoutedEventHandler DrillingIn

Visual Basic [image] Copy Code

Public Event DrillingIn As DrillValidationRoutedEventHandler

Event Data

DrillingIn event handlers receive an argument of type DrillValidationRoutedEventArgs.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineHeader.DrillingOut Event

TimelineHeader.DrillingOut Event
[image]

Raised when the TimelineHeader is currently drilling out.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event DrillValidationRoutedEventHandler DrillingOut

Visual Basic [image] Copy Code

Public Event DrillingOut As DrillValidationRoutedEventHandler

Event Data

DrillingIn event handlers receive an argument of type DrillValidationRoutedEventArgs.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings Class

TimelineSettings Class
[image]

Encapsulates settings for a timeline in a ScheduleColumnHeader.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TimelineSettings : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class TimelineSettings
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.TimelineSettings

See Also

TimelineSettings Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings Members

TimelineSettings Members
Constructors Properties Events
[image]

Encapsulates settings for a timeline in a ScheduleColumnHeader.

The following tables list the members exposed by the TimelineSettings type.

Public Constructors

Name | Description
TimelineSettings | Initializes a new instance of the TimelineSettings class.

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings Constructor

TimelineSettings Constructor
[image]

Initializes a new instance of the TimelineSettings class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings Properties

TimelineSettings Properties
[image]

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings.Format Property

TimelineSettings.Format Property
[image]

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public string Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As String

Property Value

A string specifying the format of dates.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings.Unit Property

TimelineSettings.Unit Property
[image]

Gets or sets the time unit of the timeline.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property
[image]

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int UnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property UnitCount As Integer

Property Value

An integer specifying the number of units.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings Events

TimelineSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimelineSettings.PropertyChanged Event

TimelineSettings.PropertyChanged Event
[image]

Occurs when a property value changes.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Class

TimeRange Class
[image]

Represents a time range with maximum length of one day. The range is defined by two TimeSpan instances.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public sealed class TimeRange : IComparable, IComparable<TimeRange>, IEquatable<TimeRange>

Visual Basic [image] Copy Code

Public NotInheritable Class TimeRange
Implements IComparable, IComparable(Of TimeRange), IEquatable(Of TimeRange)

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.TimeRange

See Also

TimeRange Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Members

TimeRange Members
Constructors Properties Methods
[image]

Represents a time range with maximum length of one day. The range is defined by two TimeSpan instances.

The following tables list the members exposed by the TimeRange type.

Public Constructors

Name | Description
TimeRange | Overloaded. Initializes a new instance of the TimeRange class.

Public Properties

Name | Description
Duration | Gets the duration that the time range represents.
First | Gets or sets the first time span defining the current time range.
Second | Gets or sets the second time span defining the current time range.

Public Methods

Name | Description
CompareTo | Overloaded. Compares this TimeRange to another object.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
IntersectsWith | Indicates if the specified time range intersects with the current time range.
ToString | Object.ToString override.

See Also

TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Constructor

TimeRange Constructor
[image]

Initializes a new instance of the TimeRange class.

Overload List

Name | Description
TimeRange () | Initializes a new instance of the TimeRange class with length of 24 hours.
TimeRange (Int32, Int32, Int32, Int32) | Initializes a new instance of the TimeRange class to a specified beginning and end.
TimeRange (Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the TimeRange class to a specified beginning and end.
TimeRange (TimeSpan, TimeSpan) | Initializes a new instance of the TimeRange class to a specified beginning and end.

See Also

TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Constructor ()

TimeRange Constructor ()
See Also
[image]

Initializes a new instance of the TimeRange class with length of 24 hours.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRange ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimeRange Constructor Overload List
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Constructor (Int32, Int32, Int32, Int32)

TimeRange Constructor (Int32, Int32, Int32, Int32)
See Also
[image]

Initializes a new instance of the TimeRange class to a specified beginning and end.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRange (
int fHours,
int fMinutes,
int sHours,
int sMinutes
)

Visual Basic [image] Copy Code

Public New ( _
fHours As Integer, _
fMinutes As Integer, _
sHours As Integer, _
sMinutes As Integer _
)

Parameters

fHours
The number of hours of the first TimeSpan.
fMinutes
The number of minutes of the first TimeSpan.
sHours
The number of hours of the second TimeSpan.
sMinutes
The number of minutes of the second TimeSpan.

See Also

TimeRange Constructor Overload List
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

TimeRange Constructor (Int32, Int32, Int32, Int32, Int32, Int32)
See Also
[image]

Initializes a new instance of the TimeRange class to a specified beginning and end.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRange (
int fHours,
int fMinutes,
int fSeconds,
int sHours,
int sMinutes,
int sSeconds
)

Visual Basic [image] Copy Code

Public New ( _
fHours As Integer, _
fMinutes As Integer, _
fSeconds As Integer, _
sHours As Integer, _
sMinutes As Integer, _
sSeconds As Integer _
)

Parameters

fHours
The number of hours of the first TimeSpan.
fMinutes
The number of minutes of the first TimeSpan.
fSeconds
The number of seconds of the first TimeSpan.
sHours
The number of hours of the second TimeSpan.
sMinutes
The number of minutes of the second TimeSpan.
sSeconds
The number of seconds of the second TimeSpan.

See Also

TimeRange Constructor Overload List
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Constructor (TimeSpan, TimeSpan)

TimeRange Constructor (TimeSpan, TimeSpan)
See Also
[image]

Initializes a new instance of the TimeRange class to a specified beginning and end.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRange (
TimeSpan first,
TimeSpan second
)

Visual Basic [image] Copy Code

Public New ( _
first As TimeSpan, _
second As TimeSpan _
)

Parameters

first
The first TimeSpan instance of the range.
second
The second TimeSpan instance of the range.

Remarks

It is not necessary to supply the two arguments in chronological order. TimeRange.First will always hold the value of the earlier TimeSpan.

See Also

TimeRange Constructor Overload List
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Methods

TimeRange Methods
[image]

Public Methods

Name | Description
CompareTo | Overloaded. Compares this TimeRange to another object.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
IntersectsWith | Indicates if the specified time range intersects with the current time range.
ToString | Object.ToString override.

See Also

TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.CompareTo Method

TimeRange.CompareTo Method
[image]

Compares this TimeRange to another object.

Overload List

Name | Description
TimeRange.CompareTo (Object) | IComparable.CompareTo implementation.
TimeRange.CompareTo (TimeRange) | IComparable<T>.CompareTo implementation.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.CompareTo Method (Object)

TimeRange.CompareTo Method (Object)
See Also
[image]

IComparable.CompareTo implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared.

See Also

CompareTo Method Overload List
TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.CompareTo Method (TimeRange)

TimeRange.CompareTo Method (TimeRange)
See Also
[image]

IComparable<T>.CompareTo implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public virtual int CompareTo (
TimeRange other
)

Visual Basic [image] Copy Code

Public Overridable Function CompareTo ( _
other As TimeRange _
) As Integer

Parameters

other
The TimeRange to compare to this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared.

See Also

CompareTo Method Overload List
TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.Equals Method

TimeRange.Equals Method
[image]

Overload List

Name | Description
TimeRange.Equals (Object) | Object.Equals override.
TimeRange.Equals (TimeRange) | IEquatable<T>.Equals implementation.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.Equals Method (Object)

TimeRange.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

See Also

Equals Method Overload List
TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.Equals Method (TimeRange)

TimeRange.Equals Method (TimeRange)
See Also
[image]

IEquatable<T>.Equals implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
TimeRange other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As TimeRange _
) As Boolean

Parameters

other
The TimeRange to compare with the current TimeRange.

Return Value

true if the specified TimeRange is equal to the current TimeRange; otherwise, false.

See Also

Equals Method Overload List
TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.GetHashCode Method

TimeRange.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current Object.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.IntersectsWith Method

TimeRange.IntersectsWith Method
[image]

Indicates if the specified time range intersects with the current time range.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IntersectsWith (
TimeRange range
)

Visual Basic [image] Copy Code

Public Function IntersectsWith ( _
range As TimeRange _
) As Boolean

Parameters

range
The time range to check.

Return Value

true if the two time ranges intersect, false otherwise.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.ToString Method

TimeRange.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A String that represents the current Object.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange Properties

TimeRange Properties
[image]

Public Properties

Name | Description
Duration | Gets the duration that the time range represents.
First | Gets or sets the first time span defining the current time range.
Second | Gets or sets the second time span defining the current time range.

See Also

TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.Duration Property

TimeRange.Duration Property
[image]

Gets the duration that the time range represents.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeSpan Duration { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Duration As TimeSpan

Property Value

A .NET TimeSpan object.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.First Property

TimeRange.First Property
[image]

Gets or sets the first time span defining the current time range.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeSpan First { get; set; }

Visual Basic [image] Copy Code

Public Property First As TimeSpan

Property Value

A .NET TimeSpan object.

Remarks

This property will always hold the value of the earlier time span.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRange.Second Property

TimeRange.Second Property
[image]

Gets or sets the second time span defining the current time range.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeSpan Second { get; set; }

Visual Basic [image] Copy Code

Public Property Second As TimeSpan

Property Value

A .NET TimeSpan object.

Remarks

This property will always hold the value of the later time span.

See Also

TimeRange Members
TimeRange Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Class

TimeRangeCollection Class
[image]

Represents a sorted observable collection of TimeRange objects, which are merged in their time spans overlap.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TimeRangeCollection : SortedObservableCollection<TimeRange>

Visual Basic [image] Copy Code

Public Class TimeRangeCollection
Inherits SortedObservableCollection(Of TimeRange)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(TimeRange)
System.Collections.ObjectModel.ObservableCollection(TimeRange)
MindFusion.DataViews.Wpf.SortedObservableCollection(TimeRange)
MindFusion.DataViews.Wpf.TimeRangeCollection

See Also

TimeRangeCollection Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Members

TimeRangeCollection Members
Constructors Properties Methods
[image]

Represents a sorted observable collection of TimeRange objects, which are merged in their time spans overlap.

The following tables list the members exposed by the TimeRangeCollection type.

Public Constructors

Name | Description
TimeRangeCollection | Overloaded. Initializes a new instance of the TimeRangeCollection class.

Public Properties

Name | Description
AreItemsUnique | Gets or sets a value to indicate whether the collection can contain duplicate items. (Inherited from SortedObservableCollection.)

Protected Methods

Name | Description
InsertItem | ObservableCollection<T>.InsertItem override. (Inherited from SortedObservableCollection.)
MoveItem | ObservableCollection<T>.MoveItem override. (Inherited from SortedObservableCollection.)
OnCollectionChanged | SortedObservableCollection<T>.OnCollectionChanged override.
SetItem | ObservableCollection<T>.SetItem override. (Inherited from SortedObservableCollection.)
Sort | Sorts the collection. (Inherited from SortedObservableCollection.)

See Also

TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Constructor

TimeRangeCollection Constructor
[image]

Initializes a new instance of the TimeRangeCollection class.

Overload List

Name | Description
TimeRangeCollection () | Initializes a new instance of the TimeRangeCollection class.
TimeRangeCollection (Boolean) | Initializes a new instance of the TimeRangeCollection class, specifying if the collection can hold duplicate items.

See Also

TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Constructor ()

TimeRangeCollection Constructor ()
See Also
[image]

Initializes a new instance of the TimeRangeCollection class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRangeCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimeRangeCollection Constructor Overload List
TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Constructor (Boolean)

TimeRangeCollection Constructor (Boolean)
See Also
[image]

Initializes a new instance of the TimeRangeCollection class, specifying if the collection can hold duplicate items.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TimeRangeCollection (
bool areItemsUnique
)

Visual Basic [image] Copy Code

Public New ( _
areItemsUnique As Boolean _
)

Parameters

areItemsUnique

Specifies if the collection can contain duplicate items.

See Also

TimeRangeCollection Constructor Overload List
TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection Methods

TimeRangeCollection Methods
[image]

Protected Methods

Name | Description
InsertItem | ObservableCollection<T>.InsertItem override. (Inherited from SortedObservableCollection.)
MoveItem | ObservableCollection<T>.MoveItem override. (Inherited from SortedObservableCollection.)
OnCollectionChanged | SortedObservableCollection<T>.OnCollectionChanged override.
SetItem | ObservableCollection<T>.SetItem override. (Inherited from SortedObservableCollection.)
Sort | Sorts the collection. (Inherited from SortedObservableCollection.)

See Also

TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeRangeCollection.OnCollectionChanged Method

TimeRangeCollection.OnCollectionChanged Method
[image]

SortedObservableCollection<T>.OnCollectionChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

Arguments of the event being raised.

See Also

TimeRangeCollection Members
TimeRangeCollection Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TimeUnit Enumeration

TimeUnit Enumeration
[image]

Specifies time resolution.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public enum TimeUnit

Visual Basic [image] Copy Code

Public Enum TimeUnit

Members

Member name | Description
Day | Specifies days.
Hour | Specifies hours.
Minute | Specifies minutes.
Month | Specifies months.
Week | Specifies weeks.
Year | Specifies years.

See Also

MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Class

TreeGrid Class
[image]

A grid that can display hierarchical data.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TreeGrid : DataGrid

Visual Basic [image] Copy Code

Public Class TreeGrid
Inherits DataGrid

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.Primitives.MultiSelector
MindFusion.DataViews.Wpf.DataGrid
MindFusion.DataViews.Wpf.TreeGrid
MindFusion.DataViews.Wpf.ScheduleGrid

See Also

TreeGrid Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Members

TreeGrid Members
Constructors Fields Properties Methods Events
[image]

A grid that can display hierarchical data.

The following tables list the members exposed by the TreeGrid type.

Public Constructors

Name | Description
TreeGrid | Initializes a new instance of the TreeGrid class.

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property. (Inherited from DataGrid.)
AlternatingRowBackgroundProperty | Identifies the AlternatingRowBackground dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrushProperty | Identifies the AlternatingRowBorderBrush dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThicknessProperty | Identifies the AlternatingRowBorderThickness dependency property. (Inherited from DataGrid.)
AutoGenerateColumnsProperty | Identifies the AutoGenerateColumns dependency property. (Inherited from DataGrid.)
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property. (Inherited from DataGrid.)
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. (Inherited from DataGrid.)
CurrentCellProperty | Identifies the CurrentCell dependency property. (Inherited from DataGrid.)
DataTypeProperty | Identifies the DataType dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from DataGrid.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from DataGrid.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from DataGrid.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from DataGrid.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from DataGrid.)
RowBackgroundProperty | Identifies the RowBackground dependency property. (Inherited from DataGrid.)
RowBorderBrushProperty | Identifies the RowBorderBrush dependency property. (Inherited from DataGrid.)
RowBorderThicknessProperty | Identifies the RowBorderThickness dependency property. (Inherited from DataGrid.)
RowHeadersVisibleProperty | Identifies the RowHeadersVisible dependency property. (Inherited from DataGrid.)

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBackground | Gets or sets the background brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrush | Gets or sets the border brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThickness | Gets or sets the border thickness of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AutoGenerateColumns | Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property. (Inherited from DataGrid.)
CellBorderBrush | Gets or sets the border brush of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
CellBorderThickness | Gets or sets the border thickness of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
Columns | Gets or sets a list with the columns displayed in the grid. (Inherited from DataGrid.)
CurrentCell | Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property. (Inherited from DataGrid.)
DataType | Gets or sets the type of the data contained in the grid. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderContentTemplate | Gets or sets the template to use for the individual column headers. This is a dependency property. (Inherited from DataGrid.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DataGrid.)
RowBackground | Gets or sets the background brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderBrush | Gets or sets the border brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderThickness | Gets or sets the border thickness of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowHeadersVisible | Gets or sets a value indicating whether row headers are visible. This is a dependency property. (Inherited from DataGrid.)

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override. (Inherited from DataGrid.)
CreateRowContainer | Creates the container for the header of a TreeNode.
GetContainerForItemOverride | DataGrid.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | DataGrid.IsItemItsOwnContainerOverride override.
OnColumnCreating | Raises the ColumnCreating event. (Inherited from DataGrid.)
OnItemsSourceChanged | Selector.OnItemsSourceChanged override. (Inherited from DataGrid.)
OnKeyDown | ItemsControl.OnKeyDown override. (Inherited from DataGrid.)
OnRowClicked | Raises the RowClicked event. (Inherited from DataGrid.)
OnTextInput | ItemsControl.OnTextInput override. (Inherited from DataGrid.)
PrepareContainerForItemOverride | DataGrid.PrepareContainerForItemOverride override.

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid. (Inherited from DataGrid.)
RowClicked | Raised when a row in the grid is clicked with the mouse. (Inherited from DataGrid.)

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Fields

TreeGrid Fields
[image]

Public Fields

Name | Description
AllowColumnReorderProperty | Identifies the AllowColumnReorder dependency property. (Inherited from DataGrid.)
AlternatingRowBackgroundProperty | Identifies the AlternatingRowBackground dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrushProperty | Identifies the AlternatingRowBorderBrush dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThicknessProperty | Identifies the AlternatingRowBorderThickness dependency property. (Inherited from DataGrid.)
AutoGenerateColumnsProperty | Identifies the AutoGenerateColumns dependency property. (Inherited from DataGrid.)
CellBorderBrushProperty | Identifies the CellBorderBrush dependency property. (Inherited from DataGrid.)
CellBorderThicknessProperty | Identifies the CellBorderThickness dependency property. (Inherited from DataGrid.)
CurrentCellProperty | Identifies the CurrentCell dependency property. (Inherited from DataGrid.)
DataTypeProperty | Identifies the DataType dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property. (Inherited from DataGrid.)
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property. (Inherited from DataGrid.)
HeaderContentTemplateProperty | Identifies the HeaderContentTemplate dependency property. (Inherited from DataGrid.)
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property. (Inherited from DataGrid.)
HeaderForegroundProperty | Identifies the HeaderBackground dependency property. (Inherited from DataGrid.)
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from DataGrid.)
RowBackgroundProperty | Identifies the RowBackground dependency property. (Inherited from DataGrid.)
RowBorderBrushProperty | Identifies the RowBorderBrush dependency property. (Inherited from DataGrid.)
RowBorderThicknessProperty | Identifies the RowBorderThickness dependency property. (Inherited from DataGrid.)
RowHeadersVisibleProperty | Identifies the RowHeadersVisible dependency property. (Inherited from DataGrid.)

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.DataTypeProperty Field

TreeGrid.DataTypeProperty Field
[image]

Identifies the DataType dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataTypeProperty As DependencyProperty

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Constructor

TreeGrid Constructor
[image]

Initializes a new instance of the TreeGrid class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TreeGrid ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Methods

TreeGrid Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override. (Inherited from DataGrid.)
CreateRowContainer | Creates the container for the header of a TreeNode.
GetContainerForItemOverride | DataGrid.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | DataGrid.IsItemItsOwnContainerOverride override.
OnColumnCreating | Raises the ColumnCreating event. (Inherited from DataGrid.)
OnItemsSourceChanged | Selector.OnItemsSourceChanged override. (Inherited from DataGrid.)
OnKeyDown | ItemsControl.OnKeyDown override. (Inherited from DataGrid.)
OnRowClicked | Raises the RowClicked event. (Inherited from DataGrid.)
OnTextInput | ItemsControl.OnTextInput override. (Inherited from DataGrid.)
PrepareContainerForItemOverride | DataGrid.PrepareContainerForItemOverride override.

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.CreateRowContainer Method

TreeGrid.CreateRowContainer Method
[image]

Creates the container for the header of a TreeNode.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected virtual GridRow CreateRowContainer ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateRowContainer () As GridRow

Return Value

An instance of the GridRow class.

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.GetContainerForItemOverride Method

TreeGrid.GetContainerForItemOverride Method
[image]

DataGrid.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.IsItemItsOwnContainerOverride Method

TreeGrid.IsItemItsOwnContainerOverride Method
[image]

DataGrid.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.OnApplyTemplate Method

TreeGrid.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.PrepareContainerForItemOverride Method

TreeGrid.PrepareContainerForItemOverride Method
[image]

DataGrid.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Properties

TreeGrid Properties
[image]

Public Properties

Name | Description
AllowColumnReorder | Gets or sets a value indicating whether columns in this header can be reordered interactively. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBackground | Gets or sets the background brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderBrush | Gets or sets the border brush of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AlternatingRowBorderThickness | Gets or sets the border thickness of alternating grid rows. This is a dependency property. (Inherited from DataGrid.)
AutoGenerateColumns | Gets or sets a value indicating whether to automatically generate the necessary grid columns based on the properties of the items in the underlying Items collection. This is a dependency property. (Inherited from DataGrid.)
CellBorderBrush | Gets or sets the border brush of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
CellBorderThickness | Gets or sets the border thickness of the cells in the grid. This is a dependency property. (Inherited from DataGrid.)
Columns | Gets or sets a list with the columns displayed in the grid. (Inherited from DataGrid.)
CurrentCell | Gets or sets the GridCell within this grid, which is currently holding the input focus. This is a dependency property. (Inherited from DataGrid.)
DataType | Gets or sets the type of the data contained in the grid. This is a dependency property.
HeaderBackground | Gets or sets the brush used to fill the header background. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderBrush | Gets or sets border brush of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderBorderThickness | Gets or sets the border thickness of the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderContentTemplate | Gets or sets the template to use for the individual column headers. This is a dependency property. (Inherited from DataGrid.)
HeaderFontSize | Gets or sets the size of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderForeground | Gets or sets the brush used to draw the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
HeaderMargin | Gets or sets the margin of the texts displayed in the grid header. This is a dependency property. (Inherited from DataGrid.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DataGrid.)
RowBackground | Gets or sets the background brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderBrush | Gets or sets the border brush of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowBorderThickness | Gets or sets the border thickness of grid rows. This is a dependency property. (Inherited from DataGrid.)
RowHeadersVisible | Gets or sets a value indicating whether row headers are visible. This is a dependency property. (Inherited from DataGrid.)

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid.DataType Property

TreeGrid.DataType Property
[image]

Gets or sets the type of the data contained in the grid. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Type DataType { get; set; }

Visual Basic [image] Copy Code

Public Property DataType As Type

Property Value

An instance of the Type class.

See Also

TreeGrid Members
TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGrid Events

TreeGrid Events
[image]

Public Events

Name | Description
ColumnCreating | Raised when a column is automatically generated by the grid. (Inherited from DataGrid.)
RowClicked | Raised when a row in the grid is clicked with the mouse. (Inherited from DataGrid.)

See Also

TreeGrid Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel Class

TreeGridVirtualPanel Class
[image]

A virtualizing panel for the TreeGrid class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TreeGridVirtualPanel : VirtualizingPanel, IScrollInfo

Visual Basic [image] Copy Code

Public Class TreeGridVirtualPanel
Inherits VirtualizingPanel
Implements IScrollInfo

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.VirtualizingPanel
MindFusion.DataViews.Wpf.TreeGridVirtualPanel

See Also

TreeGridVirtualPanel Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel Members

TreeGridVirtualPanel Members
Constructors Properties Methods
[image]

A virtualizing panel for the TreeGrid class.

The following tables list the members exposed by the TreeGridVirtualPanel type.

Public Constructors

Name | Description
TreeGridVirtualPanel | Initializes a new instance of the TreeGridVirtualPanel class.

Public Properties

Name | Description
CanHorizontallyScroll | IScrollInfo.CanHorizontallyScroll implementation.
CanVerticallyScroll | IScrollInfo.CanVerticallyScroll implementation.
ExtentHeight | IScrollInfo.ExtentHeight implementation.
ExtentWidth | IScrollInfo.ExtentWidth implementation.
HorizontalOffset | IScrollInfo.HorizontalOffset implementation.
ScrollOwner | IScrollInfo.ScrollOwner implementation.
VerticalOffset | IScrollInfo.VerticalOffset implementation.
ViewportHeight | IScrollInfo.ViewportHeight implementation.
ViewportWidth | IScrollInfo.ViewportWidth implementation.

Public Methods

Name | Description
LineDown | IScrollInfo.LineDown implementation.
LineLeft | IScrollInfo.LineLeft implementation.
LineRight | IScrollInfo.LineRight implementation.
LineUp | IScrollInfo.LineUp implementation.
MakeVisible | IScrollInfo.MakeVisible implementation.
MouseWheelDown | IScrollInfo.MouseWheelDown implementation.
MouseWheelLeft | IScrollInfo.MouseWheelLeft implementation.
MouseWheelRight | IScrollInfo.MouseWheelRight implementation.
MouseWheelUp | IScrollInfo.MouseWheelUp implementation.
PageDown | IScrollInfo.PageDown implementation.
PageLeft | IScrollInfo.PageLeft implementation.
PageRight | IScrollInfo.PageRight implementation.
PageUp | IScrollInfo.PageUp implementation.
SetHorizontalOffset | IScrollInfo.SetHorizontalOffset implementation.
SetVerticalOffset | IScrollInfo.SetVerticalOffset implementation.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnItemsChanged | VirtualizingPanel.OnItemsChanged override.

See Also

TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel Constructor

TreeGridVirtualPanel Constructor
[image]

Initializes a new instance of the TreeGridVirtualPanel class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TreeGridVirtualPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel Methods

TreeGridVirtualPanel Methods
[image]

Public Methods

Name | Description
LineDown | IScrollInfo.LineDown implementation.
LineLeft | IScrollInfo.LineLeft implementation.
LineRight | IScrollInfo.LineRight implementation.
LineUp | IScrollInfo.LineUp implementation.
MakeVisible | IScrollInfo.MakeVisible implementation.
MouseWheelDown | IScrollInfo.MouseWheelDown implementation.
MouseWheelLeft | IScrollInfo.MouseWheelLeft implementation.
MouseWheelRight | IScrollInfo.MouseWheelRight implementation.
MouseWheelUp | IScrollInfo.MouseWheelUp implementation.
PageDown | IScrollInfo.PageDown implementation.
PageLeft | IScrollInfo.PageLeft implementation.
PageRight | IScrollInfo.PageRight implementation.
PageUp | IScrollInfo.PageUp implementation.
SetHorizontalOffset | IScrollInfo.SetHorizontalOffset implementation.
SetVerticalOffset | IScrollInfo.SetVerticalOffset implementation.

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnItemsChanged | VirtualizingPanel.OnItemsChanged override.

See Also

TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ArrangeOverride Method

TreeGridVirtualPanel.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.LineDown Method

TreeGridVirtualPanel.LineDown Method
[image]

IScrollInfo.LineDown implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void LineDown ()

Visual Basic [image] Copy Code

Public Sub LineDown ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.LineLeft Method

TreeGridVirtualPanel.LineLeft Method
[image]

IScrollInfo.LineLeft implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void LineLeft ()

Visual Basic [image] Copy Code

Public Sub LineLeft ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.LineRight Method

TreeGridVirtualPanel.LineRight Method
[image]

IScrollInfo.LineRight implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void LineRight ()

Visual Basic [image] Copy Code

Public Sub LineRight ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.LineUp Method

TreeGridVirtualPanel.LineUp Method
[image]

IScrollInfo.LineUp implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void LineUp ()

Visual Basic [image] Copy Code

Public Sub LineUp ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MakeVisible Method

TreeGridVirtualPanel.MakeVisible Method
[image]

IScrollInfo.MakeVisible implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Rect MakeVisible (
Visual visual,
Rect rectangle
)

Visual Basic [image] Copy Code

Public Function MakeVisible( _
visual As Visual, _
rectangle As Rect _
) As Rect

Parameters

visual
A Visual that becomes visible.
rectangle
A bounding rectangle that identifies the coordinate space to make visible.

Return Value

A Rect that is visible.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MeasureOverride Method

TreeGridVirtualPanel.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize
The available size that this element can give to child elements.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MouseWheelDown Method

TreeGridVirtualPanel.MouseWheelDown Method
[image]

IScrollInfo.MouseWheelDown implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void MouseWheelDown ()

Visual Basic [image] Copy Code

Public Sub MouseWheelDown ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MouseWheelLeft Method

TreeGridVirtualPanel.MouseWheelLeft Method
[image]

IScrollInfo.MouseWheelLeft implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void MouseWheelLeft ()

Visual Basic [image] Copy Code

Public Sub MouseWheelLeft ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MouseWheelRight Method

TreeGridVirtualPanel.MouseWheelRight Method
[image]

IScrollInfo.MouseWheelRight implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void MouseWheelRight ()

Visual Basic [image] Copy Code

Public Sub MouseWheelRight ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.MouseWheelUp Method

TreeGridVirtualPanel.MouseWheelUp Method
[image]

IScrollInfo.MouseWheelUp implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void MouseWheelUp ()

Visual Basic [image] Copy Code

Public Sub MouseWheelUp ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.OnItemsChanged Method

TreeGridVirtualPanel.OnItemsChanged Method
[image]

VirtualizingPanel.OnItemsChanged override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void OnItemsChanged (
Object sender,
ItemsChangedEventArgs args
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnItemsChanged( _
sender As Object, _
args As ItemsChangedEventArgs _
)

Parameters

sender
The Object that raised the event.
args
Provides data for the ItemContainerGenerator.ItemsChanged event.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.PageDown Method

TreeGridVirtualPanel.PageDown Method
[image]

IScrollInfo.PageDown implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void PageDown ()

Visual Basic [image] Copy Code

Public Sub PageDown ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.PageLeft Method

TreeGridVirtualPanel.PageLeft Method
[image]

IScrollInfo.PageLeft implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void PageLeft ()

Visual Basic [image] Copy Code

Public Sub PageLeft ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.PageRight Method

TreeGridVirtualPanel.PageRight Method
[image]

IScrollInfo.PageRight implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void PageRight ()

Visual Basic [image] Copy Code

Public Sub PageRight ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.PageUp Method

TreeGridVirtualPanel.PageUp Method
[image]

IScrollInfo.PageUp implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void PageUp ()

Visual Basic [image] Copy Code

Public Sub PageUp ()

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.SetHorizontalOffset Method

TreeGridVirtualPanel.SetHorizontalOffset Method
[image]

IScrollInfo.SetHorizontalOffset implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void SetHorizontalOffset (
double offset
)

Visual Basic [image] Copy Code

Public Sub SetHorizontalOffset( _
offset As Double _
)

Parameters

offset
The degree to which content is horizontally offset from the containing viewport.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.SetVerticalOffset Method

TreeGridVirtualPanel.SetVerticalOffset Method
[image]

IScrollInfo.SetVerticalOffset implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public void SetVerticalOffset (
double offset
)

Visual Basic [image] Copy Code

Public Sub SetVerticalOffset( _
offset As Double _
)

Parameters

offset
The degree to which content is vertically offset from the containing viewport.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel Properties

TreeGridVirtualPanel Properties
[image]

Public Properties

Name | Description
CanHorizontallyScroll | IScrollInfo.CanHorizontallyScroll implementation.
CanVerticallyScroll | IScrollInfo.CanVerticallyScroll implementation.
ExtentHeight | IScrollInfo.ExtentHeight implementation.
ExtentWidth | IScrollInfo.ExtentWidth implementation.
HorizontalOffset | IScrollInfo.HorizontalOffset implementation.
ScrollOwner | IScrollInfo.ScrollOwner implementation.
VerticalOffset | IScrollInfo.VerticalOffset implementation.
ViewportHeight | IScrollInfo.ViewportHeight implementation.
ViewportWidth | IScrollInfo.ViewportWidth implementation.

See Also

TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.CanHorizontallyScroll Property

TreeGridVirtualPanel.CanHorizontallyScroll Property
[image]

IScrollInfo.CanHorizontallyScroll implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool CanHorizontallyScroll { get; set; }

Visual Basic [image] Copy Code

Public Property CanHorizontallyScroll As Boolean

Property Value

true if scrolling is possible; otherwise, false.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.CanVerticallyScroll Property

TreeGridVirtualPanel.CanVerticallyScroll Property
[image]

IScrollInfo.CanVerticallyScroll implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool CanVerticallyScroll { get; set; }

Visual Basic [image] Copy Code

Public Property CanVerticallyScroll As Boolean

Property Value

true if scrolling is possible; otherwise, false.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ExtentHeight Property

TreeGridVirtualPanel.ExtentHeight Property
[image]

IScrollInfo.ExtentHeight implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ExtentHeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ExtentHeight As Double

Property Value

A double that represents, in device independent pixels, the vertical size of the extent.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ExtentWidth Property

TreeGridVirtualPanel.ExtentWidth Property
[image]

IScrollInfo.ExtentWidth implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ExtentWidth { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ExtentWidth As Double

Property Value

A double that represents, in device independent pixels, the horizontal size of the extent.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.HorizontalOffset Property

TreeGridVirtualPanel.HorizontalOffset Property
[image]

IScrollInfo.HorizontalOffset implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HorizontalOffset As Double

Property Value

A double that represents, in device independent pixels, the horizontal offset.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ScrollOwner Property

TreeGridVirtualPanel.ScrollOwner Property
[image]

IScrollInfo.ScrollOwner implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public ScrollViewer ScrollOwner { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOwner As ScrollViewer

Property Value

A ScrollViewer element that controls scrolling behavior.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.VerticalOffset Property

TreeGridVirtualPanel.VerticalOffset Property
[image]

IScrollInfo.VerticalOffset implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double VerticalOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VerticalOffset As Double

Property Value

A double that represents, in device independent pixels, the vertical offset of the scrolled content.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ViewportHeight Property

TreeGridVirtualPanel.ViewportHeight Property
[image]

IScrollInfo.ViewportHeight implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ViewportHeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ViewportHeight As Double

Property Value

A double that represents, in device independent pixels, the vertical size of the viewport for this content.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeGridVirtualPanel.ViewportWidth Property

TreeGridVirtualPanel.ViewportWidth Property
[image]

IScrollInfo.ViewportWidth implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double ViewportWidth { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ViewportWidth As Double

Property Value

A double that represents, in device independent pixels, the horizontal size of the viewport for this content.

See Also

TreeGridVirtualPanel Members
TreeGridVirtualPanel Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Class

TreeNode Class
[image]

Represents an item in a TreeGrid control.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TreeNode : HeaderedItemsControl

Visual Basic [image] Copy Code

Public Class TreeNode
Inherits HeaderedItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.HeaderedItemsControl
MindFusion.DataViews.Wpf.TreeNode

See Also

TreeNode Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Members

TreeNode Members
Constructors Fields Attached Properties Properties Methods Events
[image]

Represents an item in a TreeGrid control.

The following tables list the members exposed by the TreeNode type.

Public Constructors

Name | Description
TreeNode | Initializes a new instance of the TreeNode class.

Public Fields

Name | Description
CanExpandProperty | Identifies the CanExpand dependency property.
CollapsedEvent | Identifies the Collapsed routed event.
ExpandedEvent | Identifies the Expanded routed event.
IndentProperty | Identifies the Indent attached property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Public Attached Properties

Name | Description
IndentProperty | Gets or sets a value that represents the distance between the left side of a TreeNode and its parent.

Public Properties

Name | Description
CanExpand | Gets or sets a value indicating whether the tree node can be expanded interactively. This is a dependency property.
Indent | Gets or sets the indentation of this tree node.
IsExpanded | Gets or sets a value indicating whether this tree node is expanded. This is a dependency property.

Public Methods

Name | Description
GetIndent | Sets the value of the TreeNode.Indent attached property for a given dependency object.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetIndent | Gets the value of the TreeNode.Indent attached property for a given dependency object.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
MeasureOverride | Control.MeasureOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
Collapsed | Occurs when the tree node is collapsed either programmatically or interactively.
Expanded | Occurs when the tree node is expanded either programmatically or interactively.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Fields

TreeNode Fields
[image]

Public Fields

Name | Description
CanExpandProperty | Identifies the CanExpand dependency property.
CollapsedEvent | Identifies the Collapsed routed event.
ExpandedEvent | Identifies the Expanded routed event.
IndentProperty | Identifies the Indent attached property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.CanExpandProperty Field

TreeNode.CanExpandProperty Field
[image]

Identifies the CanExpand dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanExpandProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanExpandProperty As DependencyProperty

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.CollapsedEvent Field

TreeNode.CollapsedEvent Field
[image]

Identifies the Collapsed routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent CollapsedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly CollapsedEvent As RoutedEvent

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.ExpandedEvent Field

TreeNode.ExpandedEvent Field
[image]

Identifies the Expanded routed event.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ExpandedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandedEvent As RoutedEvent

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.IndentProperty Field

TreeNode.IndentProperty Field
[image]

Identifies the Indent attached property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IndentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IndentProperty As DependencyProperty

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.IsExpandedProperty Field

TreeNode.IsExpandedProperty Field
[image]

Identifies the IsExpanded dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Constructor

TreeNode Constructor
[image]

Initializes a new instance of the TreeNode class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TreeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Methods

TreeNode Methods
[image]

Public Methods

Name | Description
GetIndent | Sets the value of the TreeNode.Indent attached property for a given dependency object.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetIndent | Gets the value of the TreeNode.Indent attached property for a given dependency object.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
ClearContainerForItemOverride | ItemsControl.ClearContainerForItemOverride override.
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
MeasureOverride | Control.MeasureOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.ArrangeOverride Method

TreeNode.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.ClearContainerForItemOverride Method

TreeNode.ClearContainerForItemOverride Method
[image]

ItemsControl.ClearContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void ClearContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub ClearContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

The container element.

item

The item.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.GetContainerForItemOverride Method

TreeNode.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.GetIndent Method

TreeNode.GetIndent Method
[image]

Sets the value of the TreeNode.Indent attached property for a given dependency object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static double GetIndent (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetIndent( _
target As DependencyObject _
) As Double

Parameters

target

The target object.

Return Value

The value of the Indent property for the specified object.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.IsItemItsOwnContainerOverride Method

TreeNode.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.MeasureOverride Method

TreeNode.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

Return Value

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.OnApplyTemplate Method

TreeNode.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.PrepareContainerForItemOverride Method

TreeNode.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.SetIndent Method

TreeNode.SetIndent Method
[image]

Gets the value of the TreeNode.Indent attached property for a given dependency object.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public static void SetIndent (
DependencyObject target,
double value
)

Visual Basic [image] Copy Code

Public Shared Sub SetIndent( _
target As DependencyObject, _
value As Double _
)

Parameters

target

The target object.

value

The new property value.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Attached Properties

TreeNode Attached Properties
[image]

Public Attached Properties

Name | Description
IndentProperty | Gets or sets a value that represents the distance between the left side of a TreeNode and its parent.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.Indent Attached Property

TreeNode.Indent Attached Property
[image]

Gets or sets a value that represents the distance between the left side of a TreeNode and its parent.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code
See TreeNode.GetIndent, TreeNode.SetIndent
Visual Basic [image] Copy Code
See TreeNode.GetIndent, TreeNode.SetIndent

Property Value

A double that represents the offset position from the TreeNode. The default is 0.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Properties

TreeNode Properties
[image]

Public Properties

Name | Description
CanExpand | Gets or sets a value indicating whether the tree node can be expanded interactively. This is a dependency property.
Indent | Gets or sets the indentation of this tree node.
IsExpanded | Gets or sets a value indicating whether this tree node is expanded. This is a dependency property.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.CanExpand Property

TreeNode.CanExpand Property
[image]

Gets or sets a value indicating whether the tree node can be expanded interactively. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool CanExpand { get; set; }

Visual Basic [image] Copy Code

Public Property CanExpand As Boolean

Property Value

true if this item can be expanded; otherwise, false.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.Indent Property

TreeNode.Indent Property
[image]

Gets or sets the indentation of this tree node.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public double Indent { get; set; }

Visual Basic [image] Copy Code

Public Property Indent As Double

Property Value

A double value specifying the indentation.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.IsExpanded Property

TreeNode.IsExpanded Property
[image]

Gets or sets a value indicating whether this tree node is expanded. This is a dependency property.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Public Property IsExpanded As Boolean

Property Value

true if the item is expanded; otherwise, false.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode Events

TreeNode Events
[image]

Public Events

Name | Description
Collapsed | Occurs when the tree node is collapsed either programmatically or interactively.
Expanded | Occurs when the tree node is expanded either programmatically or interactively.

See Also

TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.Collapsed Event

TreeNode.Collapsed Event
[image]

Occurs when the tree node is collapsed either programmatically or interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler Collapsed

Visual Basic [image] Copy Code

Public Event Collapsed As RoutedEventHandler

Event Data

Collapsed event handlers receive an argument of type RoutedEventArgs.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TreeNode.Expanded Event

TreeNode.Expanded Event
[image]

Occurs when the tree node is expanded either programmatically or interactively.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler Expanded

Visual Basic [image] Copy Code

Public Event Expanded As RoutedEventHandler

Event Data

Expanded event handlers receive an argument of type RoutedEventArgs.

See Also

TreeNode Members
TreeNode Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TypeActivator Class

TypeActivator Class
[image]

Represents an IActivator that creates objects from a type through reflection.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class TypeActivator : IActivator

Visual Basic [image] Copy Code

Public Class TypeActivator
Implements IActivator

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.TypeActivator

See Also

TypeActivator Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TypeActivator Members

TypeActivator Members
Constructors Methods
[image]

Represents an IActivator that creates objects from a type through reflection.

The following tables list the members exposed by the TypeActivator type.

Public Constructors

Name | Description
TypeActivator | Initializes a new instance of the TypeActivator class.

Public Methods

Name | Description
CreateInstance | Creates an instance of the underlying type.

See Also

TypeActivator Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TypeActivator Constructor

TypeActivator Constructor
[image]

Initializes a new instance of the TypeActivator class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public TypeActivator (
Type type
)

Visual Basic [image] Copy Code

Public New ( _
type As Type _
)

Parameters

type

The type of the objects to create.

See Also

TypeActivator Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TypeActivator Methods

TypeActivator Methods
[image]

Public Methods

Name | Description
CreateInstance | Creates an instance of the underlying type.

See Also

TypeActivator Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.TypeActivator.CreateInstance Method

TypeActivator.CreateInstance Method
[image]

Creates an instance of the underlying type.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Object CreateInstance ()

Visual Basic [image] Copy Code

Public Function CreateInstance () As Object

Return Value

The created instance.

See Also

TypeActivator Members
TypeActivator Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.DataViews.Wpf.UndoEventArgs

See Also

UndoEventArgs Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

UndoEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoState Class

UndoState Class
[image]

Encapsulates the state of an object for subsequent undo operations.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public abstract class UndoState : IEquatable<UndoState>

Visual Basic [image] Copy Code

Public MustInherit Class UndoState
Implements IEquatable(Of UndoState)

Inheritance Hierarchy

System.Object
MindFusion.DataViews.Wpf.UndoState
MindFusion.DataViews.Wpf.ActivityState
MindFusion.DataViews.Wpf.DependencyState
MindFusion.DataViews.Wpf.ResourceAllocationState
MindFusion.DataViews.Wpf.ResourceState

See Also

UndoState Members
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoState Members

UndoState Members
Constructors Methods
[image]

Encapsulates the state of an object for subsequent undo operations.

The following tables list the members exposed by the UndoState type.

Protected Constructors

Name | Description
UndoState | Initializes a new instance of the UndoState class.

Public Methods

Name | Description
Equals | IEquatable<T>.Equals implementation.

See Also

UndoState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoState Constructor

UndoState Constructor
[image]

Initializes a new instance of the UndoState class.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

protected UndoState ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

UndoState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoState Methods

UndoState Methods
[image]

Public Methods

Name | Description
Equals | IEquatable<T>.Equals implementation.

See Also

UndoState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.DataViews.Wpf.UndoState.Equals Method

UndoState.Equals Method
[image]

IEquatable<T>.Equals implementation.

Namespace: MindFusion.DataViews.Wpf
Assembly: MindFusion.DataViews.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
UndoState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As UndoState _
) As Boolean

Parameters

other

An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

UndoState Members
UndoState Class
MindFusion.DataViews.Wpf Namespace


MindFusion.Diagramming.Wpf Namespace

MindFusion.Diagramming.Wpf Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AdjustmentHandle | Represents an adjustment handle used to move or modify diagram items.
AdornerVisual | Visual that contains the adjustment handles for a diagram item. It is separate from DiagramItem so that the adjustment handles do not interfere with item geometry during intersection with visual geometry.
AeroEffect | Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.
AnchorPattern | Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | Specifies the locations in a node, to which the user is allowed to connect links.
AnchorPointCollection | Represents a strongly typed collection of anchor points.
AnchorPointEventArgs | Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.
ArcTemplate | Represents an arc in a shape definition.
AreaEventArgs | Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.
ArrowHeads | Contains predefined arrowhead shapes.
BarcodeNode | Represents nodes that can encode and render barcodes.
BarcodeNodeProperties | Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.
BezierTemplate | Represents a Bézier curve in a shape definition.
CellEventArgs | Contains the arguments passed to event handlers, such as CellClicked.
CellValidationEventArgs | Contains the arguments passed to event handlers, such as CellTextEditing.
CollectionBase(T) | An implementation of the IList<T> interface.
CommandHistory | Maintains a queue of Command records used to undo or redo actions.
ConnectionPoint | This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.
Constants | Contains various global constants, also provides measure unit independent constants.
ContainerChildEventArgs | Contains arguments passed to ContainerChildEventHandler,
ContainerNode | Implements nodes that can contain other nodes.
ContainerNodeProperties | Stores the values of ContainerNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the ContainerNode.SaveProperties, ContainerNode.RestoreProperties, and ContainerNode.CreateProperties methods.
ContentCollection | Implements the Diagram.Content property, which allow defining diagram elements through XAML.
ControlNodeEventArgs | Contains the arguments passes to handlers of the control host serialization events.
ControlPointEventArgs | Contains arguments passed to handlers of the ShapeModified event.
ControlVisibilityConverter | Converts boolean property values to Visibility values.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
CopyHostedControlEventArgs | Contains the arguments passes to the CopyHostedControl event handlers.
CustomCursors | Provides a collection of cursor object to use with the Diagram control.
Diagram | The Diagram control lets you create and visualize flow diagrams, representing hierarchical or relational data by means of graph nodes and links.
DiagramBase | The base class of the Diagram and DiagramDocument classes.
DiagramDocument | Represents a collection of diagram pages.
DiagramDocumentPaginator | Implements pagination of a DiagramDocument object.
DiagramEventArgs | Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramItemCollection | Represents a strongly typed collection of DiagramItem objects.
DiagramItemProperties | The base class for classes that store diagram item properties during undo / redo operations.
DiagramItemState | Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.
DiagramLink | Represents a link between two diagram nodes.
DiagramLinkCollection | Represents a strongly typed collection of DiagramLink objects.
DiagramLinkProperties | Stores the values of DiagramLink properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the DiagramLink.SaveProperties, DiagramLink.RestoreProperties, and DiagramLink.CreateProperties methods.
DiagramLinkState | Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the DiagramLink.CreateState, DiagramLink.SaveState and DiagramLink.RestoreState methods.
DiagramNode | Represents a diagram node.
DiagramNodeAdapter | DiagramNodeAdapter is an adapter class that enables using any UIElement -derived object as a diagram node.
DiagramNodeCollection | Represents a strongly typed collection of diagram nodes.
DiagramNodeProperties | The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.
DiagramNodeState | Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the DiagramNode.CreateState, DiagramNode.SaveState and DiagramNode.RestoreState methods.
DiagramPage | Represents a single page in a DiagramDocument object.
DiagramPageEventArgs | Contains the arguments passed to DiagramPage-related event handlers.
DiagramPageValidationEventArgs | Contains the arguments passed to handlers of DiagramPage validation events.
DiagramPaginator | Implements pagination of a Diagram document.
DiagramTabControl | Represents a TabControl that displays DiagramTabItem items.
DiagramTabItem | Represents a tab item in a DiagramTabControl.
DiagramView | DiagramView allows displaying more than one views of the content of the same Diagram instance.
DiagramView3D | Displays the elements of a Diagram in 3D space.
DoubleToRectConverter | Converts double values to Rect structures.
DraggedNode | Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.
DraggedShape | Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.
DrawAnchorPointEventArgs | Contains the arguments passed to the DrawAnchorPoint event handlers.
DrawCellEventArgs | Contains the arguments passed to the DrawCell event handlers.
DrawItemEventArgs | Contains the arguments passed to the DrawAdjustmentHandles event handlers.
DrawLinkEventArgs | Contains the arguments passed to the DrawLink event handlers.
DrawNodeEventArgs | Contains the arguments passed to the DrawNode event handlers.
DummyNode | Represents virtual nodes used for disconnected links.
EditCellTextEventArgs | Contains the arguments passed to the CellTextEdited event handlers.
EditLinkTextEventArgs | Contains the arguments passed to the EditLinkTextEventArgs event handlers.
EditNodeTextEventArgs | Contains the arguments passed to the NodeTextEdited event handlers.
ElementTemplate | Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.
Factory | Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for WPF item types. Call the class methods through the Factory property of the Diagram class.
Font | Replacement for System.Drawing.Font that does not reference System.Drawing.dll
FreeFormHandle | Represents an adjustment handle used to modify the outline of a FreeFormNode.
FreeFormNode | A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.
GlassEffect | Represents a glass-like visual effect.
GraphicsUnit | Specifies units of measure for a particular data.
GridRouter | Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.
Group | Represents a group of items in the diagram document.
Group.Attachment | Encapsulates attachment information.
GroupCollection | Represents a strongly typed collection of Group objects.
GroupEventArgs | Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.
HandlesVisualStyle | Defines the Pen and Brush objects used to draw items' adjustment handles.
HatchBrush | Emulates GDI+ hatch brushes using the WPF ImageBrush class.
HitTestEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
HtmlBuilder | Provides methods to create and use HTML client side image maps.
InPlaceEditEventArgs | Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.
InstantiateItemEventArgs | Contains the arguments passed to the InstantiateItem event handlers.
Interaction | Tracks mouse messages to implement user interaction with the diagram.
InteractionState | Encapsulates the current state of user interaction with the control.
InternalUtils | Contains common helper methods, specific to MindFusion.Diagramming for WPF.
ItemCollectionBase(T) | A base collection class for the diagram item collections.
ItemEventArgs | Contains the arguments passed to item instantiation event handlers.
Layer | Represents a layer in a Diagram object.
LayerListView | Represents a list box with MindFusion.Diagramming.Wpf.Layer objects.
LineTemplate | Represents a line segment in a shape definition.
LinkAdjustmentHandle | Represents an adjustment handle used to modify the position of a link's control point.
LinkEventArgs | Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.
LinkLabel | Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.
LinkShapeEventArgs | Contains the arguments passed to the SetSelfLoopShape event handler.
LinkTo | A helper class that provides attached properties for connecting a link to nodes from Xaml.
LinkValidationEventArgs | Contains the arguments passed to handlers of link validation events.
Magnifier | Represents a magnifying tool.
Manipulator | Base class for interactive manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.
ModifierKeyActions | Maps keyboard modifier keys to special actions in WpfDiagram such as panning and drawing selection rectangle.
NodeAdjustmentHandle | Represents an adjustment handle used to move, resize or rotate a node.
NodeConstraints | Defines specific constraints that can be applied to the size and location of nodes.
NodeEffect | Represents the base class of all visual effects that can be applied to the nodes in a Diagram.
NodeEventArgs | Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.
NodeListView | NodeListView is a toolbox alike control. It displays a list of node templates, and lets user create new nodes based on these templates by drag-and-drop. NodeListView can contain instances of any DiagramNode or UIElement derived classes.
NodeRenderer | Renders diagram nodes in their standard appearance. This element can be included in Xaml template of a node class to render node's standard graphics before any additional WPF elements defined by the template.
NodesAlignedEventArgs | Contains the arguments passed to handlers of the NodesAligned event.
NodeValidationEventArgs | Contains the arguments passed to handlers of node validation events.
NotATreeException | An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.
ObjectToBooleanConverter | For internal use.
Overview | The Overview control provides a scaled-down view of a Diagram and allows scrolling and zooming the diagram with the mouse.
PageRenamedEventArgs | Contains arguments for the PageRenamed event.
Path | Represents a sequence of connected DiagramNode and DiagramLink elements.
PathCollection | Represents a strongly typed collection of Path objects.
PathFinder | Provides methods that help you find paths and cycles in a graph.
PointCollection | Represents a strongly typed collection of points.
PrintOptions | Provides properties that allow customization of various aspects of printing and print-preview.
QuickRouter | Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.
ReadOnlyCollection(T) | Represents a read-only wrapper of a collection.
ReadOnlyDiagramItemCollection | Represents a read-only collection of items.
ReadOnlyDiagramLinkCollection | Represents a read-only collection of links.
ReadOnlyDiagramNodeCollection | Represents a read-only collection of nodes.
RelativePosition | Represents relative positions inside diagram elements.
RenderOptions | Provides properties that allow customization of various aspects of printing and print-preview.
RepaintEventArgs | Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.
RoundRectangleTemplate | Represents an ElementTemplate that draws round rectangle.
RoutingOptions | Allows customization of various aspects of the link routing algorithm.
RowEventArgs | Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.
Ruler | The Ruler control provides horizontal and vertical scales that help users measure diagram items.
ScriptHelper | Allows calling some static MindFusion.Diagramming for WPF methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.
Selection | Represents a set of items selected in the diagram document.
SelectionCopy | Used internally in the implementation of copy/paste functions.
SelectionEventArgs | Contains the arguments passed to the SelectionModified event handler.
SelectionValidationEventArgs | Contains the arguments passed to the SelectionModifying event handler.
SerializationOptions | Allows customization of some aspects of the binary serialization of MindFusion.Diagramming for WPF diagrams.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bezier segments. Such shapes can be assigned to ShapeNode ojects or used as link arrowheads. The shape segments can be a part of the outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeAdjustmentHandle | Represents an adjustment handle used to modify the Shape of a ShapeNode.
ShapeCollection | Represents a read-only collection of shapes.
ShapeControlPoint | Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.
ShapeConverter | Converts from Shape to other data types.
ShapeData | Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.
ShapeDecoration | Defines decoration elements that are displayed as filled shapes.
ShapeDesigner | Represents an interactive vector-drawing control that can be used to design node shapes.
ShapeDesignerCanvas | Represents the drawing canvas of a ShapeDesigner control.
ShapeDesignerPropertyPanel | ShapeDesignerPropertyPanel
ShapeEventArgs | Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.
ShapeFormulaParam | Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.
ShapeLibrary | The ShapeLibrary class represents a collection of shape definitions stored together.
ShapeListBox | The ShapeListBox control displays a set of shapes defined via the Shape class.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
ShapeNodeProperties | Stores the values of ShapeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the ShapeNode.SaveProperties, ShapeNode.RestoreProperties, and ShapeNode.CreateProperties methods.
ShapeNodeState | Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.
Shapes | Provides alternative method of access to the MindFusion.Diagramming for WPF predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.
StringFormat | Replaces System.Drawing.StringFormat
TabbedDiagramView | Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.
TableConnectionPoint | Represents a connection between a link and a table node.
TableNode | Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.
TableNode.Cell | Represents a cell in a TableNode instance.
TableNode.CellCollection | Represents a strongly-typed collection of TableNode.Cell objects.
TableNode.Column | Represents a column of a TableNode.
TableNode.ColumnCollection | Represents a strongly-typed collection of TableNode.Column objects.
TableNode.Row | Represents a row in TableNode node.
TableNode.RowCollection | Represents a strongly-typed collection of TableNode.Row objects.
TableNodeProperties | Stores the values of TableNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the TableNode.SaveProperties, TableNode.RestoreProperties, and TableNode.CreateProperties methods.
TemplatedNode | The TemplatedNode class represents nodes whose appearance is set through Xaml data templates.
TextAttributes | Defines attributes of text content displayed by diagram items.
TextPresenter | Implements a container for text content and defines text attributes.
Theme | Represents a set of Style objects for different diagram item types.
TreeEnumerator | Enables an easy standard method to itereate over the elements of a tree-like structure of objects.
TreeItemEventArgs | Contains the arguments passed to handlers of TreeViewItem-related events.
TreeItemValidationEventArgs | Contains the arguments passed to event handlers, such as TreeItemTextEditing.
TreeViewConnectionPoint | Represents a connection between a link and a TreeViewNode.
TreeViewItem | Represents a constituent item of the hierarchy displayed inside a TreeViewNode.
TreeViewNode | Represents nodes that can draw hierarchical data.
UndoEventArgs | Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.
UndoManager | Implements undo/redo functionality in MindFusion.Diagramming for WPF.
UndoValidationEventArgs | Contains the arguments passed to the ActionRecording event handlers.
VirtualizingDiagram | Implements virtualization of diagram elements.
VirtualLinkEventArgs | Contains arguments passed to handlers of the LinkRealized event.
VirtualNodeEventArgs | Contains arguments passed to handlers of the NodeRealized event.
VisioContent | Represents the content of a VisioNode.
VisioNode | Represents a node that can display shapes from Visio stencils.
VisioNodeProperties | Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.
VisioStencil | Represents a Visio stencil.
VisualBrushPaginator | Implements pagination of a Diagram document.
XmlConvert | Provides capabilities to convert various types to and from strings in a cutlure-independent way.
XmlOptions | Defines properties used to customize the XML serialization process.
XmlPersistContext | Contains methods that can help you serialize and deserialize MindFusion.Diagramming for WPF items to end from XML documents.

Interfaces

Interface | Description
IItemFactory | Defines an interface for constructing IPersists objects.
ILinkRouter | Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.
InplaceEditable | Represents an in-place editable object.
ITextAttributes | Defines attributes of text content displayed by diagram items.

Delegates

Delegate | Description
CreateImageCallback | Loads an image from a stream.
CreatePathDelegate | Specifies the signature of callback functions used to generate dynamic node shapes.
GetManipulatorRect | Returns the manipulator position for a given node.
InstantiateLink | Represent a method that creates actual DiagramLink objects to represent data items on screen.
InstantiateLinkData | Represents a method that instantiates data items for links drawn by the user.
InstantiateNode | Represent a method that creates actual DiagramNode -derived objects to represent data items on screen.
InstantiateNodeData | Represents a method that instantiates data items for nodes drawn by the user.
ResolveContainer | Represents a method that determines a node's container.
ResolveNodePosition | Represents a method that determines the position of a data item within the diagram.

Enumerations

Enumeration | Description
Action | Specifies the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Alignment | Generalized alignment enum.
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
AttachTo | Specifies the type of attachment in a group.
AttachToLink | Specifies the possible ways to attach a node to a link.
AttachToNode | Defines values specifying the possible ways to attach a node to another node.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CameraType | Specifies the type of camera projection.
CellFrameStyle | Specifies the style of the cells' frame lines.
ColumnStyle | Specifies how table columns' width is set.
ContainmentKeys | For internal use.
ControlMouseAction | Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.
CursorHint | Specifies what mouse cursor to display while a user interacts with the diagram.
CustomDraw | Specifies what kind of custom painting to perform on diagram elements.
DelKeyAction | Specifies the type of action performed when the user presses the DEL key.
DirectionConstraint | Defines values that specify in what direction to constrain node movement.
ExpandButtonAction | Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.
ExpandButtonPosition | Defines values that specify possible locations for expand/collapse buttons.
FitSize | Specifies how the ResizeToFitText method should resize a node.
GlassEffectType | Specifies the type of a GlassEffect node effect.
Granularity | Specifies the granularity of the obstacles map generated by QuickRouter.
GridStyle | Defines values that specify the visual style of the alignment grid.
GroupAnchorStyles | Specifies the master node edges to which a subordinate node can be anchored.
GroupRotation | Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.
HandlesStyle | Enumerates possible visual styles for frames that are drawn around selected nodes.
HatchStyle | Represents hatch patterns corresponding to GDI+ HatchBrush objects.
HitTestPriority | Defines values that specify the order of item hit-testing.
HotkeyPrefix | Replaces System.Drawing.Text.HotkeyPrefix
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
ImageAlign | Specifies the position and alignment of a picture in a node or table, or that of the background image.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkShape | Specifies available link shapes.
LinkTextStyle | Specifies the position and alignment of links' labels.
MarkStyle | Specifies the visual style of anchor point marks.
ModificationEffect | Specifies the visual effect to apply during interactive modification of items.
ModificationStart | Specifies how the user can start modifying an item.
ModifierKeyAction | Defines the actions that can be assigned to a modifier key such as CTRL or ALT.
MouseButton | Specifies constants that define which mouse button was pressed.
MouseButtonActions | Specifies what actions can be associated with the middle and right mouse buttons.
MouseInputMode | Contains values that identify how to process mouse input.
NodeHandleType | Identifies the types of selection handles of a node.
NodeRotationType | Specifies whether nodes should rotate to face the camera in DiagramView3D.
Orientation | Defines values that specify the orientation of the first segment of cascading links.
Relationship | Specifies the type of relationship between two tables.
RelativeToLink | Specifies how the link labels are positioned.
RenderTarget | Specifies where the diagram is being rendered.
RerouteLinks | Provides values indicating in what circumstances links must be rerouted automatically.
RestrictToBounds | Specifies the restriction of the position of an object as to the document extents.
RulerUnit | Specifies a measurement unit for the Ruler.
SaveToStringFormat | Specifies in what format to save the diagram when generating a string using the SaveToString method.
ScaleMode | Defines Overview scaling modes.
ScalingMode | Specifies whether 3D models of links should scale when the camera zooms in or out.
SelectionStyle | Defines values that specify how multiple selected items are indicated visually.
ShadowsStyle | Enumerates possible shadows-drawing styles.
ShowAnchors | Specifies when anchors points should be displayed.
SimpleShape | Defines the possible values for the Shape property of tables, tree views and containers.
SizeSyncMode | Contains values that identify the possible ways to synchronize the size of a DiagramNodeAdapter node with the size of its hosted control.
SnapToAnchor | Specifies when link ends are snapped to nearest anchor points.
StringAlignment | Replaces System.Drawing.StringAlignment
StringFormatFlags | Replaces System.Drawing.StringFormatFlags
StringTrimming | Replaces System.Drawing.StringTrimming
TableConnectionStyle | Specifies the possible values for the ConnectionStyle property of tables.
TreeViewConnectionStyle | Specifies the possible values for the ConnectionStyle property of TreeViewNodes.
UnitType | Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.


MindFusion.Diagramming.Wpf.Action Enumeration

Action Enumeration
[image]

Specifies the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Action

Visual Basic [image] Copy Code

Public Enum Action

Members

Member name | Description
Create | Draw a new item.
Modify | Modify an existing item.
None | Do not perform any action.
Split | Split a link's segment.

Remarks

Members of this enumeration are used as parameters of the InteractionState constructor.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandle Class

AdjustmentHandle Class
Remarks See Also
[image]

Represents an adjustment handle used to move or modify diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AdjustmentHandle

Visual Basic [image] Copy Code

Public Class AdjustmentHandle

Remarks

Instances of this class are returned by the HitTestHandle method, and are subsequently used to identify the currently dragged handle in InteractionState and methods that implement modification. Current subclasses include NodeAdjustmentHandle used to move and resize nodes, LinkAdjustmentHandle used to move link control points, ShapeAdjustmentHandle used to modify Shape formula parameters, and FreeFormHandle used to modify outline points of FreeFormNodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AdjustmentHandle
MindFusion.Diagramming.Wpf.FreeFormHandle
MindFusion.Diagramming.Wpf.LinkAdjustmentHandle
MindFusion.Diagramming.Wpf.NodeAdjustmentHandle
MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle

See Also

AdjustmentHandle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandle Members

AdjustmentHandle Members
Constructors Methods
[image]

Represents an adjustment handle used to move or modify diagram items.

The following tables list the members exposed by the AdjustmentHandle type.

Public Constructors

Name | Description
AdjustmentHandle | Initializes a new instance of the AdjustmentHandle class.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items.

See Also

AdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandle Constructor

AdjustmentHandle Constructor
[image]

Initializes a new instance of the AdjustmentHandle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandle Methods

AdjustmentHandle Methods
[image]

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items.

See Also

AdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandle.IsMoveHandle Method

AdjustmentHandle.IsMoveHandle Method
[image]

Returns a value indicating whether this handle is used to move items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool IsMoveHandle ()

Visual Basic [image] Copy Code

Public Overridable Function IsMoveHandle () As Boolean

Return Value

true if this is a move handle, or false otherwise.

See Also

AdjustmentHandle Members
AdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AdjustmentHandles

Visual Basic [image] Copy Code

Public Enum AdjustmentHandles

Members

Member name | Description
All | All selection handles areenabled and canbe used to modify the node.
BottomHandles | The bottom-left, bottom-center and bottom-right handles are enabled.
CornerHandles | The four corner handles are enabled.
HeightHandles | All top and bottom handles are enabled.
LeftHandles | The top-left, middle-left and bottom-left handles are enabled.
MiddleHandles | The four middle handles are enabled.
Move | The center selection handle is enabled and can be used to move the node.
None | Specifies that none of the selection handles can be used to modify the node.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeHandles | The eight resize handles are enabled.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
RightHandles | The top-right, bottom-right and middle-right handles are enabled.
Rotate | The rotation handle is enabled and can be used to rotate the node.
TopHandles | The top-left, top-center and top-right handles are enabled.
WidthHandles | All left and right handles are enabled.

Remarks

A combination of these flags can be assigned to the EnabledHandles property of nodes.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual Class

AdornerVisual Class
[image]

Visual that contains the adjustment handles for a diagram item. It is separate from DiagramItem so that the adjustment handles do not interfere with item geometry during intersection with visual geometry.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AdornerVisual : UIElement

Visual Basic [image] Copy Code

Public Class AdornerVisual
Inherits UIElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
MindFusion.Diagramming.Wpf.AdornerVisual

See Also

AdornerVisual Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual Members

AdornerVisual Members
Properties Methods
[image]

Visual that contains the adjustment handles for a diagram item. It is separate from DiagramItem so that the adjustment handles do not interfere with item geometry during intersection with visual geometry.

The following tables list the members exposed by the AdornerVisual type.

Protected Properties

Name | Description
VisualChildrenCount | Visual.VisualChildrenCount override.

Protected Methods

Name | Description
GetVisualChild | Visual.GetVisualChild override.
MeasureCore | UIElement.MeasureCore override.
OnDragEnter | UIElement.OnDragEnter override.
OnDragLeave | UIElement.OnDragLeave override.
OnDragOver | UIElement.OnDragOver override.
OnDrop | UIElement.OnDrop override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnRender | UIElement.OnRender override.

See Also

AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual Methods

AdornerVisual Methods
[image]

Protected Methods

Name | Description
GetVisualChild | Visual.GetVisualChild override.
MeasureCore | UIElement.MeasureCore override.
OnDragEnter | UIElement.OnDragEnter override.
OnDragLeave | UIElement.OnDragLeave override.
OnDragOver | UIElement.OnDragOver override.
OnDrop | UIElement.OnDrop override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnRender | UIElement.OnRender override.

See Also

AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.GetVisualChild Method

AdornerVisual.GetVisualChild Method
[image]

Visual.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.MeasureCore Method

AdornerVisual.MeasureCore Method
[image]

UIElement.MeasureCore override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureCore (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureCore( _
availableSize As Size _
) As Size

Parameters

availableSize

Return Value

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnDragEnter Method

AdornerVisual.OnDragEnter Method
[image]

UIElement.OnDragEnter override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnDragEnter (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnDragEnter( _
e As DragEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnDragLeave Method

AdornerVisual.OnDragLeave Method
[image]

UIElement.OnDragLeave override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnDragLeave (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnDragLeave( _
e As DragEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnDragOver Method

AdornerVisual.OnDragOver Method
[image]

UIElement.OnDragOver override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnDragOver (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnDragOver( _
e As DragEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnDrop Method

AdornerVisual.OnDrop Method
[image]

UIElement.OnDrop override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnDrop (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnDrop( _
e As DragEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnMouseDown Method

AdornerVisual.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnMouseUp Method

AdornerVisual.OnMouseUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnPreviewMouseDown Method

AdornerVisual.OnPreviewMouseDown Method
[image]

UIElement.OnPreviewMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnPreviewMouseUp Method

AdornerVisual.OnPreviewMouseUp Method
[image]

UIElement.OnPreviewMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.OnRender Method

AdornerVisual.OnRender Method
[image]

UIElement.OnRender override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual Properties

AdornerVisual Properties
[image]

Protected Properties

Name | Description
VisualChildrenCount | Visual.VisualChildrenCount override.

See Also

AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AdornerVisual.VisualChildrenCount Property

AdornerVisual.VisualChildrenCount Property
[image]

Visual.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

AdornerVisual Members
AdornerVisual Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Class

AeroEffect Class
Remarks See Also
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class AeroEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class AeroEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.NodeEffect
MindFusion.Diagramming.Wpf.AeroEffect

See Also

AeroEffect Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Members

AeroEffect Members
Constructors Properties Methods Events
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

The following tables list the members exposed by the AeroEffect type.

Public Constructors

Name | Description
AeroEffect | Initializes a new instance of the AeroEffect class.

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Constructor

AeroEffect Constructor
[image]

Initializes a new instance of the AeroEffect class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AeroEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Methods

AeroEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect.Clone Method

AeroEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

The copy of this effect.

See Also

AeroEffect Members
AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Properties

AeroEffect Properties
[image]

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

See Also

AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect.InnerOutlineColor Property

AeroEffect.InnerOutlineColor Property
[image]

Gets or sets the color of the inner outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color InnerOutlineColor { get; set; }

Visual Basic [image] Copy Code

Public Property InnerOutlineColor As Color

Property Value

A Color object. The default is White.

See Also

AeroEffect Members
AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect.Opacity Property

AeroEffect.Opacity Property
[image]

Gets or sets the opacity to apply to the node's background.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Opacity { get; set; }

Visual Basic [image] Copy Code

Public Property Opacity As Double

Property Value

A float value.

Remarks

Opacity varies in the range [0..1] where 0 indicates full transparency and 1 indicates the original transparency. Opacity has no effect on image backgrounds.

See Also

AeroEffect Members
AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect.ShadeColor Property

AeroEffect.ShadeColor Property
[image]

Gets or sets the color of the shade.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color ShadeColor { get; set; }

Visual Basic [image] Copy Code

Public Property ShadeColor As Color

Property Value

A Color object. The default is Black.

See Also

AeroEffect Members
AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AeroEffect Events

AeroEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

AeroEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect.PropertyChanged Event

NodeEffect.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

NodeEffect Members
NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Alignment Enumeration

Alignment Enumeration
[image]

Generalized alignment enum.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Alignment

Visual Basic [image] Copy Code

Public Enum Alignment

Members

Member name | Description
Far | Specifies that the object is aligned at the origin position of the layout rectangle.
Near | Specifies that the object is aligned at the opposite side of the origin position of the layout rectangle.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Anchoring Enumeration

Anchoring Enumeration
[image]

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Anchoring

Visual Basic [image] Copy Code

Public Enum Anchoring

Members

Member name | Description
Ignore | Anchor points are ignored.
Keep | Links are aligned to their original anchor points.
Reassign | Links are aligned to new anchor points, depending on the positions of graph nodes after a layout is applied.

Remarks

Assign values of this enumeration to the Anchoring property of layout algorithms. Most algorithms produce best results if they can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also

MindFusion.Diagramming.Wpf Namespace
AnchorPattern Class
TreeLayout Class
GridLayout Class
LayeredLayout Class
SpringLayout Class


MindFusion.Diagramming.Wpf.AnchorPattern Class

AnchorPattern Class
Remarks See Also
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnchorPattern : ICloneable

Visual Basic [image] Copy Code

Public Class AnchorPattern
Implements ICloneable

Remarks

A pattern can be assigned as an integral entity to the AnchorPattern property of nodes. By default, when assigning a pattern to a node, a new copy of the pattern is created. Thus you can modify nodes' anchor patterns independently at runtime. However, if your anchor patterns won't change while the application executes, you can register them as shared to save storage space for the diagram. To do so, use AnchorPattern constructors that take a string id parameter. The AnchorPattern class exposes several predefined patterns as static properties; all of them are considered shared.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AnchorPattern

See Also

AnchorPattern Members
MindFusion.Diagramming.Wpf Namespace
AnchorPoint Class


MindFusion.Diagramming.Wpf.AnchorPattern Members

AnchorPattern Members
Constructors Properties Methods
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Overloaded. Intializes a new instance of the AnchorPattern class.

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor

AnchorPattern Constructor
[image]

Intializes a new instance of the AnchorPattern class.

Overload List

Name | Description
AnchorPattern () | Intializes a new empty instance of the AnchorPattern class.
AnchorPattern (AnchorPoint[]) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPoint[], String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection, String) | Intializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (String) | Intializes a new empty instance of the AnchorPattern class.

See Also

AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor ()

AnchorPattern Constructor ()
See Also
[image]

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor (AnchorPoint[])

AnchorPattern Constructor (AnchorPoint[])
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.

Example

The following code creates a decision node with two incoming anchors at the top and the left, and two outgoing at the bottom and the right vertices.

C# [image] Copy Code

AnchorPattern decision2In2Out =
new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, false, MarkStyle.Circle, Brushes.Blue),
new AnchorPoint(0, 50, true, false, MarkStyle.Circle, Brushes.Blue),
new AnchorPoint(50, 100, false, true, MarkStyle.Rectangle, Brushes.Green),
new AnchorPoint(100, 50, false, true, MarkStyle.Rectangle, Brushes.Red)
});

ShapeNode decisionNode = diagram.Factory.CreateShapeNode(10, 10, 50, 35);
decisionNode.AnchorPattern = decision2In2Out;

Visual Basic [image] Copy Code

Dim decision2In2Out As AnchorPattern = _
New AnchorPattern(New AnchorPoint() { _
New AnchorPoint(50, 0, True, False, MarkStyle.Circle, Brushes.Blue), _
New AnchorPoint(0, 50, True, False, MarkStyle.Circle, Brushes.Blue), _
New AnchorPoint(50, 100, False, True, MarkStyle.Rectangle, Brushes.Green), _
New AnchorPoint(100, 50, False, True, MarkStyle.Rectangle, Brushes.Red) _
})

Dim decisionNode As ShapeNode = diagram.Factory.CreateShapeNode(10, 10, 50, 35)
decisionNode.AnchorPattern = decision2In2Out

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor (AnchorPoint[], String)

AnchorPattern Constructor (AnchorPoint[], String)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points,
string id
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint, _
id As String _
)

Parameters

points
Contains the initial set of AnchorPoint instances for the new pattern.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor (AnchorPointCollection)

AnchorPattern Constructor (AnchorPointCollection)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points
)

Visual Basic [image] Copy Code

Public New ( _
points As AnchorPointCollection _
)

Parameters

points
A collection of AnchorPoint objects.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor (AnchorPointCollection, String)

AnchorPattern Constructor (AnchorPointCollection, String)
See Also
[image]

Intializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points,
string id
)

Visual Basic [image] Copy Code

Public New ( _
points As AnchorPointCollection, _
id As String _
)

Parameters

points
A collection of AnchorPoint objects.
id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Constructor (String)

AnchorPattern Constructor (String)
See Also
[image]

Intializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Methods

AnchorPattern Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.Clone Method

AnchorPattern.Clone Method
[image]

Creates an exact clone of this AnchorPattern object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPattern class.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.FromId Method

AnchorPattern.FromId Method
[image]

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static AnchorPattern FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As String _
) As AnchorPattern

Parameters

id
A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter, or null (Nothing in Visual Basic) if no such object exists.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace
Shape Property
Shapes Property


MindFusion.Diagramming.Wpf.AnchorPattern.Register Method

AnchorPattern.Register Method
[image]

Registers the specified anchor pattern as shared.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void Register (
AnchorPattern pattern
)

Visual Basic [image] Copy Code

Public Shared Sub Register( _
pattern As AnchorPattern _
)

Parameters

pattern
The AnchorPattern to register.

Remarks

This method is obsolete. Please use the Id property to create shared anchor patterns.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern Properties

AnchorPattern Properties
[image]

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

See Also

AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.Decision1In3Out Property

AnchorPattern.Decision1In3Out Property
[image]

Gets the predefined anchor pattern Decision1In3Out.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static AnchorPattern Decision1In3Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision1In3Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.Decision2In2Out Property

AnchorPattern.Decision2In2Out Property
[image]

Gets the predefined anchor pattern Decision2In2Out.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static AnchorPattern Decision2In2Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2In2Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.Id Property

AnchorPattern.Id Property
[image]

Gets the AnchorPattern unique identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.LeftInRightOut Property

AnchorPattern.LeftInRightOut Property
[image]

Gets the predefined anchor pattern LeftInRightOut.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static AnchorPattern LeftInRightOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LeftInRightOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.Points Property

AnchorPattern.Points Property
[image]

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPointCollection Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As AnchorPointCollection

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

Remarks

To find an anchor pattern by its id, call the static FromId method.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPattern.TopInBottomOut Property

AnchorPattern.TopInBottomOut Property
[image]

Gets the predefined anchor pattern TopInBottomOut.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static AnchorPattern TopInBottomOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TopInBottomOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom - for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Class

AnchorPoint Class
Remarks See Also
[image]

Specifies the locations in a node, to which the user is allowed to connect links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnchorPoint : ICloneable

Visual Basic [image] Copy Code

Public Class AnchorPoint
Implements ICloneable

Remarks

An anchor point can accept incoming or outgoing links, or both, as specified by the AllowIncoming and AllowOutgoing properties. The position of the anchor point inside a node's bounding rectangle is set by the X and Y properties, expressed as percent of the rectangle width and height.

How anchor points are marked on the display can be set using MarkStyle and Brush properties. Custom painting can be done by setting MarkStyle to Custom and handling the DrawAnchorPoint event.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AnchorPoint

See Also

AnchorPoint Members
MindFusion.Diagramming.Wpf Namespace
AnchorPattern Class


MindFusion.Diagramming.Wpf.AnchorPoint Members

AnchorPoint Members
Constructors Properties Methods
[image]

Specifies the locations in a node, to which the user is allowed to connect links.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Overloaded. The following constructors are provided for creating new AnchorPoint objects.

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Brush | Gets or sets the brush of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
LinkOrientation | Gets or sets the desired orientation of link segments that connect to this point.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

Protected Methods

Name | Description
Draw | Renders the anchor point.

See Also

AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor

AnchorPoint Constructor
[image]

The following constructors are provided for creating new AnchorPoint objects.

Overload List

Name | Description
AnchorPoint (Double, Double) | Initializes a new instance of the AnchorPoint class with the specified coordinates.
AnchorPoint (Double, Double, Boolean, Boolean) | Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.
AnchorPoint (Double, Double, Boolean, Boolean, Brush, Int32) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.
AnchorPoint (Double, Double, Boolean, Boolean, Brush, Int32, Object) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle, Brush) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

See Also

AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double)

AnchorPoint Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double, Boolean, Boolean)

AnchorPoint Constructor (Double, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Brush brush,
int col
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
brush As Brush, _
col As Integer _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

brush

The brush with which the anchor mark is painted.

col

Specifies a table's column, with which an anchor point is associated.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32, Object)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Brush, Int32, Object)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Brush brush,
int col,
Object tag
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
brush As Brush, _
col As Integer, _
tag As Object _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

brush

The brush with which the anchor mark is painted.

col

The table's column, with which an anchor point is associated.

tag

User-defined data associated with the anchor point.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Brush)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Brush)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle,
Brush brush
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle, _
brush As Brush _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

brush

The brush with which the anchor mark is painted.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Methods

AnchorPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

Protected Methods

Name | Description
Draw | Renders the anchor point.

See Also

AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint.Clone Method

AnchorPoint.Clone Method
[image]

Creates an exact clone of this AnchorPoint object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPoint class.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint.Draw Method

AnchorPoint.Draw Method
[image]

Renders the anchor point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void Draw (
DrawingContext graphics,
Rect nodeRect,
double markSize,
Diagram diagram,
DrawAnchorPointEventArgs customDrawArgs
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
graphics As DrawingContext, _
nodeRect As Rect, _
markSize As Double, _
diagram As Diagram, _
customDrawArgs As DrawAnchorPointEventArgs _
)

Parameters

graphics

nodeRect

markSize

diagram

customDrawArgs

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint Properties

AnchorPoint Properties
[image]

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Brush | Gets or sets the brush of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
LinkOrientation | Gets or sets the desired orientation of link segments that connect to this point.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
ToolTip | Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

See Also

AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint.AllowIncoming Property

AnchorPoint.AllowIncoming Property
[image]

Gets or sets a value indicating whether incoming links can be connected to this anchor.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncoming As Boolean

Property Value

true to allow incoming links connect to the anchor; false to forbid that. The default is true.

Remarks

If no incoming anchors are defined for a node, links end points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
AllowOutgoing Property
ValidateAnchorPoint Event


MindFusion.Diagramming.Wpf.AnchorPoint.AllowOutgoing Property

AnchorPoint.AllowOutgoing Property
[image]

Gets or sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowOutgoing { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoing As Boolean

Property Value

true to allow outgoing links connect to the anchor; false to forbid that. The default is true.

Remarks

If no outgoing anchors are defined for a node, links start points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
AllowIncoming Property
ValidateAnchorPoint Event


MindFusion.Diagramming.Wpf.AnchorPoint.Brush Property

AnchorPoint.Brush Property
[image]

Gets or sets the brush of the anchor point mark.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the .NET Brush class. The default is Brushes.Black.

Remarks

The anchor mark shape specified by MarkStyle is painted with this brush.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
MarkStyle Property


MindFusion.Diagramming.Wpf.AnchorPoint.Column Property

AnchorPoint.Column Property
[image]

Gets or sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Column { get; set; }

Visual Basic [image] Copy Code

Public Property Column As Integer

Property Value

An integer value specifying the zero-based index of a table's column. The default is -1.

Remarks

This property is useful when the anchor point is included in table row's AnchorPattern. It defines whether the anchor point is relative to a cell or to a whole row. If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
Row.AnchorPattern Property


MindFusion.Diagramming.Wpf.AnchorPoint.LinkOrientation Property

AnchorPoint.LinkOrientation Property
[image]

Gets or sets the desired orientation of link segments that connect to this point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation LinkOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LinkOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

At this time the value of this property is considered only by GridRouter.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint.MarkStyle Property

AnchorPoint.MarkStyle Property
[image]

Gets or sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MarkStyle MarkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property MarkStyle As MarkStyle

Property Value

A member of the MarkStyle enumeration. The default is MarkStyle.X.

Remarks

Specifies how anchor points are marked visually on the display. Custom code can be used to draw the marks by setting the property value to MarkStyle.Custom and handling the DrawAnchorPoint event.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
Brush Property


MindFusion.Diagramming.Wpf.AnchorPoint.Tag Property

AnchorPoint.Tag Property
[image]

Gets or sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default is null (Nothing in Visual Basic).

Remarks

This property holds data that you define. MindFusion.Diagramming for WPF does not use it in any way. You might associate with the anchor point any value of primitive data types. The tag also might be a complex object from the .NET class library or a class defined by you. If the tag is an instance of value type it will be serialized together with the object containing it when saving / loading a diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
SerializeTag Event


MindFusion.Diagramming.Wpf.AnchorPoint.ToolTip Property

AnchorPoint.ToolTip Property
[image]

Gets or sets a tooltip text that should be displayed when the mouse hovers over an anchor point mark.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As Object

Property Value

A string specifying the tool-tip text displayed for this anchor point. The default is an empty string.

Remarks

When the mouse rests for a while over an anchor point, the tool-tip text is displayed in a small popup window near the mouse cursor. If the anchor point tooltip is an empty string, the ToolTip of the node to which the anchor point is assigned is displayed instead.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPoint.X Property

AnchorPoint.X Property
[image]

Gets or sets the horizontal position of the anchor point expressed as percent of a node's width.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
Y Property
XUnit Property


MindFusion.Diagramming.Wpf.AnchorPoint.XUnit Property

AnchorPoint.XUnit Property
[image]

Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UnitType XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
X Property
YUnit Property


MindFusion.Diagramming.Wpf.AnchorPoint.Y Property

AnchorPoint.Y Property
[image]

Gets or sets the vertical position of the anchor point expressed as percent of a node's height.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value specifying the location of the anchor point, expressed in percent.

Remarks

Set the property value to a number from 0 to 100, otherwise you might get unexpected behavior.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
X Property
YUnit Property


MindFusion.Diagramming.Wpf.AnchorPoint.YUnit Property

AnchorPoint.YUnit Property
[image]

Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UnitType YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class
MindFusion.Diagramming.Wpf Namespace
Y Property
XUnit Property


MindFusion.Diagramming.Wpf.AnchorPointCollection Class

AnchorPointCollection Class
[image]

Represents a strongly typed collection of anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnchorPointCollection : CollectionBase<AnchorPoint>

Visual Basic [image] Copy Code

Public Class AnchorPointCollection
Inherits CollectionBase(Of AnchorPoint)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(AnchorPoint)
MindFusion.Diagramming.Wpf.AnchorPointCollection

See Also

AnchorPointCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection Members

AnchorPointCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of anchor points.

The following tables list the members exposed by the AnchorPointCollection type.

Public Constructors

Name | Description
AnchorPointCollection | Overloaded. Initializes a new instance of the AnchorPointCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Remove | Removes the specified anchor point from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the anchor point at the specified index of the collection.

See Also

AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection Constructor

AnchorPointCollection Constructor
[image]

Initializes a new instance of the AnchorPointCollection class.

Overload List

Name | Description
AnchorPointCollection () | Initializes a new instance of the AnchorPointCollection class.
AnchorPointCollection (AnchorPoint[]) | Initializes a new instance of the AnchorPointCollection class.

See Also

AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection Constructor ()

AnchorPointCollection Constructor ()
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPointCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection Constructor (AnchorPoint[])

AnchorPointCollection Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPointCollection (
AnchorPoint[] array
)

Visual Basic [image] Copy Code

Public New ( _
array() As AnchorPoint _
)

Parameters

array

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection Methods

AnchorPointCollection Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Remove | Removes the specified anchor point from the collection.
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
RemoveAt | Removes the anchor point at the specified index of the collection.

See Also

AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.Add Method

AnchorPointCollection.Add Method
[image]

Adds the specified anchor point to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Add (
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
point As AnchorPoint _
)

Parameters

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.Clear Method

AnchorPointCollection.Clear Method
[image]

Removes all anchor points from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.GetAt Method

AnchorPointCollection.GetAt Method
[image]

Gets the anchor point at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As AnchorPoint

Parameters

index

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.Insert Method

AnchorPointCollection.Insert Method
[image]

Inserts the specified anchor point in the collection at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Insert (
int index,
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
point As AnchorPoint _
)

Parameters

index

point

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.Remove Method

AnchorPointCollection.Remove Method
[image]

Removes the specified anchor point from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Remove (
AnchorPoint point
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
point As AnchorPoint _
) As Boolean

Parameters

point

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointCollection.RemoveAt Method

AnchorPointCollection.RemoveAt Method
[image]

Removes the anchor point at the specified index of the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

See Also

AnchorPointCollection Members
AnchorPointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs Class

AnchorPointEventArgs Class
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.AnchorPointEventArgs

See Also

AnchorPointEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs Members

AnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

The following tables list the members exposed by the AnchorPointEventArgs type.

Public Constructors

Name | Description
AnchorPointEventArgs | Initializes a new instance of the AnchorPointEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs Constructor

AnchorPointEventArgs Constructor
[image]

Initializes a new instance of the AnchorPointEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPointEventArgs (
DiagramLink link,
int oldAnchorIndex,
int newAnchorIndex
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
oldAnchorIndex As Integer, _
newAnchorIndex As Integer _
)

Parameters

link

The link whose end has been attached to a different anchor point.

oldAnchorIndex

The index of the old anchor point.

newAnchorIndex

The index of the new anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs Properties

AnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs.Link Property

AnchorPointEventArgs.Link Property
[image]

Gets the link whose anchor point index has been changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs.NewAnchorIndex Property

AnchorPointEventArgs.NewAnchorIndex Property
[image]

Gets the index of the new anchor point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int NewAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AnchorPointEventArgs.OldAnchorIndex Property

AnchorPointEventArgs.OldAnchorIndex Property
[image]

Gets the index of the old anchor point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int OldAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Class

ArcTemplate Class
[image]

Represents an arc in a shape definition.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ArcTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class ArcTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ElementTemplate
MindFusion.Diagramming.Wpf.ArcTemplate

See Also

ArcTemplate Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Members

ArcTemplate Members
Constructors Properties Methods
[image]

Represents an arc in a shape definition.

The following tables list the members exposed by the ArcTemplate type.

Public Constructors

Name | Description
ArcTemplate | Overloaded. Initializes a new instance of the ArcTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Constructor

ArcTemplate Constructor
[image]

Initializes a new instance of the ArcTemplate class.

Overload List

Name | Description
ArcTemplate (Double, Double, Double, Double, Double, Double) | Initializes a new istance of the ArcTemplate class with the specified coordinates.
ArcTemplate (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

See Also

ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new istance of the ArcTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new istance of the ArcTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Methods

ArcTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate.Clone Method

ArcTemplate.Clone Method
[image]

Creates an exact copy of this ArcTemplate element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the ArcTemplate class.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate.SameAs Method

ArcTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj
The ElementTemplate to compare to this template.

Return Value

true if the specified object is an ArcTemplate closely approximating this template; otherwise, false.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate Properties

ArcTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate.Bounds Property

ArcTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the .NET Rect structure.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate.StartAngle Property

ArcTemplate.StartAngle Property
[image]

Gets the start angle of this arc element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Double

Property Value

A double value specifying the start angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArcTemplate.SweepAngle Property

ArcTemplate.SweepAngle Property
[image]

Gets the sweep angle of this arc element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Double

Property Value

A double value specifying the sweep angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs Class

AreaEventArgs Class
[image]

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AreaEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AreaEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.AreaEventArgs

See Also

AreaEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs Members

AreaEventArgs Members
Properties
[image]

Contains arguments passed to handlers of the CreatingArea event of the HtmlBuilder class.

The following tables list the members exposed by the AreaEventArgs type.

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs Properties

AreaEventArgs Properties
[image]

Public Properties

Name | Description
AreaTag | Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.
Column | Gets the index of a column if the event is raised for a table cell.
Item | Gets the diagram element represented by AreaTag in the image map.
Row | Gets the index of a row if the event is raised for a table cell.

See Also

AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs.AreaTag Property

AreaEventArgs.AreaTag Property
[image]

Gets or sets the HTML AREA tag created by HtmlBuilder. You can insert additional attributes or JavaScript event handlers into that string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string AreaTag { get; set; }

Visual Basic [image] Copy Code

Public Property AreaTag As String

Property Value

A string value that represents the AREA tag, including the opening and closing brackets.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs.Column Property

AreaEventArgs.Column Property
[image]

Gets the index of a column if the event is raised for a table cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the related column.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs.Item Property

AreaEventArgs.Item Property
[image]

Gets the diagram element represented by AreaTag in the image map.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AreaEventArgs.Row Property

AreaEventArgs.Row Property
[image]

Gets the index of a row if the event is raised for a table cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the related row.

See Also

AreaEventArgs Members
AreaEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads Class

ArrowHeads Class
Remarks See Also
[image]

Contains predefined arrowhead shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class ArrowHeads

Visual Basic [image] Copy Code

Public NotInheritable Class ArrowHeads

Remarks

Shape objects exposed as properties of this class can be assigned to the HeadShape, BaseShape and IntermediateShape properties of links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ArrowHeads

See Also

ArrowHeads Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads Members

ArrowHeads Members
Properties
[image]

Contains predefined arrowhead shapes.

The following tables list the members exposed by the ArrowHeads type.

Public Properties

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads Properties

ArrowHeads Properties
[image]

Public Properties

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Arrow Property

ArrowHeads.Arrow Property
[image]

Display an arrow-like shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Arrow As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.BackSlash Property

ArrowHeads.BackSlash Property
[image]

Display a back slash.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BackSlash { get; set; }

Visual Basic [image] Copy Code

Public Shared Property BackSlash As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.BowArrow Property

ArrowHeads.BowArrow Property
[image]

Display a bow arrow.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BowArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property BowArrow As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Circle Property

ArrowHeads.Circle Property
[image]

Display a circle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Circle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Circle As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.DefaultFlow Property

ArrowHeads.DefaultFlow Property
[image]

"Default flow" in BPMN diagrams.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DefaultFlow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property DefaultFlow As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.DoubleArrow Property

ArrowHeads.DoubleArrow Property
[image]

Display a double arrow.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DoubleArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property DoubleArrow As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.None Property

ArrowHeads.None Property
[image]

Do not display an arrowhead shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape None { get; set; }

Visual Basic [image] Copy Code

Public Shared Property None As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Pentagon Property

ArrowHeads.Pentagon Property
[image]

Display a pentagon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Pentagon As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.PointerArrow Property

ArrowHeads.PointerArrow Property
[image]

Display a pointer arrow.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PointerArrow { get; set; }

Visual Basic [image] Copy Code

Public Shared Property PointerArrow As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Quill Property

ArrowHeads.Quill Property
[image]

Display a quill.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Quill { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Quill As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Reversed Property

ArrowHeads.Reversed Property
[image]

Reversed arrowhead.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Reversed { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Reversed As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.RevTriangle Property

ArrowHeads.RevTriangle Property
[image]

Display a reversed triangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RevTriangle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevTriangle As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.RevWithCirc Property

ArrowHeads.RevWithCirc Property
[image]

Reversed arrowhead with a circle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RevWithCirc { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevWithCirc As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.RevWithLine Property

ArrowHeads.RevWithLine Property
[image]

Reversed arrowhead with intersecting line.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RevWithLine { get; set; }

Visual Basic [image] Copy Code

Public Shared Property RevWithLine As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Rhombus Property

ArrowHeads.Rhombus Property
[image]

Display a rhombus.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Rhombus { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Rhombus As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Slash Property

ArrowHeads.Slash Property
[image]

Display a slash.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Slash { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Slash As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Tetragon Property

ArrowHeads.Tetragon Property
[image]

Display a tetragon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Tetragon { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Tetragon As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ArrowHeads.Triangle Property

ArrowHeads.Triangle Property
[image]

Display a triangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Triangle { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Triangle As Shape

Property Value

An instance of the Shape class.

See Also

ArrowHeads Members
ArrowHeads Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AttachTo Enumeration

AttachTo Enumeration
[image]

Specifies the type of attachment in a group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AttachTo

Visual Basic [image] Copy Code

Public Enum AttachTo

Members

Member name | Description
AnchorToEdges | Indicates attachment that is anchored to one or more sides of a node.
FixedCorner | Indicates attachment to a fixed corner of a node.
LinkPoint | Indicates attachment to an link's control point.
LinkSegment | Indicates attachment to an link's segment.
LongestHSegment | Indicates attachment to the longest horizontal segment of a link.
Proportional | Indicates proportional attachment to a node.
SideMiddle | Indicates attachment to the middle of a side of a node's bounding rectangle.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AttachToLink Enumeration

AttachToLink Enumeration
[image]

Specifies the possible ways to attach a node to a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AttachToLink

Visual Basic [image] Copy Code

Public Enum AttachToLink

Members

Member name | Description
LongestHSegment | The node stays attached to the longest horizontal segment of the link.
Point | The node is attached to a fixed control point of the link.
Segment | The node is attached to a fixed segment of the link.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AttachToNode Enumeration

AttachToNode Enumeration
[image]

Defines values specifying the possible ways to attach a node to another node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AttachToNode

Visual Basic [image] Copy Code

Public Enum AttachToNode

Members

Member name | Description
BottomCenter | The node follows the bottom-center point of the master node.
BottomLeft | The node follows the bottom-left corner of the master node.
BottomRight | The node follows the bottom-right corner of the master node.
MiddleLeft | The node follows the middle-left point of the master node.
MiddleRight | The node follows the middle-right point of the master node.
Proportional | Preserve initial proportion of position and size relatively to master's boundaries.
TopCenter | The node follows the top-center point of the master node.
TopLeft | The node follows the top-left corner of the master node.
TopRight | The node follows the top-right corner of the master node.

Remarks

Members of this enumeration are used as values for the attType argument of the AttachTo method of the DiagramNode class.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.AutoResize Enumeration

AutoResize Enumeration
[image]

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AutoResize

Visual Basic [image] Copy Code

Public Enum AutoResize

Members

Member name | Description
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.

Remarks

Values from this enumeration can be assigned to the AutoResize property.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Class

BarcodeNode Class
Remarks See Also
[image]

Represents nodes that can encode and render barcodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class BarcodeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class BarcodeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The BarcodeNode class displays EAN, UPC or QR barcodes as node's content. In-place edit operations let users enter new numeric codes for 1D codes or text strings for QR codes. The barcode format is specified via the Format property, the encoded number or text is set via Content, and color of 1D bars / 2D modules via BarColor.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.BarcodeNode

See Also

BarcodeNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Members

BarcodeNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can encode and render barcodes.

The following tables list the members exposed by the BarcodeNode type.

Public Constructors

Name | Description
BarcodeNode | Overloaded. Initializes a new instance of the BarcodeNode class.

Public Fields

Name | Description
BarColorProperty | Identifies the BarColor dependency property.
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
ContentProperty | Identifies the Content dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
FormatProperty | Identifies the Format dependency property.
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
BarColor | Gets or sets the color of barcode modules.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
Format | Gets or sets the barcode format.
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Fields

BarcodeNode Fields
[image]

Public Fields

Name | Description
BarColorProperty | Identifies the BarColor dependency property.
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
ContentProperty | Identifies the Content dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
FormatProperty | Identifies the Format dependency property.
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.BarColorProperty Field

BarcodeNode.BarColorProperty Field
[image]

Identifies the BarColor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarColorProperty As DependencyProperty

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.ContentProperty Field

BarcodeNode.ContentProperty Field
[image]

Identifies the Content dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.FormatProperty Field

BarcodeNode.FormatProperty Field
[image]

Identifies the Format dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.QRCorrectionLevelProperty Field

BarcodeNode.QRCorrectionLevelProperty Field
[image]

Identifies the QRCorrectionLevel dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty QRCorrectionLevelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly QRCorrectionLevelProperty As DependencyProperty

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Constructor

BarcodeNode Constructor
[image]

Initializes a new instance of the BarcodeNode class.

Overload List

Name | Description
BarcodeNode () | Initializes a new instance of the BarcodeNode class.
BarcodeNode (BarcodeNode) | Initializes a new instance of the BarcodeNode class.
BarcodeNode (Diagram) | Initializes a new instance of the BarcodeNode class.

See Also

BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Constructor ()

BarcodeNode Constructor ()
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Constructor (BarcodeNode)

BarcodeNode Constructor (BarcodeNode)
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode (
BarcodeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As BarcodeNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Constructor (Diagram)

BarcodeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the BarcodeNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

BarcodeNode Constructor Overload List
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Methods

BarcodeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.CreateProperties Method

BarcodeNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A BarcodeNodeProperties instance containing a snapshot of the item's properties.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.DrawLocal Method

BarcodeNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.LoadFromXml Method

BarcodeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.RestoreProperties Method

BarcodeNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A BarcodeNodeProperties object containing a snapshot of the item's properties.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.SaveProperties Method

BarcodeNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A BarcodeNodeProperties object where the item's properties should be saved.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.SaveToXml Method

BarcodeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode Properties

BarcodeNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
BarColor | Gets or sets the color of barcode modules.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
Format | Gets or sets the barcode format.
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.BarColor Property

BarcodeNode.BarColor Property
[image]

Gets or sets the color of barcode modules.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color BarColor { get; set; }

Visual Basic [image] Copy Code

Public Property BarColor As Color

Property Value

A System.Windows.Media.Color instance. The default value is Black.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.Content Property

BarcodeNode.Content Property
[image]

Gets or sets the text or numeric code that should be represented as barcode symbol.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As String

Property Value

A string containing the barcode's content.

Remarks

For 1D code formats, the string should contain only digits representing the code's numerical value. The control will automatically calculate the last check-digit if it's not set. If the string contains a check-digit at expected position, the control will consider its value to be valid without verifying it.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.Format Property

BarcodeNode.Format Property
[image]

Gets or sets the barcode format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As BarcodeFormat

Property Value

A member of the BarcodeFormat enumeration. The default value is QR.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNode.QRCorrectionLevel Property

BarcodeNode.QRCorrectionLevel Property
[image]

Gets or sets the correction level of QR barcodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CorrectionLevel QRCorrectionLevel { get; set; }

Visual Basic [image] Copy Code

Public Property QRCorrectionLevel As CorrectionLevel

Property Value

A member of the CorrectionLevel enumeration. The default value is M.

See Also

BarcodeNode Members
BarcodeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNodeProperties Class

BarcodeNodeProperties Class
[image]

Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class BarcodeNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class BarcodeNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.BarcodeNodeProperties

See Also

BarcodeNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNodeProperties Members

BarcodeNodeProperties Members
Constructors Methods
[image]

Stores the values of BarcodeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from BarcodeNode, do so by deriving from BarcodeNodeProperties and overriding the BarcodeNode.SaveProperties, BarcodeNode.RestoreProperties, and BarcodeNode.CreateProperties methods.

The following tables list the members exposed by the BarcodeNodeProperties type.

Public Constructors

Name | Description
BarcodeNodeProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

BarcodeNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BarcodeNodeProperties Constructor

BarcodeNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarcodeNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Custom | Specifies that user input should be handled by the BehaviorBase-derived object assigned to CustomBehavior.
DoNothing | The control ignores users actions with the mouse, but raises the appropriate mouse events. This mode allows applications to implement their own mouse-drawing behavior, disabling the default response to users actions.
DrawBarcodes | Drawing with the mouse creates BarcodeNode instances.
DrawContainers | Drawing with the mouse creates ContainerNode instances.
DrawControls | Drawing with the mouse creates nodes from the UIElement derived type specified through DefaultControlType.
DrawFreeForms | Drawing with the mouse creates FreeFormNode instances.
DrawFreeShapes | Points from user input are shown using a FreeFormNode instance. Once the user finishes drawing, the FreeFormNode is replaced by a ShapeNode with a matching shape from FreeFormTargets list.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawNodes | Drawing with the mouse creates TemplatedNode instances.
DrawShapes | Drawing with the mouse creates ShapeNode instances.
DrawTables | Drawing with the mouse creates TableNode instances.
DrawTreeViews | Drawing with the mouse creates TreeViewNode instances.
DrawVisioNodes | Drawing with the mouse creates VisioNode instances.
LinkBarcodes | Drawing over empty document area creates a BarcodeNode instance. Drawing started over a node creates a DiagramLink.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
LinkControls | Drawing with the mouse creates nodes from the UIElement derived type specified through DefaultControlType. Drawing started over a node creates a DiagramLink.
LinkFreeForms | Drawing over empty document area creates a FreeFormNode instance. Drawing started over a node creates a DiagramLink.
LinkFreeShapes | Points from user input are shown using a FreeFormNode instance. Once the user finishes drawing, the FreeFormNode is replaced by a ShapeNode with a matching shape from FreeFormTargets list. Drawing started over a node creates a DiagramLink.
LinkNodes | Drawing over empty document area creates a TemplatedNode instance. Drawing started over a node creates a DiagramLink.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
LinkTreeViews | Drawing over an empty document area creates a TreeViewNode instance. Drawing started over a node creates a DiagramLink.
LinkVisioNodes | Drawing over empty document area creates a VisioNode instance. Drawing started over a node creates a DiagramLink.
Modify | Objects can be selected and modified. New objects cannot be created.
Pan | Dragging with the mouse pans the view. This requires that the Diagram is contained in a ScrollViewer.
PanAndModify | Items can be selected and modified. New items cannot be created, and dragging without grabbing an adjustment handle pans the view.
SelectOnly | Allow only selection of existing items. Modifying them or drawing new ones is disabled.

Remarks

Use the Behavior property to specify how MindFusion.Diagramming for WPF interprets user's actions. In all modes:

  • single clicking selects the item under the mouse pointer and make it the ActiveItem;
  • dragging while CTRL is pressed creates multiple-selection;
  • dragging while ALT is pressed pans the view;

See Also

MindFusion.Diagramming.Wpf Namespace
Behavior Property


MindFusion.Diagramming.Wpf.BezierTemplate Class

BezierTemplate Class
[image]

Represents a Bézier curve in a shape definition.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class BezierTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class BezierTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ElementTemplate
MindFusion.Diagramming.Wpf.BezierTemplate

See Also

BezierTemplate Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Members

BezierTemplate Members
Constructors Properties Methods
[image]

Represents a Bézier curve in a shape definition.

The following tables list the members exposed by the BezierTemplate type.

Public Constructors

Name | Description
BezierTemplate | Overloaded. Initializes a new instance of the BezierTemplate class.

Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Constructor

BezierTemplate Constructor
[image]

Initializes a new instance of the BezierTemplate class.

Overload List

Name | Description
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates.
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

See Also

BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

A Bézier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Methods

BezierTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate.Clone Method

BezierTemplate.Clone Method
[image]

Creates an exact copy of this BezierTemplate element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the BezierTemplate class.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate.SameAs Method

BezierTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj
The ElementTemplate to compare to this template.

Return Value

true if the specified object is a BezierTemplate closely approximating this template; otherwise, false.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate Properties

BezierTemplate Properties
[image]

Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.BezierTemplate.Coordinates Property

BezierTemplate.Coordinates Property
[image]

Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Double()

Property Value

An array of double values containing the coordinates of the points composing this element.

See Also

BezierTemplate Members
BezierTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CameraType Enumeration

CameraType Enumeration
[image]

Specifies the type of camera projection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum CameraType

Visual Basic [image] Copy Code

Public Enum CameraType

Members

Member name | Description
Orthographic | Specifies an orthographic projection camera.
Perspective | Specifies a perspective projection camera.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellClicked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.CellEventArgs
MindFusion.Diagramming.Wpf.CellValidationEventArgs

See Also

CellEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs Members

CellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as CellClicked.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CellEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
Point mousePosition,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As Point, _
column As Integer, _
row As Integer _
)

Parameters

cell
The TableNode.Cell related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs Properties

CellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.Cell Property

CellEventArgs.Cell Property
[image]

Get the cell for which the event is raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class specifying the cell related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.Column Property

CellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the table column related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.MouseButton Property

CellEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.MousePosition Property

CellEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

A Point value specifying the current mouse position.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.Row Property

CellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the table row related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellEventArgs.Table Property

CellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class specifying the table related to the event.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellFrameStyle Enumeration

CellFrameStyle Enumeration
[image]

Specifies the style of the cells' frame lines.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum CellFrameStyle

Visual Basic [image] Copy Code

Public Enum CellFrameStyle

Members

Member name | Description
None | Table cells have no border.
Simple | The border of table cells is simple line.
System3D | The border has 3D look.

Remarks

The enumeration values are used when customizing table cells.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs Class

CellValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CellValidationEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class CellValidationEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.CellEventArgs
MindFusion.Diagramming.Wpf.CellValidationEventArgs

See Also

CellValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs Members

CellValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

The following tables list the members exposed by the CellValidationEventArgs type.

Public Constructors

Name | Description
CellValidationEventArgs | Initializes a new instance of the CellValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from CellEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the resize of the node's row or column.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs Constructor

CellValidationEventArgs Constructor
[image]

Initializes a new instance of the CellValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CellValidationEventArgs (
TableNode.Cell cell,
MouseButton mouseButton,
Point mousePosition,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
mouseButton As MouseButton, _
mousePosition As Point, _
column As Integer, _
row As Integer _
)

Parameters

cell
The TableNode.Cell related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs Methods

CellValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the resize of the node's row or column.

See Also

CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs.CancelDrag Method

CellValidationEventArgs.CancelDrag Method
[image]

Cancels the resize of the node's row or column.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs Properties

CellValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from CellEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

See Also

CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CellValidationEventArgs.Cancel Property

CellValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Class

CollectionBase(T) Class
[image]

An implementation of the IList<T> interface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class CollectionBase<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Visual Basic [image] Copy Code

Public MustInherit Class CollectionBase(Of T)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(T)
MindFusion.Diagramming.Wpf.AnchorPointCollection
MindFusion.Diagramming.Wpf.GroupCollection
MindFusion.Diagramming.Wpf.ItemCollectionBase(T)

See Also

CollectionBase(T) Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Members

CollectionBase(T) Members
Constructors Fields Properties Methods
[image]

An implementation of the IList<T> interface.

The following tables list the members exposed by the CollectionBase(T) type.

Protected Constructors

Name | Description
CollectionBase | Initializes a new instance of the CollectionBase class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo |
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

See Also

CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Fields

CollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance.

See Also

CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).InnerList Field

CollectionBase(T).InnerList Field
[image]

Gets a List<T> containing the list of elements in the collecion instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected List<T> InnerList

Visual Basic [image] Copy Code

Protected InnerList As List(Of T)

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Constructor

CollectionBase(T) Constructor
[image]

Initializes a new instance of the CollectionBase class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected CollectionBase<T> ()

Visual Basic [image] Copy Code

Protected Sub New(Of T) ()

See Also

CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Methods

CollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo |
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

See Also

CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Add Method

CollectionBase(T).Add Method
[image]

Adds an object to the end of the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void Add (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Add( _
item As T _
)

Parameters

item

The object to be added to the end of the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Clear Method

CollectionBase(T).Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void Clear ()

Visual Basic [image] Copy Code

Public MustOverride Sub Clear ()

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Contains Method

CollectionBase(T).Contains Method
[image]

Determines whether an element is in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As T _
) As Boolean

Parameters

item

The object to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).CopyTo Method

CollectionBase(T).CopyTo Method
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
T[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As T, _
arrayIndex As Integer _
)

Parameters

array

arrayIndex

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).GetEnumerator Method

CollectionBase(T).GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of T)

Return Value

An IEnumerator<T> for the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).IndexOf Method

CollectionBase(T).IndexOf Method
[image]

Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As T _
) As Integer

Parameters

item

The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, –1.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Insert Method

CollectionBase(T).Insert Method
[image]

Inserts an element into the collection at the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Remove Method

CollectionBase(T).Remove Method
[image]

Removes the first occurrence of a specific object from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool Remove (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Function Remove( _
item As T _
) As Boolean

Parameters

item

The object to remove from the collection.

Return Value

true if item is successfully removed; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).RemoveAt Method

CollectionBase(T).RemoveAt Method
[image]

Removes the element at the specified index of the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public MustOverride Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T) Properties

CollectionBase(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

See Also

CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Count Property

CollectionBase(T).Count Property
[image]

Gets the number of elements actually contained in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).IsReadOnly Property

CollectionBase(T).IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CollectionBase(T).Item Property

CollectionBase(T).Item Property
[image]

Gets or sets the element at the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As T

Parameters

index

The zero-based index of the element to get or set.

Property Value

The element at the specified index.

See Also

CollectionBase(T) Members
CollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ColumnStyle Enumeration

ColumnStyle Enumeration
[image]

Specifies how table columns' width is set.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ColumnStyle

Visual Basic [image] Copy Code

Public Enum ColumnStyle

Members

Member name | Description
AutoWidth | The columns' width changes when the table is resized.
FixedWidth | The columns has fixed, unchangeable width.

Remarks

Use the enumeration values to set the behavior of table columns, when the user resizes the table.

See Also

MindFusion.Diagramming.Wpf Namespace
ColumnStyle Property


MindFusion.Diagramming.Wpf.CommandHistory Class

CommandHistory Class
Remarks See Also
[image]

Maintains a queue of Command records used to undo or redo actions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CommandHistory

Visual Basic [image] Copy Code

Public Class CommandHistory

Remarks

The only instance of CommandHistory can be accessed by the History property of UndoManager.

The Capacity property specifies how many Command instances can be stored in the history queue. If the queue is full and a new action is recorded, the oldest one will be removed and made unavailable for undo/redo. A read-only access to the command queue is provided by the Commands property.

The CommandHistory instance maintains an internal record pointer. The pointer is decreased or increased by one when an action is respectively undone or redone by the undo manager. The pointer actually refers to two adjacent action records - the older one to be used when undoing, the newer one when redoing commands. Those two records can be accessed by the NextUndo and NextRedo properties. When no action has been undone, the pointer refers to the end of the queue and NextRedo returns null (Nothing in Visual Basic). When all actions have been undone, the pointer refers to the start of the queue and NextUndo returns null.

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after Clear.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CommandHistory

See Also

CommandHistory Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory Members

CommandHistory Members
Properties Methods
[image]

Maintains a queue of Command records used to undo or redo actions.

The following tables list the members exposed by the CommandHistory type.

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory Methods

CommandHistory Methods
[image]

Public Methods

Name | Description
Clear | Removes all records from the history queue.
MergeUndoRecords | Merges several undo records into a single composite record.

See Also

CommandHistory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory.Clear Method

CommandHistory.Clear Method
[image]

Removes all records from the history queue.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to remove all action records that are currently in the history queue, making those actions unavailable for undo or redo anymore. That won't disable adding new records to the queue, so it will be possible to undo/redo any actions executed after the call.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace
UndoEnabled Property


MindFusion.Diagramming.Wpf.CommandHistory.MergeUndoRecords Method

CommandHistory.MergeUndoRecords Method
[image]

Merges several undo records into a single composite record.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MergeUndoRecords (
int numRecords,
string title
)

Visual Basic [image] Copy Code

Public Function MergeUndoRecords( _
numRecords As Integer, _
title As String _
) As Boolean

Parameters

numRecords
Specifies how many records at the end of the command list should be merged.
title
Specifies the title of the new command.

Return Value

false if the commands saved in the history are less than numRecords; otherwise, true.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory Properties

CommandHistory Properties
[image]

Public Properties

Name | Description
Capacity | Gets or sets the maximum number of records to keep in the history queue.
Commands | Gets the commands saved in the undo / redo history queue.
NextRedo | Gets a reference to the command that would be redone if Redo is invoked.
NextUndo | Gets a reference to the command that would be undone if Undo is invoked.

See Also

CommandHistory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory.Capacity Property

CommandHistory.Capacity Property
[image]

Gets or sets the maximum number of records to keep in the history queue.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Capacity { get; set; }

Visual Basic [image] Copy Code

Public Property Capacity As Integer

Property Value

An integer value specifying the number of records to keep in the queue; cannot be less than 1. The default is 10.

Remarks

If the history queue is full, the oldest command records are removed from the beginning when new ones are added. The queue is cleared when you change Capacity, so better do this at application's startup phase.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CommandHistory.Commands Property

CommandHistory.Commands Property
[image]

Gets the commands saved in the undo / redo history queue.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CommandList Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As CommandList

Property Value

An instance of the CommandList class representing a read-only collection of Command objects.

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace
NextUndo Property
NextRedo Property


MindFusion.Diagramming.Wpf.CommandHistory.NextRedo Property

CommandHistory.NextRedo Property
[image]

Gets a reference to the command that would be redone if Redo is invoked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command NextRedo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NextRedo As Command

Property Value

An instance of the Command class.

Remarks

When no action has been undone, the current action pointer refers to the end of the history queue and NextRedo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace
Redo Method
NextUndo Property


MindFusion.Diagramming.Wpf.CommandHistory.NextUndo Property

CommandHistory.NextUndo Property
[image]

Gets a reference to the command that would be undone if Undo is invoked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command NextUndo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NextUndo As Command

Property Value

An instance of the Command class.

Remarks

When all actions have been undone, the current action pointer refers to the start of the history queue and NextUndo returns null (Nothing in Visual Basic).

See Also

CommandHistory Members
CommandHistory Class
MindFusion.Diagramming.Wpf Namespace
Undo Method
NextRedo Property


MindFusion.Diagramming.Wpf.ConnectionPoint Class

ConnectionPoint Class
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ConnectionPoint

Visual Basic [image] Copy Code

Public Class ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ConnectionPoint
MindFusion.Diagramming.Wpf.TableConnectionPoint
MindFusion.Diagramming.Wpf.TreeViewConnectionPoint

See Also

ConnectionPoint Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Members

ConnectionPoint Members
Constructors Properties Methods
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink objects contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Overloaded. Initializes a new instance of the ConnectionPoint class.

Public Properties

Name | Description
Node | Gets the node associated with this connection point.
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
AnchorPointFromIndex | Returns the AnchorPoint instance with the specified index.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border.
NearestAnchorPoint | Returns the nearest anchor point pertinent to this connection.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Constructor

ConnectionPoint Constructor
[image]

Initializes a new instance of the ConnectionPoint class.

Overload List

Name | Description
ConnectionPoint () | Initializes a new instance of the ConnectionPoint class.
ConnectionPoint (DiagramNode, DiagramLink, Boolean) | Initializes a new instance of the ConnectionPoint class between the specified node and link.

See Also

ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Constructor ()

ConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the ConnectionPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected ConnectionPoint ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)

ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)
See Also
[image]

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ConnectionPoint (
DiagramNode node,
DiagramLink link,
bool incoming
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

node
The node whose connection to a link is managed by this ConnectionPoint.
link
The link whose connection to a node is managed by this ConnectionPoint.
incoming
Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Methods

ConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
AnchorPointFromIndex | Returns the AnchorPoint instance with the specified index.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the link would change if attached to the specified node at the specified point.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.
SaveEndRelative | Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border.
NearestAnchorPoint | Returns the nearest anchor point pertinent to this connection.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.AddLinkToNode Method

ConnectionPoint.AddLinkToNode Method
[image]

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overridable Sub AddLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.AnchorPointFromIndex Method

ConnectionPoint.AnchorPointFromIndex Method
[image]

Returns the AnchorPoint instance with the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual AnchorPoint AnchorPointFromIndex (
int index
)

Visual Basic [image] Copy Code

Public Overridable Function AnchorPointFromIndex( _
index As Integer _
) As AnchorPoint

Parameters

index
An index of a point within the target AnchorPattern.

Return Value

An instance of the AnchorPoint class.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.CalculateIntersections Method

ConnectionPoint.CalculateIntersections Method
[image]

Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool CalculateIntersections ()

Visual Basic [image] Copy Code

Public Overridable Function CalculateIntersections () As Boolean

Return Value

true to align the link end; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.CanMoveLink Method

ConnectionPoint.CanMoveLink Method
[image]

Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool CanMoveLink (
Point pt
)

Visual Basic [image] Copy Code

Public Overridable Function CanMoveLink( _
pt As Point _
) As Boolean

Parameters

pt
The Point to check for validity.

Return Value

true if the specified point represents a valid location for the connection point; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetAnchorPos Method

ConnectionPoint.GetAnchorPos Method
[image]

Overload List

Name | Description
ConnectionPoint.GetAnchorPos (Int32) | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
ConnectionPoint.GetAnchorPos (Int32, Point@) | Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetAnchorPos Method (Int32)

ConnectionPoint.GetAnchorPos Method (Int32)
See Also
[image]

Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetAnchorPos (
int anchorIdx
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer _
) As Point

Parameters

anchorIdx

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetAnchorPos Method (Int32, Point@)

ConnectionPoint.GetAnchorPos Method (Int32, Point@)
See Also
[image]

Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool GetAnchorPos (
int anchorIdx,
ref Point point
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer, _
ByRef point As Point _
) As Boolean

Parameters

anchorIdx

point

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetEndPoint Method

ConnectionPoint.GetEndPoint Method
[image]

Calculates the coordinates of the this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetEndPoint () As Point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetInitialPoint Method

ConnectionPoint.GetInitialPoint Method
[image]

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetInitialPoint () As Point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetIntersection Method

ConnectionPoint.GetIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetNearestBorderPoint Method

ConnectionPoint.GetNearestBorderPoint Method
[image]

Returns the nearest point lying on the node border.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

A Point instance specifying the current mouse position.

Return Value

Position of the border point nearest to the specified point.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.GetNodeRect Method

ConnectionPoint.GetNodeRect Method
[image]

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Rect GetNodeRect (
bool rotated
)

Visual Basic [image] Copy Code

Public Overridable Function GetNodeRect( _
rotated As Boolean _
) As Rect

Parameters

rotated

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.LinkChanges Method

ConnectionPoint.LinkChanges Method
[image]

Checks whether the link would change if attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool LinkChanges (
DiagramItem item,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function LinkChanges( _
item As DiagramItem, _
point As Point _
) As Boolean

Parameters

item

point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.NearestAnchorPoint Method

ConnectionPoint.NearestAnchorPoint Method
[image]

Returns the nearest anchor point pertinent to this connection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual Point NearestAnchorPoint (
Point point,
ref int idx
)

Visual Basic [image] Copy Code

Protected Overridable Function NearestAnchorPoint( _
point As Point, _
ByRef idx As Integer _
) As Point

Parameters

point

A Point instance specifying the current mouse position.

idx

Receives the anchor point index within its AnchorPattern.

Return Value

Position of the anchor point nearest to the specified point.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.NodesIntersect Method

ConnectionPoint.NodesIntersect Method
[image]

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NodesIntersect (
ConnectionPoint connectionPoint
)

Visual Basic [image] Copy Code

Public Function NodesIntersect( _
connectionPoint As ConnectionPoint _
) As Boolean

Parameters

connectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.RemoveLinkFromNode Method

ConnectionPoint.RemoveLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overridable Sub RemoveLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.SameNode Method

ConnectionPoint.SameNode Method
[image]

Checks whether the current connection point and the specified connection point are associated with the same node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool SameNode (
ConnectionPoint otherConnectionPoint
)

Visual Basic [image] Copy Code

Public Overridable Function SameNode( _
otherConnectionPoint As ConnectionPoint _
) As Boolean

Parameters

otherConnectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.SaveEndRelative Method

ConnectionPoint.SaveEndRelative Method
[image]

Updates the coordinates of the connection point represented by this link, relative to the bounding rectangle of the associated node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overridable Sub SaveEndRelative ()

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.UpdateFromPoint Method

ConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void UpdateFromPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateFromPoint( _
point As Point _
)

Parameters

point

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint Properties

ConnectionPoint Properties
[image]

Public Properties

Name | Description
Node | Gets the node associated with this connection point.
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.

See Also

ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.Incoming Property

ConnectionPoint.Incoming Property
[image]

Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool Incoming { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Incoming As Boolean

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.Link Property

ConnectionPoint.Link Property
[image]

Gets the link associated with this connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramLink Link { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Link As DiagramLink

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.Node Property

ConnectionPoint.Node Property
[image]

Gets the node associated with this connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Node As DiagramNode

Property Value

Returns the node associated with this connection point.

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.RelativePosition Property

ConnectionPoint.RelativePosition Property
[image]

Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point RelativePosition { get; set; }

Visual Basic [image] Copy Code

Public Property RelativePosition As Point

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ConnectionPoint.Row Property

ConnectionPoint.Row Property
[image]

Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual int Row { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Row As Integer

Property Value

See Also

ConnectionPoint Members
ConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants Class

Constants Class
[image]

Contains various global constants, also provides measure unit independent constants.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class Constants

Visual Basic [image] Copy Code

Public NotInheritable Class Constants

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Constants

See Also

Constants Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants Members

Constants Members
Fields Methods
[image]

Contains various global constants, also provides measure unit independent constants.

The following tables list the members exposed by the Constants type.

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.

See Also

Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants Fields

Constants Fields
[image]

Public Fields

Name | Description
E | A very small positive real number (0.01).
IdentityMatrix | The identity matrix.
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

See Also

Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.E Field

Constants.E Field
[image]

A very small positive real number (0.01).

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double E

Visual Basic [image] Copy Code

Public Shared E As Double

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.IdentityMatrix Field

Constants.IdentityMatrix Field
[image]

The identity matrix.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Matrix IdentityMatrix

Visual Basic [image] Copy Code

Public Shared IdentityMatrix As Matrix

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.NoAnchorPattern Field

Constants.NoAnchorPattern Field
[image]

A constant indicating no anchor pattern during binary serialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int NoAnchorPattern

Visual Basic [image] Copy Code

Public Shared NoAnchorPattern As Integer

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants Methods

Constants Methods
[image]

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInch | Gets the size of one inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations.
GetMarkSize | Gets the size of an anchor point mark.
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollerWdt | Gets the width of the scroller manipulator icon.
GetSelPtTest | Gets a relax value used during selection handles hit-testing.
GetTableHeaderOffset | Gets the width of a header row icon.

See Also

Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetAutoScroll Method

Constants.GetAutoScroll Method
[image]

Gets the number of units to scroll the control during autoscrolling operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetAutoScroll (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetAutoScroll( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetContainerFolderPadding Method

Constants.GetContainerFolderPadding Method
[image]

Gets the padding around the folding button of a container node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetContainerFolderPadding (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetContainerFolderPadding( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetExpandIconSize Method

Constants.GetExpandIconSize Method
[image]

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetExpandIconSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetExpandIconSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetFitTextStep Method

Constants.GetFitTextStep Method
[image]

Gets a value used when fitting the size of a node to its contained text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetFitTextStep (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetFitTextStep( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetHalfInch Method

Constants.GetHalfInch Method
[image]

Gets the size of a half inch.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetHalfInch (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetHalfInch( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetInch Method

Constants.GetInch Method
[image]

Gets the size of one inch.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetInch (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetInch( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetInflation Method

Constants.GetInflation Method
[image]

Gets a relax value used when testing object intersections.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetInflation (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetInflation( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetLineHitTest Method

Constants.GetLineHitTest Method
[image]

Gets a value specifying relative distance from an arrow used during hit-testing operations.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetLineHitTest (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetLineHitTest( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetMarkSize Method

Constants.GetMarkSize Method
[image]

Gets the size of an anchor point mark.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetMarkSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMarkSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetMillimeter Method

Constants.GetMillimeter Method
[image]

Gets the size of one millimeter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetMillimeter (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMillimeter( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetMinArrowheadSize Method

Constants.GetMinArrowheadSize Method
[image]

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetMinArrowheadSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinArrowheadSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetMinItemSize Method

Constants.GetMinItemSize Method
[image]

Gets the minimum size for a diagram node that can be achieved interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetMinItemSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinItemSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetPixel Method

Constants.GetPixel Method
[image]

Gets the size of one pixel.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetPixel (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetPixel( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetReflHth Method

Constants.GetReflHth Method
[image]

Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetReflHth (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflHth( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetReflWth2 Method

Constants.GetReflWth2 Method
[image]

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetReflWth2 (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflWth2( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetRoundRectArc Method

Constants.GetRoundRectArc Method
[image]

Gets the radius of the arc of the rounded rectangle node shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetRoundRectArc (
GraphicsUnit currUnit,
double factor
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRectArc( _
currUnit As GraphicsUnit, _
factor As Double _
) As Double

Parameters

currUnit

factor

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetRouteGridSize Method

Constants.GetRouteGridSize Method
[image]

Gets the default size of the link routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetRouteGridSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetRouteGridSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetScrollerWdt Method

Constants.GetScrollerWdt Method
[image]

Gets the width of the scroller manipulator icon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetScrollerWdt (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetScrollerWdt( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetSelPtTest Method

Constants.GetSelPtTest Method
[image]

Gets a relax value used during selection handles hit-testing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetSelPtTest (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetSelPtTest( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Constants.GetTableHeaderOffset Method

Constants.GetTableHeaderOffset Method
[image]

Gets the width of a header row icon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetTableHeaderOffset (
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetTableHeaderOffset( _
unit As GraphicsUnit _
) As Double

Parameters

unit

Return Value

See Also

Constants Members
Constants Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs Class

ContainerChildEventArgs Class
[image]

Contains arguments passed to ContainerChildEventHandler,

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ContainerChildEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class ContainerChildEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.NodeEventArgs
MindFusion.Diagramming.Wpf.ContainerChildEventArgs

See Also

ContainerChildEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs Members

ContainerChildEventArgs Members
Constructors Properties Methods
[image]

Contains arguments passed to ContainerChildEventHandler,

The following tables list the members exposed by the ContainerChildEventArgs type.

Public Constructors

Name | Description
ContainerChildEventArgs | Initializes a new instance of the ContainerChildEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | The parent ContainerNode of the Node belongs.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs Constructor

ContainerChildEventArgs Constructor
[image]

Initializes a new instance of the ContainerChildEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerChildEventArgs (
ContainerNode container,
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode, _
node As DiagramNode _
)

Parameters

container

node

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs Methods

ContainerChildEventArgs Methods
[image]

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs.ToString Method

ContainerChildEventArgs.ToString Method
[image]

NodeEventArgs.ToString override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs Properties

ContainerChildEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | The parent ContainerNode of the Node belongs.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerChildEventArgs.Container Property

ContainerChildEventArgs.Container Property
[image]

The parent ContainerNode of the Node belongs.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode Container { get; set; }

Visual Basic [image] Copy Code

Public Property Container As ContainerNode

Property Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Class

ContainerNode Class
Remarks See Also
[image]

Implements nodes that can contain other nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ContainerNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ContainerNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Users can drag nodes into a container interactively. When a dragged node is over a container, the container frame is painted using the HighlightPen property to indicate that the node would be added to the container.

Use the Add method to add a node to container programmatically. Use the Remove method to remove a node from the container. The GetContainer static method returns the container that contains a node.
AutoShrink specifies whether the size of a container should shrink when a node is removed from it. The container node will not shrink to a size smaller than MinimumSize, even if it does not contain any items.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties.

The Caption property specifies the caption text of a container node, and CaptionBrush specifies its brush. Use the CaptionFormat property to define the alignment and position of the caption text. The height of the caption area of a container can be set using the CaptionHeight property. The caption area can be optionally filled in a different color by setting CaptionBackBrush.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.ContainerNode

See Also

ContainerNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Members

ContainerNode Members
Constructors Fields Properties Methods
[image]

Implements nodes that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Overloaded. Initializes a new instance of the ContainerNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this container.
CaptionBrush | Gets or sets the brush with which container's caption text is rendered.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CornerRadius | Gets or sets the radius of node's corners when Shape is set to RoundedRectangle.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Overloaded. Adds a node to this container.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the container on the specified DrawingContext surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateBounds | Overloaded.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramNode.OnRemove override.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Fields

ContainerNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.CaptionBackBrushProperty Field

ContainerNode.CaptionBackBrushProperty Field
[image]

Identifies the CaptionBackBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionBackBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionBackBrushProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.CaptionHeightProperty Field

ContainerNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared CaptionHeightProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.CornerRadiusProperty Field

ContainerNode.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared CornerRadiusProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.ShapeProperty Field

ContainerNode.ShapeProperty Field
[image]

Identifies the Shape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ShapeProperty As DependencyProperty

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Constructor

ContainerNode Constructor
[image]

Initializes a new instance of the ContainerNode class.

Overload List

Name | Description
ContainerNode () | Initializes a new instance of the ContainerNode class.
ContainerNode (ContainerNode) | Initializes a new instance of the ContainerNode class using the specified node as a prototype.
ContainerNode (Diagram) | Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

See Also

ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Constructor ()

ContainerNode Constructor ()
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Constructor (ContainerNode)

ContainerNode Constructor (ContainerNode)
See Also
[image]

Initializes a new instance of the ContainerNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode (
ContainerNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ContainerNode _
)

Parameters

prototype

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Constructor (Diagram)

ContainerNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

See Also

ContainerNode Constructor Overload List
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode Methods

ContainerNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Overloaded. Adds a node to this container.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the container on the specified DrawingContext surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateBounds | Overloaded.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified.
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramNode.OnRemove override.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Add Method

ContainerNode.Add Method
[image]

Adds a node to this container.

Overload List

Name | Description
ContainerNode.Add (DiagramNode) | Adds a node to this container.
ContainerNode.Add (DiagramNode, AttachToNode) | Adds a node to this container.
ContainerNode.Add (DiagramNode, GroupAnchorStyles) | Adds a node to this container.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Add Method (DiagramNode)

ContainerNode.Add Method (DiagramNode)
See Also
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Add( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that should be added to the container.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Remove Method


MindFusion.Diagramming.Wpf.ContainerNode.Add Method (DiagramNode, AttachToNode)

ContainerNode.Add Method (DiagramNode, AttachToNode)
See Also
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
DiagramNode node,
AttachToNode attachType
)

Visual Basic [image] Copy Code

Public Sub Add( _
node As DiagramNode, _
attachType As AttachToNode _
)

Parameters

node

The DiagramNode that should be added to the container.

attachType

An element of the AttachToNode enumeration.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

The attachType argument lets you associate the child node with a side or corner of the container, so the child moves or resizes along with the container when users modify the latter.

See Also

Add Method Overload List
ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Add Method (DiagramNode, GroupAnchorStyles)

ContainerNode.Add Method (DiagramNode, GroupAnchorStyles)
See Also
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
DiagramNode node,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public Sub Add( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
)

Parameters

node

The DiagramNode that should be added to the container.

anchorStyles

A combination of GroupAnchorStyles enum values.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

The anchorStyles argument lets you anchor the child node to a respective side or corner of the container, so the child moves or resizes along with the container when users modify the latter.

See Also

Add Method Overload List
ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.ContainsRecursively Method

ContainerNode.ContainsRecursively Method
[image]

Determines whether this container contains the specified node, either directly or recursively through other containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ContainsRecursively (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function ContainsRecursively( _
node As DiagramNode _
) As Boolean

Parameters

node
The DiagramNode to check.

Return Value

true if this container contains the node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.CreateProperties Method

ContainerNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

An instance of the DiagramItemProperties class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.DrawLocal Method

ContainerNode.DrawLocal Method
[image]

Draws the container on the specified DrawingContext surface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A .NET DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.EnumStyleableProperties Method

ContainerNode.EnumStyleableProperties Method
[image]

DiagramItem.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.GetContainer Method

ContainerNode.GetContainer Method
[image]

Retrieves the container node (if any) the specified node belongs to.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode GetContainer (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Shared Function GetContainer( _
node As DiagramNode _
) As ContainerNode

Parameters

node
The DiagramNode whose container you need to find.

Return Value

A ContainerNode that contains the specified node, or null (Nothing in Visual Basic) if the node is not contained.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.HitTest Method

ContainerNode.HitTest Method
[image]

DiagramItem.HitTest override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DiagramItem HitTest (
Point point,
double threshold,
bool onlyNodes,
bool onlyInteractive
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
point As Point, _
threshold As Double, _
onlyNodes As Boolean, _
onlyInteractive As Boolean _
) As DiagramItem

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.HitTestHandle Method

ContainerNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

An AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.LoadFromXml Method

ContainerNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnChildModified Method

ContainerNode.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnChildModified( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node
The DiagramNode that has been moved or resized.
handle

The adjustment handle used to modify the node.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnDragOut Method

ContainerNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Sub OnDragOut( _
item As DiagramItem _
)

Parameters

item
The DiagramItem being dragged.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnDragOver Method

ContainerNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem being dragged.

Return Value

true if the drag operation will be handled by this node; otherwise, false.

Remarks

If this method returns true, no other nodes will receive the notification.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnDropOver Method

ContainerNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDropOver( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem being dragged.

Return Value

true if the drop operation will be handled by this node; otherwise, false.

Remarks

If this method returns true, no other nodes will receive the notification.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnLoad Method

ContainerNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.OnRemove Method

ContainerNode.OnRemove Method
[image]

DiagramNode.OnRemove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Remove Method

ContainerNode.Remove Method
[image]

Removes a node from this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Remove( _
node As DiagramNode _
)

Parameters

node
The DiagramNode that should be removed from the container.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Add Method


MindFusion.Diagramming.Wpf.ContainerNode.RestoreProperties Method

ContainerNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.SaveProperties Method

ContainerNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.SaveToXml Method

ContainerNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.ScaleElements Method

ContainerNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.UpdateBounds Method

ContainerNode.UpdateBounds Method
[image]

Overload List

Name | Description
ContainerNode.UpdateBounds () | Updates the container bounds to fit its contents.
ContainerNode.UpdateBounds (Boolean) | Updates the container bounds to fit its contents.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.UpdateBounds Method ()

ContainerNode.UpdateBounds Method ()
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateBounds ()

Visual Basic [image] Copy Code

Public Sub UpdateBounds ()

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.UpdateBounds Method (Boolean)

ContainerNode.UpdateBounds Method (Boolean)
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateBounds (
bool includeLinks
)

Visual Basic [image] Copy Code

Public Sub UpdateBounds( _
includeLinks As Boolean _
)

Parameters

includeLinks
true to include the area occupied by links between contained nodes; otherwise, false.

Remarks

This methods calculates the union of the bounding rectangles of all child nodes, and optionally links between them, and sets it as a new Bounds value.

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
AutoShrink Property


MindFusion.Diagramming.Wpf.ContainerNode Properties

ContainerNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this container.
CaptionBrush | Gets or sets the brush with which container's caption text is rendered.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CornerRadius | Gets or sets the radius of node's corners when Shape is set to RoundedRectangle.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether the container is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.AllowAddChildren Property

ContainerNode.AllowAddChildren Property
[image]

Gets or sets a value indicating whether child nodes can be added interactively to this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowAddChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAddChildren As Boolean

Property Value

true to allow adding child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
AllowRemoveChildren Property


MindFusion.Diagramming.Wpf.ContainerNode.AllowRemoveChildren Property

ContainerNode.AllowRemoveChildren Property
[image]

Gets or sets a value indicating whether child nodes can be removed interactively from this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowRemoveChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRemoveChildren As Boolean

Property Value

true to allow removing child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
AllowAddChildren Property


MindFusion.Diagramming.Wpf.ContainerNode.AutoShrink Property

ContainerNode.AutoShrink Property
[image]

Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoShrink { get; set; }

Visual Basic [image] Copy Code

Public Property AutoShrink As Boolean

Property Value

true if the container should shrink automatically; otherwise, false. The default is false.

Remarks

The container won't shrink to a size smaller than MinimumSize.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
MinimumSize Property
UpdateBounds Method


MindFusion.Diagramming.Wpf.ContainerNode.Caption Property

ContainerNode.Caption Property
[image]

Gets or sets the container caption text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the container's caption text.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
CaptionBrush Property
CaptionHeight Property


MindFusion.Diagramming.Wpf.ContainerNode.CaptionBackBrush Property

ContainerNode.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush object used to paint the interior of the caption area. You can assign to it an instance of one of the following classes: GradientBrush, SolidColorBrush or TileBrush, located in the System.Windows.Media namespace. If there is no brush assigned to this property, the caption area is painted using the Brush property of the ContainerNode class.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Caption Property
CaptionBrush Property
CaptionHeight Property


MindFusion.Diagramming.Wpf.ContainerNode.CaptionBrush Property

ContainerNode.CaptionBrush Property
[image]

Gets or sets the brush with which container's caption text is rendered.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a .NET Brush-derived class. The default is Brushes.Black.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Caption Property
CaptionHeight Property
CaptionBackBrush Property


MindFusion.Diagramming.Wpf.ContainerNode.CaptionFormat Property

ContainerNode.CaptionFormat Property
[image]

Gets or sets the caption alignment and format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

This property has been deprecated. Set the TextAlignment and TextVerticalAlignment properties to specify text alignment.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Caption Property
CaptionHeight Property


MindFusion.Diagramming.Wpf.ContainerNode.CaptionHeight Property

ContainerNode.CaptionHeight Property
[image]

Gets or sets the height of the container's caption area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the height of the container caption.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Caption Property


MindFusion.Diagramming.Wpf.ContainerNode.CornerRadius Property

ContainerNode.CornerRadius Property
[image]

Gets or sets the radius of node's corners when Shape is set to RoundedRectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

A double value. The default is 12.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Foldable Property

ContainerNode.Foldable Property
[image]

Gets or sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Foldable { get; set; }

Visual Basic [image] Copy Code

Public Property Foldable As Boolean

Property Value

true if the container can be folded; otherwise, false. Initialized with the value of ContainersFoldable.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Folded Property


MindFusion.Diagramming.Wpf.ContainerNode.Folded Property

ContainerNode.Folded Property
[image]

Gets or sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Folded { get; set; }

Visual Basic [image] Copy Code

Public Property Folded As Boolean

Property Value

true if the container is folded; otherwise, false. The default is false.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
Foldable Property


MindFusion.Diagramming.Wpf.ContainerNode.HighlightPen Property

ContainerNode.HighlightPen Property
[image]

Gets or sets the pen used to draw the container frame lines when an item is dragged over the container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen HighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightPen As Pen

Property Value

An instance of the .NET Pen class. Initialized with the value of ContainerHighlightPen.

Remarks

The highlight rectangle is not drawn when AllowAddChildren is disabled.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Margin Property

ContainerNode.Margin Property
[image]

Gets or sets how much space should be left between contained nodes and the container borders.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new double Margin { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Margin As Double

Property Value

A double value specifying the margin size. Initialized with the value of ContainerMargin.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
AutoShrink Property


MindFusion.Diagramming.Wpf.ContainerNode.MinimumSize Property

ContainerNode.MinimumSize Property
[image]

Gets or sets the minimum size of the container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size MinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumSize As Size

Property Value

A .NET Size object specifying the minimum size. Initialized with the value of ContainerMinimumSize.

Remarks

The container won't shrink smaller than that size, even if it does not contain any items.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace
AutoShrink Property


MindFusion.Diagramming.Wpf.ContainerNode.Shape Property

ContainerNode.Shape Property
[image]

Gets or sets the shape of the container's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default is Rectangle.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.UnfoldedSize Property

ContainerNode.UnfoldedSize Property
[image]

Returns the original size of a folded container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size UnfoldedSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UnfoldedSize As Size

Property Value

A Size object specifying what size the container had before it was folded.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNode.Visible Property

ContainerNode.Visible Property
[image]

Gets or sets a value indicating whether the container is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNodeProperties Class

ContainerNodeProperties Class
[image]

Stores the values of ContainerNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the ContainerNode.SaveProperties, ContainerNode.RestoreProperties, and ContainerNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ContainerNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ContainerNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.ContainerNodeProperties

See Also

ContainerNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNodeProperties Members

ContainerNodeProperties Members
Constructors Methods
[image]

Stores the values of ContainerNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the ContainerNode.SaveProperties, ContainerNode.RestoreProperties, and ContainerNode.CreateProperties methods.

The following tables list the members exposed by the ContainerNodeProperties type.

Public Constructors

Name | Description
ContainerNodeProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

ContainerNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainerNodeProperties Constructor

ContainerNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContainmentKeys Enumeration

ContainmentKeys Enumeration
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ContainmentKeys

Visual Basic [image] Copy Code

Public Enum ContainmentKeys

Members

Member name | Description
InContainer | Set for Group.Attachment objects for nodes in a container.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection Class

ContentCollection Class
[image]

Implements the Diagram.Content property, which allow defining diagram elements through XAML.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ContentCollection : IList, ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ContentCollection
Implements IList, ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ContentCollection

See Also

ContentCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection Members

ContentCollection Members
Constructors Properties Methods
[image]

Implements the Diagram.Content property, which allow defining diagram elements through XAML.

The following tables list the members exposed by the ContentCollection type.

Public Constructors

Name | Description
ContentCollection | Initializes a new instance of the ContentCollection class.

Public Properties

Name | Description
IsFixedSize | Gets a value indicating whether the list has a fixed size.
IsReadOnly | Gets a value indicating whether the list is read-only.
IsSynchronized | IList.IsSynchronized implementation.
Item | IList indexer implementation.
SyncRoot | IList.SyncRoot implementation.

Public Methods

Name | Description
Add | Adds the specified item to the collection.
Clear | Removes all items from the list.
Contains | Gets a value that indicates whether the item is a member of the collection.
CopyTo | IList.CopyTo implementation.
IndexOf | Gets the zero-based index of the item in the underlying collection.
Insert | Inserts an item into the list at the zero-based index specified.
Remove | Removes the specified item from the list.
RemoveAt | Removes the list item at the specified index.

Protected Methods

Name | Description
OnValidate | IList.OnValidate implementation.

See Also

ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection Constructor

ContentCollection Constructor
[image]

Initializes a new instance of the ContentCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContentCollection (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection Methods

ContentCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to the collection.
Clear | Removes all items from the list.
Contains | Gets a value that indicates whether the item is a member of the collection.
CopyTo | IList.CopyTo implementation.
IndexOf | Gets the zero-based index of the item in the underlying collection.
Insert | Inserts an item into the list at the zero-based index specified.
Remove | Removes the specified item from the list.
RemoveAt | Removes the list item at the specified index.

Protected Methods

Name | Description
OnValidate | IList.OnValidate implementation.

See Also

ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Add Method

ContentCollection.Add Method
[image]

Adds the specified item to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Add (
Object value
)

Visual Basic [image] Copy Code

Public Function Add( _
value As Object _
) As Integer

Parameters

value

An instance of DiagramItem or UIElement derived class.

Return Value

The zero-based index of the item that was just added.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Clear Method

ContentCollection.Clear Method
[image]

Removes all items from the list.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Contains Method

ContentCollection.Contains Method
[image]

Gets a value that indicates whether the item is a member of the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Object value
)

Visual Basic [image] Copy Code

Public Function Contains( _
value As Object _
) As Boolean

Parameters

value

The item to locate in the list.

Return Value

true if the specified item is in the collection; otherwise, false.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.CopyTo Method

ContentCollection.CopyTo Method
[image]

IList.CopyTo implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

index

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.IndexOf Method

ContentCollection.IndexOf Method
[image]

Gets the zero-based index of the item in the underlying collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
Object value
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
value As Object _
) As Integer

Parameters

value

The item to locate in the list.

Return Value

The zero-based index of the specified item in the collection.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Insert Method

ContentCollection.Insert Method
[image]

Inserts an item into the list at the zero-based index specified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
Object value
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
value As Object _
)

Parameters

index

The zero-based position of the insertion.

value

An instance of DiagramItem or UIElement derived class.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.OnValidate Method

ContentCollection.OnValidate Method
[image]

IList.OnValidate implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValidate (
Object value
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidate( _
value As Object _
)

Parameters

value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Remove Method

ContentCollection.Remove Method
[image]

Removes the specified item from the list.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Object value
)

Visual Basic [image] Copy Code

Public Sub Remove( _
value As Object _
)

Parameters

value

The item to remove from the list.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.RemoveAt Method

ContentCollection.RemoveAt Method
[image]

Removes the list item at the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the item to remove.

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection Properties

ContentCollection Properties
[image]

Public Properties

Name | Description
IsFixedSize | Gets a value indicating whether the list has a fixed size.
IsReadOnly | Gets a value indicating whether the list is read-only.
IsSynchronized | IList.IsSynchronized implementation.
Item | IList indexer implementation.
SyncRoot | IList.SyncRoot implementation.

See Also

ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.IsFixedSize Property

ContentCollection.IsFixedSize Property
[image]

Gets a value indicating whether the list has a fixed size.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsFixedSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsFixedSize As Boolean

Property Value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.IsReadOnly Property

ContentCollection.IsReadOnly Property
[image]

Gets a value indicating whether the list is read-only.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.IsSynchronized Property

ContentCollection.IsSynchronized Property
[image]

IList.IsSynchronized implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.Item Property

ContentCollection.Item Property
[image]

IList indexer implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Object

Parameters

index

Property Value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ContentCollection.SyncRoot Property

ContentCollection.SyncRoot Property
[image]

IList.SyncRoot implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

See Also

ContentCollection Members
ContentCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlMouseAction Enumeration

ControlMouseAction Enumeration
[image]

Specifies available ways to handle mouse clicks on .NET controls hosted in a ControlNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ControlMouseAction

Visual Basic [image] Copy Code

Public Enum ControlMouseAction

Members

Member name | Description
IgnoreControl | MindFusion.Diagramming for WPF tries to intercept the mouse message and not pass it to the control. That allows drawing links from anywhere within the control.
PassToControl | Let the control handle the mouse click. Do not select the host node.
SelectNode | The host node gets selected when the control is clicked. The control is left to handle the mouse click too.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs Class

ControlNodeEventArgs Class
[image]

Contains the arguments passes to handlers of the control host serialization events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ControlNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ControlNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.ControlNodeEventArgs

See Also

ControlNodeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs Members

ControlNodeEventArgs Members
Properties
[image]

Contains the arguments passes to handlers of the control host serialization events.

The following tables list the members exposed by the ControlNodeEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | Gets a stream object where you can store or retrieve any custom information.

See Also

ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs Properties

ControlNodeEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Node | Gets a reference to the ControlNode being serialized or deserialized.
XmlElement | Gets a stream object where you can store or retrieve any custom information.

See Also

ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs.Context Property

ControlNodeEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs.Handled Property

ControlNodeEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs.Node Property

ControlNodeEventArgs.Node Property
[image]

Gets a reference to the ControlNode being serialized or deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeAdapter Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNodeAdapter

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlNodeEventArgs.XmlElement Property

ControlNodeEventArgs.XmlElement Property
[image]

Gets a stream object where you can store or retrieve any custom information.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement XmlElement { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlElement As XmlElement

Property Value

See Also

ControlNodeEventArgs Members
ControlNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs Class

ControlPointEventArgs Class
[image]

Contains arguments passed to handlers of the ShapeModified event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ControlPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ControlPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.ControlPointEventArgs

See Also

ControlPointEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs Members

ControlPointEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the ShapeModified event.

The following tables list the members exposed by the ControlPointEventArgs type.

Public Constructors

Name | Description
ControlPointEventArgs | Initializes a new instance of the ControlPointEventArgs class.

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint used to modify the node's shape.
NewValue | Gets or sets the new position of the control point.
Node | Gets or sets the ShapeNode whose Shape has been modified.
OldValue | Gets or sets the original position of the control point.

See Also

ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs Constructor

ControlPointEventArgs Constructor
[image]

Initializes a new instance of the ControlPointEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ControlPointEventArgs (
ShapeControlPoint controlPoint,
ShapeNode node,
ShapeFormulaParam oldValue,
ShapeFormulaParam newValue
)

Visual Basic [image] Copy Code

Public New ( _
controlPoint As ShapeControlPoint, _
node As ShapeNode, _
oldValue As ShapeFormulaParam, _
newValue As ShapeFormulaParam _
)

Parameters

controlPoint

The ShapeControlPoint used to modify the node's shape.

node

The ShapeNode whose Shape has been modified.

oldValue

A ShapeFormulaParam specifying the original position of the control point.

newValue

A ShapeFormulaParam specifying the new position of the control point.

See Also

ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs Properties

ControlPointEventArgs Properties
[image]

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint used to modify the node's shape.
NewValue | Gets or sets the new position of the control point.
Node | Gets or sets the ShapeNode whose Shape has been modified.
OldValue | Gets or sets the original position of the control point.

See Also

ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs.ControlPoint Property

ControlPointEventArgs.ControlPoint Property
[image]

Gets or sets the ShapeControlPoint used to modify the node's shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeControlPoint ControlPoint { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoint As ShapeControlPoint

Property Value

An instance of the ShapeControlPoint class.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs.NewValue Property

ControlPointEventArgs.NewValue Property
[image]

Gets or sets the new position of the control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam NewValue { get; set; }

Visual Basic [image] Copy Code

Public Property NewValue As ShapeFormulaParam

Property Value

An instance of the ShapeFormulaParam class.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs.Node Property

ControlPointEventArgs.Node Property
[image]

Gets or sets the ShapeNode whose Shape has been modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As ShapeNode

Property Value

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlPointEventArgs.OldValue Property

ControlPointEventArgs.OldValue Property
[image]

Gets or sets the original position of the control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam OldValue { get; set; }

Visual Basic [image] Copy Code

Public Property OldValue As ShapeFormulaParam

Property Value

An instance of the ShapeFormulaParam class.

See Also

ControlPointEventArgs Members
ControlPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter Class

ControlVisibilityConverter Class
[image]

Converts boolean property values to Visibility values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ControlVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ControlVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ControlVisibilityConverter

See Also

ControlVisibilityConverter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter Members

ControlVisibilityConverter Members
Constructors Methods
[image]

Converts boolean property values to Visibility values.

The following tables list the members exposed by the ControlVisibilityConverter type.

Public Constructors

Name | Description
ControlVisibilityConverter |

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

ControlVisibilityConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter Constructor

ControlVisibilityConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ControlVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ControlVisibilityConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter Methods

ControlVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

ControlVisibilityConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter.Convert Method

ControlVisibilityConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

ControlVisibilityConverter Members
ControlVisibilityConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ControlVisibilityConverter.ConvertBack Method

ControlVisibilityConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo l
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
l As CultureInfo _
) As Object

Parameters

value

targetType

parameter

l

Return Value

See Also

ControlVisibilityConverter Members
ControlVisibilityConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Converter

See Also

Converter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Color.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to Color.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromImage (
BitmapSource val
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As BitmapSource _
) As String

Parameters

val

The image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Overload List

Name | Description
Converter.FromSingle (Double) | Converts the specified double value to string.
Converter.FromSingle (Single) | Converts the specified float value to string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromSingle Method (Double)

Converter.FromSingle Method (Double)
See Also
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromSingle Method (Single)

Converter.FromSingle Method (Single)
See Also
[image]

Converts the specified float value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

FromSingle Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.FromXmlElement Method

Converter.FromXmlElement Method
[image]

Deserializes a Point object from the specified XmlElement.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point FromXmlElement (
XmlElement point
)

Visual Basic [image] Copy Code

Public Shared Function FromXmlElement( _
point As XmlElement _
) As Point

Parameters

point

The XmlElement representing the serialized point.

Return Value

A Point object deserialized from the specified XmlElement.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ImageFromString Method

Converter.ImageFromString Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static BitmapFrame ImageFromString (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ImageFromString( _
s As String _
) As BitmapFrame

Parameters

s

The string value to convert from.

Return Value

An instance of the WPF BitmapFrame class that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToBrush Method

Converter.ToBrush Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Brush ToBrush (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBrush( _
s As String _
) As Brush

Parameters

s

The string value to convert from.

Return Value

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specifed string value to double.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static BitmapSource ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As BitmapSource

Parameters

s

The string value to convert from.

Return Value

A .NET Image object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToImageV4 Method

Converter.ToImageV4 Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static BitmapSource ToImageV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImageV4( _
s As String _
) As BitmapSource

Parameters

s

The string value to convert from.

Return Value

A .NET BitmapSource object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs Class

CopyHostedControlEventArgs Class
[image]

Contains the arguments passes to the CopyHostedControl event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CopyHostedControlEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CopyHostedControlEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs

See Also

CopyHostedControlEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs Members

CopyHostedControlEventArgs Members
Properties
[image]

Contains the arguments passes to the CopyHostedControl event handlers.

The following tables list the members exposed by the CopyHostedControlEventArgs type.

Public Properties

Name | Description
Destination | Gets a reference to the control embedded in the cloned ControlNode.
Source | Gets a reference to the control embedded in the original ControlNode.

See Also

CopyHostedControlEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs Properties

CopyHostedControlEventArgs Properties
[image]

Public Properties

Name | Description
Destination | Gets a reference to the control embedded in the cloned ControlNode.
Source | Gets a reference to the control embedded in the original ControlNode.

See Also

CopyHostedControlEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs.Destination Property

CopyHostedControlEventArgs.Destination Property
[image]

Gets a reference to the control embedded in the cloned ControlNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UIElement Destination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Destination As UIElement

Property Value

See Also

CopyHostedControlEventArgs Members
CopyHostedControlEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CopyHostedControlEventArgs.Source Property

CopyHostedControlEventArgs.Source Property
[image]

Gets a reference to the control embedded in the original ControlNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UIElement Source { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Source As UIElement

Property Value

See Also

CopyHostedControlEventArgs Members
CopyHostedControlEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CreateImageCallback Delegate

CreateImageCallback Delegate
[image]

Loads an image from a stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate ImageSource CreateImageCallback (
Stream stream
)

Visual Basic [image] Copy Code

Public Delegate Function CreateImageCallback( _
stream As Stream _
) As ImageSource

Parameters

stream

The stream representing the image.

Return Value

The loaded image.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CreatePathDelegate Delegate

CreatePathDelegate Delegate
[image]

Specifies the signature of callback functions used to generate dynamic node shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate PathGeometry CreatePathDelegate (
ShapeData shapeData
)

Visual Basic [image] Copy Code

Public Delegate Function CreatePathDelegate( _
shapeData As ShapeData _
) As PathGeometry

Parameters

shapeData
An instance of the ShapeData class.

Return Value

A PathGeometry specifying the shape outline or decorations.

Remarks

Functions that implement this delegate can be passed as arguments to the Shape constructor.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CursorHint Enumeration

CursorHint Enumeration
[image]

Specifies what mouse cursor to display while a user interacts with the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum CursorHint

Visual Basic [image] Copy Code

Public Enum CursorHint

Members

Member name | Description
AllowLink | Indicates the cursor specified by the AllowLinkCursor property.
CounterDiagonalResize | Indicates the cursor specified by the CounterDiagonalResizeCursor property.
DiagonalResize | Indicates the cursor specified by the DiagonalResizeCursor property.
Disallow | Indicates the cursor specified by the DisallowCursor property.
DisallowLink | Indicates the cursor specified by the DisallowLinkCursor property.
DontChange | Indicates the cursor specified by the Cursor property.
DrawLink | Indicates the cursor specified by the DrawLinkCursor property.
HorizontalResize | Indicates the cursor specified by the HorizontalResizeCursor property.
Move | Indicates the cursor specified by the MoveCursor property.
Pointer | Indicates the cursor specified by the PointerCursor property.
Rotate | Indicates the cursor specified by the RotateCursor property.
VerticalResize | Indicates the cursor specified by the VerticalResizeCursor property.

Remarks

These values can be assigned to the CustomDraw property of shapes, tables and links.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CustomCursors Class

CustomCursors Class
[image]

Provides a collection of cursor object to use with the Diagram control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class CustomCursors

Visual Basic [image] Copy Code

Public NotInheritable Class CustomCursors

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CustomCursors

See Also

CustomCursors Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CustomCursors Members

CustomCursors Members
Properties
[image]

Provides a collection of cursor object to use with the Diagram control.

The following tables list the members exposed by the CustomCursors type.

Public Properties

Name | Description
Rotate | Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

See Also

CustomCursors Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CustomCursors Properties

CustomCursors Properties
[image]

Public Properties

Name | Description
Rotate | Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

See Also

CustomCursors Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CustomCursors.Rotate Property

CustomCursors.Rotate Property
[image]

Gets the cursor, which is displayed when the mouse is positioned over the rotation handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Cursor Rotate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Rotate As Cursor

Property Value

See Also

CustomCursors Members
CustomCursors Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.CustomDraw Enumeration

CustomDraw Enumeration
[image]

Specifies what kind of custom painting to perform on diagram elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum CustomDraw

Visual Basic [image] Copy Code

Public Enum CustomDraw

Members

Member name | Description
Additional | The custom painting code executes after item's interior and frame are painted by MindFusion.Diagramming for WPF, but before text is rendered. In this mode, the DrawingContext instance passed to the custom drawing event handler has a clipping region applied to it.
Additional2 | The custom painting code executes after all parts of an item are painted by MindFusion.Diagramming for WPF. In this mode, the DrawingContext instance passed to the custom drawing event handler doesn't have a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of an item is done by the application.
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for WPF.

Remarks

These values can be assigned to the CustomDraw property of shapes, tables and links.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DelKeyAction Enumeration

DelKeyAction Enumeration
[image]

Specifies the type of action performed when the user presses the DEL key.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum DelKeyAction

Visual Basic [image] Copy Code

Public Enum DelKeyAction

Members

Member name | Description
DeleteActiveItem | Indicates that only the ActiveItem is deleted.
DeleteSelectedItems | Indicates that all selected items are deleted.
None | Indicates that nothing happens.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Class

Diagram Class
Remarks See Also
[image]

The Diagram control lets you create and visualize flow diagrams, representing hierarchical or relational data by means of graph nodes and links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Diagram : DiagramBase, IItemFactory, IZoomTarget

Visual Basic [image] Copy Code

Public Class Diagram
Inherits DiagramBase
Implements IItemFactory, IZoomTarget

Remarks

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the Nodes collection. Links in MindFusion.Diagramming for WPF are instances of the DiagramLink class and are stored in the Links collection. Diagram items can be grouped in hierarchical structures and the so formed groups can be accessed by means of the Groups collection.

Managing items

Items can be created by using the new operator and added to the diagram by means of the Add method of the Nodes or Links collection. Items are deleted by using the Remove method of the respective collection. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. Use the CreateTableNode, CreateShapeNode and CreateDiagramLink factory methods to create new items of the respective type.

Hierarchical groups of items are created by adding a Group instance to the diagram's Groups collection. The Factory object provides a shortcut CreateGroup method to do that with a single method call. Use the Remove method of the Groups collection to destroy a group.

Searching for a particular kind of items is done with the FindLink, FindNode and FindGroup methods, which look for an item that has a particular Tag. To get the item placed at a certain location, use the GetItemAt method.

Serialization

Binary serialization of diagrams is provided by the SaveToStream and LoadFromStream methods which serialize diagrams to / from .NET streams. SaveToFile and LoadFromFile wrap their stream counterparts to implement easy serialization to disk files. SaveToString and LoadFromString store or load diagrams to/from ASCII strings, allowing easy storage of whole diagrams in a database or their transfer between a web-server and a browser through a hidden html element.

Use the SaveToXml and LoadFromXml methods to serialize a diagram into/from XML documents.

User interaction

How the component interprets users actions depends mostly on the Behavior property. It specifies whether to create, select or modify diagram items in various contexts. There are several built-in modes defined in the Behavior enumeration that can be assigned to that property. It is also possible to implement a custom interaction mode in a class derived from BehaviorBase, and assign its instance to the CustomBehavior property.

Some operations on the diagram can be bound to mouse buttons or keyboard modifier keys by setting the RightButtonActions, MiddleButtonActions and ModifierKeyActions properties.

Modification of existing items can be customized by setting the ModificationStart property, which specifies how the user can start moving or resizing an item, and ModificationEffect, which specifies what visual effect to apply on items that are being modified.

Alignment

Items are aligned to a grid when AlignToGrid is enabled. To display the grid, set ShowGrid to true. The grid size and appearance can be customized via the GridSizeX, GridSizeY, GridPen and GridStyle properties.

If AutoAlignNodes is enabled, nodes are aligned to other nodes so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Links can also automatically snap to nodes when AutoSnapLinks is set. The maximal distance at which links will connect to a nearby node is set via AutoSnapDistance.

Validation

Users actions can be validated by handling various events raised while items are being created (LinkCreating and NodeCreating), modified (LinkModifying and NodeModifying) or deleted (LinkDeleting and NodeDeleting).

The following properties control what kind of links users can create: AllowLinksRepeat, AllowSelfLoops, AllowUnanchoredLinks, AllowUnconnectedLinks. To specify whether users are allowed to edit the text of nodes by double-clicking, set AllowInplaceEdit. The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority.

Appearance

The Diagram background area can be painted using a solid, gradient, texture or color brush, by setting the BackBrush property, and/or using an image specified by BackgroundImage and BackgroundImageAlign.

Text formatting

Use TextFormat and TextBrush to specify alignment and color of the text for all diagram items. EnableStyledText allows using HTML-like tags to format item's text. PolygonalTextLayout allows laying text out inside non-rectangular node shapes.

Tweaks

  • While moving grouped items, they are drawn in depth conforming to either their z-order or their group hierarchy, as set in SortGroupsByZ.
  • SelectionOnTop specifies whether selected items should be painted on top of other items.
  • MergeThreshold specifies how closely one to another adjacent link points should be placed in order to merge link segments.

Default item properties

Many properties of the Diagram class provide initial values for the properties of new items. They are listed here.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramBase
MindFusion.Diagramming.Wpf.Diagram
MindFusion.Diagramming.Wpf.DiagramPage
MindFusion.Diagramming.Wpf.VirtualizingDiagram

See Also

Diagram Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Members

Diagram Members
Constructors Fields Attached Properties Properties Methods Events
[image]

The Diagram control lets you create and visualize flow diagrams, representing hierarchical or relational data by means of graph nodes and links.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | Initializes a new instance of the Diagram class.

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property.
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property.
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property.
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property.
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property.
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node.
DefaultShapeProperty | Identifies the DefaultShape dependency property.
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property.
Dummy | A shared DummyNode instance.
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property.
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property.
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property.
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property.
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property.
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property.
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property.
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property.
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property.
LinkTextProperty | Identifies the LinkText dependency property.
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property.
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property.
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property.
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property.
MeasureUnitProperty | Identifies the MeasureUnit dependency property.
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item
NavigateRight | Selects the diagram item that stands to the right of the currently selected item
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property.
NodeTemplateProperty | Identifies the NodeTemplate dependency property.
RotationStepProperty | Identifies the RotationStep dependency property.
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property.
ShapeTextProperty | Identifies the ShapeText dependency property.
TableBrushProperty | Identifies the TableBrush dependency property.
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property.
TableCaptionProperty | Identifies the TableCaption dependency property.
TableColumnCountProperty | Identifies the TableColumnCount dependency property.
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property.
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property.
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property.
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property.
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property.
TableRowCountProperty | Identifies the TableRowCount dependency property.
TableRowHeightProperty | Identifies the TableRowHeight dependency property.
TableShapeProperty | Identifies the TableShape dependency property.
TablesScrollableProperty | Identifies the TablesScrollable dependency property.
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Attached Properties

Name | Description
IsDiagramScrollerProperty | Gets or sets a value indicating whether a ScrollViewer should be associated as a scroller for an underlying diagram.

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes.
Behavior | Gets or sets a value indicating how the control responds to user actions.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets or sets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
Content | With this property, you can define diagram elements from XAML code.
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input.
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing.
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items.
DefaultShape | Gets or sets the default shape of shape nodes.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
DiagramLinkStyle | Gets or sets the theme-level style for diagram links.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location.
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.
DocumentPlane | Gets the document plane of the diagram.
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EnableLanes | Gets or sets whether lanes are enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
Font | Gets or sets the default font for new diagram items.
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridPen | Gets or sets the pen used to draw the grid lines or points.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text.
InplaceEditFont | Gets or sets the font of the inplace-editing text box.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control.
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default shape of diagram links.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool.
MagnifierHeight | Gets or sets the height of the magnifier tool.
MagnifierStyle | Gets or sets the style of the magnifier tool.
MagnifierWidth | Gets or sets the width of the magnifier tool.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items.
ModificationStart | Gets or sets how users can start modifying diagram items.
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view.
PanInertia | Gets or sets a value indicating whether panning the view will have inertia.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RemoveHiddenItemsFromVisualTree | For internal use.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle.
RotationStep | Gets or sets the RotationAngle increment when users rotate a node.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets or sets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default shape of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
TextBrush | Gets or sets the default brush of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.
Viewport | Returns the visible portion of the diagram area.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram.

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.
VisualChildrenCount | Visual.VisualChildrenCount override.

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
BeginEdit | Overloaded.
BeginInit | FrameworkElement.BeginInit override.
BringIntoView | Overloaded. Scrolls the diagram area to make the specified item visible.
CancelDrag | Cancels the current drag operation.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
ClientToDoc | Overloaded.
Compact | Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions.
CopySelection | Creates a copy of the currently selected objects and groups.
CopyToClipboard | Overloaded.
CreateImage | Overloaded.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard.
DocToClient | Overloaded.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
EndEdit | Exits in-place editing mode and either accepts or rejects the changes made to the item's text.
EndInit | FrameworkElement.EndInit override.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetDiagramItem | Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement.
GetIsDiagramScroller | Gets the value of the IsDiagramScroller attached property from a given element.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetItemBounds | Retrieves the bounding rectangle of the specified item within the current diagram.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
GetNodesInViewport | Returns all nodes visible in the current viewport.
HandleMouseMove | Propagates mouse input to interested manipulators.
HitTestManipulators | Tests whether the specified point is within a manipulator of a diagram element.
Invalidate | Invalidates the specified rectangle of the diagram, causing it to be repainted.
InvalidateBackground | Repaints the diagram background, and raises the DrawBackground event for custom drawing.
InvalidateForeground | Repaints the diagram foreground, and raises the DrawForeground event for custom drawing.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.
PasteFromClipboard | Overloaded.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
Print | Displays a Print dialog and prints the diagram.
PrintPreview | Overloaded. Displays the diagram in a Print Preview window.
RaiseCellTextEdited | Raises the CellTextEdited event.
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event.
RaiseLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode.
RaiseLinkTextEdited | Overloaded.
RaiseLinkTextEditing | Overloaded.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate *Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RegisterClass | Registers a class for serialization support.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
ScrollTo | Scrolls the document to the specified point.
SetIsDiagramScroller | Sets the value of the IsDiagramScroller attached property to a given element.
SetItemBounds | Sets the location and size of the specified item within the current diagram.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.
UpdateRuntimeIndices | For internal use.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area.
ZoomToRect | Overloaded. Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
DrawGrid | Renders the diagram grid.
GetVisualChild | Visual.GetVisualChild override.
MeasureOverride | Control.MeasureOverride override.
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnDrop | Handles dropping of DraggedNode instances
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnVisualParentChanged | FrameworkElement.OnVisualParentChanged override.
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Fields

Diagram Fields
[image]

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property.
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property.
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property.
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property.
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property.
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node.
DefaultShapeProperty | Identifies the DefaultShape dependency property.
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property.
Dummy | A shared DummyNode instance.
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property.
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property.
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property.
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property.
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property.
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property.
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property.
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property.
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property.
LinkTextProperty | Identifies the LinkText dependency property.
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property.
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property.
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property.
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property.
MeasureUnitProperty | Identifies the MeasureUnit dependency property.
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item
NavigateRight | Selects the diagram item that stands to the right of the currently selected item
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property.
NodeTemplateProperty | Identifies the NodeTemplate dependency property.
RotationStepProperty | Identifies the RotationStep dependency property.
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property.
ShapeTextProperty | Identifies the ShapeText dependency property.
TableBrushProperty | Identifies the TableBrush dependency property.
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property.
TableCaptionProperty | Identifies the TableCaption dependency property.
TableColumnCountProperty | Identifies the TableColumnCount dependency property.
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property.
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property.
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property.
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property.
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property.
TableRowCountProperty | Identifies the TableRowCount dependency property.
TableRowHeightProperty | Identifies the TableRowHeight dependency property.
TableShapeProperty | Identifies the TableShape dependency property.
TablesScrollableProperty | Identifies the TablesScrollable dependency property.
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AlignmentGuidePenProperty Field

Diagram.AlignmentGuidePenProperty Field
[image]

Identifies the AlignmentGuidePen dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty AlignmentGuidePenProperty

Visual Basic [image] Copy Code

Public Shared AlignmentGuidePenProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AutoCloseDistanceProperty Field

Diagram.AutoCloseDistanceProperty Field
[image]

Identifies the AutoCloseDistance dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty AutoCloseDistanceProperty

Visual Basic [image] Copy Code

Public Shared AutoCloseDistanceProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BarcodeNodeStyleProperty Field

Diagram.BarcodeNodeStyleProperty Field
[image]

Identifies the BarcodeNodeStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BarcodeNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared BarcodeNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CellFrameStyleProperty Field

Diagram.CellFrameStyleProperty Field
[image]

Identifies the CellFrameStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CellFrameStyleProperty

Visual Basic [image] Copy Code

Public Shared CellFrameStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerNodeStyleProperty Field

Diagram.ContainerNodeStyleProperty Field
[image]

Identifies the ContainerNodeStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ContainerNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared ContainerNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CustomExpandButtonPosition Field

Diagram.CustomExpandButtonPosition Field
[image]

A delegate used to calculate the expand/collapse button position for a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GetManipulatorRect CustomExpandButtonPosition

Visual Basic [image] Copy Code

Public CustomExpandButtonPosition As GetManipulatorRect

Remarks

The component calls this function to get the location of expand/collapse icons when ExpandButtonPosition is set to Custom.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramNode.Expandable


MindFusion.Diagramming.Wpf.Diagram.DefaultShapeProperty Field

Diagram.DefaultShapeProperty Field
[image]

Identifies the DefaultShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty DefaultShapeProperty

Visual Basic [image] Copy Code

Public Shared DefaultShapeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DiagramLinkStyleProperty Field

Diagram.DiagramLinkStyleProperty Field
[image]

Identifies the DiagramLinkStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty DiagramLinkStyleProperty

Visual Basic [image] Copy Code

Public Shared DiagramLinkStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Dummy Field

Diagram.Dummy Field
[image]

A shared DummyNode instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DummyNode Dummy

Visual Basic [image] Copy Code

Public Dummy As DummyNode

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.FreeFormAttractDistanceProperty Field

Diagram.FreeFormAttractDistanceProperty Field
[image]

Identifies the FreeFormAttractDistance dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FreeFormAttractDistanceProperty

Visual Basic [image] Copy Code

Public Shared FreeFormAttractDistanceProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.FreeFormTargetsProperty Field

Diagram.FreeFormTargetsProperty Field
[image]

Identifies the FreeFormTargets dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FreeFormTargetsProperty

Visual Basic [image] Copy Code

Public Shared FreeFormTargetsProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsDiagramScrollerProperty Field

Diagram.IsDiagramScrollerProperty Field
[image]

Identifies the IsDiagramScroller attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDiagramScrollerProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDiagramScrollerProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkBaseShapeProperty Field

Diagram.LinkBaseShapeProperty Field
[image]

Identifies the LinkBaseShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkBaseShapeProperty

Visual Basic [image] Copy Code

Public Shared LinkBaseShapeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkBaseShapeSizeProperty Field

Diagram.LinkBaseShapeSizeProperty Field
[image]

Identifies the LinkBaseShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkBaseShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared LinkBaseShapeSizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkHeadShapeProperty Field

Diagram.LinkHeadShapeProperty Field
[image]

Identifies the LinkHeadShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkHeadShapeProperty

Visual Basic [image] Copy Code

Public Shared LinkHeadShapeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkHeadShapeSizeProperty Field

Diagram.LinkHeadShapeSizeProperty Field
[image]

Identifies the LinkHeadShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkHeadShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared LinkHeadShapeSizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkHitDistanceProperty Field

Diagram.LinkHitDistanceProperty Field
[image]

Identifies the LinkHitDistance dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkHitDistanceProperty

Visual Basic [image] Copy Code

Public Shared LinkHitDistanceProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkIntermediateShapeProperty Field

Diagram.LinkIntermediateShapeProperty Field
[image]

Identifies the LinkIntermediateShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkIntermediateShapeProperty

Visual Basic [image] Copy Code

Public Shared LinkIntermediateShapeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkIntermediateShapeSizeProperty Field

Diagram.LinkIntermediateShapeSizeProperty Field
[image]

Identifies the LinkIntermediateShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkIntermediateShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared LinkIntermediateShapeSizeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkTextProperty Field

Diagram.LinkTextProperty Field
[image]

Identifies the LinkText dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinkTextProperty

Visual Basic [image] Copy Code

Public Shared LinkTextProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierFactorProperty Field

Diagram.MagnifierFactorProperty Field
[image]

Identifies the MagnifierFactor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MagnifierFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MagnifierFactorProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierHeightProperty Field

Diagram.MagnifierHeightProperty Field
[image]

Identifies the MagnifierHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MagnifierHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MagnifierHeightProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierStyleProperty Field

Diagram.MagnifierStyleProperty Field
[image]

Identifies the MagnifierStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MagnifierStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MagnifierStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierWidthProperty Field

Diagram.MagnifierWidthProperty Field
[image]

Identifies the MagnifierWidth dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MagnifierWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MagnifierWidthProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MeasureUnitProperty Field

Diagram.MeasureUnitProperty Field
[image]

Identifies the MeasureUnit dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MeasureUnitProperty

Visual Basic [image] Copy Code

Public Shared MeasureUnitProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NavigateDown Field

Diagram.NavigateDown Field
[image]

Selects the diagram item that is below (greater x coordinate) the currently selected item

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedUICommand NavigateDown

Visual Basic [image] Copy Code

Public Shared ReadOnly NavigateDown As RoutedUICommand

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NavigateLeft Field

Diagram.NavigateLeft Field
[image]

Selects the diagram item that stands to the left of the currently selected item

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedUICommand NavigateLeft

Visual Basic [image] Copy Code

Public Shared ReadOnly NavigateLeft As RoutedUICommand

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NavigateRight Field

Diagram.NavigateRight Field
[image]

Selects the diagram item that stands to the right of the currently selected item

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedUICommand NavigateRight

Visual Basic [image] Copy Code

Public Shared ReadOnly NavigateRight As RoutedUICommand

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NavigateUp Field

Diagram.NavigateUp Field
[image]

Selects the diagram item that is above (smaller x coordinate) the currently selected item

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedUICommand NavigateUp

Visual Basic [image] Copy Code

Public Shared ReadOnly NavigateUp As RoutedUICommand

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NodeEffectsSourceProperty Field

Diagram.NodeEffectsSourceProperty Field
[image]

Identifies the NodeEffectsSource dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NodeEffectsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NodeEffectsSourceProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NodeTemplateProperty Field

Diagram.NodeTemplateProperty Field
[image]

Identifies the NodeTemplate dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty NodeTemplateProperty

Visual Basic [image] Copy Code

Public Shared NodeTemplateProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RotationStepProperty Field

Diagram.RotationStepProperty Field
[image]

Identifies the RotationStep dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty RotationStepProperty

Visual Basic [image] Copy Code

Public Shared RotationStepProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ShapeNodeStyleProperty Field

Diagram.ShapeNodeStyleProperty Field
[image]

Identifies the ShapeNodeStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared ShapeNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ShapeTextProperty Field

Diagram.ShapeTextProperty Field
[image]

Identifies the ShapeText dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeTextProperty

Visual Basic [image] Copy Code

Public Shared ShapeTextProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableBrushProperty Field

Diagram.TableBrushProperty Field
[image]

Identifies the TableBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableBrushProperty

Visual Basic [image] Copy Code

Public Shared TableBrushProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableCaptionHeightProperty Field

Diagram.TableCaptionHeightProperty Field
[image]

Identifies the TableCaptionHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableCaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared TableCaptionHeightProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableCaptionProperty Field

Diagram.TableCaptionProperty Field
[image]

Identifies the TableCaption dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableCaptionProperty

Visual Basic [image] Copy Code

Public Shared TableCaptionProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableColumnCountProperty Field

Diagram.TableColumnCountProperty Field
[image]

Identifies the TableColumnCount dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableColumnCountProperty

Visual Basic [image] Copy Code

Public Shared TableColumnCountProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableColumnWidthProperty Field

Diagram.TableColumnWidthProperty Field
[image]

Identifies the TableColumnWidth dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableColumnWidthProperty

Visual Basic [image] Copy Code

Public Shared TableColumnWidthProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableConnectionStyleProperty Field

Diagram.TableConnectionStyleProperty Field
[image]

Identifies the TableConnectionStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableConnectionStyleProperty

Visual Basic [image] Copy Code

Public Shared TableConnectionStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableCustomDrawProperty Field

Diagram.TableCustomDrawProperty Field
[image]

Identifies the TableCustomDraw dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableCustomDrawProperty

Visual Basic [image] Copy Code

Public Shared TableCustomDrawProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableHandlesStyleProperty Field

Diagram.TableHandlesStyleProperty Field
[image]

Identifies the TableHandlesStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableHandlesStyleProperty

Visual Basic [image] Copy Code

Public Shared TableHandlesStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableNodeStyleProperty Field

Diagram.TableNodeStyleProperty Field
[image]

Identifies the TableNodeStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared TableNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableRowCountProperty Field

Diagram.TableRowCountProperty Field
[image]

Identifies the TableRowCount dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableRowCountProperty

Visual Basic [image] Copy Code

Public Shared TableRowCountProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableRowHeightProperty Field

Diagram.TableRowHeightProperty Field
[image]

Identifies the TableRowHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableRowHeightProperty

Visual Basic [image] Copy Code

Public Shared TableRowHeightProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableShapeProperty Field

Diagram.TableShapeProperty Field
[image]

Identifies the TableShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TableShapeProperty

Visual Basic [image] Copy Code

Public Shared TableShapeProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TablesScrollableProperty Field

Diagram.TablesScrollableProperty Field
[image]

Identifies the TablesScrollable dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TablesScrollableProperty

Visual Basic [image] Copy Code

Public Shared TablesScrollableProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TreeViewNodeStyleProperty Field

Diagram.TreeViewNodeStyleProperty Field
[image]

Identifies the TreeViewNodeStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TreeViewNodeStyleProperty

Visual Basic [image] Copy Code

Public Shared TreeViewNodeStyleProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ZoomFactorProperty Field

Diagram.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Constructor

Diagram Constructor
[image]

Initializes a new instance of the Diagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Methods

Diagram Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
BeginEdit | Overloaded.
BeginInit | FrameworkElement.BeginInit override.
BringIntoView | Overloaded. Scrolls the diagram area to make the specified item visible.
CancelDrag | Cancels the current drag operation.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items from the diagram.
ClientToDoc | Overloaded.
Compact | Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions.
CopySelection | Creates a copy of the currently selected objects and groups.
CopyToClipboard | Overloaded.
CreateImage | Overloaded.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard.
DocToClient | Overloaded.
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.
EndEdit | Exits in-place editing mode and either accepts or rejects the changes made to the item's text.
EndInit | FrameworkElement.EndInit override.
ExecuteCommand | Executes the specified command on this diagram.
FindGroup | Finds the group that has the specified tag value.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetDiagramItem | Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement.
GetIsDiagramScroller | Gets the value of the IsDiagramScroller attached property from a given element.
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location.
GetItemBounds | Retrieves the bounding rectangle of the specified item within the current diagram.
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location.
GetNearestNode | Returns the node nearest to the specified point.
GetNodeAt | Overloaded. Gets the node that lies at the specified location.
GetNodesAt | Returns the nodes that contain the specified point.
GetNodesInViewport | Returns all nodes visible in the current viewport.
HandleMouseMove | Propagates mouse input to interested manipulators.
HitTestManipulators | Tests whether the specified point is within a manipulator of a diagram element.
Invalidate | Invalidates the specified rectangle of the diagram, causing it to be repainted.
InvalidateBackground | Repaints the diagram background, and raises the DrawBackground event for custom drawing.
InvalidateForeground | Repaints the diagram foreground, and raises the DrawForeground event for custom drawing.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromString | Decodes diagram contents from a string that was created with SaveToString.
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control.
MeasureString | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.
PasteFromClipboard | Overloaded.
PasteSelection | Adds the specified items and groups to the specified diagram document.
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation.
Print | Displays a Print dialog and prints the diagram.
PrintPreview | Overloaded. Displays the diagram in a Print Preview window.
RaiseCellTextEdited | Raises the CellTextEdited event.
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode.
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.
RaiseLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event.
RaiseLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode.
RaiseLinkTextEdited | Overloaded.
RaiseLinkTextEditing | Overloaded.
RaiseNodeTextEdited | Raises the NodeTextEdited event.
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate *Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RegisterClass | Registers a class for serialization support.
RegisterItemClass | Registers a diagram item class for serialization support.
ResizeToFitItem | Resizes the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
ScrollTo | Scrolls the document to the specified point.
SetIsDiagramScroller | Sets the value of the IsDiagramScroller attached property to a given element.
SetItemBounds | Sets the location and size of the specified item within the current diagram.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation.
UpdateRuntimeIndices | For internal use.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area.
ZoomToRect | Overloaded. Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
DrawGrid | Renders the diagram grid.
GetVisualChild | Visual.GetVisualChild override.
MeasureOverride | Control.MeasureOverride override.
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnDrop | Handles dropping of DraggedNode instances
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnVisualParentChanged | FrameworkElement.OnVisualParentChanged override.
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AlignPointToGrid Method

Diagram.AlignPointToGrid Method
[image]

Returns a point of the alignment grid nearest to the one passed as an argument.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point AlignPointToGrid (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function AlignPointToGrid( _
point As Point _
) As Point

Parameters

point

A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

Remarks

Items created or moved by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AlignToGrid Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Wpf.Diagram.ArrangeLinkLabels Method

Diagram.ArrangeLinkLabels Method
[image]

Rearranges link labels whose AutoArrange property is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ArrangeLinkLabels ()

Visual Basic [image] Copy Code

Public Sub ArrangeLinkLabels ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LinkLabel Class
AddLabel Method


MindFusion.Diagramming.Wpf.Diagram.ArrangeOverride Method

Diagram.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BeginEdit Method

Diagram.BeginEdit Method
[image]

Overload List

Name | Description
Diagram.BeginEdit (InplaceEditable) | Begins in-place editing of the specified object.
Diagram.BeginEdit (InplaceEditable, Point) | Enters in-place editing mode, letting the user edit the text of the specified item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BeginEdit Method (InplaceEditable)

Diagram.BeginEdit Method (InplaceEditable)
See Also
[image]

Begins in-place editing of the specified object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BeginEdit (
InplaceEditable item
)

Visual Basic [image] Copy Code

Public Sub BeginEdit( _
item As InplaceEditable _
)

Parameters

item

Remarks

If AllowInplaceEdit is enabled, the user can start editing the text of an item by double-clicking the item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
EndEdit Method


MindFusion.Diagramming.Wpf.Diagram.BeginEdit Method (InplaceEditable, Point)

Diagram.BeginEdit Method (InplaceEditable, Point)
See Also
[image]

Enters in-place editing mode, letting the user edit the text of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BeginEdit (
InplaceEditable editable,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub BeginEdit( _
editable As InplaceEditable, _
mousePosition As Point _
)

Parameters

editable

The diagram item or table's cell whose text should be edited.

mousePosition
A Point specifying where the in-place editing box should appear.

Remarks

If AllowInplaceEdit is enabled, the user can start editing the text of an item by double-clicking the item.

See Also

BeginEdit Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BeginInit Method

Diagram.BeginInit Method
[image]

FrameworkElement.BeginInit override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BringIntoView Method

Diagram.BringIntoView Method
[image]

Scrolls the diagram area to make the specified item visible.

Overload List

Name | Description
Diagram.BringIntoView (DiagramItem) | Scrolls the diagram area to make the specified item visible.
Diagram.BringIntoView (DiagramItem, Boolean) | Scrolls the document area to make the specified item visible.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BringIntoView Method (DiagramItem)

Diagram.BringIntoView Method (DiagramItem)
See Also
[image]

Scrolls the diagram area to make the specified item visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BringIntoView (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub BringIntoView( _
item As DiagramItem _
)

Parameters

item
The item to be brought into view.

Remarks

This method works correctly only if the Diagram is placed inside a ScrollViewer.

See Also

BringIntoView Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BringIntoView Method (DiagramItem, Boolean)

Diagram.BringIntoView Method (DiagramItem, Boolean)
See Also
[image]

Scrolls the document area to make the specified item visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BringIntoView (
DiagramItem item,
bool centered
)

Visual Basic [image] Copy Code

Public Sub BringIntoView( _
item As DiagramItem, _
centered As Boolean _
)

Parameters

item
The DiagramItem to be brought into view.
centered
true if the item should be centered in the view, otherwise false.

See Also

BringIntoView Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ScrollTo Method


MindFusion.Diagramming.Wpf.Diagram.CancelDrag Method

Diagram.CancelDrag Method
[image]

Cancels the current drag operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

This method is useful in situations when the current draw operation must be cancelled, for example when starting drag-and-drop from the MouseMove event handler.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ChangeUnit Method

Diagram.ChangeUnit Method
[image]

Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ChangeUnit (
GraphicsUnit newUnit
)

Visual Basic [image] Copy Code

Public Sub ChangeUnit( _
newUnit As GraphicsUnit _
)

Parameters

newUnit

A GraphicsUnit value specifying the new unit.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ClearAll Method

Diagram.ClearAll Method
[image]

Removes all items from the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ClearAll ()

Visual Basic [image] Copy Code

Public Sub ClearAll ()

Remarks

Use this method to clear all Groups, Links and Nodes in the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Items Property


MindFusion.Diagramming.Wpf.Diagram.ClientToDoc Method

Diagram.ClientToDoc Method
[image]

Overload List

Name | Description
Diagram.ClientToDoc (Point) | Transforms points from the client coordinate space to the document coordinate space.
Diagram.ClientToDoc (Rect) | Transforms points from the client coordinate space to the document coordinate space.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ClientToDoc Method (Point)

Diagram.ClientToDoc Method (Point)
See Also
[image]

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point ClientToDoc (
Point clientPoint
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientPoint As Point _
) As Point

Parameters

clientPoint

An instance of the .NET Point structure, whose coordinates should be transformed and returned.

Return Value

A .NET Point instance, which represents the document coordinates of clientPoint.

Remarks

This method is useful when the document coordinates of a device point are needed.

See Also

ClientToDoc Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DocToClient Method
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.ClientToDoc Method (Rect)

Diagram.ClientToDoc Method (Rect)
See Also
[image]

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect ClientToDoc (
Rect clientRect
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientRect As Rect _
) As Rect

Parameters

clientRect

An instance of the .NET Rect structure, whose coordinates should be transformed and returned.

Return Value

A .NET Rect instance, which represents the document coordinates of clientRect.

Remarks

This method is useful when the document coordinates of a rectangle are needed.

See Also

ClientToDoc Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DocToClient Method
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.Compact Method

Diagram.Compact Method
[image]

Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Compact (
Orientation orientation,
double padding,
bool minimizeLinkLength
)

Visual Basic [image] Copy Code

Public Sub Compact( _
orientation As Orientation, _
padding As Double, _
minimizeLinkLength As Boolean _
)

Parameters

orientation

Specifies horizontal or vertical layout.

padding

How much space to leave between adjacent nodes.

minimizeLinkLength

true to try to minimize link lengths between layers at the cost of a less compact layout.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CopySelection Method

Diagram.CopySelection Method
[image]

Creates a copy of the currently selected objects and groups.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SelectionCopy CopySelection (
Diagram source,
bool unconnectedLinks,
bool copyGroups
)

Visual Basic [image] Copy Code

Public Function CopySelection( _
source As Diagram, _
unconnectedLinks As Boolean, _
copyGroups As Boolean _
) As SelectionCopy

Parameters

source

The source diagram.

unconnectedLinks
true to allow copying unconnected links; otherwise, false.
copyGroups
true to copy group information; otherwise, false.

Return Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CopyToClipboard Method

Diagram.CopyToClipboard Method
[image]

Overload List

Name | Description
Diagram.CopyToClipboard (Boolean) | Copies the current selection of items to the clipboard.
Diagram.CopyToClipboard (Boolean, Boolean) | Copies the current selection of items to the clipboard.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CopyToClipboard Method (Boolean)

Diagram.CopyToClipboard Method (Boolean)
See Also
[image]

Copies the current selection of items to the clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CopyToClipboard (
bool persist
)

Visual Basic [image] Copy Code

Public Function CopyToClipboard( _
persist As Boolean _
) As Boolean

Parameters

persist
true if you want data to remain on the Clipboard after this application exits; otherwise, false.

Return Value

true if items were successfully copied to clipboard; otherwise, false.

See Also

CopyToClipboard Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
PasteFromClipboard Method
CutToClipboard Method


MindFusion.Diagramming.Wpf.Diagram.CopyToClipboard Method (Boolean, Boolean)

Diagram.CopyToClipboard Method (Boolean, Boolean)
See Also
[image]

Copies the current selection of items to the clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CopyToClipboard (
bool persist,
bool groups
)

Visual Basic [image] Copy Code

Public Function CopyToClipboard( _
persist As Boolean, _
groups As Boolean _
) As Boolean

Parameters

persist
true if you want data to remain on the Clipboard after this application exits; otherwise, false.
groups
true to copy item groups; otherwise, false.

Return Value

true if items were successfully copied; otherwise, false.

See Also

CopyToClipboard Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
PasteFromClipboard Method
CutToClipboard Method


MindFusion.Diagramming.Wpf.Diagram.CreateImage Method

Diagram.CreateImage Method
[image]

Overload List

Name | Description
Diagram.CreateImage () | Creates a bitmap containing an image of the Diagram.
Diagram.CreateImage (Double) | Creates a bitmap containing an image of the Diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CreateImage Method ()

Diagram.CreateImage Method ()
See Also
[image]

Creates a bitmap containing an image of the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BitmapSource CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As BitmapSource

Return Value

A BitmapSource instance containing the diagram image.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CreateImage Method (Double)

Diagram.CreateImage Method (Double)
See Also
[image]

Creates a bitmap containing an image of the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BitmapSource CreateImage (
double scale
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
scale As Double _
) As BitmapSource

Parameters

scale

Return Value

A Bitmap instance containing the diagram image.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CreateThemeFromDefaults Method

Diagram.CreateThemeFromDefaults Method
[image]

Creates a Theme object representing the default properties of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Theme CreateThemeFromDefaults ()

Visual Basic [image] Copy Code

Public Function CreateThemeFromDefaults () As Theme

Return Value

An instance of the Theme class.

Remarks

This method is only for compatibility with files saved with versions earlier than 3.0.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CutToClipboard Method

Diagram.CutToClipboard Method
[image]

Cuts the currently selected items to the Windows clipboard.

Overload List

Name | Description
Diagram.CutToClipboard (Boolean) | Cuts the currently selected items to the Windows clipboard.
Diagram.CutToClipboard (Boolean, Boolean) | Cuts the currently selected items to the Windows clipboard.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CutToClipboard Method (Boolean)

Diagram.CutToClipboard Method (Boolean)
See Also
[image]

Cuts the currently selected items to the Windows clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CutToClipboard (
bool copy
)

Visual Basic [image] Copy Code

Public Function CutToClipboard( _
copy As Boolean _
) As Boolean

Parameters

copy

true if you want data to remain on the clipboard after this application exits; otherwise, false.

Return Value

true if items are successfully copied to clipboard; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CopyToClipboard Method
PasteFromClipboard Method


MindFusion.Diagramming.Wpf.Diagram.CutToClipboard Method (Boolean, Boolean)

Diagram.CutToClipboard Method (Boolean, Boolean)
See Also
[image]

Cuts the currently selected items to the Windows clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CutToClipboard (
bool copy,
bool groups
)

Visual Basic [image] Copy Code

Public Function CutToClipboard( _
copy As Boolean, _
groups As Boolean _
) As Boolean

Parameters

copy

true if you want data to remain on the clipboard after this application exits; otherwise, false.

groups

true to copy item groups; otherwise, false.

Return Value

true if items are successfully copied to clipboard; otherwise, false.

See Also

CutToClipboard Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DocToClient Method

Diagram.DocToClient Method
[image]

Overload List

Name | Description
Diagram.DocToClient (Point) | Transforms points from the document coordinate space to the client coordinate space.
Diagram.DocToClient (Rect) | Converts the specified rectangle from document to client coordinates.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DocToClient Method (Point)

Diagram.DocToClient Method (Point)
See Also
[image]

Transforms points from the document coordinate space to the client coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point DocToClient (
Point docPoint
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docPoint As Point _
) As Point

Parameters

docPoint

An instance of the .NET Point structure, whose coordinates should be transformed and returned.

Return Value

A Point instance, which represents the client coordinates of docPoint.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed.

See Also

DocToClient Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ClientToDoc Method
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.DocToClient Method (Rect)

Diagram.DocToClient Method (Rect)
See Also
[image]

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect DocToClient (
Rect docRect
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docRect As Rect _
) As Rect

Parameters

docRect

An instance of the .NET Rect structure, whose coordinates should be transformed and returned.

Return Value

A Rect instance, which represents the client coordinates of docRect.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed.

See Also

DocToClient Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ClientToDoc Method
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.DrawGrid Method

Diagram.DrawGrid Method
[image]

Renders the diagram grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void DrawGrid (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawGrid( _
graphics As DrawingContext _
)

Parameters

graphics

A DrawingContext instance representing the target drawing surface where the grid should be rendered.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DrawStyledText Method

Diagram.DrawStyledText Method
[image]

Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void DrawStyledText (
DrawingContext graphics,
string text,
ITextAttributes textAttributes,
Rect textBounds
)

Visual Basic [image] Copy Code

Public Sub DrawStyledText( _
graphics As DrawingContext, _
text As String, _
textAttributes As ITextAttributes, _
textBounds As Rect _
)

Parameters

graphics

A .NET DrawingContext object used to draw the text.

text

The text that should be drawn, including formatting tags.

textAttributes
An ITextAttributes instance that specifies the text appearance.
textBounds

The bounds of the text layout rectangle.

Example

C# [image] Copy Code

private void diagram_DrawNode(object sender, DrawNodeEventArgs e)
{
Rect r = e.Node.Bounds;
r.X = 5;
r.Y = 5;

TextAttributes textAtt = new TextAttributes(e.Node);
diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>", textAtt, r);
}

Visual Basic [image] Copy Code

Private Sub diagram_DrawNode(ByVal sender As Object, ByVal e As DrawNodeEventArgs) Handles diagram.DrawNode

Dim r As Rect = e.Node.Bounds
r.X = 5
r.Y = 5

Dim textAtt As TextAttributes = New TextAttributes(e.Node)
diagram.DrawStyledText(e.Graphics, "<b>test</b> <i>test</i>", textAtt, r)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.EndEdit Method

Diagram.EndEdit Method
[image]

Exits in-place editing mode and either accepts or rejects the changes made to the item's text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void EndEdit (
bool accept
)

Visual Basic [image] Copy Code

Public Sub EndEdit( _
accept As Boolean _
)

Parameters

accept
true to accept changes made to text; false to reject them.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
BeginEdit Method


MindFusion.Diagramming.Wpf.Diagram.EndInit Method

Diagram.EndInit Method
[image]

FrameworkElement.EndInit override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ExecuteCommand Method

Diagram.ExecuteCommand Method
[image]

Executes the specified command on this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub ExecuteCommand( _
cmd As Command _
)

Parameters

cmd
The Command to execute.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.FindGroup Method

Diagram.FindGroup Method
[image]

Finds the group that has the specified tag value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group FindGroup (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindGroup( _
tagValue As Object _
) As Group

Parameters

tagValue

A .NET object assigned as a tag and characterizing the group to be searched for.

Return Value

The Group instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a group that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
FindLink Method
FindNode Method


MindFusion.Diagramming.Wpf.Diagram.FindLink Method

Diagram.FindLink Method
[image]

Finds the link that has the specified tag value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink FindLink (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindLink( _
tagValue As Object _
) As DiagramLink

Parameters

tagValue

A .NET object assigned as a tag and characterizing the link to be searched for.

Return Value

The DiagramLink instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a link that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
FindNode Method
FindGroup Method


MindFusion.Diagramming.Wpf.Diagram.FindLinkById Method

Diagram.FindLinkById Method
[image]

Finds the link that has the specified id value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink FindLinkById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindLinkById( _
id As Object _
) As DiagramLink

Parameters

id
An object used as a link id.

Return Value

A DiagramLink whose Id equals to the specified value if such link exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.FindNode Method

Diagram.FindNode Method
[image]

Finds the node that has the specified tag value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode FindNode (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindNode( _
tagValue As Object _
) As DiagramNode

Parameters

tagValue

A .NET object assigned as a tag and characterizing the node to be searched for.

Return Value

The DiagramNode instance if found; otherwise, null (Nothing in Visual Basic).

Remarks

Use this method to find a node that has been marked earlier with the specified tag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
FindLink Method
FindGroup Method


MindFusion.Diagramming.Wpf.Diagram.FindNodeById Method

Diagram.FindNodeById Method
[image]

Finds the node that has the specified id value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode FindNodeById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindNodeById( _
id As Object _
) As DiagramNode

Parameters

id
A .NET object used as a node id.

Return Value

A DiagramNode whose Id equals to the specified value if such node exists; otherwise, null (Nothing in Visual Basic).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetContentBounds Method

Diagram.GetContentBounds Method
[image]

Returns the smallest rectangle that bounds all diagram objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetContentBounds (
bool forPrint,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Function GetContentBounds( _
forPrint As Boolean, _
onlyVisible As Boolean _
) As Rect

Parameters

forPrint

Specifies whether only printable items should be considered.

onlyVisible

Specifies whether only visible items should be considered.

Return Value

The smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetDiagramItem Method

Diagram.GetDiagramItem Method
[image]

Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DiagramItem GetDiagramItem (
DependencyObject item
)

Visual Basic [image] Copy Code

Public Shared Function GetDiagramItem( _
item As DependencyObject _
) As DiagramItem

Parameters

item

Return Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetIsDiagramScroller Method

Diagram.GetIsDiagramScroller Method
[image]

Gets the value of the IsDiagramScroller attached property from a given element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool GetIsDiagramScroller (
DependencyObject obj
)

Visual Basic [image] Copy Code

Public Shared Function GetIsDiagramScroller( _
obj As DependencyObject _
) As Boolean

Parameters

obj

The element from which to read the property value.

Return Value

The value of the IsDiagramScroller attached property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetItemAt Method

Diagram.GetItemAt Method
[image]

Finds and returns the top-most diagram item that lies at the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
Point pt,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
pt As Point, _
exclLocked As Boolean _
) As DiagramItem

Parameters

pt
A Point instance identifying a diagram location.
exclLocked

Specifies whether to ignore locked items.

Return Value

The DiagramItem found or null (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the item at a certain location in the diagram. The method searches starting from the top of z-order and returns the first item found.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetNodeAt Method
GetLinkAt Method


MindFusion.Diagramming.Wpf.Diagram.GetItemBounds Method

Diagram.GetItemBounds Method
[image]

Retrieves the bounding rectangle of the specified item within the current diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect GetItemBounds (
UIElement item
)

Visual Basic [image] Copy Code

Public Shared Function GetItemBounds( _
item As UIElement _
) As Rect

Parameters

item
The diagram item whose bounding rectangle should be returned.

Return Value

A .NET Rect object specifying the item's bounding rectangle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetLinkAt Method

Diagram.GetLinkAt Method
[image]

Finds and returns the link that lies at the specified location.

Overload List

Name | Description
Diagram.GetLinkAt (Point, Double) | Finds and returns the top-most link that lies at the specified location.
Diagram.GetLinkAt (Point, Double, Boolean) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.
Diagram.GetLinkAt (Point, Double, Boolean, Int32@) | Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Wpf.Diagram.GetLinkAt Method (Point, Double)

Diagram.GetLinkAt Method (Point, Double)
See Also
[image]

Finds and returns the top-most link that lies at the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double _
) As DiagramLink

Parameters

pt
A Point instance identifying a diagram location.
maxDist

The maximal distance between the point and a link, within which to consider the point as lying on the link.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Wpf.Diagram.GetLinkAt Method (Point, Double, Boolean)

Diagram.GetLinkAt Method (Point, Double, Boolean)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean _
) As DiagramLink

Parameters

pt

A Point instance identifying a diagram location.

maxDist

The maximal distance between the point and a link, within which to consider the point as lying on the link.

exclLocked

Specifies that locked links should be ignored by the search.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetNodeAt Method


MindFusion.Diagramming.Wpf.Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)

Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)
See Also
[image]

Finds and returns the top-most link that lies at the specified location, optionally excluding locked links from the search. The zero-based index of the exact link segment at the specified position is also returned.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean, _
ByRef segmNum As Integer _
) As DiagramLink

Parameters

pt
A Point instance identifying a diagram location.
maxDist
The maximal distance between the point and a link, within which to consider the point as lying on the link.
exclLocked
Specifies that locked links should be ignored by the search.
segmNum
The zero-based index of the link's segment at which the point is lying is returned here.

Return Value

The DiagramLink found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

Call the method to get the link at a certain place in the document. The method searches starting from the top of z-order and returns the first link found. The specified point might not be laying exactly on the link, but within a certain threshold distance from it. This threshold is specified through the second parameter. Locked and invisible links can be skipped from the search by setting the third parameter to true. The link's segment closest to the point is returned through the fourth parameter.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetNodeAt Method
GetItemAt Method


MindFusion.Diagramming.Wpf.Diagram.GetNearestNode Method

Diagram.GetNearestNode Method
[image]

Returns the node nearest to the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetNearestNode (
Point pt,
double maxDistance,
DiagramNode ignored
)

Visual Basic [image] Copy Code

Public Function GetNearestNode( _
pt As Point, _
maxDistance As Double, _
ignored As DiagramNode _
) As DiagramNode

Parameters

pt
A point in the diagram.
maxDistance
The maximum distance from the point at which to look for nodes.
ignored
A node that should be ignored.

Return Value

The DiagramNode nearest to the specified point.

Remarks

The last argument is useful when calling this method from NodeCreated and NodeModified handlers and the affected node should not be included in the search.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetNodeAt Method
GetNodesAt Method


MindFusion.Diagramming.Wpf.Diagram.GetNodeAt Method

Diagram.GetNodeAt Method
[image]

Gets the node that lies at the specified location.

Overload List

Name | Description
Diagram.GetNodeAt (Point) | Finds and returns the top-most node that lies at the specified location.
Diagram.GetNodeAt (Point, Boolean) | Finds and returns the topmost node that lies at the specified location.
Diagram.GetNodeAt (Point, Boolean, Boolean) | Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.
Diagram.GetNodeAt (Point, Double) | Finds and returns the top-most node that lies within the specified threshold from the specified location.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetLinkAt Method
GetNearestNode Method


MindFusion.Diagramming.Wpf.Diagram.GetNodeAt Method (Point)

Diagram.GetNodeAt Method (Point)
See Also
[image]

Finds and returns the top-most node that lies at the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point _
) As DiagramNode

Parameters

point
A Point instance identifying a diagram location.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

Remarks

The method starts searching from the top of the z-order and returns the first node that contains the specified point.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Wpf.Diagram.GetNodeAt Method (Point, Boolean)

Diagram.GetNodeAt Method (Point, Boolean)
See Also
[image]

Finds and returns the topmost node that lies at the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
excludeLocked As Boolean _
) As DiagramNode

Parameters

point

A Point instance identifying a diagram point in logical coordinates.

excludeLocked

Specifies whether locked nodes should be excluded from the search.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no item has been found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetNodeAt Method (Point, Boolean, Boolean)

Diagram.GetNodeAt Method (Point, Boolean, Boolean)
See Also
[image]

Finds and returns the top-most node that lies at the specified location, optionally excluding locked and/or selected nodes from the search.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked,
bool excludeSelected
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
excludeLocked As Boolean, _
excludeSelected As Boolean _
) As DiagramNode

Parameters

point
A Point instance identifying a diagram location.
excludeLocked
true if nodes that are locked should be omitted by searching; otherwise, false.
excludeSelected
true if nodes that are selected should be omitted by searching; otherwise, false.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Wpf.Diagram.GetNodeAt Method (Point, Double)

Diagram.GetNodeAt Method (Point, Double)
See Also
[image]

Finds and returns the top-most node that lies within the specified threshold from the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
threshold As Double _
) As DiagramNode

Parameters

point
A Point instance identifying a diagram location.
threshold

Allowed distance from the node.

Return Value

The DiagramNode found or a null reference (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for a node occupying some location in the diagram document. The method searches starting from the top of z-order and returns the first object found.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetLinkAt Method


MindFusion.Diagramming.Wpf.Diagram.GetNodesAt Method

Diagram.GetNodesAt Method
[image]

Returns the nodes that contain the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection GetNodesAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNodesAt( _
point As Point _
) As DiagramNodeCollection

Parameters

point
A Point instance identifying a diagram location.

Return Value

An instance of the DiagramNodeCollection class containing all found nodes; null (Nothing in Visual Basic) if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for the nodes occupying some location in the diagram document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
GetItemAt Method
GetLinkAt Method
GetNearestNode Method


MindFusion.Diagramming.Wpf.Diagram.GetNodesInViewport Method

Diagram.GetNodesInViewport Method
[image]

Returns all nodes visible in the current viewport.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection GetNodesInViewport ()

Visual Basic [image] Copy Code

Public Function GetNodesInViewport () As DiagramNodeCollection

Return Value

A DiagramNodeCollection that contains the viewport nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GetVisualChild Method

Diagram.GetVisualChild Method
[image]

Visual.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Zero-based index of the requested child element in the collection.

Return Value

The requested child element.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.HandleMouseMove Method

Diagram.HandleMouseMove Method
[image]

Propagates mouse input to interested manipulators.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CursorHint HandleMouseMove (
Point pt
)

Visual Basic [image] Copy Code

Public Function HandleMouseMove( _
pt As Point _
) As CursorHint

Parameters

pt

Return Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.HitTestManipulators Method

Diagram.HitTestManipulators Method
[image]

Tests whether the specified point is within a manipulator of a diagram element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Manipulator HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Function HitTestManipulators( _
pt As Point _
) As Manipulator

Parameters

pt
A Point instance specifying the point to test.

Return Value

The Manipulator instance found.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Invalidate Method

Diagram.Invalidate Method
[image]

Invalidates the specified rectangle of the diagram, causing it to be repainted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Invalidate (
Object sender,
Rect invalidRect
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
sender As Object, _
invalidRect As Rect _
)

Parameters

sender

The object that causes the diagram invalidation.

invalidRect
A Rect instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.InvalidateBackground Method

Diagram.InvalidateBackground Method
[image]

Repaints the diagram background, and raises the DrawBackground event for custom drawing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void InvalidateBackground ()

Visual Basic [image] Copy Code

Public Sub InvalidateBackground ()

Remarks

Call this method to refresh the diagram background when custom drawing it from DrawBackground event handler.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.InvalidateForeground Method

Diagram.InvalidateForeground Method
[image]

Repaints the diagram foreground, and raises the DrawForeground event for custom drawing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void InvalidateForeground ()

Visual Basic [image] Copy Code

Public Sub InvalidateForeground ()

Remarks

Call this method to refresh the diagram background when custom drawing it from DrawForeground event handler.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsItemInteractive Method

Diagram.IsItemInteractive Method
[image]

Checks if the specified item can be modified interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsItemInteractive (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemInteractive( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item is currently visible and unlocked and it is not associated with a hidden or locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsItemLocked Method

Diagram.IsItemLocked Method
[image]

Checks if the specified item is locked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsItemLocked (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemLocked( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item's Locked property is set to true or if the item is associated with a locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsItemVisible Method

Diagram.IsItemVisible Method
[image]

Checks if the specified item is currently visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsItemVisible (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemVisible( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true if the item's Visible property is set to true and the item is not associated with a hidden layer; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LoadFromString Method

Diagram.LoadFromString Method
[image]

Decodes diagram contents from a string that was created with SaveToString.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

A string containing the serialized diagram contents.

Remarks

Loads a diagram document from a string. The string must have been created by the SaveToString method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.Diagram.LoadFromXml Method

Diagram.LoadFromXml Method
[image]

Loads the contents of an XML diagram document into the control.

Overload List

Name | Description
Diagram.LoadFromXml (String) | Loads the contents of the XML diagram document from the specified file into the control.
Diagram.LoadFromXml (XmlDocument) | Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.Diagram.LoadFromXml Method (String)

Diagram.LoadFromXml Method (String)
See Also
[image]

Loads the contents of the XML diagram document from the specified file into the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the XML file the data should be read from.

Remarks

The method reads a diagram previously saved by the SaveToXml method. This method is implemented by loading an XmlDocument from the specified file and calling the LoadFromXml overload.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.Diagram.LoadFromXml Method (XmlDocument)

Diagram.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the contents of the XML diagram document represented by the specified XmlDocument into the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object from which to load the diagram data.

Remarks

The method reads a diagram previously saved by the SaveToXml method.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.Diagram.MeasureOverride Method

Diagram.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

Measurement constraints, a control cannot return a size larger than the constraint.

Return Value

The size of the control.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MeasureString Method

Diagram.MeasureString Method
[image]

Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size MeasureString (
string text,
ITextAttributes textAttributes,
int maxWidth
)

Visual Basic [image] Copy Code

Public Function MeasureString( _
text As String, _
textAttributes As ITextAttributes, _
maxWidth As Integer _
) As Size

Parameters

text

The string to measure.

textAttributes

A TextAttributes instance that specifies the text appearance.

maxWidth

The maximum width of the string.

Return Value

This method returns a Size structure that represents the size of the string text when drawn with the font parameter and the stringFormat parameter.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnDrop Method

Diagram.OnDrop Method
[image]

Handles dropping of DraggedNode instances

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnDrop (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnDrop( _
e As DragEventArgs _
)

Parameters

e

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnMouseDown Method

Diagram.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnMouseUp Method

Diagram.OnMouseUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnPreviewMouseDown Method

Diagram.OnPreviewMouseDown Method
[image]

UIElement.OnPreviewMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnPreviewMouseMove Method

Diagram.OnPreviewMouseMove Method
[image]

UIElement.OnPreviewMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The System.Windows.Input.MouseEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnPreviewMouseUp Method

Diagram.OnPreviewMouseUp Method
[image]

UIElement.OnPreviewMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OnVisualParentChanged Method

Diagram.OnVisualParentChanged Method
[image]

FrameworkElement.OnVisualParentChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnVisualParentChanged (
DependencyObject oldParent
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnVisualParentChanged( _
oldParent As DependencyObject _
)

Parameters

oldParent

The old parent element.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PasteFromClipboard Method

Diagram.PasteFromClipboard Method
[image]

Overload List

Name | Description
Diagram.PasteFromClipboard (Vector) | Pastes diagram items from the Windows clipboard.
Diagram.PasteFromClipboard (Vector, Boolean) | Pastes diagram items from the Windows clipboard.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PasteFromClipboard Method (Vector)

Diagram.PasteFromClipboard Method (Vector)
See Also
[image]

Pastes diagram items from the Windows clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PasteFromClipboard (
Vector offset
)

Visual Basic [image] Copy Code

Public Function PasteFromClipboard( _
offset As Vector _
) As Boolean

Parameters

offset

The offset of pasted items from their original positions.

Return Value

true if successful; otherwise, false.

See Also

PasteFromClipboard Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CopyToClipboard Method
CutToClipboard Method


MindFusion.Diagramming.Wpf.Diagram.PasteFromClipboard Method (Vector, Boolean)

Diagram.PasteFromClipboard Method (Vector, Boolean)
See Also
[image]

Pastes diagram items from the Windows clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PasteFromClipboard (
Vector offset,
bool unconnectedLinks
)

Visual Basic [image] Copy Code

Public Function PasteFromClipboard( _
offset As Vector, _
unconnectedLinks As Boolean _
) As Boolean

Parameters

offset

The offset of pasted items from their original positions.

unconnectedLinks
true to allow pasting links whose origin or destination node has not been copied; otherwise, false.

Return Value

true if successful; otherwise, false.

See Also

PasteFromClipboard Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CopyToClipboard Method
CutToClipboard Method


MindFusion.Diagramming.Wpf.Diagram.PasteSelection Method

Diagram.PasteSelection Method
[image]

Adds the specified items and groups to the specified diagram document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PasteSelection (
Diagram doc,
SelectionCopy data,
CompositeCmd cmd,
Vector offset
)

Visual Basic [image] Copy Code

Public Function PasteSelection( _
doc As Diagram, _
data As SelectionCopy, _
cmd As CompositeCmd, _
offset As Vector _
) As Boolean

Parameters

doc

A Diagram object to which the items should be added.

data

A SelectionCopy object returned by a previous call to CopySelection.

cmd

A CompositeCmd object where the items state should be recorded for later undo or redo.

offset

Offset of pasted items from their original positions.

Return Value

true if data contains any items; otherwise, false.

Remarks

This method can be used in conjunction with CopySelection to copy selected items from one Diagram instance to another.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PixelToUnit Method

Diagram.PixelToUnit Method
[image]

Converts the specified point from client to document coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point PixelToUnit (
Point point
)

Visual Basic [image] Copy Code

Public Function PixelToUnit( _
point As Point _
) As Point

Parameters

point
The Point instance to convert.

Return Value

A Point representing the diagram coordinates of the client point specified as an argument.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Print Method

Diagram.Print Method
[image]

Displays a Print dialog and prints the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Print ()

Visual Basic [image] Copy Code

Public Sub Print ()

Remarks

The method displays the standard Windows print dialog, allowing users to select a printer and choose which portions of the document to print. The smallest rectangular area of the document that contains all diagram elements is printed.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PrintPreview Method

Diagram.PrintPreview Method
[image]

Displays the diagram in a Print Preview window.

Overload List

Name | Description
Diagram.PrintPreview () | Displays the diagram in a Print Preview window.
Diagram.PrintPreview (String) | Displays the diagram in a Print Preview window.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PrintPreview Method ()

Diagram.PrintPreview Method ()
See Also
[image]

Displays the diagram in a Print Preview window.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview ()

Visual Basic [image] Copy Code

Public Sub PrintPreview ()

Remarks

The Print Preview window shows what the diagram content would look like when printed on paper.

See Also

PrintPreview Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PrintPreview Method (String)

Diagram.PrintPreview Method (String)
See Also
[image]

Displays the diagram in a Print Preview window.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
string windowTitle
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
windowTitle As String _
)

Parameters

windowTitle
The title of the preview window.

See Also

PrintPreview Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseCellTextEdited Method

Diagram.RaiseCellTextEdited Method
[image]

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseCellTextEdited (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub RaiseCellTextEdited( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell
The TableNode.Cell related to the event.
oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseCellTextEditing Method

Diagram.RaiseCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseCellTextEditing (
TableNode table,
int column,
int row
)

Visual Basic [image] Copy Code

Public Function RaiseCellTextEditing( _
table As TableNode, _
column As Integer, _
row As Integer _
) As Boolean

Parameters

table
The TableNode related to the event.
column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method
[image]

Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseClicked (DiagramItem, Point, MouseButton) | Raises the appropriate *Clicked event according to the type of the specified item.
Diagram.RaiseClicked (MouseButton, Point) | Raises the Clicked event of the Diagram class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseClicked Method (DiagramItem, Point, MouseButton)

Diagram.RaiseClicked Method (DiagramItem, Point, MouseButton)
See Also
[image]

Raises the appropriate *Clicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseClicked (
DiagramItem item,
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked( _
item As DiagramItem, _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

item
The DiagramItem related to the event.
mousePosition

The current mouse position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseClicked Method (MouseButton, Point)

Diagram.RaiseClicked Method (MouseButton, Point)
See Also
[image]

Raises the Clicked event of the Diagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseClicked (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The current cursor position, in document coordinates.

See Also

RaiseClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseCreated Method

Diagram.RaiseCreated Method
[image]

Raises the appropriate *Created event according to the type of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseCreated (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaiseCreated( _
item As DiagramItem _
)

Parameters

item
The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseDeleting Method

Diagram.RaiseDeleting Method
[image]

Raises the appropriate *Deleting event according to the type of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseDeleting (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RaiseDeleting( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem related to the event.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseDoubleClicked Method

Diagram.RaiseDoubleClicked Method
[image]

Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items.

Overload List

Name | Description
Diagram.RaiseDoubleClicked (DiagramItem, Point, MouseButton) | Raises the appropriate *DoubleClicked event according to the type of the specified item.
Diagram.RaiseDoubleClicked (MouseButton, Point) | Raises the DoubleClicked event of the Diagram class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseDoubleClicked Method (DiagramItem, Point, MouseButton)

Diagram.RaiseDoubleClicked Method (DiagramItem, Point, MouseButton)
See Also
[image]

Raises the appropriate *DoubleClicked event according to the type of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
DiagramItem item,
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked( _
item As DiagramItem, _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

item
The DiagramItem related to the event.
mousePosition

The current cursor position, in document coordinates.

mouseButton

The mouse button related to the event.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseDoubleClicked Method (MouseButton, Point)

Diagram.RaiseDoubleClicked Method (MouseButton, Point)
See Also
[image]

Raises the DoubleClicked event of the Diagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseDoubleClicked (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Sub RaiseDoubleClicked( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The current cursor position, in document coordinates.

See Also

RaiseDoubleClicked Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLaneGridHeaderTextEdited Method

Diagram.RaiseLaneGridHeaderTextEdited Method
[image]

Raises the LaneGridHeaderTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseLaneGridHeaderTextEdited (
Header header,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseLaneGridHeaderTextEdited( _
header As Header, _
oldText As String, _
newText As String _
)

Parameters

header
The Header related to the event.
oldText

The old text of the header.

newText

The new text of the header.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLaneGridHeaderTextEditing Method

Diagram.RaiseLaneGridHeaderTextEditing Method
[image]

Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseLaneGridHeaderTextEditing (
Header header
)

Visual Basic [image] Copy Code

Public Function RaiseLaneGridHeaderTextEditing( _
header As Header _
) As Boolean

Parameters

header
The Header related to the event.

Return Value

true, if the in-place editing operation has been confirmed; otherwise false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEdited Method

Diagram.RaiseLinkTextEdited Method
[image]

Overload List

Name | Description
Diagram.RaiseLinkTextEdited (DiagramLink, String, String) | Raises the LinkTextEdited event.
Diagram.RaiseLinkTextEdited (DiagramLink, String, String, LinkLabel) | Raises the LinkTextEdited event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String)

Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String)
See Also
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link

oldText

newText

See Also

RaiseLinkTextEdited Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String, LinkLabel)

Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String, LinkLabel)
See Also
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText,
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited( _
link As DiagramLink, _
oldText As String, _
newText As String, _
label As LinkLabel _
)

Parameters

link

oldText

newText

label

See Also

RaiseLinkTextEdited Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEditing Method

Diagram.RaiseLinkTextEditing Method
[image]

Overload List

Name | Description
Diagram.RaiseLinkTextEditing (DiagramLink) | Raises the LinkTextEditing event to validate entering in-place editing mode.
Diagram.RaiseLinkTextEditing (DiagramLink, LinkLabel) | Raises the LinkTextEditing event to validate entering inplace edit mode.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEditing Method (DiagramLink)

Diagram.RaiseLinkTextEditing Method (DiagramLink)
See Also
[image]

Raises the LinkTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseLinkTextEditing (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RaiseLinkTextEditing( _
link As DiagramLink _
) As Boolean

Parameters

link

Return Value

See Also

RaiseLinkTextEditing Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseLinkTextEditing Method (DiagramLink, LinkLabel)

Diagram.RaiseLinkTextEditing Method (DiagramLink, LinkLabel)
See Also
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseLinkTextEditing (
DiagramLink link,
LinkLabel label
)

Visual Basic [image] Copy Code

Public Function RaiseLinkTextEditing( _
link As DiagramLink, _
label As LinkLabel _
) As Boolean

Parameters

link

label

Return Value

See Also

RaiseLinkTextEditing Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseNodeTextEdited Method

Diagram.RaiseNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseNodeTextEdited( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node
The DiagramNode related to the event.
oldText

The old text of the node.

newText
The new text of the node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseNodeTextEditing Method

Diagram.RaiseNodeTextEditing Method
[image]

Raises the NodeTextEditing event to validate entering in-place editing mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseNodeTextEditing (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function RaiseNodeTextEditing( _
node As DiagramNode _
) As Boolean

Parameters

node
The DiagramNode related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaisePasted Method

Diagram.RaisePasted Method
[image]

Raises the appropriate Pasted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaisePasted (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaisePasted( _
item As DiagramItem _
)

Parameters

item
The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseSelecting Method

Diagram.RaiseSelecting Method
[image]

Raises the appropriate *Selecting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseSelecting (
DiagramItem item,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Function RaiseSelecting( _
item As DiagramItem, _
mousePosition As Point _
) As Boolean

Parameters

item
The DiagramItem related to the event.
mousePosition

The current mouse position, in document coordinates.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RaiseTreeItemTextEditing Method

Diagram.RaiseTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RaiseTreeItemTextEditing (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Function RaiseTreeItemTextEditing( _
item As TreeViewItem _
) As Boolean

Parameters

item
The TreeViewItem instance related to the event.

Return Value

true if the event handler accepts the change, otherwise false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RegisterClass Method

Diagram.RegisterClass Method
[image]

Registers a class for serialization support.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void RegisterClass (
Type classType,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterClass( _
classType As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

classType

A Type instance identifying the class.

classId

A class identifier to use when saving and loading objects of the specified type.

classVersion

A revision number of the serialization format.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RegisterItemClass Method

Diagram.RegisterItemClass Method
[image]

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A Type instance identifying the item class.
classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

Remarks

When using custom item types, use this method to enable saving and loading the custom item instances to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used by your application: "std:DiagramLink", "std:ShapeNode", "std:TableNode", "std:ContainerNode" and "std:ControlNode".

The version identifier must be increased when the format in which items are saved changes. It can be used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor, or one that takes a Diagram argument. Failing to do so would result in exceptions during the load process, since the diagram will be unable to create items from the custom type.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ResizeToFitItem Method

Diagram.ResizeToFitItem Method
[image]

Resizes the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItem( _
item As DiagramItem _
)

Parameters

item
The diagram item contained in the document area.

Remarks

Resizes the document area to fit the specified diagram item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ResizeToFitItems Method
AutoResize Property


MindFusion.Diagramming.Wpf.Diagram.ResizeToFitItems Method

Diagram.ResizeToFitItems Method
[image]

Resizes the document scrollable area so it fits all diagram items.

Overload List

Name | Description
Diagram.ResizeToFitItems (Double) | Resizes the document scrollable area so it fits all diagram items.
Diagram.ResizeToFitItems (Double, Boolean) | Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoResize Property
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.ResizeToFitItems Method (Double)

Diagram.ResizeToFitItems Method (Double)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double borderGap
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Double _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

Remarks

Resizes the document area to be just as big as needed, for example, the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoResize Property
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.ResizeToFitItems Method (Double, Boolean)

Diagram.ResizeToFitItems Method (Double, Boolean)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items, optionally considering ony the visible items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double borderGap,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Double, _
onlyVisible As Boolean _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

onlyVisible
Specifies whether only the bounds of the Visible items should be included in the new document area.

Remarks

Resizes the document area to be just as big as needed, for example the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoResize Property
Bounds Property


MindFusion.Diagramming.Wpf.Diagram.RouteAllLinks Method

Diagram.RouteAllLinks Method
[image]

Routes all links in the diagram in a way they do not cross nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

Remarks

Each link is routed so that it goes the shortest possible way between the nodes it links without crossing any other nodes. To do so, this method might modify the number of link segments. The value of AutoRoute is not considered when RouteAllLinks executes.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RouteLinks Property


MindFusion.Diagramming.Wpf.Diagram.SaveToString Method

Diagram.SaveToString Method
[image]

Encodes the diagram contents into an ASCII string.

Overload List

Name | Description
Diagram.SaveToString () | Encodes the diagram contents into an ASCII string.
Diagram.SaveToString (SaveToStringFormat, Boolean) | Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromString Method


MindFusion.Diagramming.Wpf.Diagram.SaveToString Method ()

Diagram.SaveToString Method ()
See Also
[image]

Encodes the diagram contents into an ASCII string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

A string containing the encoded diagram data.

Remarks

There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MindFusion.Diagramming for WPF and a web server, passing the string as a value of a hidden HTML field.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromString Method


MindFusion.Diagramming.Wpf.Diagram.SaveToString Method (SaveToStringFormat, Boolean)

Diagram.SaveToString Method (SaveToStringFormat, Boolean)
See Also
[image]

Encodes the diagram contents into an ASCII string using the specified format and optionally clearing the Dirty flag.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format
A member of the SaveToStringFormat enumeration.
clearDirty
Indicates whether the Dirty flag should be cleared.

Return Value

A string containing the encoded diagram data.

Remarks

There are no special characters in the returned string, so the result can be easily stored in a database field or embedded into an XML document. That might be used also for transferring a diagram between a web page with embedded MindFusion.Diagramming for WPF and a web server, passing the string as a value of a hidden HTML field.

When using Xml or CompressedXml as the first argument, the diagram is saved in XML format. The same format is supported by the SaveToXml and LoadFromXml methods. CompressedXml specifies that the XML document should be further compressed in ZIP format and base-64 encoded.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromString Method


MindFusion.Diagramming.Wpf.Diagram.SaveToXml Method

Diagram.SaveToXml Method
[image]

Saves the diagram to an XML document.

Overload List

Name | Description
Diagram.SaveToXml (String) | Saves the diagram to the specified file as an XML document.
Diagram.SaveToXml (XmlDocument) | Saves the diagram to the specified XML document.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.Diagram.SaveToXml Method (String)

Diagram.SaveToXml Method (String)
See Also
[image]

Saves the diagram to the specified file as an XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The full path and name of the disk file where the diagram should be saved.

Remarks

The first overloaded SaveToXml method works by creating an XmlDocument instance, calling the second overloaded method, and writing the document content to a file.

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.Diagram.SaveToXml Method (XmlDocument)

Diagram.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the diagram to the specified XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object where the diagram should be saved.

Remarks

Diagram data can be loaded from an XML file or document using the LoadFromXml method.

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.Diagram.ScrollTo Method

Diagram.ScrollTo Method
[image]

Scrolls the document to the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
Point newTopLeft
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
newTopLeft As Point _
)

Parameters

newTopLeft

The point to which it should be scrolled to, in the current units of measure.

Remarks

Call the method to move the scroll bar and the current view of the document to a new position, as set by the method's parameters.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.SetIsDiagramScroller Method

Diagram.SetIsDiagramScroller Method
[image]

Sets the value of the IsDiagramScroller attached property to a given element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetIsDiagramScroller (
DependencyObject obj,
bool value
)

Visual Basic [image] Copy Code

Public Shared Sub SetIsDiagramScroller( _
obj As DependencyObject, _
value As Boolean _
)

Parameters

obj

The element on which to set the IsDiagramScroller attached property.

value

The property value to set.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.SetItemBounds Method

Diagram.SetItemBounds Method
[image]

Sets the location and size of the specified item within the current diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetItemBounds (
UIElement item,
Rect value
)

Visual Basic [image] Copy Code

Public Shared Sub SetItemBounds( _
item As UIElement, _
value As Rect _
)

Parameters

item
The diagram item whose bounding rectangle should be set.
value

A .NET Rect object specifying the item's bounding rectangle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.SetZoomFactor Method

Diagram.SetZoomFactor Method
[image]

Sets the zoom factor, preserving the on-screen position of the specified diagram point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

The new zoom factor.

pivotPoint
A Point instance specifying the zoom center.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ZoomFactor Property


MindFusion.Diagramming.Wpf.Diagram.UnitToPixel Method

Diagram.UnitToPixel Method
[image]

Converts the specified point from document to client coordinates ignoring the current scale transformation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point UnitToPixel (
Point point
)

Visual Basic [image] Copy Code

Public Function UnitToPixel( _
point As Point _
) As Point

Parameters

point
The Point instance to convert.

Return Value

A Point representing the client coordinates of the diagram point specified as an argument.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.UpdateRuntimeIndices Method

Diagram.UpdateRuntimeIndices Method
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateRuntimeIndices ()

Visual Basic [image] Copy Code

Public Sub UpdateRuntimeIndices ()

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ZoomIn Method

Diagram.ZoomIn Method
[image]

Zooms document's items thus making them appear closer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomIn ()

Visual Basic [image] Copy Code

Public Sub ZoomIn ()

Remarks

Call this method every time you want to make diagram items appear nearer and bigger. It increases the ZoomFactor with 10 each time it executes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ZoomFactor Property
ZoomOut Method
SetZoomFactor Method


MindFusion.Diagramming.Wpf.Diagram.ZoomOut Method

Diagram.ZoomOut Method
[image]

Zooms the diagram out making items appear further away.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomOut ()

Visual Basic [image] Copy Code

Public Sub ZoomOut ()

Remarks

Call this method if you want to make the diagram items appear further and smaller. It decreases the ZoomFactor with 10 each time it executes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ZoomFactor Property
ZoomIn Method
SetZoomFactor Method


MindFusion.Diagramming.Wpf.Diagram.ZoomToFit Method

Diagram.ZoomToFit Method
[image]

Zooms the view to fit the document contents in the Diagram client area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToFit ()

Visual Basic [image] Copy Code

Public Sub ZoomToFit ()

Remarks

ZoomToFit calculates the extents of the rectangle that contain all diagram items and sets the scroll position and zoom factor of the view to fit exactly that rectangle. As a result the whole diagram is displayed on the screen, with the lowest possible zoom.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ZoomFactor Property
SetZoomFactor Method


MindFusion.Diagramming.Wpf.Diagram.ZoomToRect Method

Diagram.ZoomToRect Method
[image]

Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Overload List

Name | Description
Diagram.ZoomToRect (Rect) | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.
Diagram.ZoomToRect (Rect, Boolean) | Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ZoomToRect Method (Rect)

Diagram.ZoomToRect Method (Rect)
See Also
[image]

Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToRect (
Rect rect
)

Visual Basic [image] Copy Code

Public Sub ZoomToRect( _
rect As Rect _
)

Parameters

rect
A Rect instance specifying the diagram region that should be displayed.

Remarks

The scroll position and zoom factor of the view are set so the specified rectangular area of the document is entirely visible in the diagram's client area. This method works correctly only if the Diagram is placed inside a ScrollViewer.

See Also

ZoomToRect Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ZoomToRect Method (Rect, Boolean)

Diagram.ZoomToRect Method (Rect, Boolean)
See Also
[image]

Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToRect (
Rect rect,
bool centered
)

Visual Basic [image] Copy Code

Public Sub ZoomToRect( _
rect As Rect, _
centered As Boolean _
)

Parameters

rect
A Rect instance specifying the diagram region that should be displayed.
centered
true to center the specified region in the viewport; otherwise, false.

Remarks

The scroll position and zoom factor of the view are set so the specified rectangular area of the document is entirely visible in the diagram's client area. If the aspect ratio of the specified rectangle is different than the one of the viewport, the rectangle can be optionally centered in the available space as set through the boolean argument.

This method works correctly only if the Diagram is placed inside a ScrollViewer or Ruler.

See Also

ZoomToRect Method Overload List
Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Attached Properties

Diagram Attached Properties
[image]

Public Attached Properties

Name | Description
IsDiagramScrollerProperty | Gets or sets a value indicating whether a ScrollViewer should be associated as a scroller for an underlying diagram.

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsDiagramScroller Attached Property

Diagram.IsDiagramScroller Attached Property
[image]

Gets or sets a value indicating whether a ScrollViewer should be associated as a scroller for an underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

See Diagram.GetIsDiagramScroller, Diagram.SetIsDiagramScroller

Visual Basic [image] Copy Code

See Diagram.GetIsDiagramScroller, Diagram.SetIsDiagramScroller

Property Value

true to indicate that the ScrollViewer is registered as a scrolling container for a diagram; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram Properties

Diagram Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created.
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the image displayed as background of this diagram.
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes.
Behavior | Gets or sets a value indicating how the control responds to user actions.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Gets or sets the default value for the Caption property of containers.
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets or sets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
Content | With this property, you can define diagram elements from XAML code.
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input.
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing.
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items.
DefaultShape | Gets or sets the default shape of shape nodes.
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
DiagramLinkStyle | Gets or sets the theme-level style for diagram links.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location.
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.
DocumentPlane | Gets the document plane of the diagram.
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EnableLanes | Gets or sets whether lanes are enabled.
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
Font | Gets or sets the default font for new diagram items.
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid.
GridPen | Gets or sets the pen used to draw the grid lines or points.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
Groups | Gets a collection of all groups in the diagram.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text.
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text.
InplaceEditFont | Gets or sets the font of the inplace-editing text box.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user.
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control.
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control.
Items | Gets a collection of all items in this diagram.
LaneGrid | Gets the Grid instance that represents the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all DiagramLink objects in the diagram.
LinkSegments | Gets or sets the default number of link segments.
LinkShape | Gets or sets the default shape of diagram links.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool.
MagnifierHeight | Gets or sets the height of the magnifier tool.
MagnifierStyle | Gets or sets the style of the magnifier tool.
MagnifierWidth | Gets or sets the width of the magnifier tool.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items.
ModificationStart | Gets or sets how users can start modifying diagram items.
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all DiagramNode objects in the diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view.
PanInertia | Gets or sets a value indicating whether panning the view will have inertia.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed.
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RemoveHiddenItemsFromVisualTree | For internal use.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle.
RotationStep | Gets or sets the RotationAngle increment when users rotate a node.
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control.
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets a Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points.
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets or sets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default shape of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
TextBrush | Gets or sets the default brush of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes.
UndoManager | Gets a reference to the diagram's UndoManager instance.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.
Viewport | Returns the visible portion of the diagram area.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram.

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.
VisualChildrenCount | Visual.VisualChildrenCount override.

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ActiveItem Property

Diagram.ActiveItem Property
[image]

Gets or sets the active diagram element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem ActiveItem { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveItem As DiagramItem

Property Value

A reference to the DiagramItem instance that is currently active.

Remarks

Use this property to get the active item - the one selected by the user or the last put in a multiple Selection. It is shown with white selection handles by default.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ActiveItemHandlesBrush Property
SelectionOnTop Property


MindFusion.Diagramming.Wpf.Diagram.ActiveItemHandlesStyle Property

Diagram.ActiveItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of the active item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesVisualStyle ActiveItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ActiveItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of adjustment handles drawn around the active item.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ActiveItem Property
SelectedItemHandlesStyle Property
DisabledHandlesStyle Property


MindFusion.Diagramming.Wpf.Diagram.ActiveLayer Property

Diagram.ActiveLayer Property
[image]

Gets or sets the zero-based index of the active layer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ActiveLayer { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveLayer As Integer

Property Value

An integer value.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AdapterHandlesStyle Property

Diagram.AdapterHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle AdapterHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AdapterHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default value is HatchHandles.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AdjustmentHandlesSize Property

Diagram.AdjustmentHandlesSize Property
[image]

Gets or sets the size of the handles, which appear around selected objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double AdjustmentHandlesSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandlesSize As Double

Property Value

A double value specifying the height of the selection handles. The default is 2.

Remarks

Use the property to set the size of the manipulation handles, which appear around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ModificationStart Property
SelectedItemHandlesBrush Property


MindFusion.Diagramming.Wpf.Diagram.AlignmentGuidePen Property

Diagram.AlignmentGuidePen Property
[image]

Gets or sets the pen used to draw alignment guides.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen AlignmentGuidePen { get; set; }

Visual Basic [image] Copy Code

Public Property AlignmentGuidePen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

This pen is used to draw alignment guides shown when AutoAlignNodes is enabled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoAlignDistance Property


MindFusion.Diagramming.Wpf.Diagram.AlignToGrid Property

Diagram.AlignToGrid Property
[image]

Gets or sets a value indicating whether the diagram items should be aligned to a grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AlignToGrid { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToGrid As Boolean

Property Value

true if the grid is activated; otherwise, false. The default is true.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
GridPen Property
GridSizeX Property
GridSizeY Property
AlignPointToGrid Method
AutoAlignNodes Property
DiagramNode.GridAlignPoint Property


MindFusion.Diagramming.Wpf.Diagram.AllowInplaceEdit Property

Diagram.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true if in-place editing is allowed, otherwise false. The default is false.

Remarks

Specifies whether users are allowed to edit in-place text of diagram nodes. If enabled, a text-entry field appears at node's position when the node is double-clicked. In-place editing mode can be exited by clicking anywhere outside the text-field. When this happens, the control raises NodeTextEdited if a node has been edited, or CellTextEdited if a table cell has been edited.

To enter or exit in-place editing mode programmatically, use the BeginEdit and EndEdit methods of Diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
InplaceEditFont Property
InplaceEditAcceptOnEnter Property
InplaceEditCancelOnEsc Property


MindFusion.Diagramming.Wpf.Diagram.AllowLinkCursor Property

Diagram.AllowLinkCursor Property
[image]

Gets or sets the mouse cursor shown to the user when an arrow can be created.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor AllowLinkCursor { get; set; }

Visual Basic [image] Copy Code

Public Property AllowLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Hand.

Remarks

Use the property to indicate visually to the user that the mouse is over a location where link can be created (ended).

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DisallowCursor Property
DrawLinkCursor Property
MoveCursor Property
PointerCursor Property
DisallowLinkCursor Property


MindFusion.Diagramming.Wpf.Diagram.AllowLinksRepeat Property

Diagram.AllowLinksRepeat Property
[image]

Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowLinksRepeat { get; set; }

Visual Basic [image] Copy Code

Public Property AllowLinksRepeat As Boolean

Property Value

true if repeated links are allowed; otherwise, false. The default is true.

Remarks

Specifies whether more than one link can connect the same origin and destination diagram nodes. If set to false, two diagram nodes can be connected with at most one link in a single direction.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowSelfLoops Property


MindFusion.Diagramming.Wpf.Diagram.AllowMultipleResize Property

Diagram.AllowMultipleResize Property
[image]

Specifies whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowMultipleResize { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleResize As Boolean

Property Value

true to let the user resize multiple selected nodes; otherwise, false. The default value is false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AllowSelfLoops Property

Diagram.AllowSelfLoops Property
[image]

Gets or sets a value indicating whether self-loops are allowed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowSelfLoops { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSelfLoops As Boolean

Property Value

true if self loops are allowed; otherwise, false. The default is true.

Remarks

Use the property to specify whether the user is allowed to draw self loops - links that connect a node to itself.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowLinksRepeat Property


MindFusion.Diagramming.Wpf.Diagram.AllowSplitLinks Property

Diagram.AllowSplitLinks Property
[image]

Gets or sets a value indicating whether link segments can be added and removed interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowSplitLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSplitLinks As Boolean

Property Value

true if interactive adding/removing of link segments allowed; false if not.

Remarks

You can insert new link segments interactively by clicking and dragging a point of a selected link's segment. For polyline-style links this creates one additional segment by splitting the existing one into two parts. For cascading links there are two segments inserted, keeping intact the alternating pattern of horizontal and vertical segments, each orthogonal to its neighbors.

Segments can be merged by moving their joining point until the angle between reaches certain threshold value. In case of cascading and Bezier links, segments can be merged by placing adjacent control points close to each other, as set in MergeThreshold.

This property also affects how users can change the orientation of cascading links. For more details see CascadeOrientation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LinkSplit Event
LinkSegments Property
LinkShape Property


MindFusion.Diagramming.Wpf.Diagram.AllowUnanchoredLinks Property

Diagram.AllowUnanchoredLinks Property
[image]

Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowUnanchoredLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnanchoredLinks As Boolean

Property Value

Remarks

AllowUnanchoredLinks applies to nodes whose AnchorPattern is not set or does not contain incoming or outgoing anchor points available. If the property is enabled, users can connect links to any point of such nodes. If disabled, users cannot connect links to such nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AnchorPoint.AllowIncoming Property
AnchorPoint.AllowOutgoing Property


MindFusion.Diagramming.Wpf.Diagram.AllowUnconnectedLinks Property

Diagram.AllowUnconnectedLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowUnconnectedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnconnectedLinks As Boolean

Property Value

true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes might be of type DummyNode.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowUnanchoredLinks Property


MindFusion.Diagramming.Wpf.Diagram.AutoAlignDistance Property

Diagram.AutoAlignDistance Property
[image]

Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double AutoAlignDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignDistance As Double

Property Value

A double value specifying the maximal alignment distance. The default value is 8.

Remarks

To enable node alignment, set AutoAlignNodes to true. When either the horizontal or vertical borders of the dragged node are within the specified distance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AlignmentGuidePen Property


MindFusion.Diagramming.Wpf.Diagram.AutoAlignNodes Property

Diagram.AutoAlignNodes Property
[image]

Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoAlignNodes { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignNodes As Boolean

Property Value

true to align nodes, otherwise false. The default value is false.

Remarks

When either the horizontal or vertical borders of the dragged node are within AutoAlignDistance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned. In addition, an alignment guide that indicates which borders are aligned is drawn using the pen specified through AlignmentGuidePen.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AlignToGrid Property
AutoSnapLinks Property


MindFusion.Diagramming.Wpf.Diagram.AutoCloseDistance Property

Diagram.AutoCloseDistance Property
[image]

Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double AutoCloseDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoCloseDistance As Double

Property Value

A double value. The default is double.MaxValue, which always auto-closes FreeFormNodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.AutoHighlightRows Property

Diagram.AutoHighlightRows Property
[image]

Gets or sets whether a table row should be highlighted when the user clicks on it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoHighlightRows { get; set; }

Visual Basic [image] Copy Code

Public Property AutoHighlightRows As Boolean

Property Value

true to highlight clicked table rows, otherwise false; the default value is false.

Remarks

A row is highlighted by setting the HighlightedRow property of a TableNode.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RowHighlightBrush Property


MindFusion.Diagramming.Wpf.Diagram.AutoResize Property

Diagram.AutoResize Property
[image]

Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AutoResize AutoResize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoResize As AutoResize

Property Value

A member of the AutoResize enumeration. The default is AutoResize.RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved, either by end-users or by method calls. The following AutoResize values specify in what directions the diagram area is allowed to grow:

Member name | Description
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Bounds Property
ResizeToFitItems Method


MindFusion.Diagramming.Wpf.Diagram.AutoScroll Property

Diagram.AutoScroll Property
[image]

Gets or sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScroll As Boolean

Property Value

true if auto scrolling is enabled; otherwise, false. The default is true.

Remarks

Enable this property to have the document scroll automatically when new items are added or existing items are being dragged outside the visible area. The Diagram must be a child of a ScrollViewer in order for automatic scrolling to work correctly.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ScrollX Property
ScrollY Property
ScrollZoneSize Property
AutoResize Property


MindFusion.Diagramming.Wpf.Diagram.AutoSnapDistance Property

Diagram.AutoSnapDistance Property
[image]

Specifies the maximum distance at which links auto-snap to nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double AutoSnapDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapDistance As Double

Property Value

A double value specifying the maximum auto-snap distance. The default value is 60.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoSnapLinks Property


MindFusion.Diagramming.Wpf.Diagram.AutoSnapLinks Property

Diagram.AutoSnapLinks Property
[image]

Gets or sets the default value for the AutoSnapToNode property of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoSnapLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapLinks As Boolean

Property Value

true to snap links to nearest node, otherwise false; the default value is false.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DynamicLinks Property
AutoAlignNodes Property


MindFusion.Diagramming.Wpf.Diagram.BackBrush Property

Diagram.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class. The default is a solid brush initialized with Color.FromArgb(170, 170, 200).

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

Example

The following sample paints the MindFusion.Wpf Package's background with a gradient brush:

C# [image] Copy Code
private void diagram_Loaded(object sender, RoutedEventArgs e)
{
diagram.BackBrush = new LinearGradientBrush(
Colors.LightBlue, Colors.LightCyan, 30);
}
Visual Basic [image] Copy Code
Private Sub diagram_Loaded(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs)
diagram.BackBrush = New LinearGradientBrush( _
Colors.LightBlue, Colors.LightCyan, 30)
End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.BackgroundImage Property

Diagram.BackgroundImage Property
[image]

Gets or sets the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource BackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImage As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class.

Remarks

This image is painted as a background of the diagram, behind the alignment grid and all items. Its position is controlled by the BackgroundImageAlign property. To have the background image appear on printed pages, set the EnableBackgroundImage property of Diagram.PrintOptions to true.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
BackgroundImageAlign Property
BackBrush Property


MindFusion.Diagramming.Wpf.Diagram.BackgroundImageAlign Property

Diagram.BackgroundImageAlign Property
[image]

Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageAlign BackgroundImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is ImageAlign.Document.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

Example

To have a background image stretched along the drawing surface, use code like the following:

C# [image] Copy Code
Uri uri = new Uri(@"IMG0314.jpg");
diagram.BackgroundImage = new BitmapImage(uri);
diagram.BackgroundImageAlign = ImageAlign.Stretch;
Visual Basic [image] Copy Code
Dim uri As Uri = New Uri("IMM0314.jpg")
diagram.BackgroundImage = New BitmapImage(uri)
diagram.BackgroundImageAlign = ImageAlign.Stretch

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Enumeration
BackgroundImage Property


MindFusion.Diagramming.Wpf.Diagram.BarcodeNodeStyle Property

Diagram.BarcodeNodeStyle Property
[image]

Gets or sets the theme-level style for barcode nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style BarcodeNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property BarcodeNodeStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Behavior Property

Diagram.Behavior Property
[image]

Gets or sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration. The default is LinkShapes.

Remarks

The property specifies how the control responds to user actions with the mouse. The default value, LinkShapes, facilitates drawing of flowchart diagrams. LinkTables makes MindFusion.Diagramming for WPF create table nodes and links while the user draws with the mouse, allowing creation of entity-relationship or class-hierarchy diagrams. There are several more values that can be assigned to the property, that make the control draw single types of items, for example only shape nodes, only control hosts, only links, and so on. These are useful when implementing the ability to select specific drawing tools in applications.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Behavior Enumeration
ModificationStart Property


MindFusion.Diagramming.Wpf.Diagram.Bounds Property

Diagram.Bounds Property
[image]

Gets or sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

An instance of the .NET Rect structure. The default size of the document is the standard A4 size, that is 210x297.

Remarks

Use this property to specify how large a document should be, that is, how far it can be scrolled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
MeasureUnit Property
RestrictItemsToBounds Property
AutoResize Property


MindFusion.Diagramming.Wpf.Diagram.CellCustomDraw Property

Diagram.CellCustomDraw Property
[image]

Gets or sets the default type of custom painting done on the cells of tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is CustomDraw.None.

Remarks

The CellCustomDraw member of new tables is initialized from this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableCustomDraw Property


MindFusion.Diagramming.Wpf.Diagram.CellFrameStyle Property

Diagram.CellFrameStyle Property
[image]

Gets or sets the default cell border style of new tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. The default is CellFrameStyle.System3D.

Remarks

Use this property to specify the default border style of cells in new tables. See CellFrameStyle enumeration for more details.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerCaption Property

Diagram.ContainerCaption Property
[image]

Gets or sets the default value for the Caption property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ContainerCaption { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaption As String

Property Value

A string specifying the initial caption text of containers. The default is "Container".

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerCaptionHeight Property

Diagram.ContainerCaptionHeight Property
[image]

Gets or sets the default value for the CaptionHeight property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ContainerCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaptionHeight As Double

Property Value

A double value specifying the initial height of containers' caption bars. The default is 5.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerHighlightPen Property

Diagram.ContainerHighlightPen Property
[image]

Gets or sets the default value for the HighlightPen property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen ContainerHighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerHighlightPen As Pen

Property Value

A .NET Pen instance specifying the initial highlight pen of containers. The default is a pen with Color.LightSkyBlue color and width 0.5.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerMargin Property

Diagram.ContainerMargin Property
[image]

Gets or sets the default value for the Margin property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ContainerMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMargin As Double

Property Value

A double value specifying the initial margin size of containers. The default is 10.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerMinimumSize Property

Diagram.ContainerMinimumSize Property
[image]

Gets or sets the default value for the MinimumSize property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size ContainerMinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMinimumSize As Size

Property Value

A Size value specifying the initial minimum size of containers. The default is 50x40.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainerNodeStyle Property

Diagram.ContainerNodeStyle Property
[image]

Gets or sets the theme-level style for container nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style ContainerNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerNodeStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ContainersFoldable Property

Diagram.ContainersFoldable Property
[image]

Gets or sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ContainersFoldable { get; set; }

Visual Basic [image] Copy Code

Public Property ContainersFoldable As Boolean

Property Value

A boolean value specifying whether containers are initially foldable. The default is true.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Content Property

Diagram.Content Property
[image]

With this property, you can define diagram elements from XAML code.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList Content { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Content As IList

Property Value

An instance of the ContentCollection class.

Remarks

Do not use this property directly.

Example

The objects created by the XAML parser are added to the Content property. You can use that to define diagram items in XAML:

XAML [image] Copy Code

<d:Diagram Name="diagram" xmlns:d="http://mindfusion.eu/diagramming/wpf">
<d:ShapeNode Bounds="10, 10, 20, 20" Text="A shape"></d:ShapeNode>
</d:Diagram>

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ControlMouseAction Property

Diagram.ControlMouseAction Property
[image]

Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ControlMouseAction ControlMouseAction { get; set; }

Visual Basic [image] Copy Code

Public Property ControlMouseAction As ControlMouseAction

Property Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CounterDiagonalResizeCursor Property

Diagram.CounterDiagonalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor CounterDiagonalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property CounterDiagonalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNESW.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item both vertically and horizontally.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
HorizontalResizeCursor Property
VerticalResizeCursor Property
DiagonalResizeCursor Property


MindFusion.Diagramming.Wpf.Diagram.CrossingRadius Property

Diagram.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Double

Property Value

A double value specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RoundedLinksRadius Property


MindFusion.Diagramming.Wpf.Diagram.CustomBehavior Property

Diagram.CustomBehavior Property
[image]

Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BehaviorBase CustomBehavior { get; set; }

Visual Basic [image] Copy Code

Public Property CustomBehavior As BehaviorBase

Property Value

An instance of a BehaviorBase-derived class. The default value is null (Nothing in Visual Basic).

Remarks

MindFusion.Diagramming for WPF provides several stock implementations of the BehaviorBase class that can be used by assigning a member of the Behavior enumeration to the view's Behavior property. Create a custom behavior class only if the predefined ones don't meet your application requirements.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.CustomLinkType Property

Diagram.CustomLinkType Property
[image]

Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Type CustomLinkType { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLinkType As Type

Property Value

A reference to a System.Type that specifies the custom link class.

Remarks

You must set Behavior to Custom to enable creating links of your custom type interactively.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CustomNodeType Property


MindFusion.Diagramming.Wpf.Diagram.CustomNodeType Property

Diagram.CustomNodeType Property
[image]

Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Type CustomNodeType { get; set; }

Visual Basic [image] Copy Code

Public Property CustomNodeType As Type

Property Value

A reference to a System.Type that specifies the custom node class.

Remarks

You must set Behavior to Custom to enable creating nodes of your custom type interactively.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CustomLinkType Property


MindFusion.Diagramming.Wpf.Diagram.DefaultControlType Property

Diagram.DefaultControlType Property
[image]

Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Type DefaultControlType { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultControlType As Type

Property Value

A reference to the System.Type that specifies a class of WPF controls to create.

Remarks

DefaultControlType must be set to a subclass of UIElement. In addition, the type must provide a constructor that takes no parameters.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DefaultEffect Property

Diagram.DefaultEffect Property
[image]

Gets or sets the default value for UIElement.Effect property of new items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Effect DefaultEffect { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultEffect As Effect

Property Value

An instance of the System.Windows.Media.Effects.Effect class. The default value is null (Nothing in Visual Basic).

Remarks

You can assign a DropShadowEffect object to this property to render shadows under all newly created diagram elements.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DefaultShape Property

Diagram.DefaultShape Property
[image]

Gets or sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape DefaultShape { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultShape As Shape

Property Value

An instance of the Shape class. The default is the RoundRect shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are 87 predefined shapes exposed as static members of the Shape class. You can also define your own shapes as shown below.

Example

The following example demonstrates how to create a custom shape and set it as a default in the diagram:

C# [image] Copy Code
private void example_Click(object sender, RoutedEventArgs e)
{
// Define a custom shape
// this is the same as: fc.DefaultShape = Shape.FromId("Tape");
diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(50, 100, 85, 100),
new LineTemplate(85, 100, 85, 90),
new LineTemplate(85, 90, 70, 90),
new BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0),
new BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50),
new BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100) },
FillRule.EvenOdd);
}
Visual Basic [image] Copy Code

Private Sub example_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs) Handles example.Click

' Define a custom shape
' this is the same as: fc.DefaultShape = Shape.FromId("Tape")
diagram.DefaultShape = New Shape( _
New ElementTemplate() { _
New LineTemplate(50, 100, 85, 100), _
New LineTemplate(85, 100, 85, 90), _
New LineTemplate(85, 90, 70, 90), _
New BezierTemplate(70, 90, 85, 90, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 75, 0, 50, 0), _
New BezierTemplate(50, 0, 25, 0, 0, 25, 0, 50), _
New BezierTemplate(0, 50, 0, 75, 25, 100, 50, 100)}, _
FillRule.EvenOdd)

End Sub

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShapeNode.Shape Property
Shape.FromId Method
Shape.Shapes Property
ShapeOrientation Property


MindFusion.Diagramming.Wpf.Diagram.DelKeyAction Property

Diagram.DelKeyAction Property
[image]

Gets or sets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DelKeyAction DelKeyAction { get; set; }

Visual Basic [image] Copy Code

Public Property DelKeyAction As DelKeyAction

Property Value

A member of the DelKeyAction enumeration. The default value is DeleteSelectedItems.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
NodeDeleting Event
LinkDeleting Event


MindFusion.Diagramming.Wpf.Diagram.DiagonalResizeCursor Property

Diagram.DiagonalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor DiagonalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DiagonalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNWSE.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item both vertically and horizontally.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
HorizontalResizeCursor Property
VerticalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.Wpf.Diagram.DiagramLinkStyle Property

Diagram.DiagramLinkStyle Property
[image]

Gets or sets the theme-level style for diagram links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style DiagramLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DiagramLinkStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Dirty Property

Diagram.Dirty Property
[image]

Gets or sets a value indicating whether the diagram has changed since the last save.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Dirty { get; set; }

Visual Basic [image] Copy Code

Public Property Dirty As Boolean

Property Value

A boolean value that indicates whether the diagram has changed.

Remarks

MindFusion.Diagramming for WPF tracks all changes that are done on the diagram contents, either programmatically or by users. If there are changes that are still not saved, the property has value of true. The Dirty flag is cleared automatically when a document is loaded from file or stream. When a document is saved the Dirty flag can be cleared as specified in an argument of the Save* methods.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DirtyChanged Event
Selection.SetsDirtyFlag Property


MindFusion.Diagramming.Wpf.Diagram.DisabledHandlesStyle Property

Diagram.DisabledHandlesStyle Property
[image]

Gets the visual style of disabled adjustment handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesVisualStyle DisabledHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DisabledHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of disabled adjustment handles.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramNode.EnabledHandles Property
ActiveItemHandlesStyle Property
SelectedItemHandlesStyle Property


MindFusion.Diagramming.Wpf.Diagram.DisallowCursor Property

Diagram.DisallowCursor Property
[image]

Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor DisallowCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DisallowCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.No.

Remarks

Use the property to demonstrate visually to the user that an item cannot be created at the current mouse position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowLinkCursor Property


MindFusion.Diagramming.Wpf.Diagram.DisallowLinkCursor Property

Diagram.DisallowLinkCursor Property
[image]

Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor DisallowLinkCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DisallowLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.No.

Remarks

Use the property to indicate visually to the user that the mouse is over a place, where the currently dragged link cannot be ended.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DisallowCursor Property
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property


MindFusion.Diagramming.Wpf.Diagram.DocumentPaginator Property

Diagram.DocumentPaginator Property
[image]

Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

An instance of the System.Windows.Documents.DocumentPaginator class.

Remarks

You can use this property as an argument to the PrintDocument.PrintDocument method.

Example

C# [image] Copy Code

PrintDialog pd = new PrintDialog();

if (pd.ShowDialog())
pd.PrintDocument(diagram.DocumentPaginator, "my diagram");

Visual Basic [image] Copy Code

Dim pd As New PrintDialog()

If pd.ShowDialog() Then
pd.PrintDocument(diagram.DocumentPaginator, "my diagram")
End If

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DocumentPlane Property

Diagram.DocumentPlane Property
[image]

Gets the document plane of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UIElement DocumentPlane { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DocumentPlane As UIElement

Property Value

An instance of the .NET UIElement class.

Remarks

DocumentPlane is visual child of diagram and ancestor of all diagram items. The DocumentPlane element is translated with respect to Diagram element so that the point Diagram.Bounds.TopLeft from the DocumentPlane is rendered at Diagram element location (0,0) The coordinate system of the DocumentPlane is the document coordinate system. The inteded use of this property is mainly in MouseMove event handling.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DocumentToDiagramMatrix Property

Diagram.DocumentToDiagramMatrix Property
[image]

Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual Matrix DocumentToDiagramMatrix { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property DocumentToDiagramMatrix As Matrix

Property Value

A System.Windows.Media.Matrix instance representing the current transformation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.DrawLinkCursor Property

Diagram.DrawLinkCursor Property
[image]

Gets or sets the mouse cursor shown to the user when a link can be started at the current position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor DrawLinkCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DrawLinkCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Hand.

Remarks

Use the property to indicate visually to the user that a link can be started at the current mouse position.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DisallowCursor Property
MoveCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowLinkCursor Property


MindFusion.Diagramming.Wpf.Diagram.DynamicLinks Property

Diagram.DynamicLinks Property
[image]

Gets or sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool DynamicLinks { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicLinks As Boolean

Property Value

true if dynamic links are enabled; otherwise, false. The default is false.

Remarks

Use the property to specify whether links automatically reposition their end segments, so they keep pointing to the centers of connected nodes. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them.

If the value is false, links do not look for the center of the origin and destination node, but keep their relative position as set when they were created - from the left corner of the first node to the top of the other node for instance.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.Dynamic Property
AllowSplitLinks Property


MindFusion.Diagramming.Wpf.Diagram.EnableLanes Property

Diagram.EnableLanes Property
[image]

Gets or sets whether lanes are enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableLanes { get; set; }

Visual Basic [image] Copy Code

Public Property EnableLanes As Boolean

Property Value

Remarks

You can customize the lane grid through the LaneGrid property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.EnableStyledText Property

Diagram.EnableStyledText Property
[image]

Gets or sets the default value for the EnableStyledText property of new nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of items in order to find formatting tags; otherwise, false. The default is false.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ExpandButtonAction Property

Diagram.ExpandButtonAction Property
[image]

Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ExpandButtonAction ExpandButtonAction { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonAction As ExpandButtonAction

Property Value

A member of the ExpandButtonAction enumeration. The default is ExpandTreeBranch.

Remarks

The default behavior of a [±] button displayed nearby an Expandable node is to hide or show the children of that node. In that case, the children of a node are all nodes that can be reached from it by following recursively the OutgoingLinks or IncomingLinks, as defined by the ExpandOnIncoming property.

To implement custom expand/collapse functionality, set ExpandButtonAction to RaiseEvents and handle the ExpandButtonClicked event. That lets you use other criteria for what nodes should be shown or hidden, for example, containment or hierarchical grouping.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ExpandButtonPosition Property
TreeCollapsed Event
TreeExpanded Event


MindFusion.Diagramming.Wpf.Diagram.ExpandButtonPosition Property

Diagram.ExpandButtonPosition Property
[image]

Gets or sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ExpandButtonPosition ExpandButtonPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonPosition As ExpandButtonPosition

Property Value

A member of the ExpandButtonPosition enumeration. The default is OuterRight.

Remarks

If diagram links tend to flow vertically, it would be useful to have the expand/collapse buttons stay at the left- or right-hand side of nodes. If diagram links tend to flow horizontally, choose position for expand buttons such that they stay above or below nodes. That will prevent button icons from being overlapped by links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
NodesExpandable Property
ExpandButtonAction Property
CustomExpandButtonPosition Field


MindFusion.Diagramming.Wpf.Diagram.ExpandOnIncoming Property

Diagram.ExpandOnIncoming Property
[image]

Gets or sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ExpandOnIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandOnIncoming As Boolean

Property Value

true if trees are expanded in the direction of the links, which come into nodes; otherwise, false. The default is false.

Remarks

Use this property when presenting tree structures with enabled collapse/expand. If the property is set to false, a clicked expand button of a node expands in the direction of the node's outgoing links. That is, the nodes pointed by links going out of a node are considered children of that node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RecursiveExpand Property
NodesExpandable Property


MindFusion.Diagramming.Wpf.Diagram.Factory Property

Diagram.Factory Property
[image]

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Factory Factory { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Factory As Factory

Property Value

An instance of the Factory class.

Remarks

You can add a new node or link to the diagram by creating an instance of the item class by using the new operator and adding it to the Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming for WPF predefined types. The Factory class methods are just shortcuts that let you do that with a single method call, and they work only for the predefined item classes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Font Property

Diagram.Font Property
[image]

Gets or sets the default font for new diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

An instance of the .NET Font class.

Remarks

The Font of new nodes and links is initialized with the value of this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramView.TextRenderingHint Property


MindFusion.Diagramming.Wpf.Diagram.FreeFormAttractDistance Property

Diagram.FreeFormAttractDistance Property
[image]

Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double FreeFormAttractDistance { get; set; }

Visual Basic [image] Copy Code

Public Property FreeFormAttractDistance As Double

Property Value

A double value. The default is 30.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.FreeFormTargets Property

Diagram.FreeFormTargets Property
[image]

An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape[] FreeFormTargets { get; set; }

Visual Basic [image] Copy Code

Public Property FreeFormTargets As Shape()

Property Value

An array of Shape objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.GridOffsetX Property

Diagram.GridOffsetX Property
[image]

Gets or sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetX As Double

Property Value

A double value that specifies the horizontal grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeX / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
GridOffsetY Property
MeasureUnit Property


MindFusion.Diagramming.Wpf.Diagram.GridOffsetY Property

Diagram.GridOffsetY Property
[image]

Gets or sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetY As Double

Property Value

A double value that specifies the vertical grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeY / 2.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
GridOffsetX Property
MeasureUnit Property


MindFusion.Diagramming.Wpf.Diagram.GridPen Property

Diagram.GridPen Property
[image]

Gets or sets the pen used to draw the grid lines or points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen GridPen { get; set; }

Visual Basic [image] Copy Code

Public Property GridPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class. The default is a solid-color pen with RGB = 140,140,150.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
GridStyle Property


MindFusion.Diagramming.Wpf.Diagram.GridSizeX Property

Diagram.GridSizeX Property
[image]

Gets or sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeX As Double

Property Value

A double number specifying the horizontal distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Wpf.Diagram.GridSizeY Property

Diagram.GridSizeY Property
[image]

Gets or sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeY As Double

Property Value

A double number specifying the vertical distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
AlignToGrid Property
AlignPointToGrid Method
MeasureUnit Property


MindFusion.Diagramming.Wpf.Diagram.GridStyle Property

Diagram.GridStyle Property
[image]

Gets or sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GridStyle GridStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridStyle As GridStyle

Property Value

A member of the GridStyle enumeration. The default is Points.

Remarks

Specifies how the alignment grid is drawn. If the property value is set to Points, the grid is painted as a matrix of points. If set to Lines, the grid is represented as a series of crossing horizontal and vertical lines. Grid points or lines are drawn using the pen set in GridPen; the distance between them is specified by the GridSizeX and GridSizeY properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowGrid Property
AlignToGrid Property


MindFusion.Diagramming.Wpf.Diagram.Groups Property

Diagram.Groups Property
[image]

Gets a collection of all groups in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupCollection Groups { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

Groups provides access to all groups defined in the current diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Items Property
Factory.CreateGroup Method


MindFusion.Diagramming.Wpf.Diagram.HitTestPriority Property

Diagram.HitTestPriority Property
[image]

Gets or sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HitTestPriority HitTestPriority { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestPriority As HitTestPriority

Property Value

A member of the HitTestPriority enumeration. The default value is NodesBeforeLinks.

Remarks

For easier selection, links have a hit-detection area several pixels wider than their visible segment lines. However, if several links with higher z-index cross a node, it would be difficult to select it. The HitTestPriority property allows altering hit-test results in such situations. If set to NodesBeforeLinks, nodes are hit-tested before all links. ZOrder makes all items tested in decreasing z-order, independently of their type.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.HorizontalResizeCursor Property

Diagram.HorizontalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor HorizontalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeWE.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item horizontally.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
VerticalResizeCursor Property
DiagonalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.Wpf.Diagram.InplaceEditAcceptOnEnter Property

Diagram.InplaceEditAcceptOnEnter Property
[image]

Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool InplaceEditAcceptOnEnter { get; set; }

Visual Basic [image] Copy Code

Public Property InplaceEditAcceptOnEnter As Boolean

Property Value

true to accept changes and exit in-place editing mode when ENTER is pressed; otherwise, false. The default is false.

Remarks

If the value of this property is false, pressing the ENTER key inserts a new line in the text while in-place editing mode is active.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowInplaceEdit Property
InplaceEditCancelOnEsc Property


MindFusion.Diagramming.Wpf.Diagram.InplaceEditCancelOnEsc Property

Diagram.InplaceEditCancelOnEsc Property
[image]

Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool InplaceEditCancelOnEsc { get; set; }

Visual Basic [image] Copy Code

Public Property InplaceEditCancelOnEsc As Boolean

Property Value

true to reject changes and exit in-place editing mode when ESC is pressed; otherwise, false. The default is true.

Remarks

If the value of this property is false, pressing the ESC key has no effect while in-place editing mode is active.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowInplaceEdit Property
InplaceEditAcceptOnEnter Property


MindFusion.Diagramming.Wpf.Diagram.InplaceEditFont Property

Diagram.InplaceEditFont Property
[image]

Gets or sets the font of the inplace-editing text box.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font InplaceEditFont { get; set; }

Visual Basic [image] Copy Code

Public Property InplaceEditFont As Font

Property Value

An instance of the .NET Font class.

Remarks

When inplace-editing is started, a new TextBox control is created over the edited node. InplaceEditFont is assigned to the Font property of that text box.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AllowInplaceEdit Property


MindFusion.Diagramming.Wpf.Diagram.Interaction Property

Diagram.Interaction Property
[image]

Gets an InteractionState instance representing the current action being carried out by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InteractionState Interaction { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Interaction As InteractionState

Property Value

An instance of the InteractionState class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsProEdition Property

Diagram.IsProEdition Property
[image]

Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsProEdition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsProEdition As Boolean

Property Value

true if the currently loaded MindFusion.Diagramming for WPF instance is a professional version; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.IsTrialVersion Property

Diagram.IsTrialVersion Property
[image]

Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsTrialVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrialVersion As Boolean

Property Value

true if the currently loaded MindFusion.Diagramming for WPF instance is a trial version; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Items Property

Diagram.Items Property
[image]

Gets a collection of all items in this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This collection gives you access to all items contained in this document. You can also use it to add new items to the diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Wpf.Diagram.LaneGrid Property

Diagram.LaneGrid Property
[image]

Gets the Grid instance that represents the lane grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Grid LaneGrid { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LaneGrid As Grid

Property Value

Remarks

The Grid object gives you full control over the lane grid.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Layers Property

Diagram.Layers Property
[image]

Gets a list of the layers in the current diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<Layer> Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As IList(Of Layer)

Property Value

A list of Layer objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkBaseShape Property

Diagram.LinkBaseShape Property
[image]

Gets or sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape LinkBaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.BaseShape Property
LinkBaseShapeSize Property
LinkHeadShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkBaseShapeSize Property

Diagram.LinkBaseShapeSize Property
[image]

Gets or sets the default size of the base of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkBaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShapeSize As Double

Property Value

A double value that specifies the size. The default size is 5 millimeters.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new diagram links, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.BaseShapeSize Property
LinkBaseShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkBrush Property

Diagram.LinkBrush Property
[image]

Gets or sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush LinkBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBrush As Brush

Property Value

An instance of a .NET System.Windows.Media.Brush-derived class.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled. The Brush property of new links is initialized with a clone of LinkBrush, but after link creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LinkPen Property


MindFusion.Diagramming.Wpf.Diagram.LinkCascadeOrientation Property

Diagram.LinkCascadeOrientation Property
[image]

Gets or sets the initial orientation of the first segment of new cascading links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation LinkCascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

Use this property to specify the default orientation of the first segment of DiagramLink objects whose Shape is set to LinkShape.Cascading. The default value, Auto, lets the component decide whether to draw the first segment horizontally or vertically. See Orientation for more details.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.CascadeOrientation Property


MindFusion.Diagramming.Wpf.Diagram.LinkCrossings Property

Diagram.LinkCrossings Property
[image]

Gets or sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkCrossings LinkCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCrossings As LinkCrossings

Property Value

A member of the LinkCrossings enumeration. The default is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or breaks, depending on the value of this property. The z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and breaks can be set by the CrossingRadius property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.DrawCrossings Property
RouteLinks Property
RoundedLinks Property


MindFusion.Diagramming.Wpf.Diagram.LinkCustomDraw Property

Diagram.LinkCustomDraw Property
[image]

Gets or sets the default type of custom painting done on links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw LinkCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of links is performed. Its value is assigned to the CustomDraw property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DrawLink Event


MindFusion.Diagramming.Wpf.Diagram.LinkEndsMovable Property

Diagram.LinkEndsMovable Property
[image]

Gets or sets a value indicating whether arrow ends can be moved by users after the link is created.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool LinkEndsMovable { get; set; }

Visual Basic [image] Copy Code

Public Property LinkEndsMovable As Boolean

Property Value

true if moving link ends is allowed; false, if not.

Remarks

When the property is set to true, users cannot move the ends of a link after the link is created. This prevents them from connecting the links to other origin and destination nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LinkModifying Event


MindFusion.Diagramming.Wpf.Diagram.LinkHandlesStyle Property

Diagram.LinkHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle LinkHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default is SquareHandles.

Remarks

Default value for the HandlesStyle property of new links, created either programmatically or by a user. That property specifies how links' selection status is indicated visually.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.LinkHeadShape Property

Diagram.LinkHeadShape Property
[image]

Gets or sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape LinkHeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is Arrow.

Remarks

This property specifies the default shape displayed as arrowhead at the links' end points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.HeadShape Property
LinkHeadShapeSize Property
LinkBaseShape Property
LinkIntermediateShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkHeadShapeSize Property

Diagram.LinkHeadShapeSize Property
[image]

Gets or sets the default size of arrowheads.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkHeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShapeSize As Double

Property Value

A double value that measures the size. The default size is 5 millimeters.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.HeadShapeSize Property
LinkHeadShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkHitDistance Property

Diagram.LinkHitDistance Property
[image]

Gets or sets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkHitDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHitDistance As Double

Property Value

A double value specifying the distance in MeasureUnit units. The default value is 0.

Remarks

If this property is set to 0, the control considers it a hit when a link is no further than five millimeters from the mouse position. This LinkHitDistance value is also used when hit-testing programmatically, e.g. by calling the GetItemAt method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
HitTestPriority Property


MindFusion.Diagramming.Wpf.Diagram.LinkIntermediateShape Property

Diagram.LinkIntermediateShape Property
[image]

Gets or sets default shape to be displayed at the middle of each segment of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape LinkIntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

The property specifies default shape to be displayed at the middle of each segment of new links. It facilitates users by following the path of a link across the diagram, especially for longer links in large documents. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.IntermediateShape Property
LinkIntermediateShapeSize Property
LinkHeadShape Property
LinkBaseShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkIntermediateShapeSize Property

Diagram.LinkIntermediateShapeSize Property
[image]

Gets or sets the default size of the shapes at middles of link segments.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkIntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShapeSize As Double

Property Value

A double value that measures the size. The default size is 5 millimeters.

Remarks

Specifies default value for the IntermediateShapeSize property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.IntermediateShapeSize Property
LinkIntermediateShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkPen Property

Diagram.LinkPen Property
[image]

Gets or sets the default value for the Pen and HeadPen properties of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen LinkPen { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

The property provides a default value for the pens, with which link's segments and arrowhead lines are painted. The Pen and HeadPen properties of new links are initialized with clones of LinkPen, but after link creation the properties are independent - changing one of them does not change the others.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
LinkBrush Property


MindFusion.Diagramming.Wpf.Diagram.LinkRouter Property

Diagram.LinkRouter Property
[image]

Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ILinkRouter LinkRouter { get; set; }

Visual Basic [image] Copy Code

Public Property LinkRouter As ILinkRouter

Property Value

An instance of a class implementing the ILinkRouter interface. The currently available implementations incude GridRouter and QuickRouter.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Links Property

Diagram.Links Property
[image]

Gets a collection of all DiagramLink objects in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Links provides type-safe access to all links in the current diagram. Any diagram element can be accessed also by the Items collection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Items Property
Nodes Property
Groups Property
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Wpf.Diagram.LinkSegments Property

Diagram.LinkSegments Property
[image]

Gets or sets the default number of link segments.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int LinkSegments { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegments As Integer

Property Value

An integer value specifying how many segments links consists of. The default is 1.

Remarks

Use the property to create more indented links, when necessary.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.SegmentCount Property
LinkShape Property


MindFusion.Diagramming.Wpf.Diagram.LinkShape Property

Diagram.LinkShape Property
[image]

Gets or sets the default shape of diagram links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkShape LinkShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkShape As LinkShape

Property Value

A member of the LinkShape enumeration. The default value is Polyline.

Remarks

Use this property to specify what kind of segments new links are composed of. Curved links can be created using Bezier or Spline styles. Straight-segment links can be created using Polyline and Cascading styles, the latter one restricting segments to horizontal and vertical direction, orienting each segment orthogonally to its neighbor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.Shape Property
RoundedLinks Property


MindFusion.Diagramming.Wpf.Diagram.LinksRetainForm Property

Diagram.LinksRetainForm Property
[image]

Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool LinksRetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property LinksRetainForm As Boolean

Property Value

true to retain links' forms; otherwise, false. The default is false.

Remarks

LinksRetainForm value is used to initialize the RetainForm property of new links. It has effect on links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RouteLinks Property
DynamicLinks Property


MindFusion.Diagramming.Wpf.Diagram.LinkText Property

Diagram.LinkText Property
[image]

Gets or sets the default text of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string LinkText { get; set; }

Visual Basic [image] Copy Code

Public Property LinkText As String

Property Value

A string specifying the initial text of links. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.TextBrush Property
TextFormat Property


MindFusion.Diagramming.Wpf.Diagram.LinkTextStyle Property

Diagram.LinkTextStyle Property
[image]

Gets or sets default placement and orientation for links' text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkTextStyle LinkTextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. The default value is Center.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierEnabled Property

Diagram.MagnifierEnabled Property
[image]

Gets or sets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MagnifierEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierEnabled As Boolean

Property Value

true to enable the magnifier tool; otherwise, false.

Remarks

The magnifier tool can be alternatively enabled on-demand through a modifier key or a mouse button.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierFactor Property

Diagram.MagnifierFactor Property
[image]

Gets or sets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MagnifierFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierFactor As Double

Property Value

A double value.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierHeight Property

Diagram.MagnifierHeight Property
[image]

Gets or sets the height of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MagnifierHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierHeight As Double

Property Value

A double value.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierStyle Property

Diagram.MagnifierStyle Property
[image]

Gets or sets the style of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style MagnifierStyle { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MagnifierWidth Property

Diagram.MagnifierWidth Property
[image]

Gets or sets the width of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MagnifierWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MagnifierWidth As Double

Property Value

A double value.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MeasureUnit Property

Diagram.MeasureUnit Property
[image]

Gets or sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As GraphicsUnit

Property Value

An instance of the GraphicsUnit class. The default is WpfPoint.

Remarks

Many properties in the MindFusion.Diagramming for WPF API are used to specify the dimensions of diagram items or the size of various visual elements, for example, selection handles, arrowhead shapes, frame widths, and so on. MeasureUnit specifies the measure of length in which these size values are defined.

Changing the measure unit does not automatically rescale the size-related property values. Your application must set appropriate values to: Bounds, GridSizeX, GridSizeY, GridOffsetX, GridOffsetY, AdjustmentHandlesSize, LinkBaseShapeSize, LinkHeadShapeSize, LinkIntermediateShapeSize, TableCaptionHeight, TableColumnWidth, TableRowHeight, CrossingRadius and to the size-related members of RoutingOptions.

Changing the measure unit resets RoutingOptions to default values for the new unit, because performance might suffer greatly if the routing algorithm uses too big or too small GridSize.

The arguments passed to some methods depend on the measure unit too, for example, CreateShapeNode, CreateTableNode, ClientToDoc and DocToClient, GetNodeAt, GetLinkAt, ZoomToRect.

The following GraphicsUnit members can be used as MindFusion.Diagramming for WPF measure units:

Member name | Description
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure. Note that print and on-screen output will differ greatly in size when using pixels because printer pixels are much smaller than screen ones.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MergeThreshold Property

Diagram.MergeThreshold Property
[image]

Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MergeThreshold { get; set; }

Visual Basic [image] Copy Code

Public Property MergeThreshold As Double

Property Value

A double value specifying the maximum distance in the current MeasureUnit. The default is 0.

Remarks

An user may add or remove links' segments interactively when the AllowSplitLinks property is enabled. They can drag a link's control point over the next one in order to merge two adjacent segments. Usually the two points must be placed exactly at the same coordinates in order to merge the respective segments of the link. Assign a larger value to this property if you wish to make it easier for users to merge segments by just moving link's control point close one to another.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MiddleButtonActions Property

Diagram.MiddleButtonActions Property
[image]

Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButtonActions MiddleButtonActions { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleButtonActions As MouseButtonActions

Property Value

A combination of the MouseButtonActions enumeration members. The default is None.

Remarks

This property allows the following actions to be assigned to the middle mouse button: panning the diagram view, canceling the current drawing operation, or starting a multiple selection operation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RightButtonActions Property


MindFusion.Diagramming.Wpf.Diagram.MinimumNodeSize Property

Diagram.MinimumNodeSize Property
[image]

Gets or sets the minimum node size that the user is allowed to set.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size MinimumNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumNodeSize As Size

Property Value

A Size instance specifying the minimum size allowed for nodes.

Remarks

If the user releases the mouse button while creating or modifying a node and the node size is smaller than this value, the operation is cancelled.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ModificationEffect Property

Diagram.ModificationEffect Property
[image]

Gets or sets the visual effect to apply during interactive modification of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModificationEffect ModificationEffect { get; set; }

Visual Basic [image] Copy Code

Public Property ModificationEffect As ModificationEffect

Property Value

A member of the ModificationEffect enumeration. The default value is None.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ModificationStart Property

Diagram.ModificationStart Property
[image]

Gets or sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModificationStart ModificationStart { get; set; }

Visual Basic [image] Copy Code

Public Property ModificationStart As ModificationStart

Property Value

A member of the ModificationStart enumeration. The default is SelectedOnly.

Remarks

Use this property to specify what should users do in order to start item modification.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ModificationStart Enumeration
ModificationEffect Property
AutoSnapLinks Property
AutoAlignNodes Property


MindFusion.Diagramming.Wpf.Diagram.ModifierKeyActions Property

Diagram.ModifierKeyActions Property
[image]

Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModifierKeyActions ModifierKeyActions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ModifierKeyActions As ModifierKeyActions

Property Value

An instance of the ModifierKeyActions class.

Remarks

Use the Alt, Control and Shift properties of this ModifierKeyActions instance to specify the functions of the ALT, CTRL and SHIFT keys. These properties can be set to values of the ModifierKeyAction enumeration.

Example

This code enables drawing a selection rectangle using the SHIFT modifier key:

C# [image] Copy Code
diagram.ModifierKeyActions.Shift = ModifierKeyAction.Select;
Visual Basic [image] Copy Code
diagram.ModifierKeyActions.Shift = ModifierKeyAction.Select

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.MoveCursor Property

Diagram.MoveCursor Property
[image]

Gets or sets the mouse cursor shown to the user if the pointed object can be modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor MoveCursor { get; set; }

Visual Basic [image] Copy Code

Public Property MoveCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeAll.

Remarks

Use the property to indicate visually to the user that they are pointing to an item, which can be modified at the current moment.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DrawLinkCursor Property
AllowLinkCursor Property
PointerCursor Property
DisallowCursor Property
PanCursor Property


MindFusion.Diagramming.Wpf.Diagram.NodeEffects Property

Diagram.NodeEffects Property
[image]

Gets a collection with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.Nodes Property

Diagram.Nodes Property
[image]

Gets a collection of all DiagramNode objects in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Nodes provides type-safe access to all nodes in the current diagram. Any diagram element can be accessed also by using the Items collection.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Items Property
Links Property
Groups Property
Factory.CreateShapeNode Method


MindFusion.Diagramming.Wpf.Diagram.NodesExpandable Property

Diagram.NodesExpandable Property
[image]

Gets or sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NodesExpandable { get; set; }

Visual Basic [image] Copy Code

Public Property NodesExpandable As Boolean

Property Value

true if new nodes can be expanded; otherwise, false. The default is false.

Remarks

If using MindFusion.Diagramming for WPF to present tree/hierarchical diagrams, you might set NodesExpandable to true. If enabled, the property makes each newly created node appear with a [±] sign next to it, which expands or collapses the node's descendants.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ExpandButtonPosition Property
RecursiveExpand Property
ExpandOnIncoming Property
TreeCollapsed Event
TreeExpanded Event
DiagramNode.Expandable Property


MindFusion.Diagramming.Wpf.Diagram.NodeTemplate Property

Diagram.NodeTemplate Property
[image]

Gets or sets the default DataTemplate used to display TemplatedNodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DataTemplate NodeTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property NodeTemplate As DataTemplate

Property Value

A DataTemplate instance. The default template displays a TextBlock inside a Border.

Remarks

This template is used if the Template property of a TemplatedNode is not set.

Example

The following code reproduces the default Xaml template of nodes:

Xaml [image] Copy Code

<diag:Diagram>
<diag:Diagram.NodeTemplate>
<DataTemplate DataType="diag:TemplatedNode">
<Border
BorderBrush="{Binding Stroke}"
BorderThickness="{Binding StrokeThickness}"
Background="{Binding Brush}">

<TextBlock
Text="{Binding Text}"
TextWrapping="{Binding TextWrapping}"
TextTrimming="{Binding TextTrimming}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="Center"
HorizontalAlignment="Stretch"/>

</Border>
</DataTemplate>
</diag:Diagram.NodeTemplate>
</diag:Diagram>

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.NowLoading Property

Diagram.NowLoading Property
[image]

Gets a value indicating whether the diagram data is now being loaded from a file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NowLoading { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NowLoading As Boolean

Property Value

true if the diagram is currently in a loading state; otherwise, false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.OverrideCursor Property

Diagram.OverrideCursor Property
[image]

Sets the cursor and stops changing it depending on the context.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor OverrideCursor { get; set; }

Visual Basic [image] Copy Code

Public Property OverrideCursor As Cursor

Property Value

An instance of the System.Windows.Input.Cursor class.

Remarks

By default, the mouse cursor is changed automatically depending on what elements are located at the current mouse position and what action is being carried out by the user. This property lets you override that behavior and display a custom cursor that does not depend on the context. To revert back to the default behavior, set this property to null.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PanCursor Property

Diagram.PanCursor Property
[image]

Gets or sets the mouse cursor displayed while panning the diagram view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor PanCursor { get; set; }

Visual Basic [image] Copy Code

Public Property PanCursor As Cursor

Property Value

An instance of the .NET Cursor class representing the mouse cursor that is displayed while panning.

Remarks

The diagram view can be panned by holding down the ALT key and dragging with the mouse. This can be changed by the ModifierKeyActions and MiddleButtonActions properties.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
MoveCursor Property
PointerCursor Property


MindFusion.Diagramming.Wpf.Diagram.PanInertia Property

Diagram.PanInertia Property
[image]

Gets or sets a value indicating whether panning the view will have inertia.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PanInertia { get; set; }

Visual Basic [image] Copy Code

Public Property PanInertia As Boolean

Property Value

true to pan with inertia, or false otherwise.

Remarks

To pan the diagram, hold down the key associated with ModifierKeyAction.Pan (by default Alt) and drag with the mouse. Set Behavior to Pan to let users pan without a modifier key.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.PointerCursor Property

Diagram.PointerCursor Property
[image]

Gets or sets the mouse cursor shown to the user when no modification is performed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor PointerCursor { get; set; }

Visual Basic [image] Copy Code

Public Property PointerCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.Arrow.

Remarks

This cursor is shown when clicking and dragging the mouse would start creation of a node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DrawLinkCursor Property
MoveCursor Property
AllowLinkCursor Property
PanCursor Property


MindFusion.Diagramming.Wpf.Diagram.PolygonalTextLayout Property

Diagram.PolygonalTextLayout Property
[image]

Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PolygonalTextLayout { get; set; }

Visual Basic [image] Copy Code

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

Specifies a default value for the PolygonalTextLayout property of shape nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DefaultShape Property


MindFusion.Diagramming.Wpf.Diagram.PrintOptions Property

Diagram.PrintOptions Property
[image]

Gets an object which provides customization properties for printing and print-preview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PrintOptions PrintOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

Remarks

Allows customization of various print and print-preview aspects. The settings exposed as properties include document title, page header format and several bool flags that control if images, shadows, headers, and so on are printed or rendered in preview mode.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Print Method


MindFusion.Diagramming.Wpf.Diagram.RecursiveExpand Property

Diagram.RecursiveExpand Property
[image]

Gets or sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RecursiveExpand { get; set; }

Visual Basic [image] Copy Code

Public Property RecursiveExpand As Boolean

Property Value

true if a tree is recursively expanded; otherwise, false. The default is false.

Remarks

Use the property when representing tree structures, which hide some of their elements. When the property is set to true, clicking on a certain node in the tree, expands not only its descendants, but all descendants of the descendants, and so on, till the whole tree is expanded.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ExpandOnIncoming Property
NodesExpandable Property


MindFusion.Diagramming.Wpf.Diagram.RemoveHiddenItemsFromVisualTree Property

Diagram.RemoveHiddenItemsFromVisualTree Property
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RemoveHiddenItemsFromVisualTree { get; set; }

Visual Basic [image] Copy Code

Public Property RemoveHiddenItemsFromVisualTree As Boolean

Property Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RestrictItemsToBounds Property

Diagram.RestrictItemsToBounds Property
[image]

Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RestrictToBounds RestrictItemsToBounds { get; set; }

Visual Basic [image] Copy Code

Public Property RestrictItemsToBounds As RestrictToBounds

Property Value

A member of the RestrictToBounds enumeration. The default is Intersection.

Remarks

Use this property to specify whether diagram elements can be drawn or moved outside the document area. It is possible to specify that items have to be entirely inside, partly outside or there is no restriction.

If there is no restriction and AutoResize is disabled, users could place an item to a position where they cannot reach it by scrolling. That might be interpreted as an item deletion operation by handling the NodeModified event and deleting the item if it is outside the document boundaries.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Bounds Property
AutoResize Property


MindFusion.Diagramming.Wpf.Diagram.RightButtonActions Property

Diagram.RightButtonActions Property
[image]

Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButtonActions RightButtonActions { get; set; }

Visual Basic [image] Copy Code

Public Property RightButtonActions As MouseButtonActions

Property Value

A combination of the MouseButtonActions enumeration members. The default is Cancel.

Remarks

This property allows the following actions to be assigned to the right mouse button: panning the diagram view, canceling the current drawing operation, or starting a multiple selection operation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
MiddleButtonActions Property


MindFusion.Diagramming.Wpf.Diagram.RotateCursor Property

Diagram.RotateCursor Property
[image]

Gets or sets the cursor shown when the mouse is over a node rotation handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor RotateCursor { get; set; }

Visual Basic [image] Copy Code

Public Property RotateCursor As Cursor

Property Value

An instance of the .NET Cursor class.

Remarks

This cursor is shown when clicking and dragging the mouse will start rotating a shape node.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
MoveCursor Property


MindFusion.Diagramming.Wpf.Diagram.RotationStep Property

Diagram.RotationStep Property
[image]

Gets or sets the RotationAngle increment when users rotate a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RotationStep { get; set; }

Visual Basic [image] Copy Code

Public Property RotationStep As Integer

Property Value

An integer value specifying rotation increments applied during interactive rotation. The default value 0 allows unconstrained rotation.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.RoundedLinks Property

Diagram.RoundedLinks Property
[image]

Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to use rounded segment joins; otherwise, false. The default is false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.Shape Property
LinkCrossings Property


MindFusion.Diagramming.Wpf.Diagram.RoundedLinksRadius Property

Diagram.RoundedLinksRadius Property
[image]

Gets or sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RoundedLinksRadius { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinksRadius As Double

Property Value

A double value specifying the radius length. The default is 2.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CrossingRadius Property


MindFusion.Diagramming.Wpf.Diagram.RoundRectFactor Property

Diagram.RoundRectFactor Property
[image]

Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RoundRectFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RoundRectFactor As Double

Property Value

A double multiplier applied to the radius of the arcs used as corners of rounded rectangles. The default is 1.

Remarks

The default length of the radius of rounded-corner arcs is 7. This property lets you increase or decrease that value by multiplying it by the specified factor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableShape Property


MindFusion.Diagramming.Wpf.Diagram.RouteLinks Property

Diagram.RouteLinks Property
[image]

Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RouteLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RouteLinks As Boolean

Property Value

true to route links; otherwise, false. The default is false.

Remarks

The value of RouteLinks is used to initialize the AutoRoute property of new links. If a node is moved or resized, all links that intersect with its new position and have AutoRoute enabled are rerouted. Keep in mind that number of link segments will probably change when routing is enabled.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RouteAllLinks Method
DynamicLinks Property
LinkCrossings Property
AutoSnapLinks Property


MindFusion.Diagramming.Wpf.Diagram.RoutingOptions Property

Diagram.RoutingOptions Property
[image]

Gets an object, which allows customizing various parameters of the link routing algorithm.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RoutingOptions RoutingOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RoutingOptions As RoutingOptions

Property Value

An instance of the RoutingOptions class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
RouteLinks Property
RouteAllLinks Method


MindFusion.Diagramming.Wpf.Diagram.RowHighlightBrush Property

Diagram.RowHighlightBrush Property
[image]

Gets or sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush RowHighlightBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RowHighlightBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is a solid-color brush with RGB = 185,209,234.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoHighlightRows Property
HighlightedRow Property


MindFusion.Diagramming.Wpf.Diagram.ScriptHelper Property

Diagram.ScriptHelper Property
[image]

Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScriptHelper ScriptHelper { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScriptHelper As ScriptHelper

Property Value

An instance of the ScriptHelper class.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ScrollX Property

Diagram.ScrollX Property
[image]

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Double

Property Value

A double value specifying the new horizontal scroll position in the current units of measure. The default is 0, indicating the left corner.

Remarks

Use the property to set where the horizontal scroll bar should be positioned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowScrollbars Property
ScrollY Property


MindFusion.Diagramming.Wpf.Diagram.ScrollY Property

Diagram.ScrollY Property
[image]

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Double

Property Value

A double value specifying the new vertical scroll position in the current units of measure. The default is 0, indicating the top corner.

Remarks

Use the property to set where the vertical scroll bar should be positioned.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowScrollbars Property
ScrollX Property


MindFusion.Diagramming.Wpf.Diagram.ScrollZoneSize Property

Diagram.ScrollZoneSize Property
[image]

Gets or sets the size of the auto scroll zone near the edges of the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ScrollZoneSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollZoneSize As Integer

Property Value

An integer specifying the size in pixels of the area near the view edges where auto-scrolling is triggered. The default value is 8.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AutoScroll Property


MindFusion.Diagramming.Wpf.Diagram.SelectAfterCreate Property

Diagram.SelectAfterCreate Property
[image]

Gets or sets a value indicating whether newly created objects are automatically selected.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SelectAfterCreate { get; set; }

Visual Basic [image] Copy Code

Public Property SelectAfterCreate As Boolean

Property Value

true if items are selected after being created; otherwise, false. The default is true.

Remarks

Use the property to specify if the items that are drawn are selecting, which allows immediate modification actions to be performed over them.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Selection Property


MindFusion.Diagramming.Wpf.Diagram.SelectedItemHandlesStyle Property

Diagram.SelectedItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesVisualStyle SelectedItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectedItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of adjustment handles drawn around selected items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Selection Property
ActiveItemHandlesStyle Property


MindFusion.Diagramming.Wpf.Diagram.Selection Property

Diagram.Selection Property
[image]

Gets a Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the current selection.

Remarks

Use this property to get the items currently selected by a user. Items can be enumerated by the Items member of the Selection class. An item from the selection is considered the active one and can be accessed by using ActiveItem. To prevent users from selecting multiple items, set AllowMultipleSelection to false.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ModificationStart Property
AdjustmentHandlesSize Property
HitTestPriority Property


MindFusion.Diagramming.Wpf.Diagram.SelectionOnTop Property

Diagram.SelectionOnTop Property
[image]

Gets or sets a value indicating whether selected items should be painted on top of other items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SelectionOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionOnTop As Boolean

Property Value

true if selected items must be painted on top; otherwise, false. The default is true.

Remarks

If SelectionOnTop is enabled, selected items are painted over non-selected ones, ignoring the z-order position specified in ZIndex.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Selection Class
ActiveItem Property
SortGroupsByZ Property


MindFusion.Diagramming.Wpf.Diagram.ShapeBrush Property

Diagram.ShapeBrush Property
[image]

Gets or sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBrush As Brush

Property Value

An instance of a .NET System.Windows.Media.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a node's interior is filled. The Brush property of new shape nodes is initialized with a clone of ShapeBrush, but after the node creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShapePen Property


MindFusion.Diagramming.Wpf.Diagram.ShapeCustomDraw Property

Diagram.ShapeCustomDraw Property
[image]

Gets or sets the default type of custom painting done for shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw ShapeCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of shape nodes is performed. Its value is assigned to the CustomDraw property of new shape nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
DrawNode Event


MindFusion.Diagramming.Wpf.Diagram.ShapeHandlesStyle Property

Diagram.ShapeHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle ShapeHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

This property provides default value for the HandlesStyle property of new shape nodes, created either programmatically or by the user. That property specifies how selected nodes are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ShapeNodeStyle Property

Diagram.ShapeNodeStyle Property
[image]

Gets or sets the theme-level style for shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style ShapeNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeNodeStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ShapeOrientation Property

Diagram.ShapeOrientation Property
[image]

Gets or sets the default value for the ShapeOrientation property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Double

Property Value

A double value specifying an angle in degrees. Allowed values are 0, 90, 180 and 270.

Remarks

Use this property in conjunction with DefaultShape to define what shape will be assigned to new nodes that end-users draw.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShapeNode.ShapeOrientation Property
DefaultShape Property


MindFusion.Diagramming.Wpf.Diagram.ShapePen Property

Diagram.ShapePen Property
[image]

Gets or sets the default value for the Pen property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen ShapePen { get; set; }

Visual Basic [image] Copy Code

Public Property ShapePen As Pen

Property Value

An instance of the .NET System.Windows.Media.Pen class.

Remarks

The property provides a default value for the pen, with which a shape node's frame is painted. The Pen property of new shape nodes is initialized with a clone of ShapePen, but after the node creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShapeBrush Property


MindFusion.Diagramming.Wpf.Diagram.ShapeText Property

Diagram.ShapeText Property
[image]

Gets or sets the default text of shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ShapeText { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeText As String

Property Value

A string specifying the initial text of shape nodes. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new nodes.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TextBrush Property
TextFormat Property


MindFusion.Diagramming.Wpf.Diagram.ShowAnchors Property

Diagram.ShowAnchors Property
[image]

Gets or sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShowAnchors ShowAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAnchors As ShowAnchors

Property Value

A member of the ShowAnchors enumeration. The default value is Auto.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
SnapToAnchor Property


MindFusion.Diagramming.Wpf.Diagram.ShowDisabledHandles Property

Diagram.ShowDisabledHandles Property
[image]

Gets or sets a value indicating whether manipulation handles are painted when they are disabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowDisabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDisabledHandles As Boolean

Property Value

true to display disabled manipulation handles; otherwise, false. The default is true.

Remarks

Individual handles can be disabled or enabled by clearing or setting their correspondent bits in node's EnabledHandles. If disabled handles are displayed, they are painted using the style set through DisabledHandlesStyle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ShowGrid Property

Diagram.ShowGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowGrid { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGrid As Boolean

Property Value

true if the grid is visible; otherwise, false. The default is false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
AlignToGrid Property
GridColor Property
GridSizeX Property
GridSizeY Property


MindFusion.Diagramming.Wpf.Diagram.ShowHandlesOnDrag Property

Diagram.ShowHandlesOnDrag Property
[image]

Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowHandlesOnDrag { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHandlesOnDrag As Boolean

Property Value

true to display the selection handles of an item while it is being modified; false to hide them.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ModificationEffect Property


MindFusion.Diagramming.Wpf.Diagram.SnapToAnchor Property

Diagram.SnapToAnchor Property
[image]

Gets or sets when link end points should be aligned to the nearest anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SnapToAnchor SnapToAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToAnchor As SnapToAnchor

Property Value

A member of the SnapToAnchor enumeration. The default is OnCreate.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ShowAnchors Property


MindFusion.Diagramming.Wpf.Diagram.SortGroupsByZ Property

Diagram.SortGroupsByZ Property
[image]

Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SortGroupsByZ { get; set; }

Visual Basic [image] Copy Code

Public Property SortGroupsByZ As Boolean

Property Value

true if grouped items should be painted according to their z-order; otherwise, false. The default is false.

Remarks

By default, while a group of nodes is being modified with the mouse, the grouped items are drawn in the order defined by the group hierarchy. For example, the group MainItem is drawn bellow all attached items, and if an attached item is the main item in another group, it is drawn below the next groups in the hierarchy. During this process, the ZIndex of items is ignored and the group appearance while it is being modified might differ from how it looks usually. The SortGroupsByZ property lets you override the default behavior and display items sorted by their z-order. Take heed if your application creates large hierarchies of groups - enabling that property might slow down the modification process.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
SelectionOnTop Property


MindFusion.Diagramming.Wpf.Diagram.TableBrush Property

Diagram.TableBrush Property
[image]

Gets or sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TableBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TableBrush As Brush

Property Value

An instance of a .NET System.Windows.Media.Brush-derived class.

Remarks

The property provides a default value for the brush, with which a table' interior is filled. The Brush property of new tables is initialized with a clone of TableBrush, but after table creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TablePen Property


MindFusion.Diagramming.Wpf.Diagram.TableCaption Property

Diagram.TableCaption Property
[image]

Gets or sets the default text for tables' captions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string TableCaption { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaption As String

Property Value

A string specifying the initial text of table captions. The default is "Table".

Remarks

The Caption property of new tables is initialized with the value of TableCaption.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableCaptionHeight Property


MindFusion.Diagramming.Wpf.Diagram.TableCaptionHeight Property

Diagram.TableCaptionHeight Property
[image]

Gets or sets the default height of table captions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TableCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaptionHeight As Double

Property Value

A double value, which indicates the height of table caption. Default value is 5.

Remarks

The value of this property is used to initialize the CaptionHeight property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableCaption Property


MindFusion.Diagramming.Wpf.Diagram.TableColumnCount Property

Diagram.TableColumnCount Property
[image]

Gets or sets the default number of table columns.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int TableColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnCount As Integer

Property Value

An integer value, which specifies the number of columns in new tables. The default is 2.

Remarks

This value is used to initialize the ColumnCount property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableRowCount Property


MindFusion.Diagramming.Wpf.Diagram.TableColumnWidth Property

Diagram.TableColumnWidth Property
[image]

Gets or sets the default width of tables' columns.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TableColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnWidth As Double

Property Value

A double value, which specifies the width of table columns measured. The default is 18.

Remarks

This property is used to initialize the ColumnWidth property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableRowHeight Property


MindFusion.Diagramming.Wpf.Diagram.TableConnectionStyle Property

Diagram.TableConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableConnectionStyle TableConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. The default is Rows.

Remarks

The value of TableConnectionStyle is used to initialize the ConnectionStyle property of new tables. There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target tables as whole entities, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of a table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the table's ConnectionStyle. The value of ConnectionStyle is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableCustomDraw Property

Diagram.TableCustomDraw Property
[image]

Gets or sets the default type of custom painting done on tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw TableCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property TableCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

The CustomDraw member of tables is initialized from this property.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
CellCustomDraw Property


MindFusion.Diagramming.Wpf.Diagram.TableHandlesStyle Property

Diagram.TableHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle TableHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableHandlesStyle As HandlesStyle

Property Value

One of the HandlesStyle enumeration values.

Remarks

Default value for the HandlesStyle property of new tables, created either programmatically or by the user. That property specifies how selected tables are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TableNodeStyle Property

Diagram.TableNodeStyle Property
[image]

Gets or sets the theme-level style for table nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style TableNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableNodeStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TablePen Property

Diagram.TablePen Property
[image]

Gets or sets the default value for the Pen property of tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen TablePen { get; set; }

Visual Basic [image] Copy Code

Public Property TablePen As Pen

Property Value

An instance of the .NET System.Windows.Media.Pen class.

Remarks

The property provides a default value for the pen, with which a table's frame is painted. The Pen property of new tables is initialized with a clone of TablePen, but after table creation the properties are independent - changing one of them does not change the other.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableBrush Property


MindFusion.Diagramming.Wpf.Diagram.TableRowCount Property

Diagram.TableRowCount Property
[image]

Gets or sets the default number of table rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int TableRowCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowCount As Integer

Property Value

An integer value specifying the number of rows.

Remarks

Use the property to set the initial number of rows for newly created tables. Further customization of table nodes can be done through TableNode class properties and methods.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableColumnCount Property


MindFusion.Diagramming.Wpf.Diagram.TableRowHeight Property

Diagram.TableRowHeight Property
[image]

Gets or sets the default height of tables' rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TableRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowHeight As Double

Property Value

A double value specifying the height of table rows. The default is 5.

Remarks

TableRowHeight is used to initialize the RowHeight property of new tables.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableColumnWidth Property


MindFusion.Diagramming.Wpf.Diagram.TableShape Property

Diagram.TableShape Property
[image]

Gets or sets the default shape of new tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleShape TableShape { get; set; }

Visual Basic [image] Copy Code

Public Property TableShape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default value is Rectangle.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TablesScrollable Property

Diagram.TablesScrollable Property
[image]

Gets or sets the default value for the Scrollable property of new tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool TablesScrollable { get; set; }

Visual Basic [image] Copy Code

Public Property TablesScrollable As Boolean

Property Value

true if the scrolling is possible; otherwise, false. The default is false.

Remarks

The Scrollable property of each new table is initialized with the value of TablesScrollable. Small up/down scroll buttons appear in the caption of scrollable tables. With the help of the buttons users can scroll table rows.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TableRowCount Property
TableNode.Scrollable Property


MindFusion.Diagramming.Wpf.Diagram.TextBrush Property

Diagram.TextBrush Property
[image]

Gets or sets the default brush of text displayed inside diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a .NET Brush-derived class. The default is a solid brush initialized with Colors.Black.

Remarks

Use the property to specify the default brush of the text of diagram items.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TextFormat Property


MindFusion.Diagramming.Wpf.Diagram.TextFormat Property

Diagram.TextFormat Property
[image]

Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the .NET StringFormat class. The default value for both Alignment and LineAlignment properties is StringAlignment.Center.

Remarks

When a new node is created, its TextFormat is initialized with the value of this property. The same applies for the TextFormat of the cells of a new table.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
TextBrush Property


MindFusion.Diagramming.Wpf.Diagram.Theme Property

Diagram.Theme Property
[image]

Gets or sets the theme associated with the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Theme Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As Theme

Property Value

A Theme object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.TreeViewNodeStyle Property

Diagram.TreeViewNodeStyle Property
[image]

Gets or sets the theme-level style for treeview nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style TreeViewNodeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TreeViewNodeStyle As Style

Property Value

A Style object.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.UndoManager Property

Diagram.UndoManager Property
[image]

Gets a reference to the diagram's UndoManager instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UndoManager UndoManager { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UndoManager As UndoManager

Property Value

A reference to UndoManager instance.

Remarks

Use this property to control the undo manager operations, Undo or Redo commands, and access the command History.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ValidityChecks Property

Diagram.ValidityChecks Property
[image]

Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ValidityChecks { get; set; }

Visual Basic [image] Copy Code

Public Property ValidityChecks As Boolean

Property Value

true to perform validity checks; otherwise, false. The default is true.

Remarks

If enabled, validity checks are performed each time an item is added to the diagram. That involves enumerating the Items collection and can slow up the process considerably for large diagrams. You can disable this property in order to skip the validity checks, however be sure that you don't add an item twice to the diagram and that links are created only between items in the same diagram.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
Factory.CreateShapeNode Method
Factory.CreateDiagramLink Method


MindFusion.Diagramming.Wpf.Diagram.VerticalResizeCursor Property

Diagram.VerticalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Cursor VerticalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalResizeCursor As Cursor

Property Value

An instance of the .NET Cursor class. The default is Cursors.SizeNS.

Remarks

This cursor indicates visually to the user that the mouse is over a place, where clicking+dragging would resize an item vertically.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
HorizontalResizeCursor Property
DiagonalResizeCursor Property
CounterDiagonalResizeCursor Property


MindFusion.Diagramming.Wpf.Diagram.Viewport Property

Diagram.Viewport Property
[image]

Returns the visible portion of the diagram area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Viewport { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Viewport As Rect

Property Value

A System.Windows.Rect structure specifying the visible diagram area in MeasureUnit units.

Remarks

This property returns the viewport of the diagram's parent ScrollViewer, converted to logical coordinates that reflect the current MeasureUnit and ZoomFactor.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.VisualChildrenCount Property

Diagram.VisualChildrenCount Property
[image]

Visual.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Diagram.ZoomFactor Property

Diagram.ZoomFactor Property
[image]

Gets or sets the zoom factor used to scale up or down the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying percent of the original diagram size. The default is 100.

Remarks

Use the property to set how far the diagram items should look. Values smaller than 100 make items appear further, bigger than 100 - nearer. The default value is 100, specifying that no scaling transformation is applied.

See Also

Diagram Members
Diagram Class
MindFusion.Diagramming.Wpf Namespace
ZoomIn Method
ZoomOut Method
SetZoomFactor Method


MindFusion.Diagramming.Wpf.Diagram Events

Diagram Events
[image]

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

Diagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ActionRecorded Event

DiagramBase.ActionRecorded Event
[image]

Occurs when an action is recorded in undo history.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRecorded

Visual Basic [image] Copy Code

Public Event ActionRecorded As EventHandler(Of UndoEventArgs)

Event Data

ActionRecorded event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the recorded action.

Remarks

This event is raised only for top-level commands. For example, it isn't raised for the constituent actions of a CompositeCmd.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRedone Event
ActionUndone Event


MindFusion.Diagramming.Wpf.DiagramBase.ActionRecording Event

DiagramBase.ActionRecording Event
[image]

A validation event raised before an action is recorded in the undo buffer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoValidationEventArgs> ActionRecording

Visual Basic [image] Copy Code

Public Event ActionRecording As EventHandler(Of UndoValidationEventArgs)

Event Data

ActionRecording event handlers receive an argument of type UndoValidationEventArgs. The following UndoValidationEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command instance that identifies the action being recorded.
Cancel | Set this property to true to prevent the action from being recorded in the undo buffer.

Remarks

Do not filter commands that create or delete items and groups. Otherwise, redoing or undoing recorded commands related to the items whose create/delete command is filtered will cause various exceptions. It should be safe to filter commands that modify an item, change its selection state, scroll a table, and so on.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.ActionRedone Event

DiagramBase.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been redone.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRecorded Event
ActionUndone Event


MindFusion.Diagramming.Wpf.DiagramBase.ActionUndone Event

DiagramBase.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs. The following UndoEventArgs members provide information relevant to the event:

Member name | Description
Command | Refers to the Command that has been undone.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRecorded Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.ActiveLayerChanged Event

DiagramBase.ActiveLayerChanged Event
[image]

Raised when the diagram's active layer has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ActiveLayerChanged

Visual Basic [image] Copy Code

Public Event ActiveLayerChanged As EventHandler

Event Data

ActiveLayerChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.Arranged Event

DiagramBase.Arranged Event
[image]

Raised when the diagram's visual tree has been arranged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Arranged

Visual Basic [image] Copy Code

Public Event Arranged As EventHandler

Event Data

Arranged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.BeginLoad Event

DiagramBase.BeginLoad Event
[image]

Raised when the component starts loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler BeginLoad

Visual Basic [image] Copy Code

Public Event BeginLoad As EventHandler

Event Data

BeginLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
EndLoad Event


MindFusion.Diagramming.Wpf.DiagramBase.BoundsChanged Event

DiagramBase.BoundsChanged Event
[image]

Raised when the Bounds property value has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler BoundsChanged

Visual Basic [image] Copy Code

Public Event BoundsChanged As EventHandler

Event Data

BoundsChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
MeasureUnitChanged Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.CellClicked Event

DiagramBase.CellClicked Event
[image]

Raised when the user clicks a table's cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellClicked

Visual Basic [image] Copy Code

Public Event CellClicked As EventHandler(Of CellEventArgs)

Event Data

CellClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeClicked won't be raised for the table that contains the clicked cell, but only CellClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
CellDoubleClicked Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.CellDoubleClicked Event

DiagramBase.CellDoubleClicked Event
[image]

Raised when the user double-clicks a table's cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellDoubleClicked

Visual Basic [image] Copy Code

Public Event CellDoubleClicked As EventHandler(Of CellEventArgs)

Event Data

CellDoubleClicked event handlers receive an argument of type CellEventArgs. The following CellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the clicked cell.
Cell | The Cell that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.
Column | Index of the column containing the clicked cell.
Row | Index of the row containing the clicked cell.

Remarks

If there is some handler attached to this event, NodeDoubleClicked won't be raised for the table that contains the clicked cell, but only CellDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
CellClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.CellTextEdited Event

DiagramBase.CellTextEdited Event
[image]

Raised when the user edits the text of a table's cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EditCellTextEventArgs> CellTextEdited

Visual Basic [image] Copy Code

Public Event CellTextEdited As EventHandler(Of EditCellTextEventArgs)

Event Data

CellTextEdited event handlers receive an argument of type EditCellTextEventArgs. The following EditCellTextEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the edited cell.
Cell | The Cell whose text has been edited.
NewText | The cell's new text.
OldText | The cell's old text.
Column | Index of the column containing the edited cell.
Row | Index of the row containing the edited cell.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
CellTextEditing Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.CellTextEditing Event

DiagramBase.CellTextEditing Event
[image]

A validation event that can prevent users from editing the text of a table's cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> CellTextEditing

Visual Basic [image] Copy Code

Public Event CellTextEditing As EventHandler(Of CellValidationEventArgs)

Event Data

CellTextEditing event handlers receive an argument of type CellValidationEventArgs. The following CellValidationEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that the user is trying to edit.
Cell | The Cell that the user is trying to edit.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Cancel | Set this property to true to prevent the user from editing the cell's text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
CellTextEdited Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.Clicked Event

DiagramBase.Clicked Event
[image]

Raised when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> Clicked

Visual Basic [image] Copy Code

Public Event Clicked As EventHandler(Of DiagramEventArgs)

Event Data

Clicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

Remarks

This event is raised only if the user clicks an unoccupied point of the diagram. If the user clicks a diagram item, one of the following events is raised: NodeClicked, CellClicked or LinkClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
CellDoubleClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.ContainerChildAdded Event

DiagramBase.ContainerChildAdded Event
[image]

Raised when a node is added to a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildAdded

Visual Basic [image] Copy Code

Public Event ContainerChildAdded As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildAdded event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ContainerChildRemoved Event

DiagramBase.ContainerChildRemoved Event
[image]

Raised when a node is removed from a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildRemoved

Visual Basic [image] Copy Code

Public Event ContainerChildRemoved As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildRemoved event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ContainerFolded Event

DiagramBase.ContainerFolded Event
[image]

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerFolded

Visual Basic [image] Copy Code

Public Event ContainerFolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerFolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ContainerUnfolded Event

DiagramBase.ContainerUnfolded Event
[image]

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerUnfolded

Visual Basic [image] Copy Code

Public Event ContainerUnfolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerUnfolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.CopyHostedControl Event

DiagramBase.CopyHostedControl Event
[image]

Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CopyHostedControlEventArgs> CopyHostedControl

Visual Basic [image] Copy Code

Public Event CopyHostedControl As EventHandler(Of CopyHostedControlEventArgs)

Event Data

CopyHostedControl event handlers receive an argument of type CopyHostedControlEventArgs.

Remarks

When copying a DiagramNodeAdapter to the clipboard, MindFusion.Diagramming for WPF copies automatically all properties that can be processed by the WPF XamlWriter and XamlReader classes. CopyHostedControl lets you copy attributes that do not fall into that category, such as event handlers and style assignments.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DefaultShapeChanged Event

DiagramBase.DefaultShapeChanged Event
[image]

Raised when the DefaultShape property value has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DefaultShapeChanged

Visual Basic [image] Copy Code

Public Event DefaultShapeChanged As EventHandler

Event Data

DefaultShapeChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DeserializeControl Event

DiagramBase.DeserializeControl Event
[image]

Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ControlNodeEventArgs> DeserializeControl

Visual Basic [image] Copy Code

Public Event DeserializeControl As EventHandler(Of ControlNodeEventArgs)

Event Data

DeserializeControl event handlers receive an argument of type ControlNodeEventArgs.

Remarks

Handle this event to load the content of nodes saved using SerializeControl.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DeserializeTag Event

DiagramBase.DeserializeTag Event
[image]

Raised when the Tag or Id of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being deserialized. This object can be either a diagram item, group, cell or anchor point.
Tag | Set this property to the object that has been deserialized.
Representation | An XmlElement instance that contains the XML representation of a Tag value.
Context | An XmlPersistContext object providing information about the document being deserialized, along with methods that help you deserialize data from XML.
Handled | Set this flag to true if you perform custom tag deserialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and SerializeTag.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.DiagramBase.DestinationAnchorChanged Event

DiagramBase.DestinationAnchorChanged Event
[image]

Raised when the DestinationAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> DestinationAnchorChanged

Visual Basic [image] Copy Code

Public Event DestinationAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

DestinationAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose DestinationAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the DestinationAnchor property of a link changes, either because a user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
OriginAnchorChanged Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.DirtyChanged Event

DiagramBase.DirtyChanged Event
[image]

Raised when the Dirty property value has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DirtyChanged

Visual Basic [image] Copy Code

Public Event DirtyChanged As EventHandler

Event Data

DirtyChanged event handlers receive an argument of type EventArgs.

Remarks

Dirty is set to true every time the diagram is modified, but this event is raised only if the flag value changes, either from false to true or from true to false. So the event occurs only when a diagram is modified for the first time, but not when subsequent modifications are done.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRecorded Event


MindFusion.Diagramming.Wpf.DiagramBase.DoubleClicked Event

DiagramBase.DoubleClicked Event
[image]

Raised when the user double-clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DoubleClicked

Visual Basic [image] Copy Code

Public Event DoubleClicked As EventHandler(Of DiagramEventArgs)

Event Data

DoubleClicked event handlers receive an argument of type DiagramEventArgs. The following DiagramEventArgs members provide information relevant to the event:

Member name | Description
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

Remarks

This event is raised only if the user double-clicks an unoccupied point of the diagram. If the user double-clicks a diagram item, one of the following events is raised: NodeDoubleClicked, CellDoubleClicked or LinkDoubleClicked.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ActionRedone Event
Clicked Event


MindFusion.Diagramming.Wpf.DiagramBase.DrawAdjustmentHandles Event

DiagramBase.DrawAdjustmentHandles Event
[image]

Raised when item's adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawItemEventArgs> DrawAdjustmentHandles

Visual Basic [image] Copy Code

Public Event DrawAdjustmentHandles As EventHandler(Of DrawItemEventArgs)

Event Data

DrawAdjustmentHandles event handlers receive an argument of type DrawItemEventArgs.

Remarks

DrawAdjustmentHandles is raised for selected items whose HandlesStyle is set to Custom.

Example

The following example illustrates how to draw a red frame around a node as a visualization of its adjustment handles.

C# [image] Copy Code

private void diagram_DrawAdjustmentHandles(object sender, DrawItemEventArgs e)
{
Pen pen = new Pen(Brushes.Red, 0.3);

if (e.Item is ShapeNode)
{
ShapeNode shapeNode = e.Item as ShapeNode;
Rect r = shapeNode.Bounds;
r.X = 0;
r.Y = 0;
e.Graphics.DrawRectangle(null, pen, new Rect(r.X, r.Y, r.Width, r.Height));
}

if (e.Item is DiagramLink)
{
DiagramLink link = e.Item as DiagramLink;
PathGeometry pg = new PathGeometry();
PathFigure pf = new PathFigure();
pf.StartPoint = link.ControlPoints[0];

for (int i = 1; i < link.ControlPoints.Count; i++)
pf.Segments.Add(new LineSegment(link.ControlPoints[i], true));

pg.Figures.Add(pf);

e.Graphics.DrawGeometry(null, pen, pg);
}
}

Visual Basic [image] Copy Code

Sub diagram_DrawAdjustmentHandles(ByVal sender As Object, ByVal e As MindFusion.Diagramming.Wpf.DrawItemEventArgs) Handles diagram.DrawAdjustmentHandles

Dim pen As Pen = New Pen(Brushes.Red, 0.3)

If TypeOf e.Item Is ShapeNode Then

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)
Dim r As Rect = shapeNode.Bounds
e.Graphics.DrawRectangle(Nothing, pen, New Rect(0, 0, r.Width, r.Height))

End If

If TypeOf e.Item Is DiagramLink Then

Dim link As DiagramLink = CType(e.Item, DiagramLink)
Dim pg As PathGeometry = New PathGeometry()
Dim pf As PathFigure = New PathFigure()
pf.StartPoint = link.ControlPoints(0)

For i As Integer = 1 To link.ControlPoints.Count - 1 Step 1
pf.Segments.Add(New LineSegment(link.ControlPoints(i), True))
Next

pg.Figures.Add(pf)

e.Graphics.DrawGeometry(Nothing, pen, pg)

End If

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
HitTestAdjustmentHandles Event
InternalUtils.DrawAdjustmentHandles Method


MindFusion.Diagramming.Wpf.DiagramBase.DrawAnchorPoint Event

DiagramBase.DrawAnchorPoint Event
[image]

Raised when an anchor point must be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawAnchorPointEventArgs> DrawAnchorPoint

Visual Basic [image] Copy Code

Public Event DrawAnchorPoint As EventHandler(Of DrawAnchorPointEventArgs)

Event Data

DrawAnchorPoint event handlers receive an argument of type DrawAnchorPointEventArgs. The following DrawAnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode containing the anchor point that is being painted.
AnchorIndex | Index of the anchor point withing the node's AnchorPattern.
AnchorPattern | An AnchorPattern instance that contains the anchor point definition.
Location | A Point specifying the location of the anchor point.
Graphics | A DrawingContext instance whose methods should be used to draw the anchor point mark.

Remarks

DrawAnchorPoint is raised for an AnchorPoint if the point's MarkStyle is set to Custom.

Example

The following example demonstrates how to draw images for anchor points:

C# [image] Copy Code

void diagram_DrawAnchorPoint(object sender, DrawAnchorPointEventArgs e)
{
PointF imgPos = e.Location;
imgPos.Y -= 1.8f;

e.Graphics.DrawImage(icon, imgPos);
}

Visual Basic [image] Copy Code

Sub diagram_DrawAnchorPoint(ByVal sender As Object, ByVal e As DrawAnchorPointEventArgs) Handles diagram.DrawAnchorPoint

Dim imgPos As PointF = e.Location
imgPos.Y -= 1.8F

e.Graphics.DrawImage(icon, imgPos)

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DrawBackground Event

DiagramBase.DrawBackground Event
[image]

Raised to let you custom draw the diagram background.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawBackground

Visual Basic [image] Copy Code

Public Event DrawBackground As EventHandler(Of DiagramEventArgs)

Event Data

DrawBackground event handlers receive an argument of type DiagramEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
InvalidateBackground Method


MindFusion.Diagramming.Wpf.DiagramBase.DrawCell Event

DiagramBase.DrawCell Event
[image]

Raised when a table's cell must be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawCellEventArgs> DrawCell

Visual Basic [image] Copy Code

Public Event DrawCell As EventHandler(Of DrawCellEventArgs)

Event Data

DrawCell event handlers receive an argument of type DrawCellEventArgs. The following DrawCellEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode containing the cell that should be custom drawn.
Cell | The Cell that should be custom drawn.
Column | Index of the column containing the cell.
Row | Index of the row containing the cell.
Bounds | The bounding rectangle of the cell being drawn.
Graphics | A DrawingContext instance whose methods should be used to draw the cell contents.

Remarks

This event is raised for tables whose CellCustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
DrawNode Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.DrawForeground Event

DiagramBase.DrawForeground Event
[image]

Raised to let you custom draw the diagram foreground.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawForeground

Visual Basic [image] Copy Code

Public Event DrawForeground As EventHandler(Of DiagramEventArgs)

Event Data

DrawForeground event handlers receive an argument of type DiagramEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DrawLaneHeader Event

DiagramBase.DrawLaneHeader Event
[image]

Raised to let you custom-draw lane headers in the LaneGrid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawHeaderEventArgs> DrawLaneHeader

Visual Basic [image] Copy Code

Public Event DrawLaneHeader As EventHandler(Of DrawHeaderEventArgs)

Event Data

DrawLaneHeader event handlers receive an argument of type DrawHeaderEventArgs. The following DrawHeaderEventArgs members provide information relevant to the event:

Member name | Description
Header | Gets a reference to the header being drawn.
Graphics | Gets a DrawingContext object whose methods should be used to draw the header.
Bounds | Gets the bounding rectangle of the header being drawn.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
EnableLanes Property


MindFusion.Diagramming.Wpf.DiagramBase.DrawLink Event

DiagramBase.DrawLink Event
[image]

Raised when a diagram link must be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawLinkEventArgs> DrawLink

Visual Basic [image] Copy Code

Public Event DrawLink As EventHandler(Of DrawLinkEventArgs)

Event Data

DrawLink event handlers receive an argument of type DrawLinkEventArgs. The following DrawLinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that should be custom drawn.
Points | The collection of the link's control points. When drawing shadows, the points are offset as necessary.
Graphics | A DrawingContext instance whose methods should be used to draw the link.

Remarks

This event is raised for links whose CustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
DrawNode Event


MindFusion.Diagramming.Wpf.DiagramBase.DrawNode Event

DiagramBase.DrawNode Event
[image]

Raised when a diagram node must be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawNodeEventArgs> DrawNode

Visual Basic [image] Copy Code

Public Event DrawNode As EventHandler(Of DrawNodeEventArgs)

Event Data

DrawNode event handlers receive an argument of type DrawNodeEventArgs. The following DrawNodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that should be custom drawn.
Bounds | The bounding rectangle of the node being drawn.
Graphics | A DrawingContext instance whose methods should be used to draw the node.

Remarks

This event is raised for nodes whose CustomDraw property is enabled.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
DrawLink Event


MindFusion.Diagramming.Wpf.DiagramBase.EndLoad Event

DiagramBase.EndLoad Event
[image]

Raised when the component ends loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler EndLoad

Visual Basic [image] Copy Code

Public Event EndLoad As EventHandler

Event Data

EndLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
BeginLoad Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.EnterInplaceEditMode Event

DiagramBase.EnterInplaceEditMode Event
[image]

Raised when entering inplace-edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> EnterInplaceEditMode

Visual Basic [image] Copy Code

Public Event EnterInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

Event Data

EnterInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:

Member name | Description
Item | The node or table cell whose text will be edited.
Node | The node whose text will be edited. If Item is a cell, this property returns the TableNode that contains that cell.
TextBox | The TextBox control where the user can edit the text.

Remarks

This event allows setting properties of the TextBox control used for in-place editing or attaching custom event handlers to that control. A TextBox instance is created each time in-place editing starts, so it could be necessary to set its properties and register event handlers each time EnterInplaceEditMode is raised.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LeaveInplaceEditMode Event


MindFusion.Diagramming.Wpf.DiagramBase.ExpandButtonClicked Event

DiagramBase.ExpandButtonClicked Event
[image]

Raised when the user clicks the [±] button of an Expandable node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ExpandButtonClicked

Visual Basic [image] Copy Code

Public Event ExpandButtonClicked As EventHandler(Of NodeEventArgs)

Event Data

ExpandButtonClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose [±] button has been clicked.

Remarks

This event is raised only if ExpandButtonAction is set to RaiseEvents. Otherwise either the TreeCollapsed or TreeExpanded event is raised, depending on the state of the node.

Example

The following sample code hides or shows all subordinated nodes in a group when the master node's [±] button is clicked:

C# [image] Copy Code
void diagram_ExpandButtonClicked(object sender, NodeEventArgs e)
{
if (e.Node.SubordinateGroup != null)
{
foreach (DiagramItem item in e.Node.SubordinateGroup.AttachedNodes)
item.Visible = e.Node.Expanded;
}
}
Visual Basic [image] Copy Code

Sub diagram_ExpandButtonClicked(ByVal sender As Object, ByVal e As NodeEventArgs) Handles diagram.ExpandButtonClicked

If Not e.Node.SubordinateGroup Is Nothing Then

Dim item As DiagramItem
For Each item In e.Node.SubordinateGroup.AttachedNodes
item.Visible = e.Node.Expanded
Next

End If

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.GroupDestroyed Event

DiagramBase.GroupDestroyed Event
[image]

Raised when a Group object is destroyed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<GroupEventArgs> GroupDestroyed

Visual Basic [image] Copy Code

Public Event GroupDestroyed As EventHandler(Of GroupEventArgs)

Event Data

GroupDestroyed event handlers receive an argument of type GroupEventArgs. The following GroupEventArgs members provide information relevant to the event:

Member name | Description
Group | The Group that has been destroyed.

Remarks

A group can be destroyed in several ways:

  • by removing it from the diagram's Groups collection.
  • by deleting the group's MainItem.
  • in case the main item is a link, if the control point or segment to which subordinated items are attached is removed. That could happen if link's Shape or SegmentCount properties change.

When a group is destroyed, by default the group items are not deleted automatically. You could delete such items from the GroupDestroyed handler, or enable AutoDeleteItems to delete them automatically when the group is destroyed.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.HitTestAdjustmentHandles Event

DiagramBase.HitTestAdjustmentHandles Event
[image]

Raised when custom hit testing of item's adjustment handles must be performed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<HitTestEventArgs> HitTestAdjustmentHandles

Visual Basic [image] Copy Code

Public Event HitTestAdjustmentHandles As EventHandler(Of HitTestEventArgs)

Event Data

HitTestAdjustmentHandles event handlers receive an argument of type HitTestEventArgs. The following HitTestEventArgs members provide information relevant to the event:

Member name | Description
Item | A DiagramItem whose adjustment handles should be hit tested.
MousePosition | A Point specifying the mouse cursor position.
HitResult | Set this property to the index of the adjustment handle that has been hit.

Remarks

For links, set the result to the index of the link's control point that has been hit. For nodes, set the result to 0, 1, 2, 3 for the corner resize handles, 4, 5, 6, 7 for the side center resize handles, 8 for the move handle and 9 for the rotation handle.

Example

C# [image] Copy Code
void diagram_HitTestAdjustmentHandles(object sender, HitTestEventArgs e)
{
ShapeNode shapeNode = e.Item as ShapeNode;
if (shapeNode != null)
{
if (shapeNode.Bounds.Contains(e.MousePosition))
{
// Always move
e.HitResult = 8;
}
}
}
Visual Basic [image] Copy Code

Private Sub diagram_HitTestAdjustmentHandles(ByVal sender As Object, ByVal e As HitTestEventArgs) Handles diagram.HitTestAdjustmentHandles

Dim shapeNode As ShapeNode = CType(e.Item, ShapeNode)

If Not shapeNode Is Nothing Then

If (shapeNode.Bounds.Contains(e.MousePosition)) Then

' Always move
e.HitResult = 8

End If

End If

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.InitializeLink Event

DiagramBase.InitializeLink Event
[image]

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> InitializeLink

Visual Basic [image] Copy Code

Public Event InitializeLink As EventHandler(Of LinkEventArgs)

Event Data

InitializeLink event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The new DiagramLink instance.

Remarks

This event is raised immediately after the user starts drawing a new link. It lets you set the appearance properties of the link if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkCreated Event
ActionRedone Event
LinkCreating Event


MindFusion.Diagramming.Wpf.DiagramBase.InitializeNode Event

DiagramBase.InitializeNode Event
[image]

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> InitializeNode

Visual Basic [image] Copy Code

Public Event InitializeNode As EventHandler(Of NodeEventArgs)

Event Data

InitializeNode event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The new DiagramNode instance.

Remarks

This event is raised immediately after the user starts drawing a new node. It lets you set the appearance properties of the node if you need their values to be different from the default ones defined in the Diagram object, or if they don't have correspondent properties in the Diagram class. The Initialize* events are intended only for initializing the appearance of items. Do not alter the structure of the diagram from their handlers, that is, do not create new items nor delete existing ones; if you do that, the control will be in an undefined state and will likely throw an exception at some point.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeCreated Event
ActionRedone Event
NodeCreating Event


MindFusion.Diagramming.Wpf.DiagramBase.ItemAdded Event

DiagramBase.ItemAdded Event
[image]

Raised when an item is added to the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemAdded

Visual Basic [image] Copy Code

Public Event ItemAdded As EventHandler(Of ItemEventArgs)

Event Data

ItemAdded event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been added to the diagram.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ItemRemoved Event


MindFusion.Diagramming.Wpf.DiagramBase.ItemRemoved Event

DiagramBase.ItemRemoved Event
[image]

Raised when an item is removed from the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemRemoved

Visual Basic [image] Copy Code

Public Event ItemRemoved As EventHandler(Of ItemEventArgs)

Event Data

ItemRemoved event handlers receive an argument of type ItemEventArgs. The following ItemEventArgs members provide information relevant to the event:

Member name | Description
Item | The DiagramItem that has been removed from the diagram.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
ItemAdded Event


MindFusion.Diagramming.Wpf.DiagramBase.LaneGridHeaderTextEdited Event

DiagramBase.LaneGridHeaderTextEdited Event
[image]

Raised when the user edits the text of a lane grid header.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EditHeaderTextEventArgs> LaneGridHeaderTextEdited

Visual Basic [image] Copy Code

Public Event LaneGridHeaderTextEdited As EventHandler(Of EditHeaderTextEventArgs)

Event Data

LaneGridHeaderTextEdited events receive an argument of type EditHeaderTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.LaneGridHeaderTextEditing Event

DiagramBase.LaneGridHeaderTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a lane grid header.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<HeaderValidationEventArgs> LaneGridHeaderTextEditing

Visual Basic [image] Copy Code

Public Event LaneGridHeaderTextEditing As EventHandler(Of HeaderValidationEventArgs)

Event Data

LaneGridHeaderTextEditing events receive an argument of type EditHeaderTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.LeaveInplaceEditMode Event

DiagramBase.LeaveInplaceEditMode Event
[image]

Raised when leaving inplace-edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> LeaveInplaceEditMode

Visual Basic [image] Copy Code

Public Event LeaveInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

Event Data

LeaveInplaceEditMode event handlers receive an argument of type InPlaceEditEventArgs. The following InPlaceEditEventArgs members provide information relevant to the event:

Member name | Description
Item | The node or table cell whose text has been edited.
Node | The node whose text has been edited. If Item is a cell, this property returns the TableNode containing the cell.
TextBox | The TextBox control used to edit the text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
EnterInplaceEditMode Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkActivated Event

DiagramBase.LinkActivated Event
[image]

Raised when a link becomes the ActiveItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkActivated

Visual Basic [image] Copy Code

Public Event LinkActivated As EventHandler(Of LinkEventArgs)

Event Data

LinkActivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has become the ActiveItem.

Remarks

When the event is raised, ActiveItem already refers to the activated link. If multiple-selection is disabled, the active item is the only item selected by the user; otherwise it is usually the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkDeactivated Event
LinkDeselected Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkClicked Event

DiagramBase.LinkClicked Event
[image]

Raised when the user clicks a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkClicked

Visual Basic [image] Copy Code

Public Event LinkClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkDoubleClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkCreated Event

DiagramBase.LinkCreated Event
[image]

Raised when the user draws a new link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreated

Visual Basic [image] Copy Code

Public Event LinkCreated As EventHandler(Of LinkEventArgs)

Event Data

LinkCreated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
InitializeLink Event
LinkCreating Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkCreating Event

DiagramBase.LinkCreating Event
[image]

A validation event raised while the user is drawing a new link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkCreating

Visual Basic [image] Copy Code

Public Event LinkCreating As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkCreating event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being created.
MousePosition | A Point specifying the mouse cursor position.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from creating the link at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link creation.

Remarks

LinkCreating is raised after each mouse movement while drawing a new link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the link creation.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkCreated Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkDeactivated Event

DiagramBase.LinkDeactivated Event
[image]

Raised when a link is no longer the ActiveItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeactivated

Visual Basic [image] Copy Code

Public Event LinkDeactivated As EventHandler(Of LinkEventArgs)

Event Data

LinkDeactivated event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that was the ActiveItem.

Remarks

LinkDeactivated is raised when the ActiveItem changes and before that it referred to a link.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkActivated Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkDeleted Event

DiagramBase.LinkDeleted Event
[image]

Raised when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeleted

Visual Basic [image] Copy Code

Public Event LinkDeleted As EventHandler(Of LinkEventArgs)

Event Data

LinkDeleted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deleted.

Remarks

The link is removed from the Items and Links collections before the event is raised. From within an event handler you can still check the values of simple properties such as Text or Tag. Before deleting a node, all links that link to it a deleted too. So there might be several LinkDeleted events raised before NodeDeleted is raised.

To prevent users from deleting a link by pressing the DEL key, handle the LinkDeleting event.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkCreated Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkDeleting Event

DiagramBase.LinkDeleting Event
[image]

Raised when the user tries to delete a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkDeleting

Visual Basic [image] Copy Code

Public Event LinkDeleting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkDeleting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | A DiagramLink that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the link.

Remarks

When users delete a node, its connecting links are deleted too. However, in that case LinkDeleting validation events are not raised, but just NodeDeleting.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkDeleted Event
DelKeyAction Property


MindFusion.Diagramming.Wpf.DiagramBase.LinkDeselected Event

DiagramBase.LinkDeselected Event
[image]

Raised when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeselected

Visual Basic [image] Copy Code

Public Event LinkDeselected As EventHandler(Of LinkEventArgs)

Event Data

LinkDeselected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkSelected Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkDoubleClicked Event

DiagramBase.LinkDoubleClicked Event
[image]

Raised when the user double-clicks a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDoubleClicked

Visual Basic [image] Copy Code

Public Event LinkDoubleClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkDoubleClicked event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkModified Event

DiagramBase.LinkModified Event
[image]

Raised when the user moves any control point of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModified

Visual Basic [image] Copy Code

Public Event LinkModified As EventHandler(Of LinkEventArgs)

Event Data

LinkModified event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that has been moved.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkModifying Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkModifying Event

DiagramBase.LinkModifying Event
[image]

A validation event raised while the user is modifying a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkModifying

Visual Basic [image] Copy Code

Public Event LinkModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that is being modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
Origin | The DiagramNode that will be set as the link's Origin if this event is validated.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Destination | The DiagramNode that will be set as the link's Destination if this event is validated.
AnchorIndex | Index of the anchor point to which the link will be connected if this event is validated.
TableRow | Index of the table row to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the link modification.

Remarks

This event is raised after each mouse movement while modifying a link. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the link to its original state.

The AdjustmentHandle index corresponds to the link's control point that is being dragged.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkModified Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkPasted Event

DiagramBase.LinkPasted Event
[image]

Raised when a link has been pasted from the clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkPasted

Visual Basic [image] Copy Code

Public Event LinkPasted As EventHandler(Of LinkEventArgs)

Event Data

LinkPasted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.LinkRouted Event

DiagramBase.LinkRouted Event
[image]

Raised when a link is routed by the auto-routing algorithm.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkRouted

Visual Basic [image] Copy Code

Public Event LinkRouted As EventHandler(Of LinkEventArgs)

Event Data

LinkRouted event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been routed.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
AutoRoute Property


MindFusion.Diagramming.Wpf.DiagramBase.LinkSelected Event

DiagramBase.LinkSelected Event
[image]

Raised when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSelected

Visual Basic [image] Copy Code

Public Event LinkSelected As EventHandler(Of LinkEventArgs)

Event Data

LinkSelected event handlers receive an argument of type LinkEventArgs. The following LinkEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that has been selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkDeselected Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkSelecting Event

DiagramBase.LinkSelecting Event
[image]

Occurs when users try to select a link, giving you a chance to cancel the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkSelecting

Visual Basic [image] Copy Code

Public Event LinkSelecting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkSelecting event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is trying to select.
MousePosition | A Point specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

LinkSelecting is raised in two distinct cases - when the user clicks a link, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to Rect.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to a zero point.

LinkSelecting is raised while enumerating all items in the z-order collection, so you cannot change the link's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkSelected Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkSplit Event

DiagramBase.LinkSplit Event
[image]

Raised when the user splits a link interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSplit

Visual Basic [image] Copy Code

Public Event LinkSplit As EventHandler(Of LinkEventArgs)

Event Data

LinkSplit event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
AllowSplitLinks Property


MindFusion.Diagramming.Wpf.DiagramBase.LinkStartModifying Event

DiagramBase.LinkStartModifying Event
[image]

A validation event raised when the user starts modifying a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkStartModifying

Visual Basic [image] Copy Code

Public Event LinkStartModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkStartModifying event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that the user is starting to modify.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the link modification.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkModifying Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkTextEdited Event

DiagramBase.LinkTextEdited Event
[image]

Raised when the user edits the text of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EditLinkTextEventArgs> LinkTextEdited

Visual Basic [image] Copy Code

Public Event LinkTextEdited As EventHandler(Of EditLinkTextEventArgs)

Event Data

LinkTextEdited event handlers receive an argument of type EditLinkTextEventArgs. The following EditLinkTextEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose text has been edited.
NewText | The link's new text.
OldText | The link's old text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
LinkTextEditing Event


MindFusion.Diagramming.Wpf.DiagramBase.LinkTextEditing Event

DiagramBase.LinkTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkTextEditing

Visual Basic [image] Copy Code

Public Event LinkTextEditing As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkTextEditing event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.MagnifierFactorChanged Event

DiagramBase.MagnifierFactorChanged Event
[image]

Occurs when the magnifier factor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler MagnifierFactorChanged

Visual Basic [image] Copy Code

Public Event MagnifierFactorChanged As EventHandler

Event Data

MagnifierFactorChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.MeasureUnitChanged Event

DiagramBase.MeasureUnitChanged Event
[image]

Raised when the MeasureUnit property value has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler MeasureUnitChanged

Visual Basic [image] Copy Code

Public Event MeasureUnitChanged As EventHandler

Event Data

MeasureUnitChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
BoundsChanged Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeActivated Event

DiagramBase.NodeActivated Event
[image]

Raised when a node becomes the ActiveItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeActivated

Visual Basic [image] Copy Code

Public Event NodeActivated As EventHandler(Of NodeEventArgs)

Event Data

NodeActivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has become the ActiveItem.

Remarks

When this event is raised, ActiveItem already refers to the activated node. If multiple-selection is disabled, the active item is the only item selected by the user; otherwise usually it is the one added last to the selection.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeDeactivated Event
NodeSelected Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeClicked Event

DiagramBase.NodeClicked Event
[image]

Raised when the user clicks a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeClicked

Visual Basic [image] Copy Code

Public Event NodeClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeDoubleClicked Event
CellClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeCreated Event

DiagramBase.NodeCreated Event
[image]

Occurs when the user draws a new node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreated

Visual Basic [image] Copy Code

Public Event NodeCreated As EventHandler(Of NodeEventArgs)

Event Data

NodeCreated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been created.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
InitializeNode Event
NodeCreating Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeCreating Event

DiagramBase.NodeCreating Event
[image]

A validation event raised while the user is drawing a new node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeCreating

Visual Basic [image] Copy Code

Public Event NodeCreating As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeCreating event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being created.
MousePosition | A Point specifying the mouse cursor position.
Cancel | Set this property to true to prevent the user from creating the node at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node creation.

Remarks

NodeCreating is raised after each mouse movement while drawing a new node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the node creation.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeCreated Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeDeactivated Event

DiagramBase.NodeDeactivated Event
[image]

Raised when a node is no longer the ActiveItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeactivated

Visual Basic [image] Copy Code

Public Event NodeDeactivated As EventHandler(Of NodeEventArgs)

Event Data

NodeDeactivated event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that was the ActiveItem.

Remarks

NodeDeactivated is raised when the ActiveItem changes and before that it referred to a node.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeActivated Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeDeleted Event

DiagramBase.NodeDeleted Event
[image]

Raised when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeleted

Visual Basic [image] Copy Code

Public Event NodeDeleted As EventHandler(Of NodeEventArgs)

Event Data

NodeDeleted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deleted.

Remarks

When the event is raised, the node is already removed from the Items and Nodes collections and all links connected to the node are deleted. From within an event handler you can still check the values of simple properties of the node such as Text or Tag.

To prevent users from deleting a node by pressing the DEL key, handle the NodeCreating event.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeDeleting Event
NodeCreated Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeDeleting Event

DiagramBase.NodeDeleting Event
[image]

Raised when the user tries to delete a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeDeleting

Visual Basic [image] Copy Code

Public Event NodeDeleting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeDeleting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | A DiagramNode that the user is trying to delete by pressing the DEL key.
Cancel | Set this property to true to prevent the user from deleting the node.

Remarks

When the user deletes a node, the links connected to it are deleted too. However, the LinkDeleting validation event is not raised in that case.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeDeleted Event
DelKeyAction Property


MindFusion.Diagramming.Wpf.DiagramBase.NodeDeselected Event

DiagramBase.NodeDeselected Event
[image]

Raised when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeselected

Visual Basic [image] Copy Code

Public Event NodeDeselected As EventHandler(Of NodeEventArgs)

Event Data

NodeDeselected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been deselected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeSelected Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeDoubleClicked Event

DiagramBase.NodeDoubleClicked Event
[image]

Raised when the user double-clicks a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDoubleClicked

Visual Basic [image] Copy Code

Public Event NodeDoubleClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeDoubleClicked event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been double-clicked.
MouseButton | The mouse button that has been pressed by the user.
MousePosition | A Point specifying the mouse cursor position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeClicked Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeModified Event

DiagramBase.NodeModified Event
[image]

Raised when the user moves or resizes a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModified

Visual Basic [image] Copy Code

Public Event NodeModified As EventHandler(Of NodeEventArgs)

Event Data

NodeModified event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that has been moved.

Remarks

NodeModified is not raised if the node position is changed programmatically. The event occurs only when the user has dragged an adjustment handle to a new position.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeModifying Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeModifying Event

DiagramBase.NodeModifying Event
[image]

A validation event raised while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeModifying

Visual Basic [image] Copy Code

Public Event NodeModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that is being modified.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is being moved.
Cancel | Set this property to true to prevent the user from ending the modification at the current location. That displays the Stop mouse cursor and releasing the button will cancel the operation.
CancelDrag | Call this method to immediately stop the node modification.

Remarks

This event is raised after each mouse movement while modifying a node. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the node to its original location.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeModified Event


MindFusion.Diagramming.Wpf.DiagramBase.NodePasted Event

DiagramBase.NodePasted Event
[image]

Raised when a node has been pasted from the clipboard.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodePasted

Visual Basic [image] Copy Code

Public Event NodePasted As EventHandler(Of NodeEventArgs)

Event Data

NodePasted event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been pasted from the clipboard.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.NodeSelected Event

DiagramBase.NodeSelected Event
[image]

Raised when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeSelected

Visual Basic [image] Copy Code

Public Event NodeSelected As EventHandler(Of NodeEventArgs)

Event Data

NodeSelected event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that has been selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeDeselected Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeSelecting Event

DiagramBase.NodeSelecting Event
[image]

Raised when the user tries to select a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeSelecting

Visual Basic [image] Copy Code

Public Event NodeSelecting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeSelecting event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to select.
MousePosition | A Point specifying the mouse cursor position.
SelectionRectangle | The current selection rectangle.

Remarks

NodeSelecting is raised in two distinct cases - when the user clicks a node, or while the user is drawing a selection rectangle. When raised because of a mouse click, the MousePosition argument is set to a valid point and the SelectionRectangle argument equals to Rect.Empty. While the user is drawing a selection rectangle, the event is raised for each mouse movement, the SelectionRectangle contains the selection coordinates and the MousePosition parameter equals to an empty point.

NodeSelecting is raised while enumerating all items in the z-order collection, so you cannot change the node's ZIndex while handling this event. A selection-related event suitable for changing the z-order of items is SelectionChanged.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeSelected Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeStartModifying Event

DiagramBase.NodeStartModifying Event
[image]

A validation event raised when the user starts modifying a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeStartModifying

Visual Basic [image] Copy Code

Public Event NodeStartModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeStartModifying event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is starting to modify.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | The adjustment handle that is going to be moved.
Cancel | Set this property to true to prevent the user from starting the node modification.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeModifying Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeTextEdited Event

DiagramBase.NodeTextEdited Event
[image]

Raised when the user edits the text of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EditNodeTextEventArgs> NodeTextEdited

Visual Basic [image] Copy Code

Public Event NodeTextEdited As EventHandler(Of EditNodeTextEventArgs)

Event Data

NodeTextEdited event handlers receive an argument of type EditNodeTextEventArgs. The following EditNodeTextEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode whose text has been edited.
NewText | The node's new text.
OldText | The node's old text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeTextEditing Event


MindFusion.Diagramming.Wpf.DiagramBase.NodeTextEditing Event

DiagramBase.NodeTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeTextEditing

Visual Basic [image] Copy Code

Public Event NodeTextEditing As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeTextEditing event handlers receive an argument of type NodeValidationEventArgs. The following NodeValidationEventArgs members provide information relevant to the event:

Member name | Description
Node | The DiagramNode that the user is trying to edit.
Cancel | Set this property to true to prevent the user from editing the node's text.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
NodeTextEdited Event


MindFusion.Diagramming.Wpf.DiagramBase.OriginAnchorChanged Event

DiagramBase.OriginAnchorChanged Event
[image]

Raised when the OriginAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> OriginAnchorChanged

Visual Basic [image] Copy Code

Public Event OriginAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

OriginAnchorChanged event handlers receive an argument of type AnchorPointEventArgs. The following AnchorPointEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink whose OriginAnchor has changed.
OldAnchorIndex | Index of the old anchor point.
NewAnchorIndex | Index of the new anchor point.

Remarks

This event is raised every time the OriginAnchor property of a link changes, either because an user connects the link end to a different anchor point, or because an application sets it programmatically.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
DestinationAnchorChanged Event


MindFusion.Diagramming.Wpf.DiagramBase.SelectionChanged Event

DiagramBase.SelectionChanged Event
[image]

Raised when an item is added to or removed from the selection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler SelectionChanged

Visual Basic [image] Copy Code

Public Event SelectionChanged As EventHandler

Event Data

SelectionChanged event handlers receive an argument of type EventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items are currently selected.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.SelectionModified Event

DiagramBase.SelectionModified Event
[image]

Raised when the user moves or resizes multiple selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SelectionEventArgs> SelectionModified

Visual Basic [image] Copy Code

Public Event SelectionModified As EventHandler(Of SelectionEventArgs)

Event Data

SelectionModified event handlers receive an argument of type SelectionEventArgs.

Remarks

Use the Nodes and Links properties of the diagram's Selection to find out which items have been moved.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
SelectionModifying Event


MindFusion.Diagramming.Wpf.DiagramBase.SelectionModifying Event

DiagramBase.SelectionModifying Event
[image]

Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SelectionValidationEventArgs> SelectionModifying

Visual Basic [image] Copy Code

Public Event SelectionModifying As EventHandler(Of SelectionValidationEventArgs)

Event Data

SelectionModifying event handlers receive an argument of type SelectionValidationEventArgs. The following SelectionValidationEventArgs members provide information relevant to the event:

Member name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
CancelDrag | Call this method to immediately stop the modification.
MousePosition | Gets the current mouse pointer position.

Remarks

This event is raised after each mouse movement while modifying a selection of items. Setting Cancel to true will change the mouse cursor to DisallowCursor (a Stop icon by default). The event is raised once again when the mouse button is released. Setting Cancel to true in that case will cancel the modification and return the items to their original position.

Use the Selection property of the Diagram class to access the selected items.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.SelectionStartModifying Event

DiagramBase.SelectionStartModifying Event
[image]

A validation event raised when the user starts moving or resizing multiple selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SelectionValidationEventArgs> SelectionStartModifying

Visual Basic [image] Copy Code

Public Event SelectionStartModifying As EventHandler(Of SelectionValidationEventArgs)

Event Data

SelectionStartModifying event handlers receive an argument of type SelectionValidationEventArgs. The following SelectionValidationEventArgs members provide information relevant to the event:

Member name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.SerializeControl Event

DiagramBase.SerializeControl Event
[image]

Lets you save the attributes of controls hosted inside DiagramNodeAdapters.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ControlNodeEventArgs> SerializeControl

Visual Basic [image] Copy Code

Public Event SerializeControl As EventHandler(Of ControlNodeEventArgs)

Event Data

SerializeControl event handlers receive an argument of type ControlNodeEventArgs.

Remarks

By default the diagram component saves and loads hosted controls by means of the XamlWriter and XamlReader classes provided by the WPF framework. If they cannot serialize the content of nodes automatically, the SerializeControl and DeserializeControl events can be handled to implement custom serialization.

Example

C# [image] Copy Code

private void OnDiagramSerializeControl(object sender, ControlNodeEventArgs e)
{
TextBox control = e.Node.Control as TextBox;
e.Handled = true;
e.Context.WriteString(control.Text, "Text", e.XmlElement);
}

private void OnDiagramDeserializeControl(object sender, ControlNodeEventArgs e)
{
e.Handled = true;
string text = e.Context.ReadString("Text", e.XmlElement);
e.Node.Control = new TextBox() { Text = text};
}

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.SerializeTag Event

DiagramBase.SerializeTag Event
[image]

Raised when the Tag or Id of a diagram item must be serialized into an XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs. The following SerializeTagEventArgs members provide information relevant to the event:

Member name | Description
Object | The object whose Tag is being serialized. This object can be either a diagram item, group, cell or anchor point.
Tag | The Tag object being serialized.
Representation | An XmlElement instance where the XML representation of the Tag should be saved.
Context | An XmlPersistContext object providing information about the document being serialized, along with methods that help you serialize data to XML.
Handled | Set this flag to true if you perform custom tag serialization.

Remarks

Only tags of simple value types can be saved and loaded automatically to/from the XML document. You must provide your own serialization for complex types by implementing this event and DeserializeTag.

Example

C# [image] Copy Code

private void Write(string fileName)
{
diagram.SerializeTag += new SerializeTagEventHandler(SerializeTag);
diagram.SaveToXml(fileName);
}

void SerializeTag(object sender, SerializeTagEventArgs e)
{
e.Handled = true;
object tag = e.Tag;
string stringRepresentation = "";

if (tag != null)
{
stringRepresentation = tag.GetType().ToString();
stringRepresentation += ";";
stringRepresentation += tag.ToString();
}

XmlNode repNode =
e.Context.XmlDocument.CreateTextNode(stringRepresentation);
e.Representation.AppendChild(repNode);
}

Visual Basic [image] Copy Code

Private Sub Write(ByVal fileName As String)

AddHandler diagram.SerializeTag, New SerializeTagEventHandler(AddressOf SerializeTag)
diagram.SaveToXml(fileName)

End Sub

Sub SerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

e.Handled = True

Dim tag As Object = e.Tag
Dim stringRepresentation As String = ""

If Not Tag Is Nothing Then

stringRepresentation = Tag.GetType().ToString()
stringRepresentation += ";"
stringRepresentation += Tag.ToString()

End If

Dim repNode As XmlNode = _
e.Context.XmlDocument.CreateTextNode(stringRepresentation)
e.Representation.AppendChild(repNode)

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.DiagramBase.SetSelfLoopShape Event

DiagramBase.SetSelfLoopShape Event
[image]

Raised when a link becomes a self-loop, giving you a chance to override the default look shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkShapeEventArgs> SetSelfLoopShape

Visual Basic [image] Copy Code

Public Event SetSelfLoopShape As EventHandler(Of LinkShapeEventArgs)

Event Data

SetSelfLoopShape event handlers receive an argument of type LinkShapeEventArgs. The following LinkShapeEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that becomes a self-loop.
Handled | Indicates whether the event handler has set a custom loop shape.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ShapeModified Event

DiagramBase.ShapeModified Event
[image]

Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ControlPointEventArgs> ShapeModified

Visual Basic [image] Copy Code

Public Event ShapeModified As EventHandler(Of ControlPointEventArgs)

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.TableColumnResized Event

DiagramBase.TableColumnResized Event
[image]

Raised when the user finishes resizing a column in a table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> TableColumnResized

Visual Basic [image] Copy Code

Public Event TableColumnResized As EventHandler(Of CellEventArgs)

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.TableColumnResizing Event

DiagramBase.TableColumnResizing Event
[image]

Raised when the user resizes a column in a table interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> TableColumnResizing

Visual Basic [image] Copy Code

Public Event TableColumnResizing As EventHandler(Of CellValidationEventArgs)

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.TableRowResized Event

DiagramBase.TableRowResized Event
[image]

Raised when the user finishes resizing a row in a table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> TableRowResized

Visual Basic [image] Copy Code

Public Event TableRowResized As EventHandler(Of CellEventArgs)

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.TableRowResizing Event

DiagramBase.TableRowResizing Event
[image]

Raised when the user resizes a row in a table interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> TableRowResizing

Visual Basic [image] Copy Code

Public Event TableRowResizing As EventHandler(Of CellValidationEventArgs)

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.TableSectionCollapsed Event

DiagramBase.TableSectionCollapsed Event
[image]

Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionCollapsed

Visual Basic [image] Copy Code

Public Event TableSectionCollapsed As EventHandler(Of RowEventArgs)

Event Data

TableSectionCollapsed event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the collapsed rows.
RowIndex | Index of the header row of the collapsed section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionCollapsed is raised when a user clicks the [-] button, but not when Expanded is set to false programmatically.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
TableSectionExpanded Event


MindFusion.Diagramming.Wpf.DiagramBase.TableSectionExpanded Event

DiagramBase.TableSectionExpanded Event
[image]

Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionExpanded

Visual Basic [image] Copy Code

Public Event TableSectionExpanded As EventHandler(Of RowEventArgs)

Event Data

TableSectionExpanded event handlers receive an argument of type RowEventArgs. The following RowEventArgs members provide information relevant to the event:

Member name | Description
Table | The TableNode that contains the expanded rows.
RowIndex | Index of the header row of the expanded section.

Remarks

A header row is a row whose Header property is enabled. Such rows display a [±] button which can be used to expand or collapse all rows below a header up to the next header. TableSectionExpanded is raised when a user clicks the [+] button, but not when Expanded is set to true programmatically.

Example

The code below changes the color of the first cell of a header row when the table section defined in that row is expanded:

C# [image] Copy Code

void diagram_TableSectionExpanded(object sender, RowEventArgs e)
{
e.Table[0, e.RowIndex].Brush = new MindFusion.Drawing.SolidBrush(Color.Blue);
}

Visual Basic [image] Copy Code

Private Sub Diagram_TableSectionExpanded(ByVal sender As Object, ByVal e As MindFusion.Diagramming.RowEventArgs)Handles Diagram.TableSectionExpanded

e.Table(0, e.RowIndex).Brush = New MindFusion.Drawing.SolidBrush(Colors.Blue)

End Sub

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
TableSectionCollapsed Event


MindFusion.Diagramming.Wpf.DiagramBase.TreeCollapsed Event

DiagramBase.TreeCollapsed Event
[image]

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeCollapsed

Visual Basic [image] Copy Code

Public Event TreeCollapsed As EventHandler(Of NodeEventArgs)

Event Data

TreeCollapsed event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the collapsed tree branch.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
TreeExpanded Event
ActionRedone Event


MindFusion.Diagramming.Wpf.DiagramBase.TreeExpanded Event

DiagramBase.TreeExpanded Event
[image]

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeExpanded

Visual Basic [image] Copy Code

Public Event TreeExpanded As EventHandler(Of NodeEventArgs)

Event Data

TreeExpanded event handlers receive an argument of type NodeEventArgs. The following NodeEventArgs members provide information relevant to the event:

Member name | Description
Node | The root DiagramNode of the expanded tree branch.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
TreeCollapsed Event


MindFusion.Diagramming.Wpf.DiagramBase.TreeItemTextEditing Event

DiagramBase.TreeItemTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TreeItemValidationEventArgs> TreeItemTextEditing

Visual Basic [image] Copy Code

Public Event TreeItemTextEditing As EventHandler(Of TreeItemValidationEventArgs)

Event Data

TreeItemTextEditing event handlers receive an argument of type TreeItemValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
AllowInplaceEdit Property


MindFusion.Diagramming.Wpf.DiagramBase.ValidateAnchorPoint Event

DiagramBase.ValidateAnchorPoint Event
[image]

A validation event that lets you approve or reject connecting a link to an anchor point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> ValidateAnchorPoint

Visual Basic [image] Copy Code

Public Event ValidateAnchorPoint As EventHandler(Of LinkValidationEventArgs)

Event Data

ValidateAnchorPoint event handlers receive an argument of type LinkValidationEventArgs. The following LinkValidationEventArgs members provide information relevant to the event:

Member name | Description
Link | The DiagramLink that will be connected to the anchor point.
MousePosition | A Point specifying the mouse cursor position.
AdjustmentHandle | Index of the adjustment handle that is being moved.
ChangingOrigin | A value indicating whether the operation changes the origin of the link.
ChangingDestination | A value indicating whether the operation changes the destination of the link.
Node | The DiagramNode to which the link will be connected.
AnchorIndex | Index of an anchor point to which the link will be connected if this event is validated.
Cancel | Set this property to true to prevent connecting the link to specified point.

Remarks

This event is raised for each point of an AnchorPattern while a link's end point is being moved over a node. If none of the anchor points are validated, the mouse cursor icon changes to DisallowLinkCursor, indicating that the link cannot be connected to that node.

When the mouse button is released over a node, the event is raised again for the node's anchor points. From all validated anchor points, the one nearest to the dragged link end point is used to dock the link.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.ZoomFactorChanged Event

DiagramBase.ZoomFactorChanged Event
[image]

Occurs when the zoom factor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ZoomFactorChanged

Visual Basic [image] Copy Code

Public Event ZoomFactorChanged As EventHandler

Event Data

ZoomFactorChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Class

DiagramBase Class
[image]

The base class of the Diagram and DiagramDocument classes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class DiagramBase : Control, IDocumentPaginatorSource

Visual Basic [image] Copy Code

Public MustInherit Class DiagramBase
Inherits Control
Implements IDocumentPaginatorSource

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramBase
MindFusion.Diagramming.Wpf.Diagram
MindFusion.Diagramming.Wpf.DiagramDocument

See Also

DiagramBase Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Members

DiagramBase Members
Constructors Properties Methods Events
[image]

The base class of the Diagram and DiagramDocument classes.

The following tables list the members exposed by the DiagramBase type.

Protected Constructors

Name | Description
DiagramBase | Initializes a new instance of the DiagramBase class.

Public Properties

Name | Description
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.
LicenseKey | Gets or sets the license key of the control.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process.

Public Methods

Name | Description
Print | Shows Print dialog and prints the diagram.
PrintPreview | Overloaded. Displays the diagram in a Print Preview window.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnArranged | Raises the Arranged event.
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnCopyHostedControl | Raises the CopyHostedControl event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeControl | Raises the DeserializeControl event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLaneHeader | Raises the DrawLaneHeader event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event.
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSelectionStartModifying | Raises the SelectionStartModifying event.
OnSerializeControl | Raises the SerializeControl event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnShapeModified | Raises the ShapeModified event.
OnTableColumnResized | Raises the TableColumnResized event.
OnTableColumnResizing | Raises the TableColumnResizing event.
OnTableRowResized | Raises the TableRowResized event.
OnTableRowResizing | Raises the TableRowResizing event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnZoomFactorChanged | Raises the ZoomFactorChanged event.

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
Arranged | Raised when the diagram's visual tree has been arranged.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes.
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header.
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MagnifierFactorChanged | Occurs when the magnifier factor changes.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Occurs when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves or resizes multiple selected items.
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items.
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters.
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.
TableColumnResized | Raised when the user finishes resizing a column in a table.
TableColumnResizing | Raised when the user resizes a column in a table interactively.
TableRowResized | Raised when the user finishes resizing a row in a table.
TableRowResizing | Raised when the user resizes a row in a table interactively.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ZoomFactorChanged | Occurs when the zoom factor changes.

See Also

DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Constructor

DiagramBase Constructor
[image]

Initializes a new instance of the DiagramBase class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Methods

DiagramBase Methods
[image]

Public Methods

Name | Description
Print | Shows Print dialog and prints the diagram.
PrintPreview | Overloaded. Displays the diagram in a Print Preview window.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event.
OnActionRecording | Raises the ActionRecording event.
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnArranged | Raises the Arranged event.
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellDoubleClicked | Raises the CellDoubleClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnCopyHostedControl | Raises the CopyHostedControl event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeControl | Raises the DeserializeControl event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDoubleClicked | Raises the DoubleClicked event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLaneHeader | Raises the DrawLaneHeader event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnGroupDestroyed | Raises the GroupDestroyed event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event.
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkDoubleClicked | Raises the LinkDoubleClicked event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeDoubleClicked | Raises the NodeDoubleClicked event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSelectionStartModifying | Raises the SelectionStartModifying event.
OnSerializeControl | Raises the SerializeControl event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnShapeModified | Raises the ShapeModified event.
OnTableColumnResized | Raises the TableColumnResized event.
OnTableColumnResizing | Raises the TableColumnResizing event.
OnTableRowResized | Raises the TableRowResized event.
OnTableRowResizing | Raises the TableRowResizing event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnZoomFactorChanged | Raises the ZoomFactorChanged event.

See Also

DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnActionRecorded Method

DiagramBase.OnActionRecorded Method
[image]

Raises the ActionRecorded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionRecorded (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRecorded( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnActionRecording Method

DiagramBase.OnActionRecording Method
[image]

Raises the ActionRecording event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionRecording (
UndoValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRecording( _
e As UndoValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnActionRedone Method

DiagramBase.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionRedone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRedone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnActionUndone Method

DiagramBase.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionUndone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionUndone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnArranged Method

DiagramBase.OnArranged Method
[image]

Raises the Arranged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnArranged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnArranged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnBeginLoad Method

DiagramBase.OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnBoundsChanged Method

DiagramBase.OnBoundsChanged Method
[image]

Raises the BoundsChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnBoundsChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBoundsChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnCellClicked Method

DiagramBase.OnCellClicked Method
[image]

Raises the CellClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnCellDoubleClicked Method

DiagramBase.OnCellDoubleClicked Method
[image]

Raises the CellDoubleClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellDoubleClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellDoubleClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnCellTextEdited Method

DiagramBase.OnCellTextEdited Method
[image]

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEdited (
EditCellTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEdited( _
e As EditCellTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnCellTextEditing Method

DiagramBase.OnCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEditing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEditing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnClicked Method

DiagramBase.OnClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnContainerChildAdded Method

DiagramBase.OnContainerChildAdded Method
[image]

Raises the ContainerChildAdded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildAdded (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildAdded( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnContainerChildRemoved Method

DiagramBase.OnContainerChildRemoved Method
[image]

Raises the ContainerChildRemoved event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildRemoved (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildRemoved( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnContainerFolded Method

DiagramBase.OnContainerFolded Method
[image]

Raises the ContainerFolded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnContainerFolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerFolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnContainerUnfolded Method

DiagramBase.OnContainerUnfolded Method
[image]

Raises the ContainerUnfolded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnContainerUnfolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerUnfolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnCopyHostedControl Method

DiagramBase.OnCopyHostedControl Method
[image]

Raises the CopyHostedControl event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCopyHostedControl (
CopyHostedControlEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCopyHostedControl( _
e As CopyHostedControlEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDefaultShapeChanged Method

DiagramBase.OnDefaultShapeChanged Method
[image]

Raises the DefaultShapeChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDefaultShapeChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDefaultShapeChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDeserializeControl Method

DiagramBase.OnDeserializeControl Method
[image]

Raises the DeserializeControl event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeControl (
ControlNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeControl( _
e As ControlNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDeserializeTag Method

DiagramBase.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDestinationAnchorChanged Method

DiagramBase.OnDestinationAnchorChanged Method
[image]

Raises the DestinationAnchorChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDestinationAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDestinationAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDirtyChanged Method

DiagramBase.OnDirtyChanged Method
[image]

Raises the DirtyChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDirtyChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDirtyChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDoubleClicked Method

DiagramBase.OnDoubleClicked Method
[image]

Raises the DoubleClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDoubleClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDoubleClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawAdjustmentHandles Method

DiagramBase.OnDrawAdjustmentHandles Method
[image]

Raises the DrawAdjustmentHandles event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawAdjustmentHandles (
DrawItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAdjustmentHandles( _
e As DrawItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawAnchorPoint Method

DiagramBase.OnDrawAnchorPoint Method
[image]

Raises the DrawAnchorPoint event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawAnchorPoint (
DrawAnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAnchorPoint( _
e As DrawAnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawBackground Method

DiagramBase.OnDrawBackground Method
[image]

Raises the DrawBackground event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawBackground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawBackground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawCell Method

DiagramBase.OnDrawCell Method
[image]

Raises the DrawCell event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawCell (
DrawCellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawCell( _
e As DrawCellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawForeground Method

DiagramBase.OnDrawForeground Method
[image]

Raises the DrawForeground event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawForeground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawForeground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawLaneHeader Method

DiagramBase.OnDrawLaneHeader Method
[image]

Raises the DrawLaneHeader event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawLaneHeader (
DrawHeaderEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawLaneHeader( _
e As DrawHeaderEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawLink Method

DiagramBase.OnDrawLink Method
[image]

Raises the DrawLink event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawLink (
DrawLinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawLink( _
e As DrawLinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnDrawNode Method

DiagramBase.OnDrawNode Method
[image]

Raises the DrawNode event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawNode (
DrawNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawNode( _
e As DrawNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnEndLoad Method

DiagramBase.OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnEnterInplaceEditMode Method

DiagramBase.OnEnterInplaceEditMode Method
[image]

Raises the EnterInplaceEditMode event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnEnterInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEnterInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnExpandButtonClicked Method

DiagramBase.OnExpandButtonClicked Method
[image]

Raises the ExpandButtonClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnExpandButtonClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnExpandButtonClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnGroupDestroyed Method

DiagramBase.OnGroupDestroyed Method
[image]

Raises the GroupDestroyed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnGroupDestroyed (
GroupEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnGroupDestroyed( _
e As GroupEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnHitTestAdjustmentHandles Method

DiagramBase.OnHitTestAdjustmentHandles Method
[image]

Raises the HitTestAdjustmentHandles event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnHitTestAdjustmentHandles (
HitTestEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHitTestAdjustmentHandles( _
e As HitTestEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnInitializeLink Method

DiagramBase.OnInitializeLink Method
[image]

Raises the InitializeLink event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInitializeLink (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeLink( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnInitializeNode Method

DiagramBase.OnInitializeNode Method
[image]

Raises the InitializeNode event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInitializeNode (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeNode( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnItemAdded Method

DiagramBase.OnItemAdded Method
[image]

Raises the ItemAdded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemAdded (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemAdded( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnItemRemoved Method

DiagramBase.OnItemRemoved Method
[image]

Raises the ItemRemoved event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemRemoved (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemRemoved( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLaneGridHeaderTextEdited Method

DiagramBase.OnLaneGridHeaderTextEdited Method
[image]

Raises the LaneGridHeaderTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLaneGridHeaderTextEdited (
EditHeaderTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLaneGridHeaderTextEdited( _
e As EditHeaderTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLaneGridHeaderTextEditing Method

DiagramBase.OnLaneGridHeaderTextEditing Method
[image]

Raises the LaneGridHeaderTextEditing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLaneGridHeaderTextEditing (
HeaderValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLaneGridHeaderTextEditing( _
e As HeaderValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLeaveInplaceEditMode Method

DiagramBase.OnLeaveInplaceEditMode Method
[image]

Raises the LeaveInplaceEditMode event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLeaveInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLeaveInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkActivated Method

DiagramBase.OnLinkActivated Method
[image]

Raises the LinkActivated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkActivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkActivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkClicked Method

DiagramBase.OnLinkClicked Method
[image]

Raises the LinkClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkCreated Method

DiagramBase.OnLinkCreated Method
[image]

Raises the LinkCreated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkCreating Method

DiagramBase.OnLinkCreating Method
[image]

Raises the LinkCreating event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreating (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreating( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkDeactivated Method

DiagramBase.OnLinkDeactivated Method
[image]

Raises the LinkDeactivated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeactivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeactivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkDeleted Method

DiagramBase.OnLinkDeleted Method
[image]

Raises the LinkDeleted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkDeleting Method

DiagramBase.OnLinkDeleting Method
[image]

Raises the LinkDeleting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkDeselected Method

DiagramBase.OnLinkDeselected Method
[image]

Raises the LinkDeselected event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeselected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeselected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkDoubleClicked Method

DiagramBase.OnLinkDoubleClicked Method
[image]

Raises the LinkDoubleClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkDoubleClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDoubleClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkModified Method

DiagramBase.OnLinkModified Method
[image]

Raises the LinkModified event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkModifying Method

DiagramBase.OnLinkModifying Method
[image]

Raises the LinkModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkPasted Method

DiagramBase.OnLinkPasted Method
[image]

Raises the LinkPasted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkPasted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkPasted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkRouted Method

DiagramBase.OnLinkRouted Method
[image]

Raises the LinkRouted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkRouted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkRouted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkSelected Method

DiagramBase.OnLinkSelected Method
[image]

Raises the LinkSelected event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkSelecting Method

DiagramBase.OnLinkSelecting Method
[image]

Raises the LinkSelecting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelecting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelecting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkSplit Method

DiagramBase.OnLinkSplit Method
[image]

Raises the LinkSplit event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkSplit (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSplit( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkStartModifying Method

DiagramBase.OnLinkStartModifying Method
[image]

Raises the LinkStartModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkStartModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkStartModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkTextEdited Method

DiagramBase.OnLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEdited (
EditLinkTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEdited( _
e As EditLinkTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnLinkTextEditing Method

DiagramBase.OnLinkTextEditing Method
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEditing (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEditing( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnMagnifierFactorChanged Method

DiagramBase.OnMagnifierFactorChanged Method
[image]

Raises the MagnifierFactorChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMagnifierFactorChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMagnifierFactorChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnMeasureUnitChanged Method

DiagramBase.OnMeasureUnitChanged Method
[image]

Raises the MeasureUnitChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeActivated Method

DiagramBase.OnNodeActivated Method
[image]

Raises the NodeActivated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeActivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeActivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeClicked Method

DiagramBase.OnNodeClicked Method
[image]

Raises the NodeClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeCreated Method

DiagramBase.OnNodeCreated Method
[image]

Raises the NodeCreated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeCreating Method

DiagramBase.OnNodeCreating Method
[image]

Raises the NodeCreating event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreating (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreating( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeDeactivated Method

DiagramBase.OnNodeDeactivated Method
[image]

Raises the NodeDeactivated event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeactivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeactivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeDeleted Method

DiagramBase.OnNodeDeleted Method
[image]

Raises the NodeDeleted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeDeleting Method

DiagramBase.OnNodeDeleting Method
[image]

Raises the NodeDeleting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeDeselected Method

DiagramBase.OnNodeDeselected Method
[image]

Raises the NodeDeselected event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeselected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeselected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeDoubleClicked Method

DiagramBase.OnNodeDoubleClicked Method
[image]

Raises the NodeDoubleClicked event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeDoubleClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDoubleClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeModified Method

DiagramBase.OnNodeModified Method
[image]

Raises the NodeModified event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeModifying Method

DiagramBase.OnNodeModifying Method
[image]

Raises the NodeModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodePasted Method

DiagramBase.OnNodePasted Method
[image]

Raises the NodePasted event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodePasted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodePasted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeSelected Method

DiagramBase.OnNodeSelected Method
[image]

Raises the NodeSelected event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeSelecting Method

DiagramBase.OnNodeSelecting Method
[image]

Raises the NodeSelecting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelecting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelecting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeStartModifying Method

DiagramBase.OnNodeStartModifying Method
[image]

Raises the NodeStartModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeStartModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeStartModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeTextEdited Method

DiagramBase.OnNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEdited (
EditNodeTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEdited( _
e As EditNodeTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnNodeTextEditing Method

DiagramBase.OnNodeTextEditing Method
[image]

Raises the NodeTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEditing (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEditing( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnOriginAnchorChanged Method

DiagramBase.OnOriginAnchorChanged Method
[image]

Raises the OriginAnchorChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnOriginAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnOriginAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSelectionChanged Method

DiagramBase.OnSelectionChanged Method
[image]

Raises the SelectionChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSelectionModified Method

DiagramBase.OnSelectionModified Method
[image]

Raises the SelectionModified event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModified (
SelectionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModified( _
e As SelectionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSelectionModifying Method

DiagramBase.OnSelectionModifying Method
[image]

Raises the SelectionModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModifying (
SelectionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModifying( _
e As SelectionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSelectionStartModifying Method

DiagramBase.OnSelectionStartModifying Method
[image]

Raises the SelectionStartModifying event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionStartModifying (
SelectionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionStartModifying( _
e As SelectionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSerializeControl Method

DiagramBase.OnSerializeControl Method
[image]

Raises the SerializeControl event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeControl (
ControlNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeControl( _
e As ControlNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSerializeTag Method

DiagramBase.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnSetSelfLoopShape Method

DiagramBase.OnSetSelfLoopShape Method
[image]

Raises the SetSelfLoopShape event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSetSelfLoopShape (
LinkShapeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSetSelfLoopShape( _
e As LinkShapeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnShapeModified Method

DiagramBase.OnShapeModified Method
[image]

Raises the ShapeModified event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnShapeModified (
ControlPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnShapeModified( _
e As ControlPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableColumnResized Method

DiagramBase.OnTableColumnResized Method
[image]

Raises the TableColumnResized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableColumnResized (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableColumnResized( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableColumnResizing Method

DiagramBase.OnTableColumnResizing Method
[image]

Raises the TableColumnResizing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableColumnResizing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableColumnResizing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableRowResized Method

DiagramBase.OnTableRowResized Method
[image]

Raises the TableRowResized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableRowResized (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableRowResized( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableRowResizing Method

DiagramBase.OnTableRowResizing Method
[image]

Raises the TableRowResizing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableRowResizing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableRowResizing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableSectionCollapsed Method

DiagramBase.OnTableSectionCollapsed Method
[image]

Raises the TableSectionCollapsed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionCollapsed (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionCollapsed( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTableSectionExpanded Method

DiagramBase.OnTableSectionExpanded Method
[image]

Raises the TableSectionExpanded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionExpanded (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionExpanded( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTreeCollapsed Method

DiagramBase.OnTreeCollapsed Method
[image]

Raises the TreeCollapsed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTreeCollapsed (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeCollapsed( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTreeExpanded Method

DiagramBase.OnTreeExpanded Method
[image]

Raises the TreeExpanded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTreeExpanded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeExpanded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnTreeItemTextEditing Method

DiagramBase.OnTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTreeItemTextEditing (
TreeItemValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeItemTextEditing( _
e As TreeItemValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnValidateAnchorPoint Method

DiagramBase.OnValidateAnchorPoint Method
[image]

Raises the ValidateAnchorPoint event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValidateAnchorPoint (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidateAnchorPoint( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.OnZoomFactorChanged Method

DiagramBase.OnZoomFactorChanged Method
[image]

Raises the ZoomFactorChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnZoomFactorChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomFactorChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.Print Method

DiagramBase.Print Method
[image]

Shows Print dialog and prints the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Print ()

Visual Basic [image] Copy Code

Public Sub Print ()

Remarks

The method displays the standard Windows print dialog, allowing users to select a printer and choose which portions of the document to print. The smallest rectangular area of the document that contains all diagram elements is printed.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
PrintPreview Method


MindFusion.Diagramming.Wpf.DiagramBase.PrintPreview Method

DiagramBase.PrintPreview Method
[image]

Displays the diagram in a Print Preview window.

Overload List

Name | Description
DiagramBase.PrintPreview () | Displays the diagram in a Print Preview window.
DiagramBase.PrintPreview (String) | Displays the diagram in a Print Preview window.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.PrintPreview Method ()

DiagramBase.PrintPreview Method ()
See Also
[image]

Displays the diagram in a Print Preview window.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview ()

Visual Basic [image] Copy Code

Public Sub PrintPreview ()

Remarks

The Print Preview window shows what the diagram content would look like when printed on paper.

See Also

PrintPreview Method Overload List
DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.PrintPreview Method (String)

DiagramBase.PrintPreview Method (String)
See Also
[image]

Displays the diagram in a Print Preview window.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
string windowTitle
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
windowTitle As String _
)

Parameters

windowTitle

A string specifying the title of the Print Preview window.

Remarks

The Print Preview window shows what the diagram content would look like when printed on paper.

See Also

PrintPreview Method Overload List
DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Properties

DiagramBase Properties
[image]

Public Properties

Name | Description
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.
LicenseKey | Gets or sets the license key of the control.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process.

See Also

DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.DocumentPaginator Property

DiagramBase.DocumentPaginator Property
[image]

Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

An instance of the System.Windows.Documents.DocumentPaginator class.

Remarks

You can use this property as an argument to the PrintDocument.PrintDocument method.

Example

C# [image] Copy Code

PrintDialog pd = new PrintDialog();

if (pd.ShowDialog())
pd.PrintDocument(diagram.DocumentPaginator, "my diagram");

Visual Basic [image] Copy Code

Dim pd As New PrintDialog()

If pd.ShowDialog() Then
pd.PrintDocument(diagram.DocumentPaginator, "my diagram")
End If

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.LicenseKey Property

DiagramBase.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

Set this property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one Diagram instance or other controls by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) from application start-up code to specify the key once instead of setting it per each control. License key strings are listed on the Keys & Downloads page at MindFusion's customer portal.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase.PrintOptions Property

DiagramBase.PrintOptions Property
[image]

Gets an object which provides customization properties for printing and print-preview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PrintOptions PrintOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

Remarks

Allows customization of various print and print-preview aspects. The settings exposed as properties include document title, page header format and several bool flags that control if images, shadows, headers, and so on are printed or rendered in preview mode.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace
Print Method


MindFusion.Diagramming.Wpf.DiagramBase.XmlOptions Property

DiagramBase.XmlOptions Property
[image]

An XmlOptions object providing properties for customizing the XML serialization process.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlOptions XmlOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlOptions As XmlOptions

Property Value

An XmlOptions instance.

See Also

DiagramBase Members
DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramBase Events

DiagramBase Events
[image]

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history.
ActionRecording | A validation event raised before an action is recorded in the undo buffer.
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
ActiveLayerChanged | Raised when the diagram's active layer has changed.
Arranged | Raised when the diagram's visual tree has been arranged.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellDoubleClicked | Raised when the user double-clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes.
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
EnterInplaceEditMode | Raised when entering inplace-edit mode.
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node.
GroupDestroyed | Raised when a Group object is destroyed.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header.
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkDoubleClicked | Raised when the user double-clicks a link.
LinkModified | Raised when the user moves any control point of a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MagnifierFactorChanged | Occurs when the magnifier factor changes.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreated | Occurs when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeDoubleClicked | Raised when the user double-clicks a node.
NodeModified | Raised when the user moves or resizes a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves or resizes multiple selected items.
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification.
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items.
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters.
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters.
TableColumnResized | Raised when the user finishes resizing a column in a table.
TableColumnResizing | Raised when the user resizes a column in a table interactively.
TableRowResized | Raised when the user finishes resizing a row in a table.
TableRowResizing | Raised when the user resizes a row in a table interactively.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ZoomFactorChanged | Occurs when the zoom factor changes.

See Also

DiagramBase Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Class

DiagramDocument Class
[image]

Represents a collection of diagram pages.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramDocument : DiagramBase

Visual Basic [image] Copy Code

Public Class DiagramDocument
Inherits DiagramBase

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramBase
MindFusion.Diagramming.Wpf.DiagramDocument

See Also

DiagramDocument Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Members

DiagramDocument Members
Constructors Properties Methods Events
[image]

Represents a collection of diagram pages.

The following tables list the members exposed by the DiagramDocument type.

Public Constructors

Name | Description
DiagramDocument | Initializes a new instance of the DiagramDocument class.

Public Properties

Name | Description
Dirty | Gets a value indicating whether the document has changed since the last save.
DocumentPaginator | DiagramBase.DocumentPaginator override.
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
Pages | Gets a list of the diagram pages contained in this document.
PrintOptions | Gets an object which provides customization properties for printing and print-preview. (Inherited from DiagramBase.)
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)

Public Methods

Name | Description
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded. Loads the document from an XML.
Print | Shows Print dialog and prints the diagram. (Inherited from DiagramBase.)
PrintPreview | Overloaded. Displays the diagram in a Print Preview window. (Inherited from DiagramBase.)
SaveToString | Overloaded. Saves the document as a string.
SaveToXml | Overloaded. Saves the document as an XML.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Constructor

DiagramDocument Constructor
[image]

Initializes a new instance of the DiagramDocument class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramDocument ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Methods

DiagramDocument Methods
[image]

Public Methods

Name | Description
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded. Loads the document from an XML.
Print | Shows Print dialog and prints the diagram. (Inherited from DiagramBase.)
PrintPreview | Overloaded. Displays the diagram in a Print Preview window. (Inherited from DiagramBase.)
SaveToString | Overloaded. Saves the document as a string.
SaveToXml | Overloaded. Saves the document as an XML.

Protected Methods

Name | Description
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

See Also

DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.LoadFromString Method

DiagramDocument.LoadFromString Method
[image]

Loads a diagram from the specified string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.LoadFromXml Method

DiagramDocument.LoadFromXml Method
[image]

Loads the document from an XML.

Overload List

Name | Description
DiagramDocument.LoadFromXml (String) | Loads the document from the specified XML file.
DiagramDocument.LoadFromXml (XmlDocument) | Loads the document from the specified XmlDocument object.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.LoadFromXml Method (String)

DiagramDocument.LoadFromXml Method (String)
See Also
[image]

Loads the document from the specified XML file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the XML file the data should be read from.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.LoadFromXml Method (XmlDocument)

DiagramDocument.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the document from the specified XmlDocument object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document

A .NET XmlDocument object from which to load the diagram data.

See Also

LoadFromXml Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToString Method

DiagramDocument.SaveToString Method
[image]

Saves the document as a string.

Overload List

Name | Description
DiagramDocument.SaveToString () | Saves the document as an ASCII string.
DiagramDocument.SaveToString (SaveToStringFormat, Boolean) | Saves the document as an ASCII string.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToString Method ()

DiagramDocument.SaveToString Method ()
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

A string value.

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)

DiagramDocument.SaveToString Method (SaveToStringFormat, Boolean)
See Also
[image]

Saves the document as an ASCII string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string SaveToString (
SaveToStringFormat format,
bool clearDirty
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
format As SaveToStringFormat, _
clearDirty As Boolean _
) As String

Parameters

format

One of the SaveToStringFormat values.

clearDirty

Indicates whether the 'dirty' flag should be cleared.

Return Value

A string value.

See Also

SaveToString Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToXml Method

DiagramDocument.SaveToXml Method
[image]

Saves the document as an XML.

Overload List

Name | Description
DiagramDocument.SaveToXml (String) | Saves the document to the specified file in an XML format.
DiagramDocument.SaveToXml (XmlDocument) | Saves the document to the specified XmlDocument object.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToXml Method (String)

DiagramDocument.SaveToXml Method (String)
See Also
[image]

Saves the document to the specified file in an XML format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The full path and name of the disk file where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.SaveToXml Method (XmlDocument)

DiagramDocument.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the document to the specified XmlDocument object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document

A .NET XmlDocument object where the document should be saved.

See Also

SaveToXml Method Overload List
DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Properties

DiagramDocument Properties
[image]

Public Properties

Name | Description
Dirty | Gets a value indicating whether the document has changed since the last save.
DocumentPaginator | DiagramBase.DocumentPaginator override.
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
Pages | Gets a list of the diagram pages contained in this document.
PrintOptions | Gets an object which provides customization properties for printing and print-preview. (Inherited from DiagramBase.)
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)

See Also

DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.Dirty Property

DiagramDocument.Dirty Property
[image]

Gets a value indicating whether the document has changed since the last save.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Dirty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dirty As Boolean

Property Value

true if the document has changed; otherwise, false.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.DocumentPaginator Property

DiagramDocument.DocumentPaginator Property
[image]

DiagramBase.DocumentPaginator override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

An instance of the System.Windows.Documents.DocumentPaginator class.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument.Pages Property

DiagramDocument.Pages Property
[image]

Gets a list of the diagram pages contained in this document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<DiagramPage> Pages { get; set; }

Visual Basic [image] Copy Code

Public Property Pages As ObservableCollection(Of DiagramPage)

Property Value

A list with all document pages.

See Also

DiagramDocument Members
DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocument Events

DiagramDocument Events
[image]

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramDocument Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Class

DiagramDocumentPaginator Class
[image]

Implements pagination of a DiagramDocument object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramDocumentPaginator : DocumentPaginator

Visual Basic [image] Copy Code

Public Class DiagramDocumentPaginator
Inherits DocumentPaginator

Inheritance Hierarchy

System.Object
System.Windows.Documents.DocumentPaginator
MindFusion.Diagramming.Wpf.DiagramDocumentPaginator

See Also

DiagramDocumentPaginator Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Members

DiagramDocumentPaginator Members
Constructors Properties Methods
[image]

Implements pagination of a DiagramDocument object.

The following tables list the members exposed by the DiagramDocumentPaginator type.

Public Constructors

Name | Description
DiagramDocumentPaginator | Overloaded.

Public Properties

Name | Description
IsPageCountValid | DocumentPaginator.IsPageCountValid override.
PageCount | DocumentPaginator.PageCount override.
PageSize | DocumentPaginator.PageSize override.
Source | DocumentPaginator.Source override.

Public Methods

Name | Description
GetPage | DocumentPaginator.GetPage override.

See Also

DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Constructor

DiagramDocumentPaginator Constructor
[image]

Overload List

Name | Description
DiagramDocumentPaginator (DiagramDocument) | Initializes a new instance of the DiagramDocumentPaginator class.
DiagramDocumentPaginator (DiagramDocument, PrintOptions) | Initializes a new instance of the DiagramDocumentPaginator class.

See Also

DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Constructor (DiagramDocument)

DiagramDocumentPaginator Constructor (DiagramDocument)
See Also
[image]

Initializes a new instance of the DiagramDocumentPaginator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramDocumentPaginator (
DiagramDocument document
)

Visual Basic [image] Copy Code

Public New ( _
document As DiagramDocument _
)

Parameters

document

See Also

DiagramDocumentPaginator Constructor Overload List
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Constructor (DiagramDocument, PrintOptions)

DiagramDocumentPaginator Constructor (DiagramDocument, PrintOptions)
See Also
[image]

Initializes a new instance of the DiagramDocumentPaginator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramDocumentPaginator (
DiagramDocument document,
PrintOptions printOptions
)

Visual Basic [image] Copy Code

Public New ( _
document As DiagramDocument, _
printOptions As PrintOptions _
)

Parameters

document

printOptions

See Also

DiagramDocumentPaginator Constructor Overload List
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Methods

DiagramDocumentPaginator Methods
[image]

Public Methods

Name | Description
GetPage | DocumentPaginator.GetPage override.

See Also

DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator.GetPage Method

DiagramDocumentPaginator.GetPage Method
[image]

DocumentPaginator.GetPage override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DocumentPage GetPage (
int pageNumber
)

Visual Basic [image] Copy Code

Public Overrides Function GetPage( _
pageNumber As Integer _
) As DocumentPage

Parameters

pageNumber

Return Value

See Also

DiagramDocumentPaginator Members
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator Properties

DiagramDocumentPaginator Properties
[image]

Public Properties

Name | Description
IsPageCountValid | DocumentPaginator.IsPageCountValid override.
PageCount | DocumentPaginator.PageCount override.
PageSize | DocumentPaginator.PageSize override.
Source | DocumentPaginator.Source override.

See Also

DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator.IsPageCountValid Property

DiagramDocumentPaginator.IsPageCountValid Property
[image]

DocumentPaginator.IsPageCountValid override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool IsPageCountValid { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property IsPageCountValid As Boolean

Property Value

See Also

DiagramDocumentPaginator Members
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator.PageCount Property

DiagramDocumentPaginator.PageCount Property
[image]

DocumentPaginator.PageCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int PageCount { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property PageCount As Integer

Property Value

See Also

DiagramDocumentPaginator Members
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator.PageSize Property

DiagramDocumentPaginator.PageSize Property
[image]

DocumentPaginator.PageSize override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property PageSize As Size

Property Value

See Also

DiagramDocumentPaginator Members
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramDocumentPaginator.Source Property

DiagramDocumentPaginator.Source Property
[image]

DocumentPaginator.Source override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override IDocumentPaginatorSource Source { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Source As IDocumentPaginatorSource

Property Value

See Also

DiagramDocumentPaginator Members
DiagramDocumentPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Class

DiagramEventArgs Class
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DiagramEventArgs

See Also

DiagramEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Overloaded. Initializes a new instance of the DiagramEventArgs class.

Public Properties

Name | Description
Graphics | Gets a DrawingContext instance whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Constructor

DiagramEventArgs Constructor
[image]

Initializes a new instance of the DiagramEventArgs class.

Overload List

Name | Description
DiagramEventArgs (DrawingContext) | Initializes a new instance of the DiagramEventArgs class.
DiagramEventArgs (MouseButton, Point) | Initializes a new instance of the DiagramEventArgs class.

See Also

DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Constructor (DrawingContext)

DiagramEventArgs Constructor (DrawingContext)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramEventArgs (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext _
)

Parameters

graphics

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Constructor (MouseButton, Point)

DiagramEventArgs Constructor (MouseButton, Point)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramEventArgs (
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

mouseButton

The mouse button related to the event.

mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs Properties

DiagramEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets a DrawingContext instance whose methods should be used to draw the custom graphics.
MouseButton | Gets or sets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs.Graphics Property

DiagramEventArgs.Graphics Property
[image]

Gets a DrawingContext instance whose methods should be used to draw the custom graphics.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

A DrawingContext object.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs.MouseButton Property

DiagramEventArgs.MouseButton Property
[image]

Gets or sets which mouse button has been pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; set; }

Visual Basic [image] Copy Code

Public Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramEventArgs.MousePosition Property

DiagramEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A Point value specifying the current mouse position.

See Also

DiagramEventArgs Members
DiagramEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Class

DiagramItem Class
Remarks See Also
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class DiagramItem : FrameworkElement, IDisposable, ITextAttributes

Visual Basic [image] Copy Code

Public MustInherit Class DiagramItem
Inherits FrameworkElement
Implements IDisposable, ITextAttributes

Remarks

All items in the diagram document - links and nodes - share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties, which every diagram element should have.

MindFusion.Diagramming for WPF invokes the Draw method when an item must be drawn on screen. You can call Draw if you need to draw an item on your own graphics surface. Override the method when implementing custom item types to provide your own rendering functionality.

The standard item types draw their interior using the brush assigned to the Brush property. The items borders are rendered using the attributes set through Stroke, StrokeThickness, StrokeDashStyle, StrokeMiterLimit, StrokeLineJoin and various Stroke*Cap properties.

The item's text is specified through the Text property. Its font attributes can be set through FontFamily, FontSize, FontStyle, FontWeight and FontStretch properties. Text layout attributes are specified via TextAlignment, TextVerticalAlignment, TextPadding, TextWrapping and TextTrimming.

The order in which items are painted from bottom to top is called the z-order. Moving items up or down the z-order can be done by means of the ZBottom, ZTop, ZLevelUp and ZLevelDown methods. Accessing and setting the index of an item in the z-order can be done using the ZIndex property.

An hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. The group of items attached to another item is accessed by the SubordinateGroup property of the latter. MasterGroup gets the group in which an item is subordinate.

It is possible to find items in specific relation to the current one by means of the Query method. Query can traverse the node/link graph connections and parent/child relationships in hierarchies, and filter the results by means of predicate expressions.

An application can associate custom data with an item by means of the Tag property. The tags are only meant to hold data related to the entities represented by the chart items. They are not used or modified by MindFusion.Diagramming for WPF in any way. The tags are saved and loaded together with the diagram elements when serializing the document to a disk file or a stream.

Items can be locked for interactive modification through the Locked property. Locked items can still be modified programmatically. Items can also be marked as locked for automatic layout methods by the IgnoreLayout property.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramLink
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.Selection

See Also

DiagramItem Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Members

DiagramItem Members
Constructors Fields Properties Methods
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Protected Constructors

Name | Description
DiagramItem | Overloaded. Initializes a new instance of the DiagramItem class.

Public Fields

Name | Description
BrushProperty | Idendifies the Brush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
IdProperty | Identifies the Id dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextPaddingProperty | Identifies the TextPadding dependency property.
TextProperty | Identifies the Text dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property.
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Protected Fields

Name | Description
disposed | For internal use.

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles.
Brush | Gets or sets the brush used to fill the interior of this item.
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Printable | Gets or sets a value indicating whether to print the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
Stroke | Gets or sets the Brush that specifies how the item outline is painted.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Text | Gets or sets the text displayed inside this item.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the brush used to draw the item's text.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
UIElement | Gets the UIElement associated with this DiagramItem.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.
Size | Gets the size of this item.

Public Methods

Name | Description
ClearStyleableProperties | Clears the local values of all styleable appearance properties.
Clone | Creates a copy of this item.
ContainsPoint | Overloaded.
Dispose | Overloaded.
Draw | Draws the item on the specified DrawingContext object.
DrawHandles | Renders the selection handles.
GetBounds | Gets the bounding rectangle of this item.
GetRegion | Returns a Geometry object representing the shape of this item.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression.
Repaint | Overloaded.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates.
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Draws the associated manipulators in the specified context.
EnumStyleableProperties | Applies specified function on properties intended to be set from WPF styles.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetHeight | Gets the height of this item.
GetTextRect | Subtracts the TextPadding values from the specified rectangle.
GetWidth | Gets the width of this item.
GetX | Gets the x-coordinate of the current position of this item.
GetY | Gets the y-coordinate of the current position of this item.
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or performing undo / redo.
OnChildModified | Called when a group child node has been modified.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnPositioningChanged | Called when the item's position changes.
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo.
OnRender | UIElement.OnRender override.
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes.
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes.
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes.
OnZoomChanged | Called when the ZoomFactor changes.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Fields

DiagramItem Fields
[image]

Public Fields

Name | Description
BrushProperty | Idendifies the Brush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
IdProperty | Identifies the Id dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextPaddingProperty | Identifies the TextPadding dependency property.
TextProperty | Identifies the Text dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property.
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Protected Fields

Name | Description
disposed | For internal use.

See Also

DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.BrushProperty Field

DiagramItem.BrushProperty Field
[image]

Idendifies the Brush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.disposed Field

DiagramItem.disposed Field
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool disposed

Visual Basic [image] Copy Code

Protected disposed As Boolean

Remarks

This field is used in the implementation of the IDisposable pattern.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontFamilyProperty Field

DiagramItem.FontFamilyProperty Field
[image]

Identifies the FontFamily dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontFamilyProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontSizeProperty Field

DiagramItem.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontStretchProperty Field

DiagramItem.FontStretchProperty Field
[image]

Identifies the FontStretch dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontStretchProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontStyleProperty Field

DiagramItem.FontStyleProperty Field
[image]

Identifies the FontStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontStyleProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontWeightProperty Field

DiagramItem.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontWeightProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.IdProperty Field

DiagramItem.IdProperty Field
[image]

Identifies the Id dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IdProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IdProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeDashCapProperty Field

DiagramItem.StrokeDashCapProperty Field
[image]

Identifies the StrokeDashCap dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeDashStyleProperty Field

DiagramItem.StrokeDashStyleProperty Field
[image]

Identifies the StrokeDashStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashStyleProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeEndLineCapProperty Field

DiagramItem.StrokeEndLineCapProperty Field
[image]

Identifies the StrokeEndLineCap dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeEndLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeEndLineCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeLineJoinProperty Field

DiagramItem.StrokeLineJoinProperty Field
[image]

Identifies the StrokeLineJoin dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeLineJoinProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeLineJoinProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeMiterLimitProperty Field

DiagramItem.StrokeMiterLimitProperty Field
[image]

Identifies the StrokeMiterLimit dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeMiterLimitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeMiterLimitProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeProperty Field

DiagramItem.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeStartLineCapProperty Field

DiagramItem.StrokeStartLineCapProperty Field
[image]

Identifies the StrokeStartLineCap dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeStartLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeStartLineCapProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StrokeThicknessProperty Field

DiagramItem.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextAlignmentProperty Field

DiagramItem.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextBrushProperty Field

DiagramItem.TextBrushProperty Field
[image]

Identifies the TextBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextBrushProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextDecorationsProperty Field

DiagramItem.TextDecorationsProperty Field
[image]

Identifies the TextDecorations dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextDecorationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextDecorationsProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextPaddingProperty Field

DiagramItem.TextPaddingProperty Field
[image]

Identifies the TextPadding dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextPaddingProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextProperty Field

DiagramItem.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextTrimmingProperty Field

DiagramItem.TextTrimmingProperty Field
[image]

Identifies the TextTrimming dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextTrimmingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextTrimmingProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextVerticalAlignmentProperty Field

DiagramItem.TextVerticalAlignmentProperty Field
[image]

Identifies the TextVerticalAlignment dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextVerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextVerticalAlignmentProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TextWrappingProperty Field

DiagramItem.TextWrappingProperty Field
[image]

Identifies the TextWrapping dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextWrappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Constructor

DiagramItem Constructor
[image]

Initializes a new instance of the DiagramItem class.

Overload List

Name | Description
DiagramItem () | Initializes a new instance of the DiagramItem class.
DiagramItem (Diagram) | Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.
DiagramItem (DiagramItem) | Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

See Also

DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Constructor ()

DiagramItem Constructor ()
See Also
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramItem properties to their default values.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Constructor (Diagram)

DiagramItem Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramItem (
Diagram parent
)

Visual Basic [image] Copy Code

Protected New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramItem properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Constructor (DiagramItem)

DiagramItem Constructor (DiagramItem)
See Also
[image]

Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramItem (
DiagramItem prototype
)

Visual Basic [image] Copy Code

Protected New ( _
prototype As DiagramItem _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramItem property values from the specified prototype item.

See Also

DiagramItem Constructor Overload List
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem Methods

DiagramItem Methods
[image]

Public Methods

Name | Description
ClearStyleableProperties | Clears the local values of all styleable appearance properties.
Clone | Creates a copy of this item.
ContainsPoint | Overloaded.
Dispose | Overloaded.
Draw | Draws the item on the specified DrawingContext object.
DrawHandles | Renders the selection handles.
GetBounds | Gets the bounding rectangle of this item.
GetRegion | Returns a Geometry object representing the shape of this item.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | Triggers the manipulator located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression.
Repaint | Overloaded.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates.
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AllowCreate | Invoked during interactive creation of items to test whether the operation can be completed in the current context.
AllowModify | Invoked during interactive modification of items to test whether the operation can be completed in the current context.
CompleteCreate | Invoked when the item creation has been completed.
CompleteModify | Invoked when the item modification has been completed.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Draws the associated manipulators in the specified context.
EnumStyleableProperties | Applies specified function on properties intended to be set from WPF styles.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetHeight | Gets the height of this item.
GetTextRect | Subtracts the TextPadding values from the specified rectangle.
GetWidth | Gets the width of this item.
GetX | Gets the x-coordinate of the current position of this item.
GetY | Gets the y-coordinate of the current position of this item.
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or performing undo / redo.
OnChildModified | Called when a group child node has been modified.
OnLoad | Called after successful deserialization.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override.
OnPositioningChanged | Called when the item's position changes.
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override.
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo.
OnRender | UIElement.OnRender override.
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes.
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes.
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes.
OnZoomChanged | Called when the ZoomFactor changes.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
ShouldRender | Determines whether the item should be rendered in the current context.
StartCreate | Invoked once when the user starts creating a new item interactively.
StartModify | Invoked when the user starts modifying this item interactively.
UpdateCreate | Invoked during interactive creation of this item.
UpdateModify | Invoked during interactive modification of this item.

See Also

DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.AllowCreate Method

DiagramItem.AllowCreate Method
[image]

Invoked during interactive creation of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected abstract bool AllowCreate (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Function AllowCreate( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.AllowModify Method

DiagramItem.AllowModify Method
[image]

Invoked during interactive modification of items to test whether the operation can be completed in the current context.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected abstract bool AllowModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected MustOverride Function AllowModify( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this item; otherwise, false.

Remarks

This method is invoked after each mouse movement in order to update the mouse pointer icon, so do not perform any time-consuming operations in its implementation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ClearStyleableProperties Method

DiagramItem.ClearStyleableProperties Method
[image]

Clears the local values of all styleable appearance properties.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ClearStyleableProperties ()

Visual Basic [image] Copy Code

Public Sub ClearStyleableProperties ()

Remarks

Call this method to clear the local values of appearance properties to let them inherit values from a WPF style. Items will have local property values when loaded from a diagram file created by an older version of the control, or when they are initialized with default property values specified in the Diagram instance. You can use the no-args constructor of item types in order to create objects without local values.

This method affects the following properties: StrokeProperty, StrokeMiterLimitProperty, StrokeThicknessProperty, StrokeStartLineCapProperty, StrokeEndLineCapProperty, StrokeLineJoinProperty, StrokeDashStyleProperty, StrokeDashCapProperty, TextPaddingProperty, FontFamilyProperty, FontSizeProperty, FontStyleProperty, FontWeightProperty, FontStretchProperty, BrushProperty, TextDecorationsProperty, TextAlignmentProperty, TextVerticalAlignmentProperty, TextTrimmingProperty, TextWrappingProperty.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Clone Method

DiagramItem.Clone Method
[image]

Creates a copy of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overridable Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

Remarks

The default implementation of this item invokes the item's class copy constructor through reflection. If your custom type does not provide a copy constructor, you must implement this method to provide for clipboard operations support.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.CompleteCreate Method

DiagramItem.CompleteCreate Method
[image]

Invoked when the item creation has been completed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void CompleteCreate (
Point end
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteCreate( _
end As Point _
)

Parameters

end

The mouse pointer position.

Remarks

This method is invoked when the user releases the mouse button while drawing a new item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.CompleteModify Method

DiagramItem.CompleteModify Method
[image]

Invoked when the item modification has been completed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void CompleteModify (
Point end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub CompleteModify( _
end As Point, _
ist As InteractionState _
)

Parameters

end

The mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This method is invoked when the user releases the mouse button while modifying an item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ContainsPoint Method

DiagramItem.ContainsPoint Method
[image]

Overload List

Name | Description
DiagramItem.ContainsPoint (Point) | Determines whether this item contains the specified point.
DiagramItem.ContainsPoint (Point, Double) | Determines whether this item contains the specified point.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ContainsPoint Method (Point)

DiagramItem.ContainsPoint Method (Point)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true it this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing to see if the mouse is inside the item.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ContainsPoint Method (Point, Double)

DiagramItem.ContainsPoint Method (Point, Double)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point, or false otherwise.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
HitTest Method


MindFusion.Diagramming.Wpf.DiagramItem.CreateProperties Method

DiagramItem.CreateProperties Method
[image]

Creates an item property set corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when creating a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.CreateState Method

DiagramItem.CreateState Method
[image]

Creates an item state corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Dispose Method

DiagramItem.Dispose Method
[image]

Overload List

Name | Description
DiagramItem.Dispose () | Disposes the resources managed by this item.
DiagramItem.Dispose (Boolean) | Disposes any disposable resources managed by this item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Dispose Method ()

DiagramItem.Dispose Method ()
See Also
[image]

Disposes the resources managed by this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Dispose Method (Boolean)

DiagramItem.Dispose Method (Boolean)
See Also
[image]

Disposes any disposable resources managed by this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overridable Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

Remarks

This method is used in the implementation of the IDisposable pattern.

See Also

Dispose Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Draw Method

DiagramItem.Draw Method
[image]

Draws the item on the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A DrawingContext object where the item should be rendered.
options

Provides options for the drawing operation.

Remarks

MindFusion.Diagramming for WPF calls this method to draw a representation of the diagram item onto the specified drawing surface. Implement this method in custom node or link types if you need to provide your own drawing functionality.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.DrawHandles Method

DiagramItem.DrawHandles Method
[image]

Renders the selection handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle style
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHandles( _
graphics As DrawingContext, _
style As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

style

The style that should be used to render the handles.

Remarks

This method is invoked when the item's adjustment handles must be rendered.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.DrawManipulators Method

DiagramItem.DrawManipulators Method
[image]

Draws the associated manipulators in the specified context.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void DrawManipulators (
DrawingContext graphics,
bool clip
)

Visual Basic [image] Copy Code

Protected Sub DrawManipulators( _
graphics As DrawingContext, _
clip As Boolean _
)

Parameters

graphics
The DrawingContext surface to draw the manipulators on.
clip
true to render only inside the item's bounds; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.EnumStyleableProperties Method

DiagramItem.EnumStyleableProperties Method
[image]

Applies specified function on properties intended to be set from WPF styles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overridable Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FreeResources Method

DiagramItem.FreeResources Method
[image]

Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void FreeResources ()

Visual Basic [image] Copy Code

Protected Overridable Sub FreeResources ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetBounds Method

DiagramItem.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method. MindFusion.Diagramming for WPF treats the returned value as the logical coordinates of the item and uses it in many situations when comparing items geometrically, when looking for items intersections, and so on.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetHeight Method

DiagramItem.GetHeight Method
[image]

Gets the height of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected double GetHeight ()

Visual Basic [image] Copy Code

Protected Function GetHeight () As Double

Return Value

A double value specifying the height of the item's bounding rectangle.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetRegion Method

DiagramItem.GetRegion Method
[image]

Returns a Geometry object representing the shape of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Geometry GetRegion ()

Visual Basic [image] Copy Code

Public Overridable Function GetRegion () As Geometry

Return Value

An instance of the WPF Geometry class.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetRepaintRect Method

DiagramItem.GetRepaintRect Method
[image]

Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overridable Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this item is modified.

Remarks

This method is invoked when an item is modified by the user, or when an appearance property of the item changes. The returned region is invalidated and redrawn at the next paint operation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetRotatedBounds Method

DiagramItem.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetTextRect Method

DiagramItem.GetTextRect Method
[image]

Subtracts the TextPadding values from the specified rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Rect GetTextRect (
Rect rect
)

Visual Basic [image] Copy Code

Protected Function GetTextRect( _
rect As Rect _
) As Rect

Parameters

rect

Return Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetToolTip Method

DiagramItem.GetToolTip Method
[image]

Gets the tooltip that should be displayed for this item at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Object GetToolTip (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Overridable Function GetToolTip( _
point As Point, _
isDiagramCoordinate As Boolean _
) As Object

Parameters

point

The mouse pointer position.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

Return Value

An object specifying the tooltip contents.

Remarks

You can override this method to return different tooltips for different regions of the item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetWidth Method

DiagramItem.GetWidth Method
[image]

Gets the width of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected double GetWidth ()

Visual Basic [image] Copy Code

Protected Function GetWidth () As Double

Return Value

A double value specifying the width of the item's bounding rectangle.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetX Method

DiagramItem.GetX Method
[image]

Gets the x-coordinate of the current position of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected double GetX ()

Visual Basic [image] Copy Code

Protected Function GetX () As Double

Return Value

A double value specifying the horizontal position of the item's bounding rectangle.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.GetY Method

DiagramItem.GetY Method
[image]

Gets the y-coordinate of the current position of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected double GetY ()

Visual Basic [image] Copy Code

Protected Function GetY () As Double

Return Value

A double value specifying the vertical position of the item's bounding rectangle.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.HitTest Method

DiagramItem.HitTest Method
[image]

Returns the diagram item that contains the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual DiagramItem HitTest (
Point point,
double threshold,
bool onlyNodes,
bool onlyInteractive
)

Visual Basic [image] Copy Code

Public Overridable Function HitTest( _
point As Point, _
threshold As Double, _
onlyNodes As Boolean, _
onlyInteractive As Boolean _
) As DiagramItem

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ContainsPoint Method


MindFusion.Diagramming.Wpf.DiagramItem.HitTestHandle Method

DiagramItem.HitTestHandle Method
[image]

Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

Remarks

Derived item types implement this method by returning instances of NodeAdjustmentHandle, LinkAdjustmentHandle, FreeFormHandle and ShapeAdjustmentHandle classes. You could call it when implementing custom hit-testing for standard types by handling the HitTestAdjustmentHandles event for nodes whose HandlesStyle is set to Custom.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.HitTestManipulators Method

DiagramItem.HitTestManipulators Method
[image]

Triggers the manipulator located at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Manipulator HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Overridable Function HitTestManipulators( _
pt As Point _
) As Manipulator

Parameters

pt

Return Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.LoadFromXml Method

DiagramItem.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in XML format.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.MeasureOverride Method

DiagramItem.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size that the parent element can allocate for the child.

Return Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.NotInteractive Method

DiagramItem.NotInteractive Method
[image]

Gets whether the user is prevented from manipulating this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool NotInteractive ()

Visual Basic [image] Copy Code

Public Overridable Function NotInteractive () As Boolean

Return Value

true to prevent user interaction with this item; otherwise, false.

Remarks

The default implementation prevents manipulation of invisible or locked items.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.NowModifying Method

DiagramItem.NowModifying Method
[image]

Gets a flag indicating whether this object is being currently modified interactively by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NowModifying ()

Visual Basic [image] Copy Code

Public Function NowModifying () As Boolean

Return Value

true is the item is being modified; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Diagram.ModificationEffect Property


MindFusion.Diagramming.Wpf.DiagramItem.OnAdd Method

DiagramItem.OnAdd Method
[image]

Called when the item is added to a Diagram, either by the user, programmatically or performing undo / redo.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAdd ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAdd ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnChildModified Method

DiagramItem.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node

The node that has been modified.

handle

The adjustment handle used to modify the node.

Remarks

Override this method if you need to know when a node from the SubordinateGroup is modified.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnLoad Method

DiagramItem.OnLoad Method
[image]

Called after successful deserialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnLoad ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnLoad ()

Remarks

Override this method if you need to update the state of items after successfully loading a diagram.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnMeasureUnitChanged Method

DiagramItem.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnMouseDown Method

DiagramItem.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnMouseUp Method

DiagramItem.OnMouseUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnPositioningChanged Method

DiagramItem.OnPositioningChanged Method
[image]

Called when the item's position changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPositioningChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnPositioningChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnPreviewMouseDown Method

DiagramItem.OnPreviewMouseDown Method
[image]

UIElement.OnPreviewMouseWheel override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnPreviewMouseUp Method

DiagramItem.OnPreviewMouseUp Method
[image]

UIElement.OnPreviewMouseUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnRemove Method

DiagramItem.OnRemove Method
[image]

Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRemove ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnRender Method

DiagramItem.OnRender Method
[image]

UIElement.OnRender override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

The drawing instructions for a specific element.

Remarks

This method calls Draw.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnSerializablePropertyChanged Method

DiagramItem.OnSerializablePropertyChanged Method
[image]

Invoked when a FrameworkElement property serializable by DiagramItem changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializablePropertyChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializablePropertyChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e
A DependencyPropertyChangedEventArgs instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnSizeChanged Method

DiagramItem.OnSizeChanged Method
[image]

Called when the size of the item changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSizeChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnSizeChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnStrokeAttributeChanged Method

DiagramItem.OnStrokeAttributeChanged Method
[image]

Invoked when any of the item's stroke attributes changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnStrokeAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnStrokeAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnTextAttributeChanged Method

DiagramItem.OnTextAttributeChanged Method
[image]

Invoked when any of the attributes defined in ITextAttributes changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.OnZoomChanged Method

DiagramItem.OnZoomChanged Method
[image]

Called when the ZoomFactor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomChanged ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Query Method

DiagramItem.Query Method
[image]

Returns the items that can be reached from this item by following the path specified in the given query expression.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Query (
string query
)

Visual Basic [image] Copy Code

Public Function Query( _
query As String _
) As DiagramItemCollection

Parameters

query

A query expression consisting of selectors and boolean predicates.

Return Value

A collection of the found items.

Remarks

The query string consists of selectors, where each selector specifies the next items that should be selected starting from the current one.

The following selectors can be applied to a node:

links | Selects all links connected to the current node
inlinks | Selects the incoming links of the current node
outlinks | Selects the outgoing links of the current node
parent | Selects the parent item of the current node if it is in a group
children | Selects the child nodes of the current node if it is in a group

The following selectors can be applied to a link:

nodes | Selects the two nodes connected by the current link
origin | Selects the Origin node of the current link
destination | Selects the Destination node of the current link
children | Selects the child nodes of the current link if it is in a group.

Selectors must be separated by the / character. The results returned by a selector can be also filtered using a predicate expression, enclosed in square brackets after the selector name. The predicate expression can include C# like boolean and arithmetic operators, and one of the following property identifiers:

tag | Returns the value of the Tag property.
text | Returns the value of the Text property.
weight | Returns the value of the Weight property.

Example

The following code selects nodes two levels below the current one in a tree or layered graph.

C# [image] Copy Code

DiagramItemCollection items = diagram.ActiveItem.Query(
"outlinks/destination/outlinks/destination");
diagram.Selection.Clear();
foreach (DiagramItem item in items)
item.Selected = true;

The following code finds the neighbors of the currently selected node that can be reached from it by following links with Weight greater than 3.

C# [image] Copy Code

DiagramItemCollection items = diagram.ActiveItem.Query(
"outlinks[weight>3]/destination");

The following example finds the destination nodes of links labeled "exception" going out of children of the current node's group.

C# [image] Copy Code

DiagramItemCollection items = diagram.ActiveItem.Query(
"children/outlinks[text==\"exception\"]/destination");

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
IncomingLinks Property
OutgoingLinks Property
MasterGroup Property
SubordinateGroup Property


MindFusion.Diagramming.Wpf.DiagramItem.Repaint Method

DiagramItem.Repaint Method
[image]

Overload List

Name | Description
DiagramItem.Repaint () | Repaints the region of the diagram where this item is located.
DiagramItem.Repaint (Boolean) | Repaints the specified region of the diagram.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Repaint Method ()

DiagramItem.Repaint Method ()
See Also
[image]

Repaints the region of the diagram where this item is located.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void Repaint ()

Visual Basic [image] Copy Code

Protected Sub Repaint ()

Remarks

Call this method to repaint the diagram after changing appearance attributes of this item.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Repaint Method (Boolean)

DiagramItem.Repaint Method (Boolean)
See Also
[image]

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void Repaint (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overridable Sub Repaint( _
includeConnected As Boolean _
)

Parameters

includeConnected

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.RestoreProperties Method

DiagramItem.RestoreProperties Method
[image]

Restores the properties of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties -derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when undoing or redoing a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.RestoreState Method

DiagramItem.RestoreState Method
[image]

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.SaveProperties Method

DiagramItem.SaveProperties Method
[image]

Saves the properties of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

Remarks

This method is invoked by the undo/redo subsystem when saving a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.SaveState Method

DiagramItem.SaveState Method
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.SaveToXml Method

DiagramItem.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being serialized into an XML-format diagram file.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.SetDiagramDirty Method

DiagramItem.SetDiagramDirty Method
[image]

Marks the diagram as changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Sub SetDiagramDirty ()

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.SetExpanded Method

DiagramItem.SetExpanded Method
[image]

Sets whether the item is in expanded or collapsed state.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetExpanded( _
e As Boolean _
)

Parameters

e

Specifies the new state of the item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ShouldRender Method

DiagramItem.ShouldRender Method
[image]

Determines whether the item should be rendered in the current context.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool ShouldRender ()

Visual Basic [image] Copy Code

Protected Function ShouldRender () As Boolean

Return Value

true to draw the item; otherwise, false,

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StartCreate Method

DiagramItem.StartCreate Method
[image]

Invoked once when the user starts creating a new item interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void StartCreate (
Point org
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartCreate( _
org As Point _
)

Parameters

org

Position of the mouse pointer.

Remarks

This method is invoked in response to the MouseDown event, just after an item has been instantiated.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.StartModify Method

DiagramItem.StartModify Method
[image]

Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this item.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.TransformDiagramToItem Method

DiagramItem.TransformDiagramToItem Method
[image]

Transforms a point from document coordinates to item coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point TransformDiagramToItem (
Point diagramPoint
)

Visual Basic [image] Copy Code

Public Function TransformDiagramToItem( _
diagramPoint As Point _
) As Point

Parameters

diagramPoint
A System.Windows.Point in the diagram coordinate system.

Return Value

A System.Windows.Point in the item's coordinate system.

Remarks

This method should be used instead of Visual.TransformToDescendant because it works correctly when the item is not yet Arrange() -d.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TransformItemToDiagram Method


MindFusion.Diagramming.Wpf.DiagramItem.TransformItemToDiagram Method

DiagramItem.TransformItemToDiagram Method
[image]

Transforms point from item-relative coordinates to document coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point TransformItemToDiagram (
Point itemPoint
)

Visual Basic [image] Copy Code

Public Function TransformItemToDiagram( _
itemPoint As Point _
) As Point

Parameters

itemPoint
A System.Windows.Point in the item's coordinate system.

Return Value

A System.Windows.Point in the diagram coordinate system.

Remarks

This method does not have effect for links as they are defined in document coordinates.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TransformDiagramToItem Method


MindFusion.Diagramming.Wpf.DiagramItem.UpdateCreate Method

DiagramItem.UpdateCreate Method
[image]

Invoked during interactive creation of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void UpdateCreate (
Point current
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateCreate( _
current As Point _
)

Parameters

current

Position of the mouse pointer.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.UpdateModify Method

DiagramItem.UpdateModify Method
[image]

Invoked during interactive modification of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist
An InteractionState object containing more information about the current state of the operation.

Remarks

This methods is invoked after each mouse movement in order to update the item's state in accordance with the new mouse position.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ZBottom Method

DiagramItem.ZBottom Method
[image]

Moves the item to the bottom of the z-order.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZBottom (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZBottom( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call the method to move the item to the bottom of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZTop Method
ZIndex Property
LayerIndex Property


MindFusion.Diagramming.Wpf.DiagramItem.ZLevelDown Method

DiagramItem.ZLevelDown Method
[image]

Moves the item one level down in the z-order.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZLevelDown (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelDown( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call the method to change the item's position in z-order with one level down.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZLevelUp Method
ZIndex Property
LayerIndex Property


MindFusion.Diagramming.Wpf.DiagramItem.ZLevelUp Method

DiagramItem.ZLevelUp Method
[image]

Moves the item one level up in the z-order.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZLevelUp (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelUp( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call the method to change the item's position in z-order with one level up.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZLevelDown Method
ZIndex Property
LayerIndex Property


MindFusion.Diagramming.Wpf.DiagramItem.ZTop Method

DiagramItem.ZTop Method
[image]

Moves the item to the top of the z-order.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZTop (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZTop( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

true keeps the item in its original layer; false allows moving the item across layers.

Remarks

Call the method to move the item to the top of the z-order.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZBottom Method
ZIndex Property
LayerIndex Property


MindFusion.Diagramming.Wpf.DiagramItem Properties

DiagramItem Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles.
Brush | Gets or sets the brush used to fill the interior of this item.
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
HyperLink | Gets or sets the hyperlink associated with this diagram item.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Printable | Gets or sets a value indicating whether to print the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
Stroke | Gets or sets the Brush that specifies how the item outline is painted.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline.
SubordinateGroup | Gets a reference to the group of items that are attached to this one.
Text | Gets or sets the text displayed inside this item.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the brush used to draw the item's text.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
UIElement | Gets the UIElement associated with this DiagramItem.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.
Size | Gets the size of this item.

See Also

DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Adorner Property

DiagramItem.Adorner Property
[image]

A Visual that contains the item's adjustment handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdornerVisual Adorner { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Adorner As AdornerVisual

Property Value

An instance of the AdornerVisual class.

Remarks

The adjustment handles are rendered in a separate visual so that they do not interfere with the item's geometry during hit-testing.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Brush Property

DiagramItem.Brush Property
[image]

Gets or sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a System.Windows.Media.Brush -derived class.

Remarks

This property refers to a brush with which an item is painted. You can assign to it an instance of one of the following classes: GradientBrush, SolidColorBrush or TileBrush, located in the System.Windows.Media namespace. When applied to links, the property defines how arrowheads interior is painted.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.FontFamily Property

DiagramItem.FontFamily Property
[image]

Gets or sets the preferred font family for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

A FontFamily instance. The default value is "Arial".

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontSize Property
FontStyle Property
FontWeight Property
FontStretch Property


MindFusion.Diagramming.Wpf.DiagramItem.FontSize Property

DiagramItem.FontSize Property
[image]

Gets or sets the font size for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value specifying the font size. The default value is 13.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontStyle Property
FontWeight Property
FontStretch Property


MindFusion.Diagramming.Wpf.DiagramItem.FontStretch Property

DiagramItem.FontStretch Property
[image]

Gets or sets the font-stretching characteristics for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStretch FontStretch { get; set; }

Visual Basic [image] Copy Code

Public Property FontStretch As FontStretch

Property Value

A FontStretch instance. The default value is FontStretches.Normal.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontStyle Property
FontWeight Property
FontSize Property


MindFusion.Diagramming.Wpf.DiagramItem.FontStyle Property

DiagramItem.FontStyle Property
[image]

Gets or sets the font style for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A FontStyle instance. The default value is FontStyles.Normal.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontStretch Property
FontWeight Property
FontSize Property


MindFusion.Diagramming.Wpf.DiagramItem.FontWeight Property

DiagramItem.FontWeight Property
[image]

Gets or sets the font weight for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A FontWeight instance. The default value is FontWeights.Normal.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontStretch Property
FontStyle Property
FontSize Property


MindFusion.Diagramming.Wpf.DiagramItem.HyperLink Property

DiagramItem.HyperLink Property
[image]

Gets or sets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the diagram item.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Id Property

DiagramItem.Id Property
[image]

Gets or sets user-defined identifier associated with this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As Object

Property Value

An instance of any class derived from System.Object.

Remarks

This property contains data that you define and is not used by the control in any way. You can associate with the item any value of a primitive data type, an object from the .NET class library or a custom class. If the id is a primitive value, it is serialized together with the item containing it when saving / loading the diagram. To serialize identifiers from complex types, handle the SerializeTag and DeserializeTag events.

Call FindNodeById or FindLinkById to find diagram items with the specified id. These methods compare identifiers by value using the Equals method.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FindNodeById Method
FindLinkById Method
SerializeTag Event


MindFusion.Diagramming.Wpf.DiagramItem.IgnoreLayout Property

DiagramItem.IgnoreLayout Property
[image]

Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IgnoreLayout { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLayout As Boolean

Property Value

true if the item must stay at its place nevertheless an automatic layout is performed; otherwise, false. The default is false.

Remarks

Enable IgnoreLayout to specify that Arrange method of layout classes should ignore an item. If enabled, the position of an item won't be changed. This property applies to visible nodes. Invisible nodes are always ignored by automatic layout methods.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Locked Property
Visible Property


MindFusion.Diagramming.Wpf.DiagramItem.LayerIndex Property

DiagramItem.LayerIndex Property
[image]

Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int LayerIndex { get; set; }

Visual Basic [image] Copy Code

Public Property LayerIndex As Integer

Property Value

An integer value that specifies the index of the layer.

Remarks

This property specifies the index of a Layer instance within the Layers collection of the Diagram.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZIndex Property


MindFusion.Diagramming.Wpf.DiagramItem.LayoutTraits Property

DiagramItem.LayoutTraits Property
[image]

Contains properties specific to each layout algorithm.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IDictionary LayoutTraits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayoutTraits As IDictionary

Property Value

A hashtable of key-value pairs that define layout-specific properties for this item.

Remarks

This property is used by some automatic layout classes to get attributes pertinent just for a specific layout:

  • SpringLayout looks for values associated with SpringLayoutTraits members.
  • LayeredLayout looks for values associated with LayeredLayoutTraits members.
  • TreeLayout looks for values associated with TreeLayoutTraits members.
  • HierarchicalLayout looks for values associated with HierarchicalLayoutTraits members.
  • FlowLayout looks for values associated with FlowLayoutTraits members.
  • SwimlaneLayout looks for values associated with SwimlaneLayoutTraits members.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Locked Property

DiagramItem.Locked Property
[image]

Gets or sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true to prevent users from editing a diagram element; otherwise, false. The default is false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionaly, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through the Bounds property and the Move / Resize methods. Positions of locked links' control points can be changed programmatically too - through their ControlPoints collections.

Locked items positions can change also when automatic layout algorithms are applied. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Visible Property


MindFusion.Diagramming.Wpf.DiagramItem.MeasureUnit Property

DiagramItem.MeasureUnit Property
[image]

Returns the diagram measure unit.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected GraphicsUnit MeasureUnit { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property MeasureUnit As GraphicsUnit

Property Value

A member of the GraphicsUnit enumeration.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Parent Property

DiagramItem.Parent Property
[image]

Gets the diagram that contains this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new Diagram Parent { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property Parent As Diagram

Property Value

A reference to a Diagram instance.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Printable Property

DiagramItem.Printable Property
[image]

Gets or sets a value indicating whether to print the item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Printable { get; set; }

Visual Basic [image] Copy Code

Public Property Printable As Boolean

Property Value

true to print this item; otherwise, false.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Visible Property


MindFusion.Diagramming.Wpf.DiagramItem.RuntimeIndex Property

DiagramItem.RuntimeIndex Property
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RuntimeIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RuntimeIndex As Integer

Property Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Selected Property

DiagramItem.Selected Property
[image]

Gets or sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Selected { get; set; }

Visual Basic [image] Copy Code

Public Property Selected As Boolean

Property Value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed. Selected items adjustment handles are painted using the style set through the SelectedItemHandlesStyle property. You can specify if users first have to select items in order to modify them with the ModificationStart property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Selection Class
Diagram.Selection Property


MindFusion.Diagramming.Wpf.DiagramItem.Size Property

DiagramItem.Size Property
[image]

Gets the size of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Size Size { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Size As Size

Property Value

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Stroke Property

DiagramItem.Stroke Property
[image]

Gets or sets the Brush that specifies how the item outline is painted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A Brush instance. The default value is Brushes.Black.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
StrokeDashCap
StrokeDashStyle
StrokeEndLineCap
StrokeLineJoin
StrokeMiterLimit
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeDashCap Property

DiagramItem.StrokeDashCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashCap As PenLineCap

Property Value

A member of the PenLineCap enumeration. The default value is PenLineCap.Flat.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashStyle
StrokeEndLineCap
StrokeLineJoin
StrokeMiterLimit
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeDashStyle Property

DiagramItem.StrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

A DashStyle instance. The default value is DashStyles.Solid.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeEndLineCap
StrokeLineJoin
StrokeMiterLimit
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeEndLineCap Property

DiagramItem.StrokeEndLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeEndLineCap As PenLineCap

Property Value

A member of the PenLineCap enumeration. The default value is PenLineCap.Flat.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeDashStyle
StrokeLineJoin
StrokeMiterLimit
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeLineJoin Property

DiagramItem.StrokeLineJoin Property
[image]

Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeLineJoin As PenLineJoin

Property Value

A member of the PenLineJoin enumeration. The default value is PenLineJoin.Miter.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeDashStyle
StrokeEndLineCap
StrokeMiterLimit
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeMiterLimit Property

DiagramItem.StrokeMiterLimit Property
[image]

Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeMiterLimit As Double

Property Value

A double value specifying the limit. The default value is 10.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeDashStyle
StrokeEndLineCap
StrokeLineJoin
StrokeStartLineCap
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeStartLineCap Property

DiagramItem.StrokeStartLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeStartLineCap As PenLineCap

Property Value

A member of the PenLineCap enumeration. The default value is PenLineCap.Flat.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeDashStyle
StrokeEndLineCap
StrokeLineJoin
StrokeMiterLimit
StrokeThickness


MindFusion.Diagramming.Wpf.DiagramItem.StrokeThickness Property

DiagramItem.StrokeThickness Property
[image]

Gets or sets the width of the DiagramItem stroke outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value specifying the thickness. The default value is 1.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Stroke
StrokeDashCap
StrokeDashStyle
StrokeEndLineCap
StrokeLineJoin
StrokeMiterLimit
StrokeStartLineCap


MindFusion.Diagramming.Wpf.DiagramItem.SubordinateGroup Property

DiagramItem.SubordinateGroup Property
[image]

Gets a reference to the group of items that are attached to this one.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group SubordinateGroup { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SubordinateGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the item is not master of a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. SubordinateGroup provides access to the group of items that are attached to this one. If there are no attached items, the property returns null (Nothing in Visual Basic).

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
MasterGroup Property
Factory.CreateGroup Method
Query Method


MindFusion.Diagramming.Wpf.DiagramItem.Text Property

DiagramItem.Text Property
[image]

Gets or sets the text displayed inside this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the item's label.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontSize Property
TextBrush Property
TextAlignment Property
TextPadding Property
ShapeNode.TextLines Property


MindFusion.Diagramming.Wpf.DiagramItem.TextAlignment Property

DiagramItem.TextAlignment Property
[image]

Gets or sets a value that indicates the horizontal alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. The default value is TextAlignment.Left.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TextPadding Property
TextVerticalAlignment Property


MindFusion.Diagramming.Wpf.DiagramItem.TextBrush Property

DiagramItem.TextBrush Property
[image]

Gets or sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is Brushes.Black.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Text Property
TextAlignment Property


MindFusion.Diagramming.Wpf.DiagramItem.TextDecorations Property

DiagramItem.TextDecorations Property
[image]

Gets or sets the effects to apply to the text of this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextDecorationCollection TextDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property TextDecorations As TextDecorationCollection

Property Value

A TextDecorationCollection instance. The default value is null.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
FontFamily Property
FontSize Property


MindFusion.Diagramming.Wpf.DiagramItem.TextPadding Property

DiagramItem.TextPadding Property
[image]

Gets or sets the thickness of padding space between the item boundaries and its text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Property TextPadding As Thickness

Property Value

A Thickness instance. The default thickness is 1 millimeter.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TextAlignment Property


MindFusion.Diagramming.Wpf.DiagramItem.TextTrimming Property

DiagramItem.TextTrimming Property
[image]

Gets or sets the text trimming to employ when text overflows the item area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextTrimming TextTrimming { get; set; }

Visual Basic [image] Copy Code

Public Property TextTrimming As TextTrimming

Property Value

A member of the TextTrimming enumeration. The default value is TextTrimming.None.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TextWrapping Property
TextAlignment Property


MindFusion.Diagramming.Wpf.DiagramItem.TextVerticalAlignment Property

DiagramItem.TextVerticalAlignment Property
[image]

Gets or sets a value that indicates the vertical alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AlignmentY TextVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextVerticalAlignment As AlignmentY

Property Value

A member of the AlignmentY enumeration. The default value is AlignmentY.Top.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TextAlignment Property
TextPadding Property


MindFusion.Diagramming.Wpf.DiagramItem.TextWrapping Property

DiagramItem.TextWrapping Property
[image]

Gets or sets how this DiagramItem should wrap text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextWrapping TextWrapping { get; set; }

Visual Basic [image] Copy Code

Public Property TextWrapping As TextWrapping

Property Value

A member of the TextWrapping enumeration. The default value is TextWrapping.Wrap.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
TextPadding Property
TextAlignment Property
TextTrimming Property


MindFusion.Diagramming.Wpf.DiagramItem.TopLevel Property

DiagramItem.TopLevel Property
[image]

True if this is a top-level item in the diagram, or false if it is inside a container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property TopLevel As Boolean

Property Value

true if this is a top-level item in the diagram; false otherwise.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.UIElement Property

DiagramItem.UIElement Property
[image]

Gets the UIElement associated with this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual UIElement UIElement { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property UIElement As UIElement

Property Value

An instance of the UIElement class.

Remarks

When an object that does not derive from DiagramItem is added to the Items collection of the Diagram, a wrapper DiagramItem is created and its UIElement property returns the non-DiagramItem object. DiagramItem -derived objects return themselves.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.Visible Property

DiagramItem.Visible Property
[image]

Gets or sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

Remarks

Invisible items are not drawn at all. You might use the property to hide or show items temporarily, or to construct complex group hierarchies in which intermediate helper items are invisible.

Invisible nodes are ignored by automatic layout methods. The position of such nodes won't change when the Arrange method of a layout class is called. Visible items can be ignored too by enabling their IgnoreLayout property.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
Printable Property
Locked Property


MindFusion.Diagramming.Wpf.DiagramItem.Weight Property

DiagramItem.Weight Property
[image]

Gets or sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Weight { get; set; }

Visual Basic [image] Copy Code

Public Property Weight As Double

Property Value

A float value specifying the weight of this item. The default value is 1.

Remarks

Currently Weight is used in the implementations of:

  • The SpringLayout class: the weight of a link connecting two nodes is multiplied by the desired NodeDistance to determine the final distance between the nodes.
  • The PathFinder class: an override of the FindShortestPath method uses the Weight values of nodes and/or links to find the path with smallest total weight.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItem.ZIndex Property

DiagramItem.ZIndex Property
[image]

Gets or sets the z-order position of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value specifying the position of the diagram item within the z-order. The default value is -1.

Remarks

Use this property to arrange items in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

If the ZIndex property of newly added items is equal to -1, the control will automatically assign consecutively increasing values to it. If you set ZIndex to a value greater then -1 before adding an item, the control will preserve it.

See Also

DiagramItem Members
DiagramItem Class
MindFusion.Diagramming.Wpf Namespace
ZLevelDown Method
ZBottom Method
ZLevelUp Method
ZTop Method
LayerIndex Property


MindFusion.Diagramming.Wpf.DiagramItemCollection Class

DiagramItemCollection Class
[image]

Represents a strongly typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramItemCollection : ItemCollectionBase<DiagramItem>

Visual Basic [image] Copy Code

Public Class DiagramItemCollection
Inherits ItemCollectionBase(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(DiagramItem)
MindFusion.Diagramming.Wpf.ItemCollectionBase(DiagramItem)
MindFusion.Diagramming.Wpf.DiagramItemCollection

See Also

DiagramItemCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemCollection Members

DiagramItemCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramItem objects.

The following tables list the members exposed by the DiagramItemCollection type.

Public Constructors

Name | Description
DiagramItemCollection | Initializes a new instance of the DiagramItemCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemCollection Constructor

DiagramItemCollection Constructor
[image]

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemCollection Methods

DiagramItemCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemCollection.Add Method

DiagramItemCollection.Add Method
[image]

Adds the specified diagram item to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
UIElement item
)

Visual Basic [image] Copy Code

Public Sub Add( _
item As UIElement _
)

Parameters

item
The DiagramItem object to add to the collection.

Remarks

You can add an arbitrary UIElement object to the diagram, In such a case, MindFusion.Diagramming for WPF automatically creates a DiagramItem wrapper object for the UIElement.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemCollection.Clone Method

DiagramItemCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramItemCollection

Return Value

An instance of the DiagramItemCollection class.

See Also

DiagramItemCollection Members
DiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemProperties Class

DiagramItemProperties Class
[image]

The base class for classes that store diagram item properties during undo / redo operations.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramLinkProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties

See Also

DiagramItemProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemProperties Members

DiagramItemProperties Members
Constructors Methods
[image]

The base class for classes that store diagram item properties during undo / redo operations.

The following tables list the members exposed by the DiagramItemProperties type.

Public Constructors

Name | Description
DiagramItemProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue.

See Also

DiagramItemProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemProperties Constructor

DiagramItemProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemProperties Methods

DiagramItemProperties Methods
[image]

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue.

See Also

DiagramItemProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemProperties.FreeResources Method

DiagramItemProperties.FreeResources Method
[image]

Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void FreeResources ()

Visual Basic [image] Copy Code

Public Overridable Sub FreeResources ()

See Also

DiagramItemProperties Members
DiagramItemProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemState Class

DiagramItemState Class
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemState
MindFusion.Diagramming.Wpf.DiagramLinkState
MindFusion.Diagramming.Wpf.DiagramNodeState

See Also

DiagramItemState Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemState Members

DiagramItemState Members
Constructors
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

The following tables list the members exposed by the DiagramItemState type.

Public Constructors

Name | Description
DiagramItemState |

See Also

DiagramItemState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramItemState Constructor

DiagramItemState Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Class

DiagramLink Class
Remarks See Also
[image]

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramLink : DiagramItem, InplaceEditable, Routable

Visual Basic [image] Copy Code

Public Class DiagramLink
Inherits DiagramItem
Implements InplaceEditable, Routable

Remarks

Links between nodes in MindFusion.Diagramming for WPF diagrams are represented by instances of the DiagramLink class. Links connect at most two nodes, which can be accessed through the Origin and Destination properties. If connected to node anchor points, the point indices can be accessed using the OriginAnchor and DestinationAnchor properties. To control whether users are allowed to move link end points, set AllowMoveStart and AllowMoveEnd.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bézier curves. The type of segments is set through the Shape property. The number of link's segments is specified by the SegmentCount property. Access to control point locations is provided by the ControlPoints collection.

Usually, only the first and last segments of a link are updated if the nodes it connects are moved around. Number, orientation and/or position of link segments can change dynamically in various ways depending on the values of AutoRoute, Dynamic and RetainForm. For links with a Cascading shape, the CascadeOrientation property specifies the orientation of their first segments.

If AutoSnapToNode is enabled, a link automatically aligns its end points to the border of the origin or destination nodes when a user moves the first or last control points. This has a higher priority than aligning to the grid, but a lower priority than aligning to an anchor point.

Links can display distinct arrowhead shapes at their ends. These shapes can be set with the HeadShape and BaseShape properties. The size of the base and arrowhead images is specified by the HeadShapeSize and BaseShapeSize properties. Arrowhead shapes can be displayed in the middle of each segment to facilitate users by distinguishing different links. The type and size of these shapes is set with the IntermediateShape and IntermediateShapeSize properties. The lines of arowhead shapes are painted using the HeadPen pen.

The color of link segments can be specified by the Pen property and the fill color of its base and head shapes with the Brush property. Links can have some text associated with them, displayed as specified by the Text, TextBrush and TextStyle properties. The appearance of link's selection handles can be changed using HandlesStyle.

Bounds and Length are informative properties returning respectively link's location and total length.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramLink

See Also

DiagramLink Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Members

DiagramLink Members
Constructors Fields Properties Methods
[image]

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Overloaded. Initializes a new instance of the DiagramLink class.

Public Fields

Name | Description
BaseShapeProperty | Identifies the BaseShape dependency property.
BaseShapeSizeProperty | Identifies the BaseShapeSize dependency property.
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
HeadShapeProperty | Identifies the HeadShape dependency property.
HeadShapeSizeProperty | Identifies the HeadShapeSize dependency property.
HeadStrokeDashStyleProperty | Identifies the HeadStrokeDashStyle dependency property.
HeadStrokeProperty | Identifies the HeadStroke dependency property.
HeadStrokeThicknessProperty | Identifies the HeadStrokeThickness dependency property.
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
IntermediateShapeProperty | Identifies the IntermediateShape dependency property.
IntermediateShapeSizeProperty | Identifies the IntermediateShapeSize dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link must avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Gets or sets the position of the last control point of this link.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HeadStroke | Gets or sets the Brush that specifies how the arrowhead stroke outline is painted.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowhead shapes.
HeadStrokeThickness | Gets or sets the width of the arrowhead stroke outline.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned relatively to each other.
StartPoint | Gets or sets the position of the first control point of this link.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to the link.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this link.
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the link in the specified DrawingContext.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override.
GetBounds | Overloaded.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetRegion | Returns a Geometry object representing the shape of this item. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
Intersects | Checks whether the link contour intersects with the outline of the specified node.
IsConnectedTo | Checks whether this link is connected to the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
Repaint | Overloaded. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
LoadFromXml | DiagramItem.LoadFromXml override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | DiagramItem.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo. (Inherited from DiagramItem.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes. (Inherited from DiagramItem.)
OnStrokeAttributeChanged | DiagramItem.OnStrokeAttributeChanged override.
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToXml | DiagramItem.SaveToXml override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Fields

DiagramLink Fields
[image]

Public Fields

Name | Description
BaseShapeProperty | Identifies the BaseShape dependency property.
BaseShapeSizeProperty | Identifies the BaseShapeSize dependency property.
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
HeadShapeProperty | Identifies the HeadShape dependency property.
HeadShapeSizeProperty | Identifies the HeadShapeSize dependency property.
HeadStrokeDashStyleProperty | Identifies the HeadStrokeDashStyle dependency property.
HeadStrokeProperty | Identifies the HeadStroke dependency property.
HeadStrokeThicknessProperty | Identifies the HeadStrokeThickness dependency property.
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
IntermediateShapeProperty | Identifies the IntermediateShape dependency property.
IntermediateShapeSizeProperty | Identifies the IntermediateShapeSize dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.BaseShapeProperty Field

DiagramLink.BaseShapeProperty Field
[image]

Identifies the BaseShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BaseShapeProperty

Visual Basic [image] Copy Code

Public Shared BaseShapeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.BaseShapeSizeProperty Field

DiagramLink.BaseShapeSizeProperty Field
[image]

Identifies the BaseShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BaseShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared BaseShapeSizeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadShapeProperty Field

DiagramLink.HeadShapeProperty Field
[image]

Identifies the HeadShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HeadShapeProperty

Visual Basic [image] Copy Code

Public Shared HeadShapeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadShapeSizeProperty Field

DiagramLink.HeadShapeSizeProperty Field
[image]

Identifies the HeadShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HeadShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared HeadShapeSizeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadStrokeDashStyleProperty Field

DiagramLink.HeadStrokeDashStyleProperty Field
[image]

Identifies the HeadStrokeDashStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadStrokeDashStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadStrokeDashStyleProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadStrokeProperty Field

DiagramLink.HeadStrokeProperty Field
[image]

Identifies the HeadStroke dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadStrokeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadStrokeThicknessProperty Field

DiagramLink.HeadStrokeThicknessProperty Field
[image]

Identifies the HeadStrokeThickness dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeadStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeadStrokeThicknessProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.IntermediateShapeProperty Field

DiagramLink.IntermediateShapeProperty Field
[image]

Identifies the IntermediateShape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty IntermediateShapeProperty

Visual Basic [image] Copy Code

Public Shared IntermediateShapeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.IntermediateShapeSizeProperty Field

DiagramLink.IntermediateShapeSizeProperty Field
[image]

Identifies the IntermediateShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty IntermediateShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared IntermediateShapeSizeProperty As DependencyProperty

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor

DiagramLink Constructor
[image]

Initializes a new instance of the DiagramLink class.

Overload List

Name | Description
DiagramLink () | Initializes a new instance of the DiagramLink class.
DiagramLink (Diagram) | Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, Point) | Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.
DiagramLink (Diagram, Point, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, Point, Point) | Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.
DiagramLink (DiagramLink, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

See Also

DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor ()

DiagramLink Constructor ()
See Also
[image]

Initializes a new instance of the DiagramLink class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

For internal use only.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (Diagram)

DiagramLink Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)

DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified nodes with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
origin As DiagramNode, _
destination As DiagramNode _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
origin

The origin node of the new link.

destination

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (Diagram, DiagramNode, Point)

DiagramLink Constructor (Diagram, DiagramNode, Point)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
Point destination
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
origin As DiagramNode, _
destination As Point _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
origin

The origin node of the new link.

destination

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (Diagram, Point, DiagramNode)

DiagramLink Constructor (Diagram, Point, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
Point src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
src As Point, _
dest As DiagramNode _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
src

The origin point of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (Diagram, Point, Point)

DiagramLink Constructor (Diagram, Point, Point)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
Point src,
Point dest
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
src As Point, _
dest As Point _
)

Parameters

parent
The Diagram from which to obtain default values for the link properties.
src

The origin point of the new link.

dest

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)

DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink (
DiagramLink prototype,
DiagramNode src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramLink, _
src As DiagramNode, _
dest As DiagramNode _
)

Parameters

prototype

The link to use as a prototype. The properties of the new link are initialized from the property values of this link.

src

The origin node of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Methods

DiagramLink Methods
[image]

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to the link.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this link.
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the link in the specified DrawingContext.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override.
GetBounds | Overloaded.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetRegion | Returns a Geometry object representing the shape of this item. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
Intersects | Checks whether the link contour intersects with the outline of the specified node.
IsConnectedTo | Checks whether this link is connected to the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
Repaint | Overloaded. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
LoadFromXml | DiagramItem.LoadFromXml override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | DiagramItem.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo. (Inherited from DiagramItem.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes. (Inherited from DiagramItem.)
OnStrokeAttributeChanged | DiagramItem.OnStrokeAttributeChanged override.
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToXml | DiagramItem.SaveToXml override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AddLabel Method

DiagramLink.AddLabel Method
[image]

Adds a label to the link.

Overload List

Name | Description
DiagramLink.AddLabel (LinkLabel) | Adds the specified label to this link.
DiagramLink.AddLabel (String) | Adds a new label to this link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AddLabel Method (LinkLabel)

DiagramLink.AddLabel Method (LinkLabel)
See Also
[image]

Adds the specified label to this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AddLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub AddLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AddLabel Method (String)

DiagramLink.AddLabel Method (String)
See Also
[image]

Adds a new label to this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel AddLabel (
string text
)

Visual Basic [image] Copy Code

Public Function AddLabel( _
text As String _
) As LinkLabel

Parameters

text

The label's text.

Return Value

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AllowCreate Method

DiagramLink.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowCreate (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowCreate( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AllowModify Method

DiagramLink.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowModify( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this link; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Clone Method

DiagramLink.Clone Method
[image]

Creates a copy of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overrides Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard
true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

A new instance of the DiagramLink class.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.CompleteCreate Method

DiagramLink.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
Point end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As Point _
)

Parameters

end

The mouse pointer position.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.CompleteModify Method

DiagramLink.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteModify (
Point end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteModify( _
end As Point, _
ist As InteractionState _
)

Parameters

end

The mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.ContainsPoint Method

DiagramLink.ContainsPoint Method
[image]

Overload List

Name | Description
DiagramLink.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
DiagramLink.ContainsPoint (Point, Double) | DiagramItem.ContainsPoint override.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.ContainsPoint Method (Point)

DiagramLink.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true it this link contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.ContainsPoint Method (Point, Double)

DiagramLink.ContainsPoint Method (Point, Double)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point, or false otherwise.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.CreateProperties Method

DiagramLink.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.CreateState Method

DiagramLink.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

A DiagramLinkState object.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Draw Method

DiagramLink.Draw Method
[image]

Draws the link in the specified DrawingContext.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A DrawingContext object where the link should be rendered.
options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.DrawArrowhead Method

DiagramLink.DrawArrowhead Method
[image]

Draws an arrowhead shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawArrowhead (
DrawingContext drawingContext,
Pen pen,
Brush brush,
Shape shape,
Point pivot,
Point position,
Point segmentStart,
double size
)

Visual Basic [image] Copy Code

Public Shared Sub DrawArrowhead( _
drawingContext As DrawingContext, _
pen As Pen, _
brush As Brush, _
shape As Shape, _
pivot As Point, _
position As Point, _
segmentStart As Point, _
size As Double _
)

Parameters

drawingContext
The DrawingContext surface to draw the shape on.
pen
A Pen instance used to draw the shape outline.
brush
A Brush instance used to fill the shape.
shape
A Shape instance that defines the arrowhead geometry.
pivot
A Point specified in percents that corresponds to the arrowhead tip position within the Shape geometry.
position

A point on the drawing surface where the arrowhead tip should be located.

segmentStart

A point specifying the arrowhead direction.

size

A double value that specifies the arrowhead size.

Remarks

This method lets you draw any Shape object at arbitrary position and angle, and is useful for rendering arrowhead shapes when custom-drawing links.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
CustomDraw Property
DiagramBase.DrawLink Event


MindFusion.Diagramming.Wpf.DiagramLink.DrawHandles Method

DiagramLink.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.EnumStyleableProperties Method

DiagramLink.EnumStyleableProperties Method
[image]

DiagramItem.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetBounds Method

DiagramLink.GetBounds Method
[image]

Overload List

Name | Description
DiagramLink.GetBounds () | DiagramItem.GetBounds override.
DiagramLink.GetBounds (Boolean) | Gets the bounding rectangle of this link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetBounds Method ()

DiagramLink.GetBounds Method ()
See Also
[image]

DiagramItem.GetBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

A System.Windows.Rect instance that specifies the bounds of the link.

See Also

GetBounds Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetBounds Method (Boolean)

DiagramLink.GetBounds Method (Boolean)
See Also
[image]

Gets the bounding rectangle of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetBounds (
bool withStrokeThickness
)

Visual Basic [image] Copy Code

Public Function GetBounds( _
withStrokeThickness As Boolean _
) As Rect

Parameters

withStrokeThickness

true to add stroke thickness to the rectangle, or false otherwise.

Return Value

The rectangle that bounds this link.

See Also

GetBounds Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetLongestHSegment Method

DiagramLink.GetLongestHSegment Method
[image]

Returns the index of the longest horizontal segment of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetLongestHSegment ()

Visual Basic [image] Copy Code

Public Function GetLongestHSegment () As Integer

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetRepaintRect Method

DiagramLink.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true to include the items from the SubordinateGroup; otherwise, false.

Return Value

A System.Windows.Rect instance specifying the region that should be repainted.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.GetRotatedBounds Method

DiagramLink.GetRotatedBounds Method
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A System.Windows.Rect instance that specifies the bounds of the link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HitTestHandle Method

DiagramLink.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

An instance of LinkAdjustmentHandle class if there is a control point at the specified location, or null otherwise.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Intersects Method

DiagramLink.Intersects Method
[image]

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Shadows Function Intersects( _
node As DiagramNode _
) As Boolean

Parameters

node
A DiagramNode object for which to determine whether the link intersects it.

Return Value

true if the link intersects the node; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.IsConnectedTo Method

DiagramLink.IsConnectedTo Method
[image]

Checks whether this link is connected to the specified node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsConnectedTo (
DiagramNode n
)

Visual Basic [image] Copy Code

Public Function IsConnectedTo( _
n As DiagramNode _
) As Boolean

Parameters

n

Return Value

true if node is either the link's Origin or Destination; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.LabelFromPoint Method

DiagramLink.LabelFromPoint Method
[image]

Returns the label whose layout rectangle contains the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel LabelFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function LabelFromPoint( _
point As Point _
) As LinkLabel

Parameters

point

A Point instance.

Return Value

The LinkLabel that contains the specified point.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.LoadFromXml Method

DiagramLink.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.MeasureOverride Method

DiagramLink.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize
The available size that the parent element can allocate for the child.

Return Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OnAdd Method

DiagramLink.OnAdd Method
[image]

DiagramItem.OnAdd override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OnLoad Method

DiagramLink.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OnMeasureUnitChanged Method

DiagramLink.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OnStrokeAttributeChanged Method

DiagramLink.OnStrokeAttributeChanged Method
[image]

DiagramItem.OnStrokeAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnStrokeAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnStrokeAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OnTextAttributeChanged Method

DiagramLink.OnTextAttributeChanged Method
[image]

DiagramItem.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.ReassignAnchorPoints Method

DiagramLink.ReassignAnchorPoints Method
[image]

Attaches the link end points to the anchor points defined for the link's origin and destination nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.RemoveLabel Method

DiagramLink.RemoveLabel Method
[image]

Removes the specified label from this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RemoveLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RemoveLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.RestoreProperties Method

DiagramLink.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.RestoreState Method

DiagramLink.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Route Method

DiagramLink.Route Method
[image]

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Route ()

Visual Basic [image] Copy Code

Public Function Route () As Boolean

Return Value

true is a route has been successfully found; otherwise, false.

Remarks

Routing may fail if there is a large background node whose Obstacle property is enabled, or if the value of RoutingOptions.GridSize is too big for the average distance between adjacent nodes in the diagram.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.SaveProperties Method

DiagramLink.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.SaveState Method

DiagramLink.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.SaveToXml Method

DiagramLink.SaveToXml Method
[image]

DiagramItem.SaveToXml override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the link's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.StartCreate Method

DiagramLink.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartCreate (
Point org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As Point _
)

Parameters

org

Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.StartModify Method

DiagramLink.StartModify Method
[image]

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this link.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.UpdateCreate Method

DiagramLink.UpdateCreate Method
[image]

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
Point current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As Point _
)

Parameters

current

Position of the mouse pointer.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.UpdateFromPoints Method

DiagramLink.UpdateFromPoints Method
[image]

Updates the link's internal state after the link's control points have been changed.

Overload List

Name | Description
DiagramLink.UpdateFromPoints () | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean) | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.UpdateFromPoints Method ()

DiagramLink.UpdateFromPoints Method ()
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.UpdateFromPoints Method (Boolean)

DiagramLink.UpdateFromPoints Method (Boolean)
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateFromPoints (
bool updateGroups
)

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints( _
updateGroups As Boolean _
)

Parameters

updateGroups
true to update the positions of nodes attached to the link; otherwise, false.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.UpdateModify Method

DiagramLink.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink Properties

DiagramLink Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Gets or sets a value indicating whether a link must avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints | Gets a collection of the control points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Gets or sets the position of the last control point of this link.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HeadStroke | Gets or sets the Brush that specifies how the arrowhead stroke outline is painted.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowhead shapes.
HeadStrokeThickness | Gets or sets the width of the arrowhead stroke outline.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned relatively to each other.
StartPoint | Gets or sets the position of the first control point of this link.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.AllowMoveEnd Property

DiagramLink.AllowMoveEnd Property
[image]

Gets or sets a value indicating whether the user is allowed to move the end point of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowMoveEnd { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveEnd As Boolean

Property Value

true to enable users to move the end point of the link; otherwise, false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link destination to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
AllowMoveStart Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.Wpf.DiagramLink.AllowMoveStart Property

DiagramLink.AllowMoveStart Property
[image]

Gets or sets a value indicating whether the user is allowed to move the first control point of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowMoveStart { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveStart As Boolean

Property Value

true to enable users to move the start point of the link; otherwise false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link origin to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
AllowMoveEnd Property
Diagram.LinkEndsMovable Property


MindFusion.Diagramming.Wpf.DiagramLink.AutoRoute Property

DiagramLink.AutoRoute Property
[image]

Gets or sets a value indicating whether a link must avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to route this link; otherwise, false. Initialized with the value of RouteLinks.

Remarks

If AutoRoute is enabled, a link automatically finds the shortest possible path between its origin and destination that doesn't intersect Obstacle nodes. The number and orientation of the link's segments are updated when the nodes it links are moved around. The positions of end points of a routed link are not changed, unless the link is also set to Dynamic.

It is best to use AutoRoute with links of the Cascading style. Note that automatic routing overrides the RetainForm behavior.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
RoutingOptions Class
Dynamic Property
SegmentCount Property


MindFusion.Diagramming.Wpf.DiagramLink.AutoSnapToNode Property

DiagramLink.AutoSnapToNode Property
[image]

Specifies whether a link end point should automatically snap to the nearest diagram node while the user moves the point's adjustment handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoSnapToNode { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapToNode As Boolean

Property Value

true to snap links to nearest node; otherwise, false. Initialized with the value of AutoSnapLinks.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop. If there is an AnchorPattern assigned to a node, the link snaps to an anchor point instead of a border point.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Dynamic Property
RetainForm Property


MindFusion.Diagramming.Wpf.DiagramLink.BaseShape Property

DiagramLink.BaseShape Property
[image]

Gets or sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape BaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkBaseShape.

Remarks

The property specifies the shape that is displayed at the beginning of a link, at the point where the link connects to its Origin node. This shape is rotated simultaneously with the first segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
HeadShape Property
IntermediateShape Property
BaseShapeSize Property


MindFusion.Diagramming.Wpf.DiagramLink.BaseShapeSize Property

DiagramLink.BaseShapeSize Property
[image]

Gets or sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double BaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShapeSize As Double

Property Value

A double value that specifies the shape size. Initialized with the value of LinkBaseShapeSize.

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
BaseShape Property


MindFusion.Diagramming.Wpf.DiagramLink.Bounds Property

DiagramLink.Bounds Property
[image]

Gets the size of the rectangle that bounds this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A System.Windows.Rect instance that represents the bounding rectangle.

Remarks

Use the property to get the smallest rectangle that bounds all link points.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.CascadeOrientation Property

DiagramLink.CascadeOrientation Property
[image]

Gets or sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property CascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Use this property to specify the orientation of the first segment of a link whose Shape is set to Cascading. See Orientation for more details. The orientation of the first segment defines the orientation of all other segments in the cascade, because each next segment changes its orientation alternately to the previous one.

If the property is set to Auto, users may change the orientation of a cascading link interactively. That can be done by dragging the control point next to the first or last one to its opposite corner in the rectangle defined by its two adjacent segments. Depending on the value of AllowSplitLinks, the link orientation is changed by either inserting a new segment and changing only the orientation of the first or last segment (AllowSplitLinks is true), or by changing the orientation of all segments of the link (AllowSplitLinks is false).

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Diagram.LinkCascadeOrientation Property
Shape Property


MindFusion.Diagramming.Wpf.DiagramLink.ControlPoints Property

DiagramLink.ControlPoints Property
[image]

Gets a collection of the control points of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection ControlPoints { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ControlPoints As PointCollection

Property Value

A collection of control points that specify the link's shape.

Remarks

You can specify new positions of a link's points by using this property. The number of points in the collection depends on the Shape and SegmentCount of the link. Links made of Bézier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. Check the Count property of the collection to get the number of points. After setting new positions of control points you must call the UpdateFromPoints method.

Example

The following example demonstrates how to programatically setup the control points of a link:

C# [image] Copy Code

DiagramLink link;
Point cpt;

link = diagram.Links[0];

// Move the second and the third points
cpt = link.ControlPoints[1];
link.ControlPoints[1] = new Point(cpt.X + 5, cpt.Y);
link.ControlPoints[2] = new Point(22.2, 33.3);

// Update state and redraw
link.UpdateFromPoints();

Visual Basic [image] Copy Code

Dim link As DiagramLink
Dim cpt As Point

link = diagram.Links(0)

' Move the second and the third points
cpt = link.ControlPoints(1)
link.ControlPoints(1) = New Point(cpt.X + 5, cpt.Y)
link.ControlPoints(2) = New Point(22.2, 33.3)

' Update state and redraw
link.UpdateFromPoints()

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
UpdateFromPoints Method


MindFusion.Diagramming.Wpf.DiagramLink.CustomDraw Property

DiagramLink.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of LinkCustomDraw.

Remarks

This property allows invoking custom painting code for a link. That code must execute in response to the DrawLink event. There are several modes of custom painting, allowing the custom code to paint the link entirely, or do that in addition to what MindFusion.Diagramming for WPF paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for WPF.
Additional | The custom painting code executes after the link segments and arrowhead shapes are painted by MindFusion.Diagramming for WPF, but before text is rendered.
Full | The component does not do any standard drawing, the entire painting of the link is done by the application.
ShadowOnly | Only the shadow of the link is painted by custom code, the link itself is drawn by the component.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Destination Property

DiagramLink.Destination Property
[image]

Gets or sets the destination node of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; set; }

Visual Basic [image] Copy Code

Public Property Destination As DiagramNode

Property Value

A reference to the destination DiagramNode of the link.

Remarks

The link's destination can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Origin Property
DestinationAnchor Property
Query Method


MindFusion.Diagramming.Wpf.DiagramLink.DestinationAnchor Property

DiagramLink.DestinationAnchor Property
[image]

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int DestinationAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationAnchor As Integer

Property Value

An integer index of an anchor point within the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Destination anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
OriginAnchor Property
DiagramBase.DestinationAnchorChanged Event


MindFusion.Diagramming.Wpf.DiagramLink.DestinationConnection Property

DiagramLink.DestinationConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ConnectionPoint DestinationConnection { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationConnection As ConnectionPoint

Property Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.DestinationIndex Property

DiagramLink.DestinationIndex Property
[image]

Gets or sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int DestinationIndex { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationIndex As Integer

Property Value

An integer value specifying the index of table's row or the index of an anchor point within its containing AnchorPattern.

Remarks

If a link's destination is a shape node, with this property you can get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the destination node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
OriginIndex Property


MindFusion.Diagramming.Wpf.DiagramLink.DrawCrossings Property

DiagramLink.DrawCrossings Property
[image]

Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool DrawCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property DrawCrossings As Boolean

Property Value

true if crossing points should be drawn as arcs or dashes; otherwise, false. The default is true.

Remarks

The LinkCrossings property of the Diagram class specifies what shapes are drawn at link crossing points. Individual links cannot display shapes different from the ones drawn for other links, but the crossing points shapes can be shown or hidden for a link through this property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Dynamic Property

DiagramLink.Dynamic Property
[image]

Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Dynamic { get; set; }

Visual Basic [image] Copy Code

Public Property Dynamic As Boolean

Property Value

true to make the link automatically adjust its end points; otherwise, false. Initialized with the value of DynamicLinks.

Remarks

Use the property to specify whether a link automatically repositions its end segments, so they keep pointing to the centers of nodes connected by that link. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them. End points are realigned also when moving the points next to them.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
RetainForm Property


MindFusion.Diagramming.Wpf.DiagramLink.EndPoint Property

DiagramLink.EndPoint Property
[image]

Gets or sets the position of the last control point of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point EndPoint { get; set; }

Visual Basic [image] Copy Code

Public Property EndPoint As Point

Property Value

A System.Windows.Point instance specifying the position of the link's last control point.

Remarks

This property implements a shortcut to getting or setting the last member of ControlPoints.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HandlesStyle Property

DiagramLink.HandlesStyle Property
[image]

Gets or sets the appearance of the link's selection handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. Initialized with the value of LinkHandlesStyle.

Remarks

Specifies how link's selection status is indicated visually. You can choose between the following styles:

Member name | Description
SquareHandles | The selection is indicated by drawing square handles at the position of each control point.
DashFrame | The selection is indicated by drawing dashed line segments along the link's segments. In addition, there are square selection handles drawn at the location of each control point of the link.
Custom | MindFusion.Diagramming for WPF raises the DrawAdjustmentHandles event to let your application perform custom drawing of link's selection handles.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadPen Property

DiagramLink.HeadPen Property
[image]

Gets or sets the pen to use when painting arrowheads lines.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen HeadPen { get; set; }

Visual Basic [image] Copy Code

Public Property HeadPen As Pen

Property Value

An instance of the Pen class. Initialized with a clone of LinkPen.

Remarks

This property refers to a pen used to paint arrowhead lines. To change how segment lines are painted, use the Pen property.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Brush Property


MindFusion.Diagramming.Wpf.DiagramLink.HeadShape Property

DiagramLink.HeadShape Property
[image]

Gets or sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape HeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkHeadShape.

Remarks

The property specifies what shape is displayed as an arrowhead. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
BaseShape Property
IntermediateShape Property
HeadShapeSize Property


MindFusion.Diagramming.Wpf.DiagramLink.HeadShapeSize Property

DiagramLink.HeadShapeSize Property
[image]

Gets or sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShapeSize As Double

Property Value

A double value that measures the size. Initialized with the value of LinkHeadShapeSize.

Remarks

The property specifies how big the shape of the arrowhead is.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
HeadShape Property


MindFusion.Diagramming.Wpf.DiagramLink.HeadStroke Property

DiagramLink.HeadStroke Property
[image]

Gets or sets the Brush that specifies how the arrowhead stroke outline is painted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush HeadStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStroke As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadStrokeDashStyle Property

DiagramLink.HeadStrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline arrowhead shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DashStyle HeadStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeDashStyle As DashStyle

Property Value

A System.Windows.Media.DashStyle instance. The default value is DashStyles.Solid.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.HeadStrokeThickness Property

DiagramLink.HeadStrokeThickness Property
[image]

Gets or sets the width of the arrowhead stroke outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HeadStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeThickness As Double

Property Value

A double value.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.IntermediateShape Property

DiagramLink.IntermediateShape Property
[image]

Gets or sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape IntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkIntermediateShape.

Remarks

The property specifies what shape to display at the middle of each segment of a link. This could help users to see more easily the direction of long links.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
HeadShape Property
BaseShape Property
IntermediateShapeSize Property


MindFusion.Diagramming.Wpf.DiagramLink.IntermediateShapeSize Property

DiagramLink.IntermediateShapeSize Property
[image]

Gets or sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double IntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShapeSize As Double

Property Value

A double value that measures the size. Initialized with the value of LinkIntermediateShapeSize.

Remarks

The property specifies how big are the shapes that are displayed in the middle of link segments.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
IntermediateShape Property


MindFusion.Diagramming.Wpf.DiagramLink.IsConnected Property

DiagramLink.IsConnected Property
[image]

Gets a value indicating whether the link is connected to nodes at both its ends.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsConnected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsConnected As Boolean

Property Value

true to indicate that both ends of the link are connected to nodes; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Labels Property

DiagramLink.Labels Property
[image]

Returns the list of all labels displayed by this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public List<LinkLabel> Labels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Labels As List(Of LinkLabel)

Property Value

A list of LinkLabel objects.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Length Property

DiagramLink.Length Property
[image]

Gets the length of the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Double

Property Value

A float value that represents the total length of the link, sum of the lengths of all its segments.

Remarks

If the link's Shape is set to Bezier, an approximate length is calculated. In that case, the approximate value is almost always slightly smaller than the real length of Bézier segments.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Shape Property
SegmentCount Property


MindFusion.Diagramming.Wpf.DiagramLink.Origin Property

DiagramLink.Origin Property
[image]

Gets or sets the origin node of the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; set; }

Visual Basic [image] Copy Code

Public Property Origin As DiagramNode

Property Value

A reference to the origin DiagramNode of the link.

Remarks

The link's origin can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Destination Property
OriginAnchor Property
Query Method


MindFusion.Diagramming.Wpf.DiagramLink.OriginAnchor Property

DiagramLink.OriginAnchor Property
[image]

Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int OriginAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property OriginAnchor As Integer

Property Value

An integer index of an anchor point within its the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Origin anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
DestinationAnchor Property
DiagramBase.OriginAnchorChanged Event


MindFusion.Diagramming.Wpf.DiagramLink.OriginConnection Property

DiagramLink.OriginConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ConnectionPoint OriginConnection { get; set; }

Visual Basic [image] Copy Code

Public Property OriginConnection As ConnectionPoint

Property Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.OriginIndex Property

DiagramLink.OriginIndex Property
[image]

Gets or sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int OriginIndex { get; set; }

Visual Basic [image] Copy Code

Public Property OriginIndex As Integer

Property Value

An integer value specifying the index of table's row or index of an anchor point within its containing AnchorPattern.

Remarks

If a link's origin is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the origin node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
DestinationIndex Property


MindFusion.Diagramming.Wpf.DiagramLink.RetainForm Property

DiagramLink.RetainForm Property
[image]

Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property RetainForm As Boolean

Property Value

true to retain the form of this link; otherwise, false. Initialized with the value of LinksRetainForm.

Remarks

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
AutoRoute Property
Dynamic Property


MindFusion.Diagramming.Wpf.DiagramLink.SegmentCount Property

DiagramLink.SegmentCount Property
[image]

Gets or sets the number of segments of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int SegmentCount { get; set; }

Visual Basic [image] Copy Code

Public Property SegmentCount As Integer

Property Value

An integer value specifying how many segments the link consists of. Initialized with the value of LinkSegments.

Remarks

Use this property to make a link more indented when necessary. Its value, together with Shape, specifies the number of points in the link's ControlPoints collection. You can let users insert new link segments interactively by setting AllowSplitLinks to true.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
ControlPoints Property
Length Property


MindFusion.Diagramming.Wpf.DiagramLink.Shape Property

DiagramLink.Shape Property
[image]

Gets or sets the type of link segments and how they are positioned relatively to each other.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As LinkShape

Property Value

A member of the LinkShape enumeration. Initialized with the value of LinkShape.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading style. Use the SegmentCount property to set the number of segments of the link.

The orientation of the first segment of a cascading link depends on the value of CascadeOrientation. If that property is set to Auto, users may change the cascade orientation interactively.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
ControlPoints Property
AutoRoute Property


MindFusion.Diagramming.Wpf.DiagramLink.StartPoint Property

DiagramLink.StartPoint Property
[image]

Gets or sets the position of the first control point of this link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As Point

Property Value

A System.Windows.Point instance specifying the position of the link's first control point.

Remarks

This property implements a shortcut to getting or setting the first member of ControlPoints.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.TextStyle Property

DiagramLink.TextStyle Property
[image]

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkTextStyle TextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. Initialized with the value of LinkTextStyle.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace
Text Property
TextBrush Property


MindFusion.Diagramming.Wpf.DiagramLink.TopLevel Property

DiagramLink.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLink.Visible Property

DiagramLink.Visible Property
[image]

DiagramItem.Visible override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the link is visible; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkCollection Class

DiagramLinkCollection Class
[image]

Represents a strongly typed collection of DiagramLink objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramLinkCollection : ItemCollectionBase<DiagramLink>

Visual Basic [image] Copy Code

Public Class DiagramLinkCollection
Inherits ItemCollectionBase(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(DiagramLink)
MindFusion.Diagramming.Wpf.ItemCollectionBase(DiagramLink)
MindFusion.Diagramming.Wpf.DiagramLinkCollection

See Also

DiagramLinkCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkCollection Members

DiagramLinkCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of DiagramLink objects.

The following tables list the members exposed by the DiagramLinkCollection type.

Public Constructors

Name | Description
DiagramLinkCollection | Initializes a new instance of the DiagramLinkCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkCollection Constructor

DiagramLinkCollection Constructor
[image]

Initializes a new instance of the DiagramLinkCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkCollection Methods

DiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkCollection.Clone Method

DiagramLinkCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramLinkCollection

Return Value

An instance of the DiagramLinkCollection class.

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkProperties Class

DiagramLinkProperties Class
[image]

Stores the values of DiagramLink properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the DiagramLink.SaveProperties, DiagramLink.RestoreProperties, and DiagramLink.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramLinkProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramLinkProperties
Inherits DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramLinkProperties

See Also

DiagramLinkProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkProperties Members

DiagramLinkProperties Members
Constructors Methods
[image]

Stores the values of DiagramLink properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the DiagramLink.SaveProperties, DiagramLink.RestoreProperties, and DiagramLink.CreateProperties methods.

The following tables list the members exposed by the DiagramLinkProperties type.

Public Constructors

Name | Description
DiagramLinkProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

DiagramLinkProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkProperties Constructor

DiagramLinkProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkState Class

DiagramLinkState Class
[image]

Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the DiagramLink.CreateState, DiagramLink.SaveState and DiagramLink.RestoreState methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramLinkState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramLinkState
Inherits DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemState
MindFusion.Diagramming.Wpf.DiagramLinkState

See Also

DiagramLinkState Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkState Members

DiagramLinkState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramLink. Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the DiagramLink.CreateState, DiagramLink.SaveState and DiagramLink.RestoreState methods.

The following tables list the members exposed by the DiagramLinkState type.

Public Constructors

Name | Description
DiagramLinkState |

See Also

DiagramLinkState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramLinkState Constructor

DiagramLinkState Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Class

DiagramNode Class
Remarks See Also
[image]

Represents a diagram node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class DiagramNode : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class DiagramNode
Inherits DiagramItem

Remarks

DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on. DiagramNode is an abstract class and cannot be used directly. Instead, create objects from derived specific classes such as ShapeNode and TableNode. You can also create your own node class by deriving from DiagramNode or its descendants.

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method.

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former specifies constraints on move direction and node size. The latter enables or disables specific manipulation handles of a node.

Relations between nodes are indicated by connecting the nodes with DiagramLink instances. Links are considered directed graph edges, so each node has two collections referring to links: IncomingLinks and OutgoingLinks. AnchorPattern defines to which points of a node incoming or outgoing links can be connected. The AllowIncomingLinks property specifies whether incoming links can be drawn to a node. The AllowOutgoingLinks property enables drawing of outgoing links.

A user is allowed to expand or collapse the tree starting from a node if Expandable is set to true. The Expanded property gets or sets whether the subtree starting from a node is expanded or not.

Nodes can be attached to other items, and be used as simple labels, image-holders or other kinds of UI elements. The AttachTo method creates a Group instance if necessary, and calls the group's appropriate AttachTo* method.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.BarcodeNode
MindFusion.Diagramming.Wpf.ContainerNode
MindFusion.Diagramming.Wpf.DiagramNodeAdapter
MindFusion.Diagramming.Wpf.DummyNode
MindFusion.Diagramming.Wpf.FreeFormNode
MindFusion.Diagramming.Wpf.ShapeNode
MindFusion.Diagramming.Wpf.TableNode
MindFusion.Diagramming.Wpf.TemplatedNode
MindFusion.Diagramming.Wpf.TreeViewNode
MindFusion.Diagramming.Wpf.VisioNode

See Also

DiagramNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Members

DiagramNode Members
Constructors Fields Properties Methods
[image]

Represents a diagram node.

The following tables list the members exposed by the DiagramNode type.

Protected Constructors

Name | Description
DiagramNode | Overloaded. Initializes a new instance of the DiagramNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property.
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property.
EnabledHandlesProperty | Identifies the EnabledHandles property.
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachTo | Overloaded. Attaches this node to another diagram item.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawAnchorPoints | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Draws this node on the specified DrawingContext graphics surface.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllIncomingLinks | Overloaded.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Overloaded.
GetBounds | Gets the bounding rectangle of this item.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetRegion | DiagramItem.GetRegion override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Repaint | DiagramItem.Repaint override.
Resize | Resizes the node.
SetBounds | Sets the location and size of this node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetRect | This method is used internally by the Ruler control to align nodes.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFromXml | DiagramItem.LoadFromXml override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to the Diagram.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToXml | DiagramItem.SaveToXml override.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Fields

DiagramNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property.
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property.
EnabledHandlesProperty | Identifies the EnabledHandles property.
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.BoundsProperty Field

DiagramNode.BoundsProperty Field
[image]

Identifies the Bounds dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BoundsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BoundsProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.EffectsSourceProperty Field

DiagramNode.EffectsSourceProperty Field
[image]

Identifies the EffectsSource dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EffectsSourceProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.EnabledHandlesProperty Field

DiagramNode.EnabledHandlesProperty Field
[image]

Identifies the EnabledHandles property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnabledHandlesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnabledHandlesProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.RotationAngleProperty Field

DiagramNode.RotationAngleProperty Field
[image]

Identifies the RotationAngle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty RotationAngleProperty

Visual Basic [image] Copy Code

Public Shared RotationAngleProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.TemplateProperty Field

DiagramNode.TemplateProperty Field
[image]

Identifies the Template dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TemplateProperty

Visual Basic [image] Copy Code

Public Shared TemplateProperty As DependencyProperty

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Constructor

DiagramNode Constructor
[image]

Initializes a new instance of the DiagramNode class.

Overload List

Name | Description
DiagramNode () | Initializes a new instance of the DiagramNode class.
DiagramNode (Diagram) | Initializes a new instance of the DiagramNode class with the default values set in the specified Diagram.
DiagramNode (DiagramNode) | Initializes a new instance of the DiagramNode class using the specified node as a prototype.

See Also

DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Constructor ()

DiagramNode Constructor ()
See Also
[image]

Initializes a new instance of the DiagramNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramNode ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramNode properties to their default values.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Constructor (Diagram)

DiagramNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramNode class with the default values set in the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramNode (
Diagram parent
)

Visual Basic [image] Copy Code

Protected New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramNode properties with the values specified in the respective default-value properties of the Diagram object. For more information see Initial Values of Item Properties.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Constructor (DiagramNode)

DiagramNode Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramNode (
DiagramNode prototype
)

Visual Basic [image] Copy Code

Protected New ( _
prototype As DiagramNode _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Methods

DiagramNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AttachTo | Overloaded. Attaches this node to another diagram item.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawAnchorPoints | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Draws this node on the specified DrawingContext graphics surface.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllIncomingLinks | Overloaded.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Overloaded.
GetBounds | Gets the bounding rectangle of this item.
GetCenter | Gets the center of this node's bounding rectangle.
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetRegion | DiagramItem.GetRegion override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded.
GetRotationAngle | Gets the rotation angle of this node.
GetToolTip | DiagramItem.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed.
ReassignUnanchoredLinks | Reassigns unanchored links
Repaint | DiagramItem.Repaint override.
Resize | Resizes the node.
SetBounds | Sets the location and size of this node.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
SetRect | This method is used internally by the Ruler control to align nodes.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy.
LoadFromXml | DiagramItem.LoadFromXml override.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to the Diagram.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToXml | DiagramItem.SaveToXml override.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points.
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.
UpdateModify | DiagramItem.UpdateModify override.

See Also

DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.AcceptLinks Method

DiagramNode.AcceptLinks Method
[image]

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool AcceptLinks (
bool outgoing,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Function AcceptLinks( _
outgoing As Boolean, _
mousePosition As Point _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.
mousePosition
The current mouse pointer position in diagram coordinates.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
OutgoingLinks Property
AllowOutgoingLinks Property
IncomingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.Wpf.DiagramNode.AllowCreate Method

DiagramNode.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowCreate (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowCreate( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.AllowModify Method

DiagramNode.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowModify( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ArrangeOverride Method

DiagramNode.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.AttachTo Method

DiagramNode.AttachTo Method
[image]

Attaches this node to another diagram item.

Overload List

Name | Description
DiagramNode.AttachTo (DiagramLink, AttachToLink, Int32) | Attaches this node to a point or a segment of the specified link.
DiagramNode.AttachTo (DiagramNode, AttachToNode) | Attaches this node to a corner or a middle point of the specified node's bounding rectangle.
DiagramNode.AttachTo (DiagramNode, Double, Double, Double, Double) | Attaches this node to the specified node in such a way that the ratio between their sizes is kept constant.
DiagramNode.AttachTo (DiagramNode, GroupAnchorStyles) | Attaches this node to one or more edges of the specified node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)

DiagramNode.AttachTo Method (DiagramLink, AttachToLink, Int32)
See Also
[image]

Attaches this node to a point or a segment of the specified link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramLink link,
AttachToLink attType,
int index
)

Visual Basic [image] Copy Code

Public Sub AttachTo( _
link As DiagramLink, _
attType As AttachToLink, _
index As Integer _
)

Parameters

link
A DiagramLink to whose control point or segment to attach this node.
attType
A value of the AttachToLink enumeration specifying whether to attach the node to a segment or to a control point of the link.
index
An index of link's control point or segment, depending on the attType value.

Remarks

This method attaches the node to a control point or segment of the specified link. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToLinkPoint or AttachToLinkSegment methods of Group, depending on the value of the attType argument. The attached node then maintains its original offset from a link's point or segment when link's shape changes.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Detach Method


MindFusion.Diagramming.Wpf.DiagramNode.AttachTo Method (DiagramNode, AttachToNode)

DiagramNode.AttachTo Method (DiagramNode, AttachToNode)
See Also
[image]

Attaches this node to a corner or a middle point of the specified node's bounding rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
AttachToNode attType
)

Visual Basic [image] Copy Code

Public Sub AttachTo( _
node As DiagramNode, _
attType As AttachToNode _
)

Parameters

node

A reference to the node to whose corner to attach this node.

attType
A member of the AttachToNode enumeration specifying to which corner of a node to attach this node.

Remarks

This method attaches the current node to the specified corner or middle point of another node's bounding rectangle. If there isn't a Group instance already associated with the master node, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToCorner method of Group. The attached node then maintains its original offset from another node's corner point.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Detach Method


MindFusion.Diagramming.Wpf.DiagramNode.AttachTo Method (DiagramNode, Double, Double, Double, Double)

DiagramNode.AttachTo Method (DiagramNode, Double, Double, Double, Double)
See Also
[image]

Attaches this node to the specified node in such a way that the ratio between their sizes is kept constant.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
double percentX1,
double percentY1,
double percentX2,
double percentY2
)

Visual Basic [image] Copy Code

Public Sub AttachTo( _
node As DiagramNode, _
percentX1 As Double, _
percentY1 As Double, _
percentX2 As Double, _
percentY2 As Double _
)

Parameters

node

A reference to the node to which to attach this node.

percentX1

Left-hand side coordinate of the node, expressed as percent of main node's width.

percentY1

Top side coordinate of the node, expressed as percent of main node's height.

percentX2

Right-hand side coordinate of the node, expressed as percent of main node's width.

percentY2

Bottom side coordinate of the node, expressed as percent of main node's height.

Remarks

This method attaches proportionally the current node to another node. If there isn't a Group instance already associated with the master item, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachProportional method of Group. The attached node maintains its size and position so that it always covers the specified rectangular area of the master node.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Detach Method


MindFusion.Diagramming.Wpf.DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)

DiagramNode.AttachTo Method (DiagramNode, GroupAnchorStyles)
See Also
[image]

Attaches this node to one or more edges of the specified node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AttachTo (
DiagramNode node,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public Sub AttachTo( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
)

Parameters

node

A reference to the node to which to attach this node.

anchorStyles
A member of the GroupAnchorStyles enumeration specifying the master node's edges to which this node should be anchored.

Remarks

This method attaches the current node to the corner of another node. If there isn't a Group instance already associated with the master node, one is created automatically by this method. The group is then accessible by the master's SubordinateGroup property, or this node's MasterGroup property.

The node is attached by calling the AttachToEdges method of Group, which mimics the anchoring of child controls in a form to the form edges, as implemented in Windows Forms.

See Also

AttachTo Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Detach Method


MindFusion.Diagramming.Wpf.DiagramNode.Collapse Method

DiagramNode.Collapse Method
[image]

Hides all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Collapse ()

Visual Basic [image] Copy Code

Public Sub Collapse ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Invoking Collapse on a node makes all its children in the tree invisible. It depends on the diagram's ExpandOnIncoming property which items connected to the node are considered its children.

Collapse is meant for use with tree structures and it is your responsibility to ensure that your chart is really a tree. A graph is a tree if every node has no more than one parent and there's one root node that can be reached from all nodes going in child-to-parent direction. The tree can be expanded again by the Expand method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Expand Method
Expanded Property


MindFusion.Diagramming.Wpf.DiagramNode.CompleteCreate Method

DiagramNode.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
Point end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As Point _
)

Parameters

end

The mouse pointer position.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.CompleteModify Method

DiagramNode.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteModify (
Point end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteModify( _
end As Point, _
ist As InteractionState _
)

Parameters

end

The mouse pointer position.

ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ConstraintsInfringed Method

DiagramNode.ConstraintsInfringed Method
[image]

Check whether the KeepInsideParent constrained is being violated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool ConstraintsInfringed ()

Visual Basic [image] Copy Code

Protected Function ConstraintsInfringed () As Boolean

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ContainsPoint Method

DiagramNode.ContainsPoint Method
[image]

Overload List

Name | Description
DiagramNode.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
DiagramNode.ContainsPoint (Point, Double) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ContainsPoint Method (Point)

DiagramNode.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

Remarks

true if this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ContainsPoint Method (Point, Double)

DiagramNode.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point diagramPoint,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
diagramPoint As Point, _
threshold As Double _
) As Boolean

Parameters

diagramPoint

The point to check.

threshold

Specifies the size of the area around the node outlines where the point is still considered inside the node.

Return Value

true it this node contains the specified point, or false otherwise.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming
true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.CreateState Method

DiagramNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

An instance of the DiagramNodeState class.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Detach Method

DiagramNode.Detach Method
[image]

Detaches this node from its master item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Detach ()

Visual Basic [image] Copy Code

Public Sub Detach ()

Remarks

The node should be previously attached using AttachTo.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Draw Method

DiagramNode.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the item should be rendered.

options

Provides options for the drawing operation.

Remarks

This method draws the node's Template if it is specified, or otherwise calls DrawLocal to execute standard low-level graphics rendering code of nodes.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.DrawAnchorPoints Method

DiagramNode.DrawAnchorPoints Method
[image]

Draws the anchor points of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void DrawAnchorPoints (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawAnchorPoints( _
graphics As DrawingContext _
)

Parameters

graphics

The DrawingContext that should be used to draw the anchor points.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.DrawHandles Method

DiagramNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.DrawLocal Method

DiagramNode.DrawLocal Method
[image]

Draws this node on the specified DrawingContext graphics surface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the item should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.EnumStyleableProperties Method

DiagramNode.EnumStyleableProperties Method
[image]

DiagramItem.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Expand Method

DiagramNode.Expand Method
[image]

Shows all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Expand ()

Visual Basic [image] Copy Code

Public Sub Expand ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Use Expand to show a subtree of nodes that was previously collapsed, either interactively or by calling Collapse. If the RecursiveExpand property is enabled, all tree levels are expanded recursively.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Collapse Method
Expanded Property


MindFusion.Diagramming.Wpf.DiagramNode.GetAllIncomingLinks Method

DiagramNode.GetAllIncomingLinks Method
[image]

Overload List

Name | Description
DiagramNode.GetAllIncomingLinks () | Gets a collection of all links entering this node.
DiagramNode.GetAllIncomingLinks (DiagramLinkCollection) | Adds all links going in this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetAllIncomingLinks Method ()

DiagramNode.GetAllIncomingLinks Method ()
See Also
[image]

Gets a collection of all links entering this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllIncomingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllIncomingLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection instance containing all links entering this node.

Remarks

This method returns IncomingLinks when the node does not contain constituent parts that can be related by links, such as TableNode rows or TreeViewNode items. Otherwise, the method also collects all links that enter the child items.

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
GetAllLinks Method
GetAllOutgoingLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going in this node to the specified collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetAllLinks Method

DiagramNode.GetAllLinks Method
[image]

Gets all links connected to this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllLinks ()

Visual Basic [image] Copy Code

Public Function GetAllLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection containing the links connected to this node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
IncomingLinks Property
OutgoingLinks Property
GetAllIncomingLinks Method
GetAllOutgoingLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.GetAllOutgoingLinks Method

DiagramNode.GetAllOutgoingLinks Method
[image]

Overload List

Name | Description
DiagramNode.GetAllOutgoingLinks () | Get a collection of all links going out of this node.
DiagramNode.GetAllOutgoingLinks (DiagramLinkCollection) | Adds all links going out of this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetAllOutgoingLinks Method ()

DiagramNode.GetAllOutgoingLinks Method ()
See Also
[image]

Get a collection of all links going out of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllOutgoingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllOutgoingLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection instance containing all links going out of this node.

Remarks

This method returns OutgoingLinks when the node does not contain constituent parts that can be related by links, such as TableNode rows or TreeViewNode items. Otherwise, the method also collects all links that go out of the child items.

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
GetAllLinks Method
GetAllIncomingLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going out of this node to the specified collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetBounds Method

DiagramNode.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetCenter Method

DiagramNode.GetCenter Method
[image]

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetDefaultTemplate Method

DiagramNode.GetDefaultTemplate Method
[image]

Returns a DataTemplate that should be used to render the node if its own Template property is not set.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DataTemplate GetDefaultTemplate ()

Visual Basic [image] Copy Code

Protected Overridable Function GetDefaultTemplate () As DataTemplate

Return Value

A DataTemplate instance.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetIntersection Method

DiagramNode.GetIntersection Method
[image]

Calculates the intersecion point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetLocalBounds Method

DiagramNode.GetLocalBounds Method
[image]

Gets this node's bounding rectangle in local coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Rect GetLocalBounds ()

Visual Basic [image] Copy Code

Protected Function GetLocalBounds () As Rect

Return Value

A Rect object representing the bounding rectangle of this node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetNearestBorderPoint Method

DiagramNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Point GetNearestBorderPoint (
Point diagramPt
)

Visual Basic [image] Copy Code

Public Overridable Function GetNearestBorderPoint( _
diagramPt As Point _
) As Point

Parameters

diagramPt

A Point instance specifying a point in the diagram.

Return Value

A Point specifying the point from the node's outline closest to the point specified as argument.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRegion Method

DiagramNode.GetRegion Method
[image]

DiagramItem.GetRegion override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Geometry GetRegion ()

Visual Basic [image] Copy Code

Public Overrides Function GetRegion () As Geometry

Return Value

An instance of the WPF Geometry class.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRepaintRect Method

DiagramNode.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true if related items should be considered too; otherwise, false.

Return Value

A rectangular region that is repainted when this node is modified.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRotatedBounds Method

DiagramNode.GetRotatedBounds Method
[image]

Overload List

Name | Description
DiagramNode.GetRotatedBounds () | Gets the bounding rectangle of this item when it is rotated.
DiagramNode.GetRotatedBounds (Rect, Point, Double) | Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRotatedBounds Method ()

DiagramNode.GetRotatedBounds Method ()
See Also
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRotatedBounds Method (Rect, Point, Double)

DiagramNode.GetRotatedBounds Method (Rect, Point, Double)
See Also
[image]

Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Rect GetRotatedBounds (
Rect rect,
Point center,
double angle
)

Visual Basic [image] Copy Code

Protected Function GetRotatedBounds( _
rect As Rect, _
center As Point, _
angle As Double _
) As Rect

Parameters

rect

center

angle

Return Value

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetRotationAngle Method

DiagramNode.GetRotationAngle Method
[image]

Gets the rotation angle of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual double GetRotationAngle ()

Visual Basic [image] Copy Code

Public Overridable Function GetRotationAngle () As Double

Return Value

A double value specifying the rotation angle.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetToolTip Method

DiagramNode.GetToolTip Method
[image]

DiagramItem.GetToolTip override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object GetToolTip (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Overrides Function GetToolTip( _
point As Point, _
isDiagramCoordinate As Boolean _
) As Object

Parameters

point

The mouse pointer position.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

Return Value

An object specifying the tooltip contents.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GetVisualChild Method

DiagramNode.GetVisualChild Method
[image]

FrameworkElement.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.GroupContains Method

DiagramNode.GroupContains Method
[image]

Determines whether this node is a predecessor of the specified node in the group hierarchy.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool GroupContains (
DiagramNode node
)

Visual Basic [image] Copy Code

Protected Function GroupContains( _
node As DiagramNode _
) As Boolean

Parameters

node

The node to check.

Return Value

true if the specified node is subordinate to this one; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.HitTestHandle Method

DiagramNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

Returns a NodeAdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.HitTestManipulators Method

DiagramNode.HitTestManipulators Method
[image]

DiagramItem.HitTestManipulators override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Manipulator HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestManipulators( _
pt As Point _
) As Manipulator

Parameters

pt

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.LoadFromXml Method

DiagramNode.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.MeasureOverride Method

DiagramNode.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Move Method

DiagramNode.Move Method
[image]

Moves the node to the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Move (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub Move( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the new x-coordinate of node's location.

y

A double value specifying the new y-coordinate of node's location.

Remarks

This method moves a node to the specified position, without changing the node's size. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Bounds Property
Resize Method


MindFusion.Diagramming.Wpf.DiagramNode.OnAdd Method

DiagramNode.OnAdd Method
[image]

Called when this node is added to the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnDragOut Method

DiagramNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Sub OnDragOut( _
item As DiagramItem _
)

Parameters

item
The DiagramItem that is dragged out of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnDragOver Method

DiagramNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dragged over the node.

Return Value

false if the diagram should notify nodes under this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnDropOver Method

DiagramNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDropOver( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem that is dropped over the node.

Return Value

false if the diagram should notify nodes under this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnLoad Method

DiagramNode.OnLoad Method
[image]

Called after the item is deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnRemove Method

DiagramNode.OnRemove Method
[image]

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnSizeChanged Method

DiagramNode.OnSizeChanged Method
[image]

Called when the size of the node changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnSizeChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnSizeChanged ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds Method
[image]

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnUpdateBounds ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ReassignAnchorPoints Method

DiagramNode.ReassignAnchorPoints Method
[image]

Reassigns links to anchor points so that they are evenly disctributed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

Remarks

If there are more anchor points defined for this node than links connected to it, this method ensures that each point has at most one link attached to it. ReassignAnchorPoints also tries to assign links to points that are close to their opposite end points.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
AnchorPattern Property


MindFusion.Diagramming.Wpf.DiagramNode.ReassignUnanchoredLinks Method

DiagramNode.ReassignUnanchoredLinks Method
[image]

Reassigns unanchored links

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ReassignUnanchoredLinks ()

Visual Basic [image] Copy Code

Public Sub ReassignUnanchoredLinks ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Repaint Method

DiagramNode.Repaint Method
[image]

DiagramItem.Repaint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Repaint (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Sub Repaint( _
includeConnected As Boolean _
)

Parameters

includeConnected
true if links connected to this node and the child items in its SubordinateGroup should be repainted too; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.Resize Method

DiagramNode.Resize Method
[image]

Resizes the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Resize (
double width,
double height
)

Visual Basic [image] Copy Code

Public Sub Resize( _
width As Double, _
height As Double _
)

Parameters

width

A double value specifying new width of the node.

height

A double value specifying new height of the node.

Remarks

This method resizes a node, without changing the node's top-left corner location. Resizing a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Bounds Property
Move Method


MindFusion.Diagramming.Wpf.DiagramNode.RestoreProperties Method

DiagramNode.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramNodeProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.RestoreState Method

DiagramNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SaveProperties Method

DiagramNode.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramNodeProperties-derived object where the item's properties should be saved.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SaveState Method

DiagramNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

An instance of the DiagramNodeState class.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SaveToXml Method

DiagramNode.SaveToXml Method
[image]

DiagramItem.SaveToXml override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ScaleElements Method

DiagramNode.ScaleElements Method
[image]

Scales the node's elements by specified amount.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overridable Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetBounds Method

DiagramNode.SetBounds Method
[image]

Sets the location and size of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetBounds (
Rect rect,
bool updateGroups,
bool updateLinks
)

Visual Basic [image] Copy Code

Public Sub SetBounds( _
rect As Rect, _
updateGroups As Boolean, _
updateLinks As Boolean _
)

Parameters

rect

A Rect specifying the node position.

updateGroups

Specifies whether the position of child nodes attached to this one should be updated too.

updateLinks

Specifies whether the position of links connected to this node should be updated too.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetExpandable Method

DiagramNode.SetExpandable Method
[image]

Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SetExpandable (
bool exp
)

Visual Basic [image] Copy Code

Protected Sub SetExpandable( _
exp As Boolean _
)

Parameters

exp
true if a collapse/expand button should be added to this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetExpanded Method

DiagramNode.SetExpanded Method
[image]

DiagramItem.SetExpanded override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetExpanded( _
e As Boolean _
)

Parameters

e

Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetExpandedFlag Method

DiagramNode.SetExpandedFlag Method
[image]

Sets the 'expanded' flag, repainting the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetExpandedFlag (
bool newState
)

Visual Basic [image] Copy Code

Public Sub SetExpandedFlag( _
newState As Boolean _
)

Parameters

newState

Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetIncomingLinks Method

DiagramNode.SetIncomingLinks Method
[image]

Sets the incoming links collection of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SetIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's incoming links.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetOutgoingLinks Method

DiagramNode.SetOutgoingLinks Method
[image]

Sets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SetOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the node's outgoing links.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetRect Method

DiagramNode.SetRect Method
[image]

This method is used internally by the Ruler control to align nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetRect (
Rect rect,
bool raiseModfEvent
)

Visual Basic [image] Copy Code

Public Sub SetRect( _
rect As Rect, _
raiseModfEvent As Boolean _
)

Parameters

rect

The new location of the node.

raiseModfEvent
A flag specifying whether to raise the NodeModified event.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.SetReflexive Method

DiagramNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the self-loop link.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.ShouldRenderAnchorPoints Method

DiagramNode.ShouldRenderAnchorPoints Method
[image]

Determines whether the node should render its anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool ShouldRenderAnchorPoints (
RenderOptions options
)

Visual Basic [image] Copy Code

Protected Function ShouldRenderAnchorPoints( _
options As RenderOptions _
) As Boolean

Parameters

options

Return Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.StartCreate Method

DiagramNode.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartCreate (
Point org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As Point _
)

Parameters

org

Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.StartModify Method

DiagramNode.StartModify Method
[image]

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this node.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.UpdateCreate Method

DiagramNode.UpdateCreate Method
[image]

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
Point current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As Point _
)

Parameters

current

Position of the mouse pointer.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.UpdateLinkIntersections Method

DiagramNode.UpdateLinkIntersections Method
[image]

Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void UpdateLinkIntersections ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkIntersections ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.UpdateLinkPositions Method

DiagramNode.UpdateLinkPositions Method
[image]

Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void UpdateLinkPositions ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkPositions ()

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.UpdateModify Method

DiagramNode.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist
An InteractionState object containing more information about the current state of the operation.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode Properties

DiagramNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved.
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

See Also

DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.AllowIncomingLinks Property

DiagramNode.AllowIncomingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowIncomingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncomingLinks As Boolean

Property Value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
IncomingLinks Property
AllowOutgoingLinks Property


MindFusion.Diagramming.Wpf.DiagramNode.AllowOutgoingLinks Property

DiagramNode.AllowOutgoingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowOutgoingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoingLinks As Boolean

Property Value

true to let users draw outgoing links from this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
OutgoingLinks Property
AllowIncomingLinks Property


MindFusion.Diagramming.Wpf.DiagramNode.AnchorPattern Property

DiagramNode.AnchorPattern Property
[image]

Gets or sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

A ShapeNode whose AnchorPattern is not explicitly set uses the AnchorPattern from the Shape definition.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Diagram.SnapToAnchor Property


MindFusion.Diagramming.Wpf.DiagramNode.Bounds Property

DiagramNode.Bounds Property
[image]

Gets or sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

An instance of the System.Windows.Rect structure.

Remarks

Use this property to set or get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Move Method
Resize Method
Intersects Method


MindFusion.Diagramming.Wpf.DiagramNode.Constraints Property

DiagramNode.Constraints Property
[image]

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeConstraints Constraints { get; set; }

Visual Basic [image] Copy Code

Public Property Constraints As NodeConstraints

Property Value

An instance of the NodeConstraints class.

Remarks

These constraints are considered when a user modifies the node interactively. They are ignored if node placement is changed programmatically by using methods and properties.

Example

This sample code disables moving or resizing a node vertically:

C# [image] Copy Code

DiagramNode node = diagram.ActiveItem as DiagramNode;

// Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal;

// Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move |
AdjustmentHandles.ResizeMiddleLeft | AdjustmentHandles.ResizeMiddleRight;

Visual Basic [image] Copy Code

Dim node As DiagramNode = diagram.ActiveItem

' Allow moving the node only horizontally
node.Constraints.MoveDirection = DirectionConstraint.Horizontal

' Disable handles that can be used to resize the node vertically
node.EnabledHandles = AdjustmentHandles.Move + _
AdjustmentHandles.ResizeMiddleLeft + AdjustmentHandles.ResizeMiddleRight

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
EnabledHandles Property


MindFusion.Diagramming.Wpf.DiagramNode.Effects Property

DiagramNode.Effects Property
[image]

Gets a collection with all effects applied to this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.EnabledHandles Property

DiagramNode.EnabledHandles Property
[image]

Gets or sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandles EnabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnabledHandles As AdjustmentHandles

Property Value

A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

Example

The following code disables the rotation handle of a shape node:

C# [image] Copy Code
node.EnabledHandles = AdjustmentHandles.All & ~ AdjustmentHandles.Rotate;
Visual Basic [image] Copy Code
node.EnabledHandles = AdjustmentHandles.All And Not AdjustmentHandles.Rotate

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Constraints Property
Diagram.ModificationStart Property
Diagram.DisabledHandlesStyle Property
Diagram.ShowDisabledHandles Property


MindFusion.Diagramming.Wpf.DiagramNode.Expandable Property

DiagramNode.Expandable Property
[image]

Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true if users are allowed to expand / collapse the tree starting from this node; otherwise, false. The default is false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. If it is enabled, a small [±] button is drawn beside the node. Clicking that button either shows or hides all children of this node in the tree. It depends on the diagram's ExpandOnIncoming property which items connected to a node are considered its children. The tree expansion continues recursively down the child nodes if the RecursiveExpand property is enabled.

A tree can be collapsed or expanded programmatically by invoking the Collapse or Expand methods on the tree root node.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Expanded Property
Diagram.NodesExpandable Property
HtmlBuilder.ExpandBtnHyperLink Property


MindFusion.Diagramming.Wpf.DiagramNode.Expanded Property

DiagramNode.Expanded Property
[image]

Gets or sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Expanded As Boolean

Property Value

true if the tree starting from this node is expanded; otherwise, false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. Set it to false to make the subtree starting from a node collapse, with all its child nodes and links becoming invisible. Set it to true to show the child nodes and links again.

A user is allowed to expand or collapse the tree that starts from a node interactively if the Expandable property of that node is enabled.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Expandable Property
Expand Method


MindFusion.Diagramming.Wpf.DiagramNode.GridAlignPoint Property

DiagramNode.GridAlignPoint Property
[image]

Gets or sets the node's point that should align to a grid point when the node is moved.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RelativePosition GridAlignPoint { get; set; }

Visual Basic [image] Copy Code

Public Property GridAlignPoint As RelativePosition

Property Value

A RelativePosition instance. The default value is null.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
AlignToGrid Property


MindFusion.Diagramming.Wpf.DiagramNode.HandlesStyle Property

DiagramNode.HandlesStyle Property
[image]

Gets or sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

Specifies how node selection status is indicated visually. In addition, this property defines how manipulation of the node can be done, that is, how to move it, resize it or link it to other nodes. You can assign any of the HandlesStyle values to this property.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
ShapeHandlesStyle Property
HitTestHandle Method


MindFusion.Diagramming.Wpf.DiagramNode.IncomingLinks Property

DiagramNode.IncomingLinks Property
[image]

Gets a collection of links that point to the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links. If the node is a TableNode, links that connect to it as a whole entity are included in the collection, while links that connect to particular row of the table are included in that row's IncomingLinks collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
AllowIncomingLinks Property
OutgoingLinks Property
TableNode.ConnectionStyle Property
Query Method
GetAllIncomingLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.MasterGroup Property

DiagramNode.MasterGroup Property
[image]

Gets a reference to the group to which this node is attached.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group MasterGroup { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterGroup As Group

Property Value

A reference to a Group object or null (Nothing in Visual Basic) if the item is not attached to a group.

Remarks

Diagram items can be grouped hierarchically in such a manner, that if an item is moved all of its subordinated items in the hierarchy move too. The immediate subordinates of an item are contained and represented by a Group instance. This property provides access to the group that contains the item as a subordinate. If the item is not a subordinate of another, the property returns null (Nothing in Visual Basic).

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Query Method


MindFusion.Diagramming.Wpf.DiagramNode.Obstacle Property

DiagramNode.Obstacle Property
[image]

Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Obstacle { get; set; }

Visual Basic [image] Copy Code

Public Property Obstacle As Boolean

Property Value

true makes routed links look for a path going around this node; false lets links cross the node. The default is true.

Remarks

It is useful to set this property to false for nodes used as decorative containers or labels.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
DiagramLink.AutoRoute Property
Diagram.RouteAllLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.OutgoingLinks Property

DiagramNode.OutgoingLinks Property
[image]

Gets a collection of links that start from this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links. If the node is a TableNode, links that connect to it as a whole entity are included in the collection, while links that connect to particular row of the table are included in that row's OutgoingLinks collection.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
AllowOutgoingLinks Property
IncomingLinks Property
TableNode.ConnectionStyle Property
Query Method
GetAllOutgoingLinks Method


MindFusion.Diagramming.Wpf.DiagramNode.RotationAngle Property

DiagramNode.RotationAngle Property
[image]

Gets or sets the rotation angle of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

A float number specifying the angle at which the shape node is rotated. The default is 0.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace
Diagram.RotationStep Property
Group.FollowMasterRotation Property


MindFusion.Diagramming.Wpf.DiagramNode.Template Property

DiagramNode.Template Property
[image]

Gets or sets the DataTemplate used to display this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DataTemplate Template { get; set; }

Visual Basic [image] Copy Code

Public Property Template As DataTemplate

Property Value

A System.Windows.DataTemplate instance; the default value is null.

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.TopLevel Property

DiagramNode.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNode.VisualChildrenCount Property

DiagramNode.VisualChildrenCount Property
[image]

FrameworkElement.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

DiagramNode Members
DiagramNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Class

DiagramNodeAdapter Class
Remarks See Also
[image]

DiagramNodeAdapter is an adapter class that enables using any UIElement -derived object as a diagram node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramNodeAdapter : DiagramNode

Visual Basic [image] Copy Code

Public Class DiagramNodeAdapter
Inherits DiagramNode

Remarks

DiagramNodeAdapter objects are nodes that can host any WPF UIElements, such as custom controls. The hosted element can be get or set using the UIElement property. When saving the parent diagram into a file, hosted elements are automatically serialized by means of the XamlWriter and XamlReader WPF classes. To implement custom serialization, handle the SerializeControl and DeserializeControl events.

The adapter node can either try to set its Bounds value as a size of the hosted element, or it can auto-size to the desired size of the element. This is specified via the SizeSyncMode property.

If the hosted control is interactive, you can specify that it should process mouse input instead of the Diagram control by setting MouseInputMode.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.DiagramNodeAdapter

See Also

DiagramNodeAdapter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Members

DiagramNodeAdapter Members
Constructors Fields Properties Methods
[image]

DiagramNodeAdapter is an adapter class that enables using any UIElement -derived object as a diagram node.

The following tables list the members exposed by the DiagramNodeAdapter type.

Public Constructors

Name | Description
DiagramNodeAdapter | Overloaded.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Control | Gets or set the UIElement wrapped by this node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MouseInputMode | Specifies whether mouse input is processed by the diagram or the hosted control.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SizeSyncMode | Specifies whether changes to the size of the node influence the size of the hosted control, and vice versa.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement wrapped by this node.
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item.
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the item on the specified IGraphics surface.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to Diagram
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when a node is removed from a Diagram, either by the user, programmatically or while executing undo / redo.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Constructor

DiagramNodeAdapter Constructor
[image]

Overload List

Name | Description
DiagramNodeAdapter (Diagram, UIElement) | Creates a DiagramNodeAdapter for the specified UIElement
DiagramNodeAdapter (DiagramNodeAdapter) | Initializes a new instance of the DiagramNodeAdapter class using the specified node as a prototype.
DiagramNodeAdapter (DiagramNodeAdapter, UIElement) | Initializes a new instance of the DiagramNodeAdapter class using the specified node as a prototype.
DiagramNodeAdapter (UIElement) | Creates a DiagramNodeAdapter for the specified UIElement.

See Also

DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Constructor (Diagram, UIElement)

DiagramNodeAdapter Constructor (Diagram, UIElement)
See Also
[image]

Creates a DiagramNodeAdapter for the specified UIElement

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeAdapter (
Diagram parent,
UIElement item
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
item As UIElement _
)

Parameters

parent
Diagram instance providing default values
item
An instance of UIElement -derived class.

See Also

DiagramNodeAdapter Constructor Overload List
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Constructor (DiagramNodeAdapter)

DiagramNodeAdapter Constructor (DiagramNodeAdapter)
See Also
[image]

Initializes a new instance of the DiagramNodeAdapter class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeAdapter (
DiagramNodeAdapter prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramNodeAdapter _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

DiagramNodeAdapter Constructor Overload List
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Constructor (DiagramNodeAdapter, UIElement)

DiagramNodeAdapter Constructor (DiagramNodeAdapter, UIElement)
See Also
[image]

Initializes a new instance of the DiagramNodeAdapter class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeAdapter (
DiagramNodeAdapter prototype,
UIElement element
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramNodeAdapter, _
element As UIElement _
)

Parameters

prototype
The node to use as a prototype. The properties of the new node are initialized from the property values of this node.
element
The UIElement to associate with this node.

See Also

DiagramNodeAdapter Constructor Overload List
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Constructor (UIElement)

DiagramNodeAdapter Constructor (UIElement)
See Also
[image]

Creates a DiagramNodeAdapter for the specified UIElement.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeAdapter (
UIElement item
)

Visual Basic [image] Copy Code

Public New ( _
item As UIElement _
)

Parameters

item
An instance of UIElement -derived class.

See Also

DiagramNodeAdapter Constructor Overload List
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Methods

DiagramNodeAdapter Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item.
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the item on the specified IGraphics surface.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to Diagram
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when a node is removed from a Diagram, either by the user, programmatically or while executing undo / redo.
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.Clone Method

DiagramNodeAdapter.Clone Method
[image]

Creates a copy of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overrides Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard

true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.Draw Method

DiagramNodeAdapter.Draw Method
[image]

Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the item should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.LoadFromXml Method

DiagramNodeAdapter.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.MeasureOverride Method

DiagramNodeAdapter.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size that the parent element can allocate for the child.

Return Value

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.OnAdd Method

DiagramNodeAdapter.OnAdd Method
[image]

Called when this node is added to Diagram

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.OnRemove Method

DiagramNodeAdapter.OnRemove Method
[image]

Called when a node is removed from a Diagram, either by the user, programmatically or while executing undo / redo.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.OnSizeChanged Method

DiagramNodeAdapter.OnSizeChanged Method
[image]

Called when the size of the item changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnSizeChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnSizeChanged ()

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.SaveToXml Method

DiagramNodeAdapter.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter Properties

DiagramNodeAdapter Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Control | Gets or set the UIElement wrapped by this node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
MouseInputMode | Specifies whether mouse input is processed by the diagram or the hosted control.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SizeSyncMode | Specifies whether changes to the size of the node influence the size of the hosted control, and vice versa.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement wrapped by this node.
Visible | DiagramItem.Visible override.
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.Control Property

DiagramNodeAdapter.Control Property
[image]

Gets or set the UIElement wrapped by this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UIElement Control { get; set; }

Visual Basic [image] Copy Code

Public Property Control As UIElement

Property Value

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.MouseInputMode Property

DiagramNodeAdapter.MouseInputMode Property
[image]

Specifies whether mouse input is processed by the diagram or the hosted control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseInputMode MouseInputMode { get; set; }

Visual Basic [image] Copy Code

Public Property MouseInputMode As MouseInputMode

Property Value

A member of the MouseInputMode enumeration. The default value is HandledByDiagram.

Remarks

Set this property to HandledByHostedControl to let hosted interactive controls, such as sliders and scrollbars, process mouse input. Otherwise the Diagram control could start its own interactive operation such as drawing a link or selecting items, depending on the current Behavior value.

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.SizeSyncMode Property

DiagramNodeAdapter.SizeSyncMode Property
[image]

Specifies whether changes to the size of the node influence the size of the hosted control, and vice versa.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SizeSyncMode SizeSyncMode { get; set; }

Visual Basic [image] Copy Code

Public Property SizeSyncMode As SizeSyncMode

Property Value

A member of the SizeSyncMode enumeration. The default value is Arrange.

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.UIElement Property

DiagramNodeAdapter.UIElement Property
[image]

Gets the UIElement wrapped by this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override UIElement UIElement { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property UIElement As UIElement

Property Value

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeAdapter.Visible Property

DiagramNodeAdapter.Visible Property
[image]

DiagramItem.Visible override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true to show this node; otherwise, false.

See Also

DiagramNodeAdapter Members
DiagramNodeAdapter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection Class

DiagramNodeCollection Class
[image]

Represents a strongly typed collection of diagram nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramNodeCollection : ItemCollectionBase<DiagramNode>

Visual Basic [image] Copy Code

Public Class DiagramNodeCollection
Inherits ItemCollectionBase(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(DiagramNode)
MindFusion.Diagramming.Wpf.ItemCollectionBase(DiagramNode)
MindFusion.Diagramming.Wpf.DiagramNodeCollection

See Also

DiagramNodeCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection Members

DiagramNodeCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of diagram nodes.

The following tables list the members exposed by the DiagramNodeCollection type.

Public Constructors

Name | Description
DiagramNodeCollection | Initializes a new instance of the DiagramNodeCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Add | Adds the specified node to the collection.
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection Constructor

DiagramNodeCollection Constructor
[image]

Initializes a new instance of the DiagramNodeCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection Methods

DiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Add | Adds the specified node to the collection.
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection.Add Method

DiagramNodeCollection.Add Method
[image]

Adds the specified node to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
UIElement node
)

Visual Basic [image] Copy Code

Public Sub Add( _
node As UIElement _
)

Parameters

node
A DiagramNode or an UIElement instance to add to the collection.

Remarks

If you add an arbitrary UIElement to the collection, the control automatically creates a DiagramNodeAdapter object for it.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeCollection.Clone Method

DiagramNodeCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramNodeCollection

Return Value

An instance of the DiagramNodeCollection class.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeProperties Class

DiagramNodeProperties Class
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramNodeProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramNodeProperties
Inherits DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.BarcodeNodeProperties
MindFusion.Diagramming.Wpf.ContainerNodeProperties
MindFusion.Diagramming.Wpf.ShapeNodeProperties
MindFusion.Diagramming.Wpf.TableNodeProperties
MindFusion.Diagramming.Wpf.VisioNodeProperties

See Also

DiagramNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeProperties Members

DiagramNodeProperties Members
Constructors Methods
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

The following tables list the members exposed by the DiagramNodeProperties type.

Public Constructors

Name | Description
DiagramNodeProperties | Initializes a new instance of the DiagramNodeProperties class.

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

DiagramNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeProperties Constructor

DiagramNodeProperties Constructor
[image]

Initializes a new instance of the DiagramNodeProperties class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeState Class

DiagramNodeState Class
[image]

Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the DiagramNode.CreateState, DiagramNode.SaveState and DiagramNode.RestoreState methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramNodeState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramNodeState
Inherits DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemState
MindFusion.Diagramming.Wpf.DiagramNodeState
MindFusion.Diagramming.Wpf.ShapeNodeState

See Also

DiagramNodeState Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeState Members

DiagramNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the DiagramNode.CreateState, DiagramNode.SaveState and DiagramNode.RestoreState methods.

The following tables list the members exposed by the DiagramNodeState type.

Public Constructors

Name | Description
DiagramNodeState |

See Also

DiagramNodeState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramNodeState Constructor

DiagramNodeState Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Class

DiagramPage Class
[image]

Represents a single page in a DiagramDocument object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramPage : Diagram

Visual Basic [image] Copy Code

Public Class DiagramPage
Inherits Diagram

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramBase
MindFusion.Diagramming.Wpf.Diagram
MindFusion.Diagramming.Wpf.DiagramPage

See Also

DiagramPage Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Members

DiagramPage Members
Constructors Fields Attached Properties Properties Methods Events
[image]

Represents a single page in a DiagramDocument object.

The following tables list the members exposed by the DiagramPage type.

Public Constructors

Name | Description
DiagramPage | Initializes a new instance of the DiagramPage class.

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property. (Inherited from Diagram.)
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property. (Inherited from Diagram.)
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node. (Inherited from Diagram.)
DefaultShapeProperty | Identifies the DefaultShape dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property. (Inherited from Diagram.)
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property. (Inherited from Diagram.)
IconProperty | Identifies the Icon dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property. (Inherited from Diagram.)
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property. (Inherited from Diagram.)
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property. (Inherited from Diagram.)
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property. (Inherited from Diagram.)
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property. (Inherited from Diagram.)
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property. (Inherited from Diagram.)
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property. (Inherited from Diagram.)
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property. (Inherited from Diagram.)
LinkTextProperty | Identifies the LinkText dependency property. (Inherited from Diagram.)
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property. (Inherited from Diagram.)
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property. (Inherited from Diagram.)
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property. (Inherited from Diagram.)
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property. (Inherited from Diagram.)
MeasureUnitProperty | Identifies the MeasureUnit dependency property. (Inherited from Diagram.)
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item (Inherited from Diagram.)
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item (Inherited from Diagram.)
NavigateRight | Selects the diagram item that stands to the right of the currently selected item (Inherited from Diagram.)
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
NodeTemplateProperty | Identifies the NodeTemplate dependency property. (Inherited from Diagram.)
RotationStepProperty | Identifies the RotationStep dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
ShapeTextProperty | Identifies the ShapeText dependency property. (Inherited from Diagram.)
TableBrushProperty | Identifies the TableBrush dependency property. (Inherited from Diagram.)
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property. (Inherited from Diagram.)
TableCaptionProperty | Identifies the TableCaption dependency property. (Inherited from Diagram.)
TableColumnCountProperty | Identifies the TableColumnCount dependency property. (Inherited from Diagram.)
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property. (Inherited from Diagram.)
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property. (Inherited from Diagram.)
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property. (Inherited from Diagram.)
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TableRowCountProperty | Identifies the TableRowCount dependency property. (Inherited from Diagram.)
TableRowHeightProperty | Identifies the TableRowHeight dependency property. (Inherited from Diagram.)
TableShapeProperty | Identifies the TableShape dependency property. (Inherited from Diagram.)
TablesScrollableProperty | Identifies the TablesScrollable dependency property. (Inherited from Diagram.)
TitleBrushProperty | Identifies the Title dependency property.
TitleProperty | Identifies the Title dependency property.
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor dependency property. (Inherited from Diagram.)

Public Attached Properties

Name | Description
IsDiagramScrollerProperty | Gets or sets a value indicating whether a ScrollViewer should be associated as a scroller for an underlying diagram. (Inherited from Diagram.)

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area. (Inherited from Diagram.)
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
Content | With this property, you can define diagram elements from XAML code. (Inherited from Diagram.)
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects. (Inherited from Diagram.)
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input. (Inherited from Diagram.)
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects. (Inherited from Diagram.)
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location. (Inherited from Diagram.)
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location. (Inherited from Diagram.)
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram. (Inherited from Diagram.)
DocumentPlane | Gets the document plane of the diagram. (Inherited from Diagram.)
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too. (Inherited from Diagram.)
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPen | Gets or sets the pen used to draw the grid lines or points. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. (Inherited from Diagram.)
Icon | Gets or sets an image associated with the page. This is a dependency property.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text. (Inherited from Diagram.)
InplaceEditFont | Gets or sets the font of the inplace-editing text box. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control. (Inherited from Diagram.)
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default shape of diagram links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled. (Inherited from Diagram.)
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool. (Inherited from Diagram.)
MagnifierHeight | Gets or sets the height of the magnifier tool. (Inherited from Diagram.)
MagnifierStyle | Gets or sets the style of the magnifier tool. (Inherited from Diagram.)
MagnifierWidth | Gets or sets the width of the magnifier tool. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT. (Inherited from Diagram.)
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view. (Inherited from Diagram.)
PanInertia | Gets or sets a value indicating whether panning the view will have inertia. (Inherited from Diagram.)
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
PrintOptions | Print options for individual diagram pages are not used.
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RemoveHiddenItemsFromVisualTree | For internal use. (Inherited from Diagram.)
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button. (Inherited from Diagram.)
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle. (Inherited from Diagram.)
RotationStep | Gets or sets the RotationAngle increment when users rotate a node. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default shape of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
TextBrush | Gets or sets the default brush of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
Title | Gets or sets the page title. This is a dependency property.
TitleBrush | Gets or sets the brush of the title when the title is displayed. This is a dependency property.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates. (Inherited from Diagram.)
VisualChildrenCount | Visual.VisualChildrenCount override. (Inherited from Diagram.)

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
BeginInit | FrameworkElement.BeginInit override. (Inherited from Diagram.)
BringIntoView | Overloaded. Scrolls the diagram area to make the specified item visible. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
ClientToDoc | Overloaded. (Inherited from Diagram.)
Compact | Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CopyToClipboard | Overloaded. (Inherited from Diagram.)
CreateImage | Overloaded. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard. (Inherited from Diagram.)
DocToClient | Overloaded. (Inherited from Diagram.)
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links. (Inherited from Diagram.)
EndEdit | Exits in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
EndInit | FrameworkElement.EndInit override. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindGroup | Finds the group that has the specified tag value. (Inherited from Diagram.)
FindLink | Finds the link that has the specified tag value. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNode | Finds the node that has the specified tag value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetDiagramItem | Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement. (Inherited from Diagram.)
GetIsDiagramScroller | Gets the value of the IsDiagramScroller attached property from a given element. (Inherited from Diagram.)
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location. (Inherited from Diagram.)
GetItemBounds | Retrieves the bounding rectangle of the specified item within the current diagram. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. Gets the node that lies at the specified location. (Inherited from Diagram.)
GetNodesAt | Returns the nodes that contain the specified point. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HandleMouseMove | Propagates mouse input to interested manipulators. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within a manipulator of a diagram element. (Inherited from Diagram.)
Invalidate | Invalidates the specified rectangle of the diagram, causing it to be repainted. (Inherited from Diagram.)
InvalidateBackground | Repaints the diagram background, and raises the DrawBackground event for custom drawing. (Inherited from Diagram.)
InvalidateForeground | Repaints the diagram foreground, and raises the DrawForeground event for custom drawing. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control. (Inherited from Diagram.)
MeasureString | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram. (Inherited from Diagram.)
PasteFromClipboard | Overloaded. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to the specified diagram document. (Inherited from Diagram.)
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation. (Inherited from Diagram.)
Print | Displays a Print dialog and prints the diagram. (Inherited from Diagram.)
PrintPreview | Overloaded. Displays the diagram in a Print Preview window. (Inherited from Diagram.)
RaiseCellTextEdited | Raises the CellTextEdited event. (Inherited from Diagram.)
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RaiseLinkTextEdited | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEditing | Overloaded. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
RaiseSelecting | Raises the appropriate *Selecting event. (Inherited from Diagram.)
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string. (Inherited from Diagram.)
SaveToXml | Overloaded. Saves the diagram to an XML document. (Inherited from Diagram.)
ScrollTo | Scrolls the document to the specified point. (Inherited from Diagram.)
SetIsDiagramScroller | Sets the value of the IsDiagramScroller attached property to a given element. (Inherited from Diagram.)
SetItemBounds | Sets the location and size of the specified item within the current diagram. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
ZoomIn | Zooms document's items thus making them appear closer. (Inherited from Diagram.)
ZoomOut | Zooms the diagram out making items appear further away. (Inherited from Diagram.)
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area. (Inherited from Diagram.)
ZoomToRect | Overloaded. Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from Diagram.)
DrawGrid | Renders the diagram grid. (Inherited from Diagram.)
GetVisualChild | Visual.GetVisualChild override. (Inherited from Diagram.)
MeasureOverride | Control.MeasureOverride override. (Inherited from Diagram.)
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnDrop | Handles dropping of DraggedNode instances (Inherited from Diagram.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from Diagram.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override. (Inherited from Diagram.)
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override. (Inherited from Diagram.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from Diagram.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnVisualParentChanged | FrameworkElement.OnVisualParentChanged override. (Inherited from Diagram.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Fields

DiagramPage Fields
[image]

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property. (Inherited from Diagram.)
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property. (Inherited from Diagram.)
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node. (Inherited from Diagram.)
DefaultShapeProperty | Identifies the DefaultShape dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property. (Inherited from Diagram.)
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property. (Inherited from Diagram.)
IconProperty | Identifies the Icon dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property. (Inherited from Diagram.)
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property. (Inherited from Diagram.)
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property. (Inherited from Diagram.)
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property. (Inherited from Diagram.)
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property. (Inherited from Diagram.)
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property. (Inherited from Diagram.)
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property. (Inherited from Diagram.)
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property. (Inherited from Diagram.)
LinkTextProperty | Identifies the LinkText dependency property. (Inherited from Diagram.)
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property. (Inherited from Diagram.)
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property. (Inherited from Diagram.)
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property. (Inherited from Diagram.)
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property. (Inherited from Diagram.)
MeasureUnitProperty | Identifies the MeasureUnit dependency property. (Inherited from Diagram.)
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item (Inherited from Diagram.)
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item (Inherited from Diagram.)
NavigateRight | Selects the diagram item that stands to the right of the currently selected item (Inherited from Diagram.)
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
NodeTemplateProperty | Identifies the NodeTemplate dependency property. (Inherited from Diagram.)
RotationStepProperty | Identifies the RotationStep dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
ShapeTextProperty | Identifies the ShapeText dependency property. (Inherited from Diagram.)
TableBrushProperty | Identifies the TableBrush dependency property. (Inherited from Diagram.)
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property. (Inherited from Diagram.)
TableCaptionProperty | Identifies the TableCaption dependency property. (Inherited from Diagram.)
TableColumnCountProperty | Identifies the TableColumnCount dependency property. (Inherited from Diagram.)
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property. (Inherited from Diagram.)
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property. (Inherited from Diagram.)
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property. (Inherited from Diagram.)
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TableRowCountProperty | Identifies the TableRowCount dependency property. (Inherited from Diagram.)
TableRowHeightProperty | Identifies the TableRowHeight dependency property. (Inherited from Diagram.)
TableShapeProperty | Identifies the TableShape dependency property. (Inherited from Diagram.)
TablesScrollableProperty | Identifies the TablesScrollable dependency property. (Inherited from Diagram.)
TitleBrushProperty | Identifies the Title dependency property.
TitleProperty | Identifies the Title dependency property.
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
ZoomFactorProperty | Identifies the ZoomFactor dependency property. (Inherited from Diagram.)

See Also

DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.IconProperty Field

DiagramPage.IconProperty Field
[image]

Identifies the Icon dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IconProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IconProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.TitleBrushProperty Field

DiagramPage.TitleBrushProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleBrushProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.TitleProperty Field

DiagramPage.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Constructor

DiagramPage Constructor
[image]

Initializes a new instance of the DiagramPage class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPage ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Properties

DiagramPage Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area. (Inherited from Diagram.)
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
Content | With this property, you can define diagram elements from XAML code. (Inherited from Diagram.)
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects. (Inherited from Diagram.)
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input. (Inherited from Diagram.)
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects. (Inherited from Diagram.)
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items. (Inherited from Diagram.)
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location. (Inherited from Diagram.)
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location. (Inherited from Diagram.)
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram. (Inherited from Diagram.)
DocumentPlane | Gets the document plane of the diagram. (Inherited from Diagram.)
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too. (Inherited from Diagram.)
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPen | Gets or sets the pen used to draw the grid lines or points. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. (Inherited from Diagram.)
Icon | Gets or sets an image associated with the page. This is a dependency property.
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text. (Inherited from Diagram.)
InplaceEditFont | Gets or sets the font of the inplace-editing text box. (Inherited from Diagram.)
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control. (Inherited from Diagram.)
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default shape of diagram links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled. (Inherited from Diagram.)
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool. (Inherited from Diagram.)
MagnifierHeight | Gets or sets the height of the magnifier tool. (Inherited from Diagram.)
MagnifierStyle | Gets or sets the style of the magnifier tool. (Inherited from Diagram.)
MagnifierWidth | Gets or sets the width of the magnifier tool. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT. (Inherited from Diagram.)
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view. (Inherited from Diagram.)
PanInertia | Gets or sets a value indicating whether panning the view will have inertia. (Inherited from Diagram.)
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
PrintOptions | Print options for individual diagram pages are not used.
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RemoveHiddenItemsFromVisualTree | For internal use. (Inherited from Diagram.)
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button. (Inherited from Diagram.)
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle. (Inherited from Diagram.)
RotationStep | Gets or sets the RotationAngle increment when users rotate a node. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default shape of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
TextBrush | Gets or sets the default brush of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
Title | Gets or sets the page title. This is a dependency property.
TitleBrush | Gets or sets the brush of the title when the title is displayed. This is a dependency property.
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates. (Inherited from Diagram.)
VisualChildrenCount | Visual.VisualChildrenCount override. (Inherited from Diagram.)

See Also

DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.Icon Property

DiagramPage.Icon Property
[image]

Gets or sets an image associated with the page. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource Icon { get; set; }

Visual Basic [image] Copy Code

Public Property Icon As ImageSource

Property Value

A WPF ImageSource object.

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.PrintOptions Property

DiagramPage.PrintOptions Property
[image]

Print options for individual diagram pages are not used.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new PrintOptions PrintOptions { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property PrintOptions As PrintOptions

Property Value

An instance of the PrintOptions class.

Remarks

Use the PrintOptions property of DiagramDocument to customize appearance of printed multi-page documents.

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.Title Property

DiagramPage.Title Property
[image]

Gets or sets the page title. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage.TitleBrush Property

DiagramPage.TitleBrush Property
[image]

Gets or sets the brush of the title when the title is displayed. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class.

See Also

DiagramPage Members
DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPage Events

DiagramPage Events
[image]

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

DiagramPage Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageEventArgs Class

DiagramPageEventArgs Class
[image]

Contains the arguments passed to DiagramPage-related event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramPageEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DiagramPageEventArgs
MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs

See Also

DiagramPageEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageEventArgs Members

DiagramPageEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to DiagramPage-related event handlers.

The following tables list the members exposed by the DiagramPageEventArgs type.

Public Constructors

Name | Description
DiagramPageEventArgs | Initializes a new instance of the DiagramPageEventArgs class.

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageEventArgs Constructor

DiagramPageEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPageEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageEventArgs Properties

DiagramPageEventArgs Properties
[image]

Public Properties

Name | Description
DiagramPage | Gets the DiagramPage related to the event.

See Also

DiagramPageEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageEventArgs.DiagramPage Property

DiagramPageEventArgs.DiagramPage Property
[image]

Gets the DiagramPage related to the event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPage DiagramPage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramPage As DiagramPage

Property Value

A DiagramPage object.

See Also

DiagramPageEventArgs Members
DiagramPageEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs Class

DiagramPageValidationEventArgs Class
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramPageValidationEventArgs : DiagramPageEventArgs

Visual Basic [image] Copy Code

Public Class DiagramPageValidationEventArgs
Inherits DiagramPageEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DiagramPageEventArgs
MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs

See Also

DiagramPageValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs Members

DiagramPageValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of DiagramPage validation events.

The following tables list the members exposed by the DiagramPageValidationEventArgs type.

Public Constructors

Name | Description
DiagramPageValidationEventArgs | Initializes a new instance of the DiagramPageValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs Constructor

DiagramPageValidationEventArgs Constructor
[image]

Initializes a new instance of the DiagramPageValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPageValidationEventArgs (
DiagramPage diagramPage
)

Visual Basic [image] Copy Code

Public New ( _
diagramPage As DiagramPage _
)

Parameters

diagramPage

The DiagramPage related to the event.

See Also

DiagramPageValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs Properties

DiagramPageValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
DiagramPage | Gets the DiagramPage related to the event. (Inherited from DiagramPageEventArgs.)

See Also

DiagramPageValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPageValidationEventArgs.Cancel Property

DiagramPageValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to confirm it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

DiagramPageValidationEventArgs Members
DiagramPageValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Class

DiagramPaginator Class
[image]

Implements pagination of a Diagram document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramPaginator : DocumentPaginator

Visual Basic [image] Copy Code

Public Class DiagramPaginator
Inherits DocumentPaginator

Inheritance Hierarchy

System.Object
System.Windows.Documents.DocumentPaginator
MindFusion.Diagramming.Wpf.DiagramPaginator

See Also

DiagramPaginator Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Members

DiagramPaginator Members
Constructors Properties Methods
[image]

Implements pagination of a Diagram document.

The following tables list the members exposed by the DiagramPaginator type.

Public Constructors

Name | Description
DiagramPaginator | Overloaded.

Public Properties

Name | Description
IsPageCountValid | Override DocumentPaginator.IsPageCountValid
PageCount | Override DocumentPaginator.PageCount
PageSize | Override DocumentPaginator.PageSize
Source | Override DocumentPaginator.Source

Public Methods

Name | Description
GetPage | Override DocumentPaginator.GetPage(int pageNumber)
GetPageRect | Returns the coordinates of the diagram region that is contained within a page.

See Also

DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Constructor

DiagramPaginator Constructor
[image]

Overload List

Name | Description
DiagramPaginator (Diagram) | Initializes a new instance of the DiagramPaginator class.
DiagramPaginator (Diagram, PrintOptions) | Initializes a new instance of the DiagramPaginator class.

See Also

DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Constructor (Diagram)

DiagramPaginator Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramPaginator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPaginator (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram that will be printed or exported.

See Also

DiagramPaginator Constructor Overload List
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Constructor (Diagram, PrintOptions)

DiagramPaginator Constructor (Diagram, PrintOptions)
See Also
[image]

Initializes a new instance of the DiagramPaginator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPaginator (
Diagram diagram,
PrintOptions printOptions
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
printOptions As PrintOptions _
)

Parameters

diagram

The Diagram that will be printed or exported.

printOptions

An instance of the PrintOptions class.

See Also

DiagramPaginator Constructor Overload List
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Methods

DiagramPaginator Methods
[image]

Public Methods

Name | Description
GetPage | Override DocumentPaginator.GetPage(int pageNumber)
GetPageRect | Returns the coordinates of the diagram region that is contained within a page.

See Also

DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.GetPage Method

DiagramPaginator.GetPage Method
[image]

Override DocumentPaginator.GetPage(int pageNumber)

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DocumentPage GetPage (
int pageNumber
)

Visual Basic [image] Copy Code

Public Overrides Function GetPage( _
pageNumber As Integer _
) As DocumentPage

Parameters

pageNumber

Return Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.GetPageRect Method

DiagramPaginator.GetPageRect Method
[image]

Returns the coordinates of the diagram region that is contained within a page.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetPageRect (
int pageNumber
)

Visual Basic [image] Copy Code

Public Function GetPageRect( _
pageNumber As Integer _
) As Rect

Parameters

pageNumber

Return Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator Properties

DiagramPaginator Properties
[image]

Public Properties

Name | Description
IsPageCountValid | Override DocumentPaginator.IsPageCountValid
PageCount | Override DocumentPaginator.PageCount
PageSize | Override DocumentPaginator.PageSize
Source | Override DocumentPaginator.Source

See Also

DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.IsPageCountValid Property

DiagramPaginator.IsPageCountValid Property
[image]

Override DocumentPaginator.IsPageCountValid

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool IsPageCountValid { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property IsPageCountValid As Boolean

Property Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.PageCount Property

DiagramPaginator.PageCount Property
[image]

Override DocumentPaginator.PageCount

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int PageCount { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property PageCount As Integer

Property Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.PageSize Property

DiagramPaginator.PageSize Property
[image]

Override DocumentPaginator.PageSize

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property PageSize As Size

Property Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramPaginator.Source Property

DiagramPaginator.Source Property
[image]

Override DocumentPaginator.Source

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override IDocumentPaginatorSource Source { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Source As IDocumentPaginatorSource

Property Value

See Also

DiagramPaginator Members
DiagramPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Class

DiagramTabControl Class
[image]

Represents a TabControl that displays DiagramTabItem items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramTabControl : TabControl

Visual Basic [image] Copy Code

Public Class DiagramTabControl
Inherits TabControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.TabControl
MindFusion.Diagramming.Wpf.DiagramTabControl

See Also

DiagramTabControl Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Members

DiagramTabControl Members
Constructors Fields Properties Methods
[image]

Represents a TabControl that displays DiagramTabItem items.

The following tables list the members exposed by the DiagramTabControl type.

Public Constructors

Name | Description
DiagramTabControl | Initializes a new instance of the DiagramTabControl class.

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowReorderProperty | Identifies the AllowReorder dependency property.
ShowCloseButtonsProperty | Identifies the ShowCloseButtons dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.

Public Properties

Name | Description
AllowRenamePages | Gets or sets a value indicating whether tabs can be renamed.
AllowReorder | Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.
ShowCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | TabControl.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | TabControl.GetContainerForItemOverride override.
OnItemsChanged | TabControl.OnItemsChanged override.
OnItemsSourceChanged | TabControl.OnItemsSourceChanged override.
OnPageRenamed | Raises the PageRenamed event.
OnPreviewMouseLeftButtonDown | TabControl.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseLeftButtonUp | TabControl.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseMove | TabControl.OnPreviewMouseMove override.
OnSelectionChanged | TabControl.OnSelectionChanged override.
PrepareContainerForItemOverride | TabControl.PrepareContainerForItemOverride override.

See Also

DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Fields

DiagramTabControl Fields
[image]

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowReorderProperty | Identifies the AllowReorder dependency property.
ShowCloseButtonsProperty | Identifies the ShowCloseButtons dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.

See Also

DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.AllowRenamePagesProperty Field

DiagramTabControl.AllowRenamePagesProperty Field
[image]

Identifies the AllowRenamePages dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowRenamePagesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowRenamePagesProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.AllowReorderProperty Field

DiagramTabControl.AllowReorderProperty Field
[image]

Identifies the AllowReorder dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowReorderProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowCloseButtonsProperty Field

DiagramTabControl.ShowCloseButtonsProperty Field
[image]

Identifies the ShowCloseButtons dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCloseButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCloseButtonsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowCreateNewTabProperty Field

DiagramTabControl.ShowCreateNewTabProperty Field
[image]

Identifies the ShowCreateNewTab dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCreateNewTabProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCreateNewTabProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowNavigationButtonsProperty Field

DiagramTabControl.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowTabsProperty Field

DiagramTabControl.ShowTabsProperty Field
[image]

Identifies the ShowTabs dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabsProperty As DependencyProperty

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Constructor

DiagramTabControl Constructor
[image]

Initializes a new instance of the DiagramTabControl class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramTabControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Methods

DiagramTabControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | TabControl.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | TabControl.GetContainerForItemOverride override.
OnItemsChanged | TabControl.OnItemsChanged override.
OnItemsSourceChanged | TabControl.OnItemsSourceChanged override.
OnPageRenamed | Raises the PageRenamed event.
OnPreviewMouseLeftButtonDown | TabControl.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseLeftButtonUp | TabControl.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseMove | TabControl.OnPreviewMouseMove override.
OnSelectionChanged | TabControl.OnSelectionChanged override.
PrepareContainerForItemOverride | TabControl.PrepareContainerForItemOverride override.

See Also

DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.GetContainerForItemOverride Method

DiagramTabControl.GetContainerForItemOverride Method
[image]

TabControl.GetContainerForItemOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overrides Function GetContainerForItemOverride () As DependencyObject

Return Value

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnApplyTemplate Method

DiagramTabControl.OnApplyTemplate Method
[image]

TabControl.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnItemsChanged Method

DiagramTabControl.OnItemsChanged Method
[image]

TabControl.OnItemsChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnItemsChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnItemsChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnItemsSourceChanged Method

DiagramTabControl.OnItemsSourceChanged Method
[image]

TabControl.OnItemsSourceChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnItemsSourceChanged (
IEnumerable oldValue,
IEnumerable newValue
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnItemsSourceChanged( _
oldValue As IEnumerable, _
newValue As IEnumerable _
)

Parameters

oldValue

newValue

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnPageRenamed Method

DiagramTabControl.OnPageRenamed Method
[image]

Raises the PageRenamed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPageRenamed (
PageRenamedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRenamed( _
e As PageRenamedEventArgs _
)

Parameters

e

A PageRenamedEventArgs instance providing more information about the event.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnPreviewMouseLeftButtonDown Method

DiagramTabControl.OnPreviewMouseLeftButtonDown Method
[image]

TabControl.OnPreviewMouseLeftButtonDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnPreviewMouseLeftButtonUp Method

DiagramTabControl.OnPreviewMouseLeftButtonUp Method
[image]

TabControl.OnPreviewMouseLeftButtonUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnPreviewMouseMove Method

DiagramTabControl.OnPreviewMouseMove Method
[image]

TabControl.OnPreviewMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.OnSelectionChanged Method

DiagramTabControl.OnSelectionChanged Method
[image]

TabControl.OnSelectionChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnSelectionChanged (
SelectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnSelectionChanged( _
e As SelectionChangedEventArgs _
)

Parameters

e

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.PrepareContainerForItemOverride Method

DiagramTabControl.PrepareContainerForItemOverride Method
[image]

TabControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overrides Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

item

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl Properties

DiagramTabControl Properties
[image]

Public Properties

Name | Description
AllowRenamePages | Gets or sets a value indicating whether tabs can be renamed.
AllowReorder | Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.
ShowCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

See Also

DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.AllowRenamePages Property

DiagramTabControl.AllowRenamePages Property
[image]

Gets or sets a value indicating whether tabs can be renamed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowRenamePages { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRenamePages As Boolean

Property Value

true if the user is allowed to rename tabs interactively, or false otherwise.

Remarks

To rename a tab, click to activate it first, and then click a second time to show its in-place edit text control.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.AllowReorder Property

DiagramTabControl.AllowReorder Property
[image]

Gets or sets a value indicating whether interactive reordering of tabs is allowed. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowReorder As Boolean

Property Value

true to allow interactive tab reordering; otherwise, false. The default is false.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowCloseButtons Property

DiagramTabControl.ShowCloseButtons Property
[image]

Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowCloseButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCloseButtons As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowCreateNewTab Property

DiagramTabControl.ShowCreateNewTab Property
[image]

Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowCreateNewTab { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCreateNewTab As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowNavigationButtons Property

DiagramTabControl.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to enable tab navigation; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabControl.ShowTabs Property

DiagramTabControl.ShowTabs Property
[image]

Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowTabs { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabs As Boolean

Property Value

true to display the tabs tray; otherwise, false. The default is true.

See Also

DiagramTabControl Members
DiagramTabControl Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Class

DiagramTabItem Class
[image]

Represents a tab item in a DiagramTabControl.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramTabItem : TabItem

Visual Basic [image] Copy Code

Public Class DiagramTabItem
Inherits TabItem

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.HeaderedContentControl
System.Windows.Controls.TabItem
MindFusion.Diagramming.Wpf.DiagramTabItem

See Also

DiagramTabItem Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Members

DiagramTabItem Members
Constructors Fields Properties Methods
[image]

Represents a tab item in a DiagramTabControl.

The following tables list the members exposed by the DiagramTabItem type.

Public Constructors

Name | Description
DiagramTabItem | Initializes a new instance of the DiagramTabItem class.

Public Fields

Name | Description
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.

Public Properties

Name | Description
ShowCloseButton | Gets or sets a value indicating whether the close button is visible. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Fields

DiagramTabItem Fields
[image]

Public Fields

Name | Description
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.

See Also

DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem.ShowCloseButtonProperty Field

DiagramTabItem.ShowCloseButtonProperty Field
[image]

Identifies the ShowCloseButton dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCloseButtonProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCloseButtonProperty As DependencyProperty

See Also

DiagramTabItem Members
DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Constructor

DiagramTabItem Constructor
[image]

Initializes a new instance of the DiagramTabItem class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramTabItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Methods

DiagramTabItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem.OnApplyTemplate Method

DiagramTabItem.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DiagramTabItem Members
DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem Properties

DiagramTabItem Properties
[image]

Public Properties

Name | Description
ShowCloseButton | Gets or sets a value indicating whether the close button is visible. This is a dependency property.

See Also

DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramTabItem.ShowCloseButton Property

DiagramTabItem.ShowCloseButton Property
[image]

Gets or sets a value indicating whether the close button is visible. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowCloseButton { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCloseButton As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

See Also

DiagramTabItem Members
DiagramTabItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Class

DiagramView Class
Remarks See Also
[image]

DiagramView allows displaying more than one views of the content of the same Diagram instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramView : ScrollViewer, IZoomTarget

Visual Basic [image] Copy Code

Public Class DiagramView
Inherits ScrollViewer
Implements IZoomTarget

Remarks

The DiagramView class lets you display several views of the same diagram, each having distinct zoom level and scroll position. You can assign the shared Diagram object to the Diagram property of the views, either programmatically, e.g. from a Window_Loaded event handler, or by using databinding syntax in Xaml.

Since a Diagram is a WPF Visual on its own, it can be a child of only one parent element in the WPF visual tree. As a consequence, only one DiagramView contains the actual Diagram instance, while all other views bound to it use a VisualBrush to render it. In order to receive input events, the actual Diagram could be moved to a different DiagramView when that view is clicked. This can also be done programmatically by calling the ActivateView method.

The zoom level of individual views can be set through the ZoomFactor property. Their scroll position is set through the ScrollX and ScrollY properties. Use the TransformToDocument method to find the diagram coordinates of a point specified in view coordinates.

A DiagramView could also be used just as a replacement of the WPF ScrollViewer control, even if you don't intend to display multiple views of a shared diagram.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.ScrollViewer
MindFusion.Diagramming.Wpf.DiagramView

See Also

DiagramView Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Members

DiagramView Members
Constructors Fields Properties Methods
[image]

DiagramView allows displaying more than one views of the content of the same Diagram instance.

The following tables list the members exposed by the DiagramView type.

Public Constructors

Name | Description
DiagramView | Creates DiagramView instance

Public Fields

Name | Description
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Properties

Name | Description
Diagram | Gets or sets the Diagram displayed by this view.
InactiveViewOpacity | The opacity of inactive views.
ScrollX | Gets or sets the horizontal scroll position of the Diagram.
ScrollY | Gets or sets the vertical scroll position of the Diagram.
View | A component that renders the diagram inside inactive views.
ZoomFactor | Gets or sets the effective zoom factor used to scale up or down the Diagram.

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.

Public Methods

Name | Description
ActivateView | Moves the actual Diagram to this view.
ClientToDoc | Overloaded. Transforms points from the client coordinate space to the document coordinate space.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
GetActiveView | Overloaded. Returns the active DiagramView displaying the specified Diagram, if any.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
TransformToDocument | Transforms the point from view coordinates to diagram document coordinates.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the view client area.
ZoomToRect | Overloaded.

See Also

DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Fields

DiagramView Fields
[image]

Public Fields

Name | Description
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomFactorProperty Field

DiagramView.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ZoomFactorProperty As DependencyProperty

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Constructor

DiagramView Constructor
[image]

Creates DiagramView instance

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Methods

DiagramView Methods
[image]

Public Methods

Name | Description
ActivateView | Moves the actual Diagram to this view.
ClientToDoc | Overloaded. Transforms points from the client coordinate space to the document coordinate space.
DocToClient | Overloaded. Transforms points from the document coordinate space to the client coordinate space.
GetActiveView | Overloaded. Returns the active DiagramView displaying the specified Diagram, if any.
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point.
TransformToDocument | Transforms the point from view coordinates to diagram document coordinates.
ZoomIn | Zooms document's items thus making them appear closer.
ZoomOut | Zooms the diagram out making items appear further away.
ZoomToFit | Zooms the view to fit the document contents in the view client area.
ZoomToRect | Overloaded.

See Also

DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ActivateView Method

DiagramView.ActivateView Method
[image]

Moves the actual Diagram to this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ActivateView ()

Visual Basic [image] Copy Code

Public Sub ActivateView ()

Remarks

In WPF, a Diagram instance can be a child in the visual tree of only one control. Other views displaying the same diagram contain Rectangle objects that render the diagram through a VisualBrush. In order to receive input events from the diagram, a view must be activated either by the user clicking it, or through this method.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace
GetActiveView Method
InactiveViewOpacity Property


MindFusion.Diagramming.Wpf.DiagramView.ClientToDoc Method

DiagramView.ClientToDoc Method
[image]

Transforms points from the client coordinate space to the document coordinate space.

Overload List

Name | Description
DiagramView.ClientToDoc (Point) | Transforms points from the client coordinate space to the document coordinate space.
DiagramView.ClientToDoc (Rect) | Transforms points from the client coordinate space to the document coordinate space.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ClientToDoc Method (Point)

DiagramView.ClientToDoc Method (Point)
See Also
[image]

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point ClientToDoc (
Point clientPoint
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientPoint As Point _
) As Point

Parameters

clientPoint

An instance of the .NET Point structure, whose coordinates should be transformed and returned.

Return Value

A .NET Point instance, which represents the document coordinates of clientPoint.

Remarks

This method is useful when the document coordinates of a device point are needed.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ClientToDoc Method (Rect)

DiagramView.ClientToDoc Method (Rect)
See Also
[image]

Transforms points from the client coordinate space to the document coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect ClientToDoc (
Rect clientRect
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientRect As Rect _
) As Rect

Parameters

clientRect

An instance of the .NET Rect structure, whose coordinates should be transformed and returned.

Return Value

A .NET Rect instance, which represents the document coordinates of clientRect.

Remarks

This method is useful when the document coordinates of a rectangle are needed.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.DocToClient Method

DiagramView.DocToClient Method
[image]

Transforms points from the document coordinate space to the client coordinate space.

Overload List

Name | Description
DiagramView.DocToClient (Point) | Transforms points from the document coordinate space to the client coordinate space.
DiagramView.DocToClient (Rect) | Converts the specified rectangle from document to client coordinates.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.DocToClient Method (Point)

DiagramView.DocToClient Method (Point)
See Also
[image]

Transforms points from the document coordinate space to the client coordinate space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point DocToClient (
Point docPoint
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docPoint As Point _
) As Point

Parameters

docPoint

An instance of the .NET Point structure, whose coordinates should be transformed and returned.

Return Value

A Point instance, which represents the client coordinates of docPoint.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.DocToClient Method (Rect)

DiagramView.DocToClient Method (Rect)
See Also
[image]

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect DocToClient (
Rect docRect
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docRect As Rect _
) As Rect

Parameters

docRect

An instance of the .NET Rect structure, whose coordinates should be transformed and returned.

Return Value

A Rect instance, which represents the client coordinates of docRect.

Remarks

This method is useful when the client (device) coordinates of a diagram location are needed.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.GetActiveView Method

DiagramView.GetActiveView Method
[image]

Returns the active DiagramView displaying the specified Diagram, if any.

Overload List

Name | Description
DiagramView.GetActiveView () | Returns the active DiagramView displaying this view's Diagram, if any.
DiagramView.GetActiveView (Diagram) | Returns the active DiagramView displaying the specified Diagram, if any.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace
ActivateView Method


MindFusion.Diagramming.Wpf.DiagramView.GetActiveView Method ()

DiagramView.GetActiveView Method ()
See Also
[image]

Returns the active DiagramView displaying this view's Diagram, if any.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramView GetActiveView ()

Visual Basic [image] Copy Code

Public Function GetActiveView () As DiagramView

Return Value

A DiagramView that contains Diagram.

See Also

GetActiveView Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.GetActiveView Method (Diagram)

DiagramView.GetActiveView Method (Diagram)
See Also
[image]

Returns the active DiagramView displaying the specified Diagram, if any.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DiagramView GetActiveView (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function GetActiveView( _
diagram As Diagram _
) As DiagramView

Parameters

diagram
A Diagram instance for which to find its active DiagramView.

Return Value

A DiagramView that contains diagram.

See Also

GetActiveView Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.SetZoomFactor Method

DiagramView.SetZoomFactor Method
[image]

Sets the zoom factor, preserving the on-screen position of the specified diagram point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

The new zoom factor.

pivotPoint

A Point instance specifying the zoom center.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.TransformToDocument Method

DiagramView.TransformToDocument Method
[image]

Transforms the point from view coordinates to diagram document coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point TransformToDocument (
Point viewPos
)

Visual Basic [image] Copy Code

Public Function TransformToDocument( _
viewPos As Point _
) As Point

Parameters

viewPos
A System.Windows.Point instance specifying a view point, in the WPF device-independent coordinate system.

Return Value

A System.Windows.Point specifying the diagram coordinates, in the unit set as MeasureUnit.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomIn Method

DiagramView.ZoomIn Method
[image]

Zooms document's items thus making them appear closer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomIn ()

Visual Basic [image] Copy Code

Public Sub ZoomIn ()

Remarks

Call this method every time you want to make diagram items appear nearer and bigger. It increases the ZoomFactor with 10 each time it executes.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomOut Method

DiagramView.ZoomOut Method
[image]

Zooms the diagram out making items appear further away.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomOut ()

Visual Basic [image] Copy Code

Public Sub ZoomOut ()

Remarks

Call this method if you want to make the diagram items appear further and smaller. It decreases the ZoomFactor with 10 each time it executes.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomToFit Method

DiagramView.ZoomToFit Method
[image]

Zooms the view to fit the document contents in the view client area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToFit ()

Visual Basic [image] Copy Code

Public Sub ZoomToFit ()

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomToRect Method

DiagramView.ZoomToRect Method
[image]

Overload List

Name | Description
DiagramView.ZoomToRect (Rect) | Zooms and scrolls the view to fit the specified document rectangle in the viewport.
DiagramView.ZoomToRect (Rect, Boolean) | Zooms and scrolls the view to fit the specified document rectangle in the viewport.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomToRect Method (Rect)

DiagramView.ZoomToRect Method (Rect)
See Also
[image]

Zooms and scrolls the view to fit the specified document rectangle in the viewport.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToRect (
Rect rect
)

Visual Basic [image] Copy Code

Public Sub ZoomToRect( _
rect As Rect _
)

Parameters

rect

See Also

ZoomToRect Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomToRect Method (Rect, Boolean)

DiagramView.ZoomToRect Method (Rect, Boolean)
See Also
[image]

Zooms and scrolls the view to fit the specified document rectangle in the viewport.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ZoomToRect (
Rect rect,
bool centered
)

Visual Basic [image] Copy Code

Public Sub ZoomToRect( _
rect As Rect, _
centered As Boolean _
)

Parameters

rect

centered

See Also

ZoomToRect Method Overload List
DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView Properties

DiagramView Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the Diagram displayed by this view.
InactiveViewOpacity | The opacity of inactive views.
ScrollX | Gets or sets the horizontal scroll position of the Diagram.
ScrollY | Gets or sets the vertical scroll position of the Diagram.
View | A component that renders the diagram inside inactive views.
ZoomFactor | Gets or sets the effective zoom factor used to scale up or down the Diagram.

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.

See Also

DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.Diagram Property

DiagramView.Diagram Property
[image]

Gets or sets the Diagram displayed by this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

Remarks

It is possible to display several views of the same diagram by assigning a shared Diagram object to multiple DiagramView objects.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.DocumentToDiagramMatrix Property

DiagramView.DocumentToDiagramMatrix Property
[image]

Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual Matrix DocumentToDiagramMatrix { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property DocumentToDiagramMatrix As Matrix

Property Value

A System.Windows.Media.Matrix instance representing the current transformation.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.InactiveViewOpacity Property

DiagramView.InactiveViewOpacity Property
[image]

The opacity of inactive views.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double InactiveViewOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property InactiveViewOpacity As Double

Property Value

A double value specifying the opacity of inactive views. The default value is 0.5.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace
ActivateView Method


MindFusion.Diagramming.Wpf.DiagramView.ScrollX Property

DiagramView.ScrollX Property
[image]

Gets or sets the horizontal scroll position of the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Double

Property Value

A double value specifying the horizontal scroll position in the current units of measure. The default is 0, indicating the left corner.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace
ScrollY Property


MindFusion.Diagramming.Wpf.DiagramView.ScrollY Property

DiagramView.ScrollY Property
[image]

Gets or sets the vertical scroll position of the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Double

Property Value

A double value specifying the vertical scroll position in the current units of measure. The default is 0, indicating the top corner.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace
ScrollX Property


MindFusion.Diagramming.Wpf.DiagramView.View Property

DiagramView.View Property
[image]

A component that renders the diagram inside inactive views.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rectangle View { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property View As Rectangle

Property Value

A System.Windows.Shapes.Rectangle that display the Diagram content using a VisualBrush.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView.ZoomFactor Property

DiagramView.ZoomFactor Property
[image]

Gets or sets the effective zoom factor used to scale up or down the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying percent of the original diagram size. The default is 100.

Remarks

This property overrides the ZoomFactor of the hosted Diagram, so changing the latter for a Diagram inside a DiagramView will not cause visual change.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Class

DiagramView3D Class
Remarks See Also
[image]

Displays the elements of a Diagram in 3D space.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DiagramView3D : Control

Visual Basic [image] Copy Code

Public Class DiagramView3D
Inherits Control

Remarks

Assign the Diagram that should be displayed in this view to the Diagram property. DiagramView3D adds a 3D model to the scene for each node or link of the specified diagram. The positions of nodes in 3D coordinate space are specified via the Position3D attached property. Links are rendered as straight lines connecting the 3D node models. By default, nodes always face the camera, unless NodeRotationType is set to None.

The following mouse and keyboard actions allow moving the camera around the 3D scene:

  • Mouse drag: Moves the camera across the plane orthogonal to direction of the camera.
  • CTRL+mouse drag: Orbits the camera around its focus point.
  • Mouse wheel: Moves the camera forwards or backwards along its look direction.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramView3D

See Also

DiagramView3D Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Members

DiagramView3D Members
Constructors Fields Attached Properties Properties Methods
[image]

Displays the elements of a Diagram in 3D space.

The following tables list the members exposed by the DiagramView3D type.

Public Constructors

Name | Description
DiagramView3D | Initializes a new instance of the DiagramView3D class.

Public Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
CameraTypeProperty | Identifies the CameraType dependency property.
DiagramProperty | Identifies the Diagram dependency property.
LightsProperty | Identifies the Lights dependency property.
LinkScalingModeProperty | Identifies the LinkScalingMode dependency property.
LinkThicknessProperty | Identifies the LinkThickness dependency property.
NodeRotationTypeProperty | Identifies the NodeRotationType dependency property.
NodeThicknessProperty | Identifies the NodeThickness dependency property.
Position3DProperty | Identifies the Position3D dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
RotationAxisProperty | Identifies the RotationAxis dependency property.
ScaleProperty | Identifies the Scale dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property.

Public Attached Properties

Name | Description
Position3DProperty |

Public Properties

Name | Description
AnimationDuration | Gets or sets the duration of animations in this view.
CameraType | Gets or sets the projection type of the camera.
Diagram | Gets ot sets the Diagram that should be displayed in this view.
Lights | Gets or sets a list of lights sources in the 3D scene.
LinkScalingMode | Gets or sets the scaling mode of link models.
LinkThickness | Gets or sets the 3D thickness of link models in this view.
NodeRotationType | Gets or sets whether nodes should rotate to face the camera.
NodeThickness | Gets or sets the 3D thickness of node models in this view.
RotationAngle | Gets or sets the angle of rotation for the view.
RotationAxis | Gets or sets the axis of rotation of the view.
Scale | Gets or sets the scale factor of this view.
StaticLights | Gets or sets a list of static light sources in the 3D scene.

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
EndInit | FrameworkElement.EndInit override.
GetParent3D | Gets the 3D parent of a node.
GetPosition3D | Gets the 3D position of a node.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetParent3D | Sets the 3D parent of a node.
SetPosition3D | Sets the 3D position of a node.

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Fields

DiagramView3D Fields
[image]

Public Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
CameraTypeProperty | Identifies the CameraType dependency property.
DiagramProperty | Identifies the Diagram dependency property.
LightsProperty | Identifies the Lights dependency property.
LinkScalingModeProperty | Identifies the LinkScalingMode dependency property.
LinkThicknessProperty | Identifies the LinkThickness dependency property.
NodeRotationTypeProperty | Identifies the NodeRotationType dependency property.
NodeThicknessProperty | Identifies the NodeThickness dependency property.
Position3DProperty | Identifies the Position3D dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property.
RotationAxisProperty | Identifies the RotationAxis dependency property.
ScaleProperty | Identifies the Scale dependency property.
StaticLightsProperty | Identifies the StaticLights dependency property.

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.AnimationDurationProperty Field

DiagramView3D.AnimationDurationProperty Field
[image]

Identifies the AnimationDuration dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnimationDurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnimationDurationProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.CameraTypeProperty Field

DiagramView3D.CameraTypeProperty Field
[image]

Identifies the CameraType dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CameraTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CameraTypeProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.DiagramProperty Field

DiagramView3D.DiagramProperty Field
[image]

Identifies the Diagram dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DiagramProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DiagramProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.LightsProperty Field

DiagramView3D.LightsProperty Field
[image]

Identifies the Lights dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LightsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LightsProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.LinkScalingModeProperty Field

DiagramView3D.LinkScalingModeProperty Field
[image]

Identifies the LinkScalingMode dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LinkScalingModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LinkScalingModeProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.LinkThicknessProperty Field

DiagramView3D.LinkThicknessProperty Field
[image]

Identifies the LinkThickness dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LinkThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LinkThicknessProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.NodeRotationTypeProperty Field

DiagramView3D.NodeRotationTypeProperty Field
[image]

Identifies the NodeRotationType dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NodeRotationTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NodeRotationTypeProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.NodeThicknessProperty Field

DiagramView3D.NodeThicknessProperty Field
[image]

Identifies the NodeThickness dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NodeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NodeThicknessProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Position3DProperty Field

DiagramView3D.Position3DProperty Field
[image]

Identifies the Position3D dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Position3DProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Position3DProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.RotationAngleProperty Field

DiagramView3D.RotationAngleProperty Field
[image]

Identifies the RotationAngle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotationAngleProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.RotationAxisProperty Field

DiagramView3D.RotationAxisProperty Field
[image]

Identifies the RotationAxis dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotationAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotationAxisProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.ScaleProperty Field

DiagramView3D.ScaleProperty Field
[image]

Identifies the Scale dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.StaticLightsProperty Field

DiagramView3D.StaticLightsProperty Field
[image]

Identifies the StaticLights dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StaticLightsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StaticLightsProperty As DependencyProperty

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Constructor

DiagramView3D Constructor
[image]

Initializes a new instance of the DiagramView3D class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramView3D ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Methods

DiagramView3D Methods
[image]

Public Methods

Name | Description
BeginInit | FrameworkElement.BeginInit override.
EndInit | FrameworkElement.EndInit override.
GetParent3D | Gets the 3D parent of a node.
GetPosition3D | Gets the 3D position of a node.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetParent3D | Sets the 3D parent of a node.
SetPosition3D | Sets the 3D position of a node.

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.BeginInit Method

DiagramView3D.BeginInit Method
[image]

FrameworkElement.BeginInit override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.EndInit Method

DiagramView3D.EndInit Method
[image]

FrameworkElement.EndInit override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.GetParent3D Method

DiagramView3D.GetParent3D Method
[image]

Gets the 3D parent of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Control GetParent3D (
DiagramNode element
)

Visual Basic [image] Copy Code

Public Shared Function GetParent3D( _
element As DiagramNode _
) As Control

Parameters

element

Return Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.GetPosition3D Method

DiagramView3D.GetPosition3D Method
[image]

Gets the 3D position of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point3D GetPosition3D (
DiagramNode element
)

Visual Basic [image] Copy Code

Public Shared Function GetPosition3D( _
element As DiagramNode _
) As Point3D

Parameters

element

Return Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.OnApplyTemplate Method

DiagramView3D.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.SetParent3D Method

DiagramView3D.SetParent3D Method
[image]

Sets the 3D parent of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetParent3D (
DiagramNode element,
Control value
)

Visual Basic [image] Copy Code

Public Shared Sub SetParent3D( _
element As DiagramNode, _
value As Control _
)

Parameters

element

value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.SetPosition3D Method

DiagramView3D.SetPosition3D Method
[image]

Sets the 3D position of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetPosition3D (
DiagramNode element,
Point3D value
)

Visual Basic [image] Copy Code

Public Shared Sub SetPosition3D( _
element As DiagramNode, _
value As Point3D _
)

Parameters

element

value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Attached Properties

DiagramView3D Attached Properties
[image]

Public Attached Properties

Name | Description
Position3DProperty |

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Parent3D Attached Property

DiagramView3D.Parent3D Attached Property
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code
See DiagramView3D.GetParent3D, DiagramView3D.SetParent3D
Visual Basic [image] Copy Code
See DiagramView3D.GetParent3D, DiagramView3D.SetParent3D

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Position3D Attached Property

DiagramView3D.Position3D Attached Property
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code
See DiagramView3D.GetPosition3D, DiagramView3D.SetPosition3D
Visual Basic [image] Copy Code
See DiagramView3D.GetPosition3D, DiagramView3D.SetPosition3D

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D Properties

DiagramView3D Properties
[image]

Public Properties

Name | Description
AnimationDuration | Gets or sets the duration of animations in this view.
CameraType | Gets or sets the projection type of the camera.
Diagram | Gets ot sets the Diagram that should be displayed in this view.
Lights | Gets or sets a list of lights sources in the 3D scene.
LinkScalingMode | Gets or sets the scaling mode of link models.
LinkThickness | Gets or sets the 3D thickness of link models in this view.
NodeRotationType | Gets or sets whether nodes should rotate to face the camera.
NodeThickness | Gets or sets the 3D thickness of node models in this view.
RotationAngle | Gets or sets the angle of rotation for the view.
RotationAxis | Gets or sets the axis of rotation of the view.
Scale | Gets or sets the scale factor of this view.
StaticLights | Gets or sets a list of static light sources in the 3D scene.

See Also

DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.AnimationDuration Property

DiagramView3D.AnimationDuration Property
[image]

Gets or sets the duration of animations in this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Duration AnimationDuration { get; set; }

Visual Basic [image] Copy Code

Public Property AnimationDuration As Duration

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.CameraType Property

DiagramView3D.CameraType Property
[image]

Gets or sets the projection type of the camera.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CameraType CameraType { get; set; }

Visual Basic [image] Copy Code

Public Property CameraType As CameraType

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Diagram Property

DiagramView3D.Diagram Property
[image]

Gets ot sets the Diagram that should be displayed in this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Lights Property

DiagramView3D.Lights Property
[image]

Gets or sets a list of lights sources in the 3D scene.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Light> Lights { get; set; }

Visual Basic [image] Copy Code

Public Property Lights As ObservableCollection(Of Light)

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.LinkScalingMode Property

DiagramView3D.LinkScalingMode Property
[image]

Gets or sets the scaling mode of link models.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScalingMode LinkScalingMode { get; set; }

Visual Basic [image] Copy Code

Public Property LinkScalingMode As ScalingMode

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.LinkThickness Property

DiagramView3D.LinkThickness Property
[image]

Gets or sets the 3D thickness of link models in this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LinkThickness As Double

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.NodeRotationType Property

DiagramView3D.NodeRotationType Property
[image]

Gets or sets whether nodes should rotate to face the camera.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeRotationType NodeRotationType { get; set; }

Visual Basic [image] Copy Code

Public Property NodeRotationType As NodeRotationType

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.NodeThickness Property

DiagramView3D.NodeThickness Property
[image]

Gets or sets the 3D thickness of node models in this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property NodeThickness As Double

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.RotationAngle Property

DiagramView3D.RotationAngle Property
[image]

Gets or sets the angle of rotation for the view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.RotationAxis Property

DiagramView3D.RotationAxis Property
[image]

Gets or sets the axis of rotation of the view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Vector3D RotationAxis { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAxis As Vector3D

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.Scale Property

DiagramView3D.Scale Property
[image]

Gets or sets the scale factor of this view.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DiagramView3D.StaticLights Property

DiagramView3D.StaticLights Property
[image]

Gets or sets a list of static light sources in the 3D scene.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Light> StaticLights { get; set; }

Visual Basic [image] Copy Code

Public Property StaticLights As ObservableCollection(Of Light)

Property Value

See Also

DiagramView3D Members
DiagramView3D Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DirectionConstraint Enumeration

DirectionConstraint Enumeration
[image]

Defines values that specify in what direction to constrain node movement.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum DirectionConstraint

Visual Basic [image] Copy Code

Public Enum DirectionConstraint

Members

Member name | Description
Horizontal | Users are allowed to move the node horizontally.
None | No restrictions.
Vertical | Users are allowed to move the node vertically.

Remarks

Values from this enumeration can be assigned to the MoveDirection property of the NodeConstraints class.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter Class

DoubleToRectConverter Class
[image]

Converts double values to Rect structures.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DoubleToRectConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class DoubleToRectConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DoubleToRectConverter

See Also

DoubleToRectConverter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter Members

DoubleToRectConverter Members
Constructors Methods
[image]

Converts double values to Rect structures.

The following tables list the members exposed by the DoubleToRectConverter type.

Public Constructors

Name | Description
DoubleToRectConverter |

Public Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.

See Also

DoubleToRectConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter Constructor

DoubleToRectConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DoubleToRectConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DoubleToRectConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter Methods

DoubleToRectConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.

See Also

DoubleToRectConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter.Convert Method

DoubleToRectConverter.Convert Method
[image]

Converts a value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value.

See Also

DoubleToRectConverter Members
DoubleToRectConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DoubleToRectConverter.ConvertBack Method

DoubleToRectConverter.ConvertBack Method
[image]

Converts a value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value that is produced by the binding target.

targetType

The type to convert to.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value.

See Also

DoubleToRectConverter Members
DoubleToRectConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedNode Class

DraggedNode Class
[image]

Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DraggedNode

Visual Basic [image] Copy Code

Public Class DraggedNode

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DraggedNode

See Also

DraggedNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedNode Members

DraggedNode Members
Constructors Properties
[image]

Class used to hold the DiagramNode instance during drag and drop. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.

The following tables list the members exposed by the DraggedNode type.

Public Constructors

Name | Description
DraggedNode |

Public Properties

Name | Description
Node | Holds the dragged DiagramNode

See Also

DraggedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedNode Constructor

DraggedNode Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DraggedNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DraggedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedNode Properties

DraggedNode Properties
[image]

Public Properties

Name | Description
Node | Holds the dragged DiagramNode

See Also

DraggedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedNode.Node Property

DraggedNode.Node Property
[image]

Holds the dragged DiagramNode

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

DraggedNode Members
DraggedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape Class

DraggedShape Class
[image]

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DraggedShape

Visual Basic [image] Copy Code

Public Class DraggedShape

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DraggedShape

See Also

DraggedShape Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape Members

DraggedShape Members
Constructors Properties
[image]

Contains drag-and-drop information for a shape being dragged from ShapeToolBar and ShapeListBox.

The following tables list the members exposed by the DraggedShape type.

Public Constructors

Name | Description
DraggedShape | Initializes a new instance of the DraggedShape class.

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape Constructor

DraggedShape Constructor
[image]

Initializes a new instance of the DraggedShape class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DraggedShape (
string id,
Size size
)

Visual Basic [image] Copy Code

Public New ( _
id As String, _
size As Size _
)

Parameters

id
The Id of the dragged shape.
size

The recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape Properties

DraggedShape Properties
[image]

Public Properties

Name | Description
Id | Gets the Id of the dragged shape.
Size | Gets the recommended size of the dragged shape.

See Also

DraggedShape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape.Id Property

DraggedShape.Id Property
[image]

Gets the Id of the dragged shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

A string specifying the identifier of the dragged shape.

See Also

DraggedShape Members
DraggedShape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DraggedShape.Size Property

DraggedShape.Size Property
[image]

Gets the recommended size of the dragged shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Size

Property Value

Remarks

A System.Windows.Size instance specifying the recommended size for the shape.

See Also

DraggedShape Members
DraggedShape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs Class

DrawAnchorPointEventArgs Class
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawAnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawAnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs

See Also

DrawAnchorPointEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs Members

DrawAnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

The following tables list the members exposed by the DrawAnchorPointEventArgs type.

Public Constructors

Name | Description
DrawAnchorPointEventArgs | Initializes a new instance of the DrawAnchorPointEventArgs class.

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
AnchorPoint | Gets the anchor point being drawn.
Graphics | Gets a DrawingContext in which the anchor point mark should be drawn.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs Constructor

DrawAnchorPointEventArgs Constructor
[image]

Initializes a new instance of the DrawAnchorPointEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawAnchorPointEventArgs (
DrawingContext graphics,
Point location,
DiagramNode node,
AnchorPattern anchorPattern,
int anchorIndex
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext, _
location As Point, _
node As DiagramNode, _
anchorPattern As AnchorPattern, _
anchorIndex As Integer _
)

Parameters

graphics

The DrawingContext object that represents the target of the drawing operation.

location

The position of the anchor point, expressed in document coordinates.

node

The DiagramNode related to the event.

anchorPattern

The AnchorPattern object whose point is being drawn.

anchorIndex

The zero-based index of the anchor point being drawn within its anchor pattern.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs Properties

DrawAnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
AnchorPoint | Gets the anchor point being drawn.
Graphics | Gets a DrawingContext in which the anchor point mark should be drawn.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.AnchorIndex Property

DrawAnchorPointEventArgs.AnchorIndex Property
[image]

Gets the index of the anchor point within its containing pattern.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the index of an anchor point within an AnchorPattern.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.AnchorPattern Property

DrawAnchorPointEventArgs.AnchorPattern Property
[image]

Gets the anchor pattern containing the anchor point being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.AnchorPoint Property

DrawAnchorPointEventArgs.AnchorPoint Property
[image]

Gets the anchor point being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPoint AnchorPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorPoint As AnchorPoint

Property Value

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.Graphics Property

DrawAnchorPointEventArgs.Graphics Property
[image]

Gets a DrawingContext in which the anchor point mark should be drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

Remarks

A System.Windows.Media.DrawingContext instance whose methods should be used to draw the anchor point mark.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.Location Property

DrawAnchorPointEventArgs.Location Property
[image]

Gets the location of the anchor point being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Point

Property Value

An instance of the Point structure.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawAnchorPointEventArgs.Node Property

DrawAnchorPointEventArgs.Node Property
[image]

Gets the node whose anchor point is being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs Class

DrawCellEventArgs Class
[image]

Contains the arguments passed to the DrawCell event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawCellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawCellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DrawCellEventArgs

See Also

DrawCellEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs Members

DrawCellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawCell event handlers.

The following tables list the members exposed by the DrawCellEventArgs type.

Public Constructors

Name | Description
DrawCellEventArgs | Initializes a new instance of the DrawCellEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | Gets a DrawingContext object whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs Constructor

DrawCellEventArgs Constructor
[image]

Initializes a new instance of the DrawCellEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawCellEventArgs (
DrawingContext graphics,
TableNode table,
int column,
int row,
Rect bounds
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext, _
table As TableNode, _
column As Integer, _
row As Integer, _
bounds As Rect _
)

Parameters

graphics
The System.Windows.Media.DrawingContext in which to draw.
table
The TableNode related to the event.
column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

bounds

The bounding rectangle of the cell being drawn.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs Properties

DrawCellEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | Gets a DrawingContext object whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Bounds Property

DrawCellEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the cell being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A System.Windows.Rect instance specifying the bounding rectangle of the cell.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Cell Property

DrawCellEventArgs.Cell Property
[image]

Gets the cell that should be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Column Property

DrawCellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Graphics Property

DrawCellEventArgs.Graphics Property
[image]

Gets a DrawingContext object whose methods should be used to draw the cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

An instance of the System.Windows.Media.DrawingContext class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Row Property

DrawCellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawCellEventArgs.Table Property

DrawCellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs Class

DrawItemEventArgs Class
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DrawItemEventArgs

See Also

DrawItemEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs Members

DrawItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

The following tables list the members exposed by the DrawItemEventArgs type.

Public Constructors

Name | Description
DrawItemEventArgs | Initializes a new instance of the DrawItemEventArgs class.

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs Constructor

DrawItemEventArgs Constructor
[image]

Initializes a new instance of the DrawItemEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawItemEventArgs (
DrawingContext graphics,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext, _
item As DiagramItem _
)

Parameters

graphics
The DrawingContext in which to draw.
item
The DiagramItem related to the event.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs Properties

DrawItemEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs.Graphics Property

DrawItemEventArgs.Graphics Property
[image]

Gets a DrawingContext object whose methods should be used to draw the adjustment handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

An instance of the System.Windows.Media.DrawingContext class.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawItemEventArgs.Item Property

DrawItemEventArgs.Item Property
[image]

Gets the item whose selection handles are being drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs Class

DrawLinkEventArgs Class
[image]

Contains the arguments passed to the DrawLink event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawLinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawLinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DrawLinkEventArgs

See Also

DrawLinkEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs Members

DrawLinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawLink event handlers.

The following tables list the members exposed by the DrawLinkEventArgs type.

Public Constructors

Name | Description
DrawLinkEventArgs | Initializes a new instance of the DrawLinkEventArgs class.

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs Constructor

DrawLinkEventArgs Constructor
[image]

Initializes a new instance of the DrawLinkEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawLinkEventArgs (
DrawingContext graphics,
DiagramLink link,
PointCollection points
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext, _
link As DiagramLink, _
points As PointCollection _
)

Parameters

graphics
The DrawingContext in which to draw the link.
link
The DiagramLink related to the event.
points
The collection containing the coordinates of the link control points.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs Properties

DrawLinkEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.

See Also

DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs.Graphics Property

DrawLinkEventArgs.Graphics Property
[image]

Gets a DrawingContext object whose methods should be used to draw the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

An instance of the System.Windows.Media.DrawingContext class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs.Link Property

DrawLinkEventArgs.Link Property
[image]

Gets the DiagramLink object that should be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawLinkEventArgs.Points Property

DrawLinkEventArgs.Points Property
[image]

Gets a collection of the link's control points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the PointCollection class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs Class

DrawNodeEventArgs Class
[image]

Contains the arguments passed to the DrawNode event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.DrawNodeEventArgs

See Also

DrawNodeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs Members

DrawNodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawNode event handlers.

The following tables list the members exposed by the DrawNodeEventArgs type.

Public Constructors

Name | Description
DrawNodeEventArgs | Initializes a new instance of the DrawNodeEventArgs class.

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs Constructor

DrawNodeEventArgs Constructor
[image]

Initializes a new instance of the DrawNodeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawNodeEventArgs (
DrawingContext graphics,
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
graphics As DrawingContext, _
node As DiagramNode _
)

Parameters

graphics

The DrawingContext object that represents the target of the drawing operation.

node

The DiagramNode related to the event.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs Properties

DrawNodeEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets a DrawingContext object whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.

See Also

DrawNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs.Graphics Property

DrawNodeEventArgs.Graphics Property
[image]

Gets a DrawingContext object whose methods should be used to draw the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As DrawingContext

Property Value

An instance of the System.Windows.Media.DrawingContext class.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DrawNodeEventArgs.Node Property

DrawNodeEventArgs.Node Property
[image]

Gets the DiagramNode object that should be custom drawn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode Class

DummyNode Class
[image]

Represents virtual nodes used for disconnected links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DummyNode : DiagramNode

Visual Basic [image] Copy Code

Public Class DummyNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.DummyNode

See Also

DummyNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode Members

DummyNode Members
Constructors Fields Properties Methods
[image]

Represents virtual nodes used for disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | DiagramNode.GetNearestBorderPoint override.
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | DiagramItem.SaveToXml override. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode Constructor

DummyNode Constructor
[image]

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DummyNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram this node will be associated with.

See Also

DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode Methods

DummyNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | DiagramNode.GetNearestBorderPoint override.
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | DiagramItem.SaveToXml override. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.ContainsPoint Method

DummyNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point
The point to check.

Return Value

The DummyNode implementation of this method always returns false.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.CreateConnectionPoint Method

DummyNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt
The point at which the link should be connected.
incoming
true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.DrawHandles Method

DummyNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.GetIntersection Method

DummyNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart
The first point of the segment.
segmentEnd
The second point of the segment.

Return Value

The DummyNode implementation of this method always returns segmentStart as the result.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.GetNearestBorderPoint Method

DummyNode.GetNearestBorderPoint Method
[image]

DiagramNode.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

A Point instance specifying a point in the diagram.

Return Value

A Point specifying the point from the node's outline closest to the point specified as argument.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.DummyNode.HitTestHandle Method

DummyNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point
A Point value specifying where to look for a selection handle.

Return Value

The DummyNode implementation of this method always returns null.

See Also

DummyNode Members
DummyNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs Class

EditCellTextEventArgs Class
[image]

Contains the arguments passed to the CellTextEdited event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class EditCellTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditCellTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.EditCellTextEventArgs

See Also

EditCellTextEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs Members

EditCellTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the CellTextEdited event handlers.

The following tables list the members exposed by the EditCellTextEventArgs type.

Public Constructors

Name | Description
EditCellTextEventArgs | Initializes a new instance of the EditCellTextEventArgs class.

Public Properties

Name | Description
Cell | Gets the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Gets the table that contains Cell.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs Constructor

EditCellTextEventArgs Constructor
[image]

Initializes a new instance of the EditCellTextEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public EditCellTextEventArgs (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell
The TableNode.Cell related to the event.
oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs Properties

EditCellTextEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Gets the table that contains Cell.

See Also

EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.Cell Property

EditCellTextEventArgs.Cell Property
[image]

Gets the cell whose text has been edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.Column Property

EditCellTextEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.NewText Property

EditCellTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.OldText Property

EditCellTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the cell before the user edited it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.Row Property

EditCellTextEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditCellTextEventArgs.Table Property

EditCellTextEventArgs.Table Property
[image]

Gets the table that contains Cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs Class

EditLinkTextEventArgs Class
[image]

Contains the arguments passed to the EditLinkTextEventArgs event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class EditLinkTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditLinkTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.EditLinkTextEventArgs

See Also

EditLinkTextEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs Members

EditLinkTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the EditLinkTextEventArgs event handlers.

The following tables list the members exposed by the EditLinkTextEventArgs type.

Public Constructors

Name | Description
EditLinkTextEventArgs | Initializes a new instance of the EditLinkTextEventArgs class.

Public Properties

Name | Description
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs Constructor

EditLinkTextEventArgs Constructor
[image]

Initializes a new instance of the EditLinkTextEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public EditLinkTextEventArgs (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link

oldText

newText

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs Properties

EditLinkTextEventArgs Properties
[image]

Public Properties

Name | Description
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs.Label Property

EditLinkTextEventArgs.Label Property
[image]

Gets or sets a LinkLabel related to this event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As LinkLabel

Property Value

A LinkLabel instance is the user has edited a label, or null if they edited link's Text value.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs.Link Property

EditLinkTextEventArgs.Link Property
[image]

Gets the link whose text was edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs.NewText Property

EditLinkTextEventArgs.NewText Property
[image]

Gets the new text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditLinkTextEventArgs.OldText Property

EditLinkTextEventArgs.OldText Property
[image]

Gets the text before in-place editing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs Class

EditNodeTextEventArgs Class
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class EditNodeTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditNodeTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.EditNodeTextEventArgs

See Also

EditNodeTextEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs Members

EditNodeTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

The following tables list the members exposed by the EditNodeTextEventArgs type.

Public Constructors

Name | Description
EditNodeTextEventArgs | Initializes a new instance of the EditNodeTextEventArgs class.

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs Constructor

EditNodeTextEventArgs Constructor
[image]

Initializes a new instance of the EditNodeTextEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public EditNodeTextEventArgs (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node
The DiagramNode related to the event.
oldText

The old text of the node.

newText

The new text of the node.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs Properties

EditNodeTextEventArgs Properties
[image]

Public Properties

Name | Description
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs.NewText Property

EditNodeTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs.Node Property

EditNodeTextEventArgs.Node Property
[image]

Gets the node whose text has been edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.EditNodeTextEventArgs.OldText Property

EditNodeTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate Class

ElementTemplate Class
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class ElementTemplate : ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class ElementTemplate
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ElementTemplate
MindFusion.Diagramming.Wpf.ArcTemplate
MindFusion.Diagramming.Wpf.BezierTemplate
MindFusion.Diagramming.Wpf.LineTemplate
MindFusion.Diagramming.Wpf.RoundRectangleTemplate

See Also

ElementTemplate Members
MindFusion.Diagramming.Wpf Namespace
Diagram.DefaultShape Property


MindFusion.Diagramming.Wpf.ElementTemplate Members

ElementTemplate Members
Constructors Properties Methods
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

The following tables list the members exposed by the ElementTemplate type.

Protected Constructors

Name | Description
ElementTemplate | Initializes a new instance of the ElementTemplate class.

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate Constructor

ElementTemplate Constructor
[image]

Initializes a new instance of the ElementTemplate class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected ElementTemplate ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate Methods

ElementTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.Clone Method

ElementTemplate.Clone Method
[image]

Creates an exact copy of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

An instance of the appropriate type that represents the element clone.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.GetElementPen Method

ElementTemplate.GetElementPen Method
[image]

Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Pen GetElementPen (
Pen pen
)

Visual Basic [image] Copy Code

Protected Function GetElementPen( _
pen As Pen _
) As Pen

Parameters

pen
A System.Windows.Media.Pen object specifying the base pen.

Return Value

A System.Windows.Media.Pen instance to use for drawing.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.SameAs Method

ElementTemplate.SameAs Method
[image]

Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public MustOverride Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj
The ElementTemplate to compare to this element.

Return Value

true if the specified object closely approximates this element; otherwise, false.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate Properties

ElementTemplate Properties
[image]

Public Properties

Name | Description
Color | Gest or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

See Also

ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.Color Property

ElementTemplate.Color Property
[image]

Gest or sets the outline color of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A .NET Color instance specifying the color of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.DashStyle Property

ElementTemplate.DashStyle Property
[image]

Gets or sets the dash style of the outline of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the .NET DashStyle enumeration specifying the style of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ElementTemplate.Width Property

ElementTemplate.Width Property
[image]

Gets or sets the outline width of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A float value specifying the width of the outline.

See Also

ElementTemplate Members
ElementTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ExpandButtonAction Enumeration

ExpandButtonAction Enumeration
[image]

Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ExpandButtonAction

Visual Basic [image] Copy Code

Public Enum ExpandButtonAction

Members

Member name | Description
ExpandTreeBranch | Expands or collapses the children of a node in a tree-like diagram and raises the TreeExpanded or TreeCollapsed event.
RaiseEvents | Raises the ExpandButtonClicked event.

Remarks

The members of this enumeration can be assigned to the ExpandButtonAction property of the Diagram class.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ExpandButtonPosition Enumeration

ExpandButtonPosition Enumeration
[image]

Defines values that specify possible locations for expand/collapse buttons.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ExpandButtonPosition

Visual Basic [image] Copy Code

Public Enum ExpandButtonPosition

Members

Member name | Description
Custom | Place the expand/collapse button at a position returned by the CustomExpandButtonPosition delegate.
OuterBottom | Place expand/collapse buttons at the bottom side of their nodes.
OuterLeft | Place expand/collapse buttons at the left-hand side of their nodes.
OuterLowerLeft | Place expand/collapse buttons at the lower-left corner of their nodes.
OuterLowerRight | Place expand/collapse buttons at the lower-right corner of their nodes.
OuterRight | Place expand/collapse buttons at the right-hand side of their nodes.
OuterTop | Place expand/collapse buttons at the top side of their nodes.
OuterUpperLeft | Place expand/collapse buttons at the upper-left corner of their nodes.
OuterUpperRight | Place expand/collapse buttons at the upper-right corner of their nodes.

Remarks

Assign values from this enumeration to the ExpandButtonPosition property of the Diagram class.

See Also

MindFusion.Diagramming.Wpf Namespace
DiagramNode.Expandable Property


MindFusion.Diagramming.Wpf.Factory Class

Factory Class
[image]

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for WPF item types. Call the class methods through the Factory property of the Diagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Factory

Visual Basic [image] Copy Code

Public Class Factory

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Factory

See Also

Factory Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory Members

Factory Members
Constructors Methods
[image]

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for WPF item types. Call the class methods through the Factory property of the Diagram class.

The following tables list the members exposed by the Factory type.

Public Constructors

Name | Description
Factory | Initializes a new instance of the Factory class over the specified Diagram.

Public Methods

Name | Description
CreateBarcodeNode | Overloaded. Creates a new BarcodeNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTemplatedNode | Overloaded. Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
CreateVisioNode | Overloaded. Creates a new VisioNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory Constructor

Factory Constructor
[image]

Initializes a new instance of the Factory class over the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Factory (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram object for which to create the new factory.

See Also

Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory Methods

Factory Methods
[image]

Public Methods

Name | Description
CreateBarcodeNode | Overloaded. Creates a new BarcodeNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.
CreateContainerNode | Overloaded. Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.
CreateGroup | Creates a new hierarchical Group with the specified main item.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTableNode | Overloaded. Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.
CreateTemplatedNode | Overloaded. Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
CreateVisioNode | Overloaded. Creates a new VisioNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method

Factory.CreateBarcodeNode Method
[image]

Creates a new BarcodeNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateBarcodeNode (Double, Double, Double, Double) | Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Double, Double, Double, Double, BarcodeFormat, String) | Creates a new BarcodeNode instance at the specified position with the specified size and content, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Point, Size) | Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Point, Size, BarcodeFormat, String) | Creates a new BarcodeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Rect) | Creates a new BarcodeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateBarcodeNode (Rect, BarcodeFormat, String) | Creates a new BarcodeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Double, Double, Double, Double)

Factory.CreateBarcodeNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As BarcodeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Double, Double, Double, Double, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (Double, Double, Double, Double, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and content, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
double x,
double y,
double width,
double height,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a barcode node at the position specified by x and y. The size of the node is set by width and height. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Point, Size)

Factory.CreateBarcodeNode Method (Point, Size)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
location As Point, _
size As Size _
) As BarcodeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Point, Size, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (Point, Size, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
Point location,
Size size,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
location As Point, _
size As Size, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

location

The position of the new node.

size

The size of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Rect)

Factory.CreateBarcodeNode Method (Rect)
See Also
[image]

Creates a new BarcodeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
bounds As Rect _
) As BarcodeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateBarcodeNode Method (Rect, BarcodeFormat, String)

Factory.CreateBarcodeNode Method (Rect, BarcodeFormat, String)
See Also
[image]

Creates a new BarcodeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BarcodeNode CreateBarcodeNode (
Rect bounds,
BarcodeFormat format,
string content
)

Visual Basic [image] Copy Code

Public Function CreateBarcodeNode( _
bounds As Rect, _
format As BarcodeFormat, _
content As String _
) As BarcodeNode

Parameters

bounds

The bounding rectangle of the new node.

format

Specifies the barcode format.

content

Specifies the barcode content.

Return Value

The newly created BarcodeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The barcode content and format are specified via respective parameters.

See Also

CreateBarcodeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method

Factory.CreateContainerNode Method
[image]

Creates a new ContainerNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateContainerNode (Double, Double, Double, Double) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Double, Double, Double, Double, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Point, Size) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Point, Size, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Rect) | Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Rect, Boolean) | Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Double, Double, Double, Double)

Factory.CreateContainerNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Double, Double, Double, Double, Boolean)

Factory.CreateContainerNode Method (Double, Double, Double, Double, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
double x,
double y,
double width,
double height,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
foldable As Boolean _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

foldable
true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. The foldable parameter specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Point, Size)

Factory.CreateContainerNode Method (Point, Size)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
location As Point, _
size As Size _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The size of the ContainerNode object.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Point, Size, Boolean)

Factory.CreateContainerNode Method (Point, Size, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Point location,
Size size,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
location As Point, _
size As Size, _
foldable As Boolean _
) As ContainerNode

Parameters

location
The location of the ContainerNode object.
size
The newly created ContainerNode instance.
foldable
true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. The foldable parameter specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Rect)

Factory.CreateContainerNode Method (Rect)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
bounds As Rect _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateContainerNode Method (Rect, Boolean)

Factory.CreateContainerNode Method (Rect, Boolean)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Rect bounds,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
bounds As Rect, _
foldable As Boolean _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

foldable
true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. The foldable parameter specifies whether the container node is initially foldable. For further customization of the node, use the properties and methods of the ContainerNode class.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method

Factory.CreateDiagramLink Method
[image]

Creates a new DiagramLink instance and adds it to the Links collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateDiagramLink (DiagramNode, DiagramNode) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, Point) | Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram..
Factory.CreateDiagramLink (DiagramNode, TableNode, Int32) | Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, DiagramNode) | Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, Point) | Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (ShapeNode, Int32, ShapeNode, Int32) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, DiagramNode) | Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, TableNode, Int32) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, TableNode) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)

Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (DiagramNode, Point)

Factory.CreateDiagramLink Method (DiagramNode, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram..

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the point specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)

Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the table specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (Point, DiagramNode)

Factory.CreateDiagramLink Method (Point, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the point specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (Point, Point)

Factory.CreateDiagramLink Method (Point, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the points specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)

Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
ShapeNode origin,
int originAnchor,
ShapeNode destination,
int destAnchor
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As ShapeNode, _
originAnchor As Integer, _
destination As ShapeNode, _
destAnchor As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originAnchor
The index of an anchor point within the origin node's AnchorPattern.
destination

The destination node.

destAnchor
The index of an anchor point within the destination node's AnchorPattern.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the shape nodes specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)

Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the destination table row of the new link.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the table specified by origin and the node specified by destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)

Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the origin table row of the new link.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateDiagramLink Method (TableNode, TableNode)

Factory.CreateDiagramLink Method (TableNode, TableNode)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
TableNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
destination As TableNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination. For further customization of the link, use the properties and methods of the DiagramLink class.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateTableNode Method
CreateShapeNode Method
Diagram.Links Property


MindFusion.Diagramming.Wpf.Factory.CreateGroup Method

Factory.CreateGroup Method
[image]

Creates a new hierarchical Group with the specified main item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group CreateGroup (
DiagramItem mainItem
)

Visual Basic [image] Copy Code

Public Function CreateGroup( _
mainItem As DiagramItem _
) As Group

Parameters

mainItem
The DiagramItem around which the group would be built.

Return Value

The newly created Group instance if successfully created; otherwise null (Nothing in Visual Basic).

Remarks

Use this method to create an hierarchical group of items. Attach subordinated items by the various Group members.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
DiagramBase.GroupDestroyed Event


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method

Factory.CreateShapeNode Method
[image]

Creates a new ShapeNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateShapeNode (Double, Double, Double, Double) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Double, Double, Double, Double, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect) | Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect, Shape) | Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Double, Double, Double, Double)

Factory.CreateShapeNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)

Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
shape As Shape _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Point, Size)

Factory.CreateShapeNode Method (Point, Size)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Point, Size, Shape)

Factory.CreateShapeNode Method (Point, Size, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size, _
shape As Shape _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Rect)

Factory.CreateShapeNode Method (Rect)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateShapeNode Method (Rect, Shape)

Factory.CreateShapeNode Method (Rect, Shape)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect, _
shape As Shape _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The shape of the new node is specified by shape. For further customization of the node, use the properties and methods of the ShapeNode class.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateDiagramLink Method
CreateTableNode Method
Diagram.Nodes Property
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method

Factory.CreateTableNode Method
[image]

Creates a new TableNode instance and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateTableNode (Double, Double, Double, Double) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Double, Double, Double, Double, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect) | Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect, Int32, Int32) | Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Double, Double, Double, Double)

Factory.CreateTableNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width of the new table.

height

The height of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. For further customization of the node, use the properties and methods of the TableNode class.

.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)

Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width if the new table.

height

The height of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Point, Size)

Factory.CreateTableNode Method (Point, Size)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Point, Size, Int32, Int32)

Factory.CreateTableNode Method (Point, Size, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Rect)

Factory.CreateTableNode Method (Rect)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTableNode Method (Rect, Int32, Int32)

Factory.CreateTableNode Method (Rect, Int32, Int32)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. The initial number of columns and rows in the table is specified by columns and rows respectively. For further customization of the node, use the properties and methods of the TableNode class.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace
CreateShapeNode Method
CreateDiagramLink Method
Diagram.AlignPointToGrid Method


MindFusion.Diagramming.Wpf.Factory.CreateTemplatedNode Method

Factory.CreateTemplatedNode Method
[image]

Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateTemplatedNode (Double, Double, Double, Double) | Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTemplatedNode (Point, Size) | Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTemplatedNode (Rect) | Creates a new TemplatedNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTemplatedNode Method (Double, Double, Double, Double)

Factory.CreateTemplatedNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode CreateTemplatedNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTemplatedNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TemplatedNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created TemplatedNode instance.

See Also

CreateTemplatedNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTemplatedNode Method (Point, Size)

Factory.CreateTemplatedNode Method (Point, Size)
See Also
[image]

Creates a new TemplatedNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode CreateTemplatedNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTemplatedNode( _
location As Point, _
size As Size _
) As TemplatedNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created TemplatedNode instance.

See Also

CreateTemplatedNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTemplatedNode Method (Rect)

Factory.CreateTemplatedNode Method (Rect)
See Also
[image]

Creates a new TemplatedNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode CreateTemplatedNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTemplatedNode( _
bounds As Rect _
) As TemplatedNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created TemplatedNode instance.

See Also

CreateTemplatedNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTreeViewNode Method

Factory.CreateTreeViewNode Method
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateTreeViewNode (Double, Double, Double, Double) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Point, Size) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Rect) | Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTreeViewNode Method (Double, Double, Double, Double)

Factory.CreateTreeViewNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TreeViewNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTreeViewNode Method (Point, Size)

Factory.CreateTreeViewNode Method (Point, Size)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
location As Point, _
size As Size _
) As TreeViewNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by location. The size of the node is set by size.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateTreeViewNode Method (Rect)

Factory.CreateTreeViewNode Method (Rect)
See Also
[image]

Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
bounds As Rect _
) As TreeViewNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node with dimensions specified by bounds.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method

Factory.CreateVisioNode Method
[image]

Creates a new VisioNode instance at a specified position with a specified size and adds it to the Nodes collection of the underlying diagram.

Overload List

Name | Description
Factory.CreateVisioNode (Double, Double, Double, Double) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Double, Double, Double, Double, VisioContent) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Point, Size) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Point, Size, VisioContent) | Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Rect) | Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateVisioNode (Rect, VisioContent) | Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Double, Double, Double, Double)

Factory.CreateVisioNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As VisioNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Double, Double, Double, Double, VisioContent)

Factory.CreateVisioNode Method (Double, Double, Double, Double, VisioContent)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
double x,
double y,
double width,
double height,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
content As VisioContent _
) As VisioNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Point, Size)

Factory.CreateVisioNode Method (Point, Size)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
location As Point, _
size As Size _
) As VisioNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by location. The size of the node is set by size.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Point, Size, VisioContent)

Factory.CreateVisioNode Method (Point, Size, VisioContent)
See Also
[image]

Creates a new VisioNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
Point location,
Size size,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
location As Point, _
size As Size, _
content As VisioContent _
) As VisioNode

Parameters

location

The position of the new node.

size

The size of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a Visio node at the position specified by location. The size of the node is set by size.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Rect)

Factory.CreateVisioNode Method (Rect)
See Also
[image]

Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
bounds As Rect _
) As VisioNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a VisioNode with dimensions specified by bounds.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Factory.CreateVisioNode Method (Rect, VisioContent)

Factory.CreateVisioNode Method (Rect, VisioContent)
See Also
[image]

Creates a new VisioNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode CreateVisioNode (
Rect bounds,
VisioContent content
)

Visual Basic [image] Copy Code

Public Function CreateVisioNode( _
bounds As Rect, _
content As VisioContent _
) As VisioNode

Parameters

bounds

The bounding rectangle of the new node.

content

The content of the new node.

Return Value

The newly created VisioNode instance.

Remarks

The method creates a VisioNode with dimensions specified by bounds.

See Also

CreateVisioNode Method Overload List
Factory Members
Factory Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FitSize Enumeration

FitSize Enumeration
[image]

Specifies how the ResizeToFitText method should resize a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum FitSize

Visual Basic [image] Copy Code

Public Enum FitSize

Members

Member name | Description
KeepHeight | Specifies that the original node height should remain intact.
KeepRatio | Allows changing both the width and height of a node, but keep the original width/height ratio if possible.
KeepWidth | Specifies that the original node width should remain intact.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Class

Font Class
[image]

Replacement for System.Drawing.Font that does not reference System.Drawing.dll

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Font

Visual Basic [image] Copy Code

Public Class Font

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Font

See Also

Font Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Members

Font Members
Constructors Properties Methods
[image]

Replacement for System.Drawing.Font that does not reference System.Drawing.dll

The following tables list the members exposed by the Font type.

Public Constructors

Name | Description
Font | Overloaded.

Public Properties

Name | Description
Decorations | Font Weight
Name | Font Name
Size | Font Size
Style | Font Style
Unit | The unit of measure of Size
Weight | Font Weight

Public Methods

Name | Description
Clone | Creates a copy of this object

See Also

Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Constructor

Font Constructor
[image]

Overload List

Name | Description
Font (String, Double) | Contructs new Font
Font (String, Double, GraphicsUnit) | Contructs new Font

See Also

Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Constructor (String, Double)

Font Constructor (String, Double)
See Also
[image]

Contructs new Font

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font (
string name,
double size
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
size As Double _
)

Parameters

name

size

See Also

Font Constructor Overload List
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Constructor (String, Double, GraphicsUnit)

Font Constructor (String, Double, GraphicsUnit)
See Also
[image]

Contructs new Font

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font (
string name,
double size,
GraphicsUnit unit
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
size As Double, _
unit As GraphicsUnit _
)

Parameters

name

size

unit

See Also

Font Constructor Overload List
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Methods

Font Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this object

See Also

Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Clone Method

Font.Clone Method
[image]

Creates a copy of this object

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Font

Return Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font Properties

Font Properties
[image]

Public Properties

Name | Description
Decorations | Font Weight
Name | Font Name
Size | Font Size
Style | Font Style
Unit | The unit of measure of Size
Weight | Font Weight

See Also

Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Decorations Property

Font.Decorations Property
[image]

Font Weight

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextDecorationCollection Decorations { get; set; }

Visual Basic [image] Copy Code

Public Property Decorations As TextDecorationCollection

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Name Property

Font.Name Property
[image]

Font Name

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Size Property

Font.Size Property
[image]

Font Size

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Double

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Style Property

Font.Style Property
[image]

Font Style

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As FontStyle

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Unit Property

Font.Unit Property
[image]

The unit of measure of Size

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As GraphicsUnit

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Font.Weight Property

Font.Weight Property
[image]

Font Weight

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontWeight Weight { get; set; }

Visual Basic [image] Copy Code

Public Property Weight As FontWeight

Property Value

See Also

Font Members
Font Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormHandle Class

FreeFormHandle Class
[image]

Represents an adjustment handle used to modify the outline of a FreeFormNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FreeFormHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class FreeFormHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AdjustmentHandle
MindFusion.Diagramming.Wpf.FreeFormHandle

See Also

FreeFormHandle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormHandle Members

FreeFormHandle Members
Constructors Properties Methods
[image]

Represents an adjustment handle used to modify the outline of a FreeFormNode.

The following tables list the members exposed by the FreeFormHandle type.

Public Constructors

Name | Description
FreeFormHandle | Initialzes a new instance of the FreeFormHandle class.

Public Properties

Name | Description
PointIndex | Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items. (Inherited from AdjustmentHandle.)

See Also

FreeFormHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormHandle Constructor

FreeFormHandle Constructor
[image]

Initialzes a new instance of the FreeFormHandle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FreeFormHandle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FreeFormHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormHandle Properties

FreeFormHandle Properties
[image]

Public Properties

Name | Description
PointIndex | Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

See Also

FreeFormHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormHandle.PointIndex Property

FreeFormHandle.PointIndex Property
[image]

Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int PointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PointIndex As Integer

Property Value

An integer value.

See Also

FreeFormHandle Members
FreeFormHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Class

FreeFormNode Class
Remarks See Also
[image]

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FreeFormNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class FreeFormNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

To let users draw free-form nodes interactively, set Behavior to DrawFreeForms or LinkFreeForms. Use the Points property of FreeFormNode to get or set outline points programmatically. If the Closed property is set, the node is drawn as a closed shape and its interior filled, or otherwise the node is drawn as a polyline. If the distance between first and last points drawn by user is shorter than AutoCloseDistance, the node's Closed property is automatically set to true. AutoCloseDistance default value is Double.MaxValue, so free-form nodes are always closed.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.FreeFormNode

See Also

FreeFormNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Members

FreeFormNode Members
Constructors Fields Properties Methods
[image]

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.

The following tables list the members exposed by the FreeFormNode type.

Public Constructors

Name | Description
FreeFormNode | Overloaded. Initializes a new instance of the FreeFormNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Closed | Gets or sets if the node's shape is closed.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Points | Gets or sets the node's outline points.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateFromPoints | Updates the node's internal state after its points have changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramNode.AllowCreate override.
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramNode.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramNode.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramNode.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramNode.StartCreate override.
StartModify | DiagramNode.StartModify override.
UpdateCreate | DiagramNode.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Constructor

FreeFormNode Constructor
[image]

Initializes a new instance of the FreeFormNode class.

Overload List

Name | Description
FreeFormNode () | Initializes a new instance of the FreeFormNode class.
FreeFormNode (Diagram) | Initializes a new instance of the FreeFormNode class.
FreeFormNode (FreeFormNode) | Initializes a new instance of the FreeFormNode class using the specified node as a prototype.

See Also

FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Constructor ()

FreeFormNode Constructor ()
See Also
[image]

Initializes a new instance of the FreeFormNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FreeFormNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Constructor (Diagram)

FreeFormNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the FreeFormNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FreeFormNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Constructor (FreeFormNode)

FreeFormNode Constructor (FreeFormNode)
See Also
[image]

Initializes a new instance of the FreeFormNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FreeFormNode (
FreeFormNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As FreeFormNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Methods

FreeFormNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateFromPoints | Updates the node's internal state after its points have changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramNode.AllowCreate override.
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramNode.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramNode.CreateState override.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramNode.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramNode.StartCreate override.
StartModify | DiagramNode.StartModify override.
UpdateCreate | DiagramNode.UpdateCreate override.
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override.

See Also

FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.AllowCreate Method

FreeFormNode.AllowCreate Method
[image]

DiagramNode.AllowCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowCreate (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowCreate( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist

An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the creation of this node; otherwise, false.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.CompleteCreate Method

FreeFormNode.CompleteCreate Method
[image]

DiagramNode.CompleteCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
Point end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As Point _
)

Parameters

end

The mouse pointer position.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.CreateState Method

FreeFormNode.CreateState Method
[image]

DiagramNode.CreateState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

An instance of the DiagramItemState class.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.DrawHandles Method

FreeFormNode.DrawHandles Method
[image]

DiagramNode.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.DrawLocal Method

FreeFormNode.DrawLocal Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.HitTestHandle Method

FreeFormNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

Remarks

FreeFormNode can return either a FreeFormHandle to modify the node's outline, or a NodeAdjustmentHandle to move or resize the node.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.LoadFromXml Method

FreeFormNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.OnUpdateBounds Method

FreeFormNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds ()

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.RestoreState Method

FreeFormNode.RestoreState Method
[image]

DiagramNode.RestoreState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

The previously saved state.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.SaveState Method

FreeFormNode.SaveState Method
[image]

DiagramNode.SaveState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

An instance of the DiagramItemState class.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.SaveToXml Method

FreeFormNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.StartCreate Method

FreeFormNode.StartCreate Method
[image]

DiagramNode.StartCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartCreate (
Point org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As Point _
)

Parameters

org

Position of the mouse pointer.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.StartModify Method

FreeFormNode.StartModify Method
[image]

DiagramNode.StartModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this node.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.UpdateCreate Method

FreeFormNode.UpdateCreate Method
[image]

DiagramNode.UpdateCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
Point current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As Point _
)

Parameters

current

Position of the mouse pointer.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.UpdateFromPoints Method

FreeFormNode.UpdateFromPoints Method
[image]

Updates the node's internal state after its points have changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.UpdateModify Method

FreeFormNode.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode Properties

FreeFormNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Closed | Gets or sets if the node's shape is closed.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Points | Gets or sets the node's outline points.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.FreeFormNode.Closed Property

FreeFormNode.Closed Property
[image]

Gets or sets if the node's shape is closed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Closed { get; set; }

Visual Basic [image] Copy Code

Public Property Closed As Boolean

Property Value

A boolean value.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace
AutoCloseDistance Property


MindFusion.Diagramming.Wpf.FreeFormNode.Points Property

FreeFormNode.Points Property
[image]

Gets or sets the node's outline points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StylusPointCollection Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As StylusPointCollection

Property Value

A collection of points.

See Also

FreeFormNode Members
FreeFormNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GetManipulatorRect Delegate

GetManipulatorRect Delegate
[image]

Returns the manipulator position for a given node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate Rect GetManipulatorRect (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Delegate Function GetManipulatorRect( _
node As DiagramNode _
) As Rect

Parameters

node
A DiagramNode instance.

Return Value

A Rect instance.

See Also

MindFusion.Diagramming.Wpf Namespace
CustomExpandButtonPosition


MindFusion.Diagramming.Wpf.GlassEffect Class

GlassEffect Class
Remarks See Also
[image]

Represents a glass-like visual effect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class GlassEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class GlassEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.NodeEffect
MindFusion.Diagramming.Wpf.GlassEffect

See Also

GlassEffect Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect Members

GlassEffect Members
Constructors Properties Methods Events
[image]

Represents a glass-like visual effect.

The following tables list the members exposed by the GlassEffect type.

Public Constructors

Name | Description
GlassEffect | Initializes a new instance of the GlassEffect class.

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect Constructor

GlassEffect Constructor
[image]

Initializes a new instance of the GlassEffect class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GlassEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect Methods

GlassEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect.Clone Method

GlassEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

The copy of this effect.

See Also

GlassEffect Members
GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect Properties

GlassEffect Properties
[image]

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

See Also

GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect.GlowColor Property

GlassEffect.GlowColor Property
[image]

Gets or sets the color of the glow portion of the effect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color GlowColor { get; set; }

Visual Basic [image] Copy Code

Public Property GlowColor As Color

Property Value

A Color object. The default is White.

See Also

GlassEffect Members
GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect.ReflectionColor Property

GlassEffect.ReflectionColor Property
[image]

Gets or sets the color of the reflection portion of the effect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color ReflectionColor { get; set; }

Visual Basic [image] Copy Code

Public Property ReflectionColor As Color

Property Value

A Color object. The default is White.

See Also

GlassEffect Members
GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect.Type Property

GlassEffect.Type Property
[image]

Gets or sets the type of the glass effect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GlassEffectType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As GlassEffectType

Property Value

A member of the GlassEffectType enumeration. The default is Type1.

See Also

GlassEffect Members
GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect.UsePenAsGlow Property

GlassEffect.UsePenAsGlow Property
[image]

Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool UsePenAsGlow { get; set; }

Visual Basic [image] Copy Code

Public Property UsePenAsGlow As Boolean

Property Value

true to ignore GlowColor and use the color of the pen for the effect glow; otherwise, false.

See Also

GlassEffect Members
GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffect Events

GlassEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

GlassEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GlassEffectType Enumeration

GlassEffectType Enumeration
[image]

Specifies the type of a GlassEffect node effect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum GlassEffectType

Visual Basic [image] Copy Code

Public Enum GlassEffectType

Members

Member name | Description
Type1 | Indicates a glass effect with soft radial glow at the bottom and a sharp reflection at the top.
Type2 | Indicates a glass effect with linear glow at the bottom and sharp reflection at the top.
Type3 | Indicates a glass effect with radial glow at the bottom and smooth reflection and emphasized outline at the top.
Type4 | Indicates a glass effect with sharp reflection at the top and soft glow at the left and right sides.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Granularity Enumeration

Granularity Enumeration
[image]

Specifies the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Granularity

Visual Basic [image] Copy Code

Public Enum Granularity

Members

Member name | Description
CoarseGrained | Merge map tiles if possible to create a coarse-grained map. The fewer tiles in the map lead to faster path-finding.
FineGrained | Reserved for future use.
Normal | Use the map tiles found by the initial division algorithm.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Class

GraphicsUnit Class
[image]

Specifies units of measure for a particular data.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GraphicsUnit

Visual Basic [image] Copy Code

Public Class GraphicsUnit

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.GraphicsUnit

See Also

GraphicsUnit Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Members

GraphicsUnit Members
Constructors Fields Properties Methods
[image]

Specifies units of measure for a particular data.

The following tables list the members exposed by the GraphicsUnit type.

Public Constructors

Name | Description
GraphicsUnit | Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Public Fields

Name | Description
Centimeter | Specifies centimeter as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
World | Specifies the world coordinate system unit as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

Public Properties

Name | Description
Id | The unit id
Name | The unit Name

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

Public Methods

Name | Description
Convert | Overloaded.
FromId | Overloaded.
ToString | Object.ToString override.

See Also

GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Fields

GraphicsUnit Fields
[image]

Public Fields

Name | Description
Centimeter | Specifies centimeter as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
World | Specifies the world coordinate system unit as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

See Also

GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Centimeter Field

GraphicsUnit.Centimeter Field
[image]

Specifies centimeter as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Centimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Centimeter As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Inch Field

GraphicsUnit.Inch Field
[image]

Specifies the inch as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Millimeter Field

GraphicsUnit.Millimeter Field
[image]

Specifies the millimeter as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Pixel Field

GraphicsUnit.Pixel Field
[image]

Specifies a device pixel as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Point Field

GraphicsUnit.Point Field
[image]

Specifies a printer's point (1/72 inch) as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.World Field

GraphicsUnit.World Field
[image]

Specifies the world coordinate system unit as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit World

Visual Basic [image] Copy Code

Public Shared ReadOnly World As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.WpfPoint Field

GraphicsUnit.WpfPoint Field
[image]

Specifies a device-independent pixel as the unit of measure.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit WpfPoint

Visual Basic [image] Copy Code

Public Shared ReadOnly WpfPoint As GraphicsUnit

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Constructor

GraphicsUnit Constructor
[image]

Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit (
double unitsPerInch,
string name
)

Visual Basic [image] Copy Code

Public New ( _
unitsPerInch As Double, _
name As String _
)

Parameters

unitsPerInch

name

See Also

GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Methods

GraphicsUnit Methods
[image]

Public Methods

Name | Description
Convert | Overloaded.
FromId | Overloaded.
ToString | Object.ToString override.

See Also

GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Convert Method

GraphicsUnit.Convert Method
[image]

Overload List

Name | Description
GraphicsUnit.Convert (Double, GraphicsUnit) | Converts amount from this unit to specified unit.
GraphicsUnit.Convert (Point, GraphicsUnit) | Convenience method for converting points to specified units
GraphicsUnit.Convert (Rect, GraphicsUnit) | Convenience method for converting Rect to specified units

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Convert Method (Double, GraphicsUnit)

GraphicsUnit.Convert Method (Double, GraphicsUnit)
See Also
[image]

Converts amount from this unit to specified unit.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Convert (
double amount,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
amount As Double, _
targetUnit As GraphicsUnit _
) As Double

Parameters

amount

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Convert Method (Point, GraphicsUnit)

GraphicsUnit.Convert Method (Point, GraphicsUnit)
See Also
[image]

Convenience method for converting points to specified units

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point Convert (
Point p,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
p As Point, _
targetUnit As GraphicsUnit _
) As Point

Parameters

p

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Convert Method (Rect, GraphicsUnit)

GraphicsUnit.Convert Method (Rect, GraphicsUnit)
See Also
[image]

Convenience method for converting Rect to specified units

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Convert (
Rect r,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert( _
r As Rect, _
targetUnit As GraphicsUnit _
) As Rect

Parameters

r

targetUnit

Return Value

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.FromId Method

GraphicsUnit.FromId Method
[image]

Overload List

Name | Description
GraphicsUnit.FromId (Int32, Diagram) | Returns a GraphicsUnit from its integer id. Parameter diagram is used if the id denotes the current diagram id (GraphicsUnit.World)
GraphicsUnit.FromId (Int32, GraphicsUnit) | Returns the GraphicsUnit that has the specified id

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.FromId Method (Int32, Diagram)

GraphicsUnit.FromId Method (Int32, Diagram)
See Also
[image]

Returns a GraphicsUnit from its integer id. Parameter diagram is used if the id denotes the current diagram id (GraphicsUnit.World)

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static GraphicsUnit FromId (
int id,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer, _
diagram As Diagram _
) As GraphicsUnit

Parameters

id

diagram

Return Value

See Also

FromId Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.FromId Method (Int32, GraphicsUnit)

GraphicsUnit.FromId Method (Int32, GraphicsUnit)
See Also
[image]

Returns the GraphicsUnit that has the specified id

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static GraphicsUnit FromId (
int id,
GraphicsUnit measureUnit
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer, _
measureUnit As GraphicsUnit _
) As GraphicsUnit

Parameters

id

measureUnit

Return Value

See Also

FromId Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.ToString Method

GraphicsUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit Properties

GraphicsUnit Properties
[image]

Public Properties

Name | Description
Id | The unit id
Name | The unit Name

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

See Also

GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Id Property

GraphicsUnit.Id Property
[image]

The unit id

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.Name Property

GraphicsUnit.Name Property
[image]

The unit Name

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GraphicsUnit.UnitsPerInch Property

GraphicsUnit.UnitsPerInch Property
[image]

Gets the base resolution of this GraphicsUnit object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual double UnitsPerInch { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property UnitsPerInch As Double

Property Value

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter Class

GridRouter Class
Remarks See Also
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GridRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class GridRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.GridRouter

See Also

GridRouter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter Members

GridRouter Members
Constructors Properties Methods
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the GridRouter type.

Public Constructors

Name | Description
GridRouter | Initializes a new instance of the GridRouter class.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter Constructor

GridRouter Constructor
[image]

Initializes a new instance of the GridRouter class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GridRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter Methods

GridRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter.Resume Method

GridRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

GridRouter Members
GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter.RouteLink Method

GridRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

GridRouter Members
GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter.RouteLinks Method

GridRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

GridRouter Members
GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter.Suspend Method

GridRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

GridRouter Members
GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter Properties

GridRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridRouter.Diagram Property

GridRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

GridRouter Members
GridRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GridStyle Enumeration

GridStyle Enumeration
[image]

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum GridStyle

Visual Basic [image] Copy Code

Public Enum GridStyle

Members

Member name | Description
Lines | The grid is represented as a series of crossing horizontal and vertical lines.
Points | The grid is painted as a matrix of points.

See Also

MindFusion.Diagramming.Wpf Namespace
GridStyle Property


MindFusion.Diagramming.Wpf.Group Class

Group Class
Remarks See Also
[image]

Represents a group of items in the diagram document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Group

Visual Basic [image] Copy Code

Public Class Group

Remarks

An hierarchy of items can be built, so that moving an item that is higher in the hierarchy moves all subordinated items too. The immediate subordinates of an item are represented by a Group instance. Every group must have a single master item, to which all group members are attached. The master item can be accessed by the MainItem property. The group of items attached to an item is accessed by the SubordinateGroup property of the latter. MasterGroup gets the group in which a node is subordinate.

To create a group, instantiate a Group object and add it to the diagram's Groups collection, or call the CreateGroup method passing the master item as argument. A group is automatically destroyed when its master item is deleted.

To destroy a group programmatically, call the Remove method of the Groups collection. If AutoDeleteItems is enabled, subordinated items in the group are deleted too. If AutoDeleteItems is disabled, subordinated items are just detached from their master and remain intact.

Nodes can be attached to a group in several ways, depending on the type of the master item. If the master is a node, other nodes can be attached by the AttachProportional or AttachToCorner methods. If the master is a link, nodes can be attached to it using the AttachToLinkSegment or AttachToLinkPoint methods. The DiagramNode class provides a shortcut AttachTo method, which creates a group if necessary and calls the group's appropriate AttachTo* method. Items can be detached from a group by the Detach method.

The Expandable property specifies whether expanding or collapsing a tree is propagated from the master node through the subordinated nodes. FollowMasterRotation can be used when the master item is a node. If it is enabled, the positions of attached nodes are updated to reflect the RotationAngle of the master node while it is rotated.

The Tag property allows attaching custom data to any group. The FindGroup methods looks for a groups having a specific tag.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Group

See Also

Group Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Members

Group Members
Constructors Properties Methods
[image]

Represents a group of items in the diagram document.

The following tables list the members exposed by the Group type.

Public Constructors

Name | Description
Group | Overloaded. Initializes a new instance of the Group class.

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Specifies whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes should follow the rotation of a master node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

Public Methods

Name | Description
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.
Repaint | Repaints all underlying diagram items.

See Also

Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Constructor

Group Constructor
[image]

Initializes a new instance of the Group class.

Overload List

Name | Description
Group (Diagram) | Initializes a new instance of the Group class with the specified Diagram as parent.
Group (Group) | Initializes a new instance of the Group class using the specified group as a prototype.

See Also

Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Constructor (Diagram)

Group Constructor (Diagram)
See Also
[image]

Initializes a new instance of the Group class with the specified Diagram as parent.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram the new group will belong to.

See Also

Group Constructor Overload List
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Constructor (Group)

Group Constructor (Group)
See Also
[image]

Initializes a new instance of the Group class using the specified group as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group (
Group prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As Group _
)

Parameters

prototype

The group to use as a prototype.

Remarks

This constructor supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code. Instead use the other constructor or the CreateGroup method of the Factory class.

See Also

Group Constructor Overload List
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Methods

Group Methods
[image]

Public Methods

Name | Description
AttachProportional | Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.
AttachToCorner | Attaches a node to the specified corner of the main node.
AttachToEdges | Anchors a node to the specified edges of the master node.
AttachToLinkPoint | Attaches a node to the specified control point of the link that is MainItem.
AttachToLinkSegment | Attaches a node to the specified segment of the link that is MainItem.
AttachToLongestHSegment | Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.
AttachToSideMiddle | Adds an item to the group, attaching it to the middle point of a side of the master node.
Detach | Detaches the specified item from this group.
GetRepaintRect | Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.
Repaint | Repaints all underlying diagram items.

See Also

Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.AttachProportional Method

Group.AttachProportional Method
[image]

Attaches a new node to the group, in such a way that its area is always occupying certain percentage of the main item's area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachProportional (
DiagramNode node,
double left,
double top,
double right,
double bottom
)

Visual Basic [image] Copy Code

Public Function AttachProportional( _
node As DiagramNode, _
left As Double, _
top As Double, _
right As Double, _
bottom As Double _
) As Boolean

Parameters

node
The DiagramNode to be attached.
left

The left side of the node's bounding rectangle, expressed as percent of the main node width.

top

The top side of the node's bounding rectangle, expressed as percent of the main node height.

right

The right side of the node's bounding rectangle, expressed as percent of the main node width.

bottom

The bottom side of the node's bounding rectangle, expressed as percent of the main node height.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a node. Use the left, top, right and bottom arguments to specify the position and size of the attached node relative to that of the main item. When moving or resizing the main node, the specified ratio between it and the attached node is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachToCorner Method


MindFusion.Diagramming.Wpf.Group.AttachToCorner Method

Group.AttachToCorner Method
[image]

Attaches a node to the specified corner of the main node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToCorner (
DiagramNode node,
int corner
)

Visual Basic [image] Copy Code

Public Function AttachToCorner( _
node As DiagramNode, _
corner As Integer _
) As Boolean

Parameters

node
The DiagramNode to be attached.
corner

The zero-based index of the main node's corner.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method if the main item of the group is a node. When the specified corner position of the main node's bounding rectangle is changed, the position of the attached node is also changed and the distance between them is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachProportional Method


MindFusion.Diagramming.Wpf.Group.AttachToEdges Method

Group.AttachToEdges Method
[image]

Anchors a node to the specified edges of the master node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToEdges (
DiagramNode node,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public Function AttachToEdges( _
node As DiagramNode, _
anchorStyles As GroupAnchorStyles _
) As Boolean

Parameters

node

The DiagramNode to be attached.

anchorStyles

A member of the GroupAnchorStyles enumeration.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

This method can be used only if the master item in the group is a node. Anchoring works in a manner similar to how child controls in a form can be anchored to the form edges. When the master node position changes, the position of the attached node is also changed so that the initial distance between the specified edges is preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachProportional Method


MindFusion.Diagramming.Wpf.Group.AttachToLinkPoint Method

Group.AttachToLinkPoint Method
[image]

Attaches a node to the specified control point of the link that is MainItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToLinkPoint (
DiagramNode node,
int point
)

Visual Basic [image] Copy Code

Public Function AttachToLinkPoint( _
node As DiagramNode, _
point As Integer _
) As Boolean

Parameters

node
The DiagramNode to be attached.
point

The link point to which the node should be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

You can use this method when the main item of the group is a link. When the user moves the link control point whose index is passed as argument, the attached node is also moved with the same translation vector as that of the control point.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachToLinkSegment Method


MindFusion.Diagramming.Wpf.Group.AttachToLinkSegment Method

Group.AttachToLinkSegment Method
[image]

Attaches a node to the specified segment of the link that is MainItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToLinkSegment (
DiagramNode node,
int segment
)

Visual Basic [image] Copy Code

Public Function AttachToLinkSegment( _
node As DiagramNode, _
segment As Integer _
) As Boolean

Parameters

node
The DiagramNode to be attached.
segment

The link segment to which the node should be attached.

Return Value

false if the node could not be attached; otherwise, true.

Remarks

Call this method when the main item of the group is a link. When the specified link segment changes its position, the position of the attached node is also changed, so their mutual distance and orientation are preserved.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachToLinkPoint Method


MindFusion.Diagramming.Wpf.Group.AttachToLongestHSegment Method

Group.AttachToLongestHSegment Method
[image]

Adds an item to the group, maintaining its relative position to the longest horizontal segment of the master link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToLongestHSegment (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function AttachToLongestHSegment( _
node As DiagramNode _
) As Boolean

Parameters

node

The object to attach to the current group.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.AttachToSideMiddle Method

Group.AttachToSideMiddle Method
[image]

Adds an item to the group, attaching it to the middle point of a side of the master node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AttachToSideMiddle (
DiagramNode node,
int side
)

Visual Basic [image] Copy Code

Public Function AttachToSideMiddle( _
node As DiagramNode, _
side As Integer _
) As Boolean

Parameters

node

The object to attach to the current group.

side

The corner to attach to.

Return Value

false if the node could not be attached; otherwise, true.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Detach Method

Group.Detach Method
[image]

Detaches the specified item from this group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Detach (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function Detach( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to be detached.

Return Value

false if the item could not be detached; otherwise, true.

Remarks

Call this method to remove a item from this group. Note that this method does not delete the item, but just detaches it.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachToLinkSegment Method
AttachToLinkPoint Method
AttachProportional Method
AttachToCorner Method


MindFusion.Diagramming.Wpf.Group.GetRepaintRect Method

Group.GetRepaintRect Method
[image]

Gets a rectangle containing the repaint rectangle of the group's master and all attached objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetRepaintRect ()

Visual Basic [image] Copy Code

Public Function GetRepaintRect () As Rect

Return Value

A .NET Rect instance that represents the smallest rectangle containing all diagram items related directly or indirectly to this group.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Repaint Method

Group.Repaint Method
[image]

Repaints all underlying diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Repaint ()

Visual Basic [image] Copy Code

Public Sub Repaint ()

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group Properties

Group Properties
[image]

Public Properties

Name | Description
AttachedNodes | Gets a collection of the nodes attached to this group.
AutoDeleteItems | Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.
Expandable | Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.
FollowMasterContainment | Specifies whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.
FollowMasterRotation | Gets or sets a value indicating whether attached nodes should follow the rotation of a master node.
MainItem | Gets or sets the main item of this group.
Tag | Gets or sets a custom data associated with the group.
Visible | Gets or sets a value indicating whether the group is visible.

See Also

Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.AttachedNodes Property

Group.AttachedNodes Property
[image]

Gets a collection of the nodes attached to this group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ReadOnlyDiagramNodeCollection AttachedNodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AttachedNodes As ReadOnlyDiagramNodeCollection

Property Value

Remarks

The MainItem is not included in this collection.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
MainItem Property


MindFusion.Diagramming.Wpf.Group.AutoDeleteItems Property

Group.AutoDeleteItems Property
[image]

Gets or sets a value indicating whether the subordinated items in a group are automatically deleted if the group is destroyed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoDeleteItems { get; set; }

Visual Basic [image] Copy Code

Public Property AutoDeleteItems As Boolean

Property Value

true to delete subordinated items automatically; otherwise, false. The default is false.

Remarks

A group is destroyed explicitly by calling the Remove method of the Groups collection. A group is destroyed implicitly when its MainItem is deleted.

If a group is destroyed and this property is disabled, all subordinated items remain intact in the diagram, however they are no longer grouped. If a group is destroyed and this property is enabled, all subordinated items are deleted.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Expandable Property

Group.Expandable Property
[image]

Gets or sets a value indicating whether expanding/collapsing a tree branch propagates through this group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true if expanding or collapsing of a tree branch should propagate through the group members; otherwise, false. The default is false.

Remarks

By default expanding or collapsing tree branches is done by following the links between the branch nodes. If there are not links going out from a node, the expanding or collapsing stops there. However, if a node has a group of subordinated nodes, it could be desirable to continue expanding through them. To enable that, set the group's Expandable property to true.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
Diagram.RecursiveExpand Property
Diagram.NodesExpandable Property


MindFusion.Diagramming.Wpf.Group.FollowMasterContainment Property

Group.FollowMasterContainment Property
[image]

Specifies whether the subordinated items should be considered by a ContainerNode when the master item is added to the container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool FollowMasterContainment { get; set; }

Visual Basic [image] Copy Code

Public Property FollowMasterContainment As Boolean

Property Value

true if the whole group should be contained by ContainerNode objects; otherwise, false. The default is false.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.FollowMasterRotation Property

Group.FollowMasterRotation Property
[image]

Gets or sets a value indicating whether attached nodes should follow the rotation of a master node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupRotation FollowMasterRotation { get; set; }

Visual Basic [image] Copy Code

Public Property FollowMasterRotation As GroupRotation

Property Value

A member of the GroupRotation enumeration. The default value is IgnoreRotation.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.MainItem Property

Group.MainItem Property
[image]

Gets or sets the main item of this group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem MainItem { get; set; }

Visual Basic [image] Copy Code

Public Property MainItem As DiagramItem

Property Value

An instance of the DiagramItem class that represents the main item.

Remarks

Each group has an item which the subordinated items follow when it is moved. This main item can be a node or a link. The main item is passed as argument to the CreateGroup method.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
AttachedNodes Property


MindFusion.Diagramming.Wpf.Group.Tag Property

Group.Tag Property
[image]

Gets or sets a custom data associated with the group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of a System.Object-derived class that represents the tag.

Remarks

This property holds data that you define. MindFusion.Diagramming for WPF does not use it in any way. Possible usage might be to store an integer identifier or a reference to a larger structure.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace
Diagram.FindGroup Method
DiagramBase.SerializeTag Event


MindFusion.Diagramming.Wpf.Group.Visible Property

Group.Visible Property
[image]

Gets or sets a value indicating whether the group is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the group is visible; otherwise, false.

Remarks

Assigning a value to this property sets the Visible property of all items in the group.

See Also

Group Members
Group Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment Class

Group.Attachment Class
[image]

Encapsulates attachment information.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Group.Attachment

Visual Basic [image] Copy Code

Public Class Group.Attachment

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Group.Attachment

See Also

Group.Attachment Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment Members

Group.Attachment Members
Constructors Properties Methods
[image]

Encapsulates attachment information.

The following tables list the members exposed by the Group.Attachment type.

Public Constructors

Name | Description
Group.Attachment | Initializes a new instance of the Attachment class.

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proprtional attachments.
Traits | Contains additional data associated with the attachment.
Type | Gets or sets the attachment type.

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment Constructor

Group.Attachment Constructor
[image]

Initializes a new instance of the Attachment class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group.Attachment ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment Methods

Group.Attachment Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this attachment.

See Also

Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Clone Method

Group.Attachment.Clone Method
[image]

Creates an exact copy of this attachment.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group.Attachment Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Group.Attachment

Return Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment Properties

Group.Attachment Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the attachment data.
Node | Gets or sets the attached node.
Percents | Gets a sets percent information for proprtional attachments.
Traits | Contains additional data associated with the attachment.
Type | Gets or sets the attachment type.

See Also

Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Data Property

Group.Attachment.Data Property
[image]

Gets or sets the attachment data.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Integer

Property Value

Remarks

The interpretation of this value depends on the type of the attachment.

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Node Property

Group.Attachment.Node Property
[image]

Gets or sets the attached node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Percents Property

Group.Attachment.Percents Property
[image]

Gets a sets percent information for proprtional attachments.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness Percents { get; set; }

Visual Basic [image] Copy Code

Public Property Percents As Thickness

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Traits Property

Group.Attachment.Traits Property
[image]

Contains additional data associated with the attachment.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IDictionary Traits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Traits As IDictionary

Property Value

A hashtable containing key-value pairs with additional data about the attachment.

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Group.Attachment.Type Property

Group.Attachment.Type Property
[image]

Gets or sets the attachment type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AttachTo Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As AttachTo

Property Value

See Also

Group.Attachment Members
Group.Attachment Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupAnchorStyles Enumeration

GroupAnchorStyles Enumeration
[image]

Specifies the master node edges to which a subordinate node can be anchored.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum GroupAnchorStyles

Visual Basic [image] Copy Code

Public Enum GroupAnchorStyles

Members

Member name | Description
Bottom | Specifies the bottom edge.
Left | Specifies the left edge.
Right | Specifies the right edge.
Top | Specifies the top edge.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection Class

GroupCollection Class
[image]

Represents a strongly typed collection of Group objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GroupCollection : CollectionBase<Group>

Visual Basic [image] Copy Code

Public Class GroupCollection
Inherits CollectionBase(Of Group)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(Group)
MindFusion.Diagramming.Wpf.GroupCollection

See Also

GroupCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection Members

GroupCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly typed collection of Group objects.

The following tables list the members exposed by the GroupCollection type.

Public Constructors

Name | Description
GroupCollection | Initializes a new instance of the GroupCollection class.

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified group to the collection.
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | The zero-based index of the group to retrieve.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified group in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
RemoveAt | Removes the diagram item from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection Fields

GroupCollection Fields
[image]

Protected Fields

Name | Description
groupEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.groupEventArgs Field

GroupCollection.groupEventArgs Field
[image]

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected GroupEventArgs groupEventArgs

Visual Basic [image] Copy Code

Protected groupEventArgs As GroupEventArgs

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.notifyParent Field

GroupCollection.notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection Constructor

GroupCollection Constructor
[image]

Initializes a new instance of the GroupCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection Methods

GroupCollection Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified group to the collection.
Clear | Removes all groups from the collection.
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | The zero-based index of the group to retrieve.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified group in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
Remove | Removes the specified group from the collection.
RemoveAt | Removes the diagram item from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.Add Method

GroupCollection.Add Method
[image]

Adds the specified group to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Add (
Group group
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
group As Group _
)

Parameters

group
The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.Clear Method

GroupCollection.Clear Method
[image]

Removes all groups from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.Clone Method

GroupCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As GroupCollection

Return Value

An instance of the GroupCollection class.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.GetAt Method

GroupCollection.GetAt Method
[image]

The zero-based index of the group to retrieve.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Group

Parameters

index
The zero-based index of the group to retrieve.

Return Value

An instance of the Group class that represents the node at the specified position.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.Insert Method

GroupCollection.Insert Method
[image]

Inserts the specified group in the collection at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Insert (
int index,
Group group
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
group As Group _
)

Parameters

index

The zero-based index at which to insert the group.

group
The Group object to add to the collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.RaiseAdding Method

GroupCollection.RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseAdding (
Group group
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding( _
group As Group _
)

Parameters

group

The group that is being added.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.RaiseInserting Method

GroupCollection.RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseInserting (
Group group,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting( _
group As Group, _
index As Integer _
)

Parameters

group

The group that is being added.

index

Index of the new group.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.RaiseRemoving Method

GroupCollection.RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
Group group
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving( _
group As Group _
)

Parameters

group

The group that is being removed.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.Remove Method

GroupCollection.Remove Method
[image]

Removes the specified group from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Remove (
Group group
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
group As Group _
) As Boolean

Parameters

group
The Group object to remove from the collection.

Return Value

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupCollection.RemoveAt Method

GroupCollection.RemoveAt Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Index of the object that should be removed from this collection.

See Also

GroupCollection Members
GroupCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs Class

GroupEventArgs Class
[image]

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GroupEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GroupEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.GroupEventArgs

See Also

GroupEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs Members

GroupEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of group-related events, such as GroupDestroyed.

The following tables list the members exposed by the GroupEventArgs type.

Public Constructors

Name | Description
GroupEventArgs | Initializes a new instance of the GroupEventArgs class.

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs Constructor

GroupEventArgs Constructor
[image]

Initializes a new instance of the GroupEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupEventArgs (
Group group
)

Visual Basic [image] Copy Code

Public New ( _
group As Group _
)

Parameters

group

The Group related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs Properties

GroupEventArgs Properties
[image]

Public Properties

Name | Description
Group | Gets the group for which the event was raised.
Index | Gets an integer index related to the event.

See Also

GroupEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs.Group Property

GroupEventArgs.Group Property
[image]

Gets the group for which the event was raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

See Also

GroupEventArgs Members
GroupEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupEventArgs.Index Property

GroupEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

See Also

GroupEventArgs Members
GroupEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.GroupRotation Enumeration

GroupRotation Enumeration
[image]

Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum GroupRotation

Visual Basic [image] Copy Code

Public Enum GroupRotation

Members

Member name | Description
FerrisWheel | Attached nodes are moved to a position corresponding to the master node's rotation angle, but they are node rotated.
IgnoreRotation | Attached nodes ignore the rotation angle applied to the master node.
RotateChildren | Attached nodes are rotated by the RotationAngle of the group's master node and around its center.

See Also

MindFusion.Diagramming.Wpf Namespace
FollowMasterRotation Property


MindFusion.Diagramming.Wpf.HandlesStyle Enumeration

HandlesStyle Enumeration
[image]

Enumerates possible visual styles for frames that are drawn around selected nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HandlesStyle

Visual Basic [image] Copy Code

Public Enum HandlesStyle

Members

Member name | Description
Custom | MindFusion.Diagramming for WPF raises the DrawAdjustmentHandles and HitTestAdjustmentHandles events to let your application perform custom drawing and hit testing of selection handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links. Best used with ModificationStart set to AutoHandles.
HatchFrame | If selected, the object is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
Invisible | There is no visible difference between selected and unselected node.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
MoveOnly | If a node is selected, it can be only moved. Best used with ModificationStart set to AutoHandles.
RoundAndSquare | Corner resize handles are round, remaining handles are square.
RoundAndSquare2 | Corner resize handles are round, remaining handles are square. In addition, there is a dashed frame drawn around selected nodes.
SquareHandles | If selected, the node is drawn with square modification handles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move-handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.

Remarks

The selection style can be set independently for individual nodes and links by their DiagramNode.HandlesStyle and DiagramLink.HandlesStyle property. For most of these styles, it is recommended to set ModificationStart to AutoHandles.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle Class

HandlesVisualStyle Class
Remarks See Also
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HandlesVisualStyle

Visual Basic [image] Copy Code

Public Class HandlesVisualStyle

Remarks

The component uses several different HandlesVisualStyle objects depending on the context. They can be accessed through the ActiveItemHandlesStyle, SelectedItemHandlesStyle and DisabledHandlesStyle properties of Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.HandlesVisualStyle

See Also

HandlesVisualStyle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle Members

HandlesVisualStyle Members
Constructors Properties Methods
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

The following tables list the members exposed by the HandlesVisualStyle type.

Public Constructors

Name | Description
HandlesVisualStyle | Initializes a new instance of the HandlesVisualStyle class.

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashBackground | Gets or sets a Brush used to draw dash frame background.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle Constructor

HandlesVisualStyle Constructor
[image]

Initializes a new instance of the HandlesVisualStyle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HandlesVisualStyle (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle Methods

HandlesVisualStyle Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.LoadFromXml Method

HandlesVisualStyle.LoadFromXml Method
[image]

Loads the style from XML.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string elementName,
string colorElementName,
XmlElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
elementName As String, _
colorElementName As String, _
parentElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

colorElementName

The name of an element that contains a fallback color.

parentElement

The parent XML element.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.SaveToXml Method

HandlesVisualStyle.SaveToXml Method
[image]

Saves the style to XML.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string elementName,
XmlElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
elementName As String, _
parentElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

parentElement

The parent XML element.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle Properties

HandlesVisualStyle Properties
[image]

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashBackground | Gets or sets a Brush used to draw dash frame background.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

See Also

HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.ControlPointBrush Property

HandlesVisualStyle.ControlPointBrush Property
[image]

Gets or sets a Brush used to fill the interior of shape control points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush ControlPointBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPointBrush As Brush

Property Value

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.DashBackground Property

HandlesVisualStyle.DashBackground Property
[image]

Gets or sets a Brush used to draw dash frame background.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush DashBackground { get; set; }

Visual Basic [image] Copy Code

Public Property DashBackground As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to draw the background of selection frame when item's HandlesStyle is set to DashFrame.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.DashPen Property

HandlesVisualStyle.DashPen Property
[image]

Gets or sets a Pen used to draw dashed selection frames.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen DashPen { get; set; }

Visual Basic [image] Copy Code

Public Property DashPen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw the selection frame drawn around items whose HandlesStyle is set to DashFrame.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.HandleBrush Property

HandlesVisualStyle.HandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of selection handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush HandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HandleBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to fill the interior of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.HandlePen Property

HandlesVisualStyle.HandlePen Property
[image]

Gets or sets a Pen used to draw the border of selection handles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen HandlePen { get; set; }

Visual Basic [image] Copy Code

Public Property HandlePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw the borders of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.HatchBrush Property

HandlesVisualStyle.HatchBrush Property
[image]

Gets or sets a Brush used to draw hatch frames.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush HatchBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HatchBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to draw the hatch pattern for HandlesStyle types that display hatch frames.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.PatternBrush Property

HandlesVisualStyle.PatternBrush Property
[image]

Gets or sets a Brush used to draw selection frames for the MoveOnly style.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush PatternBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PatternBrush As Brush

Property Value

An instance of a Brush -derived class.

Remarks

This brush is used to render the dot pattern for the HatchHandles3 and MoveOnly HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HandlesVisualStyle.RotationHandleBrush Property

HandlesVisualStyle.RotationHandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of the rotation handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush RotationHandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RotationHandleBrush As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HatchBrush Class

HatchBrush Class
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HatchBrush

Visual Basic [image] Copy Code

Public Class HatchBrush

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.HatchBrush

See Also

HatchBrush Members
MindFusion.Diagramming.Wpf Namespace
HatchStyle Enumeration


MindFusion.Diagramming.Wpf.HatchBrush Members

HatchBrush Members
Constructors Methods
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush |

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HatchBrush Constructor

HatchBrush Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HatchBrush ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HatchBrush Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HatchBrush.CreateInstance Method

HatchBrush.CreateInstance Method
[image]

Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Brush CreateInstance (
HatchStyle hatchStyle,
Color foreColor,
Color backColor,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function CreateInstance( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color, _
diagram As Diagram _
) As Brush

Parameters

hatchStyle

A HatchStyle member specifying the hatch pattern.

foreColor

The hatch foreground color.

backColor

The hatch background color.

diagram

A Diagram instance.

Return Value

An ImageBrush instance.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HatchStyle Enumeration

HatchStyle Enumeration
[image]

Represents hatch patterns corresponding to GDI+ HatchBrush objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HatchStyle

Visual Basic [image] Copy Code

Public Enum HatchStyle

Members

Member name | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of Horizontal.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width.
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points.
DashedVertical | Specifies dashed vertical lines.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
DiagonalCross | A pattern of crisscross diagonal lines.
Divot | Specifies a hatch that has the appearance of divots.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
LargeGrid | Specifies the hatch style Cross.
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points and are spaced 50 percent closer together than ForwardDiagonal, but are not antialiased.
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
Max | Specifies hatch style SolidDiamond.
Min | Specifies hatch style Horizontal.
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal.
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical.
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Shingle | Specifies a hatch that has the appearance of diagonally layered shingles that slant to the right from top points to bottom points.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
Trellis | Specifies a hatch that has the appearance of a trellis.
Vertical | A pattern of vertical lines.
Wave | Specifies horizontal lines that are composed of tildes.
Weave | Specifies a hatch that has the appearance of a woven material.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width.
ZigZag | Specifies horizontal lines that are composed of zigzags.

See Also

MindFusion.Diagramming.Wpf Namespace
HatchBrush Class


MindFusion.Diagramming.Wpf.HitTestEventArgs Class

HitTestEventArgs Class
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HitTestEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HitTestEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.HitTestEventArgs

See Also

HitTestEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs Members

HitTestEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the HitTestEventArgs type.

Public Constructors

Name | Description
HitTestEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs Constructor

HitTestEventArgs Constructor
[image]

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HitTestEventArgs (
DiagramItem item,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
mousePosition As Point _
)

Parameters

item
The DiagramItem related to the event.
mousePosition

The cursor location at the time the event is raised, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs Properties

HitTestEventArgs Properties
[image]

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
MousePosition | Gets the current cursor position, expressed in document coordinates.

See Also

HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs.HitResult Property

HitTestEventArgs.HitResult Property
[image]

Gets or sets the adjustment handle that has been hit.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandle HitResult { get; set; }

Visual Basic [image] Copy Code

Public Property HitResult As AdjustmentHandle

Property Value

An instance of a class derived from AdjustmentHandle if the item can be modified at specified mouse point position, or null otherwise.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs.Item Property

HitTestEventArgs.Item Property
[image]

Gets the item whose adjustment handles are being hit-tested.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestEventArgs.MousePosition Property

HitTestEventArgs.MousePosition Property
[image]

Gets the current cursor position, expressed in document coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

A Point value specifying the current mouse position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HitTestPriority Enumeration

HitTestPriority Enumeration
[image]

Defines values that specify the order of item hit-testing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HitTestPriority

Visual Basic [image] Copy Code

Public Enum HitTestPriority

Members

Member name | Description
NodesBeforeLinks | Test nodes first, then links.
ZOrder | Test items in decreasing z-order, independently of their types.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HotkeyPrefix Enumeration

HotkeyPrefix Enumeration
[image]

Replaces System.Drawing.Text.HotkeyPrefix

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HotkeyPrefix

Visual Basic [image] Copy Code

Public Enum HotkeyPrefix

Members

Member name | Description
Hide | Do not display the hot-key prefix.
None | No hot-key prefix.
Show | Display the hot-key prefix.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Class

HtmlBuilder Class
Remarks See Also
[image]

Provides methods to create and use HTML client side image maps.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HtmlBuilder

Visual Basic [image] Copy Code

Public Class HtmlBuilder

Remarks

If an exported diagram image in displayed in an HTML page, it is helpful to create an image map whose areas correspond to the items visible in the image. The CreateImageMap method generates a full <MAP> tag, including its <AREA> elements. CreateUseMapAttr method creates the code to reference a map from within an <IMG> tag, and also adds a WIDTH and HEIGHT attributes that define to the width and height of the exported image, measured in pixels.

Each <AREA> tag in the image map has its attributes set as follows:

HREF is set to the HyperLink value of the diagram item or table's cell corresponding to the area;
ALT is set to the ToolTip value of the node or table's cell corresponding to the area;
TARGET is set to the value of HtmlBuilder's LinkTarget property.
Image map areas can be also generated for the [±] buttons displayed beside Expandable nodes. To enable that, assign an URL to the ExpandBtnHyperLink property. That URL can contain some format specifiers which are automatically replaced with the values of nodes' Tag or ZIndex properties. That lets you identify on the server side the node whose [±] button is clicked.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.HtmlBuilder

See Also

HtmlBuilder Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Members

HtmlBuilder Members
Constructors Properties Methods Events
[image]

Provides methods to create and use HTML client side image maps.

The following tables list the members exposed by the HtmlBuilder type.

Public Constructors

Name | Description
HtmlBuilder | Initializes a new instance of the HtmlBuilder class.

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the +/- buttons of expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Creates an HTML code for a MAP tag.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Constructor

HtmlBuilder Constructor
[image]

Initializes a new instance of the HtmlBuilder class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HtmlBuilder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram object whose contents will generate the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Methods

HtmlBuilder Methods
[image]

Public Methods

Name | Description
CreateImageHtml | Generates an image map HTML code.
CreateImageMap | Creates an HTML code for a MAP tag.
CreateUseMapAttr | Generates a USEMAP attribute to be used within an <IMG> tag.

See Also

HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.CreateImageHtml Method

HtmlBuilder.CreateImageHtml Method
[image]

Generates an image map HTML code.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string CreateImageHtml (
string htmlFileName,
string htmlTitle,
string imgLocalPath,
string imgURL
)

Visual Basic [image] Copy Code

Public Function CreateImageHtml( _
htmlFileName As String, _
htmlTitle As String, _
imgLocalPath As String, _
imgURL As String _
) As String

Parameters

htmlFileName

A string that represents the full name of the HTML file that is created.

htmlTitle
A string that represents the <TITLE> of the HTML file created.
imgLocalPath
A string that specifies the location of the image.
imgURL
A string that specifies the URL of the image at the server.

Return Value

A string with the HTML code of the created HTML file.

Remarks

The method also creates an HTML file with attributes specified as parameters.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.CreateImageMap Method

HtmlBuilder.CreateImageMap Method
[image]

Creates an HTML code for a MAP tag.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string CreateImageMap (
string mapName
)

Visual Basic [image] Copy Code

Public Function CreateImageMap( _
mapName As String _
) As String

Parameters

mapName

A string that represents the NAME attribute in the <MAP> tag.

Return Value

A string value containing the generated HTML code.

Remarks

There are <AREA> tags generated for each node or link whose HyperLink is not an empty string. Outlines of items that cannot be represented exactly with standard <AREA> shapes are approximated to polygons. The HREF attribute of the area is set to the value of item's HyperLink property. The ALT attribute is set to the value of item's ToolTip property.

Example

The following HTML code:

HTML [image] Copy Code

<MAP NAME="diagram1">
<AREA SHAPE ="RECT" COORDS="15,3,650,774" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="POLY" COORDS="198,43,195,48,185,52,170,55,151,57,130,58,109,57,90,55,75,52,65,48,62,43,65,38,75,34,90,31,109,29,130,28,151,29,170,31,185,34,195,38,198,43" HREF="" ALT="">
<AREA SHAPE ="POLY" COORDS="96,85,164,85,198,96,198,119,164,130,96,130,62,119,62,96" HREF="http://mindfusion.eu" ALT="">
<AREA SHAPE ="RECT" COORDS="60,151,196,196" HREF="" ALT="">
<AREA SHAPE ="RECT" COORDS="60,230,196,287" HREF="" ALT="">
</MAP>

is generated from the following code:

C# [image] Copy Code
HtmlBuilder hb = new HtmlBuilder(diagram);
string htmlCode = hb.CreateImageMap("diagram");
Visual Basic [image] Copy Code
Dim hb As HtmlBuilder = New HtmlBuilder(diagram)
Dim htmlCode As String = hb.CreateImageMap("diagram")

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.CreateUseMapAttr Method

HtmlBuilder.CreateUseMapAttr Method
[image]

Generates a USEMAP attribute to be used within an <IMG> tag.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string CreateUseMapAttr (
string mapID
)

Visual Basic [image] Copy Code

Public Function CreateUseMapAttr( _
mapID As String _
) As String

Parameters

mapID
A string that represents the ID in the USEMAP attribute of the <IMG> HTML tag.

Return Value

A string that contains the generated HTML code for the USEMAP attribute.

Remarks

Use the same mapID as the one you have passed to CreateImageMap. The method generates also WIDTH and HEIGHT attributes, converting the diagram's MeasureUnit values to pixel values. The properties of ImageExportOptions are also considered, so the generated HTML code corresponds exactly to the exported image.

Example

The result of this method looks like:

HTML [image] Copy Code

USEMAP="#diagram1"WIDTH="672"HEIGHT="808"

and is ready to be inserted in your <IMG> tag.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Properties

HtmlBuilder Properties
[image]

Public Properties

Name | Description
AreasForTableCells | Gets or sets a value indicating whether AREA tags are generated for table cells.
ExpandBtnHyperLink | Gets or sets the hyperlink assigned to AREA tags generated for the +/- buttons of expandable nodes.
LinkTarget | Gets or sets the value of the TARGET attribute of AREA tags.
Scale | Gets or sets the scale factor for the generated image.

See Also

HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.AreasForTableCells Property

HtmlBuilder.AreasForTableCells Property
[image]

Gets or sets a value indicating whether AREA tags are generated for table cells.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AreasForTableCells { get; set; }

Visual Basic [image] Copy Code

Public Property AreasForTableCells As Boolean

Property Value

true to create AREA tags for table cells; otherwise, false. The default is false.

Remarks

If disabled, there is a single <AREA> created for each table, corresponding to the table's bounding rectangle. If enabled, each cell of a table has a corresponding <AREA> tag created and one <AREA> is created for the table's caption bar rectangle.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace
Table.Cell.HyperLink Property


MindFusion.Diagramming.Wpf.HtmlBuilder.ExpandBtnHyperLink Property

HtmlBuilder.ExpandBtnHyperLink Property
[image]

Gets or sets the hyperlink assigned to AREA tags generated for the +/- buttons of expandable nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ExpandBtnHyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandBtnHyperLink As String

Property Value

A string value containing an URL. The default is an empty string.

Remarks

If the value of this property is not an empty string, the HtmlBuilder creates <AREA> tags for the expand/collapse buttons displayed besides nodes. That lets you process requests to expand or collapse a tree branch on the server, or just use the [±] button as additional hot spots in the image map. The hyperlink string can contain any of the following format specifiers:

Specifier | Description
{0} | Replaced with the ZIndex of the node associated with the [±] button.
{1} | Replaced with the Tag of the node associated with the [±] button.

The ZIndex of a node can be used to directly access the node within the Items collection, it has the same value as the index of an item within that collection. The Tag can be used to find a node through the FindNode method.

Example

To have a JavaScript method called with node's Tag passed as parameter when a [±] button area is clicked, setup an HtmlBuilder instance as shown below:

C# [image] Copy Code
HtmlBuilder hb = new HtmlBuilder(diagram);
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})";
...
Visual Basic [image] Copy Code
Dim hb As New HtmlBuilder(diagram)
hb.ExpandBtnHyperLink = "javascript: void processExpand({1})"
...

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.LinkTarget Property

HtmlBuilder.LinkTarget Property
[image]

Gets or sets the value of the TARGET attribute of AREA tags.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string LinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTarget As String

Property Value

A string containing the target frame name. The default is "_self".

Remarks

This property provides a value for the TARGET attribute of each <AREA> tag included in the image map. TARGET indicates the target window or frame where image area hyperlinks are opened. The target could be either a named frame or one of the following special values:

Value | Description
_blank | Loads the linked document into a new blank window.
_parent | Loads the linked document into current document's parent.
_self | Loads the linked document into the same window.
_top | Loads the linked document into the topmost browser window.

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.Scale Property

HtmlBuilder.Scale Property
[image]

Gets or sets the scale factor for the generated image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A double value that specifies the scale factor for the generated diagram image. The default is 100 (indicating no scale transformation).

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder Events

HtmlBuilder Events
[image]

Public Events

Name | Description
CreatingArea | Raised just before a new AREA tag is added to the image map.

See Also

HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HtmlBuilder.CreatingArea Event

HtmlBuilder.CreatingArea Event
[image]

Raised just before a new AREA tag is added to the image map.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<AreaEventArgs> CreatingArea

Visual Basic [image] Copy Code

Public Event CreatingArea As EventHandler(Of AreaEventArgs)

Event Data

CreatingArea event handlers receive an argument of type AreaEventArgs. The following AreaEventArgs members provide information relevant to the event:

Member name | Description
AreaTag | The HTML AREA tag created by HtmlBuilder.
Item | The diagram element represented by AreaTag in the image map.
Column | Contains the index of a column if the event is raised for a table cell.
Row | Contains the index of a row if the event is raised for a table cell.

Remarks

You could handle this event in order to insert additional attributes or JavaScript event handlers into the AREA tag. The tag string already ends with a closing ">" when the event is raised, so you must insert any additional attributes one character before the end of the tag string.

Example

The following code adds a JavaScript onClick event handler to the area tag:

C# [image] Copy Code
void htb_CreatingArea(object sender, AreaEventArgs e)
{
string script = " onClick=\"alert('click click')\"";
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script);
}
Visual Basic [image] Copy Code

Private Sub htb_CreatingArea(ByVal sender As Object, ByVal e As AreaEventArgs) Handles htb.CreatingArea

Dim script As String = " onClick=" + Chr(34) + "alert('click click')" + Chr(34)
e.AreaTag = e.AreaTag.Insert(e.AreaTag.Length - 1, script)

End Sub

See Also

HtmlBuilder Members
HtmlBuilder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.HyperLinkStyle Enumeration

HyperLinkStyle Enumeration
[image]

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HyperLinkStyle

Visual Basic [image] Copy Code

Public Enum HyperLinkStyle

Members

Member name | Description
None | Do not generate hyperlinks.
Shape | Generate hyperlinks that correspond to the item's shape.
Text | Generate hyperlinks for the text bounding rectangle.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory Interface

IItemFactory Interface
[image]

Defines an interface for constructing IPersists objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface IItemFactory

Visual Basic [image] Copy Code

Public Interface IItemFactory

Inheritors

MindFusion.Diagramming.Wpf.Diagram

See Also

IItemFactory Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory Members

IItemFactory Members
Properties Methods Events
[image]

Defines an interface for constructing IPersists objects.

The following tables list the members exposed by the IItemFactory type.

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

Public Methods

Name | Description
CreateItem | Creates a new object given its item class string identifier.

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory Methods

IItemFactory Methods
[image]

Public Methods

Name | Description
CreateItem | Creates a new object given its item class string identifier.

See Also

IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory.CreateItem Method

IItemFactory.CreateItem Method
[image]

Creates a new object given its item class string identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Object CreateItem (
string itemClass
)

Visual Basic [image] Copy Code

Function CreateItem( _
itemClass As String _
) As Object

Parameters

itemClass

The class string id of the item to create.

Return Value

An instance of a class implementing the IPersists interface corresponding to the class with the specified id.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory Properties

IItemFactory Properties
[image]

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

See Also

IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory.ClsidTable Property

IItemFactory.ClsidTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Hashtable ClsidTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property ClsidTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class types and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory.TypeTable Property

IItemFactory.TypeTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Hashtable TypeTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property TypeTable As Hashtable

Property Value

An instance of the .NET Hashtable class that represents a map between the class string identifiers and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory Events

IItemFactory Events
[image]

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.IItemFactory.InstantiateItem Event

IItemFactory.InstantiateItem Event
[image]

Lets external classes handle item instantiation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

event EventHandler<InstantiateItemEventArgs> InstantiateItem

Visual Basic [image] Copy Code

Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

InstantiateItem event handlers receive an argument of type InstantiateItemEventArgs.

See Also

IItemFactory Members
IItemFactory Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter Interface

ILinkRouter Interface
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface ILinkRouter

Visual Basic [image] Copy Code

Public Interface ILinkRouter

Inheritors

MindFusion.Diagramming.Wpf.GridRouter
MindFusion.Diagramming.Wpf.QuickRouter

See Also

ILinkRouter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter Members

ILinkRouter Members
Properties Methods
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

The following tables list the members exposed by the ILinkRouter type.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter Methods

ILinkRouter Methods
[image]

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter.Resume Method

ILinkRouter.Resume Method
[image]

Called when the control ends a batch update operation that might affect many links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace
Suspend Method


MindFusion.Diagramming.Wpf.ILinkRouter.RouteLink Method

ILinkRouter.RouteLink Method
[image]

Called when a single link must be routed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link
A DiagramLink object representing the link.

Return Value

true if a path has been found, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter.RouteLinks Method

ILinkRouter.RouteLinks Method
[image]

Called when more than one links must be routed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection containing the links that should be routed.

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter.Suspend Method

ILinkRouter.Suspend Method
[image]

Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void Suspend ()

Visual Basic [image] Copy Code

Sub Suspend ()

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter Properties

ILinkRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ILinkRouter.Diagram Property

ILinkRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

ILinkRouter Members
ILinkRouter Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ImageAlign Enumeration

ImageAlign Enumeration
[image]

Specifies the position and alignment of a picture in a node or table, or that of the background image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ImageAlign

Visual Basic [image] Copy Code

Public Enum ImageAlign

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered in the node or diagram.
Fit | The image is resized to fit the size of the object or the component's client area.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the object or the component's client area.
Tile | The image is tiled across the node or the component's area.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned o the top right corner.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable Interface

InplaceEditable Interface
[image]

Represents an in-place editable object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface InplaceEditable

Visual Basic [image] Copy Code

Public Interface InplaceEditable

Inheritors

MindFusion.Diagramming.Wpf.BarcodeNode
MindFusion.Diagramming.Wpf.ContainerNode
MindFusion.Diagramming.Wpf.DiagramLink
MindFusion.Diagramming.Wpf.FreeFormNode
MindFusion.Diagramming.Wpf.LinkLabel
MindFusion.Diagramming.Wpf.ShapeNode
MindFusion.Diagramming.Wpf.TableNode
MindFusion.Diagramming.Wpf.TableNode.Cell
MindFusion.Diagramming.Wpf.TemplatedNode
MindFusion.Diagramming.Wpf.TreeViewItem
MindFusion.Diagramming.Wpf.TreeViewNode
MindFusion.Diagramming.Wpf.Lanes.Header

See Also

InplaceEditable Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable Members

InplaceEditable Members
Methods
[image]

Represents an in-place editable object.

The following tables list the members exposed by the InplaceEditable type.

Public Methods

Name | Description
GetDiagramItem | Returns the item to which the GetEditRect is relative
GetEditRect | Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable Methods

InplaceEditable Methods
[image]

Public Methods

Name | Description
GetDiagramItem | Returns the item to which the GetEditRect is relative
GetEditRect | Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable.GetDiagramItem Method

InplaceEditable.GetDiagramItem Method
[image]

Returns the item to which the GetEditRect is relative

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

DiagramItem GetDiagramItem ()

Visual Basic [image] Copy Code

Function GetDiagramItem () As DiagramItem

Return Value

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable.GetEditRect Method

InplaceEditable.GetEditRect Method
[image]

Returns the rectangle where the in-place editing text box appears in coordinates relative to the item returned by GetDiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Rect GetEditRect (
Point mousePosition
)

Visual Basic [image] Copy Code

Function GetEditRect( _
mousePosition As Point _
) As Rect

Parameters

mousePosition
Specifies the mouse position.

Return Value

A .NET Rect instance that represents the destination rectangle of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable.GetTextToEdit Method

InplaceEditable.GetTextToEdit Method
[image]

Returns the text of the object which should be displayed initially when the object is in-place edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

string GetTextToEdit ()

Visual Basic [image] Copy Code

Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place editing box.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InplaceEditable.SetEditedText Method

InplaceEditable.SetEditedText Method
[image]

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

InplaceEditable Members
InplaceEditable Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs Class

InPlaceEditEventArgs Class
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class InPlaceEditEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InPlaceEditEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.InPlaceEditEventArgs

See Also

InPlaceEditEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs Members

InPlaceEditEventArgs Members
Properties
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

The following tables list the members exposed by the InPlaceEditEventArgs type.

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextBox | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs Properties

InPlaceEditEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextBox | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs.Item Property

InPlaceEditEventArgs.Item Property
[image]

Gets a reference to the item being edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As InplaceEditable

Property Value

An InplaceEditable reference representing the node or table cell being edited.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs.Node Property

InPlaceEditEventArgs.Node Property
[image]

Gets the diagram node being edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class that represents either the node being edited, or the table that contains the edited cell.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InPlaceEditEventArgs.TextBox Property

InPlaceEditEventArgs.TextBox Property
[image]

Gets the control used to edit the item's text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextBox TextBox { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextBox As TextBox

Property Value

An instance of the .NET TextBox class.

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Contains the arguments passed to the InstantiateItem event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the InstantiateItem event handlers.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs Constructor

InstantiateItemEventArgs Constructor
[image]

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InstantiateItemEventArgs (
string itemClass
)

Visual Basic [image] Copy Code

Public New ( _
itemClass As String _
)

Parameters

itemClass

The class string identifier specifying the type of the new item.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property
[image]

Gets or sets a reference to the created diagram item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateItemEventArgs.ItemClass Property

InstantiateItemEventArgs.ItemClass Property
[image]

Gets the item class identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ItemClass { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemClass As String

Property Value

A string value specifying the item class identifier.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateLink Delegate

InstantiateLink Delegate
[image]

Represent a method that creates actual DiagramLink objects to represent data items on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate DiagramLink InstantiateLink (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateLink( _
dataItem As Object _
) As DiagramLink

Parameters

dataItem

A data item that should be shown on screen.

Return Value

A DiagramLink instance.

Remarks

The delegate method can be assigned to the InstantiateLink property of VirtualizingDiagram to create instances of a custom link type.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateLinkData Delegate

InstantiateLinkData Delegate
[image]

Represents a method that instantiates data items for links drawn by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate Object InstantiateLinkData (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateLinkData( _
link As DiagramLink _
) As Object

Parameters

link

A DiagramLink drawn by the user.

Return Value

A data item for the new link.

Remarks

The delegate method can be assigned to the InstantiateLinkData property of VirtualizingDiagram to create data items when the user draws new links.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateNode Delegate

InstantiateNode Delegate
[image]

Represent a method that creates actual DiagramNode -derived objects to represent data items on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate DiagramNode InstantiateNode (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateNode( _
dataItem As Object _
) As DiagramNode

Parameters

dataItem

A data item that should be shown on screen.

Return Value

A DiagramNode instance.

Remarks

The delegate method can be assigned to the InstantiateNode property of VirtualizingDiagram to create instances of a custom node type.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InstantiateNodeData Delegate

InstantiateNodeData Delegate
[image]

Represents a method that instantiates data items for nodes drawn by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate Object InstantiateNodeData (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Delegate Function InstantiateNodeData( _
node As DiagramNode _
) As Object

Parameters

node

A DiagramNode drawn by the user.

Return Value

A data item for the new node.

Remarks

The delegate method can be assigned to the InstantiateNodeData property of VirtualizingDiagram to create data items when the user draws new nodes.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction Class

Interaction Class
[image]

Tracks mouse messages to implement user interaction with the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Interaction

Visual Basic [image] Copy Code

Public Class Interaction

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase

See Also

Interaction Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction Members

Interaction Members
Constructors Properties Methods
[image]

Tracks mouse messages to implement user interaction with the diagram.

The following tables list the members exposed by the Interaction type.

Protected Constructors

Name | Description
Interaction | Initializes a new instance of the Interaction class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object.

Protected Methods

Name | Description
OnMouseDown | Invoked when the mouse button is pressed.
OnMouseMove | Invoked when the mouse moves.
OnMouseUp | Invoked when the mouse button is released.

See Also

Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction Constructor

Interaction Constructor
[image]

Initializes a new instance of the Interaction class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Interaction (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram whose content will be modified.

See Also

Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction Methods

Interaction Methods
[image]

Protected Methods

Name | Description
OnMouseDown | Invoked when the mouse button is pressed.
OnMouseMove | Invoked when the mouse moves.
OnMouseUp | Invoked when the mouse button is released.

See Also

Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction.OnMouseDown Method

Interaction.OnMouseDown Method
[image]

Invoked when the mouse button is pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseDown (
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseDown( _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

mouseButton
A member of the MouseButton enumeration.

See Also

Interaction Members
Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction.OnMouseMove Method

Interaction.OnMouseMove Method
[image]

Invoked when the mouse moves.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseMove (
Point mousePosition
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseMove( _
mousePosition As Point _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

See Also

Interaction Members
Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction.OnMouseUp Method

Interaction.OnMouseUp Method
[image]

Invoked when the mouse button is released.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseUp (
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseUp( _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

mouseButton
A member of the MouseButton enumeration.

See Also

Interaction Members
Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction Properties

Interaction Properties
[image]

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object.

See Also

Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Interaction.Diagram Property

Interaction.Diagram Property
[image]

Gets the Diagram modified through this Interaction object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

Interaction Members
Interaction Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState Class

InteractionState Class
Remarks See Also
[image]

Encapsulates the current state of user interaction with the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class InteractionState

Visual Basic [image] Copy Code

Public Class InteractionState

Remarks

Return an instance of this class from the StartDraw method of a custom Behavior class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.InteractionState

See Also

InteractionState Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState Members

InteractionState Members
Constructors Properties Methods
[image]

Encapsulates the current state of user interaction with the control.

The following tables list the members exposed by the InteractionState type.

Public Constructors

Name | Description
InteractionState | Initializes a new instance of the InteractionState class.

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the adjustment handle being dragged by the user.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
SkipSavingState | Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.
StartPoint | Gets the mouse position where the interaction started.

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the adjustment handle tracked by this object to the specified handle.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState Constructor

InteractionState Constructor
[image]

Initializes a new instance of the InteractionState class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InteractionState (
DiagramItem currentItem,
AdjustmentHandle adjustmentHandle,
Action action
)

Visual Basic [image] Copy Code

Public New ( _
currentItem As DiagramItem, _
adjustmentHandle As AdjustmentHandle, _
action As Action _
)

Parameters

currentItem

The DiagramItem to be created or modified.

adjustmentHandle
An AdjustmentHandle instance that identifies what kind of modification to perform.
action

One of the Action enumeration values, specifying what kind of action to perform.

See Also

InteractionState Class
MindFusion.Diagramming.Wpf Namespace
BehaviorBase.StartDraw Method


MindFusion.Diagramming.Wpf.InteractionState Methods

InteractionState Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the user interaction.
CancelNow | Instruct the interaction to terminate on the next pass.
Complete | This method is invoked to complete the interaction, usually when the user releases the left mouse button.
IsAllowed | Checks whether the current interaction can be completed at the specified point.
IsCompleting | Returns whether the interaction has been completed successfully.
SetHandleIndex | Sets the adjustment handle tracked by this object to the specified handle.
SetItemDeleted | Notifies the interaction that its associated diagram item has been deleted.
ShouldCancelDrag | Gets a value indicating whether the interaction should terminate on the next pass.
Start | This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.
Update | This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.
ValidateAndSetCursor | Sets the cursor depending on whether the interaction can be completed at the specified point or not.

See Also

InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.Cancel Method

InteractionState.Cancel Method
[image]

Cancels the user interaction.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Cancel (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Cancel( _
diagram As Diagram _
)

Parameters

diagram
The Diagram, at which the action is performed.

Remarks

Call this method to cancel interaction, usually in response to the user clicking the right mouse button while dragging.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace
CancelNow Method


MindFusion.Diagramming.Wpf.InteractionState.CancelNow Method

InteractionState.CancelNow Method
[image]

Instruct the interaction to terminate on the next pass.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelNow ()

Visual Basic [image] Copy Code

Public Sub CancelNow ()

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace
Cancel Method


MindFusion.Diagramming.Wpf.InteractionState.Complete Method

InteractionState.Complete Method
[image]

This method is invoked to complete the interaction, usually when the user releases the left mouse button.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Complete (
Point point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Complete( _
point As Point, _
diagram As Diagram _
)

Parameters

point
A .NET Point instance indicating the location of the cursor, in document coordinates.
diagram
The Diagram, at which the action is performed.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace
IsCompleting Method


MindFusion.Diagramming.Wpf.InteractionState.IsAllowed Method

InteractionState.IsAllowed Method
[image]

Checks whether the current interaction can be completed at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsAllowed (
Point point
)

Visual Basic [image] Copy Code

Public Function IsAllowed( _
point As Point _
) As Boolean

Parameters

point
A .NET Point instance indicating the location of the cursor, in document coordinates.

Return Value

true if the action can be completed at point; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.IsCompleting Method

InteractionState.IsCompleting Method
[image]

Returns whether the interaction has been completed successfully.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsCompleting ()

Visual Basic [image] Copy Code

Public Function IsCompleting () As Boolean

Return Value

true if the interaction has been completed successfully; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace
Complete Method


MindFusion.Diagramming.Wpf.InteractionState.SetHandleIndex Method

InteractionState.SetHandleIndex Method
[image]

Sets the adjustment handle tracked by this object to the specified handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetHandleIndex (
AdjustmentHandle newIndex
)

Visual Basic [image] Copy Code

Public Sub SetHandleIndex( _
newIndex As AdjustmentHandle _
)

Parameters

newIndex

An AdjustmentHandle instance representing the modified handle.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.SetItemDeleted Method

InteractionState.SetItemDeleted Method
[image]

Notifies the interaction that its associated diagram item has been deleted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetItemDeleted ()

Visual Basic [image] Copy Code

Public Sub SetItemDeleted ()

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.ShouldCancelDrag Method

InteractionState.ShouldCancelDrag Method
[image]

Gets a value indicating whether the interaction should terminate on the next pass.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShouldCancelDrag ()

Visual Basic [image] Copy Code

Public Function ShouldCancelDrag () As Boolean

Return Value

true if the interaction should terminate; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.Start Method

InteractionState.Start Method
[image]

This method is invoked in the beginning of the interaction, usually when the user presses the left mouse button over a modification handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Start (
Point point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Start( _
point As Point, _
diagram As Diagram _
)

Parameters

point
A .NET Point instance indicating the location of the cursor, in document coordinates.
diagram
The Diagram, at which the interaction is performed.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.Update Method

InteractionState.Update Method
[image]

This method is invoked to update the interaction state, usually in response to the user moving the mouse after the modification has started.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Update (
Point point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function Update( _
point As Point, _
diagram As Diagram _
) As Boolean

Parameters

point
A .NET Point instance indicating the location of the cursor, in document coordinates.
diagram
The Diagram, at which the interaction is performed.

Return Value

true if the update has been successful; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.ValidateAndSetCursor Method

InteractionState.ValidateAndSetCursor Method
[image]

Sets the cursor depending on whether the interaction can be completed at the specified point or not.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CursorHint ValidateAndSetCursor (
Point point,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function ValidateAndSetCursor( _
point As Point, _
diagram As Diagram _
) As CursorHint

Parameters

point
A .NET Point instance indicating the location of the cursor, in document coordinates.
diagram
The Diagram, at which the interaction is performed.

Return Value

One of the CursorHint enumeration values, which is used by Diagram to set its Cursor property.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState Properties

InteractionState Properties
[image]

Public Properties

Name | Description
Action | Gets the type of Action currently performed by the user in the Diagram.
AdjustmentHandle | Gets the adjustment handle being dragged by the user.
CurrentItem | Gets a reference to the DiagramItem to be created or modified.
CurrentPoint | Gets the current location of the mouse pointer.
Diagram | Gets the current Diagram instance.
LinkTarget | Gets or sets the current target node when a link is being modified.
MouseMoved | Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.
SkipSavingState | Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.
StartPoint | Gets the mouse position where the interaction started.

See Also

InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.Action Property

InteractionState.Action Property
[image]

Gets the type of Action currently performed by the user in the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Action Action { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Action As Action

Property Value

A member of the Action enumeration that specifies what kind of action the user currently performes on the Diagram.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.AdjustmentHandle Property

InteractionState.AdjustmentHandle Property
[image]

Gets the adjustment handle being dragged by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandle

Property Value

An AdjustmentHandle instance representing the current modification handle.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.CurrentItem Property

InteractionState.CurrentItem Property
[image]

Gets a reference to the DiagramItem to be created or modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem CurrentItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentItem As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.CurrentPoint Property

InteractionState.CurrentPoint Property
[image]

Gets the current location of the mouse pointer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point CurrentPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentPoint As Point

Property Value

A .NET Point instance that specifies the current location of the cursor, in document coordinates.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.Diagram Property

InteractionState.Diagram Property
[image]

Gets the current Diagram instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.LinkTarget Property

InteractionState.LinkTarget Property
[image]

Gets or sets the current target node when a link is being modified.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode LinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTarget As DiagramNode

Property Value

A DiagramNode that the currently modified DiagramLink should connect to if the interaction completes at the current mouse position.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.MouseMoved Property

InteractionState.MouseMoved Property
[image]

Gets or sets a value indicating whether the mouse pointer has moved since the user pressed down the mouse button.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MouseMoved { get; set; }

Visual Basic [image] Copy Code

Public Property MouseMoved As Boolean

Property Value

True is the mouse has moved; otherwise, false.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.SkipSavingState Property

InteractionState.SkipSavingState Property
[image]

Gets a value indicating whether diagram items should skip storing their state for subsequent cancel.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SkipSavingState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SkipSavingState As Boolean

Property Value

A boolean value.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InteractionState.StartPoint Property

InteractionState.StartPoint Property
[image]

Gets the mouse position where the interaction started.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point StartPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartPoint As Point

Property Value

A Point specifying the mouse position where the user started to draw or modify an item.

See Also

InteractionState Members
InteractionState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils Class

InternalUtils Class
Remarks See Also
[image]

Contains common helper methods, specific to MindFusion.Diagramming for WPF.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class InternalUtils

Visual Basic [image] Copy Code

Public NotInheritable Class InternalUtils

Remarks

This class supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.InternalUtils

See Also

InternalUtils Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils Members

InternalUtils Members
Methods
[image]

Contains common helper methods, specific to MindFusion.Diagramming for WPF.

The following tables list the members exposed by the InternalUtils type.

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CreateRoundRectRgn | Creates a round rectangle region.
DrawAdjustmentHandles | Draws node adjustment handles of the specified style.
DrawExpandButton | Overloaded.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Overloaded. Gets the type with the specified name from the specified assembly.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
MidPoint | Returns the middle point of the segment defined by the specified points.
PointInRect | Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils Methods

InternalUtils Methods
[image]

Public Methods

Name | Description
AddToRect | Inflate/deflate the specified rectangle with the specified values.
ApproxBezier | Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
ApproxEllipse | Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.
CreateRoundRectRgn | Creates a round rectangle region.
DrawAdjustmentHandles | Draws node adjustment handles of the specified style.
DrawExpandButton | Overloaded.
DrawRect | Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetLoadedAssembly | Gets the specified assembly.
GetLoadedType | Overloaded. Gets the type with the specified name from the specified assembly.
GetRoundRect | Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.
MidPoint | Returns the middle point of the segment defined by the specified points.
PointInRect | Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the specified rectangle as an array.
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.
UnionRects | Returns the smallest possible rectangle containing both of the specified rectangles.

See Also

InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.AddToRect Method

InternalUtils.AddToRect Method
[image]

Inflate/deflate the specified rectangle with the specified values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void AddToRect (
ref Rect rect,
double w,
double h
)

Visual Basic [image] Copy Code

Public Shared Sub AddToRect( _
ByRef rect As Rect, _
w As Double, _
h As Double _
)

Parameters

rect
The .NET Rect instance that should be modified.
w

The increment/decrement of the rectangle width.

h

The increment/decrement of the rectangle height.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.ApproxBezier Method

InternalUtils.ApproxBezier Method
[image]

Approximates the specified Bézier curve with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static PointCollection ApproxBezier (
Point[] points,
int startIdx,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier( _
points() As Point, _
startIdx As Integer, _
quality As Integer _
) As PointCollection

Parameters

points

An array of Point objects, which defines the Bézier curve.

startIdx

The index of the first point to be processed in points.

quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.ApproxEllipse Method

InternalUtils.ApproxEllipse Method
[image]

Approximates the ellipse contained in the specified rectanlge with a polyline. The specified quality parameter varies in the interval [1, ...) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static PointCollection ApproxEllipse (
Rect rect,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxEllipse( _
rect As Rect, _
quality As Integer _
) As PointCollection

Parameters

rect

A Rect instance, which defines the source ellipse.

quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.CreateRoundRectRgn Method

InternalUtils.CreateRoundRectRgn Method
[image]

Creates a round rectangle region.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Geometry CreateRoundRectRgn (
Rect rc,
double r
)

Visual Basic [image] Copy Code

Public Shared Function CreateRoundRectRgn( _
rc As Rect, _
r As Double _
) As Geometry

Parameters

rc

A Rect instance, which defines the rounded rectangle bounds.

r

The radius of the rectangle corners.

Return Value

An instance of the .NET Region class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.DrawAdjustmentHandles Method

InternalUtils.DrawAdjustmentHandles Method
[image]

Draws node adjustment handles of the specified style.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawAdjustmentHandles (
DrawingContext graphics,
HandlesVisualStyle enabledStyle,
HandlesVisualStyle disabledStyle,
Rect nodeBounds,
double rotationAngle,
AdjustmentHandles enabledHandles,
bool showDisabled,
HandlesStyle handlesStyle,
double size,
DiagramItem item
)

Visual Basic [image] Copy Code

Public Shared Sub DrawAdjustmentHandles( _
graphics As DrawingContext, _
enabledStyle As HandlesVisualStyle, _
disabledStyle As HandlesVisualStyle, _
nodeBounds As Rect, _
rotationAngle As Double, _
enabledHandles As AdjustmentHandles, _
showDisabled As Boolean, _
handlesStyle As HandlesStyle, _
size As Double, _
item As DiagramItem _
)

Parameters

graphics

A DrawingContext surface to draw upon.

enabledStyle
A HandlesVisualStyle instance specifying the appearance of enabled handles.
disabledStyle
A HandlesVisualStyle instance specifying the appearance of disabled handles.
nodeBounds
A System.Windows.Rect specifying the node size.
rotationAngle
A double value specifying the node's rotation angle in degrees.
enabledHandles
A combination of AdjustmentHandles flags specifying which handles are enabled.
showDisabled
true to draw disabled handles, otherwise false.
handlesStyle
A HandlesStyle member specifying the type of adjustment handles to draw.
size
A double value specifying the size of individual adjustment handles.
item
A DiagramItem for which to draw adjustment handles.

Remarks

Use this method to render adjustment handles with standard look and feel as a base for custom-drawn ones when handling the DrawAdjustmentHandles event.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.DrawExpandButton Method

InternalUtils.DrawExpandButton Method
[image]

Overload List

Name | Description
InternalUtils.DrawExpandButton (DrawingContext, Boolean, Rect, GraphicsUnit, Boolean, Color) | Renders an expand/collapse button on the specified IGraphics canvas.
InternalUtils.DrawExpandButton (DrawingContext, Boolean, Rect, GraphicsUnit, Brush, DiagramItem) | Renders an expand/collapse button to the specified graphics.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.DrawExpandButton Method (DrawingContext, Boolean, Rect, GraphicsUnit, Boolean, Color)

InternalUtils.DrawExpandButton Method (DrawingContext, Boolean, Rect, GraphicsUnit, Boolean, Color)
See Also
[image]

Renders an expand/collapse button on the specified IGraphics canvas.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawExpandButton (
DrawingContext graphics,
bool expanded,
Rect bounds,
GraphicsUnit measureUnit,
bool withShadow,
Color shadowColor
)

Visual Basic [image] Copy Code

Public Shared Sub DrawExpandButton( _
graphics As DrawingContext, _
expanded As Boolean, _
bounds As Rect, _
measureUnit As GraphicsUnit, _
withShadow As Boolean, _
shadowColor As Color _
)

Parameters

graphics

expanded

bounds

measureUnit

withShadow

shadowColor

See Also

DrawExpandButton Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.DrawExpandButton Method (DrawingContext, Boolean, Rect, GraphicsUnit, Brush, DiagramItem)

InternalUtils.DrawExpandButton Method (DrawingContext, Boolean, Rect, GraphicsUnit, Brush, DiagramItem)
See Also
[image]

Renders an expand/collapse button to the specified graphics.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawExpandButton (
DrawingContext graphics,
bool expanded,
Rect bounds,
GraphicsUnit measureUnit,
Brush shadowBrush,
DiagramItem item
)

Visual Basic [image] Copy Code

Public Shared Sub DrawExpandButton( _
graphics As DrawingContext, _
expanded As Boolean, _
bounds As Rect, _
measureUnit As GraphicsUnit, _
shadowBrush As Brush, _
item As DiagramItem _
)

Parameters

graphics

The DrawingContext object that represents the target of the drawing operation.

expanded

Specifies whether the drawn button is expanded or collapsed.

bounds

The destination rectangle of the button.

measureUnit

The current measure unit.

shadowBrush

The Brush to use in order to draw the button shadow.

item

The item whose expand button is being drawn.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

DrawExpandButton Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.DrawRect Method

InternalUtils.DrawRect Method
[image]

Draws the specified rectangle using the specified pen for stroking and the specified brush for filling.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void DrawRect (
DrawingContext graphics,
Pen p,
Brush b,
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Shared Sub DrawRect( _
graphics As DrawingContext, _
p As Pen, _
b As Brush, _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

graphics

The DrawingContext object that represents the target of the drawing operation.

p

The Pen to use when drawing the outline.

b

The Brush to use when filling the contents.

x

The x-coordinate of the top-left corner of the drawn rectangle.

y

The y-coordinate of the top-left corner of the drawn rectangle.

width

The width of the drawn rectangle.

height

The height of the drawn rectangle.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetExpandIconSize Method

InternalUtils.GetExpandIconSize Method
[image]

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double GetExpandIconSize (
GraphicsUnit currUnit
)

Visual Basic [image] Copy Code

Public Shared Function GetExpandIconSize( _
currUnit As GraphicsUnit _
) As Double

Parameters

currUnit

Return Value

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetLoadedAssembly Method

InternalUtils.GetLoadedAssembly Method
[image]

Gets the specified assembly.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Assembly GetLoadedAssembly (
string asmName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedAssembly( _
asmName As String _
) As Assembly

Parameters

asmName

The full name of the assembly.

Return Value

An instance of the .NET Assembly class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetLoadedType Method

InternalUtils.GetLoadedType Method
[image]

Gets the type with the specified name from the specified assembly.

Overload List

Name | Description
InternalUtils.GetLoadedType (String) | Gets the type with the specified name.
InternalUtils.GetLoadedType (String, String) | Gets the type with the specified name from the specified assembly.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetLoadedType Method (String)

InternalUtils.GetLoadedType Method (String)
See Also
[image]

Gets the type with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Type GetLoadedType (
string typeName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedType( _
typeName As String _
) As Type

Parameters

typeName

The full name of the type.

Return Value

An instance of the .NET Type class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

GetLoadedType Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetLoadedType Method (String, String)

InternalUtils.GetLoadedType Method (String, String)
See Also
[image]

Gets the type with the specified name from the specified assembly.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Type GetLoadedType (
string typeName,
string asmName
)

Visual Basic [image] Copy Code

Public Shared Function GetLoadedType( _
typeName As String, _
asmName As String _
) As Type

Parameters

typeName

The full name of the type.

asmName

The full name of the containing assembly.

Return Value

An instance of the .NET Type class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

GetLoadedType Method Overload List
InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.GetRoundRect Method

InternalUtils.GetRoundRect Method
[image]

Creates a graphics path of a rounded rectangle with the specified dimensions and round radius.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Geometry GetRoundRect (
Rect rc,
double r
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRect( _
rc As Rect, _
r As Double _
) As Geometry

Parameters

rc

A Rect instance, which defines the source rectangle.

r

The radius of the rectangle corners.

Return Value

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.MidPoint Method

InternalUtils.MidPoint Method
[image]

Returns the middle point of the segment defined by the specified points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point MidPoint (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function MidPoint( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

The first point.

pt2

The second point.

Return Value

A .NET Point instance that represents the middle point.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.PointInRect Method

InternalUtils.PointInRect Method
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool PointInRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.RectangleToPoints Method

InternalUtils.RectangleToPoints Method
[image]

Returns the points of the specified rectangle as an array.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point[] RectangleToPoints (
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function RectangleToPoints( _
r As Rect _
) As Point()

Parameters

r

The source rectangle.

Return Value

An array of Point objects, which contains the vertices of the rectangle.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.UnionNonEmptyRects Method

InternalUtils.UnionNonEmptyRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect UnionNonEmptyRects (
Rect rc1,
Rect rc2
)

Visual Basic [image] Copy Code

Public Shared Function UnionNonEmptyRects( _
rc1 As Rect, _
rc2 As Rect _
) As Rect

Parameters

rc1

The first rectangle.

rc2

The second rectangle.

Return Value

A .NET Rect instance that represents the union of the specified arguments.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.InternalUtils.UnionRects Method

InternalUtils.UnionRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Rect UnionRects (
Rect a,
Rect b
)

Visual Basic [image] Copy Code

Public Shared Function UnionRects( _
a As Rect, _
b As Rect _
) As Rect

Parameters

a

The first rectangle.

b

The second rectangle.

Return Value

A .NET Rect instance that represents the union of the specified arguments.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T) Class

ItemCollectionBase(T) Class
[image]

A base collection class for the diagram item collections.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class ItemCollectionBase<T> : CollectionBase<T> where T : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class ItemCollectionBase(Of T As DiagramItem)
Inherits CollectionBase(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.CollectionBase(T)
MindFusion.Diagramming.Wpf.ItemCollectionBase(T)
MindFusion.Diagramming.Wpf.DiagramItemCollection
MindFusion.Diagramming.Wpf.DiagramLinkCollection
MindFusion.Diagramming.Wpf.DiagramNodeCollection

See Also

ItemCollectionBase(T) Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T) Members

ItemCollectionBase(T) Members
Fields Properties Methods
[image]

A base collection class for the diagram item collections.

The following tables list the members exposed by the ItemCollectionBase(T) type.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T) Fields

ItemCollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collecion instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).itemEventArgs Field

ItemCollectionBase(T).itemEventArgs Field
[image]

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected ItemEventArgs itemEventArgs

Visual Basic [image] Copy Code

Protected itemEventArgs As ItemEventArgs

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).notifyParent Field

ItemCollectionBase(T).notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T) Methods

ItemCollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).Add Method

ItemCollectionBase(T).Add Method
[image]

Adds the specified diagram item to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Add (
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
item As T _
)

Parameters

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).Clear Method

ItemCollectionBase(T).Clear Method
[image]

Removes all diagram items from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).GetAt Method

ItemCollectionBase(T).GetAt Method
[image]

Gets the diagram item at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to retrieve.

Return Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).Insert Method

ItemCollectionBase(T).Insert Method
[image]

Inserts the specified diagram item into the collection at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which to insert the item.

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).RaiseAdding Method

ItemCollectionBase(T).RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseAdding (
UIElement item
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding( _
item As UIElement _
)

Parameters

item

The diagram item that is being added.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).RaiseInserting Method

ItemCollectionBase(T).RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseInserting (
DiagramItem item,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting( _
item As DiagramItem, _
index As Integer _
)

Parameters

item

The diagram item that is being inserted.

index

Index of the new item.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).RaiseRemoving Method

ItemCollectionBase(T).RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving( _
item As DiagramItem _
)

Parameters

item

The diagram item that is being removed.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).Remove Method

ItemCollectionBase(T).Remove Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
item As T _
) As Boolean

Parameters

item

The DiagramItem object to remove from the collection.

Return Value

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemCollectionBase(T).RemoveAt Method

ItemCollectionBase(T).RemoveAt Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Index of the object that should be removed from this collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.ItemEventArgs

See Also

ItemEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ItemEventArgs (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item
The DiagramItem related to the event.

See Also

ItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs.Index Property

ItemEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the item's position within its containing collection.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item for which the event is raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UIElement Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As UIElement

Property Value

An instance of UIElement.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes Interface

ITextAttributes Interface
[image]

Defines attributes of text content displayed by diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface ITextAttributes

Visual Basic [image] Copy Code

Public Interface ITextAttributes

Inheritors

MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.TextAttributes
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.Lanes.Grid

See Also

ITextAttributes Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes Members

ITextAttributes Members
Properties
[image]

Defines attributes of text content displayed by diagram items.

The following tables list the members exposed by the ITextAttributes type.

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the brush used to draw the item's text.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.

See Also

ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes Properties

ITextAttributes Properties
[image]

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the brush used to draw the item's text.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.

See Also

ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.FontFamily Property

ITextAttributes.FontFamily Property
[image]

Gets or sets the preferred font family for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Property FontFamily As FontFamily

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.FontSize Property

ITextAttributes.FontSize Property
[image]

Gets or sets the font size for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

double FontSize { get; set; }

Visual Basic [image] Copy Code

Property FontSize As Double

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.FontStretch Property

ITextAttributes.FontStretch Property
[image]

Gets or sets the font-stretching characteristics for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

FontStretch FontStretch { get; set; }

Visual Basic [image] Copy Code

Property FontStretch As FontStretch

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.FontStyle Property

ITextAttributes.FontStyle Property
[image]

Gets or sets the font style for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Property FontStyle As FontStyle

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.FontWeight Property

ITextAttributes.FontWeight Property
[image]

Gets or sets the font weight for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Property FontWeight As FontWeight

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextAlignment Property

ITextAttributes.TextAlignment Property
[image]

Gets or sets a value that indicates the horizontal alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Property TextAlignment As TextAlignment

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextBrush Property

ITextAttributes.TextBrush Property
[image]

Gets or sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Property TextBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is Brushes.Black.

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextDecorations Property

ITextAttributes.TextDecorations Property
[image]

Gets or sets the effects to apply to the text of this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

TextDecorationCollection TextDecorations { get; set; }

Visual Basic [image] Copy Code

Property TextDecorations As TextDecorationCollection

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextPadding Property

ITextAttributes.TextPadding Property
[image]

Gets or sets the thickness of padding space between the item boundaries and its text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Property TextPadding As Thickness

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextTrimming Property

ITextAttributes.TextTrimming Property
[image]

Gets or sets the text trimming to employ when text overflows the item area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

TextTrimming TextTrimming { get; set; }

Visual Basic [image] Copy Code

Property TextTrimming As TextTrimming

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextVerticalAlignment Property

ITextAttributes.TextVerticalAlignment Property
[image]

Gets or sets a value that indicates the vertical alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

AlignmentY TextVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Property TextVerticalAlignment As AlignmentY

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ITextAttributes.TextWrapping Property

ITextAttributes.TextWrapping Property
[image]

Gets or sets how this DiagramItem should wrap text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

TextWrapping TextWrapping { get; set; }

Visual Basic [image] Copy Code

Property TextWrapping As TextWrapping

Property Value

See Also

ITextAttributes Members
ITextAttributes Interface
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Class

Layer Class
[image]

Represents a layer in a Diagram object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Layer : DependencyObject

Visual Basic [image] Copy Code

Public Class Layer
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Diagramming.Wpf.Layer

See Also

Layer Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Members

Layer Members
Constructors Fields Properties Methods Events
[image]

Represents a layer in a Diagram object.

The following tables list the members exposed by the Layer type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Fields

Name | Description
ActiveProperty | Identifies the Active dependency property.
LockedProperty | Identifies the Locked dependency property.
TitleProperty | Identifies the Title dependency property.
VisibleProperty | Identifies the Visible dependency property.

Public Properties

Name | Description
Active | Gets or sets a value indicating whether this layer is the active layer of the Diagram.
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Fields

Layer Fields
[image]

Public Fields

Name | Description
ActiveProperty | Identifies the Active dependency property.
LockedProperty | Identifies the Locked dependency property.
TitleProperty | Identifies the Title dependency property.
VisibleProperty | Identifies the Visible dependency property.

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.ActiveProperty Field

Layer.ActiveProperty Field
[image]

Identifies the Active dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActiveProperty As DependencyProperty

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.LockedProperty Field

Layer.LockedProperty Field
[image]

Identifies the Locked dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LockedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LockedProperty As DependencyProperty

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.TitleProperty Field

Layer.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.VisibleProperty Field

Layer.VisibleProperty Field
[image]

Identifies the Visible dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleProperty As DependencyProperty

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Constructor

Layer Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Layer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Methods

Layer Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.OnPropertyChanged Method

Layer.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Properties

Layer Properties
[image]

Public Properties

Name | Description
Active | Gets or sets a value indicating whether this layer is the active layer of the Diagram.
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.Active Property

Layer.Active Property
[image]

Gets or sets a value indicating whether this layer is the active layer of the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Active { get; set; }

Visual Basic [image] Copy Code

Public Property Active As Boolean

Property Value

true if the layer is the currently active layer; otherwise, false.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.Locked Property

Layer.Locked Property
[image]

Gets or sets a value indicating whether the layer is locked.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true if the layer is locked; otherwise, false.

Remarks

Items associated with locked layers cannot be modified interactively, regardless of their own Locked property.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.Title Property

Layer.Title Property
[image]

Gets or sets a title associated with the layer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace
LayerListView Class


MindFusion.Diagramming.Wpf.Layer.Visible Property

Layer.Visible Property
[image]

Gets or sets a value indicating whether the layer is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the layer is visible; otherwise, false.

Remarks

Items associated with hidden layers are not displayed, regardless of their own Visible property.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.ZIndex Property

Layer.ZIndex Property
[image]

Gets or sets the z-index of the layer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer Events

Layer Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Layer.PropertyChanged Event

Layer.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Layer Members
Layer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Class

LayerListView Class
[image]

Represents a list box with MindFusion.Diagramming.Wpf.Layer objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LayerListView : Control

Visual Basic [image] Copy Code

Public Class LayerListView
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.LayerListView

See Also

LayerListView Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Members

LayerListView Members
Constructors Fields Properties Methods
[image]

Represents a list box with MindFusion.Diagramming.Wpf.Layer objects.

The following tables list the members exposed by the LayerListView type.

Public Constructors

Name | Description
LayerListView | Initializes a new instance of the LayerListView class.

Public Fields

Name | Description
AllowTitleEditProperty | Identifies the AllowTitleEdit dependency property.
CheckBoxSizeProperty | Identifies the CheckBoxSize dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ListViewProperty | Identifies the ListView dependency property.
OverviewWidthProperty | Identifies the OverviewWidth dependency property.

Public Properties

Name | Description
AllowTitleEdit | Gets or sets a value indicating whether layer titles can be in-place edited.
CheckBoxSize | Gets or sets the size of the layer checkboxes.
Diagram | Gets or sets the diagram this control is associated with.
ItemHeight | Gets or sets the height of the items.
ListView | Gets or sets the ListView object displayed by the control.
OverviewWidth | Gets or sets the width of the layer overview.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Fields

LayerListView Fields
[image]

Public Fields

Name | Description
AllowTitleEditProperty | Identifies the AllowTitleEdit dependency property.
CheckBoxSizeProperty | Identifies the CheckBoxSize dependency property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ListViewProperty | Identifies the ListView dependency property.
OverviewWidthProperty | Identifies the OverviewWidth dependency property.

See Also

LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.AllowTitleEditProperty Field

LayerListView.AllowTitleEditProperty Field
[image]

Identifies the AllowTitleEdit dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowTitleEditProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowTitleEditProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.CheckBoxSizeProperty Field

LayerListView.CheckBoxSizeProperty Field
[image]

Identifies the CheckBoxSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CheckBoxSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CheckBoxSizeProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.ItemHeightProperty Field

LayerListView.ItemHeightProperty Field
[image]

Identifies the ItemHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemHeightProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.ListViewProperty Field

LayerListView.ListViewProperty Field
[image]

Identifies the ListView dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ListViewProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ListViewProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.OverviewWidthProperty Field

LayerListView.OverviewWidthProperty Field
[image]

Identifies the OverviewWidth dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverviewWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverviewWidthProperty As DependencyProperty

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Constructor

LayerListView Constructor
[image]

Initializes a new instance of the LayerListView class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayerListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Methods

LayerListView Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.OnApplyTemplate Method

LayerListView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView Properties

LayerListView Properties
[image]

Public Properties

Name | Description
AllowTitleEdit | Gets or sets a value indicating whether layer titles can be in-place edited.
CheckBoxSize | Gets or sets the size of the layer checkboxes.
Diagram | Gets or sets the diagram this control is associated with.
ItemHeight | Gets or sets the height of the items.
ListView | Gets or sets the ListView object displayed by the control.
OverviewWidth | Gets or sets the width of the layer overview.

See Also

LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.AllowTitleEdit Property

LayerListView.AllowTitleEdit Property
[image]

Gets or sets a value indicating whether layer titles can be in-place edited.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowTitleEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowTitleEdit As Boolean

Property Value

true to allow in-place editing of layer titles; otherwise, false. The default is false.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.CheckBoxSize Property

LayerListView.CheckBoxSize Property
[image]

Gets or sets the size of the layer checkboxes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CheckBoxSize { get; set; }

Visual Basic [image] Copy Code

Public Property CheckBoxSize As Double

Property Value

A double value.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.Diagram Property

LayerListView.Diagram Property
[image]

Gets or sets the diagram this control is associated with.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

A Diagram object.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.ItemHeight Property

LayerListView.ItemHeight Property
[image]

Gets or sets the height of the items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ItemHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ItemHeight As Double

Property Value

A double value. The default is 55.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.ListView Property

LayerListView.ListView Property
[image]

Gets or sets the ListView object displayed by the control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ListView ListView { get; set; }

Visual Basic [image] Copy Code

Public Property ListView As ListView

Property Value

A WPF ListView object.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LayerListView.OverviewWidth Property

LayerListView.OverviewWidth Property
[image]

Gets or sets the width of the layer overview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double OverviewWidth { get; set; }

Visual Basic [image] Copy Code

Public Property OverviewWidth As Double

Property Value

A double value. The default is 55.

See Also

LayerListView Members
LayerListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Class

LineTemplate Class
[image]

Represents a line segment in a shape definition.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LineTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class LineTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ElementTemplate
MindFusion.Diagramming.Wpf.LineTemplate

See Also

LineTemplate Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Members

LineTemplate Members
Constructors Properties Methods
[image]

Represents a line segment in a shape definition.

The following tables list the members exposed by the LineTemplate type.

Public Constructors

Name | Description
LineTemplate | Overloaded. Initializes a new instance of the LineTemplate class.

Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Constructor

LineTemplate Constructor
[image]

Initializes a new instance of the LineTemplate class.

Overload List

Name | Description
LineTemplate (Double, Double, Double, Double) | Initializes a new instance of the LineTemplate class with the specified start and end point.
LineTemplate (Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

See Also

LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Constructor (Double, Double, Double, Double)

LineTemplate Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Constructor (Double, Double, Double, Double, Color, DashStyle, Double)

LineTemplate Constructor (Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Methods

LineTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate.Clone Method

LineTemplate.Clone Method
[image]

Creates an exact copy of this LineTemplate element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the LineTemplate class.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate.SameAs Method

LineTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj
The ElementTemplate to compare to this template.

Return Value

true if the specified object is a LineTemplate closely approximating this template; otherwise, false.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate Properties

LineTemplate Properties
[image]

Public Properties

Name | Description
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LineTemplate.Coordinates Property

LineTemplate.Coordinates Property
[image]

Gets a double array containing the coordinates of the end points of this line segment.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Double()

Property Value

An array of float values containing the coordinates of the points composing this element.

See Also

LineTemplate Members
LineTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkAdjustmentHandle Class

LinkAdjustmentHandle Class
[image]

Represents an adjustment handle used to modify the position of a link's control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class LinkAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AdjustmentHandle
MindFusion.Diagramming.Wpf.LinkAdjustmentHandle

See Also

LinkAdjustmentHandle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkAdjustmentHandle Members

LinkAdjustmentHandle Members
Constructors Properties Methods
[image]

Represents an adjustment handle used to modify the position of a link's control point.

The following tables list the members exposed by the LinkAdjustmentHandle type.

Public Constructors

Name | Description
LinkAdjustmentHandle | Initializes a new instance of the LinkAdjustmentHandle class.

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items. (Inherited from AdjustmentHandle.)

See Also

LinkAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkAdjustmentHandle Constructor

LinkAdjustmentHandle Constructor
[image]

Initializes a new instance of the LinkAdjustmentHandle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkAdjustmentHandle (
int pointIndex
)

Visual Basic [image] Copy Code

Public New ( _
pointIndex As Integer _
)

Parameters

pointIndex

An integer value specifying the index of a link's control point that will be adjusted by this handle.

See Also

LinkAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkAdjustmentHandle Properties

LinkAdjustmentHandle Properties
[image]

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

See Also

LinkAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkAdjustmentHandle.PointIndex Property

LinkAdjustmentHandle.PointIndex Property
[image]

Gets or sets the index of a link's control point that will be adjusted by this handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int PointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PointIndex As Integer

Property Value

An integer value.

See Also

LinkAdjustmentHandle Members
LinkAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkCrossings Enumeration

LinkCrossings Enumeration
[image]

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LinkCrossings

Visual Basic [image] Copy Code

Public Enum LinkCrossings

Members

Member name | Description
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.
Straight | No special indication for link intersection points.

Remarks

Values from this enumeration can be assigned to LinkCrossings.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Class

LinkEventArgs Class
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.LinkEventArgs
MindFusion.Diagramming.Wpf.LinkShapeEventArgs
MindFusion.Diagramming.Wpf.LinkValidationEventArgs
MindFusion.Diagramming.Wpf.VirtualLinkEventArgs

See Also

LinkEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Members

LinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded. Initializes a new instance of the LinkEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button was pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Constructor

LinkEventArgs Constructor
[image]

Initializes a new instance of the LinkEventArgs class.

Overload List

Name | Description
LinkEventArgs (DiagramLink) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, MouseButton, Point) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, Point, Int32) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Constructor (DiagramLink)

LinkEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link
The DiagramLink related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Constructor (DiagramLink, MouseButton, Point)

LinkEventArgs Constructor (DiagramLink, MouseButton, Point)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

link
The DiagramLink related to the event.
mouseButton

The position of the mouse cursor, in document coordinates.

mousePosition

The zero-based index of the control point related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Constructor (DiagramLink, Point, Int32)

LinkEventArgs Constructor (DiagramLink, Point, Int32)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
Point mousePosition,
int adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
mousePosition As Point, _
adjustmentHandle As Integer _
)

Parameters

link
The DiagramLink related to the event.
mousePosition
A Point specifying location of the mouse pointer.
adjustmentHandle
An integer index of the control point modified by the user.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs Properties

LinkEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
MouseButton | Gets which mouse button was pressed.
MousePosition | Gets or sets the current mouse pointer position.

See Also

LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs.AdjustmentHandle Property

LinkEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As Integer

Property Value

An integer that represents the index of the link's control point being moved.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs.Link Property

LinkEventArgs.Link Property
[image]

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs.MouseButton Property

LinkEventArgs.MouseButton Property
[image]

Gets which mouse button was pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkEventArgs.MousePosition Property

LinkEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A .NET Point object specifying the current mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Class

LinkLabel Class
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkLabel : TextPresenter, InplaceEditable

Visual Basic [image] Copy Code

Public Class LinkLabel
Inherits TextPresenter
Implements InplaceEditable

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.LinkLabel

See Also

LinkLabel Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Members

LinkLabel Members
Constructors Fields Properties Methods
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

The following tables list the members exposed by the LinkLabel type.

Public Constructors

Name | Description
LinkLabel | Overloaded. Initializes a new instance of the LinkLabel class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
EnableWrapProperty | Identifies the EnableWrap dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IndexProperty | Identifies the Index dependency property.
MarginProperty | Identifies the Margin dependency property.
MaxWidthProperty | Identifies the MaxWidth dependency property.
RelativeToProperty | Identifies the RelativeTo dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
VerticalOffset | Gets or sets the label's vertical offset.

Public Methods

Name | Description
Clone | Creates a clone of this label.
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)
Draw | Draws the link label on the specified DrawingContext surface.
GetDiagramItem | InplaceEditable.GetDiagramItem implementation.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from TextPresenter.)
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | Invoked when a value is assigned to a property and the diagram's Dirty flag must be set. (Inherited from TextPresenter.)

See Also

LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Fields

LinkLabel Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
EnableWrapProperty | Identifies the EnableWrap dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IndexProperty | Identifies the Index dependency property.
MarginProperty | Identifies the Margin dependency property.
MaxWidthProperty | Identifies the MaxWidth dependency property.
RelativeToProperty | Identifies the RelativeTo dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.

See Also

LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.BrushProperty Field

LinkLabel.BrushProperty Field
[image]

Identifies the Brush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.EnableWrapProperty Field

LinkLabel.EnableWrapProperty Field
[image]

Identifies the EnableWrap dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty EnableWrapProperty

Visual Basic [image] Copy Code

Public Shared EnableWrapProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.HorizontalOffsetProperty Field

LinkLabel.HorizontalOffsetProperty Field
[image]

Identifies the HorizontalOffset dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared HorizontalOffsetProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.IndexProperty Field

LinkLabel.IndexProperty Field
[image]

Identifies the Index dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty IndexProperty

Visual Basic [image] Copy Code

Public Shared IndexProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.MarginProperty Field

LinkLabel.MarginProperty Field
[image]

Identifies the Margin dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MarginProperty

Visual Basic [image] Copy Code

Public Shared MarginProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.MaxWidthProperty Field

LinkLabel.MaxWidthProperty Field
[image]

Identifies the MaxWidth dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MaxWidthProperty

Visual Basic [image] Copy Code

Public Shared MaxWidthProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.RelativeToProperty Field

LinkLabel.RelativeToProperty Field
[image]

Identifies the RelativeTo dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty RelativeToProperty

Visual Basic [image] Copy Code

Public Shared RelativeToProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.VerticalOffsetProperty Field

LinkLabel.VerticalOffsetProperty Field
[image]

Identifies the VerticalOffset dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared VerticalOffsetProperty As DependencyProperty

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Constructor

LinkLabel Constructor
[image]

Initializes a new instance of the LinkLabel class.

Overload List

Name | Description
LinkLabel () | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink) | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink, String) | Initializes a new instance of the LinkLabel class.

See Also

LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Constructor ()

LinkLabel Constructor ()
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinkLabel Constructor Overload List
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Constructor (DiagramLink)

LinkLabel Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that displays the label.

See Also

LinkLabel Constructor Overload List
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Constructor (DiagramLink, String)

LinkLabel Constructor (DiagramLink, String)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link,
string text
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
text As String _
)

Parameters

link

The DiagramLink that displays the label.

text

The label's text.

See Also

LinkLabel Constructor Overload List
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Methods

LinkLabel Methods
[image]

Public Methods

Name | Description
Clone | Creates a clone of this label.
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)
Draw | Draws the link label on the specified DrawingContext surface.
GetDiagramItem | InplaceEditable.GetDiagramItem implementation.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from TextPresenter.)
PointAlongLength | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | Invoked when a value is assigned to a property and the diagram's Dirty flag must be set. (Inherited from TextPresenter.)

See Also

LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.Clone Method

LinkLabel.Clone Method
[image]

Creates a clone of this label.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As LinkLabel

Return Value

A new LinkLabel instance that is an exact copy of this label.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.Draw Method

LinkLabel.Draw Method
[image]

Draws the link label on the specified DrawingContext surface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void Draw (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw( _
graphics As DrawingContext _
)

Parameters

graphics

An DrawingContext object where the link label should be rendered.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.GetDiagramItem Method

LinkLabel.GetDiagramItem Method
[image]

InplaceEditable.GetDiagramItem implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem GetDiagramItem ()

Visual Basic [image] Copy Code

Public Function GetDiagramItem () As DiagramItem

Return Value

A DiagramItem object.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.GetEditRect Method

LinkLabel.GetEditRect Method
[image]

InplaceEditable.GetEditRect implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetEditRect (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Function GetEditRect( _
mousePosition As Point _
) As Rect

Parameters

mousePosition

A Point instance specifying the mouse position.

Return Value

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.GetTextToEdit Method

LinkLabel.GetTextToEdit Method
[image]

InplaceEditable.GetTextToEdit implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string GetTextToEdit ()

Visual Basic [image] Copy Code

Public Function GetTextToEdit () As String

Return Value

A string value.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.LoadFromXml Method

LinkLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.PointAlongLength Method

LinkLabel.PointAlongLength Method
[image]

Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Point PointAlongLength (
double lengthFactor,
PointCollection segments
)

Visual Basic [image] Copy Code

Protected Function PointAlongLength( _
lengthFactor As Double, _
segments As PointCollection _
) As Point

Parameters

lengthFactor

A value from 0 to 1 specifying a portion of link's length.

segments

A list of points specifying the polyline segments.

Return Value

A Point instance.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.SaveToXml Method

LinkLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.SetControlPointPosition Method

LinkLabel.SetControlPointPosition Method
[image]

Positions this label relatively to the specified control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetControlPointPosition (
int controlPoint,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetControlPointPosition( _
controlPoint As Integer, _
dx As Single, _
dy As Single _
)

Parameters

controlPoint

The control point index.

dx

Horizontal offset from the point.

dy

Vertical offset from the point.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.SetEditedText Method

LinkLabel.SetEditedText Method
[image]

InplaceEditable.SetEditedText implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Public Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.SetLinkLengthPosition Method

LinkLabel.SetLinkLengthPosition Method
[image]

Positions this label relatively to the link length.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetLinkLengthPosition (
float lengthFactor
)

Visual Basic [image] Copy Code

Public Sub SetLinkLengthPosition( _
lengthFactor As Single _
)

Parameters

lengthFactor

A value between 0 and 1 specifying the position of the label relatively to the link's length.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.SetSegmentPosition Method

LinkLabel.SetSegmentPosition Method
[image]

Positions this label relatively to the specified link segment.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetSegmentPosition (
int segment,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetSegmentPosition( _
segment As Integer, _
dx As Single, _
dy As Single _
)

Parameters

segment

The segment index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel Properties

LinkLabel Properties
[image]

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
VerticalOffset | Gets or sets the label's vertical offset.

See Also

LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.AutoArrange Property

LinkLabel.AutoArrange Property
[image]

Gets or sets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoArrange { get; set; }

Visual Basic [image] Copy Code

Public Property AutoArrange As Boolean

Property Value

true to automatically place the label; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace
ArrangeLinkLabels Method


MindFusion.Diagramming.Wpf.LinkLabel.Brush Property

LinkLabel.Brush Property
[image]

Gets or sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

A System.Windows.Media.Brush instance. The default value is null.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.EnableWrap Property

LinkLabel.EnableWrap Property
[image]

Gets or sets a value indicating whether the label's text can be wrapped.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableWrap { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWrap As Boolean

Property Value

true to enable text wrapping; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.HorizontalOffset Property

LinkLabel.HorizontalOffset Property
[image]

Gets or sets the label's horizontal offset.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.Index Property

LinkLabel.Index Property
[image]

Gets or sets the index of the segment or control point this label is relative to.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.Link Property

LinkLabel.Link Property
[image]

Gets or sets the DiagramLink that displays this label.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Link { get; set; }

Visual Basic [image] Copy Code

Public Property Link As DiagramLink

Property Value

A DiagramLink object.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.Margin Property

LinkLabel.Margin Property
[image]

Gets or sets the label's margin.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Thickness

Property Value

A System.Windows.Thickness instance.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.MaxWidth Property

LinkLabel.MaxWidth Property
[image]

Gets or sets the maximum width of the label.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.RelativeTo Property

LinkLabel.RelativeTo Property
[image]

Gets or sets the label's relative positioning.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RelativeToLink RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As RelativeToLink

Property Value

A member of the RelativeToLink enumeration. The default is LinkLength.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkLabel.VerticalOffset Property

LinkLabel.VerticalOffset Property
[image]

Gets or sets the label's vertical offset.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShape Enumeration

LinkShape Enumeration
[image]

Specifies available link shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LinkShape

Visual Basic [image] Copy Code

Public Enum LinkShape

Members

Member name | Description
Bezier | The segments of a link are Bézier curves.
Cascading | The segments of a link are horizontal and vertical lines, each one orthogonal to each adjacent segment.
Polyline | The segments of the link are straight lines.
Spline | The segments of a link are curves forming an interpolating spline that passes through all control points.

Remarks

Values from this enumeration can be assigned to the Shape property of links or to the LinkShape property of the diagram.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShapeEventArgs Class

LinkShapeEventArgs Class
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkShapeEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkShapeEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.LinkEventArgs
MindFusion.Diagramming.Wpf.LinkShapeEventArgs

See Also

LinkShapeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShapeEventArgs Members

LinkShapeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

The following tables list the members exposed by the LinkShapeEventArgs type.

Public Constructors

Name | Description
LinkShapeEventArgs | Initializes a new instance of the LinkShapeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShapeEventArgs Constructor

LinkShapeEventArgs Constructor
[image]

Initializes a new instance of the LinkShapeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkShapeEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that becomes a self-loop.

See Also

LinkShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShapeEventArgs Properties

LinkShapeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkShapeEventArgs.Handled Property

LinkShapeEventArgs.Handled Property
[image]

Indicates whether the event handler has set a custom loop shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if a custom shape is specified and the control should not set the standard loop shape; otherwise, false. The default value is false.

See Also

LinkShapeEventArgs Members
LinkShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTextStyle Enumeration

LinkTextStyle Enumeration
[image]

Specifies the position and alignment of links' labels.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LinkTextStyle

Visual Basic [image] Copy Code

Public Enum LinkTextStyle

Members

Member name | Description
Center | The text is displayed horizontally above the middle link segment or control point, depending on whether there are an odd or even number of segments.
Follow | The label text starts from the first point of the link and follows the path defined by the link segments. This style is useful for displaying long text.
OverLongestSegment | The text follows the longest link segment and is displayed centered at the segment's middle point.
Rotate | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.

Remarks

Values from this enumeration can be assigned to the TextStyle property of links or the LinkTextStyle property of the diagram.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Class

LinkTo Class
[image]

A helper class that provides attached properties for connecting a link to nodes from Xaml.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkTo : DependencyObject

Visual Basic [image] Copy Code

Public Class LinkTo
Inherits DependencyObject

Example

Xaml [image] Copy Code

<mf:Diagram ...>
<mf:Diagram.Nodes>
<mf:ShapeNode x:Name="n1" Bounds="30,30,20,20" Brush="Red" />
<mf:ShapeNode x:Name="n2" Bounds="150,110,20,20" Brush="Yellow" Shape="Ellipse" />
</mf:Diagram.Nodes>
<mf:Diagram.Links>
<mf:DiagramLink mf:LinkTo.OriginNode="n1" mf:LinkTo.DestinationNode="n2" HeadShapeSize="10" />
</mf:Diagram.Links>
</mf:Diagram>

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Diagramming.Wpf.LinkTo

See Also

LinkTo Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Members

LinkTo Members
Constructors Fields Attached Properties Methods
[image]

A helper class that provides attached properties for connecting a link to nodes from Xaml.

The following tables list the members exposed by the LinkTo type.

Public Constructors

Name | Description
LinkTo |

Public Fields

Name | Description
DestinationNodeProperty | Identifies the DestinationNode attached property.
OriginNodeProperty | Identifies the OriginNode attached property.

Public Attached Properties

Name | Description
DestinationNodeProperty | Gets or sets the Xaml id of the link's destination node.
OriginNodeProperty | Gets or sets the Xaml id of the link's origin node.

Public Methods

Name | Description
GetDestinationNode | Gets the value of the DestinationNode attached property for a link.
GetOriginNode | Gets the value of the OriginNode attached property for a link.
SetDestinationNode | Sets the value of the DestinationNode attached property for a link.
SetOriginNode | Sets the value of the OriginNode attached property for a link.

See Also

LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Fields

LinkTo Fields
[image]

Public Fields

Name | Description
DestinationNodeProperty | Identifies the DestinationNode attached property.
OriginNodeProperty | Identifies the OriginNode attached property.

See Also

LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.DestinationNodeProperty Field

LinkTo.DestinationNodeProperty Field
[image]

Identifies the DestinationNode attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DestinationNodeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DestinationNodeProperty As DependencyProperty

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.OriginNodeProperty Field

LinkTo.OriginNodeProperty Field
[image]

Identifies the OriginNode attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OriginNodeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OriginNodeProperty As DependencyProperty

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Constructor

LinkTo Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkTo ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Methods

LinkTo Methods
[image]

Public Methods

Name | Description
GetDestinationNode | Gets the value of the DestinationNode attached property for a link.
GetOriginNode | Gets the value of the OriginNode attached property for a link.
SetDestinationNode | Sets the value of the DestinationNode attached property for a link.
SetOriginNode | Sets the value of the OriginNode attached property for a link.

See Also

LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.GetDestinationNode Method

LinkTo.GetDestinationNode Method
[image]

Gets the value of the DestinationNode attached property for a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string GetDestinationNode (
DependencyObject obj
)

Visual Basic [image] Copy Code

Public Shared Function GetDestinationNode( _
obj As DependencyObject _
) As String

Parameters

obj

The link from which the property value is read.

Return Value

The Xaml id of the destination node.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.GetOriginNode Method

LinkTo.GetOriginNode Method
[image]

Gets the value of the OriginNode attached property for a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string GetOriginNode (
DependencyObject obj
)

Visual Basic [image] Copy Code

Public Shared Function GetOriginNode( _
obj As DependencyObject _
) As String

Parameters

obj

The link from which the property value is read.

Return Value

The Xaml id of the origin node.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.SetDestinationNode Method

LinkTo.SetDestinationNode Method
[image]

Sets the value of the DestinationNode attached property for a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetDestinationNode (
DependencyObject obj,
string value
)

Visual Basic [image] Copy Code

Public Shared Sub SetDestinationNode( _
obj As DependencyObject, _
value As String _
)

Parameters

obj

The link to which the property value is written.

value

The Xaml id of the destination node.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.SetOriginNode Method

LinkTo.SetOriginNode Method
[image]

Sets the value of the OriginNode attached property for a link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetOriginNode (
DependencyObject obj,
string value
)

Visual Basic [image] Copy Code

Public Shared Sub SetOriginNode( _
obj As DependencyObject, _
value As String _
)

Parameters

obj

The link to which the property value is written.

value

The Xaml id of the origin node.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo Attached Properties

LinkTo Attached Properties
[image]

Public Attached Properties

Name | Description
DestinationNodeProperty | Gets or sets the Xaml id of the link's destination node.
OriginNodeProperty | Gets or sets the Xaml id of the link's origin node.

See Also

LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.DestinationNode Attached Property

LinkTo.DestinationNode Attached Property
[image]

Gets or sets the Xaml id of the link's destination node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

See LinkTo.GetDestinationNode, LinkTo.SetDestinationNode

Visual Basic [image] Copy Code

See LinkTo.GetDestinationNode, LinkTo.SetDestinationNode

Property Value

A string identifier of the destination node.

Example

See the example in the LinkTo topic.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkTo.OriginNode Attached Property

LinkTo.OriginNode Attached Property
[image]

Gets or sets the Xaml id of the link's origin node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

See LinkTo.GetOriginNode, LinkTo.SetOriginNode

Visual Basic [image] Copy Code

See LinkTo.GetOriginNode, LinkTo.SetOriginNode

Property Value

A string identifier of the origin node.

Example

See the example in the LinkTo topic.

See Also

LinkTo Members
LinkTo Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Class

LinkValidationEventArgs Class
[image]

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkValidationEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkValidationEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.LinkEventArgs
MindFusion.Diagramming.Wpf.LinkValidationEventArgs

See Also

LinkValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Members

LinkValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkValidationEventArgs type.

Public Constructors

Name | Description
LinkValidationEventArgs | Overloaded. Initializes a new instance of the LinkValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Constructor

LinkValidationEventArgs Constructor
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Overload List

Name | Description
LinkValidationEventArgs (DiagramLink) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Point, Int32, DiagramNode, Int32, Int32) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Rect) | Initializes a new instance of the LinkValidationEventArgs class.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Constructor (DiagramLink)

LinkValidationEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link
The DiagramLink related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)

LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Point mousePosition,
int adjustmentHandle,
DiagramNode node,
int anchorIndex,
int tableRow
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
mousePosition As Point, _
adjustmentHandle As Integer, _
node As DiagramNode, _
anchorIndex As Integer, _
tableRow As Integer _
)

Parameters

link
The DiagramLink related to the event.
mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

node
The DiagramNode related to the event.
anchorIndex

The zero-based index of the anchor point related to the event.

tableRow

The zero-based index of the table row related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Constructor (DiagramLink, Rect)

LinkValidationEventArgs Constructor (DiagramLink, Rect)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
selectionRectangle As Rect _
)

Parameters

link
The DiagramLink related to the event.
selectionRectangle
A .NET Rect object that represents the current selection rectangle.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Methods

LinkValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.CancelDrag Method

LinkValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs Properties

LinkValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

See Also

LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.AnchorIndex Property

LinkValidationEventArgs.AnchorIndex Property
[image]

Gets the anchor point related to a link validation event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the index of an anchor point within an AnchorPattern.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.Cancel Property

LinkValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.ChangingDestination Property

LinkValidationEventArgs.ChangingDestination Property
[image]

Gets a value indicating whether the user modifies the link's destination end point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ChangingDestination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingDestination As Boolean

Property Value

true if the user is changing the destination point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.ChangingOrigin Property

LinkValidationEventArgs.ChangingOrigin Property
[image]

Gets a value indicating whether the user modifies the link's origin end point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ChangingOrigin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingOrigin As Boolean

Property Value

true if the user is changing the origin point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.Destination Property

LinkValidationEventArgs.Destination Property
[image]

Gets the node that will become the link's destination if the event is validated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Destination As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.Label Property

LinkValidationEventArgs.Label Property
[image]

Gets or sets a LinkLabel related to this event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LinkLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As LinkLabel

Property Value

A LinkLabel instance if the user is trying to edit a label.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.Node Property

LinkValidationEventArgs.Node Property
[image]

Gets the node to which the link will be connected.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.Origin Property

LinkValidationEventArgs.Origin Property
[image]

Gets the node that would become the link's origin if the event is validated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Origin As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.SelectionRectangle Property

LinkValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

A .NET Rect instance representing the selection rectangle.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.LinkValidationEventArgs.TableRow Property

LinkValidationEventArgs.TableRow Property
[image]

Gets the table row related to a link validation event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int TableRow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableRow As Integer

Property Value

An integer value specifying the zero-based index of a TableNode's row.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier Class

Magnifier Class
[image]

Represents a magnifying tool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Magnifier : ContentControl

Visual Basic [image] Copy Code

Public Class Magnifier
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Diagramming.Wpf.Magnifier

See Also

Magnifier Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier Members

Magnifier Members
Constructors Methods
[image]

Represents a magnifying tool.

The following tables list the members exposed by the Magnifier type.

Public Constructors

Name | Description
Magnifier | Initializes a new instance of the Magnifier class.

Public Methods

Name | Description
MoveTo | Moves the magnifier to the specified coordinates.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Magnifier Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier Constructor

Magnifier Constructor
[image]

Initializes a new instance of the Magnifier class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Magnifier (
Diagram diagram,
Point point
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
point As Point _
)

Parameters

diagram

The diagram this control is associated with.

point

The coordinates to show the magnifier at.

See Also

Magnifier Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier Methods

Magnifier Methods
[image]

Public Methods

Name | Description
MoveTo | Moves the magnifier to the specified coordinates.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Magnifier Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier.MoveTo Method

Magnifier.MoveTo Method
[image]

Moves the magnifier to the specified coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void MoveTo (
Point position
)

Visual Basic [image] Copy Code

Public Sub MoveTo( _
position As Point _
)

Parameters

position

The point to move the magnifier to.

See Also

Magnifier Members
Magnifier Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Magnifier.OnApplyTemplate Method

Magnifier.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Magnifier Members
Magnifier Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator Class

Manipulator Class
[image]

Base class for interactive manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class Manipulator

Visual Basic [image] Copy Code

Public MustInherit Class Manipulator

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Manipulator

See Also

Manipulator Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator Members

Manipulator Members
Constructors Properties Methods
[image]

Base class for interactive manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.

The following tables list the members exposed by the Manipulator type.

Protected Constructors

Name | Description
Manipulator | Initializes a new instance of the Manipulator class.

Protected Properties

Name | Description
Item | Gets or sets the item this manipulator is attached to.

Public Methods

Name | Description
AddToRepaintRect | Adds the manipulator's repaint area to the specified rectangle.
Apply | Calls OnClick with argument transformed to local coordinates if necessary.
Cancel | Called when the manipulator should cancel the current manipulation.
Draw | Renders the manipulator.
DrawsInLocalCoordinates | Returns whether the manipulator object draws in local or global coordinates.
HitTest | Tests if the specified point lies within the manipulator's boundaries.
NeedsMouseMessages | Returns whether the manipulator object needs to track mouse events.
OnClick | Performs the action associated with this manipulator.
OnMouseDown | Called when the left mouse button is pressed while the pointer is over this manipulator.
OnMouseMove | Called when the mouse is moved while this manipulator tracks the mouse events.
OnMouseUp | Called when the left mouse button is released while this manipulator tracks the mouse events.
SetMouseCursor | Returns the cursor that should be displayed when the mouse pointer is over this manipulator.
SupportClipping | Gets a value indicating whether the manipulator supports clipping.

See Also

Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator Constructor

Manipulator Constructor
[image]

Initializes a new instance of the Manipulator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Manipulator (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected New ( _
item As DiagramItem _
)

Parameters

item

See Also

Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator Methods

Manipulator Methods
[image]

Public Methods

Name | Description
AddToRepaintRect | Adds the manipulator's repaint area to the specified rectangle.
Apply | Calls OnClick with argument transformed to local coordinates if necessary.
Cancel | Called when the manipulator should cancel the current manipulation.
Draw | Renders the manipulator.
DrawsInLocalCoordinates | Returns whether the manipulator object draws in local or global coordinates.
HitTest | Tests if the specified point lies within the manipulator's boundaries.
NeedsMouseMessages | Returns whether the manipulator object needs to track mouse events.
OnClick | Performs the action associated with this manipulator.
OnMouseDown | Called when the left mouse button is pressed while the pointer is over this manipulator.
OnMouseMove | Called when the mouse is moved while this manipulator tracks the mouse events.
OnMouseUp | Called when the left mouse button is released while this manipulator tracks the mouse events.
SetMouseCursor | Returns the cursor that should be displayed when the mouse pointer is over this manipulator.
SupportClipping | Gets a value indicating whether the manipulator supports clipping.

See Also

Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.AddToRepaintRect Method

Manipulator.AddToRepaintRect Method
[image]

Adds the manipulator's repaint area to the specified rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void AddToRepaintRect (
ref Rect rect
)

Visual Basic [image] Copy Code

Public MustOverride Sub AddToRepaintRect( _
ByRef rect As Rect _
)

Parameters

rect

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.Apply Method

Manipulator.Apply Method
[image]

Calls OnClick with argument transformed to local coordinates if necessary.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Apply (
Point diagramCoord
)

Visual Basic [image] Copy Code

Public Sub Apply( _
diagramCoord As Point _
)

Parameters

diagramCoord

A Point instance specifying diagram coordinates.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.Cancel Method

Manipulator.Cancel Method
[image]

Called when the manipulator should cancel the current manipulation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void Cancel ()

Visual Basic [image] Copy Code

Public Overridable Sub Cancel ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.Draw Method

Manipulator.Draw Method
[image]

Renders the manipulator.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void Draw (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
graphics As DrawingContext _
)

Parameters

graphics

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.DrawsInLocalCoordinates Method

Manipulator.DrawsInLocalCoordinates Method
[image]

Returns whether the manipulator object draws in local or global coordinates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool DrawsInLocalCoordinates ()

Visual Basic [image] Copy Code

Public Overridable Function DrawsInLocalCoordinates () As Boolean

Return Value

true if drawn in local coordinates, otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.HitTest Method

Manipulator.HitTest Method
[image]

Tests if the specified point lies within the manipulator's boundaries.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool HitTest (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTest( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.NeedsMouseMessages Method

Manipulator.NeedsMouseMessages Method
[image]

Returns whether the manipulator object needs to track mouse events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool NeedsMouseMessages (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function NeedsMouseMessages( _
point As Point _
) As Boolean

Parameters

point

Return Value

true to track mouse events; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.OnClick Method

Manipulator.OnClick Method
[image]

Performs the action associated with this manipulator.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract void OnClick (
Point pt
)

Visual Basic [image] Copy Code

Public MustOverride Sub OnClick( _
pt As Point _
)

Parameters

pt

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.OnMouseDown Method

Manipulator.OnMouseDown Method
[image]

Called when the left mouse button is pressed while the pointer is over this manipulator.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void OnMouseDown (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseDown( _
mousePosition As Point _
)

Parameters

mousePosition

A Point instance that specifies the current mouse position.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.OnMouseMove Method

Manipulator.OnMouseMove Method
[image]

Called when the mouse is moved while this manipulator tracks the mouse events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void OnMouseMove (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseMove( _
mousePosition As Point _
)

Parameters

mousePosition

A Point instance that specifies the current mouse position.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.OnMouseUp Method

Manipulator.OnMouseUp Method
[image]

Called when the left mouse button is released while this manipulator tracks the mouse events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual void OnMouseUp (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnMouseUp( _
mousePosition As Point _
)

Parameters

mousePosition

A Point instance that specifies the current mouse position.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.SetMouseCursor Method

Manipulator.SetMouseCursor Method
[image]

Returns the cursor that should be displayed when the mouse pointer is over this manipulator.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual CursorHint SetMouseCursor (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function SetMouseCursor( _
point As Point _
) As CursorHint

Parameters

point

A Point specifying mouse position in diagram coordinates.

Return Value

A member of the CursorHint enumeration.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.SupportClipping Method

Manipulator.SupportClipping Method
[image]

Gets a value indicating whether the manipulator supports clipping.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract bool SupportClipping ()

Visual Basic [image] Copy Code

Public MustOverride Function SupportClipping () As Boolean

Return Value

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator Properties

Manipulator Properties
[image]

Protected Properties

Name | Description
Item | Gets or sets the item this manipulator is attached to.

See Also

Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Manipulator.Item Property

Manipulator.Item Property
[image]

Gets or sets the item this manipulator is attached to.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DiagramItem Item { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Item As DiagramItem

Property Value

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.MarkStyle Enumeration

MarkStyle Enumeration
[image]

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum MarkStyle

Visual Basic [image] Copy Code

Public Enum MarkStyle

Members

Member name | Description
Circle | Anchor point marked with a circle.
Cross | No visual indication for the anchor point.
Custom | A DrawAnchorPoint event is fired, allowing custom painting of anchor points.
None | No visual indication for the anchor point.
Rectangle | Anchor point marked with a rectangle.
X | Anchor point marked with an 'X'.

Remarks

Members of this enumeration are used as values of the MarkStyle property of the AnchorPoint class.

See Also

MindFusion.Diagramming.Wpf Namespace
AnchorPoint Class
MarkStyle Property
DrawAnchorPoint Event


MindFusion.Diagramming.Wpf.ModificationEffect Enumeration

ModificationEffect Enumeration
[image]

Specifies the visual effect to apply during interactive modification of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ModificationEffect

Visual Basic [image] Copy Code

Public Enum ModificationEffect

Members

Member name | Description
MoveShades | Show a semi-transparent shade of the modified item at the current mouse position.
None | Show the actual modified item as it would look if the user completes the modification at the current mouse position.

See Also

MindFusion.Diagramming.Wpf Namespace
ModificationEffect Property


MindFusion.Diagramming.Wpf.ModificationStart Enumeration

ModificationStart Enumeration
[image]

Specifies how the user can start modifying an item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ModificationStart

Visual Basic [image] Copy Code

Public Enum ModificationStart

Members

Member name | Description
AutoHandles | Adjustment handles appear automatically around the object under the mouse; it can be modified without selecting it first.
SelectedOnly | Only selected objects can be modified.

Remarks

This enumeration specifies the possible values of the ModificationStart property.

See Also

MindFusion.Diagramming.Wpf Namespace
ModificationStart Property


MindFusion.Diagramming.Wpf.ModifierKeyAction Enumeration

ModifierKeyAction Enumeration
[image]

Defines the actions that can be assigned to a modifier key such as CTRL or ALT.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ModifierKeyAction

Visual Basic [image] Copy Code

Public Enum ModifierKeyAction

Members

Member name | Description
ExtendSelection | Similar to Select, but does not deselect currently selected items when they are outside of a newly drawn lasso rectangle.
Magnify | Magnifies the items under the mouse while the button is pressed down.
None | Specifies that a modifier key does not have any specific function assigned to it.
OverrideBehavior | While the modifier key is pressed down, dragging the mouse starts creating a new item or drawing a selection rectangle instead of modifying a selected item. Otherwise, dragging the mouse could start modification of the selected item.
Pan | Pan the view if the mouse is dragged while the modifier key is pressed down.
Select | Start drawing a selection rectangle if the mouse is dragged while a modifier key is pressed down. Toggle the selection if an item is clicked while the key is down.
ToggleSelection | Toggle the selection if an item is clicked while the key is down.

Remarks

The values from this enumeration can be assigned to the members of the diagram view's ModifierKeyActions.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ModifierKeyActions Class

ModifierKeyActions Class
[image]

Maps keyboard modifier keys to special actions in WpfDiagram such as panning and drawing selection rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class ModifierKeyActions

Visual Basic [image] Copy Code

Public NotInheritable Class ModifierKeyActions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ModifierKeyActions

See Also

ModifierKeyActions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ModifierKeyActions Members

ModifierKeyActions Members
Properties
[image]

Maps keyboard modifier keys to special actions in WpfDiagram such as panning and drawing selection rectangle.

The following tables list the members exposed by the ModifierKeyActions type.

Public Properties

Name | Description
Alt | Gets or sets what action is triggered by the ALT key.
Control | Gets or sets what action is triggered by the CTRL key.
Shift | Gets or sets what action is triggered by the SHIFT key.

See Also

ModifierKeyActions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ModifierKeyActions Properties

ModifierKeyActions Properties
[image]

Public Properties

Name | Description
Alt | Gets or sets what action is triggered by the ALT key.
Control | Gets or sets what action is triggered by the CTRL key.
Shift | Gets or sets what action is triggered by the SHIFT key.

See Also

ModifierKeyActions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ModifierKeyActions.Alt Property

ModifierKeyActions.Alt Property
[image]

Gets or sets what action is triggered by the ALT key.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModifierKeyAction Alt { get; set; }

Visual Basic [image] Copy Code

Public Property Alt As ModifierKeyAction

Property Value

A member of the ModifierKeyAction enumeration. The default value is Pan.

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.Wpf Namespace
PanInertia Property


MindFusion.Diagramming.Wpf.ModifierKeyActions.Control Property

ModifierKeyActions.Control Property
[image]

Gets or sets what action is triggered by the CTRL key.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModifierKeyAction Control { get; set; }

Visual Basic [image] Copy Code

Public Property Control As ModifierKeyAction

Property Value

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ModifierKeyActions.Shift Property

ModifierKeyActions.Shift Property
[image]

Gets or sets what action is triggered by the SHIFT key.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModifierKeyAction Shift { get; set; }

Visual Basic [image] Copy Code

Public Property Shift As ModifierKeyAction

Property Value

See Also

ModifierKeyActions Members
ModifierKeyActions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.MouseButton Enumeration

MouseButton Enumeration
[image]

Specifies constants that define which mouse button was pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum MouseButton

Visual Basic [image] Copy Code

Public Enum MouseButton

Members

Member name | Description
Left | The left mouse button was pressed.
Middle | The middle mouse button was pressed.
None | No mouse button was pressed.
Right | The right mouse button was pressed.
XButton1 | The first XButton was pressed.
XButton2 | The second XButton was pressed.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.MouseButtonActions Enumeration

MouseButtonActions Enumeration
[image]

Specifies what actions can be associated with the middle and right mouse buttons.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum MouseButtonActions

Visual Basic [image] Copy Code

Public Enum MouseButtonActions

Members

Member name | Description
Cancel | Cancels the current drawing operation.
Draw | Starts drawing a diagram item.
Magnify | Magnifies the items under the mouse while the button is pressed down.
None | Do not associate any action with the button.
Pan | Pans the view if the mouse is dragged while the button is pressed down.
Select | Starts a multiple selection operation.

Remarks

The Cancel value can be combined with Pan or Select. Thus if a user presses the mouse button while drawing an item, the operation will be cancelled; otherwise dragging with the specified button will start panning or drawing a selection rectangle.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.MouseInputMode Enumeration

MouseInputMode Enumeration
[image]

Contains values that identify how to process mouse input.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum MouseInputMode

Visual Basic [image] Copy Code

Public Enum MouseInputMode

Members

Member name | Description
HandledByDiagram | Mouse input is processed by the diagram.
HandledByHostedControl | Mouse input is processed by the hosted control.

Remarks

Members of this enumeration are assigned to the MouseInputMode property of DiagramNodeAdapter.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Class

NodeAdjustmentHandle Class
[image]

Represents an adjustment handle used to move, resize or rotate a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class NodeAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AdjustmentHandle
MindFusion.Diagramming.Wpf.NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Members

NodeAdjustmentHandle Members
Constructors Fields Properties Methods
[image]

Represents an adjustment handle used to move, resize or rotate a node.

The following tables list the members exposed by the NodeAdjustmentHandle type.

Public Constructors

Name | Description
NodeAdjustmentHandle | Initializes a new instance of the NodeAdjustmentHandle class.

Public Fields

Name | Description
Move | A NodeAdjustmentHandle used to move nodes.
ResizeBottomRight | A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

Public Properties

Name | Description
HandleType | Gets or sets the type of this adjustment handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move nodes.

See Also

NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Fields

NodeAdjustmentHandle Fields
[image]

Public Fields

Name | Description
Move | A NodeAdjustmentHandle used to move nodes.
ResizeBottomRight | A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

See Also

NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle.Move Field

NodeAdjustmentHandle.Move Field
[image]

A NodeAdjustmentHandle used to move nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static NodeAdjustmentHandle Move

Visual Basic [image] Copy Code

Public Shared Move As NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle.ResizeBottomRight Field

NodeAdjustmentHandle.ResizeBottomRight Field
[image]

A NodeAdjustmentHandle used to resize nodes from bottom-right corner.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static NodeAdjustmentHandle ResizeBottomRight

Visual Basic [image] Copy Code

Public Shared ResizeBottomRight As NodeAdjustmentHandle

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Constructor

NodeAdjustmentHandle Constructor
[image]

Initializes a new instance of the NodeAdjustmentHandle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeAdjustmentHandle (
NodeHandleType handleType
)

Visual Basic [image] Copy Code

Public New ( _
handleType As NodeHandleType _
)

Parameters

handleType

A member of the NodeHandleType enumeration identifying the handle type.

See Also

NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Methods

NodeAdjustmentHandle Methods
[image]

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move nodes.

See Also

NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle.IsMoveHandle Method

NodeAdjustmentHandle.IsMoveHandle Method
[image]

Returns a value indicating whether this handle is used to move nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool IsMoveHandle ()

Visual Basic [image] Copy Code

Public Overrides Function IsMoveHandle () As Boolean

Return Value

true if this is a move handle, or false otherwise.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle Properties

NodeAdjustmentHandle Properties
[image]

Public Properties

Name | Description
HandleType | Gets or sets the type of this adjustment handle.

See Also

NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeAdjustmentHandle.HandleType Property

NodeAdjustmentHandle.HandleType Property
[image]

Gets or sets the type of this adjustment handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeHandleType HandleType { get; set; }

Visual Basic [image] Copy Code

Public Property HandleType As NodeHandleType

Property Value

A member of the NodeHandleType enumeration.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints Class

NodeConstraints Class
Remarks See Also
[image]

Defines specific constraints that can be applied to the size and location of nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeConstraints : ICloneable

Visual Basic [image] Copy Code

Public Class NodeConstraints
Implements ICloneable

Remarks

Instances of this class can be assigned to the Constraints property of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.NodeConstraints

See Also

NodeConstraints Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints Members

NodeConstraints Members
Constructors Properties Methods
[image]

Defines specific constraints that can be applied to the size and location of nodes.

The following tables list the members exposed by the NodeConstraints type.

Public Constructors

Name | Description
NodeConstraints | Initializes a new instance of the NodeConstraints class.

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideDiagram | Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints Constructor

NodeConstraints Constructor
[image]

Initializes a new instance of the NodeConstraints class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeConstraints ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints Methods

NodeConstraints Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.Clone Method

NodeConstraints.Clone Method
[image]

Creates a copy of this object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An Object instance that is a copy of the current NodeConstraints instance.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.LoadFromXml Method

NodeConstraints.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.SaveToXml Method

NodeConstraints.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints Properties

NodeConstraints Properties
[image]

Public Properties

Name | Description
DisableMirroring | Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.
KeepInsideDiagram | Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.
KeepRatio | Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.
MaxHeight | Gets or sets the maximal node height allowed.
MaxWidth | Gets or sets the maximal node width allowed.
MinHeight | Gets or sets the minimal node height allowed.
MinWidth | Gets or sets the minimal node width allowed.
MoveDirection | Gets or sets constraints on movement direction.

See Also

NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.DisableMirroring Property

NodeConstraints.DisableMirroring Property
[image]

Gets or sets a value indicating whether the user can drag a side of the node past its opposite side, so that they switch positions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool DisableMirroring { get; set; }

Visual Basic [image] Copy Code

Public Property DisableMirroring As Boolean

Property Value

true to disable mirroring; otherwise false. The default value is false.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.KeepInsideDiagram Property

NodeConstraints.KeepInsideDiagram Property
[image]

Gets or sets a value indicating whether a node should always stay inside the boundaries of the diagram that contains it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepInsideDiagram { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideDiagram As Boolean

Property Value

true to prevent item from leaving diagram boundaries, or false otherwise.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.KeepInsideParent Property

NodeConstraints.KeepInsideParent Property
[image]

Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepInsideParent { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideParent As Boolean

Property Value

true if users should be prevented from moving the node out of its parent; otherwise, false. The default is false.

Remarks

This property lets you restrict nodes attached to another node by the AttachTo method so that users cannot move the attached nodes out of the bounds of their parent.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.KeepRatio Property

NodeConstraints.KeepRatio Property
[image]

Gets or sets a value indicating whether the initial width/height ratio of a node should be preserved.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepRatio { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRatio As Boolean

Property Value

true if the node width to height ratio should be preserved; otherwise, false. The default is false.

Remarks

If you enable this property in an initialization-event handler, the node will have an aspect ratio of 1:1. For example in order to let users draw perfect square or circle shapes, set KeepRatio to true in the InitializeNode handler.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.MaxHeight Property

NodeConstraints.MaxHeight Property
[image]

Gets or sets the maximal node height allowed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MaxHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MaxHeight As Double

Property Value

0 = no height constraints; any other value specifies the maximal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.MaxWidth Property

NodeConstraints.MaxWidth Property
[image]

Gets or sets the maximal node width allowed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Double

Property Value

0 = no width constraints; any other value specifies the maximal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.MinHeight Property

NodeConstraints.MinHeight Property
[image]

Gets or sets the minimal node height allowed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MinHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeight As Double

Property Value

0 = no height constraints; any other value specifies the minimal node height allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.MinWidth Property

NodeConstraints.MinWidth Property
[image]

Gets or sets the minimal node width allowed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MinWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MinWidth As Double

Property Value

0 = no width constraints; any other value specifies the minimal node width allowed.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeConstraints.MoveDirection Property

NodeConstraints.MoveDirection Property
[image]

Gets or sets constraints on movement direction.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DirectionConstraint MoveDirection { get; set; }

Visual Basic [image] Copy Code

Public Property MoveDirection As DirectionConstraint

Property Value

One of the DirectionConstraint enumeration values; the default is None.

See Also

NodeConstraints Members
NodeConstraints Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect Class

NodeEffect Class
Remarks See Also
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class NodeEffect : INotifyPropertyChanged, ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class NodeEffect
Implements INotifyPropertyChanged, ICloneable

Remarks

Effects can be applied by adding instances of the concrete effect classes to the NodeEffects collection of the Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.NodeEffect
MindFusion.Diagramming.Wpf.AeroEffect
MindFusion.Diagramming.Wpf.GlassEffect

See Also

NodeEffect Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect Members

NodeEffect Members
Constructors Methods Events
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

The following tables list the members exposed by the NodeEffect type.

Protected Constructors

Name | Description
NodeEffect | Initializes a new instance of the NodeEffect class.

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect Constructor

NodeEffect Constructor
[image]

Initializes a new instance of the NodeEffect class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected NodeEffect ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect Methods

NodeEffect Methods
[image]

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

See Also

NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect.Clone Method

NodeEffect.Clone Method
[image]

ICloneable.Clone implementation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

A new effect that is a copy of this effect.

See Also

NodeEffect Members
NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEffect Events

NodeEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Class

NodeEventArgs Class
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.NodeEventArgs
MindFusion.Diagramming.Wpf.ContainerChildEventArgs
MindFusion.Diagramming.Wpf.NodeValidationEventArgs
MindFusion.Diagramming.Wpf.VirtualNodeEventArgs

See Also

NodeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Members

NodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded. Initializes a new instance of the NodeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Constructor

NodeEventArgs Constructor
[image]

Initializes a new instance of the NodeEventArgs class.

Overload List

Name | Description
NodeEventArgs (DiagramNode) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, MouseButton, Point) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Constructor (DiagramNode)

NodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Constructor (DiagramNode, MouseButton, Point)

NodeEventArgs Constructor (DiagramNode, MouseButton, Point)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

node
The DiagramNode related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse cursor, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
Point mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node
The DiagramNode related to the event.
mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

A member of the AdjustmentHandles enumeration specifying what kind of handle was used to modify the node.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs Properties

NodeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Node | Gets the node for which the event was raised.

See Also

NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs.AdjustmentHandle Property

NodeEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandles AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration specifying what handle has been used.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs.MouseButton Property

NodeEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration specifying the currently pressed mouse button.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs.MousePosition Property

NodeEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

A .NET Point object specifying the current mouse position.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeEventArgs.Node Property

NodeEventArgs.Node Property
[image]

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeHandleType Enumeration

NodeHandleType Enumeration
[image]

Identifies the types of selection handles of a node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum NodeHandleType

Visual Basic [image] Copy Code

Public Enum NodeHandleType

Members

Member name | Description
Move | A central selection handle that can be used to move the node.
ResizeBottomCenter | A bottom-center handle that can be used to resize the node vertically.
ResizeBottomLeft | A bottom-left handle that can be used to resize the node.
ResizeBottomRight | A bottom-right handle that can be used to resize the node.
ResizeMiddleLeft | A middle-left handle that can be used to resize the node horizontally.
ResizeMiddleRight | A middle-right handle that can be used to resize the node horizontally.
ResizeTopCenter | A top-center handle that can be used to resize the node vertically.
ResizeTopLeft | A top-left handle that can be used to resize the node.
ResizeTopRight | A top-right handle that can be used to resize the node.
Rotate | A rotation handle that can be used to rotate the node.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView Class

NodeListView Class
[image]

NodeListView is a toolbox alike control. It displays a list of node templates, and lets user create new nodes based on these templates by drag-and-drop. NodeListView can contain instances of any DiagramNode or UIElement derived classes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeListView : ListView

Visual Basic [image] Copy Code

Public Class NodeListView
Inherits ListView

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
System.Windows.Controls.Primitives.Selector
System.Windows.Controls.ListBox
System.Windows.Controls.ListView
MindFusion.Diagramming.Wpf.NodeListView

See Also

NodeListView Members
MindFusion.Diagramming.Wpf Namespace
ShapeListBox Class


MindFusion.Diagramming.Wpf.NodeListView Members

NodeListView Members
Constructors Fields Attached Properties Methods
[image]

NodeListView is a toolbox alike control. It displays a list of node templates, and lets user create new nodes based on these templates by drag-and-drop. NodeListView can contain instances of any DiagramNode or UIElement derived classes.

The following tables list the members exposed by the NodeListView type.

Public Constructors

Name | Description
NodeListView | Initializes a new instance of the NodeListView class.

Public Fields

Name | Description
LabelProperty | Identifies the Label attached property which defines the text of the Label next to the DiagramNode icon.

Public Attached Properties

Name | Description
LabelProperty |

Public Methods

Name | Description
GetLabel | Gets the value of the Label attached property
SetLabel | Sets the value of the Label attached property

Protected Methods

Name | Description
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.

See Also

NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView Fields

NodeListView Fields
[image]

Public Fields

Name | Description
LabelProperty | Identifies the Label attached property which defines the text of the Label next to the DiagramNode icon.

See Also

NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.LabelProperty Field

NodeListView.LabelProperty Field
[image]

Identifies the Label attached property which defines the text of the Label next to the DiagramNode icon.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView Constructor

NodeListView Constructor
[image]

Initializes a new instance of the NodeListView class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView Methods

NodeListView Methods
[image]

Public Methods

Name | Description
GetLabel | Gets the value of the Label attached property
SetLabel | Sets the value of the Label attached property

Protected Methods

Name | Description
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override.

See Also

NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.GetLabel Method

NodeListView.GetLabel Method
[image]

Gets the value of the Label attached property

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string GetLabel (
UIElement diagramNode
)

Visual Basic [image] Copy Code

Public Shared Function GetLabel( _
diagramNode As UIElement _
) As String

Parameters

diagramNode

Return Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.OnPreviewMouseDown Method

NodeListView.OnPreviewMouseDown Method
[image]

UIElement.OnPreviewMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.OnPreviewMouseMove Method

NodeListView.OnPreviewMouseMove Method
[image]

UIElement.OnPreviewMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.SetLabel Method

NodeListView.SetLabel Method
[image]

Sets the value of the Label attached property

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetLabel (
UIElement diagramNode,
string value
)

Visual Basic [image] Copy Code

Public Shared Sub SetLabel( _
diagramNode As UIElement, _
value As String _
)

Parameters

diagramNode

value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView Attached Properties

NodeListView Attached Properties
[image]

Public Attached Properties

Name | Description
LabelProperty |

See Also

NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeListView.Label Attached Property

NodeListView.Label Attached Property
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code
See NodeListView.GetLabel, NodeListView.SetLabel
Visual Basic [image] Copy Code
See NodeListView.GetLabel, NodeListView.SetLabel

Property Value

See Also

NodeListView Members
NodeListView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Class

NodeRenderer Class
[image]

Renders diagram nodes in their standard appearance. This element can be included in Xaml template of a node class to render node's standard graphics before any additional WPF elements defined by the template.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeRenderer : FrameworkElement

Visual Basic [image] Copy Code

Public Class NodeRenderer
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.NodeRenderer

See Also

NodeRenderer Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Members

NodeRenderer Members
Constructors Fields Properties Methods
[image]

Renders diagram nodes in their standard appearance. This element can be included in Xaml template of a node class to render node's standard graphics before any additional WPF elements defined by the template.

The following tables list the members exposed by the NodeRenderer type.

Public Constructors

Name | Description
NodeRenderer |

Public Fields

Name | Description
NodeProperty | Identifies the Node dependency property.

Public Properties

Name | Description
Node | Gets or sets the DiagramNode rendered by this presenter.

Protected Methods

Name | Description
OnRender | FrameworkElement.OnRender override.

See Also

NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Fields

NodeRenderer Fields
[image]

Public Fields

Name | Description
NodeProperty | Identifies the Node dependency property.

See Also

NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer.NodeProperty Field

NodeRenderer.NodeProperty Field
[image]

Identifies the Node dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty NodeProperty

Visual Basic [image] Copy Code

Public Shared NodeProperty As DependencyProperty

See Also

NodeRenderer Members
NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Constructor

NodeRenderer Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeRenderer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Methods

NodeRenderer Methods
[image]

Protected Methods

Name | Description
OnRender | FrameworkElement.OnRender override.

See Also

NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer.OnRender Method

NodeRenderer.OnRender Method
[image]

FrameworkElement.OnRender override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

A DrawingContext representing the drawing canvas.

Remarks

This method calls DrawLocal method of nodes to execute their low-level drawing code.

See Also

NodeRenderer Members
NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer Properties

NodeRenderer Properties
[image]

Public Properties

Name | Description
Node | Gets or sets the DiagramNode rendered by this presenter.

See Also

NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRenderer.Node Property

NodeRenderer.Node Property
[image]

Gets or sets the DiagramNode rendered by this presenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

NodeRenderer Members
NodeRenderer Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeRotationType Enumeration

NodeRotationType Enumeration
[image]

Specifies whether nodes should rotate to face the camera in DiagramView3D.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum NodeRotationType

Visual Basic [image] Copy Code

Public Enum NodeRotationType

Members

Member name | Description
Animated | Rotation of nodes towards the camera is animated.
Instant | Nodes always face the camera.
None | Nodes do not rotate to face the camera.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodesAlignedEventArgs Class

NodesAlignedEventArgs Class
[image]

Contains the arguments passed to handlers of the NodesAligned event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodesAlignedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodesAlignedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.NodesAlignedEventArgs

See Also

NodesAlignedEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodesAlignedEventArgs Members

NodesAlignedEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of the NodesAligned event.

The following tables list the members exposed by the NodesAlignedEventArgs type.

Public Constructors

Name | Description
NodesAlignedEventArgs | Initializes a new instance of the NodesAlignedEventArgs class.

Public Properties

Name | Description
Nodes | Gets the nodes that have been aligned.

See Also

NodesAlignedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodesAlignedEventArgs Constructor

NodesAlignedEventArgs Constructor
[image]

Initializes a new instance of the NodesAlignedEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodesAlignedEventArgs (
DiagramNodeCollection nodes
)

Visual Basic [image] Copy Code

Public New ( _
nodes As DiagramNodeCollection _
)

Parameters

nodes
The DiagramNodeCollection related to the event.

See Also

NodesAlignedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodesAlignedEventArgs Properties

NodesAlignedEventArgs Properties
[image]

Public Properties

Name | Description
Nodes | Gets the nodes that have been aligned.

See Also

NodesAlignedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodesAlignedEventArgs.Nodes Property

NodesAlignedEventArgs.Nodes Property
[image]

Gets the nodes that have been aligned.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

See Also

NodesAlignedEventArgs Members
NodesAlignedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Class

NodeValidationEventArgs Class
[image]

Contains the arguments passed to handlers of node validation events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeValidationEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class NodeValidationEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.NodeEventArgs
MindFusion.Diagramming.Wpf.NodeValidationEventArgs

See Also

NodeValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Members

NodeValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of node validation events.

The following tables list the members exposed by the NodeValidationEventArgs type.

Public Constructors

Name | Description
NodeValidationEventArgs | Overloaded. Initializes a new instance of the NodeValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
SelectionRectangle | Gets the current selection rectangle.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Constructor

NodeValidationEventArgs Constructor
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Overload List

Name | Description
NodeValidationEventArgs (DiagramNode) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Rect) | Initializes a new instance of the NodeValidationEventArgs class.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Constructor (DiagramNode)

NodeValidationEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node
The DiagramNode related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Point mousePosition,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node
The DiagramNode related to the event.
mousePosition

The position of the mouse cursor, in document coordinates.

adjustmentHandle

A member of the AdjustmentHandles enumeration specifying what kind of handle is being used to modify the node.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Constructor (DiagramNode, Rect)

NodeValidationEventArgs Constructor (DiagramNode, Rect)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
selectionRectangle As Rect _
)

Parameters

node
The DiagramNode related to the event.
selectionRectangle
A .NET Rect object representing the selection reactangle.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Methods

NodeValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs.CancelDrag Method

NodeValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only changes the mouse cursor to a Stop icon and the operation is cancelled when the user releases the mouse button.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs Properties

NodeValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
SelectionRectangle | Gets the current selection rectangle.

See Also

NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs.Cancel Property

NodeValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NodeValidationEventArgs.SelectionRectangle Property

NodeValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

A Rect instance representing the selection rectangle.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NotATreeException Class

NotATreeException Class
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NotATreeException : Exception

Visual Basic [image] Copy Code

Public Class NotATreeException
Inherits Exception

Inheritance Hierarchy

System.Object
System.Exception
MindFusion.Diagramming.Wpf.NotATreeException

See Also

NotATreeException Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NotATreeException Members

NotATreeException Members
Constructors
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

The following tables list the members exposed by the NotATreeException type.

Public Constructors

Name | Description
NotATreeException | Initializes a new instance of the NotATreeException class.

See Also

NotATreeException Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.NotATreeException Constructor

NotATreeException Constructor
[image]

Initializes a new instance of the NotATreeException class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NotATreeException ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NotATreeException Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter Class

ObjectToBooleanConverter Class
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ObjectToBooleanConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ObjectToBooleanConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ObjectToBooleanConverter

See Also

ObjectToBooleanConverter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter Members

ObjectToBooleanConverter Members
Constructors Methods
[image]

For internal use.

The following tables list the members exposed by the ObjectToBooleanConverter type.

Public Constructors

Name | Description
ObjectToBooleanConverter |

Public Methods

Name | Description
Convert | For internal use.
ConvertBack | For internal use.

See Also

ObjectToBooleanConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter Constructor

ObjectToBooleanConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ObjectToBooleanConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ObjectToBooleanConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter Methods

ObjectToBooleanConverter Methods
[image]

Public Methods

Name | Description
Convert | For internal use.
ConvertBack | For internal use.

See Also

ObjectToBooleanConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter.Convert Method

ObjectToBooleanConverter.Convert Method
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ObjectToBooleanConverter Members
ObjectToBooleanConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ObjectToBooleanConverter.ConvertBack Method

ObjectToBooleanConverter.ConvertBack Method
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ObjectToBooleanConverter Members
ObjectToBooleanConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Orientation Enumeration

Orientation Enumeration
[image]

Defines values that specify the orientation of the first segment of cascading links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Auto | The control determines automatically the initial direction of link's first segment.
Horizontal | The first segment of the link is always horizontal.
Vertical | The first segment of the link is always vertical.

See Also

MindFusion.Diagramming.Wpf Namespace
CascadeOrientation Property


MindFusion.Diagramming.Wpf.Overview Class

Overview Class
Remarks See Also
[image]

The Overview control provides a scaled-down view of a Diagram and allows scrolling and zooming the diagram with the mouse.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Overview : ContentControl

Visual Basic [image] Copy Code

Public Class Overview
Inherits ContentControl

Remarks

To use the Overview control, select Customize from the Visual Studio toolbox context menu and add a reference to Overview.dll. Now the Overview control appears in the toolbox - select it and draw on a form to create its instance.

To specify which Diagram instance is shown in the overview, set the Document property of the Overview class. After adding a Diagram or an Overview instance to a form, you might have to close and reopen that form, to make the property browser's drop-down list for Diagram populated with all available Diagram instances.

The scale in which the overview control paints items is determined by ScaleFactor and ScaleMode properties. FitAll mode makes the whole diagram fit into the control.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Diagramming.Wpf.Overview

See Also

Overview Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview Members

Overview Members
Constructors Fields Properties Methods
[image]

The Overview control provides a scaled-down view of a Diagram and allows scrolling and zooming the diagram with the mouse.

The following tables list the members exposed by the Overview type.

Public Constructors

Name | Description
Overview | Initializes a new instance of the Overview class.

Public Fields

Name | Description
DocumentProperty | Identifies the Document dependency property.

Public Properties

Name | Description
AllowZoom | Gets or sets a value indicating whether users are allowed to zoom the diagram by resizing the overview's viewport tracker rectangle.
DimBrush | Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram's client rectangle.
Document | Gets or sets the Diagram instance whose content to display in this overview control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ScaleMode | Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
TrackingRectPen | Gets or sets the Pen object used to draw the tracking rectangle border.

Public Methods

Name | Description
ScrollTo | Scrolls the overview control, so that diagramPoint is displayed at the top left corner of the overview.

See Also

Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview Fields

Overview Fields
[image]

Public Fields

Name | Description
DocumentProperty | Identifies the Document dependency property.

See Also

Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.DocumentProperty Field

Overview.DocumentProperty Field
[image]

Identifies the Document dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty DocumentProperty

Visual Basic [image] Copy Code

Public Shared DocumentProperty As DependencyProperty

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview Constructor

Overview Constructor
[image]

Initializes a new instance of the Overview class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Overview ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview Methods

Overview Methods
[image]

Public Methods

Name | Description
ScrollTo | Scrolls the overview control, so that diagramPoint is displayed at the top left corner of the overview.

See Also

Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.ScrollTo Method

Overview.ScrollTo Method
[image]

Scrolls the overview control, so that diagramPoint is displayed at the top left corner of the overview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
Point diagramPoint
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
diagramPoint As Point _
)

Parameters

diagramPoint

A point in diagram document coordinates

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview Properties

Overview Properties
[image]

Public Properties

Name | Description
AllowZoom | Gets or sets a value indicating whether users are allowed to zoom the diagram by resizing the overview's viewport tracker rectangle.
DimBrush | Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram's client rectangle.
Document | Gets or sets the Diagram instance whose content to display in this overview control.
ScaleFactor | Gets or sets a fixed scale factor to be used when FitAll is disabled.
ScaleMode | Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.
ShowScrollbars | Gets or sets a value indicating whether the scrollbars of the overview control are visible.
TrackingRectPen | Gets or sets the Pen object used to draw the tracking rectangle border.

See Also

Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.AllowZoom Property

Overview.AllowZoom Property
[image]

Gets or sets a value indicating whether users are allowed to zoom the diagram by resizing the overview's viewport tracker rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowZoom { get; set; }

Visual Basic [image] Copy Code

Public Property AllowZoom As Boolean

Property Value

true to let users zoom by resizing the tracker rectangle, or false otherwise.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.DimBrush Property

Overview.DimBrush Property
[image]

Gets or sets a color used to blend with the part of the diagram that is not visible in the Diagram's client rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush DimBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DimBrush As Brush

Property Value

A .NET Color instance representing the blend color. The default is Color.FromArgb(35, Color.Black).

Remarks

The diagram portion that is currently visible in the client rectangle is painted in the overview using the exact item and background colors. Colors in the area outside that rectangle are alpha-blended with the value of DimBrush.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.Document Property

Overview.Document Property
[image]

Gets or sets the Diagram instance whose content to display in this overview control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As Diagram

Property Value

A Diagram instance bound to this Overview control.

Remarks

The overview control needs a Diagram reference to present the diagram in overview mode.

Example

The following Xaml code binds an Overview control to a Diagram instance called "diagram":

Xaml [image] Copy Code
<Wpf:Overview Name="ovw"
DockPanel.Dock="Right" Height="100" Width="100" ScaleMode="FitAll" >
<Wpf:Overview.Document>
<Binding ElementName="diagram" />
</Wpf:Overview.Document>
</Wpf:Overview>

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.ScaleFactor Property

Overview.ScaleFactor Property
[image]

Gets or sets a fixed scale factor to be used when FitAll is disabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScaleFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleFactor As Double

Property Value

A float value specifying the scale as percentage of diagram's size. The default is 30.

Remarks

When ScaleMode is set to CombinedScales, this factor is multipled by diagram's own ZoomFactor to get the final scale.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace
ScaleMode Property


MindFusion.Diagramming.Wpf.Overview.ScaleMode Property

Overview.ScaleMode Property
[image]

Gets or sets a value indicating whether to fit the whole diagram inside the overview window control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScaleMode ScaleMode { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleMode As ScaleMode

Property Value

A member of the ScaleMode enumeration.

Remarks

In FitAll mode the ScaleFactor is automatically set to a suitable value, small enough to make the diagram's contents entirely visible.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.ShowScrollbars Property

Overview.ShowScrollbars Property
[image]

Gets or sets a value indicating whether the scrollbars of the overview control are visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowScrollbars { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScrollbars As Boolean

Property Value

true to show scrollbars; otherwise, false. The default is false.

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Overview.TrackingRectPen Property

Overview.TrackingRectPen Property
[image]

Gets or sets the Pen object used to draw the tracking rectangle border.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen TrackingRectPen { get; set; }

Visual Basic [image] Copy Code

Public Property TrackingRectPen As Pen

Property Value

See Also

Overview Members
Overview Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs Class

PageRenamedEventArgs Class
[image]

Contains arguments for the PageRenamed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class PageRenamedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class PageRenamedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.PageRenamedEventArgs

See Also

PageRenamedEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs Members

PageRenamedEventArgs Members
Constructors Properties
[image]

Contains arguments for the PageRenamed event.

The following tables list the members exposed by the PageRenamedEventArgs type.

Public Constructors

Name | Description
PageRenamedEventArgs | Initializes a new instance of the PageRenamedEventArgs class.

Public Properties

Name | Description
NewTitle | Specifies the new title.
OldTitle | Specifies the old title.
Page | Specifies which page has been renamed.

See Also

PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs Constructor

PageRenamedEventArgs Constructor
[image]

Initializes a new instance of the PageRenamedEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PageRenamedEventArgs (
DiagramPage page,
string oldTitle,
string newTitle
)

Visual Basic [image] Copy Code

Public New ( _
page As DiagramPage, _
oldTitle As String, _
newTitle As String _
)

Parameters

page

A reference to the DiagramPage that has been renamed,

oldTitle
A string specifying the original Title value.
newTitle
A string specifying the new Title value.

See Also

PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs Properties

PageRenamedEventArgs Properties
[image]

Public Properties

Name | Description
NewTitle | Specifies the new title.
OldTitle | Specifies the old title.
Page | Specifies which page has been renamed.

See Also

PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs.NewTitle Property

PageRenamedEventArgs.NewTitle Property
[image]

Specifies the new title.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string NewTitle { get; set; }

Visual Basic [image] Copy Code

Public Property NewTitle As String

Property Value

A string specifying the new page title.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs.OldTitle Property

PageRenamedEventArgs.OldTitle Property
[image]

Specifies the old title.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldTitle { get; set; }

Visual Basic [image] Copy Code

Public Property OldTitle As String

Property Value

A string specifying the original page title.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PageRenamedEventArgs.Page Property

PageRenamedEventArgs.Page Property
[image]

Specifies which page has been renamed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPage Page { get; set; }

Visual Basic [image] Copy Code

Public Property Page As DiagramPage

Property Value

The page whose Title has been renamed.

See Also

PageRenamedEventArgs Members
PageRenamedEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path Class

Path Class
Remarks See Also
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class Path

Visual Basic [image] Copy Code

Public NotInheritable Class Path

Remarks

Path instances are returned by methods of the PathFinder class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Path

See Also

Path Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path Members

Path Members
Properties Methods
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

The following tables list the members exposed by the Path type.

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path Methods

Path Methods
[image]

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path.GetWeight Method

Path.GetWeight Method
[image]

Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GetWeight (
bool incNodes,
bool incLinks
)

Visual Basic [image] Copy Code

Public Function GetWeight( _
incNodes As Boolean, _
incLinks As Boolean _
) As Double

Parameters

incNodes
A boolean value, which specifies whether the Weight of DiagramNode elements will be considered.
incLinks
A boolean value, which specifies whether the Weight of DiagramLink elements will be considered.

Return Value

A double value that represents the total weight of the elements in this Path according to the incNodes and incLinks parameters.

See Also

Path Members
Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path Properties

Path Properties
[image]

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

See Also

Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path.Items Property

Path.Items Property
[image]

Gets a collection of all DiagramNode and DiagramLink elements in the path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

The collection contains consecutive DiagramNode and DiagramLink objects.

See Also

Path Members
Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path.Length Property

Path.Length Property
[image]

Gets the length of the Path expressed as the number of Links participating in it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that represents the number of edges (links) in the path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path.Links Property

Path.Links Property
[image]

Gets a collection of all DiagramLink elements participating in the path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Path.Nodes Property

Path.Nodes Property
[image]

Gets a collection of all DiagramNode elements participating in the path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection Class

PathCollection Class
[image]

Represents a strongly typed collection of Path objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class PathCollection : CollectionBase

Visual Basic [image] Copy Code

Public NotInheritable Class PathCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.PathCollection

See Also

PathCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection Members

PathCollection Members
Constructors Properties Methods
[image]

Represents a strongly typed collection of Path objects.

The following tables list the members exposed by the PathCollection type.

Public Constructors

Name | Description
PathCollection | Initializes a new instance of the PathCollection class.

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified path to the collection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection Constructor

PathCollection Constructor
[image]

Initializes a new instance of the PathCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection Methods

PathCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Path to the collection.
Clear | Removes all Path elements from the PathCollection.
GetAt | Gets the Path at the specified position.
Insert | Inserts the specified path to the collection at the specified index.
Remove | Removes the specified Path element from the PathCollection.

See Also

PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.Add Method

PathCollection.Add Method
[image]

Adds the specified Path to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
Path path
)

Visual Basic [image] Copy Code

Public Sub Add( _
path As Path _
)

Parameters

path
The Path object to add.

Remarks

The Path object is added at the end of the PathCollection. Use Insert to specify the place of the new element.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.Clear Method

PathCollection.Clear Method
[image]

Removes all Path elements from the PathCollection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

Remarks

The method removes all Path elements in the collection. If you want to delete a specific element use Remove.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.GetAt Method

PathCollection.GetAt Method
[image]

Gets the Path at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to get.

Return Value

The Path at the specified position in the PathCollection.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.Insert Method

PathCollection.Insert Method
[image]

Inserts the specified path to the collection at the specified index.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
Path path
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
path As Path _
)

Parameters

index
The zero-based index at which the new Path element should be inserted.
path
The Path element to insert.

Remarks

The method insertes a new element at a gieven position in the PathCollection. Use Add to add a new element to the end of the collection.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.Remove Method

PathCollection.Remove Method
[image]

Removes the specified Path element from the PathCollection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Path path
)

Visual Basic [image] Copy Code

Public Sub Remove( _
path As Path _
)

Parameters

path
The Path element to remove.

Remarks

The size of the PathCollection is corrected. Indexes of the elements after path are updated too.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection Properties

PathCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the Path at the specified position.

See Also

PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathCollection.Item Property

PathCollection.Item Property
[image]

Gets or sets the Path at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Path

Parameters

index
The zero-based index of the Path element to access.

Property Value

An instance of the Path class that represents the path at the specified position.

See Also

PathCollection Members
PathCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Class

PathFinder Class
Remarks See Also
[image]

Provides methods that help you find paths and cycles in a graph.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class PathFinder

Visual Basic [image] Copy Code

Public NotInheritable Class PathFinder

Remarks

By default the direction of links is taken into account when looking for paths or cycles. In that case the direction of a path is considered to be the direction defined by the outgoing links of nodes. Use the second constructor override to specify that link direction should be ignored when looking for paths.

A path-finder object caches graph information between method calls in order to achieve better performance when path and cycle -finding methods are called on the same diagram more than once. However if the diagram structure changes, you must create a new PathFinder instance in order to use the new structure of the diagram graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.PathFinder

See Also

PathFinder Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Members

PathFinder Members
Constructors Methods
[image]

Provides methods that help you find paths and cycles in a graph.

The following tables list the members exposed by the PathFinder type.

Public Constructors

Name | Description
PathFinder | Overloaded. Initializes a new instance of the PathFinder class.

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Constructor

PathFinder Constructor
[image]

Initializes a new instance of the PathFinder class.

Overload List

Name | Description
PathFinder (Diagram) | Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.
PathFinder (Diagram, Boolean) | Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

See Also

PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Constructor (Diagram)

PathFinder Constructor (Diagram)
See Also
[image]

Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
An instance of the Diagram class in which to look for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified through the argument. The diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Constructor (Diagram, Boolean)

PathFinder Constructor (Diagram, Boolean)
See Also
[image]

Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram,
bool ignoreDirection
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
ignoreDirection As Boolean _
)

Parameters

diagram
A Diagram instance in which to look for paths or cycles.
ignoreDirection

Specifies whether the direction of links should be considered when looking for paths or cycles.

Remarks

The PathFinder methods look for paths and cycles in the Diagram instance specified with the first argument. By default, the diagram is treated as a directed graph and the direction of links is considered when looking for a path, that is, a path continues from a node only through its OutgoingLinks.

To ignore the direction of links, pass true as a value of the ignoreDirection argument; then the path-finding algorithm will look for paths both through the OutgoingLinks and IncomingLinks collections of nodes. If you do not want to ignore the direction of links you can use the alternative constructor.

See Also

PathFinder Constructor Overload List
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder Methods

PathFinder Methods
[image]

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded.
FindCycle | Overloaded. Finds a cycle in the underlying diagram.
FindLongestPath | Overloaded. Finds the longest path in the underlying diagram.
FindShortestPath | Overloaded. Finds the shortest path in the underlying diagram.

See Also

PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.EnumAllCycles Method

PathFinder.EnumAllCycles Method
[image]

Enumerates all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<Path> EnumAllCycles ()

Visual Basic [image] Copy Code

Public Function EnumAllCycles () As IEnumerable(Of Path)

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

Remarks

The found paths are returned using the yield operator, so a path can be processed immediately after it is found.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllCycles Method


MindFusion.Diagramming.Wpf.PathFinder.FindAllCycles Method

PathFinder.FindAllCycles Method
[image]

Finds all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathCollection FindAllCycles ()

Visual Basic [image] Copy Code

Public Function FindAllCycles () As PathCollection

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
EnumAllCycles Method


MindFusion.Diagramming.Wpf.PathFinder.FindAllPaths Method

PathFinder.FindAllPaths Method
[image]

Overload List

Name | Description
PathFinder.FindAllPaths (DiagramNode, DiagramNode) | Finds and returns all paths that exist between two DiagramNode objects.
PathFinder.FindAllPaths (DiagramNode, DiagramNode, Int32) | Finds and returns all paths that exist between two DiagramNode objects.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindAllPaths( _
from As DiagramNode, _
to As DiagramNode _
) As PathCollection

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to,
int maxPaths
)

Visual Basic [image] Copy Code

Public Function FindAllPaths( _
from As DiagramNode, _
to As DiagramNode, _
maxPaths As Integer _
) As PathCollection

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
maxPaths

The maximum number of paths to find.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from and to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindCycle Method

PathFinder.FindCycle Method
[image]

Finds a cycle in the underlying diagram.

Overload List

Name | Description
PathFinder.FindCycle () | Finds a cycle in the Diagram.
PathFinder.FindCycle (DiagramNode) | Detects whether the specified DiagramNode participates in a cycle.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindCycle Method ()

PathFinder.FindCycle Method ()
See Also
[image]

Finds a cycle in the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindCycle ()

Visual Basic [image] Copy Code

Public Function FindCycle () As Path

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindShortestPath Method


MindFusion.Diagramming.Wpf.PathFinder.FindCycle Method (DiagramNode)

PathFinder.FindCycle Method (DiagramNode)
See Also
[image]

Detects whether the specified DiagramNode participates in a cycle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindCycle (
DiagramNode participant
)

Visual Basic [image] Copy Code

Public Function FindCycle( _
participant As DiagramNode _
) As Path

Parameters

participant
A DiagramNode element which should participate in the found cycle.

Return Value

A Path instance that represents the found cycle; null (Nothing in Visual Basic) if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllCycles Method


MindFusion.Diagramming.Wpf.PathFinder.FindLongestPath Method

PathFinder.FindLongestPath Method
[image]

Finds the longest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindLongestPath () | Finds the longest path in the graph.
PathFinder.FindLongestPath (DiagramNode, DiagramNode) | Finds the longest path between the specified DiagramNode objects.
PathFinder.FindLongestPath (Int64) | Finds the longest path in the diagram.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindLongestPath Method ()

PathFinder.FindLongestPath Method ()
See Also
[image]

Finds the longest path in the graph.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindLongestPath ()

Visual Basic [image] Copy Code

Public Function FindLongestPath () As Path

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there are no DiagramNode elements in the graph.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllPaths Method


MindFusion.Diagramming.Wpf.PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)

PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds the longest path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindLongestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindLongestPath( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode element in the Path.
to
The last DiagramNode element in the Path.

Return Value

A Path instance that represents the longest path found; null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllPaths Method


MindFusion.Diagramming.Wpf.PathFinder.FindLongestPath Method (Int64)

PathFinder.FindLongestPath Method (Int64)
See Also
[image]

Finds the longest path in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindLongestPath (
long timeLimit
)

Visual Basic [image] Copy Code

Public Function FindLongestPath( _
timeLimit As Long _
) As Path

Parameters

timeLimit

The maximum duration of the search process, in milliseconds.

Return Value

The longest Path found; null (Nothing in Visual Basic) if no Path has been detected.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllPaths Method


MindFusion.Diagramming.Wpf.PathFinder.FindShortestPath Method

PathFinder.FindShortestPath Method
[image]

Finds the shortest path in the underlying diagram.

Overload List

Name | Description
PathFinder.FindShortestPath (DiagramNode, DiagramNode) | Finds and returns the shortest Path between the specified DiagramNode objects.
PathFinder.FindShortestPath (DiagramNode, DiagramNode, Boolean, Boolean) | Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

See Also

PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns the shortest Path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindShortestPath( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.

Return Value

A Path instance that represents the shortest path found; null (Nothing in Visual Basic) if there is no path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllPaths Method


MindFusion.Diagramming.Wpf.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)
See Also
[image]

Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to,
bool useNodeWeights,
bool useLinkWeights
)

Visual Basic [image] Copy Code

Public Function FindShortestPath( _
from As DiagramNode, _
to As DiagramNode, _
useNodeWeights As Boolean, _
useLinkWeights As Boolean _
) As Path

Parameters

from
The first DiagramNode in the Path.
to
The last DiagramNode in the Path.
useNodeWeights
If true, the Path with minimal total weight is found, summing the Weight of nodes in the Path.
useLinkWeights
If true, the Path with minimal total weight is found, summing the Weight of links in the Path.

Return Value

A Path instance that represents the shortest Path found or null (Nothing in Visual Basic) if there is no Path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class
MindFusion.Diagramming.Wpf Namespace
FindAllPaths Method


MindFusion.Diagramming.Wpf.PointCollection Class

PointCollection Class
[image]

Represents a strongly typed collection of points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class PointCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class PointCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.PointCollection

See Also

PointCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Members

PointCollection Members
Constructors Properties Methods
[image]

Represents a strongly typed collection of points.

The following tables list the members exposed by the PointCollection type.

Public Constructors

Name | Description
PointCollection | Overloaded. Initializes a new instance of the PointCollection class.

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a Point array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
Reverse | Returns a copy of this collection with reversed order of elements.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Constructor

PointCollection Constructor
[image]

Initializes a new instance of the PointCollection class.

Overload List

Name | Description
PointCollection (IEnumerable(Point)) | Initializes a new instance of the PointCollection class with the specified point values.
PointCollection (Int32) | Initializes a new instance of the PointCollection class with the specified initial size.

See Also

PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Constructor (IEnumerable(Point))

PointCollection Constructor (IEnumerable(Point))
See Also
[image]

Initializes a new instance of the PointCollection class with the specified point values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection (
IEnumerable<Point> points
)

Visual Basic [image] Copy Code

Public New ( _
points As IEnumerable(Of Point) _
)

Parameters

points

A list of Point values that supplies the elements initially contained in the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Constructor (Int32)

PointCollection Constructor (Int32)
See Also
[image]

Initializes a new instance of the PointCollection class with the specified initial size.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection (
int size
)

Visual Basic [image] Copy Code

Public New ( _
size As Integer _
)

Parameters

size

The initial size of the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Methods

PointCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified point to the collection.
AddRange | Adds the points in the specified collection to this collection.
Clear | Removes all points from the collection.
Clone | Creates a shallow copy of this collection.
GetArray | Gets a Point array containing the points in this collection.
GetAt | Gets the point at the specified position.
Insert | Inserts the specified point in the collection at the specified position.
Remove | Removes the specified point from the collection.
Reverse | Returns a copy of this collection with reversed order of elements.
SetAt | Sets the specified point at the specified position within the collection.

See Also

PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Add Method

PointCollection.Add Method
[image]

Adds the specified point to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
Point point
)

Visual Basic [image] Copy Code

Public Sub Add( _
point As Point _
)

Parameters

point
The .NET Point object to add to the collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.AddRange Method

PointCollection.AddRange Method
[image]

Adds the points in the specified collection to this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AddRange (
ICollection c
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
c As ICollection _
)

Parameters

c
The .NET ICollection object that contains the points to add to this collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Clear Method

PointCollection.Clear Method
[image]

Removes all points from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Clone Method

PointCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As PointCollection

Return Value

An instance of the PointCollection class.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.GetArray Method

PointCollection.GetArray Method
[image]

Gets a Point array containing the points in this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point[] GetArray ()

Visual Basic [image] Copy Code

Public Function GetArray () As Point()

Return Value

An array of Point objects containing all points in the colleciton.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.GetAt Method

PointCollection.GetAt Method
[image]

Gets the point at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Point

Parameters

index

The zero-based index of the point to retrieve.

Return Value

The Point object at the specified index.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Insert Method

PointCollection.Insert Method
[image]

Inserts the specified point in the collection at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
Point point
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
point As Point _
)

Parameters

index

The zero-based index at which to insert the point.

point
The Point object to add to the collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Remove Method

PointCollection.Remove Method
[image]

Removes the specified point from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Point point
)

Visual Basic [image] Copy Code

Public Sub Remove( _
point As Point _
)

Parameters

point
The Point object to remove.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Reverse Method

PointCollection.Reverse Method
[image]

Returns a copy of this collection with reversed order of elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection Reverse ()

Visual Basic [image] Copy Code

Public Function Reverse () As PointCollection

Return Value

The reverse collection.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.SetAt Method

PointCollection.SetAt Method
[image]

Sets the specified point at the specified position within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetAt (
int index,
Point point
)

Visual Basic [image] Copy Code

Public Sub SetAt( _
index As Integer, _
point As Point _
)

Parameters

index

The zero-based index of the point to set.

point
The Point object to set at the specified position.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection Properties

PointCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the point at the specified position.

See Also

PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PointCollection.Item Property

PointCollection.Item Property
[image]

Gets or sets the point at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Point

Parameters

index

The zero-based index of the point to set or retrieve.

Property Value

The Point object at the specified index.

See Also

PointCollection Members
PointCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Class

PrintOptions Class
Remarks See Also
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class PrintOptions : RenderOptions

Visual Basic [image] Copy Code

Public Class PrintOptions
Inherits RenderOptions

Remarks

Use the PrintOptions property of the Diagram class to access the sole instance of this class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.RenderOptions
MindFusion.Diagramming.Wpf.PrintOptions

See Also

PrintOptions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Members

PrintOptions Members
Constructors Properties Methods
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the PrintOptions type.

Public Constructors

Name | Description
PrintOptions | Overloaded.

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled. (Inherited from RenderOptions.)
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled. (Inherited from RenderOptions.)
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled. (Inherited from RenderOptions.)
EnableEffects | Enables or disables special effects. (Inherited from RenderOptions.)
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled. (Inherited from RenderOptions.)
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled. (Inherited from RenderOptions.)
EnableLanes | Gets or sets whether to print swimlanes.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled. (Inherited from RenderOptions.)
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled. (Inherited from RenderOptions.)
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.
RenderTarget | Gets or sets the rendering target. (Inherited from RenderOptions.)
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram. (Inherited from RenderOptions.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from RenderOptions.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from RenderOptions.)
SkipEmptyPages | Gets or sets whether to print pages without any content in them.
TargetView | Gets or sets the object that currently displays the Diagram. (Inherited from RenderOptions.)

Public Methods

Name | Description
Clone | Creates a copy of the current PrintOptions instance.

See Also

PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Constructor

PrintOptions Constructor
[image]

Overload List

Name | Description
PrintOptions (Diagram) | Initializes a new instance of the PrintOptions class.
PrintOptions (DiagramBase) | Initializes a new instance of the PrintOptions class.

See Also

PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Constructor (Diagram)

PrintOptions Constructor (Diagram)
See Also
[image]

Initializes a new instance of the PrintOptions class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PrintOptions (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub PrintOptions ( _
diagram As Diagram _
)

Parameters

diagram
The diagram this object will be associated with.

See Also

PrintOptions Constructor Overload List
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Constructor (DiagramBase)

PrintOptions Constructor (DiagramBase)
See Also
[image]

Initializes a new instance of the PrintOptions class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PrintOptions (
DiagramBase diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As DiagramBase _
)

Parameters

diagram

An instance of a DiagramBase -derived class this object is associated with.

See Also

PrintOptions Constructor Overload List
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Methods

PrintOptions Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of the current PrintOptions instance.

See Also

PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.Clone Method

PrintOptions.Clone Method
[image]

Creates a copy of the current PrintOptions instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PrintOptions Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As PrintOptions

Return Value

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions Properties

PrintOptions Properties
[image]

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled. (Inherited from RenderOptions.)
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled. (Inherited from RenderOptions.)
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled. (Inherited from RenderOptions.)
EnableEffects | Enables or disables special effects. (Inherited from RenderOptions.)
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled. (Inherited from RenderOptions.)
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled. (Inherited from RenderOptions.)
EnableLanes | Gets or sets whether to print swimlanes.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled. (Inherited from RenderOptions.)
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled. (Inherited from RenderOptions.)
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.
RenderTarget | Gets or sets the rendering target. (Inherited from RenderOptions.)
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram. (Inherited from RenderOptions.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from RenderOptions.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from RenderOptions.)
SkipEmptyPages | Gets or sets whether to print pages without any content in them.
TargetView | Gets or sets the object that currently displays the Diagram. (Inherited from RenderOptions.)

See Also

PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.DocumentName Property

PrintOptions.DocumentName Property
[image]

Gets or sets the name of the printed document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string DocumentName { get; set; }

Visual Basic [image] Copy Code

Public Property DocumentName As String

Property Value

A string value specifying the name of the printed document. The default is " - Untitled - ".

Remarks

This string is displayed in the print queue status window and in page headers.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.EnableLanes Property

PrintOptions.EnableLanes Property
[image]

Gets or sets whether to print swimlanes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableLanes { get; set; }

Visual Basic [image] Copy Code

Public Property EnableLanes As Boolean

Property Value

true to print the LaneGrid, otherwise false. The default value is false.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.HeaderFormat Property

PrintOptions.HeaderFormat Property
[image]

Gets or sets the format of page headers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string HeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFormat As String

Property Value

A string value specifying the name of the printed document. The default is "%D , Page %P".

Remarks

The header format string can contain fixed text and format specifiers. Currently, there are two format specifiers supported: %D is a placeholder for the document title; %P is a placholder for the page number.

Example

To get page headers of the form "Page 21 of document MyChart.fc", use code like this:

C# [image] Copy Code
diagram.PrintOptions.HeaderFormat = "Page %P of document %D";
diagram.PrintOptions.DocumentName = "MyChart.fc";
diagram.Print();
Visual Basic [image] Copy Code
diagram.PrintOptions.HeaderFormat = "Page %P of document %D"
diagram.PrintOptions.DocumentName = "MyChart.fc"
diagram.Print()

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.Margins Property

PrintOptions.Margins Property
[image]

Gets or sets the margins for the printed pages.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

A Thickness value specifying the margins size in WPF device independent pixels. The default value is 48.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.PrintOptions.SkipEmptyPages Property

PrintOptions.SkipEmptyPages Property
[image]

Gets or sets whether to print pages without any content in them.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SkipEmptyPages { get; set; }

Visual Basic [image] Copy Code

Public Property SkipEmptyPages As Boolean

Property Value

true to skip pages without content, or false otherwise. The default value is false.

Remarks

A sparse diagram might contain large areas that do not contain any items. When such diagram is paginated, a page might be empty apart from its header content. Enable this property to prevent printing empty pages.

See Also

PrintOptions Members
PrintOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Class

QuickRouter Class
Remarks See Also
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class QuickRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class QuickRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.QuickRouter

See Also

QuickRouter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Members

QuickRouter Members
Constructors Properties Methods
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the QuickRouter type.

Public Constructors

Name | Description
QuickRouter | Overloaded.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Constructor

QuickRouter Constructor
[image]

Overload List

Name | Description
QuickRouter () | Initializes a new instance of the QuickRouter class.
QuickRouter (Diagram) | Initializes a new instance of the QuickRouter class.

See Also

QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Constructor ()

QuickRouter Constructor ()
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public QuickRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QuickRouter Constructor Overload List
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Constructor (Diagram)

QuickRouter Constructor (Diagram)
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public QuickRouter (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this router will operate on.

See Also

QuickRouter Constructor Overload List
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Methods

QuickRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.Resume Method

QuickRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks
true if the links should be routed, otherwise false.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.RouteAllLinks Method

QuickRouter.RouteAllLinks Method
[image]

Routes all links in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.RouteLink Method

QuickRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.RouteLinks Method

QuickRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A list of DiagramLink objects that should be routed.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.Suspend Method

QuickRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter Properties

QuickRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

See Also

QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.Diagram Property

QuickRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.Granularity Property

QuickRouter.Granularity Property
[image]

Gets or sets the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Granularity Granularity { get; set; }

Visual Basic [image] Copy Code

Public Property Granularity As Granularity

Property Value

A member of the Granularity enumeration. The default value is CoarseGrained.

Remarks

A CoarseGrained obstacle map leads to faster path finding, however the found paths might be longer than necessary in a small percent of the cases. The coarse-grained map also takes slightly more time to build, so you might disable it if there are aren't many links in the diagram.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.TurnCost Property

QuickRouter.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Double

Property Value

A double value specifying the turn cost. The default is 50.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.QuickRouter.UBendMaxLen Property

QuickRouter.UBendMaxLen Property
[image]

Gets or sets the maximum U-bend length.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double UBendMaxLen { get; set; }

Visual Basic [image] Copy Code

Public Property UBendMaxLen As Double

Property Value

A double value specifying the maximum length of U-bends in millimeters. The default is 30.

See Also

QuickRouter Members
QuickRouter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T) Class

ReadOnlyCollection(T) Class
[image]

Represents a read-only wrapper of a collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ReadOnlyCollection<T> : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ReadOnlyCollection(Of T)
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ReadOnlyCollection(T)
MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection
MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection
MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyCollection(T) Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T) Members

ReadOnlyCollection(T) Members
Constructors Properties Methods
[image]

Represents a read-only wrapper of a collection.

The following tables list the members exposed by the ReadOnlyCollection(T) type.

Public Constructors

Name | Description
ReadOnlyCollection | Initializes a new instance of the ReadonlyCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T) Constructor

ReadOnlyCollection(T) Constructor
[image]

Initializes a new instance of the ReadonlyCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ReadOnlyCollection<T> (
ICollection<T> innerCollection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
innerCollection As ICollection(Of T) _
)

Parameters

innerCollection

A .NET ICollection that represents the collection to wrap.

See Also

ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T) Methods

ReadOnlyCollection(T) Methods
[image]

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T).CopyTo Method

ReadOnlyCollection(T).CopyTo Method
[image]

Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

The one-dimensional Array that is the destination of the elements copied from the current collection.

index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T).GetEnumerator Method

ReadOnlyCollection(T).GetEnumerator Method
[image]

Returns an enumerator that can iterate through the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An .NET IEnumerator for the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T) Properties

ReadOnlyCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T).Count Property

ReadOnlyCollection(T).Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

The number of elements actually contained in the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T).IsSynchronized Property

ReadOnlyCollection(T).IsSynchronized Property
[image]

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyCollection(T).SyncRoot Property

ReadOnlyCollection(T).SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection Class

ReadOnlyDiagramItemCollection Class
[image]

Represents a read-only collection of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramItemCollection : ReadOnlyCollection<DiagramItem>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramItemCollection
Inherits ReadOnlyCollection(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ReadOnlyCollection(DiagramItem)
MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection

See Also

ReadOnlyDiagramItemCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection Members

ReadOnlyDiagramItemCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of items.

The following tables list the members exposed by the ReadOnlyDiagramItemCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramItemCollection | Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection Constructor

ReadOnlyDiagramItemCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ReadOnlyDiagramItemCollection (
DiagramItemCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramItemCollection _
)

Parameters

innerCollection
A DiagramItemCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection Methods

ReadOnlyDiagramItemCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection.Contains Method

ReadOnlyDiagramItemCollection.Contains Method
[image]

Checks whether the specified DiagramItem is contained within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As DiagramItem _
) As Boolean

Parameters

item
The DiagramItem to search for in the collection.

Return Value

true if the specified item is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection.IndexOf Method

ReadOnlyDiagramItemCollection.IndexOf Method
[image]

Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As DiagramItem _
) As Integer

Parameters

item
The DiagramItem whose index to retreive from the collection.

Return Value

The zero-based index of the specified item within the colleciton; or -1 if the item is not found.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection Properties

ReadOnlyDiagramItemCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramItemCollection.Item Property

ReadOnlyDiagramItemCollection.Item Property
[image]

Gets the DiagramItem at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramItem

Parameters

index
The zero-based index of the item to get.

Property Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection Class

ReadOnlyDiagramLinkCollection Class
[image]

Represents a read-only collection of links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramLinkCollection : ReadOnlyCollection<DiagramLink>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramLinkCollection
Inherits ReadOnlyCollection(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ReadOnlyCollection(DiagramLink)
MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection

See Also

ReadOnlyDiagramLinkCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection Members

ReadOnlyDiagramLinkCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of links.

The following tables list the members exposed by the ReadOnlyDiagramLinkCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramLinkCollection | Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection Constructor

ReadOnlyDiagramLinkCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ReadOnlyDiagramLinkCollection (
DiagramLinkCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramLinkCollection _
)

Parameters

innerCollection
A DiagramLinkCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection Methods

ReadOnlyDiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection.Contains Method

ReadOnlyDiagramLinkCollection.Contains Method
[image]

Checks whether the specified DiagramLink is contained within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function Contains( _
link As DiagramLink _
) As Boolean

Parameters

link
The DiagramLink to search for in the collection.

Return Value

true if the specified link is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection.IndexOf Method

ReadOnlyDiagramLinkCollection.IndexOf Method
[image]

Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
link As DiagramLink _
) As Integer

Parameters

link
The DiagramLink whose index to retreive from the collection.

Return Value

The zero-based index of the specified link within the colleciton; or -1 if the link is not found.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection Properties

ReadOnlyDiagramLinkCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramLinkCollection.Item Property

ReadOnlyDiagramLinkCollection.Item Property
[image]

Gets the DiagramLink at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramLink

Parameters

index
The zero-based index of the link to get.

Property Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection Class

ReadOnlyDiagramNodeCollection Class
[image]

Represents a read-only collection of nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramNodeCollection : ReadOnlyCollection<DiagramNode>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramNodeCollection
Inherits ReadOnlyCollection(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ReadOnlyCollection(DiagramNode)
MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyDiagramNodeCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection Members

ReadOnlyDiagramNodeCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of nodes.

The following tables list the members exposed by the ReadOnlyDiagramNodeCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramNodeCollection | Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection Constructor

ReadOnlyDiagramNodeCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ReadOnlyDiagramNodeCollection (
DiagramNodeCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramNodeCollection _
)

Parameters

innerCollection
A DiagramNodeCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection Methods

ReadOnlyDiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection.Contains Method

ReadOnlyDiagramNodeCollection.Contains Method
[image]

Checks whether the specified DiagramNode is contained within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Contains( _
node As DiagramNode _
) As Boolean

Parameters

node
The DiagramNode to search for in the collection.

Return Value

true if the specified node is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection.IndexOf Method

ReadOnlyDiagramNodeCollection.IndexOf Method
[image]

Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
node As DiagramNode _
) As Integer

Parameters

node
The DiagramNode whose index to retreive from the collection.

Return Value

The zero-based index of the specified node within the colleciton; or -1 if the node is not found.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection Properties

ReadOnlyDiagramNodeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ReadOnlyDiagramNodeCollection.Item Property

ReadOnlyDiagramNodeCollection.Item Property
[image]

Gets the DiagramNode at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramNode

Parameters

index
The zero-based index of the node to get.

Property Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Relationship Enumeration

Relationship Enumeration
[image]

Specifies the type of relationship between two tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Relationship

Visual Basic [image] Copy Code

Public Enum Relationship

Members

Member name | Description
ManyToOne | The relationship is of type M:1, that is, many to one.
OneToMany | The relationship is of type 1:M, that is, one to many.

Remarks

Use the enumeration values when drawing database diagrams. It helps to specify how database tables' fields are related.

See Also

MindFusion.Diagramming.Wpf Namespace
AddRelation Method


MindFusion.Diagramming.Wpf.RelativePosition Class

RelativePosition Class
[image]

Represents relative positions inside diagram elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RelativePosition

Visual Basic [image] Copy Code

Public Class RelativePosition

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.RelativePosition

See Also

RelativePosition Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition Members

RelativePosition Members
Constructors Properties Methods
[image]

Represents relative positions inside diagram elements.

The following tables list the members exposed by the RelativePosition type.

Public Constructors

Name | Description
RelativePosition |

Public Properties

Name | Description
RelativeTo | Gets or sets the node's corner to which this point is anchored.
X | Gets or sets the horizontal position.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or a fixed offset.
Y | Gets or sets the vertical position.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or a fixed offset.

Public Methods

Name | Description
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition Constructor

RelativePosition Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RelativePosition ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition Methods

RelativePosition Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the label into the specified XML element.

See Also

RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.LoadFromXml Method

RelativePosition.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.SaveToXml Method

RelativePosition.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

A XmlElement instance.

context

A XmlPersistContext instance.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition Properties

RelativePosition Properties
[image]

Public Properties

Name | Description
RelativeTo | Gets or sets the node's corner to which this point is anchored.
X | Gets or sets the horizontal position.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or a fixed offset.
Y | Gets or sets the vertical position.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or a fixed offset.

See Also

RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.RelativeTo Property

RelativePosition.RelativeTo Property
[image]

Gets or sets the node's corner to which this point is anchored.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupAnchorStyles RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As GroupAnchorStyles

Property Value

A combination of GroupAnchorStyles flags specifying to what point of nodes to add the offset specified by this instance.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.X Property

RelativePosition.X Property
[image]

Gets or sets the horizontal position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value specifying horizontal position.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.XUnit Property

RelativePosition.XUnit Property
[image]

Gets or sets whether the point's X position is specified as percentage of node's size or a fixed offset.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UnitType XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As UnitType

Property Value

A member of the UnitType enumeration.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.Y Property

RelativePosition.Y Property
[image]

Gets or sets the vertical position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value specifying vertical position.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativePosition.YUnit Property

RelativePosition.YUnit Property
[image]

Gets or sets whether the point's Y position is specified as percentage of node's size or a fixed offset.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UnitType YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As UnitType

Property Value

A member of the UnitType enumeration.

See Also

RelativePosition Members
RelativePosition Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RelativeToLink Enumeration

RelativeToLink Enumeration
[image]

Specifies how the link labels are positioned.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum RelativeToLink

Visual Basic [image] Copy Code

Public Enum RelativeToLink

Members

Member name | Description
ControlPoint | Indicates that the link labels are positioned relative to a specified control point.
LinkLength | Indicates that the link labels are positioned relative to the link.
Segment | Indicates that the link labels are positioned relative to a specified segment.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions Class

RenderOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RenderOptions

Visual Basic [image] Copy Code

Public Class RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.RenderOptions
MindFusion.Diagramming.Wpf.PrintOptions

See Also

RenderOptions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions Members

RenderOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the RenderOptions type.

Public Constructors

Name | Description
RenderOptions | Initializes a new instance of the RenderOptions class.

Public Properties

Name | Description
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.

See Also

RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions Constructor

RenderOptions Constructor
[image]

Initializes a new instance of the RenderOptions class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RenderOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions Properties

RenderOptions Properties
[image]

Public Properties

Name | Description
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.

See Also

RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableAnchors Property

RenderOptions.EnableAnchors Property
[image]

Gets or sets a value indicating whether the printing of anchor point marks is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnchors As Boolean

Property Value

true if anchor point marks should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableBackground Property

RenderOptions.EnableBackground Property
[image]

Gets or sets a value indicating whether the printing of the background color is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableBackground { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackground As Boolean

Property Value

true if the diagram background should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableBackgroundImage Property

RenderOptions.EnableBackgroundImage Property
[image]

Gets or sets a value indicating whether the printing of the background image is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableBackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackgroundImage As Boolean

Property Value

true if the background image should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableEffects Property

RenderOptions.EnableEffects Property
[image]

Enables or disables special effects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableEffects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableEffects As Boolean

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableImages Property

RenderOptions.EnableImages Property
[image]

Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableImages { get; set; }

Visual Basic [image] Copy Code

Public Property EnableImages As Boolean

Property Value

true to print node images; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableInterior Property

RenderOptions.EnableInterior Property
[image]

Gets or sets a value indicating whether the printing of node interiors is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableInterior { get; set; }

Visual Basic [image] Copy Code

Public Property EnableInterior As Boolean

Property Value

true to print node interiors; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableShadows Property

RenderOptions.EnableShadows Property
[image]

Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableShadows { get; set; }

Visual Basic [image] Copy Code

Public Property EnableShadows As Boolean

Property Value

true to print item shadows; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.EnableText Property

RenderOptions.EnableText Property
[image]

Gets or sets a value indicating whether the printing of the text of diagram items is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableText As Boolean

Property Value

true to print item texts; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.RenderTarget Property

RenderOptions.RenderTarget Property
[image]

Gets or sets the rendering target.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RenderTarget RenderTarget { get; set; }

Visual Basic [image] Copy Code

Public Property RenderTarget As RenderTarget

Property Value

A value from the RenderTarget enumeration specifying whether rendering is done on the screen or on a printer.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.Scale Property

RenderOptions.Scale Property
[image]

Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A float value specifying the scale factor of the print output.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.ScrollX Property

RenderOptions.ScrollX Property
[image]

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Double

Property Value

A double value specifying the X scroll position.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.ScrollY Property

RenderOptions.ScrollY Property
[image]

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Double

Property Value

A double value specifying the Y scroll position.

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderOptions.TargetView Property

RenderOptions.TargetView Property
[image]

Gets or sets the object that currently displays the Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object TargetView { get; set; }

Visual Basic [image] Copy Code

Public Property TargetView As Object

Property Value

See Also

RenderOptions Members
RenderOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RenderTarget Enumeration

RenderTarget Enumeration
[image]

Specifies where the diagram is being rendered.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum RenderTarget

Visual Basic [image] Copy Code

Public Enum RenderTarget

Members

Member name | Description
Display | The disgram is rendered on the screen.
Printer | The disgram is rendered on a printer.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Class

RepaintEventArgs Class
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RepaintEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RepaintEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.RepaintEventArgs

See Also

RepaintEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Members

RepaintEventArgs Members
Constructors Properties
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

The following tables list the members exposed by the RepaintEventArgs type.

Public Constructors

Name | Description
RepaintEventArgs | Overloaded.

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.

See Also

RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Constructor

RepaintEventArgs Constructor
[image]

Overload List

Name | Description
RepaintEventArgs (Rect) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (Rect, Boolean) | Initializes a new instance of the RepaintEventArgs class.

See Also

RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Constructor (Rect)

RepaintEventArgs Constructor (Rect)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RepaintEventArgs (
Rect invalidRect
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As Rect _
)

Parameters

invalidRect

A Rect object representing the rectangle that should be repainted.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Constructor (Rect, Boolean)

RepaintEventArgs Constructor (Rect, Boolean)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RepaintEventArgs (
Rect invalidRect,
bool redrawCacheImage
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As Rect, _
redrawCacheImage As Boolean _
)

Parameters

invalidRect

A Rect object representing the rectangle that should be repainted.

redrawCacheImage

A boolean value specifying whether the diagram cache image used during modification should be re-created.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs Properties

RepaintEventArgs Properties
[image]

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.

See Also

RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs.InvalidRect Property

RepaintEventArgs.InvalidRect Property
[image]

Gets the rectangular area in the diagram document that should be repainted.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect InvalidRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property InvalidRect As Rect

Property Value

See Also

RepaintEventArgs Members
RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RepaintEventArgs.RedrawCacheImage Property

RepaintEventArgs.RedrawCacheImage Property
[image]

Gets a value indicating whether the back-buffer cache image should be repainted as well.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RedrawCacheImage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RedrawCacheImage As Boolean

Property Value

See Also

RepaintEventArgs Members
RepaintEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RerouteLinks Enumeration

RerouteLinks Enumeration
[image]

Provides values indicating in what circumstances links must be rerouted automatically.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum RerouteLinks

Visual Basic [image] Copy Code

Public Enum RerouteLinks

Members

Member name | Description
Never | Do not reroute links automatically.
WhenIntersectNode | Reroute a link if it intersects a node.
WhenModified | Reroute a link if its end points are moved around.
WhileCreating | Route new links while users draw them. This flag can be combined with any of the previous two flags.
WhileModifying | Route links while the user modifies them or drags their incident nodes.

Remarks

These values can be assigned to the TriggerRerouting property of RoutingOptions.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ResolveContainer Delegate

ResolveContainer Delegate
[image]

Represents a method that determines a node's container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate Object ResolveContainer (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function ResolveContainer( _
dataItem As Object _
) As Object

Parameters

dataItem

A data item whose container should be returned.

Return Value

The container data object.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ResolveNodePosition Delegate

ResolveNodePosition Delegate
[image]

Represents a method that determines the position of a data item within the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate Rect ResolveNodePosition (
Object dataItem
)

Visual Basic [image] Copy Code

Public Delegate Function ResolveNodePosition( _
dataItem As Object _
) As Rect

Parameters

dataItem

A data item whose position should be returned.

Return Value

A System.Windows.Rect specifying the item's position.

Remarks

By default, VirtualizingDiagram determines the position of a data item by inspecting its X, Y, Width and Height properties through reflection. By assigning this delegate method to the ResolveNodePosition property of VirtualizingDiagram, you can place items whose position properties are named differently or whose position is stored elsewhere.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RestrictToBounds Enumeration

RestrictToBounds Enumeration
[image]

Specifies the restriction of the position of an object as to the document extents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum RestrictToBounds

Visual Basic [image] Copy Code

Public Enum RestrictToBounds

Members

Member name | Description
InsideOnly | Items must be located entirely inside the document extents.
Intersection | Items must be located at least partially inside the document extents.
NoRestriction | No restriction on the position of items.

Remarks

This enumeration specifies the possible values of the RestrictItemsToBounds property.

See Also

MindFusion.Diagramming.Wpf Namespace
RestrictItemsToBounds Property


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Class

RoundRectangleTemplate Class
Remarks See Also
[image]

Represents an ElementTemplate that draws round rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RoundRectangleTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class RoundRectangleTemplate
Inherits ElementTemplate

Remarks

This class ensures that the round corners do not change during resizing which is visually better. The drawback is that the radius appears to be specified in DiagramMeasure units and therefore a given shape instance will look bad when the measure unit is not the one for which the shape was designed.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ElementTemplate
MindFusion.Diagramming.Wpf.RoundRectangleTemplate

See Also

RoundRectangleTemplate Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Members

RoundRectangleTemplate Members
Constructors Properties Methods
[image]

Represents an ElementTemplate that draws round rectangle.

The following tables list the members exposed by the RoundRectangleTemplate type.

Public Constructors

Name | Description
RoundRectangleTemplate | Overloaded. Initializes a new istance of the RoundRectangleTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Constructor

RoundRectangleTemplate Constructor
[image]

Initializes a new istance of the RoundRectangleTemplate class.

Overload List

Name | Description
RoundRectangleTemplate () | Initializes a new istance of the RoundRectangleTemplate class.
RoundRectangleTemplate (Double, Double, Double, Double, Double) | Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Constructor ()

RoundRectangleTemplate Constructor ()
See Also
[image]

Initializes a new istance of the RoundRectangleTemplate class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RoundRectangleTemplate ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)

RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new istance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
double x,
double y,
double w,
double h,
double r
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
r As Double _
)

Parameters

x

The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w

The width of the rectangle, expressed in percents of a shape node's bounding rectangle.

h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Methods

RoundRectangleTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate.Clone Method

RoundRectangleTemplate.Clone Method
[image]

Creates an exact copy of this RoundRectangleTemplate element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

An instance of the RoundRectangleTemplate class.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate.SameAs Method

RoundRectangleTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj
The ElementTemplate to compare to this template.

Return Value

true if the specified object is a RoundRectangleTemplate closely approximating this template; otherwise, false.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate Properties

RoundRectangleTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gest or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate.Bounds Property

RoundRectangleTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rect object that represents the bounding rectangle of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoundRectangleTemplate.Radius Property

RoundRectangleTemplate.Radius Property
[image]

Gets or sets the round radius of this element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

A double value specifying the round radius of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions Class

RoutingOptions Class
Remarks See Also
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RoutingOptions : RoutingOptions

Visual Basic [image] Copy Code

Public Class RoutingOptions
Implements RoutingOptions

Remarks

Use the RoutingOptions member of the Diagram class to access the sole instance of this class.

MindFusion.Diagramming for WPF uses a cost minimization algorithm to route links between nodes. For each link, there is a routing grid built for the area that encloses the link and its origin and destination nodes. The size of the grid pieces is set by GridSize. Each piece of the grid is marked as an obstacle if it intersects an Obstacle node. Some cost values are assigned to the remaining pieces, depending on how distant they are from nodes and other links.

That algorithm evaluates possible paths across the routing grid aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path.

The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links, and Anchoring specifies whether link ends should be aligned to the anchor points defined for nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions Members

RoutingOptions Members
Properties Methods
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EvaluateFarPoints | Gets or sets a value indicating whether the router should evaluate paths between all sides of conencted nodes to find ones with lower overall cost.
GridSize | Gets or sets the size of the pieces of the routing grid.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions Methods

RoutingOptions Methods
[image]

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.SetDefaultMode Method

RoutingOptions.SetDefaultMode Method
[image]

Resets all routing properties to their default values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetDefaultMode ()

Visual Basic [image] Copy Code

Public Sub SetDefaultMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
SetMinSegmentsMode Method
SetQuickMode Method


MindFusion.Diagramming.Wpf.RoutingOptions.SetMinSegmentsMode Method

RoutingOptions.SetMinSegmentsMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetMinSegmentsMode ()

Visual Basic [image] Copy Code

Public Sub SetMinSegmentsMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
SetDefaultMode Method
SetQuickMode Method


MindFusion.Diagramming.Wpf.RoutingOptions.SetQuickMode Method

RoutingOptions.SetQuickMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetQuickMode ()

Visual Basic [image] Copy Code

Public Sub SetQuickMode ()

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
SetDefaultMode Method
SetMinSegmentsMode Method


MindFusion.Diagramming.Wpf.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EvaluateFarPoints | Gets or sets a value indicating whether the router should evaluate paths between all sides of conencted nodes to find ones with lower overall cost.
GridSize | Gets or sets the size of the pieces of the routing grid.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.Anchoring Property

RoutingOptions.Anchoring Property
[image]

Gets or sets a value indicating whether to align link ends to the anchor points of nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

By default, the routing algorithm ignores anchor points. To make it align link ends to the points specified in the AnchorPattern property of nodes, set Anchoring to Keep or Reassign. Keep specifies that the routing algorithm will not change the positions of link end points. You can use Reassign to cause the routing algorithm to choose new end points for a link from the ones specified in the AnchorPattern of its origin and destination nodes.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.CrossingCost Property

RoutingOptions.CrossingCost Property
[image]

Gets or sets a value added to the total cost of a route if it causes a link to cross another link.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public byte CrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingCost As Byte

Property Value

A byte value specifying the crossing cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it crosses another link. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to CrossingCost leads to fewer link intersections. At this time CrossingCost processing is implemented only for links with Shape set to Cascading.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
LengthCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.Wpf.RoutingOptions.Distance Property

RoutingOptions.Distance Property
[image]

Gets a heuristic delegate function that returns the real distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static RouteHeuristics Distance { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Distance As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

Distance is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it. Distance is the default value of the RouteHeuristics property.

Example

The following sample demonstrates how to use this property:

C# [image] Copy Code
diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance;
Visual Basic [image] Copy Code
Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.Distance

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
DistSquare Property
MaxAbs Property


MindFusion.Diagramming.Wpf.RoutingOptions.DistSquare Property

RoutingOptions.DistSquare Property
[image]

Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static RouteHeuristics DistSquare { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DistSquare As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

DistSquare is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target raised to the second power. DistSquare can be assigned to the RouteHeuristics property. By returning larger values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have greater impact on the evaluated routes.That would lead to faster path-finding, but the real cost functions might have less impact and thus the quality of the found routes could be low.

Example

The following sample demonstrates how to use this property:

C# [image] Copy Code
diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare;
Visual Basic [image] Copy Code
Diagram.RoutingOptions.RouteHeuristics = RoutingOptions.DistSquare

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
MaxAbs Property


MindFusion.Diagramming.Wpf.RoutingOptions.DontOptimizeLongRoutes Property

RoutingOptions.DontOptimizeLongRoutes Property
[image]

Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool DontOptimizeLongRoutes { get; set; }

Visual Basic [image] Copy Code

Public Property DontOptimizeLongRoutes As Boolean

Property Value

true to disable route optimization for long links; otherwise, false. The default is false.

Remarks

Segment optimization done on routed links might need much processing time. The control allows disabling that optimization for long links. That would make the found routes have a "staircase" pattern when they run diagonally.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.EndOrientation Property

RoutingOptions.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. EndOrientation specifies what orientation of links' last segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
StartOrientation Property


MindFusion.Diagramming.Wpf.RoutingOptions.EvaluateFarPoints Property

RoutingOptions.EvaluateFarPoints Property
[image]

Gets or sets a value indicating whether the router should evaluate paths between all sides of conencted nodes to find ones with lower overall cost.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EvaluateFarPoints { get; set; }

Visual Basic [image] Copy Code

Public Property EvaluateFarPoints As Boolean

Property Value

true to evaluate more distant pairs of node sides, or false otherwise. The default value is false.

Remarks

By default, GridRouter evaluates paths only between the closest pair of node sides or anchor points, minimizing the total LengthCost but potentially increasing the overall cost when other factors are considered (number of bends, crossings costs, etc). Set this property to true to include longer paths during total cost evaluation. Note that enabling this property will increase processing times.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A float value specifying the size of the pieces of the routing grid. The default is 4.

Remarks

A smaller size of routing grid pieces helps finding more precise paths, however since the number of pieces increases, there would be more time needed to find a path.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public byte LengthCost { get; set; }

Visual Basic [image] Copy Code

Public Property LengthCost As Byte

Property Value

A byte value specifying the length cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each piece of the routing grid it occupies. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to LengthCost leads to generating shorter paths.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
CrossingCost Property
NodeVicinityCost Property
TurnCost Property


MindFusion.Diagramming.Wpf.RoutingOptions.MaxAbs Property

RoutingOptions.MaxAbs Property
[image]

Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static RouteHeuristics MaxAbs { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MaxAbs As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate function. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

MaxAbs is a predefined delegate that assigns to pieces the higher value from the horizontal or vertical -only distances between a piece and the target. MaxAbs can be assigned to the RouteHeuristics property. By returning smaller values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have less impact on the evaluated routes. That might lead to slower path-finding, but the real cost functions would have greater impact and thus the quality of the found routes could be higher.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public byte NodeVicinityCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinityCost As Byte

Property Value

A byte value specifying the node vicinity cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it passes too close to a node. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to NodeVicinityCost makes links avoid passing close to nodes. The size of the buffer area around nodes in which passing links get a penalty cost is set by NodeVicinitySize.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
CrossingCost Property
LengthCost Property
TurnCost Property


MindFusion.Diagramming.Wpf.RoutingOptions.NodeVicinitySize Property

RoutingOptions.NodeVicinitySize Property
[image]

Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeVicinitySize { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinitySize As Double

Property Value

A floag value specifying the size of the buffer area in which passing routes receive a penalty cost. The default is 12.

Remarks

The pieces of the routing grid that are closest to a node have the value of NodeVicinityCost assigned as their cost. The outer pieces of the buffer zone are assigned a portion of NodeVicinityCost proportional to their distance to the node.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.RouteHeuristics Property

RoutingOptions.RouteHeuristics Property
[image]

Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RouteHeuristics RouteHeuristics { get; set; }

Visual Basic [image] Copy Code

Public Property RouteHeuristics As RouteHeuristics

Property Value

A RouteHeuristics delegate used to evaluate the distance from a current routing grid piece to the target one. The default is Distance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by RouteHeuristics. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

There are three predefined heuristic functions that can be assigned to RouteHeuristics: Distance, DistSquare and MaxAbs. All of them assign to pieces heuristic values that are larger for larger distances to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.SmartPolylineEnds Property

RoutingOptions.SmartPolylineEnds Property
[image]

Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SmartPolylineEnds { get; set; }

Visual Basic [image] Copy Code

Public Property SmartPolylineEnds As Boolean

Property Value

true to orient the end segments orthogonally to the node bounds; otherwise, false.

Remarks

This property is valid only for links of style Polyline.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
EndOrientation Property


MindFusion.Diagramming.Wpf.RoutingOptions.StartOrientation Property

RoutingOptions.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
EndOrientation Property


MindFusion.Diagramming.Wpf.RoutingOptions.TriggerRerouting Property

RoutingOptions.TriggerRerouting Property
[image]

Gets or sets a value indicating under what circumstances links are rerouted automatically.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RerouteLinks TriggerRerouting { get; set; }

Visual Basic [image] Copy Code

Public Property TriggerRerouting As RerouteLinks

Property Value

A member of the RerouteLinks enumeration. The default is WhenModified.

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public byte TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Byte

Property Value

A byte value specifying the turn cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

RoutingOptions Members
RoutingOptions Class
MindFusion.Diagramming.Wpf Namespace
CrossingCost Property
LengthCost Property
NodeVicinityCost Property


MindFusion.Diagramming.Wpf.RowEventArgs Class

RowEventArgs Class
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.RowEventArgs

See Also

RowEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RowEventArgs Members

RowEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

The following tables list the members exposed by the RowEventArgs type.

Public Constructors

Name | Description
RowEventArgs | Initializes a new instance of the RowEventArgs class.

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RowEventArgs Constructor

RowEventArgs Constructor
[image]

Initializes a new instance of the RowEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RowEventArgs (
TableNode table,
int rowIndex
)

Visual Basic [image] Copy Code

Public New ( _
table As TableNode, _
rowIndex As Integer _
)

Parameters

table
The TableNode related to the event.
rowIndex

The zero-based index of the table row related to the event.

See Also

RowEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RowEventArgs Properties

RowEventArgs Properties
[image]

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RowEventArgs.RowIndex Property

RowEventArgs.RowIndex Property
[image]

Gets the index of the table row for which the event has been raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RowIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowIndex As Integer

Property Value

An integer value specifying the row's index.

See Also

RowEventArgs Members
RowEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.RowEventArgs.Table Property

RowEventArgs.Table Property
[image]

Get the table for which the event has been raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

RowEventArgs Members
RowEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Class

Ruler Class
Remarks See Also
[image]

The Ruler control provides horizontal and vertical scales that help users measure diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Ruler : ContentControl

Visual Basic [image] Copy Code

Public Class Ruler
Inherits ContentControl

Remarks

To set which Diagram instance is shown in the ruler, add it as a child to the Ruler by placing the <Diagram> tags within the <Ruler> tags in XAML. Note that the Ruler contains an internal ScrollViewer, so you should not add an additional viewer to enable scrolling.

The ruler tracks mouse movements and modifications being performed on an item, and displays markers over the scales indicating the current position in diagram's coordinate system. The colors of these markers can be changed using the PointerColor and ProjectionColor properties.

If EnableGuides is set to true, the ruler allows aligning several items by clicking on a scale and dragging. That displays alignment guides which follow the mouse pointer and move all selected items on their way. If no diagram elements are selected, all items are moved.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Diagramming.Wpf.Ruler

See Also

Ruler Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Members

Ruler Members
Constructors Fields Attached Properties Properties Methods Events
[image]

The Ruler control provides horizontal and vertical scales that help users measure diagram items.

The following tables list the members exposed by the Ruler type.

Public Constructors

Name | Description
Ruler | Initializes a new instance of the Ruler class.

Public Fields

Name | Description
DocumentProperty | Identifies the Document dependency property.
IgnoredItemProperty | Identifies the IgnoredItem attached property.

Public Attached Properties

Name | Description
IgnoredItemProperty | If enabled for a diagram element, the ruler alignment guides will ignore that element.

Public Properties

Name | Description
ContextMenu | Specifies the context menu associated with the ruler.
Document | Gets or sets the Diagram document this ruler is associated with.
EnableGuides | Gets or sets a value indicating whether alignment guides are active.
GuideColor | Gets or sets the color used to paint guides.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleHeight | Gets or sets the height of the horizontal scale.
HorizontalScaleVisible | Specifies whether the horizontal ruler scale is visible.
InchDivisions | Gets or sets the number of minor divisions to show when Unit is set to Inch.
NegatedY | Gets or sets whether the vertical scale should show negated values, simulating that the coordinate system's Y axis grows to the top.
PointerColor | Gets or sets the color used to paint cursor projections.
ProjectionColor | Gets or sets the color of the projections of the active node on the ruler scales.
ProjectRotatedBounds | Gets or sets whether the projection of nodes on ruler's scales rotates with them.
ScaleColor | Gets or sets the color used to paint the color of the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
TextColor | Gets or sets the color used to paint texts in the ruler.
Unit | Gets or sets the measure unit used by the ruler scales.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Specifies whether the vertical ruler scale is visible.
VerticalScaleWidth | Gets or sets the width of the vertical scale.

Public Methods

Name | Description
GetIgnoredItem | Gets the value of the IgnoredItem attached property for an object.
SetIgnoredItem | Sets the value of the IgnoredItem attached property for an object.

Protected Methods

Name | Description
OnMouseMove | Control.OnMouseMove override.
OnNodesAligned | Raises the NodesAligned event.

Public Events

Name | Description
NodesAligned | Raised when the user aligns nodes using the ruler's alignment guide.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Fields

Ruler Fields
[image]

Public Fields

Name | Description
DocumentProperty | Identifies the Document dependency property.
IgnoredItemProperty | Identifies the IgnoredItem attached property.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.DocumentProperty Field

Ruler.DocumentProperty Field
[image]

Identifies the Document dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty DocumentProperty

Visual Basic [image] Copy Code

Public Shared DocumentProperty As DependencyProperty

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.IgnoredItemProperty Field

Ruler.IgnoredItemProperty Field
[image]

Identifies the IgnoredItem attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IgnoredItemProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IgnoredItemProperty As DependencyProperty

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Constructor

Ruler Constructor
[image]

Initializes a new instance of the Ruler class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Ruler ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Methods

Ruler Methods
[image]

Public Methods

Name | Description
GetIgnoredItem | Gets the value of the IgnoredItem attached property for an object.
SetIgnoredItem | Sets the value of the IgnoredItem attached property for an object.

Protected Methods

Name | Description
OnMouseMove | Control.OnMouseMove override.
OnNodesAligned | Raises the NodesAligned event.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.GetIgnoredItem Method

Ruler.GetIgnoredItem Method
[image]

Gets the value of the IgnoredItem attached property for an object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool GetIgnoredItem (
UIElement element
)

Visual Basic [image] Copy Code

Public Shared Function GetIgnoredItem( _
element As UIElement _
) As Boolean

Parameters

element

The diagram element from which the property value is read.

Return Value

true if the alignment guides ignore the element, otherwise false.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.OnMouseMove Method

Ruler.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.OnNodesAligned Method

Ruler.OnNodesAligned Method
[image]

Raises the NodesAligned event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void OnNodesAligned (
NodesAlignedEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnNodesAligned( _
e As NodesAlignedEventArgs _
)

Parameters

e
An NodesAlignedEventArgs that contains the event data.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.SetIgnoredItem Method

Ruler.SetIgnoredItem Method
[image]

Sets the value of the IgnoredItem attached property for an object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetIgnoredItem (
UIElement element,
bool value
)

Visual Basic [image] Copy Code

Public Shared Sub SetIgnoredItem( _
element As UIElement, _
value As Boolean _
)

Parameters

element

A diagram element that should be ignored by the ruler alignment guides.

value
true to ignore the element, otherwise false.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Attached Properties

Ruler Attached Properties
[image]

Public Attached Properties

Name | Description
IgnoredItemProperty | If enabled for a diagram element, the ruler alignment guides will ignore that element.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.IgnoredItem Attached Property

Ruler.IgnoredItem Attached Property
[image]

If enabled for a diagram element, the ruler alignment guides will ignore that element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code
See Ruler.GetIgnoredItem, Ruler.SetIgnoredItem
Visual Basic [image] Copy Code
See Ruler.GetIgnoredItem, Ruler.SetIgnoredItem

Property Value

true to ignore a diagram element, otherwise false. The default value is false.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Properties

Ruler Properties
[image]

Public Properties

Name | Description
ContextMenu | Specifies the context menu associated with the ruler.
Document | Gets or sets the Diagram document this ruler is associated with.
EnableGuides | Gets or sets a value indicating whether alignment guides are active.
GuideColor | Gets or sets the color used to paint guides.
HorizontalScaleAlignment | Gets or sets the alignment of the horizontal scale.
HorizontalScaleHeight | Gets or sets the height of the horizontal scale.
HorizontalScaleVisible | Specifies whether the horizontal ruler scale is visible.
InchDivisions | Gets or sets the number of minor divisions to show when Unit is set to Inch.
NegatedY | Gets or sets whether the vertical scale should show negated values, simulating that the coordinate system's Y axis grows to the top.
PointerColor | Gets or sets the color used to paint cursor projections.
ProjectionColor | Gets or sets the color of the projections of the active node on the ruler scales.
ProjectRotatedBounds | Gets or sets whether the projection of nodes on ruler's scales rotates with them.
ScaleColor | Gets or sets the color used to paint the color of the ruler scales.
ShowIcon | Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.
TextColor | Gets or sets the color used to paint texts in the ruler.
Unit | Gets or sets the measure unit used by the ruler scales.
VerticalScaleAlignment | Gets or sets the alignment of the vertical scale.
VerticalScaleVisible | Specifies whether the vertical ruler scale is visible.
VerticalScaleWidth | Gets or sets the width of the vertical scale.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.ContextMenu Property

Ruler.ContextMenu Property
[image]

Specifies the context menu associated with the ruler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new ContextMenu ContextMenu { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property ContextMenu As ContextMenu

Property Value

A WPF ContextMenu instance.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.Document Property

Ruler.Document Property
[image]

Gets or sets the Diagram document this ruler is associated with.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As Diagram

Property Value

An instance of the Diagram class contained within the ruler.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.EnableGuides Property

Ruler.EnableGuides Property
[image]

Gets or sets a value indicating whether alignment guides are active.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableGuides { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGuides As Boolean

Property Value

true to allow aligning diagram items using ruler guides; otherwise, false. The default is true.

Remarks

If alignment guides are enabled, users can start aligning items by pressing the left mouse button over a scale and dragging. The horizontal scale displays vertical guide lines that allow aligning the left or right sides of items. The vertical scale displays horizontal guide lines that allow aligning the top or bottom sides of items.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace
GuideColor Property
NodesAligned Event


MindFusion.Diagramming.Wpf.Ruler.GuideColor Property

Ruler.GuideColor Property
[image]

Gets or sets the color used to paint guides.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color GuideColor { get; set; }

Visual Basic [image] Copy Code

Public Property GuideColor As Color

Property Value

A WPF Color instance specifying the color of the guide lines. The default is SystemColors.ControlTextColor.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace
EnableGuides Property


MindFusion.Diagramming.Wpf.Ruler.HorizontalScaleAlignment Property

Ruler.HorizontalScaleAlignment Property
[image]

Gets or sets the alignment of the horizontal scale.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Alignment HorizontalScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration. The default value is Near.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace
VerticalScaleAlignment Property


MindFusion.Diagramming.Wpf.Ruler.HorizontalScaleHeight Property

Ruler.HorizontalScaleHeight Property
[image]

Gets or sets the height of the horizontal scale.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int HorizontalScaleHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScaleHeight As Integer

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.HorizontalScaleVisible Property

Ruler.HorizontalScaleVisible Property
[image]

Specifies whether the horizontal ruler scale is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Visibility HorizontalScaleVisible { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScaleVisible As Visibility

Property Value

true to display the horizontal scale; otherwise, false. The default is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.InchDivisions Property

Ruler.InchDivisions Property
[image]

Gets or sets the number of minor divisions to show when Unit is set to Inch.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int InchDivisions { get; set; }

Visual Basic [image] Copy Code

Public Property InchDivisions As Integer

Property Value

An integer value specifying the number of divisions. The default value is 8.

Remarks

There are exactly the specified number of divisions shown in an inch only at 100% zoom level. When the diagram is zoomed in or out, the ruler could add or remove unit ticks.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.NegatedY Property

Ruler.NegatedY Property
[image]

Gets or sets whether the vertical scale should show negated values, simulating that the coordinate system's Y axis grows to the top.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NegatedY { get; set; }

Visual Basic [image] Copy Code

Public Property NegatedY As Boolean

Property Value

true if the vertical ruler scale should show negated coordinates, otherwise false. The default value is false.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.PointerColor Property

Ruler.PointerColor Property
[image]

Gets or sets the color used to paint cursor projections.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color PointerColor { get; set; }

Visual Basic [image] Copy Code

Public Property PointerColor As Color

Property Value

A WPF Color instance specifying the color of the pointer projection lines. The default is Colors.Red.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.ProjectionColor Property

Ruler.ProjectionColor Property
[image]

Gets or sets the color of the projections of the active node on the ruler scales.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color ProjectionColor { get; set; }

Visual Basic [image] Copy Code

Public Property ProjectionColor As Color

Property Value

A WPF Color instance specifying the color of the selected node's projection on the scales. The default is Colors.LightSteelBlue.

Remarks

The active node is a DiagramNode instance which is the current diagram's ActiveItem.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.ProjectRotatedBounds Property

Ruler.ProjectRotatedBounds Property
[image]

Gets or sets whether the projection of nodes on ruler's scales rotates with them.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ProjectRotatedBounds { get; set; }

Visual Basic [image] Copy Code

Public Property ProjectRotatedBounds As Boolean

Property Value

true if node's projection should match the boundaries of rotated node shape, or false to ignore rotation and project only the coordinates of node's Bounds. The default value is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.ScaleColor Property

Ruler.ScaleColor Property
[image]

Gets or sets the color used to paint the color of the ruler scales.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color ScaleColor { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleColor As Color

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.ShowIcon Property

Ruler.ShowIcon Property
[image]

Gets or sets a value indicating whether to show the icon between the horizontal and vertical scales.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowIcon { get; set; }

Visual Basic [image] Copy Code

Public Property ShowIcon As Boolean

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.TextColor Property

Ruler.TextColor Property
[image]

Gets or sets the color used to paint texts in the ruler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color TextColor { get; set; }

Visual Basic [image] Copy Code

Public Property TextColor As Color

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.Unit Property

Ruler.Unit Property
[image]

Gets or sets the measure unit used by the ruler scales.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RulerUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As RulerUnit

Property Value

A member of the RulerUnit enumeration specifying what units are displayed in the scales. The default is Millimeter.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.VerticalScaleAlignment Property

Ruler.VerticalScaleAlignment Property
[image]

Gets or sets the alignment of the vertical scale.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Alignment VerticalScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration. The default value is Near.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace
HorizontalScaleAlignment Property


MindFusion.Diagramming.Wpf.Ruler.VerticalScaleVisible Property

Ruler.VerticalScaleVisible Property
[image]

Specifies whether the vertical ruler scale is visible.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Visibility VerticalScaleVisible { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScaleVisible As Visibility

Property Value

true to display the vertical scale; otherwise, false. The default is true.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.VerticalScaleWidth Property

Ruler.VerticalScaleWidth Property
[image]

Gets or sets the width of the vertical scale.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int VerticalScaleWidth { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScaleWidth As Integer

Property Value

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler Events

Ruler Events
[image]

Public Events

Name | Description
NodesAligned | Raised when the user aligns nodes using the ruler's alignment guide.

See Also

Ruler Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Ruler.NodesAligned Event

Ruler.NodesAligned Event
[image]

Raised when the user aligns nodes using the ruler's alignment guide.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NodesAlignedEventArgs> NodesAligned

Visual Basic [image] Copy Code

Public Event NodesAligned As EventHandler(Of NodesAlignedEventArgs)

Event Data

NodesAligned event handlers receive an argument of type NodesAlignedEventArgs.

See Also

Ruler Members
Ruler Class
MindFusion.Diagramming.Wpf Namespace
EnableGuides Property


MindFusion.Diagramming.Wpf.RulerUnit Enumeration

RulerUnit Enumeration
[image]

Specifies a measurement unit for the Ruler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum RulerUnit

Visual Basic [image] Copy Code

Public Enum RulerUnit

Members

Member name | Description
Inch | Indicates an inch.
Millimeter | Indicates a millimeter.
Percent | Indicates percent.
Pixel | Indicates a pixel.
Point | Indicates a point.
WpfPoint | Indicates WPF device-independent pixel.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SaveToStringFormat Enumeration

SaveToStringFormat Enumeration
[image]

Specifies in what format to save the diagram when generating a string using the SaveToString method.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SaveToStringFormat

Visual Basic [image] Copy Code

Public Enum SaveToStringFormat

Members

Member name | Description
CompressedXml | Indicates a compressed XML output.
Xml | Indicates a non-compressed XML output.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScaleMode Enumeration

ScaleMode Enumeration
[image]

Defines Overview scaling modes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ScaleMode

Visual Basic [image] Copy Code

Public Enum ScaleMode

Members

Member name | Description
CombinedScales | Combine diagram's ZoomFactor with overview's ScaleFactor.
FitAll | Scale the Overview dynamically to fit the entire diagram.
FixedScale | Use fixed scale specified via ScaleFactor, ignoring diagram's zoom level.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScalingMode Enumeration

ScalingMode Enumeration
[image]

Specifies whether 3D models of links should scale when the camera zooms in or out.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ScalingMode

Visual Basic [image] Copy Code

Public Enum ScalingMode

Members

Member name | Description
None | Do not scale models.
Scale | Specifies that link models should scale.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper Class

ScriptHelper Class
[image]

Allows calling some static MindFusion.Diagramming for WPF methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ScriptHelper

Visual Basic [image] Copy Code

Public Class ScriptHelper

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ScriptHelper

See Also

ScriptHelper Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper Members

ScriptHelper Members
Constructors Methods
[image]

Allows calling some static MindFusion.Diagramming for WPF methods from JavaScript and VBScript. It seems the script languages do not allow calling class static methods, so a ScriptHelper instance property is provided by the Diagram class.

The following tables list the members exposed by the ScriptHelper type.

Public Constructors

Name | Description
ScriptHelper | Initializes a new instance of the ScriptHelper class.

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MindFusion.Diagramming for WPF object given its class name.
CreateSolidColorBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper Constructor

ScriptHelper Constructor
[image]

Initializes a new instance of the ScriptHelper class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScriptHelper (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram the helper methods will work on.

See Also

ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper Methods

ScriptHelper Methods
[image]

Public Methods

Name | Description
ApplyLayout | Applies the specified layout to the underlying diagram.
CreateObject | Creates a MindFusion.Diagramming for WPF object given its class name.
CreateSolidColorBrush | Creates a solid brush with the specified color components.
NodesIntersect | Calculates whether the specified nodes' outlines intersect.
ShapeTemplateFromId | Returns the Shape having the specified identifier.

See Also

ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper.ApplyLayout Method

ScriptHelper.ApplyLayout Method
[image]

Applies the specified layout to the underlying diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ApplyLayout (
Object layout
)

Visual Basic [image] Copy Code

Public Sub ApplyLayout( _
layout As Object _
)

Parameters

layout

An instance of one of the layout classes that represents the layout to perform on the underlying diagram.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper.CreateObject Method

ScriptHelper.CreateObject Method
[image]

Creates a MindFusion.Diagramming for WPF object given its class name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object CreateObject (
string className
)

Visual Basic [image] Copy Code

Public Function CreateObject( _
className As String _
) As Object

Parameters

className

The class name of the object to create.

Return Value

A reference to the MindFusion.Diagramming for WPF object of the specified class.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper.CreateSolidColorBrush Method

ScriptHelper.CreateSolidColorBrush Method
[image]

Creates a solid brush with the specified color components.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CreateSolidColorBrush (
int alpha,
int red,
int green,
int blue
)

Visual Basic [image] Copy Code

Public Function CreateSolidColorBrush( _
alpha As Integer, _
red As Integer, _
green As Integer, _
blue As Integer _
) As Brush

Parameters

alpha

The alpha factor of the solid brush color.

red

The red component of the solid brush color.

green

The green component of the solid brush color.

blue

The blue component of the solid brush color.

Return Value

An instance of the System.Windows.Media that represents the newly created brush.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper.NodesIntersect Method

ScriptHelper.NodesIntersect Method
[image]

Calculates whether the specified nodes' outlines intersect.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool NodesIntersect (
DiagramNode n1,
DiagramNode n2
)

Visual Basic [image] Copy Code

Public Function NodesIntersect( _
n1 As DiagramNode, _
n2 As DiagramNode _
) As Boolean

Parameters

n1
The first DiagramNode to check.
n2
The second DiagramNode to check.

Return Value

true if the outlines of the specified nodes intersect; otherwise, false.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ScriptHelper.ShapeTemplateFromId Method

ScriptHelper.ShapeTemplateFromId Method
[image]

Returns the Shape having the specified identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape ShapeTemplateFromId (
string shapeId
)

Visual Basic [image] Copy Code

Public Function ShapeTemplateFromId( _
shapeId As String _
) As Shape

Parameters

shapeId

The id of the shape to create.

Return Value

An instance of the Shape class.

See Also

ScriptHelper Members
ScriptHelper Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection Class

Selection Class
Remarks See Also
[image]

Represents a set of items selected in the diagram document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Selection : DiagramItem

Visual Basic [image] Copy Code

Public Class Selection
Inherits DiagramItem

Remarks

In a diagram document several items can be selected simultaneously. If more than one item is selected, the compound set of selected items is handled by an instance of the Selection class.

Items in the selection can be of any element type. The Items property gives a collection of all the items in the selection. You can get type-safe access to items of specific class by the Links and Nodes collections properties.

Users can select multiple items by drawing a selection rectangle. Depending on the Diagram's Behavior, this is done either by simply dragging the mouse, or by holding CTRL down while dragging the mouse. Depending on the IncludeItemsIfIntersect value, items are selected if they are entirely inside the drawn selection rectangle, or if at least a part of them is inside the rectangle. It is possible to prevent users from selecting more than one items at the same time by setting AllowMultipleSelection to false.

Items can be always added or removed programmatically to selection by the AddItem method and RemoveItem method. Selection state of an item can be toggled, getting deselected from selected and vice versa, by the Toggle method. All items in the selection are deselected if Clear is invoked.

Use the Selected property of the DiagramItem class to determine whether a particular item is selected. The Selection's GetSize method returns how many items are selected. Bounds returns the rectangle that bounds all selected items.

The visual style of multiple-selection is defined by the Style property. For example selection might be painted as a dashed rectangle or a semi-transparent filled rectangle.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.Selection

See Also

Selection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection Members

Selection Members
Fields Properties Methods
[image]

Represents a set of items selected in the diagram document.

The following tables list the members exposed by the Selection type.

Public Fields

Name | Description
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
ExtendMode | Gets or sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
FreeFormMode | Gets or sets a value indicating whether selection lasso should be drawn in free-form mode.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
KeepInsideDiagram | Gets or sets whether the selection should be constrained by diagram boundaries when moving multiple items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetRegion | Returns a Geometry object representing the shape of this item. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
Repaint | Overloaded. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | Applies specified function on properties intended to be set from WPF styles. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or performing undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo. (Inherited from DiagramItem.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes. (Inherited from DiagramItem.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded.
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetRegion | Returns a Geometry object representing the shape of this item. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
GetToolTip | Gets the tooltip that should be displayed for this item at the specified point. (Inherited from DiagramItem.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
HitTestManipulators | Triggers the manipulator located at the specified point. (Inherited from DiagramItem.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
Repaint | Overloaded. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override.
AllowModify | DiagramItem.AllowModify override.
CompleteCreate | DiagramItem.CompleteCreate override.
CompleteModify | DiagramItem.CompleteModify override.
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | Applies specified function on properties intended to be set from WPF styles. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or performing undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or while performing undo / redo. (Inherited from DiagramItem.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes. (Inherited from DiagramItem.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
StartCreate | DiagramItem.StartCreate override.
StartModify | DiagramItem.StartModify override.
UpdateCreate | DiagramItem.UpdateCreate override.
UpdateModify | DiagramItem.UpdateModify override.

See Also

Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.AddItem Method

Selection.AddItem Method
[image]

Adds a new item to the current selection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AddItem (
UIElement item
)

Visual Basic [image] Copy Code

Public Sub AddItem( _
item As UIElement _
)

Parameters

item
The DiagramItem to be added to the selection.

Remarks

This method adds a new item to the selection. It also deactivates the ActiveItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Change Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Wpf.Selection.AllowCreate Method

Selection.AllowCreate Method
[image]

DiagramItem.AllowCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowCreate (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowCreate( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

ist

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.AllowModify Method

Selection.AllowModify Method
[image]

DiagramItem.AllowModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowModify( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

ist

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Change Method

Selection.Change Method
[image]

Selects an item and deselects all others.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Change (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Change( _
item As DiagramItem _
)

Parameters

item
The DiagramItem which should be made active.

Remarks

Call this method to select an item and make it the ActiveItem. The method doesn't let you select locked items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
AddItem Method
RemoveItem Method
Clear Method


MindFusion.Diagramming.Wpf.Selection.Clear Method

Selection.Clear Method
[image]

Removes all items from the selection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to deselect all items. The items are not deleted. The method also sets the diagram's ActiveItem to null (Nothing in Visual Basic).

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Wpf.Selection.CompleteCreate Method

Selection.CompleteCreate Method
[image]

DiagramItem.CompleteCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteCreate (
Point end
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteCreate( _
end As Point _
)

Parameters

end

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.CompleteModify Method

Selection.CompleteModify Method
[image]

DiagramItem.CompleteModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteModify (
Point end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteModify( _
end As Point, _
ist As InteractionState _
)

Parameters

end

ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.ContainsPoint Method

Selection.ContainsPoint Method
[image]

Overload List

Name | Description
Selection.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
Selection.ContainsPoint (Point, Double) | DiagramItem.ContainsPoint override.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.ContainsPoint Method (Point)

Selection.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.ContainsPoint Method (Point, Double)

Selection.ContainsPoint Method (Point, Double)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

threshold

Return Value

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Draw Method

Selection.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A DrawingContext object
options
Provides options for the drawing operation.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.DrawHandles Method

Selection.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.FreeResources Method

Selection.FreeResources Method
[image]

DiagramItem.FreeResources override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void FreeResources ()

Visual Basic [image] Copy Code

Protected Overrides Sub FreeResources ()

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.GetRepaintRect Method

Selection.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool connected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
connected As Boolean _
) As Rect

Parameters

connected

Return Value

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.GetSize Method

Selection.GetSize Method
[image]

Gets the number of selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetSize ()

Visual Basic [image] Copy Code

Public Function GetSize () As Integer

Return Value

An integer value indicating the size of the collection.

Remarks

Call this method to get the number of selected items, including both nodes and links.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Items Property


MindFusion.Diagramming.Wpf.Selection.HitTestHandle Method

Selection.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.RemoveItem Method

Selection.RemoveItem Method
[image]

Removes an item from the selection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RemoveItem (
UIElement item
)

Visual Basic [image] Copy Code

Public Function RemoveItem( _
item As UIElement _
) As Boolean

Parameters

item
The DiagramItem to be removed from the selection.

Return Value

true if the item has been successfully removed; otherwise, false.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
AddItem Method


MindFusion.Diagramming.Wpf.Selection.StartCreate Method

Selection.StartCreate Method
[image]

DiagramItem.StartCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartCreate (
Point org
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartCreate( _
org As Point _
)

Parameters

org

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.StartModify Method

Selection.StartModify Method
[image]

DiagramItem.StartModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

handle

ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Toggle Method

Selection.Toggle Method
[image]

Toggles the selection state of an item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Toggle (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Toggle( _
item As DiagramItem _
)

Parameters

item
The DiagramItem whose selection state should be changed.

Remarks

Call this method to toggle an item's selection state. The method selects the diagram item passed as argument if previously it was deselected. If the item was selected, the method deselects it.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Change Method
AddItem Method
RemoveItem Method


MindFusion.Diagramming.Wpf.Selection.UpdateCreate Method

Selection.UpdateCreate Method
[image]

DiagramItem.UpdateCreate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateCreate (
Point current
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateCreate( _
current As Point _
)

Parameters

current

Position of the mouse pointer.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.UpdateModify Method

Selection.UpdateModify Method
[image]

DiagramItem.UpdateModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

ist

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
ExtendMode | Gets or sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
FreeFormMode | Gets or sets a value indicating whether selection lasso should be drawn in free-form mode.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
KeepInsideDiagram | Gets or sets whether the selection should be constrained by diagram boundaries when moving multiple items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)

See Also

Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.AllowMultipleSelection Property

Selection.AllowMultipleSelection Property
[image]

Gets or sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowMultipleSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleSelection As Boolean

Property Value

Remarks

The property controls whether multiple items can be selected interactively. If it is disabled, multiple items can still be selected programmatically.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Bounds Property

Selection.Bounds Property
[image]

Gets the rectangle that bounds all selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the System.Windows.Rect structure.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.ExtendMode Property

Selection.ExtendMode Property
[image]

Gets or sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ExtendMode { get; set; }

Visual Basic [image] Copy Code

Public Property ExtendMode As Boolean

Property Value

false to deselect items located out of newly drawn lasso rectangle, or true to keep them selected. The default value is false.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.FreeFormMode Property

Selection.FreeFormMode Property
[image]

Gets or sets a value indicating whether selection lasso should be drawn in free-form mode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool FreeFormMode { get; set; }

Visual Basic [image] Copy Code

Public Property FreeFormMode As Boolean

Property Value

true to let users draw selection lasso in free-form mode, or false to draw selection rectangle. The default value is false.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.IncludeItemsIfIntersect Property

Selection.IncludeItemsIfIntersect Property
[image]

Gets or sets a value indicating which items are selected when drawing a selection rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IncludeItemsIfIntersect { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeItemsIfIntersect As Boolean

Property Value

true to select items that intersect the drawn selection rectangle; false to select items only if they are entirely inside the selection rectangle. The default is true.

Remarks

The value of this property is considered when users draw a selection rectangle using a pointing device. By default, all items inside the drawn rectangle and the ones that are only partially inside it are selected. Set the property to false to let users select items only when the items are entirely inside the selection rectangle.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Items Property

Selection.Items Property
[image]

Gets a collection of all selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class that represents the selected diagram items.

Remarks

You can select items programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Nodes Property
Links Property


MindFusion.Diagramming.Wpf.Selection.KeepInsideDiagram Property

Selection.KeepInsideDiagram Property
[image]

Gets or sets whether the selection should be constrained by diagram boundaries when moving multiple items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepInsideDiagram { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideDiagram As Boolean

Property Value

true to keep items inside diagram boundaries, or false otherwise.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Links Property

Selection.Links Property
[image]

Gets the collection of all links in the selection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class that represents the selected diagram items.

Remarks

You can select links programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Items Property
Nodes Property


MindFusion.Diagramming.Wpf.Selection.Nodes Property

Selection.Nodes Property
[image]

Gets a collection of all selected nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class that represents the nodes in the selection.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace
Items Property
Links Property


MindFusion.Diagramming.Wpf.Selection.SetsDirtyFlag Property

Selection.SetsDirtyFlag Property
[image]

Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SetsDirtyFlag { get; set; }

Visual Basic [image] Copy Code

Public Property SetsDirtyFlag As Boolean

Property Value

true to set the flag when selection changes, otherwise false. The default value is true.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Selection.Style Property

Selection.Style Property
[image]

Gets or sets a value indicating how to display multiple selection of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new SelectionStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. The default is SelectionHandles.

Remarks

The property specifies how multiple-selection is presented visually to users - with manipulation handles painted around each item or with a rectangle painted around all items.

See Also

Selection Members
Selection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy Class

SelectionCopy Class
Remarks See Also
[image]

Used internally in the implementation of copy/paste functions.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class SelectionCopy

Visual Basic [image] Copy Code

Public NotInheritable Class SelectionCopy

Remarks

This class supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.SelectionCopy

See Also

SelectionCopy Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy Members

SelectionCopy Members
Constructors Properties
[image]

Used internally in the implementation of copy/paste functions.

The following tables list the members exposed by the SelectionCopy type.

Public Constructors

Name | Description
SelectionCopy | Initializes a new instance of the SelectionCopy class.

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy Constructor

SelectionCopy Constructor
[image]

Initializes a new instance of the SelectionCopy class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SelectionCopy (
DiagramItemCollection items,
DiagramItemCollection originalItems,
GroupCollection groups
)

Visual Basic [image] Copy Code

Public New ( _
items As DiagramItemCollection, _
originalItems As DiagramItemCollection, _
groups As GroupCollection _
)

Parameters

items

A collection containing the item copies.

originalItems

A collection containing the original items.

groups

A collection containing the group copies.

Remarks

This constructor supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy Properties

SelectionCopy Properties
[image]

Public Properties

Name | Description
Groups | Gets the underlying collection of groups.
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy.Groups Property

SelectionCopy.Groups Property
[image]

Gets the underlying collection of groups.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GroupCollection Groups { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Groups As GroupCollection

Property Value

An instance of the GroupCollection class.

Remarks

This property supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy.Items Property

SelectionCopy.Items Property
[image]

Gets the underlying collection of items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionCopy.OriginalItems Property

SelectionCopy.OriginalItems Property
[image]

Gets a collection of the original items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItemCollection OriginalItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OriginalItems As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs Class

SelectionEventArgs Class
[image]

Contains the arguments passed to the SelectionModified event handler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SelectionEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SelectionEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.SelectionEventArgs
MindFusion.Diagramming.Wpf.SelectionValidationEventArgs

See Also

SelectionEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs Members

SelectionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SelectionModified event handler.

The following tables list the members exposed by the SelectionEventArgs type.

Public Constructors

Name | Description
SelectionEventArgs | Initializes a new instance of the SelectionEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
MousePosition | Gets the current mouse pointer position.

See Also

SelectionEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs Constructor

SelectionEventArgs Constructor
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SelectionEventArgs (
Point mousePosition,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

mousePosition

adjustmentHandle

See Also

SelectionEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs Properties

SelectionEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
MousePosition | Gets the current mouse pointer position.

See Also

SelectionEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs.AdjustmentHandle Property

SelectionEventArgs.AdjustmentHandle Property
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandle

Property Value

An instance of the AdjustmentHandle class representing the handle modified by user.

See Also

SelectionEventArgs Members
SelectionEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionEventArgs.MousePosition Property

SelectionEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

See Also

SelectionEventArgs Members
SelectionEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionStyle Enumeration

SelectionStyle Enumeration
[image]

Defines values that specify how multiple selected items are indicated visually.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SelectionStyle

Visual Basic [image] Copy Code

Public Enum SelectionStyle

Members

Member name | Description
Frame | A dashed rectangle is drawn around selected items.
SelectionHandles | Rectangular manipulation handles are painted over selected items.

Remarks

These values affect multiple-selection of items. If only a single item is selected, it is drawn with manipulation handles around it.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs Class

SelectionValidationEventArgs Class
[image]

Contains the arguments passed to the SelectionModifying event handler.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SelectionValidationEventArgs : SelectionEventArgs

Visual Basic [image] Copy Code

Public Class SelectionValidationEventArgs
Inherits SelectionEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.SelectionEventArgs
MindFusion.Diagramming.Wpf.SelectionValidationEventArgs

See Also

SelectionValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs Members

SelectionValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to the SelectionModifying event handler.

The following tables list the members exposed by the SelectionValidationEventArgs type.

Public Constructors

Name | Description
SelectionValidationEventArgs | Initializes a new instance of the SelectionValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
MousePosition | Gets the current mouse pointer position. (Inherited from SelectionEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs Constructor

SelectionValidationEventArgs Constructor
[image]

Initializes a new instance of the SelectionValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SelectionValidationEventArgs (
Point mousePosition,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
mousePosition As Point, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

mousePosition

adjustmentHandle

See Also

SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs Methods

SelectionValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs.CancelDrag Method

SelectionValidationEventArgs.CancelDrag Method
[image]

Cancels the modification of the selected items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs Properties

SelectionValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
MousePosition | Gets the current mouse pointer position. (Inherited from SelectionEventArgs.)

See Also

SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SelectionValidationEventArgs.Cancel Property

SelectionValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializationOptions Class

SerializationOptions Class
[image]

Allows customization of some aspects of the binary serialization of MindFusion.Diagramming for WPF diagrams.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SerializationOptions

Visual Basic [image] Copy Code

Public Class SerializationOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.SerializationOptions

See Also

SerializationOptions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializationOptions Members

SerializationOptions Members
Properties
[image]

Allows customization of some aspects of the binary serialization of MindFusion.Diagramming for WPF diagrams.

The following tables list the members exposed by the SerializationOptions type.

Public Properties

Name | Description
Base64StringEncoding | Specifies whether the SaveToString method should encode the binary stream into a base64 string or into a hexadecimal one.

See Also

SerializationOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializationOptions Properties

SerializationOptions Properties
[image]

Public Properties

Name | Description
Base64StringEncoding | Specifies whether the SaveToString method should encode the binary stream into a base64 string or into a hexadecimal one.

See Also

SerializationOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializationOptions.Base64StringEncoding Property

SerializationOptions.Base64StringEncoding Property
[image]

Specifies whether the SaveToString method should encode the binary stream into a base64 string or into a hexadecimal one.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Base64StringEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property Base64StringEncoding As Boolean

Property Value

See Also

SerializationOptions Members
SerializationOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the string representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets or sets an XmlElement object where the tag should be serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the string representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

An instance of the XmlPersistContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if you have serialized/deserialized the tag object; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets or sets an XmlElement object where the tag should be serialized/deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

A diagram item, group, cell or anchor point.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.PropertyName Property

SerializeTagEventArgs.PropertyName Property
[image]

Gets the name of the property being serialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

Either "Id" or "Tag", indicating which property is being serialized.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the tag object being serialized / deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XmlElement

Property Value

An instance of the System.XML.XmlElement class that represents the root of the XML branch where the tag is / should be stored.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object containing the custom tag data.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShadowsStyle Enumeration

ShadowsStyle Enumeration
[image]

Enumerates possible shadows-drawing styles.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ShadowsStyle

Visual Basic [image] Copy Code

Public Enum ShadowsStyle

Members

Member name | Description
None | No shadows are drawn.
OneLevel | All shadows are drawn at the lowest z-level, and appear to be on one level.
ZOrder | Every shadows is drawn just below its object, possibly covering other objects.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Class

Shape Class
Remarks See Also
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. Such shapes can be assigned to ShapeNode ojects or used as link arrowheads. The shape segments can be a part of the outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Shape : ICloneable

Visual Basic [image] Copy Code

Public Class Shape
Implements ICloneable

Remarks

Shape Definitions

The Shape class provides the means for defining complex node shapes. With its help you can design any shape composed of lines, arcs and Bezier-curves. A shape template must always contain an outline to be used for hit testing, clipping and finding intersections with other items. Optionally shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in clipping, and are used for hit-testing only if DecorationHitTesting is enabled. Text regions are the parts of shapes in which node's text is laid out and rendered.

Predefined Shapes

MindFusion.Diagramming for WPF provides a set of about 100 predefined shape templates accessible through the static Shapes collection and the FromId method of Shape. A shape template can be applied to a node by assigning it to the Shape property of shape nodes. The predefined shapes are also exposed as properties of the Shapes class.

Custom Shapes

There are several Shape constructor overrides you might choose from, depending on the complexity of the shapes you want to create. They take arrays of ElementTemplate objects as arguments, which define the outline, decorations and text region definitions. Templates are described with coordinates expressed as percents of a shape node's area. It is also possible to associate an image with a shape definition through the Image property and to define the area in which the image is displayed by ImageRectangle.

Dynamic Shapes

Shapes defined via ElementTemplate objects are scaled proportionally to the size of nodes. If shape elements should scale non-uniformly, use the Shape(formula) constructor to define shapes through Visio-like formulas that take into consideration the current width and height of nodes. Another constructor takes a CreatePathDelegate parameter that can be used to define shapes via .NET functions.

A formula shape can be parameterized by adding ShapeControlPoint objects to the shape's ControlPoints collection. The control point positions are passed as arguments to the shape scripts, where they can be used to modify the node's appearance. For example, the following code defines a rounded rectangle shape, whose corner radius can be modified by users via the control point.

C# [image] Copy Code

// a rounded rectangle shape, with an arc at each corner
string roundRect = @"
r = Min(Width / 2, radius.X);
MoveTo(r, 0);
LineTo(Width - r, 0);
ArcTo(Width, r, false, true, r, r);
LineTo(Width, Height - r);
ArcTo(Width - r, Height, false, true, r, r);
LineTo(r, Height);
ArcTo(0, Height - r, false, true, r, r);
LineTo(0, r);
ArcTo(r, 0, false, true, r, r);
";

var myRect = new Shape(roundRect, "MyRect");

// add a control point for the 'radius' parameter
myRect.ControlPoints.Add(new ShapeControlPoint(
"radius", 15, 5, 45, UnitType.Fixed, 0, 0, 0, UnitType.Fixed));

Shape Libraries

The ShapeDesigner tool included in the MindFusion.Diagramming for WPF suite lets you draw custom shapes and store them in shape libraries. A library file can be loaded into your application using the ShapeLibrary class. The definitions loaded from a shape library are automatically added to the Shapes collection and can be accessed through the FromId method, just as the predefined shapes.

Link Arrowheads

A Shape instance can be assigned to the HeadShape, BaseShape or IntermediateShape properties of a DiagramLink. When used for arrowheads, position (50, 0) in the shape definition corresponds to the arrowhead's tip point. Several predefined arrowhead shapes are provided as static properties of the ArrowHeads class.

Example

Here is how the DirectAccessStorage shape is defined in the MindFusion.Diagramming for WPF source code:

C# [image] Copy Code

new Shape(

// Outlines
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new ArcTemplate(0, 0, 20, 100, 90, 180)
},

// Decorations
new ElementTemplate[]
{
new ArcTemplate(0, 0, 20, 100, -90, 180)
},

// Text area
new ElementTemplate[]
{
new LineTemplate(10, 0, 90, 0),
new ArcTemplate(80, 0, 20, 100, -90, 180),
new LineTemplate(90, 100, 10, 100),
new BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0)
},

FillRule.EvenOdd, "DirectAccessStorage");

Visual Basic [image] Copy Code
New Shape( _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New ArcTemplate(0, 0, 20, 100, 90, 180) _
}, _
New ElementTemplate() _
{ _
New ArcTemplate(0, 0, 20, 100, -90, 180) _
}, _
New ElementTemplate() _
{ _
New LineTemplate(10, 0, 90, 0), _
New ArcTemplate(80, 0, 20, 100, -90, 180), _
New LineTemplate(90, 100, 10, 100), _
New BezierTemplate(10, 100, 35, 66, 35, 33, 10, 0) _
}, _
FillRule.EvenOdd, "DirectAccessStorage")

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Shape

See Also

Shape Members
MindFusion.Diagramming.Wpf Namespace
ShapeListBox Class


MindFusion.Diagramming.Wpf.Shape Members

Shape Members
Constructors Properties Methods
[image]

An instance of this class represents a shape defined through a series of arc, line and Bezier segments. Such shapes can be assigned to ShapeNode ojects or used as link arrowheads. The shape segments can be a part of the outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Overloaded.

Public Properties

Name | Description
AnchorPattern | Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null (Nothing in Visual Basic).
ControlPoints | A list of ShapeControlPoint objects that let users adjust a node's shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DecorationsFormula | Gets or sets a formula describing the shape decorations depending on the current width and height of the node.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects.
FillRule | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
OutlineFormula | Gets or sets a formula describing the shape outline depending on the current width and height of the node.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Draws this shape on the specified DrawingContext surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor

Shape Constructor
[image]

Overload List

Name | Description
Shape (Byte[]) | Initializes a new instance of the Shape class with the specified outline.
Shape (Byte[], String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (CreatePathDelegate, CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline and decorations callbacks and id.
Shape (CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline formula and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[]) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], FillRule) | Initializes a new instance of the Shape class with the specified outline.
Shape (ElementTemplate[], FillRule, String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (String, String) | Initializes a new instance of the Shape class with the specified outline formula and id.
Shape (String, String, List(ShapeControlPoint), String) | Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.
Shape (String, String, String) | Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

See Also

Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (Byte[])

Shape Constructor (Byte[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
byte[] outline
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (Byte[], String)

Shape Constructor (Byte[], String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
byte[] outline,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte, _
id As String _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

id

The string identifier of the new shape.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

Exceptions

Exception Type | Condition
ArgumentException | The specified array is a null reference (Nothing in Visual Basic), does not contain even number of elements or contains less than six arguments.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations callbacks and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
CreatePathDelegate decorationsDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
decorationsDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate
A delegate called to generate PathGeometry objects representing the shape outline.
decorationsDelegate
A delegate called to generate PathGeometry objects representing the shape decorations.
id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline formula and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate
A delegate called to generate PathGeometry objects representing the shape outline.
id

The string identifier of the new shape.

Example

This example creates a triangular shape:

C# [image] Copy Code
Shape shape = new Shape(CreatePath, "my shape");

PathGeometry CreatePath(ShapeData shapeData)
{
var path = new PathGeometry();
var fig = new PathFigure();
fig.StartPoint = new Point(10, 0);
fig.Segments.Add(new LineSegment(new Point(shapeData.Width, 10), true));
fig.Segments.Add(new LineSegment(new Point(shapeData.Width / 2, shapeData.Height), true));
fig.IsClosed = true;
path.Figures.Add(fig);
return path;
}

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillRule fillRule
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillRule As FillRule _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline path intersects itself.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillRule fillRule,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillRule As FillRule, _
id As String _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[])

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillRule, String, ShapeDecoration[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillRule fillRule,
string id,
ShapeDecoration[] closedDecorations
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillRule As FillRule, _
id As String, _
closedDecorations() As ShapeDecoration _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bézier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bézier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillRule

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

closedDecorations
An array of ShapeDecoration objects.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (ElementTemplate[], FillRule)

Shape Constructor (ElementTemplate[], FillRule)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillRule fillRule
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillRule As FillRule _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

fillRule

Specifies how areas are filled if the outline path intersects itself.

Example

C# [image] Copy Code
diagram.DefaultShape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 35, 0),
new LineTemplate(35, 0, 100, 0),
new LineTemplate(100, 0, 65, 100),
new LineTemplate(65, 100, 0, 100) },
FillRule.EvenOdd);
Visual Basic [image] Copy Code
diagram.DefaultShape = new Shape( _
new ElementTemplate() { _
new LineTemplate(0, 100, 35, 0), _
new LineTemplate(35, 0, 100, 0), _
new LineTemplate(100, 0, 65, 100), _
new LineTemplate(65, 100, 0, 100) }, _
FillRule.EvenOdd)

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (ElementTemplate[], FillRule, String)

Shape Constructor (ElementTemplate[], FillRule, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillRule fillRule,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillRule As FillRule, _
id As String _
)

Parameters

elements

Refers to an array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bézier curves.

fillRule

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (String, String)

Shape Constructor (String, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline formula and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
id As String _
)

Parameters

outlineFormula

A string containing the formula that defines the shape outline.

id

The string identifier of the new shape.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

Example

This sample creates an arrow shape with fixed shaft width and arrowhead length, which will still shrink when the node gets small due to the Min calls.

C# [image] Copy Code
string outline = @"
my = Height / 2;
ah = Min(20, Height / 4);
aw = Min(40, Width / 2);
MoveTo(0, my - ah);
LineTo(Width - aw, my - ah);
LineTo(Width - aw, 0);
LineTo(Width, my);
LineTo(Width - aw, Height);
LineTo(Width - aw, my + ah);
LineTo(0, my + ah);
";
Shape shape = new Shape(outline, "my shape");

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace
OutlineFormula Property


MindFusion.Diagramming.Wpf.Shape Constructor (String, String, List(ShapeControlPoint), String)

Shape Constructor (String, String, List(ShapeControlPoint), String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string decorationsFormula,
List<ShapeControlPoint> controlPoints,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
decorationsFormula As String, _
controlPoints As List(Of ShapeControlPoint), _
id As String _
)

Parameters

outlineFormula

A string containing the formula that defines the shape outline.

decorationsFormula

A string containing the formula that defines the shape decorations.

controlPoints

A list of ShapeControlPoint objects that let users adjust the shape.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Constructor (String, String, String)

Shape Constructor (String, String, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape (
string outlineFormula,
string decorationsFormula,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineFormula As String, _
decorationsFormula As String, _
id As String _
)

Parameters

outlineFormula

A string containing the formula that defines the shape outline.

decorationsFormula

A string containing the formula that defines the shape decorations.

id

The string identifier of the new shape.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Constructor Overload List
Shape Class
MindFusion.Diagramming.Wpf Namespace
OutlineFormula Property
DecorationsFormula Property


MindFusion.Diagramming.Wpf.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Draws this shape on the specified DrawingContext surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Clone Method

Shape.Clone Method
[image]

Creates an exact copy of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the Shape class representing the newly created clone.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Draw Method

Shape.Draw Method
[image]

Draws this shape on the specified DrawingContext surface.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Draw (
DrawingContext drawingContext,
Brush brush,
Pen pen,
double orientation
)

Visual Basic [image] Copy Code

Public Sub Draw( _
drawingContext As DrawingContext, _
brush As Brush, _
pen As Pen, _
orientation As Double _
)

Parameters

drawingContext
The DrawingContext surface to draw the shape on.
brush
A Brush used to fill the shape.
pen
A Pen used to draw the shape outline.
orientation

Orientation angle to apply to the shape geometry.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Equals Method

Shape.Equals Method
[image]

Checks whether this shape template is equivalent to the specified shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new bool Equals (
Shape shape
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
shape As Shape _
) As Boolean

Parameters

shape

The shape to check for equality with the current shape.

Return Value

true if the current shape is equivalent to the specified shape; otherwise, false.

Remarks

Two shapes are considered equivalent if they have the same fill type, the same number and type of segments and if the points of those segments are close enough to each other.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.FromId Method

Shape.FromId Method
[image]

Returns a reference to the shape with the specified string identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As String _
) As Shape

Parameters

id

The identifier of the shape of interest.

Return Value

A reference to the Shape with the specified identifier or a null reference (Nothing in Visual Basic) if there is no such shape.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.LoadFromXml Method

Shape.LoadFromXml Method
[image]

Loads the shape content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement containing the shape's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.Shape.SaveToXml Method

Shape.SaveToXml Method
[image]

Saves the shape content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
The XmlElement the shape's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.Shape.ToString Method

Shape.ToString Method
[image]

Returns the identifier of this shape template.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string value representing the shape identifier.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null (Nothing in Visual Basic).
ControlPoints | A list of ShapeControlPoint objects that let users adjust a node's shape.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DecorationsFormula | Gets or sets a formula describing the shape decorations depending on the current width and height of the node.
DisplayName | Specifies the name that should be displayed for this shape in user interface objects.
FillRule | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageLocation | Gets or sets the path to the file that contains the image displayed in this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
OutlineFormula | Gets or sets a formula describing the shape outline depending on the current width and height of the node.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

See Also

Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.AnchorPattern Property

Shape.AnchorPattern Property
[image]

Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null (Nothing in Visual Basic).

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

If the AnchorPattern of a ShapeNode is set, it overrides the one associated with the Shape definition.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.ControlPoints Property

Shape.ControlPoints Property
[image]

A list of ShapeControlPoint objects that let users adjust a node's shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public List<ShapeControlPoint> ControlPoints { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ControlPoints As List(Of ShapeControlPoint)

Property Value

A List<ShapeControlPoint> instance.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.DecorationHitTesting Property

Shape.DecorationHitTesting Property
[image]

Gets or sets a value indicating whether decoration lines should be considered when hit-testing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool DecorationHitTesting { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationHitTesting As Boolean

Property Value

Remarks

If this property is enabled, users are able to select shape nodes of such shape by clicking near a decoration line or curve, even if it lies outside the shape outlines.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Decorations Property

Shape.Decorations Property
[image]

Gets or sets a list with all decorations of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ElementTemplate[] Decorations { get; set; }

Visual Basic [image] Copy Code

Public Property Decorations As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the decorations of this shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.DecorationsFormula Property

Shape.DecorationsFormula Property
[image]

Gets or sets a formula describing the shape decorations depending on the current width and height of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string DecorationsFormula { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationsFormula As String

Property Value

A string containing the script that defines the shape decorations.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
Decorations Property
OutlineFormula Property


MindFusion.Diagramming.Wpf.Shape.DisplayName Property

Shape.DisplayName Property
[image]

Specifies the name that should be displayed for this shape in user interface objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string DisplayName { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayName As String

Property Value

The DisplayName of all predefined shapes is set to the value of their Id property.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.FillRule Property

Shape.FillRule Property
[image]

Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FillRule FillRule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FillRule As FillRule

Property Value

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Id Property

Shape.Id Property
[image]

Gets or sets the shape identifier.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

Remarks

Once assigned in the constructor, the shape identifier should not be changed, that is, do not use the set accessor of this property.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Image Property

Shape.Image Property
[image]

Gets or sets the image displayed in all instances of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BitmapSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As BitmapSource

Property Value

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.ImageLocation Property

Shape.ImageLocation Property
[image]

Gets or sets the path to the file that contains the image displayed in this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ImageLocation { get; set; }

Visual Basic [image] Copy Code

Public Property ImageLocation As String

Property Value

Remarks

Assigning a valid file path to this property will automatically load the image.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.ImageRectangle Property

Shape.ImageRectangle Property
[image]

Gets or sets the position of the images displayed in instances of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect ImageRectangle { get; set; }

Visual Basic [image] Copy Code

Public Property ImageRectangle As Rect

Property Value

Remarks

The coordinates of the image location are specified in percent, relatively to the rectangular bounds of shape nodes. The default value (0, 0, 100, 100) makes the image displayed in the whole area of that node.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
Image Property
ShapeNode.Image Property


MindFusion.Diagramming.Wpf.Shape.IsArrowhead Property

Shape.IsArrowhead Property
[image]

Specifies if this shape is used as arrowhead.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsArrowhead { get; set; }

Visual Basic [image] Copy Code

Public Property IsArrowhead As Boolean

Property Value

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.LinkSegmentInset Property

Shape.LinkSegmentInset Property
[image]

Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public float LinkSegmentInset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegmentInset As Single

Property Value

A float value specifying percents of arrowhead size. The default value is 100.

Remarks

The inset value matters when using transparent or semi-transparent arrowhead brush, or when the link's Pen is thicker than one pixel and its cap might extend beyond the arrowhead outline. LinkSegmentInset is set to appropriate values for all shapes from the ArrowHeads class. You might want to set it when using custom arrowhead shapes for which the link's end segment should not reach all the way to the arrowhead tip.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Outline Property

Shape.Outline Property
[image]

Gets or sets the outline of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ElementTemplate[] Outline { get; set; }

Visual Basic [image] Copy Code

Public Property Outline As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the outline of the shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
OutlineFormula Property


MindFusion.Diagramming.Wpf.Shape.OutlineFormula Property

Shape.OutlineFormula Property
[image]

Gets or sets a formula describing the shape outline depending on the current width and height of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OutlineFormula { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineFormula As String

Property Value

A string containing the script that defines the shape outline.

Remarks

Shape formulas are small scripts that call one of the following functions to add graphics to the shape:

Function | Description
MoveTo (x,y) | Moves the current position to the specified point without drawing.
LineTo (x,y) | Draws a line from the current position to the specified point.
BezierTo (x1,y1,x2,y2,x3,y3) | Draws a Bezier curve from the current position to (x3,y3) using (x1,y1) and (x2,y2) as control points.
ArcTo (x,y,largeArc,clockwiseArc,rx,ry) | Draws an arc from the specified point to (x,y) where rx and ry are the ellipse radiuses and the arc flags are boolean values specifying which of the four possible arcs to draw.

Each of them starts drawing from the current position and changes the current position to their point argument after drawing. In addition, the scripts can access the current size of the node through the Width and Height variables.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
Outline Property
DecorationsFormula Property


MindFusion.Diagramming.Wpf.Shape.ShapeDecorations Property

Shape.ShapeDecorations Property
[image]

Gets or sets the ShapeDecoration objects associated with this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeDecoration[] ShapeDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeDecorations As ShapeDecoration()

Property Value

An array of ShapeDecoration objects.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shape.Shapes Property

Shape.Shapes Property
[image]

Gets a read-only collection of all named shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ShapeCollection Shapes { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shapes As ShapeCollection

Property Value

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace
FromId Method


MindFusion.Diagramming.Wpf.Shape.TextArea Property

Shape.TextArea Property
[image]

Gets or sets the outline of the text area of this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ElementTemplate[] TextArea { get; set; }

Visual Basic [image] Copy Code

Public Property TextArea As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the text area of this shape.

See Also

Shape Members
Shape Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle Class

ShapeAdjustmentHandle Class
Remarks See Also
[image]

Represents an adjustment handle used to modify the Shape of a ShapeNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class ShapeAdjustmentHandle
Inherits AdjustmentHandle

Remarks

Adjustment handles of this type are used to modify the ControlPoints of a formula shape.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.AdjustmentHandle
MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle

See Also

ShapeAdjustmentHandle Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle Members

ShapeAdjustmentHandle Members
Constructors Properties Methods
[image]

Represents an adjustment handle used to modify the Shape of a ShapeNode.

The following tables list the members exposed by the ShapeAdjustmentHandle type.

Public Constructors

Name | Description
ShapeAdjustmentHandle | Initializes a new instance of the ShapeAdjustmentHandle class.

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.
FormulaParam | Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

Public Methods

Name | Description
IsMoveHandle | Returns a value indicating whether this handle is used to move items. (Inherited from AdjustmentHandle.)

See Also

ShapeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle Constructor

ShapeAdjustmentHandle Constructor
[image]

Initializes a new instance of the ShapeAdjustmentHandle class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeAdjustmentHandle (
ShapeControlPoint controlPoint,
ShapeFormulaParam formulaParam
)

Visual Basic [image] Copy Code

Public New ( _
controlPoint As ShapeControlPoint, _
formulaParam As ShapeFormulaParam _
)

Parameters

controlPoint

A ShapeControlPoint representing the shape's control point that will be modified by this adjustment handle.

formulaParam

A ShapeFormulaParam whose values will be updated by this handle.

See Also

ShapeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle Properties

ShapeAdjustmentHandle Properties
[image]

Public Properties

Name | Description
ControlPoint | Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.
FormulaParam | Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

See Also

ShapeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle.ControlPoint Property

ShapeAdjustmentHandle.ControlPoint Property
[image]

Gets or sets the ShapeControlPoint that will be modified by this adjustment handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeControlPoint ControlPoint { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoint As ShapeControlPoint

Property Value

An instance of the ShapeControlPoint class.

See Also

ShapeAdjustmentHandle Members
ShapeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeAdjustmentHandle.FormulaParam Property

ShapeAdjustmentHandle.FormulaParam Property
[image]

Gets or sets the ShapeFormulaParam whose values will be updated by this handle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam FormulaParam { get; set; }

Visual Basic [image] Copy Code

Public Property FormulaParam As ShapeFormulaParam

Property Value

An instance of the ShapeFormulaParam class.

See Also

ShapeAdjustmentHandle Members
ShapeAdjustmentHandle Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection Class

ShapeCollection Class
[image]

Represents a read-only collection of shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeCollection : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ShapeCollection
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeCollection

See Also

ShapeCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection Members

ShapeCollection Members
Properties Methods
[image]

Represents a read-only collection of shapes.

The following tables list the members exposed by the ShapeCollection type.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchoronize access to this collection.

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection Methods

ShapeCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified shape is contained in the collection.
CopyTo | Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.
GetAt | Gets the shape at the specified position.
GetEnumerator | Returns an enumerator for this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.Contains Method

ShapeCollection.Contains Method
[image]

Checks whether the specified shape is contained in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Shape shape
)

Visual Basic [image] Copy Code

Public Function Contains( _
shape As Shape _
) As Boolean

Parameters

shape
The Shape object to search for in the collection.

Return Value

true if the specified item was found in the collection; otherwise, false.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.CopyTo Method

ShapeCollection.CopyTo Method
[image]

Copies a range of shapes from this collection to the specified one-dimensional array starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the current collection.
index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.GetAt Method

ShapeCollection.GetAt Method
[image]

Gets the shape at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Return Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.GetEnumerator Method

ShapeCollection.GetEnumerator Method
[image]

Returns an enumerator for this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An System.Collections.IEnumerator for the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection Properties

ShapeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to this collection is synchronized.
Item | Gets the diagram item at the specified position.
SyncRoot | Gets an object that can be used to synchoronize access to this collection.

See Also

ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.Count Property

ShapeCollection.Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the size of the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.IsSynchronized Property

ShapeCollection.IsSynchronized Property
[image]

Gets a value indicating whether the access to this collection is synchronized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false. The default is false.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.Item Property

ShapeCollection.Item Property
[image]

Gets the diagram item at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As Shape

Parameters

index
The zero-based index of the shape to retrieve.

Property Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeCollection.SyncRoot Property

ShapeCollection.SyncRoot Property
[image]

Gets an object that can be used to synchoronize access to this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ShapeCollection Members
ShapeCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint Class

ShapeControlPoint Class
Remarks See Also
[image]

Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeControlPoint

Visual Basic [image] Copy Code

Public Class ShapeControlPoint

Remarks

The component raises the ShapeModified event when users drag a shape control point.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeControlPoint

See Also

ShapeControlPoint Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint Members

ShapeControlPoint Members
Constructors Properties Methods
[image]

Represents a control point that can be used to adjust the shape of a ShapeNode. Control point positions are passed as parameters to shape formulas, whose code can alter the coordinates of the shape's graphic primitives based on the parameter values.

The following tables list the members exposed by the ShapeControlPoint type.

Public Constructors

Name | Description
ShapeControlPoint | Initializes a new instance of the ShapeControlPoint class.

Public Properties

Name | Description
MaxXRelativeToWidth | Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.
MaxYRelativeToHeight | Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.
ParamName | Gets or sets the name of the formula parameter corresponding to this control point.

Public Methods

Name | Description
Clone | Creates a copy of this control point.
LocationForNode | Returns the location of this control point when applied to specified node.

Protected Methods

Name | Description
LoadFromXml | Deserializes the control point from XML format.
SaveToXml | Serializes the control point in XML format.

See Also

ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint Constructor

ShapeControlPoint Constructor
[image]

Initializes a new instance of the ShapeControlPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeControlPoint (
string paramName,
double defaultX,
double minX,
double maxX,
UnitType xUnit,
double defaultY,
double minY,
double maxY,
UnitType yUnit
)

Visual Basic [image] Copy Code

Public New ( _
paramName As String, _
defaultX As Double, _
minX As Double, _
maxX As Double, _
xUnit As UnitType, _
defaultY As Double, _
minY As Double, _
maxY As Double, _
yUnit As UnitType _
)

Parameters

paramName

Specifies the name of the shape formula parameter corresponding to this control point.

defaultX

The initial horizontal position of this control point.

minX

The minimum horizontal position that is allowed for this control point.

maxX

The maximum horizontal position that is allowed for this control point.

xUnit

The unit used to specify the horizontal position of this control point.

defaultY

The initial vertical position of this control point.

minY

The minimum vertical position that is allowed for this control point.

maxY

The maximum vertical position that is allowed for this control point.

yUnit

The unit used to specify the vertical position of this control point.

See Also

ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint Methods

ShapeControlPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this control point.
LocationForNode | Returns the location of this control point when applied to specified node.

Protected Methods

Name | Description
LoadFromXml | Deserializes the control point from XML format.
SaveToXml | Serializes the control point in XML format.

See Also

ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.Clone Method

ShapeControlPoint.Clone Method
[image]

Creates a copy of this control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeControlPoint Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As ShapeControlPoint

Return Value

A new ShapeControlPoint that is a copy of the current instance.

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.LoadFromXml Method

ShapeControlPoint.LoadFromXml Method
[image]

Deserializes the control point from XML format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.LocationForNode Method

ShapeControlPoint.LocationForNode Method
[image]

Returns the location of this control point when applied to specified node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Nullable<Point> LocationForNode (
ShapeNode node,
bool local
)

Visual Basic [image] Copy Code

Public Function LocationForNode( _
node As ShapeNode, _
local As Boolean _
) As Nullable(Of Point)

Parameters

node

A ShapeNode that displays the Shape containing this control point.

local

true to return coordinates relative to the node, or false to return ones relative to the diagram.

Return Value

A Point instance specifying the control point's coordinates.

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.SaveToXml Method

ShapeControlPoint.SaveToXml Method
[image]

Serializes the control point in XML format.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint Properties

ShapeControlPoint Properties
[image]

Public Properties

Name | Description
MaxXRelativeToWidth | Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.
MaxYRelativeToHeight | Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.
ParamName | Gets or sets the name of the formula parameter corresponding to this control point.

See Also

ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.MaxXRelativeToWidth Property

ShapeControlPoint.MaxXRelativeToWidth Property
[image]

Gets or sets a value indicating whether the maximum horizontal position is specified relatively to the node's right side.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MaxXRelativeToWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxXRelativeToWidth As Boolean

Property Value

true if the maxX value is relative to the node's right side, false if it's relative to the left side.

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.MaxYRelativeToHeight Property

ShapeControlPoint.MaxYRelativeToHeight Property
[image]

Gets or sets a value indicating whether the maximum vertical position is specified relatively to the node's bottom side.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MaxYRelativeToHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MaxYRelativeToHeight As Boolean

Property Value

true if the maxY value is relative to the node's bottom side, false if it's relative to the top side.

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeControlPoint.ParamName Property

ShapeControlPoint.ParamName Property
[image]

Gets or sets the name of the formula parameter corresponding to this control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ParamName { get; set; }

Visual Basic [image] Copy Code

Public Property ParamName As String

Property Value

A string specifying the name of the shape formula parameter.

See Also

ShapeControlPoint Members
ShapeControlPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter Class

ShapeConverter Class
[image]

Converts from Shape to other data types.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class ShapeConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Diagramming.Wpf.ShapeConverter

See Also

ShapeConverter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter Members

ShapeConverter Members
Constructors Methods
[image]

Converts from Shape to other data types.

The following tables list the members exposed by the ShapeConverter type.

Public Constructors

Name | Description
ShapeConverter |

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter Constructor

ShapeConverter Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter Methods

ShapeConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.
GetStandardValues | TypeConverter.GetStandardValues override.
GetStandardValuesExclusive | TypeConverter.GetStandardValuesExclusive override.
GetStandardValuesSupported | TypeConverter.GetStandardValuesSupported override.

See Also

ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.CanConvertFrom Method

ShapeConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

sourceType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.CanConvertTo Method

ShapeConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.ConvertFrom Method

ShapeConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

culture

value

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.ConvertTo Method

ShapeConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

culture

value

destinationType

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.GetStandardValues Method

ShapeConverter.GetStandardValues Method
[image]

TypeConverter.GetStandardValues override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override TypeConverter.StandardValuesCollection GetStandardValues (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValues( _
context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.GetStandardValuesExclusive Method

ShapeConverter.GetStandardValuesExclusive Method
[image]

TypeConverter.GetStandardValuesExclusive override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool GetStandardValuesExclusive (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValuesExclusive( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeConverter.GetStandardValuesSupported Method

ShapeConverter.GetStandardValuesSupported Method
[image]

TypeConverter.GetStandardValuesSupported override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool GetStandardValuesSupported (
ITypeDescriptorContext context
)

Visual Basic [image] Copy Code

Public Overrides Function GetStandardValuesSupported( _
context As ITypeDescriptorContext _
) As Boolean

Parameters

context

Return Value

See Also

ShapeConverter Members
ShapeConverter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData Class

ShapeData Class
[image]

Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeData

Visual Basic [image] Copy Code

Public Class ShapeData

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeData

See Also

ShapeData Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData Members

ShapeData Members
Constructors Properties
[image]

Contains the cached coordinates of the key points of a shape when the shape is applied to a specific ShapeNode. This class also stores additional data passed to custom shape-generation callbacks and to shape formula scripts.

The following tables list the members exposed by the ShapeData type.

Public Constructors

Name | Description
ShapeData |

Public Properties

Name | Description
Height | Gets the height of the node that displays this shape.
Width | Gets the width of the node that displays this shape.

See Also

ShapeData Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData Constructor

ShapeData Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeData ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeData Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData Properties

ShapeData Properties
[image]

Public Properties

Name | Description
Height | Gets the height of the node that displays this shape.
Width | Gets the width of the node that displays this shape.

See Also

ShapeData Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData.Height Property

ShapeData.Height Property
[image]

Gets the height of the node that displays this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value specifying the node's height.

See Also

ShapeData Members
ShapeData Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeData.Width Property

ShapeData.Width Property
[image]

Gets the width of the node that displays this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the node's width.

See Also

ShapeData Members
ShapeData Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration Class

ShapeDecoration Class
[image]

Defines decoration elements that are displayed as filled shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeDecoration

Visual Basic [image] Copy Code

Public Class ShapeDecoration

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeDecoration

See Also

ShapeDecoration Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration Members

ShapeDecoration Members
Constructors Properties Methods
[image]

Defines decoration elements that are displayed as filled shapes.

The following tables list the members exposed by the ShapeDecoration type.

Public Constructors

Name | Description
ShapeDecoration | Initializes a new instance of the ShapeDecoration class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
FillRule | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration Constructor

ShapeDecoration Constructor
[image]

Initializes a new instance of the ShapeDecoration class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeDecoration (
ElementTemplate[] elements,
Brush brush,
FillRule fillMode,
Pen pen
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
brush As Brush, _
fillMode As FillRule, _
pen As Pen _
)

Parameters

elements
An array of ElementTemplate objects that define the decoration shape outline.
brush

A Brush object used to fill the decoration shape interior.

fillMode

Specifies how areas are filled if the outline path intersects itself.

pen

A Pen object used to draw the decoration shape outline.

See Also

ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration Methods

ShapeDecoration Methods
[image]

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration.Clone Method

ShapeDecoration.Clone Method
[image]

Clones this ShapeDecoration object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

A copy of the ShapeDecoration.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration.LoadFromXml Method

ShapeDecoration.LoadFromXml Method
[image]

Loads the ShapeDecoration definition from an XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

The parent XmlElement object.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace
SaveToXml Method


MindFusion.Diagramming.Wpf.ShapeDecoration.SaveToXml Method

ShapeDecoration.SaveToXml Method
[image]

Saves the ShapeDecoration definition in an XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

The parent XmlElement object.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace
LoadFromXml Method


MindFusion.Diagramming.Wpf.ShapeDecoration Properties

ShapeDecoration Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
FillRule | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

See Also

ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration.Brush Property

ShapeDecoration.Brush Property
[image]

Gets or sets the brush used to fill the decoration shape interior.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the System.Windows.Media.Brush class.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration.FillRule Property

ShapeDecoration.FillRule Property
[image]

Gets or sets how areas are filled if the outline path intersects itself.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FillRule FillRule { get; set; }

Visual Basic [image] Copy Code

Public Property FillRule As FillRule

Property Value

A member of the System.Windows.Media.FillRule enumeration.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDecoration.Pen Property

ShapeDecoration.Pen Property
[image]

Gets or sets the brush used to draw the decoration shape outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

See Also

ShapeDecoration Members
ShapeDecoration Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Class

ShapeDesigner Class
Remarks See Also
[image]

Represents an interactive vector-drawing control that can be used to design node shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeDesigner : Control

Visual Basic [image] Copy Code

Public Class ShapeDesigner
Inherits Control

Remarks

The ShapeDesigner component implements a vector-drawing canvas where Shape definitions can be created interactively. Call the ImportShape method to open a shape for editing. Call the ExportShape method to create a Shape with specified Id from current content of the designer canvas.

ShapeDesigner shows a palette with two kinds of elements: Primitives which when dropped on the canvas add a single curve or line segment, and Templates which when dropped on canvas add a closed path of several graphic primitives. It supports the following drag-and-drop operations:

  • dropping a primitive over existing element of a shape outline replaces the element.
  • dropping a primitive over the joint of two outline elements inserts the element between them.
  • dropping a primitive on an empty area of the canvas adds a decoration to the Shape.
  • dropping a template over the shape outline replaces all elements of the outline with ones from the template.
  • dropping a template on an empty area of the canvas adds a filled ShapeDecoration to the Shape.
  • dropping a template over a ShapeDecoration replaces its elements.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.ShapeDesigner

See Also

ShapeDesigner Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Members

ShapeDesigner Members
Constructors Fields Properties Methods Events
[image]

Represents an interactive vector-drawing control that can be used to design node shapes.

The following tables list the members exposed by the ShapeDesigner type.

Public Constructors

Name | Description
ShapeDesigner | Initializes a new instance of the ShapeDesigner class.

Public Fields

Name | Description
AlignToGridProperty | Identifies the AlignToGrid dependency property.
AnchorPointsLabelProperty | Identifies the AnchorPointsLabel dependency property.
GridSizeProperty | Identifies the GridSize dependency property.
PrimitivesLabelProperty | Identifies the PrimitivesLabel dependency property.
SelectedElementProperty | Identifies the SelectedElement dependency property.
ShapeBoundsBrushProperty | Identifies the ShapeBoundsBrush dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
ShowGridProperty | Identifies the ShowGrid dependency property.
ShowShapePropertiesProperty | Identifies the ShowShapeProperties dependency property.
TemplatesLabelProperty | Identifies the TemplatesLabel dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Properties

Name | Description
AlignToGrid | Gets or sets a value indicating whether to align shape elements to a grid. This is a dependency property.
AnchorPointsLabel | A string specifying the label of Anchor Points category in shape designer toolbox.
GridSize | Gets or sets the size of the alignment grid. This is a dependency property.
PrimitivesLabel | A string specifying the label of graphic primitives category in shape designer toolbox.
SelectedElement | Gets or sets the selected element in the shape designer. This is a dependency property.
ShapeBoundsBrush | Specifies the brush used to fill the shape's bounding rectangle.
ShapeSize | Specifies the size of the design area representing the node's bounding rectangle.
ShowGrid | Gets or sets a value indicating whether to show the alignment grid. This is a dependency property.
ShowShapeProperties | Gets or sets a value indicating whether the shape properties panel should be visible. This is a dependency property.
TemplatesLabel | A string specifying the label of outline templates category in shape designer toolbox.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the ShapeDesigner.

Public Methods

Name | Description
ExportShape | Creates a new Shape from the current content of the design canvas.
ImportShape | Imports a Shape into the designer's drawing canvas.
OnApplyTemplate | Control.OnApplyTemplate override.
Redo | Executes again the most recently undone user action.
Undo | Undoes the most recent user action.

Protected Methods

Name | Description
OnMouseWheel | OnMouseWheel override.
OnPreviewDragOver | Control.OnPreviewDragOver override.
OnPreviewDrop | Control.OnPreviewDrop override.
OnShapeChanged | Raises the ShapeChanged event.

Public Events

Name | Description
ShapeChanged | Occurs when the shape drawing changes.

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Fields

ShapeDesigner Fields
[image]

Public Fields

Name | Description
AlignToGridProperty | Identifies the AlignToGrid dependency property.
AnchorPointsLabelProperty | Identifies the AnchorPointsLabel dependency property.
GridSizeProperty | Identifies the GridSize dependency property.
PrimitivesLabelProperty | Identifies the PrimitivesLabel dependency property.
SelectedElementProperty | Identifies the SelectedElement dependency property.
ShapeBoundsBrushProperty | Identifies the ShapeBoundsBrush dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
ShowGridProperty | Identifies the ShowGrid dependency property.
ShowShapePropertiesProperty | Identifies the ShowShapeProperties dependency property.
TemplatesLabelProperty | Identifies the TemplatesLabel dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.AlignToGridProperty Field

ShapeDesigner.AlignToGridProperty Field
[image]

Identifies the AlignToGrid dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlignToGridProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlignToGridProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.AnchorPointsLabelProperty Field

ShapeDesigner.AnchorPointsLabelProperty Field
[image]

Identifies the AnchorPointsLabel dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty AnchorPointsLabelProperty

Visual Basic [image] Copy Code

Public Shared AnchorPointsLabelProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.GridSizeProperty Field

ShapeDesigner.GridSizeProperty Field
[image]

Identifies the GridSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridSizeProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.PrimitivesLabelProperty Field

ShapeDesigner.PrimitivesLabelProperty Field
[image]

Identifies the PrimitivesLabel dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty PrimitivesLabelProperty

Visual Basic [image] Copy Code

Public Shared PrimitivesLabelProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.SelectedElementProperty Field

ShapeDesigner.SelectedElementProperty Field
[image]

Identifies the SelectedElement dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty SelectedElementProperty

Visual Basic [image] Copy Code

Public Shared SelectedElementProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShapeBoundsBrushProperty Field

ShapeDesigner.ShapeBoundsBrushProperty Field
[image]

Identifies the ShapeBoundsBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeBoundsBrushProperty

Visual Basic [image] Copy Code

Public Shared ShapeBoundsBrushProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShapeSizeProperty Field

ShapeDesigner.ShapeSizeProperty Field
[image]

Identifies the ShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared ShapeSizeProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShowGridProperty Field

ShapeDesigner.ShowGridProperty Field
[image]

Identifies the ShowGrid dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowGridProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowGridProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShowShapePropertiesProperty Field

ShapeDesigner.ShowShapePropertiesProperty Field
[image]

Identifies the ShowShapeProperties dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowShapePropertiesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowShapePropertiesProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.TemplatesLabelProperty Field

ShapeDesigner.TemplatesLabelProperty Field
[image]

Identifies the TemplatesLabel dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TemplatesLabelProperty

Visual Basic [image] Copy Code

Public Shared TemplatesLabelProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ZoomFactorProperty Field

ShapeDesigner.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ZoomFactorProperty As DependencyProperty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Constructor

ShapeDesigner Constructor
[image]

Initializes a new instance of the ShapeDesigner class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeDesigner ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Methods

ShapeDesigner Methods
[image]

Public Methods

Name | Description
ExportShape | Creates a new Shape from the current content of the design canvas.
ImportShape | Imports a Shape into the designer's drawing canvas.
OnApplyTemplate | Control.OnApplyTemplate override.
Redo | Executes again the most recently undone user action.
Undo | Undoes the most recent user action.

Protected Methods

Name | Description
OnMouseWheel | OnMouseWheel override.
OnPreviewDragOver | Control.OnPreviewDragOver override.
OnPreviewDrop | Control.OnPreviewDrop override.
OnShapeChanged | Raises the ShapeChanged event.

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ExportShape Method

ShapeDesigner.ExportShape Method
[image]

Creates a new Shape from the current content of the design canvas.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape ExportShape (
string shapeId
)

Visual Basic [image] Copy Code

Public Function ExportShape( _
shapeId As String _
) As Shape

Parameters

shapeId

The shape's string identifier.

Return Value

A Shape instance.

Remarks

This method converts the internal shape design representation to respective collections of ElementTemplate objects, assiged to Outline ot Decorations properties of the new Shape.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ImportShape Method

ShapeDesigner.ImportShape Method
[image]

Imports a Shape into the designer's drawing canvas.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ImportShape (
Shape shape
)

Visual Basic [image] Copy Code

Public Sub ImportShape( _
shape As Shape _
)

Parameters

shape

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.OnApplyTemplate Method

ShapeDesigner.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.OnMouseWheel Method

ShapeDesigner.OnMouseWheel Method
[image]

OnMouseWheel override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseWheel (
MouseWheelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseWheel( _
e As MouseWheelEventArgs _
)

Parameters

e

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.OnPreviewDragOver Method

ShapeDesigner.OnPreviewDragOver Method
[image]

Control.OnPreviewDragOver override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewDragOver (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewDragOver( _
e As DragEventArgs _
)

Parameters

e

The DragEventArgs that contains the event data.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.OnPreviewDrop Method

ShapeDesigner.OnPreviewDrop Method
[image]

Control.OnPreviewDrop override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewDrop (
DragEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewDrop( _
e As DragEventArgs _
)

Parameters

e

The DragEventArgs that contains the event data.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.OnShapeChanged Method

ShapeDesigner.OnShapeChanged Method
[image]

Raises the ShapeChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnShapeChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnShapeChanged( _
e As EventArgs _
)

Parameters

e

EventArgs.Empty

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.Redo Method

ShapeDesigner.Redo Method
[image]

Executes again the most recently undone user action.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.Undo Method

ShapeDesigner.Undo Method
[image]

Undoes the most recent user action.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Properties

ShapeDesigner Properties
[image]

Public Properties

Name | Description
AlignToGrid | Gets or sets a value indicating whether to align shape elements to a grid. This is a dependency property.
AnchorPointsLabel | A string specifying the label of Anchor Points category in shape designer toolbox.
GridSize | Gets or sets the size of the alignment grid. This is a dependency property.
PrimitivesLabel | A string specifying the label of graphic primitives category in shape designer toolbox.
SelectedElement | Gets or sets the selected element in the shape designer. This is a dependency property.
ShapeBoundsBrush | Specifies the brush used to fill the shape's bounding rectangle.
ShapeSize | Specifies the size of the design area representing the node's bounding rectangle.
ShowGrid | Gets or sets a value indicating whether to show the alignment grid. This is a dependency property.
ShowShapeProperties | Gets or sets a value indicating whether the shape properties panel should be visible. This is a dependency property.
TemplatesLabel | A string specifying the label of outline templates category in shape designer toolbox.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the ShapeDesigner.

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.AlignToGrid Property

ShapeDesigner.AlignToGrid Property
[image]

Gets or sets a value indicating whether to align shape elements to a grid. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AlignToGrid { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToGrid As Boolean

Property Value

true to align elements to the grid, or false otherwise. The default value is false.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.AnchorPointsLabel Property

ShapeDesigner.AnchorPointsLabel Property
[image]

A string specifying the label of Anchor Points category in shape designer toolbox.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string AnchorPointsLabel { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPointsLabel As String

Property Value

A string specifying the category label. The default value is "Anchor points".

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.GridSize Property

ShapeDesigner.GridSize Property
[image]

Gets or sets the size of the alignment grid. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double value specifying the grid size in shape definition coordinates, i.e. percentage of node size. The default value is 5.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.PrimitivesLabel Property

ShapeDesigner.PrimitivesLabel Property
[image]

A string specifying the label of graphic primitives category in shape designer toolbox.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string PrimitivesLabel { get; set; }

Visual Basic [image] Copy Code

Public Property PrimitivesLabel As String

Property Value

A string specifying the category label. The default value is "Primitives".

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.SelectedElement Property

ShapeDesigner.SelectedElement Property
[image]

Gets or sets the selected element in the shape designer. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FrameworkElement SelectedElement { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElement As FrameworkElement

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShapeBoundsBrush Property

ShapeDesigner.ShapeBoundsBrush Property
[image]

Specifies the brush used to fill the shape's bounding rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeBoundsBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBoundsBrush As Brush

Property Value

A System.Windows.Media.Brush instance. The default value is Brushes.White.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShapeSize Property

ShapeDesigner.ShapeSize Property
[image]

Specifies the size of the design area representing the node's bounding rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

A double value specifying the shape area size. The default value is 200.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShowGrid Property

ShapeDesigner.ShowGrid Property
[image]

Gets or sets a value indicating whether to show the alignment grid. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowGrid { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGrid As Boolean

Property Value

true to show the grid, or false otherwise. The default value is false.

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShowShapeProperties Property

ShapeDesigner.ShowShapeProperties Property
[image]

Gets or sets a value indicating whether the shape properties panel should be visible. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowShapeProperties { get; set; }

Visual Basic [image] Copy Code

Public Property ShowShapeProperties As Boolean

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.TemplatesLabel Property

ShapeDesigner.TemplatesLabel Property
[image]

A string specifying the label of outline templates category in shape designer toolbox.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string TemplatesLabel { get; set; }

Visual Basic [image] Copy Code

Public Property TemplatesLabel As String

Property Value

A string specifying the category label. The default value is "Templates".

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ZoomFactor Property

ShapeDesigner.ZoomFactor Property
[image]

Gets or sets the zoom factor used to scale up or down the ShapeDesigner.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner Events

ShapeDesigner Events
[image]

Public Events

Name | Description
ShapeChanged | Occurs when the shape drawing changes.

See Also

ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesigner.ShapeChanged Event

ShapeDesigner.ShapeChanged Event
[image]

Occurs when the shape drawing changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ShapeChanged

Visual Basic [image] Copy Code

Public Event ShapeChanged As EventHandler

See Also

ShapeDesigner Members
ShapeDesigner Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Class

ShapeDesignerCanvas Class
[image]

Represents the drawing canvas of a ShapeDesigner control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeDesignerCanvas : Control

Visual Basic [image] Copy Code

Public Class ShapeDesignerCanvas
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.ShapeDesignerCanvas

See Also

ShapeDesignerCanvas Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Members

ShapeDesignerCanvas Members
Constructors Fields Properties Methods
[image]

Represents the drawing canvas of a ShapeDesigner control.

The following tables list the members exposed by the ShapeDesignerCanvas type.

Public Constructors

Name | Description
ShapeDesignerCanvas |

Public Fields

Name | Description
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Properties

Name | Description
ShapeSize | Specifies the size of the design area representing the node's bounding rectangle.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the ShapeDesignerCanvas.

Protected Properties

Name | Description
VisualChildrenCount | Control.VisualChildrenCount override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetVisualChild | Control.GetVisualChild override.
MeasureOverride | Control.MeasureOverride override.
OnPreviewKeyDown | Control.OnPreviewKeyDown override.
OnPreviewMouseLeftButtonDown | Control.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseLeftButtonUp | Control.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseMove | Control.OnPreviewMouseMove override.
OnRender | Control.OnRender override.
OnRenderSizeChanged | Control.OnRenderSizeChanged override.

See Also

ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Fields

ShapeDesignerCanvas Fields
[image]

Public Fields

Name | Description
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.ZoomFactorProperty Field

ShapeDesignerCanvas.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Constructor

ShapeDesignerCanvas Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeDesignerCanvas ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Methods

ShapeDesignerCanvas Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetVisualChild | Control.GetVisualChild override.
MeasureOverride | Control.MeasureOverride override.
OnPreviewKeyDown | Control.OnPreviewKeyDown override.
OnPreviewMouseLeftButtonDown | Control.OnPreviewMouseLeftButtonDown override.
OnPreviewMouseLeftButtonUp | Control.OnPreviewMouseLeftButtonUp override.
OnPreviewMouseMove | Control.OnPreviewMouseMove override.
OnRender | Control.OnRender override.
OnRenderSizeChanged | Control.OnRenderSizeChanged override.

See Also

ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.ArrangeOverride Method

ShapeDesignerCanvas.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

Return Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.GetVisualChild Method

ShapeDesignerCanvas.GetVisualChild Method
[image]

Control.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.MeasureOverride Method

ShapeDesignerCanvas.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

Return Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnPreviewKeyDown Method

ShapeDesignerCanvas.OnPreviewKeyDown Method
[image]

Control.OnPreviewKeyDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewKeyDown( _
e As KeyEventArgs _
)

Parameters

e

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnPreviewMouseLeftButtonDown Method

ShapeDesignerCanvas.OnPreviewMouseLeftButtonDown Method
[image]

Control.OnPreviewMouseLeftButtonDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnPreviewMouseLeftButtonUp Method

ShapeDesignerCanvas.OnPreviewMouseLeftButtonUp Method
[image]

Control.OnPreviewMouseLeftButtonUp override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnPreviewMouseMove Method

ShapeDesignerCanvas.OnPreviewMouseMove Method
[image]

Control.OnPreviewMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnRender Method

ShapeDesignerCanvas.OnRender Method
[image]

Control.OnRender override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.OnRenderSizeChanged Method

ShapeDesignerCanvas.OnRenderSizeChanged Method
[image]

Control.OnRenderSizeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnRenderSizeChanged (
SizeChangedInfo sizeInfo
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRenderSizeChanged( _
sizeInfo As SizeChangedInfo _
)

Parameters

sizeInfo

Specifies the size changes.

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas Properties

ShapeDesignerCanvas Properties
[image]

Public Properties

Name | Description
ShapeSize | Specifies the size of the design area representing the node's bounding rectangle.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the ShapeDesignerCanvas.

Protected Properties

Name | Description
VisualChildrenCount | Control.VisualChildrenCount override.

See Also

ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.ShapeSize Property

ShapeDesignerCanvas.ShapeSize Property
[image]

Specifies the size of the design area representing the node's bounding rectangle.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.VisualChildrenCount Property

ShapeDesignerCanvas.VisualChildrenCount Property
[image]

Control.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerCanvas.ZoomFactor Property

ShapeDesignerCanvas.ZoomFactor Property
[image]

Gets or sets the zoom factor used to scale up or down the ShapeDesignerCanvas.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

ShapeDesignerCanvas Members
ShapeDesignerCanvas Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Class

ShapeDesignerPropertyPanel Class
[image]

ShapeDesignerPropertyPanel

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeDesignerPropertyPanel : UserControl, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class ShapeDesignerPropertyPanel
Inherits UserControl
Implements INotifyPropertyChanged, IComponentConnector

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel

See Also

ShapeDesignerPropertyPanel Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Members

ShapeDesignerPropertyPanel Members
Constructors Fields Properties Methods Events
[image]

ShapeDesignerPropertyPanel

The following tables list the members exposed by the ShapeDesignerPropertyPanel type.

Public Constructors

Name | Description
ShapeDesignerPropertyPanel | Describe your member here.

Public Fields

Name | Description
FillColorProperty | Identifies the FillColor dependency property.
RoundedCornerRadiusProperty | Identifies the RoundedCornerRadius dependency property.
StrokeColorProperty | Identifies the StrokeColor dependency property.
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
VisibleProperty | Identifies the Visible dependency property.

Public Properties

Name | Description
FillColor | Gets or sets the current value of fill color picker control.
RoundedCornerRadius | Gets or sets the current value of corner radius numeric up-down control.
StrokeColor | Gets or sets the current value of stroke color picker control.
StrokeDashStyle | Gets or sets the current value of dash style combo box.
StrokeThickness | Gets or sets the current value of stroke thickness numeric up-down control.
Visible | Gets or sets a value indicating whether this control should be displayed. This is a dependency property.

Public Methods

Name | Description
InitializeComponent | InitializeComponent

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Fields

ShapeDesignerPropertyPanel Fields
[image]

Public Fields

Name | Description
FillColorProperty | Identifies the FillColor dependency property.
RoundedCornerRadiusProperty | Identifies the RoundedCornerRadius dependency property.
StrokeColorProperty | Identifies the StrokeColor dependency property.
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
VisibleProperty | Identifies the Visible dependency property.

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.FillColorProperty Field

ShapeDesignerPropertyPanel.FillColorProperty Field
[image]

Identifies the FillColor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillColorProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.RoundedCornerRadiusProperty Field

ShapeDesignerPropertyPanel.RoundedCornerRadiusProperty Field
[image]

Identifies the RoundedCornerRadius dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RoundedCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RoundedCornerRadiusProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeColorProperty Field

ShapeDesignerPropertyPanel.StrokeColorProperty Field
[image]

Identifies the StrokeColor dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeColorProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeDashStyleProperty Field

ShapeDesignerPropertyPanel.StrokeDashStyleProperty Field
[image]

Identifies the StrokeDashStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashStyleProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeThicknessProperty Field

ShapeDesignerPropertyPanel.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.VisibleProperty Field

ShapeDesignerPropertyPanel.VisibleProperty Field
[image]

Identifies the Visible dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleProperty As DependencyProperty

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Constructor

ShapeDesignerPropertyPanel Constructor
[image]

Describe your member here.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeDesignerPropertyPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Methods

ShapeDesignerPropertyPanel Methods
[image]

Public Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.InitializeComponent Method

ShapeDesignerPropertyPanel.InitializeComponent Method
[image]

InitializeComponent

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Properties

ShapeDesignerPropertyPanel Properties
[image]

Public Properties

Name | Description
FillColor | Gets or sets the current value of fill color picker control.
RoundedCornerRadius | Gets or sets the current value of corner radius numeric up-down control.
StrokeColor | Gets or sets the current value of stroke color picker control.
StrokeDashStyle | Gets or sets the current value of dash style combo box.
StrokeThickness | Gets or sets the current value of stroke thickness numeric up-down control.
Visible | Gets or sets a value indicating whether this control should be displayed. This is a dependency property.

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.FillColor Property

ShapeDesignerPropertyPanel.FillColor Property
[image]

Gets or sets the current value of fill color picker control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color FillColor { get; set; }

Visual Basic [image] Copy Code

Public Property FillColor As Color

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.RoundedCornerRadius Property

ShapeDesignerPropertyPanel.RoundedCornerRadius Property
[image]

Gets or sets the current value of corner radius numeric up-down control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RoundedCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedCornerRadius As Double

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeColor Property

ShapeDesignerPropertyPanel.StrokeColor Property
[image]

Gets or sets the current value of stroke color picker control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color StrokeColor { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeColor As Color

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeDashStyle Property

ShapeDesignerPropertyPanel.StrokeDashStyle Property
[image]

Gets or sets the current value of dash style combo box.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.StrokeThickness Property

ShapeDesignerPropertyPanel.StrokeThickness Property
[image]

Gets or sets the current value of stroke thickness numeric up-down control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.Visible Property

ShapeDesignerPropertyPanel.Visible Property
[image]

Gets or sets a value indicating whether this control should be displayed. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel Events

ShapeDesignerPropertyPanel Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged

See Also

ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeDesignerPropertyPanel.PropertyChanged Event

ShapeDesignerPropertyPanel.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.PropertyChanged

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

ShapeDesignerPropertyPanel Members
ShapeDesignerPropertyPanel Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Class

ShapeEventArgs Class
[image]

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ShapeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.ShapeEventArgs

See Also

ShapeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Members

ShapeEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to the ShapeSelected and ShapeRenamed event handlers.

The following tables list the members exposed by the ShapeEventArgs type.

Public Constructors

Name | Description
ShapeEventArgs | Overloaded.

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldId | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Constructor

ShapeEventArgs Constructor
[image]

Overload List

Name | Description
ShapeEventArgs (Shape) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32) | Initializes a new instance of the ShapeEventArgs class.
ShapeEventArgs (Shape, Int32, String) | Initializes a new instance of the ShapeEventArgs class.

See Also

ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Constructor (Shape)

ShapeEventArgs Constructor (Shape)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate
)

Visual Basic [image] Copy Code

Public New ( _
shapeTemplate As Shape _
)

Parameters

shapeTemplate
The Shape related to the event.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Constructor (Shape, Int32)

ShapeEventArgs Constructor (Shape, Int32)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate,
int index
)

Visual Basic [image] Copy Code

Public New ( _
shapeTemplate As Shape, _
index As Integer _
)

Parameters

shapeTemplate
The Shape related to the event.
index

The zero-based index of the shape within its containing collection.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Constructor (Shape, Int32, String)

ShapeEventArgs Constructor (Shape, Int32, String)
See Also
[image]

Initializes a new instance of the ShapeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeEventArgs (
Shape shapeTemplate,
int index,
string oldId
)

Visual Basic [image] Copy Code

Public New ( _
shapeTemplate As Shape, _
index As Integer, _
oldId As String _
)

Parameters

shapeTemplate
The Shape related to the event.
index

The zero-based index of the shape within its containing collection.

oldId

The old identifier of the shape.

See Also

ShapeEventArgs Constructor Overload List
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Methods

ShapeEventArgs Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs.ToString Method

ShapeEventArgs.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the object.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs Properties

ShapeEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index of the Shape item within its containing collection.
OldId | Gets or sets the name of the shape before renaming.
Shape | Gets the shape related to the event.

See Also

ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs.Index Property

ShapeEventArgs.Index Property
[image]

Gets or sets the index of the Shape item within its containing collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the zero-based index of the shape.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs.OldId Property

ShapeEventArgs.OldId Property
[image]

Gets or sets the name of the shape before renaming.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldId { get; set; }

Visual Basic [image] Copy Code

Public Property OldId As String

Property Value

A string value specifying the old shape id.

Remarks

This property is relevant only for ShapeRenamed events.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeEventArgs.Shape Property

ShapeEventArgs.Shape Property
[image]

Gets the shape related to the event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape Shape { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shape As Shape

Property Value

An instance of the Shape class.

See Also

ShapeEventArgs Members
ShapeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Class

ShapeFormulaParam Class
[image]

Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeFormulaParam

Visual Basic [image] Copy Code

Public Class ShapeFormulaParam

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeFormulaParam

See Also

ShapeFormulaParam Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Members

ShapeFormulaParam Members
Constructors Properties Methods
[image]

Represents the position of a ShapeControlPoint, passed as parameter to shape formulas.

The following tables list the members exposed by the ShapeFormulaParam type.

Public Constructors

Name | Description
ShapeFormulaParam | Overloaded. Initializes a new instance of the ShapeFormulaParam class.

Public Properties

Name | Description
X | Gets or sets the horizontal position of the control point.
Y | Gets or sets the vertical position of the control point.

Public Methods

Name | Description
Clone | Creates a copy of this ShapeFormulaParam.
LoadFromXml | Loads the formula parameter from the specified XML element.
SaveToXml | Saves the formula parameter into the specified XML element.

See Also

ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Constructor

ShapeFormulaParam Constructor
[image]

Initializes a new instance of the ShapeFormulaParam class.

Overload List

Name | Description
ShapeFormulaParam () | Initializes a new instance of the ShapeFormulaParam class.
ShapeFormulaParam (Double, Double) | Initializes a new instance of the ShapeFormulaParam class.

See Also

ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Constructor ()

ShapeFormulaParam Constructor ()
See Also
[image]

Initializes a new instance of the ShapeFormulaParam class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeFormulaParam Constructor Overload List
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Constructor (Double, Double)

ShapeFormulaParam Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the ShapeFormulaParam class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

Horizontal position of the control point.

y

Vertical position of the control point.

See Also

ShapeFormulaParam Constructor Overload List
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Methods

ShapeFormulaParam Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this ShapeFormulaParam.
LoadFromXml | Loads the formula parameter from the specified XML element.
SaveToXml | Saves the formula parameter into the specified XML element.

See Also

ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam.Clone Method

ShapeFormulaParam.Clone Method
[image]

Creates a copy of this ShapeFormulaParam.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeFormulaParam Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As ShapeFormulaParam

Return Value

A new ShapeFormulaParam object that is a copy of the current instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam.LoadFromXml Method

ShapeFormulaParam.LoadFromXml Method
[image]

Loads the formula parameter from the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam.SaveToXml Method

ShapeFormulaParam.SaveToXml Method
[image]

Saves the formula parameter into the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam Properties

ShapeFormulaParam Properties
[image]

Public Properties

Name | Description
X | Gets or sets the horizontal position of the control point.
Y | Gets or sets the vertical position of the control point.

See Also

ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam.X Property

ShapeFormulaParam.X Property
[image]

Gets or sets the horizontal position of the control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value specifying the horizontal position of the shape control point.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeFormulaParam.Y Property

ShapeFormulaParam.Y Property
[image]

Gets or sets the vertical position of the control point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value specifying the vertical position of the shape control point.

See Also

ShapeFormulaParam Members
ShapeFormulaParam Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Class

ShapeLibrary Class
Remarks See Also
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeLibrary

Visual Basic [image] Copy Code

Public Class ShapeLibrary

Remarks

Shape libraries can be created using the ShapeDesigner tool that comes with MindFusion.Diagramming for WPF. Use the LoadFrom method to load a shape library from a file. The loaded shapes can be accessed through the Shapes property. They will be automatically added to the shared list of shapes kept in the Shape class, which lets you access them by calling the FromId method. A shape library can be saved into a file in XML based format using the SaveTo method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ShapeLibrary

See Also

ShapeLibrary Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Members

ShapeLibrary Members
Constructors Properties Methods
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Overloaded.

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

Public Methods

Name | Description
ConvertToRelativePath | Converts an image path to one relative to the shape library path.
LoadFromXml | Overloaded. Loads the shape library from the specified XML document.
MakeImagesRelativeTo | Makes image locations relative to specified shape library path.
SaveToXml | Overloaded. Saves the shape libaray into the specified XML document.

See Also

ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Fields

ShapeLibrary Fields
[image]

See Also

ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Constructor

ShapeLibrary Constructor
[image]

Overload List

Name | Description
ShapeLibrary () | Initializes a new empty instance of the ShapeLibrary class.
ShapeLibrary (Shape[]) | Initializes a new instance of the ShapeLibrary class.

See Also

ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Constructor ()

ShapeLibrary Constructor ()
See Also
[image]

Initializes a new empty instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeLibrary ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Constructor (Shape[])

ShapeLibrary Constructor (Shape[])
See Also
[image]

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeLibrary (
Shape[] shapes
)

Visual Basic [image] Copy Code

Public New ( _
shapes() As Shape _
)

Parameters

shapes
An array of Shape object to initialize the libarary with.

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Methods

ShapeLibrary Methods
[image]

Public Methods

Name | Description
ConvertToRelativePath | Converts an image path to one relative to the shape library path.
LoadFromXml | Overloaded. Loads the shape library from the specified XML document.
MakeImagesRelativeTo | Makes image locations relative to specified shape library path.
SaveToXml | Overloaded. Saves the shape libaray into the specified XML document.

See Also

ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.ConvertToRelativePath Method

ShapeLibrary.ConvertToRelativePath Method
[image]

Converts an image path to one relative to the shape library path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string ConvertToRelativePath (
string imagePath,
string shapeLibraryPath
)

Visual Basic [image] Copy Code

Public Shared Function ConvertToRelativePath( _
imagePath As String, _
shapeLibraryPath As String _
) As String

Parameters

imagePath

The path that contains the image.

shapeLibraryPath

The path that contains the shape library.

Return Value

A string value that represents the relative path.

Remarks

Returns a relative version of imagePath with respect to shapeLibraryPath to facilitate ShapeLibrary transport/distribution.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.LoadFromXml Method

ShapeLibrary.LoadFromXml Method
[image]

Loads the shape library from the specified XML document.

Overload List

Name | Description
ShapeLibrary.LoadFromXml (String) | Loads this library from the specified file.
ShapeLibrary.LoadFromXml (XmlDocument) | Loads the shape library from the specified XML document.
ShapeLibrary.LoadFromXml (XmlDocument, String) | Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.LoadFromXml Method (String)

ShapeLibrary.LoadFromXml Method (String)
See Also
[image]

Loads this library from the specified file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file from which to load the shape library.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.LoadFromXml Method (XmlDocument)

ShapeLibrary.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads the shape library from the specified XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document

The document to load the library from.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.LoadFromXml Method (XmlDocument, String)

ShapeLibrary.LoadFromXml Method (XmlDocument, String)
See Also
[image]

Loads the library from the specified XML document. All locations of images associated with shapes in the library are loaded relative to the specified library path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document,
string libraryPath
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument, _
libraryPath As String _
)

Parameters

document

libraryPath

Remarks

If the path is an empty string or null, image locations are loaded relative to the BaseURI of the specified document.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.MakeImagesRelativeTo Method

ShapeLibrary.MakeImagesRelativeTo Method
[image]

Makes image locations relative to specified shape library path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void MakeImagesRelativeTo (
string shapeLibraryPath
)

Visual Basic [image] Copy Code

Public Sub MakeImagesRelativeTo( _
shapeLibraryPath As String _
)

Parameters

shapeLibraryPath

The path that contains the shape library.

Remarks

This method is supposed to be called before serialization, so that the shape library can be moved/distributed.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.SaveToXml Method

ShapeLibrary.SaveToXml Method
[image]

Saves the shape libaray into the specified XML document.

Overload List

Name | Description
ShapeLibrary.SaveToXml (String) | Saves this library to the specified file.
ShapeLibrary.SaveToXml (XmlDocument) | Saves the shape libaray into the specified XML document.
ShapeLibrary.SaveToXml (XmlDocument, String) | Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.SaveToXml Method (String)

ShapeLibrary.SaveToXml Method (String)
See Also
[image]

Saves this library to the specified file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file where to save the shape library.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.SaveToXml Method (XmlDocument)

ShapeLibrary.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the shape libaray into the specified XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.SaveToXml Method (XmlDocument, String)

ShapeLibrary.SaveToXml Method (XmlDocument, String)
See Also
[image]

Saves the shape library into the specified XML document. All locations of images associated with shapes in the library are saved relative to the specified destination path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document,
string libraryFileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument, _
libraryFileName As String _
)

Parameters

document

libraryFileName

Remarks

If the path is an empty string or null, image locations are written as absolute.

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary Properties

ShapeLibrary Properties
[image]

Public Properties

Name | Description
Shapes | Gets or sets the array of all shapes in the library.

See Also

ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeLibrary.Shapes Property

ShapeLibrary.Shapes Property
[image]

Gets or sets the array of all shapes in the library.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape[] Shapes { get; set; }

Visual Basic [image] Copy Code

Public Property Shapes As Shape()

Property Value

An array of Shape objects containing the shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Class

ShapeListBox Class
Remarks See Also
[image]

The ShapeListBox control displays a set of shapes defined via the Shape class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeListBox : Control

Visual Basic [image] Copy Code

Public Class ShapeListBox
Inherits Control

Remarks

The ShapeListBox control displays a list of Shape icons along with their DisplayName. It lets users drag-and-drop a Shape to the diagram's canvas to create a new ShapeNode. Set the ItemsSource property to an array or collection of shapes that should be rendered inside the control. For example, setting the Shape.Shapes list as ItemsSource will show all pre-defined shapes. You can customize the shape appearance by setting ShapeBrush and ShapeSize properties.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.ShapeListBox

See Also

ShapeListBox Members
MindFusion.Diagramming.Wpf Namespace
NodeListView Class


MindFusion.Diagramming.Wpf.ShapeListBox Members

ShapeListBox Members
Constructors Fields Attached Properties Properties Methods
[image]

The ShapeListBox control displays a set of shapes defined via the Shape class.

The following tables list the members exposed by the ShapeListBox type.

Public Constructors

Name | Description
ShapeListBox |

Public Fields

Name | Description
ItemsSourceProperty | Identifies the ItemsSource dependency property.
ShapeBrushProperty | Identifies the ShapeBrush dependency property.
ShapeProperty | Identifies the Shape attached property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.

Public Attached Properties

Name | Description
ShapeProperty |

Public Properties

Name | Description
ItemsSource | Gets or sets a collection of Shape objects that should be displayed inside this control.
ShapeBrush | Gets or sets the Brush used to fill shape icons.
ShapeSize | Gets or sets the size of shape icons.

Public Methods

Name | Description
GetShape | Gets the value of Shape attached property.
OnApplyTemplate | Control.OnApplyTemplate override.
SetShape | Sets the value of Shape attached property.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseMove | Control.OnPreviewMouseMove override.

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Fields

ShapeListBox Fields
[image]

Public Fields

Name | Description
ItemsSourceProperty | Identifies the ItemsSource dependency property.
ShapeBrushProperty | Identifies the ShapeBrush dependency property.
ShapeProperty | Identifies the Shape attached property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ItemsSourceProperty Field

ShapeListBox.ItemsSourceProperty Field
[image]

Identifies the ItemsSource dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ShapeBrushProperty Field

ShapeListBox.ShapeBrushProperty Field
[image]

Identifies the ShapeBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeBrushProperty As DependencyProperty

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ShapeProperty Field

ShapeListBox.ShapeProperty Field
[image]

Identifies the Shape attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeProperty As DependencyProperty

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ShapeSizeProperty Field

ShapeListBox.ShapeSizeProperty Field
[image]

Identifies the ShapeSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeSizeProperty As DependencyProperty

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Constructor

ShapeListBox Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeListBox ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Methods

ShapeListBox Methods
[image]

Public Methods

Name | Description
GetShape | Gets the value of Shape attached property.
OnApplyTemplate | Control.OnApplyTemplate override.
SetShape | Sets the value of Shape attached property.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseMove | Control.OnPreviewMouseMove override.

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.GetShape Method

ShapeListBox.GetShape Method
[image]

Gets the value of Shape attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape GetShape (
DependencyObject obj
)

Visual Basic [image] Copy Code

Public Shared Function GetShape( _
obj As DependencyObject _
) As Shape

Parameters

obj

A DependencyObject whose property value to return.

Return Value

A Shape instance.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.OnApplyTemplate Method

ShapeListBox.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.OnPreviewMouseDown Method

ShapeListBox.OnPreviewMouseDown Method
[image]

Control.OnPreviewMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

A MouseButtonEventArgs instance that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.OnPreviewMouseMove Method

ShapeListBox.OnPreviewMouseMove Method
[image]

Control.OnPreviewMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseMove( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs instance that contains the event data.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.SetShape Method

ShapeListBox.SetShape Method
[image]

Sets the value of Shape attached property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void SetShape (
DependencyObject obj,
Shape value
)

Visual Basic [image] Copy Code

Public Shared Sub SetShape( _
obj As DependencyObject, _
value As Shape _
)

Parameters

obj

A DependencyObject whose property value to set.

value

A Shape instance.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Attached Properties

ShapeListBox Attached Properties
[image]

Public Attached Properties

Name | Description
ShapeProperty |

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.Shape Attached Property

ShapeListBox.Shape Attached Property
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code
See ShapeListBox.GetShape, ShapeListBox.SetShape
Visual Basic [image] Copy Code
See ShapeListBox.GetShape, ShapeListBox.SetShape

Property Value

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox Properties

ShapeListBox Properties
[image]

Public Properties

Name | Description
ItemsSource | Gets or sets a collection of Shape objects that should be displayed inside this control.
ShapeBrush | Gets or sets the Brush used to fill shape icons.
ShapeSize | Gets or sets the size of shape icons.

See Also

ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ItemsSource Property

ShapeListBox.ItemsSource Property
[image]

Gets or sets a collection of Shape objects that should be displayed inside this control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerable ItemsSource { get; set; }

Visual Basic [image] Copy Code

Public Property ItemsSource As IEnumerable

Property Value

A list of Shape objects that should be displayed inside the listbox.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ShapeBrush Property

ShapeListBox.ShapeBrush Property
[image]

Gets or sets the Brush used to fill shape icons.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBrush As Brush

Property Value

A System.Windows.Media.Brush instance. The default value is Brushes.White.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeListBox.ShapeSize Property

ShapeListBox.ShapeSize Property
[image]

Gets or sets the size of shape icons.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

A double value specifying the shape size. The default is 32.

See Also

ShapeListBox Members
ShapeListBox Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Class

ShapeNode Class
Remarks See Also
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ShapeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

A ShapeNode instance might represent nodes in graphs, tree, process diagrams, and so on.

The shape of a node is specified by the Shape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Shape nodes can display images and text. Set an image to be painted inside a node by assigning it to the Image property. The position of the image within the node as well as its alignment are set by the ImageAlign property. To make a node as big as its image, call ResizeToFitImage.

Text inside a shape node is represented by the Text property. Its attributes can be changed by using the TextBrush and TextFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the raw text. Text can be laid out inside arbitrary polygonal shapes by enabling PolygonalTextLayout. To make a node big enough to display its text without clipping, call ResizeToFitText.

To let users edit a node's text inline, call the BeginEdit method of Diagram. Call EndEdit to exit in-place editing mode.

Fill and border colors can be specified by setting the Pen and Brush properties. Shape nodes can be transparent as set by the Transparent property.

Shape nodes can have incoming and outgoing DiagramLink objects, which are accessible through the IncomingLinks and OutgoingLinks properties defined in the DiagramNode class.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.ShapeNode

See Also

ShapeNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Members

ShapeNode Members
Constructors Fields Properties Methods
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Overloaded.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
ClipTextProperty | Identifies the ClipText dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextRotationAngleProperty | Identifies the TextRotationAngle dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowFlip | Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
ClipImage | Gets or sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.
ClipText | Gets or sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FlipX | Gets or sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Gets or sets a value indicating whether the node's shape is flipped vertically.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImagePadding | Gets or sets the padding distance between node's borders and Image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a flag indicating whether node's Text is formatted in non-rectangular outline.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextLines | Returns the lines of text as displayed by this node, wrapped to fit the content of its Text property inside node's current size.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextRotationAngle | Gets or sets the text rotation angle of this node.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Finds the intersection of the node contour with the line segment defined by the specified points.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateShapeControlPoints | Updates ShapeControlPoint objects associated with the node's Shape.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override.
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override.
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
Dispose | Disposes any disposable resources managed by this shape.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or performing undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override.

See Also

ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Fields

ShapeNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
ClipTextProperty | Identifies the ClipText dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextRotationAngleProperty | Identifies the TextRotationAngle dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ClipTextProperty Field

ShapeNode.ClipTextProperty Field
[image]

Identifies the ClipText dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipTextProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ImagePaddingProperty Field

ShapeNode.ImagePaddingProperty Field
[image]

Identifies the ImagePadding dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImagePaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImagePaddingProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.TextRotationAngleProperty Field

ShapeNode.TextRotationAngleProperty Field
[image]

Identifies the TextRotationAngle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TextRotationAngleProperty

Visual Basic [image] Copy Code

Public Shared TextRotationAngleProperty As DependencyProperty

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Constructor

ShapeNode Constructor
[image]

Overload List

Name | Description
ShapeNode () | Initializes a new instance of the ShapeNode class.
ShapeNode (Diagram) | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.
ShapeNode (ShapeNode) | Initializes a new instance of the ShapeNode class using the specified node as a prototype.

See Also

ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Constructor ()

ShapeNode Constructor ()
See Also
[image]

Initializes a new instance of the ShapeNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Constructor (Diagram)

ShapeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Constructor (ShapeNode)

ShapeNode Constructor (ShapeNode)
See Also
[image]

Initializes a new instance of the ShapeNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNode (
ShapeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ShapeNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Constructor Overload List
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Methods

ShapeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Finds the intersection of the node contour with the line segment defined by the specified points.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes the shape node as big as the image it displays.
ResizeToFitText | Makes the shape node big enough to display its text without clipping.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
UpdateShapeControlPoints | Updates ShapeControlPoint objects associated with the node's Shape.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramNode.AllowModify override.
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramNode.CompleteModify override.
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
Dispose | Disposes any disposable resources managed by this shape.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or performing undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramNode.UpdateModify override.

See Also

ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.AllowModify Method

ShapeNode.AllowModify Method
[image]

DiagramNode.AllowModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool AllowModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Function AllowModify( _
current As Point, _
ist As InteractionState _
) As Boolean

Parameters

current

The current mouse pointer position.

ist

An InteractionState object containing more information about the current state of the operation.

Return Value

true to allow the modification of this node; otherwise, false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.CompleteModify Method

ShapeNode.CompleteModify Method
[image]

DiagramNode.CompleteModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void CompleteModify (
Point end,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub CompleteModify( _
end As Point, _
ist As InteractionState _
)

Parameters

end

The mouse pointer position.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ContainsPoint Method

ShapeNode.ContainsPoint Method
[image]

Overload List

Name | Description
ShapeNode.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
ShapeNode.ContainsPoint (Point, Double) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ContainsPoint Method (Point)

ShapeNode.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point diagramPoint
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
diagramPoint As Point _
) As Boolean

Parameters

diagramPoint

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ContainsPoint Method (Point, Double)

ShapeNode.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point diagramPoint,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
diagramPoint As Point, _
threshold As Double _
) As Boolean

Parameters

diagramPoint

threshold

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.CreateConnectionPoint Method

ShapeNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that will be connected to this node.
pt

The point at which the link should be connected.

incoming
true if the link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.CreateProperties Method

ShapeNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.CreateState Method

ShapeNode.CreateState Method
[image]

DiagramNode.CreateState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.Dispose Method

ShapeNode.Dispose Method
[image]

Disposes any disposable resources managed by this shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.Draw Method

ShapeNode.Draw Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.DrawHandles Method

ShapeNode.DrawHandles Method
[image]

DiagramNode.DrawHandles override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawHandles (
DrawingContext graphics,
HandlesVisualStyle hstyle
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As DrawingContext, _
hstyle As HandlesVisualStyle _
)

Parameters

graphics

The DrawingContext surface to draw the handles on.

hstyle

The style that should be used to render the handles.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.DrawLocal Method

ShapeNode.DrawLocal Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.EnumStyleableProperties Method

ShapeNode.EnumStyleableProperties Method
[image]

DiagramNode.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.GetIntersection Method

ShapeNode.GetIntersection Method
[image]

Finds the intersection of the node contour with the line segment defined by the specified points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.GetRegion Method

ShapeNode.GetRegion Method
[image]

DiagramItem.GetRegion override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Geometry GetRegion ()

Visual Basic [image] Copy Code

Public Overrides Function GetRegion () As Geometry

Return Value

An instance of the WPF Geometry class.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.GetRepaintRect Method

ShapeNode.GetRepaintRect Method
[image]

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.HitTestHandle Method

ShapeNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override. Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.LoadFromXml Method

ShapeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.XML.XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnAdd Method

ShapeNode.OnAdd Method
[image]

Called when the item is added to a Diagram, either by users, programmatically or performing undo / redo.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnLoad Method

ShapeNode.OnLoad Method
[image]

Called after the item is deserialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnMeasureUnitChanged Method

ShapeNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnTextAttributeChanged Method

ShapeNode.OnTextAttributeChanged Method
[image]

DiagramItem.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnUpdateBounds Method

ShapeNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.OnZoomChanged Method

ShapeNode.OnZoomChanged Method
[image]

Called when the Diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.ResizeToFitImage Method

ShapeNode.ResizeToFitImage Method
[image]

Makes the shape node as big as the image it displays.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a shape node exactly the same size as the image it contains.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
ResizeToFitText Method


MindFusion.Diagramming.Wpf.ShapeNode.ResizeToFitText Method

ShapeNode.ResizeToFitText Method
[image]

Makes the shape node big enough to display its text without clipping.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ResizeToFitText (
FitSize fit
)

Visual Basic [image] Copy Code

Public Function ResizeToFitText( _
fit As FitSize _
) As Boolean

Parameters

fit
A member of the FitSize enumeration specifying whether the width or height of the node should remain unchanged.

Return Value

true if the node is resized successfully; otherwise, false.

Example

The following sample resizes a node to fit its text, using 1:1 width to height ratio.

C# [image] Copy Code

r = new Rect(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10);

shapeNode.PolygonalTextLayout = true;
shapeNode.Bounds = r;
shapeNode.Text = "the method changes both the box' width" +
"and height, maintaining their original ratio.";
shapeNode.ResizeToFitText(FitSize.KeepRatio);

Visual Basic [image] Copy Code

r = New Rect(shapeNode.Bounds.Left, shapeNode.Bounds.Top, 10, 10)

shapeNode.PolygonalTextLayout = True
shapeNode.Bounds = r
shapeNode.Text = "the method changes both the box' width" + _
"and height, maintaining their original ratio."
shapeNode.ResizeToFitText(FitSize.KeepRatio)

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Text Property
ResizeToFitImage Method


MindFusion.Diagramming.Wpf.ShapeNode.RestoreProperties Method

ShapeNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.RestoreState Method

ShapeNode.RestoreState Method
[image]

DiagramNode.RestoreState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.SaveProperties Method

ShapeNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.SaveState Method

ShapeNode.SaveState Method
[image]

DiagramNode.SaveState override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.SaveToXml Method

ShapeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.Xml.XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.StartModify Method

ShapeNode.StartModify Method
[image]

DiagramNode.StartModify override. Invoked when the user starts modifying this item interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void StartModify (
Point org,
AdjustmentHandle handle,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub StartModify( _
org As Point, _
handle As AdjustmentHandle, _
ist As InteractionState _
)

Parameters

org

Position of the mouse pointer.

handle

The adjustment handle used to modify this node.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.UpdateModify Method

ShapeNode.UpdateModify Method
[image]

DiagramNode.UpdateModify override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateModify (
Point current,
InteractionState ist
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateModify( _
current As Point, _
ist As InteractionState _
)

Parameters

current

Position of the mouse pointer.

ist

An InteractionState object containing more information about the current state of the operation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.UpdateShapeControlPoints Method

ShapeNode.UpdateShapeControlPoints Method
[image]

Updates ShapeControlPoint objects associated with the node's Shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateShapeControlPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateShapeControlPoints ()

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode Properties

ShapeNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowFlip | Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
ClipImage | Gets or sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.
ClipText | Gets or sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FlipX | Gets or sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Gets or sets a value indicating whether the node's shape is flipped vertically.
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImagePadding | Gets or sets the padding distance between node's borders and Image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
PlainText | Gets the plain text of this shape node.
PolygonalTextLayout | Gets or sets a flag indicating whether node's Text is formatted in non-rectangular outline.
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextLines | Returns the lines of text as displayed by this node, wrapped to fit the content of its Text property inside node's current size.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextRotationAngle | Gets or sets the text rotation angle of this node.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.AllowFlip Property

ShapeNode.AllowFlip Property
[image]

Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowFlip { get; set; }

Visual Basic [image] Copy Code

Public Property AllowFlip As Boolean

Property Value

true to let users flip the shape, or false otherwise. The default value is false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
FlipX Property
FlipY Property


MindFusion.Diagramming.Wpf.ShapeNode.ClipImage Property

ShapeNode.ClipImage Property
[image]

Gets or sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ClipImage { get; set; }

Visual Basic [image] Copy Code

Public Property ClipImage As Boolean

Property Value

true to clip the Image, otherwise false; the default value if true.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
RotateImage Property


MindFusion.Diagramming.Wpf.ShapeNode.ClipText Property

ShapeNode.ClipText Property
[image]

Gets or sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ClipText { get; set; }

Visual Basic [image] Copy Code

Public Property ClipText As Boolean

Property Value

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.CustomDraw Property

ShapeNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this shape node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of ShapeCustomDraw.

Remarks

This property allows invoking custom painting code for a shape node. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the shape node entirely, or do that in addition to what MindFusion.Diagramming for WPF paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for WPF.
Additional | The custom painting code executes after the node interior and frame are painted by MindFusion.Diagramming for WPF, but before text is rendered. In this mode, the DrawingContext instance passed to the custom drawing event handler has a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of the node is done by the application.
ShadowOnly | Only the shadow of the node is painted by custom code, the node itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the node are painted by MindFusion.Diagramming for WPF. In this mode, the DrawingContext instance passed to the custom drawing event handler doesn't have a clipping region applied to it.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.EnableStyledText Property

ShapeNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the node's text in order to find formatting tags; otherwise, false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

Styled text can be enabled only if PolygonalTextLayout is set to true. If enabled, Text is parsed and analyzed each time it is changed. Parsing determines what formatting tags are used and adds the corresponding attribute records to MindFusion.Wpf Package's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

Example

The following sample code demonstrates how to use styled text:

C# [image] Copy Code
shapeNode.PolygonalTextLayout = true;
shapeNode.EnableStyledText = true;
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub>\n" +
"<b><color=#0088FF>methylene-chloride</b>";
Visual Basic [image] Copy Code
shapeNode.PolygonalTextLayout = True
shapeNode.EnableStyledText = True
shapeNode.Text = "CH<sub>2</sub>CL<sub>2</sub> " + vbNewLine + _
"<b><color=#0088FF>methylene-chloride</b>"

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
TextFormat Property


MindFusion.Diagramming.Wpf.ShapeNode.FlipX Property

ShapeNode.FlipX Property
[image]

Gets or sets a value indicating whether the node's shape is flipped horizontally.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool FlipX { get; set; }

Visual Basic [image] Copy Code

Public Property FlipX As Boolean

Property Value

true if the shape is flipped horizontally, or false otherwise.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
FlipY Property
AllowFlip Property


MindFusion.Diagramming.Wpf.ShapeNode.FlipY Property

ShapeNode.FlipY Property
[image]

Gets or sets a value indicating whether the node's shape is flipped vertically.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool FlipY { get; set; }

Visual Basic [image] Copy Code

Public Property FlipY As Boolean

Property Value

true if the shape is flipped vertically, or false otherwise.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
FlipX Property
AllowFlip Property


MindFusion.Diagramming.Wpf.ShapeNode.Image Property

ShapeNode.Image Property
[image]

Gets or sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class. The default value is null (Nothing in Visual Basic).

Remarks

This property lets you display an image inside the node. The ImageRectangle attribute of the shape definition specifies a rectangular area inside the node in which the image is displayed. Use the ImageAlign property to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

If there isn't any image assigned to this property, the shape node displays the Image specified in its Shape template.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
RotateImage Property
ResizeToFitImage Method
ImagePadding Property


MindFusion.Diagramming.Wpf.ShapeNode.ImageAlign Property

ShapeNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default is Center.

Remarks

This property specifies how the Image is aligned to the bounding rectangle of this node. The image is aligned relatively to the rectangle specified in the ImageRectangle attribute of the Shape definition.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Image Property
ImagePadding Property


MindFusion.Diagramming.Wpf.ShapeNode.ImagePadding Property

ShapeNode.ImagePadding Property
[image]

Gets or sets the padding distance between node's borders and Image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Thickness

Property Value

A System.Windows.Thickness specifying the padding size.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Property


MindFusion.Diagramming.Wpf.ShapeNode.PlainText Property

ShapeNode.PlainText Property
[image]

Gets the plain text of this shape node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string PlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the shape node.

Remarks

This property removes any formatting tags from the node's Text and returns the plain human-readable text.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
EnableStyledText Property


MindFusion.Diagramming.Wpf.ShapeNode.PolygonalTextLayout Property

ShapeNode.PolygonalTextLayout Property
[image]

Gets or sets a flag indicating whether node's Text is formatted in non-rectangular outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PolygonalTextLayout { get; set; }

Visual Basic [image] Copy Code

Public Property PolygonalTextLayout As Boolean

Property Value

true to enable polygonal formatting; false to disable it.

Remarks

The node's area in which text is rendered can be explicitly defined for each Shape definition, and if it is not specified, the shape outline is used implicitly. The formatting algorithm is designed to layout text inside polygonal outlines. A polygonal approximation is created for outlines that have curved segments, so text can be laid out in shapes that consist of Bezier curves too.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Text Property
EnableStyledText Property
Shape Property


MindFusion.Diagramming.Wpf.ShapeNode.RotateImage Property

ShapeNode.RotateImage Property
[image]

Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RotateImage { get; set; }

Visual Basic [image] Copy Code

Public Property RotateImage As Boolean

Property Value

true to rotate the node's image; otherwise, false. The default is true.

Remarks

The image is clipped by the rotated shape outline, even if this property is set to false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
RotationAngle Property
RotateText Property
ClipImage Property


MindFusion.Diagramming.Wpf.ShapeNode.RotateText Property

ShapeNode.RotateText Property
[image]

Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RotateText { get; set; }

Visual Basic [image] Copy Code

Public Property RotateText As Boolean

Property Value

true to rotate the node's text; otherwise, false. The default is false.

Remarks

If the property is set to false and PolygonalTextLayout is enabled, the text stays horizontal but it adapts to the rotated outline of the shape node.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
RotationAngle Property
RotateImage Property


MindFusion.Diagramming.Wpf.ShapeNode.Shape Property

ShapeNode.Shape Property
[image]

Gets or sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the Shape class.

Remarks

Use this property to assign a complex shape to a node. Complex shapes consist of outlines, decorations and text-region definitions that can be defined as series of lines, arcs and curves. To define a custom shape, create an instance of the Shape class. That class also provides 87 predefined shapes exposed by the Shapes collection.

Example

The following sample code illustrates how to use the predefined shapes and how to create your own custom shapes.

C# [image] Copy Code

private void example_Click(object sender, RoutedEventArgs e)
{
ShapeNode shapeNode0 = diagram.Nodes[0] as ShapeNode;
ShapeNode shapeNode1 = diagram.Nodes[1] as ShapeNode;

// Use one of the predefined shapes
shapeNode0.Shape = Shapes.MultiDocument;

// Create a custom shape
shapeNode1.Shape = new Shape(
new ElementTemplate[] {
new LineTemplate(0, 100, 60, 100),
new BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50),
new BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0),
new LineTemplate(60, 0, 0, 0),
new LineTemplate(0, 0, 0, 100) },
FillRule.EvenOdd);
}

Visual Basic [image] Copy Code

Private Sub example_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs) Handles example.Click

Dim shapeNode0 As ShapeNode = CType(diagram.Nodes(0), ShapeNode)
Dim shapeNode1 As ShapeNode = CType(diagram.Nodes(1), ShapeNode)

' Use one of the predefined shapes
shapeNode0.Shape = Shapes.MultiDocument

' Create a custom shape
shapeNode1.Shape = New Shape( _
New ElementTemplate() { _
New LineTemplate(0, 100, 60, 100), _
New BezierTemplate(60, 100, 80, 100, 100, 75, 100, 50), _
New BezierTemplate(100, 50, 100, 25, 80, 0, 60, 0), _
New LineTemplate(60, 0, 0, 0), _
New LineTemplate(0, 0, 0, 100)}, _
FillRule.EvenOdd)

End Sub

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Shape.FromId Method
Shape.Shapes Property
PolygonalTextLayout Property
AllowFlip Property
ShapeOrientation Property


MindFusion.Diagramming.Wpf.ShapeNode.ShapeOrientation Property

ShapeNode.ShapeOrientation Property
[image]

Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Double

Property Value

A double value specifying the orientation angle in degrees. Initialized with the value of ShapeOrientation.

Remarks

That property does not rotate the node, that is, does not rotate the bounding rectangle of the node around its center. It specifies a rotation transformation to be performed on the definition of the Shape when it is applied to a node; the node's bounding rectangle (location, width and height) remain intact. In the current MindFusion.Diagramming for WPF version, only 0, 90, 180 or 270 can be set as value of ShapeOrientation.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Shape Property
RotationAngle Property


MindFusion.Diagramming.Wpf.ShapeNode.TextFormat Property

ShapeNode.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

This property has been deprecated. Set the TextAlignment and TextVerticalAlignment properties to specify text alignment.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.TextLines Property

ShapeNode.TextLines Property
[image]

Returns the lines of text as displayed by this node, wrapped to fit the content of its Text property inside node's current size.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public List<string> TextLines { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextLines As List(Of String)

Property Value

A list of strings representing the text lines.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.TextRotationAngle Property

ShapeNode.TextRotationAngle Property
[image]

Gets or sets the text rotation angle of this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TextRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property TextRotationAngle As Double

Property Value

A double value specifying the text rotation angle. The default value is 0.

Remarks

Text rotation works best when PolygonalTextLayout or EnableStyledText is set to true.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNode.Transparent Property

ShapeNode.Transparent Property
[image]

Gets or sets a value indicating whether this shape node is transparent.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Transparent { get; set; }

Visual Basic [image] Copy Code

Public Property Transparent As Boolean

Property Value

true if the shape node is transparent; otherwise, false. The default is false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming.Wpf Namespace
Visible Property


MindFusion.Diagramming.Wpf.ShapeNodeProperties Class

ShapeNodeProperties Class
[image]

Stores the values of ShapeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the ShapeNode.SaveProperties, ShapeNode.RestoreProperties, and ShapeNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ShapeNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.ShapeNodeProperties

See Also

ShapeNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeProperties Members

ShapeNodeProperties Members
Constructors Methods
[image]

Stores the values of ShapeNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the ShapeNode.SaveProperties, ShapeNode.RestoreProperties, and ShapeNode.CreateProperties methods.

The following tables list the members exposed by the ShapeNodeProperties type.

Public Constructors

Name | Description
ShapeNodeProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

ShapeNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeProperties Constructor

ShapeNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeProperties Methods

ShapeNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

ShapeNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeState Class

ShapeNodeState Class
[image]

Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ShapeNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class ShapeNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemState
MindFusion.Diagramming.Wpf.DiagramNodeState
MindFusion.Diagramming.Wpf.ShapeNodeState

See Also

ShapeNodeState Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeState Members

ShapeNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a ShapeNode. Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from ShapeNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from ShapeNodeState and overriding the ShapeNode.CreateState, ShapeNode.SaveState and ShapeNode.RestoreState methods.

The following tables list the members exposed by the ShapeNodeState type.

Public Constructors

Name | Description
ShapeNodeState | Initializes a new instance of the ShapeNodeState class.

See Also

ShapeNodeState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShapeNodeState Constructor

ShapeNodeState Constructor
[image]

Initializes a new instance of the ShapeNodeState class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ShapeNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeState Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes Class

Shapes Class
Remarks See Also
[image]

Provides alternative method of access to the MindFusion.Diagramming for WPF predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Shapes

Visual Basic [image] Copy Code

Public Class Shapes

Remarks

The accessor properties are generating using the following code:

C# [image] Copy Code

TextWriter writer = new StreamWriter(@"D:\shapes.txt");
foreach (Shape shape in Shape.Shapes)
{
writer.WriteLine("static public Shape " + shape.Id);
writer.WriteLine("{");
writer.WriteLine("\tget { return Shape.FromId(\"" + shape.Id + "\"); }");
writer.WriteLine("}");
writer.WriteLine();
writer.Flush();
}

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Shapes

See Also

Shapes Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes Members

Shapes Members
Properties
[image]

Provides alternative method of access to the MindFusion.Diagramming for WPF predefined shapes, that allows code completion and IntelliSense support, which is not available when using Shape.FromId.

The following tables list the members exposed by the Shapes type.

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes Properties

Shapes Properties
[image]

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Actor Property

Shapes.Actor Property
[image]

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Actor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Actor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Alternative Property

Shapes.Alternative Property
[image]

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Alternative { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alternative As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow1 Property

Shapes.Arrow1 Property
[image]

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow1 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow2 Property

Shapes.Arrow2 Property
[image]

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow3 Property

Shapes.Arrow3 Property
[image]

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow3 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow4 Property

Shapes.Arrow4 Property
[image]

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow4 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow5 Property

Shapes.Arrow5 Property
[image]

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow5 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow6 Property

Shapes.Arrow6 Property
[image]

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow6 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow7 Property

Shapes.Arrow7 Property
[image]

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow7 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow8 Property

Shapes.Arrow8 Property
[image]

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow8 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Arrow9 Property

Shapes.Arrow9 Property
[image]

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Arrow9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow9 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BeginLoop Property

Shapes.BeginLoop Property
[image]

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BeginLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BeginLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnComplex Property

Shapes.BpmnComplex Property
[image]

Gets the BpmnComplex predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnComplex { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnComplex As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnDataBasedXor Property

Shapes.BpmnDataBasedXor Property
[image]

Gets the BpmnDataBasedXor predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnDataBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnDataBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndCancel Property

Shapes.BpmnEndCancel Property
[image]

Gets the BpmnEndCancel predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndCompensation Property

Shapes.BpmnEndCompensation Property
[image]

Gets the BpmnEndCompensation predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndError Property

Shapes.BpmnEndError Property
[image]

Gets the BpmnEndError predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndError As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndLink Property

Shapes.BpmnEndLink Property
[image]

Gets the BpmnEndLink predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndLink As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndMessage Property

Shapes.BpmnEndMessage Property
[image]

Gets the BpmnEndMessage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndMultiple Property

Shapes.BpmnEndMultiple Property
[image]

Gets the BpmnEndMultiple predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEndTerminate Property

Shapes.BpmnEndTerminate Property
[image]

Gets the BpmnEndTerminate predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEndTerminate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndTerminate As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnEventBasedXor Property

Shapes.BpmnEventBasedXor Property
[image]

Gets the BpmnEventBasedXor predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnEventBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEventBasedXor As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnInclusive Property

Shapes.BpmnInclusive Property
[image]

Gets the BpmnInclusive predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnInclusive { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnInclusive As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateCancel Property

Shapes.BpmnIntermediateCancel Property
[image]

Gets the BpmnIntermediateCancel predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCancel As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateCompensation Property

Shapes.BpmnIntermediateCompensation Property
[image]

Gets the BpmnIntermediateCompensation predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCompensation As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateError Property

Shapes.BpmnIntermediateError Property
[image]

Gets the BpmnIntermediateError predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateError As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateLink Property

Shapes.BpmnIntermediateLink Property
[image]

Gets the BpmnIntermediateLink predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateLink As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateMessage Property

Shapes.BpmnIntermediateMessage Property
[image]

Gets the BpmnIntermediateMessage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateMultiple Property

Shapes.BpmnIntermediateMultiple Property
[image]

Gets the BpmnIntermediateMultiple predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateRule Property

Shapes.BpmnIntermediateRule Property
[image]

Gets the BpmnIntermediateRule predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateRule As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnIntermediateTimer Property

Shapes.BpmnIntermediateTimer Property
[image]

Gets the BpmnIntermediateTimer predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnParallelFork Property

Shapes.BpmnParallelFork Property
[image]

Gets the BpmnParallelFork predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnParallelFork { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnParallelFork As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnStartLink Property

Shapes.BpmnStartLink Property
[image]

Gets the BpmnStartLink predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnStartLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartLink As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnStartMessage Property

Shapes.BpmnStartMessage Property
[image]

Gets the BpmnStartMessage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnStartMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMessage As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnStartMultiple Property

Shapes.BpmnStartMultiple Property
[image]

Gets the BpmnStartMultiple predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnStartMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMultiple As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnStartRule Property

Shapes.BpmnStartRule Property
[image]

Gets the BpmnStartRule predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnStartRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartRule As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.BpmnStartTimer Property

Shapes.BpmnStartTimer Property
[image]

Gets the BpmnStartTimer predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape BpmnStartTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartTimer As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Cloud Property

Shapes.Cloud Property
[image]

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Cloud { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cloud As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Collate Property

Shapes.Collate Property
[image]

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Collate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Collate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ConeDown Property

Shapes.ConeDown Property
[image]

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ConeDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ConeUp Property

Shapes.ConeUp Property
[image]

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ConeUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ConnectedIssues Property

Shapes.ConnectedIssues Property
[image]

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ConnectedIssues { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConnectedIssues As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.CreateRequest Property

Shapes.CreateRequest Property
[image]

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape CreateRequest { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CreateRequest As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Cross Property

Shapes.Cross Property
[image]

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Cross { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cross As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Cube Property

Shapes.Cube Property
[image]

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Cube { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cube As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Cylinder Property

Shapes.Cylinder Property
[image]

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Cylinder { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cylinder As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Database Property

Shapes.Database Property
[image]

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Database { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Database As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DataTransmition Property

Shapes.DataTransmition Property
[image]

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DataTransmition { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DataTransmition As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DDelay Property

Shapes.DDelay Property
[image]

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Decagon Property

Shapes.Decagon Property
[image]

Gets the Decagon predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Decagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decagon As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Decision Property

Shapes.Decision Property
[image]

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Decision { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Decision2 Property

Shapes.Decision2 Property
[image]

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Decision2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Delay Property

Shapes.Delay Property
[image]

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Delay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DInDelay Property

Shapes.DInDelay Property
[image]

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DInDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DInDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DirectAccessStorage Property

Shapes.DirectAccessStorage Property
[image]

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DirectAccessStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DirectAccessStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DiskStorage Property

Shapes.DiskStorage Property
[image]

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DiskStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DiskStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Display Property

Shapes.Display Property
[image]

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Display { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Display As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DividedEvent Property

Shapes.DividedEvent Property
[image]

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DividedEvent { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedEvent As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DividedProcess Property

Shapes.DividedProcess Property
[image]

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DividedProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Document Property

Shapes.Document Property
[image]

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Document { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Document As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Donut Property

Shapes.Donut Property
[image]

Gets the Donut predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Donut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Donut As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.DOutDelay Property

Shapes.DOutDelay Property
[image]

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape DOutDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DOutDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Ellipse Property

Shapes.Ellipse Property
[image]

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Ellipse { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ellipse As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.EndLoop Property

Shapes.EndLoop Property
[image]

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape EndLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property EndLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ExternalOrganization Property

Shapes.ExternalOrganization Property
[image]

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ExternalOrganization { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalOrganization As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ExternalProcess Property

Shapes.ExternalProcess Property
[image]

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ExternalProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.File Property

Shapes.File Property
[image]

Gets the File predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape File { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property File As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.FramedRectangle Property

Shapes.FramedRectangle Property
[image]

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape FramedRectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property FramedRectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Gate Property

Shapes.Gate Property
[image]

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Gate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Gate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Heart Property

Shapes.Heart Property
[image]

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Heart { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heart As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Heptagon Property

Shapes.Heptagon Property
[image]

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Heptagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heptagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Hourglass Property

Shapes.Hourglass Property
[image]

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Hourglass { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Hourglass As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Input Property

Shapes.Input Property
[image]

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Input { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Input As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.InternalStorage Property

Shapes.InternalStorage Property
[image]

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape InternalStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property InternalStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Interrupt Property

Shapes.Interrupt Property
[image]

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Interrupt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Interrupt2 Property

Shapes.Interrupt2 Property
[image]

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Interrupt2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.IsoProcess Property

Shapes.IsoProcess Property
[image]

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape IsoProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property IsoProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Junction Property

Shapes.Junction Property
[image]

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Junction { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Junction As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Lightning Property

Shapes.Lightning Property
[image]

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Lightning { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lightning As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.LinedDocument Property

Shapes.LinedDocument Property
[image]

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape LinedDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LinedDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.ManualOperation Property

Shapes.ManualOperation Property
[image]

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape ManualOperation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ManualOperation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Merge Property

Shapes.Merge Property
[image]

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Merge { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Merge As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MessageFromUser Property

Shapes.MessageFromUser Property
[image]

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MessageFromUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageFromUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MessageToUser Property

Shapes.MessageToUser Property
[image]

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MessageToUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageToUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Microform Property

Shapes.Microform Property
[image]

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Microform { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Microform As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MicroformProcessing Property

Shapes.MicroformProcessing Property
[image]

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MicroformProcessing { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformProcessing As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MicroformRecording Property

Shapes.MicroformRecording Property
[image]

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MicroformRecording { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformRecording As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MultiDocument Property

Shapes.MultiDocument Property
[image]

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MultiDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.MultiProc Property

Shapes.MultiProc Property
[image]

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape MultiProc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiProc As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Octagon Property

Shapes.Octagon Property
[image]

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Octagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Octagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.OfflineStorage Property

Shapes.OfflineStorage Property
[image]

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape OfflineStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OfflineStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.OffpageConnection Property

Shapes.OffpageConnection Property
[image]

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape OffpageConnection { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageConnection As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.OffpageReference Property

Shapes.OffpageReference Property
[image]

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape OffpageReference { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageReference As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Or Property

Shapes.Or Property
[image]

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Or { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Or As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Pentagon Property

Shapes.Pentagon Property
[image]

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Pentagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Plaque Property

Shapes.Plaque Property
[image]

Gets the Plaque predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Plaque { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Plaque As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.PrimitiveFromCall Property

Shapes.PrimitiveFromCall Property
[image]

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PrimitiveFromCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveFromCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.PrimitiveToCall Property

Shapes.PrimitiveToCall Property
[image]

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PrimitiveToCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveToCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Procedure Property

Shapes.Procedure Property
[image]

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Procedure { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Procedure As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Process Property

Shapes.Process Property
[image]

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Process { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Process As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Prysm Property

Shapes.Prysm Property
[image]

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Prysm { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Prysm As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.PunchedCard Property

Shapes.PunchedCard Property
[image]

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PunchedCard { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PunchedCard As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.PyramidDown Property

Shapes.PyramidDown Property
[image]

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PyramidDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.PyramidUp Property

Shapes.PyramidUp Property
[image]

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape PyramidUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Rectangle Property

Shapes.Rectangle Property
[image]

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Rectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Rectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.RightTriangle Property

Shapes.RightTriangle Property
[image]

Gets the RightTriangle predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RightTriangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RightTriangle As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.RoundRect Property

Shapes.RoundRect Property
[image]

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RoundRect { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RoundRect As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.RSave Property

Shapes.RSave Property
[image]

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape RSave { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RSave As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Save Property

Shapes.Save Property
[image]

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Save { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Save As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Sort Property

Shapes.Sort Property
[image]

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Sort { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sort As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Sphere Property

Shapes.Sphere Property
[image]

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Sphere { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sphere As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star Property

Shapes.Star Property
[image]

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star16Pointed Property

Shapes.Star16Pointed Property
[image]

Gets the Star16Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star16Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star16Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star24Pointed Property

Shapes.Star24Pointed Property
[image]

Gets the Star24Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star24Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star24Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star32Pointed Property

Shapes.Star32Pointed Property
[image]

Gets the Star32Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star32Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star32Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star4Pointed Property

Shapes.Star4Pointed Property
[image]

Gets the Star4Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star4Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star4Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star5Pointed Property

Shapes.Star5Pointed Property
[image]

Gets the Star5Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star5Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star5Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star6Pointed Property

Shapes.Star6Pointed Property
[image]

Gets the Star6Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star6Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star6Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Star7Pointed Property

Shapes.Star7Pointed Property
[image]

Gets the Star7Pointed predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Star7Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star7Pointed As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Start Property

Shapes.Start Property
[image]

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Start { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Start As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Tape Property

Shapes.Tape Property
[image]

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Tape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Terminator Property

Shapes.Terminator Property
[image]

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Terminator { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Terminator As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.TransmittalTape Property

Shapes.TransmittalTape Property
[image]

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape TransmittalTape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TransmittalTape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Shapes.Trapezoid Property

Shapes.Trapezoid Property
[image]

Gets the Trapezoid predefined shape.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Shape Trapezoid { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Trapezoid As Shape

Property Value

See Also

Shapes Members
Shapes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.ShowAnchors Enumeration

ShowAnchors Enumeration
[image]

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ShowAnchors

Visual Basic [image] Copy Code

Public Enum ShowAnchors

Members

Member name | Description
Always | Anchor point marks are always painted.
Auto | Anchor point marks are shown for the node under the mouse cursor.
Never | Anchor point marks are never painted.
Selected | Anchor point marks are painted for the selected node.

Remarks

Members of this enumeration are used as values of the ShowAnchors property of the Diagram class. Auto and Selected can be combined using the bitwise or operator.

See Also

MindFusion.Diagramming.Wpf Namespace
ShowAnchors Property
MarkStyle Enumeration


MindFusion.Diagramming.Wpf.SimpleShape Enumeration

SimpleShape Enumeration
[image]

Defines the possible values for the Shape property of tables, tree views and containers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SimpleShape

Visual Basic [image] Copy Code

Public Enum SimpleShape

Members

Member name | Description
Rectangle | Sets node's shape to rectangle.
RoundedRectangle | Sets node's shape to rounded rectangle.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SizeSyncMode Enumeration

SizeSyncMode Enumeration
[image]

Contains values that identify the possible ways to synchronize the size of a DiagramNodeAdapter node with the size of its hosted control.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SizeSyncMode

Visual Basic [image] Copy Code

Public Enum SizeSyncMode

Members

Member name | Description
Arrange | Resizing the node calls Arrange on the hosted element.
Measure | The node is resized automatically to match the element's DesiredSize.
SetSize | Resizing the node sets the hosted element's Width and Height properties.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.SnapToAnchor Enumeration

SnapToAnchor Enumeration
[image]

Specifies when link ends are snapped to nearest anchor points.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SnapToAnchor

Visual Basic [image] Copy Code

Public Enum SnapToAnchor

Members

Member name | Description
OnCreate | Snap to anchor point when creating a new link.
OnCreateOrModify | Snap to anchor point when creating or modifying a link.

Remarks

Members of this enumeration are used as values of the SnapToAnchor property of the Diagram class.

See Also

MindFusion.Diagramming.Wpf Namespace
SnapToAnchor Property
ShowAnchors Enumeration


MindFusion.Diagramming.Wpf.StringAlignment Enumeration

StringAlignment Enumeration
[image]

Replaces System.Drawing.StringAlignment

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum StringAlignment

Visual Basic [image] Copy Code

Public Enum StringAlignment

Members

Member name | Description
Center | Specifies that text is aligned in the center of the layout rectangle.
Far | Specifies that text is aligned far from the origin position of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | Specifies the text be aligned near the layout. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Class

StringFormat Class
[image]

Replaces System.Drawing.StringFormat

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class StringFormat : ICloneable

Visual Basic [image] Copy Code

Public Class StringFormat
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.StringFormat

See Also

StringFormat Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Members

StringFormat Members
Constructors Fields Properties Methods
[image]

Replaces System.Drawing.StringFormat

The following tables list the members exposed by the StringFormat type.

Public Constructors

Name | Description
StringFormat | Overloaded.

Public Fields

Name | Description
GenericDefault | Gets a generic default StringFormat object.
GenericTypographic | Gets a generic typographic StringFormat object.

Public Properties

Name | Description
Alignment | Gets or sets text alignment information on the vertical plane.
DigitSubstitutionLanguage | Gets or sets the language that is used when local digits are substituted for western digits.
FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
HotkeyPrefix | Gets or sets the HotkeyPrefix object for this StringFormat object.
LineAlignment | Gets or sets the line alignment on the horizontal plane.
Trimming | Gets or sets the StringTrimming enumeration for this StringFormat object.

Public Methods

Name | Description
Clone | Creates a new object that is a copy of the current instance.

See Also

StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Fields

StringFormat Fields
[image]

Public Fields

Name | Description
GenericDefault | Gets a generic default StringFormat object.
GenericTypographic | Gets a generic typographic StringFormat object.

See Also

StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.GenericDefault Field

StringFormat.GenericDefault Field
[image]

Gets a generic default StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static StringFormat GenericDefault

Visual Basic [image] Copy Code

Public Shared GenericDefault As StringFormat

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.GenericTypographic Field

StringFormat.GenericTypographic Field
[image]

Gets a generic typographic StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static StringFormat GenericTypographic

Visual Basic [image] Copy Code

Public Shared GenericTypographic As StringFormat

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Constructor

StringFormat Constructor
[image]

Overload List

Name | Description
StringFormat () | Initializes a new StringFormat object.
StringFormat (StringFormat) | Initializes a new StringFormat object.
StringFormat (StringFormatFlags) | Initializes a new StringFormat object.

See Also

StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Constructor ()

StringFormat Constructor ()
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringFormat Constructor Overload List
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Constructor (StringFormat)

StringFormat Constructor (StringFormat)
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat (
StringFormat sf
)

Visual Basic [image] Copy Code

Public New ( _
sf As StringFormat _
)

Parameters

sf

See Also

StringFormat Constructor Overload List
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Constructor (StringFormatFlags)

StringFormat Constructor (StringFormatFlags)
See Also
[image]

Initializes a new StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat (
StringFormatFlags flags
)

Visual Basic [image] Copy Code

Public New ( _
flags As StringFormatFlags _
)

Parameters

flags

See Also

StringFormat Constructor Overload List
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Methods

StringFormat Methods
[image]

Public Methods

Name | Description
Clone | Creates a new object that is a copy of the current instance.

See Also

StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.Clone Method

StringFormat.Clone Method
[image]

Creates a new object that is a copy of the current instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat Properties

StringFormat Properties
[image]

Public Properties

Name | Description
Alignment | Gets or sets text alignment information on the vertical plane.
DigitSubstitutionLanguage | Gets or sets the language that is used when local digits are substituted for western digits.
FormatFlags | Gets or sets a StringFormatFlags enumeration that contains formatting information.
HotkeyPrefix | Gets or sets the HotkeyPrefix object for this StringFormat object.
LineAlignment | Gets or sets the line alignment on the horizontal plane.
Trimming | Gets or sets the StringTrimming enumeration for this StringFormat object.

See Also

StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.Alignment Property

StringFormat.Alignment Property
[image]

Gets or sets text alignment information on the vertical plane.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringAlignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As StringAlignment

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.DigitSubstitutionLanguage Property

StringFormat.DigitSubstitutionLanguage Property
[image]

Gets or sets the language that is used when local digits are substituted for western digits.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int DigitSubstitutionLanguage { get; set; }

Visual Basic [image] Copy Code

Public Property DigitSubstitutionLanguage As Integer

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.FormatFlags Property

StringFormat.FormatFlags Property
[image]

Gets or sets a StringFormatFlags enumeration that contains formatting information.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormatFlags FormatFlags { get; set; }

Visual Basic [image] Copy Code

Public Property FormatFlags As StringFormatFlags

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.HotkeyPrefix Property

StringFormat.HotkeyPrefix Property
[image]

Gets or sets the HotkeyPrefix object for this StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HotkeyPrefix HotkeyPrefix { get; set; }

Visual Basic [image] Copy Code

Public Property HotkeyPrefix As HotkeyPrefix

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.LineAlignment Property

StringFormat.LineAlignment Property
[image]

Gets or sets the line alignment on the horizontal plane.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringAlignment LineAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LineAlignment As StringAlignment

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormat.Trimming Property

StringFormat.Trimming Property
[image]

Gets or sets the StringTrimming enumeration for this StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringTrimming Trimming { get; set; }

Visual Basic [image] Copy Code

Public Property Trimming As StringTrimming

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringFormatFlags Enumeration

StringFormatFlags Enumeration
[image]

Replaces System.Drawing.StringFormatFlags

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum StringFormatFlags

Visual Basic [image] Copy Code

Public Enum StringFormatFlags

Members

Member name | Description
DirectionRightToLeft | Text is displayed from right to left.
DirectionVertical | Text is vertically aligned.
DisplayFormatControl | Control characters such as the left-to-right mark are shown in the output with a representative glyph.
FitBlackBox | Parts of characters are allowed to overhang the string's layout rectangle. By default, characters are repositioned to avoid any overhang.
LineLimit | Only entire lines are laid out in the formatting rectangle. By default layout continues until the end of the text, or until no more lines are visible as a result of clipping, whichever comes first. Note that the default settings allow the last line to be partially obscured by a formatting rectangle that is not a whole multiple of the line height. To ensure that only whole lines are seen, specify this value and be careful to provide a formatting rectangle at least as tall as the height of one line.
MeasureTrailingSpaces | Includes the trailing space at the end of each line. By default the boundary rectangle returned by the MeasureString method excludes the space at the end of each line. Set this flag to include that space in measurement.
NoClip | Overhanging parts of glyphs, and unwrapped text reaching outside the formatting rectangle are allowed to show. By default all text and glyph parts reaching outside the formatting rectangle are clipped.
NoFontFallback | Fallback to alternate fonts for characters not supported in the requested font is disabled. Any missing characters are displayed with the fonts missing glyph, usually an open square.
NoWrap | Text wrapping between lines when formatting within a rectangle is disabled. This flag is implied when a point is passed instead of a rectangle, or when the specified rectangle has a zero line length.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.StringTrimming Enumeration

StringTrimming Enumeration
[image]

Replaces System.Drawing.StringTrimming

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum StringTrimming

Visual Basic [image] Copy Code

Public Enum StringTrimming

Members

Member name | Description
Character | Specifies that the text is trimmed to the nearest character.
EllipsisCharacter | Specifies that the text is trimmed to the nearest character, and an ellipsis is inserted at the end of a trimmed line.
EllipsisPath | The center is removed from trimmed lines and replaced by an ellipsis. The algorithm keeps as much of the last slash-delimited segment of the line as possible.
EllipsisWord | Specifies that text is trimmed to the nearest word, and an ellipsis is inserted at the end of a trimmed line.
None | Specifies no trimming.
Word | Specifies that text is trimmed to the nearest word.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Class

TabbedDiagramView Class
Remarks See Also
[image]

Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TabbedDiagramView : Control

Visual Basic [image] Copy Code

Public Class TabbedDiagramView
Inherits Control

Remarks

The appearance and behavior of the tab tray can be customized using various properties.

The ShowTabs property indicates whether the tray is visible. The location of the tray is specified through the TabAlignment property. ShowCreateNewTab and ShowTabNavigationButtons determine the visibility of the buttons for interactive tab creation and tab navigation respectively. ShowTabCloseButtons specifies whether the tabs can be closed interactively, by clicking on the small 'x' button displayed in each tab. AllowTabReorder enables interactive tab rearrangement by mouse dragging.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.TabbedDiagramView

See Also

TabbedDiagramView Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Members

TabbedDiagramView Members
Constructors Fields Properties Methods Events
[image]

Represents a control that can display DiagramDocument objects. The individual diagram pages can be activated through the tabs in the tray located at one of the view sides.

The following tables list the members exposed by the TabbedDiagramView type.

Public Constructors

Name | Description
TabbedDiagramView | Initializes a new instance of the TabbedDiagramView class.

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowTabReorderProperty | Identifies the AllowTabReorder dependency property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
DocumentProperty | Identifies the Document dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowTabCloseButtonsProperty | Identifies the ShowTabCloseButtons dependency property.
ShowTabNavigationButtonsProperty | Identifies the ShowTabNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.

Public Properties

Name | Description
AllowRenamePages | Gets or sets whether DiagramPage titles can be renamed interactively.
AllowTabReorder | Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.
CurrentPage | Gets or sets the currently active page. This is a dependency property.
Document | Gets or sets the displayed diagram document. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowTabCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowTabNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the tabs alignment. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnCurrentPageChanged | Raises the CurrentPageChanged event.
OnPageAdded | Raises the PageAdded event.
OnPageRemoved | Raises the PageRemoved event.
OnPageRemoving | Raises the PageRemoving event.
OnPageRenamed | Raises the PageRenamed event.

Public Events

Name | Description
CurrentPageChanged | Raised when the currently active page is changed.
PageAdded | Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
PageRemoved | Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.
PageRemoving | Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.
PageRenamed | Raised when the page has been renamed.

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Fields

TabbedDiagramView Fields
[image]

Public Fields

Name | Description
AllowRenamePagesProperty | Identifies the AllowRenamePages dependency property.
AllowTabReorderProperty | Identifies the AllowTabReorder dependency property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
DocumentProperty | Identifies the Document dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowTabCloseButtonsProperty | Identifies the ShowTabCloseButtons dependency property.
ShowTabNavigationButtonsProperty | Identifies the ShowTabNavigationButtons dependency property.
ShowTabsProperty | Identifies the ShowTabs dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.AllowRenamePagesProperty Field

TabbedDiagramView.AllowRenamePagesProperty Field
[image]

Identifies the AllowRenamePages dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowRenamePagesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowRenamePagesProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.AllowTabReorderProperty Field

TabbedDiagramView.AllowTabReorderProperty Field
[image]

Identifies the AllowTabReorder dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowTabReorderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowTabReorderProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.CurrentPageProperty Field

TabbedDiagramView.CurrentPageProperty Field
[image]

Identifies the CurrentPage dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentPageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentPageProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.DocumentProperty Field

TabbedDiagramView.DocumentProperty Field
[image]

Identifies the Document dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DocumentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DocumentProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowCreateNewTabProperty Field

TabbedDiagramView.ShowCreateNewTabProperty Field
[image]

Identifies the ShowCreateNewTab dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCreateNewTabProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCreateNewTabProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabCloseButtonsProperty Field

TabbedDiagramView.ShowTabCloseButtonsProperty Field
[image]

Identifies the ShowTabCloseButtons dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabCloseButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabCloseButtonsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabNavigationButtonsProperty Field

TabbedDiagramView.ShowTabNavigationButtonsProperty Field
[image]

Identifies the ShowTabNavigationButtons dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabNavigationButtonsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabsProperty Field

TabbedDiagramView.ShowTabsProperty Field
[image]

Identifies the ShowTabs dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTabsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTabsProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.TabAlignmentProperty Field

TabbedDiagramView.TabAlignmentProperty Field
[image]

Identifies the TabAlignment dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabAlignmentProperty As DependencyProperty

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Constructor

TabbedDiagramView Constructor
[image]

Initializes a new instance of the TabbedDiagramView class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TabbedDiagramView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Methods

TabbedDiagramView Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnCurrentPageChanged | Raises the CurrentPageChanged event.
OnPageAdded | Raises the PageAdded event.
OnPageRemoved | Raises the PageRemoved event.
OnPageRemoving | Raises the PageRemoving event.
OnPageRenamed | Raises the PageRenamed event.

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnApplyTemplate Method

TabbedDiagramView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnCurrentPageChanged Method

TabbedDiagramView.OnCurrentPageChanged Method
[image]

Raises the CurrentPageChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCurrentPageChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCurrentPageChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnPageAdded Method

TabbedDiagramView.OnPageAdded Method
[image]

Raises the PageAdded event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPageAdded (
DiagramPageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageAdded( _
e As DiagramPageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnPageRemoved Method

TabbedDiagramView.OnPageRemoved Method
[image]

Raises the PageRemoved event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPageRemoved (
DiagramPageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRemoved( _
e As DiagramPageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnPageRemoving Method

TabbedDiagramView.OnPageRemoving Method
[image]

Raises the PageRemoving event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPageRemoving (
DiagramPageValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRemoving( _
e As DiagramPageValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.OnPageRenamed Method

TabbedDiagramView.OnPageRenamed Method
[image]

Raises the PageRenamed event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPageRenamed (
PageRenamedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPageRenamed( _
e As PageRenamedEventArgs _
)

Parameters

e

A PageRenamedEventArgs instance providing more information about the event.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Properties

TabbedDiagramView Properties
[image]

Public Properties

Name | Description
AllowRenamePages | Gets or sets whether DiagramPage titles can be renamed interactively.
AllowTabReorder | Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.
CurrentPage | Gets or sets the currently active page. This is a dependency property.
Document | Gets or sets the displayed diagram document. This is a dependency property.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowTabCloseButtons | Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.
ShowTabNavigationButtons | Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.
ShowTabs | Gets or sets a value indicating whether the tabs are visible. This is a dependency property.
TabAlignment | Gets or sets the tabs alignment. This is a dependency property.

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.AllowRenamePages Property

TabbedDiagramView.AllowRenamePages Property
[image]

Gets or sets whether DiagramPage titles can be renamed interactively.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowRenamePages { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRenamePages As Boolean

Property Value

true if the user is allowed to rename tabs interactively, or false otherwise.

Remarks

To rename a tab, click to activate it first, and then click a second time to show its in-place edit text control.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.AllowTabReorder Property

TabbedDiagramView.AllowTabReorder Property
[image]

Gets or sets a value indicating whether tabs can be rearranged interactively. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowTabReorder { get; set; }

Visual Basic [image] Copy Code

Public Property AllowTabReorder As Boolean

Property Value

true to allow interactive tab reordering; otherwise, false. The default is false.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.CurrentPage Property

TabbedDiagramView.CurrentPage Property
[image]

Gets or sets the currently active page. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramPage CurrentPage { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentPage As DiagramPage

Property Value

A DiagramPage object.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.Document Property

TabbedDiagramView.Document Property
[image]

Gets or sets the displayed diagram document. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramDocument Document { get; set; }

Visual Basic [image] Copy Code

Public Property Document As DiagramDocument

Property Value

A DiagramDocument object.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowCreateNewTab Property

TabbedDiagramView.ShowCreateNewTab Property
[image]

Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowCreateNewTab { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCreateNewTab As Boolean

Property Value

true to enable interactive tab creation; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabCloseButtons Property

TabbedDiagramView.ShowTabCloseButtons Property
[image]

Gets or sets a value indicating whether to display a close button for each tab. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowTabCloseButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabCloseButtons As Boolean

Property Value

true to enable interactive tab deletion; otherwise, false. The default is true.

Remarks

Interactive tab deletion can still be validated through the PageRemoving event.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabNavigationButtons Property

TabbedDiagramView.ShowTabNavigationButtons Property
[image]

Gets or sets a value indicating whether the tab navigation buttons. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowTabNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabNavigationButtons As Boolean

Property Value

true to enable tab navigation; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.ShowTabs Property

TabbedDiagramView.ShowTabs Property
[image]

Gets or sets a value indicating whether the tabs are visible. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ShowTabs { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTabs As Boolean

Property Value

true to display the tabs tray; otherwise, false. The default is true.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.TabAlignment Property

TabbedDiagramView.TabAlignment Property
[image]

Gets or sets the tabs alignment. This is a dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Dock TabAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TabAlignment As Dock

Property Value

A member of the Dock enumeration. The default is Bottom.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView Events

TabbedDiagramView Events
[image]

Public Events

Name | Description
CurrentPageChanged | Raised when the currently active page is changed.
PageAdded | Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
PageRemoved | Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.
PageRemoving | Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.
PageRenamed | Raised when the page has been renamed.

See Also

TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.CurrentPageChanged Event

TabbedDiagramView.CurrentPageChanged Event
[image]

Raised when the currently active page is changed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CurrentPageChanged

Visual Basic [image] Copy Code

Public Event CurrentPageChanged As EventHandler

Event Data

CurrentPageChanged event handlers receive an argument of type EventArgs.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.PageAdded Event

TabbedDiagramView.PageAdded Event
[image]

Raised when a new page is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageEventArgs> PageAdded

Visual Basic [image] Copy Code

Public Event PageAdded As EventHandler(Of DiagramPageEventArgs)

Event Data

PageAdded event handlers receive an argument of type DiagramPageEventArgs.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.PageRemoved Event

TabbedDiagramView.PageRemoved Event
[image]

Raised when a page is removed interactively, that is, when the user clicks the close button of its associated tab.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageEventArgs> PageRemoved

Visual Basic [image] Copy Code

Public Event PageRemoved As EventHandler(Of DiagramPageEventArgs)

Event Data

PageRemoved event handlers receive an argument of type DiagramPageEventArgs.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.PageRemoving Event

TabbedDiagramView.PageRemoving Event
[image]

Raised when a page is about to be removed interactively, that is, when the user clicks the close button of its associated tab.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DiagramPageValidationEventArgs> PageRemoving

Visual Basic [image] Copy Code

Public Event PageRemoving As EventHandler(Of DiagramPageValidationEventArgs)

Event Data

PageRemoving event handlers receive an argument of type DiagramPageValidationEventArgs.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TabbedDiagramView.PageRenamed Event

TabbedDiagramView.PageRenamed Event
[image]

Raised when the page has been renamed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PageRenamedEventArgs> PageRenamed

Visual Basic [image] Copy Code

Public Event PageRenamed As EventHandler(Of PageRenamedEventArgs)

Event Data

PageRenamed event handlers receive an argument of type PageRenamedEventArgs.

See Also

TabbedDiagramView Members
TabbedDiagramView Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Class

TableConnectionPoint Class
[image]

Represents a connection between a link and a table node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class TableConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ConnectionPoint
MindFusion.Diagramming.Wpf.TableConnectionPoint

See Also

TableConnectionPoint Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Members

TableConnectionPoint Members
Constructors Properties Methods
[image]

Represents a connection between a link and a table node.

The following tables list the members exposed by the TableConnectionPoint type.

Public Constructors

Name | Description
TableConnectionPoint | Overloaded.

Public Properties

Name | Description
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.
Table | Gets the tableNode associated with the connection point.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AnchorPointFromIndex | ConnectionPoint.AnchorPointFromIndex override.
CalculateIntersections | ConnectionPoint.CalculateIntersections override.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded.
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
NearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Constructor

TableConnectionPoint Constructor
[image]

Overload List

Name | Description
TableConnectionPoint () | Initializes a new instance of the TableConnectionPoint class.
TableConnectionPoint (TableNode, DiagramLink, Boolean, Int32) | Initializes a new instance of the TableConnectionPoint class.

See Also

TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Constructor ()

TableConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the TableConnectionPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableConnectionPoint ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

TableConnectionPoint Constructor Overload List
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Constructor (TableNode, DiagramLink, Boolean, Int32)

TableConnectionPoint Constructor (TableNode, DiagramLink, Boolean, Int32)
See Also
[image]

Initializes a new instance of the TableConnectionPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableConnectionPoint (
TableNode tableNode,
DiagramLink link,
bool incoming,
int row
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
link As DiagramLink, _
incoming As Boolean, _
row As Integer _
)

Parameters

tableNode

link

incoming

row

See Also

TableConnectionPoint Constructor Overload List
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Methods

TableConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AnchorPointFromIndex | ConnectionPoint.AnchorPointFromIndex override.
CalculateIntersections | ConnectionPoint.CalculateIntersections override.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded.
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
NearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.AddLinkToNode Method

TableConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.AnchorPointFromIndex Method

TableConnectionPoint.AnchorPointFromIndex Method
[image]

ConnectionPoint.AnchorPointFromIndex override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override AnchorPoint AnchorPointFromIndex (
int index
)

Visual Basic [image] Copy Code

Public Overrides Function AnchorPointFromIndex( _
index As Integer _
) As AnchorPoint

Parameters

index

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.CalculateIntersections Method

TableConnectionPoint.CalculateIntersections Method
[image]

ConnectionPoint.CalculateIntersections override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool CalculateIntersections ()

Visual Basic [image] Copy Code

Public Overrides Function CalculateIntersections () As Boolean

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetAnchorPos Method

TableConnectionPoint.GetAnchorPos Method
[image]

Overload List

Name | Description
TableConnectionPoint.GetAnchorPos (Int32) | ConnectionPoint.GetAnchorPos override.
TableConnectionPoint.GetAnchorPos (Int32, Point@) | ConnectionPoint.GetAnchorPos override.

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetAnchorPos Method (Int32)

TableConnectionPoint.GetAnchorPos Method (Int32)
See Also
[image]

ConnectionPoint.GetAnchorPos override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetAnchorPos (
int anchorIdx
)

Visual Basic [image] Copy Code

Public Overrides Function GetAnchorPos( _
anchorIdx As Integer _
) As Point

Parameters

anchorIdx

Return Value

See Also

GetAnchorPos Method Overload List
TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetAnchorPos Method (Int32, Point@)

TableConnectionPoint.GetAnchorPos Method (Int32, Point@)
See Also
[image]

ConnectionPoint.GetAnchorPos override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool GetAnchorPos (
int anchorIdx,
ref Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetAnchorPos( _
anchorIdx As Integer, _
ByRef point As Point _
) As Boolean

Parameters

anchorIdx

point

Return Value

See Also

GetAnchorPos Method Overload List
TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetEndPoint Method

TableConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.GetEndPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As Point

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetInitialPoint Method

TableConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As Point

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetIntersection Method

TableConnectionPoint.GetIntersection Method
[image]

ConnectionPoint.GetIntersection override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.GetNearestBorderPoint Method

TableConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

A Point instance specifying the current mouse position.

Return Value

Position of the border point nearest to the specified point.

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.LinkChanges Method

TableConnectionPoint.LinkChanges Method
[image]

ConnectionPoint.LinkChanges override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool LinkChanges (
DiagramItem item,
Point pt
)

Visual Basic [image] Copy Code

Public Overrides Function LinkChanges( _
item As DiagramItem, _
pt As Point _
) As Boolean

Parameters

item

pt

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.NearestAnchorPoint Method

TableConnectionPoint.NearestAnchorPoint Method
[image]

ConnectionPoint.GetNearestAnchorPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Point NearestAnchorPoint (
Point point,
ref int idx
)

Visual Basic [image] Copy Code

Protected Overrides Function NearestAnchorPoint( _
point As Point, _
ByRef idx As Integer _
) As Point

Parameters

point

idx

Return Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.RemoveLinkFromNode Method

TableConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.SaveEndRelative Method

TableConnectionPoint.SaveEndRelative Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overrides Sub SaveEndRelative ()

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.UpdateFromPoint Method

TableConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateFromPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateFromPoint( _
point As Point _
)

Parameters

point

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint Properties

TableConnectionPoint Properties
[image]

Public Properties

Name | Description
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.
Table | Gets the tableNode associated with the connection point.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)

See Also

TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.Row Property

TableConnectionPoint.Row Property
[image]

ConnectionPoint.Row override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int Row { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Row As Integer

Property Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionPoint.Table Property

TableConnectionPoint.Table Property
[image]

Gets the tableNode associated with the connection point.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

See Also

TableConnectionPoint Members
TableConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableConnectionStyle Enumeration

TableConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of tables.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TableConnectionStyle

Visual Basic [image] Copy Code

Public Enum TableConnectionStyle

Members

Member name | Description
Both | Users are allowed to create relations both to the rows of a table or the the table as a whole.
Rows | Users are allowed to create relations to the rows of a table.
Table | Users are allowed to create relations to a table as whole entity.

Remarks

The enumeration provides possible values for the ConnectionStyle property, which specifies whether relation ends are the rows of a table or the table as a whole entity.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Class

TableNode Class
Remarks See Also
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Tables in flow diagrams are represented by instances of the TableNode class. Probably the most important property of tables is ConnectionStyle, which specifies whether users are allowed to draw links to the rows of a table, to the table as an integral entity, or both.

Tables consist of Cell instances distributed across Rows and Columns. Number of rows and columns can be set with the RowCount and ColumnCount properties. The width of the columns is set with ColumnWidth property and the height of the rows with the RowHeight property. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than one.

Rows can be assigned to distinct sections of the table. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. The button appears either on the left of the first cell of a header row or in a separate column, as set in OffsetHeaderRows. Clicking that button raises the TableSectionCollapsed and TableSectionExpanded events. Sections can be collapsed or expanded programmatically using the Expanded property of their header rows.

The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the AddColumn and AddRow methods as well as with the InsertColumn, InsertRow and RedimTable methods. DeleteRow and DeleteColumn methods delete existing rows and columns.

Table cells contain Text, displayed as specified through TextBrush and TextFormat. A table can also have a caption, whose text is set by the Caption property. The height of the caption and the alignment of the text are specified by CaptionHeight and CaptionFormat properties. To get even richer text formatting, set EnableStyledText to true and embed HTML-like formatting tags in the caption and cell texts. The ResizeToFitText method resizes all columns and rows so that each table cell fits its text on a single line without clipping it.

To display a text box that lets users edit the table caption or the text of a cell, call the BeginEdit method of Diagram. Call EndEdit to exit the inplace edit mode. If the view's AllowInplaceEdit property is enabled, users can double-click the table caption bar or a cell in order to edit their text.

The interior of tables is filled using their Brush property. The color of the table and cell borders can be set by the Pen property. The table caption area is painted using the CaptionBackBrush brush.

In order to set an image as table's background use the Image property. The alignment of the image in relation to the table's rectangle is set by the ImageAlign property. The table can be resized to fit the size of its image by calling the ResizeToFitImage method.

The location and size of a table can be accessed or changed using the Bounds property. The location of individual table cells can found by calling the GetSpannedCellRect method.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.TableNode

See Also

TableNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Members

TableNode Members
Constructors Fields Properties Methods
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Overloaded.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowResizeColumns | Gets or sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Gets or sets a value indicating whether users are allowed to resize table rows.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the color of the text used as table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextStyle | Gets an object that defines the default text formatting of table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
ImagePadding | Gets or sets the padding distance between node's borders and Image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | Visual.VisualChildrenCount override.

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Overloaded.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | DiagramNode.DrawAnchorPoints override.
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, also taking in consideration how many rows and columns the cell spans.
GetToolTip | DiagramNode.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
Repaint | DiagramItem.Repaint override.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Resizes the columns and rows so that the cells are large enough to fit their text.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
Dispose | Disposes any disposable resources managed by this table.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | Visual.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | DiagramNode.OnSizeChanged override.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram.ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | DiagramNode.SetReflexive override.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Fields

TableNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionBackBrushProperty | Identifies the CaptionBackBrush dependency property.
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CaptionBackBrushProperty Field

TableNode.CaptionBackBrushProperty Field
[image]

Identifies the CaptionBackBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CaptionBackBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CaptionBackBrushProperty As DependencyProperty

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CaptionHeightProperty Field

TableNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared CaptionHeightProperty As DependencyProperty

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellFrameStyleProperty Field

TableNode.CellFrameStyleProperty Field
[image]

Identifies the CellFrameStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CellFrameStyleProperty

Visual Basic [image] Copy Code

Public Shared CellFrameStyleProperty As DependencyProperty

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ImagePaddingProperty Field

TableNode.ImagePaddingProperty Field
[image]

Identifies the ImagePadding dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImagePaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImagePaddingProperty As DependencyProperty

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ShapeProperty Field

TableNode.ShapeProperty Field
[image]

Identifies the Shape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ShapeProperty As DependencyProperty

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Constructor

TableNode Constructor
[image]

Overload List

Name | Description
TableNode () | Initializes a new instance of the TableNode class.
TableNode (Diagram) | Initializes a new instance of the TableNode class.
TableNode (TableNode) | Initializes a new instance of the TableNode class using the specified node as a prototype.

See Also

TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Constructor ()

TableNode Constructor ()
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Constructor (Diagram)

TableNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TableNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Constructor (TableNode)

TableNode Constructor (TableNode)
See Also
[image]

Initializes a new instance of the TableNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode (
TableNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TableNode _
)

Parameters

prototype
The table node to use as a prototype. The properties of the new table are initialized from the property values of prototype.

Remarks

This constructor copies the TableNode property values from the specified prototype node.

See Also

TableNode Constructor Overload List
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Methods

TableNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Overloaded.
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | DiagramNode.DrawAnchorPoints override.
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node using the specified DrawingContext object.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, also taking in consideration how many rows and columns the cell spans.
GetToolTip | DiagramNode.GetToolTip override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override.
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
Repaint | DiagramItem.Repaint override.
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
ResizeToFitText | Resizes the columns and rows so that the cells are large enough to fit their text.
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
Dispose | Disposes any disposable resources managed by this table.
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | Visual.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | DiagramNode.OnSizeChanged override.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram.ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | DiagramNode.SetReflexive override.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.AcceptLinks Method

TableNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean, _
mousePosition As Point _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.
mousePosition
The current mouse pointer position in diagram coordinates.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.AddColumn Method

TableNode.AddColumn Method
[image]

Adds new empty column at the right end of the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int AddColumn ()

Visual Basic [image] Copy Code

Public Function AddColumn () As Integer

Return Value

Returns the index of the newly added column within the Columns collection.

Remarks

Call the method to add new columns at the end of the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
InsertColumn Method
DeleteColumn Method
RedimTable Method
Columns Property


MindFusion.Diagramming.Wpf.TableNode.AddRelation Method

TableNode.AddRelation Method
[image]

Creates a relation with the specified table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink AddRelation (
int row,
Relationship rel,
TableNode tableNode,
int relRow
)

Visual Basic [image] Copy Code

Public Function AddRelation( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode, _
relRow As Integer _
) As DiagramLink

Parameters

row

Zero-based index of a row in this table to be related.

rel

The type of the relation (and the direction of the link).

tableNode

The other table in the relation.

relRow

Zero-based index of the row in the other table.

Return Value

A DiagramLink object representing the relation.

Remarks

Call this method to link rows of two tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
BreakRelation Method


MindFusion.Diagramming.Wpf.TableNode.AddRow Method

TableNode.AddRow Method
[image]

Adds new empty row at the bottom of the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int AddRow ()

Visual Basic [image] Copy Code

Public Function AddRow () As Integer

Return Value

Returns the index of the newly added row within the Rows collection.

Remarks

Call the method to add new rows at the end of the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
InsertRow Method
DeleteRow Method
RedimTable Method
Rows Property


MindFusion.Diagramming.Wpf.TableNode.ArrangeOverride Method

TableNode.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The final area that this element should use to arrange itself and its children.

Return Value

The actual size used.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.BreakRelation Method

TableNode.BreakRelation Method
[image]

Breaks the relation with the specified table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BreakRelation (
int row,
Relationship rel,
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub BreakRelation( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode _
)

Parameters

row

Zero-based index of a row in this table that is related to a row in another.

rel

The type of the relation (and the direction of the link).

tableNode

The other table in the relation.

Remarks

Call this method to break the link between two tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
AddRelation Method


MindFusion.Diagramming.Wpf.TableNode.CellFromPoint Method

TableNode.CellFromPoint Method
[image]

Overload List

Name | Description
TableNode.CellFromPoint (Point, Boolean) | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
TableNode.CellFromPoint (Point, Boolean, Int32@, Int32@) | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellFromPoint Method (Point, Boolean)

TableNode.CellFromPoint Method (Point, Boolean)
See Also
[image]

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell CellFromPoint (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Function CellFromPoint( _
point As Point, _
isDiagramCoordinate As Boolean _
) As TableNode.Cell

Parameters

point

The point to check.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

CellFromPoint Method Overload List
TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellFromPoint Method (Point, Boolean, Int32@, Int32@)

TableNode.CellFromPoint Method (Point, Boolean, Int32@, Int32@)
See Also
[image]

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CellFromPoint (
Point point,
bool isDiagramCoordinate,
ref int row,
ref int col
)

Visual Basic [image] Copy Code

Public Function CellFromPoint( _
point As Point, _
isDiagramCoordinate As Boolean, _
ByRef row As Integer, _
ByRef col As Integer _
) As Boolean

Parameters

point

The point to check.

isDiagramCoordinate

true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

row

Receives the row index if a cell is found at the specified position.

col

Receives the column index if a cell is found at the specified position.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

CellFromPoint Method Overload List
TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CreateConnectionPoint Method

TableNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming
true if the link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CreateProperties Method

TableNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A TableNodeProperties-derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.DeleteColumn Method

TableNode.DeleteColumn Method
[image]

Deletes the column with the specified index within the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void DeleteColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub DeleteColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be deleted.

Remarks

Call the method to delete a column from the table. The size of the table is automatically updated and the columns are removed from the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
DeleteRow Method
AddColumn Method
InsertColumn Method
RedimTable Method


MindFusion.Diagramming.Wpf.TableNode.DeleteRow Method

TableNode.DeleteRow Method
[image]

Deletes the row at the specified position within the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void DeleteRow (
int row
)

Visual Basic [image] Copy Code

Public Sub DeleteRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be deleted.

Remarks

Call the method to delete a row from the table. The size of the table is automatically updated and the rows are removed from the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
DeleteColumn Method
AddRow Method
InsertRow Method
RedimTable Method


MindFusion.Diagramming.Wpf.TableNode.Dispose Method

TableNode.Dispose Method
[image]

Disposes any disposable resources managed by this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

Specifies whether the method is called explicitly or from the garbage collector.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Draw Method

TableNode.Draw Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A DrawingContext object where the node should be rendered.
options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.DrawAnchorPoints Method

TableNode.DrawAnchorPoints Method
[image]

DiagramNode.DrawAnchorPoints override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawAnchorPoints (
DrawingContext graphics
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawAnchorPoints( _
graphics As DrawingContext _
)

Parameters

graphics

The DrawingContext object to draw the anchor points on.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.DrawLocal Method

TableNode.DrawLocal Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.EnumStyleableProperties Method

TableNode.EnumStyleableProperties Method
[image]

DiagramNode.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetAllIncomingLinks Method

TableNode.GetAllIncomingLinks Method
[image]

DiagramNode.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection instance where all links entering this node should be collected.

Remarks

This method also adds the links that enter table rows, which otherwise are not included in the table's IncomingLinks collection, but in the one of the row object.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetAllOutgoingLinks Method

TableNode.GetAllOutgoingLinks Method
[image]

DiagramNode.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection instance where all links going out of this node should be collected.

Remarks

This method also adds the links that go out of table rows, which otherwise are not included in the table's OutgoingLinks collection, but in the one of the row object.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetRepaintRect Method

TableNode.GetRepaintRect Method
[image]

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected
true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetSpannedCellRect Method

TableNode.GetSpannedCellRect Method
[image]

Calculates the bounding rectangle of the specified cell, also taking in consideration how many rows and columns the cell spans.

Overload List

Name | Description
TableNode.GetSpannedCellRect (Int32, Int32) | Calculates the bounding rectangle of the cell in the specified row and column, taking into consideration how many rows and columns the cell spans.
TableNode.GetSpannedCellRect (TableNode.Cell) | Calculates the bounding rectangle of the specified cell, also taking in consideration how many rows and columns the cell spans.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetSpannedCellRect Method (Int32, Int32)

TableNode.GetSpannedCellRect Method (Int32, Int32)
See Also
[image]

Calculates the bounding rectangle of the cell in the specified row and column, taking into consideration how many rows and columns the cell spans.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetSpannedCellRect (
int row,
int col
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
row As Integer, _
col As Integer _
) As Rect

Parameters

row
Index of the table Row that contains the cell.
col
Index of the table Column that contains the cell.

Return Value

A Rect object containing the cell coordinates.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
RowSpan Property
ColumnSpan Property


MindFusion.Diagramming.Wpf.TableNode.GetSpannedCellRect Method (TableNode.Cell)

TableNode.GetSpannedCellRect Method (TableNode.Cell)
See Also
[image]

Calculates the bounding rectangle of the specified cell, also taking in consideration how many rows and columns the cell spans.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetSpannedCellRect (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
cell As TableNode.Cell _
) As Rect

Parameters

cell
A Cell whose location and size to return.

Return Value

A Rect object containing the cell coordinates.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
RowSpan Property
ColumnSpan Property


MindFusion.Diagramming.Wpf.TableNode.GetToolTip Method

TableNode.GetToolTip Method
[image]

DiagramNode.GetToolTip override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Object GetToolTip (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Overrides Function GetToolTip( _
point As Point, _
isDiagramCoordinate As Boolean _
) As Object

Parameters

point

The mouse pointer position.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

Return Value

An object specifying the tooltip contents.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.GetVisualChild Method

TableNode.GetVisualChild Method
[image]

Visual.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

The index of the child Visual object.

Return Value

The child at the specified index value.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.HitTestManipulators Method

TableNode.HitTestManipulators Method
[image]

DiagramItem.HitTestManipulators override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Manipulator HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestManipulators( _
pt As Point _
) As Manipulator

Parameters

pt

Return Value

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.InsertColumn Method

TableNode.InsertColumn Method
[image]

Inserts new empty column at the specified position within the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void InsertColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub InsertColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be inserted.

Remarks

Call the method to add new column at a particular position in the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
AddColumn Method
DeleteColumn Method
RedimTable Method


MindFusion.Diagramming.Wpf.TableNode.InsertRow Method

TableNode.InsertRow Method
[image]

Inserts new empty row at the specified position within the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void InsertRow (
int row
)

Visual Basic [image] Copy Code

Public Sub InsertRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be inserted.

Remarks

Call the method to add new row at a particular position in the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
AddRow Method
DeleteRow Method
RedimTable Method


MindFusion.Diagramming.Wpf.TableNode.LoadFromXml Method

TableNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the item's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.MeasureOverride Method

TableNode.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size.

Return Value

The desired size.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnLoad Method

TableNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnMeasureUnitChanged Method

TableNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnMouseMove Method

TableNode.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnSizeChanged Method

TableNode.OnSizeChanged Method
[image]

DiagramNode.OnSizeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnSizeChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnSizeChanged ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnTextAttributeChanged Method

TableNode.OnTextAttributeChanged Method
[image]

DiagramItem.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnUpdateBounds Method

TableNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.OnZoomChanged Method

TableNode.OnZoomChanged Method
[image]

Called when the Diagram.ZoomFactor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RedimTable Method

TableNode.RedimTable Method
[image]

Sets new number of rows and columns for this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RedimTable (
int cols,
int rows
)

Visual Basic [image] Copy Code

Public Sub RedimTable( _
cols As Integer, _
rows As Integer _
)

Parameters

cols

The new number of columns.

rows

The new number of rows.

Remarks

This method does not preserve the old contents of table cells. After its invocation all cells are empty and columns and rows are with default sizes.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
AddColumn Method
AddRow Method
DeleteColumn Method
DeleteRow Method


MindFusion.Diagramming.Wpf.TableNode.Repaint Method

TableNode.Repaint Method
[image]

DiagramItem.Repaint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Repaint (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Sub Repaint( _
includeConnected As Boolean _
)

Parameters

includeConnected

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ResizeToFitImage Method

TableNode.ResizeToFitImage Method
[image]

Makes a table as big as the image it displays.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a table exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new table size. You can use ImageAlign to specify position of the picture and Image to set the picture itself.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Image Property


MindFusion.Diagramming.Wpf.TableNode.ResizeToFitText Method

TableNode.ResizeToFitText Method
[image]

Resizes the columns and rows so that the cells are large enough to fit their text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void ResizeToFitText (
bool ignoreCaption
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitText( _
ignoreCaption As Boolean _
)

Parameters

ignoreCaption
false if the caption bar too should be resized to fit the caption text; otherwise, true.

Remarks

This method resizes the cells so they fit their Text on a single line, as long as the text does not contain new-line characters. The Width of each column is set to the width of its widest cell, and the Height of each row is set to the height of its highest cell. In the end, the table size is set to the sum of the extents of all rows and columns.

If ignoreCaption is false, the caption bar too will be resized, by setting CaptionHeight and the table width, so that it fits the Caption text.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ResizeToFitImage Method


MindFusion.Diagramming.Wpf.TableNode.RestoreProperties Method

TableNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A TableNodeProperties-derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.SaveProperties Method

TableNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A TableNodeProperties-derived object where the item's properties should be saved.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.SaveToXml Method

TableNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the item's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ScaleElements Method

TableNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.SetReflexive Method

TableNode.SetReflexive Method
[image]

DiagramNode.SetReflexive override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the self-loop link.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode Properties

TableNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowResizeColumns | Gets or sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Gets or sets a value indicating whether users are allowed to resize table rows.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the color of the text used as table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CaptionPlainText | Gets the plain text of the table's caption.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextStyle | Gets an object that defines the default text formatting of table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
ImagePadding | Gets or sets the padding distance between node's borders and Image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | Visual.VisualChildrenCount override.

See Also

TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.AllowResizeColumns Property

TableNode.AllowResizeColumns Property
[image]

Gets or sets a value indicating whether users are allowed to resize table columns.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowResizeColumns { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeColumns As Boolean

Property Value

true to let users resize columns, or false otherwise. The default value is false.

Remarks

A column can be resized by dragging its right border. If the ColumnStyle property of a column is set to AutoWidth, it is automatically reset to FixedWidth when the column is resized. Rightmost columns always fill all remaining space in their tables and cannot be resized.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.AllowResizeRows Property

TableNode.AllowResizeRows Property
[image]

Gets or sets a value indicating whether users are allowed to resize table rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowResizeRows { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeRows As Boolean

Property Value

true to let users resize rows, or false otherwise. The default value is false.

Remarks

A row can be resized by dragging its bottom border.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Caption Property

TableNode.Caption Property
[image]

Gets or sets the text displayed as caption of the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the text of the caption. Initialized with the value of TableCaption.

Remarks

Text color and alignment can be customized by the CaptionBrush and CaptionFormat properties.

Styled text allows applying various attributes to the text characters. Attributes are specified by embedding HTML-like formatting tags within the raw text. Styled text is enabled by setting EnableStyledText to true.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
CaptionHeight Property
CaptionBackBrush Property
Diagram.TableCaption Property


MindFusion.Diagramming.Wpf.TableNode.CaptionBackBrush Property

TableNode.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush object used to paint the interior of the caption area. You can assign to it an instance of one of the following classes: GradientBrush, SolidColorBrush or TileBrush, located in the System.Windows.Media namespace. If there is no brush assigned to this property, the caption area is painted using the Brush property of the TableNode class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
CaptionHeight Property
Caption Property


MindFusion.Diagramming.Wpf.TableNode.CaptionBrush Property

TableNode.CaptionBrush Property
[image]

Gets or sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush-derived class. The default is Brushes.Black.

Remarks

Use the property to make table caption more distinguished.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
CaptionHeight Property
Caption Property


MindFusion.Diagramming.Wpf.TableNode.CaptionFormat Property

TableNode.CaptionFormat Property
[image]

Gets or sets the alignment and line position of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

This property has been deprecated. Set the TextAlignment and TextVerticalAlignment properties to specify text alignment.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CaptionHeight Property

TableNode.CaptionHeight Property
[image]

Gets or sets the height of the table's caption area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the height of the table caption. Initialized with the value of TableCaptionHeight.

Remarks

Keep in mind that tables are moved by clicking their captions and dragging. Don't make captions too narrow or they would become harder to move.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
CaptionBrush Property
Caption Property
Diagram.TableCaptionHeight Property


MindFusion.Diagramming.Wpf.TableNode.CaptionPlainText Property

TableNode.CaptionPlainText Property
[image]

Gets the plain text of the table's caption.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string CaptionPlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CaptionPlainText As String

Property Value

A string containing the plain text of the caption.

Remarks

This property removes any formatting tags from Caption and returns the plain human-readable text. That is useful when styled text is enabled and you need to display caption's content outside of MindFusion.Diagramming for WPF, that is, in a message box or a dialog.

Example

The following sample code demonstrates how CaptionPlainText can be used.

C# [image] Copy Code
t.EnableStyledText = true;
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>";
MessageBox.Show(t.CaptionPlainText);
Visual Basic [image] Copy Code
t.EnableStyledText = True
t.Caption = "<b>interface</b> <i><u>IMouseListener</u></i>"
MessageBox.Show(t.CaptionPlainText)

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
EnableStyledText Property


MindFusion.Diagramming.Wpf.TableNode.CellCustomDraw Property

TableNode.CellCustomDraw Property
[image]

Gets or sets the type of custom drawing performed on the table cells.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of CellCustomDraw.

Remarks

This property allows invoking custom painting code for the cells of a table. That code must execute in response to the DrawCell event. There are several modes of custom painting, allowing the custom code to paint the cell entirely, or do that in addition to what MindFusion.Diagramming for WPF paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for WPF.
Additional | The custom painting code executes after the cell interior is painted by MindFusion.Diagramming for WPF, but before the cell's text is rendered.
Full | The component does not do any standard drawing of the cell, the entire painting is left for the application.
Additional2 | The custom painting code executes after all parts of the cell, including its text, are painted by MindFusion.Diagramming for WPF.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
TableNode.CustomDraw Property


MindFusion.Diagramming.Wpf.TableNode.CellFrameStyle Property

TableNode.CellFrameStyle Property
[image]

Gets or sets the style of the table cells.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. Initialized with the value of CellFrameStyle.

Remarks

This property specifies whether there are borders drawn around table cells, and if yes, their appearance.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
CellFrameStyle Enumeration
Diagram.CellFrameStyle Property


MindFusion.Diagramming.Wpf.TableNode.CellTextStyle Property

TableNode.CellTextStyle Property
[image]

Gets an object that defines the default text formatting of table cells.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ITextAttributes CellTextStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellTextStyle As ITextAttributes

Property Value

An object that implements the ITextAttributes interface.

Remarks

The cells of this table derive their text-related property values from CellTextStyle when there are no local values assigned to them.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCount Property

TableNode.ColumnCount Property
[image]

Gets or sets the number of columns in the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the table.

Remarks

If you increase the number of columns the contents of the old columns will remain intact. If you decrease the number, the last columns are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Columns Property


MindFusion.Diagramming.Wpf.TableNode.Columns Property

TableNode.Columns Property
[image]

Gets a list of all columns in the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As TableNode.ColumnCollection

Property Value

An instance of the ColumnCollection class.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Rows Property


MindFusion.Diagramming.Wpf.TableNode.ColumnWidth Property

TableNode.ColumnWidth Property
[image]

Gets or sets the default width of the table columns.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnWidth As Double

Property Value

A double value specifying the width of the table columns. Initialized with the value of TableColumnWidth.

Remarks

The value of this property is used to initialize the width of new columns when they are created.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
RowHeight Property


MindFusion.Diagramming.Wpf.TableNode.ConnectionStyle Property

TableNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. Initialized with the value of TableConnectionStyle.

Remarks

There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows - relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table - relations target the table as a whole entity, and not any particular row. This mode is convenient for class diagrams.
  • Both - a mixed mode where links can target either a row of the table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the ConnectionStyle. ConnectionStyle value is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CurrentScrollRow Property

TableNode.CurrentScrollRow Property
[image]

Gets or sets the index of the first visible row in the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int CurrentScrollRow { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentScrollRow As Integer

Property Value

An integer value indicating the index of the first visible row.

Remarks

To allow users to scroll the table interactively, enable the Scrollable property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Rows Property


MindFusion.Diagramming.Wpf.TableNode.CustomDraw Property

TableNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of TableCustomDraw.

Remarks

This property allows invoking custom painting code for a table. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the table entirely, or do that in addition to what MindFusion.Diagramming for WPF paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for WPF.
Additional | The custom painting code executes after the table interior and frame are painted by MindFusion.Diagramming for WPF, but before cells are rendered.
Full | The component does not do any standard drawing of the table frame, whose painting is left for the application. Cells are painted independently, as set in CellCustomDraw.
ShadowOnly | Only the shadow of the table is painted by custom code, the table itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the table, including its cells, are painted by MindFusion.Diagramming for WPF.

This property doesn't affect the painting of table cells. Table cells can be custom painted by the DrawCell event as set in CellCustomDraw.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.EnableStyledText Property

TableNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of table's caption and cells in order to find formatting tags; otherwise false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

If EnableStyledText is set to true, table's Caption and cells' Text are parsed and analyzed each time they change. Parsing determines what formatting tags are used and adds the corresponding attribute records to MindFusion.Diagramming for WPF's internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ResizeToFitText Method
CaptionPlainText Property


MindFusion.Diagramming.Wpf.TableNode.HighlightedRow Property

TableNode.HighlightedRow Property
[image]

Gets or sets the highlighted row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int HighlightedRow { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightedRow As Integer

Property Value

An integer index of the highlighted row. The default value is -1.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
RowHighlightBrush Property


MindFusion.Diagramming.Wpf.TableNode.Image Property

TableNode.Image Property
[image]

Gets or sets the image that is displayed in this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class.

Remarks

Use the property to customize your table's background. Further customization can be done with the ImageAlign property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Property
ResizeToFitImage Method
Cell.Image Property
ImagePadding Property


MindFusion.Diagramming.Wpf.TableNode.ImageAlign Property

TableNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration. The default value is Fit.

Remarks

This property specifies how images are positioned inside tables.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Image Property
ImagePadding Property


MindFusion.Diagramming.Wpf.TableNode.ImagePadding Property

TableNode.ImagePadding Property
[image]

Gets or sets the padding distance between node's borders and Image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Thickness

Property Value

A System.Windows.Thickness specifying the padding size.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Property


MindFusion.Diagramming.Wpf.TableNode.Item Property

TableNode.Item Property
[image]

Gets the Cell instance at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Item [
int col,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
col As Integer, _
row As Integer _
) As TableNode.Cell

Parameters

col
The zero-based index of the cell's column.
row

The zero-based index of the cell's row.

Property Value

An instance of the Cell class that represents the cell of the table at the specified position.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ColumnCount Property
RowCount Property
RedimTable Method


MindFusion.Diagramming.Wpf.TableNode.OffsetHeaderRows Property

TableNode.OffsetHeaderRows Property
[image]

Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool OffsetHeaderRows { get; set; }

Visual Basic [image] Copy Code

Public Property OffsetHeaderRows As Boolean

Property Value

true to offset table cells when there are header rows defined; otherwise, false. The default is false.

Remarks

If this property is set to false, the [±] buttons used to expand or collapse table sections are drawn inside the first cell of each header row. Otherwise, the buttons are drawn in their own column in front of the table's first column of cells.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowAnchorPattern Property

TableNode.RowAnchorPattern Property
[image]

Gets or sets the default anchor pattern for the rows of a table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern RowAnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RowAnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class. The default is null (Nothing in Visual Basic).

Remarks

Defines a default value for the AnchorPattern property of the rows of a table.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
AnchorPoint.Column Property
Row.AnchorPattern Property


MindFusion.Diagramming.Wpf.TableNode.RowCount Property

TableNode.RowCount Property
[image]

Gets or sets the number of rows in the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value specifying the number of rows in the table.

Remarks

If you increase the number of rows the content of the initial rows will remain intact. If you decrease the number, the last rows are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Rows Property


MindFusion.Diagramming.Wpf.TableNode.RowHeight Property

TableNode.RowHeight Property
[image]

Gets or sets the default height of table rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeight As Double

Property Value

A double value specifying the height of the table rows. Initialized with the value of TableRowHeight.

Remarks

The value of this property is used to initialize the height of new rows when they are created.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
ColumnWidth Property


MindFusion.Diagramming.Wpf.TableNode.Rows Property

TableNode.Rows Property
[image]

Gets a list of all rows in the table.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.RowCollection Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As TableNode.RowCollection

Property Value

An instance of the RowCollection class.

Remarks

The property refers to the collection of all rows that compose the table. Do not add or remove rows through this collection, but use the table's AddRow, InsertRow or DeleteRow methods.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Columns Property
CurrentScrollRow Property


MindFusion.Diagramming.Wpf.TableNode.Scrollable Property

TableNode.Scrollable Property
[image]

Gets or sets a value indicating whether users are allowed to scroll table rows.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Scrollable { get; set; }

Visual Basic [image] Copy Code

Public Property Scrollable As Boolean

Property Value

true to allow scrolling the table up or down; otherwise, false. Initialized with the value of TablesScrollable.

Remarks

A button containing up and down arrows appears in the caption area of a table for which scrolling is enabled. If a user clicks these arrows, table rows scroll up or down. The table can always be scrolled programmatically using the CurrentScrollRow property.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace
Rows Property


MindFusion.Diagramming.Wpf.TableNode.Shape Property

TableNode.Shape Property
[image]

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. Initialized with the value of TableShape.

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.VisualChildrenCount Property

TableNode.VisualChildrenCount Property
[image]

Visual.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

TableNode Members
TableNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Class

TableNode.Cell Class
Remarks See Also
[image]

Represents a cell in a TableNode instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.Cell : TextPresenter, InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode.Cell
Inherits TextPresenter
Implements InplaceEditable

Remarks

Cells are the building blocks of tables. They get their height and width indirectly, from the width of table columns and the height of table rows as set by the ColumnWidth and RowHeight properties. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than 1.

Cells can hold text, which is set by their Text property. The text can be aligned and this is set by the TextFormat property. Color of the text in the cells is set with the TextBrush property. Many other aspects of text rendering can be customized through the properties defined in the ITextAttributes interface, implemented by the Cell class. By default they derive their values from the table's CellTextStyle.

Appearance of a cell can be customized further by the Brush and Image properties.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.TableNode.Cell

See Also

TableNode.Cell Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Members

TableNode.Cell Members
Constructors Fields Properties Methods
[image]

Represents a cell in a TableNode instance.

The following tables list the members exposed by the TableNode.Cell type.

Public Constructors

Name | Description
TableNode.Cell | Initializes a new instance of the TableNode.Cell class.

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImagePadding | Gets or sets the padding distance between cell's borders and Image.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
ToolTip | Gets or sets the tooltip text associated with the cell.

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

Public Methods

Name | Description
Clone | Creates a copy of this cell.
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
GetVisualChild | FrameworkElement.GetVisualChild override.
LoadFromXml | Loads the cell content from an XML element.
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
MeasureOverride | FrameworkElement.MeasureOverride override.
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SaveToXml | Saves the cell content into an XML element.
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

See Also

TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Fields

TableNode.Cell Fields
[image]

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
ImagePaddingProperty | Identifies the ImagePadding dependency property.
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)

See Also

TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.ImagePaddingProperty Field

TableNode.Cell.ImagePaddingProperty Field
[image]

Identifies the ImagePadding dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImagePaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImagePaddingProperty As DependencyProperty

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.TemplateProperty Field

TableNode.Cell.TemplateProperty Field
[image]

Identifies the Template dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TemplateProperty

Visual Basic [image] Copy Code

Public Shared TemplateProperty As DependencyProperty

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Constructor

TableNode.Cell Constructor
[image]

Initializes a new instance of the TableNode.Cell class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell (
TableNode table
)

Visual Basic [image] Copy Code

Public New ( _
table As TableNode _
)

Parameters

table
The TableNode this cell belongs to.

See Also

TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Methods

TableNode.Cell Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this cell.
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
ArrangeOverride | FrameworkElement.ArrangeOverride override.
GetVisualChild | FrameworkElement.GetVisualChild override.
LoadFromXml | Loads the cell content from an XML element.
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
MeasureOverride | FrameworkElement.MeasureOverride override.
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SaveToXml | Saves the cell content into an XML element.
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

See Also

TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.ArrangeOverride Method

TableNode.Cell.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.Clone Method

TableNode.Cell.Clone Method
[image]

Creates a copy of this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Cell

Return Value

An instance of the TableNode.Cell class.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.GetVisualChild Method

TableNode.Cell.GetVisualChild Method
[image]

FrameworkElement.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.LoadFromXml Method

TableNode.Cell.LoadFromXml Method
[image]

Loads the cell content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement containing the cell's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.MeasureOverride Method

TableNode.Cell.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

Return Value

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.OnTextAttributeChanged Method

TableNode.Cell.OnTextAttributeChanged Method
[image]

TextPresenter.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.SaveToXml Method

TableNode.Cell.SaveToXml Method
[image]

Saves the cell content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An XmlElement the cell's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.SetDiagramDirty Method

TableNode.Cell.SetDiagramDirty Method
[image]

TextPresenter.SetDiagramDirty override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Overrides Sub SetDiagramDirty ()

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell Properties

TableNode.Cell Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImagePadding | Gets or sets the padding distance between cell's borders and Image.
PlainText | Gets the plain text of the cell.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
ToolTip | Gets or sets the tooltip text associated with the cell.

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

See Also

TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.Brush Property

TableNode.Cell.Brush Property
[image]

Gets or sets the brush used to fill this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class. The default is null (Nothing in Visual Basic).

Remarks

This property refers to a brush used to paint the cell's interior. You can assign to it an instance of one of the following classes: GradientBrush, SolidColorBrush or TileBrush, located in the System.Windows.Media namespace. If the default null value is used, the cell's interior is painted with the table's Brush instead of cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
Image Property


MindFusion.Diagramming.Wpf.TableNode.Cell.ColumnSpan Property

TableNode.Cell.ColumnSpan Property
[image]

Gets or sets how many columns the cell should span.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ColumnSpan { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnSpan As Integer

Property Value

A positive integer value specifying how many columns the cell spans to the right. The default is 1.

Remarks

Use this property and RowSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text of spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.HyperLink Property

TableNode.Cell.HyperLink Property
[image]

Gets or sets the hyperlink associated with the cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

Remarks

This property is used by the CreateImageMap method of the HtmlBuilder class. Its value is assigned to the HREF attribute of the <AREA> tag that corresponds to the cell. Map areas are defined for table cells only if the AreasForTableCells property is enabled.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.Image Property

TableNode.Cell.Image Property
[image]

Gets or sets the image that is displayed in this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class. The default is null (Nothing in Visual Basic).

Remarks

Use this property to set an image to be displayed in the cell. Use the ImageAlign property to specify how the image is placed.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Property
ImagePadding Property


MindFusion.Diagramming.Wpf.TableNode.Cell.ImageAlign Property

TableNode.Cell.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageAlign ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlign

Property Value

A member of the ImageAlign enumeration.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
Image Property
ImagePadding Property


MindFusion.Diagramming.Wpf.TableNode.Cell.ImagePadding Property

TableNode.Cell.ImagePadding Property
[image]

Gets or sets the padding distance between cell's borders and Image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Thickness

Property Value

A System.Windows.Thickness specifying the padding size.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
ImageAlign Property


MindFusion.Diagramming.Wpf.TableNode.Cell.PlainText Property

TableNode.Cell.PlainText Property
[image]

Gets the plain text of the cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string PlainText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PlainText As String

Property Value

A string containing the plain text of the cell.

Remarks

This property removes any formatting tags from cell's Text and returns the plain human-readable text. That is useful when styled text is enabled and you need to display cell's content outside of MindFusion.Diagramming for WPF, that is, in a message box or a dialog.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
TableNode.EnableStyledText Property


MindFusion.Diagramming.Wpf.TableNode.Cell.RowSpan Property

TableNode.Cell.RowSpan Property
[image]

Gets or sets how many rows the cell should span.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RowSpan { get; set; }

Visual Basic [image] Copy Code

Public Property RowSpan As Integer

Property Value

A positive integer value specifying how many rows the cell spans downwards. The default is 1.

Remarks

Use this property and ColumnSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text displayed in spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as an alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.Table Property

TableNode.Cell.Table Property
[image]

Gets a reference to the TableNode containing this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class representing the table containing this cell.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.Tag Property

TableNode.Cell.Tag Property
[image]

Gets or sets custom data associated with this cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null (Nothing in Visual Basic).

Remarks

This property holds data that you define and is not used by MindFusion.Diagramming for WPF in any way. The tag could be any value of a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the cell containing it when saving/loading the diagram. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace
DiagramBase.SerializeTag Event


MindFusion.Diagramming.Wpf.TableNode.Cell.Template Property

TableNode.Cell.Template Property
[image]

Gets or sets the DataTemplate used to display this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DataTemplate Template { get; set; }

Visual Basic [image] Copy Code

Public Property Template As DataTemplate

Property Value

A System.Windows.DataTemplate instance; the default value is null.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.TextFormat Property

TableNode.Cell.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside the cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

This property has been deprecated. Set the TextAlignment and TextVerticalAlignment properties to specify text alignment.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.ToolTip Property

TableNode.Cell.ToolTip Property
[image]

Gets or sets the tooltip text associated with the cell.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As Object

Property Value

The tool-tip text displayed for this cell. The default is an empty string.

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Cell.VisualChildrenCount Property

TableNode.Cell.VisualChildrenCount Property
[image]

FrameworkElement.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

TableNode.Cell Members
TableNode.Cell Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection Class

TableNode.CellCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.CellCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class TableNode.CellCollection
Inherits CollectionBase

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove cells from a table, use the AddRow, AddColumn, InsertRow, InsertColumn, DeleteRow, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.TableNode.CellCollection

See Also

TableNode.CellCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection Members

TableNode.CellCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

The following tables list the members exposed by the TableNode.CellCollection type.

Public Constructors

Name | Description
TableNode.CellCollection | Initializes a new instance of the TableNode.CellCollection class.

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection Constructor

TableNode.CellCollection Constructor
[image]

Initializes a new instance of the TableNode.CellCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.CellCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection Methods

TableNode.CellCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified cell to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the cell at the specified position.
Insert | Inserts the specified cell at the specified index within the collection.
Remove | Removes the specified cell from the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.Add Method

TableNode.CellCollection.Add Method
[image]

Adds the specified cell to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Add( _
cell As TableNode.Cell _
)

Parameters

cell
The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.Clone Method

TableNode.CellCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.CellCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.CellCollection

Return Value

An instance of the TableNode.CellCollection class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.GetAt Method

TableNode.CellCollection.GetAt Method
[image]

Returns the cell at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As TableNode.Cell

Parameters

index
The zero-based index of the cell to retrieve.

Return Value

A reference to the TableNode.Cell object at the specified position.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.Insert Method

TableNode.CellCollection.Insert Method
[image]

Inserts the specified cell at the specified index within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
cell As TableNode.Cell _
)

Parameters

index
The zero-based index at which to insert the cell.
cell
The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.Remove Method

TableNode.CellCollection.Remove Method
[image]

Removes the specified cell from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Sub Remove( _
cell As TableNode.Cell _
)

Parameters

cell
The TableNode.Cell object to add to the collection.

Remarks

Do not use this method directly. Use the methods of the TableNode class instead.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection Properties

TableNode.CellCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the cell at the specified position within the collection.

See Also

TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.CellCollection.Item Property

TableNode.CellCollection.Item Property
[image]

Gets or sets the cell at the specified position within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Cell Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As TableNode.Cell

Parameters

index
The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Cell object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column Class

TableNode.Column Class
Remarks See Also
[image]

Represents a column of a TableNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.Column

Visual Basic [image] Copy Code

Public Class TableNode.Column

Remarks

The width of a column can be set by its Width property. The width of a column determines the width of all cells contained within the column.

When resizing a table, its columns can be resized too. That depends on the value of ColumnStyle, which specifies whether columns are with fixed width or they resize to keep column-to-table width ratio.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.TableNode.Column

See Also

TableNode.Column Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column Members

TableNode.Column Members
Constructors Properties Methods
[image]

Represents a column of a TableNode.

The following tables list the members exposed by the TableNode.Column type.

Public Constructors

Name | Description
TableNode.Column | Initializes a new instance of the TableNode.Column class.

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the height of a table column.

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column Constructor

TableNode.Column Constructor
[image]

Initializes a new instance of the TableNode.Column class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Column (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode

The TableNode this column belongs to.

See Also

TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column Methods

TableNode.Column Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromXml | Loads the column properties from an XML element.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column.Clone Method

TableNode.Column.Clone Method
[image]

Creates a copy of this column.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Column Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Column

Return Value

An instance of the TableNode.Column class.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column.LoadFromXml Method

TableNode.Column.LoadFromXml Method
[image]

Loads the column properties from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.Xml.XmlElement containing the column's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column.SaveToXml Method

TableNode.Column.SaveToXml Method
[image]

Saves the column properties into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.Xml.XmlElement the column's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column Properties

TableNode.Column Properties
[image]

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the height of a table column.

See Also

TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column.ColumnStyle Property

TableNode.Column.ColumnStyle Property
[image]

Gets or sets the manner in which column's width is set.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ColumnStyle ColumnStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnStyle As ColumnStyle

Property Value

A member of the ColumnStyle enumeration. The default is ColumnStyle.FixedWidth.

Remarks

This property is used for calculating the width of a table column. The column can have either a fixed width set through the Width property, or can be resized proportionally to the table width.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Column.Width Property

TableNode.Column.Width Property
[image]

Gets or sets the height of a table column.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value indicating the width of the column. The default is 50.

Remarks

The user can resize columns interactively when table's AllowResizeColumns property is enabled.

See Also

TableNode.Column Members
TableNode.Column Class
MindFusion.Diagramming.Wpf Namespace
TableNode.ColumnWidth Property


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection Class

TableNode.ColumnCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Column objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.ColumnCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class TableNode.ColumnCollection
Inherits CollectionBase

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove columns from a table, use the AddColumn, InsertColumn, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.TableNode.ColumnCollection

See Also

TableNode.ColumnCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection Members

TableNode.ColumnCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Column objects.

The following tables list the members exposed by the TableNode.ColumnCollection type.

Public Constructors

Name | Description
TableNode.ColumnCollection | Initializes a new instance of the TableNode.ColumnCollection class.

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection Constructor

TableNode.ColumnCollection Constructor
[image]

Initializes a new instance of the TableNode.ColumnCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the %config% infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection Methods

TableNode.ColumnCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified column to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the column at the specified position.
Insert | Inserts the specified column at the specified index within the collection.
Remove | Removes the specified column from the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.Add Method

TableNode.ColumnCollection.Add Method
[image]

Adds the specified column to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Add( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the AddColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.Clone Method

TableNode.ColumnCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.ColumnCollection

Return Value

An instance of the TableNode.ColumnCollection class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.GetAt Method

TableNode.ColumnCollection.GetAt Method
[image]

Returns the column at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Column GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the column to retrieve.

Return Value

A reference to the TableNode.Column object at the specified position.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.Insert Method

TableNode.ColumnCollection.Insert Method
[image]

Inserts the specified column at the specified index within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
column As TableNode.Column _
)

Parameters

index
The zero-based index at which to insert the column.
column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the InsertColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.Remove Method

TableNode.ColumnCollection.Remove Method
[image]

Removes the specified column from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Column column
)

Visual Basic [image] Copy Code

Public Sub Remove( _
column As TableNode.Column _
)

Parameters

column
The TableNode.Column object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteColumn method of the TableNode class instead.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection Properties

TableNode.ColumnCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the column at the specified position within the collection.

See Also

TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.ColumnCollection.Item Property

TableNode.ColumnCollection.Item Property
[image]

Gets or sets the column at the specified position within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Column Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As TableNode.Column

Parameters

index
The zero-based index of the item which should be get or set.

Property Value

A reference to the TableNode.Column object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row Class

TableNode.Row Class
Remarks See Also
[image]

Represents a row in TableNode node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.Row

Visual Basic [image] Copy Code

Public Class TableNode.Row

Remarks

Table rows can be assigned to distinct sections of a table. For example, sections could contain rows representing different types of class members in class diagrams, there could be one section displaying the methods, another one for the events and one more for the properties of a class. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. Sections can be collapsed and expanded programmatically using the Expanded property of the header row.

The height of a row is set by the Height property. That determines the height of all non-spanning cells contained within the row. Cells can be made to span several rows by setting their RowSpan property.

Rows can be bound together to represent relationship between database tables. The relationship can be one to many and many to one. The tables that stay on the left side of M:1 relationships are stored in the RelatedManyToOne collection; the tables in 1:M relationship with the row are stored in the RelatedOneToMany collection.

The relationship between tables is shown with links. You can access the DiagramLink elements that go out of a table row by the OutgoingLinks property. Links that come into a given row can be accessed with the IncomingLinks property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.TableNode.Row

See Also

TableNode.Row Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row Members

TableNode.Row Members
Constructors Properties Methods
[image]

Represents a row in TableNode node.

The following tables list the members exposed by the TableNode.Row type.

Public Constructors

Name | Description
TableNode.Row | Initializes a new instance of the TableNode.Row class.

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row Constructor

TableNode.Row Constructor
[image]

Initializes a new instance of the TableNode.Row class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Row (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode
The TableNode this row belongs to.

See Also

TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row Methods

TableNode.Row Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromXml | Loads the row properties from an XML element.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row.Clone Method

TableNode.Row.Clone Method
[image]

Creates a copy of this row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Row Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Row

Return Value

An instance of the TableNode.Row class.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row.LoadFromXml Method

TableNode.Row.LoadFromXml Method
[image]

Loads the row properties from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.Xml.XmlElement containing the row's data.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row.SaveToXml Method

TableNode.Row.SaveToXml Method
[image]

Saves the row properties into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement
An System.Xml.XmlElement the row's data should be stored into.
context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row Properties

TableNode.Row Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.

See Also

TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row.AnchorPattern Property

TableNode.Row.AnchorPattern Property
[image]

Gets or sets a set of anchor points to which links can dock when connected to this row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

AnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
TableNode.RowAnchorPattern Property
AnchorPoint.Column Property


MindFusion.Diagramming.Wpf.TableNode.Row.Expanded Property

TableNode.Row.Expanded Property
[image]

Gets or sets whether the table section starting from this Header row is collapsed or expanded.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true if the table section that starts from this row is expanded; otherwise, false. The default is true.

Remarks

This property can be set only if the row is a Header. Links connected to the rows of a collapsed table section appear to be connected to the section header row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.Row.Header Property

TableNode.Row.Header Property
[image]

Gets or sets a value indicating whether this row is a section header.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Boolean

Property Value

true if this is the header row of a table section, otherwise false. The default is false.

Remarks

Each header row defines a section of the table that includes all non-header rows after the header. Such sections can be expanded or collapsed, that is, the rows included in them can be shown or hidden. This can be done interactively by pressing the [±] button displayed in header rows, or programmatically by setting the Expanded property. The TableSectionCollapsed and TableSectionExpanded events are raised when a user clicks the [±] button.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
OffsetHeaderRows Property


MindFusion.Diagramming.Wpf.TableNode.Row.Height Property

TableNode.Row.Height Property
[image]

Gets or sets the height of the table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value indicating the height of the row. The default is 22.

Remarks

The user can resize rows interactively when table's AllowResizeRows property is enabled.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
OffsetHeaderRows Property


MindFusion.Diagramming.Wpf.TableNode.Row.IncomingLinks Property

TableNode.Row.IncomingLinks Property
[image]

Gets a collection of all links that point to this table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the incoming links.

Remarks

The property returns a collection of all links that point to this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
OutgoingLinks Property


MindFusion.Diagramming.Wpf.TableNode.Row.OutgoingLinks Property

TableNode.Row.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the outgoing links.

Remarks

The property returns a collection of all links that start from this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
IncomingLinks Property


MindFusion.Diagramming.Wpf.TableNode.Row.RelatedManyToOne Property

TableNode.Row.RelatedManyToOne Property
[image]

Gets a collection of all tables that are in many-to-one relation with this table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedManyToOne { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedManyToOne As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation M:1 with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in M:1 relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace
RelatedOneToMany Property


MindFusion.Diagramming.Wpf.TableNode.Row.RelatedOneToMany Property

TableNode.Row.RelatedOneToMany Property
[image]

Gets a collection of all tables that are in one-to-many relation with this table row.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedOneToMany { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedOneToMany As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation 1:M with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in 1:M relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection Class

TableNode.RowCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Row objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNode.RowCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class TableNode.RowCollection
Inherits CollectionBase

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove rows from a table, use the AddRow, InsertRow, DeleteRow and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.TableNode.RowCollection

See Also

TableNode.RowCollection Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection Members

TableNode.RowCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of TableNode.Row objects.

The following tables list the members exposed by the TableNode.RowCollection type.

Public Constructors

Name | Description
TableNode.RowCollection | Initializes a new instance of the TableNode.RowCollection class.

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection Constructor

TableNode.RowCollection Constructor
[image]

Initializes a new instance of the TableNode.RowCollection class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.RowCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection Methods

TableNode.RowCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified row to the collection.
Clone | Creates a deep copy of this collection.
GetAt | Returns the row at the specified position.
IndexOf | Returns the index of the specified row within the collection.
Insert | Inserts the specified row at the specified index within the collection.
Remove | Removes the specified row from the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.Add Method

TableNode.RowCollection.Add Method
[image]

Adds the specified row to the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
TableNode.Row r
)

Visual Basic [image] Copy Code

Public Sub Add( _
r As TableNode.Row _
)

Parameters

r
The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the AddRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.Clone Method

TableNode.RowCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.RowCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.RowCollection

Return Value

An instance of the TableNode.RowCollection class.

Remarks

This method supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.GetAt Method

TableNode.RowCollection.GetAt Method
[image]

Returns the row at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Row GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As TableNode.Row

Parameters

index
The zero-based index of the row to retrieve.

Return Value

A reference to the TableNode.Row object at the specified position.

Remarks

A reference to the TableNode.Row object at the specified position.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.IndexOf Method

TableNode.RowCollection.IndexOf Method
[image]

Returns the index of the specified row within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
row As TableNode.Row _
) As Integer

Parameters

row
The TableNode.Row object whose index to search for in the collection.

Return Value

An integer value specifying the index of the row within the collection or -1, if the row was not found.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.Insert Method

TableNode.RowCollection.Insert Method
[image]

Inserts the specified row at the specified index within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
row As TableNode.Row _
)

Parameters

index
The zero-based index at which to insert the row.
row
The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the InsertRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.Remove Method

TableNode.RowCollection.Remove Method
[image]

Removes the specified row from the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
TableNode.Row row
)

Visual Basic [image] Copy Code

Public Sub Remove( _
row As TableNode.Row _
)

Parameters

row
The TableNode.Row object to add to the collection.

Remarks

Do not use this method directly. Use the DeleteRow method of the TableNode class instead.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection Properties

TableNode.RowCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the row at the specified position within the collection.

See Also

TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNode.RowCollection.Item Property

TableNode.RowCollection.Item Property
[image]

Gets or sets the row at the specified position within the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode.Row Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As TableNode.Row

Parameters

index

Property Value

A reference to the TableNode.Row object at the specified index.

Remarks

Do not use the set accessor of this property. It supports the MindFusion.Diagramming for WPF infrastructure and is not intended to be used directly from your code.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNodeProperties Class

TableNodeProperties Class
[image]

Stores the values of TableNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the TableNode.SaveProperties, TableNode.RestoreProperties, and TableNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TableNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class TableNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.TableNodeProperties

See Also

TableNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNodeProperties Members

TableNodeProperties Members
Constructors Methods
[image]

Stores the values of TableNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the TableNode.SaveProperties, TableNode.RestoreProperties, and TableNode.CreateProperties methods.

The following tables list the members exposed by the TableNodeProperties type.

Public Constructors

Name | Description
TableNodeProperties |

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

TableNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNodeProperties Constructor

TableNodeProperties Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TableNodeProperties Methods

TableNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

TableNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Class

TemplatedNode Class
Remarks See Also
[image]

The TemplatedNode class represents nodes whose appearance is set through Xaml data templates.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TemplatedNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TemplatedNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

This class is useful mostly as a base type of custom nodes, as shown in tutorials 3 and 4. However it is not abstract and can be used directly if the text -related properties defined in DiagramItem are sufficient for your purposes. The appearance of such nodes can be set through their Template property or the NodeTemplate property of the Diagram class.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.TemplatedNode

See Also

TemplatedNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Members

TemplatedNode Members
Constructors Fields Properties Methods
[image]

The TemplatedNode class represents nodes whose appearance is set through Xaml data templates.

The following tables list the members exposed by the TemplatedNode type.

Public Constructors

Name | Description
TemplatedNode | Overloaded. Initializes a new instance of the TemplatedNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | DiagramNode.GetDefaultTemplate override.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | DiagramNode.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | DiagramItem.SaveToXml override. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Fields

TemplatedNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.TemplateProperty Field

TemplatedNode.TemplateProperty Field
[image]

Identifies the Template dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TemplateProperty

Visual Basic [image] Copy Code

Public Shared TemplateProperty As DependencyProperty

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Constructor

TemplatedNode Constructor
[image]

Initializes a new instance of the TemplatedNode class.

Overload List

Name | Description
TemplatedNode () | Initializes a new instance of the TemplatedNode class.
TemplatedNode (Diagram) | Initializes a new instance of the TemplatedNode class.
TemplatedNode (TemplatedNode) | Initializes a new instance of the TemplatedNode class using the specified node as a prototype.

See Also

TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Constructor ()

TemplatedNode Constructor ()
See Also
[image]

Initializes a new instance of the TemplatedNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TemplatedNode Constructor Overload List
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Constructor (Diagram)

TemplatedNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TemplatedNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent
The parent Diagram where this node will be added.

See Also

TemplatedNode Constructor Overload List
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Constructor (TemplatedNode)

TemplatedNode Constructor (TemplatedNode)
See Also
[image]

Initializes a new instance of the TemplatedNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TemplatedNode (
TemplatedNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TemplatedNode _
)

Parameters

prototype
The prototype TemplatedNode whose property values to copy.

See Also

TemplatedNode Constructor Overload List
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Methods

TemplatedNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the node using the specified DrawingContext object.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws this node on the specified DrawingContext graphics surface. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override.
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | DiagramNode.GetDefaultTemplate override.
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
MeasureOverride | FrameworkElement.MeasureOverride override.
OnAdd | DiagramNode.OnAdd override.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | DiagramItem.SaveToXml override. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.ArrangeOverride Method

TemplatedNode.ArrangeOverride Method
[image]

FrameworkElement.ArrangeOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

Return Value

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.Draw Method

TemplatedNode.Draw Method
[image]

Draws the node using the specified DrawingContext object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A DrawingContext object where the node should be rendered.
options

Provides options for the drawing operation.

Remarks

TemplatedNode provides empty implementation of this method, and instead uses the Template property to define the appearance of nodes.

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.GetDefaultTemplate Method

TemplatedNode.GetDefaultTemplate Method
[image]

DiagramNode.GetDefaultTemplate override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DataTemplate GetDefaultTemplate ()

Visual Basic [image] Copy Code

Protected Overrides Function GetDefaultTemplate () As DataTemplate

Return Value

A DataTemplate instance.

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.GetVisualChild Method

TemplatedNode.GetVisualChild Method
[image]

FrameworkElement.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.MeasureOverride Method

TemplatedNode.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

Return Value

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.OnAdd Method

TemplatedNode.OnAdd Method
[image]

DiagramNode.OnAdd override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode Properties

TemplatedNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node.
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

See Also

TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.Template Property

TemplatedNode.Template Property
[image]

Gets or sets the DataTemplate used to display this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DataTemplate Template { get; set; }

Visual Basic [image] Copy Code

Public Property Template As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

If this property is not set (either directly or through a style), the node is displayed using the template assigned to the diagram's NodeTemplate.

Example

See tutorial 3 for an example showing how to set the node's template.

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TemplatedNode.VisualChildrenCount Property

TemplatedNode.VisualChildrenCount Property
[image]

FrameworkElement.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

TemplatedNode Members
TemplatedNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Class

TextAttributes Class
[image]

Defines attributes of text content displayed by diagram items.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TextAttributes : ITextAttributes, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class TextAttributes
Implements ITextAttributes, INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.TextAttributes

See Also

TextAttributes Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Members

TextAttributes Members
Constructors Properties Methods Events
[image]

Defines attributes of text content displayed by diagram items.

The following tables list the members exposed by the TextAttributes type.

Public Constructors

Name | Description
TextAttributes | Overloaded. Initializes a new instance of the TextAttributes class.

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the text displayed inside this item.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.

Public Methods

Name | Description
Copy | Copies text attributes from source object to target object.

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged.PropertyChanged event.

See Also

TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Constructor

TextAttributes Constructor
[image]

Initializes a new instance of the TextAttributes class.

Overload List

Name | Description
TextAttributes (Font) | Initializes a new instance of the TextAttributes class.
TextAttributes (ITextAttributes) | Initializes a new instance of the TextAttributes class.

See Also

TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Constructor (Font)

TextAttributes Constructor (Font)
See Also
[image]

Initializes a new instance of the TextAttributes class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextAttributes (
Font font
)

Visual Basic [image] Copy Code

Public New ( _
font As Font _
)

Parameters

font

A legacy Font object used to initialize the properties of the new TextAttributes instance.

See Also

TextAttributes Constructor Overload List
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Constructor (ITextAttributes)

TextAttributes Constructor (ITextAttributes)
See Also
[image]

Initializes a new instance of the TextAttributes class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextAttributes (
ITextAttributes attr
)

Visual Basic [image] Copy Code

Public New ( _
attr As ITextAttributes _
)

Parameters

attr

A prototype ITextAttributes object, whose property values are copied to the new TextAttributes instance.

See Also

TextAttributes Constructor Overload List
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Methods

TextAttributes Methods
[image]

Public Methods

Name | Description
Copy | Copies text attributes from source object to target object.

See Also

TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.Copy Method

TextAttributes.Copy Method
[image]

Copies text attributes from source object to target object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static void Copy (
ITextAttributes source,
ITextAttributes target
)

Visual Basic [image] Copy Code

Public Shared Sub Copy( _
source As ITextAttributes, _
target As ITextAttributes _
)

Parameters

source

The source object.

target

The target object.

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Properties

TextAttributes Properties
[image]

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this DiagramItem.
FontSize | Gets or sets the font size for this DiagramItem.
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem.
FontStyle | Gets or sets the font style for this DiagramItem.
FontWeight | Gets or sets the font weight for this DiagramItem.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the text displayed inside this item.
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this DiagramItem should wrap text.

See Also

TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.FontFamily Property

TextAttributes.FontFamily Property
[image]

Gets or sets the preferred font family for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.FontSize Property

TextAttributes.FontSize Property
[image]

Gets or sets the font size for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.FontStretch Property

TextAttributes.FontStretch Property
[image]

Gets or sets the font-stretching characteristics for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStretch FontStretch { get; set; }

Visual Basic [image] Copy Code

Public Property FontStretch As FontStretch

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.FontStyle Property

TextAttributes.FontStyle Property
[image]

Gets or sets the font style for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.FontWeight Property

TextAttributes.FontWeight Property
[image]

Gets or sets the font weight for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextAlignment Property

TextAttributes.TextAlignment Property
[image]

Gets or sets a value that indicates the horizontal alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextBrush Property

TextAttributes.TextBrush Property
[image]

Gets or sets the text displayed inside this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is Brushes.Black.

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextDecorations Property

TextAttributes.TextDecorations Property
[image]

Gets or sets the effects to apply to the text of this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextDecorationCollection TextDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property TextDecorations As TextDecorationCollection

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextPadding Property

TextAttributes.TextPadding Property
[image]

Gets or sets the thickness of padding space between the item boundaries and its text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Property TextPadding As Thickness

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextTrimming Property

TextAttributes.TextTrimming Property
[image]

Gets or sets the text trimming to employ when text overflows the item area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextTrimming TextTrimming { get; set; }

Visual Basic [image] Copy Code

Public Property TextTrimming As TextTrimming

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextVerticalAlignment Property

TextAttributes.TextVerticalAlignment Property
[image]

Gets or sets a value that indicates the vertical alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AlignmentY TextVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextVerticalAlignment As AlignmentY

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.TextWrapping Property

TextAttributes.TextWrapping Property
[image]

Gets or sets how this DiagramItem should wrap text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextWrapping TextWrapping { get; set; }

Visual Basic [image] Copy Code

Public Property TextWrapping As TextWrapping

Property Value

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes Events

TextAttributes Events
[image]

Public Events

Name | Description
PropertyChanged | Implements the INotifyPropertyChanged.PropertyChanged event.

See Also

TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextAttributes.PropertyChanged Event

TextAttributes.PropertyChanged Event
[image]

Implements the INotifyPropertyChanged.PropertyChanged event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

TextAttributes Members
TextAttributes Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Class

TextPresenter Class
[image]

Implements a container for text content and defines text attributes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TextPresenter : FrameworkElement, ITextAttributes

Visual Basic [image] Copy Code

Public Class TextPresenter
Inherits FrameworkElement
Implements ITextAttributes

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.LinkLabel
MindFusion.Diagramming.Wpf.TableNode.Cell
MindFusion.Diagramming.Wpf.TreeViewItem
MindFusion.Diagramming.Wpf.Lanes.Header

See Also

TextPresenter Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Members

TextPresenter Members
Constructors Fields Properties Methods
[image]

Implements a container for text content and defines text attributes.

The following tables list the members exposed by the TextPresenter type.

Public Constructors

Name | Description
TextPresenter | Initializes a new instance of the TextPresenter class.

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextPaddingProperty | Identifies the TextPadding dependency property.
TextProperty | Identifies the Text dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property.
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this TextPresenter.
FontSize | Gets or sets the font size for this TextPresenter.
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter.
FontStyle | Gets or sets the font style for this TextPresenter.
FontWeight | Gets or sets the font weight for this TextPresenter.
Text | Gets or sets the text displayed inside this item.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the text displayed inside this item.
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this TextPresenter should wrap text.

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object.

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element.
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes.
SaveTextAttributes | Saves the text properties to the specified XML element.
SetDiagramDirty | Invoked when a value is assigned to a property and the diagram's Dirty flag must be set.

See Also

TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Fields

TextPresenter Fields
[image]

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextBrushProperty | Identifies the TextBrush dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextPaddingProperty | Identifies the TextPadding dependency property.
TextProperty | Identifies the Text dependency property.
TextTrimmingProperty | Identifies the TextTrimming dependency property.
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

See Also

TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontFamilyProperty Field

TextPresenter.FontFamilyProperty Field
[image]

Identifies the FontFamily dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontFamilyProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontSizeProperty Field

TextPresenter.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontStretchProperty Field

TextPresenter.FontStretchProperty Field
[image]

Identifies the FontStretch dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontStretchProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontStyleProperty Field

TextPresenter.FontStyleProperty Field
[image]

Identifies the FontStyle dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontStyleProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontWeightProperty Field

TextPresenter.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontWeightProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextAlignmentProperty Field

TextPresenter.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextBrushProperty Field

TextPresenter.TextBrushProperty Field
[image]

Identifies the TextBrush dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextBrushProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextDecorationsProperty Field

TextPresenter.TextDecorationsProperty Field
[image]

Identifies the TextDecorations dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextDecorationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextDecorationsProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextPaddingProperty Field

TextPresenter.TextPaddingProperty Field
[image]

Identifies the TextPadding dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextPaddingProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextProperty Field

TextPresenter.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextTrimmingProperty Field

TextPresenter.TextTrimmingProperty Field
[image]

Identifies the TextTrimming dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextTrimmingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextTrimmingProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextVerticalAlignmentProperty Field

TextPresenter.TextVerticalAlignmentProperty Field
[image]

Identifies the TextVerticalAlignment dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextVerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextVerticalAlignmentProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextWrappingProperty Field

TextPresenter.TextWrappingProperty Field
[image]

Identifies the TextWrapping dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextWrappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Constructor

TextPresenter Constructor
[image]

Initializes a new instance of the TextPresenter class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextPresenter (
bool inheritFromParent
)

Visual Basic [image] Copy Code

Public New ( _
inheritFromParent As Boolean _
)

Parameters

inheritFromParent

See Also

TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Methods

TextPresenter Methods
[image]

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object.

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element.
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes.
SaveTextAttributes | Saves the text properties to the specified XML element.
SetDiagramDirty | Invoked when a value is assigned to a property and the diagram's Dirty flag must be set.

See Also

TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.CopyFrom Method

TextPresenter.CopyFrom Method
[image]

Copies all text attributes from the specified object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyFrom (
ITextAttributes prototype
)

Visual Basic [image] Copy Code

Public Sub CopyFrom( _
prototype As ITextAttributes _
)

Parameters

prototype

An object implementing the ITextAttributes interface.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.LoadTextAttributes Method

TextPresenter.LoadTextAttributes Method
[image]

Loads the text properties to the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void LoadTextAttributes (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadTextAttributes( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.OnTextAttributeChanged Method

TextPresenter.OnTextAttributeChanged Method
[image]

Invoked when any of the attributes defined in ITextAttributes changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.SaveTextAttributes Method

TextPresenter.SaveTextAttributes Method
[image]

Saves the text properties to the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void SaveTextAttributes (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveTextAttributes( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

context

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.SetDiagramDirty Method

TextPresenter.SetDiagramDirty Method
[image]

Invoked when a value is assigned to a property and the diagram's Dirty flag must be set.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Overridable Sub SetDiagramDirty ()

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter Properties

TextPresenter Properties
[image]

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this TextPresenter.
FontSize | Gets or sets the font size for this TextPresenter.
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter.
FontStyle | Gets or sets the font style for this TextPresenter.
FontWeight | Gets or sets the font weight for this TextPresenter.
Text | Gets or sets the text displayed inside this item.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
TextBrush | Gets or sets the text displayed inside this item.
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content.
TextWrapping | Gets or sets how this TextPresenter should wrap text.

See Also

TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontFamily Property

TextPresenter.FontFamily Property
[image]

Gets or sets the preferred font family for this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

A FontFamily instance. The default value is "Arial".

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontSize Property

TextPresenter.FontSize Property
[image]

Gets or sets the font size for this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value specifying the font size. The default value is 13.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontStretch Property

TextPresenter.FontStretch Property
[image]

Gets or sets the font-stretching characteristics for this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStretch FontStretch { get; set; }

Visual Basic [image] Copy Code

Public Property FontStretch As FontStretch

Property Value

A FontStretch instance. The default value is FontStretches.Normal.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontStyle Property

TextPresenter.FontStyle Property
[image]

Gets or sets the font style for this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A FontStyle instance. The default value is FontStyles.Normal.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.FontWeight Property

TextPresenter.FontWeight Property
[image]

Gets or sets the font weight for this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A FontWeight instance. The default value is FontWeights.Normal.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.Text Property

TextPresenter.Text Property
[image]

Gets or sets the text displayed inside this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextAlignment Property

TextPresenter.TextAlignment Property
[image]

Gets or sets a value that indicates the horizontal alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. The default value is TextAlignment.Left.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextBrush Property

TextPresenter.TextBrush Property
[image]

Gets or sets the text displayed inside this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is Brushes.Black.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextDecorations Property

TextPresenter.TextDecorations Property
[image]

Gets or sets the effects to apply to the text of this TextPresenter.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextDecorationCollection TextDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property TextDecorations As TextDecorationCollection

Property Value

A TextDecorationCollection instance. The default value is null.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextPadding Property

TextPresenter.TextPadding Property
[image]

Gets or sets the thickness of padding space between the item boundaries and its text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Property TextPadding As Thickness

Property Value

A Thickness instance. The default thickness is 1 millimeter.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextTrimming Property

TextPresenter.TextTrimming Property
[image]

Gets or sets the text trimming to employ when text overflows the item area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextTrimming TextTrimming { get; set; }

Visual Basic [image] Copy Code

Public Property TextTrimming As TextTrimming

Property Value

A member of the TextTrimming enumeration. The default value is TextTrimming.None.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextVerticalAlignment Property

TextPresenter.TextVerticalAlignment Property
[image]

Gets or sets a value that indicates the vertical alignment of text content.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AlignmentY TextVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextVerticalAlignment As AlignmentY

Property Value

A member of the AlignmentY enumeration. The default value is AlignmentY.Top.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TextPresenter.TextWrapping Property

TextPresenter.TextWrapping Property
[image]

Gets or sets how this TextPresenter should wrap text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TextWrapping TextWrapping { get; set; }

Visual Basic [image] Copy Code

Public Property TextWrapping As TextWrapping

Property Value

A member of the TextWrapping enumeration. The default value is TextWrapping.Wrap.

See Also

TextPresenter Members
TextPresenter Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme Class

Theme Class
[image]

Represents a set of Style objects for different diagram item types.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Theme

Visual Basic [image] Copy Code

Public Class Theme

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Theme

See Also

Theme Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme Members

Theme Members
Constructors Methods
[image]

Represents a set of Style objects for different diagram item types.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme Constructor

Theme Constructor
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Theme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme Methods

Theme Methods
[image]

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.GetStyle Method

Theme.GetStyle Method
[image]

Gets the Style object, if any, associated with the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style GetStyle (
Type type
)

Visual Basic [image] Copy Code

Public Function GetStyle( _
type As Type _
) As Style

Parameters

type

The runtime type whose style to retrieve.

Return Value

The Style associated with the type, or null (Nothing in Visual Basic).

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.LoadFromString Method

Theme.LoadFromString Method
[image]

Loads the theme from an XML string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromString (
string xml
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
xml As String _
)

Parameters

xml

The string to load from.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.LoadFromXml Method

Theme.LoadFromXml Method
[image]

Loads the theme from an XML file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.RegisterStyle Method

Theme.RegisterStyle Method
[image]

Registers the specified Style object for the items of the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RegisterStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Sub RegisterStyle( _
type As Type, _
style As Style _
)

Parameters

type

The runtime type to register.

style

The style to associate with the specified type. The previously associated style, if any, is discarded.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.SaveToString Method

Theme.SaveToString Method
[image]

Saves the theme into an XML string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

The serialized string.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.SaveToXml Method

Theme.SaveToXml Method
[image]

Saves the theme to an XML file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file to save to.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Theme.UnregisterStyle Method

Theme.UnregisterStyle Method
[image]

Unregisters the Style object associated with the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UnregisterStyle (
Type type
)

Visual Basic [image] Copy Code

Public Sub UnregisterStyle( _
type As Type _
)

Parameters

type

The runtime type to unregister.

See Also

Theme Members
Theme Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator Class

TreeEnumerator Class
Remarks See Also
[image]

Enables an easy standard method to itereate over the elements of a tree-like structure of objects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeEnumerator : IEnumerator

Visual Basic [image] Copy Code

Public Class TreeEnumerator
Implements IEnumerator

Remarks

The TreeEnumerator class implements the standard .NET IEnumerator interface. It provides an easy method to iterate over the elements of a tree-like structure of diagram items.

Example

The following example demonstrates how to use the TreeEnumerator:

C# [image] Copy Code

TreeEnumerator te = new TreeEnumerator(
rootObj, false, false);

while (te.MoveNext())
{
ShapeNode node = (ShapeNode)te.Current;
node.Brush = Brushes.Blue;
}

Visual Basic [image] Copy Code

Dim te As MindFusion.Diagramming.TreeEnumerator = New MindFusion.Diagramming.TreeEnumerator( _
rootObj, False, False)

While te.MoveNext()
Dim node As ShapeNode = CType(te.Current, ShapeNode)
Node.Brush = Brushes.Blue
End While

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.TreeEnumerator

See Also

TreeEnumerator Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator Members

TreeEnumerator Members
Constructors Properties Methods
[image]

Enables an easy standard method to itereate over the elements of a tree-like structure of objects.

The following tables list the members exposed by the TreeEnumerator type.

Public Constructors

Name | Description
TreeEnumerator | Initializes a new instance of the TreeEnumerator class.

Public Properties

Name | Description
Current | Gets the current element of the iteration.

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator Constructor

TreeEnumerator Constructor
[image]

Initializes a new instance of the TreeEnumerator class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeEnumerator (
DiagramNode root,
bool enumLinks,
bool strict
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode, _
enumLinks As Boolean, _
strict As Boolean _
)

Parameters

root

The root of the tree or subtree to be enumerated.

enumLinks

Specifies whether to enumerate links.

strict
Specifies whether to check strictly if the passed structure is a tree. If this option is enabled, NotATreeException will be thrown if a cycle or multiple links to a node are encountered. If the option is disabled, the enumerator will ignore any cycles or multiple links found and continue the iteration.

See Also

TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator Methods

TreeEnumerator Methods
[image]

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator.MoveNext Method

TreeEnumerator.MoveNext Method
[image]

Advances the enumerator to the next element of the tree.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MoveNext ()

Visual Basic [image] Copy Code

Public Function MoveNext () As Boolean

Return Value

true if the enumerator has successfully passed to the next DiagramItem in the collection; false if there are no more elements available to enumerate.

Remarks

Initially an enumerator is positioned before the first element of the tree (the root), and the first call to MoveNext moves the enumerator over that first element.

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator.Reset Method

TreeEnumerator.Reset Method
[image]

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator Properties

TreeEnumerator Properties
[image]

Public Properties

Name | Description
Current | Gets the current element of the iteration.

See Also

TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeEnumerator.Current Property

TreeEnumerator.Current Property
[image]

Gets the current element of the iteration.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Current { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Current As Object

Property Value

The DiagramItem that is current in the enumeration.

Remarks

If the enumLinks constructor argument is set to false, only nodes are enumerated. After an enumerator is created or after a Reset, MoveNext must be called to advance the enumerator to the first element before reading the value of Current; otherwise, Current is undefined.

See Also

TreeEnumerator Members
TreeEnumerator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs Class

TreeItemEventArgs Class
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TreeItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.TreeItemEventArgs
MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs

See Also

TreeItemEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs Members

TreeItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

The following tables list the members exposed by the TreeItemEventArgs type.

Public Constructors

Name | Description
TreeItemEventArgs | Initializes a new instance of the TreeItemEventArgs class.

Public Properties

Name | Description
Item | Get the item for which the event is raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.

See Also

TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs Constructor

TreeItemEventArgs Constructor
[image]

Initializes a new instance of the TreeItemEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeItemEventArgs (
TreeViewItem item,
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

item
The TreeViewItem related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

See Also

TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs Properties

TreeItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Get the item for which the event is raised.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets the current mouse pointer position.

See Also

TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs.Item Property

TreeItemEventArgs.Item Property
[image]

Get the item for which the event is raised.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

An instance of the TreeViewItem class.

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs.MouseButton Property

TreeItemEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the MouseButton enumeration.

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemEventArgs.MousePosition Property

TreeItemEventArgs.MousePosition Property
[image]

Gets the current mouse pointer position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MousePosition As Point

Property Value

An instance of the System.Windows.Point structure.

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs Class

TreeItemValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeItemValidationEventArgs : TreeItemEventArgs

Visual Basic [image] Copy Code

Public Class TreeItemValidationEventArgs
Inherits TreeItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.TreeItemEventArgs
MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs

See Also

TreeItemValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs Members

TreeItemValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

The following tables list the members exposed by the TreeItemValidationEventArgs type.

Public Constructors

Name | Description
TreeItemValidationEventArgs | Initializes a new instance of the TreeItemValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from TreeItemEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs Constructor

TreeItemValidationEventArgs Constructor
[image]

Initializes a new instance of the TreeItemValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeItemValidationEventArgs (
TreeViewItem item,
MouseButton mouseButton,
Point mousePosition
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
mouseButton As MouseButton, _
mousePosition As Point _
)

Parameters

item
The TreeViewItem related to the event.
mouseButton

The mouse button related to the event.

mousePosition

The position of the mouse at the time the event was raised.

See Also

TreeItemValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs Properties

TreeItemValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
MouseButton | Gets which mouse button has been pressed. (Inherited from TreeItemEventArgs.)
MousePosition | Gets the current mouse pointer position. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeItemValidationEventArgs.Cancel Property

TreeItemValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation, otherwise false; the default value is false.

See Also

TreeItemValidationEventArgs Members
TreeItemValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Class

TreeViewConnectionPoint Class
[image]

Represents a connection between a link and a TreeViewNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeViewConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class TreeViewConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.ConnectionPoint
MindFusion.Diagramming.Wpf.TreeViewConnectionPoint

See Also

TreeViewConnectionPoint Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Members

TreeViewConnectionPoint Members
Constructors Properties Methods
[image]

Represents a connection between a link and a TreeViewNode.

The following tables list the members exposed by the TreeViewConnectionPoint type.

Public Constructors

Name | Description
TreeViewConnectionPoint | Overloaded. Initializes a new instance of the TreeViewConnectionPoint class.

Public Properties

Name | Description
Item | Gets the item to which the link connects.
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AnchorPointFromIndex | Returns the AnchorPoint instance with the specified index. (Inherited from ConnectionPoint.)
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
NearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Constructor

TreeViewConnectionPoint Constructor
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Overload List

Name | Description
TreeViewConnectionPoint () | Initializes a new instance of the TreeViewConnectionPoint class.
TreeViewConnectionPoint (TreeViewNode, DiagramLink, Boolean, TreeViewItem) | Initializes a new instance of the TreeViewConnectionPoint class.

See Also

TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Constructor ()

TreeViewConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)

TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint (
TreeViewNode node,
DiagramLink link,
bool incoming,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
link As DiagramLink, _
incoming As Boolean, _
item As TreeViewItem _
)

Parameters

node
A TreeViewNode instance.
link
A DiagramLink instance.
incoming
Specifies which end of the link is represented by this TreeViewConnectionPoint.
item
The TreeViewItem to which the link connects.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Methods

TreeViewConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AnchorPointFromIndex | Returns the AnchorPoint instance with the specified index. (Inherited from ConnectionPoint.)
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)
SaveEndRelative | ConnectionPoint.SaveEndRelative override.

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
NearestAnchorPoint | ConnectionPoint.GetNearestAnchorPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.AddLinkToNode Method

TreeViewConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.GetEndPoint Method

TreeViewConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.GetEndPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.GetInitialPoint Method

TreeViewConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.GetIntersection Method

TreeViewConnectionPoint.GetIntersection Method
[image]

ConnectionPoint.GetIntersection override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.GetNearestBorderPoint Method

TreeViewConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

A Point instance specifying the current mouse position.

Return Value

Position of the border point nearest to the specified point.

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.LinkChanges Method

TreeViewConnectionPoint.LinkChanges Method
[image]

ConnectionPoint.LinkChanges override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool LinkChanges (
DiagramItem item,
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function LinkChanges( _
item As DiagramItem, _
point As Point _
) As Boolean

Parameters

item

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.NearestAnchorPoint Method

TreeViewConnectionPoint.NearestAnchorPoint Method
[image]

ConnectionPoint.GetNearestAnchorPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Point NearestAnchorPoint (
Point point,
ref int idx
)

Visual Basic [image] Copy Code

Protected Overrides Function NearestAnchorPoint( _
point As Point, _
ByRef idx As Integer _
) As Point

Parameters

point

idx

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.RemoveLinkFromNode Method

TreeViewConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.SaveEndRelative Method

TreeViewConnectionPoint.SaveEndRelative Method
[image]

ConnectionPoint.SaveEndRelative override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void SaveEndRelative ()

Visual Basic [image] Copy Code

Public Overrides Sub SaveEndRelative ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.UpdateFromPoint Method

TreeViewConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void UpdateFromPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateFromPoint( _
point As Point _
)

Parameters

point

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint Properties

TreeViewConnectionPoint Properties
[image]

Public Properties

Name | Description
Item | Gets the item to which the link connects.
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)
RelativePosition | Gets or sets the position of this connection point, relative to the associated node's bounding rectangle, expressed in percents. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.Item Property

TreeViewConnectionPoint.Item Property
[image]

Gets the item to which the link connects.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionPoint.Row Property

TreeViewConnectionPoint.Row Property
[image]

ConnectionPoint.Row override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int Row { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Row As Integer

Property Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewConnectionStyle Enumeration

TreeViewConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of TreeViewNodes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeViewConnectionStyle

Visual Basic [image] Copy Code

Public Enum TreeViewConnectionStyle

Members

Member name | Description
Items | Users are allowed to create relations to the items of a TreeViewNode.
Node | Users are allowed to create relations to the TreeViewNode as an integral entity.

See Also

MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Class

TreeViewItem Class
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeViewItem : TextPresenter, INotifyPropertyChanged, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewItem
Inherits TextPresenter
Implements INotifyPropertyChanged, InplaceEditable

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.TreeViewItem

See Also

TreeViewItem Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Members

TreeViewItem Members
Constructors Fields Properties Methods Events
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

The following tables list the members exposed by the TreeViewItem type.

Public Constructors

Name | Description
TreeViewItem | Overloaded. Initializes a new instance of the TreeViewItem class.

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Dirty | For internal use.
Expanded | Gets or sets whether this item is expanded to show its children.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the label color of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Tag | Gets or sets custom data associated with this item.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Constructor

TreeViewItem Constructor
[image]

Initializes a new instance of the TreeViewItem class.

Overload List

Name | Description
TreeViewItem () | Initializes a new instance of the TreeViewItem class.
TreeViewItem (String) | Initializes a new instance of the TreeViewItem class.
TreeViewItem (TreeViewItem) | Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

See Also

TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Constructor ()

TreeViewItem Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Constructor (String)

TreeViewItem Constructor (String)
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem (
string label
)

Visual Basic [image] Copy Code

Public New ( _
label As String _
)

Parameters

label
The text initially displayed by the item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Constructor (TreeViewItem)

TreeViewItem Constructor (TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem (
TreeViewItem prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewItem _
)

Parameters

prototype

The treeview item to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewItem property values from the specified prototype item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Methods

TreeViewItem Methods
[image]

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

See Also

TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.OnTextAttributeChanged Method

TreeViewItem.OnTextAttributeChanged Method
[image]

TextPresenter.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.SetDiagramDirty Method

TreeViewItem.SetDiagramDirty Method
[image]

TextPresenter.SetDiagramDirty override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Overrides Sub SetDiagramDirty ()

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Properties

TreeViewItem Properties
[image]

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Dirty | For internal use.
Expanded | Gets or sets whether this item is expanded to show its children.
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the label color of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Tag | Gets or sets custom data associated with this item.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)

See Also

TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Children Property

TreeViewItem.Children Property
[image]

Gets a list of this item's children in the hierarchy.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<TreeViewItem> Children { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Children As IList(Of TreeViewItem)

Property Value

A list of child TreeViewItem objects.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Dirty Property

TreeViewItem.Dirty Property
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Dirty { get; set; }

Visual Basic [image] Copy Code

Public Property Dirty As Boolean

Property Value

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Expanded Property

TreeViewItem.Expanded Property
[image]

Gets or sets whether this item is expanded to show its children.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true to show the children of this item, otherwise false; the default value is true.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Height Property

TreeViewItem.Height Property
[image]

Gets or sets the height of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value specifying the item's height. The default value is 20.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Image Property

TreeViewItem.Image Property
[image]

Gets or sets the image that is displayed in this treeview item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.IncomingLinks Property

TreeViewItem.IncomingLinks Property
[image]

Gets a collection of all links that point to this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that point to this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Label Property

TreeViewItem.Label Property
[image]

Gets or sets the label of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the item's label.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.LabelBrush Property

TreeViewItem.LabelBrush Property
[image]

Gets or sets the label color of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

An instance of a System.Windows.Media.Brush-derived class.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.OutgoingLinks Property

TreeViewItem.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that start from this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.Tag Property

TreeViewItem.Tag Property
[image]

Gets or sets custom data associated with this item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null (Nothing in Visual Basic).

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem Events

TreeViewItem Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewItem.PropertyChanged Event

TreeViewItem.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.PropertyChanged.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

TreeViewItem Members
TreeViewItem Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Class

TreeViewNode Class
Remarks See Also
[image]

Represents nodes that can draw hierarchical data.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeViewNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

The text and image displayed in the node caption can be customized through the Caption and CaptionImage properties respectively. The scroll position can be manipulated through ScrollPosition.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.TreeViewNode

See Also

TreeViewNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Members

TreeViewNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can draw hierarchical data.

The following tables list the members exposed by the TreeViewNode type.

Public Constructors

Name | Description
TreeViewNode | Overloaded. Initializes a new instance of the TreeViewNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionBrush | Gets or sets the brush used to draw the caption text.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the treeview's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this node.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | Visual.VisualChildrenCount override.

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the node on the specified DrawingContext.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified DrawingContext.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | Visual.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | DiagramNode.SetReflexive override.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Fields

TreeViewNode Fields
[image]

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
CaptionHeightProperty | Identifies the CaptionHeight dependency property.
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
ShapeProperty | Identifies the Shape dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

See Also

TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CaptionHeightProperty Field

TreeViewNode.CaptionHeightProperty Field
[image]

Identifies the CaptionHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CaptionHeightProperty

Visual Basic [image] Copy Code

Public Shared CaptionHeightProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.ShapeProperty Field

TreeViewNode.ShapeProperty Field
[image]

Identifies the Shape dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ShapeProperty As DependencyProperty

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Constructor

TreeViewNode Constructor
[image]

Initializes a new instance of the TreeViewNode class.

Overload List

Name | Description
TreeViewNode () | Initializes a new instance of the TreeViewNode class.
TreeViewNode (Diagram) | Initializes a new instance of the TreeViewNode class.
TreeViewNode (TreeViewNode) | Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

See Also

TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Constructor ()

TreeViewNode Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Constructor (Diagram)

TreeViewNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TreeViewNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Constructor (TreeViewNode)

TreeViewNode Constructor (TreeViewNode)
See Also
[image]

Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode (
TreeViewNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewNode _
)

Parameters

prototype

The treeview node to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewNode property values from the specified prototype node.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Methods

TreeViewNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | Draws the node on the specified DrawingContext.
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified DrawingContext.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramNode.EnumStyleableProperties override.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | Visual.GetVisualChild override.
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the item changes.
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | DiagramItem.OnTextAttributeChanged override.
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the Diagram's ZoomFactor changes.
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | DiagramNode.SetReflexive override.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.AcceptLinks Method

TreeViewNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean, _
mousePosition As Point _
) As Boolean

Parameters

outgoing
true to check for outgoing links; otherwise, false.
mousePosition

The current mouse pointer position in diagram coordinates.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CreateConnectionPoint Method

TreeViewNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Protected Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link
A DiagramLink that should be connected to this node.
pt

The point at which the link should be connected.

incoming

true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CreateProperties Method

TreeViewNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.Draw Method

TreeViewNode.Draw Method
[image]

Draws the node on the specified DrawingContext.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void Draw (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw ( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics
A System.Windows.Media.DrawingContext object where the node should be rendered.
options

Provides options for the drawing operation.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.DrawLocal Method

TreeViewNode.DrawLocal Method
[image]

Draws the node on the specified DrawingContext.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.EnumStyleableProperties Method

TreeViewNode.EnumStyleableProperties Method
[image]

DiagramNode.EnumStyleableProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void EnumStyleableProperties (
Action<DependencyProperty> func
)

Visual Basic [image] Copy Code

Protected Overrides Sub EnumStyleableProperties( _
func As Action(Of DependencyProperty) _
)

Parameters

func

The method that should be called for each property.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.GetAllIncomingLinks Method

TreeViewNode.GetAllIncomingLinks Method
[image]

DiagramNode.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection instance where all links entering this node should be collected.

Remarks

This method also adds the links that enter tree items, which otherwise are not included in the node's IncomingLinks collection, but in the one of the TreeViewItem object.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.GetAllOutgoingLinks Method

TreeViewNode.GetAllOutgoingLinks Method
[image]

DiagramNode.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links
A DiagramLinkCollection instance where all links going out of this node should be collected.

Remarks

This method also adds the links that go out of tree items, which otherwise are not included in the node's OutgoingLinks collection, but in the one of the TreeViewItem object.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.GetItemRect Method

TreeViewNode.GetItemRect Method
[image]

Gets the location and size of the specified TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetItemRect (
TreeViewItem treeItem
)

Visual Basic [image] Copy Code

Public Function GetItemRect( _
treeItem As TreeViewItem _
) As Rect

Parameters

treeItem
A TreeViewItem instance.

Return Value

A Rect specifying the item's position and size.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.GetVisualChild Method

TreeViewNode.GetVisualChild Method
[image]

Visual.GetVisualChild override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index

Return Value

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.HitTestExpander Method

TreeViewNode.HitTestExpander Method
[image]

Gets whether there is a collapse/expand button located at the specified position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool HitTestExpander (
Point point
)

Visual Basic [image] Copy Code

Public Function HitTestExpander( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true if there is +/- icon at the specified position, otherwise false.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.ItemFromPoint Method

TreeViewNode.ItemFromPoint Method
[image]

Returns the item at the specified location.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem ItemFromPoint (
Point point,
bool isDiagramCoordinate
)

Visual Basic [image] Copy Code

Public Function ItemFromPoint( _
point As Point, _
isDiagramCoordinate As Boolean _
) As TreeViewItem

Parameters

point

The point to check.

isDiagramCoordinate
true if the point is specified in logical diagram coordinates; false if the point is specified in WPF points.

Return Value

The TreeViewItem instance that contains the specified point.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.LoadFromXml Method

TreeViewNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnLoad Method

TreeViewNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLoad ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnLoad ()

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnMeasureUnitChanged Method

TreeViewNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnMouseDown Method

TreeViewNode.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnSizeChanged Method

TreeViewNode.OnSizeChanged Method
[image]

Called when the size of the item changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnSizeChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnSizeChanged ()

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnTextAttributeChanged Method

TreeViewNode.OnTextAttributeChanged Method
[image]

DiagramItem.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnUpdateBounds Method

TreeViewNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds ()

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.OnZoomChanged Method

TreeViewNode.OnZoomChanged Method
[image]

Called when the Diagram's ZoomFactor changes.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnZoomChanged ()

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.RemoveItem Method

TreeViewNode.RemoveItem Method
[image]

Removes the specified item from the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RemoveItem (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Sub RemoveItem( _
item As TreeViewItem _
)

Parameters

item
The TreeViewItem to remove.

Remarks

The method removes the specified item and all its direct or indirect children, as well as the links connecting to them.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.RestoreProperties Method

TreeViewNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.SaveProperties Method

TreeViewNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props
A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.SaveToXml Method

TreeViewNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context
An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.ScaleElements Method

TreeViewNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.SetReflexive Method

TreeViewNode.SetReflexive Method
[image]

DiagramNode.SetReflexive override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link
Reference to the self-loop link.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode Properties

TreeViewNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionBrush | Gets or sets the brush used to draw the caption text.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
EnableStyledText | Gets or sets a value indicating whether styled text rendering is enabled.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the treeview's outline.
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this node.
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | Visual.VisualChildrenCount override.

See Also

TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.Caption Property

TreeViewNode.Caption Property
[image]

Gets or sets the text displayed as caption of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string specifying the caption text.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CaptionBrush Property

TreeViewNode.CaptionBrush Property
[image]

Gets or sets the brush used to draw the caption text.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default is Brushes.Black.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CaptionHeight Property

TreeViewNode.CaptionHeight Property
[image]

Gets or sets the height of the node's caption area.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the caption area height. The default value is 18.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.CaptionImage Property

TreeViewNode.CaptionImage Property
[image]

Gets or sets the image that is displayed in the caption.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource CaptionImage { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionImage As ImageSource

Property Value

An instance of the System.Windows.Media.ImageSource class.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.ConnectionStyle Property

TreeViewNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TreeViewConnectionStyle

Property Value

A member of the TreeViewConnectionStyle enumeration. The default value is Items.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.EnableStyledText Property

TreeViewNode.EnableStyledText Property
[image]

Gets or sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableStyledText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableStyledText As Boolean

Property Value

true to parse the text of the node's caption and items in order to find formatting tags; otherwise false. Initialized with the value of EnableStyledText.

Remarks

Styled text allows applying various attributes to the characters it contains. Attributes are specified using HTML-like formatting tags embedded in the raw text. Formatting tags are listed and described in the Text Attributes and Formatting section of this help file.

If EnableStyledText is set to true, the node's Caption and the items' Label are parsed and analyzed each time they change. Parsing determines what formatting tags are used and adds the corresponding attribute records to the internal representation of styled text. If the property value is false, the text is not processed in any way and is displayed without formatting.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.RootItems Property

TreeViewNode.RootItems Property
[image]

Gets a list of the root TreeViewItem objects displayed in this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<TreeViewItem> RootItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RootItems As IList(Of TreeViewItem)

Property Value

A list of TreeViewItem objects.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.ScrollPosition Property

TreeViewNode.ScrollPosition Property
[image]

Gets or sets the current scroll position.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ScrollPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollPosition As Double

Property Value

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.Shape Property

TreeViewNode.Shape Property
[image]

Gets or sets the shape of the treeview's outline.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.TextFormat Property

TreeViewNode.TextFormat Property
[image]

Gets or sets the alignment of texts displayed inside this node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

This property is deprecated. Use the TextAlignment, TextDecorations, TextPadding, TextTrimming, TextVerticalAlignment and TextWrapping properties to set format attributes.

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.TreeViewNode.VisualChildrenCount Property

TreeViewNode.VisualChildrenCount Property
[image]

Visual.VisualChildrenCount override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

See Also

TreeViewNode Members
TreeViewNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.UndoEventArgs
MindFusion.Diagramming.Wpf.UndoValidationEventArgs

See Also

UndoEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionRecorded, ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

UndoEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of the Command class.

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager Class

UndoManager Class
Remarks See Also
[image]

Implements undo/redo functionality in MindFusion.Diagramming for WPF.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class UndoManager

Visual Basic [image] Copy Code

Public Class UndoManager

Remarks

The only instance of UndoManager can be accessed by the UndoManager property of Diagram.

Use the UndoEnabled property to enable or disable saving action records for later undo. You might need to disable undo before performing actions that must not be undoable by end-users, such as creating special start/end nodes.

MindFusion.Diagramming for WPF does not provide shortcuts to undo or redo an action. An application must provide the user interface means for undo/redo and call the Undo or Redo methods when necessary. Undoing or redoing an action updates the current record pointer of the undo-history queue. To get access to that queue, use the History property.

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming for WPF as a response to users actions or method calls cannot be added directly to a composite. Instead you must use the StartComposite method to create an 'active' composite, to which implicitly created records are added automatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.UndoManager

See Also

UndoManager Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager Members

UndoManager Members
Properties Methods
[image]

Implements undo/redo functionality in MindFusion.Diagramming for WPF.

The following tables list the members exposed by the UndoManager type.

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Wpf Package.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager Methods

UndoManager Methods
[image]

Public Methods

Name | Description
Redo | Executes again an action saved in the command history.
StartComposite | Overloaded. Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Wpf Package.
Undo | Undoes an action saved in the command history.

See Also

UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager.Redo Method

UndoManager.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

Executes again a command from the command history. The action that would be redone by calling this method is pointed by NextRedo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace
Undo Method


MindFusion.Diagramming.Wpf.UndoManager.StartComposite Method

UndoManager.StartComposite Method
[image]

Creates an 'active' composite record to store records of actions that are implicitly created by MindFusion.Wpf Package.

Overload List

Name | Description
UndoManager.StartComposite (String) | Creates an 'active' composite record with the specified title.
UndoManager.StartComposite (String, Boolean) | Creates an 'active' composite record with the specified settings.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager.StartComposite Method (String)

UndoManager.StartComposite Method (String)
See Also
[image]

Creates an 'active' composite record with the specified title.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CompositeCmd StartComposite (
string title
)

Visual Basic [image] Copy Code

Public Function StartComposite( _
title As String _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming for WPF as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

Example

The following example illustrates how to create composite commands:

C# [image] Copy Code

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode(0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();

Visual Basic [image] Copy Code

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As ChangeItemCmd = New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager.StartComposite Method (String, Boolean)

UndoManager.StartComposite Method (String, Boolean)
See Also
[image]

Creates an 'active' composite record with the specified settings.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CompositeCmd StartComposite (
string title,
bool saveZOrder
)

Visual Basic [image] Copy Code

Public Function StartComposite( _
title As String, _
saveZOrder As Boolean _
) As CompositeCmd

Parameters

title
A string to be associated with the composite record. It can be used later to give more information to users what exactly will be undone or redone. Use the Title property of the command class to get the title of an action record.
saveZOrder
Set this parameter to true to save the whole z-order array before executing the composite command, and to restore it back when the command is undone. Use that when there will be create or delete commands added to the composite one, because they do not guarantee restoring the items in the same z-order when the commands are undone or redone.

Return Value

An instance of the CompositeCmd class which represents the active composite record. Call its Execute method when done with recording actions in the composite.

Remarks

Sometimes several actions must be represented as a single atomic operation. That can be achieved by using composites, represented by the CompositeCmd class. However actions records that are implicitly created by MindFusion.Diagramming for WPF as a response to users actions or method calls cannot be added directly to a composite. The StartComposite method creates an 'active' composite, to which implicitly created records are added automatically. Call the composite's Execute method to stop adding action records to it and save it in the command history. Calling Undo or Redo for the composite record, undoes or redoes all actions contained within it.

Example

The following example illustrates how to create composite commands:

C# [image] Copy Code

// Implicitly created undo records will be saved here
CompositeCmd composite = diagram.UndoManager.StartComposite("Create group");

// Call methods that create undo records
ShapeNode node1 = diagram.Factory.CreateShapeNode(0, 0, 30, 30);
ShapeNode node2 = diagram.Factory.CreateShapeNode(0, 0, 15, 15);
Group g = diagram.Factory.CreateGroup(node1);
g.AttachToCorner(node2, 0);

// This goes to the active composite too
ChangeItemCmd change = new ChangeItemCmd(node2, "");
node2.Locked = true;
change.Execute();

// Save the active composite in history
composite.Execute();

Visual Basic [image] Copy Code

' Implicitly created undo records will be saved here
Dim composite As CompositeCmd = diagram.UndoManager.StartComposite("Create group")

' Call methods that create undo records
Dim node1 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 30, 30)
Dim node2 As ShapeNode = diagram.Factory.CreateShapeNode(0, 0, 15, 15)
Dim g As Group = diagram.Factory.CreateGroup(node1)
g.AttachToCorner(node2, 0)

' This goes to the active composite too
Dim change As ChangeItemCmd = New ChangeItemCmd(node2, "")
node2.Locked = True
change.Execute()

' Save the active composite in history
composite.Execute()

See Also

StartComposite Method Overload List
UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager.Undo Method

UndoManager.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

Undoes a command from the command history. The action that would be undone by calling this method is pointed by NextUndo property of the CommandHistory class.

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace
Redo Method


MindFusion.Diagramming.Wpf.UndoManager Properties

UndoManager Properties
[image]

Public Properties

Name | Description
History | Gets a reference to the undo manager's CommandHistory instance.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoManager.History Property

UndoManager.History Property
[image]

Gets a reference to the undo manager's CommandHistory instance.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CommandHistory History { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property History As CommandHistory

Property Value

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace
Command Class


MindFusion.Diagramming.Wpf.UndoManager.UndoEnabled Property

UndoManager.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

See Also

UndoManager Members
UndoManager Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoValidationEventArgs Class

UndoValidationEventArgs Class
[image]

Contains the arguments passed to the ActionRecording event handlers.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class UndoValidationEventArgs : UndoEventArgs

Visual Basic [image] Copy Code

Public Class UndoValidationEventArgs
Inherits UndoEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.UndoEventArgs
MindFusion.Diagramming.Wpf.UndoValidationEventArgs

See Also

UndoValidationEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoValidationEventArgs Members

UndoValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionRecording event handlers.

The following tables list the members exposed by the UndoValidationEventArgs type.

Public Constructors

Name | Description
UndoValidationEventArgs | Initializes a new instance of the UndoValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.
Command | Gets a reference to the Command instance related to the event being handled. (Inherited from UndoEventArgs.)

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoValidationEventArgs Constructor

UndoValidationEventArgs Constructor
[image]

Initializes a new instance of the UndoValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public UndoValidationEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoValidationEventArgs Properties

UndoValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value value indicating whether the operation should be canceled.
Command | Gets a reference to the Command instance related to the event being handled. (Inherited from UndoEventArgs.)

See Also

UndoValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UndoValidationEventArgs.Cancel Property

UndoValidationEventArgs.Cancel Property
[image]

Gets or sets a value value indicating whether the operation should be canceled.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

UndoValidationEventArgs Members
UndoValidationEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.UnitType Enumeration

UnitType Enumeration
[image]

Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum UnitType

Visual Basic [image] Copy Code

Public Enum UnitType

Members

Member name | Description
Fixed | Point coordinates designate fixed offset from the node's top-left corner.
Percentage | Point coordinates are specified as percentage of the node's size.

See Also

MindFusion.Diagramming.Wpf Namespace
XUnit Property
YUnit Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram Class

VirtualizingDiagram Class
Remarks See Also
[image]

Implements virtualization of diagram elements.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VirtualizingDiagram : Diagram

Visual Basic [image] Copy Code

Public Class VirtualizingDiagram
Inherits Diagram

Remarks

VirtualizingDiagram can display very large diagrams where there are actual DiagramNode and DiagramLink instances created only for the elements that should be currently shown on screen. This helps keeping the WPF visual tree small and could lead to huge performance improvements if there are thousands of elements in the diagram.

The data items that should be displayed as nodes must be assigned to the NodesSource property, and the data items that should be displayed as links must be assigned to the LinksSource property. The BindingMode property specifies whether the data source should be updated when the user draws new diagram items interactively.

When the diagram is displayed initially, or while the user scrolls it, VirtualizingDiagram automatically creates TemplatedNode and DiagramLink instances for the items that should be shown on screen. You can create diagram items of a different type via the InstantiateNode and InstantiateLink callbacks. Similarly when the user draws diagram items, the control calls the InstantiateNodeData and InstantiateLinkData delegates to create data items for the new diagram items.

VirtualizingDiagram assumes that node data items expose X and Y properties of type double specifying the node positions, and optional Width and Height properties specifying the node sizes. If Width and Height are not present, the nodes size is set to DefaultNodeSize. It is also possible to specify custom positions via the ResolveNodePosition delegate. Link data items must expose Origin and Destination properties that are references to items from NodesSource.

VirtualizingDiagram is a child class of Diagram and derives all of its properties and events. This lets you specify default appearance properties the usual way, and handle events such as NodeClicked to detect clicks over the visible items. Note that the base Nodes and Links collections will contain items only for the currently visible portion of the diagram.

When handling Diagram events raised for nodes and links, use the GetDataItem method to find out which item from the data source is associated with an actual diagram item. Vice versa, call GetDiagramNode and GetDiagramLink to find out the diagram item currently shown for a data item, if any.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Diagramming.Wpf.DiagramBase
MindFusion.Diagramming.Wpf.Diagram
MindFusion.Diagramming.Wpf.VirtualizingDiagram

See Also

VirtualizingDiagram Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram Members

VirtualizingDiagram Members
Constructors Fields Attached Properties Properties Methods Events
[image]

Implements virtualization of diagram elements.

The following tables list the members exposed by the VirtualizingDiagram type.

Public Constructors

Name | Description
VirtualizingDiagram | Initializes a new instance of the VirtualizingDiagram class.

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property. (Inherited from Diagram.)
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property. (Inherited from Diagram.)
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node. (Inherited from Diagram.)
DefaultShapeProperty | Identifies the DefaultShape dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property. (Inherited from Diagram.)
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property. (Inherited from Diagram.)
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property. (Inherited from Diagram.)
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property. (Inherited from Diagram.)
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property. (Inherited from Diagram.)
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property. (Inherited from Diagram.)
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property. (Inherited from Diagram.)
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property. (Inherited from Diagram.)
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property. (Inherited from Diagram.)
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property. (Inherited from Diagram.)
LinksSourceProperty | Identifies the LinksSource dependency property.
LinkTextProperty | Identifies the LinkText dependency property. (Inherited from Diagram.)
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property. (Inherited from Diagram.)
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property. (Inherited from Diagram.)
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property. (Inherited from Diagram.)
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property. (Inherited from Diagram.)
MeasureUnitProperty | Identifies the MeasureUnit dependency property. (Inherited from Diagram.)
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item (Inherited from Diagram.)
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item (Inherited from Diagram.)
NavigateRight | Selects the diagram item that stands to the right of the currently selected item (Inherited from Diagram.)
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
NodesSourceProperty | Identifies the NodesSource dependency property.
NodeStyleSelectorProperty | Identifies the NodeStyleSelector dependency property.
NodeTemplateProperty | Identifies the NodeTemplate dependency property. (Inherited from Diagram.)
RotationStepProperty | Identifies the RotationStep dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
ShapeTextProperty | Identifies the ShapeText dependency property. (Inherited from Diagram.)
TableBrushProperty | Identifies the TableBrush dependency property. (Inherited from Diagram.)
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property. (Inherited from Diagram.)
TableCaptionProperty | Identifies the TableCaption dependency property. (Inherited from Diagram.)
TableColumnCountProperty | Identifies the TableColumnCount dependency property. (Inherited from Diagram.)
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property. (Inherited from Diagram.)
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property. (Inherited from Diagram.)
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property. (Inherited from Diagram.)
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TableRowCountProperty | Identifies the TableRowCount dependency property. (Inherited from Diagram.)
TableRowHeightProperty | Identifies the TableRowHeight dependency property. (Inherited from Diagram.)
TableShapeProperty | Identifies the TableShape dependency property. (Inherited from Diagram.)
TablesScrollableProperty | Identifies the TablesScrollable dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
ViewportHeightProperty | Identifies the ViewportHeight dependency property.
ViewportWidthProperty | Identifies the ViewportWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property. (Inherited from Diagram.)

Public Attached Properties

Name | Description
IsDiagramScrollerProperty | Gets or sets a value indicating whether a ScrollViewer should be associated as a scroller for an underlying diagram. (Inherited from Diagram.)

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area. (Inherited from Diagram.)
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
BindingMode | Gets or sets a value that indicates the direction of the data flow in the binding.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
Content | With this property, you can define diagram elements from XAML code. (Inherited from Diagram.)
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects. (Inherited from Diagram.)
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input. (Inherited from Diagram.)
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects. (Inherited from Diagram.)
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items. (Inherited from Diagram.)
DefaultNodeSize | Gets or sets the default node size used when data elements do not contain Width and Height properties.
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location. (Inherited from Diagram.)
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location. (Inherited from Diagram.)
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram. (Inherited from Diagram.)
DocumentPlane | Gets the document plane of the diagram. (Inherited from Diagram.)
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too. (Inherited from Diagram.)
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPen | Gets or sets the pen used to draw the grid lines or points. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
HorizontalOffset | Gets or sets the horizontal offset of the scrolled diagram.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text. (Inherited from Diagram.)
InplaceEditFont | Gets or sets the font of the inplace-editing text box. (Inherited from Diagram.)
InstantiateLink | A delegate called to create a DiagramLink instance when realizing data items on screen.
InstantiateLinkData | A delegate called to create a data item for a link drawn by the user.
InstantiateNode | A delegate called to create a DiagramNode instance when realizing data items on screen.
InstantiateNodeData | A delegate called to create a data item for a node drawn by the user.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control. (Inherited from Diagram.)
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default shape of diagram links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinksSource | Gets or sets a collection whose elements will be rendered as links in the diagram.
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled. (Inherited from Diagram.)
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool. (Inherited from Diagram.)
MagnifierHeight | Gets or sets the height of the magnifier tool. (Inherited from Diagram.)
MagnifierStyle | Gets or sets the style of the magnifier tool. (Inherited from Diagram.)
MagnifierWidth | Gets or sets the width of the magnifier tool. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT. (Inherited from Diagram.)
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NodesSource | Gets or sets a collection whose elements will be rendered as nodes in the diagram.
NodeStyleSelector | Gets or sets custom style-selection logic that can be applied to each node.
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view. (Inherited from Diagram.)
PanInertia | Gets or sets a value indicating whether panning the view will have inertia. (Inherited from Diagram.)
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printing and print-preview. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RemoveHiddenItemsFromVisualTree | For internal use. (Inherited from Diagram.)
ResolveContainer | A delegate called to determine a node's container.
ResolveNodePosition | A delegate called to determine the position of a node within the diagram.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button. (Inherited from Diagram.)
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle. (Inherited from Diagram.)
RotationStep | Gets or sets the RotationAngle increment when users rotate a node. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default shape of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
TextBrush | Gets or sets the default brush of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VerticalOffset | Gets or sets the vertical offset of the scrolled diagram.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ViewportHeight | Gets or sets the height of the diagram viewport.
ViewportWidth | Gets or sets the width of the diagram viewport.
VisualCacheSize | Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates. (Inherited from Diagram.)
VisualChildrenCount | Visual.VisualChildrenCount override. (Inherited from Diagram.)

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
BeginInit | FrameworkElement.BeginInit override. (Inherited from Diagram.)
BringIntoView | Overloaded. Scrolls the diagram area to make the specified item visible. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
ClientToDoc | Overloaded. (Inherited from Diagram.)
Compact | Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CopyToClipboard | Overloaded. (Inherited from Diagram.)
CreateImage | Overloaded. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard. (Inherited from Diagram.)
DocToClient | Overloaded. (Inherited from Diagram.)
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links. (Inherited from Diagram.)
EndEdit | Exits in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
EndInit | FrameworkElement.EndInit override. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindGroup | Finds the group that has the specified tag value. (Inherited from Diagram.)
FindLink | Finds the link that has the specified tag value. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNode | Finds the node that has the specified tag value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetDataItem | Gets the item from the data source that is represented by the specified DiagramItem.
GetDiagramItem | Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement. (Inherited from Diagram.)
GetDiagramLink | Gets the DiagramLink that represents the specified data item on screen.
GetDiagramNode | Gets the DiagramNode that represents the specified data item on screen.
GetIsDiagramScroller | Gets the value of the IsDiagramScroller attached property from a given element. (Inherited from Diagram.)
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location. (Inherited from Diagram.)
GetItemBounds | Retrieves the bounding rectangle of the specified item within the current diagram. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. Gets the node that lies at the specified location. (Inherited from Diagram.)
GetNodesAt | Returns the nodes that contain the specified point. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HandleMouseMove | Propagates mouse input to interested manipulators. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within a manipulator of a diagram element. (Inherited from Diagram.)
Invalidate | Invalidates the specified rectangle of the diagram, causing it to be repainted. (Inherited from Diagram.)
InvalidateBackground | Repaints the diagram background, and raises the DrawBackground event for custom drawing. (Inherited from Diagram.)
InvalidateForeground | Repaints the diagram foreground, and raises the DrawForeground event for custom drawing. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control. (Inherited from Diagram.)
MeasureString | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram. (Inherited from Diagram.)
PasteFromClipboard | Overloaded. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to the specified diagram document. (Inherited from Diagram.)
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation. (Inherited from Diagram.)
Print | Displays a Print dialog and prints the diagram. (Inherited from Diagram.)
PrintPreview | Overloaded. Displays the diagram in a Print Preview window. (Inherited from Diagram.)
RaiseCellTextEdited | Raises the CellTextEdited event. (Inherited from Diagram.)
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RaiseLinkTextEdited | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEditing | Overloaded. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
RaiseRealized | Raises the appropriate *Realized event according to the type of the specified item.
RaiseSelecting | Raises the appropriate *Selecting event. (Inherited from Diagram.)
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string. (Inherited from Diagram.)
SaveToXml | Overloaded. Saves the diagram to an XML document. (Inherited from Diagram.)
ScrollTo | Scrolls the document to the specified point. (Inherited from Diagram.)
SetIsDiagramScroller | Sets the value of the IsDiagramScroller attached property to a given element. (Inherited from Diagram.)
SetItemBounds | Sets the location and size of the specified item within the current diagram. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
ZoomIn | Zooms document's items thus making them appear closer. (Inherited from Diagram.)
ZoomOut | Zooms the diagram out making items appear further away. (Inherited from Diagram.)
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area. (Inherited from Diagram.)
ZoomToRect | Overloaded. Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from Diagram.)
DrawGrid | Renders the diagram grid. (Inherited from Diagram.)
GetVisualChild | Visual.GetVisualChild override. (Inherited from Diagram.)
MeasureOverride | Control.MeasureOverride override. (Inherited from Diagram.)
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | DiagramBase.OnContainerChildAdded override.
OnContainerChildRemoved | DiagramBase.OnContainerChildRemoved override.
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnDrop | Handles dropping of DraggedNode instances (Inherited from Diagram.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | DiagramBase.OnLinkCreated override.
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | DiagramBase.OnLinkDeleted override.
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | DiagramBase.OnLinkModified override.
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRealized | Raises the LinkRealized event.
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from Diagram.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | DiagramBase.OnNodeCreated override.
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | DiagramBase.OnNodeDeleted override.
OnNodeDeleting | DiagramBase.OnNodeDeleting override.
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | DiagramBase.OnNodeModified override.
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeRealized | Raises the NodeRealized event.
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override. (Inherited from Diagram.)
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override. (Inherited from Diagram.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from Diagram.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnVisualParentChanged | FrameworkElement.OnVisualParentChanged override. (Inherited from Diagram.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRealized | Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeRealized | Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram Fields

VirtualizingDiagram Fields
[image]

Public Fields

Name | Description
AlignmentGuidePenProperty | Identifies the AlignmentGuidePen dependency property. (Inherited from Diagram.)
AutoCloseDistanceProperty | Identifies the AutoCloseDistance dependency property. (Inherited from Diagram.)
BarcodeNodeStyleProperty | Identifies the BarcodeNodeStyle dependency property. (Inherited from Diagram.)
CellFrameStyleProperty | Identifies the CellFrameStyle dependency property. (Inherited from Diagram.)
ContainerNodeStyleProperty | Identifies the ContainerNodeStyle dependency property. (Inherited from Diagram.)
CustomExpandButtonPosition | A delegate used to calculate the expand/collapse button position for a node. (Inherited from Diagram.)
DefaultShapeProperty | Identifies the DefaultShape dependency property. (Inherited from Diagram.)
DiagramLinkStyleProperty | Identifies the DiagramLinkStyle dependency property. (Inherited from Diagram.)
Dummy | A shared DummyNode instance. (Inherited from Diagram.)
FreeFormAttractDistanceProperty | Identifies the FreeFormAttractDistance dependency property. (Inherited from Diagram.)
FreeFormTargetsProperty | Identifies the FreeFormTargets dependency property. (Inherited from Diagram.)
HorizontalOffsetProperty | Identifies the HorizontalOffset dependency property.
IsDiagramScrollerProperty | Identifies the IsDiagramScroller attached property. (Inherited from Diagram.)
LinkBaseShapeProperty | Identifies the LinkBaseShape dependency property. (Inherited from Diagram.)
LinkBaseShapeSizeProperty | Identifies the LinkBaseShapeSize dependency property. (Inherited from Diagram.)
LinkHeadShapeProperty | Identifies the LinkHeadShape dependency property. (Inherited from Diagram.)
LinkHeadShapeSizeProperty | Identifies the LinkHeadShapeSize dependency property. (Inherited from Diagram.)
LinkHitDistanceProperty | Identifies the LinkHitDistance dependency property. (Inherited from Diagram.)
LinkIntermediateShapeProperty | Identifies the LinkIntermediateShape dependency property. (Inherited from Diagram.)
LinkIntermediateShapeSizeProperty | Identifies the LinkIntermediateShapeSize dependency property. (Inherited from Diagram.)
LinksSourceProperty | Identifies the LinksSource dependency property.
LinkTextProperty | Identifies the LinkText dependency property. (Inherited from Diagram.)
MagnifierFactorProperty | Identifies the MagnifierFactor dependency property. (Inherited from Diagram.)
MagnifierHeightProperty | Identifies the MagnifierHeight dependency property. (Inherited from Diagram.)
MagnifierStyleProperty | Identifies the MagnifierStyle dependency property. (Inherited from Diagram.)
MagnifierWidthProperty | Identifies the MagnifierWidth dependency property. (Inherited from Diagram.)
MeasureUnitProperty | Identifies the MeasureUnit dependency property. (Inherited from Diagram.)
NavigateDown | Selects the diagram item that is below (greater x coordinate) the currently selected item (Inherited from Diagram.)
NavigateLeft | Selects the diagram item that stands to the left of the currently selected item (Inherited from Diagram.)
NavigateRight | Selects the diagram item that stands to the right of the currently selected item (Inherited from Diagram.)
NavigateUp | Selects the diagram item that is above (smaller x coordinate) the currently selected item (Inherited from Diagram.)
NodeEffectsSourceProperty | Identifies the NodeEffectsSource dependency property. (Inherited from Diagram.)
NodesSourceProperty | Identifies the NodesSource dependency property.
NodeStyleSelectorProperty | Identifies the NodeStyleSelector dependency property.
NodeTemplateProperty | Identifies the NodeTemplate dependency property. (Inherited from Diagram.)
RotationStepProperty | Identifies the RotationStep dependency property. (Inherited from Diagram.)
ShapeNodeStyleProperty | Identifies the ShapeNodeStyle dependency property. (Inherited from Diagram.)
ShapeTextProperty | Identifies the ShapeText dependency property. (Inherited from Diagram.)
TableBrushProperty | Identifies the TableBrush dependency property. (Inherited from Diagram.)
TableCaptionHeightProperty | Identifies the TableCaptionHeight dependency property. (Inherited from Diagram.)
TableCaptionProperty | Identifies the TableCaption dependency property. (Inherited from Diagram.)
TableColumnCountProperty | Identifies the TableColumnCount dependency property. (Inherited from Diagram.)
TableColumnWidthProperty | Identifies the TableColumnWidth dependency property. (Inherited from Diagram.)
TableConnectionStyleProperty | Identifies the TableConnectionStyle dependency property. (Inherited from Diagram.)
TableCustomDrawProperty | Identifies the TableCustomDraw dependency property. (Inherited from Diagram.)
TableHandlesStyleProperty | Identifies the TableHandlesStyle dependency property. (Inherited from Diagram.)
TableNodeStyleProperty | Identifies the TableNodeStyle dependency property. (Inherited from Diagram.)
TableRowCountProperty | Identifies the TableRowCount dependency property. (Inherited from Diagram.)
TableRowHeightProperty | Identifies the TableRowHeight dependency property. (Inherited from Diagram.)
TableShapeProperty | Identifies the TableShape dependency property. (Inherited from Diagram.)
TablesScrollableProperty | Identifies the TablesScrollable dependency property. (Inherited from Diagram.)
TreeViewNodeStyleProperty | Identifies the TreeViewNodeStyle dependency property. (Inherited from Diagram.)
VerticalOffsetProperty | Identifies the VerticalOffset dependency property.
ViewportHeightProperty | Identifies the ViewportHeight dependency property.
ViewportWidthProperty | Identifies the ViewportWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property. (Inherited from Diagram.)

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.HorizontalOffsetProperty Field

VirtualizingDiagram.HorizontalOffsetProperty Field
[image]

Identifies the HorizontalOffset dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared HorizontalOffsetProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.LinksSourceProperty Field

VirtualizingDiagram.LinksSourceProperty Field
[image]

Identifies the LinksSource dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LinksSourceProperty

Visual Basic [image] Copy Code

Public Shared LinksSourceProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.NodesSourceProperty Field

VirtualizingDiagram.NodesSourceProperty Field
[image]

Identifies the NodesSource dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty NodesSourceProperty

Visual Basic [image] Copy Code

Public Shared NodesSourceProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.NodeStyleSelectorProperty Field

VirtualizingDiagram.NodeStyleSelectorProperty Field
[image]

Identifies the NodeStyleSelector dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty NodeStyleSelectorProperty

Visual Basic [image] Copy Code

Public Shared NodeStyleSelectorProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.VerticalOffsetProperty Field

VirtualizingDiagram.VerticalOffsetProperty Field
[image]

Identifies the VerticalOffset dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared VerticalOffsetProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ViewportHeightProperty Field

VirtualizingDiagram.ViewportHeightProperty Field
[image]

Identifies the ViewportHeight dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ViewportHeightProperty

Visual Basic [image] Copy Code

Public Shared ViewportHeightProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ViewportWidthProperty Field

VirtualizingDiagram.ViewportWidthProperty Field
[image]

Identifies the ViewportWidth dependency property.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ViewportWidthProperty

Visual Basic [image] Copy Code

Public Shared ViewportWidthProperty As DependencyProperty

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram Constructor

VirtualizingDiagram Constructor
[image]

Initializes a new instance of the VirtualizingDiagram class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VirtualizingDiagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram Methods

VirtualizingDiagram Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the one passed as an argument. (Inherited from Diagram.)
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled. (Inherited from Diagram.)
BeginEdit | Overloaded. (Inherited from Diagram.)
BeginInit | FrameworkElement.BeginInit override. (Inherited from Diagram.)
BringIntoView | Overloaded. Scrolls the diagram area to make the specified item visible. (Inherited from Diagram.)
CancelDrag | Cancels the current drag operation. (Inherited from Diagram.)
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged. (Inherited from Diagram.)
ClearAll | Removes all items from the diagram. (Inherited from Diagram.)
ClientToDoc | Overloaded. (Inherited from Diagram.)
Compact | Moves nodes as far as possible to the top or left sides of diagram without changing their initial relative positions. (Inherited from Diagram.)
CopySelection | Creates a copy of the currently selected objects and groups. (Inherited from Diagram.)
CopyToClipboard | Overloaded. (Inherited from Diagram.)
CreateImage | Overloaded. (Inherited from Diagram.)
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram. (Inherited from Diagram.)
CutToClipboard | Overloaded. Cuts the currently selected items to the Windows clipboard. (Inherited from Diagram.)
DocToClient | Overloaded. (Inherited from Diagram.)
DrawStyledText | Draws a formatted text string, the same way text is drawn in shape nodes whose EnableStyledText property is set to true. This method lets you display styled text in custom-drawn nodes or links. (Inherited from Diagram.)
EndEdit | Exits in-place editing mode and either accepts or rejects the changes made to the item's text. (Inherited from Diagram.)
EndInit | FrameworkElement.EndInit override. (Inherited from Diagram.)
ExecuteCommand | Executes the specified command on this diagram. (Inherited from Diagram.)
FindGroup | Finds the group that has the specified tag value. (Inherited from Diagram.)
FindLink | Finds the link that has the specified tag value. (Inherited from Diagram.)
FindLinkById | Finds the link that has the specified id value. (Inherited from Diagram.)
FindNode | Finds the node that has the specified tag value. (Inherited from Diagram.)
FindNodeById | Finds the node that has the specified id value. (Inherited from Diagram.)
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects. (Inherited from Diagram.)
GetDataItem | Gets the item from the data source that is represented by the specified DiagramItem.
GetDiagramItem | Returns the value of the DiagramItem attached property, representing the DiagramItem associated with a UIElement. (Inherited from Diagram.)
GetDiagramLink | Gets the DiagramLink that represents the specified data item on screen.
GetDiagramNode | Gets the DiagramNode that represents the specified data item on screen.
GetIsDiagramScroller | Gets the value of the IsDiagramScroller attached property from a given element. (Inherited from Diagram.)
GetItemAt | Finds and returns the top-most diagram item that lies at the specified location. (Inherited from Diagram.)
GetItemBounds | Retrieves the bounding rectangle of the specified item within the current diagram. (Inherited from Diagram.)
GetLinkAt | Overloaded. Finds and returns the link that lies at the specified location. (Inherited from Diagram.)
GetNearestNode | Returns the node nearest to the specified point. (Inherited from Diagram.)
GetNodeAt | Overloaded. Gets the node that lies at the specified location. (Inherited from Diagram.)
GetNodesAt | Returns the nodes that contain the specified point. (Inherited from Diagram.)
GetNodesInViewport | Returns all nodes visible in the current viewport. (Inherited from Diagram.)
HandleMouseMove | Propagates mouse input to interested manipulators. (Inherited from Diagram.)
HitTestManipulators | Tests whether the specified point is within a manipulator of a diagram element. (Inherited from Diagram.)
Invalidate | Invalidates the specified rectangle of the diagram, causing it to be repainted. (Inherited from Diagram.)
InvalidateBackground | Repaints the diagram background, and raises the DrawBackground event for custom drawing. (Inherited from Diagram.)
InvalidateForeground | Repaints the diagram foreground, and raises the DrawForeground event for custom drawing. (Inherited from Diagram.)
IsItemInteractive | Checks if the specified item can be modified interactively. (Inherited from Diagram.)
IsItemLocked | Checks if the specified item is locked. (Inherited from Diagram.)
IsItemVisible | Checks if the specified item is currently visible. (Inherited from Diagram.)
LoadFromString | Decodes diagram contents from a string that was created with SaveToString. (Inherited from Diagram.)
LoadFromXml | Overloaded. Loads the contents of an XML diagram document into the control. (Inherited from Diagram.)
MeasureString | Measures the specified text when drawn with the specified font in an area with the specified width taking into consideration the current affine transform of the diagram. (Inherited from Diagram.)
PasteFromClipboard | Overloaded. (Inherited from Diagram.)
PasteSelection | Adds the specified items and groups to the specified diagram document. (Inherited from Diagram.)
PixelToUnit | Converts the specified point from client to document coordinates ignoring the current scale transformation. (Inherited from Diagram.)
Print | Displays a Print dialog and prints the diagram. (Inherited from Diagram.)
PrintPreview | Overloaded. Displays the diagram in a Print Preview window. (Inherited from Diagram.)
RaiseCellTextEdited | Raises the CellTextEdited event. (Inherited from Diagram.)
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaiseClicked | Overloaded. Raises the Clicked event of the diagram or one of the *Clicked events related to diagram items. (Inherited from Diagram.)
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item. (Inherited from Diagram.)
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item. (Inherited from Diagram.)
RaiseDoubleClicked | Overloaded. Raises the DoubleClicked event of the diagram or one of the *DoubleClicked events related to diagram items. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from Diagram.)
RaiseLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RaiseLinkTextEdited | Overloaded. (Inherited from Diagram.)
RaiseLinkTextEditing | Overloaded. (Inherited from Diagram.)
RaiseNodeTextEdited | Raises the NodeTextEdited event. (Inherited from Diagram.)
RaiseNodeTextEditing | Raises the NodeTextEditing event to validate entering in-place editing mode. (Inherited from Diagram.)
RaisePasted | Raises the appropriate Pasted event. (Inherited from Diagram.)
RaiseRealized | Raises the appropriate *Realized event according to the type of the specified item.
RaiseSelecting | Raises the appropriate *Selecting event. (Inherited from Diagram.)
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode. (Inherited from Diagram.)
RegisterClass | Registers a class for serialization support. (Inherited from Diagram.)
RegisterItemClass | Registers a diagram item class for serialization support. (Inherited from Diagram.)
ResizeToFitItem | Resizes the document extents so that the specified item is contained within. (Inherited from Diagram.)
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items. (Inherited from Diagram.)
RouteAllLinks | Routes all links in the diagram in a way they do not cross nodes. (Inherited from Diagram.)
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string. (Inherited from Diagram.)
SaveToXml | Overloaded. Saves the diagram to an XML document. (Inherited from Diagram.)
ScrollTo | Scrolls the document to the specified point. (Inherited from Diagram.)
SetIsDiagramScroller | Sets the value of the IsDiagramScroller attached property to a given element. (Inherited from Diagram.)
SetItemBounds | Sets the location and size of the specified item within the current diagram. (Inherited from Diagram.)
SetZoomFactor | Sets the zoom factor, preserving the on-screen position of the specified diagram point. (Inherited from Diagram.)
UnitToPixel | Converts the specified point from document to client coordinates ignoring the current scale transformation. (Inherited from Diagram.)
UpdateRuntimeIndices | For internal use. (Inherited from Diagram.)
ZoomIn | Zooms document's items thus making them appear closer. (Inherited from Diagram.)
ZoomOut | Zooms the diagram out making items appear further away. (Inherited from Diagram.)
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area. (Inherited from Diagram.)
ZoomToRect | Overloaded. Zooms and scrolls the view to fit the specified document rectangle in the Diagram's visible area. (Inherited from Diagram.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from Diagram.)
DrawGrid | Renders the diagram grid. (Inherited from Diagram.)
GetVisualChild | Visual.GetVisualChild override. (Inherited from Diagram.)
MeasureOverride | Control.MeasureOverride override. (Inherited from Diagram.)
OnActionRecorded | Raises the ActionRecorded event. (Inherited from DiagramBase.)
OnActionRecording | Raises the ActionRecording event. (Inherited from DiagramBase.)
OnActionRedone | Raises the ActionRedone event. (Inherited from DiagramBase.)
OnActionUndone | Raises the ActionUndone event. (Inherited from DiagramBase.)
OnArranged | Raises the Arranged event. (Inherited from DiagramBase.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellDoubleClicked | Raises the CellDoubleClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | DiagramBase.OnContainerChildAdded override.
OnContainerChildRemoved | DiagramBase.OnContainerChildRemoved override.
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnCopyHostedControl | Raises the CopyHostedControl event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeControl | Raises the DeserializeControl event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDoubleClicked | Raises the DoubleClicked event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLaneHeader | Raises the DrawLaneHeader event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnDrop | Handles dropping of DraggedNode instances (Inherited from Diagram.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnGroupDestroyed | Raises the GroupDestroyed event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEdited | Raises the LaneGridHeaderTextEdited event. (Inherited from DiagramBase.)
OnLaneGridHeaderTextEditing | Raises the LaneGridHeaderTextEditing event. (Inherited from DiagramBase.)
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreated | DiagramBase.OnLinkCreated override.
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | DiagramBase.OnLinkDeleted override.
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkDoubleClicked | Raises the LinkDoubleClicked event. (Inherited from DiagramBase.)
OnLinkModified | DiagramBase.OnLinkModified override.
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRealized | Raises the LinkRealized event.
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMagnifierFactorChanged | Raises the MagnifierFactorChanged event. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from Diagram.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from Diagram.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreated | DiagramBase.OnNodeCreated override.
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | DiagramBase.OnNodeDeleted override.
OnNodeDeleting | DiagramBase.OnNodeDeleting override.
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeDoubleClicked | Raises the NodeDoubleClicked event. (Inherited from DiagramBase.)
OnNodeModified | DiagramBase.OnNodeModified override.
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeRealized | Raises the NodeRealized event.
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override. (Inherited from Diagram.)
OnPreviewMouseMove | UIElement.OnPreviewMouseMove override. (Inherited from Diagram.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from Diagram.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSelectionStartModifying | Raises the SelectionStartModifying event. (Inherited from DiagramBase.)
OnSerializeControl | Raises the SerializeControl event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnShapeModified | Raises the ShapeModified event. (Inherited from DiagramBase.)
OnTableColumnResized | Raises the TableColumnResized event. (Inherited from DiagramBase.)
OnTableColumnResizing | Raises the TableColumnResizing event. (Inherited from DiagramBase.)
OnTableRowResized | Raises the TableRowResized event. (Inherited from DiagramBase.)
OnTableRowResizing | Raises the TableRowResizing event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnVisualParentChanged | FrameworkElement.OnVisualParentChanged override. (Inherited from Diagram.)
OnZoomFactorChanged | Raises the ZoomFactorChanged event. (Inherited from DiagramBase.)

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.GetDataItem Method

VirtualizingDiagram.GetDataItem Method
[image]

Gets the item from the data source that is represented by the specified DiagramItem.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object GetDataItem (
DiagramItem diagramItem
)

Visual Basic [image] Copy Code

Public Function GetDataItem( _
diagramItem As DiagramItem _
) As Object

Parameters

diagramItem

A DiagramItem representing the specified data item on screen.

Return Value

An object from the data source.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
GetDiagramLink Method
GetDiagramNode Method


MindFusion.Diagramming.Wpf.VirtualizingDiagram.GetDiagramLink Method

VirtualizingDiagram.GetDiagramLink Method
[image]

Gets the DiagramLink that represents the specified data item on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLink GetDiagramLink (
Object dataItem
)

Visual Basic [image] Copy Code

Public Function GetDiagramLink( _
dataItem As Object _
) As DiagramLink

Parameters

dataItem

An element of LinksSource.

Return Value

A DiagramLink representing the specified data item, or null if the item is not shown on screen.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
GetDataItem Method
GetDiagramNode Method


MindFusion.Diagramming.Wpf.VirtualizingDiagram.GetDiagramNode Method

VirtualizingDiagram.GetDiagramNode Method
[image]

Gets the DiagramNode that represents the specified data item on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode GetDiagramNode (
Object dataItem
)

Visual Basic [image] Copy Code

Public Function GetDiagramNode( _
dataItem As Object _
) As DiagramNode

Parameters

dataItem

An element of NodesSource.

Return Value

A DiagramNode representing the specified data item, or null if the item is not shown on screen.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
GetDataItem Method
GetDiagramLink Method


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnContainerChildAdded Method

VirtualizingDiagram.OnContainerChildAdded Method
[image]

DiagramBase.OnContainerChildAdded override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnContainerChildAdded (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnContainerChildAdded( _
e As ContainerChildEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnContainerChildRemoved Method

VirtualizingDiagram.OnContainerChildRemoved Method
[image]

DiagramBase.OnContainerChildRemoved override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnContainerChildRemoved (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnContainerChildRemoved( _
e As ContainerChildEventArgs _
)

Parameters

e

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnLinkCreated Method

VirtualizingDiagram.OnLinkCreated Method
[image]

DiagramBase.OnLinkCreated override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnLinkDeleted Method

VirtualizingDiagram.OnLinkDeleted Method
[image]

DiagramBase.OnLinkDeleted override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnLinkModified Method

VirtualizingDiagram.OnLinkModified Method
[image]

DiagramBase.OnLinkModified override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

A LinkEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnLinkRealized Method

VirtualizingDiagram.OnLinkRealized Method
[image]

Raises the LinkRealized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void OnLinkRealized (
VirtualLinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnLinkRealized( _
e As VirtualLinkEventArgs _
)

Parameters

e

A VirtualLinkEventArgs that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
OnNodeRealized Method


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnNodeCreated Method

VirtualizingDiagram.OnNodeCreated Method
[image]

DiagramBase.OnNodeCreated override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnNodeDeleted Method

VirtualizingDiagram.OnNodeDeleted Method
[image]

DiagramBase.OnNodeDeleted override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnNodeDeleting Method

VirtualizingDiagram.OnNodeDeleting Method
[image]

DiagramBase.OnNodeDeleting override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

A NodeValidationEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnNodeModified Method

VirtualizingDiagram.OnNodeModified Method
[image]

DiagramBase.OnNodeModified override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

A NodeEventArgs instance that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.OnNodeRealized Method

VirtualizingDiagram.OnNodeRealized Method
[image]

Raises the NodeRealized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected void OnNodeRealized (
VirtualNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnNodeRealized( _
e As VirtualNodeEventArgs _
)

Parameters

e

A VirtualNodeEventArgs that contains the event data.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
OnLinkRealized Method


MindFusion.Diagramming.Wpf.VirtualizingDiagram.RaiseRealized Method

VirtualizingDiagram.RaiseRealized Method
[image]

Raises the appropriate *Realized event according to the type of the specified item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseRealized (
DiagramItem item,
Object dataItem
)

Visual Basic [image] Copy Code

Public Sub RaiseRealized( _
item As DiagramItem, _
dataItem As Object _
)

Parameters

item

The DiagramItem related to the event.

dataItem

The data item related to the event.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
NodeRealized Event
LinkRealized Event


MindFusion.Diagramming.Wpf.VirtualizingDiagram Properties

VirtualizingDiagram Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element. (Inherited from Diagram.)
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item. (Inherited from Diagram.)
ActiveLayer | Gets or sets the zero-based index of the active layer. (Inherited from Diagram.)
AdapterHandlesStyle | Gets or sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes. (Inherited from Diagram.)
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects. (Inherited from Diagram.)
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides. (Inherited from Diagram.)
AlignToGrid | Gets or sets a value indicating whether the diagram items should be aligned to a grid. (Inherited from Diagram.)
AllowInplaceEdit | Gets or sets a value indicating whether in-place editing of the text of objects is enabled. (Inherited from Diagram.)
AllowLinkCursor | Gets or sets the mouse cursor shown to the user when an arrow can be created. (Inherited from Diagram.)
AllowLinksRepeat | Gets or sets a value indicating whether more than one link can connect the same origin and destination diagram nodes. (Inherited from Diagram.)
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously. (Inherited from Diagram.)
AllowSelfLoops | Gets or sets a value indicating whether self-loops are allowed. (Inherited from Diagram.)
AllowSplitLinks | Gets or sets a value indicating whether link segments can be added and removed interactively. (Inherited from Diagram.)
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned. (Inherited from Diagram.)
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node. (Inherited from Diagram.)
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes. (Inherited from Diagram.)
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders ot other nodes during user interaction. (Inherited from Diagram.)
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically. (Inherited from Diagram.)
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it. (Inherited from Diagram.)
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents. (Inherited from Diagram.)
AutoScroll | Gets or sets a value indicating whether auto scrolling of the document area is enabled. (Inherited from Diagram.)
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes. (Inherited from Diagram.)
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links. (Inherited from Diagram.)
BackBrush | Gets or sets the brush used for painting the diagram background. (Inherited from Diagram.)
BackgroundImage | Gets or sets the image displayed as background of this diagram. (Inherited from Diagram.)
BackgroundImageAlign | Gets or sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area. (Inherited from Diagram.)
BarcodeNodeStyle | Gets or sets the theme-level style for barcode nodes. (Inherited from Diagram.)
Behavior | Gets or sets a value indicating how the control responds to user actions. (Inherited from Diagram.)
BindingMode | Gets or sets a value that indicates the direction of the data flow in the binding.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area. (Inherited from Diagram.)
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables. (Inherited from Diagram.)
CellFrameStyle | Gets or sets the default cell border style of new tables. (Inherited from Diagram.)
ContainerCaption | Gets or sets the default value for the Caption property of containers. (Inherited from Diagram.)
ContainerCaptionHeight | Gets or sets the default value for the CaptionHeight property of containers. (Inherited from Diagram.)
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers. (Inherited from Diagram.)
ContainerMargin | Gets or sets the default value for the Margin property of containers. (Inherited from Diagram.)
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers. (Inherited from Diagram.)
ContainerNodeStyle | Gets or sets the theme-level style for container nodes. (Inherited from Diagram.)
ContainersFoldable | Gets or sets the default value for the Foldable property of containers. (Inherited from Diagram.)
Content | With this property, you can define diagram elements from XAML code. (Inherited from Diagram.)
ControlMouseAction | Gets or sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects. (Inherited from Diagram.)
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
CrossingRadius | Gets or sets the radius length of decorations displayed at link intersection points. (Inherited from Diagram.)
CustomBehavior | Gets or sets a custom BehaviorBase-derived object specifying how MindFusion.Diagramming for WPF responds to mouse input. (Inherited from Diagram.)
CustomLinkType | Gets or sets the type of a DiagramLink-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
CustomNodeType | Gets or sets the type of a DiagramNode-derived class whose instance should be created when a user starts drawing. (Inherited from Diagram.)
DefaultControlType | Gets or sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects. (Inherited from Diagram.)
DefaultEffect | Gets or sets the default value for UIElement.Effect property of new items. (Inherited from Diagram.)
DefaultNodeSize | Gets or sets the default node size used when data elements do not contain Width and Height properties.
DefaultShape | Gets or sets the default shape of shape nodes. (Inherited from Diagram.)
DelKeyAction | Gets or sets a value that specifies what action should be performed when the user hits the Del key. (Inherited from Diagram.)
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. (Inherited from Diagram.)
DiagramLinkStyle | Gets or sets the theme-level style for diagram links. (Inherited from Diagram.)
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save. (Inherited from Diagram.)
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles. (Inherited from Diagram.)
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a particular location. (Inherited from Diagram.)
DisallowLinkCursor | Gets or sets the mouse cursor shown to the user when a link is being created but cannot be ended at the current location. (Inherited from Diagram.)
DocumentPaginator | Gets or sets the DocumentPaginator used to retrieve pages when printing the diagram. (Inherited from Diagram.)
DocumentPlane | Gets the document plane of the diagram. (Inherited from Diagram.)
DrawLinkCursor | Gets or sets the mouse cursor shown to the user when a link can be started at the current position. (Inherited from Diagram.)
DynamicLinks | Gets or sets the default value for the Dynamic property of new links. (Inherited from Diagram.)
EnableLanes | Gets or sets whether lanes are enabled. (Inherited from Diagram.)
EnableStyledText | Gets or sets the default value for the EnableStyledText property of new nodes. (Inherited from Diagram.)
ExpandButtonAction | Gets or sets a value indicating what should happen when a user clicks the [±] button that is displayed near expandable nodes. (Inherited from Diagram.)
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes. (Inherited from Diagram.)
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded. (Inherited from Diagram.)
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram. (Inherited from Diagram.)
Font | Gets or sets the default font for new diagram items. (Inherited from Diagram.)
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too. (Inherited from Diagram.)
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes. (Inherited from Diagram.)
GridOffsetX | Gets or sets the horizontal offset of the first point of the alignment grid. (Inherited from Diagram.)
GridOffsetY | Gets or sets the vertical offset of the first point of the alignment grid. (Inherited from Diagram.)
GridPen | Gets or sets the pen used to draw the grid lines or points. (Inherited from Diagram.)
GridSizeX | Gets or sets the horizontal distance between adjacent grid points. (Inherited from Diagram.)
GridSizeY | Gets or sets the vertical distance between adjacent grid points. (Inherited from Diagram.)
GridStyle | Gets or sets the visual style of the alignment grid. (Inherited from Diagram.)
Groups | Gets a collection of all groups in the diagram. (Inherited from Diagram.)
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested. (Inherited from Diagram.)
HorizontalOffset | Gets or sets the horizontal offset of the scrolled diagram.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. (Inherited from Diagram.)
InplaceEditAcceptOnEnter | Gets or sets a value indicating whether pressing the ENTER key exits in-place editing mode and accepts changes made to text. (Inherited from Diagram.)
InplaceEditCancelOnEsc | Gets or sets a value indicating whether pressing the ESC key should exit in-place editing mode and reject changes made to text. (Inherited from Diagram.)
InplaceEditFont | Gets or sets the font of the inplace-editing text box. (Inherited from Diagram.)
InstantiateLink | A delegate called to create a DiagramLink instance when realizing data items on screen.
InstantiateLinkData | A delegate called to create a data item for a link drawn by the user.
InstantiateNode | A delegate called to create a DiagramNode instance when realizing data items on screen.
InstantiateNodeData | A delegate called to create a data item for a node drawn by the user.
Interaction | Gets an InteractionState instance representing the current action being carried out by the user. (Inherited from Diagram.)
IsProEdition | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a professional version of the control. (Inherited from Diagram.)
IsTrialVersion | Gets a value indicating whether the currently loaded MindFusion.Diagramming for WPF is a trial version of the control. (Inherited from Diagram.)
Items | Gets a collection of all items in this diagram. (Inherited from Diagram.)
LaneGrid | Gets the Grid instance that represents the lane grid. (Inherited from Diagram.)
Layers | Gets a list of the layers in the current diagram. (Inherited from Diagram.)
LicenseKey | Gets or sets the license key of the control. (Inherited from DiagramBase.)
LinkBaseShape | Gets or sets the shape displayed at the base of new links. (Inherited from Diagram.)
LinkBaseShapeSize | Gets or sets the default size of the base of new links. (Inherited from Diagram.)
LinkBrush | Gets or sets the default value for the Brush property of links. (Inherited from Diagram.)
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links. (Inherited from Diagram.)
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths. (Inherited from Diagram.)
LinkCustomDraw | Gets or sets the default type of custom painting done on links. (Inherited from Diagram.)
LinkEndsMovable | Gets or sets a value indicating whether arrow ends can be moved by users after the link is created. (Inherited from Diagram.)
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links. (Inherited from Diagram.)
LinkHeadShape | Gets or sets the shape displayed as head of new links. (Inherited from Diagram.)
LinkHeadShapeSize | Gets or sets the default size of arrowheads. (Inherited from Diagram.)
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit. (Inherited from Diagram.)
LinkIntermediateShape | Gets or sets default shape to be displayed at the middle of each segment of links. (Inherited from Diagram.)
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of link segments. (Inherited from Diagram.)
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links. (Inherited from Diagram.)
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change. (Inherited from Diagram.)
Links | Gets a collection of all DiagramLink objects in the diagram. (Inherited from Diagram.)
LinkSegments | Gets or sets the default number of link segments. (Inherited from Diagram.)
LinkShape | Gets or sets the default shape of diagram links. (Inherited from Diagram.)
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around. (Inherited from Diagram.)
LinksSource | Gets or sets a collection whose elements will be rendered as links in the diagram.
LinkText | Gets or sets the default text of links. (Inherited from Diagram.)
LinkTextStyle | Gets or sets default placement and orientation for links' text. (Inherited from Diagram.)
MagnifierEnabled | Gets or sets a value indicating whether the magnifier tool is currently enabled. (Inherited from Diagram.)
MagnifierFactor | Gets or sets the zoom factor of the magnifier tool. (Inherited from Diagram.)
MagnifierHeight | Gets or sets the height of the magnifier tool. (Inherited from Diagram.)
MagnifierStyle | Gets or sets the style of the magnifier tool. (Inherited from Diagram.)
MagnifierWidth | Gets or sets the width of the magnifier tool. (Inherited from Diagram.)
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram. (Inherited from Diagram.)
MergeThreshold | Gets or sets the maximum distance between adjacent control points of a link at which the respective segments can be merged. (Inherited from Diagram.)
MiddleButtonActions | Gets or sets a combination of flags that specify what actions can be performed by using the middle mouse button. (Inherited from Diagram.)
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set. (Inherited from Diagram.)
ModificationEffect | Gets or sets the visual effect to apply during interactive modification of items. (Inherited from Diagram.)
ModificationStart | Gets or sets how users can start modifying diagram items. (Inherited from Diagram.)
ModifierKeyActions | Gets an object, which allows changing the function of keyboard modifier keys such as CTRL and ALT. (Inherited from Diagram.)
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. (Inherited from Diagram.)
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram. (Inherited from Diagram.)
Nodes | Gets a collection of all DiagramNode objects in the diagram. (Inherited from Diagram.)
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded. (Inherited from Diagram.)
NodesSource | Gets or sets a collection whose elements will be rendered as nodes in the diagram.
NodeStyleSelector | Gets or sets custom style-selection logic that can be applied to each node.
NodeTemplate | Gets or sets the default DataTemplate used to display TemplatedNodes. (Inherited from Diagram.)
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file. (Inherited from Diagram.)
OverrideCursor | Sets the cursor and stops changing it depending on the context. (Inherited from Diagram.)
PanCursor | Gets or sets the mouse cursor displayed while panning the diagram view. (Inherited from Diagram.)
PanInertia | Gets or sets a value indicating whether panning the view will have inertia. (Inherited from Diagram.)
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. (Inherited from Diagram.)
PolygonalTextLayout | Gets or sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines. (Inherited from Diagram.)
PrintOptions | Gets an object which provides customization properties for printing and print-preview. (Inherited from Diagram.)
RecursiveExpand | Gets or sets value indicating how a tree is expanded. (Inherited from Diagram.)
RemoveHiddenItemsFromVisualTree | For internal use. (Inherited from Diagram.)
ResolveContainer | A delegate called to determine a node's container.
ResolveNodePosition | A delegate called to determine the position of a node within the diagram.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram. (Inherited from Diagram.)
RightButtonActions | Gets or sets a combination of flags that specify what actions can be performed by clicking the right mouse button. (Inherited from Diagram.)
RotateCursor | Gets or sets the cursor shown when the mouse is over a node rotation handle. (Inherited from Diagram.)
RotationStep | Gets or sets the RotationAngle increment when users rotate a node. (Inherited from Diagram.)
RoundedLinks | Gets or sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded. (Inherited from Diagram.)
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments. (Inherited from Diagram.)
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles. (Inherited from Diagram.)
RouteLinks | Gets or sets a value indicating whether links must avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes. (Inherited from Diagram.)
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm. (Inherited from Diagram.)
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows. (Inherited from Diagram.)
ScriptHelper | Gets a ScriptHelper object which can be used in html scripts to instantiate various objects and to call static methods. (Inherited from Diagram.)
ScrollX | Gets or sets the document's X scroll position. (Inherited from Diagram.)
ScrollY | Gets or sets the document's Y scroll position. (Inherited from Diagram.)
ScrollZoneSize | Gets or sets the size of the auto scroll zone near the edges of the control. (Inherited from Diagram.)
SelectAfterCreate | Gets or sets a value indicating whether newly created objects are automatically selected. (Inherited from Diagram.)
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items. (Inherited from Diagram.)
Selection | Gets a Selection instance that represents the selection of items in this diagram. (Inherited from Diagram.)
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items. (Inherited from Diagram.)
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes. (Inherited from Diagram.)
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes. (Inherited from Diagram.)
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes. (Inherited from Diagram.)
ShapeNodeStyle | Gets or sets the theme-level style for shape nodes. (Inherited from Diagram.)
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes. (Inherited from Diagram.)
ShapePen | Gets or sets the default value for the Pen property of shape nodes. (Inherited from Diagram.)
ShapeText | Gets or sets the default text of shape nodes. (Inherited from Diagram.)
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed. (Inherited from Diagram.)
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled. (Inherited from Diagram.)
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible. (Inherited from Diagram.)
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified. (Inherited from Diagram.)
SnapToAnchor | Gets or sets when link end points should be aligned to the nearest anchor points. (Inherited from Diagram.)
SortGroupsByZ | Gets or sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved. (Inherited from Diagram.)
TableBrush | Gets or sets the default value for the Brush property of tables. (Inherited from Diagram.)
TableCaption | Gets or sets the default text for tables' captions. (Inherited from Diagram.)
TableCaptionHeight | Gets or sets the default height of table captions. (Inherited from Diagram.)
TableColumnCount | Gets or sets the default number of table columns. (Inherited from Diagram.)
TableColumnWidth | Gets or sets the default width of tables' columns. (Inherited from Diagram.)
TableConnectionStyle | Gets or sets a value indicating whether drawing a link between tables will connect rows of those tables, or the tables as whole entities. (Inherited from Diagram.)
TableCustomDraw | Gets or sets the default type of custom painting done on tables. (Inherited from Diagram.)
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables. (Inherited from Diagram.)
TableNodeStyle | Gets or sets the theme-level style for table nodes. (Inherited from Diagram.)
TablePen | Gets or sets the default value for the Pen property of tables. (Inherited from Diagram.)
TableRowCount | Gets or sets the default number of table rows. (Inherited from Diagram.)
TableRowHeight | Gets or sets the default height of tables' rows. (Inherited from Diagram.)
TableShape | Gets or sets the default shape of new tables. (Inherited from Diagram.)
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables. (Inherited from Diagram.)
TextBrush | Gets or sets the default brush of text displayed inside diagram items. (Inherited from Diagram.)
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells. (Inherited from Diagram.)
Theme | Gets or sets the theme associated with the diagram. (Inherited from Diagram.)
TreeViewNodeStyle | Gets or sets the theme-level style for treeview nodes. (Inherited from Diagram.)
UndoManager | Gets a reference to the diagram's UndoManager instance. (Inherited from Diagram.)
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram. (Inherited from Diagram.)
VerticalOffset | Gets or sets the vertical offset of the scrolled diagram.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. (Inherited from Diagram.)
Viewport | Returns the visible portion of the diagram area. (Inherited from Diagram.)
ViewportHeight | Gets or sets the height of the diagram viewport.
ViewportWidth | Gets or sets the width of the diagram viewport.
VisualCacheSize | Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process. (Inherited from DiagramBase.)
ZoomFactor | Gets or sets the zoom factor used to scale up or down the Diagram. (Inherited from Diagram.)

Protected Properties

Name | Description
DocumentToDiagramMatrix | Returns a Matrix representing the transformation from diagram logical coordinates to the control's actual WPF device-indepepndent point coordinates. (Inherited from Diagram.)
VisualChildrenCount | Visual.VisualChildrenCount override. (Inherited from Diagram.)

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.BindingMode Property

VirtualizingDiagram.BindingMode Property
[image]

Gets or sets a value that indicates the direction of the data flow in the binding.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public BindingMode BindingMode { get; set; }

Visual Basic [image] Copy Code

Public Property BindingMode As BindingMode

Property Value

A member of the System.Windows.Data.BindingMode enumeration. The default value is OneWay.

Remarks

If you set BindingMode to TwoWay, you should also implement the InstantiateNodeData and InstantiateLinkData callbacks to create data items when the user draws new diagram items. Set the base Behavior property to control exactly what type of items the user is allowed to draw.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
LinksSource Property
NodesSource Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.DefaultNodeSize Property

VirtualizingDiagram.DefaultNodeSize Property
[image]

Gets or sets the default node size used when data elements do not contain Width and Height properties.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size DefaultNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultNodeSize As Size

Property Value

A System.Windows.Size instance specifying the default node size.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
ResolveNodePosition Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.HorizontalOffset Property

VirtualizingDiagram.HorizontalOffset Property
[image]

Gets or sets the horizontal offset of the scrolled diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Double

Property Value

A double value specifying the horizontal scroll position.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.InstantiateLink Property

VirtualizingDiagram.InstantiateLink Property
[image]

A delegate called to create a DiagramLink instance when realizing data items on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InstantiateLink InstantiateLink { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateLink As InstantiateLink

Property Value

An InstantiateLink delegate method.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
InstantiateNode Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.InstantiateLinkData Property

VirtualizingDiagram.InstantiateLinkData Property
[image]

A delegate called to create a data item for a link drawn by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InstantiateLinkData InstantiateLinkData { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateLinkData As InstantiateLinkData

Property Value

An InstantiateLinkData delegate method.

Remarks

This method is called if BindingMode is set to TwoWay.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
InstantiateNodeData Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.InstantiateNode Property

VirtualizingDiagram.InstantiateNode Property
[image]

A delegate called to create a DiagramNode instance when realizing data items on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InstantiateNode InstantiateNode { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateNode As InstantiateNode

Property Value

An InstantiateNode delegate method.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
InstantiateLink Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.InstantiateNodeData Property

VirtualizingDiagram.InstantiateNodeData Property
[image]

A delegate called to create a data item for a node drawn by the user.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InstantiateNodeData InstantiateNodeData { get; set; }

Visual Basic [image] Copy Code

Public Property InstantiateNodeData As InstantiateNodeData

Property Value

An InstantiateNodeData delegate method.

Remarks

This method is called if BindingMode is set to TwoWay.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
InstantiateLinkData Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.LinksSource Property

VirtualizingDiagram.LinksSource Property
[image]

Gets or sets a collection whose elements will be rendered as links in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList LinksSource { get; set; }

Visual Basic [image] Copy Code

Public Property LinksSource As IList

Property Value

A collection containing data items that should be displayed as diagram links.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
NodesSource Property
BindingMode Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.NodesSource Property

VirtualizingDiagram.NodesSource Property
[image]

Gets or sets a collection whose elements will be rendered as nodes in the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList NodesSource { get; set; }

Visual Basic [image] Copy Code

Public Property NodesSource As IList

Property Value

A collection containing data items that should be displayed as diagram nodes.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
LinksSource Property
BindingMode Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.NodeStyleSelector Property

VirtualizingDiagram.NodeStyleSelector Property
[image]

Gets or sets custom style-selection logic that can be applied to each node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StyleSelector NodeStyleSelector { get; set; }

Visual Basic [image] Copy Code

Public Property NodeStyleSelector As StyleSelector

Property Value

An instance of the System.Windows.Controls.StyleSelector class.

Remarks

When the selector's SelectStyle method is invoked, its item argument refers to a data item from NodesSource, and the container argument refers to the actual DiagramNode bound to the item.

Example

The following selector returns one of two styles defined in a Xaml dictionary depending on the type of data item.

C# [image] Copy Code

class CustomStyleSelector : StyleSelector
{
public override Style SelectStyle(object item, DependencyObject container)
{
ResourceDictionary x = (ResourceDictionary)Application.LoadComponent(
new Uri("/Application;component/Styles/NodeStyles.xaml", UriKind.Relative));

FrameworkElement element = container as FrameworkElement;
element.Resources = x;

if (type is TaskItem)
return (Style)element.FindResource("TaskStyle");
else
return (Style)element.FindResource("AnnotationStyle");
}
}

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ResolveContainer Property

VirtualizingDiagram.ResolveContainer Property
[image]

A delegate called to determine a node's container.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ResolveContainer ResolveContainer { get; set; }

Visual Basic [image] Copy Code

Public Property ResolveContainer As ResolveContainer

Property Value

A function that returns container data item for specified data item.

Remarks

By default the control looks for Container property in data items to resolve containers.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ResolveNodePosition Property

VirtualizingDiagram.ResolveNodePosition Property
[image]

A delegate called to determine the position of a node within the diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ResolveNodePosition ResolveNodePosition { get; set; }

Visual Basic [image] Copy Code

Public Property ResolveNodePosition As ResolveNodePosition

Property Value

A ResolveNodePosition delegate method.

Remarks

By default, VirtualizingDiagram determines the position of a data item by inspecting its X, Y, Width and Height properties through reflection. By assigning a callback to the ResolveNodePosition property, you can place items whose position properties are named differently or whose position is stored elsewhere.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace
DefaultNodeSize Property


MindFusion.Diagramming.Wpf.VirtualizingDiagram.VerticalOffset Property

VirtualizingDiagram.VerticalOffset Property
[image]

Gets or sets the vertical offset of the scrolled diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Double

Property Value

A double value specifying the vertical scroll position.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ViewportHeight Property

VirtualizingDiagram.ViewportHeight Property
[image]

Gets or sets the height of the diagram viewport.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ViewportHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ViewportHeight As Double

Property Value

A double value specifying the height of the viewport.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.ViewportWidth Property

VirtualizingDiagram.ViewportWidth Property
[image]

Gets or sets the width of the diagram viewport.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ViewportWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ViewportWidth As Double

Property Value

A double value specifying the width of the viewport.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.VisualCacheSize Property

VirtualizingDiagram.VisualCacheSize Property
[image]

Gets or sets the size of the cache storing actual nodes and links that will be reused for displaying new data elements while scrolling.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int VisualCacheSize { get; set; }

Visual Basic [image] Copy Code

Public Property VisualCacheSize As Integer

Property Value

An integer specifying the cache size. The default value is 100.

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram Events

VirtualizingDiagram Events
[image]

Public Events

Name | Description
ActionRecorded | Occurs when an action is recorded in undo history. (Inherited from DiagramBase.)
ActionRecording | A validation event raised before an action is recorded in the undo buffer. (Inherited from DiagramBase.)
ActionRedone | Raised when an action is redone. (Inherited from DiagramBase.)
ActionUndone | Raised when an action is undone. (Inherited from DiagramBase.)
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
Arranged | Raised when the diagram's visual tree has been arranged. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellDoubleClicked | Raised when the user double-clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that can prevent users from editing the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
CopyHostedControl | Raised when a DiagramNodeAdapter is cloned. Use this event to copy the hosted control's properties. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeControl | Lets you load the attributes of controls hosted inside DiagramNodeAdapter nodes. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag or Id of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DoubleClicked | Raised when the user double-clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLaneHeader | Raised to let you custom-draw lane headers in the LaneGrid. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
EnterInplaceEditMode | Raised when entering inplace-edit mode. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised when the user clicks the [±] button of an Expandable node. (Inherited from DiagramBase.)
GroupDestroyed | Raised when a Group object is destroyed. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
LaneGridHeaderTextEdited | Raised when the user edits the text of a lane grid header. (Inherited from DiagramBase.)
LaneGridHeaderTextEditing | A validation event that lets you approve or reject changes made to the text of a lane grid header. (Inherited from DiagramBase.)
LeaveInplaceEditMode | Raised when leaving inplace-edit mode. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDoubleClicked | Raised when the user double-clicks a link. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRealized | Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Occurs when users try to select a link, giving you a chance to cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MagnifierFactorChanged | Occurs when the magnifier factor changes. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreated | Occurs when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDoubleClicked | Raised when the user double-clicks a node. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeRealized | Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves or resizes multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving or resizing multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SelectionStartModifying | A validation event raised when the user starts moving or resizing multiple selected items. (Inherited from DiagramBase.)
SerializeControl | Lets you save the attributes of controls hosted inside DiagramNodeAdapters. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag or Id of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
ShapeModified | Raised when the user modifies the shape of a ShapeNode by moving one of the control points corresponding to shape formula parameters. (Inherited from DiagramBase.)
TableColumnResized | Raised when the user finishes resizing a column in a table. (Inherited from DiagramBase.)
TableColumnResizing | Raised when the user resizes a column in a table interactively. (Inherited from DiagramBase.)
TableRowResized | Raised when the user finishes resizing a row in a table. (Inherited from DiagramBase.)
TableRowResizing | Raised when the user resizes a row in a table interactively. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a TreeViewItem. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ZoomFactorChanged | Occurs when the zoom factor changes. (Inherited from DiagramBase.)

See Also

VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.LinkRealized Event

VirtualizingDiagram.LinkRealized Event
[image]

Raised when an actual DiagramLink instance is created to represent a data item from LinksSource.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<VirtualLinkEventArgs> LinkRealized

Visual Basic [image] Copy Code

Public Event LinkRealized As EventHandler(Of VirtualLinkEventArgs)

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualizingDiagram.NodeRealized Event

VirtualizingDiagram.NodeRealized Event
[image]

Raised when an actual DiagramNode instance is created to represent a data item from NodesSource.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<VirtualNodeEventArgs> NodeRealized

Visual Basic [image] Copy Code

Public Event NodeRealized As EventHandler(Of VirtualNodeEventArgs)

See Also

VirtualizingDiagram Members
VirtualizingDiagram Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualLinkEventArgs Class

VirtualLinkEventArgs Class
[image]

Contains arguments passed to handlers of the LinkRealized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VirtualLinkEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class VirtualLinkEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.LinkEventArgs
MindFusion.Diagramming.Wpf.VirtualLinkEventArgs

See Also

VirtualLinkEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualLinkEventArgs Members

VirtualLinkEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the LinkRealized event.

The following tables list the members exposed by the VirtualLinkEventArgs type.

Public Constructors

Name | Description
VirtualLinkEventArgs | Initializes a new instance of the VirtualLinkEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
DataItem | The data item just shown on screen.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

VirtualLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualLinkEventArgs Constructor

VirtualLinkEventArgs Constructor
[image]

Initializes a new instance of the VirtualLinkEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VirtualLinkEventArgs (
DiagramLink link,
Object dataItem
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
dataItem As Object _
)

Parameters

link

The DiagramLink created to represent the data item on screen.

dataItem

The data item just shown on screen.

See Also

VirtualLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualLinkEventArgs Properties

VirtualLinkEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
DataItem | The data item just shown on screen.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
MouseButton | Gets which mouse button was pressed. (Inherited from LinkEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from LinkEventArgs.)

See Also

VirtualLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualLinkEventArgs.DataItem Property

VirtualLinkEventArgs.DataItem Property
[image]

The data item just shown on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object DataItem { get; set; }

Visual Basic [image] Copy Code

Public Property DataItem As Object

Property Value

An element of LinksSource.

See Also

VirtualLinkEventArgs Members
VirtualLinkEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualNodeEventArgs Class

VirtualNodeEventArgs Class
[image]

Contains arguments passed to handlers of the NodeRealized event.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VirtualNodeEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class VirtualNodeEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.NodeEventArgs
MindFusion.Diagramming.Wpf.VirtualNodeEventArgs

See Also

VirtualNodeEventArgs Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualNodeEventArgs Members

VirtualNodeEventArgs Members
Constructors Properties
[image]

Contains arguments passed to handlers of the NodeRealized event.

The following tables list the members exposed by the VirtualNodeEventArgs type.

Public Constructors

Name | Description
VirtualNodeEventArgs | Initializes a new instance of the VirtualNodeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
DataItem | The data item just shown on screen.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

VirtualNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualNodeEventArgs Constructor

VirtualNodeEventArgs Constructor
[image]

Initializes a new instance of the VirtualNodeEventArgs class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VirtualNodeEventArgs (
DiagramNode node,
Object dataItem
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
dataItem As Object _
)

Parameters

node

The DiagramNode created to represent the data item on screen.

dataItem

The data item just shown on screen.

See Also

VirtualNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualNodeEventArgs Properties

VirtualNodeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
DataItem | The data item just shown on screen.
MouseButton | Gets which mouse button has been pressed. (Inherited from NodeEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from NodeEventArgs.)
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)

See Also

VirtualNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VirtualNodeEventArgs.DataItem Property

VirtualNodeEventArgs.DataItem Property
[image]

The data item just shown on screen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object DataItem { get; set; }

Visual Basic [image] Copy Code

Public Property DataItem As Object

Property Value

An element of NodesSource.

See Also

VirtualNodeEventArgs Members
VirtualNodeEventArgs Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent Class

VisioContent Class
[image]

Represents the content of a VisioNode.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VisioContent

Visual Basic [image] Copy Code

Public Class VisioContent

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.VisioContent

See Also

VisioContent Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent Members

VisioContent Members
Properties Methods
[image]

Represents the content of a VisioNode.

The following tables list the members exposed by the VisioContent type.

Public Properties

Name | Description
Master | Gets the underlying Visio master.

Public Methods

Name | Description
Create | Overloaded. Creates an instance of the VisioContent class.

See Also

VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent Methods

VisioContent Methods
[image]

Public Methods

Name | Description
Create | Overloaded. Creates an instance of the VisioContent class.

See Also

VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent.Create Method

VisioContent.Create Method
[image]

Creates an instance of the VisioContent class.

Overload List

Name | Description
VisioContent.Create (VisioStencil, Int32) | Creates an instance of the VisioContent class representing the Visio master with the specified identifier from the specified Visio stencil.
VisioContent.Create (VisioStencil, String) | Creates an instance of the VisioContent class representing the Visio master with the specified name from the specified Visio stencil.

See Also

VisioContent Members
VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent.Create Method (VisioStencil, Int32)

VisioContent.Create Method (VisioStencil, Int32)
See Also
[image]

Creates an instance of the VisioContent class representing the Visio master with the specified identifier from the specified Visio stencil.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static VisioContent Create (
VisioStencil stencil,
int masterId
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
stencil As VisioStencil, _
masterId As Integer _
) As VisioContent

Parameters

stencil

The Visio stencil.

masterId

The master identifier.

Return Value

An instance of the VisioContent class representing the specified master.

See Also

Create Method Overload List
VisioContent Members
VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent.Create Method (VisioStencil, String)

VisioContent.Create Method (VisioStencil, String)
See Also
[image]

Creates an instance of the VisioContent class representing the Visio master with the specified name from the specified Visio stencil.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static VisioContent Create (
VisioStencil stencil,
string masterName
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
stencil As VisioStencil, _
masterName As String _
) As VisioContent

Parameters

stencil

The Visio stencil.

masterName

The master name.

Return Value

An instance of the VisioContent class representing the specified master.

See Also

Create Method Overload List
VisioContent Members
VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent Properties

VisioContent Properties
[image]

Public Properties

Name | Description
Master | Gets the underlying Visio master.

See Also

VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioContent.Master Property

VisioContent.Master Property
[image]

Gets the underlying Visio master.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Master<Color, ImageSource> Master { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Master As Master(Of Color, ImageSource)

Property Value

An instance of the Master(TColor, TImage) class.

See Also

VisioContent Members
VisioContent Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Class

VisioNode Class
Remarks See Also
[image]

Represents a node that can display shapes from Visio stencils.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VisioNode : DiagramNode

Visual Basic [image] Copy Code

Public Class VisioNode
Inherits DiagramNode

Remarks

The shape displayed by the node is specified through its Content property. To create the content, load a Visio stencil file (.vsx) using an instance of the VisioStencil class, then use the static VisioContent.Create method. A reference to the master shape of the content can be obtained through the Master property.

Important

The standard stencils installed with Visio are copyrighted by Microsoft, and you should not use them in your application. This feature is intended to let you use public domain stencils, or commercial ones you have purchase a license for.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.DiagramItem
MindFusion.Diagramming.Wpf.DiagramNode
MindFusion.Diagramming.Wpf.VisioNode

See Also

VisioNode Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Members

VisioNode Members
Constructors Fields Properties Methods
[image]

Represents a node that can display shapes from Visio stencils.

The following tables list the members exposed by the VisioNode type.

Public Constructors

Name | Description
VisioNode | Overloaded. Initializes a new instance of the VisioNode class.

Public Fields

Name | Description
BoundsProperty | Identifies the Bounds dependency property. (Inherited from DiagramNode.)
BrushProperty | Idendifies the Brush dependency property. (Inherited from DiagramItem.)
EffectsSourceProperty | Identifies the EffectsSource dependency property. (Inherited from DiagramNode.)
EnabledHandlesProperty | Identifies the EnabledHandles property. (Inherited from DiagramNode.)
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from DiagramItem.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from DiagramItem.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from DiagramItem.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from DiagramItem.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id dependency property. (Inherited from DiagramItem.)
RotationAngleProperty | Identifies the RotationAngle dependency property. (Inherited from DiagramNode.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from DiagramItem.)
StrokeDashStyleProperty | Identifies the StrokeDashStyle dependency property. (Inherited from DiagramItem.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from DiagramItem.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from DiagramItem.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from DiagramItem.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from DiagramItem.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from DiagramItem.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from DiagramItem.)
TemplateProperty | Identifies the Template dependency property. (Inherited from DiagramNode.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from DiagramItem.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from DiagramItem.)
TextProperty | Identifies the Text dependency property. (Inherited from DiagramItem.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from DiagramItem.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from DiagramItem.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from DiagramItem.)

Protected Fields

Name | Description
disposed | For internal use. (Inherited from DiagramItem.)

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the content of the node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Constructor

VisioNode Constructor
[image]

Initializes a new instance of the VisioNode class.

Overload List

Name | Description
VisioNode () | Initializes a new instance of the VisioNode class.
VisioNode (Diagram) | Initializes a new instance of the VisioNode class with default values supplied form the specified Diagram.
VisioNode (VisioNode) | Initializes a new instance of the VisioNode class using the specified node as a prototype.

See Also

VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Constructor ()

VisioNode Constructor ()
See Also
[image]

Initializes a new instance of the VisioNode class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioNode Constructor Overload List
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Constructor (Diagram)

VisioNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the VisioNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

VisioNode Constructor Overload List
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Constructor (VisioNode)

VisioNode Constructor (VisioNode)
See Also
[image]

Initializes a new instance of the VisioNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNode (
VisioNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As VisioNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

VisioNode Constructor Overload List
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Methods

VisioNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AttachTo | Overloaded. Attaches this node to another diagram item. (Inherited from DiagramNode.)
ClearStyleableProperties | Clears the local values of all styleable appearance properties. (Inherited from DiagramItem.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
Dispose | Overloaded. (Inherited from DiagramItem.)
Draw | DiagramItem.Draw override. (Inherited from DiagramNode.)
DrawAnchorPoints | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllIncomingLinks | Overloaded. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramNode.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersecion point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetRegion | DiagramItem.GetRegion override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. (Inherited from DiagramNode.)
GetRotationAngle | Gets the rotation angle of this node. (Inherited from DiagramNode.)
GetToolTip | DiagramItem.GetToolTip override. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
HitTestManipulators | DiagramItem.HitTestManipulators override. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
NowModifying | Gets a flag indicating whether this object is being currently modified interactively by the user. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
Query | Returns the items that can be reached from this item by following the path specified in the given query expression. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly disctributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Repaint | DiagramItem.Repaint override. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
SetBounds | Sets the location and size of this node. (Inherited from DiagramNode.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
SetRect | This method is used internally by the Ruler control to align nodes. (Inherited from DiagramNode.)
TransformDiagramToItem | Transforms a point from document coordinates to item coordinates. (Inherited from DiagramItem.)
TransformItemToDiagram | Transforms point from item-relative coordinates to document coordinates. (Inherited from DiagramItem.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AllowCreate | DiagramItem.AllowCreate override. (Inherited from DiagramNode.)
AllowModify | DiagramItem.AllowModify override. (Inherited from DiagramNode.)
ArrangeOverride | FrameworkElement.ArrangeOverride override. (Inherited from DiagramNode.)
CompleteCreate | DiagramItem.CompleteCreate override. (Inherited from DiagramNode.)
CompleteModify | DiagramItem.CompleteModify override. (Inherited from DiagramNode.)
ConstraintsInfringed | Check whether the KeepInsideParent constrained is being violated. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Draws the associated manipulators in the specified context. (Inherited from DiagramItem.)
EnumStyleableProperties | DiagramItem.EnumStyleableProperties override. (Inherited from DiagramNode.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetDefaultTemplate | Returns a DataTemplate that should be used to render the node if its own Template property is not set. (Inherited from DiagramNode.)
GetHeight | Gets the height of this item. (Inherited from DiagramItem.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetTextRect | Subtracts the TextPadding values from the specified rectangle. (Inherited from DiagramItem.)
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from DiagramNode.)
GetWidth | Gets the width of this item. (Inherited from DiagramItem.)
GetX | Gets the x-coordinate of the current position of this item. (Inherited from DiagramItem.)
GetY | Gets the y-coordinate of the current position of this item. (Inherited from DiagramItem.)
GroupContains | Determines whether this node is a predecessor of the specified node in the group hierarchy. (Inherited from DiagramNode.)
LoadFromXml | Loads the item content from an XML element.
MeasureOverride | FrameworkElement.MeasureOverride override. (Inherited from DiagramNode.)
OnAdd | Called when this node is added to the Diagram. (Inherited from DiagramNode.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnLoad | Called after the item is deserialized. (Inherited from DiagramNode.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnMouseDown | UIElement.OnMouseDown override. (Inherited from DiagramItem.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from DiagramItem.)
OnPositioningChanged | Called when the item's position changes. (Inherited from DiagramItem.)
OnPreviewMouseDown | UIElement.OnPreviewMouseWheel override. (Inherited from DiagramItem.)
OnPreviewMouseUp | UIElement.OnPreviewMouseUp override. (Inherited from DiagramItem.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRender | UIElement.OnRender override. (Inherited from DiagramItem.)
OnSerializablePropertyChanged | Invoked when a FrameworkElement property serializable by DiagramItem changes. (Inherited from DiagramItem.)
OnSizeChanged | Called when the size of the node changes. (Inherited from DiagramNode.)
OnStrokeAttributeChanged | Invoked when any of the item's stroke attributes changes. (Inherited from DiagramItem.)
OnTextAttributeChanged | Invoked when any of the attributes defined in ITextAttributes changes. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the ZoomFactor changes. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchorPoints | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
StartCreate | DiagramItem.StartCreate override. (Inherited from DiagramNode.)
StartModify | DiagramItem.StartModify override. (Inherited from DiagramNode.)
UpdateCreate | DiagramItem.UpdateCreate override. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, conntected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)
UpdateModify | DiagramItem.UpdateModify override. (Inherited from DiagramNode.)

See Also

VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.CreateProperties Method

VisioNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.DrawLocal Method

VisioNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override void DrawLocal (
DrawingContext graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As DrawingContext, _
options As RenderOptions _
)

Parameters

graphics

A DrawingContext object where the item should be rendered.

options

Provides options for the drawing operation.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.LoadFromXml Method

VisioNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.OnUpdateBounds Method

VisioNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds ()

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.RestoreProperties Method

VisioNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.SaveProperties Method

VisioNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.SaveToXml Method

VisioNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SaveToXml (
XmlElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToXml( _
xmlElement As XmlElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode Properties

VisioNode Properties
[image]

Public Properties

Name | Description
Adorner | A Visual that contains the item's adjustment handles. (Inherited from DiagramItem.)
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Content | Gets or sets the content of the node.
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FontFamily | Gets or sets the preferred font family for this DiagramItem. (Inherited from DiagramItem.)
FontSize | Gets or sets the font size for this DiagramItem. (Inherited from DiagramItem.)
FontStretch | Gets or sets the font-stretching characteristics for this DiagramItem. (Inherited from DiagramItem.)
FontStyle | Gets or sets the font style for this DiagramItem. (Inherited from DiagramItem.)
FontWeight | Gets or sets the font weight for this DiagramItem. (Inherited from DiagramItem.)
GridAlignPoint | Gets or sets the node's point that should align to a grid point when the node is moved. (Inherited from DiagramNode.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyperlink associated with this diagram item. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
MasterGroup | Gets a reference to the group to which this node is attached. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Printable | Gets or sets a value indicating whether to print the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
Stroke | Gets or sets the Brush that specifies how the item outline is painted. (Inherited from DiagramItem.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from DiagramItem.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItem.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke. (Inherited from DiagramItem.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline. (Inherited from DiagramItem.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element. (Inherited from DiagramItem.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke. (Inherited from DiagramItem.)
StrokeThickness | Gets or sets the width of the DiagramItem stroke outline. (Inherited from DiagramItem.)
SubordinateGroup | Gets a reference to the group of items that are attached to this one. (Inherited from DiagramItem.)
Template | Gets or sets the DataTemplate used to display this node. (Inherited from DiagramNode.)
Text | Gets or sets the text displayed inside this item. (Inherited from DiagramItem.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to draw the item's text. (Inherited from DiagramItem.)
TextDecorations | Gets or sets the effects to apply to the text of this DiagramItem. (Inherited from DiagramItem.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from DiagramItem.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from DiagramItem.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from DiagramItem.)
TextWrapping | Gets or sets how this DiagramItem should wrap text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UIElement | Gets the UIElement associated with this DiagramItem. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)
Size | Gets the size of this item. (Inherited from DiagramItem.)
VisualChildrenCount | FrameworkElement.VisualChildrenCount override. (Inherited from DiagramNode.)

See Also

VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNode.Content Property

VisioNode.Content Property
[image]

Gets or sets the content of the node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioContent Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As VisioContent

Property Value

An instance of the VisioContent class.

Remarks

To create a VisioContent instance, load a Visio stencil, then use one of the VisioContent.Create overloads.

See Also

VisioNode Members
VisioNode Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNodeProperties Class

VisioNodeProperties Class
[image]

Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VisioNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class VisioNodeProperties
Inherits DiagramNodeProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.DiagramItemProperties
MindFusion.Diagramming.Wpf.DiagramNodeProperties
MindFusion.Diagramming.Wpf.VisioNodeProperties

See Also

VisioNodeProperties Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNodeProperties Members

VisioNodeProperties Members
Constructors Methods
[image]

Stores the values of VisioNode properties during undo / redo operations. If you need to implement undo support for the additional properties defined by a class derived from VisioNode, do so by deriving from VisioNodeProperties and overriding the VisioNode.SaveProperties, VisioNode.RestoreProperties, and VisioNode.CreateProperties methods.

The following tables list the members exposed by the VisioNodeProperties type.

Public Constructors

Name | Description
VisioNodeProperties | Initializes a new instance of the VisioNodeProperties class.

Public Methods

Name | Description
FreeResources | Frees stored unmanaged resources which will not be used any longer. The component invokes this method when a record is discarded form the undo history queue. (Inherited from DiagramItemProperties.)

See Also

VisioNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioNodeProperties Constructor

VisioNodeProperties Constructor
[image]

Initializes a new instance of the VisioNodeProperties class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioNodeProperties Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil Class

VisioStencil Class
[image]

Represents a Visio stencil.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VisioStencil

Visual Basic [image] Copy Code

Public Class VisioStencil

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.VisioStencil

See Also

VisioStencil Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil Members

VisioStencil Members
Properties Methods
[image]

Represents a Visio stencil.

The following tables list the members exposed by the VisioStencil type.

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.

Public Methods

Name | Description
LoadFromXml | Overloaded. Creates a new VisioStencil instance from a specified Visio stencil file (.vsx).

See Also

VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil Methods

VisioStencil Methods
[image]

Public Methods

Name | Description
LoadFromXml | Overloaded. Creates a new VisioStencil instance from a specified Visio stencil file (.vsx).

See Also

VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil.LoadFromXml Method

VisioStencil.LoadFromXml Method
[image]

Creates a new VisioStencil instance from a specified Visio stencil file (.vsx).

Overload List

Name | Description
VisioStencil.LoadFromXml (String) | Creates a new VisioStencil instance from the specified Visio stencil file.
VisioStencil.LoadFromXml (String, CreateImageCallback) | Creates a new VisioStencil instance from the specified Visio stencil file.

See Also

VisioStencil Members
VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil.LoadFromXml Method (String)

VisioStencil.LoadFromXml Method (String)
See Also
[image]

Creates a new VisioStencil instance from the specified Visio stencil file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static VisioStencil LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function LoadFromXml( _
fileName As String _
) As VisioStencil

Parameters

fileName

The file to load from.

Return Value

The newly created VisioStencil object.

See Also

LoadFromXml Method Overload List
VisioStencil Members
VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil.LoadFromXml Method (String, CreateImageCallback)

VisioStencil.LoadFromXml Method (String, CreateImageCallback)
See Also
[image]

Creates a new VisioStencil instance from the specified Visio stencil file.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static VisioStencil LoadFromXml (
string fileName,
CreateImageCallback createImageCallback
)

Visual Basic [image] Copy Code

Public Shared Function LoadFromXml( _
fileName As String, _
createImageCallback As CreateImageCallback _
) As VisioStencil

Parameters

fileName

The file to load from.

createImageCallback

A callback used to load images during loading, or null (Nothing in Visual Basic), to use the default image loader.

Return Value

The newly created VisioStencil object.

See Also

LoadFromXml Method Overload List
VisioStencil Members
VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil Properties

VisioStencil Properties
[image]

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.

See Also

VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisioStencil.Masters Property

VisioStencil.Masters Property
[image]

Gets a list with all masters in this stencil.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IList<Master<Color, ImageSource>> Masters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Masters As IList(Of Master(Of Color, ImageSource))

Property Value

A list of Master(Color, Image) objects.

See Also

VisioStencil Members
VisioStencil Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Class

VisualBrushPaginator Class
[image]

Implements pagination of a Diagram document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class VisualBrushPaginator : DocumentPaginator

Visual Basic [image] Copy Code

Public Class VisualBrushPaginator
Inherits DocumentPaginator

Inheritance Hierarchy

System.Object
System.Windows.Documents.DocumentPaginator
MindFusion.Diagramming.Wpf.VisualBrushPaginator

See Also

VisualBrushPaginator Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Members

VisualBrushPaginator Members
Constructors Properties Methods
[image]

Implements pagination of a Diagram document.

The following tables list the members exposed by the VisualBrushPaginator type.

Public Constructors

Name | Description
VisualBrushPaginator | Overloaded.

Public Properties

Name | Description
IsPageCountValid | Override DocumentPaginator.IsPageCountValid
PageCount | Override DocumentPaginator.PageCount
PageSize | Override DocumentPaginator.PageSize
Source | Override DocumentPaginator.Source

Public Methods

Name | Description
GetPage | Override DocumentPaginator.GetPage(int pageNumber)
GetPageRect | Returns the coordinates of the diagram region that is contained within a page.

See Also

VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Constructor

VisualBrushPaginator Constructor
[image]

Overload List

Name | Description
VisualBrushPaginator (Diagram) | Contructs new instance
VisualBrushPaginator (Diagram, PrintOptions) | Contructs new instance

See Also

VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Constructor (Diagram)

VisualBrushPaginator Constructor (Diagram)
See Also
[image]

Contructs new instance

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisualBrushPaginator (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

VisualBrushPaginator Constructor Overload List
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Constructor (Diagram, PrintOptions)

VisualBrushPaginator Constructor (Diagram, PrintOptions)
See Also
[image]

Contructs new instance

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisualBrushPaginator (
Diagram diagram,
PrintOptions printOptions
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
printOptions As PrintOptions _
)

Parameters

diagram

printOptions

See Also

VisualBrushPaginator Constructor Overload List
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Methods

VisualBrushPaginator Methods
[image]

Public Methods

Name | Description
GetPage | Override DocumentPaginator.GetPage(int pageNumber)
GetPageRect | Returns the coordinates of the diagram region that is contained within a page.

See Also

VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.GetPage Method

VisualBrushPaginator.GetPage Method
[image]

Override DocumentPaginator.GetPage(int pageNumber)

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override DocumentPage GetPage (
int pageNumber
)

Visual Basic [image] Copy Code

Public Overrides Function GetPage( _
pageNumber As Integer _
) As DocumentPage

Parameters

pageNumber

Return Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.GetPageRect Method

VisualBrushPaginator.GetPageRect Method
[image]

Returns the coordinates of the diagram region that is contained within a page.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetPageRect (
int pageNumber
)

Visual Basic [image] Copy Code

Public Function GetPageRect( _
pageNumber As Integer _
) As Rect

Parameters

pageNumber

Return Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator Properties

VisualBrushPaginator Properties
[image]

Public Properties

Name | Description
IsPageCountValid | Override DocumentPaginator.IsPageCountValid
PageCount | Override DocumentPaginator.PageCount
PageSize | Override DocumentPaginator.PageSize
Source | Override DocumentPaginator.Source

See Also

VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.IsPageCountValid Property

VisualBrushPaginator.IsPageCountValid Property
[image]

Override DocumentPaginator.IsPageCountValid

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool IsPageCountValid { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property IsPageCountValid As Boolean

Property Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.PageCount Property

VisualBrushPaginator.PageCount Property
[image]

Override DocumentPaginator.PageCount

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int PageCount { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property PageCount As Integer

Property Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.PageSize Property

VisualBrushPaginator.PageSize Property
[image]

Override DocumentPaginator.PageSize

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property PageSize As Size

Property Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.VisualBrushPaginator.Source Property

VisualBrushPaginator.Source Property
[image]

Override DocumentPaginator.Source

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override IDocumentPaginatorSource Source { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Source As IDocumentPaginatorSource

Property Value

See Also

VisualBrushPaginator Members
VisualBrushPaginator Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert Class

XmlConvert Class
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class XmlConvert

Visual Basic [image] Copy Code

Public NotInheritable Class XmlConvert

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.XmlConvert

See Also

XmlConvert Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert Members

XmlConvert Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

The following tables list the members exposed by the XmlConvert type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromXmlElement | Reads a Point value from the specified XML element.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToColor | Converts the specified string value to Color.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.

See Also

XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert Methods

XmlConvert Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageV4 | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromXmlElement | Reads a Point value from the specified XML element.
ImageFromString | Converts the specified string value to image.
ToBoolean | Converts the specified string value to bool.
ToColor | Converts the specified string value to Color.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToImageV4 | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.

See Also

XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromBoolean Method

XmlConvert.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val
the bool value to be converted

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromColor Method

XmlConvert.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

the color value to be converted

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromDouble Method

XmlConvert.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val
the double value to be converted

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromEnum Method

XmlConvert.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val
the enum value to be converted

Return Value

a string value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromImage Method

XmlConvert.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromImage (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As Image _
) As String

Parameters

val
an image

Return Value

a string value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromImageV4 Method

XmlConvert.FromImageV4 Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromImageV4 (
Image val
)

Visual Basic [image] Copy Code

Public Shared Function FromImageV4( _
val As Image _
) As String

Parameters

val

Return Value

Remarks

This method is used in XML file format 4 and earlier.

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromInt16 Method

XmlConvert.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromInt32 Method

XmlConvert.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromInt64 Method

XmlConvert.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromSingle Method

XmlConvert.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromStream Method

XmlConvert.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromStreamV4 Method

XmlConvert.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

Return Value

Remarks

This method is used in XML file format 4 and earlier.

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.FromXmlElement Method

XmlConvert.FromXmlElement Method
[image]

Reads a Point value from the specified XML element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Point FromXmlElement (
XmlElement point
)

Visual Basic [image] Copy Code

Public Shared Function FromXmlElement( _
point As XmlElement _
) As Point

Parameters

point

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ImageFromString Method

XmlConvert.ImageFromString Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Image ImageFromString (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ImageFromString( _
s As String _
) As Image

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToBoolean Method

XmlConvert.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToColor Method

XmlConvert.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s
a string value to be converted to Color

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToDouble Method

XmlConvert.ToDouble Method
[image]

Converts the specifed string value to double.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s
a string value to be converted to double

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToEnum Method

XmlConvert.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToImage Method

XmlConvert.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Image ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As Image

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToImageV4 Method

XmlConvert.ToImageV4 Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Image ToImageV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImageV4( _
s As String _
) As Image

Parameters

s

Return Value

Remarks

This method is used in XML file format 4 and earlier.

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToInt16 Method

XmlConvert.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToInt32 Method

XmlConvert.ToInt32 Method
[image]

Overload List

Name | Description
XmlConvert.ToInt32 (String) | Converts the specified string value to 32-bit integer.
XmlConvert.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions If an exception is thrown returns the defaultValue

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToInt32 Method (String)

XmlConvert.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

Return Value

See Also

ToInt32 Method Overload List
XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToInt32 Method (String, Int32)

XmlConvert.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions If an exception is thrown returns the defaultValue

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

defaultValue

Return Value

See Also

ToInt32 Method Overload List
XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToInt64 Method

XmlConvert.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToSingle Method

XmlConvert.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToStream Method

XmlConvert.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

Return Value

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlConvert.ToStreamV4 Method

XmlConvert.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

Return Value

Remarks

This method is used in XML file format 4 and earlier.

See Also

XmlConvert Members
XmlConvert Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions Class

XmlOptions Class
[image]

Defines properties used to customize the XML serialization process.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class XmlOptions

Visual Basic [image] Copy Code

Public Class XmlOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.XmlOptions

See Also

XmlOptions Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions Members

XmlOptions Members
Constructors Properties
[image]

Defines properties used to customize the XML serialization process.

The following tables list the members exposed by the XmlOptions type.

Public Constructors

Name | Description
XmlOptions | Initializes a new instance of the XmlOptions class.

Public Properties

Name | Description
SerializeStyles | Gets or sets whether WPF styles assigned to diagram items should be serialized.
SerializeTheme | Gets or sets whether the diagram Theme should be serialized.

See Also

XmlOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions Constructor

XmlOptions Constructor
[image]

Initializes a new instance of the XmlOptions class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

XmlOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions Properties

XmlOptions Properties
[image]

Public Properties

Name | Description
SerializeStyles | Gets or sets whether WPF styles assigned to diagram items should be serialized.
SerializeTheme | Gets or sets whether the diagram Theme should be serialized.

See Also

XmlOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions.SerializeStyles Property

XmlOptions.SerializeStyles Property
[image]

Gets or sets whether WPF styles assigned to diagram items should be serialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SerializeStyles { get; set; }

Visual Basic [image] Copy Code

Public Property SerializeStyles As Boolean

Property Value

true to serialize styles, or false otherwise. The default value is true.

See Also

XmlOptions Members
XmlOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlOptions.SerializeTheme Property

XmlOptions.SerializeTheme Property
[image]

Gets or sets whether the diagram Theme should be serialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SerializeTheme { get; set; }

Visual Basic [image] Copy Code

Public Property SerializeTheme As Boolean

Property Value

true to serialize the theme, or false otherwise. The default value is true.

See Also

XmlOptions Members
XmlOptions Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming for WPF items to end from XML documents.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class XmlPersistContext

Visual Basic [image] Copy Code

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.XmlPersistContext

See Also

XmlPersistContext Members
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Members

XmlPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming for WPF items to end from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process.

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
InstantiateItem | Instantiates an item with the specified class id.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object with the specified name.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a double array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a FontStyle object with the specified name.
ReadFontUnit | Reads a FontUnit object with the specified name.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an System.Windows.Media.ImageSource object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a System.Windows.Media.Pen object with the specified name.
ReadPoint3D | Reads a Point3D object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointCoordinates | Reads a StylusPointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a System.Windows.Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Overloaded.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a System.Windows.Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
ReadVisioContent | Reads a Visio content with the specified name.
ReadXaml | Loads an object from its XAML representation.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteFontFamily | Writes a FontFamily object with the specified name.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteFontUnit | Writes a FontUnit object with the specified name.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePoint3D | Writes a Point3D with the specified name.
WritePointCollection | Writes the specified point collection.
WritePointCoordinates | Writes the specified StylusPointCollection.
WritePointF | Writes a Point with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteVisioContent | Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.
WriteXaml | Serializes an object to XAML.

See Also

XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Fields

XmlPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.LatestFormat Field

XmlPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlPersistContext (
Diagram diagram,
XmlDocument document,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
document As XmlDocument, _
fileVersion As Integer _
)

Parameters

diagram

The Diagram this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

fileVersion

Specifies the current file format number.

See Also

XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Methods

XmlPersistContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
FromRelativePath | Converts the specified path from relative to the BaseURI to an absolute path.
InstantiateItem | Instantiates an item with the specified class id.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object with the specified name.
ReadEnum | Overloaded.
ReadFloat | Overloaded.
ReadFloatArray | Reads a double array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a FontStyle object with the specified name.
ReadFontUnit | Reads a FontUnit object with the specified name.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash table object with the specified name.
ReadImage | Reads an System.Windows.Media.ImageSource object with the specified name.
ReadInt | Overloaded.
ReadItemReference | Overloaded.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a System.Windows.Media.Pen object with the specified name.
ReadPoint3D | Reads a Point3D object with the specified name.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointCoordinates | Reads a StylusPointCollection object with the specified name.
ReadPointF | Overloaded.
ReadRectangleF | Reads a System.Windows.Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Overloaded.
ReadShort | Reads a short value with the specified name.
ReadSizeF | Reads a System.Windows.Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadStringFormat | Reads a StringFormat object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
ReadVisioContent | Reads a Visio content with the specified name.
ReadXaml | Loads an object from its XAML representation.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
ToRelativePath | Converts the specified absolute path to a path relative to the BaseURI.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteFontFamily | Writes a FontFamily object with the specified name.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteFontUnit | Writes a FontUnit object with the specified name.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePoint3D | Writes a Point3D with the specified name.
WritePointCollection | Writes the specified point collection.
WritePointCoordinates | Writes the specified StylusPointCollection.
WritePointF | Writes a Point with the specified name.
WriteRectangleF | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSizeF | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.
WriteVisioContent | Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.
WriteXaml | Serializes an object to XAML.

See Also

XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.AddChildElement Method (String, XmlElement)

XmlPersistContext.AddChildElement Method (String, XmlElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName

parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.AddChildElement Method (String, XmlElement, String)

XmlPersistContext.AddChildElement Method (String, XmlElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName

parentElement

innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.FromRelativePath Method

XmlPersistContext.FromRelativePath Method
[image]

Converts the specified path from relative to the BaseURI to an absolute path.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string FromRelativePath (
string path
)

Visual Basic [image] Copy Code

Public Function FromRelativePath( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.InstantiateItem Method

XmlPersistContext.InstantiateItem Method
[image]

Instantiates an item with the specified class id.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem InstantiateItem (
string classId
)

Visual Basic [image] Copy Code

Public Function InstantiateItem( _
classId As String _
) As DiagramItem

Parameters

classId

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadAnchorPattern Method

XmlPersistContext.ReadAnchorPattern Method
[image]

Reads an AnchorPattern with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnchorPattern ReadAnchorPattern (
string elementName,
XmlElement parentElement,
bool standalone
)

Visual Basic [image] Copy Code

Public Function ReadAnchorPattern( _
elementName As String, _
parentElement As XmlElement, _
standalone As Boolean _
) As AnchorPattern

Parameters

elementName

parentElement

standalone

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadBool Method (String, XmlElement)

XmlPersistContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName

parentElement

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)

XmlPersistContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEffect Method

XmlPersistContext.ReadEffect Method
[image]

Reads a NodeEffect object with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadEffect (String, XmlElement) | Reads a NodeEffect object with the specified name.
XmlPersistContext.ReadEffect (XmlElement) | Reads a NodeEffect object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEffect Method (String, XmlElement)

XmlPersistContext.ReadEffect Method (String, XmlElement)
See Also
[image]

Reads a NodeEffect object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XmlElement _
) As NodeEffect

Parameters

elementName

parentElement

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEffect Method (XmlElement)

XmlPersistContext.ReadEffect Method (XmlElement)
See Also
[image]

Reads a NodeEffect object from the specified element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
XmlElement element
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
element As XmlElement _
) As NodeEffect

Parameters

element

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XmlElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XmlElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEnum Method (String, XmlElement)

XmlPersistContext.ReadEnum Method (String, XmlElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadEnum Method (String, XmlElement, Object)

XmlPersistContext.ReadEnum Method (String, XmlElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XmlElement) | Reads a double value with the specified name.
XmlPersistContext.ReadFloat (String, XmlElement, Single) | Reads a double value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFloat Method (String, XmlElement)

XmlPersistContext.ReadFloat Method (String, XmlElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFloat Method (String, XmlElement, Single)

XmlPersistContext.ReadFloat Method (String, XmlElement, Single)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XmlElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Single _
) As Double

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method
[image]

Reads a double array with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Double()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFontFamily Method

XmlPersistContext.ReadFontFamily Method
[image]

Reads a FontFamily object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FontFamily ReadFontFamily (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontFamily( _
elementName As String, _
parentElement As XmlElement _
) As FontFamily

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFontStyle Method

XmlPersistContext.ReadFontStyle Method
[image]

Reads a FontStyle object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadFontStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontStyle( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadFontUnit Method

XmlPersistContext.ReadFontUnit Method
[image]

Reads a FontUnit object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit ReadFontUnit (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontUnit( _
elementName As String, _
parentElement As XmlElement _
) As GraphicsUnit

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadGroup Method

XmlPersistContext.ReadGroup Method
[image]

Reads a group object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group ReadGroup (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadGroup( _
elementName As String, _
parentElement As XmlElement _
) As Group

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method
[image]

Reads a hash table object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method
[image]

Reads an System.Windows.Media.ImageSource object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ImageSource ReadImage (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XmlElement _
) As ImageSource

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XmlElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XmlElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadInt Method (String, XmlElement)

XmlPersistContext.ReadInt Method (String, XmlElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadInt Method (String, XmlElement, Int32)

XmlPersistContext.ReadInt Method (String, XmlElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value returned if the specified element is not found.

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadItemReference Method

XmlPersistContext.ReadItemReference Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadItemReference (String, XmlElement) | Reads a reference to the item with the specified name.
XmlPersistContext.ReadItemReference (XmlElement) | Reads an item reference from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadItemReference Method (String, XmlElement)

XmlPersistContext.ReadItemReference Method (String, XmlElement)
See Also
[image]

Reads a reference to the item with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
elementName As String, _
parentElement As XmlElement _
) As DiagramItem

Parameters

elementName

parentElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadItemReference Method (XmlElement)

XmlPersistContext.ReadItemReference Method (XmlElement)
See Also
[image]

Reads an item reference from the specified element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
XmlElement itemElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
itemElement As XmlElement _
) As DiagramItem

Parameters

itemElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadNodeConstraints Method

XmlPersistContext.ReadNodeConstraints Method
[image]

Reads a NodeConstraints object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeConstraints ReadNodeConstraints (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNodeConstraints( _
elementName As String, _
parentElement As XmlElement _
) As NodeConstraints

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method
[image]

Reads a System.Windows.Media.Pen object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPoint3D Method

XmlPersistContext.ReadPoint3D Method
[image]

Reads a Point3D object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Nullable<Point3D> ReadPoint3D (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint3D( _
elementName As String, _
parentElement As XmlElement _
) As Nullable(Of Point3D)

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPointCollection Method

XmlPersistContext.ReadPointCollection Method
[image]

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PointCollection ReadPointCollection (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection( _
elementName As String, _
parentElement As XmlElement _
) As PointCollection

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPointCoordinates Method

XmlPersistContext.ReadPointCoordinates Method
[image]

Reads a StylusPointCollection object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StylusPointCollection ReadPointCoordinates (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCoordinates( _
elementName As String, _
parentElement As XmlElement _
) As StylusPointCollection

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPointF Method

XmlPersistContext.ReadPointF Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadPointF (String, XmlElement) | Reads a System.Windows.Point object with the specified name.
XmlPersistContext.ReadPointF (XmlElement) | Reads a Point object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPointF Method (String, XmlElement)

XmlPersistContext.ReadPointF Method (String, XmlElement)
See Also
[image]

Reads a System.Windows.Point object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point ReadPointF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XmlElement _
) As Point

Parameters

elementName

parentElement

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadPointF Method (XmlElement)

XmlPersistContext.ReadPointF Method (XmlElement)
See Also
[image]

Reads a Point object from the specified element.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Point ReadPointF (
XmlElement element
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
element As XmlElement _
) As Point

Parameters

element

Return Value

See Also

ReadPointF Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadRectangleF Method

XmlPersistContext.ReadRectangleF Method
[image]

Reads a System.Windows.Rect object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect ReadRectangleF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XmlElement _
) As Rect

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadShape Method

XmlPersistContext.ReadShape Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadShape (String, XmlElement) | Reads a Shape object with the specified name.
XmlPersistContext.ReadShape (String, XmlElement, Shape) | Reads a Shape object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadShape Method (String, XmlElement)

XmlPersistContext.ReadShape Method (String, XmlElement)
See Also
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
elementName As String, _
parentElement As XmlElement _
) As Shape

Parameters

elementName

parentElement

Return Value

See Also

ReadShape Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadShape Method (String, XmlElement, Shape)

XmlPersistContext.ReadShape Method (String, XmlElement, Shape)
See Also
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XmlElement parentElement,
Shape defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Shape _
) As Shape

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadShape Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadSizeF Method

XmlPersistContext.ReadSizeF Method
[image]

Reads a System.Windows.Size object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size ReadSizeF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XmlElement _
) As Size

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method
[image]

Overload List

Name | Description
XmlPersistContext.ReadString (String, XmlElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XmlElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadString Method (String, XmlElement)

XmlPersistContext.ReadString Method (String, XmlElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName

parentElement

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadString Method (String, XmlElement, String)

XmlPersistContext.ReadString Method (String, XmlElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As String _
) As String

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadTag Method

XmlPersistContext.ReadTag Method
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item

elementName

parentElement

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadTheme Method

XmlPersistContext.ReadTheme Method
[image]

Reads a Theme object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Theme ReadTheme (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTheme( _
elementName As String, _
parentElement As XmlElement _
) As Theme

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadThickness Method

XmlPersistContext.ReadThickness Method
[image]

Reads a Thickness object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XmlElement _
) As Thickness

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadVisioContent Method

XmlPersistContext.ReadVisioContent Method
[image]

Reads a Visio content with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public VisioContent ReadVisioContent (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadVisioContent( _
elementName As String, _
parentElement As XmlElement _
) As VisioContent

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ReadXaml Method

XmlPersistContext.ReadXaml Method
[image]

Loads an object from its XAML representation.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object ReadXaml (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadXaml( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.SelectNode Method

XmlPersistContext.SelectNode Method
[image]

Returns the child node with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement SelectNode (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNode( _
parentElement As XmlElement, _
name As String _
) As XmlElement

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.SelectNodes Method

XmlPersistContext.SelectNodes Method
[image]

Returns the child nodes with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlNodeList SelectNodes (
XmlElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNodes( _
parentElement As XmlElement, _
name As String _
) As XmlNodeList

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child nodes.

Return Value

An XmlNodeList containing the found child nodes.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ToRelativePath Method

XmlPersistContext.ToRelativePath Method
[image]

Converts the specified absolute path to a path relative to the BaseURI.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string ToRelativePath (
string path
)

Visual Basic [image] Copy Code

Public Function ToRelativePath( _
path As String _
) As String

Parameters

path

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteAnchorPattern Method

XmlPersistContext.WriteAnchorPattern Method
[image]

Writes the specified anchor pattern.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteAnchorPattern (
AnchorPattern anchorPattern,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteAnchorPattern( _
anchorPattern As AnchorPattern, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

anchorPattern

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool boolValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

boolValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char charValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

charValue

elementName

parentElement

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal decimalValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

decimalValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double doubleValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

doubleValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteEffect Method

XmlPersistContext.WriteEffect Method
[image]

Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteEffect (
NodeEffect effect,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As NodeEffect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

effect

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object enumValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

enumValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFloat (
double floatValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

floatValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFloatArray (
double[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Double, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFontFamily Method

XmlPersistContext.WriteFontFamily Method
[image]

Writes a FontFamily object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontFamily (
FontFamily fontFamily,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontFamily( _
fontFamily As FontFamily, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

fontFamily

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFontStyle Method

XmlPersistContext.WriteFontStyle Method
[image]

Writes a FontStyle object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontStyle (
Object fontValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontStyle( _
fontValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

fontValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteFontUnit Method

XmlPersistContext.WriteFontUnit Method
[image]

Writes a FontUnit object with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFontUnit (
GraphicsUnit unit,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontUnit( _
unit As GraphicsUnit, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

unit

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteGroup Method

XmlPersistContext.WriteGroup Method
[image]

Writes the specified group object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteGroup (
Group group,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGroup( _
group As Group, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

group

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteHashtable Method

XmlPersistContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteImage (
ImageSource image,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As ImageSource, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int intValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

intValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteItemReference Method

XmlPersistContext.WriteItemReference Method
[image]

Writes a reference to the specified item with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteItemReference (
DiagramItem item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteItemReference( _
item As DiagramItem, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long longValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

longValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object objectValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

objectValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method
[image]

Writes the specified pen.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WritePoint3D Method

XmlPersistContext.WritePoint3D Method
[image]

Writes a Point3D with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePoint3D (
Point3D point,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint3D( _
point As Point3D, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

point

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WritePointCollection Method

XmlPersistContext.WritePointCollection Method
[image]

Writes the specified point collection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePointCollection (
PointCollection points,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection( _
points As PointCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

points

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WritePointCoordinates Method

XmlPersistContext.WritePointCoordinates Method
[image]

Writes the specified StylusPointCollection.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePointCoordinates (
StylusPointCollection points,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCoordinates( _
points As StylusPointCollection, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

points

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WritePointF Method

XmlPersistContext.WritePointF Method
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePointF (
Point point,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
point As Point, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

point

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteRectangleF Method

XmlPersistContext.WriteRectangleF Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteRectangleF (
Rect rectangle,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
rectangle As Rect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

rectangle

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte byteValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteShape Method

XmlPersistContext.WriteShape Method
[image]

Writes the specified shape with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteShape (
Shape shape,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShape( _
shape As Shape, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shape

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short shortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteSizeF Method

XmlPersistContext.WriteSizeF Method
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSizeF (
Size size,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
size As Size, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

size

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string stringValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringValue
The string value to write.
elementName
The name of the element that will be written.
parentElement
The parent element of the newly created node.

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteTag Method

XmlPersistContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
A reference to the item or resource whose tag is being written.
tagValue
The tag object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteTheme Method

XmlPersistContext.WriteTheme Method
[image]

Writes the specified Theme object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteTheme (
Theme theme,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTheme( _
theme As Theme, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

theme

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteThickness Method

XmlPersistContext.WriteThickness Method
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteThickness (
Thickness thickness,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

thickness

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteTraits Method

XmlPersistContext.WriteTraits Method
[image]

Writes the specified traits hashtable.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteTraits (
Hashtable traits,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTraits( _
traits As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

traits

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint uintValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

uintValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong ulongValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ulongValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort ushortValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ushortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteVisioContent Method

XmlPersistContext.WriteVisioContent Method
[image]

Writes a reference to the specified Visio content. The content is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteVisioContent (
VisioContent content,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteVisioContent( _
content As VisioContent, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

content

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.WriteXaml Method

XmlPersistContext.WriteXaml Method
[image]

Serializes an object to XAML.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteXaml (
Object elt,
string name,
XmlElement parent
)

Visual Basic [image] Copy Code

Public Function WriteXaml( _
elt As Object, _
name As String, _
parent As XmlElement _
) As XmlElement

Parameters

elt

name

parent

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext Properties

XmlPersistContext Properties
[image]

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
XmlDocument | Gets the underlying XML document.
XmlOptions | An XmlOptions object providing properties for customizing the XML serialization process.

See Also

XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.BaseURI Property

XmlPersistContext.BaseURI Property
[image]

Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string BaseURI { get; set; }

Visual Basic [image] Copy Code

Public Property BaseURI As String

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.ClassVersion Property

XmlPersistContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version.

Remarks

This property is only useful when deserializing items.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.Diagram Property

XmlPersistContext.Diagram Property
[image]

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.FileVersion Property

XmlPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the System.Xml.XmlDocument class.

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.XmlPersistContext.XmlOptions Property

XmlPersistContext.XmlOptions Property
[image]

An XmlOptions object providing properties for customizing the XML serialization process.

Namespace: MindFusion.Diagramming.Wpf
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public XmlOptions XmlOptions { get; set; }

Visual Basic [image] Copy Code

Public Property XmlOptions As XmlOptions

Property Value

See Also

XmlPersistContext Members
XmlPersistContext Class
MindFusion.Diagramming.Wpf Namespace


MindFusion.Diagramming.Wpf.Behaviors Namespace

MindFusion.Diagramming.Wpf.Behaviors Namespace
Classes

Classes

Class | Description
BehaviorBase | An abstract base class for classes that defines how MindFusion.Diagramming for WPF reacts to users' actions with a mouse or other pointing devices.
CustomTypesBehavior | This class is used when the diagram behavior is set to Behavior.Custom.
DrawBarcodesBehavior | This class is used when the diagram behavior is set to Behavior.DrawBarcodes.
DrawContainersBehavior | This class is used when the diagram behavior is set to Behavior.DrawContainers.
DrawControlsBehavior | This class is used when the diagram behavior is set to BehaviorType.DrawControls.
DrawFreeFormsBehavior | This class is used when the diagram behavior is set to Behavior.DrawFreeForms.
DrawLinksBehavior | This class is used when the diagram behavior is set to Behavior.DrawLinks.
DrawNodesBehavior | This class is the base for node-drawing behavior classes.
DrawShapesBehavior | This class is used when the diagram behavior is set to Behavior.DrawShapes.
DrawTablesBehavior | This class is used when the diagram behavior is set to Behavior.DrawTables.
DrawTreeViewsBehavior | This class is used when the diagram behavior is set to Behavior.DrawTreeView.
DrawVisioNodesBehavior | This class is used when the diagram behavior is set to Behavior.DrawVisioNodes.
LinkBarcodesBehavior | This class is used when the diagram behavior is set to Behavior.LinkBarcodes.
LinkContainersBehavior | This class is used when the diagram behavior is set to Behavior.LinkContainers.
LinkControlsBehavior | This class is used when the diagram behavior is set to BehaviorType.LinkControls.
LinkFreeFormsBehavior | This class is used when the diagram behavior is set to Behavior.LinkFreeForms.
LinkNodesBehavior | Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.
LinkShapesBehavior | This class is used when the diagram behavior is set to Behavior.LinkShapes.
LinkTablesBehavior | This class is used when the diagram behavior is set to Behavior.LinkTables.
LinkTreeViewsBehavior | This class is used when the diagram behavior is set to Behavior.LinkTreeViews.
LinkVisioNodesBehavior | This class is used when the diagram behavior is set to Behavior.LinkVisioNodes.
ModifyBehavior | This class is used when the diagram behavior is set to Behavior.Modify.
SelectOnlyBehavior | This class is used when the diagram behavior is set to Behavior.SelectOnly.


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase Class

BehaviorBase Class
Remarks See Also
[image]

An abstract base class for classes that defines how MindFusion.Diagramming for WPF reacts to users' actions with a mouse or other pointing devices.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class BehaviorBase : Interaction

Visual Basic [image] Copy Code

Public MustInherit Class BehaviorBase
Inherits Interaction

Remarks

MindFusion.Diagramming for WPF comes with several predefined Behavior classes that can be selected by the Behavior property of the Diagram class. Custom behavior objects can be assigned to the CustomBehavior property.

To define a custom behavior class, implement the StartDraw method which specifies how the control responds when a user starts to draw with the mouse. Implement the GetTargetNode method to let users draw connections between nodes. The SetMouseCursor method is called while the mouse moves to let you set a custom mouse cursor depending on the current mouse location.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior
MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior

See Also

BehaviorBase Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase Members

BehaviorBase Members
Constructors Properties Methods
[image]

An abstract base class for classes that defines how MindFusion.Diagramming for WPF reacts to users' actions with a mouse or other pointing devices.

The following tables list the members exposed by the BehaviorBase type.

Protected Constructors

Name | Description
BehaviorBase | Initializes a new instance of the BehaviorBase class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let your application set the mouse cursor.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override.
OnMouseMove | Interaction.OnMouseMove override.
OnMouseUp | Interaction.OnMouseUp override.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.
StartDrawCommon | Invoked by the control when the user presses the left mouse button.

See Also

BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase Constructor

BehaviorBase Constructor
[image]

Initializes a new instance of the BehaviorBase class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected BehaviorBase (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase Methods

BehaviorBase Methods
[image]

Public Methods

Name | Description
SetMouseCursor | Invoked while the mouse is moved to let your application set the mouse cursor.
StartDraw | Invoked when a user presses the left mouse button inside the diagram drawing area.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override.
OnMouseMove | Interaction.OnMouseMove override.
OnMouseUp | Interaction.OnMouseUp override.
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state.
StartDrawCommon | Invoked by the control when the user presses the left mouse button.

See Also

BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.CreateLink Method

BehaviorBase.CreateLink Method
[image]

Creates a link of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DiagramLink CreateLink ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateLink () As DiagramLink

Return Value

An instance of the DiagramLink class.

Remarks

Override this method to specify the type of DiagramLink, which is most appropriate for your diagram. The link is created every time the user connects two DiagramNode objects.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.OnMouseDown Method

BehaviorBase.OnMouseDown Method
[image]

Interaction.OnMouseDown override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

mouseButton

A member of the MouseButton enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.OnMouseMove Method

BehaviorBase.OnMouseMove Method
[image]

Interaction.OnMouseMove override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
Point mousePosition
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
mousePosition As Point _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.OnMouseUp Method

BehaviorBase.OnMouseUp Method
[image]

Interaction.OnMouseUp override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
Point mousePosition,
MouseButton mouseButton
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
mousePosition As Point, _
mouseButton As MouseButton _
)

Parameters

mousePosition

A Point instance that specifies the mouse pointer position.

mouseButton

A member of the MouseButton enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.SetModfCursor Method

BehaviorBase.SetModfCursor Method
[image]

Updates the current cursor according to the specified cursor position and diagram state.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected CursorHint SetModfCursor (
Point pt,
AdjustmentHandle handle,
bool active,
bool autoh
)

Visual Basic [image] Copy Code

Protected Function SetModfCursor( _
pt As Point, _
handle As AdjustmentHandle, _
active As Boolean, _
autoh As Boolean _
) As CursorHint

Parameters

pt

A Point structure that specifies the current mouse position.

handle
The adjustment handle pointed by mouse cursor.
active

Specifies whether the mouse is over the ActiveItem.

autoh

true when the mouse is over a DiagramItem and the ModificationStart property of the DiagramView is set to AutoHandles.

Return Value

A member of the CursorHint enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.SetMouseCursor Method

BehaviorBase.SetMouseCursor Method
[image]

Invoked while the mouse is moved to let your application set the mouse cursor.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public MustOverride Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A Point structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.StartDraw Method

BehaviorBase.StartDraw Method
[image]

Invoked when a user presses the left mouse button inside the diagram drawing area.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class, which specifies whether dragging the mouse should create or modify an item.

Remarks

To start creating an item, pass a new instance of a DiagramItem derived class to the InteractionState constructor and set the constructor's action argument to Action.Create. Do not use methods such as Nodes.Add or CreateShapeNode to add the new item to the diagram; the item will be added automatically when the user completes drawing it. If creating a link, use the DiagramLink constructor that takes a single DiagramNode argument, specifying the origin node.

To start modifying an item, provide a reference to an existing item as argument of the InteractionState constructor and set the action argument to Action.Modify.

Example

This StartDraw implementation allows only moving existing nodes or creating new nodes using the mouse:

C# [image] Copy Code
public override InteractionState StartDraw(Point point)
{
DiagramNode node = Diagram.GetNodeAt(point, true, false);
if (node != null)
return new InteractionState(node, NodeAdjustmentHandle.Move, Action.Modify);
else
return new InteractionState(new ShapeNode(Diagram), null, Action.Create);
}
Visual Basic [image] Copy Code

Public Overrides Function StartDraw(ByVal point As Point) As InteractionState

Dim node As DiagramNode = Diagram.GetNodeAt(point, True, False)

If Not node Is Nothing Then
Return New InteractionState(node, NodeAdjustmentHandle.Move, Action.Modify)
Else
Return New InteractionState(New ShapeNode(Diagram), Nothing, Action.Create)
End If

End Function

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase.StartDrawCommon Method

BehaviorBase.StartDrawCommon Method
[image]

Invoked by the control when the user presses the left mouse button.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual InteractionState StartDrawCommon (
Point point,
MouseButton button
)

Visual Basic [image] Copy Code

Protected Overridable Function StartDrawCommon( _
point As Point, _
button As MouseButton _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

button

A member of the MouseButton enumeration.

Return Value

An instance of the InteractionState class, which specifies whether dragging the mouse should create or modify an item.

Remarks

This method is invoked first and it relies on the public StartDraw method implemented by derived behavior classes.

See Also

BehaviorBase Members
BehaviorBase Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior Class

CustomTypesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Custom.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CustomTypesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class CustomTypesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior

See Also

CustomTypesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior Members

CustomTypesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.Custom.

The following tables list the members exposed by the CustomTypesBehavior type.

Protected Constructors

Name | Description
CustomTypesBehavior | Initializes a new instance of the CustomTypesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | BehaviorBase.CreateLink override.
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior Constructor

CustomTypesBehavior Constructor
[image]

Initializes a new instance of the CustomTypesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected CustomTypesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior Methods

CustomTypesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | BehaviorBase.CreateLink override.
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

CustomTypesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior.CreateLink Method

CustomTypesBehavior.CreateLink Method
[image]

BehaviorBase.CreateLink override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramLink CreateLink ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateLink () As DiagramLink

Return Value

An instance of the DiagramLink class.

See Also

CustomTypesBehavior Members
CustomTypesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior.CreateNode Method

CustomTypesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

CustomTypesBehavior Members
CustomTypesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior Class

DrawBarcodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawBarcodes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawBarcodesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawBarcodesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior

See Also

DrawBarcodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior Members

DrawBarcodesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawBarcodes.

The following tables list the members exposed by the DrawBarcodesBehavior type.

Protected Constructors

Name | Description
DrawBarcodesBehavior | Initializes a new instance of the DrawBarcodesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior Constructor

DrawBarcodesBehavior Constructor
[image]

Initializes a new instance of the DrawBarcodesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawBarcodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior Methods

DrawBarcodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior.CreateNode Method

DrawBarcodesBehavior.CreateNode Method
[image]

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the BarcodeNode class.

See Also

DrawBarcodesBehavior Members
DrawBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior Class

DrawContainersBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawContainers.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawContainersBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawContainersBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior

See Also

DrawContainersBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior Members

DrawContainersBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawContainers.

The following tables list the members exposed by the DrawContainersBehavior type.

Protected Constructors

Name | Description
DrawContainersBehavior | Initializes a new instance of the DrawContainersBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior Constructor

DrawContainersBehavior Constructor
[image]

Initializes a new instance of the DrawContainersBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawContainersBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior Methods

DrawContainersBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior.CreateNode Method

DrawContainersBehavior.CreateNode Method
[image]

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawContainersBehavior Members
DrawContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior Class

DrawControlsBehavior Class
[image]

This class is used when the diagram behavior is set to BehaviorType.DrawControls.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawControlsBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawControlsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior

See Also

DrawControlsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior Members

DrawControlsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to BehaviorType.DrawControls.

The following tables list the members exposed by the DrawControlsBehavior type.

Protected Constructors

Name | Description
DrawControlsBehavior | Initializes a new instance of the DrawControlsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior Constructor

DrawControlsBehavior Constructor
[image]

Initializes a new instance of the DrawControlsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawControlsBehavior (
Diagram diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As Diagram _
)

Parameters

diagramView

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior Methods

DrawControlsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior.CreateNode Method

DrawControlsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

See Also

DrawControlsBehavior Members
DrawControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior Class

DrawFreeFormsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawFreeForms.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawFreeFormsBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawFreeFormsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior

See Also

DrawFreeFormsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior Members

DrawFreeFormsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawFreeForms.

The following tables list the members exposed by the DrawFreeFormsBehavior type.

Protected Constructors

Name | Description
DrawFreeFormsBehavior | Initializes a new instance of the DrawFreeFormsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior Constructor

DrawFreeFormsBehavior Constructor
[image]

Initializes a new instance of the DrawFreeFormsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawFreeFormsBehavior (
Diagram diagram,
bool convertToShape
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram, _
convertToShape As Boolean _
)

Parameters

diagram

The Diagram this behavior will be associated with.

convertToShape

true to convert the FreeFormNode to a ShapeNode once user finishes drawing it, or false otherwise.

See Also

DrawFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior Methods

DrawFreeFormsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior.CreateNode Method

DrawFreeFormsBehavior.CreateNode Method
[image]

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the FreeFormNode class.

See Also

DrawFreeFormsBehavior Members
DrawFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior Class

DrawLinksBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawLinksBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class DrawLinksBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior

See Also

DrawLinksBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior Members

DrawLinksBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawLinks.

The following tables list the members exposed by the DrawLinksBehavior type.

Protected Constructors

Name | Description
DrawLinksBehavior | Initializes a new instance of the DrawLinksBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior Constructor

DrawLinksBehavior Constructor
[image]

Initializes a new instance of the DrawLinksBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawLinksBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior Methods

DrawLinksBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawLinksBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior.SetMouseCursor Method

DrawLinksBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A Point structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawLinksBehavior.StartDraw Method

DrawLinksBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawLinksBehavior Members
DrawLinksBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior Class

DrawNodesBehavior Class
[image]

This class is the base for node-drawing behavior classes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawNodesBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class DrawNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawBarcodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawContainersBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawControlsBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawFreeFormsBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior

See Also

DrawNodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior Members

DrawNodesBehavior Members
Constructors Properties Methods
[image]

This class is the base for node-drawing behavior classes.

The following tables list the members exposed by the DrawNodesBehavior type.

Protected Constructors

Name | Description
DrawNodesBehavior | Initializes a new instance of the DrawNodesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior Constructor

DrawNodesBehavior Constructor
[image]

Initializes a new instance of the DrawNodesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior Methods

DrawNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior.CreateNode Method

DrawNodesBehavior.CreateNode Method
[image]

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

The default implementation returns a TemplatedNode instance.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior.SetMouseCursor Method

DrawNodesBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point

A Point structure that specifies the position of the mouse cursor.

startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior.StartDraw Method

DrawNodesBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

DrawNodesBehavior Members
DrawNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior Class

DrawShapesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawShapes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawShapesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawShapesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior

See Also

DrawShapesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior Members

DrawShapesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawShapes.

The following tables list the members exposed by the DrawShapesBehavior type.

Protected Constructors

Name | Description
DrawShapesBehavior | Initializes a new instance of the DrawShapesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior Constructor

DrawShapesBehavior Constructor
[image]

Initializes a new instance of the DrawShapesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawShapesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior Methods

DrawShapesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawShapesBehavior.CreateNode Method

DrawShapesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawShapesBehavior Members
DrawShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior Class

DrawTablesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawTables.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawTablesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawTablesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior

See Also

DrawTablesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior Members

DrawTablesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawTables.

The following tables list the members exposed by the DrawTablesBehavior type.

Protected Constructors

Name | Description
DrawTablesBehavior | Initializes a new instance of the DrawTablesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior Constructor

DrawTablesBehavior Constructor
[image]

Initializes a new instance of the DrawTablesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawTablesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior Methods

DrawTablesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTablesBehavior.CreateNode Method

DrawTablesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawTablesBehavior Members
DrawTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior Class

DrawTreeViewsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawTreeView.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawTreeViewsBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawTreeViewsBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior

See Also

DrawTreeViewsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior Members

DrawTreeViewsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawTreeView.

The following tables list the members exposed by the DrawTreeViewsBehavior type.

Protected Constructors

Name | Description
DrawTreeViewsBehavior | Initializes a new instance of the DrawTreeViewsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior Constructor

DrawTreeViewsBehavior Constructor
[image]

Initializes a new instance of the DrawTreeViewsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawTreeViewsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

DrawTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior Methods

DrawTreeViewsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | DrawNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawTreeViewsBehavior.CreateNode Method

DrawTreeViewsBehavior.CreateNode Method
[image]

DrawNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the TreeViewNode class.

See Also

DrawTreeViewsBehavior Members
DrawTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior Class

DrawVisioNodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawVisioNodes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawVisioNodesBehavior : DrawNodesBehavior

Visual Basic [image] Copy Code

Public Class DrawVisioNodesBehavior
Inherits DrawNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.DrawNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior

See Also

DrawVisioNodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior Members

DrawVisioNodesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawVisioNodes.

The following tables list the members exposed by the DrawVisioNodesBehavior type.

Protected Constructors

Name | Description
DrawVisioNodesBehavior | Initializes a new instance of the DrawVisioNodesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior Constructor

DrawVisioNodesBehavior Constructor
[image]

Initializes a new instance of the DrawVisioNodesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected DrawVisioNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior Methods

DrawVisioNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from DrawNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from DrawNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

DrawVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.DrawVisioNodesBehavior.CreateNode Method

DrawVisioNodesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

DrawVisioNodesBehavior Members
DrawVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior Class

LinkBarcodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkBarcodes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkBarcodesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkBarcodesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior

See Also

LinkBarcodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior Members

LinkBarcodesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkBarcodes.

The following tables list the members exposed by the LinkBarcodesBehavior type.

Protected Constructors

Name | Description
LinkBarcodesBehavior | Initializes a new instance of the LinkBarcodesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior Constructor

LinkBarcodesBehavior Constructor
[image]

Initializes a new instance of the LinkBarcodesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkBarcodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

LinkBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior Methods

LinkBarcodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior.CreateNode Method

LinkBarcodesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the BarcodeNode class.

See Also

LinkBarcodesBehavior Members
LinkBarcodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior Class

LinkContainersBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkContainers.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkContainersBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkContainersBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior

See Also

LinkContainersBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior Members

LinkContainersBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkContainers.

The following tables list the members exposed by the LinkContainersBehavior type.

Protected Constructors

Name | Description
LinkContainersBehavior | Initializes a new instance of the LinkContainersBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior Constructor

LinkContainersBehavior Constructor
[image]

Initializes a new instance of the LinkContainersBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkContainersBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior Methods

LinkContainersBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior.CreateNode Method

LinkContainersBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkContainersBehavior Members
LinkContainersBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior Class

LinkControlsBehavior Class
[image]

This class is used when the diagram behavior is set to BehaviorType.LinkControls.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkControlsBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkControlsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior

See Also

LinkControlsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior Members

LinkControlsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to BehaviorType.LinkControls.

The following tables list the members exposed by the LinkControlsBehavior type.

Protected Constructors

Name | Description
LinkControlsBehavior | Initializes a new instance of the LinkControlsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior Constructor

LinkControlsBehavior Constructor
[image]

Initializes a new instance of the LinkControlsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkControlsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior Methods

LinkControlsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior.CreateNode Method

LinkControlsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

See Also

LinkControlsBehavior Members
LinkControlsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior Class

LinkFreeFormsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkFreeForms.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkFreeFormsBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkFreeFormsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior

See Also

LinkFreeFormsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior Members

LinkFreeFormsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkFreeForms.

The following tables list the members exposed by the LinkFreeFormsBehavior type.

Protected Constructors

Name | Description
LinkFreeFormsBehavior | Initializes a new instance of the LinkFreeFormsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior Constructor

LinkFreeFormsBehavior Constructor
[image]

Initializes a new instance of the LinkFreeFormsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkFreeFormsBehavior (
Diagram diagram,
bool convertToShape
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram, _
convertToShape As Boolean _
)

Parameters

diagram

The Diagram this behavior will be associated with.

convertToShape

true to convert the FreeFormNode to a ShapeNode once user finishes drawing it, or false otherwise.

See Also

LinkFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior Methods

LinkFreeFormsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior.CreateNode Method

LinkFreeFormsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the FreeFormNode class.

See Also

LinkFreeFormsBehavior Members
LinkFreeFormsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior Class

LinkNodesBehavior Class
[image]

Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkNodesBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class LinkNodesBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.CustomTypesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkBarcodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkContainersBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkControlsBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkFreeFormsBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior

See Also

LinkNodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior Members

LinkNodesBehavior Members
Constructors Properties Methods
[image]

Declares a base class for all node-link behaviors, such as LinkShapesBehavior, LinkTablesBehavior, and so on.

The following tables list the members exposed by the LinkNodesBehavior type.

Protected Constructors

Name | Description
LinkNodesBehavior | Initializes a new instance of the LinkNodesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior Constructor

LinkNodesBehavior Constructor
[image]

Initializes a new instance of the LinkNodesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior Methods

LinkNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | Creates a node of the type appropriate for the current behavior.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior.CreateNode Method

LinkNodesBehavior.CreateNode Method
[image]

Creates a node of the type appropriate for the current behavior.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateNode () As DiagramNode

Return Value

The default implementation returns a TemplatedNode instance.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior.SetMouseCursor Method

LinkNodesBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A Point structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior.StartDraw Method

LinkNodesBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

LinkNodesBehavior Members
LinkNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior Class

LinkShapesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkShapesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkShapesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior

See Also

LinkShapesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior Members

LinkShapesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkShapes.

The following tables list the members exposed by the LinkShapesBehavior type.

Protected Constructors

Name | Description
LinkShapesBehavior | Initializes a new instance of the LinkShapesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior Constructor

LinkShapesBehavior Constructor
[image]

Initializes a new instance of the LinkShapesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkShapesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior Methods

LinkShapesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkShapesBehavior.CreateNode Method

LinkShapesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkShapesBehavior Members
LinkShapesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior Class

LinkTablesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkTables.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkTablesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkTablesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior

See Also

LinkTablesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior Members

LinkTablesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkTables.

The following tables list the members exposed by the LinkTablesBehavior type.

Protected Constructors

Name | Description
LinkTablesBehavior | Initializes a new instance of the LinkTablesBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior Constructor

LinkTablesBehavior Constructor
[image]

Initializes a new instance of the LinkTablesBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkTablesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior Methods

LinkTablesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTablesBehavior.CreateNode Method

LinkTablesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the DiagramNode class.

See Also

LinkTablesBehavior Members
LinkTablesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior Class

LinkTreeViewsBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkTreeViews.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkTreeViewsBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkTreeViewsBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior

See Also

LinkTreeViewsBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior Members

LinkTreeViewsBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkTreeViews.

The following tables list the members exposed by the LinkTreeViewsBehavior type.

Protected Constructors

Name | Description
LinkTreeViewsBehavior | Initializes a new instance of the LinkTreeViewsBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior Constructor

LinkTreeViewsBehavior Constructor
[image]

Initializes a new instance of the LinkTreeViewsBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkTreeViewsBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

LinkTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior Methods

LinkTreeViewsBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkTreeViewsBehavior.CreateNode Method

LinkTreeViewsBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the TreeViewNode class.

See Also

LinkTreeViewsBehavior Members
LinkTreeViewsBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior Class

LinkVisioNodesBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkVisioNodes.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LinkVisioNodesBehavior : LinkNodesBehavior

Visual Basic [image] Copy Code

Public Class LinkVisioNodesBehavior
Inherits LinkNodesBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.LinkNodesBehavior
MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior

See Also

LinkVisioNodesBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior Members

LinkVisioNodesBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkVisioNodes.

The following tables list the members exposed by the LinkVisioNodesBehavior type.

Protected Constructors

Name | Description
LinkVisioNodesBehavior | Initializes a new instance of the LinkContainersBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior Constructor

LinkVisioNodesBehavior Constructor
[image]

Initializes a new instance of the LinkContainersBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected LinkVisioNodesBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior Methods

LinkVisioNodesBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override. (Inherited from LinkNodesBehavior.)
StartDraw | BehaviorBase.StartDraw override. (Inherited from LinkNodesBehavior.)

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
CreateNode | LinkNodesBehavior.CreateNode override.
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

LinkVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.LinkVisioNodesBehavior.CreateNode Method

LinkVisioNodesBehavior.CreateNode Method
[image]

LinkNodesBehavior.CreateNode override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override DiagramNode CreateNode ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateNode () As DiagramNode

Return Value

An instance of the VisioNode class.

See Also

LinkVisioNodesBehavior Members
LinkVisioNodesBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior Class

ModifyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ModifyBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class ModifyBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior

See Also

ModifyBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior Members

ModifyBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.Modify.

The following tables list the members exposed by the ModifyBehavior type.

Protected Constructors

Name | Description
ModifyBehavior | Initializes a new instance of the ModifyBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

ModifyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior Constructor

ModifyBehavior Constructor
[image]

Initializes a new instance of the ModifyBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected ModifyBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Protected New ( _
diagram As Diagram _
)

Parameters

diagram
The Diagram this behavior will be associated with.

See Also

ModifyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior Methods

ModifyBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button. (Inherited from BehaviorBase.)

See Also

ModifyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior.SetMouseCursor Method

ModifyBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point
A Point structure that specifies the position of the mouse cursor.
startInteraction
true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

ModifyBehavior Members
ModifyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.ModifyBehavior.StartDraw Method

ModifyBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point
A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

ModifyBehavior Members
ModifyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior Class

SelectOnlyBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.SelectOnly.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SelectOnlyBehavior : BehaviorBase

Visual Basic [image] Copy Code

Public Class SelectOnlyBehavior
Inherits BehaviorBase

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Interaction
MindFusion.Diagramming.Wpf.Behaviors.BehaviorBase
MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior

See Also

SelectOnlyBehavior Members
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior Members

SelectOnlyBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.SelectOnly.

The following tables list the members exposed by the SelectOnlyBehavior type.

Public Constructors

Name | Description
SelectOnlyBehavior | Initializes a new instance of the SelectOnlyBehavior class.

Public Properties

Name | Description
Diagram | Gets the Diagram modified through this Interaction object. (Inherited from Interaction.)

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button.

See Also

SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior Constructor

SelectOnlyBehavior Constructor
[image]

Initializes a new instance of the SelectOnlyBehavior class.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SelectOnlyBehavior (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this behavior will be associated with.

See Also

SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior Methods

SelectOnlyBehavior Methods
[image]

Public Methods

Name | Description
SetMouseCursor | BehaviorBase.SetMouseCursor override.
StartDraw | BehaviorBase.StartDraw override.

Protected Methods

Name | Description
CreateLink | Creates a link of the type appropriate for the current behavior. (Inherited from BehaviorBase.)
OnMouseDown | Interaction.OnMouseDown override. (Inherited from BehaviorBase.)
OnMouseMove | Interaction.OnMouseMove override. (Inherited from BehaviorBase.)
OnMouseUp | Interaction.OnMouseUp override. (Inherited from BehaviorBase.)
SetModfCursor | Updates the current cursor according to the specified cursor position and diagram state. (Inherited from BehaviorBase.)
StartDrawCommon | Invoked by the control when the user presses the left mouse button.

See Also

SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior.SetMouseCursor Method

SelectOnlyBehavior.SetMouseCursor Method
[image]

BehaviorBase.SetMouseCursor override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override CursorHint SetMouseCursor (
Point point,
out bool startInteraction
)

Visual Basic [image] Copy Code

Public Overrides Function SetMouseCursor( _
point As Point, _
<System.Runtime.InteropServices.Out()> ByRef startInteraction As Boolean _
) As CursorHint

Parameters

point

A Point structure that specifies the position of the mouse cursor.

startInteraction

true if the user is going to create, delete, modify or select a DiagramItem; false if mouse behavior is not considered; in this case the mouse pointer is set to a default cursor according to the background LaneGrid.

Return Value

A member of the CursorHint enumeration.

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior.StartDraw Method

SelectOnlyBehavior.StartDraw Method
[image]

BehaviorBase.StartDraw override.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override InteractionState StartDraw (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function StartDraw( _
point As Point _
) As InteractionState

Parameters

point

A Point structure, which specifies the current position of the mouse cursor, in document coordinates.

Return Value

An instance of the InteractionState class.

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Behaviors.SelectOnlyBehavior.StartDrawCommon Method

SelectOnlyBehavior.StartDrawCommon Method
[image]

Invoked by the control when the user presses the left mouse button.

Namespace: MindFusion.Diagramming.Wpf.Behaviors
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override InteractionState StartDrawCommon (
Point point,
MouseButton button
)

Visual Basic [image] Copy Code

Protected Overrides Function StartDrawCommon( _
point As Point, _
button As MouseButton _
) As InteractionState

Parameters

point

button

Return Value

Remarks

This method is invoked first and it relies on the public StartDraw method implemented by derived behavior classes.

See Also

SelectOnlyBehavior Members
SelectOnlyBehavior Class
MindFusion.Diagramming.Wpf.Behaviors Namespace


MindFusion.Diagramming.Wpf.Commands Namespace

MindFusion.Diagramming.Wpf.Commands Namespace
Classes

Classes

Class | Description
AddGroupCmd | Implements creation of groups.
AddItemCmd | Implements creation of new diagram items.
AddToContainerCmd | Undoable command that implements an addition of a node to a container.
ChangeItemCmd | Handles undo / redo of programmatic property changes.
Command | Represent an action that can be carried out on a diagram, and later undone or redone.
CommandCollection | A collection of commands.
CommandContext | The context of an executing command.
CommandList | Represents a read-only collection of Command objects.
CompositeCmd | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
EditTextCmd | Represents undoable edit operations.
ExpandHeaderRowCmd | Implements undo and redo of collapsing or expanding the header row of a table section.
ExpandItemCmd | Implements expanding/collapsing trees of items.
ExpandTreeViewItemCmd | Implements support for undo of TreeViewItem collapse/expand operations.
FoldContainerCmd | Undoable command that implements scrolling of table rows.
GroupAttachCmd | Implements an addition of a subordinated item to a group.
GroupDetachCmd | Implements removal of an item from a group.
ModifyItemCmd | Implements changes of item's size and position.
RedimTableCmd | Implements changes to the number of table's rows and coolumns.
RemoveFromContainerCmd | Undoable command that implements an addition of a node to a container.
RemoveGroupCmd | Implements destruction of groups.
RemoveItemCmd | Implements deletion of diagram items.
ResizeTableColumnCmd | Implements resizing of table's columns.
ResizeTableRowCmd | Implements resizing of table's rows.
ScrollTableCmd | Implements scrolling of table's rows.
ScrollTreeViewCmd | Implements support for undo of TreeViewNode scroll operations.


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd Class

AddGroupCmd Class
Remarks See Also
[image]

Implements creation of groups.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AddGroupCmd : Command

Visual Basic [image] Copy Code

Public Class AddGroupCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to calls to the CreateGroup method. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.AddGroupCmd

See Also

AddGroupCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd Members

AddGroupCmd Members
Constructors Properties Methods
[image]

Implements creation of groups.

The following tables list the members exposed by the AddGroupCmd type.

Public Constructors

Name | Description
AddGroupCmd | Initializes a new instance of the AddGroupCmd class.

Public Properties

Name | Description
Group | Gets a reference to the new group.
Item | Gets a reference to the master item in the group.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd Constructor

AddGroupCmd Constructor
[image]

Initializes a new instance of the AddGroupCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AddGroupCmd (
DiagramItem item,
Group group
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
group As Group _
)

Parameters

item

group

See Also

AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd Methods

AddGroupCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd.Execute Method

AddGroupCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd.Redo Method

AddGroupCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd.Undo Method

AddGroupCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd Properties

AddGroupCmd Properties
[image]

Public Properties

Name | Description
Group | Gets a reference to the new group.
Item | Gets a reference to the master item in the group.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd.Group Property

AddGroupCmd.Group Property
[image]

Gets a reference to the new group.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddGroupCmd.Item Property

AddGroupCmd.Item Property
[image]

Gets a reference to the master item in the group.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

AddGroupCmd Members
AddGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd Class

AddItemCmd Class
Remarks See Also
[image]

Implements creation of new diagram items.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AddItemCmd : Command

Visual Basic [image] Copy Code

Public Class AddItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to users drawing new items or to programmatically calling the Add method of the diagram's Nodes or Links collections. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.AddItemCmd

See Also

AddItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd Members

AddItemCmd Members
Constructors Properties Methods
[image]

Implements creation of new diagram items.

The following tables list the members exposed by the AddItemCmd type.

Public Constructors

Name | Description
AddItemCmd | Initializes a new instance of the AddItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the newly added item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd Constructor

AddItemCmd Constructor
[image]

Initializes a new instance of the AddItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AddItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd Methods

AddItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd.Execute Method

AddItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd.Redo Method

AddItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd.Undo Method

AddItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd Properties

AddItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the newly added item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddItemCmd.Item Property

AddItemCmd.Item Property
[image]

Gets a reference to the newly added item.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Class

AddToContainerCmd Class
[image]

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AddToContainerCmd : Command

Visual Basic [image] Copy Code

Public Class AddToContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd

See Also

AddToContainerCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Members

AddToContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the AddToContainerCmd type.

Protected Constructors

Name | Description
AddToContainerCmd | Overloaded.

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Constructor

AddToContainerCmd Constructor
[image]

Overload List

Name | Description
AddToContainerCmd (ContainerNode, DiagramNodeCollection, Boolean) | Initializes a new instance of the AddToContainerCmd class.
AddToContainerCmd (ContainerNode, DiagramNodeCollection, Boolean, GroupAnchorStyles) | Initializes a new instance of the AddToContainerCmd class.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Constructor (ContainerNode, DiagramNodeCollection, Boolean)

AddToContainerCmd Constructor (ContainerNode, DiagramNodeCollection, Boolean)
See Also
[image]

Initializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected AddToContainerCmd (
ContainerNode container,
DiagramNodeCollection nodes,
bool interactive
)

Visual Basic [image] Copy Code

Protected New ( _
container As ContainerNode, _
nodes As DiagramNodeCollection, _
interactive As Boolean _
)

Parameters

container
A ContainerNode instance.
nodes

interactive

See Also

AddToContainerCmd Constructor Overload List
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Constructor (ContainerNode, DiagramNodeCollection, Boolean, GroupAnchorStyles)

AddToContainerCmd Constructor (ContainerNode, DiagramNodeCollection, Boolean, GroupAnchorStyles)
See Also
[image]

Initializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AddToContainerCmd (
ContainerNode container,
DiagramNodeCollection nodes,
bool interactive,
GroupAnchorStyles anchorStyles
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode, _
nodes As DiagramNodeCollection, _
interactive As Boolean, _
anchorStyles As GroupAnchorStyles _
)

Parameters

container

The target ContainerNode.

nodes

The child nodes being added.

interactive

true if adding interactively, or false otherwise.

anchorStyles

A combination of GroupAnchorStyles enum members.

See Also

AddToContainerCmd Constructor Overload List
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Methods

AddToContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Adopt Method

AddToContainerCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Execute Method

AddToContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.IsContainerOf Method

AddToContainerCmd.IsContainerOf Method
[image]

Determines whether a command has been initiated by this command and should be treated as a derivative.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool IsContainerOf (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function IsContainerOf( _
command As Command _
) As Boolean

Parameters

command
The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Redo Method

AddToContainerCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Undo Method

AddToContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd Properties

AddToContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Container Property

AddToContainerCmd.Container Property
[image]

Gets the container node associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd.Nodes Property

AddToContainerCmd.Nodes Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd Class

ChangeItemCmd Class
Remarks See Also
[image]

Handles undo / redo of programmatic property changes.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ChangeItemCmd : Command

Visual Basic [image] Copy Code

Public Class ChangeItemCmd
Inherits Command

Remarks

Create an instance of this class in order to enable undo / redo of changes to item's properties. The constructor records the initial state of the item and the Execute method records the final state and adds the ChangeItemCmd object to the undo manager's history.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd

See Also

ChangeItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd Members

ChangeItemCmd Members
Constructors Properties Methods
[image]

Handles undo / redo of programmatic property changes.

The following tables list the members exposed by the ChangeItemCmd type.

Public Constructors

Name | Description
ChangeItemCmd | Initializes a new instance of the ChangeItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd Constructor

ChangeItemCmd Constructor
[image]

Initializes a new instance of the ChangeItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ChangeItemCmd (
DiagramItem item,
string title
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
title As String _
)

Parameters

item
A DiagramItem instance.
title

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd Methods

ChangeItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Execute Method

ChangeItemCmd.Execute Method
[image]

Overload List

Name | Description
ChangeItemCmd.Execute () | Excutes the command, adding it to the command history.
ChangeItemCmd.Execute (Boolean) | Carries out the command action.

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Execute Method ()

ChangeItemCmd.Execute Method ()
See Also
[image]

Excutes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Execute ()

Visual Basic [image] Copy Code

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Execute Method (Boolean)

ChangeItemCmd.Execute Method (Boolean)
See Also
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Redo Method

ChangeItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Undo Method

ChangeItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd Properties

ChangeItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd.Item Property

ChangeItemCmd.Item Property
[image]

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command Class

Command Class
Remarks See Also
[image]

Represent an action that can be carried out on a diagram, and later undone or redone.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Remarks

Command is an abctract class which defines the interface expected by the undo manager for undoing or redoing actions. All actions that can be carried out by MindFusion.Diagramming for WPF in response to users' input or method calls are implemented in Command subclasses. For a list of Command-derived classes see Actions and Commands.

The Execute, Undo or Redo methods are defined as abstract and must be implemented by derived classes. You must not call these methods directly - use the Undo or Redo methods of the UndoManager instead.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.AddGroupCmd
MindFusion.Diagramming.Wpf.Commands.AddItemCmd
MindFusion.Diagramming.Wpf.Commands.AddToContainerCmd
MindFusion.Diagramming.Wpf.Commands.ChangeItemCmd
MindFusion.Diagramming.Wpf.Commands.CompositeCmd
MindFusion.Diagramming.Wpf.Commands.EditTextCmd
MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd
MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd
MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd
MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd
MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd
MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd
MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd
MindFusion.Diagramming.Wpf.Commands.RedimTableCmd
MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd
MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd
MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd
MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd
MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd
MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd
MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd

See Also

Command Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command Members

Command Members
Constructors Properties Methods
[image]

Represent an action that can be carried out on a diagram, and later undone or redone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

Protected Properties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Command (
string title
)

Visual Basic [image] Copy Code

Protected New ( _
title As String _
)

Parameters

title

See Also

Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command Methods

Command Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.AddSubCmd Method

Command.AddSubCmd Method
[image]

Adds an action to a composite command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void AddSubCmd (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub AddSubCmd( _
cmd As Command _
)

Parameters

cmd

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Adopt Method

Command.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overridable Function Adopt( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Execute Method

Command.Execute Method
[image]

Carries out an action, usually changing the diagram in some way.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected abstract void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected MustOverride Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

Remarks

Implement your action's logic here. You must not execute commands by calling this method - instead pass them to diagram's ExecuteCommand. ExecuteCommand calls Execute and if UndoEnabled is set to true, adds the command to the undo manager's history.

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.IsContainerOf Method

Command.IsContainerOf Method
[image]

Determines whether a command has been initiated by this command and should be treated as a derivative.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual bool IsContainerOf (
Command command
)

Visual Basic [image] Copy Code

Protected Overridable Function IsContainerOf( _
command As Command _
) As Boolean

Parameters

command
The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void Redo ()

Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the diagram to the state it was in before carrying out the action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected virtual void Undo ()

Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command Properties

Command Properties
[image]

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

Protected Properties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

See Also

Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Context Property

Command.Context Property
[image]

Gets the command's context.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected CommandContext Context { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Context As CommandContext

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.SubCommands Property

Command.SubCommands Property
[image]

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected CommandCollection SubCommands { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.Command.Title Property

Command.Title Property
[image]

Gets or sets the text associated with the action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

Remarks

This text can be used to indicate to users what exactly will be undone or redone.

See Also

Command Members
Command Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Class

CommandCollection Class
[image]

A collection of commands.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CommandCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class CommandCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.Commands.CommandCollection

See Also

CommandCollection Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Members

CommandCollection Members
Constructors Properties Methods
[image]

A collection of commands.

The following tables list the members exposed by the CommandCollection type.

Public Constructors

Name | Description
CommandCollection | Overloaded.

Public Properties

Name | Description
Item | Gets or sets the command at the specified index.

Public Methods

Name | Description
Add | Adds the specified command to the collection.
Clear | Removes all commands from the collection.
Contains | Determines whether the specified command is contained in the collection.
GetAt | Returns the command at the specified index.
Remove | Removes the specified command from the collection.
RemoveRange | Removes the specified number of commands from the collection starting at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Constructor

CommandCollection Constructor
[image]

Overload List

Name | Description
CommandCollection () | Initializes a new instance of the CommandCollection class with the default initial capacity.
CommandCollection (Int32) | Initializes a new instance of the CommandCollection class with the specified initial capacity.

See Also

CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Constructor ()

CommandCollection Constructor ()
See Also
[image]

Initializes a new instance of the CommandCollection class with the default initial capacity.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CommandCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Constructor (Int32)

CommandCollection Constructor (Int32)
See Also
[image]

Initializes a new instance of the CommandCollection class with the specified initial capacity.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CommandCollection (
int capacity
)

Visual Basic [image] Copy Code

Public New ( _
capacity As Integer _
)

Parameters

capacity

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Methods

CommandCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified command to the collection.
Clear | Removes all commands from the collection.
Contains | Determines whether the specified command is contained in the collection.
GetAt | Returns the command at the specified index.
Remove | Removes the specified command from the collection.
RemoveRange | Removes the specified number of commands from the collection starting at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.Add Method

CommandCollection.Add Method
[image]

Adds the specified command to the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Add (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub Add( _
cmd As Command _
)

Parameters

cmd

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.Clear Method

CommandCollection.Clear Method
[image]

Removes all commands from the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.Contains Method

CommandCollection.Contains Method
[image]

Determines whether the specified command is contained in the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Command cmd
)

Visual Basic [image] Copy Code

Public Function Contains( _
cmd As Command _
) As Boolean

Parameters

cmd

Return Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.GetAt Method

CommandCollection.GetAt Method
[image]

Returns the command at the specified index.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command GetAt (
int i
)

Visual Basic [image] Copy Code

Public Function GetAt( _
i As Integer _
) As Command

Parameters

i

Return Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.Remove Method

CommandCollection.Remove Method
[image]

Removes the specified command from the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub Remove( _
cmd As Command _
)

Parameters

cmd

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.RemoveRange Method

CommandCollection.RemoveRange Method
[image]

Removes the specified number of commands from the collection starting at the specified index.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RemoveRange (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub RemoveRange( _
index As Integer, _
count As Integer _
)

Parameters

index

count

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection Properties

CommandCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the command at the specified index.

See Also

CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandCollection.Item Property

CommandCollection.Item Property
[image]

Gets or sets the command at the specified index.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Command

Parameters

index

Property Value

See Also

CommandCollection Members
CommandCollection Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandContext Class

CommandContext Class
[image]

The context of an executing command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CommandContext

Visual Basic [image] Copy Code

Public Class CommandContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.CommandContext

See Also

CommandContext Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandContext Members

CommandContext Members
Properties
[image]

The context of an executing command.

The following tables list the members exposed by the CommandContext type.

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandContext Properties

CommandContext Properties
[image]

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandContext.Document Property

CommandContext.Document Property
[image]

Gets the document this command will operate on.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Diagram Document { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Document As Diagram

Property Value

See Also

CommandContext Members
CommandContext Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList Class

CommandList Class
[image]

Represents a read-only collection of Command objects.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CommandList : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class CommandList
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.CommandList

See Also

CommandList Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList Members

CommandList Members
Constructors Properties Methods
[image]

Represents a read-only collection of Command objects.

The following tables list the members exposed by the CommandList type.

Public Constructors

Name | Description
CommandList | Initializes a new instance of the CommandList class.

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specfied command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList Constructor

CommandList Constructor
[image]

Initializes a new instance of the CommandList class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CommandList (
CommandCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As CommandCollection _
)

Parameters

innerCollection

See Also

CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList Methods

CommandList Methods
[image]

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specfied command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.Contains Method

CommandList.Contains Method
[image]

Determines whether the specified command is contained within the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Command value
)

Visual Basic [image] Copy Code

Public Function Contains( _
value As Command _
) As Boolean

Parameters

value

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.CopyTo Method

CommandList.CopyTo Method
[image]

Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

index

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.GetEnumerator Method

CommandList.GetEnumerator Method
[image]

Returns an enumerator for the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.IndexOf Method

CommandList.IndexOf Method
[image]

Returns the zero-based index of the specfied command within the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
Command value
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
value As Command _
) As Integer

Parameters

value

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList Properties

CommandList Properties
[image]

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.Count Property

CommandList.Count Property
[image]

Gets the number of commands contained within the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.IsSynchronized Property

CommandList.IsSynchronized Property
[image]

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.Item Property

CommandList.Item Property
[image]

Gets the command at the specified index.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Command Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As Command

Parameters

index

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CommandList.SyncRoot Property

CommandList.SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Class

CompositeCmd Class
Remarks See Also
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CompositeCmd : Command

Visual Basic [image] Copy Code

Public Class CompositeCmd
Inherits Command

Remarks

To add a subaction to the composite call the AddSubCmd method. The Execute method executes all subactions and adds the composite to undo manager's history.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.CompositeCmd

See Also

CompositeCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Members

CompositeCmd Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCmd type.

Public Constructors

Name | Description
CompositeCmd | Overloaded.

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Constructor

CompositeCmd Constructor
[image]

Overload List

Name | Description
CompositeCmd (Diagram, String) | Initializes a new instance of the CompositeCmd class.
CompositeCmd (Diagram, String, Boolean) | Initializes a new instance of the CompositeCmd class.

See Also

CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Constructor (Diagram, String)

CompositeCmd Constructor (Diagram, String)
See Also
[image]

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CompositeCmd (
Diagram diagram,
string title
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
title As String _
)

Parameters

diagram

title

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Constructor (Diagram, String, Boolean)

CompositeCmd Constructor (Diagram, String, Boolean)
See Also
[image]

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CompositeCmd (
Diagram diagram,
string title,
bool saveZOrder
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
title As String, _
saveZOrder As Boolean _
)

Parameters

diagram

title

saveZOrder

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Methods

CompositeCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.Execute Method

CompositeCmd.Execute Method
[image]

Overload List

Name | Description
CompositeCmd.Execute () | Executes the command, adding it to the command history.
CompositeCmd.Execute (Boolean) | Carries out the command action.

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.Execute Method ()

CompositeCmd.Execute Method ()
See Also
[image]

Executes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Execute ()

Visual Basic [image] Copy Code

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.Execute Method (Boolean)

CompositeCmd.Execute Method (Boolean)
See Also
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.Redo Method

CompositeCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.Undo Method

CompositeCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd Properties

CompositeCmd Properties
[image]

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)

See Also

CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.CompositeCmd.SubCommands Property

CompositeCmd.SubCommands Property
[image]

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new CommandCollection SubCommands { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd Class

EditTextCmd Class
Remarks See Also
[image]

Represents undoable edit operations.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class EditTextCmd : Command

Visual Basic [image] Copy Code

Public Class EditTextCmd
Inherits Command

Remarks

Instances of this class are created automatically by Diagram control when users edit the text of a DiagramItem.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.EditTextCmd

See Also

EditTextCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd Members

EditTextCmd Members
Constructors Properties Methods
[image]

Represents undoable edit operations.

The following tables list the members exposed by the EditTextCmd type.

Public Constructors

Name | Description
EditTextCmd | Initializes a new instance of the EditTextCmd class.

Public Properties

Name | Description
Item | Gets the diagram element changed by this command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd Constructor

EditTextCmd Constructor
[image]

Initializes a new instance of the EditTextCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public EditTextCmd (
InplaceEditable item,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
item As InplaceEditable, _
newText As String _
)

Parameters

item

The diagram element whose text will be changed.

newText

The new text.

See Also

EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd Methods

EditTextCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd.Execute Method

EditTextCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd.Redo Method

EditTextCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd.Undo Method

EditTextCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd Properties

EditTextCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the diagram element changed by this command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.EditTextCmd.Item Property

EditTextCmd.Item Property
[image]

Gets the diagram element changed by this command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public InplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As InplaceEditable

Property Value

See Also

EditTextCmd Members
EditTextCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd Class

ExpandHeaderRowCmd Class
Remarks See Also
[image]

Implements undo and redo of collapsing or expanding the header row of a table section.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ExpandHeaderRowCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandHeaderRowCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to expanding or collapsing Header rows, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd

See Also

ExpandHeaderRowCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd Members

ExpandHeaderRowCmd Members
Constructors Properties Methods
[image]

Implements undo and redo of collapsing or expanding the header row of a table section.

The following tables list the members exposed by the ExpandHeaderRowCmd type.

Public Constructors

Name | Description
ExpandHeaderRowCmd | Intializes a new instance of the ExpandHeaderRowCmd class.

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd Constructor

ExpandHeaderRowCmd Constructor
[image]

Intializes a new instance of the ExpandHeaderRowCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ExpandHeaderRowCmd (
TableNode tableNode,
int rowIndex
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
rowIndex As Integer _
)

Parameters

tableNode

rowIndex

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd Methods

ExpandHeaderRowCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd.Execute Method

ExpandHeaderRowCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd.Redo Method

ExpandHeaderRowCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd.Undo Method

ExpandHeaderRowCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd Properties

ExpandHeaderRowCmd Properties
[image]

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd.RowIndex Property

ExpandHeaderRowCmd.RowIndex Property
[image]

Gets the index of the header row whose section is expanded or collapsed.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RowIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowIndex As Integer

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandHeaderRowCmd.TableNode Property

ExpandHeaderRowCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd Class

ExpandItemCmd Class
Remarks See Also
[image]

Implements expanding/collapsing trees of items.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ExpandItemCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to expanding or collapsing trees of items, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd

See Also

ExpandItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd Members

ExpandItemCmd Members
Constructors Properties Methods
[image]

Implements expanding/collapsing trees of items.

The following tables list the members exposed by the ExpandItemCmd type.

Public Constructors

Name | Description
ExpandItemCmd | Initializes a new instance of the ExpandItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd Constructor

ExpandItemCmd Constructor
[image]

Initializes a new instance of the ExpandItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ExpandItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd Methods

ExpandItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd.Execute Method

ExpandItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd.Redo Method

ExpandItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd.Undo Method

ExpandItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd Properties

ExpandItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandItemCmd.Item Property

ExpandItemCmd.Item Property
[image]

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd Class

ExpandTreeViewItemCmd Class
[image]

Implements support for undo of TreeViewItem collapse/expand operations.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ExpandTreeViewItemCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandTreeViewItemCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd

See Also

ExpandTreeViewItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd Members

ExpandTreeViewItemCmd Members
Constructors Properties Methods
[image]

Implements support for undo of TreeViewItem collapse/expand operations.

The following tables list the members exposed by the ExpandTreeViewItemCmd type.

Public Constructors

Name | Description
ExpandTreeViewItemCmd | Initializes a new instance of the ExpandTreeViewItemCmd class.

Public Properties

Name | Description
Item | Gets the TreeViewItem that has been collapsed or expanded.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd Constructor

ExpandTreeViewItemCmd Constructor
[image]

Initializes a new instance of the ExpandTreeViewItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ExpandTreeViewItemCmd (
TreeViewNode node,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
item As TreeViewItem _
)

Parameters

node
The parent TreeViewNode.
item
The TreeViewItem that has been collapsed or expanded.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd Methods

ExpandTreeViewItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd.Execute Method

ExpandTreeViewItemCmd.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd.Redo Method

ExpandTreeViewItemCmd.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd.Undo Method

ExpandTreeViewItemCmd.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd Properties

ExpandTreeViewItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the TreeViewItem that has been collapsed or expanded.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ExpandTreeViewItemCmd.Item Property

ExpandTreeViewItemCmd.Item Property
[image]

Gets the TreeViewItem that has been collapsed or expanded.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

A TreeViewItem instance representing the collapsed item.

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd Class

FoldContainerCmd Class
[image]

Undoable command that implements scrolling of table rows.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FoldContainerCmd : Command

Visual Basic [image] Copy Code

Public Class FoldContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd

See Also

FoldContainerCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd Members

FoldContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements scrolling of table rows.

The following tables list the members exposed by the FoldContainerCmd type.

Public Constructors

Name | Description
FoldContainerCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
Container | Gets the table associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd Constructor

FoldContainerCmd Constructor
[image]

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FoldContainerCmd (
ContainerNode container
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode _
)

Parameters

container

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd Methods

FoldContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd.Execute Method

FoldContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd.Redo Method

FoldContainerCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd.Undo Method

FoldContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd Properties

FoldContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the table associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.FoldContainerCmd.Container Property

FoldContainerCmd.Container Property
[image]

Gets the table associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd Class

GroupAttachCmd Class
Remarks See Also
[image]

Implements an addition of a subordinated item to a group.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GroupAttachCmd : Command

Visual Basic [image] Copy Code

Public Class GroupAttachCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to calls to any of the Attach methods of the Group class. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd

See Also

GroupAttachCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd Members

GroupAttachCmd Members
Constructors Properties Methods
[image]

Implements an addition of a subordinated item to a group.

The following tables list the members exposed by the GroupAttachCmd type.

Protected Constructors

Name | Description
GroupAttachCmd | Intializes a new instance of the GroupAttachCmd class.

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets a reference to the subordinated item removed from the group by this command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd Constructor

GroupAttachCmd Constructor
[image]

Intializes a new instance of the GroupAttachCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected GroupAttachCmd (
Group group,
Group.Attachment attachment
)

Visual Basic [image] Copy Code

Protected New ( _
group As Group, _
attachment As Group.Attachment _
)

Parameters

group

attachment

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd Methods

GroupAttachCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd.Execute Method

GroupAttachCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd.Redo Method

GroupAttachCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd.Undo Method

GroupAttachCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd Properties

GroupAttachCmd Properties
[image]

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets a reference to the subordinated item removed from the group by this command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd.Group Property

GroupAttachCmd.Group Property
[image]

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupAttachCmd.Item Property

GroupAttachCmd.Item Property
[image]

Gets a reference to the subordinated item removed from the group by this command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

GroupAttachCmd Members
GroupAttachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd Class

GroupDetachCmd Class
Remarks See Also
[image]

Implements removal of an item from a group.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GroupDetachCmd : Command

Visual Basic [image] Copy Code

Public Class GroupDetachCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to calls to the Detach methods of the Group class. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd

See Also

GroupDetachCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd Members

GroupDetachCmd Members
Constructors Properties Methods
[image]

Implements removal of an item from a group.

The following tables list the members exposed by the GroupDetachCmd type.

Protected Constructors

Name | Description
GroupDetachCmd | Initializes a new instance of the GroupDetachCmd class.

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd Constructor

GroupDetachCmd Constructor
[image]

Initializes a new instance of the GroupDetachCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected GroupDetachCmd (
Group group,
Group.Attachment attachment
)

Visual Basic [image] Copy Code

Protected New ( _
group As Group, _
attachment As Group.Attachment _
)

Parameters

group

attachment

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd Methods

GroupDetachCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd.Execute Method

GroupDetachCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd.Redo Method

GroupDetachCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd.Undo Method

GroupDetachCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd Properties

GroupDetachCmd Properties
[image]

Public Properties

Name | Description
Group | Gets the group associated with the command.
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd.Group Property

GroupDetachCmd.Group Property
[image]

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.GroupDetachCmd.Item Property

GroupDetachCmd.Item Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

GroupDetachCmd Members
GroupDetachCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd Class

ModifyItemCmd Class
Remarks See Also
[image]

Implements changes of item's size and position.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ModifyItemCmd : Command

Visual Basic [image] Copy Code

Public Class ModifyItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to moving or resizing items, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd

See Also

ModifyItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd Members

ModifyItemCmd Members
Constructors Properties Methods
[image]

Implements changes of item's size and position.

The following tables list the members exposed by the ModifyItemCmd type.

Public Constructors

Name | Description
ModifyItemCmd | Initializes a new instance of the ModifyItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the modified item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd Constructor

ModifyItemCmd Constructor
[image]

Initializes a new instance of the ModifyItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ModifyItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd Methods

ModifyItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd.Adopt Method

ModifyItemCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd.Execute Method

ModifyItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd.Redo Method

ModifyItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd.Undo Method

ModifyItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd Properties

ModifyItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the modified item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ModifyItemCmd.Item Property

ModifyItemCmd.Item Property
[image]

Gets a reference to the modified item.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd Class

RedimTableCmd Class
Remarks See Also
[image]

Implements changes to the number of table's rows and coolumns.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RedimTableCmd : Command

Visual Basic [image] Copy Code

Public Class RedimTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to method calls and property changes that alter the number of table's rows or columns. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.RedimTableCmd

See Also

RedimTableCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd Members

RedimTableCmd Members
Constructors Properties Methods
[image]

Implements changes to the number of table's rows and coolumns.

The following tables list the members exposed by the RedimTableCmd type.

Public Constructors

Name | Description
RedimTableCmd | Initializes a new instance of the RedimTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd Constructor

RedimTableCmd Constructor
[image]

Initializes a new instance of the RedimTableCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RedimTableCmd (
TableNode tableNode,
string title
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
title As String _
)

Parameters

tableNode

title

See Also

RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd Methods

RedimTableCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd.Execute Method

RedimTableCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd.Redo Method

RedimTableCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd.Undo Method

RedimTableCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd Properties

RedimTableCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RedimTableCmd.TableNode Property

RedimTableCmd.TableNode Property
[image]

Gets a reference to the modified table.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd Class

RemoveFromContainerCmd Class
[image]

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RemoveFromContainerCmd : Command

Visual Basic [image] Copy Code

Public Class RemoveFromContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd

See Also

RemoveFromContainerCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd Members

RemoveFromContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the RemoveFromContainerCmd type.

Protected Constructors

Name | Description
RemoveFromContainerCmd | Intializes a new instance of the AddToContainerCmd class.

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd Constructor

RemoveFromContainerCmd Constructor
[image]

Intializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected RemoveFromContainerCmd (
ContainerNode container,
DiagramNode node,
bool interactive
)

Visual Basic [image] Copy Code

Protected New ( _
container As ContainerNode, _
node As DiagramNode, _
interactive As Boolean _
)

Parameters

container

node

interactive

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd Methods

RemoveFromContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Adopt Method

RemoveFromContainerCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command
The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Execute Method

RemoveFromContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Redo Method

RemoveFromContainerCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Undo Method

RemoveFromContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd Properties

RemoveFromContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Container Property

RemoveFromContainerCmd.Container Property
[image]

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveFromContainerCmd.Node Property

RemoveFromContainerCmd.Node Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd Class

RemoveGroupCmd Class
Remarks See Also
[image]

Implements destruction of groups.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RemoveGroupCmd : Command

Visual Basic [image] Copy Code

Public Class RemoveGroupCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to removing a group. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd

See Also

RemoveGroupCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd Members

RemoveGroupCmd Members
Constructors Properties Methods
[image]

Implements destruction of groups.

The following tables list the members exposed by the RemoveGroupCmd type.

Public Constructors

Name | Description
RemoveGroupCmd | Initializes a new instance of the RemoveGroupCmd class.

Public Properties

Name | Description
Group | Gets a reference to the removed Group object.
Item | Gets a reference to the main item of the group.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd Constructor

RemoveGroupCmd Constructor
[image]

Initializes a new instance of the RemoveGroupCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RemoveGroupCmd (
DiagramItem item,
Group group
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
group As Group _
)

Parameters

item

group

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to removing a group. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd Methods

RemoveGroupCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Execute Method

RemoveGroupCmd.Execute Method
[image]

Overload List

Name | Description
RemoveGroupCmd.Execute () | Executes the command.
RemoveGroupCmd.Execute (Boolean) | Carries out the command action.

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Execute Method ()

RemoveGroupCmd.Execute Method ()
See Also
[image]

Executes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Execute ()

Visual Basic [image] Copy Code

Public Sub Execute ()

See Also

Execute Method Overload List
RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Execute Method (Boolean)

RemoveGroupCmd.Execute Method (Boolean)
See Also
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

Execute Method Overload List
RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Redo Method

RemoveGroupCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Undo Method

RemoveGroupCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd Properties

RemoveGroupCmd Properties
[image]

Public Properties

Name | Description
Group | Gets a reference to the removed Group object.
Item | Gets a reference to the main item of the group.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Group Property

RemoveGroupCmd.Group Property
[image]

Gets a reference to the removed Group object.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveGroupCmd.Item Property

RemoveGroupCmd.Item Property
[image]

Gets a reference to the main item of the group.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

RemoveGroupCmd Members
RemoveGroupCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd Class

RemoveItemCmd Class
Remarks See Also
[image]

Implements deletion of diagram items.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class RemoveItemCmd : Command

Visual Basic [image] Copy Code

Public Class RemoveItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to deleting items interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd

See Also

RemoveItemCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd Members

RemoveItemCmd Members
Constructors Properties Methods
[image]

Implements deletion of diagram items.

The following tables list the members exposed by the RemoveItemCmd type.

Public Constructors

Name | Description
RemoveItemCmd | Initializes a new instance of the RemoveItemCmd class.

Public Properties

Name | Description
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd Constructor

RemoveItemCmd Constructor
[image]

Initializes a new instance of the RemoveItemCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public RemoveItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd Methods

RemoveItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd.Execute Method

RemoveItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd.Redo Method

RemoveItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd.Undo Method

RemoveItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd Properties

RemoveItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.RemoveItemCmd.Item Property

RemoveItemCmd.Item Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd Class

ResizeTableColumnCmd Class
Remarks See Also
[image]

Implements resizing of table's columns.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ResizeTableColumnCmd : Command

Visual Basic [image] Copy Code

Public Class ResizeTableColumnCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to resizing table's columns interactively. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd

See Also

ResizeTableColumnCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd Members

ResizeTableColumnCmd Members
Constructors Properties Methods
[image]

Implements resizing of table's columns.

The following tables list the members exposed by the ResizeTableColumnCmd type.

Public Constructors

Name | Description
ResizeTableColumnCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd Constructor

ResizeTableColumnCmd Constructor
[image]

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ResizeTableColumnCmd (
TableNode tableNode,
TableNode.Column column
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
column As TableNode.Column _
)

Parameters

tableNode

column

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd Methods

ResizeTableColumnCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd.Execute Method

ResizeTableColumnCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd.Redo Method

ResizeTableColumnCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd.Undo Method

ResizeTableColumnCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd Properties

ResizeTableColumnCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableColumnCmd.TableNode Property

ResizeTableColumnCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ResizeTableColumnCmd Members
ResizeTableColumnCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd Class

ResizeTableRowCmd Class
Remarks See Also
[image]

Implements resizing of table's rows.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ResizeTableRowCmd : Command

Visual Basic [image] Copy Code

Public Class ResizeTableRowCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming in response to resizing table's rows interactively. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd

See Also

ResizeTableRowCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd Members

ResizeTableRowCmd Members
Constructors Properties Methods
[image]

Implements resizing of table's rows.

The following tables list the members exposed by the ResizeTableRowCmd type.

Public Constructors

Name | Description
ResizeTableRowCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd Constructor

ResizeTableRowCmd Constructor
[image]

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ResizeTableRowCmd (
TableNode tableNode,
TableNode.Row row
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
row As TableNode.Row _
)

Parameters

tableNode

row

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd Methods

ResizeTableRowCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd.Execute Method

ResizeTableRowCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd.Redo Method

ResizeTableRowCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd.Undo Method

ResizeTableRowCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd Properties

ResizeTableRowCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ResizeTableRowCmd.TableNode Property

ResizeTableRowCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ResizeTableRowCmd Members
ResizeTableRowCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd Class

ScrollTableCmd Class
Remarks See Also
[image]

Implements scrolling of table's rows.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ScrollTableCmd : Command

Visual Basic [image] Copy Code

Public Class ScrollTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for WPF in response to scrolling table's rows, either interactively or programmatically. References to those instances are passed to handlers of the ActionRecorded, ActionUndone and ActionRedone events.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd

See Also

ScrollTableCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd Members

ScrollTableCmd Members
Constructors Properties Methods
[image]

Implements scrolling of table's rows.

The following tables list the members exposed by the ScrollTableCmd type.

Public Constructors

Name | Description
ScrollTableCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd Constructor

ScrollTableCmd Constructor
[image]

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScrollTableCmd (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd Methods

ScrollTableCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd.Execute Method

ScrollTableCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd.Redo Method

ScrollTableCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd.Undo Method

ScrollTableCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd Properties

ScrollTableCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTableCmd.TableNode Property

ScrollTableCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd Class

ScrollTreeViewCmd Class
[image]

Implements support for undo of TreeViewNode scroll operations.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ScrollTreeViewCmd : Command

Visual Basic [image] Copy Code

Public Class ScrollTreeViewCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Commands.Command
MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd

See Also

ScrollTreeViewCmd Members
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd Members

ScrollTreeViewCmd Members
Constructors Properties Methods
[image]

Implements support for undo of TreeViewNode scroll operations.

The following tables list the members exposed by the ScrollTreeViewCmd type.

Public Constructors

Name | Description
ScrollTreeViewCmd | Initializes a new instance of the ScrollTreeViewCmd class.

Public Properties

Name | Description
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets a reference to the TreeViewNode affected by this operation.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd Constructor

ScrollTreeViewCmd Constructor
[image]

Initializes a new instance of the ScrollTreeViewCmd class.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ScrollTreeViewCmd (
TreeViewNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode _
)

Parameters

node
The related TreeViewNode.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd Methods

ScrollTreeViewCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd.Execute Method

ScrollTreeViewCmd.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd.Redo Method

ScrollTreeViewCmd.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd.Undo Method

ScrollTreeViewCmd.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd Properties

ScrollTreeViewCmd Properties
[image]

Public Properties

Name | Description
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets a reference to the TreeViewNode affected by this operation.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Commands.ScrollTreeViewCmd.TreeViewNode Property

ScrollTreeViewCmd.TreeViewNode Property
[image]

Gets a reference to the TreeViewNode affected by this operation.

Namespace: MindFusion.Diagramming.Wpf.Commands
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeViewNode TreeViewNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TreeViewNode As TreeViewNode

Property Value

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Wpf.Commands Namespace


MindFusion.Diagramming.Wpf.Export Namespace

MindFusion.Diagramming.Wpf.Export Namespace
Classes Enumerations

Classes

Class | Description
ExcelExporter | Exports MindFusion.Diagramming diagrams to Excel Open XML Format (XLSX) files.
PdfExporter | Exports diagrams to Adobe Portable Document Format (PDF) files.
SvgExporter | Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.
Visio2013Exporter | Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).
VisioExporter | Exports diagrams to Visio 2003 XML Drawing files (*.vdx).
WmfExporter | Creates WMF (Windows MetaFile) images from the content of Diagram objects.

Enumerations

Enumeration | Description
AutoScale | Specifies the auto-scale mode when exporting to a PDF document.
ExportLanes | Defines values that indicate how the LaneGrid should be exported to Visio.


MindFusion.Diagramming.Wpf.Export.AutoScale Enumeration

AutoScale Enumeration
[image]

Specifies the auto-scale mode when exporting to a PDF document.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public enum AutoScale

Visual Basic [image] Copy Code

Public Enum AutoScale

Members

Member name | Description
FitToPage | Scales the chart (aspect ratio is preserved) to fit the page bounds if the document is too large.
FitToPageNoUpScale | Scales down the chart (aspect ratio is preserved) to fit the page bounds if the document is too large. Otherwise chart's size is left untouched.
FitToWidth | Scales down the chart (aspect ratio is preserved) to make sure that the width of the chart is less than the width of the PDF page.
None | No automatic scaling.

See Also

MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter Class

ExcelExporter Class
Remarks See Also
[image]

Exports MindFusion.Diagramming diagrams to Excel Open XML Format (XLSX) files.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public class ExcelExporter

Visual Basic [image] Copy Code

Public Class ExcelExporter

Remarks

Diagrams are exported as Excel AutoShapes drawings. The Export overload that takes a DiagramDocument parameter creates a sheet for each DiagramPage in the document.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.ExcelExporter

See Also

ExcelExporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter Members

ExcelExporter Members
Constructors Methods
[image]

Exports MindFusion.Diagramming diagrams to Excel Open XML Format (XLSX) files.

The following tables list the members exposed by the ExcelExporter type.

Public Constructors

Name | Description
ExcelExporter | Initializes a new instance of the ExcelExporter class.

Public Methods

Name | Description
Export | Overloaded.

See Also

ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter Constructor

ExcelExporter Constructor
[image]

Initializes a new instance of the ExcelExporter class.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public ExcelExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter Methods

ExcelExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter.Export Method

ExcelExporter.Export Method
[image]

Overload List

Name | Description
ExcelExporter.Export (Diagram, String) | Creates an XLSX file representing the specified diagram.
ExcelExporter.Export (DiagramDocument, String) | Creates an XLSX file representing the specified DiagramDocument.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter.Export Method (Diagram, String)

ExcelExporter.Export Method (Diagram, String)
See Also
[image]

Creates an XLSX file representing the specified diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the Diagram that will be exported.

filePath

The full path to the XLSX file.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExcelExporter.Export Method (DiagramDocument, String)

ExcelExporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates an XLSX file representing the specified DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument document,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
document As DiagramDocument, _
filePath As String _
)

Parameters

document

A reference to the DiagramDocument that will be exported.

filePath

The full path to the XLSX file.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.ExportLanes Enumeration

ExportLanes Enumeration
[image]

Defines values that indicate how the LaneGrid should be exported to Visio.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public enum ExportLanes

Visual Basic [image] Copy Code

Public Enum ExportLanes

Members

Member name | Description
Horizontal | Export the grid as horizontal functional band shapes.
None | Do not export the swimlane grid.
Vertical | Export the grid as vertical functional band shapes.

See Also

MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter Class

PdfExporter Class
Remarks See Also
[image]

Exports diagrams to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public class PdfExporter

Visual Basic [image] Copy Code

Public Class PdfExporter

Remarks

In order to use this component, add references to the PdfExport.dll, MindFusion.Pdf.dll and MindFusion.Common.dll assemblies to your project.

The Adobe Portable Document Format (PDF) is the most popular open format for representing textual and graphic information in resolution independent manner. In addition, PDF is a multiplatform format, viewable and printable on all popular operating systems. These features, along with its ability to describe complex documents that use a variety of graphics, images and fonts, make PDF a good choice when it comes to distributing your flowcharts and diagrams to others.

The PdfExporter class lets you create PDF files that represent MindFusion.Diagramming for WPF diagrams. In order to do that, create a PdfExporter instance and call its Export method. If you need to set the page size and orientation, use the PageSize, and PageOrientation properties. Margins specifies the page margins for all pages in the document. The AutoScale property lets you scale the diagram so it fits in one or more PDF pages.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods
[image]

Exports diagrams to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter |

Public Properties

Name | Description
AutoDetectEncoding | Specifies whether character encoding should be detected automatically.
AutoOrientation | Specifies whether the exporter should choose the PDF page orientation automatically.
AutoScale | Specifies whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies what encoding to use if the encoding for a string cannot be recognized automatically.
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated PDF.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exporter.
JpegImageEncoding | Specifies whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Specifies the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

Public Methods

Name | Description
Export | Overloaded.

See Also

PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter Constructor

PdfExporter Constructor
[image]

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PdfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter Methods

PdfExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.Export Method

PdfExporter.Export Method
[image]

Overload List

Name | Description
PdfExporter.Export (Diagram, String) | Creates a PDF file representing the specified MindFusion.Diagramming diagram.
PdfExporter.Export (DiagramDocument, String) | Creates a PDF file representing the specified DiagramDocument.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.Export Method (Diagram, String)

PdfExporter.Export Method (Diagram, String)
See Also
[image]

Creates a PDF file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath

The full path to the PDF file.

See Also

Export Method Overload List
PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.Export Method (DiagramDocument, String)

PdfExporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a PDF file representing the specified DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument diagramDoc,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagramDoc As DiagramDocument, _
filePath As String _
)

Parameters

diagramDoc

A reference to the DiagramDocument that will be exported.

filePath

The full path to the PDF file.

Remarks

If PdfExporter.Size is set to DiagramSize, the number of pages in the output PDF is equal to DiagramDocument.Pages.Count and each PDF page is as large as the respective DiagramPage.Bounds. Otherwise, all diagram pages are paginated using the specified PDF page size (A4 etc).

See Also

Export Method Overload List
PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter Properties

PdfExporter Properties
[image]

Public Properties

Name | Description
AutoDetectEncoding | Specifies whether character encoding should be detected automatically.
AutoOrientation | Specifies whether the exporter should choose the PDF page orientation automatically.
AutoScale | Specifies whether the diagram should be scaled to fit one or more pages of the PDF document.
DefaultEncoding | Specifies what encoding to use if the encoding for a string cannot be recognized automatically.
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated PDF.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exporter.
JpegImageEncoding | Specifies whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Specifies the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

See Also

PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.AutoDetectEncoding Property

PdfExporter.AutoDetectEncoding Property
[image]

Specifies whether character encoding should be detected automatically.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool AutoDetectEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property AutoDetectEncoding As Boolean

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.AutoOrientation Property

PdfExporter.AutoOrientation Property
[image]

Specifies whether the exporter should choose the PDF page orientation automatically.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool AutoOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property AutoOrientation As Boolean

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.AutoScale Property

PdfExporter.AutoScale Property
[image]

Specifies whether the diagram should be scaled to fit one or more pages of the PDF document.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public AutoScale AutoScale { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScale As AutoScale

Property Value

A member of the AutoScale enumeration. The default is None.

Remarks

By default, the original scale of the diagram is preserved and the diagram is divided into multiple pages if needed. This property lets you scale the diagram so that it exactly fits in one or more pages.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.DefaultEncoding Property

PdfExporter.DefaultEncoding Property
[image]

Specifies what encoding to use if the encoding for a string cannot be recognized automatically.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Encoding DefaultEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultEncoding As Encoding

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.DrawingBrushReplacement Property

PdfExporter.DrawingBrushReplacement Property
[image]

Specifies a hatch fill that should replace DrawingBrush instances in generated PDF.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Nullable<HatchStyle> DrawingBrushReplacement { get; set; }

Visual Basic [image] Copy Code

Public Property DrawingBrushReplacement As Nullable(Of HatchStyle)

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.InvisibleItems Property

PdfExporter.InvisibleItems Property
[image]

Gets or sets a value indicating whether invisible items should be exporter.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool InvisibleItems { get; set; }

Visual Basic [image] Copy Code

Public Property InvisibleItems As Boolean

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.JpegImageEncoding Property

PdfExporter.JpegImageEncoding Property
[image]

Specifies whether images embedded in PDF should be encoded in Jpeg format.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool JpegImageEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageEncoding As Boolean

Property Value

true to encode images in Jpeg format; otherwise false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.JpegImageQuality Property

PdfExporter.JpegImageQuality Property
[image]

Specifies the image quality of Jpeg images.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public int JpegImageQuality { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageQuality As Integer

Property Value

An integer specifying the image quality. The default value is 100.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.Margins Property

PdfExporter.Margins Property
[image]

Gets or sets the margins for the PDF pages.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

An instance of the System.Windows.Thickness structure. The default is half-inch margins.

Remarks

The values set for the Margins members are interpreted as WPF point units, where a point is 1/96 inch.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property
[image]

Gets or sets page orientation that is set to the resulting PDF pages.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property
[image]

Gets or sets PDF page size.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PageSize PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As PageSize

Property Value

A member of the PageSize enumeration. The default is A4.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.PdfExporter.Scale Property

PdfExporter.Scale Property
[image]

Gets or sets the scale of the PDF output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.PdfExport

Syntax

C# [image] Copy Code

public float Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Single

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter Class

SvgExporter Class
Remarks See Also
[image]

Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public class SvgExporter

Visual Basic [image] Copy Code

Public Class SvgExporter

Remarks

In order to use this component, add references to the MindFusion.Diagramming.Wpf.SvgExport and MindFusion.Svg.dll assemblies to your project.

Scalable Vector Graphics is an XML-based graphics language that describes images with vector shapes, text, and embedded raster graphics. Most browsers have native support for displaying SVG drawings, and the Adobe SVG Viewer browser plug-in can be installed to add SVG support to Internet Explorer. The most popular vector graphics editing applications provide support for SVG too.

In order to create an SVG file from a diagram, create an SvgExporter instance and call its Export method, passing a Diagram object as parameter.

The exporter enumerates all graphics primitives contained in the WPF visual tree and creates corresponding SVG elements. This enables custom graphics and hosted controls to be rendered in SVG too

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.SvgExporter

See Also

SvgExporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter Members

SvgExporter Members
Constructors Properties Methods
[image]

Creates SVG (Scalable Vector Graphics) drawings from the content of Diagram objects.

The following tables list the members exposed by the SvgExporter type.

Public Constructors

Name | Description
SvgExporter | Initializes a new instance of the SvgExporter class.

Public Properties

Name | Description
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated image.
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
GZipCompression | Specifies whether to create GZip compressed SVG.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.

Public Methods

Name | Description
Export | Creates an SVG file representing the specified diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter Constructor

SvgExporter Constructor
[image]

Initializes a new instance of the SvgExporter class.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public SvgExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter Methods

SvgExporter Methods
[image]

Public Methods

Name | Description
Export | Creates an SVG file representing the specified diagram.

See Also

SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter.Export Method

SvgExporter.Export Method
[image]

Creates an SVG file representing the specified diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath

The full path to the SVG file.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter Properties

SvgExporter Properties
[image]

Public Properties

Name | Description
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated image.
ExternalImages | Specifies whether images displayed by diagram items should be exported to external files.
GZipCompression | Specifies whether to create GZip compressed SVG.
InvisibleItems | Gets or sets a value indicating whether invisible items should be exported.

See Also

SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter.DrawingBrushReplacement Property

SvgExporter.DrawingBrushReplacement Property
[image]

Specifies a hatch fill that should replace DrawingBrush instances in generated image.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public Nullable<HatchStyle> DrawingBrushReplacement { get; set; }

Visual Basic [image] Copy Code

Public Property DrawingBrushReplacement As Nullable(Of HatchStyle)

Property Value

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter.ExternalImages Property

SvgExporter.ExternalImages Property
[image]

Specifies whether images displayed by diagram items should be exported to external files.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public bool ExternalImages { get; set; }

Visual Basic [image] Copy Code

Public Property ExternalImages As Boolean

Property Value

true to export images to external files; false to keep them as inline binary data in the SVG file. The default is false.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter.GZipCompression Property

SvgExporter.GZipCompression Property
[image]

Specifies whether to create GZip compressed SVG.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public bool GZipCompression { get; set; }

Visual Basic [image] Copy Code

Public Property GZipCompression As Boolean

Property Value

true to compress the SVG file; otherwise, false. The default value is false.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.SvgExporter.InvisibleItems Property

SvgExporter.InvisibleItems Property
[image]

Gets or sets a value indicating whether invisible items should be exported.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.SvgExport

Syntax

C# [image] Copy Code

public bool InvisibleItems { get; set; }

Visual Basic [image] Copy Code

Public Property InvisibleItems As Boolean

Property Value

true to render invisible items in the SVG drawing, otherwise false. The default value is false.

See Also

SvgExporter Members
SvgExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter Class

Visio2013Exporter Class
Remarks See Also
[image]

Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public class Visio2013Exporter

Visual Basic [image] Copy Code

Public Class Visio2013Exporter

Remarks

Add a reference to the MindFusion.Diagramming.Wpf.VisioExport.dll to your project in order to use this component.

The component allows exporting Visio 2013 XML Drawing files from WpfDiagram. ShapeNode objects are mapped to their closest Visio counterparts and DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

To function properly, the exporter object requires the Visio2013.vxt file to be present in the application's directory, or its location specified in TemplatePath. This file contains an XML template data used by the component to generate Visio documents.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.Visio2013Exporter

See Also

Visio2013Exporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter Members

Visio2013Exporter Members
Constructors Properties Methods
[image]

Exports the contents of Diagram or DiagramDocument objects to Visio 2013 XML drawing files (*.vsdx).

The following tables list the members exposed by the Visio2013Exporter type.

Public Constructors

Name | Description
Visio2013Exporter | Initializes a new instance of the Visio2013Exporter class.

Public Properties

Name | Description
TemplatePath | Gets or sets the full path to the 'Visio2013.vxt' template file.

Public Methods

Name | Description
Export | Overloaded.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter Constructor

Visio2013Exporter Constructor
[image]

Initializes a new instance of the Visio2013Exporter class.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public Visio2013Exporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter Methods

Visio2013Exporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter.Export Method

Visio2013Exporter.Export Method
[image]

Overload List

Name | Description
Visio2013Exporter.Export (Diagram, String) | Creates a Visio .vsdx file representing the specified Diagram.
Visio2013Exporter.Export (DiagramDocument, String) | Creates a Visio .vsdx file representing the specified DiagramDocument.

See Also

Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter.Export Method (Diagram, String)

Visio2013Exporter.Export Method (Diagram, String)
See Also
[image]

Creates a Visio .vsdx file representing the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A Diagram instance.

filePath

The full path to the exported Visio .vsdx file.

Remarks

The exported document contains a single page, as big as the scrollable diagram area set in Bounds.

To run properly, this method requires the Visio2013.vxt file to be present in the application's directory, or its full path to be assigned to TemplatePath. That file contains an XML template data used by the component to construct Visio documents.

See Also

Export Method Overload List
Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter.Export Method (DiagramDocument, String)

Visio2013Exporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a Visio .vsdx file representing the specified DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument doc,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
doc As DiagramDocument, _
filePath As String _
)

Parameters

doc

A DiagramDocument instance.

filePath

The full path to the exported Visio .vsdx file.

Remarks

Each DiagramPage in the document is exported to an individual Visio page. The title of the Visio page is set to DiagramPage.Title.

See Also

Export Method Overload List
Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter Properties

Visio2013Exporter Properties
[image]

Public Properties

Name | Description
TemplatePath | Gets or sets the full path to the 'Visio2013.vxt' template file.

See Also

Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.Visio2013Exporter.TemplatePath Property

Visio2013Exporter.TemplatePath Property
[image]

Gets or sets the full path to the 'Visio2013.vxt' template file.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public string TemplatePath { get; set; }

Visual Basic [image] Copy Code

Public Property TemplatePath As String

Property Value

A string specifying the template file location.

See Also

Visio2013Exporter Members
Visio2013Exporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter Class

VisioExporter Class
Remarks See Also
[image]

Exports diagrams to Visio 2003 XML Drawing files (*.vdx).

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public class VisioExporter

Visual Basic [image] Copy Code

Public Class VisioExporter

Remarks

Add a reference to the MindFusion.Diagramming.Wpf.VisioExport.dll to your project in order to use this component.

The component allows exporting Visio 2003 XML Drawing files from WpfDiagram. ShapeNode objects are mapped to their closest Visio counterparts and TableNode objects are exported as groups of Visio shapes. DiagramLink instances are exported as Visio connectors of a similar style. In addition, most of the attributes of diagram items such as text, text formatting, fill and line colors and styles are preserved.

To function properly, VisioExporter requires the VisioExport.vxt file to be present in the application's directory. This file contains an XML template used by the component to generate Visio documents. The template file can be optionally located in a different folder, as long as the TemplatePath property is set to the correct file path.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.VisioExporter

See Also

VisioExporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter Members

VisioExporter Members
Constructors Properties Methods
[image]

Exports diagrams to Visio 2003 XML Drawing files (*.vdx).

The following tables list the members exposed by the VisioExporter type.

Public Constructors

Name | Description
VisioExporter | Initializes a new instance of the VisioExporter class.

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from WpfDiagram groups.
DynamicsOff | Gets or sets whether Visio connector rerouting should be disabled.
ExportImagesAsGroups | Gets or sets a value indicating whether a node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportLanes | Gets or sets a value specifying whether the LaneGrid should be exported to Visio.
ExportTablesAsGroups | Gets or sets a value indicating whether TableNode objects should be exported as groups of Visio rectangular shapes.
LaneGridTitle | Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.
TemplatePath | Gets or sets the full path to the 'VisioExport.vxt' template file.

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Overloaded.

See Also

VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter Constructor

VisioExporter Constructor
[image]

Initializes a new instance of the VisioExporter class.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public VisioExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter Methods

VisioExporter Methods
[image]

Public Methods

Name | Description
ApproxColors | Approximate two color of gradient to get corresponded ACI.
Export | Overloaded.

See Also

VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.ApproxColors Method

VisioExporter.ApproxColors Method
[image]

Approximate two color of gradient to get corresponded ACI.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public static Color ApproxColors (
Color cr1,
Color cr2
)

Visual Basic [image] Copy Code

Public Shared Function ApproxColors( _
cr1 As Color, _
cr2 As Color _
) As Color

Parameters

cr1

Color 1 of gradient

cr2

Color 2 of gradient

Return Value

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.Export Method

VisioExporter.Export Method
[image]

Overload List

Name | Description
VisioExporter.Export (Diagram, String) | Creates a Visio XML Drawing file representing the specified MindFusion.Diagramming diagram.
VisioExporter.Export (DiagramDocument, String) | Creates a Visio XML Drawing file representing the specified DiagramDocument object.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.Export Method (Diagram, String)

VisioExporter.Export Method (Diagram, String)
See Also
[image]

Creates a Visio XML Drawing file representing the specified MindFusion.Diagramming diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string vdxPathName
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
vdxPathName As String _
)

Parameters

diagram

A reference to the diagram to be exported.

vdxPathName

Full path to the exported Visio .vdx file.

Remarks

The exported document contains a single page, as big as the diagram area. The Visio page dimension and items size measure unit is set to the diagram's MeasureUnit.

To run properly, this method requires the VisioExport.vxt file to be present in the application's directory. That file contains an XML template used by the component to construct Visio documents.

See Also

Export Method Overload List
VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.Export Method (DiagramDocument, String)

VisioExporter.Export Method (DiagramDocument, String)
See Also
[image]

Creates a Visio XML Drawing file representing the specified DiagramDocument object.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public void Export (
DiagramDocument diagramDoc,
string vdxPathName
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagramDoc As DiagramDocument, _
vdxPathName As String _
)

Parameters

diagramDoc

A reference to the document to be exported.

vdxPathName

Full path to the exported Visio .vdx file.

Remarks

Each DiagramPage in the document is exported to an individual Visio page. The title of the Visio page is set to DiagramPage.Title.

See Also

Export Method Overload List
VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter Properties

VisioExporter Properties
[image]

Public Properties

Name | Description
CreateVisioGroups | Gets or sets a value indicating whether Visio groups are created from WpfDiagram groups.
DynamicsOff | Gets or sets whether Visio connector rerouting should be disabled.
ExportImagesAsGroups | Gets or sets a value indicating whether a node that contains an image should be exported as a Visio group of a shape, picture and text objects.
ExportInvisibleItems | Gets or sets a value indicating whether to export invisible items.
ExportLanes | Gets or sets a value specifying whether the LaneGrid should be exported to Visio.
ExportTablesAsGroups | Gets or sets a value indicating whether TableNode objects should be exported as groups of Visio rectangular shapes.
LaneGridTitle | Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.
TemplatePath | Gets or sets the full path to the 'VisioExport.vxt' template file.

See Also

VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.CreateVisioGroups Property

VisioExporter.CreateVisioGroups Property
[image]

Gets or sets a value indicating whether Visio groups are created from WpfDiagram groups.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public bool CreateVisioGroups { get; set; }

Visual Basic [image] Copy Code

Public Property CreateVisioGroups As Boolean

Property Value

true to create Visio groups when possible; otherwise, false. The default is false.

Remarks

It is not always possible to create a Visio group corresponding to a WpfDiagram one. If the structure of your diagram seems incorrect when imported in Visio, disable this property.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.DynamicsOff Property

VisioExporter.DynamicsOff Property
[image]

Gets or sets whether Visio connector rerouting should be disabled.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public bool DynamicsOff { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicsOff As Boolean

Property Value

true to add a DynamicsOff element to the XML markup exported for a connector; otherwise false.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.ExportImagesAsGroups Property

VisioExporter.ExportImagesAsGroups Property
[image]

Gets or sets a value indicating whether a node that contains an image should be exported as a Visio group of a shape, picture and text objects.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public bool ExportImagesAsGroups { get; set; }

Visual Basic [image] Copy Code

Public Property ExportImagesAsGroups As Boolean

Property Value

true to export nodes with images as groups; otherwise, false. The default is true.

Remarks

Visio shapes cannot contain images inside them, and by default a shape node that contains an image s exported as a Visio Picture object. Unfortunately, that leads to losing the node shape and the image alignment. Setting this property to true lets you export a shape node with an image as a group of several Visio objects that will preserve the appearance of the original node as closely as possible.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.ExportInvisibleItems Property

VisioExporter.ExportInvisibleItems Property
[image]

Gets or sets a value indicating whether to export invisible items.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public bool ExportInvisibleItems { get; set; }

Visual Basic [image] Copy Code

Public Property ExportInvisibleItems As Boolean

Property Value

true to export invisible items; otherwise, false.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.ExportLanes Property

VisioExporter.ExportLanes Property
[image]

Gets or sets a value specifying whether the LaneGrid should be exported to Visio.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public ExportLanes ExportLanes { get; set; }

Visual Basic [image] Copy Code

Public Property ExportLanes As ExportLanes

Property Value

A member of the ExportLanes enumeration. The default value is None.

Remarks

If export of swimlanes is enabled, they are exported as Visio Functional Band shapes.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace
LaneGridTitle Property


MindFusion.Diagramming.Wpf.Export.VisioExporter.ExportTablesAsGroups Property

VisioExporter.ExportTablesAsGroups Property
[image]

Gets or sets a value indicating whether TableNode objects should be exported as groups of Visio rectangular shapes.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public bool ExportTablesAsGroups { get; set; }

Visual Basic [image] Copy Code

Public Property ExportTablesAsGroups As Boolean

Property Value

Visio table entities cannot display cells in multiple columns. If your diagrams contain tables having more than two columns, consider enabling this property. Then VisioExporter would create a rectangular shape for each cell, and group the cells of each table into a Visio compound shape corresponding to the table.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.LaneGridTitle Property

VisioExporter.LaneGridTitle Property
[image]

Gets or sets the title of the functional band container created when exporting the diagram's swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public string LaneGridTitle { get; set; }

Visual Basic [image] Copy Code

Public Property LaneGridTitle As String

Property Value

A string specifying the title of the Functional Band container shape. The default value is empty string.

Remarks

When ExportLanes is enabled, VisioExporter create a Functional Band shape for each swimlane and a container shape for the whole grid. This property specifies the container's title.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.VisioExporter.TemplatePath Property

VisioExporter.TemplatePath Property
[image]

Gets or sets the full path to the 'VisioExport.vxt' template file.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.VisioExport

Syntax

C# [image] Copy Code

public string TemplatePath { get; set; }

Visual Basic [image] Copy Code

Public Property TemplatePath As String

Property Value

A string specifying the location of the template file. The default is an empty string.

Remarks

If you do not specify the path to the template file, VisioExporter looks for the file in the same folder where the MindFusion.Diagramming.Wpf.VisioExport.dll assembly is located, in the folder of the application executable file, and in the current folder. However that might not work under restricted security permissions, for example when running inside a browser or under the IIS process.

See Also

VisioExporter Members
VisioExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter Class

WmfExporter Class
Remarks See Also
[image]

Creates WMF (Windows MetaFile) images from the content of Diagram objects.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.WmfExport

Syntax

C# [image] Copy Code

public class WmfExporter

Visual Basic [image] Copy Code

Public Class WmfExporter

Remarks

In order to use this component, add a reference to the MindFusion.Diagramming.Wpf.WmfExport assembly to your project. To create a WMF file from a diagram, create a WmfExporter instance and call its Export method, passing a Diagram object as parameter.

The exporter enumerates all graphics primitives contained in the WPF visual tree and creates corresponding WMF records. This enables custom graphics and hosted controls to be rendered in WMF too.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Export.WmfExporter

See Also

WmfExporter Members
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter Members

WmfExporter Members
Constructors Properties Methods
[image]

Creates WMF (Windows MetaFile) images from the content of Diagram objects.

The following tables list the members exposed by the WmfExporter type.

Public Constructors

Name | Description
WmfExporter | Initializes a new instance of the WmfExporter class.

Public Properties

Name | Description
Description | Gets or sets a description string associated with the metafile.
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated image.

Public Methods

Name | Description
Export | Creates a WMF file representing the specified diagram.

See Also

WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter Constructor

WmfExporter Constructor
[image]

Initializes a new instance of the WmfExporter class.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.WmfExport

Syntax

C# [image] Copy Code

public WmfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter Methods

WmfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a WMF file representing the specified diagram.

See Also

WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter.Export Method

WmfExporter.Export Method
[image]

Creates a WMF file representing the specified diagram.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.WmfExport

Syntax

C# [image] Copy Code

public void Export (
Diagram diagram,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
diagram As Diagram, _
filePath As String _
)

Parameters

diagram

A reference to the diagram that will be exported.

filePath
The full path to the WMF file.

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter Properties

WmfExporter Properties
[image]

Public Properties

Name | Description
Description | Gets or sets a description string associated with the metafile.
DrawingBrushReplacement | Specifies a hatch fill that should replace DrawingBrush instances in generated image.

See Also

WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter.Description Property

WmfExporter.Description Property
[image]

Gets or sets a description string associated with the metafile.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.WmfExport

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string specifying the metafile description. The default is an empty string.

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Export.WmfExporter.DrawingBrushReplacement Property

WmfExporter.DrawingBrushReplacement Property
[image]

Specifies a hatch fill that should replace DrawingBrush instances in generated image.

Namespace: MindFusion.Diagramming.Wpf.Export
Assembly: MindFusion.Diagramming.Wpf.WmfExport

Syntax

C# [image] Copy Code

public Nullable<HatchStyle> DrawingBrushReplacement { get; set; }

Visual Basic [image] Copy Code

Public Property DrawingBrushReplacement As Nullable(Of HatchStyle)

Property Value

See Also

WmfExporter Members
WmfExporter Class
MindFusion.Diagramming.Wpf.Export Namespace


MindFusion.Diagramming.Wpf.Lanes Namespace

MindFusion.Diagramming.Wpf.Lanes Namespace
Classes Interfaces Enumerations

Classes

Class | Description
CellBoundsEventArgs | Contains the arguments passed to handlers of the CellBoundsChanged event.
DrawHeaderEventArgs | Contains the arguments passed to the handlers of the DrawLaneHeader event.
EditHeaderTextEventArgs | Contains the arguments passed to the LaneGridHeaderTextEdited event handlers.
Grid | Represents a lane grid.
Header | Represents a header in a grid view.
HeaderCollection | Represents a strongly typed collection of Header objects.
HeaderEventArgs | Contains the arguments passed to handlers of header-related events.
HeaderValidationEventArgs | Contains the arguments passed to event handlers, such as LaneGridHeaderTextEditing.
Style | Encapsulates the appearance properties of an element in a lane grid.

Interfaces

Interface | Description
ICell | Defines a base for cells in a lane list.

Enumerations

Enumeration | Description
ResizeType | Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs Class

CellBoundsEventArgs Class
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CellBoundsEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellBoundsEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs

See Also

CellBoundsEventArgs Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs Members

CellBoundsEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

The following tables list the members exposed by the CellBoundsEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs Properties

CellBoundsEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs.Cell Property

CellBoundsEventArgs.Cell Property
[image]

Gets the cell which has been resized.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ICell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As ICell

Property Value

An instance of a class implementing the ICell interface that represents the cell that has been resized.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs.NewBounds Property

CellBoundsEventArgs.NewBounds Property
[image]

Gets the new bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect NewBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewBounds As Rect

Property Value

A WPF Rect object specifying the new bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.CellBoundsEventArgs.OldBounds Property

CellBoundsEventArgs.OldBounds Property
[image]

Gets the old bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect OldBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldBounds As Rect

Property Value

A WPF Rect object specifying the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs Class

DrawHeaderEventArgs Class
[image]

Contains the arguments passed to the handlers of the DrawLaneHeader event.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DrawHeaderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawHeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs

See Also

DrawHeaderEventArgs Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs Members

DrawHeaderEventArgs Members
Properties
[image]

Contains the arguments passed to the handlers of the DrawLaneHeader event.

The following tables list the members exposed by the DrawHeaderEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the header being drawn.
Header | Gets a reference to the header being drawn.
Target | Gets a DrawingContext object whose methods should be used to draw the header.

See Also

DrawHeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs Properties

DrawHeaderEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the header being drawn.
Header | Gets a reference to the header being drawn.
Target | Gets a DrawingContext object whose methods should be used to draw the header.

See Also

DrawHeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs.Bounds Property

DrawHeaderEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the header being drawn.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rect specifying the header position and size.

See Also

DrawHeaderEventArgs Members
DrawHeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs.Header Property

DrawHeaderEventArgs.Header Property
[image]

Gets a reference to the header being drawn.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header Header { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Header As Header

Property Value

The Header object that should be custom-drawn.

See Also

DrawHeaderEventArgs Members
DrawHeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.DrawHeaderEventArgs.Target Property

DrawHeaderEventArgs.Target Property
[image]

Gets a DrawingContext object whose methods should be used to draw the header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Target { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Target As DrawingContext

Property Value

An instance of the System.Windows.Media.DrawingContext class.

See Also

DrawHeaderEventArgs Members
DrawHeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs Class

EditHeaderTextEventArgs Class
[image]

Contains the arguments passed to the LaneGridHeaderTextEdited event handlers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class EditHeaderTextEventArgs : HeaderEventArgs

Visual Basic [image] Copy Code

Public Class EditHeaderTextEventArgs
Inherits HeaderEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs
MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs

See Also

EditHeaderTextEventArgs Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs Members

EditHeaderTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the LaneGridHeaderTextEdited event handlers.

The following tables list the members exposed by the EditHeaderTextEventArgs type.

Public Constructors

Name | Description
EditHeaderTextEventArgs | Initializes a new instance of the EditHeaderTextEventArgs class.

Public Properties

Name | Description
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.

See Also

EditHeaderTextEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs Constructor

EditHeaderTextEventArgs Constructor
[image]

Initializes a new instance of the EditHeaderTextEventArgs class.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public EditHeaderTextEventArgs (
Header header,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
header As Header, _
oldText As String, _
newText As String _
)

Parameters

header

The Header related to the event.

oldText

The old text of the header.

newText

The new text of the header.

See Also

EditHeaderTextEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs Properties

EditHeaderTextEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.

See Also

EditHeaderTextEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs.NewText Property

EditHeaderTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

See Also

EditHeaderTextEventArgs Members
EditHeaderTextEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs.OldText Property

EditHeaderTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the cell before the user edited it.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

See Also

EditHeaderTextEventArgs Members
EditHeaderTextEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid Class

Grid Class
Remarks See Also
[image]

Represents a lane grid.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Grid : ITextAttributes

Visual Basic [image] Copy Code

Public Class Grid
Implements ITextAttributes

Remarks

The Grid class lets you define a background grid or table that can be used in Swimlane diagrams or Gantt charts. To activate the grid, set the EnableLanes property of the Diagram class to true.

Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth.

The intersection of rows and columns can be either a simple cell for bottommost elements in the lane hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the Item property, that lets you index cells either by their integer positions, or by their Header objects.

If the AllowResizeHeaders property of the Grid class is enabled, users can resize the grid columns and rows as desired. The CellBoundsChanged event is raised when lane cell bounds are resized.

The position of the grid and grid headers within the diagram document is defined via TopMargin and LeftMargin, which specify the grid offset relative to Bounds. The sizes of headers at different levels in the lane hierarchy can be set in a single operation via the RowHeadersWidths and ColumnHeadersHeights proeprties.

The appearance of the lanes grid can be customized further via the AlignCells property which specifies whether cells are aligned to each other, the HeadersOnTop poperty which specifies whether headers should appear on top of the z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Lanes.Grid

See Also

Grid Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid Members

Grid Members
Properties Methods Events
[image]

Represents a lane grid.

The following tables list the members exposed by the Grid type.

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowAddHeaders | Gets or sets a value indicating whether users can add new headers to the grid interactively.
AllowInplaceEdit | Gets or sets a value indicating whether header titles can be in-place edited.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded. Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of the specified cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Gets the Header that is located at the specified point.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
Insert | Inserts a new header after the specified header and returns a reference to it.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.

See Also

Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid Methods

Grid Methods
[image]

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of the specified cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Gets the Header that is located at the specified point.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
Insert | Inserts a new header after the specified header and returns a reference to it.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.

See Also

Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.FindColumn Method

Grid.FindColumn Method
[image]

Returns the first column header matching the specified caption.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header FindColumn (
string title
)

Visual Basic [image] Copy Code

Public Function FindColumn( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first column Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace
FindRow Method


MindFusion.Diagramming.Wpf.Lanes.Grid.FindRow Method

Grid.FindRow Method
[image]

Finds the first row whose header caption matches the specified string.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header FindRow (
string title
)

Visual Basic [image] Copy Code

Public Function FindRow( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first row Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace
FindColumn Method


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellBounds Method

Grid.GetCellBounds Method
[image]

Returns the bounding rectangle of the specified cell.

Overload List

Name | Description
Grid.GetCellBounds (ICell) | Returns the bounding rectangle of the specified cell.
Grid.GetCellBounds (Int32, Int32) | Returns the bounding rectangle of the cell with the specified row and column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellBounds Method (ICell)

Grid.GetCellBounds Method (ICell)
See Also
[image]

Returns the bounding rectangle of the specified cell.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellBounds( _
cell As ICell _
) As Rect

Parameters

cell
An ICell object representing a cell or a group of cells in the grid.

Return Value

A Rect instance representing the rectangle that bounds the specified cell or group of cells.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellBounds Method (Int32, Int32)

Grid.GetCellBounds Method (Int32, Int32)
See Also
[image]

Returns the bounding rectangle of the cell with the specified row and column.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
int c,
int r
)

Visual Basic [image] Copy Code

Public Function GetCellBounds( _
c As Integer, _
r As Integer _
) As Rect

Parameters

c
Index of the column that contains the cell.
r
Index of the row that contains the cell.

Return Value

A Rect instance representing the rectangle that bounds the specified cell or group of cells.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellColumn Method

Grid.GetCellColumn Method
[image]

Returns the column index of the specified cell.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetCellColumn (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellColumn( _
cell As ICell _
) As Integer

Parameters

cell
An ICell object representing a single cell in the grid.

Return Value

The index of the column that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellFromPoint Method

Grid.GetCellFromPoint Method
[image]

Gets the cell located at the specified point.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ICell GetCellFromPoint (
Point point,
ref Rect cellBounds
)

Visual Basic [image] Copy Code

Public Function GetCellFromPoint( _
point As Point, _
ByRef cellBounds As Rect _
) As ICell

Parameters

point
A Point instance specifying a point within the grid.
cellBounds
A Rect instance that receives the coordinates of the found cell.

Return Value

An ICell reference to the found cell, or null (Nothing in Visual Basic) if there is no cell located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetCellRow Method

Grid.GetCellRow Method
[image]

Returns the row index of the specified cell.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetCellRow (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellRow( _
cell As ICell _
) As Integer

Parameters

cell
An ICell object representing a single cell in the grid.

Return Value

The index of the row that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetColumn Method

Grid.GetColumn Method
[image]

Returns the column header with the specified index from the bottommost column header level.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header GetColumn (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumn( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the column index.

Return Value

A Header object representing the column at the specified index. A grid column that contains child columns cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetColumnHeaderBounds Method

Grid.GetColumnHeaderBounds Method
[image]

Returns the bounding rectangle of all column headers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetColumnHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetColumnHeaderBounds () As Rect

Return Value

A Rect that bounds all column headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetColumnIndex Method

Grid.GetColumnIndex Method
[image]

Returns the 0-based index of the specified column.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetColumnIndex (
Header column
)

Visual Basic [image] Copy Code

Public Function GetColumnIndex( _
column As Header _
) As Integer

Parameters

column
A Header instance that represents a grid column.

Return Value

The index of column, or -1 if the specified header represents a row or a group of child columns.

Remarks

Only works for bottommost headers. If the specified column is a group header, returns -1.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetHeaderBounds Method

Grid.GetHeaderBounds Method
[image]

Returns the bounding rectangle of the specified header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetHeaderBounds (
Header header,
bool includeSubHeaders
)

Visual Basic [image] Copy Code

Public Function GetHeaderBounds( _
header As Header, _
includeSubHeaders As Boolean _
) As Rect

Parameters

header
The Header object whose coordinates to return.
includeSubHeaders
true to include the coordinates of the child headers in the returned rectangle; otherwise, false.

Return Value

A Rect that bounds the specified header, and optionally its child headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetHeaderFromPoint Method

Grid.GetHeaderFromPoint Method
[image]

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header GetHeaderFromPoint (
Point point,
ref Rect headerBounds
)

Visual Basic [image] Copy Code

Public Function GetHeaderFromPoint( _
point As Point, _
ByRef headerBounds As Rect _
) As Header

Parameters

point
A Point instance specifying a point within the grid.
headerBounds
A Rect instance that receives the coordinates of the found header.

Return Value

The found Header object, or null (Nothing in Visual Basic) if there is no header located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetRow Method

Grid.GetRow Method
[image]

Returns the row header with the specified index from the bottommost row header level.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header GetRow (
int index
)

Visual Basic [image] Copy Code

Public Function GetRow( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the row index.

Return Value

A Header object representing the row at the specified index. A grid row that contains child rows cannot be accessed by index; only the bottommost child elements in the hierarchy are considered by this method.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetRowHeaderBounds Method

Grid.GetRowHeaderBounds Method
[image]

Returns the bounding rectangle of all row headers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect GetRowHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetRowHeaderBounds () As Rect

Return Value

A Rect that bounds all row headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.GetRowIndex Method

Grid.GetRowIndex Method
[image]

Returns the 0-based index of the specified row.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetRowIndex (
Header row
)

Visual Basic [image] Copy Code

Public Function GetRowIndex( _
row As Header _
) As Integer

Parameters

row

A Header instance that represents a grid row.

Return Value

The index of row, or -1 if the specified header represents a column or a group of child rows.

Remarks

Only works for bottommost headers. If the specified row is a group header, returns -1;

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.Insert Method

Grid.Insert Method
[image]

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header Insert (
Header header,
bool after
)

Visual Basic [image] Copy Code

Public Function Insert( _
header As Header, _
after As Boolean _
) As Header

Parameters

header

The header after which to insert the new header.

after

The relative position of the new header

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.InsertAfter Method

Grid.InsertAfter Method
[image]

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header InsertAfter (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertAfter( _
header As Header _
) As Header

Parameters

header

The header after which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.InsertBefore Method

Grid.InsertBefore Method
[image]

Inserts a new header before the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header InsertBefore (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertBefore( _
header As Header _
) As Header

Parameters

header

The header before which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.RaiseHeaderAdded Method

Grid.RaiseHeaderAdded Method
[image]

Raises the HeaderAdded event from outside the lane grid.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void RaiseHeaderAdded (
Header header
)

Visual Basic [image] Copy Code

Public Sub RaiseHeaderAdded( _
header As Header _
)

Parameters

header

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid Properties

Grid Properties
[image]

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowAddHeaders | Gets or sets a value indicating whether users can add new headers to the grid interactively.
AllowInplaceEdit | Gets or sets a value indicating whether header titles can be in-place edited.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded. Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.AlignCells Property

Grid.AlignCells Property
[image]

Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AlignCells { get; set; }

Visual Basic [image] Copy Code

Public Property AlignCells As Boolean

Property Value

true to align cells; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.AllowAddHeaders Property

Grid.AllowAddHeaders Property
[image]

Gets or sets a value indicating whether users can add new headers to the grid interactively.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowAddHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAddHeaders As Boolean

Property Value

true to let users add new headers, or false otherwise. The default value is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.AllowInplaceEdit Property

Grid.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether header titles can be in-place edited.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true to let the user edit header titles, otherwise false. The default value is false.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.AllowResizeHeaders Property

Grid.AllowResizeHeaders Property
[image]

Gets or sets a value indicating whether users can resize the headers of the grid interactively.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AllowResizeHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeHeaders As Boolean

Property Value

true to let users resize the grid elements; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.ColumnCount Property

Grid.ColumnCount Property
[image]

Gets or sets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child columns. If all child columns in a parent column are removed, the parent will be removed too. To have greater control over where in the hierarchy columns will be added or removed, use the ColumnHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace
RowCount Property
Item Property


MindFusion.Diagramming.Wpf.Lanes.Grid.ColumnHeaders Property

Grid.ColumnHeaders Property
[image]

Gets the collection with the topmost column headers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HeaderCollection ColumnHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the topmost column headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level columns. Columns can be further divided into child columns by adding to the SubHeaders collection of the Header that represents a parent column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.ColumnHeadersHeights Property

Grid.ColumnHeadersHeights Property
[image]

Gets or sets an array with double values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double[] ColumnHeadersHeights { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnHeadersHeights As Double()

Property Value

An array of double values where each value represents the height of an individual level of column headers.

Remarks

The first level of column headers is the one defined by the ColumnHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.HeadersOnTop Property

Grid.HeadersOnTop Property
[image]

Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool HeadersOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property HeadersOnTop As Boolean

Property Value

true if lane headers should be displayed on top, otherwise false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.HookHeaders Property

Grid.HookHeaders Property
[image]

Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool HookHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property HookHeaders As Boolean

Property Value

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.Item Property

Grid.Item Property
[image]

Gets a cell or cluster of cells from the grid.

Overload List

Name | Description
Grid.Item (Header, Header) | Gets the cell or the cluster of cells corresponding to the specified row and column.
Grid.Item (Int32, Int32) | Gets the cell at the specified position.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.Item Property (Header, Header)

Grid.Item Property (Header, Header)
See Also
[image]

Gets the cell or the cluster of cells corresponding to the specified row and column.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ICell Item [
Header column,
Header row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Header, _
row As Header _
) As ICell

Parameters

column
A Header object that represents the column of the cell to get.
row
A Header object that represents the row of the cell to get.

Property Value

An ICell instance representing all grid cell corresponding to the specified headers.

Remarks

If both Header parameters are null (Nothing in Visual Basic), a group containing all cells in the grid is returned. If only one of the Header parameters is null, the returned cell group contains all cells from the row or a column specified through the other parameter. This feature lets you set the Style of all cells in a group through a single assignment.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace
ColumnCount Property
RowCount Property


MindFusion.Diagramming.Wpf.Lanes.Grid.Item Property (Int32, Int32)

Grid.Item Property (Int32, Int32)
See Also
[image]

Gets the cell at the specified position.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ICell Item [
int column,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Integer, _
row As Integer _
) As ICell

Parameters

column
An integer value that represents the column of the cell to get.
row
An integer value that represents the index of the row to get.

Property Value

An ICell instance representing the cell at the specified position.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace
ColumnCount Property
RowCount Property


MindFusion.Diagramming.Wpf.Lanes.Grid.LeftMargin Property

Grid.LeftMargin Property
[image]

Gets or sets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LeftMargin { get; set; }

Visual Basic [image] Copy Code

Public Property LeftMargin As Double

Property Value

A double value specifying the left margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.MinHeaderSize Property

Grid.MinHeaderSize Property
[image]

Gets or sets the minimum size of a header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MinHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeaderSize As Double

Property Value

A double value specifying the minimal size of a header. The default is 40.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.RowCount Property

Grid.RowCount Property
[image]

Gets or sets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value indicating the number of rows in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child rows. If all child rows in a parent row are removed, the parent will be removed too. To have greater control over where in the hierarchy rows will be added or removed, use the RowHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.RowHeaders Property

Grid.RowHeaders Property
[image]

Gets the collection with the leftmost row headers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HeaderCollection RowHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the leftmost row headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level rows. Rows can be further divided into child rows by adding to the SubHeaders collection of the Header that represents a parent row.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.RowHeadersWidths Property

Grid.RowHeadersWidths Property
[image]

Gets or sets an array with double values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double[] RowHeadersWidths { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeadersWidths As Double()

Property Value

An array of double values where each value represents the width of an individual level of row headers.

Remarks

The first level of row headers is the one defined by the RowHeaders collection. Each next level is defnied by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.TopLeftAreaStyle Property

Grid.TopLeftAreaStyle Property
[image]

Gets or sets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style TopLeftAreaStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaStyle As Style

Property Value

An instance of the Style class specifying how to paint the top left corner. The default value is null (Nothing in Visual Basic).

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.TopMargin Property

Grid.TopMargin Property
[image]

Gets or sets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TopMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TopMargin As Double

Property Value

A double value specifying the top margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid Events

Grid Events
[image]

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.

See Also

Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.CellBoundsChanged Event

Grid.CellBoundsChanged Event
[image]

Raised when the bounding rectangle of a cell has been changed.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellBoundsEventArgs> CellBoundsChanged

Visual Basic [image] Copy Code

Public Event CellBoundsChanged As EventHandler(Of CellBoundsEventArgs)

Event Data

CellBoundsChanged event handlers receive an argument of type CellBoundsEventArgs.

Remarks

By default, diagram items are not affected by resizing cells in the lanes grid. By handling this event, you can move or resize items so that they stay aligned to their enclosing grid elements, as suits your application logic.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Grid.HeaderAdded Event

Grid.HeaderAdded Event
[image]

Raised when a header has been inserted to the grid either interactively or through a call to the InsertBefore or InsertAfter methods.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<HeaderEventArgs> HeaderAdded

Visual Basic [image] Copy Code

Public Event HeaderAdded As EventHandler(Of HeaderEventArgs)

Event Data

HeaderAdded event handlers receive an argument of type HeaderEventArgs.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Class

Header Class
Remarks See Also
[image]

Represents a header in a grid view.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Header : TextPresenter, InplaceEditable

Visual Basic [image] Copy Code

Public Class Header
Inherits TextPresenter
Implements InplaceEditable

Remarks

The Header class provides the properties to define and adjust headers in the lanes grid.

The size of a header can be set through the Height and Width properties. Note that the size of the rows and columns in the grid is controlled through the size of their headers. The SubHeaders property lets you add child rows or columns to the grid. The ResizeType property is used to specify how to resize child columns and rows when the topmost headers are resized. The possible values for the ResizeType property are defined in the ResizeType enumeration.

In order to specify the color, font or alignment of the header Title, set the TitleColor, TitleFont or TitleFormat properties.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Diagramming.Wpf.TextPresenter
MindFusion.Diagramming.Wpf.Lanes.Header

See Also

Header Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Members

Header Members
Constructors Fields Properties Methods
[image]

Represents a header in a grid view.

The following tables list the members exposed by the Header type.

Public Constructors

Name | Description
Header | Overloaded.

Public Fields

Name | Description
FontFamilyProperty | Identifies the FontFamily dependency property. (Inherited from TextPresenter.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TextPresenter.)
FontStretchProperty | Identifies the FontStretch dependency property. (Inherited from TextPresenter.)
FontStyleProperty | Identifies the FontStyle dependency property. (Inherited from TextPresenter.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TextPresenter.)
TextAlignmentProperty | Identifies the TextAlignment dependency property. (Inherited from TextPresenter.)
TextBrushProperty | Identifies the TextBrush dependency property. (Inherited from TextPresenter.)
TextDecorationsProperty | Identifies the TextDecorations dependency property. (Inherited from TextPresenter.)
TextPaddingProperty | Identifies the TextPadding dependency property. (Inherited from TextPresenter.)
TextProperty | Identifies the Text dependency property. (Inherited from TextPresenter.)
TextTrimmingProperty | Identifies the TextTrimming dependency property. (Inherited from TextPresenter.)
TextVerticalAlignmentProperty | Identifies the TextVerticalAlignment dependency property. (Inherited from TextPresenter.)
TextWrappingProperty | Identifies the TextWrapping dependency property. (Inherited from TextPresenter.)

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

See Also

Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Constructor

Header Constructor
[image]

Overload List

Name | Description
Header () | Initializes a new instance of the Header class.
Header (String) | Initializes a new instance of the Header class with the specified title.

See Also

Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Constructor ()

Header Constructor ()
See Also
[image]

Initializes a new instance of the Header class.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Constructor (String)

Header Constructor (String)
See Also
[image]

Initializes a new instance of the Header class with the specified title.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header (
string title
)

Visual Basic [image] Copy Code

Public New ( _
title As String _
)

Parameters

title
A string value that represents the title for this Header object.

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Methods

Header Methods
[image]

Public Methods

Name | Description
CopyFrom | Copies all text attributes from the specified object. (Inherited from TextPresenter.)

Protected Methods

Name | Description
LoadTextAttributes | Loads the text properties to the specified XML element. (Inherited from TextPresenter.)
OnTextAttributeChanged | TextPresenter.OnTextAttributeChanged override.
SaveTextAttributes | Saves the text properties to the specified XML element. (Inherited from TextPresenter.)
SetDiagramDirty | TextPresenter.SetDiagramDirty override.

See Also

Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.OnTextAttributeChanged Method

Header.OnTextAttributeChanged Method
[image]

TextPresenter.OnTextAttributeChanged override.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextAttributeChanged (
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextAttributeChanged( _
e As DependencyPropertyChangedEventArgs _
)

Parameters

e

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.SetDiagramDirty Method

Header.SetDiagramDirty Method
[image]

TextPresenter.SetDiagramDirty override.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Overrides Sub SetDiagramDirty ()

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header Properties

Header Properties
[image]

Public Properties

Name | Description
FontFamily | Gets or sets the preferred font family for this TextPresenter. (Inherited from TextPresenter.)
FontSize | Gets or sets the font size for this TextPresenter. (Inherited from TextPresenter.)
FontStretch | Gets or sets the font-stretching characteristics for this TextPresenter. (Inherited from TextPresenter.)
FontStyle | Gets or sets the font style for this TextPresenter. (Inherited from TextPresenter.)
FontWeight | Gets or sets the font weight for this TextPresenter. (Inherited from TextPresenter.)
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Text | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content. (Inherited from TextPresenter.)
TextBrush | Gets or sets the text displayed inside this item. (Inherited from TextPresenter.)
TextDecorations | Gets or sets the effects to apply to the text of this TextPresenter. (Inherited from TextPresenter.)
TextPadding | Gets or sets the thickness of padding space between the item boundaries and its text. (Inherited from TextPresenter.)
TextTrimming | Gets or sets the text trimming to employ when text overflows the item area. (Inherited from TextPresenter.)
TextVerticalAlignment | Gets or sets a value that indicates the vertical alignment of text content. (Inherited from TextPresenter.)
TextWrapping | Gets or sets how this TextPresenter should wrap text. (Inherited from TextPresenter.)
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.Height Property

Header.Height Property
[image]

Gets or sets the height of this header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new double Height { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Height As Double

Property Value

A double value specifying the header height. The default is 0.

Remarks

If this is a row header, the property specifies the height of the whole row.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.IsColumnHeader Property

Header.IsColumnHeader Property
[image]

Gets a value indicating whether this header is a column header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool IsColumnHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsColumnHeader As Boolean

Property Value

true if the header is a column header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace
IsRowHeader Property


MindFusion.Diagramming.Wpf.Lanes.Header.IsRowHeader Property

Header.IsRowHeader Property
[image]

Gets a value indicating whether this header is a row header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool IsRowHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsRowHeader As Boolean

Property Value

true if the header is a row header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace
IsColumnHeader Property


MindFusion.Diagramming.Wpf.Lanes.Header.ResizeType Property

Header.ResizeType Property
[image]

Gets or sets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ResizeType ResizeType { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeType As ResizeType

Property Value

A member of the ResizeType enumeration. The default is Proportional.

Remarks

When a topmost header is resized, the child elements of the row or column related to the header either keep their size or are resized as set through this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace
SubHeaders Property


MindFusion.Diagramming.Wpf.Lanes.Header.RotateTitle Property

Header.RotateTitle Property
[image]

Gets or sets a value indicating whether to rotate the header caption at 90 degree.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RotateTitle { get; set; }

Visual Basic [image] Copy Code

Public Property RotateTitle As Boolean

Property Value

true if the title should be rotated; otherwise, false. The default is false.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.Style Property

Header.Style Property
[image]

Gets or sets the style of this header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new Style Style { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Style As Style

Property Value

An instance of the Style class that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.SubHeaders Property

Header.SubHeaders Property
[image]

Gets a collection of the subheaders of this header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HeaderCollection SubHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SubHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class.

Remarks

Adding SubHeaders to a row header creates child rows controlled through the same parent header. In the same way you can add child columns to a column by adding SubHeaders to the column header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.Title Property

Header.Title Property
[image]

Gets or sets the header caption.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string containing the caption text. The default is an empty string.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.TitleColor Property

Header.TitleColor Property
[image]

Gets or sets the color of the header caption.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Color TitleColor { get; set; }

Visual Basic [image] Copy Code

Public Property TitleColor As Color

Property Value

An instance of the .NET Color structure. The default is Color.Black.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.TitleFont Property

Header.TitleFont Property
[image]

Gets or sets the font of the header caption.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Font TitleFont { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFont As Font

Property Value

An instance of the Font class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set to null, the header text will be rendered using the diagram's Font.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.TitleFormat Property

Header.TitleFormat Property
[image]

Gets or sets the alignment of the header caption.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public StringFormat TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As StringFormat

Property Value

An instance of the StringFormat class. The default is null (Nothing in Visual Basic).

Remarks

Set this property to null to use the default (centered) alignment.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Header.Width Property

Header.Width Property
[image]

Gets or sets the width of this header.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new double Width { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Width As Double

Property Value

A double value specifying the header width. The default is 0.

Remarks

If this is a column header, the property specifies the width of the whole column.

See Also

Header Members
Header Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection Class

HeaderCollection Class
Remarks See Also
[image]

Represents a strongly typed collection of Header objects.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HeaderCollection : CollectionBase

Visual Basic [image] Copy Code

Public Class HeaderCollection
Inherits CollectionBase

Remarks

The ColumnHeaders and RowHeaders properties of the Grid class are of this collection type. Adding or removing headers to them automatically adds or removes parent columns and rows to the grid. Adding to or removing form the SubHeaders property of the Header class automatically adds or removes child columns or rows.

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Diagramming.Wpf.Lanes.HeaderCollection

See Also

HeaderCollection Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection Members

HeaderCollection Members
Properties Methods
[image]

Represents a strongly typed collection of Header objects.

The following tables list the members exposed by the HeaderCollection type.

Public Properties

Name | Description
Item | Gets or sets the Header at the specified position.

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection Methods

HeaderCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Add Method

HeaderCollection.Add Method
[image]

Adds the specified header to the collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Add (
Header header
)

Visual Basic [image] Copy Code

Public Function Add( _
header As Header _
) As Integer

Parameters

header

The Header object to add.

Return Value

The index at which the header was added in the collection.

Remarks

The method adds a Header object to the end of the collection. If you need to place the Header at a certain position, you should use Insert method instead.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Clear Method

HeaderCollection.Clear Method
[image]

Removes all headers from the collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Contains Method

HeaderCollection.Contains Method
[image]

Checks whether a Header is in the collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Header header
)

Visual Basic [image] Copy Code

Public Function Contains( _
header As Header _
) As Boolean

Parameters

header

The Header to locate in the collection.

Return Value

true if the header was found in the collection; otherwise, false.

Remarks

Call the method to determine whether a Header is contained within the collection. If not, you can add it with the Add method. Otherwise, if it is there, you can remove it with Remove.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.IndexOf Method

HeaderCollection.IndexOf Method
[image]

Gets the index of the specified header within this collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
Header header
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
header As Header _
) As Integer

Parameters

header

The Header to locate in the HeaderCollection. The value can be a null reference (Nothing in Visual Basic).

Return Value

The zero-based index of the first occurrence of value within the entire HeaderCollection, if found; otherwise, -1.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Insert Method

HeaderCollection.Insert Method
[image]

Inserts the specified Header at the specified position within the HeaderCollection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
Header header
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
header As Header _
)

Parameters

index

The zero-based index at which the Header should be inserted.

header

The Header object to insert.

Remarks

Use this method to insert Header objects at a specific position in the collection. If you do not need to specify header's position, use the Add method instead, which adds new headers to the end of the list.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Remove Method

HeaderCollection.Remove Method
[image]

Removes the first occurrence of the specified Header from the collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Header header
)

Visual Basic [image] Copy Code

Public Sub Remove( _
header As Header _
)

Parameters

header

The Header object to remove.

Remarks

Use this method to remove headers from the collection. Headers can be added to the collection with the Add or Insert methods.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.RemoveAt Method

HeaderCollection.RemoveAt Method
[image]

Removes the Header at the specified position within the collection.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index

The index at which the Header object should be removed.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection Properties

HeaderCollection Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the Header at the specified position.

See Also

HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderCollection.Item Property

HeaderCollection.Item Property
[image]

Gets or sets the Header at the specified position.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Header

Parameters

index

Property Value

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs Class

HeaderEventArgs Class
[image]

Contains the arguments passed to handlers of header-related events.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HeaderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs
MindFusion.Diagramming.Wpf.Lanes.EditHeaderTextEventArgs
MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs

See Also

HeaderEventArgs Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs Members

HeaderEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of header-related events.

The following tables list the members exposed by the HeaderEventArgs type.

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs Properties

HeaderEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs.Header Property

HeaderEventArgs.Header Property
[image]

Gets or sets the header related to the event.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Header Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Header

Property Value

An instance of the Header class.

See Also

HeaderEventArgs Members
HeaderEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs Class

HeaderValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as LaneGridHeaderTextEditing.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HeaderValidationEventArgs : HeaderEventArgs

Visual Basic [image] Copy Code

Public Class HeaderValidationEventArgs
Inherits HeaderEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Lanes.HeaderEventArgs
MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs

See Also

HeaderValidationEventArgs Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs Members

HeaderValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as LaneGridHeaderTextEditing.

The following tables list the members exposed by the HeaderValidationEventArgs type.

Public Constructors

Name | Description
HeaderValidationEventArgs | Initializes a new instance of the HeaderValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)

See Also

HeaderValidationEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs Constructor

HeaderValidationEventArgs Constructor
[image]

Initializes a new instance of the HeaderValidationEventArgs class.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HeaderValidationEventArgs (
Header header
)

Visual Basic [image] Copy Code

Public New ( _
header As Header _
)

Parameters

header

See Also

HeaderValidationEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs Properties

HeaderValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)

See Also

HeaderValidationEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.HeaderValidationEventArgs.Cancel Property

HeaderValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation, otherwise false. The default value is false.

See Also

HeaderValidationEventArgs Members
HeaderValidationEventArgs Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.ICell Interface

ICell Interface
[image]

Defines a base for cells in a lane list.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface ICell

Visual Basic [image] Copy Code

Public Interface ICell

See Also

ICell Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.ICell Members

ICell Members
Properties
[image]

Defines a base for cells in a lane list.

The following tables list the members exposed by the ICell type.

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.ICell Properties

ICell Properties
[image]

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.ICell.Style Property

ICell.Style Property
[image]

Gets or sets the Style of the cell or group of cells.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

Style Style { get; set; }

Visual Basic [image] Copy Code

Property Style As Style

Property Value

An instance of the Lanes.Style class that specifies the style of this cell.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the style of all cells in the group with a single assignment.

Example

C# [image] Copy Code
diagram.LaneGrid[column, null].Style.BackgroundBrush =
new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod);
Visual Basic [image] Copy Code
diagram.LaneGrid(column, Nothing).Style.BackgroundBrush = _
new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod)

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.ResizeType Enumeration

ResizeType Enumeration
[image]

Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum ResizeType

Visual Basic [image] Copy Code

Public Enum ResizeType

Members

Member name | Description
Fixed | The header's size (width or height) is fixed and does not change when its parent header is being resized unless all its siblings have fixed size too.
Proportional | The header resizes in proportion to its parent header.

Remarks

This enumeration specifies the possible values of the ResizeType property of the Header class.

See Also

MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style Class

Style Class
[image]

Encapsulates the appearance properties of an element in a lane grid.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Style

Visual Basic [image] Copy Code

Public Class Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Lanes.Style

See Also

Style Members
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style Members

Style Members
Constructors Properties
[image]

Encapsulates the appearance properties of an element in a lane grid.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style Properties

Style Properties
[image]

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style.BackgroundBrush Property

Style.BackgroundBrush Property
[image]

Gets or sets the background Brush of this style.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Brush BackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BackgroundBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style.BottomBorderPen Property

Style.BottomBorderPen Property
[image]

Gets or sets the Pen for drawing the bottom border for this style.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Pen BottomBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomBorderPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

The property refers to a Pen used to paint the bottom border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style.LeftBorderPen Property

Style.LeftBorderPen Property
[image]

Gets or sets the Pen for drawing the left border for this style.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Pen LeftBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftBorderPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

The property refers to a Pen used for painting the left border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style.RightBorderPen Property

Style.RightBorderPen Property
[image]

Gets or sets the Pen for drawing the right border for this style.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Pen RightBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightBorderPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

The property refers to the Pen used for painting the right border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Lanes.Style.TopBorderPen Property

Style.TopBorderPen Property
[image]

Gets or sets the Pen for drawing the top border for this style.

Namespace: MindFusion.Diagramming.Wpf.Lanes
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual Pen TopBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopBorderPen As Pen

Property Value

An instance of the System.Windows.Media.Pen class.

Remarks

The property refers to the Pen used for painting the top border of a cell.

See Also

Style Members
Style Class
MindFusion.Diagramming.Wpf.Lanes Namespace


MindFusion.Diagramming.Wpf.Layout Namespace

MindFusion.Diagramming.Wpf.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayout | Implements a simulated annealing graph layout algorithm.
CascadeLayout | Performs cascading layout on simple, connected graphs.
CircularLayout | Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.
CompositeLayout | Implements a multi-level graph layout algorithm.
DecisionLayout | Implements a decision graph layout algorithm.
FlowchartLayout | FlowchartLayout can be used to arrange flowcharts representing program source code.
FlowLayout | Implements a flowchart, workflow and process diagrams layout algorithm.
FractalLayout | A tree layout algorithm that places child nodes symmetrically around their parent node.
GridLayout | Implements a grid graph layout algorithm.
HierarchicalLayout | Performs hierarchical layout on simple, connected, level-planar graphs.
LaneGrid | Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.
LayeredLayout | Implements a layered graph layout algorithm.
LayeredLayoutStatistics | Encapsulates information about a layered layout which has already complete.
Layout | The base class for all layout classes.
OneWayLayout | Implements a one-way graph layout algorithm.
OrthogonalLayout | Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.
OrthogonalRouter | Implements an orthogonal link routing algorithm.
SolarLayout | A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
SwimlaneLayout | Implements an algorithm which arranges nodes in lanes.
TopologicalLayout | Implements a topological ordering.
TreeLayout | Implements several algorithms for arranging tree structures.
TreeMapLayout | Implements a tree map layout algorithm.
TriangularLayout | Performs triangular layout on simple, connected graphs.

Interfaces

Interface | Description
ILayout | Common interface for all MindFusion.Diagramming for WPF layouters.
ISwimlaneGrid | Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Delegates

Delegate | Description
LayoutLink | Represents methods that are called by the layout algorithms when the position of a link changes.
LayoutNode | Represents methods that are called by the layout algorithms when the position of a node changes.
LayoutProgress | Represents methods that are called to report on progress of layout algorithms.
LayoutSubgraph | Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Enumerations

Enumeration | Description
Direction | Specifies a layout direction.
LaneType | Specifies where FlowLayout gets the swimlane dimensions from.
LayeredLayoutLinkType | Specifies the style of the links after they are laid out.
MultipleGraphsPlacement | Specifies graph orientation.
Orientation | Specifies axial orientation.
SpringLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutBalance | Specifies how to order child nodes in order to produce tree layouts with custom balance.
TreeLayoutDirections | Specifies the direction of a tree layout.
TreeLayoutLinkType | Specifies the shape of the diagram links after they are laid out.
TreeLayoutType | Specifies the type of a tree layout.


MindFusion.Diagramming.Wpf.Layout.Fluent Namespace

MindFusion.Diagramming.Wpf.Layout.Fluent Namespace
Classes

Classes

Class | Description
AnnealLayoutExtensions | Provides extension methods for AnnealLayout fluent API.
CascadeLayoutExtensions | Provides extension methods for CascadeLayout fluent API.
CircularLayoutExtensions | Provides extension methods for CircularLayout fluent API.
DecisionLayoutExtensions | Provides extension methods for DecisionLayout fluent API.
FlowchartLayoutExtensions | Provides extension methods for FlowchartLayout fluent API.
FractalLayoutExtensions | Provides extension methods for FractalLayout fluent API.
GridLayoutExtensions | Provides extension methods for GridLayout fluent API.
HierarchicalLayoutExtensions | Provides extension methods for HierarchicalLayout fluent API.
LayeredLayoutExtensions | Provides extension methods for LayeredLayout fluent API.
OneWayLayoutExtensions | Provides extension methods for OneWayLayout fluent API.
OrthogonalLayoutExtensions | Provides extension methods for OrthogonalLayout fluent API.
OrthogonalRouterExtensions | Provides extension methods for OrthogonalRouter fluent API.
SpringLayoutExtensions | Provides extension methods for SpringLayout fluent API.
SwimlaneLayoutExtensions | Provides extension methods for SwimlaneLayout fluent API.
TopologicalLayoutExtensions | Provides extension methods for TopologicalLayout fluent API.
TreeLayoutExtensions | Provides extension methods for TreeLayout fluent API.
TreeMapLayoutExtensions | Provides extension methods for TreeMapLayout fluent API.
TriangularLayoutExtensions | Provides extension methods for TriangularLayout fluent API.


MindFusion.Diagramming.Wpf.Layout.AnnealLayout Class

AnnealLayout Class
Remarks See Also
[image]

Implements a simulated annealing graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnnealLayout : Layout

Visual Basic [image] Copy Code

Public Class AnnealLayout
Inherits Layout

Remarks

Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. In that case, a cost is assigned to a graph configuration by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings.

The AnnealLayout class implements a Simulated Annealing graph layout algorithm that can be used to arrange MindFusion.Diagramming for WPF diagrams. To arrange a diagram, create an AnnealLayout instance, set its properties and call the Arrange method.

The algorithm starts the simulation with the temperature set in InitialTemperature, and runs several cooling Stages. At each stage the algorithm evaluates several graph configurations for each node, as set in IterationsPerStage. At the end of each stage, the algorithm selects the configuration that has a minimum cost and decreases the temperature by multiplying it by TemperatureScale. The relative weight of an aesthetic criterion relative to the other criteria is set by the DistributionFactor, LinkLengthFactor, BoundaryFactor and CrossingLinksCost properties.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.AnnealLayout

See Also

AnnealLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout Members

AnnealLayout Members
Constructors Properties Methods
[image]

Implements a simulated annealing graph layout algorithm.

The following tables list the members exposed by the AnnealLayout type.

Public Constructors

Name | Description
AnnealLayout | Initializes a new instance of the AnnealLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GatherStatistics | Specifies whether the layout should gather statistics while running.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Returns statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.
ArrangeAsync | Overloaded. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout Constructor

AnnealLayout Constructor
[image]

Initializes a new instance of the AnnealLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnnealLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout Methods

AnnealLayout Methods
[image]

Public Methods

Name | Description
Arrange | Applies the layout on the specified subset of items from the specified Diagram instance.
ArrangeAsync | Overloaded. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Arrange Method

AnnealLayout.Arrange Method
[image]

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

This method always returns true.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.BeginArrange Method

AnnealLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that will be arranged.
items
A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.EndArrange Method

AnnealLayout.EndArrange Method
[image]

Completes the step-by-step execution.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Iterate Method

AnnealLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout Properties

AnnealLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GatherStatistics | Specifies whether the layout should gather statistics while running.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Returns statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.ApproximateLinkLength Property

AnnealLayout.ApproximateLinkLength Property
[image]

Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ApproximateLinkLength { get; set; }

Visual Basic [image] Copy Code

Public Property ApproximateLinkLength As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.BoundaryFactor Property

AnnealLayout.BoundaryFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double BoundaryFactor { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryFactor As Double

Property Value

A double multiplier applied to the node-to-boundary distance cost when evaluating the total cost of a graph configuration. The default is 42000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which nodes are placed farther from the layout area bounds, that is, nodes will tend to gather in the center of the layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
LinkLengthFactor Property
DistributionFactor Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.CrossingLinksCost Property

AnnealLayout.CrossingLinksCost Property
[image]

Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double CrossingLinksCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingLinksCost As Double

Property Value

A double value added to the total cost of a graph configuration for each pair of crossing links. The default is 1200000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations with fewer link crossings.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
LinkLengthFactor Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.DefaultMarginValue Property

AnnealLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.DistributionFactor Property

AnnealLayout.DistributionFactor Property
[image]

Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double DistributionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionFactor As Double

Property Value

A double multiplier applied to the node distribution cost when evaluating the total cost of a graph configuration. The default is 560000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which the nodes are placed farther one from another.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
LinkLengthFactor Property
BoundaryFactor Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.GatherStatistics Property

AnnealLayout.GatherStatistics Property
[image]

Specifies whether the layout should gather statistics while running.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool GatherStatistics { get; set; }

Visual Basic [image] Copy Code

Public Property GatherStatistics As Boolean

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.InitialTemperature Property

AnnealLayout.InitialTemperature Property
[image]

Gets or sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double InitialTemperature { get; set; }

Visual Basic [image] Copy Code

Public Property InitialTemperature As Double

Property Value

A double value specifying the initial temperature of the simulation. The default is 40.

Remarks

A low initial temperature prevents nodes from moving far from their initial position. If you need the final arrangement to have resemblance to the initial formation of the graph elements, set a lower initial temperature and disable Randomize.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
TemperatureScale Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.IterationsPerStage Property

AnnealLayout.IterationsPerStage Property
[image]

Gets or sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IterationsPerStage { get; set; }

Visual Basic [image] Copy Code

Public Property IterationsPerStage As Integer

Property Value

An integer value specifying the number of node shift iterations. The default is 50.

Remarks

IterationsPerStage specifies how many node configurations to evaluate at each stage of the temperature cool-down simulation. More iterations will yield better layouts but require more time to complete.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Progress Property
Stages Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.LayoutArea Property

AnnealLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A .NET Rect representing the boundaries of the layout area. The default is Rect.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.LinkLengthFactor Property

AnnealLayout.LinkLengthFactor Property
[image]

Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkLengthFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkLengthFactor As Double

Property Value

A double multiplier applied to the link length cost when evaluating the total cost of a graph configuration. The default is 0.02.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which links are shorter.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
CrossingLinksCost Property
DistributionFactor Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Name Property

AnnealLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Anneal layout".

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.NodeLinkCrossingCost Property

AnnealLayout.NodeLinkCrossingCost Property
[image]

Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeLinkCrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkCrossingCost As Double

Property Value

A double value added to the total cost of a graph configuration when a link crosses a node. The default is 150000.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.NodeLinkDistFactor Property

AnnealLayout.NodeLinkDistFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeLinkDistFactor { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkDistFactor As Double

Property Value

A double value specifying the distance factor. The default value is 320000.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Randomize Property

AnnealLayout.Randomize Property
[image]

Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start the simulation with random node positions; false to start it with the original node positions. The default is true.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Root Property

AnnealLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

A DiagramNode whose containing graph should be arranged. The default is null (Nothing in Visual Basic).

Remarks

If a root node is specified and SplitGraph is enabled, only the graph that contains the root node is laid out by Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.SplitGraph Property

AnnealLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Stages Property

AnnealLayout.Stages Property
[image]

Gets or sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Stages { get; set; }

Visual Basic [image] Copy Code

Public Property Stages As Integer

Property Value

An integer value specifying the number of temperature decreases the simulation should run. The default is 15.

Remarks

At each stage the algorithm evaluates different graph arrangements produced by modifying the best configuration from the previous stage. The modifications are done by shifting nodes by a distance that depends on the current temperature. The TemperatureScale property specifies how much the temperature decreases at each stage. IterationsPerStage specifies how many configurations are evaluated at each stage.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Progress Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.Statistics Property

AnnealLayout.Statistics Property
[image]

Returns statistics about the layout execution and end results.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As AnnealLayoutStatistics

Property Value

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.TemperatureScale Property

AnnealLayout.TemperatureScale Property
[image]

Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double TemperatureScale { get; set; }

Visual Basic [image] Copy Code

Public Property TemperatureScale As Double

Property Value

A double multiplier applied to the simulated temperature at each stage of the algorithm. The default is 0.75.

Remarks

This value should be in the interval (0,1). The algorithm produces better results when running for many Stages with a gradual temperature decrease, that is, a TemperatureScale closer to 1.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
InitialTemperature Property


MindFusion.Diagramming.Wpf.Layout.AnnealLayout.WidthHeightRatio Property

AnnealLayout.WidthHeightRatio Property
[image]

Gets or sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double WidthHeightRatio { get; set; }

Visual Basic [image] Copy Code

Public Property WidthHeightRatio As Double

Property Value

A double value specifying the layout area width to height ration. The default is 1.

Remarks

If the LayoutArea is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout Class

CascadeLayout Class
Remarks See Also
[image]

Performs cascading layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CascadeLayout : Layout

Visual Basic [image] Copy Code

Public Class CascadeLayout
Inherits Layout

Remarks

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.CascadeLayout

See Also

CascadeLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout Members

CascadeLayout Members
Constructors Properties Methods
[image]

Performs cascading layout on simple, connected graphs.

The following tables list the members exposed by the CascadeLayout type.

Public Constructors

Name | Description
CascadeLayout | Initializes a new instance of the CascadeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout Constructor

CascadeLayout Constructor
[image]

Initializes a new instance of the CascadeLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CascadeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout Properties

CascadeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout.DefaultMarginValue Property

CascadeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout.Name Property

CascadeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Cascade layout".

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout.Orientation Property

CascadeLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CascadeLayout.Padding Property

CascadeLayout.Padding Property
[image]

Gets or sets the spacing between nodes in adjacent layers.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

The default value is 55.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout Class

CircularLayout Class
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CircularLayout : Layout

Visual Basic [image] Copy Code

Public Class CircularLayout
Inherits Layout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.CircularLayout

See Also

CircularLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout Members

CircularLayout Members
Constructors Properties Methods
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

The following tables list the members exposed by the CircularLayout type.

Public Constructors

Name | Description
CircularLayout | Initializes a new instance of the CircularLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout Constructor

CircularLayout Constructor
[image]

Initializes a new instance of the CircularLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CircularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout Properties

CircularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.AutoRadiusFactor Property

CircularLayout.AutoRadiusFactor Property
[image]

Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double AutoRadiusFactor { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRadiusFactor As Double

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.DefaultMarginValue Property

CircularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.Name Property

CircularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Circular layout".

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.Radius Property

CircularLayout.Radius Property
[image]

Gets or sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

A double value specifying the radius. The default value is 225.

Remarks

If this property is set to 0, the layout will try to find an appropriate radius depending on the number and size of the participating nodes.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.SiftingRounds Property

CircularLayout.SiftingRounds Property
[image]

Gets or sets the number of sifts to perform during the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int SiftingRounds { get; set; }

Visual Basic [image] Copy Code

Public Property SiftingRounds As Integer

Property Value

An integer value specifying the number of sifting rounds. The default value is 1.

Remarks

After calculating the initial placement of nodes using a fast but inaccurate layout function, the algorithm can run a few sifting rounds to reduce the link crossings, as set in this property.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CircularLayout.SplitGraph Property

CircularLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout Class

CompositeLayout Class
Remarks See Also
[image]

Implements a multi-level graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class CompositeLayout : Layout

Visual Basic [image] Copy Code

Public Class CompositeLayout
Inherits Layout

Remarks

CompositeLayout partitions the diagram into several subgraphs and applies the algorithm specified via the SubgraphLayout property on each part. If the part is a tree, it is arranged using the algorithm specified via the SubtreeLayout property, which is set to a radial TreeLayout instance by default. Finally the algorithm specified via MasterLayout is applied on the graph that represents the overall partition. By running the polynomial-complexity layout algorithms on small subgraphs, CompositeLayout is able to process a large graph much faster than if a layout algorithm is applied on the whole graph.

CompositeLayout can run on custom partitions specified as lists of nodes, or automatically partition the diagram via two automatic methods based on graph connectivity and graph path lengths. Set the PartitionMethod and CustomPartition properties to specify how the diagram should be partitioned.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.CompositeLayout

See Also

CompositeLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout Members

CompositeLayout Members
Constructors Properties Methods
[image]

Implements a multi-level graph layout algorithm.

The following tables list the members exposed by the CompositeLayout type.

Public Constructors

Name | Description
CompositeLayout | Initializes a new instance of the CompositeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of vertices in the partitions allocated by the layout.
EmphasizeTrees | Gets or sets a value indicating whether the cut-vertices of tree subgraphs are added to the corresponding trees.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepVirtualItems | Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MasterLayout | Gets or sets a layout that should be applied globally to the graph.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout Constructor

CompositeLayout Constructor
[image]

Initializes a new instance of the CompositeLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public CompositeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout Properties

CompositeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.
CustomLayout | Gets or sets a custom layout method that should be invoked to arrange subgraphs.
CustomPartition | Gets or sets the custom partition to use when PartitionMethod is set to Custom.
DesiredSubgraphSize | Gets or sets the preferred number of vertices in the partitions allocated by the layout.
EmphasizeTrees | Gets or sets a value indicating whether the cut-vertices of tree subgraphs are added to the corresponding trees.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepVirtualItems | Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MasterLayout | Gets or sets a layout that should be applied globally to the graph.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
PartitionMethod | Gets or sets the partitioning method used to decompose the diagram into subgraphs.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RotateSubgraphs | Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.
SubgraphLayout | Gets or sets a layout that should be applied to general subgraphs.
SubtreeLayout | Gets or sets a layout that should be applied to subgraphs representing trees.
Tolerance | A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.
UseAdditionalPartitioning | Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.BendLinks Property

CompositeLayout.BendLinks Property
[image]

Gets or sets a value indicating whether the links in the trees from the additional partitioning pass will bend to avoid crossing leaves in the same tree.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.CustomLayout Property

CompositeLayout.CustomLayout Property
[image]

Gets or sets a custom layout method that should be invoked to arrange subgraphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayoutSubgraph CustomLayout { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLayout As LayoutSubgraph

Property Value

A LayoutSubgraph delegate object.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
CustomPartition Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.CustomPartition Property

CompositeLayout.CustomPartition Property
[image]

Gets or sets the custom partition to use when PartitionMethod is set to Custom.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public List<IEnumerable> CustomPartition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomPartition As List(Of IEnumerable)

Property Value

A list of DiagramNodeCollection objects that partitions the diagram into subgraphs.

Remarks

This value is used if PartitionMethod is set to Custom.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
CustomLayout Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.DefaultMarginValue Property

CompositeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.DesiredSubgraphSize Property

CompositeLayout.DesiredSubgraphSize Property
[image]

Gets or sets the preferred number of vertices in the partitions allocated by the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int DesiredSubgraphSize { get; set; }

Visual Basic [image] Copy Code

Public Property DesiredSubgraphSize As Integer

Property Value

An integer value specifying the desired number of nodes in each subgraph.

Remarks

This property is considered by the automatic partitioning algorithm when generating subgraphs. Usually the subgraphs won't contain exactly as many nodes, but are within the Tolerance range around the property value.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.EmphasizeTrees Property

CompositeLayout.EmphasizeTrees Property
[image]

Gets or sets a value indicating whether the cut-vertices of tree subgraphs are added to the corresponding trees.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EmphasizeTrees { get; set; }

Visual Basic [image] Copy Code

Public Property EmphasizeTrees As Boolean

Property Value

true to add cut-vertices to trees, otherwise false. The default value is true.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
SubtreeLayout Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.KeepVirtualItems Property

CompositeLayout.KeepVirtualItems Property
[image]

Gets or sets a value indicating whether to keep the intermediate virtual nodes and links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepVirtualItems { get; set; }

Visual Basic [image] Copy Code

Public Property KeepVirtualItems As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.MasterLayout Property

CompositeLayout.MasterLayout Property
[image]

Gets or sets a layout that should be applied globally to the graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Layout MasterLayout { get; set; }

Visual Basic [image] Copy Code

Public Property MasterLayout As Layout

Property Value

An instance of Layout-derived class. The default is AnnealLayout.

Remarks

Each subset in the layout partition is considered a node in a graph representing the diagram. MasterLayout is used to arrange that graph, while SubgraphLayout and SubtreeLayout are applied on the partition subsets. Since in the general case subsets will occupy areas of varying size, MasterLayout should be set to an instance of a layout class that can handle nodes of non-uniform dimensions.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.Name Property

CompositeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Composite layout".

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.PartitionMethod Property

CompositeLayout.PartitionMethod Property
[image]

Gets or sets the partitioning method used to decompose the diagram into subgraphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PartitionMethod PartitionMethod { get; set; }

Visual Basic [image] Copy Code

Public Property PartitionMethod As PartitionMethod

Property Value

A member of the PartitionMethod enumeration. The default value is BiconnectedComponents.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
CustomPartition Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.RotateSubgraphs Property

CompositeLayout.RotateSubgraphs Property
[image]

Gets or sets a value indicating whether subgraphs are rotated to minimize intersections with cross-partition links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RotateSubgraphs { get; set; }

Visual Basic [image] Copy Code

Public Property RotateSubgraphs As Boolean

Property Value

true to rotate subgraphs, otherwise false. The default value is false.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.SubgraphLayout Property

CompositeLayout.SubgraphLayout Property
[image]

Gets or sets a layout that should be applied to general subgraphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Layout SubgraphLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubgraphLayout As Layout

Property Value

An instance of Layout-derived class. The default is CircularLayout.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
MasterLayout Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.SubtreeLayout Property

CompositeLayout.SubtreeLayout Property
[image]

Gets or sets a layout that should be applied to subgraphs representing trees.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Layout SubtreeLayout { get; set; }

Visual Basic [image] Copy Code

Public Property SubtreeLayout As Layout

Property Value

An instance of Layout-derived class. The default is radial TreeLayout.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
MasterLayout Property
SubgraphLayout Property
PartitionMethod Property


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.Tolerance Property

CompositeLayout.Tolerance Property
[image]

A multiplier applied to DesiredSubgraphSize to define the allowed subgraph size range.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Tolerance { get; set; }

Visual Basic [image] Copy Code

Public Property Tolerance As Double

Property Value

A double value specifying the tolerance range. The default is 0.2.

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.CompositeLayout.UseAdditionalPartitioning Property

CompositeLayout.UseAdditionalPartitioning Property
[image]

Gets or sets a value indicating whether to use an additional partitioning pass on the result of the initial partitioning. This additional partitioning is simplified - it only looks for trees with depth 2.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool UseAdditionalPartitioning { get; set; }

Visual Basic [image] Copy Code

Public Property UseAdditionalPartitioning As Boolean

Property Value

See Also

CompositeLayout Members
CompositeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout Class

DecisionLayout Class
Remarks See Also
[image]

Implements a decision graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class DecisionLayout : Layout

Visual Basic [image] Copy Code

Public Class DecisionLayout
Inherits Layout

Remarks

This algorithm arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding.

The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

The overall orientation of the layout can be set via the Orientation property. There is no distinction made between yes/no links, and the node sides by which links are aligned depend only on the order of links in OutgoingLinks collection. If you have a preferred position for links depending on their yes/no type, make sure the OutgoingLinks collections of nodes are sorted by links' logical values.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.DecisionLayout

See Also

DecisionLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace
FlowchartLayout Class


MindFusion.Diagramming.Wpf.Layout.DecisionLayout Members

DecisionLayout Members
Constructors Properties Methods
[image]

Implements a decision graph layout algorithm.

The following tables list the members exposed by the DecisionLayout type.

Public Constructors

Name | Description
DecisionLayout | Initializes a new instance of the DecisionLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout Constructor

DecisionLayout Constructor
[image]

Initializes a new instance of the DecisionLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DecisionLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout Properties

DecisionLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.DefaultMarginValue Property

DecisionLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.HorizontalPadding Property

DecisionLayout.HorizontalPadding Property
[image]

Gets or sets the horizontal distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HorizontalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same row. The default value is 45.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.LinkPadding Property

DecisionLayout.LinkPadding Property
[image]

Gets or sets the distance between parallel links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between links that share the same row or column. The default value is 6.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.Name Property

DecisionLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Decision layout".

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.Orientation Property

DecisionLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration specifying the overall layout orientation. The default value is Vertical.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.StartNode Property

DecisionLayout.StartNode Property
[image]

Gets or sets the initial (top-left) node in the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode instance specifying the start node.

Remarks

If this property is null, the layout will pick-up the start node automatically.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.DecisionLayout.VerticalPadding Property

DecisionLayout.VerticalPadding Property
[image]

Gets or sets the vertical distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double VerticalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same column. The default value is 45.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Direction Enumeration

Direction Enumeration
[image]

Specifies a layout direction.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Direction

Visual Basic [image] Copy Code

Public Enum Direction

Members

Member name | Description
Reversed | Indicates either right-to-left or bottom-to-top direction.
Straight | Indicates either left-to-right or top-to-bottom direction.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout Class

FlowchartLayout Class
Remarks See Also
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FlowchartLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowchartLayout
Inherits Layout

Remarks

The algorithm recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.FlowchartLayout

See Also

FlowchartLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout Members

FlowchartLayout Members
Constructors Properties Methods
[image]

FlowchartLayout can be used to arrange flowcharts representing program source code.

The following tables list the members exposed by the FlowchartLayout type.

Public Constructors

Name | Description
FlowchartLayout | Initializes a new instance of the FlowchartLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout Constructor

FlowchartLayout Constructor
[image]

Initializes a new instance of the FlowchartLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FlowchartLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout Properties

FlowchartLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.BranchPadding Property

FlowchartLayout.BranchPadding Property
[image]

Gets or sets how much space to leave between adjacent decision branches in the flowchart.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double BranchPadding { get; set; }

Visual Basic [image] Copy Code

Public Property BranchPadding As Double

Property Value

A double value specifying the distance between adjacent branches.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.DefaultMarginValue Property

FlowchartLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.IgnoreRepeatingLinks Property

FlowchartLayout.IgnoreRepeatingLinks Property
[image]

Gets or sets a value indicating whether to ignore repeating links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IgnoreRepeatingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreRepeatingLinks As Boolean

Property Value

true to ignore repeating links, otherwise false. The default value is false.

Remarks

If there are many links connecting the same pair of nodes in the same direction, the analysis of the inherent flowchart structure might fail. In such cases, set this property to true.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.LinkPadding Property

FlowchartLayout.LinkPadding Property
[image]

Gets or sets how much space to leave between adjacent back links designating nested loops.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between adjacent back links. The default value is 15.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.Name Property

FlowchartLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Flowchart layout".

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.NodeDistance Property

FlowchartLayout.NodeDistance Property
[image]

Gets or sets the distance between consecutive nodes in the flowchart.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between neighbor nodes in the same sequence.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.Orientation Property

FlowchartLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowchartLayout.SplitGraph Property

FlowchartLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own, otherwise false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout Class

FlowLayout Class
Remarks See Also
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FlowLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowLayout
Inherits Layout

Remarks

The FlowLayout algorithm can be used to lay out flowcharts, workflow and process diagrams. It works by applying a customizable set of rules for local positioning of connected nodes relatively to each other. On a larger scale, the algorithm keeps groups of nodes separate and prevents links between the groups from crossing nodes. The FlowLayout and ProcessLayout examples included in the MindFusion.Diagramming for WPF package demonstrate two sample sets of layout rules.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.FlowLayout

See Also

FlowLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace
DecisionLayout Class


MindFusion.Diagramming.Wpf.Layout.FlowLayout Members

FlowLayout Members
Constructors Properties Methods
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

The following tables list the members exposed by the FlowLayout type.

Public Constructors

Name | Description
FlowLayout | Initializes a new instance of the FlowLayout class.

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneOffsetX | Gets or sets the desired distance between nodes and lanes' border.
LaneOffsetY | Gets or sets the desired distance between nodes and lanes' border.
Lanes | Returns a list of layout lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LayoutRules | Gets or sets the rules for the layout.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
LinksToRoute | Gets all links, which needs additional route.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinLaneHight | Gets or sets the minimal Lane's hight
MultipleGraphsPlacement | Not supported by FlowLayout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
ProcessOffset | Gets or sets the horizontal subgroup offset.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Defines whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming for WPF diagram.
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
SubLaneOffsetY | Gets or sets the desired distance between nodes and sub lanes' border.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
Arrange | Overloaded.
ArrangeAsync | Overloaded. (Inherited from Layout.)
ArrangeCore | Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.
BendLinks | Bends all links in an already arranged diagram.
InsertLane | Overloaded.
InsertNode | Inserts the specified node between two nodes connected by the specified link.
RemoveLane | Overloaded.
RemoveNode | Removes the specified node from an existing diagram.

See Also

FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout Constructor

FlowLayout Constructor
[image]

Initializes a new instance of the FlowLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FlowLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout Methods

FlowLayout Methods
[image]

Public Methods

Name | Description
AddNode | Adds the specified node to the already arranged diagram.
Arrange | Overloaded.
ArrangeAsync | Overloaded. (Inherited from Layout.)
ArrangeCore | Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.
BendLinks | Bends all links in an already arranged diagram.
InsertLane | Overloaded.
InsertNode | Inserts the specified node between two nodes connected by the specified link.
RemoveLane | Overloaded.
RemoveNode | Removes the specified node from an existing diagram.

See Also

FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.AddNode Method

FlowLayout.AddNode Method
[image]

Adds the specified node to the already arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddNode (
DiagramNode node,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function AddNode( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
A DiagramNode instance.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use AddNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added by a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Arrange Method

FlowLayout.Arrange Method
[image]

Overload List

Name | Description
FlowLayout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of items from the specified Diagram instance.
FlowLayout.Arrange (Diagram, Rect[]) | Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Arrange Method (Diagram, DiagramItemCollection)

FlowLayout.Arrange Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Overrides Function Arrange ( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram to arrange.
items

Specifies a subset of diagram items to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Arrange Method (Diagram, Rect[])

FlowLayout.Arrange Method (Diagram, Rect[])
See Also
[image]

Applies the layout to the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram,
Rect[] laneBorders
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram, _
laneBorders() As Rect _
) As Boolean

Parameters

diagram
The Diagram to arrange.
laneBorders

An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.ArrangeCore Method

FlowLayout.ArrangeCore Method
[image]

Applies the layout to the specified subset of items from the specified Diagram instance and an array of rectangles defining custom lane borders.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ArrangeCore (
Diagram diagram,
DiagramItemCollection items,
Rect[] laneBorders
)

Visual Basic [image] Copy Code

Public Function ArrangeCore( _
diagram As Diagram, _
items As DiagramItemCollection, _
laneBorders() As Rect _
) As Boolean

Parameters

diagram

The Diagram to arrange.

items

Specifies a subset of diagram items to arrange.

laneBorders

An array of rectangles defining custom lane borders.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.BendLinks Method

FlowLayout.BendLinks Method
[image]

Bends all links in an already arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void BendLinks (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub BendLinks( _
diagram As Diagram _
)

Parameters

diagram
A Diagram instance.

Remarks

You can use BendLinks to implement incremental layout of a diagram, for example, by calling it after the user draws a new link, or after several new links are added programmatically. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.InsertLane Method

FlowLayout.InsertLane Method
[image]

Overload List

Name | Description
FlowLayout.InsertLane (DiagramNode, Int32, Diagram) | Inserts new lane box
FlowLayout.InsertLane (Header, Diagram) | Inserts new lane

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.InsertLane Method (DiagramNode, Int32, Diagram)

FlowLayout.InsertLane Method (DiagramNode, Int32, Diagram)
See Also
[image]

Inserts new lane box

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool InsertLane (
DiagramNode node,
int indx,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function InsertLane( _
node As DiagramNode, _
indx As Integer, _
diagram As Diagram _
) As Boolean

Parameters

node

indx

diagram

Return Value

See Also

InsertLane Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.InsertLane Method (Header, Diagram)

FlowLayout.InsertLane Method (Header, Diagram)
See Also
[image]

Inserts new lane

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool InsertLane (
Header header,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function InsertLane( _
header As Header, _
diagram As Diagram _
) As Boolean

Parameters

header

diagram

Return Value

See Also

InsertLane Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.InsertNode Method

FlowLayout.InsertNode Method
[image]

Inserts the specified node between two nodes connected by the specified link.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool InsertNode (
DiagramNode node,
DiagramLink linkToSplit,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function InsertNode( _
node As DiagramNode, _
linkToSplit As DiagramLink, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to insert.
linkToSplit
The DiagramLink to split.
diagram
A Diagram instance.

Return Value

true if the node has been added successfully; otherwise, false.

Remarks

You can use InsertNode to implement incremental layout of a diagram, for example, by adding new nodes drawn by the user or added by a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RemoveLane Method

FlowLayout.RemoveLane Method
[image]

Overload List

Name | Description
FlowLayout.RemoveLane (DiagramNode, Int32, Diagram) | Removes lane box
FlowLayout.RemoveLane (Header, Diagram) | Removes selected lane from laneGrid

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RemoveLane Method (DiagramNode, Int32, Diagram)

FlowLayout.RemoveLane Method (DiagramNode, Int32, Diagram)
See Also
[image]

Removes lane box

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RemoveLane (
DiagramNode node,
int indx,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function RemoveLane( _
node As DiagramNode, _
indx As Integer, _
diagram As Diagram _
) As Boolean

Parameters

node

indx

diagram

Return Value

See Also

RemoveLane Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RemoveLane Method (Header, Diagram)

FlowLayout.RemoveLane Method (Header, Diagram)
See Also
[image]

Removes selected lane from laneGrid

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RemoveLane (
Header header,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function RemoveLane( _
header As Header, _
diagram As Diagram _
) As Boolean

Parameters

header

diagram

Return Value

See Also

RemoveLane Method Overload List
FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RemoveNode Method

FlowLayout.RemoveNode Method
[image]

Removes the specified node from an existing diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RemoveNode (
DiagramNode node,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Function RemoveNode( _
node As DiagramNode, _
diagram As Diagram _
) As Boolean

Parameters

node
The DiagramNode to remove.
diagram
An already arranged Diagram.

Return Value

true if the node has been removed successfully; otherwise, false.

Remarks

You can use RemoveNode to implement incremental layout of a diagram, for example, by removing nodes deleted by the user or removed by a context menu command. For this method to work correctly, RecreateGraph must be disabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout Properties

FlowLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Not supported by FlowLayout.
AutoRoute | Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.
ChangeLaneDimensions | Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HorizontalGroupOffset | Gets or sets the horizontal subgroup offset.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LaneBoundaries | Gets or sets the array of custom lane borders.
LaneDistance | Gets or sets the desired distance between adjacent lanes.
LaneOffsetX | Gets or sets the desired distance between nodes and lanes' border.
LaneOffsetY | Gets or sets the desired distance between nodes and lanes' border.
Lanes | Returns a list of layout lanes.
LaneType | Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LayoutRules | Gets or sets the rules for the layout.
LinksBend | Specifies whether links between non-adjacent nodes should bend.
LinksToRoute | Gets all links, which needs additional route.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinLaneHight | Gets or sets the minimal Lane's hight
MultipleGraphsPlacement | Not supported by FlowLayout.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
ProcessOffset | Gets or sets the horizontal subgroup offset.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RecreateGraph | Defines whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming for WPF diagram.
Root | Gets or sets the node specifying which subgraph of the diagram should be laid out.
SubLaneOffsetY | Gets or sets the desired distance between nodes and sub lanes' border.
VerticalGroupOffset | Gets or sets the vertical subgroup offset.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Anchoring Property

FlowLayout.Anchoring Property
[image]

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Anchoring As Anchoring

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.AutoRoute Property

FlowLayout.AutoRoute Property
[image]

Gets or sets a value indicating whether longer links should be routed to avoid crossing the diagram nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to look for link routes that do not cross nodes; otherwise, false. The default is false.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.ChangeLaneDimensions Property

FlowLayout.ChangeLaneDimensions Property
[image]

Gets or sets a value indicating whether the layout algorithm is allowed to change the initial Lane dimensions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ChangeLaneDimensions { get; set; }

Visual Basic [image] Copy Code

Public Property ChangeLaneDimensions As Boolean

Property Value

true if the algorithm is allowed to change the lane dimensions; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.DefaultMarginValue Property

FlowLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.HorizontalGroupOffset Property

FlowLayout.HorizontalGroupOffset Property
[image]

Gets or sets the horizontal subgroup offset.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double HorizontalGroupOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalGroupOffset As Double

Property Value

A value specifying the horizontal distance between groups of nodes. The default is 25.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LaneBoundaries Property

FlowLayout.LaneBoundaries Property
[image]

Gets or sets the array of custom lane borders.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect[] LaneBoundaries { get; set; }

Visual Basic [image] Copy Code

Public Property LaneBoundaries As Rect()

Property Value

An array of rectangles specifying custom lane borders.

Remarks

This array is used when LaneType is set to Custom.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LaneDistance Property

FlowLayout.LaneDistance Property
[image]

Gets or sets the desired distance between adjacent lanes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Double

Property Value

A double value specifying the distance between lanes. The default is 0.

Remarks

The lanes are placed at the specified distance from each other only if ChangeLaneDimensions is enabled.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LaneOffsetX Property

FlowLayout.LaneOffsetX Property
[image]

Gets or sets the desired distance between nodes and lanes' border.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LaneOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property LaneOffsetX As Double

Property Value

Remarks

The nodes are placed at the specified distance from lane's border

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LaneOffsetY Property

FlowLayout.LaneOffsetY Property
[image]

Gets or sets the desired distance between nodes and lanes' border.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LaneOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property LaneOffsetY As Double

Property Value

Remarks

The nodes are placed at the specified distance from lane's border

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Lanes Property

FlowLayout.Lanes Property
[image]

Returns a list of layout lanes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArrayList Lanes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Lanes As ArrayList

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LaneType Property

FlowLayout.LaneType Property
[image]

Gets or sets a value indicating how process diagram swimlanes are defined in the current Diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LaneType LaneType { get; set; }

Visual Basic [image] Copy Code

Public Property LaneType As LaneType

Property Value

A member of the LaneType enumeration. The default is LaneNodes.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LayoutRules Property

FlowLayout.LayoutRules Property
[image]

Gets or sets the rules for the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FlowLayoutRules LayoutRules { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutRules As FlowLayoutRules

Property Value

An instance of the FlowLayoutRules class.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LinksBend Property

FlowLayout.LinksBend Property
[image]

Specifies whether links between non-adjacent nodes should bend.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool LinksBend { get; set; }

Visual Basic [image] Copy Code

Public Property LinksBend As Boolean

Property Value

true is links should bend; otherwise, false. The default is true.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.LinksToRoute Property

FlowLayout.LinksToRoute Property
[image]

Gets all links, which needs additional route.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramLinkCollection LinksToRoute { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinksToRoute As DiagramLinkCollection

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.MinLaneHight Property

FlowLayout.MinLaneHight Property
[image]

Gets or sets the minimal Lane's hight

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MinLaneHight { get; set; }

Visual Basic [image] Copy Code

Public Property MinLaneHight As Double

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.MultipleGraphsPlacement Property

FlowLayout.MultipleGraphsPlacement Property
[image]

Not supported by FlowLayout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Name Property

FlowLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Flow layout".

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.NodeDistance Property

FlowLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the desired distance between nodes. The default is 4.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.ProcessOffset Property

FlowLayout.ProcessOffset Property
[image]

Gets or sets the horizontal subgroup offset.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ProcessOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ProcessOffset As Double

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RandomSeed Property

FlowLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.RecreateGraph Property

FlowLayout.RecreateGraph Property
[image]

Defines whether the layout algorithm should recreate its internal graph representation for the MindFusion.Diagramming for WPF diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RecreateGraph { get; set; }

Visual Basic [image] Copy Code

Public Property RecreateGraph As Boolean

Property Value

true if the graph representation should be recreated when Arrange executes, otherwise, false. The default is false.

Remarks

Keep this property set to false if you wish to use the AddNode and InsertNode methods to implement incremental layout.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.Root Property

FlowLayout.Root Property
[image]

Gets or sets the node specifying which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.SubLaneOffsetY Property

FlowLayout.SubLaneOffsetY Property
[image]

Gets or sets the desired distance between nodes and sub lanes' border.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double SubLaneOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property SubLaneOffsetY As Double

Property Value

Remarks

The nodes are placed at the specified distance from sub lane's border

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FlowLayout.VerticalGroupOffset Property

FlowLayout.VerticalGroupOffset Property
[image]

Gets or sets the vertical subgroup offset.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double VerticalGroupOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalGroupOffset As Double

Property Value

A value specifying the vertical distance between groups of nodes. The default is 70.

See Also

FlowLayout Members
FlowLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout Class

FractalLayout Class
Remarks See Also
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FractalLayout : Layout

Visual Basic [image] Copy Code

Public Class FractalLayout
Inherits Layout

Remarks

Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.FractalLayout

See Also

FractalLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout Members

FractalLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

The following tables list the members exposed by the FractalLayout type.

Public Constructors

Name | Description
FractalLayout | Initializes a new instance of the FractalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout Constructor

FractalLayout Constructor
[image]

Initializes a new instance of the FractalLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FractalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout Properties

FractalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout.DefaultMarginValue Property

FractalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout.Name Property

FractalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Fractal layout".

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.FractalLayout.Root Property

FractalLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

A DiagramNode that should be placed at the center of the arranged tree. The default value is null.

Remarks

If there is no root specified, the algorithm automatically selects one that will lead to more balanced branch sizes.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout Class

GridLayout Class
Remarks See Also
[image]

Implements a grid graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class GridLayout : Layout

Visual Basic [image] Copy Code

Public Class GridLayout
Inherits Layout

Remarks

GridLayout arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The distance between points in the layout grid can be changed by GridSize. Nodes to be placed at the upper-left and lower-right corners of the grid can be assigned to StartNode and EndNode.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.GridLayout

See Also

GridLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout Members

GridLayout Members
Constructors Properties Methods
[image]

Implements a grid graph layout algorithm.

The following tables list the members exposed by the GridLayout type.

Public Constructors

Name | Description
GridLayout | Initializes a new instance of the GridLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout Constructor

GridLayout Constructor
[image]

Initializes a new instance of the GridLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public GridLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout Properties

GridLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.DefaultMarginValue Property

GridLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.EndNode Property

GridLayout.EndNode Property
[image]

Gets or sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As Object

Property Value

An instance of the DiagramNode class. Default value is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then StartNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.GridSize Property

GridLayout.GridSize Property
[image]

Gets or sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double number specifying the grid size. The default is 96.

Remarks

When placing a node at a grid position, the node center point is aligned to the grid point at that position.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.Iterations Property

GridLayout.Iterations Property
[image]

Gets or sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int Iterations { get; set; }

Visual Basic [image] Copy Code

Public Property Iterations As Integer

Property Value

An integer number specifying the number of iterations. The default is 3000.

Remarks

More iterations would yield better layouts but require more time to complete.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Progress Property


MindFusion.Diagramming.Wpf.Layout.GridLayout.Name Property

GridLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Grid layout".

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.RandomSeed Property

GridLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.Root Property

GridLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.SplitGraph Property

GridLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to split the graph; otherwise, false.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.StartNode Property

GridLayout.StartNode Property
[image]

Gets or sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As Object

Property Value

An instance of the DiagramNode class. The default is null (Nothing in Visual Basic).

Remarks

If you assign a node to that property, then EndNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.TimeLimit Property

GridLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The grid layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a path long enough to produce a nice layout.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.GridLayout.UseLongestPath Property

GridLayout.UseLongestPath Property
[image]

Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool UseLongestPath { get; set; }

Visual Basic [image] Copy Code

Public Property UseLongestPath As Boolean

Property Value

true to look for the longest path in the graph and arrange nodes around it; otherwise, false.

Remarks

Initially, the algorithm places nodes and links from the longest path in the graph at the grid diagonal, and arranges the rest of the nodes around the diagonal. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. Disabling this property will let you skip the path-finding part of the algorithm, which will make it work much faster.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout Class

HierarchicalLayout Class
Remarks See Also
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class HierarchicalLayout : Layout

Visual Basic [image] Copy Code

Public Class HierarchicalLayout
Inherits Layout

Remarks

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and will not intersect. A graph is considered level-planar if it is possible to draw it without link intersections when its nodes are positioned on predefined levels. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout

See Also

HierarchicalLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout Members

HierarchicalLayout Members
Constructors Properties Methods
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

The following tables list the members exposed by the HierarchicalLayout type.

Public Constructors

Name | Description
HierarchicalLayout | Initializes a new instance of the HierarchicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout Constructor

HierarchicalLayout Constructor
[image]

Initializes a new instance of the HierarchicalLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public HierarchicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout Properties

HierarchicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout.DefaultMarginValue Property

HierarchicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout.LevelDistance Property

HierarchicalLayout.LevelDistance Property
[image]

Gets or sets the distance between adjacent levels in the hierarchical layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

The default value is 150.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout.LinkBendFactor Property

HierarchicalLayout.LinkBendFactor Property
[image]

Gets or sets the bending factor of links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkBendFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBendFactor As Double

Property Value

The default value is 1.

Remarks

A value of 1 indicates that the links should not bend. A value less than 1 indicates that the links should bend towards the geometric center of the graph. A value greater than 1 indicates that the links should bend outwards.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout.Name Property

HierarchicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Hierarchical layout".

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout.Orientation Property

HierarchicalLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout Interface

ILayout Interface
[image]

Common interface for all MindFusion.Diagramming for WPF layouters.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface ILayout

Visual Basic [image] Copy Code

Public Interface ILayout

Inheritors

MindFusion.Diagramming.Wpf.Layout.Layout

See Also

ILayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout Members

ILayout Members
Properties Methods
[image]

Common interface for all MindFusion.Diagramming for WPF layouters.

The following tables list the members exposed by the ILayout type.

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Public Methods

Name | Description
Arrange | Overloaded.

See Also

ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout Methods

ILayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded.

See Also

ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout.Arrange Method

ILayout.Arrange Method
[image]

Overload List

Name | Description
ILayout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
ILayout.Arrange (VirtualizingDiagram) | Applies the layout to the specified VirtualizingDiagram instance.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout.Arrange Method (Diagram)

ILayout.Arrange Method (Diagram)
See Also
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Function Arrange( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

Arrange Method Overload List
ILayout Members
ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout.Arrange Method (VirtualizingDiagram)

ILayout.Arrange Method (VirtualizingDiagram)
See Also
[image]

Applies the layout to the specified VirtualizingDiagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

bool Arrange (
VirtualizingDiagram diagram
)

Visual Basic [image] Copy Code

Function Arrange( _
diagram As VirtualizingDiagram _
) As Boolean

Parameters

diagram

The VirtualizingDiagram that should be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

Arrange Method Overload List
ILayout Members
ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout Properties

ILayout Properties
[image]

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

See Also

ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout.LayoutLink Property

ILayout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ILayout.LayoutNode Property

ILayout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid Interface

ISwimlaneGrid Interface
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface ISwimlaneGrid

Visual Basic [image] Copy Code

Public Interface ISwimlaneGrid

Inheritors

MindFusion.Diagramming.Wpf.Layout.LaneGrid

See Also

ISwimlaneGrid Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid Members

ISwimlaneGrid Members
Methods
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

The following tables list the members exposed by the ISwimlaneGrid type.

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid Methods

ISwimlaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.GetColumnCount Method

ISwimlaneGrid.GetColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

int GetColumnCount ()

Visual Basic [image] Copy Code

Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.GetColumnWidth Method

ISwimlaneGrid.GetColumnWidth Method
[image]

Gets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the column.

Return Value

The width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.GetRowCount Method

ISwimlaneGrid.GetRowCount Method
[image]

Gets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

int GetRowCount ()

Visual Basic [image] Copy Code

Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.GetRowHeight Method

ISwimlaneGrid.GetRowHeight Method
[image]

Gets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the row.

Return Value

The height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetColumnCount Method

ISwimlaneGrid.SetColumnCount Method
[image]

Sets the number of columns in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Sub SetColumnCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of columns.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetColumnWidth Method

ISwimlaneGrid.SetColumnWidth Method
[image]

Sets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the column.

value

The new width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetLeftMargin Method

ISwimlaneGrid.SetLeftMargin Method
[image]

Sets the left margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetLeftMargin( _
value As Double _
)

Parameters

value

The distance between the left side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetRowCount Method

ISwimlaneGrid.SetRowCount Method
[image]

Sets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Sub SetRowCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of rows.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetRowHeight Method

ISwimlaneGrid.SetRowHeight Method
[image]

Sets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the row.

value

The new height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.ISwimlaneGrid.SetTopMargin Method

ISwimlaneGrid.SetTopMargin Method
[image]

Sets the top margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetTopMargin( _
value As Double _
)

Parameters

value

The distance between the top side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid Class

LaneGrid Class
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LaneGrid : ISwimlaneGrid

Visual Basic [image] Copy Code

Public Class LaneGrid
Implements ISwimlaneGrid

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.LaneGrid

See Also

LaneGrid Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid Members

LaneGrid Members
Constructors Methods
[image]

Represents an ISwimlaneGrid which operates on a MindFusion.Diagramming.Lanes.Grid object.

The following tables list the members exposed by the LaneGrid type.

Public Constructors

Name | Description
LaneGrid | Initializes a new instance of the LaneGrid class.

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid Constructor

LaneGrid Constructor
[image]

Initializes a new instance of the LaneGrid class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LaneGrid (
Grid grid
)

Visual Basic [image] Copy Code

Public New ( _
grid As Grid _
)

Parameters

grid

See Also

LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid Methods

LaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.GetColumnCount Method

LaneGrid.GetColumnCount Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetColumnCount ()

Visual Basic [image] Copy Code

Public Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.GetColumnWidth Method

LaneGrid.GetColumnWidth Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index
The zero-based index of the column.

Return Value

The width of the column.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.GetRowCount Method

LaneGrid.GetRowCount Method
[image]

ISwimlaneGrid.GetRowCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int GetRowCount ()

Visual Basic [image] Copy Code

Public Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.GetRowHeight Method

LaneGrid.GetRowHeight Method
[image]

ISwimlaneGrid.GetRowHeight implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Public Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index
The zero-based index of the row.

Return Value

The height of the row.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetColumnCount Method

LaneGrid.SetColumnCount Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetColumnCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetColumnWidth Method

LaneGrid.SetColumnWidth Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetLeftMargin Method

LaneGrid.SetLeftMargin Method
[image]

ISwimlaneGrid.SetLeftMargin implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetLeftMargin( _
value As Double _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetRowCount Method

LaneGrid.SetRowCount Method
[image]

ISwimlaneGrid.SetRowCount implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetRowCount( _
value As Integer _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetRowHeight Method

LaneGrid.SetRowHeight Method
[image]

ISwimlaneGrid.SetRowHeight implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneGrid.SetTopMargin Method

LaneGrid.SetTopMargin Method
[image]

ISwimlaneGrid.SetTopMargin implementation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetTopMargin( _
value As Double _
)

Parameters

value

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LaneType Enumeration

LaneType Enumeration
[image]

Specifies where FlowLayout gets the swimlane dimensions from.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LaneType

Visual Basic [image] Copy Code

Public Enum LaneType

Members

Member name | Description
Custom | FlowLayout gets the swimlane dimensions from the array of rectangles passed as an argument to Arrange.
LaneGrid | FlowLayout gets the swimlane dimensions from Diagram.LaneGrid.
LaneNodes | FlowLayout interprets locked background nodes as swimlanes.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Class

LayeredLayout Class
Remarks See Also
[image]

Implements a layered graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LayeredLayout : Layout

Visual Basic [image] Copy Code

Public Class LayeredLayout
Inherits Layout

Remarks

This algorithm assigns diagram nodes to distinct horizontal or vertical layers. While arranging the layers, the layout routine seeks to meet the following criteria:

  • connected nodes must be placed close together;
  • links must flow in one direction if possible;
  • links must cross as few layers as possible;
  • links must not cross other links;

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The final appearance of arranged graphs depends mostly on the Orientation and Direction properties which define the overall orientation of the layout. The LayerDistance and NodeDistance properties specify how much space to leave between adjacent layers and adjacent nodes in a layer.

The performance of LayeredLayout is dependent on the number of links in the diagram. At its first stage, the algorithm looks for the longest sequence of links in the graph and builds the node layers along it. That stage can be the most time consuming if there are a lot of links in a graph, so there is the TimeLimit property provided to control how much time the layout routine is allowed to spend on path-finding. Next, if there are layers much longer than the other ones and SplitLayers is enabled, nodes from these layers are moved to new ones so the graph width is uniformly distributed.

The layout routine continues by shuffling nodes and link points across their layers, so the criteria mentioned above are approximated. Finally, link ends are aligned to anchor points if Anchoring is enabled and the distance between outermost links is decreased as set in LinksCompactFactor.

The layered graph layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.LayeredLayout

See Also

LayeredLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Members

LayeredLayout Members
Constructors Properties Methods
[image]

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Overloaded.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ConsiderNodeShapes | Gets or sets whether to align link end points to non-rectangular node borders.
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Specifies whether the layout algorithm should ignore the size of nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLinkShapes | Gets or sets whether to preserve initial Shape value of links when LinkType is set to Cascading. The orthogonal path applied by latter property is approximated using respective link shape.
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel cascading links.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Constructor

LayeredLayout Constructor
[image]

Overload List

Name | Description
LayeredLayout () | Initializes a new instance of the LayeredLayout class with the default settings.
LayeredLayout (Orientation, Double, Double, Size) | Initializes a new instance of the LayeredLayout class with the specified settings.

See Also

LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Constructor ()

LayeredLayout Constructor ()
See Also
[image]

Initializes a new instance of the LayeredLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayeredLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Constructor (Orientation, Double, Double, Size)

LayeredLayout Constructor (Orientation, Double, Double, Size)
See Also
[image]

Initializes a new instance of the LayeredLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayeredLayout (
Orientation orientation,
double layerDistance,
double nodeDistance,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
orientation As Orientation, _
layerDistance As Double, _
nodeDistance As Double, _
margins As Size _
)

Parameters

orientation

The orientation of the layout.

layerDistance

The distance between adjacent layers.

nodeDistance

The distance between adjacent nodes within the same layer.

margins

The margin between the produced graph and the left side of the diagram bounding rectangle.

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout Properties

LayeredLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ConsiderNodeShapes | Gets or sets whether to align link end points to non-rectangular node borders.
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Specifies whether the layout algorithm should ignore the size of nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLinkShapes | Gets or sets whether to preserve initial Shape value of links when LinkType is set to Cascading. The orthogonal path applied by latter property is approximated using respective link shape.
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel cascading links.
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost links.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.ConsiderNodeShapes Property

LayeredLayout.ConsiderNodeShapes Property
[image]

Gets or sets whether to align link end points to non-rectangular node borders.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ConsiderNodeShapes { get; set; }

Visual Basic [image] Copy Code

Public Property ConsiderNodeShapes As Boolean

Property Value

true to place link end points on shape outlines, or false otherwise.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.DefaultMarginValue Property

LayeredLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.Direction Property

LayeredLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.EnableCustomLayers Property

LayeredLayout.EnableCustomLayers Property
[image]

Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableCustomLayers { get; set; }

Visual Basic [image] Copy Code

Public Property EnableCustomLayers As Boolean

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.EndNode Property

LayeredLayout.EndNode Property
[image]

Gets or sets the node that should be placed in the last layer of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As Object

Property Value

A DiagramNode object representing the end node.

Remarks

This value is honored only if StartNode is specified too.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.EnforceLinkFlow Property

LayeredLayout.EnforceLinkFlow Property
[image]

Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnforceLinkFlow { get; set; }

Visual Basic [image] Copy Code

Public Property EnforceLinkFlow As Boolean

Property Value

Remarks

EnableCustomLayers and SplitLayers are ignored if this property is set to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
StraightenLongLinks Property


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.IgnoreNodeSize Property

LayeredLayout.IgnoreNodeSize Property
[image]

Specifies whether the layout algorithm should ignore the size of nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IgnoreNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreNodeSize As Boolean

Property Value

true to ignore the node size; otherwise, false. The default is true.

Remarks

At this time, considering the size of nodes deteriorates the performance of the algorithm, so that's disabled by default.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.KeepLinkShapes Property

LayeredLayout.KeepLinkShapes Property
[image]

Gets or sets whether to preserve initial Shape value of links when LinkType is set to Cascading. The orthogonal path applied by latter property is approximated using respective link shape.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepLinkShapes { get; set; }

Visual Basic [image] Copy Code

Public Property KeepLinkShapes As Boolean

Property Value

true to keep original link Shape, or false otherwise.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.KeepRootPosition Property

LayeredLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to preserve the position of the root node.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.LayerDistance Property

LayeredLayout.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value specifying the distance between layers. The default is 64.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.LinkPadding Property

LayeredLayout.LinkPadding Property
[image]

Gets or sets the distance between parallel cascading links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying distance between adjacent links.

Remarks

This value is considered only when LinkType is set to Cascading.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.LinksCompactFactor Property

LayeredLayout.LinksCompactFactor Property
[image]

Gets or sets a value indicating how much to compact the outermost links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinksCompactFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinksCompactFactor As Double

Property Value

A double number in the interval [0, 1]. The default is 1.

Remarks

Links and nodes on the same graph layer are distributed uniformly as specified bya the NodeDistance value. However, if there are more than 2-3 outermost links on a layer, they usually take up too much space without improving the visual quality of the diagram layout. This property allows compacting such links to save space. The factor specifies roughly a fraction of NodeDistance to leave between outer links.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.LinkType Property

LayeredLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayeredLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As LayeredLayoutLinkType

Property Value

A member of the LayeredLayoutLinkType enumeration. The default is Straight.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
StraightenLongLinks Property


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.Name Property

LayeredLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Layered layout".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.NodeDistance Property

LayeredLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes. The default is 96.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.Orientation Property

LayeredLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical .

Remarks

Specify Orientation.Vertical to have links flow in vertical direction and Orientation.Horizontal to have links flow in horizontal direction. The orientation of the resulting layers is opposite to that of the links. Thus, if the link tends to go in a vertical direction, the nodes are distributed in horizontal layers.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Direction Property


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.Root Property

LayeredLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph containing it is laid out by Arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.SplitLayers Property

LayeredLayout.SplitLayers Property
[image]

Gets or sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitLayers { get; set; }

Visual Basic [image] Copy Code

Public Property SplitLayers As Boolean

Property Value

true to split wide layers; otherwise, false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.StableSort Property

LayeredLayout.StableSort Property
[image]

Gets or sets a value indicating whether to apply stable sorting during the layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool StableSort { get; set; }

Visual Basic [image] Copy Code

Public Property StableSort As Boolean

Property Value

true to apply stable sorting algorithm, otherwise false. The default value is false.

Remarks

By default .NET sorts arrays using unstable sort, where if two elements have equal values, their order might not be the same between different runs of the sort method. This could lead to LayeredLayout not preserving the order of some nodes in a layer between different runs if there are more than one candidates for the same position. If you need the same order to be reproduced consistently, set StableSort to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.StartNode Property

LayeredLayout.StartNode Property
[image]

Gets or sets the node that should be placed in the first layer of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As Object

Property Value

A DiagramNode object representing the start node.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
EndNode Property


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.Statistics Property

LayeredLayout.Statistics Property
[image]

Gets layout-specific information about the nodes and links participating in the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayeredLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As LayeredLayoutStatistics

Property Value

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.StraightenLongLinks Property

LayeredLayout.StraightenLongLinks Property
[image]

Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool StraightenLongLinks { get; set; }

Visual Basic [image] Copy Code

Public Property StraightenLongLinks As Boolean

Property Value

true to straighten long links; otherwise false. The default value is false.

Remarks

If this property is enabled, links that cross multiple layers have at most two bends. Because of the additional horizontal alignment contraints, the arranged graph osually occupies a larger area than when not using StraightenLongLinks.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
LinkType Property
EnforceLinkFlow Property


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.SwapPairsIterations Property

LayeredLayout.SwapPairsIterations Property
[image]

Gets or sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int SwapPairsIterations { get; set; }

Visual Basic [image] Copy Code

Public Property SwapPairsIterations As Integer

Property Value

An integer value specifying how many pair-swapping iterations to perform. The default is 5.

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayout.TimeLimit Property

LayeredLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The layered layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a long-enough path to produce nice layered layout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutLinkType Enumeration

LayeredLayoutLinkType Enumeration
[image]

Specifies the style of the links after they are laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LayeredLayoutLinkType

Visual Basic [image] Copy Code

Public Enum LayeredLayoutLinkType

Members

Member name | Description
Cascading | Indicates cascading links.
Straight | Indicates straight links.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics Class

LayeredLayoutStatistics Class
[image]

Encapsulates information about a layered layout which has already complete.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class LayeredLayoutStatistics

Visual Basic [image] Copy Code

Public NotInheritable Class LayeredLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics

See Also

LayeredLayoutStatistics Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics Members

LayeredLayoutStatistics Members
Properties
[image]

Encapsulates information about a layered layout which has already complete.

The following tables list the members exposed by the LayeredLayoutStatistics type.

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics Properties

LayeredLayoutStatistics Properties
[image]

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics.LayerCount Property

LayeredLayoutStatistics.LayerCount Property
[image]

Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int LayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayerCount As Integer

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics.LinkLayerCount Property

LayeredLayoutStatistics.LinkLayerCount Property
[image]

Gets a mapping between links and the number of layers they run through.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Dictionary<Object, Int32> LinkLayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinkLayerCount As Dictionary(Of Object, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics.NodeGridPositions Property

LayeredLayoutStatistics.NodeGridPositions Property
[image]

Gets a mapping between nodes and their assigned grid positions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Dictionary<Object, Double> NodeGridPositions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeGridPositions As Dictionary(Of Object, Double)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayeredLayoutStatistics.NodeLayerIndices Property

LayeredLayoutStatistics.NodeLayerIndices Property
[image]

Gets a mapping between nodes and their assigned layers.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Dictionary<Object, Int32> NodeLayerIndices { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeLayerIndices As Dictionary(Of Object, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout Class

Layout Class
[image]

The base class for all layout classes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract class Layout : Component, ILayout

Visual Basic [image] Copy Code

Public MustInherit Class Layout
Inherits Component
Implements ILayout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.AnnealLayout
MindFusion.Diagramming.Wpf.Layout.CascadeLayout
MindFusion.Diagramming.Wpf.Layout.CircularLayout
MindFusion.Diagramming.Wpf.Layout.CompositeLayout
MindFusion.Diagramming.Wpf.Layout.DecisionLayout
MindFusion.Diagramming.Wpf.Layout.FlowchartLayout
MindFusion.Diagramming.Wpf.Layout.FlowLayout
MindFusion.Diagramming.Wpf.Layout.FractalLayout
MindFusion.Diagramming.Wpf.Layout.GridLayout
MindFusion.Diagramming.Wpf.Layout.HierarchicalLayout
MindFusion.Diagramming.Wpf.Layout.LayeredLayout
MindFusion.Diagramming.Wpf.Layout.OneWayLayout
MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout
MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter
MindFusion.Diagramming.Wpf.Layout.SolarLayout
MindFusion.Diagramming.Wpf.Layout.SpringLayout
MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout
MindFusion.Diagramming.Wpf.Layout.TopologicalLayout
MindFusion.Diagramming.Wpf.Layout.TreeLayout
MindFusion.Diagramming.Wpf.Layout.TreeMapLayout
MindFusion.Diagramming.Wpf.Layout.TriangularLayout

See Also

Layout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout Members

Layout Members
Constructors Properties Methods
[image]

The base class for all layout classes.

The following tables list the members exposed by the Layout type.

Protected Constructors

Name | Description
Layout | Initialzes a new instance of the Layout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

Public Methods

Name | Description
Arrange | Overloaded.
ArrangeAsync | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout Constructor

Layout Constructor
[image]

Initialzes a new instance of the Layout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected Layout ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout Methods

Layout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded.
ArrangeAsync | Overloaded.

See Also

Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Arrange Method

Layout.Arrange Method
[image]

Overload List

Name | Description
Layout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
Layout.Arrange (Diagram, DiagramItemCollection) | Applies the layout on the specified subset of items from the specified Diagram instance.
Layout.Arrange (VirtualizingDiagram) | Applies the layout to the specified VirtualizingDiagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Arrange Method (Diagram)

Layout.Arrange Method (Diagram)
See Also
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.

Return Value

true if the diagram is arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Arrange Method (Diagram, DiagramItemCollection)

Layout.Arrange Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout on the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram
The Diagram that should be arranged.
items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Arrange Method (VirtualizingDiagram)

Layout.Arrange Method (VirtualizingDiagram)
See Also
[image]

Applies the layout to the specified VirtualizingDiagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool Arrange (
VirtualizingDiagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As VirtualizingDiagram _
) As Boolean

Parameters

diagram

The VirtualizingDiagram that should be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.ArrangeAsync Method

Layout.ArrangeAsync Method
[image]

Overload List

Name | Description
Layout.ArrangeAsync (Diagram) | Applies the layout asynchronously to the specified Diagram instance.
Layout.ArrangeAsync (Diagram, DiagramItemCollection) | Applies the layout asynchronously to the specified subset of items from the specified Diagram instance.
Layout.ArrangeAsync (VirtualizingDiagram) | Applies the layout asynchronously to the specified VirtualizingDiagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.ArrangeAsync Method (Diagram)

Layout.ArrangeAsync Method (Diagram)
See Also
[image]

Applies the layout asynchronously to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public async Task<Boolean> ArrangeAsync (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Async Function ArrangeAsync( _
diagram As Diagram _
) As Task(Of Boolean)

Parameters

diagram

The Diagram that should be arranged.

Return Value

true if the diagram has been arranged successfully, or false otherwise.

See Also

ArrangeAsync Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.ArrangeAsync Method (Diagram, DiagramItemCollection)

Layout.ArrangeAsync Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout asynchronously to the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public async Task<Boolean> ArrangeAsync (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Async Function ArrangeAsync( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Task(Of Boolean)

Parameters

diagram

The Diagram that should be arranged.

items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully, or false otherwise.

See Also

ArrangeAsync Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.ArrangeAsync Method (VirtualizingDiagram)

Layout.ArrangeAsync Method (VirtualizingDiagram)
See Also
[image]

Applies the layout asynchronously to the specified VirtualizingDiagram instance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public async virtual Task<Boolean> ArrangeAsync (
VirtualizingDiagram diagram
)

Visual Basic [image] Copy Code

Public Async Overridable Function ArrangeAsync( _
diagram As VirtualizingDiagram _
) As Task(Of Boolean)

Parameters

diagram

The VirtualizingDiagram that should be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

ArrangeAsync Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout Properties

Layout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

See Also

Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Anchoring Property

Layout.Anchoring Property
[image]

Gets or sets how to align links to the anchor points of nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace
AnchorPattern Property


MindFusion.Diagramming.Wpf.Layout.Layout.DefaultMarginValue Property

Layout.DefaultMarginValue Property
[image]

Gets the default value for the Margins property, which may vary accross different layouts.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected abstract Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected MustOverride ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.EnableParallelism Property

Layout.EnableParallelism Property
[image]

Gets or sets a value indicating whether to arrange subgraphs on separate threads.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool EnableParallelism { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property EnableParallelism As Boolean

Property Value

Remarks

Available only in .NET 4.0 versions and later.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.GrowToFit Property

Layout.GrowToFit Property
[image]

Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool GrowToFit { get; set; }

Visual Basic [image] Copy Code

Public Property GrowToFit As Boolean

Property Value

true to grow diagram's Bounds if the arranged items would not fit, or false otherwise. The default value is true.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.KeepGroupLayout Property

Layout.KeepGroupLayout Property
[image]

Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepGroupLayout { get; set; }

Visual Basic [image] Copy Code

Public Property KeepGroupLayout As Boolean

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace
AttachTo Method


MindFusion.Diagramming.Wpf.Layout.Layout.LayoutLink Property

Layout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.LayoutNode Property

Layout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Margins Property

Layout.Margins Property
[image]

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Size Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Size

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.MaxDegreeOfParallelism Property

Layout.MaxDegreeOfParallelism Property
[image]

Gets or sets the maximum degree of parallelism.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual int MaxDegreeOfParallelism { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property MaxDegreeOfParallelism As Integer

Property Value

Remarks

Applicable only if EnableParallelization is set to true. Available only in .NET 4.0 versions and later.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.MultipleGraphsPlacement Property

Layout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Name Property

Layout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public abstract string Name { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Name As String

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Layout.Progress Property

Layout.Progress Property
[image]

Gets or sets the progress callback delegate.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual LayoutProgress Progress { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Progress As LayoutProgress

Property Value

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayoutLink Delegate

LayoutLink Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a link changes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate void LayoutLink (
Object link
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutLink( _
link As Object _
)

Parameters

link

A reference to the link being laid out.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayoutNode Delegate

LayoutNode Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a node changes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate void LayoutNode (
Object node,
Rect oldBounds
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutNode( _
node As Object, _
oldBounds As Rect _
)

Parameters

node

A reference to the node being laid out.

oldBounds

The bounding rectangle of the node before it was repositioned by the layouting algorithm.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayoutProgress Delegate

LayoutProgress Delegate
[image]

Represents methods that are called to report on progress of layout algorithms.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate void LayoutProgress (
int current,
int total
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutProgress( _
current As Integer, _
total As Integer _
)

Parameters

current

An integer value specifying the current relative progress of the layout algorithm.

total

An integer value specifying the total number of steps required by the layouting algorithm in order to finish.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.LayoutSubgraph Delegate

LayoutSubgraph Delegate
[image]

Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate bool LayoutSubgraph (
Diagram diagram,
IEnumerable items
)

Visual Basic [image] Copy Code

Public Delegate Function LayoutSubgraph( _
diagram As Diagram, _
items As IEnumerable _
) As Boolean

Parameters

diagram

The diagram being arranged.

items

The subset of items to arrange.

Return Value

true if the items were arranged; otherwise, false.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration
[image]

Specifies graph orientation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum MultipleGraphsPlacement

Visual Basic [image] Copy Code

Public Enum MultipleGraphsPlacement

Members

Member name | Description
Horizontal | Indicates that graphs should be placed in a row.
HorizontalSortAscending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in an ascending order.
HorizontalSortDescending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in a descending order.
MinimalArea | Indicates that graphs should be placed so that they cover minimal area.
Vertical | Indicates that graphs should be placed in a column.
VerticalSortAscending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in an ascending order.
VerticalSortDescending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in a descending order.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout Class

OneWayLayout Class
Remarks See Also
[image]

Implements a one-way graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class OneWayLayout : Layout

Visual Basic [image] Copy Code

Public Class OneWayLayout
Inherits Layout

Remarks

The one-way layout ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.OneWayLayout

See Also

OneWayLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout Members

OneWayLayout Members
Constructors Properties Methods
[image]

Implements a one-way graph layout algorithm.

The following tables list the members exposed by the OneWayLayout type.

Public Constructors

Name | Description
OneWayLayout | Initializes a new instance of the OneWayLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout Constructor

OneWayLayout Constructor
[image]

Initializes a new instance of the OneWayLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public OneWayLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout Properties

OneWayLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout.DefaultMarginValue Property

OneWayLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout.Name Property

OneWayLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout.NodeDistance Property

OneWayLayout.NodeDistance Property
[image]

Gets or sets the minimum spacing between adjacent nodes in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout.Orientation Property

OneWayLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OneWayLayout.RoundedLinks Property

OneWayLayout.RoundedLinks Property
[image]

Gets or sets a value indicating whether the layout should smooth link bends.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.Orientation Enumeration

Orientation Enumeration
[image]

Specifies axial orientation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Horizontal | Indicates horizontal orientation.
Vertical | Indicates vertical orientation.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout Class

OrthogonalLayout Class
Remarks See Also
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class OrthogonalLayout : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalLayout
Inherits Layout

Remarks

This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout

See Also

OrthogonalLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout Members

OrthogonalLayout Members
Constructors Properties Methods
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

The following tables list the members exposed by the OrthogonalLayout type.

Public Constructors

Name | Description
OrthogonalLayout | Initializes a new instance of the OrthogonalLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid should be considered a directed graph.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout Constructor

OrthogonalLayout Constructor
[image]

Initializes a new instance of the OrthogonalLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public OrthogonalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout Properties

OrthogonalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid should be considered a directed graph.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should minimize link bends.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.DefaultMarginValue Property

OrthogonalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.Directed Property

OrthogonalLayout.Directed Property
[image]

Gets or sets a value indicating whether the graph being laid should be considered a directed graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Directed { get; set; }

Visual Basic [image] Copy Code

Public Property Directed As Boolean

Property Value

true to consider the direction of graph edges, false to ignore it; the default value is false.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.MinimizeLinkBends Property

OrthogonalLayout.MinimizeLinkBends Property
[image]

Gets or sets a value indicating whether the layout should minimize link bends.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MinimizeLinkBends { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeLinkBends As Boolean

Property Value

true to minimize link bends, otherwise false. The default value is true.

Remarks

If this option is disabled, the layout class applies a fast linear time algorithm, however the layouts produced usually contain more bending links and occupy more space. If enabled, the layout class applies an algorithm of polynomial complexity and runs much slower.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.MinLaneSize Property

OrthogonalLayout.MinLaneSize Property
[image]

Gets or sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double MinLaneSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinLaneSize As Double

Property Value

A double value specifying the minimum lane size. The default value is 35.

Remarks

The result of the layout's Arrange is a grid that contains the diagram's nodes and links. This property specifies the size of lanes which does not contain nodes, but only links.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.Name Property

OrthogonalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Orthogonal layout".

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.Padding Property

OrthogonalLayout.Padding Property
[image]

Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding. The default is 55.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalLayout.Refine Property

OrthogonalLayout.Refine Property
[image]

Gets or sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Refine { get; set; }

Visual Basic [image] Copy Code

Public Property Refine As Boolean

Property Value

true to run a refinement pass, otherwise false. The default value is true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter Class

OrthogonalRouter Class
Remarks See Also
[image]

Implements an orthogonal link routing algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class OrthogonalRouter : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalRouter
Inherits Layout

Remarks

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

To arrange a diagram, create an OrthogonalRouter instance, set its properties and call the Arrange method.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter

See Also

OrthogonalRouter Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter Members

OrthogonalRouter Members
Constructors Properties Methods
[image]

Implements an orthogonal link routing algorithm.

The following tables list the members exposed by the OrthogonalRouter type.

Public Constructors

Name | Description
OrthogonalRouter | Initializes a new instance of the OrthogonalRouter class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter Constructor

OrthogonalRouter Constructor
[image]

Initializes a new instance of the OrthogonalRouter class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public OrthogonalRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter Properties

OrthogonalRouter Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.BendDistance Property

OrthogonalRouter.BendDistance Property
[image]

Gets or sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double BendDistance { get; set; }

Visual Basic [image] Copy Code

Public Property BendDistance As Double

Property Value

A double value specifying the distance from a link's first bend to its adjacent node. The default is 0, specifying that the algorithm should automatically choose a value for this parameter.

Remarks

This should be a value between 0 and 1, specifying a distance proportional to the node size.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.DefaultMarginValue Property

OrthogonalRouter.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.Direction Property

OrthogonalRouter.Direction Property
[image]

Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

This value is assigned to the Direction property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.EndOrientation Property

OrthogonalRouter.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.GridSize Property

OrthogonalRouter.GridSize Property
[image]

Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double number specifying the grid size. The default is 96.

Remarks

This value is assigned to the GridSize property of the base GridLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.LayerDistance Property

OrthogonalRouter.LayerDistance Property
[image]

Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value specifying the distance between layers. The default is 96.

Remarks

This value is assigned to the LayerDistance property of the base LayeredLayout or to the LevelDistance property of the TreeLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.Name Property

OrthogonalRouter.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Orthogonal router".

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.NodeDistance Property

OrthogonalRouter.NodeDistance Property
[image]

Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes. The default is 96.

Remarks

This value is assigned to the NodeDistance property of the base LayeredLayout or to the NodeDistance property of the TreeLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.Orientation Property

OrthogonalRouter.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

An instance of the Orientation enumeration. The default is Vertical.

Remarks

This value is assigned to the Orientation property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.PutEndPointsAtNodeBorders Property

OrthogonalRouter.PutEndPointsAtNodeBorders Property
[image]

Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool PutEndPointsAtNodeBorders { get; set; }

Visual Basic [image] Copy Code

Public Property PutEndPointsAtNodeBorders As Boolean

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.RandomSeed Property

OrthogonalRouter.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.OrthogonalRouter.StartOrientation Property

OrthogonalRouter.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout Class

SolarLayout Class
[image]

A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SolarLayout : Layout

Visual Basic [image] Copy Code

Public Class SolarLayout
Inherits Layout

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.SolarLayout

See Also

SolarLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout Members

SolarLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes around their parent node, such that the child nodes do not overlap. The algorithm optionally bends the links to prevent them from crossing nodes.

The following tables list the members exposed by the SolarLayout type.

Public Constructors

Name | Description
SolarLayout | Initializes a new instance of the SolarLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout Constructor

SolarLayout Constructor
[image]

Initializes a new instance of the SolarLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SolarLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout Properties

SolarLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendLinks | Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
HonorInitialNodeDisposition | Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the minimal distance between a parent node and its children.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimal distance between siblings.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.BendLinks Property

SolarLayout.BendLinks Property
[image]

Gets or sets a value indicating whether links are bend to prevent them from crossing nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BendLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendLinks As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.DefaultMarginValue Property

SolarLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.HonorInitialNodeDisposition Property

SolarLayout.HonorInitialNodeDisposition Property
[image]

Gets or sets a value indicating whether the initial position of a child node relative to its parent node is preserved in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool HonorInitialNodeDisposition { get; set; }

Visual Basic [image] Copy Code

Public Property HonorInitialNodeDisposition As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.IgnoreLinkDirection Property

SolarLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.KeepRootPosition Property

SolarLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.LevelDistance Property

SolarLayout.LevelDistance Property
[image]

Gets or sets the minimal distance between a parent node and its children.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.Name Property

SolarLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.NodeDistance Property

SolarLayout.NodeDistance Property
[image]

Gets or sets the minimal distance between siblings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.ReversedLinks Property

SolarLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SolarLayout.Root Property

SolarLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

See Also

SolarLayout Members
SolarLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Class

SpringLayout Class
Remarks See Also
[image]

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SpringLayout : Layout

Visual Basic [image] Copy Code

Public Class SpringLayout
Inherits Layout

Remarks

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

To apply this layout to a diagram, call the Arrange method of a SpringLayout instance. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

If the LayoutTraits value associated with a node through SpringLayoutTraits.Frozen is true, SpringLayout considers the repulsion forces exerted by the node on other nodes, but ignores forces acting on the node and keeps it in place.

The final appearance of arranged graphs depends mostly on the values of EnableClusters and NodeDistance properties that specify how nodes are distributed by the layout routine. Enabling the MinimizeCrossings property helps to decrease the number of link crossings, though that makes the algorithm run somewhat slower.

The layout routine runs as much iterations as set in IterationCount, calculating better node positions at each step. When that stage of the algorithm completes, and Anchoring is enabled, link ends are aligned to nodes' anchor points.

The Spring-Embedder layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.SpringLayout

See Also

SpringLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Members

SpringLayout Members
Constructors Properties Methods
[image]

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Overloaded.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Overloaded.

See Also

SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Constructor

SpringLayout Constructor
[image]

Overload List

Name | Description
SpringLayout () | Initializes a new instance of the SpringLayout class with the default settings.
SpringLayout (Int32, Double, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.
SpringLayout (Int32, Double, Boolean, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.

See Also

SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Constructor ()

SpringLayout Constructor ()
See Also
[image]

Initializes a new instance of the SpringLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SpringLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Constructor (Int32, Double, Boolean)

SpringLayout Constructor (Int32, Double, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Constructor (Int32, Double, Boolean, Boolean)

SpringLayout Constructor (Int32, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean, _
keepGroupLayout As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Methods

SpringLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Overloaded.

See Also

SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.BeginArrange Method

SpringLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The Diagram that is arranged.

items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the process at once and display just the end result, call Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.EndArrange Method

SpringLayout.EndArrange Method
[image]

Completes the step-by-step execution.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Iterate Method

SpringLayout.Iterate Method
[image]

Overload List

Name | Description
SpringLayout.Iterate (Int32, Int32) | Runs one or more layout iterations.
SpringLayout.Iterate (Int32, Int32, Boolean) | Runs one or more layout iterations.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Iterate Method (Int32, Int32)

SpringLayout.Iterate Method (Int32, Int32)
See Also
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom
Specifies from which iteration to start.
iterationTo
Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate should start from the iteration next to the one where the previous call has stopped.

See Also

Iterate Method Overload List
SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Iterate Method (Int32, Int32, Boolean)

SpringLayout.Iterate Method (Int32, Int32, Boolean)
See Also
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo,
bool asynchronous
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer, _
asynchronous As Boolean _
)

Parameters

iterationFrom

Specifies from which iteration to start.

iterationTo

Specifies at which iteration to stop.

asynchronous

true to disable UI updates, or false otherwise.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped. Setting the asynchronous argument to true will let you run SpringLayout calculations from a worker thread.

See Also

Iterate Method Overload List
SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout Properties

SpringLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Gets or sets the stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.DefaultMarginValue Property

SpringLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.EnableClusters Property

SpringLayout.EnableClusters Property
[image]

Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableClusters { get; set; }

Visual Basic [image] Copy Code

Public Property EnableClusters As Boolean

Property Value

true to detect and process node clusters; otherwise, false. The default is false.

Remarks

If enabled, the SpringLayout algorithm detects node clusters and places them at distinct positions. Each cluster consists of a center node surrounded by several local nodes. Clusters might be connected with other clusters through their center nodes. Best-looking results are achieved when there aren't links between the local nodes in a cluster.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.IterationCount Property

SpringLayout.IterationCount Property
[image]

Gets or sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int IterationCount { get; set; }

Visual Basic [image] Copy Code

Public Property IterationCount As Integer

Property Value

An integer number specifying the number of iterations. The default is 100.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Layout3D Property

SpringLayout.Layout3D Property
[image]

Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Layout3D { get; set; }

Visual Basic [image] Copy Code

Public Property Layout3D As Boolean

Property Value

true to set the 3D coordinates of nodes; otherwise, false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.LayoutArea Property

SpringLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A .NET Rect representing the boundaries of the layout area. The default is Rect.Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.LayoutMethod Property

SpringLayout.LayoutMethod Property
[image]

Specifies what energy model to use for the simulation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SpringLayoutMethod LayoutMethod { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutMethod As SpringLayoutMethod

Property Value

A member of the SpringLayoutMethod enumeration. The default value is FruchtermanReingold.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.LinkType Property

SpringLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SpringLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As SpringLayoutLinkType

Property Value

A member of the SpringLayoutLinkType enumeration. The default value is Straight.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.MinimizeCrossings Property

SpringLayout.MinimizeCrossings Property
[image]

Gets or sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool MinimizeCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeCrossings As Boolean

Property Value

true to attempt crossing minimization; otherwise, false. The default is false.

Remarks

If enabled, the algorithm tries to decrease number of crossing links. For better results, use greater IterationCount.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Name Property

SpringLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Spring layout".

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.NodeDistance Property

SpringLayout.NodeDistance Property
[image]

Gets or sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between nodes. The default is 96.

Remarks

The final distance between connected nodes is determined by multiplying the Weight of the link that connects them by the value of NodeDistance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Randomize Property

SpringLayout.Randomize Property
[image]

Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start with random node positions, otherwise false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
RandomSeed Property


MindFusion.Diagramming.Wpf.Layout.SpringLayout.RandomSeed Property

SpringLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

An integer value passed as a seed to the random number generator. The default value is 0.

Remarks

If set to 0, SpringLayout uses the current time as a seed value. Set a value greater than 0 to use a fixed seed. Random numbers are generated when nodes are at the same initial position or when Randomize is enabled. Using a fixed seed helps producing consistent layouts at each run of the Arrange method.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Randomize Property


MindFusion.Diagramming.Wpf.Layout.SpringLayout.RepulsionFactor Property

SpringLayout.RepulsionFactor Property
[image]

Gets or sets the multiplier applied to repulsion forces between nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double RepulsionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RepulsionFactor As Double

Property Value

A double value specifying the repulsion factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Root Property

SpringLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

An instance of the DiagramNode class. The default is a null reference (Nothing in Visual Basic).

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.SplitGraph Property

SpringLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Stretch Property

SpringLayout.Stretch Property
[image]

Gets or sets the stretch factor.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Stretch { get; set; }

Visual Basic [image] Copy Code

Public Property Stretch As Double

Property Value

A double value specifying the stretch factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayout.Surface Property

SpringLayout.Surface Property
[image]

Specifies on what surface the nodes should be placed initially.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Surface Surface { get; set; }

Visual Basic [image] Copy Code

Public Property Surface As Surface

Property Value

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SpringLayoutLinkType Enumeration

SpringLayoutLinkType Enumeration
[image]

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SpringLayoutLinkType

Visual Basic [image] Copy Code

Public Enum SpringLayoutLinkType

Members

Member name | Description
Rounded | Indicates Bézier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout Class

SwimlaneLayout Class
Remarks See Also
[image]

Implements an algorithm which arranges nodes in lanes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SwimlaneLayout : Layout

Visual Basic [image] Copy Code

Public Class SwimlaneLayout
Inherits Layout

Remarks

This layout algorithm can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered via a control template, or one composed of locked background nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout

See Also

SwimlaneLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout Members

SwimlaneLayout Members
Constructors Properties Methods
[image]

Implements an algorithm which arranges nodes in lanes.

The following tables list the members exposed by the SwimlaneLayout type.

Public Constructors

Name | Description
SwimlaneLayout | Initializes a new instance of the SwimlaneLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout Constructor

SwimlaneLayout Constructor
[image]

Initializes a new instance of the SwimlaneLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SwimlaneLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout Properties

SwimlaneLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.CollapseEmptyLanes Property

SwimlaneLayout.CollapseEmptyLanes Property
[image]

Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CollapseEmptyLanes { get; set; }

Visual Basic [image] Copy Code

Public Property CollapseEmptyLanes As Boolean

Property Value

true to collapse empty lanes, otherwise false. The default value is false.

Remarks

To be able to shrink the lanes of a LaneGrid to zero size, the MinHeaderSize property of the lane grid must be set to an appropriate value.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.CompactNodes Property

SwimlaneLayout.CompactNodes Property
[image]

Gets or sets a value indicating whether the nodes within individual lanes are compacted.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CompactNodes { get; set; }

Visual Basic [image] Copy Code

Public Property CompactNodes As Boolean

Property Value

true to compact nodes, otherwise false. The default value is true.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.CustomSortOrder Property

SwimlaneLayout.CustomSortOrder Property
[image]

Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CustomSortOrder { get; set; }

Visual Basic [image] Copy Code

Public Property CustomSortOrder As Boolean

Property Value

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.DefaultMarginValue Property

SwimlaneLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.Direction Property

SwimlaneLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.KeepLaneSizes Property

SwimlaneLayout.KeepLaneSizes Property
[image]

Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepLaneSizes { get; set; }

Visual Basic [image] Copy Code

Public Property KeepLaneSizes As Boolean

Property Value

true to preserve lane sizes, otherwise false. The default value is false.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.LaneDistance Property

SwimlaneLayout.LaneDistance Property
[image]

Gets or sets the spacing between adjacent lanes in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Double

Property Value

The default value is 75.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.Name Property

SwimlaneLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Swimlane layout".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.NodeDistance Property

SwimlaneLayout.NodeDistance Property
[image]

Gets or sets the spacing between adjacent nodes within a lane in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

The default value is 92.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.Orientation Property

SwimlaneLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.SwimlaneLayout.SwimlaneGrid Property

SwimlaneLayout.SwimlaneGrid Property
[image]

Gets or sets the object through which the layout can manipulate the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ISwimlaneGrid SwimlaneGrid { get; set; }

Visual Basic [image] Copy Code

Public Property SwimlaneGrid As ISwimlaneGrid

Property Value

Remarks

If this is null at the time of layout, the layout will operate on the diagram's lane grid.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout Class

TopologicalLayout Class
Remarks See Also
[image]

Implements a topological ordering.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TopologicalLayout : Layout

Visual Basic [image] Copy Code

Public Class TopologicalLayout
Inherits Layout

Remarks

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as curves above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.TopologicalLayout

See Also

TopologicalLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout Members

TopologicalLayout Members
Constructors Properties Methods
[image]

Implements a topological ordering.

The following tables list the members exposed by the TopologicalLayout type.

Public Constructors

Name | Description
TopologicalLayout | Initializes a new instance of the TopologicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout Constructor

TopologicalLayout Constructor
[image]

Initializes a new instance of the TopologicalLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TopologicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout Properties

TopologicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.BendAdjacentLinks Property

TopologicalLayout.BendAdjacentLinks Property
[image]

Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BendAdjacentLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendAdjacentLinks As Boolean

Property Value

true to bend adjacent links; otherwise, false. The default value is false.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.DefaultMarginValue Property

TopologicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.Direction Property

TopologicalLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.MultipleGraphsPlacement Property

TopologicalLayout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public new MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Vertical.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.Name Property

TopologicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Topological layout".

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.NodeDistance Property

TopologicalLayout.NodeDistance Property
[image]

Gets or sets the distance between adjacent nodes in the diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between nodes. The default value is 90.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.Orientation Property

TopologicalLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TopologicalLayout.SplitGraph Property

TopologicalLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own; otherwise, false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
MultipleGraphsPlacement Property


MindFusion.Diagramming.Wpf.Layout.TreeLayout Class

TreeLayout Class
Remarks See Also
[image]

Implements several algorithms for arranging tree structures.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeLayout
Inherits Layout

Remarks

Set the Type property of a TreeLayout instance to select which tree layout algorithm to run, and call the Arrange method to apply the layout on a tree/subtree in the current diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. You can override it by setting the Root property, e.g. in order to arrange only a selected branch of the tree. The distance between the root and the second level and between all subsequent levels can be set through the LevelDistance property. The distance between adjacent nodes in the same level is set through NodeDistance.

In addition to arranging the tree nodes, TreeLayout also sets the shape of links as set through its LinkStyle property. Anchoring specifies whether the links should be attached to the anchor points of tree nodes. Note that links that are not part of the tree are ignored, e.g. graph links that go in opposite direction of the general parent-to-child flow or cross-links that connect different tree branches. The tree layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results. You can post-process such links after calling Arrange, for example by setting their ControlPoints coordinates or by calling their Route method.

By default, the order of child nodes arranged under a parent corresponds to the order of links in the parent's OutgoingLinks collection. The Balance property can be set to Preserve to keep the original geometric order of child nodes when arranging them under their parent. This can be used to arrange tree branches in a specific order by first placing them in increasing horizontal or vertical positions. Another possibility is to apply TreeLayout from NodeModified handler to let users rearrange the tree branches by dragging and dropping a node.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.TreeLayout

See Also

TreeLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Members

TreeLayout Members
Constructors Properties Methods
[image]

Implements several algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Overloaded.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor

TreeLayout Constructor
[image]

Overload List

Name | Description
TreeLayout () | Initializes a new instance of the TreeLayout class with the default settings.
TreeLayout (Object) | Initializes a new instance of the TreeLayout class with the specified node as root.
TreeLayout (Object, TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.
TreeLayout (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean) | Initializes a new instance of the TreeLayout class.
TreeLayout (TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified type.

See Also

TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor ()

TreeLayout Constructor ()
See Also
[image]

Initializes a new instance of the TreeLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor (Object)

TreeLayout Constructor (Object)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout (
Object root
)

Visual Basic [image] Copy Code

Public New ( _
root As Object _
)

Parameters

root

The root of the arranged tree.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor (Object, TreeLayoutType)

TreeLayout Constructor (Object, TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)

TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)

TreeLayout Constructor (Object, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)
See Also
[image]

Initializes a new instance of the TreeLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout (
Object root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
root As Object, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size, _
keepGroupLayout As Boolean _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Constructor (TreeLayoutType)

TreeLayout Constructor (TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified type.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayout (
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
type As TreeLayoutType _
)

Parameters

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Methods

TreeLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified link.

See Also

TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.UpdateLink Method

TreeLayout.UpdateLink Method
[image]

Updates the style and position of the specified link.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public void UpdateLink (
DiagramLink a,
bool ignoredDirection
)

Visual Basic [image] Copy Code

Public Sub UpdateLink( _
a As DiagramLink, _
ignoredDirection As Boolean _
)

Parameters

a

ignoredDirection

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout Properties

TreeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.Balance Property

TreeLayout.Balance Property
[image]

Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayoutBalance Balance { get; set; }

Visual Basic [image] Copy Code

Public Property Balance As TreeLayoutBalance

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.CompactAssistants Property

TreeLayout.CompactAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool CompactAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property CompactAssistants As Boolean

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.DefaultMarginValue Property

TreeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.Direction Property

TreeLayout.Direction Property
[image]

Gets or sets the tree direction.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayoutDirections Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As TreeLayoutDirections

Property Value

A member of the TreeLayoutDirections enumeration.

Remarks

This property must be set to a combination of two TreeLayoutDirections members when using Type is HorizontalVertical.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.EnableAssistants Property

TreeLayout.EnableAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool EnableAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAssistants As Boolean

Property Value

true to enable assistant nodes, otherwise false; the default value is false.

Remarks

Enabling this property lets you create organizational charts as in MS office. To designate some nodes as assistants, assign true as a value for the TreeLayoutTraits.Assistant key in the node's LayoutTraits.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.IgnoreLinkDirection Property

TreeLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

true to ignore link direction; otherwise, false. The default is false.

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links. If IgnoreLinkDirection is set to true, you must explicitly specify the tree Root.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.KeepRootPosition Property

TreeLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.LevelDistance Property

TreeLayout.LevelDistance Property
[image]

Gets or sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

A double value specifying the distance between adjacent levels in the tree. The default value is 48.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.LinkOffset Property

TreeLayout.LinkOffset Property
[image]

Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double LinkOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkOffset As Double

Property Value

A double value specifying offset of links from the parent node's center. The default value is 0.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.LinkStyle Property

TreeLayout.LinkStyle Property
[image]

Gets or sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayoutLinkType LinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkStyle As TreeLayoutLinkType

Property Value

A member of the TreeLayoutLinkType enumeration.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.Name Property

TreeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree layout".

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.NodeDistance Property

TreeLayout.NodeDistance Property
[image]

Gets or sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes. The default value is 48.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.ReversedLinks Property

TreeLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

true to indicate reversed direction, that is, the parent node is the one the link points to; otherwise, false.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.Root Property

TreeLayout.Root Property
[image]

Gets or sets the root node of the tree.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As Object

Property Value

An instance of the DiagramNode class that represents the root node.

Remarks

If not set, the layout will try to find the root automatically.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.StretchFactor Property

TreeLayout.StretchFactor Property
[image]

Gets or sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double StretchFactor { get; set; }

Visual Basic [image] Copy Code

Public Property StretchFactor As Double

Property Value

A real number specifying the ratio between the horizontal and vertical radii of radial layout outlines. The default is 1.

Remarks

When applying a radial layout, node layers are laid out in concentric circles around the Root node. Stretching them by changing this property makes layers laid out in elliptic outlines.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayout.Type Property

TreeLayout.Type Property
[image]

Gets or sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeLayoutType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As TreeLayoutType

Property Value

A member of the TreeLayoutType enumeration.

Remarks

The available tree layout types include the following:

Layout type | Appearance
Cascading |
Centered |
Radial |
HorizontalVertical |

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayoutBalance Enumeration

TreeLayoutBalance Enumeration
[image]

Specifies how to order child nodes in order to produce tree layouts with custom balance.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeLayoutBalance

Visual Basic [image] Copy Code

Public Enum TreeLayoutBalance

Members

Member name | Description
LeftHeavy | Indicates that the child nodes with most total children will be processed first, thus producing a left-heavy layout.
Original | Indicates that the child order should not be changed.
Preserve | Indicates that the layout will attempt to preserve the initial relative ordering of nodes.
Reversed | Indicates that the child order should be reversed.
RightHeavy | Indicates that the child nodes with least total children will be processed first, thus producing a right-heavy layout.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayoutDirections Enumeration

TreeLayoutDirections Enumeration
[image]

Specifies the direction of a tree layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeLayoutDirections

Visual Basic [image] Copy Code

Public Enum TreeLayoutDirections

Members

Member name | Description
BottomToTop | Indicates a bottom-to-top direction.
LeftToRight | Indicates a left-to-right direction.
RightToLeft | Indicates a right-to-left direction.
TopToBottom | Indicates a top-to-bottom direction.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration
[image]

Specifies the shape of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeLayoutLinkType

Visual Basic [image] Copy Code

Public Enum TreeLayoutLinkType

Members

Member name | Description
Cascading2 | Indicates cascading links with two segments.
Cascading3 | Indicates cascading links with three segments.
Rounded | Indicates Bézier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeLayoutType Enumeration

TreeLayoutType Enumeration
[image]

Specifies the type of a tree layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeLayoutType

Visual Basic [image] Copy Code

Public Enum TreeLayoutType

Members

Member name | Description
Cascading | Indicates cascading tree layout.
Centered | Indicates centered tree layout.
HorizontalVertical | Indicates the Horizontal-Vertical layout algorithm, used to arrange full binary trees.
Radial | Indicates radial tree layout.

Remarks

Members of this enumeration can be assigned to the Type property of TreeLayout.

See Also

MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout Class

TreeMapLayout Class
Remarks See Also
[image]

Implements a tree map layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TreeMapLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeMapLayout
Inherits Layout

Remarks

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see AttachTo method and ContainerNode class), and will ignore any links in the diagram.

The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

The padding size between parent nodes and their outermost children is specified via the ContainerPadding property. The padding size between child nodes is specified via Padding.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.TreeMapLayout

See Also

TreeMapLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout Members

TreeMapLayout Members
Constructors Properties Methods
[image]

Implements a tree map layout algorithm.

The following tables list the members exposed by the TreeMapLayout type.

Public Constructors

Name | Description
TreeMapLayout | Initializes a new instance of the TreeMapLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout Constructor

TreeMapLayout Constructor
[image]

Initializes a new instance of the TreeMapLayout class with the default settings.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TreeMapLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout Properties

TreeMapLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.ContainerPadding Property

TreeMapLayout.ContainerPadding Property
[image]

Gets or sets the padding inside containers.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double ContainerPadding { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerPadding As Double

Property Value

A double value specifying the padding size between parent nodes and their outermost children. The default value is 0.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
Padding Property


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.DefaultMarginValue Property

TreeMapLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.LayoutArea Property

TreeMapLayout.LayoutArea Property
[image]

Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Nullable<Rect> LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Nullable(Of Rect)

Property Value

A Rect? specifying the area where topmost nodes in the hierarchy are laid out. The default value is null.

Remarks

If this property is not set, the algorithm uses the value of diagram's Bounds property as target layout rectangle.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.Name Property

TreeMapLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree map layout".

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.Orientation Property

TreeMapLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

Remarks

This value is used only when Squarify is set to false, and specifies the orientation of the topmost level of the hierarchy. The algorithm alternates the orientation of each subsequent level, arranging its nodes either in rows or columns.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.Padding Property

TreeMapLayout.Padding Property
[image]

Gets or sets the distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding size between sibling nodes. The default value is 3.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace
ContainerPadding Property


MindFusion.Diagramming.Wpf.Layout.TreeMapLayout.Squarify Property

TreeMapLayout.Squarify Property
[image]

Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool Squarify { get; set; }

Visual Basic [image] Copy Code

Public Property Squarify As Boolean

Property Value

true to keep the ratio of node sides as close as possible to one, or false otherwise. The default value is true.

Remarks

If set to false, each level of the hierarchy is arranged in rows or columns with same height/width, which might create very narrow rectangles when Weight values differ greatly or nodes have many children. The alternating orientation between levels however helps to distinguish between different levels in the hierarchy. The initial direction of nodes (in topmost level) depends on the value of Orientation.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout Class

TriangularLayout Class
Remarks See Also
[image]

Performs triangular layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class TriangularLayout : Layout

Visual Basic [image] Copy Code

Public Class TriangularLayout
Inherits Layout

Remarks

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Diagramming.Wpf.Layout.Layout
MindFusion.Diagramming.Wpf.Layout.TriangularLayout

See Also

TriangularLayout Members
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout Members

TriangularLayout Members
Constructors Properties Methods
[image]

Performs triangular layout on simple, connected graphs.

The following tables list the members exposed by the TriangularLayout type.

Public Constructors

Name | Description
TriangularLayout | Initializes a new instance of the TriangularLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. (Inherited from Layout.)
ArrangeAsync | Overloaded. (Inherited from Layout.)

See Also

TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout Constructor

TriangularLayout Constructor
[image]

Initializes a new instance of the TriangularLayout class.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public TriangularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout Properties

TriangularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
EnableParallelism | Gets or sets a value indicating whether to arrange subgraphs on separate threads. (Inherited from Layout.)
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the diagram boundaries should grow to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each Group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MaxDegreeOfParallelism | Gets or sets the maximum degree of parallelism. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout.BendNonplanarLinks Property

TriangularLayout.BendNonplanarLinks Property
[image]

Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool BendNonplanarLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendNonplanarLinks As Boolean

Property Value

true to bend links, otherwise false. The default value is false.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout.DefaultMarginValue Property

TriangularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout.GridSize Property

TriangularLayout.GridSize Property
[image]

Gets or sets the size of the virtual grid the layout will place vertices on.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

The default value is 75.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout.Name Property

TriangularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Triangular layout".

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Diagramming.Wpf.Layout.TriangularLayout.Orientation Property

TriangularLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Wpf.Layout Namespace


MindFusion.Gauges.Wpf Namespace

MindFusion.Gauges.Wpf Namespace
Classes Structures Delegates Enumerations

Classes

Class | Description
BaseScale | Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.
CustomInterval | Represents an interval with associated custom values for fill, stroke and stroke thickness.
CustomIntervalCollection | Represents an observable collection of CustomInterval objects.
GaugeMouseEventArgs | Contains the arguments passed to mouse-related event handlers.
Indicator | Represents a gauge element, which changes its appearance based on its current state.
Led | A LED-like control with a glow effect. This control is suitable for gauge indicators.
LengthConverter | Represents a TypeConverter for Length objects.
LinearGauge | Represents a linear gauge control.
LinearScale | Represents a linear scale.
MajorTickSettings | Provides settings for the major ticks and labels in a gauge scale.
MiddleTickSettings | Provides settings for the middle ticks and labels in a gauge scale.
MinorTickSettings | Provides settings for the minor ticks and labels in a gauge scale.
OvalGauge | Represents a circular gauge control.
OvalScale | Represents a radial scale.
PercentConverter | Converts an amount of the specified converter parameter equal to the percentage specified by the source value.
Pointer | Represents a needle (or arrow) within a gauge scale.
QueryLabelValueEventArgs | Provides data for the QueryLabelValue event.
Range | Represents a range within a gauge scale.
ThicknessConverter | Converts Thickness values to double values.
TickSettings | Provides settings for the ticks and labels in a gauge scale.
ValueChangedEventArgs(T) | Contains the arguments passed to value change notification handlers.
VisibilityConverter | Converts boolean values to Visibility and vice versa.

Structures

Structure | Description
Length | Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

Delegates

Delegate | Description
FunctionDelegate | Represents a user-defined method, which performs custom distribution of values along the gauge scale.
ValueChangedEventHandler(T) | Represents the method that will handle value change notification events.

Enumerations

Enumeration | Description
Alignment | Indicates an alignment of an object relative to the scale. In the descriptions below 'outbound' refers to an element's outer outline, 'inbound' refers to an element's inner outline and 'center' refers to en element's center, that is, the middle of the inbound and outbound.
DisplayType | Specifies a display condition.
FunctionType | Indicates the type of function that will be used to distribute values along the gauge scale.
LabelRotation | Indicates the rotation of a label within a scale.
LengthType | Indicates the type of the units of a Length object.
TickShape | Indicates the shape of a scale tick.
TickType | Indicates the type of a scale tick.


MindFusion.Gauges.Wpf.Alignment Enumeration

Alignment Enumeration
[image]

Indicates an alignment of an object relative to the scale. In the descriptions below 'outbound' refers to an element's outer outline, 'inbound' refers to an element's inner outline and 'center' refers to en element's center, that is, the middle of the inbound and outbound.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum Alignment

Visual Basic [image] Copy Code

Public Enum Alignment

Members

Member name | Description
CenterInside | Specifies that the outbound of an object is aligned with the center of the scale.
CenterOutside | Specifies that the inbound of an object is aligned with the center of the scale.
InnerCenter | Specifies that the center of an object is aligned with the inbound of the scale.
InnerInside | Specifies that the outbound of an object is aligned with the inbound of the scale.
InnerOutside | Specifies that the inbound of an object is aligned with the inbound of the scale.
OuterCenter | Specifies that the center of an object is aligned with the outbound of the scale.
OuterInside | Specifies that the outbound of an object is aligned with the outbound of the scale.
OuterOutside | Specifies that the inbound of an object is aligned with the outbound of the scale.
TrueCenter | Specifies that the center of an object is aligned with the center of the scale.

Remarks

The following scheme illustrates all possible alignment modes:

The pale blue lane at the background represents an oval scale, the orange line represents the center of the scale and the green objects are the elements being aligned to the scale using different alignment modes. The center of each element is illustrated in light green color. The alignment modes used for each of the elements in the scheme is specified below:

  1. InnerInside
  2. InnerCenter
  3. InnerOutside
  4. CenterInside
  5. TrueCenter
  6. CenterOutside
  7. OuterInside
  8. OuterCenter
  9. OuterOutside

The position of the aligned elements can be further adjusted through their offset. The offset of the different element types is specified through a different property. For example for Range objects, it is specified through the Offset property and for ticks and labels it is specified respectively by the TickOffset and LabelOffset properties of the corresponding TickSettings class.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Class

BaseScale Class
[image]

Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public abstract class BaseScale : ItemsControl

Visual Basic [image] Copy Code

Public MustInherit Class BaseScale
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Gauges.Wpf.BaseScale
MindFusion.Gauges.Wpf.LinearScale
MindFusion.Gauges.Wpf.OvalScale

See Also

BaseScale Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Members

BaseScale Members
Constructors Fields Properties Methods Events
[image]

Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.

The following tables list the members exposed by the BaseScale type.

Protected Constructors

Name | Description
BaseScale | Initializes a new instance of the BaseScale class.

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property.
EnableAnimationProperty | Identifies the EnableAnimation dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
FunctionArgumentProperty | Identifies the FunctionArgument dependency property.
FunctionTypeProperty | Identifies the FunctionType dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property.
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property.
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property.
MinValueProperty | Identifies the MinValue dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property.
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property.
PointersProperty | Identifies the Pointers dependency property.
RangesProperty | Identifies the Ranges dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property.
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property.
Fill | Gets or sets the brush used to fill the scale. This is a dependency property.
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property.
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property.
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property.
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property.
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property.
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property.

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override.
EndInit | ItemsControl.EndInit override.
GetValueFromPoint | Returns the value corresponding to the specified point.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override.
OnPointerClicked | Raises the PointerClicked event.
OnRangeClicked | Raises the RangeClicked event.
OnRender | UIElement.OnRender override.
OnScaleClicked | Raises the ScaleClicked event.
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event.

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse.
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them.
RangeClicked | Occurs when a range within the scale is clicked with the mouse.
ScaleClicked | Occurs when the scale is clicked with the mouse.
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse.

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Fields

BaseScale Fields
[image]

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property.
EnableAnimationProperty | Identifies the EnableAnimation dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
FunctionArgumentProperty | Identifies the FunctionArgument dependency property.
FunctionTypeProperty | Identifies the FunctionType dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property.
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property.
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property.
MinValueProperty | Identifies the MinValue dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property.
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property.
PointersProperty | Identifies the Pointers dependency property.
RangesProperty | Identifies the Ranges dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.DefaultPointerStyleProperty Field

BaseScale.DefaultPointerStyleProperty Field
[image]

Identifies the DefaultPointerStyle dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultPointerStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultPointerStyleProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.EnableAnimationProperty Field

BaseScale.EnableAnimationProperty Field
[image]

Identifies the EnableAnimation dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableAnimationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableAnimationProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.EndWidthProperty Field

BaseScale.EndWidthProperty Field
[image]

Identifies the EndWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndWidthProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.FillProperty Field

BaseScale.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.FunctionArgumentProperty Field

BaseScale.FunctionArgumentProperty Field
[image]

Identifies the FunctionArgument dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FunctionArgumentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FunctionArgumentProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.FunctionTypeProperty Field

BaseScale.FunctionTypeProperty Field
[image]

Identifies the FunctionType dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FunctionTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FunctionTypeProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.LogarithmBaseProperty Field

BaseScale.LogarithmBaseProperty Field
[image]

Identifies the LogarithmBase dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LogarithmBaseProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LogarithmBaseProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MajorTickSettingsProperty Field

BaseScale.MajorTickSettingsProperty Field
[image]

Identifies the MajorTickSettings dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MaxValueProperty Field

BaseScale.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MiddleTickSettingsProperty Field

BaseScale.MiddleTickSettingsProperty Field
[image]

Identifies the MiddleTickSettings dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MiddleTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MiddleTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MinorTickSettingsProperty Field

BaseScale.MinorTickSettingsProperty Field
[image]

Identifies the MinorTickSettings dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MinValueProperty Field

BaseScale.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.PointerAnimationDecelerationRatioProperty Field

BaseScale.PointerAnimationDecelerationRatioProperty Field
[image]

Identifies the PointerAnimationDecelerationRatio dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerAnimationDecelerationRatioProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerAnimationDecelerationRatioProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.PointerAnimationDurationProperty Field

BaseScale.PointerAnimationDurationProperty Field
[image]

Identifies the PointerAnimationDuration dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerAnimationDurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerAnimationDurationProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.PointersProperty Field

BaseScale.PointersProperty Field
[image]

Identifies the Pointers dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointersProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.RangesProperty Field

BaseScale.RangesProperty Field
[image]

Identifies the Ranges dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RangesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RangesProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.StartWidthProperty Field

BaseScale.StartWidthProperty Field
[image]

Identifies the StartWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartWidthProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.StrokeProperty Field

BaseScale.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.StrokeThicknessProperty Field

BaseScale.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Constructor

BaseScale Constructor
[image]

Initializes a new instance of the BaseScale class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected BaseScale ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Methods

BaseScale Methods
[image]

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override.
EndInit | ItemsControl.EndInit override.
GetValueFromPoint | Returns the value corresponding to the specified point.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override.
OnPointerClicked | Raises the PointerClicked event.
OnRangeClicked | Raises the RangeClicked event.
OnRender | UIElement.OnRender override.
OnScaleClicked | Raises the ScaleClicked event.
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event.

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.ArrangeOverride Method

BaseScale.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overridable Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.BeginInit Method

BaseScale.BeginInit Method
[image]

ItemsControl.BeginInit override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.EndInit Method

BaseScale.EndInit Method
[image]

ItemsControl.EndInit override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.GetValueFromPoint Method

BaseScale.GetValueFromPoint Method
[image]

Returns the value corresponding to the specified point.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public abstract double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.MeasureOverride Method

BaseScale.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnApplyTemplate Method

BaseScale.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnMouseDown Method

BaseScale.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnMouseMove Method

BaseScale.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

The System.Windows.Input.MouseEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnMouseUp Method

BaseScale.OnMouseUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnPointerClicked Method

BaseScale.OnPointerClicked Method
[image]

Raises the PointerClicked event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPointerClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPointerClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnRangeClicked Method

BaseScale.OnRangeClicked Method
[image]

Raises the RangeClicked event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRangeClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRangeClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnRender Method

BaseScale.OnRender Method
[image]

UIElement.OnRender override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

The drawing instructions for a specific element. This context is provided to the layout system.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnScaleClicked Method

BaseScale.OnScaleClicked Method
[image]

Raises the ScaleClicked event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnScaleClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnScaleClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.OnScaleGeometryClicked Method

BaseScale.OnScaleGeometryClicked Method
[image]

Raises the ScaleGeometryClicked event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnScaleGeometryClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnScaleGeometryClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale Properties

BaseScale Properties
[image]

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property.
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property.
Fill | Gets or sets the brush used to fill the scale. This is a dependency property.
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property.
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property.
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property.
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property.
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property.
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property.

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.CustomFunction Property

BaseScale.CustomFunction Property
[image]

Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public FunctionDelegate CustomFunction { get; set; }

Visual Basic [image] Copy Code

Public Property CustomFunction As FunctionDelegate

Property Value

A FunctionDelegate, which will be invoked when a value needs to be displayed on the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
ReversedCustomFunction Property
FunctionType Property


MindFusion.Gauges.Wpf.BaseScale.DefaultPointerStyle Property

BaseScale.DefaultPointerStyle Property
[image]

Gets or sets the default style for pointers in this scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Style DefaultPointerStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultPointerStyle As Style

Property Value

A WPF Style instance.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.EnableAnimation Property

BaseScale.EnableAnimation Property
[image]

Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool EnableAnimation { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnimation As Boolean

Property Value

true, to enable animations; otherwise, false.

Remarks

This property is useful to temporarily disable animations - during initialization phases for example. Animations are always disabled in design-time.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.EndWidth Property

BaseScale.EndWidth Property
[image]

Gets or sets the width of the scale bar at its end. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length EndWidth { get; set; }

Visual Basic [image] Copy Code

Public Property EndWidth As Length

Property Value

An instance of the Length structure.

Remarks

This property, in conjunction with StartWidth, define the thickness of the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
StartWidth Property


MindFusion.Gauges.Wpf.BaseScale.Fill Property

BaseScale.Fill Property
[image]

Gets or sets the brush used to fill the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Wpf.BaseScale.FunctionArgument Property

BaseScale.FunctionArgument Property
[image]

Gets or sets the argument passed to custom functions. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double FunctionArgument { get; set; }

Visual Basic [image] Copy Code

Public Property FunctionArgument As Double

Property Value

A double value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.FunctionType Property

BaseScale.FunctionType Property
[image]

The type of the function used to calculate the distribution of values along the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public FunctionType FunctionType { get; set; }

Visual Basic [image] Copy Code

Public Property FunctionType As FunctionType

Property Value

A member of the FunctionType enumeration.

Remarks

When the value of this property is set to Custom, the distribution of values along the scale is defined by the CustomFunction property.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
FunctionArgument Property
CustomFunction Property


MindFusion.Gauges.Wpf.BaseScale.LogarithmBase Property

BaseScale.LogarithmBase Property
[image]

Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double LogarithmBase { get; set; }

Visual Basic [image] Copy Code

Public Property LogarithmBase As Double

Property Value

A double value specifying the base of logarithmic scales.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
FunctionType Property


MindFusion.Gauges.Wpf.BaseScale.MajorTickSettings Property

BaseScale.MajorTickSettings Property
[image]

Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MajorTickSettings MajorTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MajorTickSettings As MajorTickSettings

Property Value

An instance of the MajorTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
MiddleTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Wpf.BaseScale.MaxValue Property

BaseScale.MaxValue Property
[image]

Gets or sets the maximal value displayed by the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value.

Remarks

If MaxValue is less than MinValue, the direction of the scale is automatically reversed.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
MinValue Property


MindFusion.Gauges.Wpf.BaseScale.MiddleTickSettings Property

BaseScale.MiddleTickSettings Property
[image]

Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MiddleTickSettings MiddleTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleTickSettings As MiddleTickSettings

Property Value

An instance of the MiddleTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
MajorTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Wpf.BaseScale.MinorTickSettings Property

BaseScale.MinorTickSettings Property
[image]

Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MinorTickSettings MinorTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MinorTickSettings As MinorTickSettings

Property Value

An instance of the MinorTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
MajorTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Wpf.BaseScale.MinValue Property

BaseScale.MinValue Property
[image]

Gets or sets the minimal value displayed by the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value.

Remarks

If MaxValue is less than MinValue, the direction of the scale is automatically reversed.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.PointerAnimationDecelerationRatio Property

BaseScale.PointerAnimationDecelerationRatio Property
[image]

Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double PointerAnimationDecelerationRatio { get; set; }

Visual Basic [image] Copy Code

Public Property PointerAnimationDecelerationRatio As Double

Property Value

A double value.

Remarks

The value of this property is assigned to the DecelerationRatio property of the Timeline objects used to animate pointers.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
PointerAnimationDuration Property
EnableAnimation Property


MindFusion.Gauges.Wpf.BaseScale.PointerAnimationDuration Property

BaseScale.PointerAnimationDuration Property
[image]

Gets or sets the duration of the animation of animated pointers. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public TimeSpan PointerAnimationDuration { get; set; }

Visual Basic [image] Copy Code

Public Property PointerAnimationDuration As TimeSpan

Property Value

A .NET TimeSpan object.

Remarks

The value of this property is assigned to the Duration property of the Timeline objects used to animate pointers.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
PointerAnimationDecelerationRatio Property
EnableAnimation Property


MindFusion.Gauges.Wpf.BaseScale.Pointers Property

BaseScale.Pointers Property
[image]

Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Pointer> Pointers { get; set; }

Visual Basic [image] Copy Code

Public Property Pointers As ObservableCollection(Of Pointer)

Property Value

An observable collection of Pointer objects.

Example

The following XAML code defines an OvalScale with a single pointer in it. The gauges XAML namespace is defined as http://mindfusion.eu/gauges/.

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.Ranges Property

BaseScale.Ranges Property
[image]

Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Range> Ranges { get; set; }

Visual Basic [image] Copy Code

Public Property Ranges As ObservableCollection(Of Range)

Property Value

An observable collection of Range objects.

Remarks

The following XAML code defines an OvalScale with a single range in it. The gauges XAML namespace is defined as http://mindfusion.eu/gauges/.

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.Ranges>
<gauges:Range MinValue="20" MaxValue="50" Fill="Red" />
</gauges:OvalScale.Ranges>
</gauges:OvalScale>

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.ReversedCustomFunction Property

BaseScale.ReversedCustomFunction Property
[image]

Gets or sets the reversed version of the function specified through CustomFunction.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public FunctionDelegate ReversedCustomFunction { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedCustomFunction As FunctionDelegate

Property Value

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.StartWidth Property

BaseScale.StartWidth Property
[image]

Gets or sets the width of the scale bar at its beginning. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length StartWidth { get; set; }

Visual Basic [image] Copy Code

Public Property StartWidth As Length

Property Value

An instance of the Length structure.

Remarks

This property, in conjunction with StartWidth, define the thickness of the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
EndWidth Property


MindFusion.Gauges.Wpf.BaseScale.Stroke Property

BaseScale.Stroke Property
[image]

Gets or sets the brush used to stroke the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Wpf.BaseScale.StrokeThickness Property

BaseScale.StrokeThickness Property
[image]

Gets or sets the thickness of the scale stroke. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Wpf.BaseScale Events

BaseScale Events
[image]

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse.
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them.
RangeClicked | Occurs when a range within the scale is clicked with the mouse.
ScaleClicked | Occurs when the scale is clicked with the mouse.
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse.

See Also

BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.PointerClicked Event

BaseScale.PointerClicked Event
[image]

Occurs when a pointer within the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> PointerClicked

Visual Basic [image] Copy Code

Public Event PointerClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

PointerClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.QueryLabelValue Event

BaseScale.QueryLabelValue Event
[image]

Occurs when the labels in the scale are being generated in order to associate custom values with them.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<QueryLabelValueEventArgs> QueryLabelValue

Visual Basic [image] Copy Code

Public Event QueryLabelValue As EventHandler(Of QueryLabelValueEventArgs)

Event Data

QueryLabelValue event handlers receive an argument of type QueryLabelValueEventArgs.

Remarks

This event is raised in order to allow clients to customize the texts of tick labels beyond simple formatting.

Example

The following example illustrates a QueryLabelValue event handler which customizes the labels of a scale to display "Empty" as min value and "Full" as max value:

C# [image] Copy Code

private void OnQueryLabelValue(object sender, QueryLabelValueEventArgs e)
{
var baseScale = sender as BaseScale;
if (e.Settings.TickType == TickType.Major)
{
if (e.CalculatedLabelValue == baseScale.MinValue)
e.NewValue = "Empty";
if (e.CalculatedLabelValue == baseScale.MaxValue)
e.NewValue = "Full";
}
}

Visual Basic [image] Copy Code

Private Sub OnQueryLabelValue(ByVal sender As System.Object, ByVal e As QueryLabelValueEventArgs)

Dim baseScale = CType(sender, BaseScale)
If (e.Settings.TickType = TickType.Major) Then

If (e.CalculatedLabelValue = baseScale.MinValue) Then
e.NewValue = "Empty"
End If
If (e.CalculatedLabelValue = baseScale.MaxValue) Then
e.NewValue = "Full"
End If

End If

End Sub

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.RangeClicked Event

BaseScale.RangeClicked Event
[image]

Occurs when a range within the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> RangeClicked

Visual Basic [image] Copy Code

Public Event RangeClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

RangeClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.ScaleClicked Event

BaseScale.ScaleClicked Event
[image]

Occurs when the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> ScaleClicked

Visual Basic [image] Copy Code

Public Event ScaleClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

ScaleClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.BaseScale.ScaleGeometryClicked Event

BaseScale.ScaleGeometryClicked Event
[image]

Occurs when the scale geometry is clicked with the mouse.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> ScaleGeometryClicked

Visual Basic [image] Copy Code

Public Event ScaleGeometryClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

ScaleGeometryClicked event handlers receive an argument of type GaugeMouseEventArgs.

Remarks

This event will be raised only when the path geometry representing the scale is clicked. Therefore, if the scale is very thin or transparent, this event will not be raised. In this case the more general ScaleClicked event should be used.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Class

CustomInterval Class
Remarks See Also
[image]

Represents an interval with associated custom values for fill, stroke and stroke thickness.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class CustomInterval : DependencyObject, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class CustomInterval
Inherits DependencyObject
Implements INotifyPropertyChanged

Remarks

The custom interval is defined by its MinValue and MaxValue properties. The property values provided by the custom interval to the elements within it are Fill, Stroke and StrokeThickness. Certain custom interval containers associate additional properties with the custom intervals through the use of attached properties. For example the Indicator class provides an ActiveColor property which is used for the glow effect of the indicator.

Example

The following XAML code defines a custom interval, which sets the background of all elements in the range [10..20] it to Red.

XAML [image] Copy Code

<g:CustomInterval MinValue="15" MaxValue="20" Fill="Red" />

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Gauges.Wpf.CustomInterval

See Also

CustomInterval Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Members

CustomInterval Members
Constructors Fields Properties Methods Events
[image]

Represents an interval with associated custom values for fill, stroke and stroke thickness.

The following tables list the members exposed by the CustomInterval type.

Public Constructors

Name | Description
CustomInterval | Initializes a new instance of the CustomInterval class.

Public Fields

Name | Description
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
Fill | Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.
MaxValue | Gets or sets the end of this custom interval. This is a dependency property.
MinValue | Gets or sets the start of this custom interval. This is a dependency property.
Stroke | Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.
StrokeThickness | Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Occurs when a property of the interval changes.

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Fields

CustomInterval Fields
[image]

Public Fields

Name | Description
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.FillProperty Field

CustomInterval.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.MaxValueProperty Field

CustomInterval.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.MinValueProperty Field

CustomInterval.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.StrokeProperty Field

CustomInterval.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.StrokeThicknessProperty Field

CustomInterval.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Constructor

CustomInterval Constructor
[image]

Initializes a new instance of the CustomInterval class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomInterval ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Methods

CustomInterval Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.OnPropertyChanged Method

CustomInterval.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval Properties

CustomInterval Properties
[image]

Public Properties

Name | Description
Fill | Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.
MaxValue | Gets or sets the end of this custom interval. This is a dependency property.
MinValue | Gets or sets the start of this custom interval. This is a dependency property.
Stroke | Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.
StrokeThickness | Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.Fill Property

CustomInterval.Fill Property
[image]

Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Wpf.CustomInterval.MaxValue Property

CustomInterval.MaxValue Property
[image]

Gets or sets the end of this custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value.

Remarks

If this property is not set, positive infinity will be considered as the end of the interval.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace
MinValue Property


MindFusion.Gauges.Wpf.CustomInterval.MinValue Property

CustomInterval.MinValue Property
[image]

Gets or sets the start of this custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value.

Remarks

If this property is not set, negative infinity will be considered as the start of the interval.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace
MaxValue Property


MindFusion.Gauges.Wpf.CustomInterval.Stroke Property

CustomInterval.Stroke Property
[image]

Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Wpf.CustomInterval.StrokeThickness Property

CustomInterval.StrokeThickness Property
[image]

Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Wpf.CustomInterval Events

CustomInterval Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property of the interval changes.

See Also

CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomInterval.PropertyChanged Event

CustomInterval.PropertyChanged Event
[image]

Occurs when a property of the interval changes.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomIntervalCollection Class

CustomIntervalCollection Class
[image]

Represents an observable collection of CustomInterval objects.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class CustomIntervalCollection : ObservableCollection<CustomInterval>

Visual Basic [image] Copy Code

Public Class CustomIntervalCollection
Inherits ObservableCollection(Of CustomInterval)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(CustomInterval)
System.Collections.ObjectModel.ObservableCollection(CustomInterval)
MindFusion.Gauges.Wpf.CustomIntervalCollection

See Also

CustomIntervalCollection Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomIntervalCollection Members

CustomIntervalCollection Members
Constructors
[image]

Represents an observable collection of CustomInterval objects.

The following tables list the members exposed by the CustomIntervalCollection type.

Public Constructors

Name | Description
CustomIntervalCollection |

See Also

CustomIntervalCollection Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.CustomIntervalCollection Constructor

CustomIntervalCollection Constructor
[image]

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomIntervalCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CustomIntervalCollection Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.DisplayType Enumeration

DisplayType Enumeration
[image]

Specifies a display condition.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum DisplayType

Visual Basic [image] Copy Code

Public Enum DisplayType

Members

Member name | Description
Always | Indicates that the the element should always be displayed.
Auto | Indicates that the visibility of an element should be determined automatically.
Never | Indicates that the the element should always be hidden.

Remarks

Members of this enumeration are used as values of the ShowMaxValueTick property.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.FunctionDelegate Delegate

FunctionDelegate Delegate
[image]

Represents a user-defined method, which performs custom distribution of values along the gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public delegate double FunctionDelegate (
double value,
double argument
)

Visual Basic [image] Copy Code

Public Delegate Function FunctionDelegate( _
value As Double, _
argument As Double _
) As Double

Parameters

value

The source parameter value.

argument
An optional argument passed to the function. This is the value of the FunctionArgument property of the BaseScale class.

Return Value

The function result, which will be displayed on the scale.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.FunctionType Enumeration

FunctionType Enumeration
[image]

Indicates the type of function that will be used to distribute values along the gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum FunctionType

Visual Basic [image] Copy Code

Public Enum FunctionType

Members

Member name | Description
Custom | Specifies a user defined function, which will be supplied by the CustomFunction property.
Linear | Specifies that the values will be distributed linearly.
Logarithmic | Specifies a logarithmic function with base specified by the LogarithmBase property.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs Class

GaugeMouseEventArgs Class
[image]

Contains the arguments passed to mouse-related event handlers.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class GaugeMouseEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GaugeMouseEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Wpf.GaugeMouseEventArgs

See Also

GaugeMouseEventArgs Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs Members

GaugeMouseEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to mouse-related event handlers.

The following tables list the members exposed by the GaugeMouseEventArgs type.

Public Constructors

Name | Description
GaugeMouseEventArgs |

Public Properties

Name | Description
ClickCount | Gets the number of times the button was clicked.
Element | Gets a reference to the clicked gauge element, if any.
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
Position | Gets the position of the mouse relative to the clicked element.
RightButton | Gets the current state of the right mouse button.
Value | Get the gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs Constructor (MouseButtonState, MouseButtonState, MouseButtonState, Int32, Control, Point, Double)

GaugeMouseEventArgs Constructor (MouseButtonState, MouseButtonState, MouseButtonState, Int32, Control, Point, Double)
See Also
[image]

Initializes a new instance of the GaugeMouseEventArgs class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public GaugeMouseEventArgs (
MouseButtonState leftButton,
MouseButtonState middleButton,
MouseButtonState rightButton,
int clickCount,
Control element,
Point position,
double value
)

Visual Basic [image] Copy Code

Public New ( _
leftButton As MouseButtonState, _
middleButton As MouseButtonState, _
rightButton As MouseButtonState, _
clickCount As Integer, _
element As Control, _
position As Point, _
value As Double _
)

Parameters

leftButton

The state of the left mouse button.

middleButton

The state of the middle mouse button.

rightButton

The state of the right mouse button.

clickCount

This number of times the mouse button was pressed.

element

The clicked gauge element, if any.

position

The position of the mouse relative to the clicked element.

value

The gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs Properties

GaugeMouseEventArgs Properties
[image]

Public Properties

Name | Description
ClickCount | Gets the number of times the button was clicked.
Element | Gets a reference to the clicked gauge element, if any.
LeftButton | Gets the current state of the left mouse button.
MiddleButton | Gets the current state of the middle mouse button.
Position | Gets the position of the mouse relative to the clicked element.
RightButton | Gets the current state of the right mouse button.
Value | Get the gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.ClickCount Property

GaugeMouseEventArgs.ClickCount Property
[image]

Gets the number of times the button was clicked.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public int ClickCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClickCount As Integer

Property Value

An integer value specifying the number of clicks.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.Element Property

GaugeMouseEventArgs.Element Property
[image]

Gets a reference to the clicked gauge element, if any.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Control Element { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Element As Control

Property Value

A reference to the clicked element, or null (Nothing in Visual Basic) if the property value is not relevant.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.LeftButton Property

GaugeMouseEventArgs.LeftButton Property
[image]

Gets the current state of the left mouse button.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState LeftButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LeftButton As MouseButtonState

Property Value

A member of the MouseButtonState enumeration.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.MiddleButton Property

GaugeMouseEventArgs.MiddleButton Property
[image]

Gets the current state of the middle mouse button.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState MiddleButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MiddleButton As MouseButtonState

Property Value

A member of the MouseButtonState enumeration.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.Position Property

GaugeMouseEventArgs.Position Property
[image]

Gets the position of the mouse relative to the clicked element.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A .NET Point object.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.RightButton Property

GaugeMouseEventArgs.RightButton Property
[image]

Gets the current state of the right mouse button.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState RightButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RightButton As MouseButtonState

Property Value

A member of the MouseButtonState enumeration.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.GaugeMouseEventArgs.Value Property

GaugeMouseEventArgs.Value Property
[image]

Get the gauge value corresponding to the clicked point.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Double

Property Value

A double value.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Class

Indicator Class
Remarks See Also
[image]

Represents a gauge element, which changes its appearance based on its current state.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class Indicator : Control

Visual Basic [image] Copy Code

Public Class Indicator
Inherits Control

Remarks

The indicator is a gauge element, which changes its appearance based on its Value property and its defined states. The states of the indicator are specified as CustomInterval objects and are located in the States collection. When the value of the indicator falls within one of its defined states, this state becomes active and its Fill, Stroke and StrokeThickness properties are applied to the indicator automatically. In addition, the attached property ActiveColor is applied as a glow color of the indicator. If the value of the indicator does not fall in any of the defined states, then the DefaultState becomes active.

A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

Example

Indicators can be embedded within a scale. The following XAML code illustrates a LinearGauge with an indicator embedded in it. The indicator defines a single state, which paints the indicator in a green color.

XAML [image] Copy Code

<gauges:LinearScale Orientation="Vertical">
<gauges:Indicator VerticalAlignment="Center" HorizontalAlignment="Left" Margin="10,0,0,0" Width="20" Height="20">
<gauges:Indicator.States>
<gauges:CustomInterval MinValue="0" MaxValue="25" Fill="Green" gauges:Indicator.ActiveColor="Green" />
</gauges:Indicator.States>
</gauges:Indicator>
</gauges:LinearScale>

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Gauges.Wpf.Indicator

See Also

Indicator Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Members

Indicator Members
Constructors Fields Attached Properties Properties Methods
[image]

Represents a gauge element, which changes its appearance based on its current state.

The following tables list the members exposed by the Indicator type.

Public Constructors

Name | Description
Indicator | Initializes a new instance of the Indicator class.

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor attached property.
CurrentStateProperty | Identifies the CurrentState dependency property.
DefaultStateProperty | Identifies the DefaultState dependency property.
StatesProperty | Identifies the States dependency property.
ValueProperty | Identifies the Value dependency property.

Public Attached Properties

Name | Description
ActiveColorProperty | Gets or sets the glow color of an indicator state.

Public Properties

Name | Description
CurrentState | Gets the state the indicator is currently in. This is a dependency property.
DefaultState | Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.
States | Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.
Value | Gets or sets the value associated with this indicator. This is a dependency property.

Public Methods

Name | Description
GetActiveColor | Gets the value of the Indicator.ActiveColor attached property for a given dependency object.
SetActiveColor | Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Fields

Indicator Fields
[image]

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor attached property.
CurrentStateProperty | Identifies the CurrentState dependency property.
DefaultStateProperty | Identifies the DefaultState dependency property.
StatesProperty | Identifies the States dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.ActiveColorProperty Field

Indicator.ActiveColorProperty Field
[image]

Identifies the ActiveColor attached property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActiveColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActiveColorProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.CurrentStateProperty Field

Indicator.CurrentStateProperty Field
[image]

Identifies the CurrentState dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentStateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentStateProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.DefaultStateProperty Field

Indicator.DefaultStateProperty Field
[image]

Identifies the DefaultState dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultStateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultStateProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.StatesProperty Field

Indicator.StatesProperty Field
[image]

Identifies the States dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StatesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StatesProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.ValueProperty Field

Indicator.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Constructor

Indicator Constructor
[image]

Initializes a new instance of the Indicator class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Indicator ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Methods

Indicator Methods
[image]

Public Methods

Name | Description
GetActiveColor | Gets the value of the Indicator.ActiveColor attached property for a given dependency object.
SetActiveColor | Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.GetActiveColor Method

Indicator.GetActiveColor Method
[image]

Gets the value of the Indicator.ActiveColor attached property for a given dependency object.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static Color GetActiveColor (
CustomInterval element
)

Visual Basic [image] Copy Code

Public Shared Function GetActiveColor ( _
element As CustomInterval _
) As Color

Parameters

element

The element from which the property value is read.

Return Value

The Indicator.ActiveColor value of the specified element.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace
SetActiveColor Method


MindFusion.Gauges.Wpf.Indicator.SetActiveColor Method

Indicator.SetActiveColor Method
[image]

Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static void SetActiveColor (
CustomInterval element,
Color value
)

Visual Basic [image] Copy Code

Public Shared Sub SetActiveColor ( _
element As CustomInterval, _
value As Color _
)

Parameters

element

The element to which the property value is written.

value
The new value for the Indicator.ActiveColor property of the specified element.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace
GetActiveColor Method


MindFusion.Gauges.Wpf.Indicator Attached Properties

Indicator Attached Properties
[image]

Public Attached Properties

Name | Description
ActiveColorProperty | Gets or sets the glow color of an indicator state.

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.ActiveColor Attached Property

Indicator.ActiveColor Attached Property
[image]

Gets or sets the glow color of an indicator state.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code
See Indicator.GetActiveColor, Indicator.SetActiveColor
Visual Basic [image] Copy Code
See Indicator.GetActiveColor, Indicator.SetActiveColor

Property Value

A .NET Color object.

Dependency Property Information

Identifier Field | ActiveColorProperty
Metadata Flags | None

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator Properties

Indicator Properties
[image]

Public Properties

Name | Description
CurrentState | Gets the state the indicator is currently in. This is a dependency property.
DefaultState | Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.
States | Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.
Value | Gets or sets the value associated with this indicator. This is a dependency property.

See Also

Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.CurrentState Property

Indicator.CurrentState Property
[image]

Gets the state the indicator is currently in. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomInterval CurrentState { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentState As CustomInterval

Property Value

An instance of the CustomInterval class.

Remarks

The value of this property is updated automatically to reflect the current state of the indicator. The intention is to bind to this property from within the indicator's control template. Therefore, when the current state changed, the appearance of the indicator will change accordingly.

Example

For example, the following XAML code illustrates the default template of the Indicator class and how it binds to the properties of the CurrentState:

XAML [image] Copy Code

<ControlTemplate TargetType="{x:Type local:Indicator}">
<local:Led
BorderBrush="{Binding Path=CurrentState.Stroke, RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding Path=CurrentState.Fill, RelativeSource={RelativeSource TemplatedParent}}"
GlowColor="{Binding Path=CurrentState.(local:Indicator.ActiveColor), RelativeSource={RelativeSource TemplatedParent}}" />
</ControlTemplate>

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace
DefaultState Property


MindFusion.Gauges.Wpf.Indicator.DefaultState Property

Indicator.DefaultState Property
[image]

Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomInterval DefaultState { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultState As CustomInterval

Property Value

An instance of the CustomInterval class.

Remarks

This is the state, which will be used by the indicator when it is not in any of its defined states. For example, if the States collection is empty, the indicator will always be in this default state.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.States Property

Indicator.States Property
[image]

Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomIntervalCollection States { get; set; }

Visual Basic [image] Copy Code

Public Property States As CustomIntervalCollection

Property Value

An instance of the CustomIntervalCollection class.

Remarks

To define new states for the indicator, create new CustomInterval objects, set their range through their MinValue and MaxValue properties, and add them to this collection.

Example

The following example illustrates how to create several states for an indicator through XAML:

XAML [image] Copy Code

<gauges:Indicator>
<gauges:Indicator.States>
<gauges:CustomInterval MinValue="0" MaxValue="10" Fill="DarkGreen" gauges:Indicator.ActiveColor="DarkGreen" />
<gauges:CustomInterval MinValue="10" MaxValue="20" Fill="Green" gauges:Indicator.ActiveColor="Green" />
<gauges:CustomInterval MinValue="20" MaxValue="30" Fill="Lime" gauges:Indicator.ActiveColor="Lime" />
<gauges:CustomInterval MinValue="30" MaxValue="40" Fill="Yellow" gauges:Indicator.ActiveColor="Yellow" />
<gauges:CustomInterval MinValue="40" MaxValue="50" Fill="Orange" gauges:Indicator.ActiveColor="Orange" />
<gauges:CustomInterval MinValue="50" MaxValue="60" Fill="Red" gauges:Indicator.ActiveColor="Red" />
</gauges:Indicator.States>
</gauges:Indicator>

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Indicator.Value Property

Indicator.Value Property
[image]

Gets or sets the value associated with this indicator. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

Remarks

The value of the indicator determines its current state. A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LabelRotation Enumeration

LabelRotation Enumeration
[image]

Indicates the rotation of a label within a scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum LabelRotation

Visual Basic [image] Copy Code

Public Enum LabelRotation

Members

Member name | Description
Auto | Specifies that the labels are automatically rotated so that their baseline always points downwards.
BaselineAwayFromCenter | Specifies that the labels are rotated so that their baseline points away from the center of the scale.
BaselineToCenter | Specifies that the labels are rotated so that their baseline points towards the center of the scale.
None | Specifies no rotation.
Sideways | Specifies that the labels are aligned sideways to the scale.

Remarks

The following schemes illustrates all possible label rotation modes in an oval scale.

Auto | BaselineAwayFromCenter | BaselineToCenter | None | Sideways

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led Class

Led Class
Remarks See Also
[image]

A LED-like control with a glow effect. This control is suitable for gauge indicators.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class Led : Control

Visual Basic [image] Copy Code

Public Class Led
Inherits Control

Remarks

The Led control represents a LED-like light source. The color of the light is controlled through the Background (which specifies the fill) and GlowColor (which specifies the ambience light) properties and the color of the border is specified through the BorderBrush property.

The default control template of the Indicator class uses a Led control.

Additional Led Templates

The Leds.xaml resource dictionary in the MindFusion.Gauges.Wpf.dll assembly contains some even more realistic control templates for the Led class. The two styles containing the templates are called CircularLedReflectStyle and RectangularLedReflectStyle and provide an elliptical and rectangular shaped templates respectively. The example below illustrates how to use those templates in an application.

Example

Led control, which uses the template defined in the RectangularLedReflectStyle style. The first step is to merge the resource dictionary Leds.xaml in your application.

XAML [image] Copy Code

<ResourceDictionary>
<ResourceDictionary.MergedDictionaries>
<ResourceDictionary Source="/MindFusion.Gauges.Wpf;component/Themes/Leds.xaml" />
</ResourceDictionary.MergedDictionaries>
</ResourceDictionary>

Then you can reference the resource RectangularLedReflectStyle as you would do if it were defined in the same scope as the merged resource dictionary.

XAML [image] Copy Code

<gauges:Led Width="20" Height="20" Background="Red" GlowColor="Red" BorderBrush="Black" Style="{StaticResource RectangularLedReflectStyle}" />

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Gauges.Wpf.Led

See Also

Led Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led Members

Led Members
Constructors Fields Properties
[image]

A LED-like control with a glow effect. This control is suitable for gauge indicators.

The following tables list the members exposed by the Led type.

Public Constructors

Name | Description
Led | Initializes a new instance of the Led class.

Public Fields

Name | Description
GlowColorProperty | Identifies the GlowColor dependency property.

Public Properties

Name | Description
GlowColor | Gets or sets the glow color of the control. This is a dependency property.

See Also

Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led Fields

Led Fields
[image]

Public Fields

Name | Description
GlowColorProperty | Identifies the GlowColor dependency property.

See Also

Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led.GlowColorProperty Field

Led.GlowColorProperty Field
[image]

Identifies the GlowColor dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowColorProperty As DependencyProperty

See Also

Led Members
Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led Constructor

Led Constructor
[image]

Initializes a new instance of the Led class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Led ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led Properties

Led Properties
[image]

Public Properties

Name | Description
GlowColor | Gets or sets the glow color of the control. This is a dependency property.

See Also

Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Led.GlowColor Property

Led.GlowColor Property
[image]

Gets or sets the glow color of the control. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Color GlowColor { get; set; }

Visual Basic [image] Copy Code

Public Property GlowColor As Color

Property Value

A .NET Color value.

Remarks

This color is used as an outer glow of the control.

See Also

Led Members
Led Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Structure

Length Structure
Remarks See Also
[image]

Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public struct Length

Visual Basic [image] Copy Code

Public Structure Length

Remarks

Through the use of relative lengths it is possible to create scalable gauges.

To define relative lengths in XAML, use the percentage sign after the value. For example, the following code snipped defines a Pointer with width and height set to 30% and 10% respectively.

XAML [image] Copy Code

<gauges:Pointer PointerWidth="30%" PointerHeight="10%" />

See Also

Length Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Members

Length Members
Constructors Properties Methods
[image]

Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

The following tables list the members exposed by the Length type.

Public Constructors

Name | Description
Length | Overloaded. Initializes a new instance of the Length structure with the specified absolute value.

Public Properties

Name | Description
Type | Gets or sets a value indicating how to interpret Value.
Value | Gets or sets the value representing this length.

Public Methods

Name | Description
Equals | ValueType.Equals override. Compares an object to an instance of Length for equality.
GetHashCode | Gets the hash code for this instance of Length object.
ToString | Returns a string representation of this Length object.

See Also

Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Constructor

Length Constructor
[image]

Initializes a new instance of the Length structure with the specified absolute value.

Overload List

Name | Description
Length (Double) | Initializes a new instance of the Length structure with the specified absolute value.
Length (Double, LengthType) | Initializes a new instance of the Length structure with the specified value and type.

See Also

Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Constructor (Double)

Length Constructor (Double)
See Also
[image]

Initializes a new instance of the Length structure with the specified absolute value.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length (
double absoluteValue
)

Visual Basic [image] Copy Code

Public New ( _
absoluteValue As Double _
)

Parameters

absoluteValue

A double specifying absolute length.

See Also

Length Constructor Overload List
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Constructor (Double, LengthType)

Length Constructor (Double, LengthType)
See Also
[image]

Initializes a new instance of the Length structure with the specified value and type.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length (
double value,
LengthType type
)

Visual Basic [image] Copy Code

Public New ( _
value As Double, _
type As LengthType _
)

Parameters

value

A double specifying the initial length value.

type
A member of the LengthType enumeration specifying the length type.

See Also

Length Constructor Overload List
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Methods

Length Methods
[image]

Public Methods

Name | Description
Equals | ValueType.Equals override. Compares an object to an instance of Length for equality.
GetHashCode | Gets the hash code for this instance of Length object.
ToString | Returns a string representation of this Length object.

See Also

Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length.Equals Method

Length.Equals Method
[image]

ValueType.Equals override. Compares an object to an instance of Length for equality.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare.

Return Value

true if the lengths are equal; otherwise, false.

See Also

Length Members
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length.GetHashCode Method

Length.GetHashCode Method
[image]

Gets the hash code for this instance of Length object.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The hash code for this instance of Length.

See Also

Length Members
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length.ToString Method

Length.ToString Method
[image]

Returns a string representation of this Length object.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of this Length.

See Also

Length Members
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length Properties

Length Properties
[image]

Public Properties

Name | Description
Type | Gets or sets a value indicating how to interpret Value.
Value | Gets or sets the value representing this length.

See Also

Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length.Type Property

Length.Type Property
[image]

Gets or sets a value indicating how to interpret Value.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public LengthType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As LengthType

Property Value

A member of the LengthType enumeration specifying how to interpret the length value.

See Also

Length Members
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Length.Value Property

Length.Value Property
[image]

Gets or sets the value representing this length.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

Length Members
Length Structure
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter Class

LengthConverter Class
[image]

Represents a TypeConverter for Length objects.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class LengthConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class LengthConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Gauges.Wpf.LengthConverter

See Also

LengthConverter Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter Members

LengthConverter Members
Constructors Methods
[image]

Represents a TypeConverter for Length objects.

The following tables list the members exposed by the LengthConverter type.

Public Constructors

Name | Description
LengthConverter | Initializes a new instance of the LengthConverter class.

Public Methods

Name | Description
CanConvertFrom | LengthConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter Constructor

LengthConverter Constructor
[image]

Initializes a new instance of the LengthConverter class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public LengthConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter Methods

LengthConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | LengthConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter.CanConvertFrom Method

LengthConverter.CanConvertFrom Method
[image]

LengthConverter.CanConvertFrom override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter.CanConvertTo Method

LengthConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter.ConvertFrom Method

LengthConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The System.Globalization.CultureInfo to use as the current culture.
value
The System.Object to convert.

Return Value

An System.Object that represents the converted value.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthConverter.ConvertTo Method

LengthConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
The System.Object to convert.
culture
The System.Type to convert the value parameter to.
value
An System.Object that represents the converted value.
destinationType
The System.Type to convert the value parameter to.

Return Value

An System.Object that represents the converted value.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LengthType Enumeration

LengthType Enumeration
[image]

Indicates the type of the units of a Length object.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum LengthType

Visual Basic [image] Copy Code

Public Enum LengthType

Members

Member name | Description
Absolute | Specifies absolute length, expressed in pixels.
Relative | Specifies relative length, expressed as a percentage of the container's size.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge Class

LinearGauge Class
Remarks See Also
[image]

Represents a linear gauge control.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class LinearGauge : ItemsControl

Visual Basic [image] Copy Code

Public Class LinearGauge
Inherits ItemsControl

Remarks

The LinearGauge class acts as a container for LinearScale objects. The use of the gauge is not mandatory. However, the gauge provides a nice background skinning and glass effect. The following code illustrates how to define an LinearGauge object with a single scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">
<gauges:LinearScale Orientation="Horizontal" />
</gauges:LinearGauge>

The above code will produce a gauge similar to the following image.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Gauges.Wpf.LinearGauge

See Also

LinearGauge Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge Members

LinearGauge Members
Constructors Fields Properties
[image]

Represents a linear gauge control.

The following tables list the members exposed by the LinearGauge type.

Public Constructors

Name | Description
LinearGauge | Initializes a new instance of the LinearGauge class.

Public Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.

Public Properties

Name | Description
Orientation | Gets or sets the orientation of the gauge. This is a dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge Fields

LinearGauge Fields
[image]

Public Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge.OrientationProperty Field

LinearGauge.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

LinearGauge Members
LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge Constructor

LinearGauge Constructor
[image]

Initializes a new instance of the LinearGauge class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public LinearGauge ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge Properties

LinearGauge Properties
[image]

Public Properties

Name | Description
Orientation | Gets or sets the orientation of the gauge. This is a dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearGauge.Orientation Property

LinearGauge.Orientation Property
[image]

Gets or sets the orientation of the gauge. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the .NET Orientation enumeration.

See Also

LinearGauge Members
LinearGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Class

LinearScale Class
Remarks See Also
[image]

Represents a linear scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class LinearScale : BaseScale

Visual Basic [image] Copy Code

Public Class LinearScale
Inherits BaseScale

Remarks

This scale distributes its elements along a vertical or horizontal line. The size and positioning of the scale within its container is specified through the Left, Top and ScaleLength properties. All of these are usually specified as relative lengths.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Gauges.Wpf.BaseScale
MindFusion.Gauges.Wpf.LinearScale

See Also

LinearScale Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Members

LinearScale Members
Constructors Fields Properties Methods Events
[image]

Represents a linear scale.

The following tables list the members exposed by the LinearScale type.

Public Constructors

Name | Description
LinearScale | Initializes a new instance of the LinearScale class.

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LeftProperty | Identifies the Left dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
OrientationProperty | Identifies the Orientation dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
ScaleAlignmentProperty | Identifies the ScaleAlignment dependency property.
ScaleLengthProperty | Identifies the ScaleLength dependency property.
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)
TopProperty | Identifies the Top dependency property.

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
Left | Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
Orientation | Gets or sets the orientation of the scale. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
ScaleAlignment | Gets or sets the alignment of the scale. This is a dependency property.
ScaleLength | Gets or sets the length of the scale. This is a dependency property.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)
Top | Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | BaseScale.GetValueFromPoint override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | BaseScale.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Fields

LinearScale Fields
[image]

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LeftProperty | Identifies the Left dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
OrientationProperty | Identifies the Orientation dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
ScaleAlignmentProperty | Identifies the ScaleAlignment dependency property.
ScaleLengthProperty | Identifies the ScaleLength dependency property.
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)
TopProperty | Identifies the Top dependency property.

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.LeftProperty Field

LinearScale.LeftProperty Field
[image]

Identifies the Left dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeftProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.OrientationProperty Field

LinearScale.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.ScaleAlignmentProperty Field

LinearScale.ScaleAlignmentProperty Field
[image]

Identifies the ScaleAlignment dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleAlignmentProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.ScaleLengthProperty Field

LinearScale.ScaleLengthProperty Field
[image]

Identifies the ScaleLength dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleLengthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleLengthProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.TopProperty Field

LinearScale.TopProperty Field
[image]

Identifies the Top dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Constructor

LinearScale Constructor
[image]

Initializes a new instance of the LinearScale class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public LinearScale ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Methods

LinearScale Methods
[image]

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | BaseScale.GetValueFromPoint override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | BaseScale.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.GetValueFromPoint Method

LinearScale.GetValueFromPoint Method
[image]

BaseScale.GetValueFromPoint override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.MeasureOverride Method

LinearScale.MeasureOverride Method
[image]

BaseScale.MeasureOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint
The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale Properties

LinearScale Properties
[image]

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
Left | Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
Orientation | Gets or sets the orientation of the scale. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
ScaleAlignment | Gets or sets the alignment of the scale. This is a dependency property.
ScaleLength | Gets or sets the length of the scale. This is a dependency property.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)
Top | Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.Left Property

LinearScale.Left Property
[image]

Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Length

Property Value

An instance of the Length structure.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace
Top Property
ScaleLength Property


MindFusion.Gauges.Wpf.LinearScale.Orientation Property

LinearScale.Orientation Property
[image]

Gets or sets the orientation of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the .NET Orientation enumeration.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.ScaleAlignment Property

LinearScale.ScaleAlignment Property
[image]

Gets or sets the alignment of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Alignment ScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

All Inner* values align a vertical scale to the left side and a horizontal scale to the top side of the control. All Outer* values align a vertical scale to the right side and a horizontal scale to the bottom side of the control. All Center* values center the scale along its length.

This property is relevant only when the StartWidth of the scale is different than the EndWidth.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.LinearScale.ScaleLength Property

LinearScale.ScaleLength Property
[image]

Gets or sets the length of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length ScaleLength { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleLength As Length

Property Value

An instance of the Length structure.

Remarks

Relative scale length is measured based on the width of the control in horizontal scales and on the height of the control in vertical scales.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace
Left Property
Top Property


MindFusion.Gauges.Wpf.LinearScale.Top Property

LinearScale.Top Property
[image]

Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Length

Property Value

An instance of the Length class.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Wpf Namespace
Left Property
ScaleLength Property


MindFusion.Gauges.Wpf.LinearScale Events

LinearScale Events
[image]

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MajorTickSettings Class

MajorTickSettings Class
[image]

Provides settings for the major ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class MajorTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MajorTickSettings
Inherits TickSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Gauges.Wpf.TickSettings
MindFusion.Gauges.Wpf.MajorTickSettings

See Also

MajorTickSettings Members
MindFusion.Gauges.Wpf Namespace
MiddleTickSettings Class
MinorTickSettings Class


MindFusion.Gauges.Wpf.MajorTickSettings Members

MajorTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the major ticks and labels in a gauge scale.

The following tables list the members exposed by the MajorTickSettings type.

Public Constructors

Name | Description
MajorTickSettings | Initializes a new instance of the MajorTickSettings class.

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
LabelTemplateProperty | Identifies the LabelTemplate dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickTemplateProperty | Identifies the TickTemplate dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MajorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MajorTickSettings Constructor

MajorTickSettings Constructor
[image]

Initializes a new instance of the MajorTickSettings class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MajorTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MajorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MajorTickSettings Properties

MajorTickSettings Properties
[image]

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MajorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MajorTickSettings.TickType Property

MajorTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Major.

See Also

MajorTickSettings Members
MajorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MajorTickSettings Events

MajorTickSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MajorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.PropertyChanged Event

TickSettings.PropertyChanged Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MiddleTickSettings Class

MiddleTickSettings Class
[image]

Provides settings for the middle ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class MiddleTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MiddleTickSettings
Inherits TickSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Gauges.Wpf.TickSettings
MindFusion.Gauges.Wpf.MiddleTickSettings

See Also

MiddleTickSettings Members
MindFusion.Gauges.Wpf Namespace
MajorTickSettings Class
MinorTickSettings Class


MindFusion.Gauges.Wpf.MiddleTickSettings Members

MiddleTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the middle ticks and labels in a gauge scale.

The following tables list the members exposed by the MiddleTickSettings type.

Public Constructors

Name | Description
MiddleTickSettings | Initializes a new instance of the MiddleTickSettings class.

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
LabelTemplateProperty | Identifies the LabelTemplate dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickTemplateProperty | Identifies the TickTemplate dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MiddleTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MiddleTickSettings Constructor

MiddleTickSettings Constructor
[image]

Initializes a new instance of the MiddleTickSettings class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MiddleTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MiddleTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MiddleTickSettings Properties

MiddleTickSettings Properties
[image]

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MiddleTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MiddleTickSettings.TickType Property

MiddleTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Middle.

See Also

MiddleTickSettings Members
MiddleTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MiddleTickSettings Events

MiddleTickSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MiddleTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MinorTickSettings Class

MinorTickSettings Class
[image]

Provides settings for the minor ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class MinorTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MinorTickSettings
Inherits TickSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Gauges.Wpf.TickSettings
MindFusion.Gauges.Wpf.MinorTickSettings

See Also

MinorTickSettings Members
MindFusion.Gauges.Wpf Namespace
MajorTickSettings Class
MiddleTickSettings Class


MindFusion.Gauges.Wpf.MinorTickSettings Members

MinorTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the minor ticks and labels in a gauge scale.

The following tables list the members exposed by the MinorTickSettings type.

Public Constructors

Name | Description
MinorTickSettings | Initializes a new instance of the MinorTickSettings class.

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
LabelTemplateProperty | Identifies the LabelTemplate dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickTemplateProperty | Identifies the TickTemplate dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MinorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MinorTickSettings Constructor

MinorTickSettings Constructor
[image]

Initializes a new instance of the MinorTickSettings class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public MinorTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MinorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MinorTickSettings Properties

MinorTickSettings Properties
[image]

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | TickSettings.TickType override.
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MinorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MinorTickSettings.TickType Property

MinorTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Minor.

See Also

MinorTickSettings Members
MinorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.MinorTickSettings Events

MinorTickSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MinorTickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalGauge Class

OvalGauge Class
Remarks See Also
[image]

Represents a circular gauge control.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class OvalGauge : ItemsControl

Visual Basic [image] Copy Code

Public Class OvalGauge
Inherits ItemsControl

Remarks

The OvalGauge class acts as a container for OvalScale objects. The use of the gauge is not mandatory. However, the gauge provides a nice background skinning and glass effect. The following code illustrates how to define an OvalGauge object with a single scale in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale />
</gauges:OvalGauge>

The above code will produce a gauge similar to the following image.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Gauges.Wpf.OvalGauge

See Also

OvalGauge Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalGauge Members

OvalGauge Members
Constructors
[image]

Represents a circular gauge control.

The following tables list the members exposed by the OvalGauge type.

Public Constructors

Name | Description
OvalGauge | Initializes a new instance of the OvalGauge class.

See Also

OvalGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalGauge Constructor

OvalGauge Constructor
[image]

Initializes a new instance of the OvalGauge class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public OvalGauge ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OvalGauge Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Class

OvalScale Class
Remarks See Also
[image]

Represents a radial scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class OvalScale : BaseScale

Visual Basic [image] Copy Code

Public Class OvalScale
Inherits BaseScale

Remarks

This scale distributes its elements along an circular arc. The start and angles of the arc is defined by the StartAngle and EndAngle properties respectively.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Gauges.Wpf.BaseScale
MindFusion.Gauges.Wpf.OvalScale

See Also

OvalScale Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Members

OvalScale Members
Constructors Fields Properties Methods Events
[image]

Represents a radial scale.

The following tables list the members exposed by the OvalScale type.

Public Constructors

Name | Description
OvalScale | Initializes a new instance of the OvalScale class.

Public Fields

Name | Description
AnimateThroughSmallerArcProperty | Identifies the AnimateThroughSmallerArc dependency property.
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndAngleProperty | Identifies the EndAngle dependency property.
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
OffsetProperty | Identifies the Offset dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
ScaleRelativeCenterProperty | Identifies the ScaleRelativeCenter dependency property.
ScaleRelativeRadiusProperty | Identifies the ScaleRelativeRadius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

Public Properties

Name | Description
AnimateThroughSmallerArc | Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndAngle | Gets or sets the end angle of the scale. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
Offset | Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
ScaleRelativeCenter | Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.
ScaleRelativeRadius | Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.
StartAngle | Gets or sets the start angle of the scale. This is a dependency property.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | BaseScale.GetValueFromPoint override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | BaseScale.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Fields

OvalScale Fields
[image]

Public Fields

Name | Description
AnimateThroughSmallerArcProperty | Identifies the AnimateThroughSmallerArc dependency property.
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndAngleProperty | Identifies the EndAngle dependency property.
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
OffsetProperty | Identifies the Offset dependency property.
PointerAnimationDecelerationRatioProperty | Identifies the PointerAnimationDecelerationRatio dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
ScaleRelativeCenterProperty | Identifies the ScaleRelativeCenter dependency property.
ScaleRelativeRadiusProperty | Identifies the ScaleRelativeRadius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.AnimateThroughSmallerArcProperty Field

OvalScale.AnimateThroughSmallerArcProperty Field
[image]

Identifies the AnimateThroughSmallerArc dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnimateThroughSmallerArcProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnimateThroughSmallerArcProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.EndAngleProperty Field

OvalScale.EndAngleProperty Field
[image]

Identifies the EndAngle dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndAngleProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.OffsetProperty Field

OvalScale.OffsetProperty Field
[image]

Identifies the Offset dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OffsetProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.ScaleRelativeCenterProperty Field

OvalScale.ScaleRelativeCenterProperty Field
[image]

Identifies the ScaleRelativeCenter dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleRelativeCenterProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleRelativeCenterProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.ScaleRelativeRadiusProperty Field

OvalScale.ScaleRelativeRadiusProperty Field
[image]

Identifies the ScaleRelativeRadius dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleRelativeRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleRelativeRadiusProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.StartAngleProperty Field

OvalScale.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Constructor

OvalScale Constructor
[image]

Initializes a new instance of the OvalScale class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public OvalScale ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Methods

OvalScale Methods
[image]

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | BaseScale.GetValueFromPoint override.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | BaseScale.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnMouseUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.GetValueFromPoint Method

OvalScale.GetValueFromPoint Method
[image]

BaseScale.GetValueFromPoint override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public override double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.MeasureOverride Method

OvalScale.MeasureOverride Method
[image]

BaseScale.MeasureOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale Properties

OvalScale Properties
[image]

Public Properties

Name | Description
AnimateThroughSmallerArc | Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndAngle | Gets or sets the end angle of the scale. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
Offset | Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.
PointerAnimationDecelerationRatio | Gets or sets the deceleration ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
ScaleRelativeCenter | Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.
ScaleRelativeRadius | Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.
StartAngle | Gets or sets the start angle of the scale. This is a dependency property.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.AnimateThroughSmallerArc Property

OvalScale.AnimateThroughSmallerArc Property
[image]

Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool AnimateThroughSmallerArc { get; set; }

Visual Basic [image] Copy Code

Public Property AnimateThroughSmallerArc As Boolean

Property Value

A boolean value.

Remarks

This property is useful when implementing continuous scales with animated pointers, for example clocks. When the pointer is moving across the end of the scale, it will animate properly through the smaller arc. The following image illustrates the behavior of the pointer when animating across the end of the scale.

The value of the minute pointer changes so that the pointer moves across the end of the scale. The blue arrow indicate the animation direction when the AnimateThroughSmallerArc property is set to true, the red arrow indicates the animation direction when the property is set to false.

Note

Setting this property to false immediately discards all current pointer animations and sets the position of the pointers corresponding to their current value.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.EndAngle Property

OvalScale.EndAngle Property
[image]

Gets or sets the end angle of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double EndAngle { get; set; }

Visual Basic [image] Copy Code

Public Property EndAngle As Double

Property Value

A double value, expressing the angle in degrees.

Remarks

This property along with the StartAngle property define the arc orientation and sweep of the scale. The measurement is performed using a standard coordinate system with a center in the middle of the scale and angle values increasing in a clockwise direction. The following picture illustrates this:

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace
StartAngle Property


MindFusion.Gauges.Wpf.OvalScale.Offset Property

OvalScale.Offset Property
[image]

Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Length

Property Value

An instance of the Length structure.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.OvalScale.ScaleRelativeCenter Property

OvalScale.ScaleRelativeCenter Property
[image]

Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Point ScaleRelativeCenter { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleRelativeCenter As Point

Property Value

A .NET Point object.

Remarks

ScaleRelativeCenter and ScaleRelativeRadius properties can be used to implement gauges such as quadratic and other non-centralized gauges.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace
ScaleRelativeRadius Property


MindFusion.Gauges.Wpf.OvalScale.ScaleRelativeRadius Property

OvalScale.ScaleRelativeRadius Property
[image]

Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double ScaleRelativeRadius { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleRelativeRadius As Double

Property Value

A double value.

Remarks

ScaleRelativeCenter and ScaleRelativeRadius properties can be used to implement gauges such as quadratic and other non-centralized gauges.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace
ScaleRelativeCenter Property


MindFusion.Gauges.Wpf.OvalScale.StartAngle Property

OvalScale.StartAngle Property
[image]

Gets or sets the start angle of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value, expressing the angle in degrees.

Remarks

This property along with the EndAngle property define the arc orientation and sweep of the scale. The measurement is performed using a standard coordinate system with a center in the middle of the scale and angle values increasing in a clockwise direction. The following picture illustrates this:

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Wpf Namespace
EndAngle Property


MindFusion.Gauges.Wpf.OvalScale Events

OvalScale Events
[image]

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter Class

PercentConverter Class
Remarks See Also
[image]

Converts an amount of the specified converter parameter equal to the percentage specified by the source value.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class PercentConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PercentConverter
Implements IValueConverter

Remarks

The PercentConverter can be very useful for specifying scalable values for standard properties. For example, you can define an ellipse with a StrokeThickness relative to the size of the ellipse.

Example

The following sample code defines an Ellipse with StrokeThickness equal to 2% of its actual width:

XAML [image] Copy Code

<gauges:PercentConverter x:Key="PercentConverter" />

<Ellipse StrokeThickness="{Binding ActualWidth, RelativeSource={RelativeSource Self}, Converter={StaticResource PercentConverter}, ConverterParameter=2}" />

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Wpf.PercentConverter

See Also

PercentConverter Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter Members

PercentConverter Members
Constructors Methods
[image]

Converts an amount of the specified converter parameter equal to the percentage specified by the source value.

The following tables list the members exposed by the PercentConverter type.

Public Constructors

Name | Description
PercentConverter | Initializes a new instance of the PercentConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

PercentConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter Constructor

PercentConverter Constructor
[image]

Initializes a new instance of the PercentConverter class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public PercentConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PercentConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter Methods

PercentConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

PercentConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter.Convert Method

PercentConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

PercentConverter Members
PercentConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.PercentConverter.ConvertBack Method

PercentConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

PercentConverter Members
PercentConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Class

Pointer Class
Remarks See Also
[image]

Represents a needle (or arrow) within a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class Pointer : Control

Visual Basic [image] Copy Code

Public Class Pointer
Inherits Control

Remarks

The most important member of the pointer object is its Value. The pointer is automatically adjusted by its containing scale so that it points to the scale location, corresponding to its value.

The size of the pointer is defined by the PointerWidth and PointerHeight properties. The size is usually specified as a relative value so that the pointer scales with its containing gauge. The location of the pointer can be adjusted through the PointerOffset property and its alignment in a linear scale can be specified through the Alignment property.

The pointer can be made interactive by setting the IsInteractive property to true. Clicking with the mouse within a scale causes all its interactive pointers to be adjusted to the value corresponding to the clicked point.

A pointer can be made discrete by setting IsDiscrete to true. The value of a discrete pointer is always integer.

Note

To add a pointer to a scale simply add it to the Pointers collection of the scale.

To customize the appearance of a pointer associate a new ControlTemplate with it. Several pointers with custom templates are illustrated below.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Gauges.Wpf.Pointer

See Also

Pointer Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Members

Pointer Members
Constructors Fields Properties Methods Events
[image]

Represents a needle (or arrow) within a gauge scale.

The following tables list the members exposed by the Pointer type.

Public Constructors

Name | Description
Pointer | Initializes a new instance of the Pointer class.

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsDiscreteProperty | Identifies the IsDiscrete dependency property.
IsInteractiveProperty | Identifies the IsInteractive dependency property.
PointerHeightProperty | Identifies the PointerHeight dependency property.
PointerOffsetProperty | Identifies the PointerOffset dependency property.
PointerWidthProperty | Identifies the PointerWidth dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.
IsDiscrete | Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.
IsInteractive | Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.
PointerHeight | Gets or sets the height of the pointer. This is a dependency property.
PointerOffset | Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.
PointerWidth | Gets or sets the width of the pointer. This is a dependency property.
Value | Gets or sets the value this pointer points to. This is a dependency property.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.
OnValueChanged | Raises the ValueChanged event.

Public Events

Name | Description
ValueChanged | Occurs when the Value of this pointer changes, either programmatically or interactively.

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Fields

Pointer Fields
[image]

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsDiscreteProperty | Identifies the IsDiscrete dependency property.
IsInteractiveProperty | Identifies the IsInteractive dependency property.
PointerHeightProperty | Identifies the PointerHeight dependency property.
PointerOffsetProperty | Identifies the PointerOffset dependency property.
PointerWidthProperty | Identifies the PointerWidth dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.AlignmentProperty Field

Pointer.AlignmentProperty Field
[image]

Identifies the Alignment dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlignmentProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.IsAnimatedProperty Field

Pointer.IsAnimatedProperty Field
[image]

Identifies the IsAnimated dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAnimatedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsAnimatedProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.IsDiscreteProperty Field

Pointer.IsDiscreteProperty Field
[image]

Identifies the IsDiscrete dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDiscreteProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDiscreteProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.IsInteractiveProperty Field

Pointer.IsInteractiveProperty Field
[image]

Identifies the IsInteractive dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsInteractiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsInteractiveProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.PointerHeightProperty Field

Pointer.PointerHeightProperty Field
[image]

Identifies the PointerHeight dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerHeightProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.PointerOffsetProperty Field

Pointer.PointerOffsetProperty Field
[image]

Identifies the PointerOffset dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerOffsetProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.PointerWidthProperty Field

Pointer.PointerWidthProperty Field
[image]

Identifies the PointerWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerWidthProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.ValueProperty Field

Pointer.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Constructor

Pointer Constructor
[image]

Initializes a new instance of the Pointer class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Pointer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Methods

Pointer Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.
OnValueChanged | Raises the ValueChanged event.

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.ArrangeOverride Method

Pointer.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overridable Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.MeasureOverride Method

Pointer.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.OnMouseDown Method

Pointer.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.OnValueChanged Method

Pointer.OnValueChanged Method
[image]

Raises the ValueChanged event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValueChanged (
ValueChangedEventArgs<Double> e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValueChanged ( _
e As ValueChangedEventArgs(Of Double) _
)

Parameters

e

An object, containing the event data.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Properties

Pointer Properties
[image]

Public Properties

Name | Description
Alignment | Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.
IsDiscrete | Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.
IsInteractive | Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.
PointerHeight | Gets or sets the height of the pointer. This is a dependency property.
PointerOffset | Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.
PointerWidth | Gets or sets the width of the pointer. This is a dependency property.
Value | Gets or sets the value this pointer points to. This is a dependency property.

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.Alignment Property

Pointer.Alignment Property
[image]

Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Alignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

This property is ignored in oval gauges where the pointer is always pinned to the center of the gauge.

For more information on the effect of this property, check the Alignment enumeration.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace
PointerOffset Property


MindFusion.Gauges.Wpf.Pointer.IsAnimated Property

Pointer.IsAnimated Property
[image]

Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool IsAnimated { get; set; }

Visual Basic [image] Copy Code

Public Property IsAnimated As Boolean

Property Value

true to animate the pointer when its value changes; otherwise, false.

Remarks

This property has effect only when the EnableAnimation property of the scale containing the pointer is set to true. Additionally the pointers never animate in design-time.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.IsDiscrete Property

Pointer.IsDiscrete Property
[image]

Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool IsDiscrete { get; set; }

Visual Basic [image] Copy Code

Public Property IsDiscrete As Boolean

Property Value

true to make the pointer discrete; otherwise, false.

Remarks

This property can be useful when implementing analog-style pointers, which can move only discretely.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.IsInteractive Property

Pointer.IsInteractive Property
[image]

Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool IsInteractive { get; set; }

Visual Basic [image] Copy Code

Public Property IsInteractive As Boolean

Property Value

true, to automatically adjust the pointer value when the user clicks with the mouse in the containing scale; otherwise, false.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.PointerHeight Property

Pointer.PointerHeight Property
[image]

Gets or sets the height of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length PointerHeight { get; set; }

Visual Basic [image] Copy Code

Public Property PointerHeight As Length

Property Value

An instance of the Length structure.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace
PointerWidth Property
PointerOffset Property


MindFusion.Gauges.Wpf.Pointer.PointerOffset Property

Pointer.PointerOffset Property
[image]

Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length PointerOffset { get; set; }

Visual Basic [image] Copy Code

Public Property PointerOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace
PointerHeight Property
PointerWidth Property


MindFusion.Gauges.Wpf.Pointer.PointerWidth Property

Pointer.PointerWidth Property
[image]

Gets or sets the width of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length PointerWidth { get; set; }

Visual Basic [image] Copy Code

Public Property PointerWidth As Length

Property Value

An instance of the Length structure.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace
PointerHeight Property
PointerOffset Property


MindFusion.Gauges.Wpf.Pointer.Value Property

Pointer.Value Property
[image]

Gets or sets the value this pointer points to. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer Events

Pointer Events
[image]

Public Events

Name | Description
ValueChanged | Occurs when the Value of this pointer changes, either programmatically or interactively.

See Also

Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Pointer.ValueChanged Event

Pointer.ValueChanged Event
[image]

Occurs when the Value of this pointer changes, either programmatically or interactively.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public event ValueChangedEventHandler<Double> ValueChanged

Visual Basic [image] Copy Code

Public Event ValueChanged As ValueChangedEventHandler(Of Double)

Event Data

ValueChanged event handlers receive an argument of type ValueChangedEventArgs<Double>.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs Class

QueryLabelValueEventArgs Class
[image]

Provides data for the QueryLabelValue event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class QueryLabelValueEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class QueryLabelValueEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Wpf.QueryLabelValueEventArgs

See Also

QueryLabelValueEventArgs Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs Members

QueryLabelValueEventArgs Members
Constructors Properties
[image]

Provides data for the QueryLabelValue event.

The following tables list the members exposed by the QueryLabelValueEventArgs type.

Public Constructors

Name | Description
QueryLabelValueEventArgs | Initializes a new instance of the QueryLabelValueEventArgs class.

Public Properties

Name | Description
CalculatedLabelValue | Gets the value, which has been calculated for the label and which will be used if no custom value is provided.
NewValue | Gets or sets the new value to associate with the label.
Settings | Gets the TickSettings object which specifies the settings of the label.

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs Constructor

QueryLabelValueEventArgs Constructor
[image]

Initializes a new instance of the QueryLabelValueEventArgs class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public QueryLabelValueEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs Properties

QueryLabelValueEventArgs Properties
[image]

Public Properties

Name | Description
CalculatedLabelValue | Gets the value, which has been calculated for the label and which will be used if no custom value is provided.
NewValue | Gets or sets the new value to associate with the label.
Settings | Gets the TickSettings object which specifies the settings of the label.

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs.CalculatedLabelValue Property

QueryLabelValueEventArgs.CalculatedLabelValue Property
[image]

Gets the value, which has been calculated for the label and which will be used if no custom value is provided.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double CalculatedLabelValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CalculatedLabelValue As Double

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs.NewValue Property

QueryLabelValueEventArgs.NewValue Property
[image]

Gets or sets the new value to associate with the label.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Object NewValue { get; set; }

Visual Basic [image] Copy Code

Public Property NewValue As Object

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.QueryLabelValueEventArgs.Settings Property

QueryLabelValueEventArgs.Settings Property
[image]

Gets the TickSettings object which specifies the settings of the label.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public TickSettings Settings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Settings As TickSettings

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Class

Range Class
Remarks See Also
[image]

Represents a range within a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class Range : Control

Visual Basic [image] Copy Code

Public Class Range
Inherits Control

Remarks

The range is a visual representation of an interval within a gauge. Ranges are commonly used to mark specific zones on the scale or to emphasize scale intervals. Often the end of the scale is a danger zone and a range can be used to indicate this. The following image illustrates an oval gauge with three ranges (red, yellow and green) specifying different zones on the scale.

The range interval is specified through the MinValue and MaxValue properties. The Alignment and Offset properties control the positioning and the StartWidth and EndWidth properties specify the size of the range. The range can be auto-sized to the scale by setting AutoSize to true.

The Fill, Stroke and StrokeThickness properties can be used to specify the appearance of the range.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Gauges.Wpf.Range

See Also

Range Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Members

Range Members
Constructors Fields Properties Methods
[image]

Represents a range within a gauge scale.

The following tables list the members exposed by the Range type.

Public Constructors

Name | Description
Range | Initializes a new instance of the Range class.

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AutoSizeProperty | Identifies the AutoSize dependency property.
CapEndProperty | Identifies the CapEnd dependency property.
CapStartProperty | Identifies the CapStart dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OffsetProperty | Identifies the Offset dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeInsideProperty | Identifies the StrokeInside dependency property.
StrokeOutsideProperty | Identifies the StrokeOutside dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
Alignment | Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.
AutoSize | Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.
CapEnd | Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.
CapStart | Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.
EndWidth | Gets or sets the width of this range at its end. This is a dependency property.
Fill | Gets or sets the fill brush of this range. This is a dependency property.
MaxValue | Gets or sets the end value of this range. This is a dependency property.
MinValue | Gets or sets the start value of this range. This is a dependency property.
Offset | Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.
StartWidth | Gets or sets the width of this range at its start. This is a dependency property.
Stroke | Gets or sets the stroke of this range. This is a dependency property.
StrokeInside | Gets or sets a value indicating whether to draw a stroke at the inside of this range. This is a dependency property.
StrokeOutside | Gets or sets a value indicating whether to draw a stroke at the outside of this range. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of this range. This is a dependency property.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.

See Also

Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Fields

Range Fields
[image]

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AutoSizeProperty | Identifies the AutoSize dependency property.
CapEndProperty | Identifies the CapEnd dependency property.
CapStartProperty | Identifies the CapStart dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OffsetProperty | Identifies the Offset dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeInsideProperty | Identifies the StrokeInside dependency property.
StrokeOutsideProperty | Identifies the StrokeOutside dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.AlignmentProperty Field

Range.AlignmentProperty Field
[image]

Identifies the Alignment dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlignmentProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.AutoSizeProperty Field

Range.AutoSizeProperty Field
[image]

Identifies the AutoSize dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoSizeProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.CapEndProperty Field

Range.CapEndProperty Field
[image]

Identifies the CapEnd dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CapEndProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CapEndProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.CapStartProperty Field

Range.CapStartProperty Field
[image]

Identifies the CapStart dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CapStartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CapStartProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.EndWidthProperty Field

Range.EndWidthProperty Field
[image]

Identifies the EndWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndWidthProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.FillProperty Field

Range.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.MaxValueProperty Field

Range.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.MinValueProperty Field

Range.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.OffsetProperty Field

Range.OffsetProperty Field
[image]

Identifies the Offset dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OffsetProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StartWidthProperty Field

Range.StartWidthProperty Field
[image]

Identifies the StartWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartWidthProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeInsideProperty Field

Range.StrokeInsideProperty Field
[image]

Identifies the StrokeInside dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeInsideProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeInsideProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeOutsideProperty Field

Range.StrokeOutsideProperty Field
[image]

Identifies the StrokeOutside dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeOutsideProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeOutsideProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeProperty Field

Range.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeThicknessProperty Field

Range.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Constructor

Range Constructor
[image]

Initializes a new instance of the Range class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Range ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Methods

Range Methods
[image]

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnMouseDown | UIElement.OnMouseDown override.

See Also

Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.MeasureOverride Method

Range.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.OnMouseDown Method

Range.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range Properties

Range Properties
[image]

Public Properties

Name | Description
Alignment | Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.
AutoSize | Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.
CapEnd | Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.
CapStart | Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.
EndWidth | Gets or sets the width of this range at its end. This is a dependency property.
Fill | Gets or sets the fill brush of this range. This is a dependency property.
MaxValue | Gets or sets the end value of this range. This is a dependency property.
MinValue | Gets or sets the start value of this range. This is a dependency property.
Offset | Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.
StartWidth | Gets or sets the width of this range at its start. This is a dependency property.
Stroke | Gets or sets the stroke of this range. This is a dependency property.
StrokeInside | Gets or sets a value indicating whether to draw a stroke at the inside of this range. This is a dependency property.
StrokeOutside | Gets or sets a value indicating whether to draw a stroke at the outside of this range. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of this range. This is a dependency property.

See Also

Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.Alignment Property

Range.Alignment Property
[image]

Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Alignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace
Offset Property


MindFusion.Gauges.Wpf.Range.AutoSize Property

Range.AutoSize Property
[image]

Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool AutoSize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSize As Boolean

Property Value

A boolean value.

Remarks

If this property is set to true the values of StartWidth and EndWidth properties are ignored.

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace
StartWidth Property
EndWidth Property


MindFusion.Gauges.Wpf.Range.CapEnd Property

Range.CapEnd Property
[image]

Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool CapEnd { get; set; }

Visual Basic [image] Copy Code

Public Property CapEnd As Boolean

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace
CapStart Property
StrokeInside Property
StrokeOutside Property


MindFusion.Gauges.Wpf.Range.CapStart Property

Range.CapStart Property
[image]

Gets or sets a value indicating whether to draw a stroke the beginning of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool CapStart { get; set; }

Visual Basic [image] Copy Code

Public Property CapStart As Boolean

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.EndWidth Property

Range.EndWidth Property
[image]

Gets or sets the width of this range at its end. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length EndWidth { get; set; }

Visual Basic [image] Copy Code

Public Property EndWidth As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.Fill Property

Range.Fill Property
[image]

Gets or sets the fill brush of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.MaxValue Property

Range.MaxValue Property
[image]

Gets or sets the end value of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.MinValue Property

Range.MinValue Property
[image]

Gets or sets the start value of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.Offset Property

Range.Offset Property
[image]

Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StartWidth Property

Range.StartWidth Property
[image]

Gets or sets the width of this range at its start. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length StartWidth { get; set; }

Visual Basic [image] Copy Code

Public Property StartWidth As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.Stroke Property

Range.Stroke Property
[image]

Gets or sets the stroke of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeInside Property

Range.StrokeInside Property
[image]

Gets or sets a value indicating whether to draw a stroke at the inside of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool StrokeInside { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeInside As Boolean

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeOutside Property

Range.StrokeOutside Property
[image]

Gets or sets a value indicating whether to draw a stroke at the outside of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool StrokeOutside { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeOutside As Boolean

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.Range.StrokeThickness Property

Range.StrokeThickness Property
[image]

Gets or sets the stroke thickness of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter Class

ThicknessConverter Class
[image]

Converts Thickness values to double values.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class ThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Wpf.ThicknessConverter

See Also

ThicknessConverter Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter Members

ThicknessConverter Members
Constructors Methods
[image]

Converts Thickness values to double values.

The following tables list the members exposed by the ThicknessConverter type.

Public Constructors

Name | Description
ThicknessConverter | Initializes a new instance of the ThicknessConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter Constructor

ThicknessConverter Constructor
[image]

Initializes a new instance of the ThicknessConverter class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public ThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ThicknessConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter Methods

ThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter.Convert Method

ThicknessConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

ThicknessConverter Members
ThicknessConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ThicknessConverter.ConvertBack Method

ThicknessConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

ThicknessConverter Members
ThicknessConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Class

TickSettings Class
[image]

Provides settings for the ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public abstract class TickSettings : FrameworkElement, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public MustInherit Class TickSettings
Inherits FrameworkElement
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Gauges.Wpf.TickSettings
MindFusion.Gauges.Wpf.MajorTickSettings
MindFusion.Gauges.Wpf.MiddleTickSettings
MindFusion.Gauges.Wpf.MinorTickSettings

See Also

TickSettings Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Members

TickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the ticks and labels in a gauge scale.

The following tables list the members exposed by the TickSettings type.

Protected Constructors

Name | Description
TickSettings | Initializes a new instance of the TickSettings class.

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property.
CustomIntervalsProperty | Identifies the CustomIntervals dependency property.
FillProperty | Identifies the Fill dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
LabelAlignmentProperty | Identifies the LabelAlignment dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationProperty | Identifies the LabelRotation dependency property.
LabelTemplateProperty | Identifies the LabelTemplate dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property.
ShowTicksProperty | Identifies the ShowTicks dependency property.
StepProperty | Identifies the Step dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickAlignmentProperty | Identifies the TickAlignment dependency property.
TickHeightProperty | Identifies the TickHeight dependency property.
TickOffsetProperty | Identifies the TickOffset dependency property.
TickShapeProperty | Identifies the TickShape dependency property.
TickTemplateProperty | Identifies the TickTemplate dependency property.
TickWidthProperty | Identifies the TickWidth dependency property.

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property.
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.
Fill | Gets or sets the fill brush of the ticks. This is a dependency property.
FontSize | Gets or sets the font size of the labels. This is a dependency property.
FontWeight | Gets or sets the font weight of the labels. This is a dependency property.
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property.
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property.
LabelFormat | Gets or sets the format for label texts.
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property.
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property.
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property.
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property.
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property.
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property.
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property.
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.
TickHeight | Gets or sets the height of a tick. This is a dependency property.
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.
TickShape | Gets or sets the shape of the ticks. This is a dependency property.
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property.
TickType | Gets the type of ticks this object applies to.
TickWidth | Gets or sets the width of a tick. This is a dependency property.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Fields

TickSettings Fields
[image]

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property.
CustomIntervalsProperty | Identifies the CustomIntervals dependency property.
FillProperty | Identifies the Fill dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
LabelAlignmentProperty | Identifies the LabelAlignment dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationProperty | Identifies the LabelRotation dependency property.
LabelTemplateProperty | Identifies the LabelTemplate dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property.
ShowTicksProperty | Identifies the ShowTicks dependency property.
StepProperty | Identifies the Step dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickAlignmentProperty | Identifies the TickAlignment dependency property.
TickHeightProperty | Identifies the TickHeight dependency property.
TickOffsetProperty | Identifies the TickOffset dependency property.
TickShapeProperty | Identifies the TickShape dependency property.
TickTemplateProperty | Identifies the TickTemplate dependency property.
TickWidthProperty | Identifies the TickWidth dependency property.

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.CountProperty Field

TickSettings.CountProperty Field
[image]

Identifies the Count dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CountProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.CustomIntervalsProperty Field

TickSettings.CustomIntervalsProperty Field
[image]

Identifies the CustomIntervals dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomIntervalsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomIntervalsProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.FillProperty Field

TickSettings.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.FontSizeProperty Field

TickSettings.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.FontWeightProperty Field

TickSettings.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontWeightProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelAlignmentProperty Field

TickSettings.LabelAlignmentProperty Field
[image]

Identifies the LabelAlignment dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelAlignmentProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelForegroundProperty Field

TickSettings.LabelForegroundProperty Field
[image]

Identifies the LabelForeground dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelForegroundProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelFormatProperty Field

TickSettings.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelOffsetProperty Field

TickSettings.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelRotationProperty Field

TickSettings.LabelRotationProperty Field
[image]

Identifies the LabelRotation dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelRotationProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelTemplateProperty Field

TickSettings.LabelTemplateProperty Field
[image]

Identifies the LabelTemplate dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTemplateProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.ShowLabelsProperty Field

TickSettings.ShowLabelsProperty Field
[image]

Identifies the ShowLabels dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowLabelsProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.ShowMaxValueTickProperty Field

TickSettings.ShowMaxValueTickProperty Field
[image]

Identifies the ShowMaxValueTick dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowMaxValueTickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowMaxValueTickProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.ShowTicksProperty Field

TickSettings.ShowTicksProperty Field
[image]

Identifies the ShowTicks dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTicksProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTicksProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.StepProperty Field

TickSettings.StepProperty Field
[image]

Identifies the Step dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StepProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.StrokeProperty Field

TickSettings.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.StrokeThicknessProperty Field

TickSettings.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickAlignmentProperty Field

TickSettings.TickAlignmentProperty Field
[image]

Identifies the TickAlignment dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickAlignmentProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickHeightProperty Field

TickSettings.TickHeightProperty Field
[image]

Identifies the TickHeight dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickHeightProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickOffsetProperty Field

TickSettings.TickOffsetProperty Field
[image]

Identifies the TickOffset dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickOffsetProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickShapeProperty Field

TickSettings.TickShapeProperty Field
[image]

Identifies the TickShape dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickShapeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickShapeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickTemplateProperty Field

TickSettings.TickTemplateProperty Field
[image]

Identifies the TickTemplate dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickTemplateProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickWidthProperty Field

TickSettings.TickWidthProperty Field
[image]

Identifies the TickWidth dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickWidthProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Constructor

TickSettings Constructor
[image]

Initializes a new instance of the TickSettings class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected TickSettings ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Methods

TickSettings Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.OnPropertyChanged Method

TickSettings.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings Properties

TickSettings Properties
[image]

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property.
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.
Fill | Gets or sets the fill brush of the ticks. This is a dependency property.
FontSize | Gets or sets the font size of the labels. This is a dependency property.
FontWeight | Gets or sets the font weight of the labels. This is a dependency property.
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property.
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property.
LabelFormat | Gets or sets the format for label texts.
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property.
LabelTemplate | Gets or sets the DataTemplate to use for label representation. This is a dependency property.
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property.
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property.
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property.
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property.
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property.
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.
TickHeight | Gets or sets the height of a tick. This is a dependency property.
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.
TickShape | Gets or sets the shape of the ticks. This is a dependency property.
TickTemplate | Gets or sets the DataTemplate to use for tick representation. This is a dependency property.
TickType | Gets the type of ticks this object applies to.
TickWidth | Gets or sets the width of a tick. This is a dependency property.

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.Count Property

TickSettings.Count Property
[image]

Gets or sets the number of ticks and labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public int Count { get; set; }

Visual Basic [image] Copy Code

Public Property Count As Integer

Property Value

A positive integer value.

Remarks

This property is mutually exclusive with the Step property. If both are specified the Step property will take precedence.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
Step Property


MindFusion.Gauges.Wpf.TickSettings.CustomIntervals Property

TickSettings.CustomIntervals Property
[image]

Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public CustomIntervalCollection CustomIntervals { get; set; }

Visual Basic [image] Copy Code

Public Property CustomIntervals As CustomIntervalCollection

Property Value

An instance of the CustomIntervalCollection class.

Remarks

The custom intervals can be used to give specific appearance to the ticks within a particular range.

Example

The following example defines a linear scale. The major ticks of the scale in the range [60..100] are filled with a Red brush.

XAML [image] Copy Code

<gauges:LinearScale>
<gauges:LinearScale.MajorTickSettings>
<gauges:TickSettings>
<gauges:TickSettings.CustomIntervals>
<gauges:CustomInterval MinValue="60" Fill="Red" />
</gauges:TickSettings.CustomIntervals>
</gauges:TickSettings>
</gauges:LinearScale.MajorTickSettings>
</gauges:LinearScale>

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.Fill Property

TickSettings.Fill Property
[image]

Gets or sets the fill brush of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Wpf.TickSettings.FontSize Property

TickSettings.FontSize Property
[image]

Gets or sets the font size of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Length

Property Value

An instance of the Length structure.

Remarks

The font size of type Length so that it can be specified as a relative value.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
FontWeight Property


MindFusion.Gauges.Wpf.TickSettings.FontWeight Property

TickSettings.FontWeight Property
[image]

Gets or sets the font weight of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A .NET FontWeight object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
FontSize Property


MindFusion.Gauges.Wpf.TickSettings.LabelAlignment Property

TickSettings.LabelAlignment Property
[image]

Gets or sets the alignment of the labels relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Alignment LabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LabelAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
LabelOffset Property
LabelRotation Property


MindFusion.Gauges.Wpf.TickSettings.LabelForeground Property

TickSettings.LabelForeground Property
[image]

Gets or sets the brush used to paint label texts. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush LabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelForeground As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelFormat Property

TickSettings.LabelFormat Property
[image]

Gets or sets the format for label texts.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

A standard numeric format string.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.LabelOffset Property

TickSettings.LabelOffset Property
[image]

Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
LabelOffset Property
LabelRotation Property


MindFusion.Gauges.Wpf.TickSettings.LabelRotation Property

TickSettings.LabelRotation Property
[image]

Gets or sets the rotation mode of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public LabelRotation LabelRotation { get; set; }

Visual Basic [image] Copy Code

Public Property LabelRotation As LabelRotation

Property Value

An instance of the LabelRotation enumeration.

Remarks

For more information on the effect of this property, check the LabelRotation enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
LabelAlignment Property
LabelOffset Property


MindFusion.Gauges.Wpf.TickSettings.LabelTemplate Property

TickSettings.LabelTemplate Property
[image]

Gets or sets the DataTemplate to use for label representation. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public DataTemplate LabelTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property LabelTemplate As DataTemplate

Property Value

A .NET DataTemplate object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.ShowLabels Property

TickSettings.ShowLabels Property
[image]

Gets or sets a value indicating whether the labels are visible. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool ShowLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLabels As Boolean

Property Value

true to show the labels; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
ShowTicks Property


MindFusion.Gauges.Wpf.TickSettings.ShowMaxValueTick Property

TickSettings.ShowMaxValueTick Property
[image]

Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public DisplayType ShowMaxValueTick { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMaxValueTick As DisplayType

Property Value

true, to always show a tick for the max value of the scale; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.ShowTicks Property

TickSettings.ShowTicks Property
[image]

Gets or sets a value indicating whether the ticks are visible. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public bool ShowTicks { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTicks As Boolean

Property Value

true to show the ticks; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
ShowLabels Property


MindFusion.Gauges.Wpf.TickSettings.Step Property

TickSettings.Step Property
[image]

Gets or sets the value between adjacent ticks and labels. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double Step { get; set; }

Visual Basic [image] Copy Code

Public Property Step As Double

Property Value

A positive double value.

Remarks

This property is mutually exclusive with the Count property. If both are specified the Step property will take precedence.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
Count Property


MindFusion.Gauges.Wpf.TickSettings.Stroke Property

TickSettings.Stroke Property
[image]

Gets or sets the stroke brush of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Wpf.TickSettings.StrokeThickness Property

TickSettings.StrokeThickness Property
[image]

Gets or sets the thickness of tick strokes. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Wpf.TickSettings.TickAlignment Property

TickSettings.TickAlignment Property
[image]

Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Alignment TickAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TickAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickOffset Property


MindFusion.Gauges.Wpf.TickSettings.TickHeight Property

TickSettings.TickHeight Property
[image]

Gets or sets the height of a tick. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length TickHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TickHeight As Length

Property Value

An instance of the Length structure.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickWidth Property


MindFusion.Gauges.Wpf.TickSettings.TickOffset Property

TickSettings.TickOffset Property
[image]

Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length TickOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TickOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickAlignment Property


MindFusion.Gauges.Wpf.TickSettings.TickShape Property

TickSettings.TickShape Property
[image]

Gets or sets the shape of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public TickShape TickShape { get; set; }

Visual Basic [image] Copy Code

Public Property TickShape As TickShape

Property Value

A member of the TickShape enumeration.

Remarks

In order to use a custom shape for the ticks, set this property to Custom and assign the DataTemplate that will give the appearance of the ticks to the TickTemplate property.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickTemplate Property


MindFusion.Gauges.Wpf.TickSettings.TickTemplate Property

TickSettings.TickTemplate Property
[image]

Gets or sets the DataTemplate to use for tick representation. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public DataTemplate TickTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property TickTemplate As DataTemplate

Property Value

A .NET DataTemplate object.

Remarks

This property is used only when the TickShape property is set to Custom. Otherwise the template of the ticks is internally set to a DataTemplate corresponding to the selected tick shape.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickShape Property


MindFusion.Gauges.Wpf.TickSettings.TickType Property

TickSettings.TickType Property
[image]

Gets the type of ticks this object applies to.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public TickType TickType { get; set; }

Visual Basic [image] Copy Code

Public Property TickType As TickType

Property Value

A member of the TickType enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickSettings.TickWidth Property

TickSettings.TickWidth Property
[image]

Gets or sets the width of a tick. This is a dependency property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public Length TickWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TickWidth As Length

Property Value

An instance of the Length structure.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Wpf Namespace
TickHeight Property


MindFusion.Gauges.Wpf.TickSettings Events

TickSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TickSettings Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickShape Enumeration

TickShape Enumeration
[image]

Indicates the shape of a scale tick.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum TickShape

Visual Basic [image] Copy Code

Public Enum TickShape

Members

Member name | Description
Arrow1 | Specifies an arrow shape.
Arrow2 | Specifies an arrow shape.
Arrow3 | Specifies an arrow shape.
Custom | Specifies a custom shape.
Ellipse | Specifies an elliptical shape.
Line | Specifies a line as a shape.
None | Specifies an empty shape, that is, the tick is not displayed.
Rectangle | Specifies a rectangular shape.
Rhombus | Specifies a rhombus as a shape.
RoundRect | Specifies a rounded rectangle as a shape.
Triangle | Specifies a triangular shape.

Remarks

The values of this enumeration are assigned to the TickShape property of the TickSettings class.Custom value is specified the user is expected to supply a DataTemplate for the ticks through the TickTemplate property.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.TickType Enumeration

TickType Enumeration
[image]

Indicates the type of a scale tick.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public enum TickType

Visual Basic [image] Copy Code

Public Enum TickType

Members

Member name | Description
Major | Specifies a major tick.
Middle | Specifies a middle tick.
Minor | Specifies a minor tick.
None | Specifies ticks of an unknown type.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Class

ValueChangedEventArgs(T) Class
[image]

Contains the arguments passed to value change notification handlers.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class ValueChangedEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class ValueChangedEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Wpf.ValueChangedEventArgs(T)

See Also

ValueChangedEventArgs(T) Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Members

ValueChangedEventArgs(T) Members
Constructors Properties
[image]

Contains the arguments passed to value change notification handlers.

The following tables list the members exposed by the ValueChangedEventArgs(T) type.

Public Constructors

Name | Description
ValueChangedEventArgs | Overloaded. Initializes a new instance of the ValueChangedEventArgs class.

Public Properties

Name | Description
NewValue | Gets the new value of the changed property.
OldValue | Gets the previous value of the changed property.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Constructor

ValueChangedEventArgs(T) Constructor
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Overload List

Name | Description
ValueChangedEventArgs(T) () | Initializes a new instance of the ValueChangedEventArgs class.
ValueChangedEventArgs(T) (T, T) | Initializes a new instance of the ValueChangedEventArgs class.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Constructor ()

ValueChangedEventArgs(T) Constructor ()
See Also
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public ValueChangedEventArgs<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ValueChangedEventArgs(T) Constructor Overload List
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Constructor (T, T)

ValueChangedEventArgs(T) Constructor (T, T)
See Also
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public ValueChangedEventArgs<T> (
T oldValue,
T newValue
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
oldValue As T, _
newValue As T _
)

Parameters

oldValue

The previous value of the changed property.

newValue

The new value of the changed property.

See Also

ValueChangedEventArgs(T) Constructor Overload List
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T) Properties

ValueChangedEventArgs(T) Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new value of the changed property.
OldValue | Gets the previous value of the changed property.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T).NewValue Property

ValueChangedEventArgs(T).NewValue Property
[image]

Gets the new value of the changed property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public T NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As T

Property Value

See Also

ValueChangedEventArgs(T) Members
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventArgs(T).OldValue Property

ValueChangedEventArgs(T).OldValue Property
[image]

Gets the previous value of the changed property.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public T OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As T

Property Value

See Also

ValueChangedEventArgs(T) Members
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.ValueChangedEventHandler(T) Delegate

ValueChangedEventHandler(T) Delegate
[image]

Represents the method that will handle value change notification events.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public delegate void ValueChangedEventHandler<T> (
Object sender,
ValueChangedEventArgs<T> e
)

Visual Basic [image] Copy Code

Public Delegate Sub ValueChangedEventHandler(Of T) ( _
sender As Object, _
e As ValueChangedEventArgs(Of T) _
)

Parameters

sender

The source of the event.

e
A ValueChangedEventArgs<T> that contains the event data.

See Also

MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter Class

VisibilityConverter Class
Remarks See Also
[image]

Converts boolean values to Visibility and vice versa.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public class VisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibilityConverter
Implements IValueConverter

Remarks

This converter can be useful when you need to bind properties of type Visibility to boolean values.

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Wpf.VisibilityConverter

See Also

VisibilityConverter Members
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter Members

VisibilityConverter Members
Constructors Methods
[image]

Converts boolean values to Visibility and vice versa.

The following tables list the members exposed by the VisibilityConverter type.

Public Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibilityConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter Constructor

VisibilityConverter Constructor
[image]

Initializes a new instance of the VisibilityConverter class.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public VisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibilityConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter Methods

VisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibilityConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter.Convert Method

VisibilityConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Gauges.Wpf.VisibilityConverter.ConvertBack Method

VisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Wpf
Assembly: MindFusion.Gauges.Wpf

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Gauges.Wpf Namespace


MindFusion.Geometry Namespace

MindFusion.Geometry Namespace
Classes

Classes

Class | Description
Convert | Provides various conversions.


MindFusion.Geometry.Convert Class

Convert Class
[image]

Provides various conversions.

Namespace: MindFusion.Geometry
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class Convert

Visual Basic [image] Copy Code

Public NotInheritable Class Convert

Inheritance Hierarchy

System.Object
MindFusion.Geometry.Convert

See Also

Convert Members
MindFusion.Geometry Namespace


MindFusion.Geometry.Convert Members

Convert Members
Methods
[image]

Provides various conversions.

The following tables list the members exposed by the Convert type.

Public Methods

Name | Description
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

See Also

Convert Class
MindFusion.Geometry Namespace


MindFusion.Geometry.Convert Methods

Convert Methods
[image]

Public Methods

Name | Description
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

See Also

Convert Class
MindFusion.Geometry Namespace


MindFusion.Geometry.Convert.CartesianToPolar Method

Convert.CartesianToPolar Method
[image]

Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Geometry
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static void CartesianToPolar (
Point coordCenter,
Point point,
ref double a,
ref double r
)

Visual Basic [image] Copy Code

Public Shared Sub CartesianToPolar( _
coordCenter As Point, _
point As Point, _
ByRef a As Double, _
ByRef r As Double _
)

Parameters

coordCenter

point

a

r

See Also

Convert Members
Convert Class
MindFusion.Geometry Namespace


MindFusion.Geometry.Convert.PolarToCartesian Method

Convert.PolarToCartesian Method
[image]

Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion.Geometry
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Point PolarToCartesian (
Point coordCenter,
double a,
double r
)

Visual Basic [image] Copy Code

Public Shared Function PolarToCartesian( _
coordCenter As Point, _
a As Double, _
r As Double _
) As Point

Parameters

coordCenter

a

r

Return Value

See Also

Convert Members
Convert Class
MindFusion.Geometry Namespace


MindFusion.HolidayProviders Namespace

MindFusion.HolidayProviders Namespace
Classes Interfaces

Classes

Class | Description
AustraliaHolidayProvider | Provides a list with the national holidays in Australia.
FranceHolidayProvider | Provides a list with the most common holidays in France.
FranceHolidays | A strongly-typed resource class, for looking up localized strings, etc.
GermanyHolidayProvider | Provides a list with the most common holidays in Germany.
Holiday | Represents a holiday.
HolidayProvider | The base class of all holiday providers.
RussiaHolidayProvider | Provides a list with the most common holidays in Russia.
UKHolidayProvider | Provides a list with the most common holidays in United Kingdoms.
USHolidayProvider | Provides a list with the most common holidays in United States.

Interfaces

Interface | Description
IHolidayProvider | Represents an object, which can provide arrays of culture-specific holidays.


MindFusion.HolidayProviders.AustraliaHolidayProvider Class

AustraliaHolidayProvider Class
[image]

Provides a list with the national holidays in Australia.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class AustraliaHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class AustraliaHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.AustraliaHolidayProvider

See Also

AustraliaHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider Members

AustraliaHolidayProvider Members
Constructors Methods
[image]

Provides a list with the national holidays in Australia.

The following tables list the members exposed by the AustraliaHolidayProvider type.

Public Constructors

Name | Description
AustraliaHolidayProvider | Initializes a new instance of the AustraliaHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider Constructor

AustraliaHolidayProvider Constructor
[image]

Initializes a new instance of the AustraliaHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public AustraliaHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider Methods

AustraliaHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider.GetHolidays Method

AustraliaHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
AustraliaHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
AustraliaHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

AustraliaHolidayProvider Members
AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider.GetHolidays Method (DateTime, DateTime)

AustraliaHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
AustraliaHolidayProvider Members
AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.AustraliaHolidayProvider.GetHolidays Method (Int32)

AustraliaHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
AustraliaHolidayProvider Members
AustraliaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider Class

FranceHolidayProvider Class
[image]

Provides a list with the most common holidays in France.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class FranceHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class FranceHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.FranceHolidayProvider

See Also

FranceHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider Members

FranceHolidayProvider Members
Constructors Methods
[image]

Provides a list with the most common holidays in France.

The following tables list the members exposed by the FranceHolidayProvider type.

Public Constructors

Name | Description
FranceHolidayProvider | Initializes a new instance of the FranceHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider Constructor

FranceHolidayProvider Constructor
[image]

Initializes a new instance of the FranceHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public FranceHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider Methods

FranceHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider.GetHolidays Method

FranceHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
FranceHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
FranceHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

FranceHolidayProvider Members
FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider.GetHolidays Method (DateTime, DateTime)

FranceHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
FranceHolidayProvider Members
FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidayProvider.GetHolidays Method (Int32)

FranceHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
FranceHolidayProvider Members
FranceHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays Class

FranceHolidays Class
Remarks See Also
[image]

A strongly-typed resource class, for looking up localized strings, etc.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class FranceHolidays

Visual Basic [image] Copy Code

Public Class FranceHolidays

Remarks

This class contains the localized names of the France holidays. It is for internal use only.

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.FranceHolidays

See Also

FranceHolidays Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays Members

FranceHolidays Members
Properties
[image]

A strongly-typed resource class, for looking up localized strings, etc.

The following tables list the members exposed by the FranceHolidays type.

Public Properties

Name | Description
allSaintsDay | Looks up a localized string similar to Toussaint.
armisticeDay | Looks up a localized string similar to Armistice de 1918.
ascensionDay | Looks up a localized string similar to Ascension.
assumptionOfMaryToHeaven | Looks up a localized string similar to Assomption.
bastilleDay | Looks up a localized string similar to Fête nationale.
christmasDay | Looks up a localized string similar to Noël.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
easterMonday | Looks up a localized string similar to Lundi de Pâques.
eastern | Looks up a localized string similar to Pâques.
goodFriday | Looks up a localized string similar to Vendredi saint.
labourDay | Looks up a localized string similar to Fête du Travail.
newYearDay | Looks up a localized string similar to Nouvel an.
ResourceManager | Returns the cached ResourceManager instance used by this class.
stStephenDay | Looks up a localized string similar to Saint-Étienne.
victoryInEuropeDay | Looks up a localized string similar to Fête de la Victoire.
whitMonday | Looks up a localized string similar to Lundi de Pentecôte.

See Also

FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays Properties

FranceHolidays Properties
[image]

Public Properties

Name | Description
allSaintsDay | Looks up a localized string similar to Toussaint.
armisticeDay | Looks up a localized string similar to Armistice de 1918.
ascensionDay | Looks up a localized string similar to Ascension.
assumptionOfMaryToHeaven | Looks up a localized string similar to Assomption.
bastilleDay | Looks up a localized string similar to Fête nationale.
christmasDay | Looks up a localized string similar to Noël.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
easterMonday | Looks up a localized string similar to Lundi de Pâques.
eastern | Looks up a localized string similar to Pâques.
goodFriday | Looks up a localized string similar to Vendredi saint.
labourDay | Looks up a localized string similar to Fête du Travail.
newYearDay | Looks up a localized string similar to Nouvel an.
ResourceManager | Returns the cached ResourceManager instance used by this class.
stStephenDay | Looks up a localized string similar to Saint-Étienne.
victoryInEuropeDay | Looks up a localized string similar to Fête de la Victoire.
whitMonday | Looks up a localized string similar to Lundi de Pentecôte.

See Also

FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.allSaintsDay Property

FranceHolidays.allSaintsDay Property
[image]

Looks up a localized string similar to Toussaint.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string allSaintsDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property allSaintsDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.armisticeDay Property

FranceHolidays.armisticeDay Property
[image]

Looks up a localized string similar to Armistice de 1918.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string armisticeDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property armisticeDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.ascensionDay Property

FranceHolidays.ascensionDay Property
[image]

Looks up a localized string similar to Ascension.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string ascensionDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ascensionDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.assumptionOfMaryToHeaven Property

FranceHolidays.assumptionOfMaryToHeaven Property
[image]

Looks up a localized string similar to Assomption.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string assumptionOfMaryToHeaven { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property assumptionOfMaryToHeaven As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.bastilleDay Property

FranceHolidays.bastilleDay Property
[image]

Looks up a localized string similar to Fête nationale.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string bastilleDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property bastilleDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.christmasDay Property

FranceHolidays.christmasDay Property
[image]

Looks up a localized string similar to Noël.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string christmasDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property christmasDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.Culture Property

FranceHolidays.Culture Property
[image]

Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static CultureInfo Culture { get; set; }

Visual Basic [image] Copy Code

Public Shared Property Culture As CultureInfo

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.easterMonday Property

FranceHolidays.easterMonday Property
[image]

Looks up a localized string similar to Lundi de Pâques.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string easterMonday { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property easterMonday As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.eastern Property

FranceHolidays.eastern Property
[image]

Looks up a localized string similar to Pâques.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string eastern { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property eastern As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.goodFriday Property

FranceHolidays.goodFriday Property
[image]

Looks up a localized string similar to Vendredi saint.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string goodFriday { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property goodFriday As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.labourDay Property

FranceHolidays.labourDay Property
[image]

Looks up a localized string similar to Fête du Travail.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string labourDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property labourDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.newYearDay Property

FranceHolidays.newYearDay Property
[image]

Looks up a localized string similar to Nouvel an.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string newYearDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property newYearDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.ResourceManager Property

FranceHolidays.ResourceManager Property
[image]

Returns the cached ResourceManager instance used by this class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static ResourceManager ResourceManager { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ResourceManager As ResourceManager

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.stStephenDay Property

FranceHolidays.stStephenDay Property
[image]

Looks up a localized string similar to Saint-Étienne.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string stStephenDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property stStephenDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.victoryInEuropeDay Property

FranceHolidays.victoryInEuropeDay Property
[image]

Looks up a localized string similar to Fête de la Victoire.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string victoryInEuropeDay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property victoryInEuropeDay As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.FranceHolidays.whitMonday Property

FranceHolidays.whitMonday Property
[image]

Looks up a localized string similar to Lundi de Pentecôte.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public static string whitMonday { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property whitMonday As String

Property Value

See Also

FranceHolidays Members
FranceHolidays Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider Class

GermanyHolidayProvider Class
[image]

Provides a list with the most common holidays in Germany.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class GermanyHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class GermanyHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.GermanyHolidayProvider

See Also

GermanyHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider Members

GermanyHolidayProvider Members
Constructors Methods
[image]

Provides a list with the most common holidays in Germany.

The following tables list the members exposed by the GermanyHolidayProvider type.

Public Constructors

Name | Description
GermanyHolidayProvider | Initializes a new instance of the GermanyHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

GermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider Constructor

GermanyHolidayProvider Constructor
[image]

Initializes a new instance of the GermanyHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public GermanyHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

InGermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider Methods

GermanyHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

GermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider.GetHolidays Method

GermanyHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
GermanyHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
GermanyHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

GermanyHolidayProvider Members
GermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider.GetHolidays Method (DateTime, DateTime)

GermanyHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
GermanyHolidayProvider Members
GermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.GermanyHolidayProvider.GetHolidays Method (Int32)

GermanyHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
GermanyHolidayProvider Members
GermanyHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Class

Holiday Class
Remarks See Also
[image]

Represents a holiday.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class Holiday

Visual Basic [image] Copy Code

Public Class Holiday

Remarks

Instances of this class are created and returned by the GetHolidays method of the IHolidayProvider implementations.

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.Holiday

See Also

Holiday Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Members

Holiday Members
Constructors Properties
[image]

Represents a holiday.

The following tables list the members exposed by the Holiday type.

Public Constructors

Name | Description
Holiday | Overloaded. Initializes a new instance of the Holiday class.

Public Properties

Name | Description
Date | Gets or sets the start date of the holiday.
EndDate | Gets or sets the end date of the holiday.
IsDayOff | Gets or sets a value indicating whether the holiday is a rest day.
Title | Gets or sets the title of the holiday.

See Also

Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Constructor

Holiday Constructor
[image]

Initializes a new instance of the Holiday class.

Overload List

Name | Description
Holiday () | Initializes a new instance of the Holiday class.
Holiday (DateTime, DateTime, String) | Initializes a new instance of the Holiday class with the specified start and end date and title.
Holiday (DateTime, DateTime, String, Boolean) | Initializes a new instance of the Holiday class with the specified start and end date and title.

See Also

Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Constructor ()

Holiday Constructor ()
See Also
[image]

Initializes a new instance of the Holiday class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Holiday Constructor Overload List
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Constructor (DateTime, DateTime, String)

Holiday Constructor (DateTime, DateTime, String)
See Also
[image]

Initializes a new instance of the Holiday class with the specified start and end date and title.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday (
DateTime start,
DateTime end,
string title
)

Visual Basic [image] Copy Code

Public New ( _
start As DateTime, _
end As DateTime, _
title As String _
)

Parameters

start

The start date of the holiday.

end

The end date of the holiday.

title

The title of the holiday.

See Also

Holiday Constructor Overload List
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Constructor (DateTime, DateTime, String, Boolean)

Holiday Constructor (DateTime, DateTime, String, Boolean)
See Also
[image]

Initializes a new instance of the Holiday class with the specified start and end date and title.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday (
DateTime start,
DateTime end,
string title,
bool isDayOff
)

Visual Basic [image] Copy Code

Public New ( _
start As DateTime, _
end As DateTime, _
title As String, _
isDayOff As Boolean _
)

Parameters

start

The start date of the holiday.

end

The end date of the holiday.

title

The title of the holiday.

isDayOff

A value indicating whether the holiday is a rest day.

See Also

Holiday Constructor Overload List
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday Properties

Holiday Properties
[image]

Public Properties

Name | Description
Date | Gets or sets the start date of the holiday.
EndDate | Gets or sets the end date of the holiday.
IsDayOff | Gets or sets a value indicating whether the holiday is a rest day.
Title | Gets or sets the title of the holiday.

See Also

Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday.Date Property

Holiday.Date Property
[image]

Gets or sets the start date of the holiday.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

A .NET DateTime instance.

See Also

Holiday Members
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday.EndDate Property

Holiday.EndDate Property
[image]

Gets or sets the end date of the holiday.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }

Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

A .NET DateTime instance.

See Also

Holiday Members
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday.IsDayOff Property

Holiday.IsDayOff Property
[image]

Gets or sets a value indicating whether the holiday is a rest day.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public bool IsDayOff { get; set; }

Visual Basic [image] Copy Code

Public Property IsDayOff As Boolean

Property Value

true, if the holiday is a non-working day; otherwise, false.

See Also

Holiday Members
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.Holiday.Title Property

Holiday.Title Property
[image]

Gets or sets the title of the holiday.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

Holiday Members
Holiday Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.HolidayProvider Class

HolidayProvider Class
[image]

The base class of all holiday providers.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public abstract class HolidayProvider

Visual Basic [image] Copy Code

Public MustInherit Class HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.AustraliaHolidayProvider
MindFusion.HolidayProviders.FranceHolidayProvider
MindFusion.HolidayProviders.GermanyHolidayProvider
MindFusion.HolidayProviders.RussiaHolidayProvider
MindFusion.HolidayProviders.UKHolidayProvider
MindFusion.HolidayProviders.USHolidayProvider

See Also

HolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.HolidayProvider Members

HolidayProvider Members
Constructors
[image]

The base class of all holiday providers.

The following tables list the members exposed by the HolidayProvider type.

Protected Constructors

Name | Description
HolidayProvider | Initializes a new instance of the HolidayProvider class.

See Also

HolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.HolidayProvider Constructor

HolidayProvider Constructor
[image]

Initializes a new instance of the HolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

protected HolidayProvider ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

HolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider Interface

IHolidayProvider Interface
[image]

Represents an object, which can provide arrays of culture-specific holidays.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public interface IHolidayProvider

Visual Basic [image] Copy Code

Public Interface IHolidayProvider

See Also

IHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider Members

IHolidayProvider Members
Methods
[image]

Represents an object, which can provide arrays of culture-specific holidays.

The following tables list the members exposed by the IHolidayProvider type.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

IHolidayProvider Interface
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider Methods

IHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

IHolidayProvider Interface
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider.GetHolidays Method

IHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
IHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
IHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

IHolidayProvider Members
IHolidayProvider Interface
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider.GetHolidays Method (DateTime, DateTime)

IHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public abstract Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public MustOverride Function GetHolidays ( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
IHolidayProvider Members
IHolidayProvider Interface
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.IHolidayProvider.GetHolidays Method (Int32)

IHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public abstract Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public MustOverride Function GetHolidays ( _
year As Integer _
) As Holiday()

Parameters

year
The year of interest.

Return Value

An array of Holiday objects representing the holidays in the specified year.

See Also

GetHolidays Method Overload List
IHolidayProvider Members
IHolidayProvider Interface
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider Class

RussiaHolidayProvider Class
[image]

Provides a list with the most common holidays in Russia.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class RussiaHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class RussiaHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.RussiaHolidayProvider

See Also

RussiaHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider Members

RussiaHolidayProvider Members
Constructors Methods
[image]

Provides a list with the most common holidays in Russia.

The following tables list the members exposed by the RussiaHolidayProvider type.

Public Constructors

Name | Description
RussiaHolidayProvider | Initializes a new instance of the RussiaHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider Constructor

RussiaHolidayProvider Constructor
[image]

Initializes a new instance of the RussiaHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public RussiaHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider Methods

RussiaHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider.GetHolidays Method

RussiaHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
RussiaHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
RussiaHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

RussiaHolidayProvider Members
RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider.GetHolidays Method (DateTime, DateTime)

RussiaHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
RussiaHolidayProvider Members
RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.RussiaHolidayProvider.GetHolidays Method (Int32)

RussiaHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
RussiaHolidayProvider Members
RussiaHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider Class

UKHolidayProvider Class
[image]

Provides a list with the most common holidays in United Kingdoms.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class UKHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class UKHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.UKHolidayProvider

See Also

UKHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider Members

UKHolidayProvider Members
Constructors Methods
[image]

Provides a list with the most common holidays in United Kingdoms.

The following tables list the members exposed by the UKHolidayProvider type.

Public Constructors

Name | Description
UKHolidayProvider | Initializes a new instance of the UKHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider Constructor

UKHolidayProvider Constructor
[image]

Initializes a new instance of the UKHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public UKHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider Methods

UKHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider.GetHolidays Method

UKHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
UKHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
UKHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

UKHolidayProvider Members
UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider.GetHolidays Method (DateTime, DateTime)

UKHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
UKHolidayProvider Members
UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.UKHolidayProvider.GetHolidays Method (Int32)

UKHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Function GetHolidays( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
UKHolidayProvider Members
UKHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider Class

USHolidayProvider Class
[image]

Provides a list with the most common holidays in United States.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public class USHolidayProvider : HolidayProvider

Visual Basic [image] Copy Code

Public Class USHolidayProvider
Inherits HolidayProvider

Inheritance Hierarchy

System.Object
MindFusion.HolidayProviders.HolidayProvider
MindFusion.HolidayProviders.USHolidayProvider

See Also

USHolidayProvider Members
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider Members

USHolidayProvider Members
Constructors Methods
[image]

Provides a list with the most common holidays in United States.

The following tables list the members exposed by the USHolidayProvider type.

Public Constructors

Name | Description
USHolidayProvider | Initializes a new instance of the USHolidayProvider class.

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider Constructor

USHolidayProvider Constructor
[image]

Initializes a new instance of the USHolidayProvider class.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public USHolidayProvider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider Methods

USHolidayProvider Methods
[image]

Public Methods

Name | Description
GetHolidays | Overloaded. Returns all holidays in a specified time interval.

See Also

USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider.GetHolidays Method

USHolidayProvider.GetHolidays Method
[image]

Returns all holidays in a specified time interval.

Overload List

Name | Description
USHolidayProvider.GetHolidays (DateTime, DateTime) | Returns all holidays in the specified time interval.
USHolidayProvider.GetHolidays (Int32) | Returns all holidays in the specified year.

See Also

USHolidayProvider Members
USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider.GetHolidays Method (DateTime, DateTime)

USHolidayProvider.GetHolidays Method (DateTime, DateTime)
See Also
[image]

Returns all holidays in the specified time interval.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public virtual Holiday[] GetHolidays (
DateTime from,
DateTime to
)

Visual Basic [image] Copy Code

Public Overridable Function GetHolidays ( _
from As DateTime, _
to As DateTime _
) As Holiday()

Parameters

from

The start of the time interval.

to

The end of the time interval.

Return Value

An array of Holiday objects representing the holidays in the interval of interest.

See Also

GetHolidays Method Overload List
USHolidayProvider Members
USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.HolidayProviders.USHolidayProvider.GetHolidays Method (Int32)

USHolidayProvider.GetHolidays Method (Int32)
See Also
[image]

Returns all holidays in the specified year.

Namespace: MindFusion.HolidayProviders
Assembly: MindFusion.HolidayProviders

Syntax

C# [image] Copy Code

public virtual Holiday[] GetHolidays (
int year
)

Visual Basic [image] Copy Code

Public Overridable Function GetHolidays ( _
year As Integer _
) As Holiday()

Parameters

year

The year.

Return Value

An array of Holiday objects representing the holidays in the year of interest.

See Also

GetHolidays Method Overload List
USHolidayProvider Members
USHolidayProvider Class
MindFusion.HolidayProviders Namespace


MindFusion.Layout Namespace

MindFusion.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayoutStatistics | Contains the accumulated costs for a graph configuration produced by AnnealLayout.
ConnectorRules | Represents a set of rules that are applied according to the logic identifiers of links.
FlowLayoutKeys | Defines keys that can be used to define FlowLayout rules.
FlowLayoutRules | A class representing a set of rules that define the behavior of the FlowLayout class.
LayoutRules | Summary description for LayoutRules.
NodeRules | Represents a set of rules that are applied according to the logic identifiers of node pairs.
Pair | Represents a coupling between two arbitrary objects.
SimpleKeys | Defines keys that can be used to define FlowLayout rules.
SimpleLinkLogic | Contains link identifiers for the predefined SimpleRules set of rules.
SimpleNodeLogic | Contains node identifiers for the predefined SimpleRules set of rules.
SimpleRules | Class of simple rules requisited for Flowlayout algorithm.

Interfaces

Interface | Description
RoutingOptions | Allows customization of various aspects of the link routing algorithm.

Delegates

Delegate | Description
RouteHeuristics | The link routing algorithm uses a heuristic function of this type in its prediction steps.

Enumerations

Enumeration | Description
AssistantType | Indicates the type of an assistant node in a tree.
BaseLayout | Specifies how OrthogonalRouter should arrange nodes.
FlowLayoutTraits | Values used as keys in FlowLayout rules.
HierarchicalLayoutTraits | Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
LayeredLayoutTraits | Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
OrderDirection | Values controlling the direction of link segments in FlowLayout rules.
PartitionMethod | Identifies graph partitioning methods supported by CompositeLayout.
PreferredRules | Specifies which set of rules to use.
SimpleOrientation | Specifies the preferred orientation for the main connector type in FlowLayout.
SpringLayoutMethod | Specifies what energy model SpringLayout should use for the simulation.
SpringLayoutTraits | Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
SwimlaneLayoutTraits | Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeLayoutTraits | Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeMapLayoutTraits | Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.


MindFusion.Layout.AnnealLayoutStatistics Class

AnnealLayoutStatistics Class
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class AnnealLayoutStatistics

Visual Basic [image] Copy Code

Public Class AnnealLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Layout.AnnealLayoutStatistics

See Also

AnnealLayoutStatistics Members
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Members

AnnealLayoutStatistics Members
Constructors Properties Methods
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

The following tables list the members exposed by the AnnealLayoutStatistics type.

Public Constructors

Name | Description
AnnealLayoutStatistics |

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Constructor

AnnealLayoutStatistics Constructor
[image]

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Methods

AnnealLayoutStatistics Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.ToString Method

AnnealLayoutStatistics.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Properties

AnnealLayoutStatistics Properties
[image]

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.BoundaryCost Property

AnnealLayoutStatistics.BoundaryCost Property
[image]

The total distance-to-boundary cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double BoundaryCost { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.DistributionCost Property

AnnealLayoutStatistics.DistributionCost Property
[image]

The total distribution cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double DistributionCost { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsCost Property

AnnealLayoutStatistics.EdgeCrossingsCost Property
[image]

The total edge crossings cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double EdgeCrossingsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsFound Property

AnnealLayoutStatistics.EdgeCrossingsFound Property
[image]

The number of edge crossings in the graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int EdgeCrossingsFound { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsFound As Integer

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeLengthsCost Property

AnnealLayoutStatistics.EdgeLengthsCost Property
[image]

The total edge lengths cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double EdgeLengthsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeLengthsCost As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.NodeEdgeDistance Property

AnnealLayoutStatistics.NodeEdgeDistance Property
[image]

The total node-to-edge-distance cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public double NodeEdgeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeEdgeDistance As Double

Property Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AssistantType Enumeration

AssistantType Enumeration
[image]

Indicates the type of an assistant node in a tree.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum AssistantType

Visual Basic [image] Copy Code

Public Enum AssistantType

Members

Member name | Description
Left | The node is an assistant and it is always positioned to the left of its parent.
None | The node is not an assistant.
Normal | The node is an assistant and its relative position is determined automatically by the layout.
Right | The node is an assistant and it is always positioned to the right of its parent.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.BaseLayout Enumeration

BaseLayout Enumeration
[image]

Specifies how OrthogonalRouter should arrange nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum BaseLayout

Visual Basic [image] Copy Code

Public Enum BaseLayout

Members

Member name | Description
Cascading | Use TreeLayout to arrange nodes.
Custom | Use the current node configuration.
Grid | Use GridLayout to arrange nodes.
Layered | Use LayeredLayout to arrange nodes.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Class

ConnectorRules Class
[image]

Represents a set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class ConnectorRules : LayoutRules

Visual Basic [image] Copy Code

Public Class ConnectorRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules

See Also

ConnectorRules Members
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Members

ConnectorRules Members
Properties Methods
[image]

Represents a set of rules that are applied according to the logic identifiers of links.

The following tables list the members exposed by the ConnectorRules type.

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected by such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected by such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2 (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules Properties

ConnectorRules Properties
[image]

Public Properties

Name | Description
DownOriented | Specifies a set of link identifiers for which nodes connected by such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
HorizontalBendOrientation | Specifies whether links should start with a horizontal segment.
LeftOriented | Specifies a set of link identifiers for which nodes connected by such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
RightOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.
UpOriented | Specifies a set of link identifiers for which nodes connected through such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

See Also

ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.DownOriented Property

ConnectorRules.DownOriented Property
[image]

Specifies a set of link identifiers for which nodes connected by such links will be placed downwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object DownOriented { get; set; }

Visual Basic [image] Copy Code

Public Property DownOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.HorizontalBendOrientation Property

ConnectorRules.HorizontalBendOrientation Property
[image]

Specifies whether links should start with a horizontal segment.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool HorizontalBendOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalBendOrientation As Boolean

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.LeftOriented Property

ConnectorRules.LeftOriented Property
[image]

Specifies a set of link identifiers for which nodes connected by such links will be placed leftwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object LeftOriented { get; set; }

Visual Basic [image] Copy Code

Public Property LeftOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.RightOriented Property

ConnectorRules.RightOriented Property
[image]

Specifies a set of link identifiers for which nodes connected through such links will be placed rightwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object RightOriented { get; set; }

Visual Basic [image] Copy Code

Public Property RightOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.ConnectorRules.UpOriented Property

ConnectorRules.UpOriented Property
[image]

Specifies a set of link identifiers for which nodes connected through such links will be placed upwards from already arranged nodes. You can assign a single logic identifier or an array of identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object UpOriented { get; set; }

Visual Basic [image] Copy Code

Public Property UpOriented As Object

Property Value

See Also

ConnectorRules Members
ConnectorRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Class

FlowLayoutKeys Class
[image]

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FlowLayoutKeys : SimpleKeys

Visual Basic [image] Copy Code

Public Class FlowLayoutKeys
Inherits SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

FlowLayoutKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Members

FlowLayoutKeys Members
Constructors Fields Properties Methods
[image]

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the FlowLayoutKeys type.

Public Constructors

Name | Description
FlowLayoutKeys | Initializes a new instance of the FlowLayoutKeys class.

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers. (Inherited from SimpleKeys.)
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout. (Inherited from SimpleKeys.)
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow). (Inherited from SimpleKeys.)
PossibleConnection | Specifies what kind of node connections are allowed. (Inherited from SimpleKeys.)
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
ShiftLaneProcesses | Shift subprocesses in Lane
Symbol | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class. (Inherited from SimpleKeys.)

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list. (Inherited from SimpleKeys.)

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Fields

FlowLayoutKeys Fields
[image]

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers. (Inherited from SimpleKeys.)
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key. (Inherited from SimpleKeys.)
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout. (Inherited from SimpleKeys.)
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow). (Inherited from SimpleKeys.)
PossibleConnection | Specifies what kind of node connections are allowed. (Inherited from SimpleKeys.)
PossibleNodeLogic | Specifies a list of identifiers for nodes that should be processed by FlowLayout.
ShiftLaneProcesses | Shift subprocesses in Lane
Symbol | Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.PossibleNodeLogic Field

FlowLayoutKeys.PossibleNodeLogic Field
[image]

Specifies a list of identifiers for nodes that should be processed by FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string PossibleNodeLogic

Visual Basic [image] Copy Code

Public Shared PossibleNodeLogic As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.ShiftLaneProcesses Field

FlowLayoutKeys.ShiftLaneProcesses Field
[image]

Shift subprocesses in Lane

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string ShiftLaneProcesses

Visual Basic [image] Copy Code

Public Shared ShiftLaneProcesses As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys.Symbol Field

FlowLayoutKeys.Symbol Field
[image]

Specifies a list of identifiers for nodes that should be placed with some offset from the main sequence line.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string Symbol

Visual Basic [image] Copy Code

Public Shared Symbol As String

See Also

FlowLayoutKeys Members
FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutKeys Constructor

FlowLayoutKeys Constructor
[image]

Initializes a new instance of the FlowLayoutKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FlowLayoutKeys ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayoutKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Class

FlowLayoutRules Class
[image]

A class representing a set of rules that define the behavior of the FlowLayout class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class FlowLayoutRules : LayoutRules

Visual Basic [image] Copy Code

Public Class FlowLayoutRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.FlowLayoutRules

See Also

FlowLayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Members

FlowLayoutRules Members
Constructors Properties Methods
[image]

A class representing a set of rules that define the behavior of the FlowLayout class.

The following tables list the members exposed by the FlowLayoutRules type.

Public Constructors

Name | Description
FlowLayoutRules | Initializes a new instance of the FlowLayoutRules class.

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
AddOutgoingBendRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2 (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails; (Inherited from LayoutRules.)
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Constructor

FlowLayoutRules Constructor
[image]

Initializes a new instance of the FlowLayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public FlowLayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Methods

FlowLayoutRules Methods
[image]

Public Methods

Name | Description
AddBendRule | Overloaded.
AddIncomingBendRule | Overloaded.
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
AddOutgoingBendRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2 (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails; (Inherited from LayoutRules.)
UseRuleManagedLinkBend | Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method

FlowLayoutRules.AddBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.
FlowLayoutRules.AddBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string nodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting or ending segment of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeTypes() As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

nodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the links starting or ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting or ending segments of a link according to the type of the node connected to that link.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddBendRule (
string[] nodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddBendRule( _
nodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

nodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting or ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method

FlowLayoutRules.AddIncomingBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.
FlowLayoutRules.AddIncomingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String, String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string destNodeType,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeType As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string linkType,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkType As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string originNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the ending segment of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's ending segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddIncomingBendRule Method (String[], String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the ending segments of an incoming link according to the type of the link's destination and origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddIncomingBendRule (
string[] destNodeTypes,
string[] linkTypes,
string[] originNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddIncomingBendRule( _
destNodeTypes() As String, _
linkTypes() As String, _
originNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links ending segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddIncomingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method

FlowLayoutRules.AddOutgoingBendRule Method
[image]

Overload List

Name | Description
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String, String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String, String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String, OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection) | Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.
FlowLayoutRules.AddOutgoingBendRule (String[], String[], String[], OrderDirection[]) | Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String, String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string originNodeType,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeType As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeType

The logic identifier of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String, String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string linkType,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkType As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkType

The logic identifier of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifier of links this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeType As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String, OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string destNodeType,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeType As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeType

The logic identifier of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection)
See Also
[image]

Adds a rule for the orientation of the starting segment of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection direction
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeTypes() As String, _
direction As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

direction

An OrderDirection value defining the orientation of the link's starting segment.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])

FlowLayoutRules.AddOutgoingBendRule Method (String[], String[], String[], OrderDirection[])
See Also
[image]

Adds a rule for the orientation of the starting segments of an outgoing link according to the type of the link's origin node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddOutgoingBendRule (
string[] originNodeTypes,
string[] linkTypes,
string[] destNodeTypes,
OrderDirection[] directions
)

Visual Basic [image] Copy Code

Public Function AddOutgoingBendRule( _
originNodeTypes() As String, _
linkTypes() As String, _
destNodeTypes() As String, _
directions() As OrderDirection _
) As Boolean

Parameters

originNodeTypes

The logic identifiers of nodes this rule should be applied to.

linkTypes

The logic identifiers of links this rule should be applied to.

destNodeTypes

The logic identifiers of nodes this rule should be applied to.

directions

An array of OrderDirection values defining the orientation of the links starting segments.

Return Value

true if this rule has been added successfully; otherwise, false.

See Also

AddOutgoingBendRule Method Overload List
FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.UseRuleManagedLinkBend Method

FlowLayoutRules.UseRuleManagedLinkBend Method
[image]

Specifies whether FlowLayout should use custom link-bending rules specified through the various Add*BendRule methods.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool UseRuleManagedLinkBend (
bool ruleManaged
)

Visual Basic [image] Copy Code

Public Function UseRuleManagedLinkBend( _
ruleManaged As Boolean _
) As Boolean

Parameters

ruleManaged

true to use custom link-bending rules; otherwise, false.

Return Value

true if this rule has been set successfully; otherwise, false.

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules Properties

FlowLayoutRules Properties
[image]

Public Properties

Name | Description
ConnectorRules | A set of rules that are applied according to the logic identifiers of links.
NodeRules | A set of rules that are applied according to the logic identifiers of node pairs.
PreferredRules | Specifies which set of rules to use.

See Also

FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.ConnectorRules Property

FlowLayoutRules.ConnectorRules Property
[image]

A set of rules that are applied according to the logic identifiers of links.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ConnectorRules ConnectorRules { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectorRules As ConnectorRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.NodeRules Property

FlowLayoutRules.NodeRules Property
[image]

A set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public NodeRules NodeRules { get; set; }

Visual Basic [image] Copy Code

Public Property NodeRules As NodeRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutRules.PreferredRules Property

FlowLayoutRules.PreferredRules Property
[image]

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public PreferredRules PreferredRules { get; set; }

Visual Basic [image] Copy Code

Public Property PreferredRules As PreferredRules

Property Value

See Also

FlowLayoutRules Members
FlowLayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.FlowLayoutTraits Enumeration

FlowLayoutTraits Enumeration
[image]

Values used as keys in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum FlowLayoutTraits

Visual Basic [image] Copy Code

Public Enum FlowLayoutTraits

Members

Member name | Description
AlignmentPoint | Specifies vertical and horizontal alignement.
BendVerticalLink | Specifies if vertical links will be bend, or intersected object will be moved right.
CustomPosition | Specifies a custom position for a FlowLayout group of nodes.
DestinationAlignmentPoint | Specifies alignement point at the destination node.
GroupAlignmentPoint | Specifies the alignment point of a group.
GroupLayoutSize | Overrides the layout size of a group.
GroupMargins | Specifies the margin size of a group.
HorizontalPriority | Specifies horizontal node priority for cases where the layout cannot determine the node order based on other criteria.
InLink | Identifies possible incoming links in FlowLayout rules.
Lane | Specifies the lane to which a node should be assigned.
LaneNode | Specifies that FlowLayout should treat a node as a lane.
LayoutSize | A space allocated for a node.
LogicID | Specifies a string used to identify items in FlowLayout rules.
MainProcessPriority | Specifies connected group priority in cases to avoid the change Lane effect
NodeDirection | For internal use.
NodeDistance | Specifies the distance left between this node and the next in the sequence.
NodeMargins | Additianal node placement in the allocated node's space (from LayoutSize).
NotSpecified | For internal use.
OrderingRule | Specified the preferred order for nodes.
OriginAlignmentPoint | Specifies alignement point at the origin node.
OutLink | Identifies possible outgoing links in FlowLayout rules.
PossibleConnection | For internal use.
Priority | Specifies group priority for cases where the layout cannot determine the group order based on other criteria.
StandardLinkBend | For internal use.
SublaneID | Specifies the additiona Lane position.
SubLevelNegativeDefaultDistance | Default distance of nodes at the negative sub-level to the control-flow nodes.
SubLevelNegativeMinDistance | Minimum distance of nodes at the negative sub-level to the control-flow nodes.
SubLevelPositiveDefaultDistance | Default distance of nodes at the positive sub-level to the control-flow nodes.
SubLevelPositiveMinDistance | Minimum distance of nodes at the positive sub-level to the control-flow nodes.
VerticalDisconnectedGroupsAlignment | A boolean value specifying the alignment of nodes within a group.
VerticalLink | Specifies if the nodes linkt by this king of link will be arranged verticaly.
VerticalSubgroupsAlignment | A boolean value specifying the alignment of nodes within a group.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.HierarchicalLayoutTraits Enumeration

HierarchicalLayoutTraits Enumeration
[image]

Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum HierarchicalLayoutTraits

Visual Basic [image] Copy Code

Public Enum HierarchicalLayoutTraits

Members

Member name | Description
Level | The number associated with this key specifies the index of the level of the item in the level-planar graph.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayeredLayoutTraits Enumeration

LayeredLayoutTraits Enumeration
[image]

Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum LayeredLayoutTraits

Visual Basic [image] Copy Code

Public Enum LayeredLayoutTraits

Members

Member name | Description
Layer | The number associated with this key specifies the index of the layer the layout should attempt to place the node to. Specifying a negative number indicates a layer starting from the last. For example, -1 would indicate the last layer, -2 - the layer before the last, and so on.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Class

LayoutRules Class
[image]

Summary description for LayoutRules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class LayoutRules

Visual Basic [image] Copy Code

Public Class LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.ConnectorRules
MindFusion.Layout.FlowLayoutRules
MindFusion.Layout.NodeRules
MindFusion.Layout.SimpleRules

See Also

LayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Members

LayoutRules Members
Constructors Methods
[image]

Summary description for LayoutRules.

The following tables list the members exposed by the LayoutRules type.

Public Constructors

Name | Description
LayoutRules | Initializes a new instance of the LayoutRules class.

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Constructor

LayoutRules Constructor
[image]

Initializes a new instance of the LayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public LayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Methods

LayoutRules Methods
[image]

Public Methods

Name | Description
AddLayoutRule | Overloaded.
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails;
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails;
ValidateRules | Checks if there is a rule for each key in KeyList

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method

LayoutRules.AddLayoutRule Method
[image]

Overload List

Name | Description
LayoutRules.AddLayoutRule (Object, Object) | Adds or sets a new rule, depending on if the rule with key - Key already exists or no;
LayoutRules.AddLayoutRule (Object, Object, Object) | Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object)
See Also
[image]

Adds or sets a new rule, depending on if the rule with key - Key already exists or no;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Key,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Key As Object, _
Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object, Object)
See Also
[image]

Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key anf value - Value;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Object1,
Object Object2,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Object1 As Object, _
Object2 As Object, _
Value As Object _
) As Boolean

Parameters

Object1

Object2

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.BuildKey Method

LayoutRules.BuildKey Method
[image]

Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object BuildKey (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public Function BuildKey( _
obj1 As Object, _
obj2 As Object _
) As Object

Parameters

obj1

obj2

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.GetLayoutRule Method

LayoutRules.GetLayoutRule Method
[image]

If there is rule with key - Key initializes - Value otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool GetLayoutRule (
Object Key,
out Object Value
)

Visual Basic [image] Copy Code

Public Overridable Function GetLayoutRule( _
Key As Object, _
<System.Runtime.InteropServices.Out()> ByRef Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.RemovetLayoutRule Method

LayoutRules.RemovetLayoutRule Method
[image]

If there is rule with key - Key removes the key - value, otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public virtual bool RemovetLayoutRule (
Object Key
)

Visual Basic [image] Copy Code

Public Overridable Function RemovetLayoutRule( _
Key As Object _
) As Boolean

Parameters

Key

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.ValidateRules Method

LayoutRules.ValidateRules Method
[image]

Checks if there is a rule for each key in KeyList

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ValidateRules (
ArrayList KeyList
)

Visual Basic [image] Copy Code

Public Function ValidateRules( _
KeyList As ArrayList _
) As Boolean

Parameters

KeyList

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Class

NodeRules Class
[image]

Represents a set of rules that are applied according to the logic identifiers of node pairs.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class NodeRules : LayoutRules

Visual Basic [image] Copy Code

Public Class NodeRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.NodeRules

See Also

NodeRules Members
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Members

NodeRules Members
Properties Methods
[image]

Represents a set of rules that are applied according to the logic identifiers of node pairs.

The following tables list the members exposed by the NodeRules type.

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2 (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules Properties

NodeRules Properties
[image]

Public Properties

Name | Description
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.
MainConnectorId | Specifies which type of connectors define the control flow in the process represented by the arranged diagram.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
VerticalSubgroupsAlignment | Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

See Also

NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelNegative Property

NodeRules.FirstGroupLevelNegative Property
[image]

A rule defining which nodes should be placed above the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object FirstGroupLevelNegative { get; set; }

Visual Basic [image] Copy Code

Public Property FirstGroupLevelNegative As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.FirstGroupLevelPositive Property

NodeRules.FirstGroupLevelPositive Property
[image]

A rule defining which nodes should be placed below the "Control Flow" line. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object FirstGroupLevelPositive { get; set; }

Visual Basic [image] Copy Code

Public Property FirstGroupLevelPositive As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupEndNodes Property

NodeRules.GroupEndNodes Property
[image]

Specifies which nodes should be considered the end of the current sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object GroupEndNodes { get; set; }

Visual Basic [image] Copy Code

Public Property GroupEndNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.GroupStartNodes Property

NodeRules.GroupStartNodes Property
[image]

Specifies which nodes should be considered the start of a new sub-group. Assign an array of the node types logic identifiers to this property.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object GroupStartNodes { get; set; }

Visual Basic [image] Copy Code

Public Property GroupStartNodes As Object

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorId Property

NodeRules.MainConnectorId Property
[image]

Specifies which type of connectors define the control flow in the process represented by the arranged diagram.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string MainConnectorId { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorId As String

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.MainConnectorOrientation Property

NodeRules.MainConnectorOrientation Property
[image]

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleOrientation MainConnectorOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.NodeRules.VerticalSubgroupsAlignment Property

NodeRules.VerticalSubgroupsAlignment Property
[image]

Specifies whether connected subgroups from the same lane should be aligned and arranged vertically.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool VerticalSubgroupsAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalSubgroupsAlignment As Boolean

Property Value

See Also

NodeRules Members
NodeRules Class
MindFusion.Layout Namespace


MindFusion.Layout.OrderDirection Enumeration

OrderDirection Enumeration
[image]

Values controlling the direction of link segments in FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum OrderDirection

Visual Basic [image] Copy Code

Public Enum OrderDirection

Members

Member name | Description
Downward | Specifies downward link direction.
Leftward | Specifies leftward link direction.
NotSpecified | Unspecified link direction.
Rightward | Specifies rightward link direction.
Upward | Specifies upward link direction.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.Pair Class

Pair Class
[image]

Represents a coupling between two arbitrary objects.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class Pair : IComparable

Visual Basic [image] Copy Code

Public Class Pair
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Layout.Pair

See Also

Pair Members
MindFusion.Layout Namespace


MindFusion.Layout.Pair Members

Pair Members
Constructors Properties Methods
[image]

Represents a coupling between two arbitrary objects.

The following tables list the members exposed by the Pair type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor

Pair Constructor
[image]

Overload List

Name | Description
Pair () | Initializes a new instance of the Pair class.
Pair (Object, Object) | Initializes a new instance of the Pair class.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor ()

Pair Constructor ()
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pair ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor (Object, Object)

Pair Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Pair (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public New ( _
obj1 As Object, _
obj2 As Object _
)

Parameters

obj1

obj2

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Methods

Pair Methods
[image]

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.CompareTo Method

Pair.CompareTo Method
[image]

Implements IComparable.CompareTo.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.Equals Method

Pair.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.GetHashCode Method

Pair.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Properties

Pair Properties
[image]

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.FirstObject Property

Pair.FirstObject Property
[image]

Gets or sets the first pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object FirstObject { get; set; }

Visual Basic [image] Copy Code

Public Property FirstObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.PairElements Property

Pair.PairElements Property
[image]

Gets the elements of the pair as an arraylist

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArrayList PairElements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PairElements As ArrayList

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.SecondObject Property

Pair.SecondObject Property
[image]

Gets or sets the second pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Object SecondObject { get; set; }

Visual Basic [image] Copy Code

Public Property SecondObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.PartitionMethod Enumeration

PartitionMethod Enumeration
[image]

Identifies graph partitioning methods supported by CompositeLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum PartitionMethod

Visual Basic [image] Copy Code

Public Enum PartitionMethod

Members

Member name | Description
BiconnectedComponents | Partition graphs by their biconnected components.
Custom | Custom partitioning.
ShortestPath | Partition graphs by node paths distance.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.PreferredRules Enumeration

PreferredRules Enumeration
[image]

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum PreferredRules

Visual Basic [image] Copy Code

Public Enum PreferredRules

Members

Member name | Description
ConnectorRules | Use connector rules.
NodeRules | Use node rules.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RouteHeuristics Delegate

RouteHeuristics Delegate
[image]

The link routing algorithm uses a heuristic function of this type in its prediction steps.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public delegate int RouteHeuristics (
PointI start,
PointI end
)

Visual Basic [image] Copy Code

Public Delegate Function RouteHeuristics( _
start As PointI, _
end As PointI _
) As Integer

Parameters

start

A Point specifying the first of the points, between which the distance is calculated.

end

A Point specifying the first of the points, between which the distance is calculated.

Return Value

An integer value indicating the calculated distance between the specified points.

Remarks

Functions of this type can be assigned to the RouteHeuristics property of the RoutingOptions class.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Interface

RoutingOptions Interface
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public interface RoutingOptions

Visual Basic [image] Copy Code

Public Interface RoutingOptions

Inheritors

MindFusion.Diagramming.Wpf.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Members

RoutingOptions Members
Properties
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

double GridSize { get; set; }

Visual Basic [image] Copy Code

Property GridSize As Double

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

byte LengthCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property LengthCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

byte NodeVicinityCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property NodeVicinityCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

byte TurnCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property TurnCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Class

SimpleKeys Class
[image]

Defines keys that can be used to define FlowLayout rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SimpleKeys

Visual Basic [image] Copy Code

Public Class SimpleKeys

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleKeys
MindFusion.Layout.FlowLayoutKeys

See Also

SimpleKeys Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Members

SimpleKeys Members
Constructors Fields Properties Methods
[image]

Defines keys that can be used to define FlowLayout rules.

The following tables list the members exposed by the SimpleKeys type.

Public Constructors

Name | Description
SimpleKeys | Initializes a new instance of the SimpleKeys class.

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Fields

SimpleKeys Fields
[image]

Public Fields

Name | Description
ConnectorTypes | Specifies a list of connector identifiers.
FirstGroupLevelNegative | A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
FirstGroupLevelPositive | A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.
GroupEndNodes | Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.
GroupStartNodes | Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.
MainConnectorOrientation | Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.
MainSubgroupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
PossibleConnection | Specifies what kind of node connections are allowed.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ConnectorTypes Field

SimpleKeys.ConnectorTypes Field
[image]

Specifies a list of connector identifiers.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string ConnectorTypes

Visual Basic [image] Copy Code

Public Shared ConnectorTypes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelNegative Field

SimpleKeys.FirstGroupLevelNegative Field
[image]

A rule defining which nodes should be placed above the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FirstGroupLevelNegative

Visual Basic [image] Copy Code

Public Shared FirstGroupLevelNegative As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.FirstGroupLevelPositive Field

SimpleKeys.FirstGroupLevelPositive Field
[image]

A rule defining which nodes should be placed below the "Control Flow" line. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string FirstGroupLevelPositive

Visual Basic [image] Copy Code

Public Shared FirstGroupLevelPositive As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupEndNodes Field

SimpleKeys.GroupEndNodes Field
[image]

Specifies which nodes should be considered the end of the current sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string GroupEndNodes

Visual Basic [image] Copy Code

Public Shared GroupEndNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.GroupStartNodes Field

SimpleKeys.GroupStartNodes Field
[image]

Specifies which nodes should be considered the start of a new sub-group. Associate an array of the node types logic identifiers with this key.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string GroupStartNodes

Visual Basic [image] Copy Code

Public Shared GroupStartNodes As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainConnectorOrientation Field

SimpleKeys.MainConnectorOrientation Field
[image]

Specifies the orientation of the "Control Flow" sequence of links, and thus the main orientation for the layout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string MainConnectorOrientation

Visual Basic [image] Copy Code

Public Shared MainConnectorOrientation As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.MainSubgroupConnector Field

SimpleKeys.MainSubgroupConnector Field
[image]

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string MainSubgroupConnector

Visual Basic [image] Copy Code

Public Shared MainSubgroupConnector As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.PossibleConnection Field

SimpleKeys.PossibleConnection Field
[image]

Specifies what kind of node connections are allowed.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string PossibleConnection

Visual Basic [image] Copy Code

Public Shared PossibleConnection As String

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Constructor

SimpleKeys Constructor
[image]

Initializes a new instance of the SimpleKeys class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleKeys ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Methods

SimpleKeys Methods
[image]

Public Methods

Name | Description
ValidateRules | Checks if there is a rule for each key in the key list.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.ValidateRules Method

SimpleKeys.ValidateRules Method
[image]

Checks if there is a rule for each key in the key list.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public bool ValidateRules (
LayoutRules lr
)

Visual Basic [image] Copy Code

Public Function ValidateRules( _
lr As LayoutRules _
) As Boolean

Parameters

lr

Return Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys Properties

SimpleKeys Properties
[image]

Public Properties

Name | Description
AllKeys | A list of all keys defined in this class.

See Also

SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleKeys.AllKeys Property

SimpleKeys.AllKeys Property
[image]

A list of all keys defined in this class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArrayList AllKeys { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AllKeys As ArrayList

Property Value

See Also

SimpleKeys Members
SimpleKeys Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Class

SimpleLinkLogic Class
[image]

Contains link identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SimpleLinkLogic

Visual Basic [image] Copy Code

Public Class SimpleLinkLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleLinkLogic

See Also

SimpleLinkLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Members

SimpleLinkLogic Members
Constructors Fields
[image]

Contains link identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleLinkLogic type.

Public Constructors

Name | Description
SimpleLinkLogic | Initializes a new instance of the SimpleLinkLogic class.

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Fields

SimpleLinkLogic Fields
[image]

Public Fields

Name | Description
Master | Identifier for the main connector type.
NotSpecified | Unspecified connector type.
Slave | Identifier for the secondary connector type.

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Master Field

SimpleLinkLogic.Master Field
[image]

Identifier for the main connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string Master

Visual Basic [image] Copy Code

Public Shared Master As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.NotSpecified Field

SimpleLinkLogic.NotSpecified Field
[image]

Unspecified connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string NotSpecified

Visual Basic [image] Copy Code

Public Shared NotSpecified As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic.Slave Field

SimpleLinkLogic.Slave Field
[image]

Identifier for the secondary connector type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string Slave

Visual Basic [image] Copy Code

Public Shared Slave As String

See Also

SimpleLinkLogic Members
SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleLinkLogic Constructor

SimpleLinkLogic Constructor
[image]

Initializes a new instance of the SimpleLinkLogic class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleLinkLogic ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleLinkLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Class

SimpleNodeLogic Class
[image]

Contains node identifiers for the predefined SimpleRules set of rules.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SimpleNodeLogic

Visual Basic [image] Copy Code

Public Class SimpleNodeLogic

Inheritance Hierarchy

System.Object
MindFusion.Layout.SimpleNodeLogic

See Also

SimpleNodeLogic Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Members

SimpleNodeLogic Members
Constructors Fields
[image]

Contains node identifiers for the predefined SimpleRules set of rules.

The following tables list the members exposed by the SimpleNodeLogic type.

Public Constructors

Name | Description
SimpleNodeLogic |

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Fields

SimpleNodeLogic Fields
[image]

Public Fields

Name | Description
Action | Identifier for action nodes.
End | Identifier for group end nodes.
NotSpecified | Unspecified node type.
Start | Identifier for group start nodes.

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Action Field

SimpleNodeLogic.Action Field
[image]

Identifier for action nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string Action

Visual Basic [image] Copy Code

Public Shared Action As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.End Field

SimpleNodeLogic.End Field
[image]

Identifier for group end nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string End

Visual Basic [image] Copy Code

Public Shared End As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.NotSpecified Field

SimpleNodeLogic.NotSpecified Field
[image]

Unspecified node type.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string NotSpecified

Visual Basic [image] Copy Code

Public Shared NotSpecified As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic.Start Field

SimpleNodeLogic.Start Field
[image]

Identifier for group start nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static string Start

Visual Basic [image] Copy Code

Public Shared Start As String

See Also

SimpleNodeLogic Members
SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleNodeLogic Constructor

SimpleNodeLogic Constructor
[image]

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleNodeLogic ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleNodeLogic Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleOrientation Enumeration

SimpleOrientation Enumeration
[image]

Specifies the preferred orientation for the main connector type in FlowLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SimpleOrientation

Visual Basic [image] Copy Code

Public Enum SimpleOrientation

Members

Member name | Description
BottomToTop | Specifies bottom-to-top orientation.
LeftToRight | Specifies left-to-right orientation.
None | Unspecified orientation.
RightToLeft | Specifies right-to-left orientation.
TopToBottom | Specifies top-to-bottom orientation.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Class

SimpleRules Class
[image]

Class of simple rules requisited for Flowlayout algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public class SimpleRules : LayoutRules

Visual Basic [image] Copy Code

Public Class SimpleRules
Inherits LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules
MindFusion.Layout.SimpleRules

See Also

SimpleRules Members
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Members

SimpleRules Members
Constructors Properties Methods
[image]

Class of simple rules requisited for Flowlayout algorithm.

The following tables list the members exposed by the SimpleRules type.

Public Constructors

Name | Description
SimpleRules | Overloaded.

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node.
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

Public Methods

Name | Description
AddLayoutRule | Overloaded. (Inherited from LayoutRules.)
BuildKey | Builds a key - object for the new rule, as a pair of two objects: obj1 and obj2 (Inherited from LayoutRules.)
GetLayoutRule | If there is rule with key - Key initializes - Value otherwise fails; (Inherited from LayoutRules.)
RemovetLayoutRule | If there is rule with key - Key removes the key - value, otherwise fails; (Inherited from LayoutRules.)
ValidateRules | Checks if there is a rule for each key in KeyList (Inherited from LayoutRules.)

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor

SimpleRules Constructor
[image]

Overload List

Name | Description
SimpleRules () | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String) | Initializes a new instance of the SimpleRules class.
SimpleRules (ArrayList, ArrayList, String, SimpleOrientation) | Initializes a new instance of the SimpleRules class.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor ()

SimpleRules Constructor ()
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String)

SimpleRules Constructor (ArrayList, ArrayList, String)
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector
)

Visual Basic [image] Copy Code

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String _
)

Parameters

strtSubGroupNodeType_ls

endSubGroupNodeType_ls

mainConnector

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)

SimpleRules Constructor (ArrayList, ArrayList, String, SimpleOrientation)
See Also
[image]

Initializes a new instance of the SimpleRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleRules (
ArrayList strtSubGroupNodeType_ls,
ArrayList endSubGroupNodeType_ls,
string mainConnector,
SimpleOrientation mainConnectorOrdrDrctn
)

Visual Basic [image] Copy Code

Public New ( _
strtSubGroupNodeType_ls As ArrayList, _
endSubGroupNodeType_ls As ArrayList, _
mainConnector As String, _
mainConnectorOrdrDrctn As SimpleOrientation _
)

Parameters

strtSubGroupNodeType_ls

endSubGroupNodeType_ls

mainConnector

mainConnectorOrdrDrctn

See Also

SimpleRules Constructor Overload List
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules Properties

SimpleRules Properties
[image]

Public Properties

Name | Description
EndSubgproupNode | Defines which type of nodes will be used as a "sub group end" node.
MainConnectorOrientation | A key defining the space orientation of a "Control Flow" and respectively for the layout;
MainSubgproupConnector | Defines which type of connectors can be used as guideline (defining the graph control flow).
StartSubgproupNode | Defines which type of nodes will be used as a "sub group" start node.

See Also

SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.EndSubgproupNode Property

SimpleRules.EndSubgproupNode Property
[image]

Defines which type of nodes will be used as a "sub group end" node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArrayList EndSubgproupNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainConnectorOrientation Property

SimpleRules.MainConnectorOrientation Property
[image]

A key defining the space orientation of a "Control Flow" and respectively for the layout;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public SimpleOrientation MainConnectorOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property MainConnectorOrientation As SimpleOrientation

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.MainSubgproupConnector Property

SimpleRules.MainSubgproupConnector Property
[image]

Defines which type of connectors can be used as guideline (defining the graph control flow).

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public string MainSubgproupConnector { get; set; }

Visual Basic [image] Copy Code

Public Property MainSubgproupConnector As String

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SimpleRules.StartSubgproupNode Property

SimpleRules.StartSubgproupNode Property
[image]

Defines which type of nodes will be used as a "sub group" start node.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public ArrayList StartSubgproupNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartSubgproupNode As ArrayList

Property Value

See Also

SimpleRules Members
SimpleRules Class
MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutMethod Enumeration

SpringLayoutMethod Enumeration
[image]

Specifies what energy model SpringLayout should use for the simulation.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SpringLayoutMethod

Visual Basic [image] Copy Code

Public Enum SpringLayoutMethod

Members

Member name | Description
Classic | Use Hooke's law of elasticity to treat links as springs, and Coulomb's inverse square law to implement repulsion between nodes.
FruchtermanReingold | Use artificial attraction forces for links and repulsion forces for nodes that cancel each other at about the distance specified in NodeDistance, along with a simulated cooling schedule used for fine-tuning. Based on the method of Thomas Fruchterman and Edward Reingold.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutTraits Enumeration

SpringLayoutTraits Enumeration
[image]

Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SpringLayoutTraits

Visual Basic [image] Copy Code

Public Enum SpringLayoutTraits

Members

Member name | Description
Frozen | If the LayoutTraits value associated with a node through this key is true, SpringLayout considers the repulsion forces exerted by the node to other nodes, but ignores forces acting on the node and keeps it in place.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SwimlaneLayoutTraits Enumeration

SwimlaneLayoutTraits Enumeration
[image]

Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum SwimlaneLayoutTraits

Visual Basic [image] Copy Code

Public Enum SwimlaneLayoutTraits

Members

Member name | Description
Lane | Specifies the lane to which a node should be assigned.
SortOrder | Specifies custom sort order of nodes in the same lane.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeLayoutTraits Enumeration

TreeLayoutTraits Enumeration
[image]

Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeLayoutTraits

Members

Member name | Description
Assistant | If the LayoutTraits value associated with a node through this key is true, centered TreeLayout treats this node as an "assistant" during the arrangement. If the value is false or is not present, the node is treated as "subordinate". The associated value can also be of type AssistantType if it is required to specify the position of the assistant node relative to its parent. This value is considered when the EnableAssistants property of TreeLayout is set to true.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeMapLayoutTraits Enumeration

TreeMapLayoutTraits Enumeration
[image]

Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum TreeMapLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeMapLayoutTraits

Members

Member name | Description
HeaderSize | The header size of a master node in a tree-map layout.

See Also

MindFusion.Layout Namespace


MindFusion.Mapping Namespace

MindFusion.Mapping Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Column | Represents a database column.
Database | Represents the DBF database associated with an ESRI map file.
Decoration | Represents a decoration element drawn in a separate layer over the map.
DecorationLayerBase(TColor, TPalette) | Represents a layer containing decorative elements.
Layer(TColor, TPalette) | Represents a map layer.
Map | Represents a geographic map.
MapElement | Represents visual elements of a map that can be drawn and hit-tested.
MapLayerBase(TColor, TPalette) | Represents a map layer containing geometric shapes.
NullShape | Represents a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Represents a point on the map with X (longitude) and Y (latitude) coordinates.
Rect | A class representing a rectangular are on the map.
Row | Represents a DBF database row.
Shape | Represents geometrical shapes displayed on a map.

Interfaces

Interface | Description
ICanvas | Represents a drawing canvas.
ICanvasWithPalette(TColor) | Represents a drawing canvas with an associated palette of colors.
IPalette(TColor) | Represents a palette of colors.
ITransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.

Enumerations

Enumeration | Description
ColumnType | Specifies a DBF column type.
ShapeType | Specifies the type of shapes contained in an ESRI map file.
TextAlignment | Specifies text alignment.


MindFusion.Mapping.Column Class

Column Class
Remarks See Also
[image]

Represents a database column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Column

Visual Basic [image] Copy Code

Public Class Column

Remarks

Objects of this class represent the columns in a DBF database associated with a map file. The Name property indicates the column name, and the Type property indicates the DBF data type.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Column

See Also

Column Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Column Members

Column Members
Properties Methods
[image]

Represents a database column.

The following tables list the members exposed by the Column type.

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Column Methods

Column Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Column.ToString Method

Column.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Returns the column name.

See Also

Column Members
Column Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Column Properties

Column Properties
[image]

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

See Also

Column Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Column.Decimals Property

Column.Decimals Property
[image]

Gets the number of decimals stored for numeric values in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public byte Decimals { get; set; }

Visual Basic [image] Copy Code

Public Property Decimals As Byte

Property Value

A byte value specifying the number of decimal places in numeric fields.

See Also

Column Members
Column Class
MindFusion.Mapping Namespace
Type Property


MindFusion.Mapping.Column.Length Property

Column.Length Property
[image]

Gets the length of fields in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that specifies the length in bytes of data fields in this column.

See Also

Column Members
Column Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Column.Name Property

Column.Name Property
[image]

Gets the column name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value specifying the column name.

See Also

Column Members
Column Class
MindFusion.Mapping Namespace
Type Property


MindFusion.Mapping.Column.Type Property

Column.Type Property
[image]

Gets the DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ColumnType Type { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Type As ColumnType

Property Value

A member of the ColumnType enumeration.

See Also

Column Members
Column Class
MindFusion.Mapping Namespace
Name Property


MindFusion.Mapping.ColumnType Enumeration

ColumnType Enumeration
[image]

Specifies a DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ColumnType

Visual Basic [image] Copy Code

Public Enum ColumnType

Members

Member name | Description
Binary | Indicates that the column stores binary data.
Boolean | Indicates that the column stores Boolean data.
Character | Indicates that the column stores character data.
Date | Indicates that the column stores date values.
FloatingPoint | Indicates that the column stores floating point values.
Integer | Indicates that the column stores integer values.
Memo | Indicates that the column stores memo data.
Number | Indicates that the column stores numeric data.

See Also

MindFusion.Mapping Namespace


MindFusion.Mapping.Database Class

Database Class
Remarks See Also
[image]

Represents the DBF database associated with an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Database : IListSource

Visual Basic [image] Copy Code

Public Class Database
Implements IListSource

Remarks

The DBF database associated with a map is loaded optionally, as specified via parameters of the LoadFromStream method of the Map class. If the database is loaded, it is represented by instance of this class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Database

See Also

Database Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Members

Database Members
Constructors Properties Methods
[image]

Represents the DBF database associated with an ESRI map file.

The following tables list the members exposed by the Database type.

Public Constructors

Name | Description
Database | Overloaded. Initializes a new instance of the Database class.

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded. Gets the column with a specified name or index.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded. Loads database data from a stream or a file.
SaveTo | Overloaded. Saves this database to a stream or a file.

See Also

Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Constructor

Database Constructor
[image]

Initializes a new instance of the Database class.

Overload List

Name | Description
Database (Database) | Creates a new instance of the Database class.
Database (String) | Creates a new instance of the Database class.
Database (BinaryReader) | Creates a new instance of the Database class.

See Also

Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Constructor (Database)

Database Constructor (Database)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
Database schema
)

Visual Basic [image] Copy Code

Public New ( _
schema As Database _
)

Parameters

schema

A prototype database whose schema should be copied to this database.

See Also

Database Constructor Overload List
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Constructor (String)

Database Constructor (String)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
string fileName
)

Visual Basic [image] Copy Code

Public New ( _
fileName As String _
)

Parameters

fileName

Specifies the file name of the DBF database file.

See Also

Database Constructor Overload List
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Constructor (BinaryReader)

Database Constructor (BinaryReader)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

Specifies a stream from which to load the database data.

See Also

Database Constructor Overload List
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Methods

Database Methods
[image]

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded. Loads database data from a stream or a file.
SaveTo | Overloaded. Saves this database to a stream or a file.

See Also

Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.GetList Method

Database.GetList Method
[image]

Implements IListSource.GetList.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public IList GetList ()

Visual Basic [image] Copy Code

Public Function GetList () As IList

Return Value

An IList containing the database rows.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.LoadFrom Method

Database.LoadFrom Method
[image]

Loads database data from a stream or a file.

Overload List

Name | Description
Database.LoadFrom (BinaryReader) | Loads database data from the specified stream.
Database.LoadFrom (String) | Loads database data from the specified file.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.LoadFrom Method (BinaryReader)

Database.LoadFrom Method (BinaryReader)
See Also
[image]

Loads database data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read database data.

See Also

LoadFrom Method Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.LoadFrom Method (String)

Database.LoadFrom Method (String)
See Also
[image]

Loads database data from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

LoadFrom Method Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.SaveTo Method

Database.SaveTo Method
[image]

Saves this database to a stream or a file.

Overload List

Name | Description
Database.SaveTo (String) | Saves this database to the specified file.
Database.SaveTo (BinaryWriter) | Saves this database to the specified stream.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.SaveTo Method (String)

Database.SaveTo Method (String)
See Also
[image]

Saves this database to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

SaveTo Method Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.SaveTo Method (BinaryWriter)

Database.SaveTo Method (BinaryWriter)
See Also
[image]

Saves this database to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the database data.

See Also

SaveTo Method Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database Properties

Database Properties
[image]

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded. Gets the column with a specified name or index.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

See Also

Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.ColumnCount Property

Database.ColumnCount Property
[image]

Returns the number of column in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int ColumnCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnCount As Integer

Property Value

An integer value specifying the number of columns in the DBF file.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.Columns Property

Database.Columns Property
[image]

Gets a list of columns in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Column> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As List(Of Column)

Property Value

A List of Column objects.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace
Rows Property


MindFusion.Mapping.Database.ContainsListCollection Property

Database.ContainsListCollection Property
[image]

Implements IListSource.ContainsListCollection.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsListCollection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContainsListCollection As Boolean

Property Value

This property always returns false.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.Item Property

Database.Item Property
[image]

Gets the column with a specified name or index.

Overload List

Name | Description
Database.Item (String) | Gets the column with the specified name.
Database.Item (Int32) | Gets the column with the specified index.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.Item Property (String)

Database.Item Property (String)
See Also
[image]

Gets the column with the specified name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
string name
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
name As String _
) As Column

Parameters

name

A string value specifying the column name.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.Item Property (Int32)

Database.Item Property (Int32)
See Also
[image]

Gets the column with the specified index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
int nIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
nIndex As Integer _
) As Column

Parameters

nIndex

An integer value specifying the column index.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.RowLength Property

Database.RowLength Property
[image]

Returns the length in bytes of a database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int RowLength { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowLength As Integer

Property Value

An integer value specifying the length in bytes of a DBF data record.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Database.Rows Property

Database.Rows Property
[image]

Gets a list of rows in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Row> Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As List(Of Row)

Property Value

A List of Row objects.

See Also

Database Members
Database Class
MindFusion.Mapping Namespace
Columns Property


MindFusion.Mapping.Decoration Class

Decoration Class
[image]

Represents a decoration element drawn in a separate layer over the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Decoration : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Decoration
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationBubble
MindFusion.Mapping.Wpf.DecorationImage

See Also

Decoration Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration Members

Decoration Members
Constructors Properties Methods
[image]

Represents a decoration element drawn in a separate layer over the map.

The following tables list the members exposed by the Decoration type.

Public Constructors

Name | Description
Decoration | Initializes a new instance of the Decoration class.

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration.

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration Constructor

Decoration Constructor
[image]

Initializes a new instance of the Decoration class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Decoration (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

Specifies the latitude associated with this element.

longitude

Specifies the longitude associated with this element.

See Also

Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration Properties

Decoration Properties
[image]

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

See Also

Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration.Latitude Property

Decoration.Latitude Property
[image]

Gets or sets the latitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Latitude { get; set; }

Visual Basic [image] Copy Code

Public Property Latitude As Double

Property Value

A double value specifying the latitude of the decoration's location.

Remarks

You can call the Latitude method of the Map class to get the double value for latitude specified in [degrees,minutes,seconds,N/S] format.

See Also

Decoration Members
Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration.Longitude Property

Decoration.Longitude Property
[image]

Gets or sets the longitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Longitude { get; set; }

Visual Basic [image] Copy Code

Public Property Longitude As Double

Property Value

A double value specifying the longitude of the decoration's location.

Remarks

You can call the Longitude method of the Map class to get the double value for longitudes specified in [degrees,minutes,seconds,W/E] format.

See Also

Decoration Members
Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration Methods

Decoration Methods
[image]

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration.

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Decoration.GetLocation Method

Decoration.GetLocation Method
[image]

Gets a point representing the geographical location of the decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetLocation ()

Visual Basic [image] Copy Code

Public Function GetLocation () As Point

Return Value

A Point object.

See Also

Decoration Members
Decoration Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Class

DecorationLayerBase(TColor, TPalette) Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class DecorationLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class DecorationLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.Wpf.DecorationLayer

See Also

DecorationLayerBase(TColor, TPalette) Members
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Members

DecorationLayerBase(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
DecorationLayerBase | Initializes a new instance of the DecorationLayerBase class.

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Decorations | Gets the list of decorations displayed in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected decorations.
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Layer.Draw override.
DrawHighlights | Layer.DrawHighlights override.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Overloaded. Selects one or more map elements.
Toggle | Layer.Toggle override.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Constructor

DecorationLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the DecorationLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public DecorationLayerBase<TColor, TPalette> (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New (Of TColor, TPalette) ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Methods

DecorationLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Layer.Draw override.
DrawHighlights | Layer.DrawHighlights override.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Overloaded. Selects one or more map elements.
Toggle | Layer.Toggle override.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Draw Method

DecorationLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawHighlights Method

DecorationLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Layer.DrawHighlights override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawLabels Method

DecorationLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Highlight Method

DecorationLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).HitTest Method

DecorationLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Toggle Method

DecorationLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method

DecorationLayerBase(TColor, TPalette).Select Method
[image]

Selects one or more map elements.

Overload List

Name | Description
DecorationLayerBase(TColor, TPalette).Select (MapElement) | Layer.Select override.
DecorationLayerBase(TColor, TPalette).Select (Rect) | Layer.Select override.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method (MapElement)

DecorationLayerBase(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method (Rect)

DecorationLayerBase(TColor, TPalette).Select Method (Rect)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect object specifying the area containing the elements to select.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Properties

DecorationLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Decorations | Gets the list of decorations displayed in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected decorations.
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).BoundingBox Property

DecorationLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding rectangle.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Decorations Property

DecorationLayerBase(TColor, TPalette).Decorations Property
[image]

Gets the list of decorations displayed in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ObservableCollection<Decoration> Decorations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Decorations As ObservableCollection(Of Decoration)

Property Value

A list of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Selection Property

DecorationLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected decorations.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Decoration> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Decoration)

Property Value

A List of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Events

DecorationLayerBase(TColor, TPalette) Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event

Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event
[image]

Raised when an asynchronous database-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncDatabaseLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncDatabaseLoadComplete As EventHandler

Event Data

AsyncDatabaseLoadComplete event handlers receive an argument of type EventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).AsyncLoadComplete Event

Layer(TColor, TPalette).AsyncLoadComplete Event
[image]

Raised when an asynchronous shapefile-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncLoadComplete As EventHandler

Event Data

AsyncLoadComplete event handlers receive an argument of type EventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).PropertyChanged Event

Layer(TColor, TPalette).PropertyChanged Event
[image]

Raised when the value of a property of the Layer class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas Interface

ICanvas Interface
[image]

Represents a drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvas

Inheritors

MindFusion.Mapping.ICanvasWithPalette(TColor)
MindFusion.Mapping.Wpf.LayerPresenter

See Also

ICanvas Members
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas Members

ICanvas Members
Methods
[image]

Represents a drawing canvas.

The following tables list the members exposed by the ICanvas type.

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas Methods

ICanvas Methods
[image]

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.ClipExclude Method

ICanvas.ClipExclude Method
[image]

Excludes an area from the current clip region.

Overload List

Name | Description
ICanvas.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
ICanvas.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.ClipExclude Method (IList(Point))

ICanvas.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.ClipExclude Method (List(IList(Point)))

ICanvas.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.DrawPoint Method

ICanvas.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.DrawPolyline Method

ICanvas.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.DrawString Method

ICanvas.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.FillPolygon Method

ICanvas.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.GetPixelSize Method

ICanvas.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

double GetPixelSize ()

Visual Basic [image] Copy Code

Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.ResetClip Method

ICanvas.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ResetClip ()

Visual Basic [image] Copy Code

Sub ResetClip ()

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.SetFillColor Method

ICanvas.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Sub SetFillColor( _
color As Integer _
)

Parameters

color

The index of the color in the associated palette.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.SetHighlightColor Method

ICanvas.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetHighlightColor ()

Visual Basic [image] Copy Code

Sub SetHighlightColor ()

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.SetLineColor Method

ICanvas.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetLineColor ()

Visual Basic [image] Copy Code

Sub SetLineColor ()

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvas.SetTextAlignment Method

ICanvas.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

ICanvas Members
ICanvas Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvasWithPalette(TColor) Interface

ICanvasWithPalette(TColor) Interface
[image]

Represents a drawing canvas with an associated palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvasWithPalette<TColor> : ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvasWithPalette(Of TColor)
Implements ICanvas

Inheritors

MindFusion.Mapping.Wpf.LayerPresenter

See Also

ICanvasWithPalette(TColor) Members
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvasWithPalette(TColor) Members

ICanvasWithPalette(TColor) Members
Properties
[image]

Represents a drawing canvas with an associated palette of colors.

The following tables list the members exposed by the ICanvasWithPalette(TColor) type.

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvasWithPalette(TColor) Properties

ICanvasWithPalette(TColor) Properties
[image]

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ICanvasWithPalette(TColor).Palette Property

ICanvasWithPalette(TColor).Palette Property
[image]

Gets or sets the color palette associated with this drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

IPalette<TColor> Palette { get; set; }

Visual Basic [image] Copy Code

Property Palette As IPalette(Of TColor)

Property Value

An object implementing the IPalette interface.

See Also

ICanvasWithPalette(TColor) Members
ICanvasWithPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor) Interface

IPalette(TColor) Interface
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface IPalette<TColor>

Visual Basic [image] Copy Code

Public Interface IPalette(Of TColor)

Inheritors

MindFusion.Mapping.Wpf.XamlPalette

See Also

IPalette(TColor) Members
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor) Members

IPalette(TColor) Members
Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the IPalette(TColor) type.

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor) Properties

IPalette(TColor) Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor).FillColors Property

IPalette(TColor).FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Property FillColors As TColor()

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor).HighlightColor Property

IPalette(TColor).HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Property HighlightColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.IPalette(TColor).LineColor Property

IPalette(TColor).LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Property LineColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ITransform Interface

ITransform Interface
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ITransform

Visual Basic [image] Copy Code

Public Interface ITransform

Inheritors

MindFusion.Mapping.Wpf.XamlTransform

See Also

ITransform Members
MindFusion.Mapping Namespace


MindFusion.Mapping.ITransform Members

ITransform Members
Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the ITransform type.

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Convert a point from world to screen coordinates.

See Also

ITransform Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ITransform Methods

ITransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Convert a point from world to screen coordinates.

See Also

ITransform Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ITransform.DeviceToWorld Method

ITransform.DeviceToWorld Method
[image]

Convert a point from screen to world coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

ITransform Members
ITransform Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.ITransform.WorldToDevice Method

ITransform.WorldToDevice Method
[image]

Convert a point from world to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A Point containing the corresponding screen coordinates.

See Also

ITransform Members
ITransform Interface
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Class

Layer(TColor, TPalette) Class
[image]

Represents a map layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Layer<TColor, TPalette> : INotifyPropertyChanged where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public MustInherit Class Layer(Of TColor, TPalette As IPalette(Of TColor))
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)

See Also

Layer(TColor, TPalette) Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Members

Layer(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a map layer.

The following tables list the members exposed by the Layer(TColor, TPalette) type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them.
FillColors | Gets or sets the colors used to fill map elements on this layer.
HighlightColor | Gets or sets the color used to highlight elements on this layer.
LineColor | Gets or sets the line color used to draw elements on this layer.
Palette | Gets or sets the color palette associated with this layer.
Visible | Gets or sets whether this layer should be visible in the map view.

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level.
Draw | Overloaded. Draws the elements of this layer on a canvas.
DrawHighlights | Draws the layer's highlighted elements on the specified canvas.
DrawLabels | Draws the labels of elements of this layer on the specified canvas.
Highlight | Highlights the specified map element.
HitTest | Returns the map element located at the specified point.
Select | Overloaded. Selects one or more map elements.
Toggle | Toggles the selection state the specified map element.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event.
OnAsyncLoadComplete | Raises the AsyncLoadComplete event.
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed.
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed.
PropertyChanged | Raised when the value of a property of the Layer class is changed.

See Also

Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Constructor

Layer(TColor, TPalette) Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Layer<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Methods

Layer(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level.
Draw | Overloaded. Draws the elements of this layer on a canvas.
DrawHighlights | Draws the layer's highlighted elements on the specified canvas.
DrawLabels | Draws the labels of elements of this layer on the specified canvas.
Highlight | Highlights the specified map element.
HitTest | Returns the map element located at the specified point.
Select | Overloaded. Selects one or more map elements.
Toggle | Toggles the selection state the specified map element.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event.
OnAsyncLoadComplete | Raises the AsyncLoadComplete event.
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).ClearCache Method

Layer(TColor, TPalette).ClearCache Method
[image]

Clears any cached values associated with the layer for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public virtual void ClearCache ()

Visual Basic [image] Copy Code

Public Overridable Sub ClearCache ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method

Layer(TColor, TPalette).Draw Method
[image]

Draws the elements of this layer on a canvas.

Overload List

Name | Description
Layer(TColor, TPalette).Draw (ICanvasWithPalette(TColor), Rect) | Draws the elements of this layer on the specified canvas.
Layer(TColor, TPalette).Draw (MapElement, ICanvas) | Draws the specified map element on the specified canvas.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)

Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)
See Also
[image]

Draws the elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)

Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)
See Also
[image]

Draws the specified map element on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Draw (
MapElement element,
ICanvas canvas
)

Visual Basic [image] Copy Code

Public Sub Draw( _
element As MapElement, _
canvas As ICanvas _
)

Parameters

element

A MapElement instance that should be rendered on the canvas.

canvas

An ICanvasWithPalette specifying the drawing canvas.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).DrawHighlights Method

Layer(TColor, TPalette).DrawHighlights Method
[image]

Draws the layer's highlighted elements on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).DrawLabels Method

Layer(TColor, TPalette).DrawLabels Method
[image]

Draws the labels of elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Highlight Method

Layer(TColor, TPalette).Highlight Method
[image]

Highlights the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).HitTest Method

Layer(TColor, TPalette).HitTest Method
[image]

Returns the map element located at the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method

Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method
[image]

Raises the AsyncDatabaseLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncDatabaseLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncDatabaseLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncLoadComplete Method

Layer(TColor, TPalette).OnAsyncLoadComplete Method
[image]

Raises the AsyncLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).OnPropertyChanged Method

Layer(TColor, TPalette).OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Toggle Method

Layer(TColor, TPalette).Toggle Method
[image]

Toggles the selection state the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Select Method

Layer(TColor, TPalette).Select Method
[image]

Selects one or more map elements.

Overload List

Name | Description
Layer(TColor, TPalette).Select (MapElement) | Selects the specified map element.
Layer(TColor, TPalette).Select (Rect) | Selects all map elements intersecting the specified rectangle.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Select Method (MapElement)

Layer(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Selects the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Select Method (Rect)

Layer(TColor, TPalette).Select Method (Rect)
See Also
[image]

Selects all map elements intersecting the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect object specifying the area containing the elements to select.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Properties

Layer(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them.
FillColors | Gets or sets the colors used to fill map elements on this layer.
HighlightColor | Gets or sets the color used to highlight elements on this layer.
LineColor | Gets or sets the line color used to draw elements on this layer.
Palette | Gets or sets the color palette associated with this layer.
Visible | Gets or sets whether this layer should be visible in the map view.

See Also

Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).BoundingBox Property

Layer(TColor, TPalette).BoundingBox Property
[image]

Returns the bounding box of elements in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding box.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).EnableHighlight Property

Layer(TColor, TPalette).EnableHighlight Property
[image]

Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableHighlight { get; set; }

Visual Basic [image] Copy Code

Public Property EnableHighlight As Boolean

Property Value

true to highlight elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).EnableSelection Property

Layer(TColor, TPalette).EnableSelection Property
[image]

Gets or sets whether map elements should be selected when the user clicks them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableSelection { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSelection As Boolean

Property Value

true to select elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).FillColors Property

Layer(TColor, TPalette).FillColors Property
[image]

Gets or sets the colors used to fill map elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As TColor()

Property Value

An array of color objects used as a palette.

Remarks

The Color property of the Shape class is an index within this array.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).HighlightColor Property

Layer(TColor, TPalette).HighlightColor Property
[image]

Gets or sets the color used to highlight elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightColor As TColor

Property Value

A color used to draw highlighted elements.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).LineColor Property

Layer(TColor, TPalette).LineColor Property
[image]

Gets or sets the line color used to draw elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Public Property LineColor As TColor

Property Value

A color used to draw border lines.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Palette Property

Layer(TColor, TPalette).Palette Property
[image]

Gets or sets the color palette associated with this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TPalette Palette { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Palette As TPalette

Property Value

A TPalette instance.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette).Visible Property

Layer(TColor, TPalette).Visible Property
[image]

Gets or sets whether this layer should be visible in the map view.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true to show this layer, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Layer(TColor, TPalette) Events

Layer(TColor, TPalette) Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed.
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed.
PropertyChanged | Raised when the value of a property of the Layer class is changed.

See Also

Layer(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Class

Map Class
[image]

Represents a geographic map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Map

Visual Basic [image] Copy Code

Public Class Map

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Map

See Also

Map Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Members

Map Members
Constructors Properties Methods Events
[image]

Represents a geographic map.

The following tables list the members exposed by the Map type.

Public Constructors

Name | Description
Map | Initializes a new instance of the Map class.

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded. Creates and loads a map from a file.
HitTest | Overloaded. Returns the Shape that contains a specified point.
Latitude | Overloaded. Converts latitude to its representation as a double value.
LoadFromFile | Overloaded. Loads the map data from an ESRI file.
LoadFromStream | Overloaded. Loads the map data from a stream.
Longitude | Overloaded. Converts longitude to its representation as a double value.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Constructor

Map Constructor
[image]

Initializes a new instance of the Map class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Methods

Map Methods
[image]

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded. Creates and loads a map from a file.
HitTest | Overloaded. Returns the Shape that contains a specified point.
Latitude | Overloaded. Converts latitude to its representation as a double value.
LoadFromFile | Overloaded. Loads the map data from an ESRI file.
LoadFromStream | Overloaded. Loads the map data from a stream.
Longitude | Overloaded. Converts longitude to its representation as a double value.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.AssignColors Method

Map.AssignColors Method
[image]

Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void AssignColors ()

Visual Basic [image] Copy Code

Public Sub AssignColors ()

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.ClearCache Method

Map.ClearCache Method
[image]

Clears any cached values associated with the map for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void ClearCache ()

Visual Basic [image] Copy Code

Public Sub ClearCache ()

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.FromFile Method

Map.FromFile Method
[image]

Creates and loads a map from a file.

Overload List

Name | Description
Map.FromFile (String) | Creates and loads a map from the specified file.
Map.FromFile (String, Boolean, String) | Creates and loads a map from the specified file.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.FromFile Method (String)

Map.FromFile Method (String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

Return Value

The Map loaded from the specified file.

See Also

FromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.FromFile Method (String, Boolean, String)

Map.FromFile Method (String, Boolean, String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Return Value

The Map loaded from the specified file.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

FromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.HitTest Method

Map.HitTest Method
[image]

Returns the Shape that contains a specified point.

Overload List

Name | Description
Map.HitTest (Point, ITransform) | Returns the Shape that contains the specified point.
Map.HitTest (Point) | Returns the Shape that contains the specified point.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.HitTest Method (Point, ITransform)

Map.HitTest Method (Point, ITransform)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point, _
transform As ITransform _
) As Shape

Parameters

point

A Point instance specifying location on the map.

transform

An ITransform specifying the transform used to render this map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.HitTest Method (Point)

Map.HitTest Method (Point)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point _
) As Shape

Parameters

point

A Point instance specifying location on the map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Latitude Method

Map.Latitude Method
[image]

Converts latitude to its representation as a double value.

Overload List

Name | Description
Map.Latitude (Double, Double, Double, Char) | Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.
Map.Latitude (Double, Double, Char) | Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Latitude Method (Double, Double, Double, Char)

Map.Latitude Method (Double, Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
double seconds,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

seconds

Specifies the latitude arc seconds.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Latitude Method (Double, Double, Char)

Map.Latitude Method (Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromFile Method

Map.LoadFromFile Method
[image]

Loads the map data from an ESRI file.

Overload List

Name | Description
Map.LoadFromFile (String, Boolean) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, Int32) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, String) | Loads the map data from the specified ESRI map file.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean)

Map.LoadFromFile Method (String, Boolean)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, Int32)

Map.LoadFromFile Method (String, Boolean, Int32)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
int labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As Integer _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

An integer specifying the index of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromFile Method (String)

Map.LoadFromFile Method (String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String _
)

Parameters

fileName

The file name of the map file.

See Also

LoadFromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, String)

Map.LoadFromFile Method (String, Boolean, String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromStream Method

Map.LoadFromStream Method
[image]

Loads the map data from a stream.

Overload List

Name | Description
Map.LoadFromStream (Stream, Stream, String) | Loads the map data from the specified stream.
Map.LoadFromStream (Stream) | Loads the map data from the specified stream.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromStream Method (Stream, Stream, String)

Map.LoadFromStream Method (Stream, Stream, String)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream mapStream,
Stream dbfStream,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
mapStream As Stream, _
dbfStream As Stream, _
labelField As String _
)

Parameters

mapStream

A System.IO.Stream instance representing shapefile data.

dbfStream

A System.IO.Stream instance representing the map database.

labelField

Specifies the name of the database column containing labels of map elements.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromStream Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.LoadFromStream Method (Stream)

Map.LoadFromStream Method (Stream)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream

A System.IO.Stream instance representing shapefile data.

See Also

LoadFromStream Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Longitude Method

Map.Longitude Method
[image]

Converts longitude to its representation as a double value.

Overload List

Name | Description
Map.Longitude (Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.
Map.Longitude (Double, Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Longitude Method (Double, Double, Char)

Map.Longitude Method (Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Longitude Method (Double, Double, Double, Char)

Map.Longitude Method (Double, Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
double seconds,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

seconds

Specifies the longitude arc seconds.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.OnPropertyChanged Method

Map.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.SaveToFile Method

Map.SaveToFile Method
[image]

Saves the map to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String _
)

Parameters

fileName

A string specifying the file name.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Properties

Map Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

See Also

Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.BoundingBox Property

Map.BoundingBox Property
[image]

Returns the bounding box of all map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect BoundingBox { get; set; }

Visual Basic [image] Copy Code

Public Property BoundingBox As Rect

Property Value

A Rect object.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Database Property

Map.Database Property
[image]

Gets or sets the DBF database associated with the map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database Database { get; set; }

Visual Basic [image] Copy Code

Public Property Database As Database

Property Value

A Database object.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.Shapes Property

Map.Shapes Property
[image]

Returns the list of map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Shapes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shapes As List(Of Shape)

Property Value

A list of Shape objects.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.ShapeType Property

Map.ShapeType Property
[image]

Returns the shape type associated with this map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ShapeType ShapeType { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeType As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map Events

Map Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Map.PropertyChanged Event

Map.PropertyChanged Event
[image]

Raised when the value of a property of the Map class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Map Members
Map Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement Class

MapElement Class
[image]

Represents visual elements of a map that can be drawn and hit-tested.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class MapElement

Visual Basic [image] Copy Code

Public MustInherit Class MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Shape

See Also

MapElement Members
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement Members

MapElement Members
Constructors Properties Methods
[image]

Represents visual elements of a map that can be drawn and hit-tested.

The following tables list the members exposed by the MapElement type.

Public Constructors

Name | Description
MapElement | Initializes a new instance of the MapElement class.

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element.
FontSize | Gets or sets the size of the font used to render the label of this element.
Label | Gets or sets the label of this map element.

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement Constructor

MapElement Constructor
[image]

Initializes a new instance of the MapElement class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapElement ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement Methods

MapElement Methods
[image]

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.Draw Method

MapElement.Draw Method
[image]

Draws this map element on the specified drawing surface.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected MustOverride Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.DrawLabel Method

MapElement.DrawLabel Method
[image]

Draws the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.Highlight Method

MapElement.Highlight Method
[image]

Draws a highlight of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.HitTest Method

MapElement.HitTest Method
[image]

Tests whether this map element contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected MustOverride Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement Properties

MapElement Properties
[image]

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element.
FontSize | Gets or sets the size of the font used to render the label of this element.
Label | Gets or sets the label of this map element.

See Also

MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.FontName Property

MapElement.FontName Property
[image]

Gets or sets the name of the font used to render the label of this element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string specifying the name of the label's font. The default value is "Arial".

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.FontSize Property

MapElement.FontSize Property
[image]

Gets or sets the size of the font used to render the label of this element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value specifying the size of the label's font. The default value is 12.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapElement.Label Property

MapElement.Label Property
[image]

Gets or sets the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the label text.

See Also

MapElement Members
MapElement Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Class

MapLayerBase(TColor, TPalette) Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class MapLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class MapLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)
MindFusion.Mapping.Wpf.MapLayer

See Also

MapLayerBase(TColor, TPalette) Members
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Members

MapLayerBase(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
MapLayerBase | Initializes a new instance of the MapLayerBase class.

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer.
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes.
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawHighlights | Overrides Layer.DrawHighlights.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Overloaded. Selects one or more map elements.
Toggle | Layer.Toggle override.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Constructor

MapLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the MapLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapLayerBase<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Methods

MapLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawHighlights | Overrides Layer.DrawHighlights.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Overloaded. Selects one or more map elements.
Toggle | Layer.Toggle override.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).ClearCache Method

MapLayerBase(TColor, TPalette).ClearCache Method
[image]

Layer.ClearCache override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void ClearCache ()

Visual Basic [image] Copy Code

Public Overrides Sub ClearCache ()

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Draw Method

MapLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawHighlights Method

MapLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Overrides Layer.DrawHighlights.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawLabels Method

MapLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Highlight Method

MapLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).HitTest Method

MapLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Toggle Method

MapLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method

MapLayerBase(TColor, TPalette).Select Method
[image]

Selects one or more map elements.

Overload List

Name | Description
MapLayerBase(TColor, TPalette).Select (MapElement) | Layer.Select override.
MapLayerBase(TColor, TPalette).Select (Rect) | Layer.Select override.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method (MapElement)

MapLayerBase(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method (Rect)

MapLayerBase(TColor, TPalette).Select Method (Rect)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect object specifying the area containing the elements to select.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Properties

MapLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer.
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes.
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).BoundingBox Property

MapLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the bounding box.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Map Property

MapLayerBase(TColor, TPalette).Map Property
[image]

Gets or sets the Map whose elements should be rendered on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map Map { get; set; }

Visual Basic [image] Copy Code

Public Property Map As Map

Property Value

A Map object.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Selection Property

MapLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Shape)

Property Value

A list of Shape objects.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Events

MapLayerBase(TColor, TPalette) Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape Class

NullShape Class
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class NullShape : Shape

Visual Basic [image] Copy Code

Public Class NullShape
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape

See Also

NullShape Members
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape Members

NullShape Members
Constructors Fields Properties Methods
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

The following tables list the members exposed by the NullShape type.

Public Constructors

Name | Description
NullShape | Initializes a new instance of the NullShape class.

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Shape.Type override.

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | MapElement.Draw override.
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | MapElement.HitTest override.

See Also

NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape Constructor

NullShape Constructor
[image]

Initializes a new instance of the NullShape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public NullShape (
int id
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape Methods

NullShape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | MapElement.Draw override.
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | MapElement.HitTest override.

See Also

NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.Draw Method

NullShape.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.GetBoundingBox Method

NullShape.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.GetCenter Method

NullShape.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.HitTest Method

NullShape.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.SaveTo Method

NullShape.SaveTo Method
[image]

Shape.SaveTo override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape Properties

NullShape Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Shape.Type override.

See Also

NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.NullShape.Type Property

NullShape.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

NullShape Members
NullShape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Class

Point Class
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Point : Shape

Visual Basic [image] Copy Code

Public Class Point
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.Point

See Also

Point Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Members

Point Members
Constructors Fields Properties Methods
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

The following tables list the members exposed by the Point type.

Public Constructors

Name | Description
Point | Overloaded. Initializes a new instance of the Point class.

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Shape.Type override.

Public Methods

Name | Description
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded. Determines whether this point is equal to another point.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Constructor

Point Constructor
[image]

Initializes a new instance of the Point class.

Overload List

Name | Description
Point (Int32, BinaryReader) | Initializes a new instance of the Point class.
Point (Double, Double) | Initializes a new instance of the Point class.

See Also

Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Constructor (Int32, BinaryReader)

Point Constructor (Int32, BinaryReader)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
int id,
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
reader As BinaryReader _
)

Parameters

id

The record number of this point in the ESRI map file.

reader

A BinaryReader used to read the point data.

See Also

Point Constructor Overload List
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Constructor (Double, Double)

Point Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying longitude.

y

A double value specifying latitude.

See Also

Point Constructor Overload List
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Methods

Point Methods
[image]

Public Methods

Name | Description
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded. Determines whether this point is equal to another point.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Clone Method

Point.Clone Method
[image]

Clones this point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Point

Return Value

A Point instance with the same coordinates as this point.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Distance Method

Point.Distance Method
[image]

Returns the distance from this point to the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Distance (
Point point
)

Visual Basic [image] Copy Code

Public Function Distance( _
point As Point _
) As Double

Parameters

point

A Point instance.

Return Value

A double value representing the distance between the two points.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Draw Method

Point.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.DrawLabel Method

Point.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Equals Method

Point.Equals Method
[image]

Determines whether this point is equal to another point.

Overload List

Name | Description
Point.Equals (Point) | Determines whether the specified Point is equal to this Point.
Point.Equals (Object) | Object.Equals override.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Equals Method (Point)

Point.Equals Method (Point)
See Also
[image]

Determines whether the specified Point is equal to this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public new bool Equals (
Point other
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
other As Point _
) As Boolean

Parameters

other

The Point to compare with this point.

Return Value

true if the specified Point is equal to the current Point, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Equals Method (Object)

Point.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with this object.

Return Value

true if the specified Object is equal to the current Object, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.GetBoundingBox Method

Point.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.GetCenter Method

Point.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.GetHashCode Method

Point.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the this point.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Highlight Method

Point.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.HitTest Method

Point.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.SaveTo Method

Point.SaveTo Method
[image]

Saves the point to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the point data.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.ToString Method

Point.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of this point.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Properties

Point Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Shape.Type override.

See Also

Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Type Property

Point.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point Fields

Point Fields
[image]

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

See Also

Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.X Field

Point.X Field
[image]

The X coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double X

Visual Basic [image] Copy Code

Public X As Double

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Point.Y Field

Point.Y Field
[image]

The Y coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Y

Visual Basic [image] Copy Code

Public Y As Double

See Also

Point Members
Point Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Class

Rect Class
[image]

A class representing a rectangular are on the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Rect

Visual Basic [image] Copy Code

Public Class Rect

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Rect

See Also

Rect Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Members

Rect Members
Constructors Properties Methods
[image]

A class representing a rectangular are on the map.

The following tables list the members exposed by the Rect type.

Public Constructors

Name | Description
Rect | Overloaded. Initializes a new instance of the Rect class.

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

Public Methods

Name | Description
ContainsPoint | Overloaded. Tests whether this rectangle contains a point.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
SaveTo | Saves the rectangle to the specified stream.
Union | Returns the union of two rectangles.

See Also

Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Constructor

Rect Constructor
[image]

Initializes a new instance of the Rect class.

Overload List

Name | Description
Rect (Double, Double, Double, Double) | Initializes a new instance of the Rect class.
Rect (Point, Point) | Initializes a new instance of the Rect class.
Rect (BinaryReader) | Initializes a new instance of the Rect class.

See Also

Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Constructor (Double, Double, Double, Double)

Rect Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
double xMin,
double yMin,
double xMax,
double yMax
)

Visual Basic [image] Copy Code

Public New ( _
xMin As Double, _
yMin As Double, _
xMax As Double, _
yMax As Double _
)

Parameters

xMin

The minimum X value.

yMin

The minimum Y value.

xMax

The maximum X value.

yMax

The maximum Y value.

See Also

Rect Constructor Overload List
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Constructor (Point, Point)

Rect Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
Point point1,
Point point2
)

Visual Basic [image] Copy Code

Public New ( _
point1 As Point, _
point2 As Point _
)

Parameters

point1

A Point specifying one of the rectangle corners.

point2

A Point specifying the opposite rectangle corner.

See Also

Rect Constructor Overload List
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Constructor (BinaryReader)

Rect Constructor (BinaryReader)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read the rectangle coordinates.

See Also

Rect Constructor Overload List
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Methods

Rect Methods
[image]

Public Methods

Name | Description
ContainsPoint | Overloaded. Tests whether this rectangle contains a point.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
SaveTo | Saves the rectangle to the specified stream.
Union | Returns the union of two rectangles.

See Also

Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.ContainsPoint Method

Rect.ContainsPoint Method
[image]

Tests whether this rectangle contains a point.

Overload List

Name | Description
Rect.ContainsPoint (Point, Double) | Tests whether this rectangle contains the specified point within a threshold.
Rect.ContainsPoint (Point) | Tests whether this rectangle contains the specified point.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.ContainsPoint Method (Point, Double)

Rect.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether this rectangle contains the specified point within a threshold.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point instance.

threshold

A threshold value.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.ContainsPoint Method (Point)

Rect.ContainsPoint Method (Point)
See Also
[image]

Tests whether this rectangle contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

A Point instance.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Divide Method

Rect.Divide Method
[image]

Divides this rectangle into four equal parts.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect[] Divide ()

Visual Basic [image] Copy Code

Public Function Divide () As Rect()

Return Value

An array of rectangles.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.GetCenter Method

Rect.GetCenter Method
[image]

Returns the rectangle center.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point representing the center of this rectangle.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.GetLocation Method

Rect.GetLocation Method
[image]

Returns the min X/Y corner of this rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetLocation ()

Visual Basic [image] Copy Code

Public Function GetLocation () As Point

Return Value

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Intersect Method

Rect.Intersect Method
[image]

Returns the intersection of this rectangle with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect Intersect (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersect( _
rect As Rect _
) As Rect

Parameters

rect

A Rect instance.

Return Value

A Rect representing the intersection of the two rectangles.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Intersects Method

Rect.Intersects Method
[image]

Tests whether this rectangle intersects with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Intersects (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersects( _
rect As Rect _
) As Boolean

Parameters

rect

A Rect instance.

Return Value

true if the rectangles intersect, otherwise false.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.SaveTo Method

Rect.SaveTo Method
[image]

Saves the rectangle to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the rectangle coordinates.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Union Method

Rect.Union Method
[image]

Returns the union of two rectangles.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Rect Union (
Rect rect1,
Rect rect2
)

Visual Basic [image] Copy Code

Public Shared Function Union( _
rect1 As Rect, _
rect2 As Rect _
) As Rect

Parameters

rect1

Specifies the first rectangle.

rect2

Specifies the second rectangle.

Return Value

A Rect instance representing the union of specified rectangles.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect Properties

Rect Properties
[image]

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

See Also

Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Height Property

Rect.Height Property
[image]

Gets the rectangle height.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.Width Property

Rect.Width Property
[image]

Gets the rectangle width.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.XMax Property

Rect.XMax Property
[image]

Gets or set the maximum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMax { get; set; }

Visual Basic [image] Copy Code

Public Property XMax As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.XMin Property

Rect.XMin Property
[image]

Gets or set the minimum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMin { get; set; }

Visual Basic [image] Copy Code

Public Property XMin As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.YMax Property

Rect.YMax Property
[image]

Gets or set the maximum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMax { get; set; }

Visual Basic [image] Copy Code

Public Property YMax As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Rect.YMin Property

Rect.YMin Property
[image]

Gets or set the minimum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMin { get; set; }

Visual Basic [image] Copy Code

Public Property YMin As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row Class

Row Class
[image]

Represents a DBF database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Row : ICustomTypeDescriptor

Visual Basic [image] Copy Code

Public Class Row
Implements ICustomTypeDescriptor

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Row

See Also

Row Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Row Members

Row Members
Properties
[image]

Represents a DBF database row.

The following tables list the members exposed by the Row type.

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded. Gets the data stored in a specified field.

See Also

Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row Properties

Row Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded. Gets the data stored in a specified field.

See Also

Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row.Index Property

Row.Index Property
[image]

Gets or sets the row index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the row's ordinal index within the database.

See Also

Row Members
Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row.Item Property

Row.Item Property
[image]

Gets the data stored in a specified field.

Overload List

Name | Description
Row.Item (Int32) | Returns the data stored in the specified field.
Row.Item (Column) | Returns the data stored in the specified field.
Row.Item (String) | Returns the data stored in the specified field.

See Also

Row Members
Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row.Item Property (Int32)

Row.Item Property (Int32)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
int columnIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnIndex As Integer _
) As String

Parameters

columnIndex

Specifies the index of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row.Item Property (Column)

Row.Item Property (Column)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
Column column
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Column _
) As String

Parameters

column

Specifies the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Row.Item Property (String)

Row.Item Property (String)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
string columnName
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnName As String _
) As String

Parameters

columnName

Specifies the name of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Class

Shape Class
[image]

Represents geometrical shapes displayed on a map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Shape : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Shape
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape
MindFusion.Mapping.Point

See Also

Shape Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Members

Shape Members
Constructors Fields Properties Methods
[image]

Represents geometrical shapes displayed on a map.

The following tables list the members exposed by the Shape type.

Protected Constructors

Name | Description
Shape | Initializes a new instance of the Shape class.

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance.
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Gets the ESRI shape type of this Shape.

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected Shape (
int id
)

Visual Basic [image] Copy Code

Protected New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.ClearCache Method

Shape.ClearCache Method
[image]

Clears any cached values associated with the shape for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void ClearCache ()

Visual Basic [image] Copy Code

Protected Overridable Sub ClearCache ()

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.GetBoundingBox Method

Shape.GetBoundingBox Method
[image]

Gets the bounding box of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public MustOverride Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.GetCenter Method

Shape.GetCenter Method
[image]

Gets the center point of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Point GetCenter ()

Visual Basic [image] Copy Code

Public MustOverride Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.SaveTo Method

Shape.SaveTo Method
[image]

Saves this shape to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public MustOverride Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HitTestDistance | Gets or set the current hit test threshold distance.
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Type | Gets the ESRI shape type of this Shape.

See Also

Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.Color Property

Shape.Color Property
[image]

Gets or sets the index of the shape's color within the current color palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Integer

Property Value

An integer value specifying an index within the FillColors array of a MapLayer.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.DatabaseRow Property

Shape.DatabaseRow Property
[image]

Gets the DBF database row associated with this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Row DatabaseRow { get; set; }

Visual Basic [image] Copy Code

Public Property DatabaseRow As Row

Property Value

A Row instance.

Remarks

This property is set if the loadDatabase argument of the LoadFromFile method is set to true.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.HitTestDistance Property

Shape.HitTestDistance Property
[image]

Gets or set the current hit test threshold distance.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double HitTestDistance { get; set; }

Visual Basic [image] Copy Code

Public Shared Property HitTestDistance As Double

Property Value

A double value specifying threshold distance for hit-testing non-polygonal shapes.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.Type Property

Shape.Type Property
[image]

Gets the ESRI shape type of this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract ShapeType Type { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape Fields

Shape Fields
[image]

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

See Also

Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.Shape.Id Field

Shape.Id Field
[image]

The record number of this shape in the ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Id

Visual Basic [image] Copy Code

Public Id As Integer

See Also

Shape Members
Shape Class
MindFusion.Mapping Namespace


MindFusion.Mapping.ShapeType Enumeration

ShapeType Enumeration
[image]

Specifies the type of shapes contained in an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ShapeType

Visual Basic [image] Copy Code

Public Enum ShapeType

Members

Member name | Description
MultiPatch | Indicates a MultiPatch shape, which consists of a number of surface patches.
MultiPoint | Indicates a MultiPoint shape, which contains a set of points.
MultiPointM | Indicates a MultiPointM shape, which is a MultiPoint with additional measure attributes.
MultiPointZ | Indicates a MultiPointZ shape, which is a MultiPoint with additional Z and measure attributes.
NullShape | Indicates a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Indicates a Point shape, which contains X (longitude) and Y (latitude) coordinates.
PointM | Indicates a PointM shape, which is a Point with an additional measure attribute.
PointZ | Indicates a PointZ shape, which is a Point with additional Z and measure attributes.
Polygon | Indicates a Polygon shape, which contains several ordered sets of points rendered as filled polygons.
PolygonM | Indicates a PolygonM shape, which is a Polygon with additional measure attributes.
PolygonZ | Indicates a PolygonZ shape, which is a Polygon with additional Z and measure attributes.
PolyLine | Indicates a Polyline shape, which contains several ordered sets of points rendered as connected line segments.
PolyLineM | Indicates a PolyLineM shape, which is a PolyLine with additional measure attributes.
PolyLineZ | Indicates a PolyLineZ shape, which is a PolyLine with additional Z and measure attributes.

See Also

MindFusion.Mapping Namespace


MindFusion.Mapping.TextAlignment Enumeration

TextAlignment Enumeration
[image]

Specifies text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum TextAlignment

Visual Basic [image] Copy Code

Public Enum TextAlignment

Members

Member name | Description
Center | Indicates center alignment.
Far | Indicates right or bottom alignment.
Near | Indicates top or left alignment.

See Also

MindFusion.Mapping Namespace


MindFusion.Mapping.Wpf Namespace

MindFusion.Mapping.Wpf Namespace
Classes Enumerations

Classes

Class | Description
DecorationBubble | Represents a bubble object that can be drawn as a decoration over the map.
DecorationImage | Represents an image that can be drawn as a decoration over the map.
DecorationLayer | Represents a layer containing decorative elements.
LayerEventArgs | Provides data for layer-related events.
LayerList | Represents a list of Layer objects.
LayerPresenter | A control used to render a single map layer.
MapEventArgs | Provides data for map events.
MapLayer | Represents a map layer containing geometric shapes.
MapView | A WPF control used to draw maps.
Viewbox | Defines a decorator that can stretch and scale a single child to fill the available space.
VisibilityConverter | Converts boolean property values to Visibility values.
XamlPalette | Represents a palette of colors.
XamlTransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.

Enumerations

Enumeration | Description
Behavior | Specifies how the MapView control repsonds to user interactions with the mouse.


MindFusion.Mapping.Wpf.Behavior Enumeration

Behavior Enumeration
[image]

Specifies how the MapView control repsonds to user interactions with the mouse.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Pan | Indicates that the user will scroll the view when dragging with the mouse.
Select | Indicates that the user will select multiple elements in the view when dragging with the mouse.

Remarks

Members of this enumeration can be assigned to the Behavior property of the MapView class.

See Also

MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Class

DecorationBubble Class
[image]

Represents a bubble object that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationBubble : Decoration

Visual Basic [image] Copy Code

Public Class DecorationBubble
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationBubble

See Also

DecorationBubble Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Members

DecorationBubble Members
Constructors Properties Methods
[image]

Represents a bubble object that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationBubble type.

Public Constructors

Name | Description
DecorationBubble | Initializes a new instance of the DecorationBubble class.

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)
Radius | Gets or sets the bubble radius in pixels.

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Constructor

DecorationBubble Constructor
[image]

Initializes a new instance of the DecorationBubble class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationBubble (
int radius,
Color fillColor,
Color borderColor,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
radius As Integer, _
fillColor As Color, _
borderColor As Color, _
latitude As Double, _
longitude As Double _
)

Parameters

radius

An integer specifying the bubble radius.

fillColor

A Color instance specifying the bubble fill color.

borderColor

A Color instance specifying the bubble border color.

latitude

A double value specifying the latitude at which the bubble should be drawn.

longitude

A double value specifying the longitude at which the bubble should be drawn.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Methods

DecorationBubble Methods
[image]

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Draw Method

DecorationBubble.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.DrawLabel Method

DecorationBubble.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Highlight Method

DecorationBubble.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.HitTest Method

DecorationBubble.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Properties

DecorationBubble Properties
[image]

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)
Radius | Gets or sets the bubble radius in pixels.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.BorderColor Property

DecorationBubble.BorderColor Property
[image]

Gets or sets the bubble's border color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Property BorderColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.FillColor Property

DecorationBubble.FillColor Property
[image]

Gets or sets the bubble's fill color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color FillColor { get; set; }

Visual Basic [image] Copy Code

Public Property FillColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Radius Property

DecorationBubble.Radius Property
[image]

Gets or sets the bubble radius in pixels.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Integer

Property Value

An integer value specifying the bubble radius in pixels.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Class

DecorationImage Class
[image]

Represents an image that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationImage : Decoration

Visual Basic [image] Copy Code

Public Class DecorationImage
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationImage

See Also

DecorationImage Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Members

DecorationImage Members
Constructors Properties Methods
[image]

Represents an image that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationImage type.

Public Constructors

Name | Description
DecorationImage | Overloaded. Initializes a new instance of the DecorationImage class.

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the BitmapImage that should be displayed as a decoration.
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor

DecorationImage Constructor
[image]

Initializes a new instance of the DecorationImage class.

Overload List

Name | Description
DecorationImage () | Initializes a new instance of the DecorationImage class.
DecorationImage (BitmapImage, Double, Double) | Initializes a new instance of the DecorationImage class.
DecorationImage (BitmapImage, Int32, Int32, Double, Double) | Initializes a new instance of the DecorationImage class.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor ()

DecorationImage Constructor ()
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor (BitmapImage, Double, Double)

DecorationImage Constructor (BitmapImage, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage (
BitmapImage image,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As BitmapImage, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A BitmapImage instance.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor (BitmapImage, Int32, Int32, Double, Double)

DecorationImage Constructor (BitmapImage, Int32, Int32, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage (
BitmapImage image,
int pivotX,
int pivotY,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As BitmapImage, _
pivotX As Integer, _
pivotY As Integer, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A BitmapImage instance.

pivotX

Position within the image that should be aligned to the specified longitude.

pivotY

Position within the image that should be aligned to the specified latitude.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Methods

DecorationImage Methods
[image]

Public Methods

Name | Description
GetLocation | Gets a point representing the geographical location of the decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Draw Method

DecorationImage.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.DrawLabel Method

DecorationImage.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Highlight Method

DecorationImage.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.HitTest Method

DecorationImage.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Properties

DecorationImage Properties
[image]

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element. (Inherited from MapElement.)
FontSize | Gets or sets the size of the font used to render the label of this element. (Inherited from MapElement.)
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the BitmapImage that should be displayed as a decoration.
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.HighlightImage Property

DecorationImage.HighlightImage Property
[image]

Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public BitmapImage HighlightImage { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightImage As BitmapImage

Property Value

A System.Windows.Media.Imaging.BitmapImage instance.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Image Property

DecorationImage.Image Property
[image]

Gets or sets the BitmapImage that should be displayed as a decoration.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public BitmapImage Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As BitmapImage

Property Value

A System.Windows.Media.Imaging.BitmapImage instance.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.PivotX Property

DecorationImage.PivotX Property
[image]

Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int PivotX { get; set; }

Visual Basic [image] Copy Code

Public Property PivotX As Integer

Property Value

An integer value specifying horizontal offset.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.PivotY Property

DecorationImage.PivotY Property
[image]

Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int PivotY { get; set; }

Visual Basic [image] Copy Code

Public Property PivotY As Integer

Property Value

An integer value specifying vertical offset.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Class

DecorationLayer Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationLayer : DecorationLayerBase<Color, XamlPalette>

Visual Basic [image] Copy Code

Public Class DecorationLayer
Inherits DecorationLayerBase(Of Color, XamlPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, XamlPalette)
MindFusion.Mapping.DecorationLayerBase(Color, XamlPalette)
MindFusion.Mapping.Wpf.DecorationLayer

See Also

DecorationLayer Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Members

DecorationLayer Members
Constructors Properties Methods Events
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayer type.

Public Constructors

Name | Description
DecorationLayer | Overloaded. Initializes a new instance of the DecorationLayer class.

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from DecorationLayerBase.)
Decorations | Gets the list of decorations displayed in this layer. (Inherited from DecorationLayerBase.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected decorations. (Inherited from DecorationLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Layer.Draw override. (Inherited from DecorationLayerBase.)
DrawHighlights | Layer.DrawHighlights override. (Inherited from DecorationLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from DecorationLayerBase.)
Highlight | Layer.Highlight override. (Inherited from DecorationLayerBase.)
HitTest | Layer.HitTest override. (Inherited from DecorationLayerBase.)
Select | Overloaded. Selects one or more map elements. (Inherited from DecorationLayerBase.)
Toggle | Layer.Toggle override. (Inherited from DecorationLayerBase.)

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor

DecorationLayer Constructor
[image]

Initializes a new instance of the DecorationLayer class.

Overload List

Name | Description
DecorationLayer () | Initializes a new instance of the DecorationLayer class.
DecorationLayer (Rect) | Initializes a new instance of the DecorationLayer class.

See Also

DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor ()

DecorationLayer Constructor ()
See Also
[image]

Initializes a new instance of the DecorationLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecorationLayer Constructor Overload List
DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor (Rect)

DecorationLayer Constructor (Rect)
See Also
[image]

Initializes a new instance of the DecorationLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationLayer (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayer Constructor Overload List
DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Events

DecorationLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Class

LayerEventArgs Class
[image]

Provides data for layer-related events.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LayerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Mapping.Wpf.LayerEventArgs

See Also

LayerEventArgs Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Members

LayerEventArgs Members
Constructors Properties
[image]

Provides data for layer-related events.

The following tables list the members exposed by the LayerEventArgs type.

Public Constructors

Name | Description
LayerEventArgs | Initializes a new instance of the LayerEventArgs class.

Public Properties

Name | Description
Layer | Gets or sets the layer for which the event is raised.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Constructor

LayerEventArgs Constructor
[image]

Initializes a new instance of the LayerEventArgs class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerEventArgs (
Layer<Color, XamlPalette> layer
)

Visual Basic [image] Copy Code

Public New ( _
layer As Layer(Of Color, XamlPalette) _
)

Parameters

layer

An instance of the Layer class.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Properties

LayerEventArgs Properties
[image]

Public Properties

Name | Description
Layer | Gets or sets the layer for which the event is raised.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs.Layer Property

LayerEventArgs.Layer Property
[image]

Gets or sets the layer for which the event is raised.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Layer<Color, XamlPalette> Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer(Of Color, XamlPalette)

Property Value

An instance of the Layer class.

See Also

LayerEventArgs Members
LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Class

LayerList Class
[image]

Represents a list of Layer objects.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerList : ObservableCollection<Layer<Color, XamlPalette>>

Visual Basic [image] Copy Code

Public Class LayerList
Inherits ObservableCollection(Of Layer(Of Color, XamlPalette))

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Layer(Color, XamlPalette))
System.Collections.ObjectModel.ObservableCollection(Layer(Color, XamlPalette))
MindFusion.Mapping.Wpf.LayerList

See Also

LayerList Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Members

LayerList Members
Constructors
[image]

Represents a list of Layer objects.

The following tables list the members exposed by the LayerList type.

Public Constructors

Name | Description
LayerList | Initializes a new instance of the LayerList class.

See Also

LayerList Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Constructor

LayerList Constructor
[image]

Initializes a new instance of the LayerList class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerList ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerList Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Class

LayerPresenter Class
[image]

A control used to render a single map layer.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerPresenter : Control, ICanvasWithPalette<Color>, ICanvas

Visual Basic [image] Copy Code

Public Class LayerPresenter
Inherits Control
Implements ICanvasWithPalette(Of Color), ICanvas

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Mapping.Wpf.LayerPresenter

See Also

LayerPresenter Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Members

LayerPresenter Members
Constructors Fields Properties Methods
[image]

A control used to render a single map layer.

The following tables list the members exposed by the LayerPresenter type.

Public Constructors

Name | Description
LayerPresenter | Initializes a new instance of the LayerPresenter class.

Public Fields

Name | Description
LayerProperty | Identifies the Layer dependency property.

Public Properties

Name | Description
Layer | Gets or sets the layer rendered inside this control.
Palette | Gets or sets the color palette used to draw map shapes in this layer.

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawImageUnscaled | Draws an image with the specified attributes.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
OnApplyTemplate | Control.OnApplyTemplate override.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Fields

LayerPresenter Fields
[image]

Public Fields

Name | Description
LayerProperty | Identifies the Layer dependency property.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.LayerProperty Field

LayerPresenter.LayerProperty Field
[image]

Identifies the Layer dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LayerProperty

Visual Basic [image] Copy Code

Public Shared LayerProperty As DependencyProperty

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Constructor

LayerPresenter Constructor
[image]

Initializes a new instance of the LayerPresenter class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Methods

LayerPresenter Methods
[image]

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawImageUnscaled | Draws an image with the specified attributes.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
OnApplyTemplate | Control.OnApplyTemplate override.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method

LayerPresenter.ClipExclude Method
[image]

Excludes an area from the current clip region.

Overload List

Name | Description
LayerPresenter.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
LayerPresenter.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method (IList(Point))

LayerPresenter.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method (List(IList(Point)))

LayerPresenter.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawImageUnscaled Method

LayerPresenter.DrawImageUnscaled Method
[image]

Draws an image with the specified attributes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawImageUnscaled (
BitmapImage image,
Point point,
int pivotX,
int pivotY
)

Visual Basic [image] Copy Code

Public Sub DrawImageUnscaled( _
image As BitmapImage, _
point As Point, _
pivotX As Integer, _
pivotY As Integer _
)

Parameters

image

The image that should be drawn.

point

A Point specifying the image location.

pivotX

Horizontal position within the image that should be aligned to the specified point.

pivotY

Vertical position within the image that should be aligned to the specified point.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawPoint Method

LayerPresenter.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Public Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawPolyline Method

LayerPresenter.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawString Method

LayerPresenter.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Public Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.FillPolygon Method

LayerPresenter.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.GetPixelSize Method

LayerPresenter.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double GetPixelSize ()

Visual Basic [image] Copy Code

Public Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.OnApplyTemplate Method

LayerPresenter.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ResetClip Method

LayerPresenter.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ResetClip ()

Visual Basic [image] Copy Code

Public Sub ResetClip ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetFillColor Method

LayerPresenter.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Public Sub SetFillColor( _
color As Integer _
)

Parameters

color

The index of the color in the associated palette.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetHighlightColor Method

LayerPresenter.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetHighlightColor ()

Visual Basic [image] Copy Code

Public Sub SetHighlightColor ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetLineColor Method

LayerPresenter.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetLineColor ()

Visual Basic [image] Copy Code

Public Sub SetLineColor ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetTextAlignment Method

LayerPresenter.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Public Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Properties

LayerPresenter Properties
[image]

Public Properties

Name | Description
Layer | Gets or sets the layer rendered inside this control.
Palette | Gets or sets the color palette used to draw map shapes in this layer.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.Layer Property

LayerPresenter.Layer Property
[image]

Gets or sets the layer rendered inside this control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Layer<Color, XamlPalette> Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer(Of Color, XamlPalette)

Property Value

An instance of the Layer class.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.Palette Property

LayerPresenter.Palette Property
[image]

Gets or sets the color palette used to draw map shapes in this layer.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public IPalette<Color> Palette { get; set; }

Visual Basic [image] Copy Code

Public Property Palette As IPalette(Of Color)

Property Value

An instance of the XamlPalette class.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Class

MapEventArgs Class
[image]

Provides data for map events.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class MapEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Mapping.Wpf.MapEventArgs

See Also

MapEventArgs Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Members

MapEventArgs Members
Constructors Properties
[image]

Provides data for map events.

The following tables list the members exposed by the MapEventArgs type.

Public Constructors

Name | Description
MapEventArgs | Initializes a new instance of the MapEventArgs class.

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets or sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Constructor

MapEventArgs Constructor
[image]

Initializes a new instance of the MapEventArgs class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapEventArgs (
MapElement mapElement,
MouseButton button
)

Visual Basic [image] Copy Code

Public New ( _
mapElement As MapElement, _
button As MouseButton _
)

Parameters

mapElement

A MapElement for which the event is raised.

button

A MouseButtons member specifying the related mouse button.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Properties

MapEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets or sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs.Button Property

MapEventArgs.Button Property
[image]

Gets or sets a MouseButtons member specifying the mouse button related to the event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MouseButton Button { get; set; }

Visual Basic [image] Copy Code

Public Property Button As MouseButton

Property Value

A member of the MouseButton enumeration.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs.MapElement Property

MapEventArgs.MapElement Property
[image]

Gets or sets the MapElement for which the event is raised.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapElement MapElement { get; set; }

Visual Basic [image] Copy Code

Public Property MapElement As MapElement

Property Value

A MapElement instance.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Class

MapLayer Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapLayer : MapLayerBase<Color, XamlPalette>

Visual Basic [image] Copy Code

Public Class MapLayer
Inherits MapLayerBase(Of Color, XamlPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, XamlPalette)
MindFusion.Mapping.MapLayerBase(Color, XamlPalette)
MindFusion.Mapping.Wpf.MapLayer

See Also

MapLayer Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Members

MapLayer Members
Constructors Properties Methods Events
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayer type.

Public Constructors

Name | Description
MapLayer | Initializes a new instance of the MapLayer class.

Public Properties

Name | Description
AutoAssignColors | Gets or sets whether colors should be assigned automatically to map elements.
BoundingBox | Layer.BoundingBox override.
DatabaseLocation | Gets or sets the URL of the DBF database file.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LabelField | Gets or sets the name of the label column in the DBF database.
LabelsLoaded | Gets or sets whether the map element labels have been loaded.
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
MapLocation | Gets or sets the URL of the shapefile map file.
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. Selects one or more map elements. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Constructor

MapLayer Constructor
[image]

Initializes a new instance of the MapLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Properties

MapLayer Properties
[image]

Public Properties

Name | Description
AutoAssignColors | Gets or sets whether colors should be assigned automatically to map elements.
BoundingBox | Layer.BoundingBox override.
DatabaseLocation | Gets or sets the URL of the DBF database file.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LabelField | Gets or sets the name of the label column in the DBF database.
LabelsLoaded | Gets or sets whether the map element labels have been loaded.
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
MapLocation | Gets or sets the URL of the shapefile map file.
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.AutoAssignColors Property

MapLayer.AutoAssignColors Property
[image]

Gets or sets whether colors should be assigned automatically to map elements.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public bool AutoAssignColors { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAssignColors As Boolean

Property Value

true to assign colors to map elements automatically, otherwise false. The default value is false.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.BoundingBox Property

MapLayer.BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.DatabaseLocation Property

MapLayer.DatabaseLocation Property
[image]

Gets or sets the URL of the DBF database file.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string DatabaseLocation { get; set; }

Visual Basic [image] Copy Code

Public Property DatabaseLocation As String

Property Value

A string specifying the DBF file location.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.LabelField Property

MapLayer.LabelField Property
[image]

Gets or sets the name of the label column in the DBF database.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string LabelField { get; set; }

Visual Basic [image] Copy Code

Public Property LabelField As String

Property Value

A string specifying the name of a DBF column containing map region labels.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.LabelsLoaded Property

MapLayer.LabelsLoaded Property
[image]

Gets or sets whether the map element labels have been loaded.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public bool LabelsLoaded { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsLoaded As Boolean

Property Value

true if labels have been loaded, otherwise false.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.MapLocation Property

MapLayer.MapLocation Property
[image]

Gets or sets the URL of the shapefile map file.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string MapLocation { get; set; }

Visual Basic [image] Copy Code

Public Property MapLocation As String

Property Value

A string specifying the shapefile location.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Events

MapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Class

MapView Class
[image]

A WPF control used to draw maps.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapView : Control, IZoomTarget

Visual Basic [image] Copy Code

Public Class MapView
Inherits Control
Implements IZoomTarget

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Mapping.Wpf.MapView

See Also

MapView Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Members

MapView Members
Constructors Fields Properties Methods Events
[image]

A WPF control used to draw maps.

The following tables list the members exposed by the MapView type.

Public Constructors

Name | Description
MapView | Initializes a new instance of the MapView class.

Public Fields

Name | Description
BaseBoundsProperty | Identifies the BaseBounds dependency property.
BehaviorProperty | Identifies the Behavior dependency property.
LayersProperty | Identifies the Layers dependency property.
MapHeightProperty | Identifies the MapHeight dependency property.
MapWidthProperty | Identifies the MapWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Properties

Name | Description
BaseBounds | Gets or sets the bounding rectangle of the base map.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Behavior | Gets or sets the interaction mode of the view. This is a dependency property.
Layers | Gets the list of layers displayed in this view.
MapHeight | Returns the height of the base map. Used for binding in the control's Xaml template.
MapWidth | Returns the width of the base map. Used for binding in the control's Xaml template.
ZoomFactor | Gets or sets the current zoom level.

Public Methods

Name | Description
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
GetScrollX | IZoomTarget.GetScrollX implementation.
GetScrollY | IZoomTarget.GetScrollY implementation.
GetZoomLevel | IZoomTarget.GetZoomLevel implementation.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
OnApplyTemplate | Control.OnApplyTemplate override.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded. Scrolls to a specified map location.
SetScrollX | IZoomTarget.SetScrollX implementation.
SetScrollY | IZoomTarget.SetScrollY implementation.
SetZoomFactor | Sets the map zoom level.
SetZoomLevel | IZoomTarget.SetZoomLevel implementation.
Transform | Gets the world-to-screen coordinate system transformation.

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride override.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.
OnZoomLevelChanged | Raises the ZoomLevelChanged event.

Public Events

Name | Description
LayerDatabaseLoaded | Raised when the control completes loading layer's database asynchronously.
LayerLoaded | Raised when the control completes loading layer's data asynchronously.
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.
ZoomLevelChanged | IZoomTarget.ZoomLevelChanged implementation.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Fields

MapView Fields
[image]

Public Fields

Name | Description
BaseBoundsProperty | Identifies the BaseBounds dependency property.
BehaviorProperty | Identifies the Behavior dependency property.
LayersProperty | Identifies the Layers dependency property.
MapHeightProperty | Identifies the MapHeight dependency property.
MapWidthProperty | Identifies the MapWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseBoundsProperty Field

MapView.BaseBoundsProperty Field
[image]

Identifies the BaseBounds dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BaseBoundsProperty

Visual Basic [image] Copy Code

Public Shared BaseBoundsProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BehaviorProperty Field

MapView.BehaviorProperty Field
[image]

Identifies the Behavior dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BehaviorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BehaviorProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayersProperty Field

MapView.LayersProperty Field
[image]

Identifies the Layers dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LayersProperty

Visual Basic [image] Copy Code

Public Shared LayersProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapHeightProperty Field

MapView.MapHeightProperty Field
[image]

Identifies the MapHeight dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MapHeightProperty

Visual Basic [image] Copy Code

Public Shared MapHeightProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapWidthProperty Field

MapView.MapWidthProperty Field
[image]

Identifies the MapWidth dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MapWidthProperty

Visual Basic [image] Copy Code

Public Shared MapWidthProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ZoomFactorProperty Field

MapView.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Constructor

MapView Constructor
[image]

Initializes a new instance of the MapView class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Methods

MapView Methods
[image]

Public Methods

Name | Description
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
GetScrollX | IZoomTarget.GetScrollX implementation.
GetScrollY | IZoomTarget.GetScrollY implementation.
GetZoomLevel | IZoomTarget.GetZoomLevel implementation.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
OnApplyTemplate | Control.OnApplyTemplate override.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded. Scrolls to a specified map location.
SetScrollX | IZoomTarget.SetScrollX implementation.
SetScrollY | IZoomTarget.SetScrollY implementation.
SetZoomFactor | Sets the map zoom level.
SetZoomLevel | IZoomTarget.SetZoomLevel implementation.
Transform | Gets the world-to-screen coordinate system transformation.

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride override.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.
OnZoomLevelChanged | Raises the ZoomLevelChanged event.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ClientToMap Method

MapView.ClientToMap Method
[image]

Converts a point from the control's client coordinates to map coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point ClientToMap (
Point point
)

Visual Basic [image] Copy Code

Public Function ClientToMap( _
point As Point _
) As Point

Parameters

point

A System.Windows.Point instance.

Return Value

A MindFusion.Mapping.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.GetScrollX Method

MapView.GetScrollX Method
[image]

IZoomTarget.GetScrollX implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double GetScrollX ()

Visual Basic [image] Copy Code

Public Function GetScrollX () As Double

Return Value

A double value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.GetScrollY Method

MapView.GetScrollY Method
[image]

IZoomTarget.GetScrollY implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double GetScrollY ()

Visual Basic [image] Copy Code

Public Function GetScrollY () As Double

Return Value

A double value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.GetZoomLevel Method

MapView.GetZoomLevel Method
[image]

IZoomTarget.GetZoomLevel implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double GetZoomLevel ()

Visual Basic [image] Copy Code

Public Function GetZoomLevel () As Double

Return Value

A double value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapToClient Method

MapView.MapToClient Method
[image]

Converts a point from the map coordinates to control's client coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point MapToClient (
Point point
)

Visual Basic [image] Copy Code

Public Function MapToClient( _
point As Point _
) As Point

Parameters

point

A MindFusion.Mapping.Point instance.

Return Value

A System.Windows.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MeasureOverride Method

MapView.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size that this object can give to child objects.

Return Value

The size that this object determines it needs during layout.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnApplyTemplate Method

MapView.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMapElementClick Method

MapView.OnMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMapElementClick (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementClick( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMapElementHover Method

MapView.OnMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMapElementHover (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementHover( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseLeftButtonDown Method

MapView.OnMouseLeftButtonDown Method
[image]

Control.OnMouseLeftButtonDown override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseLeftButtonUp Method

MapView.OnMouseLeftButtonUp Method
[image]

Control.OnMouseLeftButtonUp override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseMove Method

MapView.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseWheel Method

MapView.OnMouseWheel Method
[image]

Control.OnMouseWheel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseWheel (
MouseWheelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseWheel( _
e As MouseWheelEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnZoomLevelChanged Method

MapView.OnZoomLevelChanged Method
[image]

Raises the ZoomLevelChanged event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnZoomLevelChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomLevelChanged( _
e As EventArgs _
)

Parameters

e

An object that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.RaiseMapElementClick Method

MapView.RaiseMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void RaiseMapElementClick (
MapElement mapElement,
MouseButton button
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementClick( _
mapElement As MapElement, _
button As MouseButton _
)

Parameters

mapElement

The clicked map element.

button

The mouse button.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.RaiseMapElementHover Method

MapView.RaiseMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void RaiseMapElementHover (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementHover( _
mapElement As MapElement _
)

Parameters

mapElement

The hovered map element.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ScrollTo Method

MapView.ScrollTo Method
[image]

Scrolls to a specified map location.

Overload List

Name | Description
MapView.ScrollTo (Double, Double) | Scrolls to the specified map location and center it inside the control.
MapView.ScrollTo (Point) | Scrolls to the specified map location and center it inside the control.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ScrollTo Method (Double, Double)

MapView.ScrollTo Method (Double, Double)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

A double value specifying the location latitude.

longitude

A double value specifying the location longitude.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView.ScrollTo Method (Point)

MapView.ScrollTo Method (Point)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
Point point
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
point As Point _
)

Parameters

point

A Point instance specifying a map location.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView.SetScrollX Method

MapView.SetScrollX Method
[image]

IZoomTarget.SetScrollX implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetScrollX (
double scrollX
)

Visual Basic [image] Copy Code

Public Sub SetScrollX( _
scrollX As Double _
)

Parameters

scrollX

The new scroll position.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.SetScrollY Method

MapView.SetScrollY Method
[image]

IZoomTarget.SetScrollY implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetScrollY (
double scrollY
)

Visual Basic [image] Copy Code

Public Sub SetScrollY( _
scrollY As Double _
)

Parameters

scrollY

The new scroll position.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.SetZoomFactor Method

MapView.SetZoomFactor Method
[image]

Sets the map zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

A double value specifying the new zoom level; 1 is for 100% zoom.

pivotPoint

A Point whose screen location should not change after zoom.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
ScrollTo Method
ZoomFactor Property


MindFusion.Mapping.Wpf.MapView.SetZoomLevel Method

MapView.SetZoomLevel Method
[image]

IZoomTarget.SetZoomLevel implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetZoomLevel (
double zoom
)

Visual Basic [image] Copy Code

Public Sub SetZoomLevel( _
zoom As Double _
)

Parameters

zoom

The new zoom level.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.Transform Method

MapView.Transform Method
[image]

Gets the world-to-screen coordinate system transformation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public GeneralTransform Transform ()

Visual Basic [image] Copy Code

Public Function Transform () As GeneralTransform

Return Value

A GeneralTransform instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Properties

MapView Properties
[image]

Public Properties

Name | Description
BaseBounds | Gets or sets the bounding rectangle of the base map.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Behavior | Gets or sets the interaction mode of the view. This is a dependency property.
Layers | Gets the list of layers displayed in this view.
MapHeight | Returns the height of the base map. Used for binding in the control's Xaml template.
MapWidth | Returns the width of the base map. Used for binding in the control's Xaml template.
ZoomFactor | Gets or sets the current zoom level.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseBounds Property

MapView.BaseBounds Property
[image]

Gets or sets the bounding rectangle of the base map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Rect BaseBounds { get; set; }

Visual Basic [image] Copy Code

Public Property BaseBounds As Rect

Property Value

A Rect instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseMap Property

MapView.BaseMap Property
[image]

Gets or sets the Map displayed in the first layer of this view.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Map BaseMap { get; set; }

Visual Basic [image] Copy Code

Public Property BaseMap As Map

Property Value

An instance of the Map class.

Remarks

Assigning a map to this property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map to the specified value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.Behavior Property

MapView.Behavior Property
[image]

Gets or sets the interaction mode of the view. This is a dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration. The default is Pan.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.Layers Property

MapView.Layers Property
[image]

Gets the list of layers displayed in this view.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerList Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As LayerList

Property Value

A LayerList instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapHeight Property

MapView.MapHeight Property
[image]

Returns the height of the base map. Used for binding in the control's Xaml template.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double MapHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MapHeight As Double

Property Value

A double value specifying the height of the base map.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapWidth Property

MapView.MapWidth Property
[image]

Returns the width of the base map. Used for binding in the control's Xaml template.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double MapWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MapWidth As Double

Property Value

A double value specifying the width of the base map.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ZoomFactor Property

MapView.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying the zoom level. The default value is 1.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
ScrollTo Method
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView Events

MapView Events
[image]

Public Events

Name | Description
LayerDatabaseLoaded | Raised when the control completes loading layer's database asynchronously.
LayerLoaded | Raised when the control completes loading layer's data asynchronously.
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.
ZoomLevelChanged | IZoomTarget.ZoomLevelChanged implementation.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayerDatabaseLoaded Event

MapView.LayerDatabaseLoaded Event
[image]

Raised when the control completes loading layer's database asynchronously.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerDatabaseLoaded

Visual Basic [image] Copy Code

Public Event LayerDatabaseLoaded As EventHandler(Of LayerEventArgs)

Event Data

LayerDatabaseLoaded event handlers receive an argument of type LayerEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayerLoaded Event

MapView.LayerLoaded Event
[image]

Raised when the control completes loading layer's data asynchronously.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerLoaded

Visual Basic [image] Copy Code

Public Event LayerLoaded As EventHandler(Of LayerEventArgs)

Event Data

LayerLoaded event handlers receive an argument of type LayerEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapElementClick Event

MapView.MapElementClick Event
[image]

Raised when the user clicks a map element.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementClick

Visual Basic [image] Copy Code

Public Event MapElementClick As EventHandler(Of MapEventArgs)

Event Data

MapElementClick event handlers receive an argument of type MapEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapElementHover Event

MapView.MapElementHover Event
[image]

Raised when the mouse rests over a map element.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementHover

Visual Basic [image] Copy Code

Public Event MapElementHover As EventHandler(Of MapEventArgs)

Event Data

MapElementHover event handlers receive an argument of type MapEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ZoomLevelChanged Event

MapView.ZoomLevelChanged Event
[image]

IZoomTarget.ZoomLevelChanged implementation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ZoomLevelChanged

Visual Basic [image] Copy Code

Public Event ZoomLevelChanged As EventHandler

Event Data

ZoomLevelChanged event handlers receive an argument of type EventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Class

Viewbox Class
[image]

Defines a decorator that can stretch and scale a single child to fill the available space.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class Viewbox : Decorator

Visual Basic [image] Copy Code

Public Class Viewbox
Inherits Decorator

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Decorator
MindFusion.Mapping.Wpf.Viewbox

See Also

Viewbox Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Members

Viewbox Members
Constructors Methods
[image]

Defines a decorator that can stretch and scale a single child to fill the available space.

The following tables list the members exposed by the Viewbox type.

Public Constructors

Name | Description
Viewbox | Initializes a new instance of the Viewbox class.

Protected Methods

Name | Description
ArrangeOverride | Decorator.ArrangeOverride override.
MeasureOverride | Decorator.MeasureOverride override.

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Constructor

Viewbox Constructor
[image]

Initializes a new instance of the Viewbox class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Viewbox ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Methods

Viewbox Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Decorator.ArrangeOverride override.
MeasureOverride | Decorator.MeasureOverride override.

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox.ArrangeOverride Method

Viewbox.ArrangeOverride Method
[image]

Decorator.ArrangeOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeSize As Size _
) As Size

Parameters

arrangeSize

The Size this element uses to arrange its child content.

Return Value

The Size that represents the arranged size of this element and its child.

See Also

Viewbox Members
Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox.MeasureOverride Method

Viewbox.MeasureOverride Method
[image]

Decorator.MeasureOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

An upper limit Size that should not be exceeded.

Return Value

The target Size of the element.

See Also

Viewbox Members
Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Class

VisibilityConverter Class
[image]

Converts boolean property values to Visibility values.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class VisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.VisibilityConverter

See Also

VisibilityConverter Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Members

VisibilityConverter Members
Constructors Methods
[image]

Converts boolean property values to Visibility values.

The following tables list the members exposed by the VisibilityConverter type.

Public Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class.

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Constructor

VisibilityConverter Constructor
[image]

Initializes a new instance of the VisibilityConverter class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public VisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Methods

VisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter.Convert Method

VisibilityConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter.ConvertBack Method

VisibilityConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Class

XamlPalette Class
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class XamlPalette : IPalette<Color>

Visual Basic [image] Copy Code

Public Class XamlPalette
Implements IPalette(Of Color)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.XamlPalette

See Also

XamlPalette Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Members

XamlPalette Members
Constructors Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the XamlPalette type.

Public Constructors

Name | Description
XamlPalette | Initializes a new instance of the XamlPalette class.

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Constructor

XamlPalette Constructor
[image]

Initializes a new instance of the XamlPalette class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public XamlPalette ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Properties

XamlPalette Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.FillColors Property

XamlPalette.FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As Color()

Property Value

An array of System.Windows.Media.Color objects.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.HighlightColor Property

XamlPalette.HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.LineColor Property

XamlPalette.LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color LineColor { get; set; }

Visual Basic [image] Copy Code

Public Property LineColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Class

XamlTransform Class
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class XamlTransform : ITransform

Visual Basic [image] Copy Code

Public Class XamlTransform
Implements ITransform

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.XamlTransform

See Also

XamlTransform Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Members

XamlTransform Members
Constructors Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the XamlTransform type.

Public Constructors

Name | Description
XamlTransform | Initializes a new instance of the XamlTransform class.

Public Methods

Name | Description
DeviceToWorld | Converts a point from screen to world coordinates.
WorldToDevice | Converts a point from world to screen coordinates.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Constructor

XamlTransform Constructor
[image]

Initializes a new instance of the XamlTransform class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public XamlTransform (
GeneralTransform transform
)

Visual Basic [image] Copy Code

Public New ( _
transform As GeneralTransform _
)

Parameters

transform

A GeneralTransform instance specifying an affine transformation.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Methods

XamlTransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Converts a point from screen to world coordinates.
WorldToDevice | Converts a point from world to screen coordinates.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform.DeviceToWorld Method

XamlTransform.DeviceToWorld Method
[image]

Converts a point from screen to world coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Public Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A System.Windows.Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

XamlTransform Members
XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform.WorldToDevice Method

XamlTransform.WorldToDevice Method
[image]

Converts a point from world to screen coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Public Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A System.Windows.Point containing the corresponding screen coordinates.

See Also

XamlTransform Members
XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Reporting.Wpf Namespace

MindFusion.Reporting.Wpf Namespace
Classes Interfaces Structures Enumerations

Classes

Class | Description
AxesChart | The base class for charts, which support the Cartesian coordinate system.
AxisSettings | Represents the settings of a chart axis.
BarChart | Renders a bound dataset as a bar chart.
Barcode | Represents a report item that that can render barcodes.
CanvasRenderTarget | An implementation of the IRenderTarget, which renders a report on a WPF Canvas.
Chart | The base class for all chart elements.
CustomReportItem | Represents a custom report item, which provides its own DataTemplate for visualization.
DataRange | Represents a report item that provides master-detail relation during data-binding.
DataRange.SectionDataSource | Represents the data context of the headers and footers in a DataRange.
ExpressionExtension | A XAML markup extension which allows the use of general MindFusion expression as values in XAML property initialization.
FixedDocumentRenderTarget | An implementation of the IRenderTarget which operates on a FixedDocument object.
GraphicsUnit | Specifies units of measure for a given data.
ImageRenderTarget | An implementation of the IRenderTarget, which renders a report to an image.
ItemContainer | Represents a special type of item container, which should be used as the root in the DataTemplate object specified by the ItemTemplate property of data ranges.
ItemWithChildren | Represents a report item, which can hold other report items.
ItemWithSections | Represents a report item, which provides header and footer.
Label | Represents a report element that can display text or data, which can be formatted as text.
LineChart | Renders a bound dataset as a line chart.
Page | Represents a page within a report.
PageBreak | Represents a single line across the whole width of a page, which indicates a page break at that location.
PageCollection | An observable collection of Page objects.
Picture | Represents a report element that displays an image.
PieChart | Renders a bound dataset as a pie chart.
PrerenderEventArgs | Provides data for the Prerender event of the Report class.
QueryDetailsEventArgs | Provides data for the QueryDetails event of the Report class.
Report | Represents a report, which can be previewed, printed or exported.
ReportItem | Represents an abstract base class for all report elements.
ReportItemCollection | An observable collection of ReportItem objects.
ReportLayout | Encapsulates the state of a laid out Report object.
ReportParameter | Represents a parameter in a report.
ReportPrinter | Provides convenience methods for printing Report objects.
SideBySideContainer | Represents a container that can hold side-by-side data ranges.

Interfaces

Interface | Description
IRenderTarget | Represents an object, which can be used as a target of a report rendering operation. An instance of this class is supplied to the RenderPage or RenderAllPages methodReportLayout class.
IRenderTargetWithPages(T) | Represents a render target, which exposes the rendered report pages as UIElement objects.

Structures

Structure | Description
Dimension | Stores an ordered pair of floating-point numbers, typically the width and height of an object.
Location | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Enumerations

Enumeration | Description
MeasureUnit | Specifies units of measure.
PageOrientation | Specifies the orientation of a printed page.
ReportParameterType | Specifies the type of a report parameter.


MindFusion.Reporting.Wpf.AxesChart Class

AxesChart Class
Remarks See Also
[image]

The base class for charts, which support the Cartesian coordinate system.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public abstract class AxesChart : Chart

Visual Basic [image] Copy Code

Public MustInherit Class AxesChart
Inherits Chart

Remarks

This class is inherited by the concrete BarChart and LineChart classes.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.AxesChart
MindFusion.Reporting.Wpf.BarChart
MindFusion.Reporting.Wpf.LineChart

See Also

AxesChart Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart Members

AxesChart Members
Constructors Fields Properties
[image]

The base class for charts, which support the Cartesian coordinate system.

The following tables list the members exposed by the AxesChart type.

Protected Constructors

Name | Description
AxesChart | Initializes a new instance of the AxesChart class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XDataProperty | Identifies the XData dependency property.
XIntervalProperty | Identifies the XInterval dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
XLabelTypeProperty | Identifies the XLabelType dependency property.
XMaxValueProperty | Identifies the XMaxValue dependency property.
XMinValueProperty | Identifies the XMinValue dependency property.
YDataProperty | Identifies the YData dependency property.
YIntervalProperty | Identifies the YInterval dependency property.
YLabelsProperty | Identifies the YLabels dependency property.
YLabelTypeProperty | Identifies the YLabelType dependency property.
YMaxValueProperty | Identifies the YMaxValue dependency property.
YMinValueProperty | Identifies the YMinValue dependency property.

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property.
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property.
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property.
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property.
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property.
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property.
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property.
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property.
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property.
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property.
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property.
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property.

See Also

AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart Fields

AxesChart Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XDataProperty | Identifies the XData dependency property.
XIntervalProperty | Identifies the XInterval dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
XLabelTypeProperty | Identifies the XLabelType dependency property.
XMaxValueProperty | Identifies the XMaxValue dependency property.
XMinValueProperty | Identifies the XMinValue dependency property.
YDataProperty | Identifies the YData dependency property.
YIntervalProperty | Identifies the YInterval dependency property.
YLabelsProperty | Identifies the YLabels dependency property.
YLabelTypeProperty | Identifies the YLabelType dependency property.
YMaxValueProperty | Identifies the YMaxValue dependency property.
YMinValueProperty | Identifies the YMinValue dependency property.

See Also

AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XDataProperty Field

AxesChart.XDataProperty Field
[image]

Identifies the XData dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XDataProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XIntervalProperty Field

AxesChart.XIntervalProperty Field
[image]

Identifies the XInterval dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XIntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XIntervalProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XLabelsProperty Field

AxesChart.XLabelsProperty Field
[image]

Identifies the XLabels dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XLabelTypeProperty Field

AxesChart.XLabelTypeProperty Field
[image]

Identifies the XLabelType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XMaxValueProperty Field

AxesChart.XMaxValueProperty Field
[image]

Identifies the XMaxValue dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XMaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XMaxValueProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XMinValueProperty Field

AxesChart.XMinValueProperty Field
[image]

Identifies the XMinValue dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XMinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XMinValueProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YDataProperty Field

AxesChart.YDataProperty Field
[image]

Identifies the YData dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YDataProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YIntervalProperty Field

AxesChart.YIntervalProperty Field
[image]

Identifies the YInterval dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YIntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YIntervalProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YLabelsProperty Field

AxesChart.YLabelsProperty Field
[image]

Identifies the YLabels dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YLabelTypeProperty Field

AxesChart.YLabelTypeProperty Field
[image]

Identifies the YLabelType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YMaxValueProperty Field

AxesChart.YMaxValueProperty Field
[image]

Identifies the YMaxValue dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YMaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YMaxValueProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YMinValueProperty Field

AxesChart.YMinValueProperty Field
[image]

Identifies the YMinValue dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YMinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YMinValueProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart Constructor

AxesChart Constructor
[image]

Initializes a new instance of the AxesChart class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected AxesChart ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart Properties

AxesChart Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property.
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property.
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property.
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property.
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property.
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property.
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property.
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property.
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property.
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property.
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property.
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property.

See Also

AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XData Property

AxesChart.XData Property
[image]

Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As String

Property Value

A string representing the name of the property to bind the x-axis values to, or an empty string to specify that the x-axis values should be sequential. The default is an empty string.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XInterval Property

AxesChart.XInterval Property
[image]

Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double XInterval { get; set; }

Visual Basic [image] Copy Code

Public Property XInterval As Double

Property Value

A double value specifying the interval between adjacent ticks on the x-axis. The default is 1.

Remarks

Set this property to double.NaN to calculate this interval automatically.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XLabels Property

AxesChart.XLabels Property
[image]

Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string XLabels { get; set; }

Visual Basic [image] Copy Code

Public Property XLabels As String

Property Value

A string representing the name of the property to bind the x-axis labels to, or an empty string to specify that the x-axis labels should be calculated. The default is an empty string.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XLabelType Property

AxesChart.XLabelType Property
[image]

Gets or sets the type of the labels on the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LabelType XLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property XLabelType As LabelType

Property Value

A member of the LabelType enumeration.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XMaxValue Property

AxesChart.XMaxValue Property
[image]

Gets or sets the maximum value at the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> XMaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property XMaxValue As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.XMinValue Property

AxesChart.XMinValue Property
[image]

Gets or sets the minimum value at the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> XMinValue { get; set; }

Visual Basic [image] Copy Code

Public Property XMinValue As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YData Property

AxesChart.YData Property
[image]

Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As String

Property Value

A string representing the name of the property to bind the y-axis values to, or an empty string to specify that the y-axis values should be sequential.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YInterval Property

AxesChart.YInterval Property
[image]

Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double YInterval { get; set; }

Visual Basic [image] Copy Code

Public Property YInterval As Double

Property Value

A double value specifying the interval between adjacent ticks on the x-axis. The default is NaN.

Remarks

Set this property to double.NaN to calculate this interval automatically.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YLabels Property

AxesChart.YLabels Property
[image]

Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string YLabels { get; set; }

Visual Basic [image] Copy Code

Public Property YLabels As String

Property Value

A string representing the name of the property to bind the y-axis labels to, or an empty string to specify that the y-axis labels should be calculated. The default is an empty string.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YLabelType Property

AxesChart.YLabelType Property
[image]

Gets or sets the type of the labels on the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LabelType YLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property YLabelType As LabelType

Property Value

A member of the LabelType enumeration.

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YMaxValue Property

AxesChart.YMaxValue Property
[image]

Gets or sets the maximum value at the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> YMaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property YMaxValue As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxesChart.YMinValue Property

AxesChart.YMinValue Property
[image]

Gets or sets the minimum value at the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> YMinValue { get; set; }

Visual Basic [image] Copy Code

Public Property YMinValue As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

AxesChart Members
AxesChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings Class

AxisSettings Class
[image]

Represents the settings of a chart axis.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class AxisSettings : DependencyObject

Visual Basic [image] Copy Code

Public Class AxisSettings
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Reporting.Wpf.AxisSettings

See Also

AxisSettings Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings Members

AxisSettings Members
Constructors Fields Properties
[image]

Represents the settings of a chart axis.

The following tables list the members exposed by the AxisSettings type.

Public Constructors

Name | Description
AxisSettings | Initializes a new instance of the AxisSettings class.

Public Fields

Name | Description
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
HorizontalLabelAlignmentProperty | Identifies the HorizontalLabelAlignment dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.
VerticalLabelAlignmentProperty | Identifies the VerticalLabelAlignment dependency property.

Public Properties

Name | Description
CustomLabelPosition | Gets or sets the position of custom labels. This is a dependency property.
HorizontalLabelAlignment | Gets or sets the horizontal alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.
LabelFormat | Gets or sets the format of the labels. This is a dependency property.
LabelOffset | Gets or sets the offset of the label from the axis. This is a dependency property.
Stroke | Gets or sets the brush for drawing the axis. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for this axis. This is a dependency property.
Tick | Gets or sets the length of tick marks. This is a dependency property.
ValueFormat | Gets or sets the format of data related to this axis. This is a dependency property.
VerticalLabelAlignment | Gets or sets the vertical alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.

See Also

AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings Fields

AxisSettings Fields
[image]

Public Fields

Name | Description
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
HorizontalLabelAlignmentProperty | Identifies the HorizontalLabelAlignment dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.
VerticalLabelAlignmentProperty | Identifies the VerticalLabelAlignment dependency property.

See Also

AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.CustomLabelPositionProperty Field

AxisSettings.CustomLabelPositionProperty Field
[image]

Identifies the CustomLabelPosition dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomLabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomLabelPositionProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.HorizontalLabelAlignmentProperty Field

AxisSettings.HorizontalLabelAlignmentProperty Field
[image]

Identifies the HorizontalLabelAlignment dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalLabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalLabelAlignmentProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.LabelFormatProperty Field

AxisSettings.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.LabelOffsetProperty Field

AxisSettings.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.StrokeProperty Field

AxisSettings.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.StrokeThicknessProperty Field

AxisSettings.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.TickProperty Field

AxisSettings.TickProperty Field
[image]

Identifies the Tick dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.ValueFormatProperty Field

AxisSettings.ValueFormatProperty Field
[image]

Identifies the ValueFormat dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueFormatProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.VerticalLabelAlignmentProperty Field

AxisSettings.VerticalLabelAlignmentProperty Field
[image]

Identifies the VerticalLabelAlignment dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalLabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalLabelAlignmentProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings Constructor

AxisSettings Constructor
[image]

Initializes a new instance of the AxisSettings class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public AxisSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings Properties

AxisSettings Properties
[image]

Public Properties

Name | Description
CustomLabelPosition | Gets or sets the position of custom labels. This is a dependency property.
HorizontalLabelAlignment | Gets or sets the horizontal alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.
LabelFormat | Gets or sets the format of the labels. This is a dependency property.
LabelOffset | Gets or sets the offset of the label from the axis. This is a dependency property.
Stroke | Gets or sets the brush for drawing the axis. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the stroke for this axis. This is a dependency property.
Tick | Gets or sets the length of tick marks. This is a dependency property.
ValueFormat | Gets or sets the format of data related to this axis. This is a dependency property.
VerticalLabelAlignment | Gets or sets the vertical alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.

See Also

AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.CustomLabelPosition Property

AxisSettings.CustomLabelPosition Property
[image]

Gets or sets the position of custom labels. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public CustomLabelPosition CustomLabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLabelPosition As CustomLabelPosition

Property Value

A member of the CustomLabelPosition enumeration. The default is ChartDataPoints.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.HorizontalLabelAlignment Property

AxisSettings.HorizontalLabelAlignment Property
[image]

Gets or sets the horizontal alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<HorizontalAlignment> HorizontalLabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalLabelAlignment As Nullable(Of HorizontalAlignment)

Property Value

A member of the HorizontalAlignment property or null (Nothing in Visual Basic). The default is null.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.LabelFormat Property

AxisSettings.LabelFormat Property
[image]

Gets or sets the format of the labels. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

A string value. The default is "F2".

Remarks

The property accepts as values any standard .NET formatting strings for numbers (C, D, E, F, G, N, P, R or X). If the ValueFormat is ValueFormat.DateTime, the LabelFormat should be a valid DateTime format string (d, D, f, F, g, G, M, m etc.).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.LabelOffset Property

AxisSettings.LabelOffset Property
[image]

Gets or sets the offset of the label from the axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. The default is 5.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.Stroke Property

AxisSettings.Stroke Property
[image]

Gets or sets the brush for drawing the axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.StrokeThickness Property

AxisSettings.StrokeThickness Property
[image]

Gets or sets the thickness of the stroke for this axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. The default is 1.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.Tick Property

AxisSettings.Tick Property
[image]

Gets or sets the length of tick marks. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Tick { get; set; }

Visual Basic [image] Copy Code

Public Property Tick As Double

Property Value

A double value. The default is 0.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.ValueFormat Property

AxisSettings.ValueFormat Property
[image]

Gets or sets the format of data related to this axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ValueFormat ValueFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ValueFormat As ValueFormat

Property Value

A member of the ValueFormat enumeration. The default is Number.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.AxisSettings.VerticalLabelAlignment Property

AxisSettings.VerticalLabelAlignment Property
[image]

Gets or sets the vertical alignment of axis labels, or null (Nothing in Visual Basic), to use the default alignment. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<VerticalAlignment> VerticalLabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalLabelAlignment As Nullable(Of VerticalAlignment)

Property Value

A member of the HorizontalAlignment property or null (Nothing in Visual Basic). The default is null.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart Class

BarChart Class
[image]

Renders a bound dataset as a bar chart.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class BarChart : AxesChart

Visual Basic [image] Copy Code

Public Class BarChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.AxesChart
MindFusion.Reporting.Wpf.BarChart

See Also

BarChart Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart Members

BarChart Members
Constructors Fields Properties
[image]

Renders a bound dataset as a bar chart.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Initializes a new instance of the BarChart class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BarTypeProperty | Identifies the BarType dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TopLabelsProperty | Identifies the TopLabels dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesChart.)
XIntervalProperty | Identifies the XInterval dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
XLabelTypeProperty | Identifies the XLabelType dependency property. (Inherited from AxesChart.)
XMaxValueProperty | Identifies the XMaxValue dependency property. (Inherited from AxesChart.)
XMinValueProperty | Identifies the XMinValue dependency property. (Inherited from AxesChart.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesChart.)
YIntervalProperty | Identifies the YInterval dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)
YLabelTypeProperty | Identifies the YLabelType dependency property. (Inherited from AxesChart.)
YMaxValueProperty | Identifies the YMaxValue dependency property. (Inherited from AxesChart.)
YMinValueProperty | Identifies the YMinValue dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BarType | Gets or sets the type of the bar chart. This is a dependency property.
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
TopLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels at the top of the bars. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart Fields

BarChart Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BarTypeProperty | Identifies the BarType dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TopLabelsProperty | Identifies the TopLabels dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesChart.)
XIntervalProperty | Identifies the XInterval dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
XLabelTypeProperty | Identifies the XLabelType dependency property. (Inherited from AxesChart.)
XMaxValueProperty | Identifies the XMaxValue dependency property. (Inherited from AxesChart.)
XMinValueProperty | Identifies the XMinValue dependency property. (Inherited from AxesChart.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesChart.)
YIntervalProperty | Identifies the YInterval dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)
YLabelTypeProperty | Identifies the YLabelType dependency property. (Inherited from AxesChart.)
YMaxValueProperty | Identifies the YMaxValue dependency property. (Inherited from AxesChart.)
YMinValueProperty | Identifies the YMinValue dependency property. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart.BarTypeProperty Field

BarChart.BarTypeProperty Field
[image]

Identifies the BarType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarTypeProperty As DependencyProperty

See Also

BarChart Members
BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart.TopLabelsProperty Field

BarChart.TopLabelsProperty Field
[image]

Identifies the TopLabels dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelsProperty As DependencyProperty

See Also

BarChart Members
BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart Constructor

BarChart Constructor
[image]

Initializes a new instance of the BarChart class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public BarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart Properties

BarChart Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BarType | Gets or sets the type of the bar chart. This is a dependency property.
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
TopLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels at the top of the bars. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)

See Also

BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart.BarType Property

BarChart.BarType Property
[image]

Gets or sets the type of the bar chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public BarType BarType { get; set; }

Visual Basic [image] Copy Code

Public Property BarType As BarType

Property Value

A member of the BarType enumeration. The default is Vertical.

See Also

BarChart Members
BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.BarChart.TopLabels Property

BarChart.TopLabels Property
[image]

Gets or sets the name of the property or member of the bound object, that will supply the labels at the top of the bars. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string TopLabels { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabels As String

Property Value

A string representing the name of the property to bind the top labels to. The default is an empty string.

See Also

BarChart Members
BarChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode Class

Barcode Class
[image]

Represents a report item that that can render barcodes.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class Barcode : ReportItem

Visual Basic [image] Copy Code

Public Class Barcode
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Barcode

See Also

Barcode Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode Members

Barcode Members
Constructors Fields Properties
[image]

Represents a report item that that can render barcodes.

The following tables list the members exposed by the Barcode type.

Public Constructors

Name | Description
Barcode | Initializes a new instance of the Barcode class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ContentProperty | Identifies the Content dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
FormatProperty | Identifies the Format dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
FontFamily | Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.
Foreground | Gets or sets the brush used to paint the barcode modules.
Format | Gets or sets the barcode format.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode Fields

Barcode Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ContentProperty | Identifies the Content dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
FormatProperty | Identifies the Format dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
QRCorrectionLevelProperty | Identifies the QRCorrectionLevel dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.ContentProperty Field

Barcode.ContentProperty Field
[image]

Identifies the Content dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.ForegroundProperty Field

Barcode.ForegroundProperty Field
[image]

Identifies the Foreground dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ForegroundProperty As DependencyProperty

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.FormatProperty Field

Barcode.FormatProperty Field
[image]

Identifies the Format dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.QRCorrectionLevelProperty Field

Barcode.QRCorrectionLevelProperty Field
[image]

Identifies the QRCorrectionLevel dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty QRCorrectionLevelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly QRCorrectionLevelProperty As DependencyProperty

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode Constructor

Barcode Constructor
[image]

Initializes a new instance of the Barcode class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Barcode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode Properties

Barcode Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Content | Gets or sets the text or numeric code that should be represented as barcode symbol.
FontFamily | Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.
Foreground | Gets or sets the brush used to paint the barcode modules.
Format | Gets or sets the barcode format.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
QRCorrectionLevel | Gets or sets the correction level of QR barcodes.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.Content Property

Barcode.Content Property
[image]

Gets or sets the text or numeric code that should be represented as barcode symbol.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As String

Property Value

A string representing the barcode content.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.FontFamily Property

Barcode.FontFamily Property
[image]

Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

An instance of the WPF FontFamily class.

Remarks

This is a convenience property for getting and setting the Report.FontFamily attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.FontSize Property

Barcode.FontSize Property
[image]

Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value.

Remarks

This is a convenience property for getting and setting the Report.FontSize attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.FontStyle Property

Barcode.FontStyle Property
[image]

Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure.

Remarks

This is a convenience property for getting and setting the Report.FontStyle attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.FontWeight Property

Barcode.FontWeight Property
[image]

Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure.

Remarks

This is a convenience property for getting and setting the Report.FontWeight attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.Foreground Property

Barcode.Foreground Property
[image]

Gets or sets the brush used to paint the barcode modules.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }

Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

An instance of the WPF Brush class.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.Format Property

Barcode.Format Property
[image]

Gets or sets the barcode format.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public BarcodeFormat Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As BarcodeFormat

Property Value

A member of the BarcodeFormat enumeration.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Barcode.QRCorrectionLevel Property

Barcode.QRCorrectionLevel Property
[image]

Gets or sets the correction level of QR barcodes.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public CorrectionLevel QRCorrectionLevel { get; set; }

Visual Basic [image] Copy Code

Public Property QRCorrectionLevel As CorrectionLevel

Property Value

A member of the CorrectionLevel enumeration.

See Also

Barcode Members
Barcode Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget Class

CanvasRenderTarget Class
[image]

An implementation of the IRenderTarget, which renders a report on a WPF Canvas.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class CanvasRenderTarget : IRenderTarget

Visual Basic [image] Copy Code

Public Class CanvasRenderTarget
Implements IRenderTarget

Example

The following code illustrates how to use this class. The code assumes that report is a variable identifying existing Report, which has been already run.

C# [image] Copy Code

ReportLayout layout = report.Layout(new Size(8.5 * 96, 11 * 96),
new Thickness(0.5 * 96), PageOrientation.Portrait);

CanvasRenderTarget renderTarget = new CanvasRenderTarget(ReportPreview);
renderTarget.PageBorderBrush = new SolidColorBrush(Colors.Black);
layout.RenderAllPages(renderTarget);

Visual Basic [image] Copy Code

Dim layout = report.Layout(New Size(8.5 * 96, 11 * 96), _
New Thickness(0.5 * 96), PageOrientation.Portrait)

Dim renderTarget = New CanvasRenderTarget(ReportPreview)
renderTarget.PageBorderBrush = New SolidColorBrush(Colors.Black)
layout.RenderAllPages(renderTarget)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.CanvasRenderTarget

See Also

CanvasRenderTarget Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget Members

CanvasRenderTarget Members
Constructors Properties
[image]

An implementation of the IRenderTarget, which renders a report on a WPF Canvas.

The following tables list the members exposed by the CanvasRenderTarget type.

Public Constructors

Name | Description
CanvasRenderTarget | Initializes a new instance of the CanvasRenderTarget class.

Public Properties

Name | Description
PageBackground | Gets or sets the background of individual pages.
PageBorderBrush | Gets or sets the border of individual pages.

See Also

CanvasRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget Constructor

CanvasRenderTarget Constructor
[image]

Initializes a new instance of the CanvasRenderTarget class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public CanvasRenderTarget (
Canvas target
)

Visual Basic [image] Copy Code

Public New ( _
target As Canvas _
)

Parameters

target

The target of the rendering operation.

See Also

CanvasRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget Properties

CanvasRenderTarget Properties
[image]

Public Properties

Name | Description
PageBackground | Gets or sets the background of individual pages.
PageBorderBrush | Gets or sets the border of individual pages.

See Also

CanvasRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget.PageBackground Property

CanvasRenderTarget.PageBackground Property
[image]

Gets or sets the background of individual pages.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PageBackground { get; set; }

Visual Basic [image] Copy Code

Public Property PageBackground As Brush

Property Value

A WPF Brush object.

See Also

CanvasRenderTarget Members
CanvasRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CanvasRenderTarget.PageBorderBrush Property

CanvasRenderTarget.PageBorderBrush Property
[image]

Gets or sets the border of individual pages.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PageBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PageBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

CanvasRenderTarget Members
CanvasRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart Class

Chart Class
[image]

The base class for all chart elements.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public abstract class Chart : ReportItem

Visual Basic [image] Copy Code

Public MustInherit Class Chart
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.AxesChart
MindFusion.Reporting.Wpf.PieChart

See Also

Chart Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart Members

Chart Members
Constructors Fields Properties
[image]

The base class for all chart elements.

The following tables list the members exposed by the Chart type.

Protected Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property.
ChartBrushProperty | Identifies the ChartBrush dependency property.
ChartStrokeProperty | Identifies the ChartStroke dependency property.
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property.
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property.
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property.
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property.
DataSource | Gets or sets the data source of this chart. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart Fields

Chart Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property.
ChartBrushProperty | Identifies the ChartBrush dependency property.
ChartStrokeProperty | Identifies the ChartStroke dependency property.
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.BrushesProperty Field

Chart.BrushesProperty Field
[image]

Identifies the Brushes dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushesProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartBrushProperty Field

Chart.ChartBrushProperty Field
[image]

Identifies the ChartBrush dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartBrushProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartStrokeProperty Field

Chart.ChartStrokeProperty Field
[image]

Identifies the ChartStroke dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartStrokeProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartStrokeThicknessProperty Field

Chart.ChartStrokeThicknessProperty Field
[image]

Identifies the ChartStrokeThickness dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartStrokeThicknessProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.DataSourceProperty Field

Chart.DataSourceProperty Field
[image]

Identifies the DataSource dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataSourceProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.LabelBackgroundProperty Field

Chart.LabelBackgroundProperty Field
[image]

Identifies the LabelBackground dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBackgroundProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart Constructor

Chart Constructor
[image]

Initializes a new instance of the Chart class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected Chart ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart Properties

Chart Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property.
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property.
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property.
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property.
DataSource | Gets or sets the data source of this chart. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.Brushes Property

Chart.Brushes Property
[image]

Gets or sets the brushes used to fill the chart elements. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IList<Brush> Brushes { get; set; }

Visual Basic [image] Copy Code

Public Property Brushes As IList(Of Brush)

Property Value

A list of WPF Brush objects specifying the fill of the individual elements in the chart.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartBrush Property

Chart.ChartBrush Property
[image]

Gets or sets the default brush used to fill individual chart pieces. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush ChartBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ChartBrush As Brush

Property Value

A WPF Brush specifying the default fill of the elements in the chart. The default is a solid white brush.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartStroke Property

Chart.ChartStroke Property
[image]

Gets or sets the brush used to stroke individual chart pieces. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush ChartStroke { get; set; }

Visual Basic [image] Copy Code

Public Property ChartStroke As Brush

Property Value

A WPF Brush specifying the default stroke of the elements in the chart. The default is a solid black brush.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.ChartStrokeThickness Property

Chart.ChartStrokeThickness Property
[image]

Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double ChartStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ChartStrokeThickness As Double

Property Value

A double value specifying the thickness of the stroke of the individual chart elements. The default is 0.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.DataSource Property

Chart.DataSource Property
[image]

Gets or sets the data source of this chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As IEnumerable

Property Value

An IEnumerable specifying the data for the chart.

Remarks

If DataSource is null (Nothing in Visual Basic) the data for the chart is acquired through the Report.QueryDetails event using the current DataContext as a master row.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Chart.LabelBackground Property

Chart.LabelBackground Property
[image]

Gets or sets the brush for the background of the chart's labels. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBackground As Brush

Property Value

A WPF Brush object specifying the background of the chart labels. The default is a semitransparent solid white brush.

See Also

Chart Members
Chart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem Class

CustomReportItem Class
Remarks See Also
[image]

Represents a custom report item, which provides its own DataTemplate for visualization.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class CustomReportItem : ReportItem

Visual Basic [image] Copy Code

Public Class CustomReportItem
Inherits ReportItem

Remarks

The CustomReportItem can be used to embed arbitrary WPF elements in a report. The visual tree of the item is specified through a DataTemplate assigned to its Template property. The data content of the item is specified through its Value property. During rendering the CustomReportItem internally creates a WPF ContentControl and assigns Value and Template to its Content and ContentTemplate properties respectively.

Example

CustomReportItem which displays a WPF TextBlock with a Border around it. The width of the border is proportional to an IntField property of the associated DataContext.

XAML [image] Copy Code

<r:CustomReportItem Size="100%,20">
<r:CustomReportItem.Template>
<DataTemplate>
<Border Name="border"
Width="{r:Expression '[CDbl(IntField*10)]'}"
Background="Red"
BorderBrush="Black"
BorderThickness="1"
VerticalAlignment="Center"
HorizontalAlignment="Left"
Height="15">
<TextBlock Text="{r:Expression '[CStr(IntField)]'}" />
</Border>
</DataTemplate>
</r:CustomReportItem.Template>
</r:CustomReportItem>

In the above example the item is considered part of a report named report and the namespace r is defined as follows:

XAML [image] Copy Code

xmlns:r="http://mindfusion.eu/reporting/wpf"

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.CustomReportItem

See Also

CustomReportItem Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem Members

CustomReportItem Members
Constructors Fields Properties
[image]

Represents a custom report item, which provides its own DataTemplate for visualization.

The following tables list the members exposed by the CustomReportItem type.

Public Constructors

Name | Description
CustomReportItem | Initializes a new instance of the CustomReportItem class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TemplateProperty | Identifies the Template dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
Template | Gets or sets the DataTemplate, which should be used to define the visual appearance of this report item. This template can contain any WPF elements. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
Value | Gets or sets a value associated with this report item. This is a dependency property.

See Also

CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem Fields

CustomReportItem Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TemplateProperty | Identifies the Template dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
ValueProperty | Identifies the Value dependency property.

See Also

CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem.TemplateProperty Field

CustomReportItem.TemplateProperty Field
[image]

Identifies the Template dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TemplateProperty As DependencyProperty

See Also

CustomReportItem Members
CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem.ValueProperty Field

CustomReportItem.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

CustomReportItem Members
CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem Constructor

CustomReportItem Constructor
[image]

Initializes a new instance of the CustomReportItem class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public CustomReportItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem Properties

CustomReportItem Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
Template | Gets or sets the DataTemplate, which should be used to define the visual appearance of this report item. This template can contain any WPF elements. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
Value | Gets or sets a value associated with this report item. This is a dependency property.

See Also

CustomReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.CustomReportItem.Template Property

CustomReportItem.Template Property
[image]

Gets or sets the DataTemplate, which should be used to define the visual appearance of this report item. This template can contain any WPF elements. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public DataTemplate Template { get; set; }

Visual Basic [image] Copy Code

Public Property Template As DataTemplate

Property Value

A .NET DataTemplate object.

Remarks

When a CustomReportItem is rendered, it creates a WPF ContentControl and assigns its own Value and Template properties to the control's Content and ContentTemplate properties respectively.

See Also

CustomReportItem Members
CustomReportItem Class
MindFusion.Reporting.Wpf Namespace
Value Property


MindFusion.Reporting.Wpf.CustomReportItem.Value Property

CustomReportItem.Value Property
[image]

Gets or sets a value associated with this report item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Object Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Object

Property Value

An object specifying the content of the CustomReportItem.

Remarks

When a CustomReportItem is rendered, it creates a WPF ContentControl and assigns its own Value and Template properties to the control's Content and ContentTemplate properties respectively.

See Also

CustomReportItem Members
CustomReportItem Class
MindFusion.Reporting.Wpf Namespace
Template Property


MindFusion.Reporting.Wpf.DataRange Class

DataRange Class
Remarks See Also
[image]

Represents a report item that provides master-detail relation during data-binding.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class DataRange : ItemWithSections

Visual Basic [image] Copy Code

Public Class DataRange
Inherits ItemWithSections

Remarks

The DataRange element is a report item, which can hold other report items and can also provide header and footer. The data source of the DataRange is specified by the DataSource property. If DataSource is null (Nothing in Visual Basic) the DataRange raises the QueryDetails event of its containing report passing its DataContext as a master row and uses the return IEnumeration as data source. If QueryDetails did not yield any details, the DataContext is used as a data source.

The DataRange performs special processing to its content when the report is run. For each object in its data source, the DataRange creates a new instance of the contents specified by its ItemTemplate property and sets the data source object as DataContext of this instance. The root object in the DataTemplate associated with the ItemTemplate property needs to be an ItemContainer object.

The following example demonstrates a sample DataRange object declared in XAML:

XAML [image] Copy Code

<r:DataRange DataSource="{Binding Categories}" Size="200,20">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Text="{Binding CategoryName}" Size="100%,20" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemWithSections
MindFusion.Reporting.Wpf.DataRange
MindFusion.Reporting.Wpf.SideBySideContainer

See Also

DataRange Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange Members

DataRange Members
Constructors Fields Properties Methods
[image]

Represents a report item that provides master-detail relation during data-binding.

The following tables list the members exposed by the DataRange type.

Public Constructors

Name | Description
DataRange | Initializes a new instance of the DataRange class.

Public Fields

Name | Description
AlternatingBackgroundProperty | Identifies the AlternatingBackground dependency property.
AlternatingBorderBrushProperty | Identifies the AlternatingBorderBrush dependency property.
AlternatingBorderThicknessProperty | Identifies the AlternatingBorderThickness dependency property.
ArrangeByXProperty | Identifies the ArrangeByX dependency property.
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
CollideOnRunProperty | Identifies the CollideOnRun dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. (Inherited from ItemWithSections.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from ItemWithSections.)
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
RepeatProperty | Identifies the Repeat dependency property.
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range. This is a dependency property.
AlternatingBorderBrush | Gets or sets the brush that will be used to fill the border of the alternating instances of this data range. This is a dependency property.
AlternatingBorderThickness | Gets or sets the border thickness of the alternating instances of this data range. This is a dependency property.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first. This is a dependency property.
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
CollideOnRun | Gets or sets a value indicating whether this data range, when processed, would automatically adjust the position of the other items in the report. This is a dependency property.
DataSource | Gets or sets the data source of this DataRange. This is a dependency property.
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property. (Inherited from ItemWithSections.)
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property. (Inherited from ItemWithSections.)
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
ItemTemplate | Gets or sets the DataTemplate to use when generating the visualization of data range items. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range. This is a dependency property.
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange Fields

DataRange Fields
[image]

Public Fields

Name | Description
AlternatingBackgroundProperty | Identifies the AlternatingBackground dependency property.
AlternatingBorderBrushProperty | Identifies the AlternatingBorderBrush dependency property.
AlternatingBorderThicknessProperty | Identifies the AlternatingBorderThickness dependency property.
ArrangeByXProperty | Identifies the ArrangeByX dependency property.
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
CollideOnRunProperty | Identifies the CollideOnRun dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
FooterTemplateProperty | Identifies the FooterTemplate dependency property. (Inherited from ItemWithSections.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from ItemWithSections.)
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
RepeatProperty | Identifies the Repeat dependency property.
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.AlternatingBackgroundProperty Field

DataRange.AlternatingBackgroundProperty Field
[image]

Identifies the AlternatingBackground dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingBackgroundProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.AlternatingBorderBrushProperty Field

DataRange.AlternatingBorderBrushProperty Field
[image]

Identifies the AlternatingBorderBrush dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingBorderBrushProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.AlternatingBorderThicknessProperty Field

DataRange.AlternatingBorderThicknessProperty Field
[image]

Identifies the AlternatingBorderThickness dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlternatingBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlternatingBorderThicknessProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.ArrangeByXProperty Field

DataRange.ArrangeByXProperty Field
[image]

Identifies the ArrangeByX dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ArrangeByXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ArrangeByXProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.CollideOnRunProperty Field

DataRange.CollideOnRunProperty Field
[image]

Identifies the CollideOnRun dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CollideOnRunProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CollideOnRunProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.DataSourceProperty Field

DataRange.DataSourceProperty Field
[image]

Identifies the DataSource dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataSourceProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.ItemTemplateProperty Field

DataRange.ItemTemplateProperty Field
[image]

Identifies the ItemTemplate dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.RepeatProperty Field

DataRange.RepeatProperty Field
[image]

Identifies the Repeat dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RepeatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RepeatProperty As DependencyProperty

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange Constructor

DataRange Constructor
[image]

Initializes a new instance of the DataRange class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public DataRange ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange Methods

DataRange Methods
[image]

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.ShouldSerializeItems Method

DataRange.ShouldSerializeItems Method
[image]

This method is for internal use only.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override bool ShouldSerializeItems ()

Visual Basic [image] Copy Code

Public Overrides Function ShouldSerializeItems () As Boolean

Return Value

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange Properties

DataRange Properties
[image]

Public Properties

Name | Description
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range. This is a dependency property.
AlternatingBorderBrush | Gets or sets the brush that will be used to fill the border of the alternating instances of this data range. This is a dependency property.
AlternatingBorderThickness | Gets or sets the border thickness of the alternating instances of this data range. This is a dependency property.
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first. This is a dependency property.
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
CollideOnRun | Gets or sets a value indicating whether this data range, when processed, would automatically adjust the position of the other items in the report. This is a dependency property.
DataSource | Gets or sets the data source of this DataRange. This is a dependency property.
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property. (Inherited from ItemWithSections.)
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property. (Inherited from ItemWithSections.)
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
ItemTemplate | Gets or sets the DataTemplate to use when generating the visualization of data range items. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range. This is a dependency property.
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

See Also

DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.AlternatingBackground Property

DataRange.AlternatingBackground Property
[image]

Gets or sets the brush that will be used to fill the background of the alternating instances of this data range. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush AlternatingBackground { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingBackground As Brush

Property Value

An instance of the WPF Brush class.

Remarks

The default background for data range instances is specified by Background.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace
AlternatingBorderBrush Property
AlternatingBorderThickness Property
Background Property


MindFusion.Reporting.Wpf.DataRange.AlternatingBorderBrush Property

DataRange.AlternatingBorderBrush Property
[image]

Gets or sets the brush that will be used to fill the border of the alternating instances of this data range. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush AlternatingBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingBorderBrush As Brush

Property Value

An instance of the WPF Brush class.

Remarks

The default border brush for data range instances is specified by BorderBrush.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace
AlternatingBackground Property
AlternatingBorderThickness Property
BorderBrush Property


MindFusion.Reporting.Wpf.DataRange.AlternatingBorderThickness Property

DataRange.AlternatingBorderThickness Property
[image]

Gets or sets the border thickness of the alternating instances of this data range. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness AlternatingBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property AlternatingBorderThickness As Thickness

Property Value

An instance of the WPF BorderThickness class.

Remarks

The default border thickness for data range instances is specified by BorderThickness.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace
AlternatingBackground Property
AlternatingBorderBrush Property
BorderThickness Property


MindFusion.Reporting.Wpf.DataRange.ArrangeByX Property

DataRange.ArrangeByX Property
[image]

Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool ArrangeByX { get; set; }

Visual Basic [image] Copy Code

Public Property ArrangeByX As Boolean

Property Value

A boolean value. The default is false.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.CollideOnRun Property

DataRange.CollideOnRun Property
[image]

Gets or sets a value indicating whether this data range, when processed, would automatically adjust the position of the other items in the report. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool CollideOnRun { get; set; }

Visual Basic [image] Copy Code

Public Property CollideOnRun As Boolean

Property Value

true to enable; otherwise, false.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.DataSource Property

DataRange.DataSource Property
[image]

Gets or sets the data source of this DataRange. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As IEnumerable

Property Value

An IEnumerable object.

Remarks

If DataSource is null (Nothing in Visual Basic) the data for the data range is acquired through the Report.QueryDetails event using the current DataContext as a master row.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.ItemTemplate Property

DataRange.ItemTemplate Property
[image]

Gets or sets the DataTemplate to use when generating the visualization of data range items. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ItemTemplate As DataTemplate

Property Value

A DataTemplate object.

Remarks

When a data range is being processed this template is used to create the visualization of individual data range instances.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.Repeat Property

DataRange.Repeat Property
[image]

Gets or sets the number of occurrences of this data range. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As Integer

Property Value

An integer value.

Remarks

This value is only valid for disconnected data ranges, that is, data ranges with no data source specified. The number of occurrences of data-bound data ranges depends on the data they are bound to.

This property is useful if you want to print out a fixed number of static content, such as visiting cards or invitations.

See Also

DataRange Members
DataRange Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource Class

DataRange.SectionDataSource Class
[image]

Represents the data context of the headers and footers in a DataRange.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class DataRange.SectionDataSource : IEnumerable

Visual Basic [image] Copy Code

Public Class DataRange.SectionDataSource
Implements IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.DataRange.SectionDataSource

See Also

DataRange.SectionDataSource Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource Members

DataRange.SectionDataSource Members
Properties Methods
[image]

Represents the data context of the headers and footers in a DataRange.

The following tables list the members exposed by the DataRange.SectionDataSource type.

Public Properties

Name | Description
Item | Gets the data context of the associated data range.

Public Methods

Name | Description
GetEnumerator | Gets the items displayed in the associated data range.

See Also

DataRange.SectionDataSource Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource Methods

DataRange.SectionDataSource Methods
[image]

Public Methods

Name | Description
GetEnumerator | Gets the items displayed in the associated data range.

See Also

DataRange.SectionDataSource Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource.GetEnumerator Method

DataRange.SectionDataSource.GetEnumerator Method
[image]

Gets the items displayed in the associated data range.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An IEnumerable that can be used to enumerate the items.

See Also

DataRange.SectionDataSource Members
DataRange.SectionDataSource Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource Properties

DataRange.SectionDataSource Properties
[image]

Public Properties

Name | Description
Item | Gets the data context of the associated data range.

See Also

DataRange.SectionDataSource Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.DataRange.SectionDataSource.Item Property

DataRange.SectionDataSource.Item Property
[image]

Gets the data context of the associated data range.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Object Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Object

Property Value

An object representing the data context.

See Also

DataRange.SectionDataSource Members
DataRange.SectionDataSource Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Structure

Dimension Structure
[image]

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public struct Dimension

Visual Basic [image] Copy Code

Public Structure Dimension

See Also

Dimension Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Members

Dimension Members
Constructors Fields Properties Methods
[image]

Stores an ordered pair of floating-point numbers, typically the width and height of an object.

The following tables list the members exposed by the Dimension type.

Public Constructors

Name | Description
Dimension | Overloaded. Initializes a new instance of the Dimension structure.

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Fields

Dimension Fields
[image]

Public Fields

Name | Description
Empty | An empty instance of the Dimension structure.

See Also

Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Empty Field

Dimension.Empty Field
[image]

An empty instance of the Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly Dimension Empty

Visual Basic [image] Copy Code

Public Shared ReadOnly Empty As Dimension

Remarks

An instance of the Dimension structure representing an empty dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Constructor

Dimension Constructor
[image]

Initializes a new instance of the Dimension structure.

Overload List

Name | Description
Dimension (Dimension) | Initializes a new instance of the Dimension structure.
Dimension (Double, Double) | Initializes a new instance of the Dimension structure.
Dimension (Double, MeasureUnit, Double, MeasureUnit) | Initializes a new instance of the Dimension structure.
Dimension (Location) | Initializes a new instance of the Dimension structure.

See Also

Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Constructor (Dimension)

Dimension Constructor (Dimension)
See Also
[image]

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Dimension (
Dimension size
)

Visual Basic [image] Copy Code

Public New ( _
size As Dimension _
)

Parameters

size
The Dimension object to use as a prototype.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Constructor (Double, Double)

Dimension Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Dimension (
double width,
double height
)

Visual Basic [image] Copy Code

Public New ( _
width As Double, _
height As Double _
)

Parameters

width
The width component of the new dimension, expressed in pixels.
height
The height component of the new dimension, expressed in pixels.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Constructor (Double, MeasureUnit, Double, MeasureUnit)

Dimension Constructor (Double, MeasureUnit, Double, MeasureUnit)
See Also
[image]

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Dimension (
double width,
MeasureUnit widthUnit,
double height,
MeasureUnit heightUnit
)

Visual Basic [image] Copy Code

Public New ( _
width As Double, _
widthUnit As MeasureUnit, _
height As Double, _
heightUnit As MeasureUnit _
)

Parameters

width
The width component of the new dimension, expressed in the units of measure specified by widthUnit.
widthUnit

The units of measure for the width component.

height
The height component of the new dimension, expressed in the units of measure specified by heightUnit.
heightUnit
The units of measure for the height component.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Constructor (Location)

Dimension Constructor (Location)
See Also
[image]

Initializes a new instance of the Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Dimension (
Location location
)

Visual Basic [image] Copy Code

Public New ( _
location As Location _
)

Parameters

location
The Location object to use as a prototype.

See Also

Dimension Constructor Overload List
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Methods

Dimension Methods
[image]

Public Methods

Name | Description
Add | Adds the width and height of one Dimension structure to the width and height of another Dimension structure.
Equals | Determines if two Dimension structures have the same height and width.
GetHashCode | Returns a hash code for this Dimension structure.
Subtract | Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.
ToLocation | Converts this Dimension to a Location.
ToString | Creates a human-readable string that represents this Dimension.

See Also

Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Add Method

Dimension.Add Method
[image]

Adds the width and height of one Dimension structure to the width and height of another Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static Dimension Add (
Dimension dimension1,
Dimension dimension2
)

Visual Basic [image] Copy Code

Public Shared Function Add ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The first dimension to add.
dimension2

The second dimension to add.

Return Value

A Dimension object representing the result of the addition.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Equals Method

Dimension.Equals Method
[image]

Determines if two Dimension structures have the same height and width.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
An object to compare to this dimension.

Return Value

true, if obj is a Dimension with the same width an height as this dimension; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.GetHashCode Method

Dimension.GetHashCode Method
[image]

Returns a hash code for this Dimension structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Subtract Method

Dimension.Subtract Method
[image]

Subtracts the width and height of one Dimension structure from the width and height of another Dimensions structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static Dimension Subtract (
Dimension dimension1,
Dimension dimension2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract ( _
dimension1 As Dimension, _
dimension2 As Dimension _
) As Dimension

Parameters

dimension1
The source dimension.
dimension2
The dimension to subtract from the source dimension.

Return Value

A Dimension object representing the result of the subtraction.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.ToLocation Method

Dimension.ToLocation Method
[image]

Converts this Dimension to a Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Location ToLocation ()

Visual Basic [image] Copy Code

Public Function ToLocation () As Location

Return Value

A Location object corresponding to the current dimension.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.ToString Method

Dimension.ToString Method
[image]

Creates a human-readable string that represents this Dimension.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A System.String.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension Properties

Dimension Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the vertical component of this Dimension.
HeightUnit | Gets or sets the vertical units of measure of this Dimension.
IsEmpty | Gets a value indicating whether this Dimension has zero width and height.
Width | Gets or sets the horizontal component of this Dimension.
WidthUnit | Gets or sets the horizontal units of measure of this Dimension.

See Also

Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Height Property

Dimension.Height Property
[image]

Gets or sets the vertical component of this Dimension.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

The height component of this dimension. The default is 0.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.HeightUnit Property

Dimension.HeightUnit Property
[image]

Gets or sets the vertical units of measure of this Dimension.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit HeightUnit { get; set; }

Visual Basic [image] Copy Code

Public Property HeightUnit As MeasureUnit

Property Value

The measure unit of the height component of this dimension. The default is Pixel.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.IsEmpty Property

Dimension.IsEmpty Property
[image]

Gets a value indicating whether this Dimension has zero width and height.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true, if the dimension sizes are {0, 0}; otherwise, false.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.Width Property

Dimension.Width Property
[image]

Gets or sets the horizontal component of this Dimension.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

The width component of this dimension. The default is 0.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Dimension.WidthUnit Property

Dimension.WidthUnit Property
[image]

Gets or sets the horizontal units of measure of this Dimension.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit WidthUnit { get; set; }

Visual Basic [image] Copy Code

Public Property WidthUnit As MeasureUnit

Property Value

The measure unit of the width component of this dimension. The default is Pixel.

See Also

Dimension Members
Dimension Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Class

ExpressionExtension Class
Remarks See Also
[image]

A XAML markup extension which allows the use of general MindFusion expression as values in XAML property initialization.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ExpressionExtension : MarkupExtension

Visual Basic [image] Copy Code

Public Class ExpressionExtension
Inherits MarkupExtension

Remarks

This class enables the use of MindFusion expressions as property values in XAML. For more information about MindFusion expressions, check Expressions. This extension does not necessarily need to be used in the context of a MindFusion report. See the section below for an example on how to use expressions in XAML.

Example

This example assigns a simple algebraic expression to the Width property of a WPF Button:

XAML [image] Copy Code

<Button Width="{r:Expression '[CDbl((4+6)*10)]'}" Content="Hello" />

In the above example the namespace r is defined as follows:

XAML [image] Copy Code

xmlns:r="http://mindfusion.eu/reporting/wpf"

Inheritance Hierarchy

System.Object
System.Windows.Markup.MarkupExtension
MindFusion.Reporting.Wpf.ExpressionExtension

See Also

ExpressionExtension Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Members

ExpressionExtension Members
Constructors Properties Methods
[image]

A XAML markup extension which allows the use of general MindFusion expression as values in XAML property initialization.

The following tables list the members exposed by the ExpressionExtension type.

Public Constructors

Name | Description
ExpressionExtension | Overloaded. Initializes a new instance of the ExpressionExtension class.

Public Properties

Name | Description
Expression | Gets or sets the expression source code.

Public Methods

Name | Description
ProvideValue | MarkupExtension.ProvideValue override.

See Also

ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Constructor

ExpressionExtension Constructor
[image]

Initializes a new instance of the ExpressionExtension class.

Overload List

Name | Description
ExpressionExtension () | Initializes a new instance of the ExpressionExtension class.
ExpressionExtension (String) | Initializes a new instance of the ExpressionExtension class using the specified expression.

See Also

ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Constructor ()

ExpressionExtension Constructor ()
See Also
[image]

Initializes a new instance of the ExpressionExtension class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ExpressionExtension ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExpressionExtension Constructor Overload List
ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Constructor (String)

ExpressionExtension Constructor (String)
See Also
[image]

Initializes a new instance of the ExpressionExtension class using the specified expression.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ExpressionExtension (
string expression
)

Visual Basic [image] Copy Code

Public New ( _
expression As String _
)

Parameters

expression

The initial source code of the expression.

Remarks

For more information about expression syntax and functions, check Expressions.

See Also

ExpressionExtension Constructor Overload List
ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Methods

ExpressionExtension Methods
[image]

Public Methods

Name | Description
ProvideValue | MarkupExtension.ProvideValue override.

See Also

ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension.ProvideValue Method

ExpressionExtension.ProvideValue Method
[image]

MarkupExtension.ProvideValue override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override Object ProvideValue (
IServiceProvider serviceProvider
)

Visual Basic [image] Copy Code

Public Overrides Function ProvideValue( _
serviceProvider As IServiceProvider _
) As Object

Parameters

serviceProvider

Object that can provide services for the markup extension.

Return Value

The object value to set on the property where the extension is applied.

See Also

ExpressionExtension Members
ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension Properties

ExpressionExtension Properties
[image]

Public Properties

Name | Description
Expression | Gets or sets the expression source code.

See Also

ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ExpressionExtension.Expression Property

ExpressionExtension.Expression Property
[image]

Gets or sets the expression source code.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Expression { set; }

Visual Basic [image] Copy Code

Public Property Expression As String

Property Value

A string specifying the expression.

Remarks

For more information about expression syntax and functions, check Expressions.

See Also

ExpressionExtension Members
ExpressionExtension Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Class

FixedDocumentRenderTarget Class
Remarks See Also
[image]

An implementation of the IRenderTarget which operates on a FixedDocument object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class FixedDocumentRenderTarget : IRenderTarget

Visual Basic [image] Copy Code

Public Class FixedDocumentRenderTarget
Implements IRenderTarget

Remarks

You can pass an instance of this class to the RenderPage method of a ReportLayout in order to render the page as a WPF FixedDocument. The document itself can be obtained through the Document property.

Example

The following example uses a FixedDocumentRenderTarget object to render all pages of a report to a WPF FixedDocument. The document is then displayed in a WPF DocumentViewer. The example assumes that layout and viewer are variables identifying an existing ReportLayout and DocumentViewer respectively. To obtain a ReportLayout object for a report, call its Layout method after it has been run.

C# [image] Copy Code

FixedDocumentRenderTarget renderTarget = new FixedDocumentRenderTarget();
for (int i = 0; i < layout.PageCount; i++)
layout.RenderPage(i, renderTarget);

viewer.Document = renderTarget.Document;

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.FixedDocumentRenderTarget

See Also

FixedDocumentRenderTarget Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Members

FixedDocumentRenderTarget Members
Constructors Properties
[image]

An implementation of the IRenderTarget which operates on a FixedDocument object.

The following tables list the members exposed by the FixedDocumentRenderTarget type.

Public Constructors

Name | Description
FixedDocumentRenderTarget | Overloaded. Initializes a new instance of the FixedDocumentRenderTarget class.

Public Properties

Name | Description
Document | Gets the FixedDocument, which acts as rendering target.

See Also

FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Constructor

FixedDocumentRenderTarget Constructor
[image]

Initializes a new instance of the FixedDocumentRenderTarget class.

Overload List

Name | Description
FixedDocumentRenderTarget () | Initializes a new instance of the FixedDocumentRenderTarget class.
FixedDocumentRenderTarget (FixedDocument) | Initializes a new instance of the FixedDocumentRenderTarget class using the specified FixedDocument.

See Also

FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Constructor ()

FixedDocumentRenderTarget Constructor ()
See Also
[image]

Initializes a new instance of the FixedDocumentRenderTarget class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FixedDocumentRenderTarget ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FixedDocumentRenderTarget Constructor Overload List
FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Constructor (FixedDocument)

FixedDocumentRenderTarget Constructor (FixedDocument)
See Also
[image]

Initializes a new instance of the FixedDocumentRenderTarget class using the specified FixedDocument.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FixedDocumentRenderTarget (
FixedDocument document
)

Visual Basic [image] Copy Code

Public New ( _
document As FixedDocument _
)

Parameters

document
The WPF FixedDocument, which will be used as a rendering target.

See Also

FixedDocumentRenderTarget Constructor Overload List
FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget Properties

FixedDocumentRenderTarget Properties
[image]

Public Properties

Name | Description
Document | Gets the FixedDocument, which acts as rendering target.

See Also

FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.FixedDocumentRenderTarget.Document Property

FixedDocumentRenderTarget.Document Property
[image]

Gets the FixedDocument, which acts as rendering target.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FixedDocument Document { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Document As FixedDocument

Property Value

A WPF FixedDocument object.

See Also

FixedDocumentRenderTarget Members
FixedDocumentRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit Class

GraphicsUnit Class
[image]

Specifies units of measure for a given data.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class GraphicsUnit

Visual Basic [image] Copy Code

Public Class GraphicsUnit

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.GraphicsUnit

See Also

GraphicsUnit Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit Members

GraphicsUnit Members
Constructors Fields Properties Methods
[image]

Specifies units of measure for a given data.

The following tables list the members exposed by the GraphicsUnit type.

Public Constructors

Name | Description
GraphicsUnit | Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Public Fields

Name | Description
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

Public Properties

Name | Description
Name | Gets the unit name.

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

Public Methods

Name | Description
Convert | Overloaded. Converts a given amount from the current unit to a specified unit.
ToString | Object.ToString override.

See Also

GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit Fields

GraphicsUnit Fields
[image]

Public Fields

Name | Description
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
WpfPoint | Specifies a device-independent pixel as the unit of measure.

See Also

GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Inch Field

GraphicsUnit.Inch Field
[image]

Specifies the inch as the unit of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As GraphicsUnit

Remarks

The UnitsPerInch property of this unit is initialized to 1.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace
Millimeter Field
Pixel Field
Point Field
WpfPoint Field


MindFusion.Reporting.Wpf.GraphicsUnit.Millimeter Field

GraphicsUnit.Millimeter Field
[image]

Specifies the millimeter as the unit of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As GraphicsUnit

Remarks

The UnitsPerInch property of this unit is initialized to 25.4.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace
Inch Field
Pixel Field
Point Field
WpfPoint Field


MindFusion.Reporting.Wpf.GraphicsUnit.Pixel Field

GraphicsUnit.Pixel Field
[image]

Specifies a device pixel as the unit of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As GraphicsUnit

Remarks

The UnitsPerInch property of this unit is initialized to a value, based on the current DPI settings of the system.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace
Inch Field
Millimeter Field
Point Field
WpfPoint Field


MindFusion.Reporting.Wpf.GraphicsUnit.Point Field

GraphicsUnit.Point Field
[image]

Specifies a printer's point (1/72 inch) as the unit of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As GraphicsUnit

Remarks

The UnitsPerInch property of this unit is initialized to 72.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace
Inch Field
Millimeter Field
Pixel Field
WpfPoint Field


MindFusion.Reporting.Wpf.GraphicsUnit.WpfPoint Field

GraphicsUnit.WpfPoint Field
[image]

Specifies a device-independent pixel as the unit of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly GraphicsUnit WpfPoint

Visual Basic [image] Copy Code

Public Shared ReadOnly WpfPoint As GraphicsUnit

Remarks

The UnitsPerInch property of this unit is initialized to 96.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace
Inch Field
Millimeter Field
Pixel Field
Point Field


MindFusion.Reporting.Wpf.GraphicsUnit Constructor

GraphicsUnit Constructor
[image]

Initializes a new instance of the GraphicsUnit class with the specified base resolution.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit (
double unitsPerInch,
string name
)

Visual Basic [image] Copy Code

Public New ( _
unitsPerInch As Double, _
name As String _
)

Parameters

unitsPerInch
The units per inch for the new GraphicsUnit object.
name
A human-readable name of the new GraphicsUnit object.

See Also

GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit Methods

GraphicsUnit Methods
[image]

Public Methods

Name | Description
Convert | Overloaded. Converts a given amount from the current unit to a specified unit.
ToString | Object.ToString override.

See Also

GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Convert Method

GraphicsUnit.Convert Method
[image]

Converts a given amount from the current unit to a specified unit.

Overload List

Name | Description
GraphicsUnit.Convert (Double, GraphicsUnit) | Converts amount from this unit to specified unit.
GraphicsUnit.Convert (Point, GraphicsUnit) | Convenience method for converting Point to specified units.
GraphicsUnit.Convert (Rect, GraphicsUnit) | Convenience method for converting Rect to specified units.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Convert Method (Double, GraphicsUnit)

GraphicsUnit.Convert Method (Double, GraphicsUnit)
See Also
[image]

Converts amount from this unit to specified unit.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Convert (
double amount,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert ( _
amount As Double, _
targetUnit As GraphicsUnit _
) As Double

Parameters

amount
The value to be converted.
targetUnit
The target unit of the conversion.

Return Value

A double value expressed in the target unit of measure.

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Convert Method (Point, GraphicsUnit)

GraphicsUnit.Convert Method (Point, GraphicsUnit)
See Also
[image]

Convenience method for converting Point to specified units.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Point Convert (
Point p,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert ( _
p As Point, _
targetUnit As GraphicsUnit _
) As Point

Parameters

p
The Point structure to be converted.
targetUnit
The target unit of the conversion.

Return Value

A Point structure expressed in the target unit of measure.

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Convert Method (Rect, GraphicsUnit)

GraphicsUnit.Convert Method (Rect, GraphicsUnit)
See Also
[image]

Convenience method for converting Rect to specified units.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Rect Convert (
Rect r,
GraphicsUnit targetUnit
)

Visual Basic [image] Copy Code

Public Function Convert ( _
r As Rect, _
targetUnit As GraphicsUnit _
) As Rect

Parameters

r
The Rect structure to be converted.
targetUnit

The target unit of the conversion.

Return Value

A Rect structure expressed in the target unit of measure.

See Also

Convert Method Overload List
GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.ToString Method

GraphicsUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The name of this unit.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit Properties

GraphicsUnit Properties
[image]

Public Properties

Name | Description
Name | Gets the unit name.

Protected Properties

Name | Description
UnitsPerInch | Gets the base resolution of this GraphicsUnit object.

See Also

GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.Name Property

GraphicsUnit.Name Property
[image]

Gets the unit name.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string identifying the unit name.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.GraphicsUnit.UnitsPerInch Property

GraphicsUnit.UnitsPerInch Property
[image]

Gets the base resolution of this GraphicsUnit object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected virtual double UnitsPerInch { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property UnitsPerInch As Double

Property Value

A double value specifying the resolution of this unit.

See Also

GraphicsUnit Members
GraphicsUnit Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget Class

ImageRenderTarget Class
Remarks See Also
[image]

An implementation of the IRenderTarget, which renders a report to an image.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ImageRenderTarget : IRenderTarget

Visual Basic [image] Copy Code

Public Class ImageRenderTarget
Implements IRenderTarget

Remarks

This class allows reports to be exported as images. To learn more about how to use it, check Exporting Reports.

Example

The following example creates a new report with a label on it and exports it as PNG. The exported pages have white background and black border.

C# [image] Copy Code

Report report = new Report();
report.Pages.Add(new MindFusion.Reporting.Page());
report.Pages[0].Items.Add(new MindFusion.Reporting.Label() { Text = "Hello world!" });

report.Run();

ReportLayout layout = report.Layout(New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96),
MindFusion.Reporting.PageOrientation.Portrait);

ImageRenderTarget renderTarget = new ImageRenderTarget();
renderTarget.PageBackground = Brushes.White;
renderTarget.PageBorderBrush = Brushes.Black;

layout.RenderAllPages(renderTarget);

renderTarget.Save("helloworld.png");

Visual Basic [image] Copy Code

Dim report As New Report
report.Pages.Add(New MindFusion.Reporting.Page())
report.Pages(0).Items.Add(New MindFusion.Reporting.Label() With {.Text = "Hello world!"})

report.Run()

Dim layout = report.Layout(New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96), _
MindFusion.Reporting.PageOrientation.Portrait)

Dim renderTarget = New ImageRenderTarget()
renderTarget.PageBackground = Brushes.White
renderTarget.PageBorderBrush = Brushes.Black

layout.RenderAllPages(renderTarget)

renderTarget.Save("helloworld.png")

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.ImageRenderTarget

See Also

ImageRenderTarget Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget Members

ImageRenderTarget Members
Constructors Properties Methods
[image]

An implementation of the IRenderTarget, which renders a report to an image.

The following tables list the members exposed by the ImageRenderTarget type.

Public Constructors

Name | Description
ImageRenderTarget | Initializes a new instance of the ImageRenderTarget class.

Public Properties

Name | Description
Dpi | Gets or sets the DPI of the resulting image.
IsMultipage | Gets or sets a value indicating whether the pages in the report will be added as a separate BitmapFrame objects to the underlying encoder or all the pages will be rendered as a single frame.
PageBackground | Gets or sets a brush to use as a page background for pages who do not have explicit background set.
PageBorderBrush | Gets or sets a brush to use as a page border for pages who do not have explicit border set.

Public Methods

Name | Description
Save | Overloaded. Saves the rendered image in a file.

See Also

ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget Constructor

ImageRenderTarget Constructor
[image]

Initializes a new instance of the ImageRenderTarget class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ImageRenderTarget ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget Methods

ImageRenderTarget Methods
[image]

Public Methods

Name | Description
Save | Overloaded. Saves the rendered image in a file.

See Also

ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.Save Method

ImageRenderTarget.Save Method
[image]

Saves the rendered image in a file.

Overload List

Name | Description
ImageRenderTarget.Save (String) | Saves the rendered image in a PNG format to a file with the specified name.
ImageRenderTarget.Save (String, BitmapEncoder) | Saves the rendered image to a file with the specified name and using the specified bitmap encoder.

See Also

ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.Save Method (String)

ImageRenderTarget.Save Method (String)
See Also
[image]

Saves the rendered image in a PNG format to a file with the specified name.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void Save (
string fileName
)

Visual Basic [image] Copy Code

Public Sub Save( _
fileName As String _
)

Parameters

fileName

The file name where the image will be saved.

See Also

Save Method Overload List
ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.Save Method (String, BitmapEncoder)

ImageRenderTarget.Save Method (String, BitmapEncoder)
See Also
[image]

Saves the rendered image to a file with the specified name and using the specified bitmap encoder.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void Save (
string fileName,
BitmapEncoder encoder
)

Visual Basic [image] Copy Code

Public Sub Save( _
fileName As String, _
encoder As BitmapEncoder _
)

Parameters

fileName

The file name where the image will be saved.

encoder

The encoder to use for saving.

See Also

Save Method Overload List
ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget Properties

ImageRenderTarget Properties
[image]

Public Properties

Name | Description
Dpi | Gets or sets the DPI of the resulting image.
IsMultipage | Gets or sets a value indicating whether the pages in the report will be added as a separate BitmapFrame objects to the underlying encoder or all the pages will be rendered as a single frame.
PageBackground | Gets or sets a brush to use as a page background for pages who do not have explicit background set.
PageBorderBrush | Gets or sets a brush to use as a page border for pages who do not have explicit border set.

See Also

ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.Dpi Property

ImageRenderTarget.Dpi Property
[image]

Gets or sets the DPI of the resulting image.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Dpi { get; set; }

Visual Basic [image] Copy Code

Public Property Dpi As Double

Property Value

A double value specifying the DPI of the output image. The default is 0.

Remarks

If this value is zero, the screen DPI will be used instead.

See Also

ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.IsMultipage Property

ImageRenderTarget.IsMultipage Property
[image]

Gets or sets a value indicating whether the pages in the report will be added as a separate BitmapFrame objects to the underlying encoder or all the pages will be rendered as a single frame.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool IsMultipage { get; set; }

Visual Basic [image] Copy Code

Public Property IsMultipage As Boolean

Property Value

true, to try to export each page as a separate bitmap frame; otherwise, false.

Remarks

Not all encoders support multiple frames. If this property is set to true and the encoder does not support multiple frames, only the first page will be saved.

See Also

ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ImageRenderTarget.PageBackground Property

ImageRenderTarget.PageBackground Property
[image]

Gets or sets a brush to use as a page background for pages who do not have explicit background set.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PageBackground { get; set; }

Visual Basic [image] Copy Code

Public Property PageBackground As Brush

Property Value

A WPF Brush object. The default is null (Nothing in Visual Basic).

Remarks

Pages, which do not specify Background will be rendered using this brush. If this brush is null (Nothing in Visual Basic) those pages will be either transparent or rendered using the default background color of the target image format.

See Also

ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace
PageBorderBrush Property


MindFusion.Reporting.Wpf.ImageRenderTarget.PageBorderBrush Property

ImageRenderTarget.PageBorderBrush Property
[image]

Gets or sets a brush to use as a page border for pages who do not have explicit border set.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PageBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PageBorderBrush As Brush

Property Value

A WPF Brush object. The default is null (Nothing in Visual Basic).

See Also

ImageRenderTarget Members
ImageRenderTarget Class
MindFusion.Reporting.Wpf Namespace
PageBackground Property


MindFusion.Reporting.Wpf.IRenderTarget Interface

IRenderTarget Interface
Remarks See Also
[image]

Represents an object, which can be used as a target of a report rendering operation. An instance of this class is supplied to the RenderPage or RenderAllPages methodReportLayout class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public interface IRenderTarget

Visual Basic [image] Copy Code

Public Interface IRenderTarget

Remarks

This interface provides an abstraction between the report and the output format. The report can be exported to various formats using different implementations of this interface. FixedDocumentRenderTarget class provides rendering of a report to a WPF FixedDocument.

Example

The following example illustrates how to render a report to a FixedDocument. The report is identified by the report variable and is expected to be initialized and run already.

C# [image] Copy Code

ReportLayout layout = report.Layout(
new Size(8.5 * 96, 11 * 96), new Thickness(0.5 * 96),
MindFusion.Reporting.PageOrientation.Portrait);

Visual Basic [image] Copy Code

Dim layout = report.Layout( _
New Size(8.5 * 96, 11 * 96), New Thickness(0.5 * 96), _
MindFusion.Reporting.PageOrientation.Portrait)

Inheritors

MindFusion.Reporting.Wpf.CanvasRenderTarget
MindFusion.Reporting.Wpf.FixedDocumentRenderTarget
MindFusion.Reporting.Wpf.ImageRenderTarget
MindFusion.Reporting.Wpf.IRenderTargetWithPages(T)
MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase
MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget

See Also

IRenderTarget Members
MindFusion.Reporting.Wpf Namespace
FixedDocumentRenderTarget Class


MindFusion.Reporting.Wpf.IRenderTarget Members

IRenderTarget Members
Methods
[image]

Represents an object, which can be used as a target of a report rendering operation. An instance of this class is supplied to the RenderPage or RenderAllPages methodReportLayout class.

The following tables list the members exposed by the IRenderTarget type.

Public Methods

Name | Description
AddPage | Invoked by the rendering system when a new report page needs to be added to the rendering target.
BeginRender | Invoked at the start of the rendering.
EndRender | Invoked after all pages have been rendered.
Render | Invoked by the rendering system in order to render the specified UIElement.
Translate | Translates the rendering target by the specified amount.

See Also

IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget Methods

IRenderTarget Methods
[image]

Public Methods

Name | Description
AddPage | Invoked by the rendering system when a new report page needs to be added to the rendering target.
BeginRender | Invoked at the start of the rendering.
EndRender | Invoked after all pages have been rendered.
Render | Invoked by the rendering system in order to render the specified UIElement.
Translate | Translates the rendering target by the specified amount.

See Also

IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget.AddPage Method

IRenderTarget.AddPage Method
[image]

Invoked by the rendering system when a new report page needs to be added to the rendering target.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

void AddPage (
Size size
)

Visual Basic [image] Copy Code

Sub AddPage( _
size As Size _
)

Parameters

size

The size of the new page.

See Also

IRenderTarget Members
IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget.BeginRender Method

IRenderTarget.BeginRender Method
[image]

Invoked at the start of the rendering.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

void BeginRender ()

Visual Basic [image] Copy Code

Sub BeginRender ()

See Also

IRenderTarget Members
IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget.EndRender Method

IRenderTarget.EndRender Method
[image]

Invoked after all pages have been rendered.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

void EndRender ()

Visual Basic [image] Copy Code

Sub EndRender ()

See Also

IRenderTarget Members
IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget.Render Method

IRenderTarget.Render Method
[image]

Invoked by the rendering system in order to render the specified UIElement.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

void Render (
UIElement element,
double left,
double top
)

Visual Basic [image] Copy Code

Sub Render( _
element As UIElement, _
left As Double, _
top As Double _
)

Parameters

element
The UIElement to be rendered.
left

The left position of the element being rendered relative to the current page.

top

The top position of the element being rendered relative to the current page.

Remarks

The provided element is not connected to a parent and can be directly embedded in a visual or logical tree.

See Also

IRenderTarget Members
IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTarget.Translate Method

IRenderTarget.Translate Method
[image]

Translates the rendering target by the specified amount.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

void Translate (
double x,
double y
)

Visual Basic [image] Copy Code

Sub Translate( _
x As Double, _
y As Double _
)

Parameters

x

The amount to translate along the x-axis.

y

The amount to translate along the y-axis.

See Also

IRenderTarget Members
IRenderTarget Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTargetWithPages(T) Interface

IRenderTargetWithPages(T) Interface
Remarks See Also
[image]

Represents a render target, which exposes the rendered report pages as UIElement objects.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public interface IRenderTargetWithPages<T> : IRenderTarget where T : UIElement

Visual Basic [image] Copy Code

Public Interface IRenderTargetWithPages(Of T As UIElement)
Implements IRenderTarget

Remarks

This interface can be passed to the PrintRendered method of the ReportPrinter class in order to print the rendering directly.

Example

Below is a sample implementation of this interface, which renders individual pages on separate Canvas objects.

C# [image] Copy Code

/// <summary>
/// This class renders individual pages in a report on separate Canvas objects.
/// </summary>
class PrintRenderTarget : IRenderTargetWithPages<Canvas>
{
/// <summary>
/// Intializes a new instance of the PageRenderTarget class.
/// </summary>
public PrintRenderTarget()
{
pages = new List<Canvas>();
}

/// <summary>
/// IRenderTarget.AddPage implementation.
/// </summary>
/// <param name="size">
/// The size of the new page.
/// </param>
public void AddPage(Size size)
{
pages.Add(currentPage = new Canvas());
}

/// <summary>
/// IRenderTarget.BeginRender implementation.
/// </summary>
public void BeginRender()
{
}

/// <summary>
/// IRenderTarget.Render implementation.
/// </summary>
/// <param name="element">
/// The UIElement to be rendered.
/// </param>
/// <param name="left">
/// The left position of the element being rendered relative to the current page.
/// </param>
/// <param name="top">
/// </param>
public void Render(UIElement element, double left, double top)
{
Canvas.SetLeft(element, tx + left);
Canvas.SetTop(element, ty + top);
currentPage.Children.Add(element);
}

/// <summary>
/// IRenderTarget.EndRender implementation.
/// </summary>
public void EndRender()
{
}

/// <summary>
/// IRenderTarget.Translate implementation.
/// </summary>
/// <param name="x">
/// The amount to translate along the x-axis.
/// </param>
/// <param name="y">
/// The amount to translate along the y-axis.
/// </param>
public void Translate(double x, double y)
{
tx += x;
ty += y;
}

/// <summary>
/// Gets an enumerator of the rendered pages.
/// </summary>
public Canvas[] Pages
{
get { return pages.ToArray(); }
}

/// <summary>
/// The list of rendered pages.
/// </summary>
private List<Canvas> pages;

/// <summary>
/// The page currently being rendered.
/// </summary>
private Canvas currentPage;

/// <summary>
/// The currently accumulated translation along the x-axis.
/// </summary>
private double tx;

/// <summary>
/// The currently accumulated translation along th y-axis.
/// </summary>
private double ty;
}

Visual Basic [image] Copy Code

''' <summary>
''' This class renders individual pages on separate Canvas objects.
''' </summary>
Class PrintRenderTarget
Implements IRenderTargetWithPages(Of Canvas)

''' <summary>
''' Intializes a new instance of the PageRenderTarget class.
''' </summary>
Public Sub New()

_pages = New List(Of Canvas)()

End Sub

''' <summary>
''' IRenderTarget.AddPage implementation.
''' </summary>
''' <param name="size">
''' The size of the new page.
''' </param>
Public Sub AddPage(ByVal size As Size) Implements IRenderTarget.AddPage

currentPage = New Canvas()
_pages.Add(currentPage)

End Sub

''' <summary>
''' IRenderTarget.BeginRender implementation.
''' </summary>
Public Sub BeginRender() Implements IRenderTarget.BeginRender

End Sub

''' <summary>
''' IRenderTarget.Render implementation.
''' </summary>
''' <param name="element">
''' The UIElement to be rendered.
''' </param>
''' <param name="left">
''' The left position of the element being rendered relative to the current page.
''' </param>
''' <param name="top">
''' </param>
Public Sub Render(ByVal element As UIElement, ByVal left As Double, ByVal top As Double) Implements IRenderTarget.Render

Canvas.SetLeft(element, tx + left)
Canvas.SetTop(element, ty + top)
currentPage.Children.Add(element)

End Sub

''' <summary>
''' IRenderTarget.EndRender implementation.
''' </summary>
Public Sub EndRender() Implements IRenderTarget.EndRender

End Sub

''' <summary>
''' IRenderTarget.Translate implementation.
''' </summary>
''' <param name="x">
''' The amount to translate along the x-axis.
''' </param>
''' <param name="y">
''' The amount to translate along the y-axis.
''' </param>
Public Sub Translate(ByVal x As Double, ByVal y As Double) Implements IRenderTarget.Translate

tx = tx + x
ty = ty + y

End Sub

''' <summary>
''' Gets an enumerator of the rendered pages.
''' </summary>
Public ReadOnly Property Pages As Canvas() Implements IRenderTargetWithPages(Of Canvas).Pages

Get
Return _pages.ToArray()
End Get

End Property

''' <summary>
''' The list of rendered pages.
''' </summary>
Private _pages As List(Of Canvas)

''' <summary>
''' The page currently being rendered.
''' </summary>
Private currentPage As Canvas

''' <summary>
''' The currently accumulated translation along the x-axis.
''' </summary>
Private tx As Double

''' <summary>
''' The currently accumulated translation along th y-axis.
''' </summary>
Private ty As Double

End Class

See Also

IRenderTargetWithPages(T) Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTargetWithPages(T) Members

IRenderTargetWithPages(T) Members
Properties
[image]

Represents a render target, which exposes the rendered report pages as UIElement objects.

The following tables list the members exposed by the IRenderTargetWithPages(T) type.

Public Properties

Name | Description
Pages | Gets the UIElement objects representing the rendered report pages.

See Also

IRenderTargetWithPages(T) Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTargetWithPages(T) Properties

IRenderTargetWithPages(T) Properties
[image]

Public Properties

Name | Description
Pages | Gets the UIElement objects representing the rendered report pages.

See Also

IRenderTargetWithPages(T) Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.IRenderTargetWithPages(T).Pages Property

IRenderTargetWithPages(T).Pages Property
[image]

Gets the UIElement objects representing the rendered report pages.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

T[] Pages { get; }

Visual Basic [image] Copy Code

ReadOnly Property Pages As T()

Property Value

Gets an array of UIElement-derived objects, each of which represents a single page in the report.

See Also

IRenderTargetWithPages(T) Members
IRenderTargetWithPages(T) Interface
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer Class

ItemContainer Class
[image]

Represents a special type of item container, which should be used as the root in the DataTemplate object specified by the ItemTemplate property of data ranges.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ItemContainer : ItemWithChildren

Visual Basic [image] Copy Code

Public Class ItemContainer
Inherits ItemWithChildren

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemContainer

See Also

ItemContainer Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer Members

ItemContainer Members
Constructors Fields Properties Methods
[image]

Represents a special type of item container, which should be used as the root in the DataTemplate object specified by the ItemTemplate property of data ranges.

The following tables list the members exposed by the ItemContainer type.

Public Constructors

Name | Description
ItemContainer | Initializes a new instance of the ItemContainer class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
CanOverflowProperty | Identifies the CanOverflow dependency property.
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
CanOverflow | Gets or sets a value indicating whether this container can split across several pages when laid out. This is a dependency property.
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only. (Inherited from ItemWithChildren.)

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer Fields

ItemContainer Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
CanOverflowProperty | Identifies the CanOverflow dependency property.
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer.CanOverflowProperty Field

ItemContainer.CanOverflowProperty Field
[image]

Identifies the CanOverflow dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanOverflowProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanOverflowProperty As DependencyProperty

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer Constructor

ItemContainer Constructor
[image]

Initializes a new instance of the ItemContainer class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ItemContainer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer Properties

ItemContainer Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
CanOverflow | Gets or sets a value indicating whether this container can split across several pages when laid out. This is a dependency property.
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

See Also

ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemContainer.CanOverflow Property

ItemContainer.CanOverflow Property
[image]

Gets or sets a value indicating whether this container can split across several pages when laid out. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool CanOverflow { get; set; }

Visual Basic [image] Copy Code

Public Property CanOverflow As Boolean

Property Value

true, if the container is allowed to split during report pagination; otherwise, false.

See Also

ItemContainer Members
ItemContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Class

ItemWithChildren Class
Remarks See Also
[image]

Represents a report item, which can hold other report items.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public abstract class ItemWithChildren : ReportItem

Visual Basic [image] Copy Code

Public MustInherit Class ItemWithChildren
Inherits ReportItem

Remarks

This class is not meant to be directly used by the users.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemContainer
MindFusion.Reporting.Wpf.ItemWithSections

See Also

ItemWithChildren Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Members

ItemWithChildren Members
Constructors Fields Properties Methods
[image]

Represents a report item, which can hold other report items.

The following tables list the members exposed by the ItemWithChildren type.

Protected Constructors

Name | Description
ItemWithChildren | Initializes a new instance of the ItemWithChildren class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ItemsProperty | Identifies the Items dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Items | Gets or sets the report items contained in this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override.

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override.

See Also

ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Fields

ItemWithChildren Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ItemsProperty | Identifies the Items dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren.ItemsProperty Field

ItemWithChildren.ItemsProperty Field
[image]

Identifies the Items dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemsProperty As DependencyProperty

See Also

ItemWithChildren Members
ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Constructor

ItemWithChildren Constructor
[image]

Initializes a new instance of the ItemWithChildren class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected ItemWithChildren ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Methods

ItemWithChildren Methods
[image]

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override.

See Also

ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren.GetVisualChild Method

ItemWithChildren.GetVisualChild Method
[image]

FrameworkElement.GetVisualChild override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index
The zero-based index of the requested child element in the collection.

Return Value

The requested child element. If the provided index is out of range, an exception is thrown.

See Also

ItemWithChildren Members
ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren.ShouldSerializeItems Method

ItemWithChildren.ShouldSerializeItems Method
[image]

This method is for internal use only.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public virtual bool ShouldSerializeItems ()

Visual Basic [image] Copy Code

Public Overridable Function ShouldSerializeItems () As Boolean

Return Value

See Also

ItemWithChildren Members
ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren Properties

ItemWithChildren Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Items | Gets or sets the report items contained in this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override.

See Also

ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren.Items Property

ItemWithChildren.Items Property
[image]

Gets or sets the report items contained in this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportItemCollection Items { get; set; }

Visual Basic [image] Copy Code

Public Property Items As ReportItemCollection

Property Value

An instance of the ReportItemCollection class containing the children of this item.

See Also

ItemWithChildren Members
ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithChildren.VisualChildrenCount Property

ItemWithChildren.VisualChildrenCount Property
[image]

FrameworkElement.VisualChilden override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

The number of visual child elements for this element.

See Also

ItemWithChildren Members
ItemWithChildren Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections Class

ItemWithSections Class
Remarks See Also
[image]

Represents a report item, which provides header and footer.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public abstract class ItemWithSections : ItemWithChildren

Visual Basic [image] Copy Code

Public MustInherit Class ItemWithSections
Inherits ItemWithChildren

Remarks

This class is not meant to be directly used by the users.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemWithSections
MindFusion.Reporting.Wpf.DataRange
MindFusion.Reporting.Wpf.Page

See Also

ItemWithSections Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections Members

ItemWithSections Members
Constructors Fields Properties Methods
[image]

Represents a report item, which provides header and footer.

The following tables list the members exposed by the ItemWithSections type.

Protected Constructors

Name | Description
ItemWithSections | Initializes a new instance of the ItemWithSections class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
FooterTemplateProperty | Identifies the FooterTemplate dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property.
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property.
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only. (Inherited from ItemWithChildren.)

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections Fields

ItemWithSections Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
FooterTemplateProperty | Identifies the FooterTemplate dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections.FooterTemplateProperty Field

ItemWithSections.FooterTemplateProperty Field
[image]

Identifies the FooterTemplate dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FooterTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FooterTemplateProperty As DependencyProperty

See Also

ItemWithSections Members
ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections.HeaderTemplateProperty Field

ItemWithSections.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

ItemWithSections Members
ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections Constructor

ItemWithSections Constructor
[image]

Initializes a new instance of the ItemWithSections class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected ItemWithSections ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections Properties

ItemWithSections Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property.
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property.
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

See Also

ItemWithSections Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ItemWithSections.FooterTemplate Property

ItemWithSections.FooterTemplate Property
[image]

Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public DataTemplate FooterTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property FooterTemplate As DataTemplate

Property Value

A WPF DataTemplate object specifying the footer template.

See Also

ItemWithSections Members
ItemWithSections Class
MindFusion.Reporting.Wpf Namespace
HeaderTemplate Property


MindFusion.Reporting.Wpf.ItemWithSections.HeaderTemplate Property

ItemWithSections.HeaderTemplate Property
[image]

Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object specifying the header template.

See Also

ItemWithSections Members
ItemWithSections Class
MindFusion.Reporting.Wpf Namespace
FooterTemplate Property


MindFusion.Reporting.Wpf.Label Class

Label Class
Remarks See Also
[image]

Represents a report element that can display text or data, which can be formatted as text.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class Label : ReportItem

Visual Basic [image] Copy Code

Public Class Label
Inherits ReportItem

Remarks

Usually, labels display static text. In this case, the text to be displayed is assigned to the Text property of the labels.

Labels can be bound to members in the current data context using standard WPF bindings.

Finally, the text of the label may contained expressions. The expressions within the label's text are evaluated when the report is run and the result of the evaluation is displayed by the label. Extensive information about how to integrate expressions in the text of labels can be found in the Using Expressions in Label Texts topic.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Label

See Also

Label Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label Members

Label Members
Constructors Fields Properties
[image]

Represents a report element that can display text or data, which can be formatted as text.

The following tables list the members exposed by the Label type.

Public Constructors

Name | Description
Label | Initializes a new instance of the Label class.

Public Fields

Name | Description
AutoSizeProperty | Identifies the AutoSize dependency property.
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ForegroundProperty | Identifies the Foreground dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PaddingProperty | Identifies the Padding dependency property.
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextFormatProperty | Identifies the TextFormat dependency property.
TextProperty | Identifies the Text dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
AutoSize | Gets or sets a value indicating whether the label will auto resize to fit its content. This is a dependency property.
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FontFamily | Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.
Foreground | Gets or sets the brush used to fill the foreground of this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
Padding | Gets or sets the distance between the label text and the label bounds. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
Text | Gets or sets the text of the label. This is a dependency property.
TextAlignment | Gets or sets the alignment of the label's text. This is a dependency property.
TextFormat | Gets the string used to format the Text of this label. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label Fields

Label Fields
[image]

Public Fields

Name | Description
AutoSizeProperty | Identifies the AutoSize dependency property.
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ForegroundProperty | Identifies the Foreground dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PaddingProperty | Identifies the Padding dependency property.
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextFormatProperty | Identifies the TextFormat dependency property.
TextProperty | Identifies the Text dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.AutoSizeProperty Field

Label.AutoSizeProperty Field
[image]

Identifies the AutoSize dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoSizeProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.ForegroundProperty Field

Label.ForegroundProperty Field
[image]

Identifies the Foreground dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ForegroundProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.PaddingProperty Field

Label.PaddingProperty Field
[image]

Identifies the Padding dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.TextAlignmentProperty Field

Label.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.TextFormatProperty Field

Label.TextFormatProperty Field
[image]

Identifies the TextFormat dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextFormatProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.TextProperty Field

Label.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label Constructor

Label Constructor
[image]

Initializes a new instance of the Label class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Label ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label Properties

Label Properties
[image]

Public Properties

Name | Description
AutoSize | Gets or sets a value indicating whether the label will auto resize to fit its content. This is a dependency property.
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FontFamily | Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.
Foreground | Gets or sets the brush used to fill the foreground of this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
Padding | Gets or sets the distance between the label text and the label bounds. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
Text | Gets or sets the text of the label. This is a dependency property.
TextAlignment | Gets or sets the alignment of the label's text. This is a dependency property.
TextFormat | Gets the string used to format the Text of this label. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.AutoSize Property

Label.AutoSize Property
[image]

Gets or sets a value indicating whether the label will auto resize to fit its content. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool AutoSize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSize As Boolean

Property Value

true, to size the label automatically to its content; otherwise, false.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.FontFamily Property

Label.FontFamily Property
[image]

Gets or sets the font family of this label. If the font family is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

An instance of the WPF FontFamily class.

Remarks

This is a convenience property for getting and setting the Report.FontFamily attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace
FontSize Property
FontStyle Property
FontWeight Property


MindFusion.Reporting.Wpf.Label.FontSize Property

Label.FontSize Property
[image]

Gets or sets the font size of this label. If the font size is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value.

Remarks

This is a convenience property for getting and setting the Report.FontSize attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.FontStyle Property

Label.FontStyle Property
[image]

Gets or sets the font style of this label. If the font style is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure.

Remarks

This is a convenience property for getting and setting the Report.FontStyle attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.FontWeight Property

Label.FontWeight Property
[image]

Gets or sets the font weight of this label. If the font weight is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure.

Remarks

This is a convenience property for getting and setting the Report.FontWeight attached property on this label. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.Foreground Property

Label.Foreground Property
[image]

Gets or sets the brush used to fill the foreground of this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }

Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

An instance of the WPF Brush class.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.Padding Property

Label.Padding Property
[image]

Gets or sets the distance between the label text and the label bounds. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Thickness

Property Value

An instance of the WPF Thickness structure.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.Text Property

Label.Text Property
[image]

Gets or sets the text of the label. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

Remarks

The text of the label can contain expressions embedded in it. To embed an expression, simply enclose it in square brackets - '[' and ']'. The following example embeds the expression Now() in the text of a label.

XAML [image] Copy Code

<r:Label Text="[Now()]" />

For more information about expressions in general, check Expressions. For more information on how to use expressions in label texts, check Using Expressions in Label Texts.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.TextAlignment Property

Label.TextAlignment Property
[image]

Gets or sets the alignment of the label's text. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration.

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Label.TextFormat Property

Label.TextFormat Property
[image]

Gets the string used to format the Text of this label. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As String

Property Value

A string specifying the text format.

Example

The following example illustrates how to format the value of a label as a USD currency:

XAML [image] Copy Code

<r:Label Text="[UnitPrice]" TextFormat="${0:#,##0.00}" />

See Also

Label Members
Label Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart Class

LineChart Class
[image]

Renders a bound dataset as a line chart.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class LineChart : AxesChart

Visual Basic [image] Copy Code

Public Class LineChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.AxesChart
MindFusion.Reporting.Wpf.LineChart

See Also

LineChart Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart Members

LineChart Members
Constructors Fields Properties
[image]

Renders a bound dataset as a line chart.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Initializes a new instance of the LineChart class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
ForegroundProperty | Identifies the Foreground dependency property.
GridFillProperty | Identifies the GridFill dependency property.
GridStrokeProperty | Identifies the GridStroke dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LegendDockProperty | Identifies the LegendDock dependency property.
LegendLabelsProperty | Identifies the LegendLabels dependency property.
LegendOrientationProperty | Identifies the LegendOrientation dependency property.
LineTypeProperty | Identifies the LineType dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property.
XDataProperty | Identifies the XData dependency property. (Inherited from AxesChart.)
XIntervalProperty | Identifies the XInterval dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
XLabelTypeProperty | Identifies the XLabelType dependency property. (Inherited from AxesChart.)
XMaxValueProperty | Identifies the XMaxValue dependency property. (Inherited from AxesChart.)
XMinValueProperty | Identifies the XMinValue dependency property. (Inherited from AxesChart.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property.
YDataProperty | Identifies the YData dependency property. (Inherited from AxesChart.)
YIntervalProperty | Identifies the YInterval dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)
YLabelTypeProperty | Identifies the YLabelType dependency property. (Inherited from AxesChart.)
YMaxValueProperty | Identifies the YMaxValue dependency property. (Inherited from AxesChart.)
YMinValueProperty | Identifies the YMinValue dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
Foreground | Gets or sets the foreground of the chart. This is a dependency property.
GridFill | Gets or sets the brush for the grid stripes. This is a dependency property.
GridStroke | Gets or sets the brushes for the grid lines. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
LegendDock | Gets or sets the legend position relative to the chart. This is a dependency property.
LegendLabels | Gets or sets the labels displayed by the legend. This is a dependency property.
LegendOrientation | Gets or sets the orientation of the legend. This is a dependency property.
LineType | Gets or sets the type of the line chart. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
PlotAreaFill | Gets or sets the background of the plot area. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property.
PlotAreaStroke | Gets or sets the outline of the plot area. This is a dependency property.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. This is a dependency property.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
ScatterSize | Gets or sets the size of the scatter elements in the chart. This is a dependency property.
ScatterType | Gets or sets the scatter type of the line chart. This is a dependency property.
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the settings of the x-axis. This is a dependency property.
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the settings of the y-axis. This is a dependency property.
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart Fields

LineChart Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
ForegroundProperty | Identifies the Foreground dependency property.
GridFillProperty | Identifies the GridFill dependency property.
GridStrokeProperty | Identifies the GridStroke dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LegendDockProperty | Identifies the LegendDock dependency property.
LegendLabelsProperty | Identifies the LegendLabels dependency property.
LegendOrientationProperty | Identifies the LegendOrientation dependency property.
LineTypeProperty | Identifies the LineType dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)
XAxisSettingsProperty | Identifies the XAxisSettings dependency property.
XDataProperty | Identifies the XData dependency property. (Inherited from AxesChart.)
XIntervalProperty | Identifies the XInterval dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
XLabelTypeProperty | Identifies the XLabelType dependency property. (Inherited from AxesChart.)
XMaxValueProperty | Identifies the XMaxValue dependency property. (Inherited from AxesChart.)
XMinValueProperty | Identifies the XMinValue dependency property. (Inherited from AxesChart.)
YAxisSettingsProperty | Identifies the YAxisSettings dependency property.
YDataProperty | Identifies the YData dependency property. (Inherited from AxesChart.)
YIntervalProperty | Identifies the YInterval dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)
YLabelTypeProperty | Identifies the YLabelType dependency property. (Inherited from AxesChart.)
YMaxValueProperty | Identifies the YMaxValue dependency property. (Inherited from AxesChart.)
YMinValueProperty | Identifies the YMinValue dependency property. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.ForegroundProperty Field

LineChart.ForegroundProperty Field
[image]

Identifies the Foreground dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ForegroundProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.GridFillProperty Field

LineChart.GridFillProperty Field
[image]

Identifies the GridFill dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridFillProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.GridStrokeProperty Field

LineChart.GridStrokeProperty Field
[image]

Identifies the GridStroke dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokeProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendDockProperty Field

LineChart.LegendDockProperty Field
[image]

Identifies the LegendDock dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendDockProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendDockProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendLabelsProperty Field

LineChart.LegendLabelsProperty Field
[image]

Identifies the LegendLabels dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendLabelsProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendOrientationProperty Field

LineChart.LegendOrientationProperty Field
[image]

Identifies the LegendOrientation dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendOrientationProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LineTypeProperty Field

LineChart.LineTypeProperty Field
[image]

Identifies the LineType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LineTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LineTypeProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaFillProperty Field

LineChart.PlotAreaFillProperty Field
[image]

Identifies the PlotAreaFill dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaFillProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaMarginProperty Field

LineChart.PlotAreaMarginProperty Field
[image]

Identifies the PlotAreaMargin dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaMarginProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaStrokeProperty Field

LineChart.PlotAreaStrokeProperty Field
[image]

Identifies the PlotAreaStroke dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaStrokeThicknessProperty Field

LineChart.PlotAreaStrokeThicknessProperty Field
[image]

Identifies the PlotAreaStrokeThickness dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeThicknessProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.ScatterSizeProperty Field

LineChart.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.ScatterTypeProperty Field

LineChart.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.XAxisSettingsProperty Field

LineChart.XAxisSettingsProperty Field
[image]

Identifies the XAxisSettings dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisSettingsProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.YAxisSettingsProperty Field

LineChart.YAxisSettingsProperty Field
[image]

Identifies the YAxisSettings dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxisSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxisSettingsProperty As DependencyProperty

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart Constructor

LineChart Constructor
[image]

Initializes a new instance of the LineChart class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LineChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart Properties

LineChart Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
Foreground | Gets or sets the foreground of the chart. This is a dependency property.
GridFill | Gets or sets the brush for the grid stripes. This is a dependency property.
GridStroke | Gets or sets the brushes for the grid lines. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
LegendDock | Gets or sets the legend position relative to the chart. This is a dependency property.
LegendLabels | Gets or sets the labels displayed by the legend. This is a dependency property.
LegendOrientation | Gets or sets the orientation of the legend. This is a dependency property.
LineType | Gets or sets the type of the line chart. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
PlotAreaFill | Gets or sets the background of the plot area. This is a dependency property.
PlotAreaMargin | Gets or sets the margin around the plot area. This is a dependency property.
PlotAreaStroke | Gets or sets the outline of the plot area. This is a dependency property.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. This is a dependency property.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
ScatterSize | Gets or sets the size of the scatter elements in the chart. This is a dependency property.
ScatterType | Gets or sets the scatter type of the line chart. This is a dependency property.
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)
XAxisSettings | Gets or sets the settings of the x-axis. This is a dependency property.
XData | Gets or sets the name of the property or member of the bound object, that will be used on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XInterval | Gets or sets the interval between adjacent ticks on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XLabelType | Gets or sets the type of the labels on the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMaxValue | Gets or sets the maximum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
XMinValue | Gets or sets the minimum value at the x-axis. This is a dependency property. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the settings of the y-axis. This is a dependency property.
YData | Gets or sets the name of the property or member of the bound object, that will be used on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YInterval | Gets or sets the interval between adjacent ticks on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabels | Gets or sets the name of the property or member of the bound object, that will supply the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YLabelType | Gets or sets the type of the labels on the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMaxValue | Gets or sets the maximum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)
YMinValue | Gets or sets the minimum value at the y-axis. This is a dependency property. (Inherited from AxesChart.)

See Also

LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.Foreground Property

LineChart.Foreground Property
[image]

Gets or sets the foreground of the chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }

Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.GridFill Property

LineChart.GridFill Property
[image]

Gets or sets the brush for the grid stripes. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush GridFill { get; set; }

Visual Basic [image] Copy Code

Public Property GridFill As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.GridStroke Property

LineChart.GridStroke Property
[image]

Gets or sets the brushes for the grid lines. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush GridStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GridStroke As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendDock Property

LineChart.LegendDock Property
[image]

Gets or sets the legend position relative to the chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Dock> LegendDock { get; set; }

Visual Basic [image] Copy Code

Public Property LegendDock As Nullable(Of Dock)

Property Value

A member of the Dock enumeration or null (Nothing in Visual Basic). The default is null.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendLabels Property

LineChart.LegendLabels Property
[image]

Gets or sets the labels displayed by the legend. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IList LegendLabels { get; set; }

Visual Basic [image] Copy Code

Public Property LegendLabels As IList

Property Value

A list of objects representing the labels. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LegendOrientation Property

LineChart.LegendOrientation Property
[image]

Gets or sets the orientation of the legend. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Orientation LegendOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LegendOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.LineType Property

LineChart.LineType Property
[image]

Gets or sets the type of the line chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LineType LineType { get; set; }

Visual Basic [image] Copy Code

Public Property LineType As LineType

Property Value

A member of the LineType enumeration.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaFill Property

LineChart.PlotAreaFill Property
[image]

Gets or sets the background of the plot area. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PlotAreaFill { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaFill As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaMargin Property

LineChart.PlotAreaMargin Property
[image]

Gets or sets the margin around the plot area. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness PlotAreaMargin { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaMargin As Thickness

Property Value

An instance of the Thickness structure. The default is Thickness(0).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaStroke Property

LineChart.PlotAreaStroke Property
[image]

Gets or sets the outline of the plot area. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush PlotAreaStroke { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStroke As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.PlotAreaStrokeThickness Property

LineChart.PlotAreaStrokeThickness Property
[image]

Gets or sets the thickness of the outline of the plot area. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness PlotAreaStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStrokeThickness As Thickness

Property Value

An instance of the Thickness structure. The default is Thickness(0).

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.ScatterSize Property

LineChart.ScatterSize Property
[image]

Gets or sets the size of the scatter elements in the chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As Double

Property Value

A double value specifying the size of the scatter elements. The default is 8.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.ScatterType Property

LineChart.ScatterType Property
[image]

Gets or sets the scatter type of the line chart. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

A member of the ScatterType enumeration.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.XAxisSettings Property

LineChart.XAxisSettings Property
[image]

Gets or sets the settings of the x-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public AxisSettings XAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property XAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.LineChart.YAxisSettings Property

LineChart.YAxisSettings Property
[image]

Gets or sets the settings of the y-axis. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public AxisSettings YAxisSettings { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

See Also

LineChart Members
LineChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Structure

Location Structure
[image]

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public struct Location

Visual Basic [image] Copy Code

Public Structure Location

See Also

Location Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Members

Location Members
Constructors Fields Properties Methods
[image]

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Overloaded. Initializes a new instance of the Location structure.

Public Fields

Name | Description
Empty | Represents a location that is empty.

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

Public Methods

Name | Description
Add | Adds the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Fields

Location Fields
[image]

Public Fields

Name | Description
Empty | Represents a location that is empty.

See Also

Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.Empty Field

Location.Empty Field
[image]

Represents a location that is empty.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly Location Empty

Visual Basic [image] Copy Code

Public Shared ReadOnly Empty As Location

Remarks

An instance of the Location structure representing an empty location.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Constructor

Location Constructor
[image]

Initializes a new instance of the Location structure.

Overload List

Name | Description
Location (Double, Double) | Initializes a new instance of the Location structure.
Location (Double, MeasureUnit, Double, MeasureUnit) | Initializes a new instance of the Location structure.

See Also

Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Constructor (Double, Double)

Location Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Location structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Location (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x
The x-coordinate of the new location, expressed in pixels.
y
The y-coordinate of the new location, expressed in pixels.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Constructor (Double, MeasureUnit, Double, MeasureUnit)

Location Constructor (Double, MeasureUnit, Double, MeasureUnit)
See Also
[image]

Initializes a new instance of the Location structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Location (
double x,
MeasureUnit xUnit,
double y,
MeasureUnit yUnit
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
xUnit As MeasureUnit, _
y As Double, _
yUnit As MeasureUnit _
)

Parameters

x
The x-coordinate of the new location, expressed in the units of measure specified by xUnit.
xUnit
The units of measure of the x-coordinate.
y
The y-coordinate of the new location, expressed in the units of measure specified by yUnit.
yUnit
The units of measure of the y-coordinate.

See Also

Location Constructor Overload List
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Methods

Location Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Dimension to the specified Location.
Equals | Determines if two Location structures have the same coordinates.
GetHashCode | Returns a hash code for this Location structure.
Subtract | Returns the result of subtracting specified Dimension from the specified Location.
ToString | Creates a human-readable string that represents this Location.

See Also

Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.Add Method

Location.Add Method
[image]

Adds the specified Dimension to the specified Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static Location Add (
Location location,
Dimension dimension
)

Visual Basic [image] Copy Code

Public Shared Function Add ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The source location.
dimension
The dimension to add to the source location.

Return Value

A Location object representing the result of the addition.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.Equals Method

Location.Equals Method
[image]

Determines if two Location structures have the same coordinates.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
An object to compare to this location.

Return Value

true, if obj is a Location with the same coordinates as this location; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.GetHashCode Method

Location.GetHashCode Method
[image]

Returns a hash code for this Location structure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.Subtract Method

Location.Subtract Method
[image]

Returns the result of subtracting specified Dimension from the specified Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static Location Subtract (
Location location,
Dimension dimension
)

Visual Basic [image] Copy Code

Public Shared Function Subtract ( _
location As Location, _
dimension As Dimension _
) As Location

Parameters

location
The source location.
dimension
The dimension to subtract from the source location.

Return Value

A Location object representing the result of the subtraction.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.ToString Method

Location.ToString Method
[image]

Creates a human-readable string that represents this Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A System.String.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location Properties

Location Properties
[image]

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this Location is empty.
X | Gets or sets the x-coordinate of this location.
XUnit | Gets or sets the units of measure of the x-coordinate of this Location.
Y | Gets or sets the y-coordinate of this location.
YUnit | Gets or sets the units of measure of the y-coordinate of this Location.

See Also

Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.IsEmpty Property

Location.IsEmpty Property
[image]

Gets a value indicating whether this Location is empty.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true, if the location coordinates are {0, 0}; otherwise, false.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.X Property

Location.X Property
[image]

Gets or sets the x-coordinate of this location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

The x-coordinate value of this location. The default is 0.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.XUnit Property

Location.XUnit Property
[image]

Gets or sets the units of measure of the x-coordinate of this Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As MeasureUnit

Property Value

The measure unit of the x-coordinate of this location. The default is Pixel.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.Y Property

Location.Y Property
[image]

Gets or sets the y-coordinate of this location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

The y-coordinate value of this location. The default is 0.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Location.YUnit Property

Location.YUnit Property
[image]

Gets or sets the units of measure of the y-coordinate of this Location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As MeasureUnit

Property Value

The measure unit of the y-coordinate of this location. The default is Pixel.

See Also

Location Members
Location Structure
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.MeasureUnit Enumeration

MeasureUnit Enumeration
[image]

Specifies units of measure.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public enum MeasureUnit

Visual Basic [image] Copy Code

Public Enum MeasureUnit

Members

Member name | Description
Document | Indicates that the unit of measure is the document's measure unit.
Inch | Indicates an inch as the unit of measure.
Millimeter | Indicates a millimeter as the unit of measure.
Percent | Indicates percentage relative to the total size of the containing element.
PercentRemainder | Indicates percentage relative to the remaining size of the containing element.
Pixel | Indicates a pixel as the unit of measure.
Point | Indicates a point (1/72-th of an inch) as the unit of measure.
WpfPoint | Indicates a device-independent pixel (1/96-th of an inch) as the unit of measure.

See Also

MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page Class

Page Class
[image]

Represents a page within a report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class Page : ItemWithSections

Visual Basic [image] Copy Code

Public Class Page
Inherits ItemWithSections

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemWithSections
MindFusion.Reporting.Wpf.Page

See Also

Page Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page Members

Page Members
Constructors Fields Properties Methods
[image]

Represents a page within a report.

The following tables list the members exposed by the Page type.

Public Constructors

Name | Description
Page | Initializes a new instance of the Page class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
FooterTemplateProperty | Identifies the FooterTemplate dependency property. (Inherited from ItemWithSections.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from ItemWithSections.)
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
PageOrientationProperty | Identifies the PageOrientation dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FontFamily | Gets or sets the font family of the items on the page. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of the items on the page. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of the items on the page. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of the items on the page. If the font weight is not specified, it will be inherited from the containing report.
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property. (Inherited from ItemWithSections.)
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property. (Inherited from ItemWithSections.)
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
MeasureUnit | Gets or sets the unit of measure for the items on the page. If this property is not set, its value will be inherited from the containing report.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
PageOrientation | Gets or sets the orientation of the page.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only. (Inherited from ItemWithChildren.)

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page Fields

Page Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
FooterTemplateProperty | Identifies the FooterTemplate dependency property. (Inherited from ItemWithSections.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from ItemWithSections.)
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
PageOrientationProperty | Identifies the PageOrientation dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.PageOrientationProperty Field

Page.PageOrientationProperty Field
[image]

Identifies the PageOrientation dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PageOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PageOrientationProperty As DependencyProperty

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page Constructor

Page Constructor
[image]

Initializes a new instance of the Page class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Page ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page Properties

Page Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
FontFamily | Gets or sets the font family of the items on the page. If the font family is not specified, it will be inherited from the containing report.
FontSize | Gets or sets the font size of the items on the page. If the font size is not specified, it will be inherited from the containing report.
FontStyle | Gets or sets the font style of the items on the page. If the font style is not specified, it will be inherited from the containing report.
FontWeight | Gets or sets the font weight of the items on the page. If the font weight is not specified, it will be inherited from the containing report.
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property. (Inherited from ItemWithSections.)
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property. (Inherited from ItemWithSections.)
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
MeasureUnit | Gets or sets the unit of measure for the items on the page. If this property is not set, its value will be inherited from the containing report.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
PageOrientation | Gets or sets the orientation of the page.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

See Also

Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.FontFamily Property

Page.FontFamily Property
[image]

Gets or sets the font family of the items on the page. If the font family is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

An instance of the WPF FontFamily class.

Remarks

This is a convenience property for getting and setting the Report.FontFamily attached property on this page. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.FontSize Property

Page.FontSize Property
[image]

Gets or sets the font size of the items on the page. If the font size is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value.

Remarks

This is a convenience property for getting and setting the Report.FontSize attached property on this page. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.FontStyle Property

Page.FontStyle Property
[image]

Gets or sets the font style of the items on the page. If the font style is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

An instance of the WPF FontStyle structure.

Remarks

This is a convenience property for getting and setting the Report.FontStyle attached property on this page. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.FontWeight Property

Page.FontWeight Property
[image]

Gets or sets the font weight of the items on the page. If the font weight is not specified, it will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

An instance of the WPF FontWeight structure.

Remarks

This is a convenience property for getting and setting the Report.FontWeight attached property on this page. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.MeasureUnit Property

Page.MeasureUnit Property
[image]

Gets or sets the unit of measure for the items on the page. If this property is not set, its value will be inherited from the containing report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As GraphicsUnit

Property Value

An instance of the GraphicsUnit class.

Remarks

This is a convenience property for getting and setting the Report.MeasureUnit attached property on this page. This property is inherited; that is, items which do not explicitly specify a value for it, will inherit the value from their parent item, which in turn will inherit it from its parent, and so on.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Page.PageOrientation Property

Page.PageOrientation Property
[image]

Gets or sets the orientation of the page.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<PageOrientation> PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As Nullable(Of PageOrientation)

Property Value

A member of the PageOrientation enumeration.

See Also

Page Members
Page Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageBreak Class

PageBreak Class
[image]

Represents a single line across the whole width of a page, which indicates a page break at that location.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class PageBreak : ReportItem

Visual Basic [image] Copy Code

Public Class PageBreak
Inherits ReportItem

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.PageBreak

See Also

PageBreak Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageBreak Members

PageBreak Members
Constructors Fields Properties
[image]

Represents a single line across the whole width of a page, which indicates a page break at that location.

The following tables list the members exposed by the PageBreak type.

Public Constructors

Name | Description
PageBreak | Initializes a new instance of the PageBreak class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

PageBreak Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageBreak Constructor

PageBreak Constructor
[image]

Initializes a new instance of the PageBreak class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PageBreak ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PageBreak Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageCollection Class

PageCollection Class
[image]

An observable collection of Page objects.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class PageCollection : ObservableCollection<Page>

Visual Basic [image] Copy Code

Public Class PageCollection
Inherits ObservableCollection(Of Page)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Page)
System.Collections.ObjectModel.ObservableCollection(Page)
MindFusion.Reporting.Wpf.PageCollection

See Also

PageCollection Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageCollection Members

PageCollection Members
Constructors
[image]

An observable collection of Page objects.

The following tables list the members exposed by the PageCollection type.

Public Constructors

Name | Description
PageCollection |

See Also

PageCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageCollection Constructor

PageCollection Constructor
[image]

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PageCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PageCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PageOrientation Enumeration

PageOrientation Enumeration
[image]

Specifies the orientation of a printed page.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public enum PageOrientation

Visual Basic [image] Copy Code

Public Enum PageOrientation

Members

Member name | Description
Landscape | Indicates landscape orientation.
Portrait | Indicates portrait orientation.

See Also

MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture Class

Picture Class
Remarks See Also
[image]

Represents a report element that displays an image.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class Picture : ReportItem

Visual Basic [image] Copy Code

Public Class Picture
Inherits ReportItem

Remarks

In order to associate an image with the Picture element, assign any WPF System.Windows.Media.ImageSource object to its Image property. The stretching and alignment of the displayed image can be specified through the HorizontalAlignment and VerticalAlignment properties.

Alternatively, pictures can be bound to fields in a data source. To do this, the picture must be placed in a data-bound context and its Image property must be bound to the respective data field using standard WPF bindings.

Example

The following sample code demonstrates the use of Picture objects in XAML:

XAML [image] Copy Code

<r:Report x:Name="ProductCategories">
<r:Report.Resources>
<l:ByteToPictureConverter x:Key="PictureConverter" />
</r:Report.Resources>
<r:Page>
<r:DataRange DataSource="{Binding Categories}" Size="160,160" Background="#F5E49C" ArrangeByX="True" Margin="0,0,5,5" >
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Text="{Binding CategoryName}" Size="100%,15" HorizontalAlignment="Center" VerticalAlignment="Center" />
<r:Picture Image="{Binding Picture, Converter={StaticResource PictureConverter}}" Location="5,15" Size="150,150" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
</r:Page>
</r:Report>

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Picture

See Also

Picture Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture Members

Picture Members
Constructors Fields Properties
[image]

Represents a report element that displays an image.

The following tables list the members exposed by the Picture type.

Public Constructors

Name | Description
Picture | Initializes a new instance of the Picture class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ImageProperty | Identifies the Image dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Image | Gets or sets the image displayed by this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture Fields

Picture Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
ImageProperty | Identifies the Image dependency property.
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture.ImageProperty Field

Picture.ImageProperty Field
[image]

Identifies the Image dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ImageProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ImageProperty As DependencyProperty

See Also

Picture Members
Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture Constructor

Picture Constructor
[image]

Initializes a new instance of the Picture class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Picture ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture Properties

Picture Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Image | Gets or sets the image displayed by this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Picture.Image Property

Picture.Image Property
[image]

Gets or sets the image displayed by this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

A WPF ImageSource object.

See Also

Picture Members
Picture Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart Class

PieChart Class
Remarks See Also
[image]

Renders a bound dataset as a pie chart.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class PieChart : Chart ReportItem

Visual Basic [image] Copy Code

Public Class PieChart
Inherits Chart ReportItem

Remarks

The pie chart displays the data specified by the DataSource property. If DataSource is null (Nothing in Visual Basic) the PieChart raises the QueryDetails event of its containing report passing its DataContext as a master row and uses the return IEnumeration as data source. If QueryDetails did not yield any details, the DataContext is used as a data source.

The TargetMember property specifies the property of the objects in the data source, which will be used for pie plotting.

Example

Let Simple is a class defined as following:

C# [image] Copy Code

public class Simple
{
public int IntField
{
get;
set;
}

public string StringField
{
get;
set;
}
}

Visual Basic [image] Copy Code

Public Class Simple

Public Property IntField() As Integer

Get
Return _intField
End Get
Set(ByVal value As Integer)
_intField = value
End Set

End Property

Public Property StringField() As String

Get
Return _stringField
End Get
Set(ByVal value As String)
_stringField = value
End Set

End Property

Private _intField As Integer
Private _stringField As String

End Class

Let us have the following static definition of an array of Simple objects, defined in XAML:

XAML [image] Copy Code

<x:ArrayExtension Type="{x:Type l:Simple}" x:Key="data">
<l:Simple IntField="1" StringField="Item #1" />
<l:Simple IntField="15" StringField="Item #2" />
<l:Simple IntField="32" StringField="Item #3" />
<l:Simple IntField="44" StringField="Item #4" />
<l:Simple IntField="28" StringField="Item #5" />
<l:Simple IntField="61" StringField="Item #6" />
</x:ArrayExtension>

Then we can define a simple PieChart showing the above array as following:

XAML [image] Copy Code

<r:PieChart DataContext="{StaticResource data}" TargetMember="IntField" Size="200,200" PieStroke="Black" PieStrokeThickness="1" />

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.PieChart

See Also

PieChart Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart Members

PieChart Members
Constructors Fields Properties
[image]

Renders a bound dataset as a pie chart.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Initializes a new instance of the PieChart class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PaddingProperty | Identifies the Padding dependency property.
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TargetMemberProperty | Identifies the TargetMember dependency property.
TitleMemberProperty | Identifies the TitleMember dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
InnerLabelLocation | Gets or sets the location of the inner label. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.
OuterLabelType | Gets or sets the type of the outer labels. This is a dependency property.
Padding | Gets or sets the distance between the chart's contents and the chart bounds. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
TargetMember | Gets or sets the name of the property or member of the bound object, that will be plotted. This is a dependency property.
TitleMember | Gets or sets the name of the property or member of the bound object, that contains a title for the plotted value. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart Fields

PieChart Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
BrushesProperty | Identifies the Brushes dependency property. (Inherited from Chart.)
ChartBrushProperty | Identifies the ChartBrush dependency property. (Inherited from Chart.)
ChartStrokeProperty | Identifies the ChartStroke dependency property. (Inherited from Chart.)
ChartStrokeThicknessProperty | Identifies the ChartStrokeThickness dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from Chart.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PaddingProperty | Identifies the Padding dependency property.
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
TargetMemberProperty | Identifies the TargetMember dependency property.
TitleMemberProperty | Identifies the TitleMember dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

See Also

PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.InnerLabelLocationProperty Field

PieChart.InnerLabelLocationProperty Field
[image]

Identifies the InnerLabelLocation dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelLocationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelLocationProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.InnerLabelTypeProperty Field

PieChart.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.OuterLabelOffsetProperty Field

PieChart.OuterLabelOffsetProperty Field
[image]

Identifies the OuterLabelOffset dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelOffsetProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.OuterLabelTypeProperty Field

PieChart.OuterLabelTypeProperty Field
[image]

Identifies the OuterLabelType dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelTypeProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.PaddingProperty Field

PieChart.PaddingProperty Field
[image]

Identifies the Padding dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.TargetMemberProperty Field

PieChart.TargetMemberProperty Field
[image]

Identifies the TargetMember dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TargetMemberProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TargetMemberProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.TitleMemberProperty Field

PieChart.TitleMemberProperty Field
[image]

Identifies the TitleMember dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleMemberProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleMemberProperty As DependencyProperty

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart Constructor

PieChart Constructor
[image]

Initializes a new instance of the PieChart class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PieChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart Properties

PieChart Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
Brushes | Gets or sets the brushes used to fill the chart elements. This is a dependency property. (Inherited from Chart.)
ChartBrush | Gets or sets the default brush used to fill individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStroke | Gets or sets the brush used to stroke individual chart pieces. This is a dependency property. (Inherited from Chart.)
ChartStrokeThickness | Gets or sets the stroke thickness of the individual chart pieces. This is a dependency property. (Inherited from Chart.)
DataSource | Gets or sets the data source of this chart. This is a dependency property. (Inherited from Chart.)
InnerLabelLocation | Gets or sets the location of the inner label. This is a dependency property.
InnerLabelType | Gets or sets the type of the inner labels. This is a dependency property.
LabelBackground | Gets or sets the brush for the background of the chart's labels. This is a dependency property. (Inherited from Chart.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.
OuterLabelType | Gets or sets the type of the outer labels. This is a dependency property.
Padding | Gets or sets the distance between the chart's contents and the chart bounds. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
TargetMember | Gets or sets the name of the property or member of the bound object, that will be plotted. This is a dependency property.
TitleMember | Gets or sets the name of the property or member of the bound object, that contains a title for the plotted value. This is a dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

See Also

PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.InnerLabelLocation Property

PieChart.InnerLabelLocation Property
[image]

Gets or sets the location of the inner label. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double InnerLabelLocation { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelLocation As Double

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.InnerLabelType Property

PieChart.InnerLabelType Property
[image]

Gets or sets the type of the inner labels. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.OuterLabelOffset Property

PieChart.OuterLabelOffset Property
[image]

Gets or sets the offset of the outer label from the edge of the pie. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double OuterLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelOffset As Double

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.OuterLabelType Property

PieChart.OuterLabelType Property
[image]

Gets or sets the type of the outer labels. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.Padding Property

PieChart.Padding Property
[image]

Gets or sets the distance between the chart's contents and the chart bounds. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Thickness

Property Value

A WPF Thickness specifying the distance between the pie and the border of the chart.

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.TargetMember Property

PieChart.TargetMember Property
[image]

Gets or sets the name of the property or member of the bound object, that will be plotted. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string TargetMember { get; set; }

Visual Basic [image] Copy Code

Public Property TargetMember As String

Property Value

A string value specifying the name of a property.

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PieChart.TitleMember Property

PieChart.TitleMember Property
[image]

Gets or sets the name of the property or member of the bound object, that contains a title for the plotted value. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string TitleMember { get; set; }

Visual Basic [image] Copy Code

Public Property TitleMember As String

Property Value

See Also

PieChart Members
PieChart Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs Class

PrerenderEventArgs Class
[image]

Provides data for the Prerender event of the Report class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class PrerenderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class PrerenderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Wpf.PrerenderEventArgs

See Also

PrerenderEventArgs Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs Members

PrerenderEventArgs Members
Constructors Properties
[image]

Provides data for the Prerender event of the Report class.

The following tables list the members exposed by the PrerenderEventArgs type.

Public Constructors

Name | Description
PrerenderEventArgs | Initializes a new instance of the PrerenderEventArgs class.

Public Properties

Name | Description
Item | Gets the item being rendered.
RootVisual | Gets or sets the visual representing the item in the rendering.
Size | Gets the size of this item in the report layout.
SkipRender | Gets or sets a value indicating whether to cancel the rendering of this item.

See Also

PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs Constructor

PrerenderEventArgs Constructor
[image]

Initializes a new instance of the PrerenderEventArgs class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PrerenderEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs Properties

PrerenderEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item being rendered.
RootVisual | Gets or sets the visual representing the item in the rendering.
Size | Gets the size of this item in the report layout.
SkipRender | Gets or sets a value indicating whether to cancel the rendering of this item.

See Also

PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs.Item Property

PrerenderEventArgs.Item Property
[image]

Gets the item being rendered.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As ReportItem

Property Value

A reference to the ReportItem being rendered.

See Also

PrerenderEventArgs Members
PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs.RootVisual Property

PrerenderEventArgs.RootVisual Property
[image]

Gets or sets the visual representing the item in the rendering.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public UIElement RootVisual { get; set; }

Visual Basic [image] Copy Code

Public Property RootVisual As UIElement

Property Value

A WPF UIElement object.

Remarks

The UIElement returned by this property represents the visual appearance of the item in the final report. The properties of the UIElement can be modified in order to customize the item appearance. The UIElement can also be replaced but the size of the new element will not affect the current report layout. Therefore it is advisable that the new element has the same size as the existing element, as specified by Size.

The structure of the RootVisual depends on the type of the report item being rendered. The following table lists the structure of the RootVisual corresponding to different report items.

Report Item | RootVisual
CustomReportItem | <ContentControl />
ItemContainer | <Border />
Label | <Border> <TextBlock /> </Border>
Page | <Border />
Picture | <Border> <Image /> </Border>
PieChart | <PieChart />

See Also

PrerenderEventArgs Members
PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs.Size Property

PrerenderEventArgs.Size Property
[image]

Gets the size of this item in the report layout.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Size Size { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Size As Size

Property Value

A WPF Size object.

See Also

PrerenderEventArgs Members
PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.PrerenderEventArgs.SkipRender Property

PrerenderEventArgs.SkipRender Property
[image]

Gets or sets a value indicating whether to cancel the rendering of this item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool SkipRender { get; set; }

Visual Basic [image] Copy Code

Public Property SkipRender As Boolean

Property Value

true, to cancel the rendering of this item; otherwise, false.

Remarks

This property can be used to deliberately prevent some items from being rendered based on various criteria. Setting this property to false does not effect the report layout, that is, the item is considered hidden, but not collapsed.

See Also

PrerenderEventArgs Members
PrerenderEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.QueryDetailsEventArgs Class

QueryDetailsEventArgs Class
[image]

Provides data for the QueryDetails event of the Report class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class QueryDetailsEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class QueryDetailsEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Wpf.QueryDetailsEventArgs

See Also

QueryDetailsEventArgs Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.QueryDetailsEventArgs Members

QueryDetailsEventArgs Members
Properties
[image]

Provides data for the QueryDetails event of the Report class.

The following tables list the members exposed by the QueryDetailsEventArgs type.

Public Properties

Name | Description
Details | Gets or sets an object representing the details of the supplied master row.
MasterRow | Gets the master row, whose details are being queried.

See Also

QueryDetailsEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.QueryDetailsEventArgs Properties

QueryDetailsEventArgs Properties
[image]

Public Properties

Name | Description
Details | Gets or sets an object representing the details of the supplied master row.
MasterRow | Gets the master row, whose details are being queried.

See Also

QueryDetailsEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.QueryDetailsEventArgs.Details Property

QueryDetailsEventArgs.Details Property
[image]

Gets or sets an object representing the details of the supplied master row.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable Details { get; set; }

Visual Basic [image] Copy Code

Public Property Details As IEnumerable

Property Value

An IEnumeration object representing the details of the master row specified by MasterRow.

See Also

QueryDetailsEventArgs Members
QueryDetailsEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.QueryDetailsEventArgs.MasterRow Property

QueryDetailsEventArgs.MasterRow Property
[image]

Gets the master row, whose details are being queried.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Object MasterRow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MasterRow As Object

Property Value

An object representing the master row.

See Also

QueryDetailsEventArgs Members
QueryDetailsEventArgs Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Class

Report Class
Remarks See Also
[image]

Represents a report, which can be previewed, printed or exported.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class Report : FrameworkElement

Visual Basic [image] Copy Code

Public Class Report
Inherits FrameworkElement

Remarks

You can create new reports by instantiating from this class. New pages can be added to the report by creating Page objects and adding them to the report's Pages collection. Items are added to the Report indirectly by adding them to one of the pages contained in the report.

Creating reports in XAML

MindFusion reports can be created declaratively, in XAML. The code of a very simple report is displayed below:

XAML [image] Copy Code

<r:Report x:Name="myReport">
<r:Page>
<r:DataRange Repeat="10" Size="100,20" Background="#f1faff" BorderBrush="Black" BorderThickness="1">
<r:DataRange.ItemTemplate>
<DataTemplate>
<r:ItemContainer>
<r:Label Size="100,20" Text="Item #[RangeItemCurrent()]" Padding="1" />
</r:ItemContainer>
</DataTemplate>
</r:DataRange.ItemTemplate>
</r:DataRange>
</r:Page>
</r:Report>

In the above example the r namespace is declared as follows:

XAML [image] Copy Code

xmlns:r="http://mindfusion.eu/reporting/wpf"

Running the report

Once the report is initialized, you need to process it by calling its Run method. After the report has been processed it is ready to be used in various scenarios.

The report can be printed or previewed by using a ReportPrinter object. For details, check Printing and Print Previewing.

The report can be displayed in a Window by rendering it using a FixedDocumentRenderTarget and displaying the resulting document using a DocumentViewer.

The report can be exported by implementing the IRenderTarget interface. For more information, check Exporting Reports.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.Report

See Also

Report Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Members

Report Members
Constructors Fields Attached Properties Properties Methods Events
[image]

Represents a report, which can be previewed, printed or exported.

The following tables list the members exposed by the Report type.

Public Constructors

Name | Description
Report | Initializes a new instance of the Report class.

Public Fields

Name | Description
CultureInfoProperty | Identifies the CultureInfo dependency property.
FontFamilyProperty | Identifies the FontFamily attached property.
FontSizeProperty | Identifies the FontSize attached property.
FontStyleProperty | Identifies the FontStyle attached property.
FontWeightProperty | Identifies the FontWeight attached property.
MeasureUnitProperty | Identifies the MeasureUnit attached property.
PagesProperty | Identifies the Pages dependency property.

Public Attached Properties

Name | Description
FontFamilyProperty | Gets or sets the font family of a report item.
FontSizeProperty | Gets or sets the font size of a report item.
FontStyleProperty | Gets or sets the font style of a report item.
FontWeightProperty | Gets or sets the font weight of a report item.
MeasureUnitProperty | Gets or sets the units of measure of a report item.

Public Properties

Name | Description
CultureInfo | Gets or sets the contextual CultureInfo this report will work in. This is a dependency property.
FontFamily | Gets or sets the default font family of the elements of this report.
FontSize | Gets or sets the default font size of the elements of this report.
FontStyle | Gets or sets the default font style of the elements of this report.
FontWeight | Gets or sets the default font weight of the elements of this report.
IsRun | Gets a value indicating whether the report has been run and ready for layouting.
MeasureUnit | Gets or sets the default units of measure of the report's elements who do not explicitly specify units.
Pages | Gets or sets the pages contained in the report. This is a dependency property.
Parameters | Gets or sets a list with the report parameters.

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

Public Methods

Name | Description
FindItem | Searches for the report item with the specified name.
FromDictionary | Initializes a new instance of the Report class from the resource identified by the specified key in the dictionary with the specified Uri.
GetFontFamily | Gets the value of the Report.FontFamily attached property for a given dependency object.
GetFontSize | Gets the value of the Report.FontSize attached property for a given dependency object.
GetFontStyle | Gets the value of the Report.FontStyle attached property for a given dependency object.
GetFontWeight | Gets the value of the Report.FontWeight attached property for a given dependency object.
GetMeasureUnit | Gets the value of the Report.MeasureUnit attached property for a given dependency object.
Layout | Layouts the report on a page with the specified size, margin and orientation.
Run | Executes the report.
SetFontFamily | Sets the value of the Report.FontFamily attached property for a given dependency object.
SetFontSize | Sets the value of the Report.FontSize attached property for a given dependency object.
SetFontStyle | Sets the value of the Report.FontStyle attached property for a given dependency object.
SetFontWeight | Sets the value of the Report.FontWeight attached property for a given dependency object.
SetMeasureUnit | Sets the value of the Report.MeasureUnit attached property for a given dependency object.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override.
OnPrerender | Raises the Prerender event.
OnQueryDetails | Raises the QueryDetails event.
OnReportRun | Fires the ReportRun event.

Public Events

Name | Description
Prerender | Raised for each item in the report just before the item is added to the visual tree during rendering.
QueryDetails | Raised for items participating in a Master-Detail relationship in order to obtain the Details source.
ReportRun | Raised after the report has been processed using the Run method.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Fields

Report Fields
[image]

Public Fields

Name | Description
CultureInfoProperty | Identifies the CultureInfo dependency property.
FontFamilyProperty | Identifies the FontFamily attached property.
FontSizeProperty | Identifies the FontSize attached property.
FontStyleProperty | Identifies the FontStyle attached property.
FontWeightProperty | Identifies the FontWeight attached property.
MeasureUnitProperty | Identifies the MeasureUnit attached property.
PagesProperty | Identifies the Pages dependency property.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.CultureInfoProperty Field

Report.CultureInfoProperty Field
[image]

Identifies the CultureInfo dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CultureInfoProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CultureInfoProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontFamilyProperty Field

Report.FontFamilyProperty Field
[image]

Identifies the FontFamily attached property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontFamilyProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontSizeProperty Field

Report.FontSizeProperty Field
[image]

Identifies the FontSize attached property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontStyleProperty Field

Report.FontStyleProperty Field
[image]

Identifies the FontStyle attached property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontStyleProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontWeightProperty Field

Report.FontWeightProperty Field
[image]

Identifies the FontWeight attached property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontWeightProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.MeasureUnitProperty Field

Report.MeasureUnitProperty Field
[image]

Identifies the MeasureUnit attached property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MeasureUnitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MeasureUnitProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.PagesProperty Field

Report.PagesProperty Field
[image]

Identifies the Pages dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PagesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PagesProperty As DependencyProperty

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Constructor

Report Constructor
[image]

Initializes a new instance of the Report class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Report ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Methods

Report Methods
[image]

Public Methods

Name | Description
FindItem | Searches for the report item with the specified name.
FromDictionary | Initializes a new instance of the Report class from the resource identified by the specified key in the dictionary with the specified Uri.
GetFontFamily | Gets the value of the Report.FontFamily attached property for a given dependency object.
GetFontSize | Gets the value of the Report.FontSize attached property for a given dependency object.
GetFontStyle | Gets the value of the Report.FontStyle attached property for a given dependency object.
GetFontWeight | Gets the value of the Report.FontWeight attached property for a given dependency object.
GetMeasureUnit | Gets the value of the Report.MeasureUnit attached property for a given dependency object.
Layout | Layouts the report on a page with the specified size, margin and orientation.
Run | Executes the report.
SetFontFamily | Sets the value of the Report.FontFamily attached property for a given dependency object.
SetFontSize | Sets the value of the Report.FontSize attached property for a given dependency object.
SetFontStyle | Sets the value of the Report.FontStyle attached property for a given dependency object.
SetFontWeight | Sets the value of the Report.FontWeight attached property for a given dependency object.
SetMeasureUnit | Sets the value of the Report.MeasureUnit attached property for a given dependency object.

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override.
OnPrerender | Raises the Prerender event.
OnQueryDetails | Raises the QueryDetails event.
OnReportRun | Fires the ReportRun event.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FindItem Method

Report.FindItem Method
[image]

Searches for the report item with the specified name.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportItem FindItem (
string name
)

Visual Basic [image] Copy Code

Public Function FindItem( _
name As String _
) As ReportItem

Parameters

name

The name of the item to find.

Return Value

The found item.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FromDictionary Method

Report.FromDictionary Method
[image]

Initializes a new instance of the Report class from the resource identified by the specified key in the dictionary with the specified Uri.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static Report FromDictionary (
Uri uri,
string key
)

Visual Basic [image] Copy Code

Public Shared Function FromDictionary ( _
uri As Uri, _
key As String _
) As Report

Parameters

uri
The Uri of the dictionary containing the report.
key

The key of the report.

Return Value

The report with the specified key.

Remarks

This is a convenience method, which facilitates Report loading from resource dictionaries. The method will throw an exception if either uri does not resolve to a ResourceDictionary or the dictionary does not contain a report with the specified key.

Example

Assuming that there is a resource dictionary MyReport.xaml in the current application, which contains a report resource with key simpleReport, the following code loads the report from the dictionary:

C# [image] Copy Code
var report = Report.FromDictionary(new Uri(@"MyReport.xaml", UriKind.Relative), "simpleReport");

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.GetFontFamily Method

Report.GetFontFamily Method
[image]

Gets the value of the Report.FontFamily attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static FontFamily GetFontFamily (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetFontFamily( _
target As DependencyObject _
) As FontFamily

Parameters

target

The element from which the property value is read.

Return Value

The value of the FontFamily property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
SetFontFamily Method


MindFusion.Reporting.Wpf.Report.GetFontSize Method

Report.GetFontSize Method
[image]

Gets the value of the Report.FontSize attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static double GetFontSize (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetFontSize( _
target As DependencyObject _
) As Double

Parameters

target

The element from which the property value is read.

Return Value

The value of the FontSize property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
SetFontSize Method


MindFusion.Reporting.Wpf.Report.GetFontStyle Method

Report.GetFontStyle Method
[image]

Gets the value of the Report.FontStyle attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static FontStyle GetFontStyle (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetFontStyle( _
target As DependencyObject _
) As FontStyle

Parameters

target

The element from which the property value is read.

Return Value

The value of the FontStyle property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
SetFontStyle Method


MindFusion.Reporting.Wpf.Report.GetFontWeight Method

Report.GetFontWeight Method
[image]

Gets the value of the Report.FontWeight attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static FontWeight GetFontWeight (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetFontWeight( _
target As DependencyObject _
) As FontWeight

Parameters

target

The element from which the property value is read.

Return Value

The value of the FontWeight property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
SetFontWeight Method


MindFusion.Reporting.Wpf.Report.GetMeasureUnit Method

Report.GetMeasureUnit Method
[image]

Gets the value of the Report.MeasureUnit attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static GraphicsUnit GetMeasureUnit (
DependencyObject target
)

Visual Basic [image] Copy Code

Public Shared Function GetMeasureUnit ( _
target As DependencyObject _
) As GraphicsUnit

Parameters

target

The element from which the property value is read.

Return Value

The value of the MeasureUnit property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
SetMeasureUnit Method


MindFusion.Reporting.Wpf.Report.GetVisualChild Method

Report.GetVisualChild Method
[image]

FrameworkElement.GetVisualChild override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected override Visual GetVisualChild (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Function GetVisualChild( _
index As Integer _
) As Visual

Parameters

index
The zero-based index of the requested child element in the collection.

Return Value

The requested child element. If the provided index is out of range, an exception is thrown.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.Layout Method

Report.Layout Method
[image]

Layouts the report on a page with the specified size, margin and orientation.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportLayout Layout (
Size paperSize,
Thickness margin,
PageOrientation defaultOrientation
)

Visual Basic [image] Copy Code

Public Function Layout ( _
paperSize As Size, _
margin As Thickness, _
defaultOrientation As PageOrientation _
) As ReportLayout

Parameters

paperSize

The size of the paper.

margin

The distance between the paper border and contents.

defaultOrientation

The page orientation.

Return Value

An object encapsulating information about the layout of this report on paper with the specified attributes. This object can be used to render the report.

Remarks

Calling this method on a report which has not been processed by a call to its Run method will result in an InvalidOperationException.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
Run Method


MindFusion.Reporting.Wpf.Report.OnPrerender Method

Report.OnPrerender Method
[image]

Raises the Prerender event.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPrerender (
Object sender,
PrerenderEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPrerender ( _
sender As Object, _
e As PrerenderEventArgs _
)

Parameters

sender

The original source of the event.

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.OnQueryDetails Method

Report.OnQueryDetails Method
[image]

Raises the QueryDetails event.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnQueryDetails (
Object sender,
QueryDetailsEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnQueryDetails ( _
sender As Object, _
e As QueryDetailsEventArgs _
)

Parameters

sender

The original source of the event.

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.OnReportRun Method

Report.OnReportRun Method
[image]

Fires the ReportRun event.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnReportRun (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnReportRun( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.Run Method

Report.Run Method
[image]

Executes the report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void Run ()

Visual Basic [image] Copy Code

Public Sub Run ()

Remarks

This method perform various internal processing and is required to call before doing layouting of a Report. The report needs to be run only once (unless its structure is changed dynamically afterwards) and can be subsequently laid out multiple times on papers with different sizes and orientations.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
Layout Method


MindFusion.Reporting.Wpf.Report.SetFontFamily Method

Report.SetFontFamily Method
[image]

Sets the value of the Report.FontFamily attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static void SetFontFamily (
DependencyObject target,
FontFamily value
)

Visual Basic [image] Copy Code

Public Shared Sub SetFontFamily( _
target As DependencyObject, _
value As FontFamily _
)

Parameters

target

The element to which the property value is written.

value
The new value for the FontFamily property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
GetFontFamily Method


MindFusion.Reporting.Wpf.Report.SetFontSize Method

Report.SetFontSize Method
[image]

Sets the value of the Report.FontSize attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static void SetFontSize (
DependencyObject target,
double value
)

Visual Basic [image] Copy Code

Public Shared Sub SetFontSize( _
target As DependencyObject, _
value As Double _
)

Parameters

target

The element to which the property value is written.

value
The new value for the FontSize property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
GetFontSize Method


MindFusion.Reporting.Wpf.Report.SetFontStyle Method

Report.SetFontStyle Method
[image]

Sets the value of the Report.FontStyle attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static void SetFontStyle (
DependencyObject target,
FontStyle value
)

Visual Basic [image] Copy Code

Public Shared Sub SetFontStyle( _
target As DependencyObject, _
value As FontStyle _
)

Parameters

target

The element to which the property value is written.

value
The new value for the FontStyle property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
GetFontStyle Method


MindFusion.Reporting.Wpf.Report.SetFontWeight Method

Report.SetFontWeight Method
[image]

Sets the value of the Report.FontWeight attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static void SetFontWeight (
DependencyObject target,
FontWeight value
)

Visual Basic [image] Copy Code

Public Shared Sub SetFontWeight( _
target As DependencyObject, _
value As FontWeight _
)

Parameters

target

The element to which the property value is written.

value
The new value for the FontWeight property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
GetFontWeight Method


MindFusion.Reporting.Wpf.Report.SetMeasureUnit Method

Report.SetMeasureUnit Method
[image]

Sets the value of the Report.MeasureUnit attached property for a given dependency object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static void SetMeasureUnit (
DependencyObject target,
GraphicsUnit value
)

Visual Basic [image] Copy Code

Public Shared Sub SetMeasureUnit ( _
target As DependencyObject, _
value As GraphicsUnit _
)

Parameters

target

The element to which the property value is written.

value
The new value for the MeasureUnit property for the specified element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
GetMeasureUnit Method


MindFusion.Reporting.Wpf.Report Attached Properties

Report Attached Properties
[image]

Public Attached Properties

Name | Description
FontFamilyProperty | Gets or sets the font family of a report item.
FontSizeProperty | Gets or sets the font size of a report item.
FontStyleProperty | Gets or sets the font style of a report item.
FontWeightProperty | Gets or sets the font weight of a report item.
MeasureUnitProperty | Gets or sets the units of measure of a report item.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontFamily Attached Property

Report.FontFamily Attached Property
[image]

Gets or sets the font family of a report item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code
See Report.GetFontFamily, Report.SetFontFamily
Visual Basic [image] Copy Code
See Report.GetFontFamily, Report.SetFontFamily

Property Value

A WPF FontFamily object. The default value is Arial.

Dependency Property Information

Identifier Field | FontFamilyProperty
Metadata Flags | Inherits

Remarks

This property inherits across the report hierarchy. Elements which do not have this property explicitly set will inherit its value from their parent elements.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontSize Attached Property

Report.FontSize Attached Property
[image]

Gets or sets the font size of a report item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code
See Report.GetFontSize, Report.SetFontSize
Visual Basic [image] Copy Code
See Report.GetFontSize, Report.SetFontSize

Property Value

A double value. The default value is 10.

Dependency Property Information

Identifier Field | FontSizeProperty
Metadata Flags | Inherits

Remarks

This property inherits across the report hierarchy. Elements which do not have this property explicitly set will inherit its value from their parent elements.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontStyle Attached Property

Report.FontStyle Attached Property
[image]

Gets or sets the font style of a report item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code
See Report.GetFontStyle, Report.SetFontStyle
Visual Basic [image] Copy Code
See Report.GetFontStyle, Report.SetFontStyle

Property Value

A WPF FontStyle object. The default value is Normal.

Dependency Property Information

Identifier Field | FontStyleProperty
Metadata Flags | Inherits

Remarks

This property inherits across the report hierarchy. Elements which do not have this property explicitly set will inherit its value from their parent elements.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontWeight Attached Property

Report.FontWeight Attached Property
[image]

Gets or sets the font weight of a report item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code
See Report.GetFontWeight, Report.SetFontWeight
Visual Basic [image] Copy Code
See Report.GetFontWeight, Report.SetFontWeight

Property Value

A WPF FontWeight object. The default value is Normal.

Dependency Property Information

Identifier Field | FontWeightProperty
Metadata Flags | Inherits

Remarks

This property inherits across the report hierarchy. Elements which do not have this property explicitly set will inherit its value from their parent elements.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.MeasureUnit Attached Property

Report.MeasureUnit Attached Property
[image]

Gets or sets the units of measure of a report item.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code
See Report.GetMeasureUnit, Report.SetMeasureUnit
Visual Basic [image] Copy Code
See Report.GetMeasureUnit, Report.SetMeasureUnit

Property Value

A GraphicsUnit object. The default value is WpfPoint.

Dependency Property Information

Identifier Field | MeasureUnitProperty
Metadata Flags | Inherits

Remarks

This property inherits across the report hierarchy. Elements which do not have this property explicitly set will inherit its value from their parent elements.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Properties

Report Properties
[image]

Public Properties

Name | Description
CultureInfo | Gets or sets the contextual CultureInfo this report will work in. This is a dependency property.
FontFamily | Gets or sets the default font family of the elements of this report.
FontSize | Gets or sets the default font size of the elements of this report.
FontStyle | Gets or sets the default font style of the elements of this report.
FontWeight | Gets or sets the default font weight of the elements of this report.
IsRun | Gets a value indicating whether the report has been run and ready for layouting.
MeasureUnit | Gets or sets the default units of measure of the report's elements who do not explicitly specify units.
Pages | Gets or sets the pages contained in the report. This is a dependency property.
Parameters | Gets or sets a list with the report parameters.

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChildrenCount override.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.CultureInfo Property

Report.CultureInfo Property
[image]

Gets or sets the contextual CultureInfo this report will work in. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public CultureInfo CultureInfo { get; set; }

Visual Basic [image] Copy Code

Public Property CultureInfo As CultureInfo

Property Value

A CultureInfo object.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontFamily Property

Report.FontFamily Property
[image]

Gets or sets the default font family of the elements of this report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

A WPF FontFamily object.

Remarks

The value of this property is inherited by the report's children. Therefore report items, which do not specify a value for this property explicitly, will have the report's FontFamily as a default.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontSize Property

Report.FontSize Property
[image]

Gets or sets the default font size of the elements of this report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value.

Remarks

The value of this property is inherited by the report's children. Therefore report items, which do not specify a value for this property explicitly, will have the report's FontSize as a default.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontStyle Property

Report.FontStyle Property
[image]

Gets or sets the default font style of the elements of this report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A WPF FontStyle object.

Remarks

The value of this property is inherited by the report's children. Therefore report items, which do not specify a value for this property explicitly, will have the report's FontStyle as a default.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.FontWeight Property

Report.FontWeight Property
[image]

Gets or sets the default font weight of the elements of this report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A WPF FontWeight object.

Remarks

The value of this property is inherited by the report's children. Therefore report items, which do not specify a value for this property explicitly, will have the report's FontWeight as a default.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.IsRun Property

Report.IsRun Property
[image]

Gets a value indicating whether the report has been run and ready for layouting.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool IsRun { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsRun As Boolean

Property Value

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.MeasureUnit Property

Report.MeasureUnit Property
[image]

Gets or sets the default units of measure of the report's elements who do not explicitly specify units.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public GraphicsUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As GraphicsUnit

Property Value

An instance of the GraphicsUnit class.

Remarks

This property specifies the default unit of measure in the report. If the location or size of a report item do not have explicit unit of measure, this value will be used.

Example

Consider for example the following report, declared in XAML:

XAML [image] Copy Code

<r:Report MeasureUnit="Millimeter">
<r:Page>
<r:Label Text="I use the report's unit of measure for my size."
Location="0,0" Size="100,20" Background="PaleGoldenrod" />
<r:Label Text="I use 1/72-th of an inch as units of measure for my size."
Location="0,30" Size="100pt,20pt" Background="PaleVioletRed" />
</r:Page>
</r:Report>

The size of the first label does not explicitly specify units of measure therefore it will use the report's units of measure - millimeters and the labels size will be 100x20 millimeters. The second label explicitly specifies points as units of measure for its size, therefore its size will be 100x20 points.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.Pages Property

Report.Pages Property
[image]

Gets or sets the pages contained in the report. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PageCollection Pages { get; set; }

Visual Basic [image] Copy Code

Public Property Pages As PageCollection

Property Value

An instance of the PageCollection class containing the pages in the report.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.Parameters Property

Report.Parameters Property
[image]

Gets or sets a list with the report parameters.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public List<ReportParameter> Parameters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parameters As List(Of ReportParameter)

Property Value

A list of ReportParameter objects.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.VisualChildrenCount Property

Report.VisualChildrenCount Property
[image]

FrameworkElement.VisualChildrenCount override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected override int VisualChildrenCount { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property VisualChildrenCount As Integer

Property Value

The number of visual child elements for this element.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report Events

Report Events
[image]

Public Events

Name | Description
Prerender | Raised for each item in the report just before the item is added to the visual tree during rendering.
QueryDetails | Raised for items participating in a Master-Detail relationship in order to obtain the Details source.
ReportRun | Raised after the report has been processed using the Run method.

See Also

Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.Prerender Event

Report.Prerender Event
[image]

Raised for each item in the report just before the item is added to the visual tree during rendering.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PrerenderEventArgs> Prerender

Visual Basic [image] Copy Code

Public Event Prerender As EventHandler(Of PrerenderEventArgs)

Remarks

This event can be used to prevent the rendering of specific items or to modify their visual representation based on custom criteria. The event is raised after the visual representation of an item is created but before it is added to the visual tree of the final report.

The event argument supplies a reference to the ReportItem being rendered and a reference to the root UIElement of the item's visual tree. The visual tree of the item can be modified or completely replaced through this event.

Example

The following code illustrates how to use this event in order to change the background of an ItemContainer object. The ItemContainer objects are used as a container for all items in a single row entry within a DataRange.

C# [image] Copy Code

private void myReport_Prerender(object sender, PrerenderEventArgs e)
{
if (e.Item is ItemContainer)
{
if (someCondition)
{
var border = e.RootVisual as Border;
border.Background = new SolidColorBrush(Colors.Red);
}
}
}

Visual Basic [image] Copy Code

Private Sub myReport_Prerender(ByVal sender As Object, ByVal e As PrerenderEventArgs)

If (TypeOf e.Item Is ItemContainer) Then

If (someCondition) Then

Dim border = CType(e.RootVisual, Border)
border.Background = New SolidColorBrush(Colors.Red)

End If

End If

End Sub

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace
PrerenderEventArgs Class


MindFusion.Reporting.Wpf.Report.QueryDetails Event

Report.QueryDetails Event
[image]

Raised for items participating in a Master-Detail relationship in order to obtain the Details source.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<QueryDetailsEventArgs> QueryDetails

Visual Basic [image] Copy Code

Public Event QueryDetails As EventHandler(Of QueryDetailsEventArgs)

Event Data

QueryDetails event handlers receive an argument of type QueryDetailsEventArgs.

Remarks

This event is raised when a report is being run in order to obtain details for report elements participating in a master-detail composition. For example, when a DataRange object is embedded in another DataRange, this method is raised for the inner data range if its DataSource property is not set, in order to provide details.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Report.ReportRun Event

Report.ReportRun Event
[image]

Raised after the report has been processed using the Run method.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ReportRun

Visual Basic [image] Copy Code

Public Event ReportRun As EventHandler

Event Data

ReportRun event handlers receive an argument of type EventArgs.

See Also

Report Members
Report Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem Class

ReportItem Class
[image]

Represents an abstract base class for all report elements.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public abstract class ReportItem : FrameworkElement

Visual Basic [image] Copy Code

Public MustInherit Class ReportItem
Inherits FrameworkElement

Inheritance Hierarchy

MindFusion.Reporting.Wpf.Barcode
MindFusion.Reporting.Wpf.Chart
MindFusion.Reporting.Wpf.CustomReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.Label
MindFusion.Reporting.Wpf.PageBreak
MindFusion.Reporting.Wpf.Picture

See Also

ReportItem Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem Members

ReportItem Members
Constructors Fields Properties
[image]

Represents an abstract base class for all report elements.

The following tables list the members exposed by the ReportItem type.

Protected Constructors

Name | Description
ReportItem | Initialize a new instance of the ReportItem class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
LocationProperty | Identifies the Location dependency property.
PageCountProperty | Identifies the PageCount dependency property.
PageCurrentProperty | Identifies the PageCurrent dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property.
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property.
SizeProperty | Identifies the Size dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property.

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property.
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property.
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property.
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property.
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property.
Size | Gets or sets the of the item. This is dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property.

See Also

ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem Fields

ReportItem Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
LocationProperty | Identifies the Location dependency property.
PageCountProperty | Identifies the PageCount dependency property.
PageCurrentProperty | Identifies the PageCurrent dependency property.
RangeItemCountProperty | Identifies the RangeItemCount dependency property.
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property.
SizeProperty | Identifies the Size dependency property.
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property.

See Also

ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.BackgroundProperty Field

ReportItem.BackgroundProperty Field
[image]

Identifies the Background dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BackgroundProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.BorderBrushProperty Field

ReportItem.BorderBrushProperty Field
[image]

Identifies the BorderBrush dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderBrushProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.BorderThicknessProperty Field

ReportItem.BorderThicknessProperty Field
[image]

Identifies the BorderThickness dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BorderThicknessProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.LocationProperty Field

ReportItem.LocationProperty Field
[image]

Identifies the Location dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LocationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LocationProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.PageCountProperty Field

ReportItem.PageCountProperty Field
[image]

Identifies the PageCount dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PageCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PageCountProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.PageCurrentProperty Field

ReportItem.PageCurrentProperty Field
[image]

Identifies the PageCurrent dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PageCurrentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PageCurrentProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.RangeItemCountProperty Field

ReportItem.RangeItemCountProperty Field
[image]

Identifies the RangeItemCount dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RangeItemCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RangeItemCountProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.RangeItemCurrentProperty Field

ReportItem.RangeItemCurrentProperty Field
[image]

Identifies the RangeItemCurrent dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RangeItemCurrentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RangeItemCurrentProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.SizeProperty Field

ReportItem.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.UseDesignOrderProperty Field

ReportItem.UseDesignOrderProperty Field
[image]

Identifies the UseDesignOrder dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UseDesignOrderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly UseDesignOrderProperty As DependencyProperty

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem Constructor

ReportItem Constructor
[image]

Initialize a new instance of the ReportItem class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected ReportItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem Properties

ReportItem Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property.
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property.
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property.
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property.
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property.
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property.
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property.
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property.
Size | Gets or sets the of the item. This is dependency property.
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property.

See Also

ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItem.Background Property

ReportItem.Background Property
[image]

Gets or sets the brush used to fill the background of this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

A WPF Brush object.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
BorderBrush Property
BorderThickness Property


MindFusion.Reporting.Wpf.ReportItem.BorderBrush Property

ReportItem.BorderBrush Property
[image]

Gets or sets the brush used to paint the border of this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Brush BorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BorderBrush As Brush

Property Value

A WPF Brush object.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
Background Property
BorderThickness Property


MindFusion.Reporting.Wpf.ReportItem.BorderThickness Property

ReportItem.BorderThickness Property
[image]

Gets or sets the thickness of the border around this item. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Thickness BorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property BorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
Background Property
BorderBrush Property


MindFusion.Reporting.Wpf.ReportItem.Location Property

ReportItem.Location Property
[image]

Gets or sets the position of this item relative to its parent element. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Location Location { get; set; }

Visual Basic [image] Copy Code

Public Property Location As Location

Property Value

An instance of the Location structure specifying the position of the item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
Size Property


MindFusion.Reporting.Wpf.ReportItem.PageCount Property

ReportItem.PageCount Property
[image]

Gets the total number of pages in the report this item belongs to. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int PageCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageCount As Integer

Property Value

The total number of pages in the report containing this item; or -1 if the report, containing the item, is not laid out.

Remarks

The most scenario is to use this property in the text of a label, in order to display the total number of pages in the report.

Example

The following example demonstrates how to use this property in an expression:

XAML [image] Copy Code

<r:Label Text="[PageCurrent()] of [PageCount()]" />

PageCurrent and PageCount are a special functions, which can be used in expressions. They simply return the value of the PageCurrent and PageCount properties respectively.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
PageCurrent Property
RangeItemCount Property
RangeItemCurrent Property


MindFusion.Reporting.Wpf.ReportItem.PageCurrent Property

ReportItem.PageCurrent Property
[image]

Gets the index of the page this item is laid out on. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int PageCurrent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageCurrent As Integer

Property Value

The 1-based index of the page containing this item; or -1 if the report, containing the item, is not laid out.

Remarks

The most scenario is to use this property in the text of a label on a page, in order to display the index of the page.

Example

The following example demonstrates how to bind to this property in XAML:

XAML [image] Copy Code

<r:Label Text="{Binding PageCurrent, RelativeSource={RelativeSource Self}}" />

A shorter version using expression instead of binding will look like the following:

XAML [image] Copy Code

<r:Label Text="[PageCurrent()]" />

PageCurrent is a special function, which can be used in expressions. It simply returns the value of this property on the current item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
PageCount Property
RangeItemCount Property
RangeItemCurrent Property


MindFusion.Reporting.Wpf.ReportItem.RangeItemCount Property

ReportItem.RangeItemCount Property
[image]

Gets the total number of items within a data range (if any). This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int RangeItemCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RangeItemCount As Integer

Property Value

The total number of items in the data range containing this item; or -1 if the item does not belong to a data range or if the report, containing the item, is not laid out.

Remarks

The most scenario is to use this property in the text of a label, contained in a DataRange, in order to display the total number of elements in this data range.

Example

The following example demonstrates how to use this property in an expression:

XAML [image] Copy Code

<r:Label Text="[RangeItemCurrent()] of [RangeItemCount()]" />

RangeItemCurrent and RangeItemCount are a special functions, which can be used in expressions. They simply return the value of the RangeItemCurrent and RangeItemCount properties respectively.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
PageCount Property
PageCurrent Property
RangeItemCurrent Property


MindFusion.Reporting.Wpf.ReportItem.RangeItemCurrent Property

ReportItem.RangeItemCurrent Property
[image]

Gets the index of this item within a data range (if any). This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int RangeItemCurrent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RangeItemCurrent As Integer

Property Value

The 1-based index of this item within its containing data range; or -1 if the item does not belong to a data range or if the report, containing the item, is not laid out.

Remarks

The most scenario is to use this property in the text of a label, contained in a DataRange, in order to display successive numbering.

Example

The following example demonstrates how to bind to this property in XAML:

XAML [image] Copy Code

<r:Label Text="{Binding RangeItemCurrent, RelativeSource={RelativeSource Self}}" />

A shorter version using expression instead of binding will look like the following:

XAML [image] Copy Code

<r:Label Text="[RangeItemCurrent()]" />

RangeItemCurrent is a special function, which can be used in expressions. It simply returns the value of this property on the current item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
PageCount Property
PageCurrent Property
RangeItemCount Property


MindFusion.Reporting.Wpf.ReportItem.Size Property

ReportItem.Size Property
[image]

Gets or sets the of the item. This is dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Dimension Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Dimension

Property Value

An instance of the Dimension structure specifying the size of the item.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace
Location Property


MindFusion.Reporting.Wpf.ReportItem.UseDesignOrder Property

ReportItem.UseDesignOrder Property
[image]

Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool UseDesignOrder { get; set; }

Visual Basic [image] Copy Code

Public Property UseDesignOrder As Boolean

Property Value

true, to force the design-time order of the item to take precedence over the item's vertical position when determining the order in which the items are being laid out; otherwise, false. The default is false.

Remarks

When determining the order in which items are process during report layout, the following rules apply based on the value of this property:

Item1.UseDesignOrder | Item2.UseDesignOrder | Description
false | false | The vertical position of the items is considered when determining the layout order. The item with smaller y-coordinate is laid out first.
false | true | Item1 is laid out first.
true | false | Item2 is laid out first.
true | true | The design-time order of the items is considered when determining the items layout order. The item with smaller design-time order is laid out first.

See Also

ReportItem Members
ReportItem Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItemCollection Class

ReportItemCollection Class
[image]

An observable collection of ReportItem objects.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ReportItemCollection : ObservableCollection<ReportItem>

Visual Basic [image] Copy Code

Public Class ReportItemCollection
Inherits ObservableCollection(Of ReportItem)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(ReportItem)
System.Collections.ObjectModel.ObservableCollection(ReportItem)
MindFusion.Reporting.Wpf.ReportItemCollection

See Also

ReportItemCollection Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItemCollection Members

ReportItemCollection Members
Constructors Methods
[image]

An observable collection of ReportItem objects.

The following tables list the members exposed by the ReportItemCollection type.

Public Constructors

Name | Description
ReportItemCollection | Initializes a new instance of the ReportItemCollection class.

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<T>.OnCollectionChanged override.

See Also

ReportItemCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItemCollection Constructor

ReportItemCollection Constructor
[image]

Initializes a new instance of the ReportItemCollection class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportItemCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItemCollection Methods

ReportItemCollection Methods
[image]

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<T>.OnCollectionChanged override.

See Also

ReportItemCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportItemCollection.OnCollectionChanged Method

ReportItemCollection.OnCollectionChanged Method
[image]

ObservableCollection<T>.OnCollectionChanged override.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

protected override void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

The event data to report in the event.

See Also

ReportItemCollection Members
ReportItemCollection Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout Class

ReportLayout Class
Remarks See Also
[image]

Encapsulates the state of a laid out Report object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public sealed class ReportLayout

Visual Basic [image] Copy Code

Public NotInheritable Class ReportLayout

Remarks

You cannot instantiate this class directly. Instead, invoke the Layout method of an existing Report object, which has been previously processed by a call to its Run method. The ReportLayout objects encapsulate the layout of the report, that is, the page split-up and the position of individual report items.

Once you obtain a ReportLayout object you can perform several operations on it. The PageCount property returns the total number of pages in the layout. Individual pages can be rendered to an IRenderTarget object by calling the RenderPage method. The orientation and physical size of a page can be obtained through the GetPageOrientation and GetPageSize methods respectively.

Example

The following example creates a ReportLayout from an existing report and renders its 10th page to a FixedDocument object. The example assumes that report1 is a variable identifying an existing Report, which has been previously processed through a call to its Run method and that document is a variable identifying existing FixedDocument.

C# [image] Copy Code

// Layout the report
ReportLayout layout = report1.Layout(new Size(8.5 * 96, 11 * 96),
new Thickness(0.5 * 96), PageOrientation.Portrait);

// Render the page
layout.RenderPage(9, document);

Visual Basic [image] Copy Code

' Layout the report
Dim layout As ReportLayout = report1.Layout(New Size(8.5 * 96, 11 * 96), _
New Thickness(0.5 * 96), PageOrientation.Portrait)

' Render the page
layout.RenderPage(9, document)

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.ReportLayout

See Also

ReportLayout Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout Members

ReportLayout Members
Properties Methods
[image]

Encapsulates the state of a laid out Report object.

The following tables list the members exposed by the ReportLayout type.

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

Public Methods

Name | Description
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.
RenderAllPages | Renders all pages to the specified IRenderTarget object.
RenderPage | Renders the page with the specified 0-based index on the specified IRenderTarget object.

See Also

ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout Methods

ReportLayout Methods
[image]

Public Methods

Name | Description
GetPageOrientation | Returns the orientation of the page with the specified 0-based index.
GetPageSize | Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.
RenderAllPages | Renders all pages to the specified IRenderTarget object.
RenderPage | Renders the page with the specified 0-based index on the specified IRenderTarget object.

See Also

ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout.GetPageOrientation Method

ReportLayout.GetPageOrientation Method
[image]

Returns the orientation of the page with the specified 0-based index.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public PageOrientation GetPageOrientation (
int pageIndex
)

Visual Basic [image] Copy Code

Public Function GetPageOrientation ( _
pageIndex As Integer _
) As PageOrientation

Parameters

pageIndex
The 0-based index of the requested page.

Return Value

A member of the PageOrientation enumeration.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout.GetPageSize Method

ReportLayout.GetPageSize Method
[image]

Returns the size of the page with the specified 0-based index. The returned value indicates the paper size of the page, including padding, margin and content.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Size GetPageSize (
int pageIndex
)

Visual Basic [image] Copy Code

Public Function GetPageSize( _
pageIndex As Integer _
) As Size

Parameters

pageIndex
The 0-based index of the requested page.

Return Value

A WPF Size object.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout.RenderAllPages Method

ReportLayout.RenderAllPages Method
[image]

Renders all pages to the specified IRenderTarget object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void RenderAllPages (
IRenderTarget renderTarget
)

Visual Basic [image] Copy Code

Public Sub RenderAllPages ( _
renderTarget As IRenderTarget _
)

Parameters

renderTarget

An instance of the IRenderTarget class which will be used for the rendering.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout.RenderPage Method

ReportLayout.RenderPage Method
[image]

Renders the page with the specified 0-based index on the specified IRenderTarget object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void RenderPage (
int pageIndex,
IRenderTarget renderTarget
)

Visual Basic [image] Copy Code

Public Sub RenderPage ( _
pageIndex As Integer, _
renderTarget As IRenderTarget _
)

Parameters

pageIndex
The 0-based index of the page to render.
renderTarget
An instance of the IRenderTarget class which will be used for the rendering.

Remarks

Rendering a page using this method will not invoke BeginRender and EndRender on the supplied IRenderTarget object.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout Properties

ReportLayout Properties
[image]

Public Properties

Name | Description
PageCount | Gets the number of pages within the layout.

See Also

ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportLayout.PageCount Property

ReportLayout.PageCount Property
[image]

Gets the number of pages within the layout.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int PageCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PageCount As Integer

Property Value

The number of pages in the layout.

See Also

ReportLayout Members
ReportLayout Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Class

ReportParameter Class
Remarks See Also
[image]

Represents a parameter in a report.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ReportParameter

Visual Basic [image] Copy Code

Public Class ReportParameter

Remarks

For more information about report parameters, check Report Parameters.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.ReportParameter

See Also

ReportParameter Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Members

ReportParameter Members
Constructors Properties
[image]

Represents a parameter in a report.

The following tables list the members exposed by the ReportParameter type.

Public Constructors

Name | Description
ReportParameter | Overloaded.

Public Properties

Name | Description
Description | Gets or sets the parameter description.
Name | Gets or sets the parameter name.
Type | Gets or sets the type of the parameter value.
Value | Gets or sets the parameter value.

See Also

ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Constructor

ReportParameter Constructor
[image]

Overload List

Name | Description
ReportParameter () | Initializes a new instance of the ReportParameter class.
ReportParameter (String, Object) | Initializes a new instance of the ReportParameter class.

See Also

ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Constructor ()

ReportParameter Constructor ()
See Also
[image]

Initializes a new instance of the ReportParameter class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportParameter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportParameter Constructor Overload List
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Constructor (String, Object)

ReportParameter Constructor (String, Object)
See Also
[image]

Initializes a new instance of the ReportParameter class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportParameter (
string name,
Object value
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
value As Object _
)

Parameters

name

The name of the new parameter.

value

The value of the new parameter.

See Also

ReportParameter Constructor Overload List
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter Properties

ReportParameter Properties
[image]

Public Properties

Name | Description
Description | Gets or sets the parameter description.
Name | Gets or sets the parameter name.
Type | Gets or sets the type of the parameter value.
Value | Gets or sets the parameter value.

See Also

ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter.Description Property

ReportParameter.Description Property
[image]

Gets or sets the parameter description.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter.Name Property

ReportParameter.Name Property
[image]

Gets or sets the parameter name.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter.Type Property

ReportParameter.Type Property
[image]

Gets or sets the type of the parameter value.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportParameterType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As ReportParameterType

Property Value

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameter.Value Property

ReportParameter.Value Property
[image]

Gets or sets the parameter value.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Object Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Object

Property Value

See Also

ReportParameter Members
ReportParameter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportParameterType Enumeration

ReportParameterType Enumeration
[image]

Specifies the type of a report parameter.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public enum ReportParameterType

Visual Basic [image] Copy Code

Public Enum ReportParameterType

Members

Member name | Description
Boolean | Indicates a boolean value.
Date | Indicates a date.
Double | Indicates a double value.
Expression | Indicates an expression.
Integer | Indicates an integer value.
Text | Indicates a text value.
Unknown | Indicates a type which is not one of the predefined parameter types.

See Also

MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter Class

ReportPrinter Class
[image]

Provides convenience methods for printing Report objects.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class ReportPrinter

Visual Basic [image] Copy Code

Public Class ReportPrinter

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.ReportPrinter

See Also

ReportPrinter Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter Members

ReportPrinter Members
Constructors Properties Methods
[image]

Provides convenience methods for printing Report objects.

The following tables list the members exposed by the ReportPrinter type.

Public Constructors

Name | Description
ReportPrinter | Initializes a new instance of the ReportPrinter class with the specified Report as an argument.

Public Properties

Name | Description
PageMargin | Gets or sets the desired margin on each page of the printed or previewed report, expressed in device-independent pixels.
PageSize | Gets or sets the desired page size of the printed or previewed report, expressed in device-independent pixels.
PreviewWindowTitle | Gets or sets the title of the preview window displayed by the Preview method.

Public Methods

Name | Description
Preview | Previews the report identified by the underlying Report object.
Print | Prints the report identified by the underlying Report object.

See Also

ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter Constructor

ReportPrinter Constructor
[image]

Initializes a new instance of the ReportPrinter class with the specified Report as an argument.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public ReportPrinter (
Report report
)

Visual Basic [image] Copy Code

Public New ( _
report As Report _
)

Parameters

report
The Report that will be printed or previewed.

See Also

ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter Methods

ReportPrinter Methods
[image]

Public Methods

Name | Description
Preview | Previews the report identified by the underlying Report object.
Print | Prints the report identified by the underlying Report object.

See Also

ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter.Preview Method

ReportPrinter.Preview Method
[image]

Previews the report identified by the underlying Report object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void Preview ()

Visual Basic [image] Copy Code

Public Sub Preview ()

Remarks

The preview is performed on A4 paper with 0.5 inch margins.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter.Print Method ()

ReportPrinter.Print Method ()
See Also
[image]

Prints the report identified by the underlying Report object.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public void Print ()

Visual Basic [image] Copy Code

Public Sub Print ()

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter Properties

ReportPrinter Properties
[image]

Public Properties

Name | Description
PageMargin | Gets or sets the desired margin on each page of the printed or previewed report, expressed in device-independent pixels.
PageSize | Gets or sets the desired page size of the printed or previewed report, expressed in device-independent pixels.
PreviewWindowTitle | Gets or sets the title of the preview window displayed by the Preview method.

See Also

ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter.PageMargin Property

ReportPrinter.PageMargin Property
[image]

Gets or sets the desired margin on each page of the printed or previewed report, expressed in device-independent pixels.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Thickness> PageMargin { get; set; }

Visual Basic [image] Copy Code

Public Property PageMargin As Nullable(Of Thickness)

Property Value

Remarks

If this property is not specified, the report will be previewed on A4 paper using .5 inch margin and printed according to the specified print settings.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter.PageSize Property

ReportPrinter.PageSize Property
[image]

Gets or sets the desired page size of the printed or previewed report, expressed in device-independent pixels.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public Nullable<Size> PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As Nullable(Of Size)

Property Value

Remarks

If this property is not specified, the report will be previewed on A4 paper using .5 inch margin and printed according to the specified print settings.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.ReportPrinter.PreviewWindowTitle Property

ReportPrinter.PreviewWindowTitle Property
[image]

Gets or sets the title of the preview window displayed by the Preview method.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public string PreviewWindowTitle { get; set; }

Visual Basic [image] Copy Code

Public Property PreviewWindowTitle As String

Property Value

A string value specifying the title of the Preview window.

See Also

ReportPrinter Members
ReportPrinter Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.SideBySideContainer Class

SideBySideContainer Class
[image]

Represents a container that can hold side-by-side data ranges.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class SideBySideContainer : DataRange

Visual Basic [image] Copy Code

Public Class SideBySideContainer
Inherits DataRange

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Reporting.Wpf.ReportItem
MindFusion.Reporting.Wpf.ItemWithChildren
MindFusion.Reporting.Wpf.ItemWithSections
MindFusion.Reporting.Wpf.DataRange
MindFusion.Reporting.Wpf.SideBySideContainer

See Also

SideBySideContainer Members
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.SideBySideContainer Members

SideBySideContainer Members
Constructors Fields Properties Methods
[image]

Represents a container that can hold side-by-side data ranges.

The following tables list the members exposed by the SideBySideContainer type.

Public Constructors

Name | Description
SideBySideContainer | Initializes a new instance of the SideBySideContainer class.

Public Fields

Name | Description
AlternatingBackgroundProperty | Identifies the AlternatingBackground dependency property. (Inherited from DataRange.)
AlternatingBorderBrushProperty | Identifies the AlternatingBorderBrush dependency property. (Inherited from DataRange.)
AlternatingBorderThicknessProperty | Identifies the AlternatingBorderThickness dependency property. (Inherited from DataRange.)
ArrangeByXProperty | Identifies the ArrangeByX dependency property. (Inherited from DataRange.)
BackgroundProperty | Identifies the Background dependency property. (Inherited from ReportItem.)
BorderBrushProperty | Identifies the BorderBrush dependency property. (Inherited from ReportItem.)
BorderThicknessProperty | Identifies the BorderThickness dependency property. (Inherited from ReportItem.)
CollideOnRunProperty | Identifies the CollideOnRun dependency property. (Inherited from DataRange.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from DataRange.)
FooterTemplateProperty | Identifies the FooterTemplate dependency property. (Inherited from ItemWithSections.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from ItemWithSections.)
ItemsProperty | Identifies the Items dependency property. (Inherited from ItemWithChildren.)
ItemTemplateProperty | Identifies the ItemTemplate dependency property. (Inherited from DataRange.)
LocationProperty | Identifies the Location dependency property. (Inherited from ReportItem.)
PageCountProperty | Identifies the PageCount dependency property. (Inherited from ReportItem.)
PageCurrentProperty | Identifies the PageCurrent dependency property. (Inherited from ReportItem.)
RangeItemCountProperty | Identifies the RangeItemCount dependency property. (Inherited from ReportItem.)
RangeItemCurrentProperty | Identifies the RangeItemCurrent dependency property. (Inherited from ReportItem.)
RepeatProperty | Identifies the Repeat dependency property. (Inherited from DataRange.)
SizeProperty | Identifies the Size dependency property. (Inherited from ReportItem.)
UseDesignOrderProperty | Identifies the UseDesignOrder dependency property. (Inherited from ReportItem.)

Public Properties

Name | Description
AlternatingBackground | Gets or sets the brush that will be used to fill the background of the alternating instances of this data range. This is a dependency property. (Inherited from DataRange.)
AlternatingBorderBrush | Gets or sets the brush that will be used to fill the border of the alternating instances of this data range. This is a dependency property. (Inherited from DataRange.)
AlternatingBorderThickness | Gets or sets the border thickness of the alternating instances of this data range. This is a dependency property. (Inherited from DataRange.)
ArrangeByX | Gets or sets a value indicating whether to attempt to arrange the instances of this data range by the x-axis first. This is a dependency property. (Inherited from DataRange.)
Background | Gets or sets the brush used to fill the background of this item. This is a dependency property. (Inherited from ReportItem.)
BorderBrush | Gets or sets the brush used to paint the border of this item. This is a dependency property. (Inherited from ReportItem.)
BorderThickness | Gets or sets the thickness of the border around this item. This is a dependency property. (Inherited from ReportItem.)
CollideOnRun | Gets or sets a value indicating whether this data range, when processed, would automatically adjust the position of the other items in the report. This is a dependency property. (Inherited from DataRange.)
DataSource | Gets or sets the data source of this DataRange. This is a dependency property. (Inherited from DataRange.)
FooterTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item footer. This is a dependency property. (Inherited from ItemWithSections.)
HeaderTemplate | Gets or sets the DataTemplate to use when generating the visualization of the item header. This is a dependency property. (Inherited from ItemWithSections.)
Items | Gets or sets the report items contained in this item. This is a dependency property. (Inherited from ItemWithChildren.)
ItemTemplate | Gets or sets the DataTemplate to use when generating the visualization of data range items. This is a dependency property. (Inherited from DataRange.)
Location | Gets or sets the position of this item relative to its parent element. This is a dependency property. (Inherited from ReportItem.)
PageCount | Gets the total number of pages in the report this item belongs to. This is a dependency property. (Inherited from ReportItem.)
PageCurrent | Gets the index of the page this item is laid out on. This is a dependency property. (Inherited from ReportItem.)
RangeItemCount | Gets the total number of items within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
RangeItemCurrent | Gets the index of this item within a data range (if any). This is a dependency property. (Inherited from ReportItem.)
Repeat | Gets or sets the number of occurrences of this data range. This is a dependency property. (Inherited from DataRange.)
Size | Gets or sets the of the item. This is dependency property. (Inherited from ReportItem.)
UseDesignOrder | Gets or sets a value indicating whether this item's design-time order will take precedence over the item's vertical position within the page design when determining the layout order. This is a dependency property. (Inherited from ReportItem.)

Protected Properties

Name | Description
VisualChildrenCount | FrameworkElement.VisualChilden override. (Inherited from ItemWithChildren.)

Public Methods

Name | Description
ShouldSerializeItems | This method is for internal use only. (Inherited from DataRange.)

Protected Methods

Name | Description
GetVisualChild | FrameworkElement.GetVisualChild override. (Inherited from ItemWithChildren.)

See Also

SideBySideContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.SideBySideContainer Constructor

SideBySideContainer Constructor
[image]

Initializes a new instance of the SideBySideContainer class.

Namespace: MindFusion.Reporting.Wpf
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public SideBySideContainer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SideBySideContainer Class
MindFusion.Reporting.Wpf Namespace


MindFusion.Reporting.Wpf.Export Namespace

MindFusion.Reporting.Wpf.Export Namespace
Classes

Classes

Class | Description
ExcelExporter | Exports MindFusion reports to Microsoft Excel Open XML (XLSX) format.
HtmlExporter | Exports reports to HTML files.
HtmlRenderTarget | An implementation of the HtmlRenderTargetBase, which renders a report as HTML.
HtmlRenderTargetBase | An implementation of the IRenderTarget, which renders a report as HTML.
ImageEventArgs | Provides information for image-related events during HTML rendering.
MetaTagNames | Provides common HTML meta-tag names.
MhtmlExporter | Exports reports to MHTML files.
MhtmlRenderTarget | An implementation of the HtmlRenderTargetBase, which renders reports to MHTML.
PdfExporter | Exports reports to Adobe Portable Document Format (PDF) files.
VirtualGridRenderTarget | Renders reports on virtual grid with unlimited rows and columns by attempting to use least possible rows and columns for the purpose.


MindFusion.Reporting.Wpf.Export.ExcelExporter Class

ExcelExporter Class
Remarks See Also
[image]

Exports MindFusion reports to Microsoft Excel Open XML (XLSX) format.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public class ExcelExporter

Visual Basic [image] Copy Code

Public Class ExcelExporter

Remarks

In order to export to XLSX, instantiate from this class and invoke the Export method supplying as argument the report to be exported. As is customary, the report must have been processed by a previous call to its Run method. For more information, check Exporting Reports.

Note

The Excel export relies on the Ionic.Zip library, which is based on JZlib. The following copyright notice is used.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.ExcelExporter

See Also

ExcelExporter Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter Members

ExcelExporter Members
Constructors Properties Methods
[image]

Exports MindFusion reports to Microsoft Excel Open XML (XLSX) format.

The following tables list the members exposed by the ExcelExporter type.

Public Constructors

Name | Description
ExcelExporter | Initializes a new instance of the ExcelExporter class.

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

Public Methods

Name | Description
Export | Overloaded. Creates an XLSX file representing the specified report.

See Also

ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter Constructor

ExcelExporter Constructor
[image]

Initializes a new instance of the ExcelExporter class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public ExcelExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter Methods

ExcelExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Creates an XLSX file representing the specified report.

See Also

ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.Export Method

ExcelExporter.Export Method
[image]

Creates an XLSX file representing the specified report.

Overload List

Name | Description
ExcelExporter.Export (Report, Stream) | Creates an Excel file representing the specified report.
ExcelExporter.Export (Report, String) | Creates an Excel file representing the specified report.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.Export Method (Report, Stream)

ExcelExporter.Export Method (Report, Stream)
See Also
[image]

Creates an Excel file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
Stream stream
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
stream As Stream _
)

Parameters

report

A reference to the report that will be exported.

stream

The stream that will contain the exported report.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.Export Method (Report, String)

ExcelExporter.Export Method (Report, String)
See Also
[image]

Creates an Excel file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
string fileName
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
fileName As String _
)

Parameters

report

A reference to the report that will be exported.

fileName

The full path to the XLSX file.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter Properties

ExcelExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

See Also

ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.Margins Property

ExcelExporter.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

A WPF Thickness object specifying the distance between the page border and page content. The default is 0.5 inches.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.PageOrientation Property

ExcelExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ExcelExporter.PageSize Property

ExcelExporter.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.ExcelExport

Syntax

C# [image] Copy Code

public Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As Size

Property Value

A WPF Size object specifying the size of the exported pages. The default is 8.5x11 inches.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter Class

HtmlExporter Class
Remarks See Also
[image]

Exports reports to HTML files.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public class HtmlExporter

Visual Basic [image] Copy Code

Public Class HtmlExporter

Remarks

In order to export to HTML, instantiate from this class and invoke the Export method supplying as argument the report to be exported. As is customary, the report must have been processed by a previous call to its Run method. For more information, check Exporting Reports.

Example

The following example exports an existing report to HTML:

C# [image] Copy Code

HtmlExporter exporter = new HtmlExporter();
exporter.Export(report, "myreport.html", "");

Visual Basic [image] Copy Code

Dim exporter As New HtmlExporter()
exporter.Export(report, "myreport.html", "")

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.HtmlExporter

See Also

HtmlExporter Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter Members

HtmlExporter Members
Constructors Properties Methods
[image]

Exports reports to HTML files.

The following tables list the members exposed by the HtmlExporter type.

Public Constructors

Name | Description
HtmlExporter | Initializes a new instance of the HtmlExporter class.

Public Properties

Name | Description
Margins | Gets or sets the margins for the exported pages.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the size for the exported pages.

Public Methods

Name | Description
Export | Overloaded.

See Also

HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter Constructor

HtmlExporter Constructor
[image]

Initializes a new instance of the HtmlExporter class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public HtmlExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter Methods

HtmlExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded.

See Also

HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.Export Method

HtmlExporter.Export Method
[image]

Overload List

Name | Description
HtmlExporter.Export (Report, String, String) | Creates an HTML file representing the specified report.
HtmlExporter.Export (Report, String, String) | Creates an HTML file representing the specified report.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.Export Method (Report, String, String)

HtmlExporter.Export Method (Report, String, String)
See Also
[image]

Creates an HTML file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath,
string imageFolder
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
filePath As String, _
imageFolder As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the HTML file.

imageFolder

The path to the folder where the report images will be stored.

Remarks

The imageFolder argument should be either an empty string, indicating that the report images will be stored in the same folder as filePath, or a directory relative to filePath.

See Also

Export Method Overload List
HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.Export Method (Report, String, String)

HtmlExporter.Export Method (Report, String, String)
See Also
[image]

Creates an HTML file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath,
string imageFolder
)

Visual Basic [image] Copy Code

Public Sub Export( _
report As Report, _
filePath As String, _
imageFolder As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the HTML file.

imageFolder

The path to the folder where the report images will be stored.

See Also

Export Method Overload List
HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter Properties

HtmlExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the margins for the exported pages.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the size for the exported pages.

See Also

HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.Margins Property

HtmlExporter.Margins Property
[image]

Gets or sets the margins for the exported pages.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

A WPF Thickness object specifying the distance between the page border and page content. The default is 0.5 inches.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.PageOrientation Property

HtmlExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlExporter.PageSize Property

HtmlExporter.PageSize Property
[image]

Gets or sets the size for the exported pages.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As Size

Property Value

A WPF Size object specifying the size of the exported pages. The default is 8.5x11 inches.

See Also

HtmlExporter Members
HtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget Class

HtmlRenderTarget Class
Remarks See Also
[image]

An implementation of the HtmlRenderTargetBase, which renders a report as HTML.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public class HtmlRenderTarget : HtmlRenderTargetBase

Visual Basic [image] Copy Code

Public Class HtmlRenderTarget
Inherits HtmlRenderTargetBase

Remarks

This class can be used to render an existing report to an HTML file. However, it is easier (and more common) to use the HtmlExporter class for this purpose. The HtmlExporter class relies on a HtmlRenderTarget object in order to do the actual rendering.

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase
MindFusion.Reporting.Wpf.Export.HtmlRenderTarget

See Also

HtmlRenderTarget Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget Members

HtmlRenderTarget Members
Constructors Properties Methods Events
[image]

An implementation of the HtmlRenderTargetBase, which renders a report as HTML.

The following tables list the members exposed by the HtmlRenderTarget type.

Public Constructors

Name | Description
HtmlRenderTarget | Initializes a new instance of the HtmlRenderTarget class.

Public Properties

Name | Description
MetaTags | Gets a list containing the names and values of the meta-tags to be included in the HTML head. (Inherited from HtmlRenderTargetBase.)
RenderOpacity | Gets or sets a value indicating whether the export should include opacity information for various elements. (Inherited from HtmlRenderTargetBase.)
RenderPages | Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report. (Inherited from HtmlRenderTargetBase.)
RenderPageShadows | Gets or sets a value indicating whether to draw rectangular page shadows. (Inherited from HtmlRenderTargetBase.)
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlRenderTargetBase.)

Public Methods

Name | Description
Save | Saves the rendered HTML to stream.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string. (Inherited from HtmlRenderTargetBase.)
OnBeginRender | Invoked when renedring is about to start. (Inherited from HtmlRenderTargetBase.)
OnProcessImage | HtmlRenderTargetBase.OnProcessImage override.
OnRenderHead | Invoked when rendering the head tag of the HTML. (Inherited from HtmlRenderTargetBase.)

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlRenderTargetBase.)

See Also

HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget Constructor

HtmlRenderTarget Constructor
[image]

Initializes a new instance of the HtmlRenderTarget class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public HtmlRenderTarget (
string rootFolder,
string imageFolder
)

Visual Basic [image] Copy Code

Public New ( _
rootFolder As String, _
imageFolder As String _
)

Parameters

rootFolder
The destination folder.
imageFolder

The image folder, which should be relative to rootFolder or an empty string.

See Also

HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget Methods

HtmlRenderTarget Methods
[image]

Public Methods

Name | Description
Save | Saves the rendered HTML to stream.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string. (Inherited from HtmlRenderTargetBase.)
OnBeginRender | Invoked when renedring is about to start. (Inherited from HtmlRenderTargetBase.)
OnProcessImage | HtmlRenderTargetBase.OnProcessImage override.
OnRenderHead | Invoked when rendering the head tag of the HTML. (Inherited from HtmlRenderTargetBase.)

See Also

HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget.OnProcessImage Method

HtmlRenderTarget.OnProcessImage Method
[image]

HtmlRenderTargetBase.OnProcessImage override.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected override void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

HtmlRenderTarget Members
HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget.Save Method

HtmlRenderTarget.Save Method
[image]

Saves the rendered HTML to stream.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public override void Save (
Stream stream
)

Visual Basic [image] Copy Code

Public Overrides Sub Save( _
stream As Stream _
)

Parameters

stream

The stream where the HTML will be saved.

See Also

HtmlRenderTarget Members
HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTarget Events

HtmlRenderTarget Events
[image]

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlRenderTargetBase.)

See Also

HtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.ProcessImage Event

HtmlRenderTargetBase.ProcessImage Event
[image]

Raised when the underlying HTML is rendered in order to process a referenced image.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public event EventHandler<ImageEventArgs> ProcessImage

Visual Basic [image] Copy Code

Public Event ProcessImage As EventHandler(Of ImageEventArgs)

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Class

HtmlRenderTargetBase Class
[image]

An implementation of the IRenderTarget, which renders a report as HTML.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public abstract class HtmlRenderTargetBase : IRenderTarget

Visual Basic [image] Copy Code

Public MustInherit Class HtmlRenderTargetBase
Implements IRenderTarget

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase
MindFusion.Reporting.Wpf.Export.HtmlRenderTarget
MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget

See Also

HtmlRenderTargetBase Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Members

HtmlRenderTargetBase Members
Constructors Properties Methods Events
[image]

An implementation of the IRenderTarget, which renders a report as HTML.

The following tables list the members exposed by the HtmlRenderTargetBase type.

Protected Constructors

Name | Description
HtmlRenderTargetBase | Initializes a new instance of the HtmlRenderTargetBase class.

Public Properties

Name | Description
MetaTags | Gets a list containing the names and values of the meta-tags to be included in the HTML head.
RenderOpacity | Gets or sets a value indicating whether the export should include opacity information for various elements.
RenderPages | Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report.
RenderPageShadows | Gets or sets a value indicating whether to draw rectangular page shadows.
Title | Gets or sets the title of the resulting HTML.

Public Methods

Name | Description
Save | Overloaded. Saves the rendered HTML.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string.
OnBeginRender | Invoked when renedring is about to start.
OnProcessImage | Raises the ProcessImage event.
OnRenderHead | Invoked when rendering the head tag of the HTML.

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image.

See Also

HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Constructor

HtmlRenderTargetBase Constructor
[image]

Initializes a new instance of the HtmlRenderTargetBase class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected HtmlRenderTargetBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Methods

HtmlRenderTargetBase Methods
[image]

Public Methods

Name | Description
Save | Overloaded. Saves the rendered HTML.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string.
OnBeginRender | Invoked when renedring is about to start.
OnProcessImage | Raises the ProcessImage event.
OnRenderHead | Invoked when rendering the head tag of the HTML.

See Also

HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.GetHtml Method

HtmlRenderTargetBase.GetHtml Method
[image]

Returns the rendered HTML as string.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected string GetHtml ()

Visual Basic [image] Copy Code

Protected Function GetHtml () As String

Return Value

A string representing the rendered HTML.

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.OnBeginRender Method

HtmlRenderTargetBase.OnBeginRender Method
[image]

Invoked when renedring is about to start.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected virtual void OnBeginRender ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginRender ()

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.OnProcessImage Method

HtmlRenderTargetBase.OnProcessImage Method
[image]

Raises the ProcessImage event.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected virtual void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.OnRenderHead Method

HtmlRenderTargetBase.OnRenderHead Method
[image]

Invoked when rendering the head tag of the HTML.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected virtual void OnRenderHead (
StringBuilder html
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRenderHead( _
html As StringBuilder _
)

Parameters

html

A StringBuilder to write custom head tags to.

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.Save Method

HtmlRenderTargetBase.Save Method
[image]

Saves the rendered HTML.

Overload List

Name | Description
HtmlRenderTargetBase.Save (Stream) | Saves the rendered HTML to stream.
HtmlRenderTargetBase.Save (String) | Saves the rendered HTML to a file with the specified name.

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.Save Method (Stream)

HtmlRenderTargetBase.Save Method (Stream)
See Also
[image]

Saves the rendered HTML to stream.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public abstract void Save (
Stream stream
)

Visual Basic [image] Copy Code

Public MustOverride Sub Save( _
stream As Stream _
)

Parameters

stream

The stream where the HTML will be saved.

See Also

Save Method Overload List
HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.Save Method (String)

HtmlRenderTargetBase.Save Method (String)
See Also
[image]

Saves the rendered HTML to a file with the specified name.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public void Save (
string fileName
)

Visual Basic [image] Copy Code

Public Sub Save( _
fileName As String _
)

Parameters

fileName

The file name where the HTML will be saved.

See Also

Save Method Overload List
HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Properties

HtmlRenderTargetBase Properties
[image]

Public Properties

Name | Description
MetaTags | Gets a list containing the names and values of the meta-tags to be included in the HTML head.
RenderOpacity | Gets or sets a value indicating whether the export should include opacity information for various elements.
RenderPages | Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report.
RenderPageShadows | Gets or sets a value indicating whether to draw rectangular page shadows.
Title | Gets or sets the title of the resulting HTML.

See Also

HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.MetaTags Property

HtmlRenderTargetBase.MetaTags Property
[image]

Gets a list containing the names and values of the meta-tags to be included in the HTML head.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public Dictionary<string, string> MetaTags { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MetaTags As Dictionary(Of String, String)

Property Value

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.RenderOpacity Property

HtmlRenderTargetBase.RenderOpacity Property
[image]

Gets or sets a value indicating whether the export should include opacity information for various elements.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public bool RenderOpacity { get; set; }

Visual Basic [image] Copy Code

Public Property RenderOpacity As Boolean

Property Value

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.RenderPages Property

HtmlRenderTargetBase.RenderPages Property
[image]

Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public bool RenderPages { get; set; }

Visual Basic [image] Copy Code

Public Property RenderPages As Boolean

Property Value

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.RenderPageShadows Property

HtmlRenderTargetBase.RenderPageShadows Property
[image]

Gets or sets a value indicating whether to draw rectangular page shadows.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public bool RenderPageShadows { get; set; }

Visual Basic [image] Copy Code

Public Property RenderPageShadows As Boolean

Property Value

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase.Title Property

HtmlRenderTargetBase.Title Property
[image]

Gets or sets the title of the resulting HTML.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

HtmlRenderTargetBase Members
HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase Events

HtmlRenderTargetBase Events
[image]

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image.

See Also

HtmlRenderTargetBase Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs Class

ImageEventArgs Class
[image]

Provides information for image-related events during HTML rendering.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public class ImageEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ImageEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Reporting.Wpf.Export.ImageEventArgs

See Also

ImageEventArgs Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs Members

ImageEventArgs Members
Constructors Properties
[image]

Provides information for image-related events during HTML rendering.

The following tables list the members exposed by the ImageEventArgs type.

Public Constructors

Name | Description
ImageEventArgs | Initializes a new instance of the ImageEventArgs class.

Public Properties

Name | Description
Image | Gets the image related to the event.
IsProcessed | Gets or sets a value indicating whether the image has been processed.
Url | Gets or sets the desired URL of the image.

See Also

ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs Constructor

ImageEventArgs Constructor
[image]

Initializes a new instance of the ImageEventArgs class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public ImageEventArgs (
BitmapSource image
)

Visual Basic [image] Copy Code

Public New ( _
image As BitmapSource _
)

Parameters

image

The image related to the event.

See Also

ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs Properties

ImageEventArgs Properties
[image]

Public Properties

Name | Description
Image | Gets the image related to the event.
IsProcessed | Gets or sets a value indicating whether the image has been processed.
Url | Gets or sets the desired URL of the image.

See Also

ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs.Image Property

ImageEventArgs.Image Property
[image]

Gets the image related to the event.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public BitmapSource Image { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Image As BitmapSource

Property Value

A WPF BitmapSource object.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs.IsProcessed Property

ImageEventArgs.IsProcessed Property
[image]

Gets or sets a value indicating whether the image has been processed.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public bool IsProcessed { get; set; }

Visual Basic [image] Copy Code

Public Property IsProcessed As Boolean

Property Value

A boolean value.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.ImageEventArgs.Url Property

ImageEventArgs.Url Property
[image]

Gets or sets the desired URL of the image.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public string Url { get; set; }

Visual Basic [image] Copy Code

Public Property Url As String

Property Value

A string value.

Remarks

This URL will be written in the output HTML file.

See Also

ImageEventArgs Members
ImageEventArgs Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames Class

MetaTagNames Class
[image]

Provides common HTML meta-tag names.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public sealed class MetaTagNames

Visual Basic [image] Copy Code

Public NotInheritable Class MetaTagNames

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.MetaTagNames

See Also

MetaTagNames Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames Members

MetaTagNames Members
Fields
[image]

Provides common HTML meta-tag names.

The following tables list the members exposed by the MetaTagNames type.

Public Fields

Name | Description
Abstract | The "abstract" tag. Define a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. Classify the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Inform search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates the document displays for a specified amount of time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames Fields

MetaTagNames Fields
[image]

Public Fields

Name | Description
Abstract | The "abstract" tag. Define a secondary description.
Author | The "author" tag. Records the name of the author of the document.
Classification | The "classification" tag. Classify the site into the appropriate category.
Copyright | The "copyright" tag. Used to include copyright information in the document.
Description | The "description" tag. Some search engines pick up this description to show with the results of searches.
Distribution | The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".
DocClass | The "doc-class" tag. Indicates completion status of document. Possible values are "Completed", "Draft", "Living Document", "Published".
DocRights | The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".
DocType | The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".
Expires | The "expires" tag. Expiration date of the document.
Generator | The "generator" tag. The name of the program that created the document.
Googlebot | The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".
Keywords | The "keywords" tag. Inform search engines what your web site or page is about.
MSSmartTagsPreventParsing | The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".
Owner | The "owner" tag. Define the owner of the page or site.
ProgId | The "progid" tag.
Rating | The "rating" tag. A simple rating for a site.
Refresh | The "refresh" tag. Indicates the document displays for a specified amount of time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".
ReplyTo | The "reply-to" tag. Email address of contact for document.
ResourceType | The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".
RevisitAfter | The "revisit-after" tag. Defines how often search engine spiders should revisit your site.
Robots | The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

See Also

MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Abstract Field

MetaTagNames.Abstract Field
[image]

The "abstract" tag. Define a secondary description.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Abstract

Visual Basic [image] Copy Code

Public Shared Abstract As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Author Field

MetaTagNames.Author Field
[image]

The "author" tag. Records the name of the author of the document.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Author

Visual Basic [image] Copy Code

Public Shared Author As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Classification Field

MetaTagNames.Classification Field
[image]

The "classification" tag. Classify the site into the appropriate category.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Classification

Visual Basic [image] Copy Code

Public Shared Classification As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Copyright Field

MetaTagNames.Copyright Field
[image]

The "copyright" tag. Used to include copyright information in the document.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Copyright

Visual Basic [image] Copy Code

Public Shared Copyright As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Description Field

MetaTagNames.Description Field
[image]

The "description" tag. Some search engines pick up this description to show with the results of searches.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Description

Visual Basic [image] Copy Code

Public Shared Description As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Distribution Field

MetaTagNames.Distribution Field
[image]

The "distribution" tag. Declares whether a document is available to the web or on an intranet. Possible content values are "Global", "Local", "IU".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Distribution

Visual Basic [image] Copy Code

Public Shared Distribution As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.DocClass Field

MetaTagNames.DocClass Field
[image]

The "doc-class" tag. Indicates completion status of document. Possible values are "Completed", "Draft", "Living Document", "Published".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string DocClass

Visual Basic [image] Copy Code

Public Shared DocClass As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.DocRights Field

MetaTagNames.DocRights Field
[image]

The "doc-rights" tag. Indicates copyright status of document. Possible values are "Copywritten Work", "Private", "Public", "Public Domain".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string DocRights

Visual Basic [image] Copy Code

Public Shared DocRights As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.DocType Field

MetaTagNames.DocType Field
[image]

The "doc-type" tag. Specifies type of document. Possible content values are "Confidential Company Papers", "eZine", "Government", "Journal", "Manuscript", "Paper", "Private", "Public", "Web Page", "White Paper".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string DocType

Visual Basic [image] Copy Code

Public Shared DocType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Expires Field

MetaTagNames.Expires Field
[image]

The "expires" tag. Expiration date of the document.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Expires

Visual Basic [image] Copy Code

Public Shared Expires As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Generator Field

MetaTagNames.Generator Field
[image]

The "generator" tag. The name of the program that created the document.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Generator

Visual Basic [image] Copy Code

Public Shared Generator As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Googlebot Field

MetaTagNames.Googlebot Field
[image]

The "googlebot" tag. Define pages to be excluded from googlebot indexing. Possible content values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "nosnippet", "noarchive".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Googlebot

Visual Basic [image] Copy Code

Public Shared Googlebot As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Keywords Field

MetaTagNames.Keywords Field
[image]

The "keywords" tag. Inform search engines what your web site or page is about.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Keywords

Visual Basic [image] Copy Code

Public Shared Keywords As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.MSSmartTagsPreventParsing Field

MetaTagNames.MSSmartTagsPreventParsing Field
[image]

The "MSSmartTagsPreventParsing" tag. Use this tag to prevent any Microsoft product from automatically generating smart tags. Possible content value is "TRUE".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string MSSmartTagsPreventParsing

Visual Basic [image] Copy Code

Public Shared MSSmartTagsPreventParsing As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Owner Field

MetaTagNames.Owner Field
[image]

The "owner" tag. Define the owner of the page or site.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Owner

Visual Basic [image] Copy Code

Public Shared Owner As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.ProgId Field

MetaTagNames.ProgId Field
[image]

The "progid" tag.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string ProgId

Visual Basic [image] Copy Code

Public Shared ProgId As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Rating Field

MetaTagNames.Rating Field
[image]

The "rating" tag. A simple rating for a site.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Rating

Visual Basic [image] Copy Code

Public Shared Rating As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Refresh Field

MetaTagNames.Refresh Field
[image]

The "refresh" tag. Indicates the document displays for a specified amount of time before switching to a new URL. The content value should be in the format "n;url", where "n" is the number of seconds to wait before loading the URL specified by "url".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Refresh

Visual Basic [image] Copy Code

Public Shared Refresh As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.ReplyTo Field

MetaTagNames.ReplyTo Field
[image]

The "reply-to" tag. Email address of contact for document.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string ReplyTo

Visual Basic [image] Copy Code

Public Shared ReplyTo As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.ResourceType Field

MetaTagNames.ResourceType Field
[image]

The "resource-type" tag. Indicates the type of web resource. Possible content value is "document".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string ResourceType

Visual Basic [image] Copy Code

Public Shared ResourceType As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.RevisitAfter Field

MetaTagNames.RevisitAfter Field
[image]

The "revisit-after" tag. Defines how often search engine spiders should revisit your site.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string RevisitAfter

Visual Basic [image] Copy Code

Public Shared RevisitAfter As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MetaTagNames.Robots Field

MetaTagNames.Robots Field
[image]

The "robots" tag. Defines pages to be excluded from robot indexing. Possible values are "all", "index, follow", "noindex, follow", "index, nofollow", "noindex, nofollow", "none", "noimageindex".

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public static string Robots

Visual Basic [image] Copy Code

Public Shared Robots As String

See Also

MetaTagNames Members
MetaTagNames Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter Class

MhtmlExporter Class
[image]

Exports reports to MHTML files.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public class MhtmlExporter

Visual Basic [image] Copy Code

Public Class MhtmlExporter

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.MhtmlExporter

See Also

MhtmlExporter Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter Members

MhtmlExporter Members
Constructors Properties Methods
[image]

Exports reports to MHTML files.

The following tables list the members exposed by the MhtmlExporter type.

Public Constructors

Name | Description
MhtmlExporter | Initializes a new instance of the MhtmlExporter class.

Public Properties

Name | Description
Margins | Gets or sets the margins for the exported pages.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the size for the exported pages.

Public Methods

Name | Description
Export | Overloaded. Creates an MHTML file representing the specified report.

See Also

MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter Constructor

MhtmlExporter Constructor
[image]

Initializes a new instance of the MhtmlExporter class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public MhtmlExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter Methods

MhtmlExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Creates an MHTML file representing the specified report.

See Also

MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.Export Method

MhtmlExporter.Export Method
[image]

Creates an MHTML file representing the specified report.

Overload List

Name | Description
MhtmlExporter.Export (Report, Stream) | Creates an MHTML file representing the specified report.
MhtmlExporter.Export (Report, String) | Creates an MHTML file representing the specified report.

See Also

MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.Export Method (Report, Stream)

MhtmlExporter.Export Method (Report, Stream)
See Also
[image]

Creates an MHTML file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
Stream stream
)

Visual Basic [image] Copy Code

Public Sub Export( _
report As Report, _
stream As Stream _
)

Parameters

report

A reference to the report that will be exported.

stream

The stream to write to.

See Also

Export Method Overload List
MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.Export Method (Report, String)

MhtmlExporter.Export Method (Report, String)
See Also
[image]

Creates an MHTML file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the MHTML file.

See Also

Export Method Overload List
MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter Properties

MhtmlExporter Properties
[image]

Public Properties

Name | Description
Margins | Gets or sets the margins for the exported pages.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the size for the exported pages.

See Also

MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.Margins Property

MhtmlExporter.Margins Property
[image]

Gets or sets the margins for the exported pages.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

A WPF Thickness object.

See Also

MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.PageOrientation Property

MhtmlExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlExporter.PageSize Property

MhtmlExporter.PageSize Property
[image]

Gets or sets the size for the exported pages.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As Size

Property Value

A WPF Size object.

See Also

MhtmlExporter Members
MhtmlExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Class

MhtmlRenderTarget Class
[image]

An implementation of the HtmlRenderTargetBase, which renders reports to MHTML.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public class MhtmlRenderTarget : HtmlRenderTargetBase

Visual Basic [image] Copy Code

Public Class MhtmlRenderTarget
Inherits HtmlRenderTargetBase

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.HtmlRenderTargetBase
MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget

See Also

MhtmlRenderTarget Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Members

MhtmlRenderTarget Members
Constructors Properties Methods Events
[image]

An implementation of the HtmlRenderTargetBase, which renders reports to MHTML.

The following tables list the members exposed by the MhtmlRenderTarget type.

Public Constructors

Name | Description
MhtmlRenderTarget | Initializes a new instance of the MhtmlRenderTarget class.

Public Properties

Name | Description
MetaTags | Gets a list containing the names and values of the meta-tags to be included in the HTML head. (Inherited from HtmlRenderTargetBase.)
RenderOpacity | Gets or sets a value indicating whether the export should include opacity information for various elements. (Inherited from HtmlRenderTargetBase.)
RenderPages | Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report. (Inherited from HtmlRenderTargetBase.)
RenderPageShadows | Gets or sets a value indicating whether to draw rectangular page shadows. (Inherited from HtmlRenderTargetBase.)
SplitImageContent | Gets or sets a value indicating whether the content of images inside the rendered MHTML should be split to individual lines that do not exceed 80 characters.
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlRenderTargetBase.)

Public Methods

Name | Description
Save | HtmlRenderTargetBase.Save override.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string. (Inherited from HtmlRenderTargetBase.)
OnBeginRender | HtmlRenderTargetBase.OnBeginRender override.
OnProcessImage | HtmlRenderTargetBase.OnProcessImage override.
OnRenderHead | HtmlRenderTargetBase.OnRenderHead override.

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlRenderTargetBase.)

See Also

MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Constructor

MhtmlRenderTarget Constructor
[image]

Initializes a new instance of the MhtmlRenderTarget class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public MhtmlRenderTarget ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Methods

MhtmlRenderTarget Methods
[image]

Public Methods

Name | Description
Save | HtmlRenderTargetBase.Save override.

Protected Methods

Name | Description
GetHtml | Returns the rendered HTML as string. (Inherited from HtmlRenderTargetBase.)
OnBeginRender | HtmlRenderTargetBase.OnBeginRender override.
OnProcessImage | HtmlRenderTargetBase.OnProcessImage override.
OnRenderHead | HtmlRenderTargetBase.OnRenderHead override.

See Also

MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget.OnBeginRender Method

MhtmlRenderTarget.OnBeginRender Method
[image]

HtmlRenderTargetBase.OnBeginRender override.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected override void OnBeginRender ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnBeginRender ()

See Also

MhtmlRenderTarget Members
MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget.OnProcessImage Method

MhtmlRenderTarget.OnProcessImage Method
[image]

HtmlRenderTargetBase.OnProcessImage override.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected override void OnProcessImage (
ImageEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnProcessImage( _
e As ImageEventArgs _
)

Parameters

e

An object providing the event data.

See Also

MhtmlRenderTarget Members
MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget.OnRenderHead Method

MhtmlRenderTarget.OnRenderHead Method
[image]

HtmlRenderTargetBase.OnRenderHead override.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

protected override void OnRenderHead (
StringBuilder html
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRenderHead( _
html As StringBuilder _
)

Parameters

html

A StringBuilder to write custom head tags to.

See Also

MhtmlRenderTarget Members
MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget.Save Method

MhtmlRenderTarget.Save Method
[image]

HtmlRenderTargetBase.Save override.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public override void Save (
Stream stream
)

Visual Basic [image] Copy Code

Public Overrides Sub Save( _
stream As Stream _
)

Parameters

stream

The stream where the HTML will be saved.

See Also

MhtmlRenderTarget Members
MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Properties

MhtmlRenderTarget Properties
[image]

Public Properties

Name | Description
MetaTags | Gets a list containing the names and values of the meta-tags to be included in the HTML head. (Inherited from HtmlRenderTargetBase.)
RenderOpacity | Gets or sets a value indicating whether the export should include opacity information for various elements. (Inherited from HtmlRenderTargetBase.)
RenderPages | Gets or sets a value indicating whether to render white rectangle with black borders for each page in the report. (Inherited from HtmlRenderTargetBase.)
RenderPageShadows | Gets or sets a value indicating whether to draw rectangular page shadows. (Inherited from HtmlRenderTargetBase.)
SplitImageContent | Gets or sets a value indicating whether the content of images inside the rendered MHTML should be split to individual lines that do not exceed 80 characters.
Title | Gets or sets the title of the resulting HTML. (Inherited from HtmlRenderTargetBase.)

See Also

MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget.SplitImageContent Property

MhtmlRenderTarget.SplitImageContent Property
[image]

Gets or sets a value indicating whether the content of images inside the rendered MHTML should be split to individual lines that do not exceed 80 characters.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.HtmlExport

Syntax

C# [image] Copy Code

public bool SplitImageContent { get; set; }

Visual Basic [image] Copy Code

Public Property SplitImageContent As Boolean

Property Value

true to wrap image content; otherwise, false.

See Also

MhtmlRenderTarget Members
MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.MhtmlRenderTarget Events

MhtmlRenderTarget Events
[image]

Public Events

Name | Description
ProcessImage | Raised when the underlying HTML is rendered in order to process a referenced image. (Inherited from HtmlRenderTargetBase.)

See Also

MhtmlRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter Class

PdfExporter Class
Remarks See Also
[image]

Exports reports to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public class PdfExporter

Visual Basic [image] Copy Code

Public Class PdfExporter

Remarks

In order to export to PDF, instantiate from this class and invoke the Export method supplying as argument the report to be exported. As is customary, the report must have been processed by a previous call to its Run method.

Example

The following example exports an existing report to PDF:

C# [image] Copy Code

PdfExporter pdf = new PdfExporter();
pdf.Export(report, "myreport.pdf");

Visual Basic [image] Copy Code

Dim pdf As New PdfExporter()
pdf.Export(report, "myreport.pdf")

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.PdfExporter

See Also

PdfExporter Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter Members

PdfExporter Members
Constructors Properties Methods
[image]

Exports reports to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
DefaultEncoding | Gets or sets the encoding of the exported texts, or null, to automatically detect the encoding.
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter Constructor

PdfExporter Constructor
[image]

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PdfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter Methods

PdfExporter Methods
[image]

Public Methods

Name | Description
Export | Creates a PDF file representing the specified report.

See Also

PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter.Export Method (Report, String)

PdfExporter.Export Method (Report, String)
See Also
[image]

Creates a PDF file representing the specified report.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public void Export (
Report report,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export ( _
report As Report, _
filePath As String _
)

Parameters

report

A reference to the report that will be exported.

filePath

The full path to the PDF file.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter Properties

PdfExporter Properties
[image]

Public Properties

Name | Description
DefaultEncoding | Gets or sets the encoding of the exported texts, or null, to automatically detect the encoding.
Margins | Gets or sets the page margins.
PageOrientation | Gets or sets the page orientation.
PageSize | Gets or sets the page size.

See Also

PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter.DefaultEncoding Property

PdfExporter.DefaultEncoding Property
[image]

Gets or sets the encoding of the exported texts, or null, to automatically detect the encoding.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Encoding DefaultEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultEncoding As Encoding

Property Value

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter.Margins Property

PdfExporter.Margins Property
[image]

Gets or sets the page margins.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

A WPF Thickness object specifying the distance between the page border and page content.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.PdfExporter.PageSize Property

PdfExporter.PageSize Property
[image]

Gets or sets the page size.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Size PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As Size

Property Value

A WPF Size object specifying the size of the exported pages. The default is 8.5x11 inches.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget Class

VirtualGridRenderTarget Class
[image]

Renders reports on virtual grid with unlimited rows and columns by attempting to use least possible rows and columns for the purpose.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public class VirtualGridRenderTarget : IRenderTarget

Visual Basic [image] Copy Code

Public Class VirtualGridRenderTarget
Implements IRenderTarget

Inheritance Hierarchy

System.Object
MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget

See Also

VirtualGridRenderTarget Members
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget Members

VirtualGridRenderTarget Members
Constructors Properties Methods
[image]

Renders reports on virtual grid with unlimited rows and columns by attempting to use least possible rows and columns for the purpose.

The following tables list the members exposed by the VirtualGridRenderTarget type.

Public Constructors

Name | Description
VirtualGridRenderTarget | Initializes a new instance of the VirtualGridRenderTarget class.

Public Properties

Name | Description
ColumnWidths | Gets the accumulative widths of the columns in the grid.
Elements | Gets all rendered elements.
MaxCellSize | Gets or sets a value specifying a maximal size for the rows and columns in the grid. Rows with height bigger than this value and columns with height smaller than this value are split.
MinCellSize | Gets or sets a value specifying a minimal size for the rows and columns in the grid. Rows with height smaller than this value and columns with width smaller than this value are merged.
Pages | Gets or sets the accumulative page heights.
RowHeights | Gets the accumulative heights of the rows in the grid.

Public Methods

Name | Description
GetColumnWidth | Gets the absolute width of the column with specified index.
GetElementColumn | Gets the 0-based index of the start column of the specified element.
GetElementColumnSpan | Gets the number of additional columns occupied by the specified element.
GetElementRow | Gets the 0-based index of the start row of the specified element.
GetElementRowSpan | Gets the number of additional rows occupied by the specified element.
GetRowHeight | Gets the absolute height of the row with specified index.
IsPageBreak | Gets a value indicating whether there is a page start/end near the specified length.

See Also

VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget Constructor

VirtualGridRenderTarget Constructor
[image]

Initializes a new instance of the VirtualGridRenderTarget class.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public VirtualGridRenderTarget ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget Methods

VirtualGridRenderTarget Methods
[image]

Public Methods

Name | Description
GetColumnWidth | Gets the absolute width of the column with specified index.
GetElementColumn | Gets the 0-based index of the start column of the specified element.
GetElementColumnSpan | Gets the number of additional columns occupied by the specified element.
GetElementRow | Gets the 0-based index of the start row of the specified element.
GetElementRowSpan | Gets the number of additional rows occupied by the specified element.
GetRowHeight | Gets the absolute height of the row with specified index.
IsPageBreak | Gets a value indicating whether there is a page start/end near the specified length.

See Also

VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetColumnWidth Method

VirtualGridRenderTarget.GetColumnWidth Method
[image]

Gets the absolute width of the column with specified index.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double GetColumnWidth (
int column
)

Visual Basic [image] Copy Code

Public Function GetColumnWidth( _
column As Integer _
) As Double

Parameters

column

The 0-based index of the column.

Return Value

The absolute width of the specified column.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetElementColumn Method

VirtualGridRenderTarget.GetElementColumn Method
[image]

Gets the 0-based index of the start column of the specified element.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int GetElementColumn (
UIElement element
)

Visual Basic [image] Copy Code

Public Function GetElementColumn( _
element As UIElement _
) As Integer

Parameters

element

The element whose column to return.

Return Value

The 0-based index of the start column of the element.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetElementColumnSpan Method

VirtualGridRenderTarget.GetElementColumnSpan Method
[image]

Gets the number of additional columns occupied by the specified element.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int GetElementColumnSpan (
UIElement element
)

Visual Basic [image] Copy Code

Public Function GetElementColumnSpan( _
element As UIElement _
) As Integer

Parameters

element

The element whose column span to return.

Return Value

The number of extra occupied columns.

Remarks

This method returns 0 if the element occupies a single column.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetElementRow Method

VirtualGridRenderTarget.GetElementRow Method
[image]

Gets the 0-based index of the start row of the specified element.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int GetElementRow (
UIElement element
)

Visual Basic [image] Copy Code

Public Function GetElementRow( _
element As UIElement _
) As Integer

Parameters

element

The element whose row to return.

Return Value

The 0-based index of the start row of the element.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetElementRowSpan Method

VirtualGridRenderTarget.GetElementRowSpan Method
[image]

Gets the number of additional rows occupied by the specified element.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public int GetElementRowSpan (
UIElement element
)

Visual Basic [image] Copy Code

Public Function GetElementRowSpan( _
element As UIElement _
) As Integer

Parameters

element

The element whose row span to return.

Return Value

The number of extra occupied rows.

Remarks

This method returns 0 if the element occupies a single row.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.GetRowHeight Method

VirtualGridRenderTarget.GetRowHeight Method
[image]

Gets the absolute height of the row with specified index.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double GetRowHeight (
int row
)

Visual Basic [image] Copy Code

Public Function GetRowHeight( _
row As Integer _
) As Double

Parameters

row

The 0-based index of the row.

Return Value

The absolute height of the specified row.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.IsPageBreak Method

VirtualGridRenderTarget.IsPageBreak Method
[image]

Gets a value indicating whether there is a page start/end near the specified length.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public bool IsPageBreak (
double height
)

Visual Basic [image] Copy Code

Public Function IsPageBreak( _
height As Double _
) As Boolean

Parameters

height

The accumulative height to check.

Return Value

true if there is a page break near the specified length; otherwise, false.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget Properties

VirtualGridRenderTarget Properties
[image]

Public Properties

Name | Description
ColumnWidths | Gets the accumulative widths of the columns in the grid.
Elements | Gets all rendered elements.
MaxCellSize | Gets or sets a value specifying a maximal size for the rows and columns in the grid. Rows with height bigger than this value and columns with height smaller than this value are split.
MinCellSize | Gets or sets a value specifying a minimal size for the rows and columns in the grid. Rows with height smaller than this value and columns with width smaller than this value are merged.
Pages | Gets or sets the accumulative page heights.
RowHeights | Gets the accumulative heights of the rows in the grid.

See Also

VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.ColumnWidths Property

VirtualGridRenderTarget.ColumnWidths Property
[image]

Gets the accumulative widths of the columns in the grid.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public List<Double> ColumnWidths { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnWidths As List(Of Double)

Property Value

A list of accumulative column widths.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.Elements Property

VirtualGridRenderTarget.Elements Property
[image]

Gets all rendered elements.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<UIElement> Elements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Elements As IEnumerable(Of UIElement)

Property Value

A list of UIElement objects.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.MaxCellSize Property

VirtualGridRenderTarget.MaxCellSize Property
[image]

Gets or sets a value specifying a maximal size for the rows and columns in the grid. Rows with height bigger than this value and columns with height smaller than this value are split.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double MaxCellSize { get; set; }

Visual Basic [image] Copy Code

Public Property MaxCellSize As Double

Property Value

A double value specifying the maximum size of cells in the grid tessellation.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.MinCellSize Property

VirtualGridRenderTarget.MinCellSize Property
[image]

Gets or sets a value specifying a minimal size for the rows and columns in the grid. Rows with height smaller than this value and columns with width smaller than this value are merged.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public double MinCellSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinCellSize As Double

Property Value

A double value specifying the minimum size of cells in the grid tessellation.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.Pages Property

VirtualGridRenderTarget.Pages Property
[image]

Gets or sets the accumulative page heights.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public List<Double> Pages { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Pages As List(Of Double)

Property Value

A list of accumulative page heights.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Reporting.Wpf.Export.VirtualGridRenderTarget.RowHeights Property

VirtualGridRenderTarget.RowHeights Property
[image]

Gets the accumulative heights of the rows in the grid.

Namespace: MindFusion.Reporting.Wpf.Export
Assembly: MindFusion.Reporting.Wpf

Syntax

C# [image] Copy Code

public List<Double> RowHeights { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowHeights As List(Of Double)

Property Value

A list of accumulative row heights.

See Also

VirtualGridRenderTarget Members
VirtualGridRenderTarget Class
MindFusion.Reporting.Wpf.Export Namespace


MindFusion.Scheduling Namespace

MindFusion.Scheduling Namespace
Classes Enumerations

Classes

Class | Description
AddItemCommand | Implements creation of new schedule items.
Appointment | The Appointment class represents appointments within a schedule.
CellPresenterCreatingEventArgs | Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.
CellPresenterEventArgs | Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.
ChangeItemCommand | Handles undo / redo of property changes.
Command | Represents an action that changes the schedule and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
Contact | Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.
InstantiateItemEventArgs | Provides data for the InstantiateItem event.
InstantiateResourceEventArgs | Provides data for the InstantiateResource event.
Item | Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.
ItemCollection | Represents a strongly-typed collection of Item objects.
ItemEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
ItemPresenterEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
ItemState | Encapsulates the state of an Item instance.
ItemTimeEventArgs | Contains the arguments passed to handlers of time related events.
Location | Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.
Recurrence | Defines recurrence patterns for items scheduled to repeat over and over again.
RecurrenceException | This class represents exceptions of a recurrence patterns.
Reminder | Represents reminders associated with schedule items.
RemoveItemCommand | Implements deletion of schedule items.
Resource | Instances of the Resource class contain information about arbitrary resources.
ResourceCollection(T) | Represents a strongly-typed collection of Resource-derived objects.
Schedule | Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.
SerializationContext | This class contains information required to serialize a Schedule element to and from a binary stream or XML document.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Task | Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.
TaskEventArgs | Contains the arguments passed to handlers of task related events raised by the Schedule class.
UndoEventArgs | Contains the arguments passed to the ActionUndone and ActionRedone event handlers.
ValidateOccurrenceEventArgs | Contains the arguments passed to handlers of the ValidateOccurrence event.
XmlSerializationContext | Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

Enumerations

Enumeration | Description
DailyRecurrence | Specifies how daily recurrence patterns are defined.
DayOfWeekType | Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.
DaysOfWeek | Specifies the day of the week.
MonthlyRecurrence | Specifies the types of monthly recurrence patterns.
Occurrence | Specifies the occurrence number of a day or a week within a month.
RecurrenceEnd | Specifies when to stop repeating recurring events.
RecurrencePattern | Specifies the interval at which recurring items occur.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
TaskPriority | Specifies the priority of a task.
TaskStatus | Enumeration providing task status values.
YearlyRecurrence | Specifies the types of yearly recurrence patterns.


MindFusion.Scheduling.AddItemCommand Class

AddItemCommand Class
Remarks See Also
[image]

Implements creation of new schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class AddItemCommand : Command

Visual Basic [image] Copy Code

Public Class AddItemCommand
Inherits Command

Remarks

The control automatically creates instances of this class when items are added either interactively or from code.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.AddItemCommand

See Also

AddItemCommand Members
MindFusion.Scheduling Namespace
RemoveItemCommand Class
ChangeItemCommand Class


MindFusion.Scheduling.AddItemCommand Members

AddItemCommand Members
Constructors Properties Methods
[image]

Implements creation of new schedule items.

The following tables list the members exposed by the AddItemCommand type.

Public Constructors

Name | Description
AddItemCommand | Initializes a new instance of the AddItemCommand class.

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand Constructor

AddItemCommand Constructor
[image]

Initializes a new instance of the AddItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public AddItemCommand (
Schedule schedule,
Item item,
int index
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item, _
index As Integer _
)

Parameters

schedule
The Schedule to which the new item is added.
item
The new Item that should be added to the schedule.
index
The position of the item within the Items collection.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand Methods

AddItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Execute Method

AddItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

This method always returns true.

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Redo Method

AddItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Undo Method

AddItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Class

Appointment Class
[image]

The Appointment class represents appointments within a schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Appointment : Item

Visual Basic [image] Copy Code

Public Class Appointment
Inherits Item

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Appointment Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Members

Appointment Members
Constructors Properties Methods Events
[image]

The Appointment class represents appointments within a schedule.

The following tables list the members exposed by the Appointment type.

Public Constructors

Name | Description
Appointment | Initializes a new instance of the Appointment class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled old end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1. (Inherited from Item.)
Priority | Gets or sets the priority of this item. (Inherited from Item.)
Recurrence | Gets or sets the recurrence pattern of this item. (Inherited from Item.)
RecurrenceState | Gets the recurrence state of this item. (Inherited from Item.)
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
GetHashCode | Returns a hash code for this item. (Inherited from Item.)
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item. (Inherited from Item.)
CreateState | Creates an item state corresponding to the concrete type of this item. (Inherited from Item.)
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property. (Inherited from Item.)
OnChanged | Raises the OnChanged event on this item. (Inherited from Item.)
RestoreState | Restores the state of this item. (Inherited from Item.)
SaveState | Saves the state of this item. (Inherited from Item.)

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from Item.)

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Constructor

Appointment Constructor
[image]

Initializes a new instance of the Appointment class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Appointment ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Methods

Appointment Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
GetHashCode | Returns a hash code for this item. (Inherited from Item.)
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item. (Inherited from Item.)
CreateState | Creates an item state corresponding to the concrete type of this item. (Inherited from Item.)
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property. (Inherited from Item.)
OnChanged | Raises the OnChanged event on this item. (Inherited from Item.)
RestoreState | Restores the state of this item. (Inherited from Item.)
SaveState | Saves the state of this item. (Inherited from Item.)

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Clone Method

Appointment.Clone Method
[image]

Creates an exact shallow clone of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new Appointment object representing a shallow copy of this one.

Remarks

The Clone method creates an exact copy of an item with the following exceptions. The duplicates of a recurring item created through the Clone method are no longer recurring items. The Id of the newly created item is unique and not the same as the Id of the source item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)

Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads appointment data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the appointment's fields from an XML document where they were stored by a previous call to the SaveTo method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.SaveTo Method (XmlElement, XmlSerializationContext)

Appointment.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the appointment data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the appointment's fields as elements of an XML document, from which they can be loaded later via the LoadFrom method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Appointment Properties

Appointment Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled old end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1. (Inherited from Item.)
Priority | Gets or sets the priority of this item. (Inherited from Item.)
Recurrence | Gets or sets the recurrence pattern of this item. (Inherited from Item.)
RecurrenceState | Gets the recurrence state of this item. (Inherited from Item.)
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.AllDayEvent Property

Appointment.AllDayEvent Property
[image]

Gets or sets a value indicating whether the appointment is an all-day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool AllDayEvent { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false. The default is false.

Remarks

All day events are displayed in a special header area when the Calendar displays a timetable view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Appointment.AllowChangeEnd Property

Appointment.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool AllowChangeEnd { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowChangeEnd As Boolean

Property Value

true if the appointment's end can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowChangeStart Property

Appointment.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool AllowChangeStart { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowChangeStart As Boolean

Property Value

true if the appointment's start can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowMove Property

Appointment.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool AllowMove { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowMove As Boolean

Property Value

true if the appointment can be moved interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Appointment.Attendees Property

Appointment.Attendees Property
[image]

Gets the attendees of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Attendees { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Attendees As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class specifying the appointment's attendees.

Remarks

This property is equivalent to Contacts.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Contacts Property

Appointment.Contacts Property
[image]

Gets references to all contacts associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override ResourceCollection<Contact> Contacts { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class containing the contacts associated with this appointment.

Remarks

This property is equivalent to Attendees.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.DescriptionText Property

Appointment.DescriptionText Property
[image]

Gets or sets the details text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override string DescriptionText { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property DescriptionText As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property implements the DescriptionText property of the Item class and is equivalent to Details.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Details Property

Appointment.Details Property
[image]

Gets or sets the detailed description of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Details { get; set; }

Visual Basic [image] Copy Code

Public Property Details As String

Property Value

This property is equivalent to DescriptionText.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.EndTime Property

Appointment.EndTime Property
[image]

Gets or sets the appointment's scheduled old end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the appointment's end time. The default is DateTime.MaxValue.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.HeaderText Property

Appointment.HeaderText Property
[image]

Gets or sets the header text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override string HeaderText { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property HeaderText As String

Property Value

A string containing the appointment's header text. The default is an empty string.

Remarks

This property implements the Item's class HeaderText property and is equivalent to Subject.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Id Property

Appointment.Id Property
[image]

Gets or sets the string identifier of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override string Id { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Id As String

Property Value

A string value that identifies uniquely this appointment.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Location Property

Appointment.Location Property
[image]

Gets or sets the appointment location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override Location Location { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Location As Location

Property Value

An instance of the Location class specifying the appointment's location. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Locked Property

Appointment.Locked Property
[image]

Gets or sets a value indicating whether users are forbidden to modify this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Locked As Boolean

Property Value

true if users are allowed to move an appointment thus changing its scheduled time; otherwise, false. The default is false.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Reminder Property

Appointment.Reminder Property
[image]

Gets or sets the reminder for this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note

Recurring items cannot have leading reminders.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Resources Property

Appointment.Resources Property
[image]

Gets references to all resources associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override ResourceCollection<Resource> Resources { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing the resources associated with this item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.StartTime Property

Appointment.StartTime Property
[image]

Gets or sets the appointment's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.Subject Property

Appointment.Subject Property
[image]

Gets or sets the subject of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Subject { get; set; }

Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string that identifies the subject of the appointment. The default is an empty string.

Remarks

This is equivalent to the HeaderText property.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Tag Property

Appointment.Tag Property
[image]

Gets or sets custom data associated with the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Task Property

Appointment.Task Property
[image]

Gets or sets the task associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override Task Task { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Task As Task

Property Value

An instance of the Task class. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Visible Property

Appointment.Visible Property
[image]

Gets or sets whether the appointment is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Events

Appointment Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from Item.)

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.PropertyChanged Event

Item.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Class

CellPresenterCreatingEventArgs Class
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class CellPresenterCreatingEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellPresenterCreatingEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CellPresenterCreatingEventArgs

See Also

CellPresenterCreatingEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Members

CellPresenterCreatingEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.

The following tables list the members exposed by the CellPresenterCreatingEventArgs type.

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.
EndTime | Gets the end time of the cell whose presenter is being created.
Resource | Gets the resource associated with the cell whose presenter is being created.
StartTime | Gets the start time of the cell whose presenter is being created.

See Also

CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Properties

CellPresenterCreatingEventArgs Properties
[image]

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.
EndTime | Gets the end time of the cell whose presenter is being created.
Resource | Gets the resource associated with the cell whose presenter is being created.
StartTime | Gets the start time of the cell whose presenter is being created.

See Also

CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.CellPresenter Property

CellPresenterCreatingEventArgs.CellPresenter Property
[image]

Gets the cell presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellPresenter CellPresenter { get; set; }

Visual Basic [image] Copy Code

Public Property CellPresenter As CellPresenter

Property Value

An instance of the CellPresenter class.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.EndTime Property

CellPresenterCreatingEventArgs.EndTime Property
[image]

Gets the end time of the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object.

Remarks

This property, along with the StartTime and Resource properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.Resource Property

CellPresenterCreatingEventArgs.Resource Property
[image]

Gets the resource associated with the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class.

Remarks

This property, along with the StartTime and EndTime properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.StartTime Property

CellPresenterCreatingEventArgs.StartTime Property
[image]

Gets the start time of the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object.

Remarks

This property, along with the EndTime and Resource properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Class

CellPresenterEventArgs Class
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class CellPresenterEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellPresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CellPresenterEventArgs

See Also

CellPresenterEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Members

CellPresenterEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.

The following tables list the members exposed by the CellPresenterEventArgs type.

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.

See Also

CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Properties

CellPresenterEventArgs Properties
[image]

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.

See Also

CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs.CellPresenter Property

CellPresenterEventArgs.CellPresenter Property
[image]

Gets the cell presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellPresenter CellPresenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellPresenter As CellPresenter

Property Value

An instance of the CellPresenter class.

See Also

CellPresenterEventArgs Members
CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Class

ChangeItemCommand Class
Remarks See Also
[image]

Handles undo / redo of property changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ChangeItemCommand : Command

Visual Basic [image] Copy Code

Public Class ChangeItemCommand
Inherits Command

Remarks

The ChangeItemCommand constructor records the state of an item, and its Undo and Redo methods restore the item to either its old or new state.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

C# [image] Copy Code
Item item = calendar.ItemSelection.Items[0];
if (item != null)
{
ChangeItemCommand change = new ChangeItemCommand(calendar.Schedule, item);
item.HeaderText = "new header";
item.StartTime = DateTime.Now;
item.EndTime = DateTime.Now.AddHours(2);
calendar.Schedule.ExecuteCommand(change);
}
Visual Basic [image] Copy Code

Dim item = calendar.ItemSelection.Items(0)
If (item IsNot Nothing) Then

Dim change As New ChangeItemCommand(calendar.Schedule, item)
item.HeaderText = "new header"
item.StartTime = DateTime.Now
item.EndTime = DateTime.Now.AddHours(2)
calendar.Schedule.ExecuteCommand(change)

End If

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.ChangeItemCommand

See Also

ChangeItemCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Members

ChangeItemCommand Members
Constructors Properties Methods
[image]

Handles undo / redo of property changes.

The following tables list the members exposed by the ChangeItemCommand type.

Public Constructors

Name | Description
ChangeItemCommand | Initializes a new instance of the ChangeItemCommand class.

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Constructor

ChangeItemCommand Constructor
[image]

Initializes a new instance of the ChangeItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ChangeItemCommand (
Schedule schedule,
Item item
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item _
)

Parameters

schedule
The Schedule whose item is changed.
item
The Item that will be modified.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Methods

ChangeItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Execute Method

ChangeItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if the item's state has effectively changed; otherwise, false.

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Redo Method

ChangeItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Undo Method

ChangeItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Class

Command Class
[image]

Represents an action that changes the schedule and whose effects can be undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.AddItemCommand
MindFusion.Scheduling.ChangeItemCommand
MindFusion.Scheduling.CompositeCommand
MindFusion.Scheduling.RemoveItemCommand

See Also

Command Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Members

Command Members
Constructors Properties Methods
[image]

Represents an action that changes the schedule and whose effects can be undone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object.

Protected Methods

Name | Description
Execute | Carries out an action that changes the schedule in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the schedule to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected Command (
Schedule schedule
)

Visual Basic [image] Copy Code

Protected New ( _
schedule As Schedule _
)

Parameters

schedule
The Schedule object this command will operate on.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Methods

Command Methods
[image]

Protected Methods

Name | Description
Execute | Carries out an action that changes the schedule in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the schedule to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Execute Method

Command.Execute Method
[image]

Carries out an action that changes the schedule in some way.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected abstract bool Execute ()

Visual Basic [image] Copy Code

Protected MustOverride Function Execute () As Boolean

Return Value

true, if the command actually caused changes in the schedule; otherwise, false.

Remarks

Commands, which return false are never recorded in the command history.

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected abstract void Redo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Redo ()

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the schedule to the state it was in before carrying out the action.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected abstract void Undo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Properties

Command Properties
[image]

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Schedule Property

Command.Schedule Property
[image]

Gets the Schedule modified by this Command object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Class

CompositeCommand Class
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class CompositeCommand : Command

Visual Basic [image] Copy Code

Public Class CompositeCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.CompositeCommand

See Also

CompositeCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Members

CompositeCommand Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class.

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.
Schedule | Gets the Schedule modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Constructor

CompositeCommand Constructor
[image]

Initializes a new instance of the CompositeCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CompositeCommand (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
The Schedule modified by this command.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Methods

CompositeCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Execute Method

CompositeCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true, if at least one of the underlying commands returned true upon execution; otherwise, false.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Redo Method

CompositeCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Undo Method

CompositeCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Properties

CompositeCommand Properties
[image]

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.
Schedule | Gets the Schedule modified by this Command object. (Inherited from Command.)

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Commands Property

CompositeCommand.Commands Property
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public List<Command> Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As List(Of Command)

Property Value

A generic .NET List of Command objects.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Class

Contact Class
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Contact : Resource

Visual Basic [image] Copy Code

Public Class Contact
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact

See Also

Contact Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Members

Contact Members
Constructors Properties Methods
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

The following tables list the members exposed by the Contact type.

Public Constructors

Name | Description
Contact | Initializes a new instance of the Contact class.

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Name | Gets or sets the name of the resource. (Inherited from Resource.)
Phone | Gets or sets the phone of the contact.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Constructor

Contact Constructor
[image]

Initializes a new instance of the Contact class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Contact ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Methods

Contact Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method (XmlElement, XmlSerializationContext)

Contact.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads contact data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The context parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.SaveTo Method (XmlElement, XmlSerializationContext)

Contact.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the contact data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the contact properties as elements of an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact Properties

Contact Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Name | Gets or sets the name of the resource. (Inherited from Resource.)
Phone | Gets or sets the phone of the contact.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Address Property

Contact.Address Property
[image]

Gets or sets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Address { get; set; }

Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string containing address information. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Email Property

Contact.Email Property
[image]

Gets or sets the e-mail address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Email { get; set; }

Visual Basic [image] Copy Code

Public Property Email As String

Property Value

A string containing an e-mail address. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.FirstName Property

Contact.FirstName Property
[image]

Gets or sets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string FirstName { get; set; }

Visual Basic [image] Copy Code

Public Property FirstName As String

Property Value

A string containing the first name of a person. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LastName Property
MiddleName Property


MindFusion.Scheduling.Contact.LastName Property

Contact.LastName Property
[image]

Gets or sets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string LastName { get; set; }

Visual Basic [image] Copy Code

Public Property LastName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
MiddleName Property


MindFusion.Scheduling.Contact.MiddleName Property

Contact.MiddleName Property
[image]

Gets or sets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string MiddleName { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.Phone Property

Contact.Phone Property
[image]

Gets or sets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Phone { get; set; }

Visual Basic [image] Copy Code

Public Property Phone As String

Property Value

A string containing a phone number. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration
[image]

Specifies how daily recurrence patterns are defined.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum DailyRecurrence

Visual Basic [image] Copy Code

Public Enum DailyRecurrence

Members

Member name | Description
ByDayInterval | Repeats the item after every number of days specified in the Recurrence.Days property.
EveryWeekend | Repeats the item each Saturday and Sunday.
EveryWorkday | Repeats the item each workday, Monday through Friday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration
[image]

Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum DayOfWeekType

Visual Basic [image] Copy Code

Public Enum DayOfWeekType

Members

Member name | Description
AnyDay | Indicates any day.
Friday | Indicates Friday.
Monday | Indicates Monday.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.
Weekend | Indicates a weekend day.
Workday | Indicates a workday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration
[image]

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum DaysOfWeek

Visual Basic [image] Copy Code

Public Enum DaysOfWeek

Members

Member name | Description
All | Indicates all days of the week.
Friday | Indicates Friday.
Monday | Indicates Monday.
None | Indicates an undefined day value.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Provides data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Properties
[image]

Provides data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.ClassId Property

InstantiateItemEventArgs.ClassId Property
[image]

Gets the class identifier of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ClassId { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the item, which should be created.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property
[image]

Gets or sets the newly created item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As Item

Property Value

An instance of an Item-derived class.

Remarks

Upon handling the InstantiateItem event, you have to create an item of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Class

InstantiateResourceEventArgs Class
[image]

Provides data for the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class InstantiateResourceEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateResourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateResourceEventArgs

See Also

InstantiateResourceEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Members

InstantiateResourceEventArgs Members
Properties
[image]

Provides data for the InstantiateResource event.

The following tables list the members exposed by the InstantiateResourceEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Properties

InstantiateResourceEventArgs Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.ClassId Property

InstantiateResourceEventArgs.ClassId Property
[image]

Gets the class identifier of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ClassId { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the resource, which should be created.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.Resource Property

InstantiateResourceEventArgs.Resource Property
[image]

Gets or sets the newly created resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; set; }

Visual Basic [image] Copy Code

Public Property Resource As Resource

Property Value

An instance of a Resource-derived class.

Remarks

Upon handling the InstantiateResource event, you have to create a resource of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Class

Item Class
[image]

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract class Item : INotifyPropertyChanged, ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class Item
Implements INotifyPropertyChanged, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Item Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Members

Item Members
Constructors Properties Methods Events
[image]

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

The following tables list the members exposed by the Item type.

Protected Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
CreateState | Creates an item state corresponding to the concrete type of this item.
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property.
OnChanged | Raises the OnChanged event on this item.
RestoreState | Restores the state of this item.
SaveState | Saves the state of this item.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Constructor

Item Constructor
[image]

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected Item ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Methods

Item Methods
[image]

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
CreateState | Creates an item state corresponding to the concrete type of this item.
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property.
OnChanged | Raises the OnChanged event on this item.
RestoreState | Restores the state of this item.
SaveState | Saves the state of this item.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Clone Method

Item.Clone Method
[image]

Creates a clone of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

This is a pure abstract method and does not return a value.

Remarks

The clone of a recurring item is not an occurrence but an ordinary item. Aside from this, the clone is an exact duplicate of the original item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CopyOccurrence Method

Item.CopyOccurrence Method
[image]

Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void CopyOccurrence (
Item master
)

Visual Basic [image] Copy Code

Protected Overridable Sub CopyOccurrence ( _
master As Item _
)

Parameters

master
A reference to the master to copy from.

Remarks

This method is usually overridden in classes which derive from Item or Appointment in order to copy the custom fields from the master item to a particular occurrence. If the method is not overridden, the custom fields for all occurrences will have their default values and not the value of the master item.

Example

The following example illustrates how to override CopyOccurrence in a class deriving from Appointment and how to copy the custom fields from the master item.

C# [image] Copy Code

class CustomAppointment : Appointment
{
protected override void CopyOccurrence(Item master)
{
_customField = (master as CustomAppointment)._customField;
base.CopyOccurrence(master);
}

private int _customField;
}

Visual Basic [image] Copy Code

Class CustomAppointment
Inherits Appointment

Protected Overrides Sub CopyOccurrence(ByVal master As Item)

_customField = CType(master, CustomAppointment)._customField
MyBase.CopyOccurrence(master)

End Sub

Private _customField As Integer

End Class

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CreateState Method

Item.CreateState Method
[image]

Creates an item state corresponding to the concrete type of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual ItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As ItemState

Return Value

An instance of ItemState or a derived class.

Remarks

This method is used by the undo/redo system to create an ItemState-derived object that corresponds to the item class. Custom item classes must override CreateState in order to implement undo/redo support for any additional members they define. This method should be overridden together with SaveState and RestoreState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SaveState Method
RestoreState Method


MindFusion.Scheduling.Item.GetHashCode Method

Item.GetHashCode Method
[image]

Returns a hash code for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method (XmlElement, XmlSerializationContext)

Item.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads item data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.NotifyPropertyChanged Method

Item.NotifyPropertyChanged Method
[image]

Raises the PropertyChanged event for the specified property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected void NotifyPropertyChanged (
string prop
)

Visual Basic [image] Copy Code

Protected Sub NotifyPropertyChanged( _
prop As String _
)

Parameters

prop

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OnChanged Method

Item.OnChanged Method
[image]

Raises the OnChanged event on this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected void OnChanged ()

Visual Basic [image] Copy Code

Protected Sub OnChanged ()

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.RestoreState Method

Item.RestoreState Method
[image]

Restores the state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
ItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
state As ItemState _
)

Parameters

state
A ItemState that represents previous state of the item.

Remarks

This method is used by the undo/redo system to restore an item to a previous state. Custom item classes must override RestoreState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and SaveState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
CreateState Method
SaveState Method


MindFusion.Scheduling.Item.SaveState Method

Item.SaveState Method
[image]

Saves the state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual ItemState SaveState ()

Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As ItemState

Return Value

An ItemState that represents the current state of the item.

Remarks

This method is used by the undo/redo system to save the state of an item. Custom item classes must override SaveState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and RestoreState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
CreateState Method
RestoreState Method


MindFusion.Scheduling.Item.SaveTo Method (XmlElement, XmlSerializationContext)

Item.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the item data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item Properties

Item Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.AllDayEvent Property

Item.AllDayEvent Property
[image]

Gets or sets a value indicating whether the item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool AllDayEvent { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false.

Remarks

All day event items are displayed in a special header area when the Calendar displays a timetable view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Item.AllowChangeEnd Property

Item.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool AllowChangeEnd { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeEnd As Boolean

Property Value

true if the item's end can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Item.AllowChangeStart Property

Item.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool AllowChangeStart { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeStart As Boolean

Property Value

true if the item's start can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Item.AllowMove Property

Item.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool AllowMove { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowMove As Boolean

Property Value

true if the item can be moved interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Item.Contacts Property

Item.Contacts Property
[image]

Gets references to all contacts associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Contact> Contacts { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) generic class containing the Contact objects associated with the item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.DescriptionText Property

Item.DescriptionText Property
[image]

Gets or sets the description displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract string DescriptionText { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property DescriptionText As String

Property Value

A string containing the description of this item.

Remarks

All classes that derive from Item must implement this property. Controls such as Calendar display this text in the details area of an item visual representation.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.EndTime Property

Item.EndTime Property
[image]

Gets or sets the item's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property EndTime As DateTime

Property Value

A .NET DateTime instance.

Remarks

This property specifies the last time cell occupied by the item in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.HeaderText Property

Item.HeaderText Property
[image]

Gets or sets the header text displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract string HeaderText { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property HeaderText As String

Property Value

A string specifying the item's header text.

Remarks

Calendar views display this value in the header area of the box that represents an item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Id Property

Item.Id Property
[image]

Gets or sets the string identifier of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract string Id { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Id As String

Property Value

A string whose value uniquely identifies the item.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Location Property

Item.Location Property
[image]

Gets or sets the location associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract Location Location { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Location As Location

Property Value

An instance of the Location class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Locked Property

Item.Locked Property
[image]

Gets or sets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool Locked { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Locked As Boolean

Property Value

true if users are allowed to move the item thus changing its scheduled time; otherwise, false.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OccurrenceIndex Property

Item.OccurrenceIndex Property
[image]

Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int OccurrenceIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OccurrenceIndex As Integer

Property Value

An integer value identifying the index of an occurrence item within the recurrence array. If the item is not recurring, this property returns -1.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Priority Property

Item.Priority Property
[image]

Gets or sets the priority of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Priority { get; set; }

Visual Basic [image] Copy Code

Public Property Priority As Integer

Property Value

An integer value, specifying the item's priority.

Remarks

Items with higher priority have a better chance to be displayed prior items with lower priority. If two items start and end at the same time, the item with higher Priority will be displayed before the item with lower Priority. In other words, this property gives you control over the order of the items.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Recurrence Property

Item.Recurrence Property
[image]

Gets or sets the recurrence pattern of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Recurrence Recurrence { get; set; }

Visual Basic [image] Copy Code

Public Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set, the item becomes a recurring event and the Calendar control displays multiple occurrences of the item. To detach a previously set recurrence from an item, set this property to null (Nothing in Visual Basic).

Example

The following example demonstrates how to create and attach a recurring pattern to an existing item. The example assumes that item identifies an existing Item object.

C# [image] Copy Code

// Create the recurrence so that the item occurs once every two days
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Daily;
recurrence.Days = 2;
recurrence.StartDate = item.StartTime;
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence;

Visual Basic [image] Copy Code

' Create the recurrence so that the item occurs once every two days
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Daily
recurrence.Days = 2
recurrence.StartDate = item.StartTime
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.RecurrenceState Property

Item.RecurrenceState Property
[image]

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public RecurrenceState RecurrenceState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceState As RecurrenceState

Property Value

A member of the RecurrenceState enumeration.

Remarks

Events raised by the Calendar control could pass as an argument an occurrence or an exception of a recurring item. This property lets you determine the exact state of the item's recurrence state.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Reminder Property

Item.Reminder Property
[image]

Gets or sets the reminder for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note

Recurring items cannot have leading reminders.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Resources Property

Item.Resources Property
[image]

Gets references to all resources associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Resource> Resources { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing the resources associated with this item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.StartTime Property

Item.StartTime Property
[image]

Gets or sets the item's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.Tag Property

Item.Tag Property
[image]

Gets or sets custom data associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract Object Tag { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Task Property

Item.Task Property
[image]

Gets or sets the task associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract Task Task { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Task As Task

Property Value

An instance of the Task class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Visible Property

Item.Visible Property
[image]

Gets or sets a flag indicating whether the item is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract bool Visible { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Events

Item Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Class

ItemCollection Class
[image]

Represents a strongly-typed collection of Item objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class ItemCollection : IList<Item>, ICollection<Item>, IEnumerable<Item>, IEnumerable, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public NotInheritable Class ItemCollection
Implements IList(Of Item), ICollection(Of Item), IEnumerable(Of Item), IEnumerable, INotifyCollectionChanged

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.ItemCollection

See Also

ItemCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Members

ItemCollection Members
Constructors Properties Methods Events
[image]

Represents a strongly-typed collection of Item objects.

The following tables list the members exposed by the ItemCollection type.

Public Constructors

Name | Description
ItemCollection | Initializes a new instance of the ItemCollection class.

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
Item | Overloaded.

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether the collection contains specific item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

Public Events

Name | Description
CollectionChanged | Raised when the collection has been changed. Provides detailed information about what caused the changed.
ItemChanged | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Constructor

ItemCollection Constructor
[image]

Initializes a new instance of the ItemCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Methods

ItemCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether the collection contains specific item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Add Method

ItemCollection.Add Method
[image]

Adds the specified item to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void Add (
Item item
)

Visual Basic [image] Copy Code

Public Overridable Sub Add ( _
item As Item _
)

Parameters

item
An Item instance to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.AddRange Method

ItemCollection.AddRange Method
[image]

Adds the specified items to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void AddRange (
IList<Item> items
)

Visual Basic [image] Copy Code

Public Sub AddRange ( _
items As IList(Of Item) _
)

Parameters

items

The list of items to add to this collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Clear Method

ItemCollection.Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method

ItemCollection.Contains Method
[image]

Determines whether the collection contains specific item.

Overload List

Name | Description
ItemCollection.Contains (Item) | Determines whether this collection contains the specified item.
ItemCollection.Contains (String) | Determines whether this collection contains an item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (Item)

ItemCollection.Contains Method (Item)
See Also
[image]

Determines whether this collection contains the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual bool Contains (
Item item
)

Visual Basic [image] Copy Code

Public Overridable Function Contains ( _
item As Item _
) As Boolean

Parameters

item

The item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (String)

ItemCollection.Contains Method (String)
See Also
[image]

Determines whether this collection contains an item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
string id
)

Visual Basic [image] Copy Code

Public Function Contains( _
id As String _
) As Boolean

Parameters

id

The identifier of an item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.IndexOf Method

ItemCollection.IndexOf Method
[image]

Returns the zero-based index of the first occurrence of the specified item within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual int IndexOf (
Item item
)

Visual Basic [image] Copy Code

Public Overridable Function IndexOf ( _
item As Item _
) As Integer

Parameters

item

The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of the item within the collection, if found; otherwise, -1.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Insert Method

ItemCollection.Insert Method
[image]

Inserts the specified item at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void Insert (
int index,
Item item
)

Visual Basic [image] Copy Code

Public Overridable Sub Insert ( _
index As Integer, _
item As Item _
)

Parameters

index

The zero-based index at which the item must be inserted.

item
An instance of the Item class to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Remove Method

ItemCollection.Remove Method
[image]

Removes the first occurrence of the specified item from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Item item
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
item As Item _
)

Parameters

item
An instance of the Item class, which must be removed from the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.RemoveAt Method

ItemCollection.RemoveAt Method
[image]

Removes the item at the specified index of this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the item to remove.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Properties

ItemCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
Item | Overloaded.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Count Property

ItemCollection.Count Property
[image]

Gets the number of items contained in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property

ItemCollection.Item Property
[image]

Overload List

Name | Description
ItemCollection.Item (Int32) | Gets or sets the item located at the specified position within this collection.
ItemCollection.Item (String) | Gets the item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (Int32)

ItemCollection.Item Property (Int32)
See Also
[image]

Gets or sets the item located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual Item Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Item ( _
index As Integer _
) As Item

Parameters

index
The zero-based index of the item to get or set.

Property Value

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (String)

ItemCollection.Item Property (String)
See Also
[image]

Gets the item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item [
string id
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
id As String _
) As Item

Parameters

id
The Id of the Item to get.

Property Value

The Item instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Events

ItemCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection has been changed. Provides detailed information about what caused the changed.
ItemChanged | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.CollectionChanged Event

ItemCollection.CollectionChanged Event
[image]

Raised when the collection has been changed. Provides detailed information about what caused the changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event NotifyCollectionChangedEventHandler CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.ItemChanged Event

ItemCollection.ItemChanged Event
[image]

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ItemChanged

Visual Basic [image] Copy Code

Public Event ItemChanged As EventHandler

Event Data

ItemChanged event handlers receive an argument of type EventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs
MindFusion.Scheduling.Wpf.ItemConfirmEventArgs
MindFusion.Scheduling.Wpf.ItemModifiedEventArgs
MindFusion.Scheduling.Wpf.ItemMouseEventArgs
MindFusion.Scheduling.Wpf.ItemSelectionEventArgs
MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs

See Also

ItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Class

ItemPresenterEventArgs Class
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemPresenterEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemPresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemPresenterEventArgs

See Also

ItemPresenterEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Members

ItemPresenterEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemPresenterEventArgs type.

Public Properties

Name | Description
ItemPresenter | Gets the item presenter related to the event.

See Also

ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Properties

ItemPresenterEventArgs Properties
[image]

Public Properties

Name | Description
ItemPresenter | Gets the item presenter related to the event.

See Also

ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs.ItemPresenter Property

ItemPresenterEventArgs.ItemPresenter Property
[image]

Gets the item presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemPresenter ItemPresenter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemPresenter As ItemPresenter

Property Value

An instance of the ItemPresenter class.

See Also

ItemPresenterEventArgs Members
ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Class

ItemState Class
Remarks See Also
[image]

Encapsulates the state of an Item instance.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemState : IEquatable<ItemState>

Visual Basic [image] Copy Code

Public Class ItemState
Implements IEquatable(Of ItemState)

Remarks

Instances of this class are used to store the state of items for later undo or redo operations.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.ItemState

See Also

ItemState Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Members

ItemState Members
Constructors Methods
[image]

Encapsulates the state of an Item instance.

The following tables list the members exposed by the ItemState type.

Public Constructors

Name | Description
ItemState | Initializes a new instance of the ItemState class.

Public Methods

Name | Description
Equals | Indicates whether the current state is equal to the specified state.

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Constructor

ItemState Constructor
[image]

Initializes a new instance of the ItemState class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Methods

ItemState Methods
[image]

Public Methods

Name | Description
Equals | Indicates whether the current state is equal to the specified state.

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState.Equals Method

ItemState.Equals Method
[image]

Indicates whether the current state is equal to the specified state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
ItemState other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As ItemState _
) As Boolean

Parameters

other

The state to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

ItemState Members
ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Class

ItemTimeEventArgs Class
[image]

Contains the arguments passed to handlers of time related events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemTimeEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemTimeEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemTimeEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Members

ItemTimeEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of time related events.

The following tables list the members exposed by the ItemTimeEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Properties

ItemTimeEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs.Time Property

ItemTimeEventArgs.Time Property
[image]

Gets the old value of the time property whose change caused the event to occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime Time { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Time As DateTime

Property Value

An instance of the .NET DateTime class.

See Also

ItemTimeEventArgs Members
ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Class

Location Class
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Location : Resource

Visual Basic [image] Copy Code

Public Class Location
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Location

See Also

Location Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Members

Location Members
Constructors Properties Methods
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Initializes a new instance of the Location class.

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
Name | Gets or sets the name of the resource. (Inherited from Resource.)
State | Gets or sets the state of this location.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)
ZipCode | Gets or sets the zip-code of this location.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Constructor

Location Constructor
[image]

Initializes a new instance of the Location class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Location ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Methods

Location Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method (XmlElement, XmlSerializationContext)

Location.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads location data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.SaveTo Method (XmlElement, XmlSerializationContext)

Location.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the location data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location Properties

Location Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
Name | Gets or sets the name of the resource. (Inherited from Resource.)
State | Gets or sets the state of this location.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)
ZipCode | Gets or sets the zip-code of this location.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.Address Property

Location.Address Property
[image]

Gets or sets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Address { get; set; }

Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string specifying the address of this location. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
City Property
State Property
Country Property


MindFusion.Scheduling.Location.City Property

Location.City Property
[image]

Gets or sets the city of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string City { get; set; }

Visual Basic [image] Copy Code

Public Property City As String

Property Value

A string specifying the city where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
State Property
Country Property


MindFusion.Scheduling.Location.Country Property

Location.Country Property
[image]

Gets or sets the country of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Country { get; set; }

Visual Basic [image] Copy Code

Public Property Country As String

Property Value

A string specifying the country where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
State Property


MindFusion.Scheduling.Location.State Property

Location.State Property
[image]

Gets or sets the state of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string State { get; set; }

Visual Basic [image] Copy Code

Public Property State As String

Property Value

A string identifying the state where this location is. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
Country Property


MindFusion.Scheduling.Location.ZipCode Property

Location.ZipCode Property
[image]

Gets or sets the zip-code of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ZipCode { get; set; }

Visual Basic [image] Copy Code

Public Property ZipCode As String

Property Value

A string containing the location's Zip code. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration
[image]

Specifies the types of monthly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MonthlyRecurrence

Visual Basic [image] Copy Code

Public Enum MonthlyRecurrence

Members

Member name | Description
ByDayNumber | The event occurs on a specific day of the month.
ByDayType | The event occurs on a specific type of day of the specified week of the month.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration
[image]

Specifies the occurrence number of a day or a week within a month.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum Occurrence

Visual Basic [image] Copy Code

Public Enum Occurrence

Members

Member name | Description
First | Indicates the first occurrence.
Fourth | Indicates the fourth occurrence.
Last | Indicates the last occurrence.
Second | Indicates the second occurrence.
Third | Indicates the third occurrence.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Class

Recurrence Class
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Recurrence : ICloneable

Visual Basic [image] Copy Code

Public Class Recurrence
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Recurrence

See Also

Recurrence Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Properties Methods Events
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Overloaded. Creates occurrence items for this recurrence in a specified date range.
GetEndDate | Overloaded. Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom |
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo |
ToString | Overloaded. Creates a string from this recurrence.

Protected Methods

Name | Description
OnValidateOccurrence | Raises the ValidateOccurrence event.

Public Events

Name | Description
ValidateOccurrence | Raised during item generation to allow validation and customization of the generated occurrences.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor
[image]

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Recurrence ()

Visual Basic [image] Copy Code

Public Sub New ()

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;

Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods
[image]

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Overloaded. Creates occurrence items for this recurrence in a specified date range.
GetEndDate | Overloaded. Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom |
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo |
ToString | Overloaded. Creates a string from this recurrence.

Protected Methods

Name | Description
OnValidateOccurrence | Raises the ValidateOccurrence event.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ApplyPattern Method

Recurrence.ApplyPattern Method
[image]

Copies the fields of the specified Recurrence object to this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void ApplyPattern (
Recurrence recurrence
)

Visual Basic [image] Copy Code

Public Sub ApplyPattern ( _
recurrence As Recurrence _
)

Parameters

recurrence
The Recurrence object whose fields to copy.

Remarks

This method behaves similarly to the Clone method except that it does not create a new object.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ClearExceptions Method

Recurrence.ClearExceptions Method
[image]

Removes all exceptions of this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void ClearExceptions ()

Visual Basic [image] Copy Code

Public Sub ClearExceptions ()

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Clone Method

Recurrence.Clone Method
[image]

Creates an exact copy of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

A new Recurrence object, cloned from this one.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
ApplyPattern Method


MindFusion.Scheduling.Recurrence.GetOccurrence Method

Recurrence.GetOccurrence Method
[image]

Returns the occurrence having the specified index.

Overload List

Name | Description
Recurrence.GetOccurrence (Int32, Boolean@) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Boolean@, Boolean) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Calendar, Boolean@, Boolean) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Calendar, Boolean@) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Calendar) | Returns the occurrence having the specified index.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@)

Recurrence.GetOccurrence Method (Int32, Boolean@)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted
)

Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

isDeleted

If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)

Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted,
bool noException
)

Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

isDeleted

If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

noException

Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Calendar, Boolean@, Boolean)

Recurrence.GetOccurrence Method (Int32, Calendar, Boolean@, Boolean)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
Calendar c,
ref bool isDeleted,
bool noException
)

Visual Basic [image] Copy Code

Public Function GetOccurrence( _
index As Integer, _
c As Calendar, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

c

An object that specifies the calendar to use for calculating the occurrences of the recurrence.

isDeleted

If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

noException

Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Calendar, Boolean@)

Recurrence.GetOccurrence Method (Int32, Calendar, Boolean@)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
Calendar c,
ref bool isDeleted
)

Visual Basic [image] Copy Code

Public Function GetOccurrence( _
index As Integer, _
c As Calendar, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

c

An object that specifies the calendar to use for calculating the occurrences of the recurrence.

isDeleted

If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32)

Recurrence.GetOccurrence Method (Int32)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index
)

Visual Basic [image] Copy Code

Public Function GetOccurrence( _
index As Integer _
) As Item

Parameters

index

The index of the occurrence to retrieve.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Calendar)

Recurrence.GetOccurrence Method (Int32, Calendar)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
Calendar c
)

Visual Basic [image] Copy Code

Public Function GetOccurrence( _
index As Integer, _
c As Calendar _
) As Item

Parameters

index

The index of the occurrence to retrieve.

c

An object that specifies the calendar to use for calculating the occurrences of the recurrence.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)

Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads the recurrence data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved via SaveTo.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MarkException Method

Recurrence.MarkException Method
[image]

Marks the specified item as an exception of a recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void MarkException (
Item item,
bool deleted
)

Visual Basic [image] Copy Code

Public Sub MarkException ( _
item As Item, _
deleted As Boolean _
)

Parameters

item
The Item instance to be marked as an exception.
deleted

Specifies whether the exception is created by deleting one occurrence from the recurrent pattern or by changing the occurrence time properties.

Remarks

The Calendar control calls this method when a user drags an occurrence item or edits its text, thus creating an exception of the recurrence.

Example

The following example deletes the occurrences of an existing recurrence that are located in the specified date interval. The example assumes that recurrence identifies an existing Recurrence object.

C# [image] Copy Code

ItemCollection items =
recurrence.GenerateItems(new DateTime(2005, 1, 1), new DateTime(2005, 12, 31));

foreach (Item item in items)
recurrence.MarkException(item, true);

Visual Basic [image] Copy Code

Dim items As ItemCollection = _
recurrence.GenerateItems(New DateTime(2005, 1, 1), New DateTime(2005, 12, 31))

Dim item as Item
For Each item in items
recurrence.MarkException(item, True)
Next item

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.OnValidateOccurrence Method

Recurrence.OnValidateOccurrence Method
[image]

Raises the ValidateOccurrence event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValidateOccurrence (
ValidateOccurrenceEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidateOccurrence( _
e As ValidateOccurrenceEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SamePatternAs Method

Recurrence.SamePatternAs Method
[image]

Determines whether two Recurrence objects define the same recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool SamePatternAs (
Recurrence recurrence
)

Visual Basic [image] Copy Code

Public Function SamePatternAs ( _
recurrence As Recurrence _
) As Boolean

Parameters

recurrence
A Recurrence object to compare with this recurrence.

Return Value

true if the Recurrence instances represent the same recurrence patterns; otherwise false.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)

Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the recurrence data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The recurrence properties are saved as elements of an XML document, and can be later restored using the LoadFrom method.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.ToString Method

Recurrence.ToString Method
[image]

Creates a string from this recurrence.

Overload List

Name | Description
Recurrence.ToString () | Creates a string from this recurrence using the date and time formatting information defined in the current culture.
Recurrence.ToString (DateTimeFormatInfo) | Creates a string from this recurrence using the specified date and time formatting.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method ()

Recurrence.ToString Method ()
See Also
[image]

Creates a string from this recurrence using the date and time formatting information defined in the current culture.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method (DateTimeFormatInfo)

Recurrence.ToString Method (DateTimeFormatInfo)
See Also
[image]

Creates a string from this recurrence using the specified date and time formatting.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ToString (
DateTimeFormatInfo info
)

Visual Basic [image] Copy Code

Public Function ToString( _
info As DateTimeFormatInfo _
) As String

Parameters

info

Defines how date and time values are formatted and displayed.

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GenerateItems Method

Recurrence.GenerateItems Method
[image]

Creates occurrence items for this recurrence in a specified date range.

Overload List

Name | Description
Recurrence.GenerateItems (DateTime, DateTime) | Creates occurrence items for this recurrence in the specified date range.
Recurrence.GenerateItems (DateTime, DateTime, Calendar) | Creates occurrence items for this recurrence in the specified date range.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GenerateItems Method (DateTime, DateTime)

Recurrence.GenerateItems Method (DateTime, DateTime)
See Also
[image]

Creates occurrence items for this recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GenerateItems (
DateTime startDate,
DateTime endDate
)

Visual Basic [image] Copy Code

Public Function GenerateItems ( _
startDate As DateTime, _
endDate As DateTime _
) As ItemCollection

Parameters

startDate

The range start date.

endDate

The range end date.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

GenerateItems Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GenerateItems Method (DateTime, DateTime, Calendar)

Recurrence.GenerateItems Method (DateTime, DateTime, Calendar)
See Also
[image]

Creates occurrence items for this recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GenerateItems (
DateTime startDate,
DateTime endDate,
Calendar c
)

Visual Basic [image] Copy Code

Public Function GenerateItems( _
startDate As DateTime, _
endDate As DateTime, _
c As Calendar _
) As ItemCollection

Parameters

startDate

The range start date.

endDate

The range end date.

c

An object that specifies the calendar to use for calculating the occurrences of the recurrence.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

GenerateItems Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method

Recurrence.GetEndDate Method
[image]

Returns the end date for this recurrence.

Overload List

Name | Description
Recurrence.GetEndDate () | Returns the end date for this recurrence.
Recurrence.GetEndDate (Calendar) | Returns the end date for this recurrence.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method ()

Recurrence.GetEndDate Method ()
See Also
[image]

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetEndDate ()

Visual Basic [image] Copy Code

Public Function GetEndDate () As DateTime

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

GetEndDate Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method (Calendar)

Recurrence.GetEndDate Method (Calendar)
See Also
[image]

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetEndDate (
Calendar c
)

Visual Basic [image] Copy Code

Public Function GetEndDate( _
c As Calendar _
) As DateTime

Parameters

c

An object that specifies the calendar to use for calculating the end date of the recurrence.

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

GetEndDate Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Properties

Recurrence Properties
[image]

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DailyRecurrence Property

Recurrence.DailyRecurrence Property
[image]

Gets or sets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DailyRecurrence DailyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property DailyRecurrence As DailyRecurrence

Property Value

A member of the DailyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Day Property

Recurrence.Day Property
[image]

Gets or sets a value indicating on which day of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DayOfWeekType Day { get; set; }

Visual Basic [image] Copy Code

Public Property Day As DayOfWeekType

Property Value

A member of the DayOfWeekType enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DayOfMonth Property

Recurrence.DayOfMonth Property
[image]

Gets or sets on which day of a month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int DayOfMonth { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfMonth As Integer

Property Value

An integer value specifying at which day of the month the recurring event occurs. The allowed values range from 1 to 31.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Days Property

Recurrence.Days Property
[image]

Gets or sets how many days should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Days { get; set; }

Visual Basic [image] Copy Code

Public Property Days As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DaysOfWeek Property

Recurrence.DaysOfWeek Property
[image]

Gets or sets on which days of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DaysOfWeek DaysOfWeek { get; set; }

Visual Basic [image] Copy Code

Public Property DaysOfWeek As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.EndDate Property

Recurrence.EndDate Property
[image]

Gets or sets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }

Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

A .NET DateTime object specifying the end date of the recurring event.

Remarks

This property is considered by the recurrence only if the RecurrenceEnd is set to EndDate.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Exceptions Property

Recurrence.Exceptions Property
[image]

Gets the list of all recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ICollection Exceptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Exceptions As ICollection

Property Value

A .NET ICollection containing the exceptions generated for this recurrence.

Example

The following example traverses all deleted occurrences of a recurrence. The example assumes that recurrence references an existing Recurrence object.

C# [image] Copy Code
foreach (RecurrenceException exception in recurrence.Exceptions)
{
if (exception.IsDeleted)
{
// Do something here
}
}
Visual Basic [image] Copy Code

For Each exception As RecurrenceException in recurrence.Exceptions

If exception.IsDeleted Then

' Do something here

End If

Next

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Interval Property

Recurrence.Interval Property
[image]

Gets or sets the recurrence interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeSpan Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As TimeSpan

Property Value

A .NET TimeSpan value indicating the time interval between recurring items.

Remarks

This value is used when the recurrence Pattern is set to ByTimeInterval.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Master Property

Recurrence.Master Property
[image]

Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Master { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Master As Item

Property Value

A reference to the schedule item whose recurrence is defined by this object.

Remarks

To associate a recurrence with an item, set a reference to a Recurrence object to the item's Recurrence property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthlyRecurrence Property

Recurrence.MonthlyRecurrence Property
[image]

Gets or sets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthlyRecurrence MonthlyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property MonthlyRecurrence As MonthlyRecurrence

Property Value

A member of the MonthlyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly.

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;

Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthOfYear Property

Recurrence.MonthOfYear Property
[image]

Gets or sets in which month of the year the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MonthOfYear { get; set; }

Visual Basic [image] Copy Code

Public Property MonthOfYear As Integer

Property Value

An integer value specifying at which month the event occurs. The allowed values range from 1 to 12.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Months Property

Recurrence.Months Property
[image]

Gets or sets how many months should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Months { get; set; }

Visual Basic [image] Copy Code

Public Property Months As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.NumOccurrences Property

Recurrence.NumOccurrences Property
[image]

Gets or sets how many times the recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int NumOccurrences { get; set; }

Visual Basic [image] Copy Code

Public Property NumOccurrences As Integer

Property Value

An integer value specifying the number of occurrences. The allowed values range from 1 to 999.

Remarks

The value of this property is used when the RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Occurrence Property

Recurrence.Occurrence Property
[image]

Gets or sets on which occurrence of the day type specified in Day the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Occurrence Occurrence { get; set; }

Visual Basic [image] Copy Code

Public Property Occurrence As Occurrence

Property Value

A member of the Occurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Pattern Property

Recurrence.Pattern Property
[image]

Gets or sets the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public RecurrencePattern Pattern { get; set; }

Visual Basic [image] Copy Code

Public Property Pattern As RecurrencePattern

Property Value

A member of the RecurrencePattern enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.RecurrenceEnd Property

Recurrence.RecurrenceEnd Property
[image]

Gets or sets when the event should stop recurring.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public RecurrenceEnd RecurrenceEnd { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceEnd As RecurrenceEnd

Property Value

A member of the RecurrenceEnd enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
EndDate Property
NumOccurrences Property


MindFusion.Scheduling.Recurrence.StartDate Property

Recurrence.StartDate Property
[image]

Gets or sets when the recurring event should occur for the first time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }

Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the recurrence start date.

Remarks

The time properties set in a recurrence object override the time properties of a schedule item to which the recurrence is assigned. The Calendar control displays "occurrence" items corresponding to the recurring master item. The first occurrence is displayed in the date cell specified in this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Weeks Property

Recurrence.Weeks Property
[image]

Gets or sets how many weeks should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Weeks { get; set; }

Visual Basic [image] Copy Code

Public Property Weeks As Integer

Property Value

An integer value specifying the number of weeks between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.YearlyRecurrence Property

Recurrence.YearlyRecurrence Property
[image]

Gets or sets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public YearlyRecurrence YearlyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property YearlyRecurrence As YearlyRecurrence

Property Value

A member of the YearlyRecurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Events

Recurrence Events
[image]

Public Events

Name | Description
ValidateOccurrence | Raised during item generation to allow validation and customization of the generated occurrences.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ValidateOccurrence Event

Recurrence.ValidateOccurrence Event
[image]

Raised during item generation to allow validation and customization of the generated occurrences.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ValidateOccurrenceEventArgs> ValidateOccurrence

Visual Basic [image] Copy Code

Public Event ValidateOccurrence As EventHandler(Of ValidateOccurrenceEventArgs)

Event Data

ValidateOccurrence event handlers receive an argument of type ValidateOccurrenceEventArgs.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration
[image]

Specifies when to stop repeating recurring events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum RecurrenceEnd

Visual Basic [image] Copy Code

Public Enum RecurrenceEnd

Members

Member name | Description
EndDate | The recurrence ends at a specified date.
Never | Never stop repeating events.
NumOccurrences | Stop repeating events after a specified number of occurrences.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class
[image]

This class represents exceptions of a recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class RecurrenceException

Visual Basic [image] Copy Code

Public Class RecurrenceException

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.RecurrenceException

See Also

RecurrenceException Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Properties
[image]

This class represents exceptions of a recurrence patterns.

The following tables list the members exposed by the RecurrenceException type.

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Properties

RecurrenceException Properties
[image]

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.IsDeleted Property

RecurrenceException.IsDeleted Property
[image]

Gets or sets a value indicating whether this particular occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsDeleted { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsDeleted As Boolean

Property Value

true if this exception identifies a deleted occurrence; otherwise, false.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.Item Property

RecurrenceException.Item Property
[image]

Gets the item representing the recurrence exception.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the item class representing the schedule item for which this exception is defined.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration
[image]

Specifies the interval at which recurring items occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum RecurrencePattern

Visual Basic [image] Copy Code

Public Enum RecurrencePattern

Members

Member name | Description
ByTimeInterval | Repeats an item over a specified time interval.
Daily | Repeats an item every day.
Monthly | Repeats an item every month.
Weekly | Repeats an item every week.
Yearly | Repeats an item every year.

Remarks

These values can be assigned to the Pattern property of the Recurrence class.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration
[image]

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum RecurrenceState

Visual Basic [image] Copy Code

Public Enum RecurrenceState

Members

Member name | Description
Exception | Specifies an exception of a recurring event.
Master | Specifies a recurring event.
None | Specifies an one-time non-recurring event.
Occurrence | Specifies a single occurrence of a recurring event.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Class

Reminder Class
[image]

Represents reminders associated with schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class Reminder : ICloneable

Visual Basic [image] Copy Code

Public NotInheritable Class Reminder
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reminder

See Also

Reminder Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Fields Properties Methods
[image]

Represents reminders associated with schedule items.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom |
SaveTo |

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Fields

Reminder Fields
[image]

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.MaxInterval Field

Reminder.MaxInterval Field
[image]

The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly TimeSpan MaxInterval

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxInterval As TimeSpan

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor
[image]

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Reminder ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Methods

Reminder Methods
[image]

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom |
SaveTo |

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Clone Method

Reminder.Clone Method
[image]

Clones this Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An exact copy of this reminder.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)

Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads reminder data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the reminder fields from an XML document, where they were previously saved via SaveTo.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.SaveTo Method (XmlElement, XmlSerializationContext)

Reminder.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the reminder data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saved the reminder object fields as elements in a XML document. They can be restored later using the LoadFrom method.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Reminder Properties

Reminder Properties
[image]

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Message Property

Reminder.Message Property
[image]

Gets or sets the message to display as a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Message { get; set; }

Visual Basic [image] Copy Code

Public Property Message As String

Property Value

A string containing the message text.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.PlaySound Property

Reminder.PlaySound Property
[image]

Gets or sets a value indicating whether to play a sound when the reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool PlaySound { get; set; }

Visual Basic [image] Copy Code

Public Property PlaySound As Boolean

Property Value

true to play the sound file; otherwise, false.

Remarks

The path to the sound file can be set in the SoundFileName property.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SoundFileName Property

Reminder.SoundFileName Property
[image]

Gets or sets the name of a sound file to play with this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string SoundFileName { get; set; }

Visual Basic [image] Copy Code

Public Property SoundFileName As String

Property Value

A string specifying which file to play.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Time Property

Reminder.Time Property
[image]

Gets or sets the exact time when to trigger the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime Time { get; set; }

Visual Basic [image] Copy Code

Public Property Time As DateTime

Property Value

A .NET DateTime object specifying when the reminder should be triggered.

Remarks

The value of this property is considered only if the Type of the reminder is set to Exact.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.TimeInterval Property

Reminder.TimeInterval Property
[image]

Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeSpan TimeInterval { get; set; }

Visual Basic [image] Copy Code

Public Property TimeInterval As TimeSpan

Property Value

A .NET TimeSpan instance specifying how much time before event's scheduled time to trigger the reminder.

Remarks

The value of this property is considered only if the Type of the reminder is set to Leading.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Type Property

Reminder.Type Property
[image]

Gets or sets the type of this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ReminderType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As ReminderType

Property Value

A member of the ReminderType enumeration specifying the reminder type.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration
[image]

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum ReminderType

Visual Basic [image] Copy Code

Public Enum ReminderType

Members

Member name | Description
Exact | Trigger the reminder at the exact time specified in its Date property. Note: Recurring items cannot have exact reminders.
Leading | Trigger the reminder at the specified TimeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Class

RemoveItemCommand Class
[image]

Implements deletion of schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class RemoveItemCommand : Command

Visual Basic [image] Copy Code

Public Class RemoveItemCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.RemoveItemCommand

See Also

RemoveItemCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Members

RemoveItemCommand Members
Constructors Properties Methods
[image]

Implements deletion of schedule items.

The following tables list the members exposed by the RemoveItemCommand type.

Public Constructors

Name | Description
RemoveItemCommand | Initializes a new instance of the RemoveItemCommand class.

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Constructor

RemoveItemCommand Constructor
[image]

Initializes a new instance of the RemoveItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public RemoveItemCommand (
Schedule schedule,
Item item,
int index
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item, _
index As Integer _
)

Parameters

schedule
The Schedule from which the item is removed.
item
The Item that should be removed from the schedule.
index

The index of the item being removed.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Methods

RemoveItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Execute Method

RemoveItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

This method always returns true.

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Redo Method

RemoveItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Undo Method

RemoveItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Class

Resource Class
[image]

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Resource

Visual Basic [image] Copy Code

Public Class Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact
MindFusion.Scheduling.Location
MindFusion.Scheduling.Task

See Also

Resource Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Members

Resource Members
Constructors Properties Methods
[image]

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Initializes a new instance of the Resource class.

Public Properties

Name | Description
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Constructor

Resource Constructor
[image]

Initializes a new instance of the Resource class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Methods

Resource Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method (XmlElement, XmlSerializationContext)

Resource.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads resource data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The reader parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Resource.SaveTo Method (XmlElement, XmlSerializationContext)

Resource.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the resource data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the resource properties as elements of an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Resource Properties

Resource Properties
[image]

Public Properties

Name | Description
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Id Property

Resource.Id Property
[image]

Gets or sets the string identifier of this resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

A string value identifying uniquely this resource instance.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Name Property

Resource.Name Property
[image]

Gets or sets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string containing the name of the resource. The default is an empty string.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Tag Property

Resource.Tag Property
[image]

Gets or sets custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Class

ResourceCollection(T) Class
[image]

Represents a strongly-typed collection of Resource-derived objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class ResourceCollection<T> : ObservableCollection<T> where T : Resource

Visual Basic [image] Copy Code

Public NotInheritable Class ResourceCollection(Of T As Resource)
Inherits ObservableCollection(Of T)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
System.Collections.ObjectModel.ObservableCollection(T)
MindFusion.Scheduling.ResourceCollection(T)

See Also

ResourceCollection(T) Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Members

ResourceCollection(T) Members
Constructors Properties
[image]

Represents a strongly-typed collection of Resource-derived objects.

The following tables list the members exposed by the ResourceCollection(T) type.

Public Constructors

Name | Description
ResourceCollection | Initializes a new instance of the ResourceCollection class.

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Constructor

ResourceCollection(T) Constructor
[image]

Initializes a new instance of the ResourceCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Properties

ResourceCollection(T) Properties
[image]

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T).Item Property

ResourceCollection(T).Item Property
[image]

Gets the Resource identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public T Item [
string id
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
id As String _
) As T

Parameters

id
The Id of the Resource to get.

Property Value

The Resource instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

ResourceCollection(T) Members
ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Class

Schedule Class
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Schedule

Visual Basic [image] Copy Code

Public Class Schedule

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Schedule

See Also

Schedule Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Members

Schedule Members
Constructors Fields Properties Methods Events
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

The following tables list the members exposed by the Schedule type.

Public Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Public Fields

Name | Description
CurrentVersion | The current version of schedule file format.

Public Properties

Name | Description
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Contacts | Gets all contacts defined in the Schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
ExecuteCommand | Executes the specified command on this schedule.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded.
IsClassRegistered | Overloaded.
LoadFrom | Overloaded.
LoadFromXml |
Redo | Executes again an action saved in the command history.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded.
SaveToXml |
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeTag | Raises the DeserializeTag event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Fields

Schedule Fields
[image]

Public Fields

Name | Description
CurrentVersion | The current version of schedule file format.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CurrentVersion Field

Schedule.CurrentVersion Field
[image]

The current version of schedule file format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static int CurrentVersion

Visual Basic [image] Copy Code

Public Shared CurrentVersion As Integer

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Constructor

Schedule Constructor
[image]

Initializes a new instance of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Schedule ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Methods

Schedule Methods
[image]

Public Methods

Name | Description
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
ExecuteCommand | Executes the specified command on this schedule.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded.
IsClassRegistered | Overloaded.
LoadFrom | Overloaded.
LoadFromXml |
Redo | Executes again an action saved in the command history.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded.
SaveToXml |
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeTag | Raises the DeserializeTag event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CancelCompositeOperation Method

Schedule.CancelCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void CancelCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CancelCompositeOperation ()

Remarks

You must call either CommitCompositeOperation or this method when the schedule modifications are done after a StartCompositeOperation call.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.Clear Method

Schedule.Clear Method
[image]

Clears all items, tasks, locations, contacts and resources contained in this schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contacts Property
Items Property
Locations Property
Resources Property
Tasks Property


MindFusion.Scheduling.Schedule.CommitCompositeOperation Method

Schedule.CommitCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void CommitCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CommitCompositeOperation ()

Remarks

You must call either CancelCompositeOperation or this method when the schedule modifications are done after a StartCompositeOperation call.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.ExecuteCommand Method

Schedule.ExecuteCommand Method
[image]

Executes the specified command on this schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command command
)

Visual Basic [image] Copy Code

Public Sub ExecuteCommand ( _
command As Command _
)

Parameters

command
The Command to execute.

Remarks

If undo/redo is enabled, the command is saved in the undo history or added to the active composite command.

AddItemCommand and RemoveItemCommand objects are created automatically by the control when adding or removing items, both programmatically or interactively. Calling this method explicitly could be necessary in order to save item's state for later undo using a ChangeItemCommand, or to run a custom operation represented by a class derived from Command.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

C# [image] Copy Code
Item item = calendar.ItemSelection.Items[0];
if (item != null)
{
ChangeItemCommand change = new ChangeItemCommand(calendar.Schedule, item);
item.HeaderText = "new header";
item.StartTime = DateTime.Now;
item.EndTime = DateTime.Now.AddHours(2);
calendar.Schedule.ExecuteCommand(change);
}
Visual Basic [image] Copy Code

Dim item = calendar.ItemSelection.Items(0)
If (item IsNot Nothing) Then

Dim change As New ChangeItemCommand(calendar.Schedule, item)
item.HeaderText = "new header"
item.StartTime = DateTime.Now
item.EndTime = DateTime.Now.AddHours(2)
calendar.Schedule.ExecuteCommand(change)

End If

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method

Schedule.GetAllItems Method
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Overload List

Name | Description
Schedule.GetAllItems (DateTime, DateTime) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
Schedule.GetAllItems (DateTime, DateTime, Contact) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.
Schedule.GetAllItems (DateTime, DateTime, Location) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.
Schedule.GetAllItems (DateTime, DateTime, Resource) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.
Schedule.GetAllItems (DateTime, DateTime, Task) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime)

Schedule.GetAllItems Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startTime,
DateTime endTime
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startTime As DateTime, _
endTime As DateTime _
) As ItemCollection

Parameters

startTime

Time interval start.

endTime

Time interval end.

Return Value

A collection that contains the events scheduled to occur in the specified period.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Contact)

Schedule.GetAllItems Method (DateTime, DateTime, Contact)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Contact contact
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
contact As Contact _
) As ItemCollection

Parameters

startDate

Specifies the start of the time period.

endDate

Specifies the end of the time period.

contact
A Contact instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified contact.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Location)

Schedule.GetAllItems Method (DateTime, DateTime, Location)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Location location
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
location As Location _
) As ItemCollection

Parameters

startDate

Specifies the start of the time period.

endDate

Specifies the end of the time period.

location
A Location instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified location.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Resource)

Schedule.GetAllItems Method (DateTime, DateTime, Resource)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Resource resource
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
resource As Resource _
) As ItemCollection

Parameters

startDate

Specifies the start of the time period.

endDate

Specifies the end of the time period.

resource
A Resource instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified resource.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Task)

Schedule.GetAllItems Method (DateTime, DateTime, Task)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Task task
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
task As Task _
) As ItemCollection

Parameters

startDate

Specifies the start of the time period.

endDate

Specifies the end of the time period.

task
A Task instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified task.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method

Schedule.GetFreePeriod Method
[image]

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Overload List

Name | Description
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan) | Returns the next period after the specified date with the specified duration which is not occupied by items.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Contact)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Location)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Resource)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Task)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)
See Also
[image]

Returns the next period after the specified date with the specified duration which is not occupied by items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan _
) As DateTime

Parameters

from

The start date of the interval in which to search for a free period.

to

The end date of the interval in which to search for a free period.

duration

The required minimum duration of the period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Contact> contacts
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
contacts As ResourceCollection(Of Contact) _
) As DateTime

Parameters

from

The start date of the interval in which to search for a free period.

to

The end date of the interval in which to search for a free period.

duration

The required minimum duration of the period.

contacts

The contacts whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Location> locations
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
locations As ResourceCollection(Of Location) _
) As DateTime

Parameters

from

The start date of the interval in which to search for a free period.

to

The end date of the interval in which to search for a free period.

duration

The required minimum duration of the period.

locations

The locations whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Resource> resources
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
resources As ResourceCollection(Of Resource) _
) As DateTime

Parameters

from

The start date of the interval in which to search for a free period.

to

The end date of the interval in which to search for a free period.

duration

The required minimum duration of the period.

resources

The resources whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Task> tasks
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
tasks As ResourceCollection(Of Task) _
) As DateTime

Parameters

from

The start date of the interval in which to search for a free period.

to

The end date of the interval in which to search for a free period.

duration

The required minimum duration of the period.

tasks

The tasks whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method

Schedule.GetItemsToRemindOf Method
[image]

Retrieves a collection of all items that must be reminded of.

Overload List

Name | Description
Schedule.GetItemsToRemindOf () | Retrieves a collection with all items that must be reminded of at the current time.
Schedule.GetItemsToRemindOf (DateTime) | Retrieves a collection with all items that must be reminded of at the specified time.
Schedule.GetItemsToRemindOf (DateTime, DateTime) | Retrieves a collection with all items that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method ()

Schedule.GetItemsToRemindOf Method ()
See Also
[image]

Retrieves a collection with all items that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf ()

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf () As ItemCollection

Return Value

The collection of all items whose reminders must be displayed at the current time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime)

Schedule.GetItemsToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection with all items that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf (
DateTime time
)

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
time As DateTime _
) As ItemCollection

Parameters

time

Determine whether any reminders should be displayed at this time.

Return Value

The collection of all items whose reminders must be displayed at the specified time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime, DateTime)

Schedule.GetItemsToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection with all items that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ItemCollection

Parameters

start

The start of the time interval containing the items of interest.

end

The end of the time interval containing the items of interest.

Return Value

The collection of all items whose reminders must be displayed in the specified time interval.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method

Schedule.GetTasksToRemindOf Method
[image]

Overload List

Name | Description
Schedule.GetTasksToRemindOf () | Retrieves a collection of all tasks that must be reminded of at the current time.
Schedule.GetTasksToRemindOf (DateTime) | Retrieves a collection of all tasks that must be reminded of at the specified time.
Schedule.GetTasksToRemindOf (DateTime, DateTime) | Retrieves a collection of all tasks that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method ()

Schedule.GetTasksToRemindOf Method ()
See Also
[image]

Retrieves a collection of all tasks that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf ()

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf () As ResourceCollection(Of Task)

Return Value

The collection of all tasks whose reminders must be displayed at the current time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime)

Schedule.GetTasksToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection of all tasks that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime time
)

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
time As DateTime _
) As ResourceCollection(Of Task)

Parameters

time

Determine whether any task reminders should be displayed at this time.

Return Value

The collection of all tasks whose reminders must be displayed at the specified time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime, DateTime)

Schedule.GetTasksToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all tasks that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ResourceCollection(Of Task)

Parameters

start

The start of the time interval containing the tasks of interest.

end

The end of the time interval containing the tasks of interest.

Return Value

The collection of all tasks whose reminders must be displayed in the specified time interval.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method

Schedule.IsClassRegistered Method
[image]

Overload List

Name | Description
Schedule.IsClassRegistered (String) | Checks whether the specified
Schedule.IsClassRegistered (Type) | Checks whether the specified item or resource type is registered for serializaiton.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (String)

Schedule.IsClassRegistered Method (String)
See Also
[image]

Checks whether the specified

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
string classId
)

Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered( _
classId As String _
) As Boolean

Parameters

classId
The string identifier of an item or resource class.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (Type)

Schedule.IsClassRegistered Method (Type)
See Also
[image]

Checks whether the specified item or resource type is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered( _
classType As Type _
) As Boolean

Parameters

classType
The type of an item or a resource.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.LoadFrom Method

Schedule.LoadFrom Method
[image]

Overload List

Name | Description
Schedule.LoadFrom (Stream) | Loads schedule data from a stream.
Schedule.LoadFrom (String) | Loads schedule data from a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (Stream)

Schedule.LoadFrom Method (Stream)
See Also
[image]

Loads schedule data from a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
stream As Stream _
)

Parameters

stream

The .NET Stream to load the schedule from.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (String)

Schedule.LoadFrom Method (String)
See Also
[image]

Loads schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFromXml Method (XmlDocument)

Schedule.LoadFromXml Method (XmlDocument)
See Also
[image]

Loads schedule data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document

An XmlDocument instance that allows reading data from the XML document.

Remarks

Loads schedule items from an XML document previously created by SaveTo. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToXml Method


MindFusion.Scheduling.Schedule.OnActionRedone Method

Schedule.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected void OnActionRedone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnActionRedone ( _
e As UndoEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnActionUndone Method

Schedule.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected void OnActionUndone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnActionUndone ( _
e As UndoEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnDeserializeTag Method

Schedule.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateItem Method

Schedule.OnInstantiateItem Method
[image]

Raises the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateItem (
InstantiateItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateItem ( _
e As InstantiateItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateResource Method

Schedule.OnInstantiateResource Method
[image]

Raises the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateResource (
InstantiateResourceEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateResource ( _
e As InstantiateResourceEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeTriggered Method

Schedule.OnItemEndTimeTriggered Method
[image]

Raises the ItemEndTimeTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemEndTimeTriggered (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemEndTimeTriggered ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemReminderTriggered Method

Schedule.OnItemReminderTriggered Method
[image]

Raises the ItemReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemReminderTriggered (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemReminderTriggered ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnSerializeTag Method

Schedule.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnTaskReminderTriggered Method

Schedule.OnTaskReminderTriggered Method
[image]

Raises the TaskReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTaskReminderTriggered (
TaskEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTaskReminderTriggered ( _
e As TaskEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Redo Method

Schedule.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling Redo.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property
CanUndo Property
ActionUndone Event


MindFusion.Scheduling.Schedule.RegisterItemClass Method

Schedule.RegisterItemClass Method
[image]

Registers a schedule item class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A .NET Type instance identifying the item class.
classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

Remarks

When using custom item classes, use this method to enable saving and loading the custom item objects to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which items are saved changes. It is used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom items.

Example

The following example demonstrates how to use custom item classes with the schedule and how to load and save a schedule containing custom items. The example presumes that schedule already references an existing Schedule object.

Running the example should dump the following line to the output console:

Hello, friend!

C# [image] Copy Code

/// <summary>
/// The declaration of the custom item class.
/// </summary>
class CustomItem : Appointment
{
/// <summary>
/// The parameterless constructor, required by the Schedule.
/// </summary>
public CustomItem()
{
_customField = "This is my field.";
}

public override void LoadFrom(
System.Xml.XmlReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadElementString("customField");
}

public override void SaveTo(
System.Xml.XmlWriter writer,
SerializationContext context)
{
base.SaveTo(writer, context);

writer.WriteElementString("customField", _customField);
}

public string CustomField
{
get { return _customField; }
set { _customField = value; }
}

private string _customField;
}

// ...

// Register our custom item class for use with the schedule
Schedule.RegisterItemClass(typeof(CustomItem), "customItemId", 1);

// Create a new custom item and add it to the schedule
CustomItem customItem = new CustomItem();
customItem.CustomField = "Hello, friend!";
schedule.Items.Add(customItem);

// Save the schedule to a file.
// Make sure the specified path exists on your drive
schedule.SaveTo(@"c:\schedule.save");

// Clear the schedule
schedule.Items.Clear();

// Load the previously saved schedule data
schedule.LoadFrom(@"c:\schedule.save");

// Test the data
foreach (Item item in schedule.Items)
{
if (item is CustomItem)
{
System.Diagnostics.Debug.WriteLine(
(item as CustomItem).CustomField);
}
}

Visual Basic [image] Copy Code

' <summary>
' The declaration of the custom item class.
' </summary>
Class CustomItem
Inherits Appointment

' <summary>
' The parameterless constructor, required by the Schedule.
' </summary>
Public Sub New()

_customField = "This is my field."

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.Xml.XmlReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadElementString("customField")

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.Xml.XmlWriter, _
ByVal context As SerializationContext)

MyBase.SaveTo(writer, context)

writer.WriteElementString("customField", _customField)

End Sub

Public Property CustomField() As String

Get
Return _customField
End Get

Set(ByVal Value As String)
_customField = Value
End Set

End Property

Private _customField As String

End Class

' ...

' Register our custom item class for use with the schedule
schedule.RegisterItemClass(GetType(CustomItem), "customItemId", 1)

' Create a new custom item and add it to the schedule
Dim customItem As New CustomItem
customItem.CustomField = "Hello, friend!"
schedule.Items.Add(customItem)

' Save the schedule to a file.
' Make sure the specified path exists on your drive
schedule.SaveTo("c:\schedule.save")

' Clear the schedule
schedule.Items.Clear()

' Load the previously saved schedule data
schedule.LoadFrom("c:\schedule.save")

' Test the data
Dim item As Item
For Each item In schedule.Items

If TypeOf item Is CustomItem Then

System.Diagnostics.Debug.WriteLine( _
CType(item, CustomItem).CustomField)

End If

Next item

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RegisterResourceClass Method

Schedule.RegisterResourceClass Method
[image]

Registers a resource class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static void RegisterResourceClass (
Type resourceClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterResourceClass( _
resourceClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

resourceClass

A Type instance identifying the resource class.

classId

A class identifier to use when saving and loading resources of the specified type.

classVersion

A revision number of the resource's class serialization format.

Remarks

When using custom resource classes, use this method to enable saving and loading the custom resource objects to/from XML or binary files. The class id string is written before each resource's data, and when loading resources later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which resources are saved changes. It is used when loading files to let your application load resources data from an older format.

Note

All custom resource classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom resources.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method

Schedule.SaveTo Method
[image]

Overload List

Name | Description
Schedule.SaveTo (Stream) | Saves the schedule to a stream.
Schedule.SaveTo (String) | Saves the schedule to a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (Stream)

Schedule.SaveTo Method (Stream)
See Also
[image]

Saves the schedule to a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
stream As Stream _
)

Parameters

stream

The .NET Stream to save the schedule to.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (String)

Schedule.SaveTo Method (String)
See Also
[image]

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

The path of the file to save to.

Remarks

Saves the schedule data into a XML file. Use LoadFrom to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveToXml Method (XmlDocument)

Schedule.SaveToXml Method (XmlDocument)
See Also
[image]

Saves the schedule to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object that allows adding data to the XML document.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFromXml to restore the schedule data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromXml Method


MindFusion.Scheduling.Schedule.StartCompositeOperation Method

Schedule.StartCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void StartCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub StartCompositeOperation ()

Remarks

After the schedule modifications are done, call CommitCompositeOperation or CancelCompositeOperation.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.Undo Method

Schedule.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling Redo.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property
CanUndo Property
ActionUndone Event


MindFusion.Scheduling.Schedule.UnregisterClass Method

Schedule.UnregisterClass Method
[image]

Unregisters the item or resource with the specified class identifier or type from the system.

Overload List

Name | Description
Schedule.UnregisterClass (String) | Unregisters the item or resource with the specified class id from the system.
Schedule.UnregisterClass (Type) | Unregisters the specified item or resource type from the system.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.UnregisterClass Method (String)

Schedule.UnregisterClass Method (String)
See Also
[image]

Unregisters the item or resource with the specified class id from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static void UnregisterClass (
string classId
)

Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass( _
classId As String _
)

Parameters

classId
The string identifier of an item or resource class.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (Type)

Schedule.UnregisterClass Method (Type)
See Also
[image]

Unregisters the specified item or resource type from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static void UnregisterClass (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass( _
classType As Type _
)

Parameters

classType
The type of an item or a resource.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule Properties

Schedule Properties
[image]

Public Properties

Name | Description
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Contacts | Gets all contacts defined in the Schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CanRedo Property

Schedule.CanRedo Property
[image]

Gets or sets a value indicating whether there is a command in the redo history which can be redone

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool CanRedo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanRedo As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CanUndo Property

Schedule.CanUndo Property
[image]

Gets or sets a value indicating whether there is a command in the undo history which can be undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool CanUndo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanUndo As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Contacts Property

Schedule.Contacts Property
[image]

Gets all contacts defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Contacts { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class containing all contacts used in the schedule.

Remarks

Add contacts to this collection before assigning them to a schedule item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Items Property

Schedule.Items Property
[image]

Gets all scheduled items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As ItemCollection

Property Value

An instance of the ItemCollection class containing all items in the schedule.

Remarks

The Calendar control displays each element of this collection in the time cells corresponding to the item's StartTime and EndTime.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Item Class


MindFusion.Scheduling.Schedule.Locations Property

Schedule.Locations Property
[image]

Gets all locations defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Location> Locations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Locations As ResourceCollection(Of Location)

Property Value

An instance of the generic ResourceCollection(Location) class containing all locations associated with this schedule.

Remarks

Add locations to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Location Class


MindFusion.Scheduling.Schedule.Resources Property

Schedule.Resources Property
[image]

Gets all resources defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> Resources { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing all resources associated with this schedule.

Remarks

Add resources to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Resource Class


MindFusion.Scheduling.Schedule.Tasks Property

Schedule.Tasks Property
[image]

Gets all tasks defined in this Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Task> Tasks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Tasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection(Task) class containing references to the tasks assigned to the schedule.

Remarks

If you need to assign a Task object to schedule items, add the task to this collection before assigning it to the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Task Class


MindFusion.Scheduling.Schedule.UndoEnabled Property

Schedule.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Events

Schedule Events
[image]

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ActionRedone Event

Schedule.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ActionUndone Event

Schedule.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Changed Event

Schedule.Changed Event
[image]

Raised when items are added or removed from the schedule or when the schedule is loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.DeserializeTag Event

Schedule.DeserializeTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateItem Event

Schedule.InstantiateItem Event
[image]

Raised when deserializing a custom item whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateItemEventArgs> InstantiateItem

Visual Basic [image] Copy Code

Public Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

InstantiateItem event handlers receive an argument of type InstantiateItemEventArgs.

Remarks

This event is being raised during deserialization for all custom items whose types have not been previously registered within the system through a call to RegisterItemClass. The event provides an alternative way for instantiating item of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateResource Event

Schedule.InstantiateResource Event
[image]

Raised when deserializing a custom resource whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateResourceEventArgs> InstantiateResource

Visual Basic [image] Copy Code

Public Event InstantiateResource As EventHandler(Of InstantiateResourceEventArgs)

Event Data

InstantiateResource event handlers receive an argument of type InstantiateResourceEventArgs.

Remarks

This event is being raised during deserialization for all custom resources whose types have not been previously registered within the system through a call to RegisterResourceClass. The event provides an alternative way for instantiating resources of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeTriggered Event

Schedule.ItemEndTimeTriggered Event
[image]

Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemEndTimeTriggered

Visual Basic [image] Copy Code

Public Event ItemEndTimeTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemEndTimeTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemReminderTriggered Event

Schedule.ItemReminderTriggered Event
[image]

Raised when the reminder for an item is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemReminderTriggered

Visual Basic [image] Copy Code

Public Event ItemReminderTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemReminderTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SerializeTag Event

Schedule.SerializeTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.TaskReminderTriggered Event

Schedule.TaskReminderTriggered Event
[image]

Raised when the reminder for a task is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TaskEventArgs> TaskReminderTriggered

Visual Basic [image] Copy Code

Public Event TaskReminderTriggered As EventHandler(Of TaskEventArgs)

Event Data

TaskReminderTriggered event handlers receive an argument of type TaskEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Class

SerializationContext Class
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class SerializationContext

Visual Basic [image] Copy Code

Public Class SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

SerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Members

SerializationContext Members
Constructors Properties Events
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

The following tables list the members exposed by the SerializationContext type.

Public Constructors

Name | Description
SerializationContext | Initializes a new instance of the SerializationContext class.

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Constructor

SerializationContext Constructor
[image]

Initializes a new instance of the SerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public SerializationContext (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
An instance of the Schedule class representing the schedule to associate with.

Remarks

Generally, you do not have to instantiate from SerializationContext explicitly unless you want to serialize only particular elements and not the entire schedule.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Properties

SerializationContext Properties
[image]

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.FileVersion Property

SerializationContext.FileVersion Property
[image]

Gets the format revision number of the file being loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

An integer value identifying the schedule file format revision number.

Remarks

This revision number specifies the format of the schedule files, but not of distinct item classes. If using custom item classes, specify their format revision number when registering them with the schedule via the RegisterItemClass method.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Schedule Property

SerializationContext.Schedule Property
[image]

Gets a reference to the schedule currently being serialized or deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Events

SerializationContext Events
[image]

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Completed Event

SerializationContext.Completed Event
[image]

Raised when the serialization or deserialization has completed successfully.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Completed

Visual Basic [image] Copy Code

Public Event Completed As EventHandler

Event Data

Completed event handlers receive an argument of type EventArgs.

Remarks

You can use this event in your custom items to deserialize references to other Item and/or Resource objects.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlSerializationContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlSerializationContext

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets the Item or Resource whose Tag is being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the representation of the tag object being serialized / deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlDocument Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XmlDocument

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Class

Task Class
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Task : Resource

Visual Basic [image] Copy Code

Public Class Task
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Task

See Also

Task Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Members

Task Members
Constructors Properties Methods
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

The following tables list the members exposed by the Task type.

Public Constructors

Name | Description
Task | Initializes a new instance of the Task class.

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
ImageIndex | Gets or sets the index of the image associated with this task.
Name | Gets or sets the name of the resource. (Inherited from Resource.)
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Constructor

Task Constructor
[image]

Initializes a new instance of the Task class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Task ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Methods

Task Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method (XmlElement, XmlSerializationContext)

Task.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads task data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows reading data from the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the task properties from an XML document where they were previously saved by SaveTo.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.SaveTo Method (XmlElement, XmlSerializationContext)

Task.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the task data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element

Allows adding data to the XML document.

context

The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task Properties

Task Properties
[image]

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
Id | Gets or sets the string identifier of this resource. (Inherited from Resource.)
ImageIndex | Gets or sets the index of the image associated with this task.
Name | Gets or sets the name of the resource. (Inherited from Resource.)
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.
Tag | Gets or sets custom data associated with the resource. (Inherited from Resource.)

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualCost Property

Task.ActualCost Property
[image]

Gets or sets the actual cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public float ActualCost { get; set; }

Visual Basic [image] Copy Code

Public Property ActualCost As Single

Property Value

A float value specifying the task's actual cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualDuration Property

Task.ActualDuration Property
[image]

Gets or sets the task actual duration measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ActualDuration { get; set; }

Visual Basic [image] Copy Code

Public Property ActualDuration As Integer

Property Value

An integer value specifying the task's duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualEnd Property

Task.ActualEnd Property
[image]

Gets or sets the task's actual completion date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime ActualEnd { get; set; }

Visual Basic [image] Copy Code

Public Property ActualEnd As DateTime

Property Value

A .NET DateTime object specifying the task's actual end date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualStart Property

Task.ActualStart Property
[image]

Gets or sets the task's actual start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime ActualStart { get; set; }

Visual Basic [image] Copy Code

Public Property ActualStart As DateTime

Property Value

A .NET DateTime object specifying the task's actual start date. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Details Property

Task.Details Property
[image]

Gets or sets the detailed description of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Details { get; set; }

Visual Basic [image] Copy Code

Public Property Details As String

Property Value

A string containing the task's details text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.DueDate Property

Task.DueDate Property
[image]

Gets or sets the task's due date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime DueDate { get; set; }

Visual Basic [image] Copy Code

Public Property DueDate As DateTime

Property Value

A .NET DateTime object specifying the task's sue date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
StartDate Property


MindFusion.Scheduling.Task.EstimatedCost Property

Task.EstimatedCost Property
[image]

Gets or sets the estimated cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public float EstimatedCost { get; set; }

Visual Basic [image] Copy Code

Public Property EstimatedCost As Single

Property Value

A float value specifying the task's estimated cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.EstimatedDuration Property

Task.EstimatedDuration Property
[image]

Gets or sets the estimated duration of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int EstimatedDuration { get; set; }

Visual Basic [image] Copy Code

Public Property EstimatedDuration As Integer

Property Value

An integer value specifying the task's scheduled duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ImageIndex Property

Task.ImageIndex Property
[image]

Gets or sets the index of the image associated with this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ImageIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ImageIndex As Integer

Property Value

An integer value specifying the index of the task image within the calendar's ImageList. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Priority Property

Task.Priority Property
[image]

Gets or sets the task priority.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TaskPriority Priority { get; set; }

Visual Basic [image] Copy Code

Public Property Priority As TaskPriority

Property Value

A member of the TaskPriority enumeration. The default is Normal.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Progress Property

Task.Progress Property
[image]

Gets or sets the task progress measured in percents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public float Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Single

Property Value

A float value specifying the progress made on this task. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Reminder Property

Task.Reminder Property
[image]

Gets or sets the reminder for this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public Property Reminder As Reminder

Property Value

A Reminder instance specifying when the task should be reminded of. The default is null (Nothing in Visual Basic).

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.StartDate Property

Task.StartDate Property
[image]

Gets or sets the task's start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }

Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the task's scheduled start time. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
DueDate Property


MindFusion.Scheduling.Task.Status Property

Task.Status Property
[image]

Gets or sets the status of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TaskStatus Status { get; set; }

Visual Basic [image] Copy Code

Public Property Status As TaskStatus

Property Value

A member of the TaskStatus enumeration. The default is NotStarted.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Subject Property

Task.Subject Property
[image]

Gets or sets the subject of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Subject { get; set; }

Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string containing the task subject text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Class

TaskEventArgs Class
[image]

Contains the arguments passed to handlers of task related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class TaskEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TaskEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.TaskEventArgs

See Also

TaskEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Members

TaskEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of task related events raised by the Schedule class.

The following tables list the members exposed by the TaskEventArgs type.

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Properties

TaskEventArgs Properties
[image]

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs.Task Property

TaskEventArgs.Task Property
[image]

Gets the task related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Task Task { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class related to the raised event.

See Also

TaskEventArgs Members
TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration
[image]

Specifies the priority of a task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum TaskPriority

Visual Basic [image] Copy Code

Public Enum TaskPriority

Members

Member name | Description
High | Indicates high task priority.
Low | Indicates low task priority.
Normal | Indicates normal task priority.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration
[image]

Enumeration providing task status values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum TaskStatus

Visual Basic [image] Copy Code

Public Enum TaskStatus

Members

Member name | Description
Completed | Indicates a completed task.
Deferred | Indicates a deferred task.
InProgress | Indicates a task in progress.
NotStarted | Indicates that the task has not started yet.
WaitingOther | Indicates a task that depends on another task.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.UndoEventArgs

See Also

UndoEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)

Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of a Command-derived class.

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs Class

ValidateOccurrenceEventArgs Class
[image]

Contains the arguments passed to handlers of the ValidateOccurrence event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ValidateOccurrenceEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ValidateOccurrenceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ValidateOccurrenceEventArgs

See Also

ValidateOccurrenceEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs Members

ValidateOccurrenceEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ValidateOccurrence event.

The following tables list the members exposed by the ValidateOccurrenceEventArgs type.

Public Properties

Name | Description
Ignore | Gets or sets a value indicating whether this occurrence should be ignored in the pattern.
Item | Gets a reference to the occurrence being checked for validity.
RecurrenceIndex | Gets the zero-based index of the occurrence being validated.

See Also

ValidateOccurrenceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs Properties

ValidateOccurrenceEventArgs Properties
[image]

Public Properties

Name | Description
Ignore | Gets or sets a value indicating whether this occurrence should be ignored in the pattern.
Item | Gets a reference to the occurrence being checked for validity.
RecurrenceIndex | Gets the zero-based index of the occurrence being validated.

See Also

ValidateOccurrenceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs.Ignore Property

ValidateOccurrenceEventArgs.Ignore Property
[image]

Gets or sets a value indicating whether this occurrence should be ignored in the pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Ignore { get; set; }

Visual Basic [image] Copy Code

Public Property Ignore As Boolean

Property Value

true, to prevent this occurrence from appearing in the recurrence pattern; otherwise, false. The default is false.

See Also

ValidateOccurrenceEventArgs Members
ValidateOccurrenceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs.Item Property

ValidateOccurrenceEventArgs.Item Property
[image]

Gets a reference to the occurrence being checked for validity.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class specifying the occurrence for which the event is raised.

See Also

ValidateOccurrenceEventArgs Members
ValidateOccurrenceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ValidateOccurrenceEventArgs.RecurrenceIndex Property

ValidateOccurrenceEventArgs.RecurrenceIndex Property
[image]

Gets the zero-based index of the occurrence being validated.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int RecurrenceIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceIndex As Integer

Property Value

A non-negative integer value.

Remarks

At the time the item is being validated, it is still not marked as occurrence and its Item.OccurrenceIndex property returns -1. Therefore you need to use this property to obtain the actual recurrence index of the item. This is done to allow you to change any of the item's properties without forcing it to become an exception.

See Also

ValidateOccurrenceEventArgs Members
ValidateOccurrenceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class XmlSerializationContext : SerializationContext

Visual Basic [image] Copy Code

Public NotInheritable Class XmlSerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods Events
[image]

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadByte |
ReadChar |
ReadColor |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadEnum |
ReadFloat |
ReadInt |
ReadLong |
ReadObject |
ReadPoint |
ReadRect |
ReadRecurrence |
ReadReminder |
ReadSByte |
ReadShort |
ReadSize |
ReadString |
ReadTag |
ReadUInt |
ReadULong |
ReadUShort |
SelectNodes |
SelectSingleNode |
WriteBool |
WriteByte |
WriteChar |
WriteColor |
WriteDateTime |
WriteDecimal |
WriteDouble |
WriteEnum |
WriteFloat |
WriteInt |
WriteLong |
WriteObject |
WritePoint |
WriteRect |
WriteRecurrence |
WriteReminder |
WriteSByte |
WriteShort |
WriteSize |
WriteString |
WriteTag |
WriteUInt |
WriteULong |
WriteUShort |

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully. (Inherited from SerializationContext.)

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Schedule, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Schedule, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)

XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
int fileVersion,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

schedule
The Schedule this class will operate on.
fileVersion

The file version of the file being deserialized.

document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, XmlDocument)

XmlSerializationContext Constructor (Schedule, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
document As XmlDocument _
)

Parameters

schedule

The Schedule this class will operate on.

document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadByte |
ReadChar |
ReadColor |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadEnum |
ReadFloat |
ReadInt |
ReadLong |
ReadObject |
ReadPoint |
ReadRect |
ReadRecurrence |
ReadReminder |
ReadSByte |
ReadShort |
ReadSize |
ReadString |
ReadTag |
ReadUInt |
ReadULong |
ReadUShort |
SelectNodes |
SelectSingleNode |
WriteBool |
WriteByte |
WriteChar |
WriteColor |
WriteDateTime |
WriteDecimal |
WriteDouble |
WriteEnum |
WriteFloat |
WriteInt |
WriteLong |
WriteObject |
WritePoint |
WriteRect |
WriteRecurrence |
WriteReminder |
WriteSByte |
WriteShort |
WriteSize |
WriteString |
WriteTag |
WriteUInt |
WriteULong |
WriteUShort |

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Adds a new child node with the specified name to the specified parent node.

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement)

XmlSerializationContext.AddChildElement Method (String, XmlElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement, String)

XmlSerializationContext.AddChildElement Method (String, XmlElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.
innerText
The desired value of the new node.

Return Value

A .NET XmlElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Reads a boolean value with the specified name.

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.

Return Value

A bool value. Returns false if there is no element with the specified name under the specified parent.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.
defaultValue
The value that should be returned if there is no node with the specified name under the specified parent element.

Return Value

A bool value.

Remarks

If there is no element with the specified name, returns the specified default value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadByte Method (String, XmlElement)

XmlSerializationContext.ReadByte Method (String, XmlElement)
See Also
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName
The name of the element containing the byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadChar Method (String, XmlElement)

XmlSerializationContext.ReadChar Method (String, XmlElement)
See Also
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName
The name of the element containing the char value.
parentElement
The parent element of the node with the specified name.

Return Value

A char value. Returns 'a' if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteChar Method


MindFusion.Scheduling.XmlSerializationContext.ReadColor Method (String, XmlElement)

XmlSerializationContext.ReadColor Method (String, XmlElement)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName
The name of the element containing the .NET Color object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Color object. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColor Method


MindFusion.Scheduling.XmlSerializationContext.ReadDateTime Method (String, XmlElement)

XmlSerializationContext.ReadDateTime Method (String, XmlElement)
See Also
[image]

Reads a DateTime object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime ReadDateTime (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDateTime( _
elementName As String, _
parentElement As XmlElement _
) As DateTime

Parameters

elementName
The name of the element containing the .NET DateTime object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET DateTime object. Returns DateTime.MinValue if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDateTime Method


MindFusion.Scheduling.XmlSerializationContext.ReadDecimal Method (String, XmlElement)

XmlSerializationContext.ReadDecimal Method (String, XmlElement)
See Also
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName
The name of the element containing the decimal value.
parentElement
The parent element of the node with the specified name.

Return Value

A decimal value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDecimal Method


MindFusion.Scheduling.XmlSerializationContext.ReadDouble Method (String, XmlElement)

XmlSerializationContext.ReadDouble Method (String, XmlElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName
The name of the element containing the double value.
parentElement
The parent element of the node with the specified name.

Return Value

A double value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDouble Method


MindFusion.Scheduling.XmlSerializationContext.ReadEnum Method (String, XmlElement)

XmlSerializationContext.ReadEnum Method (String, XmlElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the enum value.
parentElement
The parent element of the node with the specified name.

Return Value

An enum value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteEnum Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloat Method (String, XmlElement)

XmlSerializationContext.ReadFloat Method (String, XmlElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName
The name of the element containing the float value.
parentElement
The parent element of the node with the specified name.

Return Value

A float value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloat Method


MindFusion.Scheduling.XmlSerializationContext.ReadInt Method (String, XmlElement)

XmlSerializationContext.ReadInt Method (String, XmlElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName
The name of the element containing the integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadLong Method (String, XmlElement)

XmlSerializationContext.ReadLong Method (String, XmlElement)
See Also
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName
The name of the element containing the long value.
parentElement
The parent element of the node with the specified name.

Return Value

An long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteLong Method


MindFusion.Scheduling.XmlSerializationContext.ReadObject Method (String, XmlElement)

XmlSerializationContext.ReadObject Method (String, XmlElement)
See Also
[image]

Reads an object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the value.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteObject Method


MindFusion.Scheduling.XmlSerializationContext.ReadPoint Method (String, XmlElement)

XmlSerializationContext.ReadPoint Method (String, XmlElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Point ReadPoint (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
elementName As String, _
parentElement As XmlElement _
) As Point

Parameters

elementName
The name of the element containing the .NET Point object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Point object. Returns an empty Point if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WritePoint Method


MindFusion.Scheduling.XmlSerializationContext.ReadRect Method (String, XmlElement)

XmlSerializationContext.ReadRect Method (String, XmlElement)
See Also
[image]

Reads a Rect object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Rect ReadRect (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRect( _
elementName As String, _
parentElement As XmlElement _
) As Rect

Parameters

elementName
The name of the element containing the Rect object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Rect object. Returns an empty Rect if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRect Method


MindFusion.Scheduling.XmlSerializationContext.ReadRecurrence Method (String, XmlElement)

XmlSerializationContext.ReadRecurrence Method (String, XmlElement)
See Also
[image]

Reads a Recurrence object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Recurrence ReadRecurrence (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRecurrence ( _
elementName As String, _
parentElement As XmlElement _
) As Recurrence

Parameters

elementName
The name of the element containing the Recurrence object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Recurrence class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.ReadReminder Method (String, XmlElement)

XmlSerializationContext.ReadReminder Method (String, XmlElement)
See Also
[image]

Reads a Reminder object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Reminder ReadReminder (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadReminder ( _
elementName As String, _
parentElement As XmlElement _
) As Reminder

Parameters

elementName
The name of the element containing the Reminder object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Reminder class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteReminder Method


MindFusion.Scheduling.XmlSerializationContext.ReadSByte Method (String, XmlElement)

XmlSerializationContext.ReadSByte Method (String, XmlElement)
See Also
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName

The name of the element containing the signed byte value.

parentElement
The parent element of the node with the specified name.

Return Value

A signed byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadShort Method (String, XmlElement)

XmlSerializationContext.ReadShort Method (String, XmlElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName
The name of the element containing the short value.
parentElement
The parent element of the node with the specified name.

Return Value

A short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteShort Method


MindFusion.Scheduling.XmlSerializationContext.ReadSize Method (String, XmlElement)

XmlSerializationContext.ReadSize Method (String, XmlElement)
See Also
[image]

Reads a Size object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Size ReadSize (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSize( _
elementName As String, _
parentElement As XmlElement _
) As Size

Parameters

elementName
The name of the element containing the .NET Size object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Size object. Returns an empty Size if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSize Method


MindFusion.Scheduling.XmlSerializationContext.ReadString Method (String, XmlElement)

XmlSerializationContext.ReadString Method (String, XmlElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName
The name of the element containing the string value.
parentElement
The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteString Method


MindFusion.Scheduling.XmlSerializationContext.ReadTag Method (Object, String, XmlElement)

XmlSerializationContext.ReadTag Method (Object, String, XmlElement)
See Also
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item
The Item whose tag is being read.
elementName
The name of the element containing the tag value.
parentElement
The parent element of the node with the specified name.

Return Value

An object value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteTag Method


MindFusion.Scheduling.XmlSerializationContext.ReadUInt Method (String, XmlElement)

XmlSerializationContext.ReadUInt Method (String, XmlElement)
See Also
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName
The name of the element containing the unsigned integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadULong Method (String, XmlElement)

XmlSerializationContext.ReadULong Method (String, XmlElement)
See Also
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName
The name of the element containing the unsigned long value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteULong Method


MindFusion.Scheduling.XmlSerializationContext.ReadUShort Method (String, XmlElement)

XmlSerializationContext.ReadUShort Method (String, XmlElement)
See Also
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName
The name of the element containing the unsigned short value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUShort Method


MindFusion.Scheduling.XmlSerializationContext.SelectNodes Method (XmlNode, String)

XmlSerializationContext.SelectNodes Method (XmlNode, String)
See Also
[image]

Selects all nodes matching the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static IEnumerable<XmlNode> SelectNodes (
XmlNode parent,
string name
)

Visual Basic [image] Copy Code

Public Shared Function SelectNodes( _
parent As XmlNode, _
name As String _
) As IEnumerable(Of XmlNode)

Parameters

parent

The parent element whose children are to be selected.

name

A string specifying the names of the nodes of interest.

Return Value

A .NET IEnumerable containing the nodes matching the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.SelectSingleNode Method (XmlNode, String)

XmlSerializationContext.SelectSingleNode Method (XmlNode, String)
See Also
[image]

Selects a node with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static XmlElement SelectSingleNode (
XmlNode parent,
string name
)

Visual Basic [image] Copy Code

Public Shared Function SelectSingleNode( _
parent As XmlNode, _
name As String _
) As XmlElement

Parameters

parent
The parent element whose child is to be selected.
name
A string specifying the name of the node of interest.

Return Value

A .NET XmlElement representing the found node or null (Nothing in Visual Basic) if no node with the specified name has been found.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteBool Method (Boolean, String, XmlElement)

XmlSerializationContext.WriteBool Method (Boolean, String, XmlElement)
See Also
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
value As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The bool value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBool Method


MindFusion.Scheduling.XmlSerializationContext.WriteByte Method (Byte, String, XmlElement)

XmlSerializationContext.WriteByte Method (Byte, String, XmlElement)
See Also
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
value As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteChar Method (Char, String, XmlElement)

XmlSerializationContext.WriteChar Method (Char, String, XmlElement)
See Also
[image]

Write a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
value As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The char value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadChar Method


MindFusion.Scheduling.XmlSerializationContext.WriteColor Method (Color, String, XmlElement)

XmlSerializationContext.WriteColor Method (Color, String, XmlElement)
See Also
[image]

Writes the specified color.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color
The .NET Color object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColor Method


MindFusion.Scheduling.XmlSerializationContext.WriteDateTime Method (DateTime, String, XmlElement)

XmlSerializationContext.WriteDateTime Method (DateTime, String, XmlElement)
See Also
[image]

Writes the specified DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDateTime (
DateTime value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDateTime( _
value As DateTime, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET DateTime object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDateTime Method


MindFusion.Scheduling.XmlSerializationContext.WriteDecimal Method (Decimal, String, XmlElement)

XmlSerializationContext.WriteDecimal Method (Decimal, String, XmlElement)
See Also
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
value As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The decimal value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDecimal Method


MindFusion.Scheduling.XmlSerializationContext.WriteDouble Method (Double, String, XmlElement)

XmlSerializationContext.WriteDouble Method (Double, String, XmlElement)
See Also
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
value As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The double value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDouble Method


MindFusion.Scheduling.XmlSerializationContext.WriteEnum Method (Object, String, XmlElement)

XmlSerializationContext.WriteEnum Method (Object, String, XmlElement)
See Also
[image]

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The enum value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadEnum Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloat Method (Single, String, XmlElement)

XmlSerializationContext.WriteFloat Method (Single, String, XmlElement)
See Also
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteFloat (
float value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
value As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The float value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloat Method


MindFusion.Scheduling.XmlSerializationContext.WriteInt Method (Int32, String, XmlElement)

XmlSerializationContext.WriteInt Method (Int32, String, XmlElement)
See Also
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
value As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteLong Method (Int64, String, XmlElement)

XmlSerializationContext.WriteLong Method (Int64, String, XmlElement)
See Also
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
value As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadLong Method


MindFusion.Scheduling.XmlSerializationContext.WriteObject Method (Object, String, XmlElement)

XmlSerializationContext.WriteObject Method (Object, String, XmlElement)
See Also
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadObject Method


MindFusion.Scheduling.XmlSerializationContext.WritePoint Method (Point, String, XmlElement)

XmlSerializationContext.WritePoint Method (Point, String, XmlElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WritePoint (
Point value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
value As Point, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET Point object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadPoint Method


MindFusion.Scheduling.XmlSerializationContext.WriteRect Method (Rect, String, XmlElement)

XmlSerializationContext.WriteRect Method (Rect, String, XmlElement)
See Also
[image]

Writes a Rect with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteRect (
Rect value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRect( _
value As Rect, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET Rect object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRect Method


MindFusion.Scheduling.XmlSerializationContext.WriteRecurrence Method (Recurrence, String, XmlElement)

XmlSerializationContext.WriteRecurrence Method (Recurrence, String, XmlElement)
See Also
[image]

Writes the specified Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteRecurrence (
Recurrence recurrence,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRecurrence ( _
recurrence As Recurrence, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

recurrence
The Recurrence instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.WriteReminder Method (Reminder, String, XmlElement)

XmlSerializationContext.WriteReminder Method (Reminder, String, XmlElement)
See Also
[image]

Writes the specified Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteReminder (
Reminder reminder,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteReminder ( _
reminder As Reminder, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

reminder
The Reminder instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadReminder Method


MindFusion.Scheduling.XmlSerializationContext.WriteSByte Method (SByte, String, XmlElement)

XmlSerializationContext.WriteSByte Method (SByte, String, XmlElement)
See Also
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
value As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

The signed byte value to write.

elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteShort Method (Int16, String, XmlElement)

XmlSerializationContext.WriteShort Method (Int16, String, XmlElement)
See Also
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
value As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadShort Method


MindFusion.Scheduling.XmlSerializationContext.WriteSize Method (Size, String, XmlElement)

XmlSerializationContext.WriteSize Method (Size, String, XmlElement)
See Also
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteSize (
Size value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSize( _
value As Size, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The .NET Size object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSize Method


MindFusion.Scheduling.XmlSerializationContext.WriteString Method (String, String, XmlElement)

XmlSerializationContext.WriteString Method (String, String, XmlElement)
See Also
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
value As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The string value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadString Method


MindFusion.Scheduling.XmlSerializationContext.WriteTag Method (Object, Object, String, XmlElement)

XmlSerializationContext.WriteTag Method (Object, Object, String, XmlElement)
See Also
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
The Item whose tag is being written.
tagValue
The tag value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadTag Method


MindFusion.Scheduling.XmlSerializationContext.WriteUInt Method (UInt32, String, XmlElement)

XmlSerializationContext.WriteUInt Method (UInt32, String, XmlElement)
See Also
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
value As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteULong Method (UInt64, String, XmlElement)

XmlSerializationContext.WriteULong Method (UInt64, String, XmlElement)
See Also
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
value As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadULong Method


MindFusion.Scheduling.XmlSerializationContext.WriteUShort Method (UInt16, String, XmlElement)

XmlSerializationContext.WriteUShort Method (UInt16, String, XmlElement)
See Also
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
value As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
The unsigned short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUShort Method


MindFusion.Scheduling.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ClassVersion Property

XmlSerializationContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version of the currently deserialized item as specified by the call to RegisterItemClass method at the time the item type was registered.

Remarks

This property is only useful when deserializing items.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the .NET XmlDocument class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Events

XmlSerializationContext Events
[image]

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully. (Inherited from SerializationContext.)

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration
[image]

Specifies the types of yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum YearlyRecurrence

Visual Basic [image] Copy Code

Public Enum YearlyRecurrence

Members

Member name | Description
ByDayType | The event occurs on a specific type of day of the specified week and month of the year.
SpecificDate | The event occurs on a specific date of the year.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Outlook Namespace

MindFusion.Scheduling.Outlook Namespace
Classes

Classes

Class | Description
ContactConfirmEventArgs | Contains the arguments passed to handlers of contact validation events.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events.
OutlookExporter | Provides methods for exporting items, contacts and tasks to Microsoft® Outlook®.
OutlookImporter | Provides methods for importing items, contacts and tasks from Microsoft® Outlook®.
TaskConfirmEventArgs | Contains the arguments passed to handlers of task validation events.


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Class

ContactConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of contact validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public class ContactConfirmEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ContactConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.ContactConfirmEventArgs

See Also

ContactConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Members

ContactConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of contact validation events.

The following tables list the members exposed by the ContactConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Contact | Gets the contact related to the event.

See Also

ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs Properties

ContactConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Contact | Gets the contact related to the event.

See Also

ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs.Confirm Property

ContactConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true, to confirm the operation; false, to reject it. The default is true.

See Also

ContactConfirmEventArgs Members
ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ContactConfirmEventArgs.Contact Property

ContactConfirmEventArgs.Contact Property
[image]

Gets the contact related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Contact Contact { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contact As Contact

Property Value

A reference to the related Contact object.

See Also

ContactConfirmEventArgs Members
ContactConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of item validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public class ItemConfirmEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.ItemConfirmEventArgs

See Also

ItemConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item validation events.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Item | Gets the item related to the event.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Item | Gets the item related to the event.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true, to confirm the operation; false, to reject it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.ItemConfirmEventArgs.Item Property

ItemConfirmEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

A reference to the related Item object.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Class

OutlookExporter Class
Remarks See Also
[image]

Provides methods for exporting items, contacts and tasks to Microsoft® Outlook®.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public class OutlookExporter

Visual Basic [image] Copy Code

Public Class OutlookExporter

Remarks

In order to export items from MindFusion.Scheduling for WPF to Microsoft® Outlook®, you create an instance of this class, optionally attach event handlers in order to perform conditional exporting, and invoke one of the export methods, depending on the type of objects you need to export - ExportItems, ExportContacts and ExportTasks.

Example

The following example demonstrates how to use OutlookExporter:

C# [image] Copy Code
OutlookExporter exporter = new OutlookExporter(calendar.Schedule);
exporter.ExportItems();
Visual Basic [image] Copy Code
Dim exporter As New OutlookExporter(calendar.Schedule)
exporter.ExportItems()

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Outlook.OutlookExporter

See Also

OutlookExporter Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Members

OutlookExporter Members
Constructors Properties Methods Events
[image]

Provides methods for exporting items, contacts and tasks to Microsoft® Outlook®.

The following tables list the members exposed by the OutlookExporter type.

Public Constructors

Name | Description
OutlookExporter | Overloaded. Initializes a new instance of the OutlookExporter class.

Public Properties

Name | Description
Schedule | Gets the schedule, associated with the exporter.

Public Methods

Name | Description
ExportContacts | Exports all contacts from associated schedule to Outlook®.
ExportItems | Exports all events from the associated schedule to Outlook®.
ExportTasks | Exports all tasks from the associated schedule to Outlook®.

Protected Methods

Name | Description
OnContactExporting | Raises the ContactExporting event.
OnItemExporting | Raises the ItemExporting event.
OnTaskExporting | Raises the TaskExporting event.

Public Events

Name | Description
ContactExporting | Fired for each contact to confirm that the contact should be exported.
ItemExporting | Fired for each item to confirm that the item should be exported.
TaskExporting | Fired for each task to confirm that the task should be exported.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor

OutlookExporter Constructor
[image]

Initializes a new instance of the OutlookExporter class.

Overload List

Name | Description
OutlookExporter (Schedule) | Initializes a new instance of the OutlookExporter class with the specified Schedule object.
OutlookExporter (Schedule, Object, Object) | Initializes a new instance of the OutlookExporter class with the specified Schedule object.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor (Schedule)

OutlookExporter Constructor (Schedule)
See Also
[image]

Initializes a new instance of the OutlookExporter class with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public OutlookExporter (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
A Schedule object to supply the data to export.

See Also

OutlookExporter Constructor Overload List
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Constructor (Schedule, Object, Object)

OutlookExporter Constructor (Schedule, Object, Object)
See Also
[image]

Initializes a new instance of the OutlookExporter class with the specified Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public OutlookExporter (
Schedule schedule,
Object profile,
Object password
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
profile As Object, _
password As Object _
)

Parameters

schedule
A Schedule object to supply the data to export.
profile
Outlook's profile name. Pass null (Nothing in Visual Basic) or empty string for default profile.
password
Profile's password. If no password is required by mentioned profile pass null (Nothing in Visual Basic) or empty string.

See Also

OutlookExporter Constructor Overload List
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Methods

OutlookExporter Methods
[image]

Public Methods

Name | Description
ExportContacts | Exports all contacts from associated schedule to Outlook®.
ExportItems | Exports all events from the associated schedule to Outlook®.
ExportTasks | Exports all tasks from the associated schedule to Outlook®.

Protected Methods

Name | Description
OnContactExporting | Raises the ContactExporting event.
OnItemExporting | Raises the ItemExporting event.
OnTaskExporting | Raises the TaskExporting event.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.ExportContacts Method

OutlookExporter.ExportContacts Method
[image]

Exports all contacts from associated schedule to Outlook®.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ExportContacts ()

Visual Basic [image] Copy Code

Public Sub ExportContacts ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportItems Method
ExportTasks Method


MindFusion.Scheduling.Outlook.OutlookExporter.ExportItems Method

OutlookExporter.ExportItems Method
[image]

Exports all events from the associated schedule to Outlook®.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ExportItems ()

Visual Basic [image] Copy Code

Public Sub ExportItems ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportContacts Method
ExportTasks Method


MindFusion.Scheduling.Outlook.OutlookExporter.ExportTasks Method

OutlookExporter.ExportTasks Method
[image]

Exports all tasks from the associated schedule to Outlook®.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ExportTasks ()

Visual Basic [image] Copy Code

Public Sub ExportTasks ()

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ExportContacts Method
ExportItems Method


MindFusion.Scheduling.Outlook.OutlookExporter.OnContactExporting Method

OutlookExporter.OnContactExporting Method
[image]

Raises the ContactExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnContactExporting (
ContactConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContactExporting ( _
e As ContactConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.OnItemExporting Method

OutlookExporter.OnItemExporting Method
[image]

Raises the ItemExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnItemExporting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemExporting( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.OnTaskExporting Method

OutlookExporter.OnTaskExporting Method
[image]

Raises the TaskExporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnTaskExporting (
TaskConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTaskExporting( _
e As TaskConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Properties

OutlookExporter Properties
[image]

Public Properties

Name | Description
Schedule | Gets the schedule, associated with the exporter.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.Schedule Property

OutlookExporter.Schedule Property
[image]

Gets the schedule, associated with the exporter.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Schedule Schedule { get; set; }

Visual Basic [image] Copy Code

Public Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter Events

OutlookExporter Events
[image]

Public Events

Name | Description
ContactExporting | Fired for each contact to confirm that the contact should be exported.
ItemExporting | Fired for each item to confirm that the item should be exported.
TaskExporting | Fired for each task to confirm that the task should be exported.

See Also

OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookExporter.ContactExporting Event

OutlookExporter.ContactExporting Event
[image]

Fired for each contact to confirm that the contact should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<ContactConfirmEventArgs> ContactExporting

Visual Basic [image] Copy Code

Public Event ContactExporting As EventHandler(Of ContactConfirmEventArgs)

Event Data

ContactExporting event handlers receive an argument of type ContactConfirmEventArgs.

Remarks

You can use this event to filter out certain contacts during export.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ItemExporting Event
TaskExporting Event


MindFusion.Scheduling.Outlook.OutlookExporter.ItemExporting Event

OutlookExporter.ItemExporting Event
[image]

Fired for each item to confirm that the item should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemExporting

Visual Basic [image] Copy Code

Public Event ItemExporting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemExporting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

You can use this event to filter out certain items during export.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ContactExporting Event
TaskExporting Event


MindFusion.Scheduling.Outlook.OutlookExporter.TaskExporting Event

OutlookExporter.TaskExporting Event
[image]

Fired for each task to confirm that the task should be exported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<TaskConfirmEventArgs> TaskExporting

Visual Basic [image] Copy Code

Public Event TaskExporting As EventHandler(Of TaskConfirmEventArgs)

Event Data

TaskExporting event handlers receive an argument of type TaskConfirmEventArgs.

Remarks

You can use this event to filter out certain tasks during export.

See Also

OutlookExporter Members
OutlookExporter Class
MindFusion.Scheduling.Outlook Namespace
ContactExporting Event
ItemExporting Event


MindFusion.Scheduling.Outlook.OutlookImporter Class

OutlookImporter Class
Remarks See Also
[image]

Provides methods for importing items, contacts and tasks from Microsoft® Outlook®.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public class OutlookImporter

Visual Basic [image] Copy Code

Public Class OutlookImporter

Remarks

In order to import items to MindFusion.Scheduling for WPF from Microsoft® Outlook®, you create an instance of this class, optionally attach event handlers in order to perform conditional importing, and invoke one of the import methods, depending on the type of objects you need to import - ImportItems, ImportContacts and ImportTasks.

Example

The following example demonstrates how to use OutlookImporter:

C# [image] Copy Code
OutlookImporter importer = new OutlookImporter(calendar.Schedule);
importer.ImportItems();
Visual Basic [image] Copy Code
Dim importer As New OutlookImporter(calendar.Schedule)
importer.ImportItems()

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Outlook.OutlookImporter

See Also

OutlookImporter Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Members

OutlookImporter Members
Constructors Properties Methods Events
[image]

Provides methods for importing items, contacts and tasks from Microsoft® Outlook®.

The following tables list the members exposed by the OutlookImporter type.

Public Constructors

Name | Description
OutlookImporter | Overloaded. Initializes a new instance of the OutlookImporter class.

Public Properties

Name | Description
ItemType | Gets or sets the type of the items that will be created by the importer. The default value, null (Nothing in Visual Basic), indicates items of type Appointment.
Schedule | Gets or sets the schedule, associated with the importer.

Public Methods

Name | Description
ImportContacts | Imports all contacts from Outlook® to the associated schedule.
ImportItems | Overloaded. Imports all events from Outlook® to the associated schedule.
ImportTasks | Overloaded. Imports all tasks from Outlook® to the associated schedule.

Protected Methods

Name | Description
OnContactImporting | Raises the ContactImporting event.
OnItemImporting | Raises the ItemImporting event.
OnTaskImporting | Raises the TaskImporting event.

Public Events

Name | Description
ContactImporting | Fired for each contact to confirm that the contact should be imported.
ItemImporting | Fired for each item to confirm that the item should be imported.
TaskImporting | Fired for each task to confirm that the task should be imported.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor

OutlookImporter Constructor
[image]

Initializes a new instance of the OutlookImporter class.

Overload List

Name | Description
OutlookImporter (Schedule) | Initializes a new instance of the OutlookImporter class with a Schedule object.
OutlookImporter (Schedule, Object, Object) | Initializes a new instance of the OutlookImporter class and initializes it with a Schedule object.
OutlookImporter (Schedule, Object, Object, String) | Initializes a new instance of the OutlookImporter class and initializes it with a Schedule object.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor (Schedule)

OutlookImporter Constructor (Schedule)
See Also
[image]

Initializes a new instance of the OutlookImporter class with a Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public OutlookImporter (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
A Schedule object where the data will be imported.

See Also

OutlookImporter Constructor Overload List
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor (Schedule, Object, Object)

OutlookImporter Constructor (Schedule, Object, Object)
See Also
[image]

Initializes a new instance of the OutlookImporter class and initializes it with a Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public OutlookImporter (
Schedule schedule,
Object profile,
Object password
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
profile As Object, _
password As Object _
)

Parameters

schedule
A Schedule object where the data will be imported.
profile
Outlook's profile name. Pass null (Nothing in Visual Basic) or empty string for default profile.
password
Profile's password. If no password is required by mentioned profile pass null (Nothing in Visual Basic) or empty string.

See Also

OutlookImporter Constructor Overload List
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Constructor (Schedule, Object, Object, String)

OutlookImporter Constructor (Schedule, Object, Object, String)
See Also
[image]

Initializes a new instance of the OutlookImporter class and initializes it with a Schedule object.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public OutlookImporter (
Schedule schedule,
Object profile,
Object password,
string recipient
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
profile As Object, _
password As Object, _
recipient As String _
)

Parameters

schedule
A Schedule object where the data will be imported.
profile
Outlook's profile name. Pass null (Nothing in Visual Basic) or empty string for default profile.
password
Profile's password. If no password is required by mentioned profile pass null (Nothing in Visual Basic) or empty string.
recipient

The recipient whose shared calendar the importer will work on.

See Also

OutlookImporter Constructor Overload List
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Methods

OutlookImporter Methods
[image]

Public Methods

Name | Description
ImportContacts | Imports all contacts from Outlook® to the associated schedule.
ImportItems | Overloaded. Imports all events from Outlook® to the associated schedule.
ImportTasks | Overloaded. Imports all tasks from Outlook® to the associated schedule.

Protected Methods

Name | Description
OnContactImporting | Raises the ContactImporting event.
OnItemImporting | Raises the ItemImporting event.
OnTaskImporting | Raises the TaskImporting event.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ImportContacts Method

OutlookImporter.ImportContacts Method
[image]

Imports all contacts from Outlook® to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ImportContacts ()

Visual Basic [image] Copy Code

Public Sub ImportContacts ()

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportItems Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportItems Method

OutlookImporter.ImportItems Method
[image]

Imports all events from Outlook® to the associated schedule.

Overload List

Name | Description
OutlookImporter.ImportItems () | Imports all events from the default Outlook® folder to the associated schedule.
OutlookImporter.ImportItems (String) | Imports all events from the specified Outlook® folder to the associated schedule.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportItems Method ()

OutlookImporter.ImportItems Method ()
See Also
[image]

Imports all events from the default Outlook® folder to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ImportItems ()

Visual Basic [image] Copy Code

Public Sub ImportItems ()

See Also

ImportItems Method Overload List
OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportItems Method (String)

OutlookImporter.ImportItems Method (String)
See Also
[image]

Imports all events from the specified Outlook® folder to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ImportItems (
string folderName
)

Visual Basic [image] Copy Code

Public Sub ImportItems( _
folderName As String _
)

Parameters

folderName
The Outlook® folder to import from.

See Also

ImportItems Method Overload List
OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportTasks Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportTasks Method

OutlookImporter.ImportTasks Method
[image]

Imports all tasks from Outlook® to the associated schedule.

Overload List

Name | Description
OutlookImporter.ImportTasks () | Imports all tasks from Outlook® to the associated schedule.
OutlookImporter.ImportTasks (MAPIFolder) | Imports all tasks from the specified Outlook® folder to the associated schedule.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ImportContacts Method
ImportItems Method


MindFusion.Scheduling.Outlook.OutlookImporter.ImportTasks Method ()

OutlookImporter.ImportTasks Method ()
See Also
[image]

Imports all tasks from Outlook® to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ImportTasks ()

Visual Basic [image] Copy Code

Public Sub ImportTasks ()

See Also

ImportTasks Method Overload List
OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ImportTasks Method (MAPIFolder)

OutlookImporter.ImportTasks Method (MAPIFolder)
See Also
[image]

Imports all tasks from the specified Outlook® folder to the associated schedule.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public void ImportTasks (
MAPIFolder folder
)

Visual Basic [image] Copy Code

Public Sub ImportTasks( _
folder As MAPIFolder _
)

Parameters

folder

See Also

ImportTasks Method Overload List
OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.OnContactImporting Method

OutlookImporter.OnContactImporting Method
[image]

Raises the ContactImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnContactImporting (
ContactConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContactImporting ( _
e As ContactConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.OnItemImporting Method

OutlookImporter.OnItemImporting Method
[image]

Raises the ItemImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnItemImporting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemImporting ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.OnTaskImporting Method

OutlookImporter.OnTaskImporting Method
[image]

Raises the TaskImporting event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

protected virtual void OnTaskImporting (
TaskConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTaskImporting ( _
e As TaskConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Properties

OutlookImporter Properties
[image]

Public Properties

Name | Description
ItemType | Gets or sets the type of the items that will be created by the importer. The default value, null (Nothing in Visual Basic), indicates items of type Appointment.
Schedule | Gets or sets the schedule, associated with the importer.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ItemType Property

OutlookImporter.ItemType Property
[image]

Gets or sets the type of the items that will be created by the importer. The default value, null (Nothing in Visual Basic), indicates items of type Appointment.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Type ItemType { get; set; }

Visual Basic [image] Copy Code

Public Property ItemType As Type

Property Value

A .NET Type object.

Remarks

You usually need to set this property when you are using custom items and would want the items created by the importer class to be of your custom type instead of Appointment. The specified type should derive, directly or indirectly, from Item and should provide a parameterless constructor.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.Schedule Property

OutlookImporter.Schedule Property
[image]

Gets or sets the schedule, associated with the importer.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Schedule Schedule { get; set; }

Visual Basic [image] Copy Code

Public Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter Events

OutlookImporter Events
[image]

Public Events

Name | Description
ContactImporting | Fired for each contact to confirm that the contact should be imported.
ItemImporting | Fired for each item to confirm that the item should be imported.
TaskImporting | Fired for each task to confirm that the task should be imported.

See Also

OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.OutlookImporter.ContactImporting Event

OutlookImporter.ContactImporting Event
[image]

Fired for each contact to confirm that the contact should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<ContactConfirmEventArgs> ContactImporting

Visual Basic [image] Copy Code

Public Event ContactImporting As EventHandler(Of ContactConfirmEventArgs)

Event Data

ContactImporting event handlers receive an argument of type ContactConfirmEventArgs.

Remarks

You can use this event to filter out certain contacts during import.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ItemImporting Event
TaskImporting Event


MindFusion.Scheduling.Outlook.OutlookImporter.ItemImporting Event

OutlookImporter.ItemImporting Event
[image]

Fired for each item to confirm that the item should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemImporting

Visual Basic [image] Copy Code

Public Event ItemImporting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemImporting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

You can use this event to filter out certain items during import.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ContactImporting Event
TaskImporting Event


MindFusion.Scheduling.Outlook.OutlookImporter.TaskImporting Event

OutlookImporter.TaskImporting Event
[image]

Fired for each task to confirm that the task should be imported.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public event EventHandler<TaskConfirmEventArgs> TaskImporting

Visual Basic [image] Copy Code

Public Event TaskImporting As EventHandler(Of TaskConfirmEventArgs)

Event Data

TaskImporting event handlers receive an argument of type TaskConfirmEventArgs.

Remarks

You can use this event to filter out certain tasks during import.

See Also

OutlookImporter Members
OutlookImporter Class
MindFusion.Scheduling.Outlook Namespace
ContactImporting Event
ItemImporting Event


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Class

TaskConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of task validation events.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public class TaskConfirmEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TaskConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Outlook.TaskConfirmEventArgs

See Also

TaskConfirmEventArgs Members
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Members

TaskConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of task validation events.

The following tables list the members exposed by the TaskConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Task | Gets the task related to the event.

See Also

TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs Properties

TaskConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Task | Gets the task related to the event.

See Also

TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs.Confirm Property

TaskConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true, to confirm the operation; false, to reject it. The default is true.

See Also

TaskConfirmEventArgs Members
TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Outlook.TaskConfirmEventArgs.Task Property

TaskConfirmEventArgs.Task Property
[image]

Gets the task related to the event.

Namespace: MindFusion.Scheduling.Outlook
Assembly: MindFusion.Scheduling.Wpf.Outlook

Syntax

C# [image] Copy Code

public Task Task { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

A reference to the related Task object.

See Also

TaskConfirmEventArgs Members
TaskConfirmEventArgs Class
MindFusion.Scheduling.Outlook Namespace


MindFusion.Scheduling.Reporting Namespace

MindFusion.Scheduling.Reporting Namespace
Classes Enumerations

Classes

Class | Description
Report | Provides methods to generate, preview and print reports of Schedule objects.
ReportColumn | Represents a column in the report table.
ReportFilterItemEventArgs | Contains the arguments passed to handlers of the FilterItem event raised by the Report class.
ReportOptions | Encapsulates the options controlling the printing and previewing of a report.
ReportQueryHeaderTextEventArgs | Contains the arguments passed to handlers of the QueryHeaderText event raised by the Report class.
ReportQueryStyleEventArgs | Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.
ReportQueryTextEventArgs | Contains the arguments passed to handlers of the QueryText event raised by the Report class.
ReportStyle | Provides visualization settings for various report elements.

Enumerations

Enumeration | Description
ReportGroupType | Specifies grouping criteria for reports.
Sort | Specifies a sorting.


MindFusion.Scheduling.Reporting.Report Class

Report Class
Remarks See Also
[image]

Provides methods to generate, preview and print reports of Schedule objects.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class Report : IDocumentPaginatorSource

Visual Basic [image] Copy Code

Public Class Report
Implements IDocumentPaginatorSource

Remarks

In order to create reports, you need to instantiate an object from this class. Then you need to specify the columns to display in the report by invoking the CreateColumn method and setting the appropriate properties of the returned ReportColumn object. Finally, you need to invoke the Print or PrintPreview methods of the Report object in order to print or preview the report accordingly.

For additional information, check Creating and Printing Reports.

Note

The Excel export relies on the Ionic.Zip library, which is based on JZlib. The following copyright notice copyright noticeReport is used.

Example

The following example demonstrates how to create a simple report, containing three columns. The columns display the appointment's HeaderText, StartTime and EndTime values respectively and are sorted by the StartTime of the appointments. The example assumes that calendar is a variable identifying existing Calendar control.

C# [image] Copy Code

Report report = new Report(calendar.Schedule);

ReportColumn headerTextColumn = report.CreateColumn();
headerTextColumn.Property = "HeaderText";
headerTextColumn.Width = 100;

ReportColumn startTimeColumn = report.CreateColumn();
startTimeColumn.Property = "StartTime";
startTimeColumn.Sort = Sort.Ascending;
startTimeColumn.Width = 50;

ReportColumn endTimeColumn = report.CreateColumn();
endTimeColumn.Property = "EndTime";
endTimeColumn.Width = 50;

report.Print(DateTime.MinValue, DateTime.MaxValue);

Visual Basic [image] Copy Code

Dim report As New Report(calendar.Schedule)

Dim headerTextColumn As ReportColumn = report.CreateColumn()
headerTextColumn.Property = "HeaderText"
headerTextColumn.Width = 100

Dim startTimeColumn As ReportColumn = report.CreateColumn()
startTimeColumn.Property = "StartTime"
startTimeColumn.Sort = Sort.Ascending
startTimeColumn.Width = 50

Dim endTimeColumn As ReportColumn = report.CreateColumn()
endTimeColumn.Property = "EndTime"
endTimeColumn.Width = 50

report.Print(DateTime.MinValue, DateTime.MaxValue)

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.Report

See Also

Report Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Members

Report Members
Constructors Properties Methods Events
[image]

Provides methods to generate, preview and print reports of Schedule objects.

The following tables list the members exposed by the Report type.

Public Constructors

Name | Description
Report | Initializes a new instance of the Report class.

Public Properties

Name | Description
Columns | Gets an IEnumerable for all columns in the report.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
Options | Gets the options, controlling the print output.
Schedule | Gets or sets the schedule to be printed or previewed by the report.

Public Methods

Name | Description
CreateColumn | Creates a new report column and adds it to the report's Columns collection.
ExportExcel | Exports the items in the specified range from the underlying schedule as an Open Office XML format.
ExportPdf | Exports the items in the specified range from the underlying schedule as PDF.
Print | Prints the items in the specified range from the underlying schedule.
PrintPreview | Overloaded. Shows Print preview dialog for the report.

Protected Methods

Name | Description
OnFilterItem | Raises the FilterItem event.
OnQueryHeaderText | Raises the QueryHeaderText event.
OnQueryStyle | Raises the QueryStyle event.
OnQueryText | Raises the QueryText event.

Public Events

Name | Description
FilterItem | Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.
QueryHeaderText | Raised to allow clients to customize the text of column headers.
QueryStyle | Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.
QueryText | Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Constructor

Report Constructor
[image]

Initializes a new instance of the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Report (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule

A reference to the Schedule on which the report will operate on.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Methods

Report Methods
[image]

Public Methods

Name | Description
CreateColumn | Creates a new report column and adds it to the report's Columns collection.
ExportExcel | Exports the items in the specified range from the underlying schedule as an Open Office XML format.
ExportPdf | Exports the items in the specified range from the underlying schedule as PDF.
Print | Prints the items in the specified range from the underlying schedule.
PrintPreview | Overloaded. Shows Print preview dialog for the report.

Protected Methods

Name | Description
OnFilterItem | Raises the FilterItem event.
OnQueryHeaderText | Raises the QueryHeaderText event.
OnQueryStyle | Raises the QueryStyle event.
OnQueryText | Raises the QueryText event.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.CreateColumn Method

Report.CreateColumn Method
[image]

Creates a new report column and adds it to the report's Columns collection.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportColumn CreateColumn ()

Visual Basic [image] Copy Code

Public Function CreateColumn () As ReportColumn

Return Value

A ReportColumn object representing a newly created column.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.ExportExcel Method

Report.ExportExcel Method
[image]

Exports the items in the specified range from the underlying schedule as an Open Office XML format.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public void ExportExcel (
string filePath,
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub ExportExcel( _
filePath As String, _
start As DateTime, _
end As DateTime _
)

Parameters

filePath

The name of the XLSX file to export to.

start
A DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A DateTime object, specifying the end of the time interval containing the items to be included in the report.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.ExportPdf Method

Report.ExportPdf Method
[image]

Exports the items in the specified range from the underlying schedule as PDF.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public void ExportPdf (
string filePath,
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub ExportPdf( _
filePath As String, _
start As DateTime, _
end As DateTime _
)

Parameters

filePath

The name of the PDF file to export to.

start
A DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

You would usually specify DateTime.MinValue and DateTime.MaxValue for the start and end parameters respectively, in order to include all items in the report. However, this can be dangerous when there are infinite recurring items. In this case the report generation might take considerable amount of time.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnFilterItem Method

Report.OnFilterItem Method
[image]

Raises the FilterItem event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

protected void OnFilterItem (
ReportFilterItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnFilterItem ( _
e As ReportFilterItemEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryHeaderText Method

Report.OnQueryHeaderText Method
[image]

Raises the QueryHeaderText event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

protected void OnQueryHeaderText (
ReportQueryHeaderTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnQueryHeaderText ( _
e As ReportQueryHeaderTextEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryStyle Method

Report.OnQueryStyle Method
[image]

Raises the QueryStyle event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

protected void OnQueryStyle (
ReportQueryStyleEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnQueryStyle ( _
e As ReportQueryStyleEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.OnQueryText Method

Report.OnQueryText Method
[image]

Raises the QueryText event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

protected void OnQueryText (
ReportQueryTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Sub OnQueryText ( _
e As ReportQueryTextEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Print Method

Report.Print Method
[image]

Prints the items in the specified range from the underlying schedule.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public void Print (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Print( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

You would usually specify DateTime.MinValue and DateTime.MaxValue for the start and end parameters respectively, in order to include all items in the report. However, this can be dangerous when there are infinite recurring items. In this case the report generation might take considerable amount of time.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.PrintPreview Method

Report.PrintPreview Method
[image]

Shows Print preview dialog for the report.

Overload List

Name | Description
Report.PrintPreview (DateTime, DateTime) | Shows Print preview dialog for the report.
Report.PrintPreview (DateTime, DateTime, String) | Shows Print preview dialog with the specified title for the report.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.PrintPreview Method (DateTime, DateTime)

Report.PrintPreview Method (DateTime, DateTime)
See Also
[image]

Shows Print preview dialog for the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public void PrintPreview (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A DateTime object, specifying the end of the time interval containing the items to be included in the report.

Remarks

You would usually specify DateTime.MinValue and DateTime.MaxValue for the start and end parameters respectively, in order to include all items in the report. However, this can be dangerous when there are infinite recurring items. In this case the report generation might take considerable amount of time.

See Also

PrintPreview Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.PrintPreview Method (DateTime, DateTime, String)

Report.PrintPreview Method (DateTime, DateTime, String)
See Also
[image]

Shows Print preview dialog with the specified title for the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public void PrintPreview (
DateTime start,
DateTime end,
string windowTitle
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
start As DateTime, _
end As DateTime, _
windowTitle As String _
)

Parameters

start
A DateTime object, specifying the beginning of the time interval containing the items to be included in the report.
end
A DateTime object, specifying the end of the time interval containing the items to be included in the report.
windowTitle
The string to be displayed in the preview window's title bar.

Remarks

You would usually specify DateTime.MinValue and DateTime.MaxValue for the start and end parameters respectively, in order to include all items in the report. However, this can be dangerous when there are infinite recurring items. In this case the report generation might take considerable amount of time.

See Also

PrintPreview Method Overload List
Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Properties

Report Properties
[image]

Public Properties

Name | Description
Columns | Gets an IEnumerable for all columns in the report.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
Options | Gets the options, controlling the print output.
Schedule | Gets or sets the schedule to be printed or previewed by the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Columns Property

Report.Columns Property
[image]

Gets an IEnumerable for all columns in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public IEnumerable<ReportColumn> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As IEnumerable(Of ReportColumn)

Property Value

An IEnumerable object which can be used to iterate over the columns in the report.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.DocumentPaginator Property

Report.DocumentPaginator Property
[image]

IDocumentPaginatorSource.DocumentPaginator implementation.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

A DocumentPaginator-derived class that performs the actual content pagination.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Options Property

Report.Options Property
[image]

Gets the options, controlling the print output.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportOptions Options { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Options As ReportOptions

Property Value

An instance of the ReportOptions class, which provides the ability to customize the report.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.Schedule Property

Report.Schedule Property
[image]

Gets or sets the schedule to be printed or previewed by the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

A reference to the underlying Schedule object.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report Events

Report Events
[image]

Public Events

Name | Description
FilterItem | Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.
QueryHeaderText | Raised to allow clients to customize the text of column headers.
QueryStyle | Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.
QueryText | Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

See Also

Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.FilterItem Event

Report.FilterItem Event
[image]

Raised for each individual item in the report during printing or previewing to confirm the item's availability in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<ReportFilterItemEventArgs> FilterItem

Visual Basic [image] Copy Code

Public Event FilterItem As EventHandler(Of ReportFilterItemEventArgs)

Event Data

FilterItem event handlers receive an argument of type ReportFilterItemEventArgs.

Remarks

You can use this event to remove items that meet specific criteria from the report. If you want to filter the items based on their StartTime and EndTime properties, you can use the corresponding arguments of the Print and PrintPreview methods.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryHeaderText Event

Report.QueryHeaderText Event
[image]

Raised to allow clients to customize the text of column headers.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<ReportQueryHeaderTextEventArgs> QueryHeaderText

Visual Basic [image] Copy Code

Public Event QueryHeaderText As EventHandler(Of ReportQueryHeaderTextEventArgs)

Event Data

QueryHeaderText event handlers receive an argument of type ReportQueryHeaderTextEventArgs.

Remarks

This event is fired for column and group headers. While it is non-essential for column headers where you can specify custom display texts through the Header property, it is useful for the group headers, where the text is automatically determined from the displayed resource.

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryStyle Event

Report.QueryStyle Event
[image]

Raised during the printing or previewing to allow clients to customize the style of elements displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<ReportQueryStyleEventArgs> QueryStyle

Visual Basic [image] Copy Code

Public Event QueryStyle As EventHandler(Of ReportQueryStyleEventArgs)

Event Data

QueryStyle event handlers receive an argument of type ReportQueryStyleEventArgs.

Remarks

The style of the cells displayed in the report is controlled from several properties. The ContentStyle and AlternativeContentStyle properties of the associated ReportOptions object provide general styling of the contents. The ContentStyle and AlternativeContentStyle properties of the individual ReportColumn objects provide more specific styling for the cells associated with a particular column.

You can use this event to specify even more detailed styling - for individual cells that meet certain criteria. For example, you can specify different background for cells which display specific value.

Example

The following example demonstrates how to specify red background for all items which end in the past:

C# [image] Copy Code
void OnQueryStyle(object sender, ReportQueryStyleEventArgs e)
{
if (e.Item.EndTime < DateTime.Now)
{
ReportStyle customStyle = new ReportStyle();
customStyle.Background = Brushes.Red;
e.Style = customStyle;
}
}
Visual Basic [image] Copy Code

Sub OnQueryStyle(ByVal sender As Object, ByVal e As ReportQueryStyleEventArgs)

If e.Item.EndTime < DateTime.Now Then

Dim customStyle As New ReportStyle()
customStyle.Background = Brushes.Red
e.Style = customStyle

End If

End Sub

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Report.QueryText Event

Report.QueryText Event
[image]

Raised during the printing or previewing to allow clients to customize particular texts displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public event EventHandler<ReportQueryTextEventArgs> QueryText

Visual Basic [image] Copy Code

Public Event QueryText As EventHandler(Of ReportQueryTextEventArgs)

Event Data

QueryText event handlers receive an argument of type ReportQueryTextEventArgs.

Remarks

The QueryText event is raised for individual values displayed in the report. This is very convenient when you need to format some common types, such as DateTime.

Example

The following example demonstrates how to format all DateTime objects in a report with a custom format using the QueryText event:

C# [image] Copy Code
void OnQueryText(object sender, ReportQueryTextEventArgs e)
{
if (e.Value is DateTime)
e.Representation = ((DateTime)e.Value).ToString("MMM dd, dddd");
}
Visual Basic [image] Copy Code

Sub OnQueryText(ByVal sender As Object, ByVal e As ReportQueryTextEventArgs)

If (TypeOf e.Value Is DateTime) Then
e.Representation = (CType(e.Value, DateTime)).ToString("MMM dd, dddd")
End If

End Sub

See Also

Report Members
Report Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Class

ReportColumn Class
Remarks See Also
[image]

Represents a column in the report table.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportColumn

Visual Basic [image] Copy Code

Public Class ReportColumn

Remarks

You create new columns in a report by calling its CreateColumn method. The method returns an instance of the ReportColumn class which can be used to customize the newly created column.

The most important property of the report column is Property. It specifies the item property which will be displayed in the column. The width of the column can be specified through the Width property. Depending on the AbsoluteColumnWidth property of the ReportOptions class the width is either an absolute value (expressed as independent device pixels) or a value relative to the widths of the other columns in the report.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.ReportColumn

See Also

ReportColumn Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Members

ReportColumn Members
Properties
[image]

Represents a column in the report table.

The following tables list the members exposed by the ReportColumn type.

Public Properties

Name | Description
AlternativeContentStyle | Gets or sets the visualization settings for the alternative rows in this column.
ContentStyle | Gets or sets the visualization settings for this column's content.
Header | Gets or sets the header text of the column.
HeaderStyle | Gets or sets the visualization settings for this column's header.
Property | Gets or sets the Item property displayed in the column.
Sort | Gets or sets the sort of the column.
SortPriority | Gets or sets the sort priority of the column.
Visible | Gets or sets a value indicating whether the column is displayed in the report.
Width | Gets or sets the width of the column.

See Also

ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn Properties

ReportColumn Properties
[image]

Public Properties

Name | Description
AlternativeContentStyle | Gets or sets the visualization settings for the alternative rows in this column.
ContentStyle | Gets or sets the visualization settings for this column's content.
Header | Gets or sets the header text of the column.
HeaderStyle | Gets or sets the visualization settings for this column's header.
Property | Gets or sets the Item property displayed in the column.
Sort | Gets or sets the sort of the column.
SortPriority | Gets or sets the sort priority of the column.
Visible | Gets or sets a value indicating whether the column is displayed in the report.
Width | Gets or sets the width of the column.

See Also

ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.AlternativeContentStyle Property

ReportColumn.AlternativeContentStyle Property
[image]

Gets or sets the visualization settings for the alternative rows in this column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle AlternativeContentStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AlternativeContentStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of even cells in this column.

Remarks

This style is initially empty. Which means that all values are obtained from the AlternativeContentStyle of the associated ReportOptions.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
ContentStyle Property
HeaderStyle Property


MindFusion.Scheduling.Reporting.ReportColumn.ContentStyle Property

ReportColumn.ContentStyle Property
[image]

Gets or sets the visualization settings for this column's content.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle ContentStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ContentStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of the cells in this column.

Remarks

This style is initially empty. Which means that all values are obtained from the ContentStyle of the associated ReportOptions.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
AlternativeContentStyle Property
HeaderStyle Property


MindFusion.Scheduling.Reporting.ReportColumn.Header Property

ReportColumn.Header Property
[image]

Gets or sets the header text of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As String

Property Value

A string specifying the text displayed in the column's header. The default is an empty string.

Remarks

An empty string indicates that the displayed text will be determined from the associated Property.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
Property Property


MindFusion.Scheduling.Reporting.ReportColumn.HeaderStyle Property

ReportColumn.HeaderStyle Property
[image]

Gets or sets the visualization settings for this column's header.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of the column header.

Remarks

This style is initially empty. Which means that all values are obtained from the HeaderStyle of the associated ReportOptions.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
AlternativeContentStyle Property
ContentStyle Property


MindFusion.Scheduling.Reporting.ReportColumn.Property Property

ReportColumn.Property Property
[image]

Gets or sets the Item property displayed in the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string Property { get; set; }

Visual Basic [image] Copy Code

Public Property Property As String

Property Value

A string specifying the name of the item property to display in the column. The default is "HeaderText".

Remarks

When the Header associated with the column is not specified, this property is used to determine the text displayed in the column's title as illustrated by the following table:

Property | Displayed text
AllDayEvent | All day event
Contacts | Contacts
Custom |
DescriptionText | Description
EndTime | End
HeaderText | Subject
Id | Id
Location | Location
Recurrence | Recurrence
Reminder | Reminder
Resources | Resources
StartTime | Start
Tag | Tag
Task | Task

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace
Header Property


MindFusion.Scheduling.Reporting.ReportColumn.Sort Property

ReportColumn.Sort Property
[image]

Gets or sets the sort of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Sort Sort { get; set; }

Visual Basic [image] Copy Code

Public Property Sort As Sort

Property Value

A member of the Sort enumeration.

Remarks

If you specify sorting by more than one column, you can use the SortPriority property to determine which sort should take precedence.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.SortPriority Property

ReportColumn.SortPriority Property
[image]

Gets or sets the sort priority of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int SortPriority { get; set; }

Visual Basic [image] Copy Code

Public Property SortPriority As Integer

Property Value

An integer value specifying the sort priority.

Remarks

Columns with higher sort priority take precedence during sorting.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.Visible Property

ReportColumn.Visible Property
[image]

Gets or sets a value indicating whether the column is displayed in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

A boolean value indicating whether the column will be visible in the report.

Remarks

Invisible columns can still be used for sorting.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportColumn.Width Property

ReportColumn.Width Property
[image]

Gets or sets the width of the column.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

A positive integer value specifying the width of the column.

Remarks

The width of the column is expressed either in device independent pixels or relatively to the width of the other columns in the report depending on the ReportOptions.AbsoluteColumnWidth property. When AbsoluteColumnWidth is set to false, the columns are stretched so that they fit exactly the width of the page.

See Also

ReportColumn Members
ReportColumn Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Class

ReportFilterItemEventArgs Class
[image]

Contains the arguments passed to handlers of the FilterItem event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportFilterItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ReportFilterItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs

See Also

ReportFilterItemEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Members

ReportFilterItemEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the FilterItem event raised by the Report class.

The following tables list the members exposed by the ReportFilterItemEventArgs type.

Public Properties

Name | Description
Filter | Gets or sets a value indicating whether the item should be filtered out of the report.
Item | Gets the item related to the event.
Resource | Gets the resource related to the item in a grouped report.

See Also

ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs Properties

ReportFilterItemEventArgs Properties
[image]

Public Properties

Name | Description
Filter | Gets or sets a value indicating whether the item should be filtered out of the report.
Item | Gets the item related to the event.
Resource | Gets the resource related to the item in a grouped report.

See Also

ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Filter Property

ReportFilterItemEventArgs.Filter Property
[image]

Gets or sets a value indicating whether the item should be filtered out of the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool Filter { get; set; }

Visual Basic [image] Copy Code

Public Property Filter As Boolean

Property Value

A boolean value indicating whether the item should be filtered out.

Remarks

Set this property to true for items which should be removed from the report.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Item Property

ReportFilterItemEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportFilterItemEventArgs.Resource Property

ReportFilterItemEventArgs.Resource Property
[image]

Gets the resource related to the item in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of a Resource class.

Remarks

In a grouped report the event FilterItem is fired once for each resource an item is associated with. This way it is possible to filter the same item for one resource and to retain it for another.

See Also

ReportFilterItemEventArgs Members
ReportFilterItemEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportGroupType Enumeration

ReportGroupType Enumeration
[image]

Specifies grouping criteria for reports.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public enum ReportGroupType

Visual Basic [image] Copy Code

Public Enum ReportGroupType

Members

Member name | Description
ByContacts | Indicates grouping by contacts.
ByLocations | Indicates grouping by locations.
ByResources | Indicates grouping by resources.
ByTasks | Indicates grouping by tasks.
None | Indicates that grouping is disabled.

See Also

MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Class

ReportOptions Class
Remarks See Also
[image]

Encapsulates the options controlling the printing and previewing of a report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportOptions

Visual Basic [image] Copy Code

Public Class ReportOptions

Remarks

An object of this class is exposed by the report through its Options property. This object can be used to customize various appearance aspects of the report such as the default colors of the report elements and various spacings and sizes.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.ReportOptions

See Also

ReportOptions Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Members

ReportOptions Members
Properties
[image]

Encapsulates the options controlling the printing and previewing of a report.

The following tables list the members exposed by the ReportOptions type.

Public Properties

Name | Description
AbsoluteColumnWidth | Gets or sets a value indicating whether the width specified for individual columns is expressed in device independent pixels or is relative to the width of the other columns in the report.
AlternativeContentStyle | Gets or sets the default style for alternative rows.
CellPadding | Gets or sets the padding of the report cells, expressed in device independent pixels.
ColumnSpacing | Gets or sets the spacing between adjacent columns, expressed in device independent pixels.
ContentStyle | Gets or sets the default style for report content.
DocumentName | Gets or sets the name of the print document.
FixedRowHeight | Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.
GroupHeaderStyle | Gets or sets the style for group headers in a grouped report.
GroupType | Gets or sets a value indicating whether grouping is enabled within the report.
HeaderHeight | Gets or sets the height of the columns' header, expressed in device independent pixels.
HeaderSpacing | Gets or sets the spacing between the header and the contents, expressed in device independent pixels.
HeaderStyle | Gets or sets the default style used for columns in the report.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins expressed in device independent pixels.
RowHeight | Gets or sets the height of individual rows, expressed in device independent pixels.
RowSpacing | Gets or sets the spacing between adjacent rows, expressed in device independent pixels.
ShowHeader | Gets or sets a value indicating whether the columns headers are displayed.
ShowHeadersOnAllPages | Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.

See Also

ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions Properties

ReportOptions Properties
[image]

Public Properties

Name | Description
AbsoluteColumnWidth | Gets or sets a value indicating whether the width specified for individual columns is expressed in device independent pixels or is relative to the width of the other columns in the report.
AlternativeContentStyle | Gets or sets the default style for alternative rows.
CellPadding | Gets or sets the padding of the report cells, expressed in device independent pixels.
ColumnSpacing | Gets or sets the spacing between adjacent columns, expressed in device independent pixels.
ContentStyle | Gets or sets the default style for report content.
DocumentName | Gets or sets the name of the print document.
FixedRowHeight | Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.
GroupHeaderStyle | Gets or sets the style for group headers in a grouped report.
GroupType | Gets or sets a value indicating whether grouping is enabled within the report.
HeaderHeight | Gets or sets the height of the columns' header, expressed in device independent pixels.
HeaderSpacing | Gets or sets the spacing between the header and the contents, expressed in device independent pixels.
HeaderStyle | Gets or sets the default style used for columns in the report.
Landscape | Gets or sets the orientation of the pages.
PageMargins | Gets or sets the page margins expressed in device independent pixels.
RowHeight | Gets or sets the height of individual rows, expressed in device independent pixels.
RowSpacing | Gets or sets the spacing between adjacent rows, expressed in device independent pixels.
ShowHeader | Gets or sets a value indicating whether the columns headers are displayed.
ShowHeadersOnAllPages | Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.

See Also

ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.AbsoluteColumnWidth Property

ReportOptions.AbsoluteColumnWidth Property
[image]

Gets or sets a value indicating whether the width specified for individual columns is expressed in device independent pixels or is relative to the width of the other columns in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool AbsoluteColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property AbsoluteColumnWidth As Boolean

Property Value

A boolean value specifying how to interpret the Width property of report columns. The default is false.

Remarks

The width of the column is expressed either in device independent pixels or relatively to the width of the other columns in the report depending on the value of this property. When AbsoluteColumnWidth is set to false, the columns are stretched so that they fit exactly the width of the page.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.AlternativeContentStyle Property

ReportOptions.AlternativeContentStyle Property
[image]

Gets or sets the default style for alternative rows.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle AlternativeContentStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AlternativeContentStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of even rows in the report.

Remarks

This style is based on the ContentStyle, which means that all properties which are not explicitly specified are obtained from there. The only property initially specified for alternative rows is Background, which is set to LightGoldenrodYellow.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
ContentStyle Property
GroupHeaderStyle Property
HeaderStyle Property


MindFusion.Scheduling.Reporting.ReportOptions.CellPadding Property

ReportOptions.CellPadding Property
[image]

Gets or sets the padding of the report cells, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int CellPadding { get; set; }

Visual Basic [image] Copy Code

Public Property CellPadding As Integer

Property Value

An integer value specifying the distance between the border of a report cell and its content. The default is 2.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ColumnSpacing Property

ReportOptions.ColumnSpacing Property
[image]

Gets or sets the spacing between adjacent columns, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int ColumnSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnSpacing As Integer

Property Value

An integer value specifying the distance between report columns. The default is 0.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ContentStyle Property

ReportOptions.ContentStyle Property
[image]

Gets or sets the default style for report content.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle ContentStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ContentStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of even rows in the report.

Remarks

The initial settings in this property are outlined in the following table:

Property | Value
Background | White
BottomBorderBrush | null
BottomBorderThickness | 0
FontFamily | "Verdana"
FontSize | 8
FontStyle | FontStyles.Normal
FontWeight | FontWeights.Normal
Foreground | Black
HorizontalContentAlignment | AlignmentX.Left
LeftBorderBrush | null
LeftBorderThickness | 0
RightBorderBrush | null
RightBorderThickness | 0
TopBorderBrush | null
TopBorderThickness | 0
VerticalContentAlignment | AlignmentY.Center

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
AlternativeContentStyle Property
GroupHeaderStyle Property
HeaderStyle Property


MindFusion.Scheduling.Reporting.ReportOptions.DocumentName Property

ReportOptions.DocumentName Property
[image]

Gets or sets the name of the print document.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string DocumentName { get; set; }

Visual Basic [image] Copy Code

Public Property DocumentName As String

Property Value

A string specifying the name of the print document. The default is " - Untitled - ".

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.FixedRowHeight Property

ReportOptions.FixedRowHeight Property
[image]

Gets or sets a value indicating whether to use a fixed row height as specified by the RowHeight property or to calculate the height of individual rows according to the contained text.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool FixedRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property FixedRowHeight As Boolean

Property Value

A boolean value specifying whether the columns in the report should have fixed height. The default is true.

See Also

fiReportOptions Membersa
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
RowHeight Property


MindFusion.Scheduling.Reporting.ReportOptions.GroupHeaderStyle Property

ReportOptions.GroupHeaderStyle Property
[image]

Gets or sets the style for group headers in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle GroupHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of group headers.

Remarks

This style is based on the HeaderStyle, which means that all properties which are not explicitly specified are obtained from there. No properties are initially specified which makes this style identical to HeaderStyle.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
AlternativeContentStyle Property
ContentStyle Property
HeaderStyle Property


MindFusion.Scheduling.Reporting.ReportOptions.GroupType Property

ReportOptions.GroupType Property
[image]

Gets or sets a value indicating whether grouping is enabled within the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportGroupType GroupType { get; set; }

Visual Basic [image] Copy Code

Public Property GroupType As ReportGroupType

Property Value

A member of the ReportGroupType enumeration.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.HeaderHeight Property

ReportOptions.HeaderHeight Property
[image]

Gets or sets the height of the columns' header, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Integer

Property Value

An integer value specifying the height of report headers. The default is 25.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.HeaderSpacing Property

ReportOptions.HeaderSpacing Property
[image]

Gets or sets the spacing between the header and the contents, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int HeaderSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying the distance between headers and contents.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.HeaderStyle Property

ReportOptions.HeaderStyle Property
[image]

Gets or sets the default style used for columns in the report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As ReportStyle

Property Value

An instance of the ReportStyle class specifying the style of report headers.

Remarks

The initial settings in this property are outlined in the following table:

Property | Value
Background | WhiteSmoke
BottomBorderBrush | null
BottomBorderThickness | 0
FontFamily | "Verdana"
FontSize | 8
FontStyle | FontStyles.Normal
FontWeight | FontWeights.Bold
Foreground | Black
HorizontalContentAlignment | AlignmentX.Center
LeftBorderBrush | null
LeftBorderThickness | 0
RightBorderBrush | null
RightBorderThickness | 0
TopBorderBrush | null
TopBorderThickness | 0
VerticalContentAlignment | AlignmentY.Center

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
AlternativeContentStyle Property
ContentStyle Property
GroupHeaderStyle Property


MindFusion.Scheduling.Reporting.ReportOptions.Landscape Property

ReportOptions.Landscape Property
[image]

Gets or sets the orientation of the pages.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool Landscape { get; set; }

Visual Basic [image] Copy Code

Public Property Landscape As Boolean

Property Value

A boolean value indicating whether orientation of the report is landscape or portrait. The default is false.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.PageMargins Property

ReportOptions.PageMargins Property
[image]

Gets or sets the page margins expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Thickness PageMargins { get; set; }

Visual Basic [image] Copy Code

Public Property PageMargins As Thickness

Property Value

A Thickness object specifying the page margins.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.RowHeight Property

ReportOptions.RowHeight Property
[image]

Gets or sets the height of individual rows, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int RowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeight As Integer

Property Value

An integer value specifying the height of individual rows. The default is 20.

Remarks

This value specify absolute row height if FixedRowHeight is set to true. Otherwise it specifies the minimal row height. If the later case if the row is too small to fit its content, it is automatically resized.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
FixedRowHeight Property


MindFusion.Scheduling.Reporting.ReportOptions.RowSpacing Property

ReportOptions.RowSpacing Property
[image]

Gets or sets the spacing between adjacent rows, expressed in device independent pixels.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public int RowSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property RowSpacing As Integer

Property Value

An integer value specifying the distance between report rows. The default is 0.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportOptions.ShowHeader Property

ReportOptions.ShowHeader Property
[image]

Gets or sets a value indicating whether the columns headers are displayed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool ShowHeader { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHeader As Boolean

Property Value

A boolean value indicating whether to display report headers.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
ShowHeadersOnAllPages Property


MindFusion.Scheduling.Reporting.ReportOptions.ShowHeadersOnAllPages Property

ReportOptions.ShowHeadersOnAllPages Property
[image]

Gets or sets a value indicating whether the column headers are displayed on top of each page or only on the first one.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public bool ShowHeadersOnAllPages { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHeadersOnAllPages As Boolean

Property Value

A boolean value indicating whether report headers are displayed on all pages.

See Also

ReportOptions Members
ReportOptions Class
MindFusion.Scheduling.Reporting Namespace
ShowHeader Property


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Class

ReportQueryHeaderTextEventArgs Class
[image]

Contains the arguments passed to handlers of the QueryHeaderText event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportQueryHeaderTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ReportQueryHeaderTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs

See Also

ReportQueryHeaderTextEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Members

ReportQueryHeaderTextEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the QueryHeaderText event raised by the Report class.

The following tables list the members exposed by the ReportQueryHeaderTextEventArgs type.

Public Properties

Name | Description
Column | Gets the column whose header text is being processed.
Representation | Gets or sets the text of the header.
Resource | Gets the resource whose header text is being processed when the event is fired for a group header.

See Also

ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs Properties

ReportQueryHeaderTextEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the column whose header text is being processed.
Representation | Gets or sets the text of the header.
Resource | Gets the resource whose header text is being processed when the event is fired for a group header.

See Also

ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Column Property

ReportQueryHeaderTextEventArgs.Column Property
[image]

Gets the column whose header text is being processed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportColumn Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As ReportColumn

Property Value

An instance of the ReportColumn class.

Remarks

This property is null (Nothing in Visual Basic) when the event is raised for a resource group header.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Representation Property

ReportQueryHeaderTextEventArgs.Representation Property
[image]

Gets or sets the text of the header.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As String

Property Value

A string value representing the text to display in the header.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryHeaderTextEventArgs.Resource Property

ReportQueryHeaderTextEventArgs.Resource Property
[image]

Gets the resource whose header text is being processed when the event is fired for a group header.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of a Resource class.

Remarks

This property is null (Nothing in Visual Basic) when the event is raised for a report header.

See Also

ReportQueryHeaderTextEventArgs Members
ReportQueryHeaderTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Class

ReportQueryStyleEventArgs Class
[image]

Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportQueryStyleEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ReportQueryStyleEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs

See Also

ReportQueryStyleEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Members

ReportQueryStyleEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the QueryStyle event raised by the Report class.

The following tables list the members exposed by the ReportQueryStyleEventArgs type.

Public Properties

Name | Description
Column | Gets the column containing cell whose style is being queried.
Item | Gets the item related to the event.
Style | Gets or sets the style to use for the processed cell or null (Nothing in Visual Basic) to use the default style.
Value | Gets the object displayed in the cell whose style is being queried.

See Also

ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs Properties

ReportQueryStyleEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the column containing cell whose style is being queried.
Item | Gets the item related to the event.
Style | Gets or sets the style to use for the processed cell or null (Nothing in Visual Basic) to use the default style.
Value | Gets the object displayed in the cell whose style is being queried.

See Also

ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Column Property

ReportQueryStyleEventArgs.Column Property
[image]

Gets the column containing cell whose style is being queried.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportColumn Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As ReportColumn

Property Value

An instance of the ReportColumn class.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Item Property

ReportQueryStyleEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of an Item class.

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Style Property

ReportQueryStyleEventArgs.Style Property
[image]

Gets or sets the style to use for the processed cell or null (Nothing in Visual Basic) to use the default style.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As ReportStyle

Property Value

An instance of the ReportStyle class.

Remarks

In order to specify custom visualization settings for the cell, you need to instantiate a ReportStyle object, set only those properties you are interested in changing and assign the object to this property.

Example

The following example demonstrates how to specify red background for all items which end in the past:

C# [image] Copy Code
void OnQueryStyle(object sender, ReportQueryStyleEventArgs e)
{
if (e.Item.EndTime < DateTime.Now)
{
ReportStyle customStyle = new ReportStyle();
customStyle.Background = Brushes.Red;
e.Style = customStyle;
}
}
Visual Basic [image] Copy Code

Sub OnQueryStyle(ByVal sender As Object, ByVal e As ReportQueryStyleEventArgs)

If e.Item.EndTime < DateTime.Now Then

Dim customStyle As New ReportStyle()
customStyle.Background = Brushes.Red
e.Style = customStyle

End If

End Sub

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryStyleEventArgs.Value Property

ReportQueryStyleEventArgs.Value Property
[image]

Gets the object displayed in the cell whose style is being queried.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Object Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Object

Property Value

An instance of the Object class, possibly null (Nothing in Visual Basic).

See Also

ReportQueryStyleEventArgs Members
ReportQueryStyleEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Class

ReportQueryTextEventArgs Class
[image]

Contains the arguments passed to handlers of the QueryText event raised by the Report class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportQueryTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ReportQueryTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs

See Also

ReportQueryTextEventArgs Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Members

ReportQueryTextEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the QueryText event raised by the Report class.

The following tables list the members exposed by the ReportQueryTextEventArgs type.

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Representation | Gets or sets the text representation of the object.
Resource | Gets the resource related to the item in a grouped report.
Value | Gets the object that would be displayed.

See Also

ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs Properties

ReportQueryTextEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the column where the text would appear.
Item | Gets the item related to the event.
Representation | Gets or sets the text representation of the object.
Resource | Gets the resource related to the item in a grouped report.
Value | Gets the object that would be displayed.

See Also

ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Column Property

ReportQueryTextEventArgs.Column Property
[image]

Gets the column where the text would appear.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportColumn Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As ReportColumn

Property Value

An instance of the ReportColumn class.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Item Property

ReportQueryTextEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of an Item class.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Representation Property

ReportQueryTextEventArgs.Representation Property
[image]

Gets or sets the text representation of the object.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As String

Property Value

A string value representing the text to display in the cell.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Resource Property

ReportQueryTextEventArgs.Resource Property
[image]

Gets the resource related to the item in a grouped report.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of a Resource class.

Remarks

In a grouped report the event QueryText is fired once for each resource an item is associated with. This way it is possible to display one text for the same item for one resource and another text for another resource.

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportQueryTextEventArgs.Value Property

ReportQueryTextEventArgs.Value Property
[image]

Gets the object that would be displayed.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Object Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Object

Property Value

An instance of the Object class, possibly null (Nothing in Visual Basic).

See Also

ReportQueryTextEventArgs Members
ReportQueryTextEventArgs Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle Class

ReportStyle Class
[image]

Provides visualization settings for various report elements.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public class ReportStyle

Visual Basic [image] Copy Code

Public Class ReportStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reporting.ReportStyle

See Also

ReportStyle Members
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle Members

ReportStyle Members
Constructors Properties
[image]

Provides visualization settings for various report elements.

The following tables list the members exposed by the ReportStyle type.

Public Constructors

Name | Description
ReportStyle | Initializes a new instance of the ReportStyle class.

Public Properties

Name | Description
Background | Gets or sets a brush that describes the background of the associated report element.
BottomBorderBrush | Gets or sets a brush that describes the bottom border of the associated report element.
BottomBorderThickness | Gets or sets the bottom border thickness of the associated report element.
FontFamily | Gets or sets the font family for the text content of the associated report element.
FontSize | Gets or sets the font size for the text content of the associated report element.
FontStyle | Gets or sets the font style for the text content of the specified report element.
FontWeight | Gets or sets the weight or thickness for the text content of the associated report element.
Foreground | Gets or sets a brush that describes the foreground of the associated report element.
HorizontalContentAlignment | Gets or sets the horizontal alignment of the content of the specified report element.
LeftBorderBrush | Gets or sets a brush that describes the left border of the associated report element.
LeftBorderThickness | Gets or sets the left border thickness of the associated report element.
RightBorderBrush | Gets or sets a brush that describes the right border of the associated report element.
RightBorderThickness | Gets or sets the right border thickness of the associated report element.
TopBorderBrush | Gets or sets a brush that describes the top border of the associated report element.
TopBorderThickness | Gets or sets the top border thickness of the associated report element.
VerticalContentAlignment | Gets or sets the vertical alignment of the content of the specified report element.

See Also

ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle Constructor

ReportStyle Constructor
[image]

Initializes a new instance of the ReportStyle class.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public ReportStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle Properties

ReportStyle Properties
[image]

Public Properties

Name | Description
Background | Gets or sets a brush that describes the background of the associated report element.
BottomBorderBrush | Gets or sets a brush that describes the bottom border of the associated report element.
BottomBorderThickness | Gets or sets the bottom border thickness of the associated report element.
FontFamily | Gets or sets the font family for the text content of the associated report element.
FontSize | Gets or sets the font size for the text content of the associated report element.
FontStyle | Gets or sets the font style for the text content of the specified report element.
FontWeight | Gets or sets the weight or thickness for the text content of the associated report element.
Foreground | Gets or sets a brush that describes the foreground of the associated report element.
HorizontalContentAlignment | Gets or sets the horizontal alignment of the content of the specified report element.
LeftBorderBrush | Gets or sets a brush that describes the left border of the associated report element.
LeftBorderThickness | Gets or sets the left border thickness of the associated report element.
RightBorderBrush | Gets or sets a brush that describes the right border of the associated report element.
RightBorderThickness | Gets or sets the right border thickness of the associated report element.
TopBorderBrush | Gets or sets a brush that describes the top border of the associated report element.
TopBorderThickness | Gets or sets the top border thickness of the associated report element.
VerticalContentAlignment | Gets or sets the vertical alignment of the content of the specified report element.

See Also

ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.Background Property

ReportStyle.Background Property
[image]

Gets or sets a brush that describes the background of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of a Brush-derived class. The default is solid White.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.BottomBorderBrush Property

ReportStyle.BottomBorderBrush Property
[image]

Gets or sets a brush that describes the bottom border of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush BottomBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BottomBorderBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null (Nothing in Visual Basic).

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.BottomBorderThickness Property

ReportStyle.BottomBorderThickness Property
[image]

Gets or sets the bottom border thickness of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public double BottomBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property BottomBorderThickness As Double

Property Value

A double value specifying the thickness of the bottom border, expressed in device independent pixels. The default is 0.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.FontFamily Property

ReportStyle.FontFamily Property
[image]

Gets or sets the font family for the text content of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public string FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As String

Property Value

A string specifying the font family name. The default is "Arial".

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.FontSize Property

ReportStyle.FontSize Property
[image]

Gets or sets the font size for the text content of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double specifying the font size. The default is 8.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.FontStyle Property

ReportStyle.FontStyle Property
[image]

Gets or sets the font style for the text content of the specified report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

An instance of the FontStyle structure. The default value is FontStyles.Normal.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.FontWeight Property

ReportStyle.FontWeight Property
[image]

Gets or sets the weight or thickness for the text content of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

An instance of the FontWeight structure. The default value is FontWeights.Normal.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.Foreground Property

ReportStyle.Foreground Property
[image]

Gets or sets a brush that describes the foreground of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }

Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

An instance of a Brush-derived class. The default is solid Black.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.HorizontalContentAlignment Property

ReportStyle.HorizontalContentAlignment Property
[image]

Gets or sets the horizontal alignment of the content of the specified report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public AlignmentX HorizontalContentAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalContentAlignment As AlignmentX

Property Value

A member of the AlignmentX enumeration. The default value is Center.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.LeftBorderBrush Property

ReportStyle.LeftBorderBrush Property
[image]

Gets or sets a brush that describes the left border of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush LeftBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LeftBorderBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null (Nothing in Visual Basic).

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.LeftBorderThickness Property

ReportStyle.LeftBorderThickness Property
[image]

Gets or sets the left border thickness of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public double LeftBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LeftBorderThickness As Double

Property Value

A double value specifying the thickness of the left border, expressed in device independent pixels.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.RightBorderBrush Property

ReportStyle.RightBorderBrush Property
[image]

Gets or sets a brush that describes the right border of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush RightBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RightBorderBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null (Nothing in Visual Basic).

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.RightBorderThickness Property

ReportStyle.RightBorderThickness Property
[image]

Gets or sets the right border thickness of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public double RightBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RightBorderThickness As Double

Property Value

A double value specifying the thickness of the right border, expressed in device independent pixels.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.TopBorderBrush Property

ReportStyle.TopBorderBrush Property
[image]

Gets or sets a brush that describes the top border of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public Brush TopBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TopBorderBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null (Nothing in Visual Basic).

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.TopBorderThickness Property

ReportStyle.TopBorderThickness Property
[image]

Gets or sets the top border thickness of the associated report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public double TopBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property TopBorderThickness As Double

Property Value

A double value specifying the thickness of the top border, expressed in device independent pixels.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.ReportStyle.VerticalContentAlignment Property

ReportStyle.VerticalContentAlignment Property
[image]

Gets or sets the vertical alignment of the content of the specified report element.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public AlignmentY VerticalContentAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalContentAlignment As AlignmentY

Property Value

A member of the AlignmentY enumeration. The default value is Center.

See Also

ReportStyle Members
ReportStyle Class
MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Reporting.Sort Enumeration

Sort Enumeration
[image]

Specifies a sorting.

Namespace: MindFusion.Scheduling.Reporting
Assembly: MindFusion.Scheduling.Wpf.Reporting

Syntax

C# [image] Copy Code

public enum Sort

Visual Basic [image] Copy Code

Public Enum Sort

Members

Member name | Description
Ascending | Specifies ascending sort order.
Descending | Specifies descending sort order.
None | Specifies that sorting is disabled.

Remarks

Values of this enumeration are assigned to the Sort property of report columns.

See Also

MindFusion.Scheduling.Reporting Namespace


MindFusion.Scheduling.Wpf Namespace

MindFusion.Scheduling.Wpf Namespace
Classes Enumerations

Classes

Class | Description
AppointmentForm | Ready-made form for appointment editing.
Calendar | The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.
CalendarSettings | The base class for the different theme-aware settings classes.
CalendarStyle | Specifies the appearance of calendar elements.
CellPresenter | Defines the presentation of cells in calendar views.
CellSettings | Defines appearance settings for the cells representing time ranges in the calendar.
DateChangedEventArgs | Contains the arguments passed to handlers of the VisibleDateChanged event.
DateCollection | Represents a strongly-typed sorted collection of DateTime objects.
DateEventArgs | Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.
ExpanderControl | Represents a simple expander control.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.
ItemEditConfirmEventArgs | Contains the arguments passed to handlers of the ItemInplaceEditEnding event.
ItemModifiedEventArgs | Contains the arguments passed to handlers of the ItemModified event.
ItemModifyConfirmEventArgs | Contains the arguments passed to handlers of the ItemModifying event.
ItemMouseEventArgs | Contains the arguments passed to handlers of the ItemClick event.
ItemPresenter | Defines the base class of custom item presenter classes.
ItemPresenterAttribute | Associates a custom item presenter with a schedule item class.
ItemSelection | An instance of this class represents a set of selected schedule items.
ItemSelectionEventArgs | Contains the arguments passed to handlers of selection related events.
ItemSettings | Defines properties that allow customizing the visualization of schedule items in the calendar views.
ListViewSettings | Defines properties that allow customizing the visualization of the calendar in a List view.
MonthRangeSettings | Defines settings for the years in the calendar.
MonthSettings | Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.
RecurrenceForm | Ready-made form for recurrence editing.
RecurringItemConfirmEventArgs | Contains the arguments passed to handlers of the RecurringItemDeleting event.
ResizeBands | Represents the resize and move bands of items in a Timetable and Resource views.
ResourceDateEventArgs | Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.
ResourceHeader | Represents the header of a row in a Resource view.
ResourceNameConverter | Converts ResourceHeader objects to readable strings representing their underlying resource.
ResourceViewSettings | Defines properties that allow customizing the visualization of the calendar in Resource view.
Selection | Represents a set of selected date cells and defines a visualization style applied to the selected elements.
SideBorders | Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.
TimelineHeader | Represents the left part of the timeline header in a Resource view.
TimelineSettings | Encapsulates settings for a timeline in a Resource view.
TimetableSettings | Defines properties that allow customizing the visualization of the calendar in Timetable view.
VisibleConverter | Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.
WeekRangeSettings | Defines properties that allow customizing the visualization of weeks in WeekRange view.

Enumerations

Enumeration | Description
CalendarView | Specifies the type of view to display in a calendar control.
DayOfWeekFormat | Specifies the display format of a day of the week.
GroupType | Specifies grouping or filtering criteria for views that support grouping.
ItemAction | Specifies a user action on a schedule item.
ListViewHeaderStyles | Specifies the appearance and behavior of the header in a List view.
MinuteFormat | Specifies how to format and display minutes in the Timetable view.
MonthCellLayout | Specifies the layout of the cells in a SingleMonth and MonthRange views.
MonthHeaderStyles | Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.
MonthRangeHeaderStyles | Specifies the appearance and behavior of the header in a MonthRange view.
MonthWeekHeaderStyle | Specifies the placement of the week numbers header in a SingleMonth view.
Position | Specifies the position of an element relative to its container.
ResourceViewStyle | Specifies the style of a Resource view.
ThemeType | Specifies a calendar theme.
TimeUnit | Specifies a time resolution.
WeekRangeHeaderStyle | Specifies the appearance of the time period header in WeekRange view.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.


MindFusion.Scheduling.Wpf.AppointmentForm Class

AppointmentForm Class
[image]

Ready-made form for appointment editing.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class AppointmentForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class AppointmentForm
Inherits Window
Implements IComponentConnector

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Scheduling.Wpf.AppointmentForm

See Also

AppointmentForm Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Members

AppointmentForm Members
Constructors Properties Methods
[image]

Ready-made form for appointment editing.

The following tables list the members exposed by the AppointmentForm type.

Public Constructors

Name | Description
AppointmentForm | Overloaded. Initializes a new instance of the AppointmentForm class.

Public Properties

Name | Description
Appointment | Gets the appointment being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

Public Methods

Name | Description
SetAppointment | Sets the appointment that is to be edited in the form.

See Also

AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Constructor

AppointmentForm Constructor
[image]

Initializes a new instance of the AppointmentForm class.

Overload List

Name | Description
AppointmentForm () | Initializes a new instance of the AppointmentForm class for design-time use.
AppointmentForm (Schedule) | Initializes a new instance of the AppointmentForm class.

See Also

AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Constructor ()

AppointmentForm Constructor ()
See Also
[image]

Initializes a new instance of the AppointmentForm class for design-time use.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public AppointmentForm ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AppointmentForm Constructor Overload List
AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Constructor (Schedule)

AppointmentForm Constructor (Schedule)
See Also
[image]

Initializes a new instance of the AppointmentForm class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public AppointmentForm (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
A schedule object used to initialize certain fields on the form, such as the list with available locations. This value cannot be null (Nothing in Visual Basic).

See Also

AppointmentForm Constructor Overload List
AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Methods

AppointmentForm Methods
[image]

Public Methods

Name | Description
SetAppointment | Sets the appointment that is to be edited in the form.

See Also

AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm.SetAppointment Method

AppointmentForm.SetAppointment Method
[image]

Sets the appointment that is to be edited in the form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void SetAppointment (
Appointment appointment
)

Visual Basic [image] Copy Code

Public Sub SetAppointment ( _
appointment As Appointment _
)

Parameters

appointment
A reference to the Appointment object to be selected in the form for editing.

Remarks

If the appointment represents a recurrence instance or exception, only the instance is being edited. If it represents a recurrence master, all instances are edited.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm Properties

AppointmentForm Properties
[image]

Public Properties

Name | Description
Appointment | Gets the appointment being edited in this form.
TimeFormat | Gets or sets the format of times displayed within the form.

See Also

AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm.Appointment Property

AppointmentForm.Appointment Property
[image]

Gets the appointment being edited in this form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Appointment Appointment { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Appointment As Appointment

Property Value

A reference to a schedule Appointment, which is being edited in the form. This is usually the appointment selected for editing with a call to the SetAppointment method.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.AppointmentForm.TimeFormat Property

AppointmentForm.TimeFormat Property
[image]

Gets or sets the format of times displayed within the form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string TimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TimeFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

AppointmentForm Members
AppointmentForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Class

Calendar Class
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class Calendar : UserControl, IComponentConnector

Visual Basic [image] Copy Code

Public Class Calendar
Inherits UserControl
Implements IComponentConnector

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
MindFusion.Scheduling.Wpf.Calendar

See Also

Calendar Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Members

Calendar Members
Constructors Fields Properties Methods Events
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Overloaded. Initializes a new instance of the Calendar class.

Public Fields

Name | Description
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInplaceCreateProperty | Identifies the AllowInplaceCreate dependency property.
AllowInplaceEditProperty | Identifies the AllowInplaceEdit dependency property.
ButtonOffsetProperty | Identifies the ButtonOffset dependency property.
ContactNameFormatProperty | Identifies the ContactNameFormat dependency property.
CurrentViewProperty | Identifies the CurrentView dependency property.
DateProperty | Identifies the Date dependency property.
DelayInplaceEditProperty | Identifies the DelayInplaceEdit dependency property.
DelayScrollProperty | Identifies the DelayScroll dependency property.
DelayScrollToolTipFormatProperty | Identifies the DelayScrollToolTipFormat dependency property.
DisableRemindersProperty | Identifies the DisableReminders dependency property.
EnableDragCreateProperty | Identifies the EnableDragCreate dependency property.
EndDateProperty | Identifies the EndDate dependency property.
FirstWeekendDayProperty | Identifies the FirstWeekendDay dependency property.
GroupTypeProperty | Identifies the GroupType dependency property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property.
HScrollPosProperty | Identifies the HScrollPos dependency property.
ItemChangeReferenceKeyProperty | Identifies the ItemChangeReferenceKey dependency property.
ItemContactsProperty | Identifies the ItemContacts dependency property.
ItemLocationsProperty | Identifies the ItemLocations dependency property.
ItemResourcesProperty | Identifies the ItemResources dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemTasksProperty | Identifies the ItemTasks dependency property.
KeepItemOrderProperty | Identifies the KeepItemOrder dependency property.
ListViewSettingsProperty | Identifies the ListViewSettings dependency property.
MonthRangeSettingsProperty | Identifies the MonthRangeSettings dependency property.
MonthSettingsProperty | Identifies the MonthSettings dependency property.
RemindersCheckIntervalProperty | Identifies the RemindersCheckInterval dependency property.
RescheduleRecurrenceKeyProperty | Identifies the RescheduleRecurrenceKey dependency property.
ScheduleProperty | Identifies the Schedule dependency property.
SelectionProperty | Identifies the Selection dependency property.
SelectionToolTipFormatProperty | Identifies the SelectionToolTipFormat dependency property.
ShowSelectionToolTipsProperty | Identifies the ShowSelectionToolTips dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimetableSettingsProperty | Identifies the TimetableSettings dependency property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property.
VScrollPosProperty | Identifies the VScrollPos dependency property.
WeekRangeSettingsProperty | Identifies the WeekRangeSettings dependency property.

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle. This is a dependency property.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively. This is a dependency property
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively. This is a dependency property.
ButtonOffset | Gets or set the margin of the navigation buttons. This is a dependency property.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header. This is a dependency property.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view. This is a dependency property.
Date | Gets or sets the date currently displayed in the calendar. This is a dependency property.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked. This is a dependency property.
DelayScroll | Gets or sets a value indicating whether interacting with the scrollbars will not have an effect until the interaction is over. During interaction a tooltip is displayed to indicate the expected scroll position. This is a dependency property.
DelayScrollToolTipFormat | Gets or sets the format of a tooltip displayed when scrolling and DelayScroll set to true. This is a dependency property.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule. This is a dependency property.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control. This is a dependency property.
EndDate | Gets or sets the last date displayed in the calendar. This is a dependency property.
FirstWeekendDay | Gets or sets the first weekend day in the calendar. This is a dependency property.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.
HScrollPos | Gets or sets the current horizontal scroll position. This is a dependency property.
InteractiveItemType | Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.
ItemCloneKey | Gets or sets the modifier key, which when pressed while dragging an item, will cause this item to be cloned and the clone to be dragged instead.
ItemContacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ItemLocations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
ItemResources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
KeepItemOrder | Gets or sets a value indicating whether to attempt to prioritize the newly created items during collision processing. This is a dependency property.
LicenseKey | Gets or sets the license key of the control.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds. This is a dependency property.
RescheduleRecurrenceKey | Gets or sets the modifier key, which when pressed allows users to interactively reschedule recurrent items.
ResourceViewSettings | Gets or sets the ResourceViewSettings object used to customize the Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control. This is a dependency property.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionToolTipFormat | Gets or sets the format of a selection tooltip. This is a dependency property.
ShowSelectionToolTips | Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.
Theme | Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.
VScrollPos | Gets or sets the current vertical scroll position. This is a dependency property.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Public Methods

Name | Description
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
CreateImage | Creates a WYSIWYG image from the calendar.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetItemAt | Overloaded. Gets the item displayed at a specified coordinates.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetItemStyle | Retrieves the CalendarStyle previously associated with the normal state of the specified item.
GetItemTooltip | Retrieves the string tooltip previously associated with the item.
GetPointedItemStyle | Retrieves the CalendarStyle previously associated with the pointed state of the specified item.
GetPointedSelectedItemStyle | Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at a specified coordinates.
GetSelectedItemStyle | Retrieves the CalendarStyle previously associated with the selected state of the specified item.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom | Overloaded. Loads schedule data from a file or a stream.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
SaveTo | Overloaded. Saves the underlying schedule to a file or a stream.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
SetItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.
SetItemTooltip | Associates a new string tooltip with the specified item.
SetPointedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.
SetPointedSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.
SetSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnCellPresenterCreated | Raises the CellPresenterCreated event.
OnCellPresenterCreating | Raises the CellPresenterCreating event.
OnDateClick | Raises the DateClick event.
OnFilterItem | Raises the FilterItem event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll | Raises the HScroll event.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemPresenterCreated | Raises the ItemPresenterCreated event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnItemStartModifying | Raises the ItemStartModifying event.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnRebuilding | Raises the Rebuilding event.
OnRebuilt | Raises the Rebuilt event.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTextInput | Control.OnTextInput override.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Raises the VScroll event.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

Public Events

Name | Description
CellPresenterCreated | Raised when the CellPresenter control that will visualize specific view cell is created.
CellPresenterCreating | Raised when the CellPresenter control that will visualize specific view cell is being instantiated.
DateClick | Raised when the user clicks a date cell in the calendar.
FilterItem | Raised to allow filtering specific items from the view.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user. This event is also raised upon completion of interaction which was previously canceled programmatically through the ItemModifying event.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemPresenterCreated | Raised when the ItemPresenter Control that will visualise specific item is created.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ItemStartModifying | Raised when the user is about to move or resize an item.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
Rebuilding | An event raised when the view is being rebuild and before the cell presenters are created.
Rebuilt | An event raised after the view is rebuild and after the cell presenters are created.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Fields

Calendar Fields
[image]

Public Fields

Name | Description
AllowAutoScrollProperty | Identifies the AllowAutoScroll dependency property.
AllowInplaceCreateProperty | Identifies the AllowInplaceCreate dependency property.
AllowInplaceEditProperty | Identifies the AllowInplaceEdit dependency property.
ButtonOffsetProperty | Identifies the ButtonOffset dependency property.
ContactNameFormatProperty | Identifies the ContactNameFormat dependency property.
CurrentViewProperty | Identifies the CurrentView dependency property.
DateProperty | Identifies the Date dependency property.
DelayInplaceEditProperty | Identifies the DelayInplaceEdit dependency property.
DelayScrollProperty | Identifies the DelayScroll dependency property.
DelayScrollToolTipFormatProperty | Identifies the DelayScrollToolTipFormat dependency property.
DisableRemindersProperty | Identifies the DisableReminders dependency property.
EnableDragCreateProperty | Identifies the EnableDragCreate dependency property.
EndDateProperty | Identifies the EndDate dependency property.
FirstWeekendDayProperty | Identifies the FirstWeekendDay dependency property.
GroupTypeProperty | Identifies the GroupType dependency property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property.
HScrollPosProperty | Identifies the HScrollPos dependency property.
ItemChangeReferenceKeyProperty | Identifies the ItemChangeReferenceKey dependency property.
ItemContactsProperty | Identifies the ItemContacts dependency property.
ItemLocationsProperty | Identifies the ItemLocations dependency property.
ItemResourcesProperty | Identifies the ItemResources dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemTasksProperty | Identifies the ItemTasks dependency property.
KeepItemOrderProperty | Identifies the KeepItemOrder dependency property.
ListViewSettingsProperty | Identifies the ListViewSettings dependency property.
MonthRangeSettingsProperty | Identifies the MonthRangeSettings dependency property.
MonthSettingsProperty | Identifies the MonthSettings dependency property.
RemindersCheckIntervalProperty | Identifies the RemindersCheckInterval dependency property.
RescheduleRecurrenceKeyProperty | Identifies the RescheduleRecurrenceKey dependency property.
ScheduleProperty | Identifies the Schedule dependency property.
SelectionProperty | Identifies the Selection dependency property.
SelectionToolTipFormatProperty | Identifies the SelectionToolTipFormat dependency property.
ShowSelectionToolTipsProperty | Identifies the ShowSelectionToolTips dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimetableSettingsProperty | Identifies the TimetableSettings dependency property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property.
VScrollPosProperty | Identifies the VScrollPos dependency property.
WeekRangeSettingsProperty | Identifies the WeekRangeSettings dependency property.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.AllowAutoScrollProperty Field

Calendar.AllowAutoScrollProperty Field
[image]

Identifies the AllowAutoScroll dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowAutoScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowAutoScrollProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.AllowInplaceCreateProperty Field

Calendar.AllowInplaceCreateProperty Field
[image]

Identifies the AllowInplaceCreate dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowInplaceCreateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowInplaceCreateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.AllowInplaceEditProperty Field

Calendar.AllowInplaceEditProperty Field
[image]

Identifies the AllowInplaceEdit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowInplaceEditProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowInplaceEditProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ButtonOffsetProperty Field

Calendar.ButtonOffsetProperty Field
[image]

Identifies the ButtonOffset dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOffsetProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ContactNameFormatProperty Field

Calendar.ContactNameFormatProperty Field
[image]

Identifies the ContactNameFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContactNameFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContactNameFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.CurrentViewProperty Field

Calendar.CurrentViewProperty Field
[image]

Identifies the CurrentView dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentViewProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentViewProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DateProperty Field

Calendar.DateProperty Field
[image]

Identifies the Date dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DelayInplaceEditProperty Field

Calendar.DelayInplaceEditProperty Field
[image]

Identifies the DelayInplaceEdit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DelayInplaceEditProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DelayInplaceEditProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DelayScrollProperty Field

Calendar.DelayScrollProperty Field
[image]

Identifies the DelayScroll dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DelayScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DelayScrollProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DelayScrollToolTipFormatProperty Field

Calendar.DelayScrollToolTipFormatProperty Field
[image]

Identifies the DelayScrollToolTipFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DelayScrollToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DelayScrollToolTipFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DisableRemindersProperty Field

Calendar.DisableRemindersProperty Field
[image]

Identifies the DisableReminders dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DisableRemindersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DisableRemindersProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnableDragCreateProperty Field

Calendar.EnableDragCreateProperty Field
[image]

Identifies the EnableDragCreate dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDragCreateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDragCreateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EndDateProperty Field

Calendar.EndDateProperty Field
[image]

Identifies the EndDate dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndDateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndDateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.FirstWeekendDayProperty Field

Calendar.FirstWeekendDayProperty Field
[image]

Identifies the FirstWeekendDay dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FirstWeekendDayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FirstWeekendDayProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GroupTypeProperty Field

Calendar.GroupTypeProperty Field
[image]

Identifies the GroupType dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupTypeProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HorizontalScrollBarVisibilityProperty Field

Calendar.HorizontalScrollBarVisibilityProperty Field
[image]

Identifies the HorizontalScrollBarVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalScrollBarVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalScrollBarVisibilityProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HScrollPosProperty Field

Calendar.HScrollPosProperty Field
[image]

Identifies the HScrollPos dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HScrollPosProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HScrollPosProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemChangeReferenceKeyProperty Field

Calendar.ItemChangeReferenceKeyProperty Field
[image]

Identifies the ItemChangeReferenceKey dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemChangeReferenceKeyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemChangeReferenceKeyProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemContactsProperty Field

Calendar.ItemContactsProperty Field
[image]

Identifies the ItemContacts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ItemContactsProperty

Visual Basic [image] Copy Code

Public Shared ItemContactsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemLocationsProperty Field

Calendar.ItemLocationsProperty Field
[image]

Identifies the ItemLocations dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ItemLocationsProperty

Visual Basic [image] Copy Code

Public Shared ItemLocationsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemResourcesProperty Field

Calendar.ItemResourcesProperty Field
[image]

Identifies the ItemResources dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ItemResourcesProperty

Visual Basic [image] Copy Code

Public Shared ItemResourcesProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemSettingsProperty Field

Calendar.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemTasksProperty Field

Calendar.ItemTasksProperty Field
[image]

Identifies the ItemTasks dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ItemTasksProperty

Visual Basic [image] Copy Code

Public Shared ItemTasksProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.KeepItemOrderProperty Field

Calendar.KeepItemOrderProperty Field
[image]

Identifies the KeepItemOrder dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty KeepItemOrderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly KeepItemOrderProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ListViewSettingsProperty Field

Calendar.ListViewSettingsProperty Field
[image]

Identifies the ListViewSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ListViewSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ListViewSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthRangeSettingsProperty Field

Calendar.MonthRangeSettingsProperty Field
[image]

Identifies the MonthRangeSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthRangeSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthRangeSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthSettingsProperty Field

Calendar.MonthSettingsProperty Field
[image]

Identifies the MonthSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.RemindersCheckIntervalProperty Field

Calendar.RemindersCheckIntervalProperty Field
[image]

Identifies the RemindersCheckInterval dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RemindersCheckIntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RemindersCheckIntervalProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ScheduleProperty Field

Calendar.ScheduleProperty Field
[image]

Identifies the Schedule dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScheduleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScheduleProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SelectionProperty Field

Calendar.SelectionProperty Field
[image]

Identifies the Selection dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SelectionToolTipFormatProperty Field

Calendar.SelectionToolTipFormatProperty Field
[image]

Identifies the SelectionToolTipFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionToolTipFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ShowSelectionToolTipsProperty Field

Calendar.ShowSelectionToolTipsProperty Field
[image]

Identifies the ShowSelectionToolTips dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowSelectionToolTipsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowSelectionToolTipsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ThemeProperty Field

Calendar.ThemeProperty Field
[image]

Identifies the Theme dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThemeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThemeProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.TimetableSettingsProperty Field

Calendar.TimetableSettingsProperty Field
[image]

Identifies the TimetableSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimetableSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimetableSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.VerticalScrollBarVisibilityProperty Field

Calendar.VerticalScrollBarVisibilityProperty Field
[image]

Identifies the VerticalScrollBarVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalScrollBarVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalScrollBarVisibilityProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.VScrollPosProperty Field

Calendar.VScrollPosProperty Field
[image]

Identifies the VScrollPos dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VScrollPosProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VScrollPosProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.WeekRangeSettingsProperty Field

Calendar.WeekRangeSettingsProperty Field
[image]

Identifies the WeekRangeSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekRangeSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekRangeSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.RescheduleRecurrenceKeyProperty Field

Calendar.RescheduleRecurrenceKeyProperty Field
[image]

Identifies the RescheduleRecurrenceKey dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RescheduleRecurrenceKeyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RescheduleRecurrenceKeyProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Constructor

Calendar Constructor
[image]

Initializes a new instance of the Calendar class.

Overload List

Name | Description
Calendar () | Initializes a new instance of the Calendar class using the current culture info.
Calendar (CultureInfo) | Initializes a new instance of the Calendar class using the specified culture info.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Constructor ()

Calendar Constructor ()
See Also
[image]

Initializes a new instance of the Calendar class using the current culture info.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Constructor (CultureInfo)

Calendar Constructor (CultureInfo)
See Also
[image]

Initializes a new instance of the Calendar class using the specified culture info.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar (
CultureInfo culture
)

Visual Basic [image] Copy Code

Public New ( _
culture As CultureInfo _
)

Parameters

culture
A .NET CultureInfo object providing information about formatting and displaying dates and times.

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Methods

Calendar Methods
[image]

Public Methods

Name | Description
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
CreateImage | Creates a WYSIWYG image from the calendar.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetItemAt | Overloaded. Gets the item displayed at a specified coordinates.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetItemStyle | Retrieves the CalendarStyle previously associated with the normal state of the specified item.
GetItemTooltip | Retrieves the string tooltip previously associated with the item.
GetPointedItemStyle | Retrieves the CalendarStyle previously associated with the pointed state of the specified item.
GetPointedSelectedItemStyle | Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at a specified coordinates.
GetSelectedItemStyle | Retrieves the CalendarStyle previously associated with the selected state of the specified item.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom | Overloaded. Loads schedule data from a file or a stream.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
SaveTo | Overloaded. Saves the underlying schedule to a file or a stream.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
SetItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.
SetItemTooltip | Associates a new string tooltip with the specified item.
SetPointedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.
SetPointedSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.
SetSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnCellPresenterCreated | Raises the CellPresenterCreated event.
OnCellPresenterCreating | Raises the CellPresenterCreating event.
OnDateClick | Raises the DateClick event.
OnFilterItem | Raises the FilterItem event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll | Raises the HScroll event.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemPresenterCreated | Raises the ItemPresenterCreated event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnItemStartModifying | Raises the ItemStartModifying event.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnRebuilding | Raises the Rebuilding event.
OnRebuilt | Raises the Rebuilt event.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTextInput | Control.OnTextInput override.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Raises the VScroll event.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.BeginInit Method

Calendar.BeginInit Method
[image]

Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C# [image] Copy Code

using MindFusion.Scheduling.;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = true;
calendar.EndInit();

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling.

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = True
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.CollapseResourceRow Method

Calendar.CollapseResourceRow Method
[image]

Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void CollapseResourceRow (
Resource reference
)

Visual Basic [image] Copy Code

Public Sub CollapseResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be collapsed.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ExpandResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.Wpf.Calendar.CreateImage Method

Calendar.CreateImage Method
[image]

Creates a WYSIWYG image from the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public BitmapSource CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As BitmapSource

Return Value

A BitmapSource instance representing the image.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EndInit Method

Calendar.EndInit Method
[image]

Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnsureVisible Method

Calendar.EnsureVisible Method
[image]

Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.

Overload List

Name | Description
Calendar.EnsureVisible (DateTime) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (DateTime, Resource) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.
Calendar.EnsureVisible (Item) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (Item, Resource) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnsureVisible Method (DateTime)

Calendar.EnsureVisible Method (DateTime)
See Also
[image]

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void EnsureVisible (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub EnsureVisible( _
date As DateTime _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnsureVisible Method (DateTime, Resource)

Calendar.EnsureVisible Method (DateTime, Resource)
See Also
[image]

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void EnsureVisible (
DateTime date,
Resource reference
)

Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
date As DateTime, _
reference As Resource _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.
reference
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnsureVisible Method (Item)

Calendar.EnsureVisible Method (Item)
See Also
[image]

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void EnsureVisible (
Item item
)

Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
item As Item _
)

Parameters

item
The schedule Item to scroll into view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EnsureVisible Method (Item, Resource)

Calendar.EnsureVisible Method (Item, Resource)
See Also
[image]

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void EnsureVisible (
Item item,
Resource reference
)

Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
item As Item, _
reference As Resource _
)

Parameters

item
The schedule Item to scroll into view.
reference
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ExpandResourceRow Method

Calendar.ExpandResourceRow Method
[image]

Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void ExpandResourceRow (
Resource reference
)

Visual Basic [image] Copy Code

Public Sub ExpandResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be expanded.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.Wpf.Calendar.GetDateAt Method

Calendar.GetDateAt Method
[image]

Returns the date of the calendar cell located at the specified coordinates.

Overload List

Name | Description
Calendar.GetDateAt (Int32, Int32) | Returns the date of the calendar cell located at the specified coordinates.
Calendar.GetDateAt (Point) | Returns the date of the calendar cell located at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetDateAt Method (Int32, Int32)

Calendar.GetDateAt Method (Int32, Int32)
See Also
[image]

Returns the date of the calendar cell located at the specified coordinates.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Nullable<DateTime> GetDateAt (
int x,
int y
)

Visual Basic [image] Copy Code

Public Function GetDateAt( _
x As Integer, _
y As Integer _
) As Nullable(Of DateTime)

Parameters

x

The x-coordinate of the position at which to look for a date cell.

y

The y-coordinate of the position at which to look for a date cell.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified position, the return value is null (Nothing in Visual Basic).

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetDateAt Method (Point)

Calendar.GetDateAt Method (Point)
See Also
[image]

Returns the date of the calendar cell located at the specified position.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Nullable<DateTime> GetDateAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetDateAt( _
point As Point _
) As Nullable(Of DateTime)

Parameters

point

The position at which to look for a date cell.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is null (Nothing in Visual Basic).

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetItemAt Method

Calendar.GetItemAt Method
[image]

Gets the item displayed at a specified coordinates.

Overload List

Name | Description
Calendar.GetItemAt (Int32, Int32) | Gets the scheduled Item object displayed at the specified coordinates.
Calendar.GetItemAt (Point) | Gets the scheduled Item object displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetItemAt Method (Int32, Int32)

Calendar.GetItemAt Method (Int32, Int32)
See Also
[image]

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetItemAt (
int x,
int y
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
x As Integer, _
y As Integer _
) As Item

Parameters

x

The x-coordinate of the position at which to look for a scheduled item.

y

The y-coordinate of the position at which to look for a scheduled item.

Return Value

The Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetItemAt Method (Point)

Calendar.GetItemAt Method (Point)
See Also
[image]

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item GetItemAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
point As Point _
) As Item

Parameters

point

The position at which to look for a scheduled item.

Return Value

The Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetItemListLane Method

Calendar.GetItemListLane Method
[image]

Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int GetItemListLane (
Item item
)

Visual Basic [image] Copy Code

Public Function GetItemListLane ( _
item As Item _
) As Integer

Parameters

item
A reference to the Item whose lane index to retrieve.

Return Value

The zero-based index of the item lane or -1, if the item is not associated with a lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetItemListLane Method


MindFusion.Scheduling.Wpf.Calendar.GetItemStyle Method

Calendar.GetItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the normal state of the specified item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle GetItemStyle (
Item item
)

Visual Basic [image] Copy Code

Public Function GetItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetPointedItemStyle Method
GetPointedSelectedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.GetItemTooltip Method

Calendar.GetItemTooltip Method
[image]

Retrieves the string tooltip previously associated with the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string GetItemTooltip (
Item item
)

Visual Basic [image] Copy Code

Public Function GetItemTooltip ( _
item As Item _
) As String

Parameters

item
An Item whose tooltip to retrieve.

Return Value

The tooltip previously associated with the item through the SetItemTooltip method or null (Nothing in Visual Basic) if the item does not have an associated tooltip.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetItemTooltip Method


MindFusion.Scheduling.Wpf.Calendar.GetPointedItemStyle Method

Calendar.GetPointedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the pointed state of the specified item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle GetPointedItemStyle (
Item item
)

Visual Basic [image] Copy Code

Public Function GetPointedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetItemStyle Method
GetPointedSelectedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.GetPointedSelectedItemStyle Method

Calendar.GetPointedSelectedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle GetPointedSelectedItemStyle (
Item item
)

Visual Basic [image] Copy Code

Public Function GetPointedSelectedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetItemStyle Method
GetPointedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.GetResourceAt Method

Calendar.GetResourceAt Method
[image]

Gets the Resource object whose schedule is displayed at a specified coordinates.

Overload List

Name | Description
Calendar.GetResourceAt (Int32, Int32) | Gets the Resource object whose schedule is displayed at the specified coordinates.
Calendar.GetResourceAt (Point) | Gets the Resource object whose schedule is displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetResourceAt Method (Int32, Int32)

Calendar.GetResourceAt Method (Int32, Int32)
See Also
[image]

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource GetResourceAt (
int x,
int y
)

Visual Basic [image] Copy Code

Public Function GetResourceAt( _
x As Integer, _
y As Integer _
) As Resource

Parameters

x

The x-coordinate of the position at which to look for resource's scheduled items.

y

The y-coordinate of the position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetResourceAt Method (Point)

Calendar.GetResourceAt Method (Point)
See Also
[image]

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource GetResourceAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetResourceAt( _
point As Point _
) As Resource

Parameters

point

The position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GetSelectedItemStyle Method

Calendar.GetSelectedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the selected state of the specified item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle GetSelectedItemStyle (
Item item
)

Visual Basic [image] Copy Code

Public Function GetSelectedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetItemStyle Method
GetPointedItemStyle Method
GetPointedSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.IsResourceRowExpanded Method

Calendar.IsResourceRowExpanded Method
[image]

Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsResourceRowExpanded (
Resource reference
)

Visual Basic [image] Copy Code

Public Function IsResourceRowExpanded ( _
reference As Resource _
) As Boolean

Parameters

reference
A reference to a Contact, Location, Task or Resource object to be checked.

Return Value

Returns true if the associated row is expanded or false if either the row is collapsed, there is no such row or the current view is not a ResourceView.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.Wpf.Calendar.LoadFrom Method

Calendar.LoadFrom Method
[image]

Loads schedule data from a file or a stream.

Overload List

Name | Description
Calendar.LoadFrom (Stream) | Loads schedule data from the specified stream.
Calendar.LoadFrom (String) | Loads schedule data from the specified file.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.LoadFrom Method (Stream)

Calendar.LoadFrom Method (Stream)
See Also
[image]

Loads schedule data from the specified stream.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
stream As Stream _
)

Parameters

stream

The stream from which to load the schedule.

Remarks

This method loads the schedule data from a stream where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the stream are loaded. This method also attempts to load a previously saved view state.

See Also

LoadFrom Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.LoadFrom Method (String)

Calendar.LoadFrom Method (String)
See Also
[image]

Loads schedule data from the specified file.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded. This method also attempts to load a previously saved view state.

See Also

LoadFrom Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MeasureOverride Method

Calendar.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint
The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

Remarks

MindFusion.Scheduling for WPF always uses all available space.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnCellPresenterCreated Method

Calendar.OnCellPresenterCreated Method
[image]

Raises the CellPresenterCreated event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellPresenterCreated (
CellPresenterEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellPresenterCreated ( _
e As CellPresenterEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnCellPresenterCreating Method

Calendar.OnCellPresenterCreating Method
[image]

Raises the CellPresenterCreating event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellPresenterCreating (
CellPresenterCreatingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellPresenterCreating ( _
e As CellPresenterCreatingEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnDateClick Method

Calendar.OnDateClick Method
[image]

Raises the DateClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDateClick (
ResourceDateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDateClick ( _
e As ResourceDateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnHiddenItemClick Method

Calendar.OnHiddenItemClick Method
[image]

Raises the HiddenItemClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnHiddenItemClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHiddenItemClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnHScroll Method

Calendar.OnHScroll Method
[image]

Raises the HScroll event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnHScroll (
ScrollEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHScroll( _
e As ScrollEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemClick Method

Calendar.OnItemClick Method
[image]

Raises the ItemClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemClick (
ItemMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemClick ( _
e As ItemMouseEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemCloned Method

Calendar.OnItemCloned Method
[image]

Raises the ItemCloned event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemCloned (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCloned ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemCloning Method

Calendar.OnItemCloning Method
[image]

Raises the ItemCloning event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemCloning (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCloning ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemCreated Method

Calendar.OnItemCreated Method
[image]

Raises the ItemCreated event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemCreated (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreated ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemCreating Method

Calendar.OnItemCreating Method
[image]

Raises the ItemCreating event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemCreating (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreating ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemCreationCanceled Method

Calendar.OnItemCreationCanceled Method
[image]

Raises the ItemCreationCanceled event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemCreationCanceled (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreationCanceled ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemDeleted Method

Calendar.OnItemDeleted Method
[image]

Raises the ItemDeleted event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemDeleted (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeleted ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemDeleting Method

Calendar.OnItemDeleting Method
[image]

Raises the ItemDeleting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemDeleting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeleting ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemDeselecting Method

Calendar.OnItemDeselecting Method
[image]

Raises the ItemDeselecting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemDeselecting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeselecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemInplaceEdited Method

Calendar.OnItemInplaceEdited Method
[image]

Raises the ItemInplaceEdited event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEdited (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEdited ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemInplaceEditEnding Method

Calendar.OnItemInplaceEditEnding Method
[image]

Raises the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEditEnding (
ItemEditConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEditEnding ( _
e As ItemEditConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemInplaceEditStarting Method

Calendar.OnItemInplaceEditStarting Method
[image]

Raises the ItemInplaceEditStarting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEditStarting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEditStarting ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemListLaneChanged Method

Calendar.OnItemListLaneChanged Method
[image]

Raises the ItemListLaneChanged event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemListLaneChanged (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemListLaneChanged ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemModificationCanceled Method

Calendar.OnItemModificationCanceled Method
[image]

Raises the ItemModificationCanceled event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemModificationCanceled (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModificationCanceled ( _
e As ItemEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemModified Method

Calendar.OnItemModified Method
[image]

Raises the ItemModified event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemModified (
ItemModifiedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModified ( _
e As ItemModifiedEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemModifying Method

Calendar.OnItemModifying Method
[image]

Raises the ItemModifying event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemModifying (
ItemModifyConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModifying ( _
e As ItemModifyConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemPresenterCreated Method

Calendar.OnItemPresenterCreated Method
[image]

Raises the ItemPresenterCreated event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemPresenterCreated (
ItemPresenterEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemPresenterCreated( _
e As ItemPresenterEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemSelecting Method

Calendar.OnItemSelecting Method
[image]

Raises the ItemSelecting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemSelecting (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemSelectionChanged Method

Calendar.OnItemSelectionChanged Method
[image]

Raises the ItemSelectionChanged event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemSelectionChanged (
ItemSelectionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelectionChanged ( _
e As ItemSelectionEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemSelectionComplete Method

Calendar.OnItemSelectionComplete Method
[image]

Raises the ItemSelectionComplete event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemSelectionComplete (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelectionComplete ( _
e As EventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnItemStartModifying Method

Calendar.OnItemStartModifying Method
[image]

Raises the ItemStartModifying event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemStartModifying (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemStartModifying( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnListViewHeaderClick Method

Calendar.OnListViewHeaderClick Method
[image]

Raises the ListViewHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnListViewHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnListViewHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnMonthHeaderClick Method

Calendar.OnMonthHeaderClick Method
[image]

Raises the MonthHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMonthHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnMonthRangeHeaderClick Method

Calendar.OnMonthRangeHeaderClick Method
[image]

Raises the MonthRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMonthRangeHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnMonthWeekHeaderClick Method

Calendar.OnMonthWeekHeaderClick Method
[image]

Raises the MonthWeekHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMonthWeekHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthWeekHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnRebuilding Method

Calendar.OnRebuilding Method
[image]

Raises the Rebuilding event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRebuilding (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRebuilding( _
e As EventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnRebuilt Method

Calendar.OnRebuilt Method
[image]

Raises the Rebuilt event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRebuilt (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRebuilt( _
e As EventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnRecurringItemDeleting Method

Calendar.OnRecurringItemDeleting Method
[image]

Raises the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRecurringItemDeleting (
RecurringItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRecurringItemDeleting ( _
e As RecurringItemConfirmEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnResourceViewBottomTimelineClick Method

Calendar.OnResourceViewBottomTimelineClick Method
[image]

Raises the ResourceViewBottomTimelineClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewBottomTimelineClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewBottomTimelineClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnResourceViewMiddleTimelineClick Method

Calendar.OnResourceViewMiddleTimelineClick Method
[image]

Raises the ResourceViewMiddleTimelineClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewMiddleTimelineClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewMiddleTimelineClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnResourceViewTopTimelineClick Method

Calendar.OnResourceViewTopTimelineClick Method
[image]

Raises the ResourceViewTopTimelineClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewTopTimelineClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewTopTimelineClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnScroll Method

Calendar.OnScroll Method
[image]

Raises the Scroll event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnScroll (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnScroll( _
e As EventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnTextInput Method

Calendar.OnTextInput Method
[image]

Control.OnTextInput override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextInput (
TextCompositionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextInput( _
e As TextCompositionEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnTimetableColumnHeaderClick Method

Calendar.OnTimetableColumnHeaderClick Method
[image]

Raises the TimetableColumnHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnTimetableColumnHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTimetableColumnHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnVisibleDateChanged Method

Calendar.OnVisibleDateChanged Method
[image]

Raises the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnVisibleDateChanged (
DateChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnVisibleDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnVScroll Method

Calendar.OnVScroll Method
[image]

Raises the VScroll event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnVScroll (
ScrollEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnVScroll ( _
e As ScrollEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.OnWeekRangeHeaderClick Method

Calendar.OnWeekRangeHeaderClick Method
[image]

Raises the WeekRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWeekRangeHeaderClick (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWeekRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e

An object containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ResetDrag Method

Calendar.ResetDrag Method
[image]

If there is a mouse drag operation in progress, it is canceled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void ResetDrag ()

Visual Basic [image] Copy Code

Public Sub ResetDrag ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SaveTo Method

Calendar.SaveTo Method
[image]

Saves the underlying schedule to a file or a stream.

Overload List

Name | Description
Calendar.SaveTo (Stream) | Saves the underlying schedule to the specified stream.
Calendar.SaveTo (String) | Saves the underlying schedule to the specified file.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SaveTo Method (Stream)

Calendar.SaveTo Method (Stream)
See Also
[image]

Saves the underlying schedule to the specified stream.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
stream As Stream _
)

Parameters

stream

The stream to save to.

Remarks

Saves the schedule data into a stream. Use LoadFrom to restore the data later. This method also attempts to save the current view state.

See Also

SaveTo Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SaveTo Method (String)

Calendar.SaveTo Method (String)
See Also
[image]

Saves the underlying schedule to the specified file.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

The path of the file to save to.

Remarks

Saves the schedule data into a XML file. Use LoadFrom to restore the data later. This method also attempts to save the current view state.

See Also

SaveTo Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.SetItemListLane Method

Calendar.SetItemListLane Method
[image]

Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetItemListLane (
Item item,
int lane
)

Visual Basic [image] Copy Code

Public Sub SetItemListLane ( _
item As Item, _
lane As Integer _
)

Parameters

item
A reference to the Item whose lane index to set.
lane

The zero-based index of the new item lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetItemListLane Method


MindFusion.Scheduling.Wpf.Calendar.SetItemStyle Method

Calendar.SetItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetItemStyle (
Item item,
CalendarStyle value
)

Visual Basic [image] Copy Code

Public Sub SetItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value

A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetPointedItemStyle Method
SetPointedSelectedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.SetItemTooltip Method

Calendar.SetItemTooltip Method
[image]

Associates a new string tooltip with the specified item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetItemTooltip (
Item item,
string value
)

Visual Basic [image] Copy Code

Public Sub SetItemTooltip ( _
item As Item, _
value As String _
)

Parameters

item
The Item whose tooltip to set.
value
The new tooltip of the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
GetItemTooltip Method


MindFusion.Scheduling.Wpf.Calendar.SetPointedItemStyle Method

Calendar.SetPointedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetPointedItemStyle (
Item item,
CalendarStyle value
)

Visual Basic [image] Copy Code

Public Sub SetPointedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetItemStyle Method
SetPointedSelectedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.SetPointedSelectedItemStyle Method

Calendar.SetPointedSelectedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetPointedSelectedItemStyle (
Item item,
CalendarStyle value
)

Visual Basic [image] Copy Code

Public Sub SetPointedSelectedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetItemStyle Method
SetPointedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.SetSelectedItemStyle Method

Calendar.SetSelectedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void SetSelectedItemStyle (
Item item,
CalendarStyle value
)

Visual Basic [image] Copy Code

Public Sub SetSelectedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SetItemStyle Method
SetPointedItemStyle Method
SetPointedSelectedItemStyle Method


MindFusion.Scheduling.Wpf.Calendar.OnFilterItem Method

Calendar.OnFilterItem Method
[image]

Raises the FilterItem event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnFilterItem (
ItemConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnFilterItem( _
e As ItemConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Properties

Calendar Properties
[image]

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle. This is a dependency property.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively. This is a dependency property
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively. This is a dependency property.
ButtonOffset | Gets or set the margin of the navigation buttons. This is a dependency property.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header. This is a dependency property.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view. This is a dependency property.
Date | Gets or sets the date currently displayed in the calendar. This is a dependency property.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked. This is a dependency property.
DelayScroll | Gets or sets a value indicating whether interacting with the scrollbars will not have an effect until the interaction is over. During interaction a tooltip is displayed to indicate the expected scroll position. This is a dependency property.
DelayScrollToolTipFormat | Gets or sets the format of a tooltip displayed when scrolling and DelayScroll set to true. This is a dependency property.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule. This is a dependency property.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control. This is a dependency property.
EndDate | Gets or sets the last date displayed in the calendar. This is a dependency property.
FirstWeekendDay | Gets or sets the first weekend day in the calendar. This is a dependency property.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.
HScrollPos | Gets or sets the current horizontal scroll position. This is a dependency property.
InteractiveItemType | Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.
ItemCloneKey | Gets or sets the modifier key, which when pressed while dragging an item, will cause this item to be cloned and the clone to be dragged instead.
ItemContacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ItemLocations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
ItemResources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
KeepItemOrder | Gets or sets a value indicating whether to attempt to prioritize the newly created items during collision processing. This is a dependency property.
LicenseKey | Gets or sets the license key of the control.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds. This is a dependency property.
RescheduleRecurrenceKey | Gets or sets the modifier key, which when pressed allows users to interactively reschedule recurrent items.
ResourceViewSettings | Gets or sets the ResourceViewSettings object used to customize the Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control. This is a dependency property.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionToolTipFormat | Gets or sets the format of a selection tooltip. This is a dependency property.
ShowSelectionToolTips | Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.
Theme | Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.
VScrollPos | Gets or sets the current vertical scroll position. This is a dependency property.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.AllowAutoScroll Property

Calendar.AllowAutoScroll Property
[image]

Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool AllowAutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAutoScroll As Boolean

Property Value

true to enable automatic scrolling; otherwise, false. The default is true.

Remarks

Automatic scrolling starts when a schedule item or a selection of items is dragged near the borders of the calendar contents rectangle. The contents rectangle is the part of a calendar view that contains all time cells and excludes the headers. If the mouse is moved outside the contents rectangle, the scrolling stops.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.AllowInplaceCreate Property

Calendar.AllowInplaceCreate Property
[image]

Gets or sets a value indicating whether users are allowed to create items interactively. This is a dependency property

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool AllowInplaceCreate { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceCreate As Boolean

Property Value

true to allow users to create schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot create items interactively. If it is enabled and InteractiveItemType is not null (Nothing in Visual Basic), a new schedule item of the specified type is created when users start typing in a time cell. This raises the ItemCreating event, which lets your application validate the operation or cancel it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
InteractiveItemType Property
AllowInplaceEdit Property


MindFusion.Scheduling.Wpf.Calendar.AllowInplaceEdit Property

Calendar.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether users are allowed to edit items interactively. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true to allow users to edit schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot edit item's text interactively. Controlling the editing of item text can be done by handling the ItemInplaceEditStarting and ItemInplaceEditEnding events.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
InteractiveItemType Property
AllowInplaceCreate Property


MindFusion.Scheduling.Wpf.Calendar.ButtonOffset Property

Calendar.ButtonOffset Property
[image]

Gets or set the margin of the navigation buttons. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ButtonOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOffset As Integer

Property Value

An integer value specifying how many pixels there are between a button and header edges. The default is 4.

Remarks

The buttons get smaller if the value of this property is increased.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ContactNameFormat Property

Calendar.ContactNameFormat Property
[image]

Gets or sets how to format and display contact names in the timetable header. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string ContactNameFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ContactNameFormat As String

Property Value

A string specifying the name format. The default is "F M L".

Remarks

Use the capital letters F, M and L as placeholders for the First, Middle and Last names. Any other character will be displayed unchanged.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.Culture Property

Calendar.Culture Property
[image]

Gets or sets the CultureInfo object used to format and display time information in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Culture { get; set; }

Visual Basic [image] Copy Code

Public Property Culture As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

Remarks

Setting the culture info results in reinitialization of all culture-specific properties, such as day and month names, first day of the week, and so on.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.CurrentView Property

Calendar.CurrentView Property
[image]

Gets or sets the type of the calendar view. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarView CurrentView { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentView As CalendarView

Property Value

A member of the CalendarView enumeration. The default is SingleMonth.

Remarks

The control can display the schedule data in several different types of views. This property allows changing the current view and can be used to implement drill down into the schedule data by switching from more general to more specialized views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.Date Property

Calendar.Date Property
[image]

Gets or sets the date currently displayed in the calendar. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

A .NET DateTime object. The initial value is DateTime.Today.

Remarks

This value is not used in a timetable view. To specify the dates displayed in timetable view, use TimetableSettings.Dates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
EndDate Property
TimetableSettings.Dates Property


MindFusion.Scheduling.Wpf.Calendar.DateTimeFormat Property

Calendar.DateTimeFormat Property
[image]

Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTimeFormatInfo DateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DateTimeFormat As DateTimeFormatInfo

Property Value

An instance of the .NET DateTimeFormatInfo class.

Remarks

If this property is not set, the calendar uses the DateFormatInfo from the associated Culture.

Note

Setting various subproperties of this property is transparent for the Calendar control and in order to update the control, you should enclose the property sets in a BeginInit/EndInit block. See the example section below for illustration.

Example

The following example demonstrates how to properly set various properties of the DateTimeFormat property. The example code assumes that calendar is a variable identifying existing Calendar instance.

C# [image] Copy Code

calendar.BeginInit();
calendar.DateTimeFormat.FirstDayOfWeek = DayOfWeek.Monday;
calendar.EndInit();

Visual Basic [image] Copy Code
calendar.BeginInit()
calendar.DateTimeFormat.FirstDayOfWeek = DayOfWeek.Monday
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
Culture Property


MindFusion.Scheduling.Wpf.Calendar.DelayInplaceEdit Property

Calendar.DelayInplaceEdit Property
[image]

Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool DelayInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property DelayInplaceEdit As Boolean

Property Value

true to delay in-place editing; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DelayScroll Property

Calendar.DelayScroll Property
[image]

Gets or sets a value indicating whether interacting with the scrollbars will not have an effect until the interaction is over. During interaction a tooltip is displayed to indicate the expected scroll position. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool DelayScroll { get; set; }

Visual Basic [image] Copy Code

Public Property DelayScroll As Boolean

Property Value

true to enable delayed scrolling; otherwise, false. The default is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
DelayScrollToolTipFormat Property


MindFusion.Scheduling.Wpf.Calendar.DelayScrollToolTipFormat Property

Calendar.DelayScrollToolTipFormat Property
[image]

Gets or sets the format of a tooltip displayed when scrolling and DelayScroll set to true. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string DelayScrollToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DelayScrollToolTipFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
DelayScroll Property


MindFusion.Scheduling.Wpf.Calendar.DisableReminders Property

Calendar.DisableReminders Property
[image]

Gets or sets a value indicating whether to completely disable reminders in the whole schedule. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool DisableReminders { get; set; }

Visual Basic [image] Copy Code

Public Property DisableReminders As Boolean

Property Value

true to disable the reminder events; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
RemindersCheckInterval Property


MindFusion.Scheduling.Wpf.Calendar.EnableDragCreate Property

Calendar.EnableDragCreate Property
[image]

Gets or sets a value indicating whether items are created merely by dragging in the control. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableDragCreate { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDragCreate As Boolean

Property Value

true to enable interactive item creation when the users clicks and drags in the control; false to disable it. The default is false.

Remarks

By default, the items in MindFusion.Scheduling for WPF are created interactively by selecting a time range in the current view and typing. Setting this property to true overrides this behavior and enables users to create items by clicking and dragging.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.EndDate Property

Calendar.EndDate Property
[image]

Gets or sets the last date displayed in the calendar. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }

Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

A .NET DateTime object. The initial value is set 30 days after Date.

Remarks

This member is only valid in WeekRange view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.FirstWeekendDay Property

Calendar.FirstWeekendDay Property
[image]

Gets or sets the first weekend day in the calendar. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DayOfWeek FirstWeekendDay { get; set; }

Visual Basic [image] Copy Code

Public Property FirstWeekendDay As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration.

Remarks

Specifies which day to regard as start of the weekend.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.GroupType Property

Calendar.GroupType Property
[image]

Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public GroupType GroupType { get; set; }

Visual Basic [image] Copy Code

Public Property GroupType As GroupType

Property Value

A member of the GroupType enumeration. The default is None.

Remarks

For more information about grouping in MindFusion.Scheduling for WPF check Grouping.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HorizontalScrollBarVisibility Property

Calendar.HorizontalScrollBarVisibility Property
[image]

Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalScrollBarVisibility As ScrollBarVisibility

Property Value

A member of the ScrollBarVisibility enumeration. The default is a Auto.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HScrollPos Property

Calendar.HScrollPos Property
[image]

Gets or sets the current horizontal scroll position. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double HScrollPos { get; set; }

Visual Basic [image] Copy Code

Public Property HScrollPos As Double

Property Value

An integer value specifying the current horizontal scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
VScrollPos Property


MindFusion.Scheduling.Wpf.Calendar.InteractiveItemType Property

Calendar.InteractiveItemType Property
[image]

Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Type InteractiveItemType { get; set; }

Visual Basic [image] Copy Code

Public Property InteractiveItemType As Type

Property Value

An instance of the .NET Type class specifying what type of items to create when a user starts typing. The default is Appointment.

Remarks

If this property is set to null (Nothing in Visual Basic), users cannot create items interactively.

Note

If you implement custom Item-derived class, make sure it provides parameterless constructor. Otherwise, no items will be created.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
AllowInplaceEdit Property


MindFusion.Scheduling.Wpf.Calendar.ItemChangeReferenceKey Property

Calendar.ItemChangeReferenceKey Property
[image]

Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ModifierKeys ItemChangeReferenceKey { get; set; }

Visual Basic [image] Copy Code

Public Property ItemChangeReferenceKey As ModifierKeys

Property Value

A member of the ModifiedKeys enumeration. The default is Alt.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemCloneKey Property

Calendar.ItemCloneKey Property
[image]

Gets or sets the modifier key, which when pressed while dragging an item, will cause this item to be cloned and the clone to be dragged instead.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ModifierKeys ItemCloneKey { get; set; }

Visual Basic [image] Copy Code

Public Property ItemCloneKey As ModifierKeys

Property Value

A member of the WPF ModifierKeys enumeration. The default is Shift.

Remarks

Set this property to None to prevent interactive item cloning.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemContacts Property

Calendar.ItemContacts Property
[image]

Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> ItemContacts { get; set; }

Visual Basic [image] Copy Code

Public Property ItemContacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) generic class specifying which contacts are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemLocations Property

Calendar.ItemLocations Property
[image]

Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Location> ItemLocations { get; set; }

Visual Basic [image] Copy Code

Public Property ItemLocations As ResourceCollection(Of Location)

Property Value

An instance of the ResourceCollection(Location) generic class specifying which locations are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemResources Property

Calendar.ItemResources Property
[image]

Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> ItemResources { get; set; }

Visual Basic [image] Copy Code

Public Property ItemResources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) generic class specifying which resources are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemSelection Property

Calendar.ItemSelection Property
[image]

Gets a list of all selected items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemSelection ItemSelection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemSelection As ItemSelection

Property Value

An instance of the ItemSelection class representing the currently selected items.

Remarks

Use Selection to get the collection of all selected time cells.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
Selection Property


MindFusion.Scheduling.Wpf.Calendar.ItemSettings Property

Calendar.ItemSettings Property
[image]

Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; set; }

Visual Basic [image] Copy Code

Public Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemTasks Property

Calendar.ItemTasks Property
[image]

Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceCollection<Task> ItemTasks { get; set; }

Visual Basic [image] Copy Code

Public Property ItemTasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection(Resource) generic class specifying which tasks are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.KeepItemOrder Property

Calendar.KeepItemOrder Property
[image]

Gets or sets a value indicating whether to attempt to prioritize the newly created items during collision processing. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool KeepItemOrder { get; set; }

Visual Basic [image] Copy Code

Public Property KeepItemOrder As Boolean

Property Value

true to prioritize newly created items during collisions; false to use the default item ordering. The default is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ListViewSettings Property

Calendar.ListViewSettings Property
[image]

Gets the ListViewSettings object used to customize the visualization of the List view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ListViewSettings ListViewSettings { get; set; }

Visual Basic [image] Copy Code

Public Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class.

Remarks

Use the ListViewSettings members to customize the appearance of the calendar when CurrentView is set to List.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthRangeSettings Property

Calendar.MonthRangeSettings Property
[image]

Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthRangeSettings MonthRangeSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthSettings Property

Calendar.MonthSettings Property
[image]

Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthSettings MonthSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.RemindersCheckInterval Property

Calendar.RemindersCheckInterval Property
[image]

Gets or sets the interval between reminder checks, expressed in seconds. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int RemindersCheckInterval { get; set; }

Visual Basic [image] Copy Code

Public Property RemindersCheckInterval As Integer

Property Value

An integer value. The default is 30.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ResourceViewSettings Property

Calendar.ResourceViewSettings Property
[image]

Gets or sets the ResourceViewSettings object used to customize the Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceViewSettings ResourceViewSettings { get; set; }

Visual Basic [image] Copy Code

Public Property ResourceViewSettings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.Schedule Property

Calendar.Schedule Property
[image]

Gets or sets the schedule whose information should be displayed inside the calendar control. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Schedule Schedule { get; set; }

Visual Basic [image] Copy Code

Public Property Schedule As Schedule

Property Value

A Schedule object providing the schedule data displayed in the calendar view.

Remarks

You can easily substitute the schedule being displayed by the control at any time by simply assigning a new Schedule object to this property. You can also make two or more Calendar controls display the same schedule.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
Schedule Class


MindFusion.Scheduling.Wpf.Calendar.Selection Property

Calendar.Selection Property
[image]

Gets a Selection object representing the current selection in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Selection Selection { get; set; }

Visual Basic [image] Copy Code

Public Property Selection As Selection

Property Value

An instance of the Selection class representing the selection of time cells.

Remarks

Use ItemSelection to get the selection of schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemSelection Property


MindFusion.Scheduling.Wpf.Calendar.SelectionToolTipFormat Property

Calendar.SelectionToolTipFormat Property
[image]

Gets or sets the format of a selection tooltip. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string SelectionToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionToolTipFormat As String

Property Value

A standard DateTime formatting string. The default is "HH:mm".

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ShowSelectionToolTips Property


MindFusion.Scheduling.Wpf.Calendar.ShowSelectionToolTips Property

Calendar.ShowSelectionToolTips Property
[image]

Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowSelectionToolTips { get; set; }

Visual Basic [image] Copy Code

Public Property ShowSelectionToolTips As Boolean

Property Value

true, to display tooltips on selection ranges; otherwise, false.

Remarks

This property has effect only in Timetable and Resource view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
SelectionToolTipFormat Property


MindFusion.Scheduling.Wpf.Calendar.Theme Property

Calendar.Theme Property
[image]

Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ThemeType Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As ThemeType

Property Value

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.TimetableSettings Property

Calendar.TimetableSettings Property
[image]

Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimetableSettings TimetableSettings { get; set; }

Visual Basic [image] Copy Code

Public Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.VerticalScrollBarVisibility Property

Calendar.VerticalScrollBarVisibility Property
[image]

Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalScrollBarVisibility As ScrollBarVisibility

Property Value

A member of the ScrollBarVisibility enumeration. The default is a Auto.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
HorizontalScrollBarVisibility Property


MindFusion.Scheduling.Wpf.Calendar.VScrollPos Property

Calendar.VScrollPos Property
[image]

Gets or sets the current vertical scroll position. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double VScrollPos { get; set; }

Visual Basic [image] Copy Code

Public Property VScrollPos As Double

Property Value

An integer value specifying the current vertical scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
HScrollPos Property


MindFusion.Scheduling.Wpf.Calendar.WeekRangeSettings Property

Calendar.WeekRangeSettings Property
[image]

Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public WeekRangeSettings WeekRangeSettings { get; set; }

Visual Basic [image] Copy Code

Public Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.LicenseKey Property

Calendar.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.RescheduleRecurrenceKey Property

Calendar.RescheduleRecurrenceKey Property
[image]

Gets or sets the modifier key, which when pressed allows users to interactively reschedule recurrent items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ModifierKeys RescheduleRecurrenceKey { get; set; }

Visual Basic [image] Copy Code

Public Property RescheduleRecurrenceKey As ModifierKeys

Property Value

A member of the WPF ModifierKeys enumeration. The default is None.

Remarks

Set this property to None to prevent interactive recurrence rescheduling.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar Events

Calendar Events
[image]

Public Events

Name | Description
CellPresenterCreated | Raised when the CellPresenter control that will visualize specific view cell is created.
CellPresenterCreating | Raised when the CellPresenter control that will visualize specific view cell is being instantiated.
DateClick | Raised when the user clicks a date cell in the calendar.
FilterItem | Raised to allow filtering specific items from the view.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user. This event is also raised upon completion of interaction which was previously canceled programmatically through the ItemModifying event.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemPresenterCreated | Raised when the ItemPresenter Control that will visualise specific item is created.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ItemStartModifying | Raised when the user is about to move or resize an item.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
Rebuilding | An event raised when the view is being rebuild and before the cell presenters are created.
Rebuilt | An event raised after the view is rebuild and after the cell presenters are created.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.CellPresenterCreated Event

Calendar.CellPresenterCreated Event
[image]

Raised when the CellPresenter control that will visualize specific view cell is created.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellPresenterEventArgs> CellPresenterCreated

Visual Basic [image] Copy Code

Public Event CellPresenterCreated As EventHandler(Of CellPresenterEventArgs)

Event Data

CellPresenterCreated event handlers receive an argument of type CellPresenterEventArgs.

Remarks

This event can be used to supply custom styles to specific cells.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.CellPresenterCreating Event

Calendar.CellPresenterCreating Event
[image]

Raised when the CellPresenter control that will visualize specific view cell is being instantiated.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellPresenterCreatingEventArgs> CellPresenterCreating

Visual Basic [image] Copy Code

Public Event CellPresenterCreating As EventHandler(Of CellPresenterCreatingEventArgs)

Event Data

CellPresenterCreating event handlers receive an argument of type CellPresenterCreatingEventArgs.

Remarks

The event is raised just before the presenter of a cell is created to allow the client to instantiate a presenter of a custom type. If the event is not handled or the client does not assign an object to the CellPresenter property, the control creates a presenter of type CellPresenter.

A common scenario involves the use of the StartTime, EndTime and Resource properties in order to assign custom presenters only to cells matching specific criteria. For example, the client might associate a cell presenter only with holidays or weekend days.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.DateClick Event

Calendar.DateClick Event
[image]

Raised when the user clicks a date cell in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ResourceDateEventArgs> DateClick

Visual Basic [image] Copy Code

Public Event DateClick As EventHandler(Of ResourceDateEventArgs)

Event Data

DateClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.FilterItem Event

Calendar.FilterItem Event
[image]

Raised to allow filtering specific items from the view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> FilterItem

Visual Basic [image] Copy Code

Public Event FilterItem As EventHandler(Of ItemConfirmEventArgs)

Event Data

FilterItem event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HiddenItemClick Event

Calendar.HiddenItemClick Event
[image]

Raised when a hidden items cue icon is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> HiddenItemClick

Visual Basic [image] Copy Code

Public Event HiddenItemClick As EventHandler(Of DateEventArgs)

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.HScroll Event

Calendar.HScroll Event
[image]

Raised when the control has been scrolled horizontally.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event ScrollEventHandler HScroll

Visual Basic [image] Copy Code

Public Event HScroll As ScrollEventHandler

Event Data

HScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
VScroll Event
Scroll Event


MindFusion.Scheduling.Wpf.Calendar.ItemClick Event

Calendar.ItemClick Event
[image]

Raised when the user clicks a schedule item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemMouseEventArgs> ItemClick

Visual Basic [image] Copy Code

Public Event ItemClick As EventHandler(Of ItemMouseEventArgs)

Event Data

ItemClick event handlers receive an argument of type ItemMouseEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
HiddenItemClick Event


MindFusion.Scheduling.Wpf.Calendar.ItemCloned Event

Calendar.ItemCloned Event
[image]

Raised when the user has cloned an item interactively.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCloned

Visual Basic [image] Copy Code

Public Event ItemCloned As EventHandler(Of ItemEventArgs)

Event Data

ItemCloned event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemCloning Event


MindFusion.Scheduling.Wpf.Calendar.ItemCloning Event

Calendar.ItemCloning Event
[image]

Raised when the user is about to clone an item interactively.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemCloning

Visual Basic [image] Copy Code

Public Event ItemCloning As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCloning event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemCloned Event


MindFusion.Scheduling.Wpf.Calendar.ItemCreated Event

Calendar.ItemCreated Event
[image]

Raised when a schedule item is created by the user.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCreated

Visual Basic [image] Copy Code

Public Event ItemCreated As EventHandler(Of ItemEventArgs)

Event Data

ItemCreated event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemCreating Event


MindFusion.Scheduling.Wpf.Calendar.ItemCreating Event

Calendar.ItemCreating Event
[image]

Raised when the user is about to create a new schedule item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemCreating

Visual Basic [image] Copy Code

Public Event ItemCreating As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCreating event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemCreated Event


MindFusion.Scheduling.Wpf.Calendar.ItemCreationCanceled Event

Calendar.ItemCreationCanceled Event
[image]

Raised when an interactive item creation is canceled by the user.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCreationCanceled

Visual Basic [image] Copy Code

Public Event ItemCreationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemCreationCanceled event handlers receive an argument of type ItemEventArgs.

Remarks

This event is raised when the user presses the ESC button while in-place editing the text of an item currently being created.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemDeleted Event

Calendar.ItemDeleted Event
[image]

Raised when the user deletes a schedule item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemDeleted

Visual Basic [image] Copy Code

Public Event ItemDeleted As EventHandler(Of ItemEventArgs)

Event Data

ItemDeleted event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemDeleting Event


MindFusion.Scheduling.Wpf.Calendar.ItemDeleting Event

Calendar.ItemDeleting Event
[image]

Raised when the user is about to delete a schedule item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemDeleting

Visual Basic [image] Copy Code

Public Event ItemDeleting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeleting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be used to prevent users from deleting specific non-recurring items by pressing DEL. This event is raised once for each element of the item selection. To control the deletion of recurring items, handle the RecurringItemDeleting event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemDeleted Event


MindFusion.Scheduling.Wpf.Calendar.ItemDeselecting Event

Calendar.ItemDeselecting Event
[image]

Raised when an item is about to be deselected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemDeselecting

Visual Basic [image] Copy Code

Public Event ItemDeselecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeselecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemSelecting Event


MindFusion.Scheduling.Wpf.Calendar.ItemInplaceEdited Event

Calendar.ItemInplaceEdited Event
[image]

Raised when item's text is in-place edited.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemInplaceEdited

Visual Basic [image] Copy Code

Public Event ItemInplaceEdited As EventHandler(Of ItemEventArgs)

Event Data

ItemInplaceEdited event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemInplaceEditEnding Event

Calendar.ItemInplaceEditEnding Event
[image]

Raised when in-place editing of item's text is about to be accepted.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEditConfirmEventArgs> ItemInplaceEditEnding

Visual Basic [image] Copy Code

Public Event ItemInplaceEditEnding As EventHandler(Of ItemEditConfirmEventArgs)

Event Data

ItemInplaceEditEnding event handlers receive an argument of type ItemEditConfirmEventArgs.

Remarks

This event can be used to validate the text entered into a schedule item during the in-place editing mode.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemInplaceEditStarting Event

Calendar.ItemInplaceEditStarting Event
[image]

Raised when in-place editing of item's text is about to begin.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemInplaceEditStarting

Visual Basic [image] Copy Code

Public Event ItemInplaceEditStarting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemInplaceEditStarting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be handled to prevent users from editing the text of specific schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemListLaneChanged Event

Calendar.ItemListLaneChanged Event
[image]

Raised when the lane index of an item within a List view has changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemListLaneChanged

Visual Basic [image] Copy Code

Public Event ItemListLaneChanged As EventHandler(Of ItemEventArgs)

Event Data

ItemListLaneChanged event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemModificationCanceled Event

Calendar.ItemModificationCanceled Event
[image]

Raised when an item modification is canceled by the user. This event is also raised upon completion of interaction which was previously canceled programmatically through the ItemModifying event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemModificationCanceled

Visual Basic [image] Copy Code

Public Event ItemModificationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemModificationCanceled event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemModified Event

Calendar.ItemModified Event
[image]

Raised when a schedule item is moved or resized by the user.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemModifiedEventArgs> ItemModified

Visual Basic [image] Copy Code

Public Event ItemModified As EventHandler(Of ItemModifiedEventArgs)

Event Data

ItemModified event handlers receive an argument of type ItemModifiedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemModifying Event

Calendar.ItemModifying Event
[image]

Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemModifyConfirmEventArgs> ItemModifying

Visual Basic [image] Copy Code

Public Event ItemModifying As EventHandler(Of ItemModifyConfirmEventArgs)

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

This event can be used to prevent users from modifying an item interactively.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemPresenterCreated Event

Calendar.ItemPresenterCreated Event
[image]

Raised when the ItemPresenter Control that will visualise specific item is created.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemPresenterEventArgs> ItemPresenterCreated

Visual Basic [image] Copy Code

Public Event ItemPresenterCreated As EventHandler(Of ItemPresenterEventArgs)

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

ItemPresenter property - StyleKeyComplex, StyleKeySimpleHorizontal or StyleKeySimpleVertical.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ItemSelecting Event

Calendar.ItemSelecting Event
[image]

Raised when an item is about to be selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemSelecting

Visual Basic [image] Copy Code

Public Event ItemSelecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemSelecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemDeselecting Event


MindFusion.Scheduling.Wpf.Calendar.ItemSelectionChanged Event

Calendar.ItemSelectionChanged Event
[image]

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemSelectionEventArgs> ItemSelectionChanged

Visual Basic [image] Copy Code

Public Event ItemSelectionChanged As EventHandler(Of ItemSelectionEventArgs)

Event Data

ItemSelectionChanged event handlers receive an argument of type ItemSelectionEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemSelectionComplete Event


MindFusion.Scheduling.Wpf.Calendar.ItemSelectionComplete Event

Calendar.ItemSelectionComplete Event
[image]

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ItemSelectionComplete

Visual Basic [image] Copy Code

Public Event ItemSelectionComplete As EventHandler

Event Data

ItemSelectionComplete event handlers receive an argument of type EventArgs.

Remarks

This event is fired only once unlike ItemSelectionChanged which is fired for each individual item affected by the selection operation.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ItemSelectionChanged Event


MindFusion.Scheduling.Wpf.Calendar.ItemStartModifying Event

Calendar.ItemStartModifying Event
[image]

Raised when the user is about to move or resize an item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemStartModifying

Visual Basic [image] Copy Code

Public Event ItemStartModifying As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemStartModifying event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ListViewHeaderClick Event

Calendar.ListViewHeaderClick Event
[image]

Raised when the header of a List view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ListViewHeaderClick

Visual Basic [image] Copy Code

Public Event ListViewHeaderClick As EventHandler(Of DateEventArgs)

Event Data

ListViewHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthHeaderClick Event

Calendar.MonthHeaderClick Event
[image]

Raised when the header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthHeaderClick

Visual Basic [image] Copy Code

Public Event MonthHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
MonthWeekHeaderClick Event


MindFusion.Scheduling.Wpf.Calendar.MonthRangeHeaderClick Event

Calendar.MonthRangeHeaderClick Event
[image]

Raised when the header of an MonthRange view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthRangeHeaderClick

Visual Basic [image] Copy Code

Public Event MonthRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.MonthWeekHeaderClick Event

Calendar.MonthWeekHeaderClick Event
[image]

Raised when a cell in the week header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthWeekHeaderClick

Visual Basic [image] Copy Code

Public Event MonthWeekHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthWeekHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
MonthHeaderClick Event


MindFusion.Scheduling.Wpf.Calendar.Rebuilding Event

Calendar.Rebuilding Event
[image]

An event raised when the view is being rebuild and before the cell presenters are created.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Rebuilding

Visual Basic [image] Copy Code

Public Event Rebuilding As EventHandler

Event Data

Rebuilding event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.Rebuilt Event

Calendar.Rebuilt Event
[image]

An event raised after the view is rebuild and after the cell presenters are created.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Rebuilt

Visual Basic [image] Copy Code

Public Event Rebuilt As EventHandler

Event Data

Rebuilt event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.RecurringItemDeleting Event

Calendar.RecurringItemDeleting Event
[image]

Raised when the user is about to delete a recurring item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RecurringItemConfirmEventArgs> RecurringItemDeleting

Visual Basic [image] Copy Code

Public Event RecurringItemDeleting As EventHandler(Of RecurringItemConfirmEventArgs)

Event Data

RecurringItemDeleting event handlers receive an argument of type RecurringItemConfirmEventArgs.

Remarks

This event can be used to prevent the deletion of recurring items. For non-recurring items, handle the ItemDeleting event.

Example

The following example demonstrates how to use RecurringItemDeleting event to ask the user whether he or she wants to delete all items of a recurring pattern or only the selected item(s). The example assumes that calendar already references a Calendar control. The method ConfirmDelete is supposed to return 0 if the user cancels the deletion of the item, 1 if the user chooses that only the selected item is to be deleted, and 2 if the user wants to delete the entire pattern.

C# [image] Copy Code

// Attach a handler to the event
calendar.RecurringItemDeleting +=
new EventHandler<RecurringItemConfirmEventArgs>(calendar_RecurringItemDeleting);

// ...

private void calendar_RecurringItemDeleting(object sender, RecurringItemConfirmEventArgs e)
{
int result = ConfirmDelete(e.Item);

switch (result)
{

case 0:
// Do nothing
break;

case 1:
e.ConfirmOccurrence = true;
break;

case 2:
e.ConfirmAll = true;
break;

}
}

Visual Basic [image] Copy Code

' Attach a handler to the event
AddHandler calendar.RecurringItemDeleting, AddressOf calendar_RecurringItemDeleting

' ...

Private Sub calendar_RecurringItemDeleting(ByVal sender As Object, ByVal e As RecurringItemConfirmEventArgs)

Dim result As Integer = ConfirmDelete(e.Item)

Select Case result

Case 0
' Do nothing

Case 1
e.ConfirmOccurrence = True

Case 2
e.ConfirmAll = True

End Select

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.ResourceViewBottomTimelineClick Event

Calendar.ResourceViewBottomTimelineClick Event
[image]

Raised when the bottom timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewBottomTimelineClick

Visual Basic [image] Copy Code

Public Event ResourceViewBottomTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewBottomTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ResourceViewMiddleTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.Wpf.Calendar.ResourceViewMiddleTimelineClick Event

Calendar.ResourceViewMiddleTimelineClick Event
[image]

Raised when the middle timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewMiddleTimelineClick

Visual Basic [image] Copy Code

Public Event ResourceViewMiddleTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewMiddleTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ResourceViewBottomTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.Wpf.Calendar.ResourceViewTopTimelineClick Event

Calendar.ResourceViewTopTimelineClick Event
[image]

Raised when the top timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewTopTimelineClick

Visual Basic [image] Copy Code

Public Event ResourceViewTopTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewTopTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
ResourceViewBottomTimelineClick Event
ResourceViewMiddleTimelineClick Event


MindFusion.Scheduling.Wpf.Calendar.Scroll Event

Calendar.Scroll Event
[image]

Raised when the value of a scrollbar has changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Scroll

Visual Basic [image] Copy Code

Public Event Scroll As EventHandler

Event Data

Scroll event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
HScroll Event
VScroll Event


MindFusion.Scheduling.Wpf.Calendar.TimetableColumnHeaderClick Event

Calendar.TimetableColumnHeaderClick Event
[image]

Raised when the header of a Timetable column is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> TimetableColumnHeaderClick

Visual Basic [image] Copy Code

Public Event TimetableColumnHeaderClick As EventHandler(Of DateEventArgs)

Event Data

TimetableColumnHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.VisibleDateChanged Event

Calendar.VisibleDateChanged Event
[image]

Raised when the user selects another date using the month or year navigation controls on the calendar header area.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateChangedEventArgs> VisibleDateChanged

Visual Basic [image] Copy Code

Public Event VisibleDateChanged As EventHandler(Of DateChangedEventArgs)

Event Data

VisibleDateChanged event handlers receive an argument of type DateChangedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Calendar.VScroll Event

Calendar.VScroll Event
[image]

Raised when the control has been scrolled vertically.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event ScrollEventHandler VScroll

Visual Basic [image] Copy Code

Public Event VScroll As ScrollEventHandler

Event Data

VScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace
HScroll Event
Scroll Event


MindFusion.Scheduling.Wpf.Calendar.WeekRangeHeaderClick Event

Calendar.WeekRangeHeaderClick Event
[image]

Raised when the header of a WeekRange view is clicked.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> WeekRangeHeaderClick

Visual Basic [image] Copy Code

Public Event WeekRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

WeekRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarSettings Class

CalendarSettings Class
[image]

The base class for the different theme-aware settings classes.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public abstract class CalendarSettings : FrameworkElement

Visual Basic [image] Copy Code

Public MustInherit Class CalendarSettings
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.CalendarStyle
MindFusion.Scheduling.Wpf.CellSettings
MindFusion.Scheduling.Wpf.ItemSettings
MindFusion.Scheduling.Wpf.ListViewSettings
MindFusion.Scheduling.Wpf.MonthRangeSettings
MindFusion.Scheduling.Wpf.MonthSettings
MindFusion.Scheduling.Wpf.ResourceViewSettings
MindFusion.Scheduling.Wpf.TimelineSettings
MindFusion.Scheduling.Wpf.TimetableSettings
MindFusion.Scheduling.Wpf.WeekRangeSettings

See Also

CalendarSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarSettings Members

CalendarSettings Members
Constructors
[image]

The base class for the different theme-aware settings classes.

The following tables list the members exposed by the CalendarSettings type.

Protected Constructors

Name | Description
CalendarSettings | Initializes a new instance of the CalendarSettings class.

See Also

CalendarSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarSettings Constructor

CalendarSettings Constructor
[image]

Initializes a new instance of the CalendarSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected CalendarSettings ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

CalendarSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle Class

CalendarStyle Class
[image]

Specifies the appearance of calendar elements.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class CalendarStyle : CalendarSettings

Visual Basic [image] Copy Code

Public Class CalendarStyle
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.CalendarStyle

See Also

CalendarStyle Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle Members

CalendarStyle Members
Constructors Fields Properties
[image]

Specifies the appearance of calendar elements.

The following tables list the members exposed by the CalendarStyle type.

Public Constructors

Name | Description
CalendarStyle | Initializes a new instance of the CalendarStyle class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
BottomBorderBrushProperty | Identifies the BottomBorderBrush dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
EffectProperty | Identifies the Effect dependency property.
FillBrushProperty | Identifies the FillBrush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundEffectProperty | Identifies the ForegroundEffect dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
LeftBorderBrushProperty | Identifies the LeftBorderBrush dependency property.
LineBrushProperty | Identifies the LineBrush dependency property.
MarginProperty | Identifies the Margin dependency property.
RightBorderBrushProperty | Identifies the RightBorderBrush dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TopBorderBrushProperty | Identifies the TopBorderBrush dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

Public Properties

Name | Description
Background | Gets or sets the brush used to paint the element's background.
BorderBrush | Gets or sets the brush of the element's border.
BorderThickness | Gets or sets the thickness of the element's border.
BottomBorderBrush | Gets or sets the brush of the element's bottom border.
ContentMargin | Gets or sets the margin of the element's contents.
Effect | Gets or sets the effect applied to the element.
FillBrush | Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.
FontFamily | Gets or sets the font family of the displayed text.
FontSize | Gets or sets the font size of the displayed text.
FontStretch | Gets or sets the font stretch of the displayed text.
FontStyle | Gets or sets the font style of the displayed text.
FontWeight | Gets or sets the font weight of the displayed text.
Foreground | Gets or sets the brush used to paint foreground sub-elements, such as text.
ForegroundEffect | Gets or sets the effect applied on foreground sub-elements, such as text.
HorizontalAlignment | Gets or sets the horizontal alignment of the sub-element containing the displayed text.
LeftBorderBrush | Gets or sets the brush of the element's left border.
LineBrush | Gets or sets a brush used to paint line sub-elements.
Margin | Gets or sets the margin of the element.
RightBorderBrush | Gets or sets the brush of the element's right border.
TextAlignment | Gets or sets the alignment of the displayed text.
TopBorderBrush | Gets or sets the brush of the element's top border.
VerticalAlignment | Gets or sets the vertical alignment of the sub-element containing the displayed text.

See Also

CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle Fields

CalendarStyle Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
BottomBorderBrushProperty | Identifies the BottomBorderBrush dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
EffectProperty | Identifies the Effect dependency property.
FillBrushProperty | Identifies the FillBrush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundEffectProperty | Identifies the ForegroundEffect dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
LeftBorderBrushProperty | Identifies the LeftBorderBrush dependency property.
LineBrushProperty | Identifies the LineBrush dependency property.
MarginProperty | Identifies the Margin dependency property.
RightBorderBrushProperty | Identifies the RightBorderBrush dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TopBorderBrushProperty | Identifies the TopBorderBrush dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

See Also

CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BackgroundProperty Field

CalendarStyle.BackgroundProperty Field
[image]

Identifies the Background dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BackgroundProperty

Visual Basic [image] Copy Code

Public Shared BackgroundProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BorderBrushProperty Field

CalendarStyle.BorderBrushProperty Field
[image]

Identifies the BorderBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BorderBrushProperty

Visual Basic [image] Copy Code

Public Shared BorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BorderThicknessProperty Field

CalendarStyle.BorderThicknessProperty Field
[image]

Identifies the BorderThickness dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared BorderThicknessProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BottomBorderBrushProperty Field

CalendarStyle.BottomBorderBrushProperty Field
[image]

Identifies the BottomBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BottomBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared BottomBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.ContentMarginProperty Field

CalendarStyle.ContentMarginProperty Field
[image]

Identifies the ContentMargin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ContentMarginProperty

Visual Basic [image] Copy Code

Public Shared ContentMarginProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.EffectProperty Field

CalendarStyle.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty EffectProperty

Visual Basic [image] Copy Code

Public Shared EffectProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FillBrushProperty Field

CalendarStyle.FillBrushProperty Field
[image]

Identifies the FillBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FillBrushProperty

Visual Basic [image] Copy Code

Public Shared FillBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontFamilyProperty Field

CalendarStyle.FontFamilyProperty Field
[image]

Identifies the FontFamily dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FontFamilyProperty

Visual Basic [image] Copy Code

Public Shared FontFamilyProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontSizeProperty Field

CalendarStyle.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared FontSizeProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontStretchProperty Field

CalendarStyle.FontStretchProperty Field
[image]

Identifies the FontStretch dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FontStretchProperty

Visual Basic [image] Copy Code

Public Shared FontStretchProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontStyleProperty Field

CalendarStyle.FontStyleProperty Field
[image]

Identifies the FontStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FontStyleProperty

Visual Basic [image] Copy Code

Public Shared FontStyleProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontWeightProperty Field

CalendarStyle.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared FontWeightProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.ForegroundEffectProperty Field

CalendarStyle.ForegroundEffectProperty Field
[image]

Identifies the ForegroundEffect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ForegroundEffectProperty

Visual Basic [image] Copy Code

Public Shared ForegroundEffectProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.ForegroundProperty Field

CalendarStyle.ForegroundProperty Field
[image]

Identifies the Foreground dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ForegroundProperty

Visual Basic [image] Copy Code

Public Shared ForegroundProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.HorizontalAlignmentProperty Field

CalendarStyle.HorizontalAlignmentProperty Field
[image]

Identifies the HorizontalAlignment dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared HorizontalAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.LeftBorderBrushProperty Field

CalendarStyle.LeftBorderBrushProperty Field
[image]

Identifies the LeftBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LeftBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared LeftBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.LineBrushProperty Field

CalendarStyle.LineBrushProperty Field
[image]

Identifies the LineBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LineBrushProperty

Visual Basic [image] Copy Code

Public Shared LineBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.MarginProperty Field

CalendarStyle.MarginProperty Field
[image]

Identifies the Margin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MarginProperty

Visual Basic [image] Copy Code

Public Shared MarginProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.RightBorderBrushProperty Field

CalendarStyle.RightBorderBrushProperty Field
[image]

Identifies the RightBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty RightBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared RightBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.TextAlignmentProperty Field

CalendarStyle.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared TextAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.TopBorderBrushProperty Field

CalendarStyle.TopBorderBrushProperty Field
[image]

Identifies the TopBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TopBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared TopBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.VerticalAlignmentProperty Field

CalendarStyle.VerticalAlignmentProperty Field
[image]

Identifies the VerticalAlignment dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared VerticalAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle Constructor

CalendarStyle Constructor
[image]

Initializes a new instance of the CalendarStyle class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle Properties

CalendarStyle Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to paint the element's background.
BorderBrush | Gets or sets the brush of the element's border.
BorderThickness | Gets or sets the thickness of the element's border.
BottomBorderBrush | Gets or sets the brush of the element's bottom border.
ContentMargin | Gets or sets the margin of the element's contents.
Effect | Gets or sets the effect applied to the element.
FillBrush | Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.
FontFamily | Gets or sets the font family of the displayed text.
FontSize | Gets or sets the font size of the displayed text.
FontStretch | Gets or sets the font stretch of the displayed text.
FontStyle | Gets or sets the font style of the displayed text.
FontWeight | Gets or sets the font weight of the displayed text.
Foreground | Gets or sets the brush used to paint foreground sub-elements, such as text.
ForegroundEffect | Gets or sets the effect applied on foreground sub-elements, such as text.
HorizontalAlignment | Gets or sets the horizontal alignment of the sub-element containing the displayed text.
LeftBorderBrush | Gets or sets the brush of the element's left border.
LineBrush | Gets or sets a brush used to paint line sub-elements.
Margin | Gets or sets the margin of the element.
RightBorderBrush | Gets or sets the brush of the element's right border.
TextAlignment | Gets or sets the alignment of the displayed text.
TopBorderBrush | Gets or sets the brush of the element's top border.
VerticalAlignment | Gets or sets the vertical alignment of the sub-element containing the displayed text.

See Also

CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.Background Property

CalendarStyle.Background Property
[image]

Gets or sets the brush used to paint the element's background.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

A .NET Brush instance used to fill the interior of calendar UI elements.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BorderBrush Property

CalendarStyle.BorderBrush Property
[image]

Gets or sets the brush of the element's border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush BorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the border lines.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BorderThickness Property

CalendarStyle.BorderThickness Property
[image]

Gets or sets the thickness of the element's border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness BorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property BorderThickness As Thickness

Property Value

A .NET Thickness object specifying the border width.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.BottomBorderBrush Property

CalendarStyle.BottomBorderBrush Property
[image]

Gets or sets the brush of the element's bottom border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush BottomBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BottomBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the bottom border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.ContentMargin Property

CalendarStyle.ContentMargin Property
[image]

Gets or sets the margin of the element's contents.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness ContentMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ContentMargin As Thickness

Property Value

A .NET Thickness object specifying the distance between the element's contents and the element's border.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.Effect Property

CalendarStyle.Effect Property
[image]

Gets or sets the effect applied to the element.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Effect As Effect

Property Value

A .NET Effect object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FillBrush Property

CalendarStyle.FillBrush Property
[image]

Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush FillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property FillBrush As Brush

Property Value

A .NET Brush object specifying the color of the secondary sub-elements.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontFamily Property

CalendarStyle.FontFamily Property
[image]

Gets or sets the font family of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

A .NET FontFamily object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontSize Property

CalendarStyle.FontSize Property
[image]

Gets or sets the font size of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A positive double value.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontStretch Property

CalendarStyle.FontStretch Property
[image]

Gets or sets the font stretch of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public FontStretch FontStretch { get; set; }

Visual Basic [image] Copy Code

Public Property FontStretch As FontStretch

Property Value

A .NET FontStretch object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontStyle Property

CalendarStyle.FontStyle Property
[image]

Gets or sets the font style of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A .NET FontStyle object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.FontWeight Property

CalendarStyle.FontWeight Property
[image]

Gets or sets the font weight of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A .NET FontStyle object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.Foreground Property

CalendarStyle.Foreground Property
[image]

Gets or sets the brush used to paint foreground sub-elements, such as text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }

Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

A .NET Brush object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.ForegroundEffect Property

CalendarStyle.ForegroundEffect Property
[image]

Gets or sets the effect applied on foreground sub-elements, such as text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Effect ForegroundEffect { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundEffect As Effect

Property Value

A .NET Effect object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.HorizontalAlignment Property

CalendarStyle.HorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the sub-element containing the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new HorizontalAlignment HorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property HorizontalAlignment As HorizontalAlignment

Property Value

A member of the .NET HorizontalAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.LeftBorderBrush Property

CalendarStyle.LeftBorderBrush Property
[image]

Gets or sets the brush of the element's left border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush LeftBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LeftBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the left border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.LineBrush Property

CalendarStyle.LineBrush Property
[image]

Gets or sets a brush used to paint line sub-elements.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush LineBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LineBrush As Brush

Property Value

A .NET Brush object.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.Margin Property

CalendarStyle.Margin Property
[image]

Gets or sets the margin of the element.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new Thickness Margin { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Margin As Thickness

Property Value

A .NET Thickness object specifying the distance between the element and its container's borders.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.RightBorderBrush Property

CalendarStyle.RightBorderBrush Property
[image]

Gets or sets the brush of the element's right border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush RightBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RightBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the right border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.TextAlignment Property

CalendarStyle.TextAlignment Property
[image]

Gets or sets the alignment of the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the .NET TextAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.TopBorderBrush Property

CalendarStyle.TopBorderBrush Property
[image]

Gets or sets the brush of the element's top border.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush TopBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TopBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the top border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarStyle.VerticalAlignment Property

CalendarStyle.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the sub-element containing the displayed text.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new VerticalAlignment VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property VerticalAlignment As VerticalAlignment

Property Value

A member of the .NET VerticalAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CalendarView Enumeration

CalendarView Enumeration
[image]

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum CalendarView

Visual Basic [image] Copy Code

Public Enum CalendarView

Members

Member name | Description
List | The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row or a column (see List View).
MonthRange | The calendar displays several months in a grid. The days of each month are visible too (see Month Range View).
ResourceView | The calendar displays the distribution of items over a period of time.
SingleMonth | The calendar displays a single month at a time. The days of the month are displayed in a grid (see Single Month View).
Timetable | The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day. This view allow further division by various grouping criteria such as by contacts, locations or tasks (see Timetable View).
WeekRange | The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks (see Week Range View).

Remarks

A value of this enumeration is assigned to the CurrentView property of the Calendar class.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Class

CellPresenter Class
Remarks See Also
[image]

Defines the presentation of cells in calendar views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class CellPresenter : Control

Visual Basic [image] Copy Code

Public Class CellPresenter
Inherits Control

Remarks

This class defines the presentation of view cells within the Calendar control. For information how to define a custom template for the presenter, check Creating New Cell Template Creating New Cell TemplateCellPresenter, check the Creating New Cell Presenter.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Wpf.CellPresenter

See Also

CellPresenter Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Members

CellPresenter Members
Constructors Fields Properties Methods
[image]

Defines the presentation of cells in calendar views.

The following tables list the members exposed by the CellPresenter type.

Public Constructors

Name | Description
CellPresenter | Initializes a new instance of the CellPresenter class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
CalendarProperty | Identifies the Calendar dependency property.
CanSelectProperty | Identifies the CanSelect dependency property.
CellHeaderStyleProperty | Identifies the CellHeaderStyle dependency property.
CellMarginProperty | Identifies the CellMargin dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
HeaderTextRotationProperty | Identifies the HeaderTextRotation dependency property.
HeaderVerticalAlignmentProperty | Identifies the HeaderVerticalAlignment dependency property.
HeaderWidthProperty | Identifies the HeaderWidth dependency property.
HiddenItemsCueVisibilityProperty | Identifies the HiddenItemsCueVisibility dependency property.
IsAllDayCellProperty | Identifies the IsAllDayCell property.
IsPaddingProperty | Identifies the IsPadding dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
IsTodayCellProperty | Identifies the IsTodayCell property.
ResourceProperty | Identifies the Resource dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

Public Properties

Name | Description
Background | Gets the background of the cell in its current state. This is a dependency property.
Calendar | Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.
CanSelect | Gets or sets a value indicating whether this cell can be selected. This is a dependency property.
CellHeaderStyle | Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.
CellMargin | Gets the margin of the cell. This is a dependency property.
CellSettings | Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.
CellStyle | Gets the currently effective CalendarStyle. This is a dependency property.
EndTime | Gets the end time of the cell. This is a dependency property.
HeaderHeight | Gets the height of the cell header according to the current state. This is a dependency property.
HeaderHorizontalAlignment | Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.
HeaderText | Gets the text displayed in the cell header. This is a dependency property.
HeaderTextRotation | Gets the rotation of the header text according to the current state. This is a dependency property.
HeaderVerticalAlignment | Gets the vertical alignment of the cell header according to the current state. This is a dependency property.
HeaderWidth | Gets the width of the cell header according to the current state. This is a dependency property.
HiddenItemsCueVisibility | Gets or sets a value indicating the visibility of the hidden items icon. This is a dependency property.
IsAllDayCell | Gets or sets a value indicating whether this cell is an all-day cell.
IsPadding | Gets a value indicating whether this cell is a padding cell in a SingleMonth or MonthRange view. This is a dependency property.
IsSelected | Gets a value indicating whether this cell is selected. This is a dependency property.
IsTodayCell | Gets or sets a value indicating whether this cell is today cell.
Resource | Gets the resource (if any) the cell is associated with. This is a dependency property.
StartTime | Gets the start time of the cell. This is a dependency property.
StyleKey | Gets the string identifying the type of the underlying cell. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
OnEndTimeChanged | Invoked when the EndTime property has changed.
OnStartTimeChanged | Invoked when the StartTime property has changed.

See Also

CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Fields

CellPresenter Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
CalendarProperty | Identifies the Calendar dependency property.
CanSelectProperty | Identifies the CanSelect dependency property.
CellHeaderStyleProperty | Identifies the CellHeaderStyle dependency property.
CellMarginProperty | Identifies the CellMargin dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
HeaderTextRotationProperty | Identifies the HeaderTextRotation dependency property.
HeaderVerticalAlignmentProperty | Identifies the HeaderVerticalAlignment dependency property.
HeaderWidthProperty | Identifies the HeaderWidth dependency property.
HiddenItemsCueVisibilityProperty | Identifies the HiddenItemsCueVisibility dependency property.
IsAllDayCellProperty | Identifies the IsAllDayCell property.
IsPaddingProperty | Identifies the IsPadding dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
IsTodayCellProperty | Identifies the IsTodayCell property.
ResourceProperty | Identifies the Resource dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

See Also

CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.BackgroundProperty Field

CellPresenter.BackgroundProperty Field
[image]

Identifies the Background dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BackgroundProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CalendarProperty Field

CellPresenter.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CanSelectProperty Field

CellPresenter.CanSelectProperty Field
[image]

Identifies the CanSelect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanSelectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanSelectProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellHeaderStyleProperty Field

CellPresenter.CellHeaderStyleProperty Field
[image]

Identifies the CellHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellHeaderStyleProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellMarginProperty Field

CellPresenter.CellMarginProperty Field
[image]

Identifies the CellMargin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellMarginProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellStyleProperty Field

CellPresenter.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.EndTimeProperty Field

CellPresenter.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderHeightProperty Field

CellPresenter.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderHorizontalAlignmentProperty Field

CellPresenter.HeaderHorizontalAlignmentProperty Field
[image]

Identifies the HeaderHorizontalAlignment dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHorizontalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHorizontalAlignmentProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderTextProperty Field

CellPresenter.HeaderTextProperty Field
[image]

Identifies the HeaderText dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderTextRotationProperty Field

CellPresenter.HeaderTextRotationProperty Field
[image]

Identifies the HeaderTextRotation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextRotationProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderVerticalAlignmentProperty Field

CellPresenter.HeaderVerticalAlignmentProperty Field
[image]

Identifies the HeaderVerticalAlignment dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderVerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderVerticalAlignmentProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderWidthProperty Field

CellPresenter.HeaderWidthProperty Field
[image]

Identifies the HeaderWidth dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderWidthProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HiddenItemsCueVisibilityProperty Field

CellPresenter.HiddenItemsCueVisibilityProperty Field
[image]

Identifies the HiddenItemsCueVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HiddenItemsCueVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HiddenItemsCueVisibilityProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsAllDayCellProperty Field

CellPresenter.IsAllDayCellProperty Field
[image]

Identifies the IsAllDayCell property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAllDayCellProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsAllDayCellProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsPaddingProperty Field

CellPresenter.IsPaddingProperty Field
[image]

Identifies the IsPadding dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsPaddingProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsSelectedProperty Field

CellPresenter.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsTodayCellProperty Field

CellPresenter.IsTodayCellProperty Field
[image]

Identifies the IsTodayCell property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsTodayCellProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsTodayCellProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.ResourceProperty Field

CellPresenter.ResourceProperty Field
[image]

Identifies the Resource dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.StartTimeProperty Field

CellPresenter.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.StyleKeyProperty Field

CellPresenter.StyleKeyProperty Field
[image]

Identifies the StyleKey dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeyProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Constructor

CellPresenter Constructor
[image]

Initializes a new instance of the CellPresenter class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellPresenter (
Calendar calendar
)

Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar
The Calendar instance this CellPresenter is associated with.

See Also

CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Methods

CellPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
OnEndTimeChanged | Invoked when the EndTime property has changed.
OnStartTimeChanged | Invoked when the StartTime property has changed.

See Also

CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HitTestCore Method

CellPresenter.HitTestCore Method
[image]

UIElement.HitTestCore override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override HitTestResult HitTestCore (
PointHitTestParameters hitTestParameters
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTestCore( _
hitTestParameters As PointHitTestParameters _
) As HitTestResult

Parameters

hitTestParameters
Describes the hit test to perform, including the initial hit point.

Return Value

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.OnApplyTemplate Method

CellPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.OnEndTimeChanged Method

CellPresenter.OnEndTimeChanged Method
[image]

Invoked when the EndTime property has changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnEndTimeChanged (
DateTime oldTime,
DateTime newTime
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndTimeChanged( _
oldTime As DateTime, _
newTime As DateTime _
)

Parameters

oldTime

The previous value of EndTime.

newTime

The current value of EndTime.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.OnStartTimeChanged Method

CellPresenter.OnStartTimeChanged Method
[image]

Invoked when the StartTime property has changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnStartTimeChanged (
DateTime oldTime,
DateTime newTime
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnStartTimeChanged( _
oldTime As DateTime, _
newTime As DateTime _
)

Parameters

oldTime

The previous value of StartTime.

newTime

The current value of StartTime.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter Properties

CellPresenter Properties
[image]

Public Properties

Name | Description
Background | Gets the background of the cell in its current state. This is a dependency property.
Calendar | Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.
CanSelect | Gets or sets a value indicating whether this cell can be selected. This is a dependency property.
CellHeaderStyle | Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.
CellMargin | Gets the margin of the cell. This is a dependency property.
CellSettings | Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.
CellStyle | Gets the currently effective CalendarStyle. This is a dependency property.
EndTime | Gets the end time of the cell. This is a dependency property.
HeaderHeight | Gets the height of the cell header according to the current state. This is a dependency property.
HeaderHorizontalAlignment | Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.
HeaderText | Gets the text displayed in the cell header. This is a dependency property.
HeaderTextRotation | Gets the rotation of the header text according to the current state. This is a dependency property.
HeaderVerticalAlignment | Gets the vertical alignment of the cell header according to the current state. This is a dependency property.
HeaderWidth | Gets the width of the cell header according to the current state. This is a dependency property.
HiddenItemsCueVisibility | Gets or sets a value indicating the visibility of the hidden items icon. This is a dependency property.
IsAllDayCell | Gets or sets a value indicating whether this cell is an all-day cell.
IsPadding | Gets a value indicating whether this cell is a padding cell in a SingleMonth or MonthRange view. This is a dependency property.
IsSelected | Gets a value indicating whether this cell is selected. This is a dependency property.
IsTodayCell | Gets or sets a value indicating whether this cell is today cell.
Resource | Gets the resource (if any) the cell is associated with. This is a dependency property.
StartTime | Gets the start time of the cell. This is a dependency property.
StyleKey | Gets the string identifying the type of the underlying cell. This is a dependency property.

See Also

CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.Background Property

CellPresenter.Background Property
[image]

Gets the background of the cell in its current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new Brush Background { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property Background As Brush

Property Value

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.Calendar Property

CellPresenter.Calendar Property
[image]

Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

Remarks

This property returns the Calendar instance this CellPresenter belongs to.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CanSelect Property

CellPresenter.CanSelect Property
[image]

Gets or sets a value indicating whether this cell can be selected. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool CanSelect { get; set; }

Visual Basic [image] Copy Code

Public Property CanSelect As Boolean

Property Value

true to allow the cell to become selected; otherwise, false.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellHeaderStyle Property

CellPresenter.CellHeaderStyle Property
[image]

Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CellHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellHeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each cell is usually defined by two CalendarStyle objects, depending on the current cell state - normal or selected. This property is automatically updated to reference the cell style appropriate for the current state of the cell. Therefore bindings to this property will be automatically updated when the cell state changes.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellMargin Property

CellPresenter.CellMargin Property
[image]

Gets the margin of the cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness CellMargin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellMargin As Thickness

Property Value

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellSettings Property

CellPresenter.CellSettings Property
[image]

Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This can be null (Nothing in Visual Basic) in certain views.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.CellStyle Property

CellPresenter.CellStyle Property
[image]

Gets the currently effective CalendarStyle. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each cell is usually defined by two CalendarStyle objects, depending on the current cell state - normal or selected. This property is automatically updated to reference the cell style appropriate for the current state of the cell. Therefore bindings to this property will be automatically updated when the cell state changes.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.EndTime Property

CellPresenter.EndTime Property
[image]

Gets the end time of the cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderHeight Property

CellPresenter.HeaderHeight Property
[image]

Gets the height of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double HeaderHeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderHeight As Double

Property Value

A double value specifying the height of the cell header. This is NaN for vertical headers indicating that these headers span the entire cell.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderHorizontalAlignment Property

CellPresenter.HeaderHorizontalAlignment Property
[image]

Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public HorizontalAlignment HeaderHorizontalAlignment { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderHorizontalAlignment As HorizontalAlignment

Property Value

A .NET HorizontalAlignment value.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderText Property

CellPresenter.HeaderText Property
[image]

Gets the text displayed in the cell header. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string HeaderText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderText As String

Property Value

A string value.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderTextRotation Property

CellPresenter.HeaderTextRotation Property
[image]

Gets the rotation of the header text according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double HeaderTextRotation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderTextRotation As Double

Property Value

A double value specifying the rotation of the header text.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderVerticalAlignment Property

CellPresenter.HeaderVerticalAlignment Property
[image]

Gets the vertical alignment of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment HeaderVerticalAlignment { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderVerticalAlignment As VerticalAlignment

Property Value

A .NET VerticalAlignment value.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HeaderWidth Property

CellPresenter.HeaderWidth Property
[image]

Gets the width of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public double HeaderWidth { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderWidth As Double

Property Value

A double value specifying the width of the cell header. This is NaN for horizontal headers indicating that these headers span the entire cell.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.HiddenItemsCueVisibility Property

CellPresenter.HiddenItemsCueVisibility Property
[image]

Gets or sets a value indicating the visibility of the hidden items icon. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility HiddenItemsCueVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property HiddenItemsCueVisibility As Visibility

Property Value

A member of the Visibility enumeration.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsAllDayCell Property

CellPresenter.IsAllDayCell Property
[image]

Gets or sets a value indicating whether this cell is an all-day cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsAllDayCell { get; set; }

Visual Basic [image] Copy Code

Public Property IsAllDayCell As Boolean

Property Value

true if the cell is an all-day cell; otherwise, false.

Remarks

This property is used in timetable views to distinguish between all-day header cells and ordinary cells.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsPadding Property

CellPresenter.IsPadding Property
[image]

Gets a value indicating whether this cell is a padding cell in a SingleMonth or MonthRange view. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsPadding { get; set; }

Visual Basic [image] Copy Code

Public Property IsPadding As Boolean

Property Value

true, if this cell represents a padding day; otherwise, false.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsSelected Property

CellPresenter.IsSelected Property
[image]

Gets a value indicating whether this cell is selected. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSelected As Boolean

Property Value

A boolean value.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.IsTodayCell Property

CellPresenter.IsTodayCell Property
[image]

Gets or sets a value indicating whether this cell is today cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsTodayCell { get; set; }

Visual Basic [image] Copy Code

Public Property IsTodayCell As Boolean

Property Value

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.Resource Property

CellPresenter.Resource Property
[image]

Gets the resource (if any) the cell is associated with. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or null (Nothing in Visual Basic) if the current view is not grouped.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.StartTime Property

CellPresenter.StartTime Property
[image]

Gets the start time of the cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellPresenter.StyleKey Property

CellPresenter.StyleKey Property
[image]

Gets the string identifying the type of the underlying cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string StyleKey { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StyleKey As String

Property Value

A string value.

Remarks

The possible values are 'WithHeader', 'Simple' and 'Today'.

See Also

CellPresenter Members
CellPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings Class

CellSettings Class
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class CellSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class CellSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.CellSettings

See Also

CellSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings Members

CellSettings Members
Constructors Fields Properties
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

The following tables list the members exposed by the CellSettings type.

Public Constructors

Name | Description
CellSettings | Initializes a new instance of the CellSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FirstDayOfMonthFormatProperty | Identifies the FirstDayOfMonthFormat dependency property.
FirstDayOfYearFormatProperty | Identifies the FirstDayOfYearFormat dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
HeaderPositionProperty | Identifies the HeaderPosition dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
RotateHeaderProperty | Identifies the RotateHeader dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TodayBrushProperty | Identifies the TodayBrush dependency property.
TodayFillBrushProperty | Identifies the TodayFillBrush dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
TodayBrush | Gets or sets the color used to paint the line that marks the current cell.
TodayFillBrush | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings Fields

CellSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FirstDayOfMonthFormatProperty | Identifies the FirstDayOfMonthFormat dependency property.
FirstDayOfYearFormatProperty | Identifies the FirstDayOfYearFormat dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
HeaderPositionProperty | Identifies the HeaderPosition dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
RotateHeaderProperty | Identifies the RotateHeader dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TodayBrushProperty | Identifies the TodayBrush dependency property.
TodayFillBrushProperty | Identifies the TodayFillBrush dependency property.

See Also

CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.CalendarStyleProperty Field

CellSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.FirstDayOfMonthFormatProperty Field

CellSettings.FirstDayOfMonthFormatProperty Field
[image]

Identifies the FirstDayOfMonthFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FirstDayOfMonthFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FirstDayOfMonthFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.FirstDayOfYearFormatProperty Field

CellSettings.FirstDayOfYearFormatProperty Field
[image]

Identifies the FirstDayOfYearFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FirstDayOfYearFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FirstDayOfYearFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.GeneralFormatProperty Field

CellSettings.GeneralFormatProperty Field
[image]

Identifies the GeneralFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GeneralFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GeneralFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.HeaderPositionProperty Field

CellSettings.HeaderPositionProperty Field
[image]

Identifies the HeaderPosition dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderPositionProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.HeaderSizeProperty Field

CellSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.HeaderStyleProperty Field

CellSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.RotateHeaderProperty Field

CellSettings.RotateHeaderProperty Field
[image]

Identifies the RotateHeader dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.ShowTodayProperty Field

CellSettings.ShowTodayProperty Field
[image]

Identifies the ShowToday dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTodayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTodayProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.TodayBrushProperty Field

CellSettings.TodayBrushProperty Field
[image]

Identifies the TodayBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TodayBrushProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.TodayFillBrushProperty Field

CellSettings.TodayFillBrushProperty Field
[image]

Identifies the TodayFillBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayFillBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TodayFillBrushProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings Constructor

CellSettings Constructor
[image]

Initializes a new instance of the CellSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings Properties

CellSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
TodayBrush | Gets or sets the color used to paint the line that marks the current cell.
TodayFillBrush | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.CellSettings.CalendarStyle Property

CellSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.CellSettings.FirstDayOfMonthFormat Property

CellSettings.FirstDayOfMonthFormat Property
[image]

Gets or sets the string used to format and display the first day of each month in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string FirstDayOfMonthFormat { get; set; }

Visual Basic [image] Copy Code

Public Property FirstDayOfMonthFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
GeneralFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.Wpf.CellSettings.FirstDayOfYearFormat Property

CellSettings.FirstDayOfYearFormat Property
[image]

Gets or sets the string used to format and display the first day of each year in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string FirstDayOfYearFormat { get; set; }

Visual Basic [image] Copy Code

Public Property FirstDayOfYearFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
GeneralFormat Property
FirstDayOfMonthFormat Property


MindFusion.Scheduling.Wpf.CellSettings.GeneralFormat Property

CellSettings.GeneralFormat Property
[image]

Gets or sets the string used to format and display dates and times in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }

Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
FirstDayOfMonthFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.Wpf.CellSettings.HeaderPosition Property

CellSettings.HeaderPosition Property
[image]

Gets or sets the position of the cell header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Position HeaderPosition { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderPosition As Position

Property Value

A member of the Position enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderSize Property
RotateHeader Property


MindFusion.Scheduling.Wpf.CellSettings.HeaderSize Property

CellSettings.HeaderSize Property
[image]

Gets or sets the size of the cell header in pixels.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the height of the header if HeaderPosition is set to either Top or Bottom, or the width of the header if HeaderPosition is set to Left or Right.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderPosition Property


MindFusion.Scheduling.Wpf.CellSettings.HeaderStyle Property

CellSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.CellSettings.RotateHeader Property

CellSettings.RotateHeader Property
[image]

Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateHeader { get; set; }

Visual Basic [image] Copy Code

Public Property RotateHeader As Boolean

Property Value

true to rotate header text, otherwise false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderPosition Property


MindFusion.Scheduling.Wpf.CellSettings.ShowToday Property

CellSettings.ShowToday Property
[image]

Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowToday { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToday As Boolean

Property Value

true to indicate visually the current day; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
TodayBrush Property
TodayFillBrush Property


MindFusion.Scheduling.Wpf.CellSettings.TodayBrush Property

CellSettings.TodayBrush Property
[image]

Gets or sets the color used to paint the line that marks the current cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush TodayBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TodayBrush As Brush

Property Value

A .NET Brush object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
TodayFillBrush Property
ShowToday Property


MindFusion.Scheduling.Wpf.CellSettings.TodayFillBrush Property

CellSettings.TodayFillBrush Property
[image]

Gets or sets the color used to fill the header of the current cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush TodayFillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TodayFillBrush As Brush

Property Value

A .NET Brush object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Wpf Namespace
TodayBrush Property
ShowToday Property


MindFusion.Scheduling.Wpf.DateChangedEventArgs Class

DateChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class DateChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Wpf.DateChangedEventArgs

See Also

DateChangedEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateChangedEventArgs Members

DateChangedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the VisibleDateChanged event.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateChangedEventArgs Properties

DateChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property
[image]

Gets the new visible date.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime NewDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewDate As DateTime

Property Value

A .NET DateTime object specifying the new date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property
[image]

Gets the previous visible date.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime PreviousDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PreviousDate As DateTime

Property Value

A .NET DateTime object specifying the previous date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateCollection Class

DateCollection Class
[image]

Represents a strongly-typed sorted collection of DateTime objects.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class DateCollection : ObservableCollection<DateTime>

Visual Basic [image] Copy Code

Public NotInheritable Class DateCollection
Inherits ObservableCollection(Of DateTime)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(DateTime)
System.Collections.ObjectModel.ObservableCollection(DateTime)
MindFusion.Scheduling.Wpf.DateCollection

See Also

DateCollection Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateCollection Members

DateCollection Members
Constructors Methods
[image]

Represents a strongly-typed sorted collection of DateTime objects.

The following tables list the members exposed by the DateCollection type.

Public Constructors

Name | Description
DateCollection | Initializes a new instance of the DateCollection class.

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<DateTime>.OnCollectionChanged override.

See Also

DateCollection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateCollection Constructor

DateCollection Constructor
[image]

Initializes a new instance of the DateCollection class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DateCollection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateCollection Methods

DateCollection Methods
[image]

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<DateTime>.OnCollectionChanged override.

See Also

DateCollection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateCollection.OnCollectionChanged Method

DateCollection.OnCollectionChanged Method
[image]

ObservableCollection<DateTime>.OnCollectionChanged override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Arguments of the event being raised.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs Class

DateEventArgs Class
[image]

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class DateEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DateEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Wpf.DateEventArgs
MindFusion.Scheduling.Wpf.ResourceDateEventArgs

See Also

DateEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs Members

DateEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

The following tables list the members exposed by the DateEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounds of the cell.
Clicks | Gets the number of clicks.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.
LeftButton | Gets a value indicating the state of the left mouse button.
MiddleButton | Gets a value indicating the state of the middle mouse button.
RightButton | Gets a value indicating the state of the right mouse button.

See Also

DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs Properties

DateEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounds of the cell.
Clicks | Gets the number of clicks.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.
LeftButton | Gets a value indicating the state of the left mouse button.
MiddleButton | Gets a value indicating the state of the middle mouse button.
RightButton | Gets a value indicating the state of the right mouse button.

See Also

DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs.Bounds Property

DateEventArgs.Bounds Property
[image]

Gets the bounds of the cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A .NET Rect object specifying the bounds of the cell related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs.Clicks Property

DateEventArgs.Clicks Property
[image]

Gets the number of clicks.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Clicks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Clicks As Integer

Property Value

An integer value specifying the number of clicks related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs.Date Property

DateEventArgs.Date Property
[image]

Gets the date and time associated with the event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime Date { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Date As DateTime

Property Value

A .NET DateTime object specifying the date related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs.Index Property

DateEventArgs.Index Property
[image]

Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the index of the related cell or -1 if no index is applicable to the selected cell.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.DateEventArgs.LeftButton Property

DateEventArgs.LeftButton Property
[image]

Gets a value indicating the state of the left mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState LeftButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LeftButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration specifying the state of the left mouse button.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace
MiddleButton Property
RightButton Property


MindFusion.Scheduling.Wpf.DateEventArgs.MiddleButton Property

DateEventArgs.MiddleButton Property
[image]

Gets a value indicating the state of the middle mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState MiddleButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MiddleButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration specifying the state of the middle mouse button.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace
LeftButton Property
RightButton Property


MindFusion.Scheduling.Wpf.DateEventArgs.RightButton Property

DateEventArgs.RightButton Property
[image]

Gets a value indicating the state of the right mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState RightButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RightButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration specifying the state of the right mouse button.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Wpf Namespace
LeftButton Property
MiddleButton Property


MindFusion.Scheduling.Wpf.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration
[image]

Specifies the display format of a day of the week.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum DayOfWeekFormat

Visual Basic [image] Copy Code

Public Enum DayOfWeekFormat

Members

Member name | Description
Abbreviated | The first three letters of the day of the week are displayed.
Full | The complete name of the day of the week is displayed.
SingleLetter | Only the first letter of the name of the day is displayed.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Class

ExpanderControl Class
[image]

Represents a simple expander control.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ExpanderControl : Control

Visual Basic [image] Copy Code

Public Class ExpanderControl
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Wpf.ExpanderControl

See Also

ExpanderControl Members

MindFusion.Scheduling.Silverlight Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Members

ExpanderControl Members
Constructors Fields Properties Methods Events
[image]

Represents a simple expander control.

The following tables list the members exposed by the ExpanderControl type.

Public Constructors

Name | Description
ExpanderControl | Initializes a new instance of the ExpanderControl class.

Public Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded dependency property.

Public Properties

Name | Description
IsExpanded | Gets or sets a value indicating whether the expander is expanded. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.

Public Events

Name | Description
Expanded | Raised when the control is expanded or collapsed, either programmatically or interactively.

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Fields

ExpanderControl Fields
[image]

Public Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl.IsExpandedProperty Field

ExpanderControl.IsExpandedProperty Field
[image]

Identifies the IsExpanded dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

ExpanderControl Members
ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Constructor

ExpanderControl Constructor
[image]

Initializes a new instance of the ExpanderControl class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ExpanderControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Methods

ExpanderControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl.OnApplyTemplate Method

ExpanderControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ExpanderControl Members
ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl.OnMouseLeftButtonDown Method

ExpanderControl.OnMouseLeftButtonDown Method
[image]

Control.OnMouseLeftButtonDown override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The data for the event.

See Also

ExpanderControl Members
ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Properties

ExpanderControl Properties
[image]

Public Properties

Name | Description
IsExpanded | Gets or sets a value indicating whether the expander is expanded. This is a dependency property.

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl.IsExpanded Property

ExpanderControl.IsExpanded Property
[image]

Gets or sets a value indicating whether the expander is expanded. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Public Property IsExpanded As Boolean

Property Value

true if the expander is expanded; otherwise, false.

See Also

ExpanderControl Members
ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl Events

ExpanderControl Events
[image]

Public Events

Name | Description
Expanded | Raised when the control is expanded or collapsed, either programmatically or interactively.

See Also

ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ExpanderControl.Expanded Event

ExpanderControl.Expanded Event
[image]

Raised when the control is expanded or collapsed, either programmatically or interactively.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Expanded

Visual Basic [image] Copy Code

Public Event Expanded As EventHandler

Event Data

Expanded event handlers receive an argument of type EventArgs.

See Also

ExpanderControl Members
ExpanderControl Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.GroupType Enumeration

GroupType Enumeration
[image]

Specifies grouping or filtering criteria for views that support grouping.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum GroupType

Visual Basic [image] Copy Code

Public Enum GroupType

Members

Member name | Description
FilterByContacts | Filter by contacts.
FilterByLocations | Filter by locations.
FilterByResources | Filter by resources.
FilterByTasks | Filter by tasks.
GroupByContacts | Group by contacts.
GroupByLocations | Group by locations.
GroupByResources | Group by resources.
GroupByTasks | Group by tasks.
None | No grouping or filtering.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemAction Enumeration

ItemAction Enumeration
[image]

Specifies a user action on a schedule item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum ItemAction

Visual Basic [image] Copy Code

Public Enum ItemAction

Members

Member name | Description
Move | Indicates that the item is being moved.
None | Indicates no action.
ResizeEnd | Indicates that the item's end is being modified.
ResizeStart | Indicates that the item's start is being modified.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemConfirmEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemConfirmEventArgs
MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs
MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs

See Also

ItemConfirmEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

Set Confirm to false to prevent the action or to true to allow it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs Class

ItemEditConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemEditConfirmEventArgs : ItemConfirmEventArgs

Visual Basic [image] Copy Code

Public Class ItemEditConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemConfirmEventArgs
MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs

See Also

ItemEditConfirmEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs Members

ItemEditConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

The following tables list the members exposed by the ItemEditConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs Properties

ItemEditConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemEditConfirmEventArgs.NewText Property

ItemEditConfirmEventArgs.NewText Property
[image]

Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string containing the new text of the item.

See Also

ItemEditConfirmEventArgs Members
ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModified event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemModifiedEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemModifiedEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemModifiedEventArgs

See Also

ItemModifiedEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs Properties

ItemModifiedEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs.OldEndTime Property

ItemModifiedEventArgs.OldEndTime Property
[image]

Gets the old end time of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime OldEndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldEndTime As DateTime

Property Value

A .NET DateTime value representing the original end time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs.OldResources Property

ItemModifiedEventArgs.OldResources Property
[image]

Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public List<Resource> OldResources { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldResources As List(Of Resource)

Property Value

A collection of resources originally associated with the item.

Remarks

The returned collection might contain Contact, Location, Task or Resource objects depending on the current grouping type.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs.OldStartTime Property

ItemModifiedEventArgs.OldStartTime Property
[image]

Gets the old start time of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime OldStartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldStartTime As DateTime

Property Value

A .NET DateTime value representing the original start time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs.ResizeEnd Property

ItemModifiedEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end has been modified.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end has been modified; false if item was moved or its start has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifiedEventArgs.ResizeStart Property

ItemModifiedEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start has been modified.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start has been modified; false if item was moved or its end has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs Class

ItemModifyConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModifying event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemModifyConfirmEventArgs : ItemConfirmEventArgs

Visual Basic [image] Copy Code

Public Class ItemModifyConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemConfirmEventArgs
MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs

See Also

ItemModifyConfirmEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs Members

ItemModifyConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemModifying event.

The following tables list the members exposed by the ItemModifyConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
OldEndTime | Gets or sets the old end time of the item.
OldListLane | Gets or sets the index of the old list lane of the item.
OldResources | Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.
OldStartTime | Gets or sets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs Properties

ItemModifyConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
OldEndTime | Gets or sets the old end time of the item.
OldListLane | Gets or sets the index of the old list lane of the item.
OldResources | Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.
OldStartTime | Gets or sets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.OldEndTime Property

ItemModifyConfirmEventArgs.OldEndTime Property
[image]

Gets or sets the old end time of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime OldEndTime { get; set; }

Visual Basic [image] Copy Code

Public Property OldEndTime As DateTime

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.OldListLane Property

ItemModifyConfirmEventArgs.OldListLane Property
[image]

Gets or sets the index of the old list lane of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int OldListLane { get; set; }

Visual Basic [image] Copy Code

Public Property OldListLane As Integer

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.OldResources Property

ItemModifyConfirmEventArgs.OldResources Property
[image]

Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public List<Resource> OldResources { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldResources As List(Of Resource)

Property Value

Remarks

This value can be null, if the item doesn't change associated resource.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.OldStartTime Property

ItemModifyConfirmEventArgs.OldStartTime Property
[image]

Gets or sets the old start time of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime OldStartTime { get; set; }

Visual Basic [image] Copy Code

Public Property OldStartTime As DateTime

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.ResizeEnd Property

ItemModifyConfirmEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end is being modified.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end is being modified; false if item is moved or its start is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemModifyConfirmEventArgs.ResizeStart Property

ItemModifyConfirmEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start is being modified.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start is being modified; false if item is moved or its end is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs Class

ItemMouseEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemClick event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemMouseEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemMouseEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemMouseEventArgs

See Also

ItemMouseEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs Members

ItemMouseEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemClick event.

The following tables list the members exposed by the ItemMouseEventArgs type.

Public Properties

Name | Description
Clicks | Gets the number of clicks.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
LeftButton | Gets a value indicating the state of the left mouse button.
MiddleButton | Gets a value indicating the state of the middle mouse button.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
RightButton | Gets a value indicating the state of the right mouse button.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs Properties

ItemMouseEventArgs Properties
[image]

Public Properties

Name | Description
Clicks | Gets the number of clicks.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)
LeftButton | Gets a value indicating the state of the left mouse button.
MiddleButton | Gets a value indicating the state of the middle mouse button.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
RightButton | Gets a value indicating the state of the right mouse button.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.Clicks Property

ItemMouseEventArgs.Clicks Property
[image]

Gets the number of clicks.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Clicks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Clicks As Integer

Property Value

An integer value specifying the number of mouse clicks related to the raised event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.LeftButton Property

ItemMouseEventArgs.LeftButton Property
[image]

Gets a value indicating the state of the left mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState LeftButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LeftButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.MiddleButton Property

ItemMouseEventArgs.MiddleButton Property
[image]

Gets a value indicating the state of the middle mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState MiddleButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MiddleButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.ResizeEnd Property

ItemMouseEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end is about to be resized.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

A Boolean value indicating whether the item's end is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.ResizeStart Property

ItemMouseEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start is about to be resized.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

A Boolean value indicating whether the item's start is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.RightButton Property

ItemMouseEventArgs.RightButton Property
[image]

Gets a value indicating the state of the right mouse button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MouseButtonState RightButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RightButton As MouseButtonState

Property Value

A member of the .NET MouseButtonState enumeration.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.X Property

ItemMouseEventArgs.X Property
[image]

Gets the x-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int X { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property X As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace
Y Property


MindFusion.Scheduling.Wpf.ItemMouseEventArgs.Y Property

ItemMouseEventArgs.Y Property
[image]

Gets the y-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Y { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Y As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Wpf Namespace
X Property


MindFusion.Scheduling.Wpf.ItemPresenter Class

ItemPresenter Class
Remarks See Also
[image]

Defines the base class of custom item presenter classes.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemPresenter : Control, IWeakEventListener

Visual Basic [image] Copy Code

Public Class ItemPresenter
Inherits Control
Implements IWeakEventListener

Remarks

This class defines the presentation of an Item within the Calendar control. You can think of this class as a mediator between the data (Item) and the presentation layer (Calendar). For information how to define a custom template for the presenter, check Creating New Item Template Creating New Item TemplateItemPresenter, check the Creating New Item Presenter.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Wpf.ItemPresenter

See Also

ItemPresenter Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter Members

ItemPresenter Members
Constructors Fields Properties Methods
[image]

Defines the base class of custom item presenter classes.

The following tables list the members exposed by the ItemPresenter type.

Public Constructors

Name | Description
ItemPresenter | Initializes a new instance of the ItemPresenter class.

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
EndArrowImageVisibilityProperty | Identifies the EndArrowImageVisibility dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderTextMarginProperty | Identifies the HeaderTextMargin dependency property.
ItemProperty | Identifies the Item dependency dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemStyleProperty | Identifies the ItemStyle dependency property.
MoveBandMarginProperty | Identifies the MoveBandMargin dependency property.
MoveBandVisibilityProperty | Identifies the MoveBandVisibility dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RecurrenceExceptionIconVisibilityProperty | Identifies the RecurrenceExceptionIconVisibility dependency property.
RecurrenceIconVisibilityProperty | Identifies the RecurrenceIconVisibility dependency property.
ReminderIconVisibilityProperty | Identifies the ReminderIconVisibility dependency property.
SelectedProperty | Identifies the Selected dependency property.
StartArrowImageVisibilityProperty | Identifies the StartArrowImageVisibility dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar object this presenter is associated with.
EndArrowImageVisibility | Gets a value indicating whether the end continuation arrow should be visible.
EndTime | Gets the end time of the item fragment represented by the presenter. This is a dependency property.
HeaderTextMargin | Gets the margin of the item's header text. This is a dependency property.
Item | Gets the Item associated with this presenter.
ItemSettings | Gets a reference to the Calendar.ItemSettings object.
ItemStyle | Gets the currently effective CalendarStyle.
MoveBandMargin | Gets the margins of the item's move band. This is a dependency property.
MoveBandVisibility | Gets or sets a value indicating whether the move band is visible. This is a dependency property.
Orientation | Gets the orientation of the associated item.
RecurrenceExceptionIconVisibility | Gets a value indicating whether the recurrence exception icon should be displayed.
RecurrenceIconVisibility | Gets a value indicating whether the recurrence icon should be displayed.
ReminderIconVisibility | Gets a value indicating whether the reminder icon should be displayed.
Selected | Gets a value indicating whether the underlying item is selected.
StartArrowImageVisibility | Gets a value indicating whether the start continuation arrow should be visible.
StartTime | Gets the start time of the item fragment represented by the presenter. This is a dependency property.
StyleKey | Gets the string identifying the type of the underlying item.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
OnEndTimeChanged | Called when the EndTime property is changed.
OnItemChanged | Called when the Item property is changed.
OnItemPropertyChanged | Called when the property of the associated item has changed.
OnOrientationChanged | Called when the value of the Orientation property changes.
OnStartTimeChanged | Called when the StartTime property is changed.

See Also

ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter Fields

ItemPresenter Fields
[image]

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
EndArrowImageVisibilityProperty | Identifies the EndArrowImageVisibility dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderTextMarginProperty | Identifies the HeaderTextMargin dependency property.
ItemProperty | Identifies the Item dependency dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemStyleProperty | Identifies the ItemStyle dependency property.
MoveBandMarginProperty | Identifies the MoveBandMargin dependency property.
MoveBandVisibilityProperty | Identifies the MoveBandVisibility dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RecurrenceExceptionIconVisibilityProperty | Identifies the RecurrenceExceptionIconVisibility dependency property.
RecurrenceIconVisibilityProperty | Identifies the RecurrenceIconVisibility dependency property.
ReminderIconVisibilityProperty | Identifies the ReminderIconVisibility dependency property.
SelectedProperty | Identifies the Selected dependency property.
StartArrowImageVisibilityProperty | Identifies the StartArrowImageVisibility dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

See Also

ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.CalendarProperty Field

ItemPresenter.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.EndArrowImageVisibilityProperty Field

ItemPresenter.EndArrowImageVisibilityProperty Field
[image]

Identifies the EndArrowImageVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndArrowImageVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndArrowImageVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.EndTimeProperty Field

ItemPresenter.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.HeaderTextMarginProperty Field

ItemPresenter.HeaderTextMarginProperty Field
[image]

Identifies the HeaderTextMargin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextMarginProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ItemProperty Field

ItemPresenter.ItemProperty Field
[image]

Identifies the Item dependency dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ItemSettingsProperty Field

ItemPresenter.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ItemStyleProperty Field

ItemPresenter.ItemStyleProperty Field
[image]

Identifies the ItemStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemStyleProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.MoveBandMarginProperty Field

ItemPresenter.MoveBandMarginProperty Field
[image]

Identifies the MoveBandMargin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandMarginProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.MoveBandVisibilityProperty Field

ItemPresenter.MoveBandVisibilityProperty Field
[image]

Identifies the MoveBandVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OrientationProperty Field

ItemPresenter.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.RecurrenceExceptionIconVisibilityProperty Field

ItemPresenter.RecurrenceExceptionIconVisibilityProperty Field
See Also
[image]

Identifies the RecurrenceExceptionIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RecurrenceExceptionIconVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RecurrenceExceptionIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.RecurrenceIconVisibilityProperty Field

ItemPresenter.RecurrenceIconVisibilityProperty Field
[image]

Identifies the RecurrenceIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RecurrenceIconVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RecurrenceIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ReminderIconVisibilityProperty Field

ItemPresenter.ReminderIconVisibilityProperty Field
[image]

Identifies the ReminderIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ReminderIconVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ReminderIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.SelectedProperty Field

ItemPresenter.SelectedProperty Field
[image]

Identifies the Selected dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.StartArrowImageVisibilityProperty Field

ItemPresenter.StartArrowImageVisibilityProperty Field
[image]

Identifies the StartArrowImageVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartArrowImageVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartArrowImageVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.StartTimeProperty Field

ItemPresenter.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.StyleKeyProperty Field

ItemPresenter.StyleKeyProperty Field
[image]

Identifies the StyleKey dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeyProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter Constructor

ItemPresenter Constructor
[image]

Initializes a new instance of the ItemPresenter class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemPresenter (
Calendar calendar
)

Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar
The Calendar instance this ItemPresenter is associated with.

Remarks

When creating a custom ItemPresenter, make sure to provide a constructor with single argument of type Calendar. Otherwise your class will fail to load.

Example

The following code illustrates a common way to derive from ItemPresenter:

C# [image] Copy Code
public class MyAppointmentPresenter : ItemPresenter
{
public MyAppointmentPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyAppointmentPresenter);
}

// ...
}
Visual Basic [image] Copy Code

Public Class MyAppointmentPresenter
Inherits ItemPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.new(calendar)

Me.DefaultStyleKey = GetType(MyAppointmentPresenter)

End Sub

End Class

See Also

ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter Methods

ItemPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
HitTestCore | UIElement.HitTestCore override.
OnEndTimeChanged | Called when the EndTime property is changed.
OnItemChanged | Called when the Item property is changed.
OnItemPropertyChanged | Called when the property of the associated item has changed.
OnOrientationChanged | Called when the value of the Orientation property changes.
OnStartTimeChanged | Called when the StartTime property is changed.

See Also

ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.HitTestCore Method

ItemPresenter.HitTestCore Method
[image]

UIElement.HitTestCore override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override HitTestResult HitTestCore (
PointHitTestParameters hitTestParameters
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTestCore( _
hitTestParameters As PointHitTestParameters _
) As HitTestResult

Parameters

hitTestParameters
Describes the hit test to perform, including the initial hit point.

Return Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnApplyTemplate Method

ItemPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

You can override this method in an ItemPresenter-derived class for various purposes, as described in the FrameworkElement.OnApplyTemplate [image] MSDN topic. The most common scenario includes obtaining a reference to a named element within the template, in order to attach an event handler for example. Make sure you always invoke the base' implementation of this method.

Check the CustomItemPresenter sample for an example on what you can do in this method.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnEndTimeChanged Method

ItemPresenter.OnEndTimeChanged Method
[image]

Called when the EndTime property is changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnEndTimeChanged (
DateTime oldValue,
DateTime newValue
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndTimeChanged( _
oldValue As DateTime, _
newValue As DateTime _
)

Parameters

oldValue

The previous end time of the presenter.

newValue

The new end time of the presenter.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnItemChanged Method

ItemPresenter.OnItemChanged Method
[image]

Called when the Item property is changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemChanged (
Item oldItem,
Item newItem
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemChanged( _
oldItem As Item, _
newItem As Item _
)

Parameters

oldItem

The previous item associated with the presenter.

newItem

The new item associated with the presenter.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnItemPropertyChanged Method

ItemPresenter.OnItemPropertyChanged Method
[image]

Called when the property of the associated item has changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

The name of the changed property.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnOrientationChanged Method

ItemPresenter.OnOrientationChanged Method
[image]

Called when the value of the Orientation property changes.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnOrientationChanged (
Orientation oldOrientation,
Orientation newOrientation
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnOrientationChanged( _
oldOrientation As Orientation, _
newOrientation As Orientation _
)

Parameters

oldOrientation

The old value of the Orientation property.

newOrientation

The new value of the Orientation property.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.OnStartTimeChanged Method

ItemPresenter.OnStartTimeChanged Method
[image]

Called when the StartTime property is changed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnStartTimeChanged (
DateTime oldValue,
DateTime newValue
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnStartTimeChanged( _
oldValue As DateTime, _
newValue As DateTime _
)

Parameters

oldValue

The previous start time of the presenter.

newValue

The new start time of the presenter.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter Properties

ItemPresenter Properties
[image]

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar object this presenter is associated with.
EndArrowImageVisibility | Gets a value indicating whether the end continuation arrow should be visible.
EndTime | Gets the end time of the item fragment represented by the presenter. This is a dependency property.
HeaderTextMargin | Gets the margin of the item's header text. This is a dependency property.
Item | Gets the Item associated with this presenter.
ItemSettings | Gets a reference to the Calendar.ItemSettings object.
ItemStyle | Gets the currently effective CalendarStyle.
MoveBandMargin | Gets the margins of the item's move band. This is a dependency property.
MoveBandVisibility | Gets or sets a value indicating whether the move band is visible. This is a dependency property.
Orientation | Gets the orientation of the associated item.
RecurrenceExceptionIconVisibility | Gets a value indicating whether the recurrence exception icon should be displayed.
RecurrenceIconVisibility | Gets a value indicating whether the recurrence icon should be displayed.
ReminderIconVisibility | Gets a value indicating whether the reminder icon should be displayed.
Selected | Gets a value indicating whether the underlying item is selected.
StartArrowImageVisibility | Gets a value indicating whether the start continuation arrow should be visible.
StartTime | Gets the start time of the item fragment represented by the presenter. This is a dependency property.
StyleKey | Gets the string identifying the type of the underlying item.

See Also

ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.Calendar Property

ItemPresenter.Calendar Property
[image]

Gets a reference to the Calendar object this presenter is associated with.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

Remarks

This property returns the Calendar instance this ItemPresenter belongs to.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.EndArrowImageVisibility Property

ItemPresenter.EndArrowImageVisibility Property
[image]

Gets a value indicating whether the end continuation arrow should be visible.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility EndArrowImageVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndArrowImageVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the end arrow should be visible. The end arrow is displayed when a simple item is wrapped across two or more lines.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace
StartArrowImageVisibility Property


MindFusion.Scheduling.Wpf.ItemPresenter.EndTime Property

ItemPresenter.EndTime Property
[image]

Gets the end time of the item fragment represented by the presenter. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.HeaderTextMargin Property

ItemPresenter.HeaderTextMargin Property
[image]

Gets the margin of the item's header text. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderTextMargin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderTextMargin As Thickness

Property Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.Item Property

ItemPresenter.Item Property
[image]

Gets the Item associated with this presenter.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

Remarks

This property returns the Item instance this ItemPresenter is associated with. It is possible that more than one presenters is associated with the same item, such as when an item is wrapped across several lines.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ItemSettings Property

ItemPresenter.ItemSettings Property
[image]

Gets a reference to the Calendar.ItemSettings object.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

Remarks

This is a convenience property enabling item templates to bind to ItemSettings properties directly.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.ItemStyle Property

ItemPresenter.ItemStyle Property
[image]

Gets the currently effective CalendarStyle.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle ItemStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each item is defined by four CalendarStyle objects, depending on the current item state - normal, selected, hovered and hovered and selected at the same time. This property is automatically updated to reference the item style appropriate for the current state of the item. Therefore bindings to this property will be automatically updated when the item state changes.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.MoveBandMargin Property

ItemPresenter.MoveBandMargin Property
[image]

Gets the margins of the item's move band. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness MoveBandMargin { get; set; }

Visual Basic [image] Copy Code

Public Property MoveBandMargin As Thickness

Property Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.MoveBandVisibility Property

ItemPresenter.MoveBandVisibility Property
[image]

Gets or sets a value indicating whether the move band is visible. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility MoveBandVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property MoveBandVisibility As Visibility

Property Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.Orientation Property

ItemPresenter.Orientation Property
[image]

Gets the orientation of the associated item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Items are displayed in either vertical or horizontal orientation depending on the current view and the current view settings. In SingleMonth, MonthRange, WeekRange and Resource views items are always displayed in horizontal orientation. In List view the item's orientation depends on the value of the ItemOrientation property. In Timetable view all day items have horizontal orientation and non-all day items have vertical orientation.

The value of this property is automatically updated to reflect the current orientation of the underlying item.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.RecurrenceExceptionIconVisibility Property

ItemPresenter.RecurrenceExceptionIconVisibility Property
[image]

Gets a value indicating whether the recurrence exception icon should be displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility RecurrenceExceptionIconVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceExceptionIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the recurrence exception should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/RecurrenceEx.png" Visibility="{Binding RecurrenceExceptionIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace
RecurrenceIconVisibility Property
ReminderIconVisibilityÂ Property


MindFusion.Scheduling.Wpf.ItemPresenter.RecurrenceIconVisibility Property

ItemPresenter.RecurrenceIconVisibility Property
[image]

Gets a value indicating whether the recurrence icon should be displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility RecurrenceIconVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the recurrence should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Recurrence.png" Visibility="{Binding RecurrenceIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace
RecurrenceExceptionIconVisibility Property
ReminderIconVisibility Property


MindFusion.Scheduling.Wpf.ItemPresenter.ReminderIconVisibility Property

ItemPresenter.ReminderIconVisibility Property
[image]

Gets a value indicating whether the reminder icon should be displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility ReminderIconVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ReminderIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the reminder should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Wpf;component/Resources/Reminder.png" Visibility="{Binding ReminderIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace
RecurrenceExceptionIconVisibility Property
RecurrenceIconVisibility Property


MindFusion.Scheduling.Wpf.ItemPresenter.Selected Property

ItemPresenter.Selected Property
[image]

Gets a value indicating whether the underlying item is selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Selected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selected As Boolean

Property Value

A bool value indicating the selection state of the item.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.StartArrowImageVisibility Property

ItemPresenter.StartArrowImageVisibility Property
[image]

Gets a value indicating whether the start continuation arrow should be visible.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility StartArrowImageVisibility { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartArrowImageVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the start arrow should be visible. The start arrow is displayed when a simple item is wrapped across two or more lines.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace
EndArrowImageVisibility Property


MindFusion.Scheduling.Wpf.ItemPresenter.StartTime Property

ItemPresenter.StartTime Property
[image]

Gets the start time of the item fragment represented by the presenter. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenter.StyleKey Property

ItemPresenter.StyleKey Property
[image]

Gets the string identifying the type of the underlying item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string StyleKey { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StyleKey As String

Property Value

A string value indicating the current type of the item.

Remarks

There are two types of item presentations depending on the current view and the all day state of the item. Items in SingleMonth, MonthRange, List, WeekRange and the all day items in the Timetable view are considered simple. The value of this property for those items is "Simple". Timetable and Resource view items are considered complex. The value of the property for them is "Complex".

The value of this property is checked using triggers to determine which control template to use for the item.

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenterAttribute Class

ItemPresenterAttribute Class
[image]

Associates a custom item presenter with a schedule item class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemPresenterAttribute : Attribute

Visual Basic [image] Copy Code

Public Class ItemPresenterAttribute
Inherits Attribute

Example

The following example illustrates how to associate a custom ItemPresenter class with a custom Appointment class. The example assumes that the custom ItemPresenter class is already defined and is named MyItemPresenter.

C# [image] Copy Code
[ItemPresenter(typeof(MyAppointmentPresenter))]
public class MyAppointment : Appointment
{
// ...
}
Visual Basic [image] Copy Code
<ItemPresenter(GetType(MyAppointmentPresenter))> _
Public Class MyAppointment
Inherits Appointment

' ...

End Class

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.Scheduling.Wpf.ItemPresenterAttribute

See Also

ItemPresenterAttribute Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenterAttribute Members

ItemPresenterAttribute Members
Constructors Properties
[image]

Associates a custom item presenter with a schedule item class.

The following tables list the members exposed by the ItemPresenterAttribute type.

Public Constructors

Name | Description
ItemPresenterAttribute | Initializes a new instance of the ItemPresenterAttribute class.

Public Properties

Name | Description
PresenterType | Gets the Type of the custom ItemPresenter.

See Also

ItemPresenterAttribute Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenterAttribute Constructor

ItemPresenterAttribute Constructor
[image]

Initializes a new instance of the ItemPresenterAttribute class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemPresenterAttribute (
Type presenterType
)

Visual Basic [image] Copy Code

Public New ( _
presenterType As Type _
)

Parameters

presenterType
An instance of the .NET Type class specifying the custom presenter class.

See Also

ItemPresenterAttribute Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenterAttribute Properties

ItemPresenterAttribute Properties
[image]

Public Properties

Name | Description
PresenterType | Gets the Type of the custom ItemPresenter.

See Also

ItemPresenterAttribute Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemPresenterAttribute.PresenterType Property

ItemPresenterAttribute.PresenterType Property
[image]

Gets the Type of the custom ItemPresenter.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Type PresenterType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PresenterType As Type

Property Value

An instance of the .NET Type class.

Remarks

The custom presenter class must derive from ItemPresenter.

See Also

ItemPresenterAttribute Members
ItemPresenterAttribute Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection Class

ItemSelection Class
[image]

An instance of this class represents a set of selected schedule items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class ItemSelection

Visual Basic [image] Copy Code

Public NotInheritable Class ItemSelection

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Wpf.ItemSelection

See Also

ItemSelection Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection Members

ItemSelection Members
Properties Methods
[image]

An instance of this class represents a set of selected schedule items.

The following tables list the members exposed by the ItemSelection type.

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection Methods

ItemSelection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Add Method

ItemSelection.Add Method
[image]

Adds the specified item to the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Add (
Item item
)

Visual Basic [image] Copy Code

Public Sub Add ( _
item As Item _
)

Parameters

item
The Item instance to be added to the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Clear Method

ItemSelection.Clear Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Contains Method

ItemSelection.Contains Method
[image]

Determines whether the specified item is currently selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
Item item
)

Visual Basic [image] Copy Code

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The Item instance to search for in the selection.

Return Value

true if the item is selected or false if it isn't.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Remove Method

ItemSelection.Remove Method
[image]

Removes the specified item from the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Item item
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
item As Item _
)

Parameters

item
The Item instance to be removed from the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection Properties

ItemSelection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

See Also

ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Count Property

ItemSelection.Count Property
[image]

Gets the number of selected items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the number of selected items.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelection.Items Property

ItemSelection.Items Property
[image]

Gets the selected items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Item[] Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As Item()

Property Value

An array of selected Item objects.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelectionEventArgs Class

ItemSelectionEventArgs Class
[image]

Contains the arguments passed to handlers of selection related events.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemSelectionEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemSelectionEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.ItemSelectionEventArgs

See Also

ItemSelectionEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelectionEventArgs Members

ItemSelectionEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of selection related events.

The following tables list the members exposed by the ItemSelectionEventArgs type.

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelectionEventArgs Properties

ItemSelectionEventArgs Properties
[image]

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSelectionEventArgs.IsDeselected Property

ItemSelectionEventArgs.IsDeselected Property
[image]

Gets a value indicating whether the item was deselected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsDeselected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsDeselected As Boolean

Property Value

true if the the item was deselected by the user; false if the item was selected.

Remarks

This property is mutually exclusive with IsSelected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.Wpf Namespace
IsSelected Property


MindFusion.Scheduling.Wpf.ItemSelectionEventArgs.IsSelected Property

ItemSelectionEventArgs.IsSelected Property
[image]

Gets a value indicating whether the item was selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSelected As Boolean

Property Value

true if the the item was selected by the user; false if the item was deselected.

Remarks

This property is mutually exclusive with IsDeselected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.Wpf Namespace
IsDeselected Property


MindFusion.Scheduling.Wpf.ItemSettings Class

ItemSettings Class
[image]

Defines properties that allow customizing the visualization of schedule items in the calendar views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ItemSettings : CalendarSettings

Visual Basic [image] Copy Code

Public Class ItemSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.ItemSettings

See Also

ItemSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings Members

ItemSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of schedule items in the calendar views.

The following tables list the members exposed by the ItemSettings type.

Public Constructors

Name | Description
ItemSettings | Initializes a new instance of the ItemSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CapIncompleteSegmentsProperty | Identifies the CapIncompleteSegments dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
ItemsVisibleProperty | Identifies the ItemsVisible dependency property.
MoveBandSizeProperty | Identifies the MoveBandSize dependency property.
PaddingProperty | Identifies the Padding dependency property.
PointedItemStyleProperty | Identifies the PointedItemStyle dependency property.
PointedSelectedItemStyleProperty | Identifies the PointedSelectedItemStyle dependency property.
ResizeBandSizeProperty | Identifies the ResizeBandSize dependency property.
SelectedItemStyleProperty | Identifies the SelectedItemStyle dependency property.
ShowContinuationArrowsProperty | Identifies the ShowContinuationArrows dependency property.
ShowItemEffectProperty | Identifies the ShowItemEffect dependency property.
ShowMoreItemsCueProperty | Identifies the ShowMoreItemsCue dependency property.
ShowRecurrenceExceptionIconsProperty | Identifies the ShowRecurrenceExceptionIcons dependency property.
ShowRecurrenceIconsProperty | Identifies the ShowRecurrenceIcons dependency property.
ShowReminderIconsProperty | Identifies the ShowReminderIcons dependency property.
SizeProperty | Identifies the Size dependency property.
UseExtendedStylesProperty | Identifies the UseExtendedStyles dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the CalendarStyle used to paint selected schedule items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowItemEffect | Gets or sets a value indicating whether to display the effect of the item.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

See Also

ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings Fields

ItemSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CapIncompleteSegmentsProperty | Identifies the CapIncompleteSegments dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
ItemsVisibleProperty | Identifies the ItemsVisible dependency property.
MoveBandSizeProperty | Identifies the MoveBandSize dependency property.
PaddingProperty | Identifies the Padding dependency property.
PointedItemStyleProperty | Identifies the PointedItemStyle dependency property.
PointedSelectedItemStyleProperty | Identifies the PointedSelectedItemStyle dependency property.
ResizeBandSizeProperty | Identifies the ResizeBandSize dependency property.
SelectedItemStyleProperty | Identifies the SelectedItemStyle dependency property.
ShowContinuationArrowsProperty | Identifies the ShowContinuationArrows dependency property.
ShowItemEffectProperty | Identifies the ShowItemEffect dependency property.
ShowMoreItemsCueProperty | Identifies the ShowMoreItemsCue dependency property.
ShowRecurrenceExceptionIconsProperty | Identifies the ShowRecurrenceExceptionIcons dependency property.
ShowRecurrenceIconsProperty | Identifies the ShowRecurrenceIcons dependency property.
ShowReminderIconsProperty | Identifies the ShowReminderIcons dependency property.
SizeProperty | Identifies the Size dependency property.
UseExtendedStylesProperty | Identifies the UseExtendedStyles dependency property.

See Also

ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.CalendarStyleProperty Field

ItemSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.CapIncompleteSegmentsProperty Field

ItemSettings.CapIncompleteSegmentsProperty Field
[image]

Identifies the CapIncompleteSegments dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CapIncompleteSegmentsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CapIncompleteSegmentsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.HeaderSizeProperty Field

ItemSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ItemsVisibleProperty Field

ItemSettings.ItemsVisibleProperty Field
[image]

Identifies the ItemsVisible dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemsVisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemsVisibleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.MoveBandSizeProperty Field

ItemSettings.MoveBandSizeProperty Field
[image]

Identifies the MoveBandSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.PaddingProperty Field

ItemSettings.PaddingProperty Field
[image]

Identifies the Padding dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.PointedItemStyleProperty Field

ItemSettings.PointedItemStyleProperty Field
[image]

Identifies the PointedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointedItemStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.PointedSelectedItemStyleProperty Field

ItemSettings.PointedSelectedItemStyleProperty Field
[image]

Identifies the PointedSelectedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointedSelectedItemStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointedSelectedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ResizeBandSizeProperty Field

ItemSettings.ResizeBandSizeProperty Field
[image]

Identifies the ResizeBandSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeBandSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeBandSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.SelectedItemStyleProperty Field

ItemSettings.SelectedItemStyleProperty Field
[image]

Identifies the SelectedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedItemStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowContinuationArrowsProperty Field

ItemSettings.ShowContinuationArrowsProperty Field
[image]

Identifies the ShowContinuationArrows dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowContinuationArrowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowContinuationArrowsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowItemEffectProperty Field

ItemSettings.ShowItemEffectProperty Field
[image]

Identifies the ShowItemEffect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowItemEffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowItemEffectProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowMoreItemsCueProperty Field

ItemSettings.ShowMoreItemsCueProperty Field
[image]

Identifies the ShowMoreItemsCue dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowMoreItemsCueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowMoreItemsCueProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowRecurrenceExceptionIconsProperty Field

ItemSettings.ShowRecurrenceExceptionIconsProperty Field
[image]

Identifies the ShowRecurrenceExceptionIcons dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowRecurrenceExceptionIconsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowRecurrenceExceptionIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowRecurrenceIconsProperty Field

ItemSettings.ShowRecurrenceIconsProperty Field
[image]

Identifies the ShowRecurrenceIcons dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowRecurrenceIconsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowRecurrenceIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowReminderIconsProperty Field

ItemSettings.ShowReminderIconsProperty Field
[image]

Identifies the ShowReminderIcons dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowReminderIconsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowReminderIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.SizeProperty Field

ItemSettings.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.UseExtendedStylesProperty Field

ItemSettings.UseExtendedStylesProperty Field
[image]

Identifies the UseExtendedStyles dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UseExtendedStylesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly UseExtendedStylesProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings Constructor

ItemSettings Constructor
[image]

Initializes a new instance of the ItemSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings Properties

ItemSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the CalendarStyle used to paint selected schedule items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowItemEffect | Gets or sets a value indicating whether to display the effect of the item.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

See Also

ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.CalendarStyle Property

ItemSettings.CalendarStyle Property
[image]

Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items. This property cannot be null (Nothing in Visual Basic).

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ItemSettings.CapIncompleteSegments Property

ItemSettings.CapIncompleteSegments Property
[image]

Gets or sets a value indicating whether to cap incomplete item segments.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool CapIncompleteSegments { get; set; }

Visual Basic [image] Copy Code

Public Property CapIncompleteSegments As Boolean

Property Value

true to cap incomplete items segments; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is ignored for non all-day items in the Timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.HeaderSize Property

ItemSettings.HeaderSize Property
[image]

Gets or sets the size of the item header for non all-day items in the Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the item header (in pixels).

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

You can assign 0 to hide the item header completely.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ItemsVisible Property

ItemSettings.ItemsVisible Property
[image]

Gets or sets a value indicating whether to display schedule items in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ItemsVisible { get; set; }

Visual Basic [image] Copy Code

Public Property ItemsVisible As Boolean

Property Value

true to display schedule items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.MoveBandSize Property

ItemSettings.MoveBandSize Property
[image]

Gets or sets the size of the move band of items in the Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MoveBandSize { get; set; }

Visual Basic [image] Copy Code

Public Property MoveBandSize As Integer

Property Value

A non-negative integer value specifying the band size in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.Padding Property

ItemSettings.Padding Property
[image]

Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Thickness

Property Value

A non-negative integer value specifying how many pixels there are left between items and the time cells containing them.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

In a Timetable view this is the distance between consecutive items.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.PointedItemStyle Property

ItemSettings.PointedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle PointedItemStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PointedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items when they are pointed with the mouse. This property cannot be null (Nothing in Visual Basic).

Remarks

This property is ignored when UseExtendedStyles is set to false.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
SelectedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ItemSettings.PointedSelectedItemStyle Property

ItemSettings.PointedSelectedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle PointedSelectedItemStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PointedSelectedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items when they are pointed with the mouse and selected at the same time. This property cannot be null (Nothing in Visual Basic).

Remarks

This property is ignored when UseExtendedStyles is set to false.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
SelectedItemStyle Property
PointedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ItemSettings.ResizeBandSize Property

ItemSettings.ResizeBandSize Property
[image]

Gets or sets the size of the bands used to resize an item in a Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ResizeBandSize { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeBandSize As Integer

Property Value

An integer value specifying the bands' size in pixels. The minimal allowed value is 2.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.SelectedItemStyle Property

ItemSettings.SelectedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint selected schedule items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedItemStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of selected schedule items. This property cannot be null (Nothing in Visual Basic).

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ItemSettings.ShowContinuationArrows Property

ItemSettings.ShowContinuationArrows Property
[image]

Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowContinuationArrows { get; set; }

Visual Basic [image] Copy Code

Public Property ShowContinuationArrows As Boolean

Property Value

Specify true to display arrow icons when an item continues in next time cell; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowItemEffect Property

ItemSettings.ShowItemEffect Property
[image]

Gets or sets a value indicating whether to display the effect of the item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowItemEffect { get; set; }

Visual Basic [image] Copy Code

Public Property ShowItemEffect As Boolean

Property Value

true to display item effects; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowMoreItemsCue Property

ItemSettings.ShowMoreItemsCue Property
[image]

Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowMoreItemsCue { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMoreItemsCue As Boolean

Property Value

true to display an icon for the hidden items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ItemSettings.ShowRecurrenceExceptionIcons Property

ItemSettings.ShowRecurrenceExceptionIcons Property
[image]

Gets or sets a value indicating whether the icon of recurrence exception items is displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowRecurrenceExceptionIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowRecurrenceExceptionIcons As Boolean

Property Value

true to display an icon for the exceptions of recurring items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowRecurrenceIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.Wpf.ItemSettings.ShowRecurrenceIcons Property

ItemSettings.ShowRecurrenceIcons Property
[image]

Gets or sets a value indicating whether the icon of recurring items is displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowRecurrenceIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowRecurrenceIcons As Boolean

Property Value

true to display an icon for recurring items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowRecurrenceExceptionIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.Wpf.ItemSettings.ShowReminderIcons Property

ItemSettings.ShowReminderIcons Property
[image]

Gets or sets a value indicating whether the reminder icon of items is displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowReminderIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowReminderIcons As Boolean

Property Value

true to display an icon for items that have a reminder; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowRecurrenceIcons Property
ShowRecurrenceExceptionIcons Property


MindFusion.Scheduling.Wpf.ItemSettings.Size Property

ItemSettings.Size Property
[image]

Gets or sets the size of schedule items drawn in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

A non-negative integer value specifying items width or height in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the height of horizontal items or the width of vertical items. The items length is defined by their start time and duration. The property is ignored for items drawn in timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
Padding Property


MindFusion.Scheduling.Wpf.ItemSettings.UseExtendedStyles Property

ItemSettings.UseExtendedStyles Property
[image]

Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool UseExtendedStyles { get; set; }

Visual Basic [image] Copy Code

Public Property UseExtendedStyles As Boolean

Property Value

true to enable extended styles; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to false, the pointed styles (that is, PointedItemStyle and PointedSelectedItemStyle) are ignored.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Wpf Namespace
Style Property
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property


MindFusion.Scheduling.Wpf.ListViewHeaderStyles Enumeration

ListViewHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a List view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum ListViewHeaderStyles

Visual Basic [image] Copy Code

Public Enum ListViewHeaderStyles

Members

Member name | Description
Header | Display the cells' dates in the header.
HeaderPerCell | Draw the header background for each cell separately, rather than for the whole interval.
None | Do not display a header.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings Class

ListViewSettings Class
[image]

Defines properties that allow customizing the visualization of the calendar in a List view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class ListViewSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class ListViewSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.ListViewSettings

See Also

ListViewSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings Members

ListViewSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in a List view.

The following tables list the members exposed by the ListViewSettings type.

Public Constructors

Name | Description
ListViewSettings | Initializes a new instance of the ListViewSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
CellUnitsProperty | Identifies the CellUnits dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EnableVirtualItemSpaceProperty | Identifies the EnableVirtualItemSpace dependency property.
EvenWeeksBrushProperty | Identifies the EvenWeeksBrush dependency property.
FreeDragProperty | Identifies the FreeDrag dependency property.
GroupHeaderSizeProperty | Identifies the GroupHeaderSize dependency property.
GroupHeaderStyleProperty | Identifies the GroupHeaderStyle dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
ItemOrientationProperty | Identifies the ItemOrientation dependency property.
NumberOfCellsProperty | Identifies the NumberOfCells dependency property.
OddWeeksBrushProperty | Identifies the OddWeeksBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateGroupHeaderTextsProperty | Identifies the RotateGroupHeaderTexts dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowGroupHeaderProperty | Identifies the ShowGroupHeader dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TotalLaneCountProperty | Identifies the TotalLaneCount dependency property.
VisibleCellsProperty | Identifies the VisibleCells dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets a CellSettings object used to customize the visualization of cells in the List view.
CellUnits | Gets or sets the resolution of the list view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally or vertically.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateGroupHeaderTexts | Gets or sets a value indicating whether the group header texts in a horizontal list view are rotated.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings Fields

ListViewSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
CellUnitsProperty | Identifies the CellUnits dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EnableVirtualItemSpaceProperty | Identifies the EnableVirtualItemSpace dependency property.
EvenWeeksBrushProperty | Identifies the EvenWeeksBrush dependency property.
FreeDragProperty | Identifies the FreeDrag dependency property.
GroupHeaderSizeProperty | Identifies the GroupHeaderSize dependency property.
GroupHeaderStyleProperty | Identifies the GroupHeaderStyle dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
ItemOrientationProperty | Identifies the ItemOrientation dependency property.
NumberOfCellsProperty | Identifies the NumberOfCells dependency property.
OddWeeksBrushProperty | Identifies the OddWeeksBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateGroupHeaderTextsProperty | Identifies the RotateGroupHeaderTexts dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowGroupHeaderProperty | Identifies the ShowGroupHeader dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TotalLaneCountProperty | Identifies the TotalLaneCount dependency property.
VisibleCellsProperty | Identifies the VisibleCells dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.

See Also

ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.CalendarStyleProperty Field

ListViewSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.CellSettingsProperty Field

ListViewSettings.CellSettingsProperty Field
[image]

Identifies the CellSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellSettingsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.CellUnitsProperty Field

ListViewSettings.CellUnitsProperty Field
[image]

Identifies the CellUnits dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellUnitsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellUnitsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.EnableSnappingProperty Field

ListViewSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.EnableVirtualItemSpaceProperty Field

ListViewSettings.EnableVirtualItemSpaceProperty Field
[image]

Identifies the EnableVirtualItemSpace dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableVirtualItemSpaceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableVirtualItemSpaceProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.EvenWeeksBrushProperty Field

ListViewSettings.EvenWeeksBrushProperty Field
[image]

Identifies the EvenWeeksBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EvenWeeksBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EvenWeeksBrushProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.FreeDragProperty Field

ListViewSettings.FreeDragProperty Field
[image]

Identifies the FreeDrag dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FreeDragProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FreeDragProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.GroupHeaderSizeProperty Field

ListViewSettings.GroupHeaderSizeProperty Field
[image]

Identifies the GroupHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHeaderSizeProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.GroupHeaderStyleProperty Field

ListViewSettings.GroupHeaderStyleProperty Field
[image]

Identifies the GroupHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderSizeProperty Field

ListViewSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderStyleProperty Field

ListViewSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderStylesProperty Field

ListViewSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyles dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.ItemOrientationProperty Field

ListViewSettings.ItemOrientationProperty Field
[image]

Identifies the ItemOrientation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemOrientationProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.NumberOfCellsProperty Field

ListViewSettings.NumberOfCellsProperty Field
[image]

Identifies the NumberOfCells dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NumberOfCellsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NumberOfCellsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.OddWeeksBrushProperty Field

ListViewSettings.OddWeeksBrushProperty Field
[image]

Identifies the OddWeeksBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OddWeeksBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OddWeeksBrushProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.OrientationProperty Field

ListViewSettings.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.RotateGroupHeaderTextsProperty Field

ListViewSettings.RotateGroupHeaderTextsProperty Field
[image]

Identifies the RotateGroupHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateGroupHeaderTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateGroupHeaderTextsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.RotateHeaderTextsProperty Field

ListViewSettings.RotateHeaderTextsProperty Field
[image]

Identifies the RotateHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderTextsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.ScrollStepProperty Field

ListViewSettings.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.SelectedElementsHeaderStyleProperty Field

ListViewSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.SelectedElementsStyleProperty Field

ListViewSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.ShowGroupHeaderProperty Field

ListViewSettings.ShowGroupHeaderProperty Field
[image]

Identifies the ShowGroupHeader dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowGroupHeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowGroupHeaderProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.ShowNavigationButtonsProperty Field

ListViewSettings.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.SnapUnitCountProperty Field

ListViewSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.SnapUnitProperty Field

ListViewSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.SubHeaderStyleProperty Field

ListViewSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.TitleFormatProperty Field

ListViewSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.TotalLaneCountProperty Field

ListViewSettings.TotalLaneCountProperty Field
[image]

Identifies the TotalLaneCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TotalLaneCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TotalLaneCountProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.VisibleCellsProperty Field

ListViewSettings.VisibleCellsProperty Field
[image]

Identifies the VisibleCells dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleCellsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleCellsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.VisibleColumnsProperty Field

ListViewSettings.VisibleColumnsProperty Field
[image]

Identifies the VisibleColumns dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleColumnsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleColumnsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings Constructor

ListViewSettings Constructor
[image]

Initializes a new instance of the ListViewSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ListViewSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings Properties

ListViewSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets a CellSettings object used to customize the visualization of cells in the List view.
CellUnits | Gets or sets the resolution of the list view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally or vertically.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateGroupHeaderTexts | Gets or sets a value indicating whether the group header texts in a horizontal list view are rotated.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.CalendarStyle Property

ListViewSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.CellSettings Property

ListViewSettings.CellSettings Property
[image]

Gets or sets a CellSettings object used to customize the visualization of cells in the List view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; set; }

Visual Basic [image] Copy Code

Public Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.CellUnits Property

ListViewSettings.CellUnits Property
[image]

Gets or sets the resolution of the list view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeUnit CellUnits { get; set; }

Visual Basic [image] Copy Code

Public Property CellUnits As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.EnableSnapping Property

ListViewSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

true to enable snapping; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

When this property is enabled, the users will move and resize items with the precision specified in the SnapUnit property instead of the precision of the view's resolution. When this property is disabled, the items will snap automatically to the border of their containing cells.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Wpf.ListViewSettings.EnableVirtualItemSpace Property

ListViewSettings.EnableVirtualItemSpace Property
[image]

Gets or sets a value indicating whether items in the list view can be scrolled through.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableVirtualItemSpace { get; set; }

Visual Basic [image] Copy Code

Public Property EnableVirtualItemSpace As Boolean

Property Value

true to enable virtual item space; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property to override the default behavior of the vertical scrollbar (in a horizontal List view) or the horizontal scrollbar (in a vertical List view). When this property is enabled, the appropriate scrollbar will scroll through the items that are not visible within the view (due to insufficient space) rather than scroll through the cells associated with resources in a grouped List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
FreeDrag Property


MindFusion.Scheduling.Wpf.ListViewSettings.EvenWeeksBrush Property

ListViewSettings.EvenWeeksBrush Property
[image]

Gets or sets the brush used to paint the background of the contents of even weeks.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush EvenWeeksBrush { get; set; }

Visual Basic [image] Copy Code

Public Property EvenWeeksBrush As Brush

Property Value

An instance of a Brush-derived class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to null (Nothing in Visual Basic), the brush from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
OddWeeksBrush Property


MindFusion.Scheduling.Wpf.ListViewSettings.FreeDrag Property

ListViewSettings.FreeDrag Property
[image]

Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool FreeDrag { get; set; }

Visual Basic [image] Copy Code

Public Property FreeDrag As Boolean

Property Value

true to enable free dragging; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Set this property to true to disable the default item layout algorithm, where colliding items are arranged relative to each other according to their start and end times and their Priority. Turning this property on will allow users to move items anywhere within the view.

The position of an item acquired through free dragging is related to the view. This means that if the schedule, containing the item is displayed in another Calendar control, the item's position within the List view might not be the same as its position in the initial view. Additionally, view-related data is not serialized by calling the serialization methods of the Schedule class.

Finally, the position of an item within the view can be obtained and set programmatically through the use of the GetItemListLane and SetItemListLane methods of the Calendar class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.GroupHeaderSize Property

ListViewSettings.GroupHeaderSize Property
[image]

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int GroupHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowGroupHeader Property


MindFusion.Scheduling.Wpf.ListViewSettings.GroupHeaderStyle Property

ListViewSettings.GroupHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the group header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle GroupHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the column headers. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderSize Property

ListViewSettings.HeaderSize Property
[image]

Gets or sets the header size in pixels.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the header size. A value of 0 hides the header.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the header width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
TitleFormat Property


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderStyle Property

ListViewSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
SubHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.HeaderStyles Property

ListViewSettings.HeaderStyles Property
[image]

Gets or sets the style of the List view header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ListViewHeaderStyles HeaderStyles { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyles As ListViewHeaderStyles

Property Value

A member of the ListViewHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderSize Property
TitleFormat Property


MindFusion.Scheduling.Wpf.ListViewSettings.ItemOrientation Property

ListViewSettings.ItemOrientation Property
[image]

Gets or sets a value indicating whether the items are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Orientation ItemOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ItemOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Items are usually oriented according to the view's Orientation. That is, items are horizontal in a horizontal List view and vice versa. The orientation of the items can be explicitly specified by using this property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.NumberOfCells Property

ListViewSettings.NumberOfCells Property
[image]

Gets or sets the total number of cells to be displayed in the List view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int NumberOfCells { get; set; }

Visual Basic [image] Copy Code

Public Property NumberOfCells As Integer

Property Value

An integer value specifying how many days to display.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This value cannot be less than 1 or less than the number of visible days set in the VisibleCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
VisibleCells Property


MindFusion.Scheduling.Wpf.ListViewSettings.OddWeeksBrush Property

ListViewSettings.OddWeeksBrush Property
[image]

Gets or sets the brush used to paint the background of the contents of odd weeks.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush OddWeeksBrush { get; set; }

Visual Basic [image] Copy Code

Public Property OddWeeksBrush As Brush

Property Value

An instance of a Brush-derived class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to null (Nothing in Visual Basic), the brush from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
EvenWeeksBrush Property


MindFusion.Scheduling.Wpf.ListViewSettings.Orientation Property

ListViewSettings.Orientation Property
[image]

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to Horizontal, the view header is displayed at the top and the day cells are arranged in a horizontal row underneath it. If set to Vertical, the header is displayed on the left side and the days are arranged in a vertical row on the right.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.RotateGroupHeaderTexts Property

ListViewSettings.RotateGroupHeaderTexts Property
[image]

Gets or sets a value indicating whether the group header texts in a horizontal list view are rotated.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateGroupHeaderTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateGroupHeaderTexts As Boolean

Property Value

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.RotateHeaderTexts Property

ListViewSettings.RotateHeaderTexts Property
[image]

Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateHeaderTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateHeaderTexts As Boolean

Property Value

true to display the header text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.ScrollStep Property

ListViewSettings.ScrollStep Property
[image]

Gets or sets the number of units to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Integer

Property Value

An integer value specifying the number of units to scroll.

Remarks

This property specifies the amount of units (as specified by the CellUnits property) to scroll back and forth when using the navigation buttons in the List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowNavigationButtons Property


MindFusion.Scheduling.Wpf.ListViewSettings.SelectedElementsHeaderStyle Property

ListViewSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.SelectedElementsStyle Property

ListViewSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.ShowGroupHeader Property

ListViewSettings.ShowGroupHeader Property
[image]

Gets or sets a value indicating whether to display the reference grouping header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowGroupHeader { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGroupHeader As Boolean

Property Value

true to show the group header; otherwise, false.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
GroupHeaderSize Property


MindFusion.Scheduling.Wpf.ListViewSettings.ShowNavigationButtons Property

ListViewSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the List view displays navigation buttons.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to display the navigation buttons; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The amount of units to scroll can be specified through the ScrollStep property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
ScrollStep Property


MindFusion.Scheduling.Wpf.ListViewSettings.SnapUnit Property

ListViewSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to false the value of this property is ignored and items snap to cell borders.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
EnableSnapping Property
SnapUnitCount Property


MindFusion.Scheduling.Wpf.ListViewSettings.SnapUnitCount Property

ListViewSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Wpf.ListViewSettings.SubHeaderStyle Property

ListViewSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.ListViewSettings.TitleFormat Property

ListViewSettings.TitleFormat Property
[image]

Gets or sets a string used to format the cells titles.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ListViewSettings.TotalLaneCount Property

ListViewSettings.TotalLaneCount Property
[image]

Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int TotalLaneCount { get; set; }

Visual Basic [image] Copy Code

Public Property TotalLaneCount As Integer

Property Value

A non-negative integer value specifying the number of lanes in the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

When this property is set to 0, the item scrollbar is automatically adjusted so that it covers all existing items. Otherwise the item scrollbar is adjusted so that it covers the specified number of lanes.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
EnableVirtualItemSpace Property


MindFusion.Scheduling.Wpf.ListViewSettings.VisibleCells Property

ListViewSettings.VisibleCells Property
[image]

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int VisibleCells { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleCells As Integer

Property Value

A positive integer value specifying how many days to display simultaneously in the List view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The value assigned to this property cannot be less than 1 or less than the total number of days available in the view, as specified in the NumberOfCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace
NumberOfCells Property


MindFusion.Scheduling.Wpf.ListViewSettings.VisibleColumns Property

ListViewSettings.VisibleColumns Property
[image]

Gets or sets the number of visible group columns in a list view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int VisibleColumns { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is actually used only in a grouped List view. Otherwise, the number of columns in the view is always 1.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MinuteFormat Enumeration

MinuteFormat Enumeration
[image]

Specifies how to format and display minutes in the Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MinuteFormat

Visual Basic [image] Copy Code

Public Enum MinuteFormat

Members

Member name | Description
Colons | Display a colon and a leading zero.
LeadingZero | Display a leading zero for single digit minutes.
NoLeadingZero | No leading zero for single digit minutes.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthCellLayout Enumeration

MonthCellLayout Enumeration
[image]

Specifies the layout of the cells in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MonthCellLayout

Visual Basic [image] Copy Code

Public Enum MonthCellLayout

Members

Member name | Description
Grid | Indicates that the cells are laid out in a grid, where each row in the grid contains the days of a single week.
Linear | Indicates that the cells are laid out in a single line.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthHeaderStyles Enumeration

MonthHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MonthHeaderStyles

Visual Basic [image] Copy Code

Public Enum MonthHeaderStyles

Members

Member name | Description
MonthButtons | Display buttons for scrolling to previous or next month.
None | Do not display the header.
SubheaderPerDay | The sub headers are drawn separately for each day, rather than for the whole interval.
Title | Display the date of the month in the header.
YearButtons | Display buttons for scrolling to previous or next year.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeHeaderStyles Enumeration

MonthRangeHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MonthRangeHeaderStyles

Visual Basic [image] Copy Code

Public Enum MonthRangeHeaderStyles

Members

Member name | Description
Buttons | The header displays buttons that can be used to scroll to previous and following moths.
None | The header is not displayed.
Title | The header displays the start and end dates.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings Class

MonthRangeSettings Class
[image]

Defines settings for the years in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class MonthRangeSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class MonthRangeSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.MonthRangeSettings

See Also

MonthRangeSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings Members

MonthRangeSettings Members
Constructors Fields Properties
[image]

Defines settings for the years in the calendar.

The following tables list the members exposed by the MonthRangeSettings type.

Public Constructors

Name | Description
MonthRangeSettings | Initializes a new instance of the MonthRangeSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
MonthSpacingProperty | Identifies the MonthSpacing dependency property.
MonthsPerRowProperty | Identifies the MonthsPerRow dependency property.
NumberOfMonthsProperty | Identifies the NumberOfMonths dependency property.
ScrollIntervalProperty | Identifies the ScrollInterval property.
ShowInnerPaddingDaysProperty | Identifies the ShowInnerPaddingDays dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Effect | Gets or sets the effect applied to view headers.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the MonthRange view header.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
ShowInnerPaddingDays | Gets or sets a value indicating whether to display the padding days of all months or only the start padding days of the first month and the end padding days in the last month. This is a dependency property.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings Fields

MonthRangeSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
MonthSpacingProperty | Identifies the MonthSpacing dependency property.
MonthsPerRowProperty | Identifies the MonthsPerRow dependency property.
NumberOfMonthsProperty | Identifies the NumberOfMonths dependency property.
ScrollIntervalProperty | Identifies the ScrollInterval property.
ShowInnerPaddingDaysProperty | Identifies the ShowInnerPaddingDays dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.CalendarStyleProperty Field

MonthRangeSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.EffectProperty Field

MonthRangeSettings.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EffectProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderHeightProperty Field

MonthRangeSettings.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderStyleProperty Field

MonthRangeSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderStylesProperty Field

MonthRangeSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyles dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.MonthSpacingProperty Field

MonthRangeSettings.MonthSpacingProperty Field
[image]

Identifies the MonthSpacing dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthSpacingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthSpacingProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.MonthsPerRowProperty Field

MonthRangeSettings.MonthsPerRowProperty Field
[image]

Identifies the MonthsPerRow dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthsPerRowProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthsPerRowProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.NumberOfMonthsProperty Field

MonthRangeSettings.NumberOfMonthsProperty Field
[image]

Identifies the NumberOfMonths dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NumberOfMonthsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NumberOfMonthsProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.ScrollIntervalProperty Field

MonthRangeSettings.ScrollIntervalProperty Field
[image]

Identifies the ScrollInterval property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollIntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollIntervalProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.ShowInnerPaddingDaysProperty Field

MonthRangeSettings.ShowInnerPaddingDaysProperty Field
[image]

Identifies the ShowInnerPaddingDays dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowInnerPaddingDaysProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowInnerPaddingDaysProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.TitleFormatProperty Field

MonthRangeSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.TitleSeparatorProperty Field

MonthRangeSettings.TitleSeparatorProperty Field
[image]

Identifies the TitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleSeparatorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleSeparatorProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.VisibleRowsProperty Field

MonthRangeSettings.VisibleRowsProperty Field
[image]

Identifies the VisibleRows dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleRowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleRowsProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings Constructor

MonthRangeSettings Constructor
[image]

Initializes a new instance of the MonthRangeSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthRangeSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings Properties

MonthRangeSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Effect | Gets or sets the effect applied to view headers.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the MonthRange view header.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
ShowInnerPaddingDays | Gets or sets a value indicating whether to display the padding days of all months or only the start padding days of the first month and the end padding days in the last month. This is a dependency property.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.CalendarStyle Property

MonthRangeSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthRangeSettings.Effect Property

MonthRangeSettings.Effect Property
[image]

Gets or sets the effect applied to view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Effect As Effect

Property Value

A .NET Effect object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderHeight Property

MonthRangeSettings.HeaderHeight Property
[image]

Gets or sets the height of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderStyle Property

MonthRangeSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthRangeSettings.HeaderStyles Property

MonthRangeSettings.HeaderStyles Property
[image]

Gets or sets the style of the MonthRange view header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthRangeHeaderStyles HeaderStyles { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyles As MonthRangeHeaderStyles

Property Value

A member of the MonthRangeHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderHeight Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.MonthSpacing Property

MonthRangeSettings.MonthSpacing Property
[image]

Gets or sets the amount of space between adjacent months.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness MonthSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property MonthSpacing As Thickness

Property Value

A non-negative integer value specifying how many pixels there are between adjacent month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
Margin Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.MonthsPerRow Property

MonthRangeSettings.MonthsPerRow Property
[image]

Gets or sets the number of months to be displayed in a row.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MonthsPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property MonthsPerRow As Integer

Property Value

An integer value specifying how many months are displayed in a row in the month range view. The allowed values range from 1 to 12.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this value multiplied by VisibleRows is larger than NumberOfMonths, the calendar control displays scrollbars letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
VisibleRows Property
NumberOfMonths Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.NumberOfMonths Property

MonthRangeSettings.NumberOfMonths Property
[image]

Gets or sets the number of months to display in the MonthRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int NumberOfMonths { get; set; }

Visual Basic [image] Copy Code

Public Property NumberOfMonths As Integer

Property Value

A positive integer value specifying how many months to display in the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If the number of months is set larger than number of rows multiplied by MonthsPerRow, the calendar displays scrollbar, letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
VisibleRows Property
MonthsPerRow Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.ScrollInterval Property

MonthRangeSettings.ScrollInterval Property
[image]

Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ScrollInterval { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollInterval As Integer

Property Value

A positive integer value specifying with how many months to scroll the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.ShowInnerPaddingDays Property

MonthRangeSettings.ShowInnerPaddingDays Property
[image]

Gets or sets a value indicating whether to display the padding days of all months or only the start padding days of the first month and the end padding days in the last month. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowInnerPaddingDays { get; set; }

Visual Basic [image] Copy Code

Public Property ShowInnerPaddingDays As Boolean

Property Value

true, to display the padding days of every month in the view; false, to display the leading padding days of the first month and the trailing padding days of the last month.

Remarks

This property is only considered when ShowPaddingDays is set to true.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthRangeSettings.TitleFormat Property

MonthRangeSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
TitleSeparator Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.TitleSeparator Property

MonthRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }

Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string containing the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format of the text displayed in the view's header is in the format "<FirstDate><TitleSeparator><LastDate>", where <FirstDate> and <LastDate> indicate the first and the last visible dates in the calendar, formatted according to the TitleFormat property. The <TitleSeparator> represents the value of this property. If TitleSeparator is set to an empty string, then the header's text is only "<FirstDate>". See the example below for more information.

Example

The following example shows how to display only the current year in the header of a MonthRange view. The sample assumes that calendar references an existing Calendar object.

C# [image] Copy Code
calendar.MonthRangeSettings.TitleFormat = "yyyy";
calendar.MonthRangeSettings.TitleSeparator = "";
Visual Basic [image] Copy Code
calendar.MonthRangeSettings.TitleFormat = "yyyy"
calendar.MonthRangeSettings.TitleSeparator = ""

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
TitleFormat Property


MindFusion.Scheduling.Wpf.MonthRangeSettings.VisibleRows Property

MonthRangeSettings.VisibleRows Property
[image]

Gets or sets the number of rows to display at the same time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

A positive integer value specifying how many rows of month cells to display.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
MonthsPerRow Property
NumberOfMonths Property


MindFusion.Scheduling.Wpf.MonthSettings Class

MonthSettings Class
[image]

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class MonthSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class MonthSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.MonthSettings

See Also

MonthSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings Members

MonthSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

The following tables list the members exposed by the MonthSettings type.

Public Constructors

Name | Description
MonthSettings | Initializes a new instance of the MonthSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellLayoutProperty | Identifies the CellLayout dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyle dependency property.
LeadingWeekCountProperty | Identifies the LeadingWeekCount dependency property.
MainHeaderHeightProperty | Identifies the MainHeaderHeight dependency property.
PaddingDaysHeaderStyleProperty | Identifies the PaddingDaysHeaderStyle dependency property.
PaddingDaysStyleProperty | Identifies the PaddingDaysStyle dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TrailingWeekCountProperty | Identifies the TrailingWeekCount dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
Effect | Gets or sets the effect applied to view headers.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
PaddingDaysHeaderStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings Fields

MonthSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellLayoutProperty | Identifies the CellLayout dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyle dependency property.
LeadingWeekCountProperty | Identifies the LeadingWeekCount dependency property.
MainHeaderHeightProperty | Identifies the MainHeaderHeight dependency property.
PaddingDaysHeaderStyleProperty | Identifies the PaddingDaysHeaderStyle dependency property.
PaddingDaysStyleProperty | Identifies the PaddingDaysStyle dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TrailingWeekCountProperty | Identifies the TrailingWeekCount dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

See Also

MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.CalendarStyleProperty Field

MonthSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.CellLayoutProperty Field

MonthSettings.CellLayoutProperty Field
[image]

Identifies the CellLayout dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellLayoutProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.DayOfWeekFormatProperty Field

MonthSettings.DayOfWeekFormatProperty Field
[image]

Identifies the DayOfWeekFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayOfWeekFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DayOfWeekFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.EffectProperty Field

MonthSettings.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EffectProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.HeaderStyleProperty Field

MonthSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.HeaderStylesProperty Field

MonthSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.LeadingWeekCountProperty Field

MonthSettings.LeadingWeekCountProperty Field
[image]

Identifies the LeadingWeekCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeadingWeekCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LeadingWeekCountProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.MainHeaderHeightProperty Field

MonthSettings.MainHeaderHeightProperty Field
[image]

Identifies the MainHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MainHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MainHeaderHeightProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.PaddingDaysHeaderStyleProperty Field

MonthSettings.PaddingDaysHeaderStyleProperty Field
[image]

Identifies the PaddingDaysHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingDaysHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingDaysHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.PaddingDaysStyleProperty Field

MonthSettings.PaddingDaysStyleProperty Field
[image]

Identifies the PaddingDaysStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingDaysStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingDaysStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.RotateWeekHeaderTextsProperty Field

MonthSettings.RotateWeekHeaderTextsProperty Field
[image]

Identifies the RotateWeekHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateWeekHeaderTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateWeekHeaderTextsProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SelectedElementsHeaderStyleProperty Field

MonthSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SelectedElementsStyleProperty Field

MonthSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.ShowDayOfWeekProperty Field

MonthSettings.ShowDayOfWeekProperty Field
[image]

Identifies the ShowDayOfWeek dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayOfWeekProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayOfWeekProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.ShowPaddingDaysProperty Field

MonthSettings.ShowPaddingDaysProperty Field
[image]

Identifies the ShowPaddingDays dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingDaysProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingDaysProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SubHeaderHeightProperty Field

MonthSettings.SubHeaderHeightProperty Field
[image]

Identifies the SubHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderHeightProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SubHeaderStyleProperty Field

MonthSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.TitleFormatProperty Field

MonthSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.TrailingWeekCountProperty Field

MonthSettings.TrailingWeekCountProperty Field
[image]

Identifies the TrailingWeekCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TrailingWeekCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TrailingWeekCountProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.WeekHeaderFormatProperty Field

MonthSettings.WeekHeaderFormatProperty Field
[image]

Identifies the WeekHeaderFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.WeekHeaderStyleProperty Field

MonthSettings.WeekHeaderStyleProperty Field
[image]

Identifies the WeekHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.WeekNumbersHeaderWidthProperty Field

MonthSettings.WeekNumbersHeaderWidthProperty Field
[image]

Identifies the WeekNumbersHeaderWidth dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekNumbersHeaderWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekNumbersHeaderWidthProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings Constructor

MonthSettings Constructor
[image]

Initializes a new instance of the MonthSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings Properties

MonthSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
Effect | Gets or sets the effect applied to view headers.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
PaddingDaysHeaderStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.CalendarStyle Property

MonthSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.CellLayout Property

MonthSettings.CellLayout Property
[image]

Gets or sets the layout of the cells in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthCellLayout CellLayout { get; set; }

Visual Basic [image] Copy Code

Public Property CellLayout As MonthCellLayout

Property Value

A member of the MonthCellLayout enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.DayOfWeekFormat Property

MonthSettings.DayOfWeekFormat Property
[image]

Gets or sets the format of the day names displayed in the week header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.DaySettings Property

MonthSettings.DaySettings Property
[image]

Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellSettings DaySettings { get; set; }

Visual Basic [image] Copy Code

Public Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.Effect Property

MonthSettings.Effect Property
[image]

Gets or sets the effect applied to view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public new Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Effect As Effect

Property Value

A .NET Effect object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.HeaderStyle Property

MonthSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.HeaderStyles Property

MonthSettings.HeaderStyles Property
[image]

Gets or sets the style of the month's header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthHeaderStyles HeaderStyles { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyles As MonthHeaderStyles

Property Value

A member of the MonthHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.LeadingWeekCount Property

MonthSettings.LeadingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the previous month.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int LeadingWeekCount { get; set; }

Visual Basic [image] Copy Code

Public Property LeadingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display before the first week of the selected month.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
TrailingWeekCount Property


MindFusion.Scheduling.Wpf.MonthSettings.MainHeaderHeight Property

MonthSettings.MainHeaderHeight Property
[image]

Gets or sets the height of the main header in a month view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MainHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the main header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.PaddingDaysHeaderStyle Property

MonthSettings.PaddingDaysHeaderStyle Property
[image]

Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle PaddingDaysHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PaddingDaysHeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
PaddingDaysStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.PaddingDaysStyle Property

MonthSettings.PaddingDaysStyle Property
[image]

Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle PaddingDaysStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PaddingDaysStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
PaddingDaysHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.RotateWeekHeaderTexts Property

MonthSettings.RotateWeekHeaderTexts Property
[image]

Gets or sets a value indicating whether the week header texts should be rotated.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateWeekHeaderTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateWeekHeaderTexts As Boolean

Property Value

true to rotate the texts in the week header; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SelectedElementsHeaderStyle Property

MonthSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.SelectedElementsStyle Property

MonthSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.ShowDayOfWeek Property

MonthSettings.ShowDayOfWeek Property
[image]

Gets or sets a value indicating whether the day names are displayed in the month's header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowDayOfWeek { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDayOfWeek As Boolean

Property Value

true to display day names; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it is not a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
SubHeaderHeight Property


MindFusion.Scheduling.Wpf.MonthSettings.ShowPaddingDays Property

MonthSettings.ShowPaddingDays Property
[image]

Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowPaddingDays { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPaddingDays As Boolean

Property Value

true to display days from the previous and next months to fill up this month's grid; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Padding days are also displayed in the month range view for the first and the last months contained in the view.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.SubHeaderHeight Property

MonthSettings.SubHeaderHeight Property
[image]

Gets or sets the height of the secondary header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SubHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
ShowDayOfWeek Property


MindFusion.Scheduling.Wpf.MonthSettings.SubHeaderStyle Property

MonthSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.MonthSettings.TitleFormat Property

MonthSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month's title.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.TrailingWeekCount Property

MonthSettings.TrailingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the next month.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int TrailingWeekCount { get; set; }

Visual Basic [image] Copy Code

Public Property TrailingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display after the selected month.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
LeadingWeekCount Property


MindFusion.Scheduling.Wpf.MonthSettings.WeekHeaderFormat Property

MonthSettings.WeekHeaderFormat Property
[image]

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string WeekHeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The string controls how to format the text displayed by week headers in a SingleMonth and MonthRange views. The value of this property can contain the following formatting specifiers among ordinary text in any number and order:

Specified | Description
%s[{format}] | The date of the first day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%e[{format}] | The date of the last day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%w | The number of the corresponding week relative to the current year.

Example

For example, the formatting string "(%w) %s[d ]-%e[d ], %s[MMM]" for the week 13.08-19.08 will yield the following result: "(33) 13-19, Aug". Pay attention to the space following 'd' in the format specification '[d ]'. If the space is missing, the format will be interpreted by the .NET framework as standard short date formatting.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.MonthSettings.WeekHeaderStyle Property

MonthSettings.WeekHeaderStyle Property
[image]

Gets or sets the style of the week numbers header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthWeekHeaderStyle WeekHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderStyle As MonthWeekHeaderStyle

Property Value

A member of the MonthWeekHeaderStyle enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
WeekNumbersHeaderWidth Property


MindFusion.Scheduling.Wpf.MonthSettings.WeekNumbersHeaderWidth Property

MonthSettings.WeekNumbersHeaderWidth Property
[image]

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int WeekNumbersHeaderWidth { get; set; }

Visual Basic [image] Copy Code

Public Property WeekNumbersHeaderWidth As Integer

Property Value

A non-negative integer value specifying the header width in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Wpf Namespace
WeekHeaderStyle Property


MindFusion.Scheduling.Wpf.MonthWeekHeaderStyle Enumeration

MonthWeekHeaderStyle Enumeration
[image]

Specifies the placement of the week numbers header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum MonthWeekHeaderStyle

Visual Basic [image] Copy Code

Public Enum MonthWeekHeaderStyle

Members

Member name | Description
Left | Display the header on the left side of the calendar.
None | Do not display a week numbers header.
Right | Display the header on the right side of the calendar.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Position Enumeration

Position Enumeration
[image]

Specifies the position of an element relative to its container.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum Position

Visual Basic [image] Copy Code

Public Enum Position

Members

Member name | Description
Bottom | The element is docked at the bottom side.
Left | The element is docked at the left side.
None | The element is not displayed.
Right | The element is docked at the right side.
Top | The element is docked at the top side.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm Class

RecurrenceForm Class
[image]

Ready-made form for recurrence editing.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class RecurrenceForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class RecurrenceForm
Inherits Window
Implements IComponentConnector

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Scheduling.Wpf.RecurrenceForm

See Also

RecurrenceForm Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm Members

RecurrenceForm Members
Constructors Properties Methods
[image]

Ready-made form for recurrence editing.

The following tables list the members exposed by the RecurrenceForm type.

Public Constructors

Name | Description
RecurrenceForm | Initializes a new instance of the RecurrenceForm class.

Public Properties

Name | Description
EndTime | Gets the end time of the recurrence.
IsAppointmentDeleted | Gets a value indicating whether the user has deleted the edited appointment through the button in the form's toolbar.
Recurrence | Gets the recurrence being edited in this form.
StartTime | Gets the start time of the recurrence.
TimeFormat | Gets or sets the format of times displayed within the form.

Public Methods

Name | Description
EnableRemoveButton | Enables or disables the 'Remove' button.
SetDate | Sets a date to be used to initialize the form if no recurrence is set initially.
SetDates | Sets the dates to be used to initialize the form if no recurrence is initially set.
SetRecurrence | Sets the recurrence pattern to be edited in the form.

See Also

RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm Constructor

RecurrenceForm Constructor
[image]

Initializes a new instance of the RecurrenceForm class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public RecurrenceForm ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm Methods

RecurrenceForm Methods
[image]

Public Methods

Name | Description
EnableRemoveButton | Enables or disables the 'Remove' button.
SetDate | Sets a date to be used to initialize the form if no recurrence is set initially.
SetDates | Sets the dates to be used to initialize the form if no recurrence is initially set.
SetRecurrence | Sets the recurrence pattern to be edited in the form.

See Also

RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.EnableRemoveButton Method

RecurrenceForm.EnableRemoveButton Method
[image]

Enables or disables the 'Remove' button.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void EnableRemoveButton (
bool enable
)

Visual Basic [image] Copy Code

Public Sub EnableRemoveButton( _
enable As Boolean _
)

Parameters

enable
true to enable the 'Remove' button, false to disable it.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.SetDate Method

RecurrenceForm.SetDate Method
[image]

Sets a date to be used to initialize the form if no recurrence is set initially.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void SetDate (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub SetDate( _
date As DateTime _
)

Parameters

date
A .NET DateTime object specifying the start and end time of the recurrence displayed in the form.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.SetDates Method

RecurrenceForm.SetDates Method
[image]

Sets the dates to be used to initialize the form if no recurrence is initially set.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void SetDates (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub SetDates( _
start As DateTime, _
end As DateTime _
)

Parameters

start
A .NET DateTime instance specifying the start time of the recurrence.
end
A .NET DateTime instance specifying the end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.SetRecurrence Method

RecurrenceForm.SetRecurrence Method
[image]

Sets the recurrence pattern to be edited in the form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void SetRecurrence (
Recurrence recurrence,
DateTime startTime,
DateTime endTime
)

Visual Basic [image] Copy Code

Public Sub SetRecurrence ( _
recurrence As Recurrence, _
startTime As DateTime, _
endTime As DateTime _
)

Parameters

recurrence
A reference to the Recurrence object to be selected in the form for editing.
startTime
A .NET DateTime instance specifying the initial start time of the recurrence.
endTime
A .NET DateTime instance specifying the initial end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm Properties

RecurrenceForm Properties
[image]

Public Properties

Name | Description
EndTime | Gets the end time of the recurrence.
IsAppointmentDeleted | Gets a value indicating whether the user has deleted the edited appointment through the button in the form's toolbar.
Recurrence | Gets the recurrence being edited in this form.
StartTime | Gets the start time of the recurrence.
TimeFormat | Gets or sets the format of times displayed within the form.

See Also

RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.EndTime Property

RecurrenceForm.EndTime Property
[image]

Gets the end time of the recurrence.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the end time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.IsAppointmentDeleted Property

RecurrenceForm.IsAppointmentDeleted Property
[image]

Gets a value indicating whether the user has deleted the edited appointment through the button in the form's toolbar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public bool IsAppointmentDeleted { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsAppointmentDeleted As Boolean

Property Value

true if the user clicked the Delete button on the form; otherwise, false.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.Recurrence Property

RecurrenceForm.Recurrence Property
[image]

Gets the recurrence being edited in this form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Recurrence Recurrence { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class, which is being edited in the form.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.StartTime Property

RecurrenceForm.StartTime Property
[image]

Gets the start time of the recurrence.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object specifying the start time of the recurrence.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurrenceForm.TimeFormat Property

RecurrenceForm.TimeFormat Property
[image]

Gets or sets the format of times displayed within the form.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string TimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TimeFormat As String

Property Value

A string specifying the display format.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

RecurrenceForm Members
RecurrenceForm Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs Class

RecurringItemConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class RecurringItemConfirmEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class RecurringItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs

See Also

RecurringItemConfirmEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs Members

RecurringItemConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the RecurringItemDeleting event.

The following tables list the members exposed by the RecurringItemConfirmEventArgs type.

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs Properties

RecurringItemConfirmEventArgs Properties
[image]

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.
Item | Gets the item related to the event. (Inherited from ItemEventArgs.)

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs.ConfirmAll Property

RecurringItemConfirmEventArgs.ConfirmAll Property
[image]

Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ConfirmAll { get; set; }

Visual Basic [image] Copy Code

Public Property ConfirmAll As Boolean

Property Value

true to allow the operation for all occurrences of the recurring item.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.RecurringItemConfirmEventArgs.ConfirmOccurrence Property

RecurringItemConfirmEventArgs.ConfirmOccurrence Property
[image]

Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ConfirmOccurrence { get; set; }

Visual Basic [image] Copy Code

Public Property ConfirmOccurrence As Boolean

Property Value

true to allow the operation for the specified item's occurrence; otherwise, false.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands Class

ResizeBands Class
Remarks See Also
[image]

Represents the resize and move bands of items in a Timetable and Resource views.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ResizeBands : ContentControl

Visual Basic [image] Copy Code

Public Class ResizeBands
Inherits ContentControl

Remarks

This is a utility class used in the presentation of items.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Scheduling.Wpf.ResizeBands

See Also

ResizeBands Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands Members

ResizeBands Members
Constructors Fields Properties
[image]

Represents the resize and move bands of items in a Timetable and Resource views.

The following tables list the members exposed by the ResizeBands type.

Public Constructors

Name | Description
ResizeBands | Initializes a new instance of the ResizeBands class.

Public Fields

Name | Description
ItemSettingsProperty | Identifies the ItemSettings dependency property.
MoveBandMarginProperty | Identifies the MoveBandMargin dependency property.
MoveBandVisibilityProperty | Identifies the MoveBandVisibility dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ResizeBandsVisibleProperty | Identifies the ResizeBandsVisible dependency property.

Public Properties

Name | Description
ItemSettings | Gets or sets a reference to the Calendar.ItemSettings object.
MoveBandMargin | Gets or sets the margins of the item's move band. This is a dependency property.
MoveBandVisibility | Gets or sets a value indicating whether the move band is visible. This is a dependency property.
Orientation | Gets the orientation of the item the bands belong to.
ResizeBandsVisible | Gets a value indicating whether the bands should be displayed.

See Also

ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands Fields

ResizeBands Fields
[image]

Public Fields

Name | Description
ItemSettingsProperty | Identifies the ItemSettings dependency property.
MoveBandMarginProperty | Identifies the MoveBandMargin dependency property.
MoveBandVisibilityProperty | Identifies the MoveBandVisibility dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ResizeBandsVisibleProperty | Identifies the ResizeBandsVisible dependency property.

See Also

ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.ItemSettingsProperty Field

ResizeBands.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.MoveBandMarginProperty Field

ResizeBands.MoveBandMarginProperty Field
[image]

Identifies the MoveBandMargin dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandMarginProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.MoveBandVisibilityProperty Field

ResizeBands.MoveBandVisibilityProperty Field
[image]

Identifies the MoveBandVisibility dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandVisibilityProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.OrientationProperty Field

ResizeBands.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.ResizeBandsVisibleProperty Field

ResizeBands.ResizeBandsVisibleProperty Field
[image]

Identifies the ResizeBandsVisible dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeBandsVisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeBandsVisibleProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands Constructor

ResizeBands Constructor
[image]

Initializes a new instance of the ResizeBands class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResizeBands ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands Properties

ResizeBands Properties
[image]

Public Properties

Name | Description
ItemSettings | Gets or sets a reference to the Calendar.ItemSettings object.
MoveBandMargin | Gets or sets the margins of the item's move band. This is a dependency property.
MoveBandVisibility | Gets or sets a value indicating whether the move band is visible. This is a dependency property.
Orientation | Gets the orientation of the item the bands belong to.
ResizeBandsVisible | Gets a value indicating whether the bands should be displayed.

See Also

ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.ItemSettings Property

ResizeBands.ItemSettings Property
[image]

Gets or sets a reference to the Calendar.ItemSettings object.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

Remarks

This is a convenience property enabling item templates to bind to the ItemSettings directly.

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.MoveBandMargin Property

ResizeBands.MoveBandMargin Property
[image]

Gets or sets the margins of the item's move band. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Thickness MoveBandMargin { get; set; }

Visual Basic [image] Copy Code

Public Property MoveBandMargin As Thickness

Property Value

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.MoveBandVisibility Property

ResizeBands.MoveBandVisibility Property
[image]

Gets or sets a value indicating whether the move band is visible. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Visibility MoveBandVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property MoveBandVisibility As Visibility

Property Value

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.Orientation Property

ResizeBands.Orientation Property
[image]

Gets the orientation of the item the bands belong to.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResizeBands.ResizeBandsVisible Property

ResizeBands.ResizeBandsVisible Property
[image]

Gets a value indicating whether the bands should be displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ResizeBandsVisible { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeBandsVisible As Boolean

Property Value

See Also

ResizeBands Members
ResizeBands Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceDateEventArgs Class

ResourceDateEventArgs Class
[image]

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ResourceDateEventArgs : DateEventArgs

Visual Basic [image] Copy Code

Public Class ResourceDateEventArgs
Inherits DateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Wpf.DateEventArgs
MindFusion.Scheduling.Wpf.ResourceDateEventArgs

See Also

ResourceDateEventArgs Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceDateEventArgs Members

ResourceDateEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

The following tables list the members exposed by the ResourceDateEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounds of the cell. (Inherited from DateEventArgs.)
Clicks | Gets the number of clicks. (Inherited from DateEventArgs.)
Date | Gets the date and time associated with the event. (Inherited from DateEventArgs.)
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise. (Inherited from DateEventArgs.)
LeftButton | Gets a value indicating the state of the left mouse button. (Inherited from DateEventArgs.)
MiddleButton | Gets a value indicating the state of the middle mouse button. (Inherited from DateEventArgs.)
Resource | Gets the resource associated with the clicked cell.
RightButton | Gets a value indicating the state of the right mouse button. (Inherited from DateEventArgs.)

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceDateEventArgs Properties

ResourceDateEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounds of the cell. (Inherited from DateEventArgs.)
Clicks | Gets the number of clicks. (Inherited from DateEventArgs.)
Date | Gets the date and time associated with the event. (Inherited from DateEventArgs.)
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise. (Inherited from DateEventArgs.)
LeftButton | Gets a value indicating the state of the left mouse button. (Inherited from DateEventArgs.)
MiddleButton | Gets a value indicating the state of the middle mouse button. (Inherited from DateEventArgs.)
Resource | Gets the resource associated with the clicked cell.
RightButton | Gets a value indicating the state of the right mouse button. (Inherited from DateEventArgs.)

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceDateEventArgs.Resource Property

ResourceDateEventArgs.Resource Property
[image]

Gets the resource associated with the clicked cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

This is either null (Nothing in Visual Basic) or reference to a Resource, Contact, Location or Task object.

See Also

ResourceDateEventArgs Members
ResourceDateEventArgs Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader Class

ResourceHeader Class
[image]

Represents the header of a row in a Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ResourceHeader : Control

Visual Basic [image] Copy Code

Public Class ResourceHeader
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Wpf.ResourceHeader

See Also

ResourceHeader Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader Members

ResourceHeader Members
Constructors Fields Properties
[image]

Represents the header of a row in a Resource view.

The following tables list the members exposed by the ResourceHeader type.

Public Constructors

Name | Description
ResourceHeader | Initializes a new instance of the ResourceHeader class.

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.
ResourceProperty | Identifies the Resource dependency property.
SettingsProperty | Identifies the Settings dependency property.

Public Properties

Name | Description
Calendar | Gets the associated Calendar object. This is a dependency property.
IsExpanded | Gets or sets a value indicating whether the associated row is expanded. This is a dependency property.
Resource | Gets the Resource object corresponding to the underlying row. This is a dependency property.
Settings | Gets the ResourceViewSettings object. This is a dependency property.

See Also

ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader Fields

ResourceHeader Fields
[image]

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.
ResourceProperty | Identifies the Resource dependency property.
SettingsProperty | Identifies the Settings dependency property.

See Also

ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.CalendarProperty Field

ResourceHeader.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.IsExpandedProperty Field

ResourceHeader.IsExpandedProperty Field
[image]

Identifies the IsExpanded dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.ResourceProperty Field

ResourceHeader.ResourceProperty Field
[image]

Identifies the Resource dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceProperty As DependencyProperty

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.SettingsProperty Field

ResourceHeader.SettingsProperty Field
[image]

Identifies the Settings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SettingsProperty As DependencyProperty

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader Constructor

ResourceHeader Constructor
[image]

Initializes a new instance of the ResourceHeader class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader Properties

ResourceHeader Properties
[image]

Public Properties

Name | Description
Calendar | Gets the associated Calendar object. This is a dependency property.
IsExpanded | Gets or sets a value indicating whether the associated row is expanded. This is a dependency property.
Resource | Gets the Resource object corresponding to the underlying row. This is a dependency property.
Settings | Gets the ResourceViewSettings object. This is a dependency property.

See Also

ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.Calendar Property

ResourceHeader.Calendar Property
[image]

Gets the associated Calendar object. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.IsExpanded Property

ResourceHeader.IsExpanded Property
[image]

Gets or sets a value indicating whether the associated row is expanded. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Public Property IsExpanded As Boolean

Property Value

true, to expand the associated row; false, to collapse it.

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.Resource Property

ResourceHeader.Resource Property
[image]

Gets the Resource object corresponding to the underlying row. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or a Resource-derived class.

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceHeader.Settings Property

ResourceHeader.Settings Property
[image]

Gets the ResourceViewSettings object. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceViewSettings Settings { get; set; }

Visual Basic [image] Copy Code

Public Property Settings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

ResourceHeader Members
ResourceHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter Class

ResourceNameConverter Class
[image]

Converts ResourceHeader objects to readable strings representing their underlying resource.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class ResourceNameConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ResourceNameConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Wpf.ResourceNameConverter

See Also

ResourceNameConverter Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter Members

ResourceNameConverter Members
Constructors Methods
[image]

Converts ResourceHeader objects to readable strings representing their underlying resource.

The following tables list the members exposed by the ResourceNameConverter type.

Public Constructors

Name | Description
ResourceNameConverter | Initializes a new instance of the ResourceNameConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ResourceNameConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter Constructor

ResourceNameConverter Constructor
[image]

Initializes a new instance of the ResourceNameConverter class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceNameConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceNameConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter Methods

ResourceNameConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ResourceNameConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter.Convert Method

ResourceNameConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ResourceNameConverter Members
ResourceNameConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceNameConverter.ConvertBack Method

ResourceNameConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

ResourceNameConverter Members
ResourceNameConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings Class

ResourceViewSettings Class
Remarks See Also
[image]

Defines properties that allow customizing the visualization of the calendar in Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class ResourceViewSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class ResourceViewSettings
Inherits CalendarSettings

Remarks

An instance of this class can be accessed through the ResourceViewSettings property of the Calendar class.

The settings for the timelines displayed in the Resource view are exposed through the BottomTimelineSettings, MiddleTimelineSettings and TopTimelineSettings properties. The BottomTimelineSettings are important because the resolution of the bottom timeline also determines the resolution of the view. For example, if the cells of the bottom timeline display one week intervals, the cells of the view display one week intervals as well.

The resource view supports two modes - general and lanes, according to the value of the ViewStyle property. In general mode, the size of the rows, corresponding to the individual resources displayed in the view, is fixed (as specified by VisibleRows). The colliding items are resized to fit within the available space. In lanes mode, the size of the resource rows is dynamic. When two or more items collide, each item is distributed in its own lane. The more items colliding, the more lanes are added to the resource row. The size of each individual lane is specified through the LaneSize property.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.ResourceViewSettings

See Also

ResourceViewSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings Members

ResourceViewSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in Resource view.

The following tables list the members exposed by the ResourceViewSettings type.

Public Constructors

Name | Description
ResourceViewSettings | Initializes a new instance of the ResourceViewSettings class.

Public Fields

Name | Description
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
ExpandableRowsProperty | Identifies the ExpandableRows dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GroupRowHeaderProperty | Identifies the GroupRowHeader dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
LaneSizeProperty | Identifies the LaneSize dependency property.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
RowHeaderSizeProperty | Identifies the RowHeaderSize dependency property.
RowHeaderTemplateProperty | Identifies the RowHeaderTemplate dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
TickSizeProperty | Identifies the TickSize dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.
WeekendStyleProperty | Identifies the WeekendStyle dependency property.

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of the unit cells.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
RowHeaderSize | Gets or sets the size of the row header.
RowHeaderTemplate | Gets or sets the template of the row headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.
SelectedElementsStyle | Gets or sets the style of the weekend cells.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleRows | Gets or sets the number of resources to display simultaneously when ViewStyle is set to General. This is a dependency property.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings Fields

ResourceViewSettings Fields
[image]

Public Fields

Name | Description
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
ExpandableRowsProperty | Identifies the ExpandableRows dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GroupRowHeaderProperty | Identifies the GroupRowHeader dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
LaneSizeProperty | Identifies the LaneSize dependency property.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
RowHeaderSizeProperty | Identifies the RowHeaderSize dependency property.
RowHeaderTemplateProperty | Identifies the RowHeaderTemplate dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
TickSizeProperty | Identifies the TickSize dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.
WeekendStyleProperty | Identifies the WeekendStyle dependency property.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.BottomTimelineSettingsProperty Field

ResourceViewSettings.BottomTimelineSettingsProperty Field
[image]

Identifies the BottomTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BottomTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BottomTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.CalendarStyleProperty Field

ResourceViewSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.CellSizeProperty Field

ResourceViewSettings.CellSizeProperty Field
[image]

Identifies the CellSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.CellStyleProperty Field

ResourceViewSettings.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.EnableSnappingProperty Field

ResourceViewSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.ExpandableRowsProperty Field

ResourceViewSettings.ExpandableRowsProperty Field
[image]

Identifies the ExpandableRows dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandableRowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandableRowsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.ExpandActiveItemOnProperty Field

ResourceViewSettings.ExpandActiveItemOnProperty Field
[image]

Identifies the ExpandActiveItemOn dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandActiveItemOnProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandActiveItemOnProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.GroupRowHeaderProperty Field

ResourceViewSettings.GroupRowHeaderProperty Field
[image]

Identifies the GroupRowHeader dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupRowHeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupRowHeaderProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.HeaderStyleProperty Field

ResourceViewSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.LaneSizeProperty Field

ResourceViewSettings.LaneSizeProperty Field
[image]

Identifies the LaneSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LaneSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LaneSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.MiddleTimelineSettingsProperty Field

ResourceViewSettings.MiddleTimelineSettingsProperty Field
[image]

Identifies the MiddleTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MiddleTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MiddleTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.MinItemSizeProperty Field

ResourceViewSettings.MinItemSizeProperty Field
[image]

Identifies the MinItemSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinItemSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinItemSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.RowHeaderSizeProperty Field

ResourceViewSettings.RowHeaderSizeProperty Field
[image]

Identifies the RowHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowHeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowHeaderSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.RowHeaderTemplateProperty Field

ResourceViewSettings.RowHeaderTemplateProperty Field
[image]

Identifies the RowHeaderTemplate dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowHeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RowHeaderTemplateProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.SelectedElementsStyleProperty Field

ResourceViewSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.SnapUnitCountProperty Field

ResourceViewSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.SnapUnitProperty Field

ResourceViewSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.TimelinesProperty Field

ResourceViewSettings.TimelinesProperty Field
[image]

Identifies the Timelines dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelinesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelinesProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.TopTimelineSettingsProperty Field

ResourceViewSettings.TopTimelineSettingsProperty Field
[image]

Identifies the TopTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopTimelineSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.ViewStyleProperty Field

ResourceViewSettings.ViewStyleProperty Field
[image]

Identifies the ViewStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ViewStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ViewStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.VisibleRowsProperty Field

ResourceViewSettings.VisibleRowsProperty Field
[image]

Identifies the VisibleRows dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleRowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleRowsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.WeekendStyleProperty Field

ResourceViewSettings.WeekendStyleProperty Field
[image]

Identifies the WeekendStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekendStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekendStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.TickSizeProperty Field

ResourceViewSettings.TickSizeProperty Field
[image]

Identifies the TickSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings Constructor

ResourceViewSettings Constructor
[image]

Initializes a new instance of the ResourceViewSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceViewSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings Properties

ResourceViewSettings Properties
[image]

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of the unit cells.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
RowHeaderSize | Gets or sets the size of the row header.
RowHeaderTemplate | Gets or sets the template of the row headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.
SelectedElementsStyle | Gets or sets the style of the weekend cells.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleRows | Gets or sets the number of resources to display simultaneously when ViewStyle is set to General. This is a dependency property.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.BottomTimelineSettings Property

ResourceViewSettings.BottomTimelineSettings Property
[image]

Gets the settings for the bottom timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings BottomTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property BottomTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.CalendarStyle Property

ResourceViewSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.CellSize Property

ResourceViewSettings.CellSize Property
[image]

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int CellSize { get; set; }

Visual Basic [image] Copy Code

Public Property CellSize As Integer

Property Value

An integer value specifying the size of the cells, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.CellStyle Property

ResourceViewSettings.CellStyle Property
[image]

Gets or sets the style of the unit cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
WeekendStyle Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.EnableSnapping Property

ResourceViewSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

true, to enable custom snapping; otherwise false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If custom snapping is disabled, interactions with the items will automatically align the items to the cells of the view. If custom snapping is enabled, the items are aligned to a virtual grid defined by the SnapUnit and SnapUnitCount properties.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.ExpandableRows Property

ResourceViewSettings.ExpandableRows Property
[image]

Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ExpandableRows { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandableRows As Boolean

Property Value

true, to display expand/collapse icons in the headers of resource rows; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is only used if the view style is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.ExpandActiveItemOn Property

ResourceViewSettings.ExpandActiveItemOn Property
[image]

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemAction ExpandActiveItemOn { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This only works if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.GroupRowHeader Property

ResourceViewSettings.GroupRowHeader Property
[image]

Gets or sets a value indicating whether the rows display the header as a group header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool GroupRowHeader { get; set; }

Visual Basic [image] Copy Code

Public Property GroupRowHeader As Boolean

Property Value

true, to display row headers to the left of the rows; false, to display row headers above the rows.

Remarks

This property is only used if the view style is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.HeaderStyle Property

ResourceViewSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.LaneSize Property

ResourceViewSettings.LaneSize Property
[image]

Gets or sets the size of a single lane.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int LaneSize { get; set; }

Visual Basic [image] Copy Code

Public Property LaneSize As Integer

Property Value

An integer value specifying the size of the lanes, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is only used when the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
RowSize Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.MiddleTimelineSettings Property

ResourceViewSettings.MiddleTimelineSettings Property
[image]

Gets the settings for the middle timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings MiddleTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
BottomTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.MinItemSize Property

ResourceViewSettings.MinItemSize Property
[image]

Gets or sets the smallest size allowed for resource items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MinItemSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimum item size, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If there is not enough space in a row to display all related items, the items that do not fit remain invisible. This property is only used if the view style is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.RowHeaderSize Property

ResourceViewSettings.RowHeaderSize Property
[image]

Gets or sets the size of the row header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int RowHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeaderSize As Integer

Property Value

An integer value specifying the size of the row headers, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The size of a header is used only when GroupRowHeader is enabled. Otherwise, the size of the header equals LaneSize.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.RowHeaderTemplate Property

ResourceViewSettings.RowHeaderTemplate Property
[image]

Gets or sets the template of the row headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DataTemplate RowHeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeaderTemplate As DataTemplate

Property Value

An instance of the WPF DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<DataTemplate>
<TextBlock Text="{Binding HeaderText}" />
</DataTemplate>

In addition to HeaderText, which contains the default text displayed in the row header, the properties of the template can also bind to Resource and Calendar, which reference the related Resource object and the Calendar control respectively.

Example

The following example demonstrates a custom row header template which displays an image along with the header text. The image is specified through the Tag property of the resource.

XAML [image] Copy Code

<DataTemplate>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
</Grid.ColumnDefinitions>
<Image Source="{Binding Resource.Tag}" MaxHeight="48" MaxWidth="48" Margin="2" />
<TextBlock Text="{Binding HeaderText}" Grid.Column="1" VerticalAlignment="Center" />
</Grid>
</DataTemplate>

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.SelectedElementsStyle Property

ResourceViewSettings.SelectedElementsStyle Property
[image]

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.SnapUnit Property

ResourceViewSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Remarks

This property works in conjunction with SnapUnitCount when EnableSnapping is set to true. These properties specify a virtual grid to which the items are aligned when modified interactively. If custom snapping is disabled, the items are aligned to the cells of the view.

To completely disable snapping, specify custom snapping with very small resolution - for example, one second.

Example

The following example disables snapping:

C# [image] Copy Code
calendar.ResourceViewSettings.EnableSnapping = true;
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second;
calendar.ResourceViewSettings.SnapUnitCount = 1;
Visual Basic [image] Copy Code
calendar.ResourceViewSettings.EnableSnapping = True
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second
calendar.ResourceViewSettings.SnapUnitCount = 1

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnitCount Property
EnableSnapping Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.SnapUnitCount Property

ResourceViewSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

An integer value specifying the number of units.

Remarks

This property works in conjunction with SnapUnit when EnableSnapping is set to true. These properties specify a virtual grid to which the items are aligned when modified interactively. If custom snapping is disabled, the items are aligned to the cells of the view.

To completely disable snapping, specify custom snapping with very small resolution - for example, one second.

Example

The following example disables snapping:

C# [image] Copy Code
calendar.ResourceViewSettings.EnableSnapping = true;
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second;
calendar.ResourceViewSettings.SnapUnitCount = 1;
Visual Basic [image] Copy Code
calendar.ResourceViewSettings.EnableSnapping = True
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second
calendar.ResourceViewSettings.SnapUnitCount = 1

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.Timelines Property

ResourceViewSettings.Timelines Property
[image]

Gets or sets the number of timelines displayed in the view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Timelines { get; set; }

Visual Basic [image] Copy Code

Public Property Timelines As Integer

Property Value

An integer value specifying the number of timelines.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The timelines are displayed from bottom to top. A value of 1 displays only the bottom timeline, a value of 2 displays the bottom and middle timelines and a value of 3 displays all three timelines.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.TopTimelineSettings Property

ResourceViewSettings.TopTimelineSettings Property
[image]

Gets the settings for the top timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings TopTimelineSettings { get; set; }

Visual Basic [image] Copy Code

Public Property TopTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.ViewStyle Property

ResourceViewSettings.ViewStyle Property
[image]

Gets or sets the style of the view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ResourceViewStyle ViewStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ViewStyle As ResourceViewStyle

Property Value

A member of the ResourceViewStyle enumeration.

Remarks

The resource view supports two modes - general and lanes, according to the value of the ViewStyle property. In general mode, the size of the rows, corresponding to the individual resources displayed in the view, is fixed (as specified by VisibleRows). The colliding items are resized to fit within the available space. In lanes mode, the size of the resource rows is dynamic. When two or more items collide, each item is distributed in its own lane. The more items colliding, the more lanes are added to the resource row. The size of each individual lane is specified through the LaneSize property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.VisibleRows Property

ResourceViewSettings.VisibleRows Property
[image]

Gets or sets the number of resources to display simultaneously when ViewStyle is set to General. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewSettings.WeekendStyle Property

ResourceViewSettings.WeekendStyle Property
[image]

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle WeekendStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WeekendStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace
CellStyle Property


MindFusion.Scheduling.Wpf.ResourceViewSettings.TickSize Property

ResourceViewSettings.TickSize Property
[image]

Gets or sets the size of the ticks displayed in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int TickSize { get; set; }

Visual Basic [image] Copy Code

Public Property TickSize As Integer

Property Value

An integer value specifying the size of the timeline ticks, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ResourceViewStyle Enumeration

ResourceViewStyle Enumeration
[image]

Specifies the style of a Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum ResourceViewStyle

Visual Basic [image] Copy Code

Public Enum ResourceViewStyle

Members

Member name | Description
General | Each row in a Resource view has a fixed width. The items within the row are positioned much like in a Timetable view.
Lanes | Each row in a Resource view displays one or more lanes where items are positioned. More lanes are added automatically to respect the requirement that all overlapping items are on separate lanes.

Remarks

A value of this enumeration is assigned to the ViewStyle property of the ResourceViewSettings class.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Class

Selection Class
[image]

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class Selection :

Visual Basic [image] Copy Code

Public NotInheritable Class Selection
Inherits

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Freezable
System.Windows.Media.Animation.Animatable
MindFusion.Scheduling.Wpf.Selection

See Also

Selection Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Members

Selection Members
Constructors Fields Properties Methods Events
[image]

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

The following tables list the members exposed by the Selection type.

Public Constructors

Name | Description
Selection | Initializes a new instance of the Selection class.

Public Fields

Name | Description
AllowMultipleProperty | Identifies the AllowMultiple dependency property.
ContinuousProperty | Identifies the Continuous dependency property.

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
Intersects | Determines whether the specified range is partially contained within one of the date ranges.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Protected Methods

Name | Description
CreateInstanceCore | Freezable.CreateInstanceCore override.

Public Events

Name | Description
Changed | Fired when the selection has changed;

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Fields

Selection Fields
[image]

Public Fields

Name | Description
AllowMultipleProperty | Identifies the AllowMultiple dependency property.
ContinuousProperty | Identifies the Continuous dependency property.

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.AllowMultipleProperty Field

Selection.AllowMultipleProperty Field
[image]

Identifies the AllowMultiple dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty AllowMultipleProperty

Visual Basic [image] Copy Code

Public Shared AllowMultipleProperty As DependencyProperty

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.ContinuousProperty Field

Selection.ContinuousProperty Field
[image]

Identifies the Continuous dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty ContinuousProperty

Visual Basic [image] Copy Code

Public Shared ContinuousProperty As DependencyProperty

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Constructor

Selection Constructor
[image]

Initializes a new instance of the Selection class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Selection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
Intersects | Determines whether the specified range is partially contained within one of the date ranges.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Protected Methods

Name | Description
CreateInstanceCore | Freezable.CreateInstanceCore override.

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Add Method

Selection.Add Method
[image]

Adds the specified date or range of dates to the selection.

Overload List

Name | Description
Selection.Add (DateTime) | Adds the specified date to the selection.
Selection.Add (DateTime, DateTime) | Adds the specified date range to the selection.
Selection.Add (DateTime, DateTime, Contact, Resource, Location, Task) | Adds the specified date range to the selection of the specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Add Method (DateTime)

Selection.Add Method (DateTime)
See Also
[image]

Adds the specified date to the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Add (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Add( _
date As DateTime _
)

Parameters

date

The date to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Add Method (DateTime, DateTime)

Selection.Add Method (DateTime, DateTime)
See Also
[image]

Adds the specified date range to the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Add( _
start As DateTime, _
end As DateTime _
)

Parameters

start

The start of the time range to be added to the selection.

end

The end of the time range to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Adds the specified date range to the selection of the specified resource.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)

Visual Basic [image] Copy Code

Public Sub Add ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start

The start of the time range to be added to the selection.

end

The end of the time range to be added to the selection.

contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Contains Method

Selection.Contains Method
[image]

Determines whether the specified date is currently selected.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
DateTime date
)

Visual Basic [image] Copy Code

Public Function Contains( _
date As DateTime _
) As Boolean

Parameters

date

A date to search for in the selection.

Return Value

true if the date's cell is selected; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.CreateInstanceCore Method

Selection.CreateInstanceCore Method
[image]

Freezable.CreateInstanceCore override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

protected override Freezable CreateInstanceCore ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateInstanceCore () As Freezable

Return Value

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Intersects Method

Selection.Intersects Method
[image]

Determines whether the specified range is partially contained within one of the date ranges.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Intersects (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Function Intersects( _
start As DateTime, _
end As DateTime _
) As Boolean

Parameters

start
The start date of the interval to check.
end
The end date of the interval to check.

Return Value

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Remove Method

Selection.Remove Method
[image]

Removes the specified date or range of dates from the selection.

Overload List

Name | Description
Selection.Remove (DateTime) | Removes the specified date from the selection.
Selection.Remove (DateTime, DateTime) | Removes the specified date range from the selection.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Remove Method (DateTime)

Selection.Remove Method (DateTime)
See Also
[image]

Removes the specified date from the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Remove (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Remove( _
date As DateTime _
)

Parameters

date
The date to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Remove Method (DateTime, DateTime)

Selection.Remove Method (DateTime, DateTime)
See Also
[image]

Removes the specified date range from the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Remove (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Remove( _
start As DateTime, _
end As DateTime _
)

Parameters

start

The start of the time range to be removed from the selection.

end

The end of the time range to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Reset Method

Selection.Reset Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Set Method

Selection.Set Method
[image]

Sets the current selection to the specified date or range of dates.

Overload List

Name | Description
Selection.Set (DateTime) | Selects the specified date cell.
Selection.Set (DateTime, DateTime) | Selects a range of date cells.
Selection.Set (DateTime, DateTime, Contact, Resource, Location, Task) | Selects a range of date cells for a specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Set Method (DateTime)

Selection.Set Method (DateTime)
See Also
[image]

Selects the specified date cell.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Set (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Set( _
date As DateTime _
)

Parameters

date

A date whose calendar cell to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Set Method (DateTime, DateTime)

Selection.Set Method (DateTime, DateTime)
See Also
[image]

Selects a range of date cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Set( _
start As DateTime, _
end As DateTime _
)

Parameters

start

Specifies the first date in the range.

end

Specifies the last date in the range.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Selects a range of date cells for a specified resource.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)

Visual Basic [image] Copy Code

Public Sub Set ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start

Specifies the first date in the range.

end

Specifies the last date in the range.

contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.AllowMultiple Property

Selection.AllowMultiple Property
[image]

Gets or sets a value indicating whether users are allowed to select multiple elements at a time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool AllowMultiple { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultiple As Boolean

Property Value

true to allow multiple selection; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Contact Property

Selection.Contact Property
[image]

Gets the contact related to the current selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Contact Contact { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contact As Contact

Property Value

The contact related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a contact.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace
Location Property
Resource Property
Task Property


MindFusion.Scheduling.Wpf.Selection.Continuous Property

Selection.Continuous Property
[image]

Gets or sets a value indicating whether users can select only one range of dates in the calendar.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool Continuous { get; set; }

Visual Basic [image] Copy Code

Public Property Continuous As Boolean

Property Value

true to prevent users from selecting more than one, continuous range of dates in the control; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.IsEmpty Property

Selection.IsEmpty Property
[image]

Gets a value indicating whether this selection is empty.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if there are selected calendar cells; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Location Property

Selection.Location Property
[image]

Gets the location related to the current selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Location Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Location

Property Value

The location related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a location.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace
Contact Property
Resource Property
Task Property


MindFusion.Scheduling.Wpf.Selection.Ranges Property

Selection.Ranges Property
[image]

Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public IList<DateTime> Ranges { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Ranges As IList(Of DateTime)

Property Value

An instance of an IList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove time intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Resource Property

Selection.Resource Property
[image]

Gets the resource related to the current selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

The resource related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace
Contact Property
Location Property
Task Property


MindFusion.Scheduling.Wpf.Selection.Task Property

Selection.Task Property
[image]

Gets the task related to the current selection.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Task Task { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

The task related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a task.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace
Contact Property
Location Property
Resource Property


MindFusion.Scheduling.Wpf.Selection Events

Selection Events
[image]

Public Events

Name | Description
Changed | Fired when the selection has changed;

See Also

Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Selection.Changed Event

Selection.Changed Event
[image]

Fired when the selection has changed;

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.SideBorders Class

SideBorders Class
Remarks See Also
[image]

Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class SideBorders : ContentControl

Visual Basic [image] Copy Code

Public Class SideBorders
Inherits ContentControl

Remarks

This is a utility class used in the presentation of items.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Scheduling.Wpf.SideBorders

See Also

SideBorders Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.SideBorders Members

SideBorders Members
Constructors
[image]

Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.

The following tables list the members exposed by the SideBorders type.

Public Constructors

Name | Description
SideBorders | Initializes a new instance of the SideBorders class.

See Also

SideBorders Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.SideBorders Constructor

SideBorders Constructor
[image]

Initializes a new instance of the SideBorders class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public SideBorders ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SideBorders Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.ThemeType Enumeration

ThemeType Enumeration
[image]

Specifies a calendar theme.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum ThemeType

Visual Basic [image] Copy Code

Public Enum ThemeType

Members

Member name | Description
Light | The Light theme.
Lila | The Lila theme.
Silver | The Silver theme.
Standard | The standard theme.
Vista | The Vista theme.
Windows2003 | The Windows 2003 standard theme.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Class

TimelineHeader Class
[image]

Represents the left part of the timeline header in a Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class TimelineHeader : Control

Visual Basic [image] Copy Code

Public Class TimelineHeader
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Wpf.TimelineHeader

See Also

TimelineHeader Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Members

TimelineHeader Members
Constructors Fields Properties Methods
[image]

Represents the left part of the timeline header in a Resource view.

The following tables list the members exposed by the TimelineHeader type.

Public Constructors

Name | Description
TimelineHeader | Initializes a new instance of the TimelineHeader class.

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
SettingsProperty | Identifies the Settings dependency property.

Public Properties

Name | Description
Calendar | Gets the associated Calendar object. This is a dependency property.
Settings | Gets the TimelineSettings object corresponding to the timeline this header is associated with. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Fields

TimelineHeader Fields
[image]

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
SettingsProperty | Identifies the Settings dependency property.

See Also

TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader.CalendarProperty Field

TimelineHeader.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader.SettingsProperty Field

TimelineHeader.SettingsProperty Field
[image]

Identifies the Settings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SettingsProperty As DependencyProperty

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Constructor

TimelineHeader Constructor
[image]

Initializes a new instance of the TimelineHeader class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Methods

TimelineHeader Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader.OnApplyTemplate Method

TimelineHeader.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader Properties

TimelineHeader Properties
[image]

Public Properties

Name | Description
Calendar | Gets the associated Calendar object. This is a dependency property.
Settings | Gets the TimelineSettings object corresponding to the timeline this header is associated with. This is a dependency property.

See Also

TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader.Calendar Property

TimelineHeader.Calendar Property
[image]

Gets the associated Calendar object. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineHeader.Settings Property

TimelineHeader.Settings Property
[image]

Gets the TimelineSettings object corresponding to the timeline this header is associated with. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings Settings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Settings As TimelineSettings

Property Value

An instance of the TimetableSettings class.

See Also

TimelineHeader Members
TimelineHeader Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings Class

TimelineSettings Class
Remarks See Also
[image]

Encapsulates settings for a timeline in a Resource view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class TimelineSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class TimelineSettings
Inherits CalendarSettings

Remarks

This class provides various properties which can be used for customizing the timelines in a Resource view. The settings for the individual timelines can be accessed through the BottomTimelineSettings, MiddleTimelineSettings and TopTimelineSettings of the ResourceViewSettings class respectively.

The Unit and UnitCount properties specify the resolution of the timeline. For example, specifying Day for Unit and 2 for UnitCount will divide the timeline into cells representing 2 days intervals each. The resolution of the bottom timeline also determines the resolution of the view. The dates displayed in the timeline cells are formatted according to the Format property.

To modify the appearance of the timeline, use the CalendarStyle property.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.TimelineSettings

See Also

TimelineSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings Members

TimelineSettings Members
Constructors Fields Properties
[image]

Encapsulates settings for a timeline in a Resource view.

The following tables list the members exposed by the TimelineSettings type.

Public Constructors

Name | Description
TimelineSettings | Initializes a new instance of the TimelineSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FormatProperty | Identifies the Format dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
SizeProperty | Identifies the Size dependency property.
UnitCountProperty | Identifies the UnitCount dependency property.
UnitProperty | Identifies the Unit dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the style of the timeline.
Format | Gets or sets the format of the displayed dates in the timeline.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
Size | Gets or sets the size of the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings Fields

TimelineSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FormatProperty | Identifies the Format dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
SizeProperty | Identifies the Size dependency property.
UnitCountProperty | Identifies the UnitCount dependency property.
UnitProperty | Identifies the Unit dependency property.

See Also

TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.CalendarStyleProperty Field

TimelineSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.FormatProperty Field

TimelineSettings.FormatProperty Field
[image]

Identifies the Format dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.NowBrushProperty Field

TimelineSettings.NowBrushProperty Field
[image]

Identifies the NowBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NowBrushProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.NowFillBrushProperty Field

TimelineSettings.NowFillBrushProperty Field
[image]

Identifies the NowFillBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowFillBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NowFillBrushProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.ShowCurrentTimeProperty Field

TimelineSettings.ShowCurrentTimeProperty Field
[image]

Identifies the ShowCurrentTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCurrentTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCurrentTimeProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.SizeProperty Field

TimelineSettings.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.UnitCountProperty Field

TimelineSettings.UnitCountProperty Field
[image]

Identifies the UnitCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UnitCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly UnitCountProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.UnitProperty Field

TimelineSettings.UnitProperty Field
[image]

Identifies the Unit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UnitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly UnitProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings Constructor

TimelineSettings Constructor
[image]

Initializes a new instance of the TimelineSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimelineSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings Properties

TimelineSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the style of the timeline.
Format | Gets or sets the format of the displayed dates in the timeline.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
Size | Gets or sets the size of the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.CalendarStyle Property

TimelineSettings.CalendarStyle Property
[image]

Gets or sets the style of the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Example

The following example changes the background brush of the bottom timeline. The example assumes that calendar is a variable referencing existing Calendar instance.

C# [image] Copy Code
calendar.ResourceViewSettings.BottomTimelineSettings.CalendarStyle.Background = Brushes.LightSteelBlue;
Visual Basic [image] Copy Code
calendar.ResourceViewSettings.BottomTimelineSettings.CalendarStyle.Background = Brushes.LightSteelBlue

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.Format Property

TimelineSettings.Format Property
[image]

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

Example

The following example sets the resolution of the bottom timeline to one hour and the display format to "HH:mm". The example assumes that calendar is a valid reference to a Calendar instance.

C# [image] Copy Code
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm";
Visual Basic [image] Copy Code
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm"

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.NowBrush Property

TimelineSettings.NowBrush Property
[image]

Gets or sets the brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush NowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property NowBrush As Brush

Property Value

A .NET Brush instance used to draw the current time indicator.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace
NowFillBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Wpf.TimelineSettings.NowFillBrush Property

TimelineSettings.NowFillBrush Property
[image]

Gets or sets the fill brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush NowFillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property NowFillBrush As Brush

Property Value

A .NET Brush instance specifying the background of the current time indicator.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace
NowBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Wpf.TimelineSettings.ShowCurrentTime Property

TimelineSettings.ShowCurrentTime Property
[image]

Gets or sets a value indicating whether to indicate the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowCurrentTime { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCurrentTime As Boolean

Property Value

true to display the current time; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The current time is rendered using the brushes specified by the NowBrush and NowFillBrush properties.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace
NowBrush Property
NowFillBrush Property


MindFusion.Scheduling.Wpf.TimelineSettings.Size Property

TimelineSettings.Size Property
[image]

Gets or sets the size of the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

An integer value specifying the size of the timeline in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimelineSettings.Unit Property

TimelineSettings.Unit Property
[image]

Gets or sets the time unit of the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property in conjunction with the UnitCount property specifies the resolution of the timeline.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace
UnitCount Property


MindFusion.Scheduling.Wpf.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property
[image]

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int UnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property UnitCount As Integer

Property Value

An integer value specifying the number of units.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property in conjunction with the Unit property specifies the resolution of the timeline.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Wpf Namespace
Unit Property


MindFusion.Scheduling.Wpf.TimetableSettings Class

TimetableSettings Class
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public sealed class TimetableSettings : CalendarSettings

Visual Basic [image] Copy Code

Public NotInheritable Class TimetableSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.TimetableSettings

See Also

TimetableSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings Members

TimetableSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

The following tables list the members exposed by the TimetableSettings type.

Public Constructors

Name | Description
TimetableSettings | Initializes a new instance of the TimetableSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
CellTimeProperty | Identifies the CellTime dependency property.
ColumnBandSizeProperty | Identifies the ColumnBandSize dependency property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate dependency property.
DatesProperty | Identifies the Dates dependency property.
DayHeaderMinSizeProperty | Identifies the DayHeaderMinSize dependency property.
EnableCollisionsProperty | Identifies the EnableCollisions dependency property.
EnableDayItemsProperty | Identifies the EnableDayItems dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
GroupHoursProperty | Identifies the GroupHours dependency property.
HeaderDateFormatProperty | Identifies the HeaderDateFormat dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
ItemOffsetProperty | Identifies the ItemOffset dependency property.
MainHeaderSizeProperty | Identifies the MainHeaderSize dependency property.
MaxAllDayItemsProperty | Identifies the MaxAllDayItems dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
MinuteFormatProperty | Identifies the MinuteFormat dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ReverseGroupingProperty | Identifies the ReverseGrouping dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
RotateTimelineTextsProperty | Identifies the RotateTimelineTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SecondTimelineOffsetProperty | Identifies the SecondTimelineOffset dependency property.
SecondTimelinePositionProperty | Identifies the SecondTimelinePosition dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SelectWholeDayOnHeaderClickProperty | Identifies the SelectWholeDayOnHeaderClick dependency property.
ShowAMProperty | Identifies the ShowAM dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
ShowDayHeaderProperty | Identifies the ShowDayHeader dependency property.
ShowItemSpansProperty | Identifies the ShowItemSpans dependency property.
ShowMinutesInHourHeadersProperty | Identifies the ShowMinutesInHourHeaders dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
ShowWorkTimeProperty | Identifies the ShowWorkTime dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimelineSizeProperty | Identifies the TimelineSize dependency property.
TimelineStyleProperty | Identifies the TimelineStyle dependency property.
TwelveHourFormatProperty | Identifies the TwelveHourFormat dependency property.
WorkTimeCellStyleProperty | Identifies the WorkTimeCellStyle dependency property.
WorkTimeEndProperty | Identifies the WorkTimeEnd dependency property.
WorkTimeEndsProperty | Identifies the WorkTimeEnds dependency property.
WorkTimeStartProperty | Identifies the WorkTimeStart dependency property.
WorkTimeStartsProperty | Identifies the WorkTimeStarts dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cells.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
ColumnHeaderTemplate | Gets or sets the template of the column headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelinePosition | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectedElementsStyle | Gets or sets the appearance of selected cells.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
SubHeaderSize | Gets or sets the size of the secondary header.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEnd | Gets or sets the end of the work time interval.
WorkTimeEnds | Gets or sets the end of the work time interval for each date displayed in the view.
WorkTimeStart | Gets or sets the start of the work time interval.
WorkTimeStarts | Gets or sets the start of the work time interval for each date displayed in the view.

See Also

TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings Fields

TimetableSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
CellTimeProperty | Identifies the CellTime dependency property.
ColumnBandSizeProperty | Identifies the ColumnBandSize dependency property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate dependency property.
DatesProperty | Identifies the Dates dependency property.
DayHeaderMinSizeProperty | Identifies the DayHeaderMinSize dependency property.
EnableCollisionsProperty | Identifies the EnableCollisions dependency property.
EnableDayItemsProperty | Identifies the EnableDayItems dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
GroupHoursProperty | Identifies the GroupHours dependency property.
HeaderDateFormatProperty | Identifies the HeaderDateFormat dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
ItemOffsetProperty | Identifies the ItemOffset dependency property.
MainHeaderSizeProperty | Identifies the MainHeaderSize dependency property.
MaxAllDayItemsProperty | Identifies the MaxAllDayItems dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
MinuteFormatProperty | Identifies the MinuteFormat dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ReverseGroupingProperty | Identifies the ReverseGrouping dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
RotateTimelineTextsProperty | Identifies the RotateTimelineTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SecondTimelineOffsetProperty | Identifies the SecondTimelineOffset dependency property.
SecondTimelinePositionProperty | Identifies the SecondTimelinePosition dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SelectWholeDayOnHeaderClickProperty | Identifies the SelectWholeDayOnHeaderClick dependency property.
ShowAMProperty | Identifies the ShowAM dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
ShowDayHeaderProperty | Identifies the ShowDayHeader dependency property.
ShowItemSpansProperty | Identifies the ShowItemSpans dependency property.
ShowMinutesInHourHeadersProperty | Identifies the ShowMinutesInHourHeaders dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
ShowWorkTimeProperty | Identifies the ShowWorkTime dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimelineSizeProperty | Identifies the TimelineSize dependency property.
TimelineStyleProperty | Identifies the TimelineStyle dependency property.
TwelveHourFormatProperty | Identifies the TwelveHourFormat dependency property.
WorkTimeCellStyleProperty | Identifies the WorkTimeCellStyle dependency property.
WorkTimeEndProperty | Identifies the WorkTimeEnd dependency property.
WorkTimeEndsProperty | Identifies the WorkTimeEnds dependency property.
WorkTimeStartProperty | Identifies the WorkTimeStart dependency property.
WorkTimeStartsProperty | Identifies the WorkTimeStarts dependency property.

See Also

TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CalendarStyleProperty Field

TimetableSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CellSizeProperty Field

TimetableSettings.CellSizeProperty Field
[image]

Identifies the CellSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CellStyleProperty Field

TimetableSettings.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CellTimeProperty Field

TimetableSettings.CellTimeProperty Field
[image]

Identifies the CellTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ColumnBandSizeProperty Field

TimetableSettings.ColumnBandSizeProperty Field
[image]

Identifies the ColumnBandSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColumnBandSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColumnBandSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ColumnHeaderTemplateProperty Field

TimetableSettings.ColumnHeaderTemplateProperty Field
[image]

Identifies the ColumnHeaderTemplate dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColumnHeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColumnHeaderTemplateProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.DatesProperty Field

TimetableSettings.DatesProperty Field
[image]

Identifies the Dates dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DatesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DatesProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.DayHeaderMinSizeProperty Field

TimetableSettings.DayHeaderMinSizeProperty Field
[image]

Identifies the DayHeaderMinSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayHeaderMinSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DayHeaderMinSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableCollisionsProperty Field

TimetableSettings.EnableCollisionsProperty Field
[image]

Identifies the EnableCollisions dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableCollisionsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableCollisionsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableDayItemsProperty Field

TimetableSettings.EnableDayItemsProperty Field
[image]

Identifies the EnableDayItems dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDayItemsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDayItemsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableSnappingProperty Field

TimetableSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EndTimeProperty Field

TimetableSettings.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ExpandActiveItemOnProperty Field

TimetableSettings.ExpandActiveItemOnProperty Field
[image]

Identifies the ExpandActiveItemOn dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandActiveItemOnProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandActiveItemOnProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.GeneralFormatProperty Field

TimetableSettings.GeneralFormatProperty Field
[image]

Identifies the GeneralFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GeneralFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GeneralFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.GroupHoursProperty Field

TimetableSettings.GroupHoursProperty Field
[image]

Identifies the GroupHours dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHoursProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHoursProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.HeaderDateFormatProperty Field

TimetableSettings.HeaderDateFormatProperty Field
[image]

Identifies the HeaderDateFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderDateFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderDateFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.HeaderStyleProperty Field

TimetableSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ItemOffsetProperty Field

TimetableSettings.ItemOffsetProperty Field
[image]

Identifies the ItemOffset dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemOffsetProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MainHeaderSizeProperty Field

TimetableSettings.MainHeaderSizeProperty Field
[image]

Identifies the MainHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MainHeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MainHeaderSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MaxAllDayItemsProperty Field

TimetableSettings.MaxAllDayItemsProperty Field
[image]

Identifies the MaxAllDayItems dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxAllDayItemsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxAllDayItemsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MinItemSizeProperty Field

TimetableSettings.MinItemSizeProperty Field
[image]

Identifies the MinItemSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinItemSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinItemSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MinuteFormatProperty Field

TimetableSettings.MinuteFormatProperty Field
[image]

Identifies the MinuteFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinuteFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinuteFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.NowBrushProperty Field

TimetableSettings.NowBrushProperty Field
[image]

Identifies the NowBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NowBrushProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.NowFillBrushProperty Field

TimetableSettings.NowFillBrushProperty Field
[image]

Identifies the NowFillBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowFillBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly NowFillBrushProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.OrientationProperty Field

TimetableSettings.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ReverseGroupingProperty Field

TimetableSettings.ReverseGroupingProperty Field
[image]

Identifies the ReverseGrouping dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ReverseGroupingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ReverseGroupingProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.RotateHeaderTextsProperty Field

TimetableSettings.RotateHeaderTextsProperty Field
[image]

Identifies the RotateHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderTextsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.RotateTimelineTextsProperty Field

TimetableSettings.RotateTimelineTextsProperty Field
[image]

Identifies the RotateTimelineTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateTimelineTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateTimelineTextsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ScrollStepProperty Field

TimetableSettings.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SecondTimelineOffsetProperty Field

TimetableSettings.SecondTimelineOffsetProperty Field
[image]

Identifies the SecondTimelineOffset dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondTimelineOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SecondTimelineOffsetProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SecondTimelinePositionProperty Field

TimetableSettings.SecondTimelinePositionProperty Field
[image]

Identifies the SecondTimelinePosition dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondTimelinePositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SecondTimelinePositionProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SelectedElementsStyleProperty Field

TimetableSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SelectWholeDayOnHeaderClickProperty Field

TimetableSettings.SelectWholeDayOnHeaderClickProperty Field
[image]

Identifies the SelectWholeDayOnHeaderClick dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectWholeDayOnHeaderClickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectWholeDayOnHeaderClickProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowAMProperty Field

TimetableSettings.ShowAMProperty Field
[image]

Identifies the ShowAM dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowAMProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowAMProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowCurrentTimeProperty Field

TimetableSettings.ShowCurrentTimeProperty Field
[image]

Identifies the ShowCurrentTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCurrentTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCurrentTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowDayHeaderProperty Field

TimetableSettings.ShowDayHeaderProperty Field
[image]

Identifies the ShowDayHeader dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayHeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayHeaderProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowItemSpansProperty Field

TimetableSettings.ShowItemSpansProperty Field
[image]

Identifies the ShowItemSpans dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowItemSpansProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowItemSpansProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowMinutesInHourHeadersProperty Field

TimetableSettings.ShowMinutesInHourHeadersProperty Field
[image]

Identifies the ShowMinutesInHourHeaders dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowMinutesInHourHeadersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowMinutesInHourHeadersProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowNavigationButtonsProperty Field

TimetableSettings.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowPaddingProperty Field

TimetableSettings.ShowPaddingProperty Field
[image]

Identifies the ShowPadding dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowWorkTimeProperty Field

TimetableSettings.ShowWorkTimeProperty Field
[image]

Identifies the ShowWorkTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowWorkTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowWorkTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SnapUnitCountProperty Field

TimetableSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SnapUnitProperty Field

TimetableSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.StartTimeProperty Field

TimetableSettings.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SubHeaderSizeProperty Field

TimetableSettings.SubHeaderSizeProperty Field
[image]

Identifies the SubHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SubHeaderStyleProperty Field

TimetableSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.TimelineSizeProperty Field

TimetableSettings.TimelineSizeProperty Field
[image]

Identifies the TimelineSize dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.TimelineStyleProperty Field

TimetableSettings.TimelineStyleProperty Field
[image]

Identifies the TimelineStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.TwelveHourFormatProperty Field

TimetableSettings.TwelveHourFormatProperty Field
[image]

Identifies the TwelveHourFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TwelveHourFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TwelveHourFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeCellStyleProperty Field

TimetableSettings.WorkTimeCellStyleProperty Field
[image]

Identifies the WorkTimeCellStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeCellStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeCellStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeEndProperty Field

TimetableSettings.WorkTimeEndProperty Field
[image]

Identifies the WorkTimeEnd dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeEndProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeEndProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeEndsProperty Field

TimetableSettings.WorkTimeEndsProperty Field
[image]

Identifies the WorkTimeEnds dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeEndsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeEndsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeStartProperty Field

TimetableSettings.WorkTimeStartProperty Field
[image]

Identifies the WorkTimeStart dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeStartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeStartProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeStartsProperty Field

TimetableSettings.WorkTimeStartsProperty Field
[image]

Identifies the WorkTimeStarts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeStartsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeStartsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings Constructor

TimetableSettings Constructor
[image]

Initializes a new instance of the TimetableSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimetableSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings Properties

TimetableSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cells.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
ColumnHeaderTemplate | Gets or sets the template of the column headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelinePosition | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectedElementsStyle | Gets or sets the appearance of selected cells.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
SubHeaderSize | Gets or sets the size of the secondary header.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEnd | Gets or sets the end of the work time interval.
WorkTimeEnds | Gets or sets the end of the work time interval for each date displayed in the view.
WorkTimeStart | Gets or sets the start of the work time interval.
WorkTimeStarts | Gets or sets the start of the work time interval for each date displayed in the view.

See Also

TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CalendarStyle Property

TimetableSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.CellSize Property

TimetableSettings.CellSize Property
[image]

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int CellSize { get; set; }

Visual Basic [image] Copy Code

Public Property CellSize As Integer

Property Value

An integer value specifying the cell size. The minimal allowed value is 10.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CellStyle Property


MindFusion.Scheduling.Wpf.TimetableSettings.CellStyle Property

TimetableSettings.CellStyle Property
[image]

Gets or sets the style of a time segment cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of timetable cells. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
WorkTimeCellStyle Property
CellSize Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.CellTime Property

TimetableSettings.CellTime Property
[image]

Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeSpan CellTime { get; set; }

Visual Basic [image] Copy Code

Public Property CellTime As TimeSpan

Property Value

A .NET TimeSpan object that specifies the time length of a single cell. The allowed values range from 1 second to 1 hour inclusive.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Example

The following sample demonstrates several ways for setting the time span of timetable cells. The sample assumes that calendar already references an existing Calendar object.

C# [image] Copy Code

// Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10);

// Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1);

// Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = new TimeSpan(0, 1, 20);

Visual Basic [image] Copy Code

' Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10)

' Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1)

' Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = New TimeSpan(0, 1, 20)

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ColumnBandSize Property

TimetableSettings.ColumnBandSize Property
[image]

Gets or sets the size of the bands displayed on the left/top side of each timetable column.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ColumnBandSize { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnBandSize As Integer

Property Value

A non-negative integer specifying band width in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

For best results, assign to this property the value of ItemSettings.MoveBandSize.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ColumnHeaderTemplate Property

TimetableSettings.ColumnHeaderTemplate Property
[image]

Gets or sets the template of the column headers, or null (Nothing in Visual Basic), to use the default template. This is a dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ColumnHeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnHeaderTemplate As DataTemplate

Property Value

An instance of the WPF DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<DataTemplate>
<TextBlock Text="{Binding Text}" />
</DataTemplate>

In addition to Text, which contains the default text displayed in the column header, the properties of the template can also bind to Value, which references the Resource or DateTime object associated with the column.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.Dates Property

TimetableSettings.Dates Property
[image]

Gets a collection of all dates visualized in the timetable.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DateCollection Dates { get; set; }

Visual Basic [image] Copy Code

Public Property Dates As DateCollection

Property Value

An instance of the DateCollection class specifying which dates to display as columns in the timetable view. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.DayHeaderMinSize Property

TimetableSettings.DayHeaderMinSize Property
[image]

Gets or sets the minimum size of the header displaying all-day items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int DayHeaderMinSize { get; set; }

Visual Basic [image] Copy Code

Public Property DayHeaderMinSize As Integer

Property Value

An integer value specifying the minimal header size in pixels. The minimal allowed value is 5.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableCollisions Property

TimetableSettings.EnableCollisions Property
[image]

Gets or sets a value indicating whether the item collision processing is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableCollisions { get; set; }

Visual Basic [image] Copy Code

Public Property EnableCollisions As Boolean

Property Value

A Boolean value.

Remarks

Turn this flag off if you don't need collision detection to improve performance.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableDayItems Property

TimetableSettings.EnableDayItems Property
[image]

Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableDayItems { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDayItems As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

By default, items longer than 1 day or items marked as AllDayEvent are displayed in the day header of the view. If the day header is not displayed (that is, ShowDayHeader is set to false) then these items are never displayed. Settings this property to false causes all items regardless of their length to be displayed in the main view.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.EnableSnapping Property

TimetableSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Wpf.TimetableSettings.EndTime Property

TimetableSettings.EndTime Property
[image]

Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As Integer

Property Value

An integer value specifying the end time in minutes. The allowed values range from 0 to 2880.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Specifying value for this property which is smaller than the value of StartTime is permissible. This indicates that the end value represents time from the next day. For example if StartTime is set to 600 (10:00 AM) and EndTime is set to 480 (8:00 AM), then each column in the view represents the time from 10:00 AM until 8:00 AM on the following day. Specifying 1920 (480 + 1440) for the EndTime yields the same result.

Note

It is possible to specify more than 24 hours to be displayed in a single timetable column. Doing so though might lead to ambiguities because certain periods of time will appear in more than one place (for example, a period will appear once at the end of a column and again in the beginning of the next one).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
StartTime Property
CellTime Property


MindFusion.Scheduling.Wpf.TimetableSettings.ExpandActiveItemOn Property

TimetableSettings.ExpandActiveItemOn Property
[image]

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ItemAction ExpandActiveItemOn { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.GeneralFormat Property

TimetableSettings.GeneralFormat Property
[image]

Gets or sets the string to use when formatting times in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }

Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.GroupHours Property

TimetableSettings.GroupHours Property
[image]

Gets or sets a value indicating whether hours displayed in the timeline are grouped.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool GroupHours { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHours As Boolean

Property Value

true to enable grouping; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Certain conditions prevent hours from grouping, such as when the hours are not divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.HeaderDateFormat Property

TimetableSettings.HeaderDateFormat Property
[image]

Gets or sets how to format and display dates in the timetable header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string HeaderDateFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderDateFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.HeaderStyle Property

TimetableSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.ItemOffset Property

TimetableSettings.ItemOffset Property
[image]

Gets or set the distance between the first item and its adjoining cell side.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ItemOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ItemOffset As Integer

Property Value

A non-negative integer value specifying the item offset in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MainHeaderSize Property

TimetableSettings.MainHeaderSize Property
[image]

Gets or sets the size of the main header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MainHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MaxAllDayItems Property

TimetableSettings.MaxAllDayItems Property
[image]

Gets or sets the maximum number of all-day items visible in the columns headers at a time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MaxAllDayItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxAllDayItems As Integer

Property Value

An integer value specifying how many all-day items to display at most in the column headers. The allowed values range from 1 to 20.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The all-day items header is automatically resized to hold all items up to the number set in this property. If there are more all-day items, the rest of them are not shown.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MinItemSize Property

TimetableSettings.MinItemSize Property
[image]

Gets or sets the smallest size allowed for schedule items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int MinItemSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimal size in pixels. The minimal allowed value is 5.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If there is not enough space in a column to display all related items, the items that do not fit remain invisible.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.MinuteFormat Property

TimetableSettings.MinuteFormat Property
[image]

Gets or sets how to format and display minutes.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MinuteFormat MinuteFormat { get; set; }

Visual Basic [image] Copy Code

Public Property MinuteFormat As MinuteFormat

Property Value

A MinuteFormat object specifying the minutes format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.NowBrush Property

TimetableSettings.NowBrush Property
[image]

Gets or sets the brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush NowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property NowBrush As Brush

Property Value

A .NET Brush object specifying the color used to indicate the current time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
NowFillBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Wpf.TimetableSettings.NowFillBrush Property

TimetableSettings.NowFillBrush Property
[image]

Gets or sets the fill brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush NowFillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property NowFillBrush As Brush

Property Value

A .NET Brush object specifying the color used to indicate the current time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
NowBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Wpf.TimetableSettings.Orientation Property

TimetableSettings.Orientation Property
[image]

Gets or sets the view orientation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

A vertical timetable view displays cells for the same daytime in a row, and cells for the same date in a column. A horizontal timetable view displays cells for the same time of the day in a column, and cells for the same date in a row.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ReverseGrouping Property

TimetableSettings.ReverseGrouping Property
[image]

Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ReverseGrouping { get; set; }

Visual Basic [image] Copy Code

Public Property ReverseGrouping As Boolean

Property Value

Remarks

By default grouping is done first by available dates, then by the resources specified in the current grouping type. Setting this property to true reverses this behavior.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.RotateHeaderTexts Property

TimetableSettings.RotateHeaderTexts Property
[image]

Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateHeaderTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateHeaderTexts As Boolean

Property Value

true to display the header text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
RotateTimelineTexts Property


MindFusion.Scheduling.Wpf.TimetableSettings.RotateTimelineTexts Property

TimetableSettings.RotateTimelineTexts Property
[image]

Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateTimelineTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateTimelineTexts As Boolean

Property Value

true to display the timeline text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
RotateHeaderTexts Property


MindFusion.Scheduling.Wpf.TimetableSettings.ScrollStep Property

TimetableSettings.ScrollStep Property
[image]

Gets or sets the number of days to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Integer

Property Value

A positive integer value specifying the number of days to scroll.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SecondTimelineOffset Property

TimetableSettings.SecondTimelineOffset Property
[image]

Gets or sets the offset in hours of the second timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SecondTimelineOffset { get; set; }

Visual Basic [image] Copy Code

Public Property SecondTimelineOffset As Integer

Property Value

An integer value specifying the offset in hours. The allowed values range from 0 to 23.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
SecondTimelinePosition Property


MindFusion.Scheduling.Wpf.TimetableSettings.SecondTimelinePosition Property

TimetableSettings.SecondTimelinePosition Property
[image]

Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Alignment SecondTimelinePosition { get; set; }

Visual Basic [image] Copy Code

Public Property SecondTimelinePosition As Alignment

Property Value

Specify Near to show the second timeline next to the main one, Far to place it at the opposite side of the view, or None to hide it.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
SecondTimelineOffset Property


MindFusion.Scheduling.Wpf.TimetableSettings.SelectedElementsStyle Property

TimetableSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.SelectWholeDayOnHeaderClick Property

TimetableSettings.SelectWholeDayOnHeaderClick Property
[image]

Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool SelectWholeDayOnHeaderClick { get; set; }

Visual Basic [image] Copy Code

Public Property SelectWholeDayOnHeaderClick As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowAM Property

TimetableSettings.ShowAM Property
[image]

Gets or sets a value indicating whether the AM and PM suffixes are displayed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowAM { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAM As Boolean

Property Value

true to show AM/PM suffixes; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowCurrentTime Property

TimetableSettings.ShowCurrentTime Property
[image]

Gets or sets a value indicating whether to display the current time in the timeline.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowCurrentTime { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCurrentTime As Boolean

Property Value

true to indicate the current time; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
NowBrush Property
NowFillBrush Property


MindFusion.Scheduling.Wpf.TimetableSettings.ShowDayHeader Property

TimetableSettings.ShowDayHeader Property
[image]

Gets or sets a value indicating whether to show the header displaying all-day items.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowDayHeader { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDayHeader As Boolean

Property Value

true to show the days header; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
MaxAllDayItems Property


MindFusion.Scheduling.Wpf.TimetableSettings.ShowItemSpans Property

TimetableSettings.ShowItemSpans Property
[image]

Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowItemSpans { get; set; }

Visual Basic [image] Copy Code

Public Property ShowItemSpans As Boolean

Property Value

true to display item spans; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowMinutesInHourHeaders Property

TimetableSettings.ShowMinutesInHourHeaders Property
[image]

Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowMinutesInHourHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMinutesInHourHeaders As Boolean

Property Value

true to show minutes; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Whole hour cells are displayed when the hours are divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowNavigationButtons Property

TimetableSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the Timetable view displays navigation buttons.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to show navigation buttons; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowPadding Property

TimetableSettings.ShowPadding Property
[image]

Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowPadding { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPadding As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.ShowWorkTime Property

TimetableSettings.ShowWorkTime Property
[image]

Gets or sets a value indicating whether the work time should be displayed with different style.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowWorkTime { get; set; }

Visual Basic [image] Copy Code

Public Property ShowWorkTime As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
WorkTimeCellStyle Property


MindFusion.Scheduling.Wpf.TimetableSettings.SnapUnit Property

TimetableSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to false the value of this property is ignored and items snap to cell borders.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
EnableSnapping Property
SnapUnitCount Property


MindFusion.Scheduling.Wpf.TimetableSettings.SnapUnitCount Property

TimetableSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Wpf.TimetableSettings.StartTime Property

TimetableSettings.StartTime Property
[image]

Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As Integer

Property Value

An integer value specifying the view start time in minutes. The allowed values range from 0 to 1440.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
EndTime Property
CellTime Property


MindFusion.Scheduling.Wpf.TimetableSettings.SubHeaderSize Property

TimetableSettings.SubHeaderSize Property
[image]

Gets or sets the size of the secondary header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int SubHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the secondary header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.SubHeaderStyle Property

TimetableSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.TimelineSize Property

TimetableSettings.TimelineSize Property
[image]

Gets or sets the size of the timeline header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int TimelineSize { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineSize As Integer

Property Value

A non-negative integer value specifying the size of the timeline header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.TimelineStyle Property

TimetableSettings.TimelineStyle Property
[image]

Gets or sets the style of the timeline header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle TimelineStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the appearance of the timeline header. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.TwelveHourFormat Property

TimetableSettings.TwelveHourFormat Property
[image]

Gets or sets a value indicating whether to use a 12-hour format.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool TwelveHourFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TwelveHourFormat As Boolean

Property Value

true to use 12-hour format, or false to use 24-hour format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeCellStyle Property

TimetableSettings.WorkTimeCellStyle Property
[image]

Gets or sets the style of cells in the work time interval.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle WorkTimeCellStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeCellStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the work time cells. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
CellStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeEnd Property

TimetableSettings.WorkTimeEnd Property
[image]

Gets or sets the end of the work time interval.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeSpan WorkTimeEnd { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeEnd As TimeSpan

Property Value

A TimeSpan value specifying the start of the work time. The value cannot be less than WorkTimeStart.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property and WorkTimeStart specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty CalendarStyle.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
WorkTimeStart Property


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeEnds Property

TimetableSettings.WorkTimeEnds Property
[image]

Gets or sets the end of the work time interval for each date displayed in the view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<TimeSpan> WorkTimeEnds { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeEnds As ObservableCollection(Of TimeSpan)

Property Value

A collection of TimeSpan objects specifying the end times of the work intervals for each day in the view.

Remarks

If the elements in the collection are less than the days in the view, the WorkTimeEnd property is used for the remaining days.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeStart Property

TimetableSettings.WorkTimeStart Property
[image]

Gets or sets the start of the work time interval.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public TimeSpan WorkTimeStart { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeStart As TimeSpan

Property Value

A TimeSpan value specifying the start of the work time. The value cannot be greater than WorkTimeEnd.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property and WorkTimeEnd specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty CalendarStyle.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace
WorkTimeEnd Property


MindFusion.Scheduling.Wpf.TimetableSettings.WorkTimeStarts Property

TimetableSettings.WorkTimeStarts Property
[image]

Gets or sets the start of the work time interval for each date displayed in the view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<TimeSpan> WorkTimeStarts { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeStarts As ObservableCollection(Of TimeSpan)

Property Value

A collection of TimeSpan objects specifying the start times of the work intervals for each day in the view.

Remarks

If the elements in the collection are less than the days in the view, the WorkTimeStart property is used for the remaining days.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.TimeUnit Enumeration

TimeUnit Enumeration
[image]

Specifies a time resolution.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum TimeUnit

Visual Basic [image] Copy Code

Public Enum TimeUnit

Members

Member name | Description
Day | Specifies days.
Hour | Specifies hours.
Minute | Specifies minutes.
Month | Specifies months.
Second | Specifies seconds.
Week | Specifies weeks.
Year | Specifies years.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter Class

VisibleConverter Class
Remarks See Also
[image]

Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class VisibleConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibleConverter
Implements IValueConverter

Remarks

This converter can be used when binding elements' Visibility to a boolean property.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Wpf.VisibleConverter

See Also

VisibleConverter Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter Members

VisibleConverter Members
Constructors Methods
[image]

Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.

The following tables list the members exposed by the VisibleConverter type.

Public Constructors

Name | Description
VisibleConverter | Initializes a new instance of the VisibleConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibleConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter Constructor

VisibleConverter Constructor
[image]

Initializes a new instance of the VisibleConverter class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public VisibleConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibleConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter Methods

VisibleConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibleConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter.Convert Method

VisibleConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value
The value produced by the binding source.
targetType
The type of the binding target property.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.

Remarks

Converts true to Visibility.Visible and false to Visibility.Collapsed.

See Also

VisibleConverter Members
VisibleConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.VisibleConverter.ConvertBack Method

VisibleConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value
The value that is produced by the binding target.
targetType
The type to convert to.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.

Remarks

This method is not implemented and will throw an exception if used.

See Also

VisibleConverter Members
VisibleConverter Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeHeaderStyle Enumeration

WeekRangeHeaderStyle Enumeration
[image]

Specifies the appearance of the time period header in WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum WeekRangeHeaderStyle

Visual Basic [image] Copy Code

Public Enum WeekRangeHeaderStyle

Members

Member name | Description
None | There isn't a header displayed.
Reference | The header displays the name of the associated contact, location or task. This flag is valid only if grouping is enabled.
Title | The header displays the start and end dates specified in the WeekRangeSettings object.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings Class

WeekRangeSettings Class
[image]

Defines properties that allow customizing the visualization of weeks in WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public class WeekRangeSettings : CalendarSettings

Visual Basic [image] Copy Code

Public Class WeekRangeSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Wpf.CalendarSettings
MindFusion.Scheduling.Wpf.WeekRangeSettings

See Also

WeekRangeSettings Members
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings Members

WeekRangeSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of weeks in WeekRange view.

The following tables list the members exposed by the WeekRangeSettings type.

Public Constructors

Name | Description
WeekRangeSettings | Initializes a new instance of the WeekRangeSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
DayNamesHeaderHeightProperty | Identifies the DayNamesHeaderHeight dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EvenMonthsBrushProperty | Identifies the EvenMonthsBrush dependency property.
GroupWeekendsProperty | Identifies the GroupWeekends dependency property.
GroupWeekendsTitleSeparatorProperty | Identifies the GroupWeekendsTitleSeparator dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
OddMonthsBrushProperty | Identifies the OddMonthsBrush dependency property.
ReferenceHeaderHeightProperty | Identifies the ReferenceHeaderHeight dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimePeriodHeaderHeightProperty | Identifies the TimePeriodHeaderHeight dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderPositionProperty | Identifies the WeekHeaderPosition dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleRows | Gets or sets the number of weeks visible at a time.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderPosition | Gets or sets the position of the week numbers header.
WeekHeaderStyle | Gets or sets the appearance style used to paint the week headers.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings Fields

WeekRangeSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
DayNamesHeaderHeightProperty | Identifies the DayNamesHeaderHeight dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EvenMonthsBrushProperty | Identifies the EvenMonthsBrush dependency property.
GroupWeekendsProperty | Identifies the GroupWeekends dependency property.
GroupWeekendsTitleSeparatorProperty | Identifies the GroupWeekendsTitleSeparator dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
OddMonthsBrushProperty | Identifies the OddMonthsBrush dependency property.
ReferenceHeaderHeightProperty | Identifies the ReferenceHeaderHeight dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimePeriodHeaderHeightProperty | Identifies the TimePeriodHeaderHeight dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderPositionProperty | Identifies the WeekHeaderPosition dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.CalendarStyleProperty Field

WeekRangeSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.CellSettingsProperty Field

WeekRangeSettings.CellSettingsProperty Field
[image]

Identifies the CellSettings dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CellSettingsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.DayNamesHeaderHeightProperty Field

WeekRangeSettings.DayNamesHeaderHeightProperty Field
[image]

Identifies the DayNamesHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayNamesHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DayNamesHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.DayOfWeekFormatProperty Field

WeekRangeSettings.DayOfWeekFormatProperty Field
[image]

Identifies the DayOfWeekFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayOfWeekFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DayOfWeekFormatProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.EvenMonthsBrushProperty Field

WeekRangeSettings.EvenMonthsBrushProperty Field
[image]

Identifies the EvenMonthsBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EvenMonthsBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EvenMonthsBrushProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.GroupWeekendsProperty Field

WeekRangeSettings.GroupWeekendsProperty Field
[image]

Identifies the GroupWeekends dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupWeekendsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupWeekendsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.GroupWeekendsTitleSeparatorProperty Field

WeekRangeSettings.GroupWeekendsTitleSeparatorProperty Field
[image]

Identifies the GroupWeekendsTitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupWeekendsTitleSeparatorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GroupWeekendsTitleSeparatorProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.HeaderStyleProperty Field

WeekRangeSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.OddMonthsBrushProperty Field

WeekRangeSettings.OddMonthsBrushProperty Field
[image]

Identifies the OddMonthsBrush dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OddMonthsBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OddMonthsBrushProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.ReferenceHeaderHeightProperty Field

WeekRangeSettings.ReferenceHeaderHeightProperty Field
[image]

Identifies the ReferenceHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ReferenceHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ReferenceHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.RotateWeekHeaderTextsProperty Field

WeekRangeSettings.RotateWeekHeaderTextsProperty Field
[image]

Identifies the RotateWeekHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateWeekHeaderTextsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RotateWeekHeaderTextsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.SelectedElementsHeaderStyleProperty Field

WeekRangeSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.SelectedElementsStyleProperty Field

WeekRangeSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.ShowDayOfWeekProperty Field

WeekRangeSettings.ShowDayOfWeekProperty Field
[image]

Identifies the ShowDayOfWeek dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayOfWeekProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayOfWeekProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.SubHeaderStyleProperty Field

WeekRangeSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.TimePeriodHeaderHeightProperty Field

WeekRangeSettings.TimePeriodHeaderHeightProperty Field
[image]

Identifies the TimePeriodHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimePeriodHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimePeriodHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.TitleFormatProperty Field

WeekRangeSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.TitleSeparatorProperty Field

WeekRangeSettings.TitleSeparatorProperty Field
[image]

Identifies the TitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleSeparatorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleSeparatorProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.ViewStyleProperty Field

WeekRangeSettings.ViewStyleProperty Field
[image]

Identifies the ViewStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ViewStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ViewStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.VisibleColumnsProperty Field

WeekRangeSettings.VisibleColumnsProperty Field
[image]

Identifies the VisibleColumns dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleColumnsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleColumnsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.VisibleRowsProperty Field

WeekRangeSettings.VisibleRowsProperty Field
[image]

Identifies the VisibleRows dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleRowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleRowsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderFormatProperty Field

WeekRangeSettings.WeekHeaderFormatProperty Field
[image]

Identifies the WeekHeaderFormat dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderFormatProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderPositionProperty Field

WeekRangeSettings.WeekHeaderPositionProperty Field
[image]

Identifies the WeekHeaderPosition dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderPositionProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderStyleProperty Field

WeekRangeSettings.WeekHeaderStyleProperty Field
[image]

Identifies the WeekHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekNumbersHeaderWidthProperty Field

WeekRangeSettings.WeekNumbersHeaderWidthProperty Field
[image]

Identifies the WeekNumbersHeaderWidth dependency property.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekNumbersHeaderWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekNumbersHeaderWidthProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings Constructor

WeekRangeSettings Constructor
[image]

Initializes a new instance of the WeekRangeSettings class.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public WeekRangeSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings Properties

WeekRangeSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleRows | Gets or sets the number of weeks visible at a time.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderPosition | Gets or sets the position of the week numbers header.
WeekHeaderStyle | Gets or sets the appearance style used to paint the week headers.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.CalendarStyle Property

WeekRangeSettings.CalendarStyle Property
[image]

Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.WeekRangeSettings.CellSettings Property

WeekRangeSettings.CellSettings Property
[image]

Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; set; }

Visual Basic [image] Copy Code

Public Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.DayNamesHeaderHeight Property

WeekRangeSettings.DayNamesHeaderHeight Property
[image]

Gets or sets the height of the day-names header in the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int DayNamesHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property DayNamesHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the day-names header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.DayOfWeekFormat Property

WeekRangeSettings.DayOfWeekFormat Property
[image]

Gets or sets the display format of the names of the days of the week.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.EvenMonthsBrush Property

WeekRangeSettings.EvenMonthsBrush Property
[image]

Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush EvenMonthsBrush { get; set; }

Visual Basic [image] Copy Code

Public Property EvenMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the even month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
OddMonthsBrush Property


MindFusion.Scheduling.Wpf.WeekRangeSettings.GroupWeekends Property

WeekRangeSettings.GroupWeekends Property
[image]

Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool GroupWeekends { get; set; }

Visual Basic [image] Copy Code

Public Property GroupWeekends As Boolean

Property Value

true to display weekend days together; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.GroupWeekendsTitleSeparator Property

WeekRangeSettings.GroupWeekendsTitleSeparator Property
[image]

Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string GroupWeekendsTitleSeparator { get; set; }

Visual Basic [image] Copy Code

Public Property GroupWeekendsTitleSeparator As String

Property Value

A string specifying the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.HeaderStyle Property

WeekRangeSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.WeekRangeSettings.OddMonthsBrush Property

WeekRangeSettings.OddMonthsBrush Property
[image]

Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public Brush OddMonthsBrush { get; set; }

Visual Basic [image] Copy Code

Public Property OddMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the odd month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
EvenMonthsBrush Property


MindFusion.Scheduling.Wpf.WeekRangeSettings.RotateWeekHeaderTexts Property

WeekRangeSettings.RotateWeekHeaderTexts Property
[image]

Gets or sets a value indicating whether the week header texts should be rotated.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool RotateWeekHeaderTexts { get; set; }

Visual Basic [image] Copy Code

Public Property RotateWeekHeaderTexts As Boolean

Property Value

true to rotate the texts; otherwise, false.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.SelectedElementsHeaderStyle Property

WeekRangeSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.WeekRangeSettings.SelectedElementsStyle Property

WeekRangeSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.WeekRangeSettings.ShowDayOfWeek Property

WeekRangeSettings.ShowDayOfWeek Property
[image]

Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public bool ShowDayOfWeek { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDayOfWeek As Boolean

Property Value

true to display the day names; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it isn't a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the CultureInfo object assigned to calendar's Culture.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.SubHeaderStyle Property

WeekRangeSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Wpf.WeekRangeSettings.TimePeriodHeaderHeight Property

WeekRangeSettings.TimePeriodHeaderHeight Property
[image]

Gets or sets the height of the time-period header in the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int TimePeriodHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TimePeriodHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.TitleFormat Property

WeekRangeSettings.TitleFormat Property
[image]

Gets or sets the format of the calendar's title.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.TitleSeparator Property

WeekRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a separator in the calendar's title.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }

Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string specifying the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.ViewStyle Property

WeekRangeSettings.ViewStyle Property
[image]

Gets or sets the style of the WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public WeekRangeViewStyle ViewStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ViewStyle As WeekRangeViewStyle

Property Value

A member of the WeekRangeViewStyle enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.VisibleRows Property

WeekRangeSettings.VisibleRows Property
[image]

Gets or sets the number of weeks visible at a time.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

The allowed values range from 1 to 10.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Used only when ViewStyle is set to WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderFormat Property

WeekRangeSettings.WeekHeaderFormat Property
[image]

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public string WeekHeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderPosition Property

WeekRangeSettings.WeekHeaderPosition Property
[image]

Gets or sets the position of the week numbers header.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public MonthWeekHeaderStyle WeekHeaderPosition { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderPosition As MonthWeekHeaderStyle

Property Value

A member of the MonthWeekHeaderStyle enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekHeaderStyle Property

WeekRangeSettings.WeekHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the week headers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public CalendarStyle WeekHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeSettings.WeekNumbersHeaderWidth Property

WeekRangeSettings.WeekNumbersHeaderWidth Property
[image]

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public int WeekNumbersHeaderWidth { get; set; }

Visual Basic [image] Copy Code

Public Property WeekNumbersHeaderWidth As Integer

Property Value

A non-negative integer value specifying the header width in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration
[image]

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling.Wpf
Assembly: MindFusion.Scheduling.Wpf

Syntax

C# [image] Copy Code

public enum WeekRangeViewStyle

Visual Basic [image] Copy Code

Public Enum WeekRangeViewStyle

Members

Member name | Description
SingleWeek | The calendar view displays a single week at a time.
WeekPerRow | The calendar view displays several weeks at a time.

See Also

MindFusion.Scheduling.Wpf Namespace


MindFusion.Scheduling.Wpf.Export Namespace

MindFusion.Scheduling.Wpf.Export Namespace
Classes

Classes

Class | Description
ExcelExporter | Provides methods for exporting MindFusion calendars to Excel.


MindFusion.Scheduling.Wpf.Export.ExcelExporter Class

ExcelExporter Class
Remarks See Also
[image]

Provides methods for exporting MindFusion calendars to Excel.

Namespace: MindFusion.Scheduling.Wpf.Export
Assembly: MindFusion.Scheduling.Wpf.Excel

Syntax

C# [image] Copy Code

public class ExcelExporter

Visual Basic [image] Copy Code

Public Class ExcelExporter

Remarks

For additional information, check Exporting.

Note

The Excel export relies on the Ionic.Zip library, which is based on JZlib. The following copyright notice copyright noticecopyright noticeExcelExporter is used.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Wpf.Export.ExcelExporter

See Also

ExcelExporter Members
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter Members

ExcelExporter Members
Constructors Properties Methods
[image]

Provides methods for exporting MindFusion calendars to Excel.

The following tables list the members exposed by the ExcelExporter type.

Public Constructors

Name | Description
ExcelExporter | Initializes a new instance of the ExcelExporter class.

Public Properties

Name | Description
PageOrientation | Gets or sets the page orientation.

Public Methods

Name | Description
Export | Overloaded. Exports the specified calendar as an Open Office XML format.

See Also

ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter Constructor

ExcelExporter Constructor
[image]

Initializes a new instance of the ExcelExporter class.

Namespace: MindFusion.Scheduling.Wpf.Export
Assembly: MindFusion.Scheduling.Wpf.Excel

Syntax

C# [image] Copy Code

public ExcelExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter Methods

ExcelExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Exports the specified calendar as an Open Office XML format.

See Also

ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter.Export Method

ExcelExporter.Export Method
[image]

Exports the specified calendar as an Open Office XML format.

Overload List

Name | Description
ExcelExporter.Export (Calendar, Stream) | Exports the specified calendar as an Open Office XML format.
ExcelExporter.Export (Calendar, String) | Exports the specified calendar as an Open Office XML format.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter.Export Method (Calendar, Stream)

ExcelExporter.Export Method (Calendar, Stream)
See Also
[image]

Exports the specified calendar as an Open Office XML format.

Namespace: MindFusion.Scheduling.Wpf.Export
Assembly: MindFusion.Scheduling.Wpf.Excel

Syntax

C# [image] Copy Code

public void Export (
Calendar calendar,
Stream stream
)

Visual Basic [image] Copy Code

Public Sub Export ( _
calendar As Calendar, _
stream As Stream _
)

Parameters

calendar
The Calendar to export.
stream

The target stream.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter.Export Method (Calendar, String)

ExcelExporter.Export Method (Calendar, String)
See Also
[image]

Exports the specified calendar as an Open Office XML format.

Namespace: MindFusion.Scheduling.Wpf.Export
Assembly: MindFusion.Scheduling.Wpf.Excel

Syntax

C# [image] Copy Code

public void Export (
Calendar calendar,
string fileName
)

Visual Basic [image] Copy Code

Public Sub Export ( _
calendar As Calendar, _
fileName As String _
)

Parameters

calendar
The Calendar to export.
fileName

The name of the target file.

See Also

Export Method Overload List
ExcelExporter Members
ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter Properties

ExcelExporter Properties
[image]

Public Properties

Name | Description
PageOrientation | Gets or sets the page orientation.

See Also

ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Scheduling.Wpf.Export.ExcelExporter.PageOrientation Property

ExcelExporter.PageOrientation Property
[image]

Gets or sets the page orientation.

Namespace: MindFusion.Scheduling.Wpf.Export
Assembly: MindFusion.Scheduling.Wpf.Excel

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

A member of the PageOrientation enumeration.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Scheduling.Wpf.Export Namespace


MindFusion.Spreadsheet.Wpf Namespace

MindFusion.Spreadsheet.Wpf Namespace
Classes Interfaces Enumerations

Classes

Class | Description
AddItemCommand(T) | Implements addition of items to a collection.
Annotation | Represents a comment of a cell within a worksheet.
AutoFilter | Represents autofiltering inside a worksheet.
BaseMouseEventArgs | Contains the arguments passed to mouse-related events.
CalcExporter | CalcExporter lets you export Workbook objects to OpenOffice Calc spreadsheets.
CalcImporter | CalcImporter lets you import OpenOffice Calc spreadsheets into a Workbook.
Cell | Identifies a single cell in a Worksheet.
CellAnnotation | Represents the interactive object containing a comment for a cell within a worksheet.
CellAnnotationPresenter | Defines the presentation of cell annotations in the WorkbookView control.
CellChangedEventArgs | Provides data for the CellChanged event.
CellCollection | Represents a specialized collection for worksheet cells.
CellData | Represents a copy of the cell data in a worksheet region. Instances of this class can be obtained by calling the CopyData method of a Worksheet.
CellEventArgs | Provides data for events related to individual cells.
CellMouseEventArgs | Contains the arguments passed to cell-related mouse events.
CellRange | Identifies a range of cells in a Worksheet.
CellRangeCollection | Represents a specialized collection for cell ranges.
CellValidationEventArgs | Provides data for validation events related to individual cells.
ChangeWorksheetCommand | Represents a command that can track and undo changes of a Worksheet.
Column | Identifies a column in a worksheet.
ColumnChangedEventArgs | Provides data for the ColumnChanged event.
ColumnCollection | Represents a specialized collection for worksheet columns.
ColumnEventArgs | Contains the arguments passed to column-related events.
ColumnHeader | Defines the presentation of column headers in the WorkbookView control.
ColumnMouseEventArgs | Contains the arguments passed to column-related mouse events.
ColumnRange | Identifies a range of columns in a Worksheet.
ColumnRangeEventArgs | Contains the arguments passed to events related to multiple column.
ColumnRangeMovingEventArgs | Contains the arguments passed to validation events related to multiple columns.
ColumnRangeResizingEventArgs | Contains the arguments passed to validation events related to multiple columns.
Command | Represents an action that modifies the workbook and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
Converter | Provides capabilities to convert various types to and from strings in a culture-independent way.
CornerHeader | Defines the presentation of the are in the top-left corner of the WorkbookView control.
CsvExporter | CsvExporter lets you export Worksheet data into .csv file.
CsvImporter | CsvImporter lets you import .csv files into a Worksheet.
CurrencyCodeInfo | Represents a currency ISO code to locale relationship.
CurrencyCodes | Represents a helper class containing the definitions of currency ISO codes to locale relationships.
DefaultNumericFormats | Contains predefined format strings for different numeric formats.
DisposableCommand | Represents a command that implements the IDisposable interface.
Drawing | Represents a drawing within a worksheet. A drawing can contain unlimited number of visual elements such as pictures, diagrams and charts.
ExcelExporter | ExcelExporter lets you export Workbook objects to Excel Open XML documents.
ExcelImporter | ExcelImporter lets you import Excel Open XML documents into a Workbook.
Filter | Represents a filter for a single column.
FormattedText | Represents a sequence of text fragments with different formatting (font, size, color).
HatchBrush | Emulates GDI+ hatch brushes using the WPF ImageBrush class.
Header | Defines the presentation of headers in the WorkbookView control.
Hyperlink | Represents a hyperlink associated with a worksheet cell.
InplaceEditEventArgs | Contains the arguments passed to the InplaceEditStarted and InplaceEditEnded event handlers.
InplaceEditValidationEventArgs | Contains the arguments passed to the InplaceEditStarting and InplaceEditEnding event handlers.
InteractiveObject | Represents a worksheet object that can be modified interactively by the user.
InteractiveObjectPresenter | Defines the presentation of interactive objects in the WorkbookView control.
Measure | Represents amounts of specific units.
MeasureUnit | Specifies units of measure.
MergedCellsCollection | Represents a specialized collection for merged cells in a worksheet, each merged cell is represented by a CellRange object.
MoveItemCommand(T) | Implements moving of items within a collection.
NamedCollection(T) | Represents a collection of objects that can be manipulated by name. The objects in the collection are required to have unique names.
NamedRange | Represents a named range of cells.
NamedRangeCollection | Represents a specialized collection of NamedRange objects.
NotifyCollectionChangedEventArgs | Provides data for the CollectionChanged event.
NumericFormatInfo | Represents a numeric format within a workbook.
ObjectEventArgs | Provides data for events related to interactive objects.
ObjectInteractionEventArgs | Provides data for events related to interactive objects.
ObjectInteractionValidationEventArgs | Contains the arguments passed to handlers of object validation events.
ObjectMouseEventArgs | Contains the arguments passed to object-related mouse events.
ObjectValidationEventArgs | Contains the arguments passed to handlers of object validation events.
ObservableCollection(T) | Represents a strongly-typed collection that provides notifications when items get added, removed, or when the whole list is refreshed.
OutlineEventArgs | Contains the arguments passed to the RowOutlineLevelToggled and ColumnOutlineLevelToggled event handlers.
PaginationOptions | Provides properties that allow customization of various aspects of printing and print-preview.
PdfExporter | Exports worksheets to Adobe Portable Document Format (PDF) files.
Picture | Represents a picture in a drawing within a worksheet.
PicturePresenter | Defines the presentation of pictures in the WorkbookView control.
PropertyEventArgs | Provides data for the PropertyValueChanged event.
RemoveItemCommand(T) | Implements deletion of items from a collection.
ReplaceItemCommand(T) | Implements replacement of items in a collection.
ResetCollectionCommand(T) | Implements clearing of a collection.
Row | Identifies a row in a worksheet.
RowChangedEventArgs | Provides data for the RowChanged event.
RowCollection | Represents a specialized collection for worksheet rows.
RowEventArgs | Contains the arguments passed to row-related events.
RowHeader | Defines the presentation of row headers in the WorkbookView control.
RowMouseEventArgs | Contains the arguments passed to row-related mouse events.
RowRange | Identifies a range of rows in a Worksheet.
RowRangeEventArgs | Contains the arguments passed to events related to multiple rows.
RowRangeMovingEventArgs | Contains the arguments passed to validation events related to multiple rows.
RowRangeResizingEventArgs | Contains the arguments passed to validation events related to multiple rows.
Run | Represents a fragment of text with uniform formatting in a FormattedText object.
Selection | Represents a set of selected cells and objects within a grid view.
SerializeColumnTagEventArgs | Provides data for the SerializeColumnTag and DeserializeColumnTag event handlers.
SerializeDataEventArgs | Provides data for the SerializeData and DeserializeData event handlers.
SerializeRowTagEventArgs | Provides data for the SerializeRowTag and DeserializeRowTag event handlers.
SerializeTagEventArgs | Provides data for the SerializeTag and DeserializeTag event handlers.
SortKey | Represents a key in a sorting operation.
SortOptions | Specifies the order of a sorting operation, ascending or descending.
StyleData | Represents a copy of the cell styles in a worksheet region. Instances of this class can be obtained by calling the CopyStyles method of a Worksheet.
TrackChangesCommand | Represents a command that can track and undo changes of INotifyPropertyValueChanged objects.
UndoableCollection(T) | Represents a strongly-typed collection that supports undo and redo.
UndoEventArgs | Contains the arguments passed to the ActionUndone and ActionRedone event handlers.
ValidationFailedEventArgs | Provides data for the ValidationFailed event.
Workbook | The main document class, contains a collection of worksheets, named ranges and other related objects.
WorkbookPrinter | Provides print and print preview for Workbook objects.
WorkbookView | Represents a control that can display Workbook objects.
Worksheet | Represents a worksheet in a workbook, that is, a rectangular grid of cells containing data.
WorksheetChangedEventArgs | Provides data for the WorksheetChanged event.
WorksheetCollection | Represents a specialized collection of Worksheet objects.
WorksheetEventArgs | Contains the arguments passed to Worksheet-related events.
WorksheetMouseEventArgs | Contains the arguments passed to Worksheet-related mouse events.
WorksheetTabMouseEventArgs | Contains the arguments passed to Worksheet-related mouse events.
WorksheetValidationEventArgs | Contains the arguments passed to Worksheet-related validation events.
XmlContext | Contains methods that help serializing and deserializing complex objects to and from XML documents.

Interfaces

Interface | Description
IColumnStyle | Represents the style of a column.
IConditionalFormat | Represents conditional format associated with a range of cells.
IConditionalFormatCollection | Represents a collection of IConditionalFormat objects.
IHasName | Defines a name for the type that implements this interface.
IInplaceEditable | Represents an inplace-editable object within a worksheet.
INotifyCollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.
INotifyPropertyValueChanged | Provides notification for property changes.
IRowStyle | Represents the style of a row.
IStyle | Represents the style of an element.
IValidation | Represents data validation associated with a range of cells.

Enumerations

Enumeration | Description
AdjustmentHandles | Identifies the distinct selection handles of an interactive object.
AutoFilterOperator | Indicates an autofiltering operator.
ComparisonOperator | Specifies an operator for value comparison.
ConditionalFormatType | Specifies the type of a conditional format.
CursorHint | Specifies what mouse cursor to display while a user interacts with the view controls.
DynamicFilterType | Specifies the type of a dynamic autofilter.
FillDate | Specifies the date component to increment when filling dates.
FillDirection | Specifies the direction of a data fill operation.
FillType | Specifies the method used to fill series of cells.
FindWithin | Specifies the target of find and replace operations.
HatchStyle | Represents hatch patterns corresponding to GDI+ HatchBrush objects.
HorizontalAlignment | Specifies the horizontal alignment of an element.
HyperlinkType | Specifies the type of a hyperlink.
LookIn | Specifies whether a find operation should search in cell formulas or values.
NotifyCollectionChangedAction | Describes the action that caused a CollectionChanged event.
ObjectAnchor | Specifies the anchor of a worksheet object.
ObjectAnchorPosition | Specifies the anchor position of a worksheet object.
PageOrder | Specifies the order of printed pages.
PushDirection | Specifies how the existing cells are moved when inserting new cells in a CellRange object.
SearchDirection | Specifies the direction of find and replace operations.
SearchOrder | Specifies the order of find and replace operations.
ShiftDirection | Specifies how the cells are moved when removing cells from a CellRange object.
SortDirection | Specifies the direction of a sorting operation.
SortOrder | Specifies the order of a sorting operation, ascending or descending.
ValidationErrorAction | Specifies the action to perform when data validation fails.
ValidationType | Specifies the type of data validation.
VerticalAlignment | Specifies the vertical alignment of an element.


MindFusion.Spreadsheet.Wpf.AddItemCommand(T) Class

AddItemCommand(T) Class
Remarks See Also
[image]

Implements addition of items to a collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class AddItemCommand<T> : Command

Visual Basic [image] Copy Code

Public Class AddItemCommand(Of T)
Inherits Command

Remarks

There is usually no need to instantiate this class directly. Instances of this command are automatically created and executed when an item is added to an UndoableCollection.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.AddItemCommand(T)

See Also

AddItemCommand(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T) Members

AddItemCommand(T) Members
Constructors Properties Methods
[image]

Implements addition of items to a collection.

The following tables list the members exposed by the AddItemCommand(T) type.

Public Constructors

Name | Description
AddItemCommand | Initializes a new instance of the AddItemCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T) Constructor

AddItemCommand(T) Constructor
[image]

Initializes a new instance of the AddItemCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AddItemCommand<T> (
Workbook workbook,
UndoableCollection<T> collection,
int index,
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
workbook As Workbook, _
collection As UndoableCollection(Of T), _
index As Integer, _
item As T _
)

Parameters

workbook

The Workbook modified by this command.

collection

The collection to which the new item is added.

index

The zero-based index where the new collection should be added.

item

The item that should be added to the collection.

See Also

AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T) Methods

AddItemCommand(T) Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T).Execute Method

AddItemCommand(T).Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

See Also

AddItemCommand(T) Members
AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T).Redo Method

AddItemCommand(T).Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddItemCommand(T) Members
AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AddItemCommand(T).Undo Method

AddItemCommand(T).Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddItemCommand(T) Members
AddItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of an interactive object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum AdjustmentHandles

Visual Basic [image] Copy Code

Public Enum AdjustmentHandles

Members

Member name | Description
All | Indicates all modification handles.
Move | Indicates the move handle.
None | Indicates none of the selection handles.
ResizeBottomCenter | Indicates the bottom-center resize handle.
ResizeBottomLeft | Indicates the bottom-left resize handle.
ResizeBottomRight | Indicates the bottom-right resize handle.
ResizeMiddleLeft | Indicates the middle-left resize handle.
ResizeMiddleRight | Indicates the middle-right resize handle.
ResizeTopCenter | Indicates the top-center resize handle.
ResizeTopLeft | Indicates the top-left resize handle.
ResizeTopRight | Indicates the top-right resize handle.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation Class

Annotation Class
Remarks See Also
[image]

Represents a comment of a cell within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class Annotation : IInplaceEditable

Visual Basic [image] Copy Code

Public NotInheritable Class Annotation
Implements IInplaceEditable

Remarks

Objects of this class cannot be instantiated directly. To create and associate an annotation with a cell, call the SetAnnotation method of the cell.

Example

The following example illustrates how to set and customize a cell annotation.

C# [image] Copy Code

// Create the annotation
var cell = worksheet.Cells["A1"];
cell.SetAnnotation("Test annotation");

// Customize the annotation's appearance
cell.Annotation.CellAnnotation.BackBrush = Brushes.LightSteelBlue;

Visual Basic [image] Copy Code

' Create the annotation
Dim cell = worksheet.Cells("A1")
cell.SetAnnotation("Test annotation")

' Customize the annotation's appearance
cell.Annotation.CellAnnotation.BackBrush = Brushes.LightSteelBlue

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Annotation

See Also

Annotation Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation Members

Annotation Members
Properties Methods
[image]

Represents a comment of a cell within a worksheet.

The following tables list the members exposed by the Annotation type.

Public Properties

Name | Description
CellAnnotation | Gets the interactive object associated with this annotation.
ShowAlways | Gets or sets a value indicating whether the annotation is always visible.
Text | Gets or sets the comment text of the annotation.

Public Methods

Name | Description
Remove | Removes this annotation from its owner Cell object.
ToString | Object.ToString override.

See Also

Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation Methods

Annotation Methods
[image]

Public Methods

Name | Description
Remove | Removes this annotation from its owner Cell object.
ToString | Object.ToString override.

See Also

Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation.Remove Method

Annotation.Remove Method
[image]

Removes this annotation from its owner Cell object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove ()

Visual Basic [image] Copy Code

Public Sub Remove ()

See Also

Annotation Members
Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation.ToString Method

Annotation.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of the annotation.

See Also

Annotation Members
Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation Properties

Annotation Properties
[image]

Public Properties

Name | Description
CellAnnotation | Gets the interactive object associated with this annotation.
ShowAlways | Gets or sets a value indicating whether the annotation is always visible.
Text | Gets or sets the comment text of the annotation.

See Also

Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation.CellAnnotation Property

Annotation.CellAnnotation Property
[image]

Gets the interactive object associated with this annotation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellAnnotation CellAnnotation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellAnnotation As CellAnnotation

Property Value

An instance of the CellAnnotation class that acts as the visual presentation of the annotation within the worksheet.

See Also

Annotation Members
Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation.ShowAlways Property

Annotation.ShowAlways Property
[image]

Gets or sets a value indicating whether the annotation is always visible.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowAlways { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAlways As Boolean

Property Value

true to always display the annotation object; false to display the annotation only when the user hovers with the mouse over the associated cell. The default is false.

See Also

Annotation Members
Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Annotation.Text Property

Annotation.Text Property
[image]

Gets or sets the comment text of the annotation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value. The default is an empty string.

See Also

Annotation Members
Annotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter Class

AutoFilter Class
Remarks See Also
[image]

Represents autofiltering inside a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class AutoFilter

Visual Basic [image] Copy Code

Public Class AutoFilter

Remarks

An instance of this class can be accessed through the AutoFilter property of the Worksheet class when autofiltering is enabled in the worksheet. To turn autofiltering on, call the AutoFilter method of the CellRange class.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.AutoFilter

See Also

AutoFilter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter Members

AutoFilter Members
Properties Methods
[image]

Represents autofiltering inside a worksheet.

The following tables list the members exposed by the AutoFilter type.

Public Properties

Name | Description
Filters | Gets a read-only collection with the filters of the individual columns.
On | Gets a value indicating whether at least one of the filters is active.
Range | Gets the cell range this filter is applied to.

Public Methods

Name | Description
ApplyFilter | Applies the autofilter.
ShowAllData | Displays all the data in the autofilter range.

See Also

AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter Methods

AutoFilter Methods
[image]

Public Methods

Name | Description
ApplyFilter | Applies the autofilter.
ShowAllData | Displays all the data in the autofilter range.

See Also

AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter.ApplyFilter Method

AutoFilter.ApplyFilter Method
[image]

Applies the autofilter.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ApplyFilter ()

Visual Basic [image] Copy Code

Public Sub ApplyFilter ()

See Also

AutoFilter Members
AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter.ShowAllData Method

AutoFilter.ShowAllData Method
[image]

Displays all the data in the autofilter range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ShowAllData ()

Visual Basic [image] Copy Code

Public Sub ShowAllData ()

See Also

AutoFilter Members
AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter Properties

AutoFilter Properties
[image]

Public Properties

Name | Description
Filters | Gets a read-only collection with the filters of the individual columns.
On | Gets a value indicating whether at least one of the filters is active.
Range | Gets the cell range this filter is applied to.

See Also

AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter.Filters Property

AutoFilter.Filters Property
[image]

Gets a read-only collection with the filters of the individual columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IList<Filter> Filters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Filters As IList(Of Filter)

Property Value

A list of Filter objects.

See Also

AutoFilter Members
AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter.On Property

AutoFilter.On Property
[image]

Gets a value indicating whether at least one of the filters is active.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool On { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property On As Boolean

Property Value

A boolean value.

See Also

AutoFilter Members
AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilter.Range Property

AutoFilter.Range Property
[image]

Gets the cell range this filter is applied to.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange Range { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Range As CellRange

Property Value

An instance of the CellRange class.

See Also

AutoFilter Members
AutoFilter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.AutoFilterOperator Enumeration

AutoFilterOperator Enumeration
[image]

Indicates an autofiltering operator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum AutoFilterOperator

Visual Basic [image] Copy Code

Public Enum AutoFilterOperator

Members

Member name | Description
And | Specifies logical AND of Criteria1 and Criteria2.
Bottom10Items | Lowest-valued items displayed (number of items specified in Criteria1).
Bottom10Percent | Lowest-valued items displayed (percentage specified in Criteria1).
FilterDynamic | Specifies a dynamic filter.
FilterValues | Specifies filtering based on a list of values (as specified in Criteria1).
Or | Specifies logical OR of Criteria1 or Criteria2.
Top10Items | Highest-valued items displayed (number of items specified in Criteria1).
Top10Percent | Highest-valued items displayed (percentage specified in Criteria1).

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs Class

BaseMouseEventArgs Class
[image]

Contains the arguments passed to mouse-related events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class BaseMouseEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class BaseMouseEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs
MindFusion.Spreadsheet.Wpf.CellMouseEventArgs
MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs
MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs
MindFusion.Spreadsheet.Wpf.RowMouseEventArgs

See Also

BaseMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs Members

BaseMouseEventArgs Members
Properties
[image]

Contains the arguments passed to mouse-related events.

The following tables list the members exposed by the BaseMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button.
Clicks | Gets the number of mouse clicks.
X | Gets the relative x-coordinates of the mouse.
Y | Gets the relative y-coordinates of the mouse.

See Also

BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs Properties

BaseMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button.
Clicks | Gets the number of mouse clicks.
X | Gets the relative x-coordinates of the mouse.
Y | Gets the relative y-coordinates of the mouse.

See Also

BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs.Button Property

BaseMouseEventArgs.Button Property
[image]

Gets the clicked mouse button.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MouseButton Button { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Button As MouseButton

Property Value

A member of the MouseButton enumeration.

See Also

BaseMouseEventArgs Members
BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs.Clicks Property

BaseMouseEventArgs.Clicks Property
[image]

Gets the number of mouse clicks.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Clicks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Clicks As Integer

Property Value

An integer value.

See Also

BaseMouseEventArgs Members
BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs.X Property

BaseMouseEventArgs.X Property
[image]

Gets the relative x-coordinates of the mouse.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double X { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property X As Double

Property Value

A double value.

Remarks

The origin of this coordinate depends on the specific event.

See Also

BaseMouseEventArgs Members
BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs.Y Property

BaseMouseEventArgs.Y Property
[image]

Gets the relative y-coordinates of the mouse.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double Y { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Y As Double

Property Value

A double value.

Remarks

The origin of this coordinate depends on the specific event.

See Also

BaseMouseEventArgs Members
BaseMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcExporter Class

CalcExporter Class
[image]

CalcExporter lets you export Workbook objects to OpenOffice Calc spreadsheets.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CalcExporter

Visual Basic [image] Copy Code

Public Class CalcExporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CalcExporter

See Also

CalcExporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcExporter Members

CalcExporter Members
Constructors Methods
[image]

CalcExporter lets you export Workbook objects to OpenOffice Calc spreadsheets.

The following tables list the members exposed by the CalcExporter type.

Public Constructors

Name | Description
CalcExporter | Initializes a new instance of the CalcExporter class.

Public Methods

Name | Description
Export | Exports the specified workbook to the specified OpenOffice Calc spreadsheet.

See Also

CalcExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcExporter Constructor

CalcExporter Constructor
[image]

Initializes a new instance of the CalcExporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CalcExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CalcExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcExporter Methods

CalcExporter Methods
[image]

Public Methods

Name | Description
Export | Exports the specified workbook to the specified OpenOffice Calc spreadsheet.

See Also

CalcExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcExporter.Export Method

CalcExporter.Export Method
[image]

Exports the specified workbook to the specified OpenOffice Calc spreadsheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Export (
Workbook workbook,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
workbook As Workbook, _
filePath As String _
)

Parameters

workbook

A Workbook instance to export the data from.

filePath

A string specifying the path to the .ods file.

See Also

CalcExporter Members
CalcExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcImporter Class

CalcImporter Class
[image]

CalcImporter lets you import OpenOffice Calc spreadsheets into a Workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CalcImporter

Visual Basic [image] Copy Code

Public Class CalcImporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CalcImporter

See Also

CalcImporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcImporter Members

CalcImporter Members
Constructors Methods
[image]

CalcImporter lets you import OpenOffice Calc spreadsheets into a Workbook.

The following tables list the members exposed by the CalcImporter type.

Public Constructors

Name | Description
CalcImporter | Initializes a new instance of the CalcImporter class.

Public Methods

Name | Description
Import | Imports the specified OpenOffice Calc spreadsheet into the specified workbook.

See Also

CalcImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcImporter Constructor

CalcImporter Constructor
[image]

Initializes a new instance of the CalcImporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CalcImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CalcImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcImporter Methods

CalcImporter Methods
[image]

Public Methods

Name | Description
Import | Imports the specified OpenOffice Calc spreadsheet into the specified workbook.

See Also

CalcImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CalcImporter.Import Method

CalcImporter.Import Method
[image]

Imports the specified OpenOffice Calc spreadsheet into the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Workbook workbook
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
workbook As Workbook _
)

Parameters

filePath

A string specifying the path to the .ods file.

workbook

A Workbook instance where to import the Calc data.

See Also

CalcImporter Members
CalcImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell Class

Cell Class
Remarks See Also
[image]

Identifies a single cell in a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Cell : IInplaceEditable

Visual Basic [image] Copy Code

Public Class Cell
Implements IInplaceEditable

Remarks

Instances of this class can be accessed through the Cells collection of the Worksheet class. The Cell object can be used to get or set the data contained in the cell, to customize the appearance of the cell through its Style and to associate an annotation of a hyperlink with the cell.

Example

The following example demonstrates how to set the data of a cell in an existing worksheet:

C# [image] Copy Code

var cell = worksheet.Cells["B5"];
cell.Data = 20;
cell.Style.TextBrush = Brushes.Green;

Visual Basic [image] Copy Code

Dim cell = worksheet.Cells("B5")
cell.Data = 20
cell.Style.TextBrush = Brushes.Green

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Cell

See Also

Cell Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell Members

Cell Members
Properties Methods
[image]

Identifies a single cell in a Worksheet.

The following tables list the members exposed by the Cell type.

Public Properties

Name | Description
Annotation | Gets the Annotation object that represents a comment for this cell.
Column | Gets the zero-based index of the column of the represented cell.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cell based on various conditions.
Data | Gets or sets the cell data.
Hyperlink | Gets a Hyperlink object that represents the hyperlink associated with this cell.
IsHidden | Gets a value indicating whether this cell belongs to a hidden column or row.
IsMerged | Gets a value indicating whether this cell is part of a merged cell.
Locale | Gets or sets the locale used to format the value of this cell.
Row | Gets the zero-based index of the row of the represented cell.
Style | Gets an IStyle object that can be used to customize the appearance of the cell.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the cell.
Value | Gets the effective value of this cell. If the cell contains a formula, this property should return the result of the formula evaluation.
Worksheet | Gets the worksheet this cell belongs to.

Public Methods

Name | Description
Clear | Clears the contents of this cell.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
RemoveAnnotation | Removes an annotation object from the cell.
RemoveHyperlink | Removes the hyperlink associated with this cell.
Reset | Clears the cell contents, as well as its associated style, hyperlink, annotation, conditional formatting and data validations.
SetAnnotation | Sets the text of the annotation object, associated with this cell.
SetData | Overloaded. Sets the data of the cell, represented by this object.
SetHyperlink | Sets a hyperlink, associated with this cell.
ToString | Object.ToString override.

See Also

Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell Methods

Cell Methods
[image]

Public Methods

Name | Description
Clear | Clears the contents of this cell.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
RemoveAnnotation | Removes an annotation object from the cell.
RemoveHyperlink | Removes the hyperlink associated with this cell.
Reset | Clears the cell contents, as well as its associated style, hyperlink, annotation, conditional formatting and data validations.
SetAnnotation | Sets the text of the annotation object, associated with this cell.
SetData | Overloaded. Sets the data of the cell, represented by this object.
SetHyperlink | Sets a hyperlink, associated with this cell.
ToString | Object.ToString override.

See Also

Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Clear Method

Cell.Clear Method
[image]

Clears the contents of this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Clear ()

Visual Basic [image] Copy Code

Public Function Clear () As Boolean

Return Value

true if the cell contained actual data before the call; false if the cell is already blank.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Equals Method

Cell.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.GetHashCode Method

Cell.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current object.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.RemoveAnnotation Method

Cell.RemoveAnnotation Method
[image]

Removes an annotation object from the cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void RemoveAnnotation ()

Visual Basic [image] Copy Code

Public Sub RemoveAnnotation ()

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.RemoveHyperlink Method

Cell.RemoveHyperlink Method
[image]

Removes the hyperlink associated with this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void RemoveHyperlink ()

Visual Basic [image] Copy Code

Public Sub RemoveHyperlink ()

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Reset Method

Cell.Reset Method
[image]

Clears the cell contents, as well as its associated style, hyperlink, annotation, conditional formatting and data validations.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.SetAnnotation Method

Cell.SetAnnotation Method
[image]

Sets the text of the annotation object, associated with this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SetAnnotation (
string value
)

Visual Basic [image] Copy Code

Public Sub SetAnnotation( _
value As String _
)

Parameters

value

The text of the comment.

Remarks

The annotation can be subsequently accessed and customized through the Annotation property.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.SetData Method

Cell.SetData Method
[image]

Sets the data of the cell, represented by this object.

Overload List

Name | Description
Cell.SetData (Object, Int32, Int32) | Sets the data of the cell, represented by this object.
Cell.SetData (Object, Int32, Int32, Boolean) | Sets the data of the cell, represented by this object.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.SetData Method (Object, Int32, Int32)

Cell.SetData Method (Object, Int32, Int32)
See Also
[image]

Sets the data of the cell, represented by this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SetData (
Object value,
int dcolumn,
int drow
)

Visual Basic [image] Copy Code

Public Sub SetData( _
value As Object, _
dcolumn As Integer, _
drow As Integer _
)

Parameters

value

The new data of the cell.

dcolumn

If value represents a formula, this is the column offset of all relative cell references. Otherwise, this value is ignored.

drow

If value represents a formula, this is the row offset of all relative cell references. Otherwise, this value is ignored.

Remarks

If value is a string, starting with an equal sign '=', it is interpreted as a formula. To specify a string, starting with an equal sign as cell data, prefix the string with a single apostrophe '''. The parameters dcolumn and drow can be used to offset all relative cell references in the formula. For example, the following call SetData("=A1", 1, 2) will actually set the formula "=B3" as data in the cell.

See Also

SetData Method Overload List
Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.SetData Method (Object, Int32, Int32, Boolean)

Cell.SetData Method (Object, Int32, Int32, Boolean)
See Also
[image]

Sets the data of the cell, represented by this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SetData (
Object value,
int dcolumn,
int drow,
bool isCultureInvariant
)

Visual Basic [image] Copy Code

Public Sub SetData( _
value As Object, _
dcolumn As Integer, _
drow As Integer, _
isCultureInvariant As Boolean _
)

Parameters

value

The new data of the cell.

dcolumn

If value represents a formula, this is the column offset of all relative cell references. Otherwise, this value is ignored.

drow

If value represents a formula, this is the row offset of all relative cell references. Otherwise, this value is ignored.

isCultureInvariant

true to interpret the specified data as a culture-invariant; false to interpret it in the context of the worksheet's locale.

Remarks

If value is a string, starting with an equal sign '=', it is interpreted as a formula. To specify a string, starting with an equal sign as cell data, prefix the string with a single apostrophe '''. The parameters dcolumn and drow can be used to offset all relative cell references in the formula. For example, the following call SetData("=A1", 1, 2) will actually set the formula "=B3" as data in the cell.

See Also

SetData Method Overload List
Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.SetHyperlink Method

Cell.SetHyperlink Method
[image]

Sets a hyperlink, associated with this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SetHyperlink (
HyperlinkType type,
string target,
string subTarget
)

Visual Basic [image] Copy Code

Public Sub SetHyperlink( _
type As HyperlinkType, _
target As String, _
subTarget As String _
)

Parameters

type

The type of the hyperlink.

target

The hyperlink target.

subTarget

The hyperlink sub-target.

Remarks

The hyperlink can be subsequently accessed and customized through the Hyperlink property.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.ToString Method

Cell.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of the cell.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell Properties

Cell Properties
[image]

Public Properties

Name | Description
Annotation | Gets the Annotation object that represents a comment for this cell.
Column | Gets the zero-based index of the column of the represented cell.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cell based on various conditions.
Data | Gets or sets the cell data.
Hyperlink | Gets a Hyperlink object that represents the hyperlink associated with this cell.
IsHidden | Gets a value indicating whether this cell belongs to a hidden column or row.
IsMerged | Gets a value indicating whether this cell is part of a merged cell.
Locale | Gets or sets the locale used to format the value of this cell.
Row | Gets the zero-based index of the row of the represented cell.
Style | Gets an IStyle object that can be used to customize the appearance of the cell.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the cell.
Value | Gets the effective value of this cell. If the cell contains a formula, this property should return the result of the formula evaluation.
Worksheet | Gets the worksheet this cell belongs to.

See Also

Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Annotation Property

Cell.Annotation Property
[image]

Gets the Annotation object that represents a comment for this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Annotation Annotation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Annotation As Annotation

Property Value

An instance of the Annotation class.

Remarks

To create and associate an annotation with the cell, call the SetAnnotation method.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Column Property

Cell.Column Property
[image]

Gets the zero-based index of the column of the represented cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.ConditionalFormats Property

Cell.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the cell based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Data Property

Cell.Data Property
[image]

Gets or sets the cell data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Object

Property Value

An object representing the cell data.

Remarks

If this property is set to null (Nothing in Visual Basic), this is equivalent to clearing the cell via Clear. If the specified value is a string, starting with an equal sign '=', it is interpreted as a formula. To specify a string, starting with an equal sign as cell data, prefix the string with a single apostrophe '''.

If this property is set to a string, MindFusion.Spreadsheet for WPF attempts to parse the string into one of the following types, according to the culture of the parent workbook: number (raw number, percentage, or currency), time, date, or logical. If the value cannot be converted, the value is accept as a string. The effective value of the cell can be subsequently retrieved through the Value property.

Example

The following example sets the data of an existing cell.

C# [image] Copy Code

cell.Data = "1/6/2013";
cell.Data = "45%";
cell.Data = 50;
cell.Data = "=MAX(A1:C4)";
cell.Data = "'=not a formula=";

Visual Basic [image] Copy Code

cell.Data = "1/6/2013"
cell.Data = "45%"
cell.Data = 50
cell.Data = "=MAX(A1:C4)"
cell.Data = "'=not a formula="

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Hyperlink Property

Cell.Hyperlink Property
[image]

Gets a Hyperlink object that represents the hyperlink associated with this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Hyperlink Hyperlink { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Hyperlink As Hyperlink

Property Value

An instance of the Hyperlink class.

Remarks

To create and associate a hyperlink with the cell, call the SetHyperlink method.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.IsHidden Property

Cell.IsHidden Property
[image]

Gets a value indicating whether this cell belongs to a hidden column or row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsHidden { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsHidden As Boolean

Property Value

true if the cell belongs to a hidden column or row; otherwise, false.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.IsMerged Property

Cell.IsMerged Property
[image]

Gets a value indicating whether this cell is part of a merged cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsMerged { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsMerged As Boolean

Property Value

true if the cell is part of a merged cell range; otherwise, false.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Locale Property

Cell.Locale Property
[image]

Gets or sets the locale used to format the value of this cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; set; }

Visual Basic [image] Copy Code

Public Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Row Property

Cell.Row Property
[image]

Gets the zero-based index of the row of the represented cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Style Property

Cell.Style Property
[image]

Gets an IStyle object that can be used to customize the appearance of the cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IStyle

Property Value

An IStyle instance.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Validation Property

Cell.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

Example

The following example illustrates how to set a cell validation.

C# [image] Copy Code

var validation = worksheet.Cells["J10"].Validation;
validation.Type = ValidationType.List;
validation.First = "Apples,Bananas,Plums,Strawberries";

Visual Basic [image] Copy Code

Dim validation = worksheet.Cells("J10").Validation
validation.Type = ValidationType.List
validation.First = "Apples,Bananas,Plums,Strawberries"

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Value Property

Cell.Value Property
[image]

Gets the effective value of this cell. If the cell contains a formula, this property should return the result of the formula evaluation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Object

Property Value

An object representing the cell value.

Remarks

This property cannot be assigned directly. To set the data of a cell, use the Data property.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Cell.Worksheet Property

Cell.Worksheet Property
[image]

Gets the worksheet this cell belongs to.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

A Worksheet object.

See Also

Cell Members
Cell Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation Class

CellAnnotation Class
Remarks See Also
[image]

Represents the interactive object containing a comment for a cell within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellAnnotation : InteractiveObject

Visual Basic [image] Copy Code

Public Class CellAnnotation
Inherits InteractiveObject

Remarks

Objects of this class cannot be instantiated directly. To create and associate an annotation with a cell, call the SetAnnotation method of the cell. Then, you can access the corresponding CellAnnotation object through the CellAnnotation property of the cell's Annotation.

The CellAnnotation class overrides the default values of some of the properties derived from InteractiveObject, as follows:

  • Anchor = ToCell
  • AnchorPosition = TopRight
  • VerticalOffset = "-15pt"
  • HorizontalOffset = "12pt"

In addition the CellAnnotation objects draw a black outline when LineBrush is not set.

Example

The following example illustrates how to set and customize a cell annotation.

C# [image] Copy Code

// Create the annotation
var cell = worksheet.Cells["A1"];
cell.SetAnnotation("Test annotation");

// Customize the annotation's appearance
cell.Annotation.CellAnnotation.BackBrush = Brushes.LightSteelBlue;

Visual Basic [image] Copy Code

' Create the annotation
Dim cell = worksheet.Cells("A1")
cell.SetAnnotation("Test annotation")

' Customize the annotation's appearance
cell.Annotation.CellAnnotation.BackBrush = Brushes.LightSteelBlue

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Spreadsheet.Wpf.InteractiveObject
MindFusion.Spreadsheet.Wpf.CellAnnotation

See Also

CellAnnotation Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation Members

CellAnnotation Members
Properties Methods Events
[image]

Represents the interactive object containing a comment for a cell within a worksheet.

The following tables list the members exposed by the CellAnnotation type.

Public Properties

Name | Description
Anchor | InteractiveObject.Anchor override.
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
BackBrush | Gets or sets the background color of the object.
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
FontBold | Gets or sets a value indicating whether the comment text is bold.
FontItalic | Gets or sets a value indicating whether the comment text is italic.
FontName | Gets or sets the name of the font to use in the comment.
FontSize | Gets or sets the size of the font to use in the comment.
FontStrikeout | Gets or sets a value indicating whether the comment text is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the comment text is underlined.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalAlignment | Gets or sets the horizontal alignment of the text used in the comment.
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IndicatorBrush | Gets or sets the brush of the cell indicator.
IsLockedToCell | InteractiveObject.IsLockedToCell override.
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
Margin | Gets or sets the text margins.
Parent | Gets the parent Annotation object of this instance.
ShowAlways | Gets or sets a value indicating whether the annotation is always visible.
Text | Gets or sets the comment text of the annotation.
TextBrush | Gets or sets the background color of the object.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
VerticalAlignment | Gets or sets the vertical alignment of the text used in the comment.
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)

Protected Properties

Name | Description
ExtendsOutsideBounds | InteractiveObject.ExtendsOutsideBounds override.
RegardsMergedCells | InteractiveObject.RegardsMergedCells override.

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order. (Inherited from InteractiveObject.)
BringToFront | Brings this object to the top of the z-order. (Inherited from InteractiveObject.)
Dispose | Overloaded. Disposes this object. (Inherited from InteractiveObject.)
SendBackward | Moves this object one step down in the z-order. (Inherited from InteractiveObject.)
SendToBack | Sends this object to the bottom of the z-order. (Inherited from InteractiveObject.)

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from InteractiveObject.)
OnResized | This method is called when the object's size is changed. (Inherited from InteractiveObject.)

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation Properties

CellAnnotation Properties
[image]

Public Properties

Name | Description
Anchor | InteractiveObject.Anchor override.
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
BackBrush | Gets or sets the background color of the object.
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
FontBold | Gets or sets a value indicating whether the comment text is bold.
FontItalic | Gets or sets a value indicating whether the comment text is italic.
FontName | Gets or sets the name of the font to use in the comment.
FontSize | Gets or sets the size of the font to use in the comment.
FontStrikeout | Gets or sets a value indicating whether the comment text is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the comment text is underlined.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalAlignment | Gets or sets the horizontal alignment of the text used in the comment.
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IndicatorBrush | Gets or sets the brush of the cell indicator.
IsLockedToCell | InteractiveObject.IsLockedToCell override.
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
Margin | Gets or sets the text margins.
Parent | Gets the parent Annotation object of this instance.
ShowAlways | Gets or sets a value indicating whether the annotation is always visible.
Text | Gets or sets the comment text of the annotation.
TextBrush | Gets or sets the background color of the object.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
VerticalAlignment | Gets or sets the vertical alignment of the text used in the comment.
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)

Protected Properties

Name | Description
ExtendsOutsideBounds | InteractiveObject.ExtendsOutsideBounds override.
RegardsMergedCells | InteractiveObject.RegardsMergedCells override.

See Also

CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.Anchor Property

CellAnnotation.Anchor Property
[image]

InteractiveObject.Anchor override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override ObjectAnchor Anchor { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Anchor As ObjectAnchor

Property Value

A member of the ObjectAnchor enumeration. The default is ToCell.

Remarks

This property cannot be set to ToPage for CellAnnotation objects.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.BackBrush Property

CellAnnotation.BackBrush Property
[image]

Gets or sets the background color of the object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the background of the annotation will be set to SystemColors.InfoBrush.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.ExtendsOutsideBounds Property

CellAnnotation.ExtendsOutsideBounds Property
[image]

InteractiveObject.ExtendsOutsideBounds override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool ExtendsOutsideBounds { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property ExtendsOutsideBounds As Boolean

Property Value

A boolean value. Always returns true.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontBold Property

CellAnnotation.FontBold Property
[image]

Gets or sets a value indicating whether the comment text is bold.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontBold { get; set; }

Visual Basic [image] Copy Code

Public Property FontBold As Nullable(Of Boolean)

Property Value

An boolean value or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the font style of the annotation will be set to Regular.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontItalic Property

CellAnnotation.FontItalic Property
[image]

Gets or sets a value indicating whether the comment text is italic.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property FontItalic As Nullable(Of Boolean)

Property Value

An boolean value or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the font style of the annotation will be set to Regular.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontName Property

CellAnnotation.FontName Property
[image]

Gets or sets the name of the font to use in the comment.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

If this property is set to null (Nothing in Visual Basic), the font name of the annotation will be set to "Segoe UI".

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontSize Property

CellAnnotation.FontSize Property
[image]

Gets or sets the size of the font to use in the comment.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

Remarks

If this property is set to null (Nothing in Visual Basic), the font size of the annotation will be set to 9.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontStrikeout Property

CellAnnotation.FontStrikeout Property
[image]

Gets or sets a value indicating whether the comment text is with a line through the middle.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property FontStrikeout As Nullable(Of Boolean)

Property Value

An boolean value or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the font style of the annotation will be set to Regular.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.FontUnderline Property

CellAnnotation.FontUnderline Property
[image]

Gets or sets a value indicating whether the comment text is underlined.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontUnderline { get; set; }

Visual Basic [image] Copy Code

Public Property FontUnderline As Nullable(Of Boolean)

Property Value

An boolean value or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the font style of the annotation will be set to Regular.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.HorizontalAlignment Property

CellAnnotation.HorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the text used in the comment.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalAlignment As HorizontalAlignment

Property Value

A member of the HorizontalAlignment enumeration. The default is Default.

Remarks

If this property is set to Default, the horizontal alignment of the annotation will be set to Left.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.IndicatorBrush Property

CellAnnotation.IndicatorBrush Property
[image]

Gets or sets the brush of the cell indicator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush IndicatorBrush { get; set; }

Visual Basic [image] Copy Code

Public Property IndicatorBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the indicator color of the annotation will be set to Red.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.IsLockedToCell Property

CellAnnotation.IsLockedToCell Property
[image]

InteractiveObject.IsLockedToCell override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool IsLockedToCell { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property IsLockedToCell As Boolean

Property Value

A boolean value. Always returns true.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.Margin Property

CellAnnotation.Margin Property
[image]

Gets or sets the text margins.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set to null (Nothing in Visual Basic), the margin of the annotation will be set to "1.5pt".

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.Parent Property

CellAnnotation.Parent Property
[image]

Gets the parent Annotation object of this instance.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Annotation Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As Annotation

Property Value

An instance of the Annotation class.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.RegardsMergedCells Property

CellAnnotation.RegardsMergedCells Property
[image]

InteractiveObject.RegardsMergedCells override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool RegardsMergedCells { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property RegardsMergedCells As Boolean

Property Value

A boolean value. Always returns true.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.ShowAlways Property

CellAnnotation.ShowAlways Property
[image]

Gets or sets a value indicating whether the annotation is always visible.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowAlways { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAlways As Boolean

Property Value

true to always display the annotation object; false to display the annotation only when the user hovers with the mouse over the associated cell. The default is false.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.Text Property

CellAnnotation.Text Property
[image]

Gets or sets the comment text of the annotation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value. The default is an empty string.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.TextBrush Property

CellAnnotation.TextBrush Property
[image]

Gets or sets the background color of the object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

Remarks

If this property is set to null (Nothing in Visual Basic), the text color of the annotation will be set to SystemColors.InfoTextBrush.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation.VerticalAlignment Property

CellAnnotation.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the text used in the comment.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlignment As VerticalAlignment

Property Value

A member of the VerticalAlignment enumeration. The default is Default.

Remarks

If this property is set to Default, the vertical alignment of the annotation will be set to Top.

See Also

CellAnnotation Members
CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotation Events

CellAnnotation Events
[image]

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

CellAnnotation Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.PropertyValueChanged Event

InteractiveObject.PropertyValueChanged Event
[image]

INotifyPropertyValueChanged.PropertyValueChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Public Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

Event Data

PropertyValueChanged event handlers receive an argument of type PropertyEventArgs.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter Class

CellAnnotationPresenter Class
[image]

Defines the presentation of cell annotations in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellAnnotationPresenter : InteractiveObjectPresenter

Visual Basic [image] Copy Code

Public Class CellAnnotationPresenter
Inherits InteractiveObjectPresenter

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter
MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter

See Also

CellAnnotationPresenter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter Members

CellAnnotationPresenter Members
Fields Properties Methods
[image]

Defines the presentation of cell annotations in the WorkbookView control.

The following tables list the members exposed by the CellAnnotationPresenter type.

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property. (Inherited from InteractiveObjectPresenter.)
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from InteractiveObjectPresenter.)
ObjectProperty | Identifies the Object dependency property. (Inherited from InteractiveObjectPresenter.)

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property. (Inherited from InteractiveObjectPresenter.)

Public Methods

Name | Description
OnApplyTemplate | InteractiveObjectPresenter.OnApplyTemplate override.

Protected Methods

Name | Description
GetLayoutClip | FrameworkElement.GetLayoutClip override. (Inherited from InteractiveObjectPresenter.)
OnRender | UIElement.OnRender override.

See Also

CellAnnotationPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter Methods

CellAnnotationPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | InteractiveObjectPresenter.OnApplyTemplate override.

Protected Methods

Name | Description
GetLayoutClip | FrameworkElement.GetLayoutClip override. (Inherited from InteractiveObjectPresenter.)
OnRender | UIElement.OnRender override.

See Also

CellAnnotationPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter.OnApplyTemplate Method

CellAnnotationPresenter.OnApplyTemplate Method
[image]

InteractiveObjectPresenter.OnApplyTemplate override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

CellAnnotationPresenter Members
CellAnnotationPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter.OnRender Method

CellAnnotationPresenter.OnRender Method
[image]

UIElement.OnRender override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

See Also

CellAnnotationPresenter Members
CellAnnotationPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellChangedEventArgs Class

CellChangedEventArgs Class
[image]

Provides data for the CellChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellChangedEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class CellChangedEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.CellEventArgs
MindFusion.Spreadsheet.Wpf.CellChangedEventArgs

See Also

CellChangedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellChangedEventArgs Members

CellChangedEventArgs Members
Properties
[image]

Provides data for the CellChanged event.

The following tables list the members exposed by the CellChangedEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
NewData | Gets the new data in the modified cell.
OldData | Gets the previous data in the modified cell.

See Also

CellChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellChangedEventArgs Properties

CellChangedEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
NewData | Gets the new data in the modified cell.
OldData | Gets the previous data in the modified cell.

See Also

CellChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellChangedEventArgs.NewData Property

CellChangedEventArgs.NewData Property
[image]

Gets the new data in the modified cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object NewData { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewData As Object

Property Value

An object representing the new data of the cell.

See Also

CellChangedEventArgs Members
CellChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellChangedEventArgs.OldData Property

CellChangedEventArgs.OldData Property
[image]

Gets the previous data in the modified cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object OldData { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldData As Object

Property Value

An object representing the previous data of the cell.

See Also

CellChangedEventArgs Members
CellChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection Class

CellCollection Class
[image]

Represents a specialized collection for worksheet cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellCollection : IEnumerable<Cell>, IEnumerable

Visual Basic [image] Copy Code

Public Class CellCollection
Implements IEnumerable(Of Cell), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CellCollection

See Also

CellCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection Members

CellCollection Members
Properties Methods
[image]

Represents a specialized collection for worksheet cells.

The following tables list the members exposed by the CellCollection type.

Public Properties

Name | Description
Item | Overloaded. Gets a Cell object that can be used to manipulate the data of a worksheet cell.

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection Methods

CellCollection Methods
[image]

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.

See Also

CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection.GetEnumerator Method

CellCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Cell> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Cell)

Return Value

An IEnumerator that can be used to iterate through the collection.

Remarks

The returned enumerator iterates only though the cells that are not blank.

See Also

CellCollection Members
CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection Properties

CellCollection Properties
[image]

Public Properties

Name | Description
Item | Overloaded. Gets a Cell object that can be used to manipulate the data of a worksheet cell.

See Also

CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection.Item Property

CellCollection.Item Property
[image]

Gets a Cell object that can be used to manipulate the data of a worksheet cell.

Overload List

Name | Description
CellCollection.Item (Int32, Int32) | Gets a Cell object that can be used to manipulate the data of the cell with the specified coordinates.
CellCollection.Item (String) | Gets a Cell object that can be used to manipulate the data of the specified cell.

See Also

CellCollection Members
CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection.Item Property (Int32, Int32)

CellCollection.Item Property (Int32, Int32)
See Also
[image]

Gets a Cell object that can be used to manipulate the data of the cell with the specified coordinates.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Item [
int column,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Integer, _
row As Integer _
) As Cell

Parameters

column

The zero-based index of the cell column.

row

The zero-based index of the cell row.

Property Value

A Cell object that can be used to get or set the data of the cell.

See Also

Item Property Overload List
CellCollection Members
CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellCollection.Item Property (String)

CellCollection.Item Property (String)
See Also
[image]

Gets a Cell object that can be used to manipulate the data of the specified cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Item [
string reference
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
reference As String _
) As Cell

Parameters

reference

A string value representing a cell reference in the A1 or R1C1 format.

Property Value

A Cell object that can be used to get or set the data of the cell.

Remarks

If reference is not a valid cell reference, represents a cell range, or contains a sheet name other than that of the current worksheet, this property returns null (Nothing in Visual Basic).

See Also

Item Property Overload List
CellCollection Members
CellCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellData Class

CellData Class
[image]

Represents a copy of the cell data in a worksheet region. Instances of this class can be obtained by calling the CopyData method of a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellData

Visual Basic [image] Copy Code

Public Class CellData

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CellData

See Also

CellData Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellData Members

CellData Members
[image]

Represents a copy of the cell data in a worksheet region. Instances of this class can be obtained by calling the CopyData method of a Worksheet.

The following tables list the members exposed by the CellData type.

See Also

CellData Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellEventArgs Class

CellEventArgs Class
[image]

Provides data for events related to individual cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.CellEventArgs
MindFusion.Spreadsheet.Wpf.CellChangedEventArgs
MindFusion.Spreadsheet.Wpf.CellValidationEventArgs
MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs

See Also

CellEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellEventArgs Members

CellEventArgs Members
Properties
[image]

Provides data for events related to individual cells.

The following tables list the members exposed by the CellEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell related to the event.

See Also

CellEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellEventArgs Properties

CellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell related to the event.

See Also

CellEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellEventArgs.Cell Property

CellEventArgs.Cell Property
[image]

Gets the cell related to the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As Cell

Property Value

An instance of the Cell class.

See Also

CellEventArgs Members
CellEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellMouseEventArgs Class

CellMouseEventArgs Class
[image]

Contains the arguments passed to cell-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellMouseEventArgs : BaseMouseEventArgs

Visual Basic [image] Copy Code

Public Class CellMouseEventArgs
Inherits BaseMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs
MindFusion.Spreadsheet.Wpf.CellMouseEventArgs

See Also

CellMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellMouseEventArgs Members

CellMouseEventArgs Members
Properties
[image]

Contains the arguments passed to cell-related mouse events.

The following tables list the members exposed by the CellMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Cell | Gets the cell for which the event was raised.
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

CellMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellMouseEventArgs Properties

CellMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Cell | Gets the cell for which the event was raised.
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

CellMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellMouseEventArgs.Cell Property

CellMouseEventArgs.Cell Property
[image]

Gets the cell for which the event was raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As Cell

Property Value

An instance of the Cell class.

See Also

CellMouseEventArgs Members
CellMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange Class

CellRange Class
Remarks See Also
[image]

Identifies a range of cells in a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellRange : IEnumerable<Cell>, IEnumerable

Visual Basic [image] Copy Code

Public Class CellRange
Implements IEnumerable(Of Cell), IEnumerable

Remarks

Instances of this class can be accessed through the CellRanges collection of the Worksheet class. The CellRange object can be used to customize the appearance of all cells in the range through its Style, to insert, delete, merge and unmerge cells.

Example

The following example demonstrates how to merge the cells A1:C4 in a worksheet:

C# [image] Copy Code

worksheet.CellRanges["A1:C4"].Merge();

Visual Basic [image] Copy Code

worksheet.CellRanges("A1:C4").Merge()

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CellRange

See Also

CellRange Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange Members

CellRange Members
Properties Methods
[image]

Identifies a range of cells in a Worksheet.

The following tables list the members exposed by the CellRange type.

Public Properties

Name | Description
Bottom | Gets the bottom side of the range.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the range based on various conditions.
Left | Gets the left side of the range.
Right | Gets the right side of the range.
Style | Gets an IStyle object that can be used to customize the appearance of all cells in the range.
Top | Gets the top side of the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the cell range.

Public Methods

Name | Description
AutoFill | Automatically fills the values of the cells in the specified range based on the values of the cells in this range.
AutoFilter | Overloaded. Enables or toggles autofiltering.
Clear | Clears the content of the cells in this range.
FillData | Fills the data in this range according to the current data and the specified options.
GetEnumerator | Returns an enumerator object that can be used to iterate through the cells in the range.
Insert | Inserts new cells in the current range of cells. The existing cells are pushed down or right based on the value of direction.
Merge | Merges the cells in this range into a single cell.
MoveTo | Overloaded. Moves the data from the current range to another location.
Remove | Remove the cells in the current range of cells.
Reset | Clears the contents of the cells in the range, as well as their associated styles, hyperlinks, annotations, conditional formatting and data validations.
Sort | Sorts the data in this range according to the specified options.
ToString | Object.ToString override.
Unmerge | Unmerges all merged cells intersecting with this range.

See Also

CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange Methods

CellRange Methods
[image]

Public Methods

Name | Description
AutoFill | Automatically fills the values of the cells in the specified range based on the values of the cells in this range.
AutoFilter | Overloaded. Enables or toggles autofiltering.
Clear | Clears the content of the cells in this range.
FillData | Fills the data in this range according to the current data and the specified options.
GetEnumerator | Returns an enumerator object that can be used to iterate through the cells in the range.
Insert | Inserts new cells in the current range of cells. The existing cells are pushed down or right based on the value of direction.
Merge | Merges the cells in this range into a single cell.
MoveTo | Overloaded. Moves the data from the current range to another location.
Remove | Remove the cells in the current range of cells.
Reset | Clears the contents of the cells in the range, as well as their associated styles, hyperlinks, annotations, conditional formatting and data validations.
Sort | Sorts the data in this range according to the specified options.
ToString | Object.ToString override.
Unmerge | Unmerges all merged cells intersecting with this range.

See Also

CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.AutoFill Method

CellRange.AutoFill Method
[image]

Automatically fills the values of the cells in the specified range based on the values of the cells in this range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AutoFill (
CellRange target,
bool horizontal,
bool copyOnly
)

Visual Basic [image] Copy Code

Public Function AutoFill( _
target As CellRange, _
horizontal As Boolean, _
copyOnly As Boolean _
) As Boolean

Parameters

target

The range to fill.

horizontal

A flag indicating the direction of the fill.

copyOnly

A flag indicating whether to perform a raw copy, rather than increments/estimates.

Return Value

true, if the fill was successful; otherwise, false.

Remarks

The autofill operation will fail if the specified range intersects with this range.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.AutoFilter Method

CellRange.AutoFilter Method
[image]

Enables or toggles autofiltering.

Overload List

Name | Description
CellRange.AutoFilter () | Toggles autofiltering for the columns in this range.
CellRange.AutoFilter (Int32, Object, AutoFilterOperator, Object, Boolean) | Enables autofiltering for the specified column in this range using the specified criteria.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.AutoFilter Method ()

CellRange.AutoFilter Method ()
See Also
[image]

Toggles autofiltering for the columns in this range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AutoFilter ()

Visual Basic [image] Copy Code

Public Function AutoFilter () As Boolean

Return Value

true if autofiltering was successfully toggled; otherwise, false.

See Also

AutoFilter Method Overload List
CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.AutoFilter Method (Int32, Object, AutoFilterOperator, Object, Boolean)

CellRange.AutoFilter Method (Int32, Object, AutoFilterOperator, Object, Boolean)
See Also
[image]

Enables autofiltering for the specified column in this range using the specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void AutoFilter (
int field,
Object criteria1,
AutoFilterOperator op,
Object criteria2,
bool visibleDropDown
)

Visual Basic [image] Copy Code

Public Sub AutoFilter( _
field As Integer, _
criteria1 As Object, _
op As AutoFilterOperator, _
criteria2 As Object, _
visibleDropDown As Boolean _
)

Parameters

field

The 1-based index of the column, relatively to the leftmost column in the range.

criteria1

A string or an array of values, specifying the first criteria, for example "101". Use "=" to find blank fields, or use "<>" to find nonblank fields. If this argument is omitted, the criteria is All. If op is Top10Items, criteria1 specifies the number of items, for example, "10".

op

A value specifying the type of the filter.

criteria2

The second criteria. Used with criteria1 and op to construct compound criteria.

visibleDropDown

true to display the autofilter drop-down arrow for the filtered field; false to hide the autofilter drop-down arrow for the filtered field.

See Also

AutoFilter Method Overload List
CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Clear Method

CellRange.Clear Method
[image]

Clears the content of the cells in this range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Clear ()

Visual Basic [image] Copy Code

Public Function Clear () As Boolean

Return Value

true if at least one cell has been cleared; otherwise, false.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.FillData Method

CellRange.FillData Method
[image]

Fills the data in this range according to the current data and the specified options.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void FillData (
FillType type,
FillDirection direction,
FillDate date,
double step,
Nullable<Double> stop,
bool trend
)

Visual Basic [image] Copy Code

Public Sub FillData( _
type As FillType, _
direction As FillDirection, _
date As FillDate, _
step As Double, _
stop As Nullable(Of Double), _
trend As Boolean _
)

Parameters

type

The fill type.

direction

The fill direction.

date

The date component to increment when the fill type is Date. This parameter is ignored for any of the other fill types.

step

The increment step. This parameter is ignored if the fill type is Auto or when using linear or growth trend.

stop

The fill restriction. The fill will stop when the running value exceeds this restriction. This parameter is ignored if the fill type is Auto or when using linear or growth trend.

trend

A flag indicating whether to use linear or growth trend. This flag can be combined with the Linear and Growth fill types to specify the actual trend.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.GetEnumerator Method

CellRange.GetEnumerator Method
[image]

Returns an enumerator object that can be used to iterate through the cells in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Cell> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Cell)

Return Value

An IEnumerator<Cell> object that can be used to iterate through the cells in the range.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Insert Method

CellRange.Insert Method
[image]

Inserts new cells in the current range of cells. The existing cells are pushed down or right based on the value of direction.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
PushDirection direction
)

Visual Basic [image] Copy Code

Public Sub Insert( _
direction As PushDirection _
)

Parameters

direction

Specifies the direction to push the existing cells in the range.

Remarks

This method will raise an InvalidOperationException exception if the operation would cause filled cells to be shifted beyond the sheet.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Merge Method

CellRange.Merge Method
[image]

Merges the cells in this range into a single cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Merge ()

Visual Basic [image] Copy Code

Public Function Merge () As Boolean

Return Value

true if the merge was successful; otherwise, false.

Remarks

The merge will fail if the current range contains only a single cell or if the range intersects with another merged cell.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.MoveTo Method

CellRange.MoveTo Method
[image]

Moves the data from the current range to another location.

Overload List

Name | Description
CellRange.MoveTo (Cell) | Moves the data from the current range to the range identified by the specified cell.
CellRange.MoveTo (Int32, Int32) | Moves the data from the current range to the range identified by the specified column and row.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.MoveTo Method (Cell)

CellRange.MoveTo Method (Cell)
See Also
[image]

Moves the data from the current range to the range identified by the specified cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool MoveTo (
Cell targetCell
)

Visual Basic [image] Copy Code

Public Function MoveTo( _
targetCell As Cell _
) As Boolean

Parameters

targetCell

The top-left cell of the target range.

Return Value

true if successful; otherwise, false.

Remarks

This method will raise an InvalidOperationException exception if the target range is outside of the current worksheet.

See Also

MoveTo Method Overload List
CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.MoveTo Method (Int32, Int32)

CellRange.MoveTo Method (Int32, Int32)
See Also
[image]

Moves the data from the current range to the range identified by the specified column and row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool MoveTo (
int targetColumn,
int targetRow
)

Visual Basic [image] Copy Code

Public Function MoveTo( _
targetColumn As Integer, _
targetRow As Integer _
) As Boolean

Parameters

targetColumn

The leftmost column of the target range.

targetRow

The topmost row of the target range.

Return Value

true if successful; otherwise, false.

Remarks

This method will raise an ArgumentOutOfRangeException exception if the target range is outside of the current worksheet.

See Also

MoveTo Method Overload List
CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Remove Method

CellRange.Remove Method
[image]

Remove the cells in the current range of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
ShiftDirection direction
)

Visual Basic [image] Copy Code

Public Sub Remove( _
direction As ShiftDirection _
)

Parameters

direction

Specifies how to fill the space of the removed cells.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Reset Method

CellRange.Reset Method
[image]

Clears the contents of the cells in the range, as well as their associated styles, hyperlinks, annotations, conditional formatting and data validations.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Sort Method

CellRange.Sort Method
[image]

Sorts the data in this range according to the specified options.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Sort (
SortOptions options
)

Visual Basic [image] Copy Code

Public Function Sort( _
options As SortOptions _
) As Boolean

Parameters

options

The sort settings, such as sort keys and direction.

Return Value

true if the sort was successful; otherwise, false.

Remarks

The sorting will fail if there are no keys specified or if all keys are outside of the current range.

Example

The following example illustrates how to sort the data in range A1:D10 in an existing worksheet by the first column.

C# [image] Copy Code

SortOptions options = new SortOptions();
options.Keys.Add(new SortKey(0));
worksheet.CellRanges["A1:D10"].Sort(options);

Visual Basic [image] Copy Code

Dim options As New SortOptions()
options.Keys.Add(New SortKey(0))
worksheet.CellRanges("A1:D10").Sort(options)

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.ToString Method

CellRange.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Unmerge Method

CellRange.Unmerge Method
[image]

Unmerges all merged cells intersecting with this range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Unmerge ()

Visual Basic [image] Copy Code

Public Sub Unmerge ()

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange Properties

CellRange Properties
[image]

Public Properties

Name | Description
Bottom | Gets the bottom side of the range.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the range based on various conditions.
Left | Gets the left side of the range.
Right | Gets the right side of the range.
Style | Gets an IStyle object that can be used to customize the appearance of all cells in the range.
Top | Gets the top side of the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the cell range.

See Also

CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Bottom Property

CellRange.Bottom Property
[image]

Gets the bottom side of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Bottom { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bottom As Integer

Property Value

An integer value.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.ConditionalFormats Property

CellRange.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the cells in the range based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Left Property

CellRange.Left Property
[image]

Gets the left side of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Left { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Left As Integer

Property Value

An integer value.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Right Property

CellRange.Right Property
[image]

Gets the right side of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Right { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Right As Integer

Property Value

An integer value.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Style Property

CellRange.Style Property
[image]

Gets an IStyle object that can be used to customize the appearance of all cells in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IStyle

Property Value

An IStyle instance.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Top Property

CellRange.Top Property
[image]

Gets the top side of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Top { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Top As Integer

Property Value

An integer value.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRange.Validation Property

CellRange.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the cell range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

See Also

CellRange Members
CellRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection Class

CellRangeCollection Class
[image]

Represents a specialized collection for cell ranges.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellRangeCollection

Visual Basic [image] Copy Code

Public Class CellRangeCollection

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CellRangeCollection

See Also

CellRangeCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection Members

CellRangeCollection Members
Properties
[image]

Represents a specialized collection for cell ranges.

The following tables list the members exposed by the CellRangeCollection type.

Public Properties

Name | Description
Item | Overloaded. Gets a CellRange object that can be used to manipulate the data of the cells in a specified range.

See Also

CellRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection Properties

CellRangeCollection Properties
[image]

Public Properties

Name | Description
Item | Overloaded. Gets a CellRange object that can be used to manipulate the data of the cells in a specified range.

See Also

CellRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection.Item Property

CellRangeCollection.Item Property
[image]

Gets a CellRange object that can be used to manipulate the data of the cells in a specified range.

Overload List

Name | Description
CellRangeCollection.Item (Int32, Int32, Int32, Int32) | Gets a CellRange object that can be used to manipulate the data of the cells in the specified range.
CellRangeCollection.Item (String) | Gets a CellRange object that can be used to manipulate the data of the cells in the specified range.

See Also

CellRangeCollection Members
CellRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection.Item Property (Int32, Int32, Int32, Int32)

CellRangeCollection.Item Property (Int32, Int32, Int32, Int32)
See Also
[image]

Gets a CellRange object that can be used to manipulate the data of the cells in the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange Item [
int topLeftColumn,
int topLeftRow,
int bottomRightColumn,
int bottomRightRow
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
topLeftColumn As Integer, _
topLeftRow As Integer, _
bottomRightColumn As Integer, _
bottomRightRow As Integer _
) As CellRange

Parameters

topLeftColumn

The zero-based index of the top-left column of the range.

topLeftRow

The zero-based index of the top-left row of the range.

bottomRightColumn

The zero-based index of the bottom-right column of the range.

bottomRightRow

The zero-based index of the bottom-right row of the range.

Property Value

A CellRange object that can be used to manipulate the cells in the range.

See Also

Item Property Overload List
CellRangeCollection Members
CellRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellRangeCollection.Item Property (String)

CellRangeCollection.Item Property (String)
See Also
[image]

Gets a CellRange object that can be used to manipulate the data of the cells in the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange Item [
string range
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
range As String _
) As CellRange

Parameters

range

A string identifying the range to get, in the format 'A1:B2'.

Property Value

A CellRange object that can be used to manipulate the cells in the range.

See Also

Item Property Overload List
CellRangeCollection Members
CellRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellValidationEventArgs Class

CellValidationEventArgs Class
[image]

Provides data for validation events related to individual cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CellValidationEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class CellValidationEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.CellEventArgs
MindFusion.Spreadsheet.Wpf.CellValidationEventArgs

See Also

CellValidationEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellValidationEventArgs Members

CellValidationEventArgs Members
Properties
[image]

Provides data for validation events related to individual cells.

The following tables list the members exposed by the CellValidationEventArgs type.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the related operation.
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
NewData | Gets the new data of the cell.

See Also

CellValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellValidationEventArgs Properties

CellValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the related operation.
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
NewData | Gets the new data of the cell.

See Also

CellValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellValidationEventArgs.Cancel Property

CellValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the related operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; otherwise, false. The default is false.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CellValidationEventArgs.NewData Property

CellValidationEventArgs.NewData Property
[image]

Gets the new data of the cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object NewData { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewData As Object

Property Value

An object representing the new data of the cell.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ChangeWorksheetCommand Class

ChangeWorksheetCommand Class
Remarks See Also
[image]

Represents a command that can track and undo changes of a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ChangeWorksheetCommand : TrackChangesCommand

Visual Basic [image] Copy Code

Public Class ChangeWorksheetCommand
Inherits TrackChangesCommand

Remarks

The ChangeWorksheetCommand can be used to track and undo worksheet changes. The ChangeWorksheetCommand class cannot be instantiated directly. To create a ChangeWorksheetCommand object, call the StartChangeOperation method of the Workbook class. After the command has been started, most modifications of the worksheet will be automatically recorded into this command. To complete the command, either call the CommitChangeOperation method of the Workbook class or the Dispose method of the command itself. To cancel the command (and revert all recorded modifications), call the CancelChangeOperation method of the Workbook class or the Cancel method of the command.

Example

The following code changes the name and the data of an existing worksheet. Note, that due to the disposable pattern, the change command is automatically executed at the end of the using block.

C# [image] Copy Code

using (workbook.StartChangeOperation(worksheet))
{
worksheet.Name = "My worksheet";
worksheet.Cells["A1"].Data = 100;
}

Visual Basic [image] Copy Code

Using workbook.StartChangeOperation(worksheet)
worksheet.Name = "My worksheet"
worksheet.Cells("A1").Data = 100
End Using

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.DisposableCommand
MindFusion.Spreadsheet.Wpf.TrackChangesCommand
MindFusion.Spreadsheet.Wpf.ChangeWorksheetCommand

See Also

ChangeWorksheetCommand Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ChangeWorksheetCommand Members

ChangeWorksheetCommand Members
Properties Methods
[image]

Represents a command that can track and undo changes of a Worksheet.

The following tables list the members exposed by the ChangeWorksheetCommand type.

Protected Properties

Name | Description
HasEffect | Command.HasEffect override. (Inherited from TrackChangesCommand.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Cancel | Cancels the command. (Inherited from DisposableCommand.)
Dispose | IDisposable.Dispose implementation. (Inherited from DisposableCommand.)

Protected Methods

Name | Description
BeginChange | Called before undoing or redoing the command. (Inherited from TrackChangesCommand.)
EndChange | Called after undoing or redoing the command. (Inherited from TrackChangesCommand.)
Execute | Command.Execute override. (Inherited from DisposableCommand.)
Redo | DisposableCommand.Redo override. (Inherited from TrackChangesCommand.)
Undo | DisposableCommand.Undo override. (Inherited from TrackChangesCommand.)

See Also

ChangeWorksheetCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column Class

Column Class
Remarks See Also
[image]

Identifies a column in a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Column

Visual Basic [image] Copy Code

Public Class Column

Remarks

Instances of this class can be accessed through the Columns collection of the Worksheet class.

Example

The following example demonstrates how to access and modify a column in an existing worksheet:

C# [image] Copy Code

worksheet.Columns[2].Width = "1.5in";

Visual Basic [image] Copy Code

worksheet.Columns(2).Width = "1.5in"

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Column

See Also

Column Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column Members

Column Members
Properties
[image]

Identifies a column in a worksheet.

The following tables list the members exposed by the Column type.

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the column based on various conditions.
Index | Gets the zero-based index of the represented column.
IsCollapsed | Gets or sets a value indicating whether the group represented by this column is collapsed.
IsHidden | Gets or sets a value indicating whether the column is hidden.
OutlineLevel | Gets or sets the outline level of the column, or 0, if the column is not grouped.
PageBreak | Gets or sets a value indicating whether to force a page break after this column during printing.
Style | Gets an IColumnStyle object that can be used to customize the appearance of all cells in the column.
Tag | Gets or sets a custom object associated with this column.
Title | Gets or sets the column title.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the column.
Width | Gets or sets the width of the column.

See Also

Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column Properties

Column Properties
[image]

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the column based on various conditions.
Index | Gets the zero-based index of the represented column.
IsCollapsed | Gets or sets a value indicating whether the group represented by this column is collapsed.
IsHidden | Gets or sets a value indicating whether the column is hidden.
OutlineLevel | Gets or sets the outline level of the column, or 0, if the column is not grouped.
PageBreak | Gets or sets a value indicating whether to force a page break after this column during printing.
Style | Gets an IColumnStyle object that can be used to customize the appearance of all cells in the column.
Tag | Gets or sets a custom object associated with this column.
Title | Gets or sets the column title.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the column.
Width | Gets or sets the width of the column.

See Also

Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.ConditionalFormats Property

Column.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the cells in the column based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Index Property

Column.Index Property
[image]

Gets the zero-based index of the represented column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.IsCollapsed Property

Column.IsCollapsed Property
[image]

Gets or sets a value indicating whether the group represented by this column is collapsed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsCollapsed { get; set; }

Visual Basic [image] Copy Code

Public Property IsCollapsed As Boolean

Property Value

A boolean value.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.IsHidden Property

Column.IsHidden Property
[image]

Gets or sets a value indicating whether the column is hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsHidden { get; set; }

Visual Basic [image] Copy Code

Public Property IsHidden As Boolean

Property Value

true if the column is hidden; otherwise, false. The default is false.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.OutlineLevel Property

Column.OutlineLevel Property
[image]

Gets or sets the outline level of the column, or 0, if the column is not grouped.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineLevel As Integer

Property Value

An integer value.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.PageBreak Property

Column.PageBreak Property
[image]

Gets or sets a value indicating whether to force a page break after this column during printing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool PageBreak { get; set; }

Visual Basic [image] Copy Code

Public Property PageBreak As Boolean

Property Value

true if this column should force a page break during printing; otherwise, false. The default is false.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Style Property

Column.Style Property
[image]

Gets an IColumnStyle object that can be used to customize the appearance of all cells in the column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IColumnStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IColumnStyle

Property Value

An IColumnStyle instance.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Tag Property

Column.Tag Property
[image]

Gets or sets a custom object associated with this column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the custom data associated with this column.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Title Property

Column.Title Property
[image]

Gets or sets the column title.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Validation Property

Column.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

Example

The following example illustrates how to set a validation for the cells in a column.

C# [image] Copy Code

var validation = worksheet.Columns[10].Validation;
validation.Type = ValidationType.List;
validation.First = "Apples,Bananas,Plums,Strawberries";

Visual Basic [image] Copy Code

Dim validation = worksheet.Columns(10).Validation
validation.Type = ValidationType.List
validation.First = "Apples,Bananas,Plums,Strawberries"

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Column.Width Property

Column.Width Property
[image]

Gets or sets the width of the column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic) indicating that the width of the column is specified through the DefaultColumnWidth property of the parent Worksheet.

See Also

Column Members
Column Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs Class

ColumnChangedEventArgs Class
[image]

Provides data for the ColumnChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnChangedEventArgs : PropertyEventArgs

Visual Basic [image] Copy Code

Public Class ColumnChangedEventArgs
Inherits PropertyEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.PropertyEventArgs
MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs

See Also

ColumnChangedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs Members

ColumnChangedEventArgs Members
Properties
[image]

Provides data for the ColumnChanged event.

The following tables list the members exposed by the ColumnChangedEventArgs type.

Public Properties

Name | Description
Column | Gets the column related to the event.
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Worksheet | Gets the worksheet that is the source of the event.

See Also

ColumnChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs Properties

ColumnChangedEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the column related to the event.
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Worksheet | Gets the worksheet that is the source of the event.

See Also

ColumnChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs.Column Property

ColumnChangedEventArgs.Column Property
[image]

Gets the column related to the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Column Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Column

Property Value

An instance of the Column class.

See Also

ColumnChangedEventArgs Members
ColumnChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs.Worksheet Property

ColumnChangedEventArgs.Worksheet Property
[image]

Gets the worksheet that is the source of the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

ColumnChangedEventArgs Members
ColumnChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection Class

ColumnCollection Class
[image]

Represents a specialized collection for worksheet columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnCollection : IEnumerable<Column>, IEnumerable

Visual Basic [image] Copy Code

Public Class ColumnCollection
Implements IEnumerable(Of Column), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.ColumnCollection

See Also

ColumnCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection Members

ColumnCollection Members
Properties Methods
[image]

Represents a specialized collection for worksheet columns.

The following tables list the members exposed by the ColumnCollection type.

Public Properties

Name | Description
Count | Gets the number of columns in the collection.
Item | Overloaded. Gets a column or a range of columns at the specified index.

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts one or more columns at a specified index.
Move | Overloaded. Moves the specified column or columns to another location.
Remove | Overloaded. Removes one or more columns at a specified index.

See Also

ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection Methods

ColumnCollection Methods
[image]

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts one or more columns at a specified index.
Move | Overloaded. Moves the specified column or columns to another location.
Remove | Overloaded. Removes one or more columns at a specified index.

See Also

ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.GetEnumerator Method

ColumnCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Column> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Column)

Return Value

An IEnumerator<Column> that can be used to iterate through the collection.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Insert Method

ColumnCollection.Insert Method
[image]

Inserts one or more columns at a specified index.

Overload List

Name | Description
ColumnCollection.Insert (Int32) | Inserts a new column at the specified index.
ColumnCollection.Insert (Int32, Int32) | Inserts the specified number of columns at the specified index.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Insert Method (Int32)

ColumnCollection.Insert Method (Int32)
See Also
[image]

Inserts a new column at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer _
)

Parameters

index

The zero-based index where the column should be inserted.

Remarks

This method will raise an InvalidOperationException exception if the operation would cause filled cells to be shifted beyond the sheet.

See Also

Insert Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Insert Method (Int32, Int32)

ColumnCollection.Insert Method (Int32, Int32)
See Also
[image]

Inserts the specified number of columns at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
count As Integer _
)

Parameters

index

The zero-based index where the columns should be inserted.

count

The number of columns to insert.

Remarks

This method will raise an InvalidOperationException exception if the operation would cause filled cells to be shifted beyond the sheet.

See Also

Insert Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Move Method

ColumnCollection.Move Method
[image]

Moves the specified column or columns to another location.

Overload List

Name | Description
ColumnCollection.Move (Int32, Int32) | Moves the specified column to the specified target index.
ColumnCollection.Move (Int32, Int32, Int32) | Moves the specified number of columns to the specified target index.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Move Method (Int32, Int32)

ColumnCollection.Move Method (Int32, Int32)
See Also
[image]

Moves the specified column to the specified target index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Move (
int index,
int target
)

Visual Basic [image] Copy Code

Public Sub Move( _
index As Integer, _
target As Integer _
)

Parameters

index

The zero-based index of the column to move.

target

The zero-based index of the column before which the column should be moved.

See Also

Move Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Move Method (Int32, Int32, Int32)

ColumnCollection.Move Method (Int32, Int32, Int32)
See Also
[image]

Moves the specified number of columns to the specified target index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Move (
int index,
int count,
int target
)

Visual Basic [image] Copy Code

Public Function Move( _
index As Integer, _
count As Integer, _
target As Integer _
) As Boolean

Parameters

index

The zero-based index of the first column to move.

count

The number of columns to move.

target

The zero-based index of the column before which the columns should be moved.

Return Value

true if a move occurred; otherwise, false.

See Also

Move Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Remove Method

ColumnCollection.Remove Method
[image]

Removes one or more columns at a specified index.

Overload List

Name | Description
ColumnCollection.Remove (Int32) | Removes the column at the specified index.
ColumnCollection.Remove (Int32, Int32) | Removes the specified number of columns at the specified index.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Remove Method (Int32)

ColumnCollection.Remove Method (Int32)
See Also
[image]

Removes the column at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
int index
)

Visual Basic [image] Copy Code

Public Sub Remove( _
index As Integer _
)

Parameters

index

The zero-based index of the column to remove.

See Also

Remove Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Remove Method (Int32, Int32)

ColumnCollection.Remove Method (Int32, Int32)
See Also
[image]

Removes the specified number of columns at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub Remove( _
index As Integer, _
count As Integer _
)

Parameters

index

The zero-based index of the first column to remove.

count

The number of columns to remove.

See Also

Remove Method Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection Properties

ColumnCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of columns in the collection.
Item | Overloaded. Gets a column or a range of columns at the specified index.

See Also

ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Count Property

ColumnCollection.Count Property
[image]

Gets the number of columns in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Item Property

ColumnCollection.Item Property
[image]

Gets a column or a range of columns at the specified index.

Overload List

Name | Description
ColumnCollection.Item (Int32) | Gets the column at the specified index.
ColumnCollection.Item (Int32, Int32) | Gets a ColumnRange object that can be used to manipulate the columns in the specified range.

See Also

ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Item Property (Int32)

ColumnCollection.Item Property (Int32)
See Also
[image]

Gets the column at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Column Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As Column

Parameters

index

The zero-based index of the column to get.

Property Value

A Column object identifying the column at the specified position.

See Also

Item Property Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnCollection.Item Property (Int32, Int32)

ColumnCollection.Item Property (Int32, Int32)
See Also
[image]

Gets a ColumnRange object that can be used to manipulate the columns in the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ColumnRange Item [
int left,
int right
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
left As Integer, _
right As Integer _
) As ColumnRange

Parameters

left

The zero-based index of the left column in the range.

right

The zero-based index of the right column in the range.

Property Value

A ColumnRange object that can be used to manipulate the columns in the range.

See Also

Item Property Overload List
ColumnCollection Members
ColumnCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnEventArgs Class

ColumnEventArgs Class
[image]

Contains the arguments passed to column-related events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ColumnEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ColumnEventArgs
MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs

See Also

ColumnEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnEventArgs Members

ColumnEventArgs Members
Properties
[image]

Contains the arguments passed to column-related events.

The following tables list the members exposed by the ColumnEventArgs type.

Public Properties

Name | Description
Column | Gets the related column.

See Also

ColumnEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnEventArgs Properties

ColumnEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the related column.

See Also

ColumnEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnEventArgs.Column Property

ColumnEventArgs.Column Property
[image]

Gets the related column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Column Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Column

Property Value

An instance of the Column class.

See Also

ColumnEventArgs Members
ColumnEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnHeader Class

ColumnHeader Class
[image]

Defines the presentation of column headers in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnHeader : Header

Visual Basic [image] Copy Code

Public Class ColumnHeader
Inherits Header

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Spreadsheet.Wpf.Header
MindFusion.Spreadsheet.Wpf.ColumnHeader

See Also

ColumnHeader Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnHeader Members

ColumnHeader Members
Constructors Fields Properties
[image]

Defines the presentation of column headers in the WorkbookView control.

The following tables list the members exposed by the ColumnHeader type.

Public Constructors

Name | Description
ColumnHeader | Initializes a new instance of the ColumnHeader class.

Public Fields

Name | Description
HasHiddenAfterProperty | Identifies the HasHiddenAfter dependency property. (Inherited from Header.)
HasHiddenBeforeProperty | Identifies the HasHiddenBefore dependency property. (Inherited from Header.)
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from Header.)

Public Properties

Name | Description
HasHiddenAfter | Gets or sets a value indicating whether there are hidden headers immediately after this one. This is a dependency property. (Inherited from Header.)
HasHiddenBefore | Gets or sets a value indicating whether there are hidden headers immediately before this one. This is a dependency property. (Inherited from Header.)
IsSelected | Gets or sets a value indicating whether the entire row or column represented by this header is selected. This is a dependency property. (Inherited from Header.)

See Also

ColumnHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnHeader Constructor

ColumnHeader Constructor
[image]

Initializes a new instance of the ColumnHeader class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ColumnHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ColumnHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs Class

ColumnMouseEventArgs Class
[image]

Contains the arguments passed to column-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnMouseEventArgs : BaseMouseEventArgs

Visual Basic [image] Copy Code

Public Class ColumnMouseEventArgs
Inherits BaseMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs
MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs

See Also

ColumnMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs Members

ColumnMouseEventArgs Members
Properties
[image]

Contains the arguments passed to column-related mouse events.

The following tables list the members exposed by the ColumnMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Column | Gets the column for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

ColumnMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs Properties

ColumnMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Column | Gets the column for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

ColumnMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnMouseEventArgs.Column Property

ColumnMouseEventArgs.Column Property
[image]

Gets the column for which the event was raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Column Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Column

Property Value

An instance of the Column class.

See Also

ColumnMouseEventArgs Members
ColumnMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange Class

ColumnRange Class
Remarks See Also
[image]

Identifies a range of columns in a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnRange : IEnumerable<Column>, IEnumerable

Visual Basic [image] Copy Code

Public Class ColumnRange
Implements IEnumerable(Of Column), IEnumerable

Remarks

Instances of this class can be accessed through the Columns collection of the Worksheet class.

Example

The following example demonstrates how to hide a range of columns in an existing worksheet:

C# [image] Copy Code

worksheet.Columns[1, 5].IsHidden = true;

Visual Basic [image] Copy Code

worksheet.Columns(1, 5).IsHidden = True

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.ColumnRange

See Also

ColumnRange Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange Members

ColumnRange Members
Properties Methods
[image]

Identifies a range of columns in a Worksheet.

The following tables list the members exposed by the ColumnRange type.

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the columns in the range based on various conditions.
IsHidden | Gets or sets a value indicating whether the columns in the range are hidden.
Left | Gets the left column of the range.
OutlineLevel | Gets or sets the outline level of the columns in the range.
Right | Gets the right column of the range.
Style | Gets an IColumnStyle object that can be used to customize the appearance of all columns in the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the range.
Width | Gets or sets the width of all columns in the range.

Public Methods

Name | Description
GetEnumerator | Returns an enumerator object that can be used to iterate through the columns in the range.
Group | Increases the outline level of all columns in the range.
Ungroup | Decreses the outline level of all columns in the range.

See Also

ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange Methods

ColumnRange Methods
[image]

Public Methods

Name | Description
GetEnumerator | Returns an enumerator object that can be used to iterate through the columns in the range.
Group | Increases the outline level of all columns in the range.
Ungroup | Decreses the outline level of all columns in the range.

See Also

ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.GetEnumerator Method

ColumnRange.GetEnumerator Method
[image]

Returns an enumerator object that can be used to iterate through the columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Column> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Column)

Return Value

An IEnumerator<Column> object that can be used to iterate through the columns in the range.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Group Method

ColumnRange.Group Method
[image]

Increases the outline level of all columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Group ()

Visual Basic [image] Copy Code

Public Function Group () As Boolean

Return Value

true if grouping was successful; otherwise, false.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Ungroup Method

ColumnRange.Ungroup Method
[image]

Decreses the outline level of all columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Ungroup ()

Visual Basic [image] Copy Code

Public Function Ungroup () As Boolean

Return Value

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange Properties

ColumnRange Properties
[image]

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the columns in the range based on various conditions.
IsHidden | Gets or sets a value indicating whether the columns in the range are hidden.
Left | Gets the left column of the range.
OutlineLevel | Gets or sets the outline level of the columns in the range.
Right | Gets the right column of the range.
Style | Gets an IColumnStyle object that can be used to customize the appearance of all columns in the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the range.
Width | Gets or sets the width of all columns in the range.

See Also

ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.ConditionalFormats Property

ColumnRange.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the columns in the range based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.IsHidden Property

ColumnRange.IsHidden Property
[image]

Gets or sets a value indicating whether the columns in the range are hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> IsHidden { get; set; }

Visual Basic [image] Copy Code

Public Property IsHidden As Nullable(Of Boolean)

Property Value

true if all columns in the range are hidden; otherwise false or null (Nothing in Visual Basic).

Remarks

If the columns have different or default values, this property returns null (Nothing in Visual Basic).

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Left Property

ColumnRange.Left Property
[image]

Gets the left column of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Left { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Left As Integer

Property Value

An integer value.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.OutlineLevel Property

ColumnRange.OutlineLevel Property
[image]

Gets or sets the outline level of the columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Int32> OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineLevel As Nullable(Of Int32)

Property Value

A nullable integer value.

Remarks

If the columns have different or default values, this property returns null (Nothing in Visual Basic).

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Right Property

ColumnRange.Right Property
[image]

Gets the right column of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Right { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Right As Integer

Property Value

An integer value.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Style Property

ColumnRange.Style Property
[image]

Gets an IColumnStyle object that can be used to customize the appearance of all columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IColumnStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IColumnStyle

Property Value

An IColumnStyle instance.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Validation Property

ColumnRange.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRange.Width Property

ColumnRange.Width Property
[image]

Gets or sets the width of all columns in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Measure

Property Value

An instance of the Measure class.

Remarks

If the columns have different or default widths, this property returns null (Nothing in Visual Basic).

See Also

ColumnRange Members
ColumnRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs Class

ColumnRangeEventArgs Class
[image]

Contains the arguments passed to events related to multiple column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnRangeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ColumnRangeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs

See Also

ColumnRangeEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs Members

ColumnRangeEventArgs Members
Properties
[image]

Contains the arguments passed to events related to multiple column.

The following tables list the members exposed by the ColumnRangeEventArgs type.

Public Properties

Name | Description
ColumnRange | Gets the related range of columns.

See Also

ColumnRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs Properties

ColumnRangeEventArgs Properties
[image]

Public Properties

Name | Description
ColumnRange | Gets the related range of columns.

See Also

ColumnRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs.ColumnRange Property

ColumnRangeEventArgs.ColumnRange Property
[image]

Gets the related range of columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ColumnRange ColumnRange { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnRange As ColumnRange

Property Value

An instance of the ColumnRange class.

See Also

ColumnRangeEventArgs Members
ColumnRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs Class

ColumnRangeMovingEventArgs Class
[image]

Contains the arguments passed to validation events related to multiple columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnRangeMovingEventArgs : ColumnRangeEventArgs

Visual Basic [image] Copy Code

Public Class ColumnRangeMovingEventArgs
Inherits ColumnRangeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs

See Also

ColumnRangeMovingEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs Members

ColumnRangeMovingEventArgs Members
Properties
[image]

Contains the arguments passed to validation events related to multiple columns.

The following tables list the members exposed by the ColumnRangeMovingEventArgs type.

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
ColumnRange | Gets the related range of columns. (Inherited from ColumnRangeEventArgs.)
Initial | Gets a value indicating whether this is the first time the event is raised.

See Also

ColumnRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs Properties

ColumnRangeMovingEventArgs Properties
[image]

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
ColumnRange | Gets the related range of columns. (Inherited from ColumnRangeEventArgs.)
Initial | Gets a value indicating whether this is the first time the event is raised.

See Also

ColumnRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs.Abort Property

ColumnRangeMovingEventArgs.Abort Property
[image]

Gets or sets a value indicating whether to terminate the current operation immediately.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Abort { get; set; }

Visual Basic [image] Copy Code

Public Property Abort As Boolean

Property Value

A boolean value.

See Also

ColumnRangeMovingEventArgs Members
ColumnRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs.Allow Property

ColumnRangeMovingEventArgs.Allow Property
[image]

Gets or sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Allow { get; set; }

Visual Basic [image] Copy Code

Public Property Allow As Boolean

Property Value

A boolean value.

Remarks

Set this property to true to allow the user to complete the operation.

See Also

ColumnRangeMovingEventArgs Members
ColumnRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeMovingEventArgs.Initial Property

ColumnRangeMovingEventArgs.Initial Property
[image]

Gets a value indicating whether this is the first time the event is raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Initial { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Initial As Boolean

Property Value

A boolean value.

See Also

ColumnRangeMovingEventArgs Members
ColumnRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs Class

ColumnRangeResizingEventArgs Class
[image]

Contains the arguments passed to validation events related to multiple columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ColumnRangeResizingEventArgs : ColumnRangeEventArgs

Visual Basic [image] Copy Code

Public Class ColumnRangeResizingEventArgs
Inherits ColumnRangeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeEventArgs
MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs

See Also

ColumnRangeResizingEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs Members

ColumnRangeResizingEventArgs Members
Properties
[image]

Contains the arguments passed to validation events related to multiple columns.

The following tables list the members exposed by the ColumnRangeResizingEventArgs type.

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
ColumnRange | Gets the related range of columns. (Inherited from ColumnRangeEventArgs.)
Initial | Gets a value indicating whether this is the first time the event is raised.
Width | Gets or sets the new column width.

See Also

ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs Properties

ColumnRangeResizingEventArgs Properties
[image]

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
ColumnRange | Gets the related range of columns. (Inherited from ColumnRangeEventArgs.)
Initial | Gets a value indicating whether this is the first time the event is raised.
Width | Gets or sets the new column width.

See Also

ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs.Abort Property

ColumnRangeResizingEventArgs.Abort Property
[image]

Gets or sets a value indicating whether to terminate the current operation immediately.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Abort { get; set; }

Visual Basic [image] Copy Code

Public Property Abort As Boolean

Property Value

A boolean value.

See Also

ColumnRangeResizingEventArgs Members
ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs.Allow Property

ColumnRangeResizingEventArgs.Allow Property
[image]

Gets or sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Allow { get; set; }

Visual Basic [image] Copy Code

Public Property Allow As Boolean

Property Value

A boolean value.

Remarks

Set this property to true to allow the user to complete the operation.

See Also

ColumnRangeResizingEventArgs Members
ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs.Initial Property

ColumnRangeResizingEventArgs.Initial Property
[image]

Gets a value indicating whether this is the first time the event is raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Initial { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Initial As Boolean

Property Value

A boolean value.

See Also

ColumnRangeResizingEventArgs Members
ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ColumnRangeResizingEventArgs.Width Property

ColumnRangeResizingEventArgs.Width Property
[image]

Gets or sets the new column width.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Measure

Property Value

An instance of the Measure class.

See Also

ColumnRangeResizingEventArgs Members
ColumnRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command Class

Command Class
[image]

Represents an action that modifies the workbook and whose effects can be undone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.AddItemCommand(T)
MindFusion.Spreadsheet.Wpf.DisposableCommand
MindFusion.Spreadsheet.Wpf.MoveItemCommand(T)
MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T)
MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T)
MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T)

See Also

Command Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command Members

Command Members
Constructors Properties Methods
[image]

Represents an action that modifies the workbook and whose effects can be undone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything.
Workbook | Gets the Workbook modified by this Command object.

Protected Methods

Name | Description
Execute | Carries out an action that changes the workbook in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the workbook to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected Command (
Workbook workbook
)

Visual Basic [image] Copy Code

Protected New ( _
workbook As Workbook _
)

Parameters

workbook

The Workbook modified by this command.

See Also

Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command Methods

Command Methods
[image]

Protected Methods

Name | Description
Execute | Carries out an action that changes the workbook in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the workbook to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command.Execute Method

Command.Execute Method
[image]

Carries out an action that changes the workbook in some way.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected abstract bool Execute ()

Visual Basic [image] Copy Code

Protected MustOverride Function Execute () As Boolean

Return Value

true if the command should be registered in the undo history; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected abstract void Redo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Redo ()

See Also

Command Members
Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the workbook to the state it was in before carrying out the action.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected abstract void Undo ()

Visual Basic [image] Copy Code

Protected MustOverride Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command Properties

Command Properties
[image]

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything.
Workbook | Gets the Workbook modified by this Command object.

See Also

Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command.HasEffect Property

Command.HasEffect Property
[image]

Gets a value indicating whether the command does anything.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual bool HasEffect { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property HasEffect As Boolean

Property Value

true if the command performs an actual modification; otherwise, false.

Remarks

Commands that have no effect are not stored in the undo history.

See Also

Command Members
Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Command.Workbook Property

Command.Workbook Property
[image]

Gets the Workbook modified by this Command object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected Workbook Workbook { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Workbook As Workbook

Property Value

An instance of the Workbook class.

See Also

Command Members
Command Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ComparisonOperator Enumeration

ComparisonOperator Enumeration
[image]

Specifies an operator for value comparison.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ComparisonOperator

Visual Basic [image] Copy Code

Public Enum ComparisonOperator

Members

Member name | Description
Between | Indicates that the left operand must be between the right operands.
Contain | Indicates that the left operand must contain the right operand.
Equal | Indicates that the left operand must be equal to the right operand.
GreaterThan | Indicates that the left operand must be greater than the right operand.
GreaterThanOrEqual | Indicates that the left operand must be greater than or equal to the right operand.
LessThan | Indicates that the left operand must be less than the right operand.
LessThanOrEqual | Indicates that the left operand must be less than or equal to the right operand.
NotBetween | Indicates that the left operand must not be between the right operands.
NotContain | Indicates that the left operand must not contain the right operand.
NotEqual | Indicates that the left operand must not be equal to the right operand.

Remarks

Members of this enumeration can be assigned to the Operator properties of IConditionalFormat and IValidation instances.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand Class

CompositeCommand Class
Remarks See Also
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class CompositeCommand : DisposableCommand

Visual Basic [image] Copy Code

Public NotInheritable Class CompositeCommand
Inherits DisposableCommand

Remarks

The CompositeCommand can be used to wrap up a sequence of commands into a single undoable operation. The CompositeCommand class cannot be instantiated directly. To create a CompositeCommand object, call the StartCompositeOperation method of the Workbook class. After a composite command has been started, executing other commands will register them as children of this CompositeCommand, rather than directly in the undo history. To complete the composite action, either call the CommitCompositeOperation method of the Workbook class or the Dispose method of the command itself. To cancel an active composite command (and revert all of its subactions), call the CancelCompositeOperation method of the Workbook class or the Cancel method of the command.

Example

The following example creates a new worksheet in an existing workbook and changes the name of this new worksheet, both as a single composite operation. Note, that due to the disposable pattern, the composite command is automatically executed at the end of the using block.

C# [image] Copy Code

using (workbook.StartCompositeOperation())
{
var worksheet = workbook.Worksheets.Add();
using (workbook.StartChangeOperation(worksheet))
worksheet.Name = "My worksheet";
}

Visual Basic [image] Copy Code

Using workbook.StartCompositeOperation()
Dim worksheet = workbook.Worksheets.Add()
Using workbook.StartChangeOperation(worksheet)
worksheet.Name = "My worksheet"
End Using
End Using

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.DisposableCommand
MindFusion.Spreadsheet.Wpf.CompositeCommand

See Also

CompositeCommand Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand Members

CompositeCommand Members
Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Protected Properties

Name | Description
HasEffect | Command.HasEffect override.
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Cancel | Cancels the command. (Inherited from DisposableCommand.)
Dispose | IDisposable.Dispose implementation. (Inherited from DisposableCommand.)

Protected Methods

Name | Description
Execute | DisposableCommand.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand Methods

CompositeCommand Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the command. (Inherited from DisposableCommand.)
Dispose | IDisposable.Dispose implementation. (Inherited from DisposableCommand.)

Protected Methods

Name | Description
Execute | DisposableCommand.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand.Execute Method

CompositeCommand.Execute Method
[image]

DisposableCommand.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true if the command should be registered in the undo history; otherwise, false. Always returns false.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand.Redo Method

CompositeCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand.Undo Method

CompositeCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand Properties

CompositeCommand Properties
[image]

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Protected Properties

Name | Description
HasEffect | Command.HasEffect override.
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

See Also

CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand.Commands Property

CompositeCommand.Commands Property
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IList<Command> Commands { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Commands As IList(Of Command)

Property Value

A list of Command objects.

Remarks

The returned list should not be modified directly.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CompositeCommand.HasEffect Property

CompositeCommand.HasEffect Property
[image]

Command.HasEffect override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool HasEffect { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasEffect As Boolean

Property Value

true if the command performs an actual modification; otherwise, false.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ConditionalFormatType Enumeration

ConditionalFormatType Enumeration
[image]

Specifies the type of a conditional format.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ConditionalFormatType

Visual Basic [image] Copy Code

Public Enum ConditionalFormatType

Members

Member name | Description
CellValue | Indicates that the condition is based on the value of the cell.
Expression | Indicates that the condition depends on the value of an expression.

Remarks

Members of this enumeration can be assigned to the Type property of IConditionalFormat instances.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Converter

See Also

Converter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a culture-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromColor2 | Converts the specified color value to string in the format #RRGGBB.
FromColor3 | Converts the specified color value to string in the format AARRGGBB.
FromColor4 | Converts the specified color value to string in the format RRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Overloaded.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromColor2 | Converts the specified color value to string in the format #RRGGBB.
FromColor3 | Converts the specified color value to string in the format AARRGGBB.
FromColor4 | Converts the specified color value to string in the format RRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Overloaded.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromColor2 Method

Converter.FromColor2 Method
[image]

Converts the specified color value to string in the format #RRGGBB.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromColor2 (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor2( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromColor3 Method

Converter.FromColor3 Method
[image]

Converts the specified color value to string in the format AARRGGBB.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromColor3 (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor3( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromColor4 Method

Converter.FromColor4 Method
[image]

Converts the specified color value to string in the format RRGGBB.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromColor4 (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor4( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromImage (
BitmapSource val
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As BitmapSource _
) As String

Parameters

val

The image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToImage Method

Converter.ToImage Method
[image]

Overload List

Name | Description
Converter.ToImage (Stream) | Converts the specified stream to an image.
Converter.ToImage (String) | Converts the specified string value to image.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToImage Method (Stream)

Converter.ToImage Method (Stream)
See Also
[image]

Converts the specified stream to an image.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static ImageSource ToImage (
Stream s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As Stream _
) As ImageSource

Parameters

s

The stream to convert from.

Return Value

An ImageSource object deserialized from the specified stream.

See Also

ToImage Method Overload List
Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToImage Method (String)

Converter.ToImage Method (String)
See Also
[image]

Converts the specified string value to image.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static ImageSource ToImage (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String _
) As ImageSource

Parameters

s

The string value to convert from.

Return Value

An ImageSource object that is deserialized from the specified string.

See Also

ToImage Method Overload List
Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CornerHeader Class

CornerHeader Class
[image]

Defines the presentation of the are in the top-left corner of the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CornerHeader : Control

Visual Basic [image] Copy Code

Public Class CornerHeader
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.CornerHeader

See Also

CornerHeader Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CornerHeader Members

CornerHeader Members
Constructors
[image]

Defines the presentation of the are in the top-left corner of the WorkbookView control.

The following tables list the members exposed by the CornerHeader type.

Public Constructors

Name | Description
CornerHeader | Initializes a new instance of the CornerHeader class.

See Also

CornerHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CornerHeader Constructor

CornerHeader Constructor
[image]

Initializes a new instance of the CornerHeader class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CornerHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CornerHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter Class

CsvExporter Class
[image]

CsvExporter lets you export Worksheet data into .csv file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CsvExporter

Visual Basic [image] Copy Code

Public Class CsvExporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CsvExporter

See Also

CsvExporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter Members

CsvExporter Members
Constructors Properties Methods
[image]

CsvExporter lets you export Worksheet data into .csv file.

The following tables list the members exposed by the CsvExporter type.

Public Constructors

Name | Description
CsvExporter | Initializes a new instance of the CsvExporter class.

Public Properties

Name | Description
Encoding | Gets or sets the encoding used.
Quote | Gets or sets the character used as a quote.
QuoteStrings | Gets or sets a value indicating whether to always quote strings.
Separator | Gets or sets the character used as a separator.

Public Methods

Name | Description
Export | Overloaded. Exports a worksheet or a range of cells.

See Also

CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter Constructor

CsvExporter Constructor
[image]

Initializes a new instance of the CsvExporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CsvExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter Methods

CsvExporter Methods
[image]

Public Methods

Name | Description
Export | Overloaded. Exports a worksheet or a range of cells.

See Also

CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Export Method

CsvExporter.Export Method
[image]

Exports a worksheet or a range of cells.

Overload List

Name | Description
CsvExporter.Export (CellRange, Stream) | Generates a string in an CSV format and writes it in the specified stream.
CsvExporter.Export (Worksheet, String) | Exports the specified worksheet to the specified CSV file.

See Also

CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Export Method (CellRange, Stream)

CsvExporter.Export Method (CellRange, Stream)
See Also
[image]

Generates a string in an CSV format and writes it in the specified stream.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Export (
CellRange range,
Stream stream
)

Visual Basic [image] Copy Code

Public Sub Export( _
range As CellRange, _
stream As Stream _
)

Parameters

range

The range of cells to export.

stream

The stream to write the result to.

See Also

Export Method Overload List
CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Export Method (Worksheet, String)

CsvExporter.Export Method (Worksheet, String)
See Also
[image]

Exports the specified worksheet to the specified CSV file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Export (
Worksheet worksheet,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
worksheet As Worksheet, _
filePath As String _
)

Parameters

worksheet

The worksheet to export the data from.

filePath

A string specifying the path to the .csv file.

See Also

Export Method Overload List
CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter Properties

CsvExporter Properties
[image]

Public Properties

Name | Description
Encoding | Gets or sets the encoding used.
Quote | Gets or sets the character used as a quote.
QuoteStrings | Gets or sets a value indicating whether to always quote strings.
Separator | Gets or sets the character used as a separator.

See Also

CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Encoding Property

CsvExporter.Encoding Property
[image]

Gets or sets the encoding used.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Encoding Encoding { get; set; }

Visual Basic [image] Copy Code

Public Property Encoding As Encoding

Property Value

An instance of the .NET Encoding class. The default is Encoding.Default.

See Also

CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Quote Property

CsvExporter.Quote Property
[image]

Gets or sets the character used as a quote.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public char Quote { get; set; }

Visual Basic [image] Copy Code

Public Property Quote As Char

Property Value

A character value. The default is double quotes (").

See Also

CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.QuoteStrings Property

CsvExporter.QuoteStrings Property
[image]

Gets or sets a value indicating whether to always quote strings.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool QuoteStrings { get; set; }

Visual Basic [image] Copy Code

Public Property QuoteStrings As Boolean

Property Value

A boolean value.

See Also

CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvExporter.Separator Property

CsvExporter.Separator Property
[image]

Gets or sets the character used as a separator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public char Separator { get; set; }

Visual Basic [image] Copy Code

Public Property Separator As Char

Property Value

A character value. The default is comma (,).

See Also

CsvExporter Members
CsvExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter Class

CsvImporter Class
[image]

CsvImporter lets you import .csv files into a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class CsvImporter

Visual Basic [image] Copy Code

Public Class CsvImporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CsvImporter

See Also

CsvImporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter Members

CsvImporter Members
Constructors Properties Methods
[image]

CsvImporter lets you import .csv files into a Worksheet.

The following tables list the members exposed by the CsvImporter type.

Public Constructors

Name | Description
CsvImporter | Initializes a new instance of the CsvImporter class.

Public Properties

Name | Description
Encoding | Gets the encoding that will be used by the importer.
Quote | Gets or sets the character used as a quote.
Separator | Gets or sets the character used as a separator.

Public Methods

Name | Description
Import | Imports the specified CSV file into the specified worksheet.

See Also

CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter Constructor

CsvImporter Constructor
[image]

Initializes a new instance of the CsvImporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CsvImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter Methods

CsvImporter Methods
[image]

Public Methods

Name | Description
Import | Imports the specified CSV file into the specified worksheet.

See Also

CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter.Import Method

CsvImporter.Import Method
[image]

Imports the specified CSV file into the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Import (
string filePath,
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Function Import( _
filePath As String, _
worksheet As Worksheet _
) As Boolean

Parameters

filePath

A string specifying the path to the .csv file.

worksheet

The Worksheet instance where to import the data.

Return Value

true if the data was successfully loaded; otherwise, false.

See Also

CsvImporter Members
CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter Properties

CsvImporter Properties
[image]

Public Properties

Name | Description
Encoding | Gets the encoding that will be used by the importer.
Quote | Gets or sets the character used as a quote.
Separator | Gets or sets the character used as a separator.

See Also

CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter.Encoding Property

CsvImporter.Encoding Property
[image]

Gets the encoding that will be used by the importer.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Encoding Encoding { get; set; }

Visual Basic [image] Copy Code

Public Property Encoding As Encoding

Property Value

An instance of the .NET Encoding class. The default is Encoding.Default.

See Also

CsvImporter Members
CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter.Quote Property

CsvImporter.Quote Property
[image]

Gets or sets the character used as a quote.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public char Quote { get; set; }

Visual Basic [image] Copy Code

Public Property Quote As Char

Property Value

A character value. The default is double quotes (").

See Also

CsvImporter Members
CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CsvImporter.Separator Property

CsvImporter.Separator Property
[image]

Gets or sets the character used as a separator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public char Separator { get; set; }

Visual Basic [image] Copy Code

Public Property Separator As Char

Property Value

A character value. The default is comma (,).

See Also

CsvImporter Members
CsvImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Class

CurrencyCodeInfo Class
[image]

Represents a currency ISO code to locale relationship.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class CurrencyCodeInfo

Visual Basic [image] Copy Code

Public NotInheritable Class CurrencyCodeInfo

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo

See Also

CurrencyCodeInfo Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Members

CurrencyCodeInfo Members
Constructors Properties Methods
[image]

Represents a currency ISO code to locale relationship.

The following tables list the members exposed by the CurrencyCodeInfo type.

Public Constructors

Name | Description
CurrencyCodeInfo | Overloaded. Initializes a new instance of the CurrencyCodeInfo class.

Public Properties

Name | Description
Code | Gets the ISO code.
LCID | Gets the culture locale id.
LongForm | Gets the long form code format.
ShortForm | Gets the short form code format.
Symbol | Gets the currency symbol.

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Constructor

CurrencyCodeInfo Constructor
[image]

Initializes a new instance of the CurrencyCodeInfo class.

Overload List

Name | Description
CurrencyCodeInfo (Int32, String, String) | Initializes a new instance of the CurrencyCodeInfo class.
CurrencyCodeInfo (String) | Initializes a new instance of the CurrencyCodeInfo class.

See Also

CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Constructor (Int32, String, String)

CurrencyCodeInfo Constructor (Int32, String, String)
See Also
[image]

Initializes a new instance of the CurrencyCodeInfo class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CurrencyCodeInfo (
int lcid,
string code,
string symbol
)

Visual Basic [image] Copy Code

Public New ( _
lcid As Integer, _
code As String, _
symbol As String _
)

Parameters

lcid

The culture locale id.

code

The ISO code.

symbol

The currency symbol.

See Also

CurrencyCodeInfo Constructor Overload List
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Constructor (String)

CurrencyCodeInfo Constructor (String)
See Also
[image]

Initializes a new instance of the CurrencyCodeInfo class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CurrencyCodeInfo (
string code
)

Visual Basic [image] Copy Code

Public New ( _
code As String _
)

Parameters

code

The ISO code.

See Also

CurrencyCodeInfo Constructor Overload List
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Methods

CurrencyCodeInfo Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.Equals Method

CurrencyCodeInfo.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.GetHashCode Method

CurrencyCodeInfo.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current object.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.ToString Method

CurrencyCodeInfo.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo Properties

CurrencyCodeInfo Properties
[image]

Public Properties

Name | Description
Code | Gets the ISO code.
LCID | Gets the culture locale id.
LongForm | Gets the long form code format.
ShortForm | Gets the short form code format.
Symbol | Gets the currency symbol.

See Also

CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.Code Property

CurrencyCodeInfo.Code Property
[image]

Gets the ISO code.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Code { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Code As String

Property Value

A string value.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.LCID Property

CurrencyCodeInfo.LCID Property
[image]

Gets the culture locale id.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int LCID { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LCID As Integer

Property Value

An integer value.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.LongForm Property

CurrencyCodeInfo.LongForm Property
[image]

Gets the long form code format.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string LongForm { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LongForm As String

Property Value

A string value.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.ShortForm Property

CurrencyCodeInfo.ShortForm Property
[image]

Gets the short form code format.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ShortForm { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShortForm As String

Property Value

A string value.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodeInfo.Symbol Property

CurrencyCodeInfo.Symbol Property
[image]

Gets the currency symbol.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Symbol { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Symbol As String

Property Value

A string value.

See Also

CurrencyCodeInfo Members
CurrencyCodeInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes Class

CurrencyCodes Class
[image]

Represents a helper class containing the definitions of currency ISO codes to locale relationships.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class CurrencyCodes

Visual Basic [image] Copy Code

Public NotInheritable Class CurrencyCodes

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.CurrencyCodes

See Also

CurrencyCodes Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes Members

CurrencyCodes Members
Properties Methods
[image]

Represents a helper class containing the definitions of currency ISO codes to locale relationships.

The following tables list the members exposed by the CurrencyCodes type.

Public Properties

Name | Description
DefaultCodes | The list of defined currency ISO codes to locale relationships.

Public Methods

Name | Description
InfoFromCode | Gets the CurrencyCodeInfo from a given format code from the default codes. If no match is found, the result is null (Nothing in Visual Basic).

See Also

CurrencyCodes Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes Methods

CurrencyCodes Methods
[image]

Public Methods

Name | Description
InfoFromCode | Gets the CurrencyCodeInfo from a given format code from the default codes. If no match is found, the result is null (Nothing in Visual Basic).

See Also

CurrencyCodes Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes.InfoFromCode Method

CurrencyCodes.InfoFromCode Method
[image]

Gets the CurrencyCodeInfo from a given format code from the default codes. If no match is found, the result is null (Nothing in Visual Basic).

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static CurrencyCodeInfo InfoFromCode (
string code
)

Visual Basic [image] Copy Code

Public Shared Function InfoFromCode( _
code As String _
) As CurrencyCodeInfo

Parameters

code

The code to search for.

Return Value

An instance of the CurrencyCodeInfo class.

See Also

CurrencyCodes Members
CurrencyCodes Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes Properties

CurrencyCodes Properties
[image]

Public Properties

Name | Description
DefaultCodes | The list of defined currency ISO codes to locale relationships.

See Also

CurrencyCodes Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CurrencyCodes.DefaultCodes Property

CurrencyCodes.DefaultCodes Property
[image]

The list of defined currency ISO codes to locale relationships.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static List<CurrencyCodeInfo> DefaultCodes { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DefaultCodes As List(Of CurrencyCodeInfo)

Property Value

A list of CurrencyCodeInfo objects.

See Also

CurrencyCodes Members
CurrencyCodes Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.CursorHint Enumeration

CursorHint Enumeration
[image]

Specifies what mouse cursor to display while a user interacts with the view controls.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum CursorHint

Visual Basic [image] Copy Code

Public Enum CursorHint

Members

Member name | Description
AutoFill | Indicates the cursor specified by the AutoFillCursor property.
CounterDiagonalResize | Indicates the cursor specified by the CounterDiagonalResizeCursor property.
DiagonalResize | Indicates the cursor specified by the DiagonalResizeCursor property.
Disallow | Indicates the cursor specified by the DisallowCursor property.
DontChange | Indicates the cursor specified by the Cursor property.
HorizontalResize | Indicates the cursor specified by the HorizontalResizeCursor property.
HorizontalSplit | Indicates the cursor specified by the HorizontalSplitCursor property.
Hyperlink | Indicates the cursor specified by the HyperlinkCursor property.
Move | Indicates the cursor specified by the MoveCursor property.
Pointer | Indicates the cursor specified by the PointerCursor property.
VerticalResize | Indicates the cursor specified by the VerticalResizeCursor property.
VerticalSplit | Indicates the cursor specified by the VerticalSplitCursor property.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats Class

DefaultNumericFormats Class
[image]

Contains predefined format strings for different numeric formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class DefaultNumericFormats

Visual Basic [image] Copy Code

Public NotInheritable Class DefaultNumericFormats

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.DefaultNumericFormats

See Also

DefaultNumericFormats Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats Members

DefaultNumericFormats Members
Properties Methods
[image]

Contains predefined format strings for different numeric formats.

The following tables list the members exposed by the DefaultNumericFormats type.

Public Properties

Name | Description
AllFormats | Gets all defined formats.
AutoResetFormats | Gets or sets a value indicating whether the format collections will be reset after a change in the locale.
BooleanFormats | Gets the default boolean formats.
CurrencyFormats | Gets the default currency formats.
DateFormats | Gets the default date formats.
FractionFormats | Gets the default fraction formats.
Locale | Gets the locale.
NumberFormats | Gets the default number formats.
PercentFormats | Gets the default percent formats.
ScientificFormats | Gets the default scientific formats.
TextFormats | Gets the default text formats.
TimeFormats | Gets the default time formats.

Public Methods

Name | Description
Format | Formats a given value according to the provided format string and locale.
GetCurrencyFormats | Gets the default currency formats from the CurrencyCodeInfo relationship.
Reset | Resets the numeric formats.

See Also

DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats Methods

DefaultNumericFormats Methods
[image]

Public Methods

Name | Description
Format | Formats a given value according to the provided format string and locale.
GetCurrencyFormats | Gets the default currency formats from the CurrencyCodeInfo relationship.
Reset | Resets the numeric formats.

See Also

DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.Format Method

DefaultNumericFormats.Format Method
[image]

Formats a given value according to the provided format string and locale.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static string Format (
Object value,
string format,
CultureInfo locale
)

Visual Basic [image] Copy Code

Public Shared Function Format( _
value As Object, _
format As String, _
locale As CultureInfo _
) As String

Parameters

value

The object to format.

format

The formatting specifier.

locale

The context in which to perform the formatting.

Return Value

A string value representing the result of the formatting.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.GetCurrencyFormats Method

DefaultNumericFormats.GetCurrencyFormats Method
[image]

Gets the default currency formats from the CurrencyCodeInfo relationship.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> GetCurrencyFormats (
CurrencyCodeInfo c
)

Visual Basic [image] Copy Code

Public Function GetCurrencyFormats( _
c As CurrencyCodeInfo _
) As List(Of NumericFormatInfo)

Parameters

c

The object for which to get the currency formats.

Return Value

A list of NumericFormatInfo objects for the specified object.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.Reset Method

DefaultNumericFormats.Reset Method
[image]

Resets the numeric formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

Remarks

This method is called automatically after Locale changes if AutoResetFormats is set to true.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats Properties

DefaultNumericFormats Properties
[image]

Public Properties

Name | Description
AllFormats | Gets all defined formats.
AutoResetFormats | Gets or sets a value indicating whether the format collections will be reset after a change in the locale.
BooleanFormats | Gets the default boolean formats.
CurrencyFormats | Gets the default currency formats.
DateFormats | Gets the default date formats.
FractionFormats | Gets the default fraction formats.
Locale | Gets the locale.
NumberFormats | Gets the default number formats.
PercentFormats | Gets the default percent formats.
ScientificFormats | Gets the default scientific formats.
TextFormats | Gets the default text formats.
TimeFormats | Gets the default time formats.

See Also

DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.AllFormats Property

DefaultNumericFormats.AllFormats Property
[image]

Gets all defined formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> AllFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AllFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.AutoResetFormats Property

DefaultNumericFormats.AutoResetFormats Property
[image]

Gets or sets a value indicating whether the format collections will be reset after a change in the locale.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AutoResetFormats { get; set; }

Visual Basic [image] Copy Code

Public Property AutoResetFormats As Boolean

Property Value

true if the format collection should reset to the default when the locale is changed; otherwise, false. The default is true.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.BooleanFormats Property

DefaultNumericFormats.BooleanFormats Property
[image]

Gets the default boolean formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> BooleanFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BooleanFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.CurrencyFormats Property

DefaultNumericFormats.CurrencyFormats Property
[image]

Gets the default currency formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> CurrencyFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrencyFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.DateFormats Property

DefaultNumericFormats.DateFormats Property
[image]

Gets the default date formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> DateFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DateFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.FractionFormats Property

DefaultNumericFormats.FractionFormats Property
[image]

Gets the default fraction formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> FractionFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FractionFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.Locale Property

DefaultNumericFormats.Locale Property
[image]

Gets the locale.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; set; }

Visual Basic [image] Copy Code

Public Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.NumberFormats Property

DefaultNumericFormats.NumberFormats Property
[image]

Gets the default number formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> NumberFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NumberFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.PercentFormats Property

DefaultNumericFormats.PercentFormats Property
[image]

Gets the default percent formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> PercentFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PercentFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.ScientificFormats Property

DefaultNumericFormats.ScientificFormats Property
[image]

Gets the default scientific formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> ScientificFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScientificFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.TextFormats Property

DefaultNumericFormats.TextFormats Property
[image]

Gets the default text formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> TextFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DefaultNumericFormats.TimeFormats Property

DefaultNumericFormats.TimeFormats Property
[image]

Gets the default time formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> TimeFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TimeFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

See Also

DefaultNumericFormats Members
DefaultNumericFormats Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand Class

DisposableCommand Class
Remarks See Also
[image]

Represents a command that implements the IDisposable interface.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public abstract class DisposableCommand : Command, IDisposable

Visual Basic [image] Copy Code

Public MustInherit Class DisposableCommand
Inherits Command
Implements IDisposable

Remarks

A DisposableCommand is automatically committed when disposed unless it has been already executed or cancelled.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.DisposableCommand
MindFusion.Spreadsheet.Wpf.CompositeCommand
MindFusion.Spreadsheet.Wpf.TrackChangesCommand

See Also

DisposableCommand Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand Members

DisposableCommand Members
Constructors Properties Methods
[image]

Represents a command that implements the IDisposable interface.

The following tables list the members exposed by the DisposableCommand type.

Protected Constructors

Name | Description
DisposableCommand | Initializes a new instance of the DisposableCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Cancel | Cancels the command.
Dispose | IDisposable.Dispose implementation.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand Constructor

DisposableCommand Constructor
[image]

Initializes a new instance of the DisposableCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected DisposableCommand (
Workbook workbook
)

Visual Basic [image] Copy Code

Protected New ( _
workbook As Workbook _
)

Parameters

workbook

The Workbook modified by this command.

See Also

DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand Methods

DisposableCommand Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the command.
Dispose | IDisposable.Dispose implementation.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand.Cancel Method

DisposableCommand.Cancel Method
[image]

Cancels the command.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Cancel ()

Visual Basic [image] Copy Code

Public Sub Cancel ()

See Also

DisposableCommand Members
DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand.Dispose Method

DisposableCommand.Dispose Method
[image]

IDisposable.Dispose implementation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

Remarks

Call this method to execute the command. If the command is already executed or cancelled, this method has no effect.

See Also

DisposableCommand Members
DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand.Execute Method

DisposableCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

true if the command should be registered in the undo history; otherwise, false. Always returns true.

Remarks

Calling this method on a command that has been executed or cancelled will raise an exception.

See Also

DisposableCommand Members
DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand.Redo Method

DisposableCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

DisposableCommand Members
DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DisposableCommand.Undo Method

DisposableCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

DisposableCommand Members
DisposableCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing Class

Drawing Class
Remarks See Also
[image]

Represents a drawing within a worksheet. A drawing can contain unlimited number of visual elements such as pictures, diagrams and charts.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Drawing : Canvas

Visual Basic [image] Copy Code

Public Class Drawing
Inherits Canvas

Remarks

This class cannot be instantiated directly. In order to obtain a reference to a drawing use the Drawing property of the respective Worksheet object.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Canvas
MindFusion.Spreadsheet.Wpf.Drawing

See Also

Drawing Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing Members

Drawing Members
Properties Methods
[image]

Represents a drawing within a worksheet. A drawing can contain unlimited number of visual elements such as pictures, diagrams and charts.

The following tables list the members exposed by the Drawing type.

Public Properties

Name | Description
Charts | Gets an enumerable with all charts in the drawing.
Pictures | Gets an enumerable with all pictures in the drawing.

Public Methods

Name | Description
AddChart | Overloaded. Creates and adds a new chart to the drawing.
AddPicture | Overloaded. Creates and adds a new picture to the drawing.
BringForward | Moves the specified object one step up in the z-order.
BringToFront | Brings the specified object to the top of the z-order.
Clear | Removes all objects from the drawing.
Remove | Removes the specified object from the drawing.
SendBackward | Moves the specified object one step down in the z-order.
SendToBack | Sends the specified object to the bottom of the z-order.

See Also

Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing Methods

Drawing Methods
[image]

Public Methods

Name | Description
AddChart | Overloaded. Creates and adds a new chart to the drawing.
AddPicture | Overloaded. Creates and adds a new picture to the drawing.
BringForward | Moves the specified object one step up in the z-order.
BringToFront | Brings the specified object to the top of the z-order.
Clear | Removes all objects from the drawing.
Remove | Removes the specified object from the drawing.
SendBackward | Moves the specified object one step down in the z-order.
SendToBack | Sends the specified object to the bottom of the z-order.

See Also

Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddChart Method

Drawing.AddChart Method
[image]

Creates and adds a new chart to the drawing.

Overload List

Name | Description
Drawing.AddChart () | Creates and adds a new chart to the drawing.
Drawing.AddChart (Int32, Int32) | Creates and adds a new chart to the drawing.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddChart Method ()

Drawing.AddChart Method ()
See Also
[image]

Creates and adds a new chart to the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Chart AddChart ()

Visual Basic [image] Copy Code

Public Function AddChart () As Chart

Return Value

A Chart object representing the newly created chart.

See Also

AddChart Method Overload List
Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddChart Method (Int32, Int32)

Drawing.AddChart Method (Int32, Int32)
See Also
[image]

Creates and adds a new chart to the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Chart AddChart (
int column,
int row
)

Visual Basic [image] Copy Code

Public Function AddChart( _
column As Integer, _
row As Integer _
) As Chart

Parameters

column

The column where the chart will be positioned initially.

row

The row where the chart will be positioned initially.

Return Value

A Chart object representing the newly created chart.

See Also

AddChart Method Overload List
Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddPicture Method

Drawing.AddPicture Method
[image]

Creates and adds a new picture to the drawing.

Overload List

Name | Description
Drawing.AddPicture () | Creates and adds a new picture to the drawing.
Drawing.AddPicture (String) | Creates and adds a new picture with the specified image to the drawing.
Drawing.AddPicture (String, Int32, Int32) | Creates and adds a new picture with the specified image to the drawing.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddPicture Method ()

Drawing.AddPicture Method ()
See Also
[image]

Creates and adds a new picture to the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Picture AddPicture ()

Visual Basic [image] Copy Code

Public Function AddPicture () As Picture

Return Value

A Picture object representing the newly created picture.

See Also

AddPicture Method Overload List
Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddPicture Method (String)

Drawing.AddPicture Method (String)
See Also
[image]

Creates and adds a new picture with the specified image to the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Picture AddPicture (
string imagePath
)

Visual Basic [image] Copy Code

Public Function AddPicture( _
imagePath As String _
) As Picture

Parameters

imagePath

The full name of the file containing the image.

Return Value

A Picture object representing the newly created picture.

See Also

AddPicture Method Overload List
Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.AddPicture Method (String, Int32, Int32)

Drawing.AddPicture Method (String, Int32, Int32)
See Also
[image]

Creates and adds a new picture with the specified image to the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Picture AddPicture (
string imagePath,
int column,
int row
)

Visual Basic [image] Copy Code

Public Function AddPicture( _
imagePath As String, _
column As Integer, _
row As Integer _
) As Picture

Parameters

imagePath

The full name of the file containing the image.

column

The column where the picture will be positioned initially.

row

The row where the picture will be positioned initially.

Return Value

A Picture object representing the newly created picture.

See Also

AddPicture Method Overload List
Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.BringForward Method

Drawing.BringForward Method
[image]

Moves the specified object one step up in the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void BringForward (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub BringForward( _
obj As InteractiveObject _
)

Parameters

obj

The object to reorder.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.BringToFront Method

Drawing.BringToFront Method
[image]

Brings the specified object to the top of the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void BringToFront (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub BringToFront( _
obj As InteractiveObject _
)

Parameters

obj

The object to reorder.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.Clear Method

Drawing.Clear Method
[image]

Removes all objects from the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.Remove Method

Drawing.Remove Method
[image]

Removes the specified object from the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub Remove( _
obj As InteractiveObject _
)

Parameters

obj

The object to remove.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.SendBackward Method

Drawing.SendBackward Method
[image]

Moves the specified object one step down in the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SendBackward (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub SendBackward( _
obj As InteractiveObject _
)

Parameters

obj

The object to reorder.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.SendToBack Method

Drawing.SendToBack Method
[image]

Sends the specified object to the bottom of the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SendToBack (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub SendToBack( _
obj As InteractiveObject _
)

Parameters

obj

The object to reorder.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing Properties

Drawing Properties
[image]

Public Properties

Name | Description
Charts | Gets an enumerable with all charts in the drawing.
Pictures | Gets an enumerable with all pictures in the drawing.

See Also

Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.Charts Property

Drawing.Charts Property
[image]

Gets an enumerable with all charts in the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<Chart> Charts { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Charts As IEnumerable(Of Chart)

Property Value

An IEnumerable object that can be used to enumerate all charts in the drawing.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Drawing.Pictures Property

Drawing.Pictures Property
[image]

Gets an enumerable with all pictures in the drawing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<Picture> Pictures { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Pictures As IEnumerable(Of Picture)

Property Value

An IEnumerable object that can be used to enumerate all pictures in the drawing.

See Also

Drawing Members
Drawing Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.DynamicFilterType Enumeration

DynamicFilterType Enumeration
[image]

Specifies the type of a dynamic autofilter.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum DynamicFilterType

Visual Basic [image] Copy Code

Public Enum DynamicFilterType

Members

Member name | Description
AboveAverage | Shows all values that are above average.
BelowAverage | Shows all values that are below average.
DatesInApril | Shows the dates that are in April, regardless of year.
DatesInAugust | Shows the dates that are in August, regardless of year.
DatesInDecember | Shows the dates that are in December, regardless of year.
DatesInFebruary | Shows the dates that are in February, regardless of year.
DatesInJanuary | Shows the dates that are in January, regardless of year.
DatesInJuly | Shows the dates that are in July, regardless of year.
DatesInJune | Shows the dates that are in June, regardless of year.
DatesInMarch | Shows the dates that are in March, regardless of year.
DatesInMay | Shows the dates that are in May, regardless of year.
DatesInNovember | Shows the dates that are in November, regardless of year.
DatesInOctober | Shows the dates that are in October, regardless of year.
DatesInQuarter1 | Shows the dates that are in the first calendar quarter, regardless of year.
DatesInQuarter2 | Shows the dates that are in the second calendar quarter, regardless of year.
DatesInQuarter3 | Shows the dates that are in the third calendar quarter, regardless of year.
DatesInQuarter4 | Shows the dates that are in the fourth calendar quarter, regardless of year.
DatesInSeptember | Shows the dates that are in September, regardless of year.
LastMonth | Shows last month's dates.
LastQuarter | Shows last quarter's dates.
LastWeek | Shows last week's dates, using Sunday as the first week day.
LastYear | Shows last year's dates.
NextMonth | Shows next month's dates.
NextQuarter | Shows next quarter's dates.
NextWeek | Shows next week's dates, using Sunday as the first week day.
NextYear | Shows next year's dates.
ThisMonth | Shows this month's dates.
ThisQuarter | Shows this quarter's dates.
ThisWeek | Shows this week's dates, using Sunday as the first week day.
ThisYear | Shows this year's dates.
Today | Shows today's dates.
Tomorrow | Shows tomorrow's dates.
YearToDate | Shows the dates between the beginning of the year and today, inclusive.
Yesterday | Shows yesterday's dates.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter Class

ExcelExporter Class
[image]

ExcelExporter lets you export Workbook objects to Excel Open XML documents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ExcelExporter

Visual Basic [image] Copy Code

Public Class ExcelExporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.ExcelExporter

See Also

ExcelExporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter Members

ExcelExporter Members
Constructors Properties Methods
[image]

ExcelExporter lets you export Workbook objects to Excel Open XML documents.

The following tables list the members exposed by the ExcelExporter type.

Public Constructors

Name | Description
ExcelExporter | Initializes a new instance of the ExcelExporter class.

Public Properties

Name | Description
View | Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

Public Methods

Name | Description
Export | Exports the specified workbook to the specified Excel Open XML document.

See Also

ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter Constructor

ExcelExporter Constructor
[image]

Initializes a new instance of the ExcelExporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ExcelExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter Methods

ExcelExporter Methods
[image]

Public Methods

Name | Description
Export | Exports the specified workbook to the specified Excel Open XML document.

See Also

ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter.Export Method

ExcelExporter.Export Method
[image]

Exports the specified workbook to the specified Excel Open XML document.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Export (
Workbook workbook,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
workbook As Workbook, _
filePath As String _
)

Parameters

workbook

A Workbook instance to export the data from.

filePath

A string specifying the path to the .xlsx file.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter Properties

ExcelExporter Properties
[image]

Public Properties

Name | Description
View | Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

See Also

ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelExporter.View Property

ExcelExporter.View Property
[image]

Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorkbookView View { get; set; }

Visual Basic [image] Copy Code

Public Property View As WorkbookView

Property Value

An instance of the WorkbookView class.

See Also

ExcelExporter Members
ExcelExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter Class

ExcelImporter Class
[image]

ExcelImporter lets you import Excel Open XML documents into a Workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ExcelImporter

Visual Basic [image] Copy Code

Public Class ExcelImporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.ExcelImporter

See Also

ExcelImporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter Members

ExcelImporter Members
Constructors Properties Methods
[image]

ExcelImporter lets you import Excel Open XML documents into a Workbook.

The following tables list the members exposed by the ExcelImporter type.

Public Constructors

Name | Description
ExcelImporter | Initializes a new instance of the ExcelImporter class.

Public Properties

Name | Description
ReadConditionalFormats | Gets or sets a value indicating whether to read the conditional formats.
View | Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

Public Methods

Name | Description
Import | Imports the specified Excel Open XML document into the specified workbook.

See Also

ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter Constructor

ExcelImporter Constructor
[image]

Initializes a new instance of the ExcelImporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ExcelImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter Methods

ExcelImporter Methods
[image]

Public Methods

Name | Description
Import | Imports the specified Excel Open XML document into the specified workbook.

See Also

ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter.Import Method

ExcelImporter.Import Method
[image]

Imports the specified Excel Open XML document into the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Workbook workbook
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
workbook As Workbook _
)

Parameters

filePath

A string specifying the path to the .xlsx file.

workbook

A Workbook instance where to import the Excel data.

See Also

ExcelImporter Members
ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter Properties

ExcelImporter Properties
[image]

Public Properties

Name | Description
ReadConditionalFormats | Gets or sets a value indicating whether to read the conditional formats.
View | Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

See Also

ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter.ReadConditionalFormats Property

ExcelImporter.ReadConditionalFormats Property
[image]

Gets or sets a value indicating whether to read the conditional formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ReadConditionalFormats { get; set; }

Visual Basic [image] Copy Code

Public Property ReadConditionalFormats As Boolean

Property Value

See Also

ExcelImporter Members
ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ExcelImporter.View Property

ExcelImporter.View Property
[image]

Gets or sets an optional view. This view is used during export to write the currently active worksheet and the current cell selection. If the view is not specified, the active worksheet and cell selection are set to the default.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorkbookView View { get; set; }

Visual Basic [image] Copy Code

Public Property View As WorkbookView

Property Value

An instance of the WorkbookView class.

See Also

ExcelImporter Members
ExcelImporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FillDate Enumeration

FillDate Enumeration
[image]

Specifies the date component to increment when filling dates.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum FillDate

Visual Basic [image] Copy Code

Public Enum FillDate

Members

Member name | Description
Day | Indicates that the day is incremented.
Month | Indicates that the month is incremented.
Weekday | Indicates that the day is incremented, such, that weekends are jumped over,
Year | Indicates that the year is progressed.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FillDirection Enumeration

FillDirection Enumeration
[image]

Specifies the direction of a data fill operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum FillDirection

Visual Basic [image] Copy Code

Public Enum FillDirection

Members

Member name | Description
Across | Indicates that cells are filled horizontally.
Down | Indicates that cells are filled vertically.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FillType Enumeration

FillType Enumeration
[image]

Specifies the method used to fill series of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum FillType

Visual Basic [image] Copy Code

Public Enum FillType

Members

Member name | Description
Auto | Indicates that the blank cells in the target range are filled based on the existing data in the range.
Date | Indicates that the cells in the target range are filled with dates.
Growth | Indicates that the cells in the target range are filled by multiplying a step value by the value of each cell in turn.
Linear | Indicates that the cells in the target range are filled by adding a step value to the value of each cell in turn.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter Class

Filter Class
Remarks See Also
[image]

Represents a filter for a single column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Filter

Visual Basic [image] Copy Code

Public Class Filter

Remarks

The properties of this object are read-only. To apply filtering to a cell range, use the AutoFilter method of the CellRange class.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Filter

See Also

Filter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter Members

Filter Members
Properties
[image]

Represents a filter for a single column.

The following tables list the members exposed by the Filter type.

Public Properties

Name | Description
Criteria1 | Gets the first filter criteria. The value of this property depends on the filter operator.
Criteria2 | Gets the second filter criteria. The value of this property depends on the filter operator.
On | Gets a value indicating whether the filter is active.
Operator | Gets a value that represents the operator that associates the two criteria applied by the filter.

See Also

Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter Properties

Filter Properties
[image]

Public Properties

Name | Description
Criteria1 | Gets the first filter criteria. The value of this property depends on the filter operator.
Criteria2 | Gets the second filter criteria. The value of this property depends on the filter operator.
On | Gets a value indicating whether the filter is active.
Operator | Gets a value that represents the operator that associates the two criteria applied by the filter.

See Also

Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter.Criteria1 Property

Filter.Criteria1 Property
[image]

Gets the first filter criteria. The value of this property depends on the filter operator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Criteria1 { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Criteria1 As Object

Property Value

A string, an array of values, or a member of the DynamicFilterType enumeration, depending on Operator.

See Also

Filter Members
Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter.Criteria2 Property

Filter.Criteria2 Property
[image]

Gets the second filter criteria. The value of this property depends on the filter operator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Criteria2 { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Criteria2 As Object

Property Value

A string value.

See Also

Filter Members
Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter.On Property

Filter.On Property
[image]

Gets a value indicating whether the filter is active.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool On { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property On As Boolean

Property Value

true if the filter is active; otherwise, false.

See Also

Filter Members
Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Filter.Operator Property

Filter.Operator Property
[image]

Gets a value that represents the operator that associates the two criteria applied by the filter.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AutoFilterOperator Operator { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Operator As AutoFilterOperator

Property Value

A member of the AutoFilterOperator enumeration.

See Also

Filter Members
Filter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FindWithin Enumeration

FindWithin Enumeration
[image]

Specifies the target of find and replace operations.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum FindWithin

Visual Basic [image] Copy Code

Public Enum FindWithin

Members

Member name | Description
Workbook | Indicates that the operation should work in the entire workbook.
Worksheet | Indicates that the operation should work only in the current worksheet.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Class

FormattedText Class
Remarks See Also
[image]

Represents a sequence of text fragments with different formatting (font, size, color).

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class FormattedText

Visual Basic [image] Copy Code

Public Class FormattedText

Remarks

Instances of this class can be assigned to the Data property of Cell objects.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.FormattedText

See Also

FormattedText Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Members

FormattedText Members
Constructors Properties Methods
[image]

Represents a sequence of text fragments with different formatting (font, size, color).

The following tables list the members exposed by the FormattedText type.

Public Constructors

Name | Description
FormattedText | Overloaded. Initializes a new instance of the FormattedText class.

Public Properties

Name | Description
Runs | Gets a list with the text fragments of this object.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Constructor

FormattedText Constructor
[image]

Initializes a new instance of the FormattedText class.

Overload List

Name | Description
FormattedText () | Initializes a new instance of the FormattedText class.
FormattedText (String) | Initializes a new instance of the FormattedText class from the specified markup text.

See Also

FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Constructor ()

FormattedText Constructor ()
See Also
[image]

Initializes a new instance of the FormattedText class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public FormattedText ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FormattedText Constructor Overload List
FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Constructor (String)

FormattedText Constructor (String)
See Also
[image]

Initializes a new instance of the FormattedText class from the specified markup text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public FormattedText (
string text
)

Visual Basic [image] Copy Code

Public New ( _
text As String _
)

Parameters

text

A markup text specifying the formatted text.

Remarks

The following table contains the tags that can be used in the text:

Tag | Description
<fontname="value">text</fontname> | Changes the font of the text. The value argument specifies the name of the font.
<fontsize="value">text</fontsize> | Changes the font size of the text. The value argument specifies the size as a floating point number with dot (.) as a decimal separator.
<b>text</b> | Indicates bold text.
<i>text</i> | Indicates italic text.
<u>text</u> | Indicates underlined text.
<s>text</s> | Indicates strikeout text.
<color="#RRGGBB">text</color> | Changes the color of the text. The red green and blue color channels are specified as two-digit hexadecimal numbers.

Inside the regular text, you must use &lt;, &gt; and &amp; to display respectively the <, > and & symbols.

Example

The following example demonstrates how to create FormattedText objects using this constructor:

C# [image] Copy Code

FormattedText text = new FormattedText("This is a <b>bold text</b> and <fontsize=\"12\">this text has larger font</fontsize>.");

Visual Basic [image] Copy Code

Dim text As New FormattedText("This is a <b>bold text</b> and <fontsize=""12"">this text has larger font</fontsize>.")

See Also

FormattedText Constructor Overload List
FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Methods

FormattedText Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText.ToString Method

FormattedText.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing the plain text of this object.

See Also

FormattedText Members
FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText Properties

FormattedText Properties
[image]

Public Properties

Name | Description
Runs | Gets a list with the text fragments of this object.

See Also

FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.FormattedText.Runs Property

FormattedText.Runs Property
[image]

Gets a list with the text fragments of this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<Run> Runs { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Runs As List(Of Run)

Property Value

A list of Run objects.

See Also

FormattedText Members
FormattedText Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchBrush Class

HatchBrush Class
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class HatchBrush

Visual Basic [image] Copy Code

Public Class HatchBrush

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.HatchBrush

See Also

HatchBrush Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchBrush Members

HatchBrush Members
Constructors Methods
[image]

Emulates GDI+ hatch brushes using the WPF ImageBrush class.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush | Initializes a new instance of the HatchBrush class.

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchBrush Constructor

HatchBrush Constructor
[image]

Initializes a new instance of the HatchBrush class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public HatchBrush ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HatchBrush Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
CreateInstance | Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

See Also

HatchBrush Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchBrush.CreateInstance Method

HatchBrush.CreateInstance Method
[image]

Returns an ImageBrush instance corresponding to a GDI+ HatchBrush.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Brush CreateInstance (
HatchStyle hatchStyle,
Color foreColor,
Color backColor
)

Visual Basic [image] Copy Code

Public Shared Function CreateInstance( _
hatchStyle As HatchStyle, _
foreColor As Color, _
backColor As Color _
) As Brush

Parameters

hatchStyle

A HatchStyle member specifying the hatch pattern.

foreColor

The hatch foreground color.

backColor

The hatch background color.

Return Value

An ImageBrush instance.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HatchStyle Enumeration

HatchStyle Enumeration
[image]

Represents hatch patterns corresponding to GDI+ HatchBrush objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum HatchStyle

Visual Basic [image] Copy Code

Public Enum HatchStyle

Members

Member name | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of Horizontal.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width.
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points.
DashedVertical | Specifies dashed vertical lines.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
DiagonalCross | A pattern of crisscross diagonal lines.
Divot | Specifies a hatch that has the appearance of divots.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
LargeGrid | Specifies the hatch style Cross.
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points and are spaced 50 percent closer together than ForwardDiagonal, but are not antialiased.
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
Max | Specifies hatch style SolidDiamond.
Min | Specifies hatch style Horizontal.
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal.
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical.
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Shingle | Specifies a hatch that has the appearance of diagonally layered shingles that slant to the right from top points to bottom points.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
Trellis | Specifies a hatch that has the appearance of a trellis.
Vertical | A pattern of vertical lines.
Wave | Specifies horizontal lines that are composed of tildes.
Weave | Specifies a hatch that has the appearance of a woven material.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width.
ZigZag | Specifies horizontal lines that are composed of zigzags.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header Class

Header Class
[image]

Defines the presentation of headers in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public abstract class Header : ContentControl

Visual Basic [image] Copy Code

Public MustInherit Class Header
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Spreadsheet.Wpf.Header
MindFusion.Spreadsheet.Wpf.ColumnHeader
MindFusion.Spreadsheet.Wpf.RowHeader

See Also

Header Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header Members

Header Members
Constructors Fields Properties
[image]

Defines the presentation of headers in the WorkbookView control.

The following tables list the members exposed by the Header type.

Protected Constructors

Name | Description
Header | Initializes a new instance of the Header class.

Public Fields

Name | Description
HasHiddenAfterProperty | Identifies the HasHiddenAfter dependency property.
HasHiddenBeforeProperty | Identifies the HasHiddenBefore dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

Public Properties

Name | Description
HasHiddenAfter | Gets or sets a value indicating whether there are hidden headers immediately after this one. This is a dependency property.
HasHiddenBefore | Gets or sets a value indicating whether there are hidden headers immediately before this one. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the entire row or column represented by this header is selected. This is a dependency property.

See Also

Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header Fields

Header Fields
[image]

Public Fields

Name | Description
HasHiddenAfterProperty | Identifies the HasHiddenAfter dependency property.
HasHiddenBeforeProperty | Identifies the HasHiddenBefore dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

See Also

Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.HasHiddenAfterProperty Field

Header.HasHiddenAfterProperty Field
[image]

Identifies the HasHiddenAfter dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HasHiddenAfterProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HasHiddenAfterProperty As DependencyProperty

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.HasHiddenBeforeProperty Field

Header.HasHiddenBeforeProperty Field
[image]

Identifies the HasHiddenBefore dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HasHiddenBeforeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HasHiddenBeforeProperty As DependencyProperty

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.IsSelectedProperty Field

Header.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header Constructor

Header Constructor
[image]

Initializes a new instance of the Header class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected Header ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header Properties

Header Properties
[image]

Public Properties

Name | Description
HasHiddenAfter | Gets or sets a value indicating whether there are hidden headers immediately after this one. This is a dependency property.
HasHiddenBefore | Gets or sets a value indicating whether there are hidden headers immediately before this one. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the entire row or column represented by this header is selected. This is a dependency property.

See Also

Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.HasHiddenAfter Property

Header.HasHiddenAfter Property
[image]

Gets or sets a value indicating whether there are hidden headers immediately after this one. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool HasHiddenAfter { get; set; }

Visual Basic [image] Copy Code

Public Property HasHiddenAfter As Boolean

Property Value

A boolean value.

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.HasHiddenBefore Property

Header.HasHiddenBefore Property
[image]

Gets or sets a value indicating whether there are hidden headers immediately before this one. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool HasHiddenBefore { get; set; }

Visual Basic [image] Copy Code

Public Property HasHiddenBefore As Boolean

Property Value

A boolean value.

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Header.IsSelected Property

Header.IsSelected Property
[image]

Gets or sets a value indicating whether the entire row or column represented by this header is selected. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

A boolean value.

See Also

Header Members
Header Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HorizontalAlignment Enumeration

HorizontalAlignment Enumeration
[image]

Specifies the horizontal alignment of an element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum HorizontalAlignment

Visual Basic [image] Copy Code

Public Enum HorizontalAlignment

Members

Member name | Description
Center | Indicates that the element is horizontally centered.
Default | Indicates the default alignment, usually dependent on the element's type.
Left | Indicates that the element is aligned to the left side.
Right | Indicates that the element is aligned to the right side.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink Class

Hyperlink Class
Remarks See Also
[image]

Represents a hyperlink associated with a worksheet cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Hyperlink

Visual Basic [image] Copy Code

Public Class Hyperlink

Remarks

Objects of this class cannot be instantiated directly. To create and associate a hyperlink with a cell, call the SetHyperlink method of the cell.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Hyperlink

See Also

Hyperlink Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink Members

Hyperlink Members
Properties Methods
[image]

Represents a hyperlink associated with a worksheet cell.

The following tables list the members exposed by the Hyperlink type.

Public Properties

Name | Description
IsImplicit | Gets a value indicating whether this hyperlink is created automatically by invoking the HYPERLINK function.
SubTarget | Gets or sets the hyperlink subtarget.
Target | Gets or sets the hyperlink target.
ToolTip | Gets or sets the tooltip to display for the cell containing the hyperlink.
Type | Gets or sets the hyperlink type.

Public Methods

Name | Description
Remove | Removes this hyperlink from its owner Cell object.

See Also

Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink Methods

Hyperlink Methods
[image]

Public Methods

Name | Description
Remove | Removes this hyperlink from its owner Cell object.

See Also

Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.Remove Method

Hyperlink.Remove Method
[image]

Removes this hyperlink from its owner Cell object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove ()

Visual Basic [image] Copy Code

Public Sub Remove ()

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink Properties

Hyperlink Properties
[image]

Public Properties

Name | Description
IsImplicit | Gets a value indicating whether this hyperlink is created automatically by invoking the HYPERLINK function.
SubTarget | Gets or sets the hyperlink subtarget.
Target | Gets or sets the hyperlink target.
ToolTip | Gets or sets the tooltip to display for the cell containing the hyperlink.
Type | Gets or sets the hyperlink type.

See Also

Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.IsImplicit Property

Hyperlink.IsImplicit Property
[image]

Gets a value indicating whether this hyperlink is created automatically by invoking the HYPERLINK function.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsImplicit { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsImplicit As Boolean

Property Value

true if the hyperlink is created as a result of the HYPERLINK evaluation; false if the hyperlink was created explicitly by a call to SetHyperlink.

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.SubTarget Property

Hyperlink.SubTarget Property
[image]

Gets or sets the hyperlink subtarget.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string SubTarget { get; set; }

Visual Basic [image] Copy Code

Public Property SubTarget As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This is the optional bookmark for WebAddress and ExistingFile hyperlinks, the e-mail subject for EmailAddress hyperlinks, and ignored for CurrentWorkbook hyperlinks.

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.Target Property

Hyperlink.Target Property
[image]

Gets or sets the hyperlink target.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This is the URL for WebAddress hyperlinks, the e-mail address for EmailAddress hyperlinks, the document path for ExistingFile hyperlinks, and the cell reference for CurrentWorkbook hyperlinks.

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.ToolTip Property

Hyperlink.ToolTip Property
[image]

Gets or sets the tooltip to display for the cell containing the hyperlink.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTip As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Hyperlink.Type Property

Hyperlink.Type Property
[image]

Gets or sets the hyperlink type.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public HyperlinkType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As HyperlinkType

Property Value

A member of the HyperlinkType enumeration. The default is WebAddress.

See Also

Hyperlink Members
Hyperlink Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.HyperlinkType Enumeration

HyperlinkType Enumeration
[image]

Specifies the type of a hyperlink.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum HyperlinkType

Visual Basic [image] Copy Code

Public Enum HyperlinkType

Members

Member name | Description
CurrentWorkbook | Indicates that the hyperlink points to a cell or a range of cells within the current workbook.
EmailAddress | Indicates that the hyperlink points to an e-mail address.
ExistingFile | Indicates that the hyperlink points to a document.
WebAddress | Indicates that the hyperlink points to an online resource.

Remarks

Members of this enumeration can be assigned to the Type property of the Hyperlink class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle Interface

IColumnStyle Interface
[image]

Represents the style of a column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IColumnStyle : IStyle

Visual Basic [image] Copy Code

Public Interface IColumnStyle
Implements IStyle

See Also

IColumnStyle Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle Members

IColumnStyle Members
Properties Methods
[image]

Represents the style of a column.

The following tables list the members exposed by the IColumnStyle type.

Public Properties

Name | Description
IsHidden | Gets or sets a value indicating whether the column is hidden.
OutlineLevel | Gets or sets the outline level of the column, or null (Nothing in Visual Basic), if the column is not grouped.
Width | Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.

Public Methods

Name | Description
Group | Increases the outline level of the columns by one.
Ungroup | Decreases the outline level of the columns by one.

See Also

IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle Methods

IColumnStyle Methods
[image]

Public Methods

Name | Description
Group | Increases the outline level of the columns by one.
Ungroup | Decreases the outline level of the columns by one.

See Also

IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle.Group Method

IColumnStyle.Group Method
[image]

Increases the outline level of the columns by one.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool Group ()

Visual Basic [image] Copy Code

Function Group () As Boolean

Return Value

true, if grouping was successful; otherwise, false.

See Also

IColumnStyle Members
IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle.Ungroup Method

IColumnStyle.Ungroup Method
[image]

Decreases the outline level of the columns by one.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool Ungroup ()

Visual Basic [image] Copy Code

Function Ungroup () As Boolean

Return Value

true, if grouping was successful; otherwise, false.

See Also

IColumnStyle Members
IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle Properties

IColumnStyle Properties
[image]

Public Properties

Name | Description
IsHidden | Gets or sets a value indicating whether the column is hidden.
OutlineLevel | Gets or sets the outline level of the column, or null (Nothing in Visual Basic), if the column is not grouped.
Width | Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.

See Also

IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle.IsHidden Property

IColumnStyle.IsHidden Property
[image]

Gets or sets a value indicating whether the column is hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> IsHidden { get; set; }

Visual Basic [image] Copy Code

Property IsHidden As Nullable(Of Boolean)

Property Value

true if the column is hidden; otherwise, false.

See Also

IColumnStyle Members
IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle.OutlineLevel Property

IColumnStyle.OutlineLevel Property
[image]

Gets or sets the outline level of the column, or null (Nothing in Visual Basic), if the column is not grouped.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Int32> OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Property OutlineLevel As Nullable(Of Int32)

Property Value

A nullable integer value.

See Also

IColumnStyle Members
IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IColumnStyle.Width Property

IColumnStyle.Width Property
[image]

Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure Width { get; set; }

Visual Basic [image] Copy Code

Property Width As Measure

Property Value

An instance of the Measure class.

See Also

IColumnStyle Members
IColumnStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat Interface

IConditionalFormat Interface
Remarks See Also
[image]

Represents conditional format associated with a range of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IConditionalFormat

Visual Basic [image] Copy Code

Public Interface IConditionalFormat

Remarks

This interface can be used to customize the appearance of a cell or a range of cells based on a condition. There are two types of conditions that can be used - a cell value comparison or an expression. The type of the condition is specified through the Type property. When the condition is satisfied the style specified by Style is applied to the associated cell or range of cells.

Cell Value Comparison

The first condition type compares the value of the associated cell to the values specified by First and Second using the operator specified by Operator. The following table illustrates how the two operands are used by each operator.

Operator | Condition
Between | The cell value must be greater than or equal to First and less than or equal to Second. The cell value should be numeric, and the operands must be convertible to numbers.
NotBetween | The cell value must be less than First or greater than Second. The cell value should be numeric and the operands must be convertible to numbers.
Equal / NotEqual | The cell value must be equal / not equal to First. Second is not used. If cell value is a numeric, First must be convertible to number. If cell value is a string, First must be convertible to string.
LessThan / LessThanOrEqual | The cell value must be less than / less than or equal to First. Second is not used. The cell value should be numeric and the operand must be convertible to number.
GreaterThan / GreaterThanOrEqual | The cell value must be greater than / greater than or equal to Second. First is not used. The cell value should be numeric and the operand must be convertible to number.
Contain / NotContain | The cell value should contain the value of First. Second is not used. The cell value should be string and the operand must be convertible to string.

Expression

The second condition type checks the result of an expression. The expression is specified by the First operand. The condition is satisfied when the expression evaluates to true.

See Also

IConditionalFormat Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat Members

IConditionalFormat Members
Properties Methods
[image]

Represents conditional format associated with a range of cells.

The following tables list the members exposed by the IConditionalFormat type.

Public Properties

Name | Description
First | Gets or sets the first value of the condition.
Operator | Gets or sets the comparison operator, for conditional format based on the cell value.
Second | Gets or sets the second value of the condition.
Style | Gets the style to apply to the cells if the condition is met.
Type | Gets or sets a value indicating whether the conditional format is based on the value of the cell or on the result of an expression.

Public Methods

Name | Description
Reset | Resets the format to the default.

See Also

IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat Methods

IConditionalFormat Methods
[image]

Public Methods

Name | Description
Reset | Resets the format to the default.

See Also

IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.Reset Method

IConditionalFormat.Reset Method
[image]

Resets the format to the default.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void Reset ()

Visual Basic [image] Copy Code

Sub Reset ()

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat Properties

IConditionalFormat Properties
[image]

Public Properties

Name | Description
First | Gets or sets the first value of the condition.
Operator | Gets or sets the comparison operator, for conditional format based on the cell value.
Second | Gets or sets the second value of the condition.
Style | Gets the style to apply to the cells if the condition is met.
Type | Gets or sets a value indicating whether the conditional format is based on the value of the cell or on the result of an expression.

See Also

IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.First Property

IConditionalFormat.First Property
[image]

Gets or sets the first value of the condition.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string First { get; set; }

Visual Basic [image] Copy Code

Property First As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This property can be an expression. In this case the expression is evaluated to produce a value to be used as an operand.

First must produce a value of the appropriate type. For example, if the Operator property of the condition is set to Between, First must be a string that can be converted to a number, or an expression, which evaluates to either a number or an object convertible to number. For additional information, see IConditionalFormat.

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.Operator Property

IConditionalFormat.Operator Property
[image]

Gets or sets the comparison operator, for conditional format based on the cell value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

ComparisonOperator Operator { get; set; }

Visual Basic [image] Copy Code

Property Operator As ComparisonOperator

Property Value

A member of the ComparisonOperator enumeration. The default is Between.

Remarks

For additional information, see IConditionalFormat.

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.Second Property

IConditionalFormat.Second Property
[image]

Gets or sets the second value of the condition.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string Second { get; set; }

Visual Basic [image] Copy Code

Property Second As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This property can be an expression. In this case the expression is evaluated to produce a value to be used as an operand.

Second must produce a value of the appropriate type. For example, if the Operator property of the condition is set to Between, Second must be a string that can be converted to a number, or an expression, which evaluates to either a number or an object convertible to number. For additional information, see IConditionalFormat.

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.Style Property

IConditionalFormat.Style Property
[image]

Gets the style to apply to the cells if the condition is met.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IStyle Style { get; }

Visual Basic [image] Copy Code

ReadOnly Property Style As IStyle

Property Value

An IStyle object.

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormat.Type Property

IConditionalFormat.Type Property
[image]

Gets or sets a value indicating whether the conditional format is based on the value of the cell or on the result of an expression.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

ConditionalFormatType Type { get; set; }

Visual Basic [image] Copy Code

Property Type As ConditionalFormatType

Property Value

A member of the ConditionalFormatType enumeration. The default is CellValue.

Remarks

For additional information, see IConditionalFormat.

See Also

IConditionalFormat Members
IConditionalFormat Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection Interface

IConditionalFormatCollection Interface
[image]

Represents a collection of IConditionalFormat objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IConditionalFormatCollection : IEnumerable<IConditionalFormat>, IEnumerable

Visual Basic [image] Copy Code

Public Interface IConditionalFormatCollection
Implements IEnumerable(Of IConditionalFormat), IEnumerable

See Also

IConditionalFormatCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection Members

IConditionalFormatCollection Members
Properties Methods
[image]

Represents a collection of IConditionalFormat objects.

The following tables list the members exposed by the IConditionalFormatCollection type.

Public Properties

Name | Description
HasMixedConditions | Gets a value indicating whether the collection contains overlapping conditional formats.

Public Methods

Name | Description
Add | Overloaded. Creates a new IConditionalFormat object and adds it to the collection.
Clear | Clears the collection.
Remove | Removes the specified conditional format from the collection.

See Also

IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection Methods

IConditionalFormatCollection Methods
[image]

Public Methods

Name | Description
Add | Overloaded. Creates a new IConditionalFormat object and adds it to the collection.
Clear | Clears the collection.
Remove | Removes the specified conditional format from the collection.

See Also

IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.Add Method

IConditionalFormatCollection.Add Method
[image]

Creates a new IConditionalFormat object and adds it to the collection.

Overload List

Name | Description
IConditionalFormatCollection.Add () | Creates a new IConditionalFormat object and adds it to the collection.
IConditionalFormatCollection.Add (ConditionalFormatType, ComparisonOperator, String, String) | Creates a new IConditionalFormat object with the specified attributes and adds it to the collection.

See Also

IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.Add Method ()

IConditionalFormatCollection.Add Method ()
See Also
[image]

Creates a new IConditionalFormat object and adds it to the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IConditionalFormat Add ()

Visual Basic [image] Copy Code

Function Add () As IConditionalFormat

Return Value

The newly created IConditionalFormat object.

See Also

Add Method Overload List
IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.Add Method (ConditionalFormatType, ComparisonOperator, String, String)

IConditionalFormatCollection.Add Method (ConditionalFormatType, ComparisonOperator, String, String)
See Also
[image]

Creates a new IConditionalFormat object with the specified attributes and adds it to the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IConditionalFormat Add (
ConditionalFormatType type,
ComparisonOperator op,
string first,
string second
)

Visual Basic [image] Copy Code

Function Add( _
type As ConditionalFormatType, _
op As ComparisonOperator, _
first As String, _
second As String _
) As IConditionalFormat

Parameters

type

The type of the new conditional format.

op

The comparison operator of the new conditional format.

first

The first value of the condition.

second

The second value of the condition.

Return Value

The newly created IConditionalFormat object.

See Also

Add Method Overload List
IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.Clear Method

IConditionalFormatCollection.Clear Method
[image]

Clears the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void Clear ()

Visual Basic [image] Copy Code

Sub Clear ()

See Also

IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.Remove Method

IConditionalFormatCollection.Remove Method
[image]

Removes the specified conditional format from the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void Remove (
IConditionalFormat format
)

Visual Basic [image] Copy Code

Sub Remove( _
format As IConditionalFormat _
)

Parameters

format

The conditional format to remove.

See Also

IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection Properties

IConditionalFormatCollection Properties
[image]

Public Properties

Name | Description
HasMixedConditions | Gets a value indicating whether the collection contains overlapping conditional formats.

See Also

IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IConditionalFormatCollection.HasMixedConditions Property

IConditionalFormatCollection.HasMixedConditions Property
[image]

Gets a value indicating whether the collection contains overlapping conditional formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool HasMixedConditions { get; }

Visual Basic [image] Copy Code

ReadOnly Property HasMixedConditions As Boolean

Property Value

true if the collection contains overlapping conditional formats; otherwise, false.

Remarks

If the collection contains mixed conditions, it cannot be enumerated.

See Also

IConditionalFormatCollection Members
IConditionalFormatCollection Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IHasName Interface

IHasName Interface
[image]

Defines a name for the type that implements this interface.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IHasName

Visual Basic [image] Copy Code

Public Interface IHasName

Inheritors

MindFusion.Spreadsheet.Wpf.NamedRange
MindFusion.Spreadsheet.Wpf.Worksheet

See Also

IHasName Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IHasName Members

IHasName Members
Properties
[image]

Defines a name for the type that implements this interface.

The following tables list the members exposed by the IHasName type.

Public Properties

Name | Description
Name | Gets or sets the name of the object.

See Also

IHasName Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IHasName Properties

IHasName Properties
[image]

Public Properties

Name | Description
Name | Gets or sets the name of the object.

See Also

IHasName Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IHasName.Name Property

IHasName.Name Property
[image]

Gets or sets the name of the object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string Name { get; set; }

Visual Basic [image] Copy Code

Property Name As String

Property Value

A string value.

See Also

IHasName Members
IHasName Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IInplaceEditable Interface

IInplaceEditable Interface
[image]

Represents an inplace-editable object within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IInplaceEditable

Visual Basic [image] Copy Code

Public Interface IInplaceEditable

Inheritors

MindFusion.Spreadsheet.Wpf.Annotation
MindFusion.Spreadsheet.Wpf.Cell

See Also

IInplaceEditable Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IInplaceEditable Members

IInplaceEditable Members
Methods
[image]

Represents an inplace-editable object within a worksheet.

The following tables list the members exposed by the IInplaceEditable type.

Public Methods

Name | Description
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

IInplaceEditable Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IInplaceEditable Methods

IInplaceEditable Methods
[image]

Public Methods

Name | Description
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

IInplaceEditable Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IInplaceEditable.GetTextToEdit Method

IInplaceEditable.GetTextToEdit Method
[image]

Returns the text of the object which should be displayed initially when the object is in-place edited.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string GetTextToEdit ()

Visual Basic [image] Copy Code

Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place edit box.

See Also

IInplaceEditable Members
IInplaceEditable Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IInplaceEditable.SetEditedText Method

IInplaceEditable.SetEditedText Method
[image]

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

IInplaceEditable Members
IInplaceEditable Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyCollectionChanged Interface

INotifyCollectionChanged Interface
[image]

Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Interface INotifyCollectionChanged

Inheritors

MindFusion.Spreadsheet.Wpf.ObservableCollection(T)
MindFusion.Spreadsheet.Wpf.UndoableCollection(T)

See Also

INotifyCollectionChanged Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyCollectionChanged Members

INotifyCollectionChanged Members
Events
[image]

Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.

The following tables list the members exposed by the INotifyCollectionChanged type.

Public Events

Name | Description
CollectionChanged | Occurs when the collection changes.

See Also

INotifyCollectionChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyCollectionChanged Events

INotifyCollectionChanged Events
[image]

Public Events

Name | Description
CollectionChanged | Occurs when the collection changes.

See Also

INotifyCollectionChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyCollectionChanged.CollectionChanged Event

INotifyCollectionChanged.CollectionChanged Event
[image]

Occurs when the collection changes.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

event EventHandler<NotifyCollectionChangedEventArgs> CollectionChanged

Visual Basic [image] Copy Code

Event CollectionChanged As EventHandler(Of NotifyCollectionChangedEventArgs)

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs.

See Also

INotifyCollectionChanged Members
INotifyCollectionChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyPropertyValueChanged Interface

INotifyPropertyValueChanged Interface
[image]

Provides notification for property changes.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface INotifyPropertyValueChanged

Visual Basic [image] Copy Code

Public Interface INotifyPropertyValueChanged

Inheritors

MindFusion.Spreadsheet.Wpf.InteractiveObject
MindFusion.Spreadsheet.Wpf.NamedRange
MindFusion.Spreadsheet.Wpf.Workbook
MindFusion.Spreadsheet.Wpf.Worksheet

See Also

INotifyPropertyValueChanged Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyPropertyValueChanged Members

INotifyPropertyValueChanged Members
Events
[image]

Provides notification for property changes.

The following tables list the members exposed by the INotifyPropertyValueChanged type.

Public Events

Name | Description
PropertyValueChanged | Occurs when a property value changes.

See Also

INotifyPropertyValueChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyPropertyValueChanged Events

INotifyPropertyValueChanged Events
[image]

Public Events

Name | Description
PropertyValueChanged | Occurs when a property value changes.

See Also

INotifyPropertyValueChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.INotifyPropertyValueChanged.PropertyValueChanged Event

INotifyPropertyValueChanged.PropertyValueChanged Event
[image]

Occurs when a property value changes.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

Event Data

PropertyValueChanged event handlers receive an argument of type PropertyEventArgs.

See Also

INotifyPropertyValueChanged Members
INotifyPropertyValueChanged Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs Class

InplaceEditEventArgs Class
[image]

Contains the arguments passed to the InplaceEditStarted and InplaceEditEnded event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class InplaceEditEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InplaceEditEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs
MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs

See Also

InplaceEditEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs Members

InplaceEditEventArgs Members
Properties
[image]

Contains the arguments passed to the InplaceEditStarted and InplaceEditEnded event handlers.

The following tables list the members exposed by the InplaceEditEventArgs type.

Public Properties

Name | Description
Accepted | Gets a value indicating whether the in-place edit changes were accepted. This value is relevant only for the InplaceEditEnded event.
EditControl | Gets or sets the control used to edit the item's text.
Item | Gets a reference to the item being edited.

See Also

InplaceEditEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs Properties

InplaceEditEventArgs Properties
[image]

Public Properties

Name | Description
Accepted | Gets a value indicating whether the in-place edit changes were accepted. This value is relevant only for the InplaceEditEnded event.
EditControl | Gets or sets the control used to edit the item's text.
Item | Gets a reference to the item being edited.

See Also

InplaceEditEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs.Accepted Property

InplaceEditEventArgs.Accepted Property
[image]

Gets a value indicating whether the in-place edit changes were accepted. This value is relevant only for the InplaceEditEnded event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Accepted { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Accepted As Boolean

Property Value

true if the in-place edit changes were accepted; otherwise, false.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs.EditControl Property

InplaceEditEventArgs.EditControl Property
[image]

Gets or sets the control used to edit the item's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Control EditControl { get; set; }

Visual Basic [image] Copy Code

Public Property EditControl As Control

Property Value

An instance of the WPF Control class.

Remarks

If a custom editor is specified and it does not implement the IInplaceEditor interface, the Text property will be used as the cell value upon successful edit.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs.Item Property

InplaceEditEventArgs.Item Property
[image]

Gets a reference to the item being edited.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IInplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As IInplaceEditable

Property Value

An IInplaceEditable instance.

See Also

InplaceEditEventArgs Members
InplaceEditEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs Class

InplaceEditValidationEventArgs Class
[image]

Contains the arguments passed to the InplaceEditStarting and InplaceEditEnding event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class InplaceEditValidationEventArgs : InplaceEditEventArgs

Visual Basic [image] Copy Code

Public Class InplaceEditValidationEventArgs
Inherits InplaceEditEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.InplaceEditEventArgs
MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs

See Also

InplaceEditValidationEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs Members

InplaceEditValidationEventArgs Members
Properties
[image]

Contains the arguments passed to the InplaceEditStarting and InplaceEditEnding event handlers.

The following tables list the members exposed by the InplaceEditValidationEventArgs type.

Public Properties

Name | Description
Accepted | Gets a value indicating whether the in-place edit changes were accepted. This value is relevant only for the InplaceEditEnded event. (Inherited from InplaceEditEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
EditControl | Gets or sets the control used to edit the item's text. (Inherited from InplaceEditEventArgs.)
Item | Gets a reference to the item being edited. (Inherited from InplaceEditEventArgs.)

See Also

InplaceEditValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs Properties

InplaceEditValidationEventArgs Properties
[image]

Public Properties

Name | Description
Accepted | Gets a value indicating whether the in-place edit changes were accepted. This value is relevant only for the InplaceEditEnded event. (Inherited from InplaceEditEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
EditControl | Gets or sets the control used to edit the item's text. (Inherited from InplaceEditEventArgs.)
Item | Gets a reference to the item being edited. (Inherited from InplaceEditEventArgs.)

See Also

InplaceEditValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InplaceEditValidationEventArgs.Cancel Property

InplaceEditValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the current operation (see below); otherwise, false. The default is false.

Remarks

Set this property to true to prevent the user from completing the operation. If the current operation is starting an in-place editing, the in-place editing does not happen at all. If the current operation is ending an in-place editing, the editing does not end.

See Also

InplaceEditValidationEventArgs Members
InplaceEditValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Class

InteractiveObject Class
[image]

Represents a worksheet object that can be modified interactively by the user.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public abstract class InteractiveObject : DependencyObject, IDisposable, INotifyPropertyValueChanged

Visual Basic [image] Copy Code

Public MustInherit Class InteractiveObject
Inherits DependencyObject
Implements IDisposable, INotifyPropertyValueChanged

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Spreadsheet.Wpf.InteractiveObject
MindFusion.Spreadsheet.Wpf.CellAnnotation
MindFusion.Spreadsheet.Wpf.Picture
MindFusion.Spreadsheet.Wpf.Charts.Chart

See Also

InteractiveObject Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Members

InteractiveObject Members
Constructors Properties Methods Events
[image]

Represents a worksheet object that can be modified interactively by the user.

The following tables list the members exposed by the InteractiveObject type.

Protected Constructors

Name | Description
InteractiveObject | Initializes a new instance of the InteractiveObject class.

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object.
AnchorPosition | Gets or sets the anchor position of this object.
Description | Gets or sets the object description.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored.
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored.
Height | Gets or sets the desired height, or null, to calculate the height automatically.
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor.
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet.
LineBrush | Gets or sets the outline color of this object.
LineSize | Gets or sets the thickness of the object's outline.
LineStyle | Gets or sets the style of the object's outline.
Locked | Gets or sets a value indicating whether this object can be interacted with.
Title | Gets or sets the object title.
VerticalOffset | Gets or sets the vertical offset of the object from its origin.
Width | Gets or sets the desired width, or null, to calculate width automatically.

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle.
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell.

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order.
BringToFront | Brings this object to the top of the z-order.
Dispose | Overloaded. Disposes this object.
SendBackward | Moves this object one step down in the z-order.
SendToBack | Sends this object to the bottom of the z-order.

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnResized | This method is called when the object's size is changed.

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation.

See Also

InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Constructor

InteractiveObject Constructor
[image]

Initializes a new instance of the InteractiveObject class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected InteractiveObject (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Protected New ( _
worksheet As Worksheet _
)

Parameters

worksheet

The Worksheet this object belongs to.

See Also

InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Methods

InteractiveObject Methods
[image]

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order.
BringToFront | Brings this object to the top of the z-order.
Dispose | Overloaded. Disposes this object.
SendBackward | Moves this object one step down in the z-order.
SendToBack | Sends this object to the bottom of the z-order.

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnResized | This method is called when the object's size is changed.

See Also

InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.BringForward Method

InteractiveObject.BringForward Method
[image]

Moves this object one step up in the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void BringForward ()

Visual Basic [image] Copy Code

Public Sub BringForward ()

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.BringToFront Method

InteractiveObject.BringToFront Method
[image]

Brings this object to the top of the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void BringToFront ()

Visual Basic [image] Copy Code

Public Sub BringToFront ()

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Dispose Method

InteractiveObject.Dispose Method
[image]

Disposes this object.

Overload List

Name | Description
InteractiveObject.Dispose () | Disposes this object of any unmanaged resources it might hold.
InteractiveObject.Dispose (Boolean) | Clean up any resources being used.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Dispose Method ()

InteractiveObject.Dispose Method ()
See Also
[image]

Disposes this object of any unmanaged resources it might hold.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

See Also

Dispose Method Overload List
InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Dispose Method (Boolean)

InteractiveObject.Dispose Method (Boolean)
See Also
[image]

Clean up any resources being used.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overridable Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true if managed resources should be disposed; otherwise, false.

See Also

Dispose Method Overload List
InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.OnPropertyValueChanged Method

InteractiveObject.OnPropertyValueChanged Method
[image]

Raises the PropertyValueChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyValueChanged (
PropertyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyValueChanged( _
e As PropertyEventArgs _
)

Parameters

e

An object providing the event data.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.OnResized Method

InteractiveObject.OnResized Method
[image]

This method is called when the object's size is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnResized ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnResized ()

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.SendBackward Method

InteractiveObject.SendBackward Method
[image]

Moves this object one step down in the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SendBackward ()

Visual Basic [image] Copy Code

Public Sub SendBackward ()

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.SendToBack Method

InteractiveObject.SendToBack Method
[image]

Sends this object to the bottom of the z-order.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SendToBack ()

Visual Basic [image] Copy Code

Public Sub SendToBack ()

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Properties

InteractiveObject Properties
[image]

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object.
AnchorPosition | Gets or sets the anchor position of this object.
Description | Gets or sets the object description.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored.
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored.
Height | Gets or sets the desired height, or null, to calculate the height automatically.
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor.
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet.
LineBrush | Gets or sets the outline color of this object.
LineSize | Gets or sets the thickness of the object's outline.
LineStyle | Gets or sets the style of the object's outline.
Locked | Gets or sets a value indicating whether this object can be interacted with.
Title | Gets or sets the object title.
VerticalOffset | Gets or sets the vertical offset of the object from its origin.
Width | Gets or sets the desired width, or null, to calculate width automatically.

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle.
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell.

See Also

InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Anchor Property

InteractiveObject.Anchor Property
[image]

Gets or sets the anchor of this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public virtual ObjectAnchor Anchor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Anchor As ObjectAnchor

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.AnchorPosition Property

InteractiveObject.AnchorPosition Property
[image]

Gets or sets the anchor position of this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ObjectAnchorPosition AnchorPosition { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPosition As ObjectAnchorPosition

Property Value

Remarks

This value is relevant only if the Anchor property is set to ObjectAnchor.ToCell.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Description Property

InteractiveObject.Description Property
[image]

Gets or sets the object description.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.ExtendsOutsideBounds Property

InteractiveObject.ExtendsOutsideBounds Property
[image]

Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual bool ExtendsOutsideBounds { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ExtendsOutsideBounds As Boolean

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.FromColumn Property

InteractiveObject.FromColumn Property
[image]

Gets or sets the zero-based index of the column of the cell to which the object is anchored.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FromColumn { get; set; }

Visual Basic [image] Copy Code

Public Property FromColumn As Integer

Property Value

Remarks

This value is ignored if the object is anchored to the page.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.FromRow Property

InteractiveObject.FromRow Property
[image]

Gets or sets the zero-based index of the row of the cell to which the object is anchored.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FromRow { get; set; }

Visual Basic [image] Copy Code

Public Property FromRow As Integer

Property Value

Remarks

This value is ignore if the object is anchored to the page.

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Height Property

InteractiveObject.Height Property
[image]

Gets or sets the desired height, or null, to calculate the height automatically.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Measure

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.HorizontalOffset Property

InteractiveObject.HorizontalOffset Property
[image]

Gets or sets the horizontal offset of the object from its anchor.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Measure

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.IsLockedToCell Property

InteractiveObject.IsLockedToCell Property
[image]

Gets a value indicating whether this object is always locked to a cell in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public virtual bool IsLockedToCell { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsLockedToCell As Boolean

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.LineBrush Property

InteractiveObject.LineBrush Property
[image]

Gets or sets the outline color of this object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush LineBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LineBrush As Brush

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.LineSize Property

InteractiveObject.LineSize Property
[image]

Gets or sets the thickness of the object's outline.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure LineSize { get; set; }

Visual Basic [image] Copy Code

Public Property LineSize As Measure

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.LineStyle Property

InteractiveObject.LineStyle Property
[image]

Gets or sets the style of the object's outline.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DashStyle LineStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LineStyle As DashStyle

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Locked Property

InteractiveObject.Locked Property
[image]

Gets or sets a value indicating whether this object can be interacted with.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.RegardsMergedCells Property

InteractiveObject.RegardsMergedCells Property
[image]

Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual bool RegardsMergedCells { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property RegardsMergedCells As Boolean

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Title Property

InteractiveObject.Title Property
[image]

Gets or sets the object title.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.VerticalOffset Property

InteractiveObject.VerticalOffset Property
[image]

Gets or sets the vertical offset of the object from its origin.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Measure

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject.Width Property

InteractiveObject.Width Property
[image]

Gets or sets the desired width, or null, to calculate width automatically.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Measure

Property Value

See Also

InteractiveObject Members
InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObject Events

InteractiveObject Events
[image]

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation.

See Also

InteractiveObject Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter Class

InteractiveObjectPresenter Class
[image]

Defines the presentation of interactive objects in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public abstract class InteractiveObjectPresenter : Control

Visual Basic [image] Copy Code

Public MustInherit Class InteractiveObjectPresenter
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter
MindFusion.Spreadsheet.Wpf.CellAnnotationPresenter
MindFusion.Spreadsheet.Wpf.PicturePresenter
MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter

See Also

InteractiveObjectPresenter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter Members

InteractiveObjectPresenter Members
Fields Properties Methods
[image]

Defines the presentation of interactive objects in the WorkbookView control.

The following tables list the members exposed by the InteractiveObjectPresenter type.

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property.
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property.
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ObjectProperty | Identifies the Object dependency property.

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property.
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property.
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property.
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetLayoutClip | FrameworkElement.GetLayoutClip override.

See Also

InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter Fields

InteractiveObjectPresenter Fields
[image]

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property.
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property.
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ObjectProperty | Identifies the Object dependency property.

See Also

InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleBackgroundProperty Field

InteractiveObjectPresenter.AdjustmentHandleBackgroundProperty Field
See Also
[image]

Identifies the AdjustmentHandleBackground dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleBackgroundProperty As DependencyProperty

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleBorderBrushProperty Field

InteractiveObjectPresenter.AdjustmentHandleBorderBrushProperty Field
See Also
[image]

Identifies the AdjustmentHandleBorderBrush dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleBorderBrushProperty As DependencyProperty

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleSizeProperty Field

InteractiveObjectPresenter.AdjustmentHandleSizeProperty Field
See Also
[image]

Identifies the AdjustmentHandleSize dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleSizeProperty As DependencyProperty

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.IsSelectedProperty Field

InteractiveObjectPresenter.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.ObjectProperty Field

InteractiveObjectPresenter.ObjectProperty Field
[image]

Identifies the Object dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ObjectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ObjectProperty As DependencyProperty

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter Methods

InteractiveObjectPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetLayoutClip | FrameworkElement.GetLayoutClip override.

See Also

InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.GetLayoutClip Method

InteractiveObjectPresenter.GetLayoutClip Method
[image]

FrameworkElement.GetLayoutClip override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override Geometry GetLayoutClip (
Size layoutSlotSize
)

Visual Basic [image] Copy Code

Protected Overrides Function GetLayoutClip( _
layoutSlotSize As Size _
) As Geometry

Parameters

layoutSlotSize

Return Value

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.OnApplyTemplate Method

InteractiveObjectPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter Properties

InteractiveObjectPresenter Properties
[image]

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property.
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property.
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property.
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property.

See Also

InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleBackground Property

InteractiveObjectPresenter.AdjustmentHandleBackground Property
See Also
[image]

Gets or sets the background brush of the adjustment handles. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush AdjustmentHandleBackground { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleBackground As Brush

Property Value

An instance of the WPF Brush class.

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleBorderBrush Property

InteractiveObjectPresenter.AdjustmentHandleBorderBrush Property
See Also
[image]

Gets or sets the border brush of the adjustment handles. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush AdjustmentHandleBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleBorderBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.AdjustmentHandleSize Property

InteractiveObjectPresenter.AdjustmentHandleSize Property
[image]

Gets or sets the size of the adjustment handles, in pixels. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double AdjustmentHandleSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleSize As Double

Property Value

A double value.

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.IsSelected Property

InteractiveObjectPresenter.IsSelected Property
[image]

Gets or sets a value indicating whether the presenter is selected. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

A boolean value.

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter.Object Property

InteractiveObjectPresenter.Object Property
[image]

Gets or sets the interactive object associated with this presenter. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public InteractiveObject Object { get; set; }

Visual Basic [image] Copy Code

Public Property Object As InteractiveObject

Property Value

An instance of the InteractiveObject class.

See Also

InteractiveObjectPresenter Members
InteractiveObjectPresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle Interface

IRowStyle Interface
[image]

Represents the style of a row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IRowStyle : IStyle

Visual Basic [image] Copy Code

Public Interface IRowStyle
Implements IStyle

See Also

IRowStyle Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle Members

IRowStyle Members
Properties Methods
[image]

Represents the style of a row.

The following tables list the members exposed by the IRowStyle type.

Public Properties

Name | Description
Height | Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.
IsHidden | Gets or sets a value indicating whether the row is hidden.
OutlineLevel | Gets or sets the outline level of the row, or null (Nothing in Visual Basic), if the row is not grouped.

Public Methods

Name | Description
Group | Increases the outline level of the rows by one.
Ungroup | Decreases the outline level of the rows by one.

See Also

IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle Methods

IRowStyle Methods
[image]

Public Methods

Name | Description
Group | Increases the outline level of the rows by one.
Ungroup | Decreases the outline level of the rows by one.

See Also

IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle.Group Method

IRowStyle.Group Method
[image]

Increases the outline level of the rows by one.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool Group ()

Visual Basic [image] Copy Code

Function Group () As Boolean

Return Value

true, if grouping was successful; otherwise, false.

See Also

IRowStyle Members
IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle.Ungroup Method

IRowStyle.Ungroup Method
[image]

Decreases the outline level of the rows by one.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool Ungroup ()

Visual Basic [image] Copy Code

Function Ungroup () As Boolean

Return Value

true, if grouping was successful; otherwise, false.

See Also

IRowStyle Members
IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle Properties

IRowStyle Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.
IsHidden | Gets or sets a value indicating whether the row is hidden.
OutlineLevel | Gets or sets the outline level of the row, or null (Nothing in Visual Basic), if the row is not grouped.

See Also

IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle.Height Property

IRowStyle.Height Property
[image]

Gets or sets the width of the column, or null (Nothing in Visual Basic), to use the default width.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure Height { get; set; }

Visual Basic [image] Copy Code

Property Height As Measure

Property Value

An instance of the Measure class.

See Also

IRowStyle Members
IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle.IsHidden Property

IRowStyle.IsHidden Property
[image]

Gets or sets a value indicating whether the row is hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> IsHidden { get; set; }

Visual Basic [image] Copy Code

Property IsHidden As Nullable(Of Boolean)

Property Value

true if the row is hidden; otherwise, false.

See Also

IRowStyle Members
IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IRowStyle.OutlineLevel Property

IRowStyle.OutlineLevel Property
[image]

Gets or sets the outline level of the row, or null (Nothing in Visual Basic), if the row is not grouped.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Int32> OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Property OutlineLevel As Nullable(Of Int32)

Property Value

A nullable integer value.

See Also

IRowStyle Members
IRowStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle Interface

IStyle Interface
[image]

Represents the style of an element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IStyle

Visual Basic [image] Copy Code

Public Interface IStyle

Inheritors

MindFusion.Spreadsheet.Wpf.IColumnStyle
MindFusion.Spreadsheet.Wpf.IRowStyle

See Also

IStyle Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle Members

IStyle Members
Properties Methods
[image]

Represents the style of an element.

The following tables list the members exposed by the IStyle type.

Public Properties

Name | Description
Background | Gets or sets the background.
BorderBottomBrush | Gets or sets the color of the bottom border.
BorderBottomSize | Gets or sets the thickness of the bottom border.
BorderBottomStyle | Gets or sets the style of the bottom border.
BorderLeftBrush | Gets or sets the color of the left border.
BorderLeftSize | Gets or sets the thickness of the left border.
BorderLeftStyle | Gets or sets the style of the left border.
BorderRightBrush | Gets or sets the color of the right border.
BorderRightSize | Gets or sets the thickness of the right border.
BorderRightStyle | Gets or sets the style of the right border.
BorderTopBrush | Gets or sets the color of the top border.
BorderTopSize | Gets or sets the thickness of the top border.
BorderTopStyle | Gets or sets the style of the top border.
ConditionalFormats | Gets a list with the conditional formats associated with this style.
FontBold | Gets or sets a value indicating whether the element's text is bold.
FontItalic | Gets or sets a value indicating whether the element's text is italic.
FontName | Gets or sets the name of the font of the element's text.
FontSize | Gets or sets the size of the font of the element's text.
FontStrikeout | Gets or sets a value indicating whether the element's text is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the element's text is underlined.
Format | Gets or sets the format of the element's contents.
HorizontalAlignment | Gets or sets the horizontal alignment of the element's contents.
Id | Gets or sets the style identifier.
Indent | Gets or sets the indentation of the element's text.
PaddingBottom | Gets or sets the bottom padding of the element's contents.
PaddingLeft | Gets or sets the left padding of the element's contents.
PaddingRight | Gets or sets the right padding of the element's contents.
PaddingTop | Gets or sets the top padding of the element's contents.
PrimaryDiagonalBrush | Gets or sets the color of the primary diagonal.
PrimaryDiagonalSize | Gets or sets the thickness of the primary diagonal.
PrimaryDiagonalStyle | Gets or sets the style of the primary diagonal.
SecondaryDiagonalBrush | Gets or sets the color of the secondary diagonal.
SecondaryDiagonalSize | Gets or sets the thickness of the secondary diagonal.
SecondaryDiagonalStyle | Gets or sets the style of the secondary diagonal.
TextBrush | Gets or sets the color of the element's text.
Validation | Gets an object that can be used to specify validation rules.
VerticalAlignment | Gets or sets the vertical alignment of the element's contents.
Worksheet | Gets the worksheet this style is associated with.
WrapText | Gets or sets a value indicating whether to wrap the element's text.

Public Methods

Name | Description
Reset | Resets the style to the default style.
ResetConditionalFormats | Resets the conditional formats associated with this style.
ResetValidation | Resets the validation associated with this style to the default validation.

See Also

IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle Methods

IStyle Methods
[image]

Public Methods

Name | Description
Reset | Resets the style to the default style.
ResetConditionalFormats | Resets the conditional formats associated with this style.
ResetValidation | Resets the validation associated with this style to the default validation.

See Also

IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Reset Method

IStyle.Reset Method
[image]

Resets the style to the default style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void Reset ()

Visual Basic [image] Copy Code

Sub Reset ()

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.ResetConditionalFormats Method

IStyle.ResetConditionalFormats Method
[image]

Resets the conditional formats associated with this style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void ResetConditionalFormats ()

Visual Basic [image] Copy Code

Sub ResetConditionalFormats ()

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.ResetValidation Method

IStyle.ResetValidation Method
[image]

Resets the validation associated with this style to the default validation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void ResetValidation ()

Visual Basic [image] Copy Code

Sub ResetValidation ()

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle Properties

IStyle Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the background.
BorderBottomBrush | Gets or sets the color of the bottom border.
BorderBottomSize | Gets or sets the thickness of the bottom border.
BorderBottomStyle | Gets or sets the style of the bottom border.
BorderLeftBrush | Gets or sets the color of the left border.
BorderLeftSize | Gets or sets the thickness of the left border.
BorderLeftStyle | Gets or sets the style of the left border.
BorderRightBrush | Gets or sets the color of the right border.
BorderRightSize | Gets or sets the thickness of the right border.
BorderRightStyle | Gets or sets the style of the right border.
BorderTopBrush | Gets or sets the color of the top border.
BorderTopSize | Gets or sets the thickness of the top border.
BorderTopStyle | Gets or sets the style of the top border.
ConditionalFormats | Gets a list with the conditional formats associated with this style.
FontBold | Gets or sets a value indicating whether the element's text is bold.
FontItalic | Gets or sets a value indicating whether the element's text is italic.
FontName | Gets or sets the name of the font of the element's text.
FontSize | Gets or sets the size of the font of the element's text.
FontStrikeout | Gets or sets a value indicating whether the element's text is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the element's text is underlined.
Format | Gets or sets the format of the element's contents.
HorizontalAlignment | Gets or sets the horizontal alignment of the element's contents.
Id | Gets or sets the style identifier.
Indent | Gets or sets the indentation of the element's text.
PaddingBottom | Gets or sets the bottom padding of the element's contents.
PaddingLeft | Gets or sets the left padding of the element's contents.
PaddingRight | Gets or sets the right padding of the element's contents.
PaddingTop | Gets or sets the top padding of the element's contents.
PrimaryDiagonalBrush | Gets or sets the color of the primary diagonal.
PrimaryDiagonalSize | Gets or sets the thickness of the primary diagonal.
PrimaryDiagonalStyle | Gets or sets the style of the primary diagonal.
SecondaryDiagonalBrush | Gets or sets the color of the secondary diagonal.
SecondaryDiagonalSize | Gets or sets the thickness of the secondary diagonal.
SecondaryDiagonalStyle | Gets or sets the style of the secondary diagonal.
TextBrush | Gets or sets the color of the element's text.
Validation | Gets an object that can be used to specify validation rules.
VerticalAlignment | Gets or sets the vertical alignment of the element's contents.
Worksheet | Gets the worksheet this style is associated with.
WrapText | Gets or sets a value indicating whether to wrap the element's text.

See Also

IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Background Property

IStyle.Background Property
[image]

Gets or sets the background.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush Background { get; set; }

Visual Basic [image] Copy Code

Property Background As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderBottomBrush Property

IStyle.BorderBottomBrush Property
[image]

Gets or sets the color of the bottom border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush BorderBottomBrush { get; set; }

Visual Basic [image] Copy Code

Property BorderBottomBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderBottomSize Property

IStyle.BorderBottomSize Property
[image]

Gets or sets the thickness of the bottom border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure BorderBottomSize { get; set; }

Visual Basic [image] Copy Code

Property BorderBottomSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderBottomStyle Property

IStyle.BorderBottomStyle Property
[image]

Gets or sets the style of the bottom border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle BorderBottomStyle { get; set; }

Visual Basic [image] Copy Code

Property BorderBottomStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderLeftBrush Property

IStyle.BorderLeftBrush Property
[image]

Gets or sets the color of the left border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush BorderLeftBrush { get; set; }

Visual Basic [image] Copy Code

Property BorderLeftBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderLeftSize Property

IStyle.BorderLeftSize Property
[image]

Gets or sets the thickness of the left border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure BorderLeftSize { get; set; }

Visual Basic [image] Copy Code

Property BorderLeftSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderLeftStyle Property

IStyle.BorderLeftStyle Property
[image]

Gets or sets the style of the left border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle BorderLeftStyle { get; set; }

Visual Basic [image] Copy Code

Property BorderLeftStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderRightBrush Property

IStyle.BorderRightBrush Property
[image]

Gets or sets the color of the right border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush BorderRightBrush { get; set; }

Visual Basic [image] Copy Code

Property BorderRightBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderRightSize Property

IStyle.BorderRightSize Property
[image]

Gets or sets the thickness of the right border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure BorderRightSize { get; set; }

Visual Basic [image] Copy Code

Property BorderRightSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderRightStyle Property

IStyle.BorderRightStyle Property
[image]

Gets or sets the style of the right border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle BorderRightStyle { get; set; }

Visual Basic [image] Copy Code

Property BorderRightStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderTopBrush Property

IStyle.BorderTopBrush Property
[image]

Gets or sets the color of the top border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush BorderTopBrush { get; set; }

Visual Basic [image] Copy Code

Property BorderTopBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderTopSize Property

IStyle.BorderTopSize Property
[image]

Gets or sets the thickness of the top border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure BorderTopSize { get; set; }

Visual Basic [image] Copy Code

Property BorderTopSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.BorderTopStyle Property

IStyle.BorderTopStyle Property
[image]

Gets or sets the style of the top border.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle BorderTopStyle { get; set; }

Visual Basic [image] Copy Code

Property BorderTopStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.ConditionalFormats Property

IStyle.ConditionalFormats Property
[image]

Gets a list with the conditional formats associated with this style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontBold Property

IStyle.FontBold Property
[image]

Gets or sets a value indicating whether the element's text is bold.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> FontBold { get; set; }

Visual Basic [image] Copy Code

Property FontBold As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontItalic Property

IStyle.FontItalic Property
[image]

Gets or sets a value indicating whether the element's text is italic.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> FontItalic { get; set; }

Visual Basic [image] Copy Code

Property FontItalic As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontName Property

IStyle.FontName Property
[image]

Gets or sets the name of the font of the element's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string FontName { get; set; }

Visual Basic [image] Copy Code

Property FontName As String

Property Value

A string value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontSize Property

IStyle.FontSize Property
[image]

Gets or sets the size of the font of the element's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Double> FontSize { get; set; }

Visual Basic [image] Copy Code

Property FontSize As Nullable(Of Double)

Property Value

A nullable double value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontStrikeout Property

IStyle.FontStrikeout Property
[image]

Gets or sets a value indicating whether the element's text is with a line through the middle.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> FontStrikeout { get; set; }

Visual Basic [image] Copy Code

Property FontStrikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.FontUnderline Property

IStyle.FontUnderline Property
[image]

Gets or sets a value indicating whether the element's text is underlined.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> FontUnderline { get; set; }

Visual Basic [image] Copy Code

Property FontUnderline As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Format Property

IStyle.Format Property
[image]

Gets or sets the format of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string Format { get; set; }

Visual Basic [image] Copy Code

Property Format As String

Property Value

A string value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.HorizontalAlignment Property

IStyle.HorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<HorizontalAlignment> HorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Property HorizontalAlignment As Nullable(Of HorizontalAlignment)

Property Value

A member of the HorizontalAlignment enumeration or null (Nothing in Visual Basic).

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Id Property

IStyle.Id Property
[image]

Gets or sets the style identifier.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

int Id { get; set; }

Visual Basic [image] Copy Code

Property Id As Integer

Property Value

An integer value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Indent Property

IStyle.Indent Property
[image]

Gets or sets the indentation of the element's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure Indent { get; set; }

Visual Basic [image] Copy Code

Property Indent As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PaddingBottom Property

IStyle.PaddingBottom Property
[image]

Gets or sets the bottom padding of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure PaddingBottom { get; set; }

Visual Basic [image] Copy Code

Property PaddingBottom As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PaddingLeft Property

IStyle.PaddingLeft Property
[image]

Gets or sets the left padding of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure PaddingLeft { get; set; }

Visual Basic [image] Copy Code

Property PaddingLeft As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PaddingRight Property

IStyle.PaddingRight Property
[image]

Gets or sets the right padding of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure PaddingRight { get; set; }

Visual Basic [image] Copy Code

Property PaddingRight As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PaddingTop Property

IStyle.PaddingTop Property
[image]

Gets or sets the top padding of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure PaddingTop { get; set; }

Visual Basic [image] Copy Code

Property PaddingTop As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PrimaryDiagonalBrush Property

IStyle.PrimaryDiagonalBrush Property
[image]

Gets or sets the color of the primary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush PrimaryDiagonalBrush { get; set; }

Visual Basic [image] Copy Code

Property PrimaryDiagonalBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PrimaryDiagonalSize Property

IStyle.PrimaryDiagonalSize Property
[image]

Gets or sets the thickness of the primary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure PrimaryDiagonalSize { get; set; }

Visual Basic [image] Copy Code

Property PrimaryDiagonalSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.PrimaryDiagonalStyle Property

IStyle.PrimaryDiagonalStyle Property
[image]

Gets or sets the style of the primary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle PrimaryDiagonalStyle { get; set; }

Visual Basic [image] Copy Code

Property PrimaryDiagonalStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.SecondaryDiagonalBrush Property

IStyle.SecondaryDiagonalBrush Property
[image]

Gets or sets the color of the secondary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush SecondaryDiagonalBrush { get; set; }

Visual Basic [image] Copy Code

Property SecondaryDiagonalBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.SecondaryDiagonalSize Property

IStyle.SecondaryDiagonalSize Property
[image]

Gets or sets the thickness of the secondary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Measure SecondaryDiagonalSize { get; set; }

Visual Basic [image] Copy Code

Property SecondaryDiagonalSize As Measure

Property Value

An instance of the Measure class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.SecondaryDiagonalStyle Property

IStyle.SecondaryDiagonalStyle Property
[image]

Gets or sets the style of the secondary diagonal.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

DashStyle SecondaryDiagonalStyle { get; set; }

Visual Basic [image] Copy Code

Property SecondaryDiagonalStyle As DashStyle

Property Value

An instance of the WPF DashStyle class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.TextBrush Property

IStyle.TextBrush Property
[image]

Gets or sets the color of the element's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Property TextBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Validation Property

IStyle.Validation Property
[image]

Gets an object that can be used to specify validation rules.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IValidation Validation { get; }

Visual Basic [image] Copy Code

ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.VerticalAlignment Property

IStyle.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the element's contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<VerticalAlignment> VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Property VerticalAlignment As Nullable(Of VerticalAlignment)

Property Value

A member of the VerticalAlignment enumeration or null (Nothing in Visual Basic).

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.Worksheet Property

IStyle.Worksheet Property
[image]

Gets the worksheet this style is associated with.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IStyle.WrapText Property

IStyle.WrapText Property
[image]

Gets or sets a value indicating whether to wrap the element's text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> WrapText { get; set; }

Visual Basic [image] Copy Code

Property WrapText As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

IStyle Members
IStyle Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation Interface

IValidation Interface
Remarks See Also
[image]

Represents data validation associated with a range of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IValidation

Visual Basic [image] Copy Code

Public Interface IValidation

Remarks

This interface is used to validate user input in a cell or range of cells. There are several types of validations that can be used, as specified by the Type property.

To display a popup message when a cell associated with the validation is selected, set the ShowInputMessage property to true and customize the input message through the InputTitle and InputMessage properties. The ErrorAction property determines what happens when the validation fails. The control can display a warning, an error message, or simply raise an event.

The different validation types and their required operands are discussed in more details below.

All values

This validation type indicates that the validation will always be successful and is effectively the same as no validation.

Date, Time, Decimal, and Whole number

The validation compares the input value to the values specified by First and Second using the operator specified by Operator. The input value should be numeric and the operands should be convertible to numbers. In the WholeNumber case, the input value should also be a whole number. The following table illustrates the valid operators for this validation type and how the two operands are used by each operator.

Operator | Validation
Between | The input value must be greater than or equal to First and less than or equal to Second.
NotBetween | The input value must be less than First or greater than Second.
Equal / NotEqual | The input value must be equal / not equal to First. Second is not used.
LessThan / LessThanOrEqual | The input value must be less than / less than or equal to First. Second is not used.
GreaterThan / GreaterThanOrEqual | The input value must be greater than / greater than or equal to Second. First is not used.

Text

The validation compares the input to the value specified by First using the operator specified by Operator. Second is not used. The operand should be convertible to a string. The following table illustrates the valid operators for this validation type.

Operator | Validation
Contain / NotContain | The input value must contain / not contain First.
Equal / NotEqual | The input value must be equal / not equal to First.

Text length

The validation compares the length of the input to the value specified by First and Second using the operator specified by Operator, following rules similar to those used when validating numeric values (see above).

List

The validation compares the input value to a list of values obtained from First. First can be a string, containing a comma-delimited list of values. Alternatively, First can be an expression that evaluates to a string with comma-delimited values, or to a cell reference. In the later case the list is composed of the values of all cells in the referenced range.

See Also

IValidation Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation Members

IValidation Members
Properties Methods
[image]

Represents data validation associated with a range of cells.

The following tables list the members exposed by the IValidation type.

Public Properties

Name | Description
AllowBlankCells | Gets or sets a value indicating whether the validation should be skipped for blank cells.
ErrorAction | Gets or sets the action to perform when the validation fails.
ErrorMessage | Gets or sets the error message.
ErrorTitle | Gets or sets the title of the error message.
First | Gets or sets the first value of the validation. This value is interpreted differently depending on the type of the validation.
InputMessage | Gets or sets the input message.
InputTitle | Gets or sets the title of the input message.
Operator | Gets or sets the comparison operator, for validation types that require an operator.
OriginColumn | Gets or sets the origin column of this validation. All relative references in expressions associated with this validation are calculated based on this value.
OriginRow | Gets or sets the origin row of this validation. All relative references in expressions associated with this validation are calculated based on this value.
Second | Gets or sets the second value of the validation. This value is interpreted differently depending on the type of the validation.
ShowDropdownList | Gets or sets a value indicating whether to display drop-down list when a cell in the validated range is selected and the validation type is set to List.
ShowError | Gets or sets a value indicating whether to display error messages when the validation fails.
ShowInputMessage | Gets or sets a value indicating whether to display information message when a cell in the validated range is selected.
SortListEntries | Gets or sets a value indicating whether to sort the entries in the drop-down list.
Type | Gets or sets the validation type.
Worksheet | Gets the worksheet this validation is associated with.

Public Methods

Name | Description
Reset | Resets the validation to the default.

See Also

IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation Methods

IValidation Methods
[image]

Public Methods

Name | Description
Reset | Resets the validation to the default.

See Also

IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.Reset Method

IValidation.Reset Method
[image]

Resets the validation to the default.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

void Reset ()

Visual Basic [image] Copy Code

Sub Reset ()

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation Properties

IValidation Properties
[image]

Public Properties

Name | Description
AllowBlankCells | Gets or sets a value indicating whether the validation should be skipped for blank cells.
ErrorAction | Gets or sets the action to perform when the validation fails.
ErrorMessage | Gets or sets the error message.
ErrorTitle | Gets or sets the title of the error message.
First | Gets or sets the first value of the validation. This value is interpreted differently depending on the type of the validation.
InputMessage | Gets or sets the input message.
InputTitle | Gets or sets the title of the input message.
Operator | Gets or sets the comparison operator, for validation types that require an operator.
OriginColumn | Gets or sets the origin column of this validation. All relative references in expressions associated with this validation are calculated based on this value.
OriginRow | Gets or sets the origin row of this validation. All relative references in expressions associated with this validation are calculated based on this value.
Second | Gets or sets the second value of the validation. This value is interpreted differently depending on the type of the validation.
ShowDropdownList | Gets or sets a value indicating whether to display drop-down list when a cell in the validated range is selected and the validation type is set to List.
ShowError | Gets or sets a value indicating whether to display error messages when the validation fails.
ShowInputMessage | Gets or sets a value indicating whether to display information message when a cell in the validated range is selected.
SortListEntries | Gets or sets a value indicating whether to sort the entries in the drop-down list.
Type | Gets or sets the validation type.
Worksheet | Gets the worksheet this validation is associated with.

See Also

IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.AllowBlankCells Property

IValidation.AllowBlankCells Property
[image]

Gets or sets a value indicating whether the validation should be skipped for blank cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool AllowBlankCells { get; set; }

Visual Basic [image] Copy Code

Property AllowBlankCells As Boolean

Property Value

true if cells with no data should be skipped by the validation; otherwise, false.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ErrorAction Property

IValidation.ErrorAction Property
[image]

Gets or sets the action to perform when the validation fails.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

ValidationErrorAction ErrorAction { get; set; }

Visual Basic [image] Copy Code

Property ErrorAction As ValidationErrorAction

Property Value

A member of the ValidationErrorAction enumeration.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ErrorMessage Property

IValidation.ErrorMessage Property
[image]

Gets or sets the error message.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string ErrorMessage { get; set; }

Visual Basic [image] Copy Code

Property ErrorMessage As String

Property Value

A string value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ErrorTitle Property

IValidation.ErrorTitle Property
[image]

Gets or sets the title of the error message.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string ErrorTitle { get; set; }

Visual Basic [image] Copy Code

Property ErrorTitle As String

Property Value

A string value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.First Property

IValidation.First Property
[image]

Gets or sets the first value of the validation. This value is interpreted differently depending on the type of the validation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string First { get; set; }

Visual Basic [image] Copy Code

Property First As String

Property Value

A string value.

Remarks

This property can be an expression. In this case the expression is evaluated to produce a value to be used as an operand. For additional information, see IValidation.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.InputMessage Property

IValidation.InputMessage Property
[image]

Gets or sets the input message.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string InputMessage { get; set; }

Visual Basic [image] Copy Code

Property InputMessage As String

Property Value

A string value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.InputTitle Property

IValidation.InputTitle Property
[image]

Gets or sets the title of the input message.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string InputTitle { get; set; }

Visual Basic [image] Copy Code

Property InputTitle As String

Property Value

A string value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.Operator Property

IValidation.Operator Property
[image]

Gets or sets the comparison operator, for validation types that require an operator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

ComparisonOperator Operator { get; set; }

Visual Basic [image] Copy Code

Property Operator As ComparisonOperator

Property Value

A member of the ComparisonOperator enumeration.

Remarks

For additional information, see IValidation.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.OriginColumn Property

IValidation.OriginColumn Property
[image]

Gets or sets the origin column of this validation. All relative references in expressions associated with this validation are calculated based on this value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

int OriginColumn { get; set; }

Visual Basic [image] Copy Code

Property OriginColumn As Integer

Property Value

An integer value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.OriginRow Property

IValidation.OriginRow Property
[image]

Gets or sets the origin row of this validation. All relative references in expressions associated with this validation are calculated based on this value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

int OriginRow { get; set; }

Visual Basic [image] Copy Code

Property OriginRow As Integer

Property Value

An integer value.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.Second Property

IValidation.Second Property
[image]

Gets or sets the second value of the validation. This value is interpreted differently depending on the type of the validation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string Second { get; set; }

Visual Basic [image] Copy Code

Property Second As String

Property Value

A string value.

Remarks

This property can be an expression. In this case the expression is evaluated to produce a value to be used as an operand. For additional information, see IValidation.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ShowDropdownList Property

IValidation.ShowDropdownList Property
[image]

Gets or sets a value indicating whether to display drop-down list when a cell in the validated range is selected and the validation type is set to List.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool ShowDropdownList { get; set; }

Visual Basic [image] Copy Code

Property ShowDropdownList As Boolean

Property Value

true to display a drop-down list when the associated cell is selected; otherwise, false.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ShowError Property

IValidation.ShowError Property
[image]

Gets or sets a value indicating whether to display error messages when the validation fails.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool ShowError { get; set; }

Visual Basic [image] Copy Code

Property ShowError As Boolean

Property Value

true to display error message according to ErrorAction when the validation fails; otherwise, false.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.ShowInputMessage Property

IValidation.ShowInputMessage Property
[image]

Gets or sets a value indicating whether to display information message when a cell in the validated range is selected.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool ShowInputMessage { get; set; }

Visual Basic [image] Copy Code

Property ShowInputMessage As Boolean

Property Value

true to display information tooltip when an associated cell is selected; otherwise, false.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.SortListEntries Property

IValidation.SortListEntries Property
[image]

Gets or sets a value indicating whether to sort the entries in the drop-down list.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

bool SortListEntries { get; set; }

Visual Basic [image] Copy Code

Property SortListEntries As Boolean

Property Value

true to sort the entries in the drop-down list; otherwise, false.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.Type Property

IValidation.Type Property
[image]

Gets or sets the validation type.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

ValidationType Type { get; set; }

Visual Basic [image] Copy Code

Property Type As ValidationType

Property Value

A member of the ValidationType enumeration.

Remarks

For additional information, see IValidation.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.IValidation.Worksheet Property

IValidation.Worksheet Property
[image]

Gets the worksheet this validation is associated with.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

IValidation Members
IValidation Interface
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.LookIn Enumeration

LookIn Enumeration
[image]

Specifies whether a find operation should search in cell formulas or values.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum LookIn

Visual Basic [image] Copy Code

Public Enum LookIn

Members

Member name | Description
Formula | Indicates that the operation should work in cell formulas.
Value | Indicates that the operation should work in cell values.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Class

Measure Class
[image]

Represents amounts of specific units.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Measure : IEquatable<Measure>

Visual Basic [image] Copy Code

Public Class Measure
Implements IEquatable(Of Measure)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Measure

See Also

Measure Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Members

Measure Members
Constructors Properties Methods
[image]

Represents amounts of specific units.

The following tables list the members exposed by the Measure type.

Public Constructors

Name | Description
Measure | Overloaded. Initializes a new instance of the Measure class.

Public Properties

Name | Description
Amount | Gets the amount represented by the current object.
Unit | Gets the unit of measure of the current object.

Public Methods

Name | Description
ConvertTo | Converts the amount represented by the current object to the specified unit.
Equals | Overloaded. Determines whether the current object is equal to another object.
GetHashCode | Object.GetHashCode override.
Pixel | Creates a Measure instance of the MeasureUnit.Pixel unit from the specified double value.
Point | Creates a Measure instance of the MeasureUnit.Point unit from the specified double value.
ToString | Overloaded. Returns a string representation of the current object.

See Also

Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Constructor

Measure Constructor
[image]

Initializes a new instance of the Measure class.

Overload List

Name | Description
Measure (Double) | Initializes a new instance of the Measure class.
Measure (Double, MeasureUnit) | Initializes a new instance of the Measure class.
Measure (String) | Initializes a new instance of the Measure class.
Measure (String, IFormatProvider) | Initializes a new instance of the Measure class.

See Also

Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Constructor (Double)

Measure Constructor (Double)
See Also
[image]

Initializes a new instance of the Measure class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure (
double amount
)

Visual Basic [image] Copy Code

Public New ( _
amount As Double _
)

Parameters

amount

The number of pixels represented by the new object.

See Also

Measure Constructor Overload List
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Constructor (Double, MeasureUnit)

Measure Constructor (Double, MeasureUnit)
See Also
[image]

Initializes a new instance of the Measure class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure (
double amount,
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public New ( _
amount As Double, _
unit As MeasureUnit _
)

Parameters

amount

The amount represented by the new object.

unit

The measure unit of the new object.

See Also

Measure Constructor Overload List
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Constructor (String)

Measure Constructor (String)
See Also
[image]

Initializes a new instance of the Measure class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure (
string value
)

Visual Basic [image] Copy Code

Public New ( _
value As String _
)

Parameters

value

A string representing the amount and, optionally, units of measure.

See Also

Measure Constructor Overload List
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Constructor (String, IFormatProvider)

Measure Constructor (String, IFormatProvider)
See Also
[image]

Initializes a new instance of the Measure class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure (
string value,
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public New ( _
value As String, _
provider As IFormatProvider _
)

Parameters

value

A string representing the amount and, optionally, units of measure.

provider

An IFormatProvider object that is used to interpret the specified value.

See Also

Measure Constructor Overload List
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Methods

Measure Methods
[image]

Public Methods

Name | Description
ConvertTo | Converts the amount represented by the current object to the specified unit.
Equals | Overloaded. Determines whether the current object is equal to another object.
GetHashCode | Object.GetHashCode override.
Pixel | Creates a Measure instance of the MeasureUnit.Pixel unit from the specified double value.
Point | Creates a Measure instance of the MeasureUnit.Point unit from the specified double value.
ToString | Overloaded. Returns a string representation of the current object.

See Also

Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.ConvertTo Method

Measure.ConvertTo Method
[image]

Converts the amount represented by the current object to the specified unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure ConvertTo (
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function ConvertTo( _
targetUnit As MeasureUnit, _
context As Object _
) As Measure

Parameters

targetUnit

A MeasureUnit object representing the unit to convert to.

context

When converting between logical and device units this should be a Graphics or IGraphics object that provides device resolution information; otherwise this parameter is ignored.

Return Value

A new Measure object that represents the original amount in the specified unit.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Equals Method

Measure.Equals Method
[image]

Determines whether the current object is equal to another object.

Overload List

Name | Description
Measure.Equals (Measure) | Determines whether the specified measure is equal to the current measure.
Measure.Equals (Object) | Object.Equals override.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Equals Method (Measure)

Measure.Equals Method (Measure)
See Also
[image]

Determines whether the specified measure is equal to the current measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public new bool Equals (
Measure other
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
other As Measure _
) As Boolean

Parameters

other

The object to compare to this measure.

Return Value

true if the specified measure is equal to this object; otherwise, false.

See Also

Equals Method Overload List
Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Equals Method (Object)

Measure.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare to this measure.

Return Value

true if the specified object is a Measure equal to this object; otherwise, false.

See Also

Equals Method Overload List
Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.GetHashCode Method

Measure.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current object.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Pixel Method

Measure.Pixel Method
[image]

Creates a Measure instance of the MeasureUnit.Pixel unit from the specified double value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Measure Pixel (
double value
)

Visual Basic [image] Copy Code

Public Shared Function Pixel( _
value As Double _
) As Measure

Parameters

value

The amount represented by the new object.

Return Value

A Measure object representing the specified double value.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Point Method

Measure.Point Method
[image]

Creates a Measure instance of the MeasureUnit.Point unit from the specified double value.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static Measure Point (
double value
)

Visual Basic [image] Copy Code

Public Shared Function Point( _
value As Double _
) As Measure

Parameters

value

The amount represented by the new object.

Return Value

A Measure object representing the specified double value.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.ToString Method

Measure.ToString Method
[image]

Returns a string representation of the current object.

Overload List

Name | Description
Measure.ToString () | Object.ToString override.
Measure.ToString (IFormatProvider) | Returns a string representation of the current measure.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.ToString Method ()

Measure.ToString Method ()
See Also
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of the current object.

See Also

ToString Method Overload List
Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.ToString Method (IFormatProvider)

Measure.ToString Method (IFormatProvider)
See Also
[image]

Returns a string representation of the current measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider

An IFormatProvider object that is used to format the amount.

Return Value

The string representation of the current object.

See Also

ToString Method Overload List
Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure Properties

Measure Properties
[image]

Public Properties

Name | Description
Amount | Gets the amount represented by the current object.
Unit | Gets the unit of measure of the current object.

See Also

Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Amount Property

Measure.Amount Property
[image]

Gets the amount represented by the current object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double Amount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Amount As Double

Property Value

A double value.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Measure.Unit Property

Measure.Unit Property
[image]

Gets the unit of measure of the current object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit Unit { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Unit As MeasureUnit

Property Value

An instance of the MeasureUnit class.

See Also

Measure Members
Measure Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Class

MeasureUnit Class
[image]

Specifies units of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class MeasureUnit

Visual Basic [image] Copy Code

Public Class MeasureUnit

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.MeasureUnit

See Also

MeasureUnit Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Members

MeasureUnit Members
Constructors Fields Properties Methods
[image]

Specifies units of measure.

The following tables list the members exposed by the MeasureUnit type.

Public Constructors

Name | Description
MeasureUnit | Overloaded. Initializes a new instance of the MeasureUnit class.

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Pixel | Specifies device-independent pixels (1/96 inch) as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.

Public Properties

Name | Description
Id | Gets the unit identifier.
Name | Gets the name of the unit.

Public Methods

Name | Description
Convert | Overloaded. Converts a value from this unit to another unit.
Equals | Overloaded. Determines whether the current object is equal to another object.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Fields

MeasureUnit Fields
[image]

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Pixel | Specifies device-independent pixels (1/96 inch) as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.

See Also

MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Centimeter Field

MeasureUnit.Centimeter Field
[image]

Specifies centimeters as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Centimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Centimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Document Field

MeasureUnit.Document Field
[image]

Specifies document units (1/300 inch) as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Document

Visual Basic [image] Copy Code

Public Shared ReadOnly Document As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Inch Field

MeasureUnit.Inch Field
[image]

Specifies inches as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Millimeter Field

MeasureUnit.Millimeter Field
[image]

Specifies millimeters as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Pixel Field

MeasureUnit.Pixel Field
[image]

Specifies device-independent pixels (1/96 inch) as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Point Field

MeasureUnit.Point Field
[image]

Specifies printer's points (1/72 inch) as the unit of measure.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Constructor

MeasureUnit Constructor
[image]

Initializes a new instance of the MeasureUnit class.

Overload List

Name | Description
MeasureUnit (String, Double) | Initializes a new instance of the MeasureUnit class with the specified amount.
MeasureUnit (String, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified amount.
MeasureUnit (String, MeasureUnit, Double) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.
MeasureUnit (String, MeasureUnit, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

See Also

MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Constructor (String, Double)

MeasureUnit Constructor (String, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified amount.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Constructor (String, Double, Int32)

MeasureUnit Constructor (String, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified amount.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Constructor (String, MeasureUnit, Double)

MeasureUnit Constructor (String, MeasureUnit, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Constructor (String, MeasureUnit, Double, Int32)

MeasureUnit Constructor (String, MeasureUnit, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Methods

MeasureUnit Methods
[image]

Public Methods

Name | Description
Convert | Overloaded. Converts a value from this unit to another unit.
Equals | Overloaded. Determines whether the current object is equal to another object.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Convert Method

MeasureUnit.Convert Method
[image]

Converts a value from this unit to another unit.

Overload List

Name | Description
MeasureUnit.Convert (Double, MeasureUnit, Object) | Converts the specified value from this unit to the specified unit.
MeasureUnit.Convert (Point, MeasureUnit, Object) | Converts the specified point from this unit to the specified unit.
MeasureUnit.Convert (Rect, MeasureUnit, Object) | Converts the specified rectangle from this unit to the specified unit.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Convert Method (Double, MeasureUnit, Object)

MeasureUnit.Convert Method (Double, MeasureUnit, Object)
See Also
[image]

Converts the specified value from this unit to the specified unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double Convert (
double value,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Double, _
targetUnit As MeasureUnit, _
context As Object _
) As Double

Parameters

value

The value to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units.

Return Value

The converted value.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Convert Method (Point, MeasureUnit, Object)

MeasureUnit.Convert Method (Point, MeasureUnit, Object)
See Also
[image]

Converts the specified point from this unit to the specified unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Point Convert (
Point p,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
p As Point, _
targetUnit As MeasureUnit, _
context As Object _
) As Point

Parameters

p

The point to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units.

Return Value

The converted point.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, context is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Convert Method (Rect, MeasureUnit, Object)

MeasureUnit.Convert Method (Rect, MeasureUnit, Object)
See Also
[image]

Converts the specified rectangle from this unit to the specified unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Rect Convert (
Rect r,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
r As Rect, _
targetUnit As MeasureUnit, _
context As Object _
) As Rect

Parameters

r

The rectangle to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units.

Return Value

The converted rectangle.

Remarks

If the target represents logical unit (such as mm, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, context is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Equals Method

MeasureUnit.Equals Method
[image]

Determines whether the current object is equal to another object.

Overload List

Name | Description
MeasureUnit.Equals (MeasureUnit) | Determines whether the specified measure unit is equal to the current measure unit.
MeasureUnit.Equals (Object) | Object.Equals override.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Equals Method (MeasureUnit)

MeasureUnit.Equals Method (MeasureUnit)
See Also
[image]

Determines whether the specified measure unit is equal to the current measure unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public new bool Equals (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
unit As MeasureUnit _
) As Boolean

Parameters

unit

The object to compare to this measure unit.

Return Value

true if the specified measure unit is equal to this object; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Equals Method (Object)

MeasureUnit.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current unit.

Return Value

true if the specified object is the same as or is equal to the current unit; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.FromId Method

MeasureUnit.FromId Method
[image]

Returns a MeasureUnit from its integer identifier.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static MeasureUnit FromId (
int id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer _
) As MeasureUnit

Parameters

id

The identifier of one of the built-in measure units.

Return Value

The built-in MeasureUnit corresponding to the specified identifier.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.GetHashCode Method

MeasureUnit.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current unit.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.ToString Method

MeasureUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The name of the unit.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit Properties

MeasureUnit Properties
[image]

Public Properties

Name | Description
Id | Gets the unit identifier.
Name | Gets the name of the unit.

See Also

MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Id Property

MeasureUnit.Id Property
[image]

Gets the unit identifier.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

An integer value.

Remarks

This property returns -1 for custom MeasureUnit objects.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MeasureUnit.Name Property

MeasureUnit.Name Property
[image]

Gets the name of the unit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value.

See Also

MeasureUnit Members
MeasureUnit Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MergedCellsCollection Class

MergedCellsCollection Class
[image]

Represents a specialized collection for merged cells in a worksheet, each merged cell is represented by a CellRange object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class MergedCellsCollection : UndoableCollection<CellRange>

Visual Basic [image] Copy Code

Public Class MergedCellsCollection
Inherits UndoableCollection(Of CellRange)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(CellRange)
MindFusion.Spreadsheet.Wpf.MergedCellsCollection

See Also

MergedCellsCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MergedCellsCollection Members

MergedCellsCollection Members
Properties Methods Events
[image]

Represents a specialized collection for merged cells in a worksheet, each merged cell is represented by a CellRange object.

The following tables list the members exposed by the MergedCellsCollection type.

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item at the specified index. (Inherited from UndoableCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

Public Methods

Name | Description
Clear | Clears the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UndoableCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

MergedCellsCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MergedCellsCollection Methods

MergedCellsCollection Methods
[image]

Public Methods

Name | Description
Clear | Clears the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UndoableCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

See Also

MergedCellsCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MergedCellsCollection.Clear Method

MergedCellsCollection.Clear Method
[image]

Clears the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

MergedCellsCollection Members
MergedCellsCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MergedCellsCollection Events

MergedCellsCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

MergedCellsCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).CollectionChanged Event

UndoableCollection(T).CollectionChanged Event
[image]

Raised when the collection is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NotifyCollectionChangedEventArgs> CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As EventHandler(Of NotifyCollectionChangedEventArgs)

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T) Class

MoveItemCommand(T) Class
Remarks See Also
[image]

Implements moving of items within a collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class MoveItemCommand<T> : Command

Visual Basic [image] Copy Code

Public Class MoveItemCommand(Of T)
Inherits Command

Remarks

There is usually no need to instantiate this class directly. Instances of this command are automatically created and executed when an item is moved in an UndoableCollection.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.MoveItemCommand(T)

See Also

MoveItemCommand(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T) Members

MoveItemCommand(T) Members
Constructors Properties Methods
[image]

Implements moving of items within a collection.

The following tables list the members exposed by the MoveItemCommand(T) type.

Public Constructors

Name | Description
MoveItemCommand | Initializes a new instance of the MoveItemCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T) Constructor

MoveItemCommand(T) Constructor
[image]

Initializes a new instance of the MoveItemCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MoveItemCommand<T> (
Workbook workbook,
UndoableCollection<T> collection,
int fromIndex,
int toIndex,
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
workbook As Workbook, _
collection As UndoableCollection(Of T), _
fromIndex As Integer, _
toIndex As Integer, _
item As T _
)

Parameters

workbook

The Workbook modified by this command.

collection

The collection in which the item is moved.

fromIndex

The zero-based of the item.

toIndex

The zero-based index where the item should be moved.

item

The item that should be moved.

See Also

MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T) Methods

MoveItemCommand(T) Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T).Execute Method

MoveItemCommand(T).Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

See Also

MoveItemCommand(T) Members
MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T).Redo Method

MoveItemCommand(T).Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

MoveItemCommand(T) Members
MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.MoveItemCommand(T).Undo Method

MoveItemCommand(T).Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

MoveItemCommand(T) Members
MoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T) Class

NamedCollection(T) Class
[image]

Represents a collection of objects that can be manipulated by name. The objects in the collection are required to have unique names.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class NamedCollection<T> : UndoableCollection<T> where T : IHasName, INotifyPropertyValueChanged

Visual Basic [image] Copy Code

Public Class NamedCollection(Of T As IHasName, INotifyPropertyValueChanged)
Inherits UndoableCollection(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(T)
MindFusion.Spreadsheet.Wpf.NamedCollection(T)
MindFusion.Spreadsheet.Wpf.NamedRangeCollection
MindFusion.Spreadsheet.Wpf.WorksheetCollection

See Also

NamedCollection(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T) Members

NamedCollection(T) Members
Properties Methods Events
[image]

Represents a collection of objects that can be manipulated by name. The objects in the collection are required to have unique names.

The following tables list the members exposed by the NamedCollection(T) type.

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item at the specified index. (Inherited from UndoableCollection.)
Item | Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

Public Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
Contains | Determines whether an element with the specified name is in the collection.
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override.
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T) Methods

NamedCollection(T) Methods
[image]

Public Methods

Name | Description
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
Contains | Determines whether an element with the specified name is in the collection.
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override.
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

See Also

NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T).Contains Method

NamedCollection(T).Contains Method
[image]

Determines whether an element with the specified name is in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
string name
)

Visual Basic [image] Copy Code

Public Function Contains( _
name As String _
) As Boolean

Parameters

name

The name of the item to locate in the collection.

Return Value

true if item with the specified name is found in the collection; otherwise, false.

See Also

NamedCollection(T) Members
NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T).OnCollectionChanged Method

NamedCollection(T).OnCollectionChanged Method
[image]

UndoableCollection.OnCollectionChanged override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

NamedCollection(T) Members
NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T) Properties

NamedCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item at the specified index. (Inherited from UndoableCollection.)
Item | Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

See Also

NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T).Item Property

NamedCollection(T).Item Property
[image]

Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public T Item [
string name
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
name As String _
) As T

Parameters

name

The name of the item to get.

Property Value

The item with the specified name.

See Also

NamedCollection(T) Members
NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedCollection(T) Events

NamedCollection(T) Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

NamedCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Class

NamedRange Class
[image]

Represents a named range of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class NamedRange : INotifyPropertyValueChanged, IHasName

Visual Basic [image] Copy Code

Public Class NamedRange
Implements INotifyPropertyValueChanged, IHasName

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.NamedRange

See Also

NamedRange Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Members

NamedRange Members
Constructors Properties Methods Events
[image]

Represents a named range of cells.

The following tables list the members exposed by the NamedRange type.

Public Constructors

Name | Description
NamedRange | Overloaded. Initializes a new instance of the NamedRange class.

Public Properties

Name | Description
CellRange | Gets or sets the cell or range of cells associated with this named range.
Name | Gets or sets the name of the named range.
WorksheetName | Gets the name of the worksheet represented by this named range.

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event.

Public Events

Name | Description
PropertyValueChanged | Raised when a property of this object is changed.

See Also

NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Constructor

NamedRange Constructor
[image]

Initializes a new instance of the NamedRange class.

Overload List

Name | Description
NamedRange (String, String) | Initializes a new instance of the NamedRange class.
NamedRange (String, String, Int32, Int32, Int32, Int32) | Initializes a new instance of the NamedRange class.

See Also

NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Constructor (String, String)

NamedRange Constructor (String, String)
See Also
[image]

Initializes a new instance of the NamedRange class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NamedRange (
string name,
string cellRange
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
cellRange As String _
)

Parameters

name

The initial name of the range.

cellRange

The initial cell range.

See Also

NamedRange Constructor Overload List
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Constructor (String, String, Int32, Int32, Int32, Int32)

NamedRange Constructor (String, String, Int32, Int32, Int32, Int32)
See Also
[image]

Initializes a new instance of the NamedRange class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NamedRange (
string name,
string sheetName,
int topLeftColumn,
int topLeftRow,
int bottomRightColumn,
int bottomRightRow
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
sheetName As String, _
topLeftColumn As Integer, _
topLeftRow As Integer, _
bottomRightColumn As Integer, _
bottomRightRow As Integer _
)

Parameters

name

The initial name of the range.

sheetName

The name of the sheet of the initial cell range.

topLeftColumn

The column of the top-left cell of the initial range.

topLeftRow

The row of the top-left cell of the initial range.

bottomRightColumn

The column of the bottom-right cell of the initial range.

bottomRightRow

The row of the bottom-right cell of the initial range.

See Also

NamedRange Constructor Overload List
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Methods

NamedRange Methods
[image]

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event.

See Also

NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange.OnPropertyValueChanged Method

NamedRange.OnPropertyValueChanged Method
[image]

Raises the PropertyValueChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyValueChanged (
PropertyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyValueChanged( _
e As PropertyEventArgs _
)

Parameters

e

An object providing the event data.

See Also

NamedRange Members
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Properties

NamedRange Properties
[image]

Public Properties

Name | Description
CellRange | Gets or sets the cell or range of cells associated with this named range.
Name | Gets or sets the name of the named range.
WorksheetName | Gets the name of the worksheet represented by this named range.

See Also

NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange.CellRange Property

NamedRange.CellRange Property
[image]

Gets or sets the cell or range of cells associated with this named range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string CellRange { get; set; }

Visual Basic [image] Copy Code

Public Property CellRange As String

Property Value

A string value, in the format Sheet1!A1:B2 or Sheet1!R1C1:R2C2.

Remarks

Specifying an invalid or incomplete cell range will throw an exception. A cell range without sheet name is considered incomplete.

See Also

NamedRange Members
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange.Name Property

NamedRange.Name Property
[image]

Gets or sets the name of the named range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value.

Remarks

The name of a named range must be unique (ignoring case) amongst all named ranges in a Workbook. It must not be a valid cell or cell range reference (for example, A1). It needs to be a proper identifier, that is, it must start with a letter and contain only letters, numbers and underscore characters. Lastly, the name must not coincide with the built-in identifiers 'true' and 'false'. If any of these requirements are violated, an exception will be thrown.

See Also

NamedRange Members
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange.WorksheetName Property

NamedRange.WorksheetName Property
[image]

Gets the name of the worksheet represented by this named range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string WorksheetName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property WorksheetName As String

Property Value

A string value.

See Also

NamedRange Members
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange Events

NamedRange Events
[image]

Public Events

Name | Description
PropertyValueChanged | Raised when a property of this object is changed.

See Also

NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRange.PropertyValueChanged Event

NamedRange.PropertyValueChanged Event
[image]

Raised when a property of this object is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Public Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

Event Data

PropertyValueChanged event handlers receive an argument of type PropertyEventArgs.

See Also

NamedRange Members
NamedRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection Class

NamedRangeCollection Class
[image]

Represents a specialized collection of NamedRange objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class NamedRangeCollection : NamedCollection<NamedRange>, IList<NamedRange>, ICollection<NamedRange>

Visual Basic [image] Copy Code

Public NotInheritable Class NamedRangeCollection
Inherits NamedCollection(Of NamedRange)
Implements IList(Of NamedRange), ICollection(Of NamedRange)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(NamedRange)
MindFusion.Spreadsheet.Wpf.NamedCollection(NamedRange)
MindFusion.Spreadsheet.Wpf.NamedRangeCollection

See Also

NamedRangeCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection Members

NamedRangeCollection Members
Properties Methods Events
[image]

Represents a specialized collection of NamedRange objects.

The following tables list the members exposed by the NamedRangeCollection type.

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsReadOnly | Gets a value indicating whether the collection is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect. (Inherited from NamedCollection.)
Item | Gets or sets the element at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

Public Methods

Name | Description
Add | Adds the specified element to the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
Contains | Determines whether an element with the specified name is in the collection. (Inherited from NamedCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of the collection to an array, starting at the specified index.
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Insert | Inserts the specified element at the specified index in the collection.
Remove | Removes the specified element from the collection.
RemoveAt | Removes the element at the specified index.

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override. (Inherited from NamedCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection Methods

NamedRangeCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified element to the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
Contains | Determines whether an element with the specified name is in the collection. (Inherited from NamedCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of the collection to an array, starting at the specified index.
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Insert | Inserts the specified element at the specified index in the collection.
Remove | Removes the specified element from the collection.
RemoveAt | Removes the element at the specified index.

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override. (Inherited from NamedCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

See Also

NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.Add Method

NamedRangeCollection.Add Method
[image]

Adds the specified element to the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Add (
NamedRange item
)

Visual Basic [image] Copy Code

Public Sub Add( _
item As NamedRange _
)

Parameters

item

The element to add to the collection.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.Clear Method

NamedRangeCollection.Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.CopyTo Method

NamedRangeCollection.CopyTo Method
[image]

Copies the elements of the collection to an array, starting at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public new void CopyTo (
NamedRange[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Shadows Sub CopyTo( _
array() As NamedRange, _
arrayIndex As Integer _
)

Parameters

array

A one-dimensional array that is the destination of the copied elements.

arrayIndex

The zero-based index in array at which copying begins.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.Insert Method

NamedRangeCollection.Insert Method
[image]

Inserts the specified element at the specified index in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
NamedRange item
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
item As NamedRange _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The element to insert into the collection.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.Remove Method

NamedRangeCollection.Remove Method
[image]

Removes the specified element from the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Remove (
NamedRange item
)

Visual Basic [image] Copy Code

Public Function Remove( _
item As NamedRange _
) As Boolean

Parameters

item

The element to remove from the collection.

Return Value

true if item was successfully removed from the collection; otherwise, false.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.RemoveAt Method

NamedRangeCollection.RemoveAt Method
[image]

Removes the element at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection Properties

NamedRangeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsReadOnly | Gets a value indicating whether the collection is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect. (Inherited from NamedCollection.)
Item | Gets or sets the element at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

See Also

NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.IsReadOnly Property

NamedRangeCollection.IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

A boolean value. Always returns false.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection.Item Property

NamedRangeCollection.Item Property
[image]

Gets or sets the element at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public new NamedRange Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Item( _
index As Integer _
) As NamedRange

Parameters

index

The zero-based index of the element to get or set.

Property Value

The element at the specified index.

See Also

NamedRangeCollection Members
NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NamedRangeCollection Events

NamedRangeCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

NamedRangeCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedAction Enumeration

NotifyCollectionChangedAction Enumeration
[image]

Describes the action that caused a CollectionChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum NotifyCollectionChangedAction

Visual Basic [image] Copy Code

Public Enum NotifyCollectionChangedAction

Members

Member name | Description
Add | One or more items were added to the collection.
Move | One or more items were moved within the collection.
Remove | One or more items were removed from the collection.
Replace | One or more items were replaced in the collection.
Reset | The content of the collection changed dramatically.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Class

NotifyCollectionChangedEventArgs Class
[image]

Provides data for the CollectionChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class NotifyCollectionChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NotifyCollectionChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs

See Also

NotifyCollectionChangedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Members

NotifyCollectionChangedEventArgs Members
Constructors Properties
[image]

Provides data for the CollectionChanged event.

The following tables list the members exposed by the NotifyCollectionChangedEventArgs type.

Public Constructors

Name | Description
NotifyCollectionChangedEventArgs | Overloaded.

Public Properties

Name | Description
Action | Gets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
NewStartingIndex | Gets the index at which the change occurred.
OldItems | Gets the list of items affected by a Replace, Remove, or Move action.
OldStartingIndex | Gets the index at which a Move, Remove, or Replace action occurred.

See Also

NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor

NotifyCollectionChangedEventArgs Constructor
[image]

Overload List

Name | Description
NotifyCollectionChangedEventArgs (NotifyCollectionChangedAction, IList) | Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a Reset change.
NotifyCollectionChangedEventArgs (NotifyCollectionChangedAction, IList, Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a multi-item change.
NotifyCollectionChangedEventArgs (NotifyCollectionChangedAction, Object, Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a one-item change.
NotifyCollectionChangedEventArgs (NotifyCollectionChangedAction, Object, Int32, Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a one-item Move change.
NotifyCollectionChangedEventArgs (NotifyCollectionChangedAction, Object, Object, Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a Replace change.

See Also

NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, IList)

NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, IList)
See Also
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a Reset change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs (
NotifyCollectionChangedAction action,
IList changedItems
)

Visual Basic [image] Copy Code

Public New ( _
action As NotifyCollectionChangedAction, _
changedItems As IList _
)

Parameters

action

The action that caused the event. This can be set to Reset.

changedItems

The items that are affected by the change.

See Also

NotifyCollectionChangedEventArgs Constructor Overload List
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, IList, Int32)

NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, IList, Int32)
See Also
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a multi-item change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs (
NotifyCollectionChangedAction action,
IList changedItems,
int index
)

Visual Basic [image] Copy Code

Public New ( _
action As NotifyCollectionChangedAction, _
changedItems As IList, _
index As Integer _
)

Parameters

action

The action that caused the event. This can be set to Add or Remove.

changedItems

The items that were affected by the change.

index

The index where the change occurred.

See Also

NotifyCollectionChangedEventArgs Constructor Overload List
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Int32)

NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Int32)
See Also
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a one-item change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs (
NotifyCollectionChangedAction action,
Object changedItem,
int index
)

Visual Basic [image] Copy Code

Public New ( _
action As NotifyCollectionChangedAction, _
changedItem As Object, _
index As Integer _
)

Parameters

action

The action that caused the event. This can be set to Add or Remove.

changedItem

The item that is affected by the change.

index

The index where the change occurred.

See Also

NotifyCollectionChangedEventArgs Constructor Overload List
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Int32, Int32)

NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Int32, Int32)
See Also
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a one-item Move change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs (
NotifyCollectionChangedAction action,
Object changedItem,
int index,
int oldIndex
)

Visual Basic [image] Copy Code

Public New ( _
action As NotifyCollectionChangedAction, _
changedItem As Object, _
index As Integer, _
oldIndex As Integer _
)

Parameters

action

The action that caused the event. This can only be set to Move.

changedItem

The item affected by the change.

index

The item affected by the change.

oldIndex

The old index for the changed item.

See Also

NotifyCollectionChangedEventArgs Constructor Overload List
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Object, Int32)

NotifyCollectionChangedEventArgs Constructor (NotifyCollectionChangedAction, Object, Object, Int32)
See Also
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class that describes a Replace change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs (
NotifyCollectionChangedAction action,
Object newItem,
Object oldItem,
int index
)

Visual Basic [image] Copy Code

Public New ( _
action As NotifyCollectionChangedAction, _
newItem As Object, _
oldItem As Object, _
index As Integer _
)

Parameters

action

The action that caused the event. This can only be set to Replace.

newItem

The new item.

oldItem

The old item.

index

The index where the change occurred.

See Also

NotifyCollectionChangedEventArgs Constructor Overload List
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs Properties

NotifyCollectionChangedEventArgs Properties
[image]

Public Properties

Name | Description
Action | Gets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
NewStartingIndex | Gets the index at which the change occurred.
OldItems | Gets the list of items affected by a Replace, Remove, or Move action.
OldStartingIndex | Gets the index at which a Move, Remove, or Replace action occurred.

See Also

NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs.Action Property

NotifyCollectionChangedEventArgs.Action Property
[image]

Gets the action that caused the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NotifyCollectionChangedAction Action { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Action As NotifyCollectionChangedAction

Property Value

A member of the NotifyCollectionChangedAction enumeration.

See Also

NotifyCollectionChangedEventArgs Members
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs.NewItems Property

NotifyCollectionChangedEventArgs.NewItems Property
[image]

Gets the list of new items involved in the change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IList NewItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewItems As IList

Property Value

A list of objects, or null (Nothing in Visual Basic) if there are no relevant items.

See Also

NotifyCollectionChangedEventArgs Members
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs.NewStartingIndex Property

NotifyCollectionChangedEventArgs.NewStartingIndex Property
[image]

Gets the index at which the change occurred.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int NewStartingIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewStartingIndex As Integer

Property Value

A zero-based integer value.

See Also

NotifyCollectionChangedEventArgs Members
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs.OldItems Property

NotifyCollectionChangedEventArgs.OldItems Property
[image]

Gets the list of items affected by a Replace, Remove, or Move action.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IList OldItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldItems As IList

Property Value

A list of objects, or null (Nothing in Visual Basic) if there are no relevant items.

See Also

NotifyCollectionChangedEventArgs Members
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NotifyCollectionChangedEventArgs.OldStartingIndex Property

NotifyCollectionChangedEventArgs.OldStartingIndex Property
[image]

Gets the index at which a Move, Remove, or Replace action occurred.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int OldStartingIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldStartingIndex As Integer

Property Value

A zero-based integer value.

See Also

NotifyCollectionChangedEventArgs Members
NotifyCollectionChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo Class

NumericFormatInfo Class
[image]

Represents a numeric format within a workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class NumericFormatInfo

Visual Basic [image] Copy Code

Public Class NumericFormatInfo

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.NumericFormatInfo

See Also

NumericFormatInfo Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo Members

NumericFormatInfo Members
Constructors Properties Methods
[image]

Represents a numeric format within a workbook.

The following tables list the members exposed by the NumericFormatInfo type.

Public Constructors

Name | Description
NumericFormatInfo | Initializes a new instance of the NumericFormatInfo class.

Public Properties

Name | Description
Category | Gets the category this numeric format falls into.
Format | Gets the string representation of this numeric format.

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo Constructor

NumericFormatInfo Constructor
[image]

Initializes a new instance of the NumericFormatInfo class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NumericFormatInfo (
string format
)

Visual Basic [image] Copy Code

Public New ( _
format As String _
)

Parameters

format

The string representation of the numeric format.

See Also

NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo Methods

NumericFormatInfo Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo.Equals Method

NumericFormatInfo.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare to this one.

Return Value

true is the objects are equal; otherwise, false.

See Also

NumericFormatInfo Members
NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo.GetHashCode Method

NumericFormatInfo.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current object.

See Also

NumericFormatInfo Members
NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo.ToString Method

NumericFormatInfo.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of the current object.

See Also

NumericFormatInfo Members
NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo Properties

NumericFormatInfo Properties
[image]

Public Properties

Name | Description
Category | Gets the category this numeric format falls into.
Format | Gets the string representation of this numeric format.

See Also

NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo.Category Property

NumericFormatInfo.Category Property
[image]

Gets the category this numeric format falls into.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Category { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Category As String

Property Value

A string value.

See Also

NumericFormatInfo Members
NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.NumericFormatInfo.Format Property

NumericFormatInfo.Format Property
[image]

Gets the string representation of this numeric format.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Format { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Format As String

Property Value

A string value.

See Also

NumericFormatInfo Members
NumericFormatInfo Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectAnchor Enumeration

ObjectAnchor Enumeration
[image]

Specifies the anchor of a worksheet object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ObjectAnchor

Visual Basic [image] Copy Code

Public Enum ObjectAnchor

Members

Member name | Description
ToCell | Indicates that a worksheet object is anchored to a specific cell.
ToPage | Indicates that a worksheet object is anchored to its page.

Remarks

Members of this enumeration can be assigned to the Anchor property of the InteractiveObject class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectAnchorPosition Enumeration

ObjectAnchorPosition Enumeration
[image]

Specifies the anchor position of a worksheet object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ObjectAnchorPosition

Visual Basic [image] Copy Code

Public Enum ObjectAnchorPosition

Members

Member name | Description
BottomLeft | Indicates that a worksheet object is positioned relative to the bottom-left corner of the anchor.
BottomRight | Indicates that a worksheet object is positioned relative to the bottom-right corner of the anchor.
TopLeft | Indicates that a worksheet object is positioned relative to the top-left corner of the anchor.
TopRight | Indicates that a worksheet object is positioned relative to the top-right corner of the anchor.

Remarks

Members of this enumeration can be assigned to the AnchorPosition property of the InteractiveObject class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectEventArgs Class

ObjectEventArgs Class
[image]

Provides data for events related to interactive objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObjectEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ObjectEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ObjectEventArgs
MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs
MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs

See Also

ObjectEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectEventArgs Members

ObjectEventArgs Members
Properties
[image]

Provides data for events related to interactive objects.

The following tables list the members exposed by the ObjectEventArgs type.

Public Properties

Name | Description
Object | Gets the object for which the event was raised.

See Also

ObjectEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectEventArgs Properties

ObjectEventArgs Properties
[image]

Public Properties

Name | Description
Object | Gets the object for which the event was raised.

See Also

ObjectEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectEventArgs.Object Property

ObjectEventArgs.Object Property
[image]

Gets the object for which the event was raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public InteractiveObject Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As InteractiveObject

Property Value

An instance of the InteractiveObject class.

See Also

ObjectEventArgs Members
ObjectEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs Class

ObjectInteractionEventArgs Class
[image]

Provides data for events related to interactive objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObjectInteractionEventArgs : ObjectEventArgs

Visual Basic [image] Copy Code

Public Class ObjectInteractionEventArgs
Inherits ObjectEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ObjectEventArgs
MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs
MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs

See Also

ObjectInteractionEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs Members

ObjectInteractionEventArgs Members
Properties
[image]

Provides data for events related to interactive objects.

The following tables list the members exposed by the ObjectInteractionEventArgs type.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

See Also

ObjectInteractionEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs Properties

ObjectInteractionEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
MouseButton | Gets which mouse button has been pressed.
MousePosition | Gets or sets the current mouse pointer position.
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

See Also

ObjectInteractionEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs.AdjustmentHandle Property

ObjectInteractionEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AdjustmentHandles AdjustmentHandle { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration.

See Also

ObjectInteractionEventArgs Members
ObjectInteractionEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs.MouseButton Property

ObjectInteractionEventArgs.MouseButton Property
[image]

Gets which mouse button has been pressed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MouseButton MouseButton { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseButton As MouseButton

Property Value

A member of the WPF MouseButton enumeration.

See Also

ObjectInteractionEventArgs Members
ObjectInteractionEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs.MousePosition Property

ObjectInteractionEventArgs.MousePosition Property
[image]

Gets or sets the current mouse pointer position.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

An instance of the WPF Point structure.

See Also

ObjectInteractionEventArgs Members
ObjectInteractionEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs Class

ObjectInteractionValidationEventArgs Class
[image]

Contains the arguments passed to handlers of object validation events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObjectInteractionValidationEventArgs : ObjectInteractionEventArgs

Visual Basic [image] Copy Code

Public Class ObjectInteractionValidationEventArgs
Inherits ObjectInteractionEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ObjectEventArgs
MindFusion.Spreadsheet.Wpf.ObjectInteractionEventArgs
MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs

See Also

ObjectInteractionValidationEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs Members

ObjectInteractionValidationEventArgs Members
Properties Methods
[image]

Contains the arguments passed to handlers of object validation events.

The following tables list the members exposed by the ObjectInteractionValidationEventArgs type.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from ObjectInteractionEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from ObjectInteractionEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from ObjectInteractionEventArgs.)
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the modification of the object.

See Also

ObjectInteractionValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs Methods

ObjectInteractionValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the modification of the object.

See Also

ObjectInteractionValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs.CancelDrag Method

ObjectInteractionValidationEventArgs.CancelDrag Method
[image]

Cancels the modification of the object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

ObjectInteractionValidationEventArgs Members
ObjectInteractionValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs Properties

ObjectInteractionValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from ObjectInteractionEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
MouseButton | Gets which mouse button has been pressed. (Inherited from ObjectInteractionEventArgs.)
MousePosition | Gets or sets the current mouse pointer position. (Inherited from ObjectInteractionEventArgs.)
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

See Also

ObjectInteractionValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectInteractionValidationEventArgs.Cancel Property

ObjectInteractionValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to indicate that the action cannot be completed; otherwise, false.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

ObjectInteractionValidationEventArgs Members
ObjectInteractionValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs Class

ObjectMouseEventArgs Class
[image]

Contains the arguments passed to object-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObjectMouseEventArgs : BaseMouseEventArgs

Visual Basic [image] Copy Code

Public Class ObjectMouseEventArgs
Inherits BaseMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs
MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs

See Also

ObjectMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs Members

ObjectMouseEventArgs Members
Properties
[image]

Contains the arguments passed to object-related mouse events.

The following tables list the members exposed by the ObjectMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Object | Gets the object for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

ObjectMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs Properties

ObjectMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Object | Gets the object for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

ObjectMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectMouseEventArgs.Object Property

ObjectMouseEventArgs.Object Property
[image]

Gets the object for which the event was raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public InteractiveObject Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As InteractiveObject

Property Value

An instance of the InteractiveObject class.

See Also

ObjectMouseEventArgs Members
ObjectMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs Class

ObjectValidationEventArgs Class
[image]

Contains the arguments passed to handlers of object validation events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObjectValidationEventArgs : ObjectEventArgs

Visual Basic [image] Copy Code

Public Class ObjectValidationEventArgs
Inherits ObjectEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ObjectEventArgs
MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs

See Also

ObjectValidationEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs Members

ObjectValidationEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of object validation events.

The following tables list the members exposed by the ObjectValidationEventArgs type.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

See Also

ObjectValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs Properties

ObjectValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Object | Gets the object for which the event was raised. (Inherited from ObjectEventArgs.)

See Also

ObjectValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObjectValidationEventArgs.Cancel Property

ObjectValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; otherwise, false. The default is false.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

ObjectValidationEventArgs Members
ObjectValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Class

ObservableCollection(T) Class
[image]

Represents a strongly-typed collection that provides notifications when items get added, removed, or when the whole list is refreshed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ObservableCollection<T> : Collection<T>, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Class ObservableCollection(Of T)
Inherits Collection(Of T)
Implements INotifyCollectionChanged

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
MindFusion.Spreadsheet.Wpf.ObservableCollection(T)

See Also

ObservableCollection(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Members

ObservableCollection(T) Members
Constructors Methods Events
[image]

Represents a strongly-typed collection that provides notifications when items get added, removed, or when the whole list is refreshed.

The following tables list the members exposed by the ObservableCollection(T) type.

Public Constructors

Name | Description
ObservableCollection | Overloaded. Initializes a new instance of the ObservableCollection<T> class.

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection.ClearItems override.
InsertItem | Collection.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection.RemoveItem override.
SetItem | Collection.SetItem override.

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Constructor

ObservableCollection(T) Constructor
[image]

Initializes a new instance of the ObservableCollection<T> class.

Overload List

Name | Description
ObservableCollection(T) () | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection(T) (ICollection(T)) | Initializes a new instance of the ObservableCollection<T> class.

See Also

ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Constructor ()

ObservableCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Constructor (ICollection(T))

ObservableCollection(T) Constructor (ICollection(T))
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<T> (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
items As ICollection(Of T) _
)

Parameters

items

The initial content of the collection.

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Methods

ObservableCollection(T) Methods
[image]

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection.ClearItems override.
InsertItem | Collection.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection.RemoveItem override.
SetItem | Collection.SetItem override.

See Also

ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).AddRange Method

ObservableCollection(T).AddRange Method
[image]

Adds the specified objects to the end of the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void AddRange (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
items As ICollection(Of T) _
)

Parameters

items

The objects to add.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).ClearItems Method

ObservableCollection(T).ClearItems Method
[image]

Collection.ClearItems override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void ClearItems ()

Visual Basic [image] Copy Code

Protected Overrides Sub ClearItems ()

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).InsertItem Method

ObservableCollection(T).InsertItem Method
[image]

Collection.InsertItem override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void InsertItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub InsertItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert. The value can be null for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).OnCollectionChanged Method

ObservableCollection(T).OnCollectionChanged Method
[image]

Raises the CollectionChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).RemoveItem Method

ObservableCollection(T).RemoveItem Method
[image]

Collection.RemoveItem override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void RemoveItem (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Sub RemoveItem( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).SetItem Method

ObservableCollection(T).SetItem Method
[image]

Collection.SetItem override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void SetItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index of the element to replace.

item

The new value for the element at the specified index. The value can be null (Nothing in Visual Basic) for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T) Events

ObservableCollection(T) Events
[image]

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ObservableCollection(T).CollectionChanged Event

ObservableCollection(T).CollectionChanged Event
[image]

Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<NotifyCollectionChangedEventArgs> CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As EventHandler(Of NotifyCollectionChangedEventArgs)

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.OutlineEventArgs Class

OutlineEventArgs Class
[image]

Contains the arguments passed to the RowOutlineLevelToggled and ColumnOutlineLevelToggled event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class OutlineEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class OutlineEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.OutlineEventArgs

See Also

OutlineEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.OutlineEventArgs Members

OutlineEventArgs Members
Properties
[image]

Contains the arguments passed to the RowOutlineLevelToggled and ColumnOutlineLevelToggled event handlers.

The following tables list the members exposed by the OutlineEventArgs type.

Public Properties

Name | Description
Level | Gets the outline level that was toggled.

See Also

OutlineEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.OutlineEventArgs Properties

OutlineEventArgs Properties
[image]

Public Properties

Name | Description
Level | Gets the outline level that was toggled.

See Also

OutlineEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.OutlineEventArgs.Level Property

OutlineEventArgs.Level Property
[image]

Gets the outline level that was toggled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Level { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Level As Integer

Property Value

An integer value.

See Also

OutlineEventArgs Members
OutlineEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PageOrder Enumeration

PageOrder Enumeration
[image]

Specifies the order of printed pages.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum PageOrder

Visual Basic [image] Copy Code

Public Enum PageOrder

Members

Member name | Description
DownThenOver | Indicates that pages are printed vertically and then horizontally.
OverThenDown | Indicates that pages are printed horizontally and then vertically.

Remarks

Members of this enumeration can be assigned to the PageOrder property of the WorkbookPrinter class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions Class

PaginationOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class PaginationOptions

Visual Basic [image] Copy Code

Public Class PaginationOptions

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.PaginationOptions

See Also

PaginationOptions Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions Members

PaginationOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the PaginationOptions type.

Public Constructors

Name | Description
PaginationOptions | Initializes a new instance of the PaginationOptions class.

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
EnableGridLines | Gets or sets a value indicating whether to print the grid lines.
EnableHeaders | Gets or sets a value indicating whether to print the worksheet headers.
EnableObjects | Gets or sets a value indicating whether to print drawing objects.
FromWorksheet | Gets or sets the zero-based index of the first worksheet to print.
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.
PageOrder | Gets or sets the order of printed pages.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the workbook, expressed in percents.
ToWorksheet | Gets or sets the zero-based index of the last worksheet to print, or -1, to print to the last worksheet in the workbook.

See Also

PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions Constructor

PaginationOptions Constructor
[image]

Initializes a new instance of the PaginationOptions class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public PaginationOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions Properties

PaginationOptions Properties
[image]

Public Properties

Name | Description
DocumentName | Gets or sets the name of the printed document.
EnableGridLines | Gets or sets a value indicating whether to print the grid lines.
EnableHeaders | Gets or sets a value indicating whether to print the worksheet headers.
EnableObjects | Gets or sets a value indicating whether to print drawing objects.
FromWorksheet | Gets or sets the zero-based index of the first worksheet to print.
HeaderFormat | Gets or sets the format of page headers.
Margins | Gets or sets the margins for the printed pages.
PageOrder | Gets or sets the order of printed pages.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the workbook, expressed in percents.
ToWorksheet | Gets or sets the zero-based index of the last worksheet to print, or -1, to print to the last worksheet in the workbook.

See Also

PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.DocumentName Property

PaginationOptions.DocumentName Property
[image]

Gets or sets the name of the printed document.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string DocumentName { get; set; }

Visual Basic [image] Copy Code

Public Property DocumentName As String

Property Value

A string value. The default is " - Untitled - ".

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.EnableGridLines Property

PaginationOptions.EnableGridLines Property
[image]

Gets or sets a value indicating whether to print the grid lines.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnableGridLines { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGridLines As Boolean

Property Value

A boolean value. The default is false.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.EnableHeaders Property

PaginationOptions.EnableHeaders Property
[image]

Gets or sets a value indicating whether to print the worksheet headers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnableHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property EnableHeaders As Boolean

Property Value

A boolean value. The default is false.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.EnableObjects Property

PaginationOptions.EnableObjects Property
[image]

Gets or sets a value indicating whether to print drawing objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnableObjects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableObjects As Boolean

Property Value

A boolean value. The default is true.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.FromWorksheet Property

PaginationOptions.FromWorksheet Property
[image]

Gets or sets the zero-based index of the first worksheet to print.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FromWorksheet { get; set; }

Visual Basic [image] Copy Code

Public Property FromWorksheet As Integer

Property Value

An integer value. The default is 0.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.HeaderFormat Property

PaginationOptions.HeaderFormat Property
[image]

Gets or sets the format of page headers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string HeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderFormat As String

Property Value

A string value. The default is "%D, Page %P".

Remarks

The header format string can contain fixed text and format specifiers. The following specifiers are supported:

Specifier | Description
%D | A placeholder for the document title.
%P | A placeholder for the worksheet page number.
%GP | A placeholder for the global page number.
%T | A placeholder for the worksheet name.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.Margins Property

PaginationOptions.Margins Property
[image]

Gets or sets the margins for the printed pages.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

An instance of the Thickness structure. The default is Thickness(48).

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.PageOrder Property

PaginationOptions.PageOrder Property
[image]

Gets or sets the order of printed pages.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public PageOrder PageOrder { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrder As PageOrder

Property Value

A member of the PageOrder enumeration. The default is OverThenDown.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.Scale Property

PaginationOptions.Scale Property
[image]

Gets or sets the scale of the print output relatively to the original on-screen size of the workbook, expressed in percents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A double value. The default is 100.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PaginationOptions.ToWorksheet Property

PaginationOptions.ToWorksheet Property
[image]

Gets or sets the zero-based index of the last worksheet to print, or -1, to print to the last worksheet in the workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ToWorksheet { get; set; }

Visual Basic [image] Copy Code

Public Property ToWorksheet As Integer

Property Value

An integer value. The default is -1.

See Also

PaginationOptions Members
PaginationOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter Class

PdfExporter Class
[image]

Exports worksheets to Adobe Portable Document Format (PDF) files.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public class PdfExporter

Visual Basic [image] Copy Code

Public Class PdfExporter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.PdfExporter

See Also

PdfExporter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter Members

PdfExporter Members
Constructors Properties Methods
[image]

Exports worksheets to Adobe Portable Document Format (PDF) files.

The following tables list the members exposed by the PdfExporter type.

Public Constructors

Name | Description
PdfExporter | Initializes a new instance of the PdfExporter class.

Public Properties

Name | Description
AutoDetectEncoding | Gets or sets a value indicating whether character encoding should be detected automatically.
DefaultEncoding | Gets or sets encoding to use if the encoding for a string cannot be recognized automatically.
EnableGridLines | Gets or sets a value indicating whether to export the grid lines.
EnableHeaders | Gets or sets a value indicating whether to export the row and column headers.
JpegImageEncoding | Gets or sets a value indicating whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Gets or sets the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the worksheet.

Public Methods

Name | Description
Export | Exports the specified worksheet as a PDF file.

See Also

PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter Constructor

PdfExporter Constructor
[image]

Initializes a new instance of the PdfExporter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PdfExporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter Methods

PdfExporter Methods
[image]

Public Methods

Name | Description
Export | Exports the specified worksheet as a PDF file.

See Also

PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.Export Method

PdfExporter.Export Method
[image]

Exports the specified worksheet as a PDF file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public void Export (
Worksheet worksheet,
string filePath
)

Visual Basic [image] Copy Code

Public Sub Export( _
worksheet As Worksheet, _
filePath As String _
)

Parameters

worksheet

The worksheet to export.

filePath

The name of the PDF file.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter Properties

PdfExporter Properties
[image]

Public Properties

Name | Description
AutoDetectEncoding | Gets or sets a value indicating whether character encoding should be detected automatically.
DefaultEncoding | Gets or sets encoding to use if the encoding for a string cannot be recognized automatically.
EnableGridLines | Gets or sets a value indicating whether to export the grid lines.
EnableHeaders | Gets or sets a value indicating whether to export the row and column headers.
JpegImageEncoding | Gets or sets a value indicating whether images embedded in PDF should be encoded in Jpeg format.
JpegImageQuality | Gets or sets the image quality of Jpeg images.
Margins | Gets or sets the margins for the PDF pages.
PageOrientation | Gets or sets page orientation that is set to the resulting PDF pages.
PageSize | Gets or sets PDF page size.
Scale | Gets or sets the scale of the PDF output relatively to the original on-screen size of the worksheet.

See Also

PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.AutoDetectEncoding Property

PdfExporter.AutoDetectEncoding Property
[image]

Gets or sets a value indicating whether character encoding should be detected automatically.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool AutoDetectEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property AutoDetectEncoding As Boolean

Property Value

A boolean value.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.DefaultEncoding Property

PdfExporter.DefaultEncoding Property
[image]

Gets or sets encoding to use if the encoding for a string cannot be recognized automatically.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Encoding DefaultEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultEncoding As Encoding

Property Value

An instance of the Encoding class.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.EnableGridLines Property

PdfExporter.EnableGridLines Property
[image]

Gets or sets a value indicating whether to export the grid lines.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool EnableGridLines { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGridLines As Boolean

Property Value

true to export the grid lines; otherwise, false. The default is false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.EnableHeaders Property

PdfExporter.EnableHeaders Property
[image]

Gets or sets a value indicating whether to export the row and column headers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool EnableHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property EnableHeaders As Boolean

Property Value

true to export the worksheet headers; otherwise, false. The default is false.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.JpegImageEncoding Property

PdfExporter.JpegImageEncoding Property
[image]

Gets or sets a value indicating whether images embedded in PDF should be encoded in Jpeg format.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public bool JpegImageEncoding { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageEncoding As Boolean

Property Value

A boolean value.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.JpegImageQuality Property

PdfExporter.JpegImageQuality Property
[image]

Gets or sets the image quality of Jpeg images.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public int JpegImageQuality { get; set; }

Visual Basic [image] Copy Code

Public Property JpegImageQuality As Integer

Property Value

An integer value. The default is 100.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.Margins Property

PdfExporter.Margins Property
[image]

Gets or sets the margins for the PDF pages.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public Thickness Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Thickness

Property Value

An instance of the Thickness structure. The default is Thickness(48).

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.PageOrientation Property

PdfExporter.PageOrientation Property
[image]

Gets or sets page orientation that is set to the resulting PDF pages.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PageOrientation PageOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property PageOrientation As PageOrientation

Property Value

An instance of the PageOrientation enumeration. The default is Portrait.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.PageSize Property

PdfExporter.PageSize Property
[image]

Gets or sets PDF page size.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public PageSize PageSize { get; set; }

Visual Basic [image] Copy Code

Public Property PageSize As PageSize

Property Value

An instance of the PageSize enumeration. The default is A4.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PdfExporter.Scale Property

PdfExporter.Scale Property
[image]

Gets or sets the scale of the PDF output relatively to the original on-screen size of the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf.PdfExport

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A double value. The default is 100.

See Also

PdfExporter Members
PdfExporter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Picture Class

Picture Class
Remarks See Also
[image]

Represents a picture in a drawing within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Picture : InteractiveObject

Visual Basic [image] Copy Code

Public Class Picture
Inherits InteractiveObject

Remarks

Objects of this class cannot be instantiated directly. To create and add a picture to a Worksheet, call the AddPicture method of the worksheet's Drawing.

Example

The following example demonstrates how to add a picture to an existing worksheet:

C# [image] Copy Code

worksheet.Drawing.AddPicture("picture.png");

Visual Basic [image] Copy Code

worksheet.Drawing.AddPicture("picture.png")

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Spreadsheet.Wpf.InteractiveObject
MindFusion.Spreadsheet.Wpf.Picture

See Also

Picture Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Picture Members

Picture Members
Properties Methods Events
[image]

Represents a picture in a drawing within a worksheet.

The following tables list the members exposed by the Picture type.

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object. (Inherited from InteractiveObject.)
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet. (Inherited from InteractiveObject.)
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
Source | Gets or sets the image source of the picture.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle. (Inherited from InteractiveObject.)
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell. (Inherited from InteractiveObject.)

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order. (Inherited from InteractiveObject.)
BringToFront | Brings this object to the top of the z-order. (Inherited from InteractiveObject.)
Dispose | Overloaded. Disposes this object. (Inherited from InteractiveObject.)
SendBackward | Moves this object one step down in the z-order. (Inherited from InteractiveObject.)
SendToBack | Sends this object to the bottom of the z-order. (Inherited from InteractiveObject.)

Protected Methods

Name | Description
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from InteractiveObject.)
OnResized | This method is called when the object's size is changed. (Inherited from InteractiveObject.)

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

Picture Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Picture Properties

Picture Properties
[image]

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object. (Inherited from InteractiveObject.)
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet. (Inherited from InteractiveObject.)
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
Source | Gets or sets the image source of the picture.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle. (Inherited from InteractiveObject.)
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell. (Inherited from InteractiveObject.)

See Also

Picture Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Picture.Source Property

Picture.Source Property
[image]

Gets or sets the image source of the picture.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ImageSource Source { get; set; }

Visual Basic [image] Copy Code

Public Property Source As ImageSource

Property Value

An instance of the ImageSource class.

See Also

Picture Members
Picture Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Picture Events

Picture Events
[image]

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

Picture Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PicturePresenter Class

PicturePresenter Class
[image]

Defines the presentation of pictures in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class PicturePresenter : InteractiveObjectPresenter

Visual Basic [image] Copy Code

Public Class PicturePresenter
Inherits InteractiveObjectPresenter

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter
MindFusion.Spreadsheet.Wpf.PicturePresenter

See Also

PicturePresenter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PicturePresenter Members

PicturePresenter Members
Fields Properties Methods
[image]

Defines the presentation of pictures in the WorkbookView control.

The following tables list the members exposed by the PicturePresenter type.

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property. (Inherited from InteractiveObjectPresenter.)
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from InteractiveObjectPresenter.)
ObjectProperty | Identifies the Object dependency property. (Inherited from InteractiveObjectPresenter.)

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property. (Inherited from InteractiveObjectPresenter.)

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from InteractiveObjectPresenter.)

Protected Methods

Name | Description
GetLayoutClip | FrameworkElement.GetLayoutClip override. (Inherited from InteractiveObjectPresenter.)

See Also

PicturePresenter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs Class

PropertyEventArgs Class
[image]

Provides data for the PropertyValueChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class PropertyEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class PropertyEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.PropertyEventArgs
MindFusion.Spreadsheet.Wpf.ColumnChangedEventArgs
MindFusion.Spreadsheet.Wpf.RowChangedEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs

See Also

PropertyEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs Members

PropertyEventArgs Members
Properties
[image]

Provides data for the PropertyValueChanged event.

The following tables list the members exposed by the PropertyEventArgs type.

Public Properties

Name | Description
NewValue | Gets the current value of the property.
OldValue | Gets the value of the property before the change.
PropertyName | Gets the name of the property that changed.

See Also

PropertyEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs Properties

PropertyEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the current value of the property.
OldValue | Gets the value of the property before the change.
PropertyName | Gets the name of the property that changed.

See Also

PropertyEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs.NewValue Property

PropertyEventArgs.NewValue Property
[image]

Gets the current value of the property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As Object

Property Value

An object representing the new property value.

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs.OldValue Property

PropertyEventArgs.OldValue Property
[image]

Gets the value of the property before the change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As Object

Property Value

An object representing the previous property value.

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PropertyEventArgs.PropertyName Property

PropertyEventArgs.PropertyName Property
[image]

Gets the name of the property that changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

A string value.

See Also

PropertyEventArgs Members
PropertyEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.PushDirection Enumeration

PushDirection Enumeration
[image]

Specifies how the existing cells are moved when inserting new cells in a CellRange object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum PushDirection

Visual Basic [image] Copy Code

Public Enum PushDirection

Members

Member name | Description
Down | Indicates that the existing cells are pushed downwards.
Right | Indicates that the existing cells are pushed to the right.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T) Class

RemoveItemCommand(T) Class
Remarks See Also
[image]

Implements deletion of items from a collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RemoveItemCommand<T> : Command

Visual Basic [image] Copy Code

Public Class RemoveItemCommand(Of T)
Inherits Command

Remarks

There is usually no need to instantiate this class directly. Instances of this command are automatically created and executed when an item is removed from an UndoableCollection.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T)

See Also

RemoveItemCommand(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T) Members

RemoveItemCommand(T) Members
Constructors Properties Methods
[image]

Implements deletion of items from a collection.

The following tables list the members exposed by the RemoveItemCommand(T) type.

Public Constructors

Name | Description
RemoveItemCommand | Initializes a new instance of the RemoveItemCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T) Constructor

RemoveItemCommand(T) Constructor
[image]

Initializes a new instance of the RemoveItemCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public RemoveItemCommand<T> (
Workbook workbook,
UndoableCollection<T> collection,
int index,
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
workbook As Workbook, _
collection As UndoableCollection(Of T), _
index As Integer, _
item As T _
)

Parameters

workbook

The Workbook modified by this command.

collection

The collection from which the item is deleted.

index

The zero-based index of the item within the collection.

item

The item that should be removed from the collection.

See Also

RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T) Methods

RemoveItemCommand(T) Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T).Execute Method

RemoveItemCommand(T).Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

See Also

RemoveItemCommand(T) Members
RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T).Redo Method

RemoveItemCommand(T).Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveItemCommand(T) Members
RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RemoveItemCommand(T).Undo Method

RemoveItemCommand(T).Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveItemCommand(T) Members
RemoveItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T) Class

ReplaceItemCommand(T) Class
Remarks See Also
[image]

Implements replacement of items in a collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ReplaceItemCommand<T> : Command

Visual Basic [image] Copy Code

Public Class ReplaceItemCommand(Of T)
Inherits Command

Remarks

There is usually no need to instantiate this class directly. Instances of this command are automatically created and executed when an item is replaced in an UndoableCollection.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T)

See Also

ReplaceItemCommand(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T) Members

ReplaceItemCommand(T) Members
Constructors Properties Methods
[image]

Implements replacement of items in a collection.

The following tables list the members exposed by the ReplaceItemCommand(T) type.

Public Constructors

Name | Description
ReplaceItemCommand | Initializes a new instance of the ReplaceItemCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T) Constructor

ReplaceItemCommand(T) Constructor
[image]

Initializes a new instance of the ReplaceItemCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ReplaceItemCommand<T> (
Workbook workbook,
UndoableCollection<T> collection,
int index,
T item,
T newItem
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
workbook As Workbook, _
collection As UndoableCollection(Of T), _
index As Integer, _
item As T, _
newItem As T _
)

Parameters

workbook

The Workbook modified by this command.

collection

The collection in which the item is replaced.

index

The zero-based index of the item within the collection.

item

The item that should be replaced in the collection.

newItem

The new item at the specified index.

See Also

ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T) Methods

ReplaceItemCommand(T) Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T).Execute Method

ReplaceItemCommand(T).Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

See Also

ReplaceItemCommand(T) Members
ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T).Redo Method

ReplaceItemCommand(T).Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ReplaceItemCommand(T) Members
ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ReplaceItemCommand(T).Undo Method

ReplaceItemCommand(T).Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ReplaceItemCommand(T) Members
ReplaceItemCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T) Class

ResetCollectionCommand(T) Class
Remarks See Also
[image]

Implements clearing of a collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ResetCollectionCommand<T> : Command

Visual Basic [image] Copy Code

Public Class ResetCollectionCommand(Of T)
Inherits Command

Remarks

There is usually no need to instantiate this class directly. Instances of this command are automatically created and executed when an UndoableCollection is cleared.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T)

See Also

ResetCollectionCommand(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T) Members

ResetCollectionCommand(T) Members
Constructors Properties Methods
[image]

Implements clearing of a collection.

The following tables list the members exposed by the ResetCollectionCommand(T) type.

Public Constructors

Name | Description
ResetCollectionCommand | Initializes a new instance of the ResetCollectionCommand class.

Protected Properties

Name | Description
HasEffect | Gets a value indicating whether the command does anything. (Inherited from Command.)
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T) Constructor

ResetCollectionCommand(T) Constructor
[image]

Initializes a new instance of the ResetCollectionCommand class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ResetCollectionCommand<T> (
Workbook workbook,
UndoableCollection<T> collection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
workbook As Workbook, _
collection As UndoableCollection(Of T) _
)

Parameters

workbook

The Workbook modified by this command.

collection

The collection which is cleared.

See Also

ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T) Methods

ResetCollectionCommand(T) Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T).Execute Method

ResetCollectionCommand(T).Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool Execute ()

Visual Basic [image] Copy Code

Protected Overrides Function Execute () As Boolean

Return Value

See Also

ResetCollectionCommand(T) Members
ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T).Redo Method

ResetCollectionCommand(T).Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ResetCollectionCommand(T) Members
ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ResetCollectionCommand(T).Undo Method

ResetCollectionCommand(T).Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ResetCollectionCommand(T) Members
ResetCollectionCommand(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row Class

Row Class
Remarks See Also
[image]

Identifies a row in a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Row

Visual Basic [image] Copy Code

Public Class Row

Remarks

Instances of this class can be accessed through the Rows collection of the Worksheet class.

Example

The following example demonstrates how to access and modify a row in an existing worksheet:

C# [image] Copy Code

worksheet.Rows[2].Height = "10mm";

Visual Basic [image] Copy Code

worksheet.Rows(2).Height = "10mm"

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Row

See Also

Row Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row Members

Row Members
Properties
[image]

Identifies a row in a worksheet.

The following tables list the members exposed by the Row type.

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the row based on various conditions.
Height | Gets or sets the height of the row.
Index | Gets the zero-based index of the represented row.
IsCollapsed | Gets or sets a value indicating whether the group represented by this row is collapsed.
IsHidden | Gets or sets a value indicating whether the row is hidden.
OutlineLevel | Gets or sets the outline level of the row, or 0, if the row is not grouped.
PageBreak | Gets or sets a value indicating whether to force a page break after this row during printing.
Style | Gets an IRowStyle object that can be used to customize the appearance of all cells in the row.
Tag | Gets or sets a custom object associated with this row.
Title | Gets or sets the row title.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the row.

See Also

Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row Properties

Row Properties
[image]

Public Properties

Name | Description
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the cells in the row based on various conditions.
Height | Gets or sets the height of the row.
Index | Gets the zero-based index of the represented row.
IsCollapsed | Gets or sets a value indicating whether the group represented by this row is collapsed.
IsHidden | Gets or sets a value indicating whether the row is hidden.
OutlineLevel | Gets or sets the outline level of the row, or 0, if the row is not grouped.
PageBreak | Gets or sets a value indicating whether to force a page break after this row during printing.
Style | Gets an IRowStyle object that can be used to customize the appearance of all cells in the row.
Tag | Gets or sets a custom object associated with this row.
Title | Gets or sets the row title.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the row.

See Also

Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.ConditionalFormats Property

Row.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the cells in the row based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Height Property

Row.Height Property
[image]

Gets or sets the height of the row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic) indicating that the height of the row is specified through the DefaultRowHeight property of the parent Worksheet.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Index Property

Row.Index Property
[image]

Gets the zero-based index of the represented row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.IsCollapsed Property

Row.IsCollapsed Property
[image]

Gets or sets a value indicating whether the group represented by this row is collapsed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsCollapsed { get; set; }

Visual Basic [image] Copy Code

Public Property IsCollapsed As Boolean

Property Value

A boolean value.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.IsHidden Property

Row.IsHidden Property
[image]

Gets or sets a value indicating whether the row is hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsHidden { get; set; }

Visual Basic [image] Copy Code

Public Property IsHidden As Boolean

Property Value

true if the row is hidden; otherwise, false. The default is false.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.OutlineLevel Property

Row.OutlineLevel Property
[image]

Gets or sets the outline level of the row, or 0, if the row is not grouped.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineLevel As Integer

Property Value

An integer value.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.PageBreak Property

Row.PageBreak Property
[image]

Gets or sets a value indicating whether to force a page break after this row during printing.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool PageBreak { get; set; }

Visual Basic [image] Copy Code

Public Property PageBreak As Boolean

Property Value

true if this row should force a page break during printing; otherwise, false. The default is false.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Style Property

Row.Style Property
[image]

Gets an IRowStyle object that can be used to customize the appearance of all cells in the row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IRowStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IRowStyle

Property Value

An IRowStyle instance.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Tag Property

Row.Tag Property
[image]

Gets or sets a custom object associated with this row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the custom data associated with this row.

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Title Property

Row.Title Property
[image]

Gets or sets the row title.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Row.Validation Property

Row.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

Example

The following example illustrates how to set a validation for the cells in a row.

C# [image] Copy Code

var validation = worksheet.Rows[10].Validation;
validation.Type = ValidationType.List;
validation.First = "Apples,Bananas,Plums,Strawberries";

Visual Basic [image] Copy Code

Dim validation = worksheet.Rows(10).Validation
validation.Type = ValidationType.List
validation.First = "Apples,Bananas,Plums,Strawberries"

See Also

Row Members
Row Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowChangedEventArgs Class

RowChangedEventArgs Class
[image]

Provides data for the RowChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowChangedEventArgs : PropertyEventArgs

Visual Basic [image] Copy Code

Public Class RowChangedEventArgs
Inherits PropertyEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.PropertyEventArgs
MindFusion.Spreadsheet.Wpf.RowChangedEventArgs

See Also

RowChangedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowChangedEventArgs Members

RowChangedEventArgs Members
Properties
[image]

Provides data for the RowChanged event.

The following tables list the members exposed by the RowChangedEventArgs type.

Public Properties

Name | Description
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Row | Gets the row related to the event.
Worksheet | Gets the worksheet that is the source of the event.

See Also

RowChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowChangedEventArgs Properties

RowChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Row | Gets the row related to the event.
Worksheet | Gets the worksheet that is the source of the event.

See Also

RowChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowChangedEventArgs.Row Property

RowChangedEventArgs.Row Property
[image]

Gets the row related to the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Row Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Row

Property Value

An instance of the Row class.

See Also

RowChangedEventArgs Members
RowChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowChangedEventArgs.Worksheet Property

RowChangedEventArgs.Worksheet Property
[image]

Gets the worksheet that is the source of the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

RowChangedEventArgs Members
RowChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection Class

RowCollection Class
[image]

Represents a specialized collection for worksheet rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowCollection : IEnumerable<Row>, IEnumerable

Visual Basic [image] Copy Code

Public Class RowCollection
Implements IEnumerable(Of Row), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.RowCollection

See Also

RowCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection Members

RowCollection Members
Properties Methods
[image]

Represents a specialized collection for worksheet rows.

The following tables list the members exposed by the RowCollection type.

Public Properties

Name | Description
Count | Gets the number of rows in the collection.
Item | Overloaded. Gets a row or a range of rows at the specified index.

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts one or more rows at a specified index.
Move | Overloaded. Moves the specified row or rows to another location.
Remove | Overloaded. Removes one or more rows at a specified index.

See Also

RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection Methods

RowCollection Methods
[image]

Public Methods

Name | Description
GetEnumerator | Returns an enumerator that iterates through the collection.
Insert | Overloaded. Inserts one or more rows at a specified index.
Move | Overloaded. Moves the specified row or rows to another location.
Remove | Overloaded. Removes one or more rows at a specified index.

See Also

RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.GetEnumerator Method

RowCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Row> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Row)

Return Value

An IEnumerator<Row> that can be used to iterate through the collection.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Insert Method

RowCollection.Insert Method
[image]

Inserts one or more rows at a specified index.

Overload List

Name | Description
RowCollection.Insert (Int32) | Inserts a new row at the specified index.
RowCollection.Insert (Int32, Int32) | Inserts the specified number of rows at the specified index.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Insert Method (Int32)

RowCollection.Insert Method (Int32)
See Also
[image]

Inserts a new row at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer _
)

Parameters

index

The zero-based index where the row should be inserted.

Remarks

This method will raise an InvalidOperationException exception if the operation would cause filled cells to be shifted beyond the sheet.

See Also

Insert Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Insert Method (Int32, Int32)

RowCollection.Insert Method (Int32, Int32)
See Also
[image]

Inserts the specified number of rows at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Insert (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
count As Integer _
)

Parameters

index

The zero-based index where the rows should be inserted.

count

The number of rows to insert.

Remarks

This method will raise an InvalidOperationException exception if the operation would cause filled cells to be shifted beyond the sheet.

See Also

Insert Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Move Method

RowCollection.Move Method
[image]

Moves the specified row or rows to another location.

Overload List

Name | Description
RowCollection.Move (Int32, Int32) | Moves the specified row to the specified target index.
RowCollection.Move (Int32, Int32, Int32) | Moves the specified number of rows to the specified target index.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Move Method (Int32, Int32)

RowCollection.Move Method (Int32, Int32)
See Also
[image]

Moves the specified row to the specified target index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Move (
int index,
int target
)

Visual Basic [image] Copy Code

Public Sub Move( _
index As Integer, _
target As Integer _
)

Parameters

index

The zero-based index of the row to move.

target

The zero-based index of the row before which the row should be moved.

See Also

Move Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Move Method (Int32, Int32, Int32)

RowCollection.Move Method (Int32, Int32, Int32)
See Also
[image]

Moves the specified number of rows to the specified target index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Move (
int index,
int count,
int target
)

Visual Basic [image] Copy Code

Public Function Move( _
index As Integer, _
count As Integer, _
target As Integer _
) As Boolean

Parameters

index

The zero-based index of the first row to move.

count

The number of rows to move.

target

The zero-based index of the row before which the rows should be moved.

Return Value

true if a move occurred; otherwise, false.

See Also

Move Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Remove Method

RowCollection.Remove Method
[image]

Removes one or more rows at a specified index.

Overload List

Name | Description
RowCollection.Remove (Int32) | Removes the row at the specified index.
RowCollection.Remove (Int32, Int32) | Removes the specified number of rows at the specified index.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Remove Method (Int32)

RowCollection.Remove Method (Int32)
See Also
[image]

Removes the row at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
int index
)

Visual Basic [image] Copy Code

Public Sub Remove( _
index As Integer _
)

Parameters

index

The zero-based index of the row to remove.

See Also

Remove Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Remove Method (Int32, Int32)

RowCollection.Remove Method (Int32, Int32)
See Also
[image]

Removes the specified number of rows at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub Remove( _
index As Integer, _
count As Integer _
)

Parameters

index

The zero-based index of the first row to remove.

count

The number of rows to remove.

See Also

Remove Method Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection Properties

RowCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of rows in the collection.
Item | Overloaded. Gets a row or a range of rows at the specified index.

See Also

RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Count Property

RowCollection.Count Property
[image]

Gets the number of rows in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Item Property

RowCollection.Item Property
[image]

Gets a row or a range of rows at the specified index.

Overload List

Name | Description
RowCollection.Item (Int32) | Gets the row at the specified index.
RowCollection.Item (Int32, Int32) | Gets a RowRange object that can be used to manipulate the rows in the specified range.

See Also

RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Item Property (Int32)

RowCollection.Item Property (Int32)
See Also
[image]

Gets the row at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Row Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As Row

Parameters

index

The zero-based index of the row to get.

Property Value

A Row object identifying the row at the specified position.

See Also

Item Property Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowCollection.Item Property (Int32, Int32)

RowCollection.Item Property (Int32, Int32)
See Also
[image]

Gets a RowRange object that can be used to manipulate the rows in the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public RowRange Item [
int top,
int bottom
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
top As Integer, _
bottom As Integer _
) As RowRange

Parameters

top

The zero-based index of the top row in the range.

bottom

The zero-based index of the bottom row in the range.

Property Value

A RowRange object that can be used to manipulate the rows in the range.

See Also

Item Property Overload List
RowCollection Members
RowCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowEventArgs Class

RowEventArgs Class
[image]

Contains the arguments passed to row-related events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.RowEventArgs
MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs

See Also

RowEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowEventArgs Members

RowEventArgs Members
Properties
[image]

Contains the arguments passed to row-related events.

The following tables list the members exposed by the RowEventArgs type.

Public Properties

Name | Description
Row | Gets the related row.

See Also

RowEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowEventArgs Properties

RowEventArgs Properties
[image]

Public Properties

Name | Description
Row | Gets the related row.

See Also

RowEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowEventArgs.Row Property

RowEventArgs.Row Property
[image]

Gets the related row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Row Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Row

Property Value

An instance of the Row class.

See Also

RowEventArgs Members
RowEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowHeader Class

RowHeader Class
[image]

Defines the presentation of row headers in the WorkbookView control.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowHeader : Header

Visual Basic [image] Copy Code

Public Class RowHeader
Inherits Header

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Spreadsheet.Wpf.Header
MindFusion.Spreadsheet.Wpf.RowHeader

See Also

RowHeader Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowHeader Members

RowHeader Members
Constructors Fields Properties
[image]

Defines the presentation of row headers in the WorkbookView control.

The following tables list the members exposed by the RowHeader type.

Public Constructors

Name | Description
RowHeader | Initializes a new instance of the RowHeader class.

Public Fields

Name | Description
HasHiddenAfterProperty | Identifies the HasHiddenAfter dependency property. (Inherited from Header.)
HasHiddenBeforeProperty | Identifies the HasHiddenBefore dependency property. (Inherited from Header.)
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from Header.)

Public Properties

Name | Description
HasHiddenAfter | Gets or sets a value indicating whether there are hidden headers immediately after this one. This is a dependency property. (Inherited from Header.)
HasHiddenBefore | Gets or sets a value indicating whether there are hidden headers immediately before this one. This is a dependency property. (Inherited from Header.)
IsSelected | Gets or sets a value indicating whether the entire row or column represented by this header is selected. This is a dependency property. (Inherited from Header.)

See Also

RowHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowHeader Constructor

RowHeader Constructor
[image]

Initializes a new instance of the RowHeader class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public RowHeader ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RowHeader Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowMouseEventArgs Class

RowMouseEventArgs Class
[image]

Contains the arguments passed to row-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowMouseEventArgs : BaseMouseEventArgs

Visual Basic [image] Copy Code

Public Class RowMouseEventArgs
Inherits BaseMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.BaseMouseEventArgs
MindFusion.Spreadsheet.Wpf.RowMouseEventArgs

See Also

RowMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowMouseEventArgs Members

RowMouseEventArgs Members
Properties
[image]

Contains the arguments passed to row-related mouse events.

The following tables list the members exposed by the RowMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Row | Gets the row for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

RowMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowMouseEventArgs Properties

RowMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from BaseMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from BaseMouseEventArgs.)
Row | Gets the row for which the event was raised.
X | Gets the relative x-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from BaseMouseEventArgs.)

See Also

RowMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowMouseEventArgs.Row Property

RowMouseEventArgs.Row Property
[image]

Gets the row for which the event was raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Row Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Row

Property Value

An instance of the Row class.

See Also

RowMouseEventArgs Members
RowMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange Class

RowRange Class
Remarks See Also
[image]

Identifies a range of rows in a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowRange : IEnumerable<Row>, IEnumerable

Visual Basic [image] Copy Code

Public Class RowRange
Implements IEnumerable(Of Row), IEnumerable

Remarks

Instances of this class can be accessed through the Rows collection of the Worksheet class.

Example

The following example demonstrates how to hide a range of rows in an existing worksheet:

C# [image] Copy Code

worksheet.Rows[1, 5].IsHidden = true;

Visual Basic [image] Copy Code

worksheet.Rows(1, 5).IsHidden = True

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.RowRange

See Also

RowRange Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange Members

RowRange Members
Properties Methods
[image]

Identifies a range of rows in a Worksheet.

The following tables list the members exposed by the RowRange type.

Public Properties

Name | Description
Bottom | Gets the bottom row of the range.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the rows in the range based on various conditions.
Height | Gets or sets the height of all rows in the range.
IsHidden | Gets or sets a value indicating whether the rows in the range are hidden.
OutlineLevel | Gets or sets the outline level of the rows in the range.
Style | Gets an IRowStyle object that can be used to customize the appearance of all rows in the range.
Top | Gets the top row of the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the range.

Public Methods

Name | Description
GetEnumerator | Returns an enumerator object that can be used to iterate through the rows in the range.
Group | Increases the outline level of all rows in the range.
Ungroup | Decreses the outline level of all rows in the range.

See Also

RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange Methods

RowRange Methods
[image]

Public Methods

Name | Description
GetEnumerator | Returns an enumerator object that can be used to iterate through the rows in the range.
Group | Increases the outline level of all rows in the range.
Ungroup | Decreses the outline level of all rows in the range.

See Also

RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.GetEnumerator Method

RowRange.GetEnumerator Method
[image]

Returns an enumerator object that can be used to iterate through the rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<Row> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Row)

Return Value

An IEnumerator<Row> object that can be used to iterate through the rows in the range.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Group Method

RowRange.Group Method
[image]

Increases the outline level of all rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Group ()

Visual Basic [image] Copy Code

Public Function Group () As Boolean

Return Value

true, if grouping was successful; otherwise, false.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Ungroup Method

RowRange.Ungroup Method
[image]

Decreses the outline level of all rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Ungroup ()

Visual Basic [image] Copy Code

Public Function Ungroup () As Boolean

Return Value

true, if ungrouping was successful; otherwise, false.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange Properties

RowRange Properties
[image]

Public Properties

Name | Description
Bottom | Gets the bottom row of the range.
ConditionalFormats | Gets a list with format objects that can be used to customize the appearance of the rows in the range based on various conditions.
Height | Gets or sets the height of all rows in the range.
IsHidden | Gets or sets a value indicating whether the rows in the range are hidden.
OutlineLevel | Gets or sets the outline level of the rows in the range.
Style | Gets an IRowStyle object that can be used to customize the appearance of all rows in the range.
Top | Gets the top row of the range.
Validation | Gets an IValidation object that can be used to specify validation rules for the data in the range.

See Also

RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Bottom Property

RowRange.Bottom Property
[image]

Gets the bottom row of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Bottom { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bottom As Integer

Property Value

An integer value.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.ConditionalFormats Property

RowRange.ConditionalFormats Property
[image]

Gets a list with format objects that can be used to customize the appearance of the rows in the range based on various conditions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IConditionalFormatCollection ConditionalFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConditionalFormats As IConditionalFormatCollection

Property Value

An IConditionalFormatCollection instance.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Height Property

RowRange.Height Property
[image]

Gets or sets the height of all rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Measure

Property Value

An instance of the Measure class.

Remarks

If the rows have different or default heights, this property returns null (Nothing in Visual Basic).

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.IsHidden Property

RowRange.IsHidden Property
[image]

Gets or sets a value indicating whether the rows in the range are hidden.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> IsHidden { get; set; }

Visual Basic [image] Copy Code

Public Property IsHidden As Nullable(Of Boolean)

Property Value

true if all rows in the range are hidden; otherwise false or null (Nothing in Visual Basic).

Remarks

If the rows have different or default values, this property returns null (Nothing in Visual Basic).

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.OutlineLevel Property

RowRange.OutlineLevel Property
[image]

Gets or sets the outline level of the rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Int32> OutlineLevel { get; set; }

Visual Basic [image] Copy Code

Public Property OutlineLevel As Nullable(Of Int32)

Property Value

Remarks

If the rows have different or default values, this property returns null (Nothing in Visual Basic).

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Style Property

RowRange.Style Property
[image]

Gets an IRowStyle object that can be used to customize the appearance of all rows in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IRowStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As IRowStyle

Property Value

An IRowStyle instance.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Top Property

RowRange.Top Property
[image]

Gets the top row of the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Top { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Top As Integer

Property Value

An integer value.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRange.Validation Property

RowRange.Validation Property
[image]

Gets an IValidation object that can be used to specify validation rules for the data in the range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IValidation Validation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Validation As IValidation

Property Value

An IValidation instance.

See Also

RowRange Members
RowRange Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeEventArgs Class

RowRangeEventArgs Class
[image]

Contains the arguments passed to events related to multiple rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowRangeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RowRangeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.RowRangeEventArgs
MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs
MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs

See Also

RowRangeEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeEventArgs Members

RowRangeEventArgs Members
Properties
[image]

Contains the arguments passed to events related to multiple rows.

The following tables list the members exposed by the RowRangeEventArgs type.

Public Properties

Name | Description
RowRange | Gets the related range of rows.

See Also

RowRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeEventArgs Properties

RowRangeEventArgs Properties
[image]

Public Properties

Name | Description
RowRange | Gets the related range of rows.

See Also

RowRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeEventArgs.RowRange Property

RowRangeEventArgs.RowRange Property
[image]

Gets the related range of rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public RowRange RowRange { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowRange As RowRange

Property Value

An instance of the RowRange class.

See Also

RowRangeEventArgs Members
RowRangeEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs Class

RowRangeMovingEventArgs Class
[image]

Contains the arguments passed to validation events related to multiple rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowRangeMovingEventArgs : RowRangeEventArgs

Visual Basic [image] Copy Code

Public Class RowRangeMovingEventArgs
Inherits RowRangeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.RowRangeEventArgs
MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs

See Also

RowRangeMovingEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs Members

RowRangeMovingEventArgs Members
Properties
[image]

Contains the arguments passed to validation events related to multiple rows.

The following tables list the members exposed by the RowRangeMovingEventArgs type.

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
Initial | Gets a value indicating whether this is the first time the event is raised.
RowRange | Gets the related range of rows. (Inherited from RowRangeEventArgs.)

See Also

RowRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs Properties

RowRangeMovingEventArgs Properties
[image]

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
Initial | Gets a value indicating whether this is the first time the event is raised.
RowRange | Gets the related range of rows. (Inherited from RowRangeEventArgs.)

See Also

RowRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs.Abort Property

RowRangeMovingEventArgs.Abort Property
[image]

Gets or sets a value indicating whether to terminate the current operation immediately.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Abort { get; set; }

Visual Basic [image] Copy Code

Public Property Abort As Boolean

Property Value

A boolean value.

See Also

RowRangeMovingEventArgs Members
RowRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs.Allow Property

RowRangeMovingEventArgs.Allow Property
[image]

Gets or sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Allow { get; set; }

Visual Basic [image] Copy Code

Public Property Allow As Boolean

Property Value

A boolean value.

Remarks

Set this property to true to allow the user to complete the operation.

See Also

RowRangeMovingEventArgs Members
RowRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeMovingEventArgs.Initial Property

RowRangeMovingEventArgs.Initial Property
[image]

Gets a value indicating whether this is the first time the event is raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Initial { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Initial As Boolean

Property Value

A boolean value.

See Also

RowRangeMovingEventArgs Members
RowRangeMovingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs Class

RowRangeResizingEventArgs Class
[image]

Contains the arguments passed to validation events related to multiple rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class RowRangeResizingEventArgs : RowRangeEventArgs

Visual Basic [image] Copy Code

Public Class RowRangeResizingEventArgs
Inherits RowRangeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.RowRangeEventArgs
MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs

See Also

RowRangeResizingEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs Members

RowRangeResizingEventArgs Members
Properties
[image]

Contains the arguments passed to validation events related to multiple rows.

The following tables list the members exposed by the RowRangeResizingEventArgs type.

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
Height | Gets or sets the new row height.
Initial | Gets a value indicating whether this is the first time the event is raised.
RowRange | Gets the related range of rows. (Inherited from RowRangeEventArgs.)

See Also

RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs Properties

RowRangeResizingEventArgs Properties
[image]

Public Properties

Name | Description
Abort | Gets or sets a value indicating whether to terminate the current operation immediately.
Allow | Gets or sets a value indicating whether to allow the current operation.
Height | Gets or sets the new row height.
Initial | Gets a value indicating whether this is the first time the event is raised.
RowRange | Gets the related range of rows. (Inherited from RowRangeEventArgs.)

See Also

RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs.Abort Property

RowRangeResizingEventArgs.Abort Property
[image]

Gets or sets a value indicating whether to terminate the current operation immediately.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Abort { get; set; }

Visual Basic [image] Copy Code

Public Property Abort As Boolean

Property Value

A boolean value.

See Also

RowRangeResizingEventArgs Members
RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs.Allow Property

RowRangeResizingEventArgs.Allow Property
[image]

Gets or sets a value indicating whether to allow the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Allow { get; set; }

Visual Basic [image] Copy Code

Public Property Allow As Boolean

Property Value

A boolean value.

Remarks

Set this property to true to allow the user to complete the operation.

See Also

RowRangeResizingEventArgs Members
RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs.Height Property

RowRangeResizingEventArgs.Height Property
[image]

Gets or sets the new row height.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Measure

Property Value

An instance of the Measure class.

See Also

RowRangeResizingEventArgs Members
RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.RowRangeResizingEventArgs.Initial Property

RowRangeResizingEventArgs.Initial Property
[image]

Gets a value indicating whether this is the first time the event is raised.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Initial { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Initial As Boolean

Property Value

A boolean value.

See Also

RowRangeResizingEventArgs Members
RowRangeResizingEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run Class

Run Class
[image]

Represents a fragment of text with uniform formatting in a FormattedText object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Run

Visual Basic [image] Copy Code

Public Class Run

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Run

See Also

Run Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run Members

Run Members
Constructors Properties Methods
[image]

Represents a fragment of text with uniform formatting in a FormattedText object.

The following tables list the members exposed by the Run type.

Public Constructors

Name | Description
Run | Initializes a new instance of the Run class.

Public Properties

Name | Description
Brush | Gets or sets the text color of the run, or null (Nothing in Visual Basic), if the run should use the default text color.
FontBold | Gets or sets the font weight of the run, or null (Nothing in Visual Basic), if the run should use the default font weight.
FontItalic | Gets or sets the font italic style of the run, or null (Nothing in Visual Basic), if the run should use the default font italic style.
FontName | Gets or sets the font name of the run, or null (Nothing in Visual Basic), if the run should use the default font.
FontSize | Gets or sets the font size of the run, or null (Nothing in Visual Basic), if the run should use the default font size.
FontStrikeout | Gets or sets the font strikeout style of the run, or null (Nothing in Visual Basic), if the run should use the default font strikeout style.
FontUnderlined | Gets or sets the font underlined style of the run, or null (Nothing in Visual Basic), if the run should use the default font underlined style.
Text | Gets or sets the text of the run.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run Constructor

Run Constructor
[image]

Initializes a new instance of the Run class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Run ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run Methods

Run Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.ToString Method

Run.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representing the raw text of this object.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run Properties

Run Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the text color of the run, or null (Nothing in Visual Basic), if the run should use the default text color.
FontBold | Gets or sets the font weight of the run, or null (Nothing in Visual Basic), if the run should use the default font weight.
FontItalic | Gets or sets the font italic style of the run, or null (Nothing in Visual Basic), if the run should use the default font italic style.
FontName | Gets or sets the font name of the run, or null (Nothing in Visual Basic), if the run should use the default font.
FontSize | Gets or sets the font size of the run, or null (Nothing in Visual Basic), if the run should use the default font size.
FontStrikeout | Gets or sets the font strikeout style of the run, or null (Nothing in Visual Basic), if the run should use the default font strikeout style.
FontUnderlined | Gets or sets the font underlined style of the run, or null (Nothing in Visual Basic), if the run should use the default font underlined style.
Text | Gets or sets the text of the run.

See Also

Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.Brush Property

Run.Brush Property
[image]

Gets or sets the text color of the run, or null (Nothing in Visual Basic), if the run should use the default text color.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the WPF Brush class.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontBold Property

Run.FontBold Property
[image]

Gets or sets the font weight of the run, or null (Nothing in Visual Basic), if the run should use the default font weight.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontBold { get; set; }

Visual Basic [image] Copy Code

Public Property FontBold As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontItalic Property

Run.FontItalic Property
[image]

Gets or sets the font italic style of the run, or null (Nothing in Visual Basic), if the run should use the default font italic style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property FontItalic As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontName Property

Run.FontName Property
[image]

Gets or sets the font name of the run, or null (Nothing in Visual Basic), if the run should use the default font.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontSize Property

Run.FontSize Property
[image]

Gets or sets the font size of the run, or null (Nothing in Visual Basic), if the run should use the default font size.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Nullable(Of Double)

Property Value

A nullable double value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontStrikeout Property

Run.FontStrikeout Property
[image]

Gets or sets the font strikeout style of the run, or null (Nothing in Visual Basic), if the run should use the default font strikeout style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property FontStrikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.FontUnderlined Property

Run.FontUnderlined Property
[image]

Gets or sets the font underlined style of the run, or null (Nothing in Visual Basic), if the run should use the default font underlined style.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> FontUnderlined { get; set; }

Visual Basic [image] Copy Code

Public Property FontUnderlined As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Run.Text Property

Run.Text Property
[image]

Gets or sets the text of the run.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value.

See Also

Run Members
Run Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SearchDirection Enumeration

SearchDirection Enumeration
[image]

Specifies the direction of find and replace operations.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum SearchDirection

Visual Basic [image] Copy Code

Public Enum SearchDirection

Members

Member name | Description
Backward | Indicates that the operation should proceed to the previous cell.
Forward | Indicates that the operation should proceed to the next cell.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SearchOrder Enumeration

SearchOrder Enumeration
[image]

Specifies the order of find and replace operations.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum SearchOrder

Visual Basic [image] Copy Code

Public Enum SearchOrder

Members

Member name | Description
ByColumns | Indicates that the operation should process columns first, then rows.
ByRows | Indicates that the operation should process rows first, then columns.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection Class

Selection Class
Remarks See Also
[image]

Represents a set of selected cells and objects within a grid view.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Selection

Visual Basic [image] Copy Code

Public Class Selection

Remarks

This class cannot be instantiated directly. To get an instance of this class for a specific WorkbookView, use the Selection property.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Selection

See Also

Selection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection Members

Selection Members
Properties Methods
[image]

Represents a set of selected cells and objects within a grid view.

The following tables list the members exposed by the Selection type.

Public Properties

Name | Description
Bottom | Gets the index of the bottommost column of the selected cell range.
IsEmpty | Gets a value indicating whether the selection contains any cells.
Left | Gets the index of the leftmost column of the selected cell range.
Objects | Gets a list with the selected objects.
Range | Gets a CellRange object representing the selected range of cells, or null (Nothing in Visual Basic), if the selection is empty.
Right | Gets the index of the rightmost column of the selected cell range.
Top | Gets the index of the topmost column of the selected cell range.

Public Methods

Name | Description
AddObject | Selects the specified object.
Change | Selects the specified object, deselects all other currently selected objects.
Clear | Clears the selection.
ClearObjects | Removes all interactive objects from the selection.
Contains | Checks whether the selection contains the cell at the specified coordinates.
ContainsObject | Checks whether the specified object is contained in the selection.
InColumn | Checks whether the specified column is part of the selection.
InRow | Indicates whether the specified row is part of the selection.
RemoveObject | Removes the specified object from the selection.
SelectAll | Overloaded. Selects all cells or a range of cells in the worksheet.
SelectColumns | Overloaded. Selects a column or a range of columns.
SelectRows | Overloaded. Selects a row or a range of rows.
Set | Overloaded. Sets the selection over a cell or a range of cells.
Toggle | Toggles the selection state of the specified object.

See Also

Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
AddObject | Selects the specified object.
Change | Selects the specified object, deselects all other currently selected objects.
Clear | Clears the selection.
ClearObjects | Removes all interactive objects from the selection.
Contains | Checks whether the selection contains the cell at the specified coordinates.
ContainsObject | Checks whether the specified object is contained in the selection.
InColumn | Checks whether the specified column is part of the selection.
InRow | Indicates whether the specified row is part of the selection.
RemoveObject | Removes the specified object from the selection.
SelectAll | Overloaded. Selects all cells or a range of cells in the worksheet.
SelectColumns | Overloaded. Selects a column or a range of columns.
SelectRows | Overloaded. Selects a row or a range of rows.
Set | Overloaded. Sets the selection over a cell or a range of cells.
Toggle | Toggles the selection state of the specified object.

See Also

Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.AddObject Method

Selection.AddObject Method
[image]

Selects the specified object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void AddObject (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub AddObject( _
obj As InteractiveObject _
)

Parameters

obj

The object to select.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Change Method

Selection.Change Method
[image]

Selects the specified object, deselects all other currently selected objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Change (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub Change( _
obj As InteractiveObject _
)

Parameters

obj

The object to select.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Clear Method

Selection.Clear Method
[image]

Clears the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.ClearObjects Method

Selection.ClearObjects Method
[image]

Removes all interactive objects from the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ClearObjects ()

Visual Basic [image] Copy Code

Public Sub ClearObjects ()

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Contains Method

Selection.Contains Method
[image]

Checks whether the selection contains the cell at the specified coordinates.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
int column,
int row
)

Visual Basic [image] Copy Code

Public Function Contains( _
column As Integer, _
row As Integer _
) As Boolean

Parameters

column

The 0-based index of the column of the cell to check.

row

The 0-based index of the row of the cell to check.

Return Value

true if the selection contains the cell at the specified coordinates; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.ContainsObject Method

Selection.ContainsObject Method
[image]

Checks whether the specified object is contained in the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ContainsObject (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Function ContainsObject( _
obj As InteractiveObject _
) As Boolean

Parameters

obj

The object to check.

Return Value

true if the object is selected; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.InColumn Method

Selection.InColumn Method
[image]

Checks whether the specified column is part of the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool InColumn (
int column
)

Visual Basic [image] Copy Code

Public Function InColumn( _
column As Integer _
) As Boolean

Parameters

column

The column to test.

Return Value

true if at least one cell in the column is selected; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.InRow Method

Selection.InRow Method
[image]

Indicates whether the specified row is part of the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool InRow (
int row
)

Visual Basic [image] Copy Code

Public Function InRow( _
row As Integer _
) As Boolean

Parameters

row

The row to test.

Return Value

true if at least one cell in the row is selected; otherwise, false.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.RemoveObject Method

Selection.RemoveObject Method
[image]

Removes the specified object from the selection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void RemoveObject (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub RemoveObject( _
obj As InteractiveObject _
)

Parameters

obj

The object to deselect.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectAll Method

Selection.SelectAll Method
[image]

Selects all cells or a range of cells in the worksheet.

Overload List

Name | Description
Selection.SelectAll () | Selects all cells in the worksheet.
Selection.SelectAll (Int32, Int32) | Selects all cells starting from the topmost cell in a worksheet to the specified count of columns and rows.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectAll Method ()

Selection.SelectAll Method ()
See Also
[image]

Selects all cells in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectAll ()

Visual Basic [image] Copy Code

Public Sub SelectAll ()

See Also

SelectAll Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectAll Method (Int32, Int32)

Selection.SelectAll Method (Int32, Int32)
See Also
[image]

Selects all cells starting from the topmost cell in a worksheet to the specified count of columns and rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectAll (
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Sub SelectAll( _
columns As Integer, _
rows As Integer _
)

Parameters

columns

The number of columns to select.

rows

The number of rows to select.

See Also

SelectAll Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectColumns Method

Selection.SelectColumns Method
[image]

Selects a column or a range of columns.

Overload List

Name | Description
Selection.SelectColumns (Int32) | Selects the column with the specified index.
Selection.SelectColumns (Int32, Int32) | Selects a range of columns in the worksheet.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectColumns Method (Int32)

Selection.SelectColumns Method (Int32)
See Also
[image]

Selects the column with the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectColumns (
int index
)

Visual Basic [image] Copy Code

Public Sub SelectColumns( _
index As Integer _
)

Parameters

index

The index of the column to select.

See Also

SelectColumns Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectColumns Method (Int32, Int32)

Selection.SelectColumns Method (Int32, Int32)
See Also
[image]

Selects a range of columns in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectColumns (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub SelectColumns( _
index As Integer, _
count As Integer _
)

Parameters

index

The index of the first column in the range.

count

The number of columns to select.

See Also

SelectColumns Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectRows Method

Selection.SelectRows Method
[image]

Selects a row or a range of rows.

Overload List

Name | Description
Selection.SelectRows (Int32) | Selects the row with the specified index.
Selection.SelectRows (Int32, Int32) | Selects a range of rows in the worksheet.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectRows Method (Int32)

Selection.SelectRows Method (Int32)
See Also
[image]

Selects the row with the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectRows (
int index
)

Visual Basic [image] Copy Code

Public Sub SelectRows( _
index As Integer _
)

Parameters

index

The index of the row to select.

See Also

SelectRows Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.SelectRows Method (Int32, Int32)

Selection.SelectRows Method (Int32, Int32)
See Also
[image]

Selects a range of rows in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SelectRows (
int index,
int count
)

Visual Basic [image] Copy Code

Public Sub SelectRows( _
index As Integer, _
count As Integer _
)

Parameters

index

The index of the first rows in the range.

count

The number of rows to select.

See Also

SelectRows Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Set Method

Selection.Set Method
[image]

Sets the selection over a cell or a range of cells.

Overload List

Name | Description
Selection.Set (CellRange) | Sets the selection over the cells in the specified range.
Selection.Set (Int32, Int32) | Sets the selection over the cell at the specified coordinates.
Selection.Set (Int32, Int32, Int32, Int32) | Sets the selection over the range of cells at the specified coordinates.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Set Method (CellRange)

Selection.Set Method (CellRange)
See Also
[image]

Sets the selection over the cells in the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Set (
CellRange cellRange
)

Visual Basic [image] Copy Code

Public Sub Set( _
cellRange As CellRange _
)

Parameters

cellRange

A CellRange object specifying the cells to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Set Method (Int32, Int32)

Selection.Set Method (Int32, Int32)
See Also
[image]

Sets the selection over the cell at the specified coordinates.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Set (
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub Set( _
column As Integer, _
row As Integer _
)

Parameters

column

The zero-based index of the column of the cell to select.

row

The zero-based index of the row of the cell to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Set Method (Int32, Int32, Int32, Int32)

Selection.Set Method (Int32, Int32, Int32, Int32)
See Also
[image]

Sets the selection over the range of cells at the specified coordinates.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Set (
int column1,
int row1,
int column2,
int row2
)

Visual Basic [image] Copy Code

Public Sub Set( _
column1 As Integer, _
row1 As Integer, _
column2 As Integer, _
row2 As Integer _
)

Parameters

column1

The leftmost column of the range to select.

row1

The topmost row of the range to select.

column2

The rightmost column of the range to select.

row2

The bottommost row of the range to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Toggle Method

Selection.Toggle Method
[image]

Toggles the selection state of the specified object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Toggle (
InteractiveObject obj
)

Visual Basic [image] Copy Code

Public Sub Toggle( _
obj As InteractiveObject _
)

Parameters

obj

The object to select or deselect.

Remarks

Call this method to toggle an object's selection state. The method selects the object passed as argument if it was previously deselected. If the object was selected, the method deselects it.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
Bottom | Gets the index of the bottommost column of the selected cell range.
IsEmpty | Gets a value indicating whether the selection contains any cells.
Left | Gets the index of the leftmost column of the selected cell range.
Objects | Gets a list with the selected objects.
Range | Gets a CellRange object representing the selected range of cells, or null (Nothing in Visual Basic), if the selection is empty.
Right | Gets the index of the rightmost column of the selected cell range.
Top | Gets the index of the topmost column of the selected cell range.

See Also

Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Bottom Property

Selection.Bottom Property
[image]

Gets the index of the bottommost column of the selected cell range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Bottom { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bottom As Integer

Property Value

An integer value.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.IsEmpty Property

Selection.IsEmpty Property
[image]

Gets a value indicating whether the selection contains any cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if the selection contains at least one cell; otherwise, false.

Remarks

This property should return true only when the associated view does not display any worksheets. Otherwise the selection contains at least the currently active cell.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Left Property

Selection.Left Property
[image]

Gets the index of the leftmost column of the selected cell range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Left { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Left As Integer

Property Value

An integer value.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Objects Property

Selection.Objects Property
[image]

Gets a list with the selected objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IList<InteractiveObject> Objects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Objects As IList(Of InteractiveObject)

Property Value

A list of selected objects.

Remarks

The list returned by this property should not be modified directly. To select and deselect objects, use the appropriate methods of the Selection class - AddObject, RemoveObject, Toggle and Change.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Range Property

Selection.Range Property
[image]

Gets a CellRange object representing the selected range of cells, or null (Nothing in Visual Basic), if the selection is empty.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange Range { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Range As CellRange

Property Value

An instance of the CellRange class.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Right Property

Selection.Right Property
[image]

Gets the index of the rightmost column of the selected cell range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Right { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Right As Integer

Property Value

An integer value.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Selection.Top Property

Selection.Top Property
[image]

Gets the index of the topmost column of the selected cell range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Top { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Top As Integer

Property Value

An integer value.

See Also

Selection Members
Selection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs Class

SerializeColumnTagEventArgs Class
[image]

Provides data for the SerializeColumnTag and DeserializeColumnTag event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SerializeColumnTagEventArgs : ColumnEventArgs

Visual Basic [image] Copy Code

Public Class SerializeColumnTagEventArgs
Inherits ColumnEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ColumnEventArgs
MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs

See Also

SerializeColumnTagEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs Members

SerializeColumnTagEventArgs Members
Properties
[image]

Provides data for the SerializeColumnTag and DeserializeColumnTag event handlers.

The following tables list the members exposed by the SerializeColumnTagEventArgs type.

Public Properties

Name | Description
Column | Gets the related column. (Inherited from ColumnEventArgs.)
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Tag | Gets or sets the tag being serialized/deserialized.

See Also

SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs Properties

SerializeColumnTagEventArgs Properties
[image]

Public Properties

Name | Description
Column | Gets the related column. (Inherited from ColumnEventArgs.)
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Tag | Gets or sets the tag being serialized/deserialized.

See Also

SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs.Context Property

SerializeColumnTagEventArgs.Context Property
[image]

Gets the context object that enables you to write and read data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XmlContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlContext

Property Value

An instance of the XmlContext class.

See Also

SerializeColumnTagEventArgs Members
SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs.Handled Property

SerializeColumnTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event was handled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

A boolean value.

Remarks

Always set this flag to true if you perform custom data serialization.

See Also

SerializeColumnTagEventArgs Members
SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs.Representation Property

SerializeColumnTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the data being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

An instance of the .NET XElement class.

See Also

SerializeColumnTagEventArgs Members
SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeColumnTagEventArgs.Tag Property

SerializeColumnTagEventArgs.Tag Property
[image]

Gets or sets the tag being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the tag.

See Also

SerializeColumnTagEventArgs Members
SerializeColumnTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs Class

SerializeDataEventArgs Class
[image]

Provides data for the SerializeData and DeserializeData event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SerializeDataEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class SerializeDataEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.CellEventArgs
MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs

See Also

SerializeDataEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs Members

SerializeDataEventArgs Members
Properties
[image]

Provides data for the SerializeData and DeserializeData event handlers.

The following tables list the members exposed by the SerializeDataEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
Context | Gets the context object that enables you to write and read data.
Data | Gets or sets the data being serialized/deserialized.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.

See Also

SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs Properties

SerializeDataEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell related to the event. (Inherited from CellEventArgs.)
Context | Gets the context object that enables you to write and read data.
Data | Gets or sets the data being serialized/deserialized.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.

See Also

SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs.Context Property

SerializeDataEventArgs.Context Property
[image]

Gets the context object that enables you to write and read data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XmlContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlContext

Property Value

An instance of the XmlContext class.

See Also

SerializeDataEventArgs Members
SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs.Data Property

SerializeDataEventArgs.Data Property
[image]

Gets or sets the data being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Object

Property Value

An object representing the cell data.

See Also

SerializeDataEventArgs Members
SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs.Handled Property

SerializeDataEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event was handled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

A boolean value.

Remarks

Always set this flag to true if you perform custom data serialization.

See Also

SerializeDataEventArgs Members
SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeDataEventArgs.Representation Property

SerializeDataEventArgs.Representation Property
[image]

Gets or sets the string representation of the data being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

An instance of the .NET XElement class.

See Also

SerializeDataEventArgs Members
SerializeDataEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs Class

SerializeRowTagEventArgs Class
[image]

Provides data for the SerializeRowTag and DeserializeRowTag event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SerializeRowTagEventArgs : RowEventArgs

Visual Basic [image] Copy Code

Public Class SerializeRowTagEventArgs
Inherits RowEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.RowEventArgs
MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs

See Also

SerializeRowTagEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs Members

SerializeRowTagEventArgs Members
Properties
[image]

Provides data for the SerializeRowTag and DeserializeRowTag event handlers.

The following tables list the members exposed by the SerializeRowTagEventArgs type.

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Row | Gets the related row. (Inherited from RowEventArgs.)
Tag | Gets or sets the tag being serialized/deserialized.

See Also

SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs Properties

SerializeRowTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Row | Gets the related row. (Inherited from RowEventArgs.)
Tag | Gets or sets the tag being serialized/deserialized.

See Also

SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs.Context Property

SerializeRowTagEventArgs.Context Property
[image]

Gets the context object that enables you to write and read data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XmlContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlContext

Property Value

An instance of the XmlContext class.

See Also

SerializeRowTagEventArgs Members
SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs.Handled Property

SerializeRowTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event was handled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

A boolean value.

Remarks

Always set this flag to true if you perform custom data serialization.

See Also

SerializeRowTagEventArgs Members
SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs.Representation Property

SerializeRowTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the data being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

An instance of the .NET XElement class.

See Also

SerializeRowTagEventArgs Members
SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeRowTagEventArgs.Tag Property

SerializeRowTagEventArgs.Tag Property
[image]

Gets or sets the tag being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the tag.

See Also

SerializeRowTagEventArgs Members
SerializeRowTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Provides data for the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : WorksheetEventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits WorksheetEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.WorksheetEventArgs
MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Provides data for the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Tag | Gets or sets the tag being serialized/deserialized.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)

See Also

SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Representation | Gets or sets the string representation of the data being serialized/deserialized.
Tag | Gets or sets the tag being serialized/deserialized.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)

See Also

SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets the context object that enables you to write and read data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XmlContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlContext

Property Value

An instance of the XmlContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event was handled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

A boolean value.

Remarks

Always set this flag to true if you perform custom data serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the data being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

An instance of the .NET XElement class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag being serialized/deserialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the tag.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ShiftDirection Enumeration

ShiftDirection Enumeration
[image]

Specifies how the cells are moved when removing cells from a CellRange object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ShiftDirection

Visual Basic [image] Copy Code

Public Enum ShiftDirection

Members

Member name | Description
Left | Indicates that the cells to the right of the removed cells are moved to the left.
Up | Indicates that the cells below the removed cells are moved up.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortDirection Enumeration

SortDirection Enumeration
[image]

Specifies the direction of a sorting operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum SortDirection

Visual Basic [image] Copy Code

Public Enum SortDirection

Members

Member name | Description
LeftToRight | Indicates left-to-right direction. The sort keys represent rows.
TopToBottom | Indicates top-to-bottom direction. The sort keys represent columns.

Remarks

Members of this enumeration can be assigned to the Direction property of the SortOptions class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey Class

SortKey Class
Remarks See Also
[image]

Represents a key in a sorting operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SortKey

Visual Basic [image] Copy Code

Public Class SortKey

Remarks

Instances of this class can be added to the Keys collection of the SortOptions class.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.SortKey

See Also

SortKey Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey Members

SortKey Members
Constructors Properties
[image]

Represents a key in a sorting operation.

The following tables list the members exposed by the SortKey type.

Public Constructors

Name | Description
SortKey | Initializes a new instance of the SortKey class.

Public Properties

Name | Description
Index | Gets or sets the zero-based index of the column or row to sort by.
Order | Gets or sets the sort order, either ascending or descending.
TreatTextAsNumber | Gets or sets a value identifying whether to compare text values as numbers when possible.

See Also

SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey Constructor

SortKey Constructor
[image]

Initializes a new instance of the SortKey class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public SortKey (
int index
)

Visual Basic [image] Copy Code

Public New ( _
index As Integer _
)

Parameters

index

The zero-based index of the column or row to sort by.

See Also

SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey Properties

SortKey Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the zero-based index of the column or row to sort by.
Order | Gets or sets the sort order, either ascending or descending.
TreatTextAsNumber | Gets or sets a value identifying whether to compare text values as numbers when possible.

See Also

SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey.Index Property

SortKey.Index Property
[image]

Gets or sets the zero-based index of the column or row to sort by.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

Remarks

This property identifies either column or row index, depending on the value of the Direction property of the parent SortOptions.

See Also

SortKey Members
SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey.Order Property

SortKey.Order Property
[image]

Gets or sets the sort order, either ascending or descending.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public SortOrder Order { get; set; }

Visual Basic [image] Copy Code

Public Property Order As SortOrder

Property Value

A member of the SortOrder enumeration. The default is Ascending.

See Also

SortKey Members
SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortKey.TreatTextAsNumber Property

SortKey.TreatTextAsNumber Property
[image]

Gets or sets a value identifying whether to compare text values as numbers when possible.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool TreatTextAsNumber { get; set; }

Visual Basic [image] Copy Code

Public Property TreatTextAsNumber As Boolean

Property Value

true to compare texts representing numbers as numbers; false to compare all strings using ordinal comparison. The default is false.

See Also

SortKey Members
SortKey Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions Class

SortOptions Class
Remarks See Also
[image]

Specifies the order of a sorting operation, ascending or descending.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SortOptions

Visual Basic [image] Copy Code

Public Class SortOptions

Remarks

Instances of this class are passed as arguments to the Worksheet.Sort and CellRange.Sort methods to specify the sorting settings.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.SortOptions

See Also

SortOptions Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions Members

SortOptions Members
Constructors Properties
[image]

Specifies the order of a sorting operation, ascending or descending.

The following tables list the members exposed by the SortOptions type.

Public Constructors

Name | Description
SortOptions | Initializes a new instance of the SortOptions class.

Public Properties

Name | Description
CaseSensitive | Gets or sets a value indicating whether text value comparison is case-sensitive.
Direction | Gets or sets the sort direction.
Keys | Gets the sort keys - objects identifying which columns or rows to sort by and whether the sort is ascending or descending.
Locale | Gets or sets a CultureInfo object to use when parsing text values for keys with TreatTextAsNumber set to true.

See Also

SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions Constructor

SortOptions Constructor
[image]

Initializes a new instance of the SortOptions class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public SortOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions Properties

SortOptions Properties
[image]

Public Properties

Name | Description
CaseSensitive | Gets or sets a value indicating whether text value comparison is case-sensitive.
Direction | Gets or sets the sort direction.
Keys | Gets the sort keys - objects identifying which columns or rows to sort by and whether the sort is ascending or descending.
Locale | Gets or sets a CultureInfo object to use when parsing text values for keys with TreatTextAsNumber set to true.

See Also

SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions.CaseSensitive Property

SortOptions.CaseSensitive Property
[image]

Gets or sets a value indicating whether text value comparison is case-sensitive.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool CaseSensitive { get; set; }

Visual Basic [image] Copy Code

Public Property CaseSensitive As Boolean

Property Value

true to use case-sensitive comparison for strings; otherwise, false. The default is false.

See Also

SortOptions Members
SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions.Direction Property

SortOptions.Direction Property
[image]

Gets or sets the sort direction.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public SortDirection Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As SortDirection

Property Value

A member of the SortDirection enumeration. The default is TopToBottom.

See Also

SortOptions Members
SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions.Keys Property

SortOptions.Keys Property
[image]

Gets the sort keys - objects identifying which columns or rows to sort by and whether the sort is ascending or descending.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<SortKey> Keys { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Keys As List(Of SortKey)

Property Value

A list of SortKey objects.

Remarks

The sort keys are prioritized based on their order in this collection. The sorting is first performed using the key at position 0, then using the key at position 1, and so on. Keys identifying the same row or column and keys outside of the cell range being sorted, are ignored.

See Also

SortOptions Members
SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOptions.Locale Property

SortOptions.Locale Property
[image]

Gets or sets a CultureInfo object to use when parsing text values for keys with TreatTextAsNumber set to true.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; set; }

Visual Basic [image] Copy Code

Public Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class. The default is null (Nothing in Visual Basic).

Remarks

If this property is null, the parsing will be performed using the culture of the current worksheet.

See Also

SortOptions Members
SortOptions Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.SortOrder Enumeration

SortOrder Enumeration
[image]

Specifies the order of a sorting operation, ascending or descending.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum SortOrder

Visual Basic [image] Copy Code

Public Enum SortOrder

Members

Member name | Description
Ascending | Indicates that the items are sorted in ascending order.
Descending | Indicates that the items are sorted in descending order.

Remarks

Members of this enumeration can be assigned to the Order property of the SortKey class.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.StyleData Class

StyleData Class
[image]

Represents a copy of the cell styles in a worksheet region. Instances of this class can be obtained by calling the CopyStyles method of a Worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class StyleData : ISerializable

Visual Basic [image] Copy Code

Public Class StyleData
Implements ISerializable

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.StyleData

See Also

StyleData Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.StyleData Members

StyleData Members
[image]

Represents a copy of the cell styles in a worksheet region. Instances of this class can be obtained by calling the CopyStyles method of a Worksheet.

The following tables list the members exposed by the StyleData type.

See Also

StyleData Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand Class

TrackChangesCommand Class
[image]

Represents a command that can track and undo changes of INotifyPropertyValueChanged objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class TrackChangesCommand : DisposableCommand

Visual Basic [image] Copy Code

Public Class TrackChangesCommand
Inherits DisposableCommand

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Command
MindFusion.Spreadsheet.Wpf.DisposableCommand
MindFusion.Spreadsheet.Wpf.TrackChangesCommand
MindFusion.Spreadsheet.Wpf.ChangeWorksheetCommand

See Also

TrackChangesCommand Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand Members

TrackChangesCommand Members
Properties Methods
[image]

Represents a command that can track and undo changes of INotifyPropertyValueChanged objects.

The following tables list the members exposed by the TrackChangesCommand type.

Protected Properties

Name | Description
HasEffect | Command.HasEffect override.
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

Public Methods

Name | Description
Cancel | Cancels the command. (Inherited from DisposableCommand.)
Dispose | IDisposable.Dispose implementation. (Inherited from DisposableCommand.)

Protected Methods

Name | Description
BeginChange | Called before undoing or redoing the command.
EndChange | Called after undoing or redoing the command.
Execute | Command.Execute override. (Inherited from DisposableCommand.)
Redo | DisposableCommand.Redo override.
Undo | DisposableCommand.Undo override.

See Also

TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand Methods

TrackChangesCommand Methods
[image]

Public Methods

Name | Description
Cancel | Cancels the command. (Inherited from DisposableCommand.)
Dispose | IDisposable.Dispose implementation. (Inherited from DisposableCommand.)

Protected Methods

Name | Description
BeginChange | Called before undoing or redoing the command.
EndChange | Called after undoing or redoing the command.
Execute | Command.Execute override. (Inherited from DisposableCommand.)
Redo | DisposableCommand.Redo override.
Undo | DisposableCommand.Undo override.

See Also

TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand.BeginChange Method

TrackChangesCommand.BeginChange Method
[image]

Called before undoing or redoing the command.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void BeginChange ()

Visual Basic [image] Copy Code

Protected Overridable Sub BeginChange ()

See Also

TrackChangesCommand Members
TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand.EndChange Method

TrackChangesCommand.EndChange Method
[image]

Called after undoing or redoing the command.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void EndChange ()

Visual Basic [image] Copy Code

Protected Overridable Sub EndChange ()

See Also

TrackChangesCommand Members
TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand.Redo Method

TrackChangesCommand.Redo Method
[image]

DisposableCommand.Redo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

TrackChangesCommand Members
TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand.Undo Method

TrackChangesCommand.Undo Method
[image]

DisposableCommand.Undo override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

TrackChangesCommand Members
TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand Properties

TrackChangesCommand Properties
[image]

Protected Properties

Name | Description
HasEffect | Command.HasEffect override.
Workbook | Gets the Workbook modified by this Command object. (Inherited from Command.)

See Also

TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.TrackChangesCommand.HasEffect Property

TrackChangesCommand.HasEffect Property
[image]

Command.HasEffect override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override bool HasEffect { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasEffect As Boolean

Property Value

true if the command performs an actual modification; otherwise, false.

See Also

TrackChangesCommand Members
TrackChangesCommand Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T) Class

UndoableCollection(T) Class
[image]

Represents a strongly-typed collection that supports undo and redo.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class UndoableCollection<T> : IEnumerable<T>, IEnumerable, ICollection, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Class UndoableCollection(Of T)
Implements IEnumerable(Of T), IEnumerable, ICollection, INotifyCollectionChanged

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(T)
MindFusion.Spreadsheet.Wpf.MergedCellsCollection
MindFusion.Spreadsheet.Wpf.NamedCollection(T)
MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection

See Also

UndoableCollection(T) Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T) Members

UndoableCollection(T) Members
Properties Methods Events
[image]

Represents a strongly-typed collection that supports undo and redo.

The following tables list the members exposed by the UndoableCollection(T) type.

Public Properties

Name | Description
Count | Gets the number of items in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Item | Gets the item at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object.

Public Methods

Name | Description
Contains | Determines whether an element is in the collection.
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array.
GetEnumerator | IEnumerator.GetEnumerator implementation.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event.
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly.
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly.
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly.
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly.
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly.

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed.

See Also

UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T) Methods

UndoableCollection(T) Methods
[image]

Public Methods

Name | Description
Contains | Determines whether an element is in the collection.
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array.
GetEnumerator | IEnumerator.GetEnumerator implementation.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event.
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly.
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly.
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly.
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly.
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly.

See Also

UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).Contains Method

UndoableCollection(T).Contains Method
[image]

Determines whether an element is in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As T _
) As Boolean

Parameters

item

The item to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).CopyTo Method

UndoableCollection(T).CopyTo Method
[image]

Copies the elements of this collection to the specified array starting at the specified index within the array.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

A one-dimensional array that is the destination of the copied elements.

index

The zero-based index in array at which copying begins.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).GetEnumerator Method

UndoableCollection(T).GetEnumerator Method
[image]

IEnumerator.GetEnumerator implementation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of T)

Return Value

An IEnumerator instance that can be used to iterate through the collection.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).IndexOf Method

UndoableCollection(T).IndexOf Method
[image]

Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As T _
) As Integer

Parameters

item

The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of item within the collection, if found; otherwise, -1.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).OnCollectionChanged Method

UndoableCollection(T).OnCollectionChanged Method
[image]

Raises the CollectionChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).TrackAdd Method

UndoableCollection(T).TrackAdd Method
[image]

Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected void TrackAdd (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Sub TrackAdd( _
index As Integer, _
item As T _
)

Parameters

index

item

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).TrackClear Method

UndoableCollection(T).TrackClear Method
[image]

Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected void TrackClear ()

Visual Basic [image] Copy Code

Protected Sub TrackClear ()

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).TrackMove Method

UndoableCollection(T).TrackMove Method
[image]

Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected void TrackMove (
int fromIndex,
int toIndex,
T item
)

Visual Basic [image] Copy Code

Protected Sub TrackMove( _
fromIndex As Integer, _
toIndex As Integer, _
item As T _
)

Parameters

fromIndex

A zero-based index specifying the previous position of the item in the collection.

toIndex

A zero-based index specifying the new position of the item in the collection.

item

The item to move.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).TrackRemove Method

UndoableCollection(T).TrackRemove Method
[image]

Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected void TrackRemove (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Sub TrackRemove( _
index As Integer, _
item As T _
)

Parameters

index

A zero-based index specifying the position of the item in the collection.

item

The item to remove.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).TrackReplace Method

UndoableCollection(T).TrackReplace Method
[image]

Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected void TrackReplace (
int index,
T item,
T newItem
)

Visual Basic [image] Copy Code

Protected Sub TrackReplace( _
index As Integer, _
item As T, _
newItem As T _
)

Parameters

index

A zero-based index specifying the position of the item in the collection.

item

The previous item at the specified position.

newItem

The new item at the specified position.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T) Properties

UndoableCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items in the collection.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Item | Gets the item at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object.

See Also

UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).Count Property

UndoableCollection(T).Count Property
[image]

Gets the number of items in the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).IsSynchronized Property

UndoableCollection(T).IsSynchronized Property
[image]

Gets a value indicating whether access to the collection is synchronized (thread safe).

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).Item Property

UndoableCollection(T).Item Property
[image]

Gets the item at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public T Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As T

Parameters

index

The zero-based index of the item to get.

Property Value

The item at the specified index.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).SyncRoot Property

UndoableCollection(T).SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T).Workbook Property

UndoableCollection(T).Workbook Property
[image]

Gets a reference to the parent Workbook object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected Workbook Workbook { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Workbook As Workbook

Property Value

An instance of the Workbook class.

See Also

UndoableCollection(T) Members
UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoableCollection(T) Events

UndoableCollection(T) Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed.

See Also

UndoableCollection(T) Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.UndoEventArgs

See Also

UndoEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoEventArgs Members

UndoEventArgs Members
Properties
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Command Command { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of the Command class.

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationErrorAction Enumeration

ValidationErrorAction Enumeration
[image]

Specifies the action to perform when data validation fails.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ValidationErrorAction

Visual Basic [image] Copy Code

Public Enum ValidationErrorAction

Members

Member name | Description
Information | Indicates that an information message box will be displayed.
RaiseEvent | Indicates that an event will be raised.
Stop | Indicates that an error message box will be displayed.
Warning | Indicates that a warning message box will be displayed.

Remarks

Members of this enumeration can be assigned to the ErrorAction property of IValidation instances.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs Class

ValidationFailedEventArgs Class
[image]

Provides data for the ValidationFailed event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ValidationFailedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ValidationFailedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs

See Also

ValidationFailedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs Members

ValidationFailedEventArgs Members
Properties
[image]

Provides data for the ValidationFailed event.

The following tables list the members exposed by the ValidationFailedEventArgs type.

Public Properties

Name | Description
AcceptInput | Gets or sets a value indicating whether to accept the input.
Cell | Gets the edited cell.
Data | Gets the input that failed to validate.
Worksheet | Gets the worksheet that is the source of the event.

See Also

ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs Properties

ValidationFailedEventArgs Properties
[image]

Public Properties

Name | Description
AcceptInput | Gets or sets a value indicating whether to accept the input.
Cell | Gets the edited cell.
Data | Gets the input that failed to validate.
Worksheet | Gets the worksheet that is the source of the event.

See Also

ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs.AcceptInput Property

ValidationFailedEventArgs.AcceptInput Property
[image]

Gets or sets a value indicating whether to accept the input.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AcceptInput { get; set; }

Visual Basic [image] Copy Code

Public Property AcceptInput As Boolean

Property Value

true to accept the user input; false to reject it and retain the previous cell value. The default is true.

See Also

ValidationFailedEventArgs Members
ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs.Cell Property

ValidationFailedEventArgs.Cell Property
[image]

Gets the edited cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As Cell

Property Value

An instance of the Cell class.

See Also

ValidationFailedEventArgs Members
ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs.Data Property

ValidationFailedEventArgs.Data Property
[image]

Gets the input that failed to validate.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Data { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Data As String

Property Value

A string value representing the user input.

See Also

ValidationFailedEventArgs Members
ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationFailedEventArgs.Worksheet Property

ValidationFailedEventArgs.Worksheet Property
[image]

Gets the worksheet that is the source of the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

ValidationFailedEventArgs Members
ValidationFailedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.ValidationType Enumeration

ValidationType Enumeration
[image]

Specifies the type of data validation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ValidationType

Visual Basic [image] Copy Code

Public Enum ValidationType

Members

Member name | Description
AllValues | Indicates that there are no limitations.
Date | Indicates all dates corresponding to the condition.
Decimal | Indicates all numbers corresponding to the condition.
List | Indicates all values matching a predefined list of values.
Text | Indicates all text values corresponding to the condition.
TextLength | Indicates validation based on the length of the entered text.
Time | Indicates all times corresponding to the condition.
WholeNumber | Indicates only whole numbers corresponding to the condition.

Remarks

Members of this enumeration can be assigned to the Type property of IValidation instances.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.VerticalAlignment Enumeration

VerticalAlignment Enumeration
[image]

Specifies the vertical alignment of an element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum VerticalAlignment

Visual Basic [image] Copy Code

Public Enum VerticalAlignment

Members

Member name | Description
Bottom | Indicates that the element is aligned to the bottom side.
Default | Indicates the default alignment, usually dependent on the element's type.
Middle | Indicates that the element is aligned in the middle.
Top | Indicates that the element is aligned to the top side.

See Also

MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Class

Workbook Class
Remarks See Also
[image]

The main document class, contains a collection of worksheets, named ranges and other related objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Workbook : INotifyPropertyValueChanged, ISupportInitialize, IDocumentPaginatorSource

Visual Basic [image] Copy Code

Public Class Workbook
Implements INotifyPropertyValueChanged, ISupportInitialize, IDocumentPaginatorSource

Remarks

The Workbook class is used to manage a collection of related Worksheet and NamedRange objects, provides undo/redo and formula calculations.

The worksheets of the workbook can be accessed and managed through the Worksheets collection of the Workbook class. Worksheets are added to the workbook indirectly, through the Add method of this collection. Respectively, the NamedRange objects of the workbook are managed through the NamedRanges collection.

Undo and redo can be enabled and disabled through the UndoEnabled property. To undo or redo an action, use the Undo and Redo methods. To check if there is an action to be undone or redone, use the CanUndo and CanRedo properties. When an action is undone or redone, the ActionUndone or ActionRedone events are raised.

To specify the culture of the workbook and its associated worksheets, use the Locale property. This culture is used when parsing and formatting data in the worksheets. The default of this property is the culture of the current thread.

The workbook can be serialized to and deserialized from a stream or a file through the respective SaveToXml and LoadFromXml methods.

To display a workbook on a form, use the built-in WorkbookView control. To print a workbook, use the WorkbookPrinter class. To export or import a workbook, use the appropriate importer or exporter class - PdfExporter, CsvExporter, CsvImporter, CalcImporter, and ExcelImporter.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Workbook

See Also

Workbook Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Members

Workbook Members
Constructors Properties Methods Events
[image]

The main document class, contains a collection of worksheets, named ranges and other related objects.

The following tables list the members exposed by the Workbook type.

Public Constructors

Name | Description
Workbook | Initializes a new instance of the Workbook class.

Public Properties

Name | Description
CalculationMaxIterations | Gets or sets the maximum number of iterations when calculating certain functions, such as IRR and RATE.
CalculationPrecision | Gets or sets the precision when calculating certain functions, such as IRR and RATE.
CanRedo | Gets a value indicating whether there is a command in the undo history which can be redone.
CanUndo | Gets a value indicating whether there is a command in the undo history which can be undone.
CustomNumericFormats | Gets the workbook user defined custom numeric formats.
DefaultNumericFormats | Gets the workbook defined default numeric formats.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
EnableFormulaEvaluation | Gets or sets a value indicating whether formula evaluation is enabled.
EnableTypeInference | Gets or sets a value indicating whether cell data is automatically interpreted as a value of a specific type, or accepted as text.
ExtendedEvaluator | Gets or sets a custom expression evaluator. Identifier and function calls that cannot be resolved by the core are delegated to this evaluator.
ExtendedInformationProvider | Gets or sets an information provider for custom functions.
Locale | Gets or sets the workbook locale.
NamedRanges | Gets an object that an be used to manage the named ranges in this workbook.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.
Worksheets | Gets an object that can be used to create and manage the worksheets in this workbook.

Public Methods

Name | Description
CancelChangeOperation | Stops tracking changes by the specified command and reverts all changes done so far.
CancelCompositeOperation | Stops recording the most recently started composite operation and discards the records created so far.
CommitChangeOperation | Stops tracking changes by the specified command and saves the command in the history queue.
CommitCompositeOperation | Stops recording the most recently started composite operation and saves the composite in the history queue.
EvaluateFormulas | Reevaluates all formulas containing custom and volatile functions and their dependent cells.
ExecuteCommand | Executes the specified command on this workbook.
Find | Performs a search for a cell containing the specified text, using the specified criteria.
FindAll | Finds and returns all cells containing the specified text, using the specified criteria.
LoadFromXml | Overloaded. Loads a workbook from an XML file or document.
Redo | Executes again an action saved in the command history.
Replace | Replaces the data of the specified cell if it matches the specified criteria and returns the next matching cell.
ReplaceAll | Replaces the data of all cells matching the specified criteria.
SaveToXml | Overloaded. Saves a workbook to an XML file or document.
SetLocalizationInfo | Localizes the UI elements that are related to this workbook with the strings contained in the specified XML file.
StartChangeOperation | Creates a Command object to track subsequent changes on the specified target. The returned command will be automatically executed when disposed.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeColumnTag | Raises the DeserializeColumnTag event.
OnDeserializeData | Raises the DeserializeData event.
OnDeserializeRowTag | Raises the DeserializeRowTag event.
OnDeserializeTag | Raises the DeserializeData event.
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnSerializeColumnTag | Raises the SerializeColumnTag event.
OnSerializeData | Raises the SerializeData event.
OnSerializeRowTag | Raises the SerializeRowTag event.
OnSerializeTag | Raises the SerializeTag event.
OnWorksheetCellChanged | Raises the WorksheetCellChanged event.
OnWorksheetCellChanging | Raises the WorksheetCellChanging event.
OnWorksheetCellsCleared | Raises the WorksheetCellsCleared event.
OnWorksheetChanged | Raises the WorksheetChanged event.
OnWorksheetColumnChanged | Raises the WorksheetColumnChanged event.
OnWorksheetRowChanged | Raises the WorksheetRowChanged event.
OnWorksheetValidationFailed | Raises the WorksheetValidationFailed event.

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
DeserializeColumnTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
DeserializeData | Raised during XML deserialization to enable users to perform custom deserialization of the data values of cells.
DeserializeRowTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
PropertyValueChanged | Raised when a property of this object is changed.
SerializeColumnTag | Raised during XML serialization to enable users to perform custom serialization of tags.
SerializeData | Raised during XML serialization to enable users to perform custom serialization of the data values of cells.
SerializeRowTag | Raised during XML serialization to enable users to perform custom serialization of tags.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of tags.
WorksheetCellChanged | Raised when a cell of one of the worksheets is changed.
WorksheetCellChanging | Raised when a cell of one of the worksheets is about to change.
WorksheetCellsCleared | Raised when a range of cells in one of the worksheets has been cleared.
WorksheetChanged | Raised when a property of one of the worksheets in this workbook is changed.
WorksheetColumnChanged | Raised when a column in one of the worksheets is changed.
WorksheetRowChanged | Raised when a row in one of the worksheets is changed.
WorksheetValidationFailed | Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

See Also

Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Constructor

Workbook Constructor
[image]

Initializes a new instance of the Workbook class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Workbook ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Methods

Workbook Methods
[image]

Public Methods

Name | Description
CancelChangeOperation | Stops tracking changes by the specified command and reverts all changes done so far.
CancelCompositeOperation | Stops recording the most recently started composite operation and discards the records created so far.
CommitChangeOperation | Stops tracking changes by the specified command and saves the command in the history queue.
CommitCompositeOperation | Stops recording the most recently started composite operation and saves the composite in the history queue.
EvaluateFormulas | Reevaluates all formulas containing custom and volatile functions and their dependent cells.
ExecuteCommand | Executes the specified command on this workbook.
Find | Performs a search for a cell containing the specified text, using the specified criteria.
FindAll | Finds and returns all cells containing the specified text, using the specified criteria.
LoadFromXml | Overloaded. Loads a workbook from an XML file or document.
Redo | Executes again an action saved in the command history.
Replace | Replaces the data of the specified cell if it matches the specified criteria and returns the next matching cell.
ReplaceAll | Replaces the data of all cells matching the specified criteria.
SaveToXml | Overloaded. Saves a workbook to an XML file or document.
SetLocalizationInfo | Localizes the UI elements that are related to this workbook with the strings contained in the specified XML file.
StartChangeOperation | Creates a Command object to track subsequent changes on the specified target. The returned command will be automatically executed when disposed.
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeColumnTag | Raises the DeserializeColumnTag event.
OnDeserializeData | Raises the DeserializeData event.
OnDeserializeRowTag | Raises the DeserializeRowTag event.
OnDeserializeTag | Raises the DeserializeData event.
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnSerializeColumnTag | Raises the SerializeColumnTag event.
OnSerializeData | Raises the SerializeData event.
OnSerializeRowTag | Raises the SerializeRowTag event.
OnSerializeTag | Raises the SerializeTag event.
OnWorksheetCellChanged | Raises the WorksheetCellChanged event.
OnWorksheetCellChanging | Raises the WorksheetCellChanging event.
OnWorksheetCellsCleared | Raises the WorksheetCellsCleared event.
OnWorksheetChanged | Raises the WorksheetChanged event.
OnWorksheetColumnChanged | Raises the WorksheetColumnChanged event.
OnWorksheetRowChanged | Raises the WorksheetRowChanged event.
OnWorksheetValidationFailed | Raises the WorksheetValidationFailed event.

See Also

Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CancelChangeOperation Method

Workbook.CancelChangeOperation Method
[image]

Stops tracking changes by the specified command and reverts all changes done so far.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CancelChangeOperation (
TrackChangesCommand command
)

Visual Basic [image] Copy Code

Public Sub CancelChangeOperation( _
command As TrackChangesCommand _
)

Parameters

command

The command to cancel.

Remarks

The usual scenario for cancelling a command is when an exception happens while the command is active. The code below illustrates this scenario.

C# [image] Copy Code

var command = workbook.StartChangeOperation(worksheet);
try
{
// Changes on the worksheet go here
workbook.CommitChangeOperation(command);
}
catch
{
workbook.CancelChangeOperation(command);
}

Visual Basic [image] Copy Code

Dim command = workbook.StartChangeOperation(worksheet)
Try

' Changes on the worksheet go here
workbook.CommitChangeOperation(command)

Catch

workbook.CancelChangeOperation(command)

End Try

Alternatively, the command can be cancelled by calling its Cancel method.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CancelCompositeOperation Method

Workbook.CancelCompositeOperation Method
[image]

Stops recording the most recently started composite operation and discards the records created so far.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CancelCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CancelCompositeOperation ()

Remarks

The usual scenario for cancelling a composite command is when an exception happens while the command is active. The code below illustrates this scenario.

C# [image] Copy Code

var command = workbook.StartCompositeOperation();
try
{
// Operations go here
workbook.CommitCompositeOperation();
}
catch
{
workbook.CancelCompositeOperation();
}

Visual Basic [image] Copy Code

Dim command = workbook.StartCompositeOperation()
Try

' Changes on the worksheet go here
workbook.CommitCompositeOperation()

Catch

workbook.CancelCompositeOperation()

End Try

Alternatively, the command can be cancelled by calling its Cancel method.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CommitChangeOperation Method

Workbook.CommitChangeOperation Method
[image]

Stops tracking changes by the specified command and saves the command in the history queue.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CommitChangeOperation (
TrackChangesCommand command
)

Visual Basic [image] Copy Code

Public Sub CommitChangeOperation( _
command As TrackChangesCommand _
)

Parameters

command

The command to commit.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CommitCompositeOperation Method

Workbook.CommitCompositeOperation Method
[image]

Stops recording the most recently started composite operation and saves the composite in the history queue.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void CommitCompositeOperation ()

Visual Basic [image] Copy Code

Public Sub CommitCompositeOperation ()

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.EvaluateFormulas Method

Workbook.EvaluateFormulas Method
[image]

Reevaluates all formulas containing custom and volatile functions and their dependent cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void EvaluateFormulas ()

Visual Basic [image] Copy Code

Public Sub EvaluateFormulas ()

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ExecuteCommand Method

Workbook.ExecuteCommand Method
[image]

Executes the specified command on this workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command command
)

Visual Basic [image] Copy Code

Public Sub ExecuteCommand( _
command As Command _
)

Parameters

command

The Command to execute.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Find Method

Workbook.Find Method
[image]

Performs a search for a cell containing the specified text, using the specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Find (
string search,
Cell reference,
FindWithin findWithin,
LookIn lookIn,
SearchOrder order,
SearchDirection direction,
bool matchCase,
bool wholeCells
)

Visual Basic [image] Copy Code

Public Function Find( _
search As String, _
reference As Cell, _
findWithin As FindWithin, _
lookIn As LookIn, _
order As SearchOrder, _
direction As SearchDirection, _
matchCase As Boolean, _
wholeCells As Boolean _
) As Cell

Parameters

search

The text to search.

reference

The cell to start the search from.

findWithin

The target of the search - the referenced worksheet or the entire workbook.

lookIn

Specifies whether to search in the cell's formula or value.

order

The search order - horizontal or vertical.

direction

The search direction - forward or backward.

matchCase

Specifies whether the search should be case-sensitive.

wholeCells

Specifies whether to match entire cells only.

Return Value

A Cell object representing the found cell, or null (Nothing in Visual Basic), if the text was not found.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.FindAll Method

Workbook.FindAll Method
[image]

Finds and returns all cells containing the specified text, using the specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<Cell> FindAll (
string search,
Worksheet reference,
FindWithin findWithin,
LookIn lookIn,
SearchOrder order,
SearchDirection direction,
bool matchCase,
bool wholeCells
)

Visual Basic [image] Copy Code

Public Function FindAll( _
search As String, _
reference As Worksheet, _
findWithin As FindWithin, _
lookIn As LookIn, _
order As SearchOrder, _
direction As SearchDirection, _
matchCase As Boolean, _
wholeCells As Boolean _
) As IEnumerable(Of Cell)

Parameters

search

The text to search.

reference

The worksheet to search.

findWithin

The target of the search - the specified worksheet or the entire workbook.

lookIn

Specifies whether to search in the cell's formula or value.

order

The search order - horizontal or vertical.

direction

The search direction - forward or backward.

matchCase

Specifies whether the search should be case-sensitive.

wholeCells

Specifies whether to match entire cells only.

Return Value

An enumerable containing the found cells.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.LoadFromXml Method

Workbook.LoadFromXml Method
[image]

Loads a workbook from an XML file or document.

Overload List

Name | Description
Workbook.LoadFromXml (String) | Loads the workbook from an XML file.
Workbook.LoadFromXml (XDocument) | Loads the workbook from an XML document.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.LoadFromXml Method (String)

Workbook.LoadFromXml Method (String)
See Also
[image]

Loads the workbook from an XML file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the file to load from.

See Also

LoadFromXml Method Overload List
Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.LoadFromXml Method (XDocument)

Workbook.LoadFromXml Method (XDocument)
See Also
[image]

Loads the workbook from an XML document.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
document As XDocument _
)

Parameters

document

The .NET XDocument to load from.

See Also

LoadFromXml Method Overload List
Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnActionRedone Method

Workbook.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionRedone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionRedone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnActionUndone Method

Workbook.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActionUndone (
UndoEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActionUndone( _
e As UndoEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnDeserializeColumnTag Method

Workbook.OnDeserializeColumnTag Method
[image]

Raises the DeserializeColumnTag event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeColumnTag (
SerializeColumnTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeColumnTag( _
e As SerializeColumnTagEventArgs _
)

Parameters

e

An instance of the SerializeColumnTagEventArgs class that contains data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnDeserializeData Method

Workbook.OnDeserializeData Method
[image]

Raises the DeserializeData event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeData (
SerializeDataEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeData( _
e As SerializeDataEventArgs _
)

Parameters

e

An instance of the SerializeDataEventArgs class that contains data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnDeserializeRowTag Method

Workbook.OnDeserializeRowTag Method
[image]

Raises the DeserializeRowTag event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeRowTag (
SerializeRowTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeRowTag( _
e As SerializeRowTagEventArgs _
)

Parameters

e

An instance of the SerializeRowTagEventArgs class that contains data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnDeserializeTag Method

Workbook.OnDeserializeTag Method
[image]

Raises the DeserializeData event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An instance of the SerializeDataEventArgs class that contains data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnPropertyValueChanged Method

Workbook.OnPropertyValueChanged Method
[image]

Raises the PropertyValueChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyValueChanged (
PropertyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyValueChanged( _
e As PropertyEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnSerializeColumnTag Method

Workbook.OnSerializeColumnTag Method
[image]

Raises the SerializeColumnTag event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeColumnTag (
SerializeColumnTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeColumnTag( _
e As SerializeColumnTagEventArgs _
)

Parameters

e

An instance of the SerializeColumnTagEventArgs class that provides data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnSerializeData Method

Workbook.OnSerializeData Method
[image]

Raises the SerializeData event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeData (
SerializeDataEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeData( _
e As SerializeDataEventArgs _
)

Parameters

e

An instance of the SerializeDataEventArgs class that provides data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnSerializeRowTag Method

Workbook.OnSerializeRowTag Method
[image]

Raises the SerializeRowTag event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeRowTag (
SerializeRowTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeRowTag( _
e As SerializeRowTagEventArgs _
)

Parameters

e

An instance of the SerializeRowTagEventArgs class that provides data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnSerializeTag Method

Workbook.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An instance of the SerializeDataEventArgs class that provides data for the event.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetCellChanged Method

Workbook.OnWorksheetCellChanged Method
[image]

Raises the WorksheetCellChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetCellChanged (
CellChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetCellChanged( _
e As CellChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetCellChanging Method

Workbook.OnWorksheetCellChanging Method
[image]

Raises the WorksheetCellChanging event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetCellChanging (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetCellChanging( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetCellsCleared Method

Workbook.OnWorksheetCellsCleared Method
[image]

Raises the WorksheetCellsCleared event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetCellsCleared (
WorksheetEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetCellsCleared( _
e As WorksheetEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetChanged Method

Workbook.OnWorksheetChanged Method
[image]

Raises the WorksheetChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetChanged (
WorksheetChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetChanged( _
e As WorksheetChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetColumnChanged Method

Workbook.OnWorksheetColumnChanged Method
[image]

Raises the WorksheetColumnChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetColumnChanged (
ColumnChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetColumnChanged( _
e As ColumnChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetRowChanged Method

Workbook.OnWorksheetRowChanged Method
[image]

Raises the WorksheetRowChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetRowChanged (
RowChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetRowChanged( _
e As RowChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.OnWorksheetValidationFailed Method

Workbook.OnWorksheetValidationFailed Method
[image]

Raises the WorksheetValidationFailed event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetValidationFailed (
ValidationFailedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetValidationFailed( _
e As ValidationFailedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Redo Method

Workbook.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Redo ()

Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

To check if there is currently an action that can be redone, use the CanRedo property. Calling Redo when CanRedo is false has no effect.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Replace Method

Workbook.Replace Method
[image]

Replaces the data of the specified cell if it matches the specified criteria and returns the next matching cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell Replace (
string search,
string replaceWith,
Cell cell,
FindWithin findWithin,
SearchOrder order,
SearchDirection direction,
bool matchCase,
bool wholeCells
)

Visual Basic [image] Copy Code

Public Function Replace( _
search As String, _
replaceWith As String, _
cell As Cell, _
findWithin As FindWithin, _
order As SearchOrder, _
direction As SearchDirection, _
matchCase As Boolean, _
wholeCells As Boolean _
) As Cell

Parameters

search

The text to search and replace.

replaceWith

The value to replace with.

cell

The cell containing the data to replace.

findWithin

The target of the replace operation - the referenced worksheet or the entire workbook.

order

The replace order - horizontal or vertical.

direction

The replace direction - forward or backward.

matchCase

Specifies whether the match should be case-sensitive.

wholeCells

Specifies whether to match entire cells only.

Return Value

A Cell object representing the next matching cell, or null (Nothing in Visual Basic), if the text was not found or if the specified cell does not match.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ReplaceAll Method

Workbook.ReplaceAll Method
[image]

Replaces the data of all cells matching the specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ReplaceAll (
string search,
string replaceWith,
Worksheet reference,
FindWithin findWithin,
bool matchCase,
bool wholeCells
)

Visual Basic [image] Copy Code

Public Sub ReplaceAll( _
search As String, _
replaceWith As String, _
reference As Worksheet, _
findWithin As FindWithin, _
matchCase As Boolean, _
wholeCells As Boolean _
)

Parameters

search

The text to search and replace.

replaceWith

The text to replace with.

reference

The worksheet to search.

findWithin

The target of the replace operation - the specified worksheet or the entire workbook.

matchCase

Specifies whether the search should be case-sensitive.

wholeCells

Specifies whether to match entire cells only.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SaveToXml Method

Workbook.SaveToXml Method
[image]

Saves a workbook to an XML file or document.

Overload List

Name | Description
Workbook.SaveToXml (String) | Saves the workbook into an XML file.
Workbook.SaveToXml (XDocument) | Saves the workbook into an XML document.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SaveToXml Method (String)

Workbook.SaveToXml Method (String)
See Also
[image]

Saves the workbook into an XML file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file to save to.

See Also

SaveToXml Method Overload List
Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SaveToXml Method (XDocument)

Workbook.SaveToXml Method (XDocument)
See Also
[image]

Saves the workbook into an XML document.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public virtual void SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveToXml( _
document As XDocument _
)

Parameters

document

The .NET XDocument to save to.

See Also

SaveToXml Method Overload List
Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SetLocalizationInfo Method

Workbook.SetLocalizationInfo Method
[image]

Localizes the UI elements that are related to this workbook with the strings contained in the specified XML file.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SetLocalizationInfo (
string xmlFile
)

Visual Basic [image] Copy Code

Public Sub SetLocalizationInfo( _
xmlFile As String _
)

Parameters

xmlFile

A XML file containing the localization strings.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.StartChangeOperation Method

Workbook.StartChangeOperation Method
[image]

Creates a Command object to track subsequent changes on the specified target. The returned command will be automatically executed when disposed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public TrackChangesCommand StartChangeOperation (
INotifyPropertyValueChanged target
)

Visual Basic [image] Copy Code

Public Function StartChangeOperation( _
target As INotifyPropertyValueChanged _
) As TrackChangesCommand

Parameters

target

The object to track.

Return Value

A TrackChangesCommand that is used to track the changes, or null (Nothing in Visual Basic), if undo is disabled.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.StartCompositeOperation Method

Workbook.StartCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CompositeCommand StartCompositeOperation ()

Visual Basic [image] Copy Code

Public Function StartCompositeOperation () As CompositeCommand

Return Value

An instance of the CompositeCommand class.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Undo Method

Workbook.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Undo ()

Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

To check if there is currently an action that can be undone, use the CanUndo property. Calling Undo when CanUndo is false has no effect.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Properties

Workbook Properties
[image]

Public Properties

Name | Description
CalculationMaxIterations | Gets or sets the maximum number of iterations when calculating certain functions, such as IRR and RATE.
CalculationPrecision | Gets or sets the precision when calculating certain functions, such as IRR and RATE.
CanRedo | Gets a value indicating whether there is a command in the undo history which can be redone.
CanUndo | Gets a value indicating whether there is a command in the undo history which can be undone.
CustomNumericFormats | Gets the workbook user defined custom numeric formats.
DefaultNumericFormats | Gets the workbook defined default numeric formats.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
EnableFormulaEvaluation | Gets or sets a value indicating whether formula evaluation is enabled.
EnableTypeInference | Gets or sets a value indicating whether cell data is automatically interpreted as a value of a specific type, or accepted as text.
ExtendedEvaluator | Gets or sets a custom expression evaluator. Identifier and function calls that cannot be resolved by the core are delegated to this evaluator.
ExtendedInformationProvider | Gets or sets an information provider for custom functions.
Locale | Gets or sets the workbook locale.
NamedRanges | Gets an object that an be used to manage the named ranges in this workbook.
PrintOptions | Gets an object which provides customization properties for printing and print-preview.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.
Worksheets | Gets an object that can be used to create and manage the worksheets in this workbook.

See Also

Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CalculationMaxIterations Property

Workbook.CalculationMaxIterations Property
[image]

Gets or sets the maximum number of iterations when calculating certain functions, such as IRR and RATE.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int CalculationMaxIterations { get; set; }

Visual Basic [image] Copy Code

Public Property CalculationMaxIterations As Integer

Property Value

An integer value. The default is 128.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CalculationPrecision Property

Workbook.CalculationPrecision Property
[image]

Gets or sets the precision when calculating certain functions, such as IRR and RATE.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double CalculationPrecision { get; set; }

Visual Basic [image] Copy Code

Public Property CalculationPrecision As Double

Property Value

A double value. The default is 1.0e-08.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CanRedo Property

Workbook.CanRedo Property
[image]

Gets a value indicating whether there is a command in the undo history which can be redone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool CanRedo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanRedo As Boolean

Property Value

true if there is a command in the history that can be redone; otherwise, false.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CanUndo Property

Workbook.CanUndo Property
[image]

Gets a value indicating whether there is a command in the undo history which can be undone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool CanUndo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanUndo As Boolean

Property Value

true if there is a command in the history that can be undone; otherwise, false.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.CustomNumericFormats Property

Workbook.CustomNumericFormats Property
[image]

Gets the workbook user defined custom numeric formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public List<NumericFormatInfo> CustomNumericFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CustomNumericFormats As List(Of NumericFormatInfo)

Property Value

A list of NumericFormatInfo objects.

Remarks

This property is initialized with the defined locale for the workbook.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DefaultNumericFormats Property

Workbook.DefaultNumericFormats Property
[image]

Gets the workbook defined default numeric formats.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DefaultNumericFormats DefaultNumericFormats { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DefaultNumericFormats As DefaultNumericFormats

Property Value

An instance of the DefaultNumericFormats class.

Remarks

This property is initialized with the defined locale for the workbook.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DocumentPaginator Property

Workbook.DocumentPaginator Property
[image]

IDocumentPaginatorSource.DocumentPaginator implementation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

An instance of the DocumentPaginator class.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.EnableFormulaEvaluation Property

Workbook.EnableFormulaEvaluation Property
[image]

Gets or sets a value indicating whether formula evaluation is enabled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnableFormulaEvaluation { get; set; }

Visual Basic [image] Copy Code

Public Property EnableFormulaEvaluation As Boolean

Property Value

A boolean value.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.EnableTypeInference Property

Workbook.EnableTypeInference Property
[image]

Gets or sets a value indicating whether cell data is automatically interpreted as a value of a specific type, or accepted as text.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnableTypeInference { get; set; }

Visual Basic [image] Copy Code

Public Property EnableTypeInference As Boolean

Property Value

A boolean value.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ExtendedEvaluator Property

Workbook.ExtendedEvaluator Property
[image]

Gets or sets a custom expression evaluator. Identifier and function calls that cannot be resolved by the core are delegated to this evaluator.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IExpressionEvaluator ExtendedEvaluator { get; set; }

Visual Basic [image] Copy Code

Public Property ExtendedEvaluator As IExpressionEvaluator

Property Value

An IExpressionEvaluator instance.

Remarks

You can assign to this property an instance of a custom class implementing the IExpressionEvaluator interface or an ExpressionEvaluatorList object that can contain more than one custom evaluator.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ExtendedInformationProvider Property

Workbook.ExtendedInformationProvider Property
[image]

Gets or sets an information provider for custom functions.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IInformationProvider ExtendedInformationProvider { get; set; }

Visual Basic [image] Copy Code

Public Property ExtendedInformationProvider As IInformationProvider

Property Value

An IExpressionEvaluator instance.

Remarks

This property can be used to specify tooltip information for custom functions during formula editing, or to localize the information of the built-in functions.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Locale Property

Workbook.Locale Property
[image]

Gets or sets the workbook locale.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; set; }

Visual Basic [image] Copy Code

Public Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class. The default is the culture of the current thread.

Remarks

The culture assigned to this property is used to parse and format values across the worksheets associated with the workbook.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.NamedRanges Property

Workbook.NamedRanges Property
[image]

Gets an object that an be used to manage the named ranges in this workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public NamedRangeCollection NamedRanges { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NamedRanges As NamedRangeCollection

Property Value

An instance of the NamedRangeCollection class.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.PrintOptions Property

Workbook.PrintOptions Property
[image]

Gets an object which provides customization properties for printing and print-preview.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public PaginationOptions PrintOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PrintOptions As PaginationOptions

Property Value

An instance of the PaginationOptions class.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.UndoEnabled Property

Workbook.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

true if undo/redo is enabled; otherwise, false.

Remarks

To undo the last recorded action, call the Undo method. It can be redone again by calling Redo. Custom operations can be integrated into the MindFusion.Spreadsheet for WPF undo/redo system by deriving from the Command class and running the operations by means of the ExecuteCommand method.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.Worksheets Property

Workbook.Worksheets Property
[image]

Gets an object that can be used to create and manage the worksheets in this workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorksheetCollection Worksheets { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheets As WorksheetCollection

Property Value

An instance of the WorksheetCollection class.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook Events

Workbook Events
[image]

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
DeserializeColumnTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
DeserializeData | Raised during XML deserialization to enable users to perform custom deserialization of the data values of cells.
DeserializeRowTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of tags.
PropertyValueChanged | Raised when a property of this object is changed.
SerializeColumnTag | Raised during XML serialization to enable users to perform custom serialization of tags.
SerializeData | Raised during XML serialization to enable users to perform custom serialization of the data values of cells.
SerializeRowTag | Raised during XML serialization to enable users to perform custom serialization of tags.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of tags.
WorksheetCellChanged | Raised when a cell of one of the worksheets is changed.
WorksheetCellChanging | Raised when a cell of one of the worksheets is about to change.
WorksheetCellsCleared | Raised when a range of cells in one of the worksheets has been cleared.
WorksheetChanged | Raised when a property of one of the worksheets in this workbook is changed.
WorksheetColumnChanged | Raised when a column in one of the worksheets is changed.
WorksheetRowChanged | Raised when a row in one of the worksheets is changed.
WorksheetValidationFailed | Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

See Also

Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ActionRedone Event

Workbook.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone

Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Event Data

ActionRedone event handlers receive an argument of type UndoEventArgs.

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.ActionUndone Event

Workbook.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone

Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Event Data

ActionUndone event handlers receive an argument of type UndoEventArgs.

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DeserializeColumnTag Event

Workbook.DeserializeColumnTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeColumnTagEventArgs> DeserializeColumnTag

Visual Basic [image] Copy Code

Public Event DeserializeColumnTag As EventHandler(Of SerializeColumnTagEventArgs)

Event Data

DeserializeColumnTag event handlers receive an argument of type SerializeColumnTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DeserializeData Event

Workbook.DeserializeData Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of the data values of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataEventArgs> DeserializeData

Visual Basic [image] Copy Code

Public Event DeserializeData As EventHandler(Of SerializeDataEventArgs)

Event Data

DeserializeData event handlers receive an argument of type SerializeDataEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DeserializeRowTag Event

Workbook.DeserializeRowTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeRowTagEventArgs> DeserializeRowTag

Visual Basic [image] Copy Code

Public Event DeserializeRowTag As EventHandler(Of SerializeRowTagEventArgs)

Event Data

DeserializeRowTag event handlers receive an argument of type SerializeRowTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.DeserializeTag Event

Workbook.DeserializeTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.PropertyValueChanged Event

Workbook.PropertyValueChanged Event
[image]

Raised when a property of this object is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Public Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

Event Data

PropertyValueChanged event handlers receive an argument of type PropertyEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SerializeColumnTag Event

Workbook.SerializeColumnTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeColumnTagEventArgs> SerializeColumnTag

Visual Basic [image] Copy Code

Public Event SerializeColumnTag As EventHandler(Of SerializeColumnTagEventArgs)

Event Data

SerializeColumnTag event handlers receive an argument of type SerializeColumnTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SerializeData Event

Workbook.SerializeData Event
[image]

Raised during XML serialization to enable users to perform custom serialization of the data values of cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeDataEventArgs> SerializeData

Visual Basic [image] Copy Code

Public Event SerializeData As EventHandler(Of SerializeDataEventArgs)

Event Data

SerializeData event handlers receive an argument of type SerializeDataEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SerializeRowTag Event

Workbook.SerializeRowTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeRowTagEventArgs> SerializeRowTag

Visual Basic [image] Copy Code

Public Event SerializeRowTag As EventHandler(Of SerializeRowTagEventArgs)

Event Data

SerializeRowTag event handlers receive an argument of type SerializeRowTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.SerializeTag Event

Workbook.SerializeTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of tags.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetCellChanged Event

Workbook.WorksheetCellChanged Event
[image]

Raised when a cell of one of the worksheets is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellChangedEventArgs> WorksheetCellChanged

Visual Basic [image] Copy Code

Public Event WorksheetCellChanged As EventHandler(Of CellChangedEventArgs)

Event Data

WorksheetCellChanged event handlers receive an argument of type CellChangedEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetCellChanging Event

Workbook.WorksheetCellChanging Event
[image]

Raised when a cell of one of the worksheets is about to change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> WorksheetCellChanging

Visual Basic [image] Copy Code

Public Event WorksheetCellChanging As EventHandler(Of CellValidationEventArgs)

Event Data

WorksheetCellChanging event handlers receive an argument of type CellValidationEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetCellsCleared Event

Workbook.WorksheetCellsCleared Event
[image]

Raised when a range of cells in one of the worksheets has been cleared.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<WorksheetEventArgs> WorksheetCellsCleared

Visual Basic [image] Copy Code

Public Event WorksheetCellsCleared As EventHandler(Of WorksheetEventArgs)

Event Data

WorksheetCellsCleared event handlers receive an argument of type WorksheetEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetChanged Event

Workbook.WorksheetChanged Event
[image]

Raised when a property of one of the worksheets in this workbook is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<WorksheetChangedEventArgs> WorksheetChanged

Visual Basic [image] Copy Code

Public Event WorksheetChanged As EventHandler(Of WorksheetChangedEventArgs)

Event Data

WorksheetChanged event handlers receive an argument of type WorksheetChangedEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetColumnChanged Event

Workbook.WorksheetColumnChanged Event
[image]

Raised when a column in one of the worksheets is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnChangedEventArgs> WorksheetColumnChanged

Visual Basic [image] Copy Code

Public Event WorksheetColumnChanged As EventHandler(Of ColumnChangedEventArgs)

Event Data

WorksheetColumnChanged event handlers receive an argument of type ColumnChangedEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetRowChanged Event

Workbook.WorksheetRowChanged Event
[image]

Raised when a row in one of the worksheets is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowChangedEventArgs> WorksheetRowChanged

Visual Basic [image] Copy Code

Public Event WorksheetRowChanged As EventHandler(Of RowChangedEventArgs)

Event Data

WorksheetRowChanged event handlers receive an argument of type RowChangedEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Workbook.WorksheetValidationFailed Event

Workbook.WorksheetValidationFailed Event
[image]

Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ValidationFailedEventArgs> WorksheetValidationFailed

Visual Basic [image] Copy Code

Public Event WorksheetValidationFailed As EventHandler(Of ValidationFailedEventArgs)

Event Data

WorksheetValidationFailed event handlers receive an argument of type ValidationFailedEventArgs.

See Also

Workbook Members
Workbook Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter Class

WorkbookPrinter Class
[image]

Provides print and print preview for Workbook objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorkbookPrinter

Visual Basic [image] Copy Code

Public Class WorkbookPrinter

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.WorkbookPrinter

See Also

WorkbookPrinter Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter Members

WorkbookPrinter Members
Constructors Methods
[image]

Provides print and print preview for Workbook objects.

The following tables list the members exposed by the WorkbookPrinter type.

Public Constructors

Name | Description
WorkbookPrinter | Initializes a new instance of the WorkbookPrinter class.

Public Methods

Name | Description
Print | Overloaded. Prints a Workbook object.
PrintPreview | Overloaded. Displays a print preview form for a workbook.

See Also

WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter Constructor

WorkbookPrinter Constructor
[image]

Initializes a new instance of the WorkbookPrinter class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorkbookPrinter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter Methods

WorkbookPrinter Methods
[image]

Public Methods

Name | Description
Print | Overloaded. Prints a Workbook object.
PrintPreview | Overloaded. Displays a print preview form for a workbook.

See Also

WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.Print Method

WorkbookPrinter.Print Method
[image]

Prints a Workbook object.

Overload List

Name | Description
WorkbookPrinter.Print (Workbook) | Displays the standard print dialog and prints the specified workbook.
WorkbookPrinter.Print (Worksheet) | Displays the standard print dialog and prints the specified worksheet.

See Also

WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.Print Method (Workbook)

WorkbookPrinter.Print Method (Workbook)
See Also
[image]

Displays the standard print dialog and prints the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Print (
Workbook workbook
)

Visual Basic [image] Copy Code

Public Sub Print( _
workbook As Workbook _
)

Parameters

workbook

The workbook to print.

See Also

Print Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.Print Method (Worksheet)

WorkbookPrinter.Print Method (Worksheet)
See Also
[image]

Displays the standard print dialog and prints the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Print (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Sub Print( _
worksheet As Worksheet _
)

Parameters

worksheet

The worksheet to print.

See Also

Print Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.PrintPreview Method

WorkbookPrinter.PrintPreview Method
[image]

Displays a print preview form for a workbook.

Overload List

Name | Description
WorkbookPrinter.PrintPreview (Workbook) | Shows the print preview dialog for the specified workbook.
WorkbookPrinter.PrintPreview (Workbook, String) | Shows the print preview dialog for the specified workbook.
WorkbookPrinter.PrintPreview (Worksheet) | Shows the print preview dialog for the specified worksheet.
WorkbookPrinter.PrintPreview (Worksheet, String) | Shows the print preview dialog for the specified worksheet.

See Also

WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.PrintPreview Method (Workbook)

WorkbookPrinter.PrintPreview Method (Workbook)
See Also
[image]

Shows the print preview dialog for the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
Workbook workbook
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
workbook As Workbook _
)

Parameters

workbook

The workbook to preview.

See Also

PrintPreview Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.PrintPreview Method (Workbook, String)

WorkbookPrinter.PrintPreview Method (Workbook, String)
See Also
[image]

Shows the print preview dialog for the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
Workbook workbook,
string windowTitle
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
workbook As Workbook, _
windowTitle As String _
)

Parameters

workbook

The workbook to preview.

windowTitle

A custom title for the dialog.

See Also

PrintPreview Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.PrintPreview Method (Worksheet)

WorkbookPrinter.PrintPreview Method (Worksheet)
See Also
[image]

Shows the print preview dialog for the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
worksheet As Worksheet _
)

Parameters

worksheet

The worksheet to preview.

See Also

PrintPreview Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookPrinter.PrintPreview Method (Worksheet, String)

WorkbookPrinter.PrintPreview Method (Worksheet, String)
See Also
[image]

Shows the print preview dialog for the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PrintPreview (
Worksheet worksheet,
string windowTitle
)

Visual Basic [image] Copy Code

Public Sub PrintPreview( _
worksheet As Worksheet, _
windowTitle As String _
)

Parameters

worksheet

The worksheet to preview.

windowTitle

A custom title for the dialog.

See Also

PrintPreview Method Overload List
WorkbookPrinter Members
WorkbookPrinter Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Class

WorkbookView Class
Remarks See Also
[image]

Represents a control that can display Workbook objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorkbookView : Control

Visual Basic [image] Copy Code

Public Class WorkbookView
Inherits Control

Remarks

The WorkbookView control can display Workbook objects in an environment similar to that of Microsoft Excel. The following image illustrates a WorkbookView instance.

The workbook to display in the view is specified through the Workbook property. The currently active worksheet can be get or set through the ActiveWorksheet property. The active cell inside the worksheet is available through the ActiveCell property. The Selection property provides access to a Selection object, which can be used to get or set the selected cells and objects in the active worksheet.

The view provides many events that can help track, validate and respond to user actions inside the view, including WorksheetAdded, ActiveCellChanged, SelectionChanged, ObjectClicked, and so on.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.WorkbookView

See Also

WorkbookView Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Members

WorkbookView Members
Constructors Fields Properties Methods Events
[image]

Represents a control that can display Workbook objects.

The following tables list the members exposed by the WorkbookView type.

Public Constructors

Name | Description
WorkbookView | Initializes a new instance of the WorkbookView class.

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property.
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property.
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property.
AllowAutoFillProperty | Identifies the AllowAutoFill dependency property.
AllowMoveCellsProperty | Identifies the AllowMoveCells dependency property.
AllowMoveHeadersProperty | Identifies the AllowMoveHeaders dependency property.
AutoFillCursorProperty | Identifies the AutoFillCursor dependency property.
AutoScrollProperty | Identifies the AutoScroll dependency property.
CounterDiagonalResizeCursorProperty | Identifies the CounterDiagonalResizeCursor dependency property.
DiagonalResizeCursorProperty | Identifies the DiagonalResizeCursor dependency property.
DisallowCursorProperty | Identifies the DisallowCursor dependency property.
DrawFilledCellBordersProperty | Identifies the DrawFilledCellBorders dependency property.
FormulaToolTipTemplateProperty | Identifies the FormulaToolTipTemplate dependency property.
HeaderMoveIndicatorBrushProperty | Identifies the HeaderMoveIndicatorBrush dependency property.
HeaderResizeIndicatorBrushProperty | Identifies the HeaderResizeIndicatorBrush dependency property.
HorizontalResizeCursorProperty | Identifies the HorizontalResizeCursor dependency property.
HorizontalSplitCursorProperty | Identifies the HorizontalSplitCursor dependency property.
HScrollToolTipFormatProperty | Identifies the HScrollToolTipFormat dependency property.
HyperlinkCursorProperty | Identifies the HyperlinkCursor dependency property.
MoveCursorProperty | Identifies the MoveCursor dependency property.
PointerCursorProperty | Identifies the PointerCursor dependency property.
ResizeColumnToolTipFormatProperty | Identifies the ResizeColumnToolTipFormat dependency property.
ResizeHeaderToolTipTemplateProperty | Identifies the ResizeHeaderToolTipTemplate dependency property.
ResizeRowToolTipFormatProperty | Identifies the ResizeRowToolTipFormat dependency property.
ScrollToolTipTemplateProperty | Identifies the ScrollToolTipTemplate dependency property.
ScrollXProperty | Identifies the ScrollX dependency property.
ScrollYProperty | Identifies the ScrollY dependency property.
ScrollZoneSizeProperty | Identifies the ScrollZoneSize dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowFormulaBoxProperty | Identifies the ShowFormulaBox dependency property.
ShowGridLinesProperty | Identifies the ShowGridLines dependency property.
ShowHeadersProperty | Identifies the ShowHeaders dependency property.
ShowHiddenHeaderIndicatorsProperty | Identifies the ShowHiddenHeaderIndicators dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowScrollToolTipsProperty | Identifies the ShowScrollToolTips dependency property.
ToolTipTemplateProperty | Identifies the ToolTipTemplate dependency property.
ValidationToolTipTemplateProperty | Identifies the ValidationToolTipTemplate dependency property.
VerticalResizeCursorProperty | Identifies the VerticalResizeCursor dependency property.
VerticalSplitCursorProperty | Identifies the VerticalSplitCursor dependency property.
VScrollToolTipFormatProperty | Identifies the VScrollToolTipFormat dependency property.
WorkbookProperty | Identifies the Workbook dependency property.

Public Properties

Name | Description
ActiveCell | Gets or sets the currently active cell.
ActiveWorksheet | Gets or sets the currently active worksheet.
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles of selected interactive objects. This is a dependency property.
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles of selected interactive objects. This is a dependency property.
AdjustmentHandleSize | Gets or sets the size, in pixels, of the adjustment handles of selected interactive objects. This is a dependency property.
AllowAutoFill | Gets or sets a value indicating whether to display the auto-fill handle at the bottom-right side of the selection. This is a dependency property.
AllowMoveCells | Gets or sets a value indicating whether the user can interactively move cells around the worksheet, by pressing near the edge of the currently selected cells with the mouse and dragging. This is a dependency property.
AllowMoveHeaders | Gets or sets a value indicating whether the user can interactively move the worksheet headers, by selecting the entire column or row and dragging. This is a dependency property.
AutoFillCursor | Gets or sets the mouse cursor shown to the user if the mouse is over the auto fill handle or the user is currently performing an auto fill operation. This is a dependency property.
AutoScroll | Gets or sets a value indicating whether to automatically scroll the view while the user is dragging a selection or interactive object near or beyond the view border. This is a dependency property.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a given location. This is a dependency property.
DrawFilledCellBorders | Gets or sets a value indicating whether to draw the default grid lines for cells with set background. This is a dependency property.
FormulaToolTipTemplate | Gets or sets the template of the tooltip displayed when the user is editing a formula. This is a dependency property.
HeaderMoveIndicatorBrush | Gets or sets the brush uses to paint the header move indicators. This is a dependency property.
HeaderResizeIndicatorBrush | Gets or sets the brush used to paint the header resize indicators. This is a dependency property.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. This is a dependency property.
HorizontalSplitCursor | Gets or sets the mouse cursor shown to the user if dragging would resize rows. This is a dependency property.
HScrollToolTipFormat | Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the horizontal scroll bar. This is a dependency property.
HyperlinkCursor | Gets or sets the mouse cursor shown to the user if the mouse is over a cell containing a hyperlink. This is a dependency property.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. This is a dependency property.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. This is a dependency property.
ResizeColumnToolTipFormat | Gets or sets the format of the tooltip displayed when the user resizes columns. This is a dependency property.
ResizeHeaderToolTipTemplate | Gets or sets the template of the tooltip displayed when the user resizes rows and columns. This is a dependency property.
ResizeRowToolTipFormat | Gets or sets the format of the tooltip displayed when the user resizes rows. This is a dependency property.
ScrollToolTipTemplate | Gets or sets the template of the tooltip displayed when the user scrolls the view. This is a dependency property.
ScrollX | Gets or sets the position of the horizontal scrollbar. This is a dependency property.
ScrollY | Gets or sets the position of the vertical scrollbar. This is a dependency property.
ScrollZoneSize | Gets or sets the distance from the view border within which to start autoscrolling. This is a dependency property.
Selection | Gets the selection in the view.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowFormulaBox | Gets or sets a value indicating whether to display the formula text box. This is a dependency property.
ShowGridLines | Gets or sets a value indicating whether to display the grid lines. This is a dependency property.
ShowHeaders | Gets or sets a value indicating whether to display the row and column headers. This is a dependency property.
ShowHiddenHeaderIndicators | Gets or sets a value indicating whether to display indicators for hidden row and column headers. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether to display the worksheet navigation buttons in the lower left corner of the view. This is a dependency property.
ShowScrollToolTips | Gets or sets a value indicating whether to display tooltips when scrolling with the thumb. This is a dependency property.
ToolTipTemplate | Gets or sets the template of the tooltip displayed when the user points a cell containing an error or a hyperlink with tooltip. This is a dependency property.
ValidationToolTipTemplate | Gets or sets the template of the tooltip displayed when the user selects a cell containing a validation with a message. This is a dependency property.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. This is a dependency property.
VerticalSplitCursor | Gets or sets the mouse cursor shown to the user if dragging would resize columns. This is a dependency property.
VScrollToolTipFormat | Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the vertical scroll bar. This is a dependency property.
Workbook | Gets or sets the workbook displayed in this view. This is a dependency property.

Public Methods

Name | Description
BeginEdit | Initiates in-place edit of the specified in-place editable object.
Copy | Copies the current selection to the clipboard.
Cut | Cuts the current selection to the clipboard.
EndEdit | Completes the in-place editing operation, previously started by a call to BeginEdit, and accept or cancel the change.
EnsureVisible | Scrolls the view so that the specified cell becomes visible.
Freeze | Sets the FirstFrozenColumn, FirstFrozenRow, FrozenColumnCount, and FrozenRowCount properties of the current worksheet, so that the active cell is the first unfrozen cell.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
Paste | Pastes the information from the clipboard at the active cell in the current worksheet.
ResizeColumnsToFit | Resizes the columns in the specified range of the active worksheet to fit their content.
ResizeColumnToFit | Resizes a view column to fit its contents.
ResizeRowsToFit | Resizes the rows in the specified range of the active worksheet to fit their content.
ResizeRowToFit | Resizes a view row to fit its contents.
ToggleColumnOutline | Expands or collapses all groups at the specified outline level.
ToggleRowOutline | Expands or collapses all groups at the specified outline level.
Unfreeze | Unfreezes any frozen rows and columns in the current worksheet.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnActiveCellChanged | Raises the ActiveCellChanged event.
OnActiveWorksheetChanged | Raises the ActiveWorksheetChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellSelectionChanged | Raises the CellSelectionChanged event.
OnColumnClicked | Raises the ColumnClicked event.
OnColumnGroupCollapsed | Raises the ColumnGroupCollapsed event.
OnColumnGroupExpanded | Raises the ColumnGroupExpanded event.
OnColumnOutlineLevelToggled | Raises the ColumnOutlineLevelToggled event.
OnColumnsMoved | Raises the ColumnsMoved event.
OnColumnsMoving | Raises the ColumnsMoving event.
OnColumnsResized | Raises the ColumnsResized event.
OnColumnsResizing | Raises the ColumnsResizing event.
OnHyperlinkClicked | Raises the HyperlinkClicked event.
OnInplaceEditEnded | Raises the InplaceEditEnded event.
OnInplaceEditEnding | Raises the InplaceEditEnding event.
OnInplaceEditStarted | Raises the InplaceEditStarted event.
OnInplaceEditStarting | Raises the InplaceEditStarting event.
OnKeyDown | UIElement.OnKeyDown override.
OnLostKeyboardFocus | UIElement.OnLostKeyboardFocus override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override.
OnMouseWheel | UIElement.OnMouseWheel override.
OnObjectClicked | Raises the ObjectClicked event.
OnObjectDeleted | Raises the ObjectDeleted event.
OnObjectDeleting | Raises the ObjectDeleting event.
OnObjectDeselected | Raises the ObjectDeselected event.
OnObjectModified | Raises the ObjectModified event.
OnObjectModifyCancelled | Raises the ObjectModifyCancelled event.
OnObjectModifying | Raises the ObjectModifying event.
OnObjectSelected | Raises the ObjectSelected event.
OnObjectSelecting | Raises the ObjectSelecting event.
OnObjectStartModifying | Raises the ObjectStartModifying event.
OnRowClicked | Raises the RowClicked event.
OnRowGroupCollapsed | Raises the RowGroupCollapsed event.
OnRowGroupExpanded | Raises the RowGroupExpanded event.
OnRowOutlineLevelToggled | Raises the RowOutlineLevelToggled event.
OnRowsMoved | Raises the RowsMoved event.
OnRowsMoving | Raises the RowsMoving event.
OnRowsResized | Raises the RowsResized event.
OnRowsResizing | Raises the RowsResizing event.
OnTextInput | UIElement.OnTextInput override.
OnWorksheetTabClicked | Raises the WorksheetTabClicked event.

Public Events

Name | Description
ActiveCellChanged | Raised when the active cell is changed.
ActiveWorksheetChanged | Raised when the currently active worksheet is changed.
CellClicked | Raised when a cell is clicked.
CellSelectionChanged | Raised when the selection is changed interactively, that is, modifying the selection programmatically does not raise this event.
ColumnClicked | Raised when a column header is clicked.
ColumnGroupCollapsed | Raised when a column group has been collapsed interactively.
ColumnGroupExpanded | Raised when a column group has been expanded interactively.
ColumnOutlineLevelToggled | Raised when a column outline level has been activated interactively.
ColumnsMoved | Raised when one or more columns are moved interactively.
ColumnsMoving | Raised when one or more columns are being moved interactively.
ColumnsResized | Raised when one or more columns are resized interactively.
ColumnsResizing | Raised when one or more columns are being resized interactively.
HyperlinkClicked | Raised when a cell containing a hyperlink is clicked.
InplaceEditEnded | Raised when an inplace-edit operation has finished.
InplaceEditEnding | Raised when an in-place edit operation is about to finish, before the in-place editor is closed.
InplaceEditStarted | Raised when an in-place edit operation has started, after the in-place editor is displayed.
InplaceEditStarting | Raised when an in-place edit operation is about to start, before the in-place editor is displayed.
ObjectClicked | Raised when an object is clicked.
ObjectDeleted | Raised when an object is deleted interactively.
ObjectDeleting | Raised when an object is about to be deleted interactively.
ObjectDeselected | Raised when an object is deselected, either programmatically or interactively.
ObjectModified | Raised when the user completes the modification of an object.
ObjectModifyCancelled | Raised when the user cancels the modification of an object.
ObjectModifying | Raised when the user starts modifying an interactive object.
ObjectSelected | Raised when an object is selected, either programmatically or interactively.
ObjectSelecting | Raised when the user is about to select an object.
ObjectStartModifying | Raised while the user is moving or resizing an interactive object.
RowClicked | Raised when a row header is clicked.
RowGroupCollapsed | Raised when a row group has been collapsed interactively.
RowGroupExpanded | Raised when a row group has been expanded interactively.
RowOutlineLevelToggled | Raised when a row outline level has been activated interactively.
RowsMoved | Raised when one or more rows are moved interactively.
RowsMoving | Raised when one or more rows are being moved interactively.
RowsResized | Raised when one or more rows are resized interactively.
RowsResizing | Raised when one or more rows are being resized interactively.
WorksheetAdded | Raised when a new worksheet is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
WorksheetTabClicked | Raised when a worksheet tab is clicked with the mouse.

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Fields

WorkbookView Fields
[image]

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property.
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property.
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property.
AllowAutoFillProperty | Identifies the AllowAutoFill dependency property.
AllowMoveCellsProperty | Identifies the AllowMoveCells dependency property.
AllowMoveHeadersProperty | Identifies the AllowMoveHeaders dependency property.
AutoFillCursorProperty | Identifies the AutoFillCursor dependency property.
AutoScrollProperty | Identifies the AutoScroll dependency property.
CounterDiagonalResizeCursorProperty | Identifies the CounterDiagonalResizeCursor dependency property.
DiagonalResizeCursorProperty | Identifies the DiagonalResizeCursor dependency property.
DisallowCursorProperty | Identifies the DisallowCursor dependency property.
DrawFilledCellBordersProperty | Identifies the DrawFilledCellBorders dependency property.
FormulaToolTipTemplateProperty | Identifies the FormulaToolTipTemplate dependency property.
HeaderMoveIndicatorBrushProperty | Identifies the HeaderMoveIndicatorBrush dependency property.
HeaderResizeIndicatorBrushProperty | Identifies the HeaderResizeIndicatorBrush dependency property.
HorizontalResizeCursorProperty | Identifies the HorizontalResizeCursor dependency property.
HorizontalSplitCursorProperty | Identifies the HorizontalSplitCursor dependency property.
HScrollToolTipFormatProperty | Identifies the HScrollToolTipFormat dependency property.
HyperlinkCursorProperty | Identifies the HyperlinkCursor dependency property.
MoveCursorProperty | Identifies the MoveCursor dependency property.
PointerCursorProperty | Identifies the PointerCursor dependency property.
ResizeColumnToolTipFormatProperty | Identifies the ResizeColumnToolTipFormat dependency property.
ResizeHeaderToolTipTemplateProperty | Identifies the ResizeHeaderToolTipTemplate dependency property.
ResizeRowToolTipFormatProperty | Identifies the ResizeRowToolTipFormat dependency property.
ScrollToolTipTemplateProperty | Identifies the ScrollToolTipTemplate dependency property.
ScrollXProperty | Identifies the ScrollX dependency property.
ScrollYProperty | Identifies the ScrollY dependency property.
ScrollZoneSizeProperty | Identifies the ScrollZoneSize dependency property.
ShowCreateNewTabProperty | Identifies the ShowCreateNewTab dependency property.
ShowFormulaBoxProperty | Identifies the ShowFormulaBox dependency property.
ShowGridLinesProperty | Identifies the ShowGridLines dependency property.
ShowHeadersProperty | Identifies the ShowHeaders dependency property.
ShowHiddenHeaderIndicatorsProperty | Identifies the ShowHiddenHeaderIndicators dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowScrollToolTipsProperty | Identifies the ShowScrollToolTips dependency property.
ToolTipTemplateProperty | Identifies the ToolTipTemplate dependency property.
ValidationToolTipTemplateProperty | Identifies the ValidationToolTipTemplate dependency property.
VerticalResizeCursorProperty | Identifies the VerticalResizeCursor dependency property.
VerticalSplitCursorProperty | Identifies the VerticalSplitCursor dependency property.
VScrollToolTipFormatProperty | Identifies the VScrollToolTipFormat dependency property.
WorkbookProperty | Identifies the Workbook dependency property.

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleBackgroundProperty Field

WorkbookView.AdjustmentHandleBackgroundProperty Field
[image]

Identifies the AdjustmentHandleBackground dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleBackgroundProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleBorderBrushProperty Field

WorkbookView.AdjustmentHandleBorderBrushProperty Field
[image]

Identifies the AdjustmentHandleBorderBrush dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleBorderBrushProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleSizeProperty Field

WorkbookView.AdjustmentHandleSizeProperty Field
[image]

Identifies the AdjustmentHandleSize dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AdjustmentHandleSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AdjustmentHandleSizeProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowAutoFillProperty Field

WorkbookView.AllowAutoFillProperty Field
[image]

Identifies the AllowAutoFill dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowAutoFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowAutoFillProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowMoveCellsProperty Field

WorkbookView.AllowMoveCellsProperty Field
[image]

Identifies the AllowMoveCells dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowMoveCellsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowMoveCellsProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowMoveHeadersProperty Field

WorkbookView.AllowMoveHeadersProperty Field
[image]

Identifies the AllowMoveHeaders dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowMoveHeadersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowMoveHeadersProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AutoFillCursorProperty Field

WorkbookView.AutoFillCursorProperty Field
[image]

Identifies the AutoFillCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoFillCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoFillCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AutoScrollProperty Field

WorkbookView.AutoScrollProperty Field
[image]

Identifies the AutoScroll dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoScrollProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoScrollProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.CounterDiagonalResizeCursorProperty Field

WorkbookView.CounterDiagonalResizeCursorProperty Field
[image]

Identifies the CounterDiagonalResizeCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CounterDiagonalResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CounterDiagonalResizeCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DiagonalResizeCursorProperty Field

WorkbookView.DiagonalResizeCursorProperty Field
[image]

Identifies the DiagonalResizeCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DiagonalResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DiagonalResizeCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DisallowCursorProperty Field

WorkbookView.DisallowCursorProperty Field
[image]

Identifies the DisallowCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DisallowCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DisallowCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DrawFilledCellBordersProperty Field

WorkbookView.DrawFilledCellBordersProperty Field
[image]

Identifies the DrawFilledCellBorders dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DrawFilledCellBordersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DrawFilledCellBordersProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.FormulaToolTipTemplateProperty Field

WorkbookView.FormulaToolTipTemplateProperty Field
[image]

Identifies the FormulaToolTipTemplate dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormulaToolTipTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FormulaToolTipTemplateProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HeaderMoveIndicatorBrushProperty Field

WorkbookView.HeaderMoveIndicatorBrushProperty Field
[image]

Identifies the HeaderMoveIndicatorBrush dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderMoveIndicatorBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderMoveIndicatorBrushProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HeaderResizeIndicatorBrushProperty Field

WorkbookView.HeaderResizeIndicatorBrushProperty Field
[image]

Identifies the HeaderResizeIndicatorBrush dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderResizeIndicatorBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderResizeIndicatorBrushProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HorizontalResizeCursorProperty Field

WorkbookView.HorizontalResizeCursorProperty Field
[image]

Identifies the HorizontalResizeCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalResizeCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HorizontalSplitCursorProperty Field

WorkbookView.HorizontalSplitCursorProperty Field
[image]

Identifies the HorizontalSplitCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HorizontalSplitCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HorizontalSplitCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HScrollToolTipFormatProperty Field

WorkbookView.HScrollToolTipFormatProperty Field
[image]

Identifies the HScrollToolTipFormat dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HScrollToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HScrollToolTipFormatProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HyperlinkCursorProperty Field

WorkbookView.HyperlinkCursorProperty Field
[image]

Identifies the HyperlinkCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HyperlinkCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HyperlinkCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.MoveCursorProperty Field

WorkbookView.MoveCursorProperty Field
[image]

Identifies the MoveCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MoveCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.PointerCursorProperty Field

WorkbookView.PointerCursorProperty Field
[image]

Identifies the PointerCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeColumnToolTipFormatProperty Field

WorkbookView.ResizeColumnToolTipFormatProperty Field
[image]

Identifies the ResizeColumnToolTipFormat dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeColumnToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeColumnToolTipFormatProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeHeaderToolTipTemplateProperty Field

WorkbookView.ResizeHeaderToolTipTemplateProperty Field
[image]

Identifies the ResizeHeaderToolTipTemplate dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeHeaderToolTipTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeHeaderToolTipTemplateProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeRowToolTipFormatProperty Field

WorkbookView.ResizeRowToolTipFormatProperty Field
[image]

Identifies the ResizeRowToolTipFormat dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeRowToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeRowToolTipFormatProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollToolTipTemplateProperty Field

WorkbookView.ScrollToolTipTemplateProperty Field
[image]

Identifies the ScrollToolTipTemplate dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollToolTipTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollToolTipTemplateProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollXProperty Field

WorkbookView.ScrollXProperty Field
[image]

Identifies the ScrollX dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollXProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollYProperty Field

WorkbookView.ScrollYProperty Field
[image]

Identifies the ScrollY dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollYProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollZoneSizeProperty Field

WorkbookView.ScrollZoneSizeProperty Field
[image]

Identifies the ScrollZoneSize dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollZoneSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollZoneSizeProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowCreateNewTabProperty Field

WorkbookView.ShowCreateNewTabProperty Field
[image]

Identifies the ShowCreateNewTab dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCreateNewTabProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCreateNewTabProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowFormulaBoxProperty Field

WorkbookView.ShowFormulaBoxProperty Field
[image]

Identifies the ShowFormulaBox dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowFormulaBoxProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowFormulaBoxProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowGridLinesProperty Field

WorkbookView.ShowGridLinesProperty Field
[image]

Identifies the ShowGridLines dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowGridLinesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowGridLinesProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowHeadersProperty Field

WorkbookView.ShowHeadersProperty Field
[image]

Identifies the ShowHeaders dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowHeadersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowHeadersProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowHiddenHeaderIndicatorsProperty Field

WorkbookView.ShowHiddenHeaderIndicatorsProperty Field
[image]

Identifies the ShowHiddenHeaderIndicators dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowHiddenHeaderIndicatorsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowHiddenHeaderIndicatorsProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowNavigationButtonsProperty Field

WorkbookView.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowScrollToolTipsProperty Field

WorkbookView.ShowScrollToolTipsProperty Field
[image]

Identifies the ShowScrollToolTips dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowScrollToolTipsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowScrollToolTipsProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ToolTipTemplateProperty Field

WorkbookView.ToolTipTemplateProperty Field
[image]

Identifies the ToolTipTemplate dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToolTipTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolTipTemplateProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ValidationToolTipTemplateProperty Field

WorkbookView.ValidationToolTipTemplateProperty Field
[image]

Identifies the ValidationToolTipTemplate dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValidationToolTipTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValidationToolTipTemplateProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VerticalResizeCursorProperty Field

WorkbookView.VerticalResizeCursorProperty Field
[image]

Identifies the VerticalResizeCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalResizeCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalResizeCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VerticalSplitCursorProperty Field

WorkbookView.VerticalSplitCursorProperty Field
[image]

Identifies the VerticalSplitCursor dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VerticalSplitCursorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VerticalSplitCursorProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VScrollToolTipFormatProperty Field

WorkbookView.VScrollToolTipFormatProperty Field
[image]

Identifies the VScrollToolTipFormat dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VScrollToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VScrollToolTipFormatProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.WorkbookProperty Field

WorkbookView.WorkbookProperty Field
[image]

Identifies the Workbook dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkbookProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WorkbookProperty As DependencyProperty

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Constructor

WorkbookView Constructor
[image]

Initializes a new instance of the WorkbookView class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorkbookView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Methods

WorkbookView Methods
[image]

Public Methods

Name | Description
BeginEdit | Initiates in-place edit of the specified in-place editable object.
Copy | Copies the current selection to the clipboard.
Cut | Cuts the current selection to the clipboard.
EndEdit | Completes the in-place editing operation, previously started by a call to BeginEdit, and accept or cancel the change.
EnsureVisible | Scrolls the view so that the specified cell becomes visible.
Freeze | Sets the FirstFrozenColumn, FirstFrozenRow, FrozenColumnCount, and FrozenRowCount properties of the current worksheet, so that the active cell is the first unfrozen cell.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
Paste | Pastes the information from the clipboard at the active cell in the current worksheet.
ResizeColumnsToFit | Resizes the columns in the specified range of the active worksheet to fit their content.
ResizeColumnToFit | Resizes a view column to fit its contents.
ResizeRowsToFit | Resizes the rows in the specified range of the active worksheet to fit their content.
ResizeRowToFit | Resizes a view row to fit its contents.
ToggleColumnOutline | Expands or collapses all groups at the specified outline level.
ToggleRowOutline | Expands or collapses all groups at the specified outline level.
Unfreeze | Unfreezes any frozen rows and columns in the current worksheet.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnActiveCellChanged | Raises the ActiveCellChanged event.
OnActiveWorksheetChanged | Raises the ActiveWorksheetChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellSelectionChanged | Raises the CellSelectionChanged event.
OnColumnClicked | Raises the ColumnClicked event.
OnColumnGroupCollapsed | Raises the ColumnGroupCollapsed event.
OnColumnGroupExpanded | Raises the ColumnGroupExpanded event.
OnColumnOutlineLevelToggled | Raises the ColumnOutlineLevelToggled event.
OnColumnsMoved | Raises the ColumnsMoved event.
OnColumnsMoving | Raises the ColumnsMoving event.
OnColumnsResized | Raises the ColumnsResized event.
OnColumnsResizing | Raises the ColumnsResizing event.
OnHyperlinkClicked | Raises the HyperlinkClicked event.
OnInplaceEditEnded | Raises the InplaceEditEnded event.
OnInplaceEditEnding | Raises the InplaceEditEnding event.
OnInplaceEditStarted | Raises the InplaceEditStarted event.
OnInplaceEditStarting | Raises the InplaceEditStarting event.
OnKeyDown | UIElement.OnKeyDown override.
OnLostKeyboardFocus | UIElement.OnLostKeyboardFocus override.
OnMouseDown | UIElement.OnMouseDown override.
OnMouseMove | UIElement.OnMouseMove override.
OnMouseUp | UIElement.OnMouseUp override.
OnMouseWheel | UIElement.OnMouseWheel override.
OnObjectClicked | Raises the ObjectClicked event.
OnObjectDeleted | Raises the ObjectDeleted event.
OnObjectDeleting | Raises the ObjectDeleting event.
OnObjectDeselected | Raises the ObjectDeselected event.
OnObjectModified | Raises the ObjectModified event.
OnObjectModifyCancelled | Raises the ObjectModifyCancelled event.
OnObjectModifying | Raises the ObjectModifying event.
OnObjectSelected | Raises the ObjectSelected event.
OnObjectSelecting | Raises the ObjectSelecting event.
OnObjectStartModifying | Raises the ObjectStartModifying event.
OnRowClicked | Raises the RowClicked event.
OnRowGroupCollapsed | Raises the RowGroupCollapsed event.
OnRowGroupExpanded | Raises the RowGroupExpanded event.
OnRowOutlineLevelToggled | Raises the RowOutlineLevelToggled event.
OnRowsMoved | Raises the RowsMoved event.
OnRowsMoving | Raises the RowsMoving event.
OnRowsResized | Raises the RowsResized event.
OnRowsResizing | Raises the RowsResizing event.
OnTextInput | UIElement.OnTextInput override.
OnWorksheetTabClicked | Raises the WorksheetTabClicked event.

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.BeginEdit Method

WorkbookView.BeginEdit Method
[image]

Initiates in-place edit of the specified in-place editable object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Control BeginEdit (
IInplaceEditable item
)

Visual Basic [image] Copy Code

Public Function BeginEdit( _
item As IInplaceEditable _
) As Control

Parameters

item

An in-place editable object identifying the object to edit.

Return Value

A TextBoxBase representing the in-place edit box.

Remarks

If the in-place editable object is a cell, part of a merged cell, the top-left cell of the merged range will be edited.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Copy Method

WorkbookView.Copy Method
[image]

Copies the current selection to the clipboard.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Copy ()

Visual Basic [image] Copy Code

Public Sub Copy ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Cut Method

WorkbookView.Cut Method
[image]

Cuts the current selection to the clipboard.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Cut ()

Visual Basic [image] Copy Code

Public Sub Cut ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.EndEdit Method

WorkbookView.EndEdit Method
[image]

Completes the in-place editing operation, previously started by a call to BeginEdit, and accept or cancel the change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void EndEdit (
bool acceptChanges
)

Visual Basic [image] Copy Code

Public Sub EndEdit( _
acceptChanges As Boolean _
)

Parameters

acceptChanges

true to accept in-place changes; otherwise, false.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.EnsureVisible Method

WorkbookView.EnsureVisible Method
[image]

Scrolls the view so that the specified cell becomes visible.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool EnsureVisible (
Cell cell
)

Visual Basic [image] Copy Code

Public Function EnsureVisible( _
cell As Cell _
) As Boolean

Parameters

cell

The cell to bring into view.

Return Value

true if the operation was successful; otherwise, false.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Freeze Method

WorkbookView.Freeze Method
[image]

Sets the FirstFrozenColumn, FirstFrozenRow, FrozenColumnCount, and FrozenRowCount properties of the current worksheet, so that the active cell is the first unfrozen cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Freeze ()

Visual Basic [image] Copy Code

Public Sub Freeze ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.MeasureOverride Method

WorkbookView.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

Return Value

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnActiveCellChanged Method

WorkbookView.OnActiveCellChanged Method
[image]

Raises the ActiveCellChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActiveCellChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActiveCellChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnActiveWorksheetChanged Method

WorkbookView.OnActiveWorksheetChanged Method
[image]

Raises the ActiveWorksheetChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnActiveWorksheetChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnActiveWorksheetChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnApplyTemplate Method

WorkbookView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnCellClicked Method

WorkbookView.OnCellClicked Method
[image]

Raises the CellClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellClicked (
CellMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellClicked( _
e As CellMouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnCellSelectionChanged Method

WorkbookView.OnCellSelectionChanged Method
[image]

Raises the CellSelectionChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellSelectionChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellSelectionChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnClicked Method

WorkbookView.OnColumnClicked Method
[image]

Raises the ColumnClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnClicked (
ColumnMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnClicked( _
e As ColumnMouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnGroupCollapsed Method

WorkbookView.OnColumnGroupCollapsed Method
[image]

Raises the ColumnGroupCollapsed event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnGroupCollapsed (
ColumnEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnGroupCollapsed( _
e As ColumnEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnGroupExpanded Method

WorkbookView.OnColumnGroupExpanded Method
[image]

Raises the ColumnGroupExpanded event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnGroupExpanded (
ColumnEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnGroupExpanded( _
e As ColumnEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnOutlineLevelToggled Method

WorkbookView.OnColumnOutlineLevelToggled Method
[image]

Raises the ColumnOutlineLevelToggled event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnOutlineLevelToggled (
OutlineEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnOutlineLevelToggled( _
e As OutlineEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnsMoved Method

WorkbookView.OnColumnsMoved Method
[image]

Raises the ColumnsMoved event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnsMoved (
ColumnRangeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnsMoved( _
e As ColumnRangeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnsMoving Method

WorkbookView.OnColumnsMoving Method
[image]

Raises the ColumnsMoving event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnsMoving (
ColumnRangeMovingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnsMoving( _
e As ColumnRangeMovingEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnsResized Method

WorkbookView.OnColumnsResized Method
[image]

Raises the ColumnsResized event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnsResized (
ColumnRangeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnsResized( _
e As ColumnRangeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnColumnsResizing Method

WorkbookView.OnColumnsResizing Method
[image]

Raises the ColumnsResizing event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnsResizing (
ColumnRangeResizingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnsResizing( _
e As ColumnRangeResizingEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnHyperlinkClicked Method

WorkbookView.OnHyperlinkClicked Method
[image]

Raises the HyperlinkClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnHyperlinkClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHyperlinkClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnInplaceEditEnded Method

WorkbookView.OnInplaceEditEnded Method
[image]

Raises the InplaceEditEnded event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInplaceEditEnded (
InplaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInplaceEditEnded( _
e As InplaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnInplaceEditEnding Method

WorkbookView.OnInplaceEditEnding Method
[image]

Raises the InplaceEditEnding event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInplaceEditEnding (
InplaceEditValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInplaceEditEnding( _
e As InplaceEditValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnInplaceEditStarted Method

WorkbookView.OnInplaceEditStarted Method
[image]

Raises the InplaceEditStarted event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInplaceEditStarted (
InplaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInplaceEditStarted( _
e As InplaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnInplaceEditStarting Method

WorkbookView.OnInplaceEditStarting Method
[image]

Raises the InplaceEditStarting event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnInplaceEditStarting (
InplaceEditValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInplaceEditStarting( _
e As InplaceEditValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnKeyDown Method

WorkbookView.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnLostKeyboardFocus Method

WorkbookView.OnLostKeyboardFocus Method
[image]

UIElement.OnLostKeyboardFocus override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnLostKeyboardFocus (
KeyboardFocusChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLostKeyboardFocus( _
e As KeyboardFocusChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnMouseDown Method

WorkbookView.OnMouseDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnMouseMove Method

WorkbookView.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnMouseUp Method

WorkbookView.OnMouseUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnMouseWheel Method

WorkbookView.OnMouseWheel Method
[image]

UIElement.OnMouseWheel override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseWheel (
MouseWheelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseWheel( _
e As MouseWheelEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectClicked Method

WorkbookView.OnObjectClicked Method
[image]

Raises the ObjectClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectClicked (
ObjectMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectClicked( _
e As ObjectMouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectDeleted Method

WorkbookView.OnObjectDeleted Method
[image]

Raises the ObjectDeleted event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectDeleted (
ObjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectDeleted( _
e As ObjectEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectDeleting Method

WorkbookView.OnObjectDeleting Method
[image]

Raises the ObjectDeleting event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectDeleting (
ObjectValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectDeleting( _
e As ObjectValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectDeselected Method

WorkbookView.OnObjectDeselected Method
[image]

Raises the ObjectDeselected event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectDeselected (
ObjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectDeselected( _
e As ObjectEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectModified Method

WorkbookView.OnObjectModified Method
[image]

Raises the ObjectModified event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectModified (
ObjectInteractionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectModified( _
e As ObjectInteractionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectModifyCancelled Method

WorkbookView.OnObjectModifyCancelled Method
[image]

Raises the ObjectModifyCancelled event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectModifyCancelled (
ObjectInteractionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectModifyCancelled( _
e As ObjectInteractionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectModifying Method

WorkbookView.OnObjectModifying Method
[image]

Raises the ObjectModifying event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectModifying (
ObjectInteractionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectModifying( _
e As ObjectInteractionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectSelected Method

WorkbookView.OnObjectSelected Method
[image]

Raises the ObjectSelected event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectSelected (
ObjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectSelected( _
e As ObjectEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectSelecting Method

WorkbookView.OnObjectSelecting Method
[image]

Raises the ObjectSelecting event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectSelecting (
ObjectInteractionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectSelecting( _
e As ObjectInteractionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnObjectStartModifying Method

WorkbookView.OnObjectStartModifying Method
[image]

Raises the ObjectStartModifying event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnObjectStartModifying (
ObjectInteractionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnObjectStartModifying( _
e As ObjectInteractionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowClicked Method

WorkbookView.OnRowClicked Method
[image]

Raises the RowClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowClicked (
RowMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowClicked( _
e As RowMouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowGroupCollapsed Method

WorkbookView.OnRowGroupCollapsed Method
[image]

Raises the RowGroupCollapsed event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowGroupCollapsed (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowGroupCollapsed( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowGroupExpanded Method

WorkbookView.OnRowGroupExpanded Method
[image]

Raises the RowGroupExpanded event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowGroupExpanded (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowGroupExpanded( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowOutlineLevelToggled Method

WorkbookView.OnRowOutlineLevelToggled Method
[image]

Raises the RowOutlineLevelToggled event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowOutlineLevelToggled (
OutlineEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowOutlineLevelToggled( _
e As OutlineEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowsMoved Method

WorkbookView.OnRowsMoved Method
[image]

Raises the RowsMoved event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowsMoved (
RowRangeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowsMoved( _
e As RowRangeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowsMoving Method

WorkbookView.OnRowsMoving Method
[image]

Raises the RowsMoving event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowsMoving (
RowRangeMovingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowsMoving( _
e As RowRangeMovingEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowsResized Method

WorkbookView.OnRowsResized Method
[image]

Raises the RowsResized event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowsResized (
RowRangeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowsResized( _
e As RowRangeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnRowsResizing Method

WorkbookView.OnRowsResizing Method
[image]

Raises the RowsResizing event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowsResizing (
RowRangeResizingEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowsResizing( _
e As RowRangeResizingEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnTextInput Method

WorkbookView.OnTextInput Method
[image]

UIElement.OnTextInput override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnTextInput (
TextCompositionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnTextInput( _
e As TextCompositionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.OnWorksheetTabClicked Method

WorkbookView.OnWorksheetTabClicked Method
[image]

Raises the WorksheetTabClicked event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnWorksheetTabClicked (
WorksheetTabMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnWorksheetTabClicked( _
e As WorksheetTabMouseEventArgs _
)

Parameters

e

An object providing the event data.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Paste Method

WorkbookView.Paste Method
[image]

Pastes the information from the clipboard at the active cell in the current worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Paste ()

Visual Basic [image] Copy Code

Public Sub Paste ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeColumnsToFit Method

WorkbookView.ResizeColumnsToFit Method
[image]

Resizes the columns in the specified range of the active worksheet to fit their content.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ResizeColumnsToFit (
int start,
int end
)

Visual Basic [image] Copy Code

Public Sub ResizeColumnsToFit( _
start As Integer, _
end As Integer _
)

Parameters

start

The zero-based index of the first column in the range.

end

The zero-based index of the last column in the range.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeColumnToFit Method

WorkbookView.ResizeColumnToFit Method
[image]

Resizes a view column to fit its contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ResizeColumnToFit (
int index
)

Visual Basic [image] Copy Code

Public Sub ResizeColumnToFit( _
index As Integer _
)

Parameters

index

The index of the column to resize.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeRowsToFit Method

WorkbookView.ResizeRowsToFit Method
[image]

Resizes the rows in the specified range of the active worksheet to fit their content.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ResizeRowsToFit (
int start,
int end
)

Visual Basic [image] Copy Code

Public Sub ResizeRowsToFit( _
start As Integer, _
end As Integer _
)

Parameters

start

The zero-based index of the first row in the range.

end

The zero-based index of the last row in the range.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeRowToFit Method

WorkbookView.ResizeRowToFit Method
[image]

Resizes a view row to fit its contents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ResizeRowToFit (
int index
)

Visual Basic [image] Copy Code

Public Sub ResizeRowToFit( _
index As Integer _
)

Parameters

index

The index of the row to resize.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ToggleColumnOutline Method

WorkbookView.ToggleColumnOutline Method
[image]

Expands or collapses all groups at the specified outline level.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ToggleColumnOutline (
int level
)

Visual Basic [image] Copy Code

Public Sub ToggleColumnOutline( _
level As Integer _
)

Parameters

level

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ToggleRowOutline Method

WorkbookView.ToggleRowOutline Method
[image]

Expands or collapses all groups at the specified outline level.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void ToggleRowOutline (
int level
)

Visual Basic [image] Copy Code

Public Sub ToggleRowOutline( _
level As Integer _
)

Parameters

level

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Unfreeze Method

WorkbookView.Unfreeze Method
[image]

Unfreezes any frozen rows and columns in the current worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Unfreeze ()

Visual Basic [image] Copy Code

Public Sub Unfreeze ()

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Properties

WorkbookView Properties
[image]

Public Properties

Name | Description
ActiveCell | Gets or sets the currently active cell.
ActiveWorksheet | Gets or sets the currently active worksheet.
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles of selected interactive objects. This is a dependency property.
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles of selected interactive objects. This is a dependency property.
AdjustmentHandleSize | Gets or sets the size, in pixels, of the adjustment handles of selected interactive objects. This is a dependency property.
AllowAutoFill | Gets or sets a value indicating whether to display the auto-fill handle at the bottom-right side of the selection. This is a dependency property.
AllowMoveCells | Gets or sets a value indicating whether the user can interactively move cells around the worksheet, by pressing near the edge of the currently selected cells with the mouse and dragging. This is a dependency property.
AllowMoveHeaders | Gets or sets a value indicating whether the user can interactively move the worksheet headers, by selecting the entire column or row and dragging. This is a dependency property.
AutoFillCursor | Gets or sets the mouse cursor shown to the user if the mouse is over the auto fill handle or the user is currently performing an auto fill operation. This is a dependency property.
AutoScroll | Gets or sets a value indicating whether to automatically scroll the view while the user is dragging a selection or interactive object near or beyond the view border. This is a dependency property.
CounterDiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.
DiagonalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.
DisallowCursor | Gets or sets the mouse cursor shown to the user when an object cannot be created at a given location. This is a dependency property.
DrawFilledCellBorders | Gets or sets a value indicating whether to draw the default grid lines for cells with set background. This is a dependency property.
FormulaToolTipTemplate | Gets or sets the template of the tooltip displayed when the user is editing a formula. This is a dependency property.
HeaderMoveIndicatorBrush | Gets or sets the brush uses to paint the header move indicators. This is a dependency property.
HeaderResizeIndicatorBrush | Gets or sets the brush used to paint the header resize indicators. This is a dependency property.
HorizontalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. This is a dependency property.
HorizontalSplitCursor | Gets or sets the mouse cursor shown to the user if dragging would resize rows. This is a dependency property.
HScrollToolTipFormat | Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the horizontal scroll bar. This is a dependency property.
HyperlinkCursor | Gets or sets the mouse cursor shown to the user if the mouse is over a cell containing a hyperlink. This is a dependency property.
MoveCursor | Gets or sets the mouse cursor shown to the user if the pointed object can be modified. This is a dependency property.
PointerCursor | Gets or sets the mouse cursor shown to the user when no modification is performed. This is a dependency property.
ResizeColumnToolTipFormat | Gets or sets the format of the tooltip displayed when the user resizes columns. This is a dependency property.
ResizeHeaderToolTipTemplate | Gets or sets the template of the tooltip displayed when the user resizes rows and columns. This is a dependency property.
ResizeRowToolTipFormat | Gets or sets the format of the tooltip displayed when the user resizes rows. This is a dependency property.
ScrollToolTipTemplate | Gets or sets the template of the tooltip displayed when the user scrolls the view. This is a dependency property.
ScrollX | Gets or sets the position of the horizontal scrollbar. This is a dependency property.
ScrollY | Gets or sets the position of the vertical scrollbar. This is a dependency property.
ScrollZoneSize | Gets or sets the distance from the view border within which to start autoscrolling. This is a dependency property.
Selection | Gets the selection in the view.
ShowCreateNewTab | Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.
ShowFormulaBox | Gets or sets a value indicating whether to display the formula text box. This is a dependency property.
ShowGridLines | Gets or sets a value indicating whether to display the grid lines. This is a dependency property.
ShowHeaders | Gets or sets a value indicating whether to display the row and column headers. This is a dependency property.
ShowHiddenHeaderIndicators | Gets or sets a value indicating whether to display indicators for hidden row and column headers. This is a dependency property.
ShowNavigationButtons | Gets or sets a value indicating whether to display the worksheet navigation buttons in the lower left corner of the view. This is a dependency property.
ShowScrollToolTips | Gets or sets a value indicating whether to display tooltips when scrolling with the thumb. This is a dependency property.
ToolTipTemplate | Gets or sets the template of the tooltip displayed when the user points a cell containing an error or a hyperlink with tooltip. This is a dependency property.
ValidationToolTipTemplate | Gets or sets the template of the tooltip displayed when the user selects a cell containing a validation with a message. This is a dependency property.
VerticalResizeCursor | Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. This is a dependency property.
VerticalSplitCursor | Gets or sets the mouse cursor shown to the user if dragging would resize columns. This is a dependency property.
VScrollToolTipFormat | Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the vertical scroll bar. This is a dependency property.
Workbook | Gets or sets the workbook displayed in this view. This is a dependency property.

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ActiveCell Property

WorkbookView.ActiveCell Property
[image]

Gets or sets the currently active cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cell ActiveCell { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveCell As Cell

Property Value

An instance of the Cell class.

Remarks

Setting this property to null (Nothing in Visual Basic) or to a cell in a worksheet other than ActiveWorksheet, will raise an exception.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ActiveWorksheet Property

WorkbookView.ActiveWorksheet Property
[image]

Gets or sets the currently active worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet ActiveWorksheet { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveWorksheet As Worksheet

Property Value

An instance of the Worksheet class.

Remarks

Setting this property to null (Nothing in Visual Basic) has no effect, even though this property can report null when no workbook is displayed in the view or if the workbook contains no worksheets.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleBackground Property

WorkbookView.AdjustmentHandleBackground Property
[image]

Gets or sets the background brush of the adjustment handles of selected interactive objects. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush AdjustmentHandleBackground { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleBackground As Brush

Property Value

An instance of the WPF Brush class. The default is White.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleBorderBrush Property

WorkbookView.AdjustmentHandleBorderBrush Property
[image]

Gets or sets the border brush of the adjustment handles of selected interactive objects. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush AdjustmentHandleBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleBorderBrush As Brush

Property Value

An instance of the WPF Brush class. The default is Black.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AdjustmentHandleSize Property

WorkbookView.AdjustmentHandleSize Property
[image]

Gets or sets the size, in pixels, of the adjustment handles of selected interactive objects. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double AdjustmentHandleSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandleSize As Double

Property Value

A double value. The default is 7.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowAutoFill Property

WorkbookView.AllowAutoFill Property
[image]

Gets or sets a value indicating whether to display the auto-fill handle at the bottom-right side of the selection. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AllowAutoFill { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAutoFill As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowMoveCells Property

WorkbookView.AllowMoveCells Property
[image]

Gets or sets a value indicating whether the user can interactively move cells around the worksheet, by pressing near the edge of the currently selected cells with the mouse and dragging. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AllowMoveCells { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveCells As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AllowMoveHeaders Property

WorkbookView.AllowMoveHeaders Property
[image]

Gets or sets a value indicating whether the user can interactively move the worksheet headers, by selecting the entire column or row and dragging. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AllowMoveHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveHeaders As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AutoFillCursor Property

WorkbookView.AutoFillCursor Property
[image]

Gets or sets the mouse cursor shown to the user if the mouse is over the auto fill handle or the user is currently performing an auto fill operation. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor AutoFillCursor { get; set; }

Visual Basic [image] Copy Code

Public Property AutoFillCursor As Cursor

Property Value

An instance of the Cursor class. The default is Cross.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.AutoScroll Property

WorkbookView.AutoScroll Property
[image]

Gets or sets a value indicating whether to automatically scroll the view while the user is dragging a selection or interactive object near or beyond the view border. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScroll As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.CounterDiagonalResizeCursor Property

WorkbookView.CounterDiagonalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor CounterDiagonalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property CounterDiagonalResizeCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeNESW.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DiagonalResizeCursor Property

WorkbookView.DiagonalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor DiagonalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DiagonalResizeCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeNWSE.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DisallowCursor Property

WorkbookView.DisallowCursor Property
[image]

Gets or sets the mouse cursor shown to the user when an object cannot be created at a given location. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor DisallowCursor { get; set; }

Visual Basic [image] Copy Code

Public Property DisallowCursor As Cursor

Property Value

An instance of the Cursor class. The default is No.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.DrawFilledCellBorders Property

WorkbookView.DrawFilledCellBorders Property
[image]

Gets or sets a value indicating whether to draw the default grid lines for cells with set background. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool DrawFilledCellBorders { get; set; }

Visual Basic [image] Copy Code

Public Property DrawFilledCellBorders As Boolean

Property Value

A boolean value. The default is false.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.FormulaToolTipTemplate Property

WorkbookView.FormulaToolTipTemplate Property
[image]

Gets or sets the template of the tooltip displayed when the user is editing a formula. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DataTemplate FormulaToolTipTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property FormulaToolTipTemplate As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<Border BorderBrush="{x:Static SystemColors.WindowFrameBrush}" BorderThickness="1" Background="{x:Static SystemColors.InfoBrush}" Padding="2" CornerRadius="2">
<StackPanel Orientation="Vertical">
<TextBlock Text="{Binding Title}" FontSize="12" FontWeight="Bold" Margin="0,0,0,2" MaxWidth="400" TextWrapping="Wrap" TextAlignment="Left" />
<TextBlock local:TextBlockHelper.FormattedText="{Binding Message}" FontSize="12" MaxWidth="400" TextWrapping="Wrap" TextAlignment="Left" xmlns:local="http://mindfusion.eu" />
</StackPanel>
</Border>

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HeaderMoveIndicatorBrush Property

WorkbookView.HeaderMoveIndicatorBrush Property
[image]

Gets or sets the brush uses to paint the header move indicators. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderMoveIndicatorBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderMoveIndicatorBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HeaderResizeIndicatorBrush Property

WorkbookView.HeaderResizeIndicatorBrush Property
[image]

Gets or sets the brush used to paint the header resize indicators. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderResizeIndicatorBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderResizeIndicatorBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HorizontalResizeCursor Property

WorkbookView.HorizontalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object horizontally. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor HorizontalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalResizeCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeWE.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HorizontalSplitCursor Property

WorkbookView.HorizontalSplitCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize rows. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor HorizontalSplitCursor { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalSplitCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeNS.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HScrollToolTipFormat Property

WorkbookView.HScrollToolTipFormat Property
[image]

Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the horizontal scroll bar. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string HScrollToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HScrollToolTipFormat As String

Property Value

A string value. The default is "Column: {0}".

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HyperlinkCursor Property

WorkbookView.HyperlinkCursor Property
[image]

Gets or sets the mouse cursor shown to the user if the mouse is over a cell containing a hyperlink. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor HyperlinkCursor { get; set; }

Visual Basic [image] Copy Code

Public Property HyperlinkCursor As Cursor

Property Value

An instance of the Cursor class. The default is Hand.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.MoveCursor Property

WorkbookView.MoveCursor Property
[image]

Gets or sets the mouse cursor shown to the user if the pointed object can be modified. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor MoveCursor { get; set; }

Visual Basic [image] Copy Code

Public Property MoveCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeAll.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.PointerCursor Property

WorkbookView.PointerCursor Property
[image]

Gets or sets the mouse cursor shown to the user when no modification is performed. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor PointerCursor { get; set; }

Visual Basic [image] Copy Code

Public Property PointerCursor As Cursor

Property Value

An instance of the Cursor class. The default is Arrow.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeColumnToolTipFormat Property

WorkbookView.ResizeColumnToolTipFormat Property
[image]

Gets or sets the format of the tooltip displayed when the user resizes columns. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ResizeColumnToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeColumnToolTipFormat As String

Property Value

A string value. The default is "Width: {0}".

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeHeaderToolTipTemplate Property

WorkbookView.ResizeHeaderToolTipTemplate Property
[image]

Gets or sets the template of the tooltip displayed when the user resizes rows and columns. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ResizeHeaderToolTipTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeHeaderToolTipTemplate As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<Border BorderBrush="{x:Static SystemColors.WindowFrameBrush}" BorderThickness="1" Background="{x:Static SystemColors.InfoBrush}" Padding="2" CornerRadius="2">
<TextBlock Text="{Binding}" FontSize="12" />
</Border>

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ResizeRowToolTipFormat Property

WorkbookView.ResizeRowToolTipFormat Property
[image]

Gets or sets the format of the tooltip displayed when the user resizes rows. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ResizeRowToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeRowToolTipFormat As String

Property Value

A string value. The default is "Height: {0}".

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollToolTipTemplate Property

WorkbookView.ScrollToolTipTemplate Property
[image]

Gets or sets the template of the tooltip displayed when the user scrolls the view. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ScrollToolTipTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollToolTipTemplate As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<Border BorderBrush="{x:Static SystemColors.WindowFrameBrush}" BorderThickness="1" Background="{x:Static SystemColors.InfoBrush}" Padding="2" CornerRadius="2">
<TextBlock Text="{Binding}" FontSize="12" />
</Border>

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollX Property

WorkbookView.ScrollX Property
[image]

Gets or sets the position of the horizontal scrollbar. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Integer

Property Value

An integer value.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollY Property

WorkbookView.ScrollY Property
[image]

Gets or sets the position of the vertical scrollbar. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Integer

Property Value

An integer value.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ScrollZoneSize Property

WorkbookView.ScrollZoneSize Property
[image]

Gets or sets the distance from the view border within which to start autoscrolling. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ScrollZoneSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollZoneSize As Integer

Property Value

An integer value. The default is 8.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Selection Property

WorkbookView.Selection Property
[image]

Gets the selection in the view.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowCreateNewTab Property

WorkbookView.ShowCreateNewTab Property
[image]

Gets or sets a value indicating whether to display the 'Create New Tab' button. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowCreateNewTab { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCreateNewTab As Boolean

Property Value

A boolean value. The default is true.

Remarks

The 'Create New Tab' button can be used to add worksheets to the displayed workbook interactively. When a worksheet is added this way, the WorksheetAdded event is raised.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowFormulaBox Property

WorkbookView.ShowFormulaBox Property
[image]

Gets or sets a value indicating whether to display the formula text box. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowFormulaBox { get; set; }

Visual Basic [image] Copy Code

Public Property ShowFormulaBox As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowGridLines Property

WorkbookView.ShowGridLines Property
[image]

Gets or sets a value indicating whether to display the grid lines. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowGridLines { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGridLines As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowHeaders Property

WorkbookView.ShowHeaders Property
[image]

Gets or sets a value indicating whether to display the row and column headers. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHeaders As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowHiddenHeaderIndicators Property

WorkbookView.ShowHiddenHeaderIndicators Property
[image]

Gets or sets a value indicating whether to display indicators for hidden row and column headers. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowHiddenHeaderIndicators { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHiddenHeaderIndicators As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowNavigationButtons Property

WorkbookView.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether to display the worksheet navigation buttons in the lower left corner of the view. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ShowScrollToolTips Property

WorkbookView.ShowScrollToolTips Property
[image]

Gets or sets a value indicating whether to display tooltips when scrolling with the thumb. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowScrollToolTips { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScrollToolTips As Boolean

Property Value

A boolean value. The default is true.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ToolTipTemplate Property

WorkbookView.ToolTipTemplate Property
[image]

Gets or sets the template of the tooltip displayed when the user points a cell containing an error or a hyperlink with tooltip. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ToolTipTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipTemplate As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<Border BorderBrush="{x:Static SystemColors.WindowFrameBrush}" BorderThickness="1" Background="{x:Static SystemColors.InfoBrush}" Padding="2" CornerRadius="2">
<TextBlock Text="{Binding}" FontSize="12" />
</Border>

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ValidationToolTipTemplate Property

WorkbookView.ValidationToolTipTemplate Property
[image]

Gets or sets the template of the tooltip displayed when the user selects a cell containing a validation with a message. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DataTemplate ValidationToolTipTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property ValidationToolTipTemplate As DataTemplate

Property Value

An instance of the DataTemplate class.

Remarks

The default value of this property is the following template:

XAML [image] Copy Code

<Border BorderBrush="{x:Static SystemColors.WindowFrameBrush}" BorderThickness="1" Background="{x:Static SystemColors.InfoBrush}" Padding="2" CornerRadius="2">
<StackPanel Orientation="Vertical">
<TextBlock Text="{Binding Title}" FontSize="12" FontWeight="Bold" Margin="0,0,0,2" />
<TextBlock Text="{Binding Message}" FontSize="12" MaxWidth="200" TextWrapping="Wrap" />
</StackPanel>
</Border>

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VerticalResizeCursor Property

WorkbookView.VerticalResizeCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize an object vertically. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor VerticalResizeCursor { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalResizeCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeNS.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VerticalSplitCursor Property

WorkbookView.VerticalSplitCursor Property
[image]

Gets or sets the mouse cursor shown to the user if dragging would resize columns. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Cursor VerticalSplitCursor { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalSplitCursor As Cursor

Property Value

An instance of the Cursor class. The default is SizeWE.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.VScrollToolTipFormat Property

WorkbookView.VScrollToolTipFormat Property
[image]

Gets or sets the format of the tooltip displayed when the user scrolls the view by dragging the vertical scroll bar. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string VScrollToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property VScrollToolTipFormat As String

Property Value

A string value. The default is "Row: {0}".

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.Workbook Property

WorkbookView.Workbook Property
[image]

Gets or sets the workbook displayed in this view. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Workbook Workbook { get; set; }

Visual Basic [image] Copy Code

Public Property Workbook As Workbook

Property Value

An instance of the Workbook class.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView Events

WorkbookView Events
[image]

Public Events

Name | Description
ActiveCellChanged | Raised when the active cell is changed.
ActiveWorksheetChanged | Raised when the currently active worksheet is changed.
CellClicked | Raised when a cell is clicked.
CellSelectionChanged | Raised when the selection is changed interactively, that is, modifying the selection programmatically does not raise this event.
ColumnClicked | Raised when a column header is clicked.
ColumnGroupCollapsed | Raised when a column group has been collapsed interactively.
ColumnGroupExpanded | Raised when a column group has been expanded interactively.
ColumnOutlineLevelToggled | Raised when a column outline level has been activated interactively.
ColumnsMoved | Raised when one or more columns are moved interactively.
ColumnsMoving | Raised when one or more columns are being moved interactively.
ColumnsResized | Raised when one or more columns are resized interactively.
ColumnsResizing | Raised when one or more columns are being resized interactively.
HyperlinkClicked | Raised when a cell containing a hyperlink is clicked.
InplaceEditEnded | Raised when an inplace-edit operation has finished.
InplaceEditEnding | Raised when an in-place edit operation is about to finish, before the in-place editor is closed.
InplaceEditStarted | Raised when an in-place edit operation has started, after the in-place editor is displayed.
InplaceEditStarting | Raised when an in-place edit operation is about to start, before the in-place editor is displayed.
ObjectClicked | Raised when an object is clicked.
ObjectDeleted | Raised when an object is deleted interactively.
ObjectDeleting | Raised when an object is about to be deleted interactively.
ObjectDeselected | Raised when an object is deselected, either programmatically or interactively.
ObjectModified | Raised when the user completes the modification of an object.
ObjectModifyCancelled | Raised when the user cancels the modification of an object.
ObjectModifying | Raised when the user starts modifying an interactive object.
ObjectSelected | Raised when an object is selected, either programmatically or interactively.
ObjectSelecting | Raised when the user is about to select an object.
ObjectStartModifying | Raised while the user is moving or resizing an interactive object.
RowClicked | Raised when a row header is clicked.
RowGroupCollapsed | Raised when a row group has been collapsed interactively.
RowGroupExpanded | Raised when a row group has been expanded interactively.
RowOutlineLevelToggled | Raised when a row outline level has been activated interactively.
RowsMoved | Raised when one or more rows are moved interactively.
RowsMoving | Raised when one or more rows are being moved interactively.
RowsResized | Raised when one or more rows are resized interactively.
RowsResizing | Raised when one or more rows are being resized interactively.
WorksheetAdded | Raised when a new worksheet is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.
WorksheetTabClicked | Raised when a worksheet tab is clicked with the mouse.

See Also

WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ActiveCellChanged Event

WorkbookView.ActiveCellChanged Event
[image]

Raised when the active cell is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ActiveCellChanged

Visual Basic [image] Copy Code

Public Event ActiveCellChanged As EventHandler

Event Data

ActiveCellChanged event handlers receive an argument of type EventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ActiveWorksheetChanged Event

WorkbookView.ActiveWorksheetChanged Event
[image]

Raised when the currently active worksheet is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ActiveWorksheetChanged

Visual Basic [image] Copy Code

Public Event ActiveWorksheetChanged As EventHandler

Event Data

ActiveWorksheetChanged event handlers receive an argument of type EventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.CellClicked Event

WorkbookView.CellClicked Event
[image]

Raised when a cell is clicked.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellMouseEventArgs> CellClicked

Visual Basic [image] Copy Code

Public Event CellClicked As EventHandler(Of CellMouseEventArgs)

Event Data

CellClicked event handlers receive an argument of type CellMouseEventArgs.

Remarks

This event can be used to display a context menu when a cell is right-clicked with the mouse.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.CellSelectionChanged Event

WorkbookView.CellSelectionChanged Event
[image]

Raised when the selection is changed interactively, that is, modifying the selection programmatically does not raise this event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CellSelectionChanged

Visual Basic [image] Copy Code

Public Event CellSelectionChanged As EventHandler

Event Data

CellSelectionChanged event handlers receive an argument of type EventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnClicked Event

WorkbookView.ColumnClicked Event
[image]

Raised when a column header is clicked.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnMouseEventArgs> ColumnClicked

Visual Basic [image] Copy Code

Public Event ColumnClicked As EventHandler(Of ColumnMouseEventArgs)

Event Data

ColumnClicked event handlers receive an argument of type ColumnMouseEventArgs.

Remarks

This event can be used to display a context menu when a column header is right-clicked with the mouse.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnGroupCollapsed Event

WorkbookView.ColumnGroupCollapsed Event
[image]

Raised when a column group has been collapsed interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnEventArgs> ColumnGroupCollapsed

Visual Basic [image] Copy Code

Public Event ColumnGroupCollapsed As EventHandler(Of ColumnEventArgs)

Event Data

ColumnGroupCollapsed event handlers receive an argument of type ColumnEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnGroupExpanded Event

WorkbookView.ColumnGroupExpanded Event
[image]

Raised when a column group has been expanded interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnEventArgs> ColumnGroupExpanded

Visual Basic [image] Copy Code

Public Event ColumnGroupExpanded As EventHandler(Of ColumnEventArgs)

Event Data

ColumnGroupExpanded event handlers receive an argument of type ColumnEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnOutlineLevelToggled Event

WorkbookView.ColumnOutlineLevelToggled Event
[image]

Raised when a column outline level has been activated interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<OutlineEventArgs> ColumnOutlineLevelToggled

Visual Basic [image] Copy Code

Public Event ColumnOutlineLevelToggled As EventHandler(Of OutlineEventArgs)

Event Data

ColumnOutlineLevelToggled event handlers receive an argument of type OutlineEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnsMoved Event

WorkbookView.ColumnsMoved Event
[image]

Raised when one or more columns are moved interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnRangeEventArgs> ColumnsMoved

Visual Basic [image] Copy Code

Public Event ColumnsMoved As EventHandler(Of ColumnRangeEventArgs)

Event Data

ColumnsMoved event handlers receive an argument of type ColumnRangeEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnsMoving Event

WorkbookView.ColumnsMoving Event
[image]

Raised when one or more columns are being moved interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnRangeMovingEventArgs> ColumnsMoving

Visual Basic [image] Copy Code

Public Event ColumnsMoving As EventHandler(Of ColumnRangeMovingEventArgs)

Event Data

ColumnsMoving event handlers receive an argument of type ColumnRangeMovingEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnsResized Event

WorkbookView.ColumnsResized Event
[image]

Raised when one or more columns are resized interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnRangeEventArgs> ColumnsResized

Visual Basic [image] Copy Code

Public Event ColumnsResized As EventHandler(Of ColumnRangeEventArgs)

Event Data

ColumnsResized event handlers receive an argument of type ColumnRangeEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ColumnsResizing Event

WorkbookView.ColumnsResizing Event
[image]

Raised when one or more columns are being resized interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnRangeResizingEventArgs> ColumnsResizing

Visual Basic [image] Copy Code

Public Event ColumnsResizing As EventHandler(Of ColumnRangeResizingEventArgs)

Event Data

ColumnsResizing event handlers receive an argument of type ColumnRangeResizingEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.HyperlinkClicked Event

WorkbookView.HyperlinkClicked Event
[image]

Raised when a cell containing a hyperlink is clicked.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> HyperlinkClicked

Visual Basic [image] Copy Code

Public Event HyperlinkClicked As EventHandler(Of CellEventArgs)

Event Data

HyperlinkClicked event handlers receive an argument of type CellEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.InplaceEditEnded Event

WorkbookView.InplaceEditEnded Event
[image]

Raised when an inplace-edit operation has finished.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InplaceEditEventArgs> InplaceEditEnded

Visual Basic [image] Copy Code

Public Event InplaceEditEnded As EventHandler(Of InplaceEditEventArgs)

Event Data

InplaceEditEnded event handlers receive an argument of type InplaceEditEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.InplaceEditEnding Event

WorkbookView.InplaceEditEnding Event
[image]

Raised when an in-place edit operation is about to finish, before the in-place editor is closed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InplaceEditValidationEventArgs> InplaceEditEnding

Visual Basic [image] Copy Code

Public Event InplaceEditEnding As EventHandler(Of InplaceEditValidationEventArgs)

Event Data

InplaceEditEnding event handlers receive an argument of type InplaceEditValidationEventArgs.

Remarks

This event can be used to validate the input of an in-place editing operation. Set the Cancel property of the event argument to false to reject the in-place editing operation.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.InplaceEditStarted Event

WorkbookView.InplaceEditStarted Event
[image]

Raised when an in-place edit operation has started, after the in-place editor is displayed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InplaceEditEventArgs> InplaceEditStarted

Visual Basic [image] Copy Code

Public Event InplaceEditStarted As EventHandler(Of InplaceEditEventArgs)

Event Data

InplaceEditStarted event handlers receive an argument of type InplaceEditEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.InplaceEditStarting Event

WorkbookView.InplaceEditStarting Event
[image]

Raised when an in-place edit operation is about to start, before the in-place editor is displayed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<InplaceEditValidationEventArgs> InplaceEditStarting

Visual Basic [image] Copy Code

Public Event InplaceEditStarting As EventHandler(Of InplaceEditValidationEventArgs)

Event Data

InplaceEditStarting event handlers receive an argument of type InplaceEditValidationEventArgs.

Remarks

This event can be used to prevent specific (or all) cells in a worksheet from being in-place editable. Set the Cancel property of the event argument to false to accomplish this.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectClicked Event

WorkbookView.ObjectClicked Event
[image]

Raised when an object is clicked.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectMouseEventArgs> ObjectClicked

Visual Basic [image] Copy Code

Public Event ObjectClicked As EventHandler(Of ObjectMouseEventArgs)

Event Data

ObjectClicked event handlers receive an argument of type ObjectMouseEventArgs.

Remarks

This event can be used to display a context menu when an object is right-clicked with the mouse.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectDeleted Event

WorkbookView.ObjectDeleted Event
[image]

Raised when an object is deleted interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectEventArgs> ObjectDeleted

Visual Basic [image] Copy Code

Public Event ObjectDeleted As EventHandler(Of ObjectEventArgs)

Event Data

ObjectDeleted event handlers receive an argument of type ObjectEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectDeleting Event

WorkbookView.ObjectDeleting Event
[image]

Raised when an object is about to be deleted interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectValidationEventArgs> ObjectDeleting

Visual Basic [image] Copy Code

Public Event ObjectDeleting As EventHandler(Of ObjectValidationEventArgs)

Event Data

ObjectDeleting event handlers receive an argument of type ObjectValidationEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectDeselected Event

WorkbookView.ObjectDeselected Event
[image]

Raised when an object is deselected, either programmatically or interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectEventArgs> ObjectDeselected

Visual Basic [image] Copy Code

Public Event ObjectDeselected As EventHandler(Of ObjectEventArgs)

Event Data

ObjectDeselected event handlers receive an argument of type ObjectEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectModified Event

WorkbookView.ObjectModified Event
[image]

Raised when the user completes the modification of an object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectInteractionEventArgs> ObjectModified

Visual Basic [image] Copy Code

Public Event ObjectModified As EventHandler(Of ObjectInteractionEventArgs)

Event Data

ObjectModified event handlers receive an argument of type ObjectInteractionEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectModifyCancelled Event

WorkbookView.ObjectModifyCancelled Event
[image]

Raised when the user cancels the modification of an object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectInteractionEventArgs> ObjectModifyCancelled

Visual Basic [image] Copy Code

Public Event ObjectModifyCancelled As EventHandler(Of ObjectInteractionEventArgs)

Event Data

ObjectModifyCancelled event handlers receive an argument of type ObjectInteractionEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectModifying Event

WorkbookView.ObjectModifying Event
[image]

Raised when the user starts modifying an interactive object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectInteractionValidationEventArgs> ObjectModifying

Visual Basic [image] Copy Code

Public Event ObjectModifying As EventHandler(Of ObjectInteractionValidationEventArgs)

Event Data

ObjectModifying event handlers receive an argument of type ObjectInteractionValidationEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectSelected Event

WorkbookView.ObjectSelected Event
[image]

Raised when an object is selected, either programmatically or interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectEventArgs> ObjectSelected

Visual Basic [image] Copy Code

Public Event ObjectSelected As EventHandler(Of ObjectEventArgs)

Event Data

ObjectSelected event handlers receive an argument of type ObjectEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectSelecting Event

WorkbookView.ObjectSelecting Event
[image]

Raised when the user is about to select an object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectInteractionValidationEventArgs> ObjectSelecting

Visual Basic [image] Copy Code

Public Event ObjectSelecting As EventHandler(Of ObjectInteractionValidationEventArgs)

Event Data

ObjectSelecting event handlers receive an argument of type ObjectInteractionValidationEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.ObjectStartModifying Event

WorkbookView.ObjectStartModifying Event
[image]

Raised while the user is moving or resizing an interactive object.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ObjectInteractionValidationEventArgs> ObjectStartModifying

Visual Basic [image] Copy Code

Public Event ObjectStartModifying As EventHandler(Of ObjectInteractionValidationEventArgs)

Event Data

ObjectStartModifying event handlers receive an argument of type ObjectInteractionValidationEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowClicked Event

WorkbookView.RowClicked Event
[image]

Raised when a row header is clicked.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowMouseEventArgs> RowClicked

Visual Basic [image] Copy Code

Public Event RowClicked As EventHandler(Of RowMouseEventArgs)

Event Data

RowClicked event handlers receive an argument of type RowMouseEventArgs.

Remarks

This event can be used to display a context menu when a row header is right-clicked with the mouse.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowGroupCollapsed Event

WorkbookView.RowGroupCollapsed Event
[image]

Raised when a row group has been collapsed interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> RowGroupCollapsed

Visual Basic [image] Copy Code

Public Event RowGroupCollapsed As EventHandler(Of RowEventArgs)

Event Data

RowGroupCollapsed event handlers receive an argument of type RowEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowGroupExpanded Event

WorkbookView.RowGroupExpanded Event
[image]

Raised when a row group has been expanded interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> RowGroupExpanded

Visual Basic [image] Copy Code

Public Event RowGroupExpanded As EventHandler(Of RowEventArgs)

Event Data

RowGroupExpanded event handlers receive an argument of type RowEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowOutlineLevelToggled Event

WorkbookView.RowOutlineLevelToggled Event
[image]

Raised when a row outline level has been activated interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<OutlineEventArgs> RowOutlineLevelToggled

Visual Basic [image] Copy Code

Public Event RowOutlineLevelToggled As EventHandler(Of OutlineEventArgs)

Event Data

RowOutlineLevelToggled event handlers receive an argument of type OutlineEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowsMoved Event

WorkbookView.RowsMoved Event
[image]

Raised when one or more rows are moved interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowRangeEventArgs> RowsMoved

Visual Basic [image] Copy Code

Public Event RowsMoved As EventHandler(Of RowRangeEventArgs)

Event Data

RowsMoved event handlers receive an argument of type RowRangeEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowsMoving Event

WorkbookView.RowsMoving Event
[image]

Raised when one or more rows are being moved interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowRangeMovingEventArgs> RowsMoving

Visual Basic [image] Copy Code

Public Event RowsMoving As EventHandler(Of RowRangeMovingEventArgs)

Event Data

RowsMoving event handlers receive an argument of type RowRangeMovingEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowsResized Event

WorkbookView.RowsResized Event
[image]

Raised when one or more rows are resized interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowRangeEventArgs> RowsResized

Visual Basic [image] Copy Code

Public Event RowsResized As EventHandler(Of RowRangeEventArgs)

Event Data

RowsResized event handlers receive an argument of type RowRangeEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.RowsResizing Event

WorkbookView.RowsResizing Event
[image]

Raised when one or more rows are being resized interactively.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowRangeResizingEventArgs> RowsResizing

Visual Basic [image] Copy Code

Public Event RowsResizing As EventHandler(Of RowRangeResizingEventArgs)

Event Data

RowsResizing event handlers receive an argument of type RowRangeResizingEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.WorksheetAdded Event

WorkbookView.WorksheetAdded Event
[image]

Raised when a new worksheet is added to the view interactively, that is, when the user clicks on the 'Create New Tab' button.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<WorksheetEventArgs> WorksheetAdded

Visual Basic [image] Copy Code

Public Event WorksheetAdded As EventHandler(Of WorksheetEventArgs)

Event Data

WorksheetAdded event handlers receive an argument of type WorksheetEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorkbookView.WorksheetTabClicked Event

WorkbookView.WorksheetTabClicked Event
[image]

Raised when a worksheet tab is clicked with the mouse.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<WorksheetTabMouseEventArgs> WorksheetTabClicked

Visual Basic [image] Copy Code

Public Event WorksheetTabClicked As EventHandler(Of WorksheetTabMouseEventArgs)

Event Data

WorksheetTabClicked event handlers receive an argument of type WorksheetTabMouseEventArgs.

See Also

WorkbookView Members
WorkbookView Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet Class

Worksheet Class
Remarks See Also
[image]

Represents a worksheet in a workbook, that is, a rectangular grid of cells containing data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Worksheet : ICanTrackChanges, IHasName, ISupportInitialize, INotifyPropertyValueChanged, INotifyPropertyChanged, IDocumentPaginatorSource

Visual Basic [image] Copy Code

Public Class Worksheet
Implements ICanTrackChanges, IHasName, ISupportInitialize, INotifyPropertyValueChanged, INotifyPropertyChanged, IDocumentPaginatorSource

Remarks

The Worksheet class represents a rectangular grid of cells. Each cell can contain data, such as numbers, text, and formulas. The cells in the worksheet are accessed through the Cells property, by providing the cell name or the zero-based indices of the cell's column and row. The cell name is specified in the A1 or R1C1 formats. For example, the cell with column 2 and row 3 (both zero-based) can be referenced by name by using either "C4" or "R4C3". The individual cells in the worksheet are represented by the Cell class. This class can be used to manage the cell's data, style the cell, and so on.

The Worksheet class can also provide access to a rectangular subset of cells through the CellRange class. Instances of this class can be obtained through the CellRanges collection by specifying the top, left, bottom, and right cells of the cell area of interest. The CellRange objects can be used to style the entire range of cells, to merge and unmerge the cells in the range, and so on.

The rows and columns in the worksheet are represented by the Row and Column classes respectively. The individual rows and columns are obtained by indexing the Rows and Columns collections. The Row and Column objects can be used to adjust the size of the respective row and column and to style all cells in the row or column.

In addition to the regular data, the worksheet can also contain pictures and charts (collectively known as drawings). The drawings in the worksheet are managed through the Drawing object.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Worksheet

See Also

Worksheet Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet Members

Worksheet Members
Properties Methods Events
[image]

Represents a worksheet in a workbook, that is, a rectangular grid of cells containing data.

The following tables list the members exposed by the Worksheet type.

Public Properties

Name | Description
AutoFilter | Gets an AutoFilter object if autofiltering is enabled; otherwise, null.
AutoFilterMode | Gets or sets a value indicating whether there is an active autofilter in the worksheet.
CellRanges | Gets an object that can be used to access and manipulate rectangular ranges of worksheet cells.
Cells | Gets an object that can be used to access worksheet cells by (column, row) index or by name.
Columns | Gets an object that can be used to insert, delete and modify worksheet columns.
DefaultColumnWidth | Gets or sets the default width of columns.
DefaultRowHeight | Gets or sets the default height of rows.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
Drawing | Gets the Drawing object associated with the worksheet.
FirstFrozenColumn | Gets or sets the index of the first frozen column in the worksheet.
FirstFrozenRow | Gets or sets the index of the first frozen row in the worksheet.
FrozenColumnCount | Gets or sets the number of frozen columns in the worksheet.
FrozenRowCount | Gets or sets the number of frozen rows in the worksheet.
Locale | Gets the locale of the parent workbook.
MergedCells | Gets a list with the currently merged cells.
Name | Gets or sets the name of the worksheet.
Rows | Gets an object that can be used to insert, delete and modify worksheet rows.
Tag | Gets or sets a custom object associated with the worksheet.
Visible | Gets or sets a value indicating whether this worksheet is visible.

Public Methods

Name | Description
BeginInit | Signals the worksheet to enter an initialization state. To exit the initialization state, call EndInit.
Clear | Clears the entire content of the worksheet.
Copy | Overloaded. Copies this worksheet to another workbook.
CopyData | Copies the data in the specified range and returns an object identifying the copied data.
CopyStyles | Copies the styles in the specified range and returns an object identifying the copied styles.
EndInit | Signals the worksheet that initialization is complete. To enter initialization state, call BeginInit.
GetMergedCell | Overloaded. Gets the merged cell containing the specified cell.
Merge | Overloaded. Merges the cells in a specified range into a single cell.
Move | Overloaded. Moves this worksheet to another workbook.
PasteData | Pastes the data identified by the specified object at the specified location. The data in the target range is discarded.
PasteStyles | Pastes the styles identified by the specified object at the specified location. The style information in the target range is discarded.
Sort | Sorts the data in the specified range according to the specified criteria.
ToString | Object.ToString override.
Unmerge | Overloaded. Unmerges all merged cells intersecting with a specified range.

Protected Methods

Name | Description
OnCellChanged | Raises the CellChanged event.
OnCellChanging | Raises the CellChanging event.
OnCellsCleared | Raises the CellsCleared event.
OnColumnChanged | Raises the ColumnChanged event.
OnPropertyChanged | Raises the PropertyChanged event.
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnRowChanged | Raises the RowChanged event.
OnValidationFailed | Raises the ValidationFailed event.

Public Events

Name | Description
CellChanged | Raised when a cell of the worksheet is changed.
CellChanging | Raised when a cell of the worksheet is about to change.
CellsCleared | Raised when a range of cells has been cleared.
ColumnChanged | Raised when a column is changed.
PropertyChanged | Raised when a property of the worksheet is changed.
PropertyValueChanged | Raised when a property of the worksheet is changed.
RowChanged | Raised when a row is changed.
ValidationFailed | Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

See Also

Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet Methods

Worksheet Methods
[image]

Public Methods

Name | Description
BeginInit | Signals the worksheet to enter an initialization state. To exit the initialization state, call EndInit.
Clear | Clears the entire content of the worksheet.
Copy | Overloaded. Copies this worksheet to another workbook.
CopyData | Copies the data in the specified range and returns an object identifying the copied data.
CopyStyles | Copies the styles in the specified range and returns an object identifying the copied styles.
EndInit | Signals the worksheet that initialization is complete. To enter initialization state, call BeginInit.
GetMergedCell | Overloaded. Gets the merged cell containing the specified cell.
Merge | Overloaded. Merges the cells in a specified range into a single cell.
Move | Overloaded. Moves this worksheet to another workbook.
PasteData | Pastes the data identified by the specified object at the specified location. The data in the target range is discarded.
PasteStyles | Pastes the styles identified by the specified object at the specified location. The style information in the target range is discarded.
Sort | Sorts the data in the specified range according to the specified criteria.
ToString | Object.ToString override.
Unmerge | Overloaded. Unmerges all merged cells intersecting with a specified range.

Protected Methods

Name | Description
OnCellChanged | Raises the CellChanged event.
OnCellChanging | Raises the CellChanging event.
OnCellsCleared | Raises the CellsCleared event.
OnColumnChanged | Raises the ColumnChanged event.
OnPropertyChanged | Raises the PropertyChanged event.
OnPropertyValueChanged | Raises the PropertyValueChanged event.
OnRowChanged | Raises the RowChanged event.
OnValidationFailed | Raises the ValidationFailed event.

See Also

Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.BeginInit Method

Worksheet.BeginInit Method
[image]

Signals the worksheet to enter an initialization state. To exit the initialization state, call EndInit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void BeginInit ()

Visual Basic [image] Copy Code

Public Sub BeginInit ()

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Clear Method

Worksheet.Clear Method
[image]

Clears the entire content of the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Copy Method

Worksheet.Copy Method
[image]

Copies this worksheet to another workbook.

Overload List

Name | Description
Worksheet.Copy (Workbook) | Copies this worksheet to the specified workbook.
Worksheet.Copy (Workbook, Int32) | Copies this worksheet to the specified workbook at the specified index.
Worksheet.Copy (Workbook, Int32, String) | Copies this worksheet to the specified workbook at the specified index.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Copy Method (Workbook)

Worksheet.Copy Method (Workbook)
See Also
[image]

Copies this worksheet to the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Copy (
Workbook workbook
)

Visual Basic [image] Copy Code

Public Function Copy( _
workbook As Workbook _
) As Boolean

Parameters

workbook

The workbook to copy to.

Return Value

true if the copy was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Copy Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Copy Method (Workbook, Int32)

Worksheet.Copy Method (Workbook, Int32)
See Also
[image]

Copies this worksheet to the specified workbook at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Copy (
Workbook workbook,
int index
)

Visual Basic [image] Copy Code

Public Function Copy( _
workbook As Workbook, _
index As Integer _
) As Boolean

Parameters

workbook

The workbook to copy to.

index

The 0-based index in the target workbook where to copy this worksheet, or -1, to copy at the end of the workbook.

Return Value

true if the copy was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Copy Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Copy Method (Workbook, Int32, String)

Worksheet.Copy Method (Workbook, Int32, String)
See Also
[image]

Copies this worksheet to the specified workbook at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Copy (
Workbook workbook,
int index,
string name
)

Visual Basic [image] Copy Code

Public Function Copy( _
workbook As Workbook, _
index As Integer, _
name As String _
) As Boolean

Parameters

workbook

The workbook to copy to.

index

The 0-based index in the target workbook where to copy this worksheet, or -1, to copy at the end of the workbook.

name

The new name of copied the worksheet.

Return Value

true if the copy was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Copy Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CopyData Method

Worksheet.CopyData Method
[image]

Copies the data in the specified range and returns an object identifying the copied data.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellData CopyData (
CellRange range
)

Visual Basic [image] Copy Code

Public Function CopyData( _
range As CellRange _
) As CellData

Parameters

range

The range from which the data is copied.

Return Value

An object identifying the copied data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CopyStyles Method

Worksheet.CopyStyles Method
[image]

Copies the styles in the specified range and returns an object identifying the copied styles.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public StyleData CopyStyles (
CellRange range
)

Visual Basic [image] Copy Code

Public Function CopyStyles( _
range As CellRange _
) As StyleData

Parameters

range

The range from which the styles are copied.

Return Value

An object identifying the copied styles.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.EndInit Method

Worksheet.EndInit Method
[image]

Signals the worksheet that initialization is complete. To enter initialization state, call BeginInit.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void EndInit ()

Visual Basic [image] Copy Code

Public Sub EndInit ()

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.GetMergedCell Method

Worksheet.GetMergedCell Method
[image]

Gets the merged cell containing the specified cell.

Overload List

Name | Description
Worksheet.GetMergedCell (Cell) | Gets the merged cell containing the specified cell, if this cell is part of a merged cell.
Worksheet.GetMergedCell (Int32, Int32) | Gets the merged cell containing the cell with the specified coordinates, if this cell is part of a merged cell.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.GetMergedCell Method (Cell)

Worksheet.GetMergedCell Method (Cell)
See Also
[image]

Gets the merged cell containing the specified cell, if this cell is part of a merged cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange GetMergedCell (
Cell cell
)

Visual Basic [image] Copy Code

Public Function GetMergedCell( _
cell As Cell _
) As CellRange

Parameters

cell

The cell to inspect.

Return Value

An instance of the CellRange class representing the containing merged cell, or null (Nothing in Visual Basic), if cell is not merged.

See Also

GetMergedCell Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.GetMergedCell Method (Int32, Int32)

Worksheet.GetMergedCell Method (Int32, Int32)
See Also
[image]

Gets the merged cell containing the cell with the specified coordinates, if this cell is part of a merged cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRange GetMergedCell (
int column,
int row
)

Visual Basic [image] Copy Code

Public Function GetMergedCell( _
column As Integer, _
row As Integer _
) As CellRange

Parameters

column

The column of the cell to inspect.

row

The row of the cell to inspect.

Return Value

An instance of the CellRange class representing the containing merged cell, or null (Nothing in Visual Basic), if the cell with the specified coordinates is not merged.

See Also

GetMergedCell Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Merge Method

Worksheet.Merge Method
[image]

Merges the cells in a specified range into a single cell.

Overload List

Name | Description
Worksheet.Merge (CellRange) | Merges the cells in the specified range into a single cell.
Worksheet.Merge (Int32, Int32, Int32, Int32) | Merges the cells in the specified range into a single cell.
Worksheet.Merge (String) | Merges the cells in the specified range into a single cell.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Merge Method (CellRange)

Worksheet.Merge Method (CellRange)
See Also
[image]

Merges the cells in the specified range into a single cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Merge (
CellRange range
)

Visual Basic [image] Copy Code

Public Function Merge( _
range As CellRange _
) As Boolean

Parameters

range

The range that specifies the cells to merge.

Return Value

true if the merge was successful; otherwise, false.

Remarks

The merge will fail if the specified range contains only a single cell or if the range intersects with another merged cell.

See Also

Merge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Merge Method (Int32, Int32, Int32, Int32)

Worksheet.Merge Method (Int32, Int32, Int32, Int32)
See Also
[image]

Merges the cells in the specified range into a single cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Merge (
int topLeftColumn,
int topLeftRow,
int bottomRightColumn,
int bottomRightRow
)

Visual Basic [image] Copy Code

Public Function Merge( _
topLeftColumn As Integer, _
topLeftRow As Integer, _
bottomRightColumn As Integer, _
bottomRightRow As Integer _
) As Boolean

Parameters

topLeftColumn

The top-left column of the range of cells.

topLeftRow

The top-left row of the range of cells.

bottomRightColumn

The bottom-right column of the range of cells.

bottomRightRow

The bottom-right row of the range of cells.

Return Value

true if the merge was successful; otherwise, false.

Remarks

The merge will fail if the specified range contains only a single cell or if the range intersects with another merged cell.

See Also

Merge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Merge Method (String)

Worksheet.Merge Method (String)
See Also
[image]

Merges the cells in the specified range into a single cell.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Merge (
string range
)

Visual Basic [image] Copy Code

Public Function Merge( _
range As String _
) As Boolean

Parameters

range

A string specifying the range of cells to merge.

Return Value

true if the merge was successful; otherwise, false.

Remarks

The merge will fail if the specified range contains only a single cell or if the range intersects with another merged cell.

See Also

Merge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Move Method

Worksheet.Move Method
[image]

Moves this worksheet to another workbook.

Overload List

Name | Description
Worksheet.Move (Workbook) | Moves this worksheet to the specified workbook.
Worksheet.Move (Workbook, Int32) | Moves this worksheet to the specified workbook at the specified position.
Worksheet.Move (Workbook, Int32, String) | Moves this worksheet to the specified workbook at the specified position.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Move Method (Workbook)

Worksheet.Move Method (Workbook)
See Also
[image]

Moves this worksheet to the specified workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Move (
Workbook workbook
)

Visual Basic [image] Copy Code

Public Function Move( _
workbook As Workbook _
) As Boolean

Parameters

workbook

The workbook to move to.

Return Value

true if the move was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Move Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Move Method (Workbook, Int32)

Worksheet.Move Method (Workbook, Int32)
See Also
[image]

Moves this worksheet to the specified workbook at the specified position.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Move (
Workbook workbook,
int index
)

Visual Basic [image] Copy Code

Public Function Move( _
workbook As Workbook, _
index As Integer _
) As Boolean

Parameters

workbook

The workbook to move to.

index

The 0-based index in the target workbook where to copy this worksheet, or -1, to copy at the end of the workbook.

Return Value

true if the move was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Move Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Move Method (Workbook, Int32, String)

Worksheet.Move Method (Workbook, Int32, String)
See Also
[image]

Moves this worksheet to the specified workbook at the specified position.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Move (
Workbook workbook,
int index,
string name
)

Visual Basic [image] Copy Code

Public Function Move( _
workbook As Workbook, _
index As Integer, _
name As String _
) As Boolean

Parameters

workbook

The workbook to move to.

index

The 0-based index in the target workbook where to copy this worksheet, or -1, to copy at the end of the workbook.

name

The new name of moved the worksheet.

Return Value

true if the move was successful; otherwise, false. The method returns false if the workbook contains a worksheet with the same name.

See Also

Move Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnCellChanged Method

Worksheet.OnCellChanged Method
[image]

Raises the CellChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellChanged (
CellChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellChanged( _
e As CellChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnCellChanging Method

Worksheet.OnCellChanging Method
[image]

Raises the CellChanging event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellChanging (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellChanging( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnCellsCleared Method

Worksheet.OnCellsCleared Method
[image]

Raises the CellsCleared event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCellsCleared (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellsCleared( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnColumnChanged Method

Worksheet.OnColumnChanged Method
[image]

Raises the ColumnChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnColumnChanged (
ColumnChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnColumnChanged( _
e As ColumnChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnPropertyChanged Method

Worksheet.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnPropertyValueChanged Method

Worksheet.OnPropertyValueChanged Method
[image]

Raises the PropertyValueChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPropertyValueChanged (
PropertyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyValueChanged( _
e As PropertyEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnRowChanged Method

Worksheet.OnRowChanged Method
[image]

Raises the RowChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRowChanged (
RowChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRowChanged( _
e As RowChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.OnValidationFailed Method

Worksheet.OnValidationFailed Method
[image]

Raises the ValidationFailed event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValidationFailed (
ValidationFailedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidationFailed( _
e As ValidationFailedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.PasteData Method

Worksheet.PasteData Method
[image]

Pastes the data identified by the specified object at the specified location. The data in the target range is discarded.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PasteData (
Cell cell,
CellData cellData
)

Visual Basic [image] Copy Code

Public Sub PasteData( _
cell As Cell, _
cellData As CellData _
)

Parameters

cell

A Cell object identifying the target range. The dimensions of the target range are identical to the dimensions of the source range.

cellData

An object identifying the data to paste.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.PasteStyles Method

Worksheet.PasteStyles Method
[image]

Pastes the styles identified by the specified object at the specified location. The style information in the target range is discarded.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void PasteStyles (
Cell cell,
StyleData styleData
)

Visual Basic [image] Copy Code

Public Sub PasteStyles( _
cell As Cell, _
styleData As StyleData _
)

Parameters

cell

A Cell object identifying the target range. The dimensions of the target range are identical to the dimensions of the source range.

styleData

An object identifying the styles to paste.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Sort Method

Worksheet.Sort Method
[image]

Sorts the data in the specified range according to the specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Sort (
CellRange range,
SortOptions options
)

Visual Basic [image] Copy Code

Public Function Sort( _
range As CellRange, _
options As SortOptions _
) As Boolean

Parameters

range

The range to sort.

options

The sort settings, such as sort keys and direction.

Return Value

true if the sort was successful; otherwise, false.

Remarks

The sorting will fail if there are no keys specified or if all keys are outside of the current range.

Example

The following example illustrates how to sort the data in range A1:D10 in an existing worksheet by the first column.

C# [image] Copy Code

SortOptions options = new SortOptions();
options.Keys.Add(new SortKey(0));
worksheet.CellRanges["A1:D10"].Sort(options);

Visual Basic [image] Copy Code

Dim options As New SortOptions()
options.Keys.Add(New SortKey(0))
worksheet.CellRanges("A1:D10").Sort(options)

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.ToString Method

Worksheet.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string value.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Unmerge Method

Worksheet.Unmerge Method
[image]

Unmerges all merged cells intersecting with a specified range.

Overload List

Name | Description
Worksheet.Unmerge (CellRange) | Unmerges all merged cells intersecting with the specified range.
Worksheet.Unmerge (Int32, Int32, Int32, Int32) | Unmerges all merged cells intersecting with the specified range.
Worksheet.Unmerge (String) | Unmerges all merged cells intersecting with the specified range.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Unmerge Method (CellRange)

Worksheet.Unmerge Method (CellRange)
See Also
[image]

Unmerges all merged cells intersecting with the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Unmerge (
CellRange range
)

Visual Basic [image] Copy Code

Public Sub Unmerge( _
range As CellRange _
)

Parameters

range

A range that specifies the cells to unmerge.

See Also

Unmerge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Unmerge Method (Int32, Int32, Int32, Int32)

Worksheet.Unmerge Method (Int32, Int32, Int32, Int32)
See Also
[image]

Unmerges all merged cells intersecting with the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Unmerge (
int topLeftColumn,
int topLeftRow,
int bottomRightColumn,
int bottomRightRow
)

Visual Basic [image] Copy Code

Public Sub Unmerge( _
topLeftColumn As Integer, _
topLeftRow As Integer, _
bottomRightColumn As Integer, _
bottomRightRow As Integer _
)

Parameters

topLeftColumn

The top-left column of the range of cells.

topLeftRow

The top-left row of the range of cells.

bottomRightColumn

The bottom-right column of the range of cells.

bottomRightRow

The bottom-right row of the range of cells.

See Also

Unmerge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Unmerge Method (String)

Worksheet.Unmerge Method (String)
See Also
[image]

Unmerges all merged cells intersecting with the specified range.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Unmerge (
string range
)

Visual Basic [image] Copy Code

Public Sub Unmerge( _
range As String _
)

Parameters

range

A string specifying the range of cells to unmerge.

See Also

Unmerge Method Overload List
Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet Properties

Worksheet Properties
[image]

Public Properties

Name | Description
AutoFilter | Gets an AutoFilter object if autofiltering is enabled; otherwise, null.
AutoFilterMode | Gets or sets a value indicating whether there is an active autofilter in the worksheet.
CellRanges | Gets an object that can be used to access and manipulate rectangular ranges of worksheet cells.
Cells | Gets an object that can be used to access worksheet cells by (column, row) index or by name.
Columns | Gets an object that can be used to insert, delete and modify worksheet columns.
DefaultColumnWidth | Gets or sets the default width of columns.
DefaultRowHeight | Gets or sets the default height of rows.
DocumentPaginator | IDocumentPaginatorSource.DocumentPaginator implementation.
Drawing | Gets the Drawing object associated with the worksheet.
FirstFrozenColumn | Gets or sets the index of the first frozen column in the worksheet.
FirstFrozenRow | Gets or sets the index of the first frozen row in the worksheet.
FrozenColumnCount | Gets or sets the number of frozen columns in the worksheet.
FrozenRowCount | Gets or sets the number of frozen rows in the worksheet.
Locale | Gets the locale of the parent workbook.
MergedCells | Gets a list with the currently merged cells.
Name | Gets or sets the name of the worksheet.
Rows | Gets an object that can be used to insert, delete and modify worksheet rows.
Tag | Gets or sets a custom object associated with the worksheet.
Visible | Gets or sets a value indicating whether this worksheet is visible.

See Also

Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.AutoFilter Property

Worksheet.AutoFilter Property
[image]

Gets an AutoFilter object if autofiltering is enabled; otherwise, null.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AutoFilter AutoFilter { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AutoFilter As AutoFilter

Property Value

Remarks

To create an AutoFilter object for a worksheet, you must enable autofiltering for a range on the worksheet by using the AutoFilter method of the CellRange class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.AutoFilterMode Property

Worksheet.AutoFilterMode Property
[image]

Gets or sets a value indicating whether there is an active autofilter in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool AutoFilterMode { get; set; }

Visual Basic [image] Copy Code

Public Property AutoFilterMode As Boolean

Property Value

Remarks

This property can be set to false to turn autofiltering off, but cannot be set to true. To enable autofiltering, call the AutoFilter method of the CellRange class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CellRanges Property

Worksheet.CellRanges Property
[image]

Gets an object that can be used to access and manipulate rectangular ranges of worksheet cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellRangeCollection CellRanges { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellRanges As CellRangeCollection

Property Value

An instance of the CellRangeCollection class.

Example

The following example applies a new background to all cells in the range 'A1:C10', by using a CellRange object.

C# [image] Copy Code

worksheet.CellRanges["A1:C10"].Style.Background = Brushes.PaleGoldenrod;

Visual Basic [image] Copy Code

worksheet.CellRanges("A1:C10").Style.Background = Brushes.PaleGoldenrod

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Cells Property

Worksheet.Cells Property
[image]

Gets an object that can be used to access worksheet cells by (column, row) index or by name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CellCollection Cells { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cells As CellCollection

Property Value

An instance of the CellCollection class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Columns Property

Worksheet.Columns Property
[image]

Gets an object that can be used to insert, delete and modify worksheet columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ColumnCollection Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As ColumnCollection

Property Value

An instance of the ColumnCollection class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.DefaultColumnWidth Property

Worksheet.DefaultColumnWidth Property
[image]

Gets or sets the default width of columns.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure DefaultColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultColumnWidth As Measure

Property Value

An instance of the Measure class. The default is "48pt".

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.DefaultRowHeight Property

Worksheet.DefaultRowHeight Property
[image]

Gets or sets the default height of rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure DefaultRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultRowHeight As Measure

Property Value

An instance of the Measure class. The default is "14.25pt".

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.DocumentPaginator Property

Worksheet.DocumentPaginator Property
[image]

IDocumentPaginatorSource.DocumentPaginator implementation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DocumentPaginator DocumentPaginator { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DocumentPaginator As DocumentPaginator

Property Value

An instance of the DocumentPaginator class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Drawing Property

Worksheet.Drawing Property
[image]

Gets the Drawing object associated with the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Drawing Drawing { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Drawing As Drawing

Property Value

An instance of the Drawing class.

Remarks

The Drawing class can be used to add, manipulate and remove drawing objects (such as pictures and charts) from the worksheet.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.FirstFrozenColumn Property

Worksheet.FirstFrozenColumn Property
[image]

Gets or sets the index of the first frozen column in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FirstFrozenColumn { get; set; }

Visual Basic [image] Copy Code

Public Property FirstFrozenColumn As Integer

Property Value

An integer value.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.FirstFrozenRow Property

Worksheet.FirstFrozenRow Property
[image]

Gets or sets the index of the first frozen row in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FirstFrozenRow { get; set; }

Visual Basic [image] Copy Code

Public Property FirstFrozenRow As Integer

Property Value

An integer value.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.FrozenColumnCount Property

Worksheet.FrozenColumnCount Property
[image]

Gets or sets the number of frozen columns in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FrozenColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property FrozenColumnCount As Integer

Property Value

An integer value. The default is 0.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.FrozenRowCount Property

Worksheet.FrozenRowCount Property
[image]

Gets or sets the number of frozen rows in the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int FrozenRowCount { get; set; }

Visual Basic [image] Copy Code

Public Property FrozenRowCount As Integer

Property Value

An integer value. The default is 0.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Locale Property

Worksheet.Locale Property
[image]

Gets the locale of the parent workbook.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.MergedCells Property

Worksheet.MergedCells Property
[image]

Gets a list with the currently merged cells.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MergedCellsCollection MergedCells { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MergedCells As MergedCellsCollection

Property Value

An instance of the MergedCellsCollection class.

Remarks

The returned object can be used only to iterate and clear the existing merged cells. To create and remove merged cells, use the Merge and Unmerge methods of the worksheet.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Name Property

Worksheet.Name Property
[image]

Gets or sets the name of the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value.

Remarks

The name of a worksheet must be unique (ignoring case) amongst all worksheets in a Workbook.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Rows Property

Worksheet.Rows Property
[image]

Gets an object that can be used to insert, delete and modify worksheet rows.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public RowCollection Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As RowCollection

Property Value

An instance of the RowCollection class.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Tag Property

Worksheet.Tag Property
[image]

Gets or sets a custom object associated with the worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object representing the custom data associated with this worksheet.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.Visible Property

Worksheet.Visible Property
[image]

Gets or sets a value indicating whether this worksheet is visible.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the worksheet is visible; otherwise, false. The default is true.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet Events

Worksheet Events
[image]

Public Events

Name | Description
CellChanged | Raised when a cell of the worksheet is changed.
CellChanging | Raised when a cell of the worksheet is about to change.
CellsCleared | Raised when a range of cells has been cleared.
ColumnChanged | Raised when a column is changed.
PropertyChanged | Raised when a property of the worksheet is changed.
PropertyValueChanged | Raised when a property of the worksheet is changed.
RowChanged | Raised when a row is changed.
ValidationFailed | Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

See Also

Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CellChanged Event

Worksheet.CellChanged Event
[image]

Raised when a cell of the worksheet is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellChangedEventArgs> CellChanged

Visual Basic [image] Copy Code

Public Event CellChanged As EventHandler(Of CellChangedEventArgs)

Event Data

CellChanged event handlers receive an argument of type CellChangedEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CellChanging Event

Worksheet.CellChanging Event
[image]

Raised when a cell of the worksheet is about to change.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> CellChanging

Visual Basic [image] Copy Code

Public Event CellChanging As EventHandler(Of CellValidationEventArgs)

Event Data

CellChanging event handlers receive an argument of type CellValidationEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.CellsCleared Event

Worksheet.CellsCleared Event
[image]

Raised when a range of cells has been cleared.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CellsCleared

Visual Basic [image] Copy Code

Public Event CellsCleared As EventHandler

Event Data

CellsCleared event handlers receive an argument of type EventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.ColumnChanged Event

Worksheet.ColumnChanged Event
[image]

Raised when a column is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ColumnChangedEventArgs> ColumnChanged

Visual Basic [image] Copy Code

Public Event ColumnChanged As EventHandler(Of ColumnChangedEventArgs)

Event Data

ColumnChanged event handlers receive an argument of type ColumnChangedEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.PropertyChanged Event

Worksheet.PropertyChanged Event
[image]

Raised when a property of the worksheet is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.PropertyValueChanged Event

Worksheet.PropertyValueChanged Event
[image]

Raised when a property of the worksheet is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<PropertyEventArgs> PropertyValueChanged

Visual Basic [image] Copy Code

Public Event PropertyValueChanged As EventHandler(Of PropertyEventArgs)

Event Data

PropertyValueChanged event handlers receive an argument of type PropertyEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.RowChanged Event

Worksheet.RowChanged Event
[image]

Raised when a row is changed.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<RowChangedEventArgs> RowChanged

Visual Basic [image] Copy Code

Public Event RowChanged As EventHandler(Of RowChangedEventArgs)

Event Data

RowChanged event handlers receive an argument of type RowChangedEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Worksheet.ValidationFailed Event

Worksheet.ValidationFailed Event
[image]

Raised when the validation of entered data has failed and the validation's ErrorAction property is set to RaiseEvent.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ValidationFailedEventArgs> ValidationFailed

Visual Basic [image] Copy Code

Public Event ValidationFailed As EventHandler(Of ValidationFailedEventArgs)

Event Data

ValidationFailed event handlers receive an argument of type ValidationFailedEventArgs.

See Also

Worksheet Members
Worksheet Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs Class

WorksheetChangedEventArgs Class
[image]

Provides data for the WorksheetChanged event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorksheetChangedEventArgs : PropertyEventArgs

Visual Basic [image] Copy Code

Public Class WorksheetChangedEventArgs
Inherits PropertyEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.PropertyEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs

See Also

WorksheetChangedEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs Members

WorksheetChangedEventArgs Members
Properties
[image]

Provides data for the WorksheetChanged event.

The following tables list the members exposed by the WorksheetChangedEventArgs type.

Public Properties

Name | Description
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Worksheet | Gets the related worksheet.

See Also

WorksheetChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs Properties

WorksheetChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the current value of the property. (Inherited from PropertyEventArgs.)
OldValue | Gets the value of the property before the change. (Inherited from PropertyEventArgs.)
PropertyName | Gets the name of the property that changed. (Inherited from PropertyEventArgs.)
Worksheet | Gets the related worksheet.

See Also

WorksheetChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetChangedEventArgs.Worksheet Property

WorksheetChangedEventArgs.Worksheet Property
[image]

Gets the related worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

WorksheetChangedEventArgs Members
WorksheetChangedEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection Class

WorksheetCollection Class
[image]

Represents a specialized collection of Worksheet objects.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class WorksheetCollection : NamedCollection<Worksheet>

Visual Basic [image] Copy Code

Public NotInheritable Class WorksheetCollection
Inherits NamedCollection(Of Worksheet)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(Worksheet)
MindFusion.Spreadsheet.Wpf.NamedCollection(Worksheet)
MindFusion.Spreadsheet.Wpf.WorksheetCollection

See Also

WorksheetCollection Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection Members

WorksheetCollection Members
Properties Methods Events
[image]

Represents a specialized collection of Worksheet objects.

The following tables list the members exposed by the WorksheetCollection type.

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item at the specified index. (Inherited from UndoableCollection.)
Item | Gets the item with the specified name. If there is no item with the specified name, the indexer has no effect. (Inherited from NamedCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

Public Methods

Name | Description
Add | Overloaded. Creates and adds a new Worksheet object to the collection.
Clear | Clears all elements from the collection. If the collection is empty, the method has no effect.
Contains | Determines whether an element with the specified name is in the collection. (Inherited from NamedCollection.)
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Insert | Overloaded. Creates and adds a new Worksheet object to the collection.
Move | Moves the specified Worksheet object from its current position to the specified index. If the worksheet is not part of the collection, the method has no effect.
Remove | Overloaded. Removes a Worksheet object from the collection.
RemoveAt | Removes the Worksheet object at the specified index.

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override. (Inherited from NamedCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection Methods

WorksheetCollection Methods
[image]

Public Methods

Name | Description
Add | Overloaded. Creates and adds a new Worksheet object to the collection.
Clear | Clears all elements from the collection. If the collection is empty, the method has no effect.
Contains | Determines whether an element with the specified name is in the collection. (Inherited from NamedCollection.)
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Insert | Overloaded. Creates and adds a new Worksheet object to the collection.
Move | Moves the specified Worksheet object from its current position to the specified index. If the worksheet is not part of the collection, the method has no effect.
Remove | Overloaded. Removes a Worksheet object from the collection.
RemoveAt | Removes the Worksheet object at the specified index.

Protected Methods

Name | Description
OnCollectionChanged | UndoableCollection.OnCollectionChanged override. (Inherited from NamedCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

See Also

WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Add Method

WorksheetCollection.Add Method
[image]

Creates and adds a new Worksheet object to the collection.

Overload List

Name | Description
WorksheetCollection.Add () | Creates a new Worksheet object and adds it to the end of the collection.
WorksheetCollection.Add (String) | Creates a new Worksheet object with the specified name and adds it to the end of the collection. If a worksheet with the specified name already exists, an exception is thrown.

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Add Method ()

WorksheetCollection.Add Method ()
See Also
[image]

Creates a new Worksheet object and adds it to the end of the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Add ()

Visual Basic [image] Copy Code

Public Function Add () As Worksheet

Return Value

The newly created Worksheet object.

See Also

Add Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Add Method (String)

WorksheetCollection.Add Method (String)
See Also
[image]

Creates a new Worksheet object with the specified name and adds it to the end of the collection. If a worksheet with the specified name already exists, an exception is thrown.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Add (
string name
)

Visual Basic [image] Copy Code

Public Function Add( _
name As String _
) As Worksheet

Parameters

name

The name of the new worksheet object.

Return Value

The newly created Worksheet object.

See Also

Add Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Clear Method

WorksheetCollection.Clear Method
[image]

Clears all elements from the collection. If the collection is empty, the method has no effect.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Insert Method

WorksheetCollection.Insert Method
[image]

Creates and adds a new Worksheet object to the collection.

Overload List

Name | Description
WorksheetCollection.Insert (Int32) | Creates a new Worksheet object and adds it at the specified index within the collection.
WorksheetCollection.Insert (Int32, String) | Creates a new Worksheet object with the specified name and adds it at the specified index within the collection. If a worksheet with the specified name already exists, an exception is thrown.

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Insert Method (Int32)

WorksheetCollection.Insert Method (Int32)
See Also
[image]

Creates a new Worksheet object and adds it at the specified index within the collection.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Insert (
int index
)

Visual Basic [image] Copy Code

Public Function Insert( _
index As Integer _
) As Worksheet

Parameters

index

The zero-based index where the new worksheet should be added.

Return Value

The newly created Worksheet object.

See Also

Insert Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Insert Method (Int32, String)

WorksheetCollection.Insert Method (Int32, String)
See Also
[image]

Creates a new Worksheet object with the specified name and adds it at the specified index within the collection. If a worksheet with the specified name already exists, an exception is thrown.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Insert (
int index,
string name
)

Visual Basic [image] Copy Code

Public Function Insert( _
index As Integer, _
name As String _
) As Worksheet

Parameters

index

The zero-based index where the new worksheet should be added.

name

The name of the new worksheet.

Return Value

The newly created Worksheet object.

See Also

Insert Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Move Method

WorksheetCollection.Move Method
[image]

Moves the specified Worksheet object from its current position to the specified index. If the worksheet is not part of the collection, the method has no effect.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Move (
Worksheet worksheet,
int index
)

Visual Basic [image] Copy Code

Public Sub Move( _
worksheet As Worksheet, _
index As Integer _
)

Parameters

worksheet

The worksheet to move.

index

The zero-based index of the position to move to.

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Remove Method

WorksheetCollection.Remove Method
[image]

Removes a Worksheet object from the collection.

Overload List

Name | Description
WorksheetCollection.Remove (String) | Removes the Worksheet object with the specified name from the collection. If there is no worksheet with the specified name, the method has no effect.
WorksheetCollection.Remove (Worksheet) | Removes the specified Worksheet object from the collection. If the worksheet is not part of the collection, the method has no effect.

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Remove Method (String)

WorksheetCollection.Remove Method (String)
See Also
[image]

Removes the Worksheet object with the specified name from the collection. If there is no worksheet with the specified name, the method has no effect.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
string name
)

Visual Basic [image] Copy Code

Public Sub Remove( _
name As String _
)

Parameters

name

The name of the worksheet to remove.

See Also

Remove Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.Remove Method (Worksheet)

WorksheetCollection.Remove Method (Worksheet)
See Also
[image]

Removes the specified Worksheet object from the collection. If the worksheet is not part of the collection, the method has no effect.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Sub Remove( _
worksheet As Worksheet _
)

Parameters

worksheet

The worksheet to remove.

See Also

Remove Method Overload List
WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection.RemoveAt Method

WorksheetCollection.RemoveAt Method
[image]

Removes the Worksheet object at the specified index.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the worksheet to remove.

See Also

WorksheetCollection Members
WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetCollection Events

WorksheetCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

WorksheetCollection Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetEventArgs Class

WorksheetEventArgs Class
[image]

Contains the arguments passed to Worksheet-related events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorksheetEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class WorksheetEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.WorksheetEventArgs
MindFusion.Spreadsheet.Wpf.SerializeTagEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs

See Also

WorksheetEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetEventArgs Members

WorksheetEventArgs Members
Properties
[image]

Contains the arguments passed to Worksheet-related events.

The following tables list the members exposed by the WorksheetEventArgs type.

Public Properties

Name | Description
Worksheet | Gets the related worksheet.

See Also

WorksheetEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetEventArgs Properties

WorksheetEventArgs Properties
[image]

Public Properties

Name | Description
Worksheet | Gets the related worksheet.

See Also

WorksheetEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetEventArgs.Worksheet Property

WorksheetEventArgs.Worksheet Property
[image]

Gets the related worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet Worksheet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Worksheet As Worksheet

Property Value

An instance of the Worksheet class.

See Also

WorksheetEventArgs Members
WorksheetEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs Class

WorksheetMouseEventArgs Class
[image]

Contains the arguments passed to Worksheet-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorksheetMouseEventArgs : WorksheetEventArgs

Visual Basic [image] Copy Code

Public Class WorksheetMouseEventArgs
Inherits WorksheetEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.WorksheetEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs

See Also

WorksheetMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs Members

WorksheetMouseEventArgs Members
Properties
[image]

Contains the arguments passed to Worksheet-related mouse events.

The following tables list the members exposed by the WorksheetMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button.
Clicks | Gets the number of mouse clicks.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)
X | Gets the relative x-coordinates of the mouse.
Y | Gets the relative y-coordinates of the mouse.

See Also

WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs Properties

WorksheetMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button.
Clicks | Gets the number of mouse clicks.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)
X | Gets the relative x-coordinates of the mouse.
Y | Gets the relative y-coordinates of the mouse.

See Also

WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs.Button Property

WorksheetMouseEventArgs.Button Property
[image]

Gets the clicked mouse button.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public MouseButton Button { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Button As MouseButton

Property Value

A member of the MouseButton enumeration.

See Also

WorksheetMouseEventArgs Members
WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs.Clicks Property

WorksheetMouseEventArgs.Clicks Property
[image]

Gets the number of mouse clicks.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Clicks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Clicks As Integer

Property Value

An integer value.

See Also

WorksheetMouseEventArgs Members
WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs.X Property

WorksheetMouseEventArgs.X Property
[image]

Gets the relative x-coordinates of the mouse.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double X { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property X As Double

Property Value

A double value.

Remarks

The origin of this coordinate depends on the specific event.

See Also

WorksheetMouseEventArgs Members
WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs.Y Property

WorksheetMouseEventArgs.Y Property
[image]

Gets the relative y-coordinates of the mouse.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double Y { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Y As Double

Property Value

A double value.

Remarks

The origin of this coordinate depends on the specific event.

See Also

WorksheetMouseEventArgs Members
WorksheetMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs Class

WorksheetTabMouseEventArgs Class
[image]

Contains the arguments passed to Worksheet-related mouse events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorksheetTabMouseEventArgs : WorksheetMouseEventArgs

Visual Basic [image] Copy Code

Public Class WorksheetTabMouseEventArgs
Inherits WorksheetMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.WorksheetEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetMouseEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs

See Also

WorksheetTabMouseEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs Members

WorksheetTabMouseEventArgs Members
Properties
[image]

Contains the arguments passed to Worksheet-related mouse events.

The following tables list the members exposed by the WorksheetTabMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from WorksheetMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from WorksheetMouseEventArgs.)
Tab | Gets the tab related to the event.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)
X | Gets the relative x-coordinates of the mouse. (Inherited from WorksheetMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from WorksheetMouseEventArgs.)

See Also

WorksheetTabMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs Properties

WorksheetTabMouseEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets the clicked mouse button. (Inherited from WorksheetMouseEventArgs.)
Clicks | Gets the number of mouse clicks. (Inherited from WorksheetMouseEventArgs.)
Tab | Gets the tab related to the event.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)
X | Gets the relative x-coordinates of the mouse. (Inherited from WorksheetMouseEventArgs.)
Y | Gets the relative y-coordinates of the mouse. (Inherited from WorksheetMouseEventArgs.)

See Also

WorksheetTabMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetTabMouseEventArgs.Tab Property

WorksheetTabMouseEventArgs.Tab Property
[image]

Gets the tab related to the event.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public WorksheetTab Tab { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Tab As WorksheetTab

Property Value

An instance of the WorksheetTab class.

See Also

WorksheetTabMouseEventArgs Members
WorksheetTabMouseEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs Class

WorksheetValidationEventArgs Class
[image]

Contains the arguments passed to Worksheet-related validation events.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class WorksheetValidationEventArgs : WorksheetEventArgs

Visual Basic [image] Copy Code

Public Class WorksheetValidationEventArgs
Inherits WorksheetEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Spreadsheet.Wpf.WorksheetEventArgs
MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs

See Also

WorksheetValidationEventArgs Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs Members

WorksheetValidationEventArgs Members
Properties
[image]

Contains the arguments passed to Worksheet-related validation events.

The following tables list the members exposed by the WorksheetValidationEventArgs type.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)

See Also

WorksheetValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs Properties

WorksheetValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Worksheet | Gets the related worksheet. (Inherited from WorksheetEventArgs.)

See Also

WorksheetValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.WorksheetValidationEventArgs.Cancel Property

WorksheetValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; otherwise, false.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

WorksheetValidationEventArgs Members
WorksheetValidationEventArgs Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Class

XmlContext Class
[image]

Contains methods that help serializing and deserializing complex objects to and from XML documents.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class XmlContext

Visual Basic [image] Copy Code

Public Class XmlContext

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.XmlContext

See Also

XmlContext Members
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Members

XmlContext Members
Constructors Fields Properties Methods
[image]

Contains methods that help serializing and deserializing complex objects to and from XML documents.

The following tables list the members exposed by the XmlContext type.

Public Constructors

Name | Description
XmlContext | Initializes a new instance of the XmlContext class.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
Version | Gets the format revision number for the file being currently serialized.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to a specified parent node.
LoadWorksheet | Reads a worksheet from the specified XML element.
ReadBool | Overloaded. Reads a boolean value.
ReadBrush | Overloaded. Reads a Brush object.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a Color value from the element with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadColumnTag | Reads the tag for the specified column.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enumeration object from the element with the specified name.
ReadFloat | Overloaded. Reads a float value.
ReadFloatArray | Reads a float array with the specified name.
ReadImage | Reads an ImageSource object with the specified name.
ReadInt | Overloaded. Reads an integer value.
ReadLong | Reads a long value with the specified name.
ReadMeasure | Reads a Measure value from the element with the specified name.
ReadObject | Reads an object with the specified name.
ReadPoint | Overloaded. Reads a Point object.
ReadRowTag | Reads the tag for the specified row.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Overloaded. Reads a short value.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded. Reads a string value.
ReadTag | Reads the tag for the specified worksheet.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SaveWorksheet | Saves the specified worksheet to the specified XML element.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified Color object as an XML element with the specified name and the specified parent.
WriteColorArray | Writes the specified array.
WriteColumnTag | Writes the specified tag of the specified column.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteEnum | Writes the specified enumeration as an XML element with the specified name and the specified parent.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFloatAttribute | Writes a float value with the specified name.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMeasure | Writes the specified Measure object as an XML element with the specified name and the specified parent.
WriteObject | Writes the specified object under the specified name.
WritePoint | Overloaded. Writes a Point object.
WriteRowTag | Writes the specified tag of the specified row.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteTag | Writes the specified tag of the specified worksheet.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Fields

XmlContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.LatestFormat Field

XmlContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Constructor

XmlContext Constructor
[image]

Initializes a new instance of the XmlContext class.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XmlContext (
Workbook workbook,
int version
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
version As Integer _
)

Parameters

workbook

The Workbook that will be serialized or deserialized.

version

The file version.

See Also

XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Methods

XmlContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to a specified parent node.
LoadWorksheet | Reads a worksheet from the specified XML element.
ReadBool | Overloaded. Reads a boolean value.
ReadBrush | Overloaded. Reads a Brush object.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a Color value from the element with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadColumnTag | Reads the tag for the specified column.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enumeration object from the element with the specified name.
ReadFloat | Overloaded. Reads a float value.
ReadFloatArray | Reads a float array with the specified name.
ReadImage | Reads an ImageSource object with the specified name.
ReadInt | Overloaded. Reads an integer value.
ReadLong | Reads a long value with the specified name.
ReadMeasure | Reads a Measure value from the element with the specified name.
ReadObject | Reads an object with the specified name.
ReadPoint | Overloaded. Reads a Point object.
ReadRowTag | Reads the tag for the specified row.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Overloaded. Reads a short value.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded. Reads a string value.
ReadTag | Reads the tag for the specified worksheet.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SaveWorksheet | Saves the specified worksheet to the specified XML element.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified Color object as an XML element with the specified name and the specified parent.
WriteColorArray | Writes the specified array.
WriteColumnTag | Writes the specified tag of the specified column.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteEnum | Writes the specified enumeration as an XML element with the specified name and the specified parent.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFloatAttribute | Writes a float value with the specified name.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteMeasure | Writes the specified Measure object as an XML element with the specified name and the specified parent.
WriteObject | Writes the specified object under the specified name.
WritePoint | Overloaded. Writes a Point object.
WriteRowTag | Writes the specified tag of the specified row.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteTag | Writes the specified tag of the specified worksheet.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.AddChildElement Method

XmlContext.AddChildElement Method
[image]

Adds a new child node to a specified parent node.

Overload List

Name | Description
XmlContext.AddChildElement (XName, XContainer) | Adds a new child node with the specified name to the specified parent node.
XmlContext.AddChildElement (XName, XContainer, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.AddChildElement Method (XName, XContainer)

XmlContext.AddChildElement Method (XName, XContainer)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement AddChildElement (
XName elementName,
XContainer parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As XName, _
parentElement As XContainer _
) As XElement

Parameters

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

AddChildElement Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.AddChildElement Method (XName, XContainer, String)

XmlContext.AddChildElement Method (XName, XContainer, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement AddChildElement (
XName elementName,
XContainer parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As XName, _
parentElement As XContainer, _
innerText As String _
) As XElement

Parameters

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

innerText

The value of the new element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

AddChildElement Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.LoadWorksheet Method

XmlContext.LoadWorksheet Method
[image]

Reads a worksheet from the specified XML element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Worksheet LoadWorksheet (
XElement worksheetElement
)

Visual Basic [image] Copy Code

Public Function LoadWorksheet( _
worksheetElement As XElement _
) As Worksheet

Parameters

worksheetElement

The XElement to load from.

Return Value

An instance of the Worksheet class representing the loaded worksheet.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBool Method

XmlContext.ReadBool Method
[image]

Reads a boolean value.

Overload List

Name | Description
XmlContext.ReadBool (XName, XElement) | Reads a boolean value with the specified name.
XmlContext.ReadBool (XName, XElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBool Method (XName, XElement)

XmlContext.ReadBool Method (XName, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As XName, _
parentElement As XElement _
) As Boolean

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A boolean value.

See Also

ReadBool Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBool Method (XName, XElement, Boolean)

XmlContext.ReadBool Method (XName, XElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ReadBool (
XName elementName,
XElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As XName, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists or its value is not convertible to boolean.

Return Value

A boolean value.

See Also

ReadBool Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBrush Method

XmlContext.ReadBrush Method
[image]

Reads a Brush object.

Overload List

Name | Description
XmlContext.ReadBrush (XName, XElement) | Reads a Brush object with the specified name.
XmlContext.ReadBrush (XName, XElement, Brush) | Reads a Brush object with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBrush Method (XName, XElement)

XmlContext.ReadBrush Method (XName, XElement)
See Also
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush ReadBrush (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As XName, _
parentElement As XElement _
) As Brush

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the WPF Brush class representing the read brush, or null (Nothing in Visual Basic) if reading has failed.

See Also

ReadBrush Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadBrush Method (XName, XElement, Brush)

XmlContext.ReadBrush Method (XName, XElement, Brush)
See Also
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush ReadBrush (
XName elementName,
XElement parentElement,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As XName, _
parentElement As XElement, _
defaultValue As Brush _
) As Brush

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists or its value is not convertible to Brush.

Return Value

An instance of the WPF Brush class representing the read brush, or null (Nothing in Visual Basic) if reading has failed.

See Also

ReadBrush Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadByte Method

XmlContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public byte ReadByte (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As XName, _
parentElement As XElement _
) As Byte

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A byte value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadChar Method

XmlContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public char ReadChar (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As XName, _
parentElement As XElement _
) As Char

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A character value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadColor Method

XmlContext.ReadColor Method
[image]

Reads a Color value from the element with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Color ReadColor (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As XName, _
parentElement As XElement _
) As Color

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the WPF Color structure representing the read color, or Black if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadColorArray Method

XmlContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
XName elementName,
XName subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As XName, _
subElementName As XName, _
parentElement As XElement _
) As Color()

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

subElementName

An instance of the .NET XName class that specifies the elements containing the individual array values.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An array of the WPF Color objects, or null (Nothing in Visual Basic) if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadColumnTag Method

XmlContext.ReadColumnTag Method
[image]

Reads the tag for the specified column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object ReadColumnTag (
Column column,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColumnTag( _
column As Column, _
elementName As XName, _
parentElement As XElement _
) As Object

Parameters

column

The target column.

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

The read tag.

Remarks

Tags are read similarly to arbitrary objects except that the client is given a chance to perform custom deserialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadDecimal Method

XmlContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As XName, _
parentElement As XElement _
) As Decimal

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A decimal value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadDouble Method

XmlContext.ReadDouble Method
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double ReadDouble (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As XName, _
parentElement As XElement _
) As Double

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A double value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadEnum Method

XmlContext.ReadEnum Method
[image]

Reads an enumeration object from the element with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object ReadEnum (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As XName, _
parentElement As XElement _
) As Object

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

The enumeration object read, or 0 if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadFloat Method

XmlContext.ReadFloat Method
[image]

Reads a float value.

Overload List

Name | Description
XmlContext.ReadFloat (XName, XElement) | Reads a float value with the specified name.
XmlContext.ReadFloat (XName, XElement, Single) | Reads a float value with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadFloat Method (XName, XElement)

XmlContext.ReadFloat Method (XName, XElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public float ReadFloat (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As XName, _
parentElement As XElement _
) As Single

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A float value.

See Also

ReadFloat Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadFloat Method (XName, XElement, Single)

XmlContext.ReadFloat Method (XName, XElement, Single)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public float ReadFloat (
XName elementName,
XElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As XName, _
parentElement As XElement, _
defaultValue As Single _
) As Single

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists or its value is not convertible to float.

Return Value

A float value.

See Also

ReadFloat Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadFloatArray Method

XmlContext.ReadFloatArray Method
[image]

Reads a float array with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double[] ReadFloatArray (
XName elementName,
XName subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As XName, _
subElementName As XName, _
parentElement As XElement _
) As Double()

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

subElementName

An instance of the .NET XName class that specifies the elements containing the individual array values.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An array of float values, or null (Nothing in Visual Basic) if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadImage Method

XmlContext.ReadImage Method
[image]

Reads an ImageSource object with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ImageSource ReadImage (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As XName, _
parentElement As XElement _
) As ImageSource

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the WPF ImageSource class representing the read image, or null (Nothing in Visual Basic) if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadInt Method

XmlContext.ReadInt Method
[image]

Reads an integer value.

Overload List

Name | Description
XmlContext.ReadInt (XName, XElement) | Reads an integer value with the specified name.
XmlContext.ReadInt (XName, XElement, Int32) | Reads an integer value with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadInt Method (XName, XElement)

XmlContext.ReadInt Method (XName, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As XName, _
parentElement As XElement _
) As Integer

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An integer value.

See Also

ReadInt Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadInt Method (XName, XElement, Int32)

XmlContext.ReadInt Method (XName, XElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int ReadInt (
XName elementName,
XElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As XName, _
parentElement As XElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists or its value is not convertible to integer.

Return Value

An integer value.

See Also

ReadInt Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadLong Method

XmlContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public long ReadLong (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As XName, _
parentElement As XElement _
) As Long

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A long value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadMeasure Method

XmlContext.ReadMeasure Method
[image]

Reads a Measure value from the element with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure ReadMeasure (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadMeasure( _
elementName As XName, _
parentElement As XElement _
) As Measure

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the Measure class representing the read measure, or a zero-length measure if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadObject Method

XmlContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object ReadObject (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As XName, _
parentElement As XElement _
) As Object

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

The read object, or null (Nothing in Visual Basic) if reading has failed.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadPoint Method

XmlContext.ReadPoint Method
[image]

Reads a Point object.

Overload List

Name | Description
XmlContext.ReadPoint (XElement) | Reads a Point object from the specified element.
XmlContext.ReadPoint (XName, XElement) | Reads a Point object with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadPoint Method (XElement)

XmlContext.ReadPoint Method (XElement)
See Also
[image]

Reads a Point object from the specified element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Point ReadPoint (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
element As XElement _
) As Point

Parameters

element

The element to load from.

Return Value

An instance of the WPF Point structure representing the read point, or an empty point if reading has failed.

See Also

ReadPoint Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadPoint Method (XName, XElement)

XmlContext.ReadPoint Method (XName, XElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Point ReadPoint (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
elementName As XName, _
parentElement As XElement _
) As Point

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the WPF Point structure representing the read point, or an empty point if reading has failed.

See Also

ReadPoint Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadRowTag Method

XmlContext.ReadRowTag Method
[image]

Reads the tag for the specified row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object ReadRowTag (
Row row,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRowTag( _
row As Row, _
elementName As XName, _
parentElement As XElement _
) As Object

Parameters

row

The target row.

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

The read tag.

Remarks

Tags are read similarly to arbitrary objects except that the client is given a chance to perform custom deserialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadSByte Method

XmlContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As XName, _
parentElement As XElement _
) As SByte

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A signed byte value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadShort Method

XmlContext.ReadShort Method
[image]

Reads a short value.

Overload List

Name | Description
XmlContext.ReadShort (XName, XElement) | Reads a short value with the specified name.
XmlContext.ReadShort (XName, XElement, Int16) | Reads a short value with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadShort Method (XName, XElement)

XmlContext.ReadShort Method (XName, XElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public short ReadShort (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As XName, _
parentElement As XElement _
) As Short

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A short value.

See Also

ReadShort Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadShort Method (XName, XElement, Int16)

XmlContext.ReadShort Method (XName, XElement, Int16)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public short ReadShort (
XName elementName,
XElement parentElement,
short defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As XName, _
parentElement As XElement, _
defaultValue As Short _
) As Short

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists or its value is not convertible to short.

Return Value

A short value.

See Also

ReadShort Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadStream Method

XmlContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Stream ReadStream (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As XName, _
parentElement As XElement _
) As Stream

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET Stream class representing the read stream.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadString Method

XmlContext.ReadString Method
[image]

Reads a string value.

Overload List

Name | Description
XmlContext.ReadString (XName, XElement) | Reads a string value with the specified name.
XmlContext.ReadString (XName, XElement, String) | Reads a string value with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadString Method (XName, XElement)

XmlContext.ReadString Method (XName, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As XName, _
parentElement As XElement _
) As String

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

A string value.

See Also

ReadString Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadString Method (XName, XElement, String)

XmlContext.ReadString Method (XName, XElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string ReadString (
XName elementName,
XElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As XName, _
parentElement As XElement, _
defaultValue As String _
) As String

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

defaultValue

The default value if no element with the specified name exists.

Return Value

A string value.

See Also

ReadString Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadTag Method

XmlContext.ReadTag Method
[image]

Reads the tag for the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object ReadTag (
Worksheet worksheet,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
worksheet As Worksheet, _
elementName As XName, _
parentElement As XElement _
) As Object

Parameters

worksheet

The target worksheet.

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

The read tag.

Remarks

Tags are read similarly to arbitrary objects except that the client is given a chance to perform custom deserialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadUInt Method

XmlContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public uint ReadUInt (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As XName, _
parentElement As XElement _
) As UInteger

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An unsigned integer value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadULong Method

XmlContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ulong ReadULong (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As XName, _
parentElement As XElement _
) As ULong

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An unsigned long value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.ReadUShort Method

XmlContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ushort ReadUShort (
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As XName, _
parentElement As XElement _
) As UShort

Parameters

elementName

An instance of the .NET XName class that specifies the element to read.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An unsigned short value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.SaveWorksheet Method

XmlContext.SaveWorksheet Method
[image]

Saves the specified worksheet to the specified XML element.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void SaveWorksheet (
Worksheet worksheet,
XElement worksheetElement
)

Visual Basic [image] Copy Code

Public Sub SaveWorksheet( _
worksheet As Worksheet, _
worksheetElement As XElement _
)

Parameters

worksheet

The worksheet to save.

worksheetElement

An instance of the .NET XElement class that specifies the element under which to save the worksheet.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteBool Method

XmlContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool boolValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

boolValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteBrush Method

XmlContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteBrush (
Brush brush,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

brush

The Brush object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteByte Method

XmlContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte byteValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteChar Method

XmlContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteChar (
char charValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

charValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteColor Method

XmlContext.WriteColor Method
[image]

Writes the specified Color object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

color

The Color object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteColorArray Method

XmlContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteColorArray (
Color[] array,
XName elementName,
XName subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As XName, _
subElementName As XName, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

subElementName

An instance of the .NET XName class that specifies the names of the elements containing the individual array values.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteColumnTag Method

XmlContext.WriteColumnTag Method
[image]

Writes the specified tag of the specified column.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteColumnTag (
Column column,
Object tag,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColumnTag( _
column As Column, _
tag As Object, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

column

The source column.

tag

The object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

Remarks

Tags are written similarly to arbitrary objects except that the client is given a chance to perform custom serialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteDecimal Method

XmlContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
decimal decimalValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

decimalValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteDouble Method

XmlContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double doubleValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteDoubleArray Method

XmlContext.WriteDoubleArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteDoubleArray (
double[] array,
XName elementName,
XName subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleArray( _
array() As Double, _
elementName As XName, _
subElementName As XName, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

subElementName

An instance of the .NET XName class that specifies the names of the elements containing the individual array values.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteEnum Method

XmlContext.WriteEnum Method
[image]

Writes the specified enumeration as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object value,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
value As Object, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

value

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteFloat Method

XmlContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteFloat (
float floatValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Single, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

floatValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteFloatArray Method

XmlContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteFloatArray (
double[] array,
XName elementName,
XName subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Double, _
elementName As XName, _
subElementName As XName, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

subElementName

An instance of the .NET XName class that specifies the names of the elements containing the individual array values.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteFloatAttribute Method

XmlContext.WriteFloatAttribute Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void WriteFloatAttribute (
float value,
XName name,
XElement element
)

Visual Basic [image] Copy Code

Public Sub WriteFloatAttribute( _
value As Single, _
name As XName, _
element As XElement _
)

Parameters

value

The value to write.

name

An instance of the .NET XName class that specifies the name of the new attribute.

element

An instance of the .NET XElement class that specifies the element to add the new attribute to.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteImage Method

XmlContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteImage (
ImageSource image,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As ImageSource, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

image

The WPF ImageSource object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteInt Method

XmlContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteInt (
int intValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

intValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteLong Method

XmlContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteLong (
long longValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

longValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteMeasure Method

XmlContext.WriteMeasure Method
[image]

Writes the specified Measure object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteMeasure (
Measure measure,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteMeasure( _
measure As Measure, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

measure

The Measure object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteObject Method

XmlContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteObject (
Object objectValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

objectValue

The object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WritePoint Method

XmlContext.WritePoint Method
[image]

Writes a Point object.

Overload List

Name | Description
XmlContext.WritePoint (Double, Double, XName, XElement) | Writes the specified Point under the specified name. The x and y components of the point are written as attributes.
XmlContext.WritePoint (Point, XName, XElement) | Writes a Point with the specified name.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WritePoint Method (Double, Double, XName, XElement)

XmlContext.WritePoint Method (Double, Double, XName, XElement)
See Also
[image]

Writes the specified Point under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WritePoint (
double x,
double y,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
x As Double, _
y As Double, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

x

The x-coordinate of the point to write.

y

The y-coordinate of the point to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

WritePoint Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WritePoint Method (Point, XName, XElement)

XmlContext.WritePoint Method (Point, XName, XElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WritePoint (
Point point,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
point As Point, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

point

The Point object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

WritePoint Method Overload List
XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteRowTag Method

XmlContext.WriteRowTag Method
[image]

Writes the specified tag of the specified row.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteRowTag (
Row row,
Object tag,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRowTag( _
row As Row, _
tag As Object, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

row

The source row.

tag

The object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

Remarks

Tags are written similarly to arbitrary objects except that the client is given a chance to perform custom serialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteSByte Method

XmlContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte byteValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteShort Method

XmlContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteShort (
short shortValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

shortValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteStream Method

XmlContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteStream (
Stream stream,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

stream

The .NET Stream object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteString Method

XmlContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteString (
string value,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
value As String, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

value

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteTag Method

XmlContext.WriteTag Method
[image]

Writes the specified tag of the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteTag (
Worksheet worksheet,
Object tag,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
worksheet As Worksheet, _
tag As Object, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

worksheet

The source worksheet.

tag

The object to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

Remarks

Tags are written similarly to arbitrary objects except that the client is given a chance to perform custom serialization through event handling.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteUInt Method

XmlContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint uintValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

uintValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteULong Method

XmlContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong ulongValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

ulongValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.WriteUShort Method

XmlContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort ushortValue,
XName elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As XName, _
parentElement As XElement _
) As XElement

Parameters

ushortValue

The value to write.

elementName

An instance of the .NET XName class that specifies the name of the new element.

parentElement

An instance of the .NET XElement class that specifies the parent element.

Return Value

An instance of the .NET XElement class representing the newly created element.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext Properties

XmlContext Properties
[image]

Public Properties

Name | Description
Version | Gets the format revision number for the file being currently serialized.

See Also

XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.XmlContext.Version Property

XmlContext.Version Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Spreadsheet.Wpf
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public int Version { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Version As Integer

Property Value

An integer value.

See Also

XmlContext Members
XmlContext Class
MindFusion.Spreadsheet.Wpf Namespace


MindFusion.Spreadsheet.Wpf.Charts Namespace

MindFusion.Spreadsheet.Wpf.Charts Namespace
Classes Enumerations

Classes

Class | Description
AxisSettings | Contains the settings for the axes of a Chart object.
Chart | Represents a chart in a drawing within a worksheet.
ChartPresenter | Defines the presentation of charts in the WorkbookView.
Series | Represents a data series in a Chart object.
SeriesCollection | Represents a specialized collection for the series of a Chart object.

Enumerations

Enumeration | Description
ChartType | Specified the type of a Chart object.
LegendPosition | Specifies the position of the legend in a Chart object.
MarkShape | Specifies the shape of a mark in a chart.
PlotBy | Specifies how chart series are created from a data source.


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings Class

AxisSettings Class
[image]

Contains the settings for the axes of a Chart object.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public sealed class AxisSettings

Visual Basic [image] Copy Code

Public NotInheritable Class AxisSettings

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Charts.AxisSettings

See Also

AxisSettings Members
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings Members

AxisSettings Members
Properties
[image]

Contains the settings for the axes of a Chart object.

The following tables list the members exposed by the AxisSettings type.

Public Properties

Name | Description
MajorUnit | Gets or sets the major unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the major unit based on the chart data.
Maximum | Gets or sets the maximum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the maximum value based on the chart data.
Minimum | Gets or sets the minimum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the minimum value based on the chart data.
MinorUnit | Gets or sets the minor unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the minor unit based on the chart data.
ShowMajorGridLines | Gets or sets a value indicating whether to display the major gird lines for this axis.
ShowMajorTicks | Gets or sets a value indicating whether to display the major ticks along the axis.
ShowMinorTicks | Gets or sets a value indicating whether to display the minor ticks along the axis.
Title | Gets or sets the axis title.
TitleFontBold | Gets or sets a value indicating whether the axis title is bold, or null (Nothing in Visual Basic), to use the FontBold property of the chart.
TitleFontItalic | Gets or sets a value indicating whether the axis title is italic, or null (Nothing in Visual Basic), to use the FontItalic property of the chart.
TitleFontName | Gets or sets the font name of the axis title, or null (Nothing in Visual Basic), to use the FontName property of the chart.
TitleFontSize | Gets or sets the font size of the axis title, or null (Nothing in Visual Basic), to use the FontSize property of the chart.
TitleFontStrikeout | Gets or sets a value indicating whether the axis title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property of the chart.
TitleFontUnderline | Gets or sets a value indicating whether the axis title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property of the chart.
TitleTextBrush | Gets or sets the color of the axis title, or null (Nothing in Visual Basic), to use the TextBrush property of the chart.

See Also

AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings Properties

AxisSettings Properties
[image]

Public Properties

Name | Description
MajorUnit | Gets or sets the major unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the major unit based on the chart data.
Maximum | Gets or sets the maximum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the maximum value based on the chart data.
Minimum | Gets or sets the minimum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the minimum value based on the chart data.
MinorUnit | Gets or sets the minor unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the minor unit based on the chart data.
ShowMajorGridLines | Gets or sets a value indicating whether to display the major gird lines for this axis.
ShowMajorTicks | Gets or sets a value indicating whether to display the major ticks along the axis.
ShowMinorTicks | Gets or sets a value indicating whether to display the minor ticks along the axis.
Title | Gets or sets the axis title.
TitleFontBold | Gets or sets a value indicating whether the axis title is bold, or null (Nothing in Visual Basic), to use the FontBold property of the chart.
TitleFontItalic | Gets or sets a value indicating whether the axis title is italic, or null (Nothing in Visual Basic), to use the FontItalic property of the chart.
TitleFontName | Gets or sets the font name of the axis title, or null (Nothing in Visual Basic), to use the FontName property of the chart.
TitleFontSize | Gets or sets the font size of the axis title, or null (Nothing in Visual Basic), to use the FontSize property of the chart.
TitleFontStrikeout | Gets or sets a value indicating whether the axis title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property of the chart.
TitleFontUnderline | Gets or sets a value indicating whether the axis title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property of the chart.
TitleTextBrush | Gets or sets the color of the axis title, or null (Nothing in Visual Basic), to use the TextBrush property of the chart.

See Also

AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.MajorUnit Property

AxisSettings.MajorUnit Property
[image]

Gets or sets the major unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the major unit based on the chart data.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> MajorUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MajorUnit As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

Remarks

This property is only relevant for value axes.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.Maximum Property

AxisSettings.Maximum Property
[image]

Gets or sets the maximum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the maximum value based on the chart data.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> Maximum { get; set; }

Visual Basic [image] Copy Code

Public Property Maximum As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

Remarks

This property is only relevant for value axes.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.Minimum Property

AxisSettings.Minimum Property
[image]

Gets or sets the minimum value of the axis, or null (Nothing in Visual Basic), to automatically calculate the minimum value based on the chart data.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> Minimum { get; set; }

Visual Basic [image] Copy Code

Public Property Minimum As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

Remarks

This property is only relevant for value axes.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.MinorUnit Property

AxisSettings.MinorUnit Property
[image]

Gets or sets the minor unit of the axis, or null (Nothing in Visual Basic), to automatically calculate the minor unit based on the chart data.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> MinorUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MinorUnit As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

Remarks

This property is only relevant for value axes.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.ShowMajorGridLines Property

AxisSettings.ShowMajorGridLines Property
[image]

Gets or sets a value indicating whether to display the major gird lines for this axis.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowMajorGridLines { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMajorGridLines As Boolean

Property Value

A boolean value. The default is false.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.ShowMajorTicks Property

AxisSettings.ShowMajorTicks Property
[image]

Gets or sets a value indicating whether to display the major ticks along the axis.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowMajorTicks { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMajorTicks As Boolean

Property Value

A boolean value. The default is true.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.ShowMinorTicks Property

AxisSettings.ShowMinorTicks Property
[image]

Gets or sets a value indicating whether to display the minor ticks along the axis.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowMinorTicks { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMinorTicks As Boolean

Property Value

A boolean value. The default is false.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.Title Property

AxisSettings.Title Property
[image]

Gets or sets the axis title.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontBold Property

AxisSettings.TitleFontBold Property
[image]

Gets or sets a value indicating whether the axis title is bold, or null (Nothing in Visual Basic), to use the FontBold property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontBold { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontBold As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontItalic Property

AxisSettings.TitleFontItalic Property
[image]

Gets or sets a value indicating whether the axis title is italic, or null (Nothing in Visual Basic), to use the FontItalic property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontItalic As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontName Property

AxisSettings.TitleFontName Property
[image]

Gets or sets the font name of the axis title, or null (Nothing in Visual Basic), to use the FontName property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string TitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontName As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontSize Property

AxisSettings.TitleFontSize Property
[image]

Gets or sets the font size of the axis title, or null (Nothing in Visual Basic), to use the FontSize property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontStrikeout Property

AxisSettings.TitleFontStrikeout Property
[image]

Gets or sets a value indicating whether the axis title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStrikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleFontUnderline Property

AxisSettings.TitleFontUnderline Property
[image]

Gets or sets a value indicating whether the axis title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontUnderline { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontUnderline As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.AxisSettings.TitleTextBrush Property

AxisSettings.TitleTextBrush Property
[image]

Gets or sets the color of the axis title, or null (Nothing in Visual Basic), to use the TextBrush property of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush TitleTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleTextBrush As Brush

Property Value

An instance of the .NET Brush class or null (Nothing in Visual Basic). The default is null.

See Also

AxisSettings Members
AxisSettings Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Class

Chart Class
[image]

Represents a chart in a drawing within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Chart : InteractiveObject

Visual Basic [image] Copy Code

Public Class Chart
Inherits InteractiveObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.Spreadsheet.Wpf.InteractiveObject
MindFusion.Spreadsheet.Wpf.Charts.Chart

See Also

Chart Members
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Members

Chart Members
Fields Properties Methods Events
[image]

Represents a chart in a drawing within a worksheet.

The following tables list the members exposed by the Chart type.

Public Fields

Name | Description
TypeProperty | Identifies the Type dependency property.

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object. (Inherited from InteractiveObject.)
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
AxisBrush | Gets or sets the brush of the chart axes.
AxisSize | Gets or sets the thickness of the chart axes, or null (Nothing in Visual Basic), to use a hairline thickness.
AxisStyle | Gets or sets the style of the chart axes, or null (Nothing in Visual Basic), to draw solid lines.
DefaultColors | Gets or sets the default brushes for data series that do not have explicitly defined brushes.
DefaultLineSize | Gets or sets the default thickness in line and radar charts for series that have no explicitly specified line size.
DefaultSeriesNameFormat | Gets or sets the format of the names of the data series that do not have an explicitly defined name.
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
Fill | Gets or sets a brush used to fill the background of the chart.
FontBold | Gets or sets a value indicating whether the text in the chart is bold.
FontItalic | Gets or sets a value indicating whether the text in the chart is italic.
FontName | Gets or sets the font of the texts in the chart.
FontSize | Gets or sets the font size of the texts of the chart.
FontStrikeout | Gets or sets a value indicating whether the text in the chart is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the text in the chart is underlined.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
GridFillBrush | Gets or sets the fill brush of the grid stripes.
GridLineBrush | Gets or sets the brush of the major grid lines.
GridLineSize | Gets or sets the thickness of the major grid lines, or null (Nothing in Visual Basic), to use a hairline thickness.
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet. (Inherited from InteractiveObject.)
LegendBorderBrush | Gets or sets the border brush of the legend, or null (Nothing in Visual Basic), to hide the border.
LegendBorderSize | Gets or sets the border thickness of the legend, or null (Nothing in Visual Basic), to use a hairline thickness.
LegendFill | Gets or sets a brush used to fill the legend's background.
LegendFontBold | Gets or sets a value indicating whether the legend text is bold, or null (Nothing in Visual Basic), to use the FontBold property.
LegendFontItalic | Gets or sets a value indicating whether the legend text is italic, or null (Nothing in Visual Basic), to use the FontItalic property.
LegendFontName | Gets or sets the font name of the legend, or null (Nothing in Visual Basic), to use the FontName property.
LegendFontSize | Gets or sets the font size of the legend, or null (Nothing in Visual Basic), to use the FontSize property.
LegendFontStrikeout | Gets or sets a value indicating whether the legend text is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.
LegendFontUnderline | Gets or sets a value indicating whether the legend text is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.
LegendLanes | Gets or sets the number of columns or rows to use when layouting items inside the legend, or null (Nothing in Visual Basic), to use the default number of columns or rows, which is 1.
LegendPosition | Gets or sets the legend position.
LegendTextBrush | Gets or sets the brush of the texts in the legend, or null (Nothing in Visual Basic), to use the TextBrush property.
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
MarkShape | Gets or sets the shape of marks in the chart, or null (Nothing in Visual Basic), to use alternating shapes.
PlotBorderBrush | Gets or sets the border brush of the chart's plot area, or null (Nothing in Visual Basic), to hide the border.
PlotBorderSize | Gets or sets the border thickness of the chart's plot area, or null (Nothing in Visual Basic), to use a hairline thickness.
PlotBorderStyle | Gets or sets the border style of the chart's plot area, or null (Nothing in Visual Basic), to use a solid line.
PlotFill | Gets or sets a brush used to fill the background of the chart's plot area.
Series | Gets a collection with the data series of the chart.
ShowLegend | Gets or sets a value indicating whether to display the chart's legend.
TextBrush | Gets or sets the brush of the texts in the chart.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
TitleFontBold | Gets or sets a value indicating whether the chart title is bold, or null (Nothing in Visual Basic), to use the FontBold property.
TitleFontItalic | Gets or sets a value indicating whether the chart title is italic, or null (Nothing in Visual Basic), to use the FontItalic property.
TitleFontName | Gets or sets the font of the chart title, or null (Nothing in Visual Basic), to use the FontName property.
TitleFontSize | Gets or sets the font size of the chart title, or null (Nothing in Visual Basic), to use the FontSize property.
TitleFontStrikeout | Gets or sets a value indicating whether the chart title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.
TitleFontUnderline | Gets or sets a value indicating whether the chart title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.
TitleTextBrush | Gets or sets the brush of the chart title, or null (Nothing in Visual Basic), to use the TextBrush property.
Type | Gets or sets the type of the chart. This is a dependency property.
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)
XAxisSettings | Gets the settings for the category label axis of the chart, if the chart is an axes chart.
YAxisSettings | Gets the settings for the value axis of the chart, if the chart is an axes chart.

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle. (Inherited from InteractiveObject.)
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell. (Inherited from InteractiveObject.)

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order. (Inherited from InteractiveObject.)
BringToFront | Brings this object to the top of the z-order. (Inherited from InteractiveObject.)
SendBackward | Moves this object one step down in the z-order. (Inherited from InteractiveObject.)
SendToBack | Sends this object to the bottom of the z-order. (Inherited from InteractiveObject.)
SetDataSource | Sets the chart data source to the specified range of cells.

Protected Methods

Name | Description
Dispose | InteractiveObject.Dispose override.
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from InteractiveObject.)
OnResized | InteractiveObject.OnResized override.

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Fields

Chart Fields
[image]

Public Fields

Name | Description
TypeProperty | Identifies the Type dependency property.

See Also

Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TypeProperty Field

Chart.TypeProperty Field
[image]

Identifies the Type dependency property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty TypeProperty

Visual Basic [image] Copy Code

Public Shared TypeProperty As DependencyProperty

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Methods

Chart Methods
[image]

Public Methods

Name | Description
BringForward | Moves this object one step up in the z-order. (Inherited from InteractiveObject.)
BringToFront | Brings this object to the top of the z-order. (Inherited from InteractiveObject.)
SendBackward | Moves this object one step down in the z-order. (Inherited from InteractiveObject.)
SendToBack | Sends this object to the bottom of the z-order. (Inherited from InteractiveObject.)
SetDataSource | Sets the chart data source to the specified range of cells.

Protected Methods

Name | Description
Dispose | InteractiveObject.Dispose override.
OnPropertyValueChanged | Raises the PropertyValueChanged event. (Inherited from InteractiveObject.)
OnResized | InteractiveObject.OnResized override.

See Also

Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.Dispose Method

Chart.Dispose Method
[image]

InteractiveObject.Dispose override.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true if managed resources should be disposed; otherwise, false.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.OnResized Method

Chart.OnResized Method
[image]

InteractiveObject.OnResized override.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override void OnResized ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnResized ()

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.SetDataSource Method

Chart.SetDataSource Method
[image]

Sets the chart data source to the specified range of cells.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool SetDataSource (
string data,
PlotBy plotBy,
Nullable<Boolean> firstColumnAsLabel,
Nullable<Boolean> firstRowAsLabel
)

Visual Basic [image] Copy Code

Public Function SetDataSource( _
data As String, _
plotBy As PlotBy, _
firstColumnAsLabel As Nullable(Of Boolean), _
firstRowAsLabel As Nullable(Of Boolean) _
) As Boolean

Parameters

data

A string specifying a range of cells or an expression which evaluates to a range of cells.

plotBy

A flag specifying whether the series are created from the columns or from the rows in the specified range.

firstColumnAsLabel

A flag specifying whether to use the values in the first column of the specified range as labels, or null (Nothing in Visual Basic), to attempt to automatically determine this based on the type of the data. This parameter is ignored by some charts that do not display labels.

firstRowAsLabel

A flag specifying whether to use the values in the first row of the specified range as labels, or null (Nothing in Visual Basic), to attempt to automatically determine this based on the type of the data. This parameter is ignored by some charts that do not display labels.

Return Value

true if the data source was successfully set; false if the specified string does not identify a range of cells.

Remarks

The changes caused by this method are automatically recorded for subsequent undo, therefore it is not necessary to call this method in the scope of a TrackChangesCommand.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Properties

Chart Properties
[image]

Public Properties

Name | Description
Anchor | Gets or sets the anchor of this object. (Inherited from InteractiveObject.)
AnchorPosition | Gets or sets the anchor position of this object. (Inherited from InteractiveObject.)
AxisBrush | Gets or sets the brush of the chart axes.
AxisSize | Gets or sets the thickness of the chart axes, or null (Nothing in Visual Basic), to use a hairline thickness.
AxisStyle | Gets or sets the style of the chart axes, or null (Nothing in Visual Basic), to draw solid lines.
DefaultColors | Gets or sets the default brushes for data series that do not have explicitly defined brushes.
DefaultLineSize | Gets or sets the default thickness in line and radar charts for series that have no explicitly specified line size.
DefaultSeriesNameFormat | Gets or sets the format of the names of the data series that do not have an explicitly defined name.
Description | Gets or sets the object description. (Inherited from InteractiveObject.)
Fill | Gets or sets a brush used to fill the background of the chart.
FontBold | Gets or sets a value indicating whether the text in the chart is bold.
FontItalic | Gets or sets a value indicating whether the text in the chart is italic.
FontName | Gets or sets the font of the texts in the chart.
FontSize | Gets or sets the font size of the texts of the chart.
FontStrikeout | Gets or sets a value indicating whether the text in the chart is with a line through the middle.
FontUnderline | Gets or sets a value indicating whether the text in the chart is underlined.
FromColumn | Gets or sets the zero-based index of the column of the cell to which the object is anchored. (Inherited from InteractiveObject.)
FromRow | Gets or sets the zero-based index of the row of the cell to which the object is anchored. (Inherited from InteractiveObject.)
GridFillBrush | Gets or sets the fill brush of the grid stripes.
GridLineBrush | Gets or sets the brush of the major grid lines.
GridLineSize | Gets or sets the thickness of the major grid lines, or null (Nothing in Visual Basic), to use a hairline thickness.
Height | Gets or sets the desired height, or null, to calculate the height automatically. (Inherited from InteractiveObject.)
HorizontalOffset | Gets or sets the horizontal offset of the object from its anchor. (Inherited from InteractiveObject.)
IsLockedToCell | Gets a value indicating whether this object is always locked to a cell in the worksheet. (Inherited from InteractiveObject.)
LegendBorderBrush | Gets or sets the border brush of the legend, or null (Nothing in Visual Basic), to hide the border.
LegendBorderSize | Gets or sets the border thickness of the legend, or null (Nothing in Visual Basic), to use a hairline thickness.
LegendFill | Gets or sets a brush used to fill the legend's background.
LegendFontBold | Gets or sets a value indicating whether the legend text is bold, or null (Nothing in Visual Basic), to use the FontBold property.
LegendFontItalic | Gets or sets a value indicating whether the legend text is italic, or null (Nothing in Visual Basic), to use the FontItalic property.
LegendFontName | Gets or sets the font name of the legend, or null (Nothing in Visual Basic), to use the FontName property.
LegendFontSize | Gets or sets the font size of the legend, or null (Nothing in Visual Basic), to use the FontSize property.
LegendFontStrikeout | Gets or sets a value indicating whether the legend text is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.
LegendFontUnderline | Gets or sets a value indicating whether the legend text is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.
LegendLanes | Gets or sets the number of columns or rows to use when layouting items inside the legend, or null (Nothing in Visual Basic), to use the default number of columns or rows, which is 1.
LegendPosition | Gets or sets the legend position.
LegendTextBrush | Gets or sets the brush of the texts in the legend, or null (Nothing in Visual Basic), to use the TextBrush property.
LineBrush | Gets or sets the outline color of this object. (Inherited from InteractiveObject.)
LineSize | Gets or sets the thickness of the object's outline. (Inherited from InteractiveObject.)
LineStyle | Gets or sets the style of the object's outline. (Inherited from InteractiveObject.)
Locked | Gets or sets a value indicating whether this object can be interacted with. (Inherited from InteractiveObject.)
MarkShape | Gets or sets the shape of marks in the chart, or null (Nothing in Visual Basic), to use alternating shapes.
PlotBorderBrush | Gets or sets the border brush of the chart's plot area, or null (Nothing in Visual Basic), to hide the border.
PlotBorderSize | Gets or sets the border thickness of the chart's plot area, or null (Nothing in Visual Basic), to use a hairline thickness.
PlotBorderStyle | Gets or sets the border style of the chart's plot area, or null (Nothing in Visual Basic), to use a solid line.
PlotFill | Gets or sets a brush used to fill the background of the chart's plot area.
Series | Gets a collection with the data series of the chart.
ShowLegend | Gets or sets a value indicating whether to display the chart's legend.
TextBrush | Gets or sets the brush of the texts in the chart.
Title | Gets or sets the object title. (Inherited from InteractiveObject.)
TitleFontBold | Gets or sets a value indicating whether the chart title is bold, or null (Nothing in Visual Basic), to use the FontBold property.
TitleFontItalic | Gets or sets a value indicating whether the chart title is italic, or null (Nothing in Visual Basic), to use the FontItalic property.
TitleFontName | Gets or sets the font of the chart title, or null (Nothing in Visual Basic), to use the FontName property.
TitleFontSize | Gets or sets the font size of the chart title, or null (Nothing in Visual Basic), to use the FontSize property.
TitleFontStrikeout | Gets or sets a value indicating whether the chart title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.
TitleFontUnderline | Gets or sets a value indicating whether the chart title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.
TitleTextBrush | Gets or sets the brush of the chart title, or null (Nothing in Visual Basic), to use the TextBrush property.
Type | Gets or sets the type of the chart. This is a dependency property.
VerticalOffset | Gets or sets the vertical offset of the object from its origin. (Inherited from InteractiveObject.)
Width | Gets or sets the desired width, or null, to calculate width automatically. (Inherited from InteractiveObject.)
XAxisSettings | Gets the settings for the category label axis of the chart, if the chart is an axes chart.
YAxisSettings | Gets the settings for the value axis of the chart, if the chart is an axes chart.

Protected Properties

Name | Description
ExtendsOutsideBounds | Gets a value indicating whether this object's visual can extend beyond the object's bounding rectangle. (Inherited from InteractiveObject.)
RegardsMergedCells | Gets a value indicating whether this object is positioned relatively to the bounding rectangle of the merged cell if the object's cell is a part of a merged cell. (Inherited from InteractiveObject.)

See Also

Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.AxisBrush Property

Chart.AxisBrush Property
[image]

Gets or sets the brush of the chart axes.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush AxisBrush { get; set; }

Visual Basic [image] Copy Code

Public Property AxisBrush As Brush

Property Value

An instance of the WPF Brush class. The default is Black.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.AxisSize Property

Chart.AxisSize Property
[image]

Gets or sets the thickness of the chart axes, or null (Nothing in Visual Basic), to use a hairline thickness.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure AxisSize { get; set; }

Visual Basic [image] Copy Code

Public Property AxisSize As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.AxisStyle Property

Chart.AxisStyle Property
[image]

Gets or sets the style of the chart axes, or null (Nothing in Visual Basic), to draw solid lines.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DashStyle AxisStyle { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStyle As DashStyle

Property Value

An instance of the WPF DashStyle class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.DefaultColors Property

Chart.DefaultColors Property
[image]

Gets or sets the default brushes for data series that do not have explicitly defined brushes.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Color[] DefaultColors { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultColors As Color()

Property Value

An array of WPF Color objects.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.DefaultLineSize Property

Chart.DefaultLineSize Property
[image]

Gets or sets the default thickness in line and radar charts for series that have no explicitly specified line size.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure DefaultLineSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultLineSize As Measure

Property Value

An instance of the Measure class. The default is "1.5pt".

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.DefaultSeriesNameFormat Property

Chart.DefaultSeriesNameFormat Property
[image]

Gets or sets the format of the names of the data series that do not have an explicitly defined name.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string DefaultSeriesNameFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultSeriesNameFormat As String

Property Value

A string value. The default is "Series{0}".

Remarks

The first placeholder, {0}, is replaced by the 1-based index of the respective series in the Series collection.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.Fill Property

Chart.Fill Property
[image]

Gets or sets a brush used to fill the background of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

An instance of the Brush class. The default is a solid white brush.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontBold Property

Chart.FontBold Property
[image]

Gets or sets a value indicating whether the text in the chart is bold.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool FontBold { get; set; }

Visual Basic [image] Copy Code

Public Property FontBold As Boolean

Property Value

A boolean value. The default is false.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontItalic Property

Chart.FontItalic Property
[image]

Gets or sets a value indicating whether the text in the chart is italic.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool FontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property FontItalic As Boolean

Property Value

A boolean value. The default is false.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontName Property

Chart.FontName Property
[image]

Gets or sets the font of the texts in the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string value. The default is "Segoe UI".

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontSize Property

Chart.FontSize Property
[image]

Gets or sets the font size of the texts of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value. The default is 9.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontStrikeout Property

Chart.FontStrikeout Property
[image]

Gets or sets a value indicating whether the text in the chart is with a line through the middle.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool FontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property FontStrikeout As Boolean

Property Value

A boolean value. The default is false.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.FontUnderline Property

Chart.FontUnderline Property
[image]

Gets or sets a value indicating whether the text in the chart is underlined.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool FontUnderline { get; set; }

Visual Basic [image] Copy Code

Public Property FontUnderline As Boolean

Property Value

A boolean value. The default is false.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.GridFillBrush Property

Chart.GridFillBrush Property
[image]

Gets or sets the fill brush of the grid stripes.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush GridFillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property GridFillBrush As Brush

Property Value

An instance of the Brush class.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.GridLineBrush Property

Chart.GridLineBrush Property
[image]

Gets or sets the brush of the major grid lines.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush GridLineBrush { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineBrush As Brush

Property Value

An instance of the WPF Brush class. The default is Black.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.GridLineSize Property

Chart.GridLineSize Property
[image]

Gets or sets the thickness of the major grid lines, or null (Nothing in Visual Basic), to use a hairline thickness.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure GridLineSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridLineSize As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendBorderBrush Property

Chart.LegendBorderBrush Property
[image]

Gets or sets the border brush of the legend, or null (Nothing in Visual Basic), to hide the border.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush LegendBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderBrush As Brush

Property Value

An object of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendBorderSize Property

Chart.LegendBorderSize Property
[image]

Gets or sets the border thickness of the legend, or null (Nothing in Visual Basic), to use a hairline thickness.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure LegendBorderSize { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderSize As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFill Property

Chart.LegendFill Property
[image]

Gets or sets a brush used to fill the legend's background.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush LegendFill { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFill As Brush

Property Value

An instance of the Brush class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontBold Property

Chart.LegendFontBold Property
[image]

Gets or sets a value indicating whether the legend text is bold, or null (Nothing in Visual Basic), to use the FontBold property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> LegendFontBold { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontBold As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontItalic Property

Chart.LegendFontItalic Property
[image]

Gets or sets a value indicating whether the legend text is italic, or null (Nothing in Visual Basic), to use the FontItalic property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> LegendFontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontItalic As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontName Property

Chart.LegendFontName Property
[image]

Gets or sets the font name of the legend, or null (Nothing in Visual Basic), to use the FontName property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string LegendFontName { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontName As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontSize Property

Chart.LegendFontSize Property
[image]

Gets or sets the font size of the legend, or null (Nothing in Visual Basic), to use the FontSize property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> LegendFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontSize As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontStrikeout Property

Chart.LegendFontStrikeout Property
[image]

Gets or sets a value indicating whether the legend text is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> LegendFontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontStrikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendFontUnderline Property

Chart.LegendFontUnderline Property
[image]

Gets or sets a value indicating whether the legend text is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> LegendFontUnderline { get; set; }

Visual Basic [image] Copy Code

Public Property LegendFontUnderline As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendLanes Property

Chart.LegendLanes Property
[image]

Gets or sets the number of columns or rows to use when layouting items inside the legend, or null (Nothing in Visual Basic), to use the default number of columns or rows, which is 1.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Int32> LegendLanes { get; set; }

Visual Basic [image] Copy Code

Public Property LegendLanes As Nullable(Of Int32)

Property Value

A nullable integer value. The default is null (Nothing in Visual Basic).

Remarks

This property applies to the number of columns in a left/right-aligned legends and on the number of rows in top/bottom-aligned legends.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendPosition Property

Chart.LegendPosition Property
[image]

Gets or sets the legend position.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public LegendPosition LegendPosition { get; set; }

Visual Basic [image] Copy Code

Public Property LegendPosition As LegendPosition

Property Value

A member of the LegendPosition enumeration. The default is RightMiddle.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.LegendTextBrush Property

Chart.LegendTextBrush Property
[image]

Gets or sets the brush of the texts in the legend, or null (Nothing in Visual Basic), to use the TextBrush property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush LegendTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendTextBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.MarkShape Property

Chart.MarkShape Property
[image]

Gets or sets the shape of marks in the chart, or null (Nothing in Visual Basic), to use alternating shapes.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<MarkShape> MarkShape { get; set; }

Visual Basic [image] Copy Code

Public Property MarkShape As Nullable(Of MarkShape)

Property Value

A member of the MarkShape enumeration or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.PlotBorderBrush Property

Chart.PlotBorderBrush Property
[image]

Gets or sets the border brush of the chart's plot area, or null (Nothing in Visual Basic), to hide the border.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush PlotBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.PlotBorderSize Property

Chart.PlotBorderSize Property
[image]

Gets or sets the border thickness of the chart's plot area, or null (Nothing in Visual Basic), to use a hairline thickness.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure PlotBorderSize { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderSize As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.PlotBorderStyle Property

Chart.PlotBorderStyle Property
[image]

Gets or sets the border style of the chart's plot area, or null (Nothing in Visual Basic), to use a solid line.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DashStyle PlotBorderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property PlotBorderStyle As DashStyle

Property Value

An instance of the WPF DashStyle class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.PlotFill Property

Chart.PlotFill Property
[image]

Gets or sets a brush used to fill the background of the chart's plot area.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush PlotFill { get; set; }

Visual Basic [image] Copy Code

Public Property PlotFill As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.Series Property

Chart.Series Property
[image]

Gets a collection with the data series of the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public SeriesCollection Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As SeriesCollection

Property Value

A collection of Series objects.

Remarks

Chart series cannot be instantiated directly. To create and add a new series to the chart, call the Add method of the collection object returned by this property.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.ShowLegend Property

Chart.ShowLegend Property
[image]

Gets or sets a value indicating whether to display the chart's legend.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public bool ShowLegend { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLegend As Boolean

Property Value

A boolean value. The default is false.

Remarks

To specify the position of the legend, use the LegendPosition property.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TextBrush Property

Chart.TextBrush Property
[image]

Gets or sets the brush of the texts in the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of the WPF Brush class. The default is Black.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontBold Property

Chart.TitleFontBold Property
[image]

Gets or sets a value indicating whether the chart title is bold, or null (Nothing in Visual Basic), to use the FontBold property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontBold { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontBold As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontItalic Property

Chart.TitleFontItalic Property
[image]

Gets or sets a value indicating whether the chart title is italic, or null (Nothing in Visual Basic), to use the FontItalic property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontItalic { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontItalic As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontName Property

Chart.TitleFontName Property
[image]

Gets or sets the font of the chart title, or null (Nothing in Visual Basic), to use the FontName property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string TitleFontName { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontName As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontSize Property

Chart.TitleFontSize Property
[image]

Gets or sets the font size of the chart title, or null (Nothing in Visual Basic), to use the FontSize property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Double> TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Nullable(Of Double)

Property Value

A nullable double value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontStrikeout Property

Chart.TitleFontStrikeout Property
[image]

Gets or sets a value indicating whether the chart title is with a line through the middle, or null (Nothing in Visual Basic), to use the FontStrikeout property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontStrikeout { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStrikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleFontUnderline Property

Chart.TitleFontUnderline Property
[image]

Gets or sets a value indicating whether the chart title is underlined, or null (Nothing in Visual Basic), to use the FontUnderline property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Nullable<Boolean> TitleFontUnderline { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontUnderline As Nullable(Of Boolean)

Property Value

A nullable boolean value. The default is null (Nothing in Visual Basic).

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.TitleTextBrush Property

Chart.TitleTextBrush Property
[image]

Gets or sets the brush of the chart title, or null (Nothing in Visual Basic), to use the TextBrush property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush TitleTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleTextBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.Type Property

Chart.Type Property
[image]

Gets or sets the type of the chart. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ChartType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As ChartType

Property Value

A member of the ChartType enumeration. The default is Column.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.XAxisSettings Property

Chart.XAxisSettings Property
[image]

Gets the settings for the category label axis of the chart, if the chart is an axes chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AxisSettings XAxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class that can be used to customize the label axis.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart.YAxisSettings Property

Chart.YAxisSettings Property
[image]

Gets the settings for the value axis of the chart, if the chart is an axes chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public AxisSettings YAxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property YAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class that can be used to customize the value axis.

See Also

Chart Members
Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Chart Events

Chart Events
[image]

Public Events

Name | Description
PropertyValueChanged | INotifyPropertyValueChanged.PropertyValueChanged implementation. (Inherited from InteractiveObject.)

See Also

Chart Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter Class

ChartPresenter Class
[image]

Defines the presentation of charts in the WorkbookView.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ChartPresenter : InteractiveObjectPresenter

Visual Basic [image] Copy Code

Public Class ChartPresenter
Inherits InteractiveObjectPresenter

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Spreadsheet.Wpf.InteractiveObjectPresenter
MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter

See Also

ChartPresenter Members
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter Members

ChartPresenter Members
Fields Properties Methods
[image]

Defines the presentation of charts in the WorkbookView.

The following tables list the members exposed by the ChartPresenter type.

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property. (Inherited from InteractiveObjectPresenter.)
ChartProperty | Identifies the Chart dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from InteractiveObjectPresenter.)
ObjectProperty | Identifies the Object dependency property. (Inherited from InteractiveObjectPresenter.)

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Chart | Gets or sets the chart object associated with this presenter. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property. (Inherited from InteractiveObjectPresenter.)

Public Methods

Name | Description
OnApplyTemplate | InteractiveObjectPresenter.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetLayoutClip | FrameworkElement.GetLayoutClip override. (Inherited from InteractiveObjectPresenter.)
MeasureOverride | Control.MeasureOverride override.

See Also

ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter Fields

ChartPresenter Fields
[image]

Public Fields

Name | Description
AdjustmentHandleBackgroundProperty | Identifies the AdjustmentHandleBackground dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrushProperty | Identifies the AdjustmentHandleBorderBrush dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSizeProperty | Identifies the AdjustmentHandleSize dependency property. (Inherited from InteractiveObjectPresenter.)
ChartProperty | Identifies the Chart dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property. (Inherited from InteractiveObjectPresenter.)
ObjectProperty | Identifies the Object dependency property. (Inherited from InteractiveObjectPresenter.)

See Also

ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter.ChartProperty Field

ChartPresenter.ChartProperty Field
[image]

Identifies the Chart dependency property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ChartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ChartProperty As DependencyProperty

See Also

ChartPresenter Members
ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter Methods

ChartPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | InteractiveObjectPresenter.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
GetLayoutClip | FrameworkElement.GetLayoutClip override. (Inherited from InteractiveObjectPresenter.)
MeasureOverride | Control.MeasureOverride override.

See Also

ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter.ArrangeOverride Method

ChartPresenter.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

Return Value

See Also

ChartPresenter Members
ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter.MeasureOverride Method

ChartPresenter.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

Return Value

See Also

ChartPresenter Members
ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter.OnApplyTemplate Method

ChartPresenter.OnApplyTemplate Method
[image]

InteractiveObjectPresenter.OnApplyTemplate override.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ChartPresenter Members
ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter Properties

ChartPresenter Properties
[image]

Public Properties

Name | Description
AdjustmentHandleBackground | Gets or sets the background brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleBorderBrush | Gets or sets the border brush of the adjustment handles. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
AdjustmentHandleSize | Gets or sets the size of the adjustment handles, in pixels. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Chart | Gets or sets the chart object associated with this presenter. This is a dependency property.
IsSelected | Gets or sets a value indicating whether the presenter is selected. This is a dependency property. (Inherited from InteractiveObjectPresenter.)
Object | Gets or sets the interactive object associated with this presenter. This is a dependency property. (Inherited from InteractiveObjectPresenter.)

See Also

ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartPresenter.Chart Property

ChartPresenter.Chart Property
[image]

Gets or sets the chart object associated with this presenter. This is a dependency property.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Chart Chart { get; set; }

Visual Basic [image] Copy Code

Public Property Chart As Chart

Property Value

An instance of the Chart class.

See Also

ChartPresenter Members
ChartPresenter Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.ChartType Enumeration

ChartType Enumeration
[image]

Specified the type of a Chart object.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ChartType

Visual Basic [image] Copy Code

Public Enum ChartType

Members

Member name | Description
Area | Indicates an area chart.
AreaStacked | Indicates an area chart with stacked values.
AreaStacked100Percent | Indicates an area chart with 100% stacked values.
Bar | Indicates a bar chart.
BarStacked | Indicates a bar chart with stacked values.
BarStacked100Percent | Indicates a bar chart with 100% stacked values.
Bubble | Indicates a bubble chart.
Column | Indicates a column chart.
ColumnStacked | Indicates a column chart with stacked values.
ColumnStacked100Percent | Indicates a column chart with 100% stacked values.
Donut | Indicates a donut chart.
DonutExploded | Indicates a donut chart with pieces set apart.
Line | Indicates a line chart.
LineMarks | Indicates a line chart with only marks.
LineStacked | Indicates a line chart with stacked values.
LineStacked100Percent | Indicates a line chart with 100% stacked values.
LineWithMarks | Indicates a line chart with both lines and marks.
LineWithMarksStacked | Indicates a line chart with lines and marks with stacked values.
LineWithMarksStacked100Percent | Indicates a line chart with lines and marks with 100% stacked values.
Pie | Indicates a pie chart.
PieExploded | Indicates a pie chart with pieces set apart.
RadarFilled | Indicates a radar chart with filled areas.
RadarFilledWithLines | Indicates a radar chart with filled areas and lines.
RadarWithLines | Indicates a radar chart with lines.
RadarWithLinesAndMarks | Indicates a radar chart with lines and marks.
RadarWithMarks | Indicates a radar chart with marks.
ScatterWithLines | Indicates a scatter chart with lines.
ScatterWithLinesAndMarks | Indicates a scatter chart with lines and marks.
ScatterWithMarks | Indicates a scatter chart with marks.
ScatterWithSmoothLines | Indicates a scatter chart with smooth lines.
ScatterWithSmoothLinesAndMarks | Indicates a scatter chart with smooth lines and marks.
SmoothArea | Indicates a smooth area chart.
SmoothAreaStacked | Indicates a smooth area chart with stacked values.
SmoothAreaStacked100Percent | Indicates a smooth area chart with 100% stacked values.
SmoothLine | Indicates a line chart with smooth lines.
SmoothLineStacked | Indicates a line chart with smooth lines with stacked values.
SmoothLineStacked100Percent | Indicates a line chart with smooth lines with 100% stacked values.
SmoothLineWithMarks | Indicates a line chart with smooth lines and marks.
SmoothLineWithMarksStacked | Indicates a line chart with smooth lines and marks with stacked values.
SmoothLineWithMarksStacked100Percent | Indicates a line chart with smooth lines and marks with 100% stacked values.

See Also

MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.LegendPosition Enumeration

LegendPosition Enumeration
[image]

Specifies the position of the legend in a Chart object.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum LegendPosition

Visual Basic [image] Copy Code

Public Enum LegendPosition

Members

Member name | Description
Bottom | Indicates that the legend should be placed below the plot area, centered horizontally.
Left | Indicates that the legend should be placed to the left of the plot area, centered vertically.
RightDown | Indicates that the legend should be placed to the right of the plot area, in the bottom corner.
RightMiddle | Indicates that the legend should be placed to the right of the plot area, centered vertically.
RightUp | Indicates that the legend should be placed to the right of the plot area, in the top corner.
Top | Indicates that the legend should be placed above the plot area, centered horizontally.

See Also

MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.MarkShape Enumeration

MarkShape Enumeration
[image]

Specifies the shape of a mark in a chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum MarkShape

Visual Basic [image] Copy Code

Public Enum MarkShape

Members

Member name | Description
Circle | Indicates a circle.
Cross | Indicates a cross shape.
HorStick | Indicates a horizontal stick.
InvertedTriangle | Indicates an inverted triangle.
Plus | Indicates a plus shape.
Rhombus | Indicates a rhombus.
Square | Indicates a square.
Star | Indicates a star shape.
Triangle | Indicates a triangle.
VertStick | Indicates a vertical stick.

See Also

MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.PlotBy Enumeration

PlotBy Enumeration
[image]

Specifies how chart series are created from a data source.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum PlotBy

Visual Basic [image] Copy Code

Public Enum PlotBy

Members

Member name | Description
Column | Indicates that the leftmost column in the data source represents the category labels and each subsequent column represents a data series.
Row | Indicates that the top row in the data source represents the category labels and each subsequent row represents a data series.

See Also

MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series Class

Series Class
Remarks See Also
[image]

Represents a data series in a Chart object.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class Series

Visual Basic [image] Copy Code

Public Class Series

Remarks

This class cannot be instantiated directly. To add a series to a chart, call the Add method of the SeriesCollection returned by the Series property of the chart.

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Charts.Series

See Also

Series Members
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series Members

Series Members
Properties
[image]

Represents a data series in a Chart object.

The following tables list the members exposed by the Series type.

Public Properties

Name | Description
Fill | Gets or sets a brush that is used to fill the chart elements representing the series, or null (Nothing in Visual Basic), to automatically assign a brush.
Labels | Gets or sets the labels of the series. The first available labels are used for the category names for all series in the chart.
LineBrush | Gets or sets the outline color of the chart elements representing the series, or null (Nothing in Visual Basic), to hide the outlines.
LineSize | Gets or sets the outline thickness of the chart elements representing the series, or null (Nothing in Visual Basic), to use the default thickness.
LineStyle | Gets or sets the outline style of the chart elements representing the series, or null (Nothing in Visual Basic), to draw solid lines.
Name | Gets or sets the name of the series.
Values | Gets or sets the values of the series.

See Also

Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series Properties

Series Properties
[image]

Public Properties

Name | Description
Fill | Gets or sets a brush that is used to fill the chart elements representing the series, or null (Nothing in Visual Basic), to automatically assign a brush.
Labels | Gets or sets the labels of the series. The first available labels are used for the category names for all series in the chart.
LineBrush | Gets or sets the outline color of the chart elements representing the series, or null (Nothing in Visual Basic), to hide the outlines.
LineSize | Gets or sets the outline thickness of the chart elements representing the series, or null (Nothing in Visual Basic), to use the default thickness.
LineStyle | Gets or sets the outline style of the chart elements representing the series, or null (Nothing in Visual Basic), to draw solid lines.
Name | Gets or sets the name of the series.
Values | Gets or sets the values of the series.

See Also

Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.Fill Property

Series.Fill Property
[image]

Gets or sets a brush that is used to fill the chart elements representing the series, or null (Nothing in Visual Basic), to automatically assign a brush.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

An instance of the WPF Brush class. The default is null (Nothing in Visual Basic).

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.Labels Property

Series.Labels Property
[image]

Gets or sets the labels of the series. The first available labels are used for the category names for all series in the chart.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This property can be an expression that evaluates to a range of cells or a matrix, or a name of a range of cells.

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.LineBrush Property

Series.LineBrush Property
[image]

Gets or sets the outline color of the chart elements representing the series, or null (Nothing in Visual Basic), to hide the outlines.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Brush LineBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LineBrush As Brush

Property Value

An instance of the WPF Brush class or null (Nothing in Visual Basic). The default is null.

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.LineSize Property

Series.LineSize Property
[image]

Gets or sets the outline thickness of the chart elements representing the series, or null (Nothing in Visual Basic), to use the default thickness.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Measure LineSize { get; set; }

Visual Basic [image] Copy Code

Public Property LineSize As Measure

Property Value

An instance of the Measure class. The default is null (Nothing in Visual Basic).

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.LineStyle Property

Series.LineStyle Property
[image]

Gets or sets the outline style of the chart elements representing the series, or null (Nothing in Visual Basic), to draw solid lines.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public DashStyle LineStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LineStyle As DashStyle

Property Value

A member of the WPF DashStyle enumeration or null (Nothing in Visual Basic). The default is null.

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.Name Property

Series.Name Property
[image]

Gets or sets the name of the series.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This property can be an expression or a name of a cell.

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.Series.Values Property

Series.Values Property
[image]

Gets or sets the values of the series.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string Values { get; set; }

Visual Basic [image] Copy Code

Public Property Values As String

Property Value

A string value. The default is null (Nothing in Visual Basic).

Remarks

This property can be an expression that evaluates to a range of cells or a matrix, or a name of a range of cells.

See Also

Series Members
Series Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection Class

SeriesCollection Class
[image]

Represents a specialized collection for the series of a Chart object.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class SeriesCollection : UndoableCollection<Series>

Visual Basic [image] Copy Code

Public Class SeriesCollection
Inherits UndoableCollection(Of Series)

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.UndoableCollection(Series)
MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection

See Also

SeriesCollection Members
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection Members

SeriesCollection Members
Properties Methods Events
[image]

Represents a specialized collection for the series of a Chart object.

The following tables list the members exposed by the SeriesCollection type.

Public Properties

Name | Description
Count | Gets the number of items in the collection. (Inherited from UndoableCollection.)
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from UndoableCollection.)
Item | Gets the item at the specified index. (Inherited from UndoableCollection.)
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from UndoableCollection.)

Protected Properties

Name | Description
Workbook | Gets a reference to the parent Workbook object. (Inherited from UndoableCollection.)

Public Methods

Name | Description
Add | Creates and adds a new Series to the collection.
Clear | Removes all Series objects from the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Remove | Removes the specified Series object from the collection.

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UndoableCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection Methods

SeriesCollection Methods
[image]

Public Methods

Name | Description
Add | Creates and adds a new Series to the collection.
Clear | Removes all Series objects from the collection.
Contains | Determines whether an element is in the collection. (Inherited from UndoableCollection.)
CopyTo | Copies the elements of this collection to the specified array starting at the specified index within the array. (Inherited from UndoableCollection.)
GetEnumerator | IEnumerator.GetEnumerator implementation. (Inherited from UndoableCollection.)
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the entire collection. (Inherited from UndoableCollection.)
Remove | Removes the specified Series object from the collection.

Protected Methods

Name | Description
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UndoableCollection.)
TrackAdd | Adds the specified item to the collection. If undo is enabled, the item is added through a command. Otherwise, the item is added directly. (Inherited from UndoableCollection.)
TrackClear | Clears the collection. If undo is enabled, the collection is cleared through a command. Otherwise, the collection is cleared directly. (Inherited from UndoableCollection.)
TrackMove | Moves the specified item to another position. If undo is enabled, the item is moved through a command. Otherwise, the item is moved directly. (Inherited from UndoableCollection.)
TrackRemove | Removes the specified item to the collection. If undo is enabled, the item is removed through a command. Otherwise, the item is removed directly. (Inherited from UndoableCollection.)
TrackReplace | Removes the specified item in the collection. If undo is enabled, the item is replaced through a command. Otherwise, the item is replaced directly. (Inherited from UndoableCollection.)

See Also

SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection.Add Method

SeriesCollection.Add Method
[image]

Creates and adds a new Series to the collection.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Series Add ()

Visual Basic [image] Copy Code

Public Function Add () As Series

Return Value

The newly created Series object.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection.Clear Method

SeriesCollection.Clear Method
[image]

Removes all Series objects from the collection.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection.Remove Method

SeriesCollection.Remove Method
[image]

Removes the specified Series object from the collection.

Namespace: MindFusion.Spreadsheet.Wpf.Charts
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public void Remove (
Series series
)

Visual Basic [image] Copy Code

Public Sub Remove( _
series As Series _
)

Parameters

series

The Series object to remove.

See Also

SeriesCollection Members
SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Charts.SeriesCollection Events

SeriesCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection is changed. (Inherited from UndoableCollection.)

See Also

SeriesCollection Class
MindFusion.Spreadsheet.Wpf.Charts Namespace


MindFusion.Spreadsheet.Wpf.Expressions Namespace

MindFusion.Spreadsheet.Wpf.Expressions Namespace
Classes Interfaces Enumerations

Classes

Class | Description
ExpressionEvaluatorList | An expression evaluator that represents a collection of evaluators. Evaluation is delegated to the evaluators in the list in the order they were added.
XmlInformationProvider | Provides function information from an XML file.

Interfaces

Interface | Description
IExpressionEvaluator | Provides evaluation for functions and identifiers inside expressions.
IExpressionEvaluatorContext | Provides context for expression evaluators.
IInformationProvider | Provides function information, such as summary, which can be displayed in the user interface.

Enumerations

Enumeration | Description
ErrorType | Specifies the type of error.


MindFusion.Spreadsheet.Wpf.Expressions.ErrorType Enumeration

ErrorType Enumeration
[image]

Specifies the type of error.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public enum ErrorType

Visual Basic [image] Copy Code

Public Enum ErrorType

Members

Member name | Description
Div0 | Indicates division by zero.
General | Indicates a parse error.
NA | Indicates not available.
Name | Indicates unrecognized name, such as range, function or sheet name.
None | Indicates an invalid error type.
Null | Indicates that intersection of ranges produced zero cells.
Num | Indicates failure to meet domain constraints (for example, input was too large or too small).
Ref | Indicates reference to an invalid cell (for example, beyond the application's abilities or a cell participating in a circular reference).
Value | Indicates an invalid operand type, including when range has no entry corresponding to a cell.

See Also

MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList Class

ExpressionEvaluatorList Class
[image]

An expression evaluator that represents a collection of evaluators. Evaluation is delegated to the evaluators in the list in the order they were added.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class ExpressionEvaluatorList : Collection<IExpressionEvaluator>, IExpressionEvaluator

Visual Basic [image] Copy Code

Public Class ExpressionEvaluatorList
Inherits Collection(Of IExpressionEvaluator)
Implements IExpressionEvaluator

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(IExpressionEvaluator)
MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList

See Also

ExpressionEvaluatorList Members
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList Members

ExpressionEvaluatorList Members
Constructors Methods
[image]

An expression evaluator that represents a collection of evaluators. Evaluation is delegated to the evaluators in the list in the order they were added.

The following tables list the members exposed by the ExpressionEvaluatorList type.

Public Constructors

Name | Description
ExpressionEvaluatorList | Initializes a new instance of the ExpressionEvaluatorList class.

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
InvokeFunction | Invokes the function with the specified name and parameters.

See Also

ExpressionEvaluatorList Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList Constructor

ExpressionEvaluatorList Constructor
[image]

Initializes a new instance of the ExpressionEvaluatorList class.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public ExpressionEvaluatorList ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExpressionEvaluatorList Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList Methods

ExpressionEvaluatorList Methods
[image]

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
InvokeFunction | Invokes the function with the specified name and parameters.

See Also

ExpressionEvaluatorList Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList.EvaluateIdentifier Method

ExpressionEvaluatorList.EvaluateIdentifier Method
[image]

Evaluates the identifier with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object EvaluateIdentifier (
IExpressionEvaluatorContext context,
string identifier
)

Visual Basic [image] Copy Code

Public Function EvaluateIdentifier( _
context As IExpressionEvaluatorContext, _
identifier As String _
) As Object

Parameters

context

The evaluation context.

identifier

The name of the identifier.

Return Value

The result of the evaluation.

See Also

ExpressionEvaluatorList Members
ExpressionEvaluatorList Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList.InvokeFunction Method

ExpressionEvaluatorList.InvokeFunction Method
[image]

Invokes the function with the specified name and parameters.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object InvokeFunction (
IExpressionEvaluatorContext context,
string name,
IList parameters
)

Visual Basic [image] Copy Code

Public Function InvokeFunction( _
context As IExpressionEvaluatorContext, _
name As String, _
parameters As IList _
) As Object

Parameters

context

The evaluation context.

name

The name of the function.

parameters

The function parameters.

Return Value

The result of the evaluation.

See Also

ExpressionEvaluatorList Members
ExpressionEvaluatorList Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluator Interface

IExpressionEvaluator Interface
[image]

Provides evaluation for functions and identifiers inside expressions.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IExpressionEvaluator

Visual Basic [image] Copy Code

Public Interface IExpressionEvaluator

Inheritors

MindFusion.Spreadsheet.Wpf.Expressions.ExpressionEvaluatorList

See Also

IExpressionEvaluator Members
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluator Members

IExpressionEvaluator Members
Methods
[image]

Provides evaluation for functions and identifiers inside expressions.

The following tables list the members exposed by the IExpressionEvaluator type.

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
InvokeFunction | Invokes the function with the specified name and parameters.

See Also

IExpressionEvaluator Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluator Methods

IExpressionEvaluator Methods
[image]

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
InvokeFunction | Invokes the function with the specified name and parameters.

See Also

IExpressionEvaluator Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluator.EvaluateIdentifier Method

IExpressionEvaluator.EvaluateIdentifier Method
[image]

Evaluates the identifier with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Object EvaluateIdentifier (
IExpressionEvaluatorContext context,
string identifier
)

Visual Basic [image] Copy Code

Function EvaluateIdentifier( _
context As IExpressionEvaluatorContext, _
identifier As String _
) As Object

Parameters

context

A helper object that can be used to obtain error values, invoke predefined functions, and so on.

identifier

The name of the identifier.

Return Value

A bool, double, string, DateTime, or TimeSpan value, or an error received by calling the IExpressionEvaluatorContext.GetError method. Any other value will be interpreted as the identifier not being evaluated.

See Also

IExpressionEvaluator Members
IExpressionEvaluator Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluator.InvokeFunction Method

IExpressionEvaluator.InvokeFunction Method
[image]

Invokes the function with the specified name and parameters.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Object InvokeFunction (
IExpressionEvaluatorContext context,
string name,
IList parameters
)

Visual Basic [image] Copy Code

Function InvokeFunction( _
context As IExpressionEvaluatorContext, _
name As String, _
parameters As IList _
) As Object

Parameters

context

A helper object that can be used to obtain error values, invoke predefined functions, and so on.

name

The name of the function.

parameters

The function parameters.

Return Value

A bool, double, string, DateTime, or TimeSpan value, or an error received by calling the IExpressionEvaluatorContext.GetError method. Any other value will be interpreted as the function not being invoked.

Remarks

To interpret a parameter as a CLR value, pass the parameter to one of the following methods of the supplied IExpressionEvaluatorContext object: ToDouble, ToString, ToBool, ToDateTime, or ToTimeSpan. The context will attempt to convert the parameter to the desired type and returns null (Nothing in Visual Basic) if unsuccessful. To check if a parameter is an error, call the ISERROR function of the core evaluator.

See Also

IExpressionEvaluator Members
IExpressionEvaluator Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext Interface

IExpressionEvaluatorContext Interface
[image]

Provides context for expression evaluators.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IExpressionEvaluatorContext : IFormatProvider

Visual Basic [image] Copy Code

Public Interface IExpressionEvaluatorContext
Implements IFormatProvider

See Also

IExpressionEvaluatorContext Members
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext Members

IExpressionEvaluatorContext Members
Properties Methods
[image]

Provides context for expression evaluators.

The following tables list the members exposed by the IExpressionEvaluatorContext type.

Public Properties

Name | Description
Workbook | Gets a reference to the parent workbook.

Public Methods

Name | Description
GetCoreEvaluator | Gets the core evaluator. The core evaluator can be used to invoke any of the predefined functions or identifiers.
GetError | Returns an error object of the specified type.
ToBool | Attempts to convert the specified value to a boolean.
ToDateTime | Attempts to convert the specified value to a DateTime.
ToDouble | Attempts to convert the specified value to a double.
ToString | Attempts to convert the specified value to a string.
ToTimeSpan | Attempts to convert the specified value to a TimeSpan.
ToValue | Attempts to evaluate the specified object.

See Also

IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext Methods

IExpressionEvaluatorContext Methods
[image]

Public Methods

Name | Description
GetCoreEvaluator | Gets the core evaluator. The core evaluator can be used to invoke any of the predefined functions or identifiers.
GetError | Returns an error object of the specified type.
ToBool | Attempts to convert the specified value to a boolean.
ToDateTime | Attempts to convert the specified value to a DateTime.
ToDouble | Attempts to convert the specified value to a double.
ToString | Attempts to convert the specified value to a string.
ToTimeSpan | Attempts to convert the specified value to a TimeSpan.
ToValue | Attempts to evaluate the specified object.

See Also

IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.GetCoreEvaluator Method

IExpressionEvaluatorContext.GetCoreEvaluator Method
[image]

Gets the core evaluator. The core evaluator can be used to invoke any of the predefined functions or identifiers.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IExpressionEvaluator GetCoreEvaluator ()

Visual Basic [image] Copy Code

Function GetCoreEvaluator () As IExpressionEvaluator

Return Value

An IExpressionEvaluator object identifying the core evaluator.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.GetError Method

IExpressionEvaluatorContext.GetError Method
[image]

Returns an error object of the specified type.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Object GetError (
ErrorType errorType,
string message
)

Visual Basic [image] Copy Code

Function GetError( _
errorType As ErrorType, _
message As String _
) As Object

Parameters

errorType

One of the ErrorType constants identifying the type of the error.

message

The message associated with the error.

Return Value

An error object of the specified type.

Remarks

This method can be used when a custom function needs to return an error.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToBool Method

IExpressionEvaluatorContext.ToBool Method
[image]

Attempts to convert the specified value to a boolean.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Boolean> ToBool (
Object value
)

Visual Basic [image] Copy Code

Function ToBool( _
value As Object _
) As Nullable(Of Boolean)

Parameters

value

The value to convert.

Return Value

A boolean value corresponding to the specified value, or null (Nothing in Visual Basic), if value cannot be represented as boolean.

Remarks

This method is usually used when trying to interpret a parameter passed to a custom function.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToDateTime Method

IExpressionEvaluatorContext.ToDateTime Method
[image]

Attempts to convert the specified value to a DateTime.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<DateTime> ToDateTime (
Object value
)

Visual Basic [image] Copy Code

Function ToDateTime( _
value As Object _
) As Nullable(Of DateTime)

Parameters

value

The value to convert.

Return Value

A DateTime value corresponding to the specified value, or null (Nothing in Visual Basic), if value cannot be represented as DateTime.

Remarks

This method is usually used when trying to interpret a parameter passed to a custom function.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToDouble Method

IExpressionEvaluatorContext.ToDouble Method
[image]

Attempts to convert the specified value to a double.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<Double> ToDouble (
Object value
)

Visual Basic [image] Copy Code

Function ToDouble( _
value As Object _
) As Nullable(Of Double)

Parameters

value

The value to convert.

Return Value

A double value corresponding to the specified value, or null (Nothing in Visual Basic), if value cannot be represented as double.

Remarks

This method is usually used when trying to interpret a parameter passed to a custom function.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToString Method

IExpressionEvaluatorContext.ToString Method
[image]

Attempts to convert the specified value to a string.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string ToString (
Object value
)

Visual Basic [image] Copy Code

Function ToString( _
value As Object _
) As String

Parameters

value

The value to convert.

Return Value

A string value corresponding to the specified value, or null (Nothing in Visual Basic), if value cannot be represented as string.

Remarks

This method is usually used when trying to interpret a parameter passed to a custom function.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToTimeSpan Method

IExpressionEvaluatorContext.ToTimeSpan Method
[image]

Attempts to convert the specified value to a TimeSpan.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Nullable<TimeSpan> ToTimeSpan (
Object value
)

Visual Basic [image] Copy Code

Function ToTimeSpan( _
value As Object _
) As Nullable(Of TimeSpan)

Parameters

value

The value to convert.

Return Value

A TimeSpan value corresponding to the specified value, or null (Nothing in Visual Basic), if value cannot be represented as TimeSpan.

Remarks

This method is usually used when trying to interpret a parameter passed to a custom function.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.ToValue Method

IExpressionEvaluatorContext.ToValue Method
[image]

Attempts to evaluate the specified object.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Object ToValue (
Object value
)

Visual Basic [image] Copy Code

Function ToValue( _
value As Object _
) As Object

Parameters

value

The object to evaluate.

Return Value

The value of the object, or null (Nothing in Visual Basic), if the object cannot be evaluated.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext Properties

IExpressionEvaluatorContext Properties
[image]

Public Properties

Name | Description
Workbook | Gets a reference to the parent workbook.

See Also

IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IExpressionEvaluatorContext.Workbook Property

IExpressionEvaluatorContext.Workbook Property
[image]

Gets a reference to the parent workbook.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Workbook Workbook { get; }

Visual Basic [image] Copy Code

ReadOnly Property Workbook As Workbook

Property Value

A Workbook object.

See Also

IExpressionEvaluatorContext Members
IExpressionEvaluatorContext Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider Interface

IInformationProvider Interface
[image]

Provides function information, such as summary, which can be displayed in the user interface.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public interface IInformationProvider

Visual Basic [image] Copy Code

Public Interface IInformationProvider

Inheritors

MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider

See Also

IInformationProvider Members
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider Members

IInformationProvider Members
Methods
[image]

Provides function information, such as summary, which can be displayed in the user interface.

The following tables list the members exposed by the IInformationProvider type.

Public Methods

Name | Description
GetFunctionInformation | Gets an object containing information about the function signature.
GetFunctions | Gets a list with the names of all available functions.
GetFunctionSummary | Gets a summary for the function with the specified name.

See Also

IInformationProvider Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider Methods

IInformationProvider Methods
[image]

Public Methods

Name | Description
GetFunctionInformation | Gets an object containing information about the function signature.
GetFunctions | Gets a list with the names of all available functions.
GetFunctionSummary | Gets a summary for the function with the specified name.

See Also

IInformationProvider Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider.GetFunctionInformation Method

IInformationProvider.GetFunctionInformation Method
[image]

Gets an object containing information about the function signature.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

Object GetFunctionInformation (
string name
)

Visual Basic [image] Copy Code

Function GetFunctionInformation( _
name As String _
) As Object

Parameters

name

The name of the function.

Return Value

An object containing the function signature.

Remarks

In client implementations this method should return null (Nothing in Visual Basic).

See Also

IInformationProvider Members
IInformationProvider Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider.GetFunctions Method

IInformationProvider.GetFunctions Method
[image]

Gets a list with the names of all available functions.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

IEnumerable<string> GetFunctions ()

Visual Basic [image] Copy Code

Function GetFunctions () As IEnumerable(Of String)

Return Value

An enumerable of the function names.

See Also

IInformationProvider Members
IInformationProvider Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.IInformationProvider.GetFunctionSummary Method

IInformationProvider.GetFunctionSummary Method
[image]

Gets a summary for the function with the specified name.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

string GetFunctionSummary (
string name
)

Visual Basic [image] Copy Code

Function GetFunctionSummary( _
name As String _
) As String

Parameters

name

The name of the function.

Return Value

A string representing the function description.

See Also

IInformationProvider Members
IInformationProvider Interface
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider Class

XmlInformationProvider Class
Remarks See Also
[image]

Provides function information from an XML file.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public class XmlInformationProvider : IInformationProvider

Visual Basic [image] Copy Code

Public Class XmlInformationProvider
Implements IInformationProvider

Remarks

This class can be used to load function information from an XML file. The XML file should have the following structure:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<functions>

<function name="MYFUNCTION">
<summary>This is the function summary.</summary>
<example>This is an example of the function usage.</example>
<parameters>
<parameter name="paramName" optional="true/false">
<summary>This is the parameter description.</summary>
</parameter>
...
</parameters>
</function>

...

</functions>

Inheritance Hierarchy

System.Object
MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider

See Also

XmlInformationProvider Members
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider Members

XmlInformationProvider Members
Methods
[image]

Provides function information from an XML file.

The following tables list the members exposed by the XmlInformationProvider type.

Public Methods

Name | Description
Create | Creates a XmlInformationProvider instance from the specified XDocument object.
GetFunctionInformation | IInformationProvider.GetFunctionInformation implementation.
GetFunctions | IInformationProvider.GetFunctions implementation.
GetFunctionSummary | IInformationProvider.GetFunctionSummary implementation.

See Also

XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider Methods

XmlInformationProvider Methods
[image]

Public Methods

Name | Description
Create | Creates a XmlInformationProvider instance from the specified XDocument object.
GetFunctionInformation | IInformationProvider.GetFunctionInformation implementation.
GetFunctions | IInformationProvider.GetFunctions implementation.
GetFunctionSummary | IInformationProvider.GetFunctionSummary implementation.

See Also

XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider.Create Method

XmlInformationProvider.Create Method
[image]

Creates a XmlInformationProvider instance from the specified XDocument object.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public static XmlInformationProvider Create (
XDocument doc
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
doc As XDocument _
) As XmlInformationProvider

Parameters

doc

A XDocument that contains the function information.

Return Value

An instance of the XmlInformationProvider class.

See Also

XmlInformationProvider Members
XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider.GetFunctionInformation Method

XmlInformationProvider.GetFunctionInformation Method
[image]

IInformationProvider.GetFunctionInformation implementation.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public Object GetFunctionInformation (
string name
)

Visual Basic [image] Copy Code

Public Function GetFunctionInformation( _
name As String _
) As Object

Parameters

name

The name of the function.

Return Value

An object containing the function signature.

See Also

XmlInformationProvider Members
XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider.GetFunctions Method

XmlInformationProvider.GetFunctions Method
[image]

IInformationProvider.GetFunctions implementation.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public IEnumerable<string> GetFunctions ()

Visual Basic [image] Copy Code

Public Function GetFunctions () As IEnumerable(Of String)

Return Value

An enumerable of the function names.

See Also

XmlInformationProvider Members
XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.Expressions.XmlInformationProvider.GetFunctionSummary Method

XmlInformationProvider.GetFunctionSummary Method
[image]

IInformationProvider.GetFunctionSummary implementation.

Namespace: MindFusion.Spreadsheet.Wpf.Expressions
Assembly: MindFusion.Spreadsheet.Wpf

Syntax

C# [image] Copy Code

public string GetFunctionSummary (
string name
)

Visual Basic [image] Copy Code

Public Function GetFunctionSummary( _
name As String _
) As String

Parameters

name

The name of the function.

Return Value

A string representing the function description.

See Also

XmlInformationProvider Members
XmlInformationProvider Class
MindFusion.Spreadsheet.Wpf.Expressions Namespace


MindFusion.Spreadsheet.Wpf.StandardForms Namespace

MindFusion.Spreadsheet.Wpf.StandardForms Namespace
Classes Enumerations

Classes

Class | Description
ChartForm | Represents a form which can be used to create and modify chart objects within a worksheet.
ConditionalFormatForm | A form which can be used to define conditional formats for cells within a worksheet.
CsvExportForm | A form used to define options for CSV text data exports.
CsvImportForm | A form used to define options for CSV text data imports.
DefineNamedRangeForm | Prompts the user to define a named range for a worksheet.
DeleteCellsForm | Prompts the user to insert cells within a worksheet.
FillSeriesForm | A form which can be used to specify fill patterns for filling cell ranges with data.
FindReplaceForm | Represents a form that can be used to find and/or replace texts matching a specified criteria.
FontPickerForm | Represents a dialog which can be used to specify font styles within a worksheet.
FormatForm | A form which can be used to define format for cells within a worksheet.
HeaderSizeForm | Represents a form that can be used to define row height or column width within a worksheet.
HyperlinkForm | Represents a form which can be used to create and modify cell hyperlinks in a worksheet.
InsertCellsForm | Prompts the user to insert cells within a worksheet.
InsertWorksheetForm | Prompts the user to insert worksheets within a workbook.
ManageNamedRangesForm | Represents a form which can be used to create, edit and remove named cell ranges from a workbook.
SortForm | Represents a form used to define sorting options for a cell range.
UnhideSheetsForm | Represents a form which can be used to unhide hidden worksheets in a workbook.
ValidationForm | A form which can be used to define validation rules for cells within a worksheet.
WorksheetRenameForm | Represents a form that can be used specify a name for a worksheet.

Enumerations

Enumeration | Description
CellsFormResult | Specifies identifiers to indicate the result value of an InsertCellsForm or DeleteCellsForm box.
InsertWorksheetPosition | Specifies identifiers to indicate the position of inserted worksheets within a workbook.


MindFusion.Spreadsheet.Wpf.StandardForms.CellsFormResult Enumeration

CellsFormResult Enumeration
[image]

Specifies identifiers to indicate the result value of an InsertCellsForm or DeleteCellsForm box.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public enum CellsFormResult

Visual Basic [image] Copy Code

Public Enum CellsFormResult

Members

Member name | Description
EntireColumn | Indicates that whole column(s) be inserted or deleted to the left of the active cell.
EntireRow | Indicates that whole row(s) be inserted or deleted above the active cell.
ShiftHorizontal | Indicates that new cells will be inserted to the left or removed to the right of the active cell.
ShiftVertical | Indicates that new cells will be inserted above or removed below the active cell.

See Also

MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Class

ChartForm Class
Remarks See Also
[image]

Represents a form which can be used to create and modify chart objects within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class ChartForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class ChartForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to insert new or edit existing Chart objects in a Worksheet. To use the form, create an instance of the ChartForm class, by providing the related worksheet or the chart to edit, and call the ShowDialog method. The changes made through the form are automatically applied to the target chart. The following image displays the chart form:

Example

The code below demonstrates how to display the chart form for an existing Chart object.

C# [image] Copy Code

var form = new ChartForm(worksheet, chart);
form.ShowDialog();

Visual Basic [image] Copy Code

Dim form As New ChartForm(worksheet, chart)
form.ShowDialog()

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm

See Also

ChartForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Members

ChartForm Members
Constructors Methods
[image]

Represents a form which can be used to create and modify chart objects within a worksheet.

The following tables list the members exposed by the ChartForm type.

Public Constructors

Name | Description
ChartForm | Overloaded. Initializes a new instance of the ChartForm class.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor

ChartForm Constructor
[image]

Initializes a new instance of the ChartForm class.

Overload List

Name | Description
ChartForm (Chart) | Initializes a new instance of the ChartForm class.
ChartForm (Worksheet) | Initializes a new instance of the ChartForm class.
ChartForm (Worksheet, String) | Initializes a new instance of the ChartForm class.
ChartForm (Worksheet, String, PlotBy) | Initializes a new instance of the ChartForm class.
ChartForm (Worksheet, String, PlotBy, Int32, Int32, Nullable(Boolean), Nullable(Boolean)) | Initializes a new instance of the ChartForm class.

See Also

ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor (Chart)

ChartForm Constructor (Chart)
See Also
[image]

Initializes a new instance of the ChartForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ChartForm (
Chart chart
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart _
)

Parameters

chart

The Chart object to edit with this form.

Remarks

Use this constructor to edit existing charts within a worksheet.

See Also

ChartForm Constructor Overload List
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor (Worksheet)

ChartForm Constructor (Worksheet)
See Also
[image]

Initializes a new instance of the ChartForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ChartForm (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public New ( _
worksheet As Worksheet _
)

Parameters

worksheet

The parent Worksheet that will contain the created chart.

See Also

ChartForm Constructor Overload List
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor (Worksheet, String)

ChartForm Constructor (Worksheet, String)
See Also
[image]

Initializes a new instance of the ChartForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ChartForm (
Worksheet worksheet,
string dataSource
)

Visual Basic [image] Copy Code

Public New ( _
worksheet As Worksheet, _
dataSource As String _
)

Parameters

worksheet

The parent Worksheet that will contain the created chart.

dataSource

A string specifying the data source for the chart.

See Also

ChartForm Constructor Overload List
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor (Worksheet, String, PlotBy)

ChartForm Constructor (Worksheet, String, PlotBy)
See Also
[image]

Initializes a new instance of the ChartForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ChartForm (
Worksheet worksheet,
string dataSource,
PlotBy plotBy
)

Visual Basic [image] Copy Code

Public New ( _
worksheet As Worksheet, _
dataSource As String, _
plotBy As PlotBy _
)

Parameters

worksheet

The parent Worksheet that will contain the created chart.

dataSource

A string specifying the data source for the chart.

plotBy

A flag specifying whether the series are created from the columns or from the rows in the specified range.

See Also

ChartForm Constructor Overload List
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Constructor (Worksheet, String, PlotBy, Int32, Int32, Nullable(Boolean), Nullable(Boolean))

ChartForm Constructor (Worksheet, String, PlotBy, Int32, Int32, Nullable(Boolean), Nullable(Boolean))
See Also
[image]

Initializes a new instance of the ChartForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ChartForm (
Worksheet worksheet,
string dataSource,
PlotBy plotBy,
int column,
int row,
Nullable<Boolean> firstColumnAsLabel,
Nullable<Boolean> firstRowAsLabel
)

Visual Basic [image] Copy Code

Public New ( _
worksheet As Worksheet, _
dataSource As String, _
plotBy As PlotBy, _
column As Integer, _
row As Integer, _
firstColumnAsLabel As Nullable(Of Boolean), _
firstRowAsLabel As Nullable(Of Boolean) _
)

Parameters

worksheet

The parent Worksheet that will contain the created chart.

dataSource

A string specifying the data source for the chart.

plotBy

A flag specifying whether the series are created from the columns or from the rows in the specified range.

column

The column at which to place the newly created chart at.

row

The row at which to place the newly created chart at.

firstColumnAsLabel

A flag specifying whether to use the values in the first column of the specified range as labels, or null (Nothing in Visual Basic), to attempt to automatically determine this based on the type of the data. This parameter is ignored by some charts that do not display labels.

firstRowAsLabel

A flag specifying whether to use the values in the first row of the specified range as labels, or null (Nothing in Visual Basic), to attempt to automatically determine this based on the type of the data. This parameter is ignored by some charts that do not display labels.

See Also

ChartForm Constructor Overload List
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm Methods

ChartForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm.InitializeComponent Method

ChartForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

ChartForm Members
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ChartForm.ShowDialog Method

ChartForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

ChartForm Members
ChartForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm Class

ConditionalFormatForm Class
Remarks See Also
[image]

A form which can be used to define conditional formats for cells within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class ConditionalFormatForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class ConditionalFormatForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to add, edit, and remove conditional formats for a cell or a range of cells. To use the form, create an instance of the ConditionalFormatForm class, by providing the related workbook and the IStyle object of the target cell or range of cells, and call the ShowDialog method. To apply the changes made through the form, call the Apply method. The following image shows the form:

Example

The code below demonstrates how to display the conditional format form for an existing CellRange instance.

C# [image] Copy Code

var form = new ConditionalFormatForm(workbook, cellRange.Style);
if (form.ShowDialog() == true)
{
worksheet.BeginInit();
using (workbook.StartChangeOperation(worksheet))
form.Apply(cellRange.Style);
worksheet.EndInit();
}

Visual Basic [image] Copy Code

Dim form = New ConditionalFormatForm(workbook, cellRange.Style)
If form.ShowDialog() = True Then

worksheet.BeginInit()
Using workbook.StartChangeOperation(worksheet)
form.Apply(cellRange.Style)
End Using
worksheet.EndInit()

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm

See Also

ConditionalFormatForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm Members

ConditionalFormatForm Members
Constructors Methods
[image]

A form which can be used to define conditional formats for cells within a worksheet.

The following tables list the members exposed by the ConditionalFormatForm type.

Public Constructors

Name | Description
ConditionalFormatForm | Initializes a new instance of the ConditionalFormatForm class.

Public Methods

Name | Description
Apply | Applies the conditional formats defined in the form to a target IStyle object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm Constructor

ConditionalFormatForm Constructor
[image]

Initializes a new instance of the ConditionalFormatForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ConditionalFormatForm (
Workbook workbook,
IStyle style
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
style As IStyle _
)

Parameters

workbook

The Workbook containing the predefined styles and formats used by this form.

style

The IStyle object containing the conditional formats to modify with this form.

See Also

ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm Methods

ConditionalFormatForm Methods
[image]

Public Methods

Name | Description
Apply | Applies the conditional formats defined in the form to a target IStyle object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm.Apply Method

ConditionalFormatForm.Apply Method
[image]

Applies the conditional formats defined in the form to a target IStyle object.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Apply (
IStyle target
)

Visual Basic [image] Copy Code

Public Sub Apply( _
target As IStyle _
)

Parameters

target

The target IStyle object to apply the conditional formats to, usually the same object used to initialize the form.

See Also

ConditionalFormatForm Members
ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm.InitializeComponent Method

ConditionalFormatForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

ConditionalFormatForm Members
ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ConditionalFormatForm.ShowDialog Method

ConditionalFormatForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

ConditionalFormatForm Members
ConditionalFormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Class

CsvExportForm Class
Remarks See Also
[image]

A form used to define options for CSV text data exports.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class CsvExportForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class CsvExportForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to export worksheet data to an CSV file. To use the form, create an instance of the CsvExportForm class, by specifying the name of the CSV file to export to, and call the ShowDialog method. The perform the export using the settings entered by the user, call the form's Export method and pass the worksheet to export. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm

See Also

CsvExportForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Members

CsvExportForm Members
Constructors Properties Methods Events
[image]

A form used to define options for CSV text data exports.

The following tables list the members exposed by the CsvExportForm type.

Public Constructors

Name | Description
CsvExportForm | Overloaded. Initializes a new instance of the CsvExportForm class.

Public Properties

Name | Description
Encoding | Gets or sets the encoding that will be used by the exporter.
Quote | Gets or sets the character that will be used as a separator by the exporter.
Separator | Gets or sets the character that will be used as a separator by the exporter.

Public Methods

Name | Description
Export | Exports the data from the specified worksheet.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Constructor

CsvExportForm Constructor
[image]

Initializes a new instance of the CsvExportForm class.

Overload List

Name | Description
CsvExportForm (Workbook, String) | Initializes a new instance of the CsvExportForm class.
CsvExportForm (Workbook, String, Char, Char) | Initializes a new instance of the CsvExportForm class.
CsvExportForm (Workbook, String, Char, Char, Encoding) | Initializes a new instance of the CsvExportForm class.

See Also

CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Constructor (Workbook, String)

CsvExportForm Constructor (Workbook, String)
See Also
[image]

Initializes a new instance of the CsvExportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvExportForm (
Workbook workbook,
string filePath
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

A string object specifying the path to the .csv file.

See Also

CsvExportForm Constructor Overload List
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Constructor (Workbook, String, Char, Char)

CsvExportForm Constructor (Workbook, String, Char, Char)
See Also
[image]

Initializes a new instance of the CsvExportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvExportForm (
Workbook workbook,
string filePath,
char quoteDelimiter,
char separator
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String, _
quoteDelimiter As Char, _
separator As Char _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

A string object specifying the path to the .csv file.

quoteDelimiter

The character to use as quote.

separator

The character to use as separator.

See Also

CsvExportForm Constructor Overload List
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Constructor (Workbook, String, Char, Char, Encoding)

CsvExportForm Constructor (Workbook, String, Char, Char, Encoding)
See Also
[image]

Initializes a new instance of the CsvExportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvExportForm (
Workbook workbook,
string filePath,
char quoteDelimiter,
char separator,
Encoding encoding
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String, _
quoteDelimiter As Char, _
separator As Char, _
encoding As Encoding _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

A string object specifying the path to the .csv file.

quoteDelimiter

The character to use as quote.

separator

The character to use as separator.

encoding

The encoding to use.

See Also

CsvExportForm Constructor Overload List
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Methods

CsvExportForm Methods
[image]

Public Methods

Name | Description
Export | Exports the data from the specified worksheet.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

See Also

CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.Export Method

CsvExportForm.Export Method
[image]

Exports the data from the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Export (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Sub Export( _
worksheet As Worksheet _
)

Parameters

worksheet

The Worksheet instance containing the data to export.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.InitializeComponent Method

CsvExportForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.OnClosing Method

CsvExportForm.OnClosing Method
[image]

Window.OnClosing override.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

protected override void OnClosing (
CancelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnClosing( _
e As CancelEventArgs _
)

Parameters

e

An object that contains the event data.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.ShowDialog Method

CsvExportForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Properties

CsvExportForm Properties
[image]

Public Properties

Name | Description
Encoding | Gets or sets the encoding that will be used by the exporter.
Quote | Gets or sets the character that will be used as a separator by the exporter.
Separator | Gets or sets the character that will be used as a separator by the exporter.

See Also

CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.Encoding Property

CsvExportForm.Encoding Property
[image]

Gets or sets the encoding that will be used by the exporter.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Encoding Encoding { get; set; }

Visual Basic [image] Copy Code

Public Property Encoding As Encoding

Property Value

An instance of the .NET Encoding class.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.Quote Property

CsvExportForm.Quote Property
[image]

Gets or sets the character that will be used as a separator by the exporter.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public char Quote { get; set; }

Visual Basic [image] Copy Code

Public Property Quote As Char

Property Value

A character value.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.Separator Property

CsvExportForm.Separator Property
[image]

Gets or sets the character that will be used as a separator by the exporter.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public char Separator { get; set; }

Visual Basic [image] Copy Code

Public Property Separator As Char

Property Value

A character value.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm Events

CsvExportForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvExportForm.PropertyChanged Event

CsvExportForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

CsvExportForm Members
CsvExportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Class

CsvImportForm Class
Remarks See Also
[image]

A form used to define options for CSV text data imports.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class CsvImportForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class CsvImportForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to import data from an CSV file. The form provides control over the import settings as well as preview of the imported data. To use the form, create an instance of the CsvImportForm class, by specifying the name of the CSV file to import, and call the ShowDialog method. The data can be subsequently imported in a worksheet by calling the form's Import method. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm

See Also

CsvImportForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Members

CsvImportForm Members
Constructors Properties Methods Events
[image]

A form used to define options for CSV text data imports.

The following tables list the members exposed by the CsvImportForm type.

Public Constructors

Name | Description
CsvImportForm | Overloaded. Initializes a new instance of the CsvImportForm class.

Public Properties

Name | Description
Encoding | Gets or sets the encoding that will be used by the importer.
Quote | Gets or sets the character that will be used as a quote by the importer.
Separator | Gets or sets the character that will be used as a separator by the importer.

Public Methods

Name | Description
Import | Imports the data into the specified worksheet.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Constructor

CsvImportForm Constructor
[image]

Initializes a new instance of the CsvImportForm class.

Overload List

Name | Description
CsvImportForm (Workbook, String) | Initializes a new instance of the CsvImportForm class.
CsvImportForm (Workbook, String, Char, Char) | Initializes a new instance of the CsvImportForm class.
CsvImportForm (Workbook, String, Char, Char, Encoding) | Initializes a new instance of the CsvImportForm class.

See Also

CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Constructor (Workbook, String)

CsvImportForm Constructor (Workbook, String)
See Also
[image]

Initializes a new instance of the CsvImportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvImportForm (
Workbook workbook,
string filePath
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

The string object specifying the path to the .csv file.

See Also

CsvImportForm Constructor Overload List
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Constructor (Workbook, String, Char, Char)

CsvImportForm Constructor (Workbook, String, Char, Char)
See Also
[image]

Initializes a new instance of the CsvImportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvImportForm (
Workbook workbook,
string filePath,
char quoteDelimiter,
char separator
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String, _
quoteDelimiter As Char, _
separator As Char _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

The string object specifying the path to the .csv file.

quoteDelimiter

The character to use as quote.

separator

The character to use as separator.

See Also

CsvImportForm Constructor Overload List
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Constructor (Workbook, String, Char, Char, Encoding)

CsvImportForm Constructor (Workbook, String, Char, Char, Encoding)
See Also
[image]

Initializes a new instance of the CsvImportForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CsvImportForm (
Workbook workbook,
string filePath,
char quoteDelimiter,
char separator,
Encoding encoding
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
filePath As String, _
quoteDelimiter As Char, _
separator As Char, _
encoding As Encoding _
)

Parameters

workbook

The workbook that should provide localization info.

filePath

The string object specifying the path to the .csv file.

quoteDelimiter

The character to use as quote.

separator

The character to use as separator.

encoding

See Also

CsvImportForm Constructor Overload List
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Methods

CsvImportForm Methods
[image]

Public Methods

Name | Description
Import | Imports the data into the specified worksheet.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.Import Method

CsvImportForm.Import Method
[image]

Imports the data into the specified worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Import (
Worksheet worksheet
)

Visual Basic [image] Copy Code

Public Sub Import( _
worksheet As Worksheet _
)

Parameters

worksheet

The Worksheet instance where to import the data.

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.InitializeComponent Method

CsvImportForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.ShowDialog Method

CsvImportForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Properties

CsvImportForm Properties
[image]

Public Properties

Name | Description
Encoding | Gets or sets the encoding that will be used by the importer.
Quote | Gets or sets the character that will be used as a quote by the importer.
Separator | Gets or sets the character that will be used as a separator by the importer.

See Also

CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.Encoding Property

CsvImportForm.Encoding Property
[image]

Gets or sets the encoding that will be used by the importer.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Encoding Encoding { get; set; }

Visual Basic [image] Copy Code

Public Property Encoding As Encoding

Property Value

An instance of the .NET Encoding class. The default is Encoding.Default.

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.Quote Property

CsvImportForm.Quote Property
[image]

Gets or sets the character that will be used as a quote by the importer.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public char Quote { get; set; }

Visual Basic [image] Copy Code

Public Property Quote As Char

Property Value

A character value. The default is double quotes (").

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.Separator Property

CsvImportForm.Separator Property
[image]

Gets or sets the character that will be used as a separator by the importer.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public char Separator { get; set; }

Visual Basic [image] Copy Code

Public Property Separator As Char

Property Value

A character value. The default is comma (,).

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm Events

CsvImportForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.CsvImportForm.PropertyChanged Event

CsvImportForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

CsvImportForm Members
CsvImportForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Class

DefineNamedRangeForm Class
Remarks See Also
[image]

Prompts the user to define a named range for a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class DefineNamedRangeForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class DefineNamedRangeForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to add a NamedRange object to a workbook. To use the form, create an instance of the DefineNamedRangeForm class by providing the related worksheet, and call the ShowDialog method. The NamedRange object specified in the form can be accessed through the NamedRange property. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm

See Also

DefineNamedRangeForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Members

DefineNamedRangeForm Members
Constructors Properties Methods
[image]

Prompts the user to define a named range for a worksheet.

The following tables list the members exposed by the DefineNamedRangeForm type.

Public Constructors

Name | Description
DefineNamedRangeForm | Overloaded. Initializes a new instance of the DefineNamedRangeForm class.

Public Properties

Name | Description
NamedRange | Gets the newly defined named range.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Constructor

DefineNamedRangeForm Constructor
[image]

Initializes a new instance of the DefineNamedRangeForm class.

Overload List

Name | Description
DefineNamedRangeForm (Workbook, Worksheet, String, CellRange) | Initializes a new instance of the DefineNamedRangeForm class.
DefineNamedRangeForm (Workbook, Worksheet, String, Int32, Int32, Int32, Int32) | Initializes a new instance of the DefineNamedRangeForm class.
DefineNamedRangeForm (Workbook, Worksheet, String, String) | Initializes a new instance of the DefineNamedRangeForm class.

See Also

DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Constructor (Workbook, Worksheet, String, CellRange)

DefineNamedRangeForm Constructor (Workbook, Worksheet, String, CellRange)
See Also
[image]

Initializes a new instance of the DefineNamedRangeForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DefineNamedRangeForm (
Workbook workbook,
Worksheet worksheet,
string name,
CellRange range
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
worksheet As Worksheet, _
name As String, _
range As CellRange _
)

Parameters

workbook

The workbook that should provide localization info.

worksheet

The worksheet for which the named range will be defined.

name

The initial name of the range to define.

range

The initial cell range.

See Also

DefineNamedRangeForm Constructor Overload List
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Constructor (Workbook, Worksheet, String, Int32, Int32, Int32, Int32)

DefineNamedRangeForm Constructor (Workbook, Worksheet, String, Int32, Int32, Int32, Int32)
See Also
[image]

Initializes a new instance of the DefineNamedRangeForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DefineNamedRangeForm (
Workbook workbook,
Worksheet worksheet,
string name,
int topLeftColumn,
int topLeftRow,
int bottomRightColumn,
int bottomRightRow
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
worksheet As Worksheet, _
name As String, _
topLeftColumn As Integer, _
topLeftRow As Integer, _
bottomRightColumn As Integer, _
bottomRightRow As Integer _
)

Parameters

workbook

The workbook that should provide localization info.

worksheet

The worksheet for which the named range will be defined.

name

The initial name of the range to define.

topLeftColumn

The column of the top-left cell of the initial range.

topLeftRow

The row of the top-left cell of the initial range.

bottomRightColumn

The column of the bottom-right cell of the initial range.

bottomRightRow

The row of the bottom-right cell of the initial range.

See Also

DefineNamedRangeForm Constructor Overload List
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Constructor (Workbook, Worksheet, String, String)

DefineNamedRangeForm Constructor (Workbook, Worksheet, String, String)
See Also
[image]

Initializes a new instance of the DefineNamedRangeForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DefineNamedRangeForm (
Workbook workbook,
Worksheet worksheet,
string name,
string range
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
worksheet As Worksheet, _
name As String, _
range As String _
)

Parameters

workbook

The workbook that should provide localization info.

worksheet

The worksheet for which the named range will be defined.

name

The initial name of the range to define.

range

The initial cell range.

See Also

DefineNamedRangeForm Constructor Overload List
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Methods

DefineNamedRangeForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm.InitializeComponent Method

DefineNamedRangeForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

DefineNamedRangeForm Members
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm.ShowDialog Method

DefineNamedRangeForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

DefineNamedRangeForm Members
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm Properties

DefineNamedRangeForm Properties
[image]

Public Properties

Name | Description
NamedRange | Gets the newly defined named range.

See Also

DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DefineNamedRangeForm.NamedRange Property

DefineNamedRangeForm.NamedRange Property
[image]

Gets the newly defined named range.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public NamedRange NamedRange { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NamedRange As NamedRange

Property Value

An instance of the NamedRange class.

See Also

DefineNamedRangeForm Members
DefineNamedRangeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Class

DeleteCellsForm Class
Remarks See Also
[image]

Prompts the user to insert cells within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class DeleteCellsForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class DeleteCellsForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user to delete cells from a worksheet. To use the form, create an instance of the DeleteCellsForm class and call the ShowDialog method. The user's choice can be obtained from the Result property. The following image shows the form:

Example

The code below demonstrates how to use the form to delete cells in an existing cell range.

C# [image] Copy Code

var form = new DeleteCellsForm();
if (form.ShowDialog() == true)
{
using (workbook.StartChangeOperation(worksheet))
{
switch (form.Result)
{

case CellsFormResult.ShiftVertical:
cellRange.Remove(ShiftDirection.Up);
break;

case CellsFormResult.ShiftHorizontal:
cellRange.Remove(ShiftDirection.Left);
break;

case CellsFormResult.EntireRow:
worksheet.Rows.Remove(cellRange.Top, 1 + Math.Abs(cellRange.Top - cellRange.Bottom));
break;

case CellsFormResult.EntireColumn:
worksheet.Columns.Remove(cellRange.Left, 1 + Math.Abs(cellRange.Right - cellRange.Left));
break;

}
}
}

Visual Basic [image] Copy Code

Dim form = New DeleteCellsForm()
If form.ShowDialog() = True Then

Using workbook.StartChangeOperation(worksheet)

Select Case form.Result

Case CellsFormResult.ShiftVertical
cellRange.Remove(ShiftDirection.Up)
Exit Select

Case CellsFormResult.ShiftHorizontal
cellRange.Remove(ShiftDirection.Left)
Exit Select

Case CellsFormResult.EntireRow
worksheet.Rows.Remove(cellRange.Top, 1 + Math.Abs(cellRange.Top - cellRange.Bottom))
Exit Select

Case CellsFormResult.EntireColumn
worksheet.Columns.Remove(cellRange.Left, 1 + Math.Abs(cellRange.Right - cellRange.Left))
Exit Select

End Select

End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm

See Also

DeleteCellsForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Members

DeleteCellsForm Members
Constructors Properties Methods Events
[image]

Prompts the user to insert cells within a worksheet.

The following tables list the members exposed by the DeleteCellsForm type.

Public Constructors

Name | Description
DeleteCellsForm | Initializes a new instance of the DeleteCellsForm class.

Public Properties

Name | Description
Result | Gets the type of operation to perform.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Constructor

DeleteCellsForm Constructor
[image]

Initializes a new instance of the DeleteCellsForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public DeleteCellsForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook that should provide localization info.

See Also

DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Methods

DeleteCellsForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm.InitializeComponent Method

DeleteCellsForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

DeleteCellsForm Members
DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm.ShowDialog Method

DeleteCellsForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

DeleteCellsForm Members
DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Properties

DeleteCellsForm Properties
[image]

Public Properties

Name | Description
Result | Gets the type of operation to perform.

See Also

DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm.Result Property

DeleteCellsForm.Result Property
[image]

Gets the type of operation to perform.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CellsFormResult Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As CellsFormResult

Property Value

A member of the CellsFormResult enumeration.

See Also

DeleteCellsForm Members
DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm Events

DeleteCellsForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.DeleteCellsForm.PropertyChanged Event

DeleteCellsForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

DeleteCellsForm Members
DeleteCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Class

FillSeriesForm Class
Remarks See Also
[image]

A form which can be used to specify fill patterns for filling cell ranges with data.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class FillSeriesForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class FillSeriesForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user for information about filling worksheet cells with data. To use the form, create an instance of the FillSeriesForm class by providing the target cell range, and call the ShowDialog method. The user's choice can be obtained from the FillType, FillDirection, FillDate, FillStep, FillStop, and FillTrend properties. The following image shows the form:

Example

The code below demonstrates how to use the form to fill the cells in an existing worksheet with data.

C# [image] Copy Code

var form = new FillSeriesForm(cellRange);
if (form.ShowDialog(this) == true)
{
cellRange.FillData(form.FillType, form.FillDirection,
form.FillDate, form.FillStep, form.FillStop, form.FillTrend);
}

Visual Basic [image] Copy Code

Dim form = New FillSeriesForm(cellRange)
If form.ShowDialog(Me) = True Then

cellRange.FillData(form.FillType, form.FillDirection,
form.FillDate, form.FillStep, form.FillStop, form.FillTrend)

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm

See Also

FillSeriesForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Members

FillSeriesForm Members
Constructors Properties Methods Events
[image]

A form which can be used to specify fill patterns for filling cell ranges with data.

The following tables list the members exposed by the FillSeriesForm type.

Public Constructors

Name | Description
FillSeriesForm | Overloaded. Initializes a new instance of the FillSeriesForm class.

Public Properties

Name | Description
FillDate | Gets the date component to increment when filling dates.
FillDirection | Gets the direction of a data fill operation.
FillStep | Gets the increment step.
FillStop | Gets the fill restriction.
FillTrend | Gets the flag indicating whether to use linear or growth trend.
FillType | Gets the method used to fill series of cells.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Constructor

FillSeriesForm Constructor
[image]

Initializes a new instance of the FillSeriesForm class.

Overload List

Name | Description
FillSeriesForm (Workbook) | Initializes a new instance of the FillSeriesForm class.
FillSeriesForm (Workbook, CellRange) | Initializes a new instance of the FillSeriesForm class.

See Also

FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Constructor (Workbook)

FillSeriesForm Constructor (Workbook)
See Also
[image]

Initializes a new instance of the FillSeriesForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FillSeriesForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook that should provide localization info.

See Also

FillSeriesForm Constructor Overload List
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Constructor (Workbook, CellRange)

FillSeriesForm Constructor (Workbook, CellRange)
See Also
[image]

Initializes a new instance of the FillSeriesForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FillSeriesForm (
Workbook workbook,
CellRange range
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
range As CellRange _
)

Parameters

workbook

The workbook that should provide localization info.

range

The CellRange object that will be filled.

See Also

FillSeriesForm Constructor Overload List
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Methods

FillSeriesForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.InitializeComponent Method

FillSeriesForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.ShowDialog Method

FillSeriesForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Properties

FillSeriesForm Properties
[image]

Public Properties

Name | Description
FillDate | Gets the date component to increment when filling dates.
FillDirection | Gets the direction of a data fill operation.
FillStep | Gets the increment step.
FillStop | Gets the fill restriction.
FillTrend | Gets the flag indicating whether to use linear or growth trend.
FillType | Gets the method used to fill series of cells.

See Also

FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillDate Property

FillSeriesForm.FillDate Property
[image]

Gets the date component to increment when filling dates.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FillDate FillDate { get; set; }

Visual Basic [image] Copy Code

Public Property FillDate As FillDate

Property Value

A member of the FillDate enumeration.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillDirection Property

FillSeriesForm.FillDirection Property
[image]

Gets the direction of a data fill operation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FillDirection FillDirection { get; set; }

Visual Basic [image] Copy Code

Public Property FillDirection As FillDirection

Property Value

A member of the FillDirection enumeration.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillStep Property

FillSeriesForm.FillStep Property
[image]

Gets the increment step.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public double FillStep { get; set; }

Visual Basic [image] Copy Code

Public Property FillStep As Double

Property Value

A double value.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillStop Property

FillSeriesForm.FillStop Property
[image]

Gets the fill restriction.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Double> FillStop { get; set; }

Visual Basic [image] Copy Code

Public Property FillStop As Nullable(Of Double)

Property Value

A double value or null (Nothing in Visual Basic) to indicate no restriction.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillTrend Property

FillSeriesForm.FillTrend Property
[image]

Gets the flag indicating whether to use linear or growth trend.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public bool FillTrend { get; set; }

Visual Basic [image] Copy Code

Public Property FillTrend As Boolean

Property Value

true if the Trend checkbox is selected; otherwise, false.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.FillType Property

FillSeriesForm.FillType Property
[image]

Gets the method used to fill series of cells.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FillType FillType { get; set; }

Visual Basic [image] Copy Code

Public Property FillType As FillType

Property Value

A member of the FillType enumeration.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm Events

FillSeriesForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FillSeriesForm.PropertyChanged Event

FillSeriesForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

FillSeriesForm Members
FillSeriesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Class

FindReplaceForm Class
Remarks See Also
[image]

Represents a form that can be used to find and/or replace texts matching a specified criteria.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class FindReplaceForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class FindReplaceForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

To use the form, create an instance of the FindReplaceForm class, providing the workbook to search and the cell to start the search from, and call the ShowDialog method. The various options can be get or set through the respective form properties - Find, Replace, FindWithin, SearchOrder, LookIn, MatchCase, WholeCells. When the user clicks the Find or Replace buttons, if there is a found cell, the form raises the CellFound event. When the user performs a multiple search and clicks on any of the entries in the result list, the form raises the CellActivated event. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm

See Also

FindReplaceForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Members

FindReplaceForm Members
Constructors Properties Methods Events
[image]

Represents a form that can be used to find and/or replace texts matching a specified criteria.

The following tables list the members exposed by the FindReplaceForm type.

Public Constructors

Name | Description
FindReplaceForm | Initializes a new instance of the FindReplaceForm class.

Public Properties

Name | Description
CurrentCell | Gets or set the cell to start the search from.
Find | Gets or sets the text to find.
FindWithin | Gets or sets the target of the search - the referenced worksheet or the entire workbook.
LookIn | Gets or sets the search order - horizontal or vertical.
MatchCase | Gets or sets a value indicating whether the search should be case-sensitive.
Replace | Gets or sets the text to replace with.
SearchOrder | Gets or sets a value specifying whether to search in the cell's formula or value.
WholeCells | Gets or sets a value indicating whether to match entire cells only.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnCellActivated | Raises the CellActivated event.
OnCellFound | Raises the CellFound event.

Public Events

Name | Description
CellActivated | Raised when the user clicks on an entry in the result list.
CellFound | Raised when the user finds a cell.
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Constructor

FindReplaceForm Constructor
[image]

Initializes a new instance of the FindReplaceForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FindReplaceForm (
Workbook workbook,
Cell currentCell
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
currentCell As Cell _
)

Parameters

workbook

The workbook to operate on.

currentCell

The cell to start the search from.

See Also

FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Methods

FindReplaceForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnCellActivated | Raises the CellActivated event.
OnCellFound | Raises the CellFound event.

See Also

FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.InitializeComponent Method

FindReplaceForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.OnCellActivated Method

FindReplaceForm.OnCellActivated Method
[image]

Raises the CellActivated event.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

protected virtual void OnCellActivated (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellActivated( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.OnCellFound Method

FindReplaceForm.OnCellFound Method
[image]

Raises the CellFound event.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

protected virtual void OnCellFound (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellFound( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.ShowDialog Method

FindReplaceForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Properties

FindReplaceForm Properties
[image]

Public Properties

Name | Description
CurrentCell | Gets or set the cell to start the search from.
Find | Gets or sets the text to find.
FindWithin | Gets or sets the target of the search - the referenced worksheet or the entire workbook.
LookIn | Gets or sets the search order - horizontal or vertical.
MatchCase | Gets or sets a value indicating whether the search should be case-sensitive.
Replace | Gets or sets the text to replace with.
SearchOrder | Gets or sets a value specifying whether to search in the cell's formula or value.
WholeCells | Gets or sets a value indicating whether to match entire cells only.

See Also

FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.CurrentCell Property

FindReplaceForm.CurrentCell Property
[image]

Gets or set the cell to start the search from.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Cell CurrentCell { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentCell As Cell

Property Value

An instance of the Cell class.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.Find Property

FindReplaceForm.Find Property
[image]

Gets or sets the text to find.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string Find { get; set; }

Visual Basic [image] Copy Code

Public Property Find As String

Property Value

A string value.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.FindWithin Property

FindReplaceForm.FindWithin Property
[image]

Gets or sets the target of the search - the referenced worksheet or the entire workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FindWithin FindWithin { get; set; }

Visual Basic [image] Copy Code

Public Property FindWithin As FindWithin

Property Value

A member of the FindWithin enumeration.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.LookIn Property

FindReplaceForm.LookIn Property
[image]

Gets or sets the search order - horizontal or vertical.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public LookIn LookIn { get; set; }

Visual Basic [image] Copy Code

Public Property LookIn As LookIn

Property Value

A member of the LookIn enumeration.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.MatchCase Property

FindReplaceForm.MatchCase Property
[image]

Gets or sets a value indicating whether the search should be case-sensitive.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public bool MatchCase { get; set; }

Visual Basic [image] Copy Code

Public Property MatchCase As Boolean

Property Value

A boolean value.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.Replace Property

FindReplaceForm.Replace Property
[image]

Gets or sets the text to replace with.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string Replace { get; set; }

Visual Basic [image] Copy Code

Public Property Replace As String

Property Value

A string value.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.SearchOrder Property

FindReplaceForm.SearchOrder Property
[image]

Gets or sets a value specifying whether to search in the cell's formula or value.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public SearchOrder SearchOrder { get; set; }

Visual Basic [image] Copy Code

Public Property SearchOrder As SearchOrder

Property Value

A member of the SearchOrder enumeration.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.WholeCells Property

FindReplaceForm.WholeCells Property
[image]

Gets or sets a value indicating whether to match entire cells only.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public bool WholeCells { get; set; }

Visual Basic [image] Copy Code

Public Property WholeCells As Boolean

Property Value

A boolean value.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm Events

FindReplaceForm Events
[image]

Public Events

Name | Description
CellActivated | Raised when the user clicks on an entry in the result list.
CellFound | Raised when the user finds a cell.
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.CellActivated Event

FindReplaceForm.CellActivated Event
[image]

Raised when the user clicks on an entry in the result list.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellActivated

Visual Basic [image] Copy Code

Public Event CellActivated As EventHandler(Of CellEventArgs)

Event Data

CellActivated event handlers receive an argument of type CellEventArgs.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.CellFound Event

FindReplaceForm.CellFound Event
[image]

Raised when the user finds a cell.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellFound

Visual Basic [image] Copy Code

Public Event CellFound As EventHandler(Of CellEventArgs)

Event Data

CellFound event handlers receive an argument of type CellEventArgs.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FindReplaceForm.PropertyChanged Event

FindReplaceForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

FindReplaceForm Members
FindReplaceForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Class

FontPickerForm Class
Remarks See Also
[image]

Represents a dialog which can be used to specify font styles within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class FontPickerForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class FontPickerForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to select fonts within a worksheet. To use the form, create an instance of the FontPickerForm class, by optionally providing the IStyle that should be used to initialize the form, and call the ShowDialog method. To get the user's choice, use the FontName, FontSize, Bold, Italic, Underline, Strikeout and TextBrush properties. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm

See Also

FontPickerForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Members

FontPickerForm Members
Constructors Properties Methods
[image]

Represents a dialog which can be used to specify font styles within a worksheet.

The following tables list the members exposed by the FontPickerForm type.

Public Constructors

Name | Description
FontPickerForm | Overloaded. Initializes a new instance of the FontPickerForm class.

Public Properties

Name | Description
Bold | Gets whether the font style uses bold.
FontName | Gets the font name.
FontSize | Gets the font size.
Italic | Gets whether the font style uses italic.
Strikeout | Gets whether the font style uses strikeout.
TextBrush | Gets the text color.
Underline | Gets whether the font style uses underline.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Constructor

FontPickerForm Constructor
[image]

Initializes a new instance of the FontPickerForm class.

Overload List

Name | Description
FontPickerForm (Workbook) | Initializes a new instance of the FontPickerForm class.
FontPickerForm (Workbook, IStyle) | Initializes a new instance of the FontPickerForm class.
FontPickerForm (Workbook, String, Nullable(Double), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Brush) | Initializes a new instance of the FontPickerForm class.

See Also

FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Constructor (Workbook)

FontPickerForm Constructor (Workbook)
See Also
[image]

Initializes a new instance of the FontPickerForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FontPickerForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook that should provide localization info.

See Also

FontPickerForm Constructor Overload List
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Constructor (Workbook, IStyle)

FontPickerForm Constructor (Workbook, IStyle)
See Also
[image]

Initializes a new instance of the FontPickerForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FontPickerForm (
Workbook workbook,
IStyle style
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
style As IStyle _
)

Parameters

workbook

style

The style to use to initialize the form.

See Also

FontPickerForm Constructor Overload List
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Constructor (Workbook, String, Nullable(Double), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Brush)

FontPickerForm Constructor (Workbook, String, Nullable(Double), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Nullable(Boolean), Brush)
See Also
[image]

Initializes a new instance of the FontPickerForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FontPickerForm (
Workbook workbook,
string name,
Nullable<Double> size,
Nullable<Boolean> bold,
Nullable<Boolean> italic,
Nullable<Boolean> underline,
Nullable<Boolean> strikeout,
Brush color
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
name As String, _
size As Nullable(Of Double), _
bold As Nullable(Of Boolean), _
italic As Nullable(Of Boolean), _
underline As Nullable(Of Boolean), _
strikeout As Nullable(Of Boolean), _
color As Brush _
)

Parameters

workbook

name

The initial font name displayed in the form.

size

The initial font size displayed in the form.

bold

The initial value of the bold check box.

italic

The initial value of the italic check box.

underline

The initial value of the underline check box.

strikeout

The initial value of the strikeout check box.

color

The initial text color displayed in the form.

See Also

FontPickerForm Constructor Overload List
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Methods

FontPickerForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.InitializeComponent Method

FontPickerForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.ShowDialog Method

FontPickerForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm Properties

FontPickerForm Properties
[image]

Public Properties

Name | Description
Bold | Gets whether the font style uses bold.
FontName | Gets the font name.
FontSize | Gets the font size.
Italic | Gets whether the font style uses italic.
Strikeout | Gets whether the font style uses strikeout.
TextBrush | Gets the text color.
Underline | Gets whether the font style uses underline.

See Also

FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.Bold Property

FontPickerForm.Bold Property
[image]

Gets whether the font style uses bold.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> Bold { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bold As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.FontName Property

FontPickerForm.FontName Property
[image]

Gets the font name.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string FontName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FontName As String

Property Value

A string value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.FontSize Property

FontPickerForm.FontSize Property
[image]

Gets the font size.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public new Nullable<Double> FontSize { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property FontSize As Nullable(Of Double)

Property Value

A nullable double value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.Italic Property

FontPickerForm.Italic Property
[image]

Gets whether the font style uses italic.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> Italic { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Italic As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.Strikeout Property

FontPickerForm.Strikeout Property
[image]

Gets whether the font style uses strikeout.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> Strikeout { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Strikeout As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.TextBrush Property

FontPickerForm.TextBrush Property
[image]

Gets the text color.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Brush TextBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextBrush As Brush

Property Value

An instance of the Brush class.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FontPickerForm.Underline Property

FontPickerForm.Underline Property
[image]

Gets whether the font style uses underline.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> Underline { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Underline As Nullable(Of Boolean)

Property Value

A nullable boolean value.

See Also

FontPickerForm Members
FontPickerForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Class

FormatForm Class
Remarks See Also
[image]

A form which can be used to define format for cells within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class FormatForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class FormatForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to apply formatting to a cell or a range of cells. To use the form, create an instance of the FormatForm class, by providing the related workbook and the IStyle object of the target cell or range of cells, and call the ShowDialog method. To apply the changes made through the form, call the Apply method. The following image shows the form:

Example

The code below demonstrates how to use the form to format the cells identified by an existing CellRange instance.

C# [image] Copy Code

var form = new FormatForm(workbook, cellRange.Style, workbook.Locale);
if (form.ShowDialog(this) == true)
{
using (workbook.StartChangeOperation(worksheet))
form.Apply(cellRange.Style);
}

Visual Basic [image] Copy Code

Dim form = New FormatForm(workbook, cellRange.Style, workbook.Locale)
If form.ShowDialog(Me) = True Then

Using workbook.StartChangeOperation(worksheet)
form.Apply(cellRange.Style)
End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm

See Also

FormatForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Members

FormatForm Members
Constructors Properties Methods Events
[image]

A form which can be used to define format for cells within a worksheet.

The following tables list the members exposed by the FormatForm type.

Public Constructors

Name | Description
FormatForm | Overloaded. Initializes a new instance of the FormatForm class.

Public Properties

Name | Description
Locale | Gets the locale info used for the cells format.

Public Methods

Name | Description
Apply | Applies the cell formats defined in the form to a target IStyle object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Constructor

FormatForm Constructor
[image]

Initializes a new instance of the FormatForm class.

Overload List

Name | Description
FormatForm (Workbook, IStyle) | Initializes a new instance of the FormatForm class.
FormatForm (Workbook, IStyle, CultureInfo) | Initializes a new instance of the FormatForm class.

See Also

FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Constructor (Workbook, IStyle)

FormatForm Constructor (Workbook, IStyle)
See Also
[image]

Initializes a new instance of the FormatForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FormatForm (
Workbook workbook,
IStyle istyle
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
istyle As IStyle _
)

Parameters

workbook

The Workbook containing the predefined styles and formats used by this form.

istyle

The IStyle object containing the formats to modify with this form.

See Also

FormatForm Constructor Overload List
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Constructor (Workbook, IStyle, CultureInfo)

FormatForm Constructor (Workbook, IStyle, CultureInfo)
See Also
[image]

Initializes a new instance of the FormatForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public FormatForm (
Workbook workbook,
IStyle istyle,
CultureInfo locale
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
istyle As IStyle, _
locale As CultureInfo _
)

Parameters

workbook

The Workbook containing the predefined styles and formats used by this form.

istyle

The IStyle object containing the formats to modify with this form.

locale

The locale info to be used for the cells format.

See Also

FormatForm Constructor Overload List
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Methods

FormatForm Methods
[image]

Public Methods

Name | Description
Apply | Applies the cell formats defined in the form to a target IStyle object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm.Apply Method

FormatForm.Apply Method
[image]

Applies the cell formats defined in the form to a target IStyle object.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Apply (
IStyle target
)

Visual Basic [image] Copy Code

Public Sub Apply( _
target As IStyle _
)

Parameters

target

The target IStyle object to apply the cell formats to, usually the same object used to initialize the form.

See Also

FormatForm Members
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm.InitializeComponent Method

FormatForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

FormatForm Members
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm.ShowDialog Method

FormatForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

FormatForm Members
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Properties

FormatForm Properties
[image]

Public Properties

Name | Description
Locale | Gets the locale info used for the cells format.

See Also

FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm.Locale Property

FormatForm.Locale Property
[image]

Gets the locale info used for the cells format.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CultureInfo Locale { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Locale As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

FormatForm Members
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm Events

FormatForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.FormatForm.PropertyChanged Event

FormatForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

FormatForm Members
FormatForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm Class

HeaderSizeForm Class
Remarks See Also
[image]

Represents a form that can be used to define row height or column width within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class HeaderSizeForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class HeaderSizeForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to prompt the user for the size of the column and row headers in a worksheet. To use the form, create an instance of the HeaderSizeForm class, optionally providing the title and label texts, and call the ShowDialog method. The user's choice can be obtained from the HeaderSize property. The following image shows the form:

Example

The code below demonstrates how to use the form to resize a row in an existing worksheet.

C# [image] Copy Code

var form = new HeaderSizeForm("Row Height", "Height", row.Height);
if (form.ShowDialog(this) == true)
{
using (workbook.StartChangeOperation(worksheet))
row.Height = form.HeaderSize;
}

Visual Basic [image] Copy Code

Dim form = New HeaderSizeForm("Row Height", "Height", row.Height)
If form.ShowDialog(Me) = True Then

Using workbook.StartChangeOperation(worksheet)
row.Height = form.HeaderSize
End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm

See Also

HeaderSizeForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm Members

HeaderSizeForm Members
Constructors Properties Methods
[image]

Represents a form that can be used to define row height or column width within a worksheet.

The following tables list the members exposed by the HeaderSizeForm type.

Public Constructors

Name | Description
HeaderSizeForm | Initializes a new instance of the HeaderSizeForm class.

Public Properties

Name | Description
HeaderSize | Gets the size of the header defined by the form.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm Constructor

HeaderSizeForm Constructor
[image]

Initializes a new instance of the HeaderSizeForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public HeaderSizeForm (
Workbook workbook,
string headerText,
string captionText,
Measure headerSize
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
headerText As String, _
captionText As String, _
headerSize As Measure _
)

Parameters

workbook

The workbook that should provide localization info.

headerText

The header text of the form.

captionText

The text of the caption of the form.

headerSize

The current size of the header to edit.

See Also

HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm Methods

HeaderSizeForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm.InitializeComponent Method

HeaderSizeForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

HeaderSizeForm Members
HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm.ShowDialog Method

HeaderSizeForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

HeaderSizeForm Members
HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm Properties

HeaderSizeForm Properties
[image]

Public Properties

Name | Description
HeaderSize | Gets the size of the header defined by the form.

See Also

HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HeaderSizeForm.HeaderSize Property

HeaderSizeForm.HeaderSize Property
[image]

Gets the size of the header defined by the form.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Measure HeaderSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderSize As Measure

Property Value

An instance of the Measure class.

See Also

HeaderSizeForm Members
HeaderSizeForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Class

HyperlinkForm Class
Remarks See Also
[image]

Represents a form which can be used to create and modify cell hyperlinks in a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class HyperlinkForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class HyperlinkForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user for the hyperlink information of a worksheet cell. To use the form, create an instance of the HyperlinkForm class and call the ShowDialog method. The user's choice can be obtained from the HyperlinkType, Target, SubTarget, and HyperlinkToolTip properties. The following image shows the form:

Example

The code below demonstrates how to use the form to edit the hyperlink of an existing cell.

C# [image] Copy Code

var form = new HyperlinkForm(workbook, cell.Hyperlink);
if (form.ShowDialog(this) == true)
{
using (workbook.StartChangeOperation(worksheet))
{
if (string.IsNullOrEmpty(form.Target))
{
cell.RemoveHyperlink();
}
else
{
if (cell.Hyperlink != null)
{
cell.Hyperlink.Type = form.HyperlinkType;
cell.Hyperlink.Target = form.Target;
cell.Hyperlink.SubTarget = form.SubTarget;
}
else
{
cell.SetHyperlink(form.HyperlinkType, form.Target, form.SubTarget);
}

cell.Hyperlink.ToolTip = form.HyperlinkToolTip;
}
}
}

Visual Basic [image] Copy Code

Dim form = New HyperlinkForm(workbook, cell.Hyperlink)
If form.ShowDialog(Me) = True Then

Using workbook.StartChangeOperation(worksheet)

If String.IsNullOrEmpty(form.Target) Then

cell.RemoveHyperlink()

Else

If cell.Hyperlink IsNot Nothing Then
cell.Hyperlink.Type = form.HyperlinkType
cell.Hyperlink.Target = form.Target
cell.Hyperlink.SubTarget = form.SubTarget
Else
cell.SetHyperlink(form.HyperlinkType, form.Target, form.SubTarget)
End If

cell.Hyperlink.ToolTip = form.HyperlinkToolTip

End If

End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm

See Also

HyperlinkForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Members

HyperlinkForm Members
Constructors Properties Methods Events
[image]

Represents a form which can be used to create and modify cell hyperlinks in a worksheet.

The following tables list the members exposed by the HyperlinkForm type.

Public Constructors

Name | Description
HyperlinkForm | Overloaded. Initializes a new instance of the HyperlinkForm class.

Public Properties

Name | Description
HyperlinkToolTip | Gets or sets the hyperlink tooltip.
HyperlinkType | Gets or sets the hyperlink type.
SubTarget | Gets or sets the hyperlink subtarget.
Target | Gets or sets the hyperlink target.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Constructor

HyperlinkForm Constructor
[image]

Initializes a new instance of the HyperlinkForm class.

Overload List

Name | Description
HyperlinkForm (Workbook) | Initializes a new instance of the HyperlinkForm class.
HyperlinkForm (Workbook, Hyperlink) | Initializes a new instance of the HyperlinkForm class.
HyperlinkForm (Workbook, String) | Initializes a new instance of the HyperlinkForm class.

See Also

HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Constructor (Workbook)

HyperlinkForm Constructor (Workbook)
See Also
[image]

Initializes a new instance of the HyperlinkForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public HyperlinkForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook containing the hyperlink.

See Also

HyperlinkForm Constructor Overload List
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Constructor (Workbook, Hyperlink)

HyperlinkForm Constructor (Workbook, Hyperlink)
See Also
[image]

Initializes a new instance of the HyperlinkForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public HyperlinkForm (
Workbook workbook,
Hyperlink hyperlink
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
hyperlink As Hyperlink _
)

Parameters

workbook

The workbook containing the hyperlink.

hyperlink

The hyperlink to display initially in the form, or null (Nothing in Visual Basic) to leave the form blank.

See Also

HyperlinkForm Constructor Overload List
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Constructor (Workbook, String)

HyperlinkForm Constructor (Workbook, String)
See Also
[image]

Initializes a new instance of the HyperlinkForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public HyperlinkForm (
Workbook workbook,
string target
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
target As String _
)

Parameters

workbook

The workbook containing the hyperlink.

target

The hyperlink target to use in the form.

See Also

HyperlinkForm Constructor Overload List
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Methods

HyperlinkForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

See Also

HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.InitializeComponent Method

HyperlinkForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.OnClosing Method

HyperlinkForm.OnClosing Method
[image]

Window.OnClosing override.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

protected override void OnClosing (
CancelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnClosing( _
e As CancelEventArgs _
)

Parameters

e

An object that contains the event data.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.ShowDialog Method

HyperlinkForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Properties

HyperlinkForm Properties
[image]

Public Properties

Name | Description
HyperlinkToolTip | Gets or sets the hyperlink tooltip.
HyperlinkType | Gets or sets the hyperlink type.
SubTarget | Gets or sets the hyperlink subtarget.
Target | Gets or sets the hyperlink target.

See Also

HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.HyperlinkToolTip Property

HyperlinkForm.HyperlinkToolTip Property
[image]

Gets or sets the hyperlink tooltip.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string HyperlinkToolTip { get; set; }

Visual Basic [image] Copy Code

Public Property HyperlinkToolTip As String

Property Value

A string value.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.HyperlinkType Property

HyperlinkForm.HyperlinkType Property
[image]

Gets or sets the hyperlink type.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public HyperlinkType HyperlinkType { get; set; }

Visual Basic [image] Copy Code

Public Property HyperlinkType As HyperlinkType

Property Value

A member of the HyperlinkType enumeration.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.SubTarget Property

HyperlinkForm.SubTarget Property
[image]

Gets or sets the hyperlink subtarget.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string SubTarget { get; set; }

Visual Basic [image] Copy Code

Public Property SubTarget As String

Property Value

A string value.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.Target Property

HyperlinkForm.Target Property
[image]

Gets or sets the hyperlink target.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As String

Property Value

A string value.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm Events

HyperlinkForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.HyperlinkForm.PropertyChanged Event

HyperlinkForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

HyperlinkForm Members
HyperlinkForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Class

InsertCellsForm Class
Remarks See Also
[image]

Prompts the user to insert cells within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class InsertCellsForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class InsertCellsForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user to insert cells in a worksheet. To use the form, create an instance of the InsertCellsForm class and call the ShowDialog method. The user's choice can be obtained from the Result property. The following image shows the form:

Example

The code below demonstrates how to use the form to insert cells in an existing cell range.

C# [image] Copy Code

var form = new InsertCellsForm();
if (form.ShowDialog() == true)
{
using (workbook.StartChangeOperation(worksheet))
{
switch (form.Result)
{

case CellsFormResult.ShiftVertical:
cellRange.Insert(PushDirection.Down);
break;

case CellsFormResult.ShiftHorizontal:
cellRange.Insert(PushDirection.Right);
break;

case CellsFormResult.EntireRow:
worksheet.Rows.Insert(cellRange.Top, 1 + Math.Abs(cellRange.Top - cellRange.Bottom));
break;

case CellsFormResult.EntireColumn:
worksheet.Columns.Insert(cellRange.Left, 1 + Math.Abs(cellRange.Right - cellRange.Left));
break;

}
}
}

Visual Basic [image] Copy Code

Dim form = New InsertCellsForm()
If form.ShowDialog() = DialogResult.OK Then

Using workbook.StartChangeOperation(worksheet)

Select Case form.Result
Case CellsFormResult.ShiftVertical
cellRange.Insert(PushDirection.Down)
Exit Select
Case CellsFormResult.ShiftHorizontal
cellRange.Insert(PushDirection.Right)
Exit Select
Case CellsFormResult.EntireRow
worksheet.Rows.Insert(cellRange.Top, 1 + Math.Abs(cellRange.Top - cellRange.Bottom))
Exit Select
Case CellsFormResult.EntireColumn
worksheet.Columns.Insert(cellRange.Left, 1 + Math.Abs(cellRange.Right - cellRange.Left))
Exit Select
End Select

End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm

See Also

InsertCellsForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Members

InsertCellsForm Members
Constructors Properties Methods Events
[image]

Prompts the user to insert cells within a worksheet.

The following tables list the members exposed by the InsertCellsForm type.

Public Constructors

Name | Description
InsertCellsForm | Initializes a new instance of the InsertCellsForm class.

Public Properties

Name | Description
Result | Gets the type of insert operation to perform.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Constructor

InsertCellsForm Constructor
[image]

Initializes a new instance of the InsertCellsForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public InsertCellsForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook that should provide localization info.

See Also

InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Methods

InsertCellsForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm.InitializeComponent Method

InsertCellsForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

InsertCellsForm Members
InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm.ShowDialog Method

InsertCellsForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

InsertCellsForm Members
InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Properties

InsertCellsForm Properties
[image]

Public Properties

Name | Description
Result | Gets the type of insert operation to perform.

See Also

InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm.Result Property

InsertCellsForm.Result Property
[image]

Gets the type of insert operation to perform.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public CellsFormResult Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As CellsFormResult

Property Value

A member of the CellsFormResult enumeration.

See Also

InsertCellsForm Members
InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm Events

InsertCellsForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertCellsForm.PropertyChanged Event

InsertCellsForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

InsertCellsForm Members
InsertCellsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Class

InsertWorksheetForm Class
Remarks See Also
[image]

Prompts the user to insert worksheets within a workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class InsertWorksheetForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class InsertWorksheetForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user to insert new sheets in a workbook. To use the form, create an instance of the InsertWorksheetForm class by providing the related workbook and call the ShowDialog method. The user's choice can be obtained from the Position, Index, NumberOfSheets, and SheetName properties. The following image shows the form:

Example

The code below demonstrates how to use the form to insert worksheets in an existing workbook. The activeSheet variable identifies the Worksheet that is currently active in the view.

C# [image] Copy Code

var form = new InsertWorksheetForm(workbook);
if (form.ShowDialog(this) == true)
{
using (workbook.StartCompositeOperation())
{
int index = -1;
switch (form.Position)
{

case InsertWorksheetPosition.AfterActiveSheet:
index = workbook.Worksheets.IndexOf(activeSheet) + 1;
break;

case InsertWorksheetPosition.BeforeActiveSheet:
index = workbook.Worksheets.IndexOf(activeSheet);
break;

case InsertWorksheetPosition.Other:
index = form.Index;
break;

}

if (form.NumberOfSheets == 1)
{
workbook.Worksheets.Insert(index, form.SheetName);
}
else
{
for (int i = 0; i < form.NumberOfSheets; i++)
workbook.Worksheets.Insert(index++);
}
}
}

Visual Basic [image] Copy Code

Dim form = New InsertWorksheetForm(workbook)
If form.ShowDialog(Me) = True Then

Using workbook.StartCompositeOperation()

Dim index As Integer = -1
Select Case form.Position

Case InsertWorksheetPosition.AfterActiveSheet
index = workbook.Worksheets.IndexOf(activeSheet) + 1
Exit Select

Case InsertWorksheetPosition.BeforeActiveSheet
index = workbook.Worksheets.IndexOf(activeSheet)
Exit Select

Case InsertWorksheetPosition.Other
index = form.Index
Exit Select

End Select

If form.NumberOfSheets = 1 Then
workbook.Worksheets.Insert(index, form.SheetName)
Else
For i As Integer = 0 To form.NumberOfSheets - 1
workbook.Worksheets.Insert(index)
index = index + 1
Next
End If

End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm

See Also

InsertWorksheetForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Members

InsertWorksheetForm Members
Constructors Properties Methods Events
[image]

Prompts the user to insert worksheets within a workbook.

The following tables list the members exposed by the InsertWorksheetForm type.

Public Constructors

Name | Description
InsertWorksheetForm | Initializes a new instance of the InsertWorksheetForm class.

Public Properties

Name | Description
Index | Gets or sets the index at which to insert the new worksheet(s).
NumberOfSheets | Gets or sets the number of worksheets to be added to the workbook.
Position | Gets or sets the position of the new worksheet(s) within the workbook.
SheetName | Gets or sets the name of the new worksheet.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Constructor

InsertWorksheetForm Constructor
[image]

Initializes a new instance of the InsertWorksheetForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public InsertWorksheetForm (
Workbook workbook
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook _
)

Parameters

workbook

The workbook to add the worksheet(s) to.

See Also

InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Methods

InsertWorksheetForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.InitializeComponent Method

InsertWorksheetForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.ShowDialog Method

InsertWorksheetForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Properties

InsertWorksheetForm Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index at which to insert the new worksheet(s).
NumberOfSheets | Gets or sets the number of worksheets to be added to the workbook.
Position | Gets or sets the position of the new worksheet(s) within the workbook.
SheetName | Gets or sets the name of the new worksheet.

See Also

InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.Index Property

InsertWorksheetForm.Index Property
[image]

Gets or sets the index at which to insert the new worksheet(s).

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

Remarks

Only used when the Position is set to InsertWorksheetPosition.Other.

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.NumberOfSheets Property

InsertWorksheetForm.NumberOfSheets Property
[image]

Gets or sets the number of worksheets to be added to the workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public int NumberOfSheets { get; set; }

Visual Basic [image] Copy Code

Public Property NumberOfSheets As Integer

Property Value

An integer value.

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.Position Property

InsertWorksheetForm.Position Property
[image]

Gets or sets the position of the new worksheet(s) within the workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public InsertWorksheetPosition Position { get; set; }

Visual Basic [image] Copy Code

Public Property Position As InsertWorksheetPosition

Property Value

A member of the InsertWorksheetPosition enumeration.

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.SheetName Property

InsertWorksheetForm.SheetName Property
[image]

Gets or sets the name of the new worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string SheetName { get; set; }

Visual Basic [image] Copy Code

Public Property SheetName As String

Property Value

A string value.

Remarks

Only used when the specified number of sheets in the form is 1.

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm Events

InsertWorksheetForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetForm.PropertyChanged Event

InsertWorksheetForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

InsertWorksheetForm Members
InsertWorksheetForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.InsertWorksheetPosition Enumeration

InsertWorksheetPosition Enumeration
[image]

Specifies identifiers to indicate the position of inserted worksheets within a workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public enum InsertWorksheetPosition

Visual Basic [image] Copy Code

Public Enum InsertWorksheetPosition

Members

Member name | Description
AfterActiveSheet | Indicates new worksheet(s) will be inserted after the active sheet of a workbook view.
BeforeActiveSheet | Indicates new worksheet(s) will be inserted before the active sheet of a workbook view.
Other | Indicates a user specified index to insert the new worksheets.

Remarks

Used by the InsertWorksheetForm class.

See Also

MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm Class

ManageNamedRangesForm Class
Remarks See Also
[image]

Represents a form which can be used to create, edit and remove named cell ranges from a workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class ManageNamedRangesForm : Window, IComponentConnector

Visual Basic [image] Copy Code

Public Class ManageNamedRangesForm
Inherits Window
Implements IComponentConnector

Remarks

This form can be used to add, edit, and remove named ranges from a workbook. To use the form, create an instance of the ManageNamedRangesForm class, by providing the related workbook, and call the ShowDialog method. To apply the changes made through the form, call the Apply method. The following image shows the form:

Example

The code below demonstrates how to display the form for an existing range of cells.

C# [image] Copy Code

var form = new ManageNamedRangesForm(workbook, cellRange);
if (form.ShowDialog(this) == true)
{
using (workbook.StartCompositeOperation())
form.Apply(workbook);
}

Visual Basic [image] Copy Code

Dim form = New ManageNamedRangesForm(workbook, cellRange)
If form.ShowDialog(Me) = True Then

Using workbook.StartCompositeOperation()
form.Apply(workbook)
End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm

See Also

ManageNamedRangesForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm Members

ManageNamedRangesForm Members
Constructors Methods
[image]

Represents a form which can be used to create, edit and remove named cell ranges from a workbook.

The following tables list the members exposed by the ManageNamedRangesForm type.

Public Constructors

Name | Description
ManageNamedRangesForm | Initializes a new instance of the ManageNamedRangesForm class.

Public Methods

Name | Description
Apply | Updates the NamedRanges collection of the specified workbook with the ranges, defined in the form.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm Constructor

ManageNamedRangesForm Constructor
[image]

Initializes a new instance of the ManageNamedRangesForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ManageNamedRangesForm (
Workbook workbook,
CellRange selection
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
selection As CellRange _
)

Parameters

workbook

The workbook object that contains the named cell ranges collection to modify.

selection

A CellRange collection used to specify the default initial range.

See Also

ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm Methods

ManageNamedRangesForm Methods
[image]

Public Methods

Name | Description
Apply | Updates the NamedRanges collection of the specified workbook with the ranges, defined in the form.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm.Apply Method

ManageNamedRangesForm.Apply Method
[image]

Updates the NamedRanges collection of the specified workbook with the ranges, defined in the form.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Apply (
Workbook workbook
)

Visual Basic [image] Copy Code

Public Sub Apply( _
workbook As Workbook _
)

Parameters

workbook

The workbook which will be updated.

See Also

ManageNamedRangesForm Members
ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm.InitializeComponent Method

ManageNamedRangesForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

ManageNamedRangesForm Members
ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ManageNamedRangesForm.ShowDialog Method

ManageNamedRangesForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

ManageNamedRangesForm Members
ManageNamedRangesForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm Class

SortForm Class
Remarks See Also
[image]

Represents a form used to define sorting options for a cell range.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class SortForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class SortForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to sort the data in a worksheet. To use the form, create an instance of the SortForm class by providing the target worksheet and the cell range to sort, and call the ShowDialog method. To perform the sort using the settings entered by the user, call the form's Sort method. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.SortForm

See Also

SortForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm Members

SortForm Members
Constructors Methods Events
[image]

Represents a form used to define sorting options for a cell range.

The following tables list the members exposed by the SortForm type.

Public Constructors

Name | Description
SortForm | Initializes a new instance of the SortForm class.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.
Sort | Sorts the cells in the cell range.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm Constructor

SortForm Constructor
[image]

Initializes a new instance of the SortForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public SortForm (
Worksheet worksheet,
CellRange range
)

Visual Basic [image] Copy Code

Public New ( _
worksheet As Worksheet, _
range As CellRange _
)

Parameters

worksheet

The worksheet which contains the cell range.

range

The cell range to sort.

See Also

SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm Methods

SortForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.
Sort | Sorts the cells in the cell range.

See Also

SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm.InitializeComponent Method

SortForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

SortForm Members
SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm.ShowDialog Method

SortForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

SortForm Members
SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm.Sort Method

SortForm.Sort Method
[image]

Sorts the cells in the cell range.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Sort ()

Visual Basic [image] Copy Code

Public Sub Sort ()

See Also

SortForm Members
SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm Events

SortForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.SortForm.PropertyChanged Event

SortForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

SortForm Members
SortForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm Class

UnhideSheetsForm Class
Remarks See Also
[image]

Represents a form which can be used to unhide hidden worksheets in a workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class UnhideSheetsForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class UnhideSheetsForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to show the hidden worksheets of a workbook. To use the form, create an instance of the UnhideSheetsForm class, provide the target workbook, and call the ShowDialog method. To apply the changes, call the Apply method of the form. The following image shows the form:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm

See Also

UnhideSheetsForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm Members

UnhideSheetsForm Members
Constructors Methods Events
[image]

Represents a form which can be used to unhide hidden worksheets in a workbook.

The following tables list the members exposed by the UnhideSheetsForm type.

Public Constructors

Name | Description
UnhideSheetsForm | Initializes a new instance of the UnhideSheetsForm class.

Public Methods

Name | Description
Apply | Unhides the specified worksheets in the workbook.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm Constructor

UnhideSheetsForm Constructor
[image]

Initializes a new instance of the UnhideSheetsForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public UnhideSheetsForm (
Workbook parentWorkbook
)

Visual Basic [image] Copy Code

Public New ( _
parentWorkbook As Workbook _
)

Parameters

parentWorkbook

The parent Workbook object which contains the worksheets.

See Also

UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm Methods

UnhideSheetsForm Methods
[image]

Public Methods

Name | Description
Apply | Unhides the specified worksheets in the workbook.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Protected Methods

Name | Description
OnClosing | Window.OnClosing override.

See Also

UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm.Apply Method

UnhideSheetsForm.Apply Method
[image]

Unhides the specified worksheets in the workbook.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Apply ()

Visual Basic [image] Copy Code

Public Sub Apply ()

See Also

UnhideSheetsForm Members
UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm.InitializeComponent Method

UnhideSheetsForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

UnhideSheetsForm Members
UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm.OnClosing Method

UnhideSheetsForm.OnClosing Method
[image]

Window.OnClosing override.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

protected override void OnClosing (
CancelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnClosing( _
e As CancelEventArgs _
)

Parameters

e

An object that contains the event data.

See Also

UnhideSheetsForm Members
UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm.ShowDialog Method

UnhideSheetsForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

UnhideSheetsForm Members
UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm Events

UnhideSheetsForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.UnhideSheetsForm.PropertyChanged Event

UnhideSheetsForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

UnhideSheetsForm Members
UnhideSheetsForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm Class

ValidationForm Class
Remarks See Also
[image]

A form which can be used to define validation rules for cells within a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class ValidationForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class ValidationForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to add, edit, and remove data validation for a cell or a range of cells. To use the form, create an instance of the ValidationForm class, by providing the related workbook and the initial IValidation object, and call the ShowDialog method. To apply the changes made through the form, call the Apply method. The following image shows the form:

Example

The code below demonstrates how to display the validation form for an existing CellRange instance.

C# [image] Copy Code

var form = new ValidationForm(workbook, cellRange.Validation);
if (form.ShowDialog(this) == true)
{
using (workbook.StartChangeOperation(worksheet))
form.Apply(cellRange.Validation);
}

Visual Basic [image] Copy Code

Dim form = New ValidationForm(workbook, cellRange.Validation)
If form.ShowDialog(Me) = True Then

Using workbook.StartChangeOperation(worksheet)
form.Apply(cellRange.Validation)
End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm

See Also

ValidationForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm Members

ValidationForm Members
Constructors Methods Events
[image]

A form which can be used to define validation rules for cells within a worksheet.

The following tables list the members exposed by the ValidationForm type.

Public Constructors

Name | Description
ValidationForm | Initializes a new instance of the ValidationForm class.

Public Methods

Name | Description
Apply | Applies the validation rules defined in the form to a target IValidation object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm Constructor

ValidationForm Constructor
[image]

Initializes a new instance of the ValidationForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public ValidationForm (
Workbook workbook,
IValidation ivalidation
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
ivalidation As IValidation _
)

Parameters

workbook

The Workbook containing the predefined styles and formats used by this form.

ivalidation

The IValidation object containing the validation rules to modify with this form.

See Also

ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm Methods

ValidationForm Methods
[image]

Public Methods

Name | Description
Apply | Applies the validation rules defined in the form to a target IValidation object.
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm.Apply Method

ValidationForm.Apply Method
[image]

Applies the validation rules defined in the form to a target IValidation object.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void Apply (
IValidation target
)

Visual Basic [image] Copy Code

Public Sub Apply( _
target As IValidation _
)

Parameters

target

The target IValidation object to apply the validation rules to, usually the same object used to initialize the form.

See Also

ValidationForm Members
ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm.InitializeComponent Method

ValidationForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

ValidationForm Members
ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm.ShowDialog Method

ValidationForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

ValidationForm Members
ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm Events

ValidationForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.ValidationForm.PropertyChanged Event

ValidationForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

ValidationForm Members
ValidationForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Class

WorksheetRenameForm Class
Remarks See Also
[image]

Represents a form that can be used specify a name for a worksheet.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public class WorksheetRenameForm : Window, INotifyPropertyChanged, IComponentConnector

Visual Basic [image] Copy Code

Public Class WorksheetRenameForm
Inherits Window
Implements INotifyPropertyChanged, IComponentConnector

Remarks

This form can be used to prompt the user for the name of a worksheet. To use the form, create an instance of the WorksheetRenameForm class, providing the initial name to display, and call the ShowDialog method. The user's choice can be obtained from the SheetName property. The following image shows the form:

Example

The code below demonstrates how to use the form to edit the name of an existing worksheet.

C# [image] Copy Code

var form = new WorksheetRenameForm(worksheet.Name);
if (form.ShowDialog(this) == true)
{
using (workbook.StartChangeOperation(worksheet))
worksheet.Name = form.WorksheetName;
}

Visual Basic [image] Copy Code

Dim form = New WorksheetRenameForm(worksheet.Name)
If form.ShowDialog(Me) = True Then

Using workbook.StartChangeOperation(worksheet)
worksheet.Name = form.WorksheetName
End Using

End If

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Window
MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm

See Also

WorksheetRenameForm Members
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Members

WorksheetRenameForm Members
Constructors Properties Methods Events
[image]

Represents a form that can be used specify a name for a worksheet.

The following tables list the members exposed by the WorksheetRenameForm type.

Public Constructors

Name | Description
WorksheetRenameForm | Initializes a new instance of the WorksheetRenameForm class.

Public Properties

Name | Description
SheetName | Gets the name for the worksheet, defined by the form.

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Constructor

WorksheetRenameForm Constructor
[image]

Initializes a new instance of the WorksheetRenameForm class.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public WorksheetRenameForm (
Workbook workbook,
string sheetName
)

Visual Basic [image] Copy Code

Public New ( _
workbook As Workbook, _
sheetName As String _
)

Parameters

workbook

The workbook that should provide localization info.

sheetName

The current name of the worksheet.

See Also

WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Methods

WorksheetRenameForm Methods
[image]

Public Methods

Name | Description
InitializeComponent | Performs initialization.
ShowDialog | Opens this form using the specified window as an owner.

See Also

WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm.InitializeComponent Method

WorksheetRenameForm.InitializeComponent Method
[image]

Performs initialization.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public void InitializeComponent ()

Visual Basic [image] Copy Code

Public Sub InitializeComponent ()

See Also

WorksheetRenameForm Members
WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm.ShowDialog Method

WorksheetRenameForm.ShowDialog Method
[image]

Opens this form using the specified window as an owner.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public Nullable<Boolean> ShowDialog (
Window owner
)

Visual Basic [image] Copy Code

Public Function ShowDialog( _
owner As Window _
) As Nullable(Of Boolean)

Parameters

owner

The form owner.

Return Value

A nullable boolean value that specifies whether the form was accepted (true) or canceled (false).

See Also

WorksheetRenameForm Members
WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Properties

WorksheetRenameForm Properties
[image]

Public Properties

Name | Description
SheetName | Gets the name for the worksheet, defined by the form.

See Also

WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm.SheetName Property

WorksheetRenameForm.SheetName Property
[image]

Gets the name for the worksheet, defined by the form.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public string SheetName { get; set; }

Visual Basic [image] Copy Code

Public Property SheetName As String

Property Value

A string value.

See Also

WorksheetRenameForm Members
WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm Events

WorksheetRenameForm Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.Spreadsheet.Wpf.StandardForms.WorksheetRenameForm.PropertyChanged Event

WorksheetRenameForm.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Spreadsheet.Wpf.StandardForms
Assembly: MindFusion.Spreadsheet.Wpf.StandardForms

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

WorksheetRenameForm Members
WorksheetRenameForm Class
MindFusion.Spreadsheet.Wpf.StandardForms Namespace


MindFusion.UI.Wpf Namespace

MindFusion.UI.Wpf Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Accordion | Represents a container of elements. The elements in the Accordion can be expanded or collapsed.
AccordionItem | Represents an item in an Accordion control.
Calendar | Represents a light-weight calendar control.
ColorEditor | Represents a control that can be used to edit colors in an RGB or HSL format.
ColorPicker | Represents a control that can enable users to select colors from a drop-down palette or through a specialized editor.
ConfirmEventArgs | Contains the arguments passed to handlers of validation events.
DateCollection | Represents a strongly-typed collection of DateTime objects.
DateEventArgs | Contains the arguments passed to handlers of date-related events.
DateTimePicker | Represents a drop-down control which enables users to select dates and times.
DockControl | Enables docking of user interface elements.
DockEventArgs | Contains the arguments passed to handlers of validation events.
DockItem | Enables items docking in a DockControl.
DrawEventArgs | Contains information for custom drawing events.
MindFusionButton | Represents an advanced button that can optionally display a drop-down panel when clicked.
NumericUpDown | Represents a numeric text box with buttons to increase or decrease the displayed value.
PropertyGrid | Provides a user interface for browsing the properties of an object.
RangeSelector | Represents a range selector – a control which allows the users to interactively select a range inside a larger range.
Rating | Provides the ability to select and display ratings in a variety of formats.
ScrollArrowEventArgs | Contains arguments for the ScrollArrowClicked event.
Slider | Represents a slider control that can be used to specify individual values or value ranges.
TabControl | Represents a tab control.
TabEventArgs | Contains information for TabControl-related events.
TabItem | Represents an item in a TabControl.
VisualTreeView | Visualizes the visual tree structure of an arbitrary DependencyObject in a TreeView control and allows navigation through the tree.
Window | Represents a window with title and contents, which can be moved, resized and arranged interactively.
WindowHost | Represents a container for Window objects.
ZoomButton | The button used in ZoomControl.
ZoomControl | ZoomControl lets users zoom and pan a target Diagram or DiagramView interactively.

Interfaces

Interface | Description
IZoomTarget | Specifies the capabilities required by ZoomControl from its target controls.

Enumerations

Enumeration | Description
CalendarView | Specifies the view type in a Calendar control.
ColorEditorMode | Specifies the working modes of a ColorEditor control.
DayOfWeekFormat | Specifies the display format of a day of the week.
DisplayDateFormat | Specifies how dates are displayed in the DateTimePicker control.
Dock | Specifies a dock destination.
DockItemState | Specifies the state of a DockItem inside a DockControl.
DockLocations | Specifies the possible dock destinations.
MindFusionButtonType | Specifies the behavior of a MindFusionButton.
MinimizeMode | Specifies the behavior of minimized windows.
PropertyDisplayType |
PropertySortType |
RatingMode | Specifies how the Rating control displays values.
RatingShape | Specifies the shape of the elements in a Rating control.
RatingStretch | Specifies the stretching of the elements in a Rating control.
ResizeMode | Specifies the allowed user interactions on a window.
ScrollDirection | Identifies the direction of a scroll arrow.
SelectionMode | Specifies the interactive selection behavior in a Calendar control.
TabAlignment | Specifies the alignment of the tab headers in a TabControl.
TabLayoutMode | Specifies how tab items are arranged in the header of a TabControl.
TabRotation | Specifies the rotation of the tab items in a TabControl.
TickPosition | Specifies the position of trackbar ticks.
TickType | Specifies the type of the ticks in a Slider control.
WeekHeaderAlignment | Specifies the alignment of the week numbers header in a Calendar control.
WindowState | Specifies the state of a Window.


MindFusion.UI.Wpf Namespace

MindFusion.UI.Wpf Namespace
Classes Structures Enumerations

Classes

Class | Description
ExtendedKey | Represents a key that sends several key codes when pressed.
Key | Represents a key in the keyboard.
KeyboardLayout | Defines layout of keyboard keys.
NumPadKey | Represents a num pad key.
RegularKey | Represents regular keyboard keys that send character codes as input.
SpecialKey | Represents special keys.
UnicodeKey | Represents keyboard keys that send unicode-character codes as input.
ValueSetConverter | Converts references to boolean values.
VirtualKeyboard | Virtual Keyboard Control.
VirtualKeyEventArgs | Contains data about KeyPressed events.

Structures

Structure | Description
KeyLabels | Represents custom key labels.

Enumerations

Enumeration | Description
KeyboardMode | Identifies keyboard layout modes.


MindFusion.UI.Wpf.Accordion Class

Accordion Class
Remarks See Also
[image]

Represents a container of elements. The elements in the Accordion can be expanded or collapsed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class Accordion : ItemsControl

Visual Basic [image] Copy Code

Public Class Accordion
Inherits ItemsControl

Remarks

Accordion is an ItemsControl, which means it can contain a collection of objects of any type (such as string, image, or panel). The items in the Accordion control can be expanded and collapsed. The AllowMultipleExpands property determines whether more than one item can be expanded at a time. The items in the Accordion control can display a header. To associate a header with an accordion item, use the Header attached property of the Accordion class.

Example

The following code illustrates an Accordion control defined in XAML:

XAML [image] Copy Code

<ui:Accordion>
<TextBlock Text="Hello world!" ui:Accordion.Header="A TextBlock as an item" />
<ui:AccordionItem Header="A common accordion item">
<ListBox>
<ListBoxItem Content="Item #1" />
<ListBoxItem Content="Item #2" />
<ListBoxItem Content="Item #3" />
</ListBox>
</ui:AccordionItem>
<ui:AccordionItem Header="An item with customized header" IsExpanded="True">
<ui:AccordionItem.HeaderTemplate>
<DataTemplate>
<Border BorderBrush="Red" BorderThickness="1">
<TextBlock Text="{Binding}" />
</Border>
</DataTemplate>
</ui:AccordionItem.HeaderTemplate>
<StackPanel Orientation="Vertical">
<RadioButton Content="Circle" />
<RadioButton Content="Rectangle" IsChecked="True" />
<RadioButton Content="Triangle" />
</StackPanel>
</ui:AccordionItem>
</ui:Accordion>

The image below displays the result:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.UI.Wpf.Accordion

See Also

Accordion Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Members

Accordion Members
Constructors Fields Attached Properties Properties Methods
[image]

Represents a container of elements. The elements in the Accordion can be expanded or collapsed.

The following tables list the members exposed by the Accordion type.

Public Constructors

Name | Description
Accordion | Initializes a new instance of the Accordion class.

Public Fields

Name | Description
AllowMultipleExpandsProperty | Identifies the AllowMultipleExpands dependency property.
HeaderProperty | Identifies the Header attached property.
SectionHeaderBackgroundProperty | Identifies the SectionHeaderBackground dependency property.
SectionHeaderBorderBrushProperty | Identifies the SectionHeaderBorderBrush property.
SectionHeaderTemplateProperty | Identifies the SectionHeaderTemplate dependency property.

Public Attached Properties

Name | Description
HeaderProperty | Gets or sets the header of an accordion item.

Public Properties

Name | Description
AllowMultipleExpands | Gets or sets a value indicating whether mode than one accordion item can be expended at a time. This is a dependency property.
SectionHeaderBackground | Gets or sets the header background of the accordion items. This is a dependency property.
SectionHeaderBorderBrush | Gets or sets the header border brush of the accordion items. This is a dependency property.
SectionHeaderTemplate | Gets or sets the template used to display the content of the accordion item headers. This is a dependency property.

Public Methods

Name | Description
GetHeader | Gets the value of the Accordion.Header attached property for a given dependency object.
SetHeader | Sets the value of the Accordion.Header attached property for a given dependency object.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Fields

Accordion Fields
[image]

Public Fields

Name | Description
AllowMultipleExpandsProperty | Identifies the AllowMultipleExpands dependency property.
HeaderProperty | Identifies the Header attached property.
SectionHeaderBackgroundProperty | Identifies the SectionHeaderBackground dependency property.
SectionHeaderBorderBrushProperty | Identifies the SectionHeaderBorderBrush property.
SectionHeaderTemplateProperty | Identifies the SectionHeaderTemplate dependency property.

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.AllowMultipleExpandsProperty Field

Accordion.AllowMultipleExpandsProperty Field
[image]

Identifies the AllowMultipleExpands dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowMultipleExpandsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowMultipleExpandsProperty As DependencyProperty

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.HeaderProperty Field

Accordion.HeaderProperty Field
[image]

Identifies the Header attached property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderBackgroundProperty Field

Accordion.SectionHeaderBackgroundProperty Field
[image]

Identifies the SectionHeaderBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionHeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionHeaderBackgroundProperty As DependencyProperty

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderBorderBrushProperty Field

Accordion.SectionHeaderBorderBrushProperty Field
[image]

Identifies the SectionHeaderBorderBrush property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionHeaderBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionHeaderBorderBrushProperty As DependencyProperty

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderTemplateProperty Field

Accordion.SectionHeaderTemplateProperty Field
[image]

Identifies the SectionHeaderTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionHeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionHeaderTemplateProperty As DependencyProperty

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Constructor

Accordion Constructor
[image]

Initializes a new instance of the Accordion class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Accordion ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Methods

Accordion Methods
[image]

Public Methods

Name | Description
GetHeader | Gets the value of the Accordion.Header attached property for a given dependency object.
SetHeader | Sets the value of the Accordion.Header attached property for a given dependency object.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.GetContainerForItemOverride Method

Accordion.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overridable Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.GetHeader Method

Accordion.GetHeader Method
[image]

Gets the value of the Accordion.Header attached property for a given dependency object.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static Object GetHeader (
DependencyObject obj
)

Visual Basic [image] Copy Code

Public Shared Function GetHeader( _
obj As DependencyObject _
) As Object

Parameters

obj

The element from which the property value is read.

Return Value

The value of the Accordion.Header property for the specified element.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.IsItemItsOwnContainerOverride Method

Accordion.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.PrepareContainerForItemOverride Method

Accordion.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SetHeader Method

Accordion.SetHeader Method
[image]

Sets the value of the Accordion.Header attached property for a given dependency object.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static void SetHeader (
DependencyObject obj,
Object value
)

Visual Basic [image] Copy Code

Public Shared Sub SetHeader( _
obj As DependencyObject, _
value As Object _
)

Parameters

obj

The element to which the property value is written.

value
The value of the Accordion.Header property for the specified element.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Attached Properties

Accordion Attached Properties
[image]

Public Attached Properties

Name | Description
HeaderProperty | Gets or sets the header of an accordion item.

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.Header Attached Property

Accordion.Header Attached Property
[image]

Gets or sets the header of an accordion item.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code
See Accordion.GetHeader, Accordion.SetHeader
Visual Basic [image] Copy Code
See Accordion.GetHeader, Accordion.SetHeader

Property Value

An object representing the item header.

Dependency Property Information

Identifier Field | HeaderProperty
Metadata Flags | None

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion Properties

Accordion Properties
[image]

Public Properties

Name | Description
AllowMultipleExpands | Gets or sets a value indicating whether mode than one accordion item can be expended at a time. This is a dependency property.
SectionHeaderBackground | Gets or sets the header background of the accordion items. This is a dependency property.
SectionHeaderBorderBrush | Gets or sets the header border brush of the accordion items. This is a dependency property.
SectionHeaderTemplate | Gets or sets the template used to display the content of the accordion item headers. This is a dependency property.

See Also

Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.AllowMultipleExpands Property

Accordion.AllowMultipleExpands Property
[image]

Gets or sets a value indicating whether mode than one accordion item can be expended at a time. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool AllowMultipleExpands { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleExpands As Boolean

Property Value

true, if there is no restriction to the number of items that can be expanded at a time; false, if only one item can be expanded at a time.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderBackground Property

Accordion.SectionHeaderBackground Property
[image]

Gets or sets the header background of the accordion items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush SectionHeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property SectionHeaderBackground As Brush

Property Value

A WPF Brush object.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderBorderBrush Property

Accordion.SectionHeaderBorderBrush Property
[image]

Gets or sets the header border brush of the accordion items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush SectionHeaderBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SectionHeaderBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Accordion.SectionHeaderTemplate Property

Accordion.SectionHeaderTemplate Property
[image]

Gets or sets the template used to display the content of the accordion item headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate SectionHeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property SectionHeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Accordion Members
Accordion Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Class

AccordionItem Class
Remarks See Also
[image]

Represents an item in an Accordion control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class AccordionItem : HeaderedContentControl

Visual Basic [image] Copy Code

Public Class AccordionItem
Inherits HeaderedContentControl

Remarks

An Accordion control contains a collection of AccordionItem objects. To expand an AccordionItem in an Accordion, set the IsExpanded property to true.

The AccordionItem is a HeaderedContentControl, which means that it can contain a single object of any type (such as a string, an image, or a panel) as a content and a single object of any type as a header.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.HeaderedContentControl
MindFusion.UI.Wpf.AccordionItem

See Also

AccordionItem Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Members

AccordionItem Members
Constructors Fields Properties Methods Events
[image]

Represents an item in an Accordion control.

The following tables list the members exposed by the AccordionItem type.

Public Constructors

Name | Description
AccordionItem | Initializes a new instance of the AccordionItem class.

Public Fields

Name | Description
CollapsedEvent | Identifies the Collapsed routed event.
ExpandedEvent | Identifies the Expanded routed event.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Public Properties

Name | Description
IsExpanded | Gets or sets a value indicating whether this accordion item is expanded. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Public Events

Name | Description
Collapsed | Raised when this item is collapsed.
Expanded | Raised when this item is expanded.

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Fields

AccordionItem Fields
[image]

Public Fields

Name | Description
CollapsedEvent | Identifies the Collapsed routed event.
ExpandedEvent | Identifies the Expanded routed event.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.CollapsedEvent Field

AccordionItem.CollapsedEvent Field
[image]

Identifies the Collapsed routed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent CollapsedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly CollapsedEvent As RoutedEvent

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.ExpandedEvent Field

AccordionItem.ExpandedEvent Field
[image]

Identifies the Expanded routed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly RoutedEvent ExpandedEvent

Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandedEvent As RoutedEvent

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.IsExpandedProperty Field

AccordionItem.IsExpandedProperty Field
[image]

Identifies the IsExpanded dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsExpandedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Constructor

AccordionItem Constructor
[image]

Initializes a new instance of the AccordionItem class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public AccordionItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Methods

AccordionItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.OnApplyTemplate Method

AccordionItem.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Properties

AccordionItem Properties
[image]

Public Properties

Name | Description
IsExpanded | Gets or sets a value indicating whether this accordion item is expanded. This is a dependency property.

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.IsExpanded Property

AccordionItem.IsExpanded Property
[image]

Gets or sets a value indicating whether this accordion item is expanded. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsExpanded { get; set; }

Visual Basic [image] Copy Code

Public Property IsExpanded As Boolean

Property Value

true, if the item is expanded; false, if the item is collapsed.

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem Events

AccordionItem Events
[image]

Public Events

Name | Description
Collapsed | Raised when this item is collapsed.
Expanded | Raised when this item is expanded.

See Also

AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.Collapsed Event

AccordionItem.Collapsed Event
[image]

Raised when this item is collapsed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler Collapsed

Visual Basic [image] Copy Code

Public Event Collapsed As RoutedEventHandler

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.AccordionItem.Expanded Event

AccordionItem.Expanded Event
[image]

Raised when this item is expanded.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event RoutedEventHandler Expanded

Visual Basic [image] Copy Code

Public Event Expanded As RoutedEventHandler

See Also

AccordionItem Members
AccordionItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Class

Calendar Class
Remarks See Also
[image]

Represents a light-weight calendar control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class Calendar : ContentControl

Visual Basic [image] Copy Code

Public Class Calendar
Inherits ContentControl

Remarks

The Calendar control can display several views with different resolution, varying from Time to Century. The user can switch from one view to another by either clicking on the calendar title or by clicking on a cell in the current view. The user can navigate within the current view by clicking on the navigation buttons in the calendar header.

The appearance of the cells in the different views can be customized through several data templates - DefaultItemTemplate, TodayItemTemplate, PaddingItemTemplate, WeekendItemTemplate, HolidayItemTemplate, SelectionItemTemplate, FocusItemTemplate and HoverItemTemplate.

The general appearance of the calendar can be customized through Background, BorderBrush, BorderThickness, ContentBackground, ContentBorderBrush, ContentBorderThickness, HeaderBackground, HeaderBorderBrush, HeaderBorderThickness and Foreground.

The dates displayed in the various views are formatted through several strings - TimeViewFormat, MonthViewFormat, YearViewFormat, DecadeViewFormat and CenturyViewFormat.

Example

The following code demonstrates the declaration of a Calendar control in XAML:

XAML [image] Copy Code

<ui:Calendar Date="1/1/2010" MaxDrillIn="Month" SelectionMode="Multiple" />

The code above will produce a calendar similar to the following:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.UI.Wpf.Calendar

See Also

Calendar Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Members

Calendar Members
Constructors Fields Properties Methods Events
[image]

Represents a light-weight calendar control.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Initializes a new instance of the Calendar class.

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
CenturyViewFormatProperty | Identifies the CenturyViewFormat dependency property.
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentBorderBrushProperty | Identifies the ContentBorderBrush dependency property.
ContentBorderThicknessProperty | Identifies the ContentBorderThickness dependency property.
CurrentViewProperty | Identifies the CurrentView dependency property.
DateProperty | Identifies the Date dependency property.
DateSelectionProperty | Identifies the DateSelection dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
DecadeViewFormatProperty | Identifies the DecadeViewFormat dependency property.
DefaultItemTemplateProperty | Identifies the DefaultItemTemplate dependency property.
FocusItemTemplateProperty | Identifies the FocusItemTemplate dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HolidayItemTemplateProperty | Identifies the HolidayItemTemplate dependency property.
HolidaysDateSelectionProperty | Identifies the HolidaysDateSelection dependency property.
HoverItemTemplateProperty | Identifies the HoverItemTemplate dependency property.
MaxDrillInProperty | Identifies the MaxDrillIn dependency property.
MaxDrillOutProperty | Identifies the MaxDrillOut property.
MonthViewFormatProperty | Identifies the MonthViewFormat dependency property.
PaddingItemTemplateProperty | Identifies the PaddingItemTemplate dependency property.
SelectionItemTemplateProperty | Identifies the SelectionItemTemplate dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.
SelectionOnTopProperty | Identifies the SelectionOnTop dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
TimeViewFormatProperty | Identifies the TimeViewFormat dependency property.
TodayItemTemplateProperty | Identifies the TodayItemTemplate dependency property.
WeekendItemTemplateProperty | Identifies the WeekendItemTemplate dependency property.
WeekHeaderAlignmentProperty | Identifies the WeekHeaderAlignment dependency property.
WeekHeaderWidthProperty | Identifies the WeekHeaderWidth dependency property.
YearViewFormatProperty | Identifies the YearViewFormat dependency property.

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the buttons in the calendar. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons in the calendar. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the calendar. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons in the calendar when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons in the calendar when they are pressed. This is a dependency property.
CenturyViewFormat | Gets or sets the formatting of the dates in the Century view. This is a dependency property.
ContentBackground | Gets or sets the background of the calendar content. This is a dependency property.
ContentBorderBrush | Gets or sets the border brush of the calendar content. This is a dependency property.
ContentBorderThickness | Gets or sets the border thickness of the calendar content. This is a dependency property.
CurrentView | Gets or sets the current view. This is a dependency property.
Date | Gets or sets the currently displayed date. This is a dependency property.
DateSelection | Gets or sets the list of dates selected in the calendar. This is a dependency property.
DayOfWeekFormat | Gets or sets the format of the days of the week displayed in the subheader. This is a dependency property.
DecadeViewFormat | Gets or sets the formatting of the dates in the Decade view. This is a dependency property.
DefaultItemTemplate | Gets or sets the default template of the calendar's cells. This is a dependency property.
FocusItemTemplate | Gets or sets the template of the cell containing the logical focus. This is a dependency property.
Header | Gets or sets the content of the calendar header. This is a dependency property.
HeaderBackground | Gets or sets the background of the calendar header. This is a dependency property.
HeaderBorderBrush | Gets or sets the brush of the border around the calendar header. This is a dependency property.
HeaderBorderThickness | Gets or sets the thickness of the border around the calendar header. This is a dependency property.
HeaderHeight | Gets or sets the height of the calendar header. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the calendar's header. This is a dependency property.
HolidayItemTemplate | Gets or sets the template of the cells representing holidays. This is a dependency property.
HolidaysDateSelection | Gets or sets a list of holiday dates. This is a dependency property.
HoverItemTemplate | Gets or sets the template of the cell pointed with the mouse. This is a dependency property.
MaxDrillIn | Gets or sets the last view that can be drilled-in to. This is a dependency property.
MaxDrillOut | Gets or sets the last view that can be drilled-out to. This is a dependency property.
MonthViewFormat | Gets or sets the formatting of the dates in the Month view. This is a dependency property.
PaddingItemTemplate | Gets or sets the template of the padding cells. This is a dependency property.
SelectionItemTemplate | Gets or sets the template of the selected cells. This is a dependency property.
SelectionMode | Gets or sets the mode of the interactive selection in the calendar. This is a dependency property.
SelectionOnTop | Gets or sets a value indicating whether the selection is displayed above the corresponding cells or below them. This is a dependency property.
ShowPaddingDays | Gets or sets a value indicating whether the previous and next time intervals are displayed in the available space of the current view. This is a dependency property.
ShowToday | Gets or sets a value indicating whether the current date is highlighted in the calendar. This is a dependency property.
SubHeaderHeight | Gets or sets the height of the subheader, which displays the days of the week. This is a dependency property.
TimeViewFormat | Gets or sets the formatting of the times in the Time view. This is a dependency property.
TodayItemTemplate | Gets or sets the template of the cell representing the current date. This is a dependency property.
WeekendItemTemplate | Gets or sets the template of the cells representing weekends. This is a dependency property.
WeekHeaderAlignment | Gets or sets the alignment of the subheader, which displays the week numbers. This is a dependency property.
WeekHeaderWidth | Gets or sets the width of the subheader, which displays the week numbers. This is a dependency property.
YearViewFormat | Gets or sets the formatting of the dates in the Year view. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.

Public Events

Name | Description
DateClicked | Raised when the user clicks with the mouse on a specific date in the calendar.
DateSelectionChanged | Raises when the currently selected date in the calendar is changed interactively.
DrilledIn | Raised when the calendar is drilled-in interactively to a more specific view.
DrilledOut | Raised when the calendar is drilled-out interactively to a more general view.
Scrolled | Raises when the calendar is scrolled back and forth through the navigation buttons.

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Fields

Calendar Fields
[image]

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
CenturyViewFormatProperty | Identifies the CenturyViewFormat dependency property.
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentBorderBrushProperty | Identifies the ContentBorderBrush dependency property.
ContentBorderThicknessProperty | Identifies the ContentBorderThickness dependency property.
CurrentViewProperty | Identifies the CurrentView dependency property.
DateProperty | Identifies the Date dependency property.
DateSelectionProperty | Identifies the DateSelection dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
DecadeViewFormatProperty | Identifies the DecadeViewFormat dependency property.
DefaultItemTemplateProperty | Identifies the DefaultItemTemplate dependency property.
FocusItemTemplateProperty | Identifies the FocusItemTemplate dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HolidayItemTemplateProperty | Identifies the HolidayItemTemplate dependency property.
HolidaysDateSelectionProperty | Identifies the HolidaysDateSelection dependency property.
HoverItemTemplateProperty | Identifies the HoverItemTemplate dependency property.
MaxDrillInProperty | Identifies the MaxDrillIn dependency property.
MaxDrillOutProperty | Identifies the MaxDrillOut property.
MonthViewFormatProperty | Identifies the MonthViewFormat dependency property.
PaddingItemTemplateProperty | Identifies the PaddingItemTemplate dependency property.
SelectionItemTemplateProperty | Identifies the SelectionItemTemplate dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.
SelectionOnTopProperty | Identifies the SelectionOnTop dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
TimeViewFormatProperty | Identifies the TimeViewFormat dependency property.
TodayItemTemplateProperty | Identifies the TodayItemTemplate dependency property.
WeekendItemTemplateProperty | Identifies the WeekendItemTemplate dependency property.
WeekHeaderAlignmentProperty | Identifies the WeekHeaderAlignment dependency property.
WeekHeaderWidthProperty | Identifies the WeekHeaderWidth dependency property.
YearViewFormatProperty | Identifies the YearViewFormat dependency property.

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBackgroundProperty Field

Calendar.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBorderBrushProperty Field

Calendar.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBorderThicknessProperty Field

Calendar.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonOverBackgroundProperty Field

Calendar.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonPressedBackgroundProperty Field

Calendar.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.CenturyViewFormatProperty Field

Calendar.CenturyViewFormatProperty Field
[image]

Identifies the CenturyViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CenturyViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CenturyViewFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBackgroundProperty Field

Calendar.ContentBackgroundProperty Field
[image]

Identifies the ContentBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBackgroundProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBorderBrushProperty Field

Calendar.ContentBorderBrushProperty Field
[image]

Identifies the ContentBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBorderBrushProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBorderThicknessProperty Field

Calendar.ContentBorderThicknessProperty Field
[image]

Identifies the ContentBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBorderThicknessProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.CurrentViewProperty Field

Calendar.CurrentViewProperty Field
[image]

Identifies the CurrentView dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentViewProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentViewProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DateProperty Field

Calendar.DateProperty Field
[image]

Identifies the Date dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DateSelectionProperty Field

Calendar.DateSelectionProperty Field
[image]

Identifies the DateSelection dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DateSelectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DateSelectionProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DayOfWeekFormatProperty Field

Calendar.DayOfWeekFormatProperty Field
[image]

Identifies the DayOfWeekFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayOfWeekFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DayOfWeekFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DecadeViewFormatProperty Field

Calendar.DecadeViewFormatProperty Field
[image]

Identifies the DecadeViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DecadeViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DecadeViewFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DefaultItemTemplateProperty Field

Calendar.DefaultItemTemplateProperty Field
[image]

Identifies the DefaultItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.FocusItemTemplateProperty Field

Calendar.FocusItemTemplateProperty Field
[image]

Identifies the FocusItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FocusItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FocusItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBackgroundProperty Field

Calendar.HeaderBackgroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBorderBrushProperty Field

Calendar.HeaderBorderBrushProperty Field
[image]

Identifies the HeaderBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderBrushProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBorderThicknessProperty Field

Calendar.HeaderBorderThicknessProperty Field
[image]

Identifies the HeaderBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderThicknessProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderHeightProperty Field

Calendar.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderProperty Field

Calendar.HeaderProperty Field
[image]

Identifies the Header dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderTemplateProperty Field

Calendar.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HolidayItemTemplateProperty Field

Calendar.HolidayItemTemplateProperty Field
[image]

Identifies the HolidayItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HolidayItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HolidayItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HolidaysDateSelectionProperty Field

Calendar.HolidaysDateSelectionProperty Field
[image]

Identifies the HolidaysDateSelection dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HolidaysDateSelectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HolidaysDateSelectionProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HoverItemTemplateProperty Field

Calendar.HoverItemTemplateProperty Field
[image]

Identifies the HoverItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HoverItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HoverItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.MaxDrillInProperty Field

Calendar.MaxDrillInProperty Field
[image]

Identifies the MaxDrillIn dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxDrillInProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxDrillInProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.MaxDrillOutProperty Field

Calendar.MaxDrillOutProperty Field
[image]

Identifies the MaxDrillOut property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxDrillOutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxDrillOutProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.MonthViewFormatProperty Field

Calendar.MonthViewFormatProperty Field
[image]

Identifies the MonthViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthViewFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.PaddingItemTemplateProperty Field

Calendar.PaddingItemTemplateProperty Field
[image]

Identifies the PaddingItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionItemTemplateProperty Field

Calendar.SelectionItemTemplateProperty Field
[image]

Identifies the SelectionItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionModeProperty Field

Calendar.SelectionModeProperty Field
[image]

Identifies the SelectionMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionModeProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionOnTopProperty Field

Calendar.SelectionOnTopProperty Field
[image]

Identifies the SelectionOnTop dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionOnTopProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionOnTopProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ShowPaddingDaysProperty Field

Calendar.ShowPaddingDaysProperty Field
[image]

Identifies the ShowPaddingDays dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingDaysProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingDaysProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ShowTodayProperty Field

Calendar.ShowTodayProperty Field
[image]

Identifies the ShowToday dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTodayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTodayProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SubHeaderHeightProperty Field

Calendar.SubHeaderHeightProperty Field
[image]

Identifies the SubHeaderHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderHeightProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.TimeViewFormatProperty Field

Calendar.TimeViewFormatProperty Field
[image]

Identifies the TimeViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimeViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimeViewFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.TodayItemTemplateProperty Field

Calendar.TodayItemTemplateProperty Field
[image]

Identifies the TodayItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TodayItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekendItemTemplateProperty Field

Calendar.WeekendItemTemplateProperty Field
[image]

Identifies the WeekendItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekendItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekendItemTemplateProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekHeaderAlignmentProperty Field

Calendar.WeekHeaderAlignmentProperty Field
[image]

Identifies the WeekHeaderAlignment dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderAlignmentProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekHeaderWidthProperty Field

Calendar.WeekHeaderWidthProperty Field
[image]

Identifies the WeekHeaderWidth dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderWidthProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.YearViewFormatProperty Field

Calendar.YearViewFormatProperty Field
[image]

Identifies the YearViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YearViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YearViewFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Constructor

Calendar Constructor
[image]

Initializes a new instance of the Calendar class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Calendar ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Methods

Calendar Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.OnApplyTemplate Method

Calendar.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.OnKeyDown Method

Calendar.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The System.Windows.Input.KeyEventArgs that contains the event data.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.OnMouseLeftButtonDown Method

Calendar.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Properties

Calendar Properties
[image]

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the buttons in the calendar. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons in the calendar. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the calendar. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons in the calendar when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons in the calendar when they are pressed. This is a dependency property.
CenturyViewFormat | Gets or sets the formatting of the dates in the Century view. This is a dependency property.
ContentBackground | Gets or sets the background of the calendar content. This is a dependency property.
ContentBorderBrush | Gets or sets the border brush of the calendar content. This is a dependency property.
ContentBorderThickness | Gets or sets the border thickness of the calendar content. This is a dependency property.
CurrentView | Gets or sets the current view. This is a dependency property.
Date | Gets or sets the currently displayed date. This is a dependency property.
DateSelection | Gets or sets the list of dates selected in the calendar. This is a dependency property.
DayOfWeekFormat | Gets or sets the format of the days of the week displayed in the subheader. This is a dependency property.
DecadeViewFormat | Gets or sets the formatting of the dates in the Decade view. This is a dependency property.
DefaultItemTemplate | Gets or sets the default template of the calendar's cells. This is a dependency property.
FocusItemTemplate | Gets or sets the template of the cell containing the logical focus. This is a dependency property.
Header | Gets or sets the content of the calendar header. This is a dependency property.
HeaderBackground | Gets or sets the background of the calendar header. This is a dependency property.
HeaderBorderBrush | Gets or sets the brush of the border around the calendar header. This is a dependency property.
HeaderBorderThickness | Gets or sets the thickness of the border around the calendar header. This is a dependency property.
HeaderHeight | Gets or sets the height of the calendar header. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the calendar's header. This is a dependency property.
HolidayItemTemplate | Gets or sets the template of the cells representing holidays. This is a dependency property.
HolidaysDateSelection | Gets or sets a list of holiday dates. This is a dependency property.
HoverItemTemplate | Gets or sets the template of the cell pointed with the mouse. This is a dependency property.
MaxDrillIn | Gets or sets the last view that can be drilled-in to. This is a dependency property.
MaxDrillOut | Gets or sets the last view that can be drilled-out to. This is a dependency property.
MonthViewFormat | Gets or sets the formatting of the dates in the Month view. This is a dependency property.
PaddingItemTemplate | Gets or sets the template of the padding cells. This is a dependency property.
SelectionItemTemplate | Gets or sets the template of the selected cells. This is a dependency property.
SelectionMode | Gets or sets the mode of the interactive selection in the calendar. This is a dependency property.
SelectionOnTop | Gets or sets a value indicating whether the selection is displayed above the corresponding cells or below them. This is a dependency property.
ShowPaddingDays | Gets or sets a value indicating whether the previous and next time intervals are displayed in the available space of the current view. This is a dependency property.
ShowToday | Gets or sets a value indicating whether the current date is highlighted in the calendar. This is a dependency property.
SubHeaderHeight | Gets or sets the height of the subheader, which displays the days of the week. This is a dependency property.
TimeViewFormat | Gets or sets the formatting of the times in the Time view. This is a dependency property.
TodayItemTemplate | Gets or sets the template of the cell representing the current date. This is a dependency property.
WeekendItemTemplate | Gets or sets the template of the cells representing weekends. This is a dependency property.
WeekHeaderAlignment | Gets or sets the alignment of the subheader, which displays the week numbers. This is a dependency property.
WeekHeaderWidth | Gets or sets the width of the subheader, which displays the week numbers. This is a dependency property.
YearViewFormat | Gets or sets the formatting of the dates in the Year view. This is a dependency property.

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBackground Property

Calendar.ButtonBackground Property
[image]

Gets or sets the background of the buttons in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBorderBrush Property

Calendar.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the buttons in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonBorderThickness Property

Calendar.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the buttons in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonOverBackground Property

Calendar.ButtonOverBackground Property
[image]

Gets or sets the background of the buttons in the calendar when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ButtonPressedBackground Property

Calendar.ButtonPressedBackground Property
[image]

Gets or sets the background of the buttons in the calendar when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.CenturyViewFormat Property

Calendar.CenturyViewFormat Property
[image]

Gets or sets the formatting of the dates in the Century view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string CenturyViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CenturyViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBackground Property

Calendar.ContentBackground Property
[image]

Gets or sets the background of the calendar content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ContentBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBackground As Brush

Property Value

A WPF Brush object.

Remarks

The contents is the portion of the control excluding the title and any other visible headers.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBorderBrush Property

Calendar.ContentBorderBrush Property
[image]

Gets or sets the border brush of the calendar content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ContentBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBorderBrush As Brush

Property Value

A WPF Brush object.

Remarks

The contents is the portion of the control excluding the title and any other visible headers.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ContentBorderThickness Property

Calendar.ContentBorderThickness Property
[image]

Gets or sets the border thickness of the calendar content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ContentBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBorderThickness As Thickness

Property Value

A WPF Thickness object.

Remarks

The contents is the portion of the control excluding the title and any other visible headers.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.CurrentView Property

Calendar.CurrentView Property
[image]

Gets or sets the current view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CalendarView CurrentView { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentView As CalendarView

Property Value

A member of the CalendarView enumeration.

Remarks

The current view can be switched interactively by the user. Clicking on the calendar header with the left mouse button will drill-out to a more general view, up to the view specified by the MaxDrillOut property. Clicking on an item in the current view ill drill-in to a more specific view, down to the view specified by the MaxDrillIn property.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace
MaxDrillIn Property
MaxDrillOut Property


MindFusion.UI.Wpf.Calendar.Date Property

Calendar.Date Property
[image]

Gets or sets the currently displayed date. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

A .NET DateTime object.

Remarks

This property specifies the date range currently displayed by the control, taking into consideration the current view. For example, in a Month view the Date property will specify the displayed month.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DateSelection Property

Calendar.DateSelection Property
[image]

Gets or sets the list of dates selected in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateCollection DateSelection { get; set; }

Visual Basic [image] Copy Code

Public Property DateSelection As DateCollection

Property Value

An instance of the DateCollection class.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DayOfWeekFormat Property

Calendar.DayOfWeekFormat Property
[image]

Gets or sets the format of the days of the week displayed in the subheader. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DecadeViewFormat Property

Calendar.DecadeViewFormat Property
[image]

Gets or sets the formatting of the dates in the Decade view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string DecadeViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DecadeViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DefaultItemTemplate Property

Calendar.DefaultItemTemplate Property
[image]

Gets or sets the default template of the calendar's cells. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate DefaultItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.FocusItemTemplate Property

Calendar.FocusItemTemplate Property
[image]

Gets or sets the template of the cell containing the logical focus. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate FocusItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property FocusItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.Header Property

Calendar.Header Property
[image]

Gets or sets the content of the calendar header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Object Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Object

Property Value

Any .NET object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBackground Property

Calendar.HeaderBackground Property
[image]

Gets or sets the background of the calendar header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBackground As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBorderBrush Property

Calendar.HeaderBorderBrush Property
[image]

Gets or sets the brush of the border around the calendar header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderBorderThickness Property

Calendar.HeaderBorderThickness Property
[image]

Gets or sets the thickness of the border around the calendar header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderHeight Property

Calendar.HeaderHeight Property
[image]

Gets or sets the height of the calendar header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Double

Property Value

A double value specifying the header height, in device independent pixels.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HeaderTemplate Property

Calendar.HeaderTemplate Property
[image]

Gets or sets the template used to display the content of the calendar's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HolidayItemTemplate Property

Calendar.HolidayItemTemplate Property
[image]

Gets or sets the template of the cells representing holidays. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HolidayItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HolidayItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HolidaysDateSelection Property

Calendar.HolidaysDateSelection Property
[image]

Gets or sets a list of holiday dates. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateCollection HolidaysDateSelection { get; set; }

Visual Basic [image] Copy Code

Public Property HolidaysDateSelection As DateCollection

Property Value

A DateCollection object.

Remarks

The content of the holiday dates is displayed using the HolidayItemTemplate template.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.HoverItemTemplate Property

Calendar.HoverItemTemplate Property
[image]

Gets or sets the template of the cell pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HoverItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HoverItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.MaxDrillIn Property

Calendar.MaxDrillIn Property
[image]

Gets or sets the last view that can be drilled-in to. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CalendarView MaxDrillIn { get; set; }

Visual Basic [image] Copy Code

Public Property MaxDrillIn As CalendarView

Property Value

A member of the CalendarView enumeration.

Remarks

The user can drill-in by clicking on any cell in the current view.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace
CurrentView Property
MaxDrillOut Property


MindFusion.UI.Wpf.Calendar.MaxDrillOut Property

Calendar.MaxDrillOut Property
[image]

Gets or sets the last view that can be drilled-out to. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CalendarView MaxDrillOut { get; set; }

Visual Basic [image] Copy Code

Public Property MaxDrillOut As CalendarView

Property Value

A member of the CalendarView enumeration.

Remarks

The user can drill-out by clicking on any cell in the current view.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace
CurrentView Property
MaxDrillIn Property


MindFusion.UI.Wpf.Calendar.MonthViewFormat Property

Calendar.MonthViewFormat Property
[image]

Gets or sets the formatting of the dates in the Month view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string MonthViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property MonthViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.PaddingItemTemplate Property

Calendar.PaddingItemTemplate Property
[image]

Gets or sets the template of the padding cells. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate PaddingItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property PaddingItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionItemTemplate Property

Calendar.SelectionItemTemplate Property
[image]

Gets or sets the template of the selected cells. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate SelectionItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionMode Property

Calendar.SelectionMode Property
[image]

Gets or sets the mode of the interactive selection in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public SelectionMode SelectionMode { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionMode As SelectionMode

Property Value

A member of the SelectionMode enumeration.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SelectionOnTop Property

Calendar.SelectionOnTop Property
[image]

Gets or sets a value indicating whether the selection is displayed above the corresponding cells or below them. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool SelectionOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionOnTop As Boolean

Property Value

true; to display the selection visual over the corresponding cell; false, to display the selection visual under the corresponding cell.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ShowPaddingDays Property

Calendar.ShowPaddingDays Property
[image]

Gets or sets a value indicating whether the previous and next time intervals are displayed in the available space of the current view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool ShowPaddingDays { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPaddingDays As Boolean

Property Value

true, to display the padding dates and date intervals; otherwise, false.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.ShowToday Property

Calendar.ShowToday Property
[image]

Gets or sets a value indicating whether the current date is highlighted in the calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool ShowToday { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToday As Boolean

Property Value

true, to highlight the current date; otherwise, false.

Remarks

The current date is displayed using the TodayItemTemplate.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.SubHeaderHeight Property

Calendar.SubHeaderHeight Property
[image]

Gets or sets the height of the subheader, which displays the days of the week. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SubHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property SubHeaderHeight As Double

Property Value

A double value specifying the subheader height, in device independent pixels.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.TimeViewFormat Property

Calendar.TimeViewFormat Property
[image]

Gets or sets the formatting of the times in the Time view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string TimeViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TimeViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.TodayItemTemplate Property

Calendar.TodayItemTemplate Property
[image]

Gets or sets the template of the cell representing the current date. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate TodayItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property TodayItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekendItemTemplate Property

Calendar.WeekendItemTemplate Property
[image]

Gets or sets the template of the cells representing weekends. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate WeekendItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property WeekendItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekHeaderAlignment Property

Calendar.WeekHeaderAlignment Property
[image]

Gets or sets the alignment of the subheader, which displays the week numbers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public WeekHeaderAlignment WeekHeaderAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderAlignment As WeekHeaderAlignment

Property Value

A member of the WeekHeaderAlignment enumeration.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.WeekHeaderWidth Property

Calendar.WeekHeaderWidth Property
[image]

Gets or sets the width of the subheader, which displays the week numbers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double WeekHeaderWidth { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderWidth As Double

Property Value

A double value specifying the week header width, in device independent pixels.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.YearViewFormat Property

Calendar.YearViewFormat Property
[image]

Gets or sets the formatting of the dates in the Year view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string YearViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property YearViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar Events

Calendar Events
[image]

Public Events

Name | Description
DateClicked | Raised when the user clicks with the mouse on a specific date in the calendar.
DateSelectionChanged | Raises when the currently selected date in the calendar is changed interactively.
DrilledIn | Raised when the calendar is drilled-in interactively to a more specific view.
DrilledOut | Raised when the calendar is drilled-out interactively to a more general view.
Scrolled | Raises when the calendar is scrolled back and forth through the navigation buttons.

See Also

Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DateClicked Event

Calendar.DateClicked Event
[image]

Raised when the user clicks with the mouse on a specific date in the calendar.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> DateClicked

Visual Basic [image] Copy Code

Public Event DateClicked As EventHandler(Of DateEventArgs)

Event Data

DateClicked event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DateSelectionChanged Event

Calendar.DateSelectionChanged Event
[image]

Raises when the currently selected date in the calendar is changed interactively.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> DateSelectionChanged

Visual Basic [image] Copy Code

Public Event DateSelectionChanged As EventHandler(Of DateEventArgs)

Event Data

DateSelectionChanged event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DrilledIn Event

Calendar.DrilledIn Event
[image]

Raised when the calendar is drilled-in interactively to a more specific view.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> DrilledIn

Visual Basic [image] Copy Code

Public Event DrilledIn As EventHandler(Of EventArgs)

Event Data

DrilledIn event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.DrilledOut Event

Calendar.DrilledOut Event
[image]

Raised when the calendar is drilled-out interactively to a more general view.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> DrilledOut

Visual Basic [image] Copy Code

Public Event DrilledOut As EventHandler(Of EventArgs)

Event Data

DrilledOut event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Calendar.Scrolled Event

Calendar.Scrolled Event
[image]

Raises when the calendar is scrolled back and forth through the navigation buttons.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> Scrolled

Visual Basic [image] Copy Code

Public Event Scrolled As EventHandler(Of EventArgs)

Event Data

Scrolled event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.CalendarView Enumeration

CalendarView Enumeration
[image]

Specifies the view type in a Calendar control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum CalendarView

Visual Basic [image] Copy Code

Public Enum CalendarView

Members

Member name | Description
Century | Indicates that the calendar displays the decades in a century.
Decade | Indicates that the calendar displays the years in a decade.
Month | Indicates that the calendar displays the days of a single month.
Time | Indicates that the calendar displays the hours of a single day.
Year | Indicates that the calendar displays the months of a single year.

Remarks

Values from this enumeration can be assigned to the CurrentView, MaxDrillIn and MaxDrillOut properties of the Calendar class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Class

ColorEditor Class
Remarks See Also
[image]

Represents a control that can be used to edit colors in an RGB or HSL format.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ColorEditor : Control

Visual Basic [image] Copy Code

Public Class ColorEditor
Inherits Control

Remarks

The ColorEditor control represents a standard color editor where colors can be manipulated by modifying their Red-Green-Blue or Hue-Saturation-Luminosity components. The colors can also be picked directly from a palette. The color selected in the editor can be accessed through the SelectedColor property.

Example

The following code illustrates a ColorEditor control defined in XAML:

XAML [image] Copy Code

<ui:ColorEditor SelectedColor="LightSteelBlue" />

The image below displays the result:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.ColorEditor

See Also

ColorEditor Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Members

ColorEditor Members
Constructors Fields Properties Methods Events
[image]

Represents a control that can be used to edit colors in an RGB or HSL format.

The following tables list the members exposed by the ColorEditor type.

Public Constructors

Name | Description
ColorEditor | Initializes a new instance of the ColorEditor class.

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonForegroundProperty | Identifies the ButtonForeground dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ColorEditorModeProperty | Identifies the ColorEditorMode dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.

Public Properties

Name | Description
ButtonBackground | Gets or sets the background brush for the buttons in the editor. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush for the buttons in the editor. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness for the buttons in the editor. This is a dependency property.
ButtonForeground | Gets or sets the foreground brush for the buttons in the editor. This is a dependency property.
ButtonOverBackground | Gets or sets the background brush for the buttons in the editor when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background brush for the buttons in the editor when they pressed. This is a dependency property.
ColorEditorMode | Gets or sets the working mode of the editor. This is a dependency property.
SelectedColor | Gets or sets the color selected in the editor. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Public Events

Name | Description
AddCustomColorClick | Raised when a AddCustomColor button is clicked.
ColorBoxClick | Raised when a Color Box has been selected.
CustomColorRightButtonClick | Raised when a custom color box is clicked with the right mouse button.

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Fields

ColorEditor Fields
[image]

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonForegroundProperty | Identifies the ButtonForeground dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ColorEditorModeProperty | Identifies the ColorEditorMode dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBackgroundProperty Field

ColorEditor.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBorderBrushProperty Field

ColorEditor.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBorderThicknessProperty Field

ColorEditor.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonForegroundProperty Field

ColorEditor.ButtonForegroundProperty Field
[image]

Identifies the ButtonForeground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonForegroundProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonOverBackgroundProperty Field

ColorEditor.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonPressedBackgroundProperty Field

ColorEditor.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ColorEditorModeProperty Field

ColorEditor.ColorEditorModeProperty Field
[image]

Identifies the ColorEditorMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColorEditorModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColorEditorModeProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.SelectedColorProperty Field

ColorEditor.SelectedColorProperty Field
[image]

Identifies the SelectedColor dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedColorProperty As DependencyProperty

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Constructor

ColorEditor Constructor
[image]

Initializes a new instance of the ColorEditor class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ColorEditor ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Methods

ColorEditor Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.OnApplyTemplate Method

ColorEditor.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Properties

ColorEditor Properties
[image]

Public Properties

Name | Description
ButtonBackground | Gets or sets the background brush for the buttons in the editor. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush for the buttons in the editor. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness for the buttons in the editor. This is a dependency property.
ButtonForeground | Gets or sets the foreground brush for the buttons in the editor. This is a dependency property.
ButtonOverBackground | Gets or sets the background brush for the buttons in the editor when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background brush for the buttons in the editor when they pressed. This is a dependency property.
ColorEditorMode | Gets or sets the working mode of the editor. This is a dependency property.
SelectedColor | Gets or sets the color selected in the editor. This is a dependency property.

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBackground Property

ColorEditor.ButtonBackground Property
[image]

Gets or sets the background brush for the buttons in the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBorderBrush Property

ColorEditor.ButtonBorderBrush Property
[image]

Gets or sets the border brush for the buttons in the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonBorderThickness Property

ColorEditor.ButtonBorderThickness Property
[image]

Gets or sets the border thickness for the buttons in the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonForeground Property

ColorEditor.ButtonForeground Property
[image]

Gets or sets the foreground brush for the buttons in the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonForeground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonForeground As Brush

Property Value

A WPF Brush object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonOverBackground Property

ColorEditor.ButtonOverBackground Property
[image]

Gets or sets the background brush for the buttons in the editor when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ButtonPressedBackground Property

ColorEditor.ButtonPressedBackground Property
[image]

Gets or sets the background brush for the buttons in the editor when they pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ColorEditorMode Property

ColorEditor.ColorEditorMode Property
[image]

Gets or sets the working mode of the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ColorEditorMode ColorEditorMode { get; set; }

Visual Basic [image] Copy Code

Public Property ColorEditorMode As ColorEditorMode

Property Value

A member of the ColorEditorMode enumeration.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.SelectedColor Property

ColorEditor.SelectedColor Property
[image]

Gets or sets the color selected in the editor. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Color SelectedColor { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedColor As Color

Property Value

A WPF Color object.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor Events

ColorEditor Events
[image]

Public Events

Name | Description
AddCustomColorClick | Raised when a AddCustomColor button is clicked.
ColorBoxClick | Raised when a Color Box has been selected.
CustomColorRightButtonClick | Raised when a custom color box is clicked with the right mouse button.

See Also

ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.AddCustomColorClick Event

ColorEditor.AddCustomColorClick Event
[image]

Raised when a AddCustomColor button is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler AddCustomColorClick

Visual Basic [image] Copy Code

Public Event AddCustomColorClick As EventHandler

Event Data

AddCustomColorClick event handlers receive an argument of type EventArgs.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.ColorBoxClick Event

ColorEditor.ColorBoxClick Event
[image]

Raised when a Color Box has been selected.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ColorBoxClick

Visual Basic [image] Copy Code

Public Event ColorBoxClick As EventHandler

Event Data

ColorBoxClick event handlers receive an argument of type EventArgs.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditor.CustomColorRightButtonClick Event

ColorEditor.CustomColorRightButtonClick Event
[image]

Raised when a custom color box is clicked with the right mouse button.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CustomColorRightButtonClick

Visual Basic [image] Copy Code

Public Event CustomColorRightButtonClick As EventHandler

Event Data

CustomColorRightButtonClick event handlers receive an argument of type EventArgs.

See Also

ColorEditor Members
ColorEditor Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorEditorMode Enumeration

ColorEditorMode Enumeration
[image]

Specifies the working modes of a ColorEditor control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum ColorEditorMode

Visual Basic [image] Copy Code

Public Enum ColorEditorMode

Members

Member name | Description
ShowAllColors | The control displays both custom and predefined colors.
ShowBasicColors | The control displays only a set of predefined colors.
ShowCustomColors | The control displays only custom colors.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Class

ColorPicker Class
Remarks See Also
[image]

Represents a control that can enable users to select colors from a drop-down palette or through a specialized editor.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ColorPicker : Control

Visual Basic [image] Copy Code

Public Class ColorPicker
Inherits Control

Remarks

The color displayed in the control can be get or set through the SelectedColor property.

When the drop down panel is initially open, it displays a palette with predefined colors. The user can left-click on any of the colors to select it in the picker. In addition the user can right-click on one of the color boxes to display a custom color editor inside the drop-down panel.

Example

The following code illustrates a ColorPicker control defined in XAML:

XAML [image] Copy Code

<ui:ColorPicker SelectedColor="LightSteelBlue" />

The image below displays the picker with its drop-down open:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.ColorPicker

See Also

ColorPicker Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Members

ColorPicker Members
Constructors Fields Properties Methods Events
[image]

Represents a control that can enable users to select colors from a drop-down palette or through a specialized editor.

The following tables list the members exposed by the ColorPicker type.

Public Constructors

Name | Description
ColorPicker | Initializes a new instance of the ColorPicker class.

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the increment/decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.
SelectedColor | Gets or sets the color selected in the picker. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnDropDownClosed | Raises the DropDownClosed event.
OnDropDownOpened | Raises the DropDownOpened event.
OnKeyDown | UIElement.OnKeyDown override.

Public Events

Name | Description
DropDownClosed | Raised when the drop down editor is closed.
DropDownOpened | Raised when the drop down editor is opened.

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Fields

ColorPicker Fields
[image]

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBackgroundProperty Field

ColorPicker.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBorderBrushProperty Field

ColorPicker.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBorderThicknessProperty Field

ColorPicker.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonOverBackgroundProperty Field

ColorPicker.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonPressedBackgroundProperty Field

ColorPicker.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.SelectedColorProperty Field

ColorPicker.SelectedColorProperty Field
[image]

Identifies the SelectedColor dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedColorProperty As DependencyProperty

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Constructor

ColorPicker Constructor
[image]

Initializes a new instance of the ColorPicker class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ColorPicker ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Methods

ColorPicker Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnDropDownClosed | Raises the DropDownClosed event.
OnDropDownOpened | Raises the DropDownOpened event.
OnKeyDown | UIElement.OnKeyDown override.

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.OnApplyTemplate Method

ColorPicker.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.OnDropDownClosed Method

ColorPicker.OnDropDownClosed Method
[image]

Raises the DropDownClosed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDropDownClosed (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDropDownClosed( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.OnDropDownOpened Method

ColorPicker.OnDropDownOpened Method
[image]

Raises the DropDownOpened event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDropDownOpened (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDropDownOpened( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.OnKeyDown Method

ColorPicker.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The KeyEventArgs that contains the event data.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Properties

ColorPicker Properties
[image]

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the increment/decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.
SelectedColor | Gets or sets the color selected in the picker. This is a dependency property.

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBackground Property

ColorPicker.ButtonBackground Property
[image]

Gets or sets the background of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBorderBrush Property

ColorPicker.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonBorderThickness Property

ColorPicker.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonOverBackground Property

ColorPicker.ButtonOverBackground Property
[image]

Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.ButtonPressedBackground Property

ColorPicker.ButtonPressedBackground Property
[image]

Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.SelectedColor Property

ColorPicker.SelectedColor Property
[image]

Gets or sets the color selected in the picker. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Color SelectedColor { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedColor As Color

Property Value

A WPF Color object.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker Events

ColorPicker Events
[image]

Public Events

Name | Description
DropDownClosed | Raised when the drop down editor is closed.
DropDownOpened | Raised when the drop down editor is opened.

See Also

ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.DropDownClosed Event

ColorPicker.DropDownClosed Event
[image]

Raised when the drop down editor is closed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DropDownClosed

Visual Basic [image] Copy Code

Public Event DropDownClosed As EventHandler

Event Data

DropDownClosed event handlers receive an argument of type EventArgs.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ColorPicker.DropDownOpened Event

ColorPicker.DropDownOpened Event
[image]

Raised when the drop down editor is opened.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DropDownOpened

Visual Basic [image] Copy Code

Public Event DropDownOpened As EventHandler

Event Data

DropDownOpened event handlers receive an argument of type EventArgs.

See Also

ColorPicker Members
ColorPicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ConfirmEventArgs Class

ConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of validation events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ConfirmEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ConfirmEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.ConfirmEventArgs

See Also

ConfirmEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ConfirmEventArgs Members

ConfirmEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of validation events.

The following tables list the members exposed by the ConfirmEventArgs type.

Public Constructors

Name | Description
ConfirmEventArgs | Initializes a new instance of the ConfirmEventArgs class.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operations has been validated.

See Also

ConfirmEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ConfirmEventArgs Constructor

ConfirmEventArgs Constructor
[image]

Initializes a new instance of the ConfirmEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ConfirmEventArgs (
bool confirm
)

Visual Basic [image] Copy Code

Public New ( _
confirm As Boolean _
)

Parameters

confirm
The initial value of the Confirm property.

See Also

ConfirmEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ConfirmEventArgs Properties

ConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operations has been validated.

See Also

ConfirmEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ConfirmEventArgs.Confirm Property

ConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operations has been validated.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true, to confirm the related operation; false, to reject it.

See Also

ConfirmEventArgs Members
ConfirmEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection Class

DateCollection Class
[image]

Represents a strongly-typed collection of DateTime objects.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DateCollection : IList<DateTime>, ICollection<DateTime>, IEnumerable<DateTime>, IEnumerable

Visual Basic [image] Copy Code

Public Class DateCollection
Implements IList(Of DateTime), ICollection(Of DateTime), IEnumerable(Of DateTime), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.DateCollection

See Also

DateCollection Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection Members

DateCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of DateTime objects.

The following tables list the members exposed by the DateCollection type.

Public Constructors

Name | Description
DateCollection | Initializes a new instance of the DateCollection class.

Public Properties

Name | Description
Count | Gets the number of dates contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the date at the specified index in the collection.

Public Methods

Name | Description
Add | Adds a date to the collection.
AddRange | Adds a range of dates to the collection.
AddSingle | Replaces the current content of the collection with the specified date.
Clear | Removes all dates from the collection.
Contains | Determines whether the collection contains a specific date.
CopyTo | Copies the dates of the collection to an System.Array, starting at a particular System.Array index.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Determines the index of a specific date in the collection.
Insert | Inserts a date to the collection at the specified index.
Remove | Removes the first occurrence of a specific date from the collection.
RemoveAt | Removes the collection date at the specified index.
RemoveRange | Removes a list of dates from the collection.

See Also

DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection Constructor

DateCollection Constructor
[image]

Initializes a new instance of the DateCollection class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection Methods

DateCollection Methods
[image]

Public Methods

Name | Description
Add | Adds a date to the collection.
AddRange | Adds a range of dates to the collection.
AddSingle | Replaces the current content of the collection with the specified date.
Clear | Removes all dates from the collection.
Contains | Determines whether the collection contains a specific date.
CopyTo | Copies the dates of the collection to an System.Array, starting at a particular System.Array index.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Determines the index of a specific date in the collection.
Insert | Inserts a date to the collection at the specified index.
Remove | Removes the first occurrence of a specific date from the collection.
RemoveAt | Removes the collection date at the specified index.
RemoveRange | Removes a list of dates from the collection.

See Also

DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Add Method

DateCollection.Add Method
[image]

Adds a date to the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual void Add (
DateTime date
)

Visual Basic [image] Copy Code

Public Overridable Sub Add( _
date As DateTime _
)

Parameters

date

The date to add to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.AddRange Method

DateCollection.AddRange Method
[image]

Adds a range of dates to the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void AddRange (
List<DateTime> dateList
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
dateList As List(Of DateTime) _
)

Parameters

dateList

The dates to add to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.AddSingle Method

DateCollection.AddSingle Method
[image]

Replaces the current content of the collection with the specified date.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void AddSingle (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub AddSingle( _
date As DateTime _
)

Parameters

date

The date to become the sole element in the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Clear Method

DateCollection.Clear Method
[image]

Removes all dates from the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual void Clear ()

Visual Basic [image] Copy Code

Public Overridable Sub Clear ()

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Contains Method

DateCollection.Contains Method
[image]

Determines whether the collection contains a specific date.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual bool Contains (
DateTime date
)

Visual Basic [image] Copy Code

Public Overridable Function Contains( _
date As DateTime _
) As Boolean

Parameters

date

The date to locate in the collection.

Return Value

true if date is found in the collection; otherwise, false.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.CopyTo Method

DateCollection.CopyTo Method
[image]

Copies the dates of the collection to an System.Array, starting at a particular System.Array index.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual void CopyTo (
DateTime[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Overridable Sub CopyTo( _
array() As DateTime, _
arrayIndex As Integer _
)

Parameters

array
The one-dimensional System.Array that is the destination of the dates copied from the collection. The System.Array must have zero-based indexing.
arrayIndex

The zero-based index in array at which copying begins.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.GetEnumerator Method

DateCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Overridable Function GetEnumerator () As IEnumerator

Return Value

A System.Collections.IEnumerator that can be used to iterate through the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.IndexOf Method

DateCollection.IndexOf Method
[image]

Determines the index of a specific date in the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual int IndexOf (
DateTime date
)

Visual Basic [image] Copy Code

Public Overridable Function IndexOf( _
date As DateTime _
) As Integer

Parameters

date

The date to locate in the collection.

Return Value

The index of date if found in the list; otherwise, -1.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Insert Method

DateCollection.Insert Method
[image]

Inserts a date to the collection at the specified index.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual void Insert (
int index,
DateTime date
)

Visual Basic [image] Copy Code

Public Overridable Sub Insert( _
index As Integer, _
date As DateTime _
)

Parameters

index

The zero-based index at which date should be inserted.

date

The date to insert into the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Remove Method

DateCollection.Remove Method
[image]

Removes the first occurrence of a specific date from the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual bool Remove (
DateTime date
)

Visual Basic [image] Copy Code

Public Overridable Function Remove( _
date As DateTime _
) As Boolean

Parameters

date

The date to remove from the collection.

Return Value

true if date was successfully removed from the collection; otherwise, false.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.RemoveAt Method

DateCollection.RemoveAt Method
[image]

Removes the collection date at the specified index.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overridable Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the date to remove.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.RemoveRange Method

DateCollection.RemoveRange Method
[image]

Removes a list of dates from the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void RemoveRange (
List<DateTime> dateList
)

Visual Basic [image] Copy Code

Public Sub RemoveRange( _
dateList As List(Of DateTime) _
)

Parameters

dateList

The dates to remove from the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection Properties

DateCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of dates contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the date at the specified index in the collection.

See Also

DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Count Property

DateCollection.Count Property
[image]

Gets the number of dates contained in the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual int Count { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Count As Integer

Property Value

An integer value representing the number of dates.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.IsReadOnly Property

DateCollection.IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsReadOnly As Boolean

Property Value

This property always returns false.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateCollection.Item Property

DateCollection.Item Property
[image]

Gets or sets the date at the specified index in the collection.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public virtual DateTime Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Item( _
index As Integer _
) As DateTime

Parameters

index

The zero-based index of the date to get or set.

Property Value

The date at the specified index.

See Also

DateCollection Members
DateCollection Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateEventArgs Class

DateEventArgs Class
[image]

Contains the arguments passed to handlers of date-related events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DateEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DateEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.DateEventArgs

See Also

DateEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateEventArgs Members

DateEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of date-related events.

The following tables list the members exposed by the DateEventArgs type.

Public Constructors

Name | Description
DateEventArgs | Initializes a new instance of the DateEventArgs class.

Public Properties

Name | Description
Date | Gets the DateTime object related to the event.

See Also

DateEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateEventArgs Constructor

DateEventArgs Constructor
[image]

Initializes a new instance of the DateEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateEventArgs (
DateTime date
)

Visual Basic [image] Copy Code

Public New ( _
date As DateTime _
)

Parameters

date
The DateTime object related to the event.

See Also

DateEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateEventArgs Properties

DateEventArgs Properties
[image]

Public Properties

Name | Description
Date | Gets the DateTime object related to the event.

See Also

DateEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateEventArgs.Date Property

DateEventArgs.Date Property
[image]

Gets the DateTime object related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateTime Date { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Date As DateTime

Property Value

A .NET DateTime object related to the event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Class

DateTimePicker Class
Remarks See Also
[image]

Represents a drop-down control which enables users to select dates and times.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DateTimePicker : Control

Visual Basic [image] Copy Code

Public Class DateTimePicker
Inherits Control

Remarks

The DateTimePicker control enables users to specify dates by either typing the date in a text field or choosing the date from drop-down calendar. The DateTimePicker uses a Calendar control in its drop-down popup. Various of the calendar appearance properties can be specified directly through properties exposed by the DateTimePicker control: CalendarFontSize, CalendarWidth, CalendarHeight as well as all of the formatting and templating properties as described in the Calendar class.

Example

The following code demonstrates a DateTimePicker control defined in XAML:

XAML [image] Copy Code

<ui:DateTimePicker Height="23" VerticalAlignment="Top" CalendarWidth="240" CalendarHeight="200" />

The picker defined above will look similar to the following with its drop-down calendar open:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.DateTimePicker

See Also

DateTimePicker Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Members

DateTimePicker Members
Constructors Fields Properties Methods Events
[image]

Represents a drop-down control which enables users to select dates and times.

The following tables list the members exposed by the DateTimePicker type.

Public Constructors

Name | Description
DateTimePicker | Initializes a new instance of the DateTimePicker class.

Public Fields

Name | Description
CalendarFontSizeProperty | Identifies the CalendarFontSize dependency property.
CalendarHeaderBackgroundProperty | Identifies the CalendarHeaderBackground dependency property.
CalendarHeightProperty | Identifies the CalendarHeight dependency property.
CalendarHorizontalOffsetProperty | Identifies the CalendarHorizontalOffset dependency property.
CalendarMaxHeightProperty | Identifies the CalendarMaxHeight dependency property.
CalendarMaxWidthProperty | Identifies the CalendarMaxWidth dependency property.
CalendarMinHeightProperty | Identifies the CalendarMinHeight dependency property.
CalendarMinWidthProperty | Identifies the CalendarMinWidth dependency property.
CalendarVerticalOffsetProperty | Identifies the CalendarVerticalOffset dependency property.
CalendarWidthProperty | Identifies the CalendarWidth dependency property.
CenturyViewFormatProperty | Identifies the CenturyViewFormat dependency property.
CustomDateTimeFormatProperty | Identifies the CustomDateTimeFormat dependency property.
DecadeViewFormatProperty | Identifies the DecadeViewFormat dependency property.
DefaultItemTemplateProperty | Identifies the DefaultItemTemplate dependency property.
DisplayDateFormatProperty | Identifies the DisplayDateFormat dependency property.
DisplayDateProperty | Identifies the DisplayDate dependency property.
DropDownButtonTextBrushProperty | Identifies the DropDownButtonTextBrush dependency property.
FocusItemTemplateProperty | Identifies the FocusItemTemplate dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HoverItemTemplateProperty | Identifies the HoverItemTemplate dependency property.
IsAnimationEnabledProperty | Identifies the IsAnimationEnabled dependency property.
IsCalendarOpenProperty | Identifies the IsCalendarOpen dependency property.
IsShowingCenturiesProperty | Identifies the IsShowingCenturies dependency property.
IsShowingTimeProperty | Identifies the IsShowingTime dependency property.
MonthViewFormatProperty | Identifies the MonthViewFormat dependency property.
SelectionItemTemplateProperty | Identifies the SelectionItemTemplate dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TextBoxBorderBrushProperty | Identifies the TextBoxBorderBrush dependency property.
TimeViewFormatProperty | Identifies the TimeViewFormat dependency property.
TodayItemTemplateProperty | Identifies the TodayItemTemplate dependency property.
WeekendItemTemplateProperty | Identifies the WeekendItemTemplate dependency property.
YearViewFormatProperty | Identifies the YearViewFormat dependency property.

Public Properties

Name | Description
CalendarFontSize | Gets or sets the FontSize property of the drop-down calendar. This is a dependency property.
CalendarHeaderBackground | Gets or sets the color theme of the drop-down calendar. This is a dependency property.
CalendarHeight | Gets or sets the Height property of the drop-down calendar. This is a dependency property.
CalendarHorizontalOffset | Gets or sets the distance between the left side of the DateTimePicker control and the left side of the drop-down calendar. This is a dependency property.
CalendarMaxHeight | Gets or sets the MaxHeight property of the drop-down calendar. This is a dependency property.
CalendarMaxWidth | Gets or sets the MaxWidth property of the drop-down calendar. This is a dependency property.
CalendarMinHeight | Gets or sets the MinHeight property of the drop-down calendar. This is a dependency property.
CalendarMinWidth | Gets or sets the MinWidth property of the drop-down calendar. This is a dependency property.
CalendarVerticalOffset | Gets or sets the distance between the bottom side of the DateTimePicker control and the top side of the drop-down calendar. This is a dependency property.
CalendarWidth | Gets or sets the Width property of the drop-down calendar. This is a dependency property.
CenturyViewFormat | Gets or sets a Standard .NET DateTimeFormat string to be applied on the cells in a CenturyView. This is a dependency property.
CustomDateTimeFormat | Gets or sets the formatting of the date displayed in the picker's text box. This is a dependency property.
DecadeViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a DecadeView. This is a dependency property.
DefaultItemTemplate | Gets or sets the default template of the cells in the drop-down calendar. This is a dependency property.
DisplayDate | Gets or sets the date to display in the TextBox. This is a dependency property.
DisplayDateFormat | Gets or sets the DisplayDateFormat in the inner TextBox. This is a dependency property.
DropDownButtonTextBrush | Gets or sets the text Brush of the drop-down button. This is a dependency property.
FocusItemTemplate | Gets or sets the template of the cell containing the logical focus in the drop-down calendar control. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the header in the drop-down calendar control. This is a dependency property.
HoverItemTemplate | Gets or sets the template of the cell pointed with the mouse in the drop-down calendar control. This is a dependency property.
IsAnimationEnabled | Gets or sets a value that enables or disables the popup animation of the drop-down calendar. This is a dependency property.
IsCalendarOpen | Gets a value that indicates whether the drop-down calendar is currently open. This is a dependency property.
IsShowingCenturies | Gets or sets a value that enables or disables the Century view on the drop-down calendar. This is a dependency property.
IsShowingTime | Gets or sets a value that enables or disables the Time view on the drop-down calendar. This is a dependency property.
MonthViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a MonthView [image] . This is a dependency property.
SelectionItemTemplate | Gets or sets the template of the selected cells in the drop-down calendar. This is a dependency property.
ShowToday | Gets or sets a value indicating whether the current date is highlighted in the drop-down calendar control. This is a dependency property.
TextBoxBorderBrush | Gets or sets the BorderBrush property of the inner TextBox. This is a dependency property.
TimeViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a TimeView [image] . This is a dependency property.
TodayItemTemplate | Gets or sets the template of the cell representing the current date in the drop-down calendar. This is a dependency property.
WeekendItemTemplate | Gets or sets the template of the cells representing weekends in the drop-down calendar control. This is a dependency property.
YearViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a YearView [image] . This is a dependency property.

Public Methods

Name | Description
ClearText | Clears any text in the text box element of the DateTimePicker.
FocusText | Attempts to set focus to the TextBox element in the DateTimePicker.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SelectText | Selects a range of text in the text box element of the DateTimePicker.
SetText | Sets text to the text box element of the DateTimePicker.

Protected Methods

Name | Description
OnCalendarClosed | Raises the CalendarClosed event.
OnCalendarOpened | Raises the CalendarOpened event.
OnSelectedDateChanged | Raises the DateSelectionChanged event.

Public Events

Name | Description
CalendarClosed | Raised when the drop-down calendar is closed.
CalendarOpened | Raised when the drop-down calendar is opened.
SelectedDateChanged | Occurs when the drop-down calendar date selection changes.

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Fields

DateTimePicker Fields
[image]

Public Fields

Name | Description
CalendarFontSizeProperty | Identifies the CalendarFontSize dependency property.
CalendarHeaderBackgroundProperty | Identifies the CalendarHeaderBackground dependency property.
CalendarHeightProperty | Identifies the CalendarHeight dependency property.
CalendarHorizontalOffsetProperty | Identifies the CalendarHorizontalOffset dependency property.
CalendarMaxHeightProperty | Identifies the CalendarMaxHeight dependency property.
CalendarMaxWidthProperty | Identifies the CalendarMaxWidth dependency property.
CalendarMinHeightProperty | Identifies the CalendarMinHeight dependency property.
CalendarMinWidthProperty | Identifies the CalendarMinWidth dependency property.
CalendarVerticalOffsetProperty | Identifies the CalendarVerticalOffset dependency property.
CalendarWidthProperty | Identifies the CalendarWidth dependency property.
CenturyViewFormatProperty | Identifies the CenturyViewFormat dependency property.
CustomDateTimeFormatProperty | Identifies the CustomDateTimeFormat dependency property.
DecadeViewFormatProperty | Identifies the DecadeViewFormat dependency property.
DefaultItemTemplateProperty | Identifies the DefaultItemTemplate dependency property.
DisplayDateFormatProperty | Identifies the DisplayDateFormat dependency property.
DisplayDateProperty | Identifies the DisplayDate dependency property.
DropDownButtonTextBrushProperty | Identifies the DropDownButtonTextBrush dependency property.
FocusItemTemplateProperty | Identifies the FocusItemTemplate dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HoverItemTemplateProperty | Identifies the HoverItemTemplate dependency property.
IsAnimationEnabledProperty | Identifies the IsAnimationEnabled dependency property.
IsCalendarOpenProperty | Identifies the IsCalendarOpen dependency property.
IsShowingCenturiesProperty | Identifies the IsShowingCenturies dependency property.
IsShowingTimeProperty | Identifies the IsShowingTime dependency property.
MonthViewFormatProperty | Identifies the MonthViewFormat dependency property.
SelectionItemTemplateProperty | Identifies the SelectionItemTemplate dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TextBoxBorderBrushProperty | Identifies the TextBoxBorderBrush dependency property.
TimeViewFormatProperty | Identifies the TimeViewFormat dependency property.
TodayItemTemplateProperty | Identifies the TodayItemTemplate dependency property.
WeekendItemTemplateProperty | Identifies the WeekendItemTemplate dependency property.
YearViewFormatProperty | Identifies the YearViewFormat dependency property.

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarFontSizeProperty Field

DateTimePicker.CalendarFontSizeProperty Field
[image]

Identifies the CalendarFontSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarFontSizeProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarHeaderBackgroundProperty Field

DateTimePicker.CalendarHeaderBackgroundProperty Field
[image]

Identifies the CalendarHeaderBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarHeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarHeaderBackgroundProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarHeightProperty Field

DateTimePicker.CalendarHeightProperty Field
[image]

Identifies the CalendarHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarHeightProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarHorizontalOffsetProperty Field

DateTimePicker.CalendarHorizontalOffsetProperty Field
[image]

Identifies the CalendarHorizontalOffset dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarHorizontalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarHorizontalOffsetProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarMaxHeightProperty Field

DateTimePicker.CalendarMaxHeightProperty Field
[image]

Identifies the CalendarMaxHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarMaxHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarMaxHeightProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarMaxWidthProperty Field

DateTimePicker.CalendarMaxWidthProperty Field
[image]

Identifies the CalendarMaxWidth dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarMaxWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarMaxWidthProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarMinHeightProperty Field

DateTimePicker.CalendarMinHeightProperty Field
[image]

Identifies the CalendarMinHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarMinHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarMinHeightProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarMinWidthProperty Field

DateTimePicker.CalendarMinWidthProperty Field
[image]

Identifies the CalendarMinWidth dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarMinWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarMinWidthProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarVerticalOffsetProperty Field

DateTimePicker.CalendarVerticalOffsetProperty Field
[image]

Identifies the CalendarVerticalOffset dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarVerticalOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarVerticalOffsetProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarWidthProperty Field

DateTimePicker.CalendarWidthProperty Field
[image]

Identifies the CalendarWidth dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarWidthProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CenturyViewFormatProperty Field

DateTimePicker.CenturyViewFormatProperty Field
[image]

Identifies the CenturyViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CenturyViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CenturyViewFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CustomDateTimeFormatProperty Field

DateTimePicker.CustomDateTimeFormatProperty Field
[image]

Identifies the CustomDateTimeFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomDateTimeFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomDateTimeFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DecadeViewFormatProperty Field

DateTimePicker.DecadeViewFormatProperty Field
[image]

Identifies the DecadeViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DecadeViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DecadeViewFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DefaultItemTemplateProperty Field

DateTimePicker.DefaultItemTemplateProperty Field
[image]

Identifies the DefaultItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DisplayDateFormatProperty Field

DateTimePicker.DisplayDateFormatProperty Field
[image]

Identifies the DisplayDateFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DisplayDateFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DisplayDateFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DisplayDateProperty Field

DateTimePicker.DisplayDateProperty Field
[image]

Identifies the DisplayDate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DisplayDateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DisplayDateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DropDownButtonTextBrushProperty Field

DateTimePicker.DropDownButtonTextBrushProperty Field
[image]

Identifies the DropDownButtonTextBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DropDownButtonTextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DropDownButtonTextBrushProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.FocusItemTemplateProperty Field

DateTimePicker.FocusItemTemplateProperty Field
[image]

Identifies the FocusItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FocusItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FocusItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.HeaderTemplateProperty Field

DateTimePicker.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.HoverItemTemplateProperty Field

DateTimePicker.HoverItemTemplateProperty Field
[image]

Identifies the HoverItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HoverItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HoverItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsAnimationEnabledProperty Field

DateTimePicker.IsAnimationEnabledProperty Field
[image]

Identifies the IsAnimationEnabled dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAnimationEnabledProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsAnimationEnabledProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsCalendarOpenProperty Field

DateTimePicker.IsCalendarOpenProperty Field
[image]

Identifies the IsCalendarOpen dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsCalendarOpenProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsCalendarOpenProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsShowingCenturiesProperty Field

DateTimePicker.IsShowingCenturiesProperty Field
[image]

Identifies the IsShowingCenturies dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsShowingCenturiesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsShowingCenturiesProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsShowingTimeProperty Field

DateTimePicker.IsShowingTimeProperty Field
[image]

Identifies the IsShowingTime dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsShowingTimeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsShowingTimeProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.MonthViewFormatProperty Field

DateTimePicker.MonthViewFormatProperty Field
[image]

Identifies the MonthViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MonthViewFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.SelectionItemTemplateProperty Field

DateTimePicker.SelectionItemTemplateProperty Field
[image]

Identifies the SelectionItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.ShowTodayProperty Field

DateTimePicker.ShowTodayProperty Field
[image]

Identifies the ShowToday dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTodayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTodayProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TextBoxBorderBrushProperty Field

DateTimePicker.TextBoxBorderBrushProperty Field
[image]

Identifies the TextBoxBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextBoxBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextBoxBorderBrushProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TimeViewFormatProperty Field

DateTimePicker.TimeViewFormatProperty Field
[image]

Identifies the TimeViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimeViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TimeViewFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TodayItemTemplateProperty Field

DateTimePicker.TodayItemTemplateProperty Field
[image]

Identifies the TodayItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TodayItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.WeekendItemTemplateProperty Field

DateTimePicker.WeekendItemTemplateProperty Field
[image]

Identifies the WeekendItemTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekendItemTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeekendItemTemplateProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.YearViewFormatProperty Field

DateTimePicker.YearViewFormatProperty Field
[image]

Identifies the YearViewFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YearViewFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YearViewFormatProperty As DependencyProperty

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Constructor

DateTimePicker Constructor
[image]

Initializes a new instance of the DateTimePicker class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateTimePicker ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Methods

DateTimePicker Methods
[image]

Public Methods

Name | Description
ClearText | Clears any text in the text box element of the DateTimePicker.
FocusText | Attempts to set focus to the TextBox element in the DateTimePicker.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SelectText | Selects a range of text in the text box element of the DateTimePicker.
SetText | Sets text to the text box element of the DateTimePicker.

Protected Methods

Name | Description
OnCalendarClosed | Raises the CalendarClosed event.
OnCalendarOpened | Raises the CalendarOpened event.
OnSelectedDateChanged | Raises the DateSelectionChanged event.

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.ClearText Method

DateTimePicker.ClearText Method
[image]

Clears any text in the text box element of the DateTimePicker.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void ClearText ()

Visual Basic [image] Copy Code

Public Sub ClearText ()

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.FocusText Method

DateTimePicker.FocusText Method
[image]

Attempts to set focus to the TextBox element in the DateTimePicker.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool FocusText ()

Visual Basic [image] Copy Code

Public Function FocusText () As Boolean

Return Value

true if keyboard focus and logical focus were set to this element; otherwise, false.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.OnApplyTemplate Method

DateTimePicker.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.OnCalendarClosed Method

DateTimePicker.OnCalendarClosed Method
[image]

Raises the CalendarClosed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCalendarClosed (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCalendarClosed( _
e As EventArgs _
)

Parameters

e
The object that contains the event data.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.OnCalendarOpened Method

DateTimePicker.OnCalendarOpened Method
[image]

Raises the CalendarOpened event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnCalendarOpened (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCalendarOpened( _
e As EventArgs _
)

Parameters

e
The object that contains the event data.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.OnSelectedDateChanged Method

DateTimePicker.OnSelectedDateChanged Method
[image]

Raises the DateSelectionChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectedDateChanged (
DateEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectedDateChanged ( _
e As DateEventArgs _
)

Parameters

e
The object that contains the event data.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.SelectText Method

DateTimePicker.SelectText Method
[image]

Selects a range of text in the text box element of the DateTimePicker.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void SelectText (
int start,
int length
)

Visual Basic [image] Copy Code

Public Sub SelectText( _
start As Integer, _
length As Integer _
)

Parameters

start

The zero-based character index of the first character in the selection.

length

The length of the selection, in characters.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.SetText Method

DateTimePicker.SetText Method
[image]

Sets text to the text box element of the DateTimePicker.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void SetText (
string text
)

Visual Basic [image] Copy Code

Public Sub SetText( _
text As String _
)

Parameters

text

text to be set.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Properties

DateTimePicker Properties
[image]

Public Properties

Name | Description
CalendarFontSize | Gets or sets the FontSize property of the drop-down calendar. This is a dependency property.
CalendarHeaderBackground | Gets or sets the color theme of the drop-down calendar. This is a dependency property.
CalendarHeight | Gets or sets the Height property of the drop-down calendar. This is a dependency property.
CalendarHorizontalOffset | Gets or sets the distance between the left side of the DateTimePicker control and the left side of the drop-down calendar. This is a dependency property.
CalendarMaxHeight | Gets or sets the MaxHeight property of the drop-down calendar. This is a dependency property.
CalendarMaxWidth | Gets or sets the MaxWidth property of the drop-down calendar. This is a dependency property.
CalendarMinHeight | Gets or sets the MinHeight property of the drop-down calendar. This is a dependency property.
CalendarMinWidth | Gets or sets the MinWidth property of the drop-down calendar. This is a dependency property.
CalendarVerticalOffset | Gets or sets the distance between the bottom side of the DateTimePicker control and the top side of the drop-down calendar. This is a dependency property.
CalendarWidth | Gets or sets the Width property of the drop-down calendar. This is a dependency property.
CenturyViewFormat | Gets or sets a Standard .NET DateTimeFormat string to be applied on the cells in a CenturyView. This is a dependency property.
CustomDateTimeFormat | Gets or sets the formatting of the date displayed in the picker's text box. This is a dependency property.
DecadeViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a DecadeView. This is a dependency property.
DefaultItemTemplate | Gets or sets the default template of the cells in the drop-down calendar. This is a dependency property.
DisplayDate | Gets or sets the date to display in the TextBox. This is a dependency property.
DisplayDateFormat | Gets or sets the DisplayDateFormat in the inner TextBox. This is a dependency property.
DropDownButtonTextBrush | Gets or sets the text Brush of the drop-down button. This is a dependency property.
FocusItemTemplate | Gets or sets the template of the cell containing the logical focus in the drop-down calendar control. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the header in the drop-down calendar control. This is a dependency property.
HoverItemTemplate | Gets or sets the template of the cell pointed with the mouse in the drop-down calendar control. This is a dependency property.
IsAnimationEnabled | Gets or sets a value that enables or disables the popup animation of the drop-down calendar. This is a dependency property.
IsCalendarOpen | Gets a value that indicates whether the drop-down calendar is currently open. This is a dependency property.
IsShowingCenturies | Gets or sets a value that enables or disables the Century view on the drop-down calendar. This is a dependency property.
IsShowingTime | Gets or sets a value that enables or disables the Time view on the drop-down calendar. This is a dependency property.
MonthViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a MonthView [image] . This is a dependency property.
SelectionItemTemplate | Gets or sets the template of the selected cells in the drop-down calendar. This is a dependency property.
ShowToday | Gets or sets a value indicating whether the current date is highlighted in the drop-down calendar control. This is a dependency property.
TextBoxBorderBrush | Gets or sets the BorderBrush property of the inner TextBox. This is a dependency property.
TimeViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a TimeView [image] . This is a dependency property.
TodayItemTemplate | Gets or sets the template of the cell representing the current date in the drop-down calendar. This is a dependency property.
WeekendItemTemplate | Gets or sets the template of the cells representing weekends in the drop-down calendar control. This is a dependency property.
YearViewFormat | Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a YearView [image] . This is a dependency property.

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarFontSize Property

DateTimePicker.CalendarFontSize Property
[image]

Gets or sets the FontSize property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarFontSize As Double

Property Value

A double value specifying the font size.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarHeaderBackground Property

DateTimePicker.CalendarHeaderBackground Property
[image]

Gets or sets the color theme of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush CalendarHeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarHeaderBackground As Brush

Property Value

A WPF Brush object.

Remarks

The HeaderBackground property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarHeight Property

DateTimePicker.CalendarHeight Property
[image]

Gets or sets the Height property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarHeight As Double

Property Value

A double value specifying the height of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarWidth Property
CalendarMaxHeight Property
CalendarMinHeight Property


MindFusion.UI.Wpf.DateTimePicker.CalendarHorizontalOffset Property

DateTimePicker.CalendarHorizontalOffset Property
[image]

Gets or sets the distance between the left side of the DateTimePicker control and the left side of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarHorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarHorizontalOffset As Double

Property Value

A double value indicating the horizontal offset of the drop-down calendar.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarVerticalOffset Property


MindFusion.UI.Wpf.DateTimePicker.CalendarMaxHeight Property

DateTimePicker.CalendarMaxHeight Property
[image]

Gets or sets the MaxHeight property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarMaxHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarMaxHeight As Double

Property Value

A double value specifying the maximum height of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarMinHeight Property
CalendarHeight Property


MindFusion.UI.Wpf.DateTimePicker.CalendarMaxWidth Property

DateTimePicker.CalendarMaxWidth Property
[image]

Gets or sets the MaxWidth property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarMaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarMaxWidth As Double

Property Value

A double value specifying the maximum width of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarMinWidth Property
CalendarWidth Property


MindFusion.UI.Wpf.DateTimePicker.CalendarMinHeight Property

DateTimePicker.CalendarMinHeight Property
[image]

Gets or sets the MinHeight property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarMinHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarMinHeight As Double

Property Value

A double value specifying the minimum height of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarMaxHeight Property
CalendarHeight Property


MindFusion.UI.Wpf.DateTimePicker.CalendarMinWidth Property

DateTimePicker.CalendarMinWidth Property
[image]

Gets or sets the MinWidth property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarMinWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarMinWidth As Double

Property Value

A double value specifying the minimum width of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarMaxWidth Property
CalendarWidth Property


MindFusion.UI.Wpf.DateTimePicker.CalendarVerticalOffset Property

DateTimePicker.CalendarVerticalOffset Property
[image]

Gets or sets the distance between the bottom side of the DateTimePicker control and the top side of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarVerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarVerticalOffset As Double

Property Value

A double value indicating the vertical offset of the drop-down calendar.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarHorizontalOffset Property


MindFusion.UI.Wpf.DateTimePicker.CalendarWidth Property

DateTimePicker.CalendarWidth Property
[image]

Gets or sets the Width property of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double CalendarWidth { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarWidth As Double

Property Value

A double value specifying the width of the drop-down calendar, in device-independent units.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace
CalendarHeight Property
CalendarMaxWidth Property
CalendarMinWidth Property


MindFusion.UI.Wpf.DateTimePicker.CenturyViewFormat Property

DateTimePicker.CenturyViewFormat Property
[image]

Gets or sets a Standard .NET DateTimeFormat string to be applied on the cells in a CenturyView. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string CenturyViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CenturyViewFormat As String

Property Value

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CustomDateTimeFormat Property

DateTimePicker.CustomDateTimeFormat Property
[image]

Gets or sets the formatting of the date displayed in the picker's text box. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string CustomDateTimeFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDateTimeFormat As String

Property Value

A formatting string.

Remarks

If the value of this property is null (Nothing in Visual Basic) or an empty string, the date in the text box will be formatted as Short. The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DecadeViewFormat Property

DateTimePicker.DecadeViewFormat Property
[image]

Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a DecadeView. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string DecadeViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DecadeViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DefaultItemTemplate Property

DateTimePicker.DefaultItemTemplate Property
[image]

Gets or sets the default template of the cells in the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate DefaultItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The DefaultItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DisplayDate Property

DateTimePicker.DisplayDate Property
[image]

Gets or sets the date to display in the TextBox. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DateTime DisplayDate { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayDate As DateTime

Property Value

A .NET DateTime object.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DisplayDateFormat Property

DateTimePicker.DisplayDateFormat Property
[image]

Gets or sets the DisplayDateFormat in the inner TextBox. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DisplayDateFormat DisplayDateFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayDateFormat As DisplayDateFormat

Property Value

A member of the DisplayDateFormat enumeration. The default is Short.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.DropDownButtonTextBrush Property

DateTimePicker.DropDownButtonTextBrush Property
[image]

Gets or sets the text Brush of the drop-down button. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush DropDownButtonTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DropDownButtonTextBrush As Brush

Property Value

A WPF Brush object.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.FocusItemTemplate Property

DateTimePicker.FocusItemTemplate Property
[image]

Gets or sets the template of the cell containing the logical focus in the drop-down calendar control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate FocusItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property FocusItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The FocusItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.HeaderTemplate Property

DateTimePicker.HeaderTemplate Property
[image]

Gets or sets the template used to display the content of the header in the drop-down calendar control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The HeaderTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.HoverItemTemplate Property

DateTimePicker.HoverItemTemplate Property
[image]

Gets or sets the template of the cell pointed with the mouse in the drop-down calendar control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HoverItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HoverItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The HoverItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsAnimationEnabled Property

DateTimePicker.IsAnimationEnabled Property
[image]

Gets or sets a value that enables or disables the popup animation of the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsAnimationEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsAnimationEnabled As Boolean

Property Value

true to enable the drop-down animation; otherwise, false.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsCalendarOpen Property

DateTimePicker.IsCalendarOpen Property
[image]

Gets a value that indicates whether the drop-down calendar is currently open. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsCalendarOpen { get; set; }

Visual Basic [image] Copy Code

Public Property IsCalendarOpen As Boolean

Property Value

true if the drop-down is opened; otherwise, false.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsShowingCenturies Property

DateTimePicker.IsShowingCenturies Property
[image]

Gets or sets a value that enables or disables the Century view on the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsShowingCenturies { get; set; }

Visual Basic [image] Copy Code

Public Property IsShowingCenturies As Boolean

Property Value

true if the CurrentView property of the drop-down calendar is Century; otherwise, false.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.IsShowingTime Property

DateTimePicker.IsShowingTime Property
[image]

Gets or sets a value that enables or disables the Time view on the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsShowingTime { get; set; }

Visual Basic [image] Copy Code

Public Property IsShowingTime As Boolean

Property Value

true if the CurrentView property of the drop-down calendar is Time; otherwise, false.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.MonthViewFormat Property

DateTimePicker.MonthViewFormat Property
[image]

Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a MonthView. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string MonthViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property MonthViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.SelectionItemTemplate Property

DateTimePicker.SelectionItemTemplate Property
[image]

Gets or sets the template of the selected cells in the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate SelectionItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The SelectionItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.ShowToday Property

DateTimePicker.ShowToday Property
[image]

Gets or sets a value indicating whether the current date is highlighted in the drop-down calendar control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool ShowToday { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToday As Boolean

Property Value

true to highlight the current date in the drop-down calendar; otherwise, false.

Remarks

If this property is set to true the content of the current date is displayed using TodayItemTemplate. Otherwise, the content is displayed using DefaultItemTemplate.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TextBoxBorderBrush Property

DateTimePicker.TextBoxBorderBrush Property
[image]

Gets or sets the BorderBrush property of the inner TextBox. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TextBoxBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBoxBorderBrush As Brush

Property Value

A WPF Brush object. The default is White.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TimeViewFormat Property

DateTimePicker.TimeViewFormat Property
[image]

Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a TimeView. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string TimeViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TimeViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.TodayItemTemplate Property

DateTimePicker.TodayItemTemplate Property
[image]

Gets or sets the template of the cell representing the current date in the drop-down calendar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate TodayItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property TodayItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The TodayItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.WeekendItemTemplate Property

DateTimePicker.WeekendItemTemplate Property
[image]

Gets or sets the template of the cells representing weekends in the drop-down calendar control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate WeekendItemTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property WeekendItemTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

Remarks

The WeekendItemTemplate property of the drop-down calendar is bound to this property.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.YearViewFormat Property

DateTimePicker.YearViewFormat Property
[image]

Gets or sets a Standard .NET DateTimeFormat [image] string to be applied on the cells in a YearView. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string YearViewFormat { get; set; }

Visual Basic [image] Copy Code

Public Property YearViewFormat As String

Property Value

A formatting string.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker Events

DateTimePicker Events
[image]

Public Events

Name | Description
CalendarClosed | Raised when the drop-down calendar is closed.
CalendarOpened | Raised when the drop-down calendar is opened.
SelectedDateChanged | Occurs when the drop-down calendar date selection changes.

See Also

DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarClosed Event

DateTimePicker.CalendarClosed Event
[image]

Raised when the drop-down calendar is closed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CalendarClosed

Visual Basic [image] Copy Code

Public Event CalendarClosed As EventHandler

Event Data

CalendarClosed event handlers receive an argument of type EventArgs.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.CalendarOpened Event

DateTimePicker.CalendarOpened Event
[image]

Raised when the drop-down calendar is opened.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler CalendarOpened

Visual Basic [image] Copy Code

Public Event CalendarOpened As EventHandler

Event Data

CalendarOpened event handlers receive an argument of type EventArgs.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DateTimePicker.SelectedDateChanged Event

DateTimePicker.SelectedDateChanged Event
[image]

Occurs when the drop-down calendar date selection changes.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> SelectedDateChanged

Visual Basic [image] Copy Code

Public Event SelectedDateChanged As EventHandler(Of DateEventArgs)

Event Data

SelectedDateChanged event handlers receive an argument of type DateEventArgs.

See Also

DateTimePicker Members
DateTimePicker Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration
[image]

Specifies the display format of a day of the week.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum DayOfWeekFormat

Visual Basic [image] Copy Code

Public Enum DayOfWeekFormat

Members

Member name | Description
Abbreviated | The first three letters of the day of the week are displayed.
Full | The complete name of the day of the week is displayed.
SingleLetter | Only the first letter of the name of the day is displayed.

Remarks

Values from this enumeration are be assigned to the DayOfWeekFormat property of the Calendar class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DisplayDateFormat Enumeration

DisplayDateFormat Enumeration
[image]

Specifies how dates are displayed in the DateTimePicker control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum DisplayDateFormat

Visual Basic [image] Copy Code

Public Enum DisplayDateFormat

Members

Member name | Description
Long | Indicates that dates are formatted with a long date pattern.
Short | Indicates that dates are formatted with a short date pattern.
Custom | Indicates that dates are formatted with a custom date pattern.

Remarks

Values from this enumeration are assigned to the DisplayDateFormat property of the DateTimePicker class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Dock Enumeration

Dock Enumeration
[image]

Specifies a dock destination.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum Dock

Visual Basic [image] Copy Code

Public Enum Dock

Members

Member name | Description
Bottom | Indicates docking to the bottom side.
Center | Indicates docking in the middle.
Left | Indicates docking to the left side.
Right | Indicates docking to the right side.
Top | Indicates docking to the top side.

Remarks

Values from this enumeration are assigned to the Dock property of the DockItem class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Class

DockControl Class
Remarks See Also
[image]

Enables docking of user interface elements.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DockControl : ItemsControl

Visual Basic [image] Copy Code

Public Class DockControl
Inherits ItemsControl

Remarks

The DockControl enables interactive and programmatic docking of UI elements inside a container. In order to dock elements inside the DockControl they must be explicitly or implicitly wrapped in a DockItem objects. The following example declares a DockControl in XAML and adds two child controls to it - a ListBox and a StackPanel. The first child is docked implicitly.

XAML [image] Copy Code

<ui:DockControl Padding="0">
<ListBox>
<ListBoxItem Content="item 1" />
</ListBox>
<ui:DockItem Dock="Right">
<StackPanel Orientation="Vertical">
<Button Content="Button 1" Margin="0,0,0,5" />
<Button Content="Button 2" />
</StackPanel>
</ui:DockItem>
</ui:DockControl>

Items can be added and removed from the DockControl programmatically - through the AddItem, RemoveItem and RemoveAllItems methods.

Users can reposition, dock and undock controls inside the DockControl interactively, by left-clicking on the header of the respective DockItem, holding down the mouse button and dragging.

Example

The following image illustrates a DockControl with several items docked inside:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.UI.Wpf.DockControl

See Also

DockControl Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Members

DockControl Members
Constructors Fields Properties Methods Events
[image]

Enables docking of user interface elements.

The following tables list the members exposed by the DockControl type.

Public Constructors

Name | Description
DockControl | Initializes a new instance of the DockControl class.

Public Fields

Name | Description
AllowedDockLocationsProperty | Identifies the AllowedDockLocations dependency property.
AnimateWindowsProperty | Identifies the AnimateWindows dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DockIndicatorBackgroundProperty | Identifies the DockIndicatorBackground dependency property.
DockIndicatorBorderBrushProperty | Identifies the DockIndicatorBorderBrush dependency property.
DockIndicatorBorderThicknessProperty | Identifies the DockIndicatorBorderThickness dependency property.
HandlersBackgroundProperty | Identifies the HandlersBackground dependency property.
HandlersBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HandlersBorderThicknessProperty | Identifies the HandlersBorderThickness dependency property.
HandlersOverBackgroundProperty | Identifies the HandlersOverBackground dependency property.
HandlersPressedBackgroundProperty | Identifies the HandlersPressedBackground dependency property.
ItemContainerBackgroundProperty | Identifies the ItemContainerBackground dependency property.
ItemSpacingProperty | Identifies the ItemSpacing dependency property.
MinimumItemSizeProperty | Identifies the MinimumItemSize dependency property.
PanelOffsetProperty | Identifies the PanelOffset dependency property.
RelativeDropSizeProperty | Identifies the RelativeDropSize dependency property.
TabBackgroundProperty | Identifies the TabBackground dependency property.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property.
TabOverBackgroundProperty | Identifies the TabOverBackground dependency property.
TabPressedBackgroundProperty | Identifies the TabPressedBackground dependency property.
TabSelectedBackgroundProperty | Identifies the TabSelectedBackground dependency property.

Public Properties

Name | Description
AllowedDockLocations | Gets or sets the possible dock locations inside this control. This is a dependency property.
AnimateWindows | Gets or sets a value indicating whether the operations on the items inside this control are animated. This is a dependency property.
CornerRadius | Gets or sets the roundness of the frame edges of this dock control. This is a dependency property.
DockIndicatorBackground | Gets or sets the background of the dock indicator areas. This is a dependency property.
DockIndicatorBorderBrush | Gets or sets the border brush of the dock indicator areas. This is a dependency property.
DockIndicatorBorderThickness | Gets or sets the border thickness of the dock indicator areas. This is a dependency property.
HandlersBackground | Gets or sets the background of the dock handlers and buttons. This is a dependency property.
HandlersBorderBrush | Gets or sets the border brush of the dock handlers and buttons. This is a dependency property.
HandlersBorderThickness | Gets or sets the border thickness of the dock handlers and buttons. This is a dependency property.
HandlersOverBackground | Gets or sets the background of the dock handlers and buttons when they are pointed with the mouse. This is a dependency property.
HandlersPressedBackground | Gets or sets the background of the dock handlers and buttons when they are pressed. This is a dependency property.
ItemContainerBackground | Gets or sets the background of container dock items. This is a dependency property.
ItemSpacing | Gets or sets the distance between adjacent docked items. This is a dependency property.
MinimumItemSize | Gets or sets the minimum size of the docked items. This is a dependency property.
PanelOffset | Gets or sets the portions of the control that are occupied by docked items. This is a dependency property.
RelativeDropSize | Gets or sets default size of items docked inside this DockControl, expressed as percentage of the control's size. This is a dependency property.
TabBackground | Gets or sets the background of tab items. This is a dependency property.
TabBorderBrush | Gets or sets the border brush of tab items. This is a dependency property.
TabOverBackground | Gets or sets the background of tab items pointed with the mouse. This is a dependency property.
TabPressedBackground | Gets or sets the background of pressed tab items. This is a dependency property.
TabSelectedBackground | Gets or sets the background of selected tab items. This is a dependency property.

Public Methods

Name | Description
AddItem | Adds the specified item to the DockControl. The initial positioning of the item is determined by its DockTarget and State properties.
GetAllItems | Returns a list with all items in the DockControl.
Load | Restores the last saved state of the control.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
RemoveAllItems | Removes all items form the DockControl.
RemoveItem | Removes the specified item from the DockControl.
Save | Saves the current state of the control.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnClosed | Raises the Closed event.
OnClosing | Raises the Closing event.
OnDockCompleted | Raises the DockCompleted event.
OnDockStarted | Raises the DockStarted event.
OnDragCompleted | Raises the DragCompleted event.
OnDragStarted | Raises the DragStarted event.
OnItemsChanged | ItemsControl.OnItemsChanged override.
OnItemStateChanged | Raises the ItemStateChanged event.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
Closed | Raised when a DockItem is closed.
Closing | Raised before the DockItem is closed in order to confirm the operation.
DockCompleted | Raised when an item has been docked.
DockStarted | Raised when the user is about to dock an item.
DragCompleted | Raised when a drag operation is completed.
DragStarted | Raised when the user initiates a drag operation.
ItemStateChanged | Raised when the state of an item has changed.

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Fields

DockControl Fields
[image]

Public Fields

Name | Description
AllowedDockLocationsProperty | Identifies the AllowedDockLocations dependency property.
AnimateWindowsProperty | Identifies the AnimateWindows dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DockIndicatorBackgroundProperty | Identifies the DockIndicatorBackground dependency property.
DockIndicatorBorderBrushProperty | Identifies the DockIndicatorBorderBrush dependency property.
DockIndicatorBorderThicknessProperty | Identifies the DockIndicatorBorderThickness dependency property.
HandlersBackgroundProperty | Identifies the HandlersBackground dependency property.
HandlersBorderBrushProperty | Identifies the HeaderBorderBrush dependency property.
HandlersBorderThicknessProperty | Identifies the HandlersBorderThickness dependency property.
HandlersOverBackgroundProperty | Identifies the HandlersOverBackground dependency property.
HandlersPressedBackgroundProperty | Identifies the HandlersPressedBackground dependency property.
ItemContainerBackgroundProperty | Identifies the ItemContainerBackground dependency property.
ItemSpacingProperty | Identifies the ItemSpacing dependency property.
MinimumItemSizeProperty | Identifies the MinimumItemSize dependency property.
PanelOffsetProperty | Identifies the PanelOffset dependency property.
RelativeDropSizeProperty | Identifies the RelativeDropSize dependency property.
TabBackgroundProperty | Identifies the TabBackground dependency property.
TabBorderBrushProperty | Identifies the TabBorderBrush dependency property.
TabOverBackgroundProperty | Identifies the TabOverBackground dependency property.
TabPressedBackgroundProperty | Identifies the TabPressedBackground dependency property.
TabSelectedBackgroundProperty | Identifies the TabSelectedBackground dependency property.

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.AllowedDockLocationsProperty Field

DockControl.AllowedDockLocationsProperty Field
[image]

Identifies the AllowedDockLocations dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowedDockLocationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowedDockLocationsProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.AnimateWindowsProperty Field

DockControl.AnimateWindowsProperty Field
[image]

Identifies the AnimateWindows dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnimateWindowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnimateWindowsProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.CornerRadiusProperty Field

DockControl.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBackgroundProperty Field

DockControl.DockIndicatorBackgroundProperty Field
[image]

Identifies the DockIndicatorBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockIndicatorBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockIndicatorBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBorderBrushProperty Field

DockControl.DockIndicatorBorderBrushProperty Field
[image]

Identifies the DockIndicatorBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockIndicatorBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockIndicatorBorderBrushProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBorderThicknessProperty Field

DockControl.DockIndicatorBorderThicknessProperty Field
[image]

Identifies the DockIndicatorBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockIndicatorBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockIndicatorBorderThicknessProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBackgroundProperty Field

DockControl.HandlersBackgroundProperty Field
[image]

Identifies the HandlersBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlersBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlersBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBorderBrushProperty Field

DockControl.HandlersBorderBrushProperty Field
[image]

Identifies the HeaderBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlersBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlersBorderBrushProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBorderThicknessProperty Field

DockControl.HandlersBorderThicknessProperty Field
[image]

Identifies the HandlersBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlersBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlersBorderThicknessProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersOverBackgroundProperty Field

DockControl.HandlersOverBackgroundProperty Field
[image]

Identifies the HandlersOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlersOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlersOverBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersPressedBackgroundProperty Field

DockControl.HandlersPressedBackgroundProperty Field
[image]

Identifies the HandlersPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlersPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlersPressedBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.ItemContainerBackgroundProperty Field

DockControl.ItemContainerBackgroundProperty Field
[image]

Identifies the ItemContainerBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemContainerBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemContainerBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.ItemSpacingProperty Field

DockControl.ItemSpacingProperty Field
[image]

Identifies the ItemSpacing dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSpacingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSpacingProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.MinimumItemSizeProperty Field

DockControl.MinimumItemSizeProperty Field
[image]

Identifies the MinimumItemSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumItemSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumItemSizeProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.PanelOffsetProperty Field

DockControl.PanelOffsetProperty Field
[image]

Identifies the PanelOffset dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PanelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PanelOffsetProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.RelativeDropSizeProperty Field

DockControl.RelativeDropSizeProperty Field
[image]

Identifies the RelativeDropSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RelativeDropSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RelativeDropSizeProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabBackgroundProperty Field

DockControl.TabBackgroundProperty Field
[image]

Identifies the TabBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabBorderBrushProperty Field

DockControl.TabBorderBrushProperty Field
[image]

Identifies the TabBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabBorderBrushProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabOverBackgroundProperty Field

DockControl.TabOverBackgroundProperty Field
[image]

Identifies the TabOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabOverBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabPressedBackgroundProperty Field

DockControl.TabPressedBackgroundProperty Field
[image]

Identifies the TabPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabPressedBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabSelectedBackgroundProperty Field

DockControl.TabSelectedBackgroundProperty Field
[image]

Identifies the TabSelectedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabSelectedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabSelectedBackgroundProperty As DependencyProperty

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Constructor

DockControl Constructor
[image]

Initializes a new instance of the DockControl class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Methods

DockControl Methods
[image]

Public Methods

Name | Description
AddItem | Adds the specified item to the DockControl. The initial positioning of the item is determined by its DockTarget and State properties.
GetAllItems | Returns a list with all items in the DockControl.
Load | Restores the last saved state of the control.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
RemoveAllItems | Removes all items form the DockControl.
RemoveItem | Removes the specified item from the DockControl.
Save | Saves the current state of the control.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnClosed | Raises the Closed event.
OnClosing | Raises the Closing event.
OnDockCompleted | Raises the DockCompleted event.
OnDockStarted | Raises the DockStarted event.
OnDragCompleted | Raises the DragCompleted event.
OnDragStarted | Raises the DragStarted event.
OnItemsChanged | ItemsControl.OnItemsChanged override.
OnItemStateChanged | Raises the ItemStateChanged event.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPreviewMouseDown | UIElement.OnPreviewMouseDown override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.AddItem Method

DockControl.AddItem Method
[image]

Adds the specified item to the DockControl. The initial positioning of the item is determined by its DockTarget and State properties.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void AddItem (
DockItem item
)

Visual Basic [image] Copy Code

Public Sub AddItem ( _
item As DockItem _
)

Parameters

item

The item to add.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.GetAllItems Method

DockControl.GetAllItems Method
[image]

Returns a list with all items in the DockControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public List<DockItem> GetAllItems (
bool includingContainers
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
includingContainers As Boolean _
) As List(Of DockItem)

Parameters

includingContainers
true to include container items; otherwise, false.

Return Value

A list with DockItem objects.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.GetContainerForItemOverride Method

DockControl.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overridable Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.IsItemItsOwnContainerOverride Method

DockControl.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.Load Method

DockControl.Load Method
[image]

Restores the last saved state of the control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void Load ()

Visual Basic [image] Copy Code

Public Sub Load ()

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace
Save Method


MindFusion.UI.Wpf.DockControl.OnApplyTemplate Method

DockControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnClosed Method

DockControl.OnClosed Method
[image]

Raises the Closed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClosed (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClosed ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnClosing Method

DockControl.OnClosing Method
[image]

Raises the Closing event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClosing (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClosing ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnDockCompleted Method

DockControl.OnDockCompleted Method
[image]

Raises the DockCompleted event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDockCompleted (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDockCompleted ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnDockStarted Method

DockControl.OnDockStarted Method
[image]

Raises the DockStarted event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDockStarted (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDockStarted ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnDragCompleted Method

DockControl.OnDragCompleted Method
[image]

Raises the DragCompleted event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDragCompleted (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDragCompleted ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnDragStarted Method

DockControl.OnDragStarted Method
[image]

Raises the DragStarted event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDragStarted (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDragStarted ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnItemsChanged Method

DockControl.OnItemsChanged Method
[image]

ItemsControl.OnItemsChanged override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemsChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemsChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

Information about the change.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnItemStateChanged Method

DockControl.OnItemStateChanged Method
[image]

Raises the ItemStateChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemStateChanged (
DockEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemStateChanged ( _
e As DockEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnMouseLeftButtonDown Method

DockControl.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnMouseLeftButtonUp Method

DockControl.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseLeftButtonUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnMouseMove Method

DockControl.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.OnPreviewMouseDown Method

DockControl.OnPreviewMouseDown Method
[image]

UIElement.OnPreviewMouseDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.PrepareContainerForItemOverride Method

DockControl.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.RemoveAllItems Method

DockControl.RemoveAllItems Method
[image]

Removes all items form the DockControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void RemoveAllItems ()

Visual Basic [image] Copy Code

Public Sub RemoveAllItems ()

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.RemoveItem Method

DockControl.RemoveItem Method
[image]

Removes the specified item from the DockControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void RemoveItem (
DockItem item
)

Visual Basic [image] Copy Code

Public Sub RemoveItem ( _
item As DockItem _
)

Parameters

item

The item to remove.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.Save Method

DockControl.Save Method
[image]

Saves the current state of the control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public void Save ()

Visual Basic [image] Copy Code

Public Sub Save ()

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace
Load Method


MindFusion.UI.Wpf.DockControl Properties

DockControl Properties
[image]

Public Properties

Name | Description
AllowedDockLocations | Gets or sets the possible dock locations inside this control. This is a dependency property.
AnimateWindows | Gets or sets a value indicating whether the operations on the items inside this control are animated. This is a dependency property.
CornerRadius | Gets or sets the roundness of the frame edges of this dock control. This is a dependency property.
DockIndicatorBackground | Gets or sets the background of the dock indicator areas. This is a dependency property.
DockIndicatorBorderBrush | Gets or sets the border brush of the dock indicator areas. This is a dependency property.
DockIndicatorBorderThickness | Gets or sets the border thickness of the dock indicator areas. This is a dependency property.
HandlersBackground | Gets or sets the background of the dock handlers and buttons. This is a dependency property.
HandlersBorderBrush | Gets or sets the border brush of the dock handlers and buttons. This is a dependency property.
HandlersBorderThickness | Gets or sets the border thickness of the dock handlers and buttons. This is a dependency property.
HandlersOverBackground | Gets or sets the background of the dock handlers and buttons when they are pointed with the mouse. This is a dependency property.
HandlersPressedBackground | Gets or sets the background of the dock handlers and buttons when they are pressed. This is a dependency property.
ItemContainerBackground | Gets or sets the background of container dock items. This is a dependency property.
ItemSpacing | Gets or sets the distance between adjacent docked items. This is a dependency property.
MinimumItemSize | Gets or sets the minimum size of the docked items. This is a dependency property.
PanelOffset | Gets or sets the portions of the control that are occupied by docked items. This is a dependency property.
RelativeDropSize | Gets or sets default size of items docked inside this DockControl, expressed as percentage of the control's size. This is a dependency property.
TabBackground | Gets or sets the background of tab items. This is a dependency property.
TabBorderBrush | Gets or sets the border brush of tab items. This is a dependency property.
TabOverBackground | Gets or sets the background of tab items pointed with the mouse. This is a dependency property.
TabPressedBackground | Gets or sets the background of pressed tab items. This is a dependency property.
TabSelectedBackground | Gets or sets the background of selected tab items. This is a dependency property.

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.AllowedDockLocations Property

DockControl.AllowedDockLocations Property
[image]

Gets or sets the possible dock locations inside this control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockLocations AllowedDockLocations { get; set; }

Visual Basic [image] Copy Code

Public Property AllowedDockLocations As DockLocations

Property Value

A member of the DockLocations enumeration. The default is All.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.AnimateWindows Property

DockControl.AnimateWindows Property
[image]

Gets or sets a value indicating whether the operations on the items inside this control are animated. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool AnimateWindows { get; set; }

Visual Basic [image] Copy Code

Public Property AnimateWindows As Boolean

Property Value

true to animate windows when the user interacts with them; otherwise, false.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.CornerRadius Property

DockControl.CornerRadius Property
[image]

Gets or sets the roundness of the frame edges of this dock control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBackground Property

DockControl.DockIndicatorBackground Property
[image]

Gets or sets the background of the dock indicator areas. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush DockIndicatorBackground { get; set; }

Visual Basic [image] Copy Code

Public Property DockIndicatorBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBorderBrush Property

DockControl.DockIndicatorBorderBrush Property
[image]

Gets or sets the border brush of the dock indicator areas. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush DockIndicatorBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DockIndicatorBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockIndicatorBorderThickness Property

DockControl.DockIndicatorBorderThickness Property
[image]

Gets or sets the border thickness of the dock indicator areas. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness DockIndicatorBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DockIndicatorBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBackground Property

DockControl.HandlersBackground Property
[image]

Gets or sets the background of the dock handlers and buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HandlersBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HandlersBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBorderBrush Property

DockControl.HandlersBorderBrush Property
[image]

Gets or sets the border brush of the dock handlers and buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HandlersBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HandlersBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersBorderThickness Property

DockControl.HandlersBorderThickness Property
[image]

Gets or sets the border thickness of the dock handlers and buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness HandlersBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HandlersBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersOverBackground Property

DockControl.HandlersOverBackground Property
[image]

Gets or sets the background of the dock handlers and buttons when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HandlersOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HandlersOverBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.HandlersPressedBackground Property

DockControl.HandlersPressedBackground Property
[image]

Gets or sets the background of the dock handlers and buttons when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HandlersPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HandlersPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.ItemContainerBackground Property

DockControl.ItemContainerBackground Property
[image]

Gets or sets the background of container dock items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ItemContainerBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ItemContainerBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.ItemSpacing Property

DockControl.ItemSpacing Property
[image]

Gets or sets the distance between adjacent docked items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ItemSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property ItemSpacing As Double

Property Value

A double value specifying the spacing.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.MinimumItemSize Property

DockControl.MinimumItemSize Property
[image]

Gets or sets the minimum size of the docked items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double MinimumItemSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumItemSize As Double

Property Value

A double value specifying the minimum item size.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.PanelOffset Property

DockControl.PanelOffset Property
[image]

Gets or sets the portions of the control that are occupied by docked items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness PanelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property PanelOffset As Thickness

Property Value

A WPF Thickness object specifying the offset on each side.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.RelativeDropSize Property

DockControl.RelativeDropSize Property
[image]

Gets or sets default size of items docked inside this DockControl, expressed as percentage of the control's size. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness RelativeDropSize { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeDropSize As Thickness

Property Value

A WPF Thickness object specifying the relative size of the items for each dock location.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabBackground Property

DockControl.TabBackground Property
[image]

Gets or sets the background of tab items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TabBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TabBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabBorderBrush Property

DockControl.TabBorderBrush Property
[image]

Gets or sets the border brush of tab items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TabBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TabBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabOverBackground Property

DockControl.TabOverBackground Property
[image]

Gets or sets the background of tab items pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TabOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TabOverBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabPressedBackground Property

DockControl.TabPressedBackground Property
[image]

Gets or sets the background of pressed tab items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TabPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TabPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.TabSelectedBackground Property

DockControl.TabSelectedBackground Property
[image]

Gets or sets the background of selected tab items. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TabSelectedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TabSelectedBackground As Brush

Property Value

A WPF Brush object.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl Events

DockControl Events
[image]

Public Events

Name | Description
Closed | Raised when a DockItem is closed.
Closing | Raised before the DockItem is closed in order to confirm the operation.
DockCompleted | Raised when an item has been docked.
DockStarted | Raised when the user is about to dock an item.
DragCompleted | Raised when a drag operation is completed.
DragStarted | Raised when the user initiates a drag operation.
ItemStateChanged | Raised when the state of an item has changed.

See Also

DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.Closed Event

DockControl.Closed Event
[image]

Raised when a DockItem is closed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> Closed

Visual Basic [image] Copy Code

Public Event Closed As EventHandler(Of DockEventArgs)

Event Data

Closed event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.Closing Event

DockControl.Closing Event
[image]

Raised before the DockItem is closed in order to confirm the operation.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> Closing

Visual Basic [image] Copy Code

Public Event Closing As EventHandler(Of DockEventArgs)

Event Data

Closed event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockCompleted Event

DockControl.DockCompleted Event
[image]

Raised when an item has been docked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> DockCompleted

Visual Basic [image] Copy Code

Public Event DockCompleted As EventHandler(Of DockEventArgs)

Event Data

DockCompleted event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DockStarted Event

DockControl.DockStarted Event
[image]

Raised when the user is about to dock an item.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> DockStarted

Visual Basic [image] Copy Code

Public Event DockStarted As EventHandler(Of DockEventArgs)

Event Data

DockStarted event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DragCompleted Event

DockControl.DragCompleted Event
[image]

Raised when a drag operation is completed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> DragCompleted

Visual Basic [image] Copy Code

Public Event DragCompleted As EventHandler(Of DockEventArgs)

Event Data

DockCompleted event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.DragStarted Event

DockControl.DragStarted Event
[image]

Raised when the user initiates a drag operation.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> DragStarted

Visual Basic [image] Copy Code

Public Event DragStarted As EventHandler(Of DockEventArgs)

Event Data

DragStarted event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockControl.ItemStateChanged Event

DockControl.ItemStateChanged Event
[image]

Raised when the state of an item has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DockEventArgs> ItemStateChanged

Visual Basic [image] Copy Code

Public Event ItemStateChanged As EventHandler(Of DockEventArgs)

Event Data

ItemStateChanged event handlers receive an argument of type DockEventArgs.

See Also

DockControl Members
DockControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs Class

DockEventArgs Class
[image]

Contains the arguments passed to handlers of validation events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DockEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DockEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.DockEventArgs

See Also

DockEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs Members

DockEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of validation events.

The following tables list the members exposed by the DockEventArgs type.

Public Constructors

Name | Description
DockEventArgs | Initializes a new instance of the DockEventArgs class.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Container | Gets the container item related to the event.
Items | Gets the items related to the event.

See Also

DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs Constructor

DockEventArgs Constructor
[image]

Initializes a new instance of the DockEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockEventArgs (
DockItem[] items,
DockItem container
)

Visual Basic [image] Copy Code

Public New ( _
items() As DockItem, _
container As DockItem _
)

Parameters

items
The DockItem objects related to the event.
container
The container DockItem related to the event.

See Also

DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs Properties

DockEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the operation is confirmed.
Container | Gets the container item related to the event.
Items | Gets the items related to the event.

See Also

DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs.Confirm Property

DockEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the operation is confirmed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }

Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

true to confirm the operation; false to reject it.

See Also

DockEventArgs Members
DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs.Container Property

DockEventArgs.Container Property
[image]

Gets the container item related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockItem Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As DockItem

Property Value

An instance of the DockItem class.

See Also

DockEventArgs Members
DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockEventArgs.Items Property

DockEventArgs.Items Property
[image]

Gets the items related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockItem[] Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DockItem()

Property Value

A list of DockItem instances.

See Also

DockEventArgs Members
DockEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Class

DockItem Class
[image]

Enables items docking in a DockControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DockItem : Window

Visual Basic [image] Copy Code

Public Class DockItem
Inherits Window

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.UI.Wpf.Window
MindFusion.UI.Wpf.DockItem

See Also

DockItem Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Members

DockItem Members
Constructors Fields Properties Methods Events
[image]

Enables items docking in a DockControl.

The following tables list the members exposed by the DockItem type.

Public Constructors

Name | Description
DockItem | Initializes a new instance of the DockItem class.

Public Fields

Name | Description
AllowedDockLocationsProperty | Identifies the AllowedDockLocations dependency property.
AnimationDurationProperty | Identifies the AnimationDuration dependency property. (Inherited from Window.)
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property. (Inherited from Window.)
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property. (Inherited from Window.)
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property. (Inherited from Window.)
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property. (Inherited from Window.)
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property. (Inherited from Window.)
CanCloseProperty | Identifies the CanClose dependency property. (Inherited from Window.)
CanDockProperty | Identifies the CanDock dependency property.
CanDragProperty | Identifies the CanDrag dependency property.
CanMoveProperty | Identifies the CanMove dependency property. (Inherited from Window.)
ContentBackgroundProperty | Identifies the ContentBackground dependency property. (Inherited from Window.)
ContentBorderThicknessProperty | Identifies the ContentBorderThickness dependency property.
ContentCornerRadiusProperty | Identifies the ContentCornerRadius dependency property. (Inherited from Window.)
ContentMarginProperty | Identifies the ContentMargin dependency property. (Inherited from Window.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Window.)
DockProperty | Identifies the Dock dependency property.
DockTargetProperty | Identifies the DockTarget dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderCornerRadiusProperty | Identifies the HeaderCornerRadius dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property. (Inherited from Window.)
HeaderInactiveBackgroundProperty | Identifies the HeaderInactiveBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from Window.)
HeaderProperty | Identifies the Header dependency property. (Inherited from Window.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from Window.)
IconProperty | Identifies the Icon dependency property. (Inherited from Window.)
InactiveBackgroundProperty | Identifies the InactiveBackground dependency property. (Inherited from Window.)
InactiveBorderBrushProperty | Identifies the InactiveBorderBrush dependency property. (Inherited from Window.)
IsActiveProperty | Identifies the IsActive dependency property. (Inherited from Window.)
IsAnimatedProperty | Identifies the IsAnimated dependency property. (Inherited from Window.)
KeepInsideHostProperty | Identifies the KeepInsideHost dependency property. (Inherited from Window.)
MinimizedHeightProperty | Identifies the MinimizedHeight dependency property. (Inherited from Window.)
MinimizedWidthProperty | Identifies the MinimizedWidth dependency property. (Inherited from Window.)
MinimizeModeProperty | Identifies the MinimizeMode dependency property. (Inherited from Window.)
PriorityProperty | Identifies the Priority dependency property.
ResizeModeProperty | Identifies the ResizeMode dependency property. (Inherited from Window.)
StartupLocationProperty | Identifies the StartupLocation dependency property. (Inherited from Window.)
StateMenuBorderBrushProperty | Identifies the StateMenuBorderBrush dependency property.
StateMenuBorderThicknessProperty | Identifies the StateMenuBorderThickness dependency property.
StateMenuContentBrushProperty | Identifies the StateMenuContentBrush dependency property.
StateMenuHeaderBrushProperty | Identifies the StateMenuHeaderBrush dependency property.
StateProperty | Identifies the State dependency property.
WindowStateProperty | Identifies the WindowState dependency property. (Inherited from Window.)

Public Properties

Name | Description
AllowedDockLocations | Gets or sets a value indicating the possible locations this item can be docked to. This is a dependency property.
AnimationDuration | Gets or sets the duration of the window's animations, expressed in milliseconds. This is a dependency property. (Inherited from Window.)
ButtonBackground | Gets or sets the background of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonBorderBrush | Gets or sets the border brush of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonOverBackground | Gets or sets the background of the buttons in the window when they are pointed with the mouse. This is a dependency property. (Inherited from Window.)
ButtonPressedBackground | Gets or sets the background of the buttons in the window when they are pressed. This is a dependency property. (Inherited from Window.)
CanClose | Gets or sets a value indicating whether the window will display a 'Close' button in its title bar. This is a dependency property. (Inherited from Window.)
CanDock | Gets or sets a value indicating whether the item can be docked. This is a dependency property.
CanDrag | Gets or sets a value indicating whether the item can be dragged. This is a dependency property.
CanMove | Gets or sets a value indicating whether the window can be moved interactively. This is a dependency property. (Inherited from Window.)
ContentBackground | Gets or sets the background of the window's content. This is a dependency property. (Inherited from Window.)
ContentBorderThickness | Gets or sets the thickness of the item's content border. This is a dependency property.
ContentCornerRadius | Gets or sets the corner radius of the border around the window's content. This is a dependency property. (Inherited from Window.)
ContentMargin | Gets or sets the margin of the window's content. This is a dependency property. (Inherited from Window.)
CornerRadius | Gets or sets the corner radius of the window's border. This is a dependency property. (Inherited from Window.)
Dock | Gets or sets the current dock location of the item, if the item is docked. This is a dependency property.
DockTarget | Gets or sets the parent item to dock this item to. This is a dependency property.
Header | Gets or sets the content of the window title bar. This is a dependency property. (Inherited from Window.)
HeaderBackground | Gets or sets the brush to use as background of the item's header. This is a dependency property.
HeaderBorderThickness | Gets or sets the thickness of the item's header border. This is a dependency property.
HeaderCornerRadius | Gets or sets the corner roundness of the item's header. This is a dependency property.
HeaderHeight | Gets or sets the height of the window's header. This is a dependency property. (Inherited from Window.)
HeaderInactiveBackground | Gets or sets the brush to use as a background of the item's header when the item is not the currently focused item. This is a dependency property.
HeaderMargin | Gets or sets the margin of the window's header. This is a dependency property. (Inherited from Window.)
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property. (Inherited from Window.)
Icon | Gets or sets the icon displayed in the window's title bar. This is a dependency property. (Inherited from Window.)
InactiveBackground | Gets or sets background brush of the window when it is not active. This is a dependency property. (Inherited from Window.)
InactiveBorderBrush | Gets or sets the border brush of the window when it is not active. This is a dependency property. (Inherited from Window.)
IsActive | Gets or sets a value indicating whether the window is active. This is a dependency property. (Inherited from Window.)
IsAnimated | Gets or sets a value indicating whether the window is animated. This is a dependency property. (Inherited from Window.)
KeepInsideHost | Gets or sets a value indicating whether the window can be interactively dragged outside of its containing WindowHost boundaries. This is a dependency property. (Inherited from Window.)
Left | Gets or sets the left side of the window within its container. (Inherited from Window.)
MinimizedHeight | Gets or sets the height of the window when it is minimized. This is a dependency property. (Inherited from Window.)
MinimizedWidth | Gets or sets the width of the window when it is minimized. This is a dependency property. (Inherited from Window.)
MinimizeMode | Gets or sets the behavior of this window when it is minimized. This is a dependency property. (Inherited from Window.)
Priority | Gets or sets the docking priority of the item. Items with higher priority get arranged first. This is a dependency property.
ResizeMode | Gets or sets a value indicating the allowed user interactions on this window. This is a dependency property. (Inherited from Window.)
StartupLocation | Gets or sets the initial location of the window relative to its host. This is a dependency property. (Inherited from Window.)
State | Gets or sets the docking state of the item. This is a dependency property.
StateMenuBorderBrush | Gets or sets the border brush of the item's drop-down menu. This is a dependency property.
StateMenuBorderThickness | Gets or sets the border thickness of the item's drop-down menu. This is a dependency property.
StateMenuContentBrush | Gets or sets the content brush of the item's drop-down menu. This is a dependency property.
StateMenuHeaderBrush | Gets or sets the header brush of the item's drop-down menu. This is a dependency property.
Top | Gets or sets the top side of the window within its container. (Inherited from Window.)
WindowState | Gets or sets the current state of the window. This is a dependency property. (Inherited from Window.)

Public Methods

Name | Description
OnApplyTemplate | Window.OnApplyTemplate override.
Show | Adds the window to the specified host. (Inherited from Window.)
ShowDialog | Displays the window within the specified host as a modal dialog. (Inherited from Window.)

Protected Methods

Name | Description
OnClosed | Raises the Closed event. (Inherited from Window.)
OnClosing | Raises the Closing event. (Inherited from Window.)
OnDockChanged | Raises the DockChanged event.
OnGotFocus | Control.OnGotFocus override. (Inherited from Window.)
OnLostFocus | UIElement.OnLostFocus override. (Inherited from Window.)
OnMouseDoubleClick | Control.OnMouseDoubleClick override. (Inherited from Window.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from Window.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from Window.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from Window.)
OnStateChanged | Raises the StateChanged event.

Public Events

Name | Description
Closed | Raised when a window is closed. (Inherited from Window.)
Closing | Raised before the window is closed in order to confirm the operation. (Inherited from Window.)
DockChanged | Raised when the dock location of the item has changed.
StateChanged | Raised when the state of the item has changed.

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Fields

DockItem Fields
[image]

Public Fields

Name | Description
AllowedDockLocationsProperty | Identifies the AllowedDockLocations dependency property.
AnimationDurationProperty | Identifies the AnimationDuration dependency property. (Inherited from Window.)
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property. (Inherited from Window.)
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property. (Inherited from Window.)
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property. (Inherited from Window.)
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property. (Inherited from Window.)
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property. (Inherited from Window.)
CanCloseProperty | Identifies the CanClose dependency property. (Inherited from Window.)
CanDockProperty | Identifies the CanDock dependency property.
CanDragProperty | Identifies the CanDrag dependency property.
CanMoveProperty | Identifies the CanMove dependency property. (Inherited from Window.)
ContentBackgroundProperty | Identifies the ContentBackground dependency property. (Inherited from Window.)
ContentBorderThicknessProperty | Identifies the ContentBorderThickness dependency property.
ContentCornerRadiusProperty | Identifies the ContentCornerRadius dependency property. (Inherited from Window.)
ContentMarginProperty | Identifies the ContentMargin dependency property. (Inherited from Window.)
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Window.)
DockProperty | Identifies the Dock dependency property.
DockTargetProperty | Identifies the DockTarget dependency property.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderBorderThicknessProperty | Identifies the HeaderBorderThickness dependency property.
HeaderCornerRadiusProperty | Identifies the HeaderCornerRadius dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property. (Inherited from Window.)
HeaderInactiveBackgroundProperty | Identifies the HeaderInactiveBackground dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property. (Inherited from Window.)
HeaderProperty | Identifies the Header dependency property. (Inherited from Window.)
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property. (Inherited from Window.)
IconProperty | Identifies the Icon dependency property. (Inherited from Window.)
InactiveBackgroundProperty | Identifies the InactiveBackground dependency property. (Inherited from Window.)
InactiveBorderBrushProperty | Identifies the InactiveBorderBrush dependency property. (Inherited from Window.)
IsActiveProperty | Identifies the IsActive dependency property. (Inherited from Window.)
IsAnimatedProperty | Identifies the IsAnimated dependency property. (Inherited from Window.)
KeepInsideHostProperty | Identifies the KeepInsideHost dependency property. (Inherited from Window.)
MinimizedHeightProperty | Identifies the MinimizedHeight dependency property. (Inherited from Window.)
MinimizedWidthProperty | Identifies the MinimizedWidth dependency property. (Inherited from Window.)
MinimizeModeProperty | Identifies the MinimizeMode dependency property. (Inherited from Window.)
PriorityProperty | Identifies the Priority dependency property.
ResizeModeProperty | Identifies the ResizeMode dependency property. (Inherited from Window.)
StartupLocationProperty | Identifies the StartupLocation dependency property. (Inherited from Window.)
StateMenuBorderBrushProperty | Identifies the StateMenuBorderBrush dependency property.
StateMenuBorderThicknessProperty | Identifies the StateMenuBorderThickness dependency property.
StateMenuContentBrushProperty | Identifies the StateMenuContentBrush dependency property.
StateMenuHeaderBrushProperty | Identifies the StateMenuHeaderBrush dependency property.
StateProperty | Identifies the State dependency property.
WindowStateProperty | Identifies the WindowState dependency property. (Inherited from Window.)

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.AllowedDockLocationsProperty Field

DockItem.AllowedDockLocationsProperty Field
[image]

Identifies the AllowedDockLocations dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AllowedDockLocationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AllowedDockLocationsProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.CanDockProperty Field

DockItem.CanDockProperty Field
[image]

Identifies the CanDock dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanDockProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanDockProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.CanDragProperty Field

DockItem.CanDragProperty Field
[image]

Identifies the CanDrag dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanDragProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanDragProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.ContentBorderThicknessProperty Field

DockItem.ContentBorderThicknessProperty Field
[image]

Identifies the ContentBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBorderThicknessProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.DockProperty Field

DockItem.DockProperty Field
[image]

Identifies the Dock dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.DockTargetProperty Field

DockItem.DockTargetProperty Field
[image]

Identifies the DockTarget dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockTargetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockTargetProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderBackgroundProperty Field

DockItem.HeaderBackgroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderBorderThicknessProperty Field

DockItem.HeaderBorderThicknessProperty Field
[image]

Identifies the HeaderBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBorderThicknessProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderCornerRadiusProperty Field

DockItem.HeaderCornerRadiusProperty Field
[image]

Identifies the HeaderCornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderCornerRadiusProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderInactiveBackgroundProperty Field

DockItem.HeaderInactiveBackgroundProperty Field
[image]

Identifies the HeaderInactiveBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderInactiveBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderInactiveBackgroundProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.PriorityProperty Field

DockItem.PriorityProperty Field
[image]

Identifies the Priority dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PriorityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PriorityProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuBorderBrushProperty Field

DockItem.StateMenuBorderBrushProperty Field
[image]

Identifies the StateMenuBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StateMenuBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StateMenuBorderBrushProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuBorderThicknessProperty Field

DockItem.StateMenuBorderThicknessProperty Field
[image]

Identifies the StateMenuBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StateMenuBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StateMenuBorderThicknessProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuContentBrushProperty Field

DockItem.StateMenuContentBrushProperty Field
[image]

Identifies the StateMenuContentBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StateMenuContentBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StateMenuContentBrushProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuHeaderBrushProperty Field

DockItem.StateMenuHeaderBrushProperty Field
[image]

Identifies the StateMenuHeaderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StateMenuHeaderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StateMenuHeaderBrushProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateProperty Field

DockItem.StateProperty Field
[image]

Identifies the State dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StateProperty As DependencyProperty

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Constructor

DockItem Constructor
[image]

Initializes a new instance of the DockItem class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Methods

DockItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Window.OnApplyTemplate override.
Show | Adds the window to the specified host. (Inherited from Window.)
ShowDialog | Displays the window within the specified host as a modal dialog. (Inherited from Window.)

Protected Methods

Name | Description
OnClosed | Raises the Closed event. (Inherited from Window.)
OnClosing | Raises the Closing event. (Inherited from Window.)
OnDockChanged | Raises the DockChanged event.
OnGotFocus | Control.OnGotFocus override. (Inherited from Window.)
OnLostFocus | UIElement.OnLostFocus override. (Inherited from Window.)
OnMouseDoubleClick | Control.OnMouseDoubleClick override. (Inherited from Window.)
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override. (Inherited from Window.)
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override. (Inherited from Window.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from Window.)
OnStateChanged | Raises the StateChanged event.

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.OnApplyTemplate Method

DockItem.OnApplyTemplate Method
[image]

Window.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.OnDockChanged Method

DockItem.OnDockChanged Method
[image]

Raises the DockChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDockChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDockChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.OnStateChanged Method

DockItem.OnStateChanged Method
[image]

Raises the StateChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnStateChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnStateChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Properties

DockItem Properties
[image]

Public Properties

Name | Description
AllowedDockLocations | Gets or sets a value indicating the possible locations this item can be docked to. This is a dependency property.
AnimationDuration | Gets or sets the duration of the window's animations, expressed in milliseconds. This is a dependency property. (Inherited from Window.)
ButtonBackground | Gets or sets the background of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonBorderBrush | Gets or sets the border brush of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the window. This is a dependency property. (Inherited from Window.)
ButtonOverBackground | Gets or sets the background of the buttons in the window when they are pointed with the mouse. This is a dependency property. (Inherited from Window.)
ButtonPressedBackground | Gets or sets the background of the buttons in the window when they are pressed. This is a dependency property. (Inherited from Window.)
CanClose | Gets or sets a value indicating whether the window will display a 'Close' button in its title bar. This is a dependency property. (Inherited from Window.)
CanDock | Gets or sets a value indicating whether the item can be docked. This is a dependency property.
CanDrag | Gets or sets a value indicating whether the item can be dragged. This is a dependency property.
CanMove | Gets or sets a value indicating whether the window can be moved interactively. This is a dependency property. (Inherited from Window.)
ContentBackground | Gets or sets the background of the window's content. This is a dependency property. (Inherited from Window.)
ContentBorderThickness | Gets or sets the thickness of the item's content border. This is a dependency property.
ContentCornerRadius | Gets or sets the corner radius of the border around the window's content. This is a dependency property. (Inherited from Window.)
ContentMargin | Gets or sets the margin of the window's content. This is a dependency property. (Inherited from Window.)
CornerRadius | Gets or sets the corner radius of the window's border. This is a dependency property. (Inherited from Window.)
Dock | Gets or sets the current dock location of the item, if the item is docked. This is a dependency property.
DockTarget | Gets or sets the parent item to dock this item to. This is a dependency property.
Header | Gets or sets the content of the window title bar. This is a dependency property. (Inherited from Window.)
HeaderBackground | Gets or sets the brush to use as background of the item's header. This is a dependency property.
HeaderBorderThickness | Gets or sets the thickness of the item's header border. This is a dependency property.
HeaderCornerRadius | Gets or sets the corner roundness of the item's header. This is a dependency property.
HeaderHeight | Gets or sets the height of the window's header. This is a dependency property. (Inherited from Window.)
HeaderInactiveBackground | Gets or sets the brush to use as a background of the item's header when the item is not the currently focused item. This is a dependency property.
HeaderMargin | Gets or sets the margin of the window's header. This is a dependency property. (Inherited from Window.)
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property. (Inherited from Window.)
Icon | Gets or sets the icon displayed in the window's title bar. This is a dependency property. (Inherited from Window.)
InactiveBackground | Gets or sets background brush of the window when it is not active. This is a dependency property. (Inherited from Window.)
InactiveBorderBrush | Gets or sets the border brush of the window when it is not active. This is a dependency property. (Inherited from Window.)
IsActive | Gets or sets a value indicating whether the window is active. This is a dependency property. (Inherited from Window.)
IsAnimated | Gets or sets a value indicating whether the window is animated. This is a dependency property. (Inherited from Window.)
KeepInsideHost | Gets or sets a value indicating whether the window can be interactively dragged outside of its containing WindowHost boundaries. This is a dependency property. (Inherited from Window.)
Left | Gets or sets the left side of the window within its container. (Inherited from Window.)
MinimizedHeight | Gets or sets the height of the window when it is minimized. This is a dependency property. (Inherited from Window.)
MinimizedWidth | Gets or sets the width of the window when it is minimized. This is a dependency property. (Inherited from Window.)
MinimizeMode | Gets or sets the behavior of this window when it is minimized. This is a dependency property. (Inherited from Window.)
Priority | Gets or sets the docking priority of the item. Items with higher priority get arranged first. This is a dependency property.
ResizeMode | Gets or sets a value indicating the allowed user interactions on this window. This is a dependency property. (Inherited from Window.)
StartupLocation | Gets or sets the initial location of the window relative to its host. This is a dependency property. (Inherited from Window.)
State | Gets or sets the docking state of the item. This is a dependency property.
StateMenuBorderBrush | Gets or sets the border brush of the item's drop-down menu. This is a dependency property.
StateMenuBorderThickness | Gets or sets the border thickness of the item's drop-down menu. This is a dependency property.
StateMenuContentBrush | Gets or sets the content brush of the item's drop-down menu. This is a dependency property.
StateMenuHeaderBrush | Gets or sets the header brush of the item's drop-down menu. This is a dependency property.
Top | Gets or sets the top side of the window within its container. (Inherited from Window.)
WindowState | Gets or sets the current state of the window. This is a dependency property. (Inherited from Window.)

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.AllowedDockLocations Property

DockItem.AllowedDockLocations Property
[image]

Gets or sets a value indicating the possible locations this item can be docked to. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockLocations AllowedDockLocations { get; set; }

Visual Basic [image] Copy Code

Public Property AllowedDockLocations As DockLocations

Property Value

A member of the DockLocations enumeration.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.CanDock Property

DockItem.CanDock Property
[image]

Gets or sets a value indicating whether the item can be docked. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool CanDock { get; set; }

Visual Basic [image] Copy Code

Public Property CanDock As Boolean

Property Value

true if the item can be docked; otherwise, false.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.CanDrag Property

DockItem.CanDrag Property
[image]

Gets or sets a value indicating whether the item can be dragged. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool CanDrag { get; set; }

Visual Basic [image] Copy Code

Public Property CanDrag As Boolean

Property Value

true if the item can be dragged; otherwise, false.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.ContentBorderThickness Property

DockItem.ContentBorderThickness Property
[image]

Gets or sets the thickness of the item's content border. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ContentBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.Dock Property

DockItem.Dock Property
[image]

Gets or sets the current dock location of the item, if the item is docked. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Dock Dock { get; set; }

Visual Basic [image] Copy Code

Public Property Dock As Dock

Property Value

A member of the Dock enumeration.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.DockTarget Property

DockItem.DockTarget Property
[image]

Gets or sets the parent item to dock this item to. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockItem DockTarget { get; set; }

Visual Basic [image] Copy Code

Public Property DockTarget As DockItem

Property Value

An instance of the DockItem class.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderBackground Property

DockItem.HeaderBackground Property
[image]

Gets or sets the brush to use as background of the item's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBackground As Brush

Property Value

A WPF Brush object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderBorderThickness Property

DockItem.HeaderBorderThickness Property
[image]

Gets or sets the thickness of the item's header border. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderCornerRadius Property

DockItem.HeaderCornerRadius Property
[image]

Gets or sets the corner roundness of the item's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CornerRadius HeaderCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderCornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.HeaderInactiveBackground Property

DockItem.HeaderInactiveBackground Property
[image]

Gets or sets the brush to use as a background of the item's header when the item is not the currently focused item. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderInactiveBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderInactiveBackground As Brush

Property Value

A WPF Brush object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.Priority Property

DockItem.Priority Property
[image]

Gets or sets the docking priority of the item. Items with higher priority get arranged first. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public int Priority { get; set; }

Visual Basic [image] Copy Code

Public Property Priority As Integer

Property Value

An integer value specifying the item's priority.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.State Property

DockItem.State Property
[image]

Gets or sets the docking state of the item. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DockItemState State { get; set; }

Visual Basic [image] Copy Code

Public Property State As DockItemState

Property Value

A member of the DockItemState enumeration.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuBorderBrush Property

DockItem.StateMenuBorderBrush Property
[image]

Gets or sets the border brush of the item's drop-down menu. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush StateMenuBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property StateMenuBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuBorderThickness Property

DockItem.StateMenuBorderThickness Property
[image]

Gets or sets the border thickness of the item's drop-down menu. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness StateMenuBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StateMenuBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuContentBrush Property

DockItem.StateMenuContentBrush Property
[image]

Gets or sets the content brush of the item's drop-down menu. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush StateMenuContentBrush { get; set; }

Visual Basic [image] Copy Code

Public Property StateMenuContentBrush As Brush

Property Value

A WPF Brush object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateMenuHeaderBrush Property

DockItem.StateMenuHeaderBrush Property
[image]

Gets or sets the header brush of the item's drop-down menu. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush StateMenuHeaderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property StateMenuHeaderBrush As Brush

Property Value

A WPF Brush object.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem Events

DockItem Events
[image]

Public Events

Name | Description
Closed | Raised when a window is closed. (Inherited from Window.)
Closing | Raised before the window is closed in order to confirm the operation. (Inherited from Window.)
DockChanged | Raised when the dock location of the item has changed.
StateChanged | Raised when the state of the item has changed.

See Also

DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Closed Event

Window.Closed Event
[image]

Raised when a window is closed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> Closed

Visual Basic [image] Copy Code

Public Event Closed As EventHandler(Of EventArgs)

Event Data

Closed event handlers receive an argument of type EventArgs.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Closing Event

Window.Closing Event
[image]

Raised before the window is closed in order to confirm the operation.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ConfirmEventArgs> Closing

Visual Basic [image] Copy Code

Public Event Closing As EventHandler(Of ConfirmEventArgs)

Event Data

Closed event handlers receive an argument of type ConfirmEventArgs.

Remarks

This event can be used to prevent users from closing the window under some conditions.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.DockChanged Event

DockItem.DockChanged Event
[image]

Raised when the dock location of the item has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DockChanged

Visual Basic [image] Copy Code

Public Event DockChanged As EventHandler

Event Data

DockChanged event handlers receive an argument of type EventArgs.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItem.StateChanged Event

DockItem.StateChanged Event
[image]

Raised when the state of the item has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler StateChanged

Visual Basic [image] Copy Code

Public Event StateChanged As EventHandler

Event Data

StateChanged event handlers receive an argument of type EventArgs.

See Also

DockItem Members
DockItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockItemState Enumeration

DockItemState Enumeration
[image]

Specifies the state of a DockItem inside a DockControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum DockItemState

Visual Basic [image] Copy Code

Public Enum DockItemState

Members

Member name | Description
AutoHide | Indicates that the item is auto-hidden to the side and will show automatically when hovered over with the mouse.
Docked | Indicates that the item is docked to one of the sides.
Floating | Indicates that the item is not docked.
Hide | Indicates that the item is hidden.
TabbedDocument | Indicates that the item is docked in the middle.

Remarks

Values of this enumeration can be assigned to the State property of the DockItem class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DockLocations Enumeration

DockLocations Enumeration
[image]

Specifies the possible dock destinations.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum DockLocations

Visual Basic [image] Copy Code

Public Enum DockLocations

Members

Member name | Description
All | Indicates that docking to all sides and to the center is allowed.
Bottom | Indicates that docking to the bottom side is allowed.
Center | Indicates that docking to the center is allowed.
Left | Indicates that docking to the left side is allowed.
None | Indicates that docking is not possible.
Right | Indicates that docking to the right side is allowed.
Top | Indicates that docking to the top side is allowed.

Remarks

Values of this enumeration can be assigned to the AllowedDockLocations property of the DockItem class and the AllowedDockLocations property of the DockControl class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs Class

DrawEventArgs Class
[image]

Contains information for custom drawing events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class DrawEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.DrawEventArgs

See Also

DrawEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs Members

DrawEventArgs Members
Constructors Properties
[image]

Contains information for custom drawing events.

The following tables list the members exposed by the DrawEventArgs type.

Public Constructors

Name | Description
DrawEventArgs |

Public Properties

Name | Description
Context |
Control |

See Also

DrawEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs Constructor

DrawEventArgs Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DrawEventArgs (
Control control,
DrawingContext context
)

Visual Basic [image] Copy Code

Public New ( _
control As Control, _
context As DrawingContext _
)

Parameters

control

context

See Also

DrawEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs Properties

DrawEventArgs Properties
[image]

Public Properties

Name | Description
Context |
Control |

See Also

DrawEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs.Context Property

DrawEventArgs.Context Property
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DrawingContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As DrawingContext

Property Value

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.DrawEventArgs.Control Property

DrawEventArgs.Control Property
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Control Control { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Control As Control

Property Value

See Also

DrawEventArgs Members
DrawEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Class

ExtendedKey Class
[image]

Represents a key that sends several key codes when pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class ExtendedKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class ExtendedKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.ExtendedKey

See Also

ExtendedKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Members

ExtendedKey Members
Constructors Properties Methods Events
[image]

Represents a key that sends several key codes when pressed.

The following tables list the members exposed by the ExtendedKey type.

Public Constructors

Name | Description
ExtendedKey |

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
Keys | List of regular keys sent by this key.
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this ExtendedKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Constructor

ExtendedKey Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public ExtendedKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Methods

ExtendedKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this ExtendedKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey.Clone Method

ExtendedKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new ExtendedKey instance.

See Also

ExtendedKey Members
ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey.Equals Method

ExtendedKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

ExtendedKey Members
ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey.GetHashCode Method

ExtendedKey.GetHashCode Method
[image]

Returns a hash code for this ExtendedKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

ExtendedKey Members
ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey.Send Method

ExtendedKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

ExtendedKey Members
ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Properties

ExtendedKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
Keys | List of regular keys sent by this key.
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey.Keys Property

ExtendedKey.Keys Property
[image]

List of regular keys sent by this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public List<Key> Keys { get; set; }

Visual Basic [image] Copy Code

Public Property Keys As List(Of Key)

Property Value

See Also

ExtendedKey Members
ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ExtendedKey Events

ExtendedKey Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

ExtendedKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.PropertyChanged Event

Key.PropertyChanged Event
[image]

PropertyChanged

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget Interface

IZoomTarget Interface
[image]

Specifies the capabilities required by ZoomControl from its target controls.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public interface IZoomTarget

Visual Basic [image] Copy Code

Public Interface IZoomTarget

Inheritors

MindFusion.Diagramming.Wpf.Diagram
MindFusion.Diagramming.Wpf.DiagramView
MindFusion.Mapping.Wpf.MapView

See Also

IZoomTarget Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget Members

IZoomTarget Members
Methods Events
[image]

Specifies the capabilities required by ZoomControl from its target controls.

The following tables list the members exposed by the IZoomTarget type.

Public Methods

Name | Description
GetScrollX | Sets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

Public Events

Name | Description
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget Methods

IZoomTarget Methods
[image]

Public Methods

Name | Description
GetScrollX | Sets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

See Also

IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.GetScrollX Method

IZoomTarget.GetScrollX Method
[image]

Sets the horizontal scroll position.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

double GetScrollX ()

Visual Basic [image] Copy Code

Function GetScrollX () As Double

Return Value

A double value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.GetScrollY Method

IZoomTarget.GetScrollY Method
[image]

Gets the vertical scroll position.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

double GetScrollY ()

Visual Basic [image] Copy Code

Function GetScrollY () As Double

Return Value

A double value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.GetZoomLevel Method

IZoomTarget.GetZoomLevel Method
[image]

Gets the current zoom level.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

double GetZoomLevel ()

Visual Basic [image] Copy Code

Function GetZoomLevel () As Double

Return Value

A double value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.SetScrollX Method

IZoomTarget.SetScrollX Method
[image]

Sets the horizontal scroll position.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

void SetScrollX (
double scrollX
)

Visual Basic [image] Copy Code

Sub SetScrollX( _
scrollX As Double _
)

Parameters

scrollX

A double value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.SetScrollY Method

IZoomTarget.SetScrollY Method
[image]

Sets the vertical scroll position.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

void SetScrollY (
double scrollY
)

Visual Basic [image] Copy Code

Sub SetScrollY( _
scrollY As Double _
)

Parameters

scrollY

A double value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.SetZoomLevel Method

IZoomTarget.SetZoomLevel Method
[image]

Sets a new zoom level.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

void SetZoomLevel (
double zoom
)

Visual Basic [image] Copy Code

Sub SetZoomLevel( _
zoom As Double _
)

Parameters

zoom

A double value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget Events

IZoomTarget Events
[image]

Public Events

Name | Description
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.IZoomTarget.ZoomLevelChanged Event

IZoomTarget.ZoomLevelChanged Event
[image]

Raised to notify that the target's zoom level has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

event EventHandler ZoomLevelChanged

Visual Basic [image] Copy Code

Event ZoomLevelChanged As EventHandler

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Class

Key Class
[image]

Represents a key in the keyboard.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract class Key : INotifyPropertyChanged, ICloneable

Visual Basic [image] Copy Code

Public MustInherit Class Key
Implements INotifyPropertyChanged, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.ExtendedKey
MindFusion.UI.Wpf.NumPadKey
MindFusion.UI.Wpf.RegularKey
MindFusion.UI.Wpf.SpecialKey
MindFusion.UI.Wpf.UnicodeKey

See Also

Key Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Members

Key Members
Constructors Properties Methods Events
[image]

Represents a key in the keyboard.

The following tables list the members exposed by the Key type.

Protected Constructors

Name | Description
Key |

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18
AltGr | The alt gr virtual key. Virtual Key = 165
Backspace | The backspace virtual key.
CapsLock | The caps lock virtual key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.
Context | The context menu virtual key.
Ctrl | The control virtual key. Virtual Key = 17
Delete | The delete virtual key.
End | The end virtual key.
Enter | The enter virtual key. Virtual Key = 13
Esc | The escape virtual key.
F1 | The F1 virtual key.
F10 | The F10 virtual key.
F11 | The F11 virtual key.
F12 | The F12 virtual key.
F2 | The F2 virtual key.
F3 | The F3 virtual key.
F4 | The F4 virtual key.
F5 | The F5 virtual key.
F6 | The F6 virtual key.
F7 | The F7 virtual key.
F8 | The F8 virtual key.
F9 | The F9 virtual key.
Height | The key's height.
Home | The home virtual key.
Image | Gets or sets relative path to an image that should be displayed inside this key.
Insert | The insert virtual key.
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.
IsPressed | Set to true when this key is pressed down by the user.
IsSelected | IsSelected
KeyDown | The key down virtual key.
KeyLeft | The key left virtual key.
KeyRight | The key right virtual key.
KeyUp | The key up virtual key.
Lang | Language rotation virtual key.
Left | Horizontal position of the key.
Num5 | The numpad 5 virtual key.
NumDelete | The numpad delete virtual key.
NumDiv | The numpad / virtual key.
NumEnd | The numpad end virtual key.
NumHome | The numpad home virtual key.
NumInsert | The numpad insert virtual key.
NumKeyDown | The numpad key-down virtual key.
NumKeyLeft | The numpad key-left virtual key.
NumKeyRight | The numpad key-right virtual key.
NumKeyUp | The numpad key-up virtual key.
NumLock | The num lock virtual key.
NumMinus | The numpad - virtual key.
NumMult | The numpad * virtual key.
NumPageDown | The numpad page down virtual key.
NumPageUp | The numpad page up virtual key.
NumPlus | The numpad + virtual key.
PageDown | The page down virtual key.
PageUp | The page up virtual key.
PauseBreak | The pause / break virtual key.
PrtScr | The Print Screen virtual key.
ScrollLock | The scroll lock virtual key.
Shift | The shift virtual key. Virtual Key = 16
Space | The space virtual key.
Tab | The tab virtual key.
Top | Vertical position of the key.
Width | The key's width.
Windows | The Windows virtual key.

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this Key.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value.
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one.

Public Events

Name | Description
PropertyChanged | PropertyChanged

See Also

Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Constructor

Key Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected Key ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Methods

Key Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this Key.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value.
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one.

See Also

Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Clone Method

Key.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

A new Key instance.

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Copy Method

Key.Copy Method
[image]

Copies the properties of this key to specified one.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected void Copy (
Key key
)

Visual Basic [image] Copy Code

Protected Sub Copy( _
key As Key _
)

Parameters

key

Key

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Equals Method

Key.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.GetHashCode Method

Key.GetHashCode Method
[image]

Returns a hash code for this Key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.GetVirtualKeyCode Method

Key.GetVirtualKeyCode Method
[image]

Gets the virtual key code corresponding to a System.Windows.Input.Key value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static int GetVirtualKeyCode (
Key value
)

Visual Basic [image] Copy Code

Public Shared Function GetVirtualKeyCode( _
value As Key _
) As Integer

Parameters

value

System.Windows.Input.Key value.

Return Value

int

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Send Method

Key.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public abstract void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public MustOverride Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Properties

Key Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18
AltGr | The alt gr virtual key. Virtual Key = 165
Backspace | The backspace virtual key.
CapsLock | The caps lock virtual key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.
Context | The context menu virtual key.
Ctrl | The control virtual key. Virtual Key = 17
Delete | The delete virtual key.
End | The end virtual key.
Enter | The enter virtual key. Virtual Key = 13
Esc | The escape virtual key.
F1 | The F1 virtual key.
F10 | The F10 virtual key.
F11 | The F11 virtual key.
F12 | The F12 virtual key.
F2 | The F2 virtual key.
F3 | The F3 virtual key.
F4 | The F4 virtual key.
F5 | The F5 virtual key.
F6 | The F6 virtual key.
F7 | The F7 virtual key.
F8 | The F8 virtual key.
F9 | The F9 virtual key.
Height | The key's height.
Home | The home virtual key.
Image | Gets or sets relative path to an image that should be displayed inside this key.
Insert | The insert virtual key.
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.
IsPressed | Set to true when this key is pressed down by the user.
IsSelected | IsSelected
KeyDown | The key down virtual key.
KeyLeft | The key left virtual key.
KeyRight | The key right virtual key.
KeyUp | The key up virtual key.
Lang | Language rotation virtual key.
Left | Horizontal position of the key.
Num5 | The numpad 5 virtual key.
NumDelete | The numpad delete virtual key.
NumDiv | The numpad / virtual key.
NumEnd | The numpad end virtual key.
NumHome | The numpad home virtual key.
NumInsert | The numpad insert virtual key.
NumKeyDown | The numpad key-down virtual key.
NumKeyLeft | The numpad key-left virtual key.
NumKeyRight | The numpad key-right virtual key.
NumKeyUp | The numpad key-up virtual key.
NumLock | The num lock virtual key.
NumMinus | The numpad - virtual key.
NumMult | The numpad * virtual key.
NumPageDown | The numpad page down virtual key.
NumPageUp | The numpad page up virtual key.
NumPlus | The numpad + virtual key.
PageDown | The page down virtual key.
PageUp | The page up virtual key.
PauseBreak | The pause / break virtual key.
PrtScr | The Print Screen virtual key.
ScrollLock | The scroll lock virtual key.
Shift | The shift virtual key. Virtual Key = 16
Space | The space virtual key.
Tab | The tab virtual key.
Top | Vertical position of the key.
Width | The key's width.
Windows | The Windows virtual key.

See Also

Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Alt Property

Key.Alt Property
[image]

The alt virtual key. Virtual Key = 18

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Alt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alt As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.AltGr Property

Key.AltGr Property
[image]

The alt gr virtual key. Virtual Key = 165

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key AltGr { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltGr As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Backspace Property

Key.Backspace Property
[image]

The backspace virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Backspace { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Backspace As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.CapsLock Property

Key.CapsLock Property
[image]

The caps lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key CapsLock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CapsLock As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Content Property

Key.Content Property
[image]

Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Object Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As Object

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Context Property

Key.Context Property
[image]

The context menu virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Context { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Context As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Ctrl Property

Key.Ctrl Property
[image]

The control virtual key. Virtual Key = 17

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Ctrl { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ctrl As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Delete Property

Key.Delete Property
[image]

The delete virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Delete { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delete As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.End Property

Key.End Property
[image]

The end virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key End { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property End As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Enter Property

Key.Enter Property
[image]

The enter virtual key. Virtual Key = 13

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Enter { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Enter As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Esc Property

Key.Esc Property
[image]

The escape virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Esc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Esc As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F1 Property

Key.F1 Property
[image]

The F1 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F1 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F10 Property

Key.F10 Property
[image]

The F10 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F10 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F10 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F11 Property

Key.F11 Property
[image]

The F11 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F11 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F11 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F12 Property

Key.F12 Property
[image]

The F12 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F12 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F12 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F2 Property

Key.F2 Property
[image]

The F2 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F2 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F3 Property

Key.F3 Property
[image]

The F3 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F3 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F4 Property

Key.F4 Property
[image]

The F4 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F4 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F5 Property

Key.F5 Property
[image]

The F5 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F5 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F6 Property

Key.F6 Property
[image]

The F6 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F6 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F7 Property

Key.F7 Property
[image]

The F7 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F7 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F8 Property

Key.F8 Property
[image]

The F8 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F8 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.F9 Property

Key.F9 Property
[image]

The F9 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key F9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property F9 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Height Property

Key.Height Property
[image]

The key's height.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Home Property

Key.Home Property
[image]

The home virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Home { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Home As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Image Property

Key.Image Property
[image]

Gets or sets relative path to an image that should be displayed inside this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As String

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Insert Property

Key.Insert Property
[image]

The insert virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Insert { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Insert As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.IsLocked Property

Key.IsLocked Property
[image]

IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsLocked { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsLocked As Boolean

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.IsPressed Property

Key.IsPressed Property
[image]

Set to true when this key is pressed down by the user.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsPressed { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsPressed As Boolean

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.IsSelected Property

Key.IsSelected Property
[image]

IsSelected

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.KeyDown Property

Key.KeyDown Property
[image]

The key down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyDown As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.KeyLeft Property

Key.KeyLeft Property
[image]

The key left virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyLeft { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyLeft As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.KeyRight Property

Key.KeyRight Property
[image]

The key right virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyRight { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyRight As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.KeyUp Property

Key.KeyUp Property
[image]

The key up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key KeyUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property KeyUp As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Lang Property

Key.Lang Property
[image]

Language rotation virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Lang { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lang As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Left Property

Key.Left Property
[image]

Horizontal position of the key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Double

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Num5 Property

Key.Num5 Property
[image]

The numpad 5 virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Num5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Num5 As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumDelete Property

Key.NumDelete Property
[image]

The numpad delete virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumDelete { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumDelete As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumDiv Property

Key.NumDiv Property
[image]

The numpad / virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumDiv { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumDiv As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumEnd Property

Key.NumEnd Property
[image]

The numpad end virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumEnd { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumEnd As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumHome Property

Key.NumHome Property
[image]

The numpad home virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumHome { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumHome As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumInsert Property

Key.NumInsert Property
[image]

The numpad insert virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumInsert { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumInsert As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumKeyDown Property

Key.NumKeyDown Property
[image]

The numpad key-down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyDown As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumKeyLeft Property

Key.NumKeyLeft Property
[image]

The numpad key-left virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyLeft { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyLeft As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumKeyRight Property

Key.NumKeyRight Property
[image]

The numpad key-right virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyRight { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyRight As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumKeyUp Property

Key.NumKeyUp Property
[image]

The numpad key-up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumKeyUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumKeyUp As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumLock Property

Key.NumLock Property
[image]

The num lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumLock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumLock As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumMinus Property

Key.NumMinus Property
[image]

The numpad - virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumMinus { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumMinus As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumMult Property

Key.NumMult Property
[image]

The numpad * virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumMult { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumMult As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumPageDown Property

Key.NumPageDown Property
[image]

The numpad page down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPageDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPageDown As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumPageUp Property

Key.NumPageUp Property
[image]

The numpad page up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPageUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPageUp As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.NumPlus Property

Key.NumPlus Property
[image]

The numpad + virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key NumPlus { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumPlus As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.PageDown Property

Key.PageDown Property
[image]

The page down virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PageDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PageDown As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.PageUp Property

Key.PageUp Property
[image]

The page up virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PageUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PageUp As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.PauseBreak Property

Key.PauseBreak Property
[image]

The pause / break virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PauseBreak { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PauseBreak As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.PrtScr Property

Key.PrtScr Property
[image]

The Print Screen virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key PrtScr { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrtScr As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.ScrollLock Property

Key.ScrollLock Property
[image]

The scroll lock virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key ScrollLock { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ScrollLock As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Shift Property

Key.Shift Property
[image]

The shift virtual key. Virtual Key = 16

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Shift { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shift As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Space Property

Key.Space Property
[image]

The space virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Space { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Space As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Tab Property

Key.Tab Property
[image]

The tab virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Tab { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tab As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Top Property

Key.Top Property
[image]

Vertical position of the key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Double

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Width Property

Key.Width Property
[image]

The key's width.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key.Windows Property

Key.Windows Property
[image]

The Windows virtual key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static Key Windows { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Windows As Key

Property Value

See Also

Key Members
Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Key Events

Key Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged

See Also

Key Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Class

KeyboardLayout Class
[image]

Defines layout of keyboard keys.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class KeyboardLayout : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class KeyboardLayout
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.KeyboardLayout

See Also

KeyboardLayout Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Members

KeyboardLayout Members
Constructors Properties Methods Events
[image]

Defines layout of keyboard keys.

The following tables list the members exposed by the KeyboardLayout type.

Public Constructors

Name | Description
KeyboardLayout | Initializes a new instance of the KeyboardLayout class.

Public Properties

Name | Description
Height | Gets or sets the keyboard height.
KeyboardLayoutId | Gets or sets the layout id.
Keys | Gets or sets the keys displayed in this layout.
Width | Gets or sets the keyboard width.

Public Methods

Name | Description
Create | Overloaded.

Public Events

Name | Description
PropertyChanged | PropertyChanged event

See Also

KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Constructor

KeyboardLayout Constructor
[image]

Initializes a new instance of the KeyboardLayout class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Methods

KeyboardLayout Methods
[image]

Public Methods

Name | Description
Create | Overloaded.

See Also

KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Create Method

KeyboardLayout.Create Method
[image]

Overload List

Name | Description
KeyboardLayout.Create (Stream) | Loads keyboard layout from a stream.
KeyboardLayout.Create (String) | Loads keyboard layout from a file.

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Create Method (Stream)

KeyboardLayout.Create Method (Stream)
See Also
[image]

Loads keyboard layout from a stream.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static KeyboardLayout Create (
Stream input
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
input As Stream _
) As KeyboardLayout

Parameters

input

A stream containing layout XML.

Return Value

A KeyboardLayout instance.

See Also

Create Method Overload List
KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Create Method (String)

KeyboardLayout.Create Method (String)
See Also
[image]

Loads keyboard layout from a file.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static KeyboardLayout Create (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function Create( _
fileName As String _
) As KeyboardLayout

Parameters

fileName

Path to a file containing layout XML.

Return Value

A KeyboardLayout instance.

See Also

Create Method Overload List
KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Properties

KeyboardLayout Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the keyboard height.
KeyboardLayoutId | Gets or sets the layout id.
Keys | Gets or sets the keys displayed in this layout.
Width | Gets or sets the keyboard width.

See Also

KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Height Property

KeyboardLayout.Height Property
[image]

Gets or sets the keyboard height.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.KeyboardLayoutId Property

KeyboardLayout.KeyboardLayoutId Property
[image]

Gets or sets the layout id.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public long KeyboardLayoutId { get; set; }

Visual Basic [image] Copy Code

Public Property KeyboardLayoutId As Long

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Keys Property

KeyboardLayout.Keys Property
[image]

Gets or sets the keys displayed in this layout.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Key> Keys { get; set; }

Visual Basic [image] Copy Code

Public Property Keys As ObservableCollection(Of Key)

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.Width Property

KeyboardLayout.Width Property
[image]

Gets or sets the keyboard width.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout Events

KeyboardLayout Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged event

See Also

KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardLayout.PropertyChanged Event

KeyboardLayout.PropertyChanged Event
[image]

PropertyChanged event

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

KeyboardLayout Members
KeyboardLayout Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyboardMode Enumeration

KeyboardMode Enumeration
[image]

Identifies keyboard layout modes.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public enum KeyboardMode

Visual Basic [image] Copy Code

Public Enum KeyboardMode

Members

Member name | Description
Custom | Custom layout. You must design a layout and save it in Layouts folder before using this mode. Or use TemplateLayout property to define keyboard common view.
Default | Default layout.
Extended | Extended layout.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels Structure

KeyLabels Structure
[image]

Represents custom key labels.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public struct KeyLabels

Visual Basic [image] Copy Code

Public Structure KeyLabels

See Also

KeyLabels Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels Members

KeyLabels Members
Fields
[image]

Represents custom key labels.

The following tables list the members exposed by the KeyLabels type.

Public Fields

Name | Description
Alt | Alternative label.
Caps | Upper-case label.
Lower | Lower-case label.
Shift | Label shown when Shift key is pressed down.
VirtualKey | Virtual key code.

See Also

KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels Fields

KeyLabels Fields
[image]

Public Fields

Name | Description
Alt | Alternative label.
Caps | Upper-case label.
Lower | Lower-case label.
Shift | Label shown when Shift key is pressed down.
VirtualKey | Virtual key code.

See Also

KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels.Alt Field

KeyLabels.Alt Field
[image]

Alternative label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Alt

Visual Basic [image] Copy Code

Public Alt As String

See Also

KeyLabels Members
KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels.Caps Field

KeyLabels.Caps Field
[image]

Upper-case label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Caps

Visual Basic [image] Copy Code

Public Caps As String

See Also

KeyLabels Members
KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels.Lower Field

KeyLabels.Lower Field
[image]

Lower-case label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Lower

Visual Basic [image] Copy Code

Public Lower As String

See Also

KeyLabels Members
KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels.Shift Field

KeyLabels.Shift Field
[image]

Label shown when Shift key is pressed down.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string Shift

Visual Basic [image] Copy Code

Public Shift As String

See Also

KeyLabels Members
KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.KeyLabels.VirtualKey Field

KeyLabels.VirtualKey Field
[image]

Virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey

Visual Basic [image] Copy Code

Public VirtualKey As Integer

See Also

KeyLabels Members
KeyLabels Structure
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Class

MindFusionButton Class
[image]

Represents an advanced button that can optionally display a drop-down panel when clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class MindFusionButton : ContentControl

Visual Basic [image] Copy Code

Public Class MindFusionButton
Inherits ContentControl

Example

The following example illustrates a button with a drop-down ListBox. The content of the button is automatically updated when the items in the drop-down ListBox are selected. The width of the drop-down ListBox is synchronized with the width of the button.

XAML [image] Copy Code

<ui:MindFusionButton Name="button" ButtonType="DropDown" Content="{Binding SelectedItem.Content, ElementName=dropdown}">
<ui:MindFusionButton.PopupContent>
<ListBox Name="dropdown" Width="{Binding ActualWidth, ElementName=button}">
<ListBoxItem Content="Item #1" />
<ListBoxItem Content="Item #2" />
<ListBoxItem Content="Item #3" />
</ListBox>
</ui:MindFusionButton.PopupContent>
</ui:MindFusionButton>

Here is an image illustrating the result:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.UI.Wpf.MindFusionButton

See Also

MindFusionButton Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Members

MindFusionButton Members
Constructors Fields Properties Methods Events
[image]

Represents an advanced button that can optionally display a drop-down panel when clicked.

The following tables list the members exposed by the MindFusionButton type.

Public Constructors

Name | Description
MindFusionButton | Initializes a new instance of the MindFusionButton class.

Public Fields

Name | Description
ButtonTypeProperty | Identifies the ButtonType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HandleMouseEventsProperty | This member is for internal use only.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
OverBackgroundProperty | Identifies the OverBackground dependency property.
PopupContentProperty | Identifies the PopupContent dependency property.
PressedBackgroundProperty | Identifies the PressedBackground dependency property.
SplitButtonSizeProperty | Identifies the SplitButtonSize dependency property.

Public Properties

Name | Description
ButtonType | Gets or sets the type of the button. This is a dependency property.
CornerRadius | Gets or sets the roundness of the button corners. This is a dependency property.
HandleMouseEvents | This member is for internal use only.
IsDropDownOpen | Gets or sets a value indicating whether the drop-down panel is open. This is a dependency property.
OverBackground | Gets or sets the background of the button when it is pointed with the mouse. This is a dependency property.
PopupContent | Gets or sets the contents of the drop-down panel. This is a dependency property.
PressedBackground | Gets or sets the background of the button when it is pressed. This is a dependency property.
SplitButtonSize | Gets or sets the width of the area containing the drop-down indicator. This is a dependency property.

Public Methods

Name | Description
ForseReleaseMouseCapture |
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnClick | Raises the Click event.
OnDropDownClosed | Raises the DropDownClosed event.
OnDropDownOpened | Raises the DropDownOpened event.
OnMouseButtonDown | Raises the MouseButtonDown event.
OnSplitClick | Raises the SplitClick event.

Public Events

Name | Description
Click | Raised when the button is clicked.
DropDownClosed | Raised when the drop down panel is closed.
DropDownOpened | Raised when the drop down panel is opened.
MouseButtonDown | Raised when the mouse is pressed anywhere in the button.
SplitClick | Raised when the drop-down indicator in the button is clicked.

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Fields

MindFusionButton Fields
[image]

Public Fields

Name | Description
ButtonTypeProperty | Identifies the ButtonType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HandleMouseEventsProperty | This member is for internal use only.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
OverBackgroundProperty | Identifies the OverBackground dependency property.
PopupContentProperty | Identifies the PopupContent dependency property.
PressedBackgroundProperty | Identifies the PressedBackground dependency property.
SplitButtonSizeProperty | Identifies the SplitButtonSize dependency property.

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.ButtonTypeProperty Field

MindFusionButton.ButtonTypeProperty Field
[image]

Identifies the ButtonType dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonTypeProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.CornerRadiusProperty Field

MindFusionButton.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.HandleMouseEventsProperty Field

MindFusionButton.HandleMouseEventsProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandleMouseEventsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandleMouseEventsProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.IsDropDownOpenProperty Field

MindFusionButton.IsDropDownOpenProperty Field
[image]

Identifies the IsDropDownOpen dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDropDownOpenProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OverBackgroundProperty Field

MindFusionButton.OverBackgroundProperty Field
[image]

Identifies the OverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverBackgroundProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.PopupContentProperty Field

MindFusionButton.PopupContentProperty Field
[image]

Identifies the PopupContent dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PopupContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PopupContentProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.PressedBackgroundProperty Field

MindFusionButton.PressedBackgroundProperty Field
[image]

Identifies the PressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PressedBackgroundProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.SplitButtonSizeProperty Field

MindFusionButton.SplitButtonSizeProperty Field
[image]

Identifies the SplitButtonSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SplitButtonSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SplitButtonSizeProperty As DependencyProperty

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Constructor

MindFusionButton Constructor
[image]

Initializes a new instance of the MindFusionButton class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public MindFusionButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Methods

MindFusionButton Methods
[image]

Public Methods

Name | Description
ForseReleaseMouseCapture |
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnClick | Raises the Click event.
OnDropDownClosed | Raises the DropDownClosed event.
OnDropDownOpened | Raises the DropDownOpened event.
OnMouseButtonDown | Raises the MouseButtonDown event.
OnSplitClick | Raises the SplitClick event.

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.ForseReleaseMouseCapture Method

MindFusionButton.ForseReleaseMouseCapture Method
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public void ForseReleaseMouseCapture ()

Visual Basic [image] Copy Code

Public Sub ForseReleaseMouseCapture ()

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnApplyTemplate Method

MindFusionButton.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnClick Method

MindFusionButton.OnClick Method
[image]

Raises the Click event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClick (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClick( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnDropDownClosed Method

MindFusionButton.OnDropDownClosed Method
[image]

Raises the DropDownClosed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDropDownClosed (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDropDownClosed( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnDropDownOpened Method

MindFusionButton.OnDropDownOpened Method
[image]

Raises the DropDownOpened event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDropDownOpened (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDropDownOpened( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnMouseButtonDown Method

MindFusionButton.OnMouseButtonDown Method
[image]

Raises the MouseButtonDown event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OnSplitClick Method

MindFusionButton.OnSplitClick Method
[image]

Raises the SplitClick event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSplitClick (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSplitClick( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Properties

MindFusionButton Properties
[image]

Public Properties

Name | Description
ButtonType | Gets or sets the type of the button. This is a dependency property.
CornerRadius | Gets or sets the roundness of the button corners. This is a dependency property.
HandleMouseEvents | This member is for internal use only.
IsDropDownOpen | Gets or sets a value indicating whether the drop-down panel is open. This is a dependency property.
OverBackground | Gets or sets the background of the button when it is pointed with the mouse. This is a dependency property.
PopupContent | Gets or sets the contents of the drop-down panel. This is a dependency property.
PressedBackground | Gets or sets the background of the button when it is pressed. This is a dependency property.
SplitButtonSize | Gets or sets the width of the area containing the drop-down indicator. This is a dependency property.

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.ButtonType Property

MindFusionButton.ButtonType Property
[image]

Gets or sets the type of the button. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public MindFusionButtonType ButtonType { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonType As MindFusionButtonType

Property Value

A member of the MindFusionButtonType enumeration.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.CornerRadius Property

MindFusionButton.CornerRadius Property
[image]

Gets or sets the roundness of the button corners. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.HandleMouseEvents Property

MindFusionButton.HandleMouseEvents Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool HandleMouseEvents { get; set; }

Visual Basic [image] Copy Code

Public Property HandleMouseEvents As Boolean

Property Value

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.IsDropDownOpen Property

MindFusionButton.IsDropDownOpen Property
[image]

Gets or sets a value indicating whether the drop-down panel is open. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool IsDropDownOpen { get; set; }

Visual Basic [image] Copy Code

Public Property IsDropDownOpen As Boolean

Property Value

true if the drop-down panel is open; otherwise, false.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.OverBackground Property

MindFusionButton.OverBackground Property
[image]

Gets or sets the background of the button when it is pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush OverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property OverBackground As Brush

Property Value

A WPF Brush object.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.PopupContent Property

MindFusionButton.PopupContent Property
[image]

Gets or sets the contents of the drop-down panel. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public FrameworkElement PopupContent { get; set; }

Visual Basic [image] Copy Code

Public Property PopupContent As FrameworkElement

Property Value

A FrameworkElement-derived object.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.PressedBackground Property

MindFusionButton.PressedBackground Property
[image]

Gets or sets the background of the button when it is pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush PressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property PressedBackground As Brush

Property Value

A WPF Brush object.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.SplitButtonSize Property

MindFusionButton.SplitButtonSize Property
[image]

Gets or sets the width of the area containing the drop-down indicator. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double SplitButtonSize { get; set; }

Visual Basic [image] Copy Code

Public Property SplitButtonSize As Double

Property Value

A double value specifying the size.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton Events

MindFusionButton Events
[image]

Public Events

Name | Description
Click | Raised when the button is clicked.
DropDownClosed | Raised when the drop down panel is closed.
DropDownOpened | Raised when the drop down panel is opened.
MouseButtonDown | Raised when the mouse is pressed anywhere in the button.
SplitClick | Raised when the drop-down indicator in the button is clicked.

See Also

MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.Click Event

MindFusionButton.Click Event
[image]

Raised when the button is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Click

Visual Basic [image] Copy Code

Public Event Click As EventHandler

Event Data

Click event handlers receive an argument of type EventArgs.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.DropDownClosed Event

MindFusionButton.DropDownClosed Event
[image]

Raised when the drop down panel is closed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DropDownClosed

Visual Basic [image] Copy Code

Public Event DropDownClosed As EventHandler

Event Data

DropDownClosed event handlers receive an argument of type EventArgs.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.DropDownOpened Event

MindFusionButton.DropDownOpened Event
[image]

Raised when the drop down panel is opened.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DropDownOpened

Visual Basic [image] Copy Code

Public Event DropDownOpened As EventHandler

Event Data

DropDownOpened event handlers receive an argument of type EventArgs.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.MouseButtonDown Event

MindFusionButton.MouseButtonDown Event
[image]

Raised when the mouse is pressed anywhere in the button.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event MouseButtonEventHandler MouseButtonDown

Visual Basic [image] Copy Code

Public Event MouseButtonDown As MouseButtonEventHandler

Event Data

MouseButtonDown event handlers receive an argument of type MouseButtonEventArgs.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButton.SplitClick Event

MindFusionButton.SplitClick Event
[image]

Raised when the drop-down indicator in the button is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler SplitClick

Visual Basic [image] Copy Code

Public Event SplitClick As EventHandler

Event Data

SplitClick event handlers receive an argument of type EventArgs.

See Also

MindFusionButton Members
MindFusionButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MindFusionButtonType Enumeration

MindFusionButtonType Enumeration
[image]

Specifies the behavior of a MindFusionButton.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum MindFusionButtonType

Visual Basic [image] Copy Code

Public Enum MindFusionButtonType

Members

Member name | Description
DropDown | Indicates that the button will drop down a panel when pressed.
Normal | Indicates that the button will act as a normal button.
Repeat | Indicates that the button will act as a repeat button.
SplitDropDown | Indicates that the button will drop down a panel when pressed. The drop down indicator is visually separated from the button content.

Remarks

Values of this enumeration can be assigned to the ButtonType property of the MindFusionButton class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.MinimizeMode Enumeration

MinimizeMode Enumeration
[image]

Specifies the behavior of minimized windows.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum MinimizeMode

Visual Basic [image] Copy Code

Public Enum MinimizeMode

Members

Member name | Description
HostBottom | Indicates that the minimized window is arranged at the bottom of their containing WindowHost.
HostTop | Indicates that the minimized window is arranged at the top of their containing WindowHost.
InPlace | Indicates that the window is minimized in-place.

Remarks

Values from this enumeration are assigned to the MinimizeMode property of the Window class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Class

NumericUpDown Class
Remarks See Also
[image]

Represents a numeric text box with buttons to increase or decrease the displayed value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class NumericUpDown : Control

Visual Basic [image] Copy Code

Public Class NumericUpDown
Inherits Control

Remarks

The NumericUpDown control enables users to select a numeric value by either typing the value in a text box or by using buttons to adjust the current value with a predefined amount. The current value of the control can be get or set through the Value property. The range of allowed values is specified through the Minimum and Maximum properties. The appearance of the increment and decrement buttons can be modified through the following properties: ButtonBackground, ButtonBorderBrush, ButtonBorderThickness, ButtonOverBackground, ButtonPressedBackground and ButtonSize.

Example

The following example demonstrates a NumericUpDown control declared in XAML:

XAML [image] Copy Code

<ui:NumericUpDown Value="1" SmallChange="0.5" Width="80" Height="26" HorizontalAlignment="Left" VerticalAlignment="Top" />

The above code will produce result similar to the following:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.NumericUpDown

See Also

NumericUpDown Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Members

NumericUpDown Members
Constructors Fields Properties Methods Events
[image]

Represents a numeric text box with buttons to increase or decrease the displayed value.

The following tables list the members exposed by the NumericUpDown type.

Public Constructors

Name | Description
NumericUpDown | Initializes a new instance of the NumericUpDown class.

Public Fields

Name | Description
AutoReverseProperty | Identifies the AutoReverse dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
DecimalDigitsProperty | Identifies the DecimalDigits dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
SmallChangeProperty | Identifies the SmallChange dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
AutoReverse | Gets or sets a value indicating whether the value should auto reverse when going below Minimum or above Maximum. This is a dependency property.
ButtonBackground | Gets or sets the background of the increment/decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the increment/decrement buttons. This is a dependency property.
DecimalDigits | Gets or sets the number of digits to display after the floating point. This is a dependency property.
IsEditable | Gets or sets a value indicating whether the control is enabled. This is a dependency property.
Maximum | Gets or sets the maximum possible value. This is a dependency property.
Minimum | Gets or sets the minimum possible value. This is a dependency property.
SmallChange | Gets or sets the amount to increase or decrease the value with when the increment or decrement buttons are pressed. This is a dependency property.
TextAlignment | Gets or sets the alignment of the text inside the control. This is a dependency property.
Value | Gets or sets the value of the control. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnValueChanged | Raises the ValueChanged event.

Public Events

Name | Description
ValueChanged | Raised when the value displayed by the control has changed.

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Fields

NumericUpDown Fields
[image]

Public Fields

Name | Description
AutoReverseProperty | Identifies the AutoReverse dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
DecimalDigitsProperty | Identifies the DecimalDigits dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
SmallChangeProperty | Identifies the SmallChange dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.AutoReverseProperty Field

NumericUpDown.AutoReverseProperty Field
[image]

Identifies the AutoReverse dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoReverseProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoReverseProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBackgroundProperty Field

NumericUpDown.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBorderBrushProperty Field

NumericUpDown.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBorderThicknessProperty Field

NumericUpDown.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonOverBackgroundProperty Field

NumericUpDown.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonPressedBackgroundProperty Field

NumericUpDown.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonSizeProperty Field

NumericUpDown.ButtonSizeProperty Field
[image]

Identifies the ButtonSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonSizeProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.DecimalDigitsProperty Field

NumericUpDown.DecimalDigitsProperty Field
[image]

Identifies the DecimalDigits dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DecimalDigitsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DecimalDigitsProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.IsEditableProperty Field

NumericUpDown.IsEditableProperty Field
[image]

Identifies the IsEditable dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsEditableProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsEditableProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.MaximumProperty Field

NumericUpDown.MaximumProperty Field
[image]

Identifies the Maximum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaximumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.MinimumProperty Field

NumericUpDown.MinimumProperty Field
[image]

Identifies the Minimum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.SmallChangeProperty Field

NumericUpDown.SmallChangeProperty Field
[image]

Identifies the SmallChange dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SmallChangeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SmallChangeProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.TextAlignmentProperty Field

NumericUpDown.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ValueProperty Field

NumericUpDown.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Constructor

NumericUpDown Constructor
[image]

Initializes a new instance of the NumericUpDown class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public NumericUpDown ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Methods

NumericUpDown Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnValueChanged | Raises the ValueChanged event.

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.OnApplyTemplate Method

NumericUpDown.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.OnValueChanged Method

NumericUpDown.OnValueChanged Method
[image]

Raises the ValueChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValueChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValueChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Properties

NumericUpDown Properties
[image]

Public Properties

Name | Description
AutoReverse | Gets or sets a value indicating whether the value should auto reverse when going below Minimum or above Maximum. This is a dependency property.
ButtonBackground | Gets or sets the background of the increment/decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the increment/decrement buttons. This is a dependency property.
DecimalDigits | Gets or sets the number of digits to display after the floating point. This is a dependency property.
IsEditable | Gets or sets a value indicating whether the control is enabled. This is a dependency property.
Maximum | Gets or sets the maximum possible value. This is a dependency property.
Minimum | Gets or sets the minimum possible value. This is a dependency property.
SmallChange | Gets or sets the amount to increase or decrease the value with when the increment or decrement buttons are pressed. This is a dependency property.
TextAlignment | Gets or sets the alignment of the text inside the control. This is a dependency property.
Value | Gets or sets the value of the control. This is a dependency property.

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.AutoReverse Property

NumericUpDown.AutoReverse Property
[image]

Gets or sets a value indicating whether the value should auto reverse when going below Minimum or above Maximum. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool AutoReverse { get; set; }

Visual Basic [image] Copy Code

Public Property AutoReverse As Boolean

Property Value

true to enable automatic reversal; otherwise, false.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBackground Property

NumericUpDown.ButtonBackground Property
[image]

Gets or sets the background of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBorderBrush Property

NumericUpDown.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonBorderThickness Property

NumericUpDown.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonOverBackground Property

NumericUpDown.ButtonOverBackground Property
[image]

Gets or sets the background of the increment/decrement buttons when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonPressedBackground Property

NumericUpDown.ButtonPressedBackground Property
[image]

Gets or sets the background of the increment/decrement buttons when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ButtonSize Property

NumericUpDown.ButtonSize Property
[image]

Gets or sets the size of the increment/decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double ButtonSize { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonSize As Double

Property Value

A double value specifying the size.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.DecimalDigits Property

NumericUpDown.DecimalDigits Property
[image]

Gets or sets the number of digits to display after the floating point. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public int DecimalDigits { get; set; }

Visual Basic [image] Copy Code

Public Property DecimalDigits As Integer

Property Value

An integer value specifying the number of digits.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.IsEditable Property

NumericUpDown.IsEditable Property
[image]

Gets or sets a value indicating whether the control is enabled. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool IsEditable { get; set; }

Visual Basic [image] Copy Code

Public Property IsEditable As Boolean

Property Value

true if the control is enabled; otherwise, false.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.Maximum Property

NumericUpDown.Maximum Property
[image]

Gets or sets the maximum possible value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double Maximum { get; set; }

Visual Basic [image] Copy Code

Public Property Maximum As Double

Property Value

A double value specifying the maximum.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.Minimum Property

NumericUpDown.Minimum Property
[image]

Gets or sets the minimum possible value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double Minimum { get; set; }

Visual Basic [image] Copy Code

Public Property Minimum As Double

Property Value

A double value specifying the minimum.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.SmallChange Property

NumericUpDown.SmallChange Property
[image]

Gets or sets the amount to increase or decrease the value with when the increment or decrement buttons are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double SmallChange { get; set; }

Visual Basic [image] Copy Code

Public Property SmallChange As Double

Property Value

A double value specifying the step.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.TextAlignment Property

NumericUpDown.TextAlignment Property
[image]

Gets or sets the alignment of the text inside the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the WPF TextAlignment enumeration.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.Value Property

NumericUpDown.Value Property
[image]

Gets or sets the value of the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown Events

NumericUpDown Events
[image]

Public Events

Name | Description
ValueChanged | Raised when the value displayed by the control has changed.

See Also

NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumericUpDown.ValueChanged Event

NumericUpDown.ValueChanged Event
[image]

Raised when the value displayed by the control has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> ValueChanged

Visual Basic [image] Copy Code

Public Event ValueChanged As EventHandler(Of EventArgs)

Event Data

ValueChanged event handlers receive an argument of type EventArgs.

See Also

NumericUpDown Members
NumericUpDown Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Class

NumPadKey Class
[image]

Represents a num pad key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class NumPadKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class NumPadKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.NumPadKey

See Also

NumPadKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Members

NumPadKey Members
Constructors Properties Methods Events
[image]

Represents a num pad key.

The following tables list the members exposed by the NumPadKey type.

Public Constructors

Name | Description
NumPadKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumCase | Gets or sets the key label.
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this NumPadKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Constructor

NumPadKey Constructor
[image]

Overload List

Name | Description
NumPadKey () | Initializes a new instance of the NumPadKey class.
NumPadKey (Int32) | Initializes a new instance of the NumPadKey class with specified virtual key code.
NumPadKey (Int32, Object) | Initializes a new instance of the NumPadKey class with specified virtual key code and content.

See Also

NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Constructor ()

NumPadKey Constructor ()
See Also
[image]

Initializes a new instance of the NumPadKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NumPadKey Constructor Overload List
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Constructor (Int32)

NumPadKey Constructor (Int32)
See Also
[image]

Initializes a new instance of the NumPadKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

NumPadKey Constructor Overload List
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Constructor (Int32, Object)

NumPadKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instance of the NumPadKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public NumPadKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

Label of the key's alternative function.

See Also

NumPadKey Constructor Overload List
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Methods

NumPadKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this NumPadKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.Clone Method

NumPadKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new NumPadKey instance.

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.Equals Method

NumPadKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.GetHashCode Method

NumPadKey.GetHashCode Method
[image]

Returns a hash code for this NumPadKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.Send Method

NumPadKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release special keys, or false otherwise.

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Properties

NumPadKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumCase | Gets or sets the key label.
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.NumCase Property

NumPadKey.NumCase Property
[image]

Gets or sets the key label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string NumCase { get; set; }

Visual Basic [image] Copy Code

Public Property NumCase As String

Property Value

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey.VirtualKey Property

NumPadKey.VirtualKey Property
[image]

Gets or sets the key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

NumPadKey Members
NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.NumPadKey Events

NumPadKey Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

NumPadKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyDisplayType Enumeration

PropertyDisplayType Enumeration
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum PropertyDisplayType

Visual Basic [image] Copy Code

Public Enum PropertyDisplayType

Members

Member name | Description
All |
DeclaredOnly |

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Class

PropertyGrid Class
[image]

Provides a user interface for browsing the properties of an object.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class PropertyGrid : Control

Visual Basic [image] Copy Code

Public Class PropertyGrid
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.PropertyGrid

See Also

PropertyGrid Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Members

PropertyGrid Members
Constructors Fields Properties Methods
[image]

Provides a user interface for browsing the properties of an object.

The following tables list the members exposed by the PropertyGrid type.

Public Constructors

Name | Description
PropertyGrid | Initializes a new instance of the PropertyGrid class.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DescriptionProperty | Identifies the Description dependency property.
DescriptionVisibilityProperty | Identifies the DescriptionVisibility dependency property.
FilterTypeListProperty | Identifies the FilterTypeList dependency property.
HeaderProperty | Identifies the Header dependency property.
PropertyDisplayTypeProperty | Identifies the PropertyDisplayType dependency property.
PropertySortTypeProperty | Identifies the PropertyDisplayType dependency property.
SectionBackgroundProperty | Identifies the SectionBackground dependency property.
SectionBorderBrushProperty | Identifies the SectionBorderBrush dependency property.
SectionBorderThicknessProperty | Identifies the SectionBorderThickness dependency property.
SectionCornerRadiusProperty | Identifies the SectionCornerRadius dependency property.
SectionMarginProperty | Identifies the SectionMargin dependency property.
SelectedObjectProperty | Identifies the SelectedObject dependency property.
ShowReadOnlyPropertiesProperty | Identifies the ShowReadOnlyProperties dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets the radius of the grid's corners. This is a dependency property.
Description | Gets or sets the description displayed in the grid. This is a dependency property.
DescriptionVisibility | Gets or sets a value indicating whether to show the description pane in the grid. This is a dependency property.
FilterTypeList | Get or sets a list of objects specifying which properties should be displayed in the grid. This is a dependency property.
Header | Gets or sets the text displayed in the grid title. This is a dependency property.
PropertyDisplayType | Get or sets a value indicating how to display the properties in the grid. This is a dependency property.
PropertySortType | Get or sets a value indicating how to sort the properties in the grid. This is a dependency property.
SectionBackground | Gets or sets the background brush of the inner section of the grid. This is a dependency property.
SectionBorderBrush | Gets or sets the border brush of the inner section of the grid. This is a dependency property.
SectionBorderThickness | Gets or sets the border thickness of the inner section of the grid. This is a dependency property.
SectionCornerRadius | Gets or sets the radius of the corners of the inner section of the grid. This is a dependency property.
SectionMargin | Gets or sets the margins of the inner section of the grid. This is a dependency property.
SelectedObject | Gets or sets the object whose properties are displayed in the grid. This is a dependency property.
ShowReadOnlyProperties | Gets or sets a value indicating whether to display read-only properties. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.
OnCollectionEditorClosed |

See Also

PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Fields

PropertyGrid Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DescriptionProperty | Identifies the Description dependency property.
DescriptionVisibilityProperty | Identifies the DescriptionVisibility dependency property.
FilterTypeListProperty | Identifies the FilterTypeList dependency property.
HeaderProperty | Identifies the Header dependency property.
PropertyDisplayTypeProperty | Identifies the PropertyDisplayType dependency property.
PropertySortTypeProperty | Identifies the PropertyDisplayType dependency property.
SectionBackgroundProperty | Identifies the SectionBackground dependency property.
SectionBorderBrushProperty | Identifies the SectionBorderBrush dependency property.
SectionBorderThicknessProperty | Identifies the SectionBorderThickness dependency property.
SectionCornerRadiusProperty | Identifies the SectionCornerRadius dependency property.
SectionMarginProperty | Identifies the SectionMargin dependency property.
SelectedObjectProperty | Identifies the SelectedObject dependency property.
ShowReadOnlyPropertiesProperty | Identifies the ShowReadOnlyProperties dependency property.

See Also

PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.CornerRadiusProperty Field

PropertyGrid.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.DescriptionProperty Field

PropertyGrid.DescriptionProperty Field
[image]

Identifies the Description dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DescriptionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DescriptionProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.DescriptionVisibilityProperty Field

PropertyGrid.DescriptionVisibilityProperty Field
[image]

Identifies the DescriptionVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DescriptionVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DescriptionVisibilityProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.FilterTypeListProperty Field

PropertyGrid.FilterTypeListProperty Field
[image]

Identifies the FilterTypeList dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FilterTypeListProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FilterTypeListProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.HeaderProperty Field

PropertyGrid.HeaderProperty Field
[image]

Identifies the Header dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.PropertyDisplayTypeProperty Field

PropertyGrid.PropertyDisplayTypeProperty Field
[image]

Identifies the PropertyDisplayType dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PropertyDisplayTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PropertyDisplayTypeProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.PropertySortTypeProperty Field

PropertyGrid.PropertySortTypeProperty Field
[image]

Identifies the PropertyDisplayType dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PropertySortTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PropertySortTypeProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBackgroundProperty Field

PropertyGrid.SectionBackgroundProperty Field
[image]

Identifies the SectionBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionBackgroundProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBorderBrushProperty Field

PropertyGrid.SectionBorderBrushProperty Field
[image]

Identifies the SectionBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionBorderBrushProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBorderThicknessProperty Field

PropertyGrid.SectionBorderThicknessProperty Field
[image]

Identifies the SectionBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionBorderThicknessProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionCornerRadiusProperty Field

PropertyGrid.SectionCornerRadiusProperty Field
[image]

Identifies the SectionCornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionCornerRadiusProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionMarginProperty Field

PropertyGrid.SectionMarginProperty Field
[image]

Identifies the SectionMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionMarginProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SelectedObjectProperty Field

PropertyGrid.SelectedObjectProperty Field
[image]

Identifies the SelectedObject dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedObjectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedObjectProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.ShowReadOnlyPropertiesProperty Field

PropertyGrid.ShowReadOnlyPropertiesProperty Field
[image]

Identifies the ShowReadOnlyProperties dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowReadOnlyPropertiesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowReadOnlyPropertiesProperty As DependencyProperty

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Constructor

PropertyGrid Constructor
[image]

Initializes a new instance of the PropertyGrid class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public PropertyGrid ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Methods

PropertyGrid Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.
OnCollectionEditorClosed |

See Also

PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.OnApplyTemplate Method

PropertyGrid.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.OnCollectionEditorClosed Method

PropertyGrid.OnCollectionEditorClosed Method
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public void OnCollectionEditorClosed (
EventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnCollectionEditorClosed( _
e As EventArgs _
)

Parameters

e

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid Properties

PropertyGrid Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the radius of the grid's corners. This is a dependency property.
Description | Gets or sets the description displayed in the grid. This is a dependency property.
DescriptionVisibility | Gets or sets a value indicating whether to show the description pane in the grid. This is a dependency property.
FilterTypeList | Get or sets a list of objects specifying which properties should be displayed in the grid. This is a dependency property.
Header | Gets or sets the text displayed in the grid title. This is a dependency property.
PropertyDisplayType | Get or sets a value indicating how to display the properties in the grid. This is a dependency property.
PropertySortType | Get or sets a value indicating how to sort the properties in the grid. This is a dependency property.
SectionBackground | Gets or sets the background brush of the inner section of the grid. This is a dependency property.
SectionBorderBrush | Gets or sets the border brush of the inner section of the grid. This is a dependency property.
SectionBorderThickness | Gets or sets the border thickness of the inner section of the grid. This is a dependency property.
SectionCornerRadius | Gets or sets the radius of the corners of the inner section of the grid. This is a dependency property.
SectionMargin | Gets or sets the margins of the inner section of the grid. This is a dependency property.
SelectedObject | Gets or sets the object whose properties are displayed in the grid. This is a dependency property.
ShowReadOnlyProperties | Gets or sets a value indicating whether to display read-only properties. This is a dependency property.

See Also

PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.CornerRadius Property

PropertyGrid.CornerRadius Property
[image]

Gets or sets the radius of the grid's corners. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the CornerRadius structure. The default is CornerRadius(0).

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.Description Property

PropertyGrid.Description Property
[image]

Gets or sets the description displayed in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public string Description { get; set; }

Visual Basic [image] Copy Code

Public Property Description As String

Property Value

A string value.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.DescriptionVisibility Property

PropertyGrid.DescriptionVisibility Property
[image]

Gets or sets a value indicating whether to show the description pane in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Visibility DescriptionVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property DescriptionVisibility As Visibility

Property Value

A member of the Visibility enumeration. The default is Visible.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.FilterTypeList Property

PropertyGrid.FilterTypeList Property
[image]

Get or sets a list of objects specifying which properties should be displayed in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public List<Type> FilterTypeList { get; set; }

Visual Basic [image] Copy Code

Public Property FilterTypeList As List(Of Type)

Property Value

A list of Type objects, or null (Nothing in Visual Basic) to display all properties.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.Header Property

PropertyGrid.Header Property
[image]

Gets or sets the text displayed in the grid title. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public string Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As String

Property Value

A string value.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.PropertyDisplayType Property

PropertyGrid.PropertyDisplayType Property
[image]

Get or sets a value indicating how to display the properties in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public PropertyDisplayType PropertyDisplayType { get; set; }

Visual Basic [image] Copy Code

Public Property PropertyDisplayType As PropertyDisplayType

Property Value

A member of the PropertyDisplayType enumeration. The default is All.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.PropertySortType Property

PropertyGrid.PropertySortType Property
[image]

Get or sets a value indicating how to sort the properties in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public PropertySortType PropertySortType { get; set; }

Visual Basic [image] Copy Code

Public Property PropertySortType As PropertySortType

Property Value

A member of the PropertySortType enumeration. The default is Alphabetically.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBackground Property

PropertyGrid.SectionBackground Property
[image]

Gets or sets the background brush of the inner section of the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush SectionBackground { get; set; }

Visual Basic [image] Copy Code

Public Property SectionBackground As Brush

Property Value

An instance of the WPF Brush class.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBorderBrush Property

PropertyGrid.SectionBorderBrush Property
[image]

Gets or sets the border brush of the inner section of the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush SectionBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SectionBorderBrush As Brush

Property Value

An instance of the WPF Brush class.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionBorderThickness Property

PropertyGrid.SectionBorderThickness Property
[image]

Gets or sets the border thickness of the inner section of the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness SectionBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property SectionBorderThickness As Thickness

Property Value

An instance of the Thickness structure.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionCornerRadius Property

PropertyGrid.SectionCornerRadius Property
[image]

Gets or sets the radius of the corners of the inner section of the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public CornerRadius SectionCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property SectionCornerRadius As CornerRadius

Property Value

An instance of the CornerRadius structure.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SectionMargin Property

PropertyGrid.SectionMargin Property
[image]

Gets or sets the margins of the inner section of the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness SectionMargin { get; set; }

Visual Basic [image] Copy Code

Public Property SectionMargin As Thickness

Property Value

An instance of the Thickness structure.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.SelectedObject Property

PropertyGrid.SelectedObject Property
[image]

Gets or sets the object whose properties are displayed in the grid. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Object SelectedObject { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedObject As Object

Property Value

An object.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertyGrid.ShowReadOnlyProperties Property

PropertyGrid.ShowReadOnlyProperties Property
[image]

Gets or sets a value indicating whether to display read-only properties. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool ShowReadOnlyProperties { get; set; }

Visual Basic [image] Copy Code

Public Property ShowReadOnlyProperties As Boolean

Property Value

A boolean value. The default is true.

See Also

PropertyGrid Members
PropertyGrid Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.PropertySortType Enumeration

PropertySortType Enumeration
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum PropertySortType

Visual Basic [image] Copy Code

Public Enum PropertySortType

Members

Member name | Description
Alphabetically |
ByCategory |

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Class

RangeSelector Class
[image]

Represents a range selector – a control which allows the users to interactively select a range inside a larger range.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class RangeSelector : Control

Visual Basic [image] Copy Code

Public Class RangeSelector
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.RangeSelector

See Also

RangeSelector Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Members

RangeSelector Members
Constructors Fields Properties Methods Events
[image]

Represents a range selector – a control which allows the users to interactively select a range inside a larger range.

The following tables list the members exposed by the RangeSelector type.

Public Constructors

Name | Description
RangeSelector | Initializes a new instance of the RangeSelector class.

Public Fields

Name | Description
ButtonSizeProperty | Identifies the ButtonSize dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
MinimumSelectionLengthProperty | Identifies the MinimumSelectionLength dependency property.
ProjectionBrushProperty | Identifies the ProjectionBrush dependency property,.
ScrollBackgroundBrushProperty | Identifies the ScrollBackgroundBrush dependency property.
SelectionBrushProperty | Identifies the SelectionBrush dependency property.
SelectionEndProperty | Identifies the SelectionEnd dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
StepProperty | Identifies the Step dependency property.

Public Properties

Name | Description
ButtonSize | Gets or sets the size of the buttons. This is a dependency property
Maximum | Gets or sets the maximum of the control range. This is a dependency property.
Minimum | Gets or sets the minimum of the control range. This is a dependency property.
MinimumSelectionLength | Gets or sets the minimum size of the selected range. This is a dependency property.
ProjectionBrush | Gets or sets the brush used to fill the selection projection. This is a dependency property.
ScrollBackgroundBrush | Gets or sets the brush used to fill the scroll background. This is a dependency property.
SelectionBrush | Gets or sets the brush used to fill the selection. This is a dependency property.
SelectionEnd | Gets or sets the end of the selected range. This is a dependency property.
SelectionStart | Gets or sets the start of the selected range. This is a dependency property.
Step | Gets or sets the step to scroll with when using the buttons. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.

Protected Methods

Name | Description
OnDrawBackground | Raises the DrawBackground event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnValueChanged | Raises the ValueChanged event.

Public Events

Name | Description
DrawBackground | Raised to allow custom-drawing of the selector's background.
ValueChanged | Occurs when the selection has changed interactively by the user.

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Fields

RangeSelector Fields
[image]

Public Fields

Name | Description
ButtonSizeProperty | Identifies the ButtonSize dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
MinimumSelectionLengthProperty | Identifies the MinimumSelectionLength dependency property.
ProjectionBrushProperty | Identifies the ProjectionBrush dependency property,.
ScrollBackgroundBrushProperty | Identifies the ScrollBackgroundBrush dependency property.
SelectionBrushProperty | Identifies the SelectionBrush dependency property.
SelectionEndProperty | Identifies the SelectionEnd dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
StepProperty | Identifies the Step dependency property.

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ButtonSizeProperty Field

RangeSelector.ButtonSizeProperty Field
[image]

Identifies the ButtonSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonSizeProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.MaximumProperty Field

RangeSelector.MaximumProperty Field
[image]

Identifies the Maximum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaximumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.MinimumProperty Field

RangeSelector.MinimumProperty Field
[image]

Identifies the Minimum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.MinimumSelectionLengthProperty Field

RangeSelector.MinimumSelectionLengthProperty Field
[image]

Identifies the MinimumSelectionLength dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumSelectionLengthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumSelectionLengthProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ProjectionBrushProperty Field

RangeSelector.ProjectionBrushProperty Field
[image]

Identifies the ProjectionBrush dependency property,.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProjectionBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProjectionBrushProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ScrollBackgroundBrushProperty Field

RangeSelector.ScrollBackgroundBrushProperty Field
[image]

Identifies the ScrollBackgroundBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollBackgroundBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollBackgroundBrushProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionBrushProperty Field

RangeSelector.SelectionBrushProperty Field
[image]

Identifies the SelectionBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionBrushProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionEndProperty Field

RangeSelector.SelectionEndProperty Field
[image]

Identifies the SelectionEnd dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionEndProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionEndProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionStartProperty Field

RangeSelector.SelectionStartProperty Field
[image]

Identifies the SelectionStart dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionStartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionStartProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.StepProperty Field

RangeSelector.StepProperty Field
[image]

Identifies the Step dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StepProperty As DependencyProperty

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Constructor

RangeSelector Constructor
[image]

Initializes a new instance of the RangeSelector class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RangeSelector ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Methods

RangeSelector Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Control.OnApplyTemplate override.

Protected Methods

Name | Description
OnDrawBackground | Raises the DrawBackground event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnValueChanged | Raises the ValueChanged event.

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnApplyTemplate Method

RangeSelector.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnDrawBackground Method

RangeSelector.OnDrawBackground Method
[image]

Raises the DrawBackground event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnDrawBackground (
DrawEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawBackground( _
e As DrawEventArgs _
)

Parameters

e

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnMouseDown Method

RangeSelector.OnMouseDown Method
[image]

Control.OnMouseDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnMouseMove Method

RangeSelector.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnMouseUp Method

RangeSelector.OnMouseUp Method
[image]

Control.OnMouseUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.OnValueChanged Method

RangeSelector.OnValueChanged Method
[image]

Raises the ValueChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValueChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValueChanged( _
e As EventArgs _
)

Parameters

e

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Properties

RangeSelector Properties
[image]

Public Properties

Name | Description
ButtonSize | Gets or sets the size of the buttons. This is a dependency property
Maximum | Gets or sets the maximum of the control range. This is a dependency property.
Minimum | Gets or sets the minimum of the control range. This is a dependency property.
MinimumSelectionLength | Gets or sets the minimum size of the selected range. This is a dependency property.
ProjectionBrush | Gets or sets the brush used to fill the selection projection. This is a dependency property.
ScrollBackgroundBrush | Gets or sets the brush used to fill the scroll background. This is a dependency property.
SelectionBrush | Gets or sets the brush used to fill the selection. This is a dependency property.
SelectionEnd | Gets or sets the end of the selected range. This is a dependency property.
SelectionStart | Gets or sets the start of the selected range. This is a dependency property.
Step | Gets or sets the step to scroll with when using the buttons. This is a dependency property.

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ButtonSize Property

RangeSelector.ButtonSize Property
[image]

Gets or sets the size of the buttons. This is a dependency property

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ButtonSize { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonSize As Double

Property Value

A double value. The default is 16.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.Maximum Property

RangeSelector.Maximum Property
[image]

Gets or sets the maximum of the control range. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Maximum { get; set; }

Visual Basic [image] Copy Code

Public Property Maximum As Double

Property Value

A double value. The default is 100.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.Minimum Property

RangeSelector.Minimum Property
[image]

Gets or sets the minimum of the control range. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Minimum { get; set; }

Visual Basic [image] Copy Code

Public Property Minimum As Double

Property Value

A double value. The default is 0.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.MinimumSelectionLength Property

RangeSelector.MinimumSelectionLength Property
[image]

Gets or sets the minimum size of the selected range. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double MinimumSelectionLength { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumSelectionLength As Double

Property Value

A double value. The default is 5.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ProjectionBrush Property

RangeSelector.ProjectionBrush Property
[image]

Gets or sets the brush used to fill the selection projection. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ProjectionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ProjectionBrush As Brush

Property Value

A Brush object.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ScrollBackgroundBrush Property

RangeSelector.ScrollBackgroundBrush Property
[image]

Gets or sets the brush used to fill the scroll background. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ScrollBackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollBackgroundBrush As Brush

Property Value

A Brush object.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionBrush Property

RangeSelector.SelectionBrush Property
[image]

Gets or sets the brush used to fill the selection. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush SelectionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionBrush As Brush

Property Value

A Brush object.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionEnd Property

RangeSelector.SelectionEnd Property
[image]

Gets or sets the end of the selected range. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SelectionEnd { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionEnd As Double

Property Value

A double value. The default is 10.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.SelectionStart Property

RangeSelector.SelectionStart Property
[image]

Gets or sets the start of the selected range. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SelectionStart { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionStart As Double

Property Value

A double value. The default is 0.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.Step Property

RangeSelector.Step Property
[image]

Gets or sets the step to scroll with when using the buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Step { get; set; }

Visual Basic [image] Copy Code

Public Property Step As Double

Property Value

A double value. The default is 1.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector Events

RangeSelector Events
[image]

Public Events

Name | Description
DrawBackground | Raised to allow custom-drawing of the selector's background.
ValueChanged | Occurs when the selection has changed interactively by the user.

See Also

RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.DrawBackground Event

RangeSelector.DrawBackground Event
[image]

Raised to allow custom-drawing of the selector's background.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<DrawEventArgs> DrawBackground

Visual Basic [image] Copy Code

Public Event DrawBackground As EventHandler(Of DrawEventArgs)

Event Data

DrawBackground events receive an argument of type DrawEventArgs.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RangeSelector.ValueChanged Event

RangeSelector.ValueChanged Event
[image]

Occurs when the selection has changed interactively by the user.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ValueChanged

Visual Basic [image] Copy Code

Public Event ValueChanged As EventHandler

Event Data

ValueChanged events receive an argument of type EventArgs.

See Also

RangeSelector Members
RangeSelector Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Class

Rating Class
[image]

Provides the ability to select and display ratings in a variety of formats.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class Rating : Control

Visual Basic [image] Copy Code

Public Class Rating
Inherits Control

Example

The following example declares a Rating control with custom shapes for the rating elements:

XAML [image] Copy Code

<ui:Rating Width="200" Height="200" ShapeData="M0.5,0 L0.7,0.2 L1,0.25 L0.75,0.5 L1,0.75 L0.7,0.8 L0.5,1 L0.3,0.8 L0,0.75 L0.25,0.5 L0,0.25 L0.3,0.2 z" HeaderText="Rating" FontFamily="Arial" FontSize="16" FontWeight="Bold" />

Here is an image illustrating the result:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.Rating

See Also

Rating Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Members

Rating Members
Constructors Fields Properties Methods
[image]

Provides the ability to select and display ratings in a variety of formats.

The following tables list the members exposed by the Rating type.

Public Constructors

Name | Description
Rating | Initializes a new instance of the Rating class.

Public Fields

Name | Description
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentFontSizeProperty | Identifies the ContentFontSize dependency property.
ContentFontWeightProperty | Identifies the ContentFontWeight dependency property.
ContentForegroundProperty | Identifies the ContentForeground dependency property.
ContentTextVisibilityProperty | Identifies the ContentTextVisibility dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DefaultGeometryProperty | This member is for internal use only.
EmptyGeometryProperty | This member is for internal use only.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderEffectProperty | Identifies the HeaderEffect dependency property.
HeaderForegroundProperty | Identifies the HeaderForeground dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
IsToolTipVisibleProperty | Identifies the IsToolTipVisible dependency property.
OrientationProperty | Identifies the Orientation dependency property.
OverGeometryProperty | This member is for internal use only.
PointedValueProperty | Identifies the PointedValue dependency property.
RatingModeProperty | Identifies the RatingMode dependency property.
ShapeBorderBrushProperty | Identifies the ShapeBorderBrush dependency property.
ShapeBorderThicknessProperty | Identifies the ShapeBorderThickness dependency property.
ShapeDataProperty | Identifies the ShapeData dependency property.
ShapeDefaultBackgroundProperty | Identifies the ShapeDefaultBackground dependency property.
ShapeEffectProperty | Identifies the ShapeEffect dependency property.
ShapeEmptyBackgroundProperty | Identifies the ShapeEmptyBackground dependency property.
ShapeEmptyBorderBrushProperty | Identifies the ShapeEmptyBorderBrush dependency property.
ShapeEmptyBorderThicknessProperty | Identifies the ShapeEmptyBorderThickness dependency property.
ShapeMarginProperty | Identifies the ShapeMargin dependency property.
ShapeOverBackgroundProperty | Identifies the ShapeOverBackground dependency property.
ShapeProperty | Identifies the Shape dependency property.
ShapeStretchProperty | Identifies the ShapeStretch dependency property.
ShapeValueBackgroundProperty | Identifies the ShapeValueBackground dependency property.
ShapeValueBorderBrushProperty | Identifies the ShapeValueBorderBrush dependency property.
ShapeValueBorderThicknessProperty | Identifies the ShapeValueBorderThickness dependency property.
ToolTipFormatProperty | Identifies the ToolTipFormat dependency property.
ValueGeometryProperty | This member is for internal use only.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
ContentBackground | Gets or sets the brush used to paint the content background. This is a dependency property.
ContentFontSize | Gets or sets the font size of the content text. This is a dependency property.
ContentFontWeight | Gets or sets the font weight of the content text. This is a dependency property.
ContentForeground | Gets or sets the brush used to paint the content texts. This is a dependency property.
ContentTextVisibility | Gets or sets a value indicating whether to show the content texts. This is a dependency property.
CornerRadius | Gets or sets the roundness of the control frame. This is a dependency property.
DefaultGeometry | This member is for internal use only.
EmptyGeometry | This member is for internal use only.
HeaderBackground | Gets or sets brush used to paint the header's background. This is a dependency property.
HeaderEffect | Gets or sets the effect to apply to the header. This is a dependency property.
HeaderForeground | Gets or sets brush used to paint the header. This is a dependency property.
HeaderHeight | Gets or sets the height of the control's header. This is a dependency property.
HeaderText | Gets or sets the header text of the control. This is a dependency property.
IsToolTipVisible | Gets or sets a value indicating whether to display a tooltip when the user points a rating element with the mouse. This is a dependency property.
Orientation | Gets or sets a value indicating the orientation of the elements in the control. This is a dependency property.
OverGeometry | This member is for internal use only.
PointedValue | Gets or sets the value corresponding to the current mouse position. This is a dependency property.
RatingMode | Gets or sets a value indicating how Value is represented by the control. This is a dependency property.
Shape | Gets or sets a value specifying the shape of the individual rating elements. This is a dependency property.
ShapeBorderBrush | Gets or sets the default border brushes for the rating elements. This is a dependency property.
ShapeBorderThickness | Gets or sets the default border thickness for the rating elements. This is a dependency property.
ShapeData | Gets or sets a string specifying a custom shape for the rating elements. This is a dependency property.
ShapeDefaultBackground | Gets or sets the default background brushes for the rating elements. This is a dependency property.
ShapeEffect | Gets or sets the effect to apply to the rating elements. This is a dependency property.
ShapeEmptyBackground | Gets or sets the background brushes for the empty elements. This is a dependency property.
ShapeEmptyBorderBrush | Gets or sets the border brushes for the empty rating elements. This is a dependency property.
ShapeEmptyBorderThickness | Gets or sets the default border thickness for the empty rating elements. This is a dependency property.
ShapeMargin | Gets or sets the margin of the rating elements. This is a dependency property.
ShapeOverBackground | Gets or sets the background brushes for elements pointed with the mouse. This is a dependency property.
ShapeStretch | Gets or sets a value indicating how to stretch the rating elements inside the available space. This is a dependency property.
ShapeValueBackground | Gets or sets the background brushes for the elements representing the value. This is a dependency property.
ShapeValueBorderBrush | Gets or sets the border brushes for the elements representing the value. This is a dependency property.
ShapeValueBorderThickness | Gets or sets the default border thickness for the elements representing the value. This is a dependency property.
ToolTipFormat | Gets or sets the format of the tooltip. This is a dependency property.
Value | Gets or sets the value displayed by the control. This is a dependency property.
ValueGeometry | This member is for internal use only.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Fields

Rating Fields
[image]

Public Fields

Name | Description
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentFontSizeProperty | Identifies the ContentFontSize dependency property.
ContentFontWeightProperty | Identifies the ContentFontWeight dependency property.
ContentForegroundProperty | Identifies the ContentForeground dependency property.
ContentTextVisibilityProperty | Identifies the ContentTextVisibility dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DefaultGeometryProperty | This member is for internal use only.
EmptyGeometryProperty | This member is for internal use only.
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderEffectProperty | Identifies the HeaderEffect dependency property.
HeaderForegroundProperty | Identifies the HeaderForeground dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
IsToolTipVisibleProperty | Identifies the IsToolTipVisible dependency property.
OrientationProperty | Identifies the Orientation dependency property.
OverGeometryProperty | This member is for internal use only.
PointedValueProperty | Identifies the PointedValue dependency property.
RatingModeProperty | Identifies the RatingMode dependency property.
ShapeBorderBrushProperty | Identifies the ShapeBorderBrush dependency property.
ShapeBorderThicknessProperty | Identifies the ShapeBorderThickness dependency property.
ShapeDataProperty | Identifies the ShapeData dependency property.
ShapeDefaultBackgroundProperty | Identifies the ShapeDefaultBackground dependency property.
ShapeEffectProperty | Identifies the ShapeEffect dependency property.
ShapeEmptyBackgroundProperty | Identifies the ShapeEmptyBackground dependency property.
ShapeEmptyBorderBrushProperty | Identifies the ShapeEmptyBorderBrush dependency property.
ShapeEmptyBorderThicknessProperty | Identifies the ShapeEmptyBorderThickness dependency property.
ShapeMarginProperty | Identifies the ShapeMargin dependency property.
ShapeOverBackgroundProperty | Identifies the ShapeOverBackground dependency property.
ShapeProperty | Identifies the Shape dependency property.
ShapeStretchProperty | Identifies the ShapeStretch dependency property.
ShapeValueBackgroundProperty | Identifies the ShapeValueBackground dependency property.
ShapeValueBorderBrushProperty | Identifies the ShapeValueBorderBrush dependency property.
ShapeValueBorderThicknessProperty | Identifies the ShapeValueBorderThickness dependency property.
ToolTipFormatProperty | Identifies the ToolTipFormat dependency property.
ValueGeometryProperty | This member is for internal use only.
ValueProperty | Identifies the Value dependency property.

See Also

Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentBackgroundProperty Field

Rating.ContentBackgroundProperty Field
[image]

Identifies the ContentBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentFontSizeProperty Field

Rating.ContentFontSizeProperty Field
[image]

Identifies the ContentFontSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentFontSizeProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentFontWeightProperty Field

Rating.ContentFontWeightProperty Field
[image]

Identifies the ContentFontWeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentFontWeightProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentForegroundProperty Field

Rating.ContentForegroundProperty Field
[image]

Identifies the ContentForeground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentForegroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentTextVisibilityProperty Field

Rating.ContentTextVisibilityProperty Field
[image]

Identifies the ContentTextVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentTextVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentTextVisibilityProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.CornerRadiusProperty Field

Rating.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.DefaultGeometryProperty Field

Rating.DefaultGeometryProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultGeometryProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.EmptyGeometryProperty Field

Rating.EmptyGeometryProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EmptyGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EmptyGeometryProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderBackgroundProperty Field

Rating.HeaderBackgroundProperty Field
[image]

Identifies the HeaderBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderEffectProperty Field

Rating.HeaderEffectProperty Field
[image]

Identifies the HeaderEffect dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderEffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderEffectProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderForegroundProperty Field

Rating.HeaderForegroundProperty Field
[image]

Identifies the HeaderForeground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderForegroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderHeightProperty Field

Rating.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderTextProperty Field

Rating.HeaderTextProperty Field
[image]

Identifies the HeaderText dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.IsToolTipVisibleProperty Field

Rating.IsToolTipVisibleProperty Field
[image]

Identifies the IsToolTipVisible dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsToolTipVisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsToolTipVisibleProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.OrientationProperty Field

Rating.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.OverGeometryProperty Field

Rating.OverGeometryProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverGeometryProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.PointedValueProperty Field

Rating.PointedValueProperty Field
[image]

Identifies the PointedValue dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointedValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointedValueProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.RatingModeProperty Field

Rating.RatingModeProperty Field
[image]

Identifies the RatingMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RatingModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RatingModeProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeBorderBrushProperty Field

Rating.ShapeBorderBrushProperty Field
[image]

Identifies the ShapeBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeBorderBrushProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeBorderThicknessProperty Field

Rating.ShapeBorderThicknessProperty Field
[image]

Identifies the ShapeBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeBorderThicknessProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeDataProperty Field

Rating.ShapeDataProperty Field
[image]

Identifies the ShapeData dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeDataProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeDefaultBackgroundProperty Field

Rating.ShapeDefaultBackgroundProperty Field
[image]

Identifies the ShapeDefaultBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeDefaultBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeDefaultBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEffectProperty Field

Rating.ShapeEffectProperty Field
[image]

Identifies the ShapeEffect dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeEffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeEffectProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBackgroundProperty Field

Rating.ShapeEmptyBackgroundProperty Field
[image]

Identifies the ShapeEmptyBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeEmptyBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeEmptyBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBorderBrushProperty Field

Rating.ShapeEmptyBorderBrushProperty Field
[image]

Identifies the ShapeEmptyBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeEmptyBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeEmptyBorderBrushProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBorderThicknessProperty Field

Rating.ShapeEmptyBorderThicknessProperty Field
[image]

Identifies the ShapeEmptyBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeEmptyBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeEmptyBorderThicknessProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeMarginProperty Field

Rating.ShapeMarginProperty Field
[image]

Identifies the ShapeMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeMarginProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeOverBackgroundProperty Field

Rating.ShapeOverBackgroundProperty Field
[image]

Identifies the ShapeOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeOverBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeProperty Field

Rating.ShapeProperty Field
[image]

Identifies the Shape dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeStretchProperty Field

Rating.ShapeStretchProperty Field
[image]

Identifies the ShapeStretch dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeStretchProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeStretchProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBackgroundProperty Field

Rating.ShapeValueBackgroundProperty Field
[image]

Identifies the ShapeValueBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeValueBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeValueBackgroundProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBorderBrushProperty Field

Rating.ShapeValueBorderBrushProperty Field
[image]

Identifies the ShapeValueBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeValueBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeValueBorderBrushProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBorderThicknessProperty Field

Rating.ShapeValueBorderThicknessProperty Field
[image]

Identifies the ShapeValueBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeValueBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeValueBorderThicknessProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ToolTipFormatProperty Field

Rating.ToolTipFormatProperty Field
[image]

Identifies the ToolTipFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToolTipFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolTipFormatProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ValueGeometryProperty Field

Rating.ValueGeometryProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueGeometryProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ValueProperty Field

Rating.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Constructor

Rating Constructor
[image]

Initializes a new instance of the Rating class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Rating ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Methods

Rating Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.OnApplyTemplate Method

Rating.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating Properties

Rating Properties
[image]

Public Properties

Name | Description
ContentBackground | Gets or sets the brush used to paint the content background. This is a dependency property.
ContentFontSize | Gets or sets the font size of the content text. This is a dependency property.
ContentFontWeight | Gets or sets the font weight of the content text. This is a dependency property.
ContentForeground | Gets or sets the brush used to paint the content texts. This is a dependency property.
ContentTextVisibility | Gets or sets a value indicating whether to show the content texts. This is a dependency property.
CornerRadius | Gets or sets the roundness of the control frame. This is a dependency property.
DefaultGeometry | This member is for internal use only.
EmptyGeometry | This member is for internal use only.
HeaderBackground | Gets or sets brush used to paint the header's background. This is a dependency property.
HeaderEffect | Gets or sets the effect to apply to the header. This is a dependency property.
HeaderForeground | Gets or sets brush used to paint the header. This is a dependency property.
HeaderHeight | Gets or sets the height of the control's header. This is a dependency property.
HeaderText | Gets or sets the header text of the control. This is a dependency property.
IsToolTipVisible | Gets or sets a value indicating whether to display a tooltip when the user points a rating element with the mouse. This is a dependency property.
Orientation | Gets or sets a value indicating the orientation of the elements in the control. This is a dependency property.
OverGeometry | This member is for internal use only.
PointedValue | Gets or sets the value corresponding to the current mouse position. This is a dependency property.
RatingMode | Gets or sets a value indicating how Value is represented by the control. This is a dependency property.
Shape | Gets or sets a value specifying the shape of the individual rating elements. This is a dependency property.
ShapeBorderBrush | Gets or sets the default border brushes for the rating elements. This is a dependency property.
ShapeBorderThickness | Gets or sets the default border thickness for the rating elements. This is a dependency property.
ShapeData | Gets or sets a string specifying a custom shape for the rating elements. This is a dependency property.
ShapeDefaultBackground | Gets or sets the default background brushes for the rating elements. This is a dependency property.
ShapeEffect | Gets or sets the effect to apply to the rating elements. This is a dependency property.
ShapeEmptyBackground | Gets or sets the background brushes for the empty elements. This is a dependency property.
ShapeEmptyBorderBrush | Gets or sets the border brushes for the empty rating elements. This is a dependency property.
ShapeEmptyBorderThickness | Gets or sets the default border thickness for the empty rating elements. This is a dependency property.
ShapeMargin | Gets or sets the margin of the rating elements. This is a dependency property.
ShapeOverBackground | Gets or sets the background brushes for elements pointed with the mouse. This is a dependency property.
ShapeStretch | Gets or sets a value indicating how to stretch the rating elements inside the available space. This is a dependency property.
ShapeValueBackground | Gets or sets the background brushes for the elements representing the value. This is a dependency property.
ShapeValueBorderBrush | Gets or sets the border brushes for the elements representing the value. This is a dependency property.
ShapeValueBorderThickness | Gets or sets the default border thickness for the elements representing the value. This is a dependency property.
ToolTipFormat | Gets or sets the format of the tooltip. This is a dependency property.
Value | Gets or sets the value displayed by the control. This is a dependency property.
ValueGeometry | This member is for internal use only.

See Also

Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentBackground Property

Rating.ContentBackground Property
[image]

Gets or sets the brush used to paint the content background. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ContentBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBackground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentFontSize Property

Rating.ContentFontSize Property
[image]

Gets or sets the font size of the content text. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ContentFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property ContentFontSize As Double

Property Value

A double value specifying the size.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentFontWeight Property

Rating.ContentFontWeight Property
[image]

Gets or sets the font weight of the content text. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public FontWeight ContentFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property ContentFontWeight As FontWeight

Property Value

A WPF FontWeight object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentForeground Property

Rating.ContentForeground Property
[image]

Gets or sets the brush used to paint the content texts. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ContentForeground { get; set; }

Visual Basic [image] Copy Code

Public Property ContentForeground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ContentTextVisibility Property

Rating.ContentTextVisibility Property
[image]

Gets or sets a value indicating whether to show the content texts. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility ContentTextVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property ContentTextVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.CornerRadius Property

Rating.CornerRadius Property
[image]

Gets or sets the roundness of the control frame. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.DefaultGeometry Property

Rating.DefaultGeometry Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Geometry DefaultGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultGeometry As Geometry

Property Value

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.EmptyGeometry Property

Rating.EmptyGeometry Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Geometry EmptyGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property EmptyGeometry As Geometry

Property Value

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderBackground Property

Rating.HeaderBackground Property
[image]

Gets or sets brush used to paint the header's background. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderBackground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderBackground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderEffect Property

Rating.HeaderEffect Property
[image]

Gets or sets the effect to apply to the header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Effect HeaderEffect { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderEffect As Effect

Property Value

A WPF Effect object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderForeground Property

Rating.HeaderForeground Property
[image]

Gets or sets brush used to paint the header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush HeaderForeground { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderForeground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderHeight Property

Rating.HeaderHeight Property
[image]

Gets or sets the height of the control's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Double

Property Value

A double value specifying the height.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.HeaderText Property

Rating.HeaderText Property
[image]

Gets or sets the header text of the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string HeaderText { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderText As String

Property Value

A string value.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.IsToolTipVisible Property

Rating.IsToolTipVisible Property
[image]

Gets or sets a value indicating whether to display a tooltip when the user points a rating element with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsToolTipVisible { get; set; }

Visual Basic [image] Copy Code

Public Property IsToolTipVisible As Boolean

Property Value

true to display tooltips; otherwise, false.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.Orientation Property

Rating.Orientation Property
[image]

Gets or sets a value indicating the orientation of the elements in the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the WPF Orientation enumeration.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.OverGeometry Property

Rating.OverGeometry Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Geometry OverGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property OverGeometry As Geometry

Property Value

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.PointedValue Property

Rating.PointedValue Property
[image]

Gets or sets the value corresponding to the current mouse position. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double PointedValue { get; set; }

Visual Basic [image] Copy Code

Public Property PointedValue As Double

Property Value

A double value specifying the rating value corresponding to the current mouse position.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.RatingMode Property

Rating.RatingMode Property
[image]

Gets or sets a value indicating how Value is represented by the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingMode RatingMode { get; set; }

Visual Basic [image] Copy Code

Public Property RatingMode As RatingMode

Property Value

A member of the RatingMode enumeration.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.Shape Property

Rating.Shape Property
[image]

Gets or sets a value specifying the shape of the individual rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As RatingShape

Property Value

A member of the RatingShape enumeration.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeBorderBrush Property

Rating.ShapeBorderBrush Property
[image]

Gets or sets the default border brushes for the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingBrushCollection ShapeBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBorderBrush As RatingBrushCollection

Property Value

A RatingBrushCollection object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeBorderThickness Property

Rating.ShapeBorderThickness Property
[image]

Gets or sets the default border thickness for the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ShapeBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBorderThickness As Double

Property Value

A double value specifying the thickness.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeData Property

Rating.ShapeData Property
[image]

Gets or sets a string specifying a custom shape for the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string ShapeData { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeData As String

Property Value

A string value defining the shape outline using the standard XAML syntax.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeDefaultBackground Property

Rating.ShapeDefaultBackground Property
[image]

Gets or sets the default background brushes for the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingBrushCollection ShapeDefaultBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeDefaultBackground As RatingBrushCollection

Property Value

A RatingBrushCollection object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEffect Property

Rating.ShapeEffect Property
[image]

Gets or sets the effect to apply to the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Effect ShapeEffect { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeEffect As Effect

Property Value

A WPF Effect object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBackground Property

Rating.ShapeEmptyBackground Property
[image]

Gets or sets the background brushes for the empty elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeEmptyBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeEmptyBackground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBorderBrush Property

Rating.ShapeEmptyBorderBrush Property
[image]

Gets or sets the border brushes for the empty rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeEmptyBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeEmptyBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeEmptyBorderThickness Property

Rating.ShapeEmptyBorderThickness Property
[image]

Gets or sets the default border thickness for the empty rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ShapeEmptyBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeEmptyBorderThickness As Double

Property Value

A double value specifying the thickness.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeMargin Property

Rating.ShapeMargin Property
[image]

Gets or sets the margin of the rating elements. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ShapeMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeMargin As Thickness

Property Value

A WPF Thickness object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeOverBackground Property

Rating.ShapeOverBackground Property
[image]

Gets or sets the background brushes for elements pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingBrushCollection ShapeOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOverBackground As RatingBrushCollection

Property Value

A RatingBrushCollection object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeStretch Property

Rating.ShapeStretch Property
[image]

Gets or sets a value indicating how to stretch the rating elements inside the available space. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public RatingStretch ShapeStretch { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeStretch As RatingStretch

Property Value

A member of the RatingStretch enumeration.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBackground Property

Rating.ShapeValueBackground Property
[image]

Gets or sets the background brushes for the elements representing the value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeValueBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeValueBackground As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBorderBrush Property

Rating.ShapeValueBorderBrush Property
[image]

Gets or sets the border brushes for the elements representing the value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ShapeValueBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeValueBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ShapeValueBorderThickness Property

Rating.ShapeValueBorderThickness Property
[image]

Gets or sets the default border thickness for the elements representing the value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ShapeValueBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeValueBorderThickness As Double

Property Value

A double value specifying the thickness.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ToolTipFormat Property

Rating.ToolTipFormat Property
[image]

Gets or sets the format of the tooltip. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string ToolTipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipFormat As String

Property Value

A string value specifying the formatting.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.Value Property

Rating.Value Property
[image]

Gets or sets the value displayed by the control. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Rating.ValueGeometry Property

Rating.ValueGeometry Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Geometry ValueGeometry { get; set; }

Visual Basic [image] Copy Code

Public Property ValueGeometry As Geometry

Property Value

See Also

Rating Members
Rating Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RatingMode Enumeration

RatingMode Enumeration
[image]

Specifies how the Rating control displays values.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum RatingMode

Visual Basic [image] Copy Code

Public Enum RatingMode

Members

Member name | Description
Exact | Indicates that the elements in the Rating control are filled to represent the value precisely.
Half | Indicates the Rating control displays either full or half-full elements.
Item | Indicates that the Rating control displays discrete values.

Remarks

Values of this enumeration can be assigned to the RatingMode property of the Rating class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RatingShape Enumeration

RatingShape Enumeration
[image]

Specifies the shape of the elements in a Rating control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum RatingShape

Visual Basic [image] Copy Code

Public Enum RatingShape

Members

Member name | Description
Rectangle | Indicates a rectangle.
Star | Indicates a 5-pointed star.

Remarks

Values of this enumeration can be assigned to the Shape property of the Rating class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RatingStretch Enumeration

RatingStretch Enumeration
[image]

Specifies the stretching of the elements in a Rating control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum RatingStretch

Visual Basic [image] Copy Code

Public Enum RatingStretch

Members

Member name | Description
Fill | Indicates that the elements are resized to fill the available space.
Uniform | Indicates that the elements are resized to fill the available space without breaking their width/height ratio.

Remarks

Values of this enumeration can be assigned to ShapeStretch property of the Rating class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Class

RegularKey Class
[image]

Represents regular keyboard keys that send character codes as input.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class RegularKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class RegularKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.RegularKey

See Also

RegularKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Members

RegularKey Members
Constructors Properties Methods Events
[image]

Represents regular keyboard keys that send character codes as input.

The following tables list the members exposed by the RegularKey type.

Public Constructors

Name | Description
RegularKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AlterCase | The alter-case label to display.
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
AltGrLock | AltGrLock; obsolete.
AltLock | AltLock; obsolete.
Backspace | The backspace virtual key. (Inherited from Key.)
CapitalCase | The capital-case label to display.
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
ControlLock | ControlLock; obsolete.
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
CurrentCase | Gets current character label depending on state of keys such as shift, alt etc.
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | The lower-case label to display.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
OverrideLabel | An overriding label for all cases.
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
ShiftLock | ShiftLock; obsolete.
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | The upper-case label to display.
VirtualKey | Gets or sets the virtual key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this RegularKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Constructor

RegularKey Constructor
[image]

Overload List

Name | Description
RegularKey () | Initializes a new instance of the RegularKey class.
RegularKey (Int32) | Initializes a new instance of the RegularKey class with specified virtual key code.
RegularKey (Int32, Object) | Initializes a new instance of the RegularKey class with specified virtual key code and content.

See Also

RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Constructor ()

RegularKey Constructor ()
See Also
[image]

Initializes a new instance of the RegularKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RegularKey Constructor Overload List
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Constructor (Int32)

RegularKey Constructor (Int32)
See Also
[image]

Initializes a new instance of the RegularKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

RegularKey Constructor Overload List
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Constructor (Int32, Object)

RegularKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instance of the RegularKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public RegularKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

Content sent as input to the focused control.

See Also

RegularKey Constructor Overload List
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Methods

RegularKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this RegularKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.Clone Method

RegularKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new RegularKey instance.

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.Equals Method

RegularKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.GetHashCode Method

RegularKey.GetHashCode Method
[image]

Returns a hash code for this RegularKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.Send Method

RegularKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Properties

RegularKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AlterCase | The alter-case label to display.
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
AltGrLock | AltGrLock; obsolete.
AltLock | AltLock; obsolete.
Backspace | The backspace virtual key. (Inherited from Key.)
CapitalCase | The capital-case label to display.
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
ControlLock | ControlLock; obsolete.
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
CurrentCase | Gets current character label depending on state of keys such as shift, alt etc.
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | The lower-case label to display.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
OverrideLabel | An overriding label for all cases.
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
ShiftLock | ShiftLock; obsolete.
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | The upper-case label to display.
VirtualKey | Gets or sets the virtual key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.AlterCase Property

RegularKey.AlterCase Property
[image]

The alter-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string AlterCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AlterCase As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.AltGrLock Property

RegularKey.AltGrLock Property
[image]

AltGrLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AltGrLock { get; set; }

Visual Basic [image] Copy Code

Public Property AltGrLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.AltLock Property

RegularKey.AltLock Property
[image]

AltLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AltLock { get; set; }

Visual Basic [image] Copy Code

Public Property AltLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.CapitalCase Property

RegularKey.CapitalCase Property
[image]

The capital-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string CapitalCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CapitalCase As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.ControlLock Property

RegularKey.ControlLock Property
[image]

ControlLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool ControlLock { get; set; }

Visual Basic [image] Copy Code

Public Property ControlLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.CurrentCase Property

RegularKey.CurrentCase Property
[image]

Gets current character label depending on state of keys such as shift, alt etc.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string CurrentCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CurrentCase As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.LowerCase Property

RegularKey.LowerCase Property
[image]

The lower-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LowerCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LowerCase As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.OverrideLabel Property

RegularKey.OverrideLabel Property
[image]

An overriding label for all cases.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string OverrideLabel { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OverrideLabel As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.Repeat Property

RegularKey.Repeat Property
[image]

Gets or sets how many times to send the key code when this key is pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As Integer

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.ShiftLock Property

RegularKey.ShiftLock Property
[image]

ShiftLock; obsolete.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool ShiftLock { get; set; }

Visual Basic [image] Copy Code

Public Property ShiftLock As Boolean

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.UpperCase Property

RegularKey.UpperCase Property
[image]

The upper-case label to display.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string UpperCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UpperCase As String

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey.VirtualKey Property

RegularKey.VirtualKey Property
[image]

Gets or sets the virtual key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

RegularKey Members
RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.RegularKey Events

RegularKey Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

RegularKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ResizeMode Enumeration

ResizeMode Enumeration
[image]

Specifies the allowed user interactions on a window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum ResizeMode

Visual Basic [image] Copy Code

Public Enum ResizeMode

Members

Member name | Description
CanMinimize | Indicates that the window can be minimized interactively.
CanResize | Indicates that the window can be resized interactively.
NoResize | Indicates that the window cannot be resized interactively.

Remarks

Values from this enumeration are assigned to the ResizeMode property of the Window class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollArrowEventArgs Class

ScrollArrowEventArgs Class
[image]

Contains arguments for the ScrollArrowClicked event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ScrollArrowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ScrollArrowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.ScrollArrowEventArgs

See Also

ScrollArrowEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollArrowEventArgs Members

ScrollArrowEventArgs Members
Constructors Properties
[image]

Contains arguments for the ScrollArrowClicked event.

The following tables list the members exposed by the ScrollArrowEventArgs type.

Public Constructors

Name | Description
ScrollArrowEventArgs | Initializes a new instance of the ScrollArrowEventArgs class.

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollArrowEventArgs Constructor

ScrollArrowEventArgs Constructor
[image]

Initializes a new instance of the ScrollArrowEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ScrollArrowEventArgs (
ScrollDirection p
)

Visual Basic [image] Copy Code

Public New ( _
p As ScrollDirection _
)

Parameters

p

See Also

ScrollArrowEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollArrowEventArgs Properties

ScrollArrowEventArgs Properties
[image]

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollArrowEventArgs.Direction Property

ScrollArrowEventArgs.Direction Property
[image]

Specifies which arrow button has been clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ScrollDirection Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As ScrollDirection

Property Value

A member of the ScrollDirection enumeration.

See Also

ScrollArrowEventArgs Members
ScrollArrowEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ScrollDirection Enumeration

ScrollDirection Enumeration
[image]

Identifies the direction of a scroll arrow.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum ScrollDirection

Visual Basic [image] Copy Code

Public Enum ScrollDirection

Members

Member name | Description
Bottom | Scroll to the bottom.
Left | Scroll to the left.
Right | Scroll to the right.
Top | Scroll to the top.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SelectionMode Enumeration

SelectionMode Enumeration
[image]

Specifies the interactive selection behavior in a Calendar control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum SelectionMode

Visual Basic [image] Copy Code

Public Enum SelectionMode

Members

Member name | Description
Jagged | Indicates that multiple cells can be selected.
Multiple | Indicates that multiple consecutive cells can be selected.
Single | Indicates that only a single cell can be selected at a time.

Remarks

Values from this enumeration can be assigned to the SelectionMode property of the Calendar class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Class

Slider Class
[image]

Represents a slider control that can be used to specify individual values or value ranges.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class Slider : Control

Visual Basic [image] Copy Code

Public Class Slider
Inherits Control

Example

The following example demonstrates how to declare Slider control in XAML:

XAML [image] Copy Code

<ui:Slider IsSelectionRangeEnabled="True" SelectionStart="20" SelectionEnd="30" Width="400" Height="78" VerticalAlignment="Top" HorizontalAlignment="Left" />

The code above will produce results similar to the following picture:

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.Slider

See Also

Slider Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Members

Slider Members
Constructors Fields Properties Methods Events
[image]

Represents a slider control that can be used to specify individual values or value ranges.

The following tables list the members exposed by the Slider type.

Public Constructors

Name | Description
Slider | Initializes a new instance of the Slider class.

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
HandlesVisibilityProperty | Identifies the HandlesVisibility dependency property.
IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
IsMoveToPointEnabledProperty | Identifies the IsMoveToPointEnabled dependency property.
IsSelectionRangeEnabledProperty | Identifies the IsSelectionRangeEnabled dependency property.
IsSnapValueEnabledProperty | Identifies the IsSnapValueEnabled dependency property.
LargeChangeProperty | Identifies the LargeChange dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MaximumRangeSpanProperty | Identifies the MaximumRangeSpan dependency property.
MinimumProperty | Identifies the Minimum dependency property.
MinimumRangeSpanProperty | Identifies the MinimumRangeSpan dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RailBackgroundProperty | Identifies the RailBackground dependency property.
RailInnerBorderBrushProperty | Identifies the RailInnerBorderBrush dependency property.
RailInnerBorderThicknessProperty | Identifies the RailInnerBorderThickness dependency property.
RailMarginProperty | Identifies the RailMargin dependency property.
RailOuterBorderBrushProperty | Identifies the RailOuterBorderBrush dependency property.
RailOuterBorderThicknessProperty | Identifies the RailOuterBorderThickness dependency property.
SelectionEndProperty | Identifies the SelectionEnd dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
SmallChangeProperty | Identifies the SmallChange dependency property.
SnapIntervalProperty | Identifies the SnapInterval dependency property.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property.
ThumbBorderBrushProperty | Identifies the ThumbBorderBrush dependency property.
ThumbBorderThicknessProperty | Identifies the ThumbBorderThickness dependency property.
ThumbSizeProperty | Identifies the ThumbSize dependency property.
TickBrushProperty | Identifies the TickBrush dependency property.
TickFrequencyProperty | Identifies the TickFrequency dependency property.
TickPlacementProperty | Identifies the TickPlacement dependency property.
TickSizeProperty | Identifies the TickSize dependency property.
TickTextFormatProperty | Identifies the TickTextFormat dependency property.
TickThicknessProperty | Identifies the TickThickness dependency property.
TickTypeProperty | Identifies the TickType dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the increment and decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment and decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment and decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment and decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment and decrement buttons when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the slider buttons. This is a dependency property.
HandlesVisibility | Gets or sets a value specifying whether the increment and decrement buttons should be visible. This is a dependency property.
IsDirectionReversed | Gets or sets a value indicating whether the displayed interval is reversed. This is a dependency property.
IsMoveToPointEnabled | Gets or sets a value indicating whether mouse clicks over the slider rail will automatically adjust the Value of the slider to the value corresponding to the clicked location. This is a dependency property.
IsSelectionRangeEnabled | Gets or sets a value indicating whether the slider is used to select range of values or a single value. This is a dependency property.
IsSnapValueEnabled | Gets or sets a value indicating whether the selected value is automatically snapped to the nearest SnapInterval during interactive modifications. This is a dependency property.
LargeChange | Gets or sets the large change interval. This is a dependency property.
Maximum | Gets or sets the maximum value displayed by the slider. This is a dependency property.
MaximumRangeSpan | Gets or sets the maximum allowed interval for the value range selected in the slider. This is a dependency property.
Minimum | Gets or sets the minimum value displayed by the slider. This is a dependency property.
MinimumRangeSpan | Gets or sets the minimum allowed interval for the value range selected in the slider. This is a dependency property.
Orientation | Gets or sets the orientation of the slider. This is a dependency property.
RailBackground | Gets or sets the background of the slider rail. This is a dependency property.
RailInnerBorderBrush | Gets or sets the brush of the inner border of the slider rail. This is a dependency property.
RailInnerBorderThickness | Gets or sets the thickness of the inner border of the slider rail. This is a dependency property.
RailMargin | Gets or sets the margin of the slider rail. This is a dependency property.
RailOuterBorderBrush | Gets or sets the brush of the outer border of the slider rail. This is a dependency property.
RailOuterBorderThickness | Gets or sets the thickness of the outer border of the slider rail. This is a dependency property.
SelectionEnd | Gets or sets the end of a value range selected in the slider. This is a dependency property.
SelectionStart | Gets or sets the start of a value range selected in the slider. This is a dependency property.
SmallChange | Gets or sets the small change interval. This is a dependency property.
SnapInterval | Gets or sets the interval to automatically snap values to during interactive modifications. This is a dependency property.
ThumbBackground | Gets or sets the background of the slider thumb. This is a dependency property.
ThumbBorderBrush | Gets or sets the border brush of the slider thumb. This is a dependency property.
ThumbBorderThickness | Gets or sets the border thickness of the slider thumb. This is a dependency property.
ThumbSize | Gets or sets the size of the slider thumbs. This is a dependency property.
TickBrush | Gets or sets the brush used to paint tick lines. This is a dependency property.
TickFrequency | Gets or sets the interval between adjacent ticks. This is a dependency property.
TickPlacement | Gets or sets a value indicating the position of the ticks relative to the rail. This is a dependency property.
TickSize | Gets or sets the size of the ticks. This is a dependency property.
TickTextFormat | Gets or sets the format of the values displayed for each tick. This is a dependency property.
TickThickness | Gets or sets the border thickness of the ticks. This is a dependency property.
TickType | Gets or sets a value indicating how ticks are displayed. This is a dependency property.
Value | Gets or sets the single value selected in the slider. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnSelectionEndChanged | Raises the SelectionEndChanged event.
OnSelectionStartChanged | Raises the SelectionStartChanged event.
OnValueChanged | Raises the ValueChanged event.

Public Events

Name | Description
SelectionEndChanged | Raised when the end of the selected value range has changed.
SelectionStartChanged | Raised when the start of the selected value range has changed.
ValueChanged | Raised when the selected value has changed.

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Fields

Slider Fields
[image]

Public Fields

Name | Description
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
HandlesVisibilityProperty | Identifies the HandlesVisibility dependency property.
IsDirectionReversedProperty | Identifies the IsDirectionReversed dependency property.
IsMoveToPointEnabledProperty | Identifies the IsMoveToPointEnabled dependency property.
IsSelectionRangeEnabledProperty | Identifies the IsSelectionRangeEnabled dependency property.
IsSnapValueEnabledProperty | Identifies the IsSnapValueEnabled dependency property.
LargeChangeProperty | Identifies the LargeChange dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MaximumRangeSpanProperty | Identifies the MaximumRangeSpan dependency property.
MinimumProperty | Identifies the Minimum dependency property.
MinimumRangeSpanProperty | Identifies the MinimumRangeSpan dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RailBackgroundProperty | Identifies the RailBackground dependency property.
RailInnerBorderBrushProperty | Identifies the RailInnerBorderBrush dependency property.
RailInnerBorderThicknessProperty | Identifies the RailInnerBorderThickness dependency property.
RailMarginProperty | Identifies the RailMargin dependency property.
RailOuterBorderBrushProperty | Identifies the RailOuterBorderBrush dependency property.
RailOuterBorderThicknessProperty | Identifies the RailOuterBorderThickness dependency property.
SelectionEndProperty | Identifies the SelectionEnd dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
SmallChangeProperty | Identifies the SmallChange dependency property.
SnapIntervalProperty | Identifies the SnapInterval dependency property.
ThumbBackgroundProperty | Identifies the ThumbBackground dependency property.
ThumbBorderBrushProperty | Identifies the ThumbBorderBrush dependency property.
ThumbBorderThicknessProperty | Identifies the ThumbBorderThickness dependency property.
ThumbSizeProperty | Identifies the ThumbSize dependency property.
TickBrushProperty | Identifies the TickBrush dependency property.
TickFrequencyProperty | Identifies the TickFrequency dependency property.
TickPlacementProperty | Identifies the TickPlacement dependency property.
TickSizeProperty | Identifies the TickSize dependency property.
TickTextFormatProperty | Identifies the TickTextFormat dependency property.
TickThicknessProperty | Identifies the TickThickness dependency property.
TickTypeProperty | Identifies the TickType dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBackgroundProperty Field

Slider.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBorderBrushProperty Field

Slider.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBorderThicknessProperty Field

Slider.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonOverBackgroundProperty Field

Slider.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonPressedBackgroundProperty Field

Slider.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonSizeProperty Field

Slider.ButtonSizeProperty Field
[image]

Identifies the ButtonSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonSizeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.HandlesVisibilityProperty Field

Slider.HandlesVisibilityProperty Field
[image]

Identifies the HandlesVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HandlesVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HandlesVisibilityProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsDirectionReversedProperty Field

Slider.IsDirectionReversedProperty Field
[image]

Identifies the IsDirectionReversed dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDirectionReversedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDirectionReversedProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsMoveToPointEnabledProperty Field

Slider.IsMoveToPointEnabledProperty Field
[image]

Identifies the IsMoveToPointEnabled dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsMoveToPointEnabledProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsMoveToPointEnabledProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsSelectionRangeEnabledProperty Field

Slider.IsSelectionRangeEnabledProperty Field
[image]

Identifies the IsSelectionRangeEnabled dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectionRangeEnabledProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectionRangeEnabledProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsSnapValueEnabledProperty Field

Slider.IsSnapValueEnabledProperty Field
[image]

Identifies the IsSnapValueEnabled dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSnapValueEnabledProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSnapValueEnabledProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.LargeChangeProperty Field

Slider.LargeChangeProperty Field
[image]

Identifies the LargeChange dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LargeChangeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LargeChangeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MaximumProperty Field

Slider.MaximumProperty Field
[image]

Identifies the Maximum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaximumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MaximumRangeSpanProperty Field

Slider.MaximumRangeSpanProperty Field
[image]

Identifies the MaximumRangeSpan dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaximumRangeSpanProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaximumRangeSpanProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MinimumProperty Field

Slider.MinimumProperty Field
[image]

Identifies the Minimum dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MinimumRangeSpanProperty Field

Slider.MinimumRangeSpanProperty Field
[image]

Identifies the MinimumRangeSpan dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimumRangeSpanProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumRangeSpanProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.OrientationProperty Field

Slider.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailBackgroundProperty Field

Slider.RailBackgroundProperty Field
[image]

Identifies the RailBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailBackgroundProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailInnerBorderBrushProperty Field

Slider.RailInnerBorderBrushProperty Field
[image]

Identifies the RailInnerBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailInnerBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailInnerBorderBrushProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailInnerBorderThicknessProperty Field

Slider.RailInnerBorderThicknessProperty Field
[image]

Identifies the RailInnerBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailInnerBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailInnerBorderThicknessProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailMarginProperty Field

Slider.RailMarginProperty Field
[image]

Identifies the RailMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailMarginProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailOuterBorderBrushProperty Field

Slider.RailOuterBorderBrushProperty Field
[image]

Identifies the RailOuterBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailOuterBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailOuterBorderBrushProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailOuterBorderThicknessProperty Field

Slider.RailOuterBorderThicknessProperty Field
[image]

Identifies the RailOuterBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RailOuterBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RailOuterBorderThicknessProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionEndProperty Field

Slider.SelectionEndProperty Field
[image]

Identifies the SelectionEnd dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionEndProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionEndProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionStartProperty Field

Slider.SelectionStartProperty Field
[image]

Identifies the SelectionStart dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionStartProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionStartProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SmallChangeProperty Field

Slider.SmallChangeProperty Field
[image]

Identifies the SmallChange dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SmallChangeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SmallChangeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SnapIntervalProperty Field

Slider.SnapIntervalProperty Field
[image]

Identifies the SnapInterval dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapIntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapIntervalProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBackgroundProperty Field

Slider.ThumbBackgroundProperty Field
[image]

Identifies the ThumbBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThumbBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThumbBackgroundProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBorderBrushProperty Field

Slider.ThumbBorderBrushProperty Field
[image]

Identifies the ThumbBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThumbBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThumbBorderBrushProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBorderThicknessProperty Field

Slider.ThumbBorderThicknessProperty Field
[image]

Identifies the ThumbBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThumbBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThumbBorderThicknessProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbSizeProperty Field

Slider.ThumbSizeProperty Field
[image]

Identifies the ThumbSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThumbSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ThumbSizeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickBrushProperty Field

Slider.TickBrushProperty Field
[image]

Identifies the TickBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickBrushProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickFrequencyProperty Field

Slider.TickFrequencyProperty Field
[image]

Identifies the TickFrequency dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickFrequencyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickFrequencyProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickPlacementProperty Field

Slider.TickPlacementProperty Field
[image]

Identifies the TickPlacement dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickPlacementProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickSizeProperty Field

Slider.TickSizeProperty Field
[image]

Identifies the TickSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickSizeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickTextFormatProperty Field

Slider.TickTextFormatProperty Field
[image]

Identifies the TickTextFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickTextFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickTextFormatProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickThicknessProperty Field

Slider.TickThicknessProperty Field
[image]

Identifies the TickThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickThicknessProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickTypeProperty Field

Slider.TickTypeProperty Field
[image]

Identifies the TickType dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickTypeProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ValueProperty Field

Slider.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Constructor

Slider Constructor
[image]

Initializes a new instance of the Slider class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Slider ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Methods

Slider Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnSelectionEndChanged | Raises the SelectionEndChanged event.
OnSelectionStartChanged | Raises the SelectionStartChanged event.
OnValueChanged | Raises the ValueChanged event.

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.OnApplyTemplate Method

Slider.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.OnSelectionEndChanged Method

Slider.OnSelectionEndChanged Method
[image]

Raises the SelectionEndChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionEndChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionEndChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.OnSelectionStartChanged Method

Slider.OnSelectionStartChanged Method
[image]

Raises the SelectionStartChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnSelectionStartChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionStartChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.OnValueChanged Method

Slider.OnValueChanged Method
[image]

Raises the ValueChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnValueChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValueChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Properties

Slider Properties
[image]

Public Properties

Name | Description
ButtonBackground | Gets or sets the background of the increment and decrement buttons. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the increment and decrement buttons. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the increment and decrement buttons. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the increment and decrement buttons when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the increment and decrement buttons when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the slider buttons. This is a dependency property.
HandlesVisibility | Gets or sets a value specifying whether the increment and decrement buttons should be visible. This is a dependency property.
IsDirectionReversed | Gets or sets a value indicating whether the displayed interval is reversed. This is a dependency property.
IsMoveToPointEnabled | Gets or sets a value indicating whether mouse clicks over the slider rail will automatically adjust the Value of the slider to the value corresponding to the clicked location. This is a dependency property.
IsSelectionRangeEnabled | Gets or sets a value indicating whether the slider is used to select range of values or a single value. This is a dependency property.
IsSnapValueEnabled | Gets or sets a value indicating whether the selected value is automatically snapped to the nearest SnapInterval during interactive modifications. This is a dependency property.
LargeChange | Gets or sets the large change interval. This is a dependency property.
Maximum | Gets or sets the maximum value displayed by the slider. This is a dependency property.
MaximumRangeSpan | Gets or sets the maximum allowed interval for the value range selected in the slider. This is a dependency property.
Minimum | Gets or sets the minimum value displayed by the slider. This is a dependency property.
MinimumRangeSpan | Gets or sets the minimum allowed interval for the value range selected in the slider. This is a dependency property.
Orientation | Gets or sets the orientation of the slider. This is a dependency property.
RailBackground | Gets or sets the background of the slider rail. This is a dependency property.
RailInnerBorderBrush | Gets or sets the brush of the inner border of the slider rail. This is a dependency property.
RailInnerBorderThickness | Gets or sets the thickness of the inner border of the slider rail. This is a dependency property.
RailMargin | Gets or sets the margin of the slider rail. This is a dependency property.
RailOuterBorderBrush | Gets or sets the brush of the outer border of the slider rail. This is a dependency property.
RailOuterBorderThickness | Gets or sets the thickness of the outer border of the slider rail. This is a dependency property.
SelectionEnd | Gets or sets the end of a value range selected in the slider. This is a dependency property.
SelectionStart | Gets or sets the start of a value range selected in the slider. This is a dependency property.
SmallChange | Gets or sets the small change interval. This is a dependency property.
SnapInterval | Gets or sets the interval to automatically snap values to during interactive modifications. This is a dependency property.
ThumbBackground | Gets or sets the background of the slider thumb. This is a dependency property.
ThumbBorderBrush | Gets or sets the border brush of the slider thumb. This is a dependency property.
ThumbBorderThickness | Gets or sets the border thickness of the slider thumb. This is a dependency property.
ThumbSize | Gets or sets the size of the slider thumbs. This is a dependency property.
TickBrush | Gets or sets the brush used to paint tick lines. This is a dependency property.
TickFrequency | Gets or sets the interval between adjacent ticks. This is a dependency property.
TickPlacement | Gets or sets a value indicating the position of the ticks relative to the rail. This is a dependency property.
TickSize | Gets or sets the size of the ticks. This is a dependency property.
TickTextFormat | Gets or sets the format of the values displayed for each tick. This is a dependency property.
TickThickness | Gets or sets the border thickness of the ticks. This is a dependency property.
TickType | Gets or sets a value indicating how ticks are displayed. This is a dependency property.
Value | Gets or sets the single value selected in the slider. This is a dependency property.

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBackground Property

Slider.ButtonBackground Property
[image]

Gets or sets the background of the increment and decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush property.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBorderBrush Property

Slider.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the increment and decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonBorderThickness Property

Slider.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the increment and decrement buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonOverBackground Property

Slider.ButtonOverBackground Property
[image]

Gets or sets the background of the increment and decrement buttons when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonPressedBackground Property

Slider.ButtonPressedBackground Property
[image]

Gets or sets the background of the increment and decrement buttons when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ButtonSize Property

Slider.ButtonSize Property
[image]

Gets or sets the size of the slider buttons. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ButtonSize { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonSize As Double

Property Value

A double value specifying the size.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.HandlesVisibility Property

Slider.HandlesVisibility Property
[image]

Gets or sets a value specifying whether the increment and decrement buttons should be visible. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility HandlesVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsDirectionReversed Property

Slider.IsDirectionReversed Property
[image]

Gets or sets a value indicating whether the displayed interval is reversed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsDirectionReversed { get; set; }

Visual Basic [image] Copy Code

Public Property IsDirectionReversed As Boolean

Property Value

true to reverse the slider direction; otherwise, false.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsMoveToPointEnabled Property

Slider.IsMoveToPointEnabled Property
[image]

Gets or sets a value indicating whether mouse clicks over the slider rail will automatically adjust the Value of the slider to the value corresponding to the clicked location. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsMoveToPointEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsMoveToPointEnabled As Boolean

Property Value

true to enable move to point; otherwise, false.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsSelectionRangeEnabled Property

Slider.IsSelectionRangeEnabled Property
[image]

Gets or sets a value indicating whether the slider is used to select range of values or a single value. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsSelectionRangeEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelectionRangeEnabled As Boolean

Property Value

true to enable selection of range of values; false to enable selection of single values.

Remarks

When selecting a range of values, this range is defined by the SelectionStart and SelectionEnd properties. When selecting a single value, this value is specified through the Value property.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.IsSnapValueEnabled Property

Slider.IsSnapValueEnabled Property
[image]

Gets or sets a value indicating whether the selected value is automatically snapped to the nearest SnapInterval during interactive modifications. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsSnapValueEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsSnapValueEnabled As Boolean

Property Value

true to enable snapping; otherwise, false.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.LargeChange Property

Slider.LargeChange Property
[image]

Gets or sets the large change interval. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double LargeChange { get; set; }

Visual Basic [image] Copy Code

Public Property LargeChange As Double

Property Value

A double value specifying the large change.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.Maximum Property

Slider.Maximum Property
[image]

Gets or sets the maximum value displayed by the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Maximum { get; set; }

Visual Basic [image] Copy Code

Public Property Maximum As Double

Property Value

A double value specifying the slider maximum.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MaximumRangeSpan Property

Slider.MaximumRangeSpan Property
[image]

Gets or sets the maximum allowed interval for the value range selected in the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double MaximumRangeSpan { get; set; }

Visual Basic [image] Copy Code

Public Property MaximumRangeSpan As Double

Property Value

A double value specifying the maximum possible range.

Remarks

This property is relevant only when IsSelectionRangeEnabled is set to true.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.Minimum Property

Slider.Minimum Property
[image]

Gets or sets the minimum value displayed by the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Minimum { get; set; }

Visual Basic [image] Copy Code

Public Property Minimum As Double

Property Value

A double value specifying the slider minimum.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.MinimumRangeSpan Property

Slider.MinimumRangeSpan Property
[image]

Gets or sets the minimum allowed interval for the value range selected in the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double MinimumRangeSpan { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumRangeSpan As Double

Property Value

A double value specifying the minimum possible range.

Remarks

This property is relevant only when IsSelectionRangeEnabled is set to true.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.Orientation Property

Slider.Orientation Property
[image]

Gets or sets the orientation of the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the WPF Orientation enumeration.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailBackground Property

Slider.RailBackground Property
[image]

Gets or sets the background of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush RailBackground { get; set; }

Visual Basic [image] Copy Code

Public Property RailBackground As Brush

Property Value

A WPF Brush property.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailInnerBorderBrush Property

Slider.RailInnerBorderBrush Property
[image]

Gets or sets the brush of the inner border of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush RailInnerBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RailInnerBorderBrush As Brush

Property Value

A WPF Brush property.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailInnerBorderThickness Property

Slider.RailInnerBorderThickness Property
[image]

Gets or sets the thickness of the inner border of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness RailInnerBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RailInnerBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailMargin Property

Slider.RailMargin Property
[image]

Gets or sets the margin of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness RailMargin { get; set; }

Visual Basic [image] Copy Code

Public Property RailMargin As Thickness

Property Value

A WPF Thickness object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailOuterBorderBrush Property

Slider.RailOuterBorderBrush Property
[image]

Gets or sets the brush of the outer border of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush RailOuterBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RailOuterBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.RailOuterBorderThickness Property

Slider.RailOuterBorderThickness Property
[image]

Gets or sets the thickness of the outer border of the slider rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness RailOuterBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RailOuterBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionEnd Property

Slider.SelectionEnd Property
[image]

Gets or sets the end of a value range selected in the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SelectionEnd { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionEnd As Double

Property Value

A double value specifying the end of a selected range.

Remarks

This property is relevant only when IsSelectionRangeEnabled is set to true.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionStart Property

Slider.SelectionStart Property
[image]

Gets or sets the start of a value range selected in the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SelectionStart { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionStart As Double

Property Value

A double value specifying the start of a selected range.

Remarks

This property is relevant only when IsSelectionRangeEnabled is set to true.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SmallChange Property

Slider.SmallChange Property
[image]

Gets or sets the small change interval. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SmallChange { get; set; }

Visual Basic [image] Copy Code

Public Property SmallChange As Double

Property Value

A double value specifying the small change.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SnapInterval Property

Slider.SnapInterval Property
[image]

Gets or sets the interval to automatically snap values to during interactive modifications. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double SnapInterval { get; set; }

Visual Basic [image] Copy Code

Public Property SnapInterval As Double

Property Value

A double value specifying the snapping interval.

Remarks

This value is relevant only when IsSnapValueEnabled property is set to true.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBackground Property

Slider.ThumbBackground Property
[image]

Gets or sets the background of the slider thumb. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ThumbBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ThumbBackground As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBorderBrush Property

Slider.ThumbBorderBrush Property
[image]

Gets or sets the border brush of the slider thumb. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ThumbBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ThumbBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbBorderThickness Property

Slider.ThumbBorderThickness Property
[image]

Gets or sets the border thickness of the slider thumb. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ThumbBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ThumbBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ThumbSize Property

Slider.ThumbSize Property
[image]

Gets or sets the size of the slider thumbs. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ThumbSize { get; set; }

Visual Basic [image] Copy Code

Public Property ThumbSize As Double

Property Value

A double value specifying the size of the thumbs.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickBrush Property

Slider.TickBrush Property
[image]

Gets or sets the brush used to paint tick lines. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush TickBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TickBrush As Brush

Property Value

A WPF Brush object.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickFrequency Property

Slider.TickFrequency Property
[image]

Gets or sets the interval between adjacent ticks. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double TickFrequency { get; set; }

Visual Basic [image] Copy Code

Public Property TickFrequency As Double

Property Value

A double value specifying the distance between ticks.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickPlacement Property

Slider.TickPlacement Property
[image]

Gets or sets a value indicating the position of the ticks relative to the rail. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TickPlacement TickPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TickPlacement As TickPlacement

Property Value

A member of the WPF TickPlacement enumeration.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickSize Property

Slider.TickSize Property
[image]

Gets or sets the size of the ticks. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double TickSize { get; set; }

Visual Basic [image] Copy Code

Public Property TickSize As Double

Property Value

A double value specifying the size of the ticks.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickTextFormat Property

Slider.TickTextFormat Property
[image]

Gets or sets the format of the values displayed for each tick. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public string TickTextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TickTextFormat As String

Property Value

A string value specifying the tick value formatting.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickThickness Property

Slider.TickThickness Property
[image]

Gets or sets the border thickness of the ticks. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double TickThickness { get; set; }

Visual Basic [image] Copy Code

Public Property TickThickness As Double

Property Value

A double value specifying the thickness of the tick lines.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.TickType Property

Slider.TickType Property
[image]

Gets or sets a value indicating how ticks are displayed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TickType TickType { get; set; }

Visual Basic [image] Copy Code

Public Property TickType As TickType

Property Value

A member of the TickType enumeration.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.Value Property

Slider.Value Property
[image]

Gets or sets the single value selected in the slider. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

Remarks

This property is relevant only when IsSelectionRangeEnabled is set to false.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider Events

Slider Events
[image]

Public Events

Name | Description
SelectionEndChanged | Raised when the end of the selected value range has changed.
SelectionStartChanged | Raised when the start of the selected value range has changed.
ValueChanged | Raised when the selected value has changed.

See Also

Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionEndChanged Event

Slider.SelectionEndChanged Event
[image]

Raised when the end of the selected value range has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> SelectionEndChanged

Visual Basic [image] Copy Code

Public Event SelectionEndChanged As EventHandler(Of EventArgs)

Event Data

SelectionEndChanged event handlers receive an argument of type EventArgs.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.SelectionStartChanged Event

Slider.SelectionStartChanged Event
[image]

Raised when the start of the selected value range has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> SelectionStartChanged

Visual Basic [image] Copy Code

Public Event SelectionStartChanged As EventHandler(Of EventArgs)

Event Data

SelectionStartChanged event handlers receive an argument of type EventArgs.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Slider.ValueChanged Event

Slider.ValueChanged Event
[image]

Raised when the selected value has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<EventArgs> ValueChanged

Visual Basic [image] Copy Code

Public Event ValueChanged As EventHandler(Of EventArgs)

Event Data

ValueChanged event handlers receive an argument of type EventArgs.

See Also

Slider Members
Slider Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Class

SpecialKey Class
[image]

Represents special keys.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class SpecialKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class SpecialKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.SpecialKey

See Also

SpecialKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Members

SpecialKey Members
Constructors Properties Methods Events
[image]

Represents special keys.

The following tables list the members exposed by the SpecialKey type.

Public Constructors

Name | Description
SpecialKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this SpecialKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Constructor

SpecialKey Constructor
[image]

Overload List

Name | Description
SpecialKey () | Initializes a new instace of the SpecialKey class.
SpecialKey (Int32) | Initializes a new instace of the SpecialKey class with specified virtual key code.
SpecialKey (Int32, Object) | Initializes a new instace of the SpecialKey class with specified virtual key code and content.

See Also

SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Constructor ()

SpecialKey Constructor ()
See Also
[image]

Initializes a new instace of the SpecialKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpecialKey Constructor Overload List
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Constructor (Int32)

SpecialKey Constructor (Int32)
See Also
[image]

Initializes a new instace of the SpecialKey class with specified virtual key code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey (
int virtualKey
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer _
)

Parameters

virtualKey

Virtual key code.

See Also

SpecialKey Constructor Overload List
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Constructor (Int32, Object)

SpecialKey Constructor (Int32, Object)
See Also
[image]

Initializes a new instace of the SpecialKey class with specified virtual key code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public SpecialKey (
int virtualKey,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
virtualKey As Integer, _
content As Object _
)

Parameters

virtualKey

Virtual key code.

content

The key's label.

See Also

SpecialKey Constructor Overload List
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Methods

SpecialKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this SpecialKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey.Clone Method

SpecialKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new SpecialKey instance.

See Also

SpecialKey Members
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey.Equals Method

SpecialKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

SpecialKey Members
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey.GetHashCode Method

SpecialKey.GetHashCode Method
[image]

Returns a hash code for this SpecialKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

SpecialKey Members
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey.Send Method

SpecialKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

SpecialKey Members
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Properties

SpecialKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
VirtualKey | Gets or sets the key code of this key.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey.VirtualKey Property

SpecialKey.VirtualKey Property
[image]

Gets or sets the key code of this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int VirtualKey { get; set; }

Visual Basic [image] Copy Code

Public Property VirtualKey As Integer

Property Value

See Also

SpecialKey Members
SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.SpecialKey Events

SpecialKey Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

SpecialKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabAlignment Enumeration

TabAlignment Enumeration
[image]

Specifies the alignment of the tab headers in a TabControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum TabAlignment

Visual Basic [image] Copy Code

Public Enum TabAlignment

Members

Member name | Description
Center | The headers are centered in the available space.
Far | The headers are aligned to the far end of the available space.
Near | The headers are aligned to the near end of the available space.
Stretch | The headers are resized to fill the available space.

Remarks

Values of this enumeration can be assigned to the TabAlignment property of the TabControl class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Class

TabControl Class
Remarks See Also
[image]

Represents a tab control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class TabControl : ItemsControl

Visual Basic [image] Copy Code

Public Class TabControl
Inherits ItemsControl

Remarks

The TabControl represents a standard tab control with extended functionality. The tabs in the TabControl can be repositioned interactively through dragging. To enable this, set EnableDragging to true. The tabs can be docked to any side of the control (TabStripPlacement), rotated (TabRotation) or aligned (TabAlignment) according to the user's needs. Each tab can display small buttons for interactive addition or removal of tabs. To turn the buttons on and off, set the AddButtonVisibility and RemoveButtonVisibility properties to the appropriate value.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.UI.Wpf.TabControl

See Also

TabControl Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Members

TabControl Members
Constructors Fields Properties Methods Events
[image]

Represents a tab control.

The following tables list the members exposed by the TabControl type.

Public Constructors

Name | Description
TabControl | Initializes a new instance of the TabControl class.

Public Fields

Name | Description
AddButtonVisibilityProperty | Identifies the AddButtonVisibility dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonMarginProperty | Identifies the ButtonMargin dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
EnableDraggingProperty | Identifies the EnableDragging dependency property.
RemoveButtonVisibilityProperty | Identifies the RemoveButtonVisibility dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedContentProperty | Identifies the SelectedContent dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

Public Properties

Name | Description
AddButtonVisibility | Gets or sets a value indicating whether the 'Add' button is displayed in the tab headers. This is a dependency property.
ButtonBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonMargin | Gets or sets the margin of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
EnableDragging | Gets or sets a value indicating whether tabs can be repositioned interactively through dragging. This is a dependency property.
RemoveButtonVisibility | Gets or sets a value indicating whether the 'Remove' button is displayed in the tab headers. This is a dependency property.
ScrollOffset | Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.
ScrollStep | Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.
SelectedContent | Gets or sets the content of the currently selected item. This is a dependency property.
SelectedIndex | Gets or sets the index of the currently selected item. This is a dependency property.
SelectedItem | Gets or sets the currently selected item. This is a dependency property.
TabAlignment | Gets or sets the alignment of the tab headers. This is a dependency property.
TabLayoutMode | Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.
TabRotation | Gets or sets the rotation of the tab headers. This is a dependency property.
TabStripPlacement | Gets or sets the alignment of the tab headers. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnItemsChanged | ItemsControl.OnItemsChanged override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

Public Events

Name | Description
DragCompleted | Raised when a drag operation has completed.
DragStarted | Raised when a drag operation has started.
TabAdd | Raised when a tab has been added to the control.
TabAddButtonClick | Raised when the 'Add' button in a tab header has been clicked.
TabClick | Raised when a tab has been clicked.
TabDown | Raised when the mouse is pressed over a tab.
TabEnter | Raised when the mouse enters a tab.
TabLeave | Raised when the mouse leaves a tab.
TabMove | Raised when a tab has been moved interactively through dragging.
TabRemoveButtonClick | Raised when the 'Remove' button in a tab header has been clicked.
TabSelectionChanged | Raised when the tab selection has changed.

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Fields

TabControl Fields
[image]

Public Fields

Name | Description
AddButtonVisibilityProperty | Identifies the AddButtonVisibility dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonMarginProperty | Identifies the ButtonMargin dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
ButtonSizeProperty | Identifies the ButtonSize dependency property.
EnableDraggingProperty | Identifies the EnableDragging dependency property.
RemoveButtonVisibilityProperty | Identifies the RemoveButtonVisibility dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedContentProperty | Identifies the SelectedContent dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
TabAlignmentProperty | Identifies the TabAlignment dependency property.
TabLayoutModeProperty | Identifies the TabLayoutMode dependency property.
TabRotationProperty | Identifies the TabRotation dependency property.
TabStripPlacementProperty | Identifies the TabStripPlacement dependency property.

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.AddButtonVisibilityProperty Field

TabControl.AddButtonVisibilityProperty Field
[image]

Identifies the AddButtonVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AddButtonVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AddButtonVisibilityProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBackgroundProperty Field

TabControl.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBorderBrushProperty Field

TabControl.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBorderThicknessProperty Field

TabControl.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonMarginProperty Field

TabControl.ButtonMarginProperty Field
[image]

Identifies the ButtonMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonMarginProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonOverBackgroundProperty Field

TabControl.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonPressedBackgroundProperty Field

TabControl.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonSizeProperty Field

TabControl.ButtonSizeProperty Field
[image]

Identifies the ButtonSize dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonSizeProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.EnableDraggingProperty Field

TabControl.EnableDraggingProperty Field
[image]

Identifies the EnableDragging dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDraggingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDraggingProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.RemoveButtonVisibilityProperty Field

TabControl.RemoveButtonVisibilityProperty Field
[image]

Identifies the RemoveButtonVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RemoveButtonVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RemoveButtonVisibilityProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ScrollOffsetProperty Field

TabControl.ScrollOffsetProperty Field
[image]

Identifies the ScrollOffset dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ScrollStepProperty Field

TabControl.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedContentProperty Field

TabControl.SelectedContentProperty Field
[image]

Identifies the SelectedContent dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedContentProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedIndexProperty Field

TabControl.SelectedIndexProperty Field
[image]

Identifies the SelectedIndex dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedIndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedItemProperty Field

TabControl.SelectedItemProperty Field
[image]

Identifies the SelectedItem dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedItemProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabAlignmentProperty Field

TabControl.TabAlignmentProperty Field
[image]

Identifies the TabAlignment dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabAlignmentProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabLayoutModeProperty Field

TabControl.TabLayoutModeProperty Field
[image]

Identifies the TabLayoutMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabLayoutModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabLayoutModeProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabRotationProperty Field

TabControl.TabRotationProperty Field
[image]

Identifies the TabRotation dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabRotationProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabStripPlacementProperty Field

TabControl.TabStripPlacementProperty Field
[image]

Identifies the TabStripPlacement dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabStripPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Constructor

TabControl Constructor
[image]

Initializes a new instance of the TabControl class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Methods

TabControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
GetContainerForItemOverride | ItemsControl.GetContainerForItemOverride override.
IsItemItsOwnContainerOverride | ItemsControl.IsItemItsOwnContainerOverride override.
OnItemsChanged | ItemsControl.OnItemsChanged override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.
PrepareContainerForItemOverride | ItemsControl.PrepareContainerForItemOverride override.

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.GetContainerForItemOverride Method

TabControl.GetContainerForItemOverride Method
[image]

ItemsControl.GetContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual DependencyObject GetContainerForItemOverride ()

Visual Basic [image] Copy Code

Protected Overridable Function GetContainerForItemOverride () As DependencyObject

Return Value

The element that is used to display the given item.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.IsItemItsOwnContainerOverride Method

TabControl.IsItemItsOwnContainerOverride Method
[image]

ItemsControl.IsItemItsOwnContainerOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual bool IsItemItsOwnContainerOverride (
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Function IsItemItsOwnContainerOverride( _
item As Object _
) As Boolean

Parameters

item

The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.OnApplyTemplate Method

TabControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.OnItemsChanged Method

TabControl.OnItemsChanged Method
[image]

ItemsControl.OnItemsChanged override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnItemsChanged (
NotifyCollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemsChanged( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e

Information about the change.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.OnMouseLeftButtonDown Method

TabControl.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.OnMouseLeftButtonUp Method

TabControl.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseLeftButtonUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.OnMouseMove Method

TabControl.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.PrepareContainerForItemOverride Method

TabControl.PrepareContainerForItemOverride Method
[image]

ItemsControl.PrepareContainerForItemOverride override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void PrepareContainerForItemOverride (
DependencyObject element,
Object item
)

Visual Basic [image] Copy Code

Protected Overridable Sub PrepareContainerForItemOverride( _
element As DependencyObject, _
item As Object _
)

Parameters

element

Element used to display the specified item.

item

Specified item.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Properties

TabControl Properties
[image]

Public Properties

Name | Description
AddButtonVisibility | Gets or sets a value indicating whether the 'Add' button is displayed in the tab headers. This is a dependency property.
ButtonBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonMargin | Gets or sets the margin of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pressed. This is a dependency property.
ButtonSize | Gets or sets the size of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.
EnableDragging | Gets or sets a value indicating whether tabs can be repositioned interactively through dragging. This is a dependency property.
RemoveButtonVisibility | Gets or sets a value indicating whether the 'Remove' button is displayed in the tab headers. This is a dependency property.
ScrollOffset | Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.
ScrollStep | Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.
SelectedContent | Gets or sets the content of the currently selected item. This is a dependency property.
SelectedIndex | Gets or sets the index of the currently selected item. This is a dependency property.
SelectedItem | Gets or sets the currently selected item. This is a dependency property.
TabAlignment | Gets or sets the alignment of the tab headers. This is a dependency property.
TabLayoutMode | Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.
TabRotation | Gets or sets the rotation of the tab headers. This is a dependency property.
TabStripPlacement | Gets or sets the alignment of the tab headers. This is a dependency property.

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.AddButtonVisibility Property

TabControl.AddButtonVisibility Property
[image]

Gets or sets a value indicating whether the 'Add' button is displayed in the tab headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility AddButtonVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property AddButtonVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBackground Property

TabControl.ButtonBackground Property
[image]

Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBorderBrush Property

TabControl.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonBorderThickness Property

TabControl.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonMargin Property

TabControl.ButtonMargin Property
[image]

Gets or sets the margin of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonMargin As Thickness

Property Value

A WPF Thickness object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonOverBackground Property

TabControl.ButtonOverBackground Property
[image]

Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonPressedBackground Property

TabControl.ButtonPressedBackground Property
[image]

Gets or sets the background of the buttons, displayed when TabLayoutMode is set to Scroll, when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ButtonSize Property

TabControl.ButtonSize Property
[image]

Gets or sets the size of the buttons, displayed when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ButtonSize { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonSize As Double

Property Value

A double value specifying the size of the buttons.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.EnableDragging Property

TabControl.EnableDragging Property
[image]

Gets or sets a value indicating whether tabs can be repositioned interactively through dragging. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool EnableDragging { get; set; }

Visual Basic [image] Copy Code

Public Property EnableDragging As Boolean

Property Value

true if dragging is enabled; otherwise, false.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.RemoveButtonVisibility Property

TabControl.RemoveButtonVisibility Property
[image]

Gets or sets a value indicating whether the 'Remove' button is displayed in the tab headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility RemoveButtonVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property RemoveButtonVisibility As Visibility

Property Value

A member of the WPF Visibility enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ScrollOffset Property

TabControl.ScrollOffset Property
[image]

Gets or sets the scroll amount when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ScrollOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOffset As Double

Property Value

A double value specifying the offset.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.ScrollStep Property

TabControl.ScrollStep Property
[image]

Gets or sets the scroll step when TabLayoutMode is set to Scroll. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public double ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Double

Property Value

A double value specifying the step.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedContent Property

TabControl.SelectedContent Property
[image]

Gets or sets the content of the currently selected item. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Object SelectedContent { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedContent As Object

Property Value

A reference to the content associated with the selected item.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedIndex Property

TabControl.SelectedIndex Property
[image]

Gets or sets the index of the currently selected item. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public int SelectedIndex { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedIndex As Integer

Property Value

A non-negative integer value.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.SelectedItem Property

TabControl.SelectedItem Property
[image]

Gets or sets the currently selected item. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Object SelectedItem { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedItem As Object

Property Value

A reference to the selected item.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabAlignment Property

TabControl.TabAlignment Property
[image]

Gets or sets the alignment of the tab headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabAlignment TabAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TabAlignment As TabAlignment

Property Value

A member of the TabAlignment enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabLayoutMode Property

TabControl.TabLayoutMode Property
[image]

Gets or sets a value indicating how tab headers are arranged when the available space is insufficient. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabLayoutMode TabLayoutMode { get; set; }

Visual Basic [image] Copy Code

Public Property TabLayoutMode As TabLayoutMode

Property Value

A member of the TabLayoutMode enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabRotation Property

TabControl.TabRotation Property
[image]

Gets or sets the rotation of the tab headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabRotation TabRotation { get; set; }

Visual Basic [image] Copy Code

Public Property TabRotation As TabRotation

Property Value

A member of the TabRotation enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabStripPlacement Property

TabControl.TabStripPlacement Property
[image]

Gets or sets the alignment of the tab headers. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Dock TabStripPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TabStripPlacement As Dock

Property Value

A member of the Dock enumeration.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl Events

TabControl Events
[image]

Public Events

Name | Description
DragCompleted | Raised when a drag operation has completed.
DragStarted | Raised when a drag operation has started.
TabAdd | Raised when a tab has been added to the control.
TabAddButtonClick | Raised when the 'Add' button in a tab header has been clicked.
TabClick | Raised when a tab has been clicked.
TabDown | Raised when the mouse is pressed over a tab.
TabEnter | Raised when the mouse enters a tab.
TabLeave | Raised when the mouse leaves a tab.
TabMove | Raised when a tab has been moved interactively through dragging.
TabRemoveButtonClick | Raised when the 'Remove' button in a tab header has been clicked.
TabSelectionChanged | Raised when the tab selection has changed.

See Also

TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.DragCompleted Event

TabControl.DragCompleted Event
[image]

Raised when a drag operation has completed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> DragCompleted

Visual Basic [image] Copy Code

Public Event DragCompleted As EventHandler(Of TabEventArgs)

Event Data

DragCompleted event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.DragStarted Event

TabControl.DragStarted Event
[image]

Raised when a drag operation has started.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> DragStarted

Visual Basic [image] Copy Code

Public Event DragStarted As EventHandler(Of TabEventArgs)

Event Data

DragStarted event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabAdd Event

TabControl.TabAdd Event
[image]

Raised when a tab has been added to the control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabAdd

Visual Basic [image] Copy Code

Public Event TabAdd As EventHandler(Of TabEventArgs)

Event Data

TabAdd event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabAddButtonClick Event

TabControl.TabAddButtonClick Event
[image]

Raised when the 'Add' button in a tab header has been clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabAddButtonClick

Visual Basic [image] Copy Code

Public Event TabAddButtonClick As EventHandler(Of TabEventArgs)

Event Data

TabAddButtonClick event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabClick Event

TabControl.TabClick Event
[image]

Raised when a tab has been clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabClick

Visual Basic [image] Copy Code

Public Event TabClick As EventHandler(Of TabEventArgs)

Event Data

TabClick event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabDown Event

TabControl.TabDown Event
[image]

Raised when the mouse is pressed over a tab.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabDown

Visual Basic [image] Copy Code

Public Event TabDown As EventHandler(Of TabEventArgs)

Event Data

TabDown event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabEnter Event

TabControl.TabEnter Event
[image]

Raised when the mouse enters a tab.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabEnter

Visual Basic [image] Copy Code

Public Event TabEnter As EventHandler(Of TabEventArgs)

Event Data

TabEnter event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabLeave Event

TabControl.TabLeave Event
[image]

Raised when the mouse leaves a tab.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabLeave

Visual Basic [image] Copy Code

Public Event TabLeave As EventHandler(Of TabEventArgs)

Event Data

TabLeave event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabMove Event

TabControl.TabMove Event
[image]

Raised when a tab has been moved interactively through dragging.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabMove

Visual Basic [image] Copy Code

Public Event TabMove As EventHandler(Of TabEventArgs)

Event Data

TabMove event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabRemoveButtonClick Event

TabControl.TabRemoveButtonClick Event
[image]

Raised when the 'Remove' button in a tab header has been clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabRemoveButtonClick

Visual Basic [image] Copy Code

Public Event TabRemoveButtonClick As EventHandler(Of TabEventArgs)

Event Data

TabRemoveButtonClick event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabControl.TabSelectionChanged Event

TabControl.TabSelectionChanged Event
[image]

Raised when the tab selection has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<TabEventArgs> TabSelectionChanged

Visual Basic [image] Copy Code

Public Event TabSelectionChanged As EventHandler(Of TabEventArgs)

Event Data

TabSelectionChanged event handlers receive an argument of type TabEventArgs.

See Also

TabControl Members
TabControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs Class

TabEventArgs Class
[image]

Contains information for TabControl-related events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class TabEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TabEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.TabEventArgs

See Also

TabEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs Members

TabEventArgs Members
Constructors Properties
[image]

Contains information for TabControl-related events.

The following tables list the members exposed by the TabEventArgs type.

Public Constructors

Name | Description
TabEventArgs | Initializes a new instance of the TabEventArgs class.

Public Properties

Name | Description
Control | Gets the TabControl related to the event.
Item | Gets the data item related to the event.
MouseEventArgs | Gets the MouseEventArgs related to the event.
TabItem | Gets the TabItem related to the event.

See Also

TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs Constructor

TabEventArgs Constructor
[image]

Initializes a new instance of the TabEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabEventArgs (
Object obj,
TabItem tab,
MouseEventArgs e,
TabControl control
)

Visual Basic [image] Copy Code

Public New ( _
obj As Object, _
tab As TabItem, _
e As MouseEventArgs, _
control As TabControl _
)

Parameters

obj

The data item related to the event.

tab
The TabItem related to the event.
e
The MouseEventArgs related to the event.
control
The TabControl related to the event.

See Also

TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs Properties

TabEventArgs Properties
[image]

Public Properties

Name | Description
Control | Gets the TabControl related to the event.
Item | Gets the data item related to the event.
MouseEventArgs | Gets the MouseEventArgs related to the event.
TabItem | Gets the TabItem related to the event.

See Also

TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs.Control Property

TabEventArgs.Control Property
[image]

Gets the TabControl related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabControl Control { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Control As TabControl

Property Value

An instance of the TabControl class.

See Also

TabEventArgs Members
TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs.Item Property

TabEventArgs.Item Property
[image]

Gets the data item related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Object Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Object

Property Value

An object representing the data item.

See Also

TabEventArgs Members
TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs.MouseEventArgs Property

TabEventArgs.MouseEventArgs Property
[image]

Gets the MouseEventArgs related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public MouseEventArgs MouseEventArgs { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MouseEventArgs As MouseEventArgs

Property Value

A WPF MouseEventArgs object.

See Also

TabEventArgs Members
TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabEventArgs.TabItem Property

TabEventArgs.TabItem Property
[image]

Gets the TabItem related to the event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabItem TabItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TabItem As TabItem

Property Value

An instance of the TabItem class.

See Also

TabEventArgs Members
TabEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Class

TabItem Class
[image]

Represents an item in a TabControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class TabItem : ContentControl

Visual Basic [image] Copy Code

Public Class TabItem
Inherits ContentControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.UI.Wpf.TabItem

See Also

TabItem Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Members

TabItem Members
Constructors Fields Properties Methods Events
[image]

Represents an item in a TabControl.

The following tables list the members exposed by the TabItem type.

Public Constructors

Name | Description
TabItem | Initializes a new instance of the TabItem class.

Public Fields

Name | Description
AddButtonVisibilityProperty | This member is for internal use only.
CornerRadiusProperty | This member is for internal use only.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
OverBackgroundProperty | Identifies the OverBackground dependency property.
PressedBackgroundProperty | Identifies the PressedBackground dependency property.
RemoveButtonVisibilityProperty | This member is for internal use only.
SelectedBackgroundProperty | Identifies the SelectedBackground dependency property.
SelectedBorderBrushProperty | Identifies the SelectedBorderBrush dependency property.
TabRotationProperty | This member is for internal use only.
TabStripPlacementProperty | This member is for internal use only.

Public Properties

Name | Description
AddButtonVisibility | This member is for internal use only.
CornerRadius | This member is for internal use only.
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
IsSelected | Gets or sets a value indicating whether this items is selected. This is a dependency property.
OverBackground | Gets or sets the background of the item when it is pointed with the mouse. This is a dependency property.
PressedBackground | Gets or sets the background of the item when it is pressed. This is a dependency property.
RemoveButtonVisibility | This member is for internal use only.
SelectedBackground | Gets or sets the background of the item when it is selected. This is a dependency property.
SelectedBorderBrush | Gets or sets the border brush of the item when it is selected. This is a dependency property.
TabRotation | This member is for internal use only.
TabStripPlacement | This member is for internal use only.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnAddTab | Raises the AddTab event.
OnClick | Raises the Click event.
OnIsSelectedChanged | Raises the SelectedChanged event.
OnRemoveTab | Raises the RemoveTab event.

Public Events

Name | Description
AddTab | Raised when the 'Add Tab' button in the item's header is clicked.
Click | Raised when the item is clicked.
IsSelectedChanged | Raised when the IsSelected property has changed.
RemoveTab | Raised when the 'Remove Tab' button in the item's header is clicked.

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Fields

TabItem Fields
[image]

Public Fields

Name | Description
AddButtonVisibilityProperty | This member is for internal use only.
CornerRadiusProperty | This member is for internal use only.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
OverBackgroundProperty | Identifies the OverBackground dependency property.
PressedBackgroundProperty | Identifies the PressedBackground dependency property.
RemoveButtonVisibilityProperty | This member is for internal use only.
SelectedBackgroundProperty | Identifies the SelectedBackground dependency property.
SelectedBorderBrushProperty | Identifies the SelectedBorderBrush dependency property.
TabRotationProperty | This member is for internal use only.
TabStripPlacementProperty | This member is for internal use only.

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.AddButtonVisibilityProperty Field

TabItem.AddButtonVisibilityProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AddButtonVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AddButtonVisibilityProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.CornerRadiusProperty Field

TabItem.CornerRadiusProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.HeaderProperty Field

TabItem.HeaderProperty Field
[image]

Identifies the Header dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.HeaderTemplateProperty Field

TabItem.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.IsSelectedProperty Field

TabItem.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OverBackgroundProperty Field

TabItem.OverBackgroundProperty Field
[image]

Identifies the OverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverBackgroundProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.PressedBackgroundProperty Field

TabItem.PressedBackgroundProperty Field
[image]

Identifies the PressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PressedBackgroundProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.RemoveButtonVisibilityProperty Field

TabItem.RemoveButtonVisibilityProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RemoveButtonVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RemoveButtonVisibilityProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.SelectedBackgroundProperty Field

TabItem.SelectedBackgroundProperty Field
[image]

Identifies the SelectedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedBackgroundProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.SelectedBorderBrushProperty Field

TabItem.SelectedBorderBrushProperty Field
[image]

Identifies the SelectedBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedBorderBrushProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.TabRotationProperty Field

TabItem.TabRotationProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabRotationProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.TabStripPlacementProperty Field

TabItem.TabStripPlacementProperty Field
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TabStripPlacementProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TabStripPlacementProperty As DependencyProperty

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Constructor

TabItem Constructor
[image]

Initializes a new instance of the TabItem class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Methods

TabItem Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnAddTab | Raises the AddTab event.
OnClick | Raises the Click event.
OnIsSelectedChanged | Raises the SelectedChanged event.
OnRemoveTab | Raises the RemoveTab event.

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OnAddTab Method

TabItem.OnAddTab Method
[image]

Raises the AddTab event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnAddTab (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAddTab( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OnApplyTemplate Method

TabItem.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OnClick Method

TabItem.OnClick Method
[image]

Raises the Click event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClick (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClick( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OnIsSelectedChanged Method

TabItem.OnIsSelectedChanged Method
[image]

Raises the SelectedChanged event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnIsSelectedChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnIsSelectedChanged( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OnRemoveTab Method

TabItem.OnRemoveTab Method
[image]

Raises the RemoveTab event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnRemoveTab (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemoveTab( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Properties

TabItem Properties
[image]

Public Properties

Name | Description
AddButtonVisibility | This member is for internal use only.
CornerRadius | This member is for internal use only.
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
IsSelected | Gets or sets a value indicating whether this items is selected. This is a dependency property.
OverBackground | Gets or sets the background of the item when it is pointed with the mouse. This is a dependency property.
PressedBackground | Gets or sets the background of the item when it is pressed. This is a dependency property.
RemoveButtonVisibility | This member is for internal use only.
SelectedBackground | Gets or sets the background of the item when it is selected. This is a dependency property.
SelectedBorderBrush | Gets or sets the border brush of the item when it is selected. This is a dependency property.
TabRotation | This member is for internal use only.
TabStripPlacement | This member is for internal use only.

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.AddButtonVisibility Property

TabItem.AddButtonVisibility Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility AddButtonVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property AddButtonVisibility As Visibility

Property Value

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.CornerRadius Property

TabItem.CornerRadius Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.Header Property

TabItem.Header Property
[image]

Gets or sets the content of the window title bar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Object Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Object

Property Value

An object representing the header's content.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.HeaderTemplate Property

TabItem.HeaderTemplate Property
[image]

Gets or sets the template used to display the content of the window's title. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.IsSelected Property

TabItem.IsSelected Property
[image]

Gets or sets a value indicating whether this items is selected. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool IsSelected { get; set; }

Visual Basic [image] Copy Code

Public Property IsSelected As Boolean

Property Value

true if the item is selected; otherwise, false.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.OverBackground Property

TabItem.OverBackground Property
[image]

Gets or sets the background of the item when it is pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush OverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property OverBackground As Brush

Property Value

A WPF Brush object.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.PressedBackground Property

TabItem.PressedBackground Property
[image]

Gets or sets the background of the item when it is pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush PressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property PressedBackground As Brush

Property Value

A WPF Brush object.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.RemoveButtonVisibility Property

TabItem.RemoveButtonVisibility Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Visibility RemoveButtonVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property RemoveButtonVisibility As Visibility

Property Value

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.SelectedBackground Property

TabItem.SelectedBackground Property
[image]

Gets or sets the background of the item when it is selected. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush SelectedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedBackground As Brush

Property Value

A WPF Brush object.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.SelectedBorderBrush Property

TabItem.SelectedBorderBrush Property
[image]

Gets or sets the border brush of the item when it is selected. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush SelectedBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.TabRotation Property

TabItem.TabRotation Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public TabRotation TabRotation { get; set; }

Visual Basic [image] Copy Code

Public Property TabRotation As TabRotation

Property Value

A member of the TabRotation enumeration.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.TabStripPlacement Property

TabItem.TabStripPlacement Property
[image]

This member is for internal use only.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Dock TabStripPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property TabStripPlacement As Dock

Property Value

A member of the Dock enumeration.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem Events

TabItem Events
[image]

Public Events

Name | Description
AddTab | Raised when the 'Add Tab' button in the item's header is clicked.
Click | Raised when the item is clicked.
IsSelectedChanged | Raised when the IsSelected property has changed.
RemoveTab | Raised when the 'Remove Tab' button in the item's header is clicked.

See Also

TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.AddTab Event

TabItem.AddTab Event
[image]

Raised when the 'Add Tab' button in the item's header is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler AddTab

Visual Basic [image] Copy Code

Public Event AddTab As EventHandler

Event Data

AddTab event handlers receive an argument of type EventArgs.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.Click Event

TabItem.Click Event
[image]

Raised when the item is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler Click

Visual Basic [image] Copy Code

Public Event Click As EventHandler

Event Data

Click event handlers receive an argument of type EventArgs.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.IsSelectedChanged Event

TabItem.IsSelectedChanged Event
[image]

Raised when the IsSelected property has changed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler IsSelectedChanged

Visual Basic [image] Copy Code

Public Event IsSelectedChanged As EventHandler

Event Data

IsSelectedChanged event handlers receive an argument of type EventArgs.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabItem.RemoveTab Event

TabItem.RemoveTab Event
[image]

Raised when the 'Remove Tab' button in the item's header is clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public event EventHandler RemoveTab

Visual Basic [image] Copy Code

Public Event RemoveTab As EventHandler

Event Data

RemoveTab event handlers receive an argument of type EventArgs.

See Also

TabItem Members
TabItem Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabLayoutMode Enumeration

TabLayoutMode Enumeration
[image]

Specifies how tab items are arranged in the header of a TabControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum TabLayoutMode

Visual Basic [image] Copy Code

Public Enum TabLayoutMode

Members

Member name | Description
Scroll | The TabControl can scroll the tab items.
Wrap | The tab items wrap to a new line when the available space is not sufficient.

Remarks

Values of this enumeration can be assigned to the TabLayoutMode property of the TabControl class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TabRotation Enumeration

TabRotation Enumeration
[image]

Specifies the rotation of the tab items in a TabControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum TabRotation

Visual Basic [image] Copy Code

Public Enum TabRotation

Members

Member name | Description
Clockwise | Indicates that the items are rotated clockwise.
Counterclockwise | Indicates that the items are rotated counterclockwise.
None | Indicates that the items are not rotated.

Remarks

Values of this enumeration can be assigned to the TabRotation property of the TabControl class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TickPosition Enumeration

TickPosition Enumeration
[image]

Specifies the position of trackbar ticks.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum TickPosition

Visual Basic [image] Copy Code

Public Enum TickPosition

Members

Member name | Description
Both | Ticks are rendered on both sides of the trackbar.
Left | Ticks are rendered on the left side of the trackbar.
None | There are no ticks rendered.
Right | Ticks are rendered on the right side of the trackbar.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.TickType Enumeration

TickType Enumeration
[image]

Specifies the type of the ticks in a Slider control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum TickType

Visual Basic [image] Copy Code

Public Enum TickType

Members

Member name | Description
Line | Indicates that the ticks display only a line but no value.
Number | Indicates that the ticks display only their corresponding value.
NumberAndLine | Indicates that the ticks display both line and value.

Remarks

Values of this enumeration can be assigned to the TickType property of the Slider class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Class

UnicodeKey Class
[image]

Represents keyboard keys that send unicode-character codes as input.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public sealed class UnicodeKey : Key

Visual Basic [image] Copy Code

Public NotInheritable Class UnicodeKey
Inherits Key

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.Key
MindFusion.UI.Wpf.UnicodeKey

See Also

UnicodeKey Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Members

UnicodeKey Members
Constructors Properties Methods Events
[image]

Represents keyboard keys that send unicode-character codes as input.

The following tables list the members exposed by the UnicodeKey type.

Public Constructors

Name | Description
UnicodeKey | Overloaded.

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Character | Gets or sets the Unicode character associated with this key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | Gets the lower-case characer.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | Gets the upper-case characer.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this UnicodeKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Constructor

UnicodeKey Constructor
[image]

Overload List

Name | Description
UnicodeKey () | Initializes a new instance of the UnicodeKey class.
UnicodeKey (Char) | Initializes a new instance of the UnicodeKey class with specified character code.
UnicodeKey (Char, Object) | Initializes a new instance of the UnicodeKey class with specified character code and content.

See Also

UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Constructor ()

UnicodeKey Constructor ()
See Also
[image]

Initializes a new instance of the UnicodeKey class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public UnicodeKey ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

UnicodeKey Constructor Overload List
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Constructor (Char)

UnicodeKey Constructor (Char)
See Also
[image]

Initializes a new instance of the UnicodeKey class with specified character code.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public UnicodeKey (
char character
)

Visual Basic [image] Copy Code

Public New ( _
character As Char _
)

Parameters

character

The character to send when this key is pressed.

See Also

UnicodeKey Constructor Overload List
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Constructor (Char, Object)

UnicodeKey Constructor (Char, Object)
See Also
[image]

Initializes a new instance of the UnicodeKey class with specified character code and content.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public UnicodeKey (
char character,
Object content
)

Visual Basic [image] Copy Code

Public New ( _
character As Char, _
content As Object _
)

Parameters

character

The character to send when this key is pressed.

content

Content sent as input to the focused control.

See Also

UnicodeKey Constructor Overload List
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Methods

UnicodeKey Methods
[image]

Public Methods

Name | Description
Clone | Clones this key.
Equals | Returns a value indicating whether this instance and a specified Key object represent the same value.
GetHashCode | Returns a hash code for this UnicodeKey.
GetVirtualKeyCode | Gets the virtual key code corresponding to a System.Windows.Input.Key value. (Inherited from Key.)
Send | Sends this key to the foreground window.

Protected Methods

Name | Description
Copy | Copies the properties of this key to specified one. (Inherited from Key.)

See Also

UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.Clone Method

UnicodeKey.Clone Method
[image]

Clones this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new UnicodeKey instance.

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.Equals Method

UnicodeKey.Equals Method
[image]

Returns a value indicating whether this instance and a specified Key object represent the same value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

A Key object to compare to this instance.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.GetHashCode Method

UnicodeKey.GetHashCode Method
[image]

Returns a hash code for this UnicodeKey.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The key's hash code.

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.Send Method

UnicodeKey.Send Method
[image]

Sends this key to the foreground window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void Send (
bool releaseSpecialKeys
)

Visual Basic [image] Copy Code

Public Overrides Sub Send( _
releaseSpecialKeys As Boolean _
)

Parameters

releaseSpecialKeys

true to release modifier keys, or false otherwise.

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Properties

UnicodeKey Properties
[image]

Public Properties

Name | Description
Alt | The alt virtual key. Virtual Key = 18 (Inherited from Key.)
AltGr | The alt gr virtual key. Virtual Key = 165 (Inherited from Key.)
Backspace | The backspace virtual key. (Inherited from Key.)
CapsLock | The caps lock virtual key. (Inherited from Key.)
Character | Gets or sets the Unicode character associated with this key.
Content | Gets or sets the key's text content. Some descendant key classes send their content as input to currently focused control; other ones only store their labels in it. (Inherited from Key.)
Context | The context menu virtual key. (Inherited from Key.)
Ctrl | The control virtual key. Virtual Key = 17 (Inherited from Key.)
Delete | The delete virtual key. (Inherited from Key.)
End | The end virtual key. (Inherited from Key.)
Enter | The enter virtual key. Virtual Key = 13 (Inherited from Key.)
Esc | The escape virtual key. (Inherited from Key.)
F1 | The F1 virtual key. (Inherited from Key.)
F10 | The F10 virtual key. (Inherited from Key.)
F11 | The F11 virtual key. (Inherited from Key.)
F12 | The F12 virtual key. (Inherited from Key.)
F2 | The F2 virtual key. (Inherited from Key.)
F3 | The F3 virtual key. (Inherited from Key.)
F4 | The F4 virtual key. (Inherited from Key.)
F5 | The F5 virtual key. (Inherited from Key.)
F6 | The F6 virtual key. (Inherited from Key.)
F7 | The F7 virtual key. (Inherited from Key.)
F8 | The F8 virtual key. (Inherited from Key.)
F9 | The F9 virtual key. (Inherited from Key.)
Height | The key's height. (Inherited from Key.)
Home | The home virtual key. (Inherited from Key.)
Image | Gets or sets relative path to an image that should be displayed inside this key. (Inherited from Key.)
Insert | The insert virtual key. (Inherited from Key.)
IsLocked | IsLocked. Used only for shift, alt, altgr, control, caps lock and num lock. (Inherited from Key.)
IsPressed | Set to true when this key is pressed down by the user. (Inherited from Key.)
IsSelected | IsSelected (Inherited from Key.)
KeyDown | The key down virtual key. (Inherited from Key.)
KeyLeft | The key left virtual key. (Inherited from Key.)
KeyRight | The key right virtual key. (Inherited from Key.)
KeyUp | The key up virtual key. (Inherited from Key.)
Lang | Language rotation virtual key. (Inherited from Key.)
Left | Horizontal position of the key. (Inherited from Key.)
LowerCase | Gets the lower-case characer.
Num5 | The numpad 5 virtual key. (Inherited from Key.)
NumDelete | The numpad delete virtual key. (Inherited from Key.)
NumDiv | The numpad / virtual key. (Inherited from Key.)
NumEnd | The numpad end virtual key. (Inherited from Key.)
NumHome | The numpad home virtual key. (Inherited from Key.)
NumInsert | The numpad insert virtual key. (Inherited from Key.)
NumKeyDown | The numpad key-down virtual key. (Inherited from Key.)
NumKeyLeft | The numpad key-left virtual key. (Inherited from Key.)
NumKeyRight | The numpad key-right virtual key. (Inherited from Key.)
NumKeyUp | The numpad key-up virtual key. (Inherited from Key.)
NumLock | The num lock virtual key. (Inherited from Key.)
NumMinus | The numpad - virtual key. (Inherited from Key.)
NumMult | The numpad * virtual key. (Inherited from Key.)
NumPageDown | The numpad page down virtual key. (Inherited from Key.)
NumPageUp | The numpad page up virtual key. (Inherited from Key.)
NumPlus | The numpad + virtual key. (Inherited from Key.)
PageDown | The page down virtual key. (Inherited from Key.)
PageUp | The page up virtual key. (Inherited from Key.)
PauseBreak | The pause / break virtual key. (Inherited from Key.)
PrtScr | The Print Screen virtual key. (Inherited from Key.)
Repeat | Gets or sets how many times to send the key code when this key is pressed.
ScrollLock | The scroll lock virtual key. (Inherited from Key.)
Shift | The shift virtual key. Virtual Key = 16 (Inherited from Key.)
Space | The space virtual key. (Inherited from Key.)
Tab | The tab virtual key. (Inherited from Key.)
Top | Vertical position of the key. (Inherited from Key.)
UpperCase | Gets the upper-case characer.
Width | The key's width. (Inherited from Key.)
Windows | The Windows virtual key. (Inherited from Key.)

See Also

UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.Character Property

UnicodeKey.Character Property
[image]

Gets or sets the Unicode character associated with this key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public char Character { get; set; }

Visual Basic [image] Copy Code

Public Property Character As Char

Property Value

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.LowerCase Property

UnicodeKey.LowerCase Property
[image]

Gets the lower-case characer.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public char LowerCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LowerCase As Char

Property Value

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.Repeat Property

UnicodeKey.Repeat Property
[image]

Gets or sets how many times to send the key code when this key is pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As Integer

Property Value

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey.UpperCase Property

UnicodeKey.UpperCase Property
[image]

Gets the upper-case characer.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public char UpperCase { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UpperCase As Char

Property Value

See Also

UnicodeKey Members
UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.UnicodeKey Events

UnicodeKey Events
[image]

Public Events

Name | Description
PropertyChanged | PropertyChanged (Inherited from Key.)

See Also

UnicodeKey Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter Class

ValueSetConverter Class
[image]

Converts references to boolean values.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class ValueSetConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ValueSetConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.UI.Wpf.ValueSetConverter

See Also

ValueSetConverter Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter Members

ValueSetConverter Members
Constructors Methods
[image]

Converts references to boolean values.

The following tables list the members exposed by the ValueSetConverter type.

Public Constructors

Name | Description
ValueSetConverter |

Public Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.

See Also

ValueSetConverter Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter Constructor

ValueSetConverter Constructor
[image]

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public ValueSetConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ValueSetConverter Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter Methods

ValueSetConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a value.
ConvertBack | Converts a value.

See Also

ValueSetConverter Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter.Convert Method

ValueSetConverter.Convert Method
[image]

Converts a value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value.

See Also

ValueSetConverter Members
ValueSetConverter Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ValueSetConverter.ConvertBack Method

ValueSetConverter.ConvertBack Method
[image]

Converts a value.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value that is produced by the binding target.

targetType

The type to convert to.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value.

See Also

ValueSetConverter Members
ValueSetConverter Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Class

VirtualKeyboard Class
[image]

Virtual Keyboard Control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class VirtualKeyboard : Control

Visual Basic [image] Copy Code

Public Class VirtualKeyboard
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.VirtualKeyboard

See Also

VirtualKeyboard Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Members

VirtualKeyboard Members
Constructors Fields Properties Methods Events
[image]

Virtual Keyboard Control.

The following tables list the members exposed by the VirtualKeyboard type.

Public Constructors

Name | Description
VirtualKeyboard | Initializes a new instance of VirtualKeyboard.

Public Fields

Name | Description
AttachedWindowProperty | Identifies the AttachedWindow dependency property.
AutoFillProperty | Identifies the AutoFill dependency property.
AutoReleaseModifierKeysProperty | Identifies the AutoReleaseModifierKeys dependency property.
AutoRepeatProperty | Identifies the AutoRepeat dependency property.
AutoUpdateCultureProperty | Identifies the AutoUpdateCulture dependency property.
DefaultLayoutProperty | Identifies the DefaultLayout dependency property.
InputLocaleProperty | Identifies the InputLocale dependency property.
IsStandAloneProperty | Identifies the IsStandAlone dependency property
LayoutProperty | Identifies the Layout dependency property.
LayoutsFolderProperty | Identifies the LayoutsFolder dependency property.
ModeProperty | Identifies the Mode dependency property.
RepeatDelayProperty | Identifies the RepeatDelay dependency property.
RepeatRateProperty | Identifies the RepeatRate dependency property.
TemplateLayoutProperty | Identifies the TemplateLayout dependency property.

Public Properties

Name | Description
AltGrLocked | Gets the state of the AltGr key.
AltLocked | Gets the state of the Alt key.
AttachedWindow | Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.
AutoFill | Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.
AutoReleaseModifierKeys | Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.
AutoRepeat | Gets or sets whether the component should synthesize keyboard events repeatedly when a virtual key is pressed down, until the key is released.
AutoUpdateCulture | Gets or sets whether the component should change the UI thread's CurrentCulture whenever the input locale changes.
CapsLocked | Gets the state of the Caps lock key.
ControlLocked | Gets the state of the Control key.
DefaultLayout | Obsolete; Gets or sets the default kayboard layout. This is a dependency property.
InputLocale | Gets or sets the current input language. This is a dependency property.
IsStandAlone | Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.
Layout | Gets the current keyboard layout. This is a dependency property.
LayoutsFolder | Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.
LicenseKey | Gets or sets the license key of the control.
Mode | Gets or sets the layout mode. This is a dependency property.
NumLocked | Gets the state of the Num lock key.
PreventActivation | Gets or sets whether to prevent activation of parent window when users click on a keyboard's key.
RepeatDelay | Specifies the initial delay in milliseconds before the component starts repeating key-down events when AutoRepeat is enabled.
RepeatRate | Gets or sets the delay in milliseconds between consecutive key-down events synthesized in AutoRepeat mode.
ScrollLocked | Gets the state of the Scroll lock key.
ShiftLocked | Gets the state of the Shift key.
TemplateLayout | Gets or sets the keyboard's template layout. This is a dependency property.

Public Methods

Name | Description
ForceUpdateLayout | Updates the keyboard layout.
OnApplyTemplate | Control.OnApplyTemplate override.
SendKey | Sends the specified key input to active window.
SetKeyLabels | Sets custom key labels to use for specified language.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseUp | Control.OnPreviewMouseUp override.
OnPreviewStylusDown | Control.OnPreviewStylusDown override.
OnPreviewStylusUp | Control.OnPreviewStylusUp override.
OnVisualParentChanged | Control.OnVisualParentChanged override.

Public Events

Name | Description
KeyPressed | Raised when a key has been pressed.

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Fields

VirtualKeyboard Fields
[image]

Public Fields

Name | Description
AttachedWindowProperty | Identifies the AttachedWindow dependency property.
AutoFillProperty | Identifies the AutoFill dependency property.
AutoReleaseModifierKeysProperty | Identifies the AutoReleaseModifierKeys dependency property.
AutoRepeatProperty | Identifies the AutoRepeat dependency property.
AutoUpdateCultureProperty | Identifies the AutoUpdateCulture dependency property.
DefaultLayoutProperty | Identifies the DefaultLayout dependency property.
InputLocaleProperty | Identifies the InputLocale dependency property.
IsStandAloneProperty | Identifies the IsStandAlone dependency property
LayoutProperty | Identifies the Layout dependency property.
LayoutsFolderProperty | Identifies the LayoutsFolder dependency property.
ModeProperty | Identifies the Mode dependency property.
RepeatDelayProperty | Identifies the RepeatDelay dependency property.
RepeatRateProperty | Identifies the RepeatRate dependency property.
TemplateLayoutProperty | Identifies the TemplateLayout dependency property.

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AttachedWindowProperty Field

VirtualKeyboard.AttachedWindowProperty Field
[image]

Identifies the AttachedWindow dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AttachedWindowProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AttachedWindowProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoFillProperty Field

VirtualKeyboard.AutoFillProperty Field
[image]

Identifies the AutoFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoFillProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoReleaseModifierKeysProperty Field

VirtualKeyboard.AutoReleaseModifierKeysProperty Field
[image]

Identifies the AutoReleaseModifierKeys dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoReleaseModifierKeysProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoReleaseModifierKeysProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoRepeatProperty Field

VirtualKeyboard.AutoRepeatProperty Field
[image]

Identifies the AutoRepeat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoRepeatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoRepeatProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoUpdateCultureProperty Field

VirtualKeyboard.AutoUpdateCultureProperty Field
[image]

Identifies the AutoUpdateCulture dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoUpdateCultureProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoUpdateCultureProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.DefaultLayoutProperty Field

VirtualKeyboard.DefaultLayoutProperty Field
[image]

Identifies the DefaultLayout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultLayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.InputLocaleProperty Field

VirtualKeyboard.InputLocaleProperty Field
[image]

Identifies the InputLocale dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InputLocaleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InputLocaleProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.IsStandAloneProperty Field

VirtualKeyboard.IsStandAloneProperty Field
[image]

Identifies the IsStandAlone dependency property

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsStandAloneProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsStandAloneProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.LayoutProperty Field

VirtualKeyboard.LayoutProperty Field
[image]

Identifies the Layout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.LayoutsFolderProperty Field

VirtualKeyboard.LayoutsFolderProperty Field
[image]

Identifies the LayoutsFolder dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LayoutsFolderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LayoutsFolderProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.ModeProperty Field

VirtualKeyboard.ModeProperty Field
[image]

Identifies the Mode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ModeProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.RepeatDelayProperty Field

VirtualKeyboard.RepeatDelayProperty Field
[image]

Identifies the RepeatDelay dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RepeatDelayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RepeatDelayProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.RepeatRateProperty Field

VirtualKeyboard.RepeatRateProperty Field
[image]

Identifies the RepeatRate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RepeatRateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RepeatRateProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.TemplateLayoutProperty Field

VirtualKeyboard.TemplateLayoutProperty Field
[image]

Identifies the TemplateLayout dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TemplateLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TemplateLayoutProperty As DependencyProperty

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Constructor

VirtualKeyboard Constructor
[image]

Initializes a new instance of VirtualKeyboard.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public VirtualKeyboard ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Methods

VirtualKeyboard Methods
[image]

Public Methods

Name | Description
ForceUpdateLayout | Updates the keyboard layout.
OnApplyTemplate | Control.OnApplyTemplate override.
SendKey | Sends the specified key input to active window.
SetKeyLabels | Sets custom key labels to use for specified language.

Protected Methods

Name | Description
OnPreviewMouseDown | Control.OnPreviewMouseDown override.
OnPreviewMouseUp | Control.OnPreviewMouseUp override.
OnPreviewStylusDown | Control.OnPreviewStylusDown override.
OnPreviewStylusUp | Control.OnPreviewStylusUp override.
OnVisualParentChanged | Control.OnVisualParentChanged override.

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.ForceUpdateLayout Method

VirtualKeyboard.ForceUpdateLayout Method
[image]

Updates the keyboard layout.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public void ForceUpdateLayout ()

Visual Basic [image] Copy Code

Public Sub ForceUpdateLayout ()

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnApplyTemplate Method

VirtualKeyboard.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewMouseDown Method

VirtualKeyboard.OnPreviewMouseDown Method
[image]

Control.OnPreviewMouseDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

MouseButtonEventArgs

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewMouseUp Method

VirtualKeyboard.OnPreviewMouseUp Method
[image]

Control.OnPreviewMouseUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseUp( _
e As MouseButtonEventArgs _
)

Parameters

e

A MouseButtonEventArgs instance containing data about the event.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewStylusDown Method

VirtualKeyboard.OnPreviewStylusDown Method
[image]

Control.OnPreviewStylusDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewStylusDown (
StylusDownEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewStylusDown( _
e As StylusDownEventArgs _
)

Parameters

e

A StylusDownEventArgs instance containing data about the event.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnPreviewStylusUp Method

VirtualKeyboard.OnPreviewStylusUp Method
[image]

Control.OnPreviewStylusUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewStylusUp (
StylusEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewStylusUp( _
e As StylusEventArgs _
)

Parameters

e

A StylusDownEventArgs instance containing data about the event.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.OnVisualParentChanged Method

VirtualKeyboard.OnVisualParentChanged Method
[image]

Control.OnVisualParentChanged override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

protected override void OnVisualParentChanged (
DependencyObject oldParent
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnVisualParentChanged( _
oldParent As DependencyObject _
)

Parameters

oldParent

The old parent.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.SendKey Method

VirtualKeyboard.SendKey Method
[image]

Sends the specified key input to active window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public virtual void SendKey (
Key objKey
)

Visual Basic [image] Copy Code

Public Overridable Sub SendKey( _
objKey As Key _
)

Parameters

objKey

Key

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.SetKeyLabels Method

VirtualKeyboard.SetKeyLabels Method
[image]

Sets custom key labels to use for specified language.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public void SetKeyLabels (
CultureInfo culture,
KeyLabels[] labels
)

Visual Basic [image] Copy Code

Public Sub SetKeyLabels( _
culture As CultureInfo, _
labels() As KeyLabels _
)

Parameters

culture

A CultureInfo specifying the language whose labels to override.

labels

An array of KeyLabels objects specifying custom labels.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Properties

VirtualKeyboard Properties
[image]

Public Properties

Name | Description
AltGrLocked | Gets the state of the AltGr key.
AltLocked | Gets the state of the Alt key.
AttachedWindow | Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.
AutoFill | Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.
AutoReleaseModifierKeys | Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.
AutoRepeat | Gets or sets whether the component should synthesize keyboard events repeatedly when a virtual key is pressed down, until the key is released.
AutoUpdateCulture | Gets or sets whether the component should change the UI thread's CurrentCulture whenever the input locale changes.
CapsLocked | Gets the state of the Caps lock key.
ControlLocked | Gets the state of the Control key.
DefaultLayout | Obsolete; Gets or sets the default kayboard layout. This is a dependency property.
InputLocale | Gets or sets the current input language. This is a dependency property.
IsStandAlone | Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.
Layout | Gets the current keyboard layout. This is a dependency property.
LayoutsFolder | Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.
LicenseKey | Gets or sets the license key of the control.
Mode | Gets or sets the layout mode. This is a dependency property.
NumLocked | Gets the state of the Num lock key.
PreventActivation | Gets or sets whether to prevent activation of parent window when users click on a keyboard's key.
RepeatDelay | Specifies the initial delay in milliseconds before the component starts repeating key-down events when AutoRepeat is enabled.
RepeatRate | Gets or sets the delay in milliseconds between consecutive key-down events synthesized in AutoRepeat mode.
ScrollLocked | Gets the state of the Scroll lock key.
ShiftLocked | Gets the state of the Shift key.
TemplateLayout | Gets or sets the keyboard's template layout. This is a dependency property.

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AltGrLocked Property

VirtualKeyboard.AltGrLocked Property
[image]

Gets the state of the AltGr key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool AltGrLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltGrLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AltLocked Property

VirtualKeyboard.AltLocked Property
[image]

Gets the state of the Alt key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool AltLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property AltLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AttachedWindow Property

VirtualKeyboard.AttachedWindow Property
[image]

Gets or sets the window handle of the parent window associated with this keyboard. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public IntPtr AttachedWindow { get; set; }

Visual Basic [image] Copy Code

Public Property AttachedWindow As IntPtr

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoFill Property

VirtualKeyboard.AutoFill Property
[image]

Gets or sets whether keyboard layout should be generated automatically depending on the language (e.g. qwerty, azerty, etc layouts). This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoFill { get; set; }

Visual Basic [image] Copy Code

Public Property AutoFill As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoReleaseModifierKeys Property

VirtualKeyboard.AutoReleaseModifierKeys Property
[image]

Gets or sets whether pressing a regular key automatically releases modifier keys such as shift, alt, control etc. (except CapsLock). This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoReleaseModifierKeys { get; set; }

Visual Basic [image] Copy Code

Public Property AutoReleaseModifierKeys As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.AutoRepeat Property

VirtualKeyboard.AutoRepeat Property
[image]

Gets or sets whether the component should synthesize keyboard events repeatedly when a virtual key is pressed down, until the key is released.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoRepeat { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRepeat As Boolean

Property Value

true to enable automatic repeat, or false otherwise. The default value is true.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace
RepeatDelay Property
RepeatRate Property


MindFusion.UI.Wpf.VirtualKeyboard.AutoUpdateCulture Property

VirtualKeyboard.AutoUpdateCulture Property
[image]

Gets or sets whether the component should change the UI thread's CurrentCulture whenever the input locale changes.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool AutoUpdateCulture { get; set; }

Visual Basic [image] Copy Code

Public Property AutoUpdateCulture As Boolean

Property Value

true to automatically update CurrentCulture to match InputLocale, or false otherwise. The default value is false.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.CapsLocked Property

VirtualKeyboard.CapsLocked Property
[image]

Gets the state of the Caps lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool CapsLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CapsLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.ControlLocked Property

VirtualKeyboard.ControlLocked Property
[image]

Gets the state of the Control key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ControlLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ControlLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.DefaultLayout Property

VirtualKeyboard.DefaultLayout Property
[image]

Obsolete; Gets or sets the default kayboard layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout DefaultLayout { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultLayout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.InputLocale Property

VirtualKeyboard.InputLocale Property
[image]

Gets or sets the current input language. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public CultureInfo InputLocale { get; set; }

Visual Basic [image] Copy Code

Public Property InputLocale As CultureInfo

Property Value

A CultureInfo specifying the current input language.

Remarks

This property determines the layout and character labels of virtual keys. Its value updates automatically when the Windows input locale changes.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace
AutoUpdateCulture Property


MindFusion.UI.Wpf.VirtualKeyboard.IsStandAlone Property

VirtualKeyboard.IsStandAlone Property
[image]

Gets or sets whether the keyboard's host application contains only the keyboard and sends input to external processes. This is a dependency property. Set this property to false if the keyboard will be sending input to other controls in same application. Set it to true if the application should behave as Windows On-screen Keyboard tool and send keypresses to active window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool IsStandAlone { get; set; }

Visual Basic [image] Copy Code

Public Property IsStandAlone As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.Layout Property

VirtualKeyboard.Layout Property
[image]

Gets the current keyboard layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout Layout { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.LayoutsFolder Property

VirtualKeyboard.LayoutsFolder Property
[image]

Gets or sets the folder where layout files are located. This is dependency property. Language layout files are automatically loaded from specified folder when Mode is set to Custom.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LayoutsFolder { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutsFolder As String

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.LicenseKey Property

VirtualKeyboard.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.Mode Property

VirtualKeyboard.Mode Property
[image]

Gets or sets the layout mode. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardMode Mode { get; set; }

Visual Basic [image] Copy Code

Public Property Mode As KeyboardMode

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.NumLocked Property

VirtualKeyboard.NumLocked Property
[image]

Gets the state of the Num lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool NumLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property NumLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.PreventActivation Property

VirtualKeyboard.PreventActivation Property
[image]

Gets or sets whether to prevent activation of parent window when users click on a keyboard's key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public bool PreventActivation { get; set; }

Visual Basic [image] Copy Code

Public Property PreventActivation As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.RepeatDelay Property

VirtualKeyboard.RepeatDelay Property
[image]

Specifies the initial delay in milliseconds before the component starts repeating key-down events when AutoRepeat is enabled.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int RepeatDelay { get; set; }

Visual Basic [image] Copy Code

Public Property RepeatDelay As Integer

Property Value

An integer value specifying initial delay in milliseconds. The default value is 500.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace
RepeatRate Property


MindFusion.UI.Wpf.VirtualKeyboard.RepeatRate Property

VirtualKeyboard.RepeatRate Property
[image]

Gets or sets the delay in milliseconds between consecutive key-down events synthesized in AutoRepeat mode.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public int RepeatRate { get; set; }

Visual Basic [image] Copy Code

Public Property RepeatRate As Integer

Property Value

An integer value specifying delay in milliseconds. The default value is 20.

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace
RepeatDelay Property


MindFusion.UI.Wpf.VirtualKeyboard.ScrollLocked Property

VirtualKeyboard.ScrollLocked Property
[image]

Gets the state of the Scroll lock key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ScrollLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ScrollLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.ShiftLocked Property

VirtualKeyboard.ShiftLocked Property
[image]

Gets the state of the Shift key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public static bool ShiftLocked { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ShiftLocked As Boolean

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.TemplateLayout Property

VirtualKeyboard.TemplateLayout Property
[image]

Gets or sets the keyboard's template layout. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public KeyboardLayout TemplateLayout { get; set; }

Visual Basic [image] Copy Code

Public Property TemplateLayout As KeyboardLayout

Property Value

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard Events

VirtualKeyboard Events
[image]

Public Events

Name | Description
KeyPressed | Raised when a key has been pressed.

See Also

VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyboard.KeyPressed Event

VirtualKeyboard.KeyPressed Event
[image]

Raised when a key has been pressed.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<VirtualKeyEventArgs> KeyPressed

Visual Basic [image] Copy Code

Public Event KeyPressed As EventHandler(Of VirtualKeyEventArgs)

See Also

VirtualKeyboard Members
VirtualKeyboard Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyEventArgs Class

VirtualKeyEventArgs Class
[image]

Contains data about KeyPressed events.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public class VirtualKeyEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class VirtualKeyEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.UI.Wpf.VirtualKeyEventArgs

See Also

VirtualKeyEventArgs Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyEventArgs Members

VirtualKeyEventArgs Members
Constructors Properties
[image]

Contains data about KeyPressed events.

The following tables list the members exposed by the VirtualKeyEventArgs type.

Public Constructors

Name | Description
VirtualKeyEventArgs | Initializes a new instance of the VirtualKeyEventArgs class.

Public Properties

Name | Description
Key | Gets an instance of a Key-derived class that identifies the pressed key.

See Also

VirtualKeyEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyEventArgs Constructor

VirtualKeyEventArgs Constructor
[image]

Initializes a new instance of the VirtualKeyEventArgs class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public VirtualKeyEventArgs (
Key key
)

Visual Basic [image] Copy Code

Public New ( _
key As Key _
)

Parameters

key

MindFusion.UI.Wpf.Key

See Also

VirtualKeyEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyEventArgs Properties

VirtualKeyEventArgs Properties
[image]

Public Properties

Name | Description
Key | Gets an instance of a Key-derived class that identifies the pressed key.

See Also

VirtualKeyEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VirtualKeyEventArgs.Key Property

VirtualKeyEventArgs.Key Property
[image]

Gets an instance of a Key-derived class that identifies the pressed key.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Keyboard.Wpf

Syntax

C# [image] Copy Code

public Key Key { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Key As Key

Property Value

See Also

VirtualKeyEventArgs Members
VirtualKeyEventArgs Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Class

VisualTreeView Class
Remarks See Also
[image]

Visualizes the visual tree structure of an arbitrary DependencyObject in a TreeView control and allows navigation through the tree.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public class VisualTreeView : Control

Visual Basic [image] Copy Code

Public Class VisualTreeView
Inherits Control

Remarks

The VisualTreeView is used to display the visual structure of an arbitrary DependencyObject in a more presentable manner - as a TreeView. Each element in the visual hierarchy is presented as a TreeViewItem, the visual children of an element are presented as TreeViewItem children and so on. Selecting an item in the TreeView optionally displays an overlay border on top of the corresponding visual element. In order to enable this functionality you have to supply a Grid or Canvas panel containing (or positioned over) the selected object to the CommonParent property.

Example

The following XAML example demonstrates how to use of the VisualTreeView to inspect a DateTimePicker object.

XAML [image] Copy Code

<Window x:Class="WpfApplication.Window1"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:ui="clr-namespace:MindFusion.UI.Wpf;assembly=MindFusion.UI.Wpf"
Title="VisualTreeView Test" Height="394" Width="685">
<Grid x:Name="Container">
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition />
</Grid.RowDefinitions>
<ui:DateTimePicker Name="picker" Width="179" Height="24" Margin="10" />
<ui:VisualTreeView Margin="10" Grid.Row="1" SelectedObject="{Binding ElementName=picker}" BorderBrush="Gray" BorderThickness="1" CommonParent="{Binding ElementName=Container}" OverlayBackground="#80FF0000" OverlayBorderBrush="Red" OverlayBorderThickness="1" />
</Grid>
</Window>

Selecting an item in the VisualTreeView will place a red overlay on top of the corresponding visual element.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.VisualTreeView

See Also

VisualTreeView Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Members

VisualTreeView Members
Constructors Fields Properties Methods
[image]

Visualizes the visual tree structure of an arbitrary DependencyObject in a TreeView control and allows navigation through the tree.

The following tables list the members exposed by the VisualTreeView type.

Public Constructors

Name | Description
VisualTreeView | Initializes a new instance of the VisualTreeView class.

Public Fields

Name | Description
CommonParentProperty | Identifies the CommonParent dependency property.
OverlayBackgroundProperty | Identifies the OverlayBackground dependency property.
OverlayBorderBrushProperty | Identifies the OverlayBorderBrush dependency property.
OverlayBorderThicknessProperty | Identifies the OverlayBorderThickness dependency property.
SelectedObjectProperty | Identifies the SelectedObject dependency property.
ShowInfoProperty | Identifies the ShowInfo dependency property.

Public Properties

Name | Description
CommonParent | Gets or sets a panel containing the SelectedObject. This element will be used as a parent of the overlay element. This is a dependency property.
OverlayBackground | Gets or sets the background brush of the overlay element. This is a dependency property.
OverlayBorderBrush | Gets or sets the border brush of the overlay element. This is a dependency property.
OverlayBorderThickness | Gets or sets the border thickness of the overlay element. This is a dependency property.
SelectedObject | Gets or sets the DependencyObject selected in the view. This is a dependency property.
ShowInfo | Gets or sets a value indicating whether to display the property info panel. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.

See Also

VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Fields

VisualTreeView Fields
[image]

Public Fields

Name | Description
CommonParentProperty | Identifies the CommonParent dependency property.
OverlayBackgroundProperty | Identifies the OverlayBackground dependency property.
OverlayBorderBrushProperty | Identifies the OverlayBorderBrush dependency property.
OverlayBorderThicknessProperty | Identifies the OverlayBorderThickness dependency property.
SelectedObjectProperty | Identifies the SelectedObject dependency property.
ShowInfoProperty | Identifies the ShowInfo dependency property.

See Also

VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.CommonParentProperty Field

VisualTreeView.CommonParentProperty Field
[image]

Identifies the CommonParent dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CommonParentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CommonParentProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OverlayBackgroundProperty Field

VisualTreeView.OverlayBackgroundProperty Field
[image]

Identifies the OverlayBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverlayBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverlayBackgroundProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OverlayBorderBrushProperty Field

VisualTreeView.OverlayBorderBrushProperty Field
[image]

Identifies the OverlayBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverlayBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverlayBorderBrushProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OverlayBorderThicknessProperty Field

VisualTreeView.OverlayBorderThicknessProperty Field
[image]

Identifies the OverlayBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OverlayBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OverlayBorderThicknessProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.SelectedObjectProperty Field

VisualTreeView.SelectedObjectProperty Field
[image]

Identifies the SelectedObject dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedObjectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedObjectProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.ShowInfoProperty Field

VisualTreeView.ShowInfoProperty Field
[image]

Identifies the ShowInfo dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowInfoProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowInfoProperty As DependencyProperty

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Constructor

VisualTreeView Constructor
[image]

Initializes a new instance of the VisualTreeView class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public VisualTreeView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Methods

VisualTreeView Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnKeyDown | UIElement.OnKeyDown override.

See Also

VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OnApplyTemplate Method

VisualTreeView.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OnKeyDown Method

VisualTreeView.OnKeyDown Method
[image]

UIElement.OnKeyDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnKeyDown (
KeyEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnKeyDown( _
e As KeyEventArgs _
)

Parameters

e
The System.Windows.Input.KeyEventArgs that contains the event data.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView Properties

VisualTreeView Properties
[image]

Public Properties

Name | Description
CommonParent | Gets or sets a panel containing the SelectedObject. This element will be used as a parent of the overlay element. This is a dependency property.
OverlayBackground | Gets or sets the background brush of the overlay element. This is a dependency property.
OverlayBorderBrush | Gets or sets the border brush of the overlay element. This is a dependency property.
OverlayBorderThickness | Gets or sets the border thickness of the overlay element. This is a dependency property.
SelectedObject | Gets or sets the DependencyObject selected in the view. This is a dependency property.
ShowInfo | Gets or sets a value indicating whether to display the property info panel. This is a dependency property.

See Also

VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.CommonParent Property

VisualTreeView.CommonParent Property
[image]

Gets or sets a panel containing the SelectedObject. This element will be used as a parent of the overlay element. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Panel CommonParent { get; set; }

Visual Basic [image] Copy Code

Public Property CommonParent As Panel

Property Value

A WPF Panel object.

Remarks

If this property is not set, the overlay will not be displayed. If the panel is not a Grid or a Canvas, the overlay is not guaranteed to properly appear over the selected element's visual.

The overlay is a semi-transparent border positioned on top of the element corresponding to the selected item in the VisualTreeView.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.OverlayBackground Property

VisualTreeView.OverlayBackground Property
[image]

Gets or sets the background brush of the overlay element. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush OverlayBackground { get; set; }

Visual Basic [image] Copy Code

Public Property OverlayBackground As Brush

Property Value

A WPF Brush object.

Remarks

The overlay is a semi-transparent border positioned on top of the element corresponding to the selected item in the VisualTreeView.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace
OverlayBorderBrush Property
OverlayBorderThickness Property


MindFusion.UI.Wpf.VisualTreeView.OverlayBorderBrush Property

VisualTreeView.OverlayBorderBrush Property
[image]

Gets or sets the border brush of the overlay element. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Brush OverlayBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property OverlayBorderBrush As Brush

Property Value

A WPF Brush object.

Remarks

The overlay is a semi-transparent border positioned on top of the element corresponding to the selected item in the VisualTreeView.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace
OverlayBackground Property
OverlayBorderThickness Property


MindFusion.UI.Wpf.VisualTreeView.OverlayBorderThickness Property

VisualTreeView.OverlayBorderThickness Property
[image]

Gets or sets the border thickness of the overlay element. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public Thickness OverlayBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property OverlayBorderThickness As Thickness

Property Value

A WPF Thickness object.

Remarks

The overlay is a semi-transparent border positioned on top of the element corresponding to the selected item in the VisualTreeView.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.SelectedObject Property

VisualTreeView.SelectedObject Property
[image]

Gets or sets the DependencyObject selected in the view. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public DependencyObject SelectedObject { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedObject As DependencyObject

Property Value

A WPF DependencyObject instance.

Remarks

This property specifies the DependencyObject whose visual structure should be displayed in the VisualTreeView.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.VisualTreeView.ShowInfo Property

VisualTreeView.ShowInfo Property
[image]

Gets or sets a value indicating whether to display the property info panel. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public bool ShowInfo { get; set; }

Visual Basic [image] Copy Code

Public Property ShowInfo As Boolean

Property Value

true to display the values of all dependency properties of the selected element in the tree; otherwise, false.

See Also

VisualTreeView Members
VisualTreeView Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WeekHeaderAlignment Enumeration

WeekHeaderAlignment Enumeration
[image]

Specifies the alignment of the week numbers header in a Calendar control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.UI.Wpf

Syntax

C# [image] Copy Code

public enum WeekHeaderAlignment

Visual Basic [image] Copy Code

Public Enum WeekHeaderAlignment

Members

Member name | Description
Left | Indicates that the header is displayed on the left side.
Right | Indicates that the header is displayed on the right side.

Remarks

Values from this enumeration can be assigned to the WeekHeaderAlignment property of the Calendar class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Class

Window Class
Remarks See Also
[image]

Represents a window with title and contents, which can be moved, resized and arranged interactively.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class Window : ContentControl, IComparable<Window>

Visual Basic [image] Copy Code

Public Class Window
Inherits ContentControl
Implements IComparable(Of Window)

Remarks

The Window class can be used is usually use in conjunction with the WindowHost class. The WindowHost class acts as a container of Window objects and enables the interactive functionality of the windows -moving, resizing and so on.

To add a Window to a host, either add it to its Windows collection or call the Show or ShowDialog methods of the Window passing the host as an argument. Since the Windows property is declared as the ContentProperty of the WindowHost, windows can be added to a WindowHost directly in XAML.

Example

The Window class can be used is usually use in conjunction with the WindowHost class. The WindowHost class acts as a container of Window objects and enables the interactive functionality of the windows -moving, resizing and so on.

To add a Window to a host, either add it to its Windows collection or call the Show or ShowDialog methods of the Window passing the host as an argument. Since the Windows property is declared as the ContentProperty of the WindowHost, windows can be added to a WindowHost directly in XAML.

The following code illustrates a WindowHost with a single Window defined in XAML:

XAML [image] Copy Code

<Window x:Class="WpfApplication.Window2"
xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
xmlns:ui="clr-namespace:MindFusion.UI.Wpf;assembly=MindFusion.UI.Wpf"
Title="Window2" Height="394" Width="685">
<Grid>
<ui:WindowHost Name="host" Background="#F0F0FF">
<ui:Window Width="300" Height="200" Header="This is a test window" IsActive="True" Left="100" Top="50" Foreground="White">
<Grid Margin="5">
<Grid.RowDefinitions>
<RowDefinition />
<RowDefinition Height="Auto" MinHeight="30" />
</Grid.RowDefinitions>
<StackPanel Grid.Row="1" Orientation="Horizontal" Margin="5" HorizontalAlignment="Center">
<Button Width="80">OK</Button>
<Button Width="80">Cancel</Button>
</StackPanel>
<Label Margin="20,35,0,0" Width="74" Height="25" HorizontalAlignment="Left" VerticalAlignment="Top">Enter name:</Label>
<TextBox Margin="100,37,25,0" Name="textBox1" Height="22" VerticalAlignment="Top" />
</Grid>
</ui:Window>
</ui:WindowHost>
</Grid>
</Window>

The code above yields results similar to the following picture:

To adjust the position or size of the window programmatically, use the Left, Top, Width and Height properties respectively. To minimize or maximize the window use its WindowState property.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.UI.Wpf.Window
MindFusion.UI.Wpf.DockItem

See Also

Window Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Members

Window Members
Constructors Fields Properties Methods Events
[image]

Represents a window with title and contents, which can be moved, resized and arranged interactively.

The following tables list the members exposed by the Window type.

Public Constructors

Name | Description
Window | Initializes a new instance of the Window class.

Public Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
CanCloseProperty | Identifies the CanClose dependency property.
CanMoveProperty | Identifies the CanMove dependency property.
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentCornerRadiusProperty | Identifies the ContentCornerRadius dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IconProperty | Identifies the Icon dependency property.
InactiveBackgroundProperty | Identifies the InactiveBackground dependency property.
InactiveBorderBrushProperty | Identifies the InactiveBorderBrush dependency property.
IsActiveProperty | Identifies the IsActive dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
KeepInsideHostProperty | Identifies the KeepInsideHost dependency property.
MinimizedHeightProperty | Identifies the MinimizedHeight dependency property.
MinimizedWidthProperty | Identifies the MinimizedWidth dependency property.
MinimizeModeProperty | Identifies the MinimizeMode dependency property.
ResizeModeProperty | Identifies the ResizeMode dependency property.
StartupLocationProperty | Identifies the StartupLocation dependency property.
WindowStateProperty | Identifies the WindowState dependency property.

Public Properties

Name | Description
AnimationDuration | Gets or sets the duration of the window's animations, expressed in milliseconds. This is a dependency property.
ButtonBackground | Gets or sets the background of the buttons in the window. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons in the window. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the window. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons in the window when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons in the window when they are pressed. This is a dependency property.
CanClose | Gets or sets a value indicating whether the window will display a 'Close' button in its title bar. This is a dependency property.
CanMove | Gets or sets a value indicating whether the window can be moved interactively. This is a dependency property.
ContentBackground | Gets or sets the background of the window's content. This is a dependency property.
ContentCornerRadius | Gets or sets the corner radius of the border around the window's content. This is a dependency property.
ContentMargin | Gets or sets the margin of the window's content. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the window's border. This is a dependency property.
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderHeight | Gets or sets the height of the window's header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the window's header. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
Icon | Gets or sets the icon displayed in the window's title bar. This is a dependency property.
InactiveBackground | Gets or sets background brush of the window when it is not active. This is a dependency property.
InactiveBorderBrush | Gets or sets the border brush of the window when it is not active. This is a dependency property.
IsActive | Gets or sets a value indicating whether the window is active. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the window is animated. This is a dependency property.
KeepInsideHost | Gets or sets a value indicating whether the window can be interactively dragged outside of its containing WindowHost boundaries. This is a dependency property.
Left | Gets or sets the left side of the window within its container.
MinimizedHeight | Gets or sets the height of the window when it is minimized. This is a dependency property.
MinimizedWidth | Gets or sets the width of the window when it is minimized. This is a dependency property.
MinimizeMode | Gets or sets the behavior of this window when it is minimized. This is a dependency property.
ResizeMode | Gets or sets a value indicating the allowed user interactions on this window. This is a dependency property.
StartupLocation | Gets or sets the initial location of the window relative to its host. This is a dependency property.
Top | Gets or sets the top side of the window within its container.
WindowState | Gets or sets the current state of the window. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
Show | Adds the window to the specified host.
ShowDialog | Displays the window within the specified host as a modal dialog.

Protected Methods

Name | Description
OnClosed | Raises the Closed event.
OnClosing | Raises the Closing event.
OnGotFocus | Control.OnGotFocus override.
OnLostFocus | UIElement.OnLostFocus override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.

Public Events

Name | Description
Closed | Raised when a window is closed.
Closing | Raised before the window is closed in order to confirm the operation.

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Fields

Window Fields
[image]

Public Fields

Name | Description
AnimationDurationProperty | Identifies the AnimationDuration dependency property.
ButtonBackgroundProperty | Identifies the ButtonBackground dependency property.
ButtonBorderBrushProperty | Identifies the ButtonBorderBrush dependency property.
ButtonBorderThicknessProperty | Identifies the ButtonBorderThickness dependency property.
ButtonOverBackgroundProperty | Identifies the ButtonOverBackground dependency property.
ButtonPressedBackgroundProperty | Identifies the ButtonPressedBackground dependency property.
CanCloseProperty | Identifies the CanClose dependency property.
CanMoveProperty | Identifies the CanMove dependency property.
ContentBackgroundProperty | Identifies the ContentBackground dependency property.
ContentCornerRadiusProperty | Identifies the ContentCornerRadius dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderMarginProperty | Identifies the HeaderMargin dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
IconProperty | Identifies the Icon dependency property.
InactiveBackgroundProperty | Identifies the InactiveBackground dependency property.
InactiveBorderBrushProperty | Identifies the InactiveBorderBrush dependency property.
IsActiveProperty | Identifies the IsActive dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
KeepInsideHostProperty | Identifies the KeepInsideHost dependency property.
MinimizedHeightProperty | Identifies the MinimizedHeight dependency property.
MinimizedWidthProperty | Identifies the MinimizedWidth dependency property.
MinimizeModeProperty | Identifies the MinimizeMode dependency property.
ResizeModeProperty | Identifies the ResizeMode dependency property.
StartupLocationProperty | Identifies the StartupLocation dependency property.
WindowStateProperty | Identifies the WindowState dependency property.

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.AnimationDurationProperty Field

Window.AnimationDurationProperty Field
[image]

Identifies the AnimationDuration dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnimationDurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnimationDurationProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBackgroundProperty Field

Window.ButtonBackgroundProperty Field
[image]

Identifies the ButtonBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBackgroundProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBorderBrushProperty Field

Window.ButtonBorderBrushProperty Field
[image]

Identifies the ButtonBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderBrushProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBorderThicknessProperty Field

Window.ButtonBorderThicknessProperty Field
[image]

Identifies the ButtonBorderThickness dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonBorderThicknessProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonOverBackgroundProperty Field

Window.ButtonOverBackgroundProperty Field
[image]

Identifies the ButtonOverBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonOverBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonOverBackgroundProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonPressedBackgroundProperty Field

Window.ButtonPressedBackgroundProperty Field
[image]

Identifies the ButtonPressedBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ButtonPressedBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ButtonPressedBackgroundProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.CanCloseProperty Field

Window.CanCloseProperty Field
[image]

Identifies the CanClose dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanCloseProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanCloseProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.CanMoveProperty Field

Window.CanMoveProperty Field
[image]

Identifies the CanMove dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CanMoveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CanMoveProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ContentBackgroundProperty Field

Window.ContentBackgroundProperty Field
[image]

Identifies the ContentBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentBackgroundProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ContentCornerRadiusProperty Field

Window.ContentCornerRadiusProperty Field
[image]

Identifies the ContentCornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentCornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentCornerRadiusProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ContentMarginProperty Field

Window.ContentMarginProperty Field
[image]

Identifies the ContentMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ContentMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ContentMarginProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.CornerRadiusProperty Field

Window.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderHeightProperty Field

Window.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderMarginProperty Field

Window.HeaderMarginProperty Field
[image]

Identifies the HeaderMargin dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderMarginProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderProperty Field

Window.HeaderProperty Field
[image]

Identifies the Header dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderTemplateProperty Field

Window.HeaderTemplateProperty Field
[image]

Identifies the HeaderTemplate dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTemplateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.IconProperty Field

Window.IconProperty Field
[image]

Identifies the Icon dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IconProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IconProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.InactiveBackgroundProperty Field

Window.InactiveBackgroundProperty Field
[image]

Identifies the InactiveBackground dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InactiveBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InactiveBackgroundProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.InactiveBorderBrushProperty Field

Window.InactiveBorderBrushProperty Field
[image]

Identifies the InactiveBorderBrush dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InactiveBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InactiveBorderBrushProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.IsActiveProperty Field

Window.IsActiveProperty Field
[image]

Identifies the IsActive dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsActiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsActiveProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.IsAnimatedProperty Field

Window.IsAnimatedProperty Field
[image]

Identifies the IsAnimated dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAnimatedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsAnimatedProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.KeepInsideHostProperty Field

Window.KeepInsideHostProperty Field
[image]

Identifies the KeepInsideHost dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty KeepInsideHostProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly KeepInsideHostProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.MinimizedHeightProperty Field

Window.MinimizedHeightProperty Field
[image]

Identifies the MinimizedHeight dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimizedHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimizedHeightProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.MinimizedWidthProperty Field

Window.MinimizedWidthProperty Field
[image]

Identifies the MinimizedWidth dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimizedWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimizedWidthProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.MinimizeModeProperty Field

Window.MinimizeModeProperty Field
[image]

Identifies the MinimizeMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinimizeModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimizeModeProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ResizeModeProperty Field

Window.ResizeModeProperty Field
[image]

Identifies the ResizeMode dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeModeProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.StartupLocationProperty Field

Window.StartupLocationProperty Field
[image]

Identifies the StartupLocation dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartupLocationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartupLocationProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.WindowStateProperty Field

Window.WindowStateProperty Field
[image]

Identifies the WindowState dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WindowStateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WindowStateProperty As DependencyProperty

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Constructor

Window Constructor
[image]

Initializes a new instance of the Window class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Window ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Methods

Window Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
Show | Adds the window to the specified host.
ShowDialog | Displays the window within the specified host as a modal dialog.

Protected Methods

Name | Description
OnClosed | Raises the Closed event.
OnClosing | Raises the Closing event.
OnGotFocus | Control.OnGotFocus override.
OnLostFocus | UIElement.OnLostFocus override.
OnMouseDoubleClick | Control.OnMouseDoubleClick override.
OnMouseLeftButtonDown | UIElement.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | UIElement.OnMouseLeftButtonUp override.
OnMouseMove | UIElement.OnMouseMove override.

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnApplyTemplate Method

Window.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnClosed Method

Window.OnClosed Method
[image]

Raises the Closed event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClosed (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClosed( _
e As EventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnClosing Method

Window.OnClosing Method
[image]

Raises the Closing event.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnClosing (
ConfirmEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClosing ( _
e As ConfirmEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnGotFocus Method

Window.OnGotFocus Method
[image]

Control.OnGotFocus override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnGotFocus (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnGotFocus( _
e As RoutedEventArgs _
)

Parameters

e
A RoutedEventArgs that contains event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnLostFocus Method

Window.OnLostFocus Method
[image]

UIElement.OnLostFocus override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnLostFocus (
RoutedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnLostFocus( _
e As RoutedEventArgs _
)

Parameters

e
A RoutedEventArgs that contains event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnMouseDoubleClick Method

Window.OnMouseDoubleClick Method
[image]

Control.OnMouseDoubleClick override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseDoubleClick (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDoubleClick( _
e As MouseButtonEventArgs _
)

Parameters

e

The event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnMouseLeftButtonDown Method

Window.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseLeftButtonDown override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnMouseLeftButtonUp Method

Window.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseLeftButtonUp override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e
The MouseButtonEventArgs that contains the event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.OnMouseMove Method

Window.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e
The MouseEventArgs that contains the event data.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Show Method

Window.Show Method
[image]

Adds the window to the specified host.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public void Show (
WindowHost host
)

Visual Basic [image] Copy Code

Public Sub Show ( _
host As WindowHost _
)

Parameters

host
The WindowHost to add this window to.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ShowDialog Method

Window.ShowDialog Method
[image]

Displays the window within the specified host as a modal dialog.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public void ShowDialog (
WindowHost host
)

Visual Basic [image] Copy Code

Public Sub ShowDialog ( _
host As WindowHost _
)

Parameters

host
The WindowHost to add this window to.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Properties

Window Properties
[image]

Public Properties

Name | Description
AnimationDuration | Gets or sets the duration of the window's animations, expressed in milliseconds. This is a dependency property.
ButtonBackground | Gets or sets the background of the buttons in the window. This is a dependency property.
ButtonBorderBrush | Gets or sets the border brush of the buttons in the window. This is a dependency property.
ButtonBorderThickness | Gets or sets the border thickness of the buttons in the window. This is a dependency property.
ButtonOverBackground | Gets or sets the background of the buttons in the window when they are pointed with the mouse. This is a dependency property.
ButtonPressedBackground | Gets or sets the background of the buttons in the window when they are pressed. This is a dependency property.
CanClose | Gets or sets a value indicating whether the window will display a 'Close' button in its title bar. This is a dependency property.
CanMove | Gets or sets a value indicating whether the window can be moved interactively. This is a dependency property.
ContentBackground | Gets or sets the background of the window's content. This is a dependency property.
ContentCornerRadius | Gets or sets the corner radius of the border around the window's content. This is a dependency property.
ContentMargin | Gets or sets the margin of the window's content. This is a dependency property.
CornerRadius | Gets or sets the corner radius of the window's border. This is a dependency property.
Header | Gets or sets the content of the window title bar. This is a dependency property.
HeaderHeight | Gets or sets the height of the window's header. This is a dependency property.
HeaderMargin | Gets or sets the margin of the window's header. This is a dependency property.
HeaderTemplate | Gets or sets the template used to display the content of the window's title. This is a dependency property.
Icon | Gets or sets the icon displayed in the window's title bar. This is a dependency property.
InactiveBackground | Gets or sets background brush of the window when it is not active. This is a dependency property.
InactiveBorderBrush | Gets or sets the border brush of the window when it is not active. This is a dependency property.
IsActive | Gets or sets a value indicating whether the window is active. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the window is animated. This is a dependency property.
KeepInsideHost | Gets or sets a value indicating whether the window can be interactively dragged outside of its containing WindowHost boundaries. This is a dependency property.
Left | Gets or sets the left side of the window within its container.
MinimizedHeight | Gets or sets the height of the window when it is minimized. This is a dependency property.
MinimizedWidth | Gets or sets the width of the window when it is minimized. This is a dependency property.
MinimizeMode | Gets or sets the behavior of this window when it is minimized. This is a dependency property.
ResizeMode | Gets or sets a value indicating the allowed user interactions on this window. This is a dependency property.
StartupLocation | Gets or sets the initial location of the window relative to its host. This is a dependency property.
Top | Gets or sets the top side of the window within its container.
WindowState | Gets or sets the current state of the window. This is a dependency property.

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.AnimationDuration Property

Window.AnimationDuration Property
[image]

Gets or sets the duration of the window's animations, expressed in milliseconds. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double AnimationDuration { get; set; }

Visual Basic [image] Copy Code

Public Property AnimationDuration As Double

Property Value

A double value specifying the duration.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBackground Property

Window.ButtonBackground Property
[image]

Gets or sets the background of the buttons in the window. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBackground As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBorderBrush Property

Window.ButtonBorderBrush Property
[image]

Gets or sets the border brush of the buttons in the window. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonBorderThickness Property

Window.ButtonBorderThickness Property
[image]

Gets or sets the border thickness of the buttons in the window. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness ButtonBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonBorderThickness As Thickness

Property Value

A WPF Thickness object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonOverBackground Property

Window.ButtonOverBackground Property
[image]

Gets or sets the background of the buttons in the window when they are pointed with the mouse. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonOverBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonOverBackground As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ButtonPressedBackground Property

Window.ButtonPressedBackground Property
[image]

Gets or sets the background of the buttons in the window when they are pressed. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ButtonPressedBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ButtonPressedBackground As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.CanClose Property

Window.CanClose Property
[image]

Gets or sets a value indicating whether the window will display a 'Close' button in its title bar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool CanClose { get; set; }

Visual Basic [image] Copy Code

Public Property CanClose As Boolean

Property Value

true to display the 'Close' button; otherwise, false.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
CanMove Property


MindFusion.UI.Wpf.Window.CanMove Property

Window.CanMove Property
[image]

Gets or sets a value indicating whether the window can be moved interactively. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool CanMove { get; set; }

Visual Basic [image] Copy Code

Public Property CanMove As Boolean

Property Value

true to allow the users to move the window interactively; otherwise, false.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
CanClose property


MindFusion.UI.Wpf.Window.ContentBackground Property

Window.ContentBackground Property
[image]

Gets or sets the background of the window's content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush ContentBackground { get; set; }

Visual Basic [image] Copy Code

Public Property ContentBackground As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ContentCornerRadius Property

Window.ContentCornerRadius Property
[image]

Gets or sets the corner radius of the border around the window's content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public CornerRadius ContentCornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property ContentCornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ContentMargin Property

Window.ContentMargin Property
[image]

Gets or sets the margin of the window's content. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness ContentMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ContentMargin As Thickness

Property Value

A WPF Thickness object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.CornerRadius Property

Window.CornerRadius Property
[image]

Gets or sets the corner radius of the window's border. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

A WPF CornerRadius object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Header Property

Window.Header Property
[image]

Gets or sets the content of the window title bar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Object Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Object

Property Value

Any .NET object.

Remarks

The DataTemplate specified by HeaderTemplate is used to display this object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderHeight Property

Window.HeaderHeight Property
[image]

Gets or sets the height of the window's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Double

Property Value

A double value specifying the height of the window's title, in device independent units.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderMargin Property

Window.HeaderMargin Property
[image]

Gets or sets the margin of the window's header. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Thickness HeaderMargin { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderMargin As Thickness

Property Value

A WPF Thickness object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.HeaderTemplate Property

Window.HeaderTemplate Property
[image]

Gets or sets the template used to display the content of the window's title. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public DataTemplate HeaderTemplate { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderTemplate As DataTemplate

Property Value

A WPF DataTemplate object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Icon Property

Window.Icon Property
[image]

Gets or sets the icon displayed in the window's title bar. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ImageSource Icon { get; set; }

Visual Basic [image] Copy Code

Public Property Icon As ImageSource

Property Value

A WPF ImageSource object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.InactiveBackground Property

Window.InactiveBackground Property
[image]

Gets or sets background brush of the window when it is not active. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush InactiveBackground { get; set; }

Visual Basic [image] Copy Code

Public Property InactiveBackground As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
ActiveBackground Property
EffectiveBackground Property
IsActive Property


MindFusion.UI.Wpf.Window.InactiveBorderBrush Property

Window.InactiveBorderBrush Property
[image]

Gets or sets the border brush of the window when it is not active. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush InactiveBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property InactiveBorderBrush As Brush

Property Value

A WPF Brush object.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
ActiveBorderBrush Property
EffectiveBorderBrush Property
IsActive Property


MindFusion.UI.Wpf.Window.IsActive Property

Window.IsActive Property
[image]

Gets or sets a value indicating whether the window is active. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool IsActive { get; set; }

Visual Basic [image] Copy Code

Public Property IsActive As Boolean

Property Value

true if the window is active; otherwise, false.

Remarks

When a window is activated, it is displayed on top of all other windows in its current WindowHost parent and its EffectiveBackground and EffectiveBorderBrush properties are updated accordingly.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
EffectiveBackground Property
EffectiveBorderBrush Property


MindFusion.UI.Wpf.Window.IsAnimated Property

Window.IsAnimated Property
[image]

Gets or sets a value indicating whether the window is animated. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool IsAnimated { get; set; }

Visual Basic [image] Copy Code

Public Property IsAnimated As Boolean

Property Value

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.KeepInsideHost Property

Window.KeepInsideHost Property
[image]

Gets or sets a value indicating whether the window can be interactively dragged outside of its containing WindowHost boundaries. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool KeepInsideHost { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideHost As Boolean

Property Value

true to prevent the users from dragging the window outside of its parent WindowHost; false to allow it.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Left Property

Window.Left Property
[image]

Gets or sets the left side of the window within its container.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Double

Property Value

A double value specifying the x-coordinate of the window's top-left corner, relative to its container.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
Top Property


MindFusion.UI.Wpf.Window.MinimizedHeight Property

Window.MinimizedHeight Property
[image]

Gets or sets the height of the window when it is minimized. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double MinimizedHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizedHeight As Double

Property Value

A double value specifying the height of the minimized window, in device independent units.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
MinimizedWidth Property


MindFusion.UI.Wpf.Window.MinimizedWidth Property

Window.MinimizedWidth Property
[image]

Gets or sets the width of the window when it is minimized. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double MinimizedWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizedWidth As Double

Property Value

A double value specifying the width of the minimized window, in device independent units.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
MinimizedHeight Property


MindFusion.UI.Wpf.Window.MinimizeMode Property

Window.MinimizeMode Property
[image]

Gets or sets the behavior of this window when it is minimized. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public MinimizeMode MinimizeMode { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeMode As MinimizeMode

Property Value

A member of the MinimizeMode enumeration.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.ResizeMode Property

Window.ResizeMode Property
[image]

Gets or sets a value indicating the allowed user interactions on this window. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ResizeMode ResizeMode { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeMode As ResizeMode

Property Value

A member of the ResizeMode enumeration.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.StartupLocation Property

Window.StartupLocation Property
[image]

Gets or sets the initial location of the window relative to its host. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public WindowStartupLocation StartupLocation { get; set; }

Visual Basic [image] Copy Code

Public Property StartupLocation As WindowStartupLocation

Property Value

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window.Top Property

Window.Top Property
[image]

Gets or sets the top side of the window within its container.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Double

Property Value

A double value specifying the y-coordinate of the window's top-left corner, relative to its container.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace
Left Property


MindFusion.UI.Wpf.Window.WindowState Property

Window.WindowState Property
[image]

Gets or sets the current state of the window. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public WindowState WindowState { get; set; }

Visual Basic [image] Copy Code

Public Property WindowState As WindowState

Property Value

A member of the WindowState enumeration.

See Also

Window Members
Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.Window Events

Window Events
[image]

Public Events

Name | Description
Closed | Raised when a window is closed.
Closing | Raised before the window is closed in order to confirm the operation.

See Also

Window Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Class

WindowHost Class
Remarks See Also
[image]

Represents a container for Window objects.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class WindowHost : Control

Visual Basic [image] Copy Code

Public Class WindowHost
Inherits Control

Remarks

The WindowHost is a special control which acts as a container of Window objects and enables interactive operations on the windows such as resizing and minimizing.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.WindowHost

See Also

WindowHost Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Members

WindowHost Members
Constructors Fields Properties Methods
[image]

Represents a container for Window objects.

The following tables list the members exposed by the WindowHost type.

Public Constructors

Name | Description
WindowHost | Initializes a new WindowHost class.

Public Fields

Name | Description
ClipContentProperty | Identifies the ClipContent dependency property.
WindowsProperty | Identifies the Windows dependency property.

Public Properties

Name | Description
ClipContent | Gets or sets a value indicating whether the contents of the host is clipped when outside of the host's bounds. This is a dependency property.
Windows | Gets or sets a collection with the windows contained in the host. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Fields

WindowHost Fields
[image]

Public Fields

Name | Description
ClipContentProperty | Identifies the ClipContent dependency property.
WindowsProperty | Identifies the Windows dependency property.

See Also

WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost.ClipContentProperty Field

WindowHost.ClipContentProperty Field
[image]

Identifies the ClipContent dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipContentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipContentProperty As DependencyProperty

See Also

WindowHost Members
WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost.WindowsProperty Field

WindowHost.WindowsProperty Field
[image]

Identifies the Windows dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WindowsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WindowsProperty As DependencyProperty

See Also

WindowHost Members
WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Constructor

WindowHost Constructor
[image]

Initializes a new WindowHost class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public WindowHost ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Methods

WindowHost Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost.OnApplyTemplate Method

WindowHost.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

WindowHost Members
WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost Properties

WindowHost Properties
[image]

Public Properties

Name | Description
ClipContent | Gets or sets a value indicating whether the contents of the host is clipped when outside of the host's bounds. This is a dependency property.
Windows | Gets or sets a collection with the windows contained in the host. This is a dependency property.

See Also

WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost.ClipContent Property

WindowHost.ClipContent Property
[image]

Gets or sets a value indicating whether the contents of the host is clipped when outside of the host's bounds. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool ClipContent { get; set; }

Visual Basic [image] Copy Code

Public Property ClipContent As Boolean

Property Value

true to clip the contents; otherwise, false.

See Also

WindowHost Members
WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowHost.Windows Property

WindowHost.Windows Property
[image]

Gets or sets a collection with the windows contained in the host. This is a dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ObservableCollection<Window> Windows { get; set; }

Visual Basic [image] Copy Code

Public Property Windows As ObservableCollection(Of Window)

Property Value

An observable collection of Window objects representing the windows contained in the host.

See Also

WindowHost Members
WindowHost Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.WindowState Enumeration

WindowState Enumeration
[image]

Specifies the state of a Window.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public enum WindowState

Visual Basic [image] Copy Code

Public Enum WindowState

Members

Member name | Description
Maximized | Indicates that the window is maximized.
Minimized | Indicates that the window is minimized.
Normal | Indicates that the window is neither minimized nor maximized.

Remarks

Values from this enumeration are assigned to the WindowState property of the Window class.

See Also

MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Class

ZoomButton Class
[image]

The button used in ZoomControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ZoomButton : Button

Visual Basic [image] Copy Code

Public Class ZoomButton
Inherits Button

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.Primitives.ButtonBase
System.Windows.Controls.Button
MindFusion.UI.Wpf.ZoomButton

See Also

ZoomButton Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Members

ZoomButton Members
Constructors Fields Properties Methods
[image]

The button used in ZoomControl.

The following tables list the members exposed by the ZoomButton type.

Public Constructors

Name | Description
ZoomButton | Initializes a new instance of the ZoomButton class.

Public Fields

Name | Description
ClipGeometryProperty | Identifies the ClipGeometry dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets a value that represents the degree to which the corners of a control are rounded.
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to render background when mouse is over.
GlowStroke | Gets or sets the brush used to render border brush when mouse is over.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Fields

ZoomButton Fields
[image]

Public Fields

Name | Description
ClipGeometryProperty | Identifies the ClipGeometry dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.

See Also

ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.ClipGeometryProperty Field

ZoomButton.ClipGeometryProperty Field
[image]

Identifies the ClipGeometry dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ClipGeometryProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ClipGeometryProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.CornerRadiusProperty Field

ZoomButton.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlassEffectVisibilityProperty Field

ZoomButton.GlassEffectVisibilityProperty Field
[image]

Identifies the GlassEffectVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlassEffectVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlassEffectVisibilityProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlowFillProperty Field

ZoomButton.GlowFillProperty Field
[image]

Identifies the GlowFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowFillProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlowStrokeProperty Field

ZoomButton.GlowStrokeProperty Field
[image]

Identifies the GlowStroke dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowStrokeProperty As DependencyProperty

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Constructor

ZoomButton Constructor
[image]

Initializes a new instance of the ZoomButton class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ZoomButton ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Methods

ZoomButton Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.OnApplyTemplate Method

ZoomButton.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton Properties

ZoomButton Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets a value that represents the degree to which the corners of a control are rounded.
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to render background when mouse is over.
GlowStroke | Gets or sets the brush used to render border brush when mouse is over.

See Also

ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.CornerRadius Property

ZoomButton.CornerRadius Property
[image]

Gets or sets a value that represents the degree to which the corners of a control are rounded.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

A double value specifying the radius of corner arcs.

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlassEffectVisibility Property

ZoomButton.GlassEffectVisibility Property
[image]

Sets wheather or not the Glass Effect will be visible.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Visibility GlassEffectVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property GlassEffectVisibility As Visibility

Property Value

A member of the System.Windows.Visibility enumeration. The default value is Visible.

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlowFill Property

ZoomButton.GlowFill Property
[image]

Gets or sets the brush used to render background when mouse is over.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush GlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property GlowFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomButton.GlowStroke Property

ZoomButton.GlowStroke Property
[image]

Gets or sets the brush used to render border brush when mouse is over.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush GlowStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GlowStroke As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomButton Members
ZoomButton Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Class

ZoomControl Class
Remarks See Also
[image]

ZoomControl lets users zoom and pan a target Diagram or DiagramView interactively.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public class ZoomControl : Control

Visual Basic [image] Copy Code

Public Class ZoomControl
Inherits Control

Remarks

The ZoomControl class lets user change interactively the current zoom level and scroll position of a Diagram or DiagramView. To set it up, add a ZoomControl to the window, place it anywhere over the target diagram, and set the control's Target property to that diagram or view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, Stroke, CornerRadius and TickPosition.

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.UI.Wpf.ZoomControl

See Also

ZoomControl Members
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Members

ZoomControl Members
Constructors Fields Properties Methods Events
[image]

ZoomControl lets users zoom and pan a target Diagram or DiagramView interactively.

The following tables list the members exposed by the ZoomControl type.

Public Constructors

Name | Description
ZoomControl | Initializes a new instance of the ZoomControl class.

Public Fields

Name | Description
AxisFillProperty | Identifies the AxisFill dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FillProperty | Identifies the Fill dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.
InnerStrokeProperty | Identifies the InnerStroke dependency property.
LabelFillProperty | Identifies the LabelFill dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
LabelVisibilityProperty | Identifies the LabelVisibility dependency property.
MaxZoomFactorProperty | Identifies the MaxZoomFactor dependency property.
MinZoomFactorProperty | Identifies the MinZoomFactor dependency property.
PanFillProperty | Identifies the PanFill dependency property.
PanGlowFillProperty | Identifies the PanGlowFill dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SnapToZoomStepProperty | Identifies the SnapToZoomStep dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TargetProperty | Identifies the Target dependency property.
TickPositionProperty | Identifies the TickPosition dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.
ZoomStepProperty | Identifies the ZoomStep dependency property.

Public Properties

Name | Description
AxisFill | Gets or sets the brush of ZoomControl axis.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl buttons.
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.
GlowStroke | Gets or sets the brush of ZoomControl buttons' borders when mouse is over.
InnerStroke | Gets or sets the brush of plus, minus and arrow icons.
LabelFill | Gets or sets the fill of the label.
LabelFormat | Gets or sets the zoom level label format.
LabelText | Gets or sets the content of the zoom level label.
LabelVisibility | Gets or sets the zoom factor label visibility.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
PanFill | Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.
PanGlowFill | Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Stroke | Gets or sets the brush of ZoomControl buttons' borders.
Target | Gets or sets the target view controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetZoomFactor | Sets the current zoom level.

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Fields

ZoomControl Fields
[image]

Public Fields

Name | Description
AxisFillProperty | Identifies the AxisFill dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FillProperty | Identifies the Fill dependency property.
GlassEffectVisibilityProperty | Identifies the GlassEffectVisibility dependency property.
GlowFillProperty | Identifies the GlowFill dependency property.
GlowStrokeProperty | Identifies the GlowStroke dependency property.
InnerStrokeProperty | Identifies the InnerStroke dependency property.
LabelFillProperty | Identifies the LabelFill dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelTextProperty | Identifies the LabelText dependency property.
LabelVisibilityProperty | Identifies the LabelVisibility dependency property.
MaxZoomFactorProperty | Identifies the MaxZoomFactor dependency property.
MinZoomFactorProperty | Identifies the MinZoomFactor dependency property.
PanFillProperty | Identifies the PanFill dependency property.
PanGlowFillProperty | Identifies the PanGlowFill dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SnapToZoomStepProperty | Identifies the SnapToZoomStep dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TargetProperty | Identifies the Target dependency property.
TickPositionProperty | Identifies the TickPosition dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.
ZoomStepProperty | Identifies the ZoomStep dependency property.

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.AxisFillProperty Field

ZoomControl.AxisFillProperty Field
[image]

Identifies the AxisFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AxisFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AxisFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.CornerRadiusProperty Field

ZoomControl.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.FillProperty Field

ZoomControl.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlassEffectVisibilityProperty Field

ZoomControl.GlassEffectVisibilityProperty Field
[image]

Identifies the GlassEffectVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlassEffectVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlassEffectVisibilityProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlowFillProperty Field

ZoomControl.GlowFillProperty Field
[image]

Identifies the GlowFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlowStrokeProperty Field

ZoomControl.GlowStrokeProperty Field
[image]

Identifies the GlowStroke dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowStrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.InnerStrokeProperty Field

ZoomControl.InnerStrokeProperty Field
[image]

Identifies the InnerStroke dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelFillProperty Field

ZoomControl.LabelFillProperty Field
[image]

Identifies the LabelFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelFormatProperty Field

ZoomControl.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelTextProperty Field

ZoomControl.LabelTextProperty Field
[image]

Identifies the LabelText dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTextProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelVisibilityProperty Field

ZoomControl.LabelVisibilityProperty Field
[image]

Identifies the LabelVisibility dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelVisibilityProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.MaxZoomFactorProperty Field

ZoomControl.MaxZoomFactorProperty Field
[image]

Identifies the MaxZoomFactor dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.MinZoomFactorProperty Field

ZoomControl.MinZoomFactorProperty Field
[image]

Identifies the MinZoomFactor dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.PanFillProperty Field

ZoomControl.PanFillProperty Field
[image]

Identifies the PanFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PanFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PanFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.PanGlowFillProperty Field

ZoomControl.PanGlowFillProperty Field
[image]

Identifies the PanGlowFill dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PanGlowFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PanGlowFillProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ScrollStepProperty Field

ZoomControl.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.SnapToZoomStepProperty Field

ZoomControl.SnapToZoomStepProperty Field
[image]

Identifies the SnapToZoomStep dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapToZoomStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SnapToZoomStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.StrokeProperty Field

ZoomControl.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.TargetProperty Field

ZoomControl.TargetProperty Field
[image]

Identifies the Target dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TargetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TargetProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.TickPositionProperty Field

ZoomControl.TickPositionProperty Field
[image]

Identifies the TickPosition dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickPositionProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ZoomFactorProperty Field

ZoomControl.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ZoomStepProperty Field

ZoomControl.ZoomStepProperty Field
[image]

Identifies the ZoomStep dependency property.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomStepProperty As DependencyProperty

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Constructor

ZoomControl Constructor
[image]

Initializes a new instance of the ZoomControl class.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public ZoomControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Methods

ZoomControl Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.
SetZoomFactor | Sets the current zoom level.

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.OnApplyTemplate Method

ZoomControl.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.SetZoomFactor Method

ZoomControl.SetZoomFactor Method
[image]

Sets the current zoom level.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double value,
bool applyConstraints
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
value As Double, _
applyConstraints As Boolean _
)

Parameters

value

A float value specifying the new zoom level.

applyConstraints

true to apply min/max constraints and align to ZoomStep, or false otherwise.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Properties

ZoomControl Properties
[image]

Public Properties

Name | Description
AxisFill | Gets or sets the brush of ZoomControl axis.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl buttons.
GlassEffectVisibility | Sets wheather or not the Glass Effect will be visible.
GlowFill | Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.
GlowStroke | Gets or sets the brush of ZoomControl buttons' borders when mouse is over.
InnerStroke | Gets or sets the brush of plus, minus and arrow icons.
LabelFill | Gets or sets the fill of the label.
LabelFormat | Gets or sets the zoom level label format.
LabelText | Gets or sets the content of the zoom level label.
LabelVisibility | Gets or sets the zoom factor label visibility.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
PanFill | Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.
PanGlowFill | Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Stroke | Gets or sets the brush of ZoomControl buttons' borders.
Target | Gets or sets the target view controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.AxisFill Property

ZoomControl.AxisFill Property
[image]

Gets or sets the brush of ZoomControl axis.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush AxisFill { get; set; }

Visual Basic [image] Copy Code

Public Property AxisFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.CornerRadius Property

ZoomControl.CornerRadius Property
[image]

Gets or sets the corner radius of rounded child elements.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.Fill Property

ZoomControl.Fill Property
[image]

Gets or sets the brush used to fill the ZoomControl buttons.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlassEffectVisibility Property

ZoomControl.GlassEffectVisibility Property
[image]

Sets wheather or not the Glass Effect will be visible.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Visibility GlassEffectVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property GlassEffectVisibility As Visibility

Property Value

A member of the System.Windows.Visibility enumeration. The default value is Visible.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlowFill Property

ZoomControl.GlowFill Property
[image]

Gets or sets the brush used to fill the ZoomControl buttons when mouse is over.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush GlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property GlowFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.GlowStroke Property

ZoomControl.GlowStroke Property
[image]

Gets or sets the brush of ZoomControl buttons' borders when mouse is over.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush GlowStroke { get; set; }

Visual Basic [image] Copy Code

Public Property GlowStroke As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.InnerStroke Property

ZoomControl.InnerStroke Property
[image]

Gets or sets the brush of plus, minus and arrow icons.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush InnerStroke { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStroke As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelFill Property

ZoomControl.LabelFill Property
[image]

Gets or sets the fill of the label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush LabelFill { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelFormat Property

ZoomControl.LabelFormat Property
[image]

Gets or sets the zoom level label format.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

A string specifying the numeric format of the zoom level label.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelText Property

ZoomControl.LabelText Property
[image]

Gets or sets the content of the zoom level label.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public string LabelText { get; set; }

Visual Basic [image] Copy Code

Public Property LabelText As String

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.LabelVisibility Property

ZoomControl.LabelVisibility Property
[image]

Gets or sets the zoom factor label visibility.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Visibility LabelVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property LabelVisibility As Visibility

Property Value

A member of the System.Windows.Visibility enumeration. The default value is Visible.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.MaxZoomFactor Property

ZoomControl.MaxZoomFactor Property
[image]

The maximum zoom level allowed to set through this control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double MaxZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MaxZoomFactor As Double

Property Value

A double value specifying the maximum zoom level. The default value is 200.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.MinZoomFactor Property

ZoomControl.MinZoomFactor Property
[image]

The minimum zoom level allowed to set through this control.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double MinZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MinZoomFactor As Double

Property Value

A double value specifying the minimum zoom level. The default value is 0.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.PanFill Property

ZoomControl.PanFill Property
[image]

Gets or sets the brush used to fill the ZoomControl depressed pan-buttons.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush PanFill { get; set; }

Visual Basic [image] Copy Code

Public Property PanFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.PanGlowFill Property

ZoomControl.PanGlowFill Property
[image]

Gets or sets the brush used to fill the ZoomControl pan-buttons when mouse is over.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush PanGlowFill { get; set; }

Visual Basic [image] Copy Code

Public Property PanGlowFill As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ScrollStep Property

ZoomControl.ScrollStep Property
[image]

Gets or sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Double

Property Value

A double value specifying the scroll offset. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.SnapToZoomStep Property

ZoomControl.SnapToZoomStep Property
[image]

Gets or sets whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public bool SnapToZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToZoomStep As Boolean

Property Value

true to snap to multiples of ZoomStep, or false otherwise. The default value is true.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.Stroke Property

ZoomControl.Stroke Property
[image]

Gets or sets the brush of ZoomControl buttons' borders.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A System.Windows.Media.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.Target Property

ZoomControl.Target Property
[image]

Gets or sets the target view controlled by this ZoomControl.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public IZoomTarget Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As IZoomTarget

Property Value

A Diagram or DiagramView instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.TickPosition Property

ZoomControl.TickPosition Property
[image]

Gets or sets the current tick position of the trackbar.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public TickPosition TickPosition { get; set; }

Visual Basic [image] Copy Code

Public Property TickPosition As TickPosition

Property Value

A member of the TickPosition enumeration. The default value is Left.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ZoomFactor Property

ZoomControl.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ZoomStep Property

ZoomControl.ZoomStep Property
[image]

Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public double ZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomStep As Double

Property Value

A double value specifying the zoom level change. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl Events

ZoomControl Events
[image]

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ScrollArrowClicked Event

ZoomControl.ScrollArrowClicked Event
[image]

Raised when a scroll arrow has been clicked.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<ScrollArrowEventArgs> ScrollArrowClicked

Visual Basic [image] Copy Code

Public Event ScrollArrowClicked As EventHandler(Of ScrollArrowEventArgs)

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.UI.Wpf.ZoomControl.ZoomFactorChanged Event

ZoomControl.ZoomFactorChanged Event
[image]

Raised when the zoom level changes.

Namespace: MindFusion.UI.Wpf
Assembly: MindFusion.Common.Wpf

Syntax

C# [image] Copy Code

public event EventHandler ZoomFactorChanged

Visual Basic [image] Copy Code

Public Event ZoomFactorChanged As EventHandler

See Also

ZoomControl Members
ZoomControl Class
MindFusion.UI.Wpf Namespace


MindFusion.Vsx Namespace

MindFusion.Vsx Namespace
Classes Interfaces

Classes

Class | Description
Action | Represents an action in a Visio shape.
Connection | Represents a connection point in a Visio shape.
Control | Represents a control point in a Visio shape.
Ellipse | Represents an ellipse, defined by two incident points and a center.
EllipticalArc | Represents an elliptical arc defined by three incident points, rotation angle and axes ratio.
Geometry | Represents a geometry in a Visio shape.
GeometryOperator | Represents the base class for all geometry operators.
GeometryStorage | Represents a geometry object, which is defined by up to six parameters.
GeometryVisitor | Represents a visitor of a Geometry object.
Master(TColor, TImage) | Represents a master Visio shape.
Point | Represents a 2-dimensional point.
Property | Represents a property in a Visio shape.
Rect | Represents a 2-dimensional rectangle.
Shape(TColor, TImage) | Represents a Visio shape.
Stencil(TColor, TImage) | Represents a Visio stencil.
UserValue | Represents a user value in a Visio shape.

Interfaces

Interface | Description
IPlatformHelper(TColor, TImage) | An object that provides platform-specific functions, such as creating an image or color.


MindFusion.Vsx.Action Class

Action Class
Remarks See Also
[image]

Represents an action in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Action

Visual Basic [image] Copy Code

Public Class Action

Remarks

Instances of this class can be obtained through the Actions collection of the Shape obects.

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Action

See Also

Action Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Action Members

Action Members
Properties
[image]

Represents an action in a Visio shape.

The following tables list the members exposed by the Action type.

Public Properties

Name | Description
Checked | Gets or sets a value indicating whether the action is active.
Id | Gets the action identifier.
Inivisble | Gets or sets a value indicating whether the action is visible.
Name | Gets the name of the action.

See Also

Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Action Properties

Action Properties
[image]

Public Properties

Name | Description
Checked | Gets or sets a value indicating whether the action is active.
Id | Gets the action identifier.
Inivisble | Gets or sets a value indicating whether the action is visible.
Name | Gets the name of the action.

See Also

Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Action.Checked Property

Action.Checked Property
[image]

Gets or sets a value indicating whether the action is active.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Checked { get; set; }

Visual Basic [image] Copy Code

Public Property Checked As Object

Property Value

An object evaluating to a boolean value.

See Also

Action Members
Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Action.Id Property

Action.Id Property
[image]

Gets the action identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Nullable<Int32> Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Nullable(Of Int32)

Property Value

An integer value or null (Nothing in Visual Basic).

See Also

Action Members
Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Action.Inivisble Property

Action.Inivisble Property
[image]

Gets or sets a value indicating whether the action is visible.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Inivisble { get; set; }

Visual Basic [image] Copy Code

Public Property Inivisble As Object

Property Value

An object evaluating to a boolean value.

See Also

Action Members
Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Action.Name Property

Action.Name Property
[image]

Gets the name of the action.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value.

See Also

Action Members
Action Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection Class

Connection Class
[image]

Represents a connection point in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Connection

Visual Basic [image] Copy Code

Public Class Connection

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Connection

See Also

Connection Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection Members

Connection Members
Properties
[image]

Represents a connection point in a Visio shape.

The following tables list the members exposed by the Connection type.

Public Properties

Name | Description
Id | Gets the connection point identifier.
Name | Gets the name of the connection point.
X | Gets or sets the x-coordinate of the connection point.
Y | Gets or sets the y-coordinate of the connection point.

See Also

Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection Properties

Connection Properties
[image]

Public Properties

Name | Description
Id | Gets the connection point identifier.
Name | Gets the name of the connection point.
X | Gets or sets the x-coordinate of the connection point.
Y | Gets or sets the y-coordinate of the connection point.

See Also

Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection.Id Property

Connection.Id Property
[image]

Gets the connection point identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Nullable<Int32> Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Nullable(Of Int32)

Property Value

See Also

Connection Members
Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection.Name Property

Connection.Name Property
[image]

Gets the name of the connection point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

Connection Members
Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection.X Property

Connection.X Property
[image]

Gets or sets the x-coordinate of the connection point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Object

Property Value

See Also

Connection Members
Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Connection.Y Property

Connection.Y Property
[image]

Gets or sets the y-coordinate of the connection point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Object

Property Value

See Also

Connection Members
Connection Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control Class

Control Class
Remarks See Also
[image]

Represents a control point in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Control

Visual Basic [image] Copy Code

Public Class Control

Remarks

Instances of this class can be obtained through the Controls collection of the Shape obects.

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Control

See Also

Control Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Control Members

Control Members
Properties
[image]

Represents a control point in a Visio shape.

The following tables list the members exposed by the Control type.

Public Properties

Name | Description
Id | Gets the control point identifier.
Name | Gets the name of the control point.
X | Gets or sets the x-coordinate of the control point.
Y | Gets or sets the y-coordinate of the control point.

See Also

Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control Properties

Control Properties
[image]

Public Properties

Name | Description
Id | Gets the control point identifier.
Name | Gets the name of the control point.
X | Gets or sets the x-coordinate of the control point.
Y | Gets or sets the y-coordinate of the control point.

See Also

Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control.Id Property

Control.Id Property
[image]

Gets the control point identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Nullable<Int32> Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Nullable(Of Int32)

Property Value

An integer value or null (Nothing in Visual Basic).

See Also

Control Members
Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control.Name Property

Control.Name Property
[image]

Gets the name of the control point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value.

See Also

Control Members
Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control.X Property

Control.X Property
[image]

Gets or sets the x-coordinate of the control point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Object

Property Value

An object evaluating to a double value.

See Also

Control Members
Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Control.Y Property

Control.Y Property
[image]

Gets or sets the y-coordinate of the control point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Object

Property Value

An object evaluating to a double value.

See Also

Control Members
Control Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse Class

Ellipse Class
[image]

Represents an ellipse, defined by two incident points and a center.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Ellipse

Visual Basic [image] Copy Code

Public Class Ellipse

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Ellipse

See Also

Ellipse Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse Members

Ellipse Members
Constructors Properties
[image]

Represents an ellipse, defined by two incident points and a center.

The following tables list the members exposed by the Ellipse type.

Public Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the ellipse.
Center | Gets the center of the ellipse.

See Also

Ellipse Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse Constructor

Ellipse Constructor
[image]

Initializes a new instance of the Ellipse class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Ellipse (
Point center,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public New ( _
center As Point, _
p1 As Point, _
p2 As Point _
)

Parameters

center

The center of the ellipse.

p1

The first incident point.

p2

The second incident point.

See Also

Ellipse Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse Properties

Ellipse Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the ellipse.
Center | Gets the center of the ellipse.

See Also

Ellipse Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse.Bounds Property

Ellipse.Bounds Property
[image]

Gets the bounding rectangle of the ellipse.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the Rect class.

See Also

Ellipse Members
Ellipse Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Ellipse.Center Property

Ellipse.Center Property
[image]

Gets the center of the ellipse.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Point Center { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Center As Point

Property Value

An instance of the Point class.

See Also

Ellipse Members
Ellipse Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc Class

EllipticalArc Class
[image]

Represents an elliptical arc defined by three incident points, rotation angle and axes ratio.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class EllipticalArc

Visual Basic [image] Copy Code

Public Class EllipticalArc

Inheritance Hierarchy

System.Object
MindFusion.Vsx.EllipticalArc

See Also

EllipticalArc Members
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc Members

EllipticalArc Members
Constructors Properties
[image]

Represents an elliptical arc defined by three incident points, rotation angle and axes ratio.

The following tables list the members exposed by the EllipticalArc type.

Public Constructors

Name | Description
EllipticalArc | Initializes a new instance of the EllipticalArc class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the arc's ellipse.
Center | Gets the center of the arc's ellipse.
Start | Gets the start angle of the arc.
Sweep | Gets the sweep angle of the arc.

See Also

EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc Constructor

EllipticalArc Constructor
[image]

Initializes a new instance of the EllipticalArc class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public EllipticalArc (
List<Point> points,
double dangle,
double ratio
)

Visual Basic [image] Copy Code

Public New ( _
points As List(Of Point), _
dangle As Double, _
ratio As Double _
)

Parameters

points

The three incident points.

dangle

The rotation angle of the arc's ellipse, relative to the x-axis, expressed in degrees.

ratio

The ratio of the two axes of the arc's ellipse.

See Also

EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc Properties

EllipticalArc Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the arc's ellipse.
Center | Gets the center of the arc's ellipse.
Start | Gets the start angle of the arc.
Sweep | Gets the sweep angle of the arc.

See Also

EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc.Bounds Property

EllipticalArc.Bounds Property
[image]

Gets the bounding rectangle of the arc's ellipse.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the Rect class.

See Also

EllipticalArc Members
EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc.Center Property

EllipticalArc.Center Property
[image]

Gets the center of the arc's ellipse.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Point Center { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Center As Point

Property Value

An instance of the Point class.

See Also

EllipticalArc Members
EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc.Start Property

EllipticalArc.Start Property
[image]

Gets the start angle of the arc.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Start { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Start As Double

Property Value

A double value.

See Also

EllipticalArc Members
EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.EllipticalArc.Sweep Property

EllipticalArc.Sweep Property
[image]

Gets the sweep angle of the arc.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Sweep { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Sweep As Double

Property Value

A double value.

See Also

EllipticalArc Members
EllipticalArc Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry Class

Geometry Class
[image]

Represents a geometry in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Geometry

Visual Basic [image] Copy Code

Public Class Geometry

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Geometry

See Also

Geometry Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry Members

Geometry Members
Properties
[image]

Represents a geometry in a Visio shape.

The following tables list the members exposed by the Geometry type.

Public Properties

Name | Description
NoFill | Gets or sets a value indicating whether the geometry should not be filled.
NoLine | Gets or sets a value indicating whether the geometry should not be stroked.
NoShow | Gets or sets a value indicating whether the geometry should not be hidden.
Operators | Gets a list of the operators that define the geometry.

See Also

Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry Properties

Geometry Properties
[image]

Public Properties

Name | Description
NoFill | Gets or sets a value indicating whether the geometry should not be filled.
NoLine | Gets or sets a value indicating whether the geometry should not be stroked.
NoShow | Gets or sets a value indicating whether the geometry should not be hidden.
Operators | Gets a list of the operators that define the geometry.

See Also

Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry.NoFill Property

Geometry.NoFill Property
[image]

Gets or sets a value indicating whether the geometry should not be filled.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool NoFill { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NoFill As Boolean

Property Value

A boolean value.

See Also

Geometry Members
Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry.NoLine Property

Geometry.NoLine Property
[image]

Gets or sets a value indicating whether the geometry should not be stroked.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool NoLine { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NoLine As Boolean

Property Value

A boolean value.

See Also

Geometry Members
Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry.NoShow Property

Geometry.NoShow Property
[image]

Gets or sets a value indicating whether the geometry should not be hidden.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool NoShow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NoShow As Boolean

Property Value

A boolean value.

See Also

Geometry Members
Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Geometry.Operators Property

Geometry.Operators Property
[image]

Gets a list of the operators that define the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public List<GeometryOperator> Operators { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Operators As List(Of GeometryOperator)

Property Value

A list of GeometryOperator objects.

See Also

Geometry Members
Geometry Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryOperator Class

GeometryOperator Class
[image]

Represents the base class for all geometry operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract class GeometryOperator : GeometryStorage

Visual Basic [image] Copy Code

Public MustInherit Class GeometryOperator
Inherits GeometryStorage

Inheritance Hierarchy

System.Object
MindFusion.Vsx.GeometryStorage
MindFusion.Vsx.GeometryOperator

See Also

GeometryOperator Members
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryOperator Members

GeometryOperator Members
Properties Methods
[image]

Represents the base class for all geometry operators.

The following tables list the members exposed by the GeometryOperator type.

Public Properties

Name | Description
A | Gets the third parameter of the geometry. (Inherited from GeometryStorage.)
B | Gets the fourth parameter of the geometry. (Inherited from GeometryStorage.)
C | Gets the fifth parameter of the geometry. (Inherited from GeometryStorage.)
D | Gets the sixth parameter of the geometry. (Inherited from GeometryStorage.)
X | Gets the first parameter of the geometry. (Inherited from GeometryStorage.)
Y | Gets the second parameter of the geometry. (Inherited from GeometryStorage.)

Public Methods

Name | Description
ToString | Object.ToString override. (Inherited from GeometryStorage.)

See Also

GeometryOperator Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage Class

GeometryStorage Class
[image]

Represents a geometry object, which is defined by up to six parameters.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class GeometryStorage

Visual Basic [image] Copy Code

Public Class GeometryStorage

Inheritance Hierarchy

System.Object
MindFusion.Vsx.GeometryStorage
MindFusion.Vsx.GeometryOperator

See Also

GeometryStorage Members
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage Members

GeometryStorage Members
Properties Methods
[image]

Represents a geometry object, which is defined by up to six parameters.

The following tables list the members exposed by the GeometryStorage type.

Public Properties

Name | Description
A | Gets the third parameter of the geometry.
B | Gets the fourth parameter of the geometry.
C | Gets the fifth parameter of the geometry.
D | Gets the sixth parameter of the geometry.
X | Gets the first parameter of the geometry.
Y | Gets the second parameter of the geometry.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage Methods

GeometryStorage Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.ToString Method

GeometryStorage.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage Properties

GeometryStorage Properties
[image]

Public Properties

Name | Description
A | Gets the third parameter of the geometry.
B | Gets the fourth parameter of the geometry.
C | Gets the fifth parameter of the geometry.
D | Gets the sixth parameter of the geometry.
X | Gets the first parameter of the geometry.
Y | Gets the second parameter of the geometry.

See Also

GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.A Property

GeometryStorage.A Property
[image]

Gets the third parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double A { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property A As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.B Property

GeometryStorage.B Property
[image]

Gets the fourth parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double B { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property B As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.C Property

GeometryStorage.C Property
[image]

Gets the fifth parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double C { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property C As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.D Property

GeometryStorage.D Property
[image]

Gets the sixth parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double D { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property D As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.X Property

GeometryStorage.X Property
[image]

Gets the first parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double X { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property X As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryStorage.Y Property

GeometryStorage.Y Property
[image]

Gets the second parameter of the geometry.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Y { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Y As Double

Property Value

A double value.

See Also

GeometryStorage Members
GeometryStorage Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor Class

GeometryVisitor Class
[image]

Represents a visitor of a Geometry object.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract class GeometryVisitor

Visual Basic [image] Copy Code

Public MustInherit Class GeometryVisitor

Inheritance Hierarchy

System.Object
MindFusion.Vsx.GeometryVisitor

See Also

GeometryVisitor Members
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor Members

GeometryVisitor Members
Constructors Methods
[image]

Represents a visitor of a Geometry object.

The following tables list the members exposed by the GeometryVisitor type.

Protected Constructors

Name | Description
GeometryVisitor | Initializes a new instance of the GeometryVisitor class.

Public Methods

Name | Description
ArcTo | Called when visiting ArcTo operators.
Ellipse | Called when visiting Ellipse operators.
EllipticalArcTo | Called when visiting EllipticalArcTo operators.
LineTo | Called when visiting LineTo operators.
MoveTo | Called when visiting MoveTo operators.
PolylineTo | Called when visiting PolylineTo operators.
Visit | Visits the specified Geometry object.

See Also

GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor Constructor

GeometryVisitor Constructor
[image]

Initializes a new instance of the GeometryVisitor class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

protected GeometryVisitor ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor Methods

GeometryVisitor Methods
[image]

Public Methods

Name | Description
ArcTo | Called when visiting ArcTo operators.
Ellipse | Called when visiting Ellipse operators.
EllipticalArcTo | Called when visiting EllipticalArcTo operators.
LineTo | Called when visiting LineTo operators.
MoveTo | Called when visiting MoveTo operators.
PolylineTo | Called when visiting PolylineTo operators.
Visit | Visits the specified Geometry object.

See Also

GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.ArcTo Method

GeometryVisitor.ArcTo Method
[image]

Called when visiting ArcTo operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void ArcTo (
double x,
double y,
double a
)

Visual Basic [image] Copy Code

Public MustOverride Sub ArcTo( _
x As Double, _
y As Double, _
a As Double _
)

Parameters

x

The x-coordinate of the arc's end point.

y

The y-coordinate of the arc's end point.

a

The arc's sweep angle.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.Ellipse Method

GeometryVisitor.Ellipse Method
[image]

Called when visiting Ellipse operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void Ellipse (
double cpx,
double cpy,
double ax,
double ay,
double bx,
double by
)

Visual Basic [image] Copy Code

Public MustOverride Sub Ellipse( _
cpx As Double, _
cpy As Double, _
ax As Double, _
ay As Double, _
bx As Double, _
by As Double _
)

Parameters

cpx

The x-coordinate of the ellipse's center.

cpy

The y-coordinate of the ellipse's center.

ax

The x-coordinate of the first incident point.

ay

The y-coordinate of the first incident point.

bx

The x-coordinate of the second incident point.

by

The y-coordinate of the second incident point.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.EllipticalArcTo Method

GeometryVisitor.EllipticalArcTo Method
[image]

Called when visiting EllipticalArcTo operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void EllipticalArcTo (
double cpx,
double cpy,
double x,
double y,
double angle,
double ratio
)

Visual Basic [image] Copy Code

Public MustOverride Sub EllipticalArcTo( _
cpx As Double, _
cpy As Double, _
x As Double, _
y As Double, _
angle As Double, _
ratio As Double _
)

Parameters

cpx

The x-coordinate of the arc's center.

cpy

The y-coordinate of the arc's center.

x

The x-coordinate of the arc's end point.

y

The y-coordinate of the arc's end point.

angle

The rotation angle of the arc, relative to the x-axis.

ratio

The axes ratio of the arc's ellipse.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.LineTo Method

GeometryVisitor.LineTo Method
[image]

Called when visiting LineTo operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void LineTo (
double x,
double y
)

Visual Basic [image] Copy Code

Public MustOverride Sub LineTo( _
x As Double, _
y As Double _
)

Parameters

x

The x-coordinate of the operation.

y

The y-coordinate of the operation.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.MoveTo Method

GeometryVisitor.MoveTo Method
[image]

Called when visiting MoveTo operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void MoveTo (
double x,
double y
)

Visual Basic [image] Copy Code

Public MustOverride Sub MoveTo( _
x As Double, _
y As Double _
)

Parameters

x

The x-coordinate of the operation.

y

The y-coordinate of the operation.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.PolylineTo Method

GeometryVisitor.PolylineTo Method
[image]

Called when visiting PolylineTo operators.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public abstract void PolylineTo (
double x,
double y,
double[] polyline
)

Visual Basic [image] Copy Code

Public MustOverride Sub PolylineTo( _
x As Double, _
y As Double, _
polyline() As Double _
)

Parameters

x

The x-coordinate of the last point of the polyline.

y

The y-coordinate of the last point of the polyline.

polyline

An array of coordinates describing the points of the polyline.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.GeometryVisitor.Visit Method

GeometryVisitor.Visit Method
[image]

Visits the specified Geometry object.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void Visit (
Geometry geometry
)

Visual Basic [image] Copy Code

Public Sub Visit( _
geometry As Geometry _
)

Parameters

geometry

The geometry to visit.

See Also

GeometryVisitor Members
GeometryVisitor Class
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage) Interface

IPlatformHelper(TColor, TImage) Interface
[image]

An object that provides platform-specific functions, such as creating an image or color.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public interface IPlatformHelper<TColor, TImage>

Visual Basic [image] Copy Code

Public Interface IPlatformHelper(Of TColor, TImage)

See Also

IPlatformHelper(TColor, TImage) Members
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage) Members

IPlatformHelper(TColor, TImage) Members
Methods
[image]

An object that provides platform-specific functions, such as creating an image or color.

The following tables list the members exposed by the IPlatformHelper(TColor, TImage) type.

Public Methods

Name | Description
CreateColor | Overloaded. Creates a color object.
CreateImage | Creates an image from the specified stream.
GetA | Retrieves the alpha component of the specified color.
GetB | Retrieves the blue component of the specified color.
GetG | Retrieves the green component of the specified color.
GetR | Retrieves the red component of the specified color.
SaveImage | Saves the specified image to the specified stream.
ToString | Converts the specified color to its string representation.

See Also

IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage) Methods

IPlatformHelper(TColor, TImage) Methods
[image]

Public Methods

Name | Description
CreateColor | Overloaded. Creates a color object.
CreateImage | Creates an image from the specified stream.
GetA | Retrieves the alpha component of the specified color.
GetB | Retrieves the blue component of the specified color.
GetG | Retrieves the green component of the specified color.
GetR | Retrieves the red component of the specified color.
SaveImage | Saves the specified image to the specified stream.
ToString | Converts the specified color to its string representation.

See Also

IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).CreateColor Method

IPlatformHelper(TColor, TImage).CreateColor Method
[image]

Creates a color object.

Overload List

Name | Description
IPlatformHelper(TColor, TImage).CreateColor (Int32, Int32, Int32) | Creates a color from the specified red, green, and blue values.
IPlatformHelper(TColor, TImage).CreateColor (Int32, Int32, Int32, Int32) | Creates a color from the specified red, green, and blue values.
IPlatformHelper(TColor, TImage).CreateColor (String) | Creates a color from the specified string representation.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).CreateColor Method (Int32, Int32, Int32)

IPlatformHelper(TColor, TImage).CreateColor Method (Int32, Int32, Int32)
See Also
[image]

Creates a color from the specified red, green, and blue values.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

TColor CreateColor (
int r,
int g,
int b
)

Visual Basic [image] Copy Code

Function CreateColor( _
r As Integer, _
g As Integer, _
b As Integer _
) As TColor

Parameters

r

The red component value for the new color.

g

The green component value for the new color.

b

The blue component value for the new color.

Return Value

The newly created color object.

See Also

CreateColor Method Overload List
IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).CreateColor Method (Int32, Int32, Int32, Int32)

IPlatformHelper(TColor, TImage).CreateColor Method (Int32, Int32, Int32, Int32)
See Also
[image]

Creates a color from the specified red, green, and blue values.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

TColor CreateColor (
int a,
int r,
int g,
int b
)

Visual Basic [image] Copy Code

Function CreateColor( _
a As Integer, _
r As Integer, _
g As Integer, _
b As Integer _
) As TColor

Parameters

a

The alpha component value for the new color.

r

The red component value for the new color.

g

The green component value for the new color.

b

The blue component value for the new color.

Return Value

The newly created color object.

See Also

CreateColor Method Overload List
IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).CreateColor Method (String)

IPlatformHelper(TColor, TImage).CreateColor Method (String)
See Also
[image]

Creates a color from the specified string representation.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

TColor CreateColor (
string value
)

Visual Basic [image] Copy Code

Function CreateColor( _
value As String _
) As TColor

Parameters

value

The string representation.

Return Value

The newly created color object.

See Also

CreateColor Method Overload List
IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).CreateImage Method

IPlatformHelper(TColor, TImage).CreateImage Method
[image]

Creates an image from the specified stream.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

TImage CreateImage (
Stream stream
)

Visual Basic [image] Copy Code

Function CreateImage( _
stream As Stream _
) As TImage

Parameters

stream

The stream that contains the data for the image.

Return Value

The newly created image object.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).GetA Method

IPlatformHelper(TColor, TImage).GetA Method
[image]

Retrieves the alpha component of the specified color.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

int GetA (
TColor color
)

Visual Basic [image] Copy Code

Function GetA( _
color As TColor _
) As Integer

Parameters

color

A color object.

Return Value

The alpha component of the color.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).GetB Method

IPlatformHelper(TColor, TImage).GetB Method
[image]

Retrieves the blue component of the specified color.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

int GetB (
TColor color
)

Visual Basic [image] Copy Code

Function GetB( _
color As TColor _
) As Integer

Parameters

color

A color object.

Return Value

The blue component of the color.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).GetG Method

IPlatformHelper(TColor, TImage).GetG Method
[image]

Retrieves the green component of the specified color.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

int GetG (
TColor color
)

Visual Basic [image] Copy Code

Function GetG( _
color As TColor _
) As Integer

Parameters

color

A color object.

Return Value

The green component of the color.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).GetR Method

IPlatformHelper(TColor, TImage).GetR Method
[image]

Retrieves the red component of the specified color.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

int GetR (
TColor color
)

Visual Basic [image] Copy Code

Function GetR( _
color As TColor _
) As Integer

Parameters

color

A color object.

Return Value

The red component of the color.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).SaveImage Method

IPlatformHelper(TColor, TImage).SaveImage Method
[image]

Saves the specified image to the specified stream.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

void SaveImage (
Stream stream,
TImage image
)

Visual Basic [image] Copy Code

Sub SaveImage( _
stream As Stream, _
image As TImage _
)

Parameters

stream

The stream where the image will be saved.

image

The image to save.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.IPlatformHelper(TColor, TImage).ToString Method

IPlatformHelper(TColor, TImage).ToString Method
[image]

Converts the specified color to its string representation.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

string ToString (
TColor color
)

Visual Basic [image] Copy Code

Function ToString( _
color As TColor _
) As String

Parameters

color

The color to convert.

Return Value

The string representation of the color.

See Also

IPlatformHelper(TColor, TImage) Members
IPlatformHelper(TColor, TImage) Interface
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage) Class

Master(TColor, TImage) Class
[image]

Represents a master Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Master<TColor, TImage> where TColor : ValueType

Visual Basic [image] Copy Code

Public Class Master(Of TColor As ValueType, TImage)

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Master(TColor, TImage)

See Also

Master(TColor, TImage) Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage) Members

Master(TColor, TImage) Members
Properties Methods
[image]

Represents a master Visio shape.

The following tables list the members exposed by the Master(TColor, TImage) type.

Public Properties

Name | Description
Icon | Gets or sets the preview icon of this shape.
Id | Gets the master identifier.
Shapes | Gets a list with the subordinate shapes.
UniversalName | Gets the name of the master.

Public Methods

Name | Description
Clone | Creates an exact deep copy of this object.
Invalidate | Call this method after changing any of the properties of this object or its subordinate shapes to force all dependent properties to be recalculated.
LoadLocalState | Restores previously saved local property values.
ResetLocalValues | Clears all locally set property values across this object and its subordinate shapes.
SaveLocalState | Saves all locally set property values across this object and its subordinate shapes.
ToString | Object.ToString override.

See Also

Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage) Methods

Master(TColor, TImage) Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact deep copy of this object.
Invalidate | Call this method after changing any of the properties of this object or its subordinate shapes to force all dependent properties to be recalculated.
LoadLocalState | Restores previously saved local property values.
ResetLocalValues | Clears all locally set property values across this object and its subordinate shapes.
SaveLocalState | Saves all locally set property values across this object and its subordinate shapes.
ToString | Object.ToString override.

See Also

Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).Clone Method

Master(TColor, TImage).Clone Method
[image]

Creates an exact deep copy of this object.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Master<TColor, TImage> Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Master(Of TColor, TImage)

Return Value

A Master instance representing the copy.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).Invalidate Method

Master(TColor, TImage).Invalidate Method
[image]

Call this method after changing any of the properties of this object or its subordinate shapes to force all dependent properties to be recalculated.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void Invalidate ()

Visual Basic [image] Copy Code

Public Sub Invalidate ()

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).LoadLocalState Method

Master(TColor, TImage).LoadLocalState Method
[image]

Restores previously saved local property values.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void LoadLocalState (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Sub LoadLocalState( _
reader As BinaryReader _
)

Parameters

reader

The BinaryReader to load the state from.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).ResetLocalValues Method

Master(TColor, TImage).ResetLocalValues Method
[image]

Clears all locally set property values across this object and its subordinate shapes.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void ResetLocalValues ()

Visual Basic [image] Copy Code

Public Sub ResetLocalValues ()

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).SaveLocalState Method

Master(TColor, TImage).SaveLocalState Method
[image]

Saves all locally set property values across this object and its subordinate shapes.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void SaveLocalState (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveLocalState( _
writer As BinaryWriter _
)

Parameters

writer

The BinaryWriter to save the state to.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).ToString Method

Master(TColor, TImage).ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage) Properties

Master(TColor, TImage) Properties
[image]

Public Properties

Name | Description
Icon | Gets or sets the preview icon of this shape.
Id | Gets the master identifier.
Shapes | Gets a list with the subordinate shapes.
UniversalName | Gets the name of the master.

See Also

Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).Icon Property

Master(TColor, TImage).Icon Property
[image]

Gets or sets the preview icon of this shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public TImage Icon { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Icon As TImage

Property Value

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).Id Property

Master(TColor, TImage).Id Property
[image]

Gets the master identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).Shapes Property

Master(TColor, TImage).Shapes Property
[image]

Gets a list with the subordinate shapes.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public List<Shape<TColor, TImage>> Shapes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shapes As List(Of Shape(Of TColor, TImage))

Property Value

A list of Shape(TColor, TImage) objects.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Master(TColor, TImage).UniversalName Property

Master(TColor, TImage).UniversalName Property
[image]

Gets the name of the master.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string UniversalName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UniversalName As String

Property Value

A string value.

See Also

Master(TColor, TImage) Members
Master(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Class

Point Class
[image]

Represents a 2-dimensional point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Point

Visual Basic [image] Copy Code

Public Class Point

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Point

See Also

Point Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Members

Point Members
Constructors Properties Methods
[image]

Represents a 2-dimensional point.

The following tables list the members exposed by the Point type.

Public Constructors

Name | Description
Point | Overloaded. Initializes a new instance of the Point class.

Public Properties

Name | Description
X | Gets or sets the x-coordinate of the point.
Y | Gets or sets the y-coordinate of the point.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Constructor

Point Constructor
[image]

Initializes a new instance of the Point class.

Overload List

Name | Description
Point () | Initializes a new instance of the Point class.
Point (Double, Double) | Initializes a new instance of the Point class.

See Also

Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Constructor ()

Point Constructor ()
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Point ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Point Constructor Overload List
Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Constructor (Double, Double)

Point Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Point (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

The x-coordinate of the new point.

y

The y-coordinate of the new point.

See Also

Point Constructor Overload List
Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Methods

Point Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point.ToString Method

Point.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

Point Members
Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point Properties

Point Properties
[image]

Public Properties

Name | Description
X | Gets or sets the x-coordinate of the point.
Y | Gets or sets the y-coordinate of the point.

See Also

Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point.X Property

Point.X Property
[image]

Gets or sets the x-coordinate of the point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value.

See Also

Point Members
Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Point.Y Property

Point.Y Property
[image]

Gets or sets the y-coordinate of the point.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value.

See Also

Point Members
Point Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property Class

Property Class
Remarks See Also
[image]

Represents a property in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Property

Visual Basic [image] Copy Code

Public Class Property

Remarks

Instances of this class can be obtained through the Properties collection of the Shape obects.

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Property

See Also

Property Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Property Members

Property Members
Properties Methods
[image]

Represents a property in a Visio shape.

The following tables list the members exposed by the Property type.

Public Properties

Name | Description
Format | Gets or sets the allowed property values.
Id | Gets the property identifier.
Name | Gets the name of the property.
Value | Gets or sets the property value.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property Methods

Property Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property.ToString Method

Property.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

Property Members
Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property Properties

Property Properties
[image]

Public Properties

Name | Description
Format | Gets or sets the allowed property values.
Id | Gets the property identifier.
Name | Gets the name of the property.
Value | Gets or sets the property value.

See Also

Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property.Format Property

Property.Format Property
[image]

Gets or sets the allowed property values.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As String

Property Value

See Also

Property Members
Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property.Id Property

Property.Id Property
[image]

Gets the property identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Nullable<Int32> Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Nullable(Of Int32)

Property Value

See Also

Property Members
Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property.Name Property

Property.Name Property
[image]

Gets the name of the property.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

Property Members
Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Property.Value Property

Property.Value Property
[image]

Gets or sets the property value.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Object

Property Value

See Also

Property Members
Property Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Class

Rect Class
[image]

Represents a 2-dimensional rectangle.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Rect

Visual Basic [image] Copy Code

Public Class Rect

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Rect

See Also

Rect Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Members

Rect Members
Constructors Properties Methods
[image]

Represents a 2-dimensional rectangle.

The following tables list the members exposed by the Rect type.

Public Constructors

Name | Description
Rect | Overloaded. Initializes a new instance of the Rect class.

Public Properties

Name | Description
Height | Gets or sets the height of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets the x-coordinate of the rectangle.
Y | Gets or sets the y-coordinate of the rectangle.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Constructor

Rect Constructor
[image]

Initializes a new instance of the Rect class.

Overload List

Name | Description
Rect () | Initializes a new instance of the Rect class.
Rect (Double, Double, Double, Double) | Initializes a new instance of the Rect class.

See Also

Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Constructor ()

Rect Constructor ()
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Rect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Rect Constructor Overload List
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Constructor (Double, Double, Double, Double)

Rect Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Rect (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

x

The x-coordinate of the new rectangle.

y

The y-coordinate of the new rectangle.

width

The width of the new rectangle.

height

The height of the new rectangle.

See Also

Rect Constructor Overload List
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Methods

Rect Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect.ToString Method

Rect.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

Rect Members
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect Properties

Rect Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the height of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets the x-coordinate of the rectangle.
Y | Gets or sets the y-coordinate of the rectangle.

See Also

Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect.Height Property

Rect.Height Property
[image]

Gets or sets the height of the rectangle.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect.Width Property

Rect.Width Property
[image]

Gets or sets the width of the rectangle.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect.X Property

Rect.X Property
[image]

Gets or sets the x-coordinate of the rectangle.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Rect.Y Property

Rect.Y Property
[image]

Gets or sets the y-coordinate of the rectangle.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value.

See Also

Rect Members
Rect Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage) Class

Shape(TColor, TImage) Class
[image]

Represents a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Shape<TColor, TImage> : IFormulaEvaluator where TColor : ValueType

Visual Basic [image] Copy Code

Public Class Shape(Of TColor As ValueType, TImage)
Implements IFormulaEvaluator

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Shape(TColor, TImage)

See Also

Shape(TColor, TImage) Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage) Members

Shape(TColor, TImage) Members
Properties Methods
[image]

Represents a Visio shape.

The following tables list the members exposed by the Shape(TColor, TImage) type.

Public Properties

Name | Description
Actions | Gets the actions associated with the shape.
Angle | Gets the angle of rotation, expressed in radians.
BackgroundColor | Gets or sets the background color of the shape.
BackgroundColorTransparency | Gets or sets the transparency of the background color, ranging from 0 (opaque) to 1 (fully transparent).
Connections | Gets the connection points associated with the shape.
Controls | Gets the control points associated with the shape.
FillPattern | Gets the fill pattern of the shape.
FlipX | Gets a value indicating whether the shape is flipped along the x-axis.
FlipY | Gets a value indicating whether the shape is flipped along the y-axis.
ForegroundColor | Gets or sets the foreground color of the shape.
ForegroundColorTransparency | Gets the transparency of the foreground color, ranging from 0 (opaque) to 1 (fully transparent).
Geometries | Gets a list with the shape's geometries.
HasPositionInfo | Gets a value indicating whether the shape specifies positioning information.
Height | Gets or sets the width of the shape, expressed in inches.
Id | Gets the shape identifier.
Image | Gets the image associated with the shape.
ImageHeight | Gets the height of the shape's image, expressed in inches.
ImageOffsetX | Gets the x-axis offset of the shape's image, expressed in inches, relative to the shape.
ImageOffsetY | Gets the y-axis offset of the shape's image, expressed in inches, relative to the shape.
ImageWidth | Gets the width of the shape's image, expressed in inches.
LineBeginArrow | Gets the arrowhead of the shape's line.
LineColor | Gets the line color of the shape.
LineColorTransparency | Gets the transparency of the line color, ranging from 0 (opaque) to 1 (fully transparent).
LineEndArrow | Gets the arrowhead of the shape's line.
LinePattern | Gets the style of the shape's line.
LineRounding | Gets the rounding factor of the contour joints of the shape.
LineWeight | Gets the thickness of the shape's line.
LocPinX | Gets the x-coordinate, expressed in inches, of the point used as the transformation center.
LocPinY | Gets the y-coordinate, expressed in inches, of the point used as the transformation center.
Parent | Gets the shape parent.
PinX | Gets the x-coordinate of the shape, expressed in inches, relative to its parent.
PinY | Gets the y-coordinate of the shape, expressed in inches, relative to its parent.
Properties | Gets the properties associated with the shape.
ScratchValues | Gets the "scratch" values associated with the shape.
Shapes | Gets a list with the subordinate shapes.
Text | Gets the shape's text.
UserValues | Gets the user values associated with the shape.
Width | Gets or sets the width of the shape, expressed in inches.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage) Methods

Shape(TColor, TImage) Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ToString Method

Shape(TColor, TImage).ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage) Properties

Shape(TColor, TImage) Properties
[image]

Public Properties

Name | Description
Actions | Gets the actions associated with the shape.
Angle | Gets the angle of rotation, expressed in radians.
BackgroundColor | Gets or sets the background color of the shape.
BackgroundColorTransparency | Gets or sets the transparency of the background color, ranging from 0 (opaque) to 1 (fully transparent).
Connections | Gets the connection points associated with the shape.
Controls | Gets the control points associated with the shape.
FillPattern | Gets the fill pattern of the shape.
FlipX | Gets a value indicating whether the shape is flipped along the x-axis.
FlipY | Gets a value indicating whether the shape is flipped along the y-axis.
ForegroundColor | Gets or sets the foreground color of the shape.
ForegroundColorTransparency | Gets the transparency of the foreground color, ranging from 0 (opaque) to 1 (fully transparent).
Geometries | Gets a list with the shape's geometries.
HasPositionInfo | Gets a value indicating whether the shape specifies positioning information.
Height | Gets or sets the width of the shape, expressed in inches.
Id | Gets the shape identifier.
Image | Gets the image associated with the shape.
ImageHeight | Gets the height of the shape's image, expressed in inches.
ImageOffsetX | Gets the x-axis offset of the shape's image, expressed in inches, relative to the shape.
ImageOffsetY | Gets the y-axis offset of the shape's image, expressed in inches, relative to the shape.
ImageWidth | Gets the width of the shape's image, expressed in inches.
LineBeginArrow | Gets the arrowhead of the shape's line.
LineColor | Gets the line color of the shape.
LineColorTransparency | Gets the transparency of the line color, ranging from 0 (opaque) to 1 (fully transparent).
LineEndArrow | Gets the arrowhead of the shape's line.
LinePattern | Gets the style of the shape's line.
LineRounding | Gets the rounding factor of the contour joints of the shape.
LineWeight | Gets the thickness of the shape's line.
LocPinX | Gets the x-coordinate, expressed in inches, of the point used as the transformation center.
LocPinY | Gets the y-coordinate, expressed in inches, of the point used as the transformation center.
Parent | Gets the shape parent.
PinX | Gets the x-coordinate of the shape, expressed in inches, relative to its parent.
PinY | Gets the y-coordinate of the shape, expressed in inches, relative to its parent.
Properties | Gets the properties associated with the shape.
ScratchValues | Gets the "scratch" values associated with the shape.
Shapes | Gets a list with the subordinate shapes.
Text | Gets the shape's text.
UserValues | Gets the user values associated with the shape.
Width | Gets or sets the width of the shape, expressed in inches.

See Also

Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Actions Property

Shape(TColor, TImage).Actions Property
[image]

Gets the actions associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IDictionary<string, Action> Actions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Actions As IDictionary(Of String, Action)

Property Value

A map between the shape actions and their names.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Angle Property

Shape(TColor, TImage).Angle Property
[image]

Gets the angle of rotation, expressed in radians.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Angle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Angle As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).BackgroundColor Property

Shape(TColor, TImage).BackgroundColor Property
[image]

Gets or sets the background color of the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public TColor BackgroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundColor As TColor

Property Value

A color object.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).BackgroundColorTransparency Property

Shape(TColor, TImage).BackgroundColorTransparency Property
[image]

Gets or sets the transparency of the background color, ranging from 0 (opaque) to 1 (fully transparent).

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double BackgroundColorTransparency { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundColorTransparency As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Connections Property

Shape(TColor, TImage).Connections Property
[image]

Gets the connection points associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public List<Connection> Connections { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Connections As List(Of Connection)

Property Value

A list of Connection objects defined for the shape.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Controls Property

Shape(TColor, TImage).Controls Property
[image]

Gets the control points associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IDictionary<string, Control> Controls { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Controls As IDictionary(Of String, Control)

Property Value

A map between the shape controls and their names.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).FillPattern Property

Shape(TColor, TImage).FillPattern Property
[image]

Gets the fill pattern of the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public int FillPattern { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FillPattern As Integer

Property Value

An integer value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).FlipX Property

Shape(TColor, TImage).FlipX Property
[image]

Gets a value indicating whether the shape is flipped along the x-axis.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool FlipX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FlipX As Boolean

Property Value

A boolean value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).FlipY Property

Shape(TColor, TImage).FlipY Property
[image]

Gets a value indicating whether the shape is flipped along the y-axis.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool FlipY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FlipY As Boolean

Property Value

A boolean value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ForegroundColor Property

Shape(TColor, TImage).ForegroundColor Property
[image]

Gets or sets the foreground color of the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public TColor ForegroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundColor As TColor

Property Value

A color object.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ForegroundColorTransparency Property

Shape(TColor, TImage).ForegroundColorTransparency Property
[image]

Gets the transparency of the foreground color, ranging from 0 (opaque) to 1 (fully transparent).

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double ForegroundColorTransparency { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundColorTransparency As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Geometries Property

Shape(TColor, TImage).Geometries Property
[image]

Gets a list with the shape's geometries.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IList<Geometry> Geometries { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Geometries As IList(Of Geometry)

Property Value

A list of Geometry objects.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).HasPositionInfo Property

Shape(TColor, TImage).HasPositionInfo Property
[image]

Gets a value indicating whether the shape specifies positioning information.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public bool HasPositionInfo { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HasPositionInfo As Boolean

Property Value

A boolean value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Height Property

Shape(TColor, TImage).Height Property
[image]

Gets or sets the width of the shape, expressed in inches.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Id Property

Shape(TColor, TImage).Id Property
[image]

Gets the shape identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

A string value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Image Property

Shape(TColor, TImage).Image Property
[image]

Gets the image associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public TImage Image { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Image As TImage

Property Value

An image object.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ImageHeight Property

Shape(TColor, TImage).ImageHeight Property
[image]

Gets the height of the shape's image, expressed in inches.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double ImageHeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ImageHeight As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ImageOffsetX Property

Shape(TColor, TImage).ImageOffsetX Property
[image]

Gets the x-axis offset of the shape's image, expressed in inches, relative to the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double ImageOffsetX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ImageOffsetX As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ImageOffsetY Property

Shape(TColor, TImage).ImageOffsetY Property
[image]

Gets the y-axis offset of the shape's image, expressed in inches, relative to the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double ImageOffsetY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ImageOffsetY As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ImageWidth Property

Shape(TColor, TImage).ImageWidth Property
[image]

Gets the width of the shape's image, expressed in inches.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double ImageWidth { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ImageWidth As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineBeginArrow Property

Shape(TColor, TImage).LineBeginArrow Property
[image]

Gets the arrowhead of the shape's line.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public int LineBeginArrow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineBeginArrow As Integer

Property Value

An integer value corresponding to Visio BeginArrow element values.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineColor Property

Shape(TColor, TImage).LineColor Property
[image]

Gets the line color of the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public TColor LineColor { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineColor As TColor

Property Value

A color object.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineColorTransparency Property

Shape(TColor, TImage).LineColorTransparency Property
[image]

Gets the transparency of the line color, ranging from 0 (opaque) to 1 (fully transparent).

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double LineColorTransparency { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineColorTransparency As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineEndArrow Property

Shape(TColor, TImage).LineEndArrow Property
[image]

Gets the arrowhead of the shape's line.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public int LineEndArrow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineEndArrow As Integer

Property Value

An integer value corresponding to Visio EndArrow element values.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LinePattern Property

Shape(TColor, TImage).LinePattern Property
[image]

Gets the style of the shape's line.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public int LinePattern { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinePattern As Integer

Property Value

An integer value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineRounding Property

Shape(TColor, TImage).LineRounding Property
[image]

Gets the rounding factor of the contour joints of the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double LineRounding { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineRounding As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LineWeight Property

Shape(TColor, TImage).LineWeight Property
[image]

Gets the thickness of the shape's line.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double LineWeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineWeight As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LocPinX Property

Shape(TColor, TImage).LocPinX Property
[image]

Gets the x-coordinate, expressed in inches, of the point used as the transformation center.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double LocPinX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LocPinX As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).LocPinY Property

Shape(TColor, TImage).LocPinY Property
[image]

Gets the y-coordinate, expressed in inches, of the point used as the transformation center.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double LocPinY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LocPinY As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Parent Property

Shape(TColor, TImage).Parent Property
[image]

Gets the shape parent.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Shape<TColor, TImage> Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As Shape(Of TColor, TImage)

Property Value

An instance of the Shape(TColor, TImage) class.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).PinX Property

Shape(TColor, TImage).PinX Property
[image]

Gets the x-coordinate of the shape, expressed in inches, relative to its parent.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double PinX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PinX As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).PinY Property

Shape(TColor, TImage).PinY Property
[image]

Gets the y-coordinate of the shape, expressed in inches, relative to its parent.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double PinY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PinY As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Properties Property

Shape(TColor, TImage).Properties Property
[image]

Gets the properties associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IDictionary<string, Property> Properties { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Properties As IDictionary(Of String, Property)

Property Value

A map between the shape properties and their names.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).ScratchValues Property

Shape(TColor, TImage).ScratchValues Property
[image]

Gets the "scratch" values associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IList<GeometryStorage> ScratchValues { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScratchValues As IList(Of GeometryStorage)

Property Value

A list of GeometryStorage objects.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Shapes Property

Shape(TColor, TImage).Shapes Property
[image]

Gets a list with the subordinate shapes.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public List<Shape<TColor, TImage>> Shapes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shapes As List(Of Shape(Of TColor, TImage))

Property Value

A list of Shape(TColor, TImage) objects.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Text Property

Shape(TColor, TImage).Text Property
[image]

Gets the shape's text.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Text { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Text As String

Property Value

A string value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).UserValues Property

Shape(TColor, TImage).UserValues Property
[image]

Gets the user values associated with the shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public IDictionary<string, UserValue> UserValues { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property UserValues As IDictionary(Of String, UserValue)

Property Value

A map between the shape user values and their names.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Shape(TColor, TImage).Width Property

Shape(TColor, TImage).Width Property
[image]

Gets or sets the width of the shape, expressed in inches.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value.

See Also

Shape(TColor, TImage) Members
Shape(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage) Class

Stencil(TColor, TImage) Class
[image]

Represents a Visio stencil.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class Stencil<TColor, TImage> where TColor : ValueType

Visual Basic [image] Copy Code

Public Class Stencil(Of TColor As ValueType, TImage)

Inheritance Hierarchy

System.Object
MindFusion.Vsx.Stencil(TColor, TImage)

See Also

Stencil(TColor, TImage) Members
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage) Members

Stencil(TColor, TImage) Members
Constructors Properties Methods
[image]

Represents a Visio stencil.

The following tables list the members exposed by the Stencil(TColor, TImage) type.

Public Constructors

Name | Description
Stencil | Initializes a new instance of the Stencil class.

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.
MastersByName | Gets a list with all masters in the stencil, mapped by name.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads the stencil from an XML or a binary stream.
LoadFromXml | Loads the Visio stencil from the file with the specified name.
SaveTo | Overloaded. Saves the stencil to an XML or a binary stream.

See Also

Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage) Constructor

Stencil(TColor, TImage) Constructor
[image]

Initializes a new instance of the Stencil class.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Stencil<TColor, TImage> (
IPlatformHelper<TColor, TImage> platformHelper
)

Visual Basic [image] Copy Code

Public New (Of TColor, TImage) ( _
platformHelper As IPlatformHelper(Of TColor, TImage) _
)

Parameters

platformHelper

An object implementing the IPlatformHelper interface.

See Also

Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage) Methods

Stencil(TColor, TImage) Methods
[image]

Public Methods

Name | Description
LoadFrom | Overloaded. Loads the stencil from an XML or a binary stream.
LoadFromXml | Loads the Visio stencil from the file with the specified name.
SaveTo | Overloaded. Saves the stencil to an XML or a binary stream.

See Also

Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).LoadFrom Method

Stencil(TColor, TImage).LoadFrom Method
[image]

Loads the stencil from an XML or a binary stream.

Overload List

Name | Description
Stencil(TColor, TImage).LoadFrom (BinaryReader) | Loads the stencil from the stream identified by the specified reader.
Stencil(TColor, TImage).LoadFrom (XmlElement) | Loads the stencil from the specified XML element.

See Also

Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).LoadFrom Method (BinaryReader)

Stencil(TColor, TImage).LoadFrom Method (BinaryReader)
See Also
[image]

Loads the stencil from the stream identified by the specified reader.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
reader As BinaryReader _
)

Parameters

reader

The BinaryReader to read from.

See Also

LoadFrom Method Overload List
Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).LoadFrom Method (XmlElement)

Stencil(TColor, TImage).LoadFrom Method (XmlElement)
See Also
[image]

Loads the stencil from the specified XML element.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void LoadFrom (
XmlElement element
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
element As XmlElement _
)

Parameters

element

The XML element to load from.

See Also

LoadFrom Method Overload List
Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).LoadFromXml Method

Stencil(TColor, TImage).LoadFromXml Method
[image]

Loads the Visio stencil from the file with the specified name.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void LoadFromXml (
string filePath
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
filePath As String _
)

Parameters

filePath

The file containing the stencil to load.

See Also

Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).SaveTo Method

Stencil(TColor, TImage).SaveTo Method
[image]

Saves the stencil to an XML or a binary stream.

Overload List

Name | Description
Stencil(TColor, TImage).SaveTo (BinaryWriter) | Saves the stencil to the stream identified by the specified writer.
Stencil(TColor, TImage).SaveTo (XmlElement) | Saves the stencil to the specified XML element.

See Also

Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).SaveTo Method (BinaryWriter)

Stencil(TColor, TImage).SaveTo Method (BinaryWriter)
See Also
[image]

Saves the stencil to the stream identified by the specified writer.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

The BinaryWriter to write to.

See Also

SaveTo Method Overload List
Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).SaveTo Method (XmlElement)

Stencil(TColor, TImage).SaveTo Method (XmlElement)
See Also
[image]

Saves the stencil to the specified XML element.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public void SaveTo (
XmlElement element
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
element As XmlElement _
)

Parameters

element

The XML element to save to.

See Also

SaveTo Method Overload List
Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage) Properties

Stencil(TColor, TImage) Properties
[image]

Public Properties

Name | Description
Masters | Gets a list with all masters in this stencil.
MastersByName | Gets a list with all masters in the stencil, mapped by name.

See Also

Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).Masters Property

Stencil(TColor, TImage).Masters Property
[image]

Gets a list with all masters in this stencil.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public List<Master<TColor, TImage>> Masters { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Masters As List(Of Master(Of TColor, TImage))

Property Value

A list of Master(TColor, TImage) objects.

See Also

Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.Stencil(TColor, TImage).MastersByName Property

Stencil(TColor, TImage).MastersByName Property
[image]

Gets a list with all masters in the stencil, mapped by name.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Dictionary<string, Master<TColor, TImage>> MastersByName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MastersByName As Dictionary(Of String, Master(Of TColor, TImage))

Property Value

A map between the master shapes and their names.

See Also

Stencil(TColor, TImage) Members
Stencil(TColor, TImage) Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue Class

UserValue Class
Remarks See Also
[image]

Represents a user value in a Visio shape.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public class UserValue

Visual Basic [image] Copy Code

Public Class UserValue

Remarks

Instances of this class can be obtained through the UserValues collection of the Shape obects.

Inheritance Hierarchy

System.Object
MindFusion.Vsx.UserValue

See Also

UserValue Members
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue Members

UserValue Members
Constructors Properties Methods
[image]

Represents a user value in a Visio shape.

The following tables list the members exposed by the UserValue type.

Public Constructors

Name | Description
UserValue |

Public Properties

Name | Description
Id | Gets the user value identifier.
Name | Gets the name of the user value.
Value | Gets or sets the actual value of the user value.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue Constructor

UserValue Constructor
[image]

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public UserValue ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue Methods

UserValue Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue.ToString Method

UserValue.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string that represents the current object.

See Also

UserValue Members
UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue Properties

UserValue Properties
[image]

Public Properties

Name | Description
Id | Gets the user value identifier.
Name | Gets the name of the user value.
Value | Gets or sets the actual value of the user value.

See Also

UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue.Id Property

UserValue.Id Property
[image]

Gets the user value identifier.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Nullable<Int32> Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Nullable(Of Int32)

Property Value

See Also

UserValue Members
UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue.Name Property

UserValue.Name Property
[image]

Gets the name of the user value.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

UserValue Members
UserValue Class
MindFusion.Vsx Namespace


MindFusion.Vsx.UserValue.Value Property

UserValue.Value Property
[image]

Gets or sets the actual value of the user value.

Namespace: MindFusion.Vsx
Assembly: MindFusion.Vsx

Syntax

C# [image] Copy Code

public Object Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Object

Property Value

See Also

UserValue Members
UserValue Class
MindFusion.Vsx Namespace


Online Resources

Online Resources

Diagramming

Video Tutorials

  • How to set up the WPF diagram control
  • Create a custom diagram shape

Blog Posts

  • PERT network charts in WPF
  • Combine layout algorithms I [image] (use OrthogonalLayout to generate initial placement for SpringLayout)
  • Combine layout algorithms II [image] (apply TreeLayout twice to arrange a genealogy tree)
  • Combine layout algorithms III [image] (apply FractalLayout and SpringLayout to generate a tag cloud)
  • Create a dialogue editor using MindFusion diagram
  • Display Petri nets using MindFusion diagram component
  • Create diagram connectors using drag and drop
  • Visualize graph algorithms using MindFusion diagram component
  • Database schema diagram
  • ContainerNode fold / unfold animations
  • Create a musical score writer using MindFusion diagram component

Scheduling

Blog Posts

  • Custom items in WPF Calendar
  • Implementing drag & drop in MindFusion.Scheduling for WPF
  • Custom appearance of WPF Resource view

Charting

Video Tutorials

  • The Real-time Chart Control in WPF
  • A demonstration of the ability of the WPF chart control to support unlimited number of X, X2, Y and Y2 axes

Blog Posts

  • Build and Customize a Real Time Line Chart
  • Real-time Chart: Amplification Plot
  • A Bar Chart With Multiple Axes and a Legend in WPF
  • Line Chart With Multiple Axes in WPF
  • Drill Down Chart in WPF

Mapping

The following websites host free map files in ESRI Shapefile format:

Natural Earth
http://www.naturalearthdata.com

U.S. Census Bureau
http://www.census.gov/geo/www/cob/bdy_files.html

Map Library
http://www.maplibrary.org/

MapCruzin
http://www.mapcruzin.com/download-free-arcgis-shapefiles.htm

OpenStreetMap Shapefiles
http://wiki.openstreetmap.org/wiki/Shapefiles

UN Second Administrative Level Boundaries
http://www.unsalb.org/

Centers for Disease Control and Prevention
http://wwwn.cdc.gov/epiinfo/script/shapefiles.aspx

Free Spatial Data as DIVA-GIS
http://www.diva-gis.org/Data

MindFusion Tutorials and Blog Posts on How to Use the Control:

  • Custom Colors in Maps


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question about the components contained in the MindFusion Pack for WPF on the discussion boards:

MindFusion.Charting for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=wpfchart_disc
MindFusion.DataViews for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=scheduling_wpf
MindFusion.Diagramming for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=wpfdg_disc
MindFusion.Reporting for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=reporting_wpf_disc
MindFusion.Scheduling for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=scheduling_wpf
MindFusion.UI for WPF | http://mindfusion.eu/Forum/YaBB.pl?board=uiwpf_disc

or visit our help desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion Pack for WPF. We do take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download
Diagramming for Xamarin | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download
Charting for JavaScript | Product Information Download
Charting for Xamarin | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download
Scheduling for Xamarin | Product Information Download
Scheduling for JavaScript | Product Information Download

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download
Spreadsheet for Java Swing | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download
Pack for Diagramming | Product Information Download


Acknowledgements

Acknowledgements

Copyright (c) 2000,2001,2002,2003 ymnk, JCraft,Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in
the documentation and/or other materials provided with the distribution.

3. The names of the authors may not be used to endorse or promote products
derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL JCRAFT,
INC. OR ANY CONTRIBUTORS TO THIS SOFTWARE BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Calendar Tutorials

Calendar Tutorials


ADDRESS

ADDRESS

Returns the address of a cell with the specified column and row as text.

Syntax [image] Copy Code

ADDRESS( Integer row, Integer column, [Integer abs = 1], [Logical a1 = TRUE], [Text sheet] ) → Text

Parameters

row
Required. A numeric value that specifies the row number to use in the cell reference.
column
Required. A numeric value that specifies the column number to use in the cell reference.
abs
Optional. A numeric value that specifies the type of reference to return:
  • 1 (or omitted) - Absolute
  • 2 - Absolute row; relative column
  • 3 - Relative row; absolute column
  • 4 - Relative
a1
Optional. A logical value that specifies the A1 or R1C1 reference style. In A1 style, columns are labeled alphabetically, and rows are labeled numerically. In R1C1 reference style, both columns and rows are labeled numerically. If the a1 argument is TRUE (or omitted), the ADDRESS function returns an A1-style reference; if FALSE, the ADDRESS function returns an R1C1-style reference.
sheet
Optional. A text value that specifies the name of the worksheet to be used as the external reference. If the sheet argument is omitted, no sheet name is used.

Example

Formula [image] Copy Code

=ADDRESS(3,5)
=ADDRESS(3,5,2,FALSE)
=ADDRESS(3,5,,,"My Sheet")

See Also

Function Reference
INDIRECT Function


AND

AND

Returns TRUE if all of the specified arguments evaluate to TRUE; returns FALSE if one or more of the arguments evaluate to FALSE.

Syntax [image] Copy Code

AND( Logical l1, [Logical l2], ... ) → Logical

Parameters

l1
l2
…
One or more logical values to test.

Remarks

The arguments must evaluate to logical values or arrays of logical values. If the specified range contains an argument that does not meet this requirement, the AND function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=AND(A1)
=AND(B1:B5,A1>0)

See Also

Function Reference
OR Function
IF Function


ARABIC

ARABIC

Converts the specified Roman numeral to an Arabic numeral.

Syntax [image] Copy Code

ARABIC( Text t ) → Number

Parameters

t
Required. A string value to be converted.

Remarks

If t is not a valid value, ARABIC returns the #VALUE! error value. If text is an empty string, returns 0.

See Also

Function Reference
ROMAN Function


ATAN

ATAN

Returns the arctangent, or inverse tangent, of the specified number. The arctangent is the angle whose tangent is the specified number. The returned angle is given in radians in the range [-π/2…π/2].

Syntax [image] Copy Code

ATAN( Number n ) → Number

Parameters

n
Required. A number representing a tangent.

Remarks

To express the arctangent in degrees, multiply the result by 180/PI or use the DEGREES function.

Example

Formula [image] Copy Code

=ATAN(1)
=ATAN(1)*180/PI()

See Also

Function Reference
ATAN2 Function
TAN Function
PI Function
RADIANS Function
DEGREES Function


ATAN2

ATAN2

Returns the arctangent, or inverse tangent, of the specified x-coordinates and y-coordinates. The arctangent is the angle from the x-axis to a line containing the origin (0, 0) and a point with the specified coordinates. The angle is given in radians between (-π…π].

Syntax [image] Copy Code

ATAN2( Number x, Number y ) → Number

Parameters

x
Required. The x-coordinate of the point.
y
Required. The y-coordinate of the point.

Remarks

To express the arctangent in degrees, multiply the result by 180/PI or use the DEGREES function.

Example

Formula [image] Copy Code

=ATAN2(1,1)
=ATAN2(1,1)*180/PI()

See Also

Function Reference
ATAN Function
TAN Function
PI Function
RADIANS Function
DEGREES Function


ATANH

ATANH

Returns the inverse hyperbolic tangent of the specified number. The inverse hyperbolic tangent is the value whose hyperbolic tangent is n, so ATANH(TANH(n)) equals n.

Syntax [image] Copy Code

ATANH( Number n ) → Number

Parameters

n
Required. The number whose inverse hyperbolic tangent to find, in the range (-1…1).

Example

Formula [image] Copy Code

=ATANH(0.1)
=ATANH(-0.5)

See Also

Function Reference
ATAN Function
TANH Function


AVERAGE

AVERAGE

Returns the average of the specified arguments.

Syntax [image] Copy Code

AVERAGE( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers to average.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. The specified arguments must contain at least one number or the function will return the #DIV/0! error value.

Example

Formula [image] Copy Code

=AVERAGE(A1:A10)
=AVERAGE(A1:A10,50)

See Also

Function Reference
SUM Function
COUNT Function


AVERAGEIF

AVERAGEIF

Returns the average of the specified arguments.

Syntax [image] Copy Code

AVERAGEIF( Reference range, Criterion criteria, [Reference averageRange] ) → Number

Parameters

range
Required. One or more cells to average.
criteria
Required. A number or text value that defines which cells to average. For example, ">10", "products", "5".
averageRange
Optional. The actual cells to average. If omitted, range is used.

Remarks

The range arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. The specified arguments must contain at least one number that satisfies the criteria or the function will return the #DIV/0! error value.

Example

Formula [image] Copy Code

=AVERAGEIF(A1:A5,"<18000")

See Also

Function Reference
AVERAGE Function
SUM Function
COUNT Function


BASE

BASE

Converts the specified number into a text representation with the give base.

Syntax [image] Copy Code

BASE( Integer x, Integer radix, [Integer minimumLength] ) → Text

Parameters

x
Required. The number to convert. Must be an integer greater than 0.
radix
Required. The base radix to convert the number to. Must be an integer in the range [2…36].
minimumLength
Optional. The minimum length of the returned string. Must be a non-negative integer.

Remarks

If any of the arguments violates its constraints, BASE returns the #NUM! error value. If the specified values are not integer, they are automatically truncated. If the minimumLength argument is specified, leading zeros are added to the result if the result would otherwise be shorter than the specified minimum length. For example, BASE(8,2) returns 1000, but BASE(8,2,8) returns 00001000.

Example

Formula [image] Copy Code

=BASE(4,2)
=BASE(4,2,8)
=BASE(1000,16)

See Also

Function Reference
DECIMAL Function


BIN2DEC

BIN2DEC

Converts the specified binary (base 2) number to its decimal equivalent.

Syntax [image] Copy Code

BIN2DEC( NumberOrText x ) → Number

Parameters

x
Required. The binary number to convert, expressed as either text or number. This value should not contain more than 10 characters.

Remarks

If x is not a valid binary number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=BIN2DEC(100100)
=BIN2DEC("1101001")

See Also

Function Reference
BIN2HEX Function
BIN2OCT Function
DEC2BIN Function
HEX2BIN Function
OCT2BIN Function


BIN2HEX

BIN2HEX

Converts the specified binary (base 2) number to its hexadecimal equivalent.

Syntax [image] Copy Code

BIN2HEX( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The binary number to convert, expressed as either text or number. This value should not contain more than 10 characters.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid binary number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

If digits is omitted, the function uses the minimum number of characters necessary to represent the result. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=BIN2HEX(100100)
=BIN2HEX("1101001")

See Also

Function Reference
BIN2DEC Function
BIN2OCT Function
DEC2BIN Function
HEX2BIN Function
OCT2BIN Function


BIN2OCT

BIN2OCT

Converts the specified binary (base 2) number to its octal (base 8) equivalent.

Syntax [image] Copy Code

BIN2OCT( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The binary number to convert, expressed as either text or number. This value should not contain more than 10 characters.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid binary number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

If digits is omitted, the function uses the minimum number of characters necessary to represent the result. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=BIN2OCT(100100)
=BIN2OCT("1101001")

See Also

Function Reference
BIN2DEC Function
BIN2HEX Function
DEC2HEX Function
HEX2BIN Function
OCT2BIN Function


BITAND

BITAND

Returns the bitwise 'AND' of the specified numbers.

Syntax [image] Copy Code

BITAND( Integer x, Integer y ) → Integer

Parameters

x
Required. The first argument of the operation. Must be greater than or equal to zero.
y
Required. The second argument of the operation. Must be greater than or equal to zero.

Remarks

This function calculates the bitwise 'AND' of its arguments, that is, the value of each bit position is 1 only if both parameter's bits at that position are 1.

If either argument is less than 0 or greater than or equal to (2^48), BITAND returns the #NUM! error value. If an argument is not an integer number, the argument is converted automatically.

Example

Formula [image] Copy Code

=BITAND(5,4)
=BITAND(100,11)

See Also

Function Reference
BITOR Function
BITXOR Function
AND Function


BITLSHIFT

BITLSHIFT

Returns the value of the specified argument shifted to the left by the specified number of bits.

Syntax [image] Copy Code

BITLSHIFT( Integer x, Integer bits ) → Integer

Parameters

x
Required. The number to shift. Must be greater than or equal to zero.
bits
Required. The number of bits to shift.

Remarks

Shifting a number to the left is equivalent to adding zeros to the right of the binary representation of the number. For example, shifting the number 3 to the left by two bits, converts the binary value of 3 (11) to 1100, or 12 in decimal.

If any of the arguments violates its constraints, BITLSHIFT returns the #NUM! error value. If the specified values are not integer, they are automatically converted. If bits is negative, the function shifts the specified number to the right instead.

Example

Formula [image] Copy Code

=BITLSHIFT(3,2)

See Also

Function Reference
BITAND Function
BITXOR Function
BITRSHIFT Function


BITOR

BITOR

Returns the bitwise 'OR' of the specified numbers.

Syntax [image] Copy Code

BITOR( Integer x, Integer y ) → Integer

Parameters

x
Required. The first argument of the operation. Must be greater than or equal to zero.
y
Required. The second argument of the operation. Must be greater than or equal to zero.

Remarks

This function calculates the bitwise 'OR' of its arguments, that is, the value of each bit position is 1 if at least one of the parameter's bits at that position is 1.

If either argument is less than 0 or greater than or equal to (2^48), BITOR returns the #NUM! error value. If an argument is not an integer number, the argument is converted automatically.

Example

Formula [image] Copy Code

=BITOR(5,4)
=BITOR(100,11)

See Also

Function Reference
BITAND Function
BITXOR Function
AND Function


BITRSHIFT

BITRSHIFT

Returns the value of the specified argument shifted to the right by the specified number of bits.

Syntax [image] Copy Code

FUNC( Integer x, Integer bits ) → Integer

Parameters

x
Required. The number to shift. Must be greater than or equal to zero.
bits
Required. The number of bits to shift.

Remarks

Shifting a number to the right is equivalent to removing digits from the rightmost side of the binary representation of the number. For example, shifting the number 14 to the right by one bit, converts the binary value of 14 (1110) to 111, or 7 in decimal.

If any of the arguments violates its constraints, BITRSHIFT returns the #NUM! error value. If the specified values are not integer, they are automatically converted. If bits is negative, the function shifts the specified number to the left instead.

Example

Formula [image] Copy Code

=BITRSHIFT(43,2)

See Also

Function Reference
BITAND Function
BITXOR Function
BITLSHIFT Function


BITXOR

BITXOR

Returns the bitwise 'XOR' of the specified numbers.

Syntax [image] Copy Code

BITXOR( Integer x, Integer y ) → Integer

Parameters

x
Required. The first argument of the operation. Must be greater than or equal to zero.
y
Required. The second argument of the operation. Must be greater than or equal to zero.

Remarks

This function calculates the bitwise 'XOR' of its arguments, that is, the value of each bit position is 1 if the values of the parameters at that bit position are not equal; in other words, one of the bits is 0 and the other is 1.

If either argument is less than 0 or greater than or equal to (2^48), BITXOR returns the #NUM! error value. If an argument is not an integer number, the argument is converted automatically.

Example

Formula [image] Copy Code

=BITXOR(5,4)
=BITXOR(100,11)

See Also

Function Reference


MindFusion.Diagramming.Wpf.Import.DrawImporter Constructor

DrawImporter Constructor
[image]

Initializes a new instance of the DrawImporter class.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public DrawImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Constructor

Visio2013Importer Constructor
[image]

Initializes a new instance of the Visio2013Importer class.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public Visio2013Importer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Constructor

VisioImporter Constructor
[image]

Initializes a new instance of the VisioImporter class.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public VisioImporter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Geometry2D.Polygon Constructor (IEnumerable(Point))

Polygon Constructor (IEnumerable(Point))
See Also
[image]

Initializes a new instance of the Polygon class from the specified collection of points.

Namespace: MindFusion.Geometry2D
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public Polygon (
IEnumerable<Point> points
)

Visual Basic [image] Copy Code

Public New ( _
points As IEnumerable(Of Point) _
)

Parameters

points

See Also

Polygon Class
MindFusion.Geometry2D Namespace


MindFusion.RealTimeCharting.Wpf.Axis Constructor

Axis Constructor
[image]

Initializes a new instance of the Axes class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisEventArgs Constructor

AxisEventArgs Constructor
[image]

Initializes a new instance of the AxisEventArgs class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public AxisEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxisEventArgs Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Constructor

AxisRenderer Constructor
[image]

Initializes a new instance of the AxisRenderer class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public AxisRenderer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter Constructor

ChartToLegendVisibilityConverter Constructor
[image]

Initializes a new instance of the ChartToLegendVisibilityConverter class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public ChartToLegendVisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartToLegendVisibilityConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter Constructor

DoubleToGridLengthConverter Constructor
[image]

Initializes a new instance of the DoubleToGridLengthConverter.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public DoubleToGridLengthConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DoubleToGridLengthConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter Constructor

DoubleToThicknessConverter Constructor
[image]

Initializes a new instance of the DoubleToThicknessConverter class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public DoubleToThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DoubleToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult Constructor

HitTestResult Constructor
[image]

Initializes a new instance of the HitTestResult class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public HitTestResult ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend Constructor

Legend Constructor
[image]

Initializes a new instance of the Legend class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Legend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Constructor

LegendSymbolRenderer Constructor
[image]

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public LegendSymbolRenderer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Constructor

PlotArea Constructor
[image]

Initializes a new instance of the PlotArea class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public PlotArea ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter Constructor

PointToStringConverter Constructor
[image]

Initializes a new instance of the PointToStringConverter class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public PointToStringConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PointToStringConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter Constructor

PointToThicknessConverter Constructor
[image]

Initializes a new instance of the PointToThicknessConverter class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public PointToThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PointToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Constructor

RealTimeChart Constructor
[image]

Initializes a new instance of the RealTimeChart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public RealTimeChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Constructor

Series Constructor
[image]

Initializes a new instance of the Series class bound to the specified Y-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Series (
Axis yAxis
)

Visual Basic [image] Copy Code

Public New ( _
yAxis As Axis _
)

Parameters

yAxis

The Y-axis this Series is bound to.

See Also

Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesCollection Constructor

SeriesCollection Constructor
[image]

Initializes a new instance of the SeriesCollection class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public SeriesCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SeriesCollection Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter Constructor

SeriesToGeometryConverter Constructor
[image]

Initializes a new instance of the SeriesToGeometryConverter class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public SeriesToGeometryConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SeriesToGeometryConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell Constructor

UniformStackPanell Constructor
[image]

Initializes a new instance of the UniformStackPanell class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public UniformStackPanell ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

UniformStackPanell Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.YAxisCollection Constructor

YAxisCollection Constructor
[image]

Initializes a new instance of the YAxisCollection class.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public YAxisCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

YAxisCollection Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.CompileOptions Constructor

CompileOptions Constructor
[image]

Initializes a new instance of the CompileOptions class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public CompileOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Constructor

EvaluateFunctionEventArgs Constructor
[image]

Initializes a new instance of the EvaluateFunctionEventArgs class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluateFunctionEventArgs (
string name,
Object[] arguments,
Object param
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
arguments() As Object, _
param As Object _
)

Parameters

name

The name of the function.

arguments

The list of arguments to pass to the function.

param

An object that should be passed as an argument to the function evaluation callback.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor (Object)

EvaluationContext Constructor (Object)
See Also
[image]

Initializes a new instance of the EvaluationContext class for the specified object.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluationContext (
Object target
)

Visual Basic [image] Copy Code

Public New ( _
target As Object _
)

Parameters

target
The target object of the byte code evaluation.

Remarks

The target is used when evaluating identifiers within the expression. If an identifier is not recognized as local variable or a predefined keyword, the identifier is tested as a property against the target object. In addition the keyword this is also evaluated to the target object.

See Also

EvaluationContext Constructor Overload List
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor (Object, CultureInfo)

EvaluationContext Constructor (Object, CultureInfo)
See Also
[image]

Initializes a new instance of the EvaluationContext class for the specified object and culture.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public EvaluationContext (
Object target,
CultureInfo cultureInfo
)

Visual Basic [image] Copy Code

Public New ( _
target As Object, _
cultureInfo As CultureInfo _
)

Parameters

target

The target object of the byte code evaluation.

cultureInfo
The culture associated with the context.

Remarks

The target is used when evaluating identifiers within the expression. If an identifier is not recognized as local variable or a predefined keyword, the identifier is tested as a property against the target object. In addition the keyword this is also evaluated to the target object.

See Also

EvaluationContext Constructor Overload List
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Constructor

ParseObjectEventArgs Constructor
[image]

Initializes a new instance of the ParseObjectEventArgs class.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public ParseObjectEventArgs (
string valueAsString
)

Visual Basic [image] Copy Code

Public New ( _
valueAsString As String _
)

Parameters

valueAsString

The string representation of the object to parse.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


Calendar Overview

Calendar Overview

The MindFusion.Scheduling for WPF API is divided in two major parts, implemented in different .NET namespaces. The schedule data is represented by instances of the Schedule class and the helper Appointment, Task, Location, Contact and Resource classes, implemented in the MindFusion.Scheduling namespace. The calendar views are implemented by the Calendar class in the MindFusion.Scheduling.Wpf namespace.


MindFusion.Scheduling.Appointment.LoadFrom Method

Appointment.LoadFrom Method
[image]

Overload List

Name | Description
Appointment.LoadFrom (XmlElement, XmlSerializationContext) | Loads appointment data from an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SaveTo Method

Appointment.SaveTo Method
[image]

Overload List

Name | Description
Appointment.SaveTo (XmlElement, XmlSerializationContext) | Saves the appointment data to an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method

Resource.LoadFrom Method
[image]

Overload List

Name | Description
Resource.LoadFrom (XmlElement, XmlSerializationContext) | Loads resource data from an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.SaveTo Method

Resource.SaveTo Method
[image]

Overload List

Name | Description
Resource.SaveTo (XmlElement, XmlSerializationContext) | Saves the resource data to an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion Namespace

MindFusion Namespace
Enumerations

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of contents relative to the layout rectangle.


MindFusion.Layout.Layout3D Namespace

MindFusion.Layout.Layout3D Namespace
Enumerations

Enumerations

Enumeration | Description
Surface | Contains values specifying the type of surface on which nodes are initially placed when running 3D SpringLayout.


MindFusion.Layout.Layout3D.Surface Enumeration

Surface Enumeration
[image]

Contains values specifying the type of surface on which nodes are initially placed when running 3D SpringLayout.

Namespace: MindFusion.Layout.Layout3D
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public enum Surface

Visual Basic [image] Copy Code

Public Enum Surface

Members

Member name | Description
Cone | The nodes are initially placed on a cone.
Cylinder | The nodes are initially placed on a cylinder.
Sphere | The nodes are initially placed on a sphere.
Unspecified | The nodes are initially placed on a sphere.

See Also

MindFusion.Layout.Layout3D Namespace


MindFusion.Scheduling.BinarySerializationContext Events

BinarySerializationContext Events
[image]

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully. (Inherited from SerializationContext.)

See Also

BinarySerializationContext Class
MindFusion.Scheduling Namespace


CEILING

CEILING

Rounds the specified number up, away from zero, to the nearest multiple of the specified value.

Syntax [image] Copy Code

CEILING( Number n, [Number significance], [Integer mode = 0] ) → Number

Parameters

n
Required. The value to round.
significance
Optional. The multiple to which to round.
mode
Optional. The type of ceiling to perform (see Remarks).

Remarks

If n and significance are not 0 and have different signs, the function returns the #NUM! error value.

If significance is omitted or an empty parameter (two consecutive commas) it is assumed to be -1 if n is negative and +1 if n is non-negative, making the function act like the normal mathematical ceiling function, if mode is not given or zero. If mode is given and not zero, the absolute value of n is rounded away from zero to a multiple of the absolute value of significance and then the sign is applied. If mode is omitted or zero, rounding is toward positive infinity, the number is rounded to the smallest multiple of significance that is equal to or greater than n. If the specified mode value is not an integer, it is automatically truncated.

If any of the two parameters n or significance is zero, the result is zero.

Example

Formula [image] Copy Code

=CEILING(3.5,1)
=CEILING(0.123,0.01)
=CEILING(-3.5,-1)
=CEILING(-3.5,-1,1)

See Also

Function Reference
FLOOR Function
INT Function
ROUND Function
ROUNDDOWN Function
ROUNDUP Function
TRUNC Function
EVEN Function
ODD Function


CHAR

CHAR

Returns the character represented by the specified numeric value.

Syntax [image] Copy Code

CHAR( Integer n ) → Text

Parameters

n
Required. A number between 1 and 255, inclusive, specifying the code of the character.

Remarks

If n is not an integer number, it is automatically converted.

Example

Formula [image] Copy Code

=CHAR(68)
=CHAR(35)

See Also

Function Reference
CODE Function


Charts

Charts

This section contains topics describing in details the individual chart controls and their features.


CHOOSE

CHOOSE

Returns a value from the specified list of values based on the specified index.

Syntax [image] Copy Code

CHOOSE( Integer index, Any value1, [Any value2], ... ) → Any

Parameters

index
Required. The index of the value to return. Must be greater than zero.
value1
value2
…
One or more values from which CHOOSE selects based on index.

Remarks

If index is 1, CHOOSE returns value1, if index is 2, CHOOSE returns value2, and so on. The values of parameters other than index and the one chosen are not evaluated for side effects, that is, this function short-circuits.

If index is less than zero or greater than the number of values passed as parameters, CHOOSE returns the #VALUE! error value. If index is not an integer value, it is automatically truncated.

Example

Formula [image] Copy Code

=SUM(CHOOSE(2,A1:A5,B1:B5,C1:C5))

See Also

Function Reference
IF Function
INDEX Function


CODE

CODE

Returns the numeric value corresponding to the first character of the specified text value.

Syntax [image] Copy Code

CODE( Text text ) → Integer

Parameters

text
Required. The text for which to return the code of the first character.

Remarks

If text is empty, that is, contains no characters, the function returns zero.

Example

Formula [image] Copy Code

=CODE("M")
=CODE("Text")

See Also

Function Reference
CHAR Function


COLUMN

COLUMN

Returns the column number or numbers of the specified cell reference.

Syntax [image] Copy Code

COLUMN( [Reference r] ) → IntegerOrArray

Parameters

r
Optional. The cell or range of cells for which to return the column number.

Remarks

This function returns the number of a cell column. For example, the function returns 1 for column A, 2 for column B, and so on.

If r is omitted, the function returns the column number of the current cell. If r identifies a range of cells with width greater than 1, COLUMN returns an array containing the numbers of all columns included in the range. For example, COLUMN(A1:C2) returns the array {1, 2, 3}.

Example

Formula [image] Copy Code

=COLUMN()
=COLUMN(A1:C2)

See Also

Function Reference
ROW Function
SHEET Function


COLUMNS

COLUMNS

Returns the number of columns in the specified range or array.

Syntax [image] Copy Code

COLUMNS( ReferenceOrArray r ) → Integer

Parameters

r
Required. A reference to a range of cells or an array for which to return the number of columns.

Example

Formula [image] Copy Code

=COLUMNS(A1:E4)
=COLUMNS({1;2;3|4;5;6})

See Also

Function Reference
ROWS Function


COMBIN

COMBIN

Returns the number of combinations for the specified number of items.

Syntax [image] Copy Code

COMBIN( Integer n, Integer k ) → Integer

Parameters

n
Required. The total number of objects. Must be a positive number.
k
Required. The number of objects in each combination. Must be a positive number.

Remarks

A combination is any set or subset of items, regardless of their internal order. Combinations are distinct from permutations, for which the internal order is significant. The number of combinations is n!/k!/(n-k)! where ! denotes factorial.

If n is less than k, or either n or k are negative or zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=COMBIN(49,6)

See Also

Function Reference
FACT Function
PERMUT Function


CONCATENATE

CONCATENATE

Joins the specified text values into a single text value.

Syntax [image] Copy Code

CONCATENATE( [Text text1], [Text text2], ... ) → Text

Parameters

text1
text2
…
Zero or more text items to be joined into a single text value.

Remarks

If there are no arguments provided, the function returns an empty text value.

The "&" operator can be used instead of CONCATENATE to join text items.

Example

Formula [image] Copy Code

=CONCATENATE("The date and time is ",NOW())

See Also

Function Reference


DATE

DATE

Constructs a date from the specified year, month and day of the month.

Syntax [image] Copy Code

DATE( Integer year, Integer month, Integer day ) → Date

Parameters

year
Required. The value of the year argument.
month
Required. An integer representing the month of the year from 1 to 12 (January to December).
day
Required. An integer specifying the day of the month from 1 to 31.

Remarks

This method computes the date's serial number given a year, a month, and a day of the Gregorian calendar. Fractional values are automatically truncated. If month is greater than 12 and day is greater than the days of month, the resulting date will be computed by rolling over to the next month or year as necessary. If month or day are negative, their magnitude is subtracted from the first month of the specified year or the first day of the specified month.

If the result is displayed in a cell with Format set to General, the value will be formatted as a date. To see the value as a serial number, set the format of the cell to one of the numeric formats.

Example

Formula [image] Copy Code

=DATE(2013,1,1)
=DATE(YEAR(TODAY()),1,10)

See Also

Function Reference
TIME Function


DATEDIF

DATEDIF

Returns the difference in years, months, or days between the specified dates.

Syntax [image] Copy Code

DATEDIF( Date startDate, Date endDate, Text unit ) → Number

Parameters

startDate
Required. The start date of the interval.
endDate
Required. The end date of the interval.
unit
Required. A string value specifying the type of information returned.

Remarks

The following table lists the possible values for the unit parameter:

Unit | Returns
"Y" | The number of complete calendar years in the period.
"M" | The number of complete months in the period.
"D" | The number of complete days in the period.
"MD" | The number of days from startDate to endDate. The months and years of the dates are ignored.
"YM" | The number of months from the month of startDate to the month of endDate. The days and years of the dates are ignored.
"YD" | The number of days from startDate to endDate. The years of the dates are ignored.

Example

Formula [image] Copy Code

=DATEDIF(DATE(2000,1,1),TODAY(),"d")

See Also

Function Reference
DAYS Function
DAYS360 Function


DAVERAGE

DAVERAGE

Returns the average of the values in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DAVERAGE( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The formula to evaluate the average quantity of beverages with price over 10 is given below:

Formula [image] Copy Code

=DAVERAGE(A4:E10,"Qty",B1:C2)

See Also

Function Reference
DGET Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DB

DB

Returns the depreciation allowance of an asset for the specified period using the fixed-declining balance method.

Syntax [image] Copy Code

DB( Number cost, Number salvage, Integer lifeTime, Number period, [Number month = 12] ) → Currency

Parameters

cost
Required. The initial cost of the asset. Must be greater than zero.
salvage
Required. The value at the end of the depreciation. Must be greater than or equal to zero.
lifeTime
Required. The number of periods over which the asset is being depreciated. Must be a positive integer value.
period
Required. The period for which to calculate the depreciation. Must be greater than zero and in the same units as lifeTime.
month
Optional. The number of months in the first year. If omitted, it is assumed to be 12.

Remarks

The fixed-declining balance method computes depreciation at a fixed rate. DB uses the following formulas to calculate depreciation for a period:

  • rate = 1 - ((salvage / cost) ^ (1 / lifeTime))
    rounded to three decimal places
  • value = (cost - total_depreciation_from_prior_periods) * rate

For the first period, DB uses this formula:

  • value = cost * rate * month / 12

For the last period, DB uses this formula:

  • value = ((cost - total_depreciation_from_prior_periods) * rate * (12 - month)) / 12

Example

Formula [image] Copy Code

=DB(1000000,100000,6,1)

See Also

Function Reference
DDB Function
SLN Function


DCOUNT

DCOUNT

Counts the cells that contain numbers in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DCOUNT( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will count the number of beverages in the table:

Formula [image] Copy Code

=DCOUNT(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DCOUNTA

DCOUNTA

Counts the nonblank cells in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DCOUNTA( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will count the number of beverages in the table:

Formula [image] Copy Code

=DCOUNTA(A4:E10,"Name",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DDB

DDB

Returns the depreciation of an asset for the specified period using the double-declining balance method or a custom declination method.

Syntax [image] Copy Code

DDB( Number cost, Number salvage, Number lifeTime, Number period, [Number declinationFactor = 2] ) → Currency

Parameters

cost
Required. The initial cost of the asset. Must be greater than or equal to zero.
salvage
Required. The value at the end of the depreciation. Must be greater than or equal to zero and less than cost.
lifeTime
Required. The number of periods over which the asset is being depreciated. Must be greater than zero.
period
Required. The period for which you want to calculate the depreciation. Must be greater than zero and in the same unit as lifeTime.
declinationFactor
Required. The rate at which the balance declines. Must be a positive number. If omitted, it is assumed to be 2 (double-declining).

Remarks

The double-declining balance method computes depreciation at an accelerated rate. Depreciation is highest in the first period and decreases in successive periods. DDB uses the following formula to calculate depreciation for a period:

  • ((cost - salvage) - total_depreciation_from_prior_periods) * (factor / lifeTime)

Example

Formula [image] Copy Code

=DDB(2000,500,365,1)

See Also

Function Reference
SLN Function


DEC2BIN

DEC2BIN

Converts the specified decimal number to its binary equivalent.

Syntax [image] Copy Code

DEC2BIN( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The decimal number to convert, expressed as either text or number.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is less than -512 or greater than 511, the function returns the #NUM! error value. If x is non-numeric, the function returns the #VALUE! error value.

If digits is omitted, the function uses the minimum number of characters necessary. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is negative or greater than 10, the return value is #NUM!. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=DEC2BIN(11,4)
=DEC2BIN(-10)

See Also

Function Reference
BIN2DEC Function
HEX2DEC Function
OCT2DEC Function


DEC2HEX

DEC2HEX

Converts the specified decimal number to its hexadecimal equivalent.

Syntax [image] Copy Code

DEC2HEX( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The decimal number to convert, expressed as either text or number.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is less than -2^39 or greater than 2^39-1, the function returns the #NUM! error value. If x is non-numeric, the function returns the #VALUE! error value.

If digits is omitted, the function uses the minimum number of characters necessary. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is negative or greater than 10, the return value is #NUM!. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=DEC2HEX(11,4)
=DEC2HEX(-10)

See Also

Function Reference
BIN2DEC Function
HEX2DEC Function
OCT2DEC Function


DEC2OCT

DEC2OCT

Converts the specified decimal number to its octal (base 8) equivalent.

Syntax [image] Copy Code

BIN2OCT( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The decimal number to convert, expressed as either text or number.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is less than -2^29 or greater than 2^29-1, the function returns the #NUM! error value. If x is non-numeric, the function returns the #VALUE! error value.

If digits is omitted, the function uses the minimum number of characters necessary. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is negative or greater than 10, the return value is #NUM!. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=DEC2OCT(11,4)
=DEC2OCT(-10)

See Also

Function Reference
BIN2DEC Function
HEX2DEC Function
OCT2DEC Function


DECIMAL

DECIMAL

Converts specified text representing a number in the specified base into a base 10 number.

Syntax [image] Copy Code

DECIMAL( Text text, Integer radix ) → Number

Parameters

text
Required. The value to convert.
radix
Required. The base of the value represented by text.

Remarks

The text argument can be any combination of alpha-numeric characters that are valid for the radix, and is not case sensitive. If text contains characters that do not belong to the radix, the function returns the #VALUE! error value. If text contains a value that cannot be represented as a decimal, the function returns the #NUM! error value.

The radix must be greater than or equal to 2 and less than or equal to 36. Otherwise the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=DECIMAL("F0",16)
=DECIMAL(101,2)

See Also

Function Reference
BASE Function


MindFusion.Mapping.WebForms.DecorationLayer Events

DecorationLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.WebForms Namespace


DEGREES

DEGREES

Converts the specified value from radians to degrees.

Syntax [image] Copy Code

DEGREES( Number angle ) → Number

Parameters

angle
Required. The angle, in radians, to convert.

Example

Formula [image] Copy Code

=DEGREES(PI())

See Also

Function Reference
RADIANS Function
PI Function


DELTA

DELTA

Checks whether the specified values are equal.

Syntax [image] Copy Code

DELTA( Number x, [Number y = 0] ) → Number

Parameters

x
Required. The first number to compare.
y
Optional. The second number to compare. If omitted, y is assumed to be zero.

Remarks

If x and y are equal, returns 1; otherwise, 0. This function can be used to calculate the count of equal pairs by summing several DELTA functions.

Example

Formula [image] Copy Code

=DELTA(1,1)
=DELTA(0,0.5)

See Also

Function Reference
EXACT function
GESTEP function


DGET

DGET

Extracts a single value from the specified column of the specified database that matches the specified criteria.

Syntax [image] Copy Code

DGET( Database database, TextOrNumber field, Reference criteria ) → Any

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the price of the beverage with price between 10 and 15:

Formula [image] Copy Code

=DGET(A4:E10,"Price",B1:D2)

See Also

Function Reference
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DMAX

DMAX

Returns the largest number in the specified column of the specified database that matches the specified criteria.

Syntax [image] Copy Code

DMAX( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the largest price of beverages in the table:

Formula [image] Copy Code

=DMAX(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DMIN

DMIN

Returns the smallest number in the specified column of the specified database that matches the specified criteria.

Syntax [image] Copy Code

DMIN( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the smallest price of beverages in the table:

Formula [image] Copy Code

=DMIN(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DPRODUCT

DPRODUCT

Returns the product of the values in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DPRODUCT( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the product of all prices of beverages in the table:

Formula [image] Copy Code

=DPRODUCT(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DSTDEV

DSTDEV

Estimates the standard deviation based on a sample by using the numbers in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DSTDEV( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the standard deviation of the beverage prices in the table:

Formula [image] Copy Code

=DSTDEV(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEVP Function
DSUM Function
DVAR Function
DVARP Function


DSTDEVP

DSTDEVP

Calculates standard deviation based on the entire population by using the numbers in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DSTDEVP( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the standard deviation of the beverage prices in the table:

Formula [image] Copy Code

=DSTDEVP(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSUM Function
DVAR Function
DVARP Function


DSUM

DSUM

Returns the sum of the values in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DSUM( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the sum of all prices of beverages in the table:

Formula [image] Copy Code

=DSUM(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DPRODUCT Function
DMAX Function
DMIN Function
DSTDEV Function
DSTDEVP Function
DVAR Function
DVARP Function


DVAR

DVAR

Calculates the sample variance of the values in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DVAR( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the variance of the beverage prices in the table:

Formula [image] Copy Code

=DVAR(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVARP Function


DVARP

DVARP

Calculates the variance of the values in the specified column of the specified database that match the specified criteria.

Syntax [image] Copy Code

DVARP( Database database, TextOrNumber field, Reference criteria ) → Number

Parameters

database
Required. A range of cells that makes up the database. The first row of the database contains labels for each column.
field
Required. A number or text indicating which column is used in the function.
criteria
Required. A range of cells that contains the conditions.

Remarks

You can use any range for the criteria argument, as long as it includes at least one column label and at least one cell underneath the column label for specifying the condition.

Example

The following table shows a small database for a grocery shop. Each record in the table contains information about one item. Above the database are several cells that contain the conditions used as the function criteria.

NAME | CATEGORY | PRICE | PRICE |
 | Beverages | >10 | <15 |
 | Confections |  |  |
Name | Category | Weight | Qty | Price
Blueberry Tea | Beverages | 400 | 12 | 12.50
Ipoh Cofee | Beverages | 500 | 20 | 18.00
Chocolade | Confections | 1250 | 10 | 22.45
Steeleye Stout | Beverages | 750 | 6 | 7.95
Scottish Longbreads | Confections | 450 | 8 | 11.50
Mascarpone | Dairy | 250 | 2 | 7.50

The following formula will return the variance of the beverage prices in the table:

Formula [image] Copy Code

=DVARP(A4:E10,"Price",B1:B2)

See Also

Function Reference
DGET Function
DAVERAGE Function
DCOUNT Function
DCOUNTA Function
DMAX Function
DMIN Function
DPRODUCT Function
DSTDEV Function
DSTDEVP Function
DSUM Function
DVAR Function


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.ImportItem Event

Visio2013Importer.ImportItem Event
[image]

Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public event EventHandler<ImportItemEventArgs> ImportItem

Visual Basic [image] Copy Code

Public Event ImportItem As EventHandler(Of ImportItemEventArgs)

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.ConnectorImported Event

VisioImporter.ConnectorImported Event
[image]

Raised when a Visio connector is imported as a DiagramLink.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public event EventHandler<ConnectorImportedEventArgs> ConnectorImported

Visual Basic [image] Copy Code

Public Event ConnectorImported As EventHandler(Of ConnectorImportedEventArgs)

Event Data

ConnectorImported event handlers receive an argument of type ConnectorImportedEventArgs. The following ConnectorImportedEventArgs members provide information relevant to the event:
Member name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.GroupImported Event

VisioImporter.GroupImported Event
[image]

Raised when a Visio group is imported as a MindFusion.Diagramming Group object.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public event EventHandler<GroupImportedEventArgs> GroupImported

Visual Basic [image] Copy Code

Public Event GroupImported As EventHandler(Of GroupImportedEventArgs)

Event Data

GroupImported event handlers receive an argument of type GroupImportedEventArgs. The following GroupImportedEventArgs members provide information relevant to the event:

Member name | Description
Group | Gets a reference to the imported group.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.ShapeImported Event

VisioImporter.ShapeImported Event
[image]

Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public event EventHandler<ShapeImportedEventArgs> ShapeImported

Visual Basic [image] Copy Code

Public Event ShapeImported As EventHandler(Of ShapeImportedEventArgs)

Event Data

ShapeImported event handlers receive an argument of type ShapeImportedEventArgs. The following ShapeImportedEventArgs members provide information relevant to the event:

Member name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio shape identifier.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.RealTimeCharting.Wpf.Axis.PropertyChanged Event

Axis.PropertyChanged Event
[image]

Occurs when a property value in the Axis class changes.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.YAxisClicked Event

RealTimeChart.YAxisClicked Event
[image]

Ocurrs when an Y-axis is clicked.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<AxisEventArgs> YAxisClicked

Visual Basic [image] Copy Code

Public Event YAxisClicked As EventHandler(Of AxisEventArgs)

Event Data

An instance of the AxisEventArgs class that provides data for the event.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.DataChanged Event

Series.DataChanged Event
[image]

Occurs when series data was changed.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.EvaluationContext.DispatchFunctionCall Event

EvaluationContext.DispatchFunctionCall Event
[image]

Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public event EventHandler<EvaluateFunctionEventArgs> DispatchFunctionCall

Visual Basic [image] Copy Code

Public Event DispatchFunctionCall As EventHandler(Of EvaluateFunctionEventArgs)

Event Data

DispatchFunctionCall event handlers receive an argument of type EvaluateFunctionEventArgs.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ParseObject Event

EvaluationContext.ParseObject Event
[image]

Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public event EventHandler<ParseObjectEventArgs> ParseObject

Visual Basic [image] Copy Code

Public Event ParseObject As EventHandler(Of ParseObjectEventArgs)

Event Data

ParseObject event handlers receive an argument of type EvaluateFunctionEventArgs.

Remarks

A common case for this event to occur is when parsing a color object - where the actual platform-specific type is not known beforehand.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


EDATE

EDATE

Returns the date that is the specified number of months before or after the specified date.

Syntax [image] Copy Code

EDATE( Date startDate, Integer months ) → Date

Parameters

startDate
Required. The start date.
months
Required. The number of months before or after startDate.

Remarks

If the specified months value is not integer, it is automatically truncated. If the result is not representable as a date, the function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=EDATE(TODAY(),1)

See Also

Function Reference
DAYS Function
EOMONTH Function


EOMONTH

EOMONTH

Returns a date representing the last day of the month that is the specified number of months before or after the specified date.

Syntax [image] Copy Code

EOMONTH( Date startDate, Integer months ) → Date

Parameters

startDate
Required. The start date.
months
Required. The number of months before or after startDate.

Remarks

If the specified months value is not integer, it is automatically truncated. If the result is not representable as a date, the function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=EOMONTH(TODAY(),1)

See Also

Function Reference
DATE Function
EDATE Function


ERROR.TYPE

ERROR.TYPE

Returns a number corresponding to the specified error value.

Syntax [image] Copy Code

ERROR.TYPE( Error e ) → Number

Parameters

e
Required. The error value.

Remarks

The following table contains the values that correspond to some of the predefined errors:

Error | Value
#NULL! | 1
#DIV/0! | 2
#VALUE! | 3
#REF! | 4
#NAME? | 5
#NUM! | 6
#N/A | 7
#ERROR! | 8

The parameter can be an actual error value or a reference to a cell containing a formula. If e is not an error value, the function returns the #N/A error value. The ERROR.TYPE function is useful in an IF function to test for an error value and return a text string, such as a message, instead of the actual error value.

Note that this function does not propagate error values.

Example

Formula [image] Copy Code

=ERROR.TYPE(1/0)

See Also

Function Reference
NA Function


EVEN

EVEN

Returns the specified number rounded up to the nearest even integer.

Syntax [image] Copy Code

EVEN( Number n ) → Number

Parameters

n
Required. The number to round.

Remarks

Returns the even integer whose sign is the same as the sign of n and whose absolute value is greater than or equal to the absolute value of n.

Example

Formula [image] Copy Code

=EVEN(3)

See Also

Function Reference
CEILING Function
FLOOR Function
INT Function
ISEVEN Function
ISODD Function
ODD Function
ROUND Function
TRUNC Function


EXACT

EXACT

Checks whether the specified text values are equal using case-sensitive comparison.

Syntax [image] Copy Code

EXACT( Text text1, Text text2 ) → Logical

Parameters

text1
Required. The first text to compare.
text2
Required. The first text to compare.

Example

Formula [image] Copy Code

=EXACT("AB","A"&UPPER("b"))

See Also

Function Reference
FIND Function
SEARCH Function


MindFusion.RealTimeCharting.Wpf.AxisRenderer.XAxisProperty Field

AxisRenderer.XAxisProperty Field
[image]

Identifies the XAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisProperty As DependencyProperty

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer.YAxisProperty Field

AxisRenderer.YAxisProperty Field
[image]

Identifies the YAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxisProperty As DependencyProperty

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.CornerRadiusProperty Field

Legend.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared CornerRadiusProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.LabelFontFamilyProperty Field

Legend.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.OrientationProperty Field

Legend.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer.SeriesProperty Field

LegendSymbolRenderer.SeriesProperty Field
[image]

Identifies the Series dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesProperty As DependencyProperty

See Also

LegendSymbolRenderer Members
LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.BitmapOffsetProperty Field

PlotArea.BitmapOffsetProperty Field
[image]

Identifies the BitmapOffset dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BitmapOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BitmapOffsetProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.CrosshairsDataPointProperty Field

PlotArea.CrosshairsDataPointProperty Field
[image]

Identifies the CrosshairsDataPoint dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairsDataPointProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairsDataPointProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.CrosshairsVisibilityProperty Field

PlotArea.CrosshairsVisibilityProperty Field
[image]

Identifies the CrosshairsVisibility dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CrosshairsVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CrosshairsVisibilityProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.DataPointProperty Field

PlotArea.DataPointProperty Field
[image]

Identifies the DataPoint dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataPointProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataPointProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.MousePositionProperty Field

PlotArea.MousePositionProperty Field
[image]

Identifies the MousePosition dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MousePositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MousePositionProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.ScrollOffsetProperty Field

PlotArea.ScrollOffsetProperty Field
[image]

Identifies the ScrollOffset dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.SeriesCollectionProperty Field

PlotArea.SeriesCollectionProperty Field
[image]

Identifies the SeriesCollection dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesCollectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesCollectionProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.TooltipBackgroundProperty Field

PlotArea.TooltipBackgroundProperty Field
[image]

Identifies the TooltipBackground dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipBackgroundProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.TooltipStrokeProperty Field

PlotArea.TooltipStrokeProperty Field
[image]

Identifies the TooltipStroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipStrokeProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.ToolTipVisibilityProperty Field

PlotArea.ToolTipVisibilityProperty Field
[image]

Identifies the ToolTipVisibility dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ToolTipVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ToolTipVisibilityProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.XAxisProperty Field

PlotArea.XAxisProperty Field
[image]

Identifies the XAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisProperty As DependencyProperty

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.BitmapOffsetProperty Field

RealTimeChart.BitmapOffsetProperty Field
[image]

Identifies the BitmapOffset dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BitmapOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BitmapOffsetProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.CornerRadiusProperty Field

RealTimeChart.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FastScrollModeProperty Field

RealTimeChart.FastScrollModeProperty Field
[image]

Identifies the FastScrollMode dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FastScrollModeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FastScrollModeProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameBottomThicknessProperty Field

RealTimeChart.FrameBottomThicknessProperty Field
[image]

Identifies the FrameBottomThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FrameBottomThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FrameBottomThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameLeftThicknessProperty Field

RealTimeChart.FrameLeftThicknessProperty Field
[image]

Identifies the FrameLeftThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FrameLeftThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FrameLeftThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameRightThicknessProperty Field

RealTimeChart.FrameRightThicknessProperty Field
[image]

Identifies the FrameRightThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FrameRightThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FrameRightThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameTopThicknessProperty Field

RealTimeChart.FrameTopThicknessProperty Field
[image]

Identifies the FrameTopThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FrameTopThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FrameTopThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.GridAxisProperty Field

RealTimeChart.GridAxisProperty Field
[image]

Identifies the GridAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridAxisProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendBackgroundProperty Field

RealTimeChart.LegendBackgroundProperty Field
[image]

Identifies the LegendBackground dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendBackgroundProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendBorderBrushProperty Field

RealTimeChart.LegendBorderBrushProperty Field
[image]

Identifies the LegendBorderBrush dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendBorderBrushProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendHeightProperty Field

RealTimeChart.LegendHeightProperty Field
[image]

Identifies the LegendHeight dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendHeightProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendHorizontalAlignmentProperty Field

RealTimeChart.LegendHorizontalAlignmentProperty Field
[image]

Identifies the LegendHorizontalAlignment dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendHorizontalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendHorizontalAlignmentProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendOrientationProperty Field

RealTimeChart.LegendOrientationProperty Field
[image]

Identifies the LegendOrientation dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendOrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendOrientationProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendVerticalAlignmentProperty Field

RealTimeChart.LegendVerticalAlignmentProperty Field
[image]

Identifies the LegendVerticalAlignment dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendVerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendVerticalAlignmentProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendWidthProperty Field

RealTimeChart.LegendWidthProperty Field
[image]

Identifies the LegendWidth dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendWidthProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridSizeXProperty Field

RealTimeChart.MajorGridSizeXProperty Field
[image]

Identifies the MajorGridSizeX dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorGridSizeXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorGridSizeXProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridSizeYProperty Field

RealTimeChart.MajorGridSizeYProperty Field
[image]

Identifies the MajorGridSizeY dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorGridSizeYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorGridSizeYProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridStrokeProperty Field

RealTimeChart.MajorGridStrokeProperty Field
[image]

Identifies the MajorGridStroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorGridStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorGridStrokeProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridStrokeThicknessProperty Field

RealTimeChart.MajorGridStrokeThicknessProperty Field
[image]

Identifies the MajorGridStrokeThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorGridStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorGridStrokeThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridSizeXProperty Field

RealTimeChart.MinorGridSizeXProperty Field
[image]

Identifies the MinorGridSizeX dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorGridSizeXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorGridSizeXProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridSizeYProperty Field

RealTimeChart.MinorGridSizeYProperty Field
[image]

Identifies the MinorGridSizeY dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorGridSizeYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorGridSizeYProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridStrokeProperty Field

RealTimeChart.MinorGridStrokeProperty Field
[image]

Identifies the MinorGridStroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorGridStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorGridStrokeProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridStrokeThicknessProperty Field

RealTimeChart.MinorGridStrokeThicknessProperty Field
[image]

Identifies the MinorGridStrokeThickness dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorGridStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorGridStrokeThicknessProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ScrollOffsetProperty Field

RealTimeChart.ScrollOffsetProperty Field
[image]

Identifies the ScrollOffset dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollOffsetProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.SeriesCollectionProperty Field

RealTimeChart.SeriesCollectionProperty Field
[image]

Identifies the SeriesCollection dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesCollectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesCollectionProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ShowCrosshairsProperty Field

RealTimeChart.ShowCrosshairsProperty Field
[image]

Identifies the ShowCrosshairs dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCrosshairsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCrosshairsProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ShowLegendProperty Field

RealTimeChart.ShowLegendProperty Field
[image]

Identifies the ShowLegend dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowLegendProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowLegendProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleFontFamilyProperty Field

RealTimeChart.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleFontSizeProperty Field

RealTimeChart.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleHorizontalAlignmentProperty Field

RealTimeChart.TitleHorizontalAlignmentProperty Field
[image]

Identifies the TitleHorizontalAlignment dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleHorizontalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleHorizontalAlignmentProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleTextProperty Field

RealTimeChart.TitleTextProperty Field
[image]

Identifies the TitleText dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleTextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleTextProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleVerticalAlignmentProperty Field

RealTimeChart.TitleVerticalAlignmentProperty Field
[image]

Identifies the TitleVerticalAlignment dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleVerticalAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleVerticalAlignmentProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipAxisProperty Field

RealTimeChart.TooltipAxisProperty Field
[image]

Identifies the FallbackTooltipAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipAxisProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipBackgroundProperty Field

RealTimeChart.TooltipBackgroundProperty Field
[image]

Identifies the FallbackTooltipBackground dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipBackgroundProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipVisibilityProperty Field

RealTimeChart.TooltipVisibilityProperty Field
[image]

Identifies the TooltipVisibility dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipVisibilityProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.XAxisProperty Field

RealTimeChart.XAxisProperty Field
[image]

Identifies the XAxis dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XAxisProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XAxisProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Y2AxisCollectionProperty Field

RealTimeChart.Y2AxisCollectionProperty Field
[image]

Identifies the Y2AxisCollection dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2AxisCollectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2AxisCollectionProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.YAxisCollectionProperty Field

RealTimeChart.YAxisCollectionProperty Field
[image]

Identifies the YAxisCollection dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YAxisCollectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YAxisCollectionProperty As DependencyProperty

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.FillProperty Field

Series.FillProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.LegendBackgroundProperty Field

Series.LegendBackgroundProperty Field
[image]

Identifies the LegendBackground dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LegendBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LegendBackgroundProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.ScatterStrokeProperty Field

Series.ScatterStrokeProperty Field
[image]

Identifies the ScatterStroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokeProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.ScatterTypeProperty Field

Series.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.StrokeProperty Field

Series.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontFamilyProperty Field

Series.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontSizeProperty Field

Series.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontWeightProperty Field

Series.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleProperty Field

Series.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TooltipBackgroundProperty Field

Series.TooltipBackgroundProperty Field
[image]

Identifies the TooltipBackground dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipBackgroundProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TooltipStrokeProperty Field

Series.TooltipStrokeProperty Field
[image]

Identifies the TooltipStroke dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TooltipStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TooltipStrokeProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.VisibleProperty Field

Series.VisibleProperty Field
[image]

Identifies the Visible dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleProperty As DependencyProperty

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


FACT

FACT

Returns the factorial of the specified number.

Syntax [image] Copy Code

FACT( Integer x ) → Number

Parameters

x
Required. The number to calculate factorial of. Must be non-negative.

Remarks

The factorial of a number is the product of all integer numbers from 1 to the number itself. That is, the factorial of x is 1*2*3*…*x. The factorial of zero is, by definition, 1.

If x is not integer, it is automatically truncated. If x is less than zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=FACT(0)
=FACT(5)

See Also

Function Reference
FACTDOUBLE Function
PRODUCT Function


FACTDOUBLE

FACTDOUBLE

Returns the double factorial of the specified number.

Syntax [image] Copy Code

FACTDOUBLE( Integer x ) → Number

Parameters

x
Required. The number to calculate double factorial of. Must be non-negative.

Remarks

The double factorial of a number is the product of every other integer numbers from 1 to the number itself. That is, if x is even, the double factorial of x is 2*4*6*…*x; if x is odd, the double factorial is 1*3*5*…*x. The double factorial of zero is, by definition, 1.

If x is not integer, it is automatically truncated. If x is less than zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=FACTDOUBLE(0)
=FACTDOUBLE(5)

See Also

Function Reference
FACT Function


FALSE

FALSE

Returns the logical constant FALSE.

Syntax [image] Copy Code

FALSE( ) → Logical

Remarks

This function always evaluates to FALSE. An alternative way to use the FALSE constant is through the FALSE literal.

Example

The first formula below illustrates the FALSE function, the second - the FALSE literal.

Formula [image] Copy Code

=FALSE()
=FALSE

See Also

Function Reference
TRUE Function
IF Function


FIND

FIND

Searches for the specified string in another string and returns the found position or an error.

Syntax [image] Copy Code

FIND( Text search, Text text, [Integer start = 1] ) → Integer

Parameters

search
Required. The text to find.
text
Required. The text that contains the searched text.
start
Optional. The position inside text at which to start the search. If omitted, it is assumed to be 1.

Remarks

If search is an empty string, the function returns 1. If search does not appear within text, the function returns the #VALUE! error value. If start is less than or equal to zero, the function returns the #VALUE! error message.

The start parameter can be used to skip a specified number of characters. For example, to find the second appearance of the string contained in cell A1 within the string contained in B1, use the following formula: "=FIND(A1,B1,FIND(A1,B1)+1)".

Example

Formula [image] Copy Code

=FIND("brown",A1)

See Also

Function Reference
EXACT Function
LEN Function
MID Function
SEARCH Function


FLOOR

FLOOR

Rounds the specified number down, towards zero, to the nearest multiple of the specified value.

Syntax [image] Copy Code

FLOOR( Number n, [Number significance], [Integer mode = 0] ) → Number

Parameters

n
Required. The value to round.
significance
Optional. The multiple to which to round.
mode
Optional. The type of rounding to perform (see Remarks).

Remarks

If n and significance are not 0 and have different signs, the function returns the #NUM! error value.

If significance is omitted or an empty parameter (two consecutive commas) it is assumed to be -1 if n is negative and +1 if n is non-negative, making the function act like the normal mathematical floor function if mode is not given or zero. If mode is given and not equal to zero, the absolute value of n is rounded away from zero to a multiple of the absolute value of significance and then the sign applied. Otherwise, it rounds toward negative infinity, and the result is the largest multiple of significance that is less than or equal to n. If the specified mode value is not an integer, it is automatically truncated.

If any of the two parameters n or significance is zero, the result is zero.

Example

Formula [image] Copy Code

=FLOOR(3.5,1)
=FLOOR(0.123,0.01)
=FLOOR(-3.5,-1)
=FLOOR(-3.5,-1,1)

See Also

Function Reference
CEILING Function
EVEN Function
INT Function
ODD Function
ROUND Function
ROUNDDOWN Function
ROUNDUP Function
TRUNC Function


FORMULA

FORMULA

Returns the formula at the specified cell reference as text.

Syntax [image] Copy Code

FORMULA( Reference r ) → Text

Parameters

r
Required. A reference to a cell.

Remarks

This function is intended to aid debugging by simplifying display of formulas in other cells. The referenced formula is not evaluated.

See Also

Function Reference
ISFORMULA Function


FV

FV

Returns a value specifying the future value of an annuity based on the specified periodic, fixed payments and fixed interest rate.

Syntax [image] Copy Code

FV( Number rate, Number nper, Number payment, [Number pv = 0], [Number type = 0] ) → Currency

Parameters

rate
Required. A value specifying the interest rate per period.
nper
Required. A value specifying the total number of payment periods in the annuity.
payment
Required. A value specifying the payment to be made each period.
pv
Optional. A value specifying the present value of a series of future payments. If omitted, pv is assumed to be 0.
type
Optional. A value specifying when the payments are due. If omitted, type is assumed to be 0.

Remarks

An annuity is a series of fixed cash payments made over a period of time. An annuity can be a loan (such as a home mortgage) or an investment (such as a monthly savings plan).

The rate and nper arguments must be calculated using payment periods expressed in the same units. For example, if rate is calculated using months, nper must also be calculated using months.

For all arguments, cash paid out (such as deposits to savings) is represented by negative numbers; cash received (such as dividend checks) is represented by positive numbers.

See Also

Function Reference
PV Function
NPER Function
PMT Function
RATE Function


Gauges

Gauges

This section contains information about the two type of gauge controls contained in MindFusion.Charting for WPF - OvalGauge and LinearGauge and how to use their features.


GCD

GCD

Returns the greatest common divisor (GCD) of the specified sequence of numbers.

Syntax [image] Copy Code

GCD( Integer n1, [Integer n2], ... ) → Integer

Parameters

n1
n2
…
One or more numbers.

Remarks

If any of the specified arguments is negative, the function returns the #NUM! error value. If one of the arguments is a cell reference or an array, the values of the referenced cells or the array are included in the operation. If the specified values are not integer, they are automatically truncated.

Example

Formula [image] Copy Code

=GCD(12,18)
=GCD(7,3)

See Also

Function Reference
LCM Function


GESTEP

GESTEP

Returns 1 if the specified number is greater than or equal to the specified step; otherwise returns 0.

Syntax [image] Copy Code

GESTEP( Number n, [Number step = 0] ) → Number

Parameters

n
Required. The value to test.
step
Optional. The threshold value. If omitted, step is assumed to be zero.

Example

Formula [image] Copy Code

=GESTEP(3,2)
=GESTEP(-2,-1)
=GESTEP(10)

See Also

Function Reference
DELTA Function


HEX2BIN

HEX2BIN

Converts the specified hexadecimal number to its binary equivalent.

Syntax [image] Copy Code

HEX2BIN( NumberOrText x, [Number digits] ) → Text

Parameters

x
Required. The hexadecimal number to convert, expressed as either text or number.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid hexadecimal number, the function returns the #VALUE! error value.

If digits is omitted, the function uses the minimum number of characters necessary. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is negative or greater than 10, the return value is #NUM!. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=HEX2BIN(11,8)
=HEX2BIN("10")

See Also

Function Reference
BIN2HEX Function
DEC2HEX Function
OCT2HEX Function


HEX2DEC

HEX2DEC

Converts the specified hexadecimal number to its decimal equivalent.

Syntax [image] Copy Code

HEX2DEC( NumberOrText x ) → Number

Parameters

x
Required. The hexadecimal number to convert, expressed as either text or number.

Remarks

If x is not a valid hexadecimal number, the function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=HEX2DEC(11)
=HEX2DEC("10")

See Also

Function Reference
BIN2HEX Function
DEC2HEX Function
OCT2HEX Function


HEX2OCT

HEX2OCT

Converts the specified hexadecimal number to its octal (base 8) equivalent.

Syntax [image] Copy Code

HEX2OCT( NumberOrText x, [Number digits] ) → Text

Parameters

x
Required. The hexadecimal number to convert, expressed as either text or number.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid hexadecimal number, the function returns the #VALUE! error value.

If digits is omitted, the function uses the minimum number of characters necessary. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is negative or greater than 10, the return value is #NUM!. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=HEX2OCT(11,4)
=HEX2OCT("10")

See Also

Function Reference
BIN2HEX Function
DEC2HEX Function
OCT2HEX Function


HLOOKUP

HLOOKUP

Searches for a value in the top row of the specified table or array of values, and returns a value in the same column from another specified row in the table or array.

Syntax [image] Copy Code

HLOOKUP( Any lookup, ReferenceOrArray dataSource, Integer row, [Logical rangeLookup = TRUE] ) → Any

Parameters

lookup
Required. The value to search for in the first row of the table. The lookup value can be a value or a reference.
dataSource
Required. The table to be looked up. The source can be a reference to a range of cells or an array.
row
Required. The row number in dataSource from which the matching value will be returned.
rangeLookup
Optional. A logical value indicating whether HLOOKUP should find an exact or an approximate match.

Remarks

If HLOOKUP cannot find lookup, and rangeLookup is TRUE (or omitted), it uses the largest value that is less than lookup. If rangeLookup is FALSE, HLOOKUP will find an exact match. If one is not found, the error value #N/A is returned.

See Also

Function Reference
INDEX Function
MATCH Function
OFFSET Function
VLOOKUP Function


HYPERLINK

HYPERLINK

Creates a hyperlink that opens a document, a web page, or an e-mail client, or jumps to a cell in the current worksheet.

Syntax [image] Copy Code

HYPERLINK( Text uri, [Text cellText] ) → Text

Parameters

uri
Required. The location of a document or web page, an e-mail address or a cell reference.
cellText
Optional. The text to display inside the cell.

Remarks

The function returns the value of cellText. If cellText is omitted, the function returns uri.

Example

Formula [image] Copy Code

=HYPERLINK("http://mindfusion.eu","Visit our site")

See Also

Function Reference


IF

IF

Returns one of two specified values if the specified condition evaluates to TRUE, and the other value if the condition evaluates to FALSE.

Syntax [image] Copy Code

IF( Logical condition, [Any ifTrue], [Any ifFalse] ) → Any

Parameters

condition
Required. A value or expression that can be evaluated to TRUE or FALSE. For example, A1=50.
ifTrue
Optional. The value that should be returned if condition evaluates to TRUE.
ifFalse
Optional. The value that should be returned if condition evaluates to FALSE.

Remarks

If condition is TRUE, the function returns ifTrue, else it returns ifFalse. If there is only 1 parameter, ifTrue is considered to be TRUE. If there are less than 3 parameters, ifFalse is considered to be FALSE. Thus the 1 parameter version converts condition into a Logical value. If there are 2 or 3 parameters, but the second parameter is omitted (two consecutive commas), ifFalse is considered to be 0. If there are 3 parameters, but the third parameter is omitted, ifFalse is considered to be 0. This function only evaluates ifTrue, or ifFalse, and never both; that is to say, it short-circuits.

Example

Formula [image] Copy Code

=IF(A1>B1,"Too many","OK")

See Also

Function Reference
AND Function
OR Function


IFERROR

IFERROR

Returns the specified value unless it is an error, in which case returns the specified alternative value.

Syntax [image] Copy Code

IFERROR( Any value, Any alternative ) → Any

Parameters

value
Required. The argument to check for an error.
alternative
Required. The value to return if value is an error.

Remarks

This function is useful to trap and handle formula errors.

Example

Formula [image] Copy Code

=IFERROR(1/0,"Division by zero")

See Also

Function Reference
IF Function
ISERROR Function


IFNA

IFNA

Returns the specified value unless it is the #N/A error value, in which case returns the specified alternative value.

Syntax [image] Copy Code

IFNA( Any value, Any alternative ) → Any

Parameters

value
Required. The argument to check for the #N/A error value.
alternative
Required. The value to return if value is #N/A.

Example

Formula [image] Copy Code

=IFNA(VLOOKUP("Apples",A1:B10,5),"Not found")

See Also

Function Reference
IF Function
ISNA Function


INDEX

INDEX

Returns the value with the specified row and column from the specified cell range or table.

Syntax [image] Copy Code

INDEX( ReferenceOrArray dataSource, [Integer row = 0], [Integer column = 0] ) → Any

Parameters

dataSource
Required. A reference to the cell range or the table to be indexed.
row
Optional. The index of the cell row, relatively to the top-left of the data source. If omitted, row is assumed to be zero.
column
Optional. The index of the cell column, relatively to the top-left of the data source. If omitted, column is assumed to be zero.

Remarks

This function returns a value, identified by the specified row and column from the specified data source. If row or column are zeros (or omitted), the entire dimension is returned. For example, if dataSource contains 3 columns, specifying zero for column and a non-zero row will return all values in row 1. If row or column are less than zero or greater than the number of elements in the respective dimension, the function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=INDEX(A1:B5,2,3)

See Also

Function Reference
CHOOSE Function


INDIRECT

INDIRECT

Returns the reference represented by the specified text.

Syntax [image] Copy Code

INDIRECT( Text ref, [Logical a1 = TRUE] ) → Reference

Parameters

ref
Required. The string representation of a reference.
a1
Optional. A flag indicating how to interpret ref. If omitted, a1 is assumed to be TRUE.

Remarks

If a1 is TRUE, the ref argument is interpreted as an A1-style reference; otherwise, ref is interpreted as a R1C1-style reference. If ref is not a valid reference, the function returns the #REF! error value.

Example

Formula [image] Copy Code

=INDIRECT("A1")
=INDIRECT("R[1]C5",FALSE)

See Also

Function Reference
OFFSET Function


IRR

IRR

Returns the internal rate of return for the specified series of cash flows.

Syntax [image] Copy Code

IRR( NumberSequence values, [Number guess = 0.1] ) → Number

Parameters

values
Required. A list of values specifying the cash flows. The list must contain at least one negative value (a payment) and one positive value (a receipt).
guess
Optional. The estimated return value. If omitted, guess is assumed to be 0.1 (10 percent).

Remarks

The internal rate of return is the interest rate received for an investment consisting of payments and receipts that occur at regular intervals.

The IRR function uses the order of values within the array to interpret the order of payments and receipts. Be sure to enter your payment and receipt values in the correct sequence. The cash flow for each period doesn't have to be fixed, as it is for an annuity.

IRR is calculated by iteration. Starting with the value of guess, IRR cycles through the calculation until the result is accurate enough or until the maximum number of iterations. In the later case IRR fails and returns #VALUE!.

See Also

Function Reference
NPV Function
RATE Function


ISBLANK

ISBLANK

Checks whether the specified reference identifies an empty cell.

Syntax [image] Copy Code

ISBLANK( Any x ) → Logical

Parameters

x
Required. The value to check.

Remarks

If x is a reference to an empty cell, that is, a cell with no data, the function returns TRUE. If x is a number, logical value or text, or a reference to a cell that is not empty, the function returns FALSE. If the cell contains an empty string, it is not considered blank.

Example

Formula [image] Copy Code

=ISBLANK(A1)
=ISBLANK(0)

See Also

Function Reference
ERROR.TYPE Function
ISERR Function
ISERROR Function
ISNA Function
ISREF Function
ISTEXT Function
TYPE Function


ISERR

ISERR

Checks whether the specified value is an error value, other than #N/A.

Syntax [image] Copy Code

ISERR( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is an error value other than #N/A, the function returns TRUE; in any other case the function returns FALSE. Note, that this function does not propagate error values.

Example

Formula [image] Copy Code

=ISERR(NA())
=ISERR(5/0)

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERROR Function
ISNA Function
ISREF Function
ISTEXT Function
TYPE Function


ISERROR

ISERROR

Checks whether the specified value is an error.

Syntax [image] Copy Code

ISERROR( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is an error value, the function returns TRUE; in any other case the function returns FALSE. Note, that this function does not propagate error values.

Example

Formula [image] Copy Code

=ISERROR(A1)

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISNA Function
ISREF Function
TYPE Function


ISEVEN

ISEVEN

Checks whether the specified number is even.

Syntax [image] Copy Code

ISEVEN( Integer n ) → Logical

Parameters

n
Required. The value to test.

Remarks

If n is an even number, returns TRUE; otherwise, FALSE. If n is not an integer, it is automatically truncated.

Example

Formula [image] Copy Code

=ISEVEN(2.5)
=ISEVEN(3)

See Also

Function Reference
EVEN Function
ISODD Function
ODD Function


ISFORMULA

ISFORMULA

Checks whether the cell identified by the specified reference contains a formula.

Syntax [image] Copy Code

ISFORMULA( Reference r ) → Logical

Parameters

r
Required. The reference to the cell to test.

Remarks

If r references a cell containing a formula, the function returns TRUE; otherwise, FALSE. If r is not a valid cell reference, the function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=ISFORMULA(A1)

See Also

Function Reference
ISTEXT Function
ISNUMBER Function


ISLOGICAL

ISLOGICAL

Checks whether the specified value is Logical.

Syntax [image] Copy Code

ISLOGICAL( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is a logical value, returns TRUE; if x is of any other type, returns FALSE. If x is an error value, this error value is returned.

Example

Formula [image] Copy Code

=ISLOGICAL(TRUE())
=ISLOGICAL(5>1)

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISNA Function
ISNUMBER Function
TYPE Function


ISNA

ISNA

Checks whether the specified value is the #N/A error value.

Syntax [image] Copy Code

ISNA( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is the #N/A error value, returns TRUE; if x is any of the other error values, or not an error value, returns FALSE. Note that this function does not propagate error values.

Example

Formula [image] Copy Code

=ISNA(NA())

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISLOGICAL Function
ISNONTEXT Function
ISREF Function
TYPE Function


ISNONTEXT

ISNONTEXT

Checks whether the specified value refers to any item that is not text, including blank cells.

Syntax [image] Copy Code

ISNONTEXT( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is a text value, returns FALSE. If x is a reference to a cell, the value of the referenced cell is tested. Blank cells are not considered texts. If x is an error value, this error value is returned. In any other case, the function returns TRUE.

Example

Formula [image] Copy Code

=ISNONTEXT(A1)
=ISNONTEXT("Value")

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISNA Function
ISTEXT Function
TYPE Function


ISNUMBER

ISNUMBER

Checks whether the specified value is numeric.

Syntax [image] Copy Code

ISNUMBER( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is a numeric value (this includes numbers, currencies, dates, times, and logical values), returns TRUE. If x is a reference to a cell, the value of the referenced cell is tested. If x is an error value, this error value is returned. In any other case, the function returns FALSE.

Example

Formula [image] Copy Code

=ISNUMBER(5.5)
=ISNUMBER(TRUE)

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISLOGICAL Function
ISNA Function
ISREF Function
TYPE Function


ISODD

ISODD

Checks whether the specified number is odd.

Syntax [image] Copy Code

ISODD( Integer n ) → Logical

Parameters

n
Required. The value to test.

Remarks

If n is an odd number, returns TRUE; otherwise, FALSE. If n is not an integer, it is automatically truncated.

Example

Formula [image] Copy Code

=ISODD(2.5)
=ISODD(3)

See Also

Function Reference
EVEN Function
ISEVEN Function
ODD Function


ISREF

ISREF

Checks whether the specified value is a cell reference.

Syntax [image] Copy Code

ISREF( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is a cell reference, returns TRUE. If x is not a cell reference, including when x is an error, returns FALSE. Note that this function does not propagate error values. Also note, that unlike most other functions, when given a cell reference this function does not examine the value of the referenced cell.

Example

Formula [image] Copy Code

=ISREF(A1)
=ISREF("A1")

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISNA Function
ISNONTEXT Function
TYPE Function


ISTEXT

ISTEXT

Checks whether the specified value refers to any item that is text.

Syntax [image] Copy Code

ISTEXT( Any x ) → Logical

Parameters

x
Required. The value to test.

Remarks

If x is a text value, returns TRUE. If x is a reference to a cell, the value of the referenced cell is tested. Blank cells are not considered texts. If x is an error value, this error value is returned. In any other case, the function returns FALSE.

Example

Formula [image] Copy Code

=ISTEXT(A1)
=ISTEXT("Value")

See Also

Function Reference
ERROR.TYPE Function
ISBLANK Function
ISERR Function
ISERROR Function
ISNA Function
ISNONTEXT Function
TYPE Function


LCM

LCM

Returns the least common multiplier (LCM) of the specified sequence of numbers.

Syntax [image] Copy Code

LCM( Integer n1, Integer n2, ... ) → Integer

Parameters

n1
n2
…
One or more numbers.

Remarks

If any of the specified arguments is negative, the function returns the #NUM! error value. If one of the arguments is a cell reference or an array, the values of the referenced cells or the array are included in the operation. If the specified values are not integer, they are automatically truncated.

Example

Formula [image] Copy Code

=LCM(12,18)
=LCM(7,3)

See Also

Function Reference
GCD Function


LN

LN

Returns the natural logarithm of the specified number.

Syntax [image] Copy Code

LN( Number n ) → Number

Parameters

n
Required. The number for which to find the natural logarithm. Must be a positive value.

Remarks

If n is negative or zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=LN(5)

See Also

Function Reference
EXP Function
LOG Function
LOG10 Function
POWER Function


LOOKUP

LOOKUP

Looks for the specified value in the specified list of values and returns the corresponding result.

Syntax [image] Copy Code

LOOKUP( Any lookup, ReferenceOrArray searched, [ReferenceOrArray result] ) → Any

Parameters

lookup
Required. The value to look for in the searched list.
searched
Required. A reference or array that contains only one row or column.
result
Optional. A reference or array that contains only one row or column of the same size as searched.

Remarks

The values in the searched list must be sorted in ascending order. The lookup value and the values in the searched list must be numeric or text.

This function searches for the lookup value in the searched list. The match is the largest value in searched that is less than or equal to lookup. From a sequence of identical values, the last value is selected. If lookup is smaller than the smallest of all values in searched, the function returns #N/A. When a match is found in searched, the function returns the corresponding value from the result list, or, if result is omitted, the function returns the found value.

The searched list shall be sorted in ascending order, so that values of numeric types precede text values if both types are included (for example, -2, 0, 1, "A", "B", "D"). The searched list must be a vector. That is, if searched is a cell reference, the referenced range must have one row or one column, if searched is an array, it must be one-dimensional. If searched is not a vector, the function returns #N/A.

See Also

Function Reference
HLOOKUP Function
INDEX Function
MATCH Function
OFFSET Function
VLOOKUP Function


LOWER

LOWER

Converts the specified text to lowercase.

Syntax [image] Copy Code

LOWER( Text text ) → Text

Parameters

text
Required. The text to convert.

Remarks

LOWER does not change the characters in text that are not letters.

Example

Formula [image] Copy Code

=LOWER(A2)
=LOWER("Mr. Brown")

See Also

Function Reference
UPPER Function
PROPER Function


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions.BarColor(T) Method

BarcodeNodeExtensions.BarColor(T) Method
[image]

Sets the color of barcode modules.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BarColor<T> (
T barcodeNode,
Color value
) where T : BarcodeNode

Visual Basic [image] Copy Code

Public Shared Function BarColor(Of T As BarcodeNode) ( _
barcodeNode As T, _
value As Color _
) As T

Parameters

barcodeNode

value

Return Value

See Also

BarcodeNodeExtensions Members
BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions.Content(T) Method

BarcodeNodeExtensions.Content(T) Method
[image]

Sets the text or numeric code that should be represented as barcode symbol.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Content<T> (
T barcodeNode,
string value
) where T : BarcodeNode

Visual Basic [image] Copy Code

Public Shared Function Content(Of T As BarcodeNode) ( _
barcodeNode As T, _
value As String _
) As T

Parameters

barcodeNode

value

Return Value

See Also

BarcodeNodeExtensions Members
BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions.Format(T) Method

BarcodeNodeExtensions.Format(T) Method
[image]

Sets the barcode format.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Format<T> (
T barcodeNode,
BarcodeFormat value
) where T : BarcodeNode

Visual Basic [image] Copy Code

Public Shared Function Format(Of T As BarcodeNode) ( _
barcodeNode As T, _
value As BarcodeFormat _
) As T

Parameters

barcodeNode

value

Return Value

See Also

BarcodeNodeExtensions Members
BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions.QRCorrectionLevel(T) Method

BarcodeNodeExtensions.QRCorrectionLevel(T) Method
[image]

Sets the correction level of QR barcodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T QRCorrectionLevel<T> (
T barcodeNode,
CorrectionLevel value
) where T : BarcodeNode

Visual Basic [image] Copy Code

Public Shared Function QRCorrectionLevel(Of T As BarcodeNode) ( _
barcodeNode As T, _
value As CorrectionLevel _
) As T

Parameters

barcodeNode

value

Return Value

See Also

BarcodeNodeExtensions Members
BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.AllowAddChildren(T) Method

ContainerNodeExtensions.AllowAddChildren(T) Method
[image]

Sets a value indicating whether child nodes can be added interactively to this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowAddChildren<T> (
T containerNode,
bool value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function AllowAddChildren(Of T As ContainerNode) ( _
containerNode As T, _
value As Boolean _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.AllowRemoveChildren(T) Method

ContainerNodeExtensions.AllowRemoveChildren(T) Method
[image]

Sets a value indicating whether child nodes can be removed interactively from this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowRemoveChildren<T> (
T containerNode,
bool value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function AllowRemoveChildren(Of T As ContainerNode) ( _
containerNode As T, _
value As Boolean _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.AutoShrink(T) Method

ContainerNodeExtensions.AutoShrink(T) Method
[image]

Sets a value indicating whether the container should shrink in size when nodes are removed from it.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AutoShrink<T> (
T containerNode,
bool value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function AutoShrink(Of T As ContainerNode) ( _
containerNode As T, _
value As Boolean _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.Caption Method

ContainerNodeExtensions.Caption Method
[image]

Sets the container caption text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode Caption (
ContainerNode containerNode,
string value
)

Visual Basic [image] Copy Code

Public Shared Function Caption( _
containerNode As ContainerNode, _
value As String _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Brush)

ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Brush)
See Also
[image]

Sets the brush used to paint the caption area of this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBackBrush (
ContainerNode containerNode,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush( _
containerNode As ContainerNode, _
value As Brush _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

CaptionBackBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Color)

ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Color)
See Also
[image]

Sets the brush used to paint the caption area of this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBackBrush (
ContainerNode containerNode,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush( _
containerNode As ContainerNode, _
color As Color _
) As ContainerNode

Parameters

containerNode

color

Return Value

See Also

CaptionBackBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Color, Color, Single)

ContainerNodeExtensions.CaptionBackBrush Method (ContainerNode, Color, Color, Single)
See Also
[image]

Sets the brush used to paint the caption area of this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBackBrush (
ContainerNode containerNode,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush( _
containerNode As ContainerNode, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As ContainerNode

Parameters

containerNode

color1

color2

angle

Return Value

See Also

CaptionBackBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Brush)

ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Brush)
See Also
[image]

Sets the brush with which container's caption text is rendered.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBrush (
ContainerNode containerNode,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
containerNode As ContainerNode, _
value As Brush _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

CaptionBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Color)

ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Color)
See Also
[image]

Sets the brush with which container's caption text is rendered.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBrush (
ContainerNode containerNode,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
containerNode As ContainerNode, _
color As Color _
) As ContainerNode

Parameters

containerNode

color

Return Value

See Also

CaptionBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Color, Color, Single)

ContainerNodeExtensions.CaptionBrush Method (ContainerNode, Color, Color, Single)
See Also
[image]

Sets the brush with which container's caption text is rendered.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionBrush (
ContainerNode containerNode,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
containerNode As ContainerNode, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As ContainerNode

Parameters

containerNode

color1

color2

angle

Return Value

See Also

CaptionBrush Method Overload List
ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionFormat Method

ContainerNodeExtensions.CaptionFormat Method
[image]

Sets the caption alignment and format.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionFormat (
ContainerNode containerNode,
StringFormat value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionFormat( _
containerNode As ContainerNode, _
value As StringFormat _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionHeight Method

ContainerNodeExtensions.CaptionHeight Method
[image]

Sets the height of the container's caption area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode CaptionHeight (
ContainerNode containerNode,
double value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionHeight( _
containerNode As ContainerNode, _
value As Double _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CornerRadius(T) Method

ContainerNodeExtensions.CornerRadius(T) Method
[image]

Sets the radius of node's corners when Shape is set to RoundedRectangle.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CornerRadius<T> (
T containerNode,
double value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function CornerRadius(Of T As ContainerNode) ( _
containerNode As T, _
value As Double _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.Foldable(T) Method

ContainerNodeExtensions.Foldable(T) Method
[image]

Sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Foldable<T> (
T containerNode,
bool value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function Foldable(Of T As ContainerNode) ( _
containerNode As T, _
value As Boolean _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.Folded(T) Method

ContainerNodeExtensions.Folded(T) Method
[image]

Sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Folded<T> (
T containerNode,
bool value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function Folded(Of T As ContainerNode) ( _
containerNode As T, _
value As Boolean _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.HighlightPen(T) Method

ContainerNodeExtensions.HighlightPen(T) Method
[image]

Sets the Pen used to draw the container frame lines when an item is dragged over the container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HighlightPen<T> (
T containerNode,
Pen value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function HighlightPen(Of T As ContainerNode) ( _
containerNode As T, _
value As Pen _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.Margin(T) Method

ContainerNodeExtensions.Margin(T) Method
[image]

Sets how much space should be left between contained nodes and the container borders.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Margin<T> (
T containerNode,
double value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function Margin(Of T As ContainerNode) ( _
containerNode As T, _
value As Double _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.MinimumSize(T) Method

ContainerNodeExtensions.MinimumSize(T) Method
[image]

Sets the minimum size of the container.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T MinimumSize<T> (
T containerNode,
Size value
) where T : ContainerNode

Visual Basic [image] Copy Code

Public Shared Function MinimumSize(Of T As ContainerNode) ( _
containerNode As T, _
value As Size _
) As T

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.Shape Method

ContainerNodeExtensions.Shape Method
[image]

Sets the shape of the container's outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ContainerNode Shape (
ContainerNode containerNode,
SimpleShape value
)

Visual Basic [image] Copy Code

Public Shared Function Shape( _
containerNode As ContainerNode, _
value As SimpleShape _
) As ContainerNode

Parameters

containerNode

value

Return Value

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ActiveItem Method

DiagramExtensions.ActiveItem Method
[image]

Sets the active diagram element.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ActiveItem (
Diagram diagram,
DiagramItem value
)

Visual Basic [image] Copy Code

Public Shared Function ActiveItem( _
diagram As Diagram, _
value As DiagramItem _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ActiveLayer Method

DiagramExtensions.ActiveLayer Method
[image]

Sets the zero-based index of the active layer.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ActiveLayer (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function ActiveLayer( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AdapterHandlesStyle Method

DiagramExtensions.AdapterHandlesStyle Method
[image]

Sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AdapterHandlesStyle (
Diagram diagram,
HandlesStyle value
)

Visual Basic [image] Copy Code

Public Shared Function AdapterHandlesStyle( _
diagram As Diagram, _
value As HandlesStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AdjustmentHandlesSize Method

DiagramExtensions.AdjustmentHandlesSize Method
[image]

Sets the size of the handles, which appear around selected objects.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AdjustmentHandlesSize (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function AdjustmentHandlesSize( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AlignmentGuidePen Method

DiagramExtensions.AlignmentGuidePen Method
[image]

Sets the pen used to draw alignment guides.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AlignmentGuidePen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function AlignmentGuidePen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AlignToGrid Method

DiagramExtensions.AlignToGrid Method
[image]

Sets a value indicating whether the diagram items should be aligned to a grid.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AlignToGrid (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AlignToGrid( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowInplaceEdit Method

DiagramExtensions.AllowInplaceEdit Method
[image]

Sets a value indicating whether in-place editing of the text of objects is enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowInplaceEdit (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowInplaceEdit( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowLinkCursor Method

DiagramExtensions.AllowLinkCursor Method
[image]

Sets the mouse cursor shown to the user when an arrow can be created.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowLinkCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function AllowLinkCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowLinksRepeat Method

DiagramExtensions.AllowLinksRepeat Method
[image]

Sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowLinksRepeat (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowLinksRepeat( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowMultipleResize Method

DiagramExtensions.AllowMultipleResize Method
[image]

Specifies whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowMultipleResize (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowMultipleResize( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowSelfLoops Method

DiagramExtensions.AllowSelfLoops Method
[image]

Sets a value indicating whether self-loops are allowed.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowSelfLoops (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowSelfLoops( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowSplitLinks Method

DiagramExtensions.AllowSplitLinks Method
[image]

Sets a value indicating whether link segments can be added and removed interactively.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowSplitLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowSplitLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowUnanchoredLinks Method

DiagramExtensions.AllowUnanchoredLinks Method
[image]

Sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowUnanchoredLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowUnanchoredLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AllowUnconnectedLinks Method

DiagramExtensions.AllowUnconnectedLinks Method
[image]

Sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AllowUnconnectedLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AllowUnconnectedLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoAlignDistance Method

DiagramExtensions.AutoAlignDistance Method
[image]

Sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoAlignDistance (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function AutoAlignDistance( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoAlignNodes Method

DiagramExtensions.AutoAlignNodes Method
[image]

Sets whether nodes should automatically align to the borders ot other nodes during user interaction.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoAlignNodes (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AutoAlignNodes( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoCloseDistance Method

DiagramExtensions.AutoCloseDistance Method
[image]

Sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoCloseDistance (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function AutoCloseDistance( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoHighlightRows Method

DiagramExtensions.AutoHighlightRows Method
[image]

Sets whether a table row should be highlighted when the user clicks on it.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoHighlightRows (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AutoHighlightRows( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoResize Method

DiagramExtensions.AutoResize Method
[image]

Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoResize (
Diagram diagram,
AutoResize value
)

Visual Basic [image] Copy Code

Public Shared Function AutoResize( _
diagram As Diagram, _
value As AutoResize _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoScroll Method

DiagramExtensions.AutoScroll Method
[image]

Sets a value indicating whether auto scrolling of the document area is enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoScroll (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AutoScroll( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoSnapDistance Method

DiagramExtensions.AutoSnapDistance Method
[image]

Specifies the maximum distance at which links auto-snap to nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoSnapDistance (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function AutoSnapDistance( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.AutoSnapLinks Method

DiagramExtensions.AutoSnapLinks Method
[image]

Sets the default value for the SnapToNodeBorder property of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram AutoSnapLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function AutoSnapLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackBrush Method (Diagram, Brush)

DiagramExtensions.BackBrush Method (Diagram, Brush)
See Also
[image]

Sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BackBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function BackBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

BackBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackBrush Method (Diagram, Color)

DiagramExtensions.BackBrush Method (Diagram, Color)
See Also
[image]

Sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BackBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function BackBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

BackBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.BackBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BackBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function BackBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

BackBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackgroundImage Method

DiagramExtensions.BackgroundImage Method
[image]

Sets the image displayed as background of this diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BackgroundImage (
Diagram diagram,
ImageSource value
)

Visual Basic [image] Copy Code

Public Shared Function BackgroundImage( _
diagram As Diagram, _
value As ImageSource _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackgroundImageAlign Method

DiagramExtensions.BackgroundImageAlign Method
[image]

Sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BackgroundImageAlign (
Diagram diagram,
ImageAlign value
)

Visual Basic [image] Copy Code

Public Shared Function BackgroundImageAlign( _
diagram As Diagram, _
value As ImageAlign _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BarcodeNodeStyle Method

DiagramExtensions.BarcodeNodeStyle Method
[image]

Sets the theme-level style for barcode nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram BarcodeNodeStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function BarcodeNodeStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Behavior Method

DiagramExtensions.Behavior Method
[image]

Sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Behavior (
Diagram diagram,
Behavior value
)

Visual Basic [image] Copy Code

Public Shared Function Behavior( _
diagram As Diagram, _
value As Behavior _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Bounds Method

DiagramExtensions.Bounds Method
[image]

Sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Bounds (
Diagram diagram,
Rect value
)

Visual Basic [image] Copy Code

Public Shared Function Bounds( _
diagram As Diagram, _
value As Rect _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CellCustomDraw Method

DiagramExtensions.CellCustomDraw Method
[image]

Sets the default type of custom painting done on the cells of tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CellCustomDraw (
Diagram diagram,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function CellCustomDraw( _
diagram As Diagram, _
value As CustomDraw _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CellFrameStyle Method

DiagramExtensions.CellFrameStyle Method
[image]

Sets the default cell border style of new tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CellFrameStyle (
Diagram diagram,
CellFrameStyle value
)

Visual Basic [image] Copy Code

Public Shared Function CellFrameStyle( _
diagram As Diagram, _
value As CellFrameStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerCaption Method

DiagramExtensions.ContainerCaption Method
[image]

Sets the default value for the Caption property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerCaption (
Diagram diagram,
string value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerCaption( _
diagram As Diagram, _
value As String _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerCaptionHeight Method

DiagramExtensions.ContainerCaptionHeight Method
[image]

Sets the default value for the CaptionHeight property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerCaptionHeight (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerCaptionHeight( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerHighlightPen Method

DiagramExtensions.ContainerHighlightPen Method
[image]

Sets the default value for the HighlightPen property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerHighlightPen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerHighlightPen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerMargin Method

DiagramExtensions.ContainerMargin Method
[image]

Sets the default value for the Margin property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerMargin (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerMargin( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerMinimumSize Method

DiagramExtensions.ContainerMinimumSize Method
[image]

Sets the default value for the MinimumSize property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerMinimumSize (
Diagram diagram,
Size value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerMinimumSize( _
diagram As Diagram, _
value As Size _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainerNodeStyle Method

DiagramExtensions.ContainerNodeStyle Method
[image]

Sets the theme-level style for container nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainerNodeStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function ContainerNodeStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ContainersFoldable Method

DiagramExtensions.ContainersFoldable Method
[image]

Sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ContainersFoldable (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ContainersFoldable( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ControlMouseAction Method

DiagramExtensions.ControlMouseAction Method
[image]

Sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ControlMouseAction (
Diagram diagram,
ControlMouseAction value
)

Visual Basic [image] Copy Code

Public Shared Function ControlMouseAction( _
diagram As Diagram, _
value As ControlMouseAction _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CounterDiagonalResizeCursor Method

DiagramExtensions.CounterDiagonalResizeCursor Method
[image]

Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CounterDiagonalResizeCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function CounterDiagonalResizeCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CrossingRadius Method

DiagramExtensions.CrossingRadius Method
[image]

Sets the radius length of decorations displayed at link intersection points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CrossingRadius (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function CrossingRadius( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CustomBehavior Method

DiagramExtensions.CustomBehavior Method
[image]

Sets a custom Behavior object specifying how Diagram.NET responds to mouse input.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CustomBehavior (
Diagram diagram,
BehaviorBase value
)

Visual Basic [image] Copy Code

Public Shared Function CustomBehavior( _
diagram As Diagram, _
value As BehaviorBase _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CustomLinkType Method

DiagramExtensions.CustomLinkType Method
[image]

Sets the type of a MindFusion.Diagramming.Wpf.DiagramLink derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CustomLinkType (
Diagram diagram,
Type value
)

Visual Basic [image] Copy Code

Public Shared Function CustomLinkType( _
diagram As Diagram, _
value As Type _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.CustomNodeType Method

DiagramExtensions.CustomNodeType Method
[image]

Sets the type of a MindFusion.Diagramming.Wpf.DiagramNode derived class whose instance should be created when a user starts drawing.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram CustomNodeType (
Diagram diagram,
Type value
)

Visual Basic [image] Copy Code

Public Shared Function CustomNodeType( _
diagram As Diagram, _
value As Type _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DefaultControlType Method

DiagramExtensions.DefaultControlType Method
[image]

Sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DefaultControlType (
Diagram diagram,
Type value
)

Visual Basic [image] Copy Code

Public Shared Function DefaultControlType( _
diagram As Diagram, _
value As Type _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DefaultEffect Method

DiagramExtensions.DefaultEffect Method
[image]

Sets the default value for UIElement.Effect property of new items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DefaultEffect (
Diagram diagram,
Effect value
)

Visual Basic [image] Copy Code

Public Shared Function DefaultEffect( _
diagram As Diagram, _
value As Effect _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DefaultShape Method

DiagramExtensions.DefaultShape Method
[image]

Sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DefaultShape (
Diagram diagram,
Shape value
)

Visual Basic [image] Copy Code

Public Shared Function DefaultShape( _
diagram As Diagram, _
value As Shape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DelKeyAction Method

DiagramExtensions.DelKeyAction Method
[image]

Sets a value that specifies what action should be performed when the user hits the Del key.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DelKeyAction (
Diagram diagram,
DelKeyAction value
)

Visual Basic [image] Copy Code

Public Shared Function DelKeyAction( _
diagram As Diagram, _
value As DelKeyAction _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DiagonalResizeCursor Method

DiagramExtensions.DiagonalResizeCursor Method
[image]

Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DiagonalResizeCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function DiagonalResizeCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DiagramLinkStyle Method

DiagramExtensions.DiagramLinkStyle Method
[image]

Sets the theme-level style for diagram links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DiagramLinkStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function DiagramLinkStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Dirty Method

DiagramExtensions.Dirty Method
[image]

Sets a value indicating whether the diagram has changed since the last save.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Dirty (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function Dirty( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DisallowCursor Method

DiagramExtensions.DisallowCursor Method
[image]

Sets the mouse cursor shown to the user when an object cannot be created at a given location.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DisallowCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function DisallowCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DisallowLinkCursor Method

DiagramExtensions.DisallowLinkCursor Method
[image]

Sets the mouse cursor shown to the user when an arrow is being created but cannot be ended at the current location.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DisallowLinkCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function DisallowLinkCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DrawLinkCursor Method

DiagramExtensions.DrawLinkCursor Method
[image]

Sets the mouse cursor shown to the user when an arrow can be started at the current position.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DrawLinkCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function DrawLinkCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.DynamicLinks Method

DiagramExtensions.DynamicLinks Method
[image]

Sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram DynamicLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function DynamicLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.EnableLanes Method

DiagramExtensions.EnableLanes Method
[image]

Sets whether lanes are enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram EnableLanes (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function EnableLanes( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.EnableStyledText Method

DiagramExtensions.EnableStyledText Method
[image]

Sets the default value for the EnableStyledText property of new nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram EnableStyledText (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function EnableStyledText( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ExpandButtonAction Method

DiagramExtensions.ExpandButtonAction Method
[image]

Sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ExpandButtonAction (
Diagram diagram,
ExpandButtonAction value
)

Visual Basic [image] Copy Code

Public Shared Function ExpandButtonAction( _
diagram As Diagram, _
value As ExpandButtonAction _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ExpandButtonPosition Method

DiagramExtensions.ExpandButtonPosition Method
[image]

Sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ExpandButtonPosition (
Diagram diagram,
ExpandButtonPosition value
)

Visual Basic [image] Copy Code

Public Shared Function ExpandButtonPosition( _
diagram As Diagram, _
value As ExpandButtonPosition _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ExpandOnIncoming Method

DiagramExtensions.ExpandOnIncoming Method
[image]

Sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ExpandOnIncoming (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ExpandOnIncoming( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Font Method

DiagramExtensions.Font Method
[image]

Sets the default font for new diagram items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Font (
Diagram diagram,
Font value
)

Visual Basic [image] Copy Code

Public Shared Function Font( _
diagram As Diagram, _
value As Font _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.FreeFormAttractDistance Method

DiagramExtensions.FreeFormAttractDistance Method
[image]

Sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram FreeFormAttractDistance (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function FreeFormAttractDistance( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.FreeFormTargets Method

DiagramExtensions.FreeFormTargets Method
[image]

An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram FreeFormTargets (
Diagram diagram,
Shape[] value
)

Visual Basic [image] Copy Code

Public Shared Function FreeFormTargets( _
diagram As Diagram, _
value() As Shape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridOffsetX Method

DiagramExtensions.GridOffsetX Method
[image]

Sets the horizontal offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridOffsetX (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridOffsetX( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridOffsetY Method

DiagramExtensions.GridOffsetY Method
[image]

Sets the vertical offset of the first point of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridOffsetY (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridOffsetY( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridPen Method

DiagramExtensions.GridPen Method
[image]

Sets the Pen/Brush of the grid lines/points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridPen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function GridPen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridSizeX Method

DiagramExtensions.GridSizeX Method
[image]

Sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridSizeX (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridSizeX( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridSizeY Method

DiagramExtensions.GridSizeY Method
[image]

Sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridSizeY (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridSizeY( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.GridStyle Method

DiagramExtensions.GridStyle Method
[image]

Sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram GridStyle (
Diagram diagram,
GridStyle value
)

Visual Basic [image] Copy Code

Public Shared Function GridStyle( _
diagram As Diagram, _
value As GridStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.HitTestPriority Method

DiagramExtensions.HitTestPriority Method
[image]

Sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram HitTestPriority (
Diagram diagram,
HitTestPriority value
)

Visual Basic [image] Copy Code

Public Shared Function HitTestPriority( _
diagram As Diagram, _
value As HitTestPriority _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.HorizontalResizeCursor Method

DiagramExtensions.HorizontalResizeCursor Method
[image]

Sets the mouse cursor shown to the user if dragging would resize an object horizontally.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram HorizontalResizeCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function HorizontalResizeCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.InplaceEditAcceptOnEnter Method

DiagramExtensions.InplaceEditAcceptOnEnter Method
[image]

Sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram InplaceEditAcceptOnEnter (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function InplaceEditAcceptOnEnter( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.InplaceEditCancelOnEsc Method

DiagramExtensions.InplaceEditCancelOnEsc Method
[image]

Sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram InplaceEditCancelOnEsc (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function InplaceEditCancelOnEsc( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.InplaceEditFont Method

DiagramExtensions.InplaceEditFont Method
[image]

Sets the font of the inplace-edit text box.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram InplaceEditFont (
Diagram diagram,
Font value
)

Visual Basic [image] Copy Code

Public Shared Function InplaceEditFont( _
diagram As Diagram, _
value As Font _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBaseShape Method

DiagramExtensions.LinkBaseShape Method
[image]

Sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkBaseShape (
Diagram diagram,
Shape value
)

Visual Basic [image] Copy Code

Public Shared Function LinkBaseShape( _
diagram As Diagram, _
value As Shape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBaseShapeSize Method

DiagramExtensions.LinkBaseShapeSize Method
[image]

Sets the default size of the base of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkBaseShapeSize (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkBaseShapeSize( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBrush Method (Diagram, Brush)

DiagramExtensions.LinkBrush Method (Diagram, Brush)
See Also
[image]

Sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function LinkBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

LinkBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBrush Method (Diagram, Color)

DiagramExtensions.LinkBrush Method (Diagram, Color)
See Also
[image]

Sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function LinkBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

LinkBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.LinkBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function LinkBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

LinkBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkCascadeOrientation Method

DiagramExtensions.LinkCascadeOrientation Method
[image]

Sets the initial orientation of the first segment of new cascading links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkCascadeOrientation (
Diagram diagram,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function LinkCascadeOrientation( _
diagram As Diagram, _
value As Orientation _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkCrossings Method

DiagramExtensions.LinkCrossings Method
[image]

Sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkCrossings (
Diagram diagram,
LinkCrossings value
)

Visual Basic [image] Copy Code

Public Shared Function LinkCrossings( _
diagram As Diagram, _
value As LinkCrossings _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkCustomDraw Method

DiagramExtensions.LinkCustomDraw Method
[image]

Sets the default type of custom painting done on links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkCustomDraw (
Diagram diagram,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function LinkCustomDraw( _
diagram As Diagram, _
value As CustomDraw _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkEndsMovable Method

DiagramExtensions.LinkEndsMovable Method
[image]

Sets a value indicating whether arrow ends can be moved by users after the link is created.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkEndsMovable (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function LinkEndsMovable( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkHandlesStyle Method

DiagramExtensions.LinkHandlesStyle Method
[image]

Sets the default value for the HandlesStyle property of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkHandlesStyle (
Diagram diagram,
HandlesStyle value
)

Visual Basic [image] Copy Code

Public Shared Function LinkHandlesStyle( _
diagram As Diagram, _
value As HandlesStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkHeadShape Method

DiagramExtensions.LinkHeadShape Method
[image]

Sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkHeadShape (
Diagram diagram,
Shape value
)

Visual Basic [image] Copy Code

Public Shared Function LinkHeadShape( _
diagram As Diagram, _
value As Shape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkHeadShapeSize Method

DiagramExtensions.LinkHeadShapeSize Method
[image]

Sets the default size of arrowheads.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkHeadShapeSize (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkHeadShapeSize( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkHitDistance Method

DiagramExtensions.LinkHitDistance Method
[image]

Sets a value specifying how far from a link a click is still considered a hit.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkHitDistance (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkHitDistance( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkIntermediateShape Method

DiagramExtensions.LinkIntermediateShape Method
[image]

Sets default shape to be displayed in the middle of each segment of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkIntermediateShape (
Diagram diagram,
Shape value
)

Visual Basic [image] Copy Code

Public Shared Function LinkIntermediateShape( _
diagram As Diagram, _
value As Shape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkIntermediateShapeSize Method

DiagramExtensions.LinkIntermediateShapeSize Method
[image]

Sets the default size of the shapes at middles of link segments.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkIntermediateShapeSize (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkIntermediateShapeSize( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkPen Method

DiagramExtensions.LinkPen Method
[image]

Sets the default value for the Pen and HeadPen properties of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkPen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function LinkPen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkRouter Method

DiagramExtensions.LinkRouter Method
[image]

Sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkRouter (
Diagram diagram,
ILinkRouter value
)

Visual Basic [image] Copy Code

Public Shared Function LinkRouter( _
diagram As Diagram, _
value As ILinkRouter _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkSegments Method

DiagramExtensions.LinkSegments Method
[image]

Sets the default number of link segments.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkSegments (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function LinkSegments( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkShape Method

DiagramExtensions.LinkShape Method
[image]

Sets the default shape of diagram links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkShape (
Diagram diagram,
LinkShape value
)

Visual Basic [image] Copy Code

Public Shared Function LinkShape( _
diagram As Diagram, _
value As LinkShape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinksRetainForm Method

DiagramExtensions.LinksRetainForm Method
[image]

Sets whether links should maintain their forms if the nodes linked with those links are moved around.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinksRetainForm (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function LinksRetainForm( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkText Method

DiagramExtensions.LinkText Method
[image]

Sets the default text of links.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkText (
Diagram diagram,
string value
)

Visual Basic [image] Copy Code

Public Shared Function LinkText( _
diagram As Diagram, _
value As String _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkTextStyle Method

DiagramExtensions.LinkTextStyle Method
[image]

Sets default placement and orientation for links' text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram LinkTextStyle (
Diagram diagram,
LinkTextStyle value
)

Visual Basic [image] Copy Code

Public Shared Function LinkTextStyle( _
diagram As Diagram, _
value As LinkTextStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MagnifierEnabled Method

DiagramExtensions.MagnifierEnabled Method
[image]

Sets a value indicating whether the magnifier tool is currently enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MagnifierEnabled (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function MagnifierEnabled( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MagnifierFactor Method

DiagramExtensions.MagnifierFactor Method
[image]

Sets the zoom factor of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MagnifierFactor (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function MagnifierFactor( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MagnifierHeight Method

DiagramExtensions.MagnifierHeight Method
[image]

Sets the height of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MagnifierHeight (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function MagnifierHeight( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MagnifierStyle Method

DiagramExtensions.MagnifierStyle Method
[image]

Sets the style of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MagnifierStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function MagnifierStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MagnifierWidth Method

DiagramExtensions.MagnifierWidth Method
[image]

Sets the width of the magnifier tool.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MagnifierWidth (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function MagnifierWidth( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MeasureUnit Method

DiagramExtensions.MeasureUnit Method
[image]

Sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MeasureUnit (
Diagram diagram,
GraphicsUnit value
)

Visual Basic [image] Copy Code

Public Shared Function MeasureUnit( _
diagram As Diagram, _
value As GraphicsUnit _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MergeThreshold Method

DiagramExtensions.MergeThreshold Method
[image]

Sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MergeThreshold (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function MergeThreshold( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MiddleButtonActions Method

DiagramExtensions.MiddleButtonActions Method
[image]

Sets a combination of flags that specify what actions can be performed via the middle mouse button.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MiddleButtonActions (
Diagram diagram,
MouseButtonActions value
)

Visual Basic [image] Copy Code

Public Shared Function MiddleButtonActions( _
diagram As Diagram, _
value As MouseButtonActions _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MinimumNodeSize Method

DiagramExtensions.MinimumNodeSize Method
[image]

Sets the minimum node size that the user is allowed to set.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MinimumNodeSize (
Diagram diagram,
Size value
)

Visual Basic [image] Copy Code

Public Shared Function MinimumNodeSize( _
diagram As Diagram, _
value As Size _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ModificationEffect Method

DiagramExtensions.ModificationEffect Method
[image]

Sets the visual effect to apply during interactive modification of items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ModificationEffect (
Diagram diagram,
ModificationEffect value
)

Visual Basic [image] Copy Code

Public Shared Function ModificationEffect( _
diagram As Diagram, _
value As ModificationEffect _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ModificationStart Method

DiagramExtensions.ModificationStart Method
[image]

Sets how users can start modifying diagram items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ModificationStart (
Diagram diagram,
ModificationStart value
)

Visual Basic [image] Copy Code

Public Shared Function ModificationStart( _
diagram As Diagram, _
value As ModificationStart _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.MoveCursor Method

DiagramExtensions.MoveCursor Method
[image]

Sets the mouse cursor shown to the user if the pointed object can be modified.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram MoveCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function MoveCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.NodesExpandable Method

DiagramExtensions.NodesExpandable Method
[image]

Sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram NodesExpandable (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function NodesExpandable( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.NodeTemplate Method

DiagramExtensions.NodeTemplate Method
[image]

Sets the default DataTemplate used to display TemplatedNodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram NodeTemplate (
Diagram diagram,
DataTemplate value
)

Visual Basic [image] Copy Code

Public Shared Function NodeTemplate( _
diagram As Diagram, _
value As DataTemplate _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.OverrideCursor Method

DiagramExtensions.OverrideCursor Method
[image]

Sets the cursor and stops changing it depending on the context.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram OverrideCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function OverrideCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.PanCursor Method

DiagramExtensions.PanCursor Method
[image]

Sets the mouse cursor displayed while panning the diagram view.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram PanCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function PanCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.PanInertia Method

DiagramExtensions.PanInertia Method
[image]

Sets a value indicating whether panning the view will have inertia.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram PanInertia (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function PanInertia( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.PointerCursor Method

DiagramExtensions.PointerCursor Method
[image]

Sets the mouse cursor shown to the user when no modification is performed.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram PointerCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function PointerCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.PolygonalTextLayout Method

DiagramExtensions.PolygonalTextLayout Method
[image]

Sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram PolygonalTextLayout (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function PolygonalTextLayout( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RecursiveExpand Method

DiagramExtensions.RecursiveExpand Method
[image]

Sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RecursiveExpand (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function RecursiveExpand( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RemoveHiddenItemsFromVisualTree Method

DiagramExtensions.RemoveHiddenItemsFromVisualTree Method
[image]

For internal use.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RemoveHiddenItemsFromVisualTree (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function RemoveHiddenItemsFromVisualTree( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RestrictItemsToBounds Method

DiagramExtensions.RestrictItemsToBounds Method
[image]

Sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RestrictItemsToBounds (
Diagram diagram,
RestrictToBounds value
)

Visual Basic [image] Copy Code

Public Shared Function RestrictItemsToBounds( _
diagram As Diagram, _
value As RestrictToBounds _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RightButtonActions Method

DiagramExtensions.RightButtonActions Method
[image]

Sets a combination of flags that specify what actions can be performed via the right mouse button.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RightButtonActions (
Diagram diagram,
MouseButtonActions value
)

Visual Basic [image] Copy Code

Public Shared Function RightButtonActions( _
diagram As Diagram, _
value As MouseButtonActions _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RotateCursor Method

DiagramExtensions.RotateCursor Method
[image]

Sets the cursor shown when the mouse is over a node rotation handle.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RotateCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function RotateCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RotationStep Method

DiagramExtensions.RotationStep Method
[image]

Sets the RotationAngle increment when users rotate a node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RotationStep (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function RotationStep( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RoundedLinks Method

DiagramExtensions.RoundedLinks Method
[image]

Sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RoundedLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function RoundedLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RoundedLinksRadius Method

DiagramExtensions.RoundedLinksRadius Method
[image]

Sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RoundedLinksRadius (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function RoundedLinksRadius( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RoundRectFactor Method

DiagramExtensions.RoundRectFactor Method
[image]

Sets the relative size of arcs displayed at the corners of rounded rectangles.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RoundRectFactor (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function RoundRectFactor( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RouteLinks Method

DiagramExtensions.RouteLinks Method
[image]

Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RouteLinks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function RouteLinks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RowHighlightBrush Method (Diagram, Brush)

DiagramExtensions.RowHighlightBrush Method (Diagram, Brush)
See Also
[image]

Sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RowHighlightBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function RowHighlightBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

RowHighlightBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RowHighlightBrush Method (Diagram, Color)

DiagramExtensions.RowHighlightBrush Method (Diagram, Color)
See Also
[image]

Sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RowHighlightBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function RowHighlightBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

RowHighlightBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RowHighlightBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.RowHighlightBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram RowHighlightBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function RowHighlightBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

RowHighlightBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ScrollX Method

DiagramExtensions.ScrollX Method
[image]

Sets the document's X scroll position.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ScrollX (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ScrollX( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ScrollY Method

DiagramExtensions.ScrollY Method
[image]

Sets the document's Y scroll position.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ScrollY (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ScrollY( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ScrollZoneSize Method

DiagramExtensions.ScrollZoneSize Method
[image]

Sets the size of the auto scroll zone near the edges of the control.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ScrollZoneSize (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function ScrollZoneSize( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.SelectAfterCreate Method

DiagramExtensions.SelectAfterCreate Method
[image]

Sets a value indicating whether newly created objects are automatically selected.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram SelectAfterCreate (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SelectAfterCreate( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.SelectionOnTop Method

DiagramExtensions.SelectionOnTop Method
[image]

Sets a value indicating whether selected items should be painted on top of other items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram SelectionOnTop (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SelectionOnTop( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeBrush Method (Diagram, Brush)

DiagramExtensions.ShapeBrush Method (Diagram, Brush)
See Also
[image]

Sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

ShapeBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeBrush Method (Diagram, Color)

DiagramExtensions.ShapeBrush Method (Diagram, Color)
See Also
[image]

Sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function ShapeBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

ShapeBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.ShapeBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function ShapeBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

ShapeBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeCustomDraw Method

DiagramExtensions.ShapeCustomDraw Method
[image]

Sets the default type of custom painting done for shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeCustomDraw (
Diagram diagram,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeCustomDraw( _
diagram As Diagram, _
value As CustomDraw _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeHandlesStyle Method

DiagramExtensions.ShapeHandlesStyle Method
[image]

Sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeHandlesStyle (
Diagram diagram,
HandlesStyle value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeHandlesStyle( _
diagram As Diagram, _
value As HandlesStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeNodeStyle Method

DiagramExtensions.ShapeNodeStyle Method
[image]

Sets the theme-level style for shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeNodeStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeNodeStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeOrientation Method

DiagramExtensions.ShapeOrientation Method
[image]

Sets the default value for the ShapeOrientation property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeOrientation (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeOrientation( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapePen Method

DiagramExtensions.ShapePen Method
[image]

Sets the default value for the Pen property of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapePen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function ShapePen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeText Method

DiagramExtensions.ShapeText Method
[image]

Sets the default text of shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShapeText (
Diagram diagram,
string value
)

Visual Basic [image] Copy Code

Public Shared Function ShapeText( _
diagram As Diagram, _
value As String _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShowAnchors Method

DiagramExtensions.ShowAnchors Method
[image]

Sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShowAnchors (
Diagram diagram,
ShowAnchors value
)

Visual Basic [image] Copy Code

Public Shared Function ShowAnchors( _
diagram As Diagram, _
value As ShowAnchors _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShowDisabledHandles Method

DiagramExtensions.ShowDisabledHandles Method
[image]

Sets a value indicating whether manipulation handles are painted when they are disabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShowDisabledHandles (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ShowDisabledHandles( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShowGrid Method

DiagramExtensions.ShowGrid Method
[image]

Sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShowGrid (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ShowGrid( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShowHandlesOnDrag Method

DiagramExtensions.ShowHandlesOnDrag Method
[image]

Sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ShowHandlesOnDrag (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ShowHandlesOnDrag( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.SnapToAnchor Method

DiagramExtensions.SnapToAnchor Method
[image]

Sets when arrow end points should be aligned to the nearest anchor points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram SnapToAnchor (
Diagram diagram,
SnapToAnchor value
)

Visual Basic [image] Copy Code

Public Shared Function SnapToAnchor( _
diagram As Diagram, _
value As SnapToAnchor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.SortGroupsByZ Method

DiagramExtensions.SortGroupsByZ Method
[image]

Sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram SortGroupsByZ (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SortGroupsByZ( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableBrush Method (Diagram, Brush)

DiagramExtensions.TableBrush Method (Diagram, Brush)
See Also
[image]

Sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function TableBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

TableBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableBrush Method (Diagram, Color)

DiagramExtensions.TableBrush Method (Diagram, Color)
See Also
[image]

Sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function TableBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

TableBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.TableBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function TableBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

TableBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableCaption Method

DiagramExtensions.TableCaption Method
[image]

Sets the default text for tables' captions.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableCaption (
Diagram diagram,
string value
)

Visual Basic [image] Copy Code

Public Shared Function TableCaption( _
diagram As Diagram, _
value As String _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableCaptionHeight Method

DiagramExtensions.TableCaptionHeight Method
[image]

Sets the default height of table captions.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableCaptionHeight (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function TableCaptionHeight( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableColumnCount Method

DiagramExtensions.TableColumnCount Method
[image]

Sets the default number of table columns.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableColumnCount (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function TableColumnCount( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableColumnWidth Method

DiagramExtensions.TableColumnWidth Method
[image]

Sets the default width of tables' columns.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableColumnWidth (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function TableColumnWidth( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableConnectionStyle Method

DiagramExtensions.TableConnectionStyle Method
[image]

Sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableConnectionStyle (
Diagram diagram,
TableConnectionStyle value
)

Visual Basic [image] Copy Code

Public Shared Function TableConnectionStyle( _
diagram As Diagram, _
value As TableConnectionStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableCustomDraw Method

DiagramExtensions.TableCustomDraw Method
[image]

Sets the default type of custom painting done on tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableCustomDraw (
Diagram diagram,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function TableCustomDraw( _
diagram As Diagram, _
value As CustomDraw _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableHandlesStyle Method

DiagramExtensions.TableHandlesStyle Method
[image]

Sets the default value for the HandlesStyle property of new tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableHandlesStyle (
Diagram diagram,
HandlesStyle value
)

Visual Basic [image] Copy Code

Public Shared Function TableHandlesStyle( _
diagram As Diagram, _
value As HandlesStyle _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableNodeStyle Method

DiagramExtensions.TableNodeStyle Method
[image]

Sets the theme-level style for table nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableNodeStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function TableNodeStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TablePen Method

DiagramExtensions.TablePen Method
[image]

Sets the default value for the Pen property of tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TablePen (
Diagram diagram,
Pen value
)

Visual Basic [image] Copy Code

Public Shared Function TablePen( _
diagram As Diagram, _
value As Pen _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableRowCount Method

DiagramExtensions.TableRowCount Method
[image]

Sets the default number of table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableRowCount (
Diagram diagram,
int value
)

Visual Basic [image] Copy Code

Public Shared Function TableRowCount( _
diagram As Diagram, _
value As Integer _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableRowHeight Method

DiagramExtensions.TableRowHeight Method
[image]

Sets the default height of tables' rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableRowHeight (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function TableRowHeight( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableShape Method

DiagramExtensions.TableShape Method
[image]

Sets the default shape of new tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TableShape (
Diagram diagram,
SimpleShape value
)

Visual Basic [image] Copy Code

Public Shared Function TableShape( _
diagram As Diagram, _
value As SimpleShape _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TablesScrollable Method

DiagramExtensions.TablesScrollable Method
[image]

Sets the default value for the Scrollable property of new tables.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TablesScrollable (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function TablesScrollable( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Tag Method

DiagramExtensions.Tag Method
[image]

Sets custom data associated with this diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Tag (
Diagram diagram,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Tag( _
diagram As Diagram, _
value As Object _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TextBrush Method (Diagram, Brush)

DiagramExtensions.TextBrush Method (Diagram, Brush)
See Also
[image]

Sets the default brush of text displayed inside diagram items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TextBrush (
Diagram diagram,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function TextBrush( _
diagram As Diagram, _
value As Brush _
) As Diagram

Parameters

diagram

value

Return Value

See Also

TextBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TextBrush Method (Diagram, Color)

DiagramExtensions.TextBrush Method (Diagram, Color)
See Also
[image]

Sets the default brush of text displayed inside diagram items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TextBrush (
Diagram diagram,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function TextBrush( _
diagram As Diagram, _
color As Color _
) As Diagram

Parameters

diagram

color

Return Value

See Also

TextBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TextBrush Method (Diagram, Color, Color, Single)

DiagramExtensions.TextBrush Method (Diagram, Color, Color, Single)
See Also
[image]

Sets the default brush of text displayed inside diagram items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TextBrush (
Diagram diagram,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function TextBrush( _
diagram As Diagram, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As Diagram

Parameters

diagram

color1

color2

angle

Return Value

See Also

TextBrush Method Overload List
DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TextFormat Method

DiagramExtensions.TextFormat Method
[image]

Sets the default alignment and formatting style for text displayed inside nodes and table cells.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TextFormat (
Diagram diagram,
StringFormat value
)

Visual Basic [image] Copy Code

Public Shared Function TextFormat( _
diagram As Diagram, _
value As StringFormat _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.Theme Method

DiagramExtensions.Theme Method
[image]

Sets the theme associated with the diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram Theme (
Diagram diagram,
Theme value
)

Visual Basic [image] Copy Code

Public Shared Function Theme( _
diagram As Diagram, _
value As Theme _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ToolTip Method

DiagramExtensions.ToolTip Method
[image]

Sets a short text message displayed when the mouse pointer rests over the diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ToolTip (
Diagram diagram,
string value
)

Visual Basic [image] Copy Code

Public Shared Function ToolTip( _
diagram As Diagram, _
value As String _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TreeViewNodeStyle Method

DiagramExtensions.TreeViewNodeStyle Method
[image]

Sets the theme-level style for treeview nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram TreeViewNodeStyle (
Diagram diagram,
Style value
)

Visual Basic [image] Copy Code

Public Shared Function TreeViewNodeStyle( _
diagram As Diagram, _
value As Style _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ValidityChecks Method

DiagramExtensions.ValidityChecks Method
[image]

Sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ValidityChecks (
Diagram diagram,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function ValidityChecks( _
diagram As Diagram, _
value As Boolean _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.VerticalResizeCursor Method

DiagramExtensions.VerticalResizeCursor Method
[image]

Sets the mouse cursor shown to the user if dragging would resize an object vertically.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram VerticalResizeCursor (
Diagram diagram,
Cursor value
)

Visual Basic [image] Copy Code

Public Shared Function VerticalResizeCursor( _
diagram As Diagram, _
value As Cursor _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ZoomFactor Method

DiagramExtensions.ZoomFactor Method
[image]

Sets the zoom factor used to scale up or down the Diagram.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static Diagram ZoomFactor (
Diagram diagram,
double value
)

Visual Basic [image] Copy Code

Public Shared Function ZoomFactor( _
diagram As Diagram, _
value As Double _
) As Diagram

Parameters

diagram

value

Return Value

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Brush(T) Method (T, Brush)

DiagramItemExtensions.Brush(T) Method (T, Brush)
See Also
[image]

Sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Brush<T> (
T diagramItem,
Brush value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Brush(Of T As DiagramItem) ( _
diagramItem As T, _
value As Brush _
) As T

Parameters

diagramItem

value

Return Value

See Also

Brush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Brush(T) Method (T, Color)

DiagramItemExtensions.Brush(T) Method (T, Color)
See Also
[image]

Sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Brush<T> (
T diagramItem,
Color color
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Brush(Of T As DiagramItem) ( _
diagramItem As T, _
color As Color _
) As T

Parameters

diagramItem

color

Return Value

See Also

Brush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Brush(T) Method (T, Color, Color, Single)

DiagramItemExtensions.Brush(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Brush<T> (
T diagramItem,
Color color1,
Color color2,
float angle
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Brush(Of T As DiagramItem) ( _
diagramItem As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

diagramItem

color1

color2

angle

Return Value

See Also

Brush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Font(T) Method (T, Font)

DiagramItemExtensions.Font(T) Method (T, Font)
See Also
[image]

Sets the font used to render the item's text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Font<T> (
T diagramItem,
Font value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Font(Of T As DiagramItem) ( _
diagramItem As T, _
value As Font _
) As T

Parameters

diagramItem

value

Return Value

See Also

Font Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Font(T) Method (T, String, Double)

DiagramItemExtensions.Font(T) Method (T, String, Double)
See Also
[image]

Sets the preferred font family for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Font<T> (
T diagramItem,
string fontName,
double fontSize
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Font(Of T As DiagramItem) ( _
diagramItem As T, _
fontName As String, _
fontSize As Double _
) As T

Parameters

diagramItem

fontName

fontSize

Return Value

See Also

Font Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.FontFamily(T) Method

DiagramItemExtensions.FontFamily(T) Method
[image]

Sets the preferred font family for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FontFamily<T> (
T diagramItem,
FontFamily value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function FontFamily(Of T As DiagramItem) ( _
diagramItem As T, _
value As FontFamily _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.FontSize(T) Method

DiagramItemExtensions.FontSize(T) Method
[image]

Sets the font size for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FontSize<T> (
T diagramItem,
double value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function FontSize(Of T As DiagramItem) ( _
diagramItem As T, _
value As Double _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.FontStretch(T) Method

DiagramItemExtensions.FontStretch(T) Method
[image]

Sets the font-stretching characteristics for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FontStretch<T> (
T diagramItem,
FontStretch value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function FontStretch(Of T As DiagramItem) ( _
diagramItem As T, _
value As FontStretch _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.FontStyle(T) Method

DiagramItemExtensions.FontStyle(T) Method
[image]

Sets the font style for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FontStyle<T> (
T diagramItem,
FontStyle value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function FontStyle(Of T As DiagramItem) ( _
diagramItem As T, _
value As FontStyle _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.FontWeight(T) Method

DiagramItemExtensions.FontWeight(T) Method
[image]

Sets the font weight for this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FontWeight<T> (
T diagramItem,
FontWeight value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function FontWeight(Of T As DiagramItem) ( _
diagramItem As T, _
value As FontWeight _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.HyperLink(T) Method

DiagramItemExtensions.HyperLink(T) Method
[image]

Sets the hyperlink associated with this diagram item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HyperLink<T> (
T diagramItem,
string value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function HyperLink(Of T As DiagramItem) ( _
diagramItem As T, _
value As String _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Id(T) Method

DiagramItemExtensions.Id(T) Method
[image]

Sets user-defined identifier associated with this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Id<T> (
T diagramItem,
Object value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Id(Of T As DiagramItem) ( _
diagramItem As T, _
value As Object _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.IgnoreLayout(T) Method

DiagramItemExtensions.IgnoreLayout(T) Method
[image]

Sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IgnoreLayout<T> (
T diagramItem,
bool value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function IgnoreLayout(Of T As DiagramItem) ( _
diagramItem As T, _
value As Boolean _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.LayerIndex(T) Method

DiagramItemExtensions.LayerIndex(T) Method
[image]

Sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LayerIndex<T> (
T diagramItem,
int value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function LayerIndex(Of T As DiagramItem) ( _
diagramItem As T, _
value As Integer _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Locked(T) Method

DiagramItemExtensions.Locked(T) Method
[image]

Sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Locked<T> (
T diagramItem,
bool value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Locked(Of T As DiagramItem) ( _
diagramItem As T, _
value As Boolean _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Pen(T) Method

DiagramItemExtensions.Pen(T) Method
[image]

Sets the pen used to paint the frame of the item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Pen<T> (
T diagramItem,
Pen value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Pen(Of T As DiagramItem) ( _
diagramItem As T, _
value As Pen _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Printable(T) Method

DiagramItemExtensions.Printable(T) Method
[image]

Sets a value indicating whether to print the item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Printable<T> (
T diagramItem,
bool value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Printable(Of T As DiagramItem) ( _
diagramItem As T, _
value As Boolean _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Selected(T) Method

DiagramItemExtensions.Selected(T) Method
[image]

Sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Selected<T> (
T diagramItem,
bool value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Selected(Of T As DiagramItem) ( _
diagramItem As T, _
value As Boolean _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Stroke(T) Method (T, Brush)

DiagramItemExtensions.Stroke(T) Method (T, Brush)
See Also
[image]

Sets the Brush that specifies how the item outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Stroke<T> (
T diagramItem,
Brush value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Stroke(Of T As DiagramItem) ( _
diagramItem As T, _
value As Brush _
) As T

Parameters

diagramItem

value

Return Value

See Also

Stroke Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Stroke(T) Method (T, Color)

DiagramItemExtensions.Stroke(T) Method (T, Color)
See Also
[image]

Sets the Brush that specifies how the item outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Stroke<T> (
T diagramItem,
Color color
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Stroke(Of T As DiagramItem) ( _
diagramItem As T, _
color As Color _
) As T

Parameters

diagramItem

color

Return Value

See Also

Stroke Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Stroke(T) Method (T, Color, Color, Single)

DiagramItemExtensions.Stroke(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the Brush that specifies how the item outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Stroke<T> (
T diagramItem,
Color color1,
Color color2,
float angle
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Stroke(Of T As DiagramItem) ( _
diagramItem As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

diagramItem

color1

color2

angle

Return Value

See Also

Stroke Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeDashCap(T) Method

DiagramItemExtensions.StrokeDashCap(T) Method
[image]

Sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeDashCap<T> (
T diagramItem,
PenLineCap value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeDashCap(Of T As DiagramItem) ( _
diagramItem As T, _
value As PenLineCap _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeDashStyle(T) Method

DiagramItemExtensions.StrokeDashStyle(T) Method
[image]

Sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeDashStyle<T> (
T diagramItem,
DashStyle value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeDashStyle(Of T As DiagramItem) ( _
diagramItem As T, _
value As DashStyle _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeEndLineCap(T) Method

DiagramItemExtensions.StrokeEndLineCap(T) Method
[image]

Sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeEndLineCap<T> (
T diagramItem,
PenLineCap value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeEndLineCap(Of T As DiagramItem) ( _
diagramItem As T, _
value As PenLineCap _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeLineJoin(T) Method

DiagramItemExtensions.StrokeLineJoin(T) Method
[image]

Sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeLineJoin<T> (
T diagramItem,
PenLineJoin value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeLineJoin(Of T As DiagramItem) ( _
diagramItem As T, _
value As PenLineJoin _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeMiterLimit(T) Method

DiagramItemExtensions.StrokeMiterLimit(T) Method
[image]

Sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeMiterLimit<T> (
T diagramItem,
double value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeMiterLimit(Of T As DiagramItem) ( _
diagramItem As T, _
value As Double _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeStartLineCap(T) Method

DiagramItemExtensions.StrokeStartLineCap(T) Method
[image]

Sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeStartLineCap<T> (
T diagramItem,
PenLineCap value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeStartLineCap(Of T As DiagramItem) ( _
diagramItem As T, _
value As PenLineCap _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.StrokeThickness(T) Method

DiagramItemExtensions.StrokeThickness(T) Method
[image]

Sets the width of the DiagramItem stroke outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StrokeThickness<T> (
T diagramItem,
double value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function StrokeThickness(Of T As DiagramItem) ( _
diagramItem As T, _
value As Double _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Tag(T) Method

DiagramItemExtensions.Tag(T) Method
[image]

Sets user-defined data associated with this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Tag<T> (
T diagramItem,
Object value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Tag(Of T As DiagramItem) ( _
diagramItem As T, _
value As Object _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Text(T) Method

DiagramItemExtensions.Text(T) Method
[image]

Sets the text displayed inside this item.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Text<T> (
T diagramItem,
string value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Text(Of T As DiagramItem) ( _
diagramItem As T, _
value As String _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextAlignment(T) Method

DiagramItemExtensions.TextAlignment(T) Method
[image]

Sets a value that indicates the horizontal alignment of text content.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextAlignment<T> (
T diagramItem,
TextAlignment value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextAlignment(Of T As DiagramItem) ( _
diagramItem As T, _
value As TextAlignment _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextBrush(T) Method (T, Brush)

DiagramItemExtensions.TextBrush(T) Method (T, Brush)
See Also
[image]

Sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextBrush<T> (
T diagramItem,
Brush value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextBrush(Of T As DiagramItem) ( _
diagramItem As T, _
value As Brush _
) As T

Parameters

diagramItem

value

Return Value

See Also

TextBrush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextBrush(T) Method (T, Color)

DiagramItemExtensions.TextBrush(T) Method (T, Color)
See Also
[image]

Sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextBrush<T> (
T diagramItem,
Color color
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextBrush(Of T As DiagramItem) ( _
diagramItem As T, _
color As Color _
) As T

Parameters

diagramItem

color

Return Value

See Also

TextBrush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextBrush(T) Method (T, Color, Color, Single)

DiagramItemExtensions.TextBrush(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the brush used to draw the item's text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextBrush<T> (
T diagramItem,
Color color1,
Color color2,
float angle
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextBrush(Of T As DiagramItem) ( _
diagramItem As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

diagramItem

color1

color2

angle

Return Value

See Also

TextBrush Method Overload List
DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextDecorations(T) Method

DiagramItemExtensions.TextDecorations(T) Method
[image]

Sets the effects to apply to the text of this DiagramItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextDecorations<T> (
T diagramItem,
TextDecorationCollection value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextDecorations(Of T As DiagramItem) ( _
diagramItem As T, _
value As TextDecorationCollection _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextPadding(T) Method

DiagramItemExtensions.TextPadding(T) Method
[image]

Sets the thickness of padding space between the item boundaries and its text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextPadding<T> (
T diagramItem,
Thickness value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextPadding(Of T As DiagramItem) ( _
diagramItem As T, _
value As Thickness _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextTrimming(T) Method

DiagramItemExtensions.TextTrimming(T) Method
[image]

Sets the text trimming to employ when text overflows the item area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextTrimming<T> (
T diagramItem,
TextTrimming value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextTrimming(Of T As DiagramItem) ( _
diagramItem As T, _
value As TextTrimming _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextVerticalAlignment(T) Method

DiagramItemExtensions.TextVerticalAlignment(T) Method
[image]

Sets a value that indicates the vertical alignment of text content.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextVerticalAlignment<T> (
T diagramItem,
AlignmentY value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextVerticalAlignment(Of T As DiagramItem) ( _
diagramItem As T, _
value As AlignmentY _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextWrapping(T) Method

DiagramItemExtensions.TextWrapping(T) Method
[image]

Sets how this DiagramItem should wrap text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextWrapping<T> (
T diagramItem,
TextWrapping value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function TextWrapping(Of T As DiagramItem) ( _
diagramItem As T, _
value As TextWrapping _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.ToolTip(T) Method

DiagramItemExtensions.ToolTip(T) Method
[image]

Sets a short text message displayed when the mouse pointer rests over a diagram element.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ToolTip<T> (
T diagramItem,
string value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function ToolTip(Of T As DiagramItem) ( _
diagramItem As T, _
value As String _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Visible(T) Method

DiagramItemExtensions.Visible(T) Method
[image]

Sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Visible<T> (
T diagramItem,
bool value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Visible(Of T As DiagramItem) ( _
diagramItem As T, _
value As Boolean _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Weight(T) Method

DiagramItemExtensions.Weight(T) Method
[image]

Sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Weight<T> (
T diagramItem,
double value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function Weight(Of T As DiagramItem) ( _
diagramItem As T, _
value As Double _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.ZIndex(T) Method

DiagramItemExtensions.ZIndex(T) Method
[image]

Sets the z-order position of the object.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ZIndex<T> (
T diagramItem,
int value
) where T : DiagramItem

Visual Basic [image] Copy Code

Public Shared Function ZIndex(Of T As DiagramItem) ( _
diagramItem As T, _
value As Integer _
) As T

Parameters

diagramItem

value

Return Value

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.AllowMoveEnd(T) Method

DiagramLinkExtensions.AllowMoveEnd(T) Method
[image]

Sets a value indicating whether the user is allowed to move the end point of a link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowMoveEnd<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function AllowMoveEnd(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.AllowMoveStart(T) Method

DiagramLinkExtensions.AllowMoveStart(T) Method
[image]

Sets a value indicating whether the user is allowed to move the first control point of a link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowMoveStart<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function AllowMoveStart(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.AutoRoute(T) Method

DiagramLinkExtensions.AutoRoute(T) Method
[image]

Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AutoRoute<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function AutoRoute(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.AutoSnapToNode(T) Method

DiagramLinkExtensions.AutoSnapToNode(T) Method
[image]

Sets a value indicating whether the link end points should automatically align to node borders while a user moves them.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AutoSnapToNode<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function AutoSnapToNode(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.BaseShape(T) Method

DiagramLinkExtensions.BaseShape(T) Method
[image]

Sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BaseShape<T> (
T diagramLink,
Shape value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function BaseShape(Of T As DiagramLink) ( _
diagramLink As T, _
value As Shape _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.BaseShapeSize(T) Method

DiagramLinkExtensions.BaseShapeSize(T) Method
[image]

Sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BaseShapeSize<T> (
T diagramLink,
double value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function BaseShapeSize(Of T As DiagramLink) ( _
diagramLink As T, _
value As Double _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.CascadeOrientation(T) Method

DiagramLinkExtensions.CascadeOrientation(T) Method
[image]

Sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CascadeOrientation<T> (
T diagramLink,
Orientation value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function CascadeOrientation(Of T As DiagramLink) ( _
diagramLink As T, _
value As Orientation _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.CustomDraw(T) Method

DiagramLinkExtensions.CustomDraw(T) Method
[image]

Sets the type of custom drawing performed on this link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CustomDraw<T> (
T diagramLink,
CustomDraw value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function CustomDraw(Of T As DiagramLink) ( _
diagramLink As T, _
value As CustomDraw _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.Destination(T) Method

DiagramLinkExtensions.Destination(T) Method
[image]

Sets the destination node of this link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Destination<T> (
T diagramLink,
DiagramNode value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function Destination(Of T As DiagramLink) ( _
diagramLink As T, _
value As DiagramNode _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.DestinationAnchor(T) Method

DiagramLinkExtensions.DestinationAnchor(T) Method
[image]

Sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T DestinationAnchor<T> (
T diagramLink,
int value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function DestinationAnchor(Of T As DiagramLink) ( _
diagramLink As T, _
value As Integer _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.DestinationConnection(T) Method

DiagramLinkExtensions.DestinationConnection(T) Method
[image]

Sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T DestinationConnection<T> (
T diagramLink,
ConnectionPoint value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function DestinationConnection(Of T As DiagramLink) ( _
diagramLink As T, _
value As ConnectionPoint _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.DestinationIndex(T) Method

DiagramLinkExtensions.DestinationIndex(T) Method
[image]

Sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T DestinationIndex<T> (
T diagramLink,
int value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function DestinationIndex(Of T As DiagramLink) ( _
diagramLink As T, _
value As Integer _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.DrawCrossings(T) Method

DiagramLinkExtensions.DrawCrossings(T) Method
[image]

Sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T DrawCrossings<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function DrawCrossings(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.Dynamic(T) Method

DiagramLinkExtensions.Dynamic(T) Method
[image]

Sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Dynamic<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function Dynamic(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.EndPoint(T) Method

DiagramLinkExtensions.EndPoint(T) Method
[image]

Sets the last control point of a link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EndPoint<T> (
T diagramLink,
Point value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function EndPoint(Of T As DiagramLink) ( _
diagramLink As T, _
value As Point _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HandlesStyle(T) Method

DiagramLinkExtensions.HandlesStyle(T) Method
[image]

Sets the appearance of the link's selection handles.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HandlesStyle<T> (
T diagramLink,
HandlesStyle value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HandlesStyle(Of T As DiagramLink) ( _
diagramLink As T, _
value As HandlesStyle _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadPen(T) Method

DiagramLinkExtensions.HeadPen(T) Method
[image]

Sets the pen to use when painting arrowheads lines.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadPen<T> (
T diagramLink,
Pen value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadPen(Of T As DiagramLink) ( _
diagramLink As T, _
value As Pen _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadShape(T) Method

DiagramLinkExtensions.HeadShape(T) Method
[image]

Sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadShape<T> (
T diagramLink,
Shape value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadShape(Of T As DiagramLink) ( _
diagramLink As T, _
value As Shape _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadShapeSize(T) Method

DiagramLinkExtensions.HeadShapeSize(T) Method
[image]

Sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadShapeSize<T> (
T diagramLink,
double value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadShapeSize(Of T As DiagramLink) ( _
diagramLink As T, _
value As Double _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStroke(T) Method (T, Brush)

DiagramLinkExtensions.HeadStroke(T) Method (T, Brush)
See Also
[image]

Sets the Brush that specifies how the arrowhead stroke outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadStroke<T> (
T diagramLink,
Brush value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadStroke(Of T As DiagramLink) ( _
diagramLink As T, _
value As Brush _
) As T

Parameters

diagramLink

value

Return Value

See Also

HeadStroke Method Overload List
DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStroke(T) Method (T, Color)

DiagramLinkExtensions.HeadStroke(T) Method (T, Color)
See Also
[image]

Sets the Brush that specifies how the arrowhead stroke outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadStroke<T> (
T diagramLink,
Color color
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadStroke(Of T As DiagramLink) ( _
diagramLink As T, _
color As Color _
) As T

Parameters

diagramLink

color

Return Value

See Also

HeadStroke Method Overload List
DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStroke(T) Method (T, Color, Color, Single)

DiagramLinkExtensions.HeadStroke(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the Brush that specifies how the arrowhead stroke outline is painted.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadStroke<T> (
T diagramLink,
Color color1,
Color color2,
float angle
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadStroke(Of T As DiagramLink) ( _
diagramLink As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

diagramLink

color1

color2

angle

Return Value

See Also

HeadStroke Method Overload List
DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStrokeDashStyle(T) Method

DiagramLinkExtensions.HeadStrokeDashStyle(T) Method
[image]

Sets the pattern of dashes and gaps used to outline arrowhead shapes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadStrokeDashStyle<T> (
T diagramLink,
DashStyle value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadStrokeDashStyle(Of T As DiagramLink) ( _
diagramLink As T, _
value As DashStyle _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStrokeThickness(T) Method

DiagramLinkExtensions.HeadStrokeThickness(T) Method
[image]

Sets the width of the arrowhead stroke outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HeadStrokeThickness<T> (
T diagramLink,
double value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function HeadStrokeThickness(Of T As DiagramLink) ( _
diagramLink As T, _
value As Double _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.IntermediateShape(T) Method

DiagramLinkExtensions.IntermediateShape(T) Method
[image]

Sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IntermediateShape<T> (
T diagramLink,
Shape value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function IntermediateShape(Of T As DiagramLink) ( _
diagramLink As T, _
value As Shape _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.IntermediateShapeSize(T) Method

DiagramLinkExtensions.IntermediateShapeSize(T) Method
[image]

Sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IntermediateShapeSize<T> (
T diagramLink,
double value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function IntermediateShapeSize(Of T As DiagramLink) ( _
diagramLink As T, _
value As Double _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.Origin(T) Method

DiagramLinkExtensions.Origin(T) Method
[image]

Sets the origin node of the link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Origin<T> (
T diagramLink,
DiagramNode value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function Origin(Of T As DiagramLink) ( _
diagramLink As T, _
value As DiagramNode _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.OriginAnchor(T) Method

DiagramLinkExtensions.OriginAnchor(T) Method
[image]

Sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T OriginAnchor<T> (
T diagramLink,
int value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function OriginAnchor(Of T As DiagramLink) ( _
diagramLink As T, _
value As Integer _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.OriginConnection(T) Method

DiagramLinkExtensions.OriginConnection(T) Method
[image]

Sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T OriginConnection<T> (
T diagramLink,
ConnectionPoint value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function OriginConnection(Of T As DiagramLink) ( _
diagramLink As T, _
value As ConnectionPoint _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.OriginIndex(T) Method

DiagramLinkExtensions.OriginIndex(T) Method
[image]

Sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T OriginIndex<T> (
T diagramLink,
int value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function OriginIndex(Of T As DiagramLink) ( _
diagramLink As T, _
value As Integer _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.RetainForm(T) Method

DiagramLinkExtensions.RetainForm(T) Method
[image]

Sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RetainForm<T> (
T diagramLink,
bool value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function RetainForm(Of T As DiagramLink) ( _
diagramLink As T, _
value As Boolean _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.SegmentCount(T) Method

DiagramLinkExtensions.SegmentCount(T) Method
[image]

Sets the number of segments of this link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SegmentCount<T> (
T diagramLink,
int value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function SegmentCount(Of T As DiagramLink) ( _
diagramLink As T, _
value As Integer _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.Shape(T) Method

DiagramLinkExtensions.Shape(T) Method
[image]

Sets the type of link segments and how they are positioned relatively to each other.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Shape<T> (
T diagramLink,
LinkShape value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function Shape(Of T As DiagramLink) ( _
diagramLink As T, _
value As LinkShape _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.StartPoint(T) Method

DiagramLinkExtensions.StartPoint(T) Method
[image]

Sets the first control point of a link.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StartPoint<T> (
T diagramLink,
Point value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function StartPoint(Of T As DiagramLink) ( _
diagramLink As T, _
value As Point _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.TextStyle(T) Method

DiagramLinkExtensions.TextStyle(T) Method
[image]

Sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextStyle<T> (
T diagramLink,
LinkTextStyle value
) where T : DiagramLink

Visual Basic [image] Copy Code

Public Shared Function TextStyle(Of T As DiagramLink) ( _
diagramLink As T, _
value As LinkTextStyle _
) As T

Parameters

diagramLink

value

Return Value

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.AllowIncomingLinks(T) Method

DiagramNodeExtensions.AllowIncomingLinks(T) Method
[image]

Sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowIncomingLinks<T> (
T diagramNode,
bool value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function AllowIncomingLinks(Of T As DiagramNode) ( _
diagramNode As T, _
value As Boolean _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.AllowOutgoingLinks(T) Method

DiagramNodeExtensions.AllowOutgoingLinks(T) Method
[image]

Sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowOutgoingLinks<T> (
T diagramNode,
bool value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function AllowOutgoingLinks(Of T As DiagramNode) ( _
diagramNode As T, _
value As Boolean _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.AnchorPattern(T) Method

DiagramNodeExtensions.AnchorPattern(T) Method
[image]

Sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AnchorPattern<T> (
T diagramNode,
AnchorPattern value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function AnchorPattern(Of T As DiagramNode) ( _
diagramNode As T, _
value As AnchorPattern _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Bounds(T) Method

DiagramNodeExtensions.Bounds(T) Method
[image]

Sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Bounds<T> (
T diagramNode,
Rect value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Bounds(Of T As DiagramNode) ( _
diagramNode As T, _
value As Rect _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Constraints(T) Method

DiagramNodeExtensions.Constraints(T) Method
[image]

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Constraints<T> (
T diagramNode,
NodeConstraints value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Constraints(Of T As DiagramNode) ( _
diagramNode As T, _
value As NodeConstraints _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.EnabledHandles(T) Method

DiagramNodeExtensions.EnabledHandles(T) Method
[image]

Sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnabledHandles<T> (
T diagramNode,
AdjustmentHandles value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function EnabledHandles(Of T As DiagramNode) ( _
diagramNode As T, _
value As AdjustmentHandles _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Expandable(T) Method

DiagramNodeExtensions.Expandable(T) Method
[image]

Sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Expandable<T> (
T diagramNode,
bool value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Expandable(Of T As DiagramNode) ( _
diagramNode As T, _
value As Boolean _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Expanded(T) Method

DiagramNodeExtensions.Expanded(T) Method
[image]

Sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Expanded<T> (
T diagramNode,
bool value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Expanded(Of T As DiagramNode) ( _
diagramNode As T, _
value As Boolean _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.GridAlignPoint(T) Method

DiagramNodeExtensions.GridAlignPoint(T) Method
[image]

Sets the node's point that should align to a grid point when the node is moved.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T GridAlignPoint<T> (
T diagramNode,
RelativePosition value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function GridAlignPoint(Of T As DiagramNode) ( _
diagramNode As T, _
value As RelativePosition _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.HandlesStyle Method

DiagramNodeExtensions.HandlesStyle Method
[image]

Sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DiagramNode HandlesStyle (
DiagramNode diagramNode,
HandlesStyle value
)

Visual Basic [image] Copy Code

Public Shared Function HandlesStyle( _
diagramNode As DiagramNode, _
value As HandlesStyle _
) As DiagramNode

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Obstacle(T) Method

DiagramNodeExtensions.Obstacle(T) Method
[image]

Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Obstacle<T> (
T diagramNode,
bool value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Obstacle(Of T As DiagramNode) ( _
diagramNode As T, _
value As Boolean _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.RotationAngle(T) Method

DiagramNodeExtensions.RotationAngle(T) Method
[image]

Sets the rotation angle of this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RotationAngle<T> (
T diagramNode,
double value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function RotationAngle(Of T As DiagramNode) ( _
diagramNode As T, _
value As Double _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions.Template(T) Method

DiagramNodeExtensions.Template(T) Method
[image]

Sets the DataTemplate used to display this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Template<T> (
T diagramNode,
DataTemplate value
) where T : DiagramNode

Visual Basic [image] Copy Code

Public Shared Function Template(Of T As DiagramNode) ( _
diagramNode As T, _
value As DataTemplate _
) As T

Parameters

diagramNode

value

Return Value

See Also

DiagramNodeExtensions Members
DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions.Closed(T) Method

FreeFormNodeExtensions.Closed(T) Method
[image]

Sets if the node's shape is closed.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Closed<T> (
T freeFormNode,
bool value
) where T : FreeFormNode

Visual Basic [image] Copy Code

Public Shared Function Closed(Of T As FreeFormNode) ( _
freeFormNode As T, _
value As Boolean _
) As T

Parameters

freeFormNode

value

Return Value

See Also

FreeFormNodeExtensions Members
FreeFormNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions.Points(T) Method

FreeFormNodeExtensions.Points(T) Method
[image]

Sets the node's outline points.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Points<T> (
T freeFormNode,
StylusPointCollection value
) where T : FreeFormNode

Visual Basic [image] Copy Code

Public Shared Function Points(Of T As FreeFormNode) ( _
freeFormNode As T, _
value As StylusPointCollection _
) As T

Parameters

freeFormNode

value

Return Value

See Also

FreeFormNodeExtensions Members
FreeFormNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.AllowMultipleSelection(T) Method

SelectionExtensions.AllowMultipleSelection(T) Method
[image]

Sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowMultipleSelection<T> (
T selection,
bool value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function AllowMultipleSelection(Of T As Selection) ( _
selection As T, _
value As Boolean _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.ExtendMode(T) Method

SelectionExtensions.ExtendMode(T) Method
[image]

Sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ExtendMode<T> (
T selection,
bool value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function ExtendMode(Of T As Selection) ( _
selection As T, _
value As Boolean _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.FreeFormMode(T) Method

SelectionExtensions.FreeFormMode(T) Method
[image]

Sets a value indicating whether selection lasso should be drawn in free-form mode.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FreeFormMode<T> (
T selection,
bool value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function FreeFormMode(Of T As Selection) ( _
selection As T, _
value As Boolean _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.IncludeItemsIfIntersect(T) Method

SelectionExtensions.IncludeItemsIfIntersect(T) Method
[image]

Sets a value indicating which items are selected when drawing a selection rectangle.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IncludeItemsIfIntersect<T> (
T selection,
bool value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function IncludeItemsIfIntersect(Of T As Selection) ( _
selection As T, _
value As Boolean _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.SetsDirtyFlag(T) Method

SelectionExtensions.SetsDirtyFlag(T) Method
[image]

Sets a value indicating whether the diagram's Dirty flag should be set when selection changes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SetsDirtyFlag<T> (
T selection,
bool value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function SetsDirtyFlag(Of T As Selection) ( _
selection As T, _
value As Boolean _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions.Style(T) Method

SelectionExtensions.Style(T) Method
[image]

Sets a value indicating how to display multiple selection of items.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Style<T> (
T selection,
SelectionStyle value
) where T : Selection

Visual Basic [image] Copy Code

Public Shared Function Style(Of T As Selection) ( _
selection As T, _
value As SelectionStyle _
) As T

Parameters

selection

value

Return Value

See Also

SelectionExtensions Members
SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.AllowFlip(T) Method

ShapeNodeExtensions.AllowFlip(T) Method
[image]

Sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowFlip<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function AllowFlip(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.ClipImage(T) Method

ShapeNodeExtensions.ClipImage(T) Method
[image]

Sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ClipImage<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function ClipImage(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.ClipText(T) Method

ShapeNodeExtensions.ClipText(T) Method
[image]

Sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ClipText<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function ClipText(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.CustomDraw Method

ShapeNodeExtensions.CustomDraw Method
[image]

Sets the type of custom drawing performed on this shape node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ShapeNode CustomDraw (
ShapeNode shapeNode,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function CustomDraw( _
shapeNode As ShapeNode, _
value As CustomDraw _
) As ShapeNode

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.EnableStyledText Method

ShapeNodeExtensions.EnableStyledText Method
[image]

Sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ShapeNode EnableStyledText (
ShapeNode shapeNode,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function EnableStyledText( _
shapeNode As ShapeNode, _
value As Boolean _
) As ShapeNode

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.FlipX(T) Method

ShapeNodeExtensions.FlipX(T) Method
[image]

Sets a value indicating whether the node's shape is flipped horizontally.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FlipX<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function FlipX(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.FlipY(T) Method

ShapeNodeExtensions.FlipY(T) Method
[image]

Sets a value indicating whether the node's shape is flipped vertically.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T FlipY<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function FlipY(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.Image Method

ShapeNodeExtensions.Image Method
[image]

Sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ShapeNode Image (
ShapeNode shapeNode,
ImageSource value
)

Visual Basic [image] Copy Code

Public Shared Function Image( _
shapeNode As ShapeNode, _
value As ImageSource _
) As ShapeNode

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.ImageAlign Method

ShapeNodeExtensions.ImageAlign Method
[image]

Sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static ShapeNode ImageAlign (
ShapeNode shapeNode,
ImageAlign value
)

Visual Basic [image] Copy Code

Public Shared Function ImageAlign( _
shapeNode As ShapeNode, _
value As ImageAlign _
) As ShapeNode

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.PolygonalTextLayout(T) Method

ShapeNodeExtensions.PolygonalTextLayout(T) Method
[image]

Sets a flag indicating whether node's text is formatted in non-rectangular outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T PolygonalTextLayout<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function PolygonalTextLayout(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.RotateImage(T) Method

ShapeNodeExtensions.RotateImage(T) Method
[image]

Sets a value indicating whether the Image should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RotateImage<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function RotateImage(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.RotateText(T) Method

ShapeNodeExtensions.RotateText(T) Method
[image]

Sets a value indicating whether the Text should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RotateText<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function RotateText(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.Shape(T) Method

ShapeNodeExtensions.Shape(T) Method
[image]

Sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Shape<T> (
T shapeNode,
Shape value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function Shape(Of T As ShapeNode) ( _
shapeNode As T, _
value As Shape _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.ShapeOrientation(T) Method

ShapeNodeExtensions.ShapeOrientation(T) Method
[image]

Sets the angle specifying the orientation with which a shape template is applied to the node bounds.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ShapeOrientation<T> (
T shapeNode,
double value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function ShapeOrientation(Of T As ShapeNode) ( _
shapeNode As T, _
value As Double _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.TextFormat(T) Method

ShapeNodeExtensions.TextFormat(T) Method
[image]

Sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextFormat<T> (
T shapeNode,
StringFormat value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function TextFormat(Of T As ShapeNode) ( _
shapeNode As T, _
value As StringFormat _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.TextRotationAngle(T) Method

ShapeNodeExtensions.TextRotationAngle(T) Method
[image]

Sets the text rotation angle of this node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TextRotationAngle<T> (
T shapeNode,
double value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function TextRotationAngle(Of T As ShapeNode) ( _
shapeNode As T, _
value As Double _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions.Transparent(T) Method

ShapeNodeExtensions.Transparent(T) Method
[image]

Sets a value indicating whether this shape node is transparent.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Transparent<T> (
T shapeNode,
bool value
) where T : ShapeNode

Visual Basic [image] Copy Code

Public Shared Function Transparent(Of T As ShapeNode) ( _
shapeNode As T, _
value As Boolean _
) As T

Parameters

shapeNode

value

Return Value

See Also

ShapeNodeExtensions Members
ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.AllowResizeColumns(T) Method

TableNodeExtensions.AllowResizeColumns(T) Method
[image]

Sets a value indicating whether users are allowed to resize table columns.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowResizeColumns<T> (
T tableNode,
bool value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function AllowResizeColumns(Of T As TableNode) ( _
tableNode As T, _
value As Boolean _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.AllowResizeRows(T) Method

TableNodeExtensions.AllowResizeRows(T) Method
[image]

Sets a value indicating whether users are allowed to resize table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AllowResizeRows<T> (
T tableNode,
bool value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function AllowResizeRows(Of T As TableNode) ( _
tableNode As T, _
value As Boolean _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.Caption(T) Method

TableNodeExtensions.Caption(T) Method
[image]

Sets the text displayed as caption of the table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Caption<T> (
T tableNode,
string value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function Caption(Of T As TableNode) ( _
tableNode As T, _
value As String _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBackBrush(T) Method (T, Brush)

TableNodeExtensions.CaptionBackBrush(T) Method (T, Brush)
See Also
[image]

Sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBackBrush<T> (
T tableNode,
Brush value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush(Of T As TableNode) ( _
tableNode As T, _
value As Brush _
) As T

Parameters

tableNode

value

Return Value

See Also

CaptionBackBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBackBrush(T) Method (T, Color)

TableNodeExtensions.CaptionBackBrush(T) Method (T, Color)
See Also
[image]

Sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBackBrush<T> (
T tableNode,
Color color
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush(Of T As TableNode) ( _
tableNode As T, _
color As Color _
) As T

Parameters

tableNode

color

Return Value

See Also

CaptionBackBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBackBrush(T) Method (T, Color, Color, Single)

TableNodeExtensions.CaptionBackBrush(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBackBrush<T> (
T tableNode,
Color color1,
Color color2,
float angle
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBackBrush(Of T As TableNode) ( _
tableNode As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

tableNode

color1

color2

angle

Return Value

See Also

CaptionBackBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBrush(T) Method (T, Brush)

TableNodeExtensions.CaptionBrush(T) Method (T, Brush)
See Also
[image]

Sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBrush<T> (
T tableNode,
Brush value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush(Of T As TableNode) ( _
tableNode As T, _
value As Brush _
) As T

Parameters

tableNode

value

Return Value

See Also

CaptionBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBrush(T) Method (T, Color)

TableNodeExtensions.CaptionBrush(T) Method (T, Color)
See Also
[image]

Sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBrush<T> (
T tableNode,
Color color
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush(Of T As TableNode) ( _
tableNode As T, _
color As Color _
) As T

Parameters

tableNode

color

Return Value

See Also

CaptionBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBrush(T) Method (T, Color, Color, Single)

TableNodeExtensions.CaptionBrush(T) Method (T, Color, Color, Single)
See Also
[image]

Sets the color of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionBrush<T> (
T tableNode,
Color color1,
Color color2,
float angle
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush(Of T As TableNode) ( _
tableNode As T, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As T

Parameters

tableNode

color1

color2

angle

Return Value

See Also

CaptionBrush Method Overload List
TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionFormat(T) Method

TableNodeExtensions.CaptionFormat(T) Method
[image]

Sets the alignment and line position of the text used as table caption.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionFormat<T> (
T tableNode,
StringFormat value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionFormat(Of T As TableNode) ( _
tableNode As T, _
value As StringFormat _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionHeight(T) Method

TableNodeExtensions.CaptionHeight(T) Method
[image]

Sets the height of the table's caption area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionHeight<T> (
T tableNode,
double value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CaptionHeight(Of T As TableNode) ( _
tableNode As T, _
value As Double _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CellCustomDraw(T) Method

TableNodeExtensions.CellCustomDraw(T) Method
[image]

Sets the type of custom drawing performed on the table cells.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CellCustomDraw<T> (
T tableNode,
CustomDraw value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CellCustomDraw(Of T As TableNode) ( _
tableNode As T, _
value As CustomDraw _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CellFrameStyle(T) Method

TableNodeExtensions.CellFrameStyle(T) Method
[image]

Sets the style of the table cells.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CellFrameStyle<T> (
T tableNode,
CellFrameStyle value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CellFrameStyle(Of T As TableNode) ( _
tableNode As T, _
value As CellFrameStyle _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.ColumnCount(T) Method

TableNodeExtensions.ColumnCount(T) Method
[image]

Sets the number of columns in the table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ColumnCount<T> (
T tableNode,
int value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function ColumnCount(Of T As TableNode) ( _
tableNode As T, _
value As Integer _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.ColumnWidth(T) Method

TableNodeExtensions.ColumnWidth(T) Method
[image]

Sets the default width of the table columns.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ColumnWidth<T> (
T tableNode,
double value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function ColumnWidth(Of T As TableNode) ( _
tableNode As T, _
value As Double _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.ConnectionStyle(T) Method

TableNodeExtensions.ConnectionStyle(T) Method
[image]

Sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ConnectionStyle<T> (
T tableNode,
TableConnectionStyle value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function ConnectionStyle(Of T As TableNode) ( _
tableNode As T, _
value As TableConnectionStyle _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CurrentScrollRow(T) Method

TableNodeExtensions.CurrentScrollRow(T) Method
[image]

Sets the index of the first visible row in the table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CurrentScrollRow<T> (
T tableNode,
int value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function CurrentScrollRow(Of T As TableNode) ( _
tableNode As T, _
value As Integer _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CustomDraw Method

TableNodeExtensions.CustomDraw Method
[image]

Sets the type of custom drawing performed on this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TableNode CustomDraw (
TableNode tableNode,
CustomDraw value
)

Visual Basic [image] Copy Code

Public Shared Function CustomDraw( _
tableNode As TableNode, _
value As CustomDraw _
) As TableNode

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.EnableStyledText(T) Method

TableNodeExtensions.EnableStyledText(T) Method
[image]

Sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnableStyledText<T> (
T tableNode,
bool value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function EnableStyledText(Of T As TableNode) ( _
tableNode As T, _
value As Boolean _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.HighlightedRow(T) Method

TableNodeExtensions.HighlightedRow(T) Method
[image]

Sets the highlighted row.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HighlightedRow<T> (
T tableNode,
int value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function HighlightedRow(Of T As TableNode) ( _
tableNode As T, _
value As Integer _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.Image(T) Method

TableNodeExtensions.Image(T) Method
[image]

Sets the image that is displayed in this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Image<T> (
T tableNode,
ImageSource value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function Image(Of T As TableNode) ( _
tableNode As T, _
value As ImageSource _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.ImageAlign(T) Method

TableNodeExtensions.ImageAlign(T) Method
[image]

Sets the alignment of the image displayed in this table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ImageAlign<T> (
T tableNode,
ImageAlign value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function ImageAlign(Of T As TableNode) ( _
tableNode As T, _
value As ImageAlign _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.OffsetHeaderRows(T) Method

TableNodeExtensions.OffsetHeaderRows(T) Method
[image]

Sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T OffsetHeaderRows<T> (
T tableNode,
bool value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function OffsetHeaderRows(Of T As TableNode) ( _
tableNode As T, _
value As Boolean _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.RowAnchorPattern(T) Method

TableNodeExtensions.RowAnchorPattern(T) Method
[image]

Sets the default anchor pattern for the rows of a table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RowAnchorPattern<T> (
T tableNode,
AnchorPattern value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function RowAnchorPattern(Of T As TableNode) ( _
tableNode As T, _
value As AnchorPattern _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.RowCount(T) Method

TableNodeExtensions.RowCount(T) Method
[image]

Sets the number of rows in the table.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RowCount<T> (
T tableNode,
int value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function RowCount(Of T As TableNode) ( _
tableNode As T, _
value As Integer _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.RowHeight(T) Method

TableNodeExtensions.RowHeight(T) Method
[image]

Sets the default height of table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RowHeight<T> (
T tableNode,
double value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function RowHeight(Of T As TableNode) ( _
tableNode As T, _
value As Double _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.Scrollable(T) Method

TableNodeExtensions.Scrollable(T) Method
[image]

Sets a value indicating whether users are allowed to scroll table rows.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Scrollable<T> (
T tableNode,
bool value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function Scrollable(Of T As TableNode) ( _
tableNode As T, _
value As Boolean _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.Shape(T) Method

TableNodeExtensions.Shape(T) Method
[image]

Sets the shape of the table's outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Shape<T> (
T tableNode,
SimpleShape value
) where T : TableNode

Visual Basic [image] Copy Code

Public Shared Function Shape(Of T As TableNode) ( _
tableNode As T, _
value As SimpleShape _
) As T

Parameters

tableNode

value

Return Value

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.Caption Method

TreeViewNodeExtensions.Caption Method
[image]

Sets the text displayed as caption of the node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode Caption (
TreeViewNode treeViewNode,
string value
)

Visual Basic [image] Copy Code

Public Shared Function Caption( _
treeViewNode As TreeViewNode, _
value As String _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Brush)

TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Brush)
See Also
[image]

Sets the brush used to draw the caption text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode CaptionBrush (
TreeViewNode treeViewNode,
Brush value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
treeViewNode As TreeViewNode, _
value As Brush _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

CaptionBrush Method Overload List
TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Color)

TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Color)
See Also
[image]

Sets the brush used to draw the caption text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode CaptionBrush (
TreeViewNode treeViewNode,
Color color
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
treeViewNode As TreeViewNode, _
color As Color _
) As TreeViewNode

Parameters

treeViewNode

color

Return Value

See Also

CaptionBrush Method Overload List
TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Color, Color, Single)

TreeViewNodeExtensions.CaptionBrush Method (TreeViewNode, Color, Color, Single)
See Also
[image]

Sets the brush used to draw the caption text.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode CaptionBrush (
TreeViewNode treeViewNode,
Color color1,
Color color2,
float angle
)

Visual Basic [image] Copy Code

Public Shared Function CaptionBrush( _
treeViewNode As TreeViewNode, _
color1 As Color, _
color2 As Color, _
angle As Single _
) As TreeViewNode

Parameters

treeViewNode

color1

color2

angle

Return Value

See Also

CaptionBrush Method Overload List
TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionHeight Method

TreeViewNodeExtensions.CaptionHeight Method
[image]

Sets the height of the table's caption area.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode CaptionHeight (
TreeViewNode treeViewNode,
double value
)

Visual Basic [image] Copy Code

Public Shared Function CaptionHeight( _
treeViewNode As TreeViewNode, _
value As Double _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionImage(T) Method

TreeViewNodeExtensions.CaptionImage(T) Method
[image]

Sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CaptionImage<T> (
T treeViewNode,
ImageSource value
) where T : TreeViewNode

Visual Basic [image] Copy Code

Public Shared Function CaptionImage(Of T As TreeViewNode) ( _
treeViewNode As T, _
value As ImageSource _
) As T

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.ConnectionStyle(T) Method

TreeViewNodeExtensions.ConnectionStyle(T) Method
[image]

Sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ConnectionStyle<T> (
T treeViewNode,
TreeViewConnectionStyle value
) where T : TreeViewNode

Visual Basic [image] Copy Code

Public Shared Function ConnectionStyle(Of T As TreeViewNode) ( _
treeViewNode As T, _
value As TreeViewConnectionStyle _
) As T

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.EnableStyledText Method

TreeViewNodeExtensions.EnableStyledText Method
[image]

Sets a value indicating whether styled text rendering is enabled.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode EnableStyledText (
TreeViewNode treeViewNode,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function EnableStyledText( _
treeViewNode As TreeViewNode, _
value As Boolean _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.ScrollPosition(T) Method

TreeViewNodeExtensions.ScrollPosition(T) Method
[image]

Sets the current scroll position.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ScrollPosition<T> (
T treeViewNode,
double value
) where T : TreeViewNode

Visual Basic [image] Copy Code

Public Shared Function ScrollPosition(Of T As TreeViewNode) ( _
treeViewNode As T, _
value As Double _
) As T

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.Shape Method

TreeViewNodeExtensions.Shape Method
[image]

Sets the shape of the node's outline.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode Shape (
TreeViewNode treeViewNode,
SimpleShape value
)

Visual Basic [image] Copy Code

Public Shared Function Shape( _
treeViewNode As TreeViewNode, _
value As SimpleShape _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.TextFormat Method

TreeViewNodeExtensions.TextFormat Method
[image]

Sets the alignment of texts displayed inside this shape node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeViewNode TextFormat (
TreeViewNode treeViewNode,
StringFormat value
)

Visual Basic [image] Copy Code

Public Shared Function TextFormat( _
treeViewNode As TreeViewNode, _
value As StringFormat _
) As TreeViewNode

Parameters

treeViewNode

value

Return Value

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.VisioNodeExtensions.Content(T) Method

VisioNodeExtensions.Content(T) Method
[image]

Sets the content of the node.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Content<T> (
T visioNode,
VisioContent value
) where T : VisioNode

Visual Basic [image] Copy Code

Public Shared Function Content(Of T As VisioNode) ( _
visioNode As T, _
value As VisioContent _
) As T

Parameters

visioNode

value

Return Value

See Also

VisioNodeExtensions Members
VisioNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter.Import Method (String)

DrawImporter.Import Method (String)
See Also
[image]

Imports the specified OpenOffice Draw document into a new DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string filePath
)

Visual Basic [image] Copy Code

Public Function Import( _
filePath As String _
) As DiagramDocument

Parameters

filePath

A string specifying the path to the .odg file.

Return Value

A DiagramDocument containing the imported OpenOffice drawing.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter.Import Method (String, Diagram)

DrawImporter.Import Method (String, Diagram)
See Also
[image]

Imports the specified OpenOffice Draw document into the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
diagram As Diagram _
)

Parameters

filePath

A string specifying the path to the .odg file.

diagram

A Diagram into which to import the OpenOffice drawing.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter.Import Method (String, DiagramDocument)

DrawImporter.Import Method (String, DiagramDocument)
See Also
[image]

Imports the specified OpenOffice Draw document into an existing DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public void Import (
string filePath,
DiagramDocument document
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
document As DiagramDocument _
)

Parameters

filePath

A string specifying the path to the .odg file.

document

A DiagramDocument into which to import the OpenOffice drawing.

See Also

Import Method Overload List
DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.Import Method (String)

Visio2013Importer.Import Method (String)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into a new DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string filePath
)

Visual Basic [image] Copy Code

Public Function Import( _
filePath As String _
) As DiagramDocument

Parameters

filePath

A string specifying the path to the .vsdx file.

Return Value

A DiagramDocument containing the imported Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.Import Method (String, Diagram)

Visio2013Importer.Import Method (String, Diagram)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into the specified Diagram.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public void Import (
string filePath,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
diagram As Diagram _
)

Parameters

filePath

A string specifying the path to the .vsdx file.

diagram

A Diagram into which to import the Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.Import Method (String, DiagramDocument)

Visio2013Importer.Import Method (String, DiagramDocument)
See Also
[image]

Imports the specified Visio Graphics Service VSDX file into an existing DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public void Import (
string filePath,
DiagramDocument document
)

Visual Basic [image] Copy Code

Public Sub Import( _
filePath As String, _
document As DiagramDocument _
)

Parameters

filePath

A string specifying the path to the .vsdx file.

document

A DiagramDocument into which to import the Visio drawing.

See Also

Import Method Overload List
Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.OnImportItem Method

Visio2013Importer.OnImportItem Method
[image]

Raises the ImportItem event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

protected virtual void OnImportItem (
Object sender,
ImportItemEventArgs args
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnImportItem( _
sender As Object, _
args As ImportItemEventArgs _
)

Parameters

sender

args

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.GetPageCount Method

VisioImporter.GetPageCount Method
[image]

Determines how many pages are there in a Visio diagram.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public long GetPageCount (
string vdxPathName
)

Visual Basic [image] Copy Code

Public Function GetPageCount( _
vdxPathName As String _
) As Long

Parameters

vdxPathName

A full path to the Visio VDX file.

Return Value

An integer value specifying the number of pages in the Visio diagram.

Remarks

Use this method to determine the valid range of pages for ImportPage.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.Import Method

VisioImporter.Import Method
[image]

Imports all pages from the specified Visio document into a single DiagramDocument object.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public DiagramDocument Import (
string vdxPathName
)

Visual Basic [image] Copy Code

Public Function Import( _
vdxPathName As String _
) As DiagramDocument

Parameters

vdxPathName

A full path to the Visio VDX file.

Return Value

The newly crated DiagramDocument object.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace
ImportPage Method
ImportAllPages Method


MindFusion.Diagramming.Wpf.Import.VisioImporter.ImportAllPages Method

VisioImporter.ImportAllPages Method
[image]

Imports all pages from the specified Visio document.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public void ImportAllPages (
string vdxPathName,
Diagram diagram
)

Visual Basic [image] Copy Code

Public Sub ImportAllPages( _
vdxPathName As String, _
diagram As Diagram _
)

Parameters

vdxPathName

A full path to the Visio VDX file.

diagram

Reference to the diagram where the Visio drawing is imported.

Remarks

The pages are imported starting from the top-left point of the diagram area. The current import location is moved one page-width to the right with each new page imported, until PagesPerRow pages are imported on the same y-coordinate. When that happens, the current location moves to the leftmost x-coordinate and one page-height down. If there are more pages to import, the process continues as above.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace
Import Method
ImportPage Method


MindFusion.Diagramming.Wpf.Import.VisioImporter.ImportPage Method

VisioImporter.ImportPage Method
[image]

Imports a single page from the specified Visio document.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public void ImportPage (
string vdxPathName,
Diagram diagram,
int pageIndex
)

Visual Basic [image] Copy Code

Public Sub ImportPage( _
vdxPathName As String, _
diagram As Diagram, _
pageIndex As Integer _
)

Parameters

vdxPathName

A full path to the Visio VDX file.

diagram

Reference to the Diagram where the Visio page is imported.

pageIndex

Specifies which page of the Visio document to import.

Remarks

The page index is zero based. Use GetPageCount to determine how many pages are there in the Visio diagram.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace
Import Method
ImportAllPages Method


MindFusion.Diagramming.Wpf.Import.VisioImporter.OnConnectorImported Method

VisioImporter.OnConnectorImported Method
[image]

Raises the ConnectorImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

protected virtual void OnConnectorImported (
ConnectorImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnConnectorImported( _
e As ConnectorImportedEventArgs _
)

Parameters

e

A ConnectorImportedEventArgs instance that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.OnGroupImported Method

VisioImporter.OnGroupImported Method
[image]

Raises the GroupImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

protected virtual void OnGroupImported (
GroupImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnGroupImported( _
e As GroupImportedEventArgs _
)

Parameters

e
A GroupImportedEventArgs instance that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.OnShapeImported Method

VisioImporter.OnShapeImported Method
[image]

Raises the ShapeImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

protected virtual void OnShapeImported (
ShapeImportedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnShapeImported( _
e As ShapeImportedEventArgs _
)

Parameters

e

A ShapeImportedEventArgs instance that contains the event data.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.ApproximateLinkLength(T) Method

AnnealLayoutExtensions.ApproximateLinkLength(T) Method
[image]

Sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ApproximateLinkLength<T> (
T annealLayout,
bool value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function ApproximateLinkLength(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Boolean _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.BoundaryFactor(T) Method

AnnealLayoutExtensions.BoundaryFactor(T) Method
[image]

Sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BoundaryFactor<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function BoundaryFactor(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.CrossingLinksCost(T) Method

AnnealLayoutExtensions.CrossingLinksCost(T) Method
[image]

Sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CrossingLinksCost<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function CrossingLinksCost(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.DistributionFactor(T) Method

AnnealLayoutExtensions.DistributionFactor(T) Method
[image]

Sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T DistributionFactor<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function DistributionFactor(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.GatherStatistics(T) Method

AnnealLayoutExtensions.GatherStatistics(T) Method
[image]

Specifies whether the layout should gather statistics while running.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T GatherStatistics<T> (
T annealLayout,
bool value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function GatherStatistics(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Boolean _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.InitialTemperature(T) Method

AnnealLayoutExtensions.InitialTemperature(T) Method
[image]

Sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T InitialTemperature<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function InitialTemperature(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.IterationsPerStage(T) Method

AnnealLayoutExtensions.IterationsPerStage(T) Method
[image]

Sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IterationsPerStage<T> (
T annealLayout,
int value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function IterationsPerStage(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Integer _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.LayoutArea(T) Method

AnnealLayoutExtensions.LayoutArea(T) Method
[image]

Sets the size of the layout area.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LayoutArea<T> (
T annealLayout,
Rect value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function LayoutArea(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Rect _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.LinkLengthFactor(T) Method

AnnealLayoutExtensions.LinkLengthFactor(T) Method
[image]

Sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkLengthFactor<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function LinkLengthFactor(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.NodeLinkCrossingCost(T) Method

AnnealLayoutExtensions.NodeLinkCrossingCost(T) Method
[image]

Sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T NodeLinkCrossingCost<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function NodeLinkCrossingCost(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.NodeLinkDistFactor(T) Method

AnnealLayoutExtensions.NodeLinkDistFactor(T) Method
[image]

Sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T NodeLinkDistFactor<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function NodeLinkDistFactor(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.Randomize(T) Method

AnnealLayoutExtensions.Randomize(T) Method
[image]

Sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Randomize<T> (
T annealLayout,
bool value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function Randomize(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Boolean _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.Root(T) Method

AnnealLayoutExtensions.Root(T) Method
[image]

Sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Root<T> (
T annealLayout,
Object value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function Root(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Object _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.SplitGraph(T) Method

AnnealLayoutExtensions.SplitGraph(T) Method
[image]

Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SplitGraph<T> (
T annealLayout,
bool value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function SplitGraph(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Boolean _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.Stages(T) Method

AnnealLayoutExtensions.Stages(T) Method
[image]

Sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Stages<T> (
T annealLayout,
int value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function Stages(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Integer _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.TemperatureScale(T) Method

AnnealLayoutExtensions.TemperatureScale(T) Method
[image]

Sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TemperatureScale<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function TemperatureScale(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions.WidthHeightRatio(T) Method

AnnealLayoutExtensions.WidthHeightRatio(T) Method
[image]

Sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T WidthHeightRatio<T> (
T annealLayout,
double value
) where T : AnnealLayout

Visual Basic [image] Copy Code

Public Shared Function WidthHeightRatio(Of T As AnnealLayout) ( _
annealLayout As T, _
value As Double _
) As T

Parameters

annealLayout

value

Return Value

See Also

AnnealLayoutExtensions Members
AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions.Orientation(T) Method

CascadeLayoutExtensions.Orientation(T) Method
[image]

Sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Orientation<T> (
T cascadeLayout,
Orientation value
) where T : CascadeLayout

Visual Basic [image] Copy Code

Public Shared Function Orientation(Of T As CascadeLayout) ( _
cascadeLayout As T, _
value As Orientation _
) As T

Parameters

cascadeLayout

value

Return Value

See Also

CascadeLayoutExtensions Members
CascadeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions.Padding(T) Method

CascadeLayoutExtensions.Padding(T) Method
[image]

Sets the spacing between nodes in adjacent layers.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Padding<T> (
T cascadeLayout,
double value
) where T : CascadeLayout

Visual Basic [image] Copy Code

Public Shared Function Padding(Of T As CascadeLayout) ( _
cascadeLayout As T, _
value As Double _
) As T

Parameters

cascadeLayout

value

Return Value

See Also

CascadeLayoutExtensions Members
CascadeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions.AutoRadiusFactor(T) Method

CircularLayoutExtensions.AutoRadiusFactor(T) Method
[image]

Sets a multiplier for the automatically calculated radius when Radius is set to 0.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T AutoRadiusFactor<T> (
T circularLayout,
double value
) where T : CircularLayout

Visual Basic [image] Copy Code

Public Shared Function AutoRadiusFactor(Of T As CircularLayout) ( _
circularLayout As T, _
value As Double _
) As T

Parameters

circularLayout

value

Return Value

See Also

CircularLayoutExtensions Members
CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions.Radius(T) Method

CircularLayoutExtensions.Radius(T) Method
[image]

Sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Radius<T> (
T circularLayout,
double value
) where T : CircularLayout

Visual Basic [image] Copy Code

Public Shared Function Radius(Of T As CircularLayout) ( _
circularLayout As T, _
value As Double _
) As T

Parameters

circularLayout

value

Return Value

See Also

CircularLayoutExtensions Members
CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions.SiftingRounds(T) Method

CircularLayoutExtensions.SiftingRounds(T) Method
[image]

Sets the number of sifts to perform during the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SiftingRounds<T> (
T circularLayout,
int value
) where T : CircularLayout

Visual Basic [image] Copy Code

Public Shared Function SiftingRounds(Of T As CircularLayout) ( _
circularLayout As T, _
value As Integer _
) As T

Parameters

circularLayout

value

Return Value

See Also

CircularLayoutExtensions Members
CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions.SplitGraph Method

CircularLayoutExtensions.SplitGraph Method
[image]

Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static CircularLayout SplitGraph (
CircularLayout circularLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SplitGraph( _
circularLayout As CircularLayout, _
value As Boolean _
) As CircularLayout

Parameters

circularLayout

value

Return Value

See Also

CircularLayoutExtensions Members
CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions.HorizontalPadding(T) Method

DecisionLayoutExtensions.HorizontalPadding(T) Method
[image]

Sets the horizontal distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T HorizontalPadding<T> (
T decisionLayout,
double value
) where T : DecisionLayout

Visual Basic [image] Copy Code

Public Shared Function HorizontalPadding(Of T As DecisionLayout) ( _
decisionLayout As T, _
value As Double _
) As T

Parameters

decisionLayout

value

Return Value

See Also

DecisionLayoutExtensions Members
DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions.LinkPadding(T) Method

DecisionLayoutExtensions.LinkPadding(T) Method
[image]

Sets the distance between parallel links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkPadding<T> (
T decisionLayout,
double value
) where T : DecisionLayout

Visual Basic [image] Copy Code

Public Shared Function LinkPadding(Of T As DecisionLayout) ( _
decisionLayout As T, _
value As Double _
) As T

Parameters

decisionLayout

value

Return Value

See Also

DecisionLayoutExtensions Members
DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions.Orientation Method

DecisionLayoutExtensions.Orientation Method
[image]

Sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static DecisionLayout Orientation (
DecisionLayout decisionLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
decisionLayout As DecisionLayout, _
value As Orientation _
) As DecisionLayout

Parameters

decisionLayout

value

Return Value

See Also

DecisionLayoutExtensions Members
DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions.StartNode(T) Method

DecisionLayoutExtensions.StartNode(T) Method
[image]

Sets the initial (top-left) node in the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StartNode<T> (
T decisionLayout,
DiagramNode value
) where T : DecisionLayout

Visual Basic [image] Copy Code

Public Shared Function StartNode(Of T As DecisionLayout) ( _
decisionLayout As T, _
value As DiagramNode _
) As T

Parameters

decisionLayout

value

Return Value

See Also

DecisionLayoutExtensions Members
DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions.VerticalPadding(T) Method

DecisionLayoutExtensions.VerticalPadding(T) Method
[image]

Sets the vertical distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T VerticalPadding<T> (
T decisionLayout,
double value
) where T : DecisionLayout

Visual Basic [image] Copy Code

Public Shared Function VerticalPadding(Of T As DecisionLayout) ( _
decisionLayout As T, _
value As Double _
) As T

Parameters

decisionLayout

value

Return Value

See Also

DecisionLayoutExtensions Members
DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.BranchPadding(T) Method

FlowchartLayoutExtensions.BranchPadding(T) Method
[image]

Sets how much space to leave between adjacent decision branches in the flowchart.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BranchPadding<T> (
T flowchartLayout,
double value
) where T : FlowchartLayout

Visual Basic [image] Copy Code

Public Shared Function BranchPadding(Of T As FlowchartLayout) ( _
flowchartLayout As T, _
value As Double _
) As T

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.IgnoreRepeatingLinks(T) Method

FlowchartLayoutExtensions.IgnoreRepeatingLinks(T) Method
[image]

Sets a value indicating whether to ignore repeating links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IgnoreRepeatingLinks<T> (
T flowchartLayout,
bool value
) where T : FlowchartLayout

Visual Basic [image] Copy Code

Public Shared Function IgnoreRepeatingLinks(Of T As FlowchartLayout) ( _
flowchartLayout As T, _
value As Boolean _
) As T

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.LinkPadding Method

FlowchartLayoutExtensions.LinkPadding Method
[image]

Sets how much space to leave between adjacent back links designating nested loops.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static FlowchartLayout LinkPadding (
FlowchartLayout flowchartLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkPadding( _
flowchartLayout As FlowchartLayout, _
value As Double _
) As FlowchartLayout

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.NodeDistance(T) Method

FlowchartLayoutExtensions.NodeDistance(T) Method
[image]

Sets the distance between consecutive nodes in the flowchart.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T NodeDistance<T> (
T flowchartLayout,
double value
) where T : FlowchartLayout

Visual Basic [image] Copy Code

Public Shared Function NodeDistance(Of T As FlowchartLayout) ( _
flowchartLayout As T, _
value As Double _
) As T

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.Orientation Method

FlowchartLayoutExtensions.Orientation Method
[image]

Sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static FlowchartLayout Orientation (
FlowchartLayout flowchartLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
flowchartLayout As FlowchartLayout, _
value As Orientation _
) As FlowchartLayout

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions.SplitGraph Method

FlowchartLayoutExtensions.SplitGraph Method
[image]

Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static FlowchartLayout SplitGraph (
FlowchartLayout flowchartLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SplitGraph( _
flowchartLayout As FlowchartLayout, _
value As Boolean _
) As FlowchartLayout

Parameters

flowchartLayout

value

Return Value

See Also

FlowchartLayoutExtensions Members
FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FractalLayoutExtensions.Root Method

FractalLayoutExtensions.Root Method
[image]

Sets the tree root.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static FractalLayout Root (
FractalLayout fractalLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Root( _
fractalLayout As FractalLayout, _
value As Object _
) As FractalLayout

Parameters

fractalLayout

value

Return Value

See Also

FractalLayoutExtensions Members
FractalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.EndNode(T) Method

GridLayoutExtensions.EndNode(T) Method
[image]

Sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EndNode<T> (
T gridLayout,
Object value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function EndNode(Of T As GridLayout) ( _
gridLayout As T, _
value As Object _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.GridSize(T) Method

GridLayoutExtensions.GridSize(T) Method
[image]

Sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T GridSize<T> (
T gridLayout,
double value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function GridSize(Of T As GridLayout) ( _
gridLayout As T, _
value As Double _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.Iterations(T) Method

GridLayoutExtensions.Iterations(T) Method
[image]

Sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Iterations<T> (
T gridLayout,
int value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function Iterations(Of T As GridLayout) ( _
gridLayout As T, _
value As Integer _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.RandomSeed(T) Method

GridLayoutExtensions.RandomSeed(T) Method
[image]

Sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RandomSeed<T> (
T gridLayout,
int value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function RandomSeed(Of T As GridLayout) ( _
gridLayout As T, _
value As Integer _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.Root Method

GridLayoutExtensions.Root Method
[image]

Sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static GridLayout Root (
GridLayout gridLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Root( _
gridLayout As GridLayout, _
value As Object _
) As GridLayout

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.SplitGraph Method

GridLayoutExtensions.SplitGraph Method
[image]

Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static GridLayout SplitGraph (
GridLayout gridLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SplitGraph( _
gridLayout As GridLayout, _
value As Boolean _
) As GridLayout

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.StartNode(T) Method

GridLayoutExtensions.StartNode(T) Method
[image]

Sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StartNode<T> (
T gridLayout,
Object value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function StartNode(Of T As GridLayout) ( _
gridLayout As T, _
value As Object _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.TimeLimit(T) Method

GridLayoutExtensions.TimeLimit(T) Method
[image]

Sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T TimeLimit<T> (
T gridLayout,
long value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function TimeLimit(Of T As GridLayout) ( _
gridLayout As T, _
value As Long _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions.UseLongestPath(T) Method

GridLayoutExtensions.UseLongestPath(T) Method
[image]

Sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T UseLongestPath<T> (
T gridLayout,
bool value
) where T : GridLayout

Visual Basic [image] Copy Code

Public Shared Function UseLongestPath(Of T As GridLayout) ( _
gridLayout As T, _
value As Boolean _
) As T

Parameters

gridLayout

value

Return Value

See Also

GridLayoutExtensions Members
GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions.LevelDistance(T) Method

HierarchicalLayoutExtensions.LevelDistance(T) Method
[image]

Sets the distance between adjacent levels in the hierarchical layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LevelDistance<T> (
T hierarchicalLayout,
double value
) where T : HierarchicalLayout

Visual Basic [image] Copy Code

Public Shared Function LevelDistance(Of T As HierarchicalLayout) ( _
hierarchicalLayout As T, _
value As Double _
) As T

Parameters

hierarchicalLayout

value

Return Value

See Also

HierarchicalLayoutExtensions Members
HierarchicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions.LinkBendFactor(T) Method

HierarchicalLayoutExtensions.LinkBendFactor(T) Method
[image]

Sets the bending factor of links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkBendFactor<T> (
T hierarchicalLayout,
double value
) where T : HierarchicalLayout

Visual Basic [image] Copy Code

Public Shared Function LinkBendFactor(Of T As HierarchicalLayout) ( _
hierarchicalLayout As T, _
value As Double _
) As T

Parameters

hierarchicalLayout

value

Return Value

See Also

HierarchicalLayoutExtensions Members
HierarchicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions.Orientation Method

HierarchicalLayoutExtensions.Orientation Method
[image]

Sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static HierarchicalLayout Orientation (
HierarchicalLayout hierarchicalLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
hierarchicalLayout As HierarchicalLayout, _
value As Orientation _
) As HierarchicalLayout

Parameters

hierarchicalLayout

value

Return Value

See Also

HierarchicalLayoutExtensions Members
HierarchicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.Direction(T) Method

LayeredLayoutExtensions.Direction(T) Method
[image]

Sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Direction<T> (
T layeredLayout,
Direction value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function Direction(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Direction _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.EnableCustomLayers(T) Method

LayeredLayoutExtensions.EnableCustomLayers(T) Method
[image]

Sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnableCustomLayers<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function EnableCustomLayers(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.EndNode Method

LayeredLayoutExtensions.EndNode Method
[image]

Sets the node that should be placed in the last layer of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout EndNode (
LayeredLayout layeredLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function EndNode( _
layeredLayout As LayeredLayout, _
value As Object _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.EnforceLinkFlow(T) Method

LayeredLayoutExtensions.EnforceLinkFlow(T) Method
[image]

Sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnforceLinkFlow<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function EnforceLinkFlow(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.IgnoreNodeSize(T) Method

LayeredLayoutExtensions.IgnoreNodeSize(T) Method
[image]

Sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IgnoreNodeSize<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function IgnoreNodeSize(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.KeepRootPosition(T) Method

LayeredLayoutExtensions.KeepRootPosition(T) Method
[image]

Sets a value indicating whether to preserve the position of the root node.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T KeepRootPosition<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function KeepRootPosition(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.LayerDistance(T) Method

LayeredLayoutExtensions.LayerDistance(T) Method
[image]

Sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LayerDistance<T> (
T layeredLayout,
double value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function LayerDistance(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Double _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.LinkPadding Method

LayeredLayoutExtensions.LinkPadding Method
[image]

Sets the distance between parallel cascading links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout LinkPadding (
LayeredLayout layeredLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LinkPadding( _
layeredLayout As LayeredLayout, _
value As Double _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.LinksCompactFactor(T) Method

LayeredLayoutExtensions.LinksCompactFactor(T) Method
[image]

Sets a value indicating how much to compact the outermost arrows.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinksCompactFactor<T> (
T layeredLayout,
double value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function LinksCompactFactor(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Double _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.LinkType(T) Method

LayeredLayoutExtensions.LinkType(T) Method
[image]

Sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkType<T> (
T layeredLayout,
LayeredLayoutLinkType value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function LinkType(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As LayeredLayoutLinkType _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.NodeDistance Method

LayeredLayoutExtensions.NodeDistance Method
[image]

Sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout NodeDistance (
LayeredLayout layeredLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
layeredLayout As LayeredLayout, _
value As Double _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.Orientation Method

LayeredLayoutExtensions.Orientation Method
[image]

Sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout Orientation (
LayeredLayout layeredLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
layeredLayout As LayeredLayout, _
value As Orientation _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.Root Method

LayeredLayoutExtensions.Root Method
[image]

Sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout Root (
LayeredLayout layeredLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Root( _
layeredLayout As LayeredLayout, _
value As Object _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.SplitLayers(T) Method

LayeredLayoutExtensions.SplitLayers(T) Method
[image]

Sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SplitLayers<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function SplitLayers(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.StableSort(T) Method

LayeredLayoutExtensions.StableSort(T) Method
[image]

Sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StableSort<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function StableSort(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.StartNode Method

LayeredLayoutExtensions.StartNode Method
[image]

Sets the node that should be placed in the first layer of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout StartNode (
LayeredLayout layeredLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function StartNode( _
layeredLayout As LayeredLayout, _
value As Object _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.StraightenLongLinks(T) Method

LayeredLayoutExtensions.StraightenLongLinks(T) Method
[image]

Sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StraightenLongLinks<T> (
T layeredLayout,
bool value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function StraightenLongLinks(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Boolean _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.SwapPairsIterations(T) Method

LayeredLayoutExtensions.SwapPairsIterations(T) Method
[image]

Sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SwapPairsIterations<T> (
T layeredLayout,
int value
) where T : LayeredLayout

Visual Basic [image] Copy Code

Public Shared Function SwapPairsIterations(Of T As LayeredLayout) ( _
layeredLayout As T, _
value As Integer _
) As T

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions.TimeLimit Method

LayeredLayoutExtensions.TimeLimit Method
[image]

Sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static LayeredLayout TimeLimit (
LayeredLayout layeredLayout,
long value
)

Visual Basic [image] Copy Code

Public Shared Function TimeLimit( _
layeredLayout As LayeredLayout, _
value As Long _
) As LayeredLayout

Parameters

layeredLayout

value

Return Value

See Also

LayeredLayoutExtensions Members
LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions.NodeDistance Method

OneWayLayoutExtensions.NodeDistance Method
[image]

Sets the minimum spacing between adjacent nodes in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OneWayLayout NodeDistance (
OneWayLayout oneWayLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
oneWayLayout As OneWayLayout, _
value As Double _
) As OneWayLayout

Parameters

oneWayLayout

value

Return Value

See Also

OneWayLayoutExtensions Members
OneWayLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions.Orientation Method

OneWayLayoutExtensions.Orientation Method
[image]

Sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OneWayLayout Orientation (
OneWayLayout oneWayLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
oneWayLayout As OneWayLayout, _
value As Orientation _
) As OneWayLayout

Parameters

oneWayLayout

value

Return Value

See Also

OneWayLayoutExtensions Members
OneWayLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions.RoundedLinks(T) Method

OneWayLayoutExtensions.RoundedLinks(T) Method
[image]

Sets a value indicating whether the layout should smooth link bends.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RoundedLinks<T> (
T oneWayLayout,
bool value
) where T : OneWayLayout

Visual Basic [image] Copy Code

Public Shared Function RoundedLinks(Of T As OneWayLayout) ( _
oneWayLayout As T, _
value As Boolean _
) As T

Parameters

oneWayLayout

value

Return Value

See Also

OneWayLayoutExtensions Members
OneWayLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions.Directed(T) Method

OrthogonalLayoutExtensions.Directed(T) Method
[image]

Sets a value indicating whether the graph being laid out is directed.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Directed<T> (
T orthogonalLayout,
bool value
) where T : OrthogonalLayout

Visual Basic [image] Copy Code

Public Shared Function Directed(Of T As OrthogonalLayout) ( _
orthogonalLayout As T, _
value As Boolean _
) As T

Parameters

orthogonalLayout

value

Return Value

See Also

OrthogonalLayoutExtensions Members
OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions.MinimizeLinkBends(T) Method

OrthogonalLayoutExtensions.MinimizeLinkBends(T) Method
[image]

Sets a value indicating whether the layout should attempt to minimize link bending.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T MinimizeLinkBends<T> (
T orthogonalLayout,
bool value
) where T : OrthogonalLayout

Visual Basic [image] Copy Code

Public Shared Function MinimizeLinkBends(Of T As OrthogonalLayout) ( _
orthogonalLayout As T, _
value As Boolean _
) As T

Parameters

orthogonalLayout

value

Return Value

See Also

OrthogonalLayoutExtensions Members
OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions.MinLaneSize(T) Method

OrthogonalLayoutExtensions.MinLaneSize(T) Method
[image]

Sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T MinLaneSize<T> (
T orthogonalLayout,
double value
) where T : OrthogonalLayout

Visual Basic [image] Copy Code

Public Shared Function MinLaneSize(Of T As OrthogonalLayout) ( _
orthogonalLayout As T, _
value As Double _
) As T

Parameters

orthogonalLayout

value

Return Value

See Also

OrthogonalLayoutExtensions Members
OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions.Padding Method

OrthogonalLayoutExtensions.Padding Method
[image]

Sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalLayout Padding (
OrthogonalLayout orthogonalLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function Padding( _
orthogonalLayout As OrthogonalLayout, _
value As Double _
) As OrthogonalLayout

Parameters

orthogonalLayout

value

Return Value

See Also

OrthogonalLayoutExtensions Members
OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions.Refine(T) Method

OrthogonalLayoutExtensions.Refine(T) Method
[image]

Sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Refine<T> (
T orthogonalLayout,
bool value
) where T : OrthogonalLayout

Visual Basic [image] Copy Code

Public Shared Function Refine(Of T As OrthogonalLayout) ( _
orthogonalLayout As T, _
value As Boolean _
) As T

Parameters

orthogonalLayout

value

Return Value

See Also

OrthogonalLayoutExtensions Members
OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.BendDistance(T) Method

OrthogonalRouterExtensions.BendDistance(T) Method
[image]

Sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BendDistance<T> (
T orthogonalRouter,
double value
) where T : OrthogonalRouter

Visual Basic [image] Copy Code

Public Shared Function BendDistance(Of T As OrthogonalRouter) ( _
orthogonalRouter As T, _
value As Double _
) As T

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.Direction Method

OrthogonalRouterExtensions.Direction Method
[image]

Sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter Direction (
OrthogonalRouter orthogonalRouter,
Direction value
)

Visual Basic [image] Copy Code

Public Shared Function Direction( _
orthogonalRouter As OrthogonalRouter, _
value As Direction _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.EndOrientation(T) Method

OrthogonalRouterExtensions.EndOrientation(T) Method
[image]

Sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EndOrientation<T> (
T orthogonalRouter,
Orientation value
) where T : OrthogonalRouter

Visual Basic [image] Copy Code

Public Shared Function EndOrientation(Of T As OrthogonalRouter) ( _
orthogonalRouter As T, _
value As Orientation _
) As T

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.GridSize Method

OrthogonalRouterExtensions.GridSize Method
[image]

Sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter GridSize (
OrthogonalRouter orthogonalRouter,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridSize( _
orthogonalRouter As OrthogonalRouter, _
value As Double _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.LayerDistance Method

OrthogonalRouterExtensions.LayerDistance Method
[image]

Sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter LayerDistance (
OrthogonalRouter orthogonalRouter,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LayerDistance( _
orthogonalRouter As OrthogonalRouter, _
value As Double _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.NodeDistance Method

OrthogonalRouterExtensions.NodeDistance Method
[image]

Sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter NodeDistance (
OrthogonalRouter orthogonalRouter,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
orthogonalRouter As OrthogonalRouter, _
value As Double _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.Orientation Method

OrthogonalRouterExtensions.Orientation Method
[image]

Sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter Orientation (
OrthogonalRouter orthogonalRouter,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
orthogonalRouter As OrthogonalRouter, _
value As Orientation _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.PutEndPointsAtNodeBorders(T) Method

OrthogonalRouterExtensions.PutEndPointsAtNodeBorders(T) Method
See Also
[image]

Sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T PutEndPointsAtNodeBorders<T> (
T orthogonalRouter,
bool value
) where T : OrthogonalRouter

Visual Basic [image] Copy Code

Public Shared Function PutEndPointsAtNodeBorders(Of T As OrthogonalRouter) ( _
orthogonalRouter As T, _
value As Boolean _
) As T

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.RandomSeed Method

OrthogonalRouterExtensions.RandomSeed Method
[image]

Sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static OrthogonalRouter RandomSeed (
OrthogonalRouter orthogonalRouter,
int value
)

Visual Basic [image] Copy Code

Public Shared Function RandomSeed( _
orthogonalRouter As OrthogonalRouter, _
value As Integer _
) As OrthogonalRouter

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions.StartOrientation(T) Method

OrthogonalRouterExtensions.StartOrientation(T) Method
[image]

Sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StartOrientation<T> (
T orthogonalRouter,
Orientation value
) where T : OrthogonalRouter

Visual Basic [image] Copy Code

Public Shared Function StartOrientation(Of T As OrthogonalRouter) ( _
orthogonalRouter As T, _
value As Orientation _
) As T

Parameters

orthogonalRouter

value

Return Value

See Also

OrthogonalRouterExtensions Members
OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.EnableClusters(T) Method

SpringLayoutExtensions.EnableClusters(T) Method
[image]

Sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnableClusters<T> (
T springLayout,
bool value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function EnableClusters(Of T As SpringLayout) ( _
springLayout As T, _
value As Boolean _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.IterationCount(T) Method

SpringLayoutExtensions.IterationCount(T) Method
[image]

Sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IterationCount<T> (
T springLayout,
int value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function IterationCount(Of T As SpringLayout) ( _
springLayout As T, _
value As Integer _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.Layout3D(T) Method

SpringLayoutExtensions.Layout3D(T) Method
[image]

Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Layout3D<T> (
T springLayout,
bool value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function Layout3D(Of T As SpringLayout) ( _
springLayout As T, _
value As Boolean _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.LayoutArea Method

SpringLayoutExtensions.LayoutArea Method
[image]

Sets the size of the layout area.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout LayoutArea (
SpringLayout springLayout,
Rect value
)

Visual Basic [image] Copy Code

Public Shared Function LayoutArea( _
springLayout As SpringLayout, _
value As Rect _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.LayoutMethod(T) Method

SpringLayoutExtensions.LayoutMethod(T) Method
[image]

Specifies what energy model to use for the simulation.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LayoutMethod<T> (
T springLayout,
SpringLayoutMethod value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function LayoutMethod(Of T As SpringLayout) ( _
springLayout As T, _
value As SpringLayoutMethod _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.LinkType(T) Method

SpringLayoutExtensions.LinkType(T) Method
[image]

Sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkType<T> (
T springLayout,
SpringLayoutLinkType value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function LinkType(Of T As SpringLayout) ( _
springLayout As T, _
value As SpringLayoutLinkType _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.MinimizeCrossings(T) Method

SpringLayoutExtensions.MinimizeCrossings(T) Method
[image]

Sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T MinimizeCrossings<T> (
T springLayout,
bool value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function MinimizeCrossings(Of T As SpringLayout) ( _
springLayout As T, _
value As Boolean _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.NodeDistance Method

SpringLayoutExtensions.NodeDistance Method
[image]

Sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout NodeDistance (
SpringLayout springLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
springLayout As SpringLayout, _
value As Double _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.Randomize Method

SpringLayoutExtensions.Randomize Method
[image]

Sets a value indicating whether nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout Randomize (
SpringLayout springLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function Randomize( _
springLayout As SpringLayout, _
value As Boolean _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.RandomSeed Method

SpringLayoutExtensions.RandomSeed Method
[image]

Sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout RandomSeed (
SpringLayout springLayout,
int value
)

Visual Basic [image] Copy Code

Public Shared Function RandomSeed( _
springLayout As SpringLayout, _
value As Integer _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.RepulsionFactor(T) Method

SpringLayoutExtensions.RepulsionFactor(T) Method
[image]

Sets the multiplier applied to repulsion forces between nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T RepulsionFactor<T> (
T springLayout,
double value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function RepulsionFactor(Of T As SpringLayout) ( _
springLayout As T, _
value As Double _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.Root Method

SpringLayoutExtensions.Root Method
[image]

Sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout Root (
SpringLayout springLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Root( _
springLayout As SpringLayout, _
value As Object _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.SplitGraph Method

SpringLayoutExtensions.SplitGraph Method
[image]

Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SpringLayout SplitGraph (
SpringLayout springLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SplitGraph( _
springLayout As SpringLayout, _
value As Boolean _
) As SpringLayout

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.Stretch(T) Method

SpringLayoutExtensions.Stretch(T) Method
[image]

Sets the link stretch factor.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Stretch<T> (
T springLayout,
double value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function Stretch(Of T As SpringLayout) ( _
springLayout As T, _
value As Double _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions.Surface(T) Method

SpringLayoutExtensions.Surface(T) Method
[image]

Specifies on what surface the nodes should be placed initially.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Surface<T> (
T springLayout,
Surface value
) where T : SpringLayout

Visual Basic [image] Copy Code

Public Shared Function Surface(Of T As SpringLayout) ( _
springLayout As T, _
value As Surface _
) As T

Parameters

springLayout

value

Return Value

See Also

SpringLayoutExtensions Members
SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.CollapseEmptyLanes(T) Method

SwimlaneLayoutExtensions.CollapseEmptyLanes(T) Method
[image]

Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CollapseEmptyLanes<T> (
T swimlaneLayout,
bool value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function CollapseEmptyLanes(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As Boolean _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.CompactNodes(T) Method

SwimlaneLayoutExtensions.CompactNodes(T) Method
[image]

Sets a value indicating whether the nodes within individual lanes are compacted.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CompactNodes<T> (
T swimlaneLayout,
bool value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function CompactNodes(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As Boolean _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.CustomSortOrder(T) Method

SwimlaneLayoutExtensions.CustomSortOrder(T) Method
[image]

Sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CustomSortOrder<T> (
T swimlaneLayout,
bool value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function CustomSortOrder(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As Boolean _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.Direction Method

SwimlaneLayoutExtensions.Direction Method
[image]

Sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SwimlaneLayout Direction (
SwimlaneLayout swimlaneLayout,
Direction value
)

Visual Basic [image] Copy Code

Public Shared Function Direction( _
swimlaneLayout As SwimlaneLayout, _
value As Direction _
) As SwimlaneLayout

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.KeepLaneSizes(T) Method

SwimlaneLayoutExtensions.KeepLaneSizes(T) Method
[image]

Sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T KeepLaneSizes<T> (
T swimlaneLayout,
bool value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function KeepLaneSizes(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As Boolean _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.LaneDistance(T) Method

SwimlaneLayoutExtensions.LaneDistance(T) Method
[image]

Sets the spacing between adjacent lanes in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LaneDistance<T> (
T swimlaneLayout,
double value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function LaneDistance(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As Double _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.NodeDistance Method

SwimlaneLayoutExtensions.NodeDistance Method
[image]

Sets the spacing between adjacent nodes within a lane in the final layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SwimlaneLayout NodeDistance (
SwimlaneLayout swimlaneLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
swimlaneLayout As SwimlaneLayout, _
value As Double _
) As SwimlaneLayout

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.Orientation Method

SwimlaneLayoutExtensions.Orientation Method
[image]

Sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static SwimlaneLayout Orientation (
SwimlaneLayout swimlaneLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
swimlaneLayout As SwimlaneLayout, _
value As Orientation _
) As SwimlaneLayout

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions.SwimlaneGrid(T) Method

SwimlaneLayoutExtensions.SwimlaneGrid(T) Method
[image]

Sets the object through which the layout can manipulate the swimlane grid.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T SwimlaneGrid<T> (
T swimlaneLayout,
ISwimlaneGrid value
) where T : SwimlaneLayout

Visual Basic [image] Copy Code

Public Shared Function SwimlaneGrid(Of T As SwimlaneLayout) ( _
swimlaneLayout As T, _
value As ISwimlaneGrid _
) As T

Parameters

swimlaneLayout

value

Return Value

See Also

SwimlaneLayoutExtensions Members
SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.BendAdjacentLinks(T) Method

TopologicalLayoutExtensions.BendAdjacentLinks(T) Method
[image]

Sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BendAdjacentLinks<T> (
T topologicalLayout,
bool value
) where T : TopologicalLayout

Visual Basic [image] Copy Code

Public Shared Function BendAdjacentLinks(Of T As TopologicalLayout) ( _
topologicalLayout As T, _
value As Boolean _
) As T

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.Direction Method

TopologicalLayoutExtensions.Direction Method
[image]

Sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TopologicalLayout Direction (
TopologicalLayout topologicalLayout,
Direction value
)

Visual Basic [image] Copy Code

Public Shared Function Direction( _
topologicalLayout As TopologicalLayout, _
value As Direction _
) As TopologicalLayout

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.MultipleGraphsPlacement(T) Method

TopologicalLayoutExtensions.MultipleGraphsPlacement(T) Method
See Also
[image]

Sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T MultipleGraphsPlacement<T> (
T topologicalLayout,
MultipleGraphsPlacement value
) where T : TopologicalLayout

Visual Basic [image] Copy Code

Public Shared Function MultipleGraphsPlacement(Of T As TopologicalLayout) ( _
topologicalLayout As T, _
value As MultipleGraphsPlacement _
) As T

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.NodeDistance Method

TopologicalLayoutExtensions.NodeDistance Method
[image]

Sets the distance between adjacent nodes in the diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TopologicalLayout NodeDistance (
TopologicalLayout topologicalLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
topologicalLayout As TopologicalLayout, _
value As Double _
) As TopologicalLayout

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.Orientation Method

TopologicalLayoutExtensions.Orientation Method
[image]

Sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TopologicalLayout Orientation (
TopologicalLayout topologicalLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
topologicalLayout As TopologicalLayout, _
value As Orientation _
) As TopologicalLayout

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions.SplitGraph Method

TopologicalLayoutExtensions.SplitGraph Method
[image]

Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TopologicalLayout SplitGraph (
TopologicalLayout topologicalLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function SplitGraph( _
topologicalLayout As TopologicalLayout, _
value As Boolean _
) As TopologicalLayout

Parameters

topologicalLayout

value

Return Value

See Also

TopologicalLayoutExtensions Members
TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.Balance(T) Method

TreeLayoutExtensions.Balance(T) Method
[image]

Sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Balance<T> (
T treeLayout,
TreeLayoutBalance value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function Balance(Of T As TreeLayout) ( _
treeLayout As T, _
value As TreeLayoutBalance _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.CompactAssistants(T) Method

TreeLayoutExtensions.CompactAssistants(T) Method
[image]

Sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T CompactAssistants<T> (
T treeLayout,
bool value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function CompactAssistants(Of T As TreeLayout) ( _
treeLayout As T, _
value As Boolean _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.Direction(T) Method

TreeLayoutExtensions.Direction(T) Method
[image]

Sets the tree direction.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Direction<T> (
T treeLayout,
TreeLayoutDirections value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function Direction(Of T As TreeLayout) ( _
treeLayout As T, _
value As TreeLayoutDirections _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.EnableAssistants(T) Method

TreeLayoutExtensions.EnableAssistants(T) Method
[image]

Sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T EnableAssistants<T> (
T treeLayout,
bool value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function EnableAssistants(Of T As TreeLayout) ( _
treeLayout As T, _
value As Boolean _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.IgnoreLinkDirection(T) Method

TreeLayoutExtensions.IgnoreLinkDirection(T) Method
[image]

Sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T IgnoreLinkDirection<T> (
T treeLayout,
bool value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function IgnoreLinkDirection(Of T As TreeLayout) ( _
treeLayout As T, _
value As Boolean _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.KeepRootPosition Method

TreeLayoutExtensions.KeepRootPosition Method
[image]

Sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeLayout KeepRootPosition (
TreeLayout treeLayout,
bool value
)

Visual Basic [image] Copy Code

Public Shared Function KeepRootPosition( _
treeLayout As TreeLayout, _
value As Boolean _
) As TreeLayout

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.LevelDistance Method

TreeLayoutExtensions.LevelDistance Method
[image]

Sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeLayout LevelDistance (
TreeLayout treeLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function LevelDistance( _
treeLayout As TreeLayout, _
value As Double _
) As TreeLayout

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.LinkOffset(T) Method

TreeLayoutExtensions.LinkOffset(T) Method
[image]

Sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkOffset<T> (
T treeLayout,
double value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function LinkOffset(Of T As TreeLayout) ( _
treeLayout As T, _
value As Double _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.LinkStyle(T) Method

TreeLayoutExtensions.LinkStyle(T) Method
[image]

Sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LinkStyle<T> (
T treeLayout,
TreeLayoutLinkType value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function LinkStyle(Of T As TreeLayout) ( _
treeLayout As T, _
value As TreeLayoutLinkType _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.NodeDistance Method

TreeLayoutExtensions.NodeDistance Method
[image]

Sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeLayout NodeDistance (
TreeLayout treeLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function NodeDistance( _
treeLayout As TreeLayout, _
value As Double _
) As TreeLayout

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.ReversedLinks(T) Method

TreeLayoutExtensions.ReversedLinks(T) Method
[image]

Sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ReversedLinks<T> (
T treeLayout,
bool value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function ReversedLinks(Of T As TreeLayout) ( _
treeLayout As T, _
value As Boolean _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.Root Method

TreeLayoutExtensions.Root Method
[image]

Sets the root node of the tree.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeLayout Root (
TreeLayout treeLayout,
Object value
)

Visual Basic [image] Copy Code

Public Shared Function Root( _
treeLayout As TreeLayout, _
value As Object _
) As TreeLayout

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.StretchFactor(T) Method

TreeLayoutExtensions.StretchFactor(T) Method
[image]

Sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T StretchFactor<T> (
T treeLayout,
double value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function StretchFactor(Of T As TreeLayout) ( _
treeLayout As T, _
value As Double _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions.Type(T) Method

TreeLayoutExtensions.Type(T) Method
[image]

Sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Type<T> (
T treeLayout,
TreeLayoutType value
) where T : TreeLayout

Visual Basic [image] Copy Code

Public Shared Function Type(Of T As TreeLayout) ( _
treeLayout As T, _
value As TreeLayoutType _
) As T

Parameters

treeLayout

value

Return Value

See Also

TreeLayoutExtensions Members
TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions.ContainerPadding(T) Method

TreeMapLayoutExtensions.ContainerPadding(T) Method
[image]

Sets the padding inside containers.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T ContainerPadding<T> (
T treeMapLayout,
double value
) where T : TreeMapLayout

Visual Basic [image] Copy Code

Public Shared Function ContainerPadding(Of T As TreeMapLayout) ( _
treeMapLayout As T, _
value As Double _
) As T

Parameters

treeMapLayout

value

Return Value

See Also

TreeMapLayoutExtensions Members
TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions.LayoutArea(T) Method

TreeMapLayoutExtensions.LayoutArea(T) Method
[image]

Sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T LayoutArea<T> (
T treeMapLayout,
Nullable<Rect> value
) where T : TreeMapLayout

Visual Basic [image] Copy Code

Public Shared Function LayoutArea(Of T As TreeMapLayout) ( _
treeMapLayout As T, _
value As Nullable(Of Rect) _
) As T

Parameters

treeMapLayout

value

Return Value

See Also

TreeMapLayoutExtensions Members
TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions.Orientation Method

TreeMapLayoutExtensions.Orientation Method
[image]

Sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeMapLayout Orientation (
TreeMapLayout treeMapLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
treeMapLayout As TreeMapLayout, _
value As Orientation _
) As TreeMapLayout

Parameters

treeMapLayout

value

Return Value

See Also

TreeMapLayoutExtensions Members
TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions.Padding Method

TreeMapLayoutExtensions.Padding Method
[image]

Sets the distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TreeMapLayout Padding (
TreeMapLayout treeMapLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function Padding( _
treeMapLayout As TreeMapLayout, _
value As Double _
) As TreeMapLayout

Parameters

treeMapLayout

value

Return Value

See Also

TreeMapLayoutExtensions Members
TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions.Squarify(T) Method

TreeMapLayoutExtensions.Squarify(T) Method
[image]

Sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T Squarify<T> (
T treeMapLayout,
bool value
) where T : TreeMapLayout

Visual Basic [image] Copy Code

Public Shared Function Squarify(Of T As TreeMapLayout) ( _
treeMapLayout As T, _
value As Boolean _
) As T

Parameters

treeMapLayout

value

Return Value

See Also

TreeMapLayoutExtensions Members
TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions.BendNonplanarLinks(T) Method

TriangularLayoutExtensions.BendNonplanarLinks(T) Method
[image]

Sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static T BendNonplanarLinks<T> (
T triangularLayout,
bool value
) where T : TriangularLayout

Visual Basic [image] Copy Code

Public Shared Function BendNonplanarLinks(Of T As TriangularLayout) ( _
triangularLayout As T, _
value As Boolean _
) As T

Parameters

triangularLayout

value

Return Value

See Also

TriangularLayoutExtensions Members
TriangularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions.GridSize Method

TriangularLayoutExtensions.GridSize Method
[image]

Sets the size of the virtual grid the layout will place vertices on.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TriangularLayout GridSize (
TriangularLayout triangularLayout,
double value
)

Visual Basic [image] Copy Code

Public Shared Function GridSize( _
triangularLayout As TriangularLayout, _
value As Double _
) As TriangularLayout

Parameters

triangularLayout

value

Return Value

See Also

TriangularLayoutExtensions Members
TriangularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions.Orientation Method

TriangularLayoutExtensions.Orientation Method
[image]

Sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public static TriangularLayout Orientation (
TriangularLayout triangularLayout,
Orientation value
)

Visual Basic [image] Copy Code

Public Shared Function Orientation( _
triangularLayout As TriangularLayout, _
value As Orientation _
) As TriangularLayout

Parameters

triangularLayout

value

Return Value

See Also

TriangularLayoutExtensions Members
TriangularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.RealTimeCharting.Wpf.Axis.OnPropertyChanged Method

Axis.OnPropertyChanged Method
[image]

Invoked whenever the effective value of any dependency property in the Axis class has been updated.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected void OnPropertyChanged (
string name
)

Visual Basic [image] Copy Code

Protected Sub OnPropertyChanged( _
name As String _
)

Parameters

name

The name of the dependency property that has changed.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer.MeasureOverride Method

AxisRenderer.MeasureOverride Method
[image]

Provides implementation of FrameworkElement.MeasureOverride.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The Size available to this FrameworkElement to draw itself.

Return Value

The size needed by this panel.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer.OnRender Method

AxisRenderer.OnRender Method
[image]

Renders an Axis according to its settings.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

A System.Windows.Media.DrwingContext object for the AxisRenderer to render itslef onto.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter.Convert Method

ChartToLegendVisibilityConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

ChartToLegendVisibilityConverter Members
ChartToLegendVisibilityConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter.ConvertBack Method

ChartToLegendVisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the ChartToLegendVisibilityConverter.

See Also

ChartToLegendVisibilityConverter Members
ChartToLegendVisibilityConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter.Convert Method

DoubleToGridLengthConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

DoubleToGridLengthConverter Members
DoubleToGridLengthConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter.ConvertBack Method

DoubleToGridLengthConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the DoubleToGridLengthConverter.

See Also

DoubleToGridLengthConverter Members
DoubleToGridLengthConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter.Convert Method

DoubleToThicknessConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

DoubleToThicknessConverter Members
DoubleToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter.ConvertBack Method

DoubleToThicknessConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the DoubleToThicknessConverter.

See Also

DoubleToThicknessConverter Members
DoubleToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer.MeasureOverride Method

LegendSymbolRenderer.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The size available for this element.

Return Value

The size needed by this element.

See Also

LegendSymbolRenderer Members
LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer.OnRender Method

LegendSymbolRenderer.OnRender Method
[image]

Renders the legend symbol.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

The drawing contect used for rendering.

See Also

LegendSymbolRenderer Members
LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.OnApplyTemplate Method

RealTimeChart.OnApplyTemplate Method
[image]

FrameworkElement.ApplyTemplate override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.OnPreviewMouseDown Method

RealTimeChart.OnPreviewMouseDown Method
[image]

Raises the OnPreviewMouseDown event.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override void OnPreviewMouseDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPreviewMouseDown( _
e As MouseButtonEventArgs _
)

Parameters

e

A MouseButtonEventArgs object that provides data for the event.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.Commit Method ()

PlotArea.Commit Method ()
See Also
[image]

Updates the plot area.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit ()

Visual Basic [image] Copy Code

Public Sub Commit ()

See Also

Commit Method Overload List
PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.Commit Method (Double)

PlotArea.Commit Method (Double)
See Also
[image]

Updates the plot area with the new smallest value at the X-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit (
double minAddedX
)

Visual Basic [image] Copy Code

Public Sub Commit( _
minAddedX As Double _
)

Parameters

minAddedX

The smallest number at the X-axis.

See Also

Commit Method Overload List
PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.Commit Method (Double, Int32, Boolean)

PlotArea.Commit Method (Double, Int32, Boolean)
See Also
[image]

Updates the plot area with the new smallest value at the X-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit (
double minAddedX,
int startIndex,
bool drawSeries
)

Visual Basic [image] Copy Code

Public Sub Commit( _
minAddedX As Double, _
startIndex As Integer, _
drawSeries As Boolean _
)

Parameters

minAddedX

The smallest number at the X-axis

startIndex

The index of the first point in the chart series to be updated.

drawSeries

Indicates if series are drawn.

See Also

Commit Method Overload List
PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.OnRender Method

PlotArea.OnRender Method
[image]

FrameworkElement.OnRender override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

The DrawingContext to use when rendering the plot area.

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter.Convert Method

PointToStringConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

PointToStringConverter Members
PointToStringConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter.ConvertBack Method

PointToStringConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the PointToStringConverter.

See Also

PointToStringConverter Members
PointToStringConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter.Convert Method

PointToThicknessConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

PointToThicknessConverter Members
PointToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter.ConvertBack Method

PointToThicknessConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the PointToThicknessConverter.

See Also

PointToThicknessConverter Members
PointToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ClearCache Method

RealTimeChart.ClearCache Method
[image]

Clears the cache of the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void ClearCache ()

Visual Basic [image] Copy Code

Public Sub ClearCache ()

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Commit Method ()

RealTimeChart.Commit Method ()
See Also
[image]

Updates the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit ()

Visual Basic [image] Copy Code

Public Sub Commit ()

See Also

Commit Method Overload List
RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Commit Method (Double)

RealTimeChart.Commit Method (Double)
See Also
[image]

Updates the chart with the new smallest X-axis value.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit (
double minAddedX
)

Visual Basic [image] Copy Code

Public Sub Commit( _
minAddedX As Double _
)

Parameters

minAddedX

The smallest number at the X-axis.

See Also

Commit Method Overload List
RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Commit Method (Int32)

RealTimeChart.Commit Method (Int32)
See Also
[image]

Updates the chart from the location of the value at the specified index in the Series.Data arrays.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public void Commit (
int startIndex
)

Visual Basic [image] Copy Code

Public Sub Commit( _
startIndex As Integer _
)

Parameters

startIndex

The index of the first value in the Series.Data to be updated.

See Also

Commit Method Overload List
RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter.Convert Method

SeriesToGeometryConverter.Convert Method
[image]

IValueConverter.Convert override

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type for the conversion.

parameter

A parameter to use when converting.

culture

The culture.

Return Value

The converted value.

See Also

SeriesToGeometryConverter Members
SeriesToGeometryConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter.ConvertBack Method

SeriesToGeometryConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack override.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The target type.

parameter

A parameter to be used by the conversion.

culture

The culture.

Return Value

The converted value.

Remarks

The method is not implemented in the SeriesToGeometryConverter class.

See Also

SeriesToGeometryConverter Members
SeriesToGeometryConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell.ArrangeOverride Method

UniformStackPanell.ArrangeOverride Method
[image]

Panel.ArrangeOverride implementation.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The final available size for the panel.

Return Value

The size actually used.

See Also

UniformStackPanell Members
UniformStackPanell Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell.MeasureOverride Method

UniformStackPanell.MeasureOverride Method
[image]

Panel.MeasureOverride

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size.

Return Value

The size used by the element.

See Also

UniformStackPanell Members
UniformStackPanell Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.ByteCode.Empty Method

ByteCode.Empty Method
[image]

Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Empty ()

Visual Basic [image] Copy Code

Public Shared Function Empty () As ByteCode

Return Value

An empty instance of the ByteCode class.

Remarks

Calling this method multiple times will return different instances.

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode.Evaluate Method

ByteCode.Evaluate Method
[image]

Evaluates the byte code in the specified context.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Evaluate (
EvaluationContext context
)

Visual Basic [image] Copy Code

Public Function Evaluate ( _
context As EvaluationContext _
) As Object

Parameters

context
An instance of the EvaluationContext class providing evaluation context, such as culture, target object and parameters.

Return Value

The result of the evaluation, possibly null (Nothing in Visual Basic).

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String)

Compiler.Compile Method (String)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source
)

Visual Basic [image] Copy Code

Public Shared Function Compile ( _
source As String _
) As ByteCode

Parameters

source

The script to compile.

Return Value

A ByteCode instance representing the compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String, Boolean)

Compiler.Compile Method (String, Boolean)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source,
bool normalize
)

Visual Basic [image] Copy Code

Public Shared Function Compile ( _
source As String, _
normalize As Boolean _
) As ByteCode

Parameters

source

The script to compile.

normalize
true to encase source in square brackets if it is not encased already; otherwise, false.

Return Value

A ByteCode instance representing the compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler.Compile Method (String, CompileOptions)

Compiler.Compile Method (String, CompileOptions)
See Also
[image]

Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public static ByteCode Compile (
string source,
CompileOptions options
)

Visual Basic [image] Copy Code

Public Shared Function Compile( _
source As String, _
options As CompileOptions _
) As ByteCode

Parameters

source

The script to compile.

options

The compilation options.

Return Value

The compiled script.

See Also

Compile Method Overload List
Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateIdentifier Method

EvaluationContext.EvaluateIdentifier Method
[image]

Evaluates the identifier with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object EvaluateIdentifier (
string name
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateIdentifier( _
name As String _
) As Object

Parameters

name

The identifier to evaluate.

Return Value

The result of the evaluation.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateMember Method

EvaluationContext.EvaluateMember Method
[image]

Evaluates the member with the specified name against the specified target.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object EvaluateMember (
Object target,
string name,
bool last
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateMember( _
target As Object, _
name As String, _
last As Boolean _
) As Object

Parameters

target

The target object.

name

The name of the member.

last

Indicates whether the resolved member is the last in a sequence of member references. For example, in the following expression "A.B.C", when A.B is being resolved, last is set to false, and when R.C is being resolved (where R is the value of A.B), last is set to true.

Return Value

The value of the member.

Remarks

Member references are evaluated automatically. This method is called when a member references could not be resolved through reflection.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.EvaluateQuantity Method

EvaluationContext.EvaluateQuantity Method
[image]

Evaluates the specified quanitity in the specified unit.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual double EvaluateQuantity (
double value,
string unit
)

Visual Basic [image] Copy Code

Public Overridable Function EvaluateQuantity( _
value As Double, _
unit As String _
) As Double

Parameters

value

The value to evaluate.

unit

The unit of the value.

Return Value

The evaluated quantity.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.InvokeFunction Method

EvaluationContext.InvokeFunction Method
[image]

Invokes the function with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object InvokeFunction (
string name,
Object[] p
)

Visual Basic [image] Copy Code

Public Overridable Function InvokeFunction( _
name As String, _
p() As Object _
) As Object

Parameters

name

The name of the function to invoke.

p

The list of arguments of the function.

Return Value

The result of the invocation.

Remarks

If the specified name does not match any of the built-in functions, the DispatchFunctionCall is raised.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.OnDispatchFunctionCall Method

EvaluationContext.OnDispatchFunctionCall Method
[image]

Raises the DispatchFunctionCall event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

protected virtual void OnDispatchFunctionCall (
EvaluateFunctionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDispatchFunctionCall ( _
e As EvaluateFunctionEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.OnParseObject Method

EvaluationContext.OnParseObject Method
[image]

Raises the ParseObject event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

protected virtual void OnParseObject (
ParseObjectEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnParseObject ( _
e As ParseObjectEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ResolveObject Method

EvaluationContext.ResolveObject Method
[image]

Returns the object with the specified name.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object ResolveObject (
string name
)

Visual Basic [image] Copy Code

Public Overridable Function ResolveObject( _
name As String _
) As Object

Parameters

name

The name of the object.

Return Value

The found object.

Remarks

If this method returns null (Nothing in Visual Basic), the object is looked for in the underlying list with local variables.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.ResolveReference Method

EvaluationContext.ResolveReference Method
[image]

Returns the object representing the specified reference.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public virtual Object ResolveReference (
string target,
string[] fields
)

Visual Basic [image] Copy Code

Public Overridable Function ResolveReference( _
target As String, _
fields() As String _
) As Object

Parameters

target

The name of the object.

fields

A sequence of fields contained in the reference.

Return Value

The resolved object.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Mapping.WebForms.MapLayer Events

MapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.WebForms Namespace


MATCH

MATCH

Returns the position of an item in the specified list that matches the specified value in the specified order.

Syntax [image] Copy Code

MATCH( Any lookup, ReferenceOrArray searched, [Integer matchType = 1] ) → Any

Parameters

lookup
Required. The value to look for in the searched list.
searched
Required. The cell reference or the array that should be searched that contains only one row or column.
matchType
Optional. A value indicating how to match lookup with the values in searched. If omitted, matchType is assumed to be 1.

Remarks

MATCH searches for lookup in searched and returns its relative position in the list. If lookup could not be found, the function returns the #N/A error value.

If matchType is -1, MATCH finds the smallest value that is greater than or equal to lookup. The values in searched are expected to be sorted in descending order, texts before numbers (for example, TRUE, FALSE, "D", "B", "A", 1, 0, -2). From a sequence of identical values greater than or equal to lookup, the last value is selected.

If matchType is 0, MATCH finds the first value that is equal to lookup. The values in searched do not need to be sorted.

If matchType is 1 (or omitted), MATCH finds the largest value that is less than or equal to lookup. The values in searched are expected to be sorted in ascending order, numbers before texts (for example, -2, 0, 1, "A", "B", "D", FALSE, TRUE). From a sequence of identical values less than or equal to lookup, the last value is selected.

Use MATCH instead of one of the LOOKUP functions when you need the position of an item in the list rather than the item itself.

See Also

Function Reference
HLOOKUP Function
VLOOKUP Function
INDEX Function
OFFSET Function


MMULT

MMULT

Returns the matrix product of the specified arrays.

Syntax [image] Copy Code

MMULT( ReferenceOrArray array1, ReferenceOrArray array2 ) → Array

Parameters

array1
Required. The first array to multiply.
array2
Required. The second array to multiply.

Remarks

The specified parameters must be arrays or cell references. The number of columns in array1 must be the same as the number of rows in array2. Otherwise, the function returns #VALUE!. The result is an array with the same number of rows as array1 and the same number of columns as array2.

Example

Formula [image] Copy Code

=MMULT(A1:B4,C1:F2)
=MMULT({1;2},{3|4})

See Also

Function Reference
MUNIT Function


MOD

MOD

Returns the reminder of the division of the specified number.

Syntax [image] Copy Code

MOD( Number number, Number divisor ) → Number

Parameters

number
Required. The number to divide.
divisor
Required. The number to divide by.

Remarks

If divisor is zero, the function returns #DIV/0!.

Example

Formula [image] Copy Code

=MOD(5,2)
=MOD(-3,2)

See Also

Function Reference
INT Function
ROUND Function
ROUNDDOWN Function
ROUNDUP Function
TRUNC Function
QUOTIENT Function


MROUND

MROUND

Returns the specified number rounded to the specified multiple.

Syntax [image] Copy Code

MROUND( Number number, Number multiple ) → Number

Parameters

number
Required. The value to round.
multiple
Required. The multiple to which to round number.

Remarks

Returns the number x, for which x/multiple is integer (that is, multiple divides x), and for any other y with the same property, ABS(y-number)>=ABS(x-number). In case that two such x exist, the greater one is returned.

The number argument and the multiple argument must have the same sign; otherwise, the function returns #NUM!. If multiple is 0, the function returns zero.

See Also

Function Reference
CEILING Function
EVEN Function
FLOOR Function
ODD Function
ROUND Function
ROUNDDOWN Function


MUNIT

MUNIT

Returns the identity matrix with the specified dimension.

Syntax [image] Copy Code

MUNIT( Integer dimension ) → Array

Parameters

dimension
Required. The dimensions of the returned matrix.

Remarks

If dimension is less than zero, the function returns #VALUE!. The returns value is an array with the specified dimension. The primary diagonal of the returned array contains values 1. All other values of the array are 0.

See Also

Function Reference
MMULT Function


N

N

Converts the specified value to number.

Syntax [image] Copy Code

N( Any x ) → Number

Parameters

x
Required. The value to convert.

Remarks

If x is a reference, the value of the referenced cell is examined. If the value is a number, it is returned as is. If the value is logical, the function returns 1 for TRUE and 0 for FALSE. If the value is time or date, the serial number of the value is returned. If x is text or #N/A, the function returns 0. If x is an error other than #N/A, the error is returned. In any other case, the function returns 0.

Example

Formula [image] Copy Code

=N(1>0)
=N("5")
=N(100)

See Also

Function Reference
T Function
VALUE Function


MindFusion.Diagramming.Wpf.Fluent Namespace

MindFusion.Diagramming.Wpf.Fluent Namespace
Classes

Classes

Class | Description
BarcodeNodeExtensions | Provides extension methods for BarcodeNode fluent API.
ContainerNodeExtensions | Provides extension methods for ContainerNode fluent API.
DiagramExtensions | Provides extension methods for Diagram fluent API.
DiagramItemExtensions | Provides extension methods for DiagramItem fluent API.
DiagramLinkExtensions | Provides extension methods for DiagramLink fluent API.
DiagramNodeExtensions | Provides extension methods for DiagramNode fluent API.
FreeFormNodeExtensions | Provides extension methods for FreeFormNode fluent API.
SelectionExtensions | Provides extension methods for Selection fluent API.
ShapeNodeExtensions | Provides extension methods for ShapeNode fluent API.
TableNodeExtensions | Provides extension methods for TableNode fluent API.
TemplatedNodeExtensions | Provides extension methods for TemplatedNode fluent API.
TreeViewNodeExtensions | Provides extension methods for TreeViewNode fluent API.
VisioNodeExtensions | Provides extension methods for VisioNode fluent API.


MindFusion.Diagramming.Wpf.Import Namespace

MindFusion.Diagramming.Wpf.Import Namespace
Classes

Classes

Class | Description
ConnectorImportedEventArgs | Contains the arguments passed to handlers of the ConnectorImported event.
DrawImporter | DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.
GroupImportedEventArgs | Contains the arguments passed to handlers of the GroupImported event.
ImportItemEventArgs | Contains the arguments passed to handlers of the ImportItem event.
ShapeImportedEventArgs | Contains the arguments passed to handlers of the ShapeImported event.
Visio2013Importer | Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.
VisioImporter | Imports Visio 2003 XML Drawing files (*.vdx) into Diagram or DiagramDocument objects.


MindFusion.RealTimeCharting.Wpf Namespace

MindFusion.RealTimeCharting.Wpf Namespace
Classes Enumerations

Classes

Class | Description
Axis | Provides settings for the RealTimeChart axes.
AxisEventArgs | Provides data for the Axis.PropertyChanged event.
AxisRenderer | Provides a custom FrameworkElement that renders a RealTimeChart axis according to its settings.
ChartToLegendVisibilityConverter | Converts a bool value to a System.Windows.Visibility enumeration value.
DoubleToGridLengthConverter | Converts a double value to an instance of the System.Windows.GridLength structure.
DoubleToThicknessConverter | Converts a double value to an instance of the System.Windows.Thickness structure.
HitTestResult | Represents an object returned when hit testing.
Legend | Represents a legend in the chart.
LegendSymbolRenderer | Converts a Series object to a Geometry based on the Series.ScatterType property
PlotArea | Represents the plot area of the chart.
PointToStringConverter | Converts an instance of the System.Windows.Point structure to a string.
PointToThicknessConverter | Converts an instance of the System.Windows.Point value to an instance of the System.Windows.Thickness structure.
RealTimeChart | Represents the RealTimeChart control.
Series | Represents a series in the RealTimeChart.
SeriesCollection | Contains all series in the chart.
SeriesToGeometryConverter | Converts a Series object to a Geometry based on the Series.ScatterType property.
UniformStackPanell | Represents a panel that splits horizontal space equally among its children.
YAxisCollection | A collection of vertical axes.

Enumerations

Enumeration | Description
ScatterType | Provides various scatter types.


MindFusion.Scripting Namespace

MindFusion.Scripting Namespace
Classes

Classes

Class | Description
ByteCode | Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.
CompileOptions | Contains options for the Compiler.Compile method.
Compiler | Provides methods for compiling expressions to byte code.
EvaluateFunctionEventArgs | Contains the arguments passed to DispatchFunctionCall event handlers.
EvaluationContext | Provides a context for evaluating a byte code.
ParseObjectEventArgs | Contains the arguments passed to ParseObject event handlers.


NA

NA

Returns the error value #N/A.

Syntax [image] Copy Code

NA( ) → Error

Remarks

Returns the error value #N/A. #N/A is the error value that means "no value is available." NA can be used to mark empty cells.

When a formula refers to a cell containing #N/A, the formula returns #N/A, unless the formula does not propagate errors, which is explicitly noted.

Example

Formula [image] Copy Code

=NA()

See Also

Function Reference


NETWORKDAYS

NETWORKDAYS

Returns the number of whole working days between the specified two dates.

Syntax [image] Copy Code

NETWORKDAYS( Date startDate, Date endDate, [ReferenceOrArray holidays], [ReferenceOrArray weekends] ) → Integer

Parameters

startDate
Required. The start date of the period.
endDate
Required. The end date of the period.
holidays
Optional. A list of dates, that specifying the holiday dates that should be excluded from the result.
weekends
Optional. A list of logical values that specify which days of the week are working days.

Remarks

This function returns the working days in the specified period, by taking into consideration the holidays and weekends parameters. If holidays is specified, it can be an array or a cell reference, containing dates or serial numbers of dates, that should be regarded as nonworking days. If weekends is specified, it can be an array or a cell reference, containing logical values. The length of weekends must be exactly 7; otherwise, the function will return #VALUE!. Each value in weekends indicates whether the corresponding day of the week (1 to 7 for Sunday through Saturday) should be regarded as a weekend. TRUE indicates a weekend, FALSE indicates a working day. If weekends is omitted, Saturday and Sunday are counted as weekends.

Example

Formula [image] Copy Code

=NETWORKDAYS(DATE(YEAR(TODAY()),1,1),NOW())

See Also

Function Reference
EDATE Function
EOMONTH Function
NOW Function


NOT

NOT

Returns the logical NOT of the specified argument.

Syntax [image] Copy Code

NOT( Logical l ) → Logical

Parameters

l
Required. A logical value.

Remarks

Returns the logical NOT of l. That is, if l is FALSE, NOT returns TRUE; if l is TRUE, NOT returns FALSE.

Example

Formula [image] Copy Code

=NOT(TRUE)
=NOT(1+2=4)

See Also

Function Reference
AND Function
IF Function


NPER

NPER

Returns the number of periods for the specified investment based on the specified periodic, constant payments and the specified constant interest rate.

Syntax [image] Copy Code

NPER( Number rate, Number payment, Number pv, [Number fv = 0], [Integer type = 0] ) → Number

Parameters

rate
Required. The constant interest rate per period.
payment
Required. The payment made each period.
pv
Required. The present value of the investment.
fv
Optional. The future value. If omitted, fv is assumed to be 0.
type
Optional. A number specifying when the payment is due. If omitted, type is assumed to be 0.

Example

Formula [image] Copy Code

=NPER(0.12,-100,-1000)

See Also

Function Reference
FV Function
PMT Function
PV Function
RATE Function


NPV

NPV

Returns the net present value of an investment based on the specified series of periodic cash flows and the specified discount rate.

Syntax [image] Copy Code

NPV( Number rate, Number value1, Number value2, ... ) → Currency

Parameters

rate
Required. The discount rate over the length of the period.
value1
value2
…
A list of numbers representing payments and income.

Remarks

This function computes the net present value for a series of periodic cash flows with the discount rate rate. The values should be positive if they are received as income, and negative if the amounts are paid as outgo. The result is affected by the order of values.

See Also

Function Reference
FV Function
IRR Function
NPER Function
PMT Function
PV Function


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBackBrush Method

ContainerNodeExtensions.CaptionBackBrush Method
[image]

Overload List

Name | Description
ContainerNodeExtensions.CaptionBackBrush (ContainerNode, Brush) | Sets the brush used to paint the caption area of this container.
ContainerNodeExtensions.CaptionBackBrush (ContainerNode, Color) | Sets the brush used to paint the caption area of this container.
ContainerNodeExtensions.CaptionBackBrush (ContainerNode, Color, Color, Single) | Sets the brush used to paint the caption area of this container.

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions.CaptionBrush Method

ContainerNodeExtensions.CaptionBrush Method
[image]

Overload List

Name | Description
ContainerNodeExtensions.CaptionBrush (ContainerNode, Brush) | Sets the brush with which container's caption text is rendered.
ContainerNodeExtensions.CaptionBrush (ContainerNode, Color) | Sets the brush with which container's caption text is rendered.
ContainerNodeExtensions.CaptionBrush (ContainerNode, Color, Color, Single) | Sets the brush with which container's caption text is rendered.

See Also

ContainerNodeExtensions Members
ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.BackBrush Method

DiagramExtensions.BackBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.BackBrush (Diagram, Brush) | Sets the brush used for painting the diagram background.
DiagramExtensions.BackBrush (Diagram, Color) | Sets the brush used for painting the diagram background.
DiagramExtensions.BackBrush (Diagram, Color, Color, Single) | Sets the brush used for painting the diagram background.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.LinkBrush Method

DiagramExtensions.LinkBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.LinkBrush (Diagram, Brush) | Sets the default value for the Brush property of links.
DiagramExtensions.LinkBrush (Diagram, Color) | Sets the default value for the Brush property of links.
DiagramExtensions.LinkBrush (Diagram, Color, Color, Single) | Sets the default value for the Brush property of links.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.RowHighlightBrush Method

DiagramExtensions.RowHighlightBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.RowHighlightBrush (Diagram, Brush) | Sets the Brush used to fill highlighted table rows.
DiagramExtensions.RowHighlightBrush (Diagram, Color) | Sets the Brush used to fill highlighted table rows.
DiagramExtensions.RowHighlightBrush (Diagram, Color, Color, Single) | Sets the Brush used to fill highlighted table rows.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.ShapeBrush Method

DiagramExtensions.ShapeBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.ShapeBrush (Diagram, Brush) | Sets the default value for the Brush property of shape nodes.
DiagramExtensions.ShapeBrush (Diagram, Color) | Sets the default value for the Brush property of shape nodes.
DiagramExtensions.ShapeBrush (Diagram, Color, Color, Single) | Sets the default value for the Brush property of shape nodes.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TableBrush Method

DiagramExtensions.TableBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.TableBrush (Diagram, Brush) | Sets the default value for the Brush property of tables.
DiagramExtensions.TableBrush (Diagram, Color) | Sets the default value for the Brush property of tables.
DiagramExtensions.TableBrush (Diagram, Color, Color, Single) | Sets the default value for the Brush property of tables.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions.TextBrush Method

DiagramExtensions.TextBrush Method
[image]

Overload List

Name | Description
DiagramExtensions.TextBrush (Diagram, Brush) | Sets the default brush of text displayed inside diagram items.
DiagramExtensions.TextBrush (Diagram, Color) | Sets the default brush of text displayed inside diagram items.
DiagramExtensions.TextBrush (Diagram, Color, Color, Single) | Sets the default brush of text displayed inside diagram items.

See Also

DiagramExtensions Members
DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Brush Method

DiagramItemExtensions.Brush Method
[image]

Overload List

Name | Description
DiagramItemExtensions.Brush(T) (T, Brush) | Sets the brush used to fill the interior of this item.
DiagramItemExtensions.Brush(T) (T, Color) | Sets the brush used to fill the interior of this item.
DiagramItemExtensions.Brush(T) (T, Color, Color, Single) | Sets the brush used to fill the interior of this item.

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Font Method

DiagramItemExtensions.Font Method
[image]

Overload List

Name | Description
DiagramItemExtensions.Font(T) (T, Font) | Sets the font used to render the item's text.
DiagramItemExtensions.Font(T) (T, String, Double) | Sets the preferred font family for this DiagramItem.

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.Stroke Method

DiagramItemExtensions.Stroke Method
[image]

Overload List

Name | Description
DiagramItemExtensions.Stroke(T) (T, Brush) | Sets the Brush that specifies how the item outline is painted.
DiagramItemExtensions.Stroke(T) (T, Color) | Sets the Brush that specifies how the item outline is painted.
DiagramItemExtensions.Stroke(T) (T, Color, Color, Single) | Sets the Brush that specifies how the item outline is painted.

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions.TextBrush Method

DiagramItemExtensions.TextBrush Method
[image]

Overload List

Name | Description
DiagramItemExtensions.TextBrush(T) (T, Brush) | Sets the brush used to draw the item's text.
DiagramItemExtensions.TextBrush(T) (T, Color) | Sets the brush used to draw the item's text.
DiagramItemExtensions.TextBrush(T) (T, Color, Color, Single) | Sets the brush used to draw the item's text.

See Also

DiagramItemExtensions Members
DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions.HeadStroke Method

DiagramLinkExtensions.HeadStroke Method
[image]

Overload List

Name | Description
DiagramLinkExtensions.HeadStroke(T) (T, Brush) | Sets the Brush that specifies how the arrowhead stroke outline is painted.
DiagramLinkExtensions.HeadStroke(T) (T, Color) | Sets the Brush that specifies how the arrowhead stroke outline is painted.
DiagramLinkExtensions.HeadStroke(T) (T, Color, Color, Single) | Sets the Brush that specifies how the arrowhead stroke outline is painted.

See Also

DiagramLinkExtensions Members
DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBackBrush Method

TableNodeExtensions.CaptionBackBrush Method
[image]

Overload List

Name | Description
TableNodeExtensions.CaptionBackBrush(T) (T, Brush) | Sets the brush used to paint the caption area of this table.
TableNodeExtensions.CaptionBackBrush(T) (T, Color) | Sets the brush used to paint the caption area of this table.
TableNodeExtensions.CaptionBackBrush(T) (T, Color, Color, Single) | Sets the brush used to paint the caption area of this table.

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions.CaptionBrush Method

TableNodeExtensions.CaptionBrush Method
[image]

Overload List

Name | Description
TableNodeExtensions.CaptionBrush(T) (T, Brush) | Sets the color of the text used as table caption.
TableNodeExtensions.CaptionBrush(T) (T, Color) | Sets the color of the text used as table caption.
TableNodeExtensions.CaptionBrush(T) (T, Color, Color, Single) | Sets the color of the text used as table caption.

See Also

TableNodeExtensions Members
TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions.CaptionBrush Method

TreeViewNodeExtensions.CaptionBrush Method
[image]

Overload List

Name | Description
TreeViewNodeExtensions.CaptionBrush (TreeViewNode, Brush) | Sets the brush used to draw the caption text.
TreeViewNodeExtensions.CaptionBrush (TreeViewNode, Color) | Sets the brush used to draw the caption text.
TreeViewNodeExtensions.CaptionBrush (TreeViewNode, Color, Color, Single) | Sets the brush used to draw the caption text.

See Also

TreeViewNodeExtensions Members
TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter.Import Method

DrawImporter.Import Method
[image]

Overload List

Name | Description
DrawImporter.Import (String) | Imports the specified OpenOffice Draw document into a new DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.
DrawImporter.Import (String, Diagram) | Imports the specified OpenOffice Draw document into the specified Diagram.
DrawImporter.Import (String, DiagramDocument) | Imports the specified OpenOffice Draw document into an existing DiagramDocument, where each Draw page is imported into a separate DiagramPage of the DiagramDocument.

See Also

DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.Import Method

Visio2013Importer.Import Method
[image]

Imports the specified Visio Graphics Service VSDX file.

Overload List

Name | Description
Visio2013Importer.Import (String) | Imports the specified Visio Graphics Service VSDX file into a new DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.
Visio2013Importer.Import (String, Diagram) | Imports the specified Visio Graphics Service VSDX file into the specified Diagram.
Visio2013Importer.Import (String, DiagramDocument) | Imports the specified Visio Graphics Service VSDX file into an existing DiagramDocument, where each Visio page is imported into a separate DiagramPage of the DiagramDocument.

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.Commit Method

PlotArea.Commit Method
[image]

Overload List

Name | Description
PlotArea.Commit () | Updates the plot area.
PlotArea.Commit (Double) | Updates the plot area with the new smallest value at the X-axis.
PlotArea.Commit (Double, Int32, Boolean) | Updates the plot area with the new smallest value at the X-axis.

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Commit Method

RealTimeChart.Commit Method
[image]

Overload List

Name | Description
RealTimeChart.Commit () | Updates the chart.
RealTimeChart.Commit (Double) | Updates the chart with the new smallest X-axis value.
RealTimeChart.Commit (Int32) | Updates the chart from the location of the value at the specified index in the Series.Data arrays.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.Compiler.Compile Method

Compiler.Compile Method
[image]

Compiles a string expression into ByteCode.

Overload List

Name | Description
Compiler.Compile (String) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.
Compiler.Compile (String, Boolean) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.
Compiler.Compile (String, CompileOptions) | Returns a ByteCode object corresponding to the specified source code. The returned byte code can be subsequently evaluated by calling its Evaluate method.

See Also

Compiler Members
Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Constructor

EvaluationContext Constructor
[image]

Initializes a new instance of the EvaluationContext class.

Overload List

Name | Description
EvaluationContext (Object) | Initializes a new instance of the EvaluationContext class for the specified object.
EvaluationContext (Object, CultureInfo) | Initializes a new instance of the EvaluationContext class for the specified object and culture.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


OCT2BIN

OCT2BIN

Converts the specified octal (base 8) number to its binary (base 2) equivalent.

Syntax [image] Copy Code

OCT2BIN( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The octal number to convert, expressed as either text or number. This value should not contain more than 10 characters.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid octal number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

If digits is omitted, the function uses the minimum number of characters necessary to represent the result. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=OCT2BIN(5,3)
=OCT2BIN("777")

See Also

Function Reference
BIN2OCT Function
DEC2OCT Function
HEX2OCT Function


OCT2DEC

OCT2DEC

Converts the specified octal (base 8) number to its decimal equivalent.

Syntax [image] Copy Code

OCT2DEC( NumberOrText x ) → Number

Parameters

x
Required. The octal number to convert, expressed as either text or number. This value should not contain more than 10 characters.

Remarks

If x is not a valid octal number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=OCT2DEC(5,3)
=OCT2DEC("777")

See Also

Function Reference
BIN2OCT Function
DEC2OCT Function
HEX2OCT Function


OCT2HEX

OCT2HEX

Converts the specified octal (base 8) number to its hexadecimal equivalent.

Syntax [image] Copy Code

OCT2HEX( NumberOrText x, [Integer digits] ) → Text

Parameters

x
Required. The octal number to convert, expressed as either text or number. This value should not contain more than 10 characters.
digits
Optional. The number of characters to use for the result, useful for padding the return value with leading zeros.

Remarks

If x is not a valid octal number, the function returns the #VALUE! error value. If x contains more than 10 characters (10 bits), the function returns the #NUM! error value.

If digits is omitted, the function uses the minimum number of characters necessary to represent the result. If digits is specified and is less than the number of characters required to represent the result, the function returns the #NUM! error value. If digits is not an integer number, it is truncated.

Example

Formula [image] Copy Code

=OCT2BIN(5,3)
=OCT2BIN("777")

See Also

Function Reference
BIN2OCT Function
DEC2OCT Function
HEX2OCT Function


ODD

ODD

Returns the specified number rounded up to the nearest odd integer.

Syntax [image] Copy Code

ODD( Number n ) → Number

Parameters

n
Required. The number to round.

Remarks

Returns the odd integer whose sign is the same as the sign of n and whose absolute value is greater than or equal to the absolute value of n.

Example

Formula [image] Copy Code

=ODD(4)

See Also

Function Reference
CEILING Function
FLOOR Function
INT Function
ISEVEN Function
ISODD Function
EVEN Function
ROUND Function
TRUNC Function


OFFSET

OFFSET

Returns a reference to a range that is the specified number of rows and columns from the specified cell or range of cells. The reference that is returned can be a single cell or a range of cells, according to the specified number of rows and columns.

Syntax [image] Copy Code

OFFSET( Reference r, Integer rows, Integer columns, [Integer height], [Integer width] ) → Reference

Parameters

r
Required. The reference that should be offset.
rows
Required. The row of the new reference, relative to r.
columns
Required. The column of the new reference, relative to r.
height
Optional. The height, in number of rows, of the new reference. Must be a positive number.
width
Optional. The width, in number of columns, of the new reference. Must be a positive number.

Remarks

If r does not identify a valid cell or cell range, the function returns the #REF! error value. If the new reference goes over the edge of the worksheet, OFFSET returns the #REF! error value. If the specified values are not integer, they are automatically truncated.

If height or width is omitted, the new reference is assumed to be the same height or width as r.

Example

Formula [image] Copy Code

=OFFSET(E6,-2,-2)
=OFFSET(A1:C3,2,3,,5)

See Also

Function Reference
COLUMN Function
COLUMNS Function
ROW Function
ROWS Function


OR

OR

Returns TRUE if any of the specified arguments evaluate to TRUE; returns FALSE if all arguments evaluate to FALSE.

Syntax [image] Copy Code

OR( Logical l1, [Logical l2], ... ) -> Logical

Parameters

l1
l2
…
One or more logical values to test.

Remarks

The arguments must evaluate to logical values or arrays of logical values. If the specified range contains an argument that does not meet this requirement, the OR function returns the #VALUE! error value.

Example

Formula [image] Copy Code

=AND(A1)
=AND(B1:B5,A1>0)

See Also

Function Reference
AND Function
IF Function


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs.ConnectorXml Property

ConnectorImportedEventArgs.ConnectorXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public XmlNode ConnectorXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ConnectorXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs.Link Property

ConnectorImportedEventArgs.Link Property
[image]

Gets a reference to the imported diagram link.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs.ShapeName Property

ConnectorImportedEventArgs.ShapeName Property
[image]

Gets the Visio name of the connector shape.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public string ShapeName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the connector.

See Also

ConnectorImportedEventArgs Members
ConnectorImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter.PagesPerRow Property

DrawImporter.PagesPerRow Property
[image]

Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public int PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Integer

Property Value

See Also

DrawImporter Members
DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.GroupImportedEventArgs.Group Property

GroupImportedEventArgs.Group Property
[image]

Gets a reference to the imported group.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public Group Group { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Group As Group

Property Value

An instance of the Group class.

See Also

GroupImportedEventArgs Members
GroupImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs.Item Property

ImportItemEventArgs.Item Property
[image]

Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs.MasterName Property

ImportItemEventArgs.MasterName Property
[image]

Gets the name associated with shape's master.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public string MasterName { get; set; }

Visual Basic [image] Copy Code

Public Property MasterName As String

Property Value

A string specifying the name of the shape master.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs.MasterXml Property

ImportItemEventArgs.MasterXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public XmlNode MasterXml { get; set; }

Visual Basic [image] Copy Code

Public Property MasterXml As XmlNode

Property Value

A System.Xml.XmlNode instance.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs.NamespaceManager Property

ImportItemEventArgs.NamespaceManager Property
[image]

Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public XmlNamespaceManager NamespaceManager { get; set; }

Visual Basic [image] Copy Code

Public Property NamespaceManager As XmlNamespaceManager

Property Value

A System.Xml.XmlNamespaceManager instance.

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs.ShapeXml Property

ImportItemEventArgs.ShapeXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public XmlNode ShapeXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeXml As XmlNode

Property Value

See Also

ImportItemEventArgs Members
ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs.Shape Property

ShapeImportedEventArgs.Shape Property
[image]

Gets a reference to the imported diagram shape.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public ShapeNode Shape { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shape As ShapeNode

Property Value

An instance of the ShapeNode class.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs.ShapeName Property

ShapeImportedEventArgs.ShapeName Property
[image]

Gets the Visio shape identifier.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public string ShapeName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeName As String

Property Value

A string specifying the Visio name of the shape.

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs.ShapeXml Property

ShapeImportedEventArgs.ShapeXml Property
[image]

Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public XmlNode ShapeXml { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeXml As XmlNode

Property Value

An XmlNode object corresponding to the section of the VDX document which describes the imported shape.

Example

The following sample shows how to read a custom property value defined in Visio by handling the ShapeImported event.

C# [image] Copy Code

private void ShapeImported(object sender, ShapeImportedEventArgs e)
{
XmlNode vdxCode = e.ShapeXml;
try
{
XmlNamespaceManager ns = new XmlNamespaceManager(e.ShapeXml.OwnerDocument.NameTable);
ns.AddNamespace("vdx", "http://schemas.microsoft.com/visio/2003/core");

XmlNode myPropVal = vdxCode.SelectSingleNode("vdx:Prop[vdx:Label='MyProperty']/vdx:Value", ns);
if (myPropVal != null)
e.Shape.Tag = myPropVal.InnerText;
}
catch (Exception ex)
{
MessageBox.Show(ex.Message);
}
}

See Also

ShapeImportedEventArgs Members
ShapeImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer.PagesPerRow Property

Visio2013Importer.PagesPerRow Property
[image]

Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public int PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Integer

Property Value

An integer value specifying how many pages to import in a row. The default is 1.

Remarks

This property is considered by the Import overload that imports all pages into a single diagram.

See Also

Visio2013Importer Members
Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.ApplyVisioUnit Property

VisioImporter.ApplyVisioUnit Property
[image]

Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public bool ApplyVisioUnit { get; set; }

Visual Basic [image] Copy Code

Public Property ApplyVisioUnit As Boolean

Property Value

true to set MeasureUnit; otherwise, false. The default value is false.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.ImportEntitiesAsTables Property

VisioImporter.ImportEntitiesAsTables Property
[image]

Gets or sets a value indicating whether Visio UML and DB entities are imported as TableNode objects.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public bool ImportEntitiesAsTables { get; set; }

Visual Basic [image] Copy Code

Public Property ImportEntitiesAsTables As Boolean

Property Value

true to import Visio entity nodes as tables; otherwise, false. The default is false.

Remarks

If this property is disabled, Visio entity objects are imported as MindFusion.Diagramming groups of rectangular nodes; if it is enabled, entities are imported as tables.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.PagesPerRow Property

VisioImporter.PagesPerRow Property
[image]

Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public long PagesPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property PagesPerRow As Long

Property Value

An integer value specifying how many pages to import in a row. The default is 1.

Remarks

This property is used by ImportAllPages method when merging Visio pages into a single Diagram. Use the Import method instead to import each Visio page into a separate page of a DiagramDocument.

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter.SuppressUnmanagedCode Property

VisioImporter.SuppressUnmanagedCode Property
[image]

Suppress usage of unmanaged code.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public bool SuppressUnmanagedCode { get; set; }

Visual Basic [image] Copy Code

Public Property SuppressUnmanagedCode As Boolean

Property Value

See Also

VisioImporter Members
VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Background Property

Axis.Background Property
[image]

Gets or sets the background for the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush Background { get; set; }

Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.Transparent.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.DrawLabels Property

Axis.DrawLabels Property
[image]

Gets or sets whether labels are drawn at the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool DrawLabels { get; set; }

Visual Basic [image] Copy Code

Public Property DrawLabels As Boolean

Property Value

true if labels are drawn; otherwise false. The default value is true.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Interval Property

Axis.Interval Property
[image]

Gets or sets the interval between two adjacent values at the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Double

Property Value

A double value. The default value is 10.0.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelBrush Property

Axis.LabelBrush Property
[image]

Gets or sets the brush for the labels of the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelFontFamily Property

Axis.LabelFontFamily Property
[image]

Gets or sets the font family for the axes labels.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. The default value is new FontFamily("Times New Roman").

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelFontSize Property

Axis.LabelFontSize Property
[image]

Gets the size of the label font.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value that specifies the size of the label font. Default value is 12.0.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelFormat Property

Axis.LabelFormat Property
[image]

Gets or sets the format of the axes labels.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

One of the standrad .net numeric format strings. Default value is "F2".

Remarks

You can read more about the standard .net numeric format strings here [image] .

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelFormatProvider Property

Axis.LabelFormatProvider Property
[image]

Gets or sets custom IFormatProvider object for formatting numeric labels at the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public IFormatProvider LabelFormatProvider { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormatProvider As IFormatProvider

Property Value

A class that implements System.IFormatProvider. Default value is null.

Remarks

When you assign an instance of your custom IFormatProvider class you can specify additional arguments with the LabelFormat property - see the sample code.

Example

myChart.XAxis.LabelFormatProvider = new MyFormatProviderClass();
//my format class supports arguments:
myChart.XAxis.LabelFormat = "{0:X}";

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelHorizontalAlignment Property

Axis.LabelHorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the labels.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public HorizontalAlignment LabelHorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LabelHorizontalAlignment As HorizontalAlignment

Property Value

One of the System.Windows.HorizontalAlignment enumeration values. Default value is HorizontalAlignment.Left.

Remarks

Set LabelHorizontalAlignment according to the position of the Y-axis. If it is to the left, set the property to HorizontalAlignment.Left. For Y2-axes, set it to HorizontalAlignment.Right.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelOffset Property

Axis.LabelOffset Property
[image]

Gets or sets the offset of the labels to the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. The default value is 3.0.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.LabelOrigin Property

Axis.LabelOrigin Property
[image]

Gets or sets the numeric value of the first label at the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double LabelOrigin { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOrigin As Double

Property Value

A double value. Default value is double.NaN.

Remarks

The LabelOrigin property lets you set the first label at the axis, which might be different from the Origin of the axis e.g. you can have an axis from 0 to 100, but the first label might be 5 (LabelOrigin = 5.0).

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Length Property

Axis.Length Property
[image]

Gets or sets the length of the axes as a numeric value.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double Length { get; set; }

Visual Basic [image] Copy Code

Public Property Length As Double

Property Value

A double value. Default value is 100.0.

Remarks

The length of the axis means the difference between the smallest and the largest number at the axis.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Origin Property

Axis.Origin Property
[image]

Gets or sets the smallest number at the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double Origin { get; set; }

Visual Basic [image] Copy Code

Public Property Origin As Double

Property Value

A double value. The default value is 0.0.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.PinLabels Property

Axis.PinLabels Property
[image]

Gets or sets whether chart labels are pinned to the axes.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool PinLabels { get; set; }

Visual Basic [image] Copy Code

Public Property PinLabels As Boolean

Property Value

A bool value; The default value is true.

Remarks

When the labels are pinned, they don't change position along the axes when the chart's graphics gets scrolled.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Stroke Property

Axis.Stroke Property
[image]

Gets or sets the stroke for the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TickLength Property

Axis.TickLength Property
[image]

Gets or sets the length of the axis ticks.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TickLength { get; set; }

Visual Basic [image] Copy Code

Public Property TickLength As Double

Property Value

A double value. The default value is 0.0 (no ticks).

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Title Property

Axis.Title Property
[image]

Gets or sets the title for this Axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string. The default value is ""(an empty string).

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TitleBrush Property

Axis.TitleBrush Property
[image]

Gets or sets the brush for the title of the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush TitleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TitleBrush As Brush

Property Value

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TitleFontFamily Property

Axis.TitleFontFamily Property
[image]

Gets or sets the font family for the axis title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. The default value is FontFamily("Times New Roman").

Remarks

Use the Title property to set the title label.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TitleFontSize Property

Axis.TitleFontSize Property
[image]

Gets or sets the size of the font for the axes title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. The default value is 12.0.

Remarks

Use the Title property to set the title label.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TitleOffset Property

Axis.TitleOffset Property
[image]

Gets or sets the offset for the title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TitleOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TitleOffset As Double

Property Value

A double value. The default value is 5.0.

Remarks

Use the Title property to set the title label.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.TitleRotationAngle Property

Axis.TitleRotationAngle Property
[image]

Gets or sets the rotation angle of the title label.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TitleRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleRotationAngle As Double

Property Value

A double value. The default value is 0.0.

Remarks

Use the Title property to set the title label.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.VerticalAlignment Property

Axis.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the labels.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlignment As VerticalAlignment

Property Value

One of the System.Windows.VerticalAlignment enumeration values. Default value is VerticalAlignment.Bottom.

Remarks

Use the VerticalAlignment property to align the X-axis at the top or bottom of the plot area.

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis.Visibility Property

Axis.Visibility Property
[image]

Gets or sets the visibility for the axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Visibility Visibility { get; set; }

Visual Basic [image] Copy Code

Public Property Visibility As Visibility

Property Value

See Also

Axis Members
Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisEventArgs.Axis Property

AxisEventArgs.Axis Property
[image]

Gets or sets the Axis that has raised the event.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis Axis { get; set; }

Visual Basic [image] Copy Code

Public Property Axis As Axis

Property Value

See Also

AxisEventArgs Members
AxisEventArgs Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer.XAxis Property

AxisRenderer.XAxis Property
[image]

The X-axis of the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

An instance of the Axis class.

Remarks

Some of the settings of the X-axis are used by the AxisRenderer when calculating the position of the axis and its labels.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer.YAxis Property

AxisRenderer.YAxis Property
[image]

The Y-axis to be rendered.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis YAxis { get; set; }

Visual Basic [image] Copy Code

Public Property YAxis As Axis

Property Value

An instance of the Axis class.

See Also

AxisRenderer Members
AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult.Index Property

HitTestResult.Index Property
[image]

The index the hit element has in the Series it belongs to.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

HitTestResult Members
HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult.Series Property

HitTestResult.Series Property
[image]

The Series object hit by the mouse.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Series Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As Series

Property Value

An instance of the Series class.

See Also

HitTestResult Members
HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult.Value Property

HitTestResult.Value Property
[image]

The value of the hit element.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Point Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Point

Property Value

A instance of the System.Windows.Point structure whose X and Y values represent the values of the hit point.

See Also

HitTestResult Members
HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.CornerRadius Property

Legend.CornerRadius Property
[image]

Gets or sets the corner radius of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the System.Windows.CornerRadius structure.

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.LabelFontFamily Property

Legend.LabelFontFamily Property
[image]

Gets or sets the font family for the legend labels.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. The default value is FontFamily("Times New Roman").

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend.Orientation Property

Legend.Orientation Property
[image]

Gets or sets the orientation of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

One of the System.Windows.Controls.Orientation values. The default value is Orientation.Vertical.

See Also

Legend Members
Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer.Series Property

LegendSymbolRenderer.Series Property
[image]

Gets or sets the collection of Series to mark in the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Series Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As Series

Property Value

See Also

LegendSymbolRenderer Members
LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.BitmapOffset Property

PlotArea.BitmapOffset Property
[image]

Gets or sets the bitmap cache scroll offset.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public int BitmapOffset { get; set; }

Visual Basic [image] Copy Code

Public Property BitmapOffset As Integer

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.Chart Property

PlotArea.Chart Property
[image]

Gets or sets the Chart object.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public RealTimeChart Chart { get; set; }

Visual Basic [image] Copy Code

Public Property Chart As RealTimeChart

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.CrosshairsDataPoint Property

PlotArea.CrosshairsDataPoint Property
[image]

Gets or sets the data point that corresponds to the location of the crosshairs.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Point CrosshairsDataPoint { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairsDataPoint As Point

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.CrosshairsVisibility Property

PlotArea.CrosshairsVisibility Property
[image]

Gets or sets the visibility of the crosshairs.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Visibility CrosshairsVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property CrosshairsVisibility As Visibility

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.DataPoint Property

PlotArea.DataPoint Property
[image]

Gets or sets the data point that corresponds to the location of the mouse.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Point DataPoint { get; set; }

Visual Basic [image] Copy Code

Public Property DataPoint As Point

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.MousePosition Property

PlotArea.MousePosition Property
[image]

Gets or sets the position of the mouse over the plot area.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Point MousePosition { get; set; }

Visual Basic [image] Copy Code

Public Property MousePosition As Point

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.ScrollOffset Property

PlotArea.ScrollOffset Property
[image]

Gets or sets the scroll offset.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double ScrollOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOffset As Double

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.SeriesCollection Property

PlotArea.SeriesCollection Property
[image]

Gets or sets the collection of Series for the plot area.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public SeriesCollection SeriesCollection { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesCollection As SeriesCollection

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.TooltipBackground Property

PlotArea.TooltipBackground Property
[image]

Gets or sets the tooltip background brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush TooltipBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipBackground As Brush

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.TooltipStroke Property

PlotArea.TooltipStroke Property
[image]

Gets or sets the stroke for the tooltip.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush TooltipStroke { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipStroke As Brush

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.ToolTipVisibility Property

PlotArea.ToolTipVisibility Property
[image]

Gets or sets whether the tool tip is visible.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Visibility ToolTipVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property ToolTipVisibility As Visibility

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea.XAxis Property

PlotArea.XAxis Property
[image]

Gets or sets the settings for the X-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

See Also

PlotArea Members
PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.BitmapOffset Property

RealTimeChart.BitmapOffset Property
[image]

Gets or sets the bitmap cache scroll offset.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public int BitmapOffset { get; set; }

Visual Basic [image] Copy Code

Public Property BitmapOffset As Integer

Property Value

An integer value. The default value is 0;

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.CornerRadius Property

RealTimeChart.CornerRadius Property
[image]

Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the System.Windows.CornerRadius class. The default value is CornerRadius(3.0).

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FallbackTooltipBackground Property

RealTimeChart.FallbackTooltipBackground Property
[image]

Gets or sets the tooltip background brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush FallbackTooltipBackground { get; set; }

Visual Basic [image] Copy Code

Public Property FallbackTooltipBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.White.

Remarks

Set ShowFallbackTooltip to true if you want to show the tool tip.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FastScrollMode Property

RealTimeChart.FastScrollMode Property
[image]

Gets or sets whether the chart should automatically scroll when provided data exceeds current max. value shown on axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool FastScrollMode { get; set; }

Visual Basic [image] Copy Code

Public Property FastScrollMode As Boolean

Property Value

A bool value. The default value is false.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameBottomThickness Property

RealTimeChart.FrameBottomThickness Property
[image]

Gets or sets the thickness of the bottom plot area frame.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double FrameBottomThickness { get; set; }

Visual Basic [image] Copy Code

Public Property FrameBottomThickness As Double

Property Value

A double value. The default value is 50.0.

Remarks

The FrameBottomThickness property specifies the space under the plot area.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameLeftThickness Property

RealTimeChart.FrameLeftThickness Property
[image]

Gets or sets the thickness of the left plot area frame.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double FrameLeftThickness { get; set; }

Visual Basic [image] Copy Code

Public Property FrameLeftThickness As Double

Property Value

A double value. The default value is 50.0.

Remarks

The FrameLeftThickness property specifies the space to the left of the plot area. It gets distributed by the axes in the YAxisCollection.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameRightThickness Property

RealTimeChart.FrameRightThickness Property
[image]

Gets or sets the thickness of the right plot area frame.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double FrameRightThickness { get; set; }

Visual Basic [image] Copy Code

Public Property FrameRightThickness As Double

Property Value

A double value. The default value is 50.0.

Remarks

The FrameRightThickness property specifies the space to the right of the plot area. It gets distributed by the axes in the Y2AxisCollection.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.FrameTopThickness Property

RealTimeChart.FrameTopThickness Property
[image]

Gets or sets the thickness of the top plot area frame.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double FrameTopThickness { get; set; }

Visual Basic [image] Copy Code

Public Property FrameTopThickness As Double

Property Value

A double value. The default value is 50.0.

Remarks

The FrameTopThickness property specifies the space above the plot area.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.GridAxis Property

RealTimeChart.GridAxis Property
[image]

Gets or sets the YAxis used to calculate grid spacing.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis GridAxis { get; set; }

Visual Basic [image] Copy Code

Public Property GridAxis As Axis

Property Value

An instance of the Axis class. The default value is new Axis().

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendBackground Property

RealTimeChart.LegendBackground Property
[image]

Gets or sets the legend background brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush LegendBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is null (no background is drawn).

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendBorderBrush Property

RealTimeChart.LegendBorderBrush Property
[image]

Gets or sets the legend border brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush LegendBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBorderBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is null (no background is drawn).

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendHeight Property

RealTimeChart.LegendHeight Property
[image]

Gets or sets the height of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double LegendHeight { get; set; }

Visual Basic [image] Copy Code

Public Property LegendHeight As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendHorizontalAlignment Property

RealTimeChart.LegendHorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public HorizontalAlignment LegendHorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LegendHorizontalAlignment As HorizontalAlignment

Property Value

One of the System.Windows.HorizontalAlignment enumeration values. Default value is HorizontalAlignment.Center.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendOrientation Property

RealTimeChart.LegendOrientation Property
[image]

Gets or sets the orientation of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Orientation LegendOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LegendOrientation As Orientation

Property Value

One of the System.Windows.Controls.Orientation enumeration values. Default value is Orientation.Vertical.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendVerticalAlignment Property

RealTimeChart.LegendVerticalAlignment Property
[image]

Gets or sets the vertical alignment of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment LegendVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LegendVerticalAlignment As VerticalAlignment

Property Value

One of the System.Windows.VerticalAlignment enumeration values. Default value is VerticalAlignment.Center.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.LegendWidth Property

RealTimeChart.LegendWidth Property
[image]

Gets or sets the width of the legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double LegendWidth { get; set; }

Visual Basic [image] Copy Code

Public Property LegendWidth As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridSizeX Property

RealTimeChart.MajorGridSizeX Property
[image]

Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MajorGridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property MajorGridSizeX As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridSizeY Property

RealTimeChart.MajorGridSizeY Property
[image]

Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MajorGridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property MajorGridSizeY As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridStroke Property

RealTimeChart.MajorGridStroke Property
[image]

Gets or sets the brush used for drawing major grid lines.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush MajorGridStroke { get; set; }

Visual Basic [image] Copy Code

Public Property MajorGridStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.LightGray.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MajorGridStrokeThickness Property

RealTimeChart.MajorGridStrokeThickness Property
[image]

Gets or sets the thickness of the brush for drawing major grid lines.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MajorGridStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property MajorGridStrokeThickness As Double

Property Value

A double value. The default value is 3.0.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridSizeX Property

RealTimeChart.MinorGridSizeX Property
[image]

Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MinorGridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property MinorGridSizeX As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridSizeY Property

RealTimeChart.MinorGridSizeY Property
[image]

Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MinorGridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property MinorGridSizeY As Double

Property Value

A double value. The default value is double.NaN.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridStroke Property

RealTimeChart.MinorGridStroke Property
[image]

Gets or sets the brush used for drawing minor grid lines.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush MinorGridStroke { get; set; }

Visual Basic [image] Copy Code

Public Property MinorGridStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.LightGray.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.MinorGridStrokeThickness Property

RealTimeChart.MinorGridStrokeThickness Property
[image]

Gets or sets the thickness of the brush used for drawing minor grid lines.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double MinorGridStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property MinorGridStrokeThickness As Double

Property Value

A double value. The default value is 1.0.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ScrollOffset Property

RealTimeChart.ScrollOffset Property
[image]

Gets or sets the scroll offset.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double ScrollOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollOffset As Double

Property Value

A double value. The default value is 0.0.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.SeriesCollection Property

RealTimeChart.SeriesCollection Property
[image]

Gets or sets the collection of Series for the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public SeriesCollection SeriesCollection { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesCollection As SeriesCollection

Property Value

An instance of the SeriesCollection class. The default value is new SeriesCollection().

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ShowCrosshairs Property

RealTimeChart.ShowCrosshairs Property
[image]

Gets or sets whether the crosshairs are visible.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool ShowCrosshairs { get; set; }

Visual Basic [image] Copy Code

Public Property ShowCrosshairs As Boolean

Property Value

true to show crosshairs, or false otherwise. The default value is false.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ShowFallbackTooltip Property

RealTimeChart.ShowFallbackTooltip Property
[image]

Gets or sets whether a fallback tooltip is shown.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool ShowFallbackTooltip { get; set; }

Visual Basic [image] Copy Code

Public Property ShowFallbackTooltip As Boolean

Property Value

A bool value. The default value is false.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.ShowLegend Property

RealTimeChart.ShowLegend Property
[image]

Gets or sets whether the chart has a legend.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool ShowLegend { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLegend As Boolean

Property Value

A bool value. The default value is false.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleFontFamily Property

RealTimeChart.TitleFontFamily Property
[image]

Gets or sets the font family of the chart title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. The default value is FontFamily("Times New Roman").

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleFontSize Property

RealTimeChart.TitleFontSize Property
[image]

Gets or sets the font size of the chart title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. The default value is 14.0.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleHorizontalAlignment Property

RealTimeChart.TitleHorizontalAlignment Property
[image]

iGets or sets the horizontal alignment of the title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public HorizontalAlignment TitleHorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TitleHorizontalAlignment As HorizontalAlignment

Property Value

One of the System.Windows.HorizontalAlignment enumeration values. Default value is HorizontalAlignment.Center.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleText Property

RealTimeChart.TitleText Property
[image]

Gets or sets the text of the chart title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public string TitleText { get; set; }

Visual Basic [image] Copy Code

Public Property TitleText As String

Property Value

A string value. The default value is "Title".

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TitleVerticalAlignment Property

RealTimeChart.TitleVerticalAlignment Property
[image]

Gets or sets the vertical alignment of the title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public VerticalAlignment TitleVerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TitleVerticalAlignment As VerticalAlignment

Property Value

One of the System.Windows.VerticalAlignment enumeration values. Default value is VerticalAlignment.Center.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipAxis Property

RealTimeChart.TooltipAxis Property
[image]

Gets or sets the YAxis used to calculate coordinates shown in the tooltip.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis TooltipAxis { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipAxis As Axis

Property Value

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipDistance Property

RealTimeChart.TooltipDistance Property
[image]

Gets or sets the distance of the tooltip to the element it refers to.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public int TooltipDistance { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipDistance As Integer

Property Value

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.TooltipVisibility Property

RealTimeChart.TooltipVisibility Property
[image]

Gets or sets whether tooltips are drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Visibility TooltipVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipVisibility As Visibility

Property Value

One of the System.Windows.Visibility enumeration values. Default value is Visibility.Hidden.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.XAxis Property

RealTimeChart.XAxis Property
[image]

Gets or sets the settings for the X-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis XAxis { get; set; }

Visual Basic [image] Copy Code

Public Property XAxis As Axis

Property Value

An instance of the Axis class. The default value is new Axis().

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.Y2AxisCollection Property

RealTimeChart.Y2AxisCollection Property
[image]

Gets or sets the collection of Y2Axis settings for the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public YAxisCollection Y2AxisCollection { get; set; }

Visual Basic [image] Copy Code

Public Property Y2AxisCollection As YAxisCollection

Property Value

An instance of the YAxisCollection class. The default value is new YAxisCollection.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart.YAxisCollection Property

RealTimeChart.YAxisCollection Property
[image]

Gets or sets the collection of YAxis-settings for the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public YAxisCollection YAxisCollection { get; set; }

Visual Basic [image] Copy Code

Public Property YAxisCollection As YAxisCollection

Property Value

An instance of the YAxisCollection class. The default value is new YAxisCollection.

See Also

RealTimeChart Members
RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.Data Property

Series.Data Property
[image]

Gets or sets the data for the Series.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public List<Point> Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As List(Of Point)

Property Value

An instance of a strongly typed List<Point>collection. The default value is an empty collection.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.Fill Property

Series.Fill Property
[image]

Gets or sets the fill for the series.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.Blue.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.LegendBackground Property

Series.LegendBackground Property
[image]

Gets or sets the legend background brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush LegendBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LegendBackground As Brush

Property Value

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.ScatterStroke Property

Series.ScatterStroke Property
[image]

Gets or sets the stroke for the series' scatters.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush ScatterStroke { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is null.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.ScatterType Property

Series.ScatterType Property
[image]

Gets or sets a value specifying the scatter shapes to display for the values in this series.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

One of the ScatterType enumeration values. Default value is ScatterType.None.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.Stroke Property

Series.Stroke Property
[image]

Gets or sets the stroke for the series.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.Blue.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.Title Property

Series.Title Property
[image]

Gets or sets the title for the series.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. The default value is an empty string ("").

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontFamily Property

Series.TitleFontFamily Property
[image]

Gets or sets the font family for the series title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. The default value is FontFamily("Times New Roman").

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontSize Property

Series.TitleFontSize Property
[image]

Gets or sets the font for the series title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. The default value is 12.0.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TitleFontWeight Property

Series.TitleFontWeight Property
[image]

Gets or sets the font weight for the series title.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TooltipBackground Property

Series.TooltipBackground Property
[image]

Gets or sets the tooltip background brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush TooltipBackground { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is Brushes.White.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.TooltipStroke Property

Series.TooltipStroke Property
[image]

Gets or sets the tooltip text brush.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Brush TooltipStroke { get; set; }

Visual Basic [image] Copy Code

Public Property TooltipStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. The default value is null.

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.Visible Property

Series.Visible Property
[image]

Gets or sets whether the series should be drawn.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series.YAxis Property

Series.YAxis Property
[image]

Gets the Y-axis.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public Axis YAxis { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property YAxis As Axis

Property Value

See Also

Series Members
Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.ByteCode.Identifiers Property

ByteCode.Identifiers Property
[image]

Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string[] Identifiers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Identifiers As String()

Property Value

A list with the identifiers in the code.

See Also

ByteCode Members
ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.InterpretCircumflexAsPower Property

CompileOptions.InterpretCircumflexAsPower Property
[image]

Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool InterpretCircumflexAsPower { get; set; }

Visual Basic [image] Copy Code

Public Property InterpretCircumflexAsPower As Boolean

Property Value

A boolean value. The default is false.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.InterpretExclamationAsReference Property

CompileOptions.InterpretExclamationAsReference Property
[image]

Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool InterpretExclamationAsReference { get; set; }

Visual Basic [image] Copy Code

Public Property InterpretExclamationAsReference As Boolean

Property Value

A bolean value. The default is false.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions.Normalize Property

CompileOptions.Normalize Property
[image]

Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public bool Normalize { get; set; }

Visual Basic [image] Copy Code

Public Property Normalize As Boolean

Property Value

A boolean value. The default is true.

See Also

CompileOptions Members
CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Arguments Property

EvaluateFunctionEventArgs.Arguments Property
[image]

Gets the list of the function's arguments.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object[] Arguments { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Arguments As Object()

Property Value

The list of arguments of the function; or an empty list if the function does not accept arguments.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Name Property

EvaluateFunctionEventArgs.Name Property
[image]

Gets the name of the function to evaluate.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string representing the function name, as it appears in the expression.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Param Property

EvaluateFunctionEventArgs.Param Property
[image]

Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Param { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Param As Object

Property Value

An object representing an user-defined parameter.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs.Result Property

EvaluateFunctionEventArgs.Result Property
[image]

Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As Object

Property Value

An object representing the function result.

Remarks

Functions always need to return values. If the event handler does not set Result, an exception will be thrown. null (Nothing in Visual Basic) is a valid return value.

See Also

EvaluateFunctionEventArgs Members
EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.CultureInfo Property

EvaluationContext.CultureInfo Property
[image]

Gets or sets the culture associated with the context.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public CultureInfo CultureInfo { get; set; }

Visual Basic [image] Copy Code

Public Property CultureInfo As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.DispatchFunctionParam Property

EvaluationContext.DispatchFunctionParam Property
[image]

Gets or sets a user-defined object passed to the DispatchFunctionCall event.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object DispatchFunctionParam { get; set; }

Visual Basic [image] Copy Code

Public Property DispatchFunctionParam As Object

Property Value

Any System.Object.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext.LocalVars Property

EvaluationContext.LocalVars Property
[image]

Gets a collection with defined variables and their values.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Dictionary<string, Object> LocalVars { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LocalVars As Dictionary(Of String, Object)

Property Value

A dictionary with variables and their values.

Remarks

After a byte code is evaluated within this context, LocalVars is updated with all variables declared in the code.

See Also

EvaluationContext Members
EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs.Result Property

ParseObjectEventArgs.Result Property
[image]

Gets or sets the parsed object.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public Object Result { get; set; }

Visual Basic [image] Copy Code

Public Property Result As Object

Property Value

A System.Object representing the parsed object.

See Also

ParseObjectEventArgs Members
ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs.ValueAsString Property

ParseObjectEventArgs.ValueAsString Property
[image]

Gets the string representation of the object to be parsed.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public string ValueAsString { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ValueAsString As String

Property Value

A string representing the object.

See Also

ParseObjectEventArgs Members
ParseObjectEventArgs Class
MindFusion.Scripting Namespace


PERMUT

PERMUT

Returns the number of permutations for the specified number of objects that can be selected from another specified number of objects.

Syntax [image] Copy Code

PERMUT( Integer n, Integer k ) → Integer

Parameters

n
Required. The total number of objects. Must be a positive number.
k
Required. The number of objects in each permutation. Must be a positive number.

Remarks

A permutation is any set or subset of objects or events where internal order is significant. Permutations are different from combinations, for which the internal order is not significant. The number of permutations is n!/(n-k)! where ! denotes factorial.

If n is less than k, or either n or k are negative or zero, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=PERMUT(50,5)

See Also

Function Reference
FACT Function
COMBIN Function


PI

PI

Returns the approximate value of π (pi).

Syntax [image] Copy Code

PI( ) → Number

Example

Formula [image] Copy Code

=PI()

See Also

Function Reference
COS Function
SIN Function
TAN Function


PMT

PMT

Calculates the payment for a loan based on the specified constant payments and the specified constant interest rate.

Syntax [image] Copy Code

PMT( Number rate, Number nper, Number pv, [Number fv = 0], [Number type = 0] ) → Number

Parameters

rate
Required. The interest rate per period.
nper
Required. The total number of payment periods.
pv
Required. The present value.
fv
Optional. The future value. If omitted, fv is assumed to be 0.
type
Optional. Indicates when payment is due. Less than 1 (or omitted) indicates at the end of the period, >= 1 indicates at the beginning of the period. If omitted, type is assumed to be 0.

Example

Formula [image] Copy Code

=PMT(4%/12,5*12,100000)

See Also

Function Reference
FV Function
NPER Function
PV Function
RATE Function


PRODUCT

PRODUCT

Returns the product of the specified arguments.

Syntax [image] Copy Code

PRODUCT( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more number to multiply.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain any numbers, the function returns 0.

Example

Formula [image] Copy Code

=PRODUCT(A1:A3,5)

See Also

Function Reference
SUM Function


PROPER

PROPER

Capitalizes the first letter in the specified text and any other letters that follow a character other than a letter. Converts all other letters to lowercase letters.

Syntax [image] Copy Code

PROPER( Text text ) → Text

Parameters

text
Required. The text to capitalize.

Example

Formula [image] Copy Code

=PROPER("this is a TEXT")

See Also

Function Reference
LOWER Function
UPPER Function


PV

PV

Returns the present value of an investment. The present value is the total amount that a series of future payments is worth now.

Syntax [image] Copy Code

PV( Number rate, Number nper, Number payment, [Number fv = 0], [Number type = 0] ) → Number

Parameters

rate
Required. The interest rate per period.
nper
Required. The total number of payment periods.
payment
Required. The payment made each period.
fv
Optional. The future value. If omitted, fv is assumed to be 0.
type
Optional. Indicates when payment is due. Less than 1 (or omitted) indicates at the end of the period, >= 1 indicates at the beginning of the period. If omitted, type is assumed to be 0.

Example

Formula [image] Copy Code

=PV(5%/12,10*12,250)

See Also

Function Reference
FV Function
NPER Function
PMT Function
RATE Function


QUOTIENT

QUOTIENT

Returns the integer portion of the division.

Syntax [image] Copy Code

QUOTIENT( Number numerator, Number denominator ) → Number

Parameters

numerator
Required. The divident.
denominator
Required. The divisor.

Remarks

If denominator is zero, the function returns the #DIV/0! error value.

Example

Formula [image] Copy Code

=QUOTIENT(5,2)

See Also

Function Reference
MOD Function


RADIANS

RADIANS

Converts the specified value from degrees to radians.

Syntax [image] Copy Code

RADIANS( Number angle ) → Number

Parameters

angle
Required. The angle to convert, in degrees.

Example

Formula [image] Copy Code

=RADIANS(180)

See Also

Function Reference
DEGREES Function
PI Function


RAND

RAND

Returns an evenly distributed random number in the interval [0…1).

Syntax [image] Copy Code

RAND( ) → Number

Remarks

The RAND function is reevaluated every time the sheet is calculated.

Example

Formula [image] Copy Code

=RAND()
=RAND()*(10-1)+10

See Also

Function Reference
RANDBETWEEN Function


RANDBETWEEN

RANDBETWEEN

Returns a random integer number in the specified range.

Syntax [image] Copy Code

RANDBETWEEN( Integer bottom, Integer top ) → Integer

Parameters

bottom
Required. The smallest value the function can return.
top
Required. The largest value the function can return.

Remarks

The function returns a random value in the interval [bottom…top]. If bottom is greater than top, RANDBETWEEN returns the #NUM! error value. If the specified arguments are not integer, they are automatically truncated.

Example

Formula [image] Copy Code

=RANDBETWEEN(1,100)
=RANDBETWEEN(-1,1)

See Also

Function Reference
RAND Function


RATE

RATE

Returns the interest rate per period of an annuity.

Syntax [image] Copy Code

RATE( Number nper, Number payment, Number pv, [Number fv = 0], [Number type = 0], [Number guess = 0.1] ) → Percentage

Parameters

nper
Required. The total number of payment periods.
payment
Required. The payment made each period.
pv
Required. The present value of the investment.
fv
Optional. The future value. If omitted, fv is assumed to be 0.
type
Optional. Indicates when payment is due. Less than 1 (or omitted) indicates at the end of the period, >= 1 indicates at the beginning of the period. If omitted, type is assumed to be 0.
guess
Optional. An estimate of the interest rate to start the iterative computation. If omitted, guess is assumed to be 0.1 (10%).

Example

Formula [image] Copy Code

=RATE(2*12,-250,4000)

See Also

Function Reference
FV Function
NPER Function
PMT Function
PV Function


RealTimeChart

RealTimeChart


REPT

REPT

Returns the specified text repeated the specified number of times.

Syntax [image] Copy Code

REPT( Text text, Integer count ) → Text

Parameters

text
Required. The text to repeat.
count
Required. The number of times to repeat the text. Must be a positive integer.

Remarks

If count is 0, the function returns an empty text. If count is less than 0, REPT returns the #VALUE! error value. If count is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=REPT("-",10)

See Also

Function Reference
LEFT Function
MID Function
RIGHT Function
SUBSTITUTE Function


ROMAN

ROMAN

Converts the specified Arabic numeral to its Roman equivalent.

Syntax [image] Copy Code

FUNC( Integer n ) → Text

Parameters

n
Required. The number to convert.

Remarks

If n is less than 0 or greater than or equal to 4000, the function returns the #NUM! error value. If n is 0, an empty string is returned.

The following table lists the values of the individual roman numerals. Roman numerals that precede (directly or indirectly) a larger-valued roman number subtract their value from the final value.

Roman numeral | Value
I | 1
V | 5
X | 10
L | 50
C | 100
D | 500
M | 1000

Example

Formula [image] Copy Code

=ROMAN(499)

See Also

Function Reference
ARABIC Function


ROW

ROW

Returns the row number or numbers of the specified cell reference.

Syntax [image] Copy Code

ROW( [Reference r] ) → IntegerOrArray

Parameters

r
Optional. The cell or range of cells for which to return the row number.

Remarks

This function returns the number of a cell row. For example, the function returns 1 for the first row, 2 for the second row, and so on.

If r is omitted, the function returns the row number of the current cell. If r identifies a range of cells with height greater than 1, ROW returns an array containing the numbers of all rows included in the range. For example, ROW(A1:C2) returns the array {1, 2, 3}.

Example

Formula [image] Copy Code

=ROW()
=ROW(A1:C2)

See Also

Function Reference
COLUMN Function
SHEET Function


ROWS

ROWS

Returns the number of rows in the specified range or array.

Syntax [image] Copy Code

ROWS( ReferenceOrArray r ) → Integer

Parameters

r
Required. A reference to a range of cells or an array for which to return the number of rows.

Example

Formula [image] Copy Code

=ROWS(A1:E4)
=ROWS({1;2;3|4;5;6})

See Also

Function Reference
COLUMNS Function


SEARCH

SEARCH

Returns the position at which the specified text is found in another specified text, starting at the specified position.

Syntax [image] Copy Code

SEARCH( Text search, Text text, [Integer start = 1] ) → Integer

Parameters

search
Required. The text to find.
text
Required. The text that contains the searched text.
start
Optional. The position inside text at which to start the search. If omitted, start is assumed to be 1.

Remarks

If search is an empty string, the function returns 1. If search does not appear within text, the function returns the #VALUE! error value. If start is less than or equal to zero, the function returns the #VALUE! error message.

The start parameter can be used to skip a specified number of characters. For example, to find the second appearance of the string contained in cell A1 within the string contained in B1, use the following formula: "=SEARCH(A1,B1,SEARCH(A1,B1)+1)".

Example

Formula [image] Copy Code

=SEARCH("brown",A1)

See Also

Function Reference
FIND Function
EXACT Function
MID Function
REPLACE Function
SUBSTITUTE Function


SHEET

SHEET

Returns the sheet number of the specified cell reference or sheet name.

Syntax [image] Copy Code

SHEET( [ReferenceOrText r] ) → Integer

Parameters

r
Required. The name of a sheet or a cell reference for which to returns the sheet number.

Remarks

If the value of the specified argument is not a valid cell reference or is a partial cell reference, the function returns the #REF! error value. If the argument is text and there is no sheet or named range with this name, the result is #N/A. If r is omitted, the function returns the sheet number of the current sheet.

Example

Formula [image] Copy Code

=SHEET()
=SHEET(Sheet1!A1)

See Also

Function Reference
COLUMN Function
ROW Function
SHEETS Function


SHEETS

SHEETS

Returns the number of sheets in the specified cell reference.

Syntax [image] Copy Code

FUNC( [Reference r] ) → Integer

Parameters

r
Optional. A reference to a range of cells for which to return the number of sheets.

Remarks

If the value of the specified argument is not a valid cell reference, the function returns the #REF! error value. If r is omitted, the function returns the number of sheets in the current workbook.

Example

Formula [image] Copy Code

=SHEETS()
=SHEETS(MySheet!A1:C5)

See Also

Function Reference
COLUMNS Function
ROWS Function
SHEET Function


SIGN

SIGN

Returns the sign of the specified number.

Syntax [image] Copy Code

SIGN( Number n ) → Number

Parameters

n
Required. The number to test.

Remarks

The function returns -1 if n is negative, +1, if n is positive, and 0 if n is zero.

Example

Formula [image] Copy Code

=SIGN(10)
=SIGN(A1-B1)

See Also

Function Reference
ABS Function


SLN

SLN

Returns the straight-line depreciation of an asset for one period.

Syntax [image] Copy Code

SLN( Number cost, Number salvage, Number life ) → Currency

Parameters

cost
Required. The initial cost of the asset.
salvage
Required. The value at the end of the depreciation, also known as the salvage value.
life
Required. The number of periods over which the asset is depreciated.

Example

Formula [image] Copy Code

=SLN(10000,4000,10)

See Also

Function Reference
DDB Function
SYD Function


STANDARDIZE

STANDARDIZE

Returns the normalized value from a distribution characterized by the specified arguments.

Syntax [image] Copy Code

STANDARDIZE( Number n, Number mean, Number sigma ) → Number

Parameters

n
Required. The value to normalize.
mean
Required. The arithmetic mean of the distribution.
sigma
Required. The standard deviation of the distribution. Must be a non-negative value.

Remarks

The equation of the normalized value is (n - mean) / sigma. If sigma is negative, the function returns the #NUM! error value.

Example

Formula [image] Copy Code

=STANDARDIZE(42,40,1.5)

See Also

Function Reference


STDEV

STDEV

Estimates standard deviation based on the specified set of numbers.

Syntax [image] Copy Code

STDEV( Number n1, Number n2, ... ) → Number

Parameters

n1
n2
…
Two or more numbers representing the sample.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain at least two numbers, the function returns #N/A.

Example

Formula [image] Copy Code

=STDEV({1245;1201;1268;1222;1211})

See Also

Function Reference
STDEVP Function
AVERAGE Function


STDEVP

STDEVP

Calculates standard deviation based on the entire population given as arguments.

Syntax [image] Copy Code

STDEVP( Number n1, [Number n2], ... ) → Number

Parameters

n1
n2
…
One or more numbers representing the sample.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain at least one number, the function returns #N/A.

Example

Formula [image] Copy Code

=STDEVP({1245;1201;1268;1222;1211})

See Also

Function Reference
STDEV Function
AVERAGE Function


SUBSTITUTE

SUBSTITUTE

Returns a modification of the specified text where all occurrences of a text are replaced with another text.

Syntax [image] Copy Code

SUBSTITUTE( Text text, Text old, Text new, [Integer which] ) → Text

Parameters

text
Required. The input text.
old
Required. The text to replace.
new
Required. The text to replace with.
which
Optional. Specifies (if not omitted) which occurrence to replace.

Remarks

If which is omitted every occurrence of old is substituted. If which is less than or equal to 0, the function returns the #VALUE! error value. If which is not integer, it is automatically truncated.

If there is no match, or if old has zero length, the value of text is returned unchanged.

Example

Formula [image] Copy Code

=SUBSTITUTE(A2,"Sales","Cost")

See Also

Function Reference
LEFT Function
LEN Function
MID Function
REPLACE Function
RIGHT Function


SUBTOTAL

SUBTOTAL

Returns the subtotal of the specified arguments.

Syntax [image] Copy Code

SUBTOTAL( Integer function, Number n1, Number n2, ... ) -> Number

Parameters

function
Required. A number specifying the subtotal function to apply.
n1
n2
…
One or more numbers to subtotal.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain any numbers, the function returns 0.

The following table illustrates the possible values of function and their meaning.

Function | Exclude hidden by filter | Exclude hidden by filter or collapsed
AVERAGE | 1 | 101
COUNT | 2 | 102
COUNTA | 3 | 103
MAX | 4 | 104
MIN | 5 | 105
PRODUCT | 6 | 106
STDEV | 7 | 107
STDEVP | 8 | 108
SUM | 9 | 109
VAR | 10 | 110
VARP | 11 | 111

Example

Formula [image] Copy Code

=SUBTOTAL(9,A1:A5)

See Also

Function Reference
SUM Function
AVERAGE Function


SYD

SYD

Returns the sum-of-years'-digits depreciation of an asset for the specified period.

Syntax [image] Copy Code

SYD( Number cost, Number salvage, Number life, Number period ) → Currency

Parameters

cost
Required. The initial cost of the asset.
salvage
Required. The value at the end of the depreciation (also known as the salvage value).
life
Required. The number of periods over which the asset is being depreciated.
period
Required. The period; it must use the same units as life.

Remarks

SYD is calculated as follows: SYD = (cost - salvage) * (life - per + 1) * 2 / (life * (life + 1)).

If life is zero, the function returns the #DIV/0! error value. If life is less than zero or period is greater than life, the return is #NUM!.

Example

Formula [image] Copy Code

=SYD(10000,1500,10,1)

See Also

Function Reference
DDB Function
SLN Function


T

T

Returns the text of the specified value.

Syntax [image] Copy Code

T( Any value ) → Text

Parameters

value
Required. The value to test.

Remarks

If value is or refers to text, T returns value. Otherwise, the function returns an empty text. Note, that this is not a type conversion, that is T(5) will produce an empty text, rather than "5".

Example

Formula [image] Copy Code

=T("test")
=T(123)

See Also

Function Reference
N Function
VALUE Function


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions Class

BarcodeNodeExtensions Class
[image]

Provides extension methods for BarcodeNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class BarcodeNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class BarcodeNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions

See Also

BarcodeNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions Members

BarcodeNodeExtensions Members
Methods
[image]

Provides extension methods for BarcodeNode fluent API.

The following tables list the members exposed by the BarcodeNodeExtensions type.

Public Methods

Name | Description
BarColor | Sets the color of barcode modules.
Content | Sets the text or numeric code that should be represented as barcode symbol.
Format | Sets the barcode format.
QRCorrectionLevel | Sets the correction level of QR barcodes.

See Also

BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.BarcodeNodeExtensions Methods

BarcodeNodeExtensions Methods
[image]

Public Methods

Name | Description
BarColor | Sets the color of barcode modules.
Content | Sets the text or numeric code that should be represented as barcode symbol.
Format | Sets the barcode format.
QRCorrectionLevel | Sets the correction level of QR barcodes.

See Also

BarcodeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions Class

ContainerNodeExtensions Class
[image]

Provides extension methods for ContainerNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class ContainerNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class ContainerNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions

See Also

ContainerNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions Members

ContainerNodeExtensions Members
Methods
[image]

Provides extension methods for ContainerNode fluent API.

The following tables list the members exposed by the ContainerNodeExtensions type.

Public Methods

Name | Description
AllowAddChildren | Sets a value indicating whether child nodes can be added interactively to this container.
AllowRemoveChildren | Sets a value indicating whether child nodes can be removed interactively from this container.
AutoShrink | Sets a value indicating whether the container should shrink in size when nodes are removed from it.
Caption | Sets the container caption text.
CaptionBackBrush | Overloaded.
CaptionBrush | Overloaded.
CaptionFormat | Sets the caption alignment and format.
CaptionHeight | Sets the height of the container's caption area.
CornerRadius | Sets the radius of node's corners when Shape is set to RoundedRectangle.
Foldable | Sets a value indicating whether the user is allowed to fold this container.
Folded | Sets a value indicating whether this container is folded.
HighlightPen | Sets the Pen used to draw the container frame lines when an item is dragged over the container.
Margin | Sets how much space should be left between contained nodes and the container borders.
MinimumSize | Sets the minimum size of the container.
Shape | Sets the shape of the container's outline.

See Also

ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ContainerNodeExtensions Methods

ContainerNodeExtensions Methods
[image]

Public Methods

Name | Description
AllowAddChildren | Sets a value indicating whether child nodes can be added interactively to this container.
AllowRemoveChildren | Sets a value indicating whether child nodes can be removed interactively from this container.
AutoShrink | Sets a value indicating whether the container should shrink in size when nodes are removed from it.
Caption | Sets the container caption text.
CaptionBackBrush | Overloaded.
CaptionBrush | Overloaded.
CaptionFormat | Sets the caption alignment and format.
CaptionHeight | Sets the height of the container's caption area.
CornerRadius | Sets the radius of node's corners when Shape is set to RoundedRectangle.
Foldable | Sets a value indicating whether the user is allowed to fold this container.
Folded | Sets a value indicating whether this container is folded.
HighlightPen | Sets the Pen used to draw the container frame lines when an item is dragged over the container.
Margin | Sets how much space should be left between contained nodes and the container borders.
MinimumSize | Sets the minimum size of the container.
Shape | Sets the shape of the container's outline.

See Also

ContainerNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions Class

DiagramExtensions Class
[image]

Provides extension methods for Diagram fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class DiagramExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions

See Also

DiagramExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions Members

DiagramExtensions Members
Methods
[image]

Provides extension methods for Diagram fluent API.

The following tables list the members exposed by the DiagramExtensions type.

Public Methods

Name | Description
ActiveItem | Sets the active diagram element.
ActiveLayer | Sets the zero-based index of the active layer.
AdapterHandlesStyle | Sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.
AdjustmentHandlesSize | Sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Sets the pen used to draw alignment guides.
AlignToGrid | Sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Sets the mouse cursor shown to the user when an arrow can be created.
AllowLinksRepeat | Sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoCloseDistance | Sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Sets the default value for the SnapToNodeBorder property of new links.
BackBrush | Overloaded.
BackgroundImage | Sets the image displayed as background of this diagram.
BackgroundImageAlign | Sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BarcodeNodeStyle | Sets the theme-level style for barcode nodes.
Behavior | Sets a value indicating how the control responds to user actions.
Bounds | Sets a value representing the size of the diagram's scrollable area.
CellCustomDraw | Sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Sets the default cell border style of new tables.
ContainerCaption | Sets the default value for the Caption property of containers.
ContainerCaptionHeight | Sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Sets the default value for the HighlightPen property of containers.
ContainerMargin | Sets the default value for the Margin property of containers.
ContainerMinimumSize | Sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Sets the theme-level style for container nodes.
ContainersFoldable | Sets the default value for the Foldable property of containers.
ControlMouseAction | Sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.
CounterDiagonalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CrossingRadius | Sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Sets a custom Behavior object specifying how Diagram.NET responds to mouse input.
CustomLinkType | Sets the type of a MindFusion.Diagramming.Wpf.DiagramLink derived class whose instance should be created when a user starts drawing.
CustomNodeType | Sets the type of a MindFusion.Diagramming.Wpf.DiagramNode derived class whose instance should be created when a user starts drawing.
DefaultControlType | Sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.
DefaultEffect | Sets the default value for UIElement.Effect property of new items.
DefaultShape | Sets the default shape of shape nodes.
DelKeyAction | Sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
DiagramLinkStyle | Sets the theme-level style for diagram links.
Dirty | Sets a value indicating whether the diagram has changed since the last save.
DisallowCursor | Sets the mouse cursor shown to the user when an object cannot be created at a given location.
DisallowLinkCursor | Sets the mouse cursor shown to the user when an arrow is being created but cannot be ended at the current location.
DrawLinkCursor | Sets the mouse cursor shown to the user when an arrow can be started at the current position.
DynamicLinks | Sets the default value for the Dynamic property of new links.
EnableLanes | Sets whether lanes are enabled.
EnableStyledText | Sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.
ExpandButtonPosition | Sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Sets a value, indicating in which direction object hierarchies are expanded.
Font | Sets the default font for new diagram items.
FreeFormAttractDistance | Sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridOffsetX | Sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Sets the vertical offset of the first point of the alignment grid.
GridPen | Sets the Pen/Brush of the grid lines/points.
GridSizeX | Sets the horizontal distance between adjacent grid points.
GridSizeY | Sets the vertical distance between adjacent grid points.
GridStyle | Sets the visual style of the alignment grid.
HitTestPriority | Sets a value indicating the order in which items are hit-tested.
HorizontalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object horizontally.
InplaceEditAcceptOnEnter | Sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.
InplaceEditCancelOnEsc | Sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
InplaceEditFont | Sets the font of the inplace-edit text box.
LinkBaseShape | Sets the shape displayed at the base of new links.
LinkBaseShapeSize | Sets the default size of the base of new links.
LinkBrush | Overloaded.
LinkCascadeOrientation | Sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Sets the default type of custom painting done on links.
LinkEndsMovable | Sets a value indicating whether arrow ends can be moved by users after the link is created.
LinkHandlesStyle | Sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Sets the shape displayed as head of new links.
LinkHeadShapeSize | Sets the default size of arrowheads.
LinkHitDistance | Sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Sets the default size of the shapes at middles of link segments.
LinkPen | Sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
LinkSegments | Sets the default number of link segments.
LinkShape | Sets the default shape of diagram links.
LinksRetainForm | Sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Sets the default text of links.
LinkTextStyle | Sets default placement and orientation for links' text.
MagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Sets the zoom factor of the magnifier tool.
MagnifierHeight | Sets the height of the magnifier tool.
MagnifierStyle | Sets the style of the magnifier tool.
MagnifierWidth | Sets the width of the magnifier tool.
MeasureUnit | Sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MiddleButtonActions | Sets a combination of flags that specify what actions can be performed via the middle mouse button.
MinimumNodeSize | Sets the minimum node size that the user is allowed to set.
ModificationEffect | Sets the visual effect to apply during interactive modification of items.
ModificationStart | Sets how users can start modifying diagram items.
MoveCursor | Sets the mouse cursor shown to the user if the pointed object can be modified.
NodesExpandable | Sets a value indicating whether newly created nodes can be expanded.
NodeTemplate | Sets the default DataTemplate used to display TemplatedNodes.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PanCursor | Sets the mouse cursor displayed while panning the diagram view.
PanInertia | Sets a value indicating whether panning the view will have inertia.
PointerCursor | Sets the mouse cursor shown to the user when no modification is performed.
PolygonalTextLayout | Sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Sets value indicating how a tree is expanded.
RemoveHiddenItemsFromVisualTree | For internal use.
RestrictItemsToBounds | Sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RightButtonActions | Sets a combination of flags that specify what actions can be performed via the right mouse button.
RotateCursor | Sets the cursor shown when the mouse is over a node rotation handle.
RotationStep | Sets the RotationAngle increment when users rotate a node.
RoundedLinks | Sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RowHighlightBrush | Overloaded.
ScrollX | Sets the document's X scroll position.
ScrollY | Sets the document's Y scroll position.
ScrollZoneSize | Sets the size of the auto scroll zone near the edges of the control.
SelectAfterCreate | Sets a value indicating whether newly created objects are automatically selected.
SelectionOnTop | Sets a value indicating whether selected items should be painted on top of other items.
ShapeBrush | Overloaded.
ShapeCustomDraw | Sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Sets the theme-level style for shape nodes.
ShapeOrientation | Sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Sets the default value for the Pen property of shape nodes.
ShapeText | Sets the default text of shape nodes.
ShowAnchors | Sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Sets when arrow end points should be aligned to the nearest anchor points.
SortGroupsByZ | Sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Overloaded.
TableCaption | Sets the default text for tables' captions.
TableCaptionHeight | Sets the default height of table captions.
TableColumnCount | Sets the default number of table columns.
TableColumnWidth | Sets the default width of tables' columns.
TableConnectionStyle | Sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.
TableCustomDraw | Sets the default type of custom painting done on tables.
TableHandlesStyle | Sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Sets the theme-level style for table nodes.
TablePen | Sets the default value for the Pen property of tables.
TableRowCount | Sets the default number of table rows.
TableRowHeight | Sets the default height of tables' rows.
TableShape | Sets the default shape of new tables.
TablesScrollable | Sets the default value for the Scrollable property of new tables.
Tag | Sets custom data associated with this diagram.
TextBrush | Overloaded.
TextFormat | Sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Sets the theme associated with the diagram.
ToolTip | Sets a short text message displayed when the mouse pointer rests over the diagram.
TreeViewNodeStyle | Sets the theme-level style for treeview nodes.
ValidityChecks | Sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VerticalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object vertically.
ZoomFactor | Sets the zoom factor used to scale up or down the Diagram.

See Also

DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramExtensions Methods

DiagramExtensions Methods
[image]

Public Methods

Name | Description
ActiveItem | Sets the active diagram element.
ActiveLayer | Sets the zero-based index of the active layer.
AdapterHandlesStyle | Sets the default value for the HandlesStyle property of new DiagramNodeAdapter nodes.
AdjustmentHandlesSize | Sets the size of the handles, which appear around selected objects.
AlignmentGuidePen | Sets the pen used to draw alignment guides.
AlignToGrid | Sets a value indicating whether the diagram items should be aligned to a grid.
AllowInplaceEdit | Sets a value indicating whether in-place editing of the text of objects is enabled.
AllowLinkCursor | Sets the mouse cursor shown to the user when an arrow can be created.
AllowLinksRepeat | Sets a value indicating whether more than one link can connect the same origin and destination diagram nodes.
AllowMultipleResize | Specifies whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Sets a value indicating whether self-loops are allowed.
AllowSplitLinks | Sets a value indicating whether link segments can be added and removed interactively.
AllowUnanchoredLinks | Sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Sets the maximal horizontal or vertical distance at which a node aligns to the borders ot other nodes.
AutoAlignNodes | Sets whether nodes should automatically align to the borders ot other nodes during user interaction.
AutoCloseDistance | Sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoScroll | Sets a value indicating whether auto scrolling of the document area is enabled.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Sets the default value for the SnapToNodeBorder property of new links.
BackBrush | Overloaded.
BackgroundImage | Sets the image displayed as background of this diagram.
BackgroundImageAlign | Sets a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
BarcodeNodeStyle | Sets the theme-level style for barcode nodes.
Behavior | Sets a value indicating how the control responds to user actions.
Bounds | Sets a value representing the size of the diagram's scrollable area.
CellCustomDraw | Sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Sets the default cell border style of new tables.
ContainerCaption | Sets the default value for the Caption property of containers.
ContainerCaptionHeight | Sets the default value for the CaptionHeight property of containers.
ContainerHighlightPen | Sets the default value for the HighlightPen property of containers.
ContainerMargin | Sets the default value for the Margin property of containers.
ContainerMinimumSize | Sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Sets the theme-level style for container nodes.
ContainersFoldable | Sets the default value for the Foldable property of containers.
ControlMouseAction | Sets the ways mouse clicks are handled by default in the controls hosted in ControlHost objects.
CounterDiagonalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
CrossingRadius | Sets the radius length of decorations displayed at link intersection points.
CustomBehavior | Sets a custom Behavior object specifying how Diagram.NET responds to mouse input.
CustomLinkType | Sets the type of a MindFusion.Diagramming.Wpf.DiagramLink derived class whose instance should be created when a user starts drawing.
CustomNodeType | Sets the type of a MindFusion.Diagramming.Wpf.DiagramNode derived class whose instance should be created when a user starts drawing.
DefaultControlType | Sets the type of the controls that will be hosted by default in newly created DiagramNodeAdapter objects.
DefaultEffect | Sets the default value for UIElement.Effect property of new items.
DefaultShape | Sets the default shape of shape nodes.
DelKeyAction | Sets a value that specifies what action should be performed when the user hits the Del key.
DiagonalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object both vertically and horizontally.
DiagramLinkStyle | Sets the theme-level style for diagram links.
Dirty | Sets a value indicating whether the diagram has changed since the last save.
DisallowCursor | Sets the mouse cursor shown to the user when an object cannot be created at a given location.
DisallowLinkCursor | Sets the mouse cursor shown to the user when an arrow is being created but cannot be ended at the current location.
DrawLinkCursor | Sets the mouse cursor shown to the user when an arrow can be started at the current position.
DynamicLinks | Sets the default value for the Dynamic property of new links.
EnableLanes | Sets whether lanes are enabled.
EnableStyledText | Sets the default value for the EnableStyledText property of new nodes.
ExpandButtonAction | Sets a value indicating what should happen when a user clicks the [+/-] button that is displayed near expandable nodes.
ExpandButtonPosition | Sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Sets a value, indicating in which direction object hierarchies are expanded.
Font | Sets the default font for new diagram items.
FreeFormAttractDistance | Sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridOffsetX | Sets the horizontal offset of the first point of the alignment grid.
GridOffsetY | Sets the vertical offset of the first point of the alignment grid.
GridPen | Sets the Pen/Brush of the grid lines/points.
GridSizeX | Sets the horizontal distance between adjacent grid points.
GridSizeY | Sets the vertical distance between adjacent grid points.
GridStyle | Sets the visual style of the alignment grid.
HitTestPriority | Sets a value indicating the order in which items are hit-tested.
HorizontalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object horizontally.
InplaceEditAcceptOnEnter | Sets a value indicating whether pressing the ENTER key should exit inplace-edit mode and accept changes made to text.
InplaceEditCancelOnEsc | Sets a value indicating whether pressing the ESC key should exit inplace-edit mode and reject changes made to text.
InplaceEditFont | Sets the font of the inplace-edit text box.
LinkBaseShape | Sets the shape displayed at the base of new links.
LinkBaseShapeSize | Sets the default size of the base of new links.
LinkBrush | Overloaded.
LinkCascadeOrientation | Sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Sets the default type of custom painting done on links.
LinkEndsMovable | Sets a value indicating whether arrow ends can be moved by users after the link is created.
LinkHandlesStyle | Sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Sets the shape displayed as head of new links.
LinkHeadShapeSize | Sets the default size of arrowheads.
LinkHitDistance | Sets a value specifying how far from a link a click is still considered a hit.
LinkIntermediateShape | Sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Sets the default size of the shapes at middles of link segments.
LinkPen | Sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
LinkSegments | Sets the default number of link segments.
LinkShape | Sets the default shape of diagram links.
LinksRetainForm | Sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Sets the default text of links.
LinkTextStyle | Sets default placement and orientation for links' text.
MagnifierEnabled | Sets a value indicating whether the magnifier tool is currently enabled.
MagnifierFactor | Sets the zoom factor of the magnifier tool.
MagnifierHeight | Sets the height of the magnifier tool.
MagnifierStyle | Sets the style of the magnifier tool.
MagnifierWidth | Sets the width of the magnifier tool.
MeasureUnit | Sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Sets the maximum distance between adjacent control points of a link at which the respective segments can be merged.
MiddleButtonActions | Sets a combination of flags that specify what actions can be performed via the middle mouse button.
MinimumNodeSize | Sets the minimum node size that the user is allowed to set.
ModificationEffect | Sets the visual effect to apply during interactive modification of items.
ModificationStart | Sets how users can start modifying diagram items.
MoveCursor | Sets the mouse cursor shown to the user if the pointed object can be modified.
NodesExpandable | Sets a value indicating whether newly created nodes can be expanded.
NodeTemplate | Sets the default DataTemplate used to display TemplatedNodes.
OverrideCursor | Sets the cursor and stops changing it depending on the context.
PanCursor | Sets the mouse cursor displayed while panning the diagram view.
PanInertia | Sets a value indicating whether panning the view will have inertia.
PointerCursor | Sets the mouse cursor shown to the user when no modification is performed.
PolygonalTextLayout | Sets a value indicating whether to enable the formatting of text inside non-rectangular shape node outlines.
RecursiveExpand | Sets value indicating how a tree is expanded.
RemoveHiddenItemsFromVisualTree | For internal use.
RestrictItemsToBounds | Sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RightButtonActions | Sets a combination of flags that specify what actions can be performed via the right mouse button.
RotateCursor | Sets the cursor shown when the mouse is over a node rotation handle.
RotationStep | Sets the RotationAngle increment when users rotate a node.
RoundedLinks | Sets a value indicating whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Sets a value indicating whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RowHighlightBrush | Overloaded.
ScrollX | Sets the document's X scroll position.
ScrollY | Sets the document's Y scroll position.
ScrollZoneSize | Sets the size of the auto scroll zone near the edges of the control.
SelectAfterCreate | Sets a value indicating whether newly created objects are automatically selected.
SelectionOnTop | Sets a value indicating whether selected items should be painted on top of other items.
ShapeBrush | Overloaded.
ShapeCustomDraw | Sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Sets the theme-level style for shape nodes.
ShapeOrientation | Sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Sets the default value for the Pen property of shape nodes.
ShapeText | Sets the default text of shape nodes.
ShowAnchors | Sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Sets a value indicating whether to display selection handles of objects under the mouse while another object is being modified.
SnapToAnchor | Sets when arrow end points should be aligned to the nearest anchor points.
SortGroupsByZ | Sets a value indicating whether grouped items should be drawn sorted by their z-order while the whole group is being moved.
TableBrush | Overloaded.
TableCaption | Sets the default text for tables' captions.
TableCaptionHeight | Sets the default height of table captions.
TableColumnCount | Sets the default number of table columns.
TableColumnWidth | Sets the default width of tables' columns.
TableConnectionStyle | Sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.
TableCustomDraw | Sets the default type of custom painting done on tables.
TableHandlesStyle | Sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Sets the theme-level style for table nodes.
TablePen | Sets the default value for the Pen property of tables.
TableRowCount | Sets the default number of table rows.
TableRowHeight | Sets the default height of tables' rows.
TableShape | Sets the default shape of new tables.
TablesScrollable | Sets the default value for the Scrollable property of new tables.
Tag | Sets custom data associated with this diagram.
TextBrush | Overloaded.
TextFormat | Sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Sets the theme associated with the diagram.
ToolTip | Sets a short text message displayed when the mouse pointer rests over the diagram.
TreeViewNodeStyle | Sets the theme-level style for treeview nodes.
ValidityChecks | Sets a value indicating whether validity checks are performed each time an item is added to the diagram.
VerticalResizeCursor | Sets the mouse cursor shown to the user if dragging would resize an object vertically.
ZoomFactor | Sets the zoom factor used to scale up or down the Diagram.

See Also

DiagramExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions Class

DiagramItemExtensions Class
[image]

Provides extension methods for DiagramItem fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class DiagramItemExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramItemExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions

See Also

DiagramItemExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions Members

DiagramItemExtensions Members
Methods
[image]

Provides extension methods for DiagramItem fluent API.

The following tables list the members exposed by the DiagramItemExtensions type.

Public Methods

Name | Description
Brush | Overloaded.
Font | Overloaded.
FontFamily | Sets the preferred font family for this DiagramItem.
FontSize | Sets the font size for this DiagramItem.
FontStretch | Sets the font-stretching characteristics for this DiagramItem.
FontStyle | Sets the font style for this DiagramItem.
FontWeight | Sets the font weight for this DiagramItem.
HyperLink | Sets the hyperlink associated with this diagram item.
Id | Sets user-defined identifier associated with this item.
IgnoreLayout | Sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
Locked | Sets a value indicating whether users are allowed to edit the diagram item.
Pen | Sets the pen used to paint the frame of the item.
Printable | Sets a value indicating whether to print the item.
Selected | Sets a value indicating whether a diagram item is selected.
Stroke | Overloaded.
StrokeDashCap | Sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashStyle | Sets the pattern of dashes and gaps used to outline items.
StrokeEndLineCap | Sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.
StrokeStartLineCap | Sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Sets the width of the DiagramItem stroke outline.
Tag | Sets user-defined data associated with this item.
Text | Sets the text displayed inside this item.
TextAlignment | Sets a value that indicates the horizontal alignment of text content.
TextBrush | Overloaded.
TextDecorations | Sets the effects to apply to the text of this DiagramItem.
TextPadding | Sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Sets a value that indicates the vertical alignment of text content.
TextWrapping | Sets how this DiagramItem should wrap text.
ToolTip | Sets a short text message displayed when the mouse pointer rests over a diagram element.
Visible | Sets a value indicating whether this item is visible.
Weight | Sets a weight value used in layout and path-finding algorithms.
ZIndex | Sets the z-order position of the object.

See Also

DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramItemExtensions Methods

DiagramItemExtensions Methods
[image]

Public Methods

Name | Description
Brush | Overloaded.
Font | Overloaded.
FontFamily | Sets the preferred font family for this DiagramItem.
FontSize | Sets the font size for this DiagramItem.
FontStretch | Sets the font-stretching characteristics for this DiagramItem.
FontStyle | Sets the font style for this DiagramItem.
FontWeight | Sets the font weight for this DiagramItem.
HyperLink | Sets the hyperlink associated with this diagram item.
Id | Sets user-defined identifier associated with this item.
IgnoreLayout | Sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
Locked | Sets a value indicating whether users are allowed to edit the diagram item.
Pen | Sets the pen used to paint the frame of the item.
Printable | Sets a value indicating whether to print the item.
Selected | Sets a value indicating whether a diagram item is selected.
Stroke | Overloaded.
StrokeDashCap | Sets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashStyle | Sets the pattern of dashes and gaps used to outline items.
StrokeEndLineCap | Sets a PenLineCap enumeration value that specifies what shape to draw at the end of a Stroke.
StrokeLineJoin | Sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of the item's outline.
StrokeMiterLimit | Sets a limit on the ratio of the miter length to half the StrokeThickness of an item outline element.
StrokeStartLineCap | Sets a PenLineCap enumeration value that specifies what shape to draw at the start of a Stroke.
StrokeThickness | Sets the width of the DiagramItem stroke outline.
Tag | Sets user-defined data associated with this item.
Text | Sets the text displayed inside this item.
TextAlignment | Sets a value that indicates the horizontal alignment of text content.
TextBrush | Overloaded.
TextDecorations | Sets the effects to apply to the text of this DiagramItem.
TextPadding | Sets the thickness of padding space between the item boundaries and its text.
TextTrimming | Sets the text trimming to employ when text overflows the item area.
TextVerticalAlignment | Sets a value that indicates the vertical alignment of text content.
TextWrapping | Sets how this DiagramItem should wrap text.
ToolTip | Sets a short text message displayed when the mouse pointer rests over a diagram element.
Visible | Sets a value indicating whether this item is visible.
Weight | Sets a weight value used in layout and path-finding algorithms.
ZIndex | Sets the z-order position of the object.

See Also

DiagramItemExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions Class

DiagramLinkExtensions Class
[image]

Provides extension methods for DiagramLink fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class DiagramLinkExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramLinkExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions

See Also

DiagramLinkExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions Members

DiagramLinkExtensions Members
Methods
[image]

Provides extension methods for DiagramLink fluent API.

The following tables list the members exposed by the DiagramLinkExtensions type.

Public Methods

Name | Description
AllowMoveEnd | Sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Sets a value indicating whether the link end points should automatically align to node borders while a user moves them.
BaseShape | Sets what shape to display at the beginning of a link.
BaseShapeSize | Sets the size of the BaseShape shape.
CascadeOrientation | Sets the orientation of the first segment of a cascading link.
CustomDraw | Sets the type of custom drawing performed on this link.
Destination | Sets the destination node of this link.
DestinationAnchor | Sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Sets the index of link's destination anchor point or table row.
DrawCrossings | Sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Sets the last control point of a link.
HandlesStyle | Sets the appearance of the link's selection handles.
HeadPen | Sets the pen to use when painting arrowheads lines.
HeadShape | Sets the shape of this link's arrowhead.
HeadShapeSize | Sets the size of the arrowhead shape.
HeadStroke | Overloaded.
HeadStrokeDashStyle | Sets the pattern of dashes and gaps used to outline arrowhead shapes.
HeadStrokeThickness | Sets the width of the arrowhead stroke outline.
IntermediateShape | Sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Sets the size of the IntermediateShape shape.
Origin | Sets the origin node of the link.
OriginAnchor | Sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Sets the index of link's origin anchor point or table row.
RetainForm | Sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
SegmentCount | Sets the number of segments of this link.
Shape | Sets the type of link segments and how they are positioned relatively to each other.
StartPoint | Sets the first control point of a link.
TextStyle | Sets the link's text placement and orientation.

See Also

DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramLinkExtensions Methods

DiagramLinkExtensions Methods
[image]

Public Methods

Name | Description
AllowMoveEnd | Sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Sets a value indicating whether the user is allowed to move the first control point of a link.
AutoRoute | Sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Sets a value indicating whether the link end points should automatically align to node borders while a user moves them.
BaseShape | Sets what shape to display at the beginning of a link.
BaseShapeSize | Sets the size of the BaseShape shape.
CascadeOrientation | Sets the orientation of the first segment of a cascading link.
CustomDraw | Sets the type of custom drawing performed on this link.
Destination | Sets the destination node of this link.
DestinationAnchor | Sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Sets the index of link's destination anchor point or table row.
DrawCrossings | Sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EndPoint | Sets the last control point of a link.
HandlesStyle | Sets the appearance of the link's selection handles.
HeadPen | Sets the pen to use when painting arrowheads lines.
HeadShape | Sets the shape of this link's arrowhead.
HeadShapeSize | Sets the size of the arrowhead shape.
HeadStroke | Overloaded.
HeadStrokeDashStyle | Sets the pattern of dashes and gaps used to outline arrowhead shapes.
HeadStrokeThickness | Sets the width of the arrowhead stroke outline.
IntermediateShape | Sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Sets the size of the IntermediateShape shape.
Origin | Sets the origin node of the link.
OriginAnchor | Sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Sets the index of link's origin anchor point or table row.
RetainForm | Sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
SegmentCount | Sets the number of segments of this link.
Shape | Sets the type of link segments and how they are positioned relatively to each other.
StartPoint | Sets the first control point of a link.
TextStyle | Sets the link's text placement and orientation.

See Also

DiagramLinkExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions Class

DiagramNodeExtensions Class
[image]

Provides extension methods for DiagramNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class DiagramNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions

See Also

DiagramNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions Members

DiagramNodeExtensions Members
Methods
[image]

Provides extension methods for DiagramNode fluent API.

The following tables list the members exposed by the DiagramNodeExtensions type.

Public Methods

Name | Description
AllowIncomingLinks | Sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Sets the anchor points to which links are attached when connected to the node.
Bounds | Sets the rectangle that defines the position of the diagram node.
Constraints | Allows applying constraints to the location and size of the node.
EnabledHandles | Sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Sets a value indicating whether the subtree starting from this node is expanded.
GridAlignPoint | Sets the node's point that should align to a grid point when the node is moved.
HandlesStyle | Sets a value indicating how the node adjustment handles behave and what do they look like.
Obstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
RotationAngle | Sets the rotation angle of this node.
Template | Sets the DataTemplate used to display this node.

See Also

DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.DiagramNodeExtensions Methods

DiagramNodeExtensions Methods
[image]

Public Methods

Name | Description
AllowIncomingLinks | Sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Sets the anchor points to which links are attached when connected to the node.
Bounds | Sets the rectangle that defines the position of the diagram node.
Constraints | Allows applying constraints to the location and size of the node.
EnabledHandles | Sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Sets a value indicating whether the subtree starting from this node is expanded.
GridAlignPoint | Sets the node's point that should align to a grid point when the node is moved.
HandlesStyle | Sets a value indicating how the node adjustment handles behave and what do they look like.
Obstacle | Sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
RotationAngle | Sets the rotation angle of this node.
Template | Sets the DataTemplate used to display this node.

See Also

DiagramNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions Class

FreeFormNodeExtensions Class
[image]

Provides extension methods for FreeFormNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class FreeFormNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class FreeFormNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions

See Also

FreeFormNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions Members

FreeFormNodeExtensions Members
Methods
[image]

Provides extension methods for FreeFormNode fluent API.

The following tables list the members exposed by the FreeFormNodeExtensions type.

Public Methods

Name | Description
Closed | Sets if the node's shape is closed.
Points | Sets the node's outline points.

See Also

FreeFormNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.FreeFormNodeExtensions Methods

FreeFormNodeExtensions Methods
[image]

Public Methods

Name | Description
Closed | Sets if the node's shape is closed.
Points | Sets the node's outline points.

See Also

FreeFormNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions Class

SelectionExtensions Class
[image]

Provides extension methods for Selection fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class SelectionExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class SelectionExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions

See Also

SelectionExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions Members

SelectionExtensions Members
Methods
[image]

Provides extension methods for Selection fluent API.

The following tables list the members exposed by the SelectionExtensions type.

Public Methods

Name | Description
AllowMultipleSelection | Sets a value indicating whether more than one items can be selected simultaneously.
ExtendMode | Sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.
FreeFormMode | Sets a value indicating whether selection lasso should be drawn in free-form mode.
IncludeItemsIfIntersect | Sets a value indicating which items are selected when drawing a selection rectangle.
SetsDirtyFlag | Sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
Style | Sets a value indicating how to display multiple selection of items.

See Also

SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.SelectionExtensions Methods

SelectionExtensions Methods
[image]

Public Methods

Name | Description
AllowMultipleSelection | Sets a value indicating whether more than one items can be selected simultaneously.
ExtendMode | Sets whether to prevent deselecting currently selected items when they are outside of a newly drawn lasso rectangle.
FreeFormMode | Sets a value indicating whether selection lasso should be drawn in free-form mode.
IncludeItemsIfIntersect | Sets a value indicating which items are selected when drawing a selection rectangle.
SetsDirtyFlag | Sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
Style | Sets a value indicating how to display multiple selection of items.

See Also

SelectionExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions Class

ShapeNodeExtensions Class
[image]

Provides extension methods for ShapeNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class ShapeNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class ShapeNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions

See Also

ShapeNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions Members

ShapeNodeExtensions Members
Methods
[image]

Provides extension methods for ShapeNode fluent API.

The following tables list the members exposed by the ShapeNodeExtensions type.

Public Methods

Name | Description
AllowFlip | Sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
ClipImage | Sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.
ClipText | Sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.
CustomDraw | Sets the type of custom drawing performed on this shape node.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
FlipX | Sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Sets a value indicating whether the node's shape is flipped vertically.
Image | Sets the image that is displayed in this shape node.
ImageAlign | Sets the alignment of the image displayed in this shape node.
PolygonalTextLayout | Sets a flag indicating whether node's text is formatted in non-rectangular outline.
RotateImage | Sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Sets a value indicating whether the Text should be rotated when the shape node is rotated.
Shape | Sets a reference to the node's geometric shape definition.
ShapeOrientation | Sets the angle specifying the orientation with which a shape template is applied to the node bounds.
TextFormat | Sets the alignment of the text that is displayed inside shape nodes.
TextRotationAngle | Sets the text rotation angle of this node.
Transparent | Sets a value indicating whether this shape node is transparent.

See Also

ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.ShapeNodeExtensions Methods

ShapeNodeExtensions Methods
[image]

Public Methods

Name | Description
AllowFlip | Sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
ClipImage | Sets a value indicating whether to clip the Image assigned to this node to fit into the shape's geometry.
ClipText | Sets a value indicating whether to clip the text assigned to this node to fit into the shape's geometry.
CustomDraw | Sets the type of custom drawing performed on this shape node.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
FlipX | Sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Sets a value indicating whether the node's shape is flipped vertically.
Image | Sets the image that is displayed in this shape node.
ImageAlign | Sets the alignment of the image displayed in this shape node.
PolygonalTextLayout | Sets a flag indicating whether node's text is formatted in non-rectangular outline.
RotateImage | Sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Sets a value indicating whether the Text should be rotated when the shape node is rotated.
Shape | Sets a reference to the node's geometric shape definition.
ShapeOrientation | Sets the angle specifying the orientation with which a shape template is applied to the node bounds.
TextFormat | Sets the alignment of the text that is displayed inside shape nodes.
TextRotationAngle | Sets the text rotation angle of this node.
Transparent | Sets a value indicating whether this shape node is transparent.

See Also

ShapeNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions Class

TableNodeExtensions Class
[image]

Provides extension methods for TableNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TableNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TableNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions

See Also

TableNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions Members

TableNodeExtensions Members
Methods
[image]

Provides extension methods for TableNode fluent API.

The following tables list the members exposed by the TableNodeExtensions type.

Public Methods

Name | Description
AllowResizeColumns | Sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Sets a value indicating whether users are allowed to resize table rows.
Caption | Sets the text displayed as caption of the table.
CaptionBackBrush | Overloaded.
CaptionBrush | Overloaded.
CaptionFormat | Sets the alignment and line position of the text used as table caption.
CaptionHeight | Sets the height of the table's caption area.
CellCustomDraw | Sets the type of custom drawing performed on the table cells.
CellFrameStyle | Sets the style of the table cells.
ColumnCount | Sets the number of columns in the table.
ColumnWidth | Sets the default width of the table columns.
ConnectionStyle | Sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
CurrentScrollRow | Sets the index of the first visible row in the table.
CustomDraw | Sets the type of custom drawing performed on this table.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
HighlightedRow | Sets the highlighted row.
Image | Sets the image that is displayed in this table.
ImageAlign | Sets the alignment of the image displayed in this table.
OffsetHeaderRows | Sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
RowAnchorPattern | Sets the default anchor pattern for the rows of a table.
RowCount | Sets the number of rows in the table.
RowHeight | Sets the default height of table rows.
Scrollable | Sets a value indicating whether users are allowed to scroll table rows.
Shape | Sets the shape of the table's outline.

See Also

TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TableNodeExtensions Methods

TableNodeExtensions Methods
[image]

Public Methods

Name | Description
AllowResizeColumns | Sets a value indicating whether users are allowed to resize table columns.
AllowResizeRows | Sets a value indicating whether users are allowed to resize table rows.
Caption | Sets the text displayed as caption of the table.
CaptionBackBrush | Overloaded.
CaptionBrush | Overloaded.
CaptionFormat | Sets the alignment and line position of the text used as table caption.
CaptionHeight | Sets the height of the table's caption area.
CellCustomDraw | Sets the type of custom drawing performed on the table cells.
CellFrameStyle | Sets the style of the table cells.
ColumnCount | Sets the number of columns in the table.
ColumnWidth | Sets the default width of the table columns.
ConnectionStyle | Sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
CurrentScrollRow | Sets the index of the first visible row in the table.
CustomDraw | Sets the type of custom drawing performed on this table.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
HighlightedRow | Sets the highlighted row.
Image | Sets the image that is displayed in this table.
ImageAlign | Sets the alignment of the image displayed in this table.
OffsetHeaderRows | Sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
RowAnchorPattern | Sets the default anchor pattern for the rows of a table.
RowCount | Sets the number of rows in the table.
RowHeight | Sets the default height of table rows.
Scrollable | Sets a value indicating whether users are allowed to scroll table rows.
Shape | Sets the shape of the table's outline.

See Also

TableNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TemplatedNodeExtensions Class

TemplatedNodeExtensions Class
[image]

Provides extension methods for TemplatedNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TemplatedNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TemplatedNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.TemplatedNodeExtensions

See Also

TemplatedNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TemplatedNodeExtensions Members

TemplatedNodeExtensions Members
[image]

Provides extension methods for TemplatedNode fluent API.

The following tables list the members exposed by the TemplatedNodeExtensions type.

See Also

TemplatedNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions Class

TreeViewNodeExtensions Class
[image]

Provides extension methods for TreeViewNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TreeViewNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TreeViewNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions

See Also

TreeViewNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions Members

TreeViewNodeExtensions Members
Methods
[image]

Provides extension methods for TreeViewNode fluent API.

The following tables list the members exposed by the TreeViewNodeExtensions type.

Public Methods

Name | Description
Caption | Sets the text displayed as caption of the node.
CaptionBrush | Overloaded.
CaptionHeight | Sets the height of the table's caption area.
CaptionImage | Sets the image that is displayed in this shape node.
ConnectionStyle | Sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
ScrollPosition | Sets the current scroll position.
Shape | Sets the shape of the node's outline.
TextFormat | Sets the alignment of texts displayed inside this shape node.

See Also

TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.TreeViewNodeExtensions Methods

TreeViewNodeExtensions Methods
[image]

Public Methods

Name | Description
Caption | Sets the text displayed as caption of the node.
CaptionBrush | Overloaded.
CaptionHeight | Sets the height of the table's caption area.
CaptionImage | Sets the image that is displayed in this shape node.
ConnectionStyle | Sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
EnableStyledText | Sets a value indicating whether styled text rendering is enabled.
ScrollPosition | Sets the current scroll position.
Shape | Sets the shape of the node's outline.
TextFormat | Sets the alignment of texts displayed inside this shape node.

See Also

TreeViewNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.VisioNodeExtensions Class

VisioNodeExtensions Class
[image]

Provides extension methods for VisioNode fluent API.

Namespace: MindFusion.Diagramming.Wpf.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class VisioNodeExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class VisioNodeExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Fluent.VisioNodeExtensions

See Also

VisioNodeExtensions Members
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.VisioNodeExtensions Members

VisioNodeExtensions Members
Methods
[image]

Provides extension methods for VisioNode fluent API.

The following tables list the members exposed by the VisioNodeExtensions type.

Public Methods

Name | Description
Content | Sets the content of the node.

See Also

VisioNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Fluent.VisioNodeExtensions Methods

VisioNodeExtensions Methods
[image]

Public Methods

Name | Description
Content | Sets the content of the node.

See Also

VisioNodeExtensions Class
MindFusion.Diagramming.Wpf.Fluent Namespace


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs Class

ConnectorImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the ConnectorImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class ConnectorImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ConnectorImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs

See Also

ConnectorImportedEventArgs Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs Properties

ConnectorImportedEventArgs Properties
[image]

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ConnectorImportedEventArgs Members

ConnectorImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ConnectorImported event.

The following tables list the members exposed by the ConnectorImportedEventArgs type.

Public Properties

Name | Description
ConnectorXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported connector.
Link | Gets a reference to the imported diagram link.
ShapeName | Gets the Visio name of the connector shape.

See Also

ConnectorImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter Class

DrawImporter Class
Remarks See Also
[image]

DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.DrawImport

Syntax

C# [image] Copy Code

public class DrawImporter

Visual Basic [image] Copy Code

Public Class DrawImporter

Remarks

The DrawImporter class can import .odg files, created by the OpenOffice Draw vector graphics editor. In order to use it, you must add a reference to the MindFusion.Diagramming.Wpf.DrawImport.dll assembly.

Various overloads of the Import method can be used to import the OpenOffice drawing into a DiagramDocument whose pages correspond to the Draw pages, or into a single Diagram whose content is merged from all imported pages. When merging multiple pages, their positions in the diagram depend on the PagesPerRow value.

DrawImporter supports shapes from the General and Flowchart shape palettes in Draw. For each node shape from the .odg file, the importer creates a ShapeNode object whose Shape, Text, Brush and Stroke properties are set to values corresponding to the imported OpenOffice shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Import.DrawImporter

See Also

DrawImporter Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter Properties

DrawImporter Properties
[image]

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

See Also

DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter Members

DrawImporter Members
Constructors Properties Methods
[image]

DrawImporter lets you import an OpenOffice Draw document into a Diagram or DiagramDocument object.

The following tables list the members exposed by the DrawImporter type.

Public Constructors

Name | Description
DrawImporter | Initializes a new instance of the DrawImporter class.

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Draw pages to import on a row before offsetting the import location vertically.

Public Methods

Name | Description
Import | Overloaded.

See Also

DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.DrawImporter Methods

DrawImporter Methods
[image]

Public Methods

Name | Description
Import | Overloaded.

See Also

DrawImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.GroupImportedEventArgs Class

GroupImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the GroupImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class GroupImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GroupImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Import.GroupImportedEventArgs

See Also

GroupImportedEventArgs Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.GroupImportedEventArgs Properties

GroupImportedEventArgs Properties
[image]

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.GroupImportedEventArgs Members

GroupImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the GroupImported event.

The following tables list the members exposed by the GroupImportedEventArgs type.

Public Properties

Name | Description
Group | Gets a reference to the imported group.

See Also

GroupImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs Class

ImportItemEventArgs Class
[image]

Contains the arguments passed to handlers of the ImportItem event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class ImportItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ImportItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs

See Also

ImportItemEventArgs Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs Properties

ImportItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.
MasterName | Gets the name associated with shape's master.
MasterXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.
NamespaceManager | Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ImportItemEventArgs Members

ImportItemEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ImportItem event.

The following tables list the members exposed by the ImportItemEventArgs type.

Public Properties

Name | Description
Item | Gets or sets the item that should represent the Visio shape specified by ShapeXml in the imported diagram.
MasterName | Gets the name associated with shape's master.
MasterXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the shape master.
NamespaceManager | Gets an XmlNamespaceManager instance with preloaded Visio namespaces that can be used when querying the XML elements provided by this ImportItemEventArgs instance.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ImportItemEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs Class

ShapeImportedEventArgs Class
[image]

Contains the arguments passed to handlers of the ShapeImported event.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class ShapeImportedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ShapeImportedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs

See Also

ShapeImportedEventArgs Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs Properties

ShapeImportedEventArgs Properties
[image]

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio shape identifier.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.ShapeImportedEventArgs Members

ShapeImportedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ShapeImported event.

The following tables list the members exposed by the ShapeImportedEventArgs type.

Public Properties

Name | Description
Shape | Gets a reference to the imported diagram shape.
ShapeName | Gets the Visio shape identifier.
ShapeXml | Gets the XML DOM element corresponding to the Visio document's XML code that describes the imported shape.

See Also

ShapeImportedEventArgs Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Class

Visio2013Importer Class
Remarks See Also
[image]

Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class Visio2013Importer

Visual Basic [image] Copy Code

Public Class Visio2013Importer

Remarks

The Visio2013Importer class can import .vsdx files, created by version 2013 of Microsoft Visio. In order to use it, you must add a reference to the MindFusion.Diagramming.Wpf.VisioImport.dll assembly.

Various overloads of the Import method can be used to import the Visio drawing into a DiagramDocument whose pages correspond to the Visio pages, or into a single Diagram whose content is merged from all imported pages. When merging multiple pages, their positions in the diagram depend on the PagesPerRow value.

Visio2013Importer supports Visio's basic flowchart and data flow stencils. For each node shape from the .vsdx file, the importer creates a ShapeNode object whose Shape, Text, Brush and Stroke properties are set to values corresponding to the imported Visio shape. For each connector shape, the importer creates a DiagramLink object whose Origin and Destination are set to the corresponding imported nodes, and whose ControlPoints reflect the geometry of the connector.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Import.Visio2013Importer

See Also

Visio2013Importer Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Properties

Visio2013Importer Properties
[image]

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Events

Visio2013Importer Events
[image]

Public Events

Name | Description
ImportItem | Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Members

Visio2013Importer Members
Constructors Properties Methods Events
[image]

Imports Visio 2013 XML Drawing files (*.vsdx) into Diagram or DiagramDocument objects.

The following tables list the members exposed by the Visio2013Importer type.

Public Constructors

Name | Description
Visio2013Importer | Initializes a new instance of the Visio2013Importer class.

Public Properties

Name | Description
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.

Public Methods

Name | Description
Import | Overloaded. Imports the specified Visio Graphics Service VSDX file.

Protected Methods

Name | Description
OnImportItem | Raises the ImportItem event.

Public Events

Name | Description
ImportItem | Raised for each shape's XML element in the imported VSDX drawing to let you create a custom diagram item representing the Visio shape.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.Visio2013Importer Methods

Visio2013Importer Methods
[image]

Public Methods

Name | Description
Import | Overloaded. Imports the specified Visio Graphics Service VSDX file.

Protected Methods

Name | Description
OnImportItem | Raises the ImportItem event.

See Also

Visio2013Importer Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Class

VisioImporter Class
Remarks See Also
[image]

Imports Visio 2003 XML Drawing files (*.vdx) into Diagram or DiagramDocument objects.

Namespace: MindFusion.Diagramming.Wpf.Import
Assembly: MindFusion.Diagramming.Wpf.VisioImport

Syntax

C# [image] Copy Code

public class VisioImporter

Visual Basic [image] Copy Code

Public Class VisioImporter

Remarks

Add a reference to MindFusion.Diagramming.Wpf.VisioImport.dll to your project in order to use this component.

VisioImporter allows importing Visio 2003 XML Drawing files (*.vdx) into MindFusion.Diagramming. The standard Visio flowchart shapes, as well as most of the UML and Database entity shapes are imported to their closest representation in MindFusion.Diagramming. The Visio connectors are imported as DiagramLink objects, preserving the relationship between the connected nodes. In addition, most of the attributes of Visio objects such as text, text formatting, fill and line colors and styles are preserved. The component raises an event for each imported node to let you set the node shape if it is not recognized by MindFusion.Diagramming or if you need to set a different shape.

The Import method imports all Visio pages into a DiagramDocument, creating a DiagramPage for each page from the VDX. To determine how many pages there are in a Visio document and import only a single page, call the GetPageCount and ImportPage methods. All pages of a Visio drawing can be imported into a single Diagram by calling the ImportAllPages method, which lays out the pages as set in PagesPerRow.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Import.VisioImporter

See Also

VisioImporter Members
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Properties

VisioImporter Properties
[image]

Public Properties

Name | Description
ApplyVisioUnit | Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as TableNode objects.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

See Also

VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Events

VisioImporter Events
[image]

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a DiagramLink.
GroupImported | Raised when a Visio group is imported as a MindFusion.Diagramming Group object.
ShapeImported | Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Members

VisioImporter Members
Constructors Properties Methods Events
[image]

Imports Visio 2003 XML Drawing files (*.vdx) into Diagram or DiagramDocument objects.

The following tables list the members exposed by the VisioImporter type.

Public Constructors

Name | Description
VisioImporter | Initializes a new instance of the VisioImporter class.

Public Properties

Name | Description
ApplyVisioUnit | Gets or sets a value indicating whether the diagram's MeasureUnit should be set to the one read from the imported Visio file.
ImportEntitiesAsTables | Gets or sets a value indicating whether Visio UML and DB entities are imported as TableNode objects.
PagesPerRow | Gets or sets how many Visio pages to import on a row before offsetting the import location vertically.
SuppressUnmanagedCode | Suppress usage of unmanaged code.

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
Import | Imports all pages from the specified Visio document into a single DiagramDocument object.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

Public Events

Name | Description
ConnectorImported | Raised when a Visio connector is imported as a DiagramLink.
GroupImported | Raised when a Visio group is imported as a MindFusion.Diagramming Group object.
ShapeImported | Raised when a Visio shape is imported into MindFusion.Diagramming as a ShapeNode.

See Also

VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Import.VisioImporter Methods

VisioImporter Methods
[image]

Public Methods

Name | Description
GetPageCount | Determines how many pages are there in a Visio diagram.
Import | Imports all pages from the specified Visio document into a single DiagramDocument object.
ImportAllPages | Imports all pages from the specified Visio document.
ImportPage | Imports a single page from the specified Visio document.

Protected Methods

Name | Description
OnConnectorImported | Raises the ConnectorImported event.
OnGroupImported | Raises the GroupImported event.
OnShapeImported | Raises the ShapeImported event.

See Also

VisioImporter Class
MindFusion.Diagramming.Wpf.Import Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions Class

AnnealLayoutExtensions Class
[image]

Provides extension methods for AnnealLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class AnnealLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class AnnealLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions

See Also

AnnealLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions Members

AnnealLayoutExtensions Members
Methods
[image]

Provides extension methods for AnnealLayout fluent API.

The following tables list the members exposed by the AnnealLayoutExtensions type.

Public Methods

Name | Description
ApproximateLinkLength | Sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Specifies whether the layout should gather statistics while running.
InitialTemperature | Sets the initial temperature of the simulated annealing process.
IterationsPerStage | Sets how many node shift iterations to perform at each stage of the algorithm.
LayoutArea | Sets the size of the layout area.
LinkLengthFactor | Sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
NodeLinkCrossingCost | Sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Randomize | Sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Sets how many cool-down stages the algorithm should simulate.
TemperatureScale | Sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Sets what width/height ratio the layout area should have.

See Also

AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.AnnealLayoutExtensions Methods

AnnealLayoutExtensions Methods
[image]

Public Methods

Name | Description
ApproximateLinkLength | Sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Specifies whether the layout should gather statistics while running.
InitialTemperature | Sets the initial temperature of the simulated annealing process.
IterationsPerStage | Sets how many node shift iterations to perform at each stage of the algorithm.
LayoutArea | Sets the size of the layout area.
LinkLengthFactor | Sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
NodeLinkCrossingCost | Sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Randomize | Sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
Root | Sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Sets how many cool-down stages the algorithm should simulate.
TemperatureScale | Sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Sets what width/height ratio the layout area should have.

See Also

AnnealLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions Class

CascadeLayoutExtensions Class
[image]

Provides extension methods for CascadeLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class CascadeLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class CascadeLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions

See Also

CascadeLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions Members

CascadeLayoutExtensions Members
Methods
[image]

Provides extension methods for CascadeLayout fluent API.

The following tables list the members exposed by the CascadeLayoutExtensions type.

Public Methods

Name | Description
Orientation | Sets the orientation of the arranged graph.
Padding | Sets the spacing between nodes in adjacent layers.

See Also

CascadeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CascadeLayoutExtensions Methods

CascadeLayoutExtensions Methods
[image]

Public Methods

Name | Description
Orientation | Sets the orientation of the arranged graph.
Padding | Sets the spacing between nodes in adjacent layers.

See Also

CascadeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions Class

CircularLayoutExtensions Class
[image]

Provides extension methods for CircularLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class CircularLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class CircularLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions

See Also

CircularLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions Members

CircularLayoutExtensions Members
Methods
[image]

Provides extension methods for CircularLayout fluent API.

The following tables list the members exposed by the CircularLayoutExtensions type.

Public Methods

Name | Description
AutoRadiusFactor | Sets a multiplier for the automatically calculated radius when Radius is set to 0.
Radius | Sets the radius of the layout circle.
SiftingRounds | Sets the number of sifts to perform during the layout.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

See Also

CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.CircularLayoutExtensions Methods

CircularLayoutExtensions Methods
[image]

Public Methods

Name | Description
AutoRadiusFactor | Sets a multiplier for the automatically calculated radius when Radius is set to 0.
Radius | Sets the radius of the layout circle.
SiftingRounds | Sets the number of sifts to perform during the layout.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

See Also

CircularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions Class

DecisionLayoutExtensions Class
[image]

Provides extension methods for DecisionLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class DecisionLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class DecisionLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions

See Also

DecisionLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions Members

DecisionLayoutExtensions Members
Methods
[image]

Provides extension methods for DecisionLayout fluent API.

The following tables list the members exposed by the DecisionLayoutExtensions type.

Public Methods

Name | Description
HorizontalPadding | Sets the horizontal distance between adjacent nodes.
LinkPadding | Sets the distance between parallel links.
Orientation | Sets the orientation of the arranged diagram.
StartNode | Sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Sets the vertical distance between adjacent nodes.

See Also

DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.DecisionLayoutExtensions Methods

DecisionLayoutExtensions Methods
[image]

Public Methods

Name | Description
HorizontalPadding | Sets the horizontal distance between adjacent nodes.
LinkPadding | Sets the distance between parallel links.
Orientation | Sets the orientation of the arranged diagram.
StartNode | Sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Sets the vertical distance between adjacent nodes.

See Also

DecisionLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions Class

FlowchartLayoutExtensions Class
[image]

Provides extension methods for FlowchartLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class FlowchartLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class FlowchartLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions

See Also

FlowchartLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions Members

FlowchartLayoutExtensions Members
Methods
[image]

Provides extension methods for FlowchartLayout fluent API.

The following tables list the members exposed by the FlowchartLayoutExtensions type.

Public Methods

Name | Description
BranchPadding | Sets how much space to leave between adjacent decision branches in the flowchart.
IgnoreRepeatingLinks | Sets a value indicating whether to ignore repeating links.
LinkPadding | Sets how much space to leave between adjacent back links designating nested loops.
NodeDistance | Sets the distance between consecutive nodes in the flowchart.
Orientation | Sets the overall orientation of the arranged diagram.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

See Also

FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FlowchartLayoutExtensions Methods

FlowchartLayoutExtensions Methods
[image]

Public Methods

Name | Description
BranchPadding | Sets how much space to leave between adjacent decision branches in the flowchart.
IgnoreRepeatingLinks | Sets a value indicating whether to ignore repeating links.
LinkPadding | Sets how much space to leave between adjacent back links designating nested loops.
NodeDistance | Sets the distance between consecutive nodes in the flowchart.
Orientation | Sets the overall orientation of the arranged diagram.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

See Also

FlowchartLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FractalLayoutExtensions Class

FractalLayoutExtensions Class
[image]

Provides extension methods for FractalLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class FractalLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class FractalLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.FractalLayoutExtensions

See Also

FractalLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FractalLayoutExtensions Members

FractalLayoutExtensions Members
Methods
[image]

Provides extension methods for FractalLayout fluent API.

The following tables list the members exposed by the FractalLayoutExtensions type.

Public Methods

Name | Description
Root | Sets the tree root.

See Also

FractalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.FractalLayoutExtensions Methods

FractalLayoutExtensions Methods
[image]

Public Methods

Name | Description
Root | Sets the tree root.

See Also

FractalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions Class

GridLayoutExtensions Class
[image]

Provides extension methods for GridLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class GridLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class GridLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions

See Also

GridLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions Members

GridLayoutExtensions Members
Methods
[image]

Provides extension methods for GridLayout fluent API.

The following tables list the members exposed by the GridLayoutExtensions type.

Public Methods

Name | Description
EndNode | Sets the node that is placed at the lower right corner of the grid.
GridSize | Sets the desired distance between adjacent grid points.
Iterations | Sets for how many iterations to run the grid layout algorithm.
RandomSeed | Sets the randomization seed to use for generating random node positions.
Root | Sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Sets the node that is placed at the upper left corner of the grid.
TimeLimit | Sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

See Also

GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.GridLayoutExtensions Methods

GridLayoutExtensions Methods
[image]

Public Methods

Name | Description
EndNode | Sets the node that is placed at the lower right corner of the grid.
GridSize | Sets the desired distance between adjacent grid points.
Iterations | Sets for how many iterations to run the grid layout algorithm.
RandomSeed | Sets the randomization seed to use for generating random node positions.
Root | Sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Sets the node that is placed at the upper left corner of the grid.
TimeLimit | Sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

See Also

GridLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions Class

HierarchicalLayoutExtensions Class
[image]

Provides extension methods for HierarchicalLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class HierarchicalLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class HierarchicalLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions

See Also

HierarchicalLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions Members

HierarchicalLayoutExtensions Members
Methods
[image]

Provides extension methods for HierarchicalLayout fluent API.

The following tables list the members exposed by the HierarchicalLayoutExtensions type.

Public Methods

Name | Description
LevelDistance | Sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Sets the bending factor of links.
Orientation | Sets the orientation of the arranged graph.

See Also

HierarchicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.HierarchicalLayoutExtensions Methods

HierarchicalLayoutExtensions Methods
[image]

Public Methods

Name | Description
LevelDistance | Sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Sets the bending factor of links.
Orientation | Sets the orientation of the arranged graph.

See Also

HierarchicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions Class

LayeredLayoutExtensions Class
[image]

Provides extension methods for LayeredLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class LayeredLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class LayeredLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions

See Also

LayeredLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions Members

LayeredLayoutExtensions Members
Methods
[image]

Provides extension methods for LayeredLayout fluent API.

The following tables list the members exposed by the LayeredLayoutExtensions type.

Public Methods

Name | Description
Direction | Sets the direction of the arranged diagram.
EnableCustomLayers | Sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
IgnoreNodeSize | Sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepRootPosition | Sets a value indicating whether to preserve the position of the root node.
LayerDistance | Sets the desired distance between layer axis lines.
LinkPadding | Sets the distance between parallel cascading links.
LinksCompactFactor | Sets a value indicating how much to compact the outermost arrows.
LinkType | Sets the appearance of the links in the final layout.
NodeDistance | Sets the desired distance between adjacent nodes in a layer.
Orientation | Sets the overall orientation of the arranged diagram.
Root | Sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.
StartNode | Sets the node that should be placed in the first layer of the arranged graph.
StraightenLongLinks | Sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Sets a time-out value for the path-finding part of the layered layout algorithm.

See Also

LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.LayeredLayoutExtensions Methods

LayeredLayoutExtensions Methods
[image]

Public Methods

Name | Description
Direction | Sets the direction of the arranged diagram.
EnableCustomLayers | Sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
IgnoreNodeSize | Sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepRootPosition | Sets a value indicating whether to preserve the position of the root node.
LayerDistance | Sets the desired distance between layer axis lines.
LinkPadding | Sets the distance between parallel cascading links.
LinksCompactFactor | Sets a value indicating how much to compact the outermost arrows.
LinkType | Sets the appearance of the links in the final layout.
NodeDistance | Sets the desired distance between adjacent nodes in a layer.
Orientation | Sets the overall orientation of the arranged diagram.
Root | Sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.
StartNode | Sets the node that should be placed in the first layer of the arranged graph.
StraightenLongLinks | Sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Sets a time-out value for the path-finding part of the layered layout algorithm.

See Also

LayeredLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions Class

OneWayLayoutExtensions Class
[image]

Provides extension methods for OneWayLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class OneWayLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class OneWayLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions

See Also

OneWayLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions Members

OneWayLayoutExtensions Members
Methods
[image]

Provides extension methods for OneWayLayout fluent API.

The following tables list the members exposed by the OneWayLayoutExtensions type.

Public Methods

Name | Description
NodeDistance | Sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Sets the orientation of the arranged graph.
RoundedLinks | Sets a value indicating whether the layout should smooth link bends.

See Also

OneWayLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OneWayLayoutExtensions Methods

OneWayLayoutExtensions Methods
[image]

Public Methods

Name | Description
NodeDistance | Sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Sets the orientation of the arranged graph.
RoundedLinks | Sets a value indicating whether the layout should smooth link bends.

See Also

OneWayLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions Class

OrthogonalLayoutExtensions Class
[image]

Provides extension methods for OrthogonalLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class OrthogonalLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class OrthogonalLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions

See Also

OrthogonalLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions Members

OrthogonalLayoutExtensions Members
Methods
[image]

Provides extension methods for OrthogonalLayout fluent API.

The following tables list the members exposed by the OrthogonalLayoutExtensions type.

Public Methods

Name | Description
Directed | Sets a value indicating whether the graph being laid out is directed.
MinimizeLinkBends | Sets a value indicating whether the layout should attempt to minimize link bending.
MinLaneSize | Sets a value indicating the minimum size of a lane.
Padding | Sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Sets a value indicating whether to refine the layout.

See Also

OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalLayoutExtensions Methods

OrthogonalLayoutExtensions Methods
[image]

Public Methods

Name | Description
Directed | Sets a value indicating whether the graph being laid out is directed.
MinimizeLinkBends | Sets a value indicating whether the layout should attempt to minimize link bending.
MinLaneSize | Sets a value indicating the minimum size of a lane.
Padding | Sets a value indicating how much space to leave between nodes in adjacent lanes.
Refine | Sets a value indicating whether to refine the layout.

See Also

OrthogonalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions Class

OrthogonalRouterExtensions Class
[image]

Provides extension methods for OrthogonalRouter fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class OrthogonalRouterExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class OrthogonalRouterExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions

See Also

OrthogonalRouterExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions Members

OrthogonalRouterExtensions Members
Methods
[image]

Provides extension methods for OrthogonalRouter fluent API.

The following tables list the members exposed by the OrthogonalRouterExtensions type.

Public Methods

Name | Description
BendDistance | Sets how far from its adjacent node a link should bend.
Direction | Sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Sets the desired orientation of the last segments of routed links.
GridSize | Sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Sets the desired distance between layer axis lines.
NodeDistance | Sets the desired distance between adjacent nodes in a layer.
Orientation | Sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Sets the randomization seed to use for generating random node positions.
StartOrientation | Sets the desired orientation of the first segments of routed links.

See Also

OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.OrthogonalRouterExtensions Methods

OrthogonalRouterExtensions Methods
[image]

Public Methods

Name | Description
BendDistance | Sets how far from its adjacent node a link should bend.
Direction | Sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Sets the desired orientation of the last segments of routed links.
GridSize | Sets the distance between adjacent grid points when BaseLayout is set to Grid.
LayerDistance | Sets the desired distance between layer axis lines.
NodeDistance | Sets the desired distance between adjacent nodes in a layer.
Orientation | Sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
PutEndPointsAtNodeBorders | Sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Sets the randomization seed to use for generating random node positions.
StartOrientation | Sets the desired orientation of the first segments of routed links.

See Also

OrthogonalRouterExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions Class

SpringLayoutExtensions Class
[image]

Provides extension methods for SpringLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class SpringLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class SpringLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions

See Also

SpringLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions Members

SpringLayoutExtensions Members
Methods
[image]

Provides extension methods for SpringLayout fluent API.

The following tables list the members exposed by the SpringLayoutExtensions type.

Public Methods

Name | Description
EnableClusters | Sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Sets for how many iterations to run the layout routine.
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Sets the size of the layout area.
LayoutMethod | Specifies what energy model to use for the simulation.
LinkType | Sets the appearance of the links in the final layout.
MinimizeCrossings | Sets a value indicating whether crossing minimization mode is enabled.
NodeDistance | Sets the desired distance between nodes.
Randomize | Sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Sets the randomization seed to use for generating random node positions.
RepulsionFactor | Sets the multiplier applied to repulsion forces between nodes.
Root | Sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Sets the link stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

See Also

SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SpringLayoutExtensions Methods

SpringLayoutExtensions Methods
[image]

Public Methods

Name | Description
EnableClusters | Sets a value indicating whether to enable allocation of nodes to distinct clusters.
IterationCount | Sets for how many iterations to run the layout routine.
Layout3D | Specifies whether the layout should set the 3D coordinates of nodes for display inside DiagramView3D.
LayoutArea | Sets the size of the layout area.
LayoutMethod | Specifies what energy model to use for the simulation.
LinkType | Sets the appearance of the links in the final layout.
MinimizeCrossings | Sets a value indicating whether crossing minimization mode is enabled.
NodeDistance | Sets the desired distance between nodes.
Randomize | Sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Sets the randomization seed to use for generating random node positions.
RepulsionFactor | Sets the multiplier applied to repulsion forces between nodes.
Root | Sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Sets the link stretch factor.
Surface | Specifies on what surface the nodes should be placed initially.

See Also

SpringLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions Class

SwimlaneLayoutExtensions Class
[image]

Provides extension methods for SwimlaneLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class SwimlaneLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class SwimlaneLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions

See Also

SwimlaneLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions Members

SwimlaneLayoutExtensions Members
Methods
[image]

Provides extension methods for SwimlaneLayout fluent API.

The following tables list the members exposed by the SwimlaneLayoutExtensions type.

Public Methods

Name | Description
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Sets the direction of the arranged diagram.
KeepLaneSizes | Sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Sets the spacing between adjacent lanes in the final layout.
NodeDistance | Sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Sets the overall orientation of the arranged diagram.
SwimlaneGrid | Sets the object through which the layout can manipulate the swimlane grid.

See Also

SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.SwimlaneLayoutExtensions Methods

SwimlaneLayoutExtensions Methods
[image]

Public Methods

Name | Description
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Sets the direction of the arranged diagram.
KeepLaneSizes | Sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Sets the spacing between adjacent lanes in the final layout.
NodeDistance | Sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Sets the overall orientation of the arranged diagram.
SwimlaneGrid | Sets the object through which the layout can manipulate the swimlane grid.

See Also

SwimlaneLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions Class

TopologicalLayoutExtensions Class
[image]

Provides extension methods for TopologicalLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TopologicalLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TopologicalLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions

See Also

TopologicalLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions Members

TopologicalLayoutExtensions Members
Methods
[image]

Provides extension methods for TopologicalLayout fluent API.

The following tables list the members exposed by the TopologicalLayoutExtensions type.

Public Methods

Name | Description
BendAdjacentLinks | Sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Sets the direction of the arranged diagram.
MultipleGraphsPlacement | Sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
NodeDistance | Sets the distance between adjacent nodes in the diagram.
Orientation | Sets the overall orientation of the arranged diagram.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

See Also

TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TopologicalLayoutExtensions Methods

TopologicalLayoutExtensions Methods
[image]

Public Methods

Name | Description
BendAdjacentLinks | Sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Sets the direction of the arranged diagram.
MultipleGraphsPlacement | Sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
NodeDistance | Sets the distance between adjacent nodes in the diagram.
Orientation | Sets the overall orientation of the arranged diagram.
SplitGraph | Sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

See Also

TopologicalLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions Class

TreeLayoutExtensions Class
[image]

Provides extension methods for TreeLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TreeLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TreeLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions

See Also

TreeLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions Members

TreeLayoutExtensions Members
Methods
[image]

Provides extension methods for TreeLayout fluent API.

The following tables list the members exposed by the TreeLayoutExtensions type.

Public Methods

Name | Description
Balance | Sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Sets the tree direction.
EnableAssistants | Sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Sets a value indicating whether to keep the root node at its original position.
LevelDistance | Sets how much space to leave between levels of the tree.
LinkOffset | Sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Sets a value indicating how links in the arranged tree should look.
NodeDistance | Sets how much space to leave between nodes on the same level.
ReversedLinks | Sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Sets the root node of the tree.
StretchFactor | Sets the stretch factor applied on Radial tree layouts.
Type | Sets what type of tree layout to apply to the diagram.

See Also

TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeLayoutExtensions Methods

TreeLayoutExtensions Methods
[image]

Public Methods

Name | Description
Balance | Sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Sets the tree direction.
EnableAssistants | Sets a value indicating whether the "assistant" trait is regarded when performing the layout.
IgnoreLinkDirection | Sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepRootPosition | Sets a value indicating whether to keep the root node at its original position.
LevelDistance | Sets how much space to leave between levels of the tree.
LinkOffset | Sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Sets a value indicating how links in the arranged tree should look.
NodeDistance | Sets how much space to leave between nodes on the same level.
ReversedLinks | Sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Sets the root node of the tree.
StretchFactor | Sets the stretch factor applied on Radial tree layouts.
Type | Sets what type of tree layout to apply to the diagram.

See Also

TreeLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions Class

TreeMapLayoutExtensions Class
[image]

Provides extension methods for TreeMapLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TreeMapLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TreeMapLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions

See Also

TreeMapLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions Members

TreeMapLayoutExtensions Members
Methods
[image]

Provides extension methods for TreeMapLayout fluent API.

The following tables list the members exposed by the TreeMapLayoutExtensions type.

Public Methods

Name | Description
ContainerPadding | Sets the padding inside containers.
LayoutArea | Sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
Orientation | Sets the orientation of the arranged diagram.
Padding | Sets the distance between adjacent nodes.
Squarify | Sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

See Also

TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TreeMapLayoutExtensions Methods

TreeMapLayoutExtensions Methods
[image]

Public Methods

Name | Description
ContainerPadding | Sets the padding inside containers.
LayoutArea | Sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
Orientation | Sets the orientation of the arranged diagram.
Padding | Sets the distance between adjacent nodes.
Squarify | Sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

See Also

TreeMapLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions Class

TriangularLayoutExtensions Class
[image]

Provides extension methods for TriangularLayout fluent API.

Namespace: MindFusion.Diagramming.Wpf.Layout.Fluent
Assembly: MindFusion.Diagramming.Wpf

Syntax

C# [image] Copy Code

public sealed class TriangularLayoutExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class TriangularLayoutExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions

See Also

TriangularLayoutExtensions Members
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions Members

TriangularLayoutExtensions Members
Methods
[image]

Provides extension methods for TriangularLayout fluent API.

The following tables list the members exposed by the TriangularLayoutExtensions type.

Public Methods

Name | Description
BendNonplanarLinks | Sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Sets the size of the virtual grid the layout will place vertices on.
Orientation | Sets the orientation of the arranged graph.

See Also

TriangularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Diagramming.Wpf.Layout.Fluent.TriangularLayoutExtensions Methods

TriangularLayoutExtensions Methods
[image]

Public Methods

Name | Description
BendNonplanarLinks | Sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Sets the size of the virtual grid the layout will place vertices on.
Orientation | Sets the orientation of the arranged graph.

See Also

TriangularLayoutExtensions Class
MindFusion.Diagramming.Wpf.Layout.Fluent Namespace


MindFusion.Mapping.Silverlight.DecorationLayer Events

DecorationLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.Silverlight Namespace


MindFusion.Mapping.Silverlight.MapLayer Events

MapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.Silverlight Namespace


MindFusion.Mapping.WebForms.StreetMapLayer Events

StreetMapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

StreetMapLayer Class
MindFusion.Mapping.WebForms Namespace


MindFusion.Mapping.WinForms.DecorationLayer Events

DecorationLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapLayer Events

MapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer Events

StreetMapLayer Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.RealTimeCharting.Wpf.Axis Class

Axis Class
[image]

Provides settings for the RealTimeChart axes.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class Axis : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Axis
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.Axis

See Also

Axis Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis Properties

Axis Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the background for the axis.
DrawLabels | Gets or sets whether labels are drawn at the axis.
Interval | Gets or sets the interval between two adjacent values at the axis.
LabelBrush | Gets or sets the brush for the labels of the axis.
LabelFontFamily | Gets or sets the font family for the axes labels.
LabelFontSize | Gets the size of the label font.
LabelFormat | Gets or sets the format of the axes labels.
LabelFormatProvider | Gets or sets custom IFormatProvider object for formatting numeric labels at the axis.
LabelHorizontalAlignment | Gets or sets the horizontal alignment of the labels.
LabelOffset | Gets or sets the offset of the labels to the axis.
LabelOrigin | Gets or sets the numeric value of the first label at the axis.
Length | Gets or sets the length of the axes as a numeric value.
Origin | Gets or sets the smallest number at the axis.
PinLabels | Gets or sets whether chart labels are pinned to the axes.
Stroke | Gets or sets the stroke for the axis.
TickLength | Gets or sets the length of the axis ticks.
Title | Gets or sets the title for this Axis.
TitleBrush | Gets or sets the brush for the title of the axis.
TitleFontFamily | Gets or sets the font family for the axis title.
TitleFontSize | Gets or sets the size of the font for the axes title.
TitleOffset | Gets or sets the offset for the title.
TitleRotationAngle | Gets or sets the rotation angle of the title label.
VerticalAlignment | Gets or sets the vertical alignment of the labels.
Visibility | Gets or sets the visibility for the axis.

See Also

Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis Events

Axis Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property value in the Axis class changes.

See Also

Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis Members

Axis Members
Constructors Properties Methods Events
[image]

Provides settings for the RealTimeChart axes.

The following tables list the members exposed by the Axis type.

Public Constructors

Name | Description
Axis | Initializes a new instance of the Axes class.

Public Properties

Name | Description
Background | Gets or sets the background for the axis.
DrawLabels | Gets or sets whether labels are drawn at the axis.
Interval | Gets or sets the interval between two adjacent values at the axis.
LabelBrush | Gets or sets the brush for the labels of the axis.
LabelFontFamily | Gets or sets the font family for the axes labels.
LabelFontSize | Gets the size of the label font.
LabelFormat | Gets or sets the format of the axes labels.
LabelFormatProvider | Gets or sets custom IFormatProvider object for formatting numeric labels at the axis.
LabelHorizontalAlignment | Gets or sets the horizontal alignment of the labels.
LabelOffset | Gets or sets the offset of the labels to the axis.
LabelOrigin | Gets or sets the numeric value of the first label at the axis.
Length | Gets or sets the length of the axes as a numeric value.
Origin | Gets or sets the smallest number at the axis.
PinLabels | Gets or sets whether chart labels are pinned to the axes.
Stroke | Gets or sets the stroke for the axis.
TickLength | Gets or sets the length of the axis ticks.
Title | Gets or sets the title for this Axis.
TitleBrush | Gets or sets the brush for the title of the axis.
TitleFontFamily | Gets or sets the font family for the axis title.
TitleFontSize | Gets or sets the size of the font for the axes title.
TitleOffset | Gets or sets the offset for the title.
TitleRotationAngle | Gets or sets the rotation angle of the title label.
VerticalAlignment | Gets or sets the vertical alignment of the labels.
Visibility | Gets or sets the visibility for the axis.

Protected Methods

Name | Description
OnPropertyChanged | Invoked whenever the effective value of any dependency property in the Axis class has been updated.

Public Events

Name | Description
PropertyChanged | Occurs when a property value in the Axis class changes.

See Also

Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Axis Methods

Axis Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Invoked whenever the effective value of any dependency property in the Axis class has been updated.

See Also

Axis Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisEventArgs Class

AxisEventArgs Class
[image]

Provides data for the Axis.PropertyChanged event.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class AxisEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AxisEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.RealTimeCharting.Wpf.AxisEventArgs

See Also

AxisEventArgs Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisEventArgs Properties

AxisEventArgs Properties
[image]

Public Properties

Name | Description
Axis | Gets or sets the Axis that has raised the event.

See Also

AxisEventArgs Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisEventArgs Members

AxisEventArgs Members
Constructors Properties
[image]

Provides data for the Axis.PropertyChanged event.

The following tables list the members exposed by the AxisEventArgs type.

Public Constructors

Name | Description
AxisEventArgs | Initializes a new instance of the AxisEventArgs class.

Public Properties

Name | Description
Axis | Gets or sets the Axis that has raised the event.

See Also

AxisEventArgs Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Class

AxisRenderer Class
[image]

Provides a custom FrameworkElement that renders a RealTimeChart axis according to its settings.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class AxisRenderer : FrameworkElement

Visual Basic [image] Copy Code

Public Class AxisRenderer
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.RealTimeCharting.Wpf.AxisRenderer

See Also

AxisRenderer Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Properties

AxisRenderer Properties
[image]

Public Properties

Name | Description
XAxis | The X-axis of the chart.
YAxis | The Y-axis to be rendered.

See Also

AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Fields

AxisRenderer Fields
[image]

Public Fields

Name | Description
XAxisProperty | Identifies the XAxis dependency property.
YAxisProperty | Identifies the YAxis dependency property.

See Also

AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Members

AxisRenderer Members
Constructors Fields Properties Methods
[image]

Provides a custom FrameworkElement that renders a RealTimeChart axis according to its settings.

The following tables list the members exposed by the AxisRenderer type.

Public Constructors

Name | Description
AxisRenderer | Initializes a new instance of the AxisRenderer class.

Public Fields

Name | Description
XAxisProperty | Identifies the XAxis dependency property.
YAxisProperty | Identifies the YAxis dependency property.

Public Properties

Name | Description
XAxis | The X-axis of the chart.
YAxis | The Y-axis to be rendered.

Protected Methods

Name | Description
MeasureOverride | Provides implementation of FrameworkElement.MeasureOverride.
OnRender | Renders an Axis according to its settings.

See Also

AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.AxisRenderer Methods

AxisRenderer Methods
[image]

Protected Methods

Name | Description
MeasureOverride | Provides implementation of FrameworkElement.MeasureOverride.
OnRender | Renders an Axis according to its settings.

See Also

AxisRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter Class

ChartToLegendVisibilityConverter Class
[image]

Converts a bool value to a System.Windows.Visibility enumeration value.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class ChartToLegendVisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ChartToLegendVisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter

See Also

ChartToLegendVisibilityConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter Members

ChartToLegendVisibilityConverter Members
Constructors Methods
[image]

Converts a bool value to a System.Windows.Visibility enumeration value.

The following tables list the members exposed by the ChartToLegendVisibilityConverter type.

Public Constructors

Name | Description
ChartToLegendVisibilityConverter | Initializes a new instance of the ChartToLegendVisibilityConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

ChartToLegendVisibilityConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ChartToLegendVisibilityConverter Methods

ChartToLegendVisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

ChartToLegendVisibilityConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter Class

DoubleToGridLengthConverter Class
[image]

Converts a double value to an instance of the System.Windows.GridLength structure.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class DoubleToGridLengthConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class DoubleToGridLengthConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter

See Also

DoubleToGridLengthConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter Members

DoubleToGridLengthConverter Members
Constructors Methods
[image]

Converts a double value to an instance of the System.Windows.GridLength structure.

The following tables list the members exposed by the DoubleToGridLengthConverter type.

Public Constructors

Name | Description
DoubleToGridLengthConverter | Initializes a new instance of the DoubleToGridLengthConverter.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

DoubleToGridLengthConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToGridLengthConverter Methods

DoubleToGridLengthConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

DoubleToGridLengthConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter Class

DoubleToThicknessConverter Class
[image]

Converts a double value to an instance of the System.Windows.Thickness structure.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class DoubleToThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class DoubleToThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter

See Also

DoubleToThicknessConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter Members

DoubleToThicknessConverter Members
Constructors Methods
[image]

Converts a double value to an instance of the System.Windows.Thickness structure.

The following tables list the members exposed by the DoubleToThicknessConverter type.

Public Constructors

Name | Description
DoubleToThicknessConverter | Initializes a new instance of the DoubleToThicknessConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

DoubleToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.DoubleToThicknessConverter Methods

DoubleToThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

DoubleToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult Class

HitTestResult Class
[image]

Represents an object returned when hit testing.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class HitTestResult

Visual Basic [image] Copy Code

Public Class HitTestResult

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.HitTestResult

See Also

HitTestResult Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult Properties

HitTestResult Properties
[image]

Public Properties

Name | Description
Index | The index the hit element has in the Series it belongs to.
Series | The Series object hit by the mouse.
Value | The value of the hit element.

See Also

HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.HitTestResult Members

HitTestResult Members
Constructors Properties
[image]

Represents an object returned when hit testing.

The following tables list the members exposed by the HitTestResult type.

Public Constructors

Name | Description
HitTestResult | Initializes a new instance of the HitTestResult class.

Public Properties

Name | Description
Index | The index the hit element has in the Series it belongs to.
Series | The Series object hit by the mouse.
Value | The value of the hit element.

See Also

HitTestResult Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend Class

Legend Class
[image]

Represents a legend in the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class Legend : ItemsControl

Visual Basic [image] Copy Code

Public Class Legend
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.RealTimeCharting.Wpf.Legend

See Also

Legend Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend Properties

Legend Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend.
LabelFontFamily | Gets or sets the font family for the legend labels.
Orientation | Gets or sets the orientation of the legend.

See Also

Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend Fields

Legend Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
OrientationProperty | Identifies the Orientation dependency property.

See Also

Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Legend Members

Legend Members
Constructors Fields Properties
[image]

Represents a legend in the chart.

The following tables list the members exposed by the Legend type.

Public Constructors

Name | Description
Legend | Initializes a new instance of the Legend class.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
OrientationProperty | Identifies the Orientation dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the legend.
LabelFontFamily | Gets or sets the font family for the legend labels.
Orientation | Gets or sets the orientation of the legend.

See Also

Legend Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Class

LegendSymbolRenderer Class
[image]

Converts a Series object to a Geometry based on the Series.ScatterType property

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class LegendSymbolRenderer : FrameworkElement

Visual Basic [image] Copy Code

Public Class LegendSymbolRenderer
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer

See Also

LegendSymbolRenderer Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Properties

LegendSymbolRenderer Properties
[image]

Public Properties

Name | Description
Series | Gets or sets the collection of Series to mark in the legend.

See Also

LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Fields

LegendSymbolRenderer Fields
[image]

Public Fields

Name | Description
SeriesProperty | Identifies the Series dependency property.

See Also

LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Members

LegendSymbolRenderer Members
Constructors Fields Properties Methods
[image]

Converts a Series object to a Geometry based on the Series.ScatterType property

The following tables list the members exposed by the LegendSymbolRenderer type.

Public Constructors

Name | Description
LegendSymbolRenderer |

Public Fields

Name | Description
SeriesProperty | Identifies the Series dependency property.

Public Properties

Name | Description
Series | Gets or sets the collection of Series to mark in the legend.

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride
OnRender | Renders the legend symbol.

See Also

LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.LegendSymbolRenderer Methods

LegendSymbolRenderer Methods
[image]

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride
OnRender | Renders the legend symbol.

See Also

LegendSymbolRenderer Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Class

PlotArea Class
[image]

Represents the plot area of the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class PlotArea : FrameworkElement

Visual Basic [image] Copy Code

Public Class PlotArea
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.RealTimeCharting.Wpf.PlotArea

See Also

PlotArea Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Fields

PlotArea Fields
[image]

Public Fields

Name | Description
BitmapOffsetProperty | Identifies the BitmapOffset dependency property.
CrosshairsDataPointProperty | Identifies the CrosshairsDataPoint dependency property.
CrosshairsVisibilityProperty | Identifies the CrosshairsVisibility dependency property.
DataPointProperty | Identifies the DataPoint dependency property.
MousePositionProperty | Identifies the MousePosition dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SeriesCollectionProperty | Identifies the SeriesCollection dependency property.
TooltipBackgroundProperty | Identifies the TooltipBackground dependency property.
TooltipStrokeProperty | Identifies the TooltipStroke dependency property.
ToolTipVisibilityProperty | Identifies the ToolTipVisibility dependency property.
XAxisProperty | Identifies the XAxis dependency property.

See Also

PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Members

PlotArea Members
Constructors Fields Properties Methods
[image]

Represents the plot area of the chart.

The following tables list the members exposed by the PlotArea type.

Public Constructors

Name | Description
PlotArea | Initializes a new instance of the PlotArea class.

Public Fields

Name | Description
BitmapOffsetProperty | Identifies the BitmapOffset dependency property.
CrosshairsDataPointProperty | Identifies the CrosshairsDataPoint dependency property.
CrosshairsVisibilityProperty | Identifies the CrosshairsVisibility dependency property.
DataPointProperty | Identifies the DataPoint dependency property.
MousePositionProperty | Identifies the MousePosition dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SeriesCollectionProperty | Identifies the SeriesCollection dependency property.
TooltipBackgroundProperty | Identifies the TooltipBackground dependency property.
TooltipStrokeProperty | Identifies the TooltipStroke dependency property.
ToolTipVisibilityProperty | Identifies the ToolTipVisibility dependency property.
XAxisProperty | Identifies the XAxis dependency property.

Public Properties

Name | Description
BitmapOffset | Gets or sets the bitmap cache scroll offset.
Chart | Gets or sets the Chart object.
CrosshairsDataPoint | Gets or sets the data point that corresponds to the location of the crosshairs.
CrosshairsVisibility | Gets or sets the visibility of the crosshairs.
DataPoint | Gets or sets the data point that corresponds to the location of the mouse.
MousePosition | Gets or sets the position of the mouse over the plot area.
ScrollOffset | Gets or sets the scroll offset.
SeriesCollection | Gets or sets the collection of Series for the plot area.
TooltipBackground | Gets or sets the tooltip background brush.
TooltipStroke | Gets or sets the stroke for the tooltip.
ToolTipVisibility | Gets or sets whether the tool tip is visible.
XAxis | Gets or sets the settings for the X-axis.

Public Methods

Name | Description
Commit | Overloaded.

Protected Methods

Name | Description
OnRender | FrameworkElement.OnRender override.

See Also

PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Methods

PlotArea Methods
[image]

Public Methods

Name | Description
Commit | Overloaded.

Protected Methods

Name | Description
OnRender | FrameworkElement.OnRender override.

See Also

PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PlotArea Properties

PlotArea Properties
[image]

Public Properties

Name | Description
BitmapOffset | Gets or sets the bitmap cache scroll offset.
Chart | Gets or sets the Chart object.
CrosshairsDataPoint | Gets or sets the data point that corresponds to the location of the crosshairs.
CrosshairsVisibility | Gets or sets the visibility of the crosshairs.
DataPoint | Gets or sets the data point that corresponds to the location of the mouse.
MousePosition | Gets or sets the position of the mouse over the plot area.
ScrollOffset | Gets or sets the scroll offset.
SeriesCollection | Gets or sets the collection of Series for the plot area.
TooltipBackground | Gets or sets the tooltip background brush.
TooltipStroke | Gets or sets the stroke for the tooltip.
ToolTipVisibility | Gets or sets whether the tool tip is visible.
XAxis | Gets or sets the settings for the X-axis.

See Also

PlotArea Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter Class

PointToStringConverter Class
[image]

Converts an instance of the System.Windows.Point structure to a string.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class PointToStringConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PointToStringConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.PointToStringConverter

See Also

PointToStringConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter Members

PointToStringConverter Members
Constructors Methods
[image]

Converts an instance of the System.Windows.Point structure to a string.

The following tables list the members exposed by the PointToStringConverter type.

Public Constructors

Name | Description
PointToStringConverter | Initializes a new instance of the PointToStringConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

PointToStringConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToStringConverter Methods

PointToStringConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

PointToStringConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter Class

PointToThicknessConverter Class
[image]

Converts an instance of the System.Windows.Point value to an instance of the System.Windows.Thickness structure.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class PointToThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PointToThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter

See Also

PointToThicknessConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter Members

PointToThicknessConverter Members
Constructors Methods
[image]

Converts an instance of the System.Windows.Point value to an instance of the System.Windows.Thickness structure.

The following tables list the members exposed by the PointToThicknessConverter type.

Public Constructors

Name | Description
PointToThicknessConverter | Initializes a new instance of the PointToThicknessConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

PointToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.PointToThicknessConverter Methods

PointToThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

PointToThicknessConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Class

RealTimeChart Class
[image]

Represents the RealTimeChart control.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class RealTimeChart : Control

Visual Basic [image] Copy Code

Public Class RealTimeChart
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.RealTimeCharting.Wpf.RealTimeChart

See Also

RealTimeChart Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Properties

RealTimeChart Properties
[image]

Public Properties

Name | Description
BitmapOffset | Gets or sets the bitmap cache scroll offset.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.
FallbackTooltipBackground | Gets or sets the tooltip background brush.
FastScrollMode | Gets or sets whether the chart should automatically scroll when provided data exceeds current max. value shown on axis.
FrameBottomThickness | Gets or sets the thickness of the bottom plot area frame.
FrameLeftThickness | Gets or sets the thickness of the left plot area frame.
FrameRightThickness | Gets or sets the thickness of the right plot area frame.
FrameTopThickness | Gets or sets the thickness of the top plot area frame.
GridAxis | Gets or sets the YAxis used to calculate grid spacing.
LegendBackground | Gets or sets the legend background brush.
LegendBorderBrush | Gets or sets the legend border brush.
LegendHeight | Gets or sets the height of the legend.
LegendHorizontalAlignment | Gets or sets the horizontal alignment of the legend.
LegendOrientation | Gets or sets the orientation of the legend.
LegendVerticalAlignment | Gets or sets the vertical alignment of the legend.
LegendWidth | Gets or sets the width of the legend.
MajorGridSizeX | Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.
MajorGridSizeY | Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.
MajorGridStroke | Gets or sets the brush used for drawing major grid lines.
MajorGridStrokeThickness | Gets or sets the thickness of the brush for drawing major grid lines.
MinorGridSizeX | Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.
MinorGridSizeY | Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.
MinorGridStroke | Gets or sets the brush used for drawing minor grid lines.
MinorGridStrokeThickness | Gets or sets the thickness of the brush used for drawing minor grid lines.
ScrollOffset | Gets or sets the scroll offset.
SeriesCollection | Gets or sets the collection of Series for the chart.
ShowCrosshairs | Gets or sets whether the crosshairs are visible.
ShowFallbackTooltip | Gets or sets whether a fallback tooltip is shown.
ShowLegend | Gets or sets whether the chart has a legend.
TitleFontFamily | Gets or sets the font family of the chart title.
TitleFontSize | Gets or sets the font size of the chart title.
TitleHorizontalAlignment | iGets or sets the horizontal alignment of the title.
TitleText | Gets or sets the text of the chart title.
TitleVerticalAlignment | Gets or sets the vertical alignment of the title.
TooltipAxis | Gets or sets the YAxis used to calculate coordinates shown in the tooltip.
TooltipDistance | Gets or sets the distance of the tooltip to the element it refers to.
TooltipVisibility | Gets or sets whether tooltips are drawn.
XAxis | Gets or sets the settings for the X-axis.
Y2AxisCollection | Gets or sets the collection of Y2Axis settings for the chart.
YAxisCollection | Gets or sets the collection of YAxis-settings for the chart.

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Events

RealTimeChart Events
[image]

Public Events

Name | Description
YAxisClicked | Ocurrs when an Y-axis is clicked.

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Fields

RealTimeChart Fields
[image]

Public Fields

Name | Description
BitmapOffsetProperty | Identifies the BitmapOffset dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FastScrollModeProperty | Identifies the FastScrollMode dependency property.
FrameBottomThicknessProperty | Identifies the FrameBottomThickness dependency property.
FrameLeftThicknessProperty | Identifies the FrameLeftThickness dependency property.
FrameRightThicknessProperty | Identifies the FrameRightThickness dependency property.
FrameTopThicknessProperty | Identifies the FrameTopThickness dependency property.
GridAxisProperty | Identifies the GridAxis dependency property.
LegendBackgroundProperty | Identifies the LegendBackground dependency property.
LegendBorderBrushProperty | Identifies the LegendBorderBrush dependency property.
LegendHeightProperty | Identifies the LegendHeight dependency property.
LegendHorizontalAlignmentProperty | Identifies the LegendHorizontalAlignment dependency property.
LegendOrientationProperty | Identifies the LegendOrientation dependency property.
LegendVerticalAlignmentProperty | Identifies the LegendVerticalAlignment dependency property.
LegendWidthProperty | Identifies the LegendWidth dependency property.
MajorGridSizeXProperty | Identifies the MajorGridSizeX dependency property.
MajorGridSizeYProperty | Identifies the MajorGridSizeY dependency property.
MajorGridStrokeProperty | Identifies the MajorGridStroke dependency property.
MajorGridStrokeThicknessProperty | Identifies the MajorGridStrokeThickness dependency property.
MinorGridSizeXProperty | Identifies the MinorGridSizeX dependency property.
MinorGridSizeYProperty | Identifies the MinorGridSizeY dependency property.
MinorGridStrokeProperty | Identifies the MinorGridStroke dependency property.
MinorGridStrokeThicknessProperty | Identifies the MinorGridStrokeThickness dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SeriesCollectionProperty | Identifies the SeriesCollection dependency property.
ShowCrosshairsProperty | Identifies the ShowCrosshairs dependency property.
ShowLegendProperty | Identifies the ShowLegend dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleHorizontalAlignmentProperty | Identifies the TitleHorizontalAlignment dependency property.
TitleTextProperty | Identifies the TitleText dependency property.
TitleVerticalAlignmentProperty | Identifies the TitleVerticalAlignment dependency property.
TooltipAxisProperty | Identifies the FallbackTooltipAxis dependency property.
TooltipBackgroundProperty | Identifies the FallbackTooltipBackground dependency property.
TooltipVisibilityProperty | Identifies the TooltipVisibility dependency property.
XAxisProperty | Identifies the XAxis dependency property.
Y2AxisCollectionProperty | Identifies the Y2AxisCollection dependency property.
YAxisCollectionProperty | Identifies the YAxisCollection dependency property.

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Members

RealTimeChart Members
Constructors Fields Properties Methods Events
[image]

Represents the RealTimeChart control.

The following tables list the members exposed by the RealTimeChart type.

Public Constructors

Name | Description
RealTimeChart | Initializes a new instance of the RealTimeChart.

Public Fields

Name | Description
BitmapOffsetProperty | Identifies the BitmapOffset dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
FastScrollModeProperty | Identifies the FastScrollMode dependency property.
FrameBottomThicknessProperty | Identifies the FrameBottomThickness dependency property.
FrameLeftThicknessProperty | Identifies the FrameLeftThickness dependency property.
FrameRightThicknessProperty | Identifies the FrameRightThickness dependency property.
FrameTopThicknessProperty | Identifies the FrameTopThickness dependency property.
GridAxisProperty | Identifies the GridAxis dependency property.
LegendBackgroundProperty | Identifies the LegendBackground dependency property.
LegendBorderBrushProperty | Identifies the LegendBorderBrush dependency property.
LegendHeightProperty | Identifies the LegendHeight dependency property.
LegendHorizontalAlignmentProperty | Identifies the LegendHorizontalAlignment dependency property.
LegendOrientationProperty | Identifies the LegendOrientation dependency property.
LegendVerticalAlignmentProperty | Identifies the LegendVerticalAlignment dependency property.
LegendWidthProperty | Identifies the LegendWidth dependency property.
MajorGridSizeXProperty | Identifies the MajorGridSizeX dependency property.
MajorGridSizeYProperty | Identifies the MajorGridSizeY dependency property.
MajorGridStrokeProperty | Identifies the MajorGridStroke dependency property.
MajorGridStrokeThicknessProperty | Identifies the MajorGridStrokeThickness dependency property.
MinorGridSizeXProperty | Identifies the MinorGridSizeX dependency property.
MinorGridSizeYProperty | Identifies the MinorGridSizeY dependency property.
MinorGridStrokeProperty | Identifies the MinorGridStroke dependency property.
MinorGridStrokeThicknessProperty | Identifies the MinorGridStrokeThickness dependency property.
ScrollOffsetProperty | Identifies the ScrollOffset dependency property.
SeriesCollectionProperty | Identifies the SeriesCollection dependency property.
ShowCrosshairsProperty | Identifies the ShowCrosshairs dependency property.
ShowLegendProperty | Identifies the ShowLegend dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleHorizontalAlignmentProperty | Identifies the TitleHorizontalAlignment dependency property.
TitleTextProperty | Identifies the TitleText dependency property.
TitleVerticalAlignmentProperty | Identifies the TitleVerticalAlignment dependency property.
TooltipAxisProperty | Identifies the FallbackTooltipAxis dependency property.
TooltipBackgroundProperty | Identifies the FallbackTooltipBackground dependency property.
TooltipVisibilityProperty | Identifies the TooltipVisibility dependency property.
XAxisProperty | Identifies the XAxis dependency property.
Y2AxisCollectionProperty | Identifies the Y2AxisCollection dependency property.
YAxisCollectionProperty | Identifies the YAxisCollection dependency property.

Public Properties

Name | Description
BitmapOffset | Gets or sets the bitmap cache scroll offset.
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. This is a dependency property.
FallbackTooltipBackground | Gets or sets the tooltip background brush.
FastScrollMode | Gets or sets whether the chart should automatically scroll when provided data exceeds current max. value shown on axis.
FrameBottomThickness | Gets or sets the thickness of the bottom plot area frame.
FrameLeftThickness | Gets or sets the thickness of the left plot area frame.
FrameRightThickness | Gets or sets the thickness of the right plot area frame.
FrameTopThickness | Gets or sets the thickness of the top plot area frame.
GridAxis | Gets or sets the YAxis used to calculate grid spacing.
LegendBackground | Gets or sets the legend background brush.
LegendBorderBrush | Gets or sets the legend border brush.
LegendHeight | Gets or sets the height of the legend.
LegendHorizontalAlignment | Gets or sets the horizontal alignment of the legend.
LegendOrientation | Gets or sets the orientation of the legend.
LegendVerticalAlignment | Gets or sets the vertical alignment of the legend.
LegendWidth | Gets or sets the width of the legend.
MajorGridSizeX | Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.
MajorGridSizeY | Gets or sets the numeric interval at which major grid lines parallel to the Y-axis are drawn.
MajorGridStroke | Gets or sets the brush used for drawing major grid lines.
MajorGridStrokeThickness | Gets or sets the thickness of the brush for drawing major grid lines.
MinorGridSizeX | Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.
MinorGridSizeY | Gets or sets the numeric interval at which minor grid lines parallel to the Y-axis are drawn.
MinorGridStroke | Gets or sets the brush used for drawing minor grid lines.
MinorGridStrokeThickness | Gets or sets the thickness of the brush used for drawing minor grid lines.
ScrollOffset | Gets or sets the scroll offset.
SeriesCollection | Gets or sets the collection of Series for the chart.
ShowCrosshairs | Gets or sets whether the crosshairs are visible.
ShowFallbackTooltip | Gets or sets whether a fallback tooltip is shown.
ShowLegend | Gets or sets whether the chart has a legend.
TitleFontFamily | Gets or sets the font family of the chart title.
TitleFontSize | Gets or sets the font size of the chart title.
TitleHorizontalAlignment | iGets or sets the horizontal alignment of the title.
TitleText | Gets or sets the text of the chart title.
TitleVerticalAlignment | Gets or sets the vertical alignment of the title.
TooltipAxis | Gets or sets the YAxis used to calculate coordinates shown in the tooltip.
TooltipDistance | Gets or sets the distance of the tooltip to the element it refers to.
TooltipVisibility | Gets or sets whether tooltips are drawn.
XAxis | Gets or sets the settings for the X-axis.
Y2AxisCollection | Gets or sets the collection of Y2Axis settings for the chart.
YAxisCollection | Gets or sets the collection of YAxis-settings for the chart.

Public Methods

Name | Description
ClearCache | Clears the cache of the chart.
Commit | Overloaded.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.

Protected Methods

Name | Description
OnPreviewMouseDown | Raises the OnPreviewMouseDown event.

Public Events

Name | Description
YAxisClicked | Ocurrs when an Y-axis is clicked.

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.RealTimeChart Methods

RealTimeChart Methods
[image]

Public Methods

Name | Description
ClearCache | Clears the cache of the chart.
Commit | Overloaded.
OnApplyTemplate | FrameworkElement.ApplyTemplate override.

Protected Methods

Name | Description
OnPreviewMouseDown | Raises the OnPreviewMouseDown event.

See Also

RealTimeChart Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.ScatterType Enumeration

ScatterType Enumeration
[image]

Provides various scatter types.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public enum ScatterType

Visual Basic [image] Copy Code

Public Enum ScatterType

Members

Member name | Description
Circle | Scatters are drawn as circles.
Diamond | Scatters are drawn as diamonds.
None | No scatters are drawn.
Square | Scatters are drawn as squares.
Triangle | Scatters are drawn as triangles.

See Also

MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Class

Series Class
[image]

Represents a series in the RealTimeChart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class Series : DependencyObject

Visual Basic [image] Copy Code

Public Class Series
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
MindFusion.RealTimeCharting.Wpf.Series

See Also

Series Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Properties

Series Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the data for the Series.
Fill | Gets or sets the fill for the series.
LegendBackground | Gets or sets the legend background brush.
ScatterStroke | Gets or sets the stroke for the series' scatters.
ScatterType | Gets or sets a value specifying the scatter shapes to display for the values in this series.
Stroke | Gets or sets the stroke for the series.
Title | Gets or sets the title for the series.
TitleFontFamily | Gets or sets the font family for the series title.
TitleFontSize | Gets or sets the font for the series title.
TitleFontWeight | Gets or sets the font weight for the series title.
TooltipBackground | Gets or sets the tooltip background brush.
TooltipStroke | Gets or sets the tooltip text brush.
Visible | Gets or sets whether the series should be drawn.
YAxis | Gets the Y-axis.

See Also

Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Events

Series Events
[image]

Public Events

Name | Description
DataChanged | Occurs when series data was changed.

See Also

Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Fields

Series Fields
[image]

Public Fields

Name | Description
FillProperty | Identifies the Stroke dependency property.
LegendBackgroundProperty | Identifies the LegendBackground dependency property.
ScatterStrokeProperty | Identifies the ScatterStroke dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleProperty | Identifies the Title dependency property.
TooltipBackgroundProperty | Identifies the TooltipBackground dependency property.
TooltipStrokeProperty | Identifies the TooltipStroke dependency property.
VisibleProperty | Identifies the Visible dependency property.

See Also

Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.Series Members

Series Members
Constructors Fields Properties Events
[image]

Represents a series in the RealTimeChart.

The following tables list the members exposed by the Series type.

Public Constructors

Name | Description
Series | Initializes a new instance of the Series class bound to the specified Y-axis.

Public Fields

Name | Description
FillProperty | Identifies the Stroke dependency property.
LegendBackgroundProperty | Identifies the LegendBackground dependency property.
ScatterStrokeProperty | Identifies the ScatterStroke dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.
StrokeProperty | Identifies the Stroke dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleProperty | Identifies the Title dependency property.
TooltipBackgroundProperty | Identifies the TooltipBackground dependency property.
TooltipStrokeProperty | Identifies the TooltipStroke dependency property.
VisibleProperty | Identifies the Visible dependency property.

Public Properties

Name | Description
Data | Gets or sets the data for the Series.
Fill | Gets or sets the fill for the series.
LegendBackground | Gets or sets the legend background brush.
ScatterStroke | Gets or sets the stroke for the series' scatters.
ScatterType | Gets or sets a value specifying the scatter shapes to display for the values in this series.
Stroke | Gets or sets the stroke for the series.
Title | Gets or sets the title for the series.
TitleFontFamily | Gets or sets the font family for the series title.
TitleFontSize | Gets or sets the font for the series title.
TitleFontWeight | Gets or sets the font weight for the series title.
TooltipBackground | Gets or sets the tooltip background brush.
TooltipStroke | Gets or sets the tooltip text brush.
Visible | Gets or sets whether the series should be drawn.
YAxis | Gets the Y-axis.

Public Events

Name | Description
DataChanged | Occurs when series data was changed.

See Also

Series Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesCollection Class

SeriesCollection Class
[image]

Contains all series in the chart.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class SeriesCollection : ObservableCollection<Series>

Visual Basic [image] Copy Code

Public Class SeriesCollection
Inherits ObservableCollection(Of Series)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Series)
System.Collections.ObjectModel.ObservableCollection(Series)
MindFusion.RealTimeCharting.Wpf.SeriesCollection

See Also

SeriesCollection Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesCollection Members

SeriesCollection Members
Constructors
[image]

Contains all series in the chart.

The following tables list the members exposed by the SeriesCollection type.

Public Constructors

Name | Description
SeriesCollection | Initializes a new instance of the SeriesCollection class.

See Also

SeriesCollection Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter Class

SeriesToGeometryConverter Class
[image]

Converts a Series object to a Geometry based on the Series.ScatterType property.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class SeriesToGeometryConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class SeriesToGeometryConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter

See Also

SeriesToGeometryConverter Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter Members

SeriesToGeometryConverter Members
Constructors Methods
[image]

Converts a Series object to a Geometry based on the Series.ScatterType property.

The following tables list the members exposed by the SeriesToGeometryConverter type.

Public Constructors

Name | Description
SeriesToGeometryConverter | Initializes a new instance of the SeriesToGeometryConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

SeriesToGeometryConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.SeriesToGeometryConverter Methods

SeriesToGeometryConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert override
ConvertBack | IValueConverter.ConvertBack override.

See Also

SeriesToGeometryConverter Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell Class

UniformStackPanell Class
[image]

Represents a panel that splits horizontal space equally among its children.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class UniformStackPanell : Panel

Visual Basic [image] Copy Code

Public Class UniformStackPanell
Inherits Panel

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
MindFusion.RealTimeCharting.Wpf.UniformStackPanell

See Also

UniformStackPanell Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell Members

UniformStackPanell Members
Constructors Methods
[image]

Represents a panel that splits horizontal space equally among its children.

The following tables list the members exposed by the UniformStackPanell type.

Public Constructors

Name | Description
UniformStackPanell | Initializes a new instance of the UniformStackPanell class.

Protected Methods

Name | Description
ArrangeOverride | Panel.ArrangeOverride implementation.
MeasureOverride | Panel.MeasureOverride

See Also

UniformStackPanell Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.UniformStackPanell Methods

UniformStackPanell Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Panel.ArrangeOverride implementation.
MeasureOverride | Panel.MeasureOverride

See Also

UniformStackPanell Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.YAxisCollection Class

YAxisCollection Class
[image]

A collection of vertical axes.

Namespace: MindFusion.RealTimeCharting.Wpf
Assembly: MindFusion.RealTimeCharting.Wpf

Syntax

C# [image] Copy Code

public class YAxisCollection : ObservableCollection<Axis>

Visual Basic [image] Copy Code

Public Class YAxisCollection
Inherits ObservableCollection(Of Axis)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Axis)
System.Collections.ObjectModel.ObservableCollection(Axis)
MindFusion.RealTimeCharting.Wpf.YAxisCollection

See Also

YAxisCollection Members
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.RealTimeCharting.Wpf.YAxisCollection Members

YAxisCollection Members
Constructors
[image]

A collection of vertical axes.

The following tables list the members exposed by the YAxisCollection type.

Public Constructors

Name | Description
YAxisCollection | Initializes a new instance of the YAxisCollection class.

See Also

YAxisCollection Class
MindFusion.RealTimeCharting.Wpf Namespace


MindFusion.Scripting.ByteCode Class

ByteCode Class
Remarks See Also
[image]

Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public sealed class ByteCode

Visual Basic [image] Copy Code

Public NotInheritable Class ByteCode

Remarks

This class cannot be instantiated directly. To obtain an instance, call one of the Compile methods of the Compiler class.

Inheritance Hierarchy

System.Object
MindFusion.Scripting.ByteCode

See Also

ByteCode Members
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Properties

ByteCode Properties
[image]

Public Properties

Name | Description
Identifiers | Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Members

ByteCode Members
Properties Methods
[image]

Encapsulates the compiled result of a parsed tree and performs evaluations against that compiled result in various contexts.

The following tables list the members exposed by the ByteCode type.

Public Properties

Name | Description
Identifiers | Gets the list with all identifiers within the code. There is no guarantee that this list will contain unique entries, thus, if an identifier is encountered several times in the initial sequence, it will appear several times in the returned list.

Public Methods

Name | Description
Empty | Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.
Evaluate | Evaluates the byte code in the specified context.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ByteCode Methods

ByteCode Methods
[image]

Public Methods

Name | Description
Empty | Creates and returns an empty byte code. Evaluating empty byte code will produce null (Nothing in Visual Basic) as a result.
Evaluate | Evaluates the byte code in the specified context.

See Also

ByteCode Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Class

CompileOptions Class
[image]

Contains options for the Compiler.Compile method.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class CompileOptions

Visual Basic [image] Copy Code

Public Class CompileOptions

Inheritance Hierarchy

System.Object
MindFusion.Scripting.CompileOptions

See Also

CompileOptions Members
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Properties

CompileOptions Properties
[image]

Public Properties

Name | Description
InterpretCircumflexAsPower | Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.
InterpretExclamationAsReference | Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.
Normalize | Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.CompileOptions Members

CompileOptions Members
Constructors Properties
[image]

Contains options for the Compiler.Compile method.

The following tables list the members exposed by the CompileOptions type.

Public Constructors

Name | Description
CompileOptions | Initializes a new instance of the CompileOptions class.

Public Properties

Name | Description
InterpretCircumflexAsPower | Gets or sets a value indicating whether circumflex symbols (^) are interpreted as raising to power, rather than exclusive-OR. Raising to power also has different priority than XOR.
InterpretExclamationAsReference | Gets or sets a value indicating whether exclamation marks (!) are interpreted as references, rather than NOT.
Normalize | Gets or sets a value indicating whether to encase source in square brackets if it is not encased already.

See Also

CompileOptions Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Class

Compiler Class
[image]

Provides methods for compiling expressions to byte code.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public sealed class Compiler

Visual Basic [image] Copy Code

Public NotInheritable Class Compiler

Inheritance Hierarchy

System.Object
MindFusion.Scripting.Compiler

See Also

Compiler Members
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Members

Compiler Members
Methods
[image]

Provides methods for compiling expressions to byte code.

The following tables list the members exposed by the Compiler type.

Public Methods

Name | Description
Compile | Overloaded. Compiles a string expression into ByteCode.

See Also

Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.Compiler Methods

Compiler Methods
[image]

Public Methods

Name | Description
Compile | Overloaded. Compiles a string expression into ByteCode.

See Also

Compiler Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Class

EvaluateFunctionEventArgs Class
[image]

Contains the arguments passed to DispatchFunctionCall event handlers.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class EvaluateFunctionEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EvaluateFunctionEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scripting.EvaluateFunctionEventArgs

See Also

EvaluateFunctionEventArgs Members
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Properties

EvaluateFunctionEventArgs Properties
[image]

Public Properties

Name | Description
Arguments | Gets the list of the function's arguments.
Name | Gets the name of the function to evaluate.
Param | Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.
Result | Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluateFunctionEventArgs Members

EvaluateFunctionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to DispatchFunctionCall event handlers.

The following tables list the members exposed by the EvaluateFunctionEventArgs type.

Public Constructors

Name | Description
EvaluateFunctionEventArgs | Initializes a new instance of the EvaluateFunctionEventArgs class.

Public Properties

Name | Description
Arguments | Gets the list of the function's arguments.
Name | Gets the name of the function to evaluate.
Param | Gets the user-defined object set to the EvaluationContext.DispatchFunctionParam.
Result | Gets or sets the result of the function evaluation. An attempt to get the value of this property before it was set results in an exception.

See Also

EvaluateFunctionEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Class

EvaluationContext Class
[image]

Provides a context for evaluating a byte code.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class EvaluationContext

Visual Basic [image] Copy Code

Public Class EvaluationContext

Inheritance Hierarchy

System.Object
MindFusion.Scripting.EvaluationContext

See Also

EvaluationContext Members
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Properties

EvaluationContext Properties
[image]

Public Properties

Name | Description
CultureInfo | Gets or sets the culture associated with the context.
DispatchFunctionParam | Gets or sets a user-defined object passed to the DispatchFunctionCall event.
LocalVars | Gets a collection with defined variables and their values.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Events

EvaluationContext Events
[image]

Public Events

Name | Description
DispatchFunctionCall | Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.
ParseObject | Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Members

EvaluationContext Members
Constructors Properties Methods Events
[image]

Provides a context for evaluating a byte code.

The following tables list the members exposed by the EvaluationContext type.

Public Constructors

Name | Description
EvaluationContext | Overloaded. Initializes a new instance of the EvaluationContext class.

Public Properties

Name | Description
CultureInfo | Gets or sets the culture associated with the context.
DispatchFunctionParam | Gets or sets a user-defined object passed to the DispatchFunctionCall event.
LocalVars | Gets a collection with defined variables and their values.

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
EvaluateMember | Evaluates the member with the specified name against the specified target.
EvaluateQuantity | Evaluates the specified quanitity in the specified unit.
InvokeFunction | Invokes the function with the specified name.
ResolveObject | Returns the object with the specified name.
ResolveReference | Returns the object representing the specified reference.

Protected Methods

Name | Description
OnDispatchFunctionCall | Raises the DispatchFunctionCall event.
OnParseObject | Raises the ParseObject event.

Public Events

Name | Description
DispatchFunctionCall | Raised by the EvaluationContext when a function name cannot be recognized as one of the built-in functions to allow clients to evaluate the function call.
ParseObject | Raised by the EvaluationContext when an object needs to be parsed from its string representation and the parser is either not able to parse it or not able to create an object of the respective type.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.EvaluationContext Methods

EvaluationContext Methods
[image]

Public Methods

Name | Description
EvaluateIdentifier | Evaluates the identifier with the specified name.
EvaluateMember | Evaluates the member with the specified name against the specified target.
EvaluateQuantity | Evaluates the specified quanitity in the specified unit.
InvokeFunction | Invokes the function with the specified name.
ResolveObject | Returns the object with the specified name.
ResolveReference | Returns the object representing the specified reference.

Protected Methods

Name | Description
OnDispatchFunctionCall | Raises the DispatchFunctionCall event.
OnParseObject | Raises the ParseObject event.

See Also

EvaluationContext Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Class

ParseObjectEventArgs Class
[image]

Contains the arguments passed to ParseObject event handlers.

Namespace: MindFusion.Scripting
Assembly: MindFusion.Scripting

Syntax

C# [image] Copy Code

public class ParseObjectEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ParseObjectEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scripting.ParseObjectEventArgs

See Also

ParseObjectEventArgs Members
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Properties

ParseObjectEventArgs Properties
[image]

Public Properties

Name | Description
Result | Gets or sets the parsed object.
ValueAsString | Gets the string representation of the object to be parsed.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


MindFusion.Scripting.ParseObjectEventArgs Members

ParseObjectEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to ParseObject event handlers.

The following tables list the members exposed by the ParseObjectEventArgs type.

Public Constructors

Name | Description
ParseObjectEventArgs | Initializes a new instance of the ParseObjectEventArgs class.

Public Properties

Name | Description
Result | Gets or sets the parsed object.
ValueAsString | Gets the string representation of the object to be parsed.

See Also

ParseObjectEventArgs Class
MindFusion.Scripting Namespace


TEXT

TEXT

Converts the specified numeric value to text, according to the specified format.

Syntax [image] Copy Code

TEXT( Number n, Text format ) → Text

Parameters

n
Required. The number to convert.
format
Required. The format to use in the conversion.

Remarks

For additional information about the format parameter and formatting in general, check Formatting.

Example

Formula [image] Copy Code

=TEXT(A1,"$0.##")

See Also

Function Reference
N Function
T Function


TIME

TIME

Returns a new time value with the specified hours, minutes, and seconds.

Syntax [image] Copy Code

TIME( Number hours, Number minutes, Number seconds ) → Time

Parameters

hours
Required. The number of hours in the returned time.
minutes
Required. The number of minutes in the returned time.
seconds
Required. The number of seconds in the returned time.

Remarks

Hours, minutes, and seconds may be any number, they are not limited to the ranges 0…24, 0…59, or 0…60 respectively.

Example

Formula [image] Copy Code

=TIME(3,30,0)
=TIME(55,0,0)

See Also

Function Reference
HOUR Function
MINUTE Function
NOW Function
SECOND Function
DATE Function


TRIM

TRIM

Removes all leading and trailing whitespaces from the specified text.

Syntax [image] Copy Code

TRIM( Text text ) → Text

Parameters

text
Required. The text to trim.

Remarks

The following characters are considered whitespaces by this function: HORIZONTAL TABULATION (U+0009), LINE FEED (U+000A), CARRIAGE RETURN (U+000D) or SPACE (U+0020).

Example

Formula [image] Copy Code

=TRIM(" Total income: ")

See Also

Function Reference
LEFT Function
RIGHT Function
MID Function
REPLACE Function
SUBSTITUTE Function


TRUE

TRUE

Returns the logical constant TRUE.

Syntax [image] Copy Code

TRUE( ) → Logical

Remarks

This function always evaluates to TRUE. An alternative way to use the TRUE constant is through the TRUE literal.

Example

The first formula below illustrates the TRUE function, the second - the TRUE literal.

Formula [image] Copy Code

=TRUE()
=TRUE

See Also

Function Reference
FALSE Function
IF Function


TRUNC

TRUNC

Truncates the specified number to the specified number of digits.

Syntax [image] Copy Code

TRUNC( Number n, [Integer digits = 0] ) → Number

Parameters

n
Required. The number to truncate.
digits
Optional. A number specifying the precision of the truncation. If omitted, digits is assumed to be 0.

Remarks

Truncates the n to the number of digits specified by digits. If digits is zero (or omitted), truncates to a decimal integer. If digits is positive, truncates to the specified number of decimal places. If digits is negative, truncates to the left of the decimal point. If digits is not integer, it is automatically truncated.

TRUNC and INT are similar in that both return integers. TRUNC removes the fractional part of the number. INT rounds the number down to the nearest integer based on the value of the fractional part of the number. INT and TRUNC are different only when using negative numbers: TRUNC(-4.3) returns -4, but =INT(-4.3) returns -5 because -5 is the lower number.

See Also

Function Reference
CEILING Function
FLOOR Function
INT Function
MOD Function
ROUND Function


TYPE

TYPE

Returns a number indicating the type of the specified value.

Syntax [image] Copy Code

TYPE( Any value ) → Number

Parameters

value
Required. The value to check.

Remarks

The function returns a value indicating the type of the specified argument, according to the following table.

Type | Value
Number | 1
Text | 2
Logical | 4
Error | 16
Array | 64

If a reference is provided, the reference is first dereferenced, and any formulas are evaluated. Note that this function does not propagate error values.

See Also

Function Reference
ERROR.TYPE Function


UPPER

UPPER

Converts the specified text to uppercase.

Syntax [image] Copy Code

LOWER( Text text ) → Text

Parameters

text
Required. The text to convert.

Remarks

UPPER does not change the characters in text that are not letters.

Example

Formula [image] Copy Code

=UPPER(A2)
=UPPER("Mr. Brown")

See Also

Function Reference
LOWER Function
PROPER Function


VALUE

VALUE

Converts the specified text that represents a number to a number.

Syntax [image] Copy Code

VALUE( Text text ) → Number

Parameters

text
Required. The text to convert.

Remarks

The text argument can be in any number, date, or time formats recognized by MindFusion.Spreadsheet for WPF. If text is not in one of these formats, VALUE returns the #VALUE! error value. If text is an empty text, the return value is 0.

Example

Formula [image] Copy Code

=VALUE("$1,000")
=VALUE("1/1/5")

See Also

Function Reference
N Function
T Function
TEXT Function


VAR

VAR

Calculates the sample variance of the specified arguments.

Syntax [image] Copy Code

VAR( Number n1, Number n2, ... ) → Number

Parameters

n1
n2
…
Two or more numbers representing the sample.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments do not contain at least two numbers, the function returns #N/A.

Example

Formula [image] Copy Code

=VAR({1245;1201;1268;1222;1211})

See Also

Function Reference
VARP Function
STDEV Function
AVERAGE Function


VARP

VARP

Computes the variance of the specified arguments.

Syntax [image] Copy Code

VARP( Number n1, Number n2, ... ) → Number

Parameters

n1
n2
…
Two or more numbers representing the set.

Remarks

The arguments can be either numbers or cells, ranges, or arrays that contain numbers. Logical values, text, and empty cells are ignored. If the specified arguments contain only a single number, the function returns #DIV/0!.

Example

Formula [image] Copy Code

=VARP({1245;1201;1268;1222;1211})

See Also

Function Reference
VAR Function
STDEVP Function
AVERAGE Function


VLOOKUP

VLOOKUP

Searches for a value in the first column of the specified table or array of values, and returns a value in the same row from another specified column in the table or array.

Syntax [image] Copy Code

VLOOKUP( Any lookup, ReferenceOrArray dataSource, Integer column, [Logical rangeLookup = TRUE] ) → Any

Parameters

lookup
Required. The value to search for in the first column of the table. The lookup value can be a value or a reference.
dataSource
Required. The table to be looked up. The source can be a reference to a range of cells or an array.
column
Required. The column number in dataSource from which the matching value will be returned.
rangeLookup
Optional. A logical value indicating whether VLOOKUP should find an exact or an approximate match.

Remarks

If VLOOKUP cannot find lookup, and rangeLookup is TRUE (or omitted), it uses the largest value that is less than lookup. If rangeLookup is FALSE, VLOOKUP will find an exact match. If one is not found, the error value #N/A is returned.

See Also

Function Reference
INDEX Function
MATCH Function
OFFSET Function
HLOOKUP Function


WEEKDAY

WEEKDAY

Returns a value indicating the day of the week of the specified date.

Syntax [image] Copy Code

WEEKDAY( Date date, [Integer type = 1] ) → Integer

Parameters

date
Required. The date to inspect.
type
Optional. A value indicating how to represent the day of the week. If omitted, type is assumed to be 1.

Remarks

Returns the day of the week of the specified date, as a number from 0 through 7. The exact meaning depends on the value of type, as illustrated below:

  • If type is 1 (or omitted), Sunday is the first day of the week, with value 1; Saturday has value 7.
  • If type is 2, Monday is the first day of the week, with value 1; Sunday has value 7.
  • If type is 3, Monday is the first day of the week, with value 0; Sunday has value 6.

If type is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=WEEKDAY(TODAY())

See Also

Function Reference
DAY Function
MONTH Function
YEAR Function
NOW Function
TODAY Function


WEEKNUM

WEEKNUM

Returns the number of the week of the specified date, relative to the year.

Syntax [image] Copy Code

WEEKNUM( Date date, [Integer mode = 1] ) → Integer

Parameters

date
Required. The date to inspect.
mode
Optional. A value indicating how to represent the result. If omitted, mode is assumed to be 1.

Remarks

Returns the number of the week within the year, for the specified date. If mode is not integer, it is automatically truncated.

Example

Formula [image] Copy Code

=WEEKNUM(TODAY())

See Also

Function Reference
DAY Function
MONTH Function
YEAR Function
WEEKDAY Function


WORKDAY

WORKDAY

Returns the date which is the specified number of work days before or after another specified date.

Syntax [image] Copy Code

WORKDAY( Date date, Integer offset, [ReferenceOrArray holidays], [ReferenceOrArray weekends] ) → Date

Parameters

date
Required. The date to offset.
offset
Required. The number of work days to offset.
holidays
Optional. A list of dates, that specifying the holiday dates that should not be considered work days.
weekends
Optional. A list of logical values that specify which days of the week are working days.

Remarks

This function returns the date, which is the specified amount of work days before or after date. If offset is negative, WORKDAY returns a past date; if offset is positive, WORKDAY returns a future date. If holidays is specified, it can be an array or a cell reference, containing dates or serial numbers of dates, that should be regarded as nonworking days. If weekends is specified, it can be an array or a cell reference, containing logical values. The length of weekends must be exactly 7; otherwise, the function will return #VALUE!. Each value in weekends indicates whether the corresponding day of the week (1 to 7 for Sunday through Saturday) should be regarded as a weekend. TRUE indicates a weekend, FALSE indicates a working day. If weekends is omitted, Saturday and Sunday are counted as weekends.

Example

Formula [image] Copy Code

=WORKDAY(TODAY(),10)

See Also

Function Reference
EDATE Function
EOMONTH Function
NOW Function


YEAR

YEAR

Returns the year of the specified date.

Syntax [image] Copy Code

YEAR( Date date ) → Integer

Parameters

date
Required. The date to inspect.

Example

Formula [image] Copy Code

=YEAR(TODAY())

See Also

Function Reference
DAY Function
HOUR Function
MINUTE Function
MONTH Function
NOW Function
SECOND Function
TODAY Function